TeeGrid

Summary

Represents namespace TeeGrid.

Namespaces
Name | Description
Tee.Control | Represents namespace Tee.Control.
Tee.Format | Represents namespace Tee.Format.
Tee.Grid | Represents namespace Tee.Grid.
Tee.Grid.Bands | Represents namespace Tee.Grid.Bands.
Tee.Grid.Bands.Columns | Represents namespace Tee.Grid.Bands.Columns.
Tee.Grid.Columns | Represents namespace Tee.Grid.Columns.
Tee.Grid.CSV | Represents namespace Tee.Grid.CSV.
Tee.Grid.Header | Represents namespace Tee.Grid.Header.
Tee.Grid.JSON | Represents namespace Tee.Grid.JSON.
Tee.Grid.RowGroup | Represents namespace Tee.Grid.RowGroup.
Tee.Grid.Rows | Represents namespace Tee.Grid.Rows.
Tee.Grid.Selection | Represents namespace Tee.Grid.Selection.
Tee.Grid.Themes | Represents namespace Tee.Grid.Themes.
Tee.Grid.Ticker | Represents namespace Tee.Grid.Ticker.
Tee.Grid.Totals | Represents namespace Tee.Grid.Totals.
Tee.GridData | Represents namespace Tee.GridData.
Tee.GridData.DB | Represents namespace Tee.GridData.DB.
Tee.GridData.Rtti | Represents namespace Tee.GridData.Rtti.
Tee.GridData.Strings | Represents namespace Tee.GridData.Strings.
Tee.Painter | Represents namespace Tee.Painter.
Tee.Renders | Represents namespace Tee.Renders.
Top


Tee.Control Namespace

Summary

Represents namespace Tee.Control.

Classes
Name | Description
TCustomTeeControl | Represents type TCustomTeeControl.
TScrollBar | Represents type TScrollBar.
TScrollBars | Represents type TScrollBars.
Top
Enumerations
Name | Description
TScrollBarVisible | Represents type TScrollBarVisible.
Top


Tee.Control Classes

Classes
Name | Description
TCustomTeeControl | Represents type TCustomTeeControl.
TScrollBar | Represents type TScrollBar.
TScrollBars | Represents type TScrollBars.
Top


TCustomTeeControl Class

Summary

Represents type TCustomTeeControl.

Namespace: Tee.Control
Inheritance Hierarchy
TComponent
Tee.Control.TCustomTeeControl
Tee.Grid.TCustomTeeGrid
Syntax
Delphi
type
 TCustomTeeControl=class(TComponent)
 end;

The TCustomTeeControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TCustomTeeControl class.
Destroy | Represents the destructor of the TCustomTeeControl class.
Top
Properties
Show:
Name | Description
Back | Represents property Back.
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
ClientHeight | Represents method ClientHeight.
ClientWidth | Represents method ClientWidth.
DoChanged(TObject) | Represents method DoChanged(TObject).
EndUpdate | Represents method EndUpdate.
Height | Represents method Height.
Paint | Represents method Paint.
Painter | Represents method Painter.
ResetScrollBars | Represents method ResetScrollBars.
Width | Represents method Width.
Top
Fields
Show:
Name | Description
IUpdating | Represents field IUpdating.
Top
See Also

Reference

  • Tee.Control


TCustomTeeControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TCustomTeeControl class.
Destroy | Represents the destructor of the TCustomTeeControl class.
Top


TCustomTeeControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TCustomTeeControl class.

Namespace: Tee.Control
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.Destroy Destructor

Summary

Represents the destructor of the TCustomTeeControl class.

Namespace: Tee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl Properties

Properties
Name | Description
Back | Represents property Back.
OnChange | Represents property OnChange.
Top


TCustomTeeControl.Back Property

Summary

Represents property Back.

Namespace: Tee.Control
Syntax
Delphi
published
 property Back:TFormat read FBack write SetBack;

Property Value

Type: TFormat

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.OnChange Property

Summary

Represents property OnChange.

Namespace: Tee.Control
Syntax
Delphi
protected
 property OnChange:TNotifyEvent read IChanged write IChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
ClientHeight | Represents method ClientHeight.
ClientWidth | Represents method ClientWidth.
DoChanged(TObject) | Represents method DoChanged(TObject).
EndUpdate | Represents method EndUpdate.
Height | Represents method Height.
Paint | Represents method Paint.
Painter | Represents method Painter.
ResetScrollBars | Represents method ResetScrollBars.
Width | Represents method Width.
Top


TCustomTeeControl.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Control
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.BeginUpdate Method

Summary

Represents method BeginUpdate.

Namespace: Tee.Control
Syntax
Delphi
protected
 procedure BeginUpdate; inline;
See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.ClientHeight Method

Summary

Represents method ClientHeight.

Namespace: Tee.Control
Syntax
Delphi
public
 function ClientHeight:Single; virtual;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.ClientWidth Method

Summary

Represents method ClientWidth.

Namespace: Tee.Control
Syntax
Delphi
public
 function ClientWidth:Single; virtual;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.DoChanged(TObject) Method

Summary

Represents method DoChanged(TObject).

Namespace: Tee.Control
Syntax
Delphi
protected
 procedure DoChanged(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.EndUpdate Method

Summary

Represents method EndUpdate.

Namespace: Tee.Control
Syntax
Delphi
protected
 procedure EndUpdate;
See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.Height Method

Summary

Represents method Height.

Namespace: Tee.Control
Syntax
Delphi
public
 function Height:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.Paint Method

Summary

Represents method Paint.

Namespace: Tee.Control
Syntax
Delphi
public
 procedure Paint; virtual;
See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.Painter Method

Summary

Represents method Painter.

Namespace: Tee.Control
Syntax
Delphi
public
 function Painter:TPainter; virtual; abstract;

Return Value

Type: TPainter

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.ResetScrollBars Method

Summary

Represents method ResetScrollBars.

Namespace: Tee.Control
Syntax
Delphi
protected
 procedure ResetScrollBars; virtual;
See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl.Width Method

Summary

Represents method Width.

Namespace: Tee.Control
Syntax
Delphi
public
 function Width:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TCustomTeeControl Fields

Fields
Name | Description
IUpdating | Represents field IUpdating.
Top


TCustomTeeControl.IUpdating Field

Summary

Represents field IUpdating.

Namespace: Tee.Control
Syntax
Delphi
protected
 IUpdating : Integer;

Field Value

Type: Integer

See Also

Reference

  • TCustomTeeControl
  • Tee.Control


TScrollBar Class

Summary

Represents type TScrollBar.

Namespace: Tee.Control
Inheritance Hierarchy
TPersistent
Tee.Control.TScrollBar
Syntax
Delphi
type
 TScrollBar=class(TPersistent)
 end;

The TScrollBar type exposes the following members.

Properties
Show:
Name | Description
IsVisible | Represents property IsVisible.
ThumbSize | Represents property ThumbSize.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • Tee.Control


TScrollBar Properties

Properties
Name | Description
IsVisible | Represents property IsVisible.
ThumbSize | Represents property ThumbSize.
Visible | Represents property Visible.
Top


TScrollBar.IsVisible Property

Summary

Represents property IsVisible.

Namespace: Tee.Control
Syntax
Delphi
public
 property IsVisible:Boolean read FIsVisible write FIsVisible;

Property Value

Type: Boolean

See Also

Reference

  • TScrollBar
  • Tee.Control


TScrollBar.ThumbSize Property

Summary

Represents property ThumbSize.

Namespace: Tee.Control
Syntax
Delphi
public
 property ThumbSize:Integer read FThumbSize write FThumbSize;

Property Value

Type: Integer

See Also

Reference

  • TScrollBar
  • Tee.Control


TScrollBar.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Control
Syntax
Delphi
published
 property Visible : TScrollBarVisible read FVisible write SetVisible
 default TScrollBarVisible.Automatic;

Property Value

Type: TScrollBarVisible

See Also

Reference

  • TScrollBar
  • Tee.Control


TScrollBar Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TScrollBar.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Control
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TScrollBar
  • Tee.Control


TScrollBars Class

Summary

Represents type TScrollBars.

Namespace: Tee.Control
Inheritance Hierarchy
TPersistent
Tee.Control.TScrollBars
Syntax
Delphi
type
 TScrollBars=class(TPersistent)
 end;

The TScrollBars type exposes the following members.

Constants
Show:
Name | Description
VirtualRange | Represents constant VirtualRange.
Top
Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TScrollBars class.
Destroy | Represents the destructor of the TScrollBars class.
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • Tee.Control


TScrollBars Constants

Constants
Name | Description
VirtualRange | Represents constant VirtualRange.
Top


TScrollBars.VirtualRange Constant

Summary

Represents constant VirtualRange.

Namespace: Tee.Control
Syntax
Delphi
public
 VirtualRange=2000;

Value

Type: SmallInt

See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TScrollBars class.
Destroy | Represents the destructor of the TScrollBars class.
Top


TScrollBars.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TScrollBars class.

Namespace: Tee.Control
Syntax
Delphi
public
 Constructor Create(const AOnReset:TNotifyEvent);

Parameters

AOnReset
Type: TNotifyEvent

See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars.Destroy Destructor

Summary

Represents the destructor of the TScrollBars class.

Namespace: Tee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars Properties

Properties
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Visible | Represents property Visible.
Top


TScrollBars.Horizontal Property

Summary

Represents property Horizontal.

Namespace: Tee.Control
Syntax
Delphi
published
 property Horizontal:TScrollBar read FHorizontal write SetHorizontal;

Property Value

Type: TScrollBar

See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars.Vertical Property

Summary

Represents property Vertical.

Namespace: Tee.Control
Syntax
Delphi
published
 property Vertical:TScrollBar read FVertical write SetVertical;

Property Value

Type: TScrollBar

See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Control
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TScrollBars
  • Tee.Control


TScrollBars Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TScrollBars.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Control
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TScrollBars
  • Tee.Control


Tee.Control Enumerations

Enumerations
Name | Description
TScrollBarVisible | Represents type TScrollBarVisible.
Top


TScrollBarVisible Enumeration

Summary

Represents type TScrollBarVisible.

Namespace: Tee.Control
Syntax
Delphi
type
 TScrollBarVisible=(Automatic,Show,Hide);

The TScrollBarVisible type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Hide | Represents constant Hide.
Show | Represents constant Show.
Top
See Also

Reference

  • Tee.Control


Tee.Format Namespace

Summary

Represents namespace Tee.Format.

Classes
Name | Description
TBrush | Represents type TBrush.
TCollectionChange | Represents type TCollectionChange.
TCoordinate | Represents type TCoordinate.
TFont | Represents type TFont.
TFormat | Represents type TFormat.
TGradient | Represents type TGradient.
TGradientColor | Represents type TGradientColor.
TGradientColors | Represents type TGradientColors.
THiddenStroke | Represents type THiddenStroke.
TPersistentChange | Represents type TPersistentChange.
TPicture | Represents type TPicture.
TStroke | Represents type TStroke.
TTextFormat | Represents type TTextFormat.
TVisibleFormat | Represents type TVisibleFormat.
TVisiblePersistentChange | Represents type TVisiblePersistentChange.
Top
Records
Name | Description
TColorHelper | Represents type TColorHelper.
TUIColor | Represents type TUIColor.
Top
Enumerations
Name | Description
TGradientDirection | Represents type TGradientDirection.
TSizeUnits | Represents type TSizeUnits.
TStrokeEnd | Represents type TStrokeEnd.
TStrokeJoin | Represents type TStrokeJoin.
TStrokeStyle | Represents type TStrokeStyle.
Top
Types
Name | Description
TAngle | Represents an alias of the Single type.
TColor | Represents an alias of the TAlphaColor type.
TColorOffset | Represents an alias of the Single type.
Top


Tee.Format Classes

Classes
Name | Description
TBrush | Represents type TBrush.
TCollectionChange | Represents type TCollectionChange.
TCoordinate | Represents type TCoordinate.
TFont | Represents type TFont.
TFormat | Represents type TFormat.
TGradient | Represents type TGradient.
TGradientColor | Represents type TGradientColor.
TGradientColors | Represents type TGradientColors.
THiddenStroke | Represents type THiddenStroke.
TPersistentChange | Represents type TPersistentChange.
TPicture | Represents type TPicture.
TStroke | Represents type TStroke.
TTextFormat | Represents type TTextFormat.
TVisibleFormat | Represents type TVisibleFormat.
TVisiblePersistentChange | Represents type TVisiblePersistentChange.
Top


TBrush Class

Summary

Represents type TBrush.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TBrush
Syntax
Delphi
type
 TBrush=class(TVisiblePersistentChange)
 end;

The TBrush type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBrush class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBrush class.
Top
Properties
Show:
Name | Description
Color | Represents property Color.
Gradient | Represents property Gradient.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Picture | Represents property Picture.
Visible | Represents property Visible. (Inherited from TVisiblePersistentChange.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasGradient | Represents method HasGradient.
HasPicture | Represents method HasPicture.
Hide | Represents method Hide. (Inherited from TVisiblePersistentChange.)
InitColor(TColor) | Represents method InitColor(TColor).
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisiblePersistentChange.)
Show | Represents method Show. (Inherited from TVisiblePersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TBrush Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBrush class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBrush class.
Top


TBrush.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TBrush class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisiblePersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TBrush
  • Tee.Format


TBrush.Destroy Destructor

Summary

Represents the destructor of the TBrush class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBrush
  • Tee.Format


TBrush Properties

Properties
Name | Description
Color | Represents property Color.
Gradient | Represents property Gradient.
Picture | Represents property Picture.
Top


TBrush.Color Property

Summary

Represents property Color.

Namespace: Tee.Format
Syntax
Delphi
published
 property Color:TColor read FColor write SetColor stored IsColorStored;

Property Value

Type: TColor

See Also

Reference

  • TBrush
  • Tee.Format


TBrush.Gradient Property

Summary

Represents property Gradient.

Namespace: Tee.Format
Syntax
Delphi
published
 property Gradient:TGradient read GetGradient write SetGradient stored IsGradientStored;

Property Value

Type: TGradient

See Also

Reference

  • TBrush
  • Tee.Format


TBrush.Picture Property

Summary

Represents property Picture.

Namespace: Tee.Format
Syntax
Delphi
published
 property Picture:TPicture read GetPicture write SetPicture stored IsPictureStored;

Property Value

Type: TPicture

See Also

Reference

  • TBrush
  • Tee.Format


TBrush Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
HasGradient | Represents method HasGradient.
HasPicture | Represents method HasPicture.
InitColor(TColor) | Represents method InitColor(TColor).
Top


TBrush.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisiblePersistentChange.Assign(TPersistent)
See Also

Reference

  • TBrush
  • Tee.Format


TBrush.HasGradient Method

Summary

Represents method HasGradient.

Namespace: Tee.Format
Syntax
Delphi
protected
 function HasGradient:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TBrush
  • Tee.Format


TBrush.HasPicture Method

Summary

Represents method HasPicture.

Namespace: Tee.Format
Syntax
Delphi
protected
 function HasPicture: Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TBrush
  • Tee.Format


TBrush.InitColor(TColor) Method

Summary

Represents method InitColor(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitColor(const AColor:TColor);

Parameters

AColor
Type: System.Void

See Also

Reference

  • TBrush
  • Tee.Format


TCollectionChange Class

Summary

Represents type TCollectionChange.

Namespace: Tee.Format
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Format.TGradientColors
Tee.Grid.Bands.TGridBands
Tee.Grid.Columns.TColumns
Syntax
Delphi
type
 TCollectionChange=class(TOwnedCollection)
 end;

The TCollectionChange type exposes the following members.

Properties
Show:
Name | Description
OnAdded | Represents property OnAdded.
OnChanged | Represents property OnChanged.
OnRemoved | Represents property OnRemoved.
Top
Methods
Show:
Name | Description
DoChanged(TObject) | Represents method DoChanged(TObject).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification).
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top
See Also

Reference

  • Tee.Format


TCollectionChange Properties

Properties
Name | Description
OnAdded | Represents property OnAdded.
OnChanged | Represents property OnChanged.
OnRemoved | Represents property OnRemoved.
Top


TCollectionChange.OnAdded Property

Summary

Represents property OnAdded.

Namespace: Tee.Format
Syntax
Delphi
public
 property OnAdded:TNotifyEvent read FOnAdded write FOnAdded;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCollectionChange.OnChanged Property

Summary

Represents property OnChanged.

Namespace: Tee.Format
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCollectionChange.OnRemoved Property

Summary

Represents property OnRemoved.

Namespace: Tee.Format
Syntax
Delphi
public
 property OnRemoved:TNotifyEvent read FOnRemoved write FOnRemoved;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCollectionChange Methods

Methods
Name | Description
DoChanged(TObject) | Represents method DoChanged(TObject).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification).
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top


TCollectionChange.DoChanged(TObject) Method

Summary

Represents method DoChanged(TObject).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure DoChanged(Sender:TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCollectionChange.Notify(TCollectionItem,TCollectionNotification) Method

Summary

Represents method Notify(TCollectionItem,TCollectionNotification).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure Notify(Item: TCollectionItem; Action: TCollectionNotification); override;

Parameters

Item
Type: TCollectionItem

Action
Type: TCollectionNotification

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCollectionChange.Update(TCollectionItem) Method

Summary

Represents method Update(TCollectionItem).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure Update(Item: TCollectionItem); override;

Parameters

Item
Type: TCollectionItem

See Also

Reference

  • TCollectionChange
  • Tee.Format


TCoordinate Class

Summary

Represents type TCoordinate.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Bands.TBandHeight
Tee.Grid.Columns.TColumnWidth
Tee.Grid.Rows.TCoordinateAccess
Syntax
Delphi
type
 TCoordinate=class(TPersistentChange)
 end;

The TCoordinate type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels.
Units | Represents property Units.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Calculate(Single) | Represents method Calculate(Single).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single).
Prepare(Single) | Represents method Prepare(Single).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels.
Top
See Also

Reference

  • Tee.Format


TCoordinate Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TCoordinate.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TCoordinate class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate Properties

Properties
Name | Description
Automatic | Represents property Automatic.
Pixels | Represents property Pixels.
Units | Represents property Units.
Value | Represents property Value.
Top


TCoordinate.Automatic Property

Summary

Represents property Automatic.

Namespace: Tee.Format
Syntax
Delphi
published
 property Automatic:Boolean read FAutomatic write SetAutomatic stored IsAutomaticStored;

Property Value

Type: Boolean

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.Pixels Property

Summary

Represents property Pixels.

Namespace: Tee.Format
Syntax
Delphi
public
 property Pixels:Single read IPixels;

Property Value

Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.Units Property

Summary

Represents property Units.

Namespace: Tee.Format
Syntax
Delphi
published
 property Units:TSizeUnits read FUnits write SetUnits default TSizeUnits.Pixels;

Property Value

Type: TSizeUnits

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.Value Property

Summary

Represents property Value.

Namespace: Tee.Format
Syntax
Delphi
published
 property Value:Single read FValue write SetValue stored IsValueStored;

Property Value

Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Calculate(Single) | Represents method Calculate(Single).
InitValue(Single) | Represents method InitValue(Single).
Prepare(Single) | Represents method Prepare(Single).
Top


TCoordinate.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.Calculate(Single) Method

Summary

Represents method Calculate(Single).

Namespace: Tee.Format
Syntax
Delphi
public
 function Calculate(const ATotal:Single):Single;

Parameters

ATotal
Type: Single

Return Value

Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.InitValue(Single) Method

Summary

Represents method InitValue(Single).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitValue(const AValue:Single);

Parameters

AValue
Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate.Prepare(Single) Method

Summary

Represents method Prepare(Single).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Prepare(const ATotal:Single);

Parameters

ATotal
Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TCoordinate Fields

Fields
Name | Description
IPixels | Represents field IPixels.
Top


TCoordinate.IPixels Field

Summary

Represents field IPixels.

Namespace: Tee.Format
Syntax
Delphi
protected
 IPixels : Single;

Field Value

Type: Single

See Also

Reference

  • TCoordinate
  • Tee.Format


TFont Class

Summary

Represents type TFont.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TFont
Syntax
Delphi
type
 TFont=class(TPersistentChange)
 end;

The TFont type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TFont class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TFont class.
Top
Properties
Show:
Name | Description
Brush | Represents property Brush.
Color | Represents property Color.
Name | Represents property Name.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Size | Represents property Size.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitColor(TColor) | Represents method InitColor(TColor).
InitStyle(TFontStyles) | Represents method InitStyle(TFontStyles).
Top
Fields
Show:
Name | Description
DefaultName | Represents field DefaultName.
DefaultSize | Represents field DefaultSize.
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TFont Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TFont class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TFont class.
Top


TFont.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TFont class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TFont
  • Tee.Format


TFont.Destroy Destructor

Summary

Represents the destructor of the TFont class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFont
  • Tee.Format


TFont Properties

Properties
Name | Description
Brush | Represents property Brush.
Color | Represents property Color.
Name | Represents property Name.
Size | Represents property Size.
Style | Represents property Style.
Top


TFont.Brush Property

Summary

Represents property Brush.

Namespace: Tee.Format
Syntax
Delphi
published
 property Brush:TBrush read FBrush write SetBrush;

Property Value

Type: TBrush

See Also

Reference

  • TFont
  • Tee.Format


TFont.Color Property

Summary

Represents property Color.

Namespace: Tee.Format
Syntax
Delphi
published
 property Color:TColor read GetColor write SetColor stored False;

Property Value

Type: TColor

See Also

Reference

  • TFont
  • Tee.Format


TFont.Name Property

Summary

Represents property Name.

Namespace: Tee.Format
Syntax
Delphi
published
 property Name:String read FName write SetName stored IsNameStored;

Property Value

Type: String

See Also

Reference

  • TFont
  • Tee.Format


TFont.Size Property

Summary

Represents property Size.

Namespace: Tee.Format
Syntax
Delphi
published
 property Size:Single read FSize write SetSize stored IsSizeStored;

Property Value

Type: Single

See Also

Reference

  • TFont
  • Tee.Format


TFont.Style Property

Summary

Represents property Style.

Namespace: Tee.Format
Syntax
Delphi
published
 property Style:TFontStyles read FStyle write SetStyle stored IsStyleStored;

Property Value

Type: TFontStyles

See Also

Reference

  • TFont
  • Tee.Format


TFont Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
InitColor(TColor) | Represents method InitColor(TColor).
InitStyle(TFontStyles) | Represents method InitStyle(TFontStyles).
Top


TFont.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TFont
  • Tee.Format


TFont.InitColor(TColor) Method

Summary

Represents method InitColor(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitColor(const AColor:TColor);

Parameters

AColor
Type: System.Void

See Also

Reference

  • TFont
  • Tee.Format


TFont.InitStyle(TFontStyles) Method

Summary

Represents method InitStyle(TFontStyles).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitStyle(const AStyle:TFontStyles);

Parameters

AStyle
Type: TFontStyles

See Also

Reference

  • TFont
  • Tee.Format


TFont Fields

Fields
Name | Description
DefaultName | Represents field DefaultName.
DefaultSize | Represents field DefaultSize.
Top


TFont.DefaultName Field

Summary

Represents field DefaultName.

Namespace: Tee.Format
Syntax
Delphi
public
 class var
 DefaultName : String;

Field Value

Type: String

See Also

Reference

  • TFont
  • Tee.Format


TFont.DefaultSize Field

Summary

Represents field DefaultSize.

Namespace: Tee.Format
Syntax
Delphi
public
 class var
 DefaultSize : Single;

Field Value

Type: Single

See Also

Reference

  • TFont
  • Tee.Format


TFormat Class

Summary

Represents type TFormat.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TFormat
Tee.Format.TTextFormat
Tee.Format.TVisibleFormat
Syntax
Delphi
type
 TFormat=class(TPersistentChange)
 end;

The TFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TFormat class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TFormat class.
Top
Properties
Show:
Name | Description
Brush | Represents property Brush.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Stroke | Represents property Stroke.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
ShouldPaint | Represents method ShouldPaint.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TFormat Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TFormat class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TFormat class.
Top


TFormat.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TFormat class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TFormat
  • Tee.Format


TFormat.Destroy Destructor

Summary

Represents the destructor of the TFormat class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFormat
  • Tee.Format


TFormat Properties

Properties
Name | Description
Brush | Represents property Brush.
Stroke | Represents property Stroke.
Top


TFormat.Brush Property

Summary

Represents property Brush.

Namespace: Tee.Format
Syntax
Delphi
published
 property Brush:TBrush read FBrush write SetBrush;

Property Value

Type: TBrush

See Also

Reference

  • TFormat
  • Tee.Format


TFormat.Stroke Property

Summary

Represents property Stroke.

Namespace: Tee.Format
Syntax
Delphi
published
 property Stroke:TStroke read FStroke write SetStroke;

Property Value

Type: TStroke

See Also

Reference

  • TFormat
  • Tee.Format


TFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ShouldPaint | Represents method ShouldPaint.
Top


TFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TFormat
  • Tee.Format


TFormat.ShouldPaint Method

Summary

Represents method ShouldPaint.

Namespace: Tee.Format
Syntax
Delphi
public
 function ShouldPaint:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TFormat
  • Tee.Format


TGradient Class

Summary

Represents type TGradient.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TGradient
Syntax
Delphi
type
 TGradient=class(TVisiblePersistentChange)
 end;

The TGradient type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGradient class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGradient class.
Top
Properties
Show:
Name | Description
Angle | Represents property Angle.
Colors | Represents property Colors.
Direction | Represents property Direction.
Inverted | Represents property Inverted.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Visible | Represents property Visible. (Inherited from TVisiblePersistentChange.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide. (Inherited from TVisiblePersistentChange.)
InitColors(TColor,TColor) | Represents method InitColors(TColor,TColor).
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisiblePersistentChange.)
Show | Represents method Show. (Inherited from TVisiblePersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TGradient Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGradient class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGradient class.
Top


TGradient.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TGradient class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisiblePersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TGradient
  • Tee.Format


TGradient.Destroy Destructor

Summary

Represents the destructor of the TGradient class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGradient
  • Tee.Format


TGradient Properties

Properties
Name | Description
Angle | Represents property Angle.
Colors | Represents property Colors.
Direction | Represents property Direction.
Inverted | Represents property Inverted.
Top


TGradient.Angle Property

Summary

Represents property Angle.

Namespace: Tee.Format
Syntax
Delphi
published
 property Angle:TAngle read FAngle write SetAngle stored IsAngleStored;

Property Value

Type: TAngle

See Also

Reference

  • TGradient
  • Tee.Format


TGradient.Colors Property

Summary

Represents property Colors.

Namespace: Tee.Format
Syntax
Delphi
published
 property Colors:TGradientColors read FColors write SetColors stored IsColorsStored;

Property Value

Type: TGradientColors

See Also

Reference

  • TGradient
  • Tee.Format


TGradient.Direction Property

Summary

Represents property Direction.

Namespace: Tee.Format
Syntax
Delphi
published
 property Direction:TGradientDirection read FDirection write SetDirection
 default TGradientDirection.Vertical;

Property Value

Type: TGradientDirection

See Also

Reference

  • TGradient
  • Tee.Format


TGradient.Inverted Property

Summary

Represents property Inverted.

Namespace: Tee.Format
Syntax
Delphi
published
 property Inverted:Boolean read FInverted write SetInverted default False;

Property Value

Type: Boolean

See Also

Reference

  • TGradient
  • Tee.Format


TGradient Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
InitColors(TColor,TColor) | Represents method InitColors(TColor,TColor).
Top


TGradient.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisiblePersistentChange.Assign(TPersistent)
See Also

Reference

  • TGradient
  • Tee.Format


TGradient.InitColors(TColor,TColor) Method

Summary

Represents method InitColors(TColor,TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitColors(const AColor0,AColor1:TColor);

Parameters

AColor0
Type: System.Void

AColor1
Type: System.Void

See Also

Reference

  • TGradient
  • Tee.Format


TGradientColor Class

Summary

Represents type TGradientColor.

Namespace: Tee.Format
Inheritance Hierarchy
TCollectionItem
Tee.Format.TGradientColor
Syntax
Delphi
type
 TGradientColor=class(TCollectionItem)
 end;

The TGradientColor type exposes the following members.

Properties
Show:
Name | Description
Color | Represents property Color.
Offset | Represents property Offset.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • Tee.Format


TGradientColor Properties

Properties
Name | Description
Color | Represents property Color.
Offset | Represents property Offset.
Top


TGradientColor.Color Property

Summary

Represents property Color.

Namespace: Tee.Format
Syntax
Delphi
published
 property Color:TColor read FColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TGradientColor
  • Tee.Format


TGradientColor.Offset Property

Summary

Represents property Offset.

Namespace: Tee.Format
Syntax
Delphi
published
 property Offset:TColorOffset read FOffset write SetOffset;

Property Value

Type: TColorOffset

See Also

Reference

  • TGradientColor
  • Tee.Format


TGradientColor Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TGradientColor.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGradientColor
  • Tee.Format


TGradientColors Class

Summary

Represents type TGradientColors.

Namespace: Tee.Format
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Format.TGradientColors
Syntax
Delphi
type
 TGradientColors=class(TCollectionChange)
 end;

The TGradientColors type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add.
Add(TColor,TColorOffset) | Overloaded. Represents method Add(TColor,TColorOffset).
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCollectionChange.)
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Inherited from TCollectionChange.)
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
See Also

Reference

  • Tee.Format


TGradientColors Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TGradientColors.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: Tee.Format
Syntax
Delphi
public
 property Items[const Index:Integer]:TGradientColor read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TGradientColor

See Also

Reference

  • TGradientColors
  • Tee.Format


TGradientColors Methods

Methods
Name | Description
Add | Overloaded. Represents method Add.
Add(TColor,TColorOffset) | Overloaded. Represents method Add(TColor,TColorOffset).
Top


TGradientColors.Add Method

Summary

Represents method Add.

Namespace: Tee.Format
Syntax
Delphi
public
 function Add:TGradientColor; overload; inline;

Return Value

Type: TGradientColor

See Also

Reference

  • TGradientColors
  • Tee.Format


TGradientColors.Add(TColor,TColorOffset) Method

Summary

Represents method Add(TColor,TColorOffset).

Namespace: Tee.Format
Syntax
Delphi
public
 function Add(const AColor:TColor; const AOffset:TColorOffset):TGradientColor; overload;

Parameters

AColor
Type: System.Void

AOffset
Type: System.Void

Return Value

Type: TGradientColor

See Also

Reference

  • TGradientColors
  • Tee.Format


THiddenStroke Class

Summary

Represents type THiddenStroke.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TStroke
Tee.Format.THiddenStroke
Tee.Renders.TBorder
Syntax
Delphi
type
 THiddenStroke=class(TStroke)
 end;

The THiddenStroke type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the THiddenStroke class. (Overrides TStroke.Create(TNotifyEvent).)
CreateColor(TNotifyEvent,TColor) | Initializes a new instance of the TStroke class. (Inherited from TStroke.)
Top
Properties
Show:
Name | Description
Brush | Represents property Brush. (Inherited from TStroke.)
Color | Represents property Color. (Inherited from TStroke.)
EndStyle | Represents property EndStyle. (Inherited from TStroke.)
JoinStyle | Represents property JoinStyle. (Inherited from TStroke.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Size | Represents property Size. (Inherited from TStroke.)
Style | Represents property Style. (Inherited from TStroke.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide. (Inherited from TVisiblePersistentChange.)
InitStyle(TStrokeStyle) | Represents method InitStyle(TStrokeStyle). (Inherited from TStroke.)
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisiblePersistentChange.)
Show | Represents method Show. (Inherited from TVisiblePersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


THiddenStroke Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the THiddenStroke class. (Overrides TStroke.Create(TNotifyEvent).)
Top


THiddenStroke.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the THiddenStroke class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TStroke.Create(TNotifyEvent)
See Also

Reference

  • THiddenStroke
  • Tee.Format


THiddenStroke Properties

Properties
Name | Description
Visible | Represents property Visible.
Top


THiddenStroke.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Format
Syntax
Delphi
published
 property Visible default False;

Property Value

Type: Void

See Also

Reference

  • THiddenStroke
  • Tee.Format


TPersistentChange Class

Summary

Represents type TPersistentChange.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Format.TFont
Tee.Format.TFormat
Tee.Format.TPicture
Tee.Format.TVisiblePersistentChange
Tee.Grid.Bands.Columns.TColumnDrag
Tee.Grid.Columns.TDataFormat
Tee.Grid.RowGroup.TGridScrolling
Tee.Grid.Selection.TSelectionRange
Tee.Grid.TGridEditing
Tee.Grid.Ticker.TGridTicker
Tee.Grid.TTextEditing
Tee.Renders.TAlignments
Tee.Renders.TBorders
Tee.Renders.TBox
Tee.Renders.TEdges
Tee.Renders.TRender
Tee.Renders.TTextTrimming
Syntax
Delphi
type
 TPersistentChange=class(TPersistent)
 end;

The TPersistentChange type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class.
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean).
Changed | Represents method Changed.
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer).
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single).
ChangeString(String,String) | Represents method ChangeString(String,String).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged.
Top
See Also

Reference

  • Tee.Format


TPersistentChange Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class.
Top


TPersistentChange.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TPersistentChange class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); virtual;

Parameters

AChanged
Type: TNotifyEvent

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange Properties

Properties
Name | Description
OnChange | Represents property OnChange.
Top


TPersistentChange.OnChange Property

Summary

Represents property OnChange.

Namespace: Tee.Format
Syntax
Delphi
public
 property OnChange:TNotifyEvent read IChanged write IChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange Methods

Methods
Name | Description
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean).
Changed | Represents method Changed.
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer).
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single).
ChangeString(String,String) | Represents method ChangeString(String,String).
Top


TPersistentChange.ChangeBoolean(Boolean,Boolean) Method

Summary

Represents method ChangeBoolean(Boolean,Boolean).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure ChangeBoolean(var Variable:Boolean; const Value: Boolean);

Parameters

Variable
Type: Boolean

Value
Type: Boolean

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange.Changed Method

Summary

Represents method Changed.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Changed;
See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange.ChangeInteger(Integer,Integer) Method

Summary

Represents method ChangeInteger(Integer,Integer).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure ChangeInteger(var Variable: Integer; const Value: Integer);

Parameters

Variable
Type: Integer

Value
Type: Integer

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange.ChangeSingle(Single,Single) Method

Summary

Represents method ChangeSingle(Single,Single).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure ChangeSingle(var Variable:Single; const Value: Single);

Parameters

Variable
Type: Single

Value
Type: Single

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange.ChangeString(String,String) Method

Summary

Represents method ChangeString(String,String).

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure ChangeString(var Variable:String; const Value: String);

Parameters

Variable
Type: String

Value
Type: String

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPersistentChange Fields

Fields
Name | Description
IChanged | Represents field IChanged.
Top


TPersistentChange.IChanged Field

Summary

Represents field IChanged.

Namespace: Tee.Format
Syntax
Delphi
protected
 IChanged : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TPersistentChange
  • Tee.Format


TPicture Class

Summary

Represents type TPicture.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TPicture
Tee.GridData.DB.TPictureAccess
Syntax
Delphi
type
 TPicture=class(TPersistentChange)
 end;

The TPicture type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPicture class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TPicture class.
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Top
Methods
Show:
Name | Description
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Clear | Represents method Clear.
FreeInternal | Represents method FreeInternal.
NewPicture | Represents method NewPicture.
SetGraphic(TObject) | Represents method SetGraphic(TObject).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Internal | Represents field Internal.
Original | Represents field Original.
Stretch | Represents field Stretch.
TagObject | Represents field TagObject.
Top
See Also

Reference

  • Tee.Format


TPicture Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPicture class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TPicture class.
Top


TPicture.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TPicture class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TPicture
  • Tee.Format


TPicture.Destroy Destructor

Summary

Represents the destructor of the TPicture class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TPicture
  • Tee.Format


TPicture Methods

Methods
Name | Description
Clear | Represents method Clear.
FreeInternal | Represents method FreeInternal.
NewPicture | Represents method NewPicture.
SetGraphic(TObject) | Represents method SetGraphic(TObject).
Top


TPicture.Clear Method

Summary

Represents method Clear.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TPicture
  • Tee.Format


TPicture.FreeInternal Method

Summary

Represents method FreeInternal.

Namespace: Tee.Format
Syntax
Delphi
protected
 procedure FreeInternal;
See Also

Reference

  • TPicture
  • Tee.Format


TPicture.NewPicture Method

Summary

Represents method NewPicture.

Namespace: Tee.Format
Syntax
Delphi
public
 class function NewPicture:TPersistent; virtual;

Return Value

Type: TPersistent

See Also

Reference

  • TPicture
  • Tee.Format


TPicture.SetGraphic(TObject) Method

Summary

Represents method SetGraphic(TObject).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure SetGraphic(const AObject:TObject);

Parameters

AObject
Type: TObject

See Also

Reference

  • TPicture
  • Tee.Format


TPicture Fields

Fields
Name | Description
Internal | Represents field Internal.
Original | Represents field Original.
Stretch | Represents field Stretch.
TagObject | Represents field TagObject.
Top


TPicture.Internal Field

Summary

Represents field Internal.

Namespace: Tee.Format
Syntax
Delphi
protected
 Internal,
 Original : TObject;

Field Value

Type: TObject

See Also

Reference

  • TPicture
  • Tee.Format


TPicture.Original Field

Summary

Represents field Original.

Namespace: Tee.Format
Syntax
Delphi
protected
 Internal,
 Original : TObject;

Field Value

Type: TObject

See Also

Reference

  • TPicture
  • Tee.Format


TPicture.Stretch Field

Summary

Represents field Stretch.

Namespace: Tee.Format
Syntax
Delphi
public
 Stretch : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPicture
  • Tee.Format


TPicture.TagObject Field

Summary

Represents field TagObject.

Namespace: Tee.Format
Syntax
Delphi
protected
 TagObject : TObject;

Field Value

Type: TObject

See Also

Reference

  • TPicture
  • Tee.Format


TStroke Class

Summary

Represents type TStroke.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TStroke
Tee.Format.THiddenStroke
Syntax
Delphi
type
 TStroke=class(TVisiblePersistentChange)
 end;

The TStroke type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TStroke class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
CreateColor(TNotifyEvent,TColor) | Initializes a new instance of the TStroke class.
Destroy | Represents the destructor of the TStroke class.
Top
Properties
Show:
Name | Description
Brush | Represents property Brush.
Color | Represents property Color.
EndStyle | Represents property EndStyle.
JoinStyle | Represents property JoinStyle.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Size | Represents property Size.
Style | Represents property Style.
Visible | Represents property Visible. (Inherited from TVisiblePersistentChange.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide. (Inherited from TVisiblePersistentChange.)
InitStyle(TStrokeStyle) | Represents method InitStyle(TStrokeStyle).
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisiblePersistentChange.)
Show | Represents method Show. (Inherited from TVisiblePersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TStroke Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TStroke class. (Overrides TVisiblePersistentChange.Create(TNotifyEvent).)
CreateColor(TNotifyEvent,TColor) | Initializes a new instance of the TStroke class.
Destroy | Represents the destructor of the TStroke class.
Top


TStroke.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TStroke class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisiblePersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TStroke
  • Tee.Format


TStroke.CreateColor(TNotifyEvent,TColor) Constructor

Summary

Initializes a new instance of the TStroke class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor CreateColor(const AChanged:TNotifyEvent; const AColor:TColor);

Parameters

AChanged
Type: TNotifyEvent

AColor
Type: System.Void

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.Destroy Destructor

Summary

Represents the destructor of the TStroke class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TStroke
  • Tee.Format


TStroke Properties

Properties
Name | Description
Brush | Represents property Brush.
Color | Represents property Color.
EndStyle | Represents property EndStyle.
JoinStyle | Represents property JoinStyle.
Size | Represents property Size.
Style | Represents property Style.
Top


TStroke.Brush Property

Summary

Represents property Brush.

Namespace: Tee.Format
Syntax
Delphi
published
 property Brush:TBrush read FBrush write SetBrush;

Property Value

Type: TBrush

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.Color Property

Summary

Represents property Color.

Namespace: Tee.Format
Syntax
Delphi
published
 property Color:TColor read GetColor write SetColor stored False;

Property Value

Type: TColor

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.EndStyle Property

Summary

Represents property EndStyle.

Namespace: Tee.Format
Syntax
Delphi
published
 property EndStyle:TStrokeEnd read FEnd write SetEnd default TStrokeEnd.Flat;

Property Value

Type: TStrokeEnd

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.JoinStyle Property

Summary

Represents property JoinStyle.

Namespace: Tee.Format
Syntax
Delphi
published
 property JoinStyle:TStrokeJoin read FJoin write SetJoin default TStrokeJoin.Mitter;

Property Value

Type: TStrokeJoin

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.Size Property

Summary

Represents property Size.

Namespace: Tee.Format
Syntax
Delphi
published
 property Size:Single read FSize write SetSize stored IsSizeStored;

Property Value

Type: Single

See Also

Reference

  • TStroke
  • Tee.Format


TStroke.Style Property

Summary

Represents property Style.

Namespace: Tee.Format
Syntax
Delphi
published
 property Style:TStrokeStyle read FStyle write SetStyle stored IsStyleStored;

Property Value

Type: TStrokeStyle

See Also

Reference

  • TStroke
  • Tee.Format


TStroke Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
InitStyle(TStrokeStyle) | Represents method InitStyle(TStrokeStyle).
Top


TStroke.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisiblePersistentChange.Assign(TPersistent)
See Also

Reference

  • TStroke
  • Tee.Format


TStroke.InitStyle(TStrokeStyle) Method

Summary

Represents method InitStyle(TStrokeStyle).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitStyle(const Value:TStrokeStyle);

Parameters

Value
Type: TStrokeStyle

See Also

Reference

  • TStroke
  • Tee.Format


TTextFormat Class

Summary

Represents type TTextFormat.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TFormat
Tee.Format.TTextFormat
Syntax
Delphi
type
 TTextFormat=class(TFormat)
 end;

The TTextFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextFormat class. (Overrides TFormat.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TTextFormat class. (Overrides TFormat.Destroy.)
Top
Properties
Show:
Name | Description
Brush | Represents property Brush. (Inherited from TFormat.)
Font | Represents property Font.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Stroke | Represents property Stroke. (Inherited from TFormat.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
ShouldPaint | Represents method ShouldPaint. (Inherited from TFormat.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TTextFormat Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextFormat class. (Overrides TFormat.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TTextFormat class. (Overrides TFormat.Destroy.)
Top


TTextFormat.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TTextFormat class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TFormat.Create(TNotifyEvent)
See Also

Reference

  • TTextFormat
  • Tee.Format


TTextFormat.Destroy Destructor

Summary

Represents the destructor of the TTextFormat class.

Namespace: Tee.Format
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormat.Destroy
See Also

Reference

  • TTextFormat
  • Tee.Format


TTextFormat Properties

Properties
Name | Description
Font | Represents property Font.
Top


TTextFormat.Font Property

Summary

Represents property Font.

Namespace: Tee.Format
Syntax
Delphi
published
 property Font:TFont read FFont write SetFont;

Property Value

Type: TFont

See Also

Reference

  • TTextFormat
  • Tee.Format


TTextFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top


TTextFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormat.Assign(TPersistent)
See Also

Reference

  • TTextFormat
  • Tee.Format


TVisibleFormat Class

Summary

Represents type TVisibleFormat.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TFormat
Tee.Format.TVisibleFormat
Tee.Grid.Rows.TAlternateFormat
Syntax
Delphi
type
 TVisibleFormat=class(TFormat)
 end;

The TVisibleFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TFormat class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Brush | Represents property Brush. (Inherited from TFormat.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Stroke | Represents property Stroke. (Inherited from TFormat.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TFormat.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide.
InitVisible(Boolean) | Represents method InitVisible(Boolean).
ShouldPaint | Represents method ShouldPaint. (Inherited from TFormat.)
Show | Represents method Show.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TVisibleFormat Properties

Properties
Name | Description
Visible | Represents property Visible.
Top


TVisibleFormat.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Format
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible stored IsVisibleStored;

Property Value

Type: Boolean

See Also

Reference

  • TVisibleFormat
  • Tee.Format


TVisibleFormat Methods

Methods
Name | Description
Hide | Represents method Hide.
InitVisible(Boolean) | Represents method InitVisible(Boolean).
Show | Represents method Show.
Top


TVisibleFormat.Hide Method

Summary

Represents method Hide.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Hide;
See Also

Reference

  • TVisibleFormat
  • Tee.Format


TVisibleFormat.InitVisible(Boolean) Method

Summary

Represents method InitVisible(Boolean).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitVisible(const Value:Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TVisibleFormat
  • Tee.Format


TVisibleFormat.Show Method

Summary

Represents method Show.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Show;
See Also

Reference

  • TVisibleFormat
  • Tee.Format


TVisiblePersistentChange Class

Summary

Represents type TVisiblePersistentChange.

Namespace: Tee.Format
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TBrush
Tee.Format.TGradient
Tee.Format.TStroke
Syntax
Delphi
type
 TVisiblePersistentChange=class(TPersistentChange)
 end;

The TVisiblePersistentChange type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TVisiblePersistentChange class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide.
InitVisible(Boolean) | Represents method InitVisible(Boolean).
Show | Represents method Show.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Format


TVisiblePersistentChange Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TVisiblePersistentChange class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TVisiblePersistentChange.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TVisiblePersistentChange class.

Namespace: Tee.Format
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


TVisiblePersistentChange Properties

Properties
Name | Description
Visible | Represents property Visible.
Top


TVisiblePersistentChange.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Format
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible stored IsVisibleStored;

Property Value

Type: Boolean

See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


TVisiblePersistentChange Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Hide | Represents method Hide.
InitVisible(Boolean) | Represents method InitVisible(Boolean).
Show | Represents method Show.
Top


TVisiblePersistentChange.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


TVisiblePersistentChange.Hide Method

Summary

Represents method Hide.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Hide;
See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


TVisiblePersistentChange.InitVisible(Boolean) Method

Summary

Represents method InitVisible(Boolean).

Namespace: Tee.Format
Syntax
Delphi
public
 procedure InitVisible(const Value:Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


TVisiblePersistentChange.Show Method

Summary

Represents method Show.

Namespace: Tee.Format
Syntax
Delphi
public
 procedure Show;
See Also

Reference

  • TVisiblePersistentChange
  • Tee.Format


Tee.Format Records

Records
Name | Description
TColorHelper | Represents type TColorHelper.
TUIColor | Represents type TUIColor.
Top


TColorHelper Record

Summary

Represents type TColorHelper.

Namespace: Tee.Format
Syntax
Delphi
type
 TColorHelper=record
 end;

The TColorHelper type exposes the following members.

Methods
Show:
Name | Description
From(TColor,Single) | Represents method From(TColor,Single).
Opacity(TColor) | Represents method Opacity(TColor).
RemoveOpacity(TColor) | Represents method RemoveOpacity(TColor).
Split(TColor,Single) | Represents method Split(TColor,Single).
Swap(TColor) | Represents method Swap(TColor).
SwapCheck(TColor) | Represents method SwapCheck(TColor).
Top
See Also

Reference

  • Tee.Format


TColorHelper Methods

Methods
Name | Description
From(TColor,Single) | Represents method From(TColor,Single).
Opacity(TColor) | Represents method Opacity(TColor).
RemoveOpacity(TColor) | Represents method RemoveOpacity(TColor).
Split(TColor,Single) | Represents method Split(TColor,Single).
Swap(TColor) | Represents method Swap(TColor).
SwapCheck(TColor) | Represents method SwapCheck(TColor).
Top


TColorHelper.From(TColor,Single) Method

Summary

Represents method From(TColor,Single).

Namespace: Tee.Format
Syntax
Delphi
public
 class function From(const AColor:TColor; const AOpacity:Single):TColor; static;

Parameters

AColor
Type: System.Void

AOpacity
Type: Single

Return Value

Type: TColor

See Also

Reference

  • TColorHelper
  • Tee.Format


TColorHelper.Opacity(TColor) Method

Summary

Represents method Opacity(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 class function Opacity(const AColor: TColor):Byte; inline; static;

Parameters

AColor
Type: System.Void

Return Value

Type: Byte

See Also

Reference

  • TColorHelper
  • Tee.Format


TColorHelper.RemoveOpacity(TColor) Method

Summary

Represents method RemoveOpacity(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 class function RemoveOpacity(const AColor: TColor):TColor; inline; static;

Parameters

AColor
Type: System.Void

Return Value

Type: TColor

See Also

Reference

  • TColorHelper
  • Tee.Format


TColorHelper.Split(TColor,Single) Method

Summary

Represents method Split(TColor,Single).

Namespace: Tee.Format
Syntax
Delphi
public
 class function Split(const AColor:TColor; out AOpacity:Single):TColor; static;

Parameters

AColor
Type: System.Void

AOpacity
Type: Single

Return Value

Type: TColor

See Also

Reference

  • TColorHelper
  • Tee.Format


TColorHelper.Swap(TColor) Method

Summary

Represents method Swap(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 class function Swap(const AColor:TColor):TColor; static;

Parameters

AColor
Type: System.Void

Return Value

Type: TColor

See Also

Reference

  • TColorHelper
  • Tee.Format


TColorHelper.SwapCheck(TColor) Method

Summary

Represents method SwapCheck(TColor).

Namespace: Tee.Format
Syntax
Delphi
public
 class function SwapCheck(const AColor:TColor):TColor; static;

Parameters

AColor
Type: System.Void

Return Value

Type: TColor

See Also

Reference

  • TColorHelper
  • Tee.Format


TUIColor Record

Summary

Represents type TUIColor.

Namespace: Tee.Format
Syntax
Delphi
type
 TUIColor=record
 end;

The TUIColor type exposes the following members.

Methods
Show:
Name | Description
Interpolate(TColor,TColor,Single) | Represents method Interpolate(TColor,TColor,Single).
Top
See Also

Reference

  • Tee.Format


TUIColor Methods

Methods
Name | Description
Interpolate(TColor,TColor,Single) | Represents method Interpolate(TColor,TColor,Single).
Top


TUIColor.Interpolate(TColor,TColor,Single) Method

Summary

Represents method Interpolate(TColor,TColor,Single).

Namespace: Tee.Format
Syntax
Delphi
public
 class function Interpolate(const AOld,ANew:TColor; const APercent:Single):TColor; static;

Parameters

AOld
Type: System.Void

ANew
Type: System.Void

APercent
Type: Single

Return Value

Type: TColor

See Also

Reference

  • TUIColor
  • Tee.Format


Tee.Format Enumerations

Enumerations
Name | Description
TGradientDirection | Represents type TGradientDirection.
TSizeUnits | Represents type TSizeUnits.
TStrokeEnd | Represents type TStrokeEnd.
TStrokeJoin | Represents type TStrokeJoin.
TStrokeStyle | Represents type TStrokeStyle.
Top


TGradientDirection Enumeration

Summary

Represents type TGradientDirection.

Namespace: Tee.Format
Syntax
Delphi
type
 TGradientDirection=(Vertical,Horizontal,Diagonal,BackDiagonal,Radial);

The TGradientDirection type exposes the following members.

Members
Show:
Name | Description
BackDiagonal | Represents constant BackDiagonal.
Diagonal | Represents constant Diagonal.
Horizontal | Represents constant Horizontal.
Radial | Represents constant Radial.
Vertical | Represents constant Vertical.
Top
See Also

Reference

  • Tee.Format


TSizeUnits Enumeration

Summary

Represents type TSizeUnits.

Namespace: Tee.Format
Syntax
Delphi
type
 TSizeUnits=(Pixels,Percent);

The TSizeUnits type exposes the following members.

Members
Show:
Name | Description
Percent | Represents constant Percent.
Pixels | Represents constant Pixels.
Top
See Also

Reference

  • Tee.Format


TStrokeEnd Enumeration

Summary

Represents type TStrokeEnd.

Namespace: Tee.Format
Syntax
Delphi
type
 TStrokeEnd=(Round,Square,Flat);

The TStrokeEnd type exposes the following members.

Members
Show:
Name | Description
Flat | Represents constant Flat.
Round | Represents constant Round.
Square | Represents constant Square.
Top
See Also

Reference

  • Tee.Format


TStrokeJoin Enumeration

Summary

Represents type TStrokeJoin.

Namespace: Tee.Format
Syntax
Delphi
type
 TStrokeJoin=(Round,Bevel,Mitter);

The TStrokeJoin type exposes the following members.

Members
Show:
Name | Description
Bevel | Represents constant Bevel.
Mitter | Represents constant Mitter.
Round | Represents constant Round.
Top
See Also

Reference

  • Tee.Format


TStrokeStyle Enumeration

Summary

Represents type TStrokeStyle.

Namespace: Tee.Format
Syntax
Delphi
type
 TStrokeStyle=(Solid,Dash,Dot,DashDot,DashDotDot,Custom);

The TStrokeStyle type exposes the following members.

Members
Show:
Name | Description
Custom | Represents constant Custom.
Dash | Represents constant Dash.
DashDot | Represents constant DashDot.
DashDotDot | Represents constant DashDotDot.
Dot | Represents constant Dot.
Solid | Represents constant Solid.
Top
See Also

Reference

  • Tee.Format


Tee.Format Types

Types
Name | Description
TAngle | Represents an alias of the Single type.
TColor | Represents an alias of the TAlphaColor type.
TColorOffset | Represents an alias of the Single type.
Top


TAngle Type

Summary

Represents an alias of the Single type.

Namespace: Tee.Format
Syntax
Delphi
type
 TAngle=Single;
See Also

Reference

  • Tee.Format


TColor Type

Summary

Represents an alias of the TAlphaColor type.

Namespace: Tee.Format
Syntax
Delphi
type
 TColor=TAlphaColor;
See Also

Reference

  • Tee.Format


TColorOffset Type

Summary

Represents an alias of the Single type.

Namespace: Tee.Format
Syntax
Delphi
type
 TColorOffset=Single;
See Also

Reference

  • Tee.Format


Tee.Grid Namespace

Summary

Represents namespace Tee.Grid.

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCustomTeeGrid | Represents type TCustomTeeGrid.
TCustomTeeGridEditor | Represents type TCustomTeeGridEditor.
TDataAccess | Represents type TDataAccess.
TGridEditing | Represents type TGridEditing.
TIndicatorAccess | Represents type TIndicatorAccess.
TReaderAccess | Represents type TReaderAccess.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTextEditing | Represents type TTextEditing.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top
Records
Name | Description
TPersistCollection | Represents type TPersistCollection.
Top
Enumerations
Name | Description
TEditingEnter | Represents type TEditingEnter.
Top
Delegates
Name | Description
TCustomTeeGridEditor.TEditGrid | Represents type TEditGrid.
Top
Types
Name | Description
TScroll | Represents an alias of the TPointF type.
Top


Tee.Grid Classes

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCustomTeeGrid | Represents type TCustomTeeGrid.
TCustomTeeGridEditor | Represents type TCustomTeeGridEditor.
TDataAccess | Represents type TDataAccess.
TGridEditing | Represents type TGridEditing.
TIndicatorAccess | Represents type TIndicatorAccess.
TReaderAccess | Represents type TReaderAccess.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTextEditing | Represents type TTextEditing.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top


TColumnsAccess Class

Summary

Represents type TColumnsAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Columns.TColumns
Tee.Grid.TColumnsAccess
Syntax
Delphi
type
 TColumnsAccess=class(TColumns);

The TColumnsAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent,TCollectionItemClass) | Initializes a new instance of the TColumns class. (Inherited from TColumns.)
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer]. (Inherited from TColumns.)
Items[String] | Represents property Items[String]. (Inherited from TColumns.)
LoadOrder[Integer] | Represents property LoadOrder[Integer]. (Inherited from TColumns.)
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Parent | Represents property Parent. (Inherited from TColumns.)
Spacing | Represents property Spacing. (Inherited from TColumns.)
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add. (Inherited from TColumns.)
Add(String) | Overloaded. Represents method Add(String). (Inherited from TColumns.)
AnyPercentWidth | Represents method AnyPercentWidth. (Inherited from TColumns.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TColumns.)
DoChanged(TObject) | Represents method DoChanged(TObject). (Overrides TCollectionChange.DoChanged(TObject).)
FindAt(Single,Single) | Represents method FindAt(Single,Single). (Inherited from TColumns.)
FindFirst(String) | Represents method FindFirst(String). (Inherited from TColumns.)
FirstVisible | Represents method FirstVisible. (Inherited from TColumns.)
GetEnumerator | Represents method GetEnumerator. (Inherited from TColumns.)
HasSpacing | Represents method HasSpacing. (Inherited from TColumns.)
LevelCount | Represents method LevelCount. (Inherited from TColumns.)
Moved(TColumn,Integer,Integer) | Represents method Moved(TColumn,Integer,Integer). (Inherited from TColumns.)
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Events
Show:
Name | Description
OnMoved | Represents property OnMoved. (Inherited from TColumns.)
Top
Fields
Show:
Name | Description
FLoadOrderItems | Represents field FLoadOrderItems. (Inherited from TColumns.)
IsDefault | Represents field IsDefault. (Inherited from TColumns.)
OnGetFields | Represents field OnGetFields. (Inherited from TColumns.)
OnSetField | Represents field OnSetField. (Inherited from TColumns.)
ValidWidth | Represents field ValidWidth. (Inherited from TColumns.)
Top
See Also

Reference

  • Tee.Grid


TCustomTeeGrid Class

Summary

Represents type TCustomTeeGrid.

Namespace: Tee.Grid
Inheritance Hierarchy
TComponent
Tee.Control.TCustomTeeControl
Tee.Grid.TCustomTeeGrid
Tee.Grid.Themes.TControlAccess
Syntax
Delphi
type
 TCustomTeeGrid=class(TCustomTeeControl)
 end;

The TCustomTeeGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TCustomTeeGrid class. (Overrides TCustomTeeControl.Create(TComponent).)
Destroy | Represents the destructor of the TCustomTeeGrid class. (Overrides TCustomTeeControl.Destroy.)
Top
Properties
Show:
Name | Description
Back | Represents property Back. (Inherited from TCustomTeeControl.)
Cells | Represents property Cells.
Columns | Represents property Columns.
Current | Represents property Current.
Data | Represents property Data.
DataSource | Represents property DataSource.
Editing | Represents property Editing.
Footer | Represents property Footer.
Header | Represents property Header.
Headers | Represents property Headers.
Indicator | Represents property Indicator.
Margins | Represents property Margins.
MouseActivity | Represents property MouseActivity.
OnAfterDraw | Represents property OnAfterDraw.
OnChange | Represents property OnChange. (Inherited from TCustomTeeControl.)
OnSelect | Represents property OnSelect.
ParentFont | Represents property ParentFont.
ReadOnly | Represents property ReadOnly.
Root | Represents property Root.
Rows | Represents property Rows.
Selected | Represents property Selected.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TCustomTeeControl.Assign(TPersistent).)
BeginUpdate | Represents method BeginUpdate. (Inherited from TCustomTeeControl.)
CancelEditor | Represents method CancelEditor.
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer).
ChangeEditing(TIndicatorState) | Represents method ChangeEditing(TIndicatorState).
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single).
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single).
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ClientHeight | Represents method ClientHeight. (Overrides TCustomTeeControl.ClientHeight.)
ClientWidth | Represents method ClientWidth. (Overrides TCustomTeeControl.ClientWidth.)
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
DataSourceChanged | Represents method DataSourceChanged.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCustomTeeControl.)
DoEditing(TObject,Boolean) | Represents method DoEditing(TObject,Boolean).
EndUpdate | Represents method EndUpdate. (Inherited from TCustomTeeControl.)
FinishPaint(Boolean) | Represents method FinishPaint(Boolean).
HasBandOfClass(TGridBandClass) | Represents method HasBandOfClass(TGridBandClass).
Height | Represents method Height. (Inherited from TCustomTeeControl.)
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Key(TKeyState) | Represents method Key(TKeyState).
Loaded | Represents method Loaded.
Mouse(TMouseState) | Represents method Mouse(TMouseState).
MouseLeave | Represents method MouseLeave.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Paint | Represents method Paint. (Overrides TCustomTeeControl.Paint.)
Painter | Represents method Painter. (Inherited from TCustomTeeControl.)
PasteSelected | Represents method PasteSelected.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
ReadFooter(TReader) | Represents method ReadFooter(TReader).
ReadHeaders(TReader) | Represents method ReadHeaders(TReader).
RefreshData | Represents method RefreshData.
ResetScrollBars | Represents method ResetScrollBars. (Inherited from TCustomTeeControl.)
StartEditor(String) | Overloaded. Represents method StartEditor(String).
StartEditor(TColumn,Integer,String) | Overloaded. Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
TryStartEditor(String) | Represents method TryStartEditor(String).
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
Width | Represents method Width. (Inherited from TCustomTeeControl.)
WidthForColumns(TRowGroup,Single) | Represents method WidthForColumns(TRowGroup,Single).
WriteFooter(TWriter) | Represents method WriteFooter(TWriter).
WriteHeaders(TWriter) | Represents method WriteHeaders(TWriter).
Top
Fields
Show:
Name | Description
ILoading | Represents field ILoading.
IUpdating | Represents field IUpdating. (Inherited from TCustomTeeControl.)
Top
See Also

Reference

  • Tee.Grid


TCustomTeeGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TCustomTeeGrid class. (Overrides TCustomTeeControl.Create(TComponent).)
Destroy | Represents the destructor of the TCustomTeeGrid class. (Overrides TCustomTeeControl.Destroy.)
Top


TCustomTeeGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TCustomTeeGrid class.

Namespace: Tee.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TCustomTeeControl.Create(TComponent)
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Destroy Destructor

Summary

Represents the destructor of the TCustomTeeGrid class.

Namespace: Tee.Grid
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TCustomTeeControl.Destroy
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid Properties

Properties
Name | Description
Cells | Represents property Cells.
Columns | Represents property Columns.
Current | Represents property Current.
Data | Represents property Data.
DataSource | Represents property DataSource.
Editing | Represents property Editing.
Footer | Represents property Footer.
Header | Represents property Header.
Headers | Represents property Headers.
Indicator | Represents property Indicator.
Margins | Represents property Margins.
MouseActivity | Represents property MouseActivity.
OnAfterDraw | Represents property OnAfterDraw.
OnSelect | Represents property OnSelect.
ParentFont | Represents property ParentFont.
ReadOnly | Represents property ReadOnly.
Root | Represents property Root.
Rows | Represents property Rows.
Selected | Represents property Selected.
Top


TCustomTeeGrid.Cells Property

Summary

Represents property Cells.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Cells:TTextRender read GetCells write SetCells;

Property Value

Type: TTextRender

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Columns Property

Summary

Represents property Columns.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Columns:TColumns read GetColumns write SetColumns stored IsColumnsStored;

Property Value

Type: TColumns

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Current Property

Summary

Represents property Current.

Namespace: Tee.Grid
Syntax
Delphi
public
 property Current:TRowGroup read GetCurrent write SetCurrent;

Property Value

Type: TRowGroup

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Data Property

Summary

Represents property Data.

Namespace: Tee.Grid
Syntax
Delphi
public
 property Data:TVirtualData read FData write SetData;

Property Value

Type: TVirtualData

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.DataSource Property

Summary

Represents property DataSource.

Namespace: Tee.Grid
Syntax
Delphi
published
 property DataSource:TComponent read FDataSource write SetDataSource;

Property Value

Type: TComponent

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Editing Property

Summary

Represents property Editing.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Editing:TGridEditing read FEditing write SetEditing;

Property Value

Type: TGridEditing

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Footer Property

Summary

Represents property Footer.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Footer:TGridFooter read GetFooter write SetFooter;

Property Value

Type: TGridFooter

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Header Property

Summary

Represents property Header.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Header:TColumnHeaderBand read GetHeader write SetHeader;

Property Value

Type: TColumnHeaderBand

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Headers Property

Summary

Represents property Headers.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Headers:TGridBands read GetHeaders write SetHeaders stored False;

Property Value

Type: TGridBands

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Indicator Property

Summary

Represents property Indicator.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Indicator:TIndicator read GetIndicator write SetIndicator;

Property Value

Type: TIndicator

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Margins Property

Summary

Represents property Margins.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Margins:TMargins read GetMargins write SetMargins;

Property Value

Type: TMargins

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.MouseActivity Property

Summary

Represents property MouseActivity.

Namespace: Tee.Grid
Syntax
Delphi
published
 property MouseActivity:TGridMouseSensitivity read GetMouseActive write SetMouseActive;

Property Value

Type: TGridMouseSensitivity

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.OnAfterDraw Property

Summary

Represents property OnAfterDraw.

Namespace: Tee.Grid
Syntax
Delphi
published
 property OnAfterDraw:TNotifyEvent read FOnAfterDraw write FOnAfterDraw;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.OnSelect Property

Summary

Represents property OnSelect.

Namespace: Tee.Grid
Syntax
Delphi
published
 property OnSelect:TNotifyEvent read FOnSelect write FOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ParentFont Property

Summary

Represents property ParentFont.

Namespace: Tee.Grid
Syntax
Delphi
public
 property ParentFont : Boolean read FParentFont write FParentFont default False;

Property Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: Tee.Grid
Syntax
Delphi
published
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Root Property

Summary

Represents property Root.

Namespace: Tee.Grid
Syntax
Delphi
public
 property Root:TRowGroup read FRoot;

Property Value

Type: TRowGroup

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Rows Property

Summary

Represents property Rows.

Namespace: Tee.Grid
Syntax
Delphi
public
 property Rows:TRows read GetRows write SetRows;

Property Value

Type: TRows

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Selected Property

Summary

Represents property Selected.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Selected:TGridSelection read GetSelected write SetSelected;

Property Value

Type: TGridSelection

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TCustomTeeControl.Assign(TPersistent).)
CancelEditor | Represents method CancelEditor.
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer).
ChangeEditing(TIndicatorState) | Represents method ChangeEditing(TIndicatorState).
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single).
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single).
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ClientHeight | Represents method ClientHeight. (Overrides TCustomTeeControl.ClientHeight.)
ClientWidth | Represents method ClientWidth. (Overrides TCustomTeeControl.ClientWidth.)
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
DataSourceChanged | Represents method DataSourceChanged.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoEditing(TObject,Boolean) | Represents method DoEditing(TObject,Boolean).
FinishPaint(Boolean) | Represents method FinishPaint(Boolean).
HasBandOfClass(TGridBandClass) | Represents method HasBandOfClass(TGridBandClass).
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Key(TKeyState) | Represents method Key(TKeyState).
Loaded | Represents method Loaded.
Mouse(TMouseState) | Represents method Mouse(TMouseState).
MouseLeave | Represents method MouseLeave.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Paint | Represents method Paint. (Overrides TCustomTeeControl.Paint.)
PasteSelected | Represents method PasteSelected.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
ReadFooter(TReader) | Represents method ReadFooter(TReader).
ReadHeaders(TReader) | Represents method ReadHeaders(TReader).
RefreshData | Represents method RefreshData.
StartEditor(String) | Overloaded. Represents method StartEditor(String).
StartEditor(TColumn,Integer,String) | Overloaded. Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
TryStartEditor(String) | Represents method TryStartEditor(String).
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
WidthForColumns(TRowGroup,Single) | Represents method WidthForColumns(TRowGroup,Single).
WriteFooter(TWriter) | Represents method WriteFooter(TWriter).
WriteHeaders(TWriter) | Represents method WriteHeaders(TWriter).
Top


TCustomTeeGrid.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TCustomTeeControl.Assign(TPersistent)
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.CancelEditor Method

Summary

Represents method CancelEditor.

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure CancelEditor; virtual;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.CanExpand(TRender,Integer) Method

Summary

Represents method CanExpand(TRender,Integer).

Namespace: Tee.Grid
Syntax
Delphi
public
 function CanExpand(const Sender:TRender; const ARow:Integer):Boolean;

Parameters

Sender
Type: TRender

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ChangeEditing(TIndicatorState) Method

Summary

Represents method ChangeEditing(TIndicatorState).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure ChangeEditing(const AState:TIndicatorState);

Parameters

AState
Type: TIndicatorState

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ChangeHorizScroll(Single) Method

Summary

Represents method ChangeHorizScroll(Single).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure ChangeHorizScroll(const Value:Single);

Parameters

Value
Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ChangeVertScroll(Single) Method

Summary

Represents method ChangeVertScroll(Single).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure ChangeVertScroll(const Value:Single);

Parameters

Value
Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.CheckScrollLimits(Single,Single) Method

Summary

Represents method CheckScrollLimits(Single,Single).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure CheckScrollLimits(var X,Y:Single); virtual; abstract;

Parameters

X
Type: Single

Y
Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ClientHeight Method

Summary

Represents method ClientHeight.

Namespace: Tee.Grid
Syntax
Delphi
public
 function ClientHeight:Single; override;

Return Value

Type: Single

Overrides

TCustomTeeControl.ClientHeight
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ClientWidth Method

Summary

Represents method ClientWidth.

Namespace: Tee.Grid
Syntax
Delphi
public
 function ClientWidth:Single; override;

Return Value

Type: Single

Overrides

TCustomTeeControl.ClientWidth
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ContainsFocus Method

Summary

Represents method ContainsFocus.

Namespace: Tee.Grid
Syntax
Delphi
protected
 Function ContainsFocus :Boolean; Virtual; Abstract;

Return Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Copy(TGridSelection) Method

Summary

Represents method Copy(TGridSelection).

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Copy(const ASelection:TGridSelection=nil); virtual; abstract;

Parameters

ASelection
Type: TGridSelection

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.DataChanged Method

Summary

Represents method DataChanged.

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure DataChanged; virtual;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.DataSourceChanged Method

Summary

Represents method DataSourceChanged.

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure DataSourceChanged;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.DoEditing(TObject,Boolean) Method

Summary

Represents method DoEditing(TObject,Boolean).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure DoEditing(const Sender:TObject; const IsEditing:Boolean);

Parameters

Sender
Type: TObject

IsEditing
Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.FinishPaint(Boolean) Method

Summary

Represents method FinishPaint(Boolean).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure FinishPaint(const IsDesign:Boolean);

Parameters

IsDesign
Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.HasBandOfClass(TGridBandClass) Method

Summary

Represents method HasBandOfClass(TGridBandClass).

Namespace: Tee.Grid
Syntax
Delphi
protected
 function HasBandOfClass(const AClass:TGridBandClass):Boolean;

Parameters

AClass
Type: TGridBandClass

Return Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.HorizScrollBarHeight Method

Summary

Represents method HorizScrollBarHeight.

Namespace: Tee.Grid
Syntax
Delphi
protected
 function HorizScrollBarHeight:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.HorizScrollChanged(TObject) Method

Summary

Represents method HorizScrollChanged(TObject).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure HorizScrollChanged(Sender:TObject); virtual; abstract;

Parameters

Sender
Type: TObject

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Key(TKeyState) Method

Summary

Represents method Key(TKeyState).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure Key(const AState:TKeyState);

Parameters

AState
Type: TKeyState

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Loaded Method

Summary

Represents method Loaded.

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Loaded; override;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Mouse(TMouseState) Method

Summary

Represents method Mouse(TMouseState).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure Mouse(var AState:TMouseState);

Parameters

AState
Type: TMouseState

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.MouseLeave Method

Summary

Represents method MouseLeave.

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure MouseLeave;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.Paint Method

Summary

Represents method Paint.

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Paint; override;

Overrides

TCustomTeeControl.Paint
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.PasteSelected Method

Summary

Represents method PasteSelected.

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure PasteSelected; virtual; abstract;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.PerfectScrollBar(Boolean) Method

Summary

Represents method PerfectScrollBar(Boolean).

Namespace: Tee.Grid
Syntax
Delphi
protected
 function PerfectScrollBar(const Vertical:Boolean):Boolean;

Parameters

Vertical
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ReadFooter(TReader) Method

Summary

Represents method ReadFooter(TReader).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure ReadFooter(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.ReadHeaders(TReader) Method

Summary

Represents method ReadHeaders(TReader).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure ReadHeaders(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.RefreshData Method

Summary

Represents method RefreshData.

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure RefreshData;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.StartEditor(String) Method

Summary

Represents method StartEditor(String).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure StartEditor(const AutoEdit:String=''); overload;

Parameters

AutoEdit
Type: String

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.StartEditor(TColumn,Integer,String) Method

Summary

Represents method StartEditor(TColumn,Integer,String).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure StartEditor(const AColumn:TColumn; const ARow:Integer;
 const AutoEdit:String=''); overload; virtual; abstract;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AutoEdit
Type: String

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.StopEditor Method

Summary

Represents method StopEditor.

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure StopEditor; virtual;
See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.TryStartEditor(String) Method

Summary

Represents method TryStartEditor(String).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure TryStartEditor(const AutoEdit:String='');

Parameters

AutoEdit
Type: String

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.VertScrollBarWidth Method

Summary

Represents method VertScrollBarWidth.

Namespace: Tee.Grid
Syntax
Delphi
protected
 function VertScrollBarWidth:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.VertScrollChanged(TObject) Method

Summary

Represents method VertScrollChanged(TObject).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure VertScrollChanged(Sender:TObject); virtual; abstract;

Parameters

Sender
Type: TObject

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.WidthForColumns(TRowGroup,Single) Method

Summary

Represents method WidthForColumns(TRowGroup,Single).

Namespace: Tee.Grid
Syntax
Delphi
protected
 function WidthForColumns(const AGroup:TRowGroup; const AWidth:Single):Single;

Parameters

AGroup
Type: TRowGroup

AWidth
Type: Single

Return Value

Type: Single

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.WriteFooter(TWriter) Method

Summary

Represents method WriteFooter(TWriter).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure WriteFooter(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid.WriteHeaders(TWriter) Method

Summary

Represents method WriteHeaders(TWriter).

Namespace: Tee.Grid
Syntax
Delphi
protected
 procedure WriteHeaders(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGrid Fields

Fields
Name | Description
ILoading | Represents field ILoading.
Top


TCustomTeeGrid.ILoading Field

Summary

Represents field ILoading.

Namespace: Tee.Grid
Syntax
Delphi
protected
 ILoading : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TCustomTeeGrid
  • Tee.Grid


TCustomTeeGridEditor Class

Summary

Represents type TCustomTeeGridEditor.

Namespace: Tee.Grid
Inheritance Hierarchy
TObject
Tee.Grid.TCustomTeeGridEditor
Syntax
Delphi
type
 TCustomTeeGridEditor=class
 end;

The TCustomTeeGridEditor type exposes the following members.

Fields
Show:
Name | Description
OnEdit | Represents field OnEdit.
Top
See Also

Reference

  • Tee.Grid


TCustomTeeGridEditor Fields

Fields
Name | Description
OnEdit | Represents field OnEdit.
Top


TCustomTeeGridEditor.OnEdit Field

Summary

Represents field OnEdit.

Namespace: Tee.Grid
Syntax
Delphi
public
 class var
 OnEdit : TEditGrid;

Field Value

Type: TEditGrid

See Also

Reference

  • TCustomTeeGridEditor
  • Tee.Grid


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TVirtualData);

The TDataAccess type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Inherited from TVirtualData.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Inherited from TVirtualData.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.Grid


TGridEditing Class

Summary

Represents type TGridEditing.

Namespace: Tee.Grid
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.TGridEditing
Syntax
Delphi
type
 TGridEditing=class(TPersistentChange)
 end;

The TGridEditing type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridEditing class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGridEditing class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
AlwaysVisible | Represents property AlwaysVisible.
AutoEdit | Represents property AutoEdit.
DoubleClick | Represents property DoubleClick.
EditorClass | Represents property EditorClass.
EnterKey | Represents property EnterKey.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
ClassOf(TColumn) | Represents method ClassOf(TColumn).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid


TGridEditing Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridEditing class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGridEditing class.
Top


TGridEditing.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TGridEditing class.

Namespace: Tee.Grid
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.Destroy Destructor

Summary

Represents the destructor of the TGridEditing class.

Namespace: Tee.Grid
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing Properties

Properties
Name | Description
Active | Represents property Active.
AlwaysVisible | Represents property AlwaysVisible.
AutoEdit | Represents property AutoEdit.
DoubleClick | Represents property DoubleClick.
EditorClass | Represents property EditorClass.
EnterKey | Represents property EnterKey.
Text | Represents property Text.
Top


TGridEditing.Active Property

Summary

Represents property Active.

Namespace: Tee.Grid
Syntax
Delphi
public
 property Active:Boolean read FActive write FActive default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.AlwaysVisible Property

Summary

Represents property AlwaysVisible.

Namespace: Tee.Grid
Syntax
Delphi
published
 property AlwaysVisible:Boolean read FAlwaysVisible write FAlwaysVisible default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.AutoEdit Property

Summary

Represents property AutoEdit.

Namespace: Tee.Grid
Syntax
Delphi
published
 property AutoEdit:Boolean read FAutoEdit write FAutoEdit default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.DoubleClick Property

Summary

Represents property DoubleClick.

Namespace: Tee.Grid
Syntax
Delphi
published
 property DoubleClick:Boolean read FDoubleClick write FDoubleClick default True;

Property Value

Type: Boolean

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.EditorClass Property

Summary

Represents property EditorClass.

Namespace: Tee.Grid
Syntax
Delphi
public
 property EditorClass:TClass read FClass write FClass;

Property Value

Type: TClass

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.EnterKey Property

Summary

Represents property EnterKey.

Namespace: Tee.Grid
Syntax
Delphi
published
 property EnterKey:TEditingEnter read FEnterKey write FEnterKey default TEditingEnter.NextCell;

Property Value

Type: TEditingEnter

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.Text Property

Summary

Represents property Text.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Text:TTextEditing read FText write SetText;

Property Value

Type: TTextEditing

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ClassOf(TColumn) | Represents method ClassOf(TColumn).
Top


TGridEditing.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGridEditing
  • Tee.Grid


TGridEditing.ClassOf(TColumn) Method

Summary

Represents method ClassOf(TColumn).

Namespace: Tee.Grid
Syntax
Delphi
public
 function ClassOf(const AColumn:TColumn):TClass;

Parameters

AColumn
Type: TColumn

Return Value

Type: TClass

See Also

Reference

  • TGridEditing
  • Tee.Grid


TIndicatorAccess Class

Summary

Represents type TIndicatorAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Columns.TIndicator
Tee.Grid.TIndicatorAccess
Syntax
Delphi
type
 TIndicatorAccess=class(TIndicator);

The TIndicatorAccess type exposes the following members.

Constants
Show:
Name | Description
DefaultWidth | Represents constant DefaultWidth. (Inherited from TIndicator.)
Top
Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TIndicator class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Width | Represents property Width. (Inherited from TIndicator.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
State | Represents field State. (Inherited from TIndicator.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid


TReaderAccess Class

Summary

Represents type TReaderAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TReader
Tee.Grid.TReaderAccess
Syntax
Delphi
type
 TReaderAccess=class(TReader);
See Also

Reference

  • Tee.Grid


TRowGroupAccess Class

Summary

Represents type TRowGroupAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.RowGroup.TRowGroup
Tee.Grid.TRowGroupAccess
Syntax
Delphi
type
 TRowGroupAccess=class(TRowGroup);

The TRowGroupAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection,TVirtualData) | Initializes a new instance of the TRowGroup class. (Inherited from TRowGroup.)
Top
Properties
Show:
Name | Description
Cells | Represents property Cells. (Inherited from TRowGroup.)
Columns | Represents property Columns. (Inherited from TRowGroup.)
Current | Represents property Current. (Inherited from TRowGroup.)
Data | Represents property Data. (Inherited from TRowGroup.)
Footer | Represents property Footer. (Inherited from TRowGroup.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header. (Inherited from TRowGroup.)
Headers | Represents property Headers. (Inherited from TRowGroup.)
Height | Represents property Height. (Inherited from TGridBand.)
Indicator | Represents property Indicator. (Inherited from TRowGroup.)
Margins | Represents property Margins. (Inherited from TRowGroup.)
OnChangedSelected | Represents property OnChangedSelected. (Inherited from TRowGroup.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
ReadOnly | Represents property ReadOnly. (Inherited from TRowGroup.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Rows | Represents property Rows. (Inherited from TRowGroup.)
Scrolling | Represents property Scrolling. (Inherited from TRowGroup.)
Selected | Represents property Selected. (Inherited from TRowGroup.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoScroll | Represents method AutoScroll. (Inherited from TRowGroup.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
CalculateHeight(TRenderData) | Represents method CalculateHeight(TRenderData). (Inherited from TRowGroup.)
CanEditRender(TColumn) | Represents method CanEditRender(TColumn). (Inherited from TRowGroup.)
CanStartEditor | Represents method CanStartEditor. (Inherited from TRowGroup.)
CellRect(TColumn,Integer) | Overloaded. Represents method CellRect(TColumn,Integer). (Inherited from TRowGroup.)
CellRect(TGridSelection) | Overloaded. Represents method CellRect(TGridSelection). (Inherited from TRowGroup.)
CellRect(TPointF,TColumn,Integer) | Overloaded. Represents method CellRect(TPointF,TColumn,Integer). (Inherited from TRowGroup.)
CellRect(TSelectionRange) | Overloaded. Represents method CellRect(TSelectionRange). (Inherited from TRowGroup.)
CheckColumnsWidth(TPainter,Boolean,Single) | Represents method CheckColumnsWidth(TPainter,Boolean,Single). (Inherited from TRowGroup.)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
Key(TKeyState) | Represents method Key(TKeyState). (Inherited from TRowGroup.)
Loaded | Represents method Loaded. (Inherited from TRowGroup.)
MaxBottom | Represents method MaxBottom. (Inherited from TRowGroup.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
NewExpander | Represents method NewExpander. (Inherited from TRowGroup.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PrepareColumns(TPainter,Single,Single) | Represents method PrepareColumns(TPainter,Single,Single). (Inherited from TRowGroup.)
RefreshData(TVirtualData) | Represents method RefreshData(TVirtualData). (Inherited from TRowGroup.)
RenderHit(TColumn,Integer,Single,Single) | Represents method RenderHit(TColumn,Integer,Single,Single). (Inherited from TRowGroup.)
Scroll(Single,Single) | Represents method Scroll(Single,Single). (Inherited from TRowGroup.)
SelectedContains(Single,Single) | Overloaded. Represents method SelectedContains(Single,Single). (Inherited from TRowGroup.)
SelectedContains(TPoint) | Overloaded. Represents method SelectedContains(TPoint). (Inherited from TRowGroup.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToggleDetail(TRender,Integer) | Represents method ToggleDetail(TRender,Integer). (Inherited from TRowGroup.)
TryPaste(String) | Represents method TryPaste(String). (Inherited from TRowGroup.)
TrySelectColumn | Represents method TrySelectColumn. (Inherited from TRowGroup.)
Top
Events
Show:
Name | Description
OnNewDetail | Represents property OnNewDetail. (Inherited from TRowGroup.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
CheckLimits | Represents field CheckLimits. (Inherited from TRowGroup.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IsFocused | Represents field IsFocused. (Inherited from TRowGroup.)
MinColumnWidth | Represents field MinColumnWidth. (Inherited from TRowGroup.)
OwnsData | Represents field OwnsData. (Inherited from TRowGroup.)
ParentColumn | Represents field ParentColumn. (Inherited from TRowGroup.)
RecalcScrollBars | Represents field RecalcScrollBars. (Inherited from TRowGroup.)
Top | Represents field Top. (Inherited from TGridBand.)
Top
See Also

Reference

  • Tee.Grid


TRowsAccess Class

Summary

Represents type TRowsAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Rows.TRows
Tee.Grid.TRowsAccess
Syntax
Delphi
type
 TRowsAccess=class(TRows);

The TRowsAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TRows class. (Overrides TGridBandLines.Create(TCollection).)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate. (Inherited from TRows.)
Back | Represents property Back. (Inherited from TRows.)
Children | Represents property Children. (Inherited from TRows.)
Data | Represents property Data. (Inherited from TRows.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TRows.)
Heights[Integer] | Represents property Heights[Integer]. (Inherited from TRows.)
Hover | Represents property Hover. (Inherited from TRows.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
RowLines | Represents property RowLines. (Inherited from TRows.)
Spacing | Represents property Spacing. (Inherited from TRows.)
SubBands | Represents property SubBands. (Inherited from TRows.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
VisibleColumns | Represents property VisibleColumns. (Inherited from TRows.)
YSpacing | Represents property YSpacing. (Inherited from TRows.)
Top
Methods
Show:
Name | Description
AllHeightsEqual | Represents method AllHeightsEqual. (Inherited from TRows.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoHeight(Integer) | Overloaded. Represents method AutoHeight(Integer). (Inherited from TRows.)
BottomOf(Integer) | Represents method BottomOf(Integer). (Inherited from TRows.)
CalcDefaultHeight | Represents method CalcDefaultHeight. (Inherited from TRows.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBand.)
CalcYSpacing(Single) | Represents method CalcYSpacing(Single). (Inherited from TRows.)
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single). (Inherited from TRows.)
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single). (Inherited from TRows.)
Clear | Represents method Clear. (Inherited from TRows.)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
Empty | Represents method Empty. (Inherited from TRows.)
FirstVisible(Single) | Represents method FirstVisible(Single). (Inherited from TRows.)
FontOf(TColumn) | Represents method FontOf(TColumn). (Inherited from TRows.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeightOf(Integer) | Represents method HeightOf(Integer). (Inherited from TRows.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
IsChildrenVisible(TRender,Integer) | Represents method IsChildrenVisible(TRender,Integer). (Inherited from TRows.)
MaxBottom | Represents method MaxBottom. (Inherited from TRows.)
MaxRight | Represents method MaxRight. (Inherited from TRows.)
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBand.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PaintLines(TRenderData,Integer,Single) | Represents method PaintLines(TRenderData,Integer,Single). (Inherited from TRows.)
PaintRow(TRenderData,TRender) | Represents method PaintRow(TRenderData,TRender). (Inherited from TRows.)
RowAt(Single,Single) | Represents method RowAt(Single,Single). (Inherited from TRows.)
SetColumnsLeft(Single,Single,Single) | Represents method SetColumnsLeft(Single,Single,Single). (Inherited from TRows.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Swap(Integer,Integer) | Represents method Swap(Integer,Integer). (Inherited from TRows.)
TopOf(Integer) | Represents method TopOf(Integer). (Inherited from TRows.)
TopOfRow(Integer) | Represents method TopOfRow(Integer). (Inherited from TRows.)
TotalHeight(Integer) | Represents method TotalHeight(Integer). (Inherited from TRows.)
UpToRowHeight(Integer) | Represents method UpToRowHeight(Integer). (Inherited from TRows.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FOnHorizScroll | Represents field FOnHorizScroll. (Inherited from TRows.)
FOnVertScroll | Represents field FOnVertScroll. (Inherited from TRows.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
Painter | Represents field Painter. (Inherited from TRows.)
Scroll | Represents field Scroll. (Inherited from TRows.)
Top | Represents field Top. (Inherited from TGridBand.)
XOffset | Represents field XOffset. (Inherited from TRows.)
Top
See Also

Reference

  • Tee.Grid


TTextEditing Class

Summary

Represents type TTextEditing.

Namespace: Tee.Grid
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.TTextEditing
Syntax
Delphi
type
 TTextEditing=class(TPersistentChange)
 end;

The TTextEditing type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextEditing class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Selected | Represents property Selected.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid


TTextEditing Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextEditing class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TTextEditing.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TTextEditing class.

Namespace: Tee.Grid
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TTextEditing
  • Tee.Grid


TTextEditing Properties

Properties
Name | Description
Selected | Represents property Selected.
Top


TTextEditing.Selected Property

Summary

Represents property Selected.

Namespace: Tee.Grid
Syntax
Delphi
published
 property Selected:Boolean read FSelected write SetSelected default True;

Property Value

Type: Boolean

See Also

Reference

  • TTextEditing
  • Tee.Grid


TTextEditing Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TTextEditing.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TTextEditing
  • Tee.Grid


TVirtualDataAccess Class

Summary

Represents type TVirtualDataAccess.

Namespace: Tee.Grid
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.TVirtualDataAccess
Syntax
Delphi
type
 TVirtualDataAccess=class(TVirtualData);

The TVirtualDataAccess type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Inherited from TVirtualData.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Inherited from TVirtualData.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.Grid


Tee.Grid Records

Records
Name | Description
TPersistCollection | Represents type TPersistCollection.
Top


TPersistCollection Record

Summary

Represents type TPersistCollection.

Namespace: Tee.Grid
Syntax
Delphi
type
 TPersistCollection=record
 end;

The TPersistCollection type exposes the following members.

Methods
Show:
Name | Description
Read(TCollection,TReader) | Represents method Read(TCollection,TReader).
Write(TCollection,TWriter) | Represents method Write(TCollection,TWriter).
Top
See Also

Reference

  • Tee.Grid


TPersistCollection Methods

Methods
Name | Description
Read(TCollection,TReader) | Represents method Read(TCollection,TReader).
Write(TCollection,TWriter) | Represents method Write(TCollection,TWriter).
Top


TPersistCollection.Read(TCollection,TReader) Method

Summary

Represents method Read(TCollection,TReader).

Namespace: Tee.Grid
Syntax
Delphi
public
 class procedure Read(const ACollection:TCollection; const AReader:TReader); static;

Parameters

ACollection
Type: TCollection

AReader
Type: TReader

See Also

Reference

  • TPersistCollection
  • Tee.Grid


TPersistCollection.Write(TCollection,TWriter) Method

Summary

Represents method Write(TCollection,TWriter).

Namespace: Tee.Grid
Syntax
Delphi
public
 class procedure Write(const ACollection:TCollection; const AWriter:TWriter); static;

Parameters

ACollection
Type: TCollection

AWriter
Type: TWriter

See Also

Reference

  • TPersistCollection
  • Tee.Grid


Tee.Grid Enumerations

Enumerations
Name | Description
TEditingEnter | Represents type TEditingEnter.
Top


TEditingEnter Enumeration

Summary

Represents type TEditingEnter.

Namespace: Tee.Grid
Syntax
Delphi
type
 TEditingEnter=(NextCell,NextRow,SameCell);

The TEditingEnter type exposes the following members.

Members
Show:
Name | Description
NextCell | Represents constant NextCell.
NextRow | Represents constant NextRow.
SameCell | Represents constant SameCell.
Top
See Also

Reference

  • Tee.Grid


Tee.Grid Delegates

Delegates
Name | Description
TCustomTeeGridEditor.TEditGrid | Represents type TEditGrid.
Top


TCustomTeeGridEditor.TEditGrid Delegate

Summary

Represents type TEditGrid.

Namespace: Tee.Grid
Syntax
Delphi
public
type
 TEditGrid=procedure(const Sender:TCustomTeeGrid);
See Also

Reference

  • TCustomTeeGridEditor
  • Tee.Grid


Tee.Grid Types

Types
Name | Description
TScroll | Represents an alias of the TPointF type.
Top


TScroll Type

Summary

Represents an alias of the TPointF type.

Namespace: Tee.Grid
Syntax
Delphi
type
 TScroll=TPointF;
See Also

Reference

  • Tee.Grid


Tee.Grid.Bands Namespace

Summary

Represents namespace Tee.Grid.Bands.

Classes
Name | Description
TBandHeight | Represents type TBandHeight.
TGridBand | Represents type TGridBand.
TGridBandLines | Represents type TGridBandLines.
TGridBands | Represents type TGridBands.
TTextBand | Represents type TTextBand.
Top
Records
Name | Description
TKeyState | Represents type TKeyState.
TMouseState | Represents type TMouseState.
Top
Enumerations
Name | Description
TGridKeyEvent | Represents type TGridKeyEvent.
TGridMouseButton | Represents type TGridMouseButton.
TGridMouseEvent | Represents type TGridMouseEvent.
TGridMouseSense | Represents type TGridMouseSense.
TMouseCursor | Represents type TMouseCursor.
Top
Types
Name | Description
TGridBandClass | Represents type TGridBandClass.
TGridMouseSensitivity | Represents type TGridMouseSensitivity.
Top


Tee.Grid.Bands Classes

Classes
Name | Description
TBandHeight | Represents type TBandHeight.
TGridBand | Represents type TGridBand.
TGridBandLines | Represents type TGridBandLines.
TGridBands | Represents type TGridBands.
TTextBand | Represents type TTextBand.
Top


TBandHeight Class

Summary

Represents type TBandHeight.

Namespace: Tee.Grid.Bands
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Bands.TBandHeight
Tee.Grid.Bands.Columns.TBandHeightAccess
Tee.Grid.RowGroup.TBandHeightAccess
Syntax
Delphi
type
 TBandHeight=class(TCoordinate);

The TBandHeight type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.Bands


TGridBand Class

Summary

Represents type TGridBand.

Namespace: Tee.Grid.Bands
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.TTextBand
Tee.Grid.RowGroup.TRowGroup
Syntax
Delphi
type
 TGridBand=class(TVisibleRenderItem)
 end;

The TGridBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TGridBand class. (Overrides TVisibleRenderItem.Create(TCollection).)
Destroy | Represents the destructor of the TGridBand class. (Overrides TVisibleRenderItem.Destroy.)
Top
Properties
Show:
Name | Description
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height.
OnClick | Represents property OnClick.
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single).
Contains(Single,Single) | Represents method Contains(Single,Single).
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description.
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single).
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom.
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
Top | Represents field Top.
Top
See Also

Reference

  • Tee.Grid.Bands


TGridBand Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TGridBand class. (Overrides TVisibleRenderItem.Create(TCollection).)
Destroy | Represents the destructor of the TGridBand class. (Overrides TVisibleRenderItem.Destroy.)
Top


TGridBand.Create(TCollection) Constructor

Summary

Initializes a new instance of the TGridBand class.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TVisibleRenderItem.Create(TCollection)
See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Destroy Destructor

Summary

Represents the destructor of the TGridBand class.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TVisibleRenderItem.Destroy
See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand Properties

Properties
Name | Description
Height | Represents property Height.
OnClick | Represents property OnClick.
Top


TGridBand.Height Property

Summary

Represents property Height.

Namespace: Tee.Grid.Bands
Syntax
Delphi
published
 property Height:TBandHeight read FHeight write SetHeight;

Property Value

Type: TBandHeight

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.OnClick Property

Summary

Represents property OnClick.

Namespace: Tee.Grid.Bands
Syntax
Delphi
published
 property OnClick:TNotifyEvent read FOnClick write FOnClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single).
Contains(Single,Single) | Represents method Contains(Single,Single).
Description | Represents method Description.
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single).
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
Top


TGridBand.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisibleRenderItem.Assign(TPersistent)
See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.CalcHeight(TPainter,Single) Method

Summary

Represents method CalcHeight(TPainter,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure CalcHeight(const APainter:TPainter; const ATotal:Single); virtual;

Parameters

APainter
Type: TPainter

ATotal
Type: Single

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Contains(Single,Single) Method

Summary

Represents method Contains(Single,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 function Contains(const X,Y:Single):Boolean;

Parameters

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 class function Description:String; virtual;

Return Value

Type: String

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Mouse(TMouseState,Single,Single) Method

Summary

Represents method Mouse(TMouseState,Single,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 function Mouse(var AState:TMouseState; const AWidth,AHeight:Single): Boolean; overload; virtual;

Parameters

AState
Type: TMouseState

AWidth
Type: Single

AHeight
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TVisibleRenderItem.Paint(TRenderData,TRender)
See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand Fields

Fields
Name | Description
Bottom | Represents field Bottom.
Top | Represents field Top.
Top


TGridBand.Bottom Field

Summary

Represents field Bottom.

Namespace: Tee.Grid.Bands
Syntax
Delphi
protected
 Top,
 Bottom : Single;

Field Value

Type: Single

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBand.Top Field

Summary

Represents field Top.

Namespace: Tee.Grid.Bands
Syntax
Delphi
protected
 Top,
 Bottom : Single;

Field Value

Type: Single

See Also

Reference

  • TGridBand
  • Tee.Grid.Bands


TGridBandLines Class

Summary

Represents type TGridBandLines.

Namespace: Tee.Grid.Bands
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Rows.TRows
Syntax
Delphi
type
 TGridBandLines=class(TGridBand)
 end;

The TGridBandLines type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TGridBandLines class. (Overrides TGridBand.Create(TCollection).)
Destroy | Represents the destructor of the TGridBandLines class. (Overrides TGridBand.Destroy.)
Top
Properties
Show:
Name | Description
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
Lines | Represents property Lines.
OnClick | Represents property OnClick. (Inherited from TGridBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBand.)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBand.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IJustRepaint | Represents field IJustRepaint.
Top | Represents field Top. (Inherited from TGridBand.)
Top
See Also

Reference

  • Tee.Grid.Bands


TGridBandLines Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TGridBandLines class. (Overrides TGridBand.Create(TCollection).)
Destroy | Represents the destructor of the TGridBandLines class. (Overrides TGridBand.Destroy.)
Top


TGridBandLines.Create(TCollection) Constructor

Summary

Initializes a new instance of the TGridBandLines class.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TGridBand.Create(TCollection)
See Also

Reference

  • TGridBandLines
  • Tee.Grid.Bands


TGridBandLines.Destroy Destructor

Summary

Represents the destructor of the TGridBandLines class.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGridBand.Destroy
See Also

Reference

  • TGridBandLines
  • Tee.Grid.Bands


TGridBandLines Properties

Properties
Name | Description
Lines | Represents property Lines.
Top


TGridBandLines.Lines Property

Summary

Represents property Lines.

Namespace: Tee.Grid.Bands
Syntax
Delphi
published
 property Lines:TStroke read FLines write SetLines;

Property Value

Type: TStroke

See Also

Reference

  • TGridBandLines
  • Tee.Grid.Bands


TGridBandLines Fields

Fields
Name | Description
IJustRepaint | Represents field IJustRepaint.
Top


TGridBandLines.IJustRepaint Field

Summary

Represents field IJustRepaint.

Namespace: Tee.Grid.Bands
Syntax
Delphi
protected
 IJustRepaint : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGridBandLines
  • Tee.Grid.Bands


TGridBands Class

Summary

Represents type TGridBands.

Namespace: Tee.Grid.Bands
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Bands.TGridBands
Tee.Grid.RowGroup.TGridFooter
Tee.Grid.Rows.TRowsBands
Syntax
Delphi
type
 TGridBands=class(TCollectionChange)
 end;

The TGridBands type exposes the following members.

Constants
Show:
Name | Description
Spacing | Represents constant Spacing.
Top
Constructors
Show:
Name | Description
Create(TPersistent,TNotifyEvent) | Initializes a new instance of the TGridBands class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
AddText(String) | Represents method AddText(String).
Assign(TPersistent) | Represents method Assign(TPersistent).
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single).
CanDisplay | Represents method CanDisplay.
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCollectionChange.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Inherited from TCollectionChange.)
Paint(TRenderData) | Represents method Paint(TRenderData).
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Fields
Show:
Name | Description
Height | Represents field Height.
Top
See Also

Reference

  • Tee.Grid.Bands


TGridBands Constants

Constants
Name | Description
Spacing | Represents constant Spacing.
Top


TGridBands.Spacing Constant

Summary

Represents constant Spacing.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Spacing=0;

Value

Type: ShortInt

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands Constructors

Constructors
Name | Description
Create(TPersistent,TNotifyEvent) | Initializes a new instance of the TGridBands class.
Top


TGridBands.Create(TPersistent,TNotifyEvent) Constructor

Summary

Initializes a new instance of the TGridBands class.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent; const AChanged:TNotifyEvent); reintroduce;

Parameters

AOwner
Type: TPersistent

AChanged
Type: TNotifyEvent

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Visible | Represents property Visible.
Top


TGridBands.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 property Items[Index: Integer]: TGridBand read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TGridBand

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Grid.Bands
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands Methods

Methods
Name | Description
AddText(String) | Represents method AddText(String).
Assign(TPersistent) | Represents method Assign(TPersistent).
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single).
CanDisplay | Represents method CanDisplay.
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single).
Paint(TRenderData) | Represents method Paint(TRenderData).
Top


TGridBands.AddText(String) Method

Summary

Represents method AddText(String).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 function AddText(const AText:String):TTextBand;

Parameters

AText
Type: String

Return Value

Type: TTextBand

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.CalcHeight(TPainter,Single) Method

Summary

Represents method CalcHeight(TPainter,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure CalcHeight(const APainter:TPainter; const ATotal:Single);

Parameters

APainter
Type: TPainter

ATotal
Type: Single

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.CanDisplay Method

Summary

Represents method CanDisplay.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 function CanDisplay:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.Mouse(TMouseState,Single,Single) Method

Summary

Represents method Mouse(TMouseState,Single,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Mouse(var AState:TMouseState; const AWidth,AHeight:Single);

Parameters

AState
Type: TMouseState

AWidth
Type: Single

AHeight
Type: Single

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData);

Parameters

AData
Type: TRenderData

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TGridBands Fields

Fields
Name | Description
Height | Represents field Height.
Top


TGridBands.Height Field

Summary

Represents field Height.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Height : Single;

Field Value

Type: Single

See Also

Reference

  • TGridBands
  • Tee.Grid.Bands


TTextBand Class

Summary

Represents type TTextBand.

Namespace: Tee.Grid.Bands
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TTextBand
Syntax
Delphi
type
 TTextBand=class(TGridBand)
 end;

The TTextBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TGridBand class. (Overrides TVisibleRenderItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Text | Represents property Text.
TextRender | Represents property TextRender.
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Overrides TVisibleRenderItem.CreateRender.)
Description | Represents method Description. (Overrides TGridBand.Description.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBand.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
Top | Represents field Top. (Inherited from TGridBand.)
Top
See Also

Reference

  • Tee.Grid.Bands


TTextBand Properties

Properties
Name | Description
Text | Represents property Text.
TextRender | Represents property TextRender.
Top


TTextBand.Text Property

Summary

Represents property Text.

Namespace: Tee.Grid.Bands
Syntax
Delphi
published
 property Text:String read GetText write SetText;

Property Value

Type: String

See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


TTextBand.TextRender Property

Summary

Represents property TextRender.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 property TextRender:TCellRender read GetTextRender;

Property Value

Type: TCellRender

See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


TTextBand Methods

Methods
Name | Description
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
CreateRender | Represents method CreateRender. (Overrides TVisibleRenderItem.CreateRender.)
Description | Represents method Description. (Overrides TGridBand.Description.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
Top


TTextBand.CalcHeight(TPainter,Single) Method

Summary

Represents method CalcHeight(TPainter,Single).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure CalcHeight(const APainter:TPainter; const ATotal:Single); override;

Parameters

APainter
Type: TPainter

ATotal
Type: Single

Overrides

TGridBand.CalcHeight(TPainter,Single)
See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


TTextBand.CreateRender Method

Summary

Represents method CreateRender.

Namespace: Tee.Grid.Bands
Syntax
Delphi
protected
 function CreateRender:TRender; override;

Return Value

Type: TRender

Overrides

TVisibleRenderItem.CreateRender
See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


TTextBand.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 class function Description:String; override;

Return Value

Type: String

Overrides

TGridBand.Description
See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


TTextBand.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TGridBand.Paint(TRenderData,TRender)
See Also

Reference

  • TTextBand
  • Tee.Grid.Bands


Tee.Grid.Bands Records

Records
Name | Description
TKeyState | Represents type TKeyState.
TMouseState | Represents type TMouseState.
Top


TKeyState Record

Summary

Represents type TKeyState.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TKeyState=record
 end;

The TKeyState type exposes the following members.

Fields
Show:
Name | Description
Event | Represents field Event.
Key | Represents field Key.
KeyChar | Represents field KeyChar.
Shift | Represents field Shift.
Top
See Also

Reference

  • Tee.Grid.Bands


TKeyState Fields

Fields
Name | Description
Event | Represents field Event.
Key | Represents field Key.
KeyChar | Represents field KeyChar.
Shift | Represents field Shift.
Top


TKeyState.Event Field

Summary

Represents field Event.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Event : TGridKeyEvent;

Field Value

Type: TGridKeyEvent

See Also

Reference

  • TKeyState
  • Tee.Grid.Bands


TKeyState.Key Field

Summary

Represents field Key.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Key : Word;

Field Value

Type: Word

See Also

Reference

  • TKeyState
  • Tee.Grid.Bands


TKeyState.KeyChar Field

Summary

Represents field KeyChar.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 KeyChar : Char;

Field Value

Type: Char

See Also

Reference

  • TKeyState
  • Tee.Grid.Bands


TKeyState.Shift Field

Summary

Represents field Shift.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Shift : TShiftState;

Field Value

Type: TShiftState

See Also

Reference

  • TKeyState
  • Tee.Grid.Bands


TMouseState Record

Summary

Represents type TMouseState.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TMouseState=record
 end;

The TMouseState type exposes the following members.

Methods
Show:
Name | Description
IsDoubleLeft | Represents method IsDoubleLeft.
Top
Fields
Show:
Name | Description
Button | Represents field Button.
Cursor | Represents field Cursor.
Event | Represents field Event.
Shift | Represents field Shift.
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • Tee.Grid.Bands


TMouseState Methods

Methods
Name | Description
IsDoubleLeft | Represents method IsDoubleLeft.
Top


TMouseState.IsDoubleLeft Method

Summary

Represents method IsDoubleLeft.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 function IsDoubleLeft:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState Fields

Fields
Name | Description
Button | Represents field Button.
Cursor | Represents field Cursor.
Event | Represents field Event.
Shift | Represents field Shift.
X | Represents field X.
Y | Represents field Y.
Top


TMouseState.Button Field

Summary

Represents field Button.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Button : TGridMouseButton;

Field Value

Type: TGridMouseButton

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState.Cursor Field

Summary

Represents field Cursor.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Cursor : TMouseCursor;

Field Value

Type: TMouseCursor

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState.Event Field

Summary

Represents field Event.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Event : TGridMouseEvent;

Field Value

Type: TGridMouseEvent

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState.Shift Field

Summary

Represents field Shift.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 Shift : TShiftState;

Field Value

Type: TShiftState

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState.X Field

Summary

Represents field X.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 X,Y : Single;

Field Value

Type: Single

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


TMouseState.Y Field

Summary

Represents field Y.

Namespace: Tee.Grid.Bands
Syntax
Delphi
public
 X,Y : Single;

Field Value

Type: Single

See Also

Reference

  • TMouseState
  • Tee.Grid.Bands


Tee.Grid.Bands Enumerations

Enumerations
Name | Description
TGridKeyEvent | Represents type TGridKeyEvent.
TGridMouseButton | Represents type TGridMouseButton.
TGridMouseEvent | Represents type TGridMouseEvent.
TGridMouseSense | Represents type TGridMouseSense.
TMouseCursor | Represents type TMouseCursor.
Top


TGridKeyEvent Enumeration

Summary

Represents type TGridKeyEvent.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridKeyEvent=(Down,Up);

The TGridKeyEvent type exposes the following members.

Members
Show:
Name | Description
Down | Represents constant Down.
Up | Represents constant Up.
Top
See Also

Reference

  • Tee.Grid.Bands


TGridMouseButton Enumeration

Summary

Represents type TGridMouseButton.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridMouseButton=(Left,Middle,Right);

The TGridMouseButton type exposes the following members.

Members
Show:
Name | Description
Left | Represents constant Left.
Middle | Represents constant Middle.
Right | Represents constant Right.
Top
See Also

Reference

  • Tee.Grid.Bands


TGridMouseEvent Enumeration

Summary

Represents type TGridMouseEvent.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridMouseEvent=(Down,Move,Up,DoubleClick);

The TGridMouseEvent type exposes the following members.

Members
Show:
Name | Description
DoubleClick | Represents constant DoubleClick.
Down | Represents constant Down.
Move | Represents constant Move.
Up | Represents constant Up.
Top
See Also

Reference

  • Tee.Grid.Bands


TGridMouseSense Enumeration

Summary

Represents type TGridMouseSense.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridMouseSense=(Down,Move,Up,DoubleClick,All,None);

The TGridMouseSense type exposes the following members.

Members
Show:
Name | Description
All | Represents constant All.
DoubleClick | Represents constant DoubleClick.
Down | Represents constant Down.
Move | Represents constant Move.
None | Represents constant None.
Up | Represents constant Up.
Top
See Also

Reference

  • Tee.Grid.Bands


TMouseCursor Enumeration

Summary

Represents type TMouseCursor.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TMouseCursor=(Default,HandPoint,HorizResize,VertResize);

The TMouseCursor type exposes the following members.

Members
Show:
Name | Description
Default | Represents constant Default.
HandPoint | Represents constant HandPoint.
HorizResize | Represents constant HorizResize.
VertResize | Represents constant VertResize.
Top
See Also

Reference

  • Tee.Grid.Bands


Tee.Grid.Bands Types

Types
Name | Description
TGridBandClass | Represents type TGridBandClass.
TGridMouseSensitivity | Represents type TGridMouseSensitivity.
Top


TGridBandClass Type

Summary

Represents type TGridBandClass.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridBandClass=class of TGridBand;
See Also

Reference

  • Tee.Grid.Bands


TGridMouseSensitivity Type

Summary

Represents type TGridMouseSensitivity.

Namespace: Tee.Grid.Bands
Syntax
Delphi
type
 TGridMouseSensitivity = set of TGridMouseSense;
See Also

Reference

  • Tee.Grid.Bands


Tee.Grid.Bands.Columns Namespace

Summary

Represents namespace Tee.Grid.Bands.Columns.

Classes
Name | Description
TBandHeightAccess | Represents type TBandHeightAccess.
TColumnDrag | Represents type TColumnDrag.
TColumnsBand | Represents type TColumnsBand.
TCustomColumnBand | Represents type TCustomColumnBand.
TSelectedRender | Represents type TSelectedRender.
TTextRenderAccess | Represents type TTextRenderAccess.
Top


Tee.Grid.Bands.Columns Classes

Classes
Name | Description
TBandHeightAccess | Represents type TBandHeightAccess.
TColumnDrag | Represents type TColumnDrag.
TColumnsBand | Represents type TColumnsBand.
TCustomColumnBand | Represents type TCustomColumnBand.
TSelectedRender | Represents type TSelectedRender.
TTextRenderAccess | Represents type TTextRenderAccess.
Top


TBandHeightAccess Class

Summary

Represents type TBandHeightAccess.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Bands.TBandHeight
Tee.Grid.Bands.Columns.TBandHeightAccess
Syntax
Delphi
type
 TBandHeightAccess=class(TBandHeight);

The TBandHeightAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


TColumnDrag Class

Summary

Represents type TColumnDrag.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.Bands.Columns.TColumnDrag
Syntax
Delphi
type
 TColumnDrag=class(TPersistentChange)
 end;

The TColumnDrag type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TColumnDrag class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TColumnDrag class.
Top
Properties
Show:
Name | Description
Allow | Represents property Allow.
Dragging | Represents property Dragging.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Source | Represents property Source.
Target | Represents property Target.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


TColumnDrag Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TColumnDrag class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TColumnDrag class.
Top


TColumnDrag.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TColumnDrag class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag.Destroy Destructor

Summary

Represents the destructor of the TColumnDrag class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag Properties

Properties
Name | Description
Allow | Represents property Allow.
Dragging | Represents property Dragging.
Source | Represents property Source.
Target | Represents property Target.
Top


TColumnDrag.Allow Property

Summary

Represents property Allow.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Allow:Boolean read FAllow write FAllow default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag.Dragging Property

Summary

Represents property Dragging.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property Dragging:TColumn read IDragging;

Property Value

Type: TColumn

See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag.Source Property

Summary

Represents property Source.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Source:TBrush read FSource write SetSource;

Property Value

Type: TBrush

See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag.Target Property

Summary

Represents property Target.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Target:TBrush read FTarget write SetTarget;

Property Value

Type: TBrush

See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnDrag Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TColumnDrag.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TColumnDrag
  • Tee.Grid.Bands.Columns


TColumnsBand Class

Summary

Represents type TColumnsBand.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Bands.Columns.TColumnsBand
Syntax
Delphi
type
 TColumnsBand=class(TCustomColumnBand)
 end;

The TColumnsBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomColumnBand class. (Overrides TGridBandLines.Create(TCollection).)
Destroy | Represents the destructor of the TColumnsBand class. (Overrides TCustomColumnBand.Destroy.)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Texts | Represents property Texts.
Text[TColumn] | Represents property Text[TColumn].
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Overrides TGridBand.Description.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Inherited from TCustomColumnBand.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Inherited from TCustomColumnBand.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Inherited from TCustomColumnBand.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Overrides TCustomColumnBand.SetColumns(TColumns).)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


TColumnsBand Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TColumnsBand class. (Overrides TCustomColumnBand.Destroy.)
Top


TColumnsBand.Destroy Destructor

Summary

Represents the destructor of the TColumnsBand class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TCustomColumnBand.Destroy
See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TColumnsBand Properties

Properties
Name | Description
Texts | Represents property Texts.
Text[TColumn] | Represents property Text[TColumn].
Top


TColumnsBand.Texts Property

Summary

Represents property Texts.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Texts:TStringList read GetTexts write SetTexts;

Property Value

Type: TStringList

See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TColumnsBand.Text[TColumn] Property

Summary

Represents property Text[TColumn].

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property Text[const AColumn:TColumn]:String read GetByColumn write SetByColumn;

Parameters

AColumn
Type: TColumn

Property Value

Type: String

See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TColumnsBand Methods

Methods
Name | Description
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
Description | Represents method Description. (Overrides TGridBand.Description.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Overrides TCustomColumnBand.SetColumns(TColumns).)
Top


TColumnsBand.AsString(TColumn) Method

Summary

Represents method AsString(TColumn).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function AsString(const AColumn:TColumn):String; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

Overrides

TCustomColumnBand.AsString(TColumn)
See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TColumnsBand.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 class function Description:String; override;

Return Value

Type: String

Overrides

TGridBand.Description
See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TColumnsBand.SetColumns(TColumns) Method

Summary

Represents method SetColumns(TColumns).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 procedure SetColumns(const Value: TColumns); override;

Parameters

Value
Type: TColumns

Overrides

TCustomColumnBand.SetColumns(TColumns)
See Also

Reference

  • TColumnsBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand Class

Summary

Represents type TCustomColumnBand.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Bands.Columns.TColumnsBand
Tee.Grid.Header.TColumnHeaderBand
Tee.Grid.RowGroup.TCustomColumnBandAccess
Tee.Grid.Totals.TBaseTotals
Syntax
Delphi
type
 TCustomColumnBand=class(TGridBandLines)
 end;

The TCustomColumnBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomColumnBand class. (Overrides TGridBandLines.Create(TCollection).)
Destroy | Represents the destructor of the TCustomColumnBand class. (Overrides TGridBandLines.Destroy.)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize.
Columns | Represents property Columns.
Data | Represents property Data.
Drag | Represents property Drag.
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight.
Hover | Represents property Hover.
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins.
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized.
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing.
Selected | Represents property Selected.
SelectedColumn | Represents property SelectedColumn.
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn).
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont).
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single).
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick.
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer).
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn).
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat.
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat).
LevelTop(Integer) | Represents method LevelTop(Integer).
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn).
RenderSize | Represents method RenderSize.
RowCount | Represents method RowCount.
SetColumns(TColumns) | Represents method SetColumns(TColumns).
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns.
IData | Represents field IData.
IHeights | Represents field IHeights.
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow.
IVisible | Represents field IVisible.
MinX | Represents field MinX.
MouseColumn | Represents field MouseColumn.
ResizeTolerance | Represents field ResizeTolerance.
ShouldPaintTexts | Represents field ShouldPaintTexts.
StartX | Represents field StartX.
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width.
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


TCustomColumnBand Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomColumnBand class. (Overrides TGridBandLines.Create(TCollection).)
Destroy | Represents the destructor of the TCustomColumnBand class. (Overrides TGridBandLines.Destroy.)
Top


TCustomColumnBand.Create(TCollection) Constructor

Summary

Initializes a new instance of the TCustomColumnBand class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TGridBandLines.Create(TCollection)
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Destroy Destructor

Summary

Represents the destructor of the TCustomColumnBand class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGridBandLines.Destroy
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand Properties

Properties
Name | Description
AllowResize | Represents property AllowResize.
Columns | Represents property Columns.
Data | Represents property Data.
Drag | Represents property Drag.
HighLight | Represents property HighLight.
Hover | Represents property Hover.
Margins | Represents property Margins.
OnColumnResized | Represents property OnColumnResized.
Resizing | Represents property Resizing.
Selected | Represents property Selected.
SelectedColumn | Represents property SelectedColumn.
Top


TCustomColumnBand.AllowResize Property

Summary

Represents property AllowResize.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property AllowResize:Boolean read FAllowResize write FAllowResize default True;

Property Value

Type: Boolean

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Columns Property

Summary

Represents property Columns.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property Columns:TColumns read IColumns write SetColumns;

Property Value

Type: TColumns

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Data Property

Summary

Represents property Data.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property Data:TVirtualData read IData write IData;

Property Value

Type: TVirtualData

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Drag Property

Summary

Represents property Drag.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Drag:TColumnDrag read FDrag write SetDrag;

Property Value

Type: TColumnDrag

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.HighLight Property

Summary

Represents property HighLight.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property HighLight:TColumn read IHighLight write SetHighLight;

Property Value

Type: TColumn

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Hover Property

Summary

Represents property Hover.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Hover:THover read FHover write SetHover;

Property Value

Type: THover

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Margins Property

Summary

Represents property Margins.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Margins:TMargins read GetMargins write SetMargins;

Property Value

Type: TMargins

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.OnColumnResized Property

Summary

Represents property OnColumnResized.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property OnColumnResized:TNotifyEvent read FOnColumnResized write FOnColumnResized;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Resizing Property

Summary

Represents property Resizing.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property Resizing:TColumn read IResizing;

Property Value

Type: TColumn

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Selected Property

Summary

Represents property Selected.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
published
 property Selected:TSelectedRender read FSelected write SetSelected;

Property Value

Type: TSelectedRender

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.SelectedColumn Property

Summary

Represents property SelectedColumn.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 property SelectedColumn:TColumn read ISelected write SetSelectedColumn;

Property Value

Type: TColumn

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand Methods

Methods
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn).
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont).
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single).
DoClick | Represents method DoClick.
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer).
HeaderRender(TColumn) | Represents method HeaderRender(TColumn).
InitFormat | Overloaded. Represents method InitFormat.
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat).
LevelTop(Integer) | Represents method LevelTop(Integer).
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn).
RenderSize | Represents method RenderSize.
RowCount | Represents method RowCount.
SetColumns(TColumns) | Represents method SetColumns(TColumns).
Top


TCustomColumnBand.AdjustBounds(TColumn,TRectF) Method

Summary

Represents method AdjustBounds(TColumn,TRectF).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function AdjustBounds(const AColumn:TColumn; const R:TRectF):TRectF;

Parameters

AColumn
Type: TColumn

R
Type: TRectF

Return Value

Type: TRectF

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGridBand.Assign(TPersistent)
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.AsString(TColumn) Method

Summary

Represents method AsString(TColumn).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function AsString(const AColumn:TColumn):String; virtual; abstract;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.CalcFont(TColumn,TFont) Method

Summary

Represents method CalcFont(TColumn,TFont).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 function CalcFont(const AColumn:TColumn; const AFont:TFont):TFont;

Parameters

AColumn
Type: TColumn

AFont
Type: TFont

Return Value

Type: TFont

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.CalcHeight(TPainter,Single) Method

Summary

Represents method CalcHeight(TPainter,Single).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 procedure CalcHeight(const APainter:TPainter; const ATotal:Single); override;

Parameters

APainter
Type: TPainter

ATotal
Type: Single

Overrides

TGridBand.CalcHeight(TPainter,Single)
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.DoCalcBounds(TRenderData,TColumn,Integer,Single) Method

Summary

Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function DoCalcBounds(var AData:TRenderData;
 const AColumn:TColumn;
 const ALevel:Integer;
 const ARightMargin:Single):TRectF;

Parameters

AData
Type: TRenderData

AColumn
Type: TColumn

ALevel
Type: Integer

ARightMargin
Type: Single

Return Value

Type: TRectF

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.DoClick Method

Summary

Represents method DoClick.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 procedure DoClick; virtual;
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.DoDrawText(TRenderData,TColumn,Integer) Method

Summary

Represents method DoDrawText(TRenderData,TColumn,Integer).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 procedure DoDrawText(var AData:TRenderData; const AColumn:TColumn; const ALevel:Integer); virtual;

Parameters

AData
Type: TRenderData

AColumn
Type: TColumn

ALevel
Type: Integer

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.HeaderRender(TColumn) Method

Summary

Represents method HeaderRender(TColumn).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function HeaderRender(const AColumn:TColumn):TRender;

Parameters

AColumn
Type: TColumn

Return Value

Type: TRender

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.InitFormat Method

Summary

Represents method InitFormat.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 procedure InitFormat; overload;
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.InitFormat(TTextFormat) Method

Summary

Represents method InitFormat(TTextFormat).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 procedure InitFormat(const AFormat:TTextFormat); overload;

Parameters

AFormat
Type: TTextFormat

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.LevelTop(Integer) Method

Summary

Represents method LevelTop(Integer).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function LevelTop(const ALevel:Integer):Single;

Parameters

ALevel
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Mouse(TMouseState,Single,Single) Method

Summary

Represents method Mouse(TMouseState,Single,Single).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 function Mouse(var AState:TMouseState; const AWidth,AHeight:Single):Boolean; override;

Parameters

AState
Type: TMouseState

AWidth
Type: Single

AHeight
Type: Single

Return Value

Type: Boolean

Overrides

TGridBand.Mouse(TMouseState,Single,Single)
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TGridBand.Paint(TRenderData,TRender)
See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.RenderAlign(TColumn) Method

Summary

Represents method RenderAlign(TColumn).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 class function RenderAlign(const AColumn:TColumn):THorizontalAlign;

Parameters

AColumn
Type: TColumn

Return Value

Type: THorizontalAlign

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.RenderSize Method

Summary

Represents method RenderSize.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 function RenderSize:Single; virtual;

Return Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.RowCount Method

Summary

Represents method RowCount.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 function RowCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.SetColumns(TColumns) Method

Summary

Represents method SetColumns(TColumns).

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 procedure SetColumns(const Value: TColumns); virtual;

Parameters

Value
Type: TColumns

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand Fields

Fields
Name | Description
IColumns | Represents field IColumns.
IData | Represents field IData.
IHeights | Represents field IHeights.
ISingleRow | Represents field ISingleRow.
IVisible | Represents field IVisible.
MinX | Represents field MinX.
MouseColumn | Represents field MouseColumn.
ResizeTolerance | Represents field ResizeTolerance.
ShouldPaintTexts | Represents field ShouldPaintTexts.
StartX | Represents field StartX.
Width | Represents field Width.
Top


TCustomColumnBand.IColumns Field

Summary

Represents field IColumns.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 IColumns : TColumns;

Field Value

Type: TColumns

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.IData Field

Summary

Represents field IData.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 IData : TVirtualData;

Field Value

Type: TVirtualData

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.IHeights Field

Summary

Represents field IHeights.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 IHeights : Array of Single;

Field Value

Type: Array of Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.ISingleRow Field

Summary

Represents field ISingleRow.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 ISingleRow : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.IVisible Field

Summary

Represents field IVisible.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 IVisible : TVisibleColumns;

Field Value

Type: TVisibleColumns

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.MinX Field

Summary

Represents field MinX.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 MinX,
 StartX : Single;

Field Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.MouseColumn Field

Summary

Represents field MouseColumn.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 MouseColumn : TColumn;

Field Value

Type: TColumn

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.ResizeTolerance Field

Summary

Represents field ResizeTolerance.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 class var
 ResizeTolerance : Single;

Field Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.ShouldPaintTexts Field

Summary

Represents field ShouldPaintTexts.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
protected
 ShouldPaintTexts : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.StartX Field

Summary

Represents field StartX.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 MinX,
 StartX : Single;

Field Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TCustomColumnBand.Width Field

Summary

Represents field Width.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Width : Single;

Field Value

Type: Single

See Also

Reference

  • TCustomColumnBand
  • Tee.Grid.Bands.Columns


TSelectedRender Class

Summary

Represents type TSelectedRender.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Renders.THover
Tee.Grid.Bands.Columns.TSelectedRender
Syntax
Delphi
type
 TSelectedRender=class(THover)
 end;

The TSelectedRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSelectedRender class. (Overrides THover.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
ParentFont | Represents property ParentFont. (Inherited from THover.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
InitFormat | Represents method InitFormat. (Inherited from THover.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


TSelectedRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSelectedRender class. (Overrides THover.Create(TNotifyEvent).)
Top


TSelectedRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TSelectedRender class.

Namespace: Tee.Grid.Bands.Columns
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

THover.Create(TNotifyEvent)
See Also

Reference

  • TSelectedRender
  • Tee.Grid.Bands.Columns


TTextRenderAccess Class

Summary

Represents type TTextRenderAccess.

Namespace: Tee.Grid.Bands.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Grid.Bands.Columns.TTextRenderAccess
Syntax
Delphi
type
 TTextRenderAccess=class(TTextRender);

The TTextRenderAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Bands.Columns


Tee.Grid.Columns Namespace

Summary

Represents namespace Tee.Grid.Columns.

Classes
Name | Description
TColumn | Represents type TColumn.
TColumnHeader | Represents type TColumnHeader.
TColumns | Represents type TColumns.
TColumnsEnumerator | Represents type TColumnsEnumerator.
TColumnWidth | Represents type TColumnWidth.
TDataFormat | Represents type TDataFormat.
TIndicator | Represents type TIndicator.
TVisibleColumns | Represents type TVisibleColumns.
Top
Records
Name | Description
TColumnUtils | Represents type TColumnUtils.
Top
Enumerations
Name | Description
TColumnLocked | Represents type TColumnLocked.
TColumnTextAlign | Represents type TColumnTextAlign.
TIndicatorState | Represents type TIndicatorState.
Top
Delegates
Name | Description
TColumnEvent | Represents type TColumnEvent.
TColumnMovedEvent | Represents type TColumnMovedEvent.
TColumnPaintEvent | Represents type TColumnPaintEvent.
TColumns.TGetFieldsEvent | Represents type TGetFieldsEvent.
TColumns.TSetFieldEvent | Represents type TSetFieldEvent.
Top


Tee.Grid.Columns Classes

Classes
Name | Description
TColumn | Represents type TColumn.
TColumnHeader | Represents type TColumnHeader.
TColumns | Represents type TColumns.
TColumnsEnumerator | Represents type TColumnsEnumerator.
TColumnWidth | Represents type TColumnWidth.
TDataFormat | Represents type TDataFormat.
TIndicator | Represents type TIndicator.
TVisibleColumns | Represents type TVisibleColumns.
Top


TColumn Class

Summary

Represents type TColumn.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Columns.TColumn
Tee.Grid.RowGroup.TColumnAccess
Tee.Grid.Selection.TColumnAccess
Tee.GridData.DB.TColumnAccess
Syntax
Delphi
type
 TColumn=class(TVisibleRenderItem)
 end;

The TColumn type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumn class. (Overrides TVisibleRenderItem.Create(TCollection).)
Destroy | Represents the destructor of the TColumn class. (Overrides TVisibleRenderItem.Destroy.)
Top
Properties
Show:
Name | Description
DataFormat | Represents property DataFormat.
DefaultHorizAlign | Represents property DefaultHorizAlign.
Expanded | Represents property Expanded.
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header.
Items | Represents property Items.
LoadOrder | Represents property LoadOrder.
Locked | Represents property Locked.
Margins | Represents property Margins.
Parent | Represents property Parent.
ParentFormat | Represents property ParentFormat.
ReadOnly | Represents property ReadOnly.
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Selectable | Represents property Selectable.
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
TextAlign | Represents property TextAlign.
TextAlignment | Represents property TextAlignment.
TopParent | Represents property TopParent.
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
AutoWidth(TPainter) | Represents method AutoWidth(TPainter).
CanDisplay | Represents method CanDisplay.
Changed(TObject) | Represents method Changed(TObject). (Inherited from TVisibleRenderItem.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoChanged | Represents method DoChanged. (Overrides TVisibleRenderItem.DoChanged.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasItems | Represents method HasItems.
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
HorizAlign | Represents method HorizAlign.
InitAlign(THorizontalAlign) | Represents method InitAlign(THorizontalAlign).
Level | Represents method Level.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
ParentColumns | Represents method ParentColumns.
Right | Represents method Right.
SetIndex(Integer) | Represents method SetIndex(Integer).
SetRender(TRender) | Represents method SetRender(TRender). (Overrides TVisibleRenderItem.SetRender(TRender).)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToString | Represents method ToString.
Top
Events
Show:
Name | Description
OnPaint | Represents property OnPaint.
Top
Fields
Show:
Name | Description
EditorClass | Represents field EditorClass.
FLink | Represents field FLink.
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
ITopParent | Represents field ITopParent.
Left | Represents field Left.
ValidWidth | Represents field ValidWidth.
Top
See Also

Reference

  • Tee.Grid.Columns


TColumn Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TColumn class. (Overrides TVisibleRenderItem.Create(TCollection).)
Destroy | Represents the destructor of the TColumn class. (Overrides TVisibleRenderItem.Destroy.)
Top


TColumn.Create(TCollection) Constructor

Summary

Initializes a new instance of the TColumn class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TVisibleRenderItem.Create(TCollection)
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Destroy Destructor

Summary

Represents the destructor of the TColumn class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TVisibleRenderItem.Destroy
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn Properties

Properties
Name | Description
DataFormat | Represents property DataFormat.
DefaultHorizAlign | Represents property DefaultHorizAlign.
Expanded | Represents property Expanded.
Header | Represents property Header.
Items | Represents property Items.
LoadOrder | Represents property LoadOrder.
Locked | Represents property Locked.
Margins | Represents property Margins.
Parent | Represents property Parent.
ParentFormat | Represents property ParentFormat.
ReadOnly | Represents property ReadOnly.
Selectable | Represents property Selectable.
TextAlign | Represents property TextAlign.
TextAlignment | Represents property TextAlignment.
TopParent | Represents property TopParent.
Width | Represents property Width.
Top


TColumn.DataFormat Property

Summary

Represents property DataFormat.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property DataFormat:TDataFormat read FDataFormat write SetDataFormat;

Property Value

Type: TDataFormat

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.DefaultHorizAlign Property

Summary

Represents property DefaultHorizAlign.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 property DefaultHorizAlign:THorizontalAlign read IHorizontal;

Property Value

Type: THorizontalAlign

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Expanded Property

Summary

Represents property Expanded.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Expanded:Boolean read FExpanded write SetExpanded default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Header Property

Summary

Represents property Header.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Header:TColumnHeader read FHeader write SetHeader;

Property Value

Type: TColumnHeader

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Items Property

Summary

Represents property Items.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Items:TColumns read GetItems write SetItems stored IsItemsStored;

Property Value

Type: TColumns

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.LoadOrder Property

Summary

Represents property LoadOrder.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property LoadOrder:Integer read FLoadOrder write SetLoadOrder;

Property Value

Type: Integer

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Locked Property

Summary

Represents property Locked.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Locked:TColumnLocked read FLocked write SetLocked default TColumnLocked.None;

Property Value

Type: TColumnLocked

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Margins Property

Summary

Represents property Margins.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Margins:TMargins read GetMargins write SetMargins;

Property Value

Type: TMargins

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Parent Property

Summary

Represents property Parent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property Parent:TColumn read GetParent;

Property Value

Type: TColumn

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ParentFormat Property

Summary

Represents property ParentFormat.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property ParentFormat:Boolean read FParentFormat write SetParentFormat default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property ReadOnly:Boolean read FReadOnly write FReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Selectable Property

Summary

Represents property Selectable.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Selectable:Boolean read FSelectable write FSelectable default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.TextAlign Property

Summary

Represents property TextAlign.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property TextAlign:TTextAlign read GetAlign write SetAlign;

Property Value

Type: TTextAlign

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.TextAlignment Property

Summary

Represents property TextAlignment.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property TextAlignment:TColumnTextAlign read FTextAlignment
 write SetTextAlignment default TColumnTextAlign.Automatic;

Property Value

Type: TColumnTextAlign

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.TopParent Property

Summary

Represents property TopParent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property TopParent:TColumns read ITopParent;

Property Value

Type: TColumns

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Width Property

Summary

Represents property Width.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Width:TColumnWidth read FWidth write SetWidth;

Property Value

Type: TColumnWidth

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
AutoWidth(TPainter) | Represents method AutoWidth(TPainter).
CanDisplay | Represents method CanDisplay.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoChanged | Represents method DoChanged. (Overrides TVisibleRenderItem.DoChanged.)
HasItems | Represents method HasItems.
HorizAlign | Represents method HorizAlign.
InitAlign(THorizontalAlign) | Represents method InitAlign(THorizontalAlign).
Level | Represents method Level.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
ParentColumns | Represents method ParentColumns.
Right | Represents method Right.
SetIndex(Integer) | Represents method SetIndex(Integer).
SetRender(TRender) | Represents method SetRender(TRender). (Overrides TVisibleRenderItem.SetRender(TRender).)
ToString | Represents method ToString.
Top


TColumn.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisibleRenderItem.Assign(TPersistent)
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.AutoWidth(TPainter) Method

Summary

Represents method AutoWidth(TPainter).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 function AutoWidth(const APainter:TPainter):Single; virtual;

Parameters

APainter
Type: TPainter

Return Value

Type: Single

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.CanDisplay Method

Summary

Represents method CanDisplay.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function CanDisplay:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.DoChanged Method

Summary

Represents method DoChanged.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure DoChanged; override;

Overrides

TVisibleRenderItem.DoChanged
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.HasItems Method

Summary

Represents method HasItems.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function HasItems:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.HorizAlign Method

Summary

Represents method HorizAlign.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function HorizAlign:THorizontalAlign; inline;

Return Value

Type: THorizontalAlign

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.InitAlign(THorizontalAlign) Method

Summary

Represents method InitAlign(THorizontalAlign).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure InitAlign(const AHorizontal:THorizontalAlign); inline;

Parameters

AHorizontal
Type: THorizontalAlign

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Level Method

Summary

Represents method Level.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Level:Integer;

Return Value

Type: Integer

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TVisibleRenderItem.Paint(TRenderData,TRender)
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ParentColumns Method

Summary

Represents method ParentColumns.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function ParentColumns:TColumns; inline;

Return Value

Type: TColumns

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Right Method

Summary

Represents method Right.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Right:Single; inline;

Return Value

Type: Single

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.SetIndex(Integer) Method

Summary

Represents method SetIndex(Integer).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure SetIndex(Value: Integer); override;

Parameters

Value
Type: Integer

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.SetRender(TRender) Method

Summary

Represents method SetRender(TRender).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure SetRender(const Value: TRender); override;

Parameters

Value
Type: TRender

Overrides

TVisibleRenderItem.SetRender(TRender)
See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ToString Method

Summary

Represents method ToString.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn Events

Events
Name | Description
OnPaint | Represents property OnPaint.
Top


TColumn.OnPaint Event

Summary

Represents property OnPaint.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property OnPaint:TColumnPaintEvent read FOnPaint write FOnPaint;

Value

Type: TColumnPaintEvent

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn Fields

Fields
Name | Description
EditorClass | Represents field EditorClass.
FLink | Represents field FLink.
ITopParent | Represents field ITopParent.
Left | Represents field Left.
ValidWidth | Represents field ValidWidth.
Top


TColumn.EditorClass Field

Summary

Represents field EditorClass.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 EditorClass : TClass;

Field Value

Type: TClass

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.FLink Field

Summary

Represents field FLink.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 FLink : String;

Field Value

Type: String

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ITopParent Field

Summary

Represents field ITopParent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 ITopParent : TColumns;

Field Value

Type: TColumns

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.Left Field

Summary

Represents field Left.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Left : Single;

Field Value

Type: Single

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumn.ValidWidth Field

Summary

Represents field ValidWidth.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 ValidWidth : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TColumn
  • Tee.Grid.Columns


TColumnHeader Class

Summary

Represents type TColumnHeader.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Renders.TCellRender
Tee.Grid.Columns.TColumnHeader
Syntax
Delphi
type
 TColumnHeader=class(TCellRender)
 end;

The TColumnHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TColumnHeader class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
ParentFormat | Represents property ParentFormat.
Text | Represents property Text. (Inherited from TCellRender.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
TextAlignment | Represents property TextAlignment.
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TCellRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
DisplayText | Represents method DisplayText.
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Columns


TColumnHeader Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TColumnHeader class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top


TColumnHeader.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TColumnHeader class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisibleTextRender.Create(TNotifyEvent)
See Also

Reference

  • TColumnHeader
  • Tee.Grid.Columns


TColumnHeader Properties

Properties
Name | Description
ParentFormat | Represents property ParentFormat.
TextAlignment | Represents property TextAlignment.
Top


TColumnHeader.ParentFormat Property

Summary

Represents property ParentFormat.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property ParentFormat:Boolean read FParentFormat write SetParentFormat default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumnHeader
  • Tee.Grid.Columns


TColumnHeader.TextAlignment Property

Summary

Represents property TextAlignment.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property TextAlignment:TColumnTextAlign read FTextAlignment
 write SetTextAlignment default TColumnTextAlign.Automatic;

Property Value

Type: TColumnTextAlign

See Also

Reference

  • TColumnHeader
  • Tee.Grid.Columns


TColumnHeader Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TCellRender.Assign(TPersistent).)
DisplayText | Represents method DisplayText.
Top


TColumnHeader.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TCellRender.Assign(TPersistent)
See Also

Reference

  • TColumnHeader
  • Tee.Grid.Columns


TColumnHeader.DisplayText Method

Summary

Represents method DisplayText.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function DisplayText:String;

Return Value

Type: String

See Also

Reference

  • TColumnHeader
  • Tee.Grid.Columns


TColumns Class

Summary

Represents type TColumns.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Columns.TColumns
Tee.Grid.RowGroup.TColumnsAccess
Tee.Grid.TColumnsAccess
Syntax
Delphi
type
 TColumns=class(TCollectionChange)
 end;

The TColumns type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent,TCollectionItemClass) | Initializes a new instance of the TColumns class.
Destroy | Represents the destructor of the TColumns class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Items[String] | Represents property Items[String].
LoadOrder[Integer] | Represents property LoadOrder[Integer].
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Parent | Represents property Parent.
Spacing | Represents property Spacing.
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add.
Add(String) | Overloaded. Represents method Add(String).
AnyPercentWidth | Represents method AnyPercentWidth.
Assign(TPersistent) | Represents method Assign(TPersistent).
DoChanged(TObject) | Represents method DoChanged(TObject). (Overrides TCollectionChange.DoChanged(TObject).)
FindAt(Single,Single) | Represents method FindAt(Single,Single).
FindFirst(String) | Represents method FindFirst(String).
FirstVisible | Represents method FirstVisible.
GetEnumerator | Represents method GetEnumerator.
HasSpacing | Represents method HasSpacing.
LevelCount | Represents method LevelCount.
Moved(TColumn,Integer,Integer) | Represents method Moved(TColumn,Integer,Integer).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Events
Show:
Name | Description
OnMoved | Represents property OnMoved.
Top
Fields
Show:
Name | Description
FLoadOrderItems | Represents field FLoadOrderItems.
IsDefault | Represents field IsDefault.
OnGetFields | Represents field OnGetFields.
OnSetField | Represents field OnSetField.
ValidWidth | Represents field ValidWidth.
Top
See Also

Reference

  • Tee.Grid.Columns


TColumns Constructors

Constructors
Name | Description
Create(TPersistent,TCollectionItemClass) | Initializes a new instance of the TColumns class.
Destroy | Represents the destructor of the TColumns class.
Top


TColumns.Create(TPersistent,TCollectionItemClass) Constructor

Summary

Initializes a new instance of the TColumns class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Constructor Create(const AOwner: TPersistent; const ItemClass: TCollectionItemClass);

Parameters

AOwner
Type: TPersistent

ItemClass
Type: TCollectionItemClass

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Destroy Destructor

Summary

Represents the destructor of the TColumns class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Items[String] | Represents property Items[String].
LoadOrder[Integer] | Represents property LoadOrder[Integer].
Parent | Represents property Parent.
Spacing | Represents property Spacing.
Top


TColumns.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property Items[const Index:Integer]:TColumn read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Items[String] Property

Summary

Represents property Items[String].

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 [HPPGEN('__property TColumn* Item2[const System::UnicodeString Name] = {read=GetByName/*, default*/};'+
 sLineBreak+
 'TColumn* operator[](const System::UnicodeString Name) { return this->Item2[Name]; }'
 )]
 property Items[const AName:String]:TColumn read GetByName; default;

Parameters

AName
Type: String

Property Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.LoadOrder[Integer] Property

Summary

Represents property LoadOrder[Integer].

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property LoadOrder[Index: Integer]: Integer read GetLoadOrder write SetLoadOrder;

Parameters

Index
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Parent Property

Summary

Represents property Parent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property Parent:TColumn read IParent;

Property Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Spacing Property

Summary

Represents property Spacing.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Spacing: TCoordinate read GetSpacing write SetSpacing;

Property Value

Type: TCoordinate

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns Methods

Methods
Name | Description
Add | Overloaded. Represents method Add.
Add(String) | Overloaded. Represents method Add(String).
AnyPercentWidth | Represents method AnyPercentWidth.
Assign(TPersistent) | Represents method Assign(TPersistent).
DoChanged(TObject) | Represents method DoChanged(TObject). (Overrides TCollectionChange.DoChanged(TObject).)
FindAt(Single,Single) | Represents method FindAt(Single,Single).
FindFirst(String) | Represents method FindFirst(String).
FirstVisible | Represents method FirstVisible.
GetEnumerator | Represents method GetEnumerator.
HasSpacing | Represents method HasSpacing.
LevelCount | Represents method LevelCount.
Moved(TColumn,Integer,Integer) | Represents method Moved(TColumn,Integer,Integer).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
Top


TColumns.Add Method

Summary

Represents method Add.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Add:TColumn; overload; inline;

Return Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Add(String) Method

Summary

Represents method Add(String).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Add(const AText:String):TColumn; overload;

Parameters

AText
Type: String

Return Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.AnyPercentWidth Method

Summary

Represents method AnyPercentWidth.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 function AnyPercentWidth:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.DoChanged(TObject) Method

Summary

Represents method DoChanged(TObject).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure DoChanged(Sender:TObject); override;

Parameters

Sender
Type: TObject

Overrides

TCollectionChange.DoChanged(TObject)
See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.FindAt(Single,Single) Method

Summary

Represents method FindAt(Single,Single).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function FindAt(const X,MaxRight:Single):TColumn;

Parameters

X
Type: Single

MaxRight
Type: Single

Return Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.FindFirst(String) Method

Summary

Represents method FindFirst(String).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function FindFirst(const AName:String):TColumn;

Parameters

AName
Type: String

Return Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.FirstVisible Method

Summary

Represents method FirstVisible.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function FirstVisible:TColumn;

Return Value

Type: TColumn

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.GetEnumerator Method

Summary

Represents method GetEnumerator.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function GetEnumerator: TColumnsEnumerator;

Return Value

Type: TColumnsEnumerator

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.HasSpacing Method

Summary

Represents method HasSpacing.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function HasSpacing:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.LevelCount Method

Summary

Represents method LevelCount.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function LevelCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Moved(TColumn,Integer,Integer) Method

Summary

Represents method Moved(TColumn,Integer,Integer).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure Moved(const AColumn:TColumn; const AOld,ANew:Integer);

Parameters

AColumn
Type: TColumn

AOld
Type: Integer

ANew
Type: Integer

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.Notify(TCollectionItem,TCollectionNotification) Method

Summary

Represents method Notify(TCollectionItem,TCollectionNotification).

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 procedure Notify(Item: TCollectionItem; Action: TCollectionNotification); override;

Parameters

Item
Type: TCollectionItem

Action
Type: TCollectionNotification

Overrides

TCollectionChange.Notify(TCollectionItem,TCollectionNotification)
See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns Events

Events
Name | Description
OnMoved | Represents property OnMoved.
Top


TColumns.OnMoved Event

Summary

Represents property OnMoved.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property OnMoved:TColumnMovedEvent read FOnMoved write FOnMoved;

Value

Type: TColumnMovedEvent

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns Fields

Fields
Name | Description
FLoadOrderItems | Represents field FLoadOrderItems.
IsDefault | Represents field IsDefault.
OnGetFields | Represents field OnGetFields.
OnSetField | Represents field OnSetField.
ValidWidth | Represents field ValidWidth.
Top


TColumns.FLoadOrderItems Field

Summary

Represents field FLoadOrderItems.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 FLoadOrderItems : TArray<Integer> ;

Field Value

Type: TArray<Integer>

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.IsDefault Field

Summary

Represents field IsDefault.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 IsDefault : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.OnGetFields Field

Summary

Represents field OnGetFields.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 OnGetFields : TGetFieldsEvent;

Field Value

Type: TGetFieldsEvent

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.OnSetField Field

Summary

Represents field OnSetField.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 OnSetField : TSetFieldEvent;

Field Value

Type: TSetFieldEvent

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.ValidWidth Field

Summary

Represents field ValidWidth.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 ValidWidth : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumnsEnumerator Class

Summary

Represents type TColumnsEnumerator.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TObject
Tee.Grid.Columns.TColumnsEnumerator
Syntax
Delphi
type
 TColumnsEnumerator = class
 end;

The TColumnsEnumerator type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnsEnumerator class.
Top
Properties
Show:
Name | Description
Current | Represents property Current.
Top
Methods
Show:
Name | Description
GetCurrent | Represents method GetCurrent.
MoveNext | Represents method MoveNext.
Top
See Also

Reference

  • Tee.Grid.Columns


TColumnsEnumerator Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnsEnumerator class.
Top


TColumnsEnumerator.Create(TCollection) Constructor

Summary

Initializes a new instance of the TColumnsEnumerator class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 constructor Create(ACollection: TCollection);

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TColumnsEnumerator
  • Tee.Grid.Columns


TColumnsEnumerator Properties

Properties
Name | Description
Current | Represents property Current.
Top


TColumnsEnumerator.Current Property

Summary

Represents property Current.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property Current: TColumn read GetCurrent;

Property Value

Type: TColumn

See Also

Reference

  • TColumnsEnumerator
  • Tee.Grid.Columns


TColumnsEnumerator Methods

Methods
Name | Description
GetCurrent | Represents method GetCurrent.
MoveNext | Represents method MoveNext.
Top


TColumnsEnumerator.GetCurrent Method

Summary

Represents method GetCurrent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function GetCurrent: TColumn; inline;

Return Value

Type: TColumn

See Also

Reference

  • TColumnsEnumerator
  • Tee.Grid.Columns


TColumnsEnumerator.MoveNext Method

Summary

Represents method MoveNext.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function MoveNext: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TColumnsEnumerator
  • Tee.Grid.Columns


TColumnWidth Class

Summary

Represents type TColumnWidth.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Columns.TColumnWidth
Tee.Grid.RowGroup.TColumnWidthAccess
Syntax
Delphi
type
 TColumnWidth=class(TCoordinate);

The TColumnWidth type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.Columns


TDataFormat Class

Summary

Represents type TDataFormat.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.Columns.TDataFormat
Syntax
Delphi
type
 TDataFormat=class(TPersistentChange)
 end;

The TDataFormat type exposes the following members.

Constants
Show:
Name | Description
DefaultFloat | Represents constant DefaultFloat.
Top
Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TDataFormat class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Date | Represents property Date.
DateTime | Represents property DateTime.
Float | Represents property Float.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Time | Represents property Time.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Format(Double) | Overloaded. Represents method Format(Double).
Format(Extended) | Overloaded. Represents method Format(Extended).
Format(Single) | Overloaded. Represents method Format(Single).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Columns


TDataFormat Constants

Constants
Name | Description
DefaultFloat | Represents constant DefaultFloat.
Top


TDataFormat.DefaultFloat Constant

Summary

Represents constant DefaultFloat.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 DefaultFloat='0.###';

Value

Type: string

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TDataFormat class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TDataFormat.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TDataFormat class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat Properties

Properties
Name | Description
Date | Represents property Date.
DateTime | Represents property DateTime.
Float | Represents property Float.
Time | Represents property Time.
Top


TDataFormat.Date Property

Summary

Represents property Date.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Date:String read FDate write SetDate;

Property Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.DateTime Property

Summary

Represents property DateTime.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property DateTime:String read FDateTime write SetDateTime;

Property Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.Float Property

Summary

Represents property Float.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Float:String read FFloat write SetFloat stored IsFloatStored;

Property Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.Time Property

Summary

Represents property Time.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Time:String read FTime write SetTime;

Property Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Format(Double) | Overloaded. Represents method Format(Double).
Format(Extended) | Overloaded. Represents method Format(Extended).
Format(Single) | Overloaded. Represents method Format(Single).
Top


TDataFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.Format(Double) Method

Summary

Represents method Format(Double).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Format(const AValue:Double):String; overload;

Parameters

AValue
Type: Double

Return Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.Format(Extended) Method

Summary

Represents method Format(Extended).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Format(const AValue:Extended):String; overload;

Parameters

AValue
Type: Extended

Return Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TDataFormat.Format(Single) Method

Summary

Represents method Format(Single).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Format(const AValue:Single):String; overload;

Parameters

AValue
Type: Single

Return Value

Type: String

See Also

Reference

  • TDataFormat
  • Tee.Grid.Columns


TIndicator Class

Summary

Represents type TIndicator.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Columns.TIndicator
Tee.Grid.TIndicatorAccess
Syntax
Delphi
type
 TIndicator=class(TVisibleTextRender)
 end;

The TIndicator type exposes the following members.

Constants
Show:
Name | Description
DefaultWidth | Represents constant DefaultWidth.
Top
Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TIndicator class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TIndicator class. (Overrides TTextRender.Destroy.)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
State | Represents field State.
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Columns


TIndicator Constants

Constants
Name | Description
DefaultWidth | Represents constant DefaultWidth.
Top


TIndicator.DefaultWidth Constant

Summary

Represents constant DefaultWidth.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 DefaultWidth=10;

Value

Type: ShortInt

See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TIndicator class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TIndicator class. (Overrides TTextRender.Destroy.)
Top


TIndicator.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TIndicator class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisibleTextRender.Create(TNotifyEvent)
See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator.Destroy Destructor

Summary

Represents the destructor of the TIndicator class.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TTextRender.Destroy
See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator Properties

Properties
Name | Description
Width | Represents property Width.
Top


TIndicator.Width Property

Summary

Represents property Width.

Namespace: Tee.Grid.Columns
Syntax
Delphi
published
 property Width:TColumnWidth read FWidth write SetWidth;

Property Value

Type: TColumnWidth

See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
Top


TIndicator.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisibleTextRender.Assign(TPersistent)
See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TTextRender.Paint(TRenderData)
See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TIndicator Fields

Fields
Name | Description
State | Represents field State.
Top


TIndicator.State Field

Summary

Represents field State.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
 State : TIndicatorState;

Field Value

Type: TIndicatorState

See Also

Reference

  • TIndicator
  • Tee.Grid.Columns


TVisibleColumns Class

Summary

Represents type TVisibleColumns.

Namespace: Tee.Grid.Columns
Inheritance Hierarchy
TObject
Tee.Grid.Columns.TVisibleColumns
Syntax
Delphi
type
 TVisibleColumns=class
 end;

The TVisibleColumns type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TColumn) | Overloaded. Represents method Add(TColumn).
Add(TColumns) | Overloaded. Represents method Add(TColumns).
AllSameFormat | Represents method AllSameFormat.
AnyLocked | Represents method AnyLocked.
AtEdge(Single,TColumn,Single) | Represents method AtEdge(Single,TColumn,Single).
Clear | Represents method Clear.
Count | Represents method Count.
First | Represents method First.
FirstSelectable | Represents method FirstSelectable.
IndexOf(TColumn) | Represents method IndexOf(TColumn).
Last | Represents method Last.
MaxRight | Represents method MaxRight.
Next(TColumn) | Represents method Next(TColumn).
Previous(TColumn) | Represents method Previous(TColumn).
Top
Fields
Show:
Name | Description
NonLocked | Represents field NonLocked.
Top
See Also

Reference

  • Tee.Grid.Columns


TVisibleColumns Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TVisibleColumns.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 property Items[const Index:Integer]:TColumn read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns Methods

Methods
Name | Description
Add(TColumn) | Overloaded. Represents method Add(TColumn).
Add(TColumns) | Overloaded. Represents method Add(TColumns).
AllSameFormat | Represents method AllSameFormat.
AnyLocked | Represents method AnyLocked.
AtEdge(Single,TColumn,Single) | Represents method AtEdge(Single,TColumn,Single).
Clear | Represents method Clear.
Count | Represents method Count.
First | Represents method First.
FirstSelectable | Represents method FirstSelectable.
IndexOf(TColumn) | Represents method IndexOf(TColumn).
Last | Represents method Last.
MaxRight | Represents method MaxRight.
Next(TColumn) | Represents method Next(TColumn).
Previous(TColumn) | Represents method Previous(TColumn).
Top


TVisibleColumns.Add(TColumn) Method

Summary

Represents method Add(TColumn).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Add(const AColumn:TColumn); overload;

Parameters

AColumn
Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Add(TColumns) Method

Summary

Represents method Add(TColumns).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Add(const AColumns:TColumns); overload;

Parameters

AColumns
Type: TColumns

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.AllSameFormat Method

Summary

Represents method AllSameFormat.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function AllSameFormat:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.AnyLocked Method

Summary

Represents method AnyLocked.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function AnyLocked: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.AtEdge(Single,TColumn,Single) Method

Summary

Represents method AtEdge(Single,TColumn,Single).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function AtEdge(const X:Single; const AColumn:TColumn; const Tolerance:Single=3):TColumn;

Parameters

X
Type: Single

AColumn
Type: TColumn

Tolerance
Type: Single

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Clear Method

Summary

Represents method Clear.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 procedure Clear; inline;
See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Count Method

Summary

Represents method Count.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.First Method

Summary

Represents method First.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function First:TColumn;

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.FirstSelectable Method

Summary

Represents method FirstSelectable.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function FirstSelectable:TColumn;

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.IndexOf(TColumn) Method

Summary

Represents method IndexOf(TColumn).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function IndexOf(const AColumn: TColumn): Integer;

Parameters

AColumn
Type: TColumn

Return Value

Type: Integer

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Last Method

Summary

Represents method Last.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Last:TColumn;

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.MaxRight Method

Summary

Represents method MaxRight.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function MaxRight:Single;

Return Value

Type: Single

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Next(TColumn) Method

Summary

Represents method Next(TColumn).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Next(const AColumn:TColumn):TColumn;

Parameters

AColumn
Type: TColumn

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns.Previous(TColumn) Method

Summary

Represents method Previous(TColumn).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 function Previous(const AColumn:TColumn):TColumn;

Parameters

AColumn
Type: TColumn

Return Value

Type: TColumn

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


TVisibleColumns Fields

Fields
Name | Description
NonLocked | Represents field NonLocked.
Top


TVisibleColumns.NonLocked Field

Summary

Represents field NonLocked.

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 NonLocked : TRectF;

Field Value

Type: TRectF

See Also

Reference

  • TVisibleColumns
  • Tee.Grid.Columns


Tee.Grid.Columns Records

Records
Name | Description
TColumnUtils | Represents type TColumnUtils.
Top


TColumnUtils Record

Summary

Represents type TColumnUtils.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnUtils=record
 end;

The TColumnUtils type exposes the following members.

Methods
Show:
Name | Description
ChangeHeaderFont(TColumns,TColumn,TFontStyles) | Represents method ChangeHeaderFont(TColumns,TColumn,TFontStyles).
Top
See Also

Reference

  • Tee.Grid.Columns


TColumnUtils Methods

Methods
Name | Description
ChangeHeaderFont(TColumns,TColumn,TFontStyles) | Represents method ChangeHeaderFont(TColumns,TColumn,TFontStyles).
Top


TColumnUtils.ChangeHeaderFont(TColumns,TColumn,TFontStyles) Method

Summary

Represents method ChangeHeaderFont(TColumns,TColumn,TFontStyles).

Namespace: Tee.Grid.Columns
Syntax
Delphi
public
 class procedure ChangeHeaderFont(const AColumns:TColumns;
 const ASelected:TColumn;
 const AStyle:TFontStyles); static;

Parameters

AColumns
Type: TColumns

ASelected
Type: TColumn

AStyle
Type: TFontStyles

See Also

Reference

  • TColumnUtils
  • Tee.Grid.Columns


Tee.Grid.Columns Enumerations

Enumerations
Name | Description
TColumnLocked | Represents type TColumnLocked.
TColumnTextAlign | Represents type TColumnTextAlign.
TIndicatorState | Represents type TIndicatorState.
Top


TColumnLocked Enumeration

Summary

Represents type TColumnLocked.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnLocked=(None,Left,Right);

The TColumnLocked type exposes the following members.

Members
Show:
Name | Description
Left | Represents constant Left.
None | Represents constant None.
Right | Represents constant Right.
Top
See Also

Reference

  • Tee.Grid.Columns


TColumnTextAlign Enumeration

Summary

Represents type TColumnTextAlign.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnTextAlign=(Automatic,Custom);

The TColumnTextAlign type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Custom | Represents constant Custom.
Top
See Also

Reference

  • Tee.Grid.Columns


TIndicatorState Enumeration

Summary

Represents type TIndicatorState.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TIndicatorState=(Browse,Edit,Insert);

The TIndicatorState type exposes the following members.

Members
Show:
Name | Description
Browse | Represents constant Browse.
Edit | Represents constant Edit.
Insert | Represents constant Insert.
Top
See Also

Reference

  • Tee.Grid.Columns


Tee.Grid.Columns Delegates

Delegates
Name | Description
TColumnEvent | Represents type TColumnEvent.
TColumnMovedEvent | Represents type TColumnMovedEvent.
TColumnPaintEvent | Represents type TColumnPaintEvent.
TColumns.TGetFieldsEvent | Represents type TGetFieldsEvent.
TColumns.TSetFieldEvent | Represents type TSetFieldEvent.
Top


TColumnEvent Delegate

Summary

Represents type TColumnEvent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnEvent=procedure(Sender:TObject; const AColumn:TColumn) of object;
See Also

Reference

  • Tee.Grid.Columns


TColumnMovedEvent Delegate

Summary

Represents type TColumnMovedEvent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnMovedEvent=procedure(const AColumn:TColumn; const AOld,ANew:Integer) of object;
See Also

Reference

  • Tee.Grid.Columns


TColumnPaintEvent Delegate

Summary

Represents type TColumnPaintEvent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
type
 TColumnPaintEvent=procedure(const Sender:TColumn; var AData:TRenderData; var DefaultPaint:Boolean) of object;
See Also

Reference

  • Tee.Grid.Columns


TColumns.TGetFieldsEvent Delegate

Summary

Represents type TGetFieldsEvent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
type
 TGetFieldsEvent=function:TColumns of object;
See Also

Reference

  • TColumns
  • Tee.Grid.Columns


TColumns.TSetFieldEvent Delegate

Summary

Represents type TSetFieldEvent.

Namespace: Tee.Grid.Columns
Syntax
Delphi
protected
type
 TSetFieldEvent=procedure(const AColumn:TColumn; const ASource:TObject) of object;
See Also

Reference

  • TColumns
  • Tee.Grid.Columns


Tee.Grid.CSV Namespace

Summary

Represents namespace Tee.Grid.CSV.

Records
Name | Description
TCSVData | Represents type TCSVData.
Top


Tee.Grid.CSV Records

Records
Name | Description
TCSVData | Represents type TCSVData.
Top


TCSVData Record

Summary

Represents type TCSVData.

Namespace: Tee.Grid.CSV
Syntax
Delphi
type
 TCSVData=record
 end;

The TCSVData type exposes the following members.

Methods
Show:
Name | Description
From(TCustomTeeGrid,TGridSelection,String,String,String) | Represents method From(TCustomTeeGrid,TGridSelection,String,String,String).
Top
See Also

Reference

  • Tee.Grid.CSV


TCSVData Methods

Methods
Name | Description
From(TCustomTeeGrid,TGridSelection,String,String,String) | Represents method From(TCustomTeeGrid,TGridSelection,String,String,String).
Top


TCSVData.From(TCustomTeeGrid,TGridSelection,String,String,String) Method

Summary

Represents method From(TCustomTeeGrid,TGridSelection,String,String,String).

Namespace: Tee.Grid.CSV
Syntax
Delphi
public
 class function From(const AGrid:TCustomTeeGrid;
 const ASelected:TGridSelection=nil;
 const ASeparator:String=',';
 const ALineFeed:String=#13#10;
 const ADelimiter:String='"'):String; static;

Parameters

AGrid
Type: TCustomTeeGrid

ASelected
Type: TGridSelection

ASeparator
Type: String

ALineFeed
Type: String

ADelimiter
Type: String

Return Value

Type: String

See Also

Reference

  • TCSVData
  • Tee.Grid.CSV


Tee.Grid.Header Namespace

Summary

Represents namespace Tee.Grid.Header.

Classes
Name | Description
TColumnHeaderBand | Represents type TColumnHeaderBand.
TSortableHeader | Represents type TSortableHeader.
Top
Enumerations
Name | Description
TSortState | Represents type TSortState.
Top
Delegates
Name | Description
TCanSortEvent | Represents type TCanSortEvent.
TSortStateEvent | Represents type TSortStateEvent.
Top
Types
Name | Description
TSortByEvent | Represents an alias of the TColumnEvent type.
Top


Tee.Grid.Header Classes

Classes
Name | Description
TColumnHeaderBand | Represents type TColumnHeaderBand.
TSortableHeader | Represents type TSortableHeader.
Top


TColumnHeaderBand Class

Summary

Represents type TColumnHeaderBand.

Namespace: Tee.Grid.Header
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Header.TColumnHeaderBand
Syntax
Delphi
type
 TColumnHeaderBand=class(TCustomColumnBand)
 end;

The TColumnHeaderBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnHeaderBand class. (Overrides TCustomColumnBand.Create(TCollection).)
Destroy | Represents the destructor of the TColumnHeaderBand class. (Overrides TCustomColumnBand.Destroy.)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
RowLines | Represents property RowLines.
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Sortable | Represents property Sortable.
SortRender | Represents property SortRender.
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn).
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
CanSort(TColumn) | Represents method CanSort(TColumn).
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Overrides TGridBand.Description.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Overrides TCustomColumnBand.DoClick.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Overrides TCustomColumnBand.DoDrawText(TRenderData,TColumn,Integer).)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TCustomColumnBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Overrides TCustomColumnBand.RenderSize.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Inherited from TCustomColumnBand.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.Header


TColumnHeaderBand Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnHeaderBand class. (Overrides TCustomColumnBand.Create(TCollection).)
Destroy | Represents the destructor of the TColumnHeaderBand class. (Overrides TCustomColumnBand.Destroy.)
Top


TColumnHeaderBand.Create(TCollection) Constructor

Summary

Initializes a new instance of the TColumnHeaderBand class.

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TCustomColumnBand.Create(TCollection)
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.Destroy Destructor

Summary

Represents the destructor of the TColumnHeaderBand class.

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TCustomColumnBand.Destroy
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand Properties

Properties
Name | Description
RowLines | Represents property RowLines.
Sortable | Represents property Sortable.
SortRender | Represents property SortRender.
Top


TColumnHeaderBand.RowLines Property

Summary

Represents property RowLines.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property RowLines:TStroke read FRowLines write SetRowLines;

Property Value

Type: TStroke

See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.Sortable Property

Summary

Represents property Sortable.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property Sortable:Boolean read FSortable write SetSortable default True;

Property Value

Type: Boolean

See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.SortRender Property

Summary

Represents property SortRender.

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 property SortRender:TRender read FSortRender write SetSortRender;

Property Value

Type: TRender

See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand Methods

Methods
Name | Description
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn).
CanSort(TColumn) | Represents method CanSort(TColumn).
Description | Represents method Description. (Overrides TGridBand.Description.)
DoClick | Represents method DoClick. (Overrides TCustomColumnBand.DoClick.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Overrides TCustomColumnBand.DoDrawText(TRenderData,TColumn,Integer).)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TCustomColumnBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
RenderSize | Represents method RenderSize. (Overrides TCustomColumnBand.RenderSize.)
Top


TColumnHeaderBand.AsString(TColumn) Method

Summary

Represents method AsString(TColumn).

Namespace: Tee.Grid.Header
Syntax
Delphi
protected
 function AsString(const AColumn:TColumn):String; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

Overrides

TCustomColumnBand.AsString(TColumn)
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.AutoWidth(TPainter,TColumn) Method

Summary

Represents method AutoWidth(TPainter,TColumn).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 function AutoWidth(const APainter:TPainter; const AColumn:TColumn):Single;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.CanSort(TColumn) Method

Summary

Represents method CanSort(TColumn).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 function CanSort(const AColumn:TColumn):Boolean;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 class function Description:String; override;

Return Value

Type: String

Overrides

TGridBand.Description
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.DoClick Method

Summary

Represents method DoClick.

Namespace: Tee.Grid.Header
Syntax
Delphi
protected
 procedure DoClick; override;

Overrides

TCustomColumnBand.DoClick
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.DoDrawText(TRenderData,TColumn,Integer) Method

Summary

Represents method DoDrawText(TRenderData,TColumn,Integer).

Namespace: Tee.Grid.Header
Syntax
Delphi
protected
 procedure DoDrawText(var AData:TRenderData;
 const AColumn:TColumn;
 const ALevel:Integer); override;

Parameters

AData
Type: TRenderData

AColumn
Type: TColumn

ALevel
Type: Integer

Overrides

TCustomColumnBand.DoDrawText(TRenderData,TColumn,Integer)
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.Mouse(TMouseState,Single,Single) Method

Summary

Represents method Mouse(TMouseState,Single,Single).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 function Mouse(var AState:TMouseState; const AWidth,AHeight:Single):Boolean; override;

Parameters

AState
Type: TMouseState

AWidth
Type: Single

AHeight
Type: Single

Return Value

Type: Boolean

Overrides

TCustomColumnBand.Mouse(TMouseState,Single,Single)
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TCustomColumnBand.Paint(TRenderData,TRender)
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TColumnHeaderBand.RenderSize Method

Summary

Represents method RenderSize.

Namespace: Tee.Grid.Header
Syntax
Delphi
protected
 function RenderSize:Single; override;

Return Value

Type: Single

Overrides

TCustomColumnBand.RenderSize
See Also

Reference

  • TColumnHeaderBand
  • Tee.Grid.Header


TSortableHeader Class

Summary

Represents type TSortableHeader.

Namespace: Tee.Grid.Header
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Grid.Header.TSortableHeader
Syntax
Delphi
type
 TSortableHeader=class(TFormatRender)
 end;

The TSortableHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSortableHeader class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
OnSortBy | Represents property OnSortBy.
Size | Represents property Size.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TFormatRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
Top
Events
Show:
Name | Description
OnCanSort | Represents property OnCanSort.
OnSortState | Represents property OnSortState.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Header


TSortableHeader Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSortableHeader class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TSortableHeader.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TSortableHeader class.

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader Properties

Properties
Name | Description
OnSortBy | Represents property OnSortBy.
Size | Represents property Size.
Top


TSortableHeader.OnSortBy Property

Summary

Represents property OnSortBy.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property OnSortBy:TSortByEvent read FOnSortBy write FOnSortBy;

Property Value

Type: TSortByEvent

See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader.Size Property

Summary

Represents property Size.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property Size:Single read FSize write SetSize stored IsSizeStored;

Property Value

Type: Single

See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader Methods

Methods
Name | Description
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Top


TSortableHeader.Hit(TRectF,Single,Single) Method

Summary

Represents method Hit(TRectF,Single,Single).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 function Hit(const R:TRectF; const X,Y:Single):Boolean; override;

Parameters

R
Type: TRectF

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

Overrides

TRender.Hit(TRectF,Single,Single)
See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Grid.Header
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TFormatRender.Paint(TRenderData)
See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader Events

Events
Name | Description
OnCanSort | Represents property OnCanSort.
OnSortState | Represents property OnSortState.
Top


TSortableHeader.OnCanSort Event

Summary

Represents property OnCanSort.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property OnCanSort:TCanSortEvent read FOnCanSort write FOnCanSort;

Value

Type: TCanSortEvent

See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


TSortableHeader.OnSortState Event

Summary

Represents property OnSortState.

Namespace: Tee.Grid.Header
Syntax
Delphi
published
 property OnSortState:TSortStateEvent read FOnSortState write FOnSortState;

Value

Type: TSortStateEvent

See Also

Reference

  • TSortableHeader
  • Tee.Grid.Header


Tee.Grid.Header Enumerations

Enumerations
Name | Description
TSortState | Represents type TSortState.
Top


TSortState Enumeration

Summary

Represents type TSortState.

Namespace: Tee.Grid.Header
Syntax
Delphi
type
 TSortState=(None,Ascending,Descending);

The TSortState type exposes the following members.

Members
Show:
Name | Description
Ascending | Represents constant Ascending.
Descending | Represents constant Descending.
None | Represents constant None.
Top
See Also

Reference

  • Tee.Grid.Header


Tee.Grid.Header Delegates

Delegates
Name | Description
TCanSortEvent | Represents type TCanSortEvent.
TSortStateEvent | Represents type TSortStateEvent.
Top


TCanSortEvent Delegate

Summary

Represents type TCanSortEvent.

Namespace: Tee.Grid.Header
Syntax
Delphi
type
 TCanSortEvent=procedure(const AColumn:TColumn; var CanSort:Boolean) of object;
See Also

Reference

  • Tee.Grid.Header


TSortStateEvent Delegate

Summary

Represents type TSortStateEvent.

Namespace: Tee.Grid.Header
Syntax
Delphi
type
 TSortStateEvent=procedure(const AColumn:TColumn; var State:TSortState) of object;
See Also

Reference

  • Tee.Grid.Header


Tee.Grid.Header Types

Types
Name | Description
TSortByEvent | Represents an alias of the TColumnEvent type.
Top


TSortByEvent Type

Summary

Represents an alias of the TColumnEvent type.

Namespace: Tee.Grid.Header
Syntax
Delphi
type
 TSortByEvent=TColumnEvent;
See Also

Reference

  • Tee.Grid.Header


Tee.Grid.JSON Namespace

Summary

Represents namespace Tee.Grid.JSON.

Records
Name | Description
TJSONData | Represents type TJSONData.
Top


Tee.Grid.JSON Records

Records
Name | Description
TJSONData | Represents type TJSONData.
Top


TJSONData Record

Summary

Represents type TJSONData.

Namespace: Tee.Grid.JSON
Syntax
Delphi
type
 TJSONData=record
 end;

The TJSONData type exposes the following members.

Methods
Show:
Name | Description
From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String) | Represents method From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String).
Top
See Also

Reference

  • Tee.Grid.JSON


TJSONData Methods

Methods
Name | Description
From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String) | Represents method From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String).
Top


TJSONData.From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String) Method

Summary

Represents method From(TCustomTeeGrid,TGridSelection,Boolean,String,String,String).

Namespace: Tee.Grid.JSON
Syntax
Delphi
public
 class function From(const AGrid:TCustomTeeGrid;
 const ASelected:TGridSelection=nil;
 const AObjectOnly:Boolean = False;
 const ATabSpace:String= '  ';
 const ALineFeed:String=#13#10;
 const ADelimiter:String='"'):String; static;

Parameters

AGrid
Type: TCustomTeeGrid

ASelected
Type: TGridSelection

AObjectOnly
Type: Boolean

ATabSpace
Type: String

ALineFeed
Type: String

ADelimiter
Type: String

Return Value

Type: String

See Also

Reference

  • TJSONData
  • Tee.Grid.JSON


Tee.Grid.RowGroup Namespace

Summary

Represents namespace Tee.Grid.RowGroup.

Classes
Name | Description
TBandHeightAccess | Represents type TBandHeightAccess.
TColumnAccess | Represents type TColumnAccess.
TColumnsAccess | Represents type TColumnsAccess.
TColumnWidthAccess | Represents type TColumnWidthAccess.
TCustomColumnBandAccess | Represents type TCustomColumnBandAccess.
TDataAccess | Represents type TDataAccess.
TGridFooter | Represents type TGridFooter.
TGridScrolling | Represents type TGridScrolling.
TGridSelectionAccess | Represents type TGridSelectionAccess.
TRowGroup | Represents type TRowGroup.
TRowsAccess | Represents type TRowsAccess.
TTextRenderAccess | Represents type TTextRenderAccess.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top
Enumerations
Name | Description
TScrollDirection | Represents type TScrollDirection.
TScrollingMode | Represents type TScrollingMode.
Top
Delegates
Name | Description
TNewDetailEvent | Represents type TNewDetailEvent.
TRowGroup.TLimitScrollEvent | Represents type TLimitScrollEvent.
Top


Tee.Grid.RowGroup Classes

Classes
Name | Description
TBandHeightAccess | Represents type TBandHeightAccess.
TColumnAccess | Represents type TColumnAccess.
TColumnsAccess | Represents type TColumnsAccess.
TColumnWidthAccess | Represents type TColumnWidthAccess.
TCustomColumnBandAccess | Represents type TCustomColumnBandAccess.
TDataAccess | Represents type TDataAccess.
TGridFooter | Represents type TGridFooter.
TGridScrolling | Represents type TGridScrolling.
TGridSelectionAccess | Represents type TGridSelectionAccess.
TRowGroup | Represents type TRowGroup.
TRowsAccess | Represents type TRowsAccess.
TTextRenderAccess | Represents type TTextRenderAccess.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top


TBandHeightAccess Class

Summary

Represents type TBandHeightAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Bands.TBandHeight
Tee.Grid.RowGroup.TBandHeightAccess
Syntax
Delphi
type
 TBandHeightAccess=class(TBandHeight);

The TBandHeightAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Columns.TColumn
Tee.Grid.RowGroup.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);

The TColumnAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumn class. (Overrides TVisibleRenderItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
DataFormat | Represents property DataFormat. (Inherited from TColumn.)
DefaultHorizAlign | Represents property DefaultHorizAlign. (Inherited from TColumn.)
Expanded | Represents property Expanded. (Inherited from TColumn.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header. (Inherited from TColumn.)
Items | Represents property Items. (Inherited from TColumn.)
LoadOrder | Represents property LoadOrder. (Inherited from TColumn.)
Locked | Represents property Locked. (Inherited from TColumn.)
Margins | Represents property Margins. (Inherited from TColumn.)
Parent | Represents property Parent. (Inherited from TColumn.)
ParentFormat | Represents property ParentFormat. (Inherited from TColumn.)
ReadOnly | Represents property ReadOnly. (Inherited from TColumn.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Selectable | Represents property Selectable. (Inherited from TColumn.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
TextAlign | Represents property TextAlign. (Inherited from TColumn.)
TextAlignment | Represents property TextAlignment. (Inherited from TColumn.)
TopParent | Represents property TopParent. (Inherited from TColumn.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Width | Represents property Width. (Inherited from TColumn.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
AutoWidth(TPainter) | Represents method AutoWidth(TPainter). (Inherited from TColumn.)
CanDisplay | Represents method CanDisplay. (Inherited from TColumn.)
Changed(TObject) | Represents method Changed(TObject). (Inherited from TVisibleRenderItem.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TColumn.)
DoChanged | Represents method DoChanged. (Overrides TVisibleRenderItem.DoChanged.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasItems | Represents method HasItems. (Inherited from TColumn.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
HorizAlign | Represents method HorizAlign. (Inherited from TColumn.)
InitAlign(THorizontalAlign) | Represents method InitAlign(THorizontalAlign). (Inherited from TColumn.)
Level | Represents method Level. (Inherited from TColumn.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
ParentColumns | Represents method ParentColumns. (Inherited from TColumn.)
Right | Represents method Right. (Inherited from TColumn.)
SetIndex(Integer) | Represents method SetIndex(Integer). (Inherited from TColumn.)
SetRender(TRender) | Represents method SetRender(TRender). (Overrides TVisibleRenderItem.SetRender(TRender).)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToString | Represents method ToString. (Inherited from TColumn.)
Top
Events
Show:
Name | Description
OnPaint | Represents property OnPaint. (Inherited from TColumn.)
Top
Fields
Show:
Name | Description
EditorClass | Represents field EditorClass. (Inherited from TColumn.)
FLink | Represents field FLink. (Inherited from TColumn.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
ITopParent | Represents field ITopParent. (Inherited from TColumn.)
Left | Represents field Left. (Inherited from TColumn.)
ValidWidth | Represents field ValidWidth. (Inherited from TColumn.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TColumnsAccess Class

Summary

Represents type TColumnsAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Columns.TColumns
Tee.Grid.RowGroup.TColumnsAccess
Syntax
Delphi
type
 TColumnsAccess=class(TColumns);

The TColumnsAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent,TCollectionItemClass) | Initializes a new instance of the TColumns class. (Inherited from TColumns.)
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer]. (Inherited from TColumns.)
Items[String] | Represents property Items[String]. (Inherited from TColumns.)
LoadOrder[Integer] | Represents property LoadOrder[Integer]. (Inherited from TColumns.)
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Parent | Represents property Parent. (Inherited from TColumns.)
Spacing | Represents property Spacing. (Inherited from TColumns.)
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add. (Inherited from TColumns.)
Add(String) | Overloaded. Represents method Add(String). (Inherited from TColumns.)
AnyPercentWidth | Represents method AnyPercentWidth. (Inherited from TColumns.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TColumns.)
DoChanged(TObject) | Represents method DoChanged(TObject). (Overrides TCollectionChange.DoChanged(TObject).)
FindAt(Single,Single) | Represents method FindAt(Single,Single). (Inherited from TColumns.)
FindFirst(String) | Represents method FindFirst(String). (Inherited from TColumns.)
FirstVisible | Represents method FirstVisible. (Inherited from TColumns.)
GetEnumerator | Represents method GetEnumerator. (Inherited from TColumns.)
HasSpacing | Represents method HasSpacing. (Inherited from TColumns.)
LevelCount | Represents method LevelCount. (Inherited from TColumns.)
Moved(TColumn,Integer,Integer) | Represents method Moved(TColumn,Integer,Integer). (Inherited from TColumns.)
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Events
Show:
Name | Description
OnMoved | Represents property OnMoved. (Inherited from TColumns.)
Top
Fields
Show:
Name | Description
FLoadOrderItems | Represents field FLoadOrderItems. (Inherited from TColumns.)
IsDefault | Represents field IsDefault. (Inherited from TColumns.)
OnGetFields | Represents field OnGetFields. (Inherited from TColumns.)
OnSetField | Represents field OnSetField. (Inherited from TColumns.)
ValidWidth | Represents field ValidWidth. (Inherited from TColumns.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TColumnWidthAccess Class

Summary

Represents type TColumnWidthAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Columns.TColumnWidth
Tee.Grid.RowGroup.TColumnWidthAccess
Syntax
Delphi
type
 TColumnWidthAccess=class(TColumnWidth);

The TColumnWidthAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TCustomColumnBandAccess Class

Summary

Represents type TCustomColumnBandAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.RowGroup.TCustomColumnBandAccess
Syntax
Delphi
type
 TCustomColumnBandAccess=class(TCustomColumnBand);

The TCustomColumnBandAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomColumnBand class. (Overrides TGridBandLines.Create(TCollection).)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Inherited from TCustomColumnBand.)
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Inherited from TCustomColumnBand.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Inherited from TCustomColumnBand.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Inherited from TCustomColumnBand.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Inherited from TCustomColumnBand.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.RowGroup.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TVirtualData);

The TDataAccess type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Inherited from TVirtualData.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Inherited from TVirtualData.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TGridFooter Class

Summary

Represents type TGridFooter.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Bands.TGridBands
Tee.Grid.RowGroup.TGridFooter
Syntax
Delphi
type
 TGridFooter=class(TGridBands)
 end;

The TGridFooter type exposes the following members.

Constants
Show:
Name | Description
Spacing | Represents constant Spacing. (Inherited from TGridBands.)
Top
Constructors
Show:
Name | Description
Create(TPersistent,TNotifyEvent) | Initializes a new instance of the TGridBands class. (Inherited from TGridBands.)
Top
Properties
Show:
Name | Description
Floating | Represents property Floating.
Items[Integer] | Represents property Items[Integer]. (Inherited from TGridBands.)
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Visible | Represents property Visible. (Inherited from TGridBands.)
Top
Methods
Show:
Name | Description
AddText(String) | Represents method AddText(String). (Inherited from TGridBands.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBands.Assign(TPersistent).)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBands.)
CanDisplay | Represents method CanDisplay. (Inherited from TGridBands.)
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCollectionChange.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBands.)
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Inherited from TCollectionChange.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Inherited from TGridBands.)
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Fields
Show:
Name | Description
Height | Represents field Height. (Inherited from TGridBands.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TGridFooter Properties

Properties
Name | Description
Floating | Represents property Floating.
Top


TGridFooter.Floating Property

Summary

Represents property Floating.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Floating:Boolean read FFloating write SetFloating default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridFooter
  • Tee.Grid.RowGroup


TGridFooter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBands.Assign(TPersistent).)
Top


TGridFooter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGridBands.Assign(TPersistent)
See Also

Reference

  • TGridFooter
  • Tee.Grid.RowGroup


TGridScrolling Class

Summary

Represents type TGridScrolling.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.RowGroup.TGridScrolling
Syntax
Delphi
type
 TGridScrolling=class(TPersistentChange)
 end;

The TGridScrolling type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class. (Inherited from TPersistentChange.)
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
Mode | Represents property Mode.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Vertical | Represents property Vertical.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Top
Fields
Show:
Name | Description
Active | Represents field Active.
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Origin | Represents field Origin.
Scroll | Represents field Scroll.
Scrolled | Represents field Scrolled.
Top
See Also

Reference

  • Tee.Grid.RowGroup


TGridScrolling Properties

Properties
Name | Description
Horizontal | Represents property Horizontal.
Mode | Represents property Mode.
Vertical | Represents property Vertical.
Top


TGridScrolling.Horizontal Property

Summary

Represents property Horizontal.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Horizontal:TScrollDirection read FHorizontal write SetHorizontal default TScrollDirection.Normal;

Property Value

Type: TScrollDirection

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling.Mode Property

Summary

Represents property Mode.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Mode:TScrollingMode read FMode write FMode default TScrollingMode.Touch;

Property Value

Type: TScrollingMode

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling.Vertical Property

Summary

Represents property Vertical.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Vertical:TScrollDirection read FVertical write SetVertical default TScrollDirection.Normal;

Property Value

Type: TScrollDirection

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TGridScrolling.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling Fields

Fields
Name | Description
Active | Represents field Active.
Origin | Represents field Origin.
Scroll | Represents field Scroll.
Scrolled | Represents field Scrolled.
Top


TGridScrolling.Active Field

Summary

Represents field Active.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 Active : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling.Origin Field

Summary

Represents field Origin.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 Origin : TPointF;

Field Value

Type: TPointF

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling.Scroll Field

Summary

Represents field Scroll.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 Scroll : TPointF;

Field Value

Type: TPointF

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridScrolling.Scrolled Field

Summary

Represents field Scrolled.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 Scrolled : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGridScrolling
  • Tee.Grid.RowGroup


TGridSelectionAccess Class

Summary

Represents type TGridSelectionAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Selection.TGridSelection
Tee.Grid.RowGroup.TGridSelectionAccess
Syntax
Delphi
type
 TGridSelectionAccess=class(TGridSelection);

The TGridSelectionAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridSelection class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Column | Represents property Column. (Inherited from TGridSelection.)
Format | Represents property Format. (Inherited from TFormatRender.)
FullRow | Represents property FullRow. (Inherited from TGridSelection.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TGridSelection.)
ParentFont | Represents property ParentFont. (Inherited from TGridSelection.)
Range | Represents property Range. (Inherited from TGridSelection.)
Row | Represents property Row. (Inherited from TGridSelection.)
ScrollToView | Represents property ScrollToView. (Inherited from TGridSelection.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
UnFocused | Represents property UnFocused. (Inherited from TGridSelection.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Change(TColumn,Integer) | Represents method Change(TColumn,Integer). (Inherited from TGridSelection.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Clear | Represents method Clear. (Inherited from TGridSelection.)
GetColumns(TVisibleColumns,Integer,Integer) | Represents method GetColumns(TVisibleColumns,Integer,Integer). (Inherited from TGridSelection.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
InitFormat | Represents method InitFormat. (Inherited from TGridSelection.)
IsEmpty | Represents method IsEmpty. (Inherited from TGridSelection.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
PaintColumn(TRenderData,TColumn,TFont,Boolean) | Represents method PaintColumn(TRenderData,TColumn,TFont,Boolean). (Inherited from TGridSelection.)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
TryRange(TColumn,Integer,Single) | Represents method TryRange(TColumn,Integer,Single). (Inherited from TGridSelection.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
Dragging | Represents field Dragging. (Inherited from TGridSelection.)
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
PreviousRow | Represents field PreviousRow. (Inherited from TGridSelection.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TRowGroup Class

Summary

Represents type TRowGroup.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.RowGroup.TRowGroup
Tee.Grid.TRowGroupAccess
Syntax
Delphi
type
 TRowGroup=class(TGridBand)
 end;

The TRowGroup type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection,TVirtualData) | Initializes a new instance of the TRowGroup class.
Destroy | Represents the destructor of the TRowGroup class. (Overrides TGridBand.Destroy.)
Top
Properties
Show:
Name | Description
Cells | Represents property Cells.
Columns | Represents property Columns.
Current | Represents property Current.
Data | Represents property Data.
Footer | Represents property Footer.
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header.
Headers | Represents property Headers.
Height | Represents property Height. (Inherited from TGridBand.)
Indicator | Represents property Indicator.
Margins | Represents property Margins.
OnChangedSelected | Represents property OnChangedSelected.
OnClick | Represents property OnClick. (Inherited from TGridBand.)
ReadOnly | Represents property ReadOnly.
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Rows | Represents property Rows.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoScroll | Represents method AutoScroll.
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
CalculateHeight(TRenderData) | Represents method CalculateHeight(TRenderData).
CanEditRender(TColumn) | Represents method CanEditRender(TColumn).
CanStartEditor | Represents method CanStartEditor.
CellRect(TColumn,Integer) | Overloaded. Represents method CellRect(TColumn,Integer).
CellRect(TGridSelection) | Overloaded. Represents method CellRect(TGridSelection).
CellRect(TPointF,TColumn,Integer) | Overloaded. Represents method CellRect(TPointF,TColumn,Integer).
CellRect(TSelectionRange) | Overloaded. Represents method CellRect(TSelectionRange).
CheckColumnsWidth(TPainter,Boolean,Single) | Represents method CheckColumnsWidth(TPainter,Boolean,Single).
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
Key(TKeyState) | Represents method Key(TKeyState).
Loaded | Represents method Loaded.
MaxBottom | Represents method MaxBottom.
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
NewExpander | Represents method NewExpander.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PrepareColumns(TPainter,Single,Single) | Represents method PrepareColumns(TPainter,Single,Single).
RefreshData(TVirtualData) | Represents method RefreshData(TVirtualData).
RenderHit(TColumn,Integer,Single,Single) | Represents method RenderHit(TColumn,Integer,Single,Single).
Scroll(Single,Single) | Represents method Scroll(Single,Single).
SelectedContains(Single,Single) | Overloaded. Represents method SelectedContains(Single,Single).
SelectedContains(TPoint) | Overloaded. Represents method SelectedContains(TPoint).
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToggleDetail(TRender,Integer) | Represents method ToggleDetail(TRender,Integer).
TryPaste(String) | Represents method TryPaste(String).
TrySelectColumn | Represents method TrySelectColumn.
Top
Events
Show:
Name | Description
OnNewDetail | Represents property OnNewDetail.
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
CheckLimits | Represents field CheckLimits.
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IsFocused | Represents field IsFocused.
MinColumnWidth | Represents field MinColumnWidth.
OwnsData | Represents field OwnsData.
ParentColumn | Represents field ParentColumn.
RecalcScrollBars | Represents field RecalcScrollBars.
Top | Represents field Top. (Inherited from TGridBand.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TRowGroup Constructors

Constructors
Name | Description
Create(TCollection,TVirtualData) | Initializes a new instance of the TRowGroup class.
Destroy | Represents the destructor of the TRowGroup class. (Overrides TGridBand.Destroy.)
Top


TRowGroup.Create(TCollection,TVirtualData) Constructor

Summary

Initializes a new instance of the TRowGroup class.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 Constructor Create(const ACollection:TCollection;
 const AData:TVirtualData); reintroduce;

Parameters

ACollection
Type: TCollection

AData
Type: TVirtualData

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Destroy Destructor

Summary

Represents the destructor of the TRowGroup class.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGridBand.Destroy
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup Properties

Properties
Name | Description
Cells | Represents property Cells.
Columns | Represents property Columns.
Current | Represents property Current.
Data | Represents property Data.
Footer | Represents property Footer.
Header | Represents property Header.
Headers | Represents property Headers.
Indicator | Represents property Indicator.
Margins | Represents property Margins.
OnChangedSelected | Represents property OnChangedSelected.
ReadOnly | Represents property ReadOnly.
Rows | Represents property Rows.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
Top


TRowGroup.Cells Property

Summary

Represents property Cells.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Cells:TTextRender read GetCells write SetCells;

Property Value

Type: TTextRender

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Columns Property

Summary

Represents property Columns.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 property Columns:TColumns read FColumns;

Property Value

Type: TColumns

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Current Property

Summary

Represents property Current.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 property Current:TRowGroup read FCurrent write SetCurrent;

Property Value

Type: TRowGroup

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Data Property

Summary

Represents property Data.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 property Data:TVirtualData read GetData;

Property Value

Type: TVirtualData

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Footer Property

Summary

Represents property Footer.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Footer:TGridFooter read GetFooter write SetFooter stored False;

Property Value

Type: TGridFooter

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Header Property

Summary

Represents property Header.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Header:TColumnHeaderBand read FHeader write SetHeader;

Property Value

Type: TColumnHeaderBand

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Headers Property

Summary

Represents property Headers.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Headers:TGridBands read GetHeaders write SetHeaders stored False;

Property Value

Type: TGridBands

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Indicator Property

Summary

Represents property Indicator.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Indicator:TIndicator read FIndicator write SetIndicator;

Property Value

Type: TIndicator

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Margins Property

Summary

Represents property Margins.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Margins:TMargins read GetMargins write SetMargins;

Property Value

Type: TMargins

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.OnChangedSelected Property

Summary

Represents property OnChangedSelected.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property OnChangedSelected:TNotifyEvent read FOnChangedSelected write FOnChangedSelected;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property ReadOnly:Boolean read FReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Rows Property

Summary

Represents property Rows.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Rows:TRows read FRows write SetRows;

Property Value

Type: TRows

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Scrolling Property

Summary

Represents property Scrolling.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Scrolling:TGridScrolling read FScrolling write SetScrolling;

Property Value

Type: TGridScrolling

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Selected Property

Summary

Represents property Selected.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property Selected:TGridSelection read FSelected write SetSelected;

Property Value

Type: TGridSelection

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoScroll | Represents method AutoScroll.
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
CalculateHeight(TRenderData) | Represents method CalculateHeight(TRenderData).
CanEditRender(TColumn) | Represents method CanEditRender(TColumn).
CanStartEditor | Represents method CanStartEditor.
CellRect(TColumn,Integer) | Overloaded. Represents method CellRect(TColumn,Integer).
CellRect(TGridSelection) | Overloaded. Represents method CellRect(TGridSelection).
CellRect(TPointF,TColumn,Integer) | Overloaded. Represents method CellRect(TPointF,TColumn,Integer).
CellRect(TSelectionRange) | Overloaded. Represents method CellRect(TSelectionRange).
CheckColumnsWidth(TPainter,Boolean,Single) | Represents method CheckColumnsWidth(TPainter,Boolean,Single).
Key(TKeyState) | Represents method Key(TKeyState).
Loaded | Represents method Loaded.
MaxBottom | Represents method MaxBottom.
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
NewExpander | Represents method NewExpander.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PrepareColumns(TPainter,Single,Single) | Represents method PrepareColumns(TPainter,Single,Single).
RefreshData(TVirtualData) | Represents method RefreshData(TVirtualData).
RenderHit(TColumn,Integer,Single,Single) | Represents method RenderHit(TColumn,Integer,Single,Single).
Scroll(Single,Single) | Represents method Scroll(Single,Single).
SelectedContains(Single,Single) | Overloaded. Represents method SelectedContains(Single,Single).
SelectedContains(TPoint) | Overloaded. Represents method SelectedContains(TPoint).
ToggleDetail(TRender,Integer) | Represents method ToggleDetail(TRender,Integer).
TryPaste(String) | Represents method TryPaste(String).
TrySelectColumn | Represents method TrySelectColumn.
Top


TRowGroup.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGridBand.Assign(TPersistent)
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.AutoScroll Method

Summary

Represents method AutoScroll.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure AutoScroll;
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CalcHeight(TPainter,Single) Method

Summary

Represents method CalcHeight(TPainter,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure CalcHeight(const APainter:TPainter; const ATotal:Single); override;

Parameters

APainter
Type: TPainter

ATotal
Type: Single

Overrides

TGridBand.CalcHeight(TPainter,Single)
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CalculateHeight(TRenderData) Method

Summary

Represents method CalculateHeight(TRenderData).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 procedure CalculateHeight(var AData:TRenderData);

Parameters

AData
Type: TRenderData

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CanEditRender(TColumn) Method

Summary

Represents method CanEditRender(TColumn).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CanEditRender(const AColumn:TColumn):Boolean;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CanStartEditor Method

Summary

Represents method CanStartEditor.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CanStartEditor:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CellRect(TColumn,Integer) Method

Summary

Represents method CellRect(TColumn,Integer).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CellRect(const AColumn: TColumn; const ARow: Integer): TRectF; overload; inline;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: TRectF

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CellRect(TGridSelection) Method

Summary

Represents method CellRect(TGridSelection).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CellRect(const ASelected:TGridSelection):TRectF; overload;

Parameters

ASelected
Type: TGridSelection

Return Value

Type: TRectF

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CellRect(TPointF,TColumn,Integer) Method

Summary

Represents method CellRect(TPointF,TColumn,Integer).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CellRect(const ATopLeft:TPointF; const AColumn:TColumn; const ARow:Integer):TRectF; overload;

Parameters

ATopLeft
Type: TPointF

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: TRectF

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CellRect(TSelectionRange) Method

Summary

Represents method CellRect(TSelectionRange).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function CellRect(const ARange: TSelectionRange): TRectF; overload;

Parameters

ARange
Type: TSelectionRange

Return Value

Type: TRectF

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.CheckColumnsWidth(TPainter,Boolean,Single) Method

Summary

Represents method CheckColumnsWidth(TPainter,Boolean,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure CheckColumnsWidth(const APainter:TPainter; const Forced:Boolean;
 const AWidth:Single);

Parameters

APainter
Type: TPainter

Forced
Type: Boolean

AWidth
Type: Single

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Key(TKeyState) Method

Summary

Represents method Key(TKeyState).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure Key(const AState:TKeyState);

Parameters

AState
Type: TKeyState

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Loaded Method

Summary

Represents method Loaded.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 procedure Loaded;
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.MaxBottom Method

Summary

Represents method MaxBottom.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function MaxBottom:Single;

Return Value

Type: Single

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Mouse(TMouseState,Single,Single) Method

Summary

Represents method Mouse(TMouseState,Single,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function Mouse(var AState:TMouseState; const AWidth,AHeight:Single): Boolean; override;

Parameters

AState
Type: TMouseState

AWidth
Type: Single

AHeight
Type: Single

Return Value

Type: Boolean

Overrides

TGridBand.Mouse(TMouseState,Single,Single)
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.NewExpander Method

Summary

Represents method NewExpander.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function NewExpander:TExpanderRender;

Return Value

Type: TExpanderRender

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TGridBand.Paint(TRenderData,TRender)
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.PrepareColumns(TPainter,Single,Single) Method

Summary

Represents method PrepareColumns(TPainter,Single,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure PrepareColumns(const APainter:TPainter; const ALeft,ARight:Single);

Parameters

APainter
Type: TPainter

ALeft
Type: Single

ARight
Type: Single

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.RefreshData(TVirtualData) Method

Summary

Represents method RefreshData(TVirtualData).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure RefreshData(const AData:TVirtualData);

Parameters

AData
Type: TVirtualData

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.RenderHit(TColumn,Integer,Single,Single) Method

Summary

Represents method RenderHit(TColumn,Integer,Single,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function RenderHit(const AColumn:TColumn; const ARow:Integer; const X,Y:Single):Boolean;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.Scroll(Single,Single) Method

Summary

Represents method Scroll(Single,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 function Scroll(const X,Y:Single):Boolean;

Parameters

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.SelectedContains(Single,Single) Method

Summary

Represents method SelectedContains(Single,Single).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function SelectedContains(const X,Y:Single):Boolean; overload;

Parameters

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.SelectedContains(TPoint) Method

Summary

Represents method SelectedContains(TPoint).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function SelectedContains(const P:TPoint): Boolean; overload; inline;

Parameters

P
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.ToggleDetail(TRender,Integer) Method

Summary

Represents method ToggleDetail(TRender,Integer).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 function ToggleDetail(const Sender:TRender; const ARow:Integer):Boolean;

Parameters

Sender
Type: TRender

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.TryPaste(String) Method

Summary

Represents method TryPaste(String).

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 procedure TryPaste(const AValue:String);

Parameters

AValue
Type: String

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.TrySelectColumn Method

Summary

Represents method TrySelectColumn.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 procedure TrySelectColumn;
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup Events

Events
Name | Description
OnNewDetail | Represents property OnNewDetail.
Top


TRowGroup.OnNewDetail Event

Summary

Represents property OnNewDetail.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
published
 property OnNewDetail:TNewDetailEvent read FOnNewDetail write FOnNewDetail;

Value

Type: TNewDetailEvent

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup Fields

Fields
Name | Description
CheckLimits | Represents field CheckLimits.
IsFocused | Represents field IsFocused.
MinColumnWidth | Represents field MinColumnWidth.
OwnsData | Represents field OwnsData.
ParentColumn | Represents field ParentColumn.
RecalcScrollBars | Represents field RecalcScrollBars.
Top


TRowGroup.CheckLimits Field

Summary

Represents field CheckLimits.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 CheckLimits : TLimitScrollEvent;

Field Value

Type: TLimitScrollEvent

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.IsFocused Field

Summary

Represents field IsFocused.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 IsFocused : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.MinColumnWidth Field

Summary

Represents field MinColumnWidth.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 MinColumnWidth : Single;

Field Value

Type: Single

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.OwnsData Field

Summary

Represents field OwnsData.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
 OwnsData : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.ParentColumn Field

Summary

Represents field ParentColumn.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 ParentColumn : TColumn;

Field Value

Type: TColumn

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowGroup.RecalcScrollBars Field

Summary

Represents field RecalcScrollBars.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
public
 RecalcScrollBars : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


TRowsAccess Class

Summary

Represents type TRowsAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Rows.TRows
Tee.Grid.RowGroup.TRowsAccess
Syntax
Delphi
type
 TRowsAccess=class(TRows);

The TRowsAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TRows class. (Overrides TGridBandLines.Create(TCollection).)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate. (Inherited from TRows.)
Back | Represents property Back. (Inherited from TRows.)
Children | Represents property Children. (Inherited from TRows.)
Data | Represents property Data. (Inherited from TRows.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TRows.)
Heights[Integer] | Represents property Heights[Integer]. (Inherited from TRows.)
Hover | Represents property Hover. (Inherited from TRows.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
RowLines | Represents property RowLines. (Inherited from TRows.)
Spacing | Represents property Spacing. (Inherited from TRows.)
SubBands | Represents property SubBands. (Inherited from TRows.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
VisibleColumns | Represents property VisibleColumns. (Inherited from TRows.)
YSpacing | Represents property YSpacing. (Inherited from TRows.)
Top
Methods
Show:
Name | Description
AllHeightsEqual | Represents method AllHeightsEqual. (Inherited from TRows.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoHeight(Integer) | Overloaded. Represents method AutoHeight(Integer). (Inherited from TRows.)
BottomOf(Integer) | Represents method BottomOf(Integer). (Inherited from TRows.)
CalcDefaultHeight | Represents method CalcDefaultHeight. (Inherited from TRows.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBand.)
CalcYSpacing(Single) | Represents method CalcYSpacing(Single). (Inherited from TRows.)
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single). (Inherited from TRows.)
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single). (Inherited from TRows.)
Clear | Represents method Clear. (Inherited from TRows.)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
Empty | Represents method Empty. (Inherited from TRows.)
FirstVisible(Single) | Represents method FirstVisible(Single). (Inherited from TRows.)
FontOf(TColumn) | Represents method FontOf(TColumn). (Inherited from TRows.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeightOf(Integer) | Represents method HeightOf(Integer). (Inherited from TRows.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
IsChildrenVisible(TRender,Integer) | Represents method IsChildrenVisible(TRender,Integer). (Inherited from TRows.)
MaxBottom | Represents method MaxBottom. (Inherited from TRows.)
MaxRight | Represents method MaxRight. (Inherited from TRows.)
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBand.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PaintLines(TRenderData,Integer,Single) | Represents method PaintLines(TRenderData,Integer,Single). (Inherited from TRows.)
PaintRow(TRenderData,TRender) | Represents method PaintRow(TRenderData,TRender). (Inherited from TRows.)
RowAt(Single,Single) | Represents method RowAt(Single,Single). (Inherited from TRows.)
SetColumnsLeft(Single,Single,Single) | Represents method SetColumnsLeft(Single,Single,Single). (Inherited from TRows.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Swap(Integer,Integer) | Represents method Swap(Integer,Integer). (Inherited from TRows.)
TopOf(Integer) | Represents method TopOf(Integer). (Inherited from TRows.)
TopOfRow(Integer) | Represents method TopOfRow(Integer). (Inherited from TRows.)
TotalHeight(Integer) | Represents method TotalHeight(Integer). (Inherited from TRows.)
UpToRowHeight(Integer) | Represents method UpToRowHeight(Integer). (Inherited from TRows.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FOnHorizScroll | Represents field FOnHorizScroll. (Inherited from TRows.)
FOnVertScroll | Represents field FOnVertScroll. (Inherited from TRows.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
Painter | Represents field Painter. (Inherited from TRows.)
Scroll | Represents field Scroll. (Inherited from TRows.)
Top | Represents field Top. (Inherited from TGridBand.)
XOffset | Represents field XOffset. (Inherited from TRows.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TTextRenderAccess Class

Summary

Represents type TTextRenderAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Grid.RowGroup.TTextRenderAccess
Syntax
Delphi
type
 TTextRenderAccess=class(TTextRender);

The TTextRenderAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


TVirtualDataAccess Class

Summary

Represents type TVirtualDataAccess.

Namespace: Tee.Grid.RowGroup
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.RowGroup.TVirtualDataAccess
Syntax
Delphi
type
 TVirtualDataAccess=class(TVirtualData);

The TVirtualDataAccess type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Inherited from TVirtualData.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Inherited from TVirtualData.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.Grid.RowGroup


Tee.Grid.RowGroup Enumerations

Enumerations
Name | Description
TScrollDirection | Represents type TScrollDirection.
TScrollingMode | Represents type TScrollingMode.
Top


TScrollDirection Enumeration

Summary

Represents type TScrollDirection.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
type
 TScrollDirection=(Normal,Inverted,Disabled);

The TScrollDirection type exposes the following members.

Members
Show:
Name | Description
Disabled | Represents constant Disabled.
Inverted | Represents constant Inverted.
Normal | Represents constant Normal.
Top
See Also

Reference

  • Tee.Grid.RowGroup


TScrollingMode Enumeration

Summary

Represents type TScrollingMode.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
type
 TScrollingMode=(Touch,Mouse,Both,None);

The TScrollingMode type exposes the following members.

Members
Show:
Name | Description
Both | Represents constant Both.
Mouse | Represents constant Mouse.
None | Represents constant None.
Touch | Represents constant Touch.
Top
See Also

Reference

  • Tee.Grid.RowGroup


Tee.Grid.RowGroup Delegates

Delegates
Name | Description
TNewDetailEvent | Represents type TNewDetailEvent.
TRowGroup.TLimitScrollEvent | Represents type TLimitScrollEvent.
Top


TNewDetailEvent Delegate

Summary

Represents type TNewDetailEvent.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
type
 TNewDetailEvent=procedure(const Sender,NewGroup:TRowGroup) of object;
See Also

Reference

  • Tee.Grid.RowGroup


TRowGroup.TLimitScrollEvent Delegate

Summary

Represents type TLimitScrollEvent.

Namespace: Tee.Grid.RowGroup
Syntax
Delphi
protected
type
 TLimitScrollEvent=procedure(var X,Y:Single) of object;
See Also

Reference

  • TRowGroup
  • Tee.Grid.RowGroup


Tee.Grid.Rows Namespace

Summary

Represents namespace Tee.Grid.Rows.

Classes
Name | Description
TAlternateFormat | Represents type TAlternateFormat.
TCellHover | Represents type TCellHover.
TCoordinateAccess | Represents type TCoordinateAccess.
TRows | Represents type TRows.
TRowsBands | Represents type TRowsBands.
TTextRenderAccess | Represents type TTextRenderAccess.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top


Tee.Grid.Rows Classes

Classes
Name | Description
TAlternateFormat | Represents type TAlternateFormat.
TCellHover | Represents type TCellHover.
TCoordinateAccess | Represents type TCoordinateAccess.
TRows | Represents type TRows.
TRowsBands | Represents type TRowsBands.
TTextRenderAccess | Represents type TTextRenderAccess.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top


TAlternateFormat Class

Summary

Represents type TAlternateFormat.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TFormat
Tee.Format.TVisibleFormat
Tee.Grid.Rows.TAlternateFormat
Syntax
Delphi
type
 TAlternateFormat=class(TVisibleFormat)
 end;

The TAlternateFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TAlternateFormat class. (Overrides TFormat.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Brush | Represents property Brush. (Inherited from TFormat.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Stroke | Represents property Stroke. (Inherited from TFormat.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TFormat.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide. (Inherited from TVisibleFormat.)
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisibleFormat.)
IsVisible | Represents method IsVisible.
ShouldPaint | Represents method ShouldPaint. (Inherited from TFormat.)
Show | Represents method Show. (Inherited from TVisibleFormat.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Rows


TAlternateFormat Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TAlternateFormat class. (Overrides TFormat.Create(TNotifyEvent).)
Top


TAlternateFormat.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TAlternateFormat class.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TFormat.Create(TNotifyEvent)
See Also

Reference

  • TAlternateFormat
  • Tee.Grid.Rows


TAlternateFormat Properties

Properties
Name | Description
Visible | Represents property Visible.
Top


TAlternateFormat.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Visible default False;

Property Value

Type: Void

See Also

Reference

  • TAlternateFormat
  • Tee.Grid.Rows


TAlternateFormat Methods

Methods
Name | Description
IsVisible | Represents method IsVisible.
Top


TAlternateFormat.IsVisible Method

Summary

Represents method IsVisible.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function IsVisible:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TAlternateFormat
  • Tee.Grid.Rows


TCellHover Class

Summary

Represents type TCellHover.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Selection.TGridSelection
Tee.Grid.Rows.TCellHover
Syntax
Delphi
type
 TCellHover=class(TGridSelection)
 end;

The TCellHover type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridSelection class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Column | Represents property Column. (Inherited from TGridSelection.)
Format | Represents property Format. (Inherited from TFormatRender.)
FullRow | Represents property FullRow. (Inherited from TGridSelection.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TGridSelection.)
ParentFont | Represents property ParentFont. (Inherited from TGridSelection.)
Range | Represents property Range. (Inherited from TGridSelection.)
Row | Represents property Row. (Inherited from TGridSelection.)
ScrollToView | Represents property ScrollToView. (Inherited from TGridSelection.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
UnFocused | Represents property UnFocused. (Inherited from TGridSelection.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Change(TColumn,Integer) | Represents method Change(TColumn,Integer). (Inherited from TGridSelection.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Clear | Represents method Clear. (Inherited from TGridSelection.)
GetColumns(TVisibleColumns,Integer,Integer) | Represents method GetColumns(TVisibleColumns,Integer,Integer). (Inherited from TGridSelection.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
IsEmpty | Represents method IsEmpty. (Inherited from TGridSelection.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
PaintColumn(TRenderData,TColumn,TFont,Boolean) | Represents method PaintColumn(TRenderData,TColumn,TFont,Boolean). (Inherited from TGridSelection.)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
TryRange(TColumn,Integer,Single) | Represents method TryRange(TColumn,Integer,Single). (Inherited from TGridSelection.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
Dragging | Represents field Dragging. (Inherited from TGridSelection.)
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
PreviousRow | Represents field PreviousRow. (Inherited from TGridSelection.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Rows


TCoordinateAccess Class

Summary

Represents type TCoordinateAccess.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TCoordinate
Tee.Grid.Rows.TCoordinateAccess
Syntax
Delphi
type
 TCoordinateAccess=class(TCoordinate);

The TCoordinateAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TCoordinate class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Automatic | Represents property Automatic. (Inherited from TCoordinate.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Pixels | Represents property Pixels. (Inherited from TCoordinate.)
Units | Represents property Units. (Inherited from TCoordinate.)
Value | Represents property Value. (Inherited from TCoordinate.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TCoordinate.)
Calculate(Single) | Represents method Calculate(Single). (Inherited from TCoordinate.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitValue(Single) | Represents method InitValue(Single). (Inherited from TCoordinate.)
Prepare(Single) | Represents method Prepare(Single). (Inherited from TCoordinate.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
IPixels | Represents field IPixels. (Inherited from TCoordinate.)
Top
See Also

Reference

  • Tee.Grid.Rows


TRows Class

Summary

Represents type TRows.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Rows.TRows
Tee.Grid.RowGroup.TRowsAccess
Tee.Grid.TRowsAccess
Syntax
Delphi
type
 TRows=class(TGridBandLines)
 end;

The TRows type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TRows class. (Overrides TGridBandLines.Create(TCollection).)
Destroy | Represents the destructor of the TRows class. (Overrides TGridBandLines.Destroy.)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate.
Back | Represents property Back.
Children | Represents property Children.
Data | Represents property Data.
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height.
Heights[Integer] | Represents property Heights[Integer].
Hover | Represents property Hover.
Lines | Represents property Lines. (Inherited from TGridBandLines.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
RowLines | Represents property RowLines.
Spacing | Represents property Spacing.
SubBands | Represents property SubBands.
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
VisibleColumns | Represents property VisibleColumns.
YSpacing | Represents property YSpacing.
Top
Methods
Show:
Name | Description
AllHeightsEqual | Represents method AllHeightsEqual.
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoHeight(Integer) | Overloaded. Represents method AutoHeight(Integer).
BottomOf(Integer) | Represents method BottomOf(Integer).
CalcDefaultHeight | Represents method CalcDefaultHeight.
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBand.)
CalcYSpacing(Single) | Represents method CalcYSpacing(Single).
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single).
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single).
Clear | Represents method Clear.
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
Empty | Represents method Empty.
FirstVisible(Single) | Represents method FirstVisible(Single).
FontOf(TColumn) | Represents method FontOf(TColumn).
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeightOf(Integer) | Represents method HeightOf(Integer).
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
IsChildrenVisible(TRender,Integer) | Represents method IsChildrenVisible(TRender,Integer).
MaxBottom | Represents method MaxBottom.
MaxRight | Represents method MaxRight.
Mouse(TMouseState,Single,Single) | Overloaded. Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBand.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PaintLines(TRenderData,Integer,Single) | Represents method PaintLines(TRenderData,Integer,Single).
PaintRow(TRenderData,TRender) | Represents method PaintRow(TRenderData,TRender).
RowAt(Single,Single) | Represents method RowAt(Single,Single).
SetColumnsLeft(Single,Single,Single) | Represents method SetColumnsLeft(Single,Single,Single).
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
TopOf(Integer) | Represents method TopOf(Integer).
TopOfRow(Integer) | Represents method TopOfRow(Integer).
TotalHeight(Integer) | Represents method TotalHeight(Integer).
UpToRowHeight(Integer) | Represents method UpToRowHeight(Integer).
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FOnHorizScroll | Represents field FOnHorizScroll.
FOnVertScroll | Represents field FOnVertScroll.
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
Painter | Represents field Painter.
Scroll | Represents field Scroll.
Top | Represents field Top. (Inherited from TGridBand.)
XOffset | Represents field XOffset.
Top
See Also

Reference

  • Tee.Grid.Rows


TRows Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TRows class. (Overrides TGridBandLines.Create(TCollection).)
Destroy | Represents the destructor of the TRows class. (Overrides TGridBandLines.Destroy.)
Top


TRows.Create(TCollection) Constructor

Summary

Initializes a new instance of the TRows class.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TGridBandLines.Create(TCollection)
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Destroy Destructor

Summary

Represents the destructor of the TRows class.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGridBandLines.Destroy
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows Properties

Properties
Name | Description
Alternate | Represents property Alternate.
Back | Represents property Back.
Children | Represents property Children.
Data | Represents property Data.
Height | Represents property Height.
Heights[Integer] | Represents property Heights[Integer].
Hover | Represents property Hover.
RowLines | Represents property RowLines.
Spacing | Represents property Spacing.
SubBands | Represents property SubBands.
VisibleColumns | Represents property VisibleColumns.
YSpacing | Represents property YSpacing.
Top


TRows.Alternate Property

Summary

Represents property Alternate.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Alternate:TAlternateFormat read FAlternate write SetAlternate;

Property Value

Type: TAlternateFormat

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Back Property

Summary

Represents property Back.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Back:TFormat read FBack write SetBack;

Property Value

Type: TFormat

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Children Property

Summary

Represents property Children.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property Children:TRowsBands read FChildren;

Property Value

Type: TRowsBands

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Data Property

Summary

Represents property Data.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property Data:TVirtualData read IData write IData;

Property Value

Type: TVirtualData

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Height Property

Summary

Represents property Height.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Height:TCoordinate read FHeight write SetHeight;

Property Value

Type: TCoordinate

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Heights[Integer] Property

Summary

Represents property Heights[Integer].

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property Heights[const Index:Integer]:Single read GetHeights write SetHeights;

Parameters

Index
Type: Integer

Property Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Hover Property

Summary

Represents property Hover.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Hover:TCellHover read FHover write SetHover;

Property Value

Type: TCellHover

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.RowLines Property

Summary

Represents property RowLines.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property RowLines:TStroke read FRowLines write SetRowLines;

Property Value

Type: TStroke

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Spacing Property

Summary

Represents property Spacing.

Namespace: Tee.Grid.Rows
Syntax
Delphi
published
 property Spacing:TCoordinate read FSpacing write SetSpacing;

Property Value

Type: TCoordinate

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.SubBands Property

Summary

Represents property SubBands.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property SubBands:TRowsBands read FSubBands;

Property Value

Type: TRowsBands

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.VisibleColumns Property

Summary

Represents property VisibleColumns.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property VisibleColumns:TVisibleColumns read FVisibleColumns;

Property Value

Type: TVisibleColumns

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.YSpacing Property

Summary

Represents property YSpacing.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property YSpacing:Single read ISpacing;

Property Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows Methods

Methods
Name | Description
AllHeightsEqual | Represents method AllHeightsEqual.
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AutoHeight(Integer) | Overloaded. Represents method AutoHeight(Integer).
BottomOf(Integer) | Represents method BottomOf(Integer).
CalcDefaultHeight | Represents method CalcDefaultHeight.
CalcYSpacing(Single) | Represents method CalcYSpacing(Single).
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single).
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single).
Clear | Represents method Clear.
Empty | Represents method Empty.
FirstVisible(Single) | Represents method FirstVisible(Single).
FontOf(TColumn) | Represents method FontOf(TColumn).
HeightOf(Integer) | Represents method HeightOf(Integer).
IsChildrenVisible(TRender,Integer) | Represents method IsChildrenVisible(TRender,Integer).
MaxBottom | Represents method MaxBottom.
MaxRight | Represents method MaxRight.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TGridBand.Paint(TRenderData,TRender).)
PaintLines(TRenderData,Integer,Single) | Represents method PaintLines(TRenderData,Integer,Single).
PaintRow(TRenderData,TRender) | Represents method PaintRow(TRenderData,TRender).
RowAt(Single,Single) | Represents method RowAt(Single,Single).
SetColumnsLeft(Single,Single,Single) | Represents method SetColumnsLeft(Single,Single,Single).
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
TopOf(Integer) | Represents method TopOf(Integer).
TopOfRow(Integer) | Represents method TopOfRow(Integer).
TotalHeight(Integer) | Represents method TotalHeight(Integer).
UpToRowHeight(Integer) | Represents method UpToRowHeight(Integer).
Top


TRows.AllHeightsEqual Method

Summary

Represents method AllHeightsEqual.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function AllHeightsEqual:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGridBand.Assign(TPersistent)
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.AutoHeight(Integer) Method

Summary

Represents method AutoHeight(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function AutoHeight(const ARow: Integer): Single; overload;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.BottomOf(Integer) Method

Summary

Represents method BottomOf(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function BottomOf(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.CalcDefaultHeight Method

Summary

Represents method CalcDefaultHeight.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure CalcDefaultHeight;
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.CalcYSpacing(Single) Method

Summary

Represents method CalcYSpacing(Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure CalcYSpacing(const AHeight:Single);

Parameters

AHeight
Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.ChangeHorizScroll(Single) Method

Summary

Represents method ChangeHorizScroll(Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 function ChangeHorizScroll(const Value:Single):Boolean;

Parameters

Value
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.ChangeVertScroll(Single) Method

Summary

Represents method ChangeVertScroll(Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 function ChangeVertScroll(const Value:Single):Boolean;

Parameters

Value
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Clear Method

Summary

Represents method Clear.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Empty Method

Summary

Represents method Empty.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function Empty:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.FirstVisible(Single) Method

Summary

Represents method FirstVisible(Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function FirstVisible(const AOffset:Single=0):Integer;

Parameters

AOffset
Type: Single

Return Value

Type: Integer

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.FontOf(TColumn) Method

Summary

Represents method FontOf(TColumn).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function FontOf(const AColumn:TColumn):TFont;

Parameters

AColumn
Type: TColumn

Return Value

Type: TFont

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.HeightOf(Integer) Method

Summary

Represents method HeightOf(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function HeightOf(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.IsChildrenVisible(TRender,Integer) Method

Summary

Represents method IsChildrenVisible(TRender,Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function IsChildrenVisible(const Sender:TRender; const ARow: Integer): Boolean;

Parameters

Sender
Type: TRender

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.MaxBottom Method

Summary

Represents method MaxBottom.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function MaxBottom: Single;

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.MaxRight Method

Summary

Represents method MaxRight.

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 function MaxRight:Single;

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TGridBand.Paint(TRenderData,TRender)
See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.PaintLines(TRenderData,Integer,Single) Method

Summary

Represents method PaintLines(TRenderData,Integer,Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure PaintLines(const AData:TRenderData; const FirstRow:Integer; Y:Single);

Parameters

AData
Type: TRenderData

FirstRow
Type: Integer

Y
Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.PaintRow(TRenderData,TRender) Method

Summary

Represents method PaintRow(TRenderData,TRender).

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 procedure PaintRow(var AData:TRenderData; const ARender: TRender);

Parameters

AData
Type: TRenderData

ARender
Type: TRender

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.RowAt(Single,Single) Method

Summary

Represents method RowAt(Single,Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function RowAt(const Y, AvailableHeight: Single): Integer;

Parameters

Y
Type: Single

AvailableHeight
Type: Single

Return Value

Type: Integer

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.SetColumnsLeft(Single,Single,Single) Method

Summary

Represents method SetColumnsLeft(Single,Single,Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function SetColumnsLeft(const ALeft,ARight,ASpacing:Single):TRectF;

Parameters

ALeft
Type: Single

ARight
Type: Single

ASpacing
Type: Single

Return Value

Type: TRectF

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Swap(Integer,Integer) Method

Summary

Represents method Swap(Integer,Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure Swap(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.TopOf(Integer) Method

Summary

Represents method TopOf(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function TopOf(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.TopOfRow(Integer) Method

Summary

Represents method TopOfRow(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function TopOfRow(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.TotalHeight(Integer) Method

Summary

Represents method TotalHeight(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function TotalHeight(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.UpToRowHeight(Integer) Method

Summary

Represents method UpToRowHeight(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function UpToRowHeight(const ARow:Integer):Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows Fields

Fields
Name | Description
FOnHorizScroll | Represents field FOnHorizScroll.
FOnVertScroll | Represents field FOnVertScroll.
Painter | Represents field Painter.
Scroll | Represents field Scroll.
XOffset | Represents field XOffset.
Top


TRows.FOnHorizScroll Field

Summary

Represents field FOnHorizScroll.

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 FOnHorizScroll,
 FOnVertScroll : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.FOnVertScroll Field

Summary

Represents field FOnVertScroll.

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 FOnHorizScroll,
 FOnVertScroll : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Painter Field

Summary

Represents field Painter.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 Painter : TPainter;

Field Value

Type: TPainter

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.Scroll Field

Summary

Represents field Scroll.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 Scroll : TPointF;

Field Value

Type: TPointF

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRows.XOffset Field

Summary

Represents field XOffset.

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 XOffset : Single;

Field Value

Type: Single

See Also

Reference

  • TRows
  • Tee.Grid.Rows


TRowsBands Class

Summary

Represents type TRowsBands.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TOwnedCollection
Tee.Format.TCollectionChange
Tee.Grid.Bands.TGridBands
Tee.Grid.Rows.TRowsBands
Syntax
Delphi
type
 TRowsBands=class(TGridBands)
 end;

The TRowsBands type exposes the following members.

Constants
Show:
Name | Description
Spacing | Represents constant Spacing. (Inherited from TGridBands.)
Top
Constructors
Show:
Name | Description
Create(TPersistent,TNotifyEvent) | Initializes a new instance of the TGridBands class. (Inherited from TGridBands.)
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer]. (Inherited from TGridBands.)
OnAdded | Represents property OnAdded. (Inherited from TCollectionChange.)
OnChanged | Represents property OnChanged. (Inherited from TCollectionChange.)
OnRemoved | Represents property OnRemoved. (Inherited from TCollectionChange.)
Row[Integer] | Represents property Row[Integer].
Visible | Represents property Visible. (Inherited from TGridBands.)
Top
Methods
Show:
Name | Description
AddText(String) | Represents method AddText(String). (Inherited from TGridBands.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TGridBands.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Inherited from TGridBands.)
CanDisplay | Represents method CanDisplay. (Inherited from TGridBands.)
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCollectionChange.)
Height(Integer) | Represents method Height(Integer).
Hit(Single,Single) | Represents method Hit(Single,Single).
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Inherited from TGridBands.)
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Inherited from TGridBands.)
RowOf(TGridBand) | Represents method RowOf(TGridBand).
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
Update(TCollectionItem) | Represents method Update(TCollectionItem). (Inherited from TCollectionChange.)
Top
Fields
Show:
Name | Description
Rows | Represents field Rows.
Top
See Also

Reference

  • Tee.Grid.Rows


TRowsBands Properties

Properties
Name | Description
Row[Integer] | Represents property Row[Integer].
Top


TRowsBands.Row[Integer] Property

Summary

Represents property Row[Integer].

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 property Row[const Index:Integer]:TGridBand read GetRow write SetRow;

Parameters

Index
Type: Integer

Property Value

Type: TGridBand

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands Methods

Methods
Name | Description
Height(Integer) | Represents method Height(Integer).
Hit(Single,Single) | Represents method Hit(Single,Single).
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification). (Overrides TCollectionChange.Notify(TCollectionItem,TCollectionNotification).)
RowOf(TGridBand) | Represents method RowOf(TGridBand).
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
Top


TRowsBands.Height(Integer) Method

Summary

Represents method Height(Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function Height(const ARow: Integer): Single;

Parameters

ARow
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands.Hit(Single,Single) Method

Summary

Represents method Hit(Single,Single).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function Hit(const X,Y:Single):TGridBand;

Parameters

X
Type: Single

Y
Type: Single

Return Value

Type: TGridBand

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands.Notify(TCollectionItem,TCollectionNotification) Method

Summary

Represents method Notify(TCollectionItem,TCollectionNotification).

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 procedure Notify(Item: TCollectionItem; Action: TCollectionNotification); override;

Parameters

Item
Type: TCollectionItem

Action
Type: TCollectionNotification

Overrides

TCollectionChange.Notify(TCollectionItem,TCollectionNotification)
See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands.RowOf(TGridBand) Method

Summary

Represents method RowOf(TGridBand).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 function RowOf(const ABand:TGridBand):Integer;

Parameters

ABand
Type: TGridBand

Return Value

Type: Integer

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands.Swap(Integer,Integer) Method

Summary

Represents method Swap(Integer,Integer).

Namespace: Tee.Grid.Rows
Syntax
Delphi
public
 procedure Swap(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TRowsBands Fields

Fields
Name | Description
Rows | Represents field Rows.
Top


TRowsBands.Rows Field

Summary

Represents field Rows.

Namespace: Tee.Grid.Rows
Syntax
Delphi
protected
 Rows : Array of TGridBand;

Field Value

Type: Array of TGridBand

See Also

Reference

  • TRowsBands
  • Tee.Grid.Rows


TTextRenderAccess Class

Summary

Represents type TTextRenderAccess.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Grid.Rows.TTextRenderAccess
Syntax
Delphi
type
 TTextRenderAccess=class(TTextRender);

The TTextRenderAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Rows


TVirtualDataAccess Class

Summary

Represents type TVirtualDataAccess.

Namespace: Tee.Grid.Rows
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.Rows.TVirtualDataAccess
Syntax
Delphi
type
 TVirtualDataAccess=class(TVirtualData);

The TVirtualDataAccess type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Inherited from TVirtualData.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Inherited from TVirtualData.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.Grid.Rows


Tee.Grid.Selection Namespace

Summary

Represents namespace Tee.Grid.Selection.

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridSelection | Represents type TGridSelection.
TSelectionRange | Represents type TSelectionRange.
Top


Tee.Grid.Selection Classes

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridSelection | Represents type TGridSelection.
TSelectionRange | Represents type TSelectionRange.
Top


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: Tee.Grid.Selection
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Columns.TColumn
Tee.Grid.Selection.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);

The TColumnAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumn class. (Overrides TVisibleRenderItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
DataFormat | Represents property DataFormat. (Inherited from TColumn.)
DefaultHorizAlign | Represents property DefaultHorizAlign. (Inherited from TColumn.)
Expanded | Represents property Expanded. (Inherited from TColumn.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header. (Inherited from TColumn.)
Items | Represents property Items. (Inherited from TColumn.)
LoadOrder | Represents property LoadOrder. (Inherited from TColumn.)
Locked | Represents property Locked. (Inherited from TColumn.)
Margins | Represents property Margins. (Inherited from TColumn.)
Parent | Represents property Parent. (Inherited from TColumn.)
ParentFormat | Represents property ParentFormat. (Inherited from TColumn.)
ReadOnly | Represents property ReadOnly. (Inherited from TColumn.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Selectable | Represents property Selectable. (Inherited from TColumn.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
TextAlign | Represents property TextAlign. (Inherited from TColumn.)
TextAlignment | Represents property TextAlignment. (Inherited from TColumn.)
TopParent | Represents property TopParent. (Inherited from TColumn.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Width | Represents property Width. (Inherited from TColumn.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
AutoWidth(TPainter) | Represents method AutoWidth(TPainter). (Inherited from TColumn.)
CanDisplay | Represents method CanDisplay. (Inherited from TColumn.)
Changed(TObject) | Represents method Changed(TObject). (Inherited from TVisibleRenderItem.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TColumn.)
DoChanged | Represents method DoChanged. (Overrides TVisibleRenderItem.DoChanged.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasItems | Represents method HasItems. (Inherited from TColumn.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
HorizAlign | Represents method HorizAlign. (Inherited from TColumn.)
InitAlign(THorizontalAlign) | Represents method InitAlign(THorizontalAlign). (Inherited from TColumn.)
Level | Represents method Level. (Inherited from TColumn.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
ParentColumns | Represents method ParentColumns. (Inherited from TColumn.)
Right | Represents method Right. (Inherited from TColumn.)
SetIndex(Integer) | Represents method SetIndex(Integer). (Inherited from TColumn.)
SetRender(TRender) | Represents method SetRender(TRender). (Overrides TVisibleRenderItem.SetRender(TRender).)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToString | Represents method ToString. (Inherited from TColumn.)
Top
Events
Show:
Name | Description
OnPaint | Represents property OnPaint. (Inherited from TColumn.)
Top
Fields
Show:
Name | Description
EditorClass | Represents field EditorClass. (Inherited from TColumn.)
FLink | Represents field FLink. (Inherited from TColumn.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
ITopParent | Represents field ITopParent. (Inherited from TColumn.)
Left | Represents field Left. (Inherited from TColumn.)
ValidWidth | Represents field ValidWidth. (Inherited from TColumn.)
Top
See Also

Reference

  • Tee.Grid.Selection


TGridSelection Class

Summary

Represents type TGridSelection.

Namespace: Tee.Grid.Selection
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Selection.TGridSelection
Tee.Grid.RowGroup.TGridSelectionAccess
Tee.Grid.Rows.TCellHover
Syntax
Delphi
type
 TGridSelection=class(TVisibleTextRender)
 end;

The TGridSelection type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridSelection class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGridSelection class. (Overrides TTextRender.Destroy.)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Column | Represents property Column.
Format | Represents property Format. (Inherited from TFormatRender.)
FullRow | Represents property FullRow.
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange.
ParentFont | Represents property ParentFont.
Range | Represents property Range.
Row | Represents property Row.
ScrollToView | Represents property ScrollToView.
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
UnFocused | Represents property UnFocused.
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Change(TColumn,Integer) | Represents method Change(TColumn,Integer).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Clear | Represents method Clear.
GetColumns(TVisibleColumns,Integer,Integer) | Represents method GetColumns(TVisibleColumns,Integer,Integer).
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
InitFormat | Represents method InitFormat.
IsEmpty | Represents method IsEmpty.
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
PaintColumn(TRenderData,TColumn,TFont,Boolean) | Represents method PaintColumn(TRenderData,TColumn,TFont,Boolean).
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
TryRange(TColumn,Integer,Single) | Represents method TryRange(TColumn,Integer,Single).
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
Dragging | Represents field Dragging.
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
PreviousRow | Represents field PreviousRow.
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Grid.Selection


TGridSelection Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TGridSelection class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TGridSelection class. (Overrides TTextRender.Destroy.)
Top


TGridSelection.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TGridSelection class.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisibleTextRender.Create(TNotifyEvent)
See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.Destroy Destructor

Summary

Represents the destructor of the TGridSelection class.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TTextRender.Destroy
See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection Properties

Properties
Name | Description
Column | Represents property Column.
FullRow | Represents property FullRow.
OnChange | Represents property OnChange.
ParentFont | Represents property ParentFont.
Range | Represents property Range.
Row | Represents property Row.
ScrollToView | Represents property ScrollToView.
UnFocused | Represents property UnFocused.
Top


TGridSelection.Column Property

Summary

Represents property Column.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property Column:TColumn read FColumn write SetColumn stored False;

Property Value

Type: TColumn

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.FullRow Property

Summary

Represents property FullRow.

Namespace: Tee.Grid.Selection
Syntax
Delphi
published
 property FullRow:Boolean read FFull write SetFull default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.OnChange Property

Summary

Represents property OnChange.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.ParentFont Property

Summary

Represents property ParentFont.

Namespace: Tee.Grid.Selection
Syntax
Delphi
published
 property ParentFont:Boolean read FParentFont write SetParentFont default True;

Property Value

Type: Boolean

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.Range Property

Summary

Represents property Range.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property Range:TSelectionRange read FRange write SetRange;

Property Value

Type: TSelectionRange

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.Row Property

Summary

Represents property Row.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property Row:Integer read FRow write SetRow stored False;

Property Value

Type: Integer

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.ScrollToView Property

Summary

Represents property ScrollToView.

Namespace: Tee.Grid.Selection
Syntax
Delphi
published
 property ScrollToView:Boolean read FScrollToView write SetScrollToView default False;

Property Value

Type: Boolean

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.UnFocused Property

Summary

Represents property UnFocused.

Namespace: Tee.Grid.Selection
Syntax
Delphi
published
 property UnFocused:TVisibleTextRender read FUnfocused write SetUnfocused;

Property Value

Type: TVisibleTextRender

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
Change(TColumn,Integer) | Represents method Change(TColumn,Integer).
Clear | Represents method Clear.
GetColumns(TVisibleColumns,Integer,Integer) | Represents method GetColumns(TVisibleColumns,Integer,Integer).
InitFormat | Represents method InitFormat.
IsEmpty | Represents method IsEmpty.
PaintColumn(TRenderData,TColumn,TFont,Boolean) | Represents method PaintColumn(TRenderData,TColumn,TFont,Boolean).
TryRange(TColumn,Integer,Single) | Represents method TryRange(TColumn,Integer,Single).
Top


TGridSelection.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisibleTextRender.Assign(TPersistent)
See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.Change(TColumn,Integer) Method

Summary

Represents method Change(TColumn,Integer).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure Change(const AColumn:TColumn; const ARow:Integer);

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.Clear Method

Summary

Represents method Clear.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.GetColumns(TVisibleColumns,Integer,Integer) Method

Summary

Represents method GetColumns(TVisibleColumns,Integer,Integer).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure GetColumns(const Visible:TVisibleColumns; out AFrom,ATo:Integer);

Parameters

Visible
Type: TVisibleColumns

AFrom
Type: Integer

ATo
Type: Integer

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.InitFormat Method

Summary

Represents method InitFormat.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure InitFormat;
See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.IsEmpty Method

Summary

Represents method IsEmpty.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 function IsEmpty:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.PaintColumn(TRenderData,TColumn,TFont,Boolean) Method

Summary

Represents method PaintColumn(TRenderData,TColumn,TFont,Boolean).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure PaintColumn(var AData:TRenderData; const AColumn:TColumn; const AFont:TFont; const IsFocused:Boolean);

Parameters

AData
Type: TRenderData

AColumn
Type: TColumn

AFont
Type: TFont

IsFocused
Type: Boolean

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.TryRange(TColumn,Integer,Single) Method

Summary

Represents method TryRange(TColumn,Integer,Single).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure TryRange(const AColumn:TColumn; const ARow:Integer; const Y:Single);

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Y
Type: Single

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection Fields

Fields
Name | Description
Dragging | Represents field Dragging.
PreviousRow | Represents field PreviousRow.
Top


TGridSelection.Dragging Field

Summary

Represents field Dragging.

Namespace: Tee.Grid.Selection
Syntax
Delphi
protected
 Dragging : Integer;

Field Value

Type: Integer

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TGridSelection.PreviousRow Field

Summary

Represents field PreviousRow.

Namespace: Tee.Grid.Selection
Syntax
Delphi
protected
 PreviousRow : Integer;

Field Value

Type: Integer

See Also

Reference

  • TGridSelection
  • Tee.Grid.Selection


TSelectionRange Class

Summary

Represents type TSelectionRange.

Namespace: Tee.Grid.Selection
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.Selection.TSelectionRange
Syntax
Delphi
type
 TSelectionRange=class(TPersistentChange)
 end;

The TSelectionRange type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSelectionRange class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
FromColumn | Represents property FromColumn.
FromRow | Represents property FromRow.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
ToColumn | Represents property ToColumn.
ToRow | Represents property ToRow.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
IsEmpty | Represents method IsEmpty.
Reset(TColumn,Integer) | Represents method Reset(TColumn,Integer).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Selection


TSelectionRange Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TSelectionRange class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TSelectionRange.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TSelectionRange class.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange Properties

Properties
Name | Description
Enabled | Represents property Enabled.
FromColumn | Represents property FromColumn.
FromRow | Represents property FromRow.
ToColumn | Represents property ToColumn.
ToRow | Represents property ToRow.
Top


TSelectionRange.Enabled Property

Summary

Represents property Enabled.

Namespace: Tee.Grid.Selection
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default False;

Property Value

Type: Boolean

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.FromColumn Property

Summary

Represents property FromColumn.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property FromColumn:TColumn read FFromColumn write SetFromColumn;

Property Value

Type: TColumn

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.FromRow Property

Summary

Represents property FromRow.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property FromRow:Integer read FFromRow write SetFromRow default -1;

Property Value

Type: Integer

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.ToColumn Property

Summary

Represents property ToColumn.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property ToColumn:TColumn read FToColumn write SetToColumn;

Property Value

Type: TColumn

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.ToRow Property

Summary

Represents property ToRow.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 property ToRow:Integer read FToRow write SetToRow default -1;

Property Value

Type: Integer

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
IsEmpty | Represents method IsEmpty.
Reset(TColumn,Integer) | Represents method Reset(TColumn,Integer).
Top


TSelectionRange.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.IsEmpty Method

Summary

Represents method IsEmpty.

Namespace: Tee.Grid.Selection
Syntax
Delphi
public
 function IsEmpty:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


TSelectionRange.Reset(TColumn,Integer) Method

Summary

Represents method Reset(TColumn,Integer).

Namespace: Tee.Grid.Selection
Syntax
Delphi
protected
 procedure Reset(const AColumn:TColumn; const ARow:Integer);

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

See Also

Reference

  • TSelectionRange
  • Tee.Grid.Selection


Tee.Grid.Themes Namespace

Summary

Represents namespace Tee.Grid.Themes.

Classes
Name | Description
TControlAccess | Represents type TControlAccess.
TCustomTheme | Represents type TCustomTheme.
Top
Records
Name | Description
TAndroidTheme | Represents type TAndroidTheme.
TBlackTheme | Represents type TBlackTheme.
TCustomTheme.THeaderTheme | Represents type THeaderTheme.
TCustomTheme.TThemeFont | Represents type TThemeFont.
TDefaultTheme | Represents type TDefaultTheme.
TGridThemes | Represents type TGridThemes.
TiOSTheme | Represents type TiOSTheme.
Top
Routines
Name | Description
ResetBrush(TRowGroup,TColor) | Overloaded. Represents method ResetBrush(TRowGroup,TColor).
ResetFonts(TCustomTeeGrid,String,Single) | Overloaded. Represents method ResetFonts(TCustomTeeGrid,String,Single).
ResetFonts(TRowGroup,String,Single) | Overloaded. Represents method ResetFonts(TRowGroup,String,Single).
ResetFonts(TRowGroup,String,Single,TColor) | Overloaded. Represents method ResetFonts(TRowGroup,String,Single,TColor).
ResetFontsColor(TRowGroup,TColor) | Represents method ResetFontsColor(TRowGroup,TColor).
ResetSelected(TGridSelection) | Represents method ResetSelected(TGridSelection).
ResetStroke(TRowGroup,TColor) | Represents method ResetStroke(TRowGroup,TColor).
Top


Tee.Grid.Themes Classes

Classes
Name | Description
TControlAccess | Represents type TControlAccess.
TCustomTheme | Represents type TCustomTheme.
Top


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: Tee.Grid.Themes
Inheritance Hierarchy
TComponent
Tee.Control.TCustomTeeControl
Tee.Grid.TCustomTeeGrid
Tee.Grid.Themes.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TCustomTeeGrid);

The TControlAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TCustomTeeGrid class. (Overrides TCustomTeeControl.Create(TComponent).)
Top
Properties
Show:
Name | Description
Back | Represents property Back. (Inherited from TCustomTeeControl.)
Cells | Represents property Cells. (Inherited from TCustomTeeGrid.)
Columns | Represents property Columns. (Inherited from TCustomTeeGrid.)
Current | Represents property Current. (Inherited from TCustomTeeGrid.)
Data | Represents property Data. (Inherited from TCustomTeeGrid.)
DataSource | Represents property DataSource. (Inherited from TCustomTeeGrid.)
Editing | Represents property Editing. (Inherited from TCustomTeeGrid.)
Footer | Represents property Footer. (Inherited from TCustomTeeGrid.)
Header | Represents property Header. (Inherited from TCustomTeeGrid.)
Headers | Represents property Headers. (Inherited from TCustomTeeGrid.)
Indicator | Represents property Indicator. (Inherited from TCustomTeeGrid.)
Margins | Represents property Margins. (Inherited from TCustomTeeGrid.)
MouseActivity | Represents property MouseActivity. (Inherited from TCustomTeeGrid.)
OnAfterDraw | Represents property OnAfterDraw. (Inherited from TCustomTeeGrid.)
OnChange | Represents property OnChange. (Inherited from TCustomTeeControl.)
OnSelect | Represents property OnSelect. (Inherited from TCustomTeeGrid.)
ParentFont | Represents property ParentFont. (Inherited from TCustomTeeGrid.)
ReadOnly | Represents property ReadOnly. (Inherited from TCustomTeeGrid.)
Root | Represents property Root. (Inherited from TCustomTeeGrid.)
Rows | Represents property Rows. (Inherited from TCustomTeeGrid.)
Selected | Represents property Selected. (Inherited from TCustomTeeGrid.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TCustomTeeControl.Assign(TPersistent).)
BeginUpdate | Represents method BeginUpdate. (Inherited from TCustomTeeControl.)
CancelEditor | Represents method CancelEditor. (Inherited from TCustomTeeGrid.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TCustomTeeGrid.)
ChangeEditing(TIndicatorState) | Represents method ChangeEditing(TIndicatorState). (Inherited from TCustomTeeGrid.)
ChangeHorizScroll(Single) | Represents method ChangeHorizScroll(Single). (Inherited from TCustomTeeGrid.)
ChangeVertScroll(Single) | Represents method ChangeVertScroll(Single). (Inherited from TCustomTeeGrid.)
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single). (Inherited from TCustomTeeGrid.)
ClientHeight | Represents method ClientHeight. (Overrides TCustomTeeControl.ClientHeight.)
ClientWidth | Represents method ClientWidth. (Overrides TCustomTeeControl.ClientWidth.)
ContainsFocus | Represents method ContainsFocus. (Inherited from TCustomTeeGrid.)
Copy(TGridSelection) | Represents method Copy(TGridSelection). (Inherited from TCustomTeeGrid.)
DataChanged | Represents method DataChanged. (Inherited from TCustomTeeGrid.)
DataSourceChanged | Represents method DataSourceChanged. (Inherited from TCustomTeeGrid.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TCustomTeeGrid.)
DoChanged(TObject) | Represents method DoChanged(TObject). (Inherited from TCustomTeeControl.)
DoEditing(TObject,Boolean) | Represents method DoEditing(TObject,Boolean). (Inherited from TCustomTeeGrid.)
EndUpdate | Represents method EndUpdate. (Inherited from TCustomTeeControl.)
FinishPaint(Boolean) | Represents method FinishPaint(Boolean). (Inherited from TCustomTeeGrid.)
HasBandOfClass(TGridBandClass) | Represents method HasBandOfClass(TGridBandClass). (Inherited from TCustomTeeGrid.)
Height | Represents method Height. (Inherited from TCustomTeeControl.)
HorizScrollBarHeight | Represents method HorizScrollBarHeight. (Inherited from TCustomTeeGrid.)
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject). (Inherited from TCustomTeeGrid.)
Key(TKeyState) | Represents method Key(TKeyState). (Inherited from TCustomTeeGrid.)
Loaded | Represents method Loaded. (Inherited from TCustomTeeGrid.)
Mouse(TMouseState) | Represents method Mouse(TMouseState). (Inherited from TCustomTeeGrid.)
MouseLeave | Represents method MouseLeave. (Inherited from TCustomTeeGrid.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TCustomTeeGrid.)
Paint | Represents method Paint. (Overrides TCustomTeeControl.Paint.)
Painter | Represents method Painter. (Inherited from TCustomTeeControl.)
PasteSelected | Represents method PasteSelected. (Inherited from TCustomTeeGrid.)
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean). (Inherited from TCustomTeeGrid.)
ReadFooter(TReader) | Represents method ReadFooter(TReader). (Inherited from TCustomTeeGrid.)
ReadHeaders(TReader) | Represents method ReadHeaders(TReader). (Inherited from TCustomTeeGrid.)
RefreshData | Represents method RefreshData. (Inherited from TCustomTeeGrid.)
ResetScrollBars | Represents method ResetScrollBars. (Inherited from TCustomTeeControl.)
StartEditor(String) | Overloaded. Represents method StartEditor(String). (Inherited from TCustomTeeGrid.)
StartEditor(TColumn,Integer,String) | Overloaded. Represents method StartEditor(TColumn,Integer,String). (Inherited from TCustomTeeGrid.)
StopEditor | Represents method StopEditor. (Inherited from TCustomTeeGrid.)
TryStartEditor(String) | Represents method TryStartEditor(String). (Inherited from TCustomTeeGrid.)
VertScrollBarWidth | Represents method VertScrollBarWidth. (Inherited from TCustomTeeGrid.)
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject). (Inherited from TCustomTeeGrid.)
Width | Represents method Width. (Inherited from TCustomTeeControl.)
WidthForColumns(TRowGroup,Single) | Represents method WidthForColumns(TRowGroup,Single). (Inherited from TCustomTeeGrid.)
WriteFooter(TWriter) | Represents method WriteFooter(TWriter). (Inherited from TCustomTeeGrid.)
WriteHeaders(TWriter) | Represents method WriteHeaders(TWriter). (Inherited from TCustomTeeGrid.)
Top
Fields
Show:
Name | Description
ILoading | Represents field ILoading. (Inherited from TCustomTeeGrid.)
IUpdating | Represents field IUpdating. (Inherited from TCustomTeeControl.)
Top
See Also

Reference

  • Tee.Grid.Themes


TCustomTheme Class

Summary

Represents type TCustomTheme.

Namespace: Tee.Grid.Themes
Inheritance Hierarchy
TObject
Tee.Grid.Themes.TCustomTheme
Syntax
Delphi
type
 TCustomTheme=class
 end;

The TCustomTheme type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top
Fields
Show:
Name | Description
Brush | Represents field Brush.
Font | Represents field Font.
Header | Represents field Header.
Hover | Represents field Hover.
HoverFont | Represents field HoverFont.
Selected | Represents field Selected.
SelectedFont | Represents field SelectedFont.
Stroke | Represents field Stroke.
Top
See Also

Reference

  • Tee.Grid.Themes


TCustomTheme Methods

Methods
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top


TCustomTheme.ApplyTo(TCustomTeeGrid) Method

Summary

Represents method ApplyTo(TCustomTeeGrid).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 procedure ApplyTo(const AGrid:TCustomTeeGrid); overload;

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.ApplyTo(TRowGroup) Method

Summary

Represents method ApplyTo(TRowGroup).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 procedure ApplyTo(const AGroup:TRowGroup); overload;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme Fields

Fields
Name | Description
Brush | Represents field Brush.
Font | Represents field Font.
Header | Represents field Header.
Hover | Represents field Hover.
HoverFont | Represents field HoverFont.
Selected | Represents field Selected.
SelectedFont | Represents field SelectedFont.
Stroke | Represents field Stroke.
Top


TCustomTheme.Brush Field

Summary

Represents field Brush.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Brush : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.Font Field

Summary

Represents field Font.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Font : TThemeFont;

Field Value

Type: TThemeFont

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.Header Field

Summary

Represents field Header.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Header : THeaderTheme;

Field Value

Type: THeaderTheme

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.Hover Field

Summary

Represents field Hover.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Hover : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.HoverFont Field

Summary

Represents field HoverFont.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 HoverFont : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.Selected Field

Summary

Represents field Selected.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Selected : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.SelectedFont Field

Summary

Represents field SelectedFont.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 SelectedFont : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.Stroke Field

Summary

Represents field Stroke.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Stroke : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


Tee.Grid.Themes Records

Records
Name | Description
TAndroidTheme | Represents type TAndroidTheme.
TBlackTheme | Represents type TBlackTheme.
TCustomTheme.THeaderTheme | Represents type THeaderTheme.
TCustomTheme.TThemeFont | Represents type TThemeFont.
TDefaultTheme | Represents type TDefaultTheme.
TGridThemes | Represents type TGridThemes.
TiOSTheme | Represents type TiOSTheme.
Top


TAndroidTheme Record

Summary

Represents type TAndroidTheme.

Namespace: Tee.Grid.Themes
Syntax
Delphi
type
 TAndroidTheme=record
 end;

The TAndroidTheme type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top
See Also

Reference

  • Tee.Grid.Themes


TAndroidTheme Methods

Methods
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top


TAndroidTheme.ApplyTo(TCustomTeeGrid) Method

Summary

Represents method ApplyTo(TCustomTeeGrid).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TCustomTeeGrid); overload; static;

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • TAndroidTheme
  • Tee.Grid.Themes


TAndroidTheme.ApplyTo(TRowGroup) Method

Summary

Represents method ApplyTo(TRowGroup).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGroup:TRowGroup); overload; static;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TAndroidTheme
  • Tee.Grid.Themes


TBlackTheme Record

Summary

Represents type TBlackTheme.

Namespace: Tee.Grid.Themes
Syntax
Delphi
type
 TBlackTheme=record
 end;

The TBlackTheme type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top
See Also

Reference

  • Tee.Grid.Themes


TBlackTheme Methods

Methods
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top


TBlackTheme.ApplyTo(TCustomTeeGrid) Method

Summary

Represents method ApplyTo(TCustomTeeGrid).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TCustomTeeGrid); overload; static;

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • TBlackTheme
  • Tee.Grid.Themes


TBlackTheme.ApplyTo(TRowGroup) Method

Summary

Represents method ApplyTo(TRowGroup).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGroup:TRowGroup); overload; static;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TBlackTheme
  • Tee.Grid.Themes


TCustomTheme.THeaderTheme Record

Summary

Represents type THeaderTheme.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
type
 THeaderTheme=record
 end;

The TCustomTheme.THeaderTheme type exposes the following members.

Fields
Show:
Name | Description
Brush | Represents field Brush.
Font | Represents field Font.
Top
See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.THeaderTheme Fields

Fields
Name | Description
Brush | Represents field Brush.
Font | Represents field Font.
Top


TCustomTheme.THeaderTheme.Brush Field

Summary

Represents field Brush.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Brush : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme.THeaderTheme
  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.THeaderTheme.Font Field

Summary

Represents field Font.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Font : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme.THeaderTheme
  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.TThemeFont Record

Summary

Represents type TThemeFont.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
type
 TThemeFont=record
 end;

The TCustomTheme.TThemeFont type exposes the following members.

Fields
Show:
Name | Description
Color | Represents field Color.
Name | Represents field Name.
Size | Represents field Size.
Top
See Also

Reference

  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.TThemeFont Fields

Fields
Name | Description
Color | Represents field Color.
Name | Represents field Name.
Size | Represents field Size.
Top


TCustomTheme.TThemeFont.Color Field

Summary

Represents field Color.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Color : TColor;

Field Value

Type: TColor

See Also

Reference

  • TCustomTheme.TThemeFont
  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.TThemeFont.Name Field

Summary

Represents field Name.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Name : String;

Field Value

Type: String

See Also

Reference

  • TCustomTheme.TThemeFont
  • TCustomTheme
  • Tee.Grid.Themes


TCustomTheme.TThemeFont.Size Field

Summary

Represents field Size.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 Size : Single;

Field Value

Type: Single

See Also

Reference

  • TCustomTheme.TThemeFont
  • TCustomTheme
  • Tee.Grid.Themes


TDefaultTheme Record

Summary

Represents type TDefaultTheme.

Namespace: Tee.Grid.Themes
Syntax
Delphi
type
 TDefaultTheme=record
 end;

The TDefaultTheme type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
CheckRenders(TColumns,TColor) | Represents method CheckRenders(TColumns,TColor).
Top
See Also

Reference

  • Tee.Grid.Themes


TDefaultTheme Methods

Methods
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
CheckRenders(TColumns,TColor) | Represents method CheckRenders(TColumns,TColor).
Top


TDefaultTheme.ApplyTo(TCustomTeeGrid) Method

Summary

Represents method ApplyTo(TCustomTeeGrid).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TCustomTeeGrid); overload; static;

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • TDefaultTheme
  • Tee.Grid.Themes


TDefaultTheme.ApplyTo(TRowGroup) Method

Summary

Represents method ApplyTo(TRowGroup).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGroup:TRowGroup); overload; static;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TDefaultTheme
  • Tee.Grid.Themes


TDefaultTheme.CheckRenders(TColumns,TColor) Method

Summary

Represents method CheckRenders(TColumns,TColor).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure CheckRenders(const AColumns:TColumns; const AColor:TColor); static;

Parameters

AColumns
Type: TColumns

AColor
Type: System.Void

See Also

Reference

  • TDefaultTheme
  • Tee.Grid.Themes


TGridThemes Record

Summary

Represents type TGridThemes.

Namespace: Tee.Grid.Themes
Syntax
Delphi
type
 TGridThemes=record
 end;

The TGridThemes type exposes the following members.

Fields
Show:
Name | Description
Android | Represents field Android.
Black | Represents field Black.
Default | Represents field Default.
iOS | Represents field iOS.
Top
See Also

Reference

  • Tee.Grid.Themes


TGridThemes Fields

Fields
Name | Description
Android | Represents field Android.
Black | Represents field Black.
Default | Represents field Default.
iOS | Represents field iOS.
Top


TGridThemes.Android Field

Summary

Represents field Android.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class var
 Android : TAndroidTheme;

Field Value

Type: TAndroidTheme

See Also

Reference

  • TGridThemes
  • Tee.Grid.Themes


TGridThemes.Black Field

Summary

Represents field Black.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class var
 Black : TBlackTheme;

Field Value

Type: TBlackTheme

See Also

Reference

  • TGridThemes
  • Tee.Grid.Themes


TGridThemes.Default Field

Summary

Represents field Default.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class var
 Default : TDefaultTheme;

Field Value

Type: TDefaultTheme

See Also

Reference

  • TGridThemes
  • Tee.Grid.Themes


TGridThemes.iOS Field

Summary

Represents field iOS.

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class var
 iOS : TiOSTheme;

Field Value

Type: TiOSTheme

See Also

Reference

  • TGridThemes
  • Tee.Grid.Themes


TiOSTheme Record

Summary

Represents type TiOSTheme.

Namespace: Tee.Grid.Themes
Syntax
Delphi
type
 TiOSTheme=record
 end;

The TiOSTheme type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top
See Also

Reference

  • Tee.Grid.Themes


TiOSTheme Methods

Methods
Name | Description
ApplyTo(TCustomTeeGrid) | Overloaded. Represents method ApplyTo(TCustomTeeGrid).
ApplyTo(TRowGroup) | Overloaded. Represents method ApplyTo(TRowGroup).
Top


TiOSTheme.ApplyTo(TCustomTeeGrid) Method

Summary

Represents method ApplyTo(TCustomTeeGrid).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TCustomTeeGrid); overload; static;

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • TiOSTheme
  • Tee.Grid.Themes


TiOSTheme.ApplyTo(TRowGroup) Method

Summary

Represents method ApplyTo(TRowGroup).

Namespace: Tee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGroup: TRowGroup); overload; static;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TiOSTheme
  • Tee.Grid.Themes


Tee.Grid.Themes Routines

Routines
Name | Description
ResetBrush(TRowGroup,TColor) | Overloaded. Represents method ResetBrush(TRowGroup,TColor).
ResetFonts(TCustomTeeGrid,String,Single) | Overloaded. Represents method ResetFonts(TCustomTeeGrid,String,Single).
ResetFonts(TRowGroup,String,Single) | Overloaded. Represents method ResetFonts(TRowGroup,String,Single).
ResetFonts(TRowGroup,String,Single,TColor) | Overloaded. Represents method ResetFonts(TRowGroup,String,Single,TColor).
ResetFontsColor(TRowGroup,TColor) | Represents method ResetFontsColor(TRowGroup,TColor).
ResetSelected(TGridSelection) | Represents method ResetSelected(TGridSelection).
ResetStroke(TRowGroup,TColor) | Represents method ResetStroke(TRowGroup,TColor).
Top


ResetBrush(TRowGroup,TColor) Method

Summary

Represents method ResetBrush(TRowGroup,TColor).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetBrush(const AGroup:TRowGroup; const AColor:TColor); overload;

Parameters

AGroup
Type: TRowGroup

AColor
Type: System.Void

See Also

Reference

  • Tee.Grid.Themes


ResetFonts(TCustomTeeGrid,String,Single) Method

Summary

Represents method ResetFonts(TCustomTeeGrid,String,Single).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetFonts(const AGrid:TCustomTeeGrid; const AName:String; const ASize:Single); overload;

Parameters

AGrid
Type: TCustomTeeGrid

AName
Type: String

ASize
Type: Single

See Also

Reference

  • Tee.Grid.Themes


ResetFonts(TRowGroup,String,Single) Method

Summary

Represents method ResetFonts(TRowGroup,String,Single).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetFonts(const AGroup:TRowGroup; const AName:String; const ASize:Single); overload;

Parameters

AGroup
Type: TRowGroup

AName
Type: String

ASize
Type: Single

See Also

Reference

  • Tee.Grid.Themes


ResetFonts(TRowGroup,String,Single,TColor) Method

Summary

Represents method ResetFonts(TRowGroup,String,Single,TColor).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetFonts(const AGroup:TRowGroup; const AName:String; const ASize:Single; const AColor:TColor); overload;

Parameters

AGroup
Type: TRowGroup

AName
Type: String

ASize
Type: Single

AColor
Type: System.Void

See Also

Reference

  • Tee.Grid.Themes


ResetFontsColor(TRowGroup,TColor) Method

Summary

Represents method ResetFontsColor(TRowGroup,TColor).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetFontsColor(const AGroup:TRowGroup; const AColor:TColor);

Parameters

AGroup
Type: TRowGroup

AColor
Type: System.Void

See Also

Reference

  • Tee.Grid.Themes


ResetSelected(TGridSelection) Method

Summary

Represents method ResetSelected(TGridSelection).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetSelected(const ASelected:TGridSelection);

Parameters

ASelected
Type: TGridSelection

See Also

Reference

  • Tee.Grid.Themes


ResetStroke(TRowGroup,TColor) Method

Summary

Represents method ResetStroke(TRowGroup,TColor).

Namespace: Tee.Grid.Themes
Syntax
Delphi
procedure ResetStroke(const AGroup:TRowGroup; const AColor:TColor);

Parameters

AGroup
Type: TRowGroup

AColor
Type: System.Void

See Also

Reference

  • Tee.Grid.Themes


Tee.Grid.Ticker Namespace

Summary

Represents namespace Tee.Grid.Ticker.

Classes
Name | Description
TGridTicker | Represents type TGridTicker.
TTickerThread | Represents type TTickerThread.
Top
Records
Name | Description
TTickerCell | Represents type TTickerCell.
Top


Tee.Grid.Ticker Classes

Classes
Name | Description
TGridTicker | Represents type TGridTicker.
TTickerThread | Represents type TTickerThread.
Top


TGridTicker Class

Summary

Represents type TGridTicker.

Namespace: Tee.Grid.Ticker
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Grid.Ticker.TGridTicker
Syntax
Delphi
type
 TGridTicker=class(TPersistentChange)
 end;

The TGridTicker type exposes the following members.

Constructors
Show:
Name | Description
Create(TRowGroup) | Initializes a new instance of the TGridTicker class.
Destroy | Represents the destructor of the TGridTicker class.
Top
Properties
Show:
Name | Description
Delay | Represents property Delay.
Enabled | Represents property Enabled.
FadeColors | Represents property FadeColors.
Higher | Represents property Higher.
Lower | Represents property Lower.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
RefreshSpeed | Represents property RefreshSpeed.
Top
Methods
Show:
Name | Description
Change(Integer,Integer,Double) | Represents method Change(Integer,Integer,Double).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Paint(TColumn,TRenderData) | Represents method Paint(TColumn,TRenderData).
Resize | Represents method Resize.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Grid.Ticker


TGridTicker Constructors

Constructors
Name | Description
Create(TRowGroup) | Initializes a new instance of the TGridTicker class.
Destroy | Represents the destructor of the TGridTicker class.
Top


TGridTicker.Create(TRowGroup) Constructor

Summary

Initializes a new instance of the TGridTicker class.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Constructor Create(const AGroup:TRowGroup); reintroduce;

Parameters

AGroup
Type: TRowGroup

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Destroy Destructor

Summary

Represents the destructor of the TGridTicker class.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker Properties

Properties
Name | Description
Delay | Represents property Delay.
Enabled | Represents property Enabled.
FadeColors | Represents property FadeColors.
Higher | Represents property Higher.
Lower | Represents property Lower.
RefreshSpeed | Represents property RefreshSpeed.
Top


TGridTicker.Delay Property

Summary

Represents property Delay.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property Delay:Integer read FDelay write FDelay default 1000;

Property Value

Type: Integer

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Enabled Property

Summary

Represents property Enabled.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write FEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.FadeColors Property

Summary

Represents property FadeColors.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property FadeColors:Boolean read FFadeColors write FFadeColors default True;

Property Value

Type: Boolean

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Higher Property

Summary

Represents property Higher.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property Higher:TBrush read FHigherBrush write SetHigherBrush;

Property Value

Type: TBrush

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Lower Property

Summary

Represents property Lower.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property Lower:TBrush read FLowerBrush write SetLowerBrush;

Property Value

Type: TBrush

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.RefreshSpeed Property

Summary

Represents property RefreshSpeed.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
published
 property RefreshSpeed:Integer read FRefreshSpeed write FRefreshSpeed default 10;

Property Value

Type: Integer

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker Methods

Methods
Name | Description
Change(Integer,Integer,Double) | Represents method Change(Integer,Integer,Double).
Paint(TColumn,TRenderData) | Represents method Paint(TColumn,TRenderData).
Resize | Represents method Resize.
Top


TGridTicker.Change(Integer,Integer,Double) Method

Summary

Represents method Change(Integer,Integer,Double).

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 procedure Change(const ACol,ARow:Integer; const AOldValue:Double);

Parameters

ACol
Type: Integer

ARow
Type: Integer

AOldValue
Type: Double

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Paint(TColumn,TRenderData) Method

Summary

Represents method Paint(TColumn,TRenderData).

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 procedure Paint(const AColumn:TColumn; var AData:TRenderData);

Parameters

AColumn
Type: TColumn

AData
Type: TRenderData

See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TGridTicker.Resize Method

Summary

Represents method Resize.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 procedure Resize;
See Also

Reference

  • TGridTicker
  • Tee.Grid.Ticker


TTickerThread Class

Summary

Represents type TTickerThread.

Namespace: Tee.Grid.Ticker
Inheritance Hierarchy
TThread
Tee.Grid.Ticker.TTickerThread
Syntax
Delphi
type
 TTickerThread=class(TThread)
 end;

The TTickerThread type exposes the following members.

Methods
Show:
Name | Description
Execute | Represents method Execute.
Top
See Also

Reference

  • Tee.Grid.Ticker


TTickerThread Methods

Methods
Name | Description
Execute | Represents method Execute.
Top


TTickerThread.Execute Method

Summary

Represents method Execute.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
protected
 procedure Execute; override;
See Also

Reference

  • TTickerThread
  • Tee.Grid.Ticker


Tee.Grid.Ticker Records

Records
Name | Description
TTickerCell | Represents type TTickerCell.
Top


TTickerCell Record

Summary

Represents type TTickerCell.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
type
 TTickerCell=record
 end;

The TTickerCell type exposes the following members.

Fields
Show:
Name | Description
Delta | Represents field Delta.
Enabled | Represents field Enabled.
Old | Represents field Old.
Range | Represents field Range.
Value | Represents field Value.
Top
See Also

Reference

  • Tee.Grid.Ticker


TTickerCell Fields

Fields
Name | Description
Delta | Represents field Delta.
Enabled | Represents field Enabled.
Old | Represents field Old.
Range | Represents field Range.
Value | Represents field Value.
Top


TTickerCell.Delta Field

Summary

Represents field Delta.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Delta,
 Range,
 Old,
 Value : Double;

Field Value

Type: Double

See Also

Reference

  • TTickerCell
  • Tee.Grid.Ticker


TTickerCell.Enabled Field

Summary

Represents field Enabled.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Enabled : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TTickerCell
  • Tee.Grid.Ticker


TTickerCell.Old Field

Summary

Represents field Old.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Delta,
 Range,
 Old,
 Value : Double;

Field Value

Type: Double

See Also

Reference

  • TTickerCell
  • Tee.Grid.Ticker


TTickerCell.Range Field

Summary

Represents field Range.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Delta,
 Range,
 Old,
 Value : Double;

Field Value

Type: Double

See Also

Reference

  • TTickerCell
  • Tee.Grid.Ticker


TTickerCell.Value Field

Summary

Represents field Value.

Namespace: Tee.Grid.Ticker
Syntax
Delphi
public
 Delta,
 Range,
 Old,
 Value : Double;

Field Value

Type: Double

See Also

Reference

  • TTickerCell
  • Tee.Grid.Ticker


Tee.Grid.Totals Namespace

Summary

Represents namespace Tee.Grid.Totals.

Classes
Name | Description
TBaseTotals | Represents type TBaseTotals.
TColumnTotals | Represents type TColumnTotals.
TTotalsHeader | Represents type TTotalsHeader.
Top
Records
Name | Description
TColumnTotals.TTotalCalculation | Represents type TTotalCalculation.
TColumnTotals.TTotals | Represents type TTotals.
Top
Routines
Name | Description
CalculationToString(TColumnCalculation) | Represents method CalculationToString(TColumnCalculation).
Top


Tee.Grid.Totals Classes

Classes
Name | Description
TBaseTotals | Represents type TBaseTotals.
TColumnTotals | Represents type TColumnTotals.
TTotalsHeader | Represents type TTotalsHeader.
Top


TBaseTotals Class

Summary

Represents type TBaseTotals.

Namespace: Tee.Grid.Totals
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Totals.TBaseTotals
Tee.Grid.Totals.TColumnTotals
Tee.Grid.Totals.TTotalsHeader
Syntax
Delphi
type
 TBaseTotals=class(TCustomColumnBand)
 end;

The TBaseTotals type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TBaseTotals class. (Overrides TCustomColumnBand.Create(TCollection).)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Inherited from TCustomColumnBand.)
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Inherited from TGridBand.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Inherited from TCustomColumnBand.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Inherited from TCustomColumnBand.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Inherited from TCustomColumnBand.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Inherited from TCustomColumnBand.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.Totals


TBaseTotals Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TBaseTotals class. (Overrides TCustomColumnBand.Create(TCollection).)
Top


TBaseTotals.Create(TCollection) Constructor

Summary

Initializes a new instance of the TBaseTotals class.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TCustomColumnBand.Create(TCollection)
See Also

Reference

  • TBaseTotals
  • Tee.Grid.Totals


TBaseTotals Methods

Methods
Name | Description
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
Top


TBaseTotals.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); override;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

Overrides

TCustomColumnBand.Paint(TRenderData,TRender)
See Also

Reference

  • TBaseTotals
  • Tee.Grid.Totals


TColumnTotals Class

Summary

Represents type TColumnTotals.

Namespace: Tee.Grid.Totals
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Totals.TBaseTotals
Tee.Grid.Totals.TColumnTotals
Syntax
Delphi
type
 TColumnTotals=class(TBaseTotals)
 end;

The TColumnTotals type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnTotals class. (Overrides TBaseTotals.Create(TCollection).)
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Overrides TGridBand.Description.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Inherited from TCustomColumnBand.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Inherited from TCustomColumnBand.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Inherited from TCustomColumnBand.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Inherited from TCustomColumnBand.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
Calculation | Represents field Calculation.
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.Totals


TColumnTotals Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TColumnTotals class. (Overrides TBaseTotals.Create(TCollection).)
Top


TColumnTotals.Create(TCollection) Constructor

Summary

Initializes a new instance of the TColumnTotals class.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TBaseTotals.Create(TCollection)
See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals Methods

Methods
Name | Description
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
Description | Represents method Description. (Overrides TGridBand.Description.)
Top


TColumnTotals.AsString(TColumn) Method

Summary

Represents method AsString(TColumn).

Namespace: Tee.Grid.Totals
Syntax
Delphi
protected
 function AsString(const AColumn:TColumn):String; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

Overrides

TCustomColumnBand.AsString(TColumn)
See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 class function Description:String; override;

Return Value

Type: String

Overrides

TGridBand.Description
See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals Fields

Fields
Name | Description
Calculation | Represents field Calculation.
Top


TColumnTotals.Calculation Field

Summary

Represents field Calculation.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Calculation : TTotals;

Field Value

Type: TTotals

See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TTotalsHeader Class

Summary

Represents type TTotalsHeader.

Namespace: Tee.Grid.Totals
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Bands.TGridBandLines
Tee.Grid.Bands.Columns.TCustomColumnBand
Tee.Grid.Totals.TBaseTotals
Tee.Grid.Totals.TTotalsHeader
Syntax
Delphi
type
 TTotalsHeader=class(TBaseTotals)
 end;

The TTotalsHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TTotalsHeader class. (Overrides TBaseTotals.Create(TCollection).)
CreateTotals(TCollection,TColumnTotals) | Initializes a new instance of the TTotalsHeader class.
Top
Properties
Show:
Name | Description
AllowResize | Represents property AllowResize. (Inherited from TCustomColumnBand.)
Columns | Represents property Columns. (Inherited from TCustomColumnBand.)
Data | Represents property Data. (Inherited from TCustomColumnBand.)
Drag | Represents property Drag. (Inherited from TCustomColumnBand.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Height | Represents property Height. (Inherited from TGridBand.)
HighLight | Represents property HighLight. (Inherited from TCustomColumnBand.)
Hover | Represents property Hover. (Inherited from TCustomColumnBand.)
Lines | Represents property Lines. (Inherited from TGridBandLines.)
Margins | Represents property Margins. (Inherited from TCustomColumnBand.)
OnClick | Represents property OnClick. (Inherited from TGridBand.)
OnColumnResized | Represents property OnColumnResized. (Inherited from TCustomColumnBand.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Resizing | Represents property Resizing. (Inherited from TCustomColumnBand.)
Selected | Represents property Selected. (Inherited from TCustomColumnBand.)
SelectedColumn | Represents property SelectedColumn. (Inherited from TCustomColumnBand.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
Totals | Represents property Totals.
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Top
Methods
Show:
Name | Description
AdjustBounds(TColumn,TRectF) | Represents method AdjustBounds(TColumn,TRectF). (Inherited from TCustomColumnBand.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGridBand.Assign(TPersistent).)
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
CalcFont(TColumn,TFont) | Represents method CalcFont(TColumn,TFont). (Inherited from TCustomColumnBand.)
CalcHeight(TPainter,Single) | Represents method CalcHeight(TPainter,Single). (Overrides TGridBand.CalcHeight(TPainter,Single).)
Contains(Single,Single) | Represents method Contains(Single,Single). (Inherited from TGridBand.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
Description | Represents method Description. (Overrides TGridBand.Description.)
DoCalcBounds(TRenderData,TColumn,Integer,Single) | Represents method DoCalcBounds(TRenderData,TColumn,Integer,Single). (Inherited from TCustomColumnBand.)
DoChanged | Represents method DoChanged. (Inherited from TVisibleRenderItem.)
DoClick | Represents method DoClick. (Inherited from TCustomColumnBand.)
DoDrawText(TRenderData,TColumn,Integer) | Represents method DoDrawText(TRenderData,TColumn,Integer). (Inherited from TCustomColumnBand.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
HeaderRender(TColumn) | Represents method HeaderRender(TColumn). (Inherited from TCustomColumnBand.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
InitFormat | Overloaded. Represents method InitFormat. (Inherited from TCustomColumnBand.)
InitFormat(TTextFormat) | Overloaded. Represents method InitFormat(TTextFormat). (Inherited from TCustomColumnBand.)
LevelTop(Integer) | Represents method LevelTop(Integer). (Inherited from TCustomColumnBand.)
Mouse(TMouseState,Single,Single) | Represents method Mouse(TMouseState,Single,Single). (Overrides TGridBand.Mouse(TMouseState,Single,Single).)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TCustomColumnBand.Paint(TRenderData,TRender).)
RenderAlign(TColumn) | Represents method RenderAlign(TColumn). (Inherited from TCustomColumnBand.)
RenderSize | Represents method RenderSize. (Inherited from TCustomColumnBand.)
RowCount | Represents method RowCount. (Inherited from TCustomColumnBand.)
SetColumns(TColumns) | Represents method SetColumns(TColumns). (Inherited from TCustomColumnBand.)
SetRender(TRender) | Represents method SetRender(TRender). (Inherited from TVisibleRenderItem.)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
Top
Fields
Show:
Name | Description
Bottom | Represents field Bottom. (Inherited from TGridBand.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
IColumns | Represents field IColumns. (Inherited from TCustomColumnBand.)
IData | Represents field IData. (Inherited from TCustomColumnBand.)
IHeights | Represents field IHeights. (Inherited from TCustomColumnBand.)
IJustRepaint | Represents field IJustRepaint. (Inherited from TGridBandLines.)
ISingleRow | Represents field ISingleRow. (Inherited from TCustomColumnBand.)
IVisible | Represents field IVisible. (Inherited from TCustomColumnBand.)
MinX | Represents field MinX. (Inherited from TCustomColumnBand.)
MouseColumn | Represents field MouseColumn. (Inherited from TCustomColumnBand.)
ResizeTolerance | Represents field ResizeTolerance. (Inherited from TCustomColumnBand.)
ShouldPaintTexts | Represents field ShouldPaintTexts. (Inherited from TCustomColumnBand.)
StartX | Represents field StartX. (Inherited from TCustomColumnBand.)
Top | Represents field Top. (Inherited from TGridBand.)
Width | Represents field Width. (Inherited from TCustomColumnBand.)
Top
See Also

Reference

  • Tee.Grid.Totals


TTotalsHeader Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TTotalsHeader class. (Overrides TBaseTotals.Create(TCollection).)
CreateTotals(TCollection,TColumnTotals) | Initializes a new instance of the TTotalsHeader class.
Top


TTotalsHeader.Create(TCollection) Constructor

Summary

Initializes a new instance of the TTotalsHeader class.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TBaseTotals.Create(TCollection)
See Also

Reference

  • TTotalsHeader
  • Tee.Grid.Totals


TTotalsHeader.CreateTotals(TCollection,TColumnTotals) Constructor

Summary

Initializes a new instance of the TTotalsHeader class.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Constructor CreateTotals(const ACollection:TCollection; const ATotals:TColumnTotals);

Parameters

ACollection
Type: TCollection

ATotals
Type: TColumnTotals

See Also

Reference

  • TTotalsHeader
  • Tee.Grid.Totals


TTotalsHeader Properties

Properties
Name | Description
Totals | Represents property Totals.
Top


TTotalsHeader.Totals Property

Summary

Represents property Totals.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 property Totals : TColumnTotals read FTotals write SetTotals;

Property Value

Type: TColumnTotals

See Also

Reference

  • TTotalsHeader
  • Tee.Grid.Totals


TTotalsHeader Methods

Methods
Name | Description
AsString(TColumn) | Represents method AsString(TColumn). (Overrides TCustomColumnBand.AsString(TColumn).)
Description | Represents method Description. (Overrides TGridBand.Description.)
Top


TTotalsHeader.AsString(TColumn) Method

Summary

Represents method AsString(TColumn).

Namespace: Tee.Grid.Totals
Syntax
Delphi
protected
 function AsString(const AColumn:TColumn):String; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

Overrides

TCustomColumnBand.AsString(TColumn)
See Also

Reference

  • TTotalsHeader
  • Tee.Grid.Totals


TTotalsHeader.Description Method

Summary

Represents method Description.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 class function Description:String; override;

Return Value

Type: String

Overrides

TGridBand.Description
See Also

Reference

  • TTotalsHeader
  • Tee.Grid.Totals


Tee.Grid.Totals Records

Records
Name | Description
TColumnTotals.TTotalCalculation | Represents type TTotalCalculation.
TColumnTotals.TTotals | Represents type TTotals.
Top


TColumnTotals.TTotalCalculation Record

Summary

Represents type TTotalCalculation.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
type
 TTotalCalculation=record
 end;

The TColumnTotals.TTotalCalculation type exposes the following members.

Fields
Show:
Name | Description
Calculation | Represents field Calculation.
Column | Represents field Column.
Top
See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotalCalculation Fields

Fields
Name | Description
Calculation | Represents field Calculation.
Column | Represents field Column.
Top


TColumnTotals.TTotalCalculation.Calculation Field

Summary

Represents field Calculation.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Calculation : TColumnCalculation;

Field Value

Type: TColumnCalculation

See Also

Reference

  • TColumnTotals.TTotalCalculation
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotalCalculation.Column Field

Summary

Represents field Column.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Column: TColumn;

Field Value

Type: TColumn

See Also

Reference

  • TColumnTotals.TTotalCalculation
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals Record

Summary

Represents type TTotals.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
type
 TTotals=record
 end;

The TColumnTotals.TTotals type exposes the following members.

Methods
Show:
Name | Description
Add(String,TColumnCalculation) | Overloaded. Represents method Add(String,TColumnCalculation).
Add(TColumn,TColumnCalculation) | Overloaded. Represents method Add(TColumn,TColumnCalculation).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Find(TColumn,TColumnCalculation) | Represents method Find(TColumn,TColumnCalculation).
IndexOf(TColumn) | Represents method IndexOf(TColumn).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals Methods

Methods
Name | Description
Add(String,TColumnCalculation) | Overloaded. Represents method Add(String,TColumnCalculation).
Add(TColumn,TColumnCalculation) | Overloaded. Represents method Add(TColumn,TColumnCalculation).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Find(TColumn,TColumnCalculation) | Represents method Find(TColumn,TColumnCalculation).
IndexOf(TColumn) | Represents method IndexOf(TColumn).
Top


TColumnTotals.TTotals.Add(String,TColumnCalculation) Method

Summary

Represents method Add(String,TColumnCalculation).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 procedure Add(const AColumnName:String; const ACalculation:TColumnCalculation); overload;

Parameters

AColumnName
Type: String

ACalculation
Type: TColumnCalculation

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.Add(TColumn,TColumnCalculation) Method

Summary

Represents method Add(TColumn,TColumnCalculation).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 procedure Add(const AColumn:TColumn; const ACalculation:TColumnCalculation); overload;

Parameters

AColumn
Type: TColumn

ACalculation
Type: TColumnCalculation

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.Clear Method

Summary

Represents method Clear.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 procedure Clear; inline;
See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.Count Method

Summary

Represents method Count.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 procedure Delete(const AIndex:Integer);

Parameters

AIndex
Type: Integer

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.Find(TColumn,TColumnCalculation) Method

Summary

Represents method Find(TColumn,TColumnCalculation).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 function Find(const AColumn:TColumn; out ACalculation:TColumnCalculation):Boolean;

Parameters

AColumn
Type: TColumn

ACalculation
Type: TColumnCalculation

Return Value

Type: Boolean

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals.IndexOf(TColumn) Method

Summary

Represents method IndexOf(TColumn).

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 function IndexOf(const AColumn:TColumn):Integer;

Parameters

AColumn
Type: TColumn

Return Value

Type: Integer

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


TColumnTotals.TTotals Fields

Fields
Name | Description
Items | Represents field Items.
Top


TColumnTotals.TTotals.Items Field

Summary

Represents field Items.

Namespace: Tee.Grid.Totals
Syntax
Delphi
public
 Items : Array of TTotalCalculation;

Field Value

Type: Array of TTotalCalculation

See Also

Reference

  • TColumnTotals.TTotals
  • TColumnTotals
  • Tee.Grid.Totals


Tee.Grid.Totals Routines

Routines
Name | Description
CalculationToString(TColumnCalculation) | Represents method CalculationToString(TColumnCalculation).
Top


CalculationToString(TColumnCalculation) Method

Summary

Represents method CalculationToString(TColumnCalculation).

Namespace: Tee.Grid.Totals
Syntax
Delphi
function CalculationToString(const ACalculation:TColumnCalculation):String;

Parameters

ACalculation
Type: TColumnCalculation

Return Value

Type: String

See Also

Reference

  • Tee.Grid.Totals


Tee.GridData Namespace

Summary

Represents namespace Tee.GridData.

Classes
Name | Description
TVirtualData | Represents type TVirtualData.
Top
Records
Name | Description
TInfoHelper | Represents type TInfoHelper.
TVirtualDataClasses | Represents type TVirtualDataClasses.
Top
Enumerations
Name | Description
TColumnCalculation | Represents type TColumnCalculation.
TEditMode | Represents type TEditMode.
Top
Delegates
Name | Description
TDataEditingEvent | Represents type TDataEditingEvent.
TRowChangedEvent | Represents type TRowChangedEvent.
Top
Types
Name | Description
TFloat | Represents an alias of the Double type.
TVirtualDataClass | Represents type TVirtualDataClass.
Top
Routines
Name | Description
TryStrToUInt(string,Cardinal) | Represents method TryStrToUInt(string,Cardinal).
TryStrToUInt64(string,UInt64) | Represents method TryStrToUInt64(string,UInt64).
Top


Tee.GridData Classes

Classes
Name | Description
TVirtualData | Represents type TVirtualData.
Top


TVirtualData Class

Summary

Represents type TVirtualData.

Namespace: Tee.GridData
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.Grid.RowGroup.TDataAccess
Tee.Grid.RowGroup.TVirtualDataAccess
Tee.Grid.Rows.TVirtualDataAccess
Tee.Grid.TDataAccess
Tee.Grid.TVirtualDataAccess
Tee.GridData.DB.TVirtualDBData
Tee.GridData.Rtti.TVirtualDataRtti
Tee.GridData.Strings.TVirtualModeData
Syntax
Delphi
type
 TVirtualData=class abstract
 end;

The TVirtualData type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing.
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject).
AddColumns(TColumns) | Represents method AddColumns(TColumns).
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer).
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer).
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single).
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn).
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation).
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer).
CanSortBy(TColumn) | Represents method CanSortBy(TColumn).
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer).
Count | Represents method Count.
DataType(TColumn) | Represents method DataType(TColumn).
DoError(String) | Represents method DoError(String).
EditingChanged(Boolean) | Represents method EditingChanged(Boolean).
EditMode(TEditMode) | Represents method EditMode(TEditMode).
Empty | Represents method Empty.
From(TComponent) | Overloaded. Represents method From(TComponent).
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn).
HasDetail(Integer) | Represents method HasDetail(Integer).
InternalRefresh | Represents method InternalRefresh.
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn).
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean).
KnownCount | Represents method KnownCount.
Load(TColumns) | Represents method Load(TColumns).
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn).
PastEnd(Integer) | Represents method PastEnd(Integer).
ReadOnly(TColumn) | Represents method ReadOnly(TColumn).
Refresh | Represents method Refresh.
Repaint | Represents method Repaint.
RowChanged(Integer) | Represents method RowChanged(Integer).
SampleDate(TColumn) | Represents method SampleDate(TColumn).
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn).
SampleTime(TColumn) | Represents method SampleTime(TColumn).
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject).
SetFirstRow(Integer) | Represents method SetFirstRow(Integer).
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String).
SortBy(TColumn) | Represents method SortBy(TColumn).
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer).
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow.
FOnEditing | Represents field FOnEditing.
FOnRefresh | Represents field FOnRefresh.
FOnRepaint | Represents field FOnRepaint.
FRefreshing | Represents field FRefreshing.
PictureClass | Represents field PictureClass.
Top
See Also

Reference

  • Tee.GridData


TVirtualData Properties

Properties
Name | Description
Refreshing | Represents property Refreshing.
Top


TVirtualData.Refreshing Property

Summary

Represents property Refreshing.

Namespace: Tee.GridData
Syntax
Delphi
public
 Property Refreshing :Boolean Read FRefreshing;

Property Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData Methods

Methods
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject).
AddColumns(TColumns) | Represents method AddColumns(TColumns).
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer).
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer).
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single).
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn).
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation).
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer).
CanSortBy(TColumn) | Represents method CanSortBy(TColumn).
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer).
Count | Represents method Count.
DataType(TColumn) | Represents method DataType(TColumn).
DoError(String) | Represents method DoError(String).
EditingChanged(Boolean) | Represents method EditingChanged(Boolean).
EditMode(TEditMode) | Represents method EditMode(TEditMode).
Empty | Represents method Empty.
From(TComponent) | Overloaded. Represents method From(TComponent).
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn).
HasDetail(Integer) | Represents method HasDetail(Integer).
InternalRefresh | Represents method InternalRefresh.
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn).
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean).
KnownCount | Represents method KnownCount.
Load(TColumns) | Represents method Load(TColumns).
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn).
PastEnd(Integer) | Represents method PastEnd(Integer).
ReadOnly(TColumn) | Represents method ReadOnly(TColumn).
Refresh | Represents method Refresh.
Repaint | Represents method Repaint.
RowChanged(Integer) | Represents method RowChanged(Integer).
SampleDate(TColumn) | Represents method SampleDate(TColumn).
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn).
SampleTime(TColumn) | Represents method SampleTime(TColumn).
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject).
SetFirstRow(Integer) | Represents method SetFirstRow(Integer).
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String).
SortBy(TColumn) | Represents method SortBy(TColumn).
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer).
Top


TVirtualData.Add(TColumns,String,TObject) Method

Summary

Represents method Add(TColumns,String,TObject).

Namespace: Tee.GridData
Syntax
Delphi
protected
 class function Add(const AColumns:TColumns; const AName:String; const ATag:TObject):TColumn; overload; static;

Parameters

AColumns
Type: TColumns

AName
Type: String

ATag
Type: TObject

Return Value

Type: TColumn

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.AddColumns(TColumns) Method

Summary

Represents method AddColumns(TColumns).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure AddColumns(const AColumns:TColumns); virtual; abstract;

Parameters

AColumns
Type: TColumns

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.AsFloat(TColumn,Integer) Method

Summary

Represents method AsFloat(TColumn,Integer).

Namespace: Tee.GridData
Syntax
Delphi
public
 function AsFloat(const AColumn:TColumn; const ARow:Integer):TFloat; virtual;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: TFloat

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.AsString(TColumn,Integer) Method

Summary

Represents method AsString(TColumn,Integer).

Namespace: Tee.GridData
Syntax
Delphi
public
 function AsString(const AColumn:TColumn; const ARow:Integer):String; virtual; abstract;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.AutoHeight(TPainter,TColumn,Integer,Single) Method

Summary

Represents method AutoHeight(TPainter,TColumn,Integer,Single).

Namespace: Tee.GridData
Syntax
Delphi
public
 function AutoHeight(const APainter:TPainter; const AColumn:TColumn; const ARow:Integer; out AHeight:Single):Boolean; virtual;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

ARow
Type: Integer

AHeight
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.AutoWidth(TPainter,TColumn) Method

Summary

Represents method AutoWidth(TPainter,TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function AutoWidth(const APainter:TPainter; const AColumn:TColumn):Single; virtual; abstract;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Calculate(TColumn,TColumnCalculation) Method

Summary

Represents method Calculate(TColumn,TColumnCalculation).

Namespace: Tee.GridData
Syntax
Delphi
public
 function Calculate(const AColumn:TColumn; const ACalculation:TColumnCalculation):TFloat;

Parameters

AColumn
Type: TColumn

ACalculation
Type: TColumnCalculation

Return Value

Type: TFloat

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.CanExpand(TRender,Integer) Method

Summary

Represents method CanExpand(TRender,Integer).

Namespace: Tee.GridData
Syntax
Delphi
public
 function CanExpand(const Sender:TRender; const ARow:Integer):Boolean; virtual;

Parameters

Sender
Type: TRender

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.CanSortBy(TColumn) Method

Summary

Represents method CanSortBy(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function CanSortBy(const AColumn:TColumn):Boolean; virtual;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.ChangeSelectedRow(Integer) Method

Summary

Represents method ChangeSelectedRow(Integer).

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure ChangeSelectedRow(const ARow:Integer);

Parameters

ARow
Type: Integer

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Count Method

Summary

Represents method Count.

Namespace: Tee.GridData
Syntax
Delphi
public
 function Count:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.DataType(TColumn) Method

Summary

Represents method DataType(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function DataType(const AColumn:TColumn):PTypeInfo; virtual;

Parameters

AColumn
Type: TColumn

Return Value

Type: PTypeInfo

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.DoError(String) Method

Summary

Represents method DoError(String).

Namespace: Tee.GridData
Syntax
Delphi
protected
 class procedure DoError(const AText:String); static;

Parameters

AText
Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.EditingChanged(Boolean) Method

Summary

Represents method EditingChanged(Boolean).

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure EditingChanged(const IsEditing:Boolean); virtual;

Parameters

IsEditing
Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.EditMode(TEditMode) Method

Summary

Represents method EditMode(TEditMode).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure EditMode(const AMode:TEditMode); virtual;

Parameters

AMode
Type: TEditMode

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Empty Method

Summary

Represents method Empty.

Namespace: Tee.GridData
Syntax
Delphi
protected
 function Empty:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.From(TComponent) Method

Summary

Represents method From(TComponent).

Namespace: Tee.GridData
Syntax
Delphi
public
 class function From(const ASource:TComponent):TVirtualData; overload; virtual;

Parameters

ASource
Type: TComponent

Return Value

Type: TVirtualData

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.GetDetail(Integer,TColumns,TColumn) Method

Summary

Represents method GetDetail(Integer,TColumns,TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function GetDetail(const ARow:Integer; const AColumns:TColumns; out AParent:TColumn):TVirtualData; virtual;

Parameters

ARow
Type: Integer

AColumns
Type: TColumns

AParent
Type: TColumn

Return Value

Type: TVirtualData

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.HasDetail(Integer) Method

Summary

Represents method HasDetail(Integer).

Namespace: Tee.GridData
Syntax
Delphi
public
 function HasDetail(const ARow:Integer):Boolean; virtual;

Parameters

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.InternalRefresh Method

Summary

Represents method InternalRefresh.

Namespace: Tee.GridData
Syntax
Delphi
protected
 Procedure InternalRefresh; virtual;
See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.IsNumeric(TColumn) Method

Summary

Represents method IsNumeric(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 class function IsNumeric(const AColumn:TColumn):Boolean; overload; virtual;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.IsSorted(TColumn,Boolean) Method

Summary

Represents method IsSorted(TColumn,Boolean).

Namespace: Tee.GridData
Syntax
Delphi
public
 function IsSorted(const AColumn:TColumn; out Ascending:Boolean):Boolean; virtual;

Parameters

AColumn
Type: TColumn

Ascending
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.KnownCount Method

Summary

Represents method KnownCount.

Namespace: Tee.GridData
Syntax
Delphi
protected
 function KnownCount: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Load(TColumns) Method

Summary

Represents method Load(TColumns).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure Load(const AColumns:TColumns); virtual; abstract;

Parameters

AColumns
Type: TColumns

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.LongestString(TPainter,TColumn) Method

Summary

Represents method LongestString(TPainter,TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function LongestString(const APainter:TPainter; const AColumn:TColumn):Single;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.PastEnd(Integer) Method

Summary

Represents method PastEnd(Integer).

Namespace: Tee.GridData
Syntax
Delphi
protected
 function PastEnd(const ARow:Integer):Boolean; virtual;

Parameters

ARow
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.ReadOnly(TColumn) Method

Summary

Represents method ReadOnly(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 function ReadOnly(const AColumn:TColumn):Boolean; virtual;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Refresh Method

Summary

Represents method Refresh.

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure Refresh;
See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.Repaint Method

Summary

Represents method Repaint.

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure Repaint;
See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.RowChanged(Integer) Method

Summary

Represents method RowChanged(Integer).

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure RowChanged(const ARow:Integer); virtual;

Parameters

ARow
Type: Integer

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SampleDate(TColumn) Method

Summary

Represents method SampleDate(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
protected
 function SampleDate(const AColumn:TColumn): String;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SampleDateTime(TColumn) Method

Summary

Represents method SampleDateTime(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
protected
 function SampleDateTime(const AColumn:TColumn):String;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SampleTime(TColumn) Method

Summary

Represents method SampleTime(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
protected
 function SampleTime(const AColumn:TColumn):String;

Parameters

AColumn
Type: TColumn

Return Value

Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SetField(TColumn,TObject) Method

Summary

Represents method SetField(TColumn,TObject).

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure SetField(const AColumn:TColumn; const ASource:TObject); virtual;

Parameters

AColumn
Type: TColumn

ASource
Type: TObject

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SetFirstRow(Integer) Method

Summary

Represents method SetFirstRow(Integer).

Namespace: Tee.GridData
Syntax
Delphi
protected
 procedure SetFirstRow(const ARow:Integer); virtual;

Parameters

ARow
Type: Integer

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SetValue(TColumn,Integer,String) Method

Summary

Represents method SetValue(TColumn,Integer,String).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure SetValue(const AColumn:TColumn; const ARow:Integer; const AText:String); virtual; abstract;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AText
Type: String

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.SortBy(TColumn) Method

Summary

Represents method SortBy(TColumn).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure SortBy(const AColumn:TColumn); virtual;

Parameters

AColumn
Type: TColumn

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.ToggleBoolean(TColumn,Integer) Method

Summary

Represents method ToggleBoolean(TColumn,Integer).

Namespace: Tee.GridData
Syntax
Delphi
public
 procedure ToggleBoolean(const AColumn:TColumn; const ARow:Integer);

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData Fields

Fields
Name | Description
FOnChangeRow | Represents field FOnChangeRow.
FOnEditing | Represents field FOnEditing.
FOnRefresh | Represents field FOnRefresh.
FOnRepaint | Represents field FOnRepaint.
FRefreshing | Represents field FRefreshing.
PictureClass | Represents field PictureClass.
Top


TVirtualData.FOnChangeRow Field

Summary

Represents field FOnChangeRow.

Namespace: Tee.GridData
Syntax
Delphi
protected
 FOnChangeRow : TRowChangedEvent;

Field Value

Type: TRowChangedEvent

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.FOnEditing Field

Summary

Represents field FOnEditing.

Namespace: Tee.GridData
Syntax
Delphi
protected
 FOnEditing : TDataEditingEvent;

Field Value

Type: TDataEditingEvent

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.FOnRefresh Field

Summary

Represents field FOnRefresh.

Namespace: Tee.GridData
Syntax
Delphi
protected
 FOnRepaint,
 FOnRefresh : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.FOnRepaint Field

Summary

Represents field FOnRepaint.

Namespace: Tee.GridData
Syntax
Delphi
protected
 FOnRepaint,
 FOnRefresh : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.FRefreshing Field

Summary

Represents field FRefreshing.

Namespace: Tee.GridData
Syntax
Delphi
protected
 FRefreshing : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TVirtualData
  • Tee.GridData


TVirtualData.PictureClass Field

Summary

Represents field PictureClass.

Namespace: Tee.GridData
Syntax
Delphi
protected
 PictureClass : TPersistentClass;

Field Value

Type: TPersistentClass

See Also

Reference

  • TVirtualData
  • Tee.GridData


Tee.GridData Records

Records
Name | Description
TInfoHelper | Represents type TInfoHelper.
TVirtualDataClasses | Represents type TVirtualDataClasses.
Top


TInfoHelper Record

Summary

Represents type TInfoHelper.

Namespace: Tee.GridData
Syntax
Delphi
type
 TInfoHelper=record
 end;

The TInfoHelper type exposes the following members.

Methods
Show:
Name | Description
ShouldQuote(PTypeInfo) | Represents method ShouldQuote(PTypeInfo).
Top
See Also

Reference

  • Tee.GridData


TInfoHelper Methods

Methods
Name | Description
ShouldQuote(PTypeInfo) | Represents method ShouldQuote(PTypeInfo).
Top


TInfoHelper.ShouldQuote(PTypeInfo) Method

Summary

Represents method ShouldQuote(PTypeInfo).

Namespace: Tee.GridData
Syntax
Delphi
public
 class function ShouldQuote(const AType:PTypeInfo):Boolean; static;

Parameters

AType
Type: PTypeInfo

Return Value

Type: Boolean

See Also

Reference

  • TInfoHelper
  • Tee.GridData


TVirtualDataClasses Record

Summary

Represents type TVirtualDataClasses.

Namespace: Tee.GridData
Syntax
Delphi
type
 TVirtualDataClasses=record
 end;

The TVirtualDataClasses type exposes the following members.

Methods
Show:
Name | Description
Guess(TComponent) | Represents method Guess(TComponent).
Register(TVirtualDataClass) | Represents method Register(TVirtualDataClass).
UnRegister(TVirtualDataClass) | Represents method UnRegister(TVirtualDataClass).
Top
See Also

Reference

  • Tee.GridData


TVirtualDataClasses Methods

Methods
Name | Description
Guess(TComponent) | Represents method Guess(TComponent).
Register(TVirtualDataClass) | Represents method Register(TVirtualDataClass).
UnRegister(TVirtualDataClass) | Represents method UnRegister(TVirtualDataClass).
Top


TVirtualDataClasses.Guess(TComponent) Method

Summary

Represents method Guess(TComponent).

Namespace: Tee.GridData
Syntax
Delphi
public
 class function Guess(const ASource:TComponent):TVirtualData; static;

Parameters

ASource
Type: TComponent

Return Value

Type: TVirtualData

See Also

Reference

  • TVirtualDataClasses
  • Tee.GridData


TVirtualDataClasses.Register(TVirtualDataClass) Method

Summary

Represents method Register(TVirtualDataClass).

Namespace: Tee.GridData
Syntax
Delphi
public
 class procedure Register(const AClass:TVirtualDataClass); static;

Parameters

AClass
Type: TVirtualDataClass

See Also

Reference

  • TVirtualDataClasses
  • Tee.GridData


TVirtualDataClasses.UnRegister(TVirtualDataClass) Method

Summary

Represents method UnRegister(TVirtualDataClass).

Namespace: Tee.GridData
Syntax
Delphi
public
 class procedure UnRegister(const AClass:TVirtualDataClass); static;

Parameters

AClass
Type: TVirtualDataClass

See Also

Reference

  • TVirtualDataClasses
  • Tee.GridData


Tee.GridData Enumerations

Enumerations
Name | Description
TColumnCalculation | Represents type TColumnCalculation.
TEditMode | Represents type TEditMode.
Top


TColumnCalculation Enumeration

Summary

Represents type TColumnCalculation.

Namespace: Tee.GridData
Syntax
Delphi
type
 TColumnCalculation=(Count,Sum,Min,Max,Average);

The TColumnCalculation type exposes the following members.

Members
Show:
Name | Description
Average | Represents constant Average.
Count | Represents constant Count.
Max | Represents constant Max.
Min | Represents constant Min.
Sum | Represents constant Sum.
Top
See Also

Reference

  • Tee.GridData


TEditMode Enumeration

Summary

Represents type TEditMode.

Namespace: Tee.GridData
Syntax
Delphi
type
 TEditMode=(Start,Cancel,Finish);

The TEditMode type exposes the following members.

Members
Show:
Name | Description
Cancel | Represents constant Cancel.
Finish | Represents constant Finish.
Start | Represents constant Start.
Top
See Also

Reference

  • Tee.GridData


Tee.GridData Delegates

Delegates
Name | Description
TDataEditingEvent | Represents type TDataEditingEvent.
TRowChangedEvent | Represents type TRowChangedEvent.
Top


TDataEditingEvent Delegate

Summary

Represents type TDataEditingEvent.

Namespace: Tee.GridData
Syntax
Delphi
type
 TDataEditingEvent=procedure(const Sender:TObject; const IsEditing:Boolean) of object;
See Also

Reference

  • Tee.GridData


TRowChangedEvent Delegate

Summary

Represents type TRowChangedEvent.

Namespace: Tee.GridData
Syntax
Delphi
type
 TRowChangedEvent=procedure(const Sender:TObject; const ARow:Integer) of object;
See Also

Reference

  • Tee.GridData


Tee.GridData Types

Types
Name | Description
TFloat | Represents an alias of the Double type.
TVirtualDataClass | Represents type TVirtualDataClass.
Top


TFloat Type

Summary

Represents an alias of the Double type.

Namespace: Tee.GridData
Syntax
Delphi
type
 TFloat=Double;
See Also

Reference

  • Tee.GridData


TVirtualDataClass Type

Summary

Represents type TVirtualDataClass.

Namespace: Tee.GridData
Syntax
Delphi
type
 TVirtualDataClass=class of TVirtualData;
See Also

Reference

  • Tee.GridData


Tee.GridData Routines

Routines
Name | Description
TryStrToUInt(string,Cardinal) | Represents method TryStrToUInt(string,Cardinal).
TryStrToUInt64(string,UInt64) | Represents method TryStrToUInt64(string,UInt64).
Top


TryStrToUInt(string,Cardinal) Method

Summary

Represents method TryStrToUInt(string,Cardinal).

Namespace: Tee.GridData
Syntax
Delphi
function TryStrToUInt(const S: string; out Value: Cardinal): Boolean;

Parameters

S
Type: string

Value
Type: Cardinal

Return Value

Type: Boolean

See Also

Reference

  • Tee.GridData


TryStrToUInt64(string,UInt64) Method

Summary

Represents method TryStrToUInt64(string,UInt64).

Namespace: Tee.GridData
Syntax
Delphi
function TryStrToUInt64(const S: string; out Value: UInt64): Boolean;

Parameters

S
Type: string

Value
Type: UInt64

Return Value

Type: Boolean

See Also

Reference

  • Tee.GridData


Tee.GridData.DB Namespace

Summary

Represents namespace Tee.GridData.DB.

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TPictureAccess | Represents type TPictureAccess.
TVirtualDataLink | Represents type TVirtualDataLink.
TVirtualDBData | Represents type TVirtualDBData.
Top
Enumerations
Name | Description
TVirtualFetchMode | Represents type TVirtualFetchMode.
Top
Types
Name | Description
TDataSetRecNo | Represents an alias of the Integer type.
Top
Routines
Name | Description
IsPictureField(TField) | Represents method IsPictureField(TField).
Top


Tee.GridData.DB Classes

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TPictureAccess | Represents type TPictureAccess.
TVirtualDataLink | Represents type TVirtualDataLink.
TVirtualDBData | Represents type TVirtualDBData.
Top


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: Tee.GridData.DB
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Columns.TColumn
Tee.GridData.DB.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);

The TColumnAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TColumn class. (Overrides TVisibleRenderItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
DataFormat | Represents property DataFormat. (Inherited from TColumn.)
DefaultHorizAlign | Represents property DefaultHorizAlign. (Inherited from TColumn.)
Expanded | Represents property Expanded. (Inherited from TColumn.)
Format | Represents property Format. (Inherited from TVisibleRenderItem.)
Header | Represents property Header. (Inherited from TColumn.)
Items | Represents property Items. (Inherited from TColumn.)
LoadOrder | Represents property LoadOrder. (Inherited from TColumn.)
Locked | Represents property Locked. (Inherited from TColumn.)
Margins | Represents property Margins. (Inherited from TColumn.)
Parent | Represents property Parent. (Inherited from TColumn.)
ParentFormat | Represents property ParentFormat. (Inherited from TColumn.)
ReadOnly | Represents property ReadOnly. (Inherited from TColumn.)
Render | Represents property Render. (Inherited from TVisibleRenderItem.)
Selectable | Represents property Selectable. (Inherited from TColumn.)
Tag | Represents property Tag. (Inherited from TVisibleRenderItem.)
TagObject | Represents property TagObject. (Inherited from TVisibleRenderItem.)
TextAlign | Represents property TextAlign. (Inherited from TColumn.)
TextAlignment | Represents property TextAlignment. (Inherited from TColumn.)
TopParent | Represents property TopParent. (Inherited from TColumn.)
Visible | Represents property Visible. (Inherited from TVisibleRenderItem.)
Width | Represents property Width. (Inherited from TColumn.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleRenderItem.Assign(TPersistent).)
AutoWidth(TPainter) | Represents method AutoWidth(TPainter). (Inherited from TColumn.)
CanDisplay | Represents method CanDisplay. (Inherited from TColumn.)
Changed(TObject) | Represents method Changed(TObject). (Inherited from TVisibleRenderItem.)
CreateRender | Represents method CreateRender. (Inherited from TVisibleRenderItem.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TColumn.)
DoChanged | Represents method DoChanged. (Overrides TVisibleRenderItem.DoChanged.)
GetFormat | Represents method GetFormat. (Inherited from TVisibleRenderItem.)
HasFormat | Represents method HasFormat. (Inherited from TVisibleRenderItem.)
HasItems | Represents method HasItems. (Inherited from TColumn.)
HasRender | Represents method HasRender. (Inherited from TVisibleRenderItem.)
Hide | Represents method Hide. (Inherited from TVisibleRenderItem.)
HorizAlign | Represents method HorizAlign. (Inherited from TColumn.)
InitAlign(THorizontalAlign) | Represents method InitAlign(THorizontalAlign). (Inherited from TColumn.)
Level | Represents method Level. (Inherited from TColumn.)
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender). (Overrides TVisibleRenderItem.Paint(TRenderData,TRender).)
ParentColumns | Represents method ParentColumns. (Inherited from TColumn.)
Right | Represents method Right. (Inherited from TColumn.)
SetIndex(Integer) | Represents method SetIndex(Integer). (Inherited from TColumn.)
SetRender(TRender) | Represents method SetRender(TRender). (Overrides TVisibleRenderItem.SetRender(TRender).)
Show | Represents method Show. (Inherited from TVisibleRenderItem.)
ToString | Represents method ToString. (Inherited from TColumn.)
Top
Events
Show:
Name | Description
OnPaint | Represents property OnPaint. (Inherited from TColumn.)
Top
Fields
Show:
Name | Description
EditorClass | Represents field EditorClass. (Inherited from TColumn.)
FLink | Represents field FLink. (Inherited from TColumn.)
FRender | Represents field FRender. (Inherited from TVisibleRenderItem.)
ITopParent | Represents field ITopParent. (Inherited from TColumn.)
Left | Represents field Left. (Inherited from TColumn.)
ValidWidth | Represents field ValidWidth. (Inherited from TColumn.)
Top
See Also

Reference

  • Tee.GridData.DB


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: Tee.GridData.DB
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TPicture
Tee.GridData.DB.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);

The TPictureAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPicture class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Top
Methods
Show:
Name | Description
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Clear | Represents method Clear. (Inherited from TPicture.)
FreeInternal | Represents method FreeInternal. (Inherited from TPicture.)
NewPicture | Represents method NewPicture. (Inherited from TPicture.)
SetGraphic(TObject) | Represents method SetGraphic(TObject). (Inherited from TPicture.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Internal | Represents field Internal. (Inherited from TPicture.)
Original | Represents field Original. (Inherited from TPicture.)
Stretch | Represents field Stretch. (Inherited from TPicture.)
TagObject | Represents field TagObject. (Inherited from TPicture.)
Top
See Also

Reference

  • Tee.GridData.DB


TVirtualDataLink Class

Summary

Represents type TVirtualDataLink.

Namespace: Tee.GridData.DB
Inheritance Hierarchy
TDataLink
Tee.GridData.DB.TVirtualDataLink
Syntax
Delphi
type
 TVirtualDataLink=class(TDataLink)
 end;

The TVirtualDataLink type exposes the following members.

Methods
Show:
Name | Description
ActiveChanged | Represents method ActiveChanged.
DataSetChanged | Represents method DataSetChanged.
DataSetScrolled(Integer) | Represents method DataSetScrolled(Integer).
EditingChanged | Represents method EditingChanged.
LayoutChanged | Represents method LayoutChanged.
RecordChanged(TField) | Represents method RecordChanged(TField).
UpdateData | Represents method UpdateData.
Top
See Also

Reference

  • Tee.GridData.DB


TVirtualDataLink Methods

Methods
Name | Description
ActiveChanged | Represents method ActiveChanged.
DataSetChanged | Represents method DataSetChanged.
DataSetScrolled(Integer) | Represents method DataSetScrolled(Integer).
EditingChanged | Represents method EditingChanged.
LayoutChanged | Represents method LayoutChanged.
RecordChanged(TField) | Represents method RecordChanged(TField).
UpdateData | Represents method UpdateData.
Top


TVirtualDataLink.ActiveChanged Method

Summary

Represents method ActiveChanged.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure ActiveChanged; override;
See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.DataSetChanged Method

Summary

Represents method DataSetChanged.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure DataSetChanged; override;
See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.DataSetScrolled(Integer) Method

Summary

Represents method DataSetScrolled(Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 Procedure DataSetScrolled (Distance :Integer); Override;

Parameters

Distance
Type: Integer

See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.EditingChanged Method

Summary

Represents method EditingChanged.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure EditingChanged; override;
See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.LayoutChanged Method

Summary

Represents method LayoutChanged.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure LayoutChanged; override;
See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.RecordChanged(TField) Method

Summary

Represents method RecordChanged(TField).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure RecordChanged(Field: TField); override;

Parameters

Field
Type: TField

See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDataLink.UpdateData Method

Summary

Represents method UpdateData.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure UpdateData; override;
See Also

Reference

  • TVirtualDataLink
  • Tee.GridData.DB


TVirtualDBData Class

Summary

Represents type TVirtualDBData.

Namespace: Tee.GridData.DB
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.GridData.DB.TVirtualDBData
Syntax
Delphi
type
 TVirtualDBData=class(TVirtualData)
 end;

The TVirtualDBData type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TVirtualDBData class.
Top
Properties
Show:
Name | Description
DataSet | Represents property DataSet.
FetchMode | Represents property FetchMode.
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
Add(TColumns,TField) | Represents method Add(TColumns,TField).
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Overrides TVirtualData.AsFloat(TColumn,Integer).)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Overrides TVirtualData.AutoHeight(TPainter,TColumn,Integer,Single).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Overrides TVirtualData.Count.)
CreateLink | Represents method CreateLink.
DataType(TColumn) | Represents method DataType(TColumn). (Overrides TVirtualData.DataType(TColumn).)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Overrides TVirtualData.EditMode(TEditMode).)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
FieldOf(TColumn) | Represents method FieldOf(TColumn).
From(TComponent) | Represents method From(TComponent). (Overrides TVirtualData.From(TComponent).)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
HorizAlignOf(TField) | Represents method HorizAlignOf(TField).
InternalRefresh | Represents method InternalRefresh. (Overrides TVirtualData.InternalRefresh.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
LinkTo(TColumn,TField) | Represents method LinkTo(TColumn,TField).
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Overrides TVirtualData.PastEnd(Integer).)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Overrides TVirtualData.ReadOnly(TColumn).)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Overrides TVirtualData.RowChanged(Integer).)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Overrides TVirtualData.SetField(TColumn,TObject).)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Overrides TVirtualData.SetFirstRow(Integer).)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
IDataSet | Represents field IDataSet.
IDataSource | Represents field IDataSource.
ILink | Represents field ILink.
OwnsData | Represents field OwnsData.
OwnsDataSource | Represents field OwnsDataSource.
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.GridData.DB


TVirtualDBData Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TVirtualDBData class.
Top


TVirtualDBData.Destroy Destructor

Summary

Represents the destructor of the TVirtualDBData class.

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData Properties

Properties
Name | Description
DataSet | Represents property DataSet.
FetchMode | Represents property FetchMode.
Top


TVirtualDBData.DataSet Property

Summary

Represents property DataSet.

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 property DataSet:TDataSet read IDataSet;

Property Value

Type: TDataSet

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.FetchMode Property

Summary

Represents property FetchMode.

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 property FetchMode:TVirtualFetchMode read FFetchMode write SetFetchMode default TVirtualFetchMode.Automatic;

Property Value

Type: TVirtualFetchMode

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData Methods

Methods
Name | Description
Add(TColumns,TField) | Represents method Add(TColumns,TField).
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Overrides TVirtualData.AsFloat(TColumn,Integer).)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Overrides TVirtualData.AutoHeight(TPainter,TColumn,Integer,Single).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Count | Represents method Count. (Overrides TVirtualData.Count.)
CreateLink | Represents method CreateLink.
DataType(TColumn) | Represents method DataType(TColumn). (Overrides TVirtualData.DataType(TColumn).)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Overrides TVirtualData.EditMode(TEditMode).)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
FieldOf(TColumn) | Represents method FieldOf(TColumn).
From(TComponent) | Represents method From(TComponent). (Overrides TVirtualData.From(TComponent).)
HorizAlignOf(TField) | Represents method HorizAlignOf(TField).
InternalRefresh | Represents method InternalRefresh. (Overrides TVirtualData.InternalRefresh.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
LinkTo(TColumn,TField) | Represents method LinkTo(TColumn,TField).
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
PastEnd(Integer) | Represents method PastEnd(Integer). (Overrides TVirtualData.PastEnd(Integer).)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Overrides TVirtualData.ReadOnly(TColumn).)
RowChanged(Integer) | Represents method RowChanged(Integer). (Overrides TVirtualData.RowChanged(Integer).)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Overrides TVirtualData.SetField(TColumn,TObject).)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Overrides TVirtualData.SetFirstRow(Integer).)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
Top


TVirtualDBData.Add(TColumns,TField) Method

Summary

Represents method Add(TColumns,TField).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 class function Add(const AColumns:TColumns; const AField:TField):TColumn;

Parameters

AColumns
Type: TColumns

AField
Type: TField

Return Value

Type: TColumn

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.AddColumns(TColumns) Method

Summary

Represents method AddColumns(TColumns).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 procedure AddColumns(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.AddColumns(TColumns)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.AsFloat(TColumn,Integer) Method

Summary

Represents method AsFloat(TColumn,Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function AsFloat(const AColumn:TColumn; const ARow:Integer):TFloat; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: TFloat

Overrides

TVirtualData.AsFloat(TColumn,Integer)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.AsString(TColumn,Integer) Method

Summary

Represents method AsString(TColumn,Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function AsString(const AColumn:TColumn; const ARow:Integer):String; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: String

Overrides

TVirtualData.AsString(TColumn,Integer)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.AutoHeight(TPainter,TColumn,Integer,Single) Method

Summary

Represents method AutoHeight(TPainter,TColumn,Integer,Single).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function AutoHeight(const APainter:TPainter; const AColumn:TColumn; const ARow:Integer; out AHeight:Single):Boolean; override;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

ARow
Type: Integer

AHeight
Type: Single

Return Value

Type: Boolean

Overrides

TVirtualData.AutoHeight(TPainter,TColumn,Integer,Single)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.AutoWidth(TPainter,TColumn) Method

Summary

Represents method AutoWidth(TPainter,TColumn).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function AutoWidth(const APainter:TPainter; const AColumn:TColumn):Single; override;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

Overrides

TVirtualData.AutoWidth(TPainter,TColumn)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.Count Method

Summary

Represents method Count.

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TVirtualData.Count
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.CreateLink Method

Summary

Represents method CreateLink.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure CreateLink;
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.DataType(TColumn) Method

Summary

Represents method DataType(TColumn).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function DataType(const AColumn:TColumn):PTypeInfo; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: PTypeInfo

Overrides

TVirtualData.DataType(TColumn)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.EditMode(TEditMode) Method

Summary

Represents method EditMode(TEditMode).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 procedure EditMode(const AMode:TEditMode); override;

Parameters

AMode
Type: TEditMode

Overrides

TVirtualData.EditMode(TEditMode)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.Empty Method

Summary

Represents method Empty.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 function Empty:Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.Empty
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.FieldOf(TColumn) Method

Summary

Represents method FieldOf(TColumn).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 function FieldOf(const AColumn:TColumn):TField; inline;

Parameters

AColumn
Type: TColumn

Return Value

Type: TField

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.From(TComponent) Method

Summary

Represents method From(TComponent).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 class function From(const ASource:TComponent):TVirtualData; override;

Parameters

ASource
Type: TComponent

Return Value

Type: TVirtualData

Overrides

TVirtualData.From(TComponent)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.HorizAlignOf(TField) Method

Summary

Represents method HorizAlignOf(TField).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 class function HorizAlignOf(const AField:TField):THorizontalAlign; static;

Parameters

AField
Type: TField

Return Value

Type: THorizontalAlign

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.InternalRefresh Method

Summary

Represents method InternalRefresh.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 Procedure InternalRefresh; Override;

Overrides

TVirtualData.InternalRefresh
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.KnownCount Method

Summary

Represents method KnownCount.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 function KnownCount: Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.KnownCount
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.LinkTo(TColumn,TField) Method

Summary

Represents method LinkTo(TColumn,TField).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 class procedure LinkTo(const AColumn:TColumn; const AField:TField); static;

Parameters

AColumn
Type: TColumn

AField
Type: TField

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.Load(TColumns) Method

Summary

Represents method Load(TColumns).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 procedure Load(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.Load(TColumns)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.PastEnd(Integer) Method

Summary

Represents method PastEnd(Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 function PastEnd(const ARow:Integer):Boolean; override;

Parameters

ARow
Type: Integer

Return Value

Type: Boolean

Overrides

TVirtualData.PastEnd(Integer)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.ReadOnly(TColumn) Method

Summary

Represents method ReadOnly(TColumn).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 function ReadOnly(const AColumn:TColumn):Boolean; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: Boolean

Overrides

TVirtualData.ReadOnly(TColumn)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.RowChanged(Integer) Method

Summary

Represents method RowChanged(Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure RowChanged(const ARow:Integer); override;

Parameters

ARow
Type: Integer

Overrides

TVirtualData.RowChanged(Integer)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.SetField(TColumn,TObject) Method

Summary

Represents method SetField(TColumn,TObject).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure SetField(const AColumn:TColumn; const ASource:TObject); override;

Parameters

AColumn
Type: TColumn

ASource
Type: TObject

Overrides

TVirtualData.SetField(TColumn,TObject)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.SetFirstRow(Integer) Method

Summary

Represents method SetFirstRow(Integer).

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 procedure SetFirstRow(const ARow:Integer); override;

Parameters

ARow
Type: Integer

Overrides

TVirtualData.SetFirstRow(Integer)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.SetValue(TColumn,Integer,String) Method

Summary

Represents method SetValue(TColumn,Integer,String).

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 procedure SetValue(const AColumn:TColumn; const ARow:Integer; const AText:String); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AText
Type: String

Overrides

TVirtualData.SetValue(TColumn,Integer,String)
See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData Fields

Fields
Name | Description
IDataSet | Represents field IDataSet.
IDataSource | Represents field IDataSource.
ILink | Represents field ILink.
OwnsData | Represents field OwnsData.
OwnsDataSource | Represents field OwnsDataSource.
Top


TVirtualDBData.IDataSet Field

Summary

Represents field IDataSet.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 IDataSet : TDataSet;

Field Value

Type: TDataSet

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.IDataSource Field

Summary

Represents field IDataSource.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 IDataSource : TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.ILink Field

Summary

Represents field ILink.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 ILink : TVirtualDataLink;

Field Value

Type: TVirtualDataLink

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.OwnsData Field

Summary

Represents field OwnsData.

Namespace: Tee.GridData.DB
Syntax
Delphi
public
 OwnsData : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


TVirtualDBData.OwnsDataSource Field

Summary

Represents field OwnsDataSource.

Namespace: Tee.GridData.DB
Syntax
Delphi
protected
 OwnsDataSource : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TVirtualDBData
  • Tee.GridData.DB


Tee.GridData.DB Enumerations

Enumerations
Name | Description
TVirtualFetchMode | Represents type TVirtualFetchMode.
Top


TVirtualFetchMode Enumeration

Summary

Represents type TVirtualFetchMode.

Namespace: Tee.GridData.DB
Syntax
Delphi
type
 TVirtualFetchMode=(Automatic,All,Partial);

The TVirtualFetchMode type exposes the following members.

Members
Show:
Name | Description
All | Represents constant All.
Automatic | Represents constant Automatic.
Partial | Represents constant Partial.
Top
See Also

Reference

  • Tee.GridData.DB


Tee.GridData.DB Types

Types
Name | Description
TDataSetRecNo | Represents an alias of the Integer type.
Top


TDataSetRecNo Type

Summary

Represents an alias of the Integer type.

Namespace: Tee.GridData.DB
Syntax
Delphi
type
 TDataSetRecNo=Integer;
See Also

Reference

  • Tee.GridData.DB


Tee.GridData.DB Routines

Routines
Name | Description
IsPictureField(TField) | Represents method IsPictureField(TField).
Top


IsPictureField(TField) Method

Summary

Represents method IsPictureField(TField).

Namespace: Tee.GridData.DB
Syntax
Delphi
function IsPictureField(const AField:TField):Boolean;

Parameters

AField
Type: TField

Return Value

Type: Boolean

See Also

Reference

  • Tee.GridData.DB


Tee.GridData.Rtti Namespace

Summary

Represents namespace Tee.GridData.Rtti.

Classes
Name | Description
TBaseVirtualData | Represents type TBaseVirtualData.
TVirtualData<T> | Represents type TVirtualData<T>.
TVirtualDataRtti | Represents type TVirtualDataRtti.
Top
Enumerations
Name | Description
TRttiMembers | Represents type TRttiMembers.
Top
Types
Name | Description
TVisibility | Represents type TVisibility.
Top


Tee.GridData.Rtti Classes

Classes
Name | Description
TBaseVirtualData | Represents type TBaseVirtualData.
TVirtualData<T> | Represents type TVirtualData<T>.
TVirtualDataRtti | Represents type TVirtualDataRtti.
Top


TBaseVirtualData Class

Summary

Represents type TBaseVirtualData.

Namespace: Tee.GridData.Rtti
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.GridData.Rtti.TVirtualDataRtti
Tee.GridData.Rtti.TBaseVirtualData
Syntax
Delphi
type
 TBaseVirtualData=class(TVirtualDataRtti)
 end;

The TBaseVirtualData type exposes the following members.

Constructors
Show:
Name | Description
Create(TObject,String,Integer,TVisibility,TRttiMembers,Boolean) | Overloaded. Initializes a new instance of the TBaseVirtualData class.
Top
Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Overrides TVirtualData.AsFloat(TColumn,Integer).)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Overrides TVirtualData.Count.)
DataType(TColumn) | Represents method DataType(TColumn). (Overrides TVirtualData.DataType(TColumn).)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
DoSetArrayValue(TColumn,Integer,TValue) | Represents method DoSetArrayValue(TColumn,Integer,TValue).
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
GetPointerOf(TColumn,Integer) | Represents method GetPointerOf(TColumn,Integer).
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
RowValue(Integer) | Represents method RowValue(Integer).
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Overrides TVirtualData.SetField(TColumn,TObject).)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.GridData.Rtti


TBaseVirtualData Constructors

Constructors
Name | Description
Create(TObject,String,Integer,TVisibility,TRttiMembers,Boolean) | Overloaded. Initializes a new instance of the TBaseVirtualData class.
Top


TBaseVirtualData.Create(TObject,String,Integer,TVisibility,TRttiMembers,Boolean) Constructor

Summary

Initializes a new instance of the TBaseVirtualData class.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 Constructor Create(const AObject:TObject;
 const AProperty:String;
 const ACount:Integer;
 const AVisibility:TVisibility=[mvPublic,mvPublished];
 const AMembers:TRttiMembers=TRttiMembers.Both;
 const AAncestor:Boolean=False); overload;

Parameters

AObject
Type: TObject

AProperty
Type: String

ACount
Type: Integer

AVisibility
Type: TVisibility

AMembers
Type: TRttiMembers

AAncestor
Type: Boolean

See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData Methods

Methods
Name | Description
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Overrides TVirtualData.AsFloat(TColumn,Integer).)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Count | Represents method Count. (Overrides TVirtualData.Count.)
DoSetArrayValue(TColumn,Integer,TValue) | Represents method DoSetArrayValue(TColumn,Integer,TValue).
GetPointerOf(TColumn,Integer) | Represents method GetPointerOf(TColumn,Integer).
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
RowValue(Integer) | Represents method RowValue(Integer).
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Overrides TVirtualData.SetField(TColumn,TObject).)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
Top


TBaseVirtualData.AddColumns(TColumns) Method

Summary

Represents method AddColumns(TColumns).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 procedure AddColumns(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.AddColumns(TColumns)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.AsFloat(TColumn,Integer) Method

Summary

Represents method AsFloat(TColumn,Integer).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 function AsFloat(const AColumn: TColumn; const ARow: Integer): TFloat; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: TFloat

Overrides

TVirtualData.AsFloat(TColumn,Integer)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.AsString(TColumn,Integer) Method

Summary

Represents method AsString(TColumn,Integer).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 function AsString(const AColumn:TColumn; const ARow:Integer):String; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: String

Overrides

TVirtualData.AsString(TColumn,Integer)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.AutoWidth(TPainter,TColumn) Method

Summary

Represents method AutoWidth(TPainter,TColumn).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 function AutoWidth(const APainter:TPainter; const AColumn:TColumn):Single; override;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

Overrides

TVirtualData.AutoWidth(TPainter,TColumn)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.Count Method

Summary

Represents method Count.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TVirtualData.Count
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.DoSetArrayValue(TColumn,Integer,TValue) Method

Summary

Represents method DoSetArrayValue(TColumn,Integer,TValue).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 procedure DoSetArrayValue(const AColumn:TColumn; const ARow:Integer; const Value:TValue); virtual;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Value
Type: TValue

See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.GetPointerOf(TColumn,Integer) Method

Summary

Represents method GetPointerOf(TColumn,Integer).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 function GetPointerOf(const AColumn:TColumn; const ARow:Integer):Pointer; virtual;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.Load(TColumns) Method

Summary

Represents method Load(TColumns).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 procedure Load(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.Load(TColumns)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.RowValue(Integer) Method

Summary

Represents method RowValue(Integer).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 function RowValue(const ARow:Integer):TValue; virtual;

Parameters

ARow
Type: Integer

Return Value

Type: TValue

See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.SetField(TColumn,TObject) Method

Summary

Represents method SetField(TColumn,TObject).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 procedure SetField(const AColumn:TColumn; const ASource:TObject); override;

Parameters

AColumn
Type: TColumn

ASource
Type: TObject

Overrides

TVirtualData.SetField(TColumn,TObject)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TBaseVirtualData.SetValue(TColumn,Integer,String) Method

Summary

Represents method SetValue(TColumn,Integer,String).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 procedure SetValue(const AColumn:TColumn; const ARow:Integer; const AText:String); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AText
Type: String

Overrides

TVirtualData.SetValue(TColumn,Integer,String)
See Also

Reference

  • TBaseVirtualData
  • Tee.GridData.Rtti


TVirtualData<T> Class

Summary

Represents type TVirtualData<T>.

Namespace: Tee.GridData.Rtti
Inheritance Hierarchy
TObject
Tee.GridData.Rtti.TVirtualData<T>
Syntax
Delphi
type
 TVirtualData<T

Type Parameters

T
See Also

Reference

  • Tee.GridData.Rtti


TVirtualDataRtti Class

Summary

Represents type TVirtualDataRtti.

Namespace: Tee.GridData.Rtti
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.GridData.Rtti.TVirtualDataRtti
Tee.GridData.Rtti.TBaseVirtualData
Syntax
Delphi
type
 TVirtualDataRtti=class(TVirtualData)
 end;

The TVirtualDataRtti type exposes the following members.

Properties
Show:
Name | Description
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Inherited from TVirtualData.)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Inherited from TVirtualData.)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Inherited from TVirtualData.)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Inherited from TVirtualData.)
DataType(TColumn) | Represents method DataType(TColumn). (Overrides TVirtualData.DataType(TColumn).)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Load(TColumns) | Represents method Load(TColumns). (Inherited from TVirtualData.)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Inherited from TVirtualData.)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.GridData.Rtti


TVirtualDataRtti Methods

Methods
Name | Description
DataType(TColumn) | Represents method DataType(TColumn). (Overrides TVirtualData.DataType(TColumn).)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Top


TVirtualDataRtti.DataType(TColumn) Method

Summary

Represents method DataType(TColumn).

Namespace: Tee.GridData.Rtti
Syntax
Delphi
public
 function DataType(const AColumn:TColumn):PTypeInfo; override;

Parameters

AColumn
Type: TColumn

Return Value

Type: PTypeInfo

Overrides

TVirtualData.DataType(TColumn)
See Also

Reference

  • TVirtualDataRtti
  • Tee.GridData.Rtti


TVirtualDataRtti.Empty Method

Summary

Represents method Empty.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 function Empty:Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.Empty
See Also

Reference

  • TVirtualDataRtti
  • Tee.GridData.Rtti


TVirtualDataRtti.KnownCount Method

Summary

Represents method KnownCount.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
protected
 function KnownCount: Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.KnownCount
See Also

Reference

  • TVirtualDataRtti
  • Tee.GridData.Rtti


Tee.GridData.Rtti Enumerations

Enumerations
Name | Description
TRttiMembers | Represents type TRttiMembers.
Top


TRttiMembers Enumeration

Summary

Represents type TRttiMembers.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
type
 TRttiMembers=(Both, Fields, Properties);

The TRttiMembers type exposes the following members.

Members
Show:
Name | Description
Both | Represents constant Both.
Fields | Represents constant Fields.
Properties | Represents constant Properties.
Top
See Also

Reference

  • Tee.GridData.Rtti


Tee.GridData.Rtti Types

Types
Name | Description
TVisibility | Represents type TVisibility.
Top


TVisibility Type

Summary

Represents type TVisibility.

Namespace: Tee.GridData.Rtti
Syntax
Delphi
type
 TVisibility=set of TMemberVisibility;
See Also

Reference

  • Tee.GridData.Rtti


Tee.GridData.Strings Namespace

Summary

Represents namespace Tee.GridData.Strings.

Classes
Name | Description
TStringsData | Represents type TStringsData.
TVirtualModeData | Represents type TVirtualModeData.
Top
Delegates
Name | Description
TOnVirtualData | Represents type TOnVirtualData.
Top
Types
Name | Description
TStringArray | Represents an array of the type.
TStringArrays | Represents an array of the TStringArray type.
Top


Tee.GridData.Strings Classes

Classes
Name | Description
TStringsData | Represents type TStringsData.
TVirtualModeData | Represents type TVirtualModeData.
Top


TStringsData Class

Summary

Represents type TStringsData.

Namespace: Tee.GridData.Strings
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.GridData.Strings.TVirtualModeData
Tee.GridData.Strings.TStringsData
Syntax
Delphi
type
 TStringsData=class(TVirtualModeData)
 end;

The TStringsData type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Single) | Initializes a new instance of the TVirtualModeData class. (Inherited from TVirtualModeData.)
Top
Properties
Show:
Name | Description
Cells[Integer,Integer] | Represents property Cells[Integer,Integer].
ColumnList | Represents property ColumnList. (Inherited from TVirtualModeData.)
Columns | Represents property Columns. (Inherited from TVirtualModeData.)
Headers[Integer] | Represents property Headers[Integer]. (Inherited from TVirtualModeData.)
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Rows | Represents property Rows. (Inherited from TVirtualModeData.)
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualModeData.AsString(TColumn,Integer).)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Overrides TVirtualData.Count.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetCell(Integer,Integer) | Represents method GetCell(Integer,Integer).
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
IndexOf(TColumn) | Represents method IndexOf(TColumn). (Inherited from TVirtualModeData.)
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
InternalResize | Represents method InternalResize. (Overrides TVirtualModeData.InternalResize.)
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
Resize(Integer,Integer) | Represents method Resize(Integer,Integer). (Inherited from TVirtualModeData.)
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetCell(Integer,Integer,String) | Represents method SetCell(Integer,Integer,String).
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualModeData.SetValue(TColumn,Integer,String).)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Events
Show:
Name | Description
OnGetValue | Represents property OnGetValue. (Inherited from TVirtualModeData.)
OnSetValue | Represents property OnSetValue. (Inherited from TVirtualModeData.)
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
IData | Represents field IData. (Inherited from TVirtualModeData.)
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.GridData.Strings


TStringsData Properties

Properties
Name | Description
Cells[Integer,Integer] | Represents property Cells[Integer,Integer].
Top


TStringsData.Cells[Integer,Integer] Property

Summary

Represents property Cells[Integer,Integer].

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property Cells[const Column,Row:Integer]:String read GetCell write SetCell; default;

Parameters

Column
Type: Integer

Row
Type: Integer

Property Value

Type: String

See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TStringsData Methods

Methods
Name | Description
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualModeData.AsString(TColumn,Integer).)
GetCell(Integer,Integer) | Represents method GetCell(Integer,Integer).
InternalResize | Represents method InternalResize. (Overrides TVirtualModeData.InternalResize.)
SetCell(Integer,Integer,String) | Represents method SetCell(Integer,Integer,String).
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualModeData.SetValue(TColumn,Integer,String).)
Top


TStringsData.AsString(TColumn,Integer) Method

Summary

Represents method AsString(TColumn,Integer).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 function AsString(const AColumn:TColumn; const ARow:Integer):String; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: String

Overrides

TVirtualModeData.AsString(TColumn,Integer)
See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TStringsData.GetCell(Integer,Integer) Method

Summary

Represents method GetCell(Integer,Integer).

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 function GetCell(const AColumn,ARow: Integer): String; virtual;

Parameters

AColumn
Type: Integer

ARow
Type: Integer

Return Value

Type: String

See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TStringsData.InternalResize Method

Summary

Represents method InternalResize.

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 procedure InternalResize; override;

Overrides

TVirtualModeData.InternalResize
See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TStringsData.SetCell(Integer,Integer,String) Method

Summary

Represents method SetCell(Integer,Integer,String).

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 procedure SetCell(const AColumn,ARow: Integer; const Value: String); virtual;

Parameters

AColumn
Type: Integer

ARow
Type: Integer

Value
Type: String

See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TStringsData.SetValue(TColumn,Integer,String) Method

Summary

Represents method SetValue(TColumn,Integer,String).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 procedure SetValue(const AColumn:TColumn; const ARow:Integer; const AText:String); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AText
Type: String

Overrides

TVirtualModeData.SetValue(TColumn,Integer,String)
See Also

Reference

  • TStringsData
  • Tee.GridData.Strings


TVirtualModeData Class

Summary

Represents type TVirtualModeData.

Namespace: Tee.GridData.Strings
Inheritance Hierarchy
TObject
Tee.GridData.TVirtualData
Tee.GridData.Strings.TVirtualModeData
Tee.GridData.Strings.TStringsData
Syntax
Delphi
type
 TVirtualModeData=class(TVirtualData)
 end;

The TVirtualModeData type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Single) | Initializes a new instance of the TVirtualModeData class.
Top
Properties
Show:
Name | Description
ColumnList | Represents property ColumnList.
Columns | Represents property Columns.
Headers[Integer] | Represents property Headers[Integer].
Refreshing | Represents property Refreshing. (Inherited from TVirtualData.)
Rows | Represents property Rows.
Top
Methods
Show:
Name | Description
Add(TColumns,String,TObject) | Overloaded. Represents method Add(TColumns,String,TObject). (Inherited from TVirtualData.)
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsFloat(TColumn,Integer) | Represents method AsFloat(TColumn,Integer). (Inherited from TVirtualData.)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoHeight(TPainter,TColumn,Integer,Single) | Represents method AutoHeight(TPainter,TColumn,Integer,Single). (Inherited from TVirtualData.)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Calculate(TColumn,TColumnCalculation) | Represents method Calculate(TColumn,TColumnCalculation). (Inherited from TVirtualData.)
CanExpand(TRender,Integer) | Represents method CanExpand(TRender,Integer). (Inherited from TVirtualData.)
CanSortBy(TColumn) | Represents method CanSortBy(TColumn). (Inherited from TVirtualData.)
ChangeSelectedRow(Integer) | Represents method ChangeSelectedRow(Integer). (Inherited from TVirtualData.)
Count | Represents method Count. (Overrides TVirtualData.Count.)
DataType(TColumn) | Represents method DataType(TColumn). (Inherited from TVirtualData.)
DoError(String) | Represents method DoError(String). (Inherited from TVirtualData.)
EditingChanged(Boolean) | Represents method EditingChanged(Boolean). (Inherited from TVirtualData.)
EditMode(TEditMode) | Represents method EditMode(TEditMode). (Inherited from TVirtualData.)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
From(TComponent) | Overloaded. Represents method From(TComponent). (Inherited from TVirtualData.)
GetDetail(Integer,TColumns,TColumn) | Represents method GetDetail(Integer,TColumns,TColumn). (Inherited from TVirtualData.)
HasDetail(Integer) | Represents method HasDetail(Integer). (Inherited from TVirtualData.)
IndexOf(TColumn) | Represents method IndexOf(TColumn).
InternalRefresh | Represents method InternalRefresh. (Inherited from TVirtualData.)
InternalResize | Represents method InternalResize.
IsNumeric(TColumn) | Overloaded. Represents method IsNumeric(TColumn). (Inherited from TVirtualData.)
IsSorted(TColumn,Boolean) | Represents method IsSorted(TColumn,Boolean). (Inherited from TVirtualData.)
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
LongestString(TPainter,TColumn) | Represents method LongestString(TPainter,TColumn). (Inherited from TVirtualData.)
PastEnd(Integer) | Represents method PastEnd(Integer). (Inherited from TVirtualData.)
ReadOnly(TColumn) | Represents method ReadOnly(TColumn). (Inherited from TVirtualData.)
Refresh | Represents method Refresh. (Inherited from TVirtualData.)
Repaint | Represents method Repaint. (Inherited from TVirtualData.)
Resize(Integer,Integer) | Represents method Resize(Integer,Integer).
RowChanged(Integer) | Represents method RowChanged(Integer). (Inherited from TVirtualData.)
SampleDate(TColumn) | Represents method SampleDate(TColumn). (Inherited from TVirtualData.)
SampleDateTime(TColumn) | Represents method SampleDateTime(TColumn). (Inherited from TVirtualData.)
SampleTime(TColumn) | Represents method SampleTime(TColumn). (Inherited from TVirtualData.)
SetField(TColumn,TObject) | Represents method SetField(TColumn,TObject). (Inherited from TVirtualData.)
SetFirstRow(Integer) | Represents method SetFirstRow(Integer). (Inherited from TVirtualData.)
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
SortBy(TColumn) | Represents method SortBy(TColumn). (Inherited from TVirtualData.)
ToggleBoolean(TColumn,Integer) | Represents method ToggleBoolean(TColumn,Integer). (Inherited from TVirtualData.)
Top
Events
Show:
Name | Description
OnGetValue | Represents property OnGetValue.
OnSetValue | Represents property OnSetValue.
Top
Fields
Show:
Name | Description
FOnChangeRow | Represents field FOnChangeRow. (Inherited from TVirtualData.)
FOnEditing | Represents field FOnEditing. (Inherited from TVirtualData.)
FOnRefresh | Represents field FOnRefresh. (Inherited from TVirtualData.)
FOnRepaint | Represents field FOnRepaint. (Inherited from TVirtualData.)
FRefreshing | Represents field FRefreshing. (Inherited from TVirtualData.)
IData | Represents field IData.
PictureClass | Represents field PictureClass. (Inherited from TVirtualData.)
Top
See Also

Reference

  • Tee.GridData.Strings


TVirtualModeData Constructors

Constructors
Name | Description
Create(Integer,Integer,Single) | Initializes a new instance of the TVirtualModeData class.
Top


TVirtualModeData.Create(Integer,Integer,Single) Constructor

Summary

Initializes a new instance of the TVirtualModeData class.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 Constructor Create(const AColumns:Integer=0; const ARows:Integer=0; const DefaultWidth:Single=0); virtual;

Parameters

AColumns
Type: Integer

ARows
Type: Integer

DefaultWidth
Type: Single

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData Properties

Properties
Name | Description
ColumnList | Represents property ColumnList.
Columns | Represents property Columns.
Headers[Integer] | Represents property Headers[Integer].
Rows | Represents property Rows.
Top


TVirtualModeData.ColumnList Property

Summary

Represents property ColumnList.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property ColumnList:TColumns read IColumns;

Property Value

Type: TColumns

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Columns Property

Summary

Represents property Columns.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property Columns:Integer read FColumns write SetColumns default 0;

Property Value

Type: Integer

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Headers[Integer] Property

Summary

Represents property Headers[Integer].

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property Headers[const Column:Integer]:String read GetHeader write SetHeader;

Parameters

Column
Type: Integer

Property Value

Type: String

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Rows Property

Summary

Represents property Rows.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property Rows:Integer read FRows write SetRows default 0;

Property Value

Type: Integer

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData Methods

Methods
Name | Description
AddColumns(TColumns) | Represents method AddColumns(TColumns). (Overrides TVirtualData.AddColumns(TColumns).)
AsString(TColumn,Integer) | Represents method AsString(TColumn,Integer). (Overrides TVirtualData.AsString(TColumn,Integer).)
AutoWidth(TPainter,TColumn) | Represents method AutoWidth(TPainter,TColumn). (Overrides TVirtualData.AutoWidth(TPainter,TColumn).)
Count | Represents method Count. (Overrides TVirtualData.Count.)
Empty | Represents method Empty. (Overrides TVirtualData.Empty.)
IndexOf(TColumn) | Represents method IndexOf(TColumn).
InternalResize | Represents method InternalResize.
KnownCount | Represents method KnownCount. (Overrides TVirtualData.KnownCount.)
Load(TColumns) | Represents method Load(TColumns). (Overrides TVirtualData.Load(TColumns).)
Resize(Integer,Integer) | Represents method Resize(Integer,Integer).
SetValue(TColumn,Integer,String) | Represents method SetValue(TColumn,Integer,String). (Overrides TVirtualData.SetValue(TColumn,Integer,String).)
Top


TVirtualModeData.AddColumns(TColumns) Method

Summary

Represents method AddColumns(TColumns).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 procedure AddColumns(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.AddColumns(TColumns)
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.AsString(TColumn,Integer) Method

Summary

Represents method AsString(TColumn,Integer).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 function AsString(const AColumn:TColumn; const ARow:Integer):String; override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

Return Value

Type: String

Overrides

TVirtualData.AsString(TColumn,Integer)
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.AutoWidth(TPainter,TColumn) Method

Summary

Represents method AutoWidth(TPainter,TColumn).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 function AutoWidth(const APainter:TPainter; const AColumn:TColumn):Single; override;

Parameters

APainter
Type: TPainter

AColumn
Type: TColumn

Return Value

Type: Single

Overrides

TVirtualData.AutoWidth(TPainter,TColumn)
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Count Method

Summary

Represents method Count.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TVirtualData.Count
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Empty Method

Summary

Represents method Empty.

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 function Empty:Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.Empty
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.IndexOf(TColumn) Method

Summary

Represents method IndexOf(TColumn).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 function IndexOf(const AColumn: TColumn):Integer; inline;

Parameters

AColumn
Type: TColumn

Return Value

Type: Integer

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.InternalResize Method

Summary

Represents method InternalResize.

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 procedure InternalResize; virtual;
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.KnownCount Method

Summary

Represents method KnownCount.

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 function KnownCount: Boolean; override;

Return Value

Type: Boolean

Overrides

TVirtualData.KnownCount
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Load(TColumns) Method

Summary

Represents method Load(TColumns).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 procedure Load(const AColumns:TColumns); override;

Parameters

AColumns
Type: TColumns

Overrides

TVirtualData.Load(TColumns)
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.Resize(Integer,Integer) Method

Summary

Represents method Resize(Integer,Integer).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 procedure Resize(const AColumns,ARows:Integer);

Parameters

AColumns
Type: Integer

ARows
Type: Integer

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.SetValue(TColumn,Integer,String) Method

Summary

Represents method SetValue(TColumn,Integer,String).

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 procedure SetValue(const AColumn:TColumn; const ARow:Integer; const AText:String); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AText
Type: String

Overrides

TVirtualData.SetValue(TColumn,Integer,String)
See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData Events

Events
Name | Description
OnGetValue | Represents property OnGetValue.
OnSetValue | Represents property OnSetValue.
Top


TVirtualModeData.OnGetValue Event

Summary

Represents property OnGetValue.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property OnGetValue:TOnVirtualData read FOnGetValue write FOnGetValue;

Value

Type: TOnVirtualData

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData.OnSetValue Event

Summary

Represents property OnSetValue.

Namespace: Tee.GridData.Strings
Syntax
Delphi
public
 property OnSetValue:TOnVirtualData read FOnSetValue write FOnSetValue;

Value

Type: TOnVirtualData

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


TVirtualModeData Fields

Fields
Name | Description
IData | Represents field IData.
Top


TVirtualModeData.IData Field

Summary

Represents field IData.

Namespace: Tee.GridData.Strings
Syntax
Delphi
protected
 IData : TStringArrays;

Field Value

Type: TStringArrays

See Also

Reference

  • TVirtualModeData
  • Tee.GridData.Strings


Tee.GridData.Strings Delegates

Delegates
Name | Description
TOnVirtualData | Represents type TOnVirtualData.
Top


TOnVirtualData Delegate

Summary

Represents type TOnVirtualData.

Namespace: Tee.GridData.Strings
Syntax
Delphi
type
 TOnVirtualData=procedure(Sender:TObject;
 const AColumn:TColumn;
 const ARow:Integer;
 var AValue:String ) of object;
See Also

Reference

  • Tee.GridData.Strings


Tee.GridData.Strings Types

Types
Name | Description
TStringArray | Represents an array of the type.
TStringArrays | Represents an array of the TStringArray type.
Top


TStringArray Type

Summary

Represents an array of the type.

Namespace: Tee.GridData.Strings
Syntax
Delphi
type
 TStringArray=Array of String;
See Also

Reference

  • Tee.GridData.Strings


TStringArrays Type

Summary

Represents an array of the TStringArray type.

Namespace: Tee.GridData.Strings
Syntax
Delphi
type
 TStringArrays=Array of TStringArray;
See Also

Reference

  • Tee.GridData.Strings


Tee.Painter Namespace

Summary

Represents namespace Tee.Painter.

Classes
Name | Description
TPainter | Represents type TPainter.
Top
Enumerations
Name | Description
THorizontalAlign | Represents type THorizontalAlign.
TTrimmingMode | Represents type TTrimmingMode.
TVerticalAlign | Represents type TVerticalAlign.
Top
Types
Name | Description
TPointsF | Represents an array of the TPointF type.
Top


Tee.Painter Classes

Classes
Name | Description
TPainter | Represents type TPainter.
Top


TPainter Class

Summary

Represents type TPainter.

Namespace: Tee.Painter
Inheritance Hierarchy
TObject
Tee.Painter.TPainter
Syntax
Delphi
type
 TPainter=class
 end;

The TPainter type exposes the following members.

Methods
Show:
Name | Description
CalcTextLines(String) | Represents method CalcTextLines(String).
Clip(TRectF) | Overloaded. Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Overloaded. Represents method Draw(TPointsF).
Draw(TRectF) | Overloaded. Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Overloaded. Represents method Fill(TPointsF).
Fill(TRectF) | Overloaded. Represents method Fill(TRectF).
Fill(TRectF,TColor) | Overloaded. Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Overloaded. Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Overloaded. Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Overloaded. Represents method TextHeight(String).
TextHeight(TFont) | Overloaded. Represents method TextHeight(TFont).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
TryClip(String,Single,Single,Single,Single,Single) | Overloaded. Represents method TryClip(String,Single,Single,Single,Single,Single).
TryClip(String,TRectF,Single) | Overloaded. Represents method TryClip(String,TRectF,Single).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top
See Also

Reference

  • Tee.Painter


TPainter Methods

Methods
Name | Description
CalcTextLines(String) | Represents method CalcTextLines(String).
Clip(TRectF) | Overloaded. Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Overloaded. Represents method Draw(TPointsF).
Draw(TRectF) | Overloaded. Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Overloaded. Represents method Fill(TPointsF).
Fill(TRectF) | Overloaded. Represents method Fill(TRectF).
Fill(TRectF,TColor) | Overloaded. Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Overloaded. Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Overloaded. Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Overloaded. Represents method TextHeight(String).
TextHeight(TFont) | Overloaded. Represents method TextHeight(TFont).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
TryClip(String,Single,Single,Single,Single,Single) | Overloaded. Represents method TryClip(String,Single,Single,Single,Single,Single).
TryClip(String,TRectF,Single) | Overloaded. Represents method TryClip(String,TRectF,Single).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top


TPainter.CalcTextLines(String) Method

Summary

Represents method CalcTextLines(String).

Namespace: Tee.Painter
Syntax
Delphi
public
 class function CalcTextLines(const AText:String):Integer; static;

Parameters

AText
Type: String

Return Value

Type: Integer

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Clip(TRectF) Method

Summary

Represents method Clip(TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Clip(const R:TRectF); overload; virtual; abstract;

Parameters

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Draw(TPicture,Single,Single) Method

Summary

Represents method Draw(TPicture,Single,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const X,Y:Single); overload; virtual; abstract;

Parameters

APicture
Type: TPicture

X
Type: Single

Y
Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Draw(TPicture,TRectF) Method

Summary

Represents method Draw(TPicture,TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const R:TRectF); overload; virtual; abstract;

Parameters

APicture
Type: TPicture

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Draw(TPointsF) Method

Summary

Represents method Draw(TPointsF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Draw(const P:TPointsF); overload; virtual; abstract;

Parameters

P
Type: TPointsF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Draw(TRectF) Method

Summary

Represents method Draw(TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Draw(const R:TRectF); overload; virtual; abstract;

Parameters

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.DrawEllipse(TRectF) Method

Summary

Represents method DrawEllipse(TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure DrawEllipse(const R:TRectF); virtual; abstract;

Parameters

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Fill(TPointsF) Method

Summary

Represents method Fill(TPointsF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Fill(const P:TPointsF); overload; virtual; abstract;

Parameters

P
Type: TPointsF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Fill(TRectF) Method

Summary

Represents method Fill(TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Fill(const R:TRectF); overload; virtual; abstract;

Parameters

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Fill(TRectF,TColor) Method

Summary

Represents method Fill(TRectF,TColor).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Fill(const R:TRectF; const AColor:TColor); overload; virtual; abstract;

Parameters

R
Type: TRectF

AColor
Type: System.Void

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.FillEllipse(TRectF) Method

Summary

Represents method FillEllipse(TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure FillEllipse(const R:TRectF); virtual; abstract;

Parameters

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.HideBrush Method

Summary

Represents method HideBrush.

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure HideBrush; virtual; abstract;
See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.HorizontalLine(Single,Single,Single) Method

Summary

Represents method HorizontalLine(Single,Single,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure HorizontalLine(const Y,X0,X1:Single); virtual; abstract;

Parameters

Y
Type: Single

X0
Type: Single

X1
Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Line(Single,Single,Single,Single) Method

Summary

Represents method Line(Single,Single,Single,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Line(const X0,Y0,X1,Y1:Single); virtual; abstract;

Parameters

X0
Type: Single

Y0
Type: Single

X1
Type: Single

Y1
Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Lines(TPointsF) Method

Summary

Represents method Lines(TPointsF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Lines(const P:TPointsF); virtual; abstract;

Parameters

P
Type: TPointsF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Paint(TFormat,TPointsF) Method

Summary

Represents method Paint(TFormat,TPointsF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Paint(const AFormat:TFormat; const P:TPointsF); overload; virtual; abstract;

Parameters

AFormat
Type: TFormat

P
Type: TPointsF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.Paint(TFormat,TRectF) Method

Summary

Represents method Paint(TFormat,TRectF).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure Paint(const AFormat:TFormat; const R:TRectF); overload; virtual; abstract;

Parameters

AFormat
Type: TFormat

R
Type: TRectF

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetBrush(TBrush) Method

Summary

Represents method SetBrush(TBrush).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetBrush(const ABrush:TBrush); virtual; abstract;

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetFont(const AFont:TFont); virtual; abstract;

Parameters

AFont
Type: TFont

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetFontColor(TColor) Method

Summary

Represents method SetFontColor(TColor).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetFontColor(const AColor:TColor); virtual; abstract;

Parameters

AColor
Type: System.Void

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetHorizontalAlign(THorizontalAlign) Method

Summary

Represents method SetHorizontalAlign(THorizontalAlign).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetHorizontalAlign(const Align:THorizontalAlign); virtual; abstract;

Parameters

Align
Type: THorizontalAlign

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetStroke(TStroke) Method

Summary

Represents method SetStroke(TStroke).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetStroke(const AStroke:TStroke); virtual; abstract;

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetTextTrimming(TTrimmingMode,Boolean) Method

Summary

Represents method SetTextTrimming(TTrimmingMode,Boolean).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetTextTrimming(const ATrimming:TTrimmingMode; const Ellipsi:Boolean); virtual; abstract;

Parameters

ATrimming
Type: TTrimmingMode

Ellipsi
Type: Boolean

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.SetVerticalAlign(TVerticalAlign) Method

Summary

Represents method SetVerticalAlign(TVerticalAlign).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure SetVerticalAlign(const Align:TVerticalAlign); virtual; abstract;

Parameters

Align
Type: TVerticalAlign

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TextHeight(String) Method

Summary

Represents method TextHeight(String).

Namespace: Tee.Painter
Syntax
Delphi
public
 function TextHeight(const AText:String):Single; overload; virtual; abstract;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TextHeight(TFont) Method

Summary

Represents method TextHeight(TFont).

Namespace: Tee.Painter
Syntax
Delphi
public
 function TextHeight(const AFont:TFont):Single; overload;

Parameters

AFont
Type: TFont

Return Value

Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TextOut(TRectF,String) Method

Summary

Represents method TextOut(TRectF,String).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure TextOut(const ARect:TRectF; const AText:String); virtual; abstract;

Parameters

ARect
Type: TRectF

AText
Type: String

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TextWidth(String) Method

Summary

Represents method TextWidth(String).

Namespace: Tee.Painter
Syntax
Delphi
public
 function TextWidth(const AText:String):Single; virtual; abstract;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TryClip(String,Single,Single,Single,Single,Single) Method

Summary

Represents method TryClip(String,Single,Single,Single,Single,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 function TryClip(const AText:String;
 const X,Y,AWidth,AHeight,AMinX:Single):Boolean; overload;

Parameters

AText
Type: String

X
Type: Single

Y
Type: Single

AWidth
Type: Single

AHeight
Type: Single

AMinX
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.TryClip(String,TRectF,Single) Method

Summary

Represents method TryClip(String,TRectF,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 function TryClip(const AText:String;
 const ARect:TRectF;
 const AMinX:Single):Boolean; overload;

Parameters

AText
Type: String

ARect
Type: TRectF

AMinX
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.UnClip Method

Summary

Represents method UnClip.

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure UnClip; virtual; abstract;
See Also

Reference

  • TPainter
  • Tee.Painter


TPainter.VerticalLine(Single,Single,Single) Method

Summary

Represents method VerticalLine(Single,Single,Single).

Namespace: Tee.Painter
Syntax
Delphi
public
 procedure VerticalLine(const X,Y0,Y1:Single); virtual; abstract;

Parameters

X
Type: Single

Y0
Type: Single

Y1
Type: Single

See Also

Reference

  • TPainter
  • Tee.Painter


Tee.Painter Enumerations

Enumerations
Name | Description
THorizontalAlign | Represents type THorizontalAlign.
TTrimmingMode | Represents type TTrimmingMode.
TVerticalAlign | Represents type TVerticalAlign.
Top


THorizontalAlign Enumeration

Summary

Represents type THorizontalAlign.

Namespace: Tee.Painter
Syntax
Delphi
type
 THorizontalAlign=(Left,Center,Right);

The THorizontalAlign type exposes the following members.

Members
Show:
Name | Description
Center | Represents constant Center.
Left | Represents constant Left.
Right | Represents constant Right.
Top
See Also

Reference

  • Tee.Painter


TTrimmingMode Enumeration

Summary

Represents type TTrimmingMode.

Namespace: Tee.Painter
Syntax
Delphi
type
 TTrimmingMode=(None,Character,Word);

The TTrimmingMode type exposes the following members.

Members
Show:
Name | Description
Character | Represents constant Character.
None | Represents constant None.
Word | Represents constant Word.
Top
See Also

Reference

  • Tee.Painter


TVerticalAlign Enumeration

Summary

Represents type TVerticalAlign.

Namespace: Tee.Painter
Syntax
Delphi
type
 TVerticalAlign=(Top,Center,Bottom);

The TVerticalAlign type exposes the following members.

Members
Show:
Name | Description
Bottom | Represents constant Bottom.
Center | Represents constant Center.
Top | Represents constant Top.
Top
See Also

Reference

  • Tee.Painter


Tee.Painter Types

Types
Name | Description
TPointsF | Represents an array of the TPointF type.
Top


TPointsF Type

Summary

Represents an array of the TPointF type.

Namespace: Tee.Painter
Syntax
Delphi
type
 TPointsF=Array of TPointF;
See Also

Reference

  • Tee.Painter


Tee.Renders Namespace

Summary

Represents namespace Tee.Renders.

Classes
Name | Description
TAlignments | Represents type TAlignments.
TBooleanRender | Represents type TBooleanRender.
TBorder | Represents type TBorder.
TBorders | Represents type TBorders.
TBox | Represents type TBox.
TBoxRender | Represents type TBoxRender.
TCellRender | Represents type TCellRender.
TEdges | Represents type TEdges.
TExpanderRender | Represents type TExpanderRender.
TFormatRender | Represents type TFormatRender.
THover | Represents type THover.
TMargins | Represents type TMargins.
TPasswordRender | Represents type TPasswordRender.
TProgressRender | Represents type TProgressRender.
TRender | Represents type TRender.
TTextAlign | Represents type TTextAlign.
TTextRender | Represents type TTextRender.
TTextTrimming | Represents type TTextTrimming.
TVisibleRenderItem | Represents type TVisibleRenderItem.
TVisibleTextRender | Represents type TVisibleTextRender.
Top
Records
Name | Description
TRenderData | Represents type TRenderData.
TShapePainter | Represents type TShapePainter.
TShapePainter.TArrow | Represents type TArrow.
TShapePainter.TTriangle | Represents type TTriangle.
Top
Enumerations
Name | Description
TBooleanRenderStyle | Represents type TBooleanRenderStyle.
TExpanderStyle | Represents type TExpanderStyle.
TOrientation | Represents type TOrientation.
Top
Delegates
Name | Description
TExpanderEvent | Represents type TExpanderEvent.
TExpanderGetDataEvent | Represents type TExpanderGetDataEvent.
Top
Types
Name | Description
TRenderClass | Represents type TRenderClass.
Top


Tee.Renders Classes

Classes
Name | Description
TAlignments | Represents type TAlignments.
TBooleanRender | Represents type TBooleanRender.
TBorder | Represents type TBorder.
TBorders | Represents type TBorders.
TBox | Represents type TBox.
TBoxRender | Represents type TBoxRender.
TCellRender | Represents type TCellRender.
TEdges | Represents type TEdges.
TExpanderRender | Represents type TExpanderRender.
TFormatRender | Represents type TFormatRender.
THover | Represents type THover.
TMargins | Represents type TMargins.
TPasswordRender | Represents type TPasswordRender.
TProgressRender | Represents type TProgressRender.
TRender | Represents type TRender.
TTextAlign | Represents type TTextAlign.
TTextRender | Represents type TTextRender.
TTextTrimming | Represents type TTextTrimming.
TVisibleRenderItem | Represents type TVisibleRenderItem.
TVisibleTextRender | Represents type TVisibleTextRender.
Top


TAlignments Class

Summary

Represents type TAlignments.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TAlignments
Tee.Renders.TTextAlign
Syntax
Delphi
type
 TAlignments=class(TPersistentChange)
 end;

The TAlignments type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class. (Inherited from TPersistentChange.)
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Vertical | Represents property Vertical.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitHorizontal(THorizontalAlign) | Represents method InitHorizontal(THorizontalAlign).
InitVertical(TVerticalAlign) | Represents method InitVertical(TVerticalAlign).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TAlignments Properties

Properties
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Top


TAlignments.Horizontal Property

Summary

Represents property Horizontal.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Horizontal:THorizontalAlign read FHorizontal write SetHorizontal stored IsHorizontalStored;

Property Value

Type: THorizontalAlign

See Also

Reference

  • TAlignments
  • Tee.Renders


TAlignments.Vertical Property

Summary

Represents property Vertical.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Vertical:TVerticalAlign read FVertical write SetVertical stored IsVerticalStored;

Property Value

Type: TVerticalAlign

See Also

Reference

  • TAlignments
  • Tee.Renders


TAlignments Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
InitHorizontal(THorizontalAlign) | Represents method InitHorizontal(THorizontalAlign).
InitVertical(TVerticalAlign) | Represents method InitVertical(TVerticalAlign).
Top


TAlignments.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TAlignments
  • Tee.Renders


TAlignments.InitHorizontal(THorizontalAlign) Method

Summary

Represents method InitHorizontal(THorizontalAlign).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure InitHorizontal(const Value:THorizontalAlign);

Parameters

Value
Type: THorizontalAlign

See Also

Reference

  • TAlignments
  • Tee.Renders


TAlignments.InitVertical(TVerticalAlign) Method

Summary

Represents method InitVertical(TVerticalAlign).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure InitVertical(const Value:TVerticalAlign);

Parameters

Value
Type: TVerticalAlign

See Also

Reference

  • TAlignments
  • Tee.Renders


TBooleanRender Class

Summary

Represents type TBooleanRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TBoxRender
Tee.Renders.TBooleanRender
Syntax
Delphi
type
 TBooleanRender=class(TBoxRender)
 end;

The TBooleanRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBooleanRender class. (Overrides TBoxRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBooleanRender class. (Overrides TBoxRender.Destroy.)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Box | Represents property Box. (Inherited from TBoxRender.)
CheckFormat | Represents property CheckFormat.
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Style | Represents property Style.
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TBoxRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Calculate(TRectF) | Represents method Calculate(TRectF). (Inherited from TBoxRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TBoxRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
AlwaysDraw | Represents field AlwaysDraw. (Inherited from TBoxRender.)
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TBooleanRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBooleanRender class. (Overrides TBoxRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBooleanRender class. (Overrides TBoxRender.Destroy.)
Top


TBooleanRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TBooleanRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TBoxRender.Create(TNotifyEvent)
See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBooleanRender.Destroy Destructor

Summary

Represents the destructor of the TBooleanRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBoxRender.Destroy
See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBooleanRender Properties

Properties
Name | Description
CheckFormat | Represents property CheckFormat.
Style | Represents property Style.
Top


TBooleanRender.CheckFormat Property

Summary

Represents property CheckFormat.

Namespace: Tee.Renders
Syntax
Delphi
published
 property CheckFormat:TFormat read FCheckFormat write SetCheckFormat;

Property Value

Type: TFormat

See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBooleanRender.Style Property

Summary

Represents property Style.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Style:TBooleanRenderStyle read FStyle write SetStyle default TBooleanRenderStyle.Check;

Property Value

Type: TBooleanRenderStyle

See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBooleanRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TBoxRender.Assign(TPersistent).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TBoxRender.Paint(TRenderData).)
Top


TBooleanRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TBoxRender.Assign(TPersistent)
See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBooleanRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TBoxRender.Paint(TRenderData)
See Also

Reference

  • TBooleanRender
  • Tee.Renders


TBorder Class

Summary

Represents type TBorder.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Format.TVisiblePersistentChange
Tee.Format.TStroke
Tee.Format.THiddenStroke
Tee.Renders.TBorder
Syntax
Delphi
type
 TBorder=class(THiddenStroke);

The TBorder type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the THiddenStroke class. (Overrides TStroke.Create(TNotifyEvent).)
CreateColor(TNotifyEvent,TColor) | Initializes a new instance of the TStroke class. (Inherited from TStroke.)
Top
Properties
Show:
Name | Description
Brush | Represents property Brush. (Inherited from TStroke.)
Color | Represents property Color. (Inherited from TStroke.)
EndStyle | Represents property EndStyle. (Inherited from TStroke.)
JoinStyle | Represents property JoinStyle. (Inherited from TStroke.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Size | Represents property Size. (Inherited from TStroke.)
Style | Represents property Style. (Inherited from TStroke.)
Visible | Represents property Visible. (Inherited from THiddenStroke.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisiblePersistentChange.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hide | Represents method Hide. (Inherited from TVisiblePersistentChange.)
InitStyle(TStrokeStyle) | Represents method InitStyle(TStrokeStyle). (Inherited from TStroke.)
InitVisible(Boolean) | Represents method InitVisible(Boolean). (Inherited from TVisiblePersistentChange.)
Show | Represents method Show. (Inherited from TVisiblePersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TBorders Class

Summary

Represents type TBorders.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TBorders
Syntax
Delphi
type
 TBorders=class(TPersistentChange)
 end;

The TBorders type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBorders class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBorders class.
Top
Properties
Show:
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Right | Represents property Right.
Top | Represents property Top.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Paint(TPainter,TRectF) | Represents method Paint(TPainter,TRectF).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TBorders Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBorders class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBorders class.
Top


TBorders.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TBorders class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TBorders
  • Tee.Renders


TBorders.Destroy Destructor

Summary

Represents the destructor of the TBorders class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBorders
  • Tee.Renders


TBorders Properties

Properties
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
Right | Represents property Right.
Top | Represents property Top.
Top


TBorders.Bottom Property

Summary

Represents property Bottom.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Bottom:TBorder read FBottom write SetBottom;

Property Value

Type: TBorder

See Also

Reference

  • TBorders
  • Tee.Renders


TBorders.Left Property

Summary

Represents property Left.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Left:TBorder read FLeft write SetLeft;

Property Value

Type: TBorder

See Also

Reference

  • TBorders
  • Tee.Renders


TBorders.Right Property

Summary

Represents property Right.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Right:TBorder read FRight write SetRight;

Property Value

Type: TBorder

See Also

Reference

  • TBorders
  • Tee.Renders


TBorders.Top Property

Summary

Represents property Top.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Top:TBorder read FTop write SetTop;

Property Value

Type: TBorder

See Also

Reference

  • TBorders
  • Tee.Renders


TBorders Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Paint(TPainter,TRectF) | Represents method Paint(TPainter,TRectF).
Top


TBorders.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBorders
  • Tee.Renders


TBorders.Paint(TPainter,TRectF) Method

Summary

Represents method Paint(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(const APainter: TPainter; const ARect: TRectF);

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TBorders
  • Tee.Renders


TBox Class

Summary

Represents type TBox.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TBox
Syntax
Delphi
type
 TBox=class(TPersistentChange)
 end;

The TBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBox class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBox class.
Top
Properties
Show:
Name | Description
Format | Represents property Format.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Size | Represents property Size.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Top
Fields
Show:
Name | Description
Draw | Represents field Draw.
DrawBox | Represents field DrawBox.
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TBox Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBox class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBox class.
Top


TBox.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TBox class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged: TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TBox
  • Tee.Renders


TBox.Destroy Destructor

Summary

Represents the destructor of the TBox class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBox
  • Tee.Renders


TBox Properties

Properties
Name | Description
Format | Represents property Format.
Size | Represents property Size.
Top


TBox.Format Property

Summary

Represents property Format.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Format:TFormat read FFormat write SetFormat;

Property Value

Type: TFormat

See Also

Reference

  • TBox
  • Tee.Renders


TBox.Size Property

Summary

Represents property Size.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Size:Single read FSize write SetSize stored IsSizeStored;

Property Value

Type: Single

See Also

Reference

  • TBox
  • Tee.Renders


TBox Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TBox.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBox
  • Tee.Renders


TBox Fields

Fields
Name | Description
Draw | Represents field Draw.
DrawBox | Represents field DrawBox.
Top


TBox.Draw Field

Summary

Represents field Draw.

Namespace: Tee.Renders
Syntax
Delphi
protected
 DrawBox,
 Draw : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBox
  • Tee.Renders


TBox.DrawBox Field

Summary

Represents field DrawBox.

Namespace: Tee.Renders
Syntax
Delphi
protected
 DrawBox,
 Draw : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBox
  • Tee.Renders


TBoxRender Class

Summary

Represents type TBoxRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TBoxRender
Tee.Renders.TBooleanRender
Tee.Renders.TExpanderRender
Syntax
Delphi
type
 TBoxRender=class(TTextRender)
 end;

The TBoxRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBoxRender class. (Overrides TTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBoxRender class. (Overrides TTextRender.Destroy.)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Box | Represents property Box.
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Calculate(TRectF) | Represents method Calculate(TRectF).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
AlwaysDraw | Represents field AlwaysDraw.
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TBoxRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TBoxRender class. (Overrides TTextRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TBoxRender class. (Overrides TTextRender.Destroy.)
Top


TBoxRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TBoxRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TTextRender.Create(TNotifyEvent)
See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender.Destroy Destructor

Summary

Represents the destructor of the TBoxRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TTextRender.Destroy
See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender Properties

Properties
Name | Description
Box | Represents property Box.
Top


TBoxRender.Box Property

Summary

Represents property Box.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Box:TBox read FBox write SetBox;

Property Value

Type: TBox

See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
Calculate(TRectF) | Represents method Calculate(TRectF).
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
Top


TBoxRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TTextRender.Assign(TPersistent)
See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender.Calculate(TRectF) Method

Summary

Represents method Calculate(TRectF).

Namespace: Tee.Renders
Syntax
Delphi
protected
 function Calculate(const R:TRectF):TRectF;

Parameters

R
Type: TRectF

Return Value

Type: TRectF

See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender.Hit(TRectF,Single,Single) Method

Summary

Represents method Hit(TRectF,Single,Single).

Namespace: Tee.Renders
Syntax
Delphi
public
 function Hit(const R:TRectF; const X,Y:Single):Boolean; override;

Parameters

R
Type: TRectF

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

Overrides

TRender.Hit(TRectF,Single,Single)
See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TTextRender.Paint(TRenderData)
See Also

Reference

  • TBoxRender
  • Tee.Renders


TBoxRender Fields

Fields
Name | Description
AlwaysDraw | Represents field AlwaysDraw.
Top


TBoxRender.AlwaysDraw Field

Summary

Represents field AlwaysDraw.

Namespace: Tee.Renders
Syntax
Delphi
protected
 AlwaysDraw : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBoxRender
  • Tee.Renders


TCellRender Class

Summary

Represents type TCellRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Renders.TCellRender
Tee.Grid.Columns.TColumnHeader
Syntax
Delphi
type
 TCellRender=class(TVisibleTextRender)
 end;

The TCellRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TVisibleTextRender class. (Overrides TTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Text | Represents property Text.
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TCellRender Properties

Properties
Name | Description
Text | Represents property Text.
Top


TCellRender.Text Property

Summary

Represents property Text.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Text:String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TCellRender
  • Tee.Renders


TCellRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TVisibleTextRender.Assign(TPersistent).)
Top


TCellRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TVisibleTextRender.Assign(TPersistent)
See Also

Reference

  • TCellRender
  • Tee.Renders


TEdges Class

Summary

Represents type TEdges.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TEdges
Tee.Renders.TMargins
Syntax
Delphi
type
 TEdges=class(TPersistentChange)
 end;

The TEdges type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TEdges class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TEdges class.
Top
Properties
Show:
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Right | Represents property Right.
Top | Represents property Top.
Top
Methods
Show:
Name | Description
Adjust(TRectF) | Represents method Adjust(TRectF).
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Horizontal | Represents method Horizontal.
Init(Single,Single) | Represents method Init(Single,Single).
Prepare(Single,Single) | Represents method Prepare(Single,Single).
Vertical | Represents method Vertical.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TEdges Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TEdges class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TEdges class.
Top


TEdges.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TEdges class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Destroy Destructor

Summary

Represents the destructor of the TEdges class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TEdges
  • Tee.Renders


TEdges Properties

Properties
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
Right | Represents property Right.
Top | Represents property Top.
Top


TEdges.Bottom Property

Summary

Represents property Bottom.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Bottom:TCoordinate read FBottom write SetBottom;

Property Value

Type: TCoordinate

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Left Property

Summary

Represents property Left.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Left:TCoordinate read FLeft write SetLeft;

Property Value

Type: TCoordinate

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Right Property

Summary

Represents property Right.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Right:TCoordinate read FRight write SetRight;

Property Value

Type: TCoordinate

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Top Property

Summary

Represents property Top.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Top:TCoordinate read FTop write SetTop;

Property Value

Type: TCoordinate

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges Methods

Methods
Name | Description
Adjust(TRectF) | Represents method Adjust(TRectF).
Assign(TPersistent) | Represents method Assign(TPersistent).
Horizontal | Represents method Horizontal.
Init(Single,Single) | Represents method Init(Single,Single).
Prepare(Single,Single) | Represents method Prepare(Single,Single).
Vertical | Represents method Vertical.
Top


TEdges.Adjust(TRectF) Method

Summary

Represents method Adjust(TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 function Adjust(const R:TRectF):TRectF;

Parameters

R
Type: TRectF

Return Value

Type: TRectF

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Horizontal Method

Summary

Represents method Horizontal.

Namespace: Tee.Renders
Syntax
Delphi
public
 function Horizontal:Single;

Return Value

Type: Single

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Init(Single,Single) Method

Summary

Represents method Init(Single,Single).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Init(const AHoriz,AVert:Single);

Parameters

AHoriz
Type: Single

AVert
Type: Single

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Prepare(Single,Single) Method

Summary

Represents method Prepare(Single,Single).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Prepare(const AWidth,AHeight:Single);

Parameters

AWidth
Type: Single

AHeight
Type: Single

See Also

Reference

  • TEdges
  • Tee.Renders


TEdges.Vertical Method

Summary

Represents method Vertical.

Namespace: Tee.Renders
Syntax
Delphi
public
 function Vertical:Single;

Return Value

Type: Single

See Also

Reference

  • TEdges
  • Tee.Renders


TExpanderRender Class

Summary

Represents type TExpanderRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TBoxRender
Tee.Renders.TExpanderRender
Syntax
Delphi
type
 TExpanderRender=class(TBoxRender)
 end;

The TExpanderRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TExpanderRender class. (Overrides TBoxRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TExpanderRender class. (Overrides TBoxRender.Destroy.)
Top
Properties
Show:
Name | Description
AlwaysExpand | Represents property AlwaysExpand.
Borders | Represents property Borders. (Inherited from TFormatRender.)
Box | Represents property Box. (Inherited from TBoxRender.)
ExpandFormat | Represents property ExpandFormat.
ExpandLine | Represents property ExpandLine.
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Style | Represents property Style.
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TBoxRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
Calculate(TRectF) | Represents method Calculate(TRectF). (Inherited from TBoxRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Expand(Integer) | Represents method Expand(Integer).
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Overrides TRender.Hit(TRectF,Single,Single).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TBoxRender.Paint(TRenderData).)
PaintLines(TRenderData) | Represents method PaintLines(TRenderData).
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Events
Show:
Name | Description
OnCanExpand | Represents property OnCanExpand.
OnExpand | Represents property OnExpand.
OnGetData | Represents property OnGetData.
OnGetExpanded | Represents property OnGetExpanded.
Top
Fields
Show:
Name | Description
AlwaysDraw | Represents field AlwaysDraw. (Inherited from TBoxRender.)
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TExpanderRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TExpanderRender class. (Overrides TBoxRender.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TExpanderRender class. (Overrides TBoxRender.Destroy.)
Top


TExpanderRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TExpanderRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TBoxRender.Create(TNotifyEvent)
See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.Destroy Destructor

Summary

Represents the destructor of the TExpanderRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBoxRender.Destroy
See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender Properties

Properties
Name | Description
AlwaysExpand | Represents property AlwaysExpand.
ExpandFormat | Represents property ExpandFormat.
ExpandLine | Represents property ExpandLine.
Style | Represents property Style.
Top


TExpanderRender.AlwaysExpand Property

Summary

Represents property AlwaysExpand.

Namespace: Tee.Renders
Syntax
Delphi
published
 property AlwaysExpand:Boolean read FAlwaysExpand write FAlwaysExpand;

Property Value

Type: Boolean

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.ExpandFormat Property

Summary

Represents property ExpandFormat.

Namespace: Tee.Renders
Syntax
Delphi
published
 property ExpandFormat:TFormat read FExpandFormat write SetExpandFormat;

Property Value

Type: TFormat

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.ExpandLine Property

Summary

Represents property ExpandLine.

Namespace: Tee.Renders
Syntax
Delphi
published
 property ExpandLine:TStroke read FExpandLine write SetExpandLine;

Property Value

Type: TStroke

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.Style Property

Summary

Represents property Style.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Style:TExpanderStyle read FStyle write SetStyle default TExpanderStyle.PlusMinus;

Property Value

Type: TExpanderStyle

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TBoxRender.Assign(TPersistent).)
Expand(Integer) | Represents method Expand(Integer).
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TBoxRender.Paint(TRenderData).)
PaintLines(TRenderData) | Represents method PaintLines(TRenderData).
Top


TExpanderRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TBoxRender.Assign(TPersistent)
See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.Expand(Integer) Method

Summary

Represents method Expand(Integer).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Expand(const ARow:Integer);

Parameters

ARow
Type: Integer

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TBoxRender.Paint(TRenderData)
See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.PaintLines(TRenderData) Method

Summary

Represents method PaintLines(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure PaintLines(var AData:TRenderData);

Parameters

AData
Type: TRenderData

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender Events

Events
Name | Description
OnCanExpand | Represents property OnCanExpand.
OnExpand | Represents property OnExpand.
OnGetData | Represents property OnGetData.
OnGetExpanded | Represents property OnGetExpanded.
Top


TExpanderRender.OnCanExpand Event

Summary

Represents property OnCanExpand.

Namespace: Tee.Renders
Syntax
Delphi
published
 property OnCanExpand:TExpanderEvent read FOnCanExpand write FOnCanExpand;

Value

Type: TExpanderEvent

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.OnExpand Event

Summary

Represents property OnExpand.

Namespace: Tee.Renders
Syntax
Delphi
published
 property OnExpand:TExpanderEvent read FOnExpand write FOnExpand;

Value

Type: TExpanderEvent

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.OnGetData Event

Summary

Represents property OnGetData.

Namespace: Tee.Renders
Syntax
Delphi
published
 property OnGetData:TExpanderGetDataEvent read FOnGetData write FOnGetData;

Value

Type: TExpanderGetDataEvent

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TExpanderRender.OnGetExpanded Event

Summary

Represents property OnGetExpanded.

Namespace: Tee.Renders
Syntax
Delphi
published
 property OnGetExpanded:TExpanderEvent read FOnGetExpanded write FOnGetExpanded;

Value

Type: TExpanderEvent

See Also

Reference

  • TExpanderRender
  • Tee.Renders


TFormatRender Class

Summary

Represents type TFormatRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Grid.Header.TSortableHeader
Tee.Renders.TProgressRender
Tee.Renders.TTextRender
Syntax
Delphi
type
 TFormatRender=class(TRender)
 end;

The TFormatRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class. (Inherited from TPersistentChange.)
Destroy | Represents the destructor of the TFormatRender class.
Top
Properties
Show:
Name | Description
Borders | Represents property Borders.
Format | Represents property Format.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat.
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TFormatRender Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TFormatRender class.
Top


TFormatRender.Destroy Destructor

Summary

Represents the destructor of the TFormatRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender Properties

Properties
Name | Description
Borders | Represents property Borders.
Format | Represents property Format.
Top


TFormatRender.Borders Property

Summary

Represents property Borders.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Borders:TBorders read GetBorders write SetBorders;

Property Value

Type: TBorders

See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender.Format Property

Summary

Represents property Format.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Format:TTextFormat read GetFormat write SetFormat;

Property Value

Type: TTextFormat

See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
HasFormat | Represents method HasFormat.
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight.
Top


TFormatRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender.HasFormat Method

Summary

Represents method HasFormat.

Namespace: Tee.Renders
Syntax
Delphi
public
 function HasFormat:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TRender.Paint(TRenderData)
See Also

Reference

  • TFormatRender
  • Tee.Renders


TFormatRender.StrokeHeight Method

Summary

Represents method StrokeHeight.

Namespace: Tee.Renders
Syntax
Delphi
public
 function StrokeHeight:Single;

Return Value

Type: Single

See Also

Reference

  • TFormatRender
  • Tee.Renders


THover Class

Summary

Represents type THover.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Renders.THover
Tee.Grid.Bands.Columns.TSelectedRender
Syntax
Delphi
type
 THover=class(TVisibleTextRender)
 end;

The THover type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the THover class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
ParentFont | Represents property ParentFont.
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible. (Inherited from TVisibleTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide. (Inherited from TVisibleTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
InitFormat | Represents method InitFormat.
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Show | Represents method Show. (Inherited from TVisibleTextRender.)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


THover Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the THover class. (Overrides TVisibleTextRender.Create(TNotifyEvent).)
Top


THover.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the THover class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TVisibleTextRender.Create(TNotifyEvent)
See Also

Reference

  • THover
  • Tee.Renders


THover Properties

Properties
Name | Description
ParentFont | Represents property ParentFont.
Top


THover.ParentFont Property

Summary

Represents property ParentFont.

Namespace: Tee.Renders
Syntax
Delphi
published
 property ParentFont:Boolean read FParentFont write SetParentFont default True;

Property Value

Type: Boolean

See Also

Reference

  • THover
  • Tee.Renders


THover Methods

Methods
Name | Description
InitFormat | Represents method InitFormat.
Top


THover.InitFormat Method

Summary

Represents method InitFormat.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure InitFormat;
See Also

Reference

  • THover
  • Tee.Renders


TMargins Class

Summary

Represents type TMargins.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TEdges
Tee.Renders.TMargins
Syntax
Delphi
type
 TMargins=class(TEdges);

The TMargins type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TEdges class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Bottom | Represents property Bottom. (Inherited from TEdges.)
Left | Represents property Left. (Inherited from TEdges.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Right | Represents property Right. (Inherited from TEdges.)
Top | Represents property Top. (Inherited from TEdges.)
Top
Methods
Show:
Name | Description
Adjust(TRectF) | Represents method Adjust(TRectF). (Inherited from TEdges.)
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TEdges.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Horizontal | Represents method Horizontal. (Inherited from TEdges.)
Init(Single,Single) | Represents method Init(Single,Single). (Inherited from TEdges.)
Prepare(Single,Single) | Represents method Prepare(Single,Single). (Inherited from TEdges.)
Vertical | Represents method Vertical. (Inherited from TEdges.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TPasswordRender Class

Summary

Represents type TPasswordRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TPasswordRender
Syntax
Delphi
type
 TPasswordRender=class(TTextRender)
 end;

The TPasswordRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TPasswordRender Methods

Methods
Name | Description
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TTextRender.Paint(TRenderData).)
Top


TPasswordRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TTextRender.Paint(TRenderData)
See Also

Reference

  • TPasswordRender
  • Tee.Renders


TProgressRender Class

Summary

Represents type TProgressRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TProgressRender
Syntax
Delphi
type
 TProgressRender=class(TFormatRender)
 end;

The TProgressRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TProgressRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Orientation | Represents property Orientation.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TProgressRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TProgressRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TProgressRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TProgressRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TProgressRender
  • Tee.Renders


TProgressRender Properties

Properties
Name | Description
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
Orientation | Represents property Orientation.
Top


TProgressRender.Maximum Property

Summary

Represents property Maximum.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Maximum:Single read FMax write SetMax stored IsMaxStored;

Property Value

Type: Single

See Also

Reference

  • TProgressRender
  • Tee.Renders


TProgressRender.Minimum Property

Summary

Represents property Minimum.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Minimum:Single read FMin write SetMin stored IsMinStored;

Property Value

Type: Single

See Also

Reference

  • TProgressRender
  • Tee.Renders


TProgressRender.Orientation Property

Summary

Represents property Orientation.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Orientation:TOrientation read FOrientation write SetOrientation default TOrientation.Horizontal;

Property Value

Type: TOrientation

See Also

Reference

  • TProgressRender
  • Tee.Renders


TProgressRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Top


TProgressRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormatRender.Assign(TPersistent)
See Also

Reference

  • TProgressRender
  • Tee.Renders


TProgressRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TFormatRender.Paint(TRenderData)
See Also

Reference

  • TProgressRender
  • Tee.Renders


TRender Class

Summary

Represents type TRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Syntax
Delphi
type
 TRender=class(TPersistentChange)
 end;

The TRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class. (Inherited from TPersistentChange.)
Top
Properties
Show:
Name | Description
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Top
Methods
Show:
Name | Description
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single).
Paint(TRenderData) | Represents method Paint(TRenderData).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TRender Methods

Methods
Name | Description
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single).
Paint(TRenderData) | Represents method Paint(TRenderData).
Top


TRender.Hit(TRectF,Single,Single) Method

Summary

Represents method Hit(TRectF,Single,Single).

Namespace: Tee.Renders
Syntax
Delphi
public
 function Hit(const R:TRectF; const X,Y:Single):Boolean; virtual;

Parameters

R
Type: TRectF

X
Type: Single

Y
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TRender
  • Tee.Renders


TRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); virtual;

Parameters

AData
Type: TRenderData

See Also

Reference

  • TRender
  • Tee.Renders


TTextAlign Class

Summary

Represents type TTextAlign.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TAlignments
Tee.Renders.TTextAlign
Syntax
Delphi
type
 TTextAlign=class(TAlignments);

The TTextAlign type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TPersistentChange class. (Inherited from TPersistentChange.)
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal. (Inherited from TAlignments.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Vertical | Represents property Vertical. (Inherited from TAlignments.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TAlignments.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
InitHorizontal(THorizontalAlign) | Represents method InitHorizontal(THorizontalAlign). (Inherited from TAlignments.)
InitVertical(TVerticalAlign) | Represents method InitVertical(TVerticalAlign). (Inherited from TAlignments.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TTextRender Class

Summary

Represents type TTextRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Grid.Bands.Columns.TTextRenderAccess
Tee.Grid.RowGroup.TTextRenderAccess
Tee.Grid.Rows.TTextRenderAccess
Tee.Renders.TBoxRender
Tee.Renders.TPasswordRender
Tee.Renders.TVisibleTextRender
Syntax
Delphi
type
 TTextRender=class(TFormatRender)
 end;

The TTextRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TTextRender class. (Overrides TFormatRender.Destroy.)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign.
Trimming | Represents property Trimming.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter).
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins.
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin.
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText.
TextLines | Represents field TextLines.
Top
See Also

Reference

  • Tee.Renders


TTextRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextRender class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Destroy | Represents the destructor of the TTextRender class. (Overrides TFormatRender.Destroy.)
Top


TTextRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TTextRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.Destroy Destructor

Summary

Represents the destructor of the TTextRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormatRender.Destroy
See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender Properties

Properties
Name | Description
Margins | Represents property Margins.
TextAlign | Represents property TextAlign.
Trimming | Represents property Trimming.
Top


TTextRender.Margins Property

Summary

Represents property Margins.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Margins:TMargins read GetMargins write SetMargins;

Property Value

Type: TMargins

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.TextAlign Property

Summary

Represents property TextAlign.

Namespace: Tee.Renders
Syntax
Delphi
published
 property TextAlign:TTextAlign read FAlign write SetAlign;

Property Value

Type: TTextAlign

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.Trimming Property

Summary

Represents property Trimming.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Trimming:TTextTrimming read GetTrimming write SetTrimming;

Property Value

Type: TTextTrimming

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormatRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter).
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String).
HasMargins | Represents method HasMargins.
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
VerticalMargin | Represents method VerticalMargin.
Top


TTextRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormatRender.Assign(TPersistent)
See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.CalcHeight(TPainter) Method

Summary

Represents method CalcHeight(TPainter).

Namespace: Tee.Renders
Syntax
Delphi
public
 function CalcHeight(const APainter:TPainter):Single; overload;

Parameters

APainter
Type: TPainter

Return Value

Type: Single

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.CalcHeight(TPainter,String) Method

Summary

Represents method CalcHeight(TPainter,String).

Namespace: Tee.Renders
Syntax
Delphi
public
 function CalcHeight(const APainter:TPainter; const AText:String):Single; overload;

Parameters

APainter
Type: TPainter

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.HasMargins Method

Summary

Represents method HasMargins.

Namespace: Tee.Renders
Syntax
Delphi
protected
 function HasMargins:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.Paint(TRenderData) Method

Summary

Represents method Paint(TRenderData).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData); override;

Parameters

AData
Type: TRenderData

Overrides

TFormatRender.Paint(TRenderData)
See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.VerticalMargin Method

Summary

Represents method VerticalMargin.

Namespace: Tee.Renders
Syntax
Delphi
protected
 function VerticalMargin:Single;

Return Value

Type: Single

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender Fields

Fields
Name | Description
PaintText | Represents field PaintText.
TextLines | Represents field TextLines.
Top


TTextRender.PaintText Field

Summary

Represents field PaintText.

Namespace: Tee.Renders
Syntax
Delphi
public
 PaintText : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextRender.TextLines Field

Summary

Represents field TextLines.

Namespace: Tee.Renders
Syntax
Delphi
public
 TextLines : Integer;

Field Value

Type: Integer

See Also

Reference

  • TTextRender
  • Tee.Renders


TTextTrimming Class

Summary

Represents type TTextTrimming.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TTextTrimming
Syntax
Delphi
type
 TTextTrimming=class(TPersistentChange)
 end;

The TTextTrimming type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextTrimming class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Ellipsi | Represents property Ellipsi.
Mode | Represents property Mode.
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
Top
See Also

Reference

  • Tee.Renders


TTextTrimming Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TTextTrimming class. (Overrides TPersistentChange.Create(TNotifyEvent).)
Top


TTextTrimming.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TTextTrimming class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TPersistentChange.Create(TNotifyEvent)
See Also

Reference

  • TTextTrimming
  • Tee.Renders


TTextTrimming Properties

Properties
Name | Description
Ellipsi | Represents property Ellipsi.
Mode | Represents property Mode.
Top


TTextTrimming.Ellipsi Property

Summary

Represents property Ellipsi.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Ellipsi:Boolean read FEllipsi write SetEllipsi default True;

Property Value

Type: Boolean

See Also

Reference

  • TTextTrimming
  • Tee.Renders


TTextTrimming.Mode Property

Summary

Represents property Mode.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Mode:TTrimmingMode read FMode write SetMode default TTrimmingMode.None;

Property Value

Type: TTrimmingMode

See Also

Reference

  • TTextTrimming
  • Tee.Renders


TTextTrimming Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TTextTrimming.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TTextTrimming
  • Tee.Renders


TVisibleRenderItem Class

Summary

Represents type TVisibleRenderItem.

Namespace: Tee.Renders
Inheritance Hierarchy
TCollectionItem
Tee.Renders.TVisibleRenderItem
Tee.Grid.Bands.TGridBand
Tee.Grid.Columns.TColumn
Syntax
Delphi
type
 TVisibleRenderItem=class(TCollectionItem)
 end;

The TVisibleRenderItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TVisibleRenderItem class.
Destroy | Represents the destructor of the TVisibleRenderItem class.
Top
Properties
Show:
Name | Description
Format | Represents property Format.
Render | Represents property Render.
Tag | Represents property Tag.
TagObject | Represents property TagObject.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Changed(TObject) | Represents method Changed(TObject).
CreateRender | Represents method CreateRender.
DoChanged | Represents method DoChanged.
GetFormat | Represents method GetFormat.
HasFormat | Represents method HasFormat.
HasRender | Represents method HasRender.
Hide | Represents method Hide.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender).
SetRender(TRender) | Represents method SetRender(TRender).
Show | Represents method Show.
Top
Fields
Show:
Name | Description
FRender | Represents field FRender.
Top
See Also

Reference

  • Tee.Renders


TVisibleRenderItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TVisibleRenderItem class.
Destroy | Represents the destructor of the TVisibleRenderItem class.
Top


TVisibleRenderItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TVisibleRenderItem class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Destroy Destructor

Summary

Represents the destructor of the TVisibleRenderItem class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem Properties

Properties
Name | Description
Format | Represents property Format.
Render | Represents property Render.
Tag | Represents property Tag.
TagObject | Represents property TagObject.
Visible | Represents property Visible.
Top


TVisibleRenderItem.Format Property

Summary

Represents property Format.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Format:TTextFormat read GetFormat write SetFormat stored IsFormatStored;

Property Value

Type: TTextFormat

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Render Property

Summary

Represents property Render.

Namespace: Tee.Renders
Syntax
Delphi
public
 property Render:TRender read GetRender write SetRender;

Property Value

Type: TRender

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Tag Property

Summary

Represents property Tag.

Namespace: Tee.Renders
Syntax
Delphi
public
 property Tag:Integer read FTag write FTag;

Property Value

Type: Integer

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.TagObject Property

Summary

Represents property TagObject.

Namespace: Tee.Renders
Syntax
Delphi
public
 property TagObject:TObject read FTagObject write FTagObject;

Property Value

Type: TObject

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Changed(TObject) | Represents method Changed(TObject).
CreateRender | Represents method CreateRender.
DoChanged | Represents method DoChanged.
GetFormat | Represents method GetFormat.
HasFormat | Represents method HasFormat.
HasRender | Represents method HasRender.
Hide | Represents method Hide.
Paint(TRenderData,TRender) | Represents method Paint(TRenderData,TRender).
SetRender(TRender) | Represents method SetRender(TRender).
Show | Represents method Show.
Top


TVisibleRenderItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Changed(TObject) Method

Summary

Represents method Changed(TObject).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Changed(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.CreateRender Method

Summary

Represents method CreateRender.

Namespace: Tee.Renders
Syntax
Delphi
protected
 function CreateRender:TRender; virtual;

Return Value

Type: TRender

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.DoChanged Method

Summary

Represents method DoChanged.

Namespace: Tee.Renders
Syntax
Delphi
protected
 procedure DoChanged; virtual;
See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.GetFormat Method

Summary

Represents method GetFormat.

Namespace: Tee.Renders
Syntax
Delphi
protected
 function GetFormat: TTextFormat; virtual;

Return Value

Type: TTextFormat

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.HasFormat Method

Summary

Represents method HasFormat.

Namespace: Tee.Renders
Syntax
Delphi
public
 function HasFormat:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.HasRender Method

Summary

Represents method HasRender.

Namespace: Tee.Renders
Syntax
Delphi
public
 function HasRender:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Hide Method

Summary

Represents method Hide.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Hide;
See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Paint(TRenderData,TRender) Method

Summary

Represents method Paint(TRenderData,TRender).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Paint(var AData:TRenderData; const ARender:TRender); virtual;

Parameters

AData
Type: TRenderData

ARender
Type: TRender

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.SetRender(TRender) Method

Summary

Represents method SetRender(TRender).

Namespace: Tee.Renders
Syntax
Delphi
protected
 procedure SetRender(const Value: TRender); virtual;

Parameters

Value
Type: TRender

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem.Show Method

Summary

Represents method Show.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Show;
See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleRenderItem Fields

Fields
Name | Description
FRender | Represents field FRender.
Top


TVisibleRenderItem.FRender Field

Summary

Represents field FRender.

Namespace: Tee.Renders
Syntax
Delphi
protected
 FRender: TRender;

Field Value

Type: TRender

See Also

Reference

  • TVisibleRenderItem
  • Tee.Renders


TVisibleTextRender Class

Summary

Represents type TVisibleTextRender.

Namespace: Tee.Renders
Inheritance Hierarchy
TPersistent
Tee.Format.TPersistentChange
Tee.Renders.TRender
Tee.Renders.TFormatRender
Tee.Renders.TTextRender
Tee.Renders.TVisibleTextRender
Tee.Grid.Columns.TIndicator
Tee.Grid.Selection.TGridSelection
Tee.Renders.TCellRender
Tee.Renders.THover
Syntax
Delphi
type
 TVisibleTextRender=class(TTextRender)
 end;

The TVisibleTextRender type exposes the following members.

Constructors
Show:
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TVisibleTextRender class. (Overrides TTextRender.Create(TNotifyEvent).)
Top
Properties
Show:
Name | Description
Borders | Represents property Borders. (Inherited from TFormatRender.)
Format | Represents property Format. (Inherited from TFormatRender.)
Margins | Represents property Margins. (Inherited from TTextRender.)
OnChange | Represents property OnChange. (Inherited from TPersistentChange.)
TextAlign | Represents property TextAlign. (Inherited from TTextRender.)
Trimming | Represents property Trimming. (Inherited from TTextRender.)
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
CalcHeight(TPainter) | Overloaded. Represents method CalcHeight(TPainter). (Inherited from TTextRender.)
CalcHeight(TPainter,String) | Overloaded. Represents method CalcHeight(TPainter,String). (Inherited from TTextRender.)
ChangeBoolean(Boolean,Boolean) | Represents method ChangeBoolean(Boolean,Boolean). (Inherited from TPersistentChange.)
Changed | Represents method Changed. (Inherited from TPersistentChange.)
ChangeInteger(Integer,Integer) | Represents method ChangeInteger(Integer,Integer). (Inherited from TPersistentChange.)
ChangeSingle(Single,Single) | Represents method ChangeSingle(Single,Single). (Inherited from TPersistentChange.)
ChangeString(String,String) | Represents method ChangeString(String,String). (Inherited from TPersistentChange.)
HasFormat | Represents method HasFormat. (Inherited from TFormatRender.)
HasMargins | Represents method HasMargins. (Inherited from TTextRender.)
Hide | Represents method Hide.
Hit(TRectF,Single,Single) | Represents method Hit(TRectF,Single,Single). (Inherited from TRender.)
Paint(TRenderData) | Represents method Paint(TRenderData). (Overrides TFormatRender.Paint(TRenderData).)
Show | Represents method Show.
StrokeHeight | Represents method StrokeHeight. (Inherited from TFormatRender.)
VerticalMargin | Represents method VerticalMargin. (Inherited from TTextRender.)
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged. (Inherited from TPersistentChange.)
PaintText | Represents field PaintText. (Inherited from TTextRender.)
TextLines | Represents field TextLines. (Inherited from TTextRender.)
Top
See Also

Reference

  • Tee.Renders


TVisibleTextRender Constructors

Constructors
Name | Description
Create(TNotifyEvent) | Initializes a new instance of the TVisibleTextRender class. (Overrides TTextRender.Create(TNotifyEvent).)
Top


TVisibleTextRender.Create(TNotifyEvent) Constructor

Summary

Initializes a new instance of the TVisibleTextRender class.

Namespace: Tee.Renders
Syntax
Delphi
public
 Constructor Create(const AChanged:TNotifyEvent); override;

Parameters

AChanged
Type: TNotifyEvent

Overrides

TTextRender.Create(TNotifyEvent)
See Also

Reference

  • TVisibleTextRender
  • Tee.Renders


TVisibleTextRender Properties

Properties
Name | Description
Visible | Represents property Visible.
Top


TVisibleTextRender.Visible Property

Summary

Represents property Visible.

Namespace: Tee.Renders
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TVisibleTextRender
  • Tee.Renders


TVisibleTextRender Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTextRender.Assign(TPersistent).)
Hide | Represents method Hide.
Show | Represents method Show.
Top


TVisibleTextRender.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TTextRender.Assign(TPersistent)
See Also

Reference

  • TVisibleTextRender
  • Tee.Renders


TVisibleTextRender.Hide Method

Summary

Represents method Hide.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Hide;
See Also

Reference

  • TVisibleTextRender
  • Tee.Renders


TVisibleTextRender.Show Method

Summary

Represents method Show.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure Show;
See Also

Reference

  • TVisibleTextRender
  • Tee.Renders


Tee.Renders Records

Records
Name | Description
TRenderData | Represents type TRenderData.
TShapePainter | Represents type TShapePainter.
TShapePainter.TArrow | Represents type TArrow.
TShapePainter.TTriangle | Represents type TTriangle.
Top


TRenderData Record

Summary

Represents type TRenderData.

Namespace: Tee.Renders
Syntax
Delphi
type
 TRenderData=record
 end;

The TRenderData type exposes the following members.

Methods
Show:
Name | Description
AsBoolean | Represents method AsBoolean.
ClearData | Represents method ClearData.
IsEmpty | Represents method IsEmpty.
Top
Fields
Show:
Name | Description
Bounds | Represents field Bounds.
Data | Represents field Data.
Painter | Represents field Painter.
Row | Represents field Row.
Top
See Also

Reference

  • Tee.Renders


TRenderData Methods

Methods
Name | Description
AsBoolean | Represents method AsBoolean.
ClearData | Represents method ClearData.
IsEmpty | Represents method IsEmpty.
Top


TRenderData.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: Tee.Renders
Syntax
Delphi
public
 function AsBoolean:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData.ClearData Method

Summary

Represents method ClearData.

Namespace: Tee.Renders
Syntax
Delphi
public
 procedure ClearData;
See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData.IsEmpty Method

Summary

Represents method IsEmpty.

Namespace: Tee.Renders
Syntax
Delphi
public
 function IsEmpty:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData Fields

Fields
Name | Description
Bounds | Represents field Bounds.
Data | Represents field Data.
Painter | Represents field Painter.
Row | Represents field Row.
Top


TRenderData.Bounds Field

Summary

Represents field Bounds.

Namespace: Tee.Renders
Syntax
Delphi
public
 Bounds : TRectF;

Field Value

Type: TRectF

See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData.Data Field

Summary

Represents field Data.

Namespace: Tee.Renders
Syntax
Delphi
public
 Data : String;

Field Value

Type: String

See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData.Painter Field

Summary

Represents field Painter.

Namespace: Tee.Renders
Syntax
Delphi
public
 Painter : TPainter;

Field Value

Type: TPainter

See Also

Reference

  • TRenderData
  • Tee.Renders


TRenderData.Row Field

Summary

Represents field Row.

Namespace: Tee.Renders
Syntax
Delphi
public
 Row : Integer;

Field Value

Type: Integer

See Also

Reference

  • TRenderData
  • Tee.Renders


TShapePainter Record

Summary

Represents type TShapePainter.

Namespace: Tee.Renders
Syntax
Delphi
type
 TShapePainter=record
 end;

The TShapePainter type exposes the following members.

Methods
Show:
Name | Description
Check(TPainter,TRectF) | Represents method Check(TPainter,TRectF).
PlusMinus(TPainter,TRectF,Boolean) | Represents method PlusMinus(TPainter,TRectF,Boolean).
Top
Fields
Show:
Name | Description
Arrow | Represents field Arrow.
Triangle | Represents field Triangle.
Top
See Also

Reference

  • Tee.Renders


TShapePainter Methods

Methods
Name | Description
Check(TPainter,TRectF) | Represents method Check(TPainter,TRectF).
PlusMinus(TPainter,TRectF,Boolean) | Represents method PlusMinus(TPainter,TRectF,Boolean).
Top


TShapePainter.Check(TPainter,TRectF) Method

Summary

Represents method Check(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure Check(const APainter:TPainter; const ARect:TRectF); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter.PlusMinus(TPainter,TRectF,Boolean) Method

Summary

Represents method PlusMinus(TPainter,TRectF,Boolean).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure PlusMinus(const APainter:TPainter; const ARect:TRectF; const IsExpanded:Boolean); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

IsExpanded
Type: Boolean

See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter Fields

Fields
Name | Description
Arrow | Represents field Arrow.
Triangle | Represents field Triangle.
Top


TShapePainter.Arrow Field

Summary

Represents field Arrow.

Namespace: Tee.Renders
Syntax
Delphi
public
 class var
 Arrow : TArrow;

Field Value

Type: TArrow

See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter.Triangle Field

Summary

Represents field Triangle.

Namespace: Tee.Renders
Syntax
Delphi
public
 class var
 Triangle : TTriangle;

Field Value

Type: TTriangle

See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter.TArrow Record

Summary

Represents type TArrow.

Namespace: Tee.Renders
Syntax
Delphi
public
type
 TArrow=record
 end;

The TShapePainter.TArrow type exposes the following members.

Methods
Show:
Name | Description
Down(TPainter,TRectF) | Represents method Down(TPainter,TRectF).
Right(TPainter,TRectF) | Represents method Right(TPainter,TRectF).
Top
See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter.TArrow Methods

Methods
Name | Description
Down(TPainter,TRectF) | Represents method Down(TPainter,TRectF).
Right(TPainter,TRectF) | Represents method Right(TPainter,TRectF).
Top


TShapePainter.TArrow.Down(TPainter,TRectF) Method

Summary

Represents method Down(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure Down(const APainter:TPainter; const ARect:TRectF); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TShapePainter.TArrow
  • TShapePainter
  • Tee.Renders


TShapePainter.TArrow.Right(TPainter,TRectF) Method

Summary

Represents method Right(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure Right(const APainter:TPainter; const ARect:TRectF); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TShapePainter.TArrow
  • TShapePainter
  • Tee.Renders


TShapePainter.TTriangle Record

Summary

Represents type TTriangle.

Namespace: Tee.Renders
Syntax
Delphi
public
type
 TTriangle=record
 end;

The TShapePainter.TTriangle type exposes the following members.

Methods
Show:
Name | Description
LeftRight(TPainter,TRectF) | Represents method LeftRight(TPainter,TRectF).
TopBottom(TPainter,TRectF) | Represents method TopBottom(TPainter,TRectF).
Top
See Also

Reference

  • TShapePainter
  • Tee.Renders


TShapePainter.TTriangle Methods

Methods
Name | Description
LeftRight(TPainter,TRectF) | Represents method LeftRight(TPainter,TRectF).
TopBottom(TPainter,TRectF) | Represents method TopBottom(TPainter,TRectF).
Top


TShapePainter.TTriangle.LeftRight(TPainter,TRectF) Method

Summary

Represents method LeftRight(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure LeftRight(const APainter:TPainter; const ARect:TRectF); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TShapePainter.TTriangle
  • TShapePainter
  • Tee.Renders


TShapePainter.TTriangle.TopBottom(TPainter,TRectF) Method

Summary

Represents method TopBottom(TPainter,TRectF).

Namespace: Tee.Renders
Syntax
Delphi
public
 class procedure TopBottom(const APainter:TPainter; const ARect:TRectF); static;

Parameters

APainter
Type: TPainter

ARect
Type: TRectF

See Also

Reference

  • TShapePainter.TTriangle
  • TShapePainter
  • Tee.Renders


Tee.Renders Enumerations

Enumerations
Name | Description
TBooleanRenderStyle | Represents type TBooleanRenderStyle.
TExpanderStyle | Represents type TExpanderStyle.
TOrientation | Represents type TOrientation.
Top


TBooleanRenderStyle Enumeration

Summary

Represents type TBooleanRenderStyle.

Namespace: Tee.Renders
Syntax
Delphi
type
 TBooleanRenderStyle=(Check,Text);

The TBooleanRenderStyle type exposes the following members.

Members
Show:
Name | Description
Check | Represents constant Check.
Text | Represents constant Text.
Top
See Also

Reference

  • Tee.Renders


TExpanderStyle Enumeration

Summary

Represents type TExpanderStyle.

Namespace: Tee.Renders
Syntax
Delphi
type
 TExpanderStyle=(PlusMinus,Triangle,Arrow);

The TExpanderStyle type exposes the following members.

Members
Show:
Name | Description
Arrow | Represents constant Arrow.
PlusMinus | Represents constant PlusMinus.
Triangle | Represents constant Triangle.
Top
See Also

Reference

  • Tee.Renders


TOrientation Enumeration

Summary

Represents type TOrientation.

Namespace: Tee.Renders
Syntax
Delphi
type
 TOrientation=(Horizontal,Vertical);

The TOrientation type exposes the following members.

Members
Show:
Name | Description
Horizontal | Represents constant Horizontal.
Vertical | Represents constant Vertical.
Top
See Also

Reference

  • Tee.Renders


Tee.Renders Delegates

Delegates
Name | Description
TExpanderEvent | Represents type TExpanderEvent.
TExpanderGetDataEvent | Represents type TExpanderGetDataEvent.
Top


TExpanderEvent Delegate

Summary

Represents type TExpanderEvent.

Namespace: Tee.Renders
Syntax
Delphi
type
 TExpanderEvent=function(const Sender:TRender; const ARow:Integer):Boolean of object;
See Also

Reference

  • Tee.Renders


TExpanderGetDataEvent Delegate

Summary

Represents type TExpanderGetDataEvent.

Namespace: Tee.Renders
Syntax
Delphi
type
 TExpanderGetDataEvent=procedure(const Sender: TExpanderRender; const ARow:Integer; out AData:TObject) of object;
See Also

Reference

  • Tee.Renders


Tee.Renders Types

Types
Name | Description
TRenderClass | Represents type TRenderClass.
Top


TRenderClass Type

Summary

Represents type TRenderClass.

Namespace: Tee.Renders
Syntax
Delphi
type
 TRenderClass=class of TRender;
See Also

Reference

  • Tee.Renders


VCLTeeGrid

Summary

Represents namespace VCLTeeGrid.

Namespaces
Name | Description
VCLTee.Control | Represents namespace VCLTee.Control.
VCLTee.Editor.Borders | Represents namespace VCLTee.Editor.Borders.
VCLTee.Editor.Brush | Represents namespace VCLTee.Editor.Brush.
VCLTee.Editor.Column | Represents namespace VCLTee.Editor.Column.
VCLTee.Editor.ColumnBand | Represents namespace VCLTee.Editor.ColumnBand.
VCLTee.Editor.Coordinate | Represents namespace VCLTee.Editor.Coordinate.
VCLTee.Editor.Font | Represents namespace VCLTee.Editor.Font.
VCLTee.Editor.Format | Represents namespace VCLTee.Editor.Format.
VCLTee.Editor.Format.Text | Represents namespace VCLTee.Editor.Format.Text.
VCLTee.Editor.Gradient | Represents namespace VCLTee.Editor.Gradient.
VCLTee.Editor.Grid | Represents namespace VCLTee.Editor.Grid.
VCLTee.Editor.Grid.Band.Columns | Represents namespace VCLTee.Editor.Grid.Band.Columns.
VCLTee.Editor.Grid.Band.Text | Represents namespace VCLTee.Editor.Grid.Band.Text.
VCLTee.Editor.Grid.Band.Totals | Represents namespace VCLTee.Editor.Grid.Band.Totals.
VCLTee.Editor.Grid.Bands | Represents namespace VCLTee.Editor.Grid.Bands.
VCLTee.Editor.Grid.Ticker | Represents namespace VCLTee.Editor.Grid.Ticker.
VCLTee.Editor.Header | Represents namespace VCLTee.Editor.Header.
VCLTee.Editor.Margins | Represents namespace VCLTee.Editor.Margins.
VCLTee.Editor.Render.Text | Represents namespace VCLTee.Editor.Render.Text.
VCLTee.Editor.Scrolling | Represents namespace VCLTee.Editor.Scrolling.
VCLTee.Editor.Selected | Represents namespace VCLTee.Editor.Selected.
VCLTee.Editor.Stroke | Represents namespace VCLTee.Editor.Stroke.
VCLTee.Editor.Text.Align | Represents namespace VCLTee.Editor.Text.Align.
VCLTee.Grid | Represents namespace VCLTee.Grid.
VCLTee.Grid.Layout | Represents namespace VCLTee.Grid.Layout.
VCLTee.Grid.Themes | Represents namespace VCLTee.Grid.Themes.
VCLTee.Painter | Represents namespace VCLTee.Painter.
VCLTee.Painter.GdiPlus | Represents namespace VCLTee.Painter.GdiPlus.
VCLTee.Picture | Represents namespace VCLTee.Picture.
Top


VCLTee.Control Namespace

Summary

Represents namespace VCLTee.Control.

Classes
Name | Description
TFilterComboBox | Represents type TFilterComboBox.
TScrollableControl | Represents type TScrollableControl.
Top


VCLTee.Control Classes

Classes
Name | Description
TFilterComboBox | Represents type TFilterComboBox.
TScrollableControl | Represents type TScrollableControl.
Top


TFilterComboBox Class

Summary

Represents type TFilterComboBox.

Namespace: VCLTee.Control
Inheritance Hierarchy
TComboBox
VCLTee.Control.TFilterComboBox
Syntax
Delphi
type
 TFilterComboBox = class(TComboBox)
 end;

The TFilterComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterComboBox class.
Destroy | Represents the destructor of the TFilterComboBox class.
Top
Properties
Show:
Name | Description
StoredItems | Represents property StoredItems.
Top
See Also

Reference

  • VCLTee.Control


TFilterComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterComboBox class.
Destroy | Represents the destructor of the TFilterComboBox class.
Top


TFilterComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TFilterComboBox class.

Namespace: VCLTee.Control
Syntax
Delphi
public
 Constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TFilterComboBox
  • VCLTee.Control


TFilterComboBox.Destroy Destructor

Summary

Represents the destructor of the TFilterComboBox class.

Namespace: VCLTee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFilterComboBox
  • VCLTee.Control


TFilterComboBox Properties

Properties
Name | Description
StoredItems | Represents property StoredItems.
Top


TFilterComboBox.StoredItems Property

Summary

Represents property StoredItems.

Namespace: VCLTee.Control
Syntax
Delphi
public
 property StoredItems: TStringList read FStoredItems write SetStoredItems;

Property Value

Type: TStringList

See Also

Reference

  • TFilterComboBox
  • VCLTee.Control


TScrollableControl Class

Summary

Represents type TScrollableControl.

Namespace: VCLTee.Control
Inheritance Hierarchy
TCustomControl
VCLTee.Control.TScrollableControl
VCLTee.Grid.TTeeGrid
Syntax
Delphi
type
 TScrollableControl=class(TCustomControl)
 end;

The TScrollableControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TScrollableControl class.
Destroy | Represents the destructor of the TScrollableControl class.
Top
Properties
Show:
Name | Description
ScrollBars | Represents property ScrollBars.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetMaxBottom | Represents method GetMaxBottom.
GetMaxRight | Represents method GetMaxRight.
GetScrollX | Represents method GetScrollX.
GetScrollY | Represents method GetScrollY.
HorizScrollHeight | Represents method HorizScrollHeight.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
RemainSize(Boolean) | Represents method RemainSize(Boolean).
ResetScrollBars | Represents method ResetScrollBars.
SetScrollX(Single) | Represents method SetScrollX(Single).
SetScrollY(Single) | Represents method SetScrollY(Single).
UpdateScroll(Integer,Single) | Represents method UpdateScroll(Integer,Single).
VertScrollWidth | Represents method VertScrollWidth.
Top
See Also

Reference

  • VCLTee.Control


TScrollableControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TScrollableControl class.
Destroy | Represents the destructor of the TScrollableControl class.
Top


TScrollableControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TScrollableControl class.

Namespace: VCLTee.Control
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.Destroy Destructor

Summary

Represents the destructor of the TScrollableControl class.

Namespace: VCLTee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl Properties

Properties
Name | Description
ScrollBars | Represents property ScrollBars.
Top


TScrollableControl.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: VCLTee.Control
Syntax
Delphi
public
 property ScrollBars:TScrollBars read FScrollBars write SetScrollBars;

Property Value

Type: TScrollBars

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetMaxBottom | Represents method GetMaxBottom.
GetMaxRight | Represents method GetMaxRight.
GetScrollX | Represents method GetScrollX.
GetScrollY | Represents method GetScrollY.
HorizScrollHeight | Represents method HorizScrollHeight.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
RemainSize(Boolean) | Represents method RemainSize(Boolean).
ResetScrollBars | Represents method ResetScrollBars.
SetScrollX(Single) | Represents method SetScrollX(Single).
SetScrollY(Single) | Represents method SetScrollY(Single).
UpdateScroll(Integer,Single) | Represents method UpdateScroll(Integer,Single).
VertScrollWidth | Represents method VertScrollWidth.
Top


TScrollableControl.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLTee.Control
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.GetMaxBottom Method

Summary

Represents method GetMaxBottom.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function GetMaxBottom:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.GetMaxRight Method

Summary

Represents method GetMaxRight.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function GetMaxRight:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.GetScrollX Method

Summary

Represents method GetScrollX.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function GetScrollX:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.GetScrollY Method

Summary

Represents method GetScrollY.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function GetScrollY:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.HorizScrollHeight Method

Summary

Represents method HorizScrollHeight.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function HorizScrollHeight:Integer;

Return Value

Type: Integer

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.PerfectScrollBar(Boolean) Method

Summary

Represents method PerfectScrollBar(Boolean).

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function PerfectScrollBar(const Vertical:Boolean):Boolean; virtual; abstract;

Parameters

Vertical
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.RemainSize(Boolean) Method

Summary

Represents method RemainSize(Boolean).

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function RemainSize(const Horizontal:Boolean):Single;

Parameters

Horizontal
Type: Boolean

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.ResetScrollBars Method

Summary

Represents method ResetScrollBars.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 procedure ResetScrollBars; virtual;
See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.SetScrollX(Single) Method

Summary

Represents method SetScrollX(Single).

Namespace: VCLTee.Control
Syntax
Delphi
protected
 procedure SetScrollX(const Value:Single); virtual; abstract;

Parameters

Value
Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.SetScrollY(Single) Method

Summary

Represents method SetScrollY(Single).

Namespace: VCLTee.Control
Syntax
Delphi
protected
 procedure SetScrollY(const Value:Single); virtual; abstract;

Parameters

Value
Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.UpdateScroll(Integer,Single) Method

Summary

Represents method UpdateScroll(Integer,Single).

Namespace: VCLTee.Control
Syntax
Delphi
protected
 procedure UpdateScroll(const Bar:Integer; const Value:Single);

Parameters

Bar
Type: Integer

Value
Type: Single

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


TScrollableControl.VertScrollWidth Method

Summary

Represents method VertScrollWidth.

Namespace: VCLTee.Control
Syntax
Delphi
protected
 function VertScrollWidth:Integer;

Return Value

Type: Integer

See Also

Reference

  • TScrollableControl
  • VCLTee.Control


VCLTee.Editor.Borders Namespace

Summary

Represents namespace VCLTee.Editor.Borders.

Classes
Name | Description
TBordersEditor | Represents type TBordersEditor.
Top


VCLTee.Editor.Borders Classes

Classes
Name | Description
TBordersEditor | Represents type TBordersEditor.
Top


TBordersEditor Class

Summary

Represents type TBordersEditor.

Namespace: VCLTee.Editor.Borders
Inheritance Hierarchy
TForm
VCLTee.Editor.Borders.TBordersEditor
Syntax
Delphi
type
 TBordersEditor = class(TForm)
 end;

The TBordersEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TBorders) | Represents method Edit(TComponent,TBorders).
Embedd(TComponent,TWinControl,TBorders) | Represents method Embedd(TComponent,TWinControl,TBorders).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageBordersChange(TObject) | Represents method PageBordersChange(TObject).
RefreshBorders(TBorders) | Represents method RefreshBorders(TBorders).
Top
Fields
Show:
Name | Description
PageBorders | Represents field PageBorders.
TabBottom | Represents field TabBottom.
TabLeft | Represents field TabLeft.
TabRight | Represents field TabRight.
TabTop | Represents field TabTop.
Top
See Also

Reference

  • VCLTee.Editor.Borders


TBordersEditor Methods

Methods
Name | Description
Edit(TComponent,TBorders) | Represents method Edit(TComponent,TBorders).
Embedd(TComponent,TWinControl,TBorders) | Represents method Embedd(TComponent,TWinControl,TBorders).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageBordersChange(TObject) | Represents method PageBordersChange(TObject).
RefreshBorders(TBorders) | Represents method RefreshBorders(TBorders).
Top


TBordersEditor.Edit(TComponent,TBorders) Method

Summary

Represents method Edit(TComponent,TBorders).

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABorders:TBorders):Boolean; static;

Parameters

AOwner
Type: TComponent

ABorders
Type: TBorders

Return Value

Type: Boolean

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.Embedd(TComponent,TWinControl,TBorders) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBorders).

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ABorders:TBorders):TBordersEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ABorders
Type: TBorders

Return Value

Type: TBordersEditor

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.PageBordersChange(TObject) Method

Summary

Represents method PageBordersChange(TObject).

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 procedure PageBordersChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.RefreshBorders(TBorders) Method

Summary

Represents method RefreshBorders(TBorders).

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
public
 procedure RefreshBorders(const ABorders:TBorders);

Parameters

ABorders
Type: TBorders

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor Fields

Fields
Name | Description
PageBorders | Represents field PageBorders.
TabBottom | Represents field TabBottom.
TabLeft | Represents field TabLeft.
TabRight | Represents field TabRight.
TabTop | Represents field TabTop.
Top


TBordersEditor.PageBorders Field

Summary

Represents field PageBorders.

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 PageBorders: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.TabBottom Field

Summary

Represents field TabBottom.

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 TabBottom: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.TabLeft Field

Summary

Represents field TabLeft.

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 TabLeft: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.TabRight Field

Summary

Represents field TabRight.

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 TabRight: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


TBordersEditor.TabTop Field

Summary

Represents field TabTop.

Namespace: VCLTee.Editor.Borders
Syntax
Delphi
published
 TabTop: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBordersEditor
  • VCLTee.Editor.Borders


VCLTee.Editor.Brush Namespace

Summary

Represents namespace VCLTee.Editor.Brush.

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TBrushEditor | Represents type TBrushEditor.
TPictureAccess | Represents type TPictureAccess.
Top
Routines
Name | Description
SizeOfPicture(Graphics) | Represents method SizeOfPicture(Graphics).
Top


VCLTee.Editor.Brush Classes

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TBrushEditor | Represents type TBrushEditor.
TPictureAccess | Represents type TPictureAccess.
Top


TBrushAccess Class

Summary

Represents type TBrushAccess.

Namespace: VCLTee.Editor.Brush
Inheritance Hierarchy
TBrush
VCLTee.Editor.Brush.TBrushAccess
Syntax
Delphi
type
 TBrushAccess=class(TBrush);
See Also

Reference

  • VCLTee.Editor.Brush


TBrushEditor Class

Summary

Represents type TBrushEditor.

Namespace: VCLTee.Editor.Brush
Inheritance Hierarchy
TForm
VCLTee.Editor.Brush.TBrushEditor
Syntax
Delphi
type
 TBrushEditor = class(TForm)
 end;

The TBrushEditor type exposes the following members.

Properties
Show:
Name | Description
OnColorChange | Represents property OnColorChange.
Top
Methods
Show:
Name | Description
BClearPictureClick(TObject) | Represents method BClearPictureClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBStretchClick(TObject) | Represents method CBStretchClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TBrush) | Represents method Edit(TComponent,TBrush).
Embedd(TComponent,TWinControl,TBrush) | Represents method Embedd(TComponent,TWinControl,TBrush).
FormShow(TObject) | Represents method FormShow(TObject).
PageBrushChange(TObject) | Represents method PageBrushChange(TObject).
RefreshBrush(TBrush) | Represents method RefreshBrush(TBrush).
RefreshColor | Represents method RefreshColor.
TBOpacityChange(TObject) | Represents method TBOpacityChange(TObject).
Top
Fields
Show:
Name | Description
BClearPicture | Represents field BClearPicture.
Button1 | Represents field Button1.
CBColor | Represents field CBColor.
CBStretch | Represents field CBStretch.
CBVisible | Represents field CBVisible.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
LOpacity | Represents field LOpacity.
LPictureSize | Represents field LPictureSize.
LPictureType | Represents field LPictureType.
OpenPictureDialog1 | Represents field OpenPictureDialog1.
PageBrush | Represents field PageBrush.
PanelTop | Represents field PanelTop.
Shape1 | Represents field Shape1.
TabGradient | Represents field TabGradient.
TabPicture | Represents field TabPicture.
TabSolid | Represents field TabSolid.
TBOpacity | Represents field TBOpacity.
Top
See Also

Reference

  • VCLTee.Editor.Brush


TBrushEditor Properties

Properties
Name | Description
OnColorChange | Represents property OnColorChange.
Top


TBrushEditor.OnColorChange Property

Summary

Represents property OnColorChange.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
public
 property OnColorChange:TNotifyEvent read FOnColorChange write FOnColorChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor Methods

Methods
Name | Description
BClearPictureClick(TObject) | Represents method BClearPictureClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBStretchClick(TObject) | Represents method CBStretchClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TBrush) | Represents method Edit(TComponent,TBrush).
Embedd(TComponent,TWinControl,TBrush) | Represents method Embedd(TComponent,TWinControl,TBrush).
FormShow(TObject) | Represents method FormShow(TObject).
PageBrushChange(TObject) | Represents method PageBrushChange(TObject).
RefreshBrush(TBrush) | Represents method RefreshBrush(TBrush).
RefreshColor | Represents method RefreshColor.
TBOpacityChange(TObject) | Represents method TBOpacityChange(TObject).
Top


TBrushEditor.BClearPictureClick(TObject) Method

Summary

Represents method BClearPictureClick(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure BClearPictureClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBColorChange(TObject) Method

Summary

Represents method CBColorChange(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure CBColorChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBStretchClick(TObject) Method

Summary

Represents method CBStretchClick(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure CBStretchClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Edit(TComponent,TBrush) Method

Summary

Represents method Edit(TComponent,TBrush).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABrush:TBrush):Boolean; static;

Parameters

AOwner
Type: TComponent

ABrush
Type: TBrush

Return Value

Type: Boolean

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Embedd(TComponent,TWinControl,TBrush) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBrush).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ABrush:TBrush):TBrushEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ABrush
Type: TBrush

Return Value

Type: TBrushEditor

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.PageBrushChange(TObject) Method

Summary

Represents method PageBrushChange(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure PageBrushChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.RefreshBrush(TBrush) Method

Summary

Represents method RefreshBrush(TBrush).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
public
 procedure RefreshBrush(const ABrush:TBrush);

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.RefreshColor Method

Summary

Represents method RefreshColor.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
public
 procedure RefreshColor;
See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.TBOpacityChange(TObject) Method

Summary

Represents method TBOpacityChange(TObject).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 procedure TBOpacityChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor Fields

Fields
Name | Description
BClearPicture | Represents field BClearPicture.
Button1 | Represents field Button1.
CBColor | Represents field CBColor.
CBStretch | Represents field CBStretch.
CBVisible | Represents field CBVisible.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
LOpacity | Represents field LOpacity.
LPictureSize | Represents field LPictureSize.
LPictureType | Represents field LPictureType.
OpenPictureDialog1 | Represents field OpenPictureDialog1.
PageBrush | Represents field PageBrush.
PanelTop | Represents field PanelTop.
Shape1 | Represents field Shape1.
TabGradient | Represents field TabGradient.
TabPicture | Represents field TabPicture.
TabSolid | Represents field TabSolid.
TBOpacity | Represents field TBOpacity.
Top


TBrushEditor.BClearPicture Field

Summary

Represents field BClearPicture.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 BClearPicture: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBColor Field

Summary

Represents field CBColor.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 CBColor: TColorBox;

Field Value

Type: TColorBox

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBStretch Field

Summary

Represents field CBStretch.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 CBStretch: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Image1 Field

Summary

Represents field Image1.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 Image1: TImage;

Field Value

Type: TImage

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.LOpacity Field

Summary

Represents field LOpacity.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 LOpacity: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.LPictureSize Field

Summary

Represents field LPictureSize.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 LPictureSize: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.LPictureType Field

Summary

Represents field LPictureType.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 LPictureType: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.OpenPictureDialog1 Field

Summary

Represents field OpenPictureDialog1.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 OpenPictureDialog1: TOpenPictureDialog;

Field Value

Type: TOpenPictureDialog

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.PageBrush Field

Summary

Represents field PageBrush.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 PageBrush: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.PanelTop Field

Summary

Represents field PanelTop.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 PanelTop: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.Shape1 Field

Summary

Represents field Shape1.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 Shape1: TShape;

Field Value

Type: TShape

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.TabGradient Field

Summary

Represents field TabGradient.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 TabGradient: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.TabPicture Field

Summary

Represents field TabPicture.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 TabPicture: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.TabSolid Field

Summary

Represents field TabSolid.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 TabSolid: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TBrushEditor.TBOpacity Field

Summary

Represents field TBOpacity.

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
published
 TBOpacity: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TBrushEditor
  • VCLTee.Editor.Brush


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: VCLTee.Editor.Brush
Inheritance Hierarchy
TPicture
VCLTee.Editor.Brush.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • VCLTee.Editor.Brush


VCLTee.Editor.Brush Routines

Routines
Name | Description
SizeOfPicture(Graphics) | Represents method SizeOfPicture(Graphics).
Top


SizeOfPicture(Graphics) Method

Summary

Represents method SizeOfPicture(Graphics).

Namespace: VCLTee.Editor.Brush
Syntax
Delphi
function SizeOfPicture(const APicture:Graphics.TPicture):String;

Parameters

APicture
Type: Graphics.TPicture

Return Value

Type: String

See Also

Reference

  • VCLTee.Editor.Brush


VCLTee.Editor.Column Namespace

Summary

Represents namespace VCLTee.Editor.Column.

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TColumnEditor | Represents type TColumnEditor.
TColumnsAccess | Represents type TColumnsAccess.
Top


VCLTee.Editor.Column Classes

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TColumnEditor | Represents type TColumnEditor.
TColumnsAccess | Represents type TColumnsAccess.
Top


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: VCLTee.Editor.Column
Inheritance Hierarchy
TColumn
VCLTee.Editor.Column.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);
See Also

Reference

  • VCLTee.Editor.Column


TColumnEditor Class

Summary

Represents type TColumnEditor.

Namespace: VCLTee.Editor.Column
Inheritance Hierarchy
TForm
VCLTee.Editor.Column.TColumnEditor
Syntax
Delphi
type
 TColumnEditor = class(TForm)
 end;

The TColumnEditor type exposes the following members.

Properties
Show:
Name | Description
OnChangedHeader | Represents property OnChangedHeader.
Top
Methods
Show:
Name | Description
CBAutoAlignClick(TObject) | Represents method CBAutoAlignClick(TObject).
CBExpandedClick(TObject) | Represents method CBExpandedClick(TObject).
CBHeaderParentClick(TObject) | Represents method CBHeaderParentClick(TObject).
CBHeaderVisibleClick(TObject) | Represents method CBHeaderVisibleClick(TObject).
CBLockedChange(TObject) | Represents method CBLockedChange(TObject).
CBParentFormatClick(TObject) | Represents method CBParentFormatClick(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
EDateFormatChange(TObject) | Represents method EDateFormatChange(TObject).
EDateTimeFormatChange(TObject) | Represents method EDateTimeFormatChange(TObject).
Edit(TComponent,TColumn) | Represents method Edit(TComponent,TColumn).
EFloatFormatChange(TObject) | Represents method EFloatFormatChange(TObject).
Embedd(TComponent,TWinControl,TColumn) | Overloaded. Represents method Embedd(TComponent,TWinControl,TColumn).
ETimeFormatChange(TObject) | Represents method ETimeFormatChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBSourceClick(TObject) | Represents method LBSourceClick(TObject).
MemoHeaderChange(TObject) | Represents method MemoHeaderChange(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshColumn(TColumn) | Represents method RefreshColumn(TColumn).
Top
Fields
Show:
Name | Description
CBAutoAlign | Represents field CBAutoAlign.
CBExpanded | Represents field CBExpanded.
CBHeaderParent | Represents field CBHeaderParent.
CBHeaderVisible | Represents field CBHeaderVisible.
CBLocked | Represents field CBLocked.
CBParentFormat | Represents field CBParentFormat.
CBReadOnly | Represents field CBReadOnly.
CBVisible | Represents field CBVisible.
EDateFormat | Represents field EDateFormat.
EDateTimeFormat | Represents field EDateTimeFormat.
EFloatFormat | Represents field EFloatFormat.
ETimeFormat | Represents field ETimeFormat.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
LBSource | Represents field LBSource.
MemoHeader | Represents field MemoHeader.
PageData | Represents field PageData.
PageFormat | Represents field PageFormat.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
TabAlign | Represents field TabAlign.
TabData | Represents field TabData.
TabFormat | Represents field TabFormat.
TabFormatting | Represents field TabFormatting.
TabGeneral | Represents field TabGeneral.
TabHeader | Represents field TabHeader.
TabMargins | Represents field TabMargins.
TabSource | Represents field TabSource.
TabWidth | Represents field TabWidth.
Top
See Also

Reference

  • VCLTee.Editor.Column


TColumnEditor Properties

Properties
Name | Description
OnChangedHeader | Represents property OnChangedHeader.
Top


TColumnEditor.OnChangedHeader Property

Summary

Represents property OnChangedHeader.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
public
 property OnChangedHeader:TNotifyEvent read FOnChangedHeader
 write FOnChangedHeader;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor Methods

Methods
Name | Description
CBAutoAlignClick(TObject) | Represents method CBAutoAlignClick(TObject).
CBExpandedClick(TObject) | Represents method CBExpandedClick(TObject).
CBHeaderParentClick(TObject) | Represents method CBHeaderParentClick(TObject).
CBHeaderVisibleClick(TObject) | Represents method CBHeaderVisibleClick(TObject).
CBLockedChange(TObject) | Represents method CBLockedChange(TObject).
CBParentFormatClick(TObject) | Represents method CBParentFormatClick(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
EDateFormatChange(TObject) | Represents method EDateFormatChange(TObject).
EDateTimeFormatChange(TObject) | Represents method EDateTimeFormatChange(TObject).
Edit(TComponent,TColumn) | Represents method Edit(TComponent,TColumn).
EFloatFormatChange(TObject) | Represents method EFloatFormatChange(TObject).
Embedd(TComponent,TWinControl,TColumn) | Overloaded. Represents method Embedd(TComponent,TWinControl,TColumn).
ETimeFormatChange(TObject) | Represents method ETimeFormatChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBSourceClick(TObject) | Represents method LBSourceClick(TObject).
MemoHeaderChange(TObject) | Represents method MemoHeaderChange(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshColumn(TColumn) | Represents method RefreshColumn(TColumn).
Top


TColumnEditor.CBAutoAlignClick(TObject) Method

Summary

Represents method CBAutoAlignClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBAutoAlignClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBExpandedClick(TObject) Method

Summary

Represents method CBExpandedClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBExpandedClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBHeaderParentClick(TObject) Method

Summary

Represents method CBHeaderParentClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBHeaderParentClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBHeaderVisibleClick(TObject) Method

Summary

Represents method CBHeaderVisibleClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBHeaderVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBLockedChange(TObject) Method

Summary

Represents method CBLockedChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBLockedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBParentFormatClick(TObject) Method

Summary

Represents method CBParentFormatClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBParentFormatClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBReadOnlyClick(TObject) Method

Summary

Represents method CBReadOnlyClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBReadOnlyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EDateFormatChange(TObject) Method

Summary

Represents method EDateFormatChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure EDateFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EDateTimeFormatChange(TObject) Method

Summary

Represents method EDateTimeFormatChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure EDateTimeFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Edit(TComponent,TColumn) Method

Summary

Represents method Edit(TComponent,TColumn).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AColumn:TColumn):Boolean; static;

Parameters

AOwner
Type: TComponent

AColumn
Type: TColumn

Return Value

Type: Boolean

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EFloatFormatChange(TObject) Method

Summary

Represents method EFloatFormatChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure EFloatFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Embedd(TComponent,TWinControl,TColumn) Method

Summary

Represents method Embedd(TComponent,TWinControl,TColumn).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AColumn:TColumn):TColumnEditor; overload; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AColumn
Type: TColumn

Return Value

Type: TColumnEditor

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.ETimeFormatChange(TObject) Method

Summary

Represents method ETimeFormatChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure ETimeFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.LBSourceClick(TObject) Method

Summary

Represents method LBSourceClick(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure LBSourceClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.MemoHeaderChange(TObject) Method

Summary

Represents method MemoHeaderChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure MemoHeaderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.PageFormatChange(TObject) Method

Summary

Represents method PageFormatChange(TObject).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 procedure PageFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.RefreshColumn(TColumn) Method

Summary

Represents method RefreshColumn(TColumn).

Namespace: VCLTee.Editor.Column
Syntax
Delphi
public
 procedure RefreshColumn(const AColumn:TColumn);

Parameters

AColumn
Type: TColumn

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor Fields

Fields
Name | Description
CBAutoAlign | Represents field CBAutoAlign.
CBExpanded | Represents field CBExpanded.
CBHeaderParent | Represents field CBHeaderParent.
CBHeaderVisible | Represents field CBHeaderVisible.
CBLocked | Represents field CBLocked.
CBParentFormat | Represents field CBParentFormat.
CBReadOnly | Represents field CBReadOnly.
CBVisible | Represents field CBVisible.
EDateFormat | Represents field EDateFormat.
EDateTimeFormat | Represents field EDateTimeFormat.
EFloatFormat | Represents field EFloatFormat.
ETimeFormat | Represents field ETimeFormat.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
LBSource | Represents field LBSource.
MemoHeader | Represents field MemoHeader.
PageData | Represents field PageData.
PageFormat | Represents field PageFormat.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
TabAlign | Represents field TabAlign.
TabData | Represents field TabData.
TabFormat | Represents field TabFormat.
TabFormatting | Represents field TabFormatting.
TabGeneral | Represents field TabGeneral.
TabHeader | Represents field TabHeader.
TabMargins | Represents field TabMargins.
TabSource | Represents field TabSource.
TabWidth | Represents field TabWidth.
Top


TColumnEditor.CBAutoAlign Field

Summary

Represents field CBAutoAlign.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBAutoAlign: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBExpanded Field

Summary

Represents field CBExpanded.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBExpanded: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBHeaderParent Field

Summary

Represents field CBHeaderParent.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBHeaderParent: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBHeaderVisible Field

Summary

Represents field CBHeaderVisible.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBHeaderVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBLocked Field

Summary

Represents field CBLocked.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBLocked: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBParentFormat Field

Summary

Represents field CBParentFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBParentFormat: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBReadOnly Field

Summary

Represents field CBReadOnly.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBReadOnly: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EDateFormat Field

Summary

Represents field EDateFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 EDateFormat: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EDateTimeFormat Field

Summary

Represents field EDateTimeFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 EDateTimeFormat: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.EFloatFormat Field

Summary

Represents field EFloatFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 EFloatFormat: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.ETimeFormat Field

Summary

Represents field ETimeFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 ETimeFormat: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.LBSource Field

Summary

Represents field LBSource.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 LBSource: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.MemoHeader Field

Summary

Represents field MemoHeader.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 MemoHeader: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.PageData Field

Summary

Represents field PageData.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 PageData: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.PageFormat Field

Summary

Represents field PageFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 PageFormat: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.Panel6 Field

Summary

Represents field Panel6.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 Panel6: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabAlign Field

Summary

Represents field TabAlign.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabAlign: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabFormatting Field

Summary

Represents field TabFormatting.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabFormatting: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabGeneral Field

Summary

Represents field TabGeneral.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabGeneral: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabHeader Field

Summary

Represents field TabHeader.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabHeader: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabMargins Field

Summary

Represents field TabMargins.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabMargins: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabSource Field

Summary

Represents field TabSource.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabSource: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnEditor.TabWidth Field

Summary

Represents field TabWidth.

Namespace: VCLTee.Editor.Column
Syntax
Delphi
published
 TabWidth: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnEditor
  • VCLTee.Editor.Column


TColumnsAccess Class

Summary

Represents type TColumnsAccess.

Namespace: VCLTee.Editor.Column
Inheritance Hierarchy
TColumns
VCLTee.Editor.Column.TColumnsAccess
Syntax
Delphi
type
 TColumnsAccess=class(TColumns);
See Also

Reference

  • VCLTee.Editor.Column


VCLTee.Editor.ColumnBand Namespace

Summary

Represents namespace VCLTee.Editor.ColumnBand.

Classes
Name | Description
TColumnBandEditor | Represents type TColumnBandEditor.
Top


VCLTee.Editor.ColumnBand Classes

Classes
Name | Description
TColumnBandEditor | Represents type TColumnBandEditor.
Top


TColumnBandEditor Class

Summary

Represents type TColumnBandEditor.

Namespace: VCLTee.Editor.ColumnBand
Inheritance Hierarchy
TForm
VCLTee.Editor.ColumnBand.TColumnBandEditor
Syntax
Delphi
type
 TColumnBandEditor = class(TForm)
 end;

The TColumnBandEditor type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBAllowDragClick(TObject) | Represents method CBAllowDragClick(TObject).
CBAllowResizeClick(TObject) | Represents method CBAllowResizeClick(TObject).
CBHoverVisibleClick(TObject) | Represents method CBHoverVisibleClick(TObject).
Edit(TComponent,TCustomColumnBand) | Represents method Edit(TComponent,TCustomColumnBand).
Embedd(TComponent,TWinControl,TCustomColumnBand) | Overloaded. Represents method Embedd(TComponent,TWinControl,TCustomColumnBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageBandChange(TObject) | Represents method PageBandChange(TObject).
RefreshBand(TCustomColumnBand) | Represents method RefreshBand(TCustomColumnBand).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBAllowDrag | Represents field CBAllowDrag.
CBAllowResize | Represents field CBAllowResize.
CBHoverParentFont | Represents field CBHoverParentFont.
CBHoverVisible | Represents field CBHoverVisible.
GroupBox1 | Represents field GroupBox1.
PageBand | Represents field PageBand.
Panel1 | Represents field Panel1.
TabFormat | Represents field TabFormat.
TabHeight | Represents field TabHeight.
TabHover | Represents field TabHover.
TabLines | Represents field TabLines.
TabMouse | Represents field TabMouse.
Top
See Also

Reference

  • VCLTee.Editor.ColumnBand


TColumnBandEditor Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBAllowDragClick(TObject) | Represents method CBAllowDragClick(TObject).
CBAllowResizeClick(TObject) | Represents method CBAllowResizeClick(TObject).
CBHoverVisibleClick(TObject) | Represents method CBHoverVisibleClick(TObject).
Edit(TComponent,TCustomColumnBand) | Represents method Edit(TComponent,TCustomColumnBand).
Embedd(TComponent,TWinControl,TCustomColumnBand) | Overloaded. Represents method Embedd(TComponent,TWinControl,TCustomColumnBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageBandChange(TObject) | Represents method PageBandChange(TObject).
RefreshBand(TCustomColumnBand) | Represents method RefreshBand(TCustomColumnBand).
Top


TColumnBandEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.Button2Click(TObject) Method

Summary

Represents method Button2Click(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure Button2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBAllowDragClick(TObject) Method

Summary

Represents method CBAllowDragClick(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure CBAllowDragClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBAllowResizeClick(TObject) Method

Summary

Represents method CBAllowResizeClick(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure CBAllowResizeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBHoverVisibleClick(TObject) Method

Summary

Represents method CBHoverVisibleClick(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure CBHoverVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.Edit(TComponent,TCustomColumnBand) Method

Summary

Represents method Edit(TComponent,TCustomColumnBand).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABand:TCustomColumnBand):Boolean; static;

Parameters

AOwner
Type: TComponent

ABand
Type: TCustomColumnBand

Return Value

Type: Boolean

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.Embedd(TComponent,TWinControl,TCustomColumnBand) Method

Summary

Represents method Embedd(TComponent,TWinControl,TCustomColumnBand).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ABand:TCustomColumnBand):TColumnBandEditor; overload; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ABand
Type: TCustomColumnBand

Return Value

Type: TColumnBandEditor

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.PageBandChange(TObject) Method

Summary

Represents method PageBandChange(TObject).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 procedure PageBandChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.RefreshBand(TCustomColumnBand) Method

Summary

Represents method RefreshBand(TCustomColumnBand).

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
public
 procedure RefreshBand(const ABand:TCustomColumnBand);

Parameters

ABand
Type: TCustomColumnBand

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor Fields

Fields
Name | Description
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBAllowDrag | Represents field CBAllowDrag.
CBAllowResize | Represents field CBAllowResize.
CBHoverParentFont | Represents field CBHoverParentFont.
CBHoverVisible | Represents field CBHoverVisible.
GroupBox1 | Represents field GroupBox1.
PageBand | Represents field PageBand.
Panel1 | Represents field Panel1.
TabFormat | Represents field TabFormat.
TabHeight | Represents field TabHeight.
TabHover | Represents field TabHover.
TabLines | Represents field TabLines.
TabMouse | Represents field TabMouse.
Top


TColumnBandEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBAllowDrag Field

Summary

Represents field CBAllowDrag.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 CBAllowDrag: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBAllowResize Field

Summary

Represents field CBAllowResize.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 CBAllowResize: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBHoverParentFont Field

Summary

Represents field CBHoverParentFont.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 CBHoverParentFont: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.CBHoverVisible Field

Summary

Represents field CBHoverVisible.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 CBHoverVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.PageBand Field

Summary

Represents field PageBand.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 PageBand: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.TabHeight Field

Summary

Represents field TabHeight.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 TabHeight: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.TabHover Field

Summary

Represents field TabHover.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 TabHover: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.TabLines Field

Summary

Represents field TabLines.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 TabLines: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


TColumnBandEditor.TabMouse Field

Summary

Represents field TabMouse.

Namespace: VCLTee.Editor.ColumnBand
Syntax
Delphi
published
 TabMouse: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnBandEditor
  • VCLTee.Editor.ColumnBand


VCLTee.Editor.Coordinate Namespace

Summary

Represents namespace VCLTee.Editor.Coordinate.

Classes
Name | Description
TCoordinateEditor | Represents type TCoordinateEditor.
Top


VCLTee.Editor.Coordinate Classes

Classes
Name | Description
TCoordinateEditor | Represents type TCoordinateEditor.
Top


TCoordinateEditor Class

Summary

Represents type TCoordinateEditor.

Namespace: VCLTee.Editor.Coordinate
Inheritance Hierarchy
TForm
VCLTee.Editor.Coordinate.TCoordinateEditor
Syntax
Delphi
type
 TCoordinateEditor = class(TForm)
 end;

The TCoordinateEditor type exposes the following members.

Methods
Show:
Name | Description
CBAutoClick(TObject) | Represents method CBAutoClick(TObject).
Embedd(TComponent,TWinControl,TCoordinate) | Overloaded. Represents method Embedd(TComponent,TWinControl,TCoordinate).
EValueChange(TObject) | Represents method EValueChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
RefreshCoordinate(TCoordinate) | Represents method RefreshCoordinate(TCoordinate).
RGUnitsClick(TObject) | Represents method RGUnitsClick(TObject).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBSubClick(TObject) | Represents method SBSubClick(TObject).
Top
Fields
Show:
Name | Description
CBAuto | Represents field CBAuto.
EValue | Represents field EValue.
Label5 | Represents field Label5.
RGUnits | Represents field RGUnits.
SBAdd | Represents field SBAdd.
SBSub | Represents field SBSub.
Top
See Also

Reference

  • VCLTee.Editor.Coordinate


TCoordinateEditor Methods

Methods
Name | Description
CBAutoClick(TObject) | Represents method CBAutoClick(TObject).
Embedd(TComponent,TWinControl,TCoordinate) | Overloaded. Represents method Embedd(TComponent,TWinControl,TCoordinate).
EValueChange(TObject) | Represents method EValueChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
RefreshCoordinate(TCoordinate) | Represents method RefreshCoordinate(TCoordinate).
RGUnitsClick(TObject) | Represents method RGUnitsClick(TObject).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBSubClick(TObject) | Represents method SBSubClick(TObject).
Top


TCoordinateEditor.CBAutoClick(TObject) Method

Summary

Represents method CBAutoClick(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure CBAutoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.Embedd(TComponent,TWinControl,TCoordinate) Method

Summary

Represents method Embedd(TComponent,TWinControl,TCoordinate).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ACoordinate:TCoordinate):TCoordinateEditor; overload; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ACoordinate
Type: TCoordinate

Return Value

Type: TCoordinateEditor

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.EValueChange(TObject) Method

Summary

Represents method EValueChange(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure EValueChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.RefreshCoordinate(TCoordinate) Method

Summary

Represents method RefreshCoordinate(TCoordinate).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
public
 procedure RefreshCoordinate(const ACoordinate:TCoordinate);

Parameters

ACoordinate
Type: TCoordinate

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.RGUnitsClick(TObject) Method

Summary

Represents method RGUnitsClick(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure RGUnitsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.SBAddClick(TObject) Method

Summary

Represents method SBAddClick(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure SBAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.SBSubClick(TObject) Method

Summary

Represents method SBSubClick(TObject).

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 procedure SBSubClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor Fields

Fields
Name | Description
CBAuto | Represents field CBAuto.
EValue | Represents field EValue.
Label5 | Represents field Label5.
RGUnits | Represents field RGUnits.
SBAdd | Represents field SBAdd.
SBSub | Represents field SBSub.
Top


TCoordinateEditor.CBAuto Field

Summary

Represents field CBAuto.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 CBAuto: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.EValue Field

Summary

Represents field EValue.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 EValue: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.RGUnits Field

Summary

Represents field RGUnits.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 RGUnits: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.SBAdd Field

Summary

Represents field SBAdd.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 SBAdd: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


TCoordinateEditor.SBSub Field

Summary

Represents field SBSub.

Namespace: VCLTee.Editor.Coordinate
Syntax
Delphi
published
 SBSub: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TCoordinateEditor
  • VCLTee.Editor.Coordinate


VCLTee.Editor.Font Namespace

Summary

Represents namespace VCLTee.Editor.Font.

Classes
Name | Description
TFontEditor | Represents type TFontEditor.
Top


VCLTee.Editor.Font Classes

Classes
Name | Description
TFontEditor | Represents type TFontEditor.
Top


TFontEditor Class

Summary

Represents type TFontEditor.

Namespace: VCLTee.Editor.Font
Inheritance Hierarchy
TForm
VCLTee.Editor.Font.TFontEditor
Syntax
Delphi
type
 TFontEditor = class(TForm)
 end;

The TFontEditor type exposes the following members.

Methods
Show:
Name | Description
CBBoldClick(TObject) | Represents method CBBoldClick(TObject).
CBItalicClick(TObject) | Represents method CBItalicClick(TObject).
CBStrikeOutClick(TObject) | Represents method CBStrikeOutClick(TObject).
CBUnderlineClick(TObject) | Represents method CBUnderlineClick(TObject).
Edit(TComponent,TFont) | Represents method Edit(TComponent,TFont).
Embedd(TComponent,TWinControl,TFont) | Represents method Embedd(TComponent,TWinControl,TFont).
LBNameClick(TObject) | Represents method LBNameClick(TObject).
PageFontChange(TObject) | Represents method PageFontChange(TObject).
RefreshFont(TFont) | Represents method RefreshFont(TFont).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top
Fields
Show:
Name | Description
CBBold | Represents field CBBold.
CBItalic | Represents field CBItalic.
CBStrikeOut | Represents field CBStrikeOut.
CBUnderline | Represents field CBUnderline.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LBName | Represents field LBName.
LSize | Represents field LSize.
PageFont | Represents field PageFont.
TabFill | Represents field TabFill.
TabOptions | Represents field TabOptions.
TBSize | Represents field TBSize.
Top
See Also

Reference

  • VCLTee.Editor.Font


TFontEditor Methods

Methods
Name | Description
CBBoldClick(TObject) | Represents method CBBoldClick(TObject).
CBItalicClick(TObject) | Represents method CBItalicClick(TObject).
CBStrikeOutClick(TObject) | Represents method CBStrikeOutClick(TObject).
CBUnderlineClick(TObject) | Represents method CBUnderlineClick(TObject).
Edit(TComponent,TFont) | Represents method Edit(TComponent,TFont).
Embedd(TComponent,TWinControl,TFont) | Represents method Embedd(TComponent,TWinControl,TFont).
LBNameClick(TObject) | Represents method LBNameClick(TObject).
PageFontChange(TObject) | Represents method PageFontChange(TObject).
RefreshFont(TFont) | Represents method RefreshFont(TFont).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top


TFontEditor.CBBoldClick(TObject) Method

Summary

Represents method CBBoldClick(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure CBBoldClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBItalicClick(TObject) Method

Summary

Represents method CBItalicClick(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure CBItalicClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBStrikeOutClick(TObject) Method

Summary

Represents method CBStrikeOutClick(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure CBStrikeOutClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBUnderlineClick(TObject) Method

Summary

Represents method CBUnderlineClick(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure CBUnderlineClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.Edit(TComponent,TFont) Method

Summary

Represents method Edit(TComponent,TFont).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AFont:TFont):Boolean; static;

Parameters

AOwner
Type: TComponent

AFont
Type: TFont

Return Value

Type: Boolean

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.Embedd(TComponent,TWinControl,TFont) Method

Summary

Represents method Embedd(TComponent,TWinControl,TFont).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AFont:TFont):TFontEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AFont
Type: TFont

Return Value

Type: TFontEditor

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.LBNameClick(TObject) Method

Summary

Represents method LBNameClick(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure LBNameClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.PageFontChange(TObject) Method

Summary

Represents method PageFontChange(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure PageFontChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.RefreshFont(TFont) Method

Summary

Represents method RefreshFont(TFont).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
public
 procedure RefreshFont(const AFont:TFont);

Parameters

AFont
Type: TFont

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.TBSizeChange(TObject) Method

Summary

Represents method TBSizeChange(TObject).

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 procedure TBSizeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor Fields

Fields
Name | Description
CBBold | Represents field CBBold.
CBItalic | Represents field CBItalic.
CBStrikeOut | Represents field CBStrikeOut.
CBUnderline | Represents field CBUnderline.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LBName | Represents field LBName.
LSize | Represents field LSize.
PageFont | Represents field PageFont.
TabFill | Represents field TabFill.
TabOptions | Represents field TabOptions.
TBSize | Represents field TBSize.
Top


TFontEditor.CBBold Field

Summary

Represents field CBBold.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 CBBold: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBItalic Field

Summary

Represents field CBItalic.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 CBItalic: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBStrikeOut Field

Summary

Represents field CBStrikeOut.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 CBStrikeOut: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.CBUnderline Field

Summary

Represents field CBUnderline.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 CBUnderline: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.LBName Field

Summary

Represents field LBName.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 LBName: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.LSize Field

Summary

Represents field LSize.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 LSize: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.PageFont Field

Summary

Represents field PageFont.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 PageFont: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.TabFill Field

Summary

Represents field TabFill.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 TabFill: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


TFontEditor.TBSize Field

Summary

Represents field TBSize.

Namespace: VCLTee.Editor.Font
Syntax
Delphi
published
 TBSize: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TFontEditor
  • VCLTee.Editor.Font


VCLTee.Editor.Format Namespace

Summary

Represents namespace VCLTee.Editor.Format.

Classes
Name | Description
TTeeFormatEditor | Represents type TTeeFormatEditor.
Top


VCLTee.Editor.Format Classes

Classes
Name | Description
TTeeFormatEditor | Represents type TTeeFormatEditor.
Top


TTeeFormatEditor Class

Summary

Represents type TTeeFormatEditor.

Namespace: VCLTee.Editor.Format
Inheritance Hierarchy
TForm
VCLTee.Editor.Format.TTeeFormatEditor
Syntax
Delphi
type
 TTeeFormatEditor = class(TForm)
 end;

The TTeeFormatEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TFormat) | Represents method Edit(TComponent,TFormat).
Embedd(TComponent,TWinControl,TFormat) | Represents method Embedd(TComponent,TWinControl,TFormat).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshFormat(TFormat) | Represents method RefreshFormat(TFormat).
Top
Fields
Show:
Name | Description
PageFormat | Represents field PageFormat.
TabBrush | Represents field TabBrush.
TabStroke | Represents field TabStroke.
Top
See Also

Reference

  • VCLTee.Editor.Format


TTeeFormatEditor Methods

Methods
Name | Description
Edit(TComponent,TFormat) | Represents method Edit(TComponent,TFormat).
Embedd(TComponent,TWinControl,TFormat) | Represents method Embedd(TComponent,TWinControl,TFormat).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshFormat(TFormat) | Represents method RefreshFormat(TFormat).
Top


TTeeFormatEditor.Edit(TComponent,TFormat) Method

Summary

Represents method Edit(TComponent,TFormat).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AFormat:TFormat):Boolean; static;

Parameters

AOwner
Type: TComponent

AFormat
Type: TFormat

Return Value

Type: Boolean

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.Embedd(TComponent,TWinControl,TFormat) Method

Summary

Represents method Embedd(TComponent,TWinControl,TFormat).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AFormat:TFormat):TTeeFormatEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AFormat
Type: TFormat

Return Value

Type: TTeeFormatEditor

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.PageFormatChange(TObject) Method

Summary

Represents method PageFormatChange(TObject).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 procedure PageFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.RefreshFormat(TFormat) Method

Summary

Represents method RefreshFormat(TFormat).

Namespace: VCLTee.Editor.Format
Syntax
Delphi
public
 procedure RefreshFormat(const AFormat:TFormat);

Parameters

AFormat
Type: TFormat

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor Fields

Fields
Name | Description
PageFormat | Represents field PageFormat.
TabBrush | Represents field TabBrush.
TabStroke | Represents field TabStroke.
Top


TTeeFormatEditor.PageFormat Field

Summary

Represents field PageFormat.

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 PageFormat: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.TabBrush Field

Summary

Represents field TabBrush.

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 TabBrush: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


TTeeFormatEditor.TabStroke Field

Summary

Represents field TabStroke.

Namespace: VCLTee.Editor.Format
Syntax
Delphi
published
 TabStroke: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeFormatEditor
  • VCLTee.Editor.Format


VCLTee.Editor.Format.Text Namespace

Summary

Represents namespace VCLTee.Editor.Format.Text.

Classes
Name | Description
TTextFormatEditor | Represents type TTextFormatEditor.
Top


VCLTee.Editor.Format.Text Classes

Classes
Name | Description
TTextFormatEditor | Represents type TTextFormatEditor.
Top


TTextFormatEditor Class

Summary

Represents type TTextFormatEditor.

Namespace: VCLTee.Editor.Format.Text
Inheritance Hierarchy
TForm
VCLTee.Editor.Format.Text.TTextFormatEditor
Syntax
Delphi
type
 TTextFormatEditor = class(TForm)
 end;

The TTextFormatEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TTextFormat) | Represents method Edit(TComponent,TTextFormat).
Embedd(TComponent,TWinControl,TTextFormat) | Represents method Embedd(TComponent,TWinControl,TTextFormat).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshFormat(TTextFormat) | Represents method RefreshFormat(TTextFormat).
Top
Fields
Show:
Name | Description
PageFormat | Represents field PageFormat.
TabBrush | Represents field TabBrush.
TabFont | Represents field TabFont.
TabStroke | Represents field TabStroke.
Top
See Also

Reference

  • VCLTee.Editor.Format.Text


TTextFormatEditor Methods

Methods
Name | Description
Edit(TComponent,TTextFormat) | Represents method Edit(TComponent,TTextFormat).
Embedd(TComponent,TWinControl,TTextFormat) | Represents method Embedd(TComponent,TWinControl,TTextFormat).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
RefreshFormat(TTextFormat) | Represents method RefreshFormat(TTextFormat).
Top


TTextFormatEditor.Edit(TComponent,TTextFormat) Method

Summary

Represents method Edit(TComponent,TTextFormat).

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AFormat:TTextFormat):Boolean; static;

Parameters

AOwner
Type: TComponent

AFormat
Type: TTextFormat

Return Value

Type: Boolean

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.Embedd(TComponent,TWinControl,TTextFormat) Method

Summary

Represents method Embedd(TComponent,TWinControl,TTextFormat).

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AFormat:TTextFormat):TTextFormatEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AFormat
Type: TTextFormat

Return Value

Type: TTextFormatEditor

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.PageFormatChange(TObject) Method

Summary

Represents method PageFormatChange(TObject).

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 procedure PageFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.RefreshFormat(TTextFormat) Method

Summary

Represents method RefreshFormat(TTextFormat).

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
public
 procedure RefreshFormat(const AFormat:TTextFormat);

Parameters

AFormat
Type: TTextFormat

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor Fields

Fields
Name | Description
PageFormat | Represents field PageFormat.
TabBrush | Represents field TabBrush.
TabFont | Represents field TabFont.
TabStroke | Represents field TabStroke.
Top


TTextFormatEditor.PageFormat Field

Summary

Represents field PageFormat.

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 PageFormat: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.TabBrush Field

Summary

Represents field TabBrush.

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 TabBrush: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.TabFont Field

Summary

Represents field TabFont.

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 TabFont: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


TTextFormatEditor.TabStroke Field

Summary

Represents field TabStroke.

Namespace: VCLTee.Editor.Format.Text
Syntax
Delphi
published
 TabStroke: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextFormatEditor
  • VCLTee.Editor.Format.Text


VCLTee.Editor.Gradient Namespace

Summary

Represents namespace VCLTee.Editor.Gradient.

Classes
Name | Description
TGradientEditor | Represents type TGradientEditor.
Top


VCLTee.Editor.Gradient Classes

Classes
Name | Description
TGradientEditor | Represents type TGradientEditor.
Top


TGradientEditor Class

Summary

Represents type TGradientEditor.

Namespace: VCLTee.Editor.Gradient
Inheritance Hierarchy
TForm
VCLTee.Editor.Gradient.TGradientEditor
Syntax
Delphi
type
 TGradientEditor = class(TForm)
 end;

The TGradientEditor type exposes the following members.

Methods
Show:
Name | Description
CBColor0Change(TObject) | Represents method CBColor0Change(TObject).
CBColor1Change(TObject) | Represents method CBColor1Change(TObject).
CBInvertedClick(TObject) | Represents method CBInvertedClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TGradient) | Represents method Edit(TComponent,TGradient).
Embedd(TComponent,TWinControl,TGradient) | Represents method Embedd(TComponent,TWinControl,TGradient).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshGradient(TGradient) | Represents method RefreshGradient(TGradient).
RGDirectionClick(TObject) | Represents method RGDirectionClick(TObject).
TBOpacity0Change(TObject) | Represents method TBOpacity0Change(TObject).
TBOpacity1Change(TObject) | Represents method TBOpacity1Change(TObject).
Top
Fields
Show:
Name | Description
CBColor0 | Represents field CBColor0.
CBColor1 | Represents field CBColor1.
CBInverted | Represents field CBInverted.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LOpacity0 | Represents field LOpacity0.
LOpacity1 | Represents field LOpacity1.
PageGradient | Represents field PageGradient.
RGDirection | Represents field RGDirection.
TabColors | Represents field TabColors.
TabDirection | Represents field TabDirection.
TBOpacity0 | Represents field TBOpacity0.
TBOpacity1 | Represents field TBOpacity1.
Top
See Also

Reference

  • VCLTee.Editor.Gradient


TGradientEditor Methods

Methods
Name | Description
CBColor0Change(TObject) | Represents method CBColor0Change(TObject).
CBColor1Change(TObject) | Represents method CBColor1Change(TObject).
CBInvertedClick(TObject) | Represents method CBInvertedClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TGradient) | Represents method Edit(TComponent,TGradient).
Embedd(TComponent,TWinControl,TGradient) | Represents method Embedd(TComponent,TWinControl,TGradient).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshGradient(TGradient) | Represents method RefreshGradient(TGradient).
RGDirectionClick(TObject) | Represents method RGDirectionClick(TObject).
TBOpacity0Change(TObject) | Represents method TBOpacity0Change(TObject).
TBOpacity1Change(TObject) | Represents method TBOpacity1Change(TObject).
Top


TGradientEditor.CBColor0Change(TObject) Method

Summary

Represents method CBColor0Change(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure CBColor0Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBColor1Change(TObject) Method

Summary

Represents method CBColor1Change(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure CBColor1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBInvertedClick(TObject) Method

Summary

Represents method CBInvertedClick(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure CBInvertedClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.Edit(TComponent,TGradient) Method

Summary

Represents method Edit(TComponent,TGradient).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AGradient:TGradient):Boolean; static;

Parameters

AOwner
Type: TComponent

AGradient
Type: TGradient

Return Value

Type: Boolean

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.Embedd(TComponent,TWinControl,TGradient) Method

Summary

Represents method Embedd(TComponent,TWinControl,TGradient).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AGradient:TGradient):TGradientEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AGradient
Type: TGradient

Return Value

Type: TGradientEditor

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.RefreshGradient(TGradient) Method

Summary

Represents method RefreshGradient(TGradient).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
public
 procedure RefreshGradient(const AGradient:TGradient);

Parameters

AGradient
Type: TGradient

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.RGDirectionClick(TObject) Method

Summary

Represents method RGDirectionClick(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure RGDirectionClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TBOpacity0Change(TObject) Method

Summary

Represents method TBOpacity0Change(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure TBOpacity0Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TBOpacity1Change(TObject) Method

Summary

Represents method TBOpacity1Change(TObject).

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 procedure TBOpacity1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor Fields

Fields
Name | Description
CBColor0 | Represents field CBColor0.
CBColor1 | Represents field CBColor1.
CBInverted | Represents field CBInverted.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LOpacity0 | Represents field LOpacity0.
LOpacity1 | Represents field LOpacity1.
PageGradient | Represents field PageGradient.
RGDirection | Represents field RGDirection.
TabColors | Represents field TabColors.
TabDirection | Represents field TabDirection.
TBOpacity0 | Represents field TBOpacity0.
TBOpacity1 | Represents field TBOpacity1.
Top


TGradientEditor.CBColor0 Field

Summary

Represents field CBColor0.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 CBColor0: TColorBox;

Field Value

Type: TColorBox

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBColor1 Field

Summary

Represents field CBColor1.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 CBColor1: TColorBox;

Field Value

Type: TColorBox

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBInverted Field

Summary

Represents field CBInverted.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 CBInverted: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.LOpacity0 Field

Summary

Represents field LOpacity0.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 LOpacity0: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.LOpacity1 Field

Summary

Represents field LOpacity1.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 LOpacity1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.PageGradient Field

Summary

Represents field PageGradient.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 PageGradient: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.RGDirection Field

Summary

Represents field RGDirection.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 RGDirection: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TabColors Field

Summary

Represents field TabColors.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 TabColors: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TabDirection Field

Summary

Represents field TabDirection.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 TabDirection: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TBOpacity0 Field

Summary

Represents field TBOpacity0.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 TBOpacity0: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


TGradientEditor.TBOpacity1 Field

Summary

Represents field TBOpacity1.

Namespace: VCLTee.Editor.Gradient
Syntax
Delphi
published
 TBOpacity1: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TGradientEditor
  • VCLTee.Editor.Gradient


VCLTee.Editor.Grid Namespace

Summary

Represents namespace VCLTee.Editor.Grid.

Classes
Name | Description
TGridBandsEditorAccess | Represents type TGridBandsEditorAccess.
TTeeGridEditor | Represents type TTeeGridEditor.
Top
Constants
Name | Description
TeeMsg_GridEditing | Represents constant TeeMsg_GridEditing.
Top
Routines
Name | Description
InternalEditGrid(TCustomTeeGrid) | Represents method InternalEditGrid(TCustomTeeGrid).
Top


VCLTee.Editor.Grid Classes

Classes
Name | Description
TGridBandsEditorAccess | Represents type TGridBandsEditorAccess.
TTeeGridEditor | Represents type TTeeGridEditor.
Top


TGridBandsEditorAccess Class

Summary

Represents type TGridBandsEditorAccess.

Namespace: VCLTee.Editor.Grid
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Bands.TGridBandsEditor
VCLTee.Editor.Grid.TGridBandsEditorAccess
Syntax
Delphi
type
 TGridBandsEditorAccess=class(TGridBandsEditor);

The TGridBandsEditorAccess type exposes the following members.

Methods
Show:
Name | Description
CBFloatingClick(TObject) | Represents method CBFloatingClick(TObject). (Inherited from TGridBandsEditor.)
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject). (Inherited from TGridBandsEditor.)
ColumnsText1Click(TObject) | Represents method ColumnsText1Click(TObject). (Inherited from TGridBandsEditor.)
Edit(TComponent,TGridBands) | Represents method Edit(TComponent,TGridBands). (Inherited from TGridBandsEditor.)
Embedd(TComponent,TWinControl,TGridBands) | Represents method Embedd(TComponent,TWinControl,TGridBands). (Inherited from TGridBandsEditor.)
ext1Click(TObject) | Represents method ext1Click(TObject). (Inherited from TGridBandsEditor.)
Header1Click(TObject) | Represents method Header1Click(TObject). (Inherited from TGridBandsEditor.)
LBBandsClick(TObject) | Represents method LBBandsClick(TObject). (Inherited from TGridBandsEditor.)
LBBandsClickCheck(TObject) | Represents method LBBandsClickCheck(TObject). (Inherited from TGridBandsEditor.)
otals1Click(TObject) | Represents method otals1Click(TObject). (Inherited from TGridBandsEditor.)
otalsHeader1Click(TObject) | Represents method otalsHeader1Click(TObject). (Inherited from TGridBandsEditor.)
RefreshBands(TGridBands) | Represents method RefreshBands(TGridBands). (Inherited from TGridBandsEditor.)
RefreshUpDown | Represents method RefreshUpDown. (Inherited from TGridBandsEditor.)
SBAddClick(TObject) | Represents method SBAddClick(TObject). (Inherited from TGridBandsEditor.)
SBDownClick(TObject) | Represents method SBDownClick(TObject). (Inherited from TGridBandsEditor.)
SBRemoveClick(TObject) | Represents method SBRemoveClick(TObject). (Inherited from TGridBandsEditor.)
SBUpClick(TObject) | Represents method SBUpClick(TObject). (Inherited from TGridBandsEditor.)
Top
Fields
Show:
Name | Description
CBFloating | Represents field CBFloating. (Inherited from TGridBandsEditor.)
CBVisible | Represents field CBVisible. (Inherited from TGridBandsEditor.)
ColumnsText1 | Represents field ColumnsText1. (Inherited from TGridBandsEditor.)
ext1 | Represents field ext1. (Inherited from TGridBandsEditor.)
Header | Represents field Header. (Inherited from TGridBandsEditor.)
Header1 | Represents field Header1. (Inherited from TGridBandsEditor.)
LBBands | Represents field LBBands. (Inherited from TGridBandsEditor.)
otals1 | Represents field otals1. (Inherited from TGridBandsEditor.)
otalsHeader1 | Represents field otalsHeader1. (Inherited from TGridBandsEditor.)
PanelMain | Represents field PanelMain. (Inherited from TGridBandsEditor.)
PanelTop | Represents field PanelTop. (Inherited from TGridBandsEditor.)
PopupMenu1 | Represents field PopupMenu1. (Inherited from TGridBandsEditor.)
SBAdd | Represents field SBAdd. (Inherited from TGridBandsEditor.)
SBDown | Represents field SBDown. (Inherited from TGridBandsEditor.)
SBRemove | Represents field SBRemove. (Inherited from TGridBandsEditor.)
SBUp | Represents field SBUp. (Inherited from TGridBandsEditor.)
Top
See Also

Reference

  • VCLTee.Editor.Grid


TTeeGridEditor Class

Summary

Represents type TTeeGridEditor.

Namespace: VCLTee.Editor.Grid
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.TTeeGridEditor
Syntax
Delphi
type
 TTeeGridEditor = class(TForm)
 end;

The TTeeGridEditor type exposes the following members.

Methods
Show:
Name | Description
CBAlternateVisibleClick(TObject) | Represents method CBAlternateVisibleClick(TObject).
CBAutoEditClick(TObject) | Represents method CBAutoEditClick(TObject).
CBDoubleClickClick(TObject) | Represents method CBDoubleClickClick(TObject).
CBEditingAlwaysClick(TObject) | Represents method CBEditingAlwaysClick(TObject).
CBEnterKeyChange(TObject) | Represents method CBEnterKeyChange(TObject).
CBIndicatorVisibleClick(TObject) | Represents method CBIndicatorVisibleClick(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBSelectTextClick(TObject) | Represents method CBSelectTextClick(TObject).
Edit(TComponent,TTeeGrid) | Represents method Edit(TComponent,TTeeGrid).
Embedd(TComponent,TWinControl,TTeeGrid) | Represents method Embedd(TComponent,TWinControl,TTeeGrid).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBThemesClick(TObject) | Represents method LBThemesClick(TObject).
PageBandsChange(TObject) | Represents method PageBandsChange(TObject).
PageCellsChange(TObject) | Represents method PageCellsChange(TObject).
PageGridChange(TObject) | Represents method PageGridChange(TObject).
PageIndicatorChange(TObject) | Represents method PageIndicatorChange(TObject).
PageOptionsChange(TObject) | Represents method PageOptionsChange(TObject).
PageRowsChange(TObject) | Represents method PageRowsChange(TObject).
RefreshGrid(TTeeGrid) | Overloaded. Represents method RefreshGrid(TTeeGrid).
RGPainterClick(TObject) | Represents method RGPainterClick(TObject).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBColumnDownClick(TObject) | Represents method SBColumnDownClick(TObject).
SBColumnUpClick(TObject) | Represents method SBColumnUpClick(TObject).
SBDeleteColumnClick(TObject) | Represents method SBDeleteColumnClick(TObject).
TBHorizSpacingChange(TObject) | Represents method TBHorizSpacingChange(TObject).
TBVertSpacingChange(TObject) | Represents method TBVertSpacingChange(TObject).
TreeColumnsChange(TObject,TTreeNode) | Represents method TreeColumnsChange(TObject,TTreeNode).
TreeColumnsDeletion(TObject,TTreeNode) | Represents method TreeColumnsDeletion(TObject,TTreeNode).
TreeColumnsEdited(TObject,TTreeNode,string) | Represents method TreeColumnsEdited(TObject,TTreeNode,string).
TreeColumnsKeyUp(TObject,Word,TShiftState) | Represents method TreeColumnsKeyUp(TObject,Word,TShiftState).
Top
Fields
Show:
Name | Description
BOk | Represents field BOk.
CBAlternateVisible | Represents field CBAlternateVisible.
CBAutoEdit | Represents field CBAutoEdit.
CBDoubleClick | Represents field CBDoubleClick.
CBEditingAlways | Represents field CBEditingAlways.
CBEnterKey | Represents field CBEnterKey.
CBIndicatorVisible | Represents field CBIndicatorVisible.
CBReadOnly | Represents field CBReadOnly.
CBSelectText | Represents field CBSelectText.
GBText | Represents field GBText.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label6 | Represents field Label6.
LBThemes | Represents field LBThemes.
LHorizSpacing | Represents field LHorizSpacing.
LVertSpacing | Represents field LVertSpacing.
PageBands | Represents field PageBands.
PageCells | Represents field PageCells.
PageGrid | Represents field PageGrid.
PageIndicator | Represents field PageIndicator.
PageOptions | Represents field PageOptions.
PageRows | Represents field PageRows.
Panel1 | Represents field Panel1.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelButtons | Represents field PanelButtons.
PanelEditor | Represents field PanelEditor.
PanelOk | Represents field PanelOk.
RGPainter | Represents field RGPainter.
SBAdd | Represents field SBAdd.
SBColumnDown | Represents field SBColumnDown.
SBColumnUp | Represents field SBColumnUp.
SBDeleteColumn | Represents field SBDeleteColumn.
Splitter1 | Represents field Splitter1.
TabBack | Represents field TabBack.
TabBands | Represents field TabBands.
TabCells | Represents field TabCells.
TabCellsFormat | Represents field TabCellsFormat.
TabCellsHover | Represents field TabCellsHover.
TabColumnLines | Represents field TabColumnLines.
TabColumns | Represents field TabColumns.
TabEditing | Represents field TabEditing.
TabFooter | Represents field TabFooter.
TabHeaders | Represents field TabHeaders.
TabIndicator | Represents field TabIndicator.
TabIndicatorFormat | Represents field TabIndicatorFormat.
TabIndicatorWidth | Represents field TabIndicatorWidth.
TabMargins | Represents field TabMargins.
TabOptions | Represents field TabOptions.
TabRowAlternate | Represents field TabRowAlternate.
TabRowLines | Represents field TabRowLines.
TabRows | Represents field TabRows.
TabRowsBack | Represents field TabRowsBack.
TabRowsHeight | Represents field TabRowsHeight.
TabScrolling | Represents field TabScrolling.
TabSelection | Represents field TabSelection.
TabSubBands | Represents field TabSubBands.
TabTheme | Represents field TabTheme.
TBHorizSpacing | Represents field TBHorizSpacing.
TBVertSpacing | Represents field TBVertSpacing.
TreeColumns | Represents field TreeColumns.
Top
See Also

Reference

  • VCLTee.Editor.Grid


TTeeGridEditor Methods

Methods
Name | Description
CBAlternateVisibleClick(TObject) | Represents method CBAlternateVisibleClick(TObject).
CBAutoEditClick(TObject) | Represents method CBAutoEditClick(TObject).
CBDoubleClickClick(TObject) | Represents method CBDoubleClickClick(TObject).
CBEditingAlwaysClick(TObject) | Represents method CBEditingAlwaysClick(TObject).
CBEnterKeyChange(TObject) | Represents method CBEnterKeyChange(TObject).
CBIndicatorVisibleClick(TObject) | Represents method CBIndicatorVisibleClick(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBSelectTextClick(TObject) | Represents method CBSelectTextClick(TObject).
Edit(TComponent,TTeeGrid) | Represents method Edit(TComponent,TTeeGrid).
Embedd(TComponent,TWinControl,TTeeGrid) | Represents method Embedd(TComponent,TWinControl,TTeeGrid).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBThemesClick(TObject) | Represents method LBThemesClick(TObject).
PageBandsChange(TObject) | Represents method PageBandsChange(TObject).
PageCellsChange(TObject) | Represents method PageCellsChange(TObject).
PageGridChange(TObject) | Represents method PageGridChange(TObject).
PageIndicatorChange(TObject) | Represents method PageIndicatorChange(TObject).
PageOptionsChange(TObject) | Represents method PageOptionsChange(TObject).
PageRowsChange(TObject) | Represents method PageRowsChange(TObject).
RefreshGrid(TTeeGrid) | Overloaded. Represents method RefreshGrid(TTeeGrid).
RGPainterClick(TObject) | Represents method RGPainterClick(TObject).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBColumnDownClick(TObject) | Represents method SBColumnDownClick(TObject).
SBColumnUpClick(TObject) | Represents method SBColumnUpClick(TObject).
SBDeleteColumnClick(TObject) | Represents method SBDeleteColumnClick(TObject).
TBHorizSpacingChange(TObject) | Represents method TBHorizSpacingChange(TObject).
TBVertSpacingChange(TObject) | Represents method TBVertSpacingChange(TObject).
TreeColumnsChange(TObject,TTreeNode) | Represents method TreeColumnsChange(TObject,TTreeNode).
TreeColumnsDeletion(TObject,TTreeNode) | Represents method TreeColumnsDeletion(TObject,TTreeNode).
TreeColumnsEdited(TObject,TTreeNode,string) | Represents method TreeColumnsEdited(TObject,TTreeNode,string).
TreeColumnsKeyUp(TObject,Word,TShiftState) | Represents method TreeColumnsKeyUp(TObject,Word,TShiftState).
Top


TTeeGridEditor.CBAlternateVisibleClick(TObject) Method

Summary

Represents method CBAlternateVisibleClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBAlternateVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBAutoEditClick(TObject) Method

Summary

Represents method CBAutoEditClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBAutoEditClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBDoubleClickClick(TObject) Method

Summary

Represents method CBDoubleClickClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBDoubleClickClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBEditingAlwaysClick(TObject) Method

Summary

Represents method CBEditingAlwaysClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBEditingAlwaysClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBEnterKeyChange(TObject) Method

Summary

Represents method CBEnterKeyChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBEnterKeyChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBIndicatorVisibleClick(TObject) Method

Summary

Represents method CBIndicatorVisibleClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBIndicatorVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBReadOnlyClick(TObject) Method

Summary

Represents method CBReadOnlyClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBReadOnlyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBSelectTextClick(TObject) Method

Summary

Represents method CBSelectTextClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure CBSelectTextClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Edit(TComponent,TTeeGrid) Method

Summary

Represents method Edit(TComponent,TTeeGrid).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AGrid:TTeeGrid):Boolean; static;

Parameters

AOwner
Type: TComponent

AGrid
Type: TTeeGrid

Return Value

Type: Boolean

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Embedd(TComponent,TWinControl,TTeeGrid) Method

Summary

Represents method Embedd(TComponent,TWinControl,TTeeGrid).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AGrid:TTeeGrid):TTeeGridEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AGrid
Type: TTeeGrid

Return Value

Type: TTeeGridEditor

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.LBThemesClick(TObject) Method

Summary

Represents method LBThemesClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure LBThemesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageBandsChange(TObject) Method

Summary

Represents method PageBandsChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageBandsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageCellsChange(TObject) Method

Summary

Represents method PageCellsChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageCellsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageGridChange(TObject) Method

Summary

Represents method PageGridChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageGridChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageIndicatorChange(TObject) Method

Summary

Represents method PageIndicatorChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageIndicatorChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageOptionsChange(TObject) Method

Summary

Represents method PageOptionsChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageOptionsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageRowsChange(TObject) Method

Summary

Represents method PageRowsChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure PageRowsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.RefreshGrid(TTeeGrid) Method

Summary

Represents method RefreshGrid(TTeeGrid).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
public
 procedure RefreshGrid(const AGrid:TTeeGrid); overload;

Parameters

AGrid
Type: TTeeGrid

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.RGPainterClick(TObject) Method

Summary

Represents method RGPainterClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure RGPainterClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBAddClick(TObject) Method

Summary

Represents method SBAddClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure SBAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBColumnDownClick(TObject) Method

Summary

Represents method SBColumnDownClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure SBColumnDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBColumnUpClick(TObject) Method

Summary

Represents method SBColumnUpClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure SBColumnUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBDeleteColumnClick(TObject) Method

Summary

Represents method SBDeleteColumnClick(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure SBDeleteColumnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TBHorizSpacingChange(TObject) Method

Summary

Represents method TBHorizSpacingChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TBHorizSpacingChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TBVertSpacingChange(TObject) Method

Summary

Represents method TBVertSpacingChange(TObject).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TBVertSpacingChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TreeColumnsChange(TObject,TTreeNode) Method

Summary

Represents method TreeColumnsChange(TObject,TTreeNode).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TreeColumnsChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TreeColumnsDeletion(TObject,TTreeNode) Method

Summary

Represents method TreeColumnsDeletion(TObject,TTreeNode).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TreeColumnsDeletion(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TreeColumnsEdited(TObject,TTreeNode,string) Method

Summary

Represents method TreeColumnsEdited(TObject,TTreeNode,string).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TreeColumnsEdited(Sender: TObject; Node: TTreeNode; var S: string);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

S
Type: string

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TreeColumnsKeyUp(TObject,Word,TShiftState) Method

Summary

Represents method TreeColumnsKeyUp(TObject,Word,TShiftState).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 procedure TreeColumnsKeyUp(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor Fields

Fields
Name | Description
BOk | Represents field BOk.
CBAlternateVisible | Represents field CBAlternateVisible.
CBAutoEdit | Represents field CBAutoEdit.
CBDoubleClick | Represents field CBDoubleClick.
CBEditingAlways | Represents field CBEditingAlways.
CBEnterKey | Represents field CBEnterKey.
CBIndicatorVisible | Represents field CBIndicatorVisible.
CBReadOnly | Represents field CBReadOnly.
CBSelectText | Represents field CBSelectText.
GBText | Represents field GBText.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label6 | Represents field Label6.
LBThemes | Represents field LBThemes.
LHorizSpacing | Represents field LHorizSpacing.
LVertSpacing | Represents field LVertSpacing.
PageBands | Represents field PageBands.
PageCells | Represents field PageCells.
PageGrid | Represents field PageGrid.
PageIndicator | Represents field PageIndicator.
PageOptions | Represents field PageOptions.
PageRows | Represents field PageRows.
Panel1 | Represents field Panel1.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelButtons | Represents field PanelButtons.
PanelEditor | Represents field PanelEditor.
PanelOk | Represents field PanelOk.
RGPainter | Represents field RGPainter.
SBAdd | Represents field SBAdd.
SBColumnDown | Represents field SBColumnDown.
SBColumnUp | Represents field SBColumnUp.
SBDeleteColumn | Represents field SBDeleteColumn.
Splitter1 | Represents field Splitter1.
TabBack | Represents field TabBack.
TabBands | Represents field TabBands.
TabCells | Represents field TabCells.
TabCellsFormat | Represents field TabCellsFormat.
TabCellsHover | Represents field TabCellsHover.
TabColumnLines | Represents field TabColumnLines.
TabColumns | Represents field TabColumns.
TabEditing | Represents field TabEditing.
TabFooter | Represents field TabFooter.
TabHeaders | Represents field TabHeaders.
TabIndicator | Represents field TabIndicator.
TabIndicatorFormat | Represents field TabIndicatorFormat.
TabIndicatorWidth | Represents field TabIndicatorWidth.
TabMargins | Represents field TabMargins.
TabOptions | Represents field TabOptions.
TabRowAlternate | Represents field TabRowAlternate.
TabRowLines | Represents field TabRowLines.
TabRows | Represents field TabRows.
TabRowsBack | Represents field TabRowsBack.
TabRowsHeight | Represents field TabRowsHeight.
TabScrolling | Represents field TabScrolling.
TabSelection | Represents field TabSelection.
TabSubBands | Represents field TabSubBands.
TabTheme | Represents field TabTheme.
TBHorizSpacing | Represents field TBHorizSpacing.
TBVertSpacing | Represents field TBVertSpacing.
TreeColumns | Represents field TreeColumns.
Top


TTeeGridEditor.BOk Field

Summary

Represents field BOk.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBAlternateVisible Field

Summary

Represents field CBAlternateVisible.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBAlternateVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBAutoEdit Field

Summary

Represents field CBAutoEdit.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBAutoEdit: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBDoubleClick Field

Summary

Represents field CBDoubleClick.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBDoubleClick: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBEditingAlways Field

Summary

Represents field CBEditingAlways.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBEditingAlways: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBEnterKey Field

Summary

Represents field CBEnterKey.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBEnterKey: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBIndicatorVisible Field

Summary

Represents field CBIndicatorVisible.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBIndicatorVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBReadOnly Field

Summary

Represents field CBReadOnly.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBReadOnly: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.CBSelectText Field

Summary

Represents field CBSelectText.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 CBSelectText: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.GBText Field

Summary

Represents field GBText.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 GBText: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.LBThemes Field

Summary

Represents field LBThemes.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 LBThemes: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.LHorizSpacing Field

Summary

Represents field LHorizSpacing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 LHorizSpacing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.LVertSpacing Field

Summary

Represents field LVertSpacing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 LVertSpacing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageBands Field

Summary

Represents field PageBands.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageBands: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageCells Field

Summary

Represents field PageCells.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageCells: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageGrid Field

Summary

Represents field PageGrid.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageGrid: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageIndicator Field

Summary

Represents field PageIndicator.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageIndicator: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageOptions Field

Summary

Represents field PageOptions.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageOptions: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PageRows Field

Summary

Represents field PageRows.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PageRows: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PanelEditor Field

Summary

Represents field PanelEditor.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PanelEditor: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.RGPainter Field

Summary

Represents field RGPainter.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 RGPainter: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBAdd Field

Summary

Represents field SBAdd.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 SBAdd: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBColumnDown Field

Summary

Represents field SBColumnDown.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 SBColumnDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBColumnUp Field

Summary

Represents field SBColumnUp.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 SBColumnUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.SBDeleteColumn Field

Summary

Represents field SBDeleteColumn.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 SBDeleteColumn: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabBack Field

Summary

Represents field TabBack.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabBack: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabBands Field

Summary

Represents field TabBands.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabBands: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabCells Field

Summary

Represents field TabCells.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabCells: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabCellsFormat Field

Summary

Represents field TabCellsFormat.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabCellsFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabCellsHover Field

Summary

Represents field TabCellsHover.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabCellsHover: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabColumnLines Field

Summary

Represents field TabColumnLines.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabColumnLines: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabColumns Field

Summary

Represents field TabColumns.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabColumns: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabEditing Field

Summary

Represents field TabEditing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabEditing: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabFooter Field

Summary

Represents field TabFooter.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabFooter: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabHeaders Field

Summary

Represents field TabHeaders.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabHeaders: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabIndicator Field

Summary

Represents field TabIndicator.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabIndicator: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabIndicatorFormat Field

Summary

Represents field TabIndicatorFormat.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabIndicatorFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabIndicatorWidth Field

Summary

Represents field TabIndicatorWidth.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabIndicatorWidth: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabMargins Field

Summary

Represents field TabMargins.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabMargins: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabRowAlternate Field

Summary

Represents field TabRowAlternate.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabRowAlternate: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabRowLines Field

Summary

Represents field TabRowLines.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabRowLines: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabRows Field

Summary

Represents field TabRows.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabRows: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabRowsBack Field

Summary

Represents field TabRowsBack.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabRowsBack: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabRowsHeight Field

Summary

Represents field TabRowsHeight.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabRowsHeight: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabScrolling Field

Summary

Represents field TabScrolling.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabScrolling: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabSelection Field

Summary

Represents field TabSelection.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabSelection: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabSubBands Field

Summary

Represents field TabSubBands.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabSubBands: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TabTheme Field

Summary

Represents field TabTheme.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TabTheme: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TBHorizSpacing Field

Summary

Represents field TBHorizSpacing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TBHorizSpacing: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TBVertSpacing Field

Summary

Represents field TBVertSpacing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TBVertSpacing: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


TTeeGridEditor.TreeColumns Field

Summary

Represents field TreeColumns.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
published
 TreeColumns: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TTeeGridEditor
  • VCLTee.Editor.Grid


VCLTee.Editor.Grid Constants

Constants
Name | Description
TeeMsg_GridEditing | Represents constant TeeMsg_GridEditing.
Top


TeeMsg_GridEditing Constant

Summary

Represents constant TeeMsg_GridEditing.

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
 TeeMsg_GridEditing='Editing ';

Value

Type: string

See Also

Reference

  • VCLTee.Editor.Grid


VCLTee.Editor.Grid Routines

Routines
Name | Description
InternalEditGrid(TCustomTeeGrid) | Represents method InternalEditGrid(TCustomTeeGrid).
Top


InternalEditGrid(TCustomTeeGrid) Method

Summary

Represents method InternalEditGrid(TCustomTeeGrid).

Namespace: VCLTee.Editor.Grid
Syntax
Delphi
procedure InternalEditGrid(const AGrid:TCustomTeeGrid);

Parameters

AGrid
Type: TCustomTeeGrid

See Also

Reference

  • VCLTee.Editor.Grid


VCLTee.Editor.Grid.Band.Columns Namespace

Summary

Represents namespace VCLTee.Editor.Grid.Band.Columns.

Classes
Name | Description
TColumnsBandEditor | Represents type TColumnsBandEditor.
Top


VCLTee.Editor.Grid.Band.Columns Classes

Classes
Name | Description
TColumnsBandEditor | Represents type TColumnsBandEditor.
Top


TColumnsBandEditor Class

Summary

Represents type TColumnsBandEditor.

Namespace: VCLTee.Editor.Grid.Band.Columns
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Band.Columns.TColumnsBandEditor
Syntax
Delphi
type
 TColumnsBandEditor = class(TForm)
 end;

The TColumnsBandEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TColumnsBand) | Represents method Edit(TComponent,TColumnsBand).
Embedd(TComponent,TWinControl,TColumnsBand) | Represents method Embedd(TComponent,TWinControl,TColumnsBand).
RefreshBand(TColumnsBand) | Represents method RefreshBand(TColumnsBand).
Top
Fields
Show:
Name | Description
PageControl1 | Represents field PageControl1.
TabFormat | Represents field TabFormat.
TabText | Represents field TabText.
TeeGrid1 | Represents field TeeGrid1.
Top
See Also

Reference

  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor Methods

Methods
Name | Description
Edit(TComponent,TColumnsBand) | Represents method Edit(TComponent,TColumnsBand).
Embedd(TComponent,TWinControl,TColumnsBand) | Represents method Embedd(TComponent,TWinControl,TColumnsBand).
RefreshBand(TColumnsBand) | Represents method RefreshBand(TColumnsBand).
Top


TColumnsBandEditor.Edit(TComponent,TColumnsBand) Method

Summary

Represents method Edit(TComponent,TColumnsBand).

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABand:TColumnsBand):Boolean; static;

Parameters

AOwner
Type: TComponent

ABand
Type: TColumnsBand

Return Value

Type: Boolean

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor.Embedd(TComponent,TWinControl,TColumnsBand) Method

Summary

Represents method Embedd(TComponent,TWinControl,TColumnsBand).

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ABand:TColumnsBand):TColumnsBandEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ABand
Type: TColumnsBand

Return Value

Type: TColumnsBandEditor

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor.RefreshBand(TColumnsBand) Method

Summary

Represents method RefreshBand(TColumnsBand).

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
public
 procedure RefreshBand(const ABand:TColumnsBand);

Parameters

ABand
Type: TColumnsBand

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor Fields

Fields
Name | Description
PageControl1 | Represents field PageControl1.
TabFormat | Represents field TabFormat.
TabText | Represents field TabText.
TeeGrid1 | Represents field TeeGrid1.
Top


TColumnsBandEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor.TabText Field

Summary

Represents field TabText.

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
published
 TabText: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


TColumnsBandEditor.TeeGrid1 Field

Summary

Represents field TeeGrid1.

Namespace: VCLTee.Editor.Grid.Band.Columns
Syntax
Delphi
published
 TeeGrid1: TTeeGrid;

Field Value

Type: TTeeGrid

See Also

Reference

  • TColumnsBandEditor
  • VCLTee.Editor.Grid.Band.Columns


VCLTee.Editor.Grid.Band.Text Namespace

Summary

Represents namespace VCLTee.Editor.Grid.Band.Text.

Classes
Name | Description
TTextBandEditor | Represents type TTextBandEditor.
Top


VCLTee.Editor.Grid.Band.Text Classes

Classes
Name | Description
TTextBandEditor | Represents type TTextBandEditor.
Top


TTextBandEditor Class

Summary

Represents type TTextBandEditor.

Namespace: VCLTee.Editor.Grid.Band.Text
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Band.Text.TTextBandEditor
Syntax
Delphi
type
 TTextBandEditor = class(TForm)
 end;

The TTextBandEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TTextBand) | Represents method Edit(TComponent,TTextBand).
Embedd(TComponent,TWinControl,TTextBand) | Represents method Embedd(TComponent,TWinControl,TTextBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
MemoTextChange(TObject) | Represents method MemoTextChange(TObject).
PageTextChange(TObject) | Represents method PageTextChange(TObject).
RefreshText(TTextBand) | Represents method RefreshText(TTextBand).
Top
Fields
Show:
Name | Description
MemoText | Represents field MemoText.
PageText | Represents field PageText.
TabHeight | Represents field TabHeight.
TabOptions | Represents field TabOptions.
TabText | Represents field TabText.
Top
See Also

Reference

  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor Methods

Methods
Name | Description
Edit(TComponent,TTextBand) | Represents method Edit(TComponent,TTextBand).
Embedd(TComponent,TWinControl,TTextBand) | Represents method Embedd(TComponent,TWinControl,TTextBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
MemoTextChange(TObject) | Represents method MemoTextChange(TObject).
PageTextChange(TObject) | Represents method PageTextChange(TObject).
RefreshText(TTextBand) | Represents method RefreshText(TTextBand).
Top


TTextBandEditor.Edit(TComponent,TTextBand) Method

Summary

Represents method Edit(TComponent,TTextBand).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AText:TTextBand):Boolean; static;

Parameters

AOwner
Type: TComponent

AText
Type: TTextBand

Return Value

Type: Boolean

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.Embedd(TComponent,TWinControl,TTextBand) Method

Summary

Represents method Embedd(TComponent,TWinControl,TTextBand).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AText:TTextBand):TTextBandEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AText
Type: TTextBand

Return Value

Type: TTextBandEditor

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.MemoTextChange(TObject) Method

Summary

Represents method MemoTextChange(TObject).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 procedure MemoTextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.PageTextChange(TObject) Method

Summary

Represents method PageTextChange(TObject).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 procedure PageTextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.RefreshText(TTextBand) Method

Summary

Represents method RefreshText(TTextBand).

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
public
 procedure RefreshText(const AText:TTextBand);

Parameters

AText
Type: TTextBand

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor Fields

Fields
Name | Description
MemoText | Represents field MemoText.
PageText | Represents field PageText.
TabHeight | Represents field TabHeight.
TabOptions | Represents field TabOptions.
TabText | Represents field TabText.
Top


TTextBandEditor.MemoText Field

Summary

Represents field MemoText.

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 MemoText: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.PageText Field

Summary

Represents field PageText.

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 PageText: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.TabHeight Field

Summary

Represents field TabHeight.

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 TabHeight: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


TTextBandEditor.TabText Field

Summary

Represents field TabText.

Namespace: VCLTee.Editor.Grid.Band.Text
Syntax
Delphi
published
 TabText: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextBandEditor
  • VCLTee.Editor.Grid.Band.Text


VCLTee.Editor.Grid.Band.Totals Namespace

Summary

Represents namespace VCLTee.Editor.Grid.Band.Totals.

Classes
Name | Description
TColumnTotalsEditor | Represents type TColumnTotalsEditor.
Top


VCLTee.Editor.Grid.Band.Totals Classes

Classes
Name | Description
TColumnTotalsEditor | Represents type TColumnTotalsEditor.
Top


TColumnTotalsEditor Class

Summary

Represents type TColumnTotalsEditor.

Namespace: VCLTee.Editor.Grid.Band.Totals
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Band.Totals.TColumnTotalsEditor
Syntax
Delphi
type
 TColumnTotalsEditor = class(TForm)
 end;

The TColumnTotalsEditor type exposes the following members.

Methods
Show:
Name | Description
BNoneClick(TObject) | Represents method BNoneClick(TObject).
Edit(TComponent,TColumnTotals) | Represents method Edit(TComponent,TColumnTotals).
Embedd(TComponent,TWinControl,TColumnTotals) | Represents method Embedd(TComponent,TWinControl,TColumnTotals).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageTotalsChange(TObject) | Represents method PageTotalsChange(TObject).
RefreshTotals(TColumnTotals) | Represents method RefreshTotals(TColumnTotals).
RGCalcClick(TObject) | Represents method RGCalcClick(TObject).
TreeColumnsChange(TObject,TTreeNode) | Represents method TreeColumnsChange(TObject,TTreeNode).
Top
Fields
Show:
Name | Description
BNone | Represents field BNone.
PageTotals | Represents field PageTotals.
RGCalc | Represents field RGCalc.
TabCalc | Represents field TabCalc.
TabOptions | Represents field TabOptions.
TreeColumns | Represents field TreeColumns.
Top
See Also

Reference

  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor Methods

Methods
Name | Description
BNoneClick(TObject) | Represents method BNoneClick(TObject).
Edit(TComponent,TColumnTotals) | Represents method Edit(TComponent,TColumnTotals).
Embedd(TComponent,TWinControl,TColumnTotals) | Represents method Embedd(TComponent,TWinControl,TColumnTotals).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageTotalsChange(TObject) | Represents method PageTotalsChange(TObject).
RefreshTotals(TColumnTotals) | Represents method RefreshTotals(TColumnTotals).
RGCalcClick(TObject) | Represents method RGCalcClick(TObject).
TreeColumnsChange(TObject,TTreeNode) | Represents method TreeColumnsChange(TObject,TTreeNode).
Top


TColumnTotalsEditor.BNoneClick(TObject) Method

Summary

Represents method BNoneClick(TObject).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 procedure BNoneClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.Edit(TComponent,TColumnTotals) Method

Summary

Represents method Edit(TComponent,TColumnTotals).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ATotals:TColumnTotals):Boolean; static;

Parameters

AOwner
Type: TComponent

ATotals
Type: TColumnTotals

Return Value

Type: Boolean

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.Embedd(TComponent,TWinControl,TColumnTotals) Method

Summary

Represents method Embedd(TComponent,TWinControl,TColumnTotals).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ATotals:TColumnTotals):TColumnTotalsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ATotals
Type: TColumnTotals

Return Value

Type: TColumnTotalsEditor

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.PageTotalsChange(TObject) Method

Summary

Represents method PageTotalsChange(TObject).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 procedure PageTotalsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.RefreshTotals(TColumnTotals) Method

Summary

Represents method RefreshTotals(TColumnTotals).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
public
 procedure RefreshTotals(const ATotals:TColumnTotals);

Parameters

ATotals
Type: TColumnTotals

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.RGCalcClick(TObject) Method

Summary

Represents method RGCalcClick(TObject).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 procedure RGCalcClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.TreeColumnsChange(TObject,TTreeNode) Method

Summary

Represents method TreeColumnsChange(TObject,TTreeNode).

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 procedure TreeColumnsChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor Fields

Fields
Name | Description
BNone | Represents field BNone.
PageTotals | Represents field PageTotals.
RGCalc | Represents field RGCalc.
TabCalc | Represents field TabCalc.
TabOptions | Represents field TabOptions.
TreeColumns | Represents field TreeColumns.
Top


TColumnTotalsEditor.BNone Field

Summary

Represents field BNone.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 BNone: TButton;

Field Value

Type: TButton

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.PageTotals Field

Summary

Represents field PageTotals.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 PageTotals: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.RGCalc Field

Summary

Represents field RGCalc.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 RGCalc: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.TabCalc Field

Summary

Represents field TabCalc.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 TabCalc: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


TColumnTotalsEditor.TreeColumns Field

Summary

Represents field TreeColumns.

Namespace: VCLTee.Editor.Grid.Band.Totals
Syntax
Delphi
published
 TreeColumns: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TColumnTotalsEditor
  • VCLTee.Editor.Grid.Band.Totals


VCLTee.Editor.Grid.Bands Namespace

Summary

Represents namespace VCLTee.Editor.Grid.Bands.

Classes
Name | Description
TGridBandsEditor | Represents type TGridBandsEditor.
Top
Routines
Name | Description
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
Top


VCLTee.Editor.Grid.Bands Classes

Classes
Name | Description
TGridBandsEditor | Represents type TGridBandsEditor.
Top


TGridBandsEditor Class

Summary

Represents type TGridBandsEditor.

Namespace: VCLTee.Editor.Grid.Bands
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Bands.TGridBandsEditor
VCLTee.Editor.Grid.TGridBandsEditorAccess
Syntax
Delphi
type
 TGridBandsEditor = class(TForm)
 end;

The TGridBandsEditor type exposes the following members.

Methods
Show:
Name | Description
CBFloatingClick(TObject) | Represents method CBFloatingClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
ColumnsText1Click(TObject) | Represents method ColumnsText1Click(TObject).
Edit(TComponent,TGridBands) | Represents method Edit(TComponent,TGridBands).
Embedd(TComponent,TWinControl,TGridBands) | Represents method Embedd(TComponent,TWinControl,TGridBands).
ext1Click(TObject) | Represents method ext1Click(TObject).
Header1Click(TObject) | Represents method Header1Click(TObject).
LBBandsClick(TObject) | Represents method LBBandsClick(TObject).
LBBandsClickCheck(TObject) | Represents method LBBandsClickCheck(TObject).
otals1Click(TObject) | Represents method otals1Click(TObject).
otalsHeader1Click(TObject) | Represents method otalsHeader1Click(TObject).
RefreshBands(TGridBands) | Represents method RefreshBands(TGridBands).
RefreshUpDown | Represents method RefreshUpDown.
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBRemoveClick(TObject) | Represents method SBRemoveClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top
Fields
Show:
Name | Description
CBFloating | Represents field CBFloating.
CBVisible | Represents field CBVisible.
ColumnsText1 | Represents field ColumnsText1.
ext1 | Represents field ext1.
Header | Represents field Header.
Header1 | Represents field Header1.
LBBands | Represents field LBBands.
otals1 | Represents field otals1.
otalsHeader1 | Represents field otalsHeader1.
PanelMain | Represents field PanelMain.
PanelTop | Represents field PanelTop.
PopupMenu1 | Represents field PopupMenu1.
SBAdd | Represents field SBAdd.
SBDown | Represents field SBDown.
SBRemove | Represents field SBRemove.
SBUp | Represents field SBUp.
Top
See Also

Reference

  • VCLTee.Editor.Grid.Bands


TGridBandsEditor Methods

Methods
Name | Description
CBFloatingClick(TObject) | Represents method CBFloatingClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
ColumnsText1Click(TObject) | Represents method ColumnsText1Click(TObject).
Edit(TComponent,TGridBands) | Represents method Edit(TComponent,TGridBands).
Embedd(TComponent,TWinControl,TGridBands) | Represents method Embedd(TComponent,TWinControl,TGridBands).
ext1Click(TObject) | Represents method ext1Click(TObject).
Header1Click(TObject) | Represents method Header1Click(TObject).
LBBandsClick(TObject) | Represents method LBBandsClick(TObject).
LBBandsClickCheck(TObject) | Represents method LBBandsClickCheck(TObject).
otals1Click(TObject) | Represents method otals1Click(TObject).
otalsHeader1Click(TObject) | Represents method otalsHeader1Click(TObject).
RefreshBands(TGridBands) | Represents method RefreshBands(TGridBands).
RefreshUpDown | Represents method RefreshUpDown.
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBRemoveClick(TObject) | Represents method SBRemoveClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top


TGridBandsEditor.CBFloatingClick(TObject) Method

Summary

Represents method CBFloatingClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure CBFloatingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.ColumnsText1Click(TObject) Method

Summary

Represents method ColumnsText1Click(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure ColumnsText1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.Edit(TComponent,TGridBands) Method

Summary

Represents method Edit(TComponent,TGridBands).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABands:TGridBands):Boolean; static;

Parameters

AOwner
Type: TComponent

ABands
Type: TGridBands

Return Value

Type: Boolean

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.Embedd(TComponent,TWinControl,TGridBands) Method

Summary

Represents method Embedd(TComponent,TWinControl,TGridBands).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ABands:TGridBands):TGridBandsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ABands
Type: TGridBands

Return Value

Type: TGridBandsEditor

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.ext1Click(TObject) Method

Summary

Represents method ext1Click(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure ext1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.Header1Click(TObject) Method

Summary

Represents method Header1Click(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure Header1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.LBBandsClick(TObject) Method

Summary

Represents method LBBandsClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure LBBandsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.LBBandsClickCheck(TObject) Method

Summary

Represents method LBBandsClickCheck(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure LBBandsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.otals1Click(TObject) Method

Summary

Represents method otals1Click(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure otals1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.otalsHeader1Click(TObject) Method

Summary

Represents method otalsHeader1Click(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure otalsHeader1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.RefreshBands(TGridBands) Method

Summary

Represents method RefreshBands(TGridBands).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
public
 procedure RefreshBands(const ABands:TGridBands);

Parameters

ABands
Type: TGridBands

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.RefreshUpDown Method

Summary

Represents method RefreshUpDown.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
protected
 procedure RefreshUpDown;
See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBAddClick(TObject) Method

Summary

Represents method SBAddClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure SBAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBDownClick(TObject) Method

Summary

Represents method SBDownClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure SBDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBRemoveClick(TObject) Method

Summary

Represents method SBRemoveClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure SBRemoveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBUpClick(TObject) Method

Summary

Represents method SBUpClick(TObject).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 procedure SBUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor Fields

Fields
Name | Description
CBFloating | Represents field CBFloating.
CBVisible | Represents field CBVisible.
ColumnsText1 | Represents field ColumnsText1.
ext1 | Represents field ext1.
Header | Represents field Header.
Header1 | Represents field Header1.
LBBands | Represents field LBBands.
otals1 | Represents field otals1.
otalsHeader1 | Represents field otalsHeader1.
PanelMain | Represents field PanelMain.
PanelTop | Represents field PanelTop.
PopupMenu1 | Represents field PopupMenu1.
SBAdd | Represents field SBAdd.
SBDown | Represents field SBDown.
SBRemove | Represents field SBRemove.
SBUp | Represents field SBUp.
Top


TGridBandsEditor.CBFloating Field

Summary

Represents field CBFloating.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 CBFloating: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.ColumnsText1 Field

Summary

Represents field ColumnsText1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 ColumnsText1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.ext1 Field

Summary

Represents field ext1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 ext1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.Header Field

Summary

Represents field Header.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
protected
 Header : TGridBand;

Field Value

Type: TGridBand

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.Header1 Field

Summary

Represents field Header1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 Header1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.LBBands Field

Summary

Represents field LBBands.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 LBBands: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.otals1 Field

Summary

Represents field otals1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 otals1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.otalsHeader1 Field

Summary

Represents field otalsHeader1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 otalsHeader1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.PanelMain Field

Summary

Represents field PanelMain.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 PanelMain: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.PanelTop Field

Summary

Represents field PanelTop.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 PanelTop: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBAdd Field

Summary

Represents field SBAdd.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 SBAdd: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBDown Field

Summary

Represents field SBDown.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 SBDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBRemove Field

Summary

Represents field SBRemove.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 SBRemove: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


TGridBandsEditor.SBUp Field

Summary

Represents field SBUp.

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
published
 SBUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TGridBandsEditor
  • VCLTee.Editor.Grid.Bands


VCLTee.Editor.Grid.Bands Routines

Routines
Name | Description
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
Top


Popup(TPopupMenu,TControl) Method

Summary

Represents method Popup(TPopupMenu,TControl).

Namespace: VCLTee.Editor.Grid.Bands
Syntax
Delphi
procedure Popup(const APopup: TPopupMenu; const AParent: TControl);

Parameters

APopup
Type: TPopupMenu

AParent
Type: TControl

See Also

Reference

  • VCLTee.Editor.Grid.Bands


VCLTee.Editor.Grid.Ticker Namespace

Summary

Represents namespace VCLTee.Editor.Grid.Ticker.

Classes
Name | Description
TGridTickerEditor | Represents type TGridTickerEditor.
Top


VCLTee.Editor.Grid.Ticker Classes

Classes
Name | Description
TGridTickerEditor | Represents type TGridTickerEditor.
Top


TGridTickerEditor Class

Summary

Represents type TGridTickerEditor.

Namespace: VCLTee.Editor.Grid.Ticker
Inheritance Hierarchy
TForm
VCLTee.Editor.Grid.Ticker.TGridTickerEditor
Syntax
Delphi
type
 TGridTickerEditor = class(TForm)
 end;

The TGridTickerEditor type exposes the following members.

Methods
Show:
Name | Description
CBEnabledClick(TObject) | Represents method CBEnabledClick(TObject).
CBFadeClick(TObject) | Represents method CBFadeClick(TObject).
Edit(TComponent,TGridTicker) | Represents method Edit(TComponent,TGridTicker).
Embedd(TComponent,TWinControl,TGridTicker) | Represents method Embedd(TComponent,TWinControl,TGridTicker).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageTickerChange(TObject) | Represents method PageTickerChange(TObject).
RefreshTicker(TGridTicker) | Represents method RefreshTicker(TGridTicker).
TBDelayChange(TObject) | Represents method TBDelayChange(TObject).
Top
Fields
Show:
Name | Description
CBEnabled | Represents field CBEnabled.
CBFade | Represents field CBFade.
Label2 | Represents field Label2.
LDelay | Represents field LDelay.
PageTicker | Represents field PageTicker.
TabHigher | Represents field TabHigher.
TabLower | Represents field TabLower.
TabOptions | Represents field TabOptions.
TBDelay | Represents field TBDelay.
Top
See Also

Reference

  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor Methods

Methods
Name | Description
CBEnabledClick(TObject) | Represents method CBEnabledClick(TObject).
CBFadeClick(TObject) | Represents method CBFadeClick(TObject).
Edit(TComponent,TGridTicker) | Represents method Edit(TComponent,TGridTicker).
Embedd(TComponent,TWinControl,TGridTicker) | Represents method Embedd(TComponent,TWinControl,TGridTicker).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageTickerChange(TObject) | Represents method PageTickerChange(TObject).
RefreshTicker(TGridTicker) | Represents method RefreshTicker(TGridTicker).
TBDelayChange(TObject) | Represents method TBDelayChange(TObject).
Top


TGridTickerEditor.CBEnabledClick(TObject) Method

Summary

Represents method CBEnabledClick(TObject).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 procedure CBEnabledClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.CBFadeClick(TObject) Method

Summary

Represents method CBFadeClick(TObject).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 procedure CBFadeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.Edit(TComponent,TGridTicker) Method

Summary

Represents method Edit(TComponent,TGridTicker).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ATicker:TGridTicker):Boolean; static;

Parameters

AOwner
Type: TComponent

ATicker
Type: TGridTicker

Return Value

Type: Boolean

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.Embedd(TComponent,TWinControl,TGridTicker) Method

Summary

Represents method Embedd(TComponent,TWinControl,TGridTicker).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ATicker:TGridTicker):TGridTickerEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ATicker
Type: TGridTicker

Return Value

Type: TGridTickerEditor

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.PageTickerChange(TObject) Method

Summary

Represents method PageTickerChange(TObject).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 procedure PageTickerChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.RefreshTicker(TGridTicker) Method

Summary

Represents method RefreshTicker(TGridTicker).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
public
 procedure RefreshTicker(const ATicker:TGridTicker);

Parameters

ATicker
Type: TGridTicker

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.TBDelayChange(TObject) Method

Summary

Represents method TBDelayChange(TObject).

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 procedure TBDelayChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor Fields

Fields
Name | Description
CBEnabled | Represents field CBEnabled.
CBFade | Represents field CBFade.
Label2 | Represents field Label2.
LDelay | Represents field LDelay.
PageTicker | Represents field PageTicker.
TabHigher | Represents field TabHigher.
TabLower | Represents field TabLower.
TabOptions | Represents field TabOptions.
TBDelay | Represents field TBDelay.
Top


TGridTickerEditor.CBEnabled Field

Summary

Represents field CBEnabled.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 CBEnabled: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.CBFade Field

Summary

Represents field CBFade.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 CBFade: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.LDelay Field

Summary

Represents field LDelay.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 LDelay: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.PageTicker Field

Summary

Represents field PageTicker.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 PageTicker: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.TabHigher Field

Summary

Represents field TabHigher.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 TabHigher: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.TabLower Field

Summary

Represents field TabLower.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 TabLower: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


TGridTickerEditor.TBDelay Field

Summary

Represents field TBDelay.

Namespace: VCLTee.Editor.Grid.Ticker
Syntax
Delphi
published
 TBDelay: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TGridTickerEditor
  • VCLTee.Editor.Grid.Ticker


VCLTee.Editor.Header Namespace

Summary

Represents namespace VCLTee.Editor.Header.

Classes
Name | Description
THeaderEditor | Represents type THeaderEditor.
Top


VCLTee.Editor.Header Classes

Classes
Name | Description
THeaderEditor | Represents type THeaderEditor.
Top


THeaderEditor Class

Summary

Represents type THeaderEditor.

Namespace: VCLTee.Editor.Header
Inheritance Hierarchy
TForm
VCLTee.Editor.Header.THeaderEditor
Syntax
Delphi
type
 THeaderEditor = class(TForm)
 end;

The THeaderEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TColumnHeaderBand) | Represents method Edit(TComponent,TColumnHeaderBand).
Embedd(TComponent,TWinControl,TColumnHeaderBand) | Overloaded. Represents method Embedd(TComponent,TWinControl,TColumnHeaderBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageHeaderChange(TObject) | Represents method PageHeaderChange(TObject).
RefreshHeader(TColumnHeaderBand) | Represents method RefreshHeader(TColumnHeaderBand).
Top
Fields
Show:
Name | Description
PageHeader | Represents field PageHeader.
TabFormat | Represents field TabFormat.
TabMargins | Represents field TabMargins.
TabRowLines | Represents field TabRowLines.
Top
See Also

Reference

  • VCLTee.Editor.Header


THeaderEditor Methods

Methods
Name | Description
Edit(TComponent,TColumnHeaderBand) | Represents method Edit(TComponent,TColumnHeaderBand).
Embedd(TComponent,TWinControl,TColumnHeaderBand) | Overloaded. Represents method Embedd(TComponent,TWinControl,TColumnHeaderBand).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageHeaderChange(TObject) | Represents method PageHeaderChange(TObject).
RefreshHeader(TColumnHeaderBand) | Represents method RefreshHeader(TColumnHeaderBand).
Top


THeaderEditor.Edit(TComponent,TColumnHeaderBand) Method

Summary

Represents method Edit(TComponent,TColumnHeaderBand).

Namespace: VCLTee.Editor.Header
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AHeader:TColumnHeaderBand):Boolean; static;

Parameters

AOwner
Type: TComponent

AHeader
Type: TColumnHeaderBand

Return Value

Type: Boolean

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.Embedd(TComponent,TWinControl,TColumnHeaderBand) Method

Summary

Represents method Embedd(TComponent,TWinControl,TColumnHeaderBand).

Namespace: VCLTee.Editor.Header
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AHeader:TColumnHeaderBand):THeaderEditor; overload; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AHeader
Type: TColumnHeaderBand

Return Value

Type: THeaderEditor

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.PageHeaderChange(TObject) Method

Summary

Represents method PageHeaderChange(TObject).

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 procedure PageHeaderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.RefreshHeader(TColumnHeaderBand) Method

Summary

Represents method RefreshHeader(TColumnHeaderBand).

Namespace: VCLTee.Editor.Header
Syntax
Delphi
public
 procedure RefreshHeader(const AHeader:TColumnHeaderBand);

Parameters

AHeader
Type: TColumnHeaderBand

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor Fields

Fields
Name | Description
PageHeader | Represents field PageHeader.
TabFormat | Represents field TabFormat.
TabMargins | Represents field TabMargins.
TabRowLines | Represents field TabRowLines.
Top


THeaderEditor.PageHeader Field

Summary

Represents field PageHeader.

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 PageHeader: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.TabMargins Field

Summary

Represents field TabMargins.

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 TabMargins: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


THeaderEditor.TabRowLines Field

Summary

Represents field TabRowLines.

Namespace: VCLTee.Editor.Header
Syntax
Delphi
published
 TabRowLines: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • THeaderEditor
  • VCLTee.Editor.Header


VCLTee.Editor.Margins Namespace

Summary

Represents namespace VCLTee.Editor.Margins.

Classes
Name | Description
TTeeMarginsEditor | Represents type TTeeMarginsEditor.
Top


VCLTee.Editor.Margins Classes

Classes
Name | Description
TTeeMarginsEditor | Represents type TTeeMarginsEditor.
Top


TTeeMarginsEditor Class

Summary

Represents type TTeeMarginsEditor.

Namespace: VCLTee.Editor.Margins
Inheritance Hierarchy
TForm
VCLTee.Editor.Margins.TTeeMarginsEditor
Syntax
Delphi
type
 TTeeMarginsEditor = class(TForm)
 end;

The TTeeMarginsEditor type exposes the following members.

Methods
Show:
Name | Description
Edit(TComponent,TMargins) | Represents method Edit(TComponent,TMargins).
Embedd(TComponent,TWinControl,TMargins) | Represents method Embedd(TComponent,TWinControl,TMargins).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
RefreshMargins(TMargins) | Represents method RefreshMargins(TMargins).
Top
Fields
Show:
Name | Description
PageControl1 | Represents field PageControl1.
TabBottom | Represents field TabBottom.
TabLeft | Represents field TabLeft.
TabRight | Represents field TabRight.
TabTop | Represents field TabTop.
Top
See Also

Reference

  • VCLTee.Editor.Margins


TTeeMarginsEditor Methods

Methods
Name | Description
Edit(TComponent,TMargins) | Represents method Edit(TComponent,TMargins).
Embedd(TComponent,TWinControl,TMargins) | Represents method Embedd(TComponent,TWinControl,TMargins).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
RefreshMargins(TMargins) | Represents method RefreshMargins(TMargins).
Top


TTeeMarginsEditor.Edit(TComponent,TMargins) Method

Summary

Represents method Edit(TComponent,TMargins).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AMargins:TMargins):Boolean; static;

Parameters

AOwner
Type: TComponent

AMargins
Type: TMargins

Return Value

Type: Boolean

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.Embedd(TComponent,TWinControl,TMargins) Method

Summary

Represents method Embedd(TComponent,TWinControl,TMargins).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AMargins:TMargins):TTeeMarginsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AMargins
Type: TMargins

Return Value

Type: TTeeMarginsEditor

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.RefreshMargins(TMargins) Method

Summary

Represents method RefreshMargins(TMargins).

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
public
 procedure RefreshMargins(const AMargins:TMargins);

Parameters

AMargins
Type: TMargins

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor Fields

Fields
Name | Description
PageControl1 | Represents field PageControl1.
TabBottom | Represents field TabBottom.
TabLeft | Represents field TabLeft.
TabRight | Represents field TabRight.
TabTop | Represents field TabTop.
Top


TTeeMarginsEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.TabBottom Field

Summary

Represents field TabBottom.

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 TabBottom: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.TabLeft Field

Summary

Represents field TabLeft.

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 TabLeft: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.TabRight Field

Summary

Represents field TabRight.

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 TabRight: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


TTeeMarginsEditor.TabTop Field

Summary

Represents field TabTop.

Namespace: VCLTee.Editor.Margins
Syntax
Delphi
published
 TabTop: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTeeMarginsEditor
  • VCLTee.Editor.Margins


VCLTee.Editor.Render.Text Namespace

Summary

Represents namespace VCLTee.Editor.Render.Text.

Classes
Name | Description
TTextRenderEditor | Represents type TTextRenderEditor.
Top


VCLTee.Editor.Render.Text Classes

Classes
Name | Description
TTextRenderEditor | Represents type TTextRenderEditor.
Top


TTextRenderEditor Class

Summary

Represents type TTextRenderEditor.

Namespace: VCLTee.Editor.Render.Text
Inheritance Hierarchy
TForm
VCLTee.Editor.Render.Text.TTextRenderEditor
Syntax
Delphi
type
 TTextRenderEditor = class(TForm)
 end;

The TTextRenderEditor type exposes the following members.

Methods
Show:
Name | Description
CBTrimEllipsiClick(TObject) | Represents method CBTrimEllipsiClick(TObject).
Edit(TComponent,TTextRender) | Represents method Edit(TComponent,TTextRender).
Embedd(TComponent,TWinControl,TTextRender) | Represents method Embedd(TComponent,TWinControl,TTextRender).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageSelectedChange(TObject) | Represents method PageSelectedChange(TObject).
RefreshTextRender(TTextRender) | Represents method RefreshTextRender(TTextRender).
RGTrimmingClick(TObject) | Represents method RGTrimmingClick(TObject).
Top
Fields
Show:
Name | Description
CBTrimEllipsi | Represents field CBTrimEllipsi.
Options | Represents field Options.
PageSelected | Represents field PageSelected.
RGTrimming | Represents field RGTrimming.
TabAlign | Represents field TabAlign.
TabBorders | Represents field TabBorders.
TabFormat | Represents field TabFormat.
TabMargins | Represents field TabMargins.
Top
See Also

Reference

  • VCLTee.Editor.Render.Text


TTextRenderEditor Methods

Methods
Name | Description
CBTrimEllipsiClick(TObject) | Represents method CBTrimEllipsiClick(TObject).
Edit(TComponent,TTextRender) | Represents method Edit(TComponent,TTextRender).
Embedd(TComponent,TWinControl,TTextRender) | Represents method Embedd(TComponent,TWinControl,TTextRender).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageSelectedChange(TObject) | Represents method PageSelectedChange(TObject).
RefreshTextRender(TTextRender) | Represents method RefreshTextRender(TTextRender).
RGTrimmingClick(TObject) | Represents method RGTrimmingClick(TObject).
Top


TTextRenderEditor.CBTrimEllipsiClick(TObject) Method

Summary

Represents method CBTrimEllipsiClick(TObject).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 procedure CBTrimEllipsiClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.Edit(TComponent,TTextRender) Method

Summary

Represents method Edit(TComponent,TTextRender).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ATextRender:TTextRender):Boolean; static;

Parameters

AOwner
Type: TComponent

ATextRender
Type: TTextRender

Return Value

Type: Boolean

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.Embedd(TComponent,TWinControl,TTextRender) Method

Summary

Represents method Embedd(TComponent,TWinControl,TTextRender).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ATextRender:TTextRender):TTextRenderEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ATextRender
Type: TTextRender

Return Value

Type: TTextRenderEditor

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.PageSelectedChange(TObject) Method

Summary

Represents method PageSelectedChange(TObject).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 procedure PageSelectedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.RefreshTextRender(TTextRender) Method

Summary

Represents method RefreshTextRender(TTextRender).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
public
 procedure RefreshTextRender(const ATextRender:TTextRender);

Parameters

ATextRender
Type: TTextRender

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.RGTrimmingClick(TObject) Method

Summary

Represents method RGTrimmingClick(TObject).

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 procedure RGTrimmingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor Fields

Fields
Name | Description
CBTrimEllipsi | Represents field CBTrimEllipsi.
Options | Represents field Options.
PageSelected | Represents field PageSelected.
RGTrimming | Represents field RGTrimming.
TabAlign | Represents field TabAlign.
TabBorders | Represents field TabBorders.
TabFormat | Represents field TabFormat.
TabMargins | Represents field TabMargins.
Top


TTextRenderEditor.CBTrimEllipsi Field

Summary

Represents field CBTrimEllipsi.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 CBTrimEllipsi: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.Options Field

Summary

Represents field Options.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 Options: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.PageSelected Field

Summary

Represents field PageSelected.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 PageSelected: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.RGTrimming Field

Summary

Represents field RGTrimming.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 RGTrimming: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.TabAlign Field

Summary

Represents field TabAlign.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 TabAlign: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.TabBorders Field

Summary

Represents field TabBorders.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 TabBorders: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


TTextRenderEditor.TabMargins Field

Summary

Represents field TabMargins.

Namespace: VCLTee.Editor.Render.Text
Syntax
Delphi
published
 TabMargins: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTextRenderEditor
  • VCLTee.Editor.Render.Text


VCLTee.Editor.Scrolling Namespace

Summary

Represents namespace VCLTee.Editor.Scrolling.

Classes
Name | Description
TScrollingEditor | Represents type TScrollingEditor.
Top


VCLTee.Editor.Scrolling Classes

Classes
Name | Description
TScrollingEditor | Represents type TScrollingEditor.
Top


TScrollingEditor Class

Summary

Represents type TScrollingEditor.

Namespace: VCLTee.Editor.Scrolling
Inheritance Hierarchy
TForm
VCLTee.Editor.Scrolling.TScrollingEditor
Syntax
Delphi
type
 TScrollingEditor = class(TForm)
 end;

The TScrollingEditor type exposes the following members.

Methods
Show:
Name | Description
CBHorizChange(TObject) | Represents method CBHorizChange(TObject).
CBHorizScrollBarChange(TObject) | Represents method CBHorizScrollBarChange(TObject).
CBScrollBarsClick(TObject) | Represents method CBScrollBarsClick(TObject).
CBVertChange(TObject) | Represents method CBVertChange(TObject).
CBVertScrollBarChange(TObject) | Represents method CBVertScrollBarChange(TObject).
Edit(TComponent,TCustomTeeGrid,TScrollBars) | Represents method Edit(TComponent,TCustomTeeGrid,TScrollBars).
Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars) | Represents method Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshScrolling(TCustomTeeGrid,TScrollBars) | Represents method RefreshScrolling(TCustomTeeGrid,TScrollBars).
RGModeClick(TObject) | Represents method RGModeClick(TObject).
Top
Fields
Show:
Name | Description
CBHoriz | Represents field CBHoriz.
CBHorizScrollBar | Represents field CBHorizScrollBar.
CBScrollBars | Represents field CBScrollBars.
CBVert | Represents field CBVert.
CBVertScrollBar | Represents field CBVertScrollBar.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label5 | Represents field Label5.
LHoriz | Represents field LHoriz.
PageScrolling | Represents field PageScrolling.
RGMode | Represents field RGMode.
TabOptions | Represents field TabOptions.
TabScrollBars | Represents field TabScrollBars.
Top
See Also

Reference

  • VCLTee.Editor.Scrolling


TScrollingEditor Methods

Methods
Name | Description
CBHorizChange(TObject) | Represents method CBHorizChange(TObject).
CBHorizScrollBarChange(TObject) | Represents method CBHorizScrollBarChange(TObject).
CBScrollBarsClick(TObject) | Represents method CBScrollBarsClick(TObject).
CBVertChange(TObject) | Represents method CBVertChange(TObject).
CBVertScrollBarChange(TObject) | Represents method CBVertScrollBarChange(TObject).
Edit(TComponent,TCustomTeeGrid,TScrollBars) | Represents method Edit(TComponent,TCustomTeeGrid,TScrollBars).
Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars) | Represents method Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshScrolling(TCustomTeeGrid,TScrollBars) | Represents method RefreshScrolling(TCustomTeeGrid,TScrollBars).
RGModeClick(TObject) | Represents method RGModeClick(TObject).
Top


TScrollingEditor.CBHorizChange(TObject) Method

Summary

Represents method CBHorizChange(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure CBHorizChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBHorizScrollBarChange(TObject) Method

Summary

Represents method CBHorizScrollBarChange(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure CBHorizScrollBarChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBScrollBarsClick(TObject) Method

Summary

Represents method CBScrollBarsClick(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure CBScrollBarsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBVertChange(TObject) Method

Summary

Represents method CBVertChange(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure CBVertChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBVertScrollBarChange(TObject) Method

Summary

Represents method CBVertScrollBarChange(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure CBVertScrollBarChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.Edit(TComponent,TCustomTeeGrid,TScrollBars) Method

Summary

Represents method Edit(TComponent,TCustomTeeGrid,TScrollBars).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const AGrid:TCustomTeeGrid;
 const AScrollBars:TScrollBars):Boolean; static;

Parameters

AOwner
Type: TComponent

AGrid
Type: TCustomTeeGrid

AScrollBars
Type: TScrollBars

Return Value

Type: Boolean

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars) Method

Summary

Represents method Embedd(TComponent,TWinControl,TCustomTeeGrid,TScrollBars).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AGrid:TCustomTeeGrid;
 const AScrollBars:TScrollBars):TScrollingEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AGrid
Type: TCustomTeeGrid

AScrollBars
Type: TScrollBars

Return Value

Type: TScrollingEditor

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.RefreshScrolling(TCustomTeeGrid,TScrollBars) Method

Summary

Represents method RefreshScrolling(TCustomTeeGrid,TScrollBars).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
public
 procedure RefreshScrolling(const AGrid:TCustomTeeGrid;
 const AScrollBars:TScrollBars);

Parameters

AGrid
Type: TCustomTeeGrid

AScrollBars
Type: TScrollBars

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.RGModeClick(TObject) Method

Summary

Represents method RGModeClick(TObject).

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 procedure RGModeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor Fields

Fields
Name | Description
CBHoriz | Represents field CBHoriz.
CBHorizScrollBar | Represents field CBHorizScrollBar.
CBScrollBars | Represents field CBScrollBars.
CBVert | Represents field CBVert.
CBVertScrollBar | Represents field CBVertScrollBar.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label5 | Represents field Label5.
LHoriz | Represents field LHoriz.
PageScrolling | Represents field PageScrolling.
RGMode | Represents field RGMode.
TabOptions | Represents field TabOptions.
TabScrollBars | Represents field TabScrollBars.
Top


TScrollingEditor.CBHoriz Field

Summary

Represents field CBHoriz.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 CBHoriz: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBHorizScrollBar Field

Summary

Represents field CBHorizScrollBar.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 CBHorizScrollBar: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBScrollBars Field

Summary

Represents field CBScrollBars.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 CBScrollBars: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBVert Field

Summary

Represents field CBVert.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 CBVert: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.CBVertScrollBar Field

Summary

Represents field CBVertScrollBar.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 CBVertScrollBar: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.LHoriz Field

Summary

Represents field LHoriz.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 LHoriz: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.PageScrolling Field

Summary

Represents field PageScrolling.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 PageScrolling: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.RGMode Field

Summary

Represents field RGMode.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 RGMode: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


TScrollingEditor.TabScrollBars Field

Summary

Represents field TabScrollBars.

Namespace: VCLTee.Editor.Scrolling
Syntax
Delphi
published
 TabScrollBars: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TScrollingEditor
  • VCLTee.Editor.Scrolling


VCLTee.Editor.Selected Namespace

Summary

Represents namespace VCLTee.Editor.Selected.

Classes
Name | Description
TSelectedEditor | Represents type TSelectedEditor.
Top


VCLTee.Editor.Selected Classes

Classes
Name | Description
TSelectedEditor | Represents type TSelectedEditor.
Top


TSelectedEditor Class

Summary

Represents type TSelectedEditor.

Namespace: VCLTee.Editor.Selected
Inheritance Hierarchy
TForm
VCLTee.Editor.Selected.TSelectedEditor
Syntax
Delphi
type
 TSelectedEditor = class(TForm)
 end;

The TSelectedEditor type exposes the following members.

Methods
Show:
Name | Description
CBFullRowClick(TObject) | Represents method CBFullRowClick(TObject).
CBParentFontClick(TObject) | Represents method CBParentFontClick(TObject).
CBRangeClick(TObject) | Represents method CBRangeClick(TObject).
CBScrollToViewClick(TObject) | Represents method CBScrollToViewClick(TObject).
Edit(TComponent,TGridSelection) | Represents method Edit(TComponent,TGridSelection).
Embedd(TComponent,TWinControl,TGridSelection) | Represents method Embedd(TComponent,TWinControl,TGridSelection).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
PageSelectedChange(TObject) | Represents method PageSelectedChange(TObject).
RefreshSelected(TGridSelection) | Represents method RefreshSelected(TGridSelection).
Top
Fields
Show:
Name | Description
CBFullRow | Represents field CBFullRow.
CBParentFont | Represents field CBParentFont.
CBRange | Represents field CBRange.
CBScrollToView | Represents field CBScrollToView.
PageFormat | Represents field PageFormat.
PageSelected | Represents field PageSelected.
Panel2 | Represents field Panel2.
TabFocused | Represents field TabFocused.
TabFormat | Represents field TabFormat.
TabOptions | Represents field TabOptions.
TabUnfocused | Represents field TabUnfocused.
Top
See Also

Reference

  • VCLTee.Editor.Selected


TSelectedEditor Methods

Methods
Name | Description
CBFullRowClick(TObject) | Represents method CBFullRowClick(TObject).
CBParentFontClick(TObject) | Represents method CBParentFontClick(TObject).
CBRangeClick(TObject) | Represents method CBRangeClick(TObject).
CBScrollToViewClick(TObject) | Represents method CBScrollToViewClick(TObject).
Edit(TComponent,TGridSelection) | Represents method Edit(TComponent,TGridSelection).
Embedd(TComponent,TWinControl,TGridSelection) | Represents method Embedd(TComponent,TWinControl,TGridSelection).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageFormatChange(TObject) | Represents method PageFormatChange(TObject).
PageSelectedChange(TObject) | Represents method PageSelectedChange(TObject).
RefreshSelected(TGridSelection) | Represents method RefreshSelected(TGridSelection).
Top


TSelectedEditor.CBFullRowClick(TObject) Method

Summary

Represents method CBFullRowClick(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure CBFullRowClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBParentFontClick(TObject) Method

Summary

Represents method CBParentFontClick(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure CBParentFontClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBRangeClick(TObject) Method

Summary

Represents method CBRangeClick(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure CBRangeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBScrollToViewClick(TObject) Method

Summary

Represents method CBScrollToViewClick(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure CBScrollToViewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.Edit(TComponent,TGridSelection) Method

Summary

Represents method Edit(TComponent,TGridSelection).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ASelected:TGridSelection):Boolean; static;

Parameters

AOwner
Type: TComponent

ASelected
Type: TGridSelection

Return Value

Type: Boolean

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.Embedd(TComponent,TWinControl,TGridSelection) Method

Summary

Represents method Embedd(TComponent,TWinControl,TGridSelection).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ASelected:TGridSelection):TSelectedEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ASelected
Type: TGridSelection

Return Value

Type: TSelectedEditor

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.PageFormatChange(TObject) Method

Summary

Represents method PageFormatChange(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure PageFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.PageSelectedChange(TObject) Method

Summary

Represents method PageSelectedChange(TObject).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 procedure PageSelectedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.RefreshSelected(TGridSelection) Method

Summary

Represents method RefreshSelected(TGridSelection).

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
public
 procedure RefreshSelected(const ASelected:TGridSelection);

Parameters

ASelected
Type: TGridSelection

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor Fields

Fields
Name | Description
CBFullRow | Represents field CBFullRow.
CBParentFont | Represents field CBParentFont.
CBRange | Represents field CBRange.
CBScrollToView | Represents field CBScrollToView.
PageFormat | Represents field PageFormat.
PageSelected | Represents field PageSelected.
Panel2 | Represents field Panel2.
TabFocused | Represents field TabFocused.
TabFormat | Represents field TabFormat.
TabOptions | Represents field TabOptions.
TabUnfocused | Represents field TabUnfocused.
Top


TSelectedEditor.CBFullRow Field

Summary

Represents field CBFullRow.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 CBFullRow: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBParentFont Field

Summary

Represents field CBParentFont.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 CBParentFont: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBRange Field

Summary

Represents field CBRange.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 CBRange: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.CBScrollToView Field

Summary

Represents field CBScrollToView.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 CBScrollToView: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.PageFormat Field

Summary

Represents field PageFormat.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 PageFormat: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.PageSelected Field

Summary

Represents field PageSelected.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 PageSelected: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.TabFocused Field

Summary

Represents field TabFocused.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 TabFocused: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.TabFormat Field

Summary

Represents field TabFormat.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 TabFormat: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


TSelectedEditor.TabUnfocused Field

Summary

Represents field TabUnfocused.

Namespace: VCLTee.Editor.Selected
Syntax
Delphi
published
 TabUnfocused: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectedEditor
  • VCLTee.Editor.Selected


VCLTee.Editor.Stroke Namespace

Summary

Represents namespace VCLTee.Editor.Stroke.

Classes
Name | Description
TStrokeEditor | Represents type TStrokeEditor.
Top


VCLTee.Editor.Stroke Classes

Classes
Name | Description
TStrokeEditor | Represents type TStrokeEditor.
Top


TStrokeEditor Class

Summary

Represents type TStrokeEditor.

Namespace: VCLTee.Editor.Stroke
Inheritance Hierarchy
TForm
VCLTee.Editor.Stroke.TStrokeEditor
Syntax
Delphi
type
 TStrokeEditor = class(TForm)
 end;

The TStrokeEditor type exposes the following members.

Methods
Show:
Name | Description
AddForm(TCustomForm,TWinControl) | Represents method AddForm(TCustomForm,TWinControl).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TStroke) | Represents method Edit(TComponent,TStroke).
Embedd(TComponent,TWinControl,TStroke) | Represents method Embedd(TComponent,TWinControl,TStroke).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBEndStyleClick(TObject) | Represents method LBEndStyleClick(TObject).
LBJoinStyleClick(TObject) | Represents method LBJoinStyleClick(TObject).
LBStyleClick(TObject) | Represents method LBStyleClick(TObject).
PageStrokeChange(TObject) | Represents method PageStrokeChange(TObject).
RefreshStroke(TStroke) | Represents method RefreshStroke(TStroke).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top
Fields
Show:
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBEndStyle | Represents field LBEndStyle.
LBJoinStyle | Represents field LBJoinStyle.
LBStyle | Represents field LBStyle.
LSize | Represents field LSize.
PageStroke | Represents field PageStroke.
TabBrush | Represents field TabBrush.
TabPen | Represents field TabPen.
TabStyle | Represents field TabStyle.
TBSize | Represents field TBSize.
Top
See Also

Reference

  • VCLTee.Editor.Stroke


TStrokeEditor Methods

Methods
Name | Description
AddForm(TCustomForm,TWinControl) | Represents method AddForm(TCustomForm,TWinControl).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
Edit(TComponent,TStroke) | Represents method Edit(TComponent,TStroke).
Embedd(TComponent,TWinControl,TStroke) | Represents method Embedd(TComponent,TWinControl,TStroke).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBEndStyleClick(TObject) | Represents method LBEndStyleClick(TObject).
LBJoinStyleClick(TObject) | Represents method LBJoinStyleClick(TObject).
LBStyleClick(TObject) | Represents method LBStyleClick(TObject).
PageStrokeChange(TObject) | Represents method PageStrokeChange(TObject).
RefreshStroke(TStroke) | Represents method RefreshStroke(TStroke).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top


TStrokeEditor.AddForm(TCustomForm,TWinControl) Method

Summary

Represents method AddForm(TCustomForm,TWinControl).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
public
 class procedure AddForm(const AForm: TCustomForm; const AParent: TWinControl); static;

Parameters

AForm
Type: TCustomForm

AParent
Type: TWinControl

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.CBColorChange(TObject) Method

Summary

Represents method CBColorChange(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure CBColorChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Edit(TComponent,TStroke) Method

Summary

Represents method Edit(TComponent,TStroke).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AStroke:TStroke):Boolean; static;

Parameters

AOwner
Type: TComponent

AStroke
Type: TStroke

Return Value

Type: Boolean

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Embedd(TComponent,TWinControl,TStroke) Method

Summary

Represents method Embedd(TComponent,TWinControl,TStroke).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AStroke:TStroke):TStrokeEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AStroke
Type: TStroke

Return Value

Type: TStrokeEditor

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBEndStyleClick(TObject) Method

Summary

Represents method LBEndStyleClick(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure LBEndStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBJoinStyleClick(TObject) Method

Summary

Represents method LBJoinStyleClick(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure LBJoinStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBStyleClick(TObject) Method

Summary

Represents method LBStyleClick(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure LBStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.PageStrokeChange(TObject) Method

Summary

Represents method PageStrokeChange(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure PageStrokeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.RefreshStroke(TStroke) Method

Summary

Represents method RefreshStroke(TStroke).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
public
 procedure RefreshStroke(const AStroke:TStroke);

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.TBSizeChange(TObject) Method

Summary

Represents method TBSizeChange(TObject).

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 procedure TBSizeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor Fields

Fields
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBEndStyle | Represents field LBEndStyle.
LBJoinStyle | Represents field LBJoinStyle.
LBStyle | Represents field LBStyle.
LSize | Represents field LSize.
PageStroke | Represents field PageStroke.
TabBrush | Represents field TabBrush.
TabPen | Represents field TabPen.
TabStyle | Represents field TabStyle.
TBSize | Represents field TBSize.
Top


TStrokeEditor.CBColor Field

Summary

Represents field CBColor.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 CBColor: TColorBox;

Field Value

Type: TColorBox

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBEndStyle Field

Summary

Represents field LBEndStyle.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 LBEndStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBJoinStyle Field

Summary

Represents field LBJoinStyle.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 LBJoinStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LBStyle Field

Summary

Represents field LBStyle.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 LBStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.LSize Field

Summary

Represents field LSize.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 LSize: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.PageStroke Field

Summary

Represents field PageStroke.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 PageStroke: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.TabBrush Field

Summary

Represents field TabBrush.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 TabBrush: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.TabPen Field

Summary

Represents field TabPen.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 TabPen: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.TabStyle Field

Summary

Represents field TabStyle.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 TabStyle: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


TStrokeEditor.TBSize Field

Summary

Represents field TBSize.

Namespace: VCLTee.Editor.Stroke
Syntax
Delphi
published
 TBSize: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TStrokeEditor
  • VCLTee.Editor.Stroke


VCLTee.Editor.Text.Align Namespace

Summary

Represents namespace VCLTee.Editor.Text.Align.

Classes
Name | Description
TTextAlignEditor | Represents type TTextAlignEditor.
Top


VCLTee.Editor.Text.Align Classes

Classes
Name | Description
TTextAlignEditor | Represents type TTextAlignEditor.
Top


TTextAlignEditor Class

Summary

Represents type TTextAlignEditor.

Namespace: VCLTee.Editor.Text.Align
Inheritance Hierarchy
TForm
VCLTee.Editor.Text.Align.TTextAlignEditor
Syntax
Delphi
type
 TTextAlignEditor = class(TForm)
 end;

The TTextAlignEditor type exposes the following members.

Properties
Show:
Name | Description
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
Edit(TComponent,TTextAlign) | Represents method Edit(TComponent,TTextAlign).
Embedd(TComponent,TWinControl,TTextAlign) | Overloaded. Represents method Embedd(TComponent,TWinControl,TTextAlign).
RefreshAlign(TTextAlign) | Represents method RefreshAlign(TTextAlign).
RGHorizontalClick(TObject) | Represents method RGHorizontalClick(TObject).
RGVerticalClick(TObject) | Represents method RGVerticalClick(TObject).
Top
Fields
Show:
Name | Description
RGHorizontal | Represents field RGHorizontal.
RGVertical | Represents field RGVertical.
Top
See Also

Reference

  • VCLTee.Editor.Text.Align


TTextAlignEditor Properties

Properties
Name | Description
OnChange | Represents property OnChange.
Top


TTextAlignEditor.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor Methods

Methods
Name | Description
Edit(TComponent,TTextAlign) | Represents method Edit(TComponent,TTextAlign).
Embedd(TComponent,TWinControl,TTextAlign) | Overloaded. Represents method Embedd(TComponent,TWinControl,TTextAlign).
RefreshAlign(TTextAlign) | Represents method RefreshAlign(TTextAlign).
RGHorizontalClick(TObject) | Represents method RGHorizontalClick(TObject).
RGVerticalClick(TObject) | Represents method RGVerticalClick(TObject).
Top


TTextAlignEditor.Edit(TComponent,TTextAlign) Method

Summary

Represents method Edit(TComponent,TTextAlign).

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ATextAlign:TTextAlign):Boolean; static;

Parameters

AOwner
Type: TComponent

ATextAlign
Type: TTextAlign

Return Value

Type: Boolean

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor.Embedd(TComponent,TWinControl,TTextAlign) Method

Summary

Represents method Embedd(TComponent,TWinControl,TTextAlign).

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ATextAlign:TTextAlign):TTextAlignEditor; overload; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ATextAlign
Type: TTextAlign

Return Value

Type: TTextAlignEditor

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor.RefreshAlign(TTextAlign) Method

Summary

Represents method RefreshAlign(TTextAlign).

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
public
 procedure RefreshAlign(const ATextAlign:TTextAlign);

Parameters

ATextAlign
Type: TTextAlign

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor.RGHorizontalClick(TObject) Method

Summary

Represents method RGHorizontalClick(TObject).

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
published
 procedure RGHorizontalClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor.RGVerticalClick(TObject) Method

Summary

Represents method RGVerticalClick(TObject).

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
published
 procedure RGVerticalClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor Fields

Fields
Name | Description
RGHorizontal | Represents field RGHorizontal.
RGVertical | Represents field RGVertical.
Top


TTextAlignEditor.RGHorizontal Field

Summary

Represents field RGHorizontal.

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
published
 RGHorizontal: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


TTextAlignEditor.RGVertical Field

Summary

Represents field RGVertical.

Namespace: VCLTee.Editor.Text.Align
Syntax
Delphi
published
 RGVertical: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TTextAlignEditor
  • VCLTee.Editor.Text.Align


VCLTee.Grid Namespace

Summary

Represents namespace VCLTee.Grid.

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCommonCalendarAccess | Represents type TCommonCalendarAccess.
TControlAccess | Represents type TControlAccess.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTeeGrid | Represents type TTeeGrid.
TVCLTeeGrid | Represents type TVCLTeeGrid.
TVirtualDataAccess | Represents type TVirtualDataAccess.
TWinControlAccess | Represents type TWinControlAccess.
Top
Delegates
Name | Description
TCellEditedEvent | Represents type TCellEditedEvent.
TCellEditingEvent | Represents type TCellEditingEvent.
Top
Routines
Name | Description
CursorOf(TCursor) | Overloaded. Represents method CursorOf(TCursor).
CursorOf(TMouseCursor) | Overloaded. Represents method CursorOf(TMouseCursor).
Top


VCLTee.Grid Classes

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCommonCalendarAccess | Represents type TCommonCalendarAccess.
TControlAccess | Represents type TControlAccess.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTeeGrid | Represents type TTeeGrid.
TVCLTeeGrid | Represents type TVCLTeeGrid.
TVirtualDataAccess | Represents type TVirtualDataAccess.
TWinControlAccess | Represents type TWinControlAccess.
Top


TColumnsAccess Class

Summary

Represents type TColumnsAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TColumns
VCLTee.Grid.TColumnsAccess
Syntax
Delphi
type
 TColumnsAccess=class(TColumns);
See Also

Reference

  • VCLTee.Grid


TCommonCalendarAccess Class

Summary

Represents type TCommonCalendarAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TCommonCalendar
VCLTee.Grid.TCommonCalendarAccess
Syntax
Delphi
type
 TCommonCalendarAccess=class(TCommonCalendar);
See Also

Reference

  • VCLTee.Grid


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TControl
VCLTee.Grid.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TControl);
See Also

Reference

  • VCLTee.Grid


TCustomTeeGridAccess Class

Summary

Represents type TCustomTeeGridAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TCustomTeeGrid
VCLTee.Grid.TVCLTeeGrid
VCLTee.Grid.TCustomTeeGridAccess
Syntax
Delphi
type
 TCustomTeeGridAccess=class(TVCLTeeGrid);

The TCustomTeeGridAccess type exposes the following members.

Methods
Show:
Name | Description
CancelEditor | Represents method CancelEditor. (Inherited from TVCLTeeGrid.)
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single). (Inherited from TVCLTeeGrid.)
ContainsFocus | Represents method ContainsFocus. (Inherited from TVCLTeeGrid.)
Copy(TGridSelection) | Represents method Copy(TGridSelection). (Inherited from TVCLTeeGrid.)
DataChanged | Represents method DataChanged. (Inherited from TVCLTeeGrid.)
Height | Represents method Height. (Inherited from TVCLTeeGrid.)
HorizScrollBarHeight | Represents method HorizScrollBarHeight. (Inherited from TVCLTeeGrid.)
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject). (Inherited from TVCLTeeGrid.)
Painter | Represents method Painter. (Inherited from TVCLTeeGrid.)
PasteSelected | Represents method PasteSelected. (Inherited from TVCLTeeGrid.)
StartEditor(TColumn,Integer,String) | Represents method StartEditor(TColumn,Integer,String). (Inherited from TVCLTeeGrid.)
StopEditor | Represents method StopEditor. (Inherited from TVCLTeeGrid.)
VertScrollBarWidth | Represents method VertScrollBarWidth. (Inherited from TVCLTeeGrid.)
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject). (Inherited from TVCLTeeGrid.)
Width | Represents method Width. (Inherited from TVCLTeeGrid.)
Top
See Also

Reference

  • VCLTee.Grid


TRowGroupAccess Class

Summary

Represents type TRowGroupAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TRowGroup
VCLTee.Grid.TRowGroupAccess
Syntax
Delphi
type
 TRowGroupAccess=class(TRowGroup);
See Also

Reference

  • VCLTee.Grid


TRowsAccess Class

Summary

Represents type TRowsAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TRows
VCLTee.Grid.TRowsAccess
Syntax
Delphi
type
 TRowsAccess=class(TRows);
See Also

Reference

  • VCLTee.Grid


TTeeGrid Class

Summary

Represents type TTeeGrid.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TCustomControl
VCLTee.Control.TScrollableControl
VCLTee.Grid.TTeeGrid
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TTeeGrid=class(TScrollableControl)
 end;

The TTeeGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeGrid class. (Overrides TScrollableControl.Create(TComponent).)
Destroy | Represents the destructor of the TTeeGrid class. (Overrides TScrollableControl.Destroy.)
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
Back | Represents property Back.
BiDiMode | Represents property BiDiMode.
Canvas | Represents property Canvas.
Cells | Represents property Cells.
Color | Represents property Color.
Columns | Represents property Columns.
Constraints | Represents property Constraints.
Data | Represents property Data.
DataSource | Represents property DataSource.
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Editing | Represents property Editing.
Enabled | Represents property Enabled.
Footer | Represents property Footer.
Grid | Represents property Grid.
Header | Represents property Header.
Headers | Represents property Headers.
Height | Represents property Height.
Indicator | Represents property Indicator.
Margins | Represents property Margins.
MouseActivity | Represents property MouseActivity.
OnAfterDraw | Represents property OnAfterDraw.
OnAlignInsertBefore | Represents property OnAlignInsertBefore.
OnAlignPosition | Represents property OnAlignPosition.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnClickedHeader | Represents property OnClickedHeader.
OnColumnResized | Represents property OnColumnResized.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseActivate | Represents property OnMouseActivate.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnNewDetail | Represents property OnNewDetail.
OnResize | Represents property OnResize.
OnSelect | Represents property OnSelect.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
Padding | Represents property Padding.
Painter | Represents property Painter.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentDoubleBuffered | Represents property ParentDoubleBuffered.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
Rows | Represents property Rows.
ScrollBars | Represents property ScrollBars.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
ShowHint | Represents property ShowHint.
StyleElements | Represents property StyleElements.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TScrollableControl.Assign(TPersistent).)
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
DblClick | Represents method DblClick.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoChanged(TObject) | Represents method DoChanged(TObject).
DoMouseWheelDown(TShiftState,TPoint) | Represents method DoMouseWheelDown(TShiftState,TPoint).
DoMouseWheelUp(TShiftState,TPoint) | Represents method DoMouseWheelUp(TShiftState,TPoint).
GetMaxBottom | Represents method GetMaxBottom. (Overrides TScrollableControl.GetMaxBottom.)
GetMaxRight | Represents method GetMaxRight. (Overrides TScrollableControl.GetMaxRight.)
GetScrollX | Represents method GetScrollX. (Overrides TScrollableControl.GetScrollX.)
GetScrollY | Represents method GetScrollY. (Overrides TScrollableControl.GetScrollY.)
HorizScrollHeight | Represents method HorizScrollHeight. (Inherited from TScrollableControl.)
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
Loaded | Represents method Loaded.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
PaintWindow(HDC) | Represents method PaintWindow(HDC).
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean). (Overrides TScrollableControl.PerfectScrollBar(Boolean).)
RemainSize(Boolean) | Represents method RemainSize(Boolean). (Inherited from TScrollableControl.)
ResetScrollBars | Represents method ResetScrollBars. (Overrides TScrollableControl.ResetScrollBars.)
SetScrollX(Single) | Represents method SetScrollX(Single). (Overrides TScrollableControl.SetScrollX(Single).)
SetScrollY(Single) | Represents method SetScrollY(Single). (Overrides TScrollableControl.SetScrollY(Single).)
UpdateScroll(Integer,Single) | Represents method UpdateScroll(Integer,Single). (Inherited from TScrollableControl.)
VertScrollWidth | Represents method VertScrollWidth. (Inherited from TScrollableControl.)
Top
Events
Show:
Name | Description
OnCellEdited | Represents property OnCellEdited.
OnCellEditing | Represents property OnCellEditing.
Top
Fields
Show:
Name | Description
IGDIPainter | Represents field IGDIPainter.
Top
See Also

Reference

  • VCLTee.Grid


TTeeGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeGrid class. (Overrides TScrollableControl.Create(TComponent).)
Destroy | Represents the destructor of the TTeeGrid class. (Overrides TScrollableControl.Destroy.)
Top


TTeeGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeGrid class.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TScrollableControl.Create(TComponent)
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Destroy Destructor

Summary

Represents the destructor of the TTeeGrid class.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TScrollableControl.Destroy
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
Back | Represents property Back.
BiDiMode | Represents property BiDiMode.
Canvas | Represents property Canvas.
Cells | Represents property Cells.
Color | Represents property Color.
Columns | Represents property Columns.
Constraints | Represents property Constraints.
Data | Represents property Data.
DataSource | Represents property DataSource.
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Editing | Represents property Editing.
Enabled | Represents property Enabled.
Footer | Represents property Footer.
Grid | Represents property Grid.
Header | Represents property Header.
Headers | Represents property Headers.
Height | Represents property Height.
Indicator | Represents property Indicator.
Margins | Represents property Margins.
MouseActivity | Represents property MouseActivity.
OnAfterDraw | Represents property OnAfterDraw.
OnAlignInsertBefore | Represents property OnAlignInsertBefore.
OnAlignPosition | Represents property OnAlignPosition.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnClickedHeader | Represents property OnClickedHeader.
OnColumnResized | Represents property OnColumnResized.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseActivate | Represents property OnMouseActivate.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnNewDetail | Represents property OnNewDetail.
OnResize | Represents property OnResize.
OnSelect | Represents property OnSelect.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
Padding | Represents property Padding.
Painter | Represents property Painter.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentDoubleBuffered | Represents property ParentDoubleBuffered.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
Rows | Represents property Rows.
ScrollBars | Represents property ScrollBars.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
ShowHint | Represents property ShowHint.
StyleElements | Represents property StyleElements.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TTeeGrid.Align Property

Summary

Represents property Align.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Anchors Property

Summary

Represents property Anchors.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.AutoSize Property

Summary

Represents property AutoSize.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property AutoSize;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Back Property

Summary

Represents property Back.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Back:TFormat read GetBack write SetBack;

Property Value

Type: TFormat

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Canvas Property

Summary

Represents property Canvas.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 property Canvas:TControlCanvas read ICanvas;

Property Value

Type: TControlCanvas

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Cells Property

Summary

Represents property Cells.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Cells:TTextRender read GetCells write SetCells;

Property Value

Type: TTextRender

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Color Property

Summary

Represents property Color.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Color default clWhite;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Columns Property

Summary

Represents property Columns.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Columns:TColumns read GetColumns write SetColumns stored IsColumnsStored;

Property Value

Type: TColumns

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Constraints Property

Summary

Represents property Constraints.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Data Property

Summary

Represents property Data.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 property Data:TVirtualData read GetData write SetData;

Property Value

Type: TVirtualData

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DataSource Property

Summary

Represents property DataSource.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DataSource:TComponent read GetDataSource write SetDataSource;

Property Value

Type: TComponent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DockSite Property

Summary

Represents property DockSite.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DockSite;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DoubleBuffered Property

Summary

Represents property DoubleBuffered.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DoubleBuffered default True;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DragCursor Property

Summary

Represents property DragCursor.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DragKind Property

Summary

Represents property DragKind.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DragMode Property

Summary

Represents property DragMode.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Editing Property

Summary

Represents property Editing.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Editing:TGridEditing read GetEditing write SetEditing;

Property Value

Type: TGridEditing

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Enabled Property

Summary

Represents property Enabled.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Footer Property

Summary

Represents property Footer.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Footer:TGridFooter read GetFooter write SetFooter stored False;

Property Value

Type: TGridFooter

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Grid Property

Summary

Represents property Grid.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 property Grid:TVCLTeeGrid read FGrid;

Property Value

Type: TVCLTeeGrid

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Header Property

Summary

Represents property Header.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Header:TColumnHeaderBand read GetHeader write SetHeader;

Property Value

Type: TColumnHeaderBand

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Headers Property

Summary

Represents property Headers.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Headers:TGridBands read GetHeaders write SetHeaders stored False;

Property Value

Type: TGridBands

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Height Property

Summary

Represents property Height.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Indicator Property

Summary

Represents property Indicator.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Indicator:TIndicator read GetIndicator write SetIndicator;

Property Value

Type: TIndicator

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Margins Property

Summary

Represents property Margins.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.MouseActivity Property

Summary

Represents property MouseActivity.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property MouseActivity:TGridMouseSensitivity read GetMouseActivity write SetMouseActivity;

Property Value

Type: TGridMouseSensitivity

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnAfterDraw Property

Summary

Represents property OnAfterDraw.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnAfterDraw:TNotifyEvent read GetAfterDraw write SetAfterDraw;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnAlignInsertBefore Property

Summary

Represents property OnAlignInsertBefore.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnAlignInsertBefore;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnAlignPosition Property

Summary

Represents property OnAlignPosition.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnAlignPosition;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnCanResize Property

Summary

Represents property OnCanResize.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnCanResize;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnClick Property

Summary

Represents property OnClick.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnClickedHeader Property

Summary

Represents property OnClickedHeader.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnClickedHeader:TNotifyEvent read GetClickedHeader write SetClickedHeader;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnColumnResized Property

Summary

Represents property OnColumnResized.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnColumnResized:TColumnEvent read FOnColumnResized write FOnColumnResized;

Property Value

Type: TColumnEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnConstrainedResize Property

Summary

Represents property OnConstrainedResize.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnConstrainedResize;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnContextPopup Property

Summary

Represents property OnContextPopup.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnContextPopup;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnDockDrop Property

Summary

Represents property OnDockDrop.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnDockDrop;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnDockOver Property

Summary

Represents property OnDockOver.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnDockOver;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnEnter Property

Summary

Represents property OnEnter.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnExit Property

Summary

Represents property OnExit.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnGetSiteInfo Property

Summary

Represents property OnGetSiteInfo.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnGetSiteInfo;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseActivate Property

Summary

Represents property OnMouseActivate.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseActivate;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnNewDetail Property

Summary

Represents property OnNewDetail.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnNewDetail:TNewDetailEvent read GetOnNewDetail write SetOnNewDetail;

Property Value

Type: TNewDetailEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnResize Property

Summary

Represents property OnResize.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnSelect Property

Summary

Represents property OnSelect.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnSelect:TNotifyEvent read GetOnSelect write SetOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnUnDock Property

Summary

Represents property OnUnDock.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnUnDock;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Padding Property

Summary

Represents property Padding.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Painter Property

Summary

Represents property Painter.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 property Painter:TPainter read FPainter write SetPainter;

Property Value

Type: TPainter

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentBackground Property

Summary

Represents property ParentBackground.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentBackground ;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentColor Property

Summary

Represents property ParentColor.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentDoubleBuffered Property

Summary

Represents property ParentDoubleBuffered.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentDoubleBuffered default False;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentFont Property

Summary

Represents property ParentFont.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentFont default false;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Rows Property

Summary

Represents property Rows.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Rows:TRows read GetRows write SetRows;

Property Value

Type: TRows

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ScrollBars;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Scrolling Property

Summary

Represents property Scrolling.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Scrolling:TGridScrolling read GetScrolling write SetScrolling;

Property Value

Type: TGridScrolling

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Selected Property

Summary

Represents property Selected.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Selected:TGridSelection read GetSelected write SetSelected;

Property Value

Type: TGridSelection

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ShowHint Property

Summary

Represents property ShowHint.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.StyleElements Property

Summary

Represents property StyleElements.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property StyleElements;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.TabOrder Property

Summary

Represents property TabOrder.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.TabStop Property

Summary

Represents property TabStop.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property TabStop default True;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.UseDockManager Property

Summary

Represents property UseDockManager.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property UseDockManager default True;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Visible Property

Summary

Represents property Visible.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Width Property

Summary

Represents property Width.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TScrollableControl.Assign(TPersistent).)
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
DblClick | Represents method DblClick.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoChanged(TObject) | Represents method DoChanged(TObject).
DoMouseWheelDown(TShiftState,TPoint) | Represents method DoMouseWheelDown(TShiftState,TPoint).
DoMouseWheelUp(TShiftState,TPoint) | Represents method DoMouseWheelUp(TShiftState,TPoint).
GetMaxBottom | Represents method GetMaxBottom. (Overrides TScrollableControl.GetMaxBottom.)
GetMaxRight | Represents method GetMaxRight. (Overrides TScrollableControl.GetMaxRight.)
GetScrollX | Represents method GetScrollX. (Overrides TScrollableControl.GetScrollX.)
GetScrollY | Represents method GetScrollY. (Overrides TScrollableControl.GetScrollY.)
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
Loaded | Represents method Loaded.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
PaintWindow(HDC) | Represents method PaintWindow(HDC).
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean). (Overrides TScrollableControl.PerfectScrollBar(Boolean).)
ResetScrollBars | Represents method ResetScrollBars. (Overrides TScrollableControl.ResetScrollBars.)
SetScrollX(Single) | Represents method SetScrollX(Single). (Overrides TScrollableControl.SetScrollX(Single).)
SetScrollY(Single) | Represents method SetScrollY(Single). (Overrides TScrollableControl.SetScrollY(Single).)
Top


TTeeGrid.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLTee.Grid
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TScrollableControl.Assign(TPersistent)
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure CMMouseLeave(var Message: TMessage); message CM_MOUSELEAVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DblClick Method

Summary

Represents method DblClick.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure DblClick; override;
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DoChanged(TObject) Method

Summary

Represents method DoChanged(TObject).

Namespace: VCLTee.Grid
Syntax
Delphi
public
 procedure DoChanged(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DoMouseWheelDown(TShiftState,TPoint) Method

Summary

Represents method DoMouseWheelDown(TShiftState,TPoint).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function DoMouseWheelDown(Shift: TShiftState; MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

MousePos
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.DoMouseWheelUp(TShiftState,TPoint) Method

Summary

Represents method DoMouseWheelUp(TShiftState,TPoint).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function DoMouseWheelUp(Shift: TShiftState; MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

MousePos
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.GetMaxBottom Method

Summary

Represents method GetMaxBottom.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function GetMaxBottom:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetMaxBottom
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.GetMaxRight Method

Summary

Represents method GetMaxRight.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function GetMaxRight:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetMaxRight
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.GetScrollX Method

Summary

Represents method GetScrollX.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function GetScrollX:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetScrollX
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.GetScrollY Method

Summary

Represents method GetScrollY.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function GetScrollY:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetScrollY
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.KeyDown(Word,TShiftState) Method

Summary

Represents method KeyDown(Word,TShiftState).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure KeyDown(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.PaintWindow(HDC) Method

Summary

Represents method PaintWindow(HDC).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure PaintWindow(DC: HDC); override;

Parameters

DC
Type: HDC

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.PerfectScrollBar(Boolean) Method

Summary

Represents method PerfectScrollBar(Boolean).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function PerfectScrollBar(const Vertical:Boolean):Boolean; override;

Parameters

Vertical
Type: Boolean

Return Value

Type: Boolean

Overrides

TScrollableControl.PerfectScrollBar(Boolean)
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.ResetScrollBars Method

Summary

Represents method ResetScrollBars.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure ResetScrollBars; override;

Overrides

TScrollableControl.ResetScrollBars
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.SetScrollX(Single) Method

Summary

Represents method SetScrollX(Single).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure SetScrollX(const Value:Single); override;

Parameters

Value
Type: Single

Overrides

TScrollableControl.SetScrollX(Single)
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.SetScrollY(Single) Method

Summary

Represents method SetScrollY(Single).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure SetScrollY(const Value:Single); override;

Parameters

Value
Type: Single

Overrides

TScrollableControl.SetScrollY(Single)
See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid Events

Events
Name | Description
OnCellEdited | Represents property OnCellEdited.
OnCellEditing | Represents property OnCellEditing.
Top


TTeeGrid.OnCellEdited Event

Summary

Represents property OnCellEdited.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnCellEdited:TCellEditedEvent read FOnCellEdited write FOnCellEdited;

Value

Type: TCellEditedEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid.OnCellEditing Event

Summary

Represents property OnCellEditing.

Namespace: VCLTee.Grid
Syntax
Delphi
published
 property OnCellEditing:TCellEditingEvent read FOnCellEditing write FOnCellEditing;

Value

Type: TCellEditingEvent

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TTeeGrid Fields

Fields
Name | Description
IGDIPainter | Represents field IGDIPainter.
Top


TTeeGrid.IGDIPainter Field

Summary

Represents field IGDIPainter.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 IGDIPainter : TWindowsPainter;

Field Value

Type: TWindowsPainter

See Also

Reference

  • TTeeGrid
  • VCLTee.Grid


TVCLTeeGrid Class

Summary

Represents type TVCLTeeGrid.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TCustomTeeGrid
VCLTee.Grid.TVCLTeeGrid
VCLTee.Grid.TCustomTeeGridAccess
Syntax
Delphi
type
 TVCLTeeGrid=class(TCustomTeeGrid)
 end;

The TVCLTeeGrid type exposes the following members.

Methods
Show:
Name | Description
CancelEditor | Represents method CancelEditor.
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
Height | Represents method Height.
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Painter | Represents method Painter.
PasteSelected | Represents method PasteSelected.
StartEditor(TColumn,Integer,String) | Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
Width | Represents method Width.
Top
See Also

Reference

  • VCLTee.Grid


TVCLTeeGrid Methods

Methods
Name | Description
CancelEditor | Represents method CancelEditor.
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
Height | Represents method Height.
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Painter | Represents method Painter.
PasteSelected | Represents method PasteSelected.
StartEditor(TColumn,Integer,String) | Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
Width | Represents method Width.
Top


TVCLTeeGrid.CancelEditor Method

Summary

Represents method CancelEditor.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure CancelEditor; override;
See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.CheckScrollLimits(Single,Single) Method

Summary

Represents method CheckScrollLimits(Single,Single).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure CheckScrollLimits(var X,Y:Single); override;

Parameters

X
Type: Single

Y
Type: Single

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.ContainsFocus Method

Summary

Represents method ContainsFocus.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 Function ContainsFocus :Boolean; Override;

Return Value

Type: Boolean

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.Copy(TGridSelection) Method

Summary

Represents method Copy(TGridSelection).

Namespace: VCLTee.Grid
Syntax
Delphi
public
 procedure Copy(const ASelection:TGridSelection=nil); override;

Parameters

ASelection
Type: TGridSelection

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.DataChanged Method

Summary

Represents method DataChanged.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure DataChanged; override;
See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.Height Method

Summary

Represents method Height.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 function Height:Single; override;

Return Value

Type: Single

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.HorizScrollBarHeight Method

Summary

Represents method HorizScrollBarHeight.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function HorizScrollBarHeight:Single; override;

Return Value

Type: Single

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.HorizScrollChanged(TObject) Method

Summary

Represents method HorizScrollChanged(TObject).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure HorizScrollChanged(Sender:TObject); override;

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.Painter Method

Summary

Represents method Painter.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 function Painter:TPainter; override;

Return Value

Type: TPainter

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.PasteSelected Method

Summary

Represents method PasteSelected.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 procedure PasteSelected; override;
See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.StartEditor(TColumn,Integer,String) Method

Summary

Represents method StartEditor(TColumn,Integer,String).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure StartEditor(const AColumn:TColumn; const ARow:Integer;
 const AutoEdit:String=''); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AutoEdit
Type: String

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.StopEditor Method

Summary

Represents method StopEditor.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure StopEditor; override;
See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.VertScrollBarWidth Method

Summary

Represents method VertScrollBarWidth.

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 function VertScrollBarWidth:Single; override;

Return Value

Type: Single

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.VertScrollChanged(TObject) Method

Summary

Represents method VertScrollChanged(TObject).

Namespace: VCLTee.Grid
Syntax
Delphi
protected
 procedure VertScrollChanged(Sender:TObject); override;

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVCLTeeGrid.Width Method

Summary

Represents method Width.

Namespace: VCLTee.Grid
Syntax
Delphi
public
 function Width:Single; override;

Return Value

Type: Single

See Also

Reference

  • TVCLTeeGrid
  • VCLTee.Grid


TVirtualDataAccess Class

Summary

Represents type TVirtualDataAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TVirtualData
VCLTee.Grid.TVirtualDataAccess
Syntax
Delphi
type
 TVirtualDataAccess=class(TVirtualData);
See Also

Reference

  • VCLTee.Grid


TWinControlAccess Class

Summary

Represents type TWinControlAccess.

Namespace: VCLTee.Grid
Inheritance Hierarchy
TWinControl
VCLTee.Grid.TWinControlAccess
Syntax
Delphi
type
 TWinControlAccess=class(TWinControl);
See Also

Reference

  • VCLTee.Grid


VCLTee.Grid Delegates

Delegates
Name | Description
TCellEditedEvent | Represents type TCellEditedEvent.
TCellEditingEvent | Represents type TCellEditingEvent.
Top


TCellEditedEvent Delegate

Summary

Represents type TCellEditedEvent.

Namespace: VCLTee.Grid
Syntax
Delphi
type
 TCellEditedEvent=procedure(const Sender:TObject; const AEditor:TControl;
 const AColumn:TColumn; const ARow:Integer;
 var ChangeData:Boolean;
 var NewData:String) of object;
See Also

Reference

  • VCLTee.Grid


TCellEditingEvent Delegate

Summary

Represents type TCellEditingEvent.

Namespace: VCLTee.Grid
Syntax
Delphi
type
 TCellEditingEvent=procedure(const Sender:TObject; const AEditor:TControl;
 const AColumn:TColumn; const ARow:Integer) of object;
See Also

Reference

  • VCLTee.Grid


VCLTee.Grid Routines

Routines
Name | Description
CursorOf(TCursor) | Overloaded. Represents method CursorOf(TCursor).
CursorOf(TMouseCursor) | Overloaded. Represents method CursorOf(TMouseCursor).
Top


CursorOf(TCursor) Method

Summary

Represents method CursorOf(TCursor).

Namespace: VCLTee.Grid
Syntax
Delphi
function CursorOf(const ACursor:TCursor):TMouseCursor; overload;

Parameters

ACursor
Type: TCursor

Return Value

Type: TMouseCursor

See Also

Reference

  • VCLTee.Grid


CursorOf(TMouseCursor) Method

Summary

Represents method CursorOf(TMouseCursor).

Namespace: VCLTee.Grid
Syntax
Delphi
function CursorOf(const ACursor:TMouseCursor):TCursor; overload;

Parameters

ACursor
Type: TMouseCursor

Return Value

Type: TCursor

See Also

Reference

  • VCLTee.Grid


VCLTee.Grid.Layout Namespace

Summary

Represents namespace VCLTee.Grid.Layout.

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridLayout | Represents type TGridLayout.
TLocalCols | Represents type TLocalCols.
TWriterAccess | Represents type TWriterAccess.
Top
Variables
Name | Description
ColumnMoves | Represents variable ColumnMoves.
CurNode | Represents variable CurNode.
Layout | Represents variable Layout.
ParentNode | Represents variable ParentNode.
RootNode | Represents variable RootNode.
XMLDoc | Represents variable XMLDoc.
Top


VCLTee.Grid.Layout Classes

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridLayout | Represents type TGridLayout.
TLocalCols | Represents type TLocalCols.
TWriterAccess | Represents type TWriterAccess.
Top


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: VCLTee.Grid.Layout
Inheritance Hierarchy
TColumn
VCLTee.Grid.Layout.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);
See Also

Reference

  • VCLTee.Grid.Layout


TGridLayout Class

Summary

Represents type TGridLayout.

Namespace: VCLTee.Grid.Layout
Inheritance Hierarchy
TObject
VCLTee.Grid.Layout.TGridLayout
Syntax
Delphi
type
 TGridLayout = class
 end;

The TGridLayout type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGridLayout class.
Top
Methods
Show:
Name | Description
LoadFromFile(TTeeGrid,String) | Represents method LoadFromFile(TTeeGrid,String).
LoadFromStrings(TTeeGrid,TStrings) | Represents method LoadFromStrings(TTeeGrid,TStrings).
SaveToFile(TTeeGrid,String) | Represents method SaveToFile(TTeeGrid,String).
SaveToStrings(TTeeGrid) | Represents method SaveToStrings(TTeeGrid).
SaveXML(TTeeGrid,String) | Represents method SaveXML(TTeeGrid,String).
Top
See Also

Reference

  • VCLTee.Grid.Layout


TGridLayout Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGridLayout class.
Top


TGridLayout.Create Constructor

Summary

Initializes a new instance of the TGridLayout class.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TGridLayout Methods

Methods
Name | Description
LoadFromFile(TTeeGrid,String) | Represents method LoadFromFile(TTeeGrid,String).
LoadFromStrings(TTeeGrid,TStrings) | Represents method LoadFromStrings(TTeeGrid,TStrings).
SaveToFile(TTeeGrid,String) | Represents method SaveToFile(TTeeGrid,String).
SaveToStrings(TTeeGrid) | Represents method SaveToStrings(TTeeGrid).
SaveXML(TTeeGrid,String) | Represents method SaveXML(TTeeGrid,String).
Top


TGridLayout.LoadFromFile(TTeeGrid,String) Method

Summary

Represents method LoadFromFile(TTeeGrid,String).

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
public
 procedure LoadFromFile(AGrid : TTeeGrid; Filename: String);

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TGridLayout.LoadFromStrings(TTeeGrid,TStrings) Method

Summary

Represents method LoadFromStrings(TTeeGrid,TStrings).

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
public
 procedure LoadFromStrings(AGrid : TTeeGrid; AStrings: TStrings);

Parameters

AGrid
Type: TTeeGrid

AStrings
Type: TStrings

See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TGridLayout.SaveToFile(TTeeGrid,String) Method

Summary

Represents method SaveToFile(TTeeGrid,String).

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
public
 procedure SaveToFile(AGrid : TTeeGrid; Filename: String);

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TGridLayout.SaveToStrings(TTeeGrid) Method

Summary

Represents method SaveToStrings(TTeeGrid).

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
public
 function SaveToStrings(AGrid : TTeeGrid) : TStringList;

Parameters

AGrid
Type: TTeeGrid

Return Value

Type: TStringList

See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TGridLayout.SaveXML(TTeeGrid,String) Method

Summary

Represents method SaveXML(TTeeGrid,String).

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
protected
 function SaveXML(AGrid : TTeeGrid; Filename: String): TStringList;

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

Return Value

Type: TStringList

See Also

Reference

  • TGridLayout
  • VCLTee.Grid.Layout


TLocalCols Class

Summary

Represents type TLocalCols.

Namespace: VCLTee.Grid.Layout
Inheritance Hierarchy
TColumns
VCLTee.Grid.Layout.TLocalCols
Syntax
Delphi
type
 TLocalCols = class(TColumns);
See Also

Reference

  • VCLTee.Grid.Layout


TWriterAccess Class

Summary

Represents type TWriterAccess.

Namespace: VCLTee.Grid.Layout
Inheritance Hierarchy
TWriter
VCLTee.Grid.Layout.TWriterAccess
Syntax
Delphi
type
 TWriterAccess=class(TWriter);
See Also

Reference

  • VCLTee.Grid.Layout


VCLTee.Grid.Layout Variables

Variables
Name | Description
ColumnMoves | Represents variable ColumnMoves.
CurNode | Represents variable CurNode.
Layout | Represents variable Layout.
ParentNode | Represents variable ParentNode.
RootNode | Represents variable RootNode.
XMLDoc | Represents variable XMLDoc.
Top


ColumnMoves Variable

Summary

Represents variable ColumnMoves.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
ColumnMoves : Array of String;

Value

Type: Array of String

See Also

Reference

  • VCLTee.Grid.Layout


CurNode Variable

Summary

Represents variable CurNode.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • VCLTee.Grid.Layout


Layout Variable

Summary

Represents variable Layout.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
Layout: TGridLayout;

Value

Type: TGridLayout

See Also

Reference

  • VCLTee.Grid.Layout


ParentNode Variable

Summary

Represents variable ParentNode.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • VCLTee.Grid.Layout


RootNode Variable

Summary

Represents variable RootNode.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • VCLTee.Grid.Layout


XMLDoc Variable

Summary

Represents variable XMLDoc.

Namespace: VCLTee.Grid.Layout
Syntax
Delphi
XMLDoc :TXMLDocument;

Value

Type: TXMLDocument

See Also

Reference

  • VCLTee.Grid.Layout


VCLTee.Grid.Themes Namespace

Summary

Represents namespace VCLTee.Grid.Themes.

Records
Name | Description
TVCLGridThemes | Represents type TVCLGridThemes.
Top


VCLTee.Grid.Themes Records

Records
Name | Description
TVCLGridThemes | Represents type TVCLGridThemes.
Top


TVCLGridThemes Record

Summary

Represents type TVCLGridThemes.

Namespace: VCLTee.Grid.Themes
Syntax
Delphi
type
 TVCLGridThemes=record
 end;

The TVCLGridThemes type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TTeeGrid) | Represents method ApplyTo(TTeeGrid).
Available(TStrings) | Represents method Available(TStrings).
Top
See Also

Reference

  • VCLTee.Grid.Themes


TVCLGridThemes Methods

Methods
Name | Description
ApplyTo(TTeeGrid) | Represents method ApplyTo(TTeeGrid).
Available(TStrings) | Represents method Available(TStrings).
Top


TVCLGridThemes.ApplyTo(TTeeGrid) Method

Summary

Represents method ApplyTo(TTeeGrid).

Namespace: VCLTee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TTeeGrid); static;

Parameters

AGrid
Type: TTeeGrid

See Also

Reference

  • TVCLGridThemes
  • VCLTee.Grid.Themes


TVCLGridThemes.Available(TStrings) Method

Summary

Represents method Available(TStrings).

Namespace: VCLTee.Grid.Themes
Syntax
Delphi
public
 class procedure Available(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TVCLGridThemes
  • VCLTee.Grid.Themes


VCLTee.Painter Namespace

Summary

Represents namespace VCLTee.Painter.

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TGDIPainter | Represents type TGDIPainter.
TPictureAccess | Represents type TPictureAccess.
TWindowsPainter | Represents type TWindowsPainter.
Top
Types
Name | Description
TPoints | Represents an array of the TPoint type.
TTeeFont | Represents an alias of the TFont type.
TVCLGraphic | Represents an alias of the Graphics type.
TVCLPicture | Represents an alias of the Graphics type.
Top
Routines
Name | Description
FixRect(TRectF) | Represents method FixRect(TRectF).
RoundPoints(TPointsF) | Represents method RoundPoints(TPointsF).
SetDefaultFontNameAndSize | Represents method SetDefaultFontNameAndSize.
Top


VCLTee.Painter Classes

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TGDIPainter | Represents type TGDIPainter.
TPictureAccess | Represents type TPictureAccess.
TWindowsPainter | Represents type TWindowsPainter.
Top


TBrushAccess Class

Summary

Represents type TBrushAccess.

Namespace: VCLTee.Painter
Inheritance Hierarchy
TBrush
VCLTee.Painter.TBrushAccess
Syntax
Delphi
type
 TBrushAccess=class(TBrush);
See Also

Reference

  • VCLTee.Painter


TGDIPainter Class

Summary

Represents type TGDIPainter.

Namespace: VCLTee.Painter
Inheritance Hierarchy
TPainter
VCLTee.Painter.TWindowsPainter
VCLTee.Painter.TGDIPainter
Syntax
Delphi
type
 TGDIPainter=class(TWindowsPainter)
 end;

The TGDIPainter type exposes the following members.

Constructors
Show:
Name | Description
Create(TCanvas) | Initializes a new instance of the TWindowsPainter class. (Inherited from TWindowsPainter.)
Top
Properties
Show:
Name | Description
Canvas | Represents property Canvas. (Inherited from TWindowsPainter.)
Top
Methods
Show:
Name | Description
ApplyFont(TTeeFont,Graphics) | Represents method ApplyFont(TTeeFont,Graphics).
Clip(TRect) | Overloaded. Represents method Clip(TRect).
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Init(HDC) | Represents method Init(HDC). (Inherited from TWindowsPainter.)
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top
Fields
Show:
Name | Description
ICanvas | Represents field ICanvas. (Inherited from TWindowsPainter.)
IDC | Represents field IDC. (Inherited from TWindowsPainter.)
Top
See Also

Reference

  • VCLTee.Painter


TGDIPainter Methods

Methods
Name | Description
ApplyFont(TTeeFont,Graphics) | Represents method ApplyFont(TTeeFont,Graphics).
Clip(TRect) | Overloaded. Represents method Clip(TRect).
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top


TGDIPainter.ApplyFont(TTeeFont,Graphics) Method

Summary

Represents method ApplyFont(TTeeFont,Graphics).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 class procedure ApplyFont(const ASource:TTeeFont; const ADest:Graphics.TFont); static;

Parameters

ASource
Type: System.Void

ADest
Type: Graphics.TFont

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Clip(TRect) Method

Summary

Represents method Clip(TRect).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Clip(const R:TRect); overload;

Parameters

R
Type: TRect

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Clip(TRectF) Method

Summary

Represents method Clip(TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Clip(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Draw(TPicture,Single,Single) Method

Summary

Represents method Draw(TPicture,Single,Single).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const X,Y:Single); overload; override;

Parameters

APicture
Type: TPicture

X
Type: Single

Y
Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Draw(TPicture,TRectF) Method

Summary

Represents method Draw(TPicture,TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const R:TRectF); overload; override;

Parameters

APicture
Type: TPicture

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Draw(TRectF) Method

Summary

Represents method Draw(TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Draw(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.DrawEllipse(TRectF) Method

Summary

Represents method DrawEllipse(TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure DrawEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Fill(TRectF,TColor) Method

Summary

Represents method Fill(TRectF,TColor).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Fill(const R:TRectF; const AColor:TColor); override;

Parameters

R
Type: TRectF

AColor
Type: TColor

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.FillEllipse(TRectF) Method

Summary

Represents method FillEllipse(TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure FillEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.HideBrush Method

Summary

Represents method HideBrush.

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure HideBrush; override;
See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.HorizontalLine(Single,Single,Single) Method

Summary

Represents method HorizontalLine(Single,Single,Single).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure HorizontalLine(const Y,X0,X1:Single); override;

Parameters

Y
Type: Single

X0
Type: Single

X1
Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Line(Single,Single,Single,Single) Method

Summary

Represents method Line(Single,Single,Single,Single).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Line(const X0,Y0,X1,Y1:Single); override;

Parameters

X0
Type: Single

Y0
Type: Single

X1
Type: Single

Y1
Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Lines(TPointsF) Method

Summary

Represents method Lines(TPointsF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Lines(const P:TPointsF); override;

Parameters

P
Type: TPointsF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.Paint(TFormat,TRectF) Method

Summary

Represents method Paint(TFormat,TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Paint(const AFormat: TFormat; const R: TRectF); override;

Parameters

AFormat
Type: TFormat

R
Type: TRectF

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetBrush(TBrush) Method

Summary

Represents method SetBrush(TBrush).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetBrush(const ABrush:TBrush); override;

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetFont(const AFont:TFont); override;

Parameters

AFont
Type: TFont

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetFontColor(TColor) Method

Summary

Represents method SetFontColor(TColor).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetFontColor(const AColor:TColor); override;

Parameters

AColor
Type: TColor

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetHorizontalAlign(THorizontalAlign) Method

Summary

Represents method SetHorizontalAlign(THorizontalAlign).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetHorizontalAlign(const Value:THorizontalAlign); override;

Parameters

Value
Type: THorizontalAlign

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetStroke(TStroke) Method

Summary

Represents method SetStroke(TStroke).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetStroke(const AStroke:TStroke); override;

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetTextTrimming(TTrimmingMode,Boolean) Method

Summary

Represents method SetTextTrimming(TTrimmingMode,Boolean).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetTextTrimming(const ATrimming:TTrimmingMode; const Ellipsi:Boolean); override;

Parameters

ATrimming
Type: TTrimmingMode

Ellipsi
Type: Boolean

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.SetVerticalAlign(TVerticalAlign) Method

Summary

Represents method SetVerticalAlign(TVerticalAlign).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure SetVerticalAlign(const Value:TVerticalAlign); override;

Parameters

Value
Type: TVerticalAlign

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.TextHeight(String) Method

Summary

Represents method TextHeight(String).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 function TextHeight(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.TextOut(TRectF,String) Method

Summary

Represents method TextOut(TRectF,String).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure TextOut(const ARect:TRectF; const AText:String); override;

Parameters

ARect
Type: TRectF

AText
Type: String

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.TextWidth(String) Method

Summary

Represents method TextWidth(String).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 function TextWidth(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.UnClip Method

Summary

Represents method UnClip.

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure UnClip; override;
See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TGDIPainter.VerticalLine(Single,Single,Single) Method

Summary

Represents method VerticalLine(Single,Single,Single).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure VerticalLine(const X,Y0,Y1:Single); override;

Parameters

X
Type: Single

Y0
Type: Single

Y1
Type: Single

See Also

Reference

  • TGDIPainter
  • VCLTee.Painter


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: VCLTee.Painter
Inheritance Hierarchy
TPicture
VCLTee.Painter.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • VCLTee.Painter


TWindowsPainter Class

Summary

Represents type TWindowsPainter.

Namespace: VCLTee.Painter
Inheritance Hierarchy
TPainter
VCLTee.Painter.TWindowsPainter
VCLTee.Painter.GdiPlus.TGdiPlusPainter
VCLTee.Painter.TGDIPainter
Syntax
Delphi
type
 TWindowsPainter=class(TPainter)
 end;

The TWindowsPainter type exposes the following members.

Constructors
Show:
Name | Description
Create(TCanvas) | Initializes a new instance of the TWindowsPainter class.
Top
Properties
Show:
Name | Description
Canvas | Represents property Canvas.
Top
Methods
Show:
Name | Description
Init(HDC) | Represents method Init(HDC).
Top
Fields
Show:
Name | Description
ICanvas | Represents field ICanvas.
IDC | Represents field IDC.
Top
See Also

Reference

  • VCLTee.Painter


TWindowsPainter Constructors

Constructors
Name | Description
Create(TCanvas) | Initializes a new instance of the TWindowsPainter class.
Top


TWindowsPainter.Create(TCanvas) Constructor

Summary

Initializes a new instance of the TWindowsPainter class.

Namespace: VCLTee.Painter
Syntax
Delphi
public
 Constructor Create(const ACanvas:TCanvas);

Parameters

ACanvas
Type: TCanvas

See Also

Reference

  • TWindowsPainter
  • VCLTee.Painter


TWindowsPainter Properties

Properties
Name | Description
Canvas | Represents property Canvas.
Top


TWindowsPainter.Canvas Property

Summary

Represents property Canvas.

Namespace: VCLTee.Painter
Syntax
Delphi
public
 property Canvas:TCanvas read ICanvas;

Property Value

Type: TCanvas

See Also

Reference

  • TWindowsPainter
  • VCLTee.Painter


TWindowsPainter Methods

Methods
Name | Description
Init(HDC) | Represents method Init(HDC).
Top


TWindowsPainter.Init(HDC) Method

Summary

Represents method Init(HDC).

Namespace: VCLTee.Painter
Syntax
Delphi
public
 procedure Init(const DC:HDC); virtual;

Parameters

DC
Type: HDC

See Also

Reference

  • TWindowsPainter
  • VCLTee.Painter


TWindowsPainter Fields

Fields
Name | Description
ICanvas | Represents field ICanvas.
IDC | Represents field IDC.
Top


TWindowsPainter.ICanvas Field

Summary

Represents field ICanvas.

Namespace: VCLTee.Painter
Syntax
Delphi
protected
 ICanvas : TCanvas;

Field Value

Type: TCanvas

See Also

Reference

  • TWindowsPainter
  • VCLTee.Painter


TWindowsPainter.IDC Field

Summary

Represents field IDC.

Namespace: VCLTee.Painter
Syntax
Delphi
protected
 IDC : HDC;

Field Value

Type: HDC

See Also

Reference

  • TWindowsPainter
  • VCLTee.Painter


VCLTee.Painter Types

Types
Name | Description
TPoints | Represents an array of the TPoint type.
TTeeFont | Represents an alias of the TFont type.
TVCLGraphic | Represents an alias of the Graphics type.
TVCLPicture | Represents an alias of the Graphics type.
Top


TPoints Type

Summary

Represents an array of the TPoint type.

Namespace: VCLTee.Painter
Syntax
Delphi
type
 TPoints=Array of TPoint;
See Also

Reference

  • VCLTee.Painter


TTeeFont Type

Summary

Represents an alias of the TFont type.

Namespace: VCLTee.Painter
Syntax
Delphi
type
 TTeeFont=Tee.Format.TFont;
See Also

Reference

  • VCLTee.Painter


TVCLGraphic Type

Summary

Represents an alias of the Graphics type.

Namespace: VCLTee.Painter
Syntax
Delphi
type
 TVCLGraphic=Graphics.TGraphic;
See Also

Reference

  • VCLTee.Painter


TVCLPicture Type

Summary

Represents an alias of the Graphics type.

Namespace: VCLTee.Painter
Syntax
Delphi
type
 TVCLPicture=Graphics.TPicture;
See Also

Reference

  • VCLTee.Painter


VCLTee.Painter Routines

Routines
Name | Description
FixRect(TRectF) | Represents method FixRect(TRectF).
RoundPoints(TPointsF) | Represents method RoundPoints(TPointsF).
SetDefaultFontNameAndSize | Represents method SetDefaultFontNameAndSize.
Top


FixRect(TRectF) Method

Summary

Represents method FixRect(TRectF).

Namespace: VCLTee.Painter
Syntax
Delphi
function FixRect(const R:TRectF):TRect;

Parameters

R
Type: TRectF

Return Value

Type: TRect

See Also

Reference

  • VCLTee.Painter


RoundPoints(TPointsF) Method

Summary

Represents method RoundPoints(TPointsF).

Namespace: VCLTee.Painter
Syntax
Delphi
function RoundPoints(const P:TPointsF):TPoints;

Parameters

P
Type: TPointsF

Return Value

Type: TPoints

See Also

Reference

  • VCLTee.Painter


SetDefaultFontNameAndSize Method

Summary

Represents method SetDefaultFontNameAndSize.

Namespace: VCLTee.Painter
Syntax
Delphi
procedure SetDefaultFontNameAndSize;
See Also

Reference

  • VCLTee.Painter


VCLTee.Painter.GdiPlus Namespace

Summary

Represents namespace VCLTee.Painter.GdiPlus.

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TGdiPlusPainter | Represents type TGdiPlusPainter.
TPictureAccess | Represents type TPictureAccess.
Top
Types
Name | Description
TVCLGraphic | Represents an alias of the Graphics type.
TVCLPicture | Represents an alias of the Graphics type.
Top
Constants
Name | Description
ZeroPoint | Represents constant ZeroPoint.
Top
Routines
Name | Description
BitmapFrom(TGraphic) | Overloaded. Represents method BitmapFrom(TGraphic).
BitmapFrom(TIcon) | Overloaded. Represents method BitmapFrom(TIcon).
GDIPColor(TColor) | Represents method GDIPColor(TColor).
GPRectF(TRectF) | Represents method GPRectF(TRectF).
GraphicFrom(TObject) | Represents method GraphicFrom(TObject).
InflateRectF(TGPRectF,Single,Single) | Represents method InflateRectF(TGPRectF,Single,Single).
RectCenterF(TGPRectF) | Represents method RectCenterF(TGPRectF).
Top


VCLTee.Painter.GdiPlus Classes

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TGdiPlusPainter | Represents type TGdiPlusPainter.
TPictureAccess | Represents type TPictureAccess.
Top


TBrushAccess Class

Summary

Represents type TBrushAccess.

Namespace: VCLTee.Painter.GdiPlus
Inheritance Hierarchy
TBrush
VCLTee.Painter.GdiPlus.TBrushAccess
Syntax
Delphi
type
 TBrushAccess=class(TBrush);
See Also

Reference

  • VCLTee.Painter.GdiPlus


TGdiPlusPainter Class

Summary

Represents type TGdiPlusPainter.

Namespace: VCLTee.Painter.GdiPlus
Inheritance Hierarchy
TPainter
VCLTee.Painter.TWindowsPainter
VCLTee.Painter.GdiPlus.TGdiPlusPainter
Syntax
Delphi
type
 TGdiPlusPainter=class(TWindowsPainter)
 end;

The TGdiPlusPainter type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGdiPlusPainter class.
Destroy | Represents the destructor of the TGdiPlusPainter class.
Top
Properties
Show:
Name | Description
Canvas | Represents property Canvas.
ParentFont | Represents property ParentFont.
SmoothMode | Represents property SmoothMode.
StringFormat | Represents property StringFormat.
TextQuality | Represents property TextQuality.
Top
Methods
Show:
Name | Description
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Init(HDC) | Represents method Init(HDC). (Overrides TWindowsPainter.Init(HDC).)
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top
Fields
Show:
Name | Description
ICanvas | Represents field ICanvas. (Inherited from TWindowsPainter.)
IDC | Represents field IDC. (Inherited from TWindowsPainter.)
Top
See Also

Reference

  • VCLTee.Painter.GdiPlus


TGdiPlusPainter Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGdiPlusPainter class.
Destroy | Represents the destructor of the TGdiPlusPainter class.
Top


TGdiPlusPainter.Create Constructor

Summary

Initializes a new instance of the TGdiPlusPainter class.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Destroy Destructor

Summary

Represents the destructor of the TGdiPlusPainter class.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter Properties

Properties
Name | Description
Canvas | Represents property Canvas.
ParentFont | Represents property ParentFont.
SmoothMode | Represents property SmoothMode.
StringFormat | Represents property StringFormat.
TextQuality | Represents property TextQuality.
Top


TGdiPlusPainter.Canvas Property

Summary

Represents property Canvas.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 property Canvas:TGPGraphics read GetCanvas;

Property Value

Type: TGPGraphics

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.ParentFont Property

Summary

Represents property ParentFont.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 property ParentFont:Boolean read IParentFont write IParentFont;

Property Value

Type: Boolean

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SmoothMode Property

Summary

Represents property SmoothMode.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 property SmoothMode:TSmoothingMode read FSmoothingMode write SetSmoothingMode
 default SmoothingModeHighQuality;

Property Value

Type: TSmoothingMode

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.StringFormat Property

Summary

Represents property StringFormat.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 property StringFormat:TGpStringFormat read IStringFormat write IStringFormat;

Property Value

Type: TGpStringFormat

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.TextQuality Property

Summary

Represents property TextQuality.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 property TextQuality:TTextRenderingHint read FTextQuality write SetTextQuality
 default TextRenderingHintClearTypeGridFit;

Property Value

Type: TTextRenderingHint

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter Methods

Methods
Name | Description
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Overloaded. Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Overloaded. Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Init(HDC) | Represents method Init(HDC). (Overrides TWindowsPainter.Init(HDC).)
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top


TGdiPlusPainter.Clip(TRectF) Method

Summary

Represents method Clip(TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Clip(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Draw(TPicture,Single,Single) Method

Summary

Represents method Draw(TPicture,Single,Single).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const X,Y:Single); overload; override;

Parameters

APicture
Type: TPicture

X
Type: Single

Y
Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Draw(TPicture,TRectF) Method

Summary

Represents method Draw(TPicture,TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Draw(const APicture:TPicture; const R:TRectF); overload; override;

Parameters

APicture
Type: TPicture

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Draw(TRectF) Method

Summary

Represents method Draw(TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Draw(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.DrawEllipse(TRectF) Method

Summary

Represents method DrawEllipse(TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure DrawEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Fill(TRectF,TColor) Method

Summary

Represents method Fill(TRectF,TColor).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Fill(const R:TRectF; const AColor:TColor); override;

Parameters

R
Type: TRectF

AColor
Type: TColor

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.FillEllipse(TRectF) Method

Summary

Represents method FillEllipse(TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure FillEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.HideBrush Method

Summary

Represents method HideBrush.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure HideBrush; override;
See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.HorizontalLine(Single,Single,Single) Method

Summary

Represents method HorizontalLine(Single,Single,Single).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure HorizontalLine(const Y,X0,X1:Single); override;

Parameters

Y
Type: Single

X0
Type: Single

X1
Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Init(HDC) Method

Summary

Represents method Init(HDC).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Init(const DC:HDC); override;

Parameters

DC
Type: HDC

Overrides

TWindowsPainter.Init(HDC)
See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Line(Single,Single,Single,Single) Method

Summary

Represents method Line(Single,Single,Single,Single).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Line(const X0,Y0,X1,Y1:Single); override;

Parameters

X0
Type: Single

Y0
Type: Single

X1
Type: Single

Y1
Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Lines(TPointsF) Method

Summary

Represents method Lines(TPointsF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Lines(const P:TPointsF); override;

Parameters

P
Type: TPointsF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.Paint(TFormat,TRectF) Method

Summary

Represents method Paint(TFormat,TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure Paint(const AFormat:TFormat; const R:TRectF); override;

Parameters

AFormat
Type: TFormat

R
Type: TRectF

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetBrush(TBrush) Method

Summary

Represents method SetBrush(TBrush).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetBrush(const ABrush:TBrush); override;

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetFont(const AFont:TFont); override;

Parameters

AFont
Type: TFont

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetFontColor(TColor) Method

Summary

Represents method SetFontColor(TColor).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetFontColor(const AColor:TColor); override;

Parameters

AColor
Type: TColor

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetHorizontalAlign(THorizontalAlign) Method

Summary

Represents method SetHorizontalAlign(THorizontalAlign).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetHorizontalAlign(const Align:THorizontalAlign); override;

Parameters

Align
Type: THorizontalAlign

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetStroke(TStroke) Method

Summary

Represents method SetStroke(TStroke).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetStroke(const AStroke:TStroke); override;

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetTextTrimming(TTrimmingMode,Boolean) Method

Summary

Represents method SetTextTrimming(TTrimmingMode,Boolean).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetTextTrimming(const ATrimming:TTrimmingMode; const Ellipsi:Boolean); override;

Parameters

ATrimming
Type: TTrimmingMode

Ellipsi
Type: Boolean

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.SetVerticalAlign(TVerticalAlign) Method

Summary

Represents method SetVerticalAlign(TVerticalAlign).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure SetVerticalAlign(const Align:TVerticalAlign); override;

Parameters

Align
Type: TVerticalAlign

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.TextHeight(String) Method

Summary

Represents method TextHeight(String).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 function TextHeight(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.TextOut(TRectF,String) Method

Summary

Represents method TextOut(TRectF,String).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure TextOut(const ARect:TRectF; const AText:String); override;

Parameters

ARect
Type: TRectF

AText
Type: String

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.TextWidth(String) Method

Summary

Represents method TextWidth(String).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 function TextWidth(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.UnClip Method

Summary

Represents method UnClip.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure UnClip; override;
See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TGdiPlusPainter.VerticalLine(Single,Single,Single) Method

Summary

Represents method VerticalLine(Single,Single,Single).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
public
 procedure VerticalLine(const X,Y0,Y1:Single); override;

Parameters

X
Type: Single

Y0
Type: Single

Y1
Type: Single

See Also

Reference

  • TGdiPlusPainter
  • VCLTee.Painter.GdiPlus


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: VCLTee.Painter.GdiPlus
Inheritance Hierarchy
TPicture
VCLTee.Painter.GdiPlus.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • VCLTee.Painter.GdiPlus


VCLTee.Painter.GdiPlus Types

Types
Name | Description
TVCLGraphic | Represents an alias of the Graphics type.
TVCLPicture | Represents an alias of the Graphics type.
Top


TVCLGraphic Type

Summary

Represents an alias of the Graphics type.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
type
 TVCLGraphic=Graphics.TGraphic;
See Also

Reference

  • VCLTee.Painter.GdiPlus


TVCLPicture Type

Summary

Represents an alias of the Graphics type.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
type
 TVCLPicture=Graphics.TPicture;
See Also

Reference

  • VCLTee.Painter.GdiPlus


VCLTee.Painter.GdiPlus Constants

Constants
Name | Description
ZeroPoint | Represents constant ZeroPoint.
Top


ZeroPoint Constant

Summary

Represents constant ZeroPoint.

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
 ZeroPoint:TGPPointF=(X:0; Y:0);

Value

Type: TGPPointF

See Also

Reference

  • VCLTee.Painter.GdiPlus


VCLTee.Painter.GdiPlus Routines

Routines
Name | Description
BitmapFrom(TGraphic) | Overloaded. Represents method BitmapFrom(TGraphic).
BitmapFrom(TIcon) | Overloaded. Represents method BitmapFrom(TIcon).
GDIPColor(TColor) | Represents method GDIPColor(TColor).
GPRectF(TRectF) | Represents method GPRectF(TRectF).
GraphicFrom(TObject) | Represents method GraphicFrom(TObject).
InflateRectF(TGPRectF,Single,Single) | Represents method InflateRectF(TGPRectF,Single,Single).
RectCenterF(TGPRectF) | Represents method RectCenterF(TGPRectF).
Top


BitmapFrom(TGraphic) Method

Summary

Represents method BitmapFrom(TGraphic).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function BitmapFrom(const AGraphic:TGraphic):TBitmap; overload;

Parameters

AGraphic
Type: TGraphic

Return Value

Type: TBitmap

See Also

Reference

  • VCLTee.Painter.GdiPlus


BitmapFrom(TIcon) Method

Summary

Represents method BitmapFrom(TIcon).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function BitmapFrom(const AIcon:TIcon):TBitmap; overload;

Parameters

AIcon
Type: TIcon

Return Value

Type: TBitmap

See Also

Reference

  • VCLTee.Painter.GdiPlus


GDIPColor(TColor) Method

Summary

Represents method GDIPColor(TColor).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function GDIPColor(const AColor:TColor):TGPColor; inline;

Parameters

AColor
Type: TColor

Return Value

Type: TGPColor

See Also

Reference

  • VCLTee.Painter.GdiPlus


GPRectF(TRectF) Method

Summary

Represents method GPRectF(TRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function GPRectF(const R:TRectF):TGPRectF;

Parameters

R
Type: TRectF

Return Value

Type: TGPRectF

See Also

Reference

  • VCLTee.Painter.GdiPlus


GraphicFrom(TObject) Method

Summary

Represents method GraphicFrom(TObject).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function GraphicFrom(const AObject:TObject):TGraphic;

Parameters

AObject
Type: TObject

Return Value

Type: TGraphic

See Also

Reference

  • VCLTee.Painter.GdiPlus


InflateRectF(TGPRectF,Single,Single) Method

Summary

Represents method InflateRectF(TGPRectF,Single,Single).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function InflateRectF(const R:TGPRectF; const X,Y:Single):TGPRectF;

Parameters

R
Type: TGPRectF

X
Type: Single

Y
Type: Single

Return Value

Type: TGPRectF

See Also

Reference

  • VCLTee.Painter.GdiPlus


RectCenterF(TGPRectF) Method

Summary

Represents method RectCenterF(TGPRectF).

Namespace: VCLTee.Painter.GdiPlus
Syntax
Delphi
function RectCenterF(const R:TGPRectF):TGPPointF;

Parameters

R
Type: TGPRectF

Return Value

Type: TGPPointF

See Also

Reference

  • VCLTee.Painter.GdiPlus


VCLTee.Picture Namespace

Summary

Represents namespace VCLTee.Picture.

Classes
Name | Description
TPictureAccess | Represents type TPictureAccess.
Top
Records
Name | Description
TVCLPicture | Represents type TVCLPicture.
Top


VCLTee.Picture Classes

Classes
Name | Description
TPictureAccess | Represents type TPictureAccess.
Top


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: VCLTee.Picture
Inheritance Hierarchy
TPicture
VCLTee.Picture.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • VCLTee.Picture


VCLTee.Picture Records

Records
Name | Description
TVCLPicture | Represents type TVCLPicture.
Top


TVCLPicture Record

Summary

Represents type TVCLPicture.

Namespace: VCLTee.Picture
Syntax
Delphi
type
 TVCLPicture=record
 end;

The TVCLPicture type exposes the following members.

Methods
Show:
Name | Description
From(Graphics) | Overloaded. Represents method From(Graphics).
From(String) | Overloaded. Represents method From(String).
From(TImage) | Overloaded. Represents method From(TImage).
From(TVCLGraphic) | Overloaded. Represents method From(TVCLGraphic).
Load(String) | Overloaded. Represents method Load(String).
Load(TPicture,String) | Overloaded. Represents method Load(TPicture,String).
TypeOfGraphic(TGraphic) | Represents method TypeOfGraphic(TGraphic).
Top
See Also

Reference

  • VCLTee.Picture


TVCLPicture Methods

Methods
Name | Description
From(Graphics) | Overloaded. Represents method From(Graphics).
From(String) | Overloaded. Represents method From(String).
From(TImage) | Overloaded. Represents method From(TImage).
From(TVCLGraphic) | Overloaded. Represents method From(TVCLGraphic).
Load(String) | Overloaded. Represents method Load(String).
Load(TPicture,String) | Overloaded. Represents method Load(TPicture,String).
TypeOfGraphic(TGraphic) | Represents method TypeOfGraphic(TGraphic).
Top


TVCLPicture.From(Graphics) Method

Summary

Represents method From(Graphics).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function From(const APicture:Graphics.TPicture):TPicture; overload; static;

Parameters

APicture
Type: Graphics.TPicture

Return Value

Type: TPicture

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.From(String) Method

Summary

Represents method From(String).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function From(const AFileName:String):TPicture; overload; static;

Parameters

AFileName
Type: String

Return Value

Type: TPicture

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.From(TImage) Method

Summary

Represents method From(TImage).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function From(const AImage:TImage):TPicture; overload; static;

Parameters

AImage
Type: TImage

Return Value

Type: TPicture

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.From(TVCLGraphic) Method

Summary

Represents method From(TVCLGraphic).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function From(const AGraphic:TVCLGraphic):TPicture; overload; static;

Parameters

AGraphic
Type: System.Void

Return Value

Type: TPicture

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.Load(String) Method

Summary

Represents method Load(String).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function Load(const AFileName:String):Graphics.TPicture; overload; static;

Parameters

AFileName
Type: String

Return Value

Type: Graphics.TPicture

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.Load(TPicture,String) Method

Summary

Represents method Load(TPicture,String).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class procedure Load(const APicture:TPicture; const AFileName:String); overload; static;

Parameters

APicture
Type: TPicture

AFileName
Type: String

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


TVCLPicture.TypeOfGraphic(TGraphic) Method

Summary

Represents method TypeOfGraphic(TGraphic).

Namespace: VCLTee.Picture
Syntax
Delphi
public
 class function TypeOfGraphic(const AGraphic:TGraphic):String; static;

Parameters

AGraphic
Type: TGraphic

Return Value

Type: String

See Also

Reference

  • TVCLPicture
  • VCLTee.Picture


DCLVCLTeeGrid

Summary

Represents namespace DCLVCLTeeGrid.

Namespaces
Name | Description
VCLTee.Grid.About | Represents namespace VCLTee.Grid.About.
VCLTeeGridRegister | Represents namespace VCLTeeGridRegister.
Top


VCLTee.Grid.About Namespace

Summary

Represents namespace VCLTee.Grid.About.

Classes
Name | Description
TVCLGridAbout | Represents type TVCLGridAbout.
Top
Constants
Name | Description
TeeGrid_Version | Represents constant TeeGrid_Version.
TeeGrid_Version_Numeric | Represents constant TeeGrid_Version_Numeric.
Top


VCLTee.Grid.About Classes

Classes
Name | Description
TVCLGridAbout | Represents type TVCLGridAbout.
Top


TVCLGridAbout Class

Summary

Represents type TVCLGridAbout.

Namespace: VCLTee.Grid.About
Inheritance Hierarchy
TForm
VCLTee.Grid.About.TVCLGridAbout
Syntax
Delphi
type
 TVCLGridAbout = class(TForm)
 end;

The TVCLGridAbout type exposes the following members.

Methods
Show:
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent) | Represents method Show(TComponent).
TeeGrid1DblClick(TObject) | Represents method TeeGrid1DblClick(TObject).
Timer1Timer(TObject) | Represents method Timer1Timer(TObject).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
LVersion | Represents field LVersion.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
TeeGrid1 | Represents field TeeGrid1.
Timer1 | Represents field Timer1.
Top
See Also

Reference

  • VCLTee.Grid.About


TVCLGridAbout Methods

Methods
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent) | Represents method Show(TComponent).
TeeGrid1DblClick(TObject) | Represents method TeeGrid1DblClick(TObject).
Timer1Timer(TObject) | Represents method Timer1Timer(TObject).
Top


TVCLGridAbout.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.Show(TComponent) Method

Summary

Represents method Show(TComponent).

Namespace: VCLTee.Grid.About
Syntax
Delphi
public
 class procedure Show(const AOwner:TComponent); static;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.TeeGrid1DblClick(TObject) Method

Summary

Represents method TeeGrid1DblClick(TObject).

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 procedure TeeGrid1DblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.Timer1Timer(TObject) Method

Summary

Represents method Timer1Timer(TObject).

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 procedure Timer1Timer(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout Fields

Fields
Name | Description
Button1 | Represents field Button1.
LVersion | Represents field LVersion.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
TeeGrid1 | Represents field TeeGrid1.
Timer1 | Represents field Timer1.
Top


TVCLGridAbout.Button1 Field

Summary

Represents field Button1.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.LVersion Field

Summary

Represents field LVersion.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 LVersion: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.TeeGrid1 Field

Summary

Represents field TeeGrid1.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 TeeGrid1: TTeeGrid;

Field Value

Type: TTeeGrid

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


TVCLGridAbout.Timer1 Field

Summary

Represents field Timer1.

Namespace: VCLTee.Grid.About
Syntax
Delphi
published
 Timer1: TTimer;

Field Value

Type: TTimer

See Also

Reference

  • TVCLGridAbout
  • VCLTee.Grid.About


VCLTee.Grid.About Constants

Constants
Name | Description
TeeGrid_Version | Represents constant TeeGrid_Version.
TeeGrid_Version_Numeric | Represents constant TeeGrid_Version_Numeric.
Top


TeeGrid_Version Constant

Summary

Represents constant TeeGrid_Version.

Namespace: VCLTee.Grid.About
Syntax
Delphi
 TeeGrid_Version='v1.08';

Value

Type: string

See Also

Reference

  • VCLTee.Grid.About


TeeGrid_Version_Numeric Constant

Summary

Represents constant TeeGrid_Version_Numeric.

Namespace: VCLTee.Grid.About
Syntax
Delphi
 TeeGrid_Version_Numeric=108;

Value

Type: ShortInt

See Also

Reference

  • VCLTee.Grid.About


VCLTeeGridRegister Namespace

Summary

Represents namespace VCLTeeGridRegister.

Classes
Name | Description
TBordersProperty | Represents type TBordersProperty.
TBrushProperty | Represents type TBrushProperty.
TColumnProperty | Represents type TColumnProperty.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TFontProperty | Represents type TFontProperty.
TFormatProperty | Represents type TFormatProperty.
TGradientProperty | Represents type TGradientProperty.
TGridClassProperty | Represents type TGridClassProperty.
TGridClassSubProperties | Represents type TGridClassSubProperties.
THeaderProperty | Represents type THeaderProperty.
TMarginsProperty | Represents type TMarginsProperty.
TStrokeProperty | Represents type TStrokeProperty.
TTeeComponentEditor | Represents type TTeeComponentEditor.
TTeeGridCompEditor | Represents type TTeeGridCompEditor.
TTeeGridSelectionEditor | Represents type TTeeGridSelectionEditor.
TTextFormatProperty | Represents type TTextFormatProperty.
Top
Routines
Name | Description
Register | Represents method Register.
Top


VCLTeeGridRegister Classes

Classes
Name | Description
TBordersProperty | Represents type TBordersProperty.
TBrushProperty | Represents type TBrushProperty.
TColumnProperty | Represents type TColumnProperty.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TFontProperty | Represents type TFontProperty.
TFormatProperty | Represents type TFormatProperty.
TGradientProperty | Represents type TGradientProperty.
TGridClassProperty | Represents type TGridClassProperty.
TGridClassSubProperties | Represents type TGridClassSubProperties.
THeaderProperty | Represents type THeaderProperty.
TMarginsProperty | Represents type TMarginsProperty.
TStrokeProperty | Represents type TStrokeProperty.
TTeeComponentEditor | Represents type TTeeComponentEditor.
TTeeGridCompEditor | Represents type TTeeGridCompEditor.
TTeeGridSelectionEditor | Represents type TTeeGridSelectionEditor.
TTextFormatProperty | Represents type TTextFormatProperty.
Top


TBordersProperty Class

Summary

Represents type TBordersProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TBordersProperty
Syntax
Delphi
type
 TBordersProperty=class(TGridClassSubProperties)
 end;

The TBordersProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TBordersProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBordersProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBordersProperty
  • VCLTeeGridRegister


TBrushProperty Class

Summary

Represents type TBrushProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TBrushProperty
Syntax
Delphi
type
 TBrushProperty=class(TGridClassSubProperties)
 end;

The TBrushProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TBrushProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBrushProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBrushProperty
  • VCLTeeGridRegister


TColumnProperty Class

Summary

Represents type TColumnProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TColumnProperty
Syntax
Delphi
type
 TColumnProperty=class(TGridClassSubProperties)
 end;

The TColumnProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TColumnProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TColumnProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TColumnProperty
  • VCLTeeGridRegister


TCustomTeeGridAccess Class

Summary

Represents type TCustomTeeGridAccess.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TCustomTeeGrid
VCLTeeGridRegister.TCustomTeeGridAccess
Syntax
Delphi
type
 TCustomTeeGridAccess=class(TCustomTeeGrid);
See Also

Reference

  • VCLTeeGridRegister


TFontProperty Class

Summary

Represents type TFontProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TFontProperty
Syntax
Delphi
type
 TFontProperty=class(TGridClassSubProperties)
 end;

The TFontProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TFontProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TFontProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TFontProperty
  • VCLTeeGridRegister


TFormatProperty Class

Summary

Represents type TFormatProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TFormatProperty
Syntax
Delphi
type
 TFormatProperty=class(TGridClassSubProperties)
 end;

The TFormatProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TFormatProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TFormatProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TFormatProperty
  • VCLTeeGridRegister


TGradientProperty Class

Summary

Represents type TGradientProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TGradientProperty
Syntax
Delphi
type
 TGradientProperty=class(TGridClassSubProperties)
 end;

The TGradientProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TGradientProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TGradientProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TGradientProperty
  • VCLTeeGridRegister


TGridClassProperty Class

Summary

Represents type TGridClassProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
Syntax
Delphi
type
 TGridClassProperty=class(TClassProperty)
 end;

The TGridClassProperty type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes.
GetObject | Represents method GetObject.
Top
See Also

Reference

  • VCLTeeGridRegister


TGridClassProperty Methods

Methods
Name | Description
GetAttributes | Represents method GetAttributes.
GetObject | Represents method GetObject.
Top


TGridClassProperty.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

See Also

Reference

  • TGridClassProperty
  • VCLTeeGridRegister


TGridClassProperty.GetObject Method

Summary

Represents method GetObject.

Namespace: VCLTeeGridRegister
Syntax
Delphi
protected
 function GetObject:Integer;

Return Value

Type: Integer

See Also

Reference

  • TGridClassProperty
  • VCLTeeGridRegister


TGridClassSubProperties Class

Summary

Represents type TGridClassSubProperties.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TBordersProperty
VCLTeeGridRegister.TBrushProperty
VCLTeeGridRegister.TColumnProperty
VCLTeeGridRegister.TFontProperty
VCLTeeGridRegister.TFormatProperty
VCLTeeGridRegister.TGradientProperty
VCLTeeGridRegister.THeaderProperty
VCLTeeGridRegister.TMarginsProperty
VCLTeeGridRegister.TStrokeProperty
VCLTeeGridRegister.TTextFormatProperty
Syntax
Delphi
type
 TGridClassSubProperties=class(TGridClassProperty)
 end;

The TGridClassSubProperties type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TGridClassSubProperties Methods

Methods
Name | Description
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
Top


TGridClassSubProperties.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

Overrides

TGridClassProperty.GetAttributes
See Also

Reference

  • TGridClassSubProperties
  • VCLTeeGridRegister


THeaderProperty Class

Summary

Represents type THeaderProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.THeaderProperty
Syntax
Delphi
type
 THeaderProperty=class(TGridClassSubProperties)
 end;

The THeaderProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


THeaderProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


THeaderProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • THeaderProperty
  • VCLTeeGridRegister


TMarginsProperty Class

Summary

Represents type TMarginsProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TMarginsProperty
Syntax
Delphi
type
 TMarginsProperty=class(TGridClassSubProperties)
 end;

The TMarginsProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TMarginsProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TMarginsProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TMarginsProperty
  • VCLTeeGridRegister


TStrokeProperty Class

Summary

Represents type TStrokeProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TStrokeProperty
Syntax
Delphi
type
 TStrokeProperty=class(TGridClassSubProperties)
 end;

The TStrokeProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TStrokeProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TStrokeProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TStrokeProperty
  • VCLTeeGridRegister


TTeeComponentEditor Class

Summary

Represents type TTeeComponentEditor.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TComponentEditor
VCLTeeGridRegister.TTeeComponentEditor
VCLTeeGridRegister.TTeeGridCompEditor
Syntax
Delphi
type
 TTeeComponentEditor=class(TComponentEditor)
 end;

The TTeeComponentEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top
See Also

Reference

  • VCLTeeGridRegister


TTeeComponentEditor Methods

Methods
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top


TTeeComponentEditor.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TTeeComponentEditor
  • VCLTeeGridRegister


TTeeComponentEditor.ExecuteVerb(Integer) Method

Summary

Represents method ExecuteVerb(Integer).

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure ExecuteVerb(Index:Integer); override;

Parameters

Index
Type: Integer

See Also

Reference

  • TTeeComponentEditor
  • VCLTeeGridRegister


TTeeComponentEditor.GetVerb(Integer) Method

Summary

Represents method GetVerb(Integer).

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 function GetVerb(Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TTeeComponentEditor
  • VCLTeeGridRegister


TTeeComponentEditor.GetVerbCount Method

Summary

Represents method GetVerbCount.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 function GetVerbCount:Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TTeeComponentEditor
  • VCLTeeGridRegister


TTeeGridCompEditor Class

Summary

Represents type TTeeGridCompEditor.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TComponentEditor
VCLTeeGridRegister.TTeeComponentEditor
VCLTeeGridRegister.TTeeGridCompEditor
Syntax
Delphi
type
 TTeeGridCompEditor=class(TTeeComponentEditor)
 end;

The TTeeGridCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TTeeComponentEditor.Edit.)
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer). (Inherited from TTeeComponentEditor.)
GetVerb(Integer) | Represents method GetVerb(Integer). (Inherited from TTeeComponentEditor.)
GetVerbCount | Represents method GetVerbCount. (Inherited from TTeeComponentEditor.)
Top
See Also

Reference

  • VCLTeeGridRegister


TTeeGridCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TTeeComponentEditor.Edit.)
Top


TTeeGridCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TTeeComponentEditor.Edit
See Also

Reference

  • TTeeGridCompEditor
  • VCLTeeGridRegister


TTeeGridSelectionEditor Class

Summary

Represents type TTeeGridSelectionEditor.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TSelectionEditor
VCLTeeGridRegister.TTeeGridSelectionEditor
Syntax
Delphi
type
 TTeeGridSelectionEditor=class(TSelectionEditor)
 end;

The TTeeGridSelectionEditor type exposes the following members.

Methods
Show:
Name | Description
RequiresUnits(TGetStrProc) | Represents method RequiresUnits(TGetStrProc).
Top
See Also

Reference

  • VCLTeeGridRegister


TTeeGridSelectionEditor Methods

Methods
Name | Description
RequiresUnits(TGetStrProc) | Represents method RequiresUnits(TGetStrProc).
Top


TTeeGridSelectionEditor.RequiresUnits(TGetStrProc) Method

Summary

Represents method RequiresUnits(TGetStrProc).

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure RequiresUnits(Proc: TGetStrProc); override;

Parameters

Proc
Type: TGetStrProc

See Also

Reference

  • TTeeGridSelectionEditor
  • VCLTeeGridRegister


TTextFormatProperty Class

Summary

Represents type TTextFormatProperty.

Namespace: VCLTeeGridRegister
Inheritance Hierarchy
TClassProperty
VCLTeeGridRegister.TGridClassProperty
VCLTeeGridRegister.TGridClassSubProperties
VCLTeeGridRegister.TTextFormatProperty
Syntax
Delphi
type
 TTextFormatProperty=class(TGridClassSubProperties)
 end;

The TTextFormatProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • VCLTeeGridRegister


TTextFormatProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TTextFormatProperty.Edit Method

Summary

Represents method Edit.

Namespace: VCLTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TTextFormatProperty
  • VCLTeeGridRegister


VCLTeeGridRegister Routines

Routines
Name | Description
Register | Represents method Register.
Top


Register Method

Summary

Represents method Register.

Namespace: VCLTeeGridRegister
Syntax
Delphi
procedure Register;
See Also

Reference

  • VCLTeeGridRegister


FMXTeeGrid

Summary

Represents namespace FMXTeeGrid.

Namespaces
Name | Description
FMXTee.Control | Represents namespace FMXTee.Control.
FMXTee.Editor.Painter.Brush | Represents namespace FMXTee.Editor.Painter.Brush.
FMXTee.Editor.Painter.Gradient | Represents namespace FMXTee.Editor.Painter.Gradient.
FMXTee.Editor.Painter.Stroke | Represents namespace FMXTee.Editor.Painter.Stroke.
FMXTee.Grid | Represents namespace FMXTee.Grid.
FMXTee.Grid.Layout | Represents namespace FMXTee.Grid.Layout.
FMXTee.Grid.Themes | Represents namespace FMXTee.Grid.Themes.
FMXTee.Painter | Represents namespace FMXTee.Painter.
FMXTee.Picture | Represents namespace FMXTee.Picture.
Top


FMXTee.Control Namespace

Summary

Represents namespace FMXTee.Control.

Classes
Name | Description
TScrollableControl | Represents type TScrollableControl.
TScrollableControl.TFMXScrollBars | Represents type TFMXScrollBars.
Top
Types
Name | Description
TScrollableControl.TFMXScrollBar | Represents an alias of the TScrollBar type.
Top
Constants
Name | Description
TeeAllComponentPlatformIDs | Represents constant TeeAllComponentPlatformIDs.
Top


FMXTee.Control Classes

Classes
Name | Description
TScrollableControl | Represents type TScrollableControl.
TScrollableControl.TFMXScrollBars | Represents type TFMXScrollBars.
Top


TScrollableControl Class

Summary

Represents type TScrollableControl.

Namespace: FMXTee.Control
Inheritance Hierarchy
TStyledControl
FMXTee.Control.TScrollableControl
FMXTee.Grid.TTeeGrid
Syntax
Delphi
type
 TScrollableControl=class(TStyledControl)
 end;

The TScrollableControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TScrollableControl class.
Destroy | Represents the destructor of the TScrollableControl class.
Top
Properties
Show:
Name | Description
ScrollBars | Represents property ScrollBars.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetMaxBottom | Represents method GetMaxBottom.
GetMaxRight | Represents method GetMaxRight.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
RemainSize(Boolean) | Represents method RemainSize(Boolean).
ResetScrollBars | Represents method ResetScrollBars.
SetScrollX(Single) | Represents method SetScrollX(Single).
SetScrollY(Single) | Represents method SetScrollY(Single).
UpdateScroll(Boolean,Single) | Represents method UpdateScroll(Boolean,Single).
Top
Fields
Show:
Name | Description
IFMXScrollBars | Represents field IFMXScrollBars.
Top
See Also

Reference

  • FMXTee.Control


TScrollableControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TScrollableControl class.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.Destroy Destructor

Summary

Represents the destructor of the TScrollableControl class.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: FMXTee.Control
Syntax
Delphi
public
 property ScrollBars:TScrollBars read FScrollBars write SetScrollBars;

Property Value

Type: TScrollBars

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetMaxBottom | Represents method GetMaxBottom.
GetMaxRight | Represents method GetMaxRight.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean).
RemainSize(Boolean) | Represents method RemainSize(Boolean).
ResetScrollBars | Represents method ResetScrollBars.
SetScrollX(Single) | Represents method SetScrollX(Single).
SetScrollY(Single) | Represents method SetScrollY(Single).
UpdateScroll(Boolean,Single) | Represents method UpdateScroll(Boolean,Single).
Top


TScrollableControl.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXTee.Control
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.GetMaxBottom Method

Summary

Represents method GetMaxBottom.

Namespace: FMXTee.Control
Syntax
Delphi
protected
 function GetMaxBottom:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.GetMaxRight Method

Summary

Represents method GetMaxRight.

Namespace: FMXTee.Control
Syntax
Delphi
protected
 function GetMaxRight:Single; virtual; abstract;

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.PerfectScrollBar(Boolean) Method

Summary

Represents method PerfectScrollBar(Boolean).

Namespace: FMXTee.Control
Syntax
Delphi
protected
 function PerfectScrollBar(const Vertical:Boolean):Boolean; virtual; abstract;

Parameters

Vertical
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.RemainSize(Boolean) Method

Summary

Represents method RemainSize(Boolean).

Namespace: FMXTee.Control
Syntax
Delphi
protected
 function RemainSize(const Horizontal:Boolean):Single;

Parameters

Horizontal
Type: Boolean

Return Value

Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.ResetScrollBars Method

Summary

Represents method ResetScrollBars.

Namespace: FMXTee.Control
Syntax
Delphi
protected
 procedure ResetScrollBars; virtual;
See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.SetScrollX(Single) Method

Summary

Represents method SetScrollX(Single).

Namespace: FMXTee.Control
Syntax
Delphi
protected
 procedure SetScrollX(const Value:Single); virtual; abstract;

Parameters

Value
Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.SetScrollY(Single) Method

Summary

Represents method SetScrollY(Single).

Namespace: FMXTee.Control
Syntax
Delphi
protected
 procedure SetScrollY(const Value:Single); virtual; abstract;

Parameters

Value
Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.UpdateScroll(Boolean,Single) Method

Summary

Represents method UpdateScroll(Boolean,Single).

Namespace: FMXTee.Control
Syntax
Delphi
protected
 procedure UpdateScroll(const Horiz:Boolean; const AValue: Single);

Parameters

Horiz
Type: Boolean

AValue
Type: Single

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl Fields

Fields
Name | Description
IFMXScrollBars | Represents field IFMXScrollBars.
Top


TScrollableControl.IFMXScrollBars Field

Summary

Represents field IFMXScrollBars.

Namespace: FMXTee.Control
Syntax
Delphi
protected
 IFMXScrollBars : TFMXScrollBars;

Field Value

Type: TFMXScrollBars

See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.TFMXScrollBars Class

Summary

Represents type TFMXScrollBars.

Namespace: FMXTee.Control
Inheritance Hierarchy
TObject
FMXTee.Control.TScrollableControl.TFMXScrollBars
Syntax
Delphi
protected
type
 TFMXScrollBars=class
 end;

The TScrollableControl.TFMXScrollBars type exposes the following members.

Constructors
Show:
Name | Description
CreateParent(TControl) | Initializes a new instance of the TScrollableControl.TFMXScrollBars class.
Destroy | Represents the destructor of the TScrollableControl.TFMXScrollBars class.
Top
Fields
Show:
Name | Description
Horizontal | Represents field Horizontal.
Vertical | Represents field Vertical.
Top
See Also

Reference

  • TScrollableControl
  • FMXTee.Control


TScrollableControl.TFMXScrollBars Constructors

Constructors
Name | Description
CreateParent(TControl) | Initializes a new instance of the TScrollableControl.TFMXScrollBars class.
Destroy | Represents the destructor of the TScrollableControl.TFMXScrollBars class.
Top


TScrollableControl.TFMXScrollBars.CreateParent(TControl) Constructor

Summary

Initializes a new instance of the TScrollableControl.TFMXScrollBars class.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Constructor CreateParent(const AParent:TControl);

Parameters

AParent
Type: TControl

See Also

Reference

  • TScrollableControl.TFMXScrollBars
  • TScrollableControl
  • FMXTee.Control


TScrollableControl.TFMXScrollBars.Destroy Destructor

Summary

Represents the destructor of the TScrollableControl.TFMXScrollBars class.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TScrollableControl.TFMXScrollBars
  • TScrollableControl
  • FMXTee.Control


TScrollableControl.TFMXScrollBars Fields

Fields
Name | Description
Horizontal | Represents field Horizontal.
Vertical | Represents field Vertical.
Top


TScrollableControl.TFMXScrollBars.Horizontal Field

Summary

Represents field Horizontal.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Horizontal,
 Vertical : TFMXScrollBar;

Field Value

Type: TFMXScrollBar

See Also

Reference

  • TScrollableControl.TFMXScrollBars
  • TScrollableControl
  • FMXTee.Control


TScrollableControl.TFMXScrollBars.Vertical Field

Summary

Represents field Vertical.

Namespace: FMXTee.Control
Syntax
Delphi
public
 Horizontal,
 Vertical : TFMXScrollBar;

Field Value

Type: TFMXScrollBar

See Also

Reference

  • TScrollableControl.TFMXScrollBars
  • TScrollableControl
  • FMXTee.Control


FMXTee.Control Types

Types
Name | Description
TScrollableControl.TFMXScrollBar | Represents an alias of the TScrollBar type.
Top


TScrollableControl.TFMXScrollBar Type

Summary

Represents an alias of the TScrollBar type.

Namespace: FMXTee.Control
Syntax
Delphi
protected
type
 TFMXScrollBar=FMX.StdCtrls.TScrollBar;
See Also

Reference

  • TScrollableControl
  • FMXTee.Control


FMXTee.Control Constants

Constants
Name | Description
TeeAllComponentPlatformIDs | Represents constant TeeAllComponentPlatformIDs.
Top


TeeAllComponentPlatformIDs Constant

Summary

Represents constant TeeAllComponentPlatformIDs.

Namespace: FMXTee.Control
Syntax
Delphi
 TeeAllComponentPlatformIDs=(pidWin32 or pidWin64 or pidOSX32
 or
 pidiOSSimulator
 or
 pidiOSDevice
 or
 pidAndroid
 or pidiOSDevice64
 );

Value

Type: Void

See Also

Reference

  • FMXTee.Control


FMXTee.Editor.Painter.Brush Namespace

Summary

Represents namespace FMXTee.Editor.Painter.Brush.

Classes
Name | Description
TBrushEditor | Represents type TBrushEditor.
Top


FMXTee.Editor.Painter.Brush Classes

Classes
Name | Description
TBrushEditor | Represents type TBrushEditor.
Top


TBrushEditor Class

Summary

Represents type TBrushEditor.

Namespace: FMXTee.Editor.Painter.Brush
Inheritance Hierarchy
TForm
FMXTee.Editor.Painter.Brush.TBrushEditor
Syntax
Delphi
type
 TBrushEditor = class(TForm)
 end;

The TBrushEditor type exposes the following members.

Properties
Show:
Name | Description
OnColorChange | Represents property OnColorChange.
Top
Methods
Show:
Name | Description
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
Edit(TComponent,TBrush) | Represents method Edit(TComponent,TBrush).
Embedd(TComponent,TControl,TBrush) | Represents method Embedd(TComponent,TControl,TBrush).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshBrush(TBrush) | Represents method RefreshBrush(TBrush).
RefreshColor | Represents method RefreshColor.
TabBrushChange(TObject) | Represents method TabBrushChange(TObject).
Top
Fields
Show:
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
LayoutTop | Represents field LayoutTop.
TabBrush | Represents field TabBrush.
TabColor | Represents field TabColor.
TabGradient | Represents field TabGradient.
TabPicture | Represents field TabPicture.
Top
See Also

Reference

  • FMXTee.Editor.Painter.Brush


TBrushEditor.OnColorChange Property

Summary

Represents property OnColorChange.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
public
 property OnColorChange:TNotifyEvent read FOnColorChange write FOnColorChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor Methods

Methods
Name | Description
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
Edit(TComponent,TBrush) | Represents method Edit(TComponent,TBrush).
Embedd(TComponent,TControl,TBrush) | Represents method Embedd(TComponent,TControl,TBrush).
FormCreate(TObject) | Represents method FormCreate(TObject).
RefreshBrush(TBrush) | Represents method RefreshBrush(TBrush).
RefreshColor | Represents method RefreshColor.
TabBrushChange(TObject) | Represents method TabBrushChange(TObject).
Top


TBrushEditor.CBColorChange(TObject) Method

Summary

Represents method CBColorChange(TObject).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 procedure CBColorChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.CBVisibleChange(TObject) Method

Summary

Represents method CBVisibleChange(TObject).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 procedure CBVisibleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.Edit(TComponent,TBrush) Method

Summary

Represents method Edit(TComponent,TBrush).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ABrush:TBrush):Boolean; static;

Parameters

AOwner
Type: TComponent

ABrush
Type: TBrush

Return Value

Type: Boolean

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.Embedd(TComponent,TControl,TBrush) Method

Summary

Represents method Embedd(TComponent,TControl,TBrush).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const ABrush:TBrush):TBrushEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

ABrush
Type: TBrush

Return Value

Type: TBrushEditor

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.RefreshBrush(TBrush) Method

Summary

Represents method RefreshBrush(TBrush).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
public
 procedure RefreshBrush(const ABrush:TBrush);

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.RefreshColor Method

Summary

Represents method RefreshColor.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
public
 procedure RefreshColor;
See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.TabBrushChange(TObject) Method

Summary

Represents method TabBrushChange(TObject).

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 procedure TabBrushChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor Fields

Fields
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
LayoutTop | Represents field LayoutTop.
TabBrush | Represents field TabBrush.
TabColor | Represents field TabColor.
TabGradient | Represents field TabGradient.
TabPicture | Represents field TabPicture.
Top


TBrushEditor.CBColor Field

Summary

Represents field CBColor.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 CBColor: TColorPanel;

Field Value

Type: TColorPanel

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.LayoutTop Field

Summary

Represents field LayoutTop.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 LayoutTop: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.TabBrush Field

Summary

Represents field TabBrush.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 TabBrush: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.TabColor Field

Summary

Represents field TabColor.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 TabColor: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.TabGradient Field

Summary

Represents field TabGradient.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 TabGradient: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


TBrushEditor.TabPicture Field

Summary

Represents field TabPicture.

Namespace: FMXTee.Editor.Painter.Brush
Syntax
Delphi
published
 TabPicture: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TBrushEditor
  • FMXTee.Editor.Painter.Brush


FMXTee.Editor.Painter.Gradient Namespace

Summary

Represents namespace FMXTee.Editor.Painter.Gradient.

Classes
Name | Description
TGradientEditor | Represents type TGradientEditor.
Top


FMXTee.Editor.Painter.Gradient Classes

Classes
Name | Description
TGradientEditor | Represents type TGradientEditor.
Top


TGradientEditor Class

Summary

Represents type TGradientEditor.

Namespace: FMXTee.Editor.Painter.Gradient
Inheritance Hierarchy
TForm
FMXTee.Editor.Painter.Gradient.TGradientEditor
Syntax
Delphi
type
 TGradientEditor = class(TForm)
 end;

The TGradientEditor type exposes the following members.

Methods
Show:
Name | Description
CBDirectionChange(TObject) | Represents method CBDirectionChange(TObject).
CBInvertedChange(TObject) | Represents method CBInvertedChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
ColorButton1Change(TObject) | Represents method ColorButton1Change(TObject).
ColorButton2Change(TObject) | Represents method ColorButton2Change(TObject).
Edit(TComponent,TGradient) | Represents method Edit(TComponent,TGradient).
Embedd(TComponent,TControl,TGradient) | Represents method Embedd(TComponent,TControl,TGradient).
RefreshGradient(TGradient) | Represents method RefreshGradient(TGradient).
Top
Fields
Show:
Name | Description
CBDirection | Represents field CBDirection.
CBInverted | Represents field CBInverted.
CBVisible | Represents field CBVisible.
ColorButton1 | Represents field ColorButton1.
ColorButton2 | Represents field ColorButton2.
Label1 | Represents field Label1.
Panel1 | Represents field Panel1.
Top
See Also

Reference

  • FMXTee.Editor.Painter.Gradient


TGradientEditor Methods

Methods
Name | Description
CBDirectionChange(TObject) | Represents method CBDirectionChange(TObject).
CBInvertedChange(TObject) | Represents method CBInvertedChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
ColorButton1Change(TObject) | Represents method ColorButton1Change(TObject).
ColorButton2Change(TObject) | Represents method ColorButton2Change(TObject).
Edit(TComponent,TGradient) | Represents method Edit(TComponent,TGradient).
Embedd(TComponent,TControl,TGradient) | Represents method Embedd(TComponent,TControl,TGradient).
RefreshGradient(TGradient) | Represents method RefreshGradient(TGradient).
Top


TGradientEditor.CBDirectionChange(TObject) Method

Summary

Represents method CBDirectionChange(TObject).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 procedure CBDirectionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.CBInvertedChange(TObject) Method

Summary

Represents method CBInvertedChange(TObject).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 procedure CBInvertedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.CBVisibleChange(TObject) Method

Summary

Represents method CBVisibleChange(TObject).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 procedure CBVisibleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.ColorButton1Change(TObject) Method

Summary

Represents method ColorButton1Change(TObject).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 procedure ColorButton1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.ColorButton2Change(TObject) Method

Summary

Represents method ColorButton2Change(TObject).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 procedure ColorButton2Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.Edit(TComponent,TGradient) Method

Summary

Represents method Edit(TComponent,TGradient).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AGradient:TGradient):Boolean; static;

Parameters

AOwner
Type: TComponent

AGradient
Type: TGradient

Return Value

Type: Boolean

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.Embedd(TComponent,TControl,TGradient) Method

Summary

Represents method Embedd(TComponent,TControl,TGradient).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const AGradient:TGradient):TGradientEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AGradient
Type: TGradient

Return Value

Type: TGradientEditor

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.RefreshGradient(TGradient) Method

Summary

Represents method RefreshGradient(TGradient).

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
public
 procedure RefreshGradient(const AGradient:TGradient);

Parameters

AGradient
Type: TGradient

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor Fields

Fields
Name | Description
CBDirection | Represents field CBDirection.
CBInverted | Represents field CBInverted.
CBVisible | Represents field CBVisible.
ColorButton1 | Represents field ColorButton1.
ColorButton2 | Represents field ColorButton2.
Label1 | Represents field Label1.
Panel1 | Represents field Panel1.
Top


TGradientEditor.CBDirection Field

Summary

Represents field CBDirection.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 CBDirection: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.CBInverted Field

Summary

Represents field CBInverted.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 CBInverted: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.ColorButton1 Field

Summary

Represents field ColorButton1.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 ColorButton1: TComboColorBox;

Field Value

Type: TComboColorBox

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.ColorButton2 Field

Summary

Represents field ColorButton2.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 ColorButton2: TComboColorBox;

Field Value

Type: TComboColorBox

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


TGradientEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: FMXTee.Editor.Painter.Gradient
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TGradientEditor
  • FMXTee.Editor.Painter.Gradient


FMXTee.Editor.Painter.Stroke Namespace

Summary

Represents namespace FMXTee.Editor.Painter.Stroke.

Classes
Name | Description
TStrokeEditor | Represents type TStrokeEditor.
Top


FMXTee.Editor.Painter.Stroke Classes

Classes
Name | Description
TStrokeEditor | Represents type TStrokeEditor.
Top


TStrokeEditor Class

Summary

Represents type TStrokeEditor.

Namespace: FMXTee.Editor.Painter.Stroke
Inheritance Hierarchy
TForm
FMXTee.Editor.Painter.Stroke.TStrokeEditor
Syntax
Delphi
type
 TStrokeEditor = class(TForm)
 end;

The TStrokeEditor type exposes the following members.

Methods
Show:
Name | Description
AddForm(TCustomForm,TControl) | Represents method AddForm(TCustomForm,TControl).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
Edit(TComponent,TStroke) | Represents method Edit(TComponent,TStroke).
Embedd(TComponent,TControl,TStroke) | Represents method Embedd(TComponent,TControl,TStroke).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBEndStyleChange(TObject) | Represents method LBEndStyleChange(TObject).
LBJoinStyleChange(TObject) | Represents method LBJoinStyleChange(TObject).
LBStyleChange(TObject) | Represents method LBStyleChange(TObject).
RefreshStroke(TStroke) | Represents method RefreshStroke(TStroke).
TabStrokeChange(TObject) | Represents method TabStrokeChange(TObject).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top
Fields
Show:
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBEndStyle | Represents field LBEndStyle.
LBJoinStyle | Represents field LBJoinStyle.
LBStyle | Represents field LBStyle.
LSize | Represents field LSize.
TabFill | Represents field TabFill.
TabOptions | Represents field TabOptions.
TabStroke | Represents field TabStroke.
TabStyle | Represents field TabStyle.
TBSize | Represents field TBSize.
Top
See Also

Reference

  • FMXTee.Editor.Painter.Stroke


TStrokeEditor Methods

Methods
Name | Description
AddForm(TCustomForm,TControl) | Represents method AddForm(TCustomForm,TControl).
CBColorChange(TObject) | Represents method CBColorChange(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
Edit(TComponent,TStroke) | Represents method Edit(TComponent,TStroke).
Embedd(TComponent,TControl,TStroke) | Represents method Embedd(TComponent,TControl,TStroke).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBEndStyleChange(TObject) | Represents method LBEndStyleChange(TObject).
LBJoinStyleChange(TObject) | Represents method LBJoinStyleChange(TObject).
LBStyleChange(TObject) | Represents method LBStyleChange(TObject).
RefreshStroke(TStroke) | Represents method RefreshStroke(TStroke).
TabStrokeChange(TObject) | Represents method TabStrokeChange(TObject).
TBSizeChange(TObject) | Represents method TBSizeChange(TObject).
Top


TStrokeEditor.AddForm(TCustomForm,TControl) Method

Summary

Represents method AddForm(TCustomForm,TControl).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
public
 class procedure AddForm(const AForm: TCustomForm; const AParent: TControl); static;

Parameters

AForm
Type: TCustomForm

AParent
Type: TControl

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.CBColorChange(TObject) Method

Summary

Represents method CBColorChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure CBColorChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.CBVisibleChange(TObject) Method

Summary

Represents method CBVisibleChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure CBVisibleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Edit(TComponent,TStroke) Method

Summary

Represents method Edit(TComponent,TStroke).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AStroke:TStroke):Boolean; static;

Parameters

AOwner
Type: TComponent

AStroke
Type: TStroke

Return Value

Type: Boolean

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Embedd(TComponent,TControl,TStroke) Method

Summary

Represents method Embedd(TComponent,TControl,TStroke).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const AStroke:TStroke):TStrokeEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AStroke
Type: TStroke

Return Value

Type: TStrokeEditor

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBEndStyleChange(TObject) Method

Summary

Represents method LBEndStyleChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure LBEndStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBJoinStyleChange(TObject) Method

Summary

Represents method LBJoinStyleChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure LBJoinStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBStyleChange(TObject) Method

Summary

Represents method LBStyleChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure LBStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.RefreshStroke(TStroke) Method

Summary

Represents method RefreshStroke(TStroke).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
public
 procedure RefreshStroke(const AStroke:TStroke);

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TabStrokeChange(TObject) Method

Summary

Represents method TabStrokeChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure TabStrokeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TBSizeChange(TObject) Method

Summary

Represents method TBSizeChange(TObject).

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 procedure TBSizeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor Fields

Fields
Name | Description
CBColor | Represents field CBColor.
CBVisible | Represents field CBVisible.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBEndStyle | Represents field LBEndStyle.
LBJoinStyle | Represents field LBJoinStyle.
LBStyle | Represents field LBStyle.
LSize | Represents field LSize.
TabFill | Represents field TabFill.
TabOptions | Represents field TabOptions.
TabStroke | Represents field TabStroke.
TabStyle | Represents field TabStyle.
TBSize | Represents field TBSize.
Top


TStrokeEditor.CBColor Field

Summary

Represents field CBColor.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 CBColor: TColorComboBox;

Field Value

Type: TColorComboBox

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.CBVisible Field

Summary

Represents field CBVisible.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Label2 Field

Summary

Represents field Label2.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Label3 Field

Summary

Represents field Label3.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.Label4 Field

Summary

Represents field Label4.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBEndStyle Field

Summary

Represents field LBEndStyle.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 LBEndStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBJoinStyle Field

Summary

Represents field LBJoinStyle.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 LBJoinStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LBStyle Field

Summary

Represents field LBStyle.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 LBStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.LSize Field

Summary

Represents field LSize.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 LSize: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TabFill Field

Summary

Represents field TabFill.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 TabFill: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 TabOptions: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TabStroke Field

Summary

Represents field TabStroke.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 TabStroke: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TabStyle Field

Summary

Represents field TabStyle.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 TabStyle: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


TStrokeEditor.TBSize Field

Summary

Represents field TBSize.

Namespace: FMXTee.Editor.Painter.Stroke
Syntax
Delphi
published
 TBSize: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TStrokeEditor
  • FMXTee.Editor.Painter.Stroke


FMXTee.Grid Namespace

Summary

Represents namespace FMXTee.Grid.

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TFMXPainterAccess | Represents type TFMXPainterAccess.
TFMXTeeGrid | Represents type TFMXTeeGrid.
TPictureWrapper | Represents type TPictureWrapper.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTeeGrid | Represents type TTeeGrid.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top
Delegates
Name | Description
TCellEditedEvent | Represents type TCellEditedEvent.
TCellEditingEvent | Represents type TCellEditingEvent.
Top
Types
Name | Description
TControlClass | Represents type TControlClass.
Top
Routines
Name | Description
CursorOf(TCursor) | Overloaded. Represents method CursorOf(TCursor).
CursorOf(TMouseCursor) | Overloaded. Represents method CursorOf(TMouseCursor).
Top


FMXTee.Grid Classes

Classes
Name | Description
TColumnsAccess | Represents type TColumnsAccess.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TFMXPainterAccess | Represents type TFMXPainterAccess.
TFMXTeeGrid | Represents type TFMXTeeGrid.
TPictureWrapper | Represents type TPictureWrapper.
TRowGroupAccess | Represents type TRowGroupAccess.
TRowsAccess | Represents type TRowsAccess.
TTeeGrid | Represents type TTeeGrid.
TVirtualDataAccess | Represents type TVirtualDataAccess.
Top


TColumnsAccess Class

Summary

Represents type TColumnsAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TColumns
FMXTee.Grid.TColumnsAccess
Syntax
Delphi
type
 TColumnsAccess=class(TColumns);
See Also

Reference

  • FMXTee.Grid


TCustomTeeGridAccess Class

Summary

Represents type TCustomTeeGridAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TCustomTeeGrid
FMXTee.Grid.TCustomTeeGridAccess
Syntax
Delphi
type
 TCustomTeeGridAccess=class(TCustomTeeGrid);
See Also

Reference

  • FMXTee.Grid


TFMXPainterAccess Class

Summary

Represents type TFMXPainterAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TPainter
FMXTee.Painter.TFMXPainter
FMXTee.Grid.TFMXPainterAccess
Syntax
Delphi
type
 TFMXPainterAccess=class(TFMXPainter);

The TFMXPainterAccess type exposes the following members.

Constructors
Show:
Name | Description
Create(TCanvas) | Initializes a new instance of the TFMXPainter class. (Inherited from TFMXPainter.)
Top
Methods
Show:
Name | Description
ApplyFont(TFont,FMXTFont) | Represents method ApplyFont(TFont,FMXTFont). (Inherited from TFMXPainter.)
Clip(TRectF) | Represents method Clip(TRectF). (Inherited from TFMXPainter.)
Draw(TPicture,Single,Single) | Represents method Draw(TPicture,Single,Single). (Inherited from TFMXPainter.)
Draw(TPicture,TRectF) | Represents method Draw(TPicture,TRectF). (Inherited from TFMXPainter.)
Draw(TPointsF) | Represents method Draw(TPointsF). (Inherited from TFMXPainter.)
Draw(TRectF) | Represents method Draw(TRectF). (Inherited from TFMXPainter.)
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF). (Inherited from TFMXPainter.)
Fill(TPointsF) | Represents method Fill(TPointsF). (Inherited from TFMXPainter.)
Fill(TRectF) | Represents method Fill(TRectF). (Inherited from TFMXPainter.)
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor). (Inherited from TFMXPainter.)
FillEllipse(TRectF) | Represents method FillEllipse(TRectF). (Inherited from TFMXPainter.)
HideBrush | Represents method HideBrush. (Inherited from TFMXPainter.)
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single). (Inherited from TFMXPainter.)
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single). (Inherited from TFMXPainter.)
Lines(TPointsF) | Represents method Lines(TPointsF). (Inherited from TFMXPainter.)
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF). (Inherited from TFMXPainter.)
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF). (Inherited from TFMXPainter.)
SetBrush(TBrush) | Represents method SetBrush(TBrush). (Inherited from TFMXPainter.)
SetCanvas(TCanvas) | Represents method SetCanvas(TCanvas). (Inherited from TFMXPainter.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TFMXPainter.)
SetFontColor(TColor) | Represents method SetFontColor(TColor). (Inherited from TFMXPainter.)
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign). (Inherited from TFMXPainter.)
SetStroke(TStroke) | Represents method SetStroke(TStroke). (Inherited from TFMXPainter.)
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean). (Inherited from TFMXPainter.)
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign). (Inherited from TFMXPainter.)
TextHeight(String) | Represents method TextHeight(String). (Inherited from TFMXPainter.)
TextOut(TRectF,String) | Represents method TextOut(TRectF,String). (Inherited from TFMXPainter.)
TextWidth(String) | Represents method TextWidth(String). (Inherited from TFMXPainter.)
UnClip | Represents method UnClip. (Inherited from TFMXPainter.)
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single). (Inherited from TFMXPainter.)
Top
Fields
Show:
Name | Description
BitmapQuality | Represents field BitmapQuality. (Inherited from TFMXPainter.)
Top
See Also

Reference

  • FMXTee.Grid


TFMXTeeGrid Class

Summary

Represents type TFMXTeeGrid.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TCustomTeeGrid
FMXTee.Grid.TFMXTeeGrid
Syntax
Delphi
type
 TFMXTeeGrid=class(TCustomTeeGrid)
 end;

The TFMXTeeGrid type exposes the following members.

Properties
Show:
Name | Description
OnTyping | Represents property OnTyping.
Top
Methods
Show:
Name | Description
CancelEditor | Represents method CancelEditor.
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
Height | Represents method Height.
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Painter | Represents method Painter.
PasteSelected | Represents method PasteSelected.
StartEditor(TColumn,Integer,String) | Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
Width | Represents method Width.
Top
See Also

Reference

  • FMXTee.Grid


TFMXTeeGrid Properties

Properties
Name | Description
OnTyping | Represents property OnTyping.
Top


TFMXTeeGrid.OnTyping Property

Summary

Represents property OnTyping.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 property OnTyping:TNotifyEvent read FOnTyping write FOnTyping;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid Methods

Methods
Name | Description
CancelEditor | Represents method CancelEditor.
CheckScrollLimits(Single,Single) | Represents method CheckScrollLimits(Single,Single).
ContainsFocus | Represents method ContainsFocus.
Copy(TGridSelection) | Represents method Copy(TGridSelection).
DataChanged | Represents method DataChanged.
Height | Represents method Height.
HorizScrollBarHeight | Represents method HorizScrollBarHeight.
HorizScrollChanged(TObject) | Represents method HorizScrollChanged(TObject).
Painter | Represents method Painter.
PasteSelected | Represents method PasteSelected.
StartEditor(TColumn,Integer,String) | Represents method StartEditor(TColumn,Integer,String).
StopEditor | Represents method StopEditor.
VertScrollBarWidth | Represents method VertScrollBarWidth.
VertScrollChanged(TObject) | Represents method VertScrollChanged(TObject).
Width | Represents method Width.
Top


TFMXTeeGrid.CancelEditor Method

Summary

Represents method CancelEditor.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure CancelEditor; override;
See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.CheckScrollLimits(Single,Single) Method

Summary

Represents method CheckScrollLimits(Single,Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure CheckScrollLimits(var X,Y:Single); override;

Parameters

X
Type: Single

Y
Type: Single

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.ContainsFocus Method

Summary

Represents method ContainsFocus.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function ContainsFocus:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.Copy(TGridSelection) Method

Summary

Represents method Copy(TGridSelection).

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure Copy(const ASelection:TGridSelection=nil); override;

Parameters

ASelection
Type: TGridSelection

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.DataChanged Method

Summary

Represents method DataChanged.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DataChanged; override;
See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.Height Method

Summary

Represents method Height.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 function Height:Single; override;

Return Value

Type: Single

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.HorizScrollBarHeight Method

Summary

Represents method HorizScrollBarHeight.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function HorizScrollBarHeight:Single; override;

Return Value

Type: Single

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.HorizScrollChanged(TObject) Method

Summary

Represents method HorizScrollChanged(TObject).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure HorizScrollChanged(Sender:TObject); override;

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.Painter Method

Summary

Represents method Painter.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 function Painter:TPainter; override;

Return Value

Type: TPainter

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.PasteSelected Method

Summary

Represents method PasteSelected.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure PasteSelected; override;
See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.StartEditor(TColumn,Integer,String) Method

Summary

Represents method StartEditor(TColumn,Integer,String).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure StartEditor(const AColumn:TColumn; const ARow:Integer;
 const AutoEdit:String=''); override;

Parameters

AColumn
Type: TColumn

ARow
Type: Integer

AutoEdit
Type: String

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.StopEditor Method

Summary

Represents method StopEditor.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure StopEditor; override;
See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.VertScrollBarWidth Method

Summary

Represents method VertScrollBarWidth.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function VertScrollBarWidth:Single; override;

Return Value

Type: Single

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.VertScrollChanged(TObject) Method

Summary

Represents method VertScrollChanged(TObject).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure VertScrollChanged(Sender:TObject); override;

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TFMXTeeGrid.Width Method

Summary

Represents method Width.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 function Width:Single; override;

Return Value

Type: Single

See Also

Reference

  • TFMXTeeGrid
  • FMXTee.Grid


TPictureWrapper Class

Summary

Represents type TPictureWrapper.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TPicture
FMXTee.Grid.TPictureWrapper
Syntax
Delphi
type
 TPictureWrapper=class(TPicture)
 end;

The TPictureWrapper type exposes the following members.

Methods
Show:
Name | Description
NewPicture | Represents method NewPicture.
Top
See Also

Reference

  • FMXTee.Grid


TPictureWrapper Methods

Methods
Name | Description
NewPicture | Represents method NewPicture.
Top


TPictureWrapper.NewPicture Method

Summary

Represents method NewPicture.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 class function NewPicture:TPersistent; override;

Return Value

Type: TPersistent

See Also

Reference

  • TPictureWrapper
  • FMXTee.Grid


TRowGroupAccess Class

Summary

Represents type TRowGroupAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TRowGroup
FMXTee.Grid.TRowGroupAccess
Syntax
Delphi
type
 TRowGroupAccess=class(TRowGroup);
See Also

Reference

  • FMXTee.Grid


TRowsAccess Class

Summary

Represents type TRowsAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TRows
FMXTee.Grid.TRowsAccess
Syntax
Delphi
type
 TRowsAccess=class(TRows);
See Also

Reference

  • FMXTee.Grid


TTeeGrid Class

Summary

Represents type TTeeGrid.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TStyledControl
FMXTee.Control.TScrollableControl
FMXTee.Grid.TTeeGrid
Syntax
Delphi
type
 [ComponentPlatformsAttribute(TeeAllComponentPlatformIDs)]
 TTeeGrid=class(TScrollableControl)
 end;

The TTeeGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeGrid class. (Overrides TScrollableControl.Create(TComponent).)
Destroy | Represents the destructor of the TTeeGrid class. (Overrides TScrollableControl.Destroy.)
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
Back | Represents property Back.
Cells | Represents property Cells.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Columns | Represents property Columns.
Data | Represents property Data.
DataSource | Represents property DataSource.
DragMode | Represents property DragMode.
Editing | Represents property Editing.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Footer | Represents property Footer.
Grid | Represents property Grid.
Header | Represents property Header.
Headers | Represents property Headers.
Height | Represents property Height.
HitTest | Represents property HitTest.
Indicator | Represents property Indicator.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnAfterDraw | Represents property OnAfterDraw.
OnClick | Represents property OnClick.
OnClickedHeader | Represents property OnClickedHeader.
OnColumnResized | Represents property OnColumnResized.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnNewDetail | Represents property OnNewDetail.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
OnSelect | Represents property OnSelect.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
Painter | Represents property Painter.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
ReadOnly | Represents property ReadOnly.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Rows | Represents property Rows.
Scale | Represents property Scale.
ScrollBars | Represents property ScrollBars.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
ShowHint | Represents property ShowHint.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
ApplyStyle | Represents method ApplyStyle.
Assign(TPersistent) | Represents method Assign(TPersistent). (Inherited from TScrollableControl.)
Changed(TObject) | Represents method Changed(TObject).
CMGesture(TGestureEventInfo) | Represents method CMGesture(TGestureEventInfo).
DblClick | Represents method DblClick.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DialogKey(Word,TShiftState) | Represents method DialogKey(Word,TShiftState).
DoEnter | Represents method DoEnter.
DoExit | Represents method DoExit.
DoMouseLeave | Represents method DoMouseLeave.
GetCursorPos | Represents method GetCursorPos.
GetMaxBottom | Represents method GetMaxBottom. (Overrides TScrollableControl.GetMaxBottom.)
GetMaxRight | Represents method GetMaxRight. (Overrides TScrollableControl.GetMaxRight.)
KeyDown(Word,WideChar,TShiftState) | Represents method KeyDown(Word,WideChar,TShiftState).
Loaded | Represents method Loaded.
MouseDown(TMouseButton,TShiftState,Single,Single) | Represents method MouseDown(TMouseButton,TShiftState,Single,Single).
MouseMove(TShiftState,Single,Single) | Represents method MouseMove(TShiftState,Single,Single).
MouseUp(TMouseButton,TShiftState,Single,Single) | Represents method MouseUp(TMouseButton,TShiftState,Single,Single).
MouseWheel(TShiftState,Integer,Boolean) | Represents method MouseWheel(TShiftState,Integer,Boolean).
Paint | Represents method Paint.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean). (Overrides TScrollableControl.PerfectScrollBar(Boolean).)
RemainSize(Boolean) | Represents method RemainSize(Boolean). (Inherited from TScrollableControl.)
ResetScrollBars | Represents method ResetScrollBars. (Overrides TScrollableControl.ResetScrollBars.)
Resize | Represents method Resize.
SetScrollX(Single) | Represents method SetScrollX(Single). (Overrides TScrollableControl.SetScrollX(Single).)
SetScrollY(Single) | Represents method SetScrollY(Single). (Overrides TScrollableControl.SetScrollY(Single).)
UpdateScroll(Boolean,Single) | Represents method UpdateScroll(Boolean,Single). (Inherited from TScrollableControl.)
Top
Events
Show:
Name | Description
OnCellEdited | Represents property OnCellEdited.
OnCellEditing | Represents property OnCellEditing.
Top
Fields
Show:
Name | Description
IFMXScrollBars | Represents field IFMXScrollBars. (Inherited from TScrollableControl.)
Top
See Also

Reference

  • FMXTee.Grid


TTeeGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeGrid class.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TScrollableControl.Create(TComponent)
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Destroy Destructor

Summary

Represents the destructor of the TTeeGrid class.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TScrollableControl.Destroy
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
Back | Represents property Back.
Cells | Represents property Cells.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Columns | Represents property Columns.
Data | Represents property Data.
DataSource | Represents property DataSource.
DragMode | Represents property DragMode.
Editing | Represents property Editing.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Footer | Represents property Footer.
Grid | Represents property Grid.
Header | Represents property Header.
Headers | Represents property Headers.
Height | Represents property Height.
HitTest | Represents property HitTest.
Indicator | Represents property Indicator.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnAfterDraw | Represents property OnAfterDraw.
OnClick | Represents property OnClick.
OnClickedHeader | Represents property OnClickedHeader.
OnColumnResized | Represents property OnColumnResized.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnNewDetail | Represents property OnNewDetail.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
OnSelect | Represents property OnSelect.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
Painter | Represents property Painter.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
ReadOnly | Represents property ReadOnly.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Rows | Represents property Rows.
Scale | Represents property Scale.
ScrollBars | Represents property ScrollBars.
Scrolling | Represents property Scrolling.
Selected | Represents property Selected.
ShowHint | Represents property ShowHint.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TTeeGrid.Align Property

Summary

Represents property Align.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Anchors Property

Summary

Represents property Anchors.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Back Property

Summary

Represents property Back.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Back:TFormat read GetBack write SetBack;

Property Value

Type: TFormat

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Cells Property

Summary

Represents property Cells.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Cells:TTextRender read GetCells write SetCells;

Property Value

Type: TTextRender

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ClipChildren Property

Summary

Represents property ClipChildren.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property ClipChildren default True;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ClipParent Property

Summary

Represents property ClipParent.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property ClipParent;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Columns Property

Summary

Represents property Columns.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Columns:TColumns read GetColumns write SetColumns stored IsColumnsStored;

Property Value

Type: TColumns

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Data Property

Summary

Represents property Data.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 property Data:TVirtualData read GetDataItem write SetDataItem;

Property Value

Type: TVirtualData

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DataSource Property

Summary

Represents property DataSource.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property DataSource:TComponent read GetDataSource write SetDataSource;

Property Value

Type: TComponent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DragMode Property

Summary

Represents property DragMode.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Editing Property

Summary

Represents property Editing.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Editing:TGridEditing read GetEditing write SetEditing;

Property Value

Type: TGridEditing

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Enabled Property

Summary

Represents property Enabled.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.EnableDragHighlight Property

Summary

Represents property EnableDragHighlight.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property EnableDragHighlight;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Footer Property

Summary

Represents property Footer.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Footer:TGridFooter read GetFooter write SetFooter stored False;

Property Value

Type: TGridFooter

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Grid Property

Summary

Represents property Grid.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 property Grid:TFMXTeeGrid read FGrid;

Property Value

Type: TFMXTeeGrid

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Header Property

Summary

Represents property Header.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Header:TColumnHeaderBand read GetHeader write SetHeader;

Property Value

Type: TColumnHeaderBand

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Headers Property

Summary

Represents property Headers.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Headers:TGridBands read GetHeaders write SetHeaders stored False;

Property Value

Type: TGridBands

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Height Property

Summary

Represents property Height.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.HitTest Property

Summary

Represents property HitTest.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property HitTest;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Indicator Property

Summary

Represents property Indicator.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Indicator:TIndicator read GetIndicator write SetIndicator;

Property Value

Type: TIndicator

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Locked Property

Summary

Represents property Locked.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Locked;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Margins Property

Summary

Represents property Margins.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnAfterDraw Property

Summary

Represents property OnAfterDraw.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnAfterDraw:TNotifyEvent read GetAfterDraw write SetAfterDraw;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnClick Property

Summary

Represents property OnClick.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnClickedHeader Property

Summary

Represents property OnClickedHeader.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnClickedHeader:TNotifyEvent read GetClickedHeader write SetClickedHeader;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnColumnResized Property

Summary

Represents property OnColumnResized.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnColumnResized:TColumnEvent read FOnColumnResized write FOnColumnResized;

Property Value

Type: TColumnEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDragEnd Property

Summary

Represents property OnDragEnd.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDragEnd;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDragEnter Property

Summary

Represents property OnDragEnter.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDragEnter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDragLeave Property

Summary

Represents property OnDragLeave.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDragLeave;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnEnter Property

Summary

Represents property OnEnter.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnExit Property

Summary

Represents property OnExit.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnGesture Property

Summary

Represents property OnGesture.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnGesture;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnNewDetail Property

Summary

Represents property OnNewDetail.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnNewDetail:TNewDetailEvent read GetOnNewDetail write SetOnNewDetail;

Property Value

Type: TNewDetailEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnPaint Property

Summary

Represents property OnPaint.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnPaint;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnPainting Property

Summary

Represents property OnPainting.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnPainting;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnResize Property

Summary

Represents property OnResize.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnSelect Property

Summary

Represents property OnSelect.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnSelect:TNotifyEvent read GetOnSelect write SetOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Opacity Property

Summary

Represents property Opacity.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Opacity;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Padding Property

Summary

Represents property Padding.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Painter Property

Summary

Represents property Painter.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 property Painter:TFMXPainter read FPainter;

Property Value

Type: TFMXPainter

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Position Property

Summary

Represents property Position.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Position;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.RotationAngle Property

Summary

Represents property RotationAngle.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property RotationAngle;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.RotationCenter Property

Summary

Represents property RotationCenter.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property RotationCenter;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Rows Property

Summary

Represents property Rows.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Rows:TRows read GetRows write SetRows;

Property Value

Type: TRows

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Scale Property

Summary

Represents property Scale.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Scale;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property ScrollBars;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Scrolling Property

Summary

Represents property Scrolling.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Scrolling:TGridScrolling read GetScrolling write SetScrolling;

Property Value

Type: TGridScrolling

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Selected Property

Summary

Represents property Selected.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Selected:TGridSelection read GetSelected write SetSelected;

Property Value

Type: TGridSelection

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ShowHint Property

Summary

Represents property ShowHint.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Size Property

Summary

Represents property Size.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Size;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.TabOrder Property

Summary

Represents property TabOrder.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.TabStop Property

Summary

Represents property TabStop.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property TabStop default True;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Touch Property

Summary

Represents property Touch.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Touch;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.TouchTargetExpansion Property

Summary

Represents property TouchTargetExpansion.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property TouchTargetExpansion;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Visible Property

Summary

Represents property Visible.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Width Property

Summary

Represents property Width.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid Methods

Methods
Name | Description
ApplyStyle | Represents method ApplyStyle.
Changed(TObject) | Represents method Changed(TObject).
CMGesture(TGestureEventInfo) | Represents method CMGesture(TGestureEventInfo).
DblClick | Represents method DblClick.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DialogKey(Word,TShiftState) | Represents method DialogKey(Word,TShiftState).
DoEnter | Represents method DoEnter.
DoExit | Represents method DoExit.
DoMouseLeave | Represents method DoMouseLeave.
GetCursorPos | Represents method GetCursorPos.
GetMaxBottom | Represents method GetMaxBottom. (Overrides TScrollableControl.GetMaxBottom.)
GetMaxRight | Represents method GetMaxRight. (Overrides TScrollableControl.GetMaxRight.)
KeyDown(Word,WideChar,TShiftState) | Represents method KeyDown(Word,WideChar,TShiftState).
Loaded | Represents method Loaded.
MouseDown(TMouseButton,TShiftState,Single,Single) | Represents method MouseDown(TMouseButton,TShiftState,Single,Single).
MouseMove(TShiftState,Single,Single) | Represents method MouseMove(TShiftState,Single,Single).
MouseUp(TMouseButton,TShiftState,Single,Single) | Represents method MouseUp(TMouseButton,TShiftState,Single,Single).
MouseWheel(TShiftState,Integer,Boolean) | Represents method MouseWheel(TShiftState,Integer,Boolean).
Paint | Represents method Paint.
PerfectScrollBar(Boolean) | Represents method PerfectScrollBar(Boolean). (Overrides TScrollableControl.PerfectScrollBar(Boolean).)
ResetScrollBars | Represents method ResetScrollBars. (Overrides TScrollableControl.ResetScrollBars.)
Resize | Represents method Resize.
SetScrollX(Single) | Represents method SetScrollX(Single). (Overrides TScrollableControl.SetScrollX(Single).)
SetScrollY(Single) | Represents method SetScrollY(Single). (Overrides TScrollableControl.SetScrollY(Single).)
Top


TTeeGrid.ApplyStyle Method

Summary

Represents method ApplyStyle.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure ApplyStyle; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Changed(TObject) Method

Summary

Represents method Changed(TObject).

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure Changed(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.CMGesture(TGestureEventInfo) Method

Summary

Represents method CMGesture(TGestureEventInfo).

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure CMGesture(var EventInfo: TGestureEventInfo); override;

Parameters

EventInfo
Type: TGestureEventInfo

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DblClick Method

Summary

Represents method DblClick.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DblClick; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DialogKey(Word,TShiftState) Method

Summary

Represents method DialogKey(Word,TShiftState).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DialogKey(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DoEnter Method

Summary

Represents method DoEnter.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DoEnter; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DoExit Method

Summary

Represents method DoExit.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DoExit; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.DoMouseLeave Method

Summary

Represents method DoMouseLeave.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure DoMouseLeave; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.GetCursorPos Method

Summary

Represents method GetCursorPos.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function GetCursorPos:TPointF;

Return Value

Type: TPointF

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.GetMaxBottom Method

Summary

Represents method GetMaxBottom.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function GetMaxBottom:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetMaxBottom
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.GetMaxRight Method

Summary

Represents method GetMaxRight.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function GetMaxRight:Single; override;

Return Value

Type: Single

Overrides

TScrollableControl.GetMaxRight
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.KeyDown(Word,WideChar,TShiftState) Method

Summary

Represents method KeyDown(Word,WideChar,TShiftState).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure KeyDown(var Key: Word; var KeyChar: WideChar; Shift: TShiftState); override;

Parameters

Key
Type: Word

KeyChar
Type: WideChar

Shift
Type: TShiftState

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXTee.Grid
Syntax
Delphi
public
 procedure Loaded; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.MouseDown(TMouseButton,TShiftState,Single,Single) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Single,Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Single

Y
Type: Single

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.MouseMove(TShiftState,Single,Single) Method

Summary

Represents method MouseMove(TShiftState,Single,Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Single); override;

Parameters

Shift
Type: TShiftState

X
Type: Single

Y
Type: Single

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.MouseUp(TMouseButton,TShiftState,Single,Single) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Single,Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Single); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Single

Y
Type: Single

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.MouseWheel(TShiftState,Integer,Boolean) Method

Summary

Represents method MouseWheel(TShiftState,Integer,Boolean).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure MouseWheel(Shift: TShiftState; WheelDelta: Integer; var Handled: Boolean); override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

Handled
Type: Boolean

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Paint Method

Summary

Represents method Paint.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure Paint; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.PerfectScrollBar(Boolean) Method

Summary

Represents method PerfectScrollBar(Boolean).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 function PerfectScrollBar(const Vertical:Boolean):Boolean; override;

Parameters

Vertical
Type: Boolean

Return Value

Type: Boolean

Overrides

TScrollableControl.PerfectScrollBar(Boolean)
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.ResetScrollBars Method

Summary

Represents method ResetScrollBars.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure ResetScrollBars; override;

Overrides

TScrollableControl.ResetScrollBars
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.Resize Method

Summary

Represents method Resize.

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.SetScrollX(Single) Method

Summary

Represents method SetScrollX(Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure SetScrollX(const Value:Single); override;

Parameters

Value
Type: Single

Overrides

TScrollableControl.SetScrollX(Single)
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.SetScrollY(Single) Method

Summary

Represents method SetScrollY(Single).

Namespace: FMXTee.Grid
Syntax
Delphi
protected
 procedure SetScrollY(const Value:Single); override;

Parameters

Value
Type: Single

Overrides

TScrollableControl.SetScrollY(Single)
See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnCellEdited Event

Summary

Represents property OnCellEdited.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnCellEdited:TCellEditedEvent read FOnCellEdited write FOnCellEdited;

Value

Type: TCellEditedEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TTeeGrid.OnCellEditing Event

Summary

Represents property OnCellEditing.

Namespace: FMXTee.Grid
Syntax
Delphi
published
 property OnCellEditing:TCellEditingEvent read FOnCellEditing write FOnCellEditing;

Value

Type: TCellEditingEvent

See Also

Reference

  • TTeeGrid
  • FMXTee.Grid


TVirtualDataAccess Class

Summary

Represents type TVirtualDataAccess.

Namespace: FMXTee.Grid
Inheritance Hierarchy
TVirtualData
FMXTee.Grid.TVirtualDataAccess
Syntax
Delphi
type
 TVirtualDataAccess=class(TVirtualData);
See Also

Reference

  • FMXTee.Grid


FMXTee.Grid Delegates

Delegates
Name | Description
TCellEditedEvent | Represents type TCellEditedEvent.
TCellEditingEvent | Represents type TCellEditingEvent.
Top


TCellEditedEvent Delegate

Summary

Represents type TCellEditedEvent.

Namespace: FMXTee.Grid
Syntax
Delphi
type
 TCellEditedEvent=procedure(const Sender:TObject; const AEditor:TControl;
 const AColumn:TColumn; const ARow:Integer;
 var ChangeData:Boolean;
 var NewData:String) of object;
See Also

Reference

  • FMXTee.Grid


TCellEditingEvent Delegate

Summary

Represents type TCellEditingEvent.

Namespace: FMXTee.Grid
Syntax
Delphi
type
 TCellEditingEvent=procedure(const Sender:TObject; const AEditor:TControl;
 const AColumn:TColumn; const ARow:Integer) of object;
See Also

Reference

  • FMXTee.Grid


FMXTee.Grid Types

Types
Name | Description
TControlClass | Represents type TControlClass.
Top


TControlClass Type

Summary

Represents type TControlClass.

Namespace: FMXTee.Grid
Syntax
Delphi
type
 TControlClass=class of TControl;
See Also

Reference

  • FMXTee.Grid


FMXTee.Grid Routines

Routines
Name | Description
CursorOf(TCursor) | Overloaded. Represents method CursorOf(TCursor).
CursorOf(TMouseCursor) | Overloaded. Represents method CursorOf(TMouseCursor).
Top


CursorOf(TCursor) Method

Summary

Represents method CursorOf(TCursor).

Namespace: FMXTee.Grid
Syntax
Delphi
function CursorOf(const ACursor:TCursor):TMouseCursor; overload;

Parameters

ACursor
Type: TCursor

Return Value

Type: TMouseCursor

See Also

Reference

  • FMXTee.Grid


CursorOf(TMouseCursor) Method

Summary

Represents method CursorOf(TMouseCursor).

Namespace: FMXTee.Grid
Syntax
Delphi
function CursorOf(const ACursor:TMouseCursor):TCursor; overload;

Parameters

ACursor
Type: TMouseCursor

Return Value

Type: TCursor

See Also

Reference

  • FMXTee.Grid


FMXTee.Grid.Layout Namespace

Summary

Represents namespace FMXTee.Grid.Layout.

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridLayout | Represents type TGridLayout.
TLocalCols | Represents type TLocalCols.
TWriterAccess | Represents type TWriterAccess.
Top
Variables
Name | Description
ColumnMoves | Represents variable ColumnMoves.
CurNode | Represents variable CurNode.
Layout | Represents variable Layout.
ParentNode | Represents variable ParentNode.
RootNode | Represents variable RootNode.
XMLDoc | Represents variable XMLDoc.
Top


FMXTee.Grid.Layout Classes

Classes
Name | Description
TColumnAccess | Represents type TColumnAccess.
TGridLayout | Represents type TGridLayout.
TLocalCols | Represents type TLocalCols.
TWriterAccess | Represents type TWriterAccess.
Top


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: FMXTee.Grid.Layout
Inheritance Hierarchy
TColumn
FMXTee.Grid.Layout.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);
See Also

Reference

  • FMXTee.Grid.Layout


TGridLayout Class

Summary

Represents type TGridLayout.

Namespace: FMXTee.Grid.Layout
Inheritance Hierarchy
TObject
FMXTee.Grid.Layout.TGridLayout
Syntax
Delphi
type
 TGridLayout = class
 end;

The TGridLayout type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGridLayout class.
Top
Methods
Show:
Name | Description
LoadFromFile(TTeeGrid,String) | Represents method LoadFromFile(TTeeGrid,String).
LoadFromStrings(TTeeGrid,TStrings) | Represents method LoadFromStrings(TTeeGrid,TStrings).
SaveToFile(TTeeGrid,String) | Represents method SaveToFile(TTeeGrid,String).
SaveToStrings(TTeeGrid) | Represents method SaveToStrings(TTeeGrid).
SaveXML(TTeeGrid,String) | Represents method SaveXML(TTeeGrid,String).
Top
See Also

Reference

  • FMXTee.Grid.Layout


TGridLayout.Create Constructor

Summary

Initializes a new instance of the TGridLayout class.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TGridLayout.LoadFromFile(TTeeGrid,String) Method

Summary

Represents method LoadFromFile(TTeeGrid,String).

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
public
 procedure LoadFromFile(AGrid : TTeeGrid; Filename: String);

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TGridLayout.LoadFromStrings(TTeeGrid,TStrings) Method

Summary

Represents method LoadFromStrings(TTeeGrid,TStrings).

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
public
 procedure LoadFromStrings(AGrid : TTeeGrid; AStrings: TStrings);

Parameters

AGrid
Type: TTeeGrid

AStrings
Type: TStrings

See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TGridLayout.SaveToFile(TTeeGrid,String) Method

Summary

Represents method SaveToFile(TTeeGrid,String).

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
public
 procedure SaveToFile(AGrid : TTeeGrid; Filename: String);

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TGridLayout.SaveToStrings(TTeeGrid) Method

Summary

Represents method SaveToStrings(TTeeGrid).

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
public
 function SaveToStrings(AGrid : TTeeGrid) : TStringList;

Parameters

AGrid
Type: TTeeGrid

Return Value

Type: TStringList

See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TGridLayout.SaveXML(TTeeGrid,String) Method

Summary

Represents method SaveXML(TTeeGrid,String).

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
protected
 function SaveXML(AGrid : TTeeGrid; Filename: String): TStringList;

Parameters

AGrid
Type: TTeeGrid

Filename
Type: String

Return Value

Type: TStringList

See Also

Reference

  • TGridLayout
  • FMXTee.Grid.Layout


TLocalCols Class

Summary

Represents type TLocalCols.

Namespace: FMXTee.Grid.Layout
Inheritance Hierarchy
TColumns
FMXTee.Grid.Layout.TLocalCols
Syntax
Delphi
type
 TLocalCols = class(TColumns);
See Also

Reference

  • FMXTee.Grid.Layout


TWriterAccess Class

Summary

Represents type TWriterAccess.

Namespace: FMXTee.Grid.Layout
Inheritance Hierarchy
TWriter
FMXTee.Grid.Layout.TWriterAccess
Syntax
Delphi
type
 TWriterAccess=class(TWriter);
See Also

Reference

  • FMXTee.Grid.Layout


FMXTee.Grid.Layout Variables

Variables
Name | Description
ColumnMoves | Represents variable ColumnMoves.
CurNode | Represents variable CurNode.
Layout | Represents variable Layout.
ParentNode | Represents variable ParentNode.
RootNode | Represents variable RootNode.
XMLDoc | Represents variable XMLDoc.
Top


ColumnMoves Variable

Summary

Represents variable ColumnMoves.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
ColumnMoves : Array of String;

Value

Type: Array of String

See Also

Reference

  • FMXTee.Grid.Layout


CurNode Variable

Summary

Represents variable CurNode.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • FMXTee.Grid.Layout


Layout Variable

Summary

Represents variable Layout.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
Layout: TGridLayout;

Value

Type: TGridLayout

See Also

Reference

  • FMXTee.Grid.Layout


ParentNode Variable

Summary

Represents variable ParentNode.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • FMXTee.Grid.Layout


RootNode Variable

Summary

Represents variable RootNode.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
RootNode, ParentNode, CurNode : IXMLNODE;

Value

Type: IXMLNODE

See Also

Reference

  • FMXTee.Grid.Layout


XMLDoc Variable

Summary

Represents variable XMLDoc.

Namespace: FMXTee.Grid.Layout
Syntax
Delphi
XMLDoc :TXMLDocument;

Value

Type: TXMLDocument

See Also

Reference

  • FMXTee.Grid.Layout


FMXTee.Grid.Themes Namespace

Summary

Represents namespace FMXTee.Grid.Themes.

Records
Name | Description
TFMXGridThemes | Represents type TFMXGridThemes.
Top


FMXTee.Grid.Themes Records

Records
Name | Description
TFMXGridThemes | Represents type TFMXGridThemes.
Top


TFMXGridThemes Record

Summary

Represents type TFMXGridThemes.

Namespace: FMXTee.Grid.Themes
Syntax
Delphi
type
 TFMXGridThemes=record
 end;

The TFMXGridThemes type exposes the following members.

Methods
Show:
Name | Description
ApplyTo(TTeeGrid) | Represents method ApplyTo(TTeeGrid).
Available(TStrings) | Represents method Available(TStrings).
StylesPath | Represents method StylesPath.
Top
See Also

Reference

  • FMXTee.Grid.Themes


TFMXGridThemes Methods

Methods
Name | Description
ApplyTo(TTeeGrid) | Represents method ApplyTo(TTeeGrid).
Available(TStrings) | Represents method Available(TStrings).
StylesPath | Represents method StylesPath.
Top


TFMXGridThemes.ApplyTo(TTeeGrid) Method

Summary

Represents method ApplyTo(TTeeGrid).

Namespace: FMXTee.Grid.Themes
Syntax
Delphi
public
 class procedure ApplyTo(const AGrid:TTeeGrid); static;

Parameters

AGrid
Type: TTeeGrid

See Also

Reference

  • TFMXGridThemes
  • FMXTee.Grid.Themes


TFMXGridThemes.Available(TStrings) Method

Summary

Represents method Available(TStrings).

Namespace: FMXTee.Grid.Themes
Syntax
Delphi
public
 class procedure Available(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TFMXGridThemes
  • FMXTee.Grid.Themes


TFMXGridThemes.StylesPath Method

Summary

Represents method StylesPath.

Namespace: FMXTee.Grid.Themes
Syntax
Delphi
public
 class function StylesPath:String; static;

Return Value

Type: String

See Also

Reference

  • TFMXGridThemes
  • FMXTee.Grid.Themes


FMXTee.Painter Namespace

Summary

Represents namespace FMXTee.Painter.

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TFMXPainter | Represents type TFMXPainter.
TPictureAccess | Represents type TPictureAccess.
Top
Enumerations
Name | Description
TBitmapQuality | Represents type TBitmapQuality.
Top
Types
Name | Description
FMXGradient | Represents an alias of the TGradient type.
FMXJoin | Represents an alias of the TStrokeJoin type.
FMXTBrush | Represents an alias of the TBrush type.
FMXTFont | Represents an alias of the TFont type.
Top
Constants
Name | Description
BrushKindBitmap | Represents constant BrushKindBitmap.
BrushKindGradient | Represents constant BrushKindGradient.
BrushKindNone | Represents constant BrushKindNone.
BrushKindSolid | Represents constant BrushKindSolid.
Top
Routines
Name | Description
BoundsOf(TBitmap) | Represents method BoundsOf(TBitmap).
CalcHorizAlign(THorizontalAlign) | Represents method CalcHorizAlign(THorizontalAlign).
CalcVertAlign(TVerticalAlign) | Represents method CalcVertAlign(TVerticalAlign).
DashOf(TStrokeStyle) | Represents method DashOf(TStrokeStyle).
SetDefaultFontNameAndSize | Represents method SetDefaultFontNameAndSize.
Top


FMXTee.Painter Classes

Classes
Name | Description
TBrushAccess | Represents type TBrushAccess.
TFMXPainter | Represents type TFMXPainter.
TPictureAccess | Represents type TPictureAccess.
Top


TBrushAccess Class

Summary

Represents type TBrushAccess.

Namespace: FMXTee.Painter
Inheritance Hierarchy
TBrush
FMXTee.Painter.TBrushAccess
Syntax
Delphi
type
 TBrushAccess=class(TBrush);
See Also

Reference

  • FMXTee.Painter


TFMXPainter Class

Summary

Represents type TFMXPainter.

Namespace: FMXTee.Painter
Inheritance Hierarchy
TPainter
FMXTee.Painter.TFMXPainter
FMXTee.Grid.TFMXPainterAccess
Syntax
Delphi
type
 TFMXPainter=class(TPainter)
 end;

The TFMXPainter type exposes the following members.

Constructors
Show:
Name | Description
Create(TCanvas) | Initializes a new instance of the TFMXPainter class.
Destroy | Represents the destructor of the TFMXPainter class.
Top
Methods
Show:
Name | Description
ApplyFont(TFont,FMXTFont) | Represents method ApplyFont(TFont,FMXTFont).
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetCanvas(TCanvas) | Represents method SetCanvas(TCanvas).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top
Fields
Show:
Name | Description
BitmapQuality | Represents field BitmapQuality.
Top
See Also

Reference

  • FMXTee.Painter


TFMXPainter Constructors

Constructors
Name | Description
Create(TCanvas) | Initializes a new instance of the TFMXPainter class.
Destroy | Represents the destructor of the TFMXPainter class.
Top


TFMXPainter.Create(TCanvas) Constructor

Summary

Initializes a new instance of the TFMXPainter class.

Namespace: FMXTee.Painter
Syntax
Delphi
public
 Constructor Create(const ACanvas:TCanvas);

Parameters

ACanvas
Type: TCanvas

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Destroy Destructor

Summary

Represents the destructor of the TFMXPainter class.

Namespace: FMXTee.Painter
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter Methods

Methods
Name | Description
ApplyFont(TFont,FMXTFont) | Represents method ApplyFont(TFont,FMXTFont).
Clip(TRectF) | Represents method Clip(TRectF).
Draw(TPicture,Single,Single) | Represents method Draw(TPicture,Single,Single).
Draw(TPicture,TRectF) | Represents method Draw(TPicture,TRectF).
Draw(TPointsF) | Represents method Draw(TPointsF).
Draw(TRectF) | Represents method Draw(TRectF).
DrawEllipse(TRectF) | Represents method DrawEllipse(TRectF).
Fill(TPointsF) | Represents method Fill(TPointsF).
Fill(TRectF) | Represents method Fill(TRectF).
Fill(TRectF,TColor) | Represents method Fill(TRectF,TColor).
FillEllipse(TRectF) | Represents method FillEllipse(TRectF).
HideBrush | Represents method HideBrush.
HorizontalLine(Single,Single,Single) | Represents method HorizontalLine(Single,Single,Single).
Line(Single,Single,Single,Single) | Represents method Line(Single,Single,Single,Single).
Lines(TPointsF) | Represents method Lines(TPointsF).
Paint(TFormat,TPointsF) | Represents method Paint(TFormat,TPointsF).
Paint(TFormat,TRectF) | Represents method Paint(TFormat,TRectF).
SetBrush(TBrush) | Represents method SetBrush(TBrush).
SetCanvas(TCanvas) | Represents method SetCanvas(TCanvas).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontColor(TColor) | Represents method SetFontColor(TColor).
SetHorizontalAlign(THorizontalAlign) | Represents method SetHorizontalAlign(THorizontalAlign).
SetStroke(TStroke) | Represents method SetStroke(TStroke).
SetTextTrimming(TTrimmingMode,Boolean) | Represents method SetTextTrimming(TTrimmingMode,Boolean).
SetVerticalAlign(TVerticalAlign) | Represents method SetVerticalAlign(TVerticalAlign).
TextHeight(String) | Represents method TextHeight(String).
TextOut(TRectF,String) | Represents method TextOut(TRectF,String).
TextWidth(String) | Represents method TextWidth(String).
UnClip | Represents method UnClip.
VerticalLine(Single,Single,Single) | Represents method VerticalLine(Single,Single,Single).
Top


TFMXPainter.ApplyFont(TFont,FMXTFont) Method

Summary

Represents method ApplyFont(TFont,FMXTFont).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 class procedure ApplyFont(const ASource:Tee.Format.TFont; const ADest:FMXTFont); static;

Parameters

ASource
Type: Tee.Format.TFont

ADest
Type: System.Void

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Clip(TRectF) Method

Summary

Represents method Clip(TRectF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Clip(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Draw(TRectF) Method

Summary

Represents method Draw(TRectF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Draw(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.DrawEllipse(TRectF) Method

Summary

Represents method DrawEllipse(TRectF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure DrawEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Fill(TRectF,TColor) Method

Summary

Represents method Fill(TRectF,TColor).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Fill(const R:TRectF; const AColor:TColor); override;

Parameters

R
Type: TRectF

AColor
Type: TColor

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.FillEllipse(TRectF) Method

Summary

Represents method FillEllipse(TRectF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure FillEllipse(const R:TRectF); override;

Parameters

R
Type: TRectF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.HideBrush Method

Summary

Represents method HideBrush.

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure HideBrush; override;
See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.HorizontalLine(Single,Single,Single) Method

Summary

Represents method HorizontalLine(Single,Single,Single).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure HorizontalLine(const Y,X0,X1:Single); override;

Parameters

Y
Type: Single

X0
Type: Single

X1
Type: Single

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Line(Single,Single,Single,Single) Method

Summary

Represents method Line(Single,Single,Single,Single).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Line(const X0,Y0,X1,Y1:Single); override;

Parameters

X0
Type: Single

Y0
Type: Single

X1
Type: Single

Y1
Type: Single

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Lines(TPointsF) Method

Summary

Represents method Lines(TPointsF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Lines(const P:TPointsF); override;

Parameters

P
Type: TPointsF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.Paint(TFormat,TRectF) Method

Summary

Represents method Paint(TFormat,TRectF).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure Paint(const AFormat:TFormat; const R:TRectF); override;

Parameters

AFormat
Type: TFormat

R
Type: TRectF

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetBrush(TBrush) Method

Summary

Represents method SetBrush(TBrush).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetBrush(const ABrush:TBrush); override;

Parameters

ABrush
Type: TBrush

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetCanvas(TCanvas) Method

Summary

Represents method SetCanvas(TCanvas).

Namespace: FMXTee.Painter
Syntax
Delphi
protected
 procedure SetCanvas(const ACanvas:TCanvas); inline;

Parameters

ACanvas
Type: TCanvas

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetFont(const AFont:TFont); override;

Parameters

AFont
Type: TFont

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetFontColor(TColor) Method

Summary

Represents method SetFontColor(TColor).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetFontColor(const AColor:TColor); override;

Parameters

AColor
Type: TColor

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetHorizontalAlign(THorizontalAlign) Method

Summary

Represents method SetHorizontalAlign(THorizontalAlign).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetHorizontalAlign(const Align:THorizontalAlign); override;

Parameters

Align
Type: THorizontalAlign

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetStroke(TStroke) Method

Summary

Represents method SetStroke(TStroke).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetStroke(const AStroke:TStroke); override;

Parameters

AStroke
Type: TStroke

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetTextTrimming(TTrimmingMode,Boolean) Method

Summary

Represents method SetTextTrimming(TTrimmingMode,Boolean).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetTextTrimming(const ATrimming:TTrimmingMode; const Ellipsi:Boolean); override;

Parameters

ATrimming
Type: TTrimmingMode

Ellipsi
Type: Boolean

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.SetVerticalAlign(TVerticalAlign) Method

Summary

Represents method SetVerticalAlign(TVerticalAlign).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure SetVerticalAlign(const Align:TVerticalAlign); override;

Parameters

Align
Type: TVerticalAlign

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.TextHeight(String) Method

Summary

Represents method TextHeight(String).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 function TextHeight(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.TextOut(TRectF,String) Method

Summary

Represents method TextOut(TRectF,String).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure TextOut(const ARect:TRectF; const AText:String); override;

Parameters

ARect
Type: TRectF

AText
Type: String

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.TextWidth(String) Method

Summary

Represents method TextWidth(String).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 function TextWidth(const AText:String):Single; override;

Parameters

AText
Type: String

Return Value

Type: Single

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.UnClip Method

Summary

Represents method UnClip.

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure UnClip; override;
See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter.VerticalLine(Single,Single,Single) Method

Summary

Represents method VerticalLine(Single,Single,Single).

Namespace: FMXTee.Painter
Syntax
Delphi
public
 procedure VerticalLine(const X,Y0,Y1:Single); override;

Parameters

X
Type: Single

Y0
Type: Single

Y1
Type: Single

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TFMXPainter Fields

Fields
Name | Description
BitmapQuality | Represents field BitmapQuality.
Top


TFMXPainter.BitmapQuality Field

Summary

Represents field BitmapQuality.

Namespace: FMXTee.Painter
Syntax
Delphi
public
 BitmapQuality : TBitmapQuality;

Field Value

Type: TBitmapQuality

See Also

Reference

  • TFMXPainter
  • FMXTee.Painter


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: FMXTee.Painter
Inheritance Hierarchy
TPicture
FMXTee.Painter.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • FMXTee.Painter


FMXTee.Painter Enumerations

Enumerations
Name | Description
TBitmapQuality | Represents type TBitmapQuality.
Top


TBitmapQuality Enumeration

Summary

Represents type TBitmapQuality.

Namespace: FMXTee.Painter
Syntax
Delphi
type
 TBitmapQuality=(Quality,Speed);

The TBitmapQuality type exposes the following members.

Members
Show:
Name | Description
Quality | Represents constant Quality.
Speed | Represents constant Speed.
Top
See Also

Reference

  • FMXTee.Painter


FMXTee.Painter Types

Types
Name | Description
FMXGradient | Represents an alias of the TGradient type.
FMXJoin | Represents an alias of the TStrokeJoin type.
FMXTBrush | Represents an alias of the TBrush type.
FMXTFont | Represents an alias of the TFont type.
Top


FMXGradient Type

Summary

Represents an alias of the TGradient type.

Namespace: FMXTee.Painter
Syntax
Delphi
type
 FMXGradient=FMX.Graphics.TGradient;
See Also

Reference

  • FMXTee.Painter


FMXJoin Type

Summary

Represents an alias of the TStrokeJoin type.

Namespace: FMXTee.Painter
Syntax
Delphi
type
 FMXJoin=FMX.Graphics.TStrokeJoin;
See Also

Reference

  • FMXTee.Painter


FMXTBrush Type

Summary

Represents an alias of the TBrush type.

Namespace: FMXTee.Painter
Syntax
Delphi
type
 FMXTBrush=FMX.Graphics.TBrush;
See Also

Reference

  • FMXTee.Painter


FMXTFont Type

Summary

Represents an alias of the TFont type.

Namespace: FMXTee.Painter
Syntax
Delphi
type
 FMXTFont=FMX.Graphics.TFont;
See Also

Reference

  • FMXTee.Painter


FMXTee.Painter Constants

Constants
Name | Description
BrushKindBitmap | Represents constant BrushKindBitmap.
BrushKindGradient | Represents constant BrushKindGradient.
BrushKindNone | Represents constant BrushKindNone.
BrushKindSolid | Represents constant BrushKindSolid.
Top


BrushKindBitmap Constant

Summary

Represents constant BrushKindBitmap.

Namespace: FMXTee.Painter
Syntax
Delphi
 BrushKindBitmap=TBrushKind.Bitmap;

Value

Type: Void

See Also

Reference

  • FMXTee.Painter


BrushKindGradient Constant

Summary

Represents constant BrushKindGradient.

Namespace: FMXTee.Painter
Syntax
Delphi
 BrushKindGradient=TBrushKind.Gradient;

Value

Type: Void

See Also

Reference

  • FMXTee.Painter


BrushKindNone Constant

Summary

Represents constant BrushKindNone.

Namespace: FMXTee.Painter
Syntax
Delphi
 BrushKindNone=TBrushKind.None;

Value

Type: Void

See Also

Reference

  • FMXTee.Painter


BrushKindSolid Constant

Summary

Represents constant BrushKindSolid.

Namespace: FMXTee.Painter
Syntax
Delphi
 BrushKindSolid=TBrushKind.Solid;

Value

Type: Void

See Also

Reference

  • FMXTee.Painter


FMXTee.Painter Routines

Routines
Name | Description
BoundsOf(TBitmap) | Represents method BoundsOf(TBitmap).
CalcHorizAlign(THorizontalAlign) | Represents method CalcHorizAlign(THorizontalAlign).
CalcVertAlign(TVerticalAlign) | Represents method CalcVertAlign(TVerticalAlign).
DashOf(TStrokeStyle) | Represents method DashOf(TStrokeStyle).
SetDefaultFontNameAndSize | Represents method SetDefaultFontNameAndSize.
Top


BoundsOf(TBitmap) Method

Summary

Represents method BoundsOf(TBitmap).

Namespace: FMXTee.Painter
Syntax
Delphi
function BoundsOf(const ABitmap:TBitmap):TRectF;

Parameters

ABitmap
Type: TBitmap

Return Value

Type: TRectF

See Also

Reference

  • FMXTee.Painter


CalcHorizAlign(THorizontalAlign) Method

Summary

Represents method CalcHorizAlign(THorizontalAlign).

Namespace: FMXTee.Painter
Syntax
Delphi
function CalcHorizAlign(const Align:THorizontalAlign):TTextAlign;

Parameters

Align
Type: THorizontalAlign

Return Value

Type: TTextAlign

See Also

Reference

  • FMXTee.Painter


CalcVertAlign(TVerticalAlign) Method

Summary

Represents method CalcVertAlign(TVerticalAlign).

Namespace: FMXTee.Painter
Syntax
Delphi
function CalcVertAlign(const Align:TVerticalAlign):TTextAlign;

Parameters

Align
Type: TVerticalAlign

Return Value

Type: TTextAlign

See Also

Reference

  • FMXTee.Painter


DashOf(TStrokeStyle) Method

Summary

Represents method DashOf(TStrokeStyle).

Namespace: FMXTee.Painter
Syntax
Delphi
function DashOf(const AStyle:TStrokeStyle):TStrokeDash;

Parameters

AStyle
Type: TStrokeStyle

Return Value

Type: TStrokeDash

See Also

Reference

  • FMXTee.Painter


SetDefaultFontNameAndSize Method

Summary

Represents method SetDefaultFontNameAndSize.

Namespace: FMXTee.Painter
Syntax
Delphi
procedure SetDefaultFontNameAndSize;
See Also

Reference

  • FMXTee.Painter


FMXTee.Picture Namespace

Summary

Represents namespace FMXTee.Picture.

Classes
Name | Description
TPictureAccess | Represents type TPictureAccess.
Top
Records
Name | Description
TFMXPicture | Represents type TFMXPicture.
Top


FMXTee.Picture Classes

Classes
Name | Description
TPictureAccess | Represents type TPictureAccess.
Top


TPictureAccess Class

Summary

Represents type TPictureAccess.

Namespace: FMXTee.Picture
Inheritance Hierarchy
TPicture
FMXTee.Picture.TPictureAccess
Syntax
Delphi
type
 TPictureAccess=class(TPicture);
See Also

Reference

  • FMXTee.Picture


FMXTee.Picture Records

Records
Name | Description
TFMXPicture | Represents type TFMXPicture.
Top


TFMXPicture Record

Summary

Represents type TFMXPicture.

Namespace: FMXTee.Picture
Syntax
Delphi
type
 TFMXPicture=record
 end;

The TFMXPicture type exposes the following members.

Methods
Show:
Name | Description
From(String) | Overloaded. Represents method From(String).
From(TBitmap) | Overloaded. Represents method From(TBitmap).
From(TImage) | Overloaded. Represents method From(TImage).
From(TImageControl) | Overloaded. Represents method From(TImageControl).
Load(String) | Overloaded. Represents method Load(String).
Load(TPicture,String) | Overloaded. Represents method Load(TPicture,String).
TypeOfGraphic(TBitmap) | Represents method TypeOfGraphic(TBitmap).
Top
See Also

Reference

  • FMXTee.Picture


TFMXPicture Methods

Methods
Name | Description
From(String) | Overloaded. Represents method From(String).
From(TBitmap) | Overloaded. Represents method From(TBitmap).
From(TImage) | Overloaded. Represents method From(TImage).
From(TImageControl) | Overloaded. Represents method From(TImageControl).
Load(String) | Overloaded. Represents method Load(String).
Load(TPicture,String) | Overloaded. Represents method Load(TPicture,String).
TypeOfGraphic(TBitmap) | Represents method TypeOfGraphic(TBitmap).
Top


TFMXPicture.From(String) Method

Summary

Represents method From(String).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function From(const AFileName:String):TPicture; overload; static;

Parameters

AFileName
Type: String

Return Value

Type: TPicture

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.From(TBitmap) Method

Summary

Represents method From(TBitmap).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function From(const ABitmap:TBitmap):TPicture; overload; static;

Parameters

ABitmap
Type: TBitmap

Return Value

Type: TPicture

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.From(TImage) Method

Summary

Represents method From(TImage).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function From(const AImage:TImage):TPicture; overload; static;

Parameters

AImage
Type: TImage

Return Value

Type: TPicture

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.From(TImageControl) Method

Summary

Represents method From(TImageControl).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function From(const AImage:TImageControl):TPicture; overload; static;

Parameters

AImage
Type: TImageControl

Return Value

Type: TPicture

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.Load(String) Method

Summary

Represents method Load(String).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function Load(const AFileName:String):TBitmap; overload; static;

Parameters

AFileName
Type: String

Return Value

Type: TBitmap

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.Load(TPicture,String) Method

Summary

Represents method Load(TPicture,String).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class procedure Load(const APicture:TPicture; const AFileName:String); overload; static;

Parameters

APicture
Type: TPicture

AFileName
Type: String

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


TFMXPicture.TypeOfGraphic(TBitmap) Method

Summary

Represents method TypeOfGraphic(TBitmap).

Namespace: FMXTee.Picture
Syntax
Delphi
public
 class function TypeOfGraphic(const ABitmap: TBitmap): String; static;

Parameters

ABitmap
Type: TBitmap

Return Value

Type: String

See Also

Reference

  • TFMXPicture
  • FMXTee.Picture


DCLFMXTeeGrid

Summary

Represents namespace DCLFMXTeeGrid.

Namespaces
Name | Description
FMXTee.Grid.About | Represents namespace FMXTee.Grid.About.
FMXTeeGridRegister | Represents namespace FMXTeeGridRegister.
Top


FMXTee.Grid.About Namespace

Summary

Represents namespace FMXTee.Grid.About.

Classes
Name | Description
TFMXGridAbout | Represents type TFMXGridAbout.
Top
Constants
Name | Description
TeeGrid_Version | Represents constant TeeGrid_Version.
TeeGrid_Version_Numeric | Represents constant TeeGrid_Version_Numeric.
Top


FMXTee.Grid.About Classes

Classes
Name | Description
TFMXGridAbout | Represents type TFMXGridAbout.
Top


TFMXGridAbout Class

Summary

Represents type TFMXGridAbout.

Namespace: FMXTee.Grid.About
Inheritance Hierarchy
TForm
FMXTee.Grid.About.TFMXGridAbout
Syntax
Delphi
type
 TFMXGridAbout = class(TForm)
 end;

The TFMXGridAbout type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent) | Represents method Show(TComponent).
Timer1Timer(TObject) | Represents method Timer1Timer(TObject).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LVersion | Represents field LVersion.
TeeGrid1 | Represents field TeeGrid1.
Timer1 | Represents field Timer1.
Top
See Also

Reference

  • FMXTee.Grid.About


TFMXGridAbout Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent) | Represents method Show(TComponent).
Timer1Timer(TObject) | Represents method Timer1Timer(TObject).
Top


TFMXGridAbout.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.Show(TComponent) Method

Summary

Represents method Show(TComponent).

Namespace: FMXTee.Grid.About
Syntax
Delphi
public
 class procedure Show(const AOwner:TComponent); static;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.Timer1Timer(TObject) Method

Summary

Represents method Timer1Timer(TObject).

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 procedure Timer1Timer(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout Fields

Fields
Name | Description
Button1 | Represents field Button1.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LVersion | Represents field LVersion.
TeeGrid1 | Represents field TeeGrid1.
Timer1 | Represents field Timer1.
Top


TFMXGridAbout.Button1 Field

Summary

Represents field Button1.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.LVersion Field

Summary

Represents field LVersion.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 LVersion: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.TeeGrid1 Field

Summary

Represents field TeeGrid1.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 TeeGrid1: TTeeGrid;

Field Value

Type: TTeeGrid

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


TFMXGridAbout.Timer1 Field

Summary

Represents field Timer1.

Namespace: FMXTee.Grid.About
Syntax
Delphi
published
 Timer1: TTimer;

Field Value

Type: TTimer

See Also

Reference

  • TFMXGridAbout
  • FMXTee.Grid.About


FMXTee.Grid.About Constants

Constants
Name | Description
TeeGrid_Version | Represents constant TeeGrid_Version.
TeeGrid_Version_Numeric | Represents constant TeeGrid_Version_Numeric.
Top


TeeGrid_Version Constant

Summary

Represents constant TeeGrid_Version.

Namespace: FMXTee.Grid.About
Syntax
Delphi
 TeeGrid_Version='v1.08';

Value

Type: string

See Also

Reference

  • FMXTee.Grid.About


TeeGrid_Version_Numeric Constant

Summary

Represents constant TeeGrid_Version_Numeric.

Namespace: FMXTee.Grid.About
Syntax
Delphi
 TeeGrid_Version_Numeric=108;

Value

Type: ShortInt

See Also

Reference

  • FMXTee.Grid.About


FMXTeeGridRegister Namespace

Summary

Represents namespace FMXTeeGridRegister.

Classes
Name | Description
TBrushProperty | Represents type TBrushProperty.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TGridClassProperty | Represents type TGridClassProperty.
TGridClassSubProperties | Represents type TGridClassSubProperties.
TStrokeProperty | Represents type TStrokeProperty.
TTeeComponentEditor | Represents type TTeeComponentEditor.
TTeeGridCompEditor | Represents type TTeeGridCompEditor.
TTeeGridSelectionEditor | Represents type TTeeGridSelectionEditor.
Top
Routines
Name | Description
Register | Represents method Register.
Top


FMXTeeGridRegister Classes

Classes
Name | Description
TBrushProperty | Represents type TBrushProperty.
TCustomTeeGridAccess | Represents type TCustomTeeGridAccess.
TGridClassProperty | Represents type TGridClassProperty.
TGridClassSubProperties | Represents type TGridClassSubProperties.
TStrokeProperty | Represents type TStrokeProperty.
TTeeComponentEditor | Represents type TTeeComponentEditor.
TTeeGridCompEditor | Represents type TTeeGridCompEditor.
TTeeGridSelectionEditor | Represents type TTeeGridSelectionEditor.
Top


TBrushProperty Class

Summary

Represents type TBrushProperty.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TClassProperty
FMXTeeGridRegister.TGridClassProperty
FMXTeeGridRegister.TGridClassSubProperties
FMXTeeGridRegister.TBrushProperty
Syntax
Delphi
type
 TBrushProperty=class(TGridClassSubProperties)
 end;

The TBrushProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • FMXTeeGridRegister


TBrushProperty.Edit Method

Summary

Represents method Edit.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBrushProperty
  • FMXTeeGridRegister


TCustomTeeGridAccess Class

Summary

Represents type TCustomTeeGridAccess.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TCustomTeeGrid
FMXTeeGridRegister.TCustomTeeGridAccess
Syntax
Delphi
type
 TCustomTeeGridAccess=class(TCustomTeeGrid);
See Also

Reference

  • FMXTeeGridRegister


TGridClassProperty Class

Summary

Represents type TGridClassProperty.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TClassProperty
FMXTeeGridRegister.TGridClassProperty
FMXTeeGridRegister.TGridClassSubProperties
Syntax
Delphi
type
 TGridClassProperty=class(TClassProperty)
 end;

The TGridClassProperty type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes.
GetObject | Represents method GetObject.
Top
See Also

Reference

  • FMXTeeGridRegister


TGridClassProperty.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

See Also

Reference

  • TGridClassProperty
  • FMXTeeGridRegister


TGridClassProperty.GetObject Method

Summary

Represents method GetObject.

Namespace: FMXTeeGridRegister
Syntax
Delphi
protected
 function GetObject:Integer;

Return Value

Type: Integer

See Also

Reference

  • TGridClassProperty
  • FMXTeeGridRegister


TGridClassSubProperties Class

Summary

Represents type TGridClassSubProperties.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TClassProperty
FMXTeeGridRegister.TGridClassProperty
FMXTeeGridRegister.TGridClassSubProperties
FMXTeeGridRegister.TBrushProperty
FMXTeeGridRegister.TStrokeProperty
Syntax
Delphi
type
 TGridClassSubProperties=class(TGridClassProperty)
 end;

The TGridClassSubProperties type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • FMXTeeGridRegister


TGridClassSubProperties.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

Overrides

TGridClassProperty.GetAttributes
See Also

Reference

  • TGridClassSubProperties
  • FMXTeeGridRegister


TStrokeProperty Class

Summary

Represents type TStrokeProperty.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TClassProperty
FMXTeeGridRegister.TGridClassProperty
FMXTeeGridRegister.TGridClassSubProperties
FMXTeeGridRegister.TStrokeProperty
Syntax
Delphi
type
 TStrokeProperty=class(TGridClassSubProperties)
 end;

The TStrokeProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
GetAttributes | Represents method GetAttributes. (Overrides TGridClassProperty.GetAttributes.)
GetObject | Represents method GetObject. (Inherited from TGridClassProperty.)
Top
See Also

Reference

  • FMXTeeGridRegister


TStrokeProperty.Edit Method

Summary

Represents method Edit.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TStrokeProperty
  • FMXTeeGridRegister


TTeeComponentEditor Class

Summary

Represents type TTeeComponentEditor.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TComponentEditor
FMXTeeGridRegister.TTeeComponentEditor
FMXTeeGridRegister.TTeeGridCompEditor
Syntax
Delphi
type
 TTeeComponentEditor=class(TComponentEditor)
 end;

The TTeeComponentEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top
See Also

Reference

  • FMXTeeGridRegister


TTeeComponentEditor.Edit Method

Summary

Represents method Edit.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TTeeComponentEditor
  • FMXTeeGridRegister


TTeeComponentEditor.ExecuteVerb(Integer) Method

Summary

Represents method ExecuteVerb(Integer).

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure ExecuteVerb(Index:Integer); override;

Parameters

Index
Type: Integer

See Also

Reference

  • TTeeComponentEditor
  • FMXTeeGridRegister


TTeeComponentEditor.GetVerb(Integer) Method

Summary

Represents method GetVerb(Integer).

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 function GetVerb(Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TTeeComponentEditor
  • FMXTeeGridRegister


TTeeComponentEditor.GetVerbCount Method

Summary

Represents method GetVerbCount.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 function GetVerbCount:Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TTeeComponentEditor
  • FMXTeeGridRegister


TTeeGridCompEditor Class

Summary

Represents type TTeeGridCompEditor.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TComponentEditor
FMXTeeGridRegister.TTeeComponentEditor
FMXTeeGridRegister.TTeeGridCompEditor
Syntax
Delphi
type
 TTeeGridCompEditor=class(TTeeComponentEditor)
 end;

The TTeeGridCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TTeeComponentEditor.Edit.)
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer). (Inherited from TTeeComponentEditor.)
GetVerb(Integer) | Represents method GetVerb(Integer). (Inherited from TTeeComponentEditor.)
GetVerbCount | Represents method GetVerbCount. (Inherited from TTeeComponentEditor.)
Top
See Also

Reference

  • FMXTeeGridRegister


TTeeGridCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TTeeComponentEditor.Edit
See Also

Reference

  • TTeeGridCompEditor
  • FMXTeeGridRegister


TTeeGridSelectionEditor Class

Summary

Represents type TTeeGridSelectionEditor.

Namespace: FMXTeeGridRegister
Inheritance Hierarchy
TSelectionEditor
FMXTeeGridRegister.TTeeGridSelectionEditor
Syntax
Delphi
type
 TTeeGridSelectionEditor=class(TSelectionEditor)
 end;

The TTeeGridSelectionEditor type exposes the following members.

Methods
Show:
Name | Description
RequiresUnits(TGetStrProc) | Represents method RequiresUnits(TGetStrProc).
Top
See Also

Reference

  • FMXTeeGridRegister


TTeeGridSelectionEditor.RequiresUnits(TGetStrProc) Method

Summary

Represents method RequiresUnits(TGetStrProc).

Namespace: FMXTeeGridRegister
Syntax
Delphi
public
 procedure RequiresUnits(Proc: TGetStrProc); override;

Parameters

Proc
Type: TGetStrProc

See Also

Reference

  • TTeeGridSelectionEditor
  • FMXTeeGridRegister


FMXTeeGridRegister Routines

Routines
Name | Description
Register | Represents method Register.
Top


Register Method

Summary

Represents method Register.

Namespace: FMXTeeGridRegister
Syntax
Delphi
procedure Register;
See Also

Reference

  • FMXTeeGridRegister