CodeIt.Right Documentation

Summary Report API

Provides access to the post-analysis data to be rendered in the Summary report. The instance of this class is available as Summary within the Razor formatted Summary.cshtml which you can edit to fit your summary report needs.

© 2002-2016 SubMain. All rights reserved.
Designated trademarks and brands are the property of their respective owners.


SubMain.CodeItRight Namespace

Classes

 | Class | Description
Public class | ExcludedFile | Contains information about excluded file.
Public class | ExcludedProject | Contains information about excluded project.
Public class | ExcludedRule | Contains information about excluded rule.
Public class | ExcludedViolation | Contains information about excluded violation.
Public class | Excludes | Provides information about excluded violations, rules, files and projects.
Public class | Metrics | Provides members for retrieving data about the solution code metrics and totals
Public class | Summary | Provides access to the post-analysis data to be rendered in the Summary report. The instance of this class is available as Summary within the Razor formatted Summary.cshtml which you can edit to fit your summary report needs.
Public class | ViolationsReport | Provides list of Violations, Excludes as well as statistics for violations by severity.
Help File generated with GhostDoc


ExcludedFile Class

Contains information about excluded file.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class ExcludedFile

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..ExcludedFile

See Also

ExcludedFile Members
SubMain.CodeItRight Namespace


ExcludedFile Members

The ExcludedFile type exposes the following members.

Properties

 | Name | Description
Public property | Date | Returns date when the file was excluded.
Public property | File | Returns name of the excluded file.
Public property | Note | Returns note by the user who excluded the file.
Public property | User | Returns name of the user who excluded the file.

See Also

ExcludedFile Class


ExcludedFile Properties

The ExcludedFile type exposes the following members.

Properties

 | Name | Description
Public property | Date | Returns date when the file was excluded.
Public property | File | Returns name of the excluded file.
Public property | Note | Returns note by the user who excluded the file.
Public property | User | Returns name of the user who excluded the file.

See Also

ExcludedFile Class


Date Property

Summary Report API Documentation

ExcludedFile..::..Date Property

Returns date when the file was excluded.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string Date { get; set; }

Field Value

The date.

See Also

ExcludedFile Class


File Property

ExcludedFile..::..File Property

Returns name of the excluded file.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string File { get; set; }

Field Value

The file name.

See Also

ExcludedFile Class


Note Property

ExcludedFile..::..Note Property

Returns note by the user who excluded the file.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string Note { get; set; }

Field Value

The exclusion note.

See Also

ExcludedFile Class


User Property

ExcludedFile..::..User Property

Returns name of the user who excluded the file.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string User { get; set; }

Field Value

The user name.

See Also

ExcludedFile Class


ExcludedProject Class

Contains information about excluded project.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class ExcludedProject

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..ExcludedProject

See Also

ExcludedProject Members


ExcludedProject Members

The ExcludedProject type exposes the following members.

Properties

 | Name | Description
Public property | Date | Returns date when the project was excluded.
Public property | Note | Returns note by the user who excluded the project.
Public property | Project | Returns name of the excluded project.
Public property | User | Returns name of the user who excluded the project.

See Also

ExcludedProject Class


ExcludedProject Properties

The ExcludedProject type exposes the following members.

Properties

 | Name | Description
Public property | Date | Returns date when the project was excluded.
Public property | Note | Returns note by the user who excluded the project.
Public property | Project | Returns name of the excluded project.
Public property | User | Returns name of the user who excluded the project.

See Also

ExcludedProject Class


Date Property

ExcludedProject..::..Date Property

Returns date when the project was excluded.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string Date { get; set; }

Field Value

The date.

See Also

ExcludedProject Class


Note Property

ExcludedProject..::..Note Property

Returns note by the user who excluded the project.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string Note { get; set; }

Field Value

The text.

See Also

ExcludedProject Class


Project Property

ExcludedProject..::..Project Property

Returns name of the excluded project.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string Project { get; set; }

Field Value

The project.

See Also

ExcludedProject Class


User Property

ExcludedProject..::..User Property

Returns name of the user who excluded the project.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string User { get; set; }

Field Value

The user.

See Also

ExcludedProject Class


ExcludedRule Class

Contains information about excluded rule.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class ExcludedRule

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..ExcludedRule

See Also

ExcludedRule Members


ExcludedRule Members

The ExcludedRule type exposes the following members.

Properties

 | Name | Description
Public property | Rule | Returns the rule details.

See Also

ExcludedRule Class


ExcludedRule Properties

The ExcludedRule type exposes the following members.

Properties

 | Name | Description
Public property | Rule | Returns the rule details.

See Also

ExcludedRule Class


Rule Property

ExcludedRule..::..Rule Property

Returns the rule details.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public IRule Rule { get; set; }

Field Value

The rule.

See Also

ExcludedRule Class


ExcludedViolation Class

Contains information about excluded violation.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class ExcludedViolation

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..ExcludedViolation

See Also

ExcludedViolation Members


ExcludedViolation Members

The ExcludedViolation type exposes the following members.

Properties

 | Name | Description
Public property | Violation | Returns the violation details.

See Also

ExcludedViolation Class


ExcludedViolation Properties

The ExcludedViolation type exposes the following members.

Properties

 | Name | Description
Public property | Violation | Returns the violation details.

See Also

ExcludedViolation Class


Violation Property

ExcludedViolation..::..Violation Property

Returns the violation details.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public IRule Violation { get; set; }

Field Value

The violation.

See Also

ExcludedViolation Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ExcludedViolation


Excludes Class

Provides information about excluded violations, rules, files and projects.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class Excludes

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..Excludes

See Also

Excludes Members


Excludes Members

The Excludes type exposes the following members.

Properties

 | Name | Description
Public property | Files | Returns List of excluded files.
Public property | Projects | Returns List of excluded projects.
Public property | Rules | Returns List of excluded rules.
Public property | Violations | Returns List of excluded violations.

See Also

Excludes Class


Excludes Properties

The Excludes type exposes the following members.

Properties

 | Name | Description
Public property | Files | Returns List of excluded files.
Public property | Projects | Returns List of excluded projects.
Public property | Rules | Returns List of excluded rules.
Public property | Violations | Returns List of excluded violations.

See Also

Excludes Class


Files Property

Excludes..::..Files Property

Returns List of excluded files.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<ExcludedFile> Files { get; set; }

Field Value

The excluded files.

See Also

Excludes Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ExcludedFile


Projects Property

Excludes..::..Projects Property

Returns List of excluded projects.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<ExcludedProject> Projects { get; set; }

Field Value

The list of projects.

See Also

Excludes Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ExcludedProject


Rules Property

Excludes..::..Rules Property

Returns List of excluded rules.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<ExcludedRule> Rules { get; set; }

Field Value

The excluded rules.

See Also

Excludes Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ExcludedRule


Violations Property

Excludes..::..Violations Property

Returns List of excluded violations.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<ExcludedViolation> Violations { get; set; }

Field Value

The excluded violations.

See Also

Excludes Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ExcludedViolation


Metrics Class

Provides members for retrieving data about the solution code metrics and totals

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class Metrics

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..Metrics

See Also

Metrics Members


Metrics Members

The Metrics type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyCount | Returns the count of assemblies in the analyzed file set.
Public property | CodeLineCount | Returns the count of lines of code in the analyzed file set.
Public property | CommentLineCount | Returns the count of comment lines in the analyzed file set.
Public property | CyclomaticComplexityAvg | Returns the average cyclomatic complexity in the analyzed file set.
Public property | CyclomaticComplexityMax | Returns the maximum cyclomatic complexity in the analyzed file set.
Public property | DepthOfInheritanceAvg | Returns the average depth of inheritance in the analyzed file set.
Public property | DepthOfInheritanceMax | Returns the maximum depth of inheritance in the analyzed file set.
Public property | EmptyLineCount | Returns the count of empty lines in the analyzed file set.
Public property | EventCount | Returns the count of events in the analyzed file set.
Public property | FieldCount | Returns the count of fields in the analyzed file set.
Public property | FileCount | Returns the count of files in the analyzed file set.
Public property | LineCount | Returns the count of total lines in the analyzed file set, including the empty lines.
Public property | MethodCount | Returns the count of methods in the analyzed file set.
Public property | NamespaceCount | Returns the count of namespeces in the analyzed file set.
Public property | OperatorCount | Returns the count of operators in the analyzed file set.
Public property | PropertyCount | Returns the count of properties in the analyzed file set.
Public property | TypeCount | Returns the count of types in the analyzed file set.

See Also

Metrics Class


Metrics Properties

The Metrics type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyCount | Returns the count of assemblies in the analyzed file set.
Public property | CodeLineCount | Returns the count of lines of code in the analyzed file set.
Public property | CommentLineCount | Returns the count of comment lines in the analyzed file set.
Public property | CyclomaticComplexityAvg | Returns the average cyclomatic complexity in the analyzed file set.
Public property | CyclomaticComplexityMax | Returns the maximum cyclomatic complexity in the analyzed file set.
Public property | DepthOfInheritanceAvg | Returns the average depth of inheritance in the analyzed file set.
Public property | DepthOfInheritanceMax | Returns the maximum depth of inheritance in the analyzed file set.
Public property | EmptyLineCount | Returns the count of empty lines in the analyzed file set.
Public property | EventCount | Returns the count of events in the analyzed file set.
Public property | FieldCount | Returns the count of fields in the analyzed file set.
Public property | FileCount | Returns the count of files in the analyzed file set.
Public property | LineCount | Returns the count of total lines in the analyzed file set, including the empty lines.
Public property | MethodCount | Returns the count of methods in the analyzed file set.
Public property | NamespaceCount | Returns the count of namespeces in the analyzed file set.
Public property | OperatorCount | Returns the count of operators in the analyzed file set.
Public property | PropertyCount | Returns the count of properties in the analyzed file set.
Public property | TypeCount | Returns the count of types in the analyzed file set.

See Also

Metrics Class


AssemblyCount Property

Metrics..::..AssemblyCount Property

Returns the count of assemblies in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int AssemblyCount { get; set; }

Field Value

The assemblies count.

See Also

Metrics Class


CodeLineCount Property

Metrics..::..CodeLineCount Property

Returns the count of lines of code in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int CodeLineCount { get; set; }

Field Value

The lines of code count.

See Also

Metrics Class


CommentLineCount Property

Metrics..::..CommentLineCount Property

Returns the count of comment lines in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int CommentLineCount { get; set; }

Field Value

The comment lines count.

See Also

Metrics Class


CyclomaticComplexityAvg Property

Metrics..::..CyclomaticComplexityAvg Property

Returns the average cyclomatic complexity in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public double CyclomaticComplexityAvg { get; set; }

Field Value

The value of the average cyclomatic complexity.

See Also

Metrics Class


CyclomaticComplexityMax Property

Metrics..::..CyclomaticComplexityMax Property

Returns the maximum cyclomatic complexity in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int CyclomaticComplexityMax { get; set; }

Field Value

The value of the maximum cyclomatic complexity.

See Also

Metrics Class


DepthOfInheritanceAvg Property

Metrics..::..DepthOfInheritanceAvg Property

Returns the average depth of inheritance in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public double DepthOfInheritanceAvg { get; set; }

Field Value

The value of the average depth of inheritance.

See Also

Metrics Class


DepthOfInheritanceMax Property

Metrics..::..DepthOfInheritanceMax Property

Returns the maximum depth of inheritance in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int DepthOfInheritanceMax { get; set; }

Field Value

The value of the maximum depth of inheritance.

See Also

Metrics Class


EmptyLineCount Property

Metrics..::..EmptyLineCount Property

Returns the count of empty lines in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int EmptyLineCount { get; set; }

Field Value

The empty lines count.

See Also

Metrics Class


EventCount Property

Metrics..::..EventCount Property

Returns the count of events in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int EventCount { get; set; }

Field Value

The events count.

See Also

Metrics Class


FieldCount Property

Metrics..::..FieldCount Property

Returns the count of fields in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int FieldCount { get; set; }

Field Value

The fields count.

See Also

Metrics Class


FileCount Property

Metrics..::..FileCount Property

Returns the count of files in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int FileCount { get; set; }

Field Value

The files count.

See Also

Metrics Class


LineCount Property

Metrics..::..LineCount Property

Returns the count of total lines in the analyzed file set, including the empty lines.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int LineCount { get; set; }

Field Value

The total lines count.

See Also

Metrics Class


MethodCount Property

Metrics..::..MethodCount Property

Returns the count of methods in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int MethodCount { get; set; }

Field Value

The methods count.

See Also

Metrics Class


NamespaceCount Property

Metrics..::..NamespaceCount Property

Returns the count of namespeces in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int NamespaceCount { get; set; }

Field Value

The namespaces count.

See Also

Metrics Class


OperatorCount Property

Metrics..::..OperatorCount Property

Returns the count of operators in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int OperatorCount { get; set; }

Field Value

The operators count.

See Also

Metrics Class


PropertyCount Property

Metrics..::..PropertyCount Property

Returns the count of properties in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int PropertyCount { get; set; }

Field Value

The properties count.

See Also

Metrics Class


TypeCount Property

Metrics..::..TypeCount Property

Returns the count of types in the analyzed file set.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int TypeCount { get; set; }

Field Value

The types count.

See Also

Metrics Class


Summary Class

Provides access to the post-analysis data to be rendered in the Summary report. The instance of this class is available as Summary within the Razor formatted Summary.cshtml which you can edit to fit your summary report needs.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class Summary

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..Summary

See Also

Summary Members


Summary Members

The Summary type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProfile | Returns the name of the rule set profile used for the analysis.
Public property | AnalysisDate | Returns string representing the date and time of the analysis.
Public property | AnalysisDuration | Returns the time duration of the analysis as a formatted string ({D2}h:{D2}m:{D2}s).
Public property | FileFiltering | Returns the List of the input solution file set filtering criteria used during the analysis.
Public property | Metrics | Provides access to the code metrics data.
Public property | ProductEdition | Returns the CodeIt.Right product edition string code.
Public property | ProductEditionName | Returns the CodeIt.Right product edition name.
Public property | ProductVersion | Returns the CodeIt.Right product version string.
Public property | SeverityThreshold | Returns the severity threshold value used for the analysis.
Public property | SolutionName | Returns the name of the solution.
Public property | ViolationsReport | Provides access to the violation report data.

See Also

Summary Class


Summary Properties

The Summary type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProfile | Returns the name of the rule set profile used for the analysis.
Public property | AnalysisDate | Returns string representing the date and time of the analysis.
Public property | AnalysisDuration | Returns the time duration of the analysis as a formatted string ({D2}h:{D2}m:{D2}s).
Public property | FileFiltering | Returns the List of the input solution file set filtering criteria used during the analysis.
Public property | Metrics | Provides access to the code metrics data.
Public property | ProductEdition | Returns the CodeIt.Right product edition string code.
Public property | ProductEditionName | Returns the CodeIt.Right product edition name.
Public property | ProductVersion | Returns the CodeIt.Right product version string.
Public property | SeverityThreshold | Returns the severity threshold value used for the analysis.
Public property | SolutionName | Returns the name of the solution.
Public property | ViolationsReport | Provides access to the violation report data.

See Also

Summary Class


ActiveProfile Property

Summary..::..ActiveProfile Property

Returns the name of the rule set profile used for the analysis.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string ActiveProfile { get; set; }

Field Value

The profile name.

See Also

Summary Class


AnalysisDate Property

Summary..::..AnalysisDate Property

Returns string representing the date and time of the analysis.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string AnalysisDate { get; set; }

Field Value

The analysis date.

See Also

Summary Class


AnalysisDuration Property

Summary..::..AnalysisDuration Property

Returns the time duration of the analysis as a formatted string ({D2}h:{D2}m:{D2}s).

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string AnalysisDuration { get; set; }

Field Value

The duration of the analysis string.

See Also

Summary Class


FileFiltering Property

Summary..::..FileFiltering Property

Returns the List of the input solution file set filtering criteria used during the analysis.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<string> FileFiltering { get; set; }

Field Value

The file filtering criteria list.

See Also

Summary Class


Metrics Property

Summary..::..Metrics Property

Provides access to the code metrics data.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public Metrics Metrics { get; set; }

Field Value

The metrics.

See Also

Summary Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..Metrics


ProductEdition Property

Summary..::..ProductEdition Property

Returns the CodeIt.Right product edition string code.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string ProductEdition { get; set; }

Field Value

The product edition code string.

Return Value

Returns
  • "cirse" for CodeIt.Right Standard
  • "ciree" for CodeIt.Right Enterprise
  • "cirpe" for CodeIt.Right Personal

See Also

Summary Class


ProductEditionName Property

Summary..::..ProductEditionName Property

Returns the CodeIt.Right product edition name.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string ProductEditionName { get; set; }

Field Value

The product edition name string.

See Also

Summary Class


ProductVersion Property

Summary..::..ProductVersion Property

Returns the CodeIt.Right product version string.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string ProductVersion { get; set; }

Field Value

The product version.

See Also

Summary Class


SeverityThreshold Property

Summary..::..SeverityThreshold Property

Returns the severity threshold value used for the analysis.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string SeverityThreshold { get; set; }

Field Value

The severity threshold value.

See Also

Summary Class


SolutionName Property

Summary..::..SolutionName Property

Returns the name of the solution.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public string SolutionName { get; set; }

Field Value

The name of the solution.

See Also

Summary Class


ViolationsReport Property

Summary..::..ViolationsReport Property

Provides access to the violation report data.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public ViolationsReport ViolationsReport { get; set; }

Field Value

The violations report.

See Also

Summary Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..ViolationsReport


ViolationsReport Class

Provides list of Violations, Excludes as well as statistics for violations by severity.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
[SerializableAttribute]
public class ViolationsReport

Inheritance Hierarchy

Object
SubMain.CodeItRight..::..ViolationsReport

See Also

ViolationsReport Members
SubMain.CodeItRight Namespace
ViolationsReport..::..Violations
SubMain.CodeItRight..::..Excludes


ViolationsReport Members

The ViolationsReport type exposes the following members.

Properties

 | Name | Description
Public property | CriticalErrorCount | Returns number of violations type "Critical Error".
Public property | CriticalWarningCount | Returns number of violations type "CriticalWarning".
Public property | ErrorCount | Returns number of violations type "Error".
Public property | Excludes | Returns list of Excludes.
Public property | InformationCount | Returns number of violations type "Information".
Public property | Violations | Returns list of Violations.
Public property | WarningCount | Returns number of violations type "Warning".

See Also

ViolationsReport Class


ViolationsReport Properties

The ViolationsReport type exposes the following members.

Properties

 | Name | Description
Public property | CriticalErrorCount | Returns number of violations type "Critical Error".
Public property | CriticalWarningCount | Returns number of violations type "CriticalWarning".
Public property | ErrorCount | Returns number of violations type "Error".
Public property | Excludes | Returns list of Excludes.
Public property | InformationCount | Returns number of violations type "Information".
Public property | Violations | Returns list of Violations.
Public property | WarningCount | Returns number of violations type "Warning".

See Also

ViolationsReport Class


CriticalErrorCount Property

ViolationsReport..::..CriticalErrorCount Property

Returns number of violations type "Critical Error".

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int CriticalErrorCount { get; set; }

Field Value

The number of "Critical Error" violations.

See Also

ViolationsReport Class


CriticalWarningCount Property

ViolationsReport..::..CriticalWarningCount Property

Returns number of violations type "CriticalWarning".

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int CriticalWarningCount { get; set; }

Field Value

The number of "Critical Warning" violations.

See Also

ViolationsReport Class


ErrorCount Property

ViolationsReport..::..ErrorCount Property

Returns number of violations type "Error".

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int ErrorCount { get; set; }

Field Value

The number of "Error" violations.

See Also

ViolationsReport Class


Excludes Property

ViolationsReport..::..Excludes Property

Returns list of Excludes.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public Excludes Excludes { get; set; }

Field Value

The excludes.

See Also

ViolationsReport Class
SubMain.CodeItRight Namespace
SubMain.CodeItRight..::..Excludes


InformationCount Property

ViolationsReport..::..InformationCount Property

Returns number of violations type "Information".

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int InformationCount { get; set; }

Field Value

The number of "Information" violations.

See Also

ViolationsReport Class


Violations Property

ViolationsReport..::..Violations Property

Returns list of Violations.

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public List<IRule> Violations { get; set; }

Field Value

The violations.

See Also

ViolationsReport Class
SubMain.CodeItRight Namespace
ViolationsReport..::..Violations


WarningCount Property

ViolationsReport..::..WarningCount Property

Returns number of violations type "Warning".

Namespace: SubMain.CodeItRight
Assembly: SubMain.CodeItRight.clr4 (in SubMain.CodeItRight.clr4.dll)

Syntax

C#
public int WarningCount { get; set; }

Field Value

The number of "Warning" violations.

See Also

ViolationsReport Class