SubMain.CodeItRight.Sdk.Core.Collections Namespace

Classes

 | Class | Description
Public class | RulesCollection | Represents a collection of rules.
Help File generated with GhostDoc


RulesCollection Class

Represents a collection of rules.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[SerializableAttribute]
public class RulesCollection : IBindingList,
    ICloneable, ISerializable

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Core.Collections..::..RulesCollection

See Also

RulesCollection Members
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Members

The RulesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | RulesCollection()()()() | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(Int32) | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(RulesCollection) | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(array<IRule>[]()[][]) | Initializes a new instance of the RulesCollection class.

Methods

 | Name | Description
Public method | Add | Adds a rule to the end of the RulesCollection.
Public method | AddRange(RulesCollection) | Copies the rules of a rules collection to the end of the RulesCollection.
Public method | AddRange(array<IRule>[]()[][]) | Copies the rules of a rules array to the end of the RulesCollection.
Public method | Clear | Removes all the rules from the RulesCollection.
Public method | Clone | Creates a copy of the current RulesCollection object.
Public method | CopyTo()()()() | Copies the entire RulesCollection values to a one-dimensional array of rules.
Public method | ExportProfileToXml | Writes XML data to the specified file from the current RulesCollection object.
Public method | ExportToXml(String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.
Public method | ExportToXml(String, String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.
Public method | IndexOf | Searches for the specified rule and returns the zero-based index of the first occurrence within the RulesCollection.
Public method | Insert | Inserts a rule into the RulesCollection at the specified index.
Public method | Remove | Removes the first occurrence of a rule from the RulesCollection.
Public method | RemoveAt | Removes the rule at the specified index of the RulesCollection.
Public method | Sort()()()() | Sorts the rules in the entire RulesCollection.
Public method | Sort(IComparer) | Sorts the rules in the entire RulesCollection using the specified comparer.

Properties

 | Name | Description
Public property | Count | Gets the number of rules contained in the RulesCollection.
Public property | Item | Gets or sets the rule at the specified index.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Constructor

Overload List

 | Name | Description
Public method | RulesCollection()()()() | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(Int32) | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(RulesCollection) | Initializes a new instance of the RulesCollection class.
Public method | RulesCollection(array<IRule>[]()[][]) | Initializes a new instance of the RulesCollection class.

See Also

RulesCollection Class
RulesCollection Members
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Constructor

Initializes a new instance of the RulesCollection class.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public RulesCollection()

Remarks

Examples

To be added.

See Also

RulesCollection Class
RulesCollection Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Constructor (Int32)

Initializes a new instance of the RulesCollection class.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public RulesCollection(
    int initialCapacity
)

Parameters

initialCapacity
Type: Int32

Initial capacity of the collection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
RulesCollection Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Constructor (RulesCollection)

Initializes a new instance of the RulesCollection class.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public RulesCollection(
    RulesCollection value
)

Parameters

value
Type: SubMain.CodeItRight.Sdk.Core.Collections..::..RulesCollection

Initializes collection with a specified collection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
RulesCollection Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Constructor (IRule[])

CodeIt.Right SDK API

RulesCollection Constructor (array<IRule>[]()[][])

Initializes a new instance of the RulesCollection class.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public RulesCollection(
    IRule[] value
)

Parameters

value
Type: array<IRule>[]()[][]

Initializes collection with an array of rules.

Remarks

Examples

To be added.

See Also

RulesCollection Class
RulesCollection Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Methods

The RulesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a rule to the end of the RulesCollection.
Public method | AddRange(RulesCollection) | Copies the rules of a rules collection to the end of the RulesCollection.
Public method | AddRange(array<IRule>[]()[][]) | Copies the rules of a rules array to the end of the RulesCollection.
Public method | Clear | Removes all the rules from the RulesCollection.
Public method | Clone | Creates a copy of the current RulesCollection object.
Public method | CopyTo()()()() | Copies the entire RulesCollection values to a one-dimensional array of rules.
Public method | ExportProfileToXml | Writes XML data to the specified file from the current RulesCollection object.
Public method | ExportToXml(String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.
Public method | ExportToXml(String, String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.
Public method | IndexOf | Searches for the specified rule and returns the zero-based index of the first occurrence within the RulesCollection.
Public method | Insert | Inserts a rule into the RulesCollection at the specified index.
Public method | Remove | Removes the first occurrence of a rule from the RulesCollection.
Public method | RemoveAt | Removes the rule at the specified index of the RulesCollection.
Public method | Sort()()()() | Sorts the rules in the entire RulesCollection.
Public method | Sort(IComparer) | Sorts the rules in the entire RulesCollection using the specified comparer.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Add Method

RulesCollection..::..Add Method

Adds a rule to the end of the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Add(
    IRule value
)

Parameters

value
Type: SubMain.CodeItRight.Sdk.Core.Rules..::..IRule

The rule to add to the end of the RulesCollection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


AddRange Method

RulesCollection..::..AddRange Method

Overload List

 | Name | Description
Public method | AddRange(RulesCollection) | Copies the rules of a rules collection to the end of the RulesCollection.
Public method | AddRange(array<IRule>[]()[][]) | Copies the rules of a rules array to the end of the RulesCollection.

See Also

RulesCollection Class
RulesCollection Members
SubMain.CodeItRight.Sdk.Core.Collections Namespace


AddRange Method (RulesCollection)

RulesCollection..::..AddRange Method (RulesCollection)

Copies the rules of a rules collection to the end of the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void AddRange(
    RulesCollection items
)

Parameters

items
Type: SubMain.CodeItRight.Sdk.Core.Collections..::..RulesCollection

A collection of rules to add to the end of the RulesCollection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
AddRange Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


AddRange Method (IRule[])

RulesCollection..::..AddRange Method (array<IRule>[]()[][])

Copies the rules of a rules array to the end of the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void AddRange(
    IRule[] items
)

Parameters

items
Type: array<IRule>[]()[][]

An array of rules to add to the end of the RulesCollection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
AddRange Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Clear Method

RulesCollection..::..Clear Method

Removes all the rules from the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Clear()

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Clone Method

RulesCollection..::..Clone Method

Creates a copy of the current RulesCollection object.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public Object Clone()

Return Value

A copy of the current RulesCollection object.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


CopyTo Method

RulesCollection..::..CopyTo Method

Copies the entire RulesCollection values to a one-dimensional array of rules.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public IRule[] CopyTo()

Return Value

The one-dimensional array of rules that is the destination of the rules copied from RulesCollection.

Remarks

Examples

To be added.

See Also

RulesCollection Class
CopyTo Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


ExportProfileToXml Method

RulesCollection..::..ExportProfileToXml Method

Writes XML data to the specified file from the current RulesCollection object.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void ExportProfileToXml(
    string fileName,
    string profileName,
    string xslFileName
)

Parameters

fileName
Type: String

File name.

profileName
Type: String

Profile name.

xslFileName
Type: String

XSL File name.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


ExportToXml Method

RulesCollection..::..ExportToXml Method

Overload List

 | Name | Description
Public method | ExportToXml(String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.
Public method | ExportToXml(String, String, String, String, String, String, ICollection) | Writes XML data to the specified file from the current RulesCollection object.

See Also

RulesCollection Class
RulesCollection Members
SubMain.CodeItRight.Sdk.Core.Collections Namespace


ExportToXml Method (String, String, String, String, String, ICollection)

RulesCollection..::..ExportToXml Method (String, String, String, String, String, ICollection)

Writes XML data to the specified file from the current RulesCollection object.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void ExportToXml(
    string fileName,
    string currentProfile,
    string severityThreshold,
    string cirVersion,
    string analysisDuration,
    ICollection excludesArray
)

Parameters

fileName
Type: String

File name.

currentProfile
Type: String

Profile.

severityThreshold
Type: String

severityThreshold.

cirVersion
Type: String

cirVersion.

analysisDuration
Type: String

analysisDuration.

excludesArray
Type: ICollection

excludesArray.

Remarks

Examples

To be added.

See Also

RulesCollection Class
ExportToXml Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


ExportToXml Method (String, String, String, String, String, String, ICollection)

RulesCollection..::..ExportToXml Method (String, String, String, String, String, String, ICollection)

Writes XML data to the specified file from the current RulesCollection object.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void ExportToXml(
    string fileName,
    string xslFileName,
    string currentProfile,
    string severityThreshold,
    string cirVersion,
    string analysisDuration,
    ICollection excludesArray
)

Parameters

fileName
Type: String

File name.

xslFileName
Type: String

XSL File name.

currentProfile
Type: String

currentProfile.

severityThreshold
Type: String

severityThreshold.

cirVersion
Type: String

cirVersion.

analysisDuration
Type: String

analysisDuration.

excludesArray
Type: ICollection

excludesArray.

Remarks

Examples

To be added.

See Also

RulesCollection Class
ExportToXml Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


IndexOf Method

RulesCollection..::..IndexOf Method

Searches for the specified rule and returns the zero-based index of the first occurrence within the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public int IndexOf(
    IRule rule
)

Parameters

rule
Type: SubMain.CodeItRight.Sdk.Core.Rules..::..IRule

The rule to locate.

Return Value

The zero-based index of the first occurrence of value in the RulesCollection, if found; otherwise, -1.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Insert Method

RulesCollection..::..Insert Method

Inserts a rule into the RulesCollection at the specified index.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Insert(
    int index,
    IRule value
)

Parameters

index
Type: Int32

The zero-based index at which value should be inserted.

value
Type: SubMain.CodeItRight.Sdk.Core.Rules..::..IRule

The rule to insert.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Remove Method

RulesCollection..::..Remove Method

Removes the first occurrence of a rule from the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Remove(
    IRule rule
)

Parameters

rule
Type: SubMain.CodeItRight.Sdk.Core.Rules..::..IRule

The rule to remove.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RemoveAt Method

RulesCollection..::..RemoveAt Method

Removes the rule at the specified index of the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void RemoveAt(
    int index
)

Parameters

index
Type: Int32

The zero-based index of the rule to remove.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Sort Method

RulesCollection..::..Sort Method

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the rules in the entire RulesCollection.
Public method | Sort(IComparer) | Sorts the rules in the entire RulesCollection using the specified comparer.

See Also

RulesCollection Class
RulesCollection Members
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Sort Method

RulesCollection..::..Sort Method

Sorts the rules in the entire RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Sort()

Remarks

Examples

To be added.

See Also

RulesCollection Class
Sort Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Sort Method (IComparer)

RulesCollection..::..Sort Method (IComparer)

Sorts the rules in the entire RulesCollection using the specified comparer.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public void Sort(
    IComparer sorter
)

Parameters

sorter
Type: IComparer

The IComparer implementation to use when comparing rules.

Remarks

Examples

To be added.

See Also

RulesCollection Class
Sort Overload
SubMain.CodeItRight.Sdk.Core.Collections Namespace


RulesCollection Properties

The RulesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of rules contained in the RulesCollection.
Public property | Item | Gets or sets the rule at the specified index.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Count Property

RulesCollection..::..Count Property

Gets the number of rules contained in the RulesCollection.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public int Count { get; }

Field Value

The number of rules contained in the RulesCollection

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


Item Property

RulesCollection..::..Item Property

Gets or sets the rule at the specified index.

Namespace: SubMain.CodeItRight.Sdk.Core.Collections
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public IRule this[
    int index
] { get; set; }

Parameters

index
Type: Int32

Field Value

The rule at the specified index.

Remarks

Examples

To be added.

See Also

RulesCollection Class
SubMain.CodeItRight.Sdk.Core.Collections Namespace


SubMain.CodeItRight.Sdk.Core.Reflection Namespace

Interfaces

 | Interface | Description
Public interface | IAnonymousMethodInfo | Stores an anonymous method information.
Public interface | IAssemblyInfo | Stores attributes of an assembly and provides access to assembly metadata.
Public interface | IAttributeInfo | Stores an attribute information.
Public interface | IAttributeSectionInfo | Stores an attribute section information.
Public interface | IBlockInfo | Stores a statement block information.
Public interface | IClassInfo | Stores a class information.
Public interface | ICodeElementInfo | Stores a code element information.
Public interface | ICodeRegionInfo | Stores a code region information.
Public interface | IConstantInfo | Stores a constant information.
Public interface | IDelegateInfo | Stores a delegate information.
Public interface | IElementInfo | Stores an element information.
Public interface | IEnumInfo | Stores an enumeration information.
Public interface | IEnumMemberInfo | Stores an enumeration member information.
Public interface | IEventInfo | Stores an event information.
Public interface | IExpressionInfo | Stores an expression information.
Public interface | IFieldInfo | Stores a field information.
Public interface | IIdentifierInfo | Stores an identifier information.
Public interface | IIndexerInfo | Stores an indexer information.
Public interface | IInterfaceInfo | Stores an interface information.
Public interface | IJavaScriptExpressionInfo | Stores an expression information.
Public interface | IJavaScriptFunctionInfo | Stores a javascript function information.
Public interface | IJavaScriptGlobalVariableInfo | Stores a javascript global variable information.
Public interface | IJavaScriptParameterInfo | Stores a parameter information.
Public interface | IJavaScriptStatementInfo | Stores a statement information.
Public interface | IJavaScriptVariableInfo | Stores a javascript variable information.
Public interface | ILineInfo | Stores a line information.
Public interface | ILiteralInfo | Stores a literal information.
Public interface | ILocalConstantInfo | Stores a local constant information.
Public interface | ILocalVariableInfo | Stores a local variable information.
Public interface | IMemberInfo | Stores a member information.
Public interface | IMethodInfo | Stores a method information.
Public interface | IModuleInfo | Stores a module information.
Public interface | INamespaceDeclarationInfo | Stores a namespace declaration information.
Public interface | INamespaceInfo | Stores a namespace information.
Public interface | IOperatorInfo | Stores an operator information.
Public interface | IParameterInfo | Stores a parameter information.
Public interface | IPluginAnalyzer | Plugins analyzer interface
Public interface | IProjectFileInfo | Stores a project file information.
Public interface | IProjectInfo | Stores a project information.
Public interface | IPropertyBaseInfo | Stores a common information about propery or indexer.
Public interface | IPropertyInfo | Stores a property information.
Public interface | IRegionInfo | Stores a region information.
Public interface | IReturnTypeInfo | Stores a return type information.
Public interface | ISolutionInfo | Stores a solution information.
Public interface | IStatementInfo | Stores a statement information.
Public interface | IStructInfo | Stores a structure information.
Public interface | ITypeInfo | Stores a type information.
Public interface | ITypeMembersInfo | Stores a common information about class, interface and struct.
Public interface | IVariableInfo | Stores a variable information.
Public interface | IVisualStudioInfo | Stores a Visual Studio information.
Public interface | IXamlTagAttributeInfo | Stores an xaml tag information.
Public interface | IXamlTagInfo | Stores an xaml tag information.

Enumerations

 | Enumeration | Description
Public enumeration | ClassInfoType | Specifies constants defining type of a class.
Public enumeration | MemberInfoModifiers | Specifies constants defining a member modifiers.
Public enumeration | OutputTypeInfo | Specifies constants defining a project type.
Public enumeration | ProjectInfoLanguage | Specifies constants defining a project language.


ClassInfoType Enumeration

Specifies constants defining type of a class.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public enum ClassInfoType

Members

Member name | Description
Class | Indicates that the type is a class.
Enum | Indicates that the type is an enumeration.
Interface | Indicates that the type is an interface.
Struct | Indicates that the type is a structure.
Delegate | Indicates that the type is a delegate.
SystemClass | Indicates that the type is class defined in external assembly.
Module | Indicates that the type is a module.

Examples

See Also

SubMain.CodeItRight.Sdk.Core.Reflection Namespace


IAnonymousMethodInfo Interface

Stores an anonymous method information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IAnonymousMethodInfo : IMethodInfo

Examples

To be added.

See Also

IAnonymousMethodInfo Members


IAnonymousMethodInfo Members

The IAnonymousMethodInfo type exposes the following members.

Properties

 | Name | Description
Public property | ParentMember | Gets parent member of the anonymous method.

See Also

IAnonymousMethodInfo Interface


IAnonymousMethodInfo Properties

The IAnonymousMethodInfo type exposes the following members.

Properties

 | Name | Description
Public property | ParentMember | Gets parent member of the anonymous method.

See Also

IAnonymousMethodInfo Interface


ParentMember Property

IAnonymousMethodInfo..::..ParentMember Property

Gets parent member of the anonymous method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo ParentMember { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

IAnonymousMethodInfo Interface


IAssemblyInfo Interface

Stores attributes of an assembly and provides access to assembly metadata.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IAssemblyInfo : IElementInfo

Examples

To be added.

See Also

IAssemblyInfo Members


IAssemblyInfo Members

The IAssemblyInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute | Add the custom attribute for the assembly.
Public method | GetAttributes | Returns the custom attributes for the assembly.
Public method | GetTypes | Returns the array if types located in the assembly.
Public method | Sign | Creates the AssemblyKeyFile attribute with the name of a generated file containing the key pair used to generate a strong name.

Properties

 | Name | Description
Public property | FileName | Gets the full path and name of the assembly's file.
Public property | Name | Gets the display name of the assembly.

See Also

IAssemblyInfo Interface


IAssemblyInfo Methods

The IAssemblyInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute | Add the custom attribute for the assembly.
Public method | GetAttributes | Returns the custom attributes for the assembly.
Public method | GetTypes | Returns the array if types located in the assembly.
Public method | Sign | Creates the AssemblyKeyFile attribute with the name of a generated file containing the key pair used to generate a strong name.

See Also

IAssemblyInfo Interface


AddAttribute Method

IAssemblyInfo..::..AddAttribute Method

Add the custom attribute for the assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAttribute(
    string attributeName,
    params string[] arguments
)

Parameters

attributeName
Type: String

Type name

arguments
Type: array< String >[]()[][]

Positional arguments

Remarks

This method creates a custom attribute.

Examples

To be added.

See Also

IAssemblyInfo Interface


GetAttributes Method

IAssemblyInfo..::..GetAttributes Method

Returns the custom attributes for the assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeSectionInfo[] GetAttributes()

Return Value

An array of type IAttributeSectionInfo containing the custom attributes for the assembly.

Examples

To be added.

See Also

IAssemblyInfo Interface


GetTypes Method

IAssemblyInfo..::..GetTypes Method

Returns the array if types located in the assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetTypes()

Return Value

An array of type ITypeInfo containing types located in the assembly.

Examples

To be added.

See Also

IAssemblyInfo Interface


Sign Method

IAssemblyInfo..::..Sign Method

Creates the AssemblyKeyFile attribute with the name of a generated file containing the key pair used to generate a strong name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Sign(
    string snkFilePath
)

Parameters

snkFilePath
Type: String

Key file path

Remarks

This method generates a new key pair and writes it to the project directory with file name the same as project name and creates the AssemblyKeyFile attribute with the name of a file containing the key pair used to generate a strong name.

Examples

To be added.

See Also

IAssemblyInfo Interface


IAssemblyInfo Properties

The IAssemblyInfo type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets the full path and name of the assembly's file.
Public property | Name | Gets the display name of the assembly.

See Also

IAssemblyInfo Interface


FileName Property

IAssemblyInfo..::..FileName Property

Gets the full path and name of the assembly's file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string FileName { get; }

Field Value

The full path and name of the assembly's file.

Examples

To be added.

See Also

IAssemblyInfo Interface


Name Property

IAssemblyInfo..::..Name Property

Gets the display name of the assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

The display name of the assembly.

Remarks

See AssemblyName for a description of the format of the display name of an assembly.

Examples

To be added.

See Also

IAssemblyInfo Interface


IAttributeInfo Interface

Stores an attribute information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IAttributeInfo : IComparable

Examples

To be added.

See Also

IAttributeInfo Members


IAttributeInfo Members

The IAttributeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the attribute.
Public method | GetArgumentText | Returns an argument's text.
Public method | GetNamedArguments | Returns named arguments of the attribute.
Public method | GetPositionalArguments | Returns positional arguments of this instance.
Public method | GetType | Gets a type of the attribute.

Properties

 | Name | Description
Public property | Index | Gets an index for this attribute in the parent attribute section.
Public property | Name | Gets name of the attribute.
Public property | ParentAttributeSectionInfo | Gets parent attribute section.

See Also

IAttributeInfo Interface


IAttributeInfo Methods

The IAttributeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the attribute.
Public method | GetArgumentText | Returns an argument's text.
Public method | GetNamedArguments | Returns named arguments of the attribute.
Public method | GetPositionalArguments | Returns positional arguments of this instance.
Public method | GetType | Gets a type of the attribute.

See Also

IAttributeInfo Interface


Comment Method

IAttributeInfo..::..Comment Method

Comments out the attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Comment()

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


GetArgumentText Method

IAttributeInfo..::..GetArgumentText Method

Returns an argument's text.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string GetArgumentText(
    int index
)

Parameters

index
Type: Int32

Index of the argument

Return Value

An argument's text.

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


GetNamedArguments Method

IAttributeInfo..::..GetNamedArguments Method

Returns named arguments of the attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
SortedList GetNamedArguments()

Return Value

Sorted list of the objects.

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


GetPositionalArguments Method

IAttributeInfo..::..GetPositionalArguments Method

Returns positional arguments of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Array GetPositionalArguments()

Return Value

An array of positional arguments

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


GetType Method

IAttributeInfo..::..GetType Method

Gets a type of the attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo GetType()

Return Value

ITypeInfo object.

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


IAttributeInfo Properties

The IAttributeInfo type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets an index for this attribute in the parent attribute section.
Public property | Name | Gets name of the attribute.
Public property | ParentAttributeSectionInfo | Gets parent attribute section.

See Also

IAttributeInfo Interface


Index Property

IAttributeInfo..::..Index Property

Gets an index for this attribute in the parent attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the attribute

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


Name Property

IAttributeInfo..::..Name Property

Gets name of the attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; set; }

Field Value

Name of the attribute.

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


ParentAttributeSectionInfo Property

IAttributeInfo..::..ParentAttributeSectionInfo Property

Gets parent attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeSectionInfo ParentAttributeSectionInfo { get; }

Field Value

IAttributeSectionInfo object.

Remarks

Examples

To be added.

See Also

IAttributeInfo Interface


IAttributeSectionInfo Interface

Stores an attribute section information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IAttributeSectionInfo : IComparable

Examples

To be added.

See Also

IAttributeSectionInfo Members


IAttributeSectionInfo Members

The IAttributeSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the attribute section.
Public method | GetAttributes | Returns custom attributes of the attribute section.
Public method | MoveToAssemblyInfo | Moves the attribute section to the AssemblyInfo file.

Properties

 | Name | Description
Public property | AttributeTarget | Gets attribute target of the attribute section.
Public property | Parent | Gets parent code element.
Public property | ProjectFile | Gets project file information of the attribute section.

See Also

IAttributeSectionInfo Interface


IAttributeSectionInfo Methods

The IAttributeSectionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the attribute section.
Public method | GetAttributes | Returns custom attributes of the attribute section.
Public method | MoveToAssemblyInfo | Moves the attribute section to the AssemblyInfo file.

See Also

IAttributeSectionInfo Interface


Comment Method

IAttributeSectionInfo..::..Comment Method

Comments out the attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Comment()

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


GetAttributes Method

IAttributeSectionInfo..::..GetAttributes Method

Returns custom attributes of the attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeInfo[] GetAttributes()

Return Value

An array of IAttributeInfo objects.

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


MoveToAssemblyInfo Method

IAttributeSectionInfo..::..MoveToAssemblyInfo Method

Moves the attribute section to the AssemblyInfo file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void MoveToAssemblyInfo()

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


IAttributeSectionInfo Properties

The IAttributeSectionInfo type exposes the following members.

Properties

 | Name | Description
Public property | AttributeTarget | Gets attribute target of the attribute section.
Public property | Parent | Gets parent code element.
Public property | ProjectFile | Gets project file information of the attribute section.

See Also

IAttributeSectionInfo Interface


AttributeTarget Property

IAttributeSectionInfo..::..AttributeTarget Property

Gets attribute target of the attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
AttributeTargets AttributeTarget { get; }

Field Value

AttributeTargets object.

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


Parent Property

IAttributeSectionInfo..::..Parent Property

Gets parent code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ICodeElementInfo Parent { get; }

Field Value

ICodeElementInfo object.

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


ProjectFile Property

IAttributeSectionInfo..::..ProjectFile Property

Gets project file information of the attribute section.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IAttributeSectionInfo Interface


IBlockInfo Interface

Stores a statement block information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IBlockInfo : IElementInfo

Examples

To be added.

See Also

IBlockInfo Members


IBlockInfo Members

The IBlockInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the block.
Public method | GetStatements | Returns array of IStatementInfo objects that located inside this instance.

Properties

 | Name | Description
Public property | Index | Gets an index for this statement in the parent statement.
Public property | Member | Gets parent IMemberInfo object of the block.
Public property | Parent | Gets parent IStatementInfo object of the block.
Public property | Region | Gets IRegionInfo object of the block.
Public property | StatementType | Gets StatementType object of the block.

See Also

IBlockInfo Interface


IBlockInfo Methods

The IBlockInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the block.
Public method | GetStatements | Returns array of IStatementInfo objects that located inside this instance.

See Also

IBlockInfo Interface


Comment Method

IBlockInfo..::..Comment Method

Comments out the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Comment()

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


GetStatements Method

IBlockInfo..::..GetStatements Method

Returns array of IStatementInfo objects that located inside this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IStatementInfo[] GetStatements()

Return Value

An array of IStatementInfo objects.

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


IBlockInfo Properties

The IBlockInfo type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets an index for this statement in the parent statement.
Public property | Member | Gets parent IMemberInfo object of the block.
Public property | Parent | Gets parent IStatementInfo object of the block.
Public property | Region | Gets IRegionInfo object of the block.
Public property | StatementType | Gets StatementType object of the block.

See Also

IBlockInfo Interface


Index Property

IBlockInfo..::..Index Property

Gets an index for this statement in the parent statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the statement

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


Member Property

IBlockInfo..::..Member Property

Gets parent IMemberInfo object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo Member { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


Parent Property

IBlockInfo..::..Parent Property

Gets parent IStatementInfo object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IStatementInfo Parent { get; }

Field Value

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


Region Property

IBlockInfo..::..Region Property

Gets IRegionInfo object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


StatementType Property

IBlockInfo..::..StatementType Property

Gets StatementType object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
StatementType StatementType { get; }

Field Value

StatementType object.

Remarks

Examples

To be added.

See Also

IBlockInfo Interface


IClassInfo Interface

Stores a class information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IClassInfo : ITypeInfo,
    ITypeMembersInfo

Examples

To be added.

See Also

IClassInfo Members


IClassInfo Members

The IClassInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerTypes | Gets inner types of the type.

See Also

IClassInfo Interface


IClassInfo Methods

The IClassInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerTypes | Gets inner types of the type.

See Also

IClassInfo Interface


GetInnerTypes Method

IClassInfo..::..GetInnerTypes Method

Gets inner types of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetInnerTypes()

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

IClassInfo Interface


ICodeElementInfo Interface

Stores a code element information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ICodeElementInfo : IElementInfo

Examples

To be added.

See Also

ICodeElementInfo Members


ICodeElementInfo Members

The ICodeElementInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the code element.
Public method | Rename | Replaces a name of the code element, with another specified name.

Properties

 | Name | Description
Public property | DisplayName | Gets display name of the code element.
Public property | FullyQualifiedName | Gets a full name of the code element.
Public property | HasXmlComments | Returns True if the code element has XML comment
Public property | Name | Gets name of the code element.
Public property | XmlComment | Gets and sets a XML comment for the code element.

See Also

ICodeElementInfo Interface


ICodeElementInfo Methods

The ICodeElementInfo type exposes the following members.

Methods

 | Name | Description
Public method | Comment | Comments out the code element.
Public method | Rename | Replaces a name of the code element, with another specified name.

See Also

ICodeElementInfo Interface


Comment Method

ICodeElementInfo..::..Comment Method

Comments out the code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Comment()

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


Rename Method

ICodeElementInfo..::..Rename Method

Replaces a name of the code element, with another specified name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Rename(
    string newName
)

Parameters

newName
Type: String

New code element name.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


ICodeElementInfo Properties

The ICodeElementInfo type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets display name of the code element.
Public property | FullyQualifiedName | Gets a full name of the code element.
Public property | HasXmlComments | Returns True if the code element has XML comment
Public property | Name | Gets name of the code element.
Public property | XmlComment | Gets and sets a XML comment for the code element.

See Also

ICodeElementInfo Interface


DisplayName Property

ICodeElementInfo..::..DisplayName Property

Gets display name of the code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string DisplayName { get; }

Field Value

Display name of the code element.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


FullyQualifiedName Property

ICodeElementInfo..::..FullyQualifiedName Property

Gets a full name of the code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string FullyQualifiedName { get; }

Field Value

String full name of the code element.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


HasXmlComments Property

ICodeElementInfo..::..HasXmlComments Property

Returns True if the code element has XML comment

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool HasXmlComments { get; }

Field Value

True if the code element has XML comment; False if otherwise.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


Name Property

ICodeElementInfo..::..Name Property

Gets name of the code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; set; }

Field Value

String name of the code element.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


XmlComment Property

ICodeElementInfo..::..XmlComment Property

Gets and sets a XML comment for the code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string XmlComment { get; set; }

Field Value

XML comment string for the code element.

Remarks

Examples

To be added.

See Also

ICodeElementInfo Interface


ICodeRegionInfo Interface

Stores a code region information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ICodeRegionInfo : IElementInfo

Examples

To be added.

See Also

ICodeRegionInfo Members


ICodeRegionInfo Members

The ICodeRegionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets name of the code region.
Public property | RawCode | Gets raw code of the region.

See Also

ICodeRegionInfo Interface


ICodeRegionInfo Properties

The ICodeRegionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets name of the code region.
Public property | RawCode | Gets raw code of the region.

See Also

ICodeRegionInfo Interface


Name Property

ICodeRegionInfo..::..Name Property

Gets name of the code region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; set; }

Field Value

String name of the code region.

Remarks

Examples

To be added.

See Also

ICodeRegionInfo Interface


RawCode Property

ICodeRegionInfo..::..RawCode Property

Gets raw code of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string RawCode { get; }

Field Value

Raw code of the code region.

Remarks

Examples

To be added.

See Also

ICodeRegionInfo Interface


IConstantInfo Interface

Stores a constant information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IConstantInfo : IMemberInfo

Examples

To be added.

See Also

IConstantInfo Members


IConstantInfo Members

The IConstantInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets a constant expression that gives the value of the constant.

See Also

IConstantInfo Interface


IConstantInfo Properties

The IConstantInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets a constant expression that gives the value of the constant.

See Also

IConstantInfo Interface


InitExpression Property

IConstantInfo..::..InitExpression Property

Gets a constant expression that gives the value of the constant.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IExpressionInfo InitExpression { get; }

Field Value

IExpressionInfo object.

Remarks

Examples

To be added.

See Also

IConstantInfo Interface


IDelegateInfo Interface

Stores a delegate information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IDelegateInfo : ITypeInfo

Examples

To be added.

See Also

IDelegateInfo Members


IDelegateInfo Members

The IDelegateInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetMethod | Gets a method of the delegate.

Properties

 | Name | Description
Public property | ReturnType | Gets a return type of the delegate method.

See Also

IDelegateInfo Interface


IDelegateInfo Methods

The IDelegateInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetMethod | Gets a method of the delegate.

See Also

IDelegateInfo Interface


GetMethod Method

IDelegateInfo..::..GetMethod Method

Gets a method of the delegate.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMethodInfo GetMethod()

Return Value

IMethodInfo object.

Remarks

Examples

To be added.

See Also

IDelegateInfo Interface


IDelegateInfo Properties

The IDelegateInfo type exposes the following members.

Properties

 | Name | Description
Public property | ReturnType | Gets a return type of the delegate method.

See Also

IDelegateInfo Interface


ReturnType Property

IDelegateInfo..::..ReturnType Property

Gets a return type of the delegate method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo ReturnType { get; }

Field Value

IReturnTypeInfo object.

Remarks

Examples

To be added.

See Also

IDelegateInfo Interface


IElementInfo Interface

Stores an element information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IElementInfo : IComparable

Examples

To be added.

See Also

IElementInfo Members


IElementInfo Members

The IElementInfo type exposes the following members.

Methods

 | Name | Description
Public method | IsInScope | Returns true if the element contains specified scopes.
Public method | IsValid | Returns true if the element is valid.
Public method | ResolveProjectFile | Gets a project file for the element.
Public method | ToAssemblyInfo | Gets an assembly of this instance.
Public method | ToClassInfo | Gets a class of this instance.
Public method | ToCodeElementInfo | Gets a code element of this instance.
Public method | ToEnumInfo | Gets an enumeration of this instance.
Public method | ToEnumMemberInfo | Gets an enumeration memeber of this instance.
Public method | ToFieldInfo | Gets a field of this instance.
Public method | ToMemberInfo | Gets a member of this instance.
Public method | ToMethodInfo | Gets a method of this instance.
Public method | ToParameterInfo | Gets a parameter of this instance.
Public method | ToPropertyInfo | Gets a property of this instance.
Public method | ToTypeInfo | Gets a type of this instance.

Properties

 | Name | Description
Public property | IsAssemblyInfo | Gets true if element is an assembly.
Public property | IsClassInfo | Gets true if element is a class.
Public property | IsCodeElementInfo | Gets true if element is a code element.
Public property | IsEnumInfo | Gets true if element is a enumeration.
Public property | IsEnumMemberInfo | Gets true if element is an enumeration member.
Public property | IsFieldInfo | Gets true if element is a field.
Public property | IsMemberInfo | Gets true if element is a member of type.
Public property | IsMethodInfo | Gets true if element is a method.
Public property | IsParameterInfo | Gets true if element is a parameter.
Public property | IsPropertyInfo | Gets true if element is a property.
Public property | IsTypeInfo | Gets true if element is a type.

See Also

IElementInfo Interface


IElementInfo Methods

The IElementInfo type exposes the following members.

Methods

 | Name | Description
Public method | IsInScope | Returns true if the element contains specified scopes.
Public method | IsValid | Returns true if the element is valid.
Public method | ResolveProjectFile | Gets a project file for the element.
Public method | ToAssemblyInfo | Gets an assembly of this instance.
Public method | ToClassInfo | Gets a class of this instance.
Public method | ToCodeElementInfo | Gets a code element of this instance.
Public method | ToEnumInfo | Gets an enumeration of this instance.
Public method | ToEnumMemberInfo | Gets an enumeration memeber of this instance.
Public method | ToFieldInfo | Gets a field of this instance.
Public method | ToMemberInfo | Gets a member of this instance.
Public method | ToMethodInfo | Gets a method of this instance.
Public method | ToParameterInfo | Gets a parameter of this instance.
Public method | ToPropertyInfo | Gets a property of this instance.
Public method | ToTypeInfo | Gets a type of this instance.

See Also

IElementInfo Interface


IsInScope Method

IElementInfo..::..IsInScope Method

Returns true if the element contains specified scopes.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsInScope(
    RuleScopes scopes
)

Parameters

scopes
Type: SubMain.CodeItRight.Sdk.Core.Rules..::..RuleScopes

RuleScopes object.

Return Value

True if the element contains specified scopes; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsValid Method

IElementInfo..::..IsValid Method

Returns true if the element is valid.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsValid()

Return Value

True if the element is valid; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ResolveProjectFile Method

IElementInfo..::..ResolveProjectFile Method

Gets a project file for the element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ResolveProjectFile()

Return Value

An IProjectFileInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToAssemblyInfo Method

IElementInfo..::..ToAssemblyInfo Method

Gets an assembly of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAssemblyInfo ToAssemblyInfo()

Return Value

An IAssemblyInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToClassInfo Method

IElementInfo..::..ToClassInfo Method

Gets a class of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IClassInfo ToClassInfo()

Return Value

An IClassInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToCodeElementInfo Method

IElementInfo..::..ToCodeElementInfo Method

Gets a code element of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ICodeElementInfo ToCodeElementInfo()

Return Value

An ICodeElementInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToEnumInfo Method

IElementInfo..::..ToEnumInfo Method

Gets an enumeration of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IEnumInfo ToEnumInfo()

Return Value

An IEnumInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToEnumMemberInfo Method

IElementInfo..::..ToEnumMemberInfo Method

Gets an enumeration memeber of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IEnumMemberInfo ToEnumMemberInfo()

Return Value

An IEnumMemberInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToFieldInfo Method

IElementInfo..::..ToFieldInfo Method

Gets a field of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IFieldInfo ToFieldInfo()

Return Value

An IFieldInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToMemberInfo Method

IElementInfo..::..ToMemberInfo Method

Gets a member of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo ToMemberInfo()

Return Value

An IMemberInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToMethodInfo Method

IElementInfo..::..ToMethodInfo Method

Gets a method of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMethodInfo ToMethodInfo()

Return Value

An IMethodInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToParameterInfo Method

IElementInfo..::..ToParameterInfo Method

Gets a parameter of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IParameterInfo ToParameterInfo()

Return Value

An IParameterInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToPropertyInfo Method

IElementInfo..::..ToPropertyInfo Method

Gets a property of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IPropertyInfo ToPropertyInfo()

Return Value

An IPropertyInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


ToTypeInfo Method

IElementInfo..::..ToTypeInfo Method

Gets a type of this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo ToTypeInfo()

Return Value

An ITypeInfo objects.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IElementInfo Properties

The IElementInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsAssemblyInfo | Gets true if element is an assembly.
Public property | IsClassInfo | Gets true if element is a class.
Public property | IsCodeElementInfo | Gets true if element is a code element.
Public property | IsEnumInfo | Gets true if element is a enumeration.
Public property | IsEnumMemberInfo | Gets true if element is an enumeration member.
Public property | IsFieldInfo | Gets true if element is a field.
Public property | IsMemberInfo | Gets true if element is a member of type.
Public property | IsMethodInfo | Gets true if element is a method.
Public property | IsParameterInfo | Gets true if element is a parameter.
Public property | IsPropertyInfo | Gets true if element is a property.
Public property | IsTypeInfo | Gets true if element is a type.

See Also

IElementInfo Interface


IsAssemblyInfo Property

IElementInfo..::..IsAssemblyInfo Property

Gets true if element is an assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsAssemblyInfo { get; }

Field Value

True if element is an assembly; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsClassInfo Property

IElementInfo..::..IsClassInfo Property

Gets true if element is a class.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsClassInfo { get; }

Field Value

True if element is a class; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsCodeElementInfo Property

IElementInfo..::..IsCodeElementInfo Property

Gets true if element is a code element.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsCodeElementInfo { get; }

Field Value

True if element is a code element; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsEnumInfo Property

IElementInfo..::..IsEnumInfo Property

Gets true if element is a enumeration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsEnumInfo { get; }

Field Value

True if element is a enumeration; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsEnumMemberInfo Property

IElementInfo..::..IsEnumMemberInfo Property

Gets true if element is an enumeration member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsEnumMemberInfo { get; }

Field Value

True if element is an enumeration member; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsFieldInfo Property

IElementInfo..::..IsFieldInfo Property

Gets true if element is a field.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsFieldInfo { get; }

Field Value

True if element is a field; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsMemberInfo Property

IElementInfo..::..IsMemberInfo Property

Gets true if element is a member of type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsMemberInfo { get; }

Field Value

True if element is a member of type; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsMethodInfo Property

IElementInfo..::..IsMethodInfo Property

Gets true if element is a method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsMethodInfo { get; }

Field Value

True if element is a method; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsParameterInfo Property

IElementInfo..::..IsParameterInfo Property

Gets true if element is a parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsParameterInfo { get; }

Field Value

True if element is a parameter; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsPropertyInfo Property

IElementInfo..::..IsPropertyInfo Property

Gets true if element is a property.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPropertyInfo { get; }

Field Value

True if element is a property; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IsTypeInfo Property

IElementInfo..::..IsTypeInfo Property

Gets true if element is a type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsTypeInfo { get; }

Field Value

True if element is a type; False if otherwise.

Remarks

Examples

To be added.

See Also

IElementInfo Interface


IEnumInfo Interface

Stores an enumeration information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IEnumInfo : ITypeInfo

Examples

To be added.

See Also

IEnumInfo Members


IEnumInfo Members

The IEnumInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetMembers | Gets an enumeration members.
Public method | SetMemberType | Sets a type of enumeration members.

See Also

IEnumInfo Interface


IEnumInfo Methods

The IEnumInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetMembers | Gets an enumeration members.
Public method | SetMemberType | Sets a type of enumeration members.

See Also

IEnumInfo Interface


GetMembers Method

IEnumInfo..::..GetMembers Method

Gets an enumeration members.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] GetMembers()

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

IEnumInfo Interface


SetMemberType Method

IEnumInfo..::..SetMemberType Method

Sets a type of enumeration members.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SetMemberType(
    Type type
)

Parameters

type
Type: Type

Type of the members.

Remarks

Examples

To be added.

See Also

IEnumInfo Interface


IEnumMemberInfo Interface

Stores an enumeration member information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IEnumMemberInfo : IMemberInfo

Examples

To be added.

See Also

IEnumMemberInfo Members


IEnumMemberInfo Members

The IEnumMemberInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets a constant expression that gives the value of the constant.

See Also

IEnumMemberInfo Interface


IEnumMemberInfo Properties

The IEnumMemberInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets a constant expression that gives the value of the constant.

See Also

IEnumMemberInfo Interface


InitExpression Property

IEnumMemberInfo..::..InitExpression Property

Gets a constant expression that gives the value of the constant.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IExpressionInfo InitExpression { get; }

Field Value

IExpressionInfo object.

Remarks

Examples

To be added.

See Also

IEnumMemberInfo Interface


IEventInfo Interface

Stores an event information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IEventInfo : IMemberInfo

Examples

To be added.

See Also

IEventInfo Members


IEventInfo Members

The IEventInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Returns local constants that declared inside of the event.
Public method | GetParameters | Returns parameters of the event.
Public method | GetVariables | Returns local valiables that declared inside of the event.

Properties

 | Name | Description
Public property | AddBlock | Gets IBlockInfo object with information about add block of the event.
Public property | AddRegion | Gets a region of the add block.
Public property | RemoveBlock | Gets IBlockInfo object with information about remove block of the event.
Public property | RemoveRegion | Gets a region of the remove block.

See Also

IEventInfo Interface


IEventInfo Methods

The IEventInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Returns local constants that declared inside of the event.
Public method | GetParameters | Returns parameters of the event.
Public method | GetVariables | Returns local valiables that declared inside of the event.

See Also

IEventInfo Interface


GetConstants Method

IEventInfo..::..GetConstants Method

Returns local constants that declared inside of the event.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ILocalConstantInfo[] GetConstants()

Return Value

An array of ILocalConstantInfo objects.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


GetParameters Method

IEventInfo..::..GetParameters Method

Returns parameters of the event.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IParameterInfo[] GetParameters()

Return Value

An array of IParameterInfo objects.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


GetVariables Method

IEventInfo..::..GetVariables Method

Returns local valiables that declared inside of the event.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IVariableInfo[] GetVariables()

Return Value

An array of IVariableInfo objects.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


IEventInfo Properties

The IEventInfo type exposes the following members.

Properties

 | Name | Description
Public property | AddBlock | Gets IBlockInfo object with information about add block of the event.
Public property | AddRegion | Gets a region of the add block.
Public property | RemoveBlock | Gets IBlockInfo object with information about remove block of the event.
Public property | RemoveRegion | Gets a region of the remove block.

See Also

IEventInfo Interface


AddBlock Property

IEventInfo..::..AddBlock Property

Gets IBlockInfo object with information about add block of the event.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IBlockInfo AddBlock { get; }

Field Value

IBlockInfo object.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


AddRegion Property

IEventInfo..::..AddRegion Property

Gets a region of the add block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo AddRegion { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


RemoveBlock Property

IEventInfo..::..RemoveBlock Property

Gets IBlockInfo object with information about remove block of the event.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IBlockInfo RemoveBlock { get; }

Field Value

IBlockInfo object.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


RemoveRegion Property

IEventInfo..::..RemoveRegion Property

Gets a region of the remove block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo RemoveRegion { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IEventInfo Interface


IExpressionInfo Interface

Stores an expression information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IExpressionInfo : IElementInfo

Examples

To be added.

See Also

IExpressionInfo Members


IExpressionInfo Members

The IExpressionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetIdentifiers | Returs an identifiers that located inside the expression.
Public method | GetInnerExpressions | Returns an expressions that located inside the expression.
Public method | InsertCodeBlockAfter | Inserts a specified code after the expression.
Public method | InsertCodeBlockBefore | Inserts a specified code at the beginning of the expressions.
Public method | ReplaceCodeBlock | Replaces the expression code with another specified code.

Properties

 | Name | Description
Public property | ExpressionType | Gets a type of the expression.
Public property | Index | Gets an index for this expression in the parent expression.
Public property | Parent | Gets parent object of the expression.
Public property | ProjectFile | Gets information about project file where this instance located.
Public property | Region | Gets a region of the expression.
Public property | Value | Gets value of the expression.

See Also

IExpressionInfo Interface


IExpressionInfo Methods

The IExpressionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetIdentifiers | Returs an identifiers that located inside the expression.
Public method | GetInnerExpressions | Returns an expressions that located inside the expression.
Public method | InsertCodeBlockAfter | Inserts a specified code after the expression.
Public method | InsertCodeBlockBefore | Inserts a specified code at the beginning of the expressions.
Public method | ReplaceCodeBlock | Replaces the expression code with another specified code.

See Also

IExpressionInfo Interface


GetIdentifiers Method

IExpressionInfo..::..GetIdentifiers Method

Returs an identifiers that located inside the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IIdentifierInfo[] GetIdentifiers()

Return Value

An array of IIdentifierInfo objects.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


GetInnerExpressions Method

IExpressionInfo..::..GetInnerExpressions Method

Returns an expressions that located inside the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IExpressionInfo[] GetInnerExpressions()

Return Value

An array of IExpressionInfo objects

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


InsertCodeBlockAfter Method

IExpressionInfo..::..InsertCodeBlockAfter Method

Inserts a specified code after the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAfter(
    string code,
    bool insertOnNewLine
)

Parameters

code
Type: String

A code.

insertOnNewLine
Type: Boolean

Is insert on new line.

Remarks

Examples

See Also

IExpressionInfo Interface


InsertCodeBlockBefore Method

IExpressionInfo..::..InsertCodeBlockBefore Method

Inserts a specified code at the beginning of the expressions.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockBefore(
    string code
)

Parameters

code
Type: String

A code.

Remarks

Examples

See Also

IExpressionInfo Interface


ReplaceCodeBlock Method

IExpressionInfo..::..ReplaceCodeBlock Method

Replaces the expression code with another specified code.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ReplaceCodeBlock(
    string newCode
)

Parameters

newCode
Type: String

New code.

Remarks

Examples

See Also

IExpressionInfo Interface


IExpressionInfo Properties

The IExpressionInfo type exposes the following members.

Properties

 | Name | Description
Public property | ExpressionType | Gets a type of the expression.
Public property | Index | Gets an index for this expression in the parent expression.
Public property | Parent | Gets parent object of the expression.
Public property | ProjectFile | Gets information about project file where this instance located.
Public property | Region | Gets a region of the expression.
Public property | Value | Gets value of the expression.

See Also

IExpressionInfo Interface


ExpressionType Property

IExpressionInfo..::..ExpressionType Property

Gets a type of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ExpressionType ExpressionType { get; }

Field Value

ExpressionType object.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


Index Property

IExpressionInfo..::..Index Property

Gets an index for this expression in the parent expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the expression

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


Parent Property

IExpressionInfo..::..Parent Property

Gets parent object of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Parent { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


ProjectFile Property

IExpressionInfo..::..ProjectFile Property

Gets information about project file where this instance located.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


Region Property

IExpressionInfo..::..Region Property

Gets a region of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


Value Property

IExpressionInfo..::..Value Property

Gets value of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Value { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IExpressionInfo Interface


IFieldInfo Interface

Stores a field information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IFieldInfo : IMemberInfo

Examples

To be added.

See Also

IFieldInfo Members


IFieldInfo Members

The IFieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | EncapsulateField | Provides a quick way to create a property from the field.

Properties

 | Name | Description
Public property | InitExpression | Gets an expression that gives the value of the field.

See Also

IFieldInfo Interface


IFieldInfo Methods

The IFieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | EncapsulateField | Provides a quick way to create a property from the field.

See Also

IFieldInfo Interface


EncapsulateField Method

IFieldInfo..::..EncapsulateField Method

Provides a quick way to create a property from the field.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void EncapsulateField(
    string newFieldName,
    string propertyName,
    MemberInfoModifiers modifiers,
    bool isReadOnly,
    bool updateLocalReferences
)

Parameters

newFieldName
Type: String

New field name.

propertyName
Type: String

New property name.

modifiers
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..MemberInfoModifiers

New property modifiers.

isReadOnly
Type: Boolean

Is new property read-only

updateLocalReferences
Type: Boolean

Update references in type where field is declared

Remarks

Examples

To be added.

See Also

IFieldInfo Interface


IFieldInfo Properties

The IFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets an expression that gives the value of the field.

See Also

IFieldInfo Interface


InitExpression Property

IFieldInfo..::..InitExpression Property

Gets an expression that gives the value of the field.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IExpressionInfo InitExpression { get; }

Field Value

IExpressionInfo object.

Remarks

Examples

To be added.

See Also

IFieldInfo Interface


IIdentifierInfo Interface

Stores an identifier information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IIdentifierInfo

Examples

To be added.

See Also

IIdentifierInfo Members


IIdentifierInfo Members

The IIdentifierInfo type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets definition of the identifier.
Public property | Name | Gets a name of the identifier.
Public property | Parent | Gets parent object of the identifier.
Public property | Region | Gets a region of the identifier.
Public property | Type | Gets a type of the identifier.

See Also

IIdentifierInfo Interface


IIdentifierInfo Properties

The IIdentifierInfo type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets definition of the identifier.
Public property | Name | Gets a name of the identifier.
Public property | Parent | Gets parent object of the identifier.
Public property | Region | Gets a region of the identifier.
Public property | Type | Gets a type of the identifier.

See Also

IIdentifierInfo Interface


Definition Property

IIdentifierInfo..::..Definition Property

Gets definition of the identifier.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Definition { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IIdentifierInfo Interface


Name Property

IIdentifierInfo..::..Name Property

Gets a name of the identifier.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

Name of the identifier.

Remarks

Examples

To be added.

See Also

IIdentifierInfo Interface


Parent Property

IIdentifierInfo..::..Parent Property

Gets parent object of the identifier.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Parent { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IIdentifierInfo Interface


Region Property

IIdentifierInfo..::..Region Property

Gets a region of the identifier.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IIdentifierInfo Interface


Type Property

IIdentifierInfo..::..Type Property

Gets a type of the identifier.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IdentifierType Type { get; }

Field Value

IdentifierType object.

Remarks

Examples

To be added.

See Also

IIdentifierInfo Interface


IIndexerInfo Interface

Stores an indexer information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IIndexerInfo : IPropertyBaseInfo

Examples

To be implemented in a future build.

See Also


IInterfaceInfo Interface

Stores an interface information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IInterfaceInfo : ITypeInfo,
    ITypeMembersInfo

Examples

To be added.

See Also


IJavaScriptExpressionInfo Interface

Stores an expression information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptExpressionInfo : IElementInfo

Examples

To be added.

See Also

IJavaScriptExpressionInfo Members


IJavaScriptExpressionInfo Members

The IJavaScriptExpressionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerExpressions | Returns an expressions that located inside the expression.

Properties

 | Name | Description
Public property | ExpressionType | Gets a type of the expression.
Public property | Index | Gets an index for this expression in the parent expression.
Public property | Parent | Gets parent object of the expression.
Public property | ProjectFile | Gets information about project file where this instance located.
Public property | Region | Gets a region of the expression.
Public property | Value | Gets value of the expression.

See Also

IJavaScriptExpressionInfo Interface


IJavaScriptExpressionInfo Methods

The IJavaScriptExpressionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerExpressions | Returns an expressions that located inside the expression.

See Also

IJavaScriptExpressionInfo Interface


GetInnerExpressions Method

IJavaScriptExpressionInfo..::..GetInnerExpressions Method

Returns an expressions that located inside the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptExpressionInfo[] GetInnerExpressions()

Return Value

An array of IExpressionInfo objects

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


IJavaScriptExpressionInfo Properties

The IJavaScriptExpressionInfo type exposes the following members.

Properties

 | Name | Description
Public property | ExpressionType | Gets a type of the expression.
Public property | Index | Gets an index for this expression in the parent expression.
Public property | Parent | Gets parent object of the expression.
Public property | ProjectFile | Gets information about project file where this instance located.
Public property | Region | Gets a region of the expression.
Public property | Value | Gets value of the expression.

See Also

IJavaScriptExpressionInfo Interface


ExpressionType Property

IJavaScriptExpressionInfo..::..ExpressionType Property

Gets a type of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ScriptExpressionType ExpressionType { get; }

Field Value

ExpressionType object.

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


Index Property

IJavaScriptExpressionInfo..::..Index Property

Gets an index for this expression in the parent expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the expression

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


Parent Property

IJavaScriptExpressionInfo..::..Parent Property

Gets parent object of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Parent { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


ProjectFile Property

IJavaScriptExpressionInfo..::..ProjectFile Property

Gets information about project file where this instance located.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


Region Property

IJavaScriptExpressionInfo..::..Region Property

Gets a region of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


Value Property

IJavaScriptExpressionInfo..::..Value Property

Gets value of the expression.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object Value { get; }

Field Value

An object.

Remarks

Examples

To be added.

See Also

IJavaScriptExpressionInfo Interface


IJavaScriptFunctionInfo Interface

Stores a javascript function information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptFunctionInfo : ICodeElementInfo

Examples

To be added.

See Also

IJavaScriptFunctionInfo Members


IJavaScriptFunctionInfo Members

The IJavaScriptFunctionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetParameters | Returns parameters of the function.
Public method | GetVariables | Gets variables that declared inside of the method.

Properties

 | Name | Description
Public property | ParentFunction | Gets parent function.
Public property | ProjectFile | Gets project file information of the member.
Public property | Statements | Gets statements of the function.

See Also

IJavaScriptFunctionInfo Interface


IJavaScriptFunctionInfo Methods

The IJavaScriptFunctionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetParameters | Returns parameters of the function.
Public method | GetVariables | Gets variables that declared inside of the method.

See Also

IJavaScriptFunctionInfo Interface


GetParameters Method

IJavaScriptFunctionInfo..::..GetParameters Method

Returns parameters of the function.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptParameterInfo[] GetParameters()

Return Value

An array of IJavaScriptParameterInfo objects.

Remarks

Examples

To be added.

See Also

IJavaScriptFunctionInfo Interface


GetVariables Method

IJavaScriptFunctionInfo..::..GetVariables Method

Gets variables that declared inside of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptVariableInfo[] GetVariables()

Return Value

An array of IJavaScriptVariableInfo objects.

Remarks

Examples

To be added.

See Also

IJavaScriptFunctionInfo Interface


IJavaScriptFunctionInfo Properties

The IJavaScriptFunctionInfo type exposes the following members.

Properties

 | Name | Description
Public property | ParentFunction | Gets parent function.
Public property | ProjectFile | Gets project file information of the member.
Public property | Statements | Gets statements of the function.

See Also

IJavaScriptFunctionInfo Interface


ParentFunction Property

IJavaScriptFunctionInfo..::..ParentFunction Property

Gets parent function.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptFunctionInfo ParentFunction { get; }

Field Value

IJavaScriptFunctionInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptFunctionInfo Interface


ProjectFile Property

IJavaScriptFunctionInfo..::..ProjectFile Property

Gets project file information of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptFunctionInfo Interface


Statements Property

IJavaScriptFunctionInfo..::..Statements Property

Gets statements of the function.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptStatementInfo[] Statements { get; }

Field Value

IJavaScriptStatementInfo[] object.

Remarks

Examples

To be added.

See Also

IJavaScriptFunctionInfo Interface


IJavaScriptGlobalVariableInfo Interface

Stores a javascript global variable information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptGlobalVariableInfo : ICodeElementInfo

Examples

To be added.

See Also

IJavaScriptGlobalVariableInfo Members


IJavaScriptGlobalVariableInfo Members

The IJavaScriptGlobalVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets an expression that gives the value of the javascript global variable.
Public property | ProjectFile | Gets project file information of the member.

See Also

IJavaScriptGlobalVariableInfo Interface


IJavaScriptGlobalVariableInfo Properties

The IJavaScriptGlobalVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | InitExpression | Gets an expression that gives the value of the javascript global variable.
Public property | ProjectFile | Gets project file information of the member.

See Also

IJavaScriptGlobalVariableInfo Interface


InitExpression Property

IJavaScriptGlobalVariableInfo..::..InitExpression Property

Gets an expression that gives the value of the javascript global variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptExpressionInfo InitExpression { get; }

Field Value

IJavaScriptExpressionInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptGlobalVariableInfo Interface


ProjectFile Property

IJavaScriptGlobalVariableInfo..::..ProjectFile Property

Gets project file information of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptGlobalVariableInfo Interface


IJavaScriptParameterInfo Interface

Stores a parameter information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptParameterInfo : ICodeElementInfo

Examples

To be added.

See Also

IJavaScriptParameterInfo Members


IJavaScriptParameterInfo Members

The IJavaScriptParameterInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the parameter.
Public property | ProjectFile | Gets a project file information of the parameter.

See Also

IJavaScriptParameterInfo Interface


IJavaScriptParameterInfo Properties

The IJavaScriptParameterInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the parameter.
Public property | ProjectFile | Gets a project file information of the parameter.

See Also

IJavaScriptParameterInfo Interface


Parent Property

IJavaScriptParameterInfo..::..Parent Property

Gets a parent member of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptFunctionInfo Parent { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptParameterInfo Interface


ProjectFile Property

IJavaScriptParameterInfo..::..ProjectFile Property

Gets a project file information of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptParameterInfo Interface


IJavaScriptStatementInfo Interface

Stores a statement information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptStatementInfo : IElementInfo

Examples

To be added.

See Also

IJavaScriptStatementInfo Members


IJavaScriptStatementInfo Members

The IJavaScriptStatementInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetExpressions | Gets custom expressions of the statement.
Public method | GetStatements | Returns array of IJavaScriptStatementInfo objects that located inside this instance.

Properties

 | Name | Description
Public property | Function | Gets parent Function object of the block.
Public property | Index | Gets an index for this statement in the parent statement.
Public property | Parent | Gets parent IJavaScriptStatementInfo object of the block.
Public property | Region | Gets IRegionInfo object of the block.
Public property | StatementType | Gets StatementType object of the block.

See Also

IJavaScriptStatementInfo Interface


IJavaScriptStatementInfo Methods

The IJavaScriptStatementInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetExpressions | Gets custom expressions of the statement.
Public method | GetStatements | Returns array of IJavaScriptStatementInfo objects that located inside this instance.

See Also

IJavaScriptStatementInfo Interface


GetExpressions Method

IJavaScriptStatementInfo..::..GetExpressions Method

Gets custom expressions of the statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptExpressionInfo[] GetExpressions()

Return Value

An array of IJavaScriptExpressionInfo objects.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


GetStatements Method

IJavaScriptStatementInfo..::..GetStatements Method

Returns array of IJavaScriptStatementInfo objects that located inside this instance.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptStatementInfo[] GetStatements()

Return Value

An array of IJavaScriptStatementInfo objects.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


IJavaScriptStatementInfo Properties

The IJavaScriptStatementInfo type exposes the following members.

Properties

 | Name | Description
Public property | Function | Gets parent Function object of the block.
Public property | Index | Gets an index for this statement in the parent statement.
Public property | Parent | Gets parent IJavaScriptStatementInfo object of the block.
Public property | Region | Gets IRegionInfo object of the block.
Public property | StatementType | Gets StatementType object of the block.

See Also

IJavaScriptStatementInfo Interface


Function Property

IJavaScriptStatementInfo..::..Function Property

Gets parent Function object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptFunctionInfo Function { get; }

Field Value

Function object.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


Index Property

IJavaScriptStatementInfo..::..Index Property

Gets an index for this statement in the parent statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the statement

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


Parent Property

IJavaScriptStatementInfo..::..Parent Property

Gets parent IJavaScriptStatementInfo object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptStatementInfo Parent { get; }

Field Value

IJavaScriptStatementInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


Region Property

IJavaScriptStatementInfo..::..Region Property

Gets IRegionInfo object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


StatementType Property

IJavaScriptStatementInfo..::..StatementType Property

Gets StatementType object of the block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ScriptStatementType StatementType { get; }

Field Value

StatementType object.

Remarks

Examples

To be added.

See Also

IJavaScriptStatementInfo Interface


IJavaScriptVariableInfo Interface

Stores a javascript variable information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IJavaScriptVariableInfo : ICodeElementInfo

Examples

To be added.

See Also

IJavaScriptVariableInfo Members


IJavaScriptVariableInfo Members

The IJavaScriptVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the javascript variable.
Public property | ProjectFile | Gets a project file where the javascript variable declared.
Public property | Statement | Gets a statement where the javascript variable declared.

See Also

IJavaScriptVariableInfo Interface


IJavaScriptVariableInfo Properties

The IJavaScriptVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the javascript variable.
Public property | ProjectFile | Gets a project file where the javascript variable declared.
Public property | Statement | Gets a statement where the javascript variable declared.

See Also

IJavaScriptVariableInfo Interface


Parent Property

IJavaScriptVariableInfo..::..Parent Property

Gets a parent member of the javascript variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptFunctionInfo Parent { get; }

Field Value

IJavaScriptFunctionInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptVariableInfo Interface


ProjectFile Property

IJavaScriptVariableInfo..::..ProjectFile Property

Gets a project file where the javascript variable declared.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptVariableInfo Interface


Statement Property

IJavaScriptVariableInfo..::..Statement Property

Gets a statement where the javascript variable declared.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IJavaScriptStatementInfo Statement { get; }

Field Value

IJavaScriptStatementInfo object.

Remarks

Examples

To be added.

See Also

IJavaScriptVariableInfo Interface


ILineInfo Interface

Stores a line information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ILineInfo : IElementInfo

Examples

To be added.

See Also

ILineInfo Members


ILineInfo Members

The ILineInfo type exposes the following members.

Properties

 | Name | Description
Public property | Region | Gets the line region.

See Also

ILineInfo Interface


ILineInfo Properties

The ILineInfo type exposes the following members.

Properties

 | Name | Description
Public property | Region | Gets the line region.

See Also

ILineInfo Interface


Region Property

ILineInfo..::..Region Property

Gets the line region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo Region { get; }

Field Value

Region of the line.

Remarks

Examples

To be added.

See Also

ILineInfo Interface


ILiteralInfo Interface

Stores a literal information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ILiteralInfo

Examples

To be added.

See Also

ILiteralInfo Members


ILiteralInfo Members

The ILiteralInfo type exposes the following members.

Methods

 | Name | Description
Public method | IntroduceConstant | Provides a quick way to create a new constant member, initializes it with the selected literal and replaces the selected text with the new constant.

Properties

 | Name | Description
Public property | Parent | Gets a parent of the literal.
Public property | Type | Gets a type of the literal.
Public property | Value | Gets a value of the literal.

See Also

ILiteralInfo Interface


ILiteralInfo Methods

The ILiteralInfo type exposes the following members.

Methods

 | Name | Description
Public method | IntroduceConstant | Provides a quick way to create a new constant member, initializes it with the selected literal and replaces the selected text with the new constant.

See Also

ILiteralInfo Interface


IntroduceConstant Method

ILiteralInfo..::..IntroduceConstant Method

Provides a quick way to create a new constant member, initializes it with the selected literal and replaces the selected text with the new constant.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void IntroduceConstant(
    string constantName
)

Parameters

constantName
Type: String

New constant name.

Examples

To be added.

See Also

ILiteralInfo Interface


ILiteralInfo Properties

The ILiteralInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent of the literal.
Public property | Type | Gets a type of the literal.
Public property | Value | Gets a value of the literal.

See Also

ILiteralInfo Interface


Parent Property

ILiteralInfo..::..Parent Property

Gets a parent of the literal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo Parent { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

ILiteralInfo Interface


Type Property

ILiteralInfo..::..Type Property

Gets a type of the literal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
LiteralType Type { get; }

Field Value

LiteralType object.

Remarks

Examples

To be added.

See Also

ILiteralInfo Interface


Value Property

ILiteralInfo..::..Value Property

Gets a value of the literal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Value { get; }

Field Value

Value of the literal.

Remarks

Examples

To be added.

See Also

ILiteralInfo Interface


ILocalConstantInfo Interface

Stores a local constant information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ILocalConstantInfo : ILocalVariableInfo

Examples

To be added.

See Also


ILocalVariableInfo Interface

Stores a local variable information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ILocalVariableInfo : ICodeElementInfo

Examples

To be added.

See Also

ILocalVariableInfo Members


ILocalVariableInfo Members

The ILocalVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the variable.
Public property | ProjectFile | Gets a project file where the variable declared.
Public property | ReturnType | Gets a return type of the variable.
Public property | Statement | Gets a statement where the variable declared.

See Also

ILocalVariableInfo Interface


ILocalVariableInfo Properties

The ILocalVariableInfo type exposes the following members.

Properties

 | Name | Description
Public property | Parent | Gets a parent member of the variable.
Public property | ProjectFile | Gets a project file where the variable declared.
Public property | ReturnType | Gets a return type of the variable.
Public property | Statement | Gets a statement where the variable declared.

See Also

ILocalVariableInfo Interface


Parent Property

ILocalVariableInfo..::..Parent Property

Gets a parent member of the variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo Parent { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

ILocalVariableInfo Interface


ProjectFile Property

ILocalVariableInfo..::..ProjectFile Property

Gets a project file where the variable declared.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

ILocalVariableInfo Interface


ReturnType Property

ILocalVariableInfo..::..ReturnType Property

Gets a return type of the variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo ReturnType { get; }

Field Value

IReturnTypeInfo object.

Remarks

Examples

To be added.

See Also

ILocalVariableInfo Interface


Statement Property

ILocalVariableInfo..::..Statement Property

Gets a statement where the variable declared.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IStatementInfo Statement { get; }

Field Value

IStatementInfo object.

Remarks

Examples

To be added.

See Also

ILocalVariableInfo Interface


IMemberInfo Interface

Stores a member information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IMemberInfo : ICodeElementInfo

Examples

To be added.

See Also

IMemberInfo Members


IMemberInfo Members

The IMemberInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds attribute for the member.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds attribute for the member.
Public method | GetAttributes | Gets custom attributes of the member.
Public method | GetIdentifiers | Returns identifiers that located in the member.
Public method | ReplaceCodeBlock | Replaces the code in specified region with another specified code.
Public method | SetModifier | Provides a quick way to change a modifiers for the member.

Properties

 | Name | Description
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | ExplicitInterfaceImplementationType | Gets a return type of the explicit interface member implementation.
Public property | IsAbstract | Gets a value indicating whether the member is abstract.
Public property | IsExtern | Gets a value indicating whether the member is external.
Public property | IsInternal | Gets a value indicating whether the member is internal.
Public property | IsLiteral | Gets a value indicating whether the member is a literal.
Public property | IsNew | Gets a value indicating whether the member hides another member.
Public property | IsOverloads | Gets a value indicating whether the member overloads another member.
Public property | IsOverride | Gets a value indicating whether the member overrides another member.
Public property | IsPrivate | Gets a value indicating whether the member is private.
Public property | IsProtected | Gets a value indicating whether the member is protected.
Public property | IsProtectedInternal | Gets a value indicating whether the member is protected and internal.
Public property | IsPublic | Gets a value indicating whether the member is public.
Public property | IsReadonly | Gets a value indicating whether the member is read only.
Public property | IsSealed | Gets a value indicating whether the member is sealed.
Public property | IsStatic | Gets a value indicating whether the member is static.
Public property | IsVirtual | Gets a value indicating whether the member is virtual.
Public property | Modifiers | Gets modifiers of the member.
Public property | Parent | Gets a parent type of the member.
Public property | ProjectFile | Gets project file information of the member.
Public property | ReturnType | Gets a return type of the member.

See Also

IMemberInfo Interface


IMemberInfo Methods

The IMemberInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds attribute for the member.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds attribute for the member.
Public method | GetAttributes | Gets custom attributes of the member.
Public method | GetIdentifiers | Returns identifiers that located in the member.
Public method | ReplaceCodeBlock | Replaces the code in specified region with another specified code.
Public method | SetModifier | Provides a quick way to change a modifiers for the member.

See Also

IMemberInfo Interface


AddAttribute Method

IMemberInfo..::..AddAttribute Method

Overload List

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds attribute for the member.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds attribute for the member.

See Also

IMemberInfo Interface
IMemberInfo Members


AddAttribute Method (String, String[])

IMemberInfo..::..AddAttribute Method (String, array<String>[]()[][])

Adds attribute for the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAttribute(
    string attributeName,
    string[] arguments
)

Parameters

attributeName
Type: String

Type name

arguments
Type: array< String >[]()[][]

Positional arguments.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface
AddAttribute Overload


AddAttribute Method (AttributeTargets, String, String[])

IMemberInfo..::..AddAttribute Method (AttributeTargets, String, array<String>[]()[][])

Adds attribute for the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAttribute(
    AttributeTargets targets,
    string attributeName,
    string[] arguments
)

Parameters

targets
Type: AttributeTargets

Type name

attributeName
Type: String

Type name

arguments
Type: array< String >[]()[][]

Positional arguments.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface
AddAttribute Overload


GetAttributes Method

IMemberInfo..::..GetAttributes Method

Gets custom attributes of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeSectionInfo[] GetAttributes()

Return Value

An array of IAttributeSectionInfo objects.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


GetIdentifiers Method

IMemberInfo..::..GetIdentifiers Method

Returns identifiers that located in the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IIdentifierInfo[] GetIdentifiers()

Return Value

An array of IIdentifierInfo objects.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


ReplaceCodeBlock Method

IMemberInfo..::..ReplaceCodeBlock Method

Replaces the code in specified region with another specified code.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ReplaceCodeBlock(
    IRegion region,
    string newCode
)

Parameters

region
Type: IRegion

Code region.

newCode
Type: String

New code.

Remarks

Examples

See Also

IMemberInfo Interface


SetModifier Method

IMemberInfo..::..SetModifier Method

Provides a quick way to change a modifiers for the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SetModifier(
    MemberInfoModifiers newModifier
)

Parameters

newModifier
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..MemberInfoModifiers

MemberInfoModifiers object.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IMemberInfo Properties

The IMemberInfo type exposes the following members.

Properties

 | Name | Description
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | ExplicitInterfaceImplementationType | Gets a return type of the explicit interface member implementation.
Public property | IsAbstract | Gets a value indicating whether the member is abstract.
Public property | IsExtern | Gets a value indicating whether the member is external.
Public property | IsInternal | Gets a value indicating whether the member is internal.
Public property | IsLiteral | Gets a value indicating whether the member is a literal.
Public property | IsNew | Gets a value indicating whether the member hides another member.
Public property | IsOverloads | Gets a value indicating whether the member overloads another member.
Public property | IsOverride | Gets a value indicating whether the member overrides another member.
Public property | IsPrivate | Gets a value indicating whether the member is private.
Public property | IsProtected | Gets a value indicating whether the member is protected.
Public property | IsProtectedInternal | Gets a value indicating whether the member is protected and internal.
Public property | IsPublic | Gets a value indicating whether the member is public.
Public property | IsReadonly | Gets a value indicating whether the member is read only.
Public property | IsSealed | Gets a value indicating whether the member is sealed.
Public property | IsStatic | Gets a value indicating whether the member is static.
Public property | IsVirtual | Gets a value indicating whether the member is virtual.
Public property | Modifiers | Gets modifiers of the member.
Public property | Parent | Gets a parent type of the member.
Public property | ProjectFile | Gets project file information of the member.
Public property | ReturnType | Gets a return type of the member.

See Also

IMemberInfo Interface


CaseSensitive Property

IMemberInfo..::..CaseSensitive Property

Returns true if project default language is case sensitive.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CaseSensitive { get; }

Field Value

True if project default language is case sensitive; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


ExplicitInterfaceImplementationType Property

IMemberInfo..::..ExplicitInterfaceImplementationType Property

Gets a return type of the explicit interface member implementation.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo ExplicitInterfaceImplementationType { get; }

Field Value

Return type of the explicit interface member implementation.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsAbstract Property

IMemberInfo..::..IsAbstract Property

Gets a value indicating whether the member is abstract.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsAbstract { get; }

Field Value

True if the member is abstract; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsExtern Property

IMemberInfo..::..IsExtern Property

Gets a value indicating whether the member is external.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsExtern { get; }

Field Value

True if the member is external; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsInternal Property

IMemberInfo..::..IsInternal Property

Gets a value indicating whether the member is internal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsInternal { get; }

Field Value

True if the member is internal; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsLiteral Property

IMemberInfo..::..IsLiteral Property

Gets a value indicating whether the member is a literal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsLiteral { get; }

Field Value

True if the member is a literal; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsNew Property

IMemberInfo..::..IsNew Property

Gets a value indicating whether the member hides another member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsNew { get; }

Field Value

True if the member hides another member; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsOverloads Property

IMemberInfo..::..IsOverloads Property

Gets a value indicating whether the member overloads another member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsOverloads { get; }

Field Value

True if the member overloads another member; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsOverride Property

IMemberInfo..::..IsOverride Property

Gets a value indicating whether the member overrides another member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsOverride { get; }

Field Value

True if the member overrides another member; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsPrivate Property

IMemberInfo..::..IsPrivate Property

Gets a value indicating whether the member is private.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPrivate { get; }

Field Value

True if the member is private; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsProtected Property

IMemberInfo..::..IsProtected Property

Gets a value indicating whether the member is protected.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsProtected { get; }

Field Value

True if the member is protected; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsProtectedInternal Property

IMemberInfo..::..IsProtectedInternal Property

Gets a value indicating whether the member is protected and internal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsProtectedInternal { get; }

Field Value

True if the member is protected and internal; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsPublic Property

IMemberInfo..::..IsPublic Property

Gets a value indicating whether the member is public.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPublic { get; }

Field Value

True if the member is public; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsReadonly Property

IMemberInfo..::..IsReadonly Property

Gets a value indicating whether the member is read only.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsReadonly { get; }

Field Value

True if the member is read only; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsSealed Property

IMemberInfo..::..IsSealed Property

Gets a value indicating whether the member is sealed.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsSealed { get; }

Field Value

True if the member is sealed; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsStatic Property

IMemberInfo..::..IsStatic Property

Gets a value indicating whether the member is static.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsStatic { get; }

Field Value

True if the member is static; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IsVirtual Property

IMemberInfo..::..IsVirtual Property

Gets a value indicating whether the member is virtual.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsVirtual { get; }

Field Value

True if the member is virtual; False if otherwise.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


Modifiers Property

IMemberInfo..::..Modifiers Property

Gets modifiers of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
MemberInfoModifiers Modifiers { get; }

Field Value

MemberInfoModifiers object.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


Parent Property

IMemberInfo..::..Parent Property

Gets a parent type of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo Parent { get; }

Field Value

ITypeInfo object.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


ProjectFile Property

IMemberInfo..::..ProjectFile Property

Gets project file information of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


ReturnType Property

IMemberInfo..::..ReturnType Property

Gets a return type of the member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo ReturnType { get; }

Field Value

IReturnTypeInfo object.

Remarks

Examples

To be added.

See Also

IMemberInfo Interface


IMethodInfo Interface

Stores a method information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IMethodInfo : IMemberInfo

Examples

To be added.

See Also

IMethodInfo Members


IMethodInfo Members

The IMethodInfo type exposes the following members.

Methods

 | Name | Description
Public method | ChangeParametersList | Provides a quick way to replace the method parameters with specified parameters.
Public method | ChangeReturnType | Changes return type of the method.
Public method | CommentBody | Comments out the body of the method.
Public method | GetConstants | Gets constants that declared inside of the method.
Public method | GetParameters | Returns parameters of the method.
Public method | GetVariables | Gets variables that declared inside of the method.
Public method | InsertBaseMethodCall | Inserts a base method call after the method declaration.
Public method | InsertCodeBlockAfterStatement | Inserts a code block after the specified statement.
Public method | InsertCodeBlockAt(String, Int32, Int32) | Inserts a code block at the specified line and column.
Public method | InsertCodeBlockAt(String, IStatementInfo, IStatementInfo, IStatementInfo, Boolean, Boolean) | Inserts a code block.
Public method | InsertCodeBlockAtEnd | Inserts a code block at the end of specified statement.
Public method | InsertCodeBlockAtStart | Inserts a code block at the start of specified statement.
Public method | InsertCodeBlockBeforeStatement | Inserts a code block before the specified statement.
Public method | RemoveParameterAt | Removes a parameter from specified index.

Properties

 | Name | Description
Public property | Block | Gets statements block of the method.
Public property | IsAsync | Gets a value indicating whether the method is async.
Public property | IsConstructor | Gets true if the method is a constructor.
Public property | IsDestructor | Gets true if method is a destructor.
Public property | IsGenericMethodDefinition | Gets a value that indicates whether the method represents the definition of a generic method.

See Also

IMethodInfo Interface


IMethodInfo Methods

The IMethodInfo type exposes the following members.

Methods

 | Name | Description
Public method | ChangeParametersList | Provides a quick way to replace the method parameters with specified parameters.
Public method | ChangeReturnType | Changes return type of the method.
Public method | CommentBody | Comments out the body of the method.
Public method | GetConstants | Gets constants that declared inside of the method.
Public method | GetParameters | Returns parameters of the method.
Public method | GetVariables | Gets variables that declared inside of the method.
Public method | InsertBaseMethodCall | Inserts a base method call after the method declaration.
Public method | InsertCodeBlockAfterStatement | Inserts a code block after the specified statement.
Public method | InsertCodeBlockAt(String, Int32, Int32) | Inserts a code block at the specified line and column.
Public method | InsertCodeBlockAt(String, IStatementInfo, IStatementInfo, IStatementInfo, Boolean, Boolean) | Inserts a code block.
Public method | InsertCodeBlockAtEnd | Inserts a code block at the end of specified statement.
Public method | InsertCodeBlockAtStart | Inserts a code block at the start of specified statement.
Public method | InsertCodeBlockBeforeStatement | Inserts a code block before the specified statement.
Public method | RemoveParameterAt | Removes a parameter from specified index.

See Also

IMethodInfo Interface


ChangeParametersList Method

IMethodInfo..::..ChangeParametersList Method

Provides a quick way to replace the method parameters with specified parameters.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ChangeParametersList(
    ParameterCollection parameters
)

Parameters

parameters
Type: ParameterCollection

An array of ParameterCollection objects.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


ChangeReturnType Method

IMethodInfo..::..ChangeReturnType Method

Changes return type of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ChangeReturnType(
    string namespaceFullName,
    string newReturnType
)

Parameters

namespaceFullName
Type: String

Namespace full name.

newReturnType
Type: String

New return type name.

See Also

IMethodInfo Interface


CommentBody Method

IMethodInfo..::..CommentBody Method

Comments out the body of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void CommentBody()

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


GetConstants Method

IMethodInfo..::..GetConstants Method

Gets constants that declared inside of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ILocalConstantInfo[] GetConstants()

Return Value

An array of ILocalConstantInfo objects.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


GetParameters Method

IMethodInfo..::..GetParameters Method

Returns parameters of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IParameterInfo[] GetParameters()

Return Value

An array of IParameterInfo objects.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


GetVariables Method

IMethodInfo..::..GetVariables Method

Gets variables that declared inside of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IVariableInfo[] GetVariables()

Return Value

An array of IVariableInfo objects.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


InsertBaseMethodCall Method

IMethodInfo..::..InsertBaseMethodCall Method

Inserts a base method call after the method declaration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertBaseMethodCall(
    string code
)

Parameters

code
Type: String

Code to call base method.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


InsertCodeBlockAfterStatement Method

IMethodInfo..::..InsertCodeBlockAfterStatement Method

Inserts a code block after the specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAfterStatement(
    string code,
    IStatementInfo statementInfoToInsertAfter
)

Parameters

code
Type: String

Code to be inserted.

statementInfoToInsertAfter
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


InsertCodeBlockAt Method

IMethodInfo..::..InsertCodeBlockAt Method

Overload List

 | Name | Description
Public method | InsertCodeBlockAt(String, Int32, Int32) | Inserts a code block at the specified line and column.
Public method | InsertCodeBlockAt(String, IStatementInfo, IStatementInfo, IStatementInfo, Boolean, Boolean) | Inserts a code block.

See Also

IMethodInfo Interface
IMethodInfo Members


InsertCodeBlockAt Method (String, Int32, Int32)

IMethodInfo..::..InsertCodeBlockAt Method (String, Int32, Int32)

Inserts a code block at the specified line and column.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAt(
    string code,
    int startLine,
    int startColumn
)

Parameters

code
Type: String

Code to be inserted.

startLine
Type: Int32

Start line.

startColumn
Type: Int32

Start column.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface
InsertCodeBlockAt Overload


InsertCodeBlockAt Method (String, IStatementInfo, IStatementInfo, IStatementInfo, Boolean, Boolean)

IMethodInfo..::..InsertCodeBlockAt Method (String, IStatementInfo, IStatementInfo, IStatementInfo, Boolean, Boolean)

Inserts a code block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAt(
    string code,
    IStatementInfo parentStatementInfo,
    IStatementInfo statementInfoToInsertBefore,
    IStatementInfo statementInfoToInsertAfter,
    bool insertAtStart,
    bool insertAtEnd
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

statementInfoToInsertBefore
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

statementInfoToInsertAfter
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

insertAtStart
Type: Boolean

True if insert at the start; False if otherwise.

insertAtEnd
Type: Boolean

True if insert at the end; False if otherwise.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface
InsertCodeBlockAt Overload


InsertCodeBlockAtEnd Method

IMethodInfo..::..InsertCodeBlockAtEnd Method

Inserts a code block at the end of specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAtEnd(
    string code,
    IStatementInfo parentStatementInfo
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


InsertCodeBlockAtStart Method

IMethodInfo..::..InsertCodeBlockAtStart Method

Inserts a code block at the start of specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAtStart(
    string code,
    IStatementInfo parentStatementInfo
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


InsertCodeBlockBeforeStatement Method

IMethodInfo..::..InsertCodeBlockBeforeStatement Method

Inserts a code block before the specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockBeforeStatement(
    string code,
    IStatementInfo statementInfoToInsertBefore
)

Parameters

code
Type: String

Code to be inserted.

statementInfoToInsertBefore
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


RemoveParameterAt Method

IMethodInfo..::..RemoveParameterAt Method

Removes a parameter from specified index.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void RemoveParameterAt(
    int index
)

Parameters

index
Type: Int32

Index of the parameter.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IMethodInfo Properties

The IMethodInfo type exposes the following members.

Properties

 | Name | Description
Public property | Block | Gets statements block of the method.
Public property | IsAsync | Gets a value indicating whether the method is async.
Public property | IsConstructor | Gets true if the method is a constructor.
Public property | IsDestructor | Gets true if method is a destructor.
Public property | IsGenericMethodDefinition | Gets a value that indicates whether the method represents the definition of a generic method.

See Also

IMethodInfo Interface


Block Property

IMethodInfo..::..Block Property

Gets statements block of the method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IBlockInfo Block { get; }

Field Value

IBlockInfo object.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IsAsync Property

IMethodInfo..::..IsAsync Property

Gets a value indicating whether the method is async.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsAsync { get; }

Field Value

True if the member is async; False if otherwise.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IsConstructor Property

IMethodInfo..::..IsConstructor Property

Gets true if the method is a constructor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsConstructor { get; }

Field Value

True if method is a constructor; False if otherwise.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IsDestructor Property

IMethodInfo..::..IsDestructor Property

Gets true if method is a destructor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsDestructor { get; }

Field Value

True if method is a destructor; False if otherwise.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IsGenericMethodDefinition Property

IMethodInfo..::..IsGenericMethodDefinition Property

Gets a value that indicates whether the method represents the definition of a generic method.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsGenericMethodDefinition { get; }

Field Value

True if the method represents the definition of a generic method; False if otherwise.

Remarks

Examples

To be added.

See Also

IMethodInfo Interface


IModuleInfo Interface

Stores a module information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IModuleInfo : ITypeInfo,
    ITypeMembersInfo

Examples

To be added.

See Also


INamespaceDeclarationInfo Interface

Stores a namespace declaration information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface INamespaceDeclarationInfo : ICodeElementInfo

Examples

To be added.

See Also

INamespaceDeclarationInfo Members


INamespaceDeclarationInfo Members

The INamespaceDeclarationInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetIdentifiers | Gets an identifiers of the namespace declaration.

Properties

 | Name | Description
Public property | NamespaceDeclarations | Gets a namespace declaration.
Public property | ParentNamespaceDeclaration | Gets a parent namespace declaration.
Public property | ProjectFile | Gets a project file.

See Also

INamespaceDeclarationInfo Interface


INamespaceDeclarationInfo Methods

The INamespaceDeclarationInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetIdentifiers | Gets an identifiers of the namespace declaration.

See Also

INamespaceDeclarationInfo Interface


GetIdentifiers Method

INamespaceDeclarationInfo..::..GetIdentifiers Method

Gets an identifiers of the namespace declaration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IIdentifierInfo[] GetIdentifiers()

Return Value

An array of IIdentifierInfo objects.

Remarks

Examples

To be added.

See Also

INamespaceDeclarationInfo Interface


INamespaceDeclarationInfo Properties

The INamespaceDeclarationInfo type exposes the following members.

Properties

 | Name | Description
Public property | NamespaceDeclarations | Gets a namespace declaration.
Public property | ParentNamespaceDeclaration | Gets a parent namespace declaration.
Public property | ProjectFile | Gets a project file.

See Also

INamespaceDeclarationInfo Interface


NamespaceDeclarations Property

INamespaceDeclarationInfo..::..NamespaceDeclarations Property

Gets a namespace declaration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
INamespaceDeclarationInfo[] NamespaceDeclarations { get; }

Field Value

An array of INamespaceDeclarationInfo objects.

Remarks

Examples

To be added.

See Also

INamespaceDeclarationInfo Interface


ParentNamespaceDeclaration Property

INamespaceDeclarationInfo..::..ParentNamespaceDeclaration Property

Gets a parent namespace declaration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
INamespaceDeclarationInfo ParentNamespaceDeclaration { get; }

Field Value

INamespaceDeclarationInfo object.

Remarks

Examples

To be added.

See Also

INamespaceDeclarationInfo Interface


ProjectFile Property

INamespaceDeclarationInfo..::..ProjectFile Property

Gets a project file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

INamespaceDeclarationInfo Interface


INamespaceInfo Interface

Stores a namespace information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface INamespaceInfo : ICodeElementInfo

Examples

To be added.

See Also

INamespaceInfo Members


INamespaceInfo Members

The INamespaceInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetTypes | Gets all types declrated in the namespace.

Properties

 | Name | Description
Public property | Projects | Gets projects contained the namespace.

See Also

INamespaceInfo Interface


INamespaceInfo Methods

The INamespaceInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetTypes | Gets all types declrated in the namespace.

See Also

INamespaceInfo Interface


GetTypes Method

INamespaceInfo..::..GetTypes Method

Gets all types declrated in the namespace.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetTypes()

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

INamespaceInfo Interface


INamespaceInfo Properties

The INamespaceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Projects | Gets projects contained the namespace.

See Also

INamespaceInfo Interface


Projects Property

INamespaceInfo..::..Projects Property

Gets projects contained the namespace.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectInfo[] Projects { get; }

Field Value

An array of IProjectInfo objects.

Remarks

Examples

To be added.

See Also

INamespaceInfo Interface


IOperatorInfo Interface

Stores an operator information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IOperatorInfo : IMethodInfo

Examples

To be added.

See Also

IOperatorInfo Members


IOperatorInfo Members

The IOperatorInfo type exposes the following members.

Properties

 | Name | Description
Public property | Cast | Gets an user-defined conversion.

See Also

IOperatorInfo Interface


IOperatorInfo Properties

The IOperatorInfo type exposes the following members.

Properties

 | Name | Description
Public property | Cast | Gets an user-defined conversion.

See Also

IOperatorInfo Interface


Cast Property

IOperatorInfo..::..Cast Property

Gets an user-defined conversion.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
OperatorConversion Cast { get; }

Field Value

OperatorConversion object.

Remarks

Examples

To be added.

See Also

IOperatorInfo Interface


IParameterInfo Interface

Stores a parameter information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IParameterInfo : ICodeElementInfo

Examples

To be added.

See Also

IParameterInfo Members


IParameterInfo Members

The IParameterInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetAttributes | Gets custom attributes of the parameters.

Properties

 | Name | Description
Public property | IsOptional | Gets a value indicating whether the parameter is an optional.
Public property | IsOut | Gets a value indicating whether the parameter is out.
Public property | IsParams | Gets a value indicating whether the parameter is a parameter array.
Public property | IsRef | Gets a value indicating whether the parameter is ref.
Public property | Modifier | Gets modifiers of the parameter.
Public property | Parent | Gets a parent member of the parameter.
Public property | ProjectFile | Gets a project file information of the parameter.
Public property | ReturnType | Gets a return type of the parameter.

See Also

IParameterInfo Interface


IParameterInfo Methods

The IParameterInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetAttributes | Gets custom attributes of the parameters.

See Also

IParameterInfo Interface


GetAttributes Method

IParameterInfo..::..GetAttributes Method

Gets custom attributes of the parameters.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeSectionInfo[] GetAttributes()

Return Value

An array of IAttributeSectionInfo objects.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


IParameterInfo Properties

The IParameterInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsOptional | Gets a value indicating whether the parameter is an optional.
Public property | IsOut | Gets a value indicating whether the parameter is out.
Public property | IsParams | Gets a value indicating whether the parameter is a parameter array.
Public property | IsRef | Gets a value indicating whether the parameter is ref.
Public property | Modifier | Gets modifiers of the parameter.
Public property | Parent | Gets a parent member of the parameter.
Public property | ProjectFile | Gets a project file information of the parameter.
Public property | ReturnType | Gets a return type of the parameter.

See Also

IParameterInfo Interface


IsOptional Property

IParameterInfo..::..IsOptional Property

Gets a value indicating whether the parameter is an optional.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsOptional { get; }

Field Value

True if parameter is an optional; False if otherwise.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


IsOut Property

IParameterInfo..::..IsOut Property

Gets a value indicating whether the parameter is out.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsOut { get; }

Field Value

True if parameter is out; False if otherwise.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


IsParams Property

IParameterInfo..::..IsParams Property

Gets a value indicating whether the parameter is a parameter array.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsParams { get; }

Field Value

True if parameter is a parameter array; False if otherwise.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


IsRef Property

IParameterInfo..::..IsRef Property

Gets a value indicating whether the parameter is ref.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsRef { get; }

Field Value

True if parameter is ref; False if otherwise.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


Modifier Property

IParameterInfo..::..Modifier Property

Gets modifiers of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ParameterModifier Modifier { get; }

Field Value

ParameterModifier object.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


Parent Property

IParameterInfo..::..Parent Property

Gets a parent member of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo Parent { get; }

Field Value

IMemberInfo object.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


ProjectFile Property

IParameterInfo..::..ProjectFile Property

Gets a project file information of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


ReturnType Property

IParameterInfo..::..ReturnType Property

Gets a return type of the parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo ReturnType { get; }

Field Value

IReturnTypeInfo object.

Remarks

Examples

To be added.

See Also

IParameterInfo Interface


IPluginAnalyzer Interface

Plugins analyzer interface

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IPluginAnalyzer

See Also

IPluginAnalyzer Members


IPluginAnalyzer Members

The IPluginAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Cleanup | Cleanup the cache
Public method | Run | Run analysis for plugin

Properties

 | Name | Description
Public property | IsValid | Returns True if plugin can analyze the file

See Also

IPluginAnalyzer Interface


IPluginAnalyzer Methods

The IPluginAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | Cleanup | Cleanup the cache
Public method | Run | Run analysis for plugin

See Also

IPluginAnalyzer Interface


Cleanup Method

IPluginAnalyzer..::..Cleanup Method

Cleanup the cache

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Cleanup()

See Also

IPluginAnalyzer Interface


Run Method

IPluginAnalyzer..::..Run Method

Run analysis for plugin

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
RulesCollection Run(
    IProjectFile projectFile,
    int startLine,
    int endLine
)

Parameters

projectFile
Type: IProjectFile
startLine
Type: Int32
endLine
Type: Int32

Return Value

Returns violation collection.

See Also

IPluginAnalyzer Interface


IPluginAnalyzer Properties

The IPluginAnalyzer type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns True if plugin can analyze the file

See Also

IPluginAnalyzer Interface


IsValid Property

IPluginAnalyzer..::..IsValid Property

Returns True if plugin can analyze the file

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsValid { get; }

See Also

IPluginAnalyzer Interface


IProjectFileInfo Interface

Stores a project file information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IProjectFileInfo : IElementInfo

Examples

To be added.

See Also

IProjectFileInfo Members


IProjectFileInfo Members

The IProjectFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddHeaderText(String) | Adds header to the source file.
Public method | GetCodeRegions | Returns code regions of the project file.
Public method | GetTypes | Returns types of the project file.
Public method | Rename | Replaces a name of the file, with another specified name.
Public method | ReplaceCodeBlock(IRegionInfo, String) | Replaces the code in specified region with another in file specified.

Properties

 | Name | Description
Public property | FullName | Gets a project file full name.
Public property | HeaderText | Gets a project file header.
Public property | Name | Gets a project file name.
Public property | Project | Gets a project where project file located.

See Also

IProjectFileInfo Interface


IProjectFileInfo Methods

The IProjectFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddHeaderText(String) | Adds header to the source file.
Public method | GetCodeRegions | Returns code regions of the project file.
Public method | GetTypes | Returns types of the project file.
Public method | Rename | Replaces a name of the file, with another specified name.
Public method | ReplaceCodeBlock(IRegionInfo, String) | Replaces the code in specified region with another in file specified.

See Also

IProjectFileInfo Interface


AddHeaderText Method (String)

IProjectFileInfo..::..AddHeaderText Method (String)

Adds header to the source file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddHeaderText(
    string templateText
)

Parameters

templateText
Type: String

Template text.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface
AddHeaderText Overload


GetCodeRegions Method

IProjectFileInfo..::..GetCodeRegions Method

Returns code regions of the project file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ICodeRegionInfo[] GetCodeRegions()

Return Value

An array of ICodeRegionInfo objects.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


GetTypes Method

IProjectFileInfo..::..GetTypes Method

Returns types of the project file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetTypes()

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


Rename Method

IProjectFileInfo..::..Rename Method

Replaces a name of the file, with another specified name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool Rename(
    string newName
)

Parameters

newName
Type: String

New file name.

Return Value

True if the file was renamed successfully; False if otherwise.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


ReplaceCodeBlock Method (IRegionInfo, String)

IProjectFileInfo..::..ReplaceCodeBlock Method (IRegionInfo, String)

Replaces the code in specified region with another in file specified.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ReplaceCodeBlock(
    IRegionInfo regionInfo,
    string newCode
)

Parameters

regionInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IRegionInfo

Code region.

newCode
Type: String

New code.

Remarks

Examples

See Also

IProjectFileInfo Interface
ReplaceCodeBlock Overload


IProjectFileInfo Properties

The IProjectFileInfo type exposes the following members.

Properties

 | Name | Description
Public property | FullName | Gets a project file full name.
Public property | HeaderText | Gets a project file header.
Public property | Name | Gets a project file name.
Public property | Project | Gets a project where project file located.

See Also

IProjectFileInfo Interface


FullName Property

IProjectFileInfo..::..FullName Property

Gets a project file full name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string FullName { get; }

Field Value

Project file full name.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


HeaderText Property

IProjectFileInfo..::..HeaderText Property

Gets a project file header.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string HeaderText { get; }

Field Value

Project file header.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


Name Property

IProjectFileInfo..::..Name Property

Gets a project file name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

Project file name.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


Project Property

IProjectFileInfo..::..Project Property

Gets a project where project file located.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectInfo Project { get; }

Field Value

Project.

Remarks

Examples

To be added.

See Also

IProjectFileInfo Interface


IProjectInfo Interface

Stores a project information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IProjectInfo : IElementInfo

Examples

To be added.

See Also

IProjectInfo Members


IProjectInfo Members

The IProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAssemblyInfo | Adds assembly info file to the project.
Public method | AddFile | Adds a project file to the project.
Public method | GetProjectFiles | Gets a project files.
Public method | GetProperty | Gets a project property value.
Public method | SetProperty | Sets a project property value.

Properties

 | Name | Description
Public property | AssemblyInfo | Gets an assembly of the project.
Public property | AssemblyOriginatorKeyFile | Gets full path of key file.
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | DocumentationFile | Gets a project xml documentation file.
Public property | FileName | Gets a project full name.
Public property | HasStrongName | Gets true if the assembly has a strong name.
Public property | IsSigned | Gets true if the value of SignAssembly element in project file is true.
Public property | Language | Gets a project language.
Public property | Name | Gets a project name.
Public property | OutputType | Gets a type of the project.
Public property | RootNamespace | Gets a root namespace of the project.
Public property | Solution | Gets a solution where project located.
Public property | StartupObject | Gets a startup object.

See Also

IProjectInfo Interface


IProjectInfo Methods

The IProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAssemblyInfo | Adds assembly info file to the project.
Public method | AddFile | Adds a project file to the project.
Public method | GetProjectFiles | Gets a project files.
Public method | GetProperty | Gets a project property value.
Public method | SetProperty | Sets a project property value.

See Also

IProjectInfo Interface


AddAssemblyInfo Method

IProjectInfo..::..AddAssemblyInfo Method

Adds assembly info file to the project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAssemblyInfo()

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


AddFile Method

IProjectInfo..::..AddFile Method

Adds a project file to the project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddFile(
    string filePath
)

Parameters

filePath
Type: String

File name.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


GetProjectFiles Method

IProjectInfo..::..GetProjectFiles Method

Gets a project files.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo[] GetProjectFiles()

Return Value

An array of IProjectFileInfo objects.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


GetProperty Method

IProjectInfo..::..GetProperty Method

Gets a project property value.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object GetProperty(
    string propertyName
)

Parameters

propertyName
Type: String

Name of the property.

Return Value

Property value.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


SetProperty Method

IProjectInfo..::..SetProperty Method

Sets a project property value.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SetProperty(
    string propertyName,
    Object value
)

Parameters

propertyName
Type: String

Name of the property.

value
Type: Object

Default value for the property.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


IProjectInfo Properties

The IProjectInfo type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInfo | Gets an assembly of the project.
Public property | AssemblyOriginatorKeyFile | Gets full path of key file.
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | DocumentationFile | Gets a project xml documentation file.
Public property | FileName | Gets a project full name.
Public property | HasStrongName | Gets true if the assembly has a strong name.
Public property | IsSigned | Gets true if the value of SignAssembly element in project file is true.
Public property | Language | Gets a project language.
Public property | Name | Gets a project name.
Public property | OutputType | Gets a type of the project.
Public property | RootNamespace | Gets a root namespace of the project.
Public property | Solution | Gets a solution where project located.
Public property | StartupObject | Gets a startup object.

See Also

IProjectInfo Interface


AssemblyInfo Property

IProjectInfo..::..AssemblyInfo Property

Gets an assembly of the project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAssemblyInfo AssemblyInfo { get; }

Field Value

IAssemblyInfo object.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


AssemblyOriginatorKeyFile Property

IProjectInfo..::..AssemblyOriginatorKeyFile Property

Gets full path of key file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string AssemblyOriginatorKeyFile { get; }

Field Value

The full path of the key file.

Examples

To be added.

See Also

IProjectInfo Interface


CaseSensitive Property

IProjectInfo..::..CaseSensitive Property

Returns true if project default language is case sensitive.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CaseSensitive { get; }

Field Value

True if project default language is case sensitive; False if otherwise.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


DocumentationFile Property

IProjectInfo..::..DocumentationFile Property

Gets a project xml documentation file.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string DocumentationFile { get; }

Field Value

Project xml documentation file.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


FileName Property

IProjectInfo..::..FileName Property

Gets a project full name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string FileName { get; }

Field Value

Project full name.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


HasStrongName Property

IProjectInfo..::..HasStrongName Property

Gets true if the assembly has a strong name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool HasStrongName { get; }

Field Value

True if the assembly has a strong name; False if otherwise.

Remarks

See Strong-Named Assemblies for a description of the strong named assemblies.

Examples

To be added.

See Also

IProjectInfo Interface


IsSigned Property

IProjectInfo..::..IsSigned Property

Gets true if the value of SignAssembly element in project file is true.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsSigned { get; }

Field Value

True if the value of SignAssembly element in project file is true; False if otherwise.

Examples

To be added.

See Also

IProjectInfo Interface


Language Property

IProjectInfo..::..Language Property

Gets a project language.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ProjectInfoLanguage Language { get; }

Field Value

ProjectInfoLanguage object.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


Name Property

IProjectInfo..::..Name Property

Gets a project name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

Project name.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


OutputType Property

IProjectInfo..::..OutputType Property

Gets a type of the project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
OutputTypeInfo OutputType { get; }

Field Value

OutputTypeInfo object.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


RootNamespace Property

IProjectInfo..::..RootNamespace Property

Gets a root namespace of the project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string RootNamespace { get; }

Field Value

Root namespace of the project.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


Solution Property

IProjectInfo..::..Solution Property

Gets a solution where project located.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ISolutionInfo Solution { get; }

Field Value

ISolutionInfo object.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


StartupObject Property

IProjectInfo..::..StartupObject Property

Gets a startup object.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string StartupObject { get; }

Field Value

Startup object.

Remarks

Examples

To be added.

See Also

IProjectInfo Interface


IPropertyBaseInfo Interface

Stores a common information about propery or indexer.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IPropertyBaseInfo : IMemberInfo

Examples

To be added.

See Also

IPropertyBaseInfo Members


IPropertyBaseInfo Members

The IPropertyBaseInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Gets custom constants of the property/indexer.
Public method | GetParameters | Gets custom parameters of the property/indexer.
Public method | GetVariables | Gets a custom variables of the property/indexer.
Public method | InsertCodeBlockAfterStatement | Inserts a code block after the specified statement.
Public method | InsertCodeBlockAt | Inserts a code block.
Public method | InsertCodeBlockAtEnd | Inserts a code block at the end of specified statement.
Public method | InsertCodeBlockAtStart | Inserts a code block at the start of specified statement.
Public method | InsertCodeBlockBeforeStatement | Inserts a code block before the specified statement.

Properties

 | Name | Description
Public property | CanGet | Returns true if the property/indexer has get-accessor.
Public property | CanSet | Returns true if property/indexer has set-accessor.
Public property | GetBlock | Gets a block object of the property/indexer get-accessor.
Public property | GetRegion | Gets a region of the property/indexer get-accessor.
Public property | SetBlock | Gets a block object of the property/indexer set-accessor.
Public property | SetRegion | Gets a region of the property/indexer set-accessor.

See Also

IPropertyBaseInfo Interface


IPropertyBaseInfo Methods

The IPropertyBaseInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Gets custom constants of the property/indexer.
Public method | GetParameters | Gets custom parameters of the property/indexer.
Public method | GetVariables | Gets a custom variables of the property/indexer.
Public method | InsertCodeBlockAfterStatement | Inserts a code block after the specified statement.
Public method | InsertCodeBlockAt | Inserts a code block.
Public method | InsertCodeBlockAtEnd | Inserts a code block at the end of specified statement.
Public method | InsertCodeBlockAtStart | Inserts a code block at the start of specified statement.
Public method | InsertCodeBlockBeforeStatement | Inserts a code block before the specified statement.

See Also

IPropertyBaseInfo Interface


GetConstants Method

IPropertyBaseInfo..::..GetConstants Method

Gets custom constants of the property/indexer.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ILocalConstantInfo[] GetConstants()

Return Value

An array of ILocalConstantInfo objects.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


GetParameters Method

IPropertyBaseInfo..::..GetParameters Method

Gets custom parameters of the property/indexer.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IParameterInfo[] GetParameters()

Return Value

An array of IParameterInfo objects.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


GetVariables Method

IPropertyBaseInfo..::..GetVariables Method

Gets a custom variables of the property/indexer.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IVariableInfo[] GetVariables()

Return Value

An array of IVariableInfo objects.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


InsertCodeBlockAfterStatement Method

IPropertyBaseInfo..::..InsertCodeBlockAfterStatement Method

Inserts a code block after the specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAfterStatement(
    string code,
    IStatementInfo statementInfoToInsertAfter
)

Parameters

code
Type: String

Code to be inserted.

statementInfoToInsertAfter
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


InsertCodeBlockAt Method

IPropertyBaseInfo..::..InsertCodeBlockAt Method

Inserts a code block.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAt(
    string code,
    IStatementInfo parentStatementInfo,
    IStatementInfo statementInfoToInsertBefore,
    IStatementInfo statementInfoToInsertAfter,
    bool insertAtStart,
    bool insertAtEnd
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

statementInfoToInsertBefore
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

statementInfoToInsertAfter
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

insertAtStart
Type: Boolean

True if insert at the start; False if otherwise.

insertAtEnd
Type: Boolean

True if insert at the end; False if otherwise.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


InsertCodeBlockAtEnd Method

IPropertyBaseInfo..::..InsertCodeBlockAtEnd Method

Inserts a code block at the end of specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAtEnd(
    string code,
    IStatementInfo parentStatementInfo
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


InsertCodeBlockAtStart Method

IPropertyBaseInfo..::..InsertCodeBlockAtStart Method

Inserts a code block at the start of specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockAtStart(
    string code,
    IStatementInfo parentStatementInfo
)

Parameters

code
Type: String

Code to be inserted.

parentStatementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


InsertCodeBlockBeforeStatement Method

IPropertyBaseInfo..::..InsertCodeBlockBeforeStatement Method

Inserts a code block before the specified statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertCodeBlockBeforeStatement(
    string code,
    IStatementInfo statementInfoToInsertBefore
)

Parameters

code
Type: String

Code to be inserted.

statementInfoToInsertBefore
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IStatementInfo

IStatementInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


IPropertyBaseInfo Properties

The IPropertyBaseInfo type exposes the following members.

Properties

 | Name | Description
Public property | CanGet | Returns true if the property/indexer has get-accessor.
Public property | CanSet | Returns true if property/indexer has set-accessor.
Public property | GetBlock | Gets a block object of the property/indexer get-accessor.
Public property | GetRegion | Gets a region of the property/indexer get-accessor.
Public property | SetBlock | Gets a block object of the property/indexer set-accessor.
Public property | SetRegion | Gets a region of the property/indexer set-accessor.

See Also

IPropertyBaseInfo Interface


CanGet Property

IPropertyBaseInfo..::..CanGet Property

Returns true if the property/indexer has get-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CanGet { get; }

Field Value

True if the property/indexer has get-accessor; False if otherwise.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


CanSet Property

IPropertyBaseInfo..::..CanSet Property

Returns true if property/indexer has set-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CanSet { get; }

Field Value

True if the property/indexer has set-accessor; False if otherwise.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


GetBlock Property

IPropertyBaseInfo..::..GetBlock Property

Gets a block object of the property/indexer get-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IBlockInfo GetBlock { get; }

Field Value

IBlockInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


GetRegion Property

IPropertyBaseInfo..::..GetRegion Property

Gets a region of the property/indexer get-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo GetRegion { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


SetBlock Property

IPropertyBaseInfo..::..SetBlock Property

Gets a block object of the property/indexer set-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IBlockInfo SetBlock { get; }

Field Value

IBlockInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


SetRegion Property

IPropertyBaseInfo..::..SetRegion Property

Gets a region of the property/indexer set-accessor.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IRegionInfo SetRegion { get; }

Field Value

IRegionInfo object.

Remarks

Examples

To be added.

See Also

IPropertyBaseInfo Interface


IPropertyInfo Interface

Stores a property information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IPropertyInfo : IPropertyBaseInfo

Examples

To be added.

See Also

IPropertyInfo Members


IPropertyInfo Members

The IPropertyInfo type exposes the following members.

Methods

 | Name | Description
Public method | ConvertToMethods | Converts the property to getter and/or setter methods

Properties

 | Name | Description
Public property | IsDefault | Return true if property is default.

See Also

IPropertyInfo Interface


IPropertyInfo Methods

The IPropertyInfo type exposes the following members.

Methods

 | Name | Description
Public method | ConvertToMethods | Converts the property to getter and/or setter methods

See Also

IPropertyInfo Interface


ConvertToMethods Method

IPropertyInfo..::..ConvertToMethods Method

Converts the property to getter and/or setter methods

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ConvertToMethods()

Remarks

Examples

To be added.

See Also

IPropertyInfo Interface


IPropertyInfo Properties

The IPropertyInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsDefault | Return true if property is default.

See Also

IPropertyInfo Interface


IsDefault Property

IPropertyInfo..::..IsDefault Property

Return true if property is default.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsDefault { get; }

Field Value

True if property is default; False if otherwise.

Remarks

Examples

To be added.

See Also

IPropertyInfo Interface


IRegionInfo Interface

Stores a region information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IRegionInfo : IComparable,
    ICloneable

Examples

To be added.

See Also

IRegionInfo Members


IRegionInfo Members

The IRegionInfo type exposes the following members.

Properties

 | Name | Description
Public property | EndColumn | Gets or sets an end column of the region.
Public property | EndLine | Gets or sets an end line of the region.
Public property | EndOffset | Gets or sets a character offset from the beginning of the document to end of the region.
Public property | StartColumn | Gets or sets a start column of the region.
Public property | StartLine | Gets or sets a start line of the region.
Public property | StartOffset | Gets or sets a character offset from the beginning of the document to start of the region.

See Also

IRegionInfo Interface


IRegionInfo Properties

The IRegionInfo type exposes the following members.

Properties

 | Name | Description
Public property | EndColumn | Gets or sets an end column of the region.
Public property | EndLine | Gets or sets an end line of the region.
Public property | EndOffset | Gets or sets a character offset from the beginning of the document to end of the region.
Public property | StartColumn | Gets or sets a start column of the region.
Public property | StartLine | Gets or sets a start line of the region.
Public property | StartOffset | Gets or sets a character offset from the beginning of the document to start of the region.

See Also

IRegionInfo Interface


EndColumn Property

IRegionInfo..::..EndColumn Property

Gets or sets an end column of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int EndColumn { get; set; }

Field Value

End column of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


EndLine Property

IRegionInfo..::..EndLine Property

Gets or sets an end line of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int EndLine { get; set; }

Field Value

End line of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


EndOffset Property

IRegionInfo..::..EndOffset Property

Gets or sets a character offset from the beginning of the document to end of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int EndOffset { get; set; }

Field Value

Character offset from the beginning of the document to end of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


StartColumn Property

IRegionInfo..::..StartColumn Property

Gets or sets a start column of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int StartColumn { get; set; }

Field Value

Start column of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


StartLine Property

IRegionInfo..::..StartLine Property

Gets or sets a start line of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int StartLine { get; set; }

Field Value

Start line of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


StartOffset Property

IRegionInfo..::..StartOffset Property

Gets or sets a character offset from the beginning of the document to start of the region.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int StartOffset { get; set; }

Field Value

Character offset from the beginning of the document to start of the region.

Remarks

Examples

To be added.

See Also

IRegionInfo Interface


IReturnTypeInfo Interface

Stores a return type information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IReturnTypeInfo : IComparable

Examples

To be added.

See Also

IReturnTypeInfo Members


IReturnTypeInfo Members

The IReturnTypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetArrayRank | Gets an array rank of the return type.
Public method | GetDisplayName | Gets a display name of the return type.
Public method | GetGenericArguments | Gets an array of the generic arguments.
Public method | GetType | Gets a type of the return type.
Public method | Rename | Replaces a name of the return type, with another specified name.

Properties

 | Name | Description
Public property | FullyQualifiedName | Gets a full name of the return type.
Public property | IsArray | Returns true if return type is array.
Public property | IsNullable | Returns true if return type is nullable.
Public property | IsPointer | Returns true if return type is pointer.
Public property | Name | Gets a name of the return type.
Public property | ProjectFile | Gets a project file of the return type.

See Also

IReturnTypeInfo Interface


IReturnTypeInfo Methods

The IReturnTypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetArrayRank | Gets an array rank of the return type.
Public method | GetDisplayName | Gets a display name of the return type.
Public method | GetGenericArguments | Gets an array of the generic arguments.
Public method | GetType | Gets a type of the return type.
Public method | Rename | Replaces a name of the return type, with another specified name.

See Also

IReturnTypeInfo Interface


GetArrayRank Method

IReturnTypeInfo..::..GetArrayRank Method

Gets an array rank of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int[] GetArrayRank()

Return Value

Array rank of the return type.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


GetDisplayName Method

IReturnTypeInfo..::..GetDisplayName Method

Gets a display name of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string GetDisplayName(
    ICodeElementInfo codeElementInfo
)

Parameters

codeElementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

ICodeElementInfo object.

Return Value

Display name of the return type.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


GetGenericArguments Method

IReturnTypeInfo..::..GetGenericArguments Method

Gets an array of the generic arguments.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IReturnTypeInfo[] GetGenericArguments()

Return Value

Array of the generic arguments.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


GetType Method

IReturnTypeInfo..::..GetType Method

Gets a type of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo GetType()

Return Value

ITypeInfo object.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


Rename Method

IReturnTypeInfo..::..Rename Method

Replaces a name of the return type, with another specified name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Rename(
    ICodeElementInfo codeElementInfo,
    string newName
)

Parameters

codeElementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

ICodeElementInfo object.

newName
Type: String

New code element name.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


IReturnTypeInfo Properties

The IReturnTypeInfo type exposes the following members.

Properties

 | Name | Description
Public property | FullyQualifiedName | Gets a full name of the return type.
Public property | IsArray | Returns true if return type is array.
Public property | IsNullable | Returns true if return type is nullable.
Public property | IsPointer | Returns true if return type is pointer.
Public property | Name | Gets a name of the return type.
Public property | ProjectFile | Gets a project file of the return type.

See Also

IReturnTypeInfo Interface


FullyQualifiedName Property

IReturnTypeInfo..::..FullyQualifiedName Property

Gets a full name of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string FullyQualifiedName { get; }

Field Value

Full name of the return type.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


IsArray Property

IReturnTypeInfo..::..IsArray Property

Returns true if return type is array.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsArray { get; }

Field Value

True if return type is array; False if otherwise.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


IsNullable Property

IReturnTypeInfo..::..IsNullable Property

Returns true if return type is nullable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsNullable { get; }

Field Value

True if return type is nullable; False if otherwise.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


IsPointer Property

IReturnTypeInfo..::..IsPointer Property

Returns true if return type is pointer.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPointer { get; }

Field Value

True if return type is pointer; False if otherwise.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


Name Property

IReturnTypeInfo..::..Name Property

Gets a name of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

Name of the return type.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


ProjectFile Property

IReturnTypeInfo..::..ProjectFile Property

Gets a project file of the return type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IReturnTypeInfo Interface


ISolutionInfo Interface

Stores a solution information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ISolutionInfo : IElementInfo

Examples

To be added.

See Also

ISolutionInfo Members


ISolutionInfo Members

The ISolutionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetProjects | Gets a projects of the solution.

Properties

 | Name | Description
Public property | Location | Gets a file name of the solution.
Public property | Name | Gets a solution name.

See Also

ISolutionInfo Interface


ISolutionInfo Methods

The ISolutionInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetProjects | Gets a projects of the solution.

See Also

ISolutionInfo Interface


GetProjects Method

ISolutionInfo..::..GetProjects Method

Gets a projects of the solution.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectInfo[] GetProjects()

Return Value

An array of IProjectInfo objects.

Remarks

Examples

To be added.

See Also

ISolutionInfo Interface


ISolutionInfo Properties

The ISolutionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Location | Gets a file name of the solution.
Public property | Name | Gets a solution name.

See Also

ISolutionInfo Interface


Location Property

ISolutionInfo..::..Location Property

Gets a file name of the solution.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Location { get; }

Field Value

File name of the solution.

Remarks

Examples

To be added.

See Also

ISolutionInfo Interface


Name Property

ISolutionInfo..::..Name Property

Gets a solution name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; }

Field Value

Solution name.

Remarks

Examples

To be added.

See Also

ISolutionInfo Interface


IStatementInfo Interface

Stores a statement information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IStatementInfo : IBlockInfo

Examples

To be added.

See Also

IStatementInfo Members


IStatementInfo Members

The IStatementInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Gets custom constants of the statement.
Public method | GetExpressions | Gets custom expressions of the statement.
Public method | GetIdentifiers | Gets custom identifiers of the statement.
Public method | GetVariables | Gets custom varibles of the statement.
Public method | ReplaceCodeBlock | Replaces the statement code with another specified code.

See Also

IStatementInfo Interface


IStatementInfo Methods

The IStatementInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetConstants | Gets custom constants of the statement.
Public method | GetExpressions | Gets custom expressions of the statement.
Public method | GetIdentifiers | Gets custom identifiers of the statement.
Public method | GetVariables | Gets custom varibles of the statement.
Public method | ReplaceCodeBlock | Replaces the statement code with another specified code.

See Also

IStatementInfo Interface


GetConstants Method

IStatementInfo..::..GetConstants Method

Gets custom constants of the statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ILocalConstantInfo[] GetConstants()

Return Value

An array of ILocalConstantInfo objects.

Remarks

Examples

To be added.

See Also

IStatementInfo Interface


GetExpressions Method

IStatementInfo..::..GetExpressions Method

Gets custom expressions of the statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IExpressionInfo[] GetExpressions()

Return Value

An array of IExpressionInfo objects.

Remarks

Examples

To be added.

See Also

IStatementInfo Interface


GetIdentifiers Method

IStatementInfo..::..GetIdentifiers Method

Gets custom identifiers of the statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IIdentifierInfo[] GetIdentifiers()

Return Value

An array of IIdentifierInfo objects.

Remarks

Examples

To be added.

See Also

IStatementInfo Interface


GetVariables Method

IStatementInfo..::..GetVariables Method

Gets custom varibles of the statement.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IVariableInfo[] GetVariables()

Return Value

An array of IVariableInfo objects.

Remarks

Examples

To be added.

See Also

IStatementInfo Interface


ReplaceCodeBlock Method

IStatementInfo..::..ReplaceCodeBlock Method

Replaces the statement code with another specified code.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ReplaceCodeBlock(
    string newCode
)

Parameters

newCode
Type: String

New code.

Remarks

Examples

See Also

IStatementInfo Interface


IStructInfo Interface

Stores a structure information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IStructInfo : ITypeInfo,
    ITypeMembersInfo

Examples

To be added.

See Also

IStructInfo Members


IStructInfo Members

The IStructInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerTypes | Gets inner types of the structure.

See Also

IStructInfo Interface


IStructInfo Methods

The IStructInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetInnerTypes | Gets inner types of the structure.

See Also

IStructInfo Interface


GetInnerTypes Method

IStructInfo..::..GetInnerTypes Method

Gets inner types of the structure.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetInnerTypes()

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

IStructInfo Interface


ITypeInfo Interface

Stores a type information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ITypeInfo : ICodeElementInfo

Examples

To be added.

See Also

ITypeInfo Members


ITypeInfo Members

The ITypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds an attribute to the type.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds an attribute to the type
Public method | GetAttributes | Gets custom attributes of the type.
Public method | GetBaseTypes | Gets base types of the type.
Public method | GetProjectFiles | Gets project files that contain the type.
Public method | IsAssignableFrom | Returns true if the type is assigned from the type with specified name.
Public method | IsImplementsInterface | Returns true if the type is implemented the interface with specified name.
Public method | Move | Moves the type to specified project file or/and namespace
Public method | SetModifier | Sets modifiers of the type.

Properties

 | Name | Description
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | ClassType | Gets a class type.
Public property | IsAbstract | Returns true if the type is abstact.
Public property | IsInternal | Returns true if the type is internal.
Public property | IsNestedType | Returns true if the type is nested type.
Public property | IsNew | Gets a value indicating whether the type hides another types.
Public property | IsPrivate | Returns true if the type is private.
Public property | IsProtected | Returns true if the type is protected.
Public property | IsPublic | Returns true if the type is public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsStatic | Returns true if the type is static.
Public property | Modifiers | Get modifiers of the type.
Public property | Namespace | Gets a namespace of the type.
Public property | Parent | Gets a parent of the type.
Public property | Project | Gets a project.

See Also

ITypeInfo Interface


ITypeInfo Methods

The ITypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds an attribute to the type.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds an attribute to the type
Public method | GetAttributes | Gets custom attributes of the type.
Public method | GetBaseTypes | Gets base types of the type.
Public method | GetProjectFiles | Gets project files that contain the type.
Public method | IsAssignableFrom | Returns true if the type is assigned from the type with specified name.
Public method | IsImplementsInterface | Returns true if the type is implemented the interface with specified name.
Public method | Move | Moves the type to specified project file or/and namespace
Public method | SetModifier | Sets modifiers of the type.

See Also

ITypeInfo Interface


AddAttribute Method

ITypeInfo..::..AddAttribute Method

Overload List

 | Name | Description
Public method | AddAttribute(String, array<String>[]()[][]) | Adds an attribute to the type.
Public method | AddAttribute(AttributeTargets, String, array<String>[]()[][]) | Adds an attribute to the type

See Also

ITypeInfo Interface
ITypeInfo Members


AddAttribute Method (String, String[])

ITypeInfo..::..AddAttribute Method (String, array<String>[]()[][])

Adds an attribute to the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAttribute(
    string attributeName,
    string[] arguments
)

Parameters

attributeName
Type: String

Attribute type name

arguments
Type: array< String >[]()[][]

Positional arguments.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface
AddAttribute Overload


AddAttribute Method (AttributeTargets, String, String[])

ITypeInfo..::..AddAttribute Method (AttributeTargets, String, array<String>[]()[][])

Adds an attribute to the type

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddAttribute(
    AttributeTargets targets,
    string attributeName,
    string[] arguments
)

Parameters

targets
Type: AttributeTargets

Attribute targets

attributeName
Type: String

Attribute type name

arguments
Type: array< String >[]()[][]

Positional arguments.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface
AddAttribute Overload


GetAttributes Method

ITypeInfo..::..GetAttributes Method

Gets custom attributes of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IAttributeSectionInfo[] GetAttributes()

Return Value

An array of IAttributeSectionInfo objects.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


GetBaseTypes Method

ITypeInfo..::..GetBaseTypes Method

Gets base types of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo[] GetBaseTypes()

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


GetProjectFiles Method

ITypeInfo..::..GetProjectFiles Method

Gets project files that contain the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo[] GetProjectFiles()

Return Value

An array of IProjectFileInfo objects.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsAssignableFrom Method

ITypeInfo..::..IsAssignableFrom Method

Returns true if the type is assigned from the type with specified name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsAssignableFrom(
    string fullTypeName
)

Parameters

fullTypeName
Type: String

Full type name

Return Value

True if the type is assigned from the type with specified name; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsImplementsInterface Method

ITypeInfo..::..IsImplementsInterface Method

Returns true if the type is implemented the interface with specified name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsImplementsInterface(
    string fullInterfaceName
)

Parameters

fullInterfaceName
Type: String

Full interface name

Return Value

True if the type is implemented the interface with specified name; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


Move Method

ITypeInfo..::..Move Method

Moves the type to specified project file or/and namespace

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void Move(
    string newFileName,
    string namespaceName
)

Parameters

newFileName
Type: String

New project file

namespaceName
Type: String

New namespace

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


SetModifier Method

ITypeInfo..::..SetModifier Method

Sets modifiers of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SetModifier(
    MemberInfoModifiers newModifier
)

Parameters

newModifier
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..MemberInfoModifiers

New modifiers of the type.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


ITypeInfo Properties

The ITypeInfo type exposes the following members.

Properties

 | Name | Description
Public property | CaseSensitive | Returns true if project default language is case sensitive.
Public property | ClassType | Gets a class type.
Public property | IsAbstract | Returns true if the type is abstact.
Public property | IsInternal | Returns true if the type is internal.
Public property | IsNestedType | Returns true if the type is nested type.
Public property | IsNew | Gets a value indicating whether the type hides another types.
Public property | IsPrivate | Returns true if the type is private.
Public property | IsProtected | Returns true if the type is protected.
Public property | IsPublic | Returns true if the type is public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsStatic | Returns true if the type is static.
Public property | Modifiers | Get modifiers of the type.
Public property | Namespace | Gets a namespace of the type.
Public property | Parent | Gets a parent of the type.
Public property | Project | Gets a project.

See Also

ITypeInfo Interface


CaseSensitive Property

ITypeInfo..::..CaseSensitive Property

Returns true if project default language is case sensitive.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CaseSensitive { get; }

Field Value

True if project default language is case sensitive; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


ClassType Property

ITypeInfo..::..ClassType Property

Gets a class type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ClassInfoType ClassType { get; }

Field Value

ClassInfoType object.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsAbstract Property

ITypeInfo..::..IsAbstract Property

Returns true if the type is abstact.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsAbstract { get; }

Field Value

True if the type is abstract; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsInternal Property

ITypeInfo..::..IsInternal Property

Returns true if the type is internal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsInternal { get; }

Field Value

True if the type is internal; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsNestedType Property

ITypeInfo..::..IsNestedType Property

Returns true if the type is nested type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsNestedType { get; }

Field Value

True if the type is nested type; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsNew Property

ITypeInfo..::..IsNew Property

Gets a value indicating whether the type hides another types.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsNew { get; }

Field Value

True if the type is new; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsPrivate Property

ITypeInfo..::..IsPrivate Property

Returns true if the type is private.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPrivate { get; }

Field Value

True if the type is private; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsProtected Property

ITypeInfo..::..IsProtected Property

Returns true if the type is protected.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsProtected { get; }

Field Value

True if the type is protected; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsPublic Property

ITypeInfo..::..IsPublic Property

Returns true if the type is public.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsPublic { get; }

Field Value

True if the type is public; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsSealed Property

ITypeInfo..::..IsSealed Property

Returns true if the type is sealed.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsSealed { get; }

Field Value

True if the type is sealed; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


IsStatic Property

ITypeInfo..::..IsStatic Property

Returns true if the type is static.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool IsStatic { get; }

Field Value

True if the type is static; False if otherwise.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


Modifiers Property

ITypeInfo..::..Modifiers Property

Get modifiers of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
MemberInfoModifiers Modifiers { get; }

Field Value

MemberInfoModifiers object.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


Namespace Property

ITypeInfo..::..Namespace Property

Gets a namespace of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
INamespaceInfo Namespace { get; }

Field Value

INamespaceInfo object.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


Parent Property

ITypeInfo..::..Parent Property

Gets a parent of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
ITypeInfo Parent { get; }

Field Value

ITypeInfo object.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


Project Property

ITypeInfo..::..Project Property

Gets a project.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectInfo Project { get; }

Field Value

IProjectInfo object.

Remarks

Examples

To be added.

See Also

ITypeInfo Interface


ITypeMembersInfo Interface

Stores a common information about class, interface and struct.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface ITypeMembersInfo : ITypeInfo

Examples

To be added.

See Also

ITypeMembersInfo Members


ITypeMembersInfo Members

The ITypeMembersInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddMember | Adds a member.
Public method | GetFields | Gets fields of the type.
Public method | GetMembers()()()() | Gets members of the type.
Public method | GetMembers(Boolean) | Gets members of the type.
Public method | GetMethods | Gets methods of the type.
Public method | ImplementInterface | Implement an interface.
Public method | InsertMember | Inserts a member into the type.
Public method | RemoveInterfaceImplementation | Removes an implementation of the interface.
Public method | SearchMember(String) | Searches for a member.
Public method | SearchMember(String, Boolean) | Searches for a member.

See Also

ITypeMembersInfo Interface


ITypeMembersInfo Methods

The ITypeMembersInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddMember | Adds a member.
Public method | GetFields | Gets fields of the type.
Public method | GetMembers()()()() | Gets members of the type.
Public method | GetMembers(Boolean) | Gets members of the type.
Public method | GetMethods | Gets methods of the type.
Public method | ImplementInterface | Implement an interface.
Public method | InsertMember | Inserts a member into the type.
Public method | RemoveInterfaceImplementation | Removes an implementation of the interface.
Public method | SearchMember(String) | Searches for a member.
Public method | SearchMember(String, Boolean) | Searches for a member.

See Also

ITypeMembersInfo Interface


AddMember Method

ITypeMembersInfo..::..AddMember Method

Adds a member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void AddMember(
    IProjectFileInfo projectFileInfo,
    string text
)

Parameters

projectFileInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IProjectFileInfo

Project file.

text
Type: String

Member code.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


GetFields Method

ITypeMembersInfo..::..GetFields Method

Gets fields of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] GetFields()

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


GetMembers Method

ITypeMembersInfo..::..GetMembers Method

Overload List

 | Name | Description
Public method | GetMembers()()()() | Gets members of the type.
Public method | GetMembers(Boolean) | Gets members of the type.

See Also

ITypeMembersInfo Interface
ITypeMembersInfo Members


GetMembers Method

ITypeMembersInfo..::..GetMembers Method

Gets members of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] GetMembers()

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface
GetMembers Overload


GetMembers Method (Boolean)

ITypeMembersInfo..::..GetMembers Method (Boolean)

Gets members of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] GetMembers(
    bool includeBaseTypeMembers
)

Parameters

includeBaseTypeMembers
Type: Boolean

True if include base type members; False if otherwise.

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface
GetMembers Overload


GetMethods Method

ITypeMembersInfo..::..GetMethods Method

Gets methods of the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] GetMethods()

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


ImplementInterface Method

ITypeMembersInfo..::..ImplementInterface Method

Implement an interface.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void ImplementInterface(
    string fullTypeName
)

Parameters

fullTypeName
Type: String

Full type name.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


InsertMember Method

ITypeMembersInfo..::..InsertMember Method

Inserts a member into the type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void InsertMember(
    IMemberInfo memberInfoToInsertBefore,
    IProjectFileInfo projectFileInfo,
    string text
)

Parameters

memberInfoToInsertBefore
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMemberInfo

Member to insert before.

projectFileInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IProjectFileInfo

Project file.

text
Type: String

Member code.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


RemoveInterfaceImplementation Method

ITypeMembersInfo..::..RemoveInterfaceImplementation Method

Removes an implementation of the interface.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void RemoveInterfaceImplementation(
    string fullTypeName
)

Parameters

fullTypeName
Type: String

Full type name.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface


SearchMember Method

ITypeMembersInfo..::..SearchMember Method

Overload List

 | Name | Description
Public method | SearchMember(String) | Searches for a member.
Public method | SearchMember(String, Boolean) | Searches for a member.

See Also

ITypeMembersInfo Interface
ITypeMembersInfo Members


SearchMember Method (String)

ITypeMembersInfo..::..SearchMember Method (String)

Searches for a member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] SearchMember(
    string memberName
)

Parameters

memberName
Type: String

Name of the member.

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface
SearchMember Overload


SearchMember Method (String, Boolean)

ITypeMembersInfo..::..SearchMember Method (String, Boolean)

Searches for a member.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IMemberInfo[] SearchMember(
    string memberName,
    bool includeBaseTypeMembers
)

Parameters

memberName
Type: String

Name of the member.

includeBaseTypeMembers
Type: Boolean

True if include base type members; False if otherwise.

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

ITypeMembersInfo Interface
SearchMember Overload


IVariableInfo Interface

Stores a variable information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IVariableInfo : ILocalVariableInfo

Examples

To be added.

See Also


IVisualStudioInfo Interface

Stores a Visual Studio information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IVisualStudioInfo : IElementInfo

Examples

To be added.

See Also

IVisualStudioInfo Members


IVisualStudioInfo Members

The IVisualStudioInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetWindowsFormsDesignerProperty | Gets a Visual Studio property.
Public method | SetWindowsFormsDesignerProperty | Sets a Visual Studio property.

See Also

IVisualStudioInfo Interface


IVisualStudioInfo Methods

The IVisualStudioInfo type exposes the following members.

Methods

 | Name | Description
Public method | GetWindowsFormsDesignerProperty | Gets a Visual Studio property.
Public method | SetWindowsFormsDesignerProperty | Sets a Visual Studio property.

See Also

IVisualStudioInfo Interface


GetWindowsFormsDesignerProperty Method

IVisualStudioInfo..::..GetWindowsFormsDesignerProperty Method

Gets a Visual Studio property.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Object GetWindowsFormsDesignerProperty(
    string page,
    string propertyName
)

Parameters

page
Type: String

Page name.

propertyName
Type: String

Property name.

Return Value

Property value.

Remarks

Examples

To be added.

See Also

IVisualStudioInfo Interface


SetWindowsFormsDesignerProperty Method

IVisualStudioInfo..::..SetWindowsFormsDesignerProperty Method

Sets a Visual Studio property.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SetWindowsFormsDesignerProperty(
    string page,
    string propertyName,
    Object value
)

Parameters

page
Type: String

Page name.

propertyName
Type: String

Property name.

value
Type: Object

Default property value.

Remarks

Examples

To be added.

See Also

IVisualStudioInfo Interface


IXamlTagAttributeInfo Interface

Stores an xaml tag information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IXamlTagAttributeInfo : IElementInfo,
    IComparable

Examples

To be added.

See Also

IXamlTagAttributeInfo Members


IXamlTagAttributeInfo Members

The IXamlTagAttributeInfo type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets name of the tag attribute.
Public property | Namespace | Gets namespace of the tag attribute.
Public property | Parent | Gets information of the parent tag.

See Also

IXamlTagAttributeInfo Interface


IXamlTagAttributeInfo Properties

The IXamlTagAttributeInfo type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets name of the tag attribute.
Public property | Namespace | Gets namespace of the tag attribute.
Public property | Parent | Gets information of the parent tag.

See Also

IXamlTagAttributeInfo Interface


Name Property

IXamlTagAttributeInfo..::..Name Property

Gets name of the tag attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; set; }

Field Value

Name of the tag attribute.

Remarks

Examples

To be added.

See Also

IXamlTagAttributeInfo Interface


Namespace Property

IXamlTagAttributeInfo..::..Namespace Property

Gets namespace of the tag attribute.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Namespace { get; set; }

Field Value

Namespace of the tag attribute.

Remarks

Examples

To be added.

See Also

IXamlTagAttributeInfo Interface


Parent Property

IXamlTagAttributeInfo..::..Parent Property

Gets information of the parent tag.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IXamlTagInfo Parent { get; }

Field Value

IXamlTagInfo object.

Remarks

Examples

To be added.

See Also

IXamlTagAttributeInfo Interface


IXamlTagInfo Interface

Stores an xaml tag information.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IXamlTagInfo : IElementInfo,
    IComparable

Examples

To be added.

See Also

IXamlTagInfo Members


IXamlTagInfo Members

The IXamlTagInfo type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets an index for this tag
Public property | Name | Gets name of the tag.
Public property | Namespace | Gets the tag's namespace.
Public property | ProjectFile | Gets project file information of the tag.

See Also

IXamlTagInfo Interface


IXamlTagInfo Properties

The IXamlTagInfo type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets an index for this tag
Public property | Name | Gets name of the tag.
Public property | Namespace | Gets the tag's namespace.
Public property | ProjectFile | Gets project file information of the tag.

See Also

IXamlTagInfo Interface


Index Property

IXamlTagInfo..::..Index Property

Gets an index for this tag

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int Index { get; }

Return Value

Index of the tag

Remarks

Examples

To be added.

See Also

IXamlTagInfo Interface


Name Property

IXamlTagInfo..::..Name Property

Gets name of the tag.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Name { get; set; }

Field Value

Name of the tag.

Remarks

Examples

To be added.

See Also

IXamlTagInfo Interface


Namespace Property

IXamlTagInfo..::..Namespace Property

Gets the tag's namespace.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Namespace { get; set; }

Field Value

Namespace of the tag.

Remarks

Examples

To be added.

See Also

IXamlTagInfo Interface


ProjectFile Property

IXamlTagInfo..::..ProjectFile Property

Gets project file information of the tag.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IProjectFileInfo ProjectFile { get; }

Field Value

IProjectFileInfo object.

Remarks

Examples

To be added.

See Also

IXamlTagInfo Interface


MemberInfoModifiers Enumeration

Specifies constants defining a member modifiers.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[FlagsAttribute]
public enum MemberInfoModifiers

Members

Member name | Description
None | Indicates that the member modifier is unknown.
New | Indicates that the member modifier is new.
Public | Indicates that the member modifier is public.
Protected | Indicates that the member modifier is protected.
Internal | Indicates that the member modifier is internal.
ProtectedInternal | Indicates that the member modifier is protected and internal.
Private | Indicates that the member modifier is private.
Abstract | Indicates that the member modifier is abstract.
Sealed | Indicates that the member modifier is sealed.
Static | Indicates that the member modifier is static.
Readonly | Indicates that the member modifier is read only.
Virtual | Indicates that the member modifier is virtual.
Override | Indicates that the member modifier is override.
Extern | Indicates that the member modifier is extern.
Unsafe | Indicates that the member modifier is unsafe.
SpecialName | Indicates that the member modifier is special name.
Literal | Indicates that the member modifier is literal.
Const | Indicates that the member modifier is const.
Volatile | Indicates that the member modifier is volatile.
Partial | Indicates that the member modifier is partial.
Writeonly | Indicates that the member modifier is write only.
NotOverridable | Indicates that the member modifier is NotOverridable.
WithEvents | Indicates that the member modifier is WithEvents.
Default | Indicates that the member modifier is Default.
Overloads | Indicates that the member modifier is Overloads.

Examples

See Also


OutputTypeInfo Enumeration

Specifies constants defining a project type.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public enum OutputTypeInfo

Members

Member name | Description
None | Indicates that the project type is unknown.
WindowsApplication | Indicates that the project type is Windows Application.
ConsoleApplication | Indicates that the project type is Console Application.
ClassLibrary | Indicates that the project type is Class Library.

Examples

See Also


ProjectInfoLanguage Enumeration

Specifies constants defining a project language.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[FlagsAttribute]
public enum ProjectInfoLanguage

Members

Member name | Description
None | Indicates that the project language is unknown.
CSharp | Indicates that the project language is C#.
VBNet | Indicates that the project language is VB.NET.
VC | Indicates that the project language is C++.

Examples

See Also


SubMain.CodeItRight.Sdk.Core.Rules Namespace

Classes

 | Class | Description
Public class | Note | Rule's note.

Interfaces

 | Interface | Description
Public interface | IRule | Base interface for Custom Rules API.

Enumerations

 | Enumeration | Description
Public enumeration | ActiveStatus | Rule active status.
Public enumeration | RuleScopes | The visibility of types or members to be checked by the rule.
Public enumeration | RuleTargets | Defines possible targets the rule applies to.
Public enumeration | SeverityLevel | Rule severity level.


ActiveStatus Enumeration

Rule active status.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public enum ActiveStatus

Members

Member name | Description
None | Indicates that status of rule is unknown.
Active | Indicates that the rule is active.
Excluded | Indicates that the rule is excluded.
Inactive | Indicates that the rule is inactive.

Remarks

See Also

SubMain.CodeItRight.Sdk.Core.Rules Namespace


IRule Interface

Base interface for Custom Rules API.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public interface IRule : IDisposable, ICloneable

Remarks

Examples

See Also

IRule Members
SubMain.CodeItRight.Sdk.Core.Rules Namespace


IRule Members

The IRule type exposes the following members.

Methods

 | Name | Description
Public method | Check | Method to be implemented by the author to check code elements for the rule violation.
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.
Public method | SubscribeToCorrectionOptionIndexChanged | Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

Properties

 | Name | Description
Public property | Author | Rule author information
Public property | AutoCorrectionOptions | String description of one or many ways to auto-correct the reported violation.
Public property | AvailableTargets | Types of code elements to which the rule can be applied
Public property | CanCorrect | Defines whether the Rule implements at least one auto-correct method
Public property | Category | Rule category
Public property | CorrectDescription | Describes options of correcting the violation
Public property | Element | Code element where the violaiton was found
Public property | Email | Rule author email address
Public property | ExclusionNote | Rule exclusion note
Public property | File | File name where the violation was found
Public property | ID | Rule Id
Public property | ItemFullyQualifiedName | Fully qualified name of code element where the violation was found
Public property | ItemName | Name of code element where the violation was found
Public property | ItemType | Type of the code element where the violation was found
Public property | Languages | Supported programming languages or markups
Public property | LineNumber | Line number in the file where the violation was found
Public property | Name | Rule Instance unique name
Public property | Project | Project name where the violation was found
Public property | Scopes | The scope of type or member to trigger the rule validation
Public property | SelectedCorrectionIndex | Selected index for AutoCorrectionOptions
Public property | Severity | How critical is the violation
Public property | Status | Rule activity status
Public property | Targets | Subset of AvailableTargets selected by user
Public property | Title | Long Rule Instance description
Public property | Url | Link to page with additional information
Public property | ViolationDescription | Description of the found violation

Events

 | Name | Description
Public event | DefaultCorrectionOptionIndexChanged | Occurs when the correction option changes.

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


IRule Methods

The IRule type exposes the following members.

Methods

 | Name | Description
Public method | Check | Method to be implemented by the author to check code elements for the rule violation.
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.
Public method | SubscribeToCorrectionOptionIndexChanged | Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Check Method

IRule..::..Check Method

Method to be implemented by the author to check code elements for the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool Check(
    IElementInfo element
)

Parameters

element
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Code element

Return Value

True if violation was found; else False

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Correct Method

IRule..::..Correct Method

Overload List

 | Name | Description
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.

See Also

IRule Interface
IRule Members
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Correct Method

IRule..::..Correct Method

Method to be implemented by the author that corrects the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool Correct()

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

IRule Interface
Correct Overload
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Correct Method (Int32)

IRule..::..Correct Method (Int32)

Method to be implemented by the author that corrects the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool Correct(
    int correctionOptionIndex
)

Parameters

correctionOptionIndex
Type: Int32

Index for AutoCorrectionOptions

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

IRule Interface
Correct Overload
SubMain.CodeItRight.Sdk.Core.Rules Namespace


SubscribeToCorrectionOptionIndexChanged Method

IRule..::..SubscribeToCorrectionOptionIndexChanged Method

Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
void SubscribeToCorrectionOptionIndexChanged()

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


IRule Properties

The IRule type exposes the following members.

Properties

 | Name | Description
Public property | Author | Rule author information
Public property | AutoCorrectionOptions | String description of one or many ways to auto-correct the reported violation.
Public property | AvailableTargets | Types of code elements to which the rule can be applied
Public property | CanCorrect | Defines whether the Rule implements at least one auto-correct method
Public property | Category | Rule category
Public property | CorrectDescription | Describes options of correcting the violation
Public property | Element | Code element where the violaiton was found
Public property | Email | Rule author email address
Public property | ExclusionNote | Rule exclusion note
Public property | File | File name where the violation was found
Public property | ID | Rule Id
Public property | ItemFullyQualifiedName | Fully qualified name of code element where the violation was found
Public property | ItemName | Name of code element where the violation was found
Public property | ItemType | Type of the code element where the violation was found
Public property | Languages | Supported programming languages or markups
Public property | LineNumber | Line number in the file where the violation was found
Public property | Name | Rule Instance unique name
Public property | Project | Project name where the violation was found
Public property | Scopes | The scope of type or member to trigger the rule validation
Public property | SelectedCorrectionIndex | Selected index for AutoCorrectionOptions
Public property | Severity | How critical is the violation
Public property | Status | Rule activity status
Public property | Targets | Subset of AvailableTargets selected by user
Public property | Title | Long Rule Instance description
Public property | Url | Link to page with additional information
Public property | ViolationDescription | Description of the found violation

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Author Property

IRule..::..Author Property

Rule author information

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Author { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


AutoCorrectionOptions Property

IRule..::..AutoCorrectionOptions Property

String description of one or many ways to auto-correct the reported violation.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string[] AutoCorrectionOptions { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


AvailableTargets Property

IRule..::..AvailableTargets Property

Types of code elements to which the rule can be applied

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
RuleTargets AvailableTargets { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


CanCorrect Property

IRule..::..CanCorrect Property

Defines whether the Rule implements at least one auto-correct method

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
bool CanCorrect { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Category Property

IRule..::..Category Property

Rule category

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Category { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


CorrectDescription Property

IRule..::..CorrectDescription Property

Describes options of correcting the violation

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string CorrectDescription { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Element Property

IRule..::..Element Property

Code element where the violaiton was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
IElementInfo Element { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Email Property

IRule..::..Email Property

Rule author email address

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Email { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ExclusionNote Property

IRule..::..ExclusionNote Property

Rule exclusion note

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
Note ExclusionNote { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


File Property

IRule..::..File Property

File name where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string File { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ID Property

IRule..::..ID Property

Rule Id

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string ID { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ItemFullyQualifiedName Property

IRule..::..ItemFullyQualifiedName Property

Fully qualified name of code element where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string ItemFullyQualifiedName { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ItemName Property

IRule..::..ItemName Property

Name of code element where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string ItemName { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ItemType Property

IRule..::..ItemType Property

Type of the code element where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string ItemType { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Languages Property

IRule..::..Languages Property

Supported programming languages or markups

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
Languages Languages { get; set; }

Remarks

See Languages enumeration for the value option descriptions.

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


LineNumber Property

IRule..::..LineNumber Property

Line number in the file where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string LineNumber { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Name Property

IRule..::..Name Property

Rule Instance unique name

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
string Name { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Project Property

IRule..::..Project Property

Project name where the violation was found

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Project { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Scopes Property

IRule..::..Scopes Property

The scope of type or member to trigger the rule validation

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
RuleScopes Scopes { get; set; }

Remarks

See RuleScopes enumeration for the value option descriptions.

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


SelectedCorrectionIndex Property

IRule..::..SelectedCorrectionIndex Property

Selected index for AutoCorrectionOptions

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
int SelectedCorrectionIndex { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Severity Property

IRule..::..Severity Property

How critical is the violation

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
SeverityLevel Severity { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Status Property

IRule..::..Status Property

Rule activity status

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
ActiveStatus Status { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Targets Property

IRule..::..Targets Property

Subset of AvailableTargets selected by user

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
RuleTargets Targets { get; set; }

Remarks

See RuleTargets enumeration for the value option descriptions.

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Title Property

IRule..::..Title Property

Long Rule Instance description

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
string Title { get; set; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Url Property

IRule..::..Url Property

Link to page with additional information

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string Url { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ViolationDescription Property

IRule..::..ViolationDescription Property

Description of the found violation

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
string ViolationDescription { get; }

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


IRule Events

The IRule type exposes the following members.

Events

 | Name | Description
Public event | DefaultCorrectionOptionIndexChanged | Occurs when the correction option changes.

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


DefaultCorrectionOptionIndexChanged Event

IRule..::..DefaultCorrectionOptionIndexChanged Event

Occurs when the correction option changes.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
event EventHandler DefaultCorrectionOptionIndexChanged

Remarks

Examples

See Also

IRule Interface
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Note Class

Rule's note.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[SerializableAttribute]
public class Note

Remarks

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Core.Rules..::..Note

See Also

Note Members
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Note Members

The Note type exposes the following members.

Properties

 | Name | Description
Public property | Date | Date of the note
Public property | Text | Text of the note
Public property | User | User who added the note

See Also

Note Class
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Note Properties

The Note type exposes the following members.

Properties

 | Name | Description
Public property | Date | Date of the note
Public property | Text | Text of the note
Public property | User | User who added the note

See Also

Note Class
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Date Property

Note..::..Date Property

Date of the note

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public DateTime Date { get; }

See Also

Note Class
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Text Property

Note..::..Text Property

Text of the note

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public string Text { get; }

See Also

Note Class
SubMain.CodeItRight.Sdk.Core.Rules Namespace


User Property

Note..::..User Property

User who added the note

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public string User { get; }

See Also

Note Class
SubMain.CodeItRight.Sdk.Core.Rules Namespace


RuleScopes Enumeration

The visibility of types or members to be checked by the rule.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[FlagsAttribute]
public enum RuleScopes

Members

Member name | Description
None | Indicates unknown scope.
New | Indicates that only classes and class members declared with 'new' modifier will be checked by the rule.
Public | Indicates that only public classes and class members will be checked by the rule. Public access is the most permissive access level. There are no restrictions on accessing public members.
Protected | Indicates that only protected classes and class members will be checked by the rule. A protected member is accessible from within the class in which it is declared, and from within any class derived from the class that declared this member.
Internal | Indicates that only internal classes and class members will be checked by the rule. Internal types or members are accessible only within files in the same assembly.
ProtectedInternal | Indicates that only internal and protected classes and class members will be checked by the rule.
Private | Indicates that only private classes and class members will be checked by the rule. Private members are accessible only within the body of the class or the struct in which they are declared.
Abstract | Indicates that only abstract classes and class members will be checked by the rule. Abstract classes and class members that are incomplete and must be implemented in a derived class.
Sealed | Indicates that only sealed classes will be checked by the rule. A sealed class cannot be used as a base class. For this reason, it cannot also be an abstract class. Sealed classes prevent derivation.
Static | Indicates that only static classes and class members will be checked by the rule. A static class is basically the same as a non-static class, but a static class cannot be instantiated. Because there is no instance variable, the members of a static class can be accessed by using the class name itself.
Readonly | Indicates that read-only fields and properties will be checked by the rule. A read-only field or property can be read but not written.
Virtual | Indicates that only virtual method, property, indexer, or event will be checked by the rule. A virtual method, property, indexer, or event declaration are allowed to be overridden in a derived class.
Override | Indicates that only overriden method, property, indexer, or event will be checked by the rule. Overriden members are extend or modify the abstract or virtual implementation of an inherited method, property, indexer, or event.
Extern | Indicates that only external method declarations will be checked by the rule. An external method is a method that is implemented externally (usually in unmanaged DLL library).
Unsafe | Indicates that only unsafe blocks will be checked by the rule. Unsafe blocks denote an unsafe context, which is required for any operation involving pointers.
Literal | Indicates that only literals will be checked by the rule. A literals is a string, a number, or a date which directly represents a constant value. Literals have types , but they do not have names and they cannot be modified.
Const | Indicates that only constants will be checked by the rule. A constant is a field or local variable, which cannot be modified.
Volatile | Indicates that only volatile fields will be checked by the rule. A volatile field might be modified by multiple threads that are executing at the same time.
WriteOnly | Indicates that write-only properties will be checked by the rule. A write-only property can be written but not read.
WithEvents | Indicates that only WithEvents variables will be checked by the rule (Visual Basic). WithEvents keyword specifies that one or more declared member variables refer to an instance of a class that can raise events.
Any | Indicates any scope from listed above. It's a maximum visibility.

Remarks

See Also

SubMain.CodeItRight.Sdk.Core.Rules Namespace


RuleTargets Enumeration

Defines possible targets the rule applies to.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[FlagsAttribute]
public enum RuleTargets

Members

Member name | Description
None | Indicates unknown target.
VS | Indicates Visual Studio IDE as target. The Visual Studio IDE (Integrated Development Environment) is a set of tools that helps to write and modify the code for programs, and also detect and correct errors in programs.
Solution | Indicates solution as target. A solution is a conceptual container implemented in Visual Studio. Solutions manage the way Visual Studio configures, builds, and deploys sets of related projects. A Visual Studio solution can include just one project or several projects built jointly by a development team. A complex application might require multiple solutions.
Project | Indicates project as target. A project is a conceptual container implemented in Visual Studio. A project includes a set of source files, plus related metadata such as component references and build instructions. Projects generally produce one or more output files when built.
File | Indicates file as target. Files are items that compose a project, such as forms, source files, and classes within a project.
Namespace | Indicates namespace as target. A namespace is a logical naming scheme for grouping related types. The .NET Framework uses a hierarchical naming scheme for grouping types into logical categories of related functionality, such as the ASP.NET technology or remoting functionality.
Class | Indicates class as target. A class is a construct that enables you to create your own custom types by grouping together variables of other types, methods and events. A class is like a blueprint. It defines the data and behavior of a type. If the class is not declared as static, client code can use it by creating objects or instances which are assigned to a variable.
Interface | Indicates interface as target. An interface is a reference type that defines a contract. Other types implement an interface to guarantee that they support certain operations. The interface specifies the members that must be supplied by classes or other interfaces that implement it. Like classes, interfaces can contain methods, properties, indexers, and events as members.
Delegate | Indicates delegate as target. A delegate is a class that can hold a reference to a method. Unlike other classes, a delegate class has a signature, and it can hold references only to methods that match its signature. A delegate is thus equivalent to a type-safe function pointer or a callback.
Struct | Indicates struct as target. A struct is a user-defined value type. Like a class, structures can contain constructors, constants, fields, methods, properties, indexers, operators, and nested types. Unlike classes, however, structures do not support inheritance.
Enumeration | Indicates enum as target. An enumeration type (also named an enumeration or an enum) provides an efficient way to define a set of named integral constants that may be assigned to a variable.
Module | Indicates module as target. A module (Visual Basic .NET) is similar to a class but with some important distinctions. Every module has exactly one instance and does not need to be created or assigned to a variable. Modules do not support inheritance or implement interfaces. Notice that a module is not a type in the sense that a class or structure is - you cannot declare a programming element to have the data type of a module.
Type | Indicates type as target. Type in this enumeration is one of the following: Class, Interface, Struct, Delegate, Enumeration, Module
Variable | Indicates variable as target. A variable is an item of data named by an identifier. Each variable has a data type (which determines the kind of data that the variable can store), such as int or string, and a scope.
LocalConstant | Indicates local contant as target. Constants are fields or properties whose value is set at compile time and cannot be changed. The scope of a local constant is the block in which the declaration occurs.
Method | Indicates method as target. Methods define the actions that a class can perform. Methods can take parameters that provide input data, and can return output data through parameters. Methods can also return a value directly, without using a parameter.
Operator | Indicates operator as target. An operator is a term or a symbol that takes one or more expressions, called operands, as input and returns a value. Operators in an expression are evaluated in a specific order known as operator precedence.
Event | Indicates event as target. Events provide notifications about occurrences, such as button clicks or the successful completion of a method, to other objects. Events are defined and triggered by using delegates.
Property | Indicates property as target. Properties are methods on a class that are accessed as if they were fields on that class. A property can provide protection for a class field to keep it from being changed without the knowledge of the object.
Indexer | Indicates indexer as target. Indexers enable an object to be indexed in a manner similar to arrays.
EnumerationItem | Indicates enum member as target. An enum member is a named integral constant defined in the enumeration type.
Parameter | Indicates parameter as target. A parameter of a method (formal parameter) is a container which is used to transfer information to or from methods. There are four kinds of formal parameters: value parameters, reference parameters, output parameters and parameter arrays.
Constant | Indicates constant as target. Constants are fields or properties whose value is set at compile time and cannot be changed.
Field | Indicates field as target. Fields are variables declared at class scope. A field may be a built-in numeric type or an instance of another class. For example, a calendar class may have a field that contains the current date.
Expression | Indicates expression as target. An expression is a sequence of operators and operands.
CodeRegion | Indicates code region as target. A code region is a single statement or a list of statements.
Comment | Indicates comment as target. A comment is an information embedded in the source code of a computer program. Compiler ignores comments during source file processing.
XmlComment | Indicates XML comment as target. XML comment is an information embedded in the source code of a computer program. Compiler ignores comments during source file processing.
Statement | Indicates statement as target. Statement is a sequence of expressions.
Member | Indicates member as target. Member in this enumeration is one of the following: Constant, Field, Event, Property, Indexer, Method, Operator or EnumerationItem
Line | Indicates line as target.

Remarks

See Also

SubMain.CodeItRight.Sdk.Core.Rules Namespace


SeverityLevel Enumeration

Rule severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public enum SeverityLevel

Members

Member name | Description
None | Indicates that severity level is unknown.
Information | Indicates information severity level.
Warning | Indicates warning severity level.
CriticalWarning | Indicates critical warning severity level.
Error | Indicates error severity level.
CriticalError | Indicates critical error severity level.

Remarks

See Also

SubMain.CodeItRight.Sdk.Core.Rules Namespace


SubMain.CodeItRight.Sdk.Rules Namespace

Classes

 | Class | Description
Public class | AbstractRuleBase | Provides the abstract (MustInherit in Visual Basic) base class that implements IRule interface.
Public class | NamingRuleBase | Provides the abstract (MustInherit in Visual Basic) base class for naming rules.
Public class | RuleBase | Provides the abstract (MustInherit in Visual Basic) base class that inherited from AbstractRuleBase class.
Public class | SpellingRuleBase | Provides the abstract (MustInherit in Visual Basic) base class for naming rules.
Public class | SubMainRuleBase | Provides the abstract (MustInherit in Visual Basic) base class for the rules.


AbstractRuleBase Class

Provides the abstract (MustInherit in Visual Basic) base class that implements IRule interface.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[SerializableAttribute]
public abstract class AbstractRuleBase : IRule

Remarks

Examples

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Rules..::..AbstractRuleBase

See Also

AbstractRuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


AbstractRuleBase Members

The AbstractRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Check | Abstract method to be implemented by the author to check code elements for the rule violation.
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.
Public method | DefaultCorrectionOptionIndex_Changed | The virtual default event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose | Releases all resources used by this rule instance.
Public method | SubscribeToCorrectionOptionIndexChanged | Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

Properties

 | Name | Description
Public property | Author | Gets the Author of the rule instance.
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | AvailableTargets | Gets all available targets for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Category | Gets the Category of the rule instance.
Public property | CorrectDescription | Gets the correction description.
Public property | Element | Gets the Element of the rule instance.
Public property | Email | Gets the Email of the rule instance.
Public property | ExclusionNote | Gets the exclusion note of the rule instance.
Public property | File | Gets the File of the rule instance.
Public property | ID | Gets the ID of the rule instance.
Public property | ItemFullyQualifiedName | Gets the full qualified name of the code element.
Public property | ItemName | Gets the name of the code element.
Public property | ItemType | Gets the type of the code element.
Public property | LineNumber | Gets the line number of the code element.
Public property | Name | Gets the Name of the rule instance.
Public property | Project | Gets the Project of the rule instance.
Public property | Scopes | Gets Scopes of the rule instance.
Public property | SelectedCorrectionIndex | Gets selected correction index.
Public property | Severity | Gets the Severity of the rule instance.
Public property | Status | Gets the status of the rule instance.
Public property | Targets | Gets Targets of the rule instance.
Public property | Title | Gets the Title of the rule instance.
Public property | Url | Gets the Url of the rule instance.
Public property | ViolationDescription | Gets the description of the violation.

Events

 | Name | Description
Public event | DefaultCorrectionOptionIndexChanged | Occurs when the correction option changes.

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AbstractRuleBase Methods

The AbstractRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Check | Abstract method to be implemented by the author to check code elements for the rule violation.
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.
Public method | DefaultCorrectionOptionIndex_Changed | The virtual default event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose | Releases all resources used by this rule instance.
Public method | SubscribeToCorrectionOptionIndexChanged | Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Check Method

AbstractRuleBase..::..Check Method

Abstract method to be implemented by the author to check code elements for the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool Check(
    IElementInfo element
)

Parameters

element
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Code element

Return Value

True if violation was found; else False

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Correct Method

AbstractRuleBase..::..Correct Method

Overload List

 | Name | Description
Public method | Correct()()()() | Method to be implemented by the author that corrects the rule violation.
Public method | Correct(Int32) | Method to be implemented by the author that corrects the rule violation.

See Also

AbstractRuleBase Class
AbstractRuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


Correct Method

AbstractRuleBase..::..Correct Method

Method to be implemented by the author that corrects the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool Correct()

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

AbstractRuleBase Class
Correct Overload
SubMain.CodeItRight.Sdk.Rules Namespace


Correct Method (Int32)

AbstractRuleBase..::..Correct Method (Int32)

Method to be implemented by the author that corrects the rule violation.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual bool Correct(
    int correctionOptionIndex
)

Parameters

correctionOptionIndex
Type: Int32

Index for AutoCorrectionOptions

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

AbstractRuleBase Class
Correct Overload
SubMain.CodeItRight.Sdk.Rules Namespace


DefaultCorrectionOptionIndex_Changed Method

AbstractRuleBase..::..DefaultCorrectionOptionIndex_Changed Method

The virtual default event handler for DefaultCorrectionOptionIndex event.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual void DefaultCorrectionOptionIndex_Changed(
    Object sender,
    EventArgs agrs
)

Parameters

sender
Type: Object

Sender of the event

agrs
Type: EventArgs

event argument

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Dispose Method

AbstractRuleBase..::..Dispose Method

Releases all resources used by this rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void Dispose()

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SubscribeToCorrectionOptionIndexChanged Method

AbstractRuleBase..::..SubscribeToCorrectionOptionIndexChanged Method

Subscribes the rule instance on DefaultCorrectionOptionIndexChanged event.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void SubscribeToCorrectionOptionIndexChanged()

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AbstractRuleBase Properties

The AbstractRuleBase type exposes the following members.

Properties

 | Name | Description
Public property | Author | Gets the Author of the rule instance.
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | AvailableTargets | Gets all available targets for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Category | Gets the Category of the rule instance.
Public property | CorrectDescription | Gets the correction description.
Public property | Element | Gets the Element of the rule instance.
Public property | Email | Gets the Email of the rule instance.
Public property | ExclusionNote | Gets the exclusion note of the rule instance.
Public property | File | Gets the File of the rule instance.
Public property | ID | Gets the ID of the rule instance.
Public property | ItemFullyQualifiedName | Gets the full qualified name of the code element.
Public property | ItemName | Gets the name of the code element.
Public property | ItemType | Gets the type of the code element.
Public property | LineNumber | Gets the line number of the code element.
Public property | Name | Gets the Name of the rule instance.
Public property | Project | Gets the Project of the rule instance.
Public property | Scopes | Gets Scopes of the rule instance.
Public property | SelectedCorrectionIndex | Gets selected correction index.
Public property | Severity | Gets the Severity of the rule instance.
Public property | Status | Gets the status of the rule instance.
Public property | Targets | Gets Targets of the rule instance.
Public property | Title | Gets the Title of the rule instance.
Public property | Url | Gets the Url of the rule instance.
Public property | ViolationDescription | Gets the description of the violation.

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Author Property

AbstractRuleBase..::..Author Property

Gets the Author of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string Author { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AutoCorrectionOptions Property

AbstractRuleBase..::..AutoCorrectionOptions Property

Gets all correction options for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string[] AutoCorrectionOptions { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AvailableTargets Property

AbstractRuleBase..::..AvailableTargets Property

Gets all available targets for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public RuleTargets AvailableTargets { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


CanCorrect Property

AbstractRuleBase..::..CanCorrect Property

Gets True if the rule instance support correction; else False.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool CanCorrect { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Category Property

AbstractRuleBase..::..Category Property

Gets the Category of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string Category { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


CorrectDescription Property

AbstractRuleBase..::..CorrectDescription Property

Gets the correction description.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string CorrectDescription { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Element Property

AbstractRuleBase..::..Element Property

Gets the Element of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public IElementInfo Element { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Email Property

AbstractRuleBase..::..Email Property

Gets the Email of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string Email { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ExclusionNote Property

AbstractRuleBase..::..ExclusionNote Property

Gets the exclusion note of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public Note ExclusionNote { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


File Property

AbstractRuleBase..::..File Property

Gets the File of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string File { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ID Property

AbstractRuleBase..::..ID Property

Gets the ID of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string ID { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ItemFullyQualifiedName Property

AbstractRuleBase..::..ItemFullyQualifiedName Property

Gets the full qualified name of the code element.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string ItemFullyQualifiedName { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ItemName Property

AbstractRuleBase..::..ItemName Property

Gets the name of the code element.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string ItemName { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ItemType Property

AbstractRuleBase..::..ItemType Property

Gets the type of the code element.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string ItemType { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


LineNumber Property

AbstractRuleBase..::..LineNumber Property

Gets the line number of the code element.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[BrowsableAttribute]
public string LineNumber { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Name Property

AbstractRuleBase..::..Name Property

Gets the Name of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public virtual string Name { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Project Property

AbstractRuleBase..::..Project Property

Gets the Project of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string Project { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Scopes Property

AbstractRuleBase..::..Scopes Property

Gets Scopes of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public virtual RuleScopes Scopes { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SelectedCorrectionIndex Property

AbstractRuleBase..::..SelectedCorrectionIndex Property

Gets selected correction index.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public int SelectedCorrectionIndex { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Severity Property

AbstractRuleBase..::..Severity Property

Gets the Severity of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public virtual SeverityLevel Severity { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Status Property

AbstractRuleBase..::..Status Property

Gets the status of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public ActiveStatus Status { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Targets Property

AbstractRuleBase..::..Targets Property

Gets Targets of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public RuleTargets Targets { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Title Property

AbstractRuleBase..::..Title Property

Gets the Title of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
public virtual string Title { get; set; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Url Property

AbstractRuleBase..::..Url Property

Gets the Url of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string Url { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ViolationDescription Property

AbstractRuleBase..::..ViolationDescription Property

Gets the description of the violation.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public virtual string ViolationDescription { get; }

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AbstractRuleBase Events

The AbstractRuleBase type exposes the following members.

Events

 | Name | Description
Public event | DefaultCorrectionOptionIndexChanged | Occurs when the correction option changes.

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


DefaultCorrectionOptionIndexChanged Event

AbstractRuleBase..::..DefaultCorrectionOptionIndexChanged Event

Occurs when the correction option changes.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[NonSerializedAttribute]
public event EventHandler DefaultCorrectionOptionIndexChanged

Remarks

Examples

See Also

AbstractRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


NamingRuleBase Class

Provides the abstract (MustInherit in Visual Basic) base class for naming rules.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[SerializableAttribute]
public abstract class NamingRuleBase : AbstractRuleBase

Remarks

Examples

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Rules..::..AbstractRuleBase
SubMain.CodeItRight.Sdk.Rules..::..NamingRuleBase

See Also

NamingRuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


NamingRuleBase Members

The NamingRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Correct | Method corrects the violations for the rule instance.
Public method | DefaultCorrectionOptionIndex_Changed | The event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose()()()() | Releases all resources used by this rule instance.

Properties

 | Name | Description
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | ExcludeList | Gets exclude list of words for the rule.
Public property | Targets | Gets Targets of the rule instance.

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


NamingRuleBase Methods

The NamingRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Correct | Method corrects the violations for the rule instance.
Public method | DefaultCorrectionOptionIndex_Changed | The event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose()()()() | Releases all resources used by this rule instance.

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Correct Method

NamingRuleBase..::..Correct Method

Method corrects the violations for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool Correct(
    int correctionOptionIndex
)

Parameters

correctionOptionIndex
Type: Int32

Index for AutoCorrectionOptions

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


DefaultCorrectionOptionIndex_Changed Method

NamingRuleBase..::..DefaultCorrectionOptionIndex_Changed Method

The event handler for DefaultCorrectionOptionIndex event.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void DefaultCorrectionOptionIndex_Changed(
    Object sender,
    EventArgs agrs
)

Parameters

sender
Type: Object

Sender of the event

agrs
Type: EventArgs

event argument

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Dispose Method

NamingRuleBase..::..Dispose Method

Releases all resources used by this rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void Dispose()

Remarks

Examples

See Also

NamingRuleBase Class
Dispose Overload
SubMain.CodeItRight.Sdk.Rules Namespace


NamingRuleBase Properties

The NamingRuleBase type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | ExcludeList | Gets exclude list of words for the rule.
Public property | Targets | Gets Targets of the rule instance.

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AutoCorrectionOptions Property

NamingRuleBase..::..AutoCorrectionOptions Property

Gets all correction options for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string[] AutoCorrectionOptions { get; }

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


CanCorrect Property

NamingRuleBase..::..CanCorrect Property

Gets True if the rule instance support correction; else False.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool CanCorrect { get; set; }

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


ExcludeList Property

NamingRuleBase..::..ExcludeList Property

Gets exclude list of words for the rule.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[ConfigurablePropertyAttribute]
[DescriptionAttribute]
public string ExcludeList { get; set; }

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Targets Property

NamingRuleBase..::..Targets Property

Gets Targets of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public RuleTargets Targets { get; set; }

Remarks

Examples

See Also

NamingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


RuleBase Class

Provides the abstract (MustInherit in Visual Basic) base class that inherited from AbstractRuleBase class.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[SerializableAttribute]
public abstract class RuleBase : AbstractRuleBase

Remarks

Examples

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Rules..::..AbstractRuleBase
SubMain.CodeItRight.Sdk.Rules..::..RuleBase

See Also

RuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


RuleBase Members

The RuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by this rule instance.

Properties

 | Name | Description
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Targets | Gets Targets of the rule instance.

See Also

RuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


RuleBase Methods

The RuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by this rule instance.

See Also

RuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Dispose Method

RuleBase..::..Dispose Method

Releases all resources used by this rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void Dispose()

Remarks

Examples

See Also

RuleBase Class
Dispose Overload
SubMain.CodeItRight.Sdk.Rules Namespace


RuleBase Properties

The RuleBase type exposes the following members.

Properties

 | Name | Description
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Targets | Gets Targets of the rule instance.

See Also

RuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


CanCorrect Property

RuleBase..::..CanCorrect Property

Gets True if the rule instance support correction; else False.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool CanCorrect { get; set; }

Remarks

Examples

See Also

RuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Targets Property

RuleBase..::..Targets Property

Gets Targets of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public RuleTargets Targets { get; set; }

Remarks

Examples

See Also

RuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SpellingRuleBase Class

Provides the abstract (MustInherit in Visual Basic) base class for naming rules.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[SerializableAttribute]
public abstract class SpellingRuleBase : AbstractRuleBase

Remarks

Examples

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Rules..::..AbstractRuleBase
SubMain.CodeItRight.Sdk.Rules..::..SpellingRuleBase

See Also

SpellingRuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


SpellingRuleBase Members

The SpellingRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Correct | Method corrects the violations for the rule instance.
Public method | DefaultCorrectionOptionIndex_Changed | The event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose()()()() | Releases all resources used by this rule instance.

Properties

 | Name | Description
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Targets | Gets Targets of the rule instance.

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SpellingRuleBase Methods

The SpellingRuleBase type exposes the following members.

Methods

 | Name | Description
Public method | Correct | Method corrects the violations for the rule instance.
Public method | DefaultCorrectionOptionIndex_Changed | The event handler for DefaultCorrectionOptionIndex event.
Public method | Dispose()()()() | Releases all resources used by this rule instance.

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Correct Method

SpellingRuleBase..::..Correct Method

Method corrects the violations for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool Correct(
    int correctionOptionIndex
)

Parameters

correctionOptionIndex
Type: Int32

Index for AutoCorrectionOptions

Return Value

True if violation was corrected succesfully; else False

Remarks

Examples

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


DefaultCorrectionOptionIndex_Changed Method

SpellingRuleBase..::..DefaultCorrectionOptionIndex_Changed Method

The event handler for DefaultCorrectionOptionIndex event.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void DefaultCorrectionOptionIndex_Changed(
    Object sender,
    EventArgs agrs
)

Parameters

sender
Type: Object

Sender of the event

agrs
Type: EventArgs

event argument

Remarks

Examples

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Dispose Method

SpellingRuleBase..::..Dispose Method

Releases all resources used by this rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public void Dispose()

Remarks

Examples

See Also

SpellingRuleBase Class
Dispose Overload
SubMain.CodeItRight.Sdk.Rules Namespace


SpellingRuleBase Properties

The SpellingRuleBase type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectionOptions | Gets all correction options for the rule instance.
Public property | CanCorrect | Gets True if the rule instance support correction; else False.
Public property | Targets | Gets Targets of the rule instance.

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


AutoCorrectionOptions Property

SpellingRuleBase..::..AutoCorrectionOptions Property

Gets all correction options for the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string[] AutoCorrectionOptions { get; }

Remarks

Examples

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


CanCorrect Property

SpellingRuleBase..::..CanCorrect Property

Gets True if the rule instance support correction; else False.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public bool CanCorrect { get; set; }

Remarks

Examples

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Targets Property

SpellingRuleBase..::..Targets Property

Gets Targets of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public RuleTargets Targets { get; set; }

Remarks

Examples

See Also

SpellingRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SubMainRuleBase Class

Provides the abstract (MustInherit in Visual Basic) base class for the rules.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
[SerializableAttribute]
public abstract class SubMainRuleBase : RuleBase

Remarks

Examples

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Rules..::..AbstractRuleBase
SubMain.CodeItRight.Sdk.Rules..::..RuleBase
SubMain.CodeItRight.Sdk.Rules..::..SubMainRuleBase

See Also

SubMainRuleBase Members
SubMain.CodeItRight.Sdk.Rules Namespace


SubMainRuleBase Members

The SubMainRuleBase type exposes the following members.

Properties

 | Name | Description
Public property | Email | Gets the Email of the rule instance.

See Also

SubMainRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SubMainRuleBase Properties

The SubMainRuleBase type exposes the following members.

Properties

 | Name | Description
Public property | Email | Gets the Email of the rule instance.

See Also

SubMainRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


Email Property

SubMainRuleBase..::..Email Property

Gets the Email of the rule instance.

Namespace: SubMain.CodeItRight.Sdk.Rules
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public string Email { get; }

Remarks

Examples

See Also

SubMainRuleBase Class
SubMain.CodeItRight.Sdk.Rules Namespace


SubMain.CodeItRight.Sdk.Utils Namespace

Classes

 | Class | Description
Public class | GuiManagerUtils | Provides dialogs for rule correction.
Public class | NamingRuleUtilities | Provides common naming rule utilities.
Public class | RuleUtilities | Provides common rule utilities.
Public class | SecurityRuleUtilities | Provides methods for security rules.
Public class | UsageRuleUtilities | Provides methods for usage rules.


GuiManagerUtils Class

Provides dialogs for rule correction.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public sealed class GuiManagerUtils

Remarks

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Utils..::..GuiManagerUtils

See Also

GuiManagerUtils Members
SubMain.CodeItRight.Sdk.Utils Namespace


GuiManagerUtils Members

The GuiManagerUtils type exposes the following members.

Methods

Name | Description
ShowRenameDialog | Returns True if the valid name was entered; False if otherwise.
ShowRenameExceptionTypeDialog | Returns True if the valid exception type was entered; False if otherwise.

See Also

GuiManagerUtils Class
SubMain.CodeItRight.Sdk.Utils Namespace


GuiManagerUtils Methods

The GuiManagerUtils type exposes the following members.

Methods

Name | Description
ShowRenameDialog | Returns True if the valid name was entered; False if otherwise.
ShowRenameExceptionTypeDialog | Returns True if the valid exception type was entered; False if otherwise.

See Also

GuiManagerUtils Class
SubMain.CodeItRight.Sdk.Utils Namespace


ShowRenameDialog Method

GuiManagerUtils..::..ShowRenameDialog Method

Returns True if the valid name was entered; False if otherwise.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool ShowRenameDialog(
    IElementInfo elementInfo,
    string name,
    ref string updatedName
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Code Element object

name
Type: String

Name of the object

updatedName
Type: String %

Updated name of the object

Return Value

True if the valid name was entered; False if otherwise.

Remarks

Examples

To be added.

See Also

GuiManagerUtils Class
SubMain.CodeItRight.Sdk.Utils Namespace


ShowRenameExceptionTypeDialog Method

GuiManagerUtils..::..ShowRenameExceptionTypeDialog Method

Returns True if the valid exception type was entered; False if otherwise.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool ShowRenameExceptionTypeDialog(
    ICodeElementInfo codeElementInfo,
    string newName,
    ref string updatedName
)

Parameters

codeElementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

Code Element object

newName
Type: String

Name of the exception type

updatedName
Type: String %

Updated name of the exception type

Return Value

True if the valid exception was entered; False if otherwise.

Remarks

Examples

To be added.

See Also

GuiManagerUtils Class
SubMain.CodeItRight.Sdk.Utils Namespace


NamingRuleUtilities Class

Provides common naming rule utilities.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public sealed class NamingRuleUtilities

Remarks

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Utils..::..NamingRuleUtilities

See Also

NamingRuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


NamingRuleUtilities Members

The NamingRuleUtilities type exposes the following members.

Methods

Name | Description
FixForUniqueName | Returns new unique name for the code element.
GetCamelCased | Returns camel cased name.
GetPascalCased | Returns pascal cased name.
HasPrefix | Returns True if the name has specified prefix.
HasSuffix | Returns True if the name has specified suffix.
IsCamelCased | Returns True if the name is camel cased.
IsConflictWithKeywords | Returns True if the name conflicts with a keyword.
IsPascalCased | Returns True if the name is pascal cased.
IsTypeConflictsWithNamespace | Returns True if the type name conflicts with existing namespace name.
IsTypeConflictsWithSystemNamespace | Returns True if the name conflicts with existing namespace name.
IsUpperCased | Returns True if the name is upper cased.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


NamingRuleUtilities Methods

The NamingRuleUtilities type exposes the following members.

Methods

Name | Description
FixForUniqueName | Returns new unique name for the code element.
GetCamelCased | Returns camel cased name.
GetPascalCased | Returns pascal cased name.
HasPrefix | Returns True if the name has specified prefix.
HasSuffix | Returns True if the name has specified suffix.
IsCamelCased | Returns True if the name is camel cased.
IsConflictWithKeywords | Returns True if the name conflicts with a keyword.
IsPascalCased | Returns True if the name is pascal cased.
IsTypeConflictsWithNamespace | Returns True if the type name conflicts with existing namespace name.
IsTypeConflictsWithSystemNamespace | Returns True if the name conflicts with existing namespace name.
IsUpperCased | Returns True if the name is upper cased.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FixForUniqueName Method

NamingRuleUtilities..::..FixForUniqueName Method

Returns new unique name for the code element.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static string FixForUniqueName(
    string baseName,
    Object codeElementInfo
)

Parameters

baseName
Type: String

Base name for code element

codeElementInfo
Type: Object

Code element

Return Value

Unique name for the code element

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetCamelCased Method

NamingRuleUtilities..::..GetCamelCased Method

Returns camel cased name.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static string GetCamelCased(
    ICodeElementInfo codeElementInfo,
    string name
)

Parameters

codeElementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

Code element

name
Type: String

Name of the code element

Return Value

Camel cased name.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetPascalCased Method

NamingRuleUtilities..::..GetPascalCased Method

Returns pascal cased name.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static string GetPascalCased(
    IElementInfo codeElementInfo,
    string name
)

Parameters

codeElementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Code element

name
Type: String

Name of the code element

Return Value

Pascal cased name.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasPrefix Method

NamingRuleUtilities..::..HasPrefix Method

Returns True if the name has specified prefix.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasPrefix(
    string name,
    string prefix
)

Parameters

name
Type: String

Name of the code element

prefix
Type: String

Prefix to check

Return Value

True if the nam has specified prefix; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasSuffix Method

NamingRuleUtilities..::..HasSuffix Method

Returns True if the name has specified suffix.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasSuffix(
    string name,
    string suffix
)

Parameters

name
Type: String

Name of the code element

suffix
Type: String

Suffix to check

Return Value

True if the name has specified suffix; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsCamelCased Method

NamingRuleUtilities..::..IsCamelCased Method

Returns True if the name is camel cased.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsCamelCased(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the name is camel cased; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsConflictWithKeywords Method

NamingRuleUtilities..::..IsConflictWithKeywords Method

Returns True if the name conflicts with a keyword.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsConflictWithKeywords(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the name conflicts with a keyword; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsPascalCased Method

NamingRuleUtilities..::..IsPascalCased Method

Returns True if the name is pascal cased.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsPascalCased(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the name is pascal cased; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsTypeConflictsWithNamespace Method

NamingRuleUtilities..::..IsTypeConflictsWithNamespace Method

Returns True if the type name conflicts with existing namespace name.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsTypeConflictsWithNamespace(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the type name conflicts with existing namespace name; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsTypeConflictsWithSystemNamespace Method

NamingRuleUtilities..::..IsTypeConflictsWithSystemNamespace Method

Returns True if the name conflicts with existing namespace name.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsTypeConflictsWithSystemNamespace(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the name conflicts with existing namespace name; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsUpperCased Method

NamingRuleUtilities..::..IsUpperCased Method

Returns True if the name is upper cased.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsUpperCased(
    string name
)

Parameters

name
Type: String

Name of the code element

Return Value

True if the name is upper cased; False if otherwise.

Remarks

Examples

To be added.

See Also

NamingRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


RuleUtilities Class

Provides common rule utilities.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public sealed class RuleUtilities

Remarks

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Utils..::..RuleUtilities

See Also

RuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


RuleUtilities Members

The RuleUtilities type exposes the following members.

Methods

Name | Description
GetAttribute | Returns an attrbute for the specified code element.
GetBaseMethods | Returns the base method.
GetBaseTypeMembers | Gets members from the base type.
GetMethodStatements | Gets a collection of the statements from the method specified.
GetTypeInfoByFullName | Returns type object by fully qualified name.
GetTypesFromNamespace | Returns an array of types from specified namespace.
HasAttribute | Returns True if specified code element has an attribute.
HasCorrectDisposeMethodImplementation | Returns True if the dispose method has a correct implementation.
HasCorrectFinalizeImplementation | Returns True if the Finalize method has a correct implementation.
HasUnmanagedTypeFields | Returns True if the type contains unmanaged fields.
IsAnyTypeDerivedFromType | Returns True if any type derives from the specified type.
IsAnyTypeImplementsInterface | Returns True if any type implements the specified interface.
IsAspProject | Returns True if specified project is ASP.NET project.
IsAspProjectFile | Returns True if specified project file is ASP.NET related.
IsComVisibleSetAndEqualToSpecifiedValue | Returns True if ComVisible attribute is set and equal to specified value.
IsEventHandler | Returns True if specified code element is an event handler.
IsMemberOverride | Returns True if specified code element overrides another member.
IsMemberUsedOutsideParentType | Returns True if the member is used outside of the parent type.
IsMethodContainsFieldAssignmentExpression | Returns True if the method contains assignment expression for specified field.
IsMultipleFieldsDeclaration | Returns True if the field declaration statement declares more than one field.
IsMutableType | Returns True if the return type is mutable.
IsNonPublicField | Returns True if specified field is not public.
IsReimplementsInterface | Returns True if the type re-implements specified interface.
IsTypeUsedOutsideParentType | Returns True if the type is used outside in code.
IsUnmanagedType | Returns True if the return type is unmanaged.
IsWindowsFormsSolution | Returns True if the solution contains at least one WindowsForms project.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


RuleUtilities Methods

The RuleUtilities type exposes the following members.

Methods

Name | Description
GetAttribute | Returns an attrbute for the specified code element.
GetBaseMethods | Returns the base method.
GetBaseTypeMembers | Gets members from the base type.
GetMethodStatements | Gets a collection of the statements from the method specified.
GetTypeInfoByFullName | Returns type object by fully qualified name.
GetTypesFromNamespace | Returns an array of types from specified namespace.
HasAttribute | Returns True if specified code element has an attribute.
HasCorrectDisposeMethodImplementation | Returns True if the dispose method has a correct implementation.
HasCorrectFinalizeImplementation | Returns True if the Finalize method has a correct implementation.
HasUnmanagedTypeFields | Returns True if the type contains unmanaged fields.
IsAnyTypeDerivedFromType | Returns True if any type derives from the specified type.
IsAnyTypeImplementsInterface | Returns True if any type implements the specified interface.
IsAspProject | Returns True if specified project is ASP.NET project.
IsAspProjectFile | Returns True if specified project file is ASP.NET related.
IsComVisibleSetAndEqualToSpecifiedValue | Returns True if ComVisible attribute is set and equal to specified value.
IsEventHandler | Returns True if specified code element is an event handler.
IsMemberOverride | Returns True if specified code element overrides another member.
IsMemberUsedOutsideParentType | Returns True if the member is used outside of the parent type.
IsMethodContainsFieldAssignmentExpression | Returns True if the method contains assignment expression for specified field.
IsMultipleFieldsDeclaration | Returns True if the field declaration statement declares more than one field.
IsMutableType | Returns True if the return type is mutable.
IsNonPublicField | Returns True if specified field is not public.
IsReimplementsInterface | Returns True if the type re-implements specified interface.
IsTypeUsedOutsideParentType | Returns True if the type is used outside in code.
IsUnmanagedType | Returns True if the return type is unmanaged.
IsWindowsFormsSolution | Returns True if the solution contains at least one WindowsForms project.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetAttribute Method

RuleUtilities..::..GetAttribute Method

Returns an attrbute for the specified code element.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IAttributeInfo GetAttribute(
    IElementInfo elementInfo,
    string attributeFullName,
    bool isCaseSensitive
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Element object

attributeFullName
Type: String

Attribute full name

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise

Return Value

Returns an attrbute for the specified code element.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetBaseMethods Method

RuleUtilities..::..GetBaseMethods Method

Returns the base method.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMemberInfo[] GetBaseMethods(
    IMethodInfo methodInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Overrided Method

Return Value

The base method.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetBaseTypeMembers Method

RuleUtilities..::..GetBaseTypeMembers Method

Gets members from the base type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMemberInfo[] GetBaseTypeMembers(
    ITypeInfo typeInfo,
    string methodName,
    bool isCaseSensitive
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

methodName
Type: String

Method name

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise.

Return Value

An array of IMemberInfo objects.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetMethodStatements Method

RuleUtilities..::..GetMethodStatements Method

Gets a collection of the statements from the method specified.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static StatementCollection GetMethodStatements(
    IMethodInfo methodInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

Return Value

Collection of statements from the method specified.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetTypeInfoByFullName Method

RuleUtilities..::..GetTypeInfoByFullName Method

Returns type object by fully qualified name.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static ITypeInfo GetTypeInfoByFullName(
    string projectName,
    string typeFullName
)

Parameters

projectName
Type: String

Project name

typeFullName
Type: String

Type fully qualified name

Return Value

Type object.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetTypesFromNamespace Method

RuleUtilities..::..GetTypesFromNamespace Method

Returns an array of types from specified namespace.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static ITypeInfo[] GetTypesFromNamespace(
    INamespaceInfo namespaceInfo
)

Parameters

namespaceInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..INamespaceInfo

Namespace object

Return Value

An array of ITypeInfo objects.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasAttribute Method

RuleUtilities..::..HasAttribute Method

Returns True if specified code element has an attribute.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasAttribute(
    IElementInfo elementInfo,
    string attributeFullName,
    bool isCaseSensitive
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Element

attributeFullName
Type: String

Attribute full name

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise

Return Value

True if specified code element has specified attribute; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasCorrectDisposeMethodImplementation Method

RuleUtilities..::..HasCorrectDisposeMethodImplementation Method

Returns True if the dispose method has a correct implementation.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasCorrectDisposeMethodImplementation(
    IMethodInfo disposeMethodInfo
)

Parameters

disposeMethodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Dispose method

Return Value

True if the dispose method has a correct implementation; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasCorrectFinalizeImplementation Method

RuleUtilities..::..HasCorrectFinalizeImplementation Method

Returns True if the Finalize method has a correct implementation.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasCorrectFinalizeImplementation(
    IMethodInfo finalizerMethodInfo
)

Parameters

finalizerMethodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Dispose method

Return Value

True if the Finalize method has a correct implementation; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasUnmanagedTypeFields Method

RuleUtilities..::..HasUnmanagedTypeFields Method

Returns True if the type contains unmanaged fields.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasUnmanagedTypeFields(
    ITypeMembersInfo typeInfo,
    out IFieldInfo unmanagedFieldInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

unmanagedFieldInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IFieldInfo %

Field object

Return Value

True if the type contains unmanaged fields; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsAnyTypeDerivedFromType Method

RuleUtilities..::..IsAnyTypeDerivedFromType Method

Returns True if any type derives from the specified type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsAnyTypeDerivedFromType(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

Return Value

True if any type derives from the specified type; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsAnyTypeImplementsInterface Method

RuleUtilities..::..IsAnyTypeImplementsInterface Method

Returns True if any type implements the specified interface.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsAnyTypeImplementsInterface(
    IInterfaceInfo interfaceInfo
)

Parameters

interfaceInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IInterfaceInfo

Type object

Return Value

True if any type implements the specified interface; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsAspProject Method

RuleUtilities..::..IsAspProject Method

Returns True if specified project is ASP.NET project.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsAspProject(
    IProjectInfo projectInfo
)

Parameters

projectInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IProjectInfo

Project object

Return Value

True if specified project is ASP.NET project; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsAspProjectFile Method

RuleUtilities..::..IsAspProjectFile Method

Returns True if specified project file is ASP.NET related.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsAspProjectFile(
    IProjectFileInfo projectFileInfo
)

Parameters

projectFileInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IProjectFileInfo

Project file object

Return Value

True if specified project file is ASP.NET file; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsComVisibleSetAndEqualToSpecifiedValue Method

RuleUtilities..::..IsComVisibleSetAndEqualToSpecifiedValue Method

Returns True if ComVisible attribute is set and equal to specified value.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsComVisibleSetAndEqualToSpecifiedValue(
    IElementInfo elementInfo,
    bool value
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

Element

value
Type: Boolean

ComVisible attribute value to check

Return Value

True if ComVisible attribute is set and equal to specified value; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsEventHandler Method

RuleUtilities..::..IsEventHandler Method

Returns True if specified code element is an event handler.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsEventHandler(
    ICodeElementInfo codeElement
)

Parameters

codeElement
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

Code element

Return Value

True if specified code element is an event handler; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsMemberOverride Method

RuleUtilities..::..IsMemberOverride Method

Returns True if specified code element overrides another member.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsMemberOverride(
    ICodeElementInfo codeElement
)

Parameters

codeElement
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

Code element

Return Value

True if specified code element overrides another member; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsMemberUsedOutsideParentType Method

RuleUtilities..::..IsMemberUsedOutsideParentType Method

Returns True if the member is used outside of the parent type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsMemberUsedOutsideParentType(
    IMemberInfo memberInfo
)

Parameters

memberInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMemberInfo

Member object

Return Value

True if the member is used outside of the parent type; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsMethodContainsFieldAssignmentExpression Method

RuleUtilities..::..IsMethodContainsFieldAssignmentExpression Method

Returns True if the method contains assignment expression for specified field.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsMethodContainsFieldAssignmentExpression(
    IMethodInfo methodInfo,
    IFieldInfo fieldInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

fieldInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IFieldInfo

Field object

Return Value

True if the method contains assignment expression for specified field; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsMultipleFieldsDeclaration Method

RuleUtilities..::..IsMultipleFieldsDeclaration Method

Returns True if the field declaration statement declares more than one field.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsMultipleFieldsDeclaration(
    IFieldInfo fieldInfo
)

Parameters

fieldInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IFieldInfo

Field object

Return Value

True if the field declaration statement declares more than one field; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsMutableType Method

RuleUtilities..::..IsMutableType Method

Returns True if the return type is mutable.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsMutableType(
    IReturnTypeInfo returnTypeInfo,
    bool isCaseSensitive
)

Parameters

returnTypeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IReturnTypeInfo

Type object

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise

Return Value

True if the return type is mutable; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsNonPublicField Method

RuleUtilities..::..IsNonPublicField Method

Returns True if specified field is not public.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsNonPublicField(
    ICodeElementInfo codeElement
)

Parameters

codeElement
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ICodeElementInfo

Code element

Return Value

True if specified field is not public; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsReimplementsInterface Method

RuleUtilities..::..IsReimplementsInterface Method

Returns True if the type re-implements specified interface.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsReimplementsInterface(
    ITypeInfo typeInfo,
    string interfaceFullName,
    out ITypeInfo baseTypeImplementedInterface
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

interfaceFullName
Type: String

Interface fully qualified name

baseTypeImplementedInterface
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo %

Base type that implements specified interface

Return Value

True if the type re-implements specified interface; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsTypeUsedOutsideParentType Method

RuleUtilities..::..IsTypeUsedOutsideParentType Method

Returns True if the type is used outside in code.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsTypeUsedOutsideParentType(
    ITypeInfo nestedTypeInfo
)

Parameters

nestedTypeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

Return Value

True if type is used outside in code; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsUnmanagedType Method

RuleUtilities..::..IsUnmanagedType Method

Returns True if the return type is unmanaged.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsUnmanagedType(
    IReturnTypeInfo returnTypeInfo,
    bool isCaseSensitive
)

Parameters

returnTypeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IReturnTypeInfo

Type object

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise

Return Value

True if the return type is unmanaged; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsWindowsFormsSolution Method

RuleUtilities..::..IsWindowsFormsSolution Method

Returns True if the solution contains at least one WindowsForms project.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsWindowsFormsSolution()

Return Value

True if the solution contains at least one WindowsForms project; False if otherwise.

Remarks

Examples

To be added.

See Also

RuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


SecurityRuleUtilities Class

Provides methods for security rules.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public sealed class SecurityRuleUtilities

Remarks

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Utils..::..SecurityRuleUtilities

See Also

SecurityRuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


SecurityRuleUtilities Members

Methods

Name | Description
GetSecurityAttributes(IElementInfo) | Returns array of secutiry attributes for the specified element.
GetSecurityAttributes(IElementInfo, SecurityAction) | Returns array of secutiry attributes for the specified element and action.

See Also

SecurityRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


SecurityRuleUtilities Methods

Methods

Name | Description
GetSecurityAttributes(IElementInfo) | Returns array of secutiry attributes for the specified element.
GetSecurityAttributes(IElementInfo, SecurityAction) | Returns array of secutiry attributes for the specified element and action.

See Also

SecurityRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetSecurityAttributes Method

SecurityRuleUtilities..::..GetSecurityAttributes Method

Overload List

Name | Description
GetSecurityAttributes(IElementInfo) | Returns array of secutiry attributes for the specified element.
GetSecurityAttributes(IElementInfo, SecurityAction) | Returns array of secutiry attributes for the specified element and action.

See Also

SecurityRuleUtilities Class
SecurityRuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


GetSecurityAttributes Method (IElementInfo)

SecurityRuleUtilities..::..GetSecurityAttributes Method (IElementInfo)

Returns array of secutiry attributes for the specified element.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IAttributeInfo[] GetSecurityAttributes(
    IElementInfo elementInfo
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

element

Return Value

Array of secutiry attributes for the specified element.

Remarks

Examples

To be added.

See Also

SecurityRuleUtilities Class
GetSecurityAttributes Overload
SubMain.CodeItRight.Sdk.Utils Namespace


GetSecurityAttributes Method (IElementInfo, SecurityAction)

SecurityRuleUtilities..::..GetSecurityAttributes Method (IElementInfo, SecurityAction)

Returns array of secutiry attributes for the specified element and action.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IAttributeInfo[] GetSecurityAttributes(
    IElementInfo elementInfo,
    SecurityAction action
)

Parameters

elementInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IElementInfo

element

action
Type: SecurityAction

Security action

Return Value

Array of secutiry attributes for the specified element and action.

Remarks

Examples

To be added.

See Also

SecurityRuleUtilities Class
GetSecurityAttributes Overload
SubMain.CodeItRight.Sdk.Utils Namespace


UsageRuleUtilities Class

Provides methods for usage rules.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public sealed class UsageRuleUtilities

Remarks

Examples

To be added.

Inheritance Hierarchy

Object
SubMain.CodeItRight.Sdk.Utils..::..UsageRuleUtilities

See Also

UsageRuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


UsageRuleUtilities Members

The UsageRuleUtilities type exposes the following members.

Methods

Name | Description
CanOverrideDisposeBool | Returns True if the type can override Dispose(Boolean) method from the base class.
FindDestructor | Searches for destructor in specified type
FindDisposeBoolField | Searches for "disposed" field in specified type
FindDisposeBoolMethod | Searches for Dispose(Boolean) method in specified type
FindDisposeMethod(ITypeMembersInfo) | Returns Dispose() method for specified type
FindDisposeMethod(ITypeMembersInfo, Boolean) | Searches for Dispose() method in specified type
FindFinalizeMethod | Searches for Finalise method in specified type
FindGetObjectDataMethod | Searches for GetObjectData method of the specified type.
GetBaseClassDestructor | Returns a base class destructor
GetBaseClassFinalizeMethod | Returns a base class finalize method
GetBaseClassParameterlessConstructor | Returns a base class parameterless constructor
GetDeserializationConstructor | Returns a deserialization constructor for specified type.
GetFinalizer | Returns a finalizer(desctuctor) method for the specified class.
GetMemberStatements | Returns a collection of statements for specified member
GetParameterlessConstructor | Returns a parameterless constructor
GetSerializableFields | Returns serializable fields for specified type.
HasBaseClassDisposeBoolField | Returns True if base type contains "disposed" field
HasBaseClassDisposeBoolMethod | Returns True if base type contains Dispose(Boolean) method
HasDefaultConstructor | Returns True if type has a default parameterless constructor; False if otherwise.
IsDeserializationConstructor | Returns a true if member is a deserialization constructor.
IsDisposeBoolField | Returns True if specified field is a "disposed" field
IsDisposeBoolMethod | Returns True if specified method is Dispose(Boolean) method
IsDisposeMethod(IMethodInfo) | Returns True if specified method is Dispose() method
IsFinalizeMethod | Returns True if specified method is a finalizer(desctuctor)
IsReturnTypeEqualsSpecifiedType | Returns True if return type equals to the specified type by the fully qualified name
MethodContainsBaseTypeMethodInvocation | Returns True if specified method contains a call of the base method
MethodContainsFieldMethodInvocation | Returns True if specified method contains a call of field type method
MethodContainsMethodInvocation | Returns True if the method contains invocation of the specified method

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


UsageRuleUtilities Methods

The UsageRuleUtilities type exposes the following members.

Methods

Name | Description
CanOverrideDisposeBool | Returns True if the type can override Dispose(Boolean) method from the base class.
FindDestructor | Searches for destructor in specified type
FindDisposeBoolField | Searches for "disposed" field in specified type
FindDisposeBoolMethod | Searches for Dispose(Boolean) method in specified type
FindDisposeMethod(ITypeMembersInfo) | Returns Dispose() method for specified type
FindDisposeMethod(ITypeMembersInfo, Boolean) | Searches for Dispose() method in specified type
FindFinalizeMethod | Searches for Finalise method in specified type
FindGetObjectDataMethod | Searches for GetObjectData method of the specified type.
GetBaseClassDestructor | Returns a base class destructor
GetBaseClassFinalizeMethod | Returns a base class finalize method
GetBaseClassParameterlessConstructor | Returns a base class parameterless constructor
GetDeserializationConstructor | Returns a deserialization constructor for specified type.
GetFinalizer | Returns a finalizer(desctuctor) method for the specified class.
GetMemberStatements | Returns a collection of statements for specified member
GetParameterlessConstructor | Returns a parameterless constructor
GetSerializableFields | Returns serializable fields for specified type.
HasBaseClassDisposeBoolField | Returns True if base type contains "disposed" field
HasBaseClassDisposeBoolMethod | Returns True if base type contains Dispose(Boolean) method
HasDefaultConstructor | Returns True if type has a default parameterless constructor; False if otherwise.
IsDeserializationConstructor | Returns a true if member is a deserialization constructor.
IsDisposeBoolField | Returns True if specified field is a "disposed" field
IsDisposeBoolMethod | Returns True if specified method is Dispose(Boolean) method
IsDisposeMethod(IMethodInfo) | Returns True if specified method is Dispose() method
IsFinalizeMethod | Returns True if specified method is a finalizer(desctuctor)
IsReturnTypeEqualsSpecifiedType | Returns True if return type equals to the specified type by the fully qualified name
MethodContainsBaseTypeMethodInvocation | Returns True if specified method contains a call of the base method
MethodContainsFieldMethodInvocation | Returns True if specified method contains a call of field type method
MethodContainsMethodInvocation | Returns True if the method contains invocation of the specified method

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


CanOverrideDisposeBool Method

UsageRuleUtilities..::..CanOverrideDisposeBool Method

Returns True if the type can override Dispose(Boolean) method from the base class.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool CanOverrideDisposeBool(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type

Return Value

True if the type can override Dispose(Boolean) method from the base class; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FindDestructor Method

UsageRuleUtilities..::..FindDestructor Method

Searches for destructor in specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindDestructor(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

Destructor for specified type

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FindDisposeBoolField Method

UsageRuleUtilities..::..FindDisposeBoolField Method

Searches for "disposed" field in specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IFieldInfo FindDisposeBoolField(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

"disposed" field for specified type

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FindDisposeBoolMethod Method

UsageRuleUtilities..::..FindDisposeBoolMethod Method

Searches for Dispose(Boolean) method in specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindDisposeBoolMethod(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

Dispose(Boolean) method for specified type

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FindDisposeMethod Method

UsageRuleUtilities..::..FindDisposeMethod Method

Overload List

Name | Description
FindDisposeMethod(ITypeMembersInfo) | Returns Dispose() method for specified type
FindDisposeMethod(ITypeMembersInfo, Boolean) | Searches for Dispose() method in specified type

See Also

UsageRuleUtilities Class
UsageRuleUtilities Members
SubMain.CodeItRight.Sdk.Utils Namespace


FindDisposeMethod Method (ITypeMembersInfo)

UsageRuleUtilities..::..FindDisposeMethod Method (ITypeMembersInfo)

Returns Dispose() method for specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindDisposeMethod(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type

Return Value

Dispose() method for specified type.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
FindDisposeMethod Overload
SubMain.CodeItRight.Sdk.Utils Namespace


FindDisposeMethod Method (ITypeMembersInfo, Boolean)

UsageRuleUtilities..::..FindDisposeMethod Method (ITypeMembersInfo, Boolean)

Searches for Dispose() method in specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindDisposeMethod(
    ITypeMembersInfo typeInfo,
    bool includeBaseTypeMembers
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

includeBaseTypeMembers
Type: Boolean

Search for Dispose() method in base types

Return Value

Dispose() method for specified type

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
FindDisposeMethod Overload
SubMain.CodeItRight.Sdk.Utils Namespace


FindFinalizeMethod Method

UsageRuleUtilities..::..FindFinalizeMethod Method

Searches for Finalise method in specified type

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindFinalizeMethod(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

Finalize method for specified type

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


FindGetObjectDataMethod Method

UsageRuleUtilities..::..FindGetObjectDataMethod Method

Searches for GetObjectData method of the specified type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo FindGetObjectDataMethod(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type

Return Value

GetObjectData method of the specified type.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetBaseClassDestructor Method

UsageRuleUtilities..::..GetBaseClassDestructor Method

Returns a base class destructor

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetBaseClassDestructor(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

Return Value

Base class destructor

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetBaseClassFinalizeMethod Method

UsageRuleUtilities..::..GetBaseClassFinalizeMethod Method

Returns a base class finalize method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetBaseClassFinalizeMethod(
    IClassInfo classInfo
)

Parameters

classInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IClassInfo

Class object

Return Value

Base class finalize method

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetBaseClassParameterlessConstructor Method

UsageRuleUtilities..::..GetBaseClassParameterlessConstructor Method

Returns a base class parameterless constructor

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetBaseClassParameterlessConstructor(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

Return Value

Base class parameterless constructor

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetDeserializationConstructor Method

UsageRuleUtilities..::..GetDeserializationConstructor Method

Returns a deserialization constructor for specified type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetDeserializationConstructor(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

Deserialization constructor for specified type.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetFinalizer Method

UsageRuleUtilities..::..GetFinalizer Method

Returns a finalizer(desctuctor) method for the specified class.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetFinalizer(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

Finalizer(desctuctor) method for the specified class.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetMemberStatements Method

UsageRuleUtilities..::..GetMemberStatements Method

Returns a collection of statements for specified member

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static StatementCollection GetMemberStatements(
    IMemberInfo memberInfo
)

Parameters

memberInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMemberInfo

Member object

Return Value

Collection of statements for specified member

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetParameterlessConstructor Method

UsageRuleUtilities..::..GetParameterlessConstructor Method

Returns a parameterless constructor

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IMethodInfo GetParameterlessConstructor(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type object

Return Value

Parameterless constructor

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


GetSerializableFields Method

UsageRuleUtilities..::..GetSerializableFields Method

Returns serializable fields for specified type.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static IFieldInfo[] GetSerializableFields(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

An array of IFieldInfo objects.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasBaseClassDisposeBoolField Method

UsageRuleUtilities..::..HasBaseClassDisposeBoolField Method

Returns True if base type contains "disposed" field

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasBaseClassDisposeBoolField(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type

Return Value

True if base type contains "disposed" field; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasBaseClassDisposeBoolMethod Method

UsageRuleUtilities..::..HasBaseClassDisposeBoolMethod Method

Returns True if base type contains Dispose(Boolean) method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasBaseClassDisposeBoolMethod(
    ITypeInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeInfo

Type

Return Value

True if base type contains Dispose(Boolean) method; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


HasDefaultConstructor Method

UsageRuleUtilities..::..HasDefaultConstructor Method

Returns True if type has a default parameterless constructor; False if otherwise.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool HasDefaultConstructor(
    ITypeMembersInfo typeInfo
)

Parameters

typeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..ITypeMembersInfo

Type object

Return Value

True if type has a default parameterless constructor; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsDeserializationConstructor Method

UsageRuleUtilities..::..IsDeserializationConstructor Method

Returns a true if member is a deserialization constructor.

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsDeserializationConstructor(
    IMemberInfo memberInfo
)

Parameters

memberInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMemberInfo

Type object

Return Value

True if member is a deserialization constructor; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsDisposeBoolField Method

UsageRuleUtilities..::..IsDisposeBoolField Method

Returns True if specified field is a "disposed" field

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsDisposeBoolField(
    IFieldInfo fieldInfo
)

Parameters

fieldInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IFieldInfo

Field object

Return Value

True if specified field is a "disposed" field; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsDisposeBoolMethod Method

UsageRuleUtilities..::..IsDisposeBoolMethod Method

Returns True if specified method is Dispose(Boolean) method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsDisposeBoolMethod(
    IMethodInfo methodInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

Return Value

True if specified method is Dispose(Boolean) method; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsDisposeMethod Method (IMethodInfo)

UsageRuleUtilities..::..IsDisposeMethod Method (IMethodInfo)

Returns True if specified method is Dispose() method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsDisposeMethod(
    IMethodInfo methodInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

Return Value

True if specified method is Dispose() method; False if otherwise

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
IsDisposeMethod Overload
SubMain.CodeItRight.Sdk.Utils Namespace


IsFinalizeMethod Method

UsageRuleUtilities..::..IsFinalizeMethod Method

Returns True if specified method is a finalizer(desctuctor)

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsFinalizeMethod(
    IMethodInfo methodInfo
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method

Return Value

True if specified method is a finalizer (desctuctor); False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


IsReturnTypeEqualsSpecifiedType Method

UsageRuleUtilities..::..IsReturnTypeEqualsSpecifiedType Method

Returns True if return type equals to the specified type by the fully qualified name

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool IsReturnTypeEqualsSpecifiedType(
    IReturnTypeInfo returnTypeInfo,
    string specifiedTypeFullName,
    bool isCaseSensitive
)

Parameters

returnTypeInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IReturnTypeInfo

Return type

specifiedTypeFullName
Type: String

Type fully qualified name

isCaseSensitive
Type: Boolean

True if project language is case sensitive; False if otherwise.

Return Value

Returns True if return type equals to the specified type by the fully qualified name; False if otherwise

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


MethodContainsBaseTypeMethodInvocation Method

UsageRuleUtilities..::..MethodContainsBaseTypeMethodInvocation Method

Returns True if specified method contains a call of the base method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool MethodContainsBaseTypeMethodInvocation(
    IMethodInfo methodInfo,
    string methodName
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

methodName
Type: String

Method name

Return Value

True if specified method contains a call of the base method; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


MethodContainsFieldMethodInvocation Method

UsageRuleUtilities..::..MethodContainsFieldMethodInvocation Method

Returns True if specified method contains a call of field type method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool MethodContainsFieldMethodInvocation(
    IMethodInfo methodInfo,
    IFieldInfo fieldInfo,
    string methodName
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

fieldInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IFieldInfo

Field object

methodName
Type: String

Method name

Return Value

True if specified method contains a call of field type method; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


MethodContainsMethodInvocation Method

UsageRuleUtilities..::..MethodContainsMethodInvocation Method

Returns True if the method contains invocation of the specified method

Namespace: SubMain.CodeItRight.Sdk.Utils
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public static bool MethodContainsMethodInvocation(
    IMethodInfo methodInfo,
    string methodName
)

Parameters

methodInfo
Type: SubMain.CodeItRight.Sdk.Core.Reflection..::..IMethodInfo

Method object

methodName
Type: String

Name of method

Return Value

True if the method contains invocation of the specified method ; False if otherwise.

Remarks

Examples

To be added.

See Also

UsageRuleUtilities Class
SubMain.CodeItRight.Sdk.Utils Namespace


VC Field

ProjectInfoLanguage..::..VC Field

Indicates that the project language is C++.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ProjectInfoLanguage VC

See Also

ProjectInfoLanguage Enumeration


Override Field

MemberInfoModifiers..::..Override Field

Indicates that the member modifier is override.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Override

See Also

MemberInfoModifiers Enumeration


Abstract Field

RuleScopes..::..Abstract Field

Indicates that only abstract classes and class members will be checked by the rule. Abstract classes and class members that are incomplete and must be implemented in a derived class.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Abstract

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


New Field

RuleScopes..::..New Field

Indicates that only classes and class members declared with 'new' modifier will be checked by the rule.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes New

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Event Field

RuleTargets..::..Event Field

Indicates event as target. Events provide notifications about occurrences, such as button clicks or the successful completion of a method, to other objects. Events are defined and triggered by using delegates.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Event

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


VBNet Field

ProjectInfoLanguage..::..VBNet Field

Indicates that the project language is VB.NET.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ProjectInfoLanguage VBNet

See Also

ProjectInfoLanguage Enumeration


CriticalError Field

SeverityLevel..::..CriticalError Field

Indicates critical error severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel CriticalError

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Virtual Field

RuleScopes..::..Virtual Field

Indicates that only virtual method, property, indexer, or event will be checked by the rule. A virtual method, property, indexer, or event declaration are allowed to be overridden in a derived class.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Virtual

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Member Field

RuleTargets..::..Member Field

Indicates member as target. Member in this enumeration is one of the following: Constant, Field, Event, Property, Indexer, Method, Operator or EnumerationItem

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Member

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Solution Field

RuleTargets..::..Solution Field

Indicates solution as target. A solution is a conceptual container implemented in Visual Studio. Solutions manage the way Visual Studio configures, builds, and deploys sets of related projects. A Visual Studio solution can include just one project or several projects built jointly by a development team. A complex application might require multiple solutions.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Solution

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Writeonly Field

MemberInfoModifiers..::..Writeonly Field

Indicates that the member modifier is write only.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Writeonly

See Also

MemberInfoModifiers Enumeration


Statement Field

RuleTargets..::..Statement Field

Indicates statement as target. Statement is a sequence of expressions.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Statement

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Constant Field

RuleTargets..::..Constant Field

Indicates constant as target. Constants are fields or properties whose value is set at compile time and cannot be changed.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Constant

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


EnumerationItem Field

RuleTargets..::..EnumerationItem Field

Indicates enum member as target. An enum member is a named integral constant defined in the enumeration type.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets EnumerationItem

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Literal Field

RuleScopes..::..Literal Field

Indicates that only literals will be checked by the rule. A literals is a string, a number, or a date which directly represents a constant value. Literals have types , but they do not have names and they cannot be modified.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Literal

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Delegate Field

RuleTargets..::..Delegate Field

Indicates delegate as target. A delegate is a class that can hold a reference to a method. Unlike other classes, a delegate class has a signature, and it can hold references only to methods that match its signature. A delegate is thus equivalent to a type-safe function pointer or a callback.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Delegate

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Module Field

ClassInfoType..::..Module Field

Indicates that the type is a module.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Module

See Also

ClassInfoType Enumeration


Private Field

RuleScopes..::..Private Field

Indicates that only private classes and class members will be checked by the rule. Private members are accessible only within the body of the class or the struct in which they are declared.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Private

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Inactive Field

ActiveStatus..::..Inactive Field

Indicates that the rule is inactive.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ActiveStatus Inactive

See Also

ActiveStatus Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Rename Method

ICommentInfo..::..Rename Method

Replaces a comment line, with another comment line.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public abstract void Rename(
    string newCommentLine
)

Parameters

newCommentLine
Type: String

New comment line.

Remarks

Examples

To be added.

See Also

ICommentInfo


PhoneticNearMiss Field

SuggestionEnum..::..PhoneticNearMiss Field

Combines the phonetic and near miss strategies

Namespace: NetSpell.SpellChecker
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public const SuggestionEnum PhoneticNearMiss

See Also

SuggestionEnum
NetSpell.SpellChecker Namespace


Line Field

RuleTargets..::..Line Field

Indicates line as target.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Line

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


New Field

MemberInfoModifiers..::..New Field

Indicates that the member modifier is new.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers New

See Also

MemberInfoModifiers Enumeration


None Field

RuleTargets..::..None Field

Indicates unknown target.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets None

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


NearMiss Field

SuggestionEnum..::..NearMiss Field

The near miss strategy generates suggestion by replacing, removing, adding chars to make words

Namespace: NetSpell.SpellChecker
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public const SuggestionEnum NearMiss

Remarks

This technique was developed by the open source spell checker ISpell

See Also

SuggestionEnum
NetSpell.SpellChecker Namespace


WindowsApplication Field

OutputTypeInfo..::..WindowsApplication Field

Indicates that the project type is Windows Application.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const OutputTypeInfo WindowsApplication

See Also

OutputTypeInfo Enumeration


Comment Field

RuleTargets..::..Comment Field

Indicates comment as target. A comment is an information embedded in the source code of a computer program. Compiler ignores comments during source file processing.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Comment

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


XmlComment Field

RuleTargets..::..XmlComment Field

Indicates XML comment as target. XML comment is an information embedded in the source code of a computer program. Compiler ignores comments during source file processing.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets XmlComment

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Information Field

SeverityLevel..::..Information Field

Indicates information severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel Information

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Readonly Field

MemberInfoModifiers..::..Readonly Field

Indicates that the member modifier is read only.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Readonly

See Also

MemberInfoModifiers Enumeration


Virtual Field

MemberInfoModifiers..::..Virtual Field

Indicates that the member modifier is virtual.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Virtual

See Also

MemberInfoModifiers Enumeration


Unsafe Field

MemberInfoModifiers..::..Unsafe Field

Indicates that the member modifier is unsafe.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Unsafe

See Also

MemberInfoModifiers Enumeration


Const Field

MemberInfoModifiers..::..Const Field

Indicates that the member modifier is const.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Const

See Also

MemberInfoModifiers Enumeration


Warning Field

SeverityLevel..::..Warning Field

Indicates warning severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel Warning

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Class Field

ClassInfoType..::..Class Field

Indicates that the type is a class.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Class

See Also

ClassInfoType Enumeration


SystemClass Field

ClassInfoType..::..SystemClass Field

Indicates that the type is class defined in external assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType SystemClass

See Also

ClassInfoType Enumeration


None Field

ActiveStatus..::..None Field

Indicates that status of rule is unknown.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ActiveStatus None

See Also

ActiveStatus Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Rename Method

IXmlCommentInfo..::..Rename Method

Replaces a comment line, with another comment line.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public abstract void Rename(
    string newCommentLine
)

Parameters

newCommentLine
Type: String

New comment line.

Remarks

Examples

To be added.

See Also

IXmlCommentInfo


Interface Field

ClassInfoType..::..Interface Field

Indicates that the type is an interface.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Interface

See Also

ClassInfoType Enumeration


Volatile Field

MemberInfoModifiers..::..Volatile Field

Indicates that the member modifier is volatile.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Volatile

See Also

MemberInfoModifiers Enumeration


Enumeration Field

RuleTargets..::..Enumeration Field

Indicates enum as target. An enumeration type (also named an enumeration or an enum) provides an efficient way to define a set of named integral constants that may be assigned to a variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Enumeration

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


File Field

RuleTargets..::..File Field

Indicates file as target. Files are items that compose a project, such as forms, source files, and classes within a project.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets File

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Static Field

RuleScopes..::..Static Field

Indicates that only static classes and class members will be checked by the rule. A static class is basically the same as a non-static class, but a static class cannot be instantiated. Because there is no instance variable, the members of a static class can be accessed by using the class name itself.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Static

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Method Field

RuleTargets..::..Method Field

Indicates method as target. Methods define the actions that a class can perform. Methods can take parameters that provide input data, and can return output data through parameters. Methods can also return a value directly, without using a parameter.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Method

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ProtectedInternal Field

MemberInfoModifiers..::..ProtectedInternal Field

Indicates that the member modifier is protected and internal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers ProtectedInternal

See Also

MemberInfoModifiers Enumeration


Default Field

MemberInfoModifiers..::..Default Field

Indicates that the member modifier is Default.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Default

See Also

MemberInfoModifiers Enumeration


Extern Field

MemberInfoModifiers..::..Extern Field

Indicates that the member modifier is extern.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Extern

See Also

MemberInfoModifiers Enumeration


VS Field

RuleTargets..::..VS Field

Indicates Visual Studio IDE as target. The Visual Studio IDE (Integrated Development Environment) is a set of tools that helps to write and modify the code for programs, and also detect and correct errors in programs.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets VS

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Static Field

MemberInfoModifiers..::..Static Field

Indicates that the member modifier is static.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Static

See Also

MemberInfoModifiers Enumeration


LocalConstant Field

RuleTargets..::..LocalConstant Field

Indicates local contant as target. Constants are fields or properties whose value is set at compile time and cannot be changed. The scope of a local constant is the block in which the declaration occurs.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets LocalConstant

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Internal Field

RuleScopes..::..Internal Field

Indicates that only internal classes and class members will be checked by the rule. Internal types or members are accessible only within files in the same assembly.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Internal

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


None Field

RuleScopes..::..None Field

Indicates unknown scope.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes None

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Interface Field

RuleTargets..::..Interface Field

Indicates interface as target. An interface is a reference type that defines a contract. Other types implement an interface to guarantee that they support certain operations. The interface specifies the members that must be supplied by classes or other interfaces that implement it. Like classes, interfaces can contain methods, properties, indexers, and events as members.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Interface

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


CriticalWarning Field

SeverityLevel..::..CriticalWarning Field

Indicates critical warning severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel CriticalWarning

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ProtectedInternal Field

RuleScopes..::..ProtectedInternal Field

Indicates that only internal and protected classes and class members will be checked by the rule.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes ProtectedInternal

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Error Field

SeverityLevel..::..Error Field

Indicates error severity level.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel Error

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Protected Field

RuleScopes..::..Protected Field

Indicates that only protected classes and class members will be checked by the rule. A protected member is accessible from within the class in which it is declared, and from within any class derived from the class that declared this member.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Protected

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Sealed Field

RuleScopes..::..Sealed Field

Indicates that only sealed classes will be checked by the rule. A sealed class cannot be used as a base class. For this reason, it cannot also be an abstract class. Sealed classes prevent derivation.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Sealed

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Namespace Field

RuleTargets..::..Namespace Field

Indicates namespace as target. A namespace is a logical naming scheme for grouping related types. The .NET Framework uses a hierarchical naming scheme for grouping types into logical categories of related functionality, such as the ASP.NET technology or remoting functionality.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Namespace

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Variable Field

RuleTargets..::..Variable Field

Indicates variable as target. A variable is an item of data named by an identifier. Each variable has a data type (which determines the kind of data that the variable can store), such as int or string, and a scope.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Variable

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


None Field

MemberInfoModifiers..::..None Field

Indicates that the member modifier is unknown.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers None

See Also

MemberInfoModifiers Enumeration


ConsoleApplication Field

OutputTypeInfo..::..ConsoleApplication Field

Indicates that the project type is Console Application.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const OutputTypeInfo ConsoleApplication

See Also

OutputTypeInfo Enumeration


Project Field

RuleTargets..::..Project Field

Indicates project as target. A project is a conceptual container implemented in Visual Studio. A project includes a set of source files, plus related metadata such as component references and build instructions. Projects generally produce one or more output files when built.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Project

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Class Field

RuleTargets..::..Class Field

Indicates class as target. A class is a construct that enables you to create your own custom types by grouping together variables of other types, methods and events. A class is like a blueprint. It defines the data and behavior of a type. If the class is not declared as static, client code can use it by creating objects or instances which are assigned to a variable.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Class

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Property Field

RuleTargets..::..Property Field

Indicates property as target. Properties are methods on a class that are accessed as if they were fields on that class. A property can provide protection for a class field to keep it from being changed without the knowledge of the object.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Property

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Literal Field

MemberInfoModifiers..::..Literal Field

Indicates that the member modifier is literal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Literal

See Also

MemberInfoModifiers Enumeration


Enum Field

ClassInfoType..::..Enum Field

Indicates that the type is an enumeration.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Enum

See Also

ClassInfoType Enumeration


Private Field

MemberInfoModifiers..::..Private Field

Indicates that the member modifier is private.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Private

See Also

MemberInfoModifiers Enumeration


None Field

SeverityLevel..::..None Field

Indicates that severity level is unknown.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
[ElementAttribute]
public const SeverityLevel None

See Also

SeverityLevel Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Any Field

RuleScopes..::..Any Field

Indicates any scope from listed above. It's a maximum visibility.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Any

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


CodeRegion Field

RuleTargets..::..CodeRegion Field

Indicates code region as target. A code region is a single statement or a list of statements.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets CodeRegion

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Public Field

RuleScopes..::..Public Field

Indicates that only public classes and class members will be checked by the rule. Public access is the most permissive access level. There are no restrictions on accessing public members.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Public

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Overloads Field

MemberInfoModifiers..::..Overloads Field

Indicates that the member modifier is Overloads.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Overloads

See Also

MemberInfoModifiers Enumeration


Active Field

ActiveStatus..::..Active Field

Indicates that the rule is active.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ActiveStatus Active

See Also

ActiveStatus Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


None Field

OutputTypeInfo..::..None Field

Indicates that the project type is unknown.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const OutputTypeInfo None

See Also

OutputTypeInfo Enumeration


Override Field

RuleScopes..::..Override Field

Indicates that only overriden method, property, indexer, or event will be checked by the rule. Overriden members are extend or modify the abstract or virtual implementation of an inherited method, property, indexer, or event.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Override

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Readonly Field

RuleScopes..::..Readonly Field

Indicates that read-only fields and properties will be checked by the rule. A read-only field or property can be read but not written.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Readonly

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


None Field

ProjectInfoLanguage..::..None Field

Indicates that the project language is unknown.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ProjectInfoLanguage None

See Also

ProjectInfoLanguage Enumeration


Sealed Field

MemberInfoModifiers..::..Sealed Field

Indicates that the member modifier is sealed.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Sealed

See Also

MemberInfoModifiers Enumeration


WithEvents Field

RuleScopes..::..WithEvents Field

Indicates that only WithEvents variables will be checked by the rule (Visual Basic). WithEvents keyword specifies that one or more declared member variables refer to an instance of a class that can raise events.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes WithEvents

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Field Field

RuleTargets..::..Field Field

Indicates field as target. Fields are variables declared at class scope. A field may be a built-in numeric type or an instance of another class. For example, a calendar class may have a field that contains the current date.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Field

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


SpecialName Field

MemberInfoModifiers..::..SpecialName Field

Indicates that the member modifier is special name.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers SpecialName

See Also

MemberInfoModifiers Enumeration


Expression Field

RuleTargets..::..Expression Field

Indicates expression as target. An expression is a sequence of operators and operands.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Expression

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


ClassLibrary Field

OutputTypeInfo..::..ClassLibrary Field

Indicates that the project type is Class Library.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const OutputTypeInfo ClassLibrary

See Also

OutputTypeInfo Enumeration


CSharp Field

ProjectInfoLanguage..::..CSharp Field

Indicates that the project language is C#.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ProjectInfoLanguage CSharp

See Also

ProjectInfoLanguage Enumeration


Excluded Field

ActiveStatus..::..Excluded Field

Indicates that the rule is excluded.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ActiveStatus Excluded

See Also

ActiveStatus Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Const Field

RuleScopes..::..Const Field

Indicates that only constants will be checked by the rule. A constant is a field or local variable, which cannot be modified.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Const

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Abstract Field

MemberInfoModifiers..::..Abstract Field

Indicates that the member modifier is abstract.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Abstract

See Also

MemberInfoModifiers Enumeration


Protected Field

MemberInfoModifiers..::..Protected Field

Indicates that the member modifier is protected.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Protected

See Also

MemberInfoModifiers Enumeration


Struct Field

ClassInfoType..::..Struct Field

Indicates that the type is a structure.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Struct

See Also

ClassInfoType Enumeration


Struct Field

RuleTargets..::..Struct Field

Indicates struct as target. A struct is a user-defined value type. Like a class, structures can contain constructors, constants, fields, methods, properties, indexers, operators, and nested types. Unlike classes, however, structures do not support inheritance.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Struct

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Parameter Field

RuleTargets..::..Parameter Field

Indicates parameter as target. A parameter of a method (formal parameter) is a container which is used to transfer information to or from methods. There are four kinds of formal parameters: value parameters, reference parameters, output parameters and parameter arrays.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Parameter

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Type Field

RuleTargets..::..Type Field

Indicates type as target. Type in this enumeration is one of the following: Class, Interface, Struct, Delegate, Enumeration, Module

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Type

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


NotOverridable Field

MemberInfoModifiers..::..NotOverridable Field

Indicates that the member modifier is NotOverridable.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers NotOverridable

See Also

MemberInfoModifiers Enumeration


Module Field

RuleTargets..::..Module Field

Indicates module as target. A module (Visual Basic .NET) is similar to a class but with some important distinctions. Every module has exactly one instance and does not need to be created or assigned to a variable. Modules do not support inheritance or implement interfaces. Notice that a module is not a type in the sense that a class or structure is - you cannot declare a programming element to have the data type of a module.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Module

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Public Field

MemberInfoModifiers..::..Public Field

Indicates that the member modifier is public.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Public

See Also

MemberInfoModifiers Enumeration


Unsafe Field

RuleScopes..::..Unsafe Field

Indicates that only unsafe blocks will be checked by the rule. Unsafe blocks denote an unsafe context, which is required for any operation involving pointers.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Unsafe

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Extern Field

RuleScopes..::..Extern Field

Indicates that only external method declarations will be checked by the rule. An external method is a method that is implemented externally (usually in unmanaged DLL library).

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Extern

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


WithEvents Field

MemberInfoModifiers..::..WithEvents Field

Indicates that the member modifier is WithEvents.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers WithEvents

See Also

MemberInfoModifiers Enumeration


Partial Field

MemberInfoModifiers..::..Partial Field

Indicates that the member modifier is partial.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Partial

See Also

MemberInfoModifiers Enumeration


Delegate Field

ClassInfoType..::..Delegate Field

Indicates that the type is a delegate.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const ClassInfoType Delegate

See Also

ClassInfoType Enumeration


Internal Field

MemberInfoModifiers..::..Internal Field

Indicates that the member modifier is internal.

Namespace: SubMain.CodeItRight.Sdk.Core.Reflection
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const MemberInfoModifiers Internal

See Also

MemberInfoModifiers Enumeration


Indexer Field

RuleTargets..::..Indexer Field

Indicates indexer as target. Indexers enable an object to be indexed in a manner similar to arrays.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Indexer

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Volatile Field

RuleScopes..::..Volatile Field

Indicates that only volatile fields will be checked by the rule. A volatile field might be modified by multiple threads that are executing at the same time.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes Volatile

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Operator Field

RuleTargets..::..Operator Field

Indicates operator as target. An operator is a term or a symbol that takes one or more expressions, called operands, as input and returns a value. Operators in an expression are evaluated in a specific order known as operator precedence.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleTargets Operator

See Also

RuleTargets Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace


Phonetic Field

SuggestionEnum..::..Phonetic Field

The phonetic strategy generates suggestions by word sound

Namespace: NetSpell.SpellChecker
Assembly: SubMain.CodeItRight.Sdk (in SubMain.CodeItRight.Sdk.dll)

Syntax

C#
public const SuggestionEnum Phonetic

Remarks

This technique was developed by the open source project ASpell.net

See Also

SuggestionEnum
NetSpell.SpellChecker Namespace


WriteOnly Field

RuleScopes..::..WriteOnly Field

Indicates that write-only properties will be checked by the rule. A write-only property can be written but not read.

Namespace: SubMain.CodeItRight.Sdk.Core.Rules
Assembly: SubMain.CodeItRight.Sdk.Core (in SubMain.CodeItRight.Sdk.Core.dll)

Syntax

C#
public const RuleScopes WriteOnly

See Also

RuleScopes Enumeration
SubMain.CodeItRight.Sdk.Core.Rules Namespace