SubMain.GhostDoc.T4 Namespace

Classes

 | Class | Description
Public class | Attribute | The attribute class.
Public class | CodeElement | Provides access to any code element within the rule.
Public class | Context | The Context class is the root class for all code for T4 rules.
Public class | Parameter | Parameter of the code element.
Public class | ReturnType | Return type of the code element.
Public class | TypeParameter | Type parameter of type or method.
Copyright © 2003-2020 SubMain
Help File generated with GhostDoc


Attribute Class

The attribute class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public class Attribute
Public Class Attribute

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..Attribute

See Also

Attribute Members
SubMain.GhostDoc.T4 Namespace


Attribute Members

The Attribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | The attribute name.

See Also

Attribute Class


Attribute Properties

The Attribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | The attribute name.

See Also

Attribute Class


Name Property

GhostDoc Pro API

Attribute..::..Name Property

The attribute name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Remarks

See Also

Attribute Class


CodeElement Class

Provides access to any code element within the rule.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public class CodeElement
Public Class CodeElement

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..CodeElement

See Also

CodeElement Members


CodeElement Members

The CodeElement type exposes the following members.

Constructors

 | Name | Description
Public method | CodeElement()()()() | Initializes a new instance of the CodeElement class.

Properties

 | Name | Description
Public property | Attributes | Returns list of attributes.
Public property | BaseTypes | Returns base types for class or interface.
Public property | HasBaseTypes | Returns true if the class or interface has base types; otherwise, false.
Public property | HasGet | Returns true if the instance has a Get accessor; otherwise, false.
Public property | HasParameters | Returns true if the instance has parameters; otherwise, false.
Public property | HasReturnType | Returns true if the instance has return type; otherwise, false.
Public property | HasSet | Returns true if the instance has a Set accessor; otherwise, false.
Public property | HasTypeParameters | Returns true if the instance has type parameters; otherwise, false.
Public property | IsAbstract | Returns true if the instance is abstract; otherwise, false.
Public property | IsAsync | Returns true if the method is async; otherwise, false.
Public property | IsClass | Returns true if the instance is a class; otherwise, false.
Public property | IsConst | Returns true if the instance is constant; otherwise, false.
Public property | IsDelegate | Returns true if the instance is a delegate; otherwise, false.
Public property | IsEnum | Returns true if the instance is a enumeration; otherwise, false.
Public property | IsExtensionMethod | Returns true if the method is extension method; otherwise, false.
Public property | IsInterface | Returns true if the instance is an interface; otherwise, false.
Public property | IsInternal | Returns true if the instance is internal; otherwise, false.
Public property | IsMember | Returns true if the instance is a member; otherwise, false.
Public property | IsMethod | Returns true if the instance is a method; otherwise, false.
Public property | IsOperator | Returns true if the instance is an operator; otherwise, false.
Public property | IsPrivate | Returns true if the instance is private; otherwise, false.
Public property | IsProperty | Returns true if the instance is a property; otherwise, false.
Public property | IsProtected | Returns true if the instance is protected; otherwise, false.
Public property | IsProtectedInternal | Returns true if the instance is protected internal; otherwise, false.
Public property | IsPublic | Returns true if the instance is public; otherwise, false.
Public property | IsSealed | Returns true if the instance is sealed; otherwise, false.
Public property | IsStatic | Returns true if the instance is static; otherwise, false.
Public property | IsStruct | Returns true if the instance is a struct; otherwise, false.
Public property | IsVirtual | Returns true if the instance is virtual; otherwise, false.
Public property | Name | Returns name of the code element.
Public property | Parameters | Returns list of parameters.
Public property | Parent | Returns parent type for the member.
Public property | ReturnType | Returs code element return type.
Public property | TypeParameters | Returns list of type parameters.

See Also

CodeElement Class


CodeElement Constructor

Initializes a new instance of the CodeElement class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public CodeElement()
Public Sub New

Remarks

See Also

CodeElement Class
#ctor Overload


CodeElement Properties

The CodeElement type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Returns list of attributes.
Public property | BaseTypes | Returns base types for class or interface.
Public property | HasBaseTypes | Returns true if the class or interface has base types; otherwise, false.
Public property | HasGet | Returns true if the instance has a Get accessor; otherwise, false.
Public property | HasParameters | Returns true if the instance has parameters; otherwise, false.
Public property | HasReturnType | Returns true if the instance has return type; otherwise, false.
Public property | HasSet | Returns true if the instance has a Set accessor; otherwise, false.
Public property | HasTypeParameters | Returns true if the instance has type parameters; otherwise, false.
Public property | IsAbstract | Returns true if the instance is abstract; otherwise, false.
Public property | IsAsync | Returns true if the method is async; otherwise, false.
Public property | IsClass | Returns true if the instance is a class; otherwise, false.
Public property | IsConst | Returns true if the instance is constant; otherwise, false.
Public property | IsDelegate | Returns true if the instance is a delegate; otherwise, false.
Public property | IsEnum | Returns true if the instance is a enumeration; otherwise, false.
Public property | IsExtensionMethod | Returns true if the method is extension method; otherwise, false.
Public property | IsInterface | Returns true if the instance is an interface; otherwise, false.
Public property | IsInternal | Returns true if the instance is internal; otherwise, false.
Public property | IsMember | Returns true if the instance is a member; otherwise, false.
Public property | IsMethod | Returns true if the instance is a method; otherwise, false.
Public property | IsOperator | Returns true if the instance is an operator; otherwise, false.
Public property | IsPrivate | Returns true if the instance is private; otherwise, false.
Public property | IsProperty | Returns true if the instance is a property; otherwise, false.
Public property | IsProtected | Returns true if the instance is protected; otherwise, false.
Public property | IsProtectedInternal | Returns true if the instance is protected internal; otherwise, false.
Public property | IsPublic | Returns true if the instance is public; otherwise, false.
Public property | IsSealed | Returns true if the instance is sealed; otherwise, false.
Public property | IsStatic | Returns true if the instance is static; otherwise, false.
Public property | IsStruct | Returns true if the instance is a struct; otherwise, false.
Public property | IsVirtual | Returns true if the instance is virtual; otherwise, false.
Public property | Name | Returns name of the code element.
Public property | Parameters | Returns list of parameters.
Public property | Parent | Returns parent type for the member.
Public property | ReturnType | Returs code element return type.
Public property | TypeParameters | Returns list of type parameters.

See Also

CodeElement Class


Attributes Property

CodeElement..::..Attributes Property

Returns list of attributes.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Attribute[] Attributes { get; }
Public ReadOnly Property Attributes As Attribute()
    Get

Remarks

See Also

CodeElement Class


BaseTypes Property

CodeElement..::..BaseTypes Property

Returns base types for class or interface.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string[] BaseTypes { get; }
Public ReadOnly Property BaseTypes As String()
    Get

Remarks

See Also

CodeElement Class


HasBaseTypes Property

CodeElement..::..HasBaseTypes Property

Returns true if the class or interface has base types; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Remarks

See Also

CodeElement Class


HasGet Property

CodeElement..::..HasGet Property

Returns true if the instance has a Get accessor; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasGet { get; }
Public ReadOnly Property HasGet As Boolean
    Get

Remarks

See Also

CodeElement Class


HasParameters Property

CodeElement..::..HasParameters Property

Returns true if the instance has parameters; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Remarks

See Also

CodeElement Class


HasReturnType Property

CodeElement..::..HasReturnType Property

Returns true if the instance has return type; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasReturnType { get; }
Public ReadOnly Property HasReturnType As Boolean
    Get

Remarks

See Also

CodeElement Class


HasSet Property

CodeElement..::..HasSet Property

Returns true if the instance has a Set accessor; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasSet { get; }
Public ReadOnly Property HasSet As Boolean
    Get

Remarks

See Also

CodeElement Class


HasTypeParameters Property

CodeElement..::..HasTypeParameters Property

Returns true if the instance has type parameters; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Remarks

See Also

CodeElement Class


IsAbstract Property

CodeElement..::..IsAbstract Property

Returns true if the instance is abstract; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsAbstract { get; }
Public ReadOnly Property IsAbstract As Boolean
    Get

Remarks

See Also

CodeElement Class


IsAsync Property

CodeElement..::..IsAsync Property

Returns true if the method is async; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsAsync { get; }
Public ReadOnly Property IsAsync As Boolean
    Get

Remarks

See Also

CodeElement Class


IsClass Property

CodeElement..::..IsClass Property

Returns true if the instance is a class; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsClass { get; }
Public ReadOnly Property IsClass As Boolean
    Get

Remarks

See Also

CodeElement Class


IsConst Property

CodeElement..::..IsConst Property

Returns true if the instance is constant; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsConst { get; }
Public ReadOnly Property IsConst As Boolean
    Get

Remarks

See Also

CodeElement Class


IsDelegate Property

CodeElement..::..IsDelegate Property

Returns true if the instance is a delegate; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsDelegate { get; }
Public ReadOnly Property IsDelegate As Boolean
    Get

Remarks

See Also

CodeElement Class


IsEnum Property

CodeElement..::..IsEnum Property

Returns true if the instance is a enumeration; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsEnum { get; }
Public ReadOnly Property IsEnum As Boolean
    Get

Remarks

See Also

CodeElement Class


IsExtensionMethod Property

CodeElement..::..IsExtensionMethod Property

Returns true if the method is extension method; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsExtensionMethod { get; }
Public ReadOnly Property IsExtensionMethod As Boolean
    Get

Remarks

See Also

CodeElement Class


IsInterface Property

CodeElement..::..IsInterface Property

Returns true if the instance is an interface; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsInterface { get; }
Public ReadOnly Property IsInterface As Boolean
    Get

Remarks

See Also

CodeElement Class


IsInternal Property

CodeElement..::..IsInternal Property

Returns true if the instance is internal; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsInternal { get; }
Public ReadOnly Property IsInternal As Boolean
    Get

Remarks

See Also

CodeElement Class


IsMember Property

CodeElement..::..IsMember Property

Returns true if the instance is a member; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsMember { get; }
Public ReadOnly Property IsMember As Boolean
    Get

Remarks

See Also

CodeElement Class


IsMethod Property

CodeElement..::..IsMethod Property

Returns true if the instance is a method; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsMethod { get; }
Public ReadOnly Property IsMethod As Boolean
    Get

Remarks

See Also

CodeElement Class


IsOperator Property

CodeElement..::..IsOperator Property

Returns true if the instance is an operator; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsOperator { get; }
Public ReadOnly Property IsOperator As Boolean
    Get

Remarks

See Also

CodeElement Class


IsPrivate Property

CodeElement..::..IsPrivate Property

Returns true if the instance is private; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsPrivate { get; }
Public ReadOnly Property IsPrivate As Boolean
    Get

Remarks

See Also

CodeElement Class


IsProperty Property

CodeElement..::..IsProperty Property

Returns true if the instance is a property; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsProperty { get; }
Public ReadOnly Property IsProperty As Boolean
    Get

Remarks

See Also

CodeElement Class


IsProtected Property

CodeElement..::..IsProtected Property

Returns true if the instance is protected; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsProtected { get; }
Public ReadOnly Property IsProtected As Boolean
    Get

Remarks

See Also

CodeElement Class


IsProtectedInternal Property

CodeElement..::..IsProtectedInternal Property

Returns true if the instance is protected internal; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsProtectedInternal { get; }
Public ReadOnly Property IsProtectedInternal As Boolean
    Get

Remarks

See Also

CodeElement Class


IsPublic Property

CodeElement..::..IsPublic Property

Returns true if the instance is public; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsPublic { get; }
Public ReadOnly Property IsPublic As Boolean
    Get

Remarks

See Also

CodeElement Class


IsSealed Property

CodeElement..::..IsSealed Property

Returns true if the instance is sealed; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsSealed { get; }
Public ReadOnly Property IsSealed As Boolean
    Get

Remarks

See Also

CodeElement Class


IsStatic Property

CodeElement..::..IsStatic Property

Returns true if the instance is static; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get

Remarks

See Also

CodeElement Class


IsStruct Property

CodeElement..::..IsStruct Property

Returns true if the instance is a struct; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsStruct { get; }
Public ReadOnly Property IsStruct As Boolean
    Get

Remarks

See Also

CodeElement Class


IsVirtual Property

CodeElement..::..IsVirtual Property

Returns true if the instance is virtual; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsVirtual { get; }
Public ReadOnly Property IsVirtual As Boolean
    Get

Remarks

See Also

CodeElement Class


Name Property

CodeElement..::..Name Property

Returns name of the code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Remarks

See Also

CodeElement Class


Parameters Property

CodeElement..::..Parameters Property

Returns list of parameters.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Parameter[] Parameters { get; }
Public ReadOnly Property Parameters As Parameter()
    Get

Remarks

See Also

CodeElement Class


Parent Property

CodeElement..::..Parent Property

Returns parent type for the member.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public CodeElement Parent { get; }
Public ReadOnly Property Parent As CodeElement
    Get

Remarks

See Also

CodeElement Class


ReturnType Property

CodeElement..::..ReturnType Property

Returs code element return type.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public ReturnType ReturnType { get; }
Public ReadOnly Property ReturnType As ReturnType
    Get

Remarks

See Also

CodeElement Class


TypeParameters Property

CodeElement..::..TypeParameters Property

Returns list of type parameters.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public TypeParameter[] TypeParameters { get; }
Public ReadOnly Property TypeParameters As TypeParameter()
    Get

Remarks

See Also

CodeElement Class


Context Class

The Context class is the root class for all code for T4 rules.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static class Context
Public NotInheritable Class Context

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..Context

See Also

Context Members


Context Members

The Context type exposes the following members.

Methods

Name | Description
ContainsOfTheReordering | Determines whether the name contains "OfThe" reordering.
ExecMacro(String, String) | Executes macro for specific code element.
ExecMacro(String, String, String) | Executes macro for specific code element and parameter.
ExecMacro(String) | Executes macro for current code element.
GetExceptionTagText | Returns the exising exception tag text.
GetExistingExceptionTagText | Returns the exising exception tag text.
GetExistingSeeAlsoTags | Returns the exising seealso tags.
GetExistingTagText(String) | Returns the specified tag text.
GetExistingTagText(String, Int32) | Returns the specified tag text.
GetGlobalProperty | Returns property value.
GetInheritedTagText(String) | Returns inherited tag text.
GetInheritedTagText(String, Int32) | Returns inherited tag text.
GetNonGeneratedTags | Returns custom tags.
GetSettingValue | Returns the product configration setting value (from GhostDoc {Edition}.settings file).
GetSummaryOverride | Gets summary override for member name.
GetWords | Splits code element name into words.
HasExistingTagText(String) | Determines whether the specified tag exists in the context.
HasExistingTagText(String, Int32) | Determines whether the specified tag exists in the context.
HasInheritedTagText(String) | Determines whether inherited tag exists in the context.
HasInheritedTagText(String, Int32) | Determines whether inherited tag exists in the context.

Properties

Name | Description
AssemblyCompany | Returns assembly company.
AssemblyCopyright | Returns assembly copyright.
AssemblyName | Returns assembly name.
AssemblyVersion | Returns assembly version.
CurrentCodeElement | Returns current code element.
DestinationFile | Returns file name.
DestinationFileCreationDateTime | Returns file creation date.
DestinationFileModificationDateTime | Returns file modification date.
ExceptionDictionary | Returns dictionary of thrown exceptions with description.
ExceptionList | Returns list of thrown exceptions with description.
Exceptions | Returns list of thrown exceptions.
FileHeaderExistingAssembly | Returns file header existing assembly name.
FileHeaderExistingAuthor | Returns file header existing author.
FileHeaderExistingCopyrightCompany | Returns file header copyright company name.
FileHeaderExistingCopyrightFile | Returns file header copyright file name.
FileHeaderExistingCreatedDate | Returns file header created date.
FileHeaderExistingLastModifiedDate | Returns file header last modified date.
FileHeaderExistingLastModifiedUser | Returns file header last modified user.
HasExceptions | Returns true if the instance thrown exceptions; otherwise, false.

See Also

Context Class


Context Methods

The Context type exposes the following members.

Methods

Name | Description
ContainsOfTheReordering | Determines whether the name contains "OfThe" reordering.
ExecMacro(String, String) | Executes macro for specific code element.
ExecMacro(String, String, String) | Executes macro for specific code element and parameter.
ExecMacro(String) | Executes macro for current code element.
GetExceptionTagText | Returns the exising exception tag text.
GetExistingExceptionTagText | Returns the exising exception tag text.
GetExistingSeeAlsoTags | Returns the exising seealso tags.
GetExistingTagText(String) | Returns the specified tag text.
GetExistingTagText(String, Int32) | Returns the specified tag text.
GetGlobalProperty | Returns property value.
GetInheritedTagText(String) | Returns inherited tag text.
GetInheritedTagText(String, Int32) | Returns inherited tag text.
GetNonGeneratedTags | Returns custom tags.
GetSettingValue | Returns the product configration setting value (from GhostDoc {Edition}.settings file).
GetSummaryOverride | Gets summary override for member name.
GetWords | Splits code element name into words.
HasExistingTagText(String) | Determines whether the specified tag exists in the context.
HasExistingTagText(String, Int32) | Determines whether the specified tag exists in the context.
HasInheritedTagText(String) | Determines whether inherited tag exists in the context.
HasInheritedTagText(String, Int32) | Determines whether inherited tag exists in the context.

See Also

Context Class


ContainsOfTheReordering Method

Context..::..ContainsOfTheReordering Method

Determines whether the name contains "OfThe" reordering.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool ContainsOfTheReordering(
    string name
)
Public Shared Function ContainsOfTheReordering ( _
    name As String _
) As Boolean

Parameters

name
Type: String
The name.

Return Value

true if the name contains "OfThe" reordering; otherwise, false.

Remarks

See Also

Context Class


ExecMacro Method

Context..::..ExecMacro Method

Overload List

Name | Description
ExecMacro(String, String) | Executes macro for specific code element.
ExecMacro(String, String, String) | Executes macro for specific code element and parameter.
ExecMacro(String) | Executes macro for current code element.

See Also

Context Class
Context Members


ExecMacro Method (String, String)

Context..::..ExecMacro Method (String, String)

Executes macro for specific code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string ExecMacro(
    string name,
    string macroName
)
Public Shared Function ExecMacro ( _
    name As String, _
    macroName As String _
) As String

Parameters

name
Type: String
The type name.
macroName
Type: String
Name of the macro.

Return Value

Remarks

See Also

Context Class
ExecMacro Overload


ExecMacro Method (String, String, String)

Context..::..ExecMacro Method (String, String, String)

Executes macro for specific code element and parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string ExecMacro(
    string name,
    string macroName,
    string parameter
)
Public Shared Function ExecMacro ( _
    name As String, _
    macroName As String, _
    parameter As String _
) As String

Parameters

name
Type: String
The name.
macroName
Type: String
Name of the macro.
parameter
Type: String
The parameter.

Return Value

Remarks

See Also

Context Class
ExecMacro Overload


ExecMacro Method (String)

Context..::..ExecMacro Method (String)

Executes macro for current code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string ExecMacro(
    string macroName
)
Public Shared Function ExecMacro ( _
    macroName As String _
) As String

Parameters

macroName
Type: String
Name of the macro.

Return Value

Remarks

See Also

Context Class
ExecMacro Overload


GetExceptionTagText Method

Context..::..GetExceptionTagText Method

Returns the exising exception tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetExceptionTagText(
    ICollection<string> exceptionArguments
)
Public Shared Function GetExceptionTagText ( _
    exceptionArguments As ICollection(Of String) _
) As String

Parameters

exceptionArguments
Type: ICollection <(Of <(<' String >)>)>
The exception arguments.

Return Value

The exising exception tag text.

See Also

Context Class


GetExistingExceptionTagText Method

Context..::..GetExistingExceptionTagText Method

Returns the exising exception tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetExistingExceptionTagText(
    string exceptionType
)
Public Shared Function GetExistingExceptionTagText ( _
    exceptionType As String _
) As String

Parameters

exceptionType
Type: String
The exception type.

Return Value

The exising exception tag text.

See Also

Context Class


GetExistingSeeAlsoTags Method

Context..::..GetExistingSeeAlsoTags Method

Returns the exising seealso tags.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string[] GetExistingSeeAlsoTags()
Public Shared Function GetExistingSeeAlsoTags As String()

Return Value

The exising seealso tags.

See Also

Context Class


GetExistingTagText Method

Context..::..GetExistingTagText Method

Overload List

Name | Description
GetExistingTagText(String) | Returns the specified tag text.
GetExistingTagText(String, Int32) | Returns the specified tag text.

See Also

Context Class
Context Members


GetExistingTagText Method (String)

Context..::..GetExistingTagText Method (String)

Returns the specified tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetExistingTagText(
    string tag
)
Public Shared Function GetExistingTagText ( _
    tag As String _
) As String

Parameters

tag
Type: String
The tag.

Return Value

Remarks

See Also

Context Class
GetExistingTagText Overload


GetExistingTagText Method (String, Int32)

Context..::..GetExistingTagText Method (String, Int32)

Returns the specified tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetExistingTagText(
    string tag,
    int index
)
Public Shared Function GetExistingTagText ( _
    tag As String, _
    index As Integer _
) As String

Parameters

tag
Type: String
The tag.
index
Type: Int32
The index.

Return Value

Remarks

See Also

Context Class
GetExistingTagText Overload


GetGlobalProperty Method

Context..::..GetGlobalProperty Method

Returns property value.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetGlobalProperty(
    string propertyName
)
Public Shared Function GetGlobalProperty ( _
    propertyName As String _
) As String

Parameters

propertyName
Type: String

Remarks

See Also

Context Class


GetInheritedTagText Method

Context..::..GetInheritedTagText Method

Overload List

Name | Description
GetInheritedTagText(String) | Returns inherited tag text.
GetInheritedTagText(String, Int32) | Returns inherited tag text.

See Also

Context Class
Context Members


GetInheritedTagText Method (String)

Context..::..GetInheritedTagText Method (String)

Returns inherited tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetInheritedTagText(
    string tag
)
Public Shared Function GetInheritedTagText ( _
    tag As String _
) As String

Parameters

tag
Type: String
The tag.

Return Value

Remarks

See Also

Context Class
GetInheritedTagText Overload


GetInheritedTagText Method (String, Int32)

Context..::..GetInheritedTagText Method (String, Int32)

Returns inherited tag text.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetInheritedTagText(
    string tag,
    int index
)
Public Shared Function GetInheritedTagText ( _
    tag As String, _
    index As Integer _
) As String

Parameters

tag
Type: String
The tag.
index
Type: Int32
The index.

Return Value

Remarks

See Also

Context Class
GetInheritedTagText Overload


GetNonGeneratedTags Method

Context..::..GetNonGeneratedTags Method

Returns custom tags.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetNonGeneratedTags()
Public Shared Function GetNonGeneratedTags As String

Return Value

Remarks

See Also

Context Class


GetSettingValue Method

Context..::..GetSettingValue Method

Returns the product configration setting value (from GhostDoc {Edition}.settings file).

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static Object GetSettingValue(
    string name,
    Object defaultValue
)
Public Shared Function GetSettingValue ( _
    name As String, _
    defaultValue As Object _
) As Object

Parameters

name
Type: String
Setting name.
defaultValue
Type: Object
Setting default value.

Return Value

Setting value.

See Also

Context Class


GetSummaryOverride Method

Context..::..GetSummaryOverride Method

Gets summary override for member name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string GetSummaryOverride(
    string memberName
)
Public Shared Function GetSummaryOverride ( _
    memberName As String _
) As String

Parameters

memberName
Type: String
The member name.

Return Value

Summary override for member.

See Also

Context Class


GetWords Method

Context..::..GetWords Method

Splits code element name into words.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static Words GetWords(
    string name
)
Public Shared Function GetWords ( _
    name As String _
) As Words

Parameters

name
Type: String
The name.

Return Value

Remarks

See Also

Context Class


HasExistingTagText Method

Context..::..HasExistingTagText Method

Overload List

Name | Description
HasExistingTagText(String) | Determines whether the specified tag exists in the context.
HasExistingTagText(String, Int32) | Determines whether the specified tag exists in the context.

See Also

Context Class
Context Members


HasExistingTagText Method (String)

Context..::..HasExistingTagText Method (String)

Determines whether the specified tag exists in the context.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool HasExistingTagText(
    string tag
)
Public Shared Function HasExistingTagText ( _
    tag As String _
) As Boolean

Parameters

tag
Type: String
The tag.

Return Value

true if specified tag exists; otherwise, false.

Remarks

See Also

Context Class
HasExistingTagText Overload


HasExistingTagText Method (String, Int32)

Context..::..HasExistingTagText Method (String, Int32)

Determines whether the specified tag exists in the context.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool HasExistingTagText(
    string tag,
    int index
)
Public Shared Function HasExistingTagText ( _
    tag As String, _
    index As Integer _
) As Boolean

Parameters

tag
Type: String
The tag.
index
Type: Int32
The index.

Return Value

true if specified tag exists; otherwise, false.

Remarks

See Also

Context Class
HasExistingTagText Overload


HasInheritedTagText Method

Context..::..HasInheritedTagText Method

Overload List

Name | Description
HasInheritedTagText(String) | Determines whether inherited tag exists in the context.
HasInheritedTagText(String, Int32) | Determines whether inherited tag exists in the context.

See Also

Context Class
Context Members


HasInheritedTagText Method (String)

Context..::..HasInheritedTagText Method (String)

Determines whether inherited tag exists in the context.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool HasInheritedTagText(
    string tag
)
Public Shared Function HasInheritedTagText ( _
    tag As String _
) As Boolean

Parameters

tag
Type: String
The tag.

Return Value

true if the inherited tag exists; otherwise, false.

Remarks

See Also

Context Class
HasInheritedTagText Overload


HasInheritedTagText Method (String, Int32)

Context..::..HasInheritedTagText Method (String, Int32)

Determines whether inherited tag exists in the context.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool HasInheritedTagText(
    string tag,
    int index
)
Public Shared Function HasInheritedTagText ( _
    tag As String, _
    index As Integer _
) As Boolean

Parameters

tag
Type: String
The tag.
index
Type: Int32
The index.

Return Value

true if the inherited tag exists; otherwise, false.

Remarks

See Also

Context Class
HasInheritedTagText Overload


Context Properties

The Context type exposes the following members.

Properties

Name | Description
AssemblyCompany | Returns assembly company.
AssemblyCopyright | Returns assembly copyright.
AssemblyName | Returns assembly name.
AssemblyVersion | Returns assembly version.
CurrentCodeElement | Returns current code element.
DestinationFile | Returns file name.
DestinationFileCreationDateTime | Returns file creation date.
DestinationFileModificationDateTime | Returns file modification date.
ExceptionDictionary | Returns dictionary of thrown exceptions with description.
ExceptionList | Returns list of thrown exceptions with description.
Exceptions | Returns list of thrown exceptions.
FileHeaderExistingAssembly | Returns file header existing assembly name.
FileHeaderExistingAuthor | Returns file header existing author.
FileHeaderExistingCopyrightCompany | Returns file header copyright company name.
FileHeaderExistingCopyrightFile | Returns file header copyright file name.
FileHeaderExistingCreatedDate | Returns file header created date.
FileHeaderExistingLastModifiedDate | Returns file header last modified date.
FileHeaderExistingLastModifiedUser | Returns file header last modified user.
HasExceptions | Returns true if the instance thrown exceptions; otherwise, false.

See Also

Context Class


AssemblyCompany Property

Context..::..AssemblyCompany Property

Returns assembly company.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string AssemblyCompany { get; }
Public Shared ReadOnly Property AssemblyCompany As String
    Get

Remarks

See Also

Context Class


AssemblyCopyright Property

Context..::..AssemblyCopyright Property

Returns assembly copyright.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string AssemblyCopyright { get; }
Public Shared ReadOnly Property AssemblyCopyright As String
    Get

Remarks

See Also

Context Class


AssemblyName Property

Context..::..AssemblyName Property

Returns assembly name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string AssemblyName { get; }
Public Shared ReadOnly Property AssemblyName As String
    Get

Remarks

See Also

Context Class


AssemblyVersion Property

Context..::..AssemblyVersion Property

Returns assembly version.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string AssemblyVersion { get; }
Public Shared ReadOnly Property AssemblyVersion As String
    Get

Remarks

See Also

Context Class


CurrentCodeElement Property

Context..::..CurrentCodeElement Property

Returns current code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static CodeElement CurrentCodeElement { get; }
Public Shared ReadOnly Property CurrentCodeElement As CodeElement
    Get

Remarks

See Also

Context Class


DestinationFile Property

Context..::..DestinationFile Property

Returns file name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string DestinationFile { get; }
Public Shared ReadOnly Property DestinationFile As String
    Get

Remarks

See Also

Context Class


DestinationFileCreationDateTime Property

Context..::..DestinationFileCreationDateTime Property

Returns file creation date.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static DateTime DestinationFileCreationDateTime { get; }
Public Shared ReadOnly Property DestinationFileCreationDateTime As DateTime
    Get

Remarks

See Also

Context Class


DestinationFileModificationDateTime Property

Context..::..DestinationFileModificationDateTime Property

Returns file modification date.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static DateTime DestinationFileModificationDateTime { get; }
Public Shared ReadOnly Property DestinationFileModificationDateTime As DateTime
    Get

Remarks

See Also

Context Class


ExceptionDictionary Property

Context..::..ExceptionDictionary Property

Returns dictionary of thrown exceptions with description.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static Dictionary<string, ICollection<string>> ExceptionDictionary { get; }
Public Shared ReadOnly Property ExceptionDictionary As Dictionary(Of String, ICollection(Of String))
    Get

Remarks

See Also

Context Class


ExceptionList Property

Context..::..ExceptionList Property

Returns list of thrown exceptions with description.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static Dictionary<string, string> ExceptionList { get; }
Public Shared ReadOnly Property ExceptionList As Dictionary(Of String, String)
    Get

Remarks

See Also

Context Class


Exceptions Property

Context..::..Exceptions Property

Returns list of thrown exceptions.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string[] Exceptions { get; }
Public Shared ReadOnly Property Exceptions As String()
    Get

Remarks

See Also

Context Class


FileHeaderExistingAssembly Property

Context..::..FileHeaderExistingAssembly Property

Returns file header existing assembly name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingAssembly { get; }
Public Shared ReadOnly Property FileHeaderExistingAssembly As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingAuthor Property

Context..::..FileHeaderExistingAuthor Property

Returns file header existing author.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingAuthor { get; }
Public Shared ReadOnly Property FileHeaderExistingAuthor As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingCopyrightCompany Property

Context..::..FileHeaderExistingCopyrightCompany Property

Returns file header copyright company name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingCopyrightCompany { get; }
Public Shared ReadOnly Property FileHeaderExistingCopyrightCompany As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingCopyrightFile Property

Context..::..FileHeaderExistingCopyrightFile Property

Returns file header copyright file name.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingCopyrightFile { get; }
Public Shared ReadOnly Property FileHeaderExistingCopyrightFile As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingCreatedDate Property

Context..::..FileHeaderExistingCreatedDate Property

Returns file header created date.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingCreatedDate { get; }
Public Shared ReadOnly Property FileHeaderExistingCreatedDate As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingLastModifiedDate Property

Context..::..FileHeaderExistingLastModifiedDate Property

Returns file header last modified date.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingLastModifiedDate { get; }
Public Shared ReadOnly Property FileHeaderExistingLastModifiedDate As String
    Get

Remarks

See Also

Context Class


FileHeaderExistingLastModifiedUser Property

Context..::..FileHeaderExistingLastModifiedUser Property

Returns file header last modified user.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static string FileHeaderExistingLastModifiedUser { get; }
Public Shared ReadOnly Property FileHeaderExistingLastModifiedUser As String
    Get

Remarks

See Also

Context Class


HasExceptions Property

Context..::..HasExceptions Property

Returns true if the instance thrown exceptions; otherwise, false.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public static bool HasExceptions { get; }
Public Shared ReadOnly Property HasExceptions As Boolean
    Get

Remarks

See Also

Context Class


Parameter Class

Parameter of the code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public class Parameter
Public Class Parameter

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..Parameter

See Also

Parameter Members


Parameter Members

The Parameter type exposes the following members.

Constructors

 | Name | Description
Public method | Parameter(IParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(IScriptParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(CodeParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(CodeParameter, Int32, CodeLanguage) | Initializes a new instance of the Parameter class.

Properties

 | Name | Description
Public property | Attributes | Returns list of attributes.
Public property | Index | Returns index of the parameter.
Public property | Name | Returns name of the parameter.
Public property | ParameterKind | Returns the parameter kind.
Public property | ReturnType | Returns return type of the parameter.

See Also

Parameter Class


Parameter Constructor

Overload List

 | Name | Description
Public method | Parameter(IParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(IScriptParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(CodeParameter, Int32) | Initializes a new instance of the Parameter class.
Public method | Parameter(CodeParameter, Int32, CodeLanguage) | Initializes a new instance of the Parameter class.

See Also

Parameter Class
Parameter Members


Parameter Constructor (IParameter, Int32)

Initializes a new instance of the Parameter class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Parameter(
    IParameter parameterInfo,
    int index
)
Public Sub New ( _
    parameterInfo As IParameter, _
    index As Integer _
)

Parameters

parameterInfo
Type: IParameter
The parameter info.
index
Type: Int32
The index.

Remarks

See Also

Parameter Class
Parameter Overload


Parameter Constructor (IScriptParameter, Int32)

Initializes a new instance of the Parameter class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Parameter(
    IScriptParameter parameter,
    int index
)
Public Sub New ( _
    parameter As IScriptParameter, _
    index As Integer _
)

Parameters

parameter
Type: IScriptParameter
The parameter.
index
Type: Int32
The index.

Remarks

See Also

Parameter Class
Parameter Overload


Parameter Constructor (CodeParameter, Int32)

Initializes a new instance of the Parameter class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Parameter(
    CodeParameter parameterInfo,
    int index
)
Public Sub New ( _
    parameterInfo As CodeParameter, _
    index As Integer _
)

Parameters

parameterInfo
Type: CodeParameter
The parameter info.
index
Type: Int32
The index.

Remarks

See Also

Parameter Class
Parameter Overload


Parameter Constructor (CodeParameter, Int32, CodeLanguage)

Initializes a new instance of the Parameter class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Parameter(
    CodeParameter parameterInfo,
    int index,
    CodeLanguage language
)
Public Sub New ( _
    parameterInfo As CodeParameter, _
    index As Integer, _
    language As CodeLanguage _
)

Parameters

parameterInfo
Type: CodeParameter
The parameter info.
index
Type: Int32
The index.
language
Type: CodeLanguage
The language.

Remarks

See Also

Parameter Class
Parameter Overload


Parameter Properties

The Parameter type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Returns list of attributes.
Public property | Index | Returns index of the parameter.
Public property | Name | Returns name of the parameter.
Public property | ParameterKind | Returns the parameter kind.
Public property | ReturnType | Returns return type of the parameter.

See Also

Parameter Class


Attributes Property

Parameter..::..Attributes Property

Returns list of attributes.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public Attribute[] Attributes { get; }
Public ReadOnly Property Attributes As Attribute()
    Get

Remarks

See Also

Parameter Class


Index Property

Parameter..::..Index Property

Returns index of the parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Remarks

See Also

Parameter Class


Name Property

Parameter..::..Name Property

Returns name of the parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Remarks

See Also

Parameter Class


ParameterKind Property

Parameter..::..ParameterKind Property

Returns the parameter kind.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public int ParameterKind { get; }
Public ReadOnly Property ParameterKind As Integer
    Get

Remarks

The property returns a value of EnvDTE80.vsCMParameterKind enumeration

See Also

Parameter Class


ReturnType Property

Parameter..::..ReturnType Property

Returns return type of the parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public ReturnType ReturnType { get; }
Public ReadOnly Property ReturnType As ReturnType
    Get

Remarks

See Also

Parameter Class


ReturnType Class

Return type of the code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public class ReturnType
Public Class ReturnType

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..ReturnType

See Also

ReturnType Members


ReturnType Members

The ReturnType type exposes the following members.

Constructors

 | Name | Description
Public method | ReturnType()()()() | Initializes a new instance of the ReturnType class.
Public method | ReturnType(String, Boolean) | Initializes a new instance of the ReturnType class.

Properties

 | Name | Description
Public property | FullName | Returns full name of the code element.
Public property | IsNullable | Returns true of return type is nullable.

See Also

ReturnType Class


ReturnType Constructor

Overload List

 | Name | Description
Public method | ReturnType()()()() | Initializes a new instance of the ReturnType class.
Public method | ReturnType(String, Boolean) | Initializes a new instance of the ReturnType class.

See Also

ReturnType Class
ReturnType Members


ReturnType Constructor

Initializes a new instance of the ReturnType class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public ReturnType()
Public Sub New

Remarks

See Also

ReturnType Class
ReturnType Overload


ReturnType Constructor (String, Boolean)

Initializes a new instance of the ReturnType class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public ReturnType(
    string fullName,
    bool isNullable
)
Public Sub New ( _
    fullName As String, _
    isNullable As Boolean _
)

Parameters

fullName
Type: String
The full name.
isNullable
Type: Boolean
Is nullable.

Remarks

See Also

ReturnType Class
ReturnType Overload


ReturnType Properties

The ReturnType type exposes the following members.

Properties

 | Name | Description
Public property | FullName | Returns full name of the code element.
Public property | IsNullable | Returns true of return type is nullable.

See Also

ReturnType Class


FullName Property

ReturnType..::..FullName Property

Returns full name of the code element.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get

Remarks

See Also

ReturnType Class


IsNullable Property

ReturnType..::..IsNullable Property

Returns true of return type is nullable.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public bool IsNullable { get; }
Public ReadOnly Property IsNullable As Boolean
    Get

Remarks

See Also

ReturnType Class


TypeParameter Class

Type parameter of type or method.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public class TypeParameter
Public Class TypeParameter

Remarks

Inheritance Hierarchy

Object
SubMain.GhostDoc.T4..::..TypeParameter

See Also

TypeParameter Members


TypeParameter Members

The TypeParameter type exposes the following members.

Constructors

 | Name | Description
Public method | TypeParameter | Initializes a new instance of the TypeParameter class.

Properties

 | Name | Description
Public property | Index | Returns index of the type parameter.
Public property | Name | Returns name of the type parameter.

See Also

TypeParameter Class


TypeParameter Constructor

Initializes a new instance of the TypeParameter class.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public TypeParameter(
    string typeParameterName,
    int index
)
Public Sub New ( _
    typeParameterName As String, _
    index As Integer _
)

Parameters

typeParameterName
Type: String
Name of the type parameter.
index
Type: Int32
The index.

Remarks

See Also

TypeParameter Class


TypeParameter Properties

The TypeParameter type exposes the following members.

Properties

 | Name | Description
Public property | Index | Returns index of the type parameter.
Public property | Name | Returns name of the type parameter.

See Also

TypeParameter Class


Index Property

TypeParameter..::..Index Property

Returns index of the type parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Remarks

See Also

TypeParameter Class


Name Property

TypeParameter..::..Name Property

Returns name of the type parameter.

Namespace: SubMain.GhostDoc.T4
Assembly: PackagePro.clr4.6 (in PackagePro.clr4.6.dll)

Syntax

C#
VB
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Remarks

See Also

TypeParameter Class