TX Text Control .NET Programmer's Guide

Welcome to TX Text Control, the text processor in a single .NET control. Using TX Text Control, you can create all kinds of text-based applications with the ease of programming that is characteristic of the .NET Framework and with highly sophisticated formatting and display capabilities which are normally the exclusive domain of large word processing packages.

As an aid to help you locate the information that interests you most, the following section lists and describes the main areas of the documentation.

  • Introduction

    This part provides information about the system requirements you need and how to obtain support.

  • What's New

    This part discusses the new features introduced in the last TX Text Control releases.

  • Windows Forms User's Guide

    This guide describes how to create TX Text Control Windows Forms applications and browser-based TX Text Control Windows Forms applications which run in Microsoft Internet Explorer. All examples are available either for Microsoft Visual Basic .NET or Microsoft Visual C# .NET. To run these examples you have to install TXTextControl .NET for Windows Forms.

  • Windows Presentation Foundation User's Guide

    This guide describes how to create TX Text Control WPF applications (.exe) and TX Text Control WPF browser applications (.xbap) which run in Microsoft Internet Explorer. All examples are available either for Microsoft Visual Basic .NET or Microsoft Visual C# .NET. To run these examples you have to install TXTextControl .NET for WPF.

  • ASP.NET User's Guide

    This part describes how to create ASP.NET applications using TX Text Control .NET Server with Microsoft Visual Basic .NET and Microsoft Visual C# .NET.

  • Text Control Reporting User's Guide

    This guide describes how to use the Reporting and Mail Merge features of TX Text Control within Windows Forms, WPF and ASP.NET applications.

  • Distributing your Applications

    This chapter describes how to create a setup program for your application.

  • Technical Articles

    This part informs about TX Text Control's programming capabilities in more depth.

  • Class Library Overview

    This part contains an overview of the TX Text Control Class Library sorted by programming categories. Graphical charts give an overview how the different classes work together. A porting reference helps to port an application using TX Text Control from the ActiveX to the .NET technology.

  • Class Library Reference

    The Text Control .NET class library in detail and alphabetical order.


Introduction

This part provides information about the system requirements you need and how to obtain support.

System Requirements

Updating your Project from a prior TX Text Control Version

TX Text Control 32bit and 64bit Edition

How to Obtain Support

Legal Notice


System Requirements

TX Text Control .NET requires one of the following Windows versions:

  • Windows XP SP3
  • Windows Server 2003
  • Windows Vista
  • Windows Server 2008
  • Windows 7
  • Windows 8
  • Windows 8.1

TX Text Control .NET supports the following development enviroments or scripting engines:

  • Microsoft Visual Basic .NET
  • Microsoft Visual C# .NET
  • Borland Delphi 2005
  • Microsoft Internet Explorer 7.0 or higher
  • Microsoft Internet Information Server 6.0, 7.0, 7.5

TX Text Control .NET supports the following Microsoft .NET Frameworks:

  • .NET 2.0
  • .NET 3.0
  • .NET 3.5
  • .NET 4.0
  • .NET 4.5

When TX Text Control .NET is used in a .NET 4.0 application, TX Text Control .NET automatically binds the current runtime for all legacy common language runtime (CLR) version 2 activation policy decisions.


Updating your Project from a prior TX Text Control Version

The easiest way to adapt your Visual Studio .NET project from a prior to a newer TX Text Control version is to deinstall your prior version before installing the newer TX Text Control version. In this case your project is automatically adapted through the Visual Studio .NET development environment.

If you have installed more than one TX Text Control version perform the following steps:

  • Load your Visual Studio .NET project.
  • Open the Add Reference... dialog box in the Project... menu.
  • Delete the references to the current TX Text Control version.
  • Add the required references to the new version and close the dialog box.
  • Open the licenses.licx file of your project and change the version number of the referenced TX Text Control version to the version number of the newer TX Text Control version. The current version number can be found in Redistributable Files.
  • Close the Visual Studio .NET development environment.
  • Reopen the Visual Studio .NET development environment.
  • Rebuild your project using the Rebuild Solution menu item.


TX Text Control 32bit and 64bit Edition

TX Text Control .NET is shipped with separate sets of distributable files developed and compiled for 32bit and 64bit processors. To create a 64bit application, the project must be compiled with an x64 build configuration. To create an application that runs on both 32bit and 64bit platforms, the project must be compiled with an x86 build configuration. All TX Text Control sample programs come with a project file containing these two build configurations. More information how to deploy your application is contained in the chapter Distributing your Applications.


How to Obtain Support

Every registered and free trial version user can benefit from our free, technical support.

Our support team provides several information sources for technical details. A good starting point for getting information is the TX Text Control Support Forum. Here you can post your problems and discuss it with our support staff and other experienced TX Text Control users.

If you are searching for further samples, then please have a look at the Source Code Library. This library has additional samples that are not provided in this release and is updated with new samples frequently.

If you would like to contact us via e-mail, we would be very obliged if you would use the Support Form.

We understand that there are some support cases where a one-to-one talk can solve some programming problem much quicker than endless e-mails.

Our customer services representatives and support agents speak English and German and are available to assist with all your sales and technical queries.

Contact Information

Please visit our website for contact details:

http://www.textcontrol.com/contact/info/


Legal Notice

Information in this document is subject to change without notice and does not represent a commitment on the part of Text Control GmbH. The Software described in this document is furnished under a license agreement. The Software may only be used or copied in accordance with the terms of this agreement.

Copyright 1991-2017 Text Control GmbH. All rights reserved.

Microsoft, Windows, Visual Basic .NET, Visual C#, Developer Studio are either registered trademarks or trademarks of Microsoft Corporation in the USA and/or other countries.

Borland, Delphi are Trademarks of Borland Software Corporation.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


What's New

This part discusses the new features introduced in the last TX Text Control releases.

What's New in Version 24.0

What's New in Version 23.0

What's New in Version 22.0

What's New in Version 21.0

What's New in Version 20.0

What's New in Version 19.0

What's New in Version 18.0

What's New in Version 17.0

What's New in Version 16.0

What's New in Version 15.1

What's New in Version 15.0

What's New in Version 14.0

What's New in Version 13.0

What's New in Version 12.0

What's New in Version 11.0

What's New in Version 10.1


What's New in Version 24.0

The following provides a general list of features that have been added since TX Text Control version 23.0.

New Features

New Classes, Properties, Methods and Events for Windows Forms

New Classes, Properties, Methods and Events for WPF

New Classes, Properties, Methods and Events for ASP.NET

Update Notes


New Features

TX Text Control 24.0 provides the following new features:

New Features

Feature | Description
Windows Forms Ribbon Controls | The TXTextControl class library offers now classes to build Windows Forms applications with a ribbon instead of a menu and toolbars. The main window must inherit from the new RibbonForm class which can draw a Ribbon Quick Access Toolbar and contextual tabs in its border. An instance of the Ribbon, docked at the top of the main window, hosts an Application Menu as its first tab and organizes the features of an application into a series of tabs, presented through RibbonTab controls. These controls then host a variety of button and menu controls, organized in groups, that enable access to application commands. Predefined tabs, such as the RibbonFormattingTab or the RibbonInsertTab support all generic features of a TextControl, so that an application with rich text editing features can quickly be developed. A Ribbon can also contain groups of contextual tabs which dynamically displays controls that are only relevant in a particular context. A group can be added to the ContextualTabGroupCollection available through the ribbon's ContextualTabGroups property.
WPF Ribbon Controls | In addition to the WPF.RibbonFormattingTab and WPF.RibbonInsertTab classes five new predefined ribbon tabs have been added. The WPF.RibbonFrameLayoutTab can be used to alter the attributes of images, text frames, barcodes and drawings, the WPF.RibbonTableLayoutTab handles the layout and the attributes of a table and the WPF.RibbonPageLayoutTab has elements to set page attributes such as margins, page size, columns and document frames. The WPF.RibbonProofingTab can be used to check spelling and hyphenation and the WPF.RibbonViewTab offers elements to alter the document's view. All classes are inherited from the System.Windows.Controls.Ribbon.RibbonTab class and can be hosted in a System.Windows.Controls.Ribbon.Ribbon object. They can be connected with a WPF.TextControl through the WPF.TextControl.RibbonFrameLayoutTab, WPF.TextControl.RibbonTableLayoutTab, WPF.TextControl.RibbonPageLayoutTab WPF.TextControl.RibbonProofingTab and WPF.TextControl.RibbonViewTab properties. To use the TX Text Control Ribbon Controls, Microsoft Ribbon for WPF 3.5 must be installed.
Colored Paragraphs | A paragraph's background and the lines of a paragraph frame can be colored. The properties ParagraphFormat.BackColor and ParagraphFormat.FrameLineColor can be used to get or to set such colors. The InputFormat class, the built-in dialog box for setting paragraph attributes, the TX Text Control file format and all text filters have been extended to support this feature.
Zooming | Zooming has been extended with new zoom options. These options can be used to zoom the contents of a TextControl or WPF.TextControl so that either the whole page, the complete width of a page or the complete text of a line becomes visible. They can be used with the new Zoom method. The StatusBar and WPF.StatusBar have been extended with two new buttons to support this feature.
User-Defined Document Properties | User-defined document properties can now be saved and loaded with the TX Text Control file format, the Rich Text Format (rtf) and the Microsoft Word formats (doc, docx). The new SaveSettings.UserDefinedDocumentProperties property accepts an object of the type UserDefinedPropertyDictionary which can contain a number of document properties, which are saved in the document. The dictionary allows properties of the types System.String, System.Boolean, System.Int32 and System.Double. After a document has been loaded these properties are available through the LoadSettings.UserDefinedDocumentProperties property.
Toolbars | The ButtonBar, RulerBar and WPF.RulerBar can be set to read only now. When such a tool bar is set to read only, it still shows all formatting attributes of the connected TextControl or WPF.TextControl, but formatting attributes cannot be changed.
TextField Programming | The new IFormattedText.GetTextFields method returns a collection of text fields of one or more field types. When more than one field type is specified the returned collection contains all fields of these types in the same order as the fields are contained in the document. The new PageNumberFieldCollection.GetItem method gets a particular page number field from a page number field collection.
Text Formatting | The InputFormat class has some new properties which support the setting of colors, frames and text alignment. The InputFormat.TopAligned, InputFormat.BottomAligned and InputFormat.VerticallyCentered properties can be used to set the text alignment, InputFormat.FrameFillColor and InputFormat.FrameLineColor set colors for the table cell background and the frame color and InputFormat.FrameLineWidth sets the width of frame lines.
PDF Import | PDF import now supports encrypted files. Please refer to the chapter Loading Encrypted PDF files in the Technical Articles part of this manual.
Error Handling | New classes have been implemented to enable a better exception handling. A TextControl throws a TextEditorException when an error occurs during text editing and a FilterException, if an error occurs when a text filter is used to convert a document to or from another format. The LicenseLevelException is thrown, when a feature is not contained in the currently licensed product level. The TX Text Control class library explicitly throws an ArgumentException, an ArgumentNullException or an ArgumentOutOfRangeException, when the parameter of a called method or the value of a set property has a wrong value. Furthermore, an InvalidOperationException is thrown when a method call is invalid for the object's current state.
Sections and Pages | The new TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods return the names and the sizes of all currently supported paper sizes. These paper sizes depend on the formatting device set with the TextControl.FormattingPrinter or WPF.TextControl.FormattingPrinter property.
Server Visualization | The ServerVisualization.View class provides further overloads of the GetImage method to get a clipping of the view's image. The view's Changed event informs about the clipping's position and size. When the view must be updated as a result of scrolling, the new ServerVisualization.ViewChangedEventArgs class provides information about the distance and the scroll orientation. Scrolling occurs either through setting the view's location in the document or through autoscrolling initiated through the control when the input position leaves the visible part of the document. Selected text can now be dragged and dropped at another position in the document. The TextViewGenerator.AllowDrag and TextViewGenerator.AllowDrop properties must be set to true to switch on this feature.
Mail Merge and Reporting | The MailMerge class now provides the possibility to merge JSON data via the method MailMerge.MergeJsonData. The JSON data can contain either a single object or an array of equally structured objects. Furthermore, most of the events fired during a merge process have been enhanced in such a way that it is easier to figure out from where inside the document template the event was fired.
Web Editor | In addition to XML files and DataSet objects the web editor can now also handle JSON and object based data sources via the new methods LoadDataFromJson and LoadDataFromModel.
Web Editor Programming | The JavaScript API of the Text Control Web Editor has been enhanced substantially. For example, it is now possible to load an XML database, set and load text into the current selection, retrieve the document text parts or set the control colors via new JavaScript functions and properties. Also a few events which are fired by the editor have been added (see TXTextControl.addEventListener).


New Classes, Properties, Methods and Events for Windows Forms

In TX Text Control 24.0 for Windows Forms the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DocumentServer.DataSources.DataColumnInfo | The DataColumnInfo class provides basic information about a table column in a data source.
TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection | An instance of the DataColumnInfoCollection class contains all data columns of a data table in a data source represented through objects of the type DataColumnInfo.
TXTextControl.DocumentServer.DataSources.DataRelationInfo | The DataRelationInfo class provides all necessary information about parent-child-relations between data tables.
TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection | An instance of the DataRelationInfoCollection class contains all data relations in a data source represented through objects of the type DataRelationInfo.
TXTextControl.DocumentServer.DataSources.DataSourceManager | The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class.
TXTextControl.DocumentServer.DataSources.DataTableInfo | The DataTableInfo class provides basic information about a data table in a data source.
TXTextControl.DocumentServer.DataSources.DataTableInfoCollection | An instance of the DataTableInfoCollection class contains all data tables in a data source represented through objects of the type DataTableInfo.
TXTextControl.DocumentServer.DataSources.MergeBlockInfo | The MergeBlockInfo class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.DataSources.MergeBlockSettings | The MergeBlockSettings class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.Json.InvalidCodePointException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an invalid hexadecimal unicode code point.
TXTextControl.DocumentServer.Json.InvalidNumberFormatException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing a number with an invalid number format.
TXTextControl.DocumentServer.Json.ParserException | Base class of all JSON parser related exceptions which can be thrown when calling method MailMerge.MergeJsonData with an incorrect JSON string.
TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException | Is thrown when calling method MailMerge.MergeJsonData with an incomplete JSON string.
TXTextControl.DocumentServer.Json.UnexpectedTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unexpected character.
TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unknown character sequence at a position where one of the strings "true", "false" or "null" are expected.
TXTextControl.DocumentServer.Json.UnknownParseErrorException | Is thrown when calling method MailMerge.MergeJsonData and the internal JSON parser encounters an unknown error.
TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog | The DatabaseConnectionDialog class allows the user to build connection strings and to connect to specific data sources.
TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog | The DataSourceExtractionDialog class allows the user to save an excerpt from the currently loaded data source.
TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.
TXTextControl.Drawing.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the TXDrawingControl.ViewChanged event.
TXTextControl.FilterException | The FilterException class informs about errors which can occur when a text filter is used to convert a document to or from another format.
TXTextControl.FrameEventArgs | The FrameEventArgs class provides data for all events that occur with frames.
TXTextControl.LicenseLevelException | A LicenseLevelException is thrown when a feature is not contained in the currently licensed product level.
TXTextControl.PaperSize | The PaperSize class is used with the TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods, which return the names and the sizes of all currently supported paper sizes.
TXTextControl.TextEditorException | The TextEditorException class informs about errors which can occur during editing text.
TXTextControl.UserDefinedPropertyDictionary | An instance of the UserDefinedPropertyDictionary class contains all user-defined document properties contained in a loaded document or which will be saved in a document.
TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup | An object of the ContextualTabGroup class represents a group of ribbon tabs which are only shown in a certain context.
TXTextControl.Windows.Forms.Ribbon.ContextualTabGroupCollection | The ContextualTabGroupCollection class represents all groups of ribbon tabs which are only shown in a certain context.
TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup | The HorizontalRibbonGroup class represents a logical group of controls as they appear on a RibbonTab.
TXTextControl.Windows.Forms.Ribbon.Ribbon | The Ribbon class is a command bar that organizes the features of an application into a series of tabs at the top of the application window.
TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors | The Ribbon.Colors class gets, sets or resets the display colors of a Windows Forms Ribbon control.
TXTextControl.Windows.Forms.Ribbon.RibbonButton | The RibbonButton class is a button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu.
TXTextControl.Windows.Forms.Ribbon.RibbonComboBox | The RibbonComboBox class represents a combobox which is inherited from the System.Windows.Forms.ComboBox class.
TXTextControl.Windows.Forms.Ribbon.RibbonForm | The RibbonForm class represents a Windows Forms form that can draw a Ribbon Quick Access Toolbar and contextual tabs in its border.
TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab | The RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard.
TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab | The RibbonFrameLayoutTab class represents a Windows Forms ribbon tab for editing objects of type Image, TextFrame, DrawingFrame, BarcodeFrame and ChartFrame.
TXTextControl.Windows.Forms.Ribbon.RibbonGroup | The RibbonGroup class represents a logical group of controls as they appear on a RibbonTab and is the base class of the HorizontalRibbonGroup class.
TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher | The DialogBoxLauncher class represents the dialog box launcher item of a RibbonGroup.
TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection | An instance of the RibbonGroupCollection class contains objects of type RibbonGroup and can be obtained with the RibbonTab.RibbonGroups property.
TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab | The RibbonInsertTab class represents a Windows Forms ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols.
TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection | An instance of the RibbonItemCollection class contains controls of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator and can be obtained with the RibbonGroup.RibbonItems, Ribbon.ApplicationMenuHelpPaneItems, Ribbon.ApplicationMenuItems, RibbonMenuButton.DropDownItems or RibbonListView.DropDownItems property.
TXTextControl.Windows.Forms.Ribbon.RibbonLabel | The RibbonLabel class represents a label which is inherited from the System.Windows.Forms.Control class.
TXTextControl.Windows.Forms.Ribbon.RibbonListView | The RibbonListView class is a list view control, which displays a collection of items that can be displayed using one of three different views.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem | The RibbonListViewItem class represents an item in a RibbonListView control.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection | An instance of the RibbonListViewItemCollection class contains controls of type RibbonListViewItem and can be obtained with the RibbonListView.RibbonListViewItems property.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemEventArgs | The RibbonListViewItemEventArgs class provides data for the RibbonListView.ItemClick, ItemMouseEnter or ItemMouseLeave event.
TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton | The RibbonMenuButton class is a button control that displays a drop-down menu when clicked.
TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab | The RibbonPageLayoutTab class represents a Windows Forms ribbon tab for editing the page setup and layout.
TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab | The RibbonProofingTab class represents a Windows Forms ribbon tab for setting proofing options such as spelling, hyphenation or language settings.
TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab | The RibbonReportingTab class represents a Windows Forms ribbon tab to integrate mail merge and reporting functionality.
TXTextControl.Windows.Forms.Ribbon.RibbonSeperator | The RibbonSeperator class represents a control that provides a seperator between elements in a HorizontalRibbonGroup, an ApplicationMenu or a drop-down menu of a RibbonMenuButton.
TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton | The RibbonSplitButton class is a control that has a primary button that responds to a Click event and a secondary button that displays a drop-down menu when clicked.
TXTextControl.Windows.Forms.Ribbon.RibbonTab | The RibbonTab class represents a tab in a Ribbon.
TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab | The RibbonTableLayoutTab class represents a Windows Forms ribbon tab for editing tables.
TXTextControl.Windows.Forms.Ribbon.RibbonTextBox | The RibbonTextBox class is a control that can be used to display or edit unformatted text.
TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton | The RibbonToggleButton class is a checkable button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu.
TXTextControl.Windows.Forms.Ribbon.RibbonToolTip | The RibbonToolTip class represents a small rectangular pop-up window that displays the title and/or a brief description of a ribbon item's purpose when the user rests the pointer on the control.
TXTextControl.Windows.Forms.Ribbon.RibbonViewTab | The RibbonViewTab class represents a Windows Forms ribbon tab for customizing the view settings.

Properties

Property | Description
TXTextControl.ButtonBar.ReadOnly | Gets or sets a value determining the button bar's read only mode.
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.DataRow | Gets the current data row's content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.DataRow | Gets the data row which is used to supply the current field with merge content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergeBlockName | If the merge field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.NestingDepth | If the merge field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.TableCell | If the merge field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.MergeBlockName | If the image field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.NestingDepth | If the image field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.TableCell | If the image field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.DataRow | Gets the data row which is used to supply the current image with merge content.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.MergeBlockName | If the image is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.NestingDepth | If the image is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix | A static property returning the internal merge block name prefix “txmb_”.
TXTextControl.FormattingStyle.BaseStyle | Gets the FormattingStyle which is the base style of this style.
TXTextControl.InputFormat.BottomAligned | Gets or sets a value specifying whether text is bottom aligned at the current input position.
TXTextControl.InputFormat.FrameFillColor | Gets or sets the color used to display the frame fill color at the current input position.
TXTextControl.InputFormat.FrameLineColor | Gets or sets the color used to display the color of frame lines at the current text input position.
TXTextControl.InputFormat.FrameLineWidth | Gets or sets the line width, in twips, of the paragraph's or table's frame at the current input position.
TXTextControl.InputFormat.TopAligned | Gets or sets a value specifying whether text is top aligned at the current input position.
TXTextControl.InputFormat.VerticallyCentered | Gets or sets a value specifying whether text is vertically centered at the current text input position.
TXTextControl.LoadSettings.DocumentAccessPermissions | Specifies how a document can be accessed after it has been loaded.
TXTextControl.LoadSettings.LoadDocumentBackColor | Specifies whether or not the document background color is loaded.
TXTextControl.LoadSettings.MasterPassword | Specifies the password when the document is restricted with access permissions.
TXTextControl.LoadSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is loaded.
TXTextControl.LoadSettings.UserDefinedDocumentProperties | Gets a dictionary with all user-defined document properties contained in the loaded document.
TXTextControl.LoadSettings.UserPassword | Specifies the password for the user to open a password protected document.
TXTextControl.ParagraphFormat.BackColor | Gets or sets the background color of a paragraph.
TXTextControl.ParagraphFormat.FrameLineColor | Gets or sets the color used for the frame lines of a paragraph.
TXTextControl.RulerBar.ReadOnly | Gets or sets a value determining the ruler bar's read only mode.
TXTextControl.SaveSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is saved.
TXTextControl.SaveSettings.SaveDocumentBackColor | Specifies whether or not the document background color is saved.
TXTextControl.SaveSettings.UserDefinedDocumentProperties | Sets a dictionary with all user-defined document properties which will be saved in the document.
TXTextControl.TextControl.Ribbon | Specifies the ribbon control to be used with a TextControl.

Methods

Method | Description
TXTextControl.DocumentServer.MailMerge.MergeJsonData | Merges data given as a JSON string into a document template.
TXTextControl.HeaderFooter.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.IFormattedText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.MainText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.PageNumberFieldCollection.GetItem | Gets a particular page number field from the collection.
TXTextControl.Selection.RemoveInlineStyles | Removes all character based styles of the selected text so that all attributes are reset to the attributes of the paragraph style.
TXTextControl.ServerTextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.ServerTextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.ServerTextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.TextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.TextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.TextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.TextControl.OnFrameClicked | Raises the FrameClicked event.
TXTextControl.TextControl.OnFrameDeselected | Raises the FrameDeselected event.
TXTextControl.TextControl.OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
TXTextControl.TextControl.OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
TXTextControl.TextControl.OnFrameMoved | Raises the FrameMoved event.
TXTextControl.TextControl.OnFrameRightClicked | Raises the FrameRightClicked event.
TXTextControl.TextControl.OnFrameSelected | Raises the FrameSelected event.
TXTextControl.TextControl.OnFrameSized | Raises the FrameSized event.
TXTextControl.TextControl.OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.
TXTextControl.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.TextControl.Zoom | Zooms the contents of the TextControl.
TXTextControl.TextFrame.GetTextFields | Returns a collection containing text fields of the specified types.

Events

Event | Description
TXTextControl.ServerTextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.TextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.TextControl.FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
TXTextControl.TextControl.FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
TXTextControl.TextControl.FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
TXTextControl.TextControl.FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
TXTextControl.TextControl.FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
TXTextControl.TextControl.FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
TXTextControl.TextControl.FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
TXTextControl.TextControl.FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
TXTextControl.TextControl.TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.


New Classes, Properties, Methods and Events for WPF

In TX Text Control 24.0 for WPF the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DocumentServer.DataSources.DataColumnInfo | The DataColumnInfo class provides basic information about a table column in a data source.
TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection | An instance of the DataColumnInfoCollection class contains all data columns of a data table in a data source represented through objects of the type DataColumnInfo.
TXTextControl.DocumentServer.DataSources.DataRelationInfo | The DataRelationInfo class provides all necessary information about parent-child-relations between data tables.
TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection | An instance of the DataRelationInfoCollection class contains all data relations in a data source represented through objects of the type DataRelationInfo.
TXTextControl.DocumentServer.DataSources.DataSourceManager | The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class.
TXTextControl.DocumentServer.DataSources.DataTableInfo | The DataTableInfo class provides basic information about a data table in a data source.
TXTextControl.DocumentServer.DataSources.DataTableInfoCollection | An instance of the DataTableInfoCollection class contains all data tables in a data source represented through objects of the type DataTableInfo.
TXTextControl.DocumentServer.DataSources.MergeBlockInfo | The MergeBlockInfo class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.DataSources.MergeBlockSettings | The MergeBlockSettings class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.Json.InvalidCodePointException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an invalid hexadecimal unicode code point.
TXTextControl.DocumentServer.Json.InvalidNumberFormatException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing a number with an invalid number format.
TXTextControl.DocumentServer.Json.ParserException | Base class of all JSON parser related exceptions which can be thrown when calling method MailMerge.MergeJsonData with an incorrect JSON string.
TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException | Is thrown when calling method MailMerge.MergeJsonData with an incomplete JSON string.
TXTextControl.DocumentServer.Json.UnexpectedTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unexpected character.
TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unknown character sequence at a position where one of the strings "true", "false" or "null" are expected.
TXTextControl.DocumentServer.Json.UnknownParseErrorException | Is thrown when calling method MailMerge.MergeJsonData and the internal JSON parser encounters an unknown error.
TXTextControl.DocumentServer.WPF.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.
TXTextControl.Drawing.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the TXDrawingControl.ViewChanged event.
TXTextControl.FilterException | The FilterException class informs about errors which can occur when a text filter is used to convert a document to or from another format.
TXTextControl.FrameEventArgs | The FrameEventArgs class provides data for all events that occur with frames.
TXTextControl.LicenseLevelException | A LicenseLevelException is thrown when a feature is not contained in the currently licensed product level.
TXTextControl.PaperSize | The PaperSize class is used with the TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods, which return the names and the sizes of all currently supported paper sizes.
TXTextControl.TextEditorException | The TextEditorException class informs about errors which can occur during editing text.
TXTextControl.UserDefinedPropertyDictionary | An instance of the UserDefinedPropertyDictionary class contains all user-defined document properties contained in a loaded document or which will be saved in a document.
TXTextControl.WPF.RibbonFrameLayoutTab | The RibbonFrameLayoutTab class represents a ribbon tab for editing objects of type Image, TextFrame, DrawingFrame and BarcodeFrame.
TXTextControl.WPF.RibbonPageLayoutTab | The RibbonPageLayoutTab class represents a tab for editing the page setup and layout.
TXTextControl.WPF.RibbonProofingTab | The RibbonProofingTab class represents a tab for setting proofing options such as spelling, hypheantion or language detection.
TXTextControl.WPF.RibbonReportingTab | The RibbonReportingTab class represents a WPF ribbon tab to integrate mail merge and reporting functionality.
TXTextControl.WPF.RibbonTableLayoutTab | The RibbonTableLayoutTab class represents a ribbon tab for editing tables.
TXTextControl.WPF.RibbonViewTab | The RibbonViewTab class represents a tab for customizing the view settings.

Properties

Property | Description
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.DataRow | Gets the current data row's content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.DataRow | Gets the data row which is used to supply the current field with merge content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergeBlockName | If the merge field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.NestingDepth | If the merge field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.TableCell | If the merge field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.MergeBlockName | If the image field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.NestingDepth | If the image field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.TableCell | If the image field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.DataRow | Gets the data row which is used to supply the current image with merge content.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.MergeBlockName | If the image is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.NestingDepth | If the image is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix | A static property returning the internal merge block name prefix “txmb_”.
TXTextControl.FormattingStyle.BaseStyle | Gets the FormattingStyle which is the base style of this style.
TXTextControl.InputFormat.BottomAligned | Gets or sets a value specifying whether text is bottom aligned at the current input position.
TXTextControl.InputFormat.FrameFillColor | Gets or sets the color used to display the frame fill color at the current input position.
TXTextControl.InputFormat.FrameLineColor | Gets or sets the color used to display the color of frame lines at the current text input position.
TXTextControl.InputFormat.FrameLineWidth | Gets or sets the line width, in twips, of the paragraph's or table's frame at the current input position.
TXTextControl.InputFormat.TopAligned | Gets or sets a value specifying whether text is top aligned at the current input position.
TXTextControl.InputFormat.VerticallyCentered | Gets or sets a value specifying whether text is vertically centered at the current text input position.
TXTextControl.LoadSettings.DocumentAccessPermissions | Specifies how a document can be accessed after it has been loaded.
TXTextControl.LoadSettings.LoadDocumentBackColor | Specifies whether or not the document background color is loaded.
TXTextControl.LoadSettings.MasterPassword | Specifies the password when the document is restricted with access permissions.
TXTextControl.LoadSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is loaded.
TXTextControl.LoadSettings.UserDefinedDocumentProperties | Gets a dictionary with all user-defined document properties contained in the loaded document.
TXTextControl.LoadSettings.UserPassword | Specifies the password for the user to open a password protected document.
TXTextControl.ParagraphFormat.BackColor | Gets or sets the background color of a paragraph.
TXTextControl.ParagraphFormat.FrameLineColor | Gets or sets the color used for the frame lines of a paragraph.
TXTextControl.SaveSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is saved.
TXTextControl.SaveSettings.SaveDocumentBackColor | Specifies whether or not the document background color is saved.
TXTextControl.SaveSettings.UserDefinedDocumentProperties | Sets a dictionary with all user-defined document properties which will be saved in the document.
TXTextControl.WPF.TextControl.RibbonFrameLayoutTab | Specifies the name of the WPF.RibbonFrameLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonPageLayoutTab | Specifies the name of the WPF.RibbonPageLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonProofingTab | Specifies the name of the WPF.RibbonProofingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonReportingTab | Specifies the name of the WPF.RibbonReportingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonTableLayoutTab | Specifies the name of the WPF.RibbonTableLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonViewTab | Specifies the name of the WPF.RibbonViewTab object to be used with a TextControl.

Methods

Method | Description
TXTextControl.DocumentServer.MailMerge.MergeJsonData | Merges data given as a JSON string into a document template.
TXTextControl.HeaderFooter.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.IFormattedText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.MainText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.PageNumberFieldCollection.GetItem | Gets a particular page number field from the collection.
TXTextControl.Selection.RemoveInlineStyles | Removes all character based styles of the selected text so that all attributes are reset to the attributes of the paragraph style.
TXTextControl.ServerTextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.ServerTextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.ServerTextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.TextFrame.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.WPF.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.WPF.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.WPF.TextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.WPF.TextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.WPF.TextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.WPF.TextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.WPF.TextControl.OnFrameClicked | Raises the FrameClicked event.
TXTextControl.WPF.TextControl.OnFrameDeselected | Raises the FrameDeselected event.
TXTextControl.WPF.TextControl.OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
TXTextControl.WPF.TextControl.OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
TXTextControl.WPF.TextControl.OnFrameMoved | Raises the FrameMoved event.
TXTextControl.WPF.TextControl.OnFrameRightClicked | Raises the FrameRightClicked event.
TXTextControl.WPF.TextControl.OnFrameSelected | Raises the FrameSelected event.
TXTextControl.WPF.TextControl.OnFrameSized | Raises the FrameSized event.
TXTextControl.WPF.TextControl.OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.
TXTextControl.WPF.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.WPF.TextControl.Zoom | Zooms the contents of the TextControl.

Events

Event | Description
TXTextControl.ServerTextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.WPF.TextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.WPF.TextControl.FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
TXTextControl.WPF.TextControl.FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
TXTextControl.WPF.TextControl.FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
TXTextControl.WPF.TextControl.FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
TXTextControl.WPF.TextControl.FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
TXTextControl.WPF.TextControl.FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
TXTextControl.WPF.TextControl.FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
TXTextControl.WPF.TextControl.TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.


New Classes, Properties, Methods and Events for ASP.NET

In TX Text Control 24.0 for ASP.NET the following new classes, properties, methods and events have been added:

Classes

Class | Description
Javascript: TXTextControl.CultureSettings | An object of this type is returned by the function getCultures.
Javascript: TXTextControl.HyperlinkClickedEventArgs | The event argument object for the hyperlinkClicked event.
Javascript: TXTextControl.InputPositionChangedEventArgs | The event argument object for the inputPositionChanged event.
Javascript: TXTextControl.Ribbon | The type of the ribbon property of the TXTextControl object.
Javascript: TXTextControl.RibbonTabIndexChangedEventArgs | The event argument object for the ribbonTabIndexChanged event.
Javascript: TXTextControl.Selection | Describes and handles the position and length of a text selection.
Javascript: TXTextControl.SelectionBounds | Is used with the setter of the selection property of the TextPart object.
Javascript: TXTextControl.SubTextPartEventArgs | The event argument for the SubTextPart related events.
Javascript: TXTextControl.TextPart | The callback function argument for the getTextParts function.
Javascript: TXTextControl.WebSocketClosedEventArgs | The event argument object for the webSocketClosed event.
TXTextControl.DocumentServer.DataSources.DataColumnInfo | The DataColumnInfo class provides basic information about a table column in a data source.
TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection | An instance of the DataColumnInfoCollection class contains all data columns of a data table in a data source represented through objects of the type DataColumnInfo.
TXTextControl.DocumentServer.DataSources.DataRelationInfo | The DataRelationInfo class provides all necessary information about parent-child-relations between data tables.
TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection | An instance of the DataRelationInfoCollection class contains all data relations in a data source represented through objects of the type DataRelationInfo.
TXTextControl.DocumentServer.DataSources.DataSourceManager | The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class.
TXTextControl.DocumentServer.DataSources.DataTableInfo | The DataTableInfo class provides basic information about a data table in a data source.
TXTextControl.DocumentServer.DataSources.DataTableInfoCollection | An instance of the DataTableInfoCollection class contains all data tables in a data source represented through objects of the type DataTableInfo.
TXTextControl.DocumentServer.DataSources.MergeBlockInfo | The MergeBlockInfo class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.DataSources.MergeBlockSettings | The MergeBlockSettings class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.Json.InvalidCodePointException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an invalid hexadecimal unicode code point.
TXTextControl.DocumentServer.Json.InvalidNumberFormatException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing a number with an invalid number format.
TXTextControl.DocumentServer.Json.ParserException | Base class of all JSON parser related exceptions which can be thrown when calling method MailMerge.MergeJsonData with an incorrect JSON string.
TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException | Is thrown when calling method MailMerge.MergeJsonData with an incomplete JSON string.
TXTextControl.DocumentServer.Json.UnexpectedTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unexpected character.
TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unknown character sequence at a position where one of the strings "true", "false" or "null" are expected.
TXTextControl.DocumentServer.Json.UnknownParseErrorException | Is thrown when calling method MailMerge.MergeJsonData and the internal JSON parser encounters an unknown error.
TXTextControl.Drawing.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the TXDrawingControl.ViewChanged event.
TXTextControl.FilterException | The FilterException class informs about errors which can occur when a text filter is used to convert a document to or from another format.
TXTextControl.FrameEventArgs | The FrameEventArgs class provides data for all events that occur with frames.
TXTextControl.LicenseLevelException | A LicenseLevelException is thrown when a feature is not contained in the currently licensed product level.
TXTextControl.PaperSize | The PaperSize class is used with the TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods, which return the names and the sizes of all currently supported paper sizes.
TXTextControl.ServerVisualization.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the View.Changed event.
TXTextControl.TextEditorException | The TextEditorException class informs about errors which can occur during editing text.
TXTextControl.UserDefinedPropertyDictionary | An instance of the UserDefinedPropertyDictionary class contains all user-defined document properties contained in a loaded document or which will be saved in a document.

Properties

Property | Description
Javascript: TXTextControl.contextMenusEnabled | Gets or sets if a right click into the text area opens a context menu or not.
Javascript: TXTextControl.controlChars | Gets or sets if control characters are visible.
Javascript: TXTextControl.documentTargetMarkers | Gets or sets if document target markers are visible.
Javascript: TXTextControl.editMode | Gets or sets the edit mode the control is in.
Javascript: TXTextControl.isHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
Javascript: TXTextControl.isLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
Javascript: TXTextControl.isSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
Javascript: TXTextControl.ribbon | Gets the control's ribbon bar object.
Javascript: TXTextControl.saveDocumentQuestionDialogEnabled | Gets or sets if a confirmation dialog should be shown before discarding unsaved changes.
Javascript: TXTextControl.selection | Gets the current selection.
Javascript: TXTextControl.tableGridLines | Gets or sets if table grid lines are visible.
Javascript: TXTextControl.textFieldsEditable | Gets or sets if text fields are editable or not.
Javascript: TXTextControl.textFrameMarkerLines | Gets or sets if text frame marker lines are visible.
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.DataRow | Gets the current data row's content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.DataRow | Gets the data row which is used to supply the current field with merge content.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergeBlockName | If the merge field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.NestingDepth | If the merge field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.TableCell | If the merge field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.MergeBlockName | If the image field is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.NestingDepth | If the image field is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.TableCell | If the image field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.DataRow | Gets the data row which is used to supply the current image with merge content.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.MergeBlockName | If the image is part of a merge block, this property returns the name of the block.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.NestingDepth | If the image is part of a merge block, this property returns the one-based nesting depth of the block.
TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix | A static property returning the internal merge block name prefix “txmb_”.
TXTextControl.FormattingStyle.BaseStyle | Gets the FormattingStyle which is the base style of this style.
TXTextControl.InputFormat.BottomAligned | Gets or sets a value specifying whether text is bottom aligned at the current input position.
TXTextControl.InputFormat.FrameFillColor | Gets or sets the color used to display the frame fill color at the current input position.
TXTextControl.InputFormat.FrameLineColor | Gets or sets the color used to display the color of frame lines at the current text input position.
TXTextControl.InputFormat.FrameLineWidth | Gets or sets the line width, in twips, of the paragraph's or table's frame at the current input position.
TXTextControl.InputFormat.TopAligned | Gets or sets a value specifying whether text is top aligned at the current input position.
TXTextControl.InputFormat.VerticallyCentered | Gets or sets a value specifying whether text is vertically centered at the current text input position.
TXTextControl.LoadSettings.DocumentAccessPermissions | Specifies how a document can be accessed after it has been loaded.
TXTextControl.LoadSettings.LoadDocumentBackColor | Specifies whether or not the document background color is loaded.
TXTextControl.LoadSettings.MasterPassword | Specifies the password when the document is restricted with access permissions.
TXTextControl.LoadSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is loaded.
TXTextControl.LoadSettings.UserDefinedDocumentProperties | Gets a dictionary with all user-defined document properties contained in the loaded document.
TXTextControl.LoadSettings.UserPassword | Specifies the password for the user to open a password protected document.
TXTextControl.ParagraphFormat.BackColor | Gets or sets the background color of a paragraph.
TXTextControl.ParagraphFormat.FrameLineColor | Gets or sets the color used for the frame lines of a paragraph.
TXTextControl.SaveSettings.ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is saved.
TXTextControl.SaveSettings.SaveDocumentBackColor | Specifies whether or not the document background color is saved.
TXTextControl.SaveSettings.UserDefinedDocumentProperties | Sets a dictionary with all user-defined document properties which will be saved in the document.
TXTextControl.ServerVisualization.RulerBarViewGenerator.ReadOnly | Gets or sets a value determining the ruler bar's read only mode.
TXTextControl.ServerVisualization.TextViewGenerator.AllowDrag | Gets or sets a value indicating whether the view generator can be a source of a Drag&Drop operation.
TXTextControl.ServerVisualization.TextViewGenerator.AllowDrop | Gets or sets a value indicating whether the view generator can accept data that the user drags onto it.

Methods

Method | Description
Javascript: TXTextControl.getBackColor | Returns the background color of the main text area and the ruler bars by calling a provided callback function.
Javascript: TXTextControl.getCultures | Returns the culture and the UI culture of the control.
Javascript: TXTextControl.getFileDirectory | Requests the directory path where the files of a specific file type are stored on the web server.
Javascript: TXTextControl.getFormattingPrinter | Returns the name of the currently selected formatting printer by calling a provided callback function.
Javascript: TXTextControl.getInstalledPrinters | Gets the names of the printers installed on the server which are usable by Text Control.
Javascript: TXTextControl.getStatusBarColor | Returns the background color of the status bar by calling a provided callback function.
Javascript: TXTextControl.getTextParts | Requests a collection of all text parts the current document contains from the server and returns the collection by calling a callback function which has to be provided as a parameter to the function.
Javascript: TXTextControl.loadXMLDatabase | Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.
Javascript: TXTextControl.removeFromDom | The removeFromDom function closes the WebSocket connection gracefully and removes the whole editor from the DOM.
Javascript: TXTextControl.setBackColor | Sets the background color of the main text area and the ruler bars.
Javascript: TXTextControl.setFileDirectory | Sets the directory path where the files of a specific file type are stored on the web server.
Javascript: TXTextControl.setFormattingPrinter | Sets the name of a printer the text dimensions and capabilities of which are used to format the document.
Javascript: TXTextControl.setStatusBarColor | Sets the background color of the status bar.
TXTextControl.DocumentServer.MailMerge.MergeJsonData | Merges data given as a JSON string into a document template.
TXTextControl.HeaderFooter.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.IFormattedText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.MainText.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.PageNumberFieldCollection.GetItem | Gets a particular page number field from the collection.
TXTextControl.Selection.RemoveInlineStyles | Removes all character based styles of the selected text so that all attributes are reset to the attributes of the paragraph style.
TXTextControl.ServerTextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.ServerTextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.ServerTextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.ServerVisualization.TextViewGenerator.Zoom | Zooms the contents of the TextViewGenerator.
TXTextControl.ServerVisualization.View.GetUpdateRectangle | Returns the coordinates of the smallest rectangle that completely encloses the update region.
TXTextControl.TextFrame.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.Web.TextControl.LoadDataFromJson | Uses data given as a JSON string as a data source.
TXTextControl.Web.TextControl.LoadDataFromJsonAsync | Uses data given as a JSON string as a data source.
TXTextControl.Web.TextControl.LoadDataFromModel | Loads a collection implementing interface System.Collections.IEnumerable as a data source.
TXTextControl.Web.TextControl.LoadDataFromModelAsync | Loads a collection implementing interface System.Collections.IEnumerable as a data source.

Events

Event | Description
TXTextControl.ServerTextControl.DocumentLoaded | Occurs when a new document has been loaded.


Update Notes

TX Text Control 24.0 provides the following changes and enhancements on existing elements:

Update Notes

Class/Property/Method/Event | Update Note
TextControl.BarcodeLayoutDialog method | A new overload has been added to specify the tab that is shown when the tabbed dialog box is opened.
TextControl.DrawingLayoutDialog method | A new overload has been added to specify the tab that is shown when the tabbed dialog box is opened.
TextControl.ImageAttributesDialog method | A new overload has been added to specify the tab that is shown when the tabbed dialog box is opened.
TextControl.TextFrameAttributesDialog method | A new overload has been added to specify the tab that is shown when the tabbed dialog box is opened.
DataVisualization.DrawingFrame.Refresh method | A further overload can be used when only a part of the drawing must be refreshed.
ServerVisualization.DrawShapeEventArgs.Shape enumeration | The new DropCaret member determines the rectangle indicating the text input position where text is inserted during a drag and drop operation.
CursorKind enumeration | The new DragDropCopy, DragDropMove and No members indicate the different cursors during a drag and drop operation.
ServerVisualization.View.Changed event | The event handler's type has been changed from System.EventHandler to ViewChangedEventHandler. The event handler receives now an argument of type ViewChangedEventArgs containing data related to this event.
ServerVisualization.View.GetImage method | Two further overloads can be used to get a clipping of the view's image.
ServerVisualization.View.ScrollPadding field | The constant field has been changed to a readonly property.
DocumentServer.MailMerge.MergeObjects method | The method now also handles collections containing items of type System.Collections.Generic.Dictionary with string keys. This makes it possible to use the parse result of JSON arrays containing objects of unknown types as data sources, for example. The method DocumentServer.MailMerge.MergeObject can also handle single dictionaries now.


What's New in Version 23.0

The following provides a general list of features that have been added since TX Text Control version 22.0.

New Features

New Classes, Properties, Methods and Events

Update Notes


New Features

TX Text Control 23.0 provides the following new features:

New Features

Feature | Description
Drawings and Shapes | TX Text Control now supports the insertion of drawings and preset shapes defined by ISO/IEC 29500-1 in section 20.1.10.55. A drawing represents a single shape or a canvas including a number of shapes. It can be positioned like an image or textframe, either geometrically or as a single character. Geometrically, its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The new DrawingFrame class handles the positioning of the drawing in the document. A drawing frame is always associated with a Drawing.TXDrawingControl or WPF.Drawing.TXDrawingControl which handles the appearance and the data of the drawing. A drawing can be activated and its contained shapes can be altered through the user with built-in mouse and keyboard interfaces. A drawing control is also fully programmable, its contained shapes are accessible through a Drawing.ShapeCollection. All drawings in a document are contained in a DrawingCollection. The collection can also be used to add drawings to or to remove drawings from the document. The drawing collection can be obtained through the TextControl.Drawings, WPF.TextControl.Drawings or ServerTextControl.Drawings property. The TextControl.DrawingLayoutDialog and WPF.TextControl.DrawingLayoutDialog methods opens a dialog box, which offers layout settings such as positioning, size and text distances. A drawing can be saved and loaded with the TX Text Control format and the Microsoft Word format (.docx). With other formats the drawing's bitmap image is saved.
New Built-in Windows Forms Dialog Boxes | TXTextControl for Windows Forms provides additional built-in dialog boxes for inserting, editing and deleting hyperlinks and bookmarks. The HyperlinkDialog class provides a dialog box to insert either a HypertextLink to an external location or a DocumentLink to a location in the same document. If there is a link at the current input position, the data of the link is shown and can be edited or the link can be deleted. The BookmarkDialog class provides a dialog box to insert a bookmark at the current text input position. If there is a bookmark at the current input position, the name of the bookmark is shown and can be edited. The DeleteBookmarksDialog class is a dialog box which shows all bookmarks in the current document. The user can jump to a bookmark or can delete one or more bookmarks. The GotoDialog dialog box can be used to move the current input position to a certain page, section, line, table or bookmark. The new input position is shown with a marker.
Programming Formatted Text | A TX Text Control document consists of the main text, and additionally other pieces of text such as text frames and headers or footers which are called textparts. A programmer can define now smaller parts called subtextparts to perform operations on smaller pieces of text. A SubTextPart can be defined through a start character index and a length or through a selection. All subtextparts are contained in a SubTextPartCollection which can be obtained with the TextControl.SubTextParts, TextFrame.SubTextParts or HeaderFooter.SubTextParts property. The collection can be used to add or to remove a subtextpart. A SubTextPart can be programmatically identified through a name or an identifier and it can be highlighted on the screen either permanently or only when it contains the current text input position. Each subtextpart can contain further nested subtextparts, but subtextparts cannot overlap. Its contents can be saved in a byte array or a string with all formats which TX Text Control supports.
Saving Document Properties | General document properties such as author, creation date or keywords can be saved with all supported text formats using the new properties SaveSettings.CreationDate, SaveSettings.CreatorApplication, SaveSettings.DocumentKeywords SaveSettings.DocumentSubject, SaveSettings.LastModificationDate and SaveSettings.Author. When a document is loaded, these properties are also available in the LoadSettings class.
Numbered and Bulleted Lists | The bullet character is no longer limited to the Windows Symbol font. The new ListFormat.FontName property can be used to specify a font for the bullet character. The bullet character itself can be any Unicode character. The TextControl.ListFormatDialog and WPF.TextControl.ListFormatDialog dialog boxes have been extended to specify a font and a Unicode character.
Inserting Symbol characters | A new dialog box is available to insert a Symbol character into the document. It is available with the TextControl.AddSymbolDialog and WPF.TextControl.AddSymbolDialog methods. The TextCharCollection has been extended with several Add methods to add symbol and control characters from programming code.
Undo/Redo | A user-defined undo step can be defined with the new BeginUndoAction and EndUndoAction methods. All editing and fomatting changes made between these methods belong to the undo operation. All these changes are undone or redone in a single step. The user can define a name which is available with the UndoActionName property.
Inserting Text Frames, Barcodes and Drawings | A new built-in mouse interface can be used to insert a text frame, a drawing or a barcode into the document. A further Add method has been added to the appropriate collection receiving a TextFrame, BarcodeFrame and DrawingFrame object and a FrameInsertionMode value. The end-user can then click into the document and draw a frame which determines the postion of the item. After releasing the mouse button the new item is created and inserted into the document.
Programming with Collections | Objects of the types DocumentLinkCollection, DocumentTargetCollection, FrameCollection, ChartCollection, BarcodeCollection and DrawingCollection are now available for all text parts of the document like the main text, headers, footers and text frames.
Mail Merge | The new DocumentServer.MailMerge.MergeObject method takes a single object as a merge data source. This makes it more convenient to merge a single "row" of object based data which until now had to be enclosed in an enumerable type (e. g. an array or a list) before being merged. Repeating merge blocks in mail merge templates are now realized with SubTextParts instead of document targets. Old templates can still be loaded.
Web Editor | It is now possible to set the culture and the UI culture of the web editor programmatically with the Web.TextControl.Culture and Web.TextControl.UICulture properties. If no culture is set, the browser language is used to determine the displayed string resources and units of measurement. It is no longer necessary to run the TX TextControl web service on the same machine as the IIS web server hosting the web editor. With the new properties Web.TextControl.ServiceAddress and Web.TextControl.ServicePort, it is now possible to connect to a service running on another physical server. This allows using a load balancer, for example.
Web Editor Programming | The new methods saveDocument, loadSelection and saveSelection were added to the TXTextControl JavaScript object. This enables saving the current document, inserting formatted text into the current selection and saving the current selection to different document formats from the client side.


New Classes, Properties, Methods and Events

In TX Text Control 23.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
Javascript: TXTextControl.DocumentLoadedEventArgs | The event argument object for the documentLoaded event.
Javascript: TXTextControl.SaveDocumentResult | The callback function argument for the saveDocument and the saveSelection functions.
Javascript: TXTextControl.TextDroppedEventArgs | The event argument object for the textDropped event.
Javascript: TXTextControl.TextFieldEventArgs | The event argument object for text field related events.
TXTextControl.BookmarkDialog | The BookmarkDialog class implements a Windows Forms dialog box to insert a DocumentTarget at the current input position.
TXTextControl.DataVisualization.DrawingCollection | An instance of the DrawingCollection class contains all drawings in a document represented through objects of the type DataVisualization.DrawingFrame.
TXTextControl.DataVisualization.DrawingEventArgs | The DrawingEventArgs class provides data for all events that occur with drawings.
TXTextControl.DataVisualization.DrawingFrame | An instance of the DrawingFrame class represents a drawing and its layout in a Text Control document.
TXTextControl.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a Windows Forms dialog box which shows all targets in the current document.
TXTextControl.DocumentServer.DataSources.IDataRowAdapter | The IDataRowAdapter interface contains properties and methods implemented by data row instances used in the BlockMerging event.
TXTextControl.DocumentServer.DataSources.IDataTableAdapter | The IDataTableAdapter interface contains properties and methods implemented by data table instances used in the BlockMerging event.
TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs | The BlockMergingEventArgs class provides data for the BlockMerging event.
TXTextControl.Drawing.MenuItem | The Drawing.MenuItem class represents a bindable Windows Forms ToolStripMenuItem.
TXTextControl.Drawing.Selection | The Drawing.Selection class represents all selected shapes.
TXTextControl.Drawing.Shape | The Drawing.Shape class represents a shape which can be displayed inside the TX Drawing Control.
TXTextControl.Drawing.Shape.Fill | The Drawing.Shape.Fill class determines the fill properties of a shape.
TXTextControl.Drawing.Shape.Outline | The Drawing.Shape.Outline class determines the line properties of a shape.
TXTextControl.Drawing.ShapeCollection | An instance of the ShapeCollection class contains all displayed shapes represented through objects of type Shape.
TXTextControl.Drawing.ShapeEventArgs | The ShapeEventArgs class provides data for all events that occur with shapes.
TXTextControl.Drawing.ShapesContextMenuStrip | The Drawing.ShapesContextMenuStrip class represents the default context menu of the Windows Forms TXDrawingControl.
TXTextControl.Drawing.TXDrawingControl | The TXDrawingControl class implements a Windows Forms control with features to draw custom or predefined shapes.
TXTextControl.GotoDialog | The GotoDialog class implements a Windows Forms dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.
TXTextControl.HyperlinkDialog | The HyperlinkDialog class implements a Windows Forms dialog box for inserting and editing a hyperlink at the current text input position.
TXTextControl.SubTextPart | A SubTextPart object represents a user-defined part of a TX Text Control document.
TXTextControl.SubTextPartCollection | Contains all subtextparts in the main text or another main part of a document.
TXTextControl.SubTextPartEventArgs | The SubTextPartEventArgs class provides data for the TextControl.SubTextPartClicked, TextControl.SubTextPartDoubleClicked, TextControl.SubTextPartEntered and TextControl.SubTextPartLeft events.
TXTextControl.WPF.Drawing.ShapesContextMenu | The WPF.Drawing.ShapesContextMenu class represents the default context menu of the WPF TXDrawingControl.
TXTextControl.WPF.Drawing.TXDrawingControl | The WPF.TXDrawingControl class implements a WPF FrameworkElement with features to draw custom or predefined shapes.

Properties

Property | Description
Javascript: TXTextControl.isLoadingDialogEnabled | Gets or sets if a wait dialog is shown while a document is being loaded.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.Merged | Gets a boolean value that indicates whether the current image has been merged successfully or not.
TXTextControl.DocumentServer.MailMerge.RemoveEmptyBlocks | Specifies whether the content of empty merge blocks should be removed from the template or not.
TXTextControl.DocumentServer.MailMerge.RemoveEmptyImages | Specifies whether images which don't have merge data should be removed from the template or not.
TXTextControl.DocumentServer.Web.DocumentViewer.PageAnimationDuration | Gets or sets the duration of the page animations in seconds.
TXTextControl.DocumentServer.Web.DocumentViewer.PageAnimations | Specifies whether CSS transition animations should be used or not when navigating through pages.
TXTextControl.DocumentServer.Web.DocumentViewer.RoundedPageCorners | Specifies whether rounded document page corners should be used or not.
TXTextControl.DocumentServer.Web.DocumentViewer.ShowEditButton | Specifies whether the edit button is shown or not.
TXTextControl.HeaderFooter.Barcodes | Gets a collection of all barcodes contained in a header or footer.
TXTextControl.HeaderFooter.Charts | Gets a collection of all charts contained in a header or footer.
TXTextControl.HeaderFooter.DocumentLinks | Gets a collection of all links in a header or footer which point to targets in the same document.
TXTextControl.HeaderFooter.DocumentTargets | Gets a collection of all targets in a header or footer.
TXTextControl.HeaderFooter.Drawings | Gets a collection of all drawings contained in a header or footer.
TXTextControl.HeaderFooter.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings in a header or footer.
TXTextControl.HeaderFooter.SubTextParts | Gets a collection of all subtextparts in the header or footer.
TXTextControl.IFormattedText.Barcodes | Gets a collection of all barcodes.
TXTextControl.IFormattedText.DocumentLinks | Gets a collection of all links which point to targets in the same document.
TXTextControl.IFormattedText.DocumentTargets | Gets a collection of all targets.
TXTextControl.IFormattedText.Drawings | Gets a collection of all drawings.
TXTextControl.IFormattedText.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings.
TXTextControl.IFormattedText.SubTextParts | Gets a collection of all subtextparts.
TXTextControl.ListFormat.FontName | Gets or sets the font used for the bullet character.
TXTextControl.LoadSettings.Author | Gets the document's author.
TXTextControl.LoadSettings.CreationDate | Gets the document's creation date.
TXTextControl.LoadSettings.CreatorApplication | Gets the application, which has created the document.
TXTextControl.LoadSettings.DocumentKeywords | Gets the document's keywords.
TXTextControl.LoadSettings.DocumentSubject | Gets the document's subject string.
TXTextControl.LoadSettings.LastModificationDate | Gets the date the document is last modified.
TXTextControl.LoadSettings.LoadSubTextParts | DOCX Format only: Specifies whether or not bookmarks which extend over several characters are converted to SubTextParts.
TXTextControl.MainText.Barcodes | Gets a collection of all barcodes contained in the main text of the document.
TXTextControl.MainText.Charts | Gets a collection of all charts contained in the main text of the document.
TXTextControl.MainText.DocumentLinks | Gets a collection of all links in the main text of the document which point to targets in the same document.
TXTextControl.MainText.DocumentTargets | Gets a collection of all targets in the main text of the document.
TXTextControl.MainText.Drawings | Gets a collection of all drawings contained in the main text of the document.
TXTextControl.MainText.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings contained in the main text of the document.
TXTextControl.MainText.SubTextParts | Gets a collection of all subtextparts contained in the main text of the document.
TXTextControl.SaveSettings.Author | Sets the document's author which will be saved in the document.
TXTextControl.SaveSettings.CreationDate | Sets the document's creation date which will be saved in the document.
TXTextControl.SaveSettings.CreatorApplication | Sets the application, which has created the document.
TXTextControl.SaveSettings.DocumentKeywords | Sets the document's keywords which will be saved in the document.
TXTextControl.SaveSettings.DocumentSubject | Sets the document's subject string which will be saved in the document.
TXTextControl.SaveSettings.LastModificationDate | Sets the date the document is last modified.
TXTextControl.ServerTextControl.Drawings | Gets a collection of all drawings in a document.
TXTextControl.ServerTextControl.SubTextParts | Gets a collection of all subtextparts contained in the document.
TXTextControl.ServerVisualization.TextViewGenerator.DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
TXTextControl.ServerVisualization.TextViewGenerator.RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
TXTextControl.ServerVisualization.TextViewGenerator.UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.
TXTextControl.TextControl.DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
TXTextControl.TextControl.Drawings | Gets a collection of all drawings contained in the text part with the input focus.
TXTextControl.TextControl.SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.
TXTextControl.TextFrame.Barcodes | Gets a collection of all barcodes contained in a text frame.
TXTextControl.TextFrame.Charts | Gets a collection of all charts contained in a text frame.
TXTextControl.TextFrame.DocumentLinks | Gets a collection of all links in a text frame which point to targets in the same document.
TXTextControl.TextFrame.DocumentTargets | Gets a collection of all targets in a text frame.
TXTextControl.TextFrame.Drawings | Gets a collection of all drawings contained in a text frame.
TXTextControl.TextFrame.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings in a text frame.
TXTextControl.TextFrame.SubTextParts | Gets a collection of all subtextparts in a text frame.
TXTextControl.Web.TextControl.Culture | Gets or sets the control's culture.
TXTextControl.Web.TextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.Web.TextControl.ServiceAddress | Gets or sets the IP address at which the websocket handler tries to connect to the Service.
TXTextControl.Web.TextControl.ServicePort | Gets or sets the Port at which the websocket handler tries to connect to the Service.
TXTextControl.Web.TextControl.UICulture | Gets or sets the control's user interface culture.
TXTextControl.WPF.TextControl.DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
TXTextControl.WPF.TextControl.Drawings | Gets a collection of all drawings contained in the text part with the input focus.
TXTextControl.WPF.TextControl.SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.

Methods

Method | Description
Javascript: TXTextControl.loadSelection | Loads text in a certain format into the current selection.
Javascript: TXTextControl.resetContents | Deletes the entire contents of the control.
Javascript: TXTextControl.saveDocument | Saves the current document in a certain format and sends the result back asynchronously by calling a given callback function.
Javascript: TXTextControl.saveSelection | Saves the current selection in a certain format and sends the result back asynchronously by calling a given callback function.
TXTextControl.DocumentServer.MailMerge.MergeObject | Merges a single instance of an arbitrary type into the loaded document template.
TXTextControl.ServerTextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.ServerTextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.ServerVisualization.TextViewGenerator.BeginUndoAction | Begins a user-defined undo operation.
TXTextControl.ServerVisualization.TextViewGenerator.EndUndoAction | Ends a user-defined undo operation.
TXTextControl.ServerVisualization.TextViewGenerator.OnDrawingDeselected | Raises the DrawingDeselected event.
TXTextControl.ServerVisualization.TextViewGenerator.OnDrawingSelected | Raises the DrawingSelected event.
TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartClicked | Raises the SubTextPartClicked event.
TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartEntered | Raises the SubTextPartEntered event.
TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartLeft | Raises the SubTextPartLeft event.
TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldClicked | Raises the TextFieldClicked event.
TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldEntered | Raises the TextFieldEntered event.
TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldLeft | Raises the TextFieldLeft event.
TXTextControl.TextCharCollection.Add | Adds a character to the document.
TXTextControl.TextCharCollection.Remove | Removes a character from a Text Control document.
TXTextControl.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
TXTextControl.TextControl.BeginUndoAction | Begins a user-defined undo operation.
TXTextControl.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.TextControl.EndUndoAction | Ends a user-defined undo operation.
TXTextControl.TextControl.OnDrawingActivated | Raises the DrawingActivated event.
TXTextControl.TextControl.OnDrawingClicked | Raises the DrawingClicked event.
TXTextControl.TextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.TextControl.OnDrawingDeactivated | Raises the DrawingDeactivated event.
TXTextControl.TextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.TextControl.OnDrawingDeselected | Raises the DrawingDeselected event.
TXTextControl.TextControl.OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
TXTextControl.TextControl.OnDrawingMoved | Raises the DrawingMoved event.
TXTextControl.TextControl.OnDrawingRightClicked | Raises the DrawingRightClicked event.
TXTextControl.TextControl.OnDrawingSelected | Raises the DrawingSelected event.
TXTextControl.TextControl.OnDrawingSized | Raises the DrawingSized event.
TXTextControl.TextControl.OnSubTextPartClicked | Raises the SubTextPartClicked event.
TXTextControl.TextControl.OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
TXTextControl.TextControl.OnSubTextPartEntered | Raises the SubTextPartEntered event.
TXTextControl.TextControl.OnSubTextPartLeft | Raises the SubTextPartLeft event.
TXTextControl.TextFrameCollection.GetActivatedItem | Returns the currently activated text frame.
TXTextControl.Web.TextControl.ResetContents | Deletes the entire contents of the control.
TXTextControl.WPF.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
TXTextControl.WPF.TextControl.BeginUndoAction | Begins a user-defined undo operation.
TXTextControl.WPF.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.WPF.TextControl.EndUndoAction | Ends a user-defined undo operation.
TXTextControl.WPF.TextControl.OnDrawingActivated | Raises the DrawingActivated event.
TXTextControl.WPF.TextControl.OnDrawingClicked | Raises the DrawingClicked event.
TXTextControl.WPF.TextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.WPF.TextControl.OnDrawingDeactivated | Raises the DrawingDeactivated event.
TXTextControl.WPF.TextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.WPF.TextControl.OnDrawingDeselected | Raises the DrawingDeselected event.
TXTextControl.WPF.TextControl.OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
TXTextControl.WPF.TextControl.OnDrawingMoved | Raises the DrawingMoved event.
TXTextControl.WPF.TextControl.OnDrawingRightClicked | Raises the DrawingRightClicked event.
TXTextControl.WPF.TextControl.OnDrawingSelected | Raises the DrawingSelected event.
TXTextControl.WPF.TextControl.OnDrawingSized | Raises the DrawingSized event.
TXTextControl.WPF.TextControl.OnSubTextPartClicked | Raises the SubTextPartClicked event.
TXTextControl.WPF.TextControl.OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
TXTextControl.WPF.TextControl.OnSubTextPartEntered | Raises the SubTextPartEntered event.
TXTextControl.WPF.TextControl.OnSubTextPartLeft | Raises the SubTextPartLeft event.

Events

Event | Description
TXTextControl.DocumentServer.MailMerge.BlockMerging | Occurs when a merge block is about to be merged.
TXTextControl.ServerTextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.ServerTextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.ServerVisualization.TextViewGenerator.DrawingDeselected | Occurs when a drawing has been deselected.
TXTextControl.ServerVisualization.TextViewGenerator.DrawingSelected | Occurs when a drawing has been selected.
TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartClicked | Occurs when a subtextpart has been clicked on.
TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TXTextControl.ServerVisualization.TextViewGenerator.TextControl.TextFieldClicked | Occurs when a text field has been clicked on.
TXTextControl.ServerVisualization.TextViewGenerator.TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TXTextControl.ServerVisualization.TextViewGenerator.TextFieldLeft | Occurs when the current input position has left a text field.
TXTextControl.TextControl.DrawingActivated | Occurs when a drawing has been activated.
TXTextControl.TextControl.DrawingClicked | Occurs when a drawing has been clicked on.
TXTextControl.TextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.TextControl.DrawingDeactivated | Occurs when a drawing has been deactivated.
TXTextControl.TextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.TextControl.DrawingDeselected | Occurs when a drawing has been deselected.
TXTextControl.TextControl.DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
TXTextControl.TextControl.DrawingMoved | Occurs when a drawing has been moved.
TXTextControl.TextControl.DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
TXTextControl.TextControl.DrawingSelected | Occurs when a drawing has been selected.
TXTextControl.TextControl.DrawingSized | Occurs when a drawing has been sized.
TXTextControl.TextControl.SubTextPartClicked | Occurs when a subtextpart has been clicked on.
TXTextControl.TextControl.SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
TXTextControl.TextControl.SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
TXTextControl.TextControl.SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TXTextControl.WPF.TextControl.DrawingActivated | Occurs when a drawing has been activated.
TXTextControl.WPF.TextControl.DrawingClicked | Occurs when a drawing has been clicked on.
TXTextControl.WPF.TextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.WPF.TextControl.DrawingDeactivated | Occurs when a drawing has been deactivated.
TXTextControl.WPF.TextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.WPF.TextControl.DrawingDeselected | Occurs when a drawing has been deselected.
TXTextControl.WPF.TextControl.DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
TXTextControl.WPF.TextControl.DrawingMoved | Occurs when a drawing has been moved.
TXTextControl.WPF.TextControl.DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.DrawingSelected | Occurs when a drawing has been selected.
TXTextControl.WPF.TextControl.DrawingSized | Occurs when a drawing has been sized.
TXTextControl.WPF.TextControl.SubTextPartClicked | Occurs when a subtextpart has been clicked on.
TXTextControl.WPF.TextControl.SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
TXTextControl.WPF.TextControl.SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
TXTextControl.WPF.TextControl.SubTextPartLeft | Occurs when the current input position has left a subtextpart.


Update Notes

TX Text Control 23.0 provides the following enhancements:

Update Notes

Class/Property/Method/Event | Update Note
ServerVisualization.TextViewGenerator.DialogBoxKind enumeration | Has been extended with the DrawingLayoutDialog member.
TextFrameCollection.Add method | A new overload enables the built-in mouse interface for inserting a TextFrame.
DataVisualization.BarcodeCollection.Add method | A new overload enables the built-in mouse interface for inserting a DataVisualization.BarcodeFrame.


What's New in Version 22.0

The following provides a general list of features that have been added since TX Text Control version 21.0.

New Features

New Classes, Properties, Methods and Events


New Features

TX Text Control 22.0 provides the following new features:

New Features

Feature | Description
Web Editor Enhancements | Formatted content can now be copied and pasted from a client application (i.e. MS Word) to the web editor and it is possible now to directly drag and drop document files and images into the text area of the web control. Furthermore the web control's ribbon bar can be collapsed and scrolled horizontally and a dialog box for spell-checking has been added. When a document is printed the browser's printing dialog box is opened directly without using an external window.
Web Editor Programming | In a web editor's document selected text can be exchanged with text in a certain format. The new Web.Selection class and the new Web.TextControl.Selection property enable this feature. The Web editor can be programmed in the browser using JavaScript. For this purpose, the TXTextControl JavaScript object can be used. It allows attaching event handlers to the editor and hiding editor elements like the ruler bars or the status bar.
WPF Control Presentation | The TX TExtControl WPF controls are now inherited from the System.Windows.Controls.Control class instead from the System.Windows.FrameworkElement class. The control itself is now a sealed template of other WPF controls. This enables a better integration in the WPF Framework, so that other framework elements can overlap now a WPF.TextControl or a TX Text Control toolbar.
New WPF Button Bar | The WPF.ButtonBar control is inherited now from the System.Windows.Controls.ToolBar class, containing default buttons and comboboxes as items, accessible through the Items property. These items can be sorted, deleted or moved through programming code, additional items can be added through programming code or the design time collection editor. Also the WPF.ButtonBar can be used now as part of a System.Windows.Controls.ToolBarTray. The Items property replaces the ButtonPositions, ButtonOffsets and ButtonSeparators properties. The button bar's frame can be designed with the inherited BorderBrush and BorderThickness properties, the prior BorderStyle property has been removed.
WPF Ribbon Controls | The new WPF.RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard. The new WPF.RibbonInsertTab class represents a ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols. Both are inherited from the System.Windows.Controls.Ribbon.RibbonTab class and can be hosted in a System.Windows.Controls.Ribbon.Ribbon object. They can be connected with a WPF.TextControl through the WPF.TextControl.RibbonFormattingTab and WPF.TextControl.RibbonInsertTab properties. To use the TX Text Control Ribbon Controls, Microsoft Ribbon for WPF 3.5 must be installed.
New Built-in Dialog Boxes | TXTextControl for WPF provides additional built-in dialog boxes for inserting, editing and deleting hyperlinks and bookmarks. The WPF.HyperlinkDialog class provides a dialog box to insert either a HypertextLink to an external location or a DocumentLink to a location in the same document. If there is a link at the current input position, the data of the link is shown and can be edited or the link can be deleted. The WPF.BookmarkDialog class provides a dialog box to insert a bookmark at the current text input position. If there is a bookmark at the current input position, the name of the bookmark is shown and can be edited. The WPF.DeleteBookmarksDialog class is a dialog box which shows all bookmarks in the current document. The user can jump to a bookmark or can delete one or more bookmarks. The WPF.GotoDialog dialog box can be used to move the current input position to a certain page, section, line, table or bookmark. The new input position is shown with a marker.
Loading and Saving Images | TX Text Control now uses Windows Imaging Component (WIC), a Component Object Model based imaging codec framework for working with and processing digital images and image metadata. The Tagged Image Format (.TIF) and Graphics Interchange Format (.GIF) image formats can now additionally be used for exporting images. The Image.ExportFilterIndex and SaveSettings.ImageExportFilterIndex properties support this feature.
Resource Kit | The web editor component can now be fully localized and is part of the TX TextControl resource kit.

Update Notes

Class/Property/Method/Event | Update Note
ButtonBar.ButtonPositions property | Has been replaced through the Items property.
ButtonBar.ButtonOffsets property | Has been replaced through the Items property.
ButtonBar.ButtonSeparators property | Has been replaced through the Items property.
ButtonBar.BorderStyle property | Has been replaced through the BorderBrush and BorderThickness properties.
ButtonBar.ButtonStyle property | Has been removed. All default items of a WPF.ButtonBar are WPF controls which can be designed with System.Windows.Style objects.
ButtonBar.DisplayColors property | Has been removed. All default items of a WPF.ButtonBar are WPF controls which can be designed with System.Windows.Style objects.
WPF.TextControl.MousePosition property | Has been removed. The position can be obtained from the MouseEventArgs parameter of the WPF.TextControl.MouseMove routed event or through the Mouse.GetPosition method.
WPF.TextControl.Loaded event | A WPF.TextControl object is ready for interaction, when its Loaded event occurs. The application window's Loaded event can no longer be used to interact with a TextControl contained in this application.


New Classes, Properties, Methods and Events

In TX Text Control 22.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.Web.HeaderFooter | An instance of the Web.HeaderFooter class represents a header or footer in a Text Control document.
TXTextControl.Web.IFormattedText | The Web.IFormattedText interface contains properties common to all text parts in a TX Text Control document.
TXTextControl.Web.MainText | The Web.MainText class represents the main text of a TX Text Control document.
TXTextControl.Web.Selection | The Web.Selection class describes and handles the position and length of a text selection.
TXTextControl.Web.TextFrame | An instance of the Web.TextFrame class represents a text frame in a Text Control document.
TXTextControl.Web.TextPart | The Web.TextPart class implements the Web.IFormattedText interface as well as public properties and internal functionality common to all text parts in a TX Text Control document.
TXTextControl.Web.TextPartCollection | An instance of the Web.TextPartCollection class contains all text parts in a TX Text Control document.
TXTextControl.WPF.BookmarkDialog | The WPF.BookmarkDialog class implements a dialog box to insert a DocumentTarget at the current input position.
TXTextControl.WPF.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a dialog box which shows all targets in the current document.
TXTextControl.WPF.GotoDialog | The GotoDialog class implements a dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.
TXTextControl.WPF.HyperlinkDialog | The WPF.HyperlinkDialog class implements a built-in dialog box for inserting and editing a hyperlink at the current text input position.
TXTextControl.WPF.RibbonFormattingTab | The WPF.RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard.
TXTextControl.WPF.RibbonInsertTab | The WPF.RibbonInsertTab class represents a ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols.
TXTextControl.WPF.TextControlDocument | An object of the WPF.TextControlDocument class represents a document and is part of the template of a WPF.TextControl.
TXTextControl.WPF.TextControlToolBar | The WPF.TextControlToolBar class is the base class of the WPF.RulerBar and the WPF.StatusBar classes.
TXTextControl.WPF.TextControlToolBarPresenter | A WPF.TextControlToolBarPresenter object is part of the template of a WPF.TextControlToolBar.

Properties

Property | Description
TXTextControl.InputPosition.InactiveMarker | Shows or hides a marker which indicates the current text input position when the TextControl is inactive and the blinking caret is not visible.
TXTextControl.Page.Footer | Gets the footer of the page.
TXTextControl.Page.Header | Gets the header of the page.
TXTextControl.SaveSettings.DocumentLevelJavaScriptActions | Specifies an array of strings containing Javascript.
TXTextControl.TextField.ContainsInputPosition | Returns true, if the Textfield contains the current text input position.
TXTextControl.Web.TextControl.BackColor | Specifies or returns the background color of the main text area and the ruler bars.
TXTextControl.Web.TextControl.ContextMenusEnabled | Specifies or returns a value indicating if a right click opens a context menu or not.
TXTextControl.Web.TextControl.ControlChars | Specifies if control characters are visible or not.
TXTextControl.Web.TextControl.DocumentTargetMarkers | Specifies or returns a value indicating if markers for hypertext targets are shown in the editor or not.
TXTextControl.Web.TextControl.EditMode | Specifies or returns a value of type Web.EditMode indicating whether the document's text is read-only, can be selected or is editable.
TXTextControl.Web.TextControl.SaveDocumentQuestionDialogEnabled | Specifies or returns a value indicating if a confirmation dialog should be shown before discarding unsaved changes.
TXTextControl.Web.TextControl.Selection | Gets or sets the current selection in the text part with the input focus.
TXTextControl.Web.TextControl.StatusBarColor | Specifies or returns the background color of the status bar.
TXTextControl.Web.TextControl.TableGridLines | Specifies or returns a value indicating wether table grid lines are shown in the editor or not.
TXTextControl.Web.TextControl.TextFieldsEditable | Gets or sets if text fields are editable or not.
TXTextControl.Web.TextControl.TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TXTextControl.Web.TextControl.TextParts | Gets a collection of all text parts the current document contains.
TXTextControl.Web.TextControl.WebSocketHandlerPath | Specifies the path to the WebSocket handler (TXWebSocketHandler.ashx).
TXTextControl.WPF.TextControl.RibbonFormattingTab | Specifies the name of the WPF.RibbonFormattingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonInsertTab | Specifies the name of the WPF.RibbonInsertTab object to be used with a TextControl.

Methods

Method | Description
TXTextControl.InputPosition.ScrollTo | Scrolls the contents of a Text Control so that the current input position becomes visible.
TXTextControl.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TXTextControl.WPF.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.WPF.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.


What's New in Version 21.0

The following provides a general list of features that have been added since TX Text Control version 20.0.

New Features

New Classes, Properties, Methods and Events


New Features

TX Text Control 21.0 provides the following new features:

New Features

Feature | Description
HTML5 Web Editor | The new Web.TextControl (HTML5 Web Editor) is an ASP.NET server control that allows the integration of a fully-featured WYSIWYG word processor in ASP.NET Web applications. This control works together with the TX Text Control Web Server running as a Windows Service hosted on a Web server. The TX Text Control Web Server engine is used to synchronize the document with the server in order to provide consistent WYSIWYG text rendering. The technical concept is explained in HTML5 Web Editor - Technical Considerations. All programming elements belonging to the HTML5 Web Editor can be found in the TXTextControl.Web namespace.
Automatic Language Detection | TX TextControl supports now the language detection feature of the TXSpell 5.0 component. If the IsLanguageDetectionEnabled property has been set to true, a language is automatically detected for all text parts with a neutral language.
Find and Replace | The built-in find and replace dialog boxes have been extended with several new features. The search process is no longer limited to the main text, it can be continued in text frames and in headers and footers. The new FindOptions member MatchWholeWord locates only instances of the search text which are whole words.
Table Programming | A new overload of the Table.Select method allows a certain part of a table defined through two table cells to be selected.
Resource Kit | The built-in Find, Replace and Color dialog boxes have been added to the resource kit and can be localized now.
Content Control Adapter Fields | In Microsoft Word, Content Controls are controls that can be added and customized for use in documents and templates. Those controls provide properties and settings that can be used to automate documents. The TXTextControl.DocumentServer.Fields namespace provides new field adapter classes for the following content controls: RichTextContentControl, PlainTextContentControl, CheckBoxContentControl, ComboBoxContentControl, DateContentControl, DropDownContentControl.
Visualization of the ServerTextControl | The new ServerVisualization.TextViewGenerator class, a special kind of ServerTextControl, can be used to generate an image of the text which is contained in a ServerTextControl. It provides a ServerVisualization.View object, which provides the image and which defines the part of the document for which the image is generated. Furthermore, it offers a ServerVisualization.UserInput object which can be used to simulate keyboard and mouse input. If this user-input affects the image defined through the View object, the image is automatically updated and a View.Changed event occurs. The ServerVisualization.RulerBarViewGenerator and ServerVisualization.StatusBarViewGenerator classes work in the same way to generate images of a status bar and of horizontal and vertical ruler bars. Images of all built-in dialog boxes can be generated through the ServerVisualization.DialogViewGenerator class. Objects of this class can be obtained through the TextViewGenerator.GetDialogBox property. All of these classes can be found in the TXTextControl.ServerVisualization namespace.


New Classes, Properties, Methods and Events

In TX Text Control 21.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DocumentServer.Fields.CheckBoxContentControl | The CheckBoxContentControl implements the MS Word specific check box content control field.
TXTextControl.DocumentServer.Fields.ComboBoxContentControl | The ComboBoxContentControl implements the MS Word specific combo box content control field.
TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter | The abstract ContentControlFieldAdapter class is the base class of all Microsoft Word content control field adapter classes.
TXTextControl.DocumentServer.Fields.DateContentControl | The DateContentControl implements the MS Word specific date content control field.
TXTextControl.DocumentServer.Fields.DropDownListContentControl | The DropDownListContentControl implements the MS Word specific drop down list content control field.
TXTextControl.DocumentServer.Fields.PlainTextContentControl | The PlainTextContentControl implements the MS Word specific plain text content control field.
TXTextControl.DocumentServer.Fields.RichTextContentControl | The RichTextContentControl implements the MS Word specific plain text content control field.
TXTextControl.ServerVisualization.CaretStateEventArgs | The CaretStateEventArgs class provides data about the state of the caret, such as position, size and visibility.
TXTextControl.ServerVisualization.DialogViewGenerator | An instance of the DialogViewGenerator class can be used to visualize a built-in dialog box through an image.
TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs | The DocumentSizeChangedEventArgs class informs about a changed document size.
TXTextControl.ServerVisualization.DrawShapeEventArgs | The DrawShapeEventArgs class contains information to draw additional parts necessary when the user interacts with the document.
TXTextControl.ServerVisualization.MenuItem | The MenuItem class provides all data necessary to visualize a menu item, such as the menu's text and the menu's image.
TXTextControl.ServerVisualization.RulerBarViewGenerator | An instance of the RulerBarViewGenerator class can be used to visualize a ruler bar through an image.
TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors | The ServerVisualization.RulerBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.RulerBarViewGenerator component.
TXTextControl.ServerVisualization.ShowDialogBoxEventArgs | The ShowDialogBoxEventArgs class provides a DialogViewGenerator object which can be used to show a further dialog box from a parent dialog box.
TXTextControl.ServerVisualization.ShowErrorMessageEventArgs | The ShowErrorMessageEventArgs class provides a string which should be shown as an error message for the end-user.
TXTextControl.ServerVisualization.StatusBarViewGenerator | An instance of the StatusBarViewGenerator class can be used to visualize a status bar through an image.
TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors | The StatusBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.StatusBarViewGenerator component.
TXTextControl.ServerVisualization.TextContextMenuEventArgs | The TextContextMenuEventArgs class provides data for the ServerVisualization.TextViewGenerator.TextContextMenuOpening event.
TXTextControl.ServerVisualization.TextViewGenerator | The TextViewGenerator class is a special ServerTextControl, which can be used to visualize the control's text contents through a generated image.
TXTextControl.ServerVisualization.TextViewGenerator.Colors | The TextViewGenerator.Colors class gets, sets or resets the display colors of a TextViewGenerator component.
TXTextControl.ServerVisualization.UserInput | An instance of the UserInput class can be used to inform a view generator about user input.
TXTextControl.ServerVisualization.View | An instance of the View class represents a part of a document for which an image can be generated.
TXTextControl.VersionInfo | The VersionInfo class provides information about the running TX Text Control version, such as the version number, the installed service pack number and the product level.
TXTextControl.Web.TextControl | The TextControl class implements a control with high-level text editing features.

Properties

Property | Description
TXTextControl.ServerTextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
TXTextControl.TextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
TXTextControl.WPF.TextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.

Methods

Method | Description
TXTextControl.ServerTextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
TXTextControl.TextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
TXTextControl.WPF.TextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.


What's New in Version 20.0

The following provides a general list of features that have been added since TX Text Control version 19.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 20.0 provides the following new features:

New Features

Feature | Description
Right to Left Support | Text Control supports right to left text rendering for languages such as Arabic or Hebrew. Each line in a document can be bidirectional, which means, that it can contain text parts written from left to right and text parts written from right to left. The text input position behind a left-to-right character is on its right side and the input position behind a right-to-left character is on its left side. In addition, a paragraph can be formatted from right to left, which means that the blocks of bidirectional text are ordered from right ro left. The ParagraphFormat.Direction property has been added to support this feature. The paragraph formatting dialog box has also been extended to enable an end-user to format a paragraph from right to left. A tabulator in a right-to-left paragraph is a distance from the document's right page margin. When a paragraph is justified, TextControl now supports the insertion of Arabic Kashida lines in addition to expanding spaces. The ParagraphFormat.Justification property can be used to set the kind of justification for each paragraph. Both justification features can be combined. The horizontal ruler bar has been extended to show the horizontal origin in a right-to-left paragraph at the right page margin. In right to left text the natural paragraph alignment and tabulator kind is right aligned. The new Selection.ChangeDirection method can be used to changed the writing direction of one or more paragraphs. When the direction of a paragraph is changed this paragraph's alignment is toggled from left to right or from right to left. The alignment of centered and justified paragraphs is not changed. Left and right tabulators are also toggled.
Right to Left Application Design | To support a right to left application design, all TX TextControl controls support the RightToLeft property. A TextControl or WPF.TextControl then shows the vertical scrollbar at the left border and has a zoom origin at the top right corner. All built-in dialog boxes and context menus have a right-to-left design. The RulerBar control has a right-to-left ruler and the ButtonBar and StatusBar controls show their buttons or text parts from right to left.
Hyphenation | TextControl supports the TXSpellChecker 4.0 component, which, in addition to spell checking, can be used to hyphenate a document. This component must be connected with a TextControl through the TextControl.SpellChecker property and automatic hyphenation must be activated with the TextControl.IsHyphenationEnabled property. Every time a word does not fit in the line the spell checker component calculates a dividing position. TextControl then raises the TextControl.HyphenateWord event and sends the calculated position with the event's data. The calculated position can be changed through the event handler. TextControl then uses the calculated or changed position to divide the word and insert a hyphen at the end of the line.
Multilingual documents | A piece of text can be formatted now for a specific language, which is used for spell checking and hyphenation. A document can be multilingual, which means that multiple languages can be used in the same document. A new built-in dialog box available with the TextControl.LanguageDialog method can be used to get or to set the language for a selection of text or for the current text input position. Programmatically, this can be done with the Selection.Culture property. All text filters have been adapted to support language settings in other text formats. The StatusBar and WPF.StatusBar controls offer the new ShowLanguage property to show the language at the text input position.
Button Bar | Additional predefined buttons have been added to the ButtonBar and WPF.ButtonBar classes. The StrikeOutButton, SubscriptButton and SuperscriptButton buttons have been added to set additional font attributes. The GrowFontSizeButton and ShrinkFontSizeButton buttons can be used to grow or shrink all font sizes in a text selection and the IncreaseIndentButton and DecreaseIndentButton buttons increase or decrease the paragraph indents in a text selection. The LeftToRightButton and RightToLeftButton buttons set the writing direction either left-to-right or right-to-left.
Mail Merge | Until now column names of table columns which were used to supply the merge data for image merge fields (i. e. MERGEFIELD fields with the prefix “image:”) also had to begin with the prefix “image:”. From now on this is no longer necessary although it still works to ensure backward compatibility. The field dialog of MERGEFIELD fields has been expanded by two text boxes, one for the date / time format flag, one for the numeric format flag. Images are now included in the merge process and are replaced according to their name. Merged images are scaled up / down such that they maintain the same width as the placeholder image in the template. To enable image merging the table column containing the image data has to contain one of the following: Either binary data as a byte array, objects of type System.Drawing.Image, file names or hexadecimal strings beginning with “X'”. All overloads of the method Merge now process data relations. This makes it easier to create and merge template documents containing master detail relations. (e. g. Invoices containing order and customer informations together with order details such as a list of purchased articles.) Using the now obsolete method MergeBlocks required an additional merge block surrounding the whole document to achieve the same merge result. Yet another improvement is the possibility to use any collection of objects as a data source using the new method MergeObjects. For detailed information have a look at the documentation of that method.

Update Notes

Class/Property/Method/Event | Update Note
Page.GetImage method | The ScreenElements member has been added to the PageContent enumeration, which can be used to get an image of a page containing all elements which are additionally displayed on a screen, such as the selection, the control characters and helper lines.


New Classes, Properties, Methods and Events

In TX Text Control 20.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DocumentServer.Fields.NextField | The NextField class implements the MS Word specific NEXT field.
TXTextControl.DocumentServer.Fields.NextIfField | The NextIfField class implements the MS Word specific NEXTIF field.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs | The ImageMergedEventArgs class provides data for the ImageMerged event.
TXTextControl.HyphenateWordEventArgs | The HyphenateWordEventArgs class provides data for the TextControl.HyphenateWord, ServerTextControl.HyphenateWord and WPF.TextControl.HyphenateWord events.

Properties

Property | Description
TXTextControl.DocumentServer.Fields.MergeField.DateTimeFormat | Specifies a string format which is applied to date / time values.
TXTextControl.DocumentServer.Fields.MergeField.NumericFormat | Specifies a string format which is applied to numeric values.
TXTextControl.DocumentServer.MailMerge.ReportDataSourceConfig | Specifies the Report Data Source Configuration as an XML string.
TXTextControl.DocumentServer.MailMerge.ReportDataSourceConfigFile | Gets or sets the file path of a Report Data Source Configuration file (*.rdsc) which has been created with TX Text Control Words.
TXTextControl.DocumentServer.MailMerge.TemplateFile | Specifies the template file path.
TXTextControl.InputFormat.LeftToRight | Gets or sets a value specifying whether the writung direction is left-to-right at the current input position.
TXTextControl.InputFormat.RightToLeft | Gets or sets a value specifying whether the writing direction is right-to-left at the current input position.
TXTextControl.InputPosition.CaretSize | Gets the size of the caret, in pixels, at the current text input position.
TXTextControl.MisspelledWord.Culture | Gets the culture of the misspelled word.
TXTextControl.ParagraphFormat.Direction | Gets or sets the writing direction.
TXTextControl.ParagraphFormat.Justification | Gets or sets the kind of justification in documents containing Arabic or Hebrew characters.
TXTextControl.Selection.Culture | Gets or sets the culture of the selected text.
TXTextControl.ServerTextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
TXTextControl.SpellCheckTextEventArgs.Culture | Gets the culture of the text to check.
TXTextControl.StatusBar.ShowLanguage | Specifies whether the status bar shows the language of the text selection or the text input position.
TXTextControl.TextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
TXTextControl.WPF.StatusBar.ShowLanguage | Specifies whether the status bar shows the language of the text selection or the text input position.
TXTextControl.WPF.TextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.

Methods

Method | Description
TXTextControl.DocumentServer.MailMerge.MergeObjects | Merges a collection of type System.Collections.IEnumerable containing objects of any type or instances of type System.Collections.Generic.Dictionary with string keys into the loaded document template.
TXTextControl.Selection.ChangeDirection | Changes the writing direction of all selected paragraphs.
TXTextControl.ServerTextControl.OnHyphenateWord | Raises the HyphenateWord event.
TXTextControl.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.TextControl.OnHyphenateWord | Raises the HyphenateWord event.
TXTextControl.WPF.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.WPF.TextControl.OnHyphenateWord | Raises the HyphenateWord event.

Events

Event | Description
TXTextControl.DocumentServer.MailMerge.ImageMerged | Occurs when an image has been merged successfully.
TXTextControl.ServerTextControl.HyphenateWord | Occurs, if a word does not fit on the line and must be hyphenated.
TXTextControl.TextControl.HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.
TXTextControl.WPF.TextControl.HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.


What's New in Version 19.0

The following provides a general list of features that have been added since TX Text Control version 18.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 19.0 provides the following new features:

New Features

Feature | Description
Headers and Footers | Text Control now supports different headers and footers for the even and odd pages of the whole document or of a single section. A document's section can either contain the same header or footer for all pages or different headers and footers for even and odd pages. The HeaderFooterCollection.Add, HeaderFooterCollection.GetItem and HeaderFooterCollection.Remove methods have been extended, so that an even header or footer can be added and removed programmatically. When an even header or footer has been defined, a HeaderFooter object of the type Header or Footer represents the odd header or footer. Otherwise, it represents the header or footer of both pages. The built-in SectionFormatDialog has been extended to enable an end-user to select different headers and footers for even and odd pages. When a header or footer is activated, a dividing line between the header or footer and the main text is displayed instead of a frame. The dividing line has a label indicating which type of header or footer (even, odd, first page) is activated. The TextControl.HeaderFooterFrameStyle property has been extended, so that the former activation styles are still possible. The TextControl.Colors and WPF.TextControlColors classes have been extended to support designing the colors of dividing lines and labels.
Barcodes | TX Text Control now supports the insertion of barcode controls of the type TXTextControl.Barcode.TXBarcodeControl. A barcode can be positioned like an image or textframe, either geometrically or as a single character. Geometrically, its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The new BarcodeFrame class handles the positioning of the barcode in the document. A barcode frame is always associated with a barcode control which handles the appearance and the data of the barcode. All barcodes in a document are contained in a BarcodeCollection. The collection can also be used to add barcodes to or to remove barcodes from the document. The barcode collection can be obtained through the TextControl.Barcodes, WPF.TextControl.Barcodes or ServerTextControl.Barcodes property. The TextControl.BarcodeLayoutDialog and WPF.TextControl.BarcodeLayoutDialog methods opens a dialog box, which offers layout settings such as positioning, size and text distances. A barcode can be saved with the TX Text Control and the RTF format and is reconstructed during a loading process. With other formats the barcode image is saved. If a document with barcodes is loaded on a system where no barcode controls are installed, the barcode's image is inserted.
Page Numbering | Text Control now supports additional features for showing page numbers. For each section in the document page numbers can either be continued from the previous section or can be restarted with a certain start number. The SectionFormat class has been extended with the SectionFormat.RestartPageNumbering property to support this feature. A PageNumberField can now be used to show the total number of pages. The new PageNumberField.ShowNumberOfPages property supports this feature. A new built-in dialog box can be used to alter the formatting and numbering attributes of page number fields. It can be opened with the PageNumberField.PageNumberDialog method.
Built-in Context Menus | Text Control now offers built-in context menus. Depending on the area, where the right mouse button has been clicked a menu with standard options for this area is shown. There is a menu for standard text formatting, a menu for inserting or editing headers and footers including altering page settings and a menu for handling images and text frames. Before a built-in context menu is opened, a TextContextMenuOpening event occurs. This event can be used to alter or to expand the predefined menu, to provide a custom menu or to completely suppress the menu.
Tables | A new TableCollection.Add method has been added, which opens a built-in dialog box to specify a new table.
Application Fields | TX Text Control now supports Microsoft Word Content Controls. Content controls are converted to TX Text Control ApplicationField, when a Microsoft Word (.DOCX) document is loaded. For more information see the technical article Text Fields and Hypertext Links - Importing Fields from Microsoft Word.
Control Characters | TX Text Control now has a control character which shows the anchor position of an anchored object. Anchored objects are positioned relative to a paragraph. The anchor postion is shown left of this paragraph's first character. The anchor is shown only when an anchored object is selected. Additionally, individual control characters can be shown permanently on the screen independently of the value of the ControlChars property. This setting can be performed with the new TextControl.PermanentControlChars or WPF.TextControl.PermanentControlChars property.
Mail Merge | The MailMerge component is now able to merge data into DataVisualization.ChartFrame and DataVisualization.BarcodeFrame objects. Barcodes are essentially processed just like merge fields: If the name of a BarcodeFrame object is the same as a table column, data will be merged into it. This also works with barcodes in merge blocks. ChartFrame objects are only supported outside merge blocks and can be supplied with merge data by means of data relations, which have to be part of the DataTable object passed to the DocumentServer.MailMerge.Merge method. Another improvement is the option to interrupt a merge process after each merged data row by using the Cancel property of the event arguments for the DocumentServer.MailMerge.DataRowMerged event. Additionally, the DocumentServer.MailMerge.BarcodeMerged and DocumentServer.MailMerge.ChartMerged events have been added, which are fired after a barcode or a chart has been merged.

Update Notes

Class/Property/Method/Event | Update Note
HeaderFooterCollection methods | Have been extended with the HeaderFooterType.EvenHeader and HeaderFooterType.EvenFooter values.
TextControl.HeaderFooterFrameStyle property | Has been extended with the HeaderFooterFrameStyle.DividingLine setting.


New Classes, Properties, Methods and Events

In TX Text Control 19.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DataVisualization.BarcodeCollection | An instance of the BarcodeCollection class contains all barcodes in a document represented through objects of the type DataVisualization.BarcodeFrame.
TXTextControl.DataVisualization.BarcodeEventArgs | The BarcodeEventArgs class provides data for all events that occur with barcodes.
TXTextControl.DataVisualization.BarcodeFrame | An instance of the BarcodeFrame class represents a barcode and its layout in a Text Control document.
TXTextControl.DocumentServer.MailMerge.BarcodeMergedEventArgs | The BarcodeMergedEventArgs class provides data for the BarcodeMerged event.
TXTextControl.DocumentServer.MailMerge.ChartMergedEventArgs | The ChartMergedEventArgs class provides data for the ChartMerged event.
TXTextControl.DocumentServer.MergeCanceledException | A MergeCanceledException is thrown through the Merge method when the current merge process was canceled through the DataRowMergedEventArgs.Cancel property.
TXTextControl.TextContextMenuEventArgs | The TextContextMenuEventArgs class provides data for the TextControl.TextContextMenuOpening event of a Windows Forms TextControl.
TXTextControl.WPF.TextContextMenuEventArgs | The WPF.TextContextMenuEventArgs class provides data for the WPF.TextControl.TextContextMenuOpening event.

Properties

Property | Description
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.Cancel | Gets or sets a value indicating whether the current merge process should be canceled.
TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs.IncludeTextField | Represents the currently merged INCLUDETEXT field.
TXTextControl.PageNumberField.ShowNumberOfPages | Gets or sets a value indicating whether the field shows the page number or the total number of pages.
TXTextControl.SectionFormat.RestartPageNumbering | Gets or sets a value indicating whether page numbering is restarted at the section's beginning.
TXTextControl.ServerTextControl.Barcodes | Gets a collection of all barcodes in a document.
TXTextControl.TextControl.Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.
TXTextControl.TextControl.Colors.HeaderFooterLabelColor | Gets or sets the display color for the label showing which header or footer is activated.
TXTextControl.TextControl.Colors.HeaderFooterLineColor | Gets or sets the display color for the dividing line between headers and footers and the main text.
TXTextControl.TextControl.PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
TXTextControl.WPF.TextControl.Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.
TXTextControl.WPF.TextControl.PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
TXTextControl.WPF.TextControlColors.HeaderFooterLabelColor | Gets or sets the display color for the label showing which header or footer is activated.
TXTextControl.WPF.TextControlColors.HeaderFooterLineColor | Gets or sets the display color for the dividing line between headers and footers and the main text.

Methods

Method | Description
TXTextControl.DocumentServer.MailMerge.GetBlockFieldNames | Returns the names of all merge fields inside the merge block with the specified name.
TXTextControl.PageNumberField.PageNumberDialog | Opens a dialog box to alter the formatting and numbering attributes of the page number field.
TXTextControl.ServerTextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.ServerTextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.TextControl.Colors.ResetHeaderFooterLabelColor | Resets the text control's HeaderFooterLabelColor to its system dependent default value.
TXTextControl.TextControl.Colors.ResetHeaderFooterLineColor | Resets the text control's HeaderFooterLineColor to its system dependent default value.
TXTextControl.TextControl.OnBarcodeClicked | Raises the BarcodeClicked event.
TXTextControl.TextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.TextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.TextControl.OnBarcodeDeselected | Raises the BarcodeDeselected event.
TXTextControl.TextControl.OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
TXTextControl.TextControl.OnBarcodeMoved | Raises the BarcodeMoved event.
TXTextControl.TextControl.OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
TXTextControl.TextControl.OnBarcodeSelected | Raises the BarcodeSelected event.
TXTextControl.TextControl.OnBarcodeSized | Raises the BarcodeSized event.
TXTextControl.TextControl.OnChartDeselected | Raises the ChartDeselected event.
TXTextControl.TextControl.OnChartSelected | Raises the ChartSelected event.
TXTextControl.TextControl.OnImageDeselected | Raises the ImageDeselected event.
TXTextControl.TextControl.OnImageSelected | Raises the ImageSelected event.
TXTextControl.TextControl.OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
TXTextControl.TextControl.OnTextFrameDeselected | Raises the TextFrameDeselected event.
TXTextControl.TextControl.OnTextFrameSelected | Raises the TextFrameSelected event.
TXTextControl.WPF.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.WPF.TextControl.OnBarcodeClicked | Raises the BarcodeClicked event.
TXTextControl.WPF.TextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.WPF.TextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.WPF.TextControl.OnBarcodeDeselected | Raises the BarcodeDeselected event.
TXTextControl.WPF.TextControl.OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
TXTextControl.WPF.TextControl.OnBarcodeMoved | Raises the BarcodeMoved event.
TXTextControl.WPF.TextControl.OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
TXTextControl.WPF.TextControl.OnBarcodeSelected | Raises the BarcodeSelected event.
TXTextControl.WPF.TextControl.OnBarcodeSized | Raises the BarcodeSized event.
TXTextControl.WPF.TextControl.OnImageDeselected | Raises the ImageDeselected event.
TXTextControl.WPF.TextControl.OnImageSelected | Raises the ImageSelected event.
TXTextControl.WPF.TextControl.OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
TXTextControl.WPF.TextControl.OnTextFrameDeselected | Raises the TextFrameDeselected event.
TXTextControl.WPF.TextControl.OnTextFrameSelected | Raises the TextFrameSelected event.

Events

Event | Description
TXTextControl.DocumentServer.MailMerge.BarcodeMerged | Occurs when a barcode has been merged successfully.
TXTextControl.DocumentServer.MailMerge.ChartMerged | Occurs when a chart has been merged successfully.
TXTextControl.Drawing.TXDrawingControl.ShapeDeleted | Occurs when a shape has been deleted from the TX Drawing Control's shapes collection.
TXTextControl.ServerTextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.ServerTextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.TextControl.BarcodeClicked | Occurs when a barcode has been clicked on.
TXTextControl.TextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.TextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.TextControl.BarcodeDeselected | Occurs when a barcode has been deselected.
TXTextControl.TextControl.BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
TXTextControl.TextControl.BarcodeMoved | Occurs when a barcode has been moved.
TXTextControl.TextControl.BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
TXTextControl.TextControl.BarcodeSelected | Occurs when a barcode has been selected.
TXTextControl.TextControl.BarcodeSized | Occurs when a barcode has been sized.
TXTextControl.TextControl.ChartDeselected | Occurs when a chart has been deselected.
TXTextControl.TextControl.ChartSelected | Occurs when a chart has been selected.
TXTextControl.TextControl.ImageDeselected | Occurs when an image has been deselected.
TXTextControl.TextControl.ImageSelected | Occurs when an image has been selected.
TXTextControl.TextControl.TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TXTextControl.TextControl.TextFrameDeselected | Occurs when a text frame has been deselected.
TXTextControl.TextControl.TextFrameSelected | Occurs when a text frame has been selected.
TXTextControl.WPF.Drawing.TXDrawingControl.ShapeDeleted | Occurs when a shape has been deleted from the TX Drawing Control's shapes collection.
TXTextControl.WPF.TextControl.BarcodeClicked | Occurs when a barcode has been clicked on.
TXTextControl.WPF.TextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.WPF.TextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.WPF.TextControl.BarcodeDeselected | Occurs when a barcode has been deselected.
TXTextControl.WPF.TextControl.BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
TXTextControl.WPF.TextControl.BarcodeMoved | Occurs when a barcode has been moved.
TXTextControl.WPF.TextControl.BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.BarcodeSelected | Occurs when a barcode has been selected.
TXTextControl.WPF.TextControl.BarcodeSized | Occurs when a barcode has been sized.
TXTextControl.WPF.TextControl.ImageDeselected | Occurs when an image has been deselected.
TXTextControl.WPF.TextControl.ImageSelected | Occurs when an image has been selected.
TXTextControl.WPF.TextControl.TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TXTextControl.WPF.TextControl.TextFrameDeselected | Occurs when a text frame has been deselected.
TXTextControl.WPF.TextControl.TextFrameSelected | Occurs when a text frame has been selected.


What's New in Version 18.0

The following provides a general list of features that have been added since TX Text Control version 17.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 18.0 provides the following new features:

New Features

Feature | Description
Charts | TX Text Control for Windows Forms now supports the insertion of chart controls of the type System.Windows.Forms.DataVisualization.Charting.Chart. This control is part of the .net framework since version 4, but can be added to prior versions. A chart can be positioned like an image or textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The new ChartFrame class handles the positioning of the chart in the document. A chart frame is always associated with a chart control which handles the appearance and the data of the chart. All charts in a document are contained in a ChartCollection. The collection can also be used to add charts to or to remove charts from the document. The chart collection can be obtained from a TextControl or ServerTextControl through the Charts property. The TextControl.ChartLayoutDialog method opens a dialog box, which offers layout settings such as positioning, size and text distances. A chart can be saved with the TX Text Control and the RTF format and is reconstructed during a loading process. With other formats the chart image is saved. If a document with charts is loaded on a system where no chart controls are installed, the chart's image is inserted.
Z-Order | Text Control now offers a z-order of all images, text frames and charts which are inserted in the text. All of these objects can be either in front of the text or behind the text and the z-order among these objects can be changed. The new insertion modes AboveTheText and BelowTheText have been added. Depending on these modes either the text overwrites the object or the object overwrites the main text. The ImageCollection.Add, TextFrameCollection.Add and ChartCollection.Add methods and the Image.InsertionMode, TextFrame.InsertionMode and FrameBase.InsertionMode properties support these new modes. The z-order can be changed with the ChangeZOrder method of an Image, TextFrame or DataVisualization.ChartFrame object. With this method the image, text frame or chart can be moved up or down one plane or it can be moved to the topmost or to the bottom most position. Objects inserted inline have always a z-order of zero.
Transparent Text Frames | Text frames can be transparent, so that images and other text frames behind a transparent text frame are visible. Transparency can be set as a value from 0 to 255 with the TextFrame.Transparency property. Zero means opaque and 255 means completely transparent.
Frame Collection | A common collection containing all images, text frames and charts of a document is now available. This FrameCollection can be obtained with the TextControl.Frames, WPF.TextControl.Frames or ServerTextControl.Frames property. It can be used to alter common attributes or to get the currently selected item. The objects in the collection are of the type Image, TextFrame and DataVisualization.ChartFrame.
Text Parts | Two new TextPartCollection.GetItem methods have been implemented. The first retrieves the offset of the text part from the top left corner of the TextControl and the second searches for a text part at a certain gemetric location.
Spell checking | Two new properties have been implemented for the MisspelledWord class. The MisspelledWord.IsIgnored property marks the misspelled word as ignored. An ignored misspelled word remains in the collection of misspelled words, but it is not underlined in the text with a red zigzag line. The MisspelledWord.IsDuplicate property informs whether the word is a duplicate word. A duplicate word is not misspelled, but it has the same text as the word in front of it. The new SpellCheckContextMenu property of the WPF.TextControl can be used to define a context menu, when the end-user right-clicks a misspelled word. Either a built-in default menu or a user-defined menu can be specified.
Images | TX Text Control supports now the EMF image format (Windows Enhanced Metafile). The EMF and WMF image formats are handled internally without an image filter. The WMF image filter is no longer necessary.
New Status Bar Design | The TX Text Control StatusBar and WPF.StatusBar offers a new background style with a vertical color gradient and separator lines between the display parts. Furthermore a track bar has been added to set the zooming factor of a Text Control. All colors depend either on the Windows themes or can be user-defined with the StatusBar.DisplayColors and WPF.StatusBar.DisplayColors properties. The new VerticalColorScheme style can be set with the StatusBar.BorderStyle property.

Update Notes

Class/Property/Method/Event | Update Note
MisspelledWordCollection.GetItem method | The coordinates to use with the location parameter have been changed from twips to pixels.
Image.InsertionMode property | The ImageInsertionMode enumeration has been extended with the AboveTheText and BelowTheText settings.
TextFrame.InsertionMode property | The TextFrameInsertionMode enumeration has been extended with the AboveTheText and BelowTheText settings.


New Classes, Properties, Methods and Events

In TX Text Control 18.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DataVisualization.ChartCollection | An instance of the ChartCollection class contains all charts in a document represented through objects of the type DataVisualization.ChartFrame.
TXTextControl.DataVisualization.ChartEventArgs | The ChartEventArgs class provides data for all events that occur with charts.
TXTextControl.DataVisualization.ChartFrame | An instance of the ChartFrame class represents a chart and its layout in a Text Control document.
TXTextControl.FrameCollection | An instance of the FrameCollection class contains all images, text frames and charts in a document.

Properties

Property | Description
TXTextControl.MisspelledWord.IsDuplicate | Gets or sets a value which marks the misspelled word as duplicate.
TXTextControl.MisspelledWord.IsIgnored | Gets or sets a value which marks the misspelled word as ignored.
TXTextControl.ServerTextControl.Charts | Gets a collection of all charts in a document.
TXTextControl.ServerTextControl.Frames | Gets a collection of all images, textframes, charts and barcodes in a document.
TXTextControl.ServerTextControl.IsCreated | Gets a value indicating whether the control is completely created.
TXTextControl.StatusBar.Colors.BackColorBottom | Gets or sets the background color at the bottom of the status bar.
TXTextControl.StatusBar.Colors.BackColorMiddle | Gets or sets the background color in the middle of the status bar.
TXTextControl.StatusBar.Colors.BackColorTop | Gets or sets the background color at the top of the status bar.
TXTextControl.StatusBar.Colors.SeparatorColorDark | Gets or sets the color of the dark part of a separator.
TXTextControl.StatusBar.Colors.SeparatorColorLight | Gets or sets the color of the light part of a separator.
TXTextControl.StatusBar.ShowZoomTrackBar | Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.
TXTextControl.TextControl.Charts | Gets a collection of all charts contained in the text part with the input focus.
TXTextControl.TextControl.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings contained in the text part with the input focus.
TXTextControl.TextFrame.Transparency | Gets or sets the text frame's transparency.
TXTextControl.WPF.StatusBar.ShowZoomTrackBar | Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.
TXTextControl.WPF.StatusBarColors.BackColorBottom | Gets or sets the background color at the bottom of the status bar.
TXTextControl.WPF.StatusBarColors.BackColorMiddle | Gets or sets the background color in the middle of the status bar.
TXTextControl.WPF.StatusBarColors.BackColorTop | Gets or sets the background color at the top of the status bar.
TXTextControl.WPF.StatusBarColors.SeparatorColorDark | Gets or sets the color of the dark part of a separator.
TXTextControl.WPF.StatusBarColors.SeparatorColorLight | Gets or sets the color of the light part of a separator.
TXTextControl.WPF.TextControl.Frames | Gets a collection of all images, textframes, barcodes and drawings contained in the text part with the input focus.
TXTextControl.WPF.TextControl.SpellCheckContextMenu | Specifies the context menu which is used when the end-user right-clicks a misspelled word.

Methods

Method | Description
TXTextControl.FrameBase.ChangeZOrder | Changes the frame's z-order.
TXTextControl.MisspelledWordCollection.GetCount | Returns the number of misspelled words with a special meaning from the collection.
TXTextControl.MisspelledWordCollection.Ignore | Changes the text of the specified misspelled word and marks it as ignored.
TXTextControl.StatusBar.Colors.ResetBackColorBottom | Resets the status bar's BackColorBottom to its system dependent default value.
TXTextControl.StatusBar.Colors.ResetBackColorMiddle | Resets the status bar's BackColorMiddle to its system dependent default value.
TXTextControl.StatusBar.Colors.ResetBackColorTop | Resets the status bar's BackColorTop to its system dependent default value.
TXTextControl.StatusBar.Colors.ResetSeparatorColorDark | Resets the status bar's SeparatorColorDark to its system dependent default value.
TXTextControl.StatusBar.Colors.ResetSeparatorColorLight | Resets the status bar's SeparatorColorLight to its system dependent default value.
TXTextControl.TextControl.ChartLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a chart.
TXTextControl.TextControl.OnChartClicked | Raises the ChartClicked event.
TXTextControl.TextControl.OnChartCreated | Raises the ChartCreated event.
TXTextControl.TextControl.OnChartDeleted | Raises the ChartDeleted event.
TXTextControl.TextControl.OnChartDoubleClicked | Raises the ChartDoubleClicked event.
TXTextControl.TextControl.OnChartMoved | Raises the ChartMoved event.
TXTextControl.TextControl.OnChartRightClicked | Raises the ChartRightClicked event.
TXTextControl.TextControl.OnChartSized | Raises the ChartSized event.

Events

Event | Description
TXTextControl.ServerTextControl.ChartCreated | Occurs when a new chart has been created.
TXTextControl.ServerTextControl.ChartDeleted | Occurs when a chart has been deleted.
TXTextControl.TextControl.ChartClicked | Occurs when a chart has been clicked on.
TXTextControl.TextControl.ChartCreated | Occurs when a new chart has been created.
TXTextControl.TextControl.ChartDeleted | Occurs when a chart has been deleted.
TXTextControl.TextControl.ChartDoubleClicked | Occurs when a chart has been doubleclicked on.
TXTextControl.TextControl.ChartMoved | Occurs when a chart has been moved.
TXTextControl.TextControl.ChartRightClicked | Occurs when a chart has been clicked on with the right mouse button.
TXTextControl.TextControl.ChartSized | Occurs when a chart has been sized.


What's New in Version 17.0

The following provides a general list of features that have been added since TX Text Control version 16.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 17.0 provides the following new features:

New Features

Feature | Description
Text Selections | Text selections in tables have been extended so that it is now possible to select table columns and rectangular areas of table cells. Table columns can be formatted and copied to the clipboard. The TableColumn.Select method has been added to support this feature programmatically. Text selections are now displayed with a transparent blue bitmap. The new SelectionViewMode property can be used to display selections with the classic selection view mode.
Merged Table Cells | Table cells can be merged with the new Table.MergeCells method. The method merges all selected cells to a single cell which has the same width and the same content as the original cells. The new Table.SplitCells method can be used to split previously merged cells. Table cells can only be merged, if more than one cell is selected, and if the selection is in a single table. The Table.CanMergeCells property can be used to check whether cells can be merged.
Named Table Cells | Each table cell can have a name which can be used to store any string data associated with the cell. The new TableCell.Name property can be used to get or to set a cell's name. The name is stored only, when the TXTextControl file format is used.
Colored Table Lines | Table lines can be colored. Each line of a table cell can have a different color. All text filters and the TXTextControl file format have been extended so that this feature can be exchanged with other applications. The TableCellFormat class has been extended with the LeftBorderColor, TopBorderColor, RightBorderColor and BottomBorderColor properties to set these attributes programmatically. Colored table lines can also be set with the built-in dialogbox for setting table attributes.
Page Borders | Borders can now be defined for each page of a document section. A page border can have a top, left, right or bottom line or a combination of these lines. The line width and the color can be defined for each line separately. For each line a distance can be specified, which is either a distance to the edge of the page or to the text. The page border can surround the text including page headers and footers or only the text of the page. The border can be defined for the first page, for all pages or beginning with the second page. The new PageBorder class represents all these attributes of a page border. The SectionFormat class has been extended with the new PageBorder property to can set all these attributes programmatically. The page settings dialog box has also been extended so that an end-user can define a page border.
Digital Signatures | PDF files can be saved digitally signed with an X.509 certificate. The SaveSettings class has been extended with the SaveSettings.DigitalSignature property to set a certificate for a saving process. The DigitalSignature class used with this property represents the X.509 certificate and all other information necessary to digitally sign the file.
Spell checking | A TextControl supports now the TXSpellChecker component, which can be used to get and to correct misspelled words in the current document. This component can be connected with a TextControl through the TextControl.SpellChecker property and must be activated with the TextControl.IsSpellCheckingEnabled property. The component handles the TextControl.SpellCheckText event internally and provides a dialog box and a context menu to correct misspelled words. The Dialog can be invoked with the TextControl.SpellCheckDialog method and the context menu is opened when the end-user right-clicks a misspelled word.
HTML Format | The TX Text Control HTML import filter now uses the parsing rules described in the W3C specification of HTML5 (http://www.w3.org/TR/html5/Overview.html#parsing).


New Classes, Properties, Methods and Events

In TX Text Control 17.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DigitalSignature | An instance of the DigitalSignature class represents an X.509 certificate which can be used to digitally sign a PDF or PDF/A document.
TXTextControl.PageBorder | An instance of the PageBorder class represents the attributes of a border, which is drawn in the margin area of a page.

Properties

Property | Description
TXTextControl.SaveSettings.DigitalSignature | Specifies a DigitalSignature object, which defines an X.509 certificate.
TXTextControl.SectionFormat.PageBorder | Gets or sets the attributes of a section's page border.
TXTextControl.ServerTextControl.SpellChecker | Specifies the spell checking component to be used with a ServerTextControl.
TXTextControl.Table.CanMergeCells | Checks whether table cells can be merged.
TXTextControl.Table.CanSplitCells | Checks whether previously merged table cells in this table can be split.
TXTextControl.TableCell.Name | Gets or sets the cell's name.
TXTextControl.TableCellCollection.CanRemove | Gets a value indicating whether table cells can be removed.
TXTextControl.TableCellFormat.BottomBorderColor | Gets or sets the color of the table cell's bottom border.
TXTextControl.TableCellFormat.LeftBorderColor | Gets or sets the color of the table cell's left border.
TXTextControl.TableCellFormat.RightBorderColor | Gets or sets the color of the table cell's right border.
TXTextControl.TableCellFormat.TopBorderColor | Gets or sets the color of the table cell's top border.
TXTextControl.TextControl.SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.
TXTextControl.TextControl.SpellCheckContextMenuStrip | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
TXTextControl.TextControl.SpellChecker | Specifies the spell checking component to be used with a TextControl.
TXTextControl.WPF.TextControl.SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.
TXTextControl.WPF.TextControl.SpellChecker | Specifies the spell checking component to be used with a TextControl.

Methods

Method | Description
TXTextControl.Table.MergeCells | Merges all selected table cells in this table.
TXTextControl.Table.SplitCells | Splits all selected table cells in this table.
TXTextControl.TableCellCollection.Remove | Removes the table cell at the current text input position or all selected table cells when a text selection exists.
TXTextControl.TableColumn.Select | Selects the table column.
TXTextControl.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.
TXTextControl.WPF.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.


What's New in Version 16.0

The following provides a general list of features that have been added since TX Text Control version 15.1.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 16.0 provides the following new features:

New Features

Feature | Description
Windows Presentation Framework | TX Text Control now supports the development of WPF applications (.exe) and WPF browser applications (.xbap). Four new controls WPF.TextControl, WPF.ButtonBar, WPF.RulerBar and WPF.StatusBar have been added to the TX Text Control class library. They can be found in the new TXTextControl.WPF namespace. These controls offer the same feature set as the Windows Forms controls.
Ribbon Support | TX TextControl provides now support for ribbon user interfaces. The new InputFormat class contains a large set of properties representing all character and paragraph formatting attributes at the text input position. The TextControl.InputFormat and WPF.TextControl.InputFormat properties provide access to these properties. All properties are automatically updated, when the input position changes so that the class can be used in a XAML data binding without code behind. The chapter Data binding with TX Text Control show how to use this class. Additionally the Selection class has been extended with the IncreaseIndent, DecreaseIndent, GrowFont and ShrinkFont methods.
Table Header | A header can be defined for each table in a TX Text Control document. A table header consists of one or more table rows, which are repeated on top of each page when a single table extends over several pages. The table attributes dialog box has been extended so that an end-user can define a table header. The new TableRow.IsHeader property can be used to set this feature programmatically. If a header is defined for a table which extends over several columns of a page, the header is displayed on top of each column.
Windows Forms Browser Applications | The Windows Forms TextControl can now be used in a browser-based application with the same functionality as in a Windows Forms application including loading and saving files on the client machine with every supported format. The BrowserTextControl and its toolbars are therefore no longer necessary and have been removed from the TXTextControl class library.
Spell checking | TX Text Control provides a new spell checker interface so that every spell checker can easily be used with a TextControl, ServerTextControl or WPF.TextControl. Every time the text of a document changes a SpellCheckText event is raised. The event's data contains the text that must be checked on misspelled words. The event's data can receive an array of MisspelledWord objects to inform TextControl about the positions of all misspelled words. These words are underlined with a red zigzag line. Spell checking is only active, if the IsSpellCheckingEnabled property has been set to true. A programmer has access to all misspelled words in the document through a MisspelledWordCollection, which can be obtained with the TextControl.MisspelledWords, ServerTextControl.MisspelledWords and WPF.TextControl.MisspelledWords properties. Similar properties are available for headers, footers and text frames. In text fields spell checking can be disabled with the TextField.IsSpellCheckingEnabled property.
Mail Merge | The DocumentServer.MailMerge class now supports merging of nested blocks. The component recursively descents into the tree structure and merges the contained fields with the corresponding relational data. Also, it is now possible to merge images into merge fields that have been prefixed with the string "image:". This allows to always merge the most recent version of a company logo into templates, for instance. Furthermore, the events now are all in line. DocumentServer.MailMerge.DataRowMergedEventArgs and DocumentServer.MailMerge.FieldMergedEventArgs now allow for subsequently changing the merged data using the internal TX Text Control Unicode format. Similarly, the new DocumentServer.MailMerge.ImageFieldMergedEventArgs allow to access the merged image as instance of the Image class.
Text Part Collection | A TX Text Control document consists of the document's main text and additional pieces of text like text frames and headers and footers. To provide easy access to all of these text parts TX Text Control offers the new TextPartCollection class. An instance of the this class contains all text parts in a TX Text Control document. A text part can either be the document's main text, a text frame or a header or footer. A text frame is represented through a TextFrame object, a header or footer through a HeaderFooter object and the document's main text is represented through a MainText object. A TextPartCollection object contains all these objects in a geometric order. The first object in the collection is the main text, followed by all text frames in geometric order. At the end of the collection all headers and footers are contained also geometrically ordered. All objects in a text part collection implement the IFormattedText interface. The collection can be obtained with the TextControl.TextParts, WPF.TextControl.TextParts or ServerTextControl.TextParts property. The collection provides an Activate method to set the current input position to a certain text part and the GetItem method to get the currently activated part.
IFormattedText Interface | The IFormattedText interface contains properties and methods common to all text parts in a TX Text Control document. A TX Text Control document consists of the document's main text and additional pieces of text such as text frames and headers and footers. A single text part has lines, paragraphs, characters and a selection which can be used to assign character and paragraph formatting attributes to a piece of text. Additionally, a text part can contain tables, images, text fields, hypertext links and misspelled words. The following classes implement this interface: TextControl, ServerTextControl, WPF.TextControl, TextFrame, HeaderFooter and MainText.
The MainText Class | The new MainText class represents the main text of a TX Text Control document. Differently from the TextControl or WPF.TextControl classes, the MainText object's collections of the IFormattedText interface do not depend on the input focus. For example, the TextControl.Tables collection contains the tables of the main text, if the main text has the input focus, but it contains the tables of the text frame, if a text frame has the input focus. The MainText.Tables collection always contains the tables of the main text regardless of the input focus.

Update Notes

Class/Property/Method/Event | Update Note
PageMargins class | The property type of the PageMargins.Left, PageMargins.Top, PageMargins.Right and PageMargins.Bottom properties has been changed from int to double.
TextControl.PageSize property | The property type has been changed from System.Drawing.Size to PageSize.
ServerTextControl.PageSize property | The property type has been changed from System.Drawing.Size to PageSize.
Selection.Load method | The return value of the methods, which open a dialog box has been changed from System.Windows.Forms.DialogResult to Selection.DialogResult.
BrowserTextControl class | This class has been removed. Each occurence can be replaced with the TextControl class.
BrowserButtonBar class | This class has been removed. Each occurence can be replaced with the ButtonBar class.
BrowserRulerBar class | This class has been removed. Each occurence can be replaced with the RulerBar class.
BrowserStatusBar class | This class has been removed. Each occurence can be replaced with the StatusBar class.
TX Text Control assemblies | The TXTextControl.dll assembly has been divided into TXTextControl.dll and TXTextControl.Windows.Forms.dll.


New Classes, Properties, Methods and Events

In TX Text Control 16.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs | The ImageFieldMergedEventArgs class provides data for the ImageFieldMerged event.
TXTextControl.IFormattedText | The IFormattedText interface contains properties and methods common to all text parts in a TX Text Control document.
TXTextControl.InputFormat | The InputFormat class represents all formatting attributes at the current text input position.
TXTextControl.MainText | The MainText class represents the main text of a TX Text Control document.
TXTextControl.MisspelledWord | The MisspelledWord class represents a misspelled word in a document's text.
TXTextControl.MisspelledWordCollection | An instance of the MisspelledWordCollection class contains all misspelled words in the main part of a Text Control document.
TXTextControl.PageSize | An instance of the PageSize class represents the page size of a TX Text Control document or document section.
TXTextControl.SpellCheckTextEventArgs | The SpellCheckTextEventArgs class provides data for the TextControl.SpellCheckText and WPF.TextControl.SpellCheckText events.
TXTextControl.TextPartCollection | An instance of the TextPartCollection class contains all text parts in a TX Text Control document.
TXTextControl.WPF.BooleanConverter | The BooleanConverter class provides a way to convert a value to a boolean value.
TXTextControl.WPF.ColorConverter | The WPF.ColorConverter class provides a way to convert a System.Drawing.Color value to System.Windows.Media.Color value.
TXTextControl.WPF.LogarithmicConverter | The class WPF.LogarithmicConverter Converts a numeric value from a linear scale to a logarithmic scale.
TXTextControl.WPF.MeasureConverter | The MeasureConverter class provides a way to convert a measure in twips (twentieth of a point) to a value in another measuring unit.
TXTextControl.WPF.RulerBar | The WPF.RulerBar class represents a tool bar which can be used to show or to set indents, margins and tabs of a WPF.TextControl.
TXTextControl.WPF.RulerBar.Colors | The WPF.RulerBarColors class gets, sets or resets the display colors of a WPF.RulerBar control.
TXTextControl.WPF.StatusBar | The WPF.StatusBar class represents a tool bar which can be used to show the position of the curent text input position and other status information of a WPF.TextControl.
TXTextControl.WPF.StatusBarColors | The WPF.StatusBarColors class gets, sets or resets the display colors of a WPF.StatusBar control.
TXTextControl.WPF.TextControl | The WPF.TextControl class class implements a control with high-level text editing features.
TXTextControl.WPF.TextControlColors | The WPF.TextControlColors class gets, sets or resets the display colors of a WPF.TextControl control.

Properties

Property | Description
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.MergedRow | Gets or sets a byte array that contains the complete data of the merged data row.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergedField | Gets or sets a byte array that contains the complete data of the merged field.
TXTextControl.DocumentServer.MailMerge.RemoveTrailingWhitespace | Specifies whether trailing whitespace should be removed before saving a document.
TXTextControl.HeaderFooter.HypertextLinks | Gets a collection of all hypertext links the header or footer contains.
TXTextControl.HeaderFooter.MisspelledWords | Gets a collection of all misspelled words the header or footer contains.
TXTextControl.ServerTextControl.IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
TXTextControl.ServerTextControl.MisspelledWords | Gets a collection of all misspelled words in the main text of the document.
TXTextControl.ServerTextControl.PageUnit | Gets or sets the measure used for page sizes and page margins.
TXTextControl.ServerTextControl.TextParts | Gets a collection of all text parts the current document contains.
TXTextControl.TableRow.IsHeader | Gets or sets a value specifying whether the table row is part of the table's header.
TXTextControl.TextControl.InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
TXTextControl.TextControl.IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
TXTextControl.TextControl.MisspelledWords | Gets a collection of all misspelled words contained in the text part with the input focus.
TXTextControl.TextControl.PageUnit | Gets or sets the measure used for page sizes and page margins.
TXTextControl.TextControl.TextParts | Gets a collection of all main text parts the current document contains.
TXTextControl.TextField.IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words.
TXTextControl.TextFrame.HypertextLinks | Gets a collection of all hypertext links in a text frame.
TXTextControl.TextFrame.MisspelledWords | Gets a collection of all misspelled words the text frame contains.

Methods

Method | Description
TXTextControl.DocumentServer.MailMerge.GetBlockNames | Lists the names of all merge blocks contained in the currently loaded template.
TXTextControl.HeaderFooter.Find | Finds a text string in a header or footer.
TXTextControl.Selection.DecreaseIndent | Decreases the left indent of all paragraphs contained in the current text selection.
TXTextControl.Selection.GrowFont | Increases the font size of each font contained in the current text selection.
TXTextControl.Selection.IncreaseIndent | Increases the left indent of all paragraphs contained in the current text selection.
TXTextControl.Selection.ShrinkFont | Decreases the font size of each font contained in the current text selection.
TXTextControl.ServerTextControl.OnSpellCheckText | Raises the SpellCheckText event.
TXTextControl.TextControl.OnSpellCheckText | Raises the SpellCheckText event.
TXTextControl.WPF.TextControl.OnSpellCheckText | Raises the SpellCheckText event.

Events

Event | Description
TXTextControl.DocumentServer.MailMerge.ImageFieldMerged | Occurs when an image field, i.e., a merge field whose name is prefixed with "image:" has been merged.
TXTextControl.ServerTextControl.SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
TXTextControl.TextControl.SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.


What's New in Version 15.1

The following provides a general list of features that have been added since TX Text Control version 15.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 15.1 provides the following new features:

New Features

Feature | Description
Drag&Drop | A Text Control has now a built-in Drag&Drop functionality. The TextControl.AllowDrop property installs the control as a target for data the user drags onto it and the TextControl.AllowDrag property enables the control as a source of a Drag&Drop operation. A TextControl accepts text formatted as Rich Text Format, HTML Format or plain text and images formatted as device dependent or device independent bitmaps, TIFF images or Windows metafiles. Other formats like files must be furthermore handled in the control's DragEnter, DragOver, DragLeave and DragDrop events, because the control does not know how the application handles files. If the user moves the cursor over the control, it shows the insertion point where the data is inserted with a non-blinking caret. By default text is moved through Drag&Drop, pressing the CTRL key, text is copied. The ESC key cancels an operation. The formats the control accepts through a drop can be set with the TextControl.DropFormats property.
Images and Text frames | Images and text frames can have an identifier and/or a name, which can be set with FrameBase.ID and FrameBase.Name properties. The ImageCollection.GetItem and the TextFrameCollection.GetItem methods can be used to look for an image or text frame with a given id or name. The InsertionMode and Location properties of images and text frames have been extended with a Set method, so that these properties can be altered. An Alignment property has been added for images and text frames which are anchored to a paragraph.
Display Colors | The colors which TX Text Control uses for the display elements of the tool bars and the text control can now be changed when for the control the ColorScheme border style has been set. By default the controls have a fixed color table for the standard Windows themes. Supported standard themes are the Windows XP standard theme: luna.msstyles (colors: Blue (NormalColor), Olive Green (Homestead), Silver (Metallic)), the Windows XP Media Center Edition standard theme: royale.msstyles (colors: NormalColor and Royale) and the Windows Vista and Windows 7 standard theme: aero.msstyles(colors: NormalColor). For all other themes the default colors depend on theme colors. If no theme is selected, the default colors depend on system colors. The TextControl.DisplayColors, ButtonBar.DisplayColors, RulerBar.DisplayColors and StatusBar.DisplayColors properties can be used to individually design the controls' colors.
Saving Images | With the SaveSettings.ImageSaveMode and SaveSettings.ImageExportFilterIndex properties all images of the document can be exported in a certain format and saving mode. The technical article Loading and Saving Images gives an overview how to export images.
Unlimited Zoom Factor | The ZoomFactor of a TextControl is no longer limited to 400 percent, when the ViewMode property has been set to PageView or Normal. For the other modes the zoom factor is furthermore limited to 400 percent.
Mouse Wheel | The functionality of the mouse wheel has been extended. Pressing the SHIFT key scrolls the visual part of the document horizontally and pressing the CONTROL key zooms the document.
Supported Fonts | The new GetSupportedFonts method returns an array of strings specifying the names of all currently supported fonts. These fonts depend on the formatting device set with the FormattingPrinter property.
Inserting Images | A new Image constructor accepts a System.Drawing.Image object, which is used to initialize the TXTextcontrol.Image object.

Update Notes

Class/Property/Method/Event | Update Note
FrameBase.Location property | This property can now be used to set the location of an image or text frame.
Image.InsertionMode property | This property can now be used to set the insertion mode of an image programatically.
TextFrame.InsertionMode property | This property can now be used to set the insertion mode of a text frame programatically.


New Classes, Properties, Methods and Events

In TX Text Control 15.1 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.ButtonBar.Colors | The ButtonBar.Colors class gets, sets or resets the display colors of a Windows Forms ButtonBar control.
TXTextControl.RulerBar.Colors | The RulerBar.Colors class gets, sets or resets the display colors of a Windows Forms RulerBar control.
TXTextControl.StatusBar.Colors | The StatusBar.Colors class gets, sets or resets the display colors of a Windows Forms StatusBar control.
TXTextControl.TextControl.Colors | The TextControl.Colors class gets, sets or resets the display colors of a Windows Forms TextControl control.

Properties

Property | Description
TXTextControl.ButtonBar.DisplayColors | Gets or sets the colors of the button bar.
TXTextControl.FrameBase.Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph.
TXTextControl.FrameBase.ID | Gets or sets an identifier for the frame.
TXTextControl.FrameBase.Name | Gets or sets a name for the frame.
TXTextControl.RulerBar.DisplayColors | Gets or sets the colors of the ruler bar.
TXTextControl.SaveSettings.ImageExportFilterIndex | Sets the format used for saving all images contained in the document.
TXTextControl.SaveSettings.ImageSaveMode | Determines whether the document's images are stored through its data or through its file reference.
TXTextControl.StatusBar.DisplayColors | Gets or sets the colors of the status bar.
TXTextControl.TextControl.AllowDrag | Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation.
TXTextControl.TextControl.AllowDrop | Overridden. Gets or sets a value indicating whether the control can accept data that the user drags onto it.
TXTextControl.TextControl.DisplayColors | Gets or sets the colors of the text control.
TXTextControl.TextControl.DropFormats | Gets or sets the formats of data the control can accept when the user drags it onto the control.

Methods

Method | Description
TXTextControl.ButtonBar.ResetDisplayColors | Resets all display colors of a button bar to their system dependent default values.
TXTextControl.ImageCollection.GetItem | Gets a particular image from the collection.
TXTextControl.RulerBar.ResetDisplayColors | Resets all display colors of a ruler bar to their system dependent default values.
TXTextControl.ServerTextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.StatusBar.ResetDisplayColors | Resets all display colors of a status bar to their system dependent default values.
TXTextControl.TextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.TextControl.ResetDisplayColors | Resets all display colors of a text control to their system dependent default values.
TXTextControl.TextFrameCollection.GetItem | Gets a particular text frame from the collection.


What's New in Version 15.0

The following provides a general list of features that have been added since TX Text Control version 14.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 15.0 provides several new features described in the following table.

New Features

Feature | Description
Arranging Text in Columns | The text of a document can now be arranged in columns. The number of columns is an attribute of a document section, so that different numbers of columns can be used in the same document. Depending on where a section starts, the number of columns can change everywhere on a page. Further attributes are the widths of the columns and the distance between the columns that can individually be changed. In an automatic mode the width of the columns are calculated from the page width, which is the default setting. An end-user can use an additional tab of the Page Setup dialog box to make column settings and the TX TextControl ruler bar shows the columns' widths and the distances between the columns. The SHIFT-CTRL-RETURN keyboard key combination inserts a break character which forces that text is continued in the next column. The SectionFormat class has been extended with several properties to alter columns programatically.
Archiving Documents in PDF/A Format A document can now be archived in PDF/A format. TX Text Control supports the ISO Standard PDF/A-1 Level B. In addition to standard PDF the following data is saved:
  • only embeddable fonts are saved
  • document data like title or author is saved in XMP format
  • Additional font data is stored specifying which characters of a font are used
  • A color profile is saved
  • Links to start other applications are not allowed
  • Access restrictions are not allowed. The SaveSettings.DocumentAccessPermissions property is ignored.
The StreamType and BinaryStreamType enumerations have been extended with the AdobePDFA member thus this format can be saved with all TextControl.Save methods. Before saving PDF/A the FontSettings.EmbeddableFontsOnly property must be set to true, so that the document contains only embeddable fonts. The font replacement can be controlled with the TextControl.AdaptFont event.
Structured Numbered Lists | TX Text Control supports now structured numbered lists. A structured list displays for each level its list number and additionally the list numbers of the higher levels. The text in front and behind the list number is also displayed for all higher levels. The text in front and behind the list number can now be longer than one character. The ListFormat.Type property has been extended with the ListType.Structured setting to support such lists. The ListFormat.TextAfterNumber and ListFormat.TextBeforeNumber properties have been added to support text longer than one character in front and behind the list numbers.
Importing Text from PDF Files | TX Text Control can extract the text from PDF files and load it in a TXTextControl document. The StreamType.AdobePDF member can be used with all TextControl.Load methods to import the text. Adobe PDF format is a low-level output format. In most cases in contains only geometrical information about the single characters. A high-level document structure specifying paragraphs, tables, sections and styles is not available. The TXTextControl PDF import filter can either handle each line of text as a single paragraph or it can generate paragraphs from the text flow. Another mode generates a text frame for each block of text. These frames are placed at the same position as in the PDF document. The LoadSettings.PDFImportSettings property can be used to specify the required behavior. These features will be enhanced in future TXTextControl versions.
Programming Paragraphs | To provide a better support for programming paragraphs a Paragraphs collection has been implemented. This collection is seperately available for the main text of the document and for headers and footers and text frames. For each Paragraph all formatting attributes can be programmed with a ParagraphFormat and a ListFormat object. Further properties are available for the first character and the first line of a paragraph, for the number of characters and lines and for the formatting style. A Text property and several Save methods can be used to get the paragraph's contents. The ListNumber and the ListNumberText properties provide further support for numbered lists.
Tool Bars | The TX Text Control Button Bar provides a new button for setting a structured numbered list. The ButtonPositions, ButtonOffsets and ButtonSeparators properties of the TX Text Control Button Bar have been appropriately extended.
Pasting data from the Clipboard | TX Text Control provides an interface that enables a programmer to change the default behaviour for pasting data from the clipboard. The new TextControl.GetClipboardFormats method and an additional version of the TextControl.Paste method have been implemented to support this feature.
Page Images | TX Text Control provides an image of a page's contents. The image is either an enhanced metafile or a bitmap in screen resolution. The new Page.GetImage method can be used to get the image.
ASP.NET DocumentViewer | This new cross-browser compatible ASP.NET component is designed to view documents on the web. In combination with the DocumentServer.DocumentController, all file types supported by TX Text Control can be loaded and displayed in this WYSIWYG viewer. Additionally, MS Word compatible form fields can be completed using the DocumentServer.Web.DocumentViewer. Also, snapshots of the currently loaded document can be taken for further processing and the user input can be saved separately as well.
MailMerge | The DocumentServer.MailMerge component's functionality has been extended with the MS Word compatible field types DocumentServer.Fields.IfField, DocumentServer.Fields.DateField and DocumentServer.Fields.IncludeText. Additionally, the event DocumentServer.MailMerge.FieldMerged has been implemented which is triggered on merging each field.
Adapter Fields | The DocumentServer is extended with the Fields namespace. This namespace implements adapter fields for the typically used MS Word merge and form fields that are used by the DocumentServer.MailMerge and DocumentServer.Web.DocumentViewer components. These adapter fields can be used to create and manipulate these specific ApplicationField objects without changing the ApplicationField.Parameters manually.

Update Notes

Class/Property/Method/Event | Update Note
ListFormat class | The ListFormat.TextAfterNumber and ListFormat.TextBeforeNumber properties replace the ListFormat.CharAfterNumber and ListFormat.CharBeforeNumber properties to support longer text in front and behind the numbers of numbered lists. Although still implemented for compatibility a new application should not use the older versions.


New Classes, Properties, Methods and Events

In TX Text Control 15.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.AdaptFontEventArgs | The AdaptFontEventArgs class provides data for the TextControl.AdaptFont, WPF.TextControl.AdaptFont and ServerTextControl.AdaptFont events.
TXTextControl.DocumentServer.DocumentController | The DocumentController class is a .NET component that can be used to perform the necessary document handling on the server, when using a control such as the DocumentServer.Web.DocumentViewer.
TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection | An instance of the FieldAdapterCollection class contains adapters for all application fields of the page it belongs to.
TXTextControl.DocumentServer.Fields.DateField | The DateField implements the MS Word specific DATEFIELD field.
TXTextControl.DocumentServer.Fields.FieldAdapter | The abstract FieldAdapter class is the base class of all special DocumentServer field adapters.
TXTextControl.DocumentServer.Fields.FormCheckBox | The FormText implements the MS Word specific FORMCHECKBOX field.
TXTextControl.DocumentServer.Fields.FormDropDown | The FormDropDown class implements the MS Word specific FORMDROPDOWN field.
TXTextControl.DocumentServer.Fields.FormFieldAdapter | The abstract FormFieldAdapter class is the base class of all special DocumentServer form field adapters.
TXTextControl.DocumentServer.Fields.FormText | The FormText class implements the MS Word specific FORMTEXT field.
TXTextControl.DocumentServer.Fields.IfField | The IfField class implements the MS Word specific IF field.
TXTextControl.DocumentServer.Fields.IncludeText | The IncludeText class implements the MS Word specific INCLUDETEXT field.
TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter | The abstract MailMergeFieldAdapter class is the base class of all special DocumentServer mail merge field adapters.
TXTextControl.DocumentServer.Fields.MergeField | The MergeField class implements the MS Word specific MERGEFIELD field.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs | The FieldMergedEventArgs class provides data for the FieldMerged event.
TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs | The IncludeTextMergingEventArgs class provides data for the IncludeTextMerging event.
TXTextControl.DocumentServer.Web.DocumentViewer | The DocumentViewer class is a .NET component that can be used to display documents in the web browser in ASP.NET projects.
TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs | The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveDocument event.
TXTextControl.DocumentServer.Web.DocumentViewer.SaveFormDataEventArgs | The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveFormData event.
TXTextControl.FontSettings | The FontSettings class provides settings determining which fonts can be used in a document.
TXTextControl.Paragraph | An instance of the Paragraph class represents a single paragraph in a Text Control document.
TXTextControl.ParagraphCollection | An instance of the ParagraphCollection class contains all paragraphs in a Text Control document or part of the document represented through objects of the type Paragraph.

Properties

Property | Description
TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.DataRowCount | Gets an int value that indicates the total number of data rows.
TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.MergeBlockName | Gets a string value that indicates current merge block name.
TXTextControl.DocumentServer.MailMerge.SearchPath | Specifies a directory name where sub-templates and images (for image merging) should be searched.
TXTextControl.HeaderFooter.Paragraphs | Gets a collection of all paragraphs the header or footer contains.
TXTextControl.ListFormat.TextAfterNumber | Gets or sets the text that is displayed behind the number in a numbered list.
TXTextControl.ListFormat.TextBeforeNumber | Gets or sets the text that is displayed in front of the number in a numbered list.
TXTextControl.LoadSettings.PDFImportSettings | Specifies how the document structure is generated when a PDF document is imported.
TXTextControl.SectionFormat.ColumnDistances | Gets the distances, in twips, between the columns on a page.
TXTextControl.SectionFormat.ColumnLineColor | Gets or sets the color of a dividing line between two columns.
TXTextControl.SectionFormat.ColumnLineWidth | Gets or sets the width of a dividing line between two columns.
TXTextControl.SectionFormat.Columns | Gets or sets the number of columns on a page.
TXTextControl.SectionFormat.ColumnWidths | Gets the widths, in twips, of the columns on a page.
TXTextControl.SectionFormat.EqualColumnWidth | Gets or sets a value indicating whether the columns on a page have all the same width and the same distance between them.
TXTextControl.ServerTextControl.FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
TXTextControl.ServerTextControl.Paragraphs | Gets a collection of all paragraphs contained in the main text of the document.
TXTextControl.TextControl.FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
TXTextControl.TextControl.Paragraphs | Gets a collection of all paragraphs contained in the text part with the input focus.
TXTextControl.TextField.Bounds | Gets the bounding rectangle of a text field.
TXTextControl.TextField.FormattingBounds | Gets the formatting rectangle of a text field.
TXTextControl.TextFrame.Paragraphs | Gets a collection of all paragraphs contained in a text frame.

Methods

Method | Description
TXTextControl.Page.GetImage | Gets an image of the page's contents.
TXTextControl.ServerTextControl.OnAdaptFont | Raises the AdaptFont event.
TXTextControl.TextControl.GetClipboardFormats | Returns an array of ClipboardFormat values.
TXTextControl.TextControl.OnAdaptFont | Raises the AdaptFont event.
TXTextControl.TextControl.Paste | Replaces the current selection in the Text Control with the contents of the Clipboard.

Events

Event | Description
TXTextControl.DocumentServer.MailMerge.FieldMerged | Occurs when a field has been merged.
TXTextControl.DocumentServer.MailMerge.IncludeTextMerging | Occurs when an IncludeText field has been merged.
TXTextControl.ServerTextControl.AdaptFont | Occurs for each font that must be adapted, because it is not supported.
TXTextControl.TextControl.AdaptFont | Occurs for each font that must be adapted, because it is not supported.


What's New in Version 14.0

The following provides a general list of features that have been added since TX Text Control version 13.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 14.0 provides several new features described in the following table.

New Features

Feature | Description
64 bit Edition | TX Text Control is available as a 64 bit edition. All kernel and filter DLL files have been extended to support 64 bit memory addresses. The names of the DLL files are the same for 32 bit and 64 bit. The TX Text Control class library is platform independent.
Section Formatting | A document can be split into several sections to enable different page sizes and margins and different headers and footers in the same document. An end-user can use the new Page Setup dialog box available through the TextControl.SectionFormatDialog method. All section attributes and headers and footers can be set either for a single section or for the complete document. A SectionCollection available through the TextControl.Sections property enables a programmer to alter the formatting attributes of a section from programming code. The sections of a document are numbered beginning with 1. The StatusBar has been extended to show the section number at the text input position. Additionally, it shows the number of pages and the number of sections contained in the document.
Headers and Footers | The contents and the alignment of headers and footers can be different for each section. Also each section can have a special header and a special footer for the section's first page. If a section does not need its own header or footer, its header or footer can be connected with the header or footer of the previous section. The HeaderFooter.ConnectedToPrevious property implements this feature. A HeaderFooterCollection is available for the complete document and for a single section.
WordprocessingML Format | TX Text Control supports the WordprocessingML part of the Microsoft Office Open XML format. This format is a ZIP compressed XML format for word processing and is used as standard format of Microsoft Word. A TextControl can load and save files (.docx extension) and blocks of memory containing documents formatted with this format. The StreamType and BinaryStreamType enumerations have been extended with the WordprocessingML member thus this format can be loaded and saved with the TextControl.Load and TextControl.Save methods.
Import and Export of Microsoft Word Fields | TX Text Control now supports importing and exporting Microsoft Word fields contained in Microsoft Word and RTF documents. The arguments and switches of these fields are available through the ApplicationField class using the ApplicationFieldFormat.MSWord format. This class only provides an interface to retrieve and change the data and parameters of such fields. The field logic itself is not implemented. The TextControl.ApplicationFields collection lists all fields in the document. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set to ApplicationFieldFormat.MSWord. The LoadSettings.ApplicationFieldTypeNames property can be used to select particular types of fields. For more information, see the technical article Text Fields and Hypertext Links - Importing Fields from Microsoft Word.
Mail Merge | A MailMerge component has been added that can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET web applications, web services or Windows services. The MailMerge component uses a ServerTextControl and fields of the type ApplicationField to merge the database content and a document template. The set of merged documents can be saved in each format available through the StreamType enumeration, either as single documents or as one document.
Import and Export of Heiler HighEdit Fields | TX Text Control also supports the import and export of Heiler HighEdit fields contained in RTF documents. The names of these fields are available through the ApplicationField class using the ApplicationFieldFormat.HighEdit format.
Page Coordinates | Because a document can have pages with different sizes a PageCollection informs about the alignment of the page and the page's text contents. Furthermore, a Page object has properties to inform about its character index, number of characters, section number and the number of the page in the section. The PageCollection is available through the TextControl.GetPages method.
Merging Documents | For better support when merging documents, the TextControl.Append and ServerTextControl.Append methods have been added. These sets of methods load text in a certain format from a file, a byte array or a string and append it to the existing document. It can be specified that the document is appended at the end of the existing document or if a new paragraph or section is created for the appended document.
Formatting Printer | A printer for which the document is formatted can be specified with the TextControl.FormattingPrinter property. If the document is printed with this printer the displayed and the printed document have the same dimensions. The formatting device can also be the display device.
Background Printing | Additional contents such as images or watermarks can be printed on a page of a document. An application can add its own PrintPageEventHandler to a PrintDocument. If this handler performs some output the contents of a TextControl or ServerTextControl are printed transparently on top of this output.

Update Notes

Class/Property/Method/Event | Update Note
HeaderFooterCollection.Style property | This property has been replaced with the TextControl.HeaderFooterActivationStyle and TextControl.HeaderFooterFrameStyle properties.


New Classes, Properties, Methods and Events

In TX Text Control 14.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.ApplicationField | The ApplicationField class supports text field formats of applications such as Microsoft Word.
TXTextControl.ApplicationFieldCollection | An instance of the ApplicationFieldCollection class contains all created or imported Microsoft Word or Heiler HighEdit fields represented through objects of the type ApplicationField.
TXTextControl.DocumentServer.MailMerge | The MailMerge class is a .NET component that can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET web applications, web services or Windows services.
TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs | The BlockRowMergedEventArgs class provides data for the BlockRowMerged event.
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs | The DataRowMergedEventArgs class provides data for the DataRowMerged event.
TXTextControl.Page | An object of the Page class represents a formatted page of a document.
TXTextControl.PageCollection | An instance of the PageCollection class contains all pages of a document.
TXTextControl.Section | An object of the Section class represents a section of a document.
TXTextControl.SectionCollection | An instance of the SectionCollection class contains all sections of a document.
TXTextControl.SectionFormat | An instance of the SectionFormat class represents the formatting attributes of a section.

Properties

Property | Description
TXTextControl.HeaderFooter.ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
TXTextControl.HeaderFooter.ConnectedToPrevious | Gets or sets a value specifying whether the header or footer is connected with the header or footer of the previous section.
TXTextControl.HeaderFooter.SectionNumber | Returns the number of the section to which the header or footer belongs.
TXTextControl.InputPosition.PageInSection | Gets the page number in the section containing the current text input position.
TXTextControl.InputPosition.Section | Gets the section number of the current text input position.
TXTextControl.Line.Page | Gets the number of the page to which the line belongs.
TXTextControl.LoadSettings.ApplicationFieldFormat | Specifies the format of text fields which are imported.
TXTextControl.LoadSettings.ApplicationFieldTypeNames | Specifies an array of strings containing the type names of fields which are to be imported.
TXTextControl.Selection.SectionFormat | Gets or sets page settings such as margins, size and orientation for the selected text.
TXTextControl.ServerTextControl.ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
TXTextControl.ServerTextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.ServerTextControl.GetPages | Gets a collection of all pages in the document.
TXTextControl.ServerTextControl.Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
TXTextControl.ServerTextControl.Sections | Gets a collection of all sections in the document.
TXTextControl.StatusBar.PageCounterText | Gets or sets the text in the 'Page counter' area of the status bar.
TXTextControl.StatusBar.SectionCounterText | Gets or sets the text in the 'Section counter' area of the status bar.
TXTextControl.StatusBar.SectionText | Gets or sets the text in the 'Section' area of the status bar.
TXTextControl.StatusBar.ShowColumn | Specifies whether the status bar shows the column number of the current text input position.
TXTextControl.StatusBar.ShowKeyStates | Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.
TXTextControl.StatusBar.ShowLine | Specifies whether the status bar shows the line number of the current text input position.
TXTextControl.StatusBar.ShowPage | Specifies whether the status bar shows the page number of the current text input position.
TXTextControl.StatusBar.ShowPageCounter | Specifies whether the status bar shows the number of pages the document consists of.
TXTextControl.StatusBar.ShowSection | Specifies whether the status bar shows the section number of the current text input position.
TXTextControl.StatusBar.ShowSectionCounter | Specifies whether the status bar shows the number of sections the document consists of.
TXTextControl.StatusBar.ShowZoom | Specifies whether the status bar shows the current zoom factor.
TXTextControl.TextControl.ApplicationFields | Gets a collection of all application fields contained in the text part with the input focus.
TXTextControl.TextControl.BackgroundStyle | Defines the kind of view to display the page background.
TXTextControl.TextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.TextControl.GetPages | Gets a collection of all pages in the document.
TXTextControl.TextControl.HeaderFooterActivationStyle | Gets or sets a value specifying the activation style for headers and footers.
TXTextControl.TextControl.HeaderFooterFrameStyle | Gets or sets a value specifying the frame for activated headers and footers.
TXTextControl.TextControl.Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
TXTextControl.TextControl.Sections | Gets a collection of all sections in the document.
TXTextControl.TextFrame.ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.

Methods

Method | Description
TXTextControl.ServerTextControl.Append | Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
TXTextControl.TextControl.Append | Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
TXTextControl.TextControl.OnPageChanged | Raises the PageChanged event.
TXTextControl.TextControl.OnSectionChanged | Raises the SectionChanged event.
TXTextControl.TextControl.SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.

Events

Event | Description
TXTextControl.TextControl.PageChanged | Occurs when the text input position has been moved to another page.
TXTextControl.TextControl.SectionChanged | Occurs when the text input position has been moved to another section.


What's New in Version 13.0

The following provides a general list of features that have been added since TX Text Control version 12.0.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 13.0 provides the several new features all described in the following tables.

New Features

Feature | Description
Vertical Ruler Bar | TX Text Control now offers a vertical ruler bar with which the user can set the top and the bottom page margin, the position and the height of headers and footers and the height of table cells. The RulerBar class has an additional Alignment property to switch the bar from horizontal to vertical. The control's Dock property sets the bar's direction automatically. The vertical ruler bar is connected to a TextControl with the TextControl.VerticalRulerBar property.
Tool Bar Design | All tool bars now support the Windows color schemes that can be selected through the system settings. The buttons and the background of the button bar has a light to dark variation in color and the ruler bar and status bar have a unified background color depending on the system's color scheme. The new design can be selected through the ColorScheme setting of the ButtonBar.ButtonStyle, ButtonBar.BorderStyle, RulerBar.BorderStyle and StatusBar.BorderStyle properties.
Hypertext Links in PDF Documents | TX Text Control now supports hypertext links when a document is exported in Adobe PDF format. All text fields in a TX Text Control document which are of the types HypertextLink, DocumentLink or DocumentTarget are converted to an appropriate link or target in the Adobe PDF document.
Paragraph Formatting | TX Text Control offers a new dialog box for setting paragraph attributes. Additional features have been added to set paragraph frames and textflow options like Keep with next paragraph, Keep lines of paragraph together, Page break before paragraph and Widow/Orphan control. These features are also available with the ParagraphFormat.KeepWithNext, ParagraphFormat.KeepLinesTogether, ParagraphFormat.PageBreakBefore and ParagraphFormat.WidowOrphanLines properties.
Clipboard Import | TX Text Control now imports HTML formatted text from the clipboard.
Hypertext Targets | The new property TextControl.DocumentTargetMarkers can be used to make hypertext targets visible.
Text Fields and Hypertext Links | A new constructor of the InputPosition class determines the exact input position at the beginning or at the end of a TextField or one of its derived classes.

Update Notes

Class/Property/Method/Event | Update Note
TextControl.AutoControlSize Property | This property has been renamed from AutoSize to AutoControlSize because the System.Windows.Forms.Control class that is the base class of the TextControl class has been extended with an AutoSize property of a different type.
TextFieldCollection.Remove Method | The new keepText parameter can be used to preserve the field's text from deleting.
HypertextLinkCollection.Remove Method | The new keepText parameter can be used to preserve the hypertext link's text from deleting.
DocumentLinkCollection.Remove Method | The new keepText parameter can be used to preserve the document link's text from deleting.


New Classes, Properties, Methods and Events

In TX Text Control 13.0 the following new classes, properties, methods and events have been added:

Properties

Property | Description
TXTextControl.ParagraphFormat.KeepLinesTogether | Gets or sets a value indicating whether a page break is allowed within the paragraph.
TXTextControl.ParagraphFormat.KeepWithNext | If this property is set to true, the paragraph is displayed on the same page as its following paragraph.
TXTextControl.ParagraphFormat.PageBreakBefore | If this property is set to true, the paragraph is always displayed on top of a page.
TXTextControl.ParagraphFormat.WidowOrphanLines | Gets or sets the number of lines for widow/orphan control.
TXTextControl.RulerBar.Alignment | Gets or sets a value specifying the alignment of the ruler bar in the document.
TXTextControl.RulerBar.EnablePageMargins | Enables or disables the setting of page margins.
TXTextControl.TextControl.DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.

Methods

Method | Description
TXTextControl.DocumentLinkCollection.Clear | Removes all document links from a Text Control document.
TXTextControl.DocumentTargetCollection.Clear | Removes all document targets from a Text Control document.
TXTextControl.FrameBaseCollection.Clear | Removes all objects from the collection and from the document.
TXTextControl.HypertextLinkCollection.Clear | Removes all hypertext links from a Text Control document.
TXTextControl.PageNumberFieldCollection.Clear | Removes all page number fields contained in the collection from the document.
TXTextControl.TableBaseCollection.Clear | Removes all tables contained in the collection from a Text Control document.
TXTextControl.TextFieldCollection.Clear | Removes all text fields from a Text Control document.
TXTextControl.TextFrame.Activate | Activates the text frame.
TXTextControl.TextFrame.Find | Finds a text string in a text frame.
TXTextControl.TextFrameCollection.DeactivateItem | Deactivates the activated text frame and sets the input focus back to the text part that contains the text frame.


What's New in Version 12.0

The following provides a general list of features that have been added since TX Text Control version 11.0.

New Features

New Classes, Properties, Methods and Events


New Features

TX Text Control 12.0 provides the several new features all described in the following tables.

New Features

Feature | Description
Anchored Images | In prior versions of TX Text Control images could either be inserted as a single character or geometrically positioned relative to the complete document. Now a third method is supported that is called 'anchored to a paragraph'. This means that the text still flows around the image but the geometrical position is relative to the paragraph to which it is anchored. If other text is inserted in front of this paragraph the image is moved with the text. Additional implementations of the ImageCollection.Add method have been implemented to insert such an image in the text. All properties of the Image class have been enhanced so that the programmer can manipulate anchored images like all other images.
Text Frames | TX Text Control now supports text frames. A text frame is a rectangle that can be filled with text by an end-user and that can be edited like the main text. A text frame can be positioned like an image, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to a document's page. Text frames can be inserted, deleted and manipulated through the TextFrameCollection class that can be obtained through the TextControl.TextFrames Property. The TextFrameCollection class work in the same way as the ImageCollection class. A text frame is fully programable from program code. The TextFrame class provides properties and methods that enable a programmer to manipulate a text frame's text in the same way as the document's main text. Further properties set text frame attributes, such as the width of the border line, internal margins and the background color.
Image and Text Frame Attributes | Two new built-in dialog boxes have been added to allow attributes of images and text frames to be changed. It can be used to set general attributes, such as size, text wrapping, scaling and text distances. Furthermore, special attributes of images like filename, format, resolution and compression for image export, and special attributes of text frames like background color and frame attributes can be set. The new TextControl.ImageAttributesDialog and TextControl.TextFrameAttributesDialog methods open these dialogs.
Server Programming | TX Text Control provides the new ServerTextControl class to support programable text features for use in a server-based ASP.NET application. This class has the same programming interface than the TextControl class without the visual interface. A large amount of example programs are available and are described in the ASP.NET User's Guide.
Image and Text Frame Mouse Interface | A new mouse interface for images and text frames is available. They can be moved and sized in every insertion mode. A selection frame with size handles shows the current selection state.
Table Formatting | Additional features have been added to give end-users more control of how tables are formatted at page breaks. A forced page break can be inserted in a table at each character position using the CTRL+ENTER key combination. This moves the complete table row to the next page. Additionally, a table row can receive a new formatting attribute determining that the complete row is moved to the next page, if at least one line of text is on the next page. Furthermore, a height can be specified which is the table row's minimum height. If more text is inserted, the height grows as necessary. All of these features can be set with the built-in dialog box for setting table attributes and through code using the TableRow.MinimumHeight and TableRow.AllowPageBreak properties.


New Classes, Properties, Methods and Events

In TX Text Control 12.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.ServerTextControl | The ServerTextControl class implements a component that provide high-level text processing features for server-based applications.
TXTextControl.TextFrame | An instance of the TextFrame class represents a text frame in a Text Control document.
TXTextControl.TextFrameCollection | An instance of the TextFrameCollection class contains all text frames in a Text Control document or part of the document represented through objects of the type TextFrame.
TXTextControl.TextFrameEventArgs | The TextFrameEventArgs class provides data for all events that occur with text frames.

Properties

Property | Description
TXTextControl.HeaderFooter.TextFrames | Gets a collection of all text frames contained in a header or footer.
TXTextControl.TableRow.AllowPageBreak | Gets or sets a value specifying how the table row is formatted at page breaks.
TXTextControl.TableRow.MinimumHeight | Gets or sets the minimum height, in twips, of the table row.
TXTextControl.TextControl.TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TXTextControl.TextControl.TextFrames | Gets a collection of all text frames contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.TextControl.ImageAttributesDialog | Invokes the built-in dialog box for setting attributes of images.
TXTextControl.TextControl.OnImageRightClicked | Raises the ImageRightClicked event.
TXTextControl.TextControl.OnTextFrameActivated | Raises the TextFrameActivated event.
TXTextControl.TextControl.OnTextFrameClicked | Raises the TextFrameClicked event.
TXTextControl.TextControl.OnTextFrameCreated | Raises the TextFrameCreated event.
TXTextControl.TextControl.OnTextFrameDeactivated | Raises the TextFrameDeactivated event.
TXTextControl.TextControl.OnTextFrameDeleted | Raises the TextFrameDeleted event.
TXTextControl.TextControl.OnTextFrameDoubleClicked | Raises the TextFrameDoubleClicked event.
TXTextControl.TextControl.OnTextFrameMoved | Raises the TextFrameMoved event.
TXTextControl.TextControl.OnTextFrameRightClicked | Raises the TextFrameRightClicked event.
TXTextControl.TextControl.OnTextFrameSized | Raises the TextFrameSized event.
TXTextControl.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.
TXTextControl.WPF.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.

Events

Event | Description
TXTextControl.TextControl.ImageRightClicked | Occurs when an image has been clicked on with the right mouse button.
TXTextControl.TextControl.TextFrameActivated | Occurs when a text frame has been activated.
TXTextControl.TextControl.TextFrameClicked | Occurs when a text frame has been clicked on.
TXTextControl.TextControl.TextFrameCreated | Occurs when a new text frame has been created.
TXTextControl.TextControl.TextFrameDeactivated | Occurs when a text frame has been deactivated.
TXTextControl.TextControl.TextFrameDeleted | Occurs when a text frame has been deleted.
TXTextControl.TextControl.TextFrameDoubleClicked | Occurs when a text frame has been doubleclicked on.
TXTextControl.TextControl.TextFrameMoved | Occurs when a text frame has been moved.
TXTextControl.TextControl.TextFrameRightClicked | Occurs when a text frame has been clicked on with the right mouse button.
TXTextControl.TextControl.TextFrameSized | Occurs when a text frame has been sized.


What's New in Version 11.0

The following provides a general list of features that have been added since TX Text Control version 10.1.

New Features and Update Notes

New Classes, Properties, Methods and Events


New Features and Update Notes

TX Text Control 11.0 provides the several new features all described in the following tables.

New Features

Feature | Description
Nested Tables | A table can be inserted within another table. Such a table is called a nested table. The level of nesting is not limited. All of TX Text Control's text filters have been expanded to import and export nested tables. To refer to a nested table, the same classes can be used as for top-level tables. The TextControl.Tables collection contains all top-level and all nested tables in the order they appear in the text flow. In addition, each table has a Table.NestedTables property to get a collection of all tables embedded in a certain table. Other properties have been added to the Table class to get a table's nesting level or to get its outer or outermost table.
Table Splitting | A table can be split below or above the table row containing the current input position with the Table.Split method. If the original table has an identifier, both parts retain their identifier. A TextControl.TableCreated event occurs for the bottom part to enable the application to change the identifier of the bottom part. If a table is split above the first row, a new line is inserted above the table, and if a table is split below the last row, a new line is inserted below the table. This is useful to insert text above or below a nested table that immediately starts and/or ends at the beginning or the end of the cell in which it is nested.
Multiple Undo | Text Control has a new undo buffer that supports multiple undo and redo operations. Additionally, the undo buffer now supports many more Text Control features such as images, text fields and all table operations. The new properties TextControl.UndoActionName and TextControl.RedoActionName can help to inform an end-user what is the next action to undo or redo. The new property TextControl.AllowUndo activates or deactivates the undo buffer. Deactivating the undo buffer saves time and memory which can be useful, if a Text Control for example is deployed as a report generator.
Image Resolution and Compression Quality | If images are embedded in a document with their complete binary data, it can be useful to alter an image's resolution and the quality of the data compression algorithm to minimize the file size. By default, Text Control uses the image's default resolution and a default value for the data compression. The SaveSettings.ImageCompressionQuality and SaveSettings.ImageMaxResolution properties can be used to alter these values for all images in the complete document. The Image.ExportCompressionQuality and Image.ExportMaxResolution properties can be used to overwrite these values for a single image.
Resource Kit for Localization | A new Resource Kit allows all built-in resources to be localized. Text Control uses satellite assemblies for localized resources. Developers simply need to translate the strings in a .resx file to another language and run a batch file to build a satellite assembly. The created assembly can be installed in a subdirectory of your application's directory.
PDF Document Security | New properties of the SaveSettings class allow the setting of the standard PDF security features. Both passwords can be set: a user password to allow document opening and a master password to allow modification of the current access permissions. Furthermore, the SaveSettings.DocumentAccessPermissions property allows individual access permissions to be set.
Ruler Bar Design | The Ruler Bar Control has an additional look with a flat design. This new look is now the default setting, but the previous look can still be set with the new RulerBar.BorderStyle property.
Autoexpanding/Autoshrinking | If a Text Control is used to display small pieces of text, for example to show the contents of a database field, it can be useful to adapt the control's size to its text contents. The TextControl.AutoControlSize property and the AutoSize class have been added to support automatically expanding and shrinking up to a specified maximum and/or minimum. New events have been added to the TextControl class that occur after a Text Control has been expanded and/or shrunk. All of these features require the SimpleControl setting of the TextControl.ViewMode property.
Transparency | Another feature that can be useful when displaying small pieces of text is to show the text with a transparent background. The TextControl.BackColor property can be set to Color.Transparent to support this feature. Transparency also requires the SimpleControl setting of the TextControl.ViewMode property.

Update Notes

Class/Property/Method/Event | Update Note
TextControl.BackColor Property | The property value can be set to Color.Transparent to have a transparent background. A transparent background is only possible if the TextControl.ViewMode property has been set to SimpleControl.
InlineStyle Class | An additional constructor allows to create a new style based on a given style. All attributes of the given style are used to initialize the new style.
ParagraphStyle Class | An additional constructor allows to create a new style based on a given style. All attributes of the given style are used to initialize the new style.


New Classes, Properties, Methods and Events

In TX Text Control 11.0 the following new classes, properties, methods and events have been added:

Classes

Class | Description
TXTextControl.AutoSize | The AutoSize class is used with the TextControl.AutoControlSize property, to enable automatic expansion or shrinking of a Text Control's width or height.
TXTextControl.TableBaseCollection | The TableBaseCollection class is the base class for the table collection classes.

Properties

Property | Description
TXTextControl.Image.ExportCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy data compression used if this image is saved.
TXTextControl.Image.ExportMaxResolution | Gets or sets the maximum resolution in dots per inch used if this image is saved.
TXTextControl.RulerBar.BorderStyle | Gets or sets the border style of the ruler bar.
TXTextControl.SaveSettings.DocumentAccessPermissions | Specifies how a document can be accessed after it has been opened.
TXTextControl.SaveSettings.ImageCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy image compression used when a document is saved.
TXTextControl.SaveSettings.ImageMaxResolution | Sets the maximum resolution for all images in the document in dots per inch when the document is saved.
TXTextControl.SaveSettings.MasterPassword | Specifies the password for the document's access permissions.
TXTextControl.SaveSettings.UserPassword | Specifies the password for the user when the document is reopened.
TXTextControl.StatusBar.BorderStyle | Gets or sets the border style of the status bar.
TXTextControl.Table.CanSplit | Checks whether this table can be split.
TXTextControl.Table.NestedLevel | Gets the nested level for the specified table.
TXTextControl.Table.NestedTables | Gets a collection of all tables nested in this table.
TXTextControl.Table.OuterMostTable | Gets a table's outermost table.
TXTextControl.Table.OuterTable | Gets a table's outer table.
TXTextControl.TextControl.AllowUndo | Gets or sets a value indicating whether the undo buffer is active or not.
TXTextControl.TextControl.AutoControlSize | Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text.
TXTextControl.TextControl.RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
TXTextControl.TextControl.UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.

Methods

Method | Description
TXTextControl.Table.Split | Splits a table below or above the current input position.
TXTextControl.TextControl.OnHExpanded | Raises the HExpanded event.
TXTextControl.TextControl.OnHShrunk | Raises the HShrunk event.
TXTextControl.TextControl.OnVExpanded | Raises the VExpanded event.
TXTextControl.TextControl.OnVShrunk | Raises the VShrunk event.
TXTextControl.TextControl.ResetAutoControlSize | Resets the AutoControlSize property to its default values.

Events

Event | Description
TXTextControl.TextControl.HExpanded | Occurs when the Text Control has automatically expanded its size horizontally.
TXTextControl.TextControl.HShrunk | Occurs when the Text Control has automatically shrunk its size horizontally.
TXTextControl.TextControl.VExpanded | Occurs when the Text Control has automatically expanded its size vertically.
TXTextControl.TextControl.VShrunk | Occurs when the Text Control has automatically shrunk its size vertically.


What's New in Version 10.1

The following provides a general list of features that have been added since Text Control version 10.0.

New Classes, Properties, Methods and Events

In TX Text Control 10.1 the following new classes properties, methods and events have been added:

Classes

Class | Description
TXTextControl.FormattingStyle | The FormattingStyle class is the base class for the InlineStyle and ParagraphStyle classes.
TXTextControl.FormattingStyleCollection | The FormattingStyleCollection class is the base class of the ParagraphStyleCollection and InlineStyleCollection classes.
TXTextControl.InlineStyle | The InlineStyle class defines a formatting style that can be used to format single words in a line of text.
TXTextControl.InlineStyleCollection | An instance of the InlineStyleCollection class contains all inline formatting styles in the current document represented through objects of the type InlineStyle.
TXTextControl.InputPosition | An instance of the InputPosition class represents the current text input position of a TXTextControl document.
TXTextControl.Line | An instance of the Line class represents a single line in a Text Control document.
TXTextControl.LineCollection | An instance of the LineCollection class contains all text lines in a Text Control document or part of the document represented through objects of the type Line.
TXTextControl.ParagraphStyle | The ParagraphStyle class defines a formatting style for paragraphs.
TXTextControl.ParagraphStyleCollection | An instance of the ParagraphStyleCollection class contains all paragraph formatting styles in the current document represented through objects of the type ParagraphStyle.
TXTextControl.TextChar | An instance of the TextChar class represents a single character in a Text Control document.
TXTextControl.TextCharCollection | An instance of the TextCharCollection class contains all characters in a Text Control document or part of the document represented through objects of the type TextChar.

Properties

Property | Description
TXTextControl.HeaderFooter.Lines | Gets a collection of all text lines the header or footer contains.
TXTextControl.HeaderFooter.Tables | Gets a collection of all tables in the header or footer.
TXTextControl.HeaderFooter.TextChars | Gets a collection of all characters the header or footer contains.
TXTextControl.Selection.FormattingStyle | Gets or sets the formatting style of the selected text.
TXTextControl.TextControl.InlineStyles | Gets a collection of all inline styles the current document contains.
TXTextControl.TextControl.InputPosition | Gets or sets the current text input position.
TXTextControl.TextControl.Lines | Gets a collection of all lines contained in the text part with the input focus.
TXTextControl.TextControl.ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
TXTextControl.TextControl.TextChars | Gets a collection of all characters contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.Table.Select | Selects the table or a part of the table.
TXTextControl.TableCell.Select | Selects the table cell.
TXTextControl.TableRow.Select | Selects the table row.


Windows Forms User's Guide

This guide describes how to create TX Text Control Windows Forms applications and browser-based TX Text Control Windows Forms applications which run in Microsoft Internet Explorer. All examples are available either for Microsoft Visual Basic .NET or Microsoft Visual C# .NET. To run these examples you have to install TXTextControl .NET for Windows Forms.

Tutorial: Starting with Microsoft Visual Studio

Tutorial: Creating a Ribbon Application

Howto: Work With Files

Howto: Print

Howto: Use Text Fields

Howto: Connect to Databases

Howto: Edit and Format Text From Code

Howto: Use the DataSourceManager

Howto: Mail Merge

Howto: Modify the Ribbon Bar

Howto: Use Hypertext Links

Howto: Use XML Files

Howto: Use Text Frames

Howto: Drag and Drop Files

Howto: Implement Spreadsheet Functionality

Howto: Add charting support to your applications

Howto: Add drawings and shapes to your application

Link: Online Source Code Library

Link: Support FAQ


Tutorial: Starting with Microsoft Visual Studio

Welcome to TX Text Control, the text processor in a single .NET control. Using TX Text Control, you can create all kinds of text-based applications with the ease of programming that is characteristic of development environments, such as Visual Studio .NET and with highly sophisticated formatting and display capabilities which are normally the exclusive domain of large word processing packages.

1. Creating the project and controls

2. Adding a menu to the project


1. Creating the project and controls

Start Visual Studio .NET and create a new project. Select either Visual Basic or C# as a project type, and Windows Application as a template.

Find the TX Text Control 24.0 toolbox tab that has been created automatically. All usable TX Text Control controls or components are listed in this tab.

Click on the TextControl icon and draw it on the form.

Now, click on the Smart Tag in the upper right corner of TextControl. In the Wizards group, click on Add a Button Bar, Add a Status Bar, Add a Ruler Bar and Add a Vertical Ruler. Finally, click on Arrange Controls Automatically. The controls are now connected and docked to fill the container:

Build and start the application to see the first results.

Next step >>


2. Adding a menu to the project

In this chapter, we will add a menu to the text processor to enable you to call some of the built-in dialog boxes.

Drag a Main Menu control on your form and create a File menu with the items Load... and Save....

Add the following code to the Click procedures of the menu items:

[C#]
private void mnuFile_OpenFile_Click(object sender, System.EventArgs e)
{
    textControl1.Load(TXTextControl.StreamType.RichTextFormat | TXTextControl.StreamType.HTMLFormat);
}

private void mnuFile_SaveFileAs_Click(object sender, System.EventArgs e)
{
    textControl1.Save(TXTextControl.StreamType.RichTextFormat | TXTextControl.StreamType.HTMLFormat);
}
[Visual Basic]
Private Sub mnuFile_OpenFile_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_OpenFile.Click
    TextControl1.Load(TXTextControl.StreamType.RichTextFormat + TXTextControl.StreamType.HTMLFormat)
End Sub

Private Sub mnuFile_SaveFileAs_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_SaveFileAs.Click
    TextControl1.Save(TXTextControl.StreamType.RichTextFormat + TXTextControl.StreamType.HTMLFormat)
End Sub

The Load and Save methods will automatically open a dialog box for the user to select a filename and file format, and then load, respectively save, the selected file.

Now for the Edit menu. Create an Edit menu containing items for Cut, Copy and Paste. The code for these menu items is:

[C#]
private void mnuCut_Click(object sender, System.EventArgs e)
{
    textControl1.Cut();
}

private void mnuCopy_Click(object sender, System.EventArgs e)
{
    textControl1.Copy();
}

private void mnuPaste_Click(object sender, System.EventArgs e)
{
    textControl1.Paste();
}
[Visual Basic]
Private Sub mnuEdit_Cut_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuEdit_Cut.Click
    TextControl1.Cut()
End Sub

Private Sub mnuEdit_Copy_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuEdit_Copy.Click
    TextControl1.Copy()
End Sub

Private Sub mnuEdit_Paste_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuEdit_Paste.Click
    TextControl1.Paste()
End Sub

Having added these menu items, you can exchange formatted text with other word processors via the clipboard.

Now, create a Format menu with the items Character... and Paragraph.... Name the items mnuFomat_Character and mnuFormat_Paragraph and add the following code to their procedures.

[C#]
private void mnuFormat_Character_Click(object sender, System.EventArgs e)
{
    textControl1.FontDialog();
}

private void mnuFormat_Paragraph_Click(object sender, System.EventArgs e)
{
    textControl1.ParagraphFormatDialog();
}
[Visual Basic]
Private Sub mnuFormat_Character_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFormat_Character.Click
    TextControl1.FontDialog()
End Sub

Private Sub mnuFormat_Paragraph_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFormat_Paragraph.Click
    TextControl1.ParagraphFormatDialog()
End Sub

<< Previous step


Tutorial: Creating a Ribbon Application

This chapter shows how to create a word processor application with a ribbon interface from scratch with just a few lines of code. It uses the included, ready-to-use Windows.Forms.Ribbon.Ribbon control and pre-configured ribbon tabs that implement typical word processing tasks. Step 1 shows how to add a ribbon bar and the ribbon tabs. In step 2, contextual ribbon tabs for table and frame layout tasks are added and connected. In step 3, Windows.Forms.Ribbon.Ribbon.ApplicationMenuItems are added to load and save documents.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Ribbon
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Ribbon

Step 1: Creating the project and controls

Step 2: Adding Contextual Ribbon Tabs

Step 3: Adding an Application Menu


Step 1: Creating the project and controls

In this first step, an application is created and Text Control is connected with a ribbon bar and ribbon tabs.

1. Start Visual Studio .NET and create a new project. Select either Visual Basic or C# as a project type, and Windows Forms Application as a template.

2. Find the TX Text Control 24.0 toolbox tab that has been created automatically by the TX Text Control setup program. All usable TX Text Control controls and components are listed in this tab.

3. Click on the TextControl icon and draw it on a form.

4. Click on the Smart Tag (little right-facing arrow) in the upper right corner of TextControl. In the Wizards group, click on Add a Ribbon, Add a Status Bar, Add a Ruler and Add a Vertical Ruler. Do not insert a ButtonBar. Finally, click on Arrange Controls Automatically. The controls are now connected and docked to fill the container:

5. On the form, select the ribbon control by clicking the blue File tab title in order to click on the Smart Tag in the upper right corner of the ribbon control. Click on Add a RibbonFormattingTab, Add a RibbonInsertTab, Add a RibbonPageLayoutTab, Add a RibbonViewTab, Add a RibbonProofingTab and Add a RibbonReportingTab.

6. Build and start the application to see first results.

Step 2: Adding Contextual Ribbon Tabs >>


Step 2: Adding Contextual Ribbon Tabs

In this step, contextual ribbon tabs for table and frame layout tasks are added and connected.

1. On the form, select the ribbon control by clicking the blue File tab title in order to click on the Smart Tag in the upper right corner of the ribbon control. Click on Add a Quick Access Toolbar to convert the form to a Windows.Forms.Ribbon.RibbonForm.

2. Select again the ribbon control by clicking the blue File tab title and find the ContextualTabGroups property in the Properties window.

3. Open the ContextualTabGroup Collection Editor by clicking on the ellipsis button in the (Collection) value column of the ContextualTabGroups property.

4. In the Collection Editor, click on Add to add a new Windows.Forms.Ribbon.ContextualTabGroup. Name this group m_grpTableTools, set the Header property to Table Tools and pick a BackColor.

5. Find the ContextualTabs property in the m_grpTableTools properties and click on the ellipsis button in the (Collection) value column to open the RibbonTab Collection Editor.

Open the Add drop-down button and click the RibbonTableLayoutTab item.

Close the dialog by clicking OK.

6. Repeat step 4 and name this new group m_grpFrameTools, set the Header property to Frame Tools and pick another BackColor.

7. Find the ContextualTabs property and click on the ellipsis button in the (Collection) value column to open the RibbonTab Collection Editor. Like in step 5, open the Add drop-down button and click the RibbonFrameLayoutTab item and close the dialog by clicking OK.

8. In the Solution Explorer, select the form Form1 and choose Code from the View main menu. Add the following code, so that the complete Form1 class code looks like this:

[C#]
public partial class Form1 : TXTextControl.Windows.Forms.Ribbon.RibbonForm
{
    public Form1()
    {
        InitializeComponent();

        textControl1.InputPositionChanged += TextControl1_InputPositionChanged;
        textControl1.FrameSelected += TextControl1_FrameSelected;
        textControl1.FrameDeselected += TextControl1_FrameDeselected;
        textControl1.DrawingActivated += TextControl1_DrawingActivated;
        textControl1.DrawingDeselected += TextControl1_DrawingDeselected;
    }

    private void TextControl1_DrawingDeselected(object sender,
        TXTextControl.DataVisualization.DrawingEventArgs e)
    {
        if ((textControl1.Frames.GetItem() == null) &&
            (textControl1.Drawings.GetActivatedItem() == null))
        {
            m_grpFrameTools.Visible = false;
        }
    }

    private void TextControl1_DrawingActivated(object sender,
        TXTextControl.DataVisualization.DrawingEventArgs e)
    {
        m_grpFrameTools.Visible = true;
    }

    private void TextControl1_FrameDeselected(object sender,
        TXTextControl.FrameEventArgs e)
    {
        if ((textControl1.Frames.GetItem() == null) &&
            (textControl1.Drawings.GetActivatedItem() == null))
        {
            m_grpFrameTools.Visible = false;
        }
    }

    private void TextControl1_FrameSelected(object sender,
        TXTextControl.FrameEventArgs e)
    {
        m_grpFrameTools.Visible = true;
    }

    private void TextControl1_InputPositionChanged(object sender, EventArgs e)
    {
        m_grpTableTools.Visible = textControl1.Tables.GetItem() != null;
    }
}
[Visual Basic]
Public Partial Class Form1
    Inherits TXTextControl.Windows.Forms.Ribbon.RibbonForm
    Public Sub New()
        InitializeComponent()

        AddHandler textControl1.InputPositionChanged, AddressOf TextControl1_InputPositionChanged
        AddHandler textControl1.FrameSelected, AddressOf TextControl1_FrameSelected
        AddHandler textControl1.FrameDeselected, AddressOf TextControl1_FrameDeselected
        AddHandler textControl1.DrawingActivated, AddressOf TextControl1_DrawingActivated
        AddHandler textControl1.DrawingDeselected, AddressOf TextControl1_DrawingDeselected
    End Sub

    Private Sub TextControl1_DrawingDeselected(sender As Object, e As TXTextControl.DataVisualization.DrawingEventArgs)
        If (textControl1.Frames.GetItem() Is Nothing) AndAlso (textControl1.Drawings.GetActivatedItem() Is Nothing) Then
            m_grpFrameTools.Visible = False
        End If
    End Sub

    Private Sub TextControl1_DrawingActivated(sender As Object, e As TXTextControl.DataVisualization.DrawingEventArgs)
        m_grpFrameTools.Visible = True
    End Sub

    Private Sub TextControl1_FrameDeselected(sender As Object, e As TXTextControl.FrameEventArgs)
        If (textControl1.Frames.GetItem() Is Nothing) AndAlso (textControl1.Drawings.GetActivatedItem() Is Nothing) Then
            m_grpFrameTools.Visible = False
        End If
    End Sub

    Private Sub TextControl1_FrameSelected(sender As Object, e As TXTextControl.FrameEventArgs)
        m_grpFrameTools.Visible = True
    End Sub

    Private Sub TextControl1_InputPositionChanged(sender As Object, e As EventArgs)
        m_grpTableTools.Visible = textControl1.Tables.GetItem() IsNot Nothing
    End Sub
End Class

9. Build and start the application.

Insert a table using the Table drop-down wizard in the Insert ribbon tab. Set the input position into the table to see the contextual Table Tools tab.

Step 3: Adding an Application Menu >>


Step 3: Adding an Application Menu

1. In the Solution Explorer, select the form Form1 and choose Designer from the View main menu.

2. Select the ribbon control and find the ApplicationMenuItems property in the Properties window.

3. Open the Control Collection Editor by clicking on the ellipsis button in the (Collection) value column of the ApplicationMenuItems property.

4. In the Control Collection Editor, click on Add to add a new Windows.Forms.Ribbon.RibbonButton. Name this button m_rbtnLoad and set the Text property to Load.... Add a second button with the name m_rbtnSave and the Text Save.... Close the dialog by clicking OK.

5. In the Solution Explorer, select the form Form1 and choose Code from the View main menu. Attach two more events to the Form1 constructor code, so that the complete constructor code looks like this:

[C#]
public Form1()
{
    InitializeComponent();

    textControl1.InputPositionChanged += TextControl1_InputPositionChanged;
    textControl1.FrameSelected += TextControl1_FrameSelected;
    textControl1.FrameDeselected += TextControl1_FrameDeselected;
    textControl1.DrawingActivated += TextControl1_DrawingActivated;
    textControl1.DrawingDeselected += TextControl1_DrawingDeselected;

    m_rbtnLoad.Click += M_rbtnLoad_Click;
    m_rbtnSave.Click += M_rbtnSave_Click;
}
[Visual Basic]
Public Sub New()
    InitializeComponent()

    textControl1.InputPositionChanged += TextControl1_InputPositionChanged
    textControl1.FrameSelected += TextControl1_FrameSelected
    textControl1.FrameDeselected += TextControl1_FrameDeselected
    textControl1.DrawingActivated += TextControl1_DrawingActivated
    textControl1.DrawingDeselected += TextControl1_DrawingDeselected

    AddHandler m_rbtnLoad.Click, AddressOf M_rbtnLoad_Click
    AddHandler m_rbtnSave.Click, AddressOf M_rbtnSave_Click
End Sub

6. Under the Form constructor code, add the following two new event handler methods:

[C#]
private void M_rbtnSave_Click(object sender, EventArgs e)
{
    textControl1.Save();
}

private void M_rbtnLoad_Click(object sender, EventArgs e)
{
    textControl1.Load();
}
[Visual Basic]
Private Sub M_rbtnSave_Click(sender As Object, e As EventArgs)
    textControl1.Save()
End Sub

Private Sub M_rbtnLoad_Click(sender As Object, e As EventArgs)
    textControl1.Load()
End Sub

7. Build and start the application.

When clicking on the File application menu, the two menu items are visible to load and save documents.


Howto: Work With Files

This chapter shows you how to load and save files with TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Files
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Files

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

Relevant API links:

  • TextControl.Load
  • TextControl.Save
  • LoadSettings
  • SaveSettings

Using the Built-in Dialog Boxes

Restricting File Formats

Displaying The File Name

Save and Save As...

Export to PDF and CSS


Using the Built-in Dialog Boxes

The easiest way to load and save files with Text Control is to use the Load and Save methods without a parameter, as shown in Creating a Simple Word Processor. This way, only a single line of code is required to open a file dialog box, fill its Files of type: combo box with supported file formats, and finally load and display a file the user has selected:

You may have noticed, though, that Load and Save actually consist of 11 overloaded functions each, and thus enable you to customize TX Text Control's file handling for various types of application. You can, for instance, load data from a string instead of a file, or provide your own customized dialog box. The next sections shows you some of the options available.

Next >>


Restricting File Formats

By default, the Load and Save methods will display all file formats Text Control supports. If you wish to support a subset of these formats, or if you have a version of Text Control that does not support all of the formats, you can specify the formats to be displayed as a parameter. Several members of Text Control's StreamType enumeration can be combined to, for instance, only support HTML and RTF:

[C#]
private void mnuFile_OpenFile_Click(object sender,
    System.EventArgs e)
{
    textControl1.Load(TXTextControl.StreamType.HTMLFormat |
                        TXTextControl.StreamType.RichTextFormat);
}
[Visual Basic]
Private Sub mnuFile_OpenFile_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_OpenFile.Click
    TextControl1.Load(TXTextControl.StreamType.HTMLFormat + _
                        TXTextControl.StreamType.RichTextFormat)
End Sub
[Delphi]
procedure Form1.mnuFile_OpenFile_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Load(TXTextControl.StreamType.HTMLFormat +
                        TXTextControl.StreamType.RichTextFormat);
end;


Displaying The File Name

It is convenient for the user to have the name of the file he or she is currently working with displayed as a window caption. One would normally use the FileName property of the file dialog box for this, but, as the dialog box is called from within Text Control, this option is not available.

This code sample shows how get the filename by creating and passing a LoadSettings object as a parameter to the Load method.

[C#]
private void mnuFile_OpenFile_Click(object sender, System.EventArgs e)
{
    TXTextControl.LoadSettings LoadSettings = new TXTextControl.LoadSettings();
    textControl1.Load(TXTextControl.StreamType.All, LoadSettings);
    this.Text = LoadSettings.LoadedFile;
}
[Visual Basic]
Private Sub mnuFile_OpenFile_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_OpenFile.Click
    Dim LoadSettings As New TXTextControl.LoadSettings()
    TextControl1.Load(TXTextControl.StreamType.All, LoadSettings)
    Me.Text = LoadSettings.LoadedFile
End Sub
[Delphi]
procedure Form1.mnuFile_OpenFile_Click(sender: System.Object;
    e: System.EventArgs);
var
    LoadSettings : TXTextControl.LoadSettings;

begin
    LoadSettings := TXTextControl.LoadSettings.Create;
    TextControl1.Load(TXTextControl.StreamType.All, LoadSettings);
    DocumentFileName := LoadSettings.LoadedFile;
    DocumentStreamType := LoadSettings.LoadedStreamType;
    Self.Text := DocumentFileName;
end;


Save and Save As...

Word processing programs typically have seperate menu items for Save... and Save As.. operations. Unless a file has been created from scratch, it can be saved with its previously assigned filename and type by just hitting Save, and without a dialog box.

The sample program maintains two variables called DocumentFileName and DocumentStreamType in which it stores the name and type of the current file. The information is updated when a file is loaded, and when it is stored under a different name.

When the user clicks Save, the file is stored using this information. A dialog box is only displayed if the file has been created from scratch, i.e. if it does not yet have a name.

[C#]
private void mnuFile_Save_Click(object sender, System.EventArgs e)
{
    TXTextControl.SaveSettings SaveSettings = new TXTextControl.SaveSettings();
    if (DocumentFileName != "" )
    {
        // save under same name and type
        textControl1.Save(DocumentFileName, DocumentStreamType);
    }
    else
    {
        // save as..
        textControl1.Save(TXTextControl.StreamType.All, SaveSettings);
        DocumentFileName = SaveSettings.SavedFile;
        DocumentStreamType = SaveSettings.SavedStreamType;
    }
}
[Visual Basic]
Private Sub mnuFile_Save_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Save.Click
    Dim SaveSettings As New TXTextControl.SaveSettings()
    If DocumentFileName <> "" Then
        ' save under same name and type
        TextControl1.Save(DocumentFileName, DocumentStreamType)
    Else
        ' save as..
        TextControl1.Save(TXTextControl.StreamType.All, SaveSettings)
        DocumentFileName = SaveSettings.SavedFile
        DocumentStreamType = SaveSettings.SavedStreamType
    End If
End Sub
[Delphi]
procedure Form1.mnuFile_Save_Click(sender: System.Object;
    e: System.EventArgs);
var
    SaveSettings : TXTextControl.SaveSettings;

begin
    SaveSettings := TXTextControl.SaveSettings.Create;
    if DocumentFileName <> '' then begin
        // save under same name and type
        TextControl1.Save(DocumentFileName, DocumentStreamType);
    end
    else begin
        // save as..
        TextControl1.Save(TXTextControl.StreamType.All, SaveSettings);
        DocumentFileName := SaveSettings.SavedFile;
        DocumentStreamType := SaveSettings.SavedStreamType;
        Self.Text := DocumentFileName;
    end;
end;


Export to PDF and CSS

PDF and CSS formats require special attention, as they can be saved to, but not loaded from. The problem is that if you save a file as PDF, you cannot load it back in for further editing. CSS will not even save the text contained in a document, but only the formatting.

The best way to circumvent this is to create a seperate Export... menu item in addition to Save and Save As..., and keep the document in its original format when exporting it to a non-editable format. Note that, unlike Save As..., Export... does not change the file name and type.

[C#]
private void mnuFile_Export_Click(object sender, System.EventArgs e)
{
    textControl1.Save(TXTextControl.StreamType.AdobePDF);
}
[Visual Basic]
Private Sub mnuFile_Export_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Export.Click
    TextControl1.Save(TXTextControl.StreamType.AdobePDF)
End Sub
[Delphi]
procedure Form1.mnuFile_Export_Click(sender: System.Object; e: System.EventArgs);
begin
    TextControl1.Save(TXTextControl.StreamType.AdobePDF);
end;

<< Previous


Howto: Print

This chapter shows you how to print with Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Printing
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Printing

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

Relevant API links:

  • TextControl.Print

Using The Built-In Print Dialog Box

Customizing The Print Dialog Box

Printing Without A Dialog Box


Using The Built-In Print Dialog Box

Sending a file to the printer in most cases only requires a single line of code. The TextControl.Print method will open a dialog box to let the user select a printer and all required options.

This code sample will open a print dialog box, and, if the user clicks OK, print the document:

[C#]
private void mnuFile_Print_WithBuiltInDialog_Click(object sender, System.EventArgs e)
{
    textControl1.Print("My Print Job");
}
[Visual Basic]
Private Sub mnuFile_Print_WithBuiltInDialog_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Print_WithBuiltInDialog.Click
    TextControl1.Print("My Print Job")
End Sub
[Delphi]
procedure Form1.mnuFile_Print_WithBuiltInDialog_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Print('My Print Job');
end;

Next >>


Customizing The Print Dialog Box

By default, the print dialog box will be displayed with default options, which is fine for most applications. Should you need to configure the print dialog, for instance to enable or disable options like AllowPrintToFile, ShowHelp, or ShowNetwork, you can use the TextControl.Print method with an application provided dialog box. This code sample will open a print dialog box with the AllowPrintToFile and AllowSomePages options disabled:

[C#]
private void mnuFile_Print_WithCustomizedDialog_Click(object sender, System.EventArgs e)
{
    PrintDialog myPrintDialog = new PrintDialog();
    PrintDocument myPrintDocument = new PrintDocument();
    myPrintDialog.Document = myPrintDocument;
    myPrintDialog.AllowSomePages = false;
    myPrintDialog.AllowPrintToFile = false;
    myPrintDialog.PrinterSettings.FromPage = 1;
    myPrintDialog.PrinterSettings.ToPage = txTextControl1.Pages;
    if (myPrintDialog.ShowDialog() == DialogResult.OK )
    {
        textControl1.Print(myPrintDocument);
    }
}
[Visual Basic]
Private Sub mnuFile_Print_WithCustomizedDialog_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Print_WithCustomizedDialog.Click
    Dim MyPrintDialog As New PrintDialog()
    Dim MyPrintDocument As New System.Drawing.Printing.PrintDocument()
    MyPrintDialog.Document = MyPrintDocument
    MyPrintDialog.AllowSomePages = False
    MyPrintDialog.AllowPrintToFile = False
    MyPrintDialog.PrinterSettings.FromPage = 1
    MyPrintDialog.PrinterSettings.ToPage = TextControl1.Pages
    If MyPrintDialog.ShowDialog() = DialogResult.OK Then
        TextControl1.Print(MyPrintDocument)
    End If
End Sub
[Delphi]
procedure Form1.mnuFile_Print_WithCustomizedDialog_Click(sender: System.Object;
    e: System.EventArgs);
var
    myPrintDialog : PrintDialog;
    myPrintDocument : System.Drawing.Printing.PrintDocument;

begin
    myPrintDialog := PrintDialog.Create;
    myPrintDocument := System.Drawing.Printing.PrintDocument.Create;
    myPrintDialog.Document := myPrintDocument;
    myPrintDialog.AllowSomePages := False;
    myPrintDialog.AllowPrintToFile := False;
    myPrintDialog.PrinterSettings.FromPage := 1;
    myPrintDialog.PrinterSettings.ToPage := TxTextControl1.Pages;
    If myPrintDialog.ShowDialog = System.Windows.Forms.DialogResult.OK then
        TextControl1.Print(myPrintDocument);
end;


Printing Without A Dialog Box

It is also possible to print a document without user interaction. This is done by assigning all required options to a PrintDocument object, and then passing it to the TextControl.Print method. This code sample will send page 1 of a document to the default printer:

[C#]
private void mnuFile_Print_WithoutDialog_Click(object sender, System.EventArgs e)
{
    PrintDocument myPrintDocument = new PrintDocument();
    myPrintDocument.PrinterSettings.FromPage = 1;
    myPrintDocument.PrinterSettings.ToPage = 1;
    txTextControl1.Print(myPrintDocument);
}
[Visual Basic]
Private Sub mnuFile_Print_WithoutDialog_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Print_WithoutDialog.Click
    Dim myPrintDocument As New System.Drawing.Printing.PrintDocument()
    myPrintDocument.PrinterSettings.FromPage = 1
    myPrintDocument.PrinterSettings.ToPage = 1
    TxTextControl1.Print(myPrintDocument)
End Sub
[Delphi]
procedure Form1.mnuFile_Print_WithoutDialog_Click(sender: System.Object;
    e: System.EventArgs);
var
    myPrintDocument : System.Drawing.Printing.PrintDocument;

begin
    myPrintDocument := System.Drawing.Printing.PrintDocument.Create;
    myPrintDocument.PrinterSettings.FromPage := 1;
    myPrintDocument.PrinterSettings.ToPage := 1;
    TxTextControl1.Print(myPrintDocument);
end;

<< Previous


Howto: Use Text Fields

Text Fields are markers which are inserted in the text. They can be used to implement a wide range of special functions in a text processor. To name just a few:

  • Mail Merge functions
  • Spreadsheet-like calculation fields
  • Bookmarks
  • Automatic table of contents and index generation
  • Hypertext links and targets

Any group of characters within the text can be a marked text field. The maximum number of fields is 65,535. Text Control maintains the positions and numbers of the fields. It also takes care of loading, saving and clipboard operations.

Additional information about text fields can be found in the Technical Articles part in the chapter Text Fields and Hypertext Links.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\TextFields
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\TextFields

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

Relevant API links:

  • TextControl.TextFields
  • TextControl.DocumentTargets
  • TextControl.DocumentLinks
  • TextControl.ApplicationFields
  • LoadSettings
  • DocumentServer.Fields.FieldAdapter

A Simple Example

Bookmarks

Adding Strings to Marked Text Fields

Importing and Exporting Fields from and to MS Word

Implementing a MERGEFIELD Class

Implementing a FORMTEXT Class

Creating and Merging MS Word Compatible Templates

TX Quote Gemerator - An Advanced Example


A Simple Example

This first sample program will show you how fields are created and what happens when they are clicked on. The code shown here is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\TextFields\Fields1
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\TextFields\Fields1

The program consists of a form with just one menu item, Insert Field!, with an exclamation mark to say that clicking on this item will cause an immediate action instead of dropping a menu. There are two Text Controls on the form, one of which is used as a normal text window (TextControl1), the other one as a pop-up window (TextControl2).

The following code is executed when the menu item is clicked on:

[C#]
private void mnuInsertField_Click(object sender, System.EventArgs e)
{
    TXTextControl.TextField newField = new TXTextControl.TextField();
    newField.Text = "--------";
    newField.ID = fieldID;
    fieldID += 1;
    textControl1.TextFields.Add(newField);
}
[Visual Basic]
Private Sub mnuInsertField_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuInsertField.Click
    Dim NewField As New TXTextControl.TextField()
    NewField.Text = "--------"
    NewField.ID = FieldID
    FieldID += 1
    TextControl1.TextFields.Add(NewField)
End Sub
[Delphi]
procedure Form1.mnuInsertField_Click(sender: System.Object;
    e: System.EventArgs);
var
    NewField :TXTextControl.TextField;
begin
    NewField := TXTextControl.TextField.Create;
    // Insert a new field and increase field ID
    NewField.Text := '--------';
    NewField.ID := FieldID;
    FieldID := FieldID + 1;
    TextControl1.TextFields.Add(NewField);
end;

This inserts a field at the current caret position and assigns a unique number to the fields ID property. If you move the cursor over the field, Text Control changes the mouse pointer to a hand cursor to indicate that there is something to click on.

If you click on the field, the application receives a TextFieldClicked event, to which it responds by popping up a window which displays the field number.

Only two lines of code are required for this:

[C#]
private void textControl1_TextFieldClicked(object sender, TXTextControl.TextFieldEventArgs e)
{
    // Field has been clicked on, update text of second TX and display it
    textControl2.Text = "Field clicked, ID: " + e.TextField.ID;
    textControl2.BringToFront();
}
[Visual Basic]
Private Sub TextControl1_TextFieldClicked(ByVal sender As System.Object, _
ByVal e As TXTextControl.TextFieldEventArgs) Handles TextControl1.TextFieldClicked
    TextControl2.Text = "Field clicked, ID: " + CStr(e.TextField.ID())
    TextControl2.BringToFront()
End Sub
[Delphi]
procedure Form1.TextControl1_TextFieldClicked(sender: System.Object;
    e: TXTextControl.TextFieldEventArgs);
begin
    // Field has been clicked on, update text of second TX and display it
    TextControl2.Text := 'Field clicked, ID: ' + IntToStr(e.TextField.ID);
    TextControl2.BringToFront;
end;

When the mouse button is released, the text window is moved to the front again:

[C#]
private void textControl1_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    textControl1.BringToFront();
}
[Visual Basic]
Private Sub TextControl1_MouseUp(ByVal sender As System.Object, _
ByVal e As System.Windows.Forms.MouseEventArgs) Handles TextControl1.MouseUp
    TextControl1.BringToFront()
End Sub
[Delphi]
procedure Form1.TextControl1_MouseUp(sender: System.Object;
    e: System.Windows.Forms.MouseEventArgs);
begin
    TextControl1.BringToFront;
end;

Next >>


Bookmarks

This example shows you how to use text fields to create bookmarks. The first version will reference the bookmarks simply by their field numbers. The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\TextFields\Fields2
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\TextFields\Fields2

The sample application has a Bookmark menu with two items which are named Insert and Go to.... Clicking Insert creates a text field at the current caret position. If a text selection exists, the selected text is converted into a text field.

[C#]
private void mnuBookmark_Insert_Click(object sender, System.EventArgs e)
{
    if (textControl1.Text == "")
    {
        MessageBox.Show("Cannot insert a bookmark if the Text Control is empty.");
    }
    else if (textControl1.Selection.Length == 0)
    {
        textControl1.Selection.Length = 1;
    }
    else
    {
        TXTextControl.TextField newField = new TXTextControl.TextField();
        newField.ID = fieldID;
        newField.Text = textControl1.Selection.Text;
        textControl1.Selection.Text = "";
        fieldID += 1;
        textControl1.TextFields.Add(newField);
    }
}
[Visual Basic]
Private Sub mnuBookmark_Insert_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuBookmark_Insert.Click
    If TextControl1.Text = "" Then
        MsgBox("Cannot insert a bookmark if the Text Control is empty.")
    ElseIf TextControl1.Selection.Length = 0 Then
        TextControl1.Selection.Length = 1
    Else
        Dim NewField As New TXTextControl.TextField()

        NewField.ID = FieldID
        NewField.Text = TextControl1.Selection.Text
        TextControl1.Selection.Text = ""
        FieldID += 1
        TextControl1.TextFields.Add(NewField)
    End If
End Sub
[Delphi]
procedure Form1.mnuBookmark_Insert_Click(sender: System.Object;
    e: System.EventArgs);
var
    NewField :TXTextControl.TextField;
begin
    if TextControl1.Text = '' then
        MessageBox.Show('Cannot insert a bookmark if the '
            +'Text Control is empty.')
    else
      If TextControl1.Selection.Length = 0 then
        TextControl1.Selection.Length := 1
    else begin
        NewField := TXTextControl.TextField.Create;
        NewField.ID := FieldID;
        NewField.Text := TextControl1.Selection.Text;
        TextControl1.Selection.Text := '';
        FieldID := FieldID + 1;
        TextControl1.TextFields.Add(NewField);
    end;
end;

After typing in some text and inserting a few bookmarks, select the Go To... menu item. This will launch a dialog box which allows you to enter the number of the bookmark to jump to.

Clicking the OK button executes the following procedure:

[C#]
private void cmdOK_Click(object sender, System.EventArgs e)
{
    if (Convert.ToInt32(textBox1.Text) > tx.TextFields.Count)
    {
        MessageBox.Show ("Invalid bookmark number!");
    }
    else
    {
        foreach (TXTextControl.TextField field in tx.TextFields)
        {
            if (field.ID == Convert.ToInt32(textBox1.Text))
            {
                tx.Selection.Start = field.Start - 1;
                tx.Selection.Length = field.Length;
            }
        }
    }
    Close();
}
[Visual Basic]
Private Sub cmdOK_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles cmdOK.Click
    Dim Field As TXTextControl.TextField

    If (CInt(TextBox1.Text) > tx.TextFields.Count) Then
        MsgBox("Invalid bookmark number!")
    Else
        For Each Field In tx.TextFields
            If (Field.ID = CInt(TextBox1.Text)) Then
                tx.Selection.Start = Field.Start - 1
                tx.Selection.Length = Field.Length
            End If
        Next
    End If
    Close()
End Sub
[Delphi]
procedure frmGoto.cmdOK_Click(sender: System.Object; e: System.EventArgs);
var
    Field : TXTextControl.TextField;

begin
    if (StrToInt(TextBox1.Text) > tx.TextFields.Count) then begin
        MessageBox.Show('Invalid bookmark number!');
    end
    else begin
        for Field in tx.TextFields do begin
            if (Field.ID = StrToInt(TextBox1.Text)) then begin
               tx.Selection.Start := Field.Start - 1;
               tx.Selection.Length := Field.Length;
            end;
        end;
    end;
    Close;
end;


Adding Strings to Marked Text Fields

In commercial word processors, bookmarks are normally referenced by names, not just by numbers. The names are typed in by the user when he creates a bookmark. The Goto Bookmark dialog box then presents a listbox or combobox in which one of the strings can be selected.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\TextFields\Fields3
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\TextFields\Fields3

The Insert Bookmark... menu item in this version of the program creates a dialog box where the user can enter a label for the bookmark.

When the OK button is clicked, the following code is executed:

[C#]
private void cmdOK_Click(object sender, System.EventArgs e)
{
    TXTextControl.TextField field = new TXTextControl.TextField();

    field.Name = textBox1.Text;
    field.Text = tx.Selection.Text;
    tx.Selection.Text = "";

    tx.TextFields.Add(Field);
    Close();
}
[Visual Basic]
Private Sub cmdOK_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles cmdOK.Click
    Dim Field As New TXTextControl.TextField()

    Field.Name = TextBox1.Text
    Field.Text = tx.Selection.Text
    tx.Selection.Text = ""

    tx.TextFields.Add(field)
    Close()
End Sub
[Delphi]
procedure frmInsertDialog.cmdOK_Click(sender: System.Object;
    e: System.EventArgs);
var
    Field : TXTextControl.TextField;

begin
    Field := TXTextControl.TextField.Create;
    Field.Name := TextBox1.Text;
    Field.Text := tx.Selection.Text;
    tx.Selection.Text := '';
    tx.TextFields.Add(field);
    Close;
end;

First, a marked text field is created at the current caret position. Second, the name of the bookmark, which is the text that has been typed in by the user, is stored in the TextField.Name property.

The Goto Bookmark dialog box contains a combo box which lists all of the bookmarks which have been created so far.

The combo box is filled with the bookmark titles when its form is loaded:

[C#]
private void frmGotoDialog_Load(object sender, System.EventArgs e)
{
    foreach (TXTextControl.TextField Field in tx.TextFields) {
        ComboBox1.Items.Add(Field.Name);
    }
}
[Visual Basic]
Private Sub frmGotoDialog_Load(ByVal sender As Object, _
ByVal e As System.EventArgs) Handles MyBase.Load
    Dim field As TXTextControl.TextField

    For Each field In tx.TextFields
        ComboBox1.Items.Add(field.Name)
    Next
End Sub
[Delphi]
procedure frmGotoDialog.frmGotoDialog_Load(sender: System.Object;
    e: System.EventArgs);
var
    Field : TXTextControl.TextField;

begin
    for Field in  tx.TextFields do begin
        ComboBox1.Items.Add(Field.Name);
    end;
end;

When the OK button is clicked, the bookmark list is searched for the string which has been selected in the combo box, and the corresponding marked text field is selected.

[C#]
private void cmdOK_Click(object sender, System.EventArgs e)
{
    foreach (TXTextControl.TextField field in tx.TextFields)
    {
        if (field.Name == comboBox1.Text)
        {
            tx.Selection.Start = field.Start - 1;
            tx.Selection.Length = field.Length;
        }
    }
    Close();
}
[Visual Basic]
Private Sub cmdOK_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles cmdOK.Click
    Dim Field As TXTextControl.TextField

    For Each Field In tx.TextFields
        If (Field.Name = ComboBox1.Items.Item(ComboBox1.SelectedIndex)) Then
            tx.Selection.Start = Field.Start - 1
            tx.Selection.Length = Field.Length
        End If
    Next
    Close()
End Sub
[Delphi]
procedure frmGotoDialog.cmdOK_Click(sender: System.Object;
    e: System.EventArgs);
var
    Field : TXTextControl.TextField;

begin
    for Field in tx.TextFields do begin
        if Field.Name = ComboBox1.Text then begin
            tx.Selection.Start := Field.Start - 1;
            tx.Selection.Length := Field.Length;
        end;
    end;
    Close;
end;


Importing and Exporting Fields from and to MS Word

TX Text Control imports and exports all fields that can be inserted into an MS Word document. As described in the technical article, the ApplicationField class provides a special interface to get and set the data and parameters of these fields.

The following two samples show how to use the two most common used fields of MS Word: MERGEFIELD and FORMTEXTBOX.

The source code for these samples is contained in the following directory:

  • Samples\WinForms\VB.NET\ApplicationFields
  • Samples\WinForms\CSharp\ApplicationFields

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar
  • TXTextControl.ServerTextControl
  • TXTextControl.DocumentServer

Relevant API links:

  • TextControl.ApplicationFields
  • LoadSettings
  • DocumentServer.Fields.FieldAdapter


Implementing a MERGEFIELD Class

The MS Word MergeField is the most commonly used field in MS Word and RTF documents. It enables template designers to add additional information to a text field, such as a specific text that should be displayed before or after the field text or the format of the text.

To handle these fields and it's functionality, this sample implements three different classes:

  • MergeField
  • MergeFieldCollection
  • CollectionSync

The MergeField class is inherited from the TextField base class and extends it's functionality to cover all properties of a MergeField. This MergeField gets a reference to the ApplicationField that will be manipulated by the class. Additionally, a MergeField contains the following parameters that are implemented through it's properties:

  • TextFormat
  • TextBefore
  • TextAfter
  • Mapped
  • MergeFieldName
  • PreserveFormatting
  • VerticalFormatting

If the TextBefore property of the MergeField is set, the Text property of this inherited class manipulates the referenced ApplicationField instance and it's Text. Additionally, this new setting is saved in the Parameters property in the appropriate format.

The MergeFieldCollection is the collection for the MergeField instances. It implements all common properties and methods of standard collection.

Finally, a synchronization object is required to synchronize the existing collections of a TextControl instance and the new MergeFieldCollection. It must be synchronized every time the ApplicationField collection is changed. This class attaches two important events to the parent TextControl class that listen for changes in this collection: TextFieldCreated and TextFieldDeleted.

After starting the sample, click on File / Load to load a sample document, which contains several merge fields. Set the input position inside an exsiting field, for sample <<COMPANY>>.

Open the implemented merge field dialog by choosing Edit... from the MergeField main menu.

Using this dialog, it is possible to manipulate all properties of the MergeField instance. Add some text that should be inserted after the field by checking the checkbox Text to be inserted after. Type some text in the appropriate text box and close the dialog by clicking OK.

Open the customer data grid form by clicking Merge fields... from the Merge menu entry. Choose a customer by clicking on a specific row and click Merge to merge all merge fields with the database content.

In this process, the MergeFieldCollection is used to loop through all inserted fields to replace the text. The following code shows this loop:

[C#]
DataGridViewRow curRow = dataGridView1.SelectedRows[0];
foreach (MergeField curMergeField in m_mergeFieldCollection)
{
  foreach (DataGridViewTextBoxCell curCell in curRow.Cells)
  {
    if (curCell.OwningColumn.Name == curMergeField.MergeFieldName)
      curMergeField.Text = curCell.Value.ToString();
  }
}
[Visual Basic]
Dim CurRow As DataGridViewRow = DataGridView1.SelectedRows(0)
For Each CurMergeField As MergeField In m_MergeFieldCollection
    For Each CurCell As DataGridViewTextBoxCell In CurRow.Cells
        If CurCell.OwningColumn.Name = CurMergeField.MergeFieldName then
            CurMergeField.Text = CurCell.Value.ToString()
        End if
    Next
Next


Implementing a FORMTEXT Class

The FormText field is used in MS Word to create fillable documents. In many applications, such documents are automated, so that these fields must be readable to be completed automatically. An ApplicationField object acts like a container for all settings (switches) of these fields.

In contrast to the first example, this sample implements a class for the FormText fields that is not inherited from the TextField base class. In this case, no separate collection is required to synchronize these fields. Everytime, an ApplicationField of type FORMTEXT should be edited, a new FormText object is created:

[C#]
FormText curFormText = new FormText(textControl1.ApplicationFields.GetItem());
[Visual Basic]
Dim curFormText As New FormText(TextControl1.ApplicationFields.GetItem())

A reference to the ApplicationField is stored in the FormText instance. Similar to the first sample, this ApplicationField is used to get or set the parameters that are mapped to the properties of the new implemented FormText object.

A dialog box is implemented to change the properties of the specific form text field. The dialog represents the properties of the implemented FormText field:

After clicking OK, the specified values in the dialog box are set in the implemented FormText object which writes the parameters of the referenced ApplicationField.


Creating and Merging MS Word Compatible Templates

Mail merge is the most typical application for TX Text Control. The combination of TX Text Control's MS Word compatible field functionality and TX Text Control .NET Server's automated MailMerge component is a very powerful toolset to build high peformance and MS Word compatible mail merge applications.

TX Text Control supports not only the merge process, but also provides the required editor functionality to create templates with a true WYSIWYG interface.

This sample project shows most of the mail merge possibilities of TX Text Control. The following steps are included:

  • Database binding
  • Adding fields
  • Preview
  • Export the merged document

It is quite similar to MS Word mail merge capabilities, but it comes with source code and can be customized completely. The following tutorial explains how to use this sample.

1. Connect to a database

  • Click on the Select recipients button in the toolbar or choose Select Recipients... from the Mail Merge menu.

  • In the opened dialog box, browse for the shipped XML database file address.xml which is located in the sample root folder and load it by clicking Open.

Now you can see the contained DataTables in the drop down box of the toolbar. If the database would contain more DataTables, you could select the required DataTable from this box. Based on the selected database and DataTable, the contained merge fields are automatically added to the Insert Field drop down button and the Insert Merge Field menu item.

2. Insert merge fields

  • Insert some merge fields from the above filled drop down list. These fields will be inserted at the current input position.

  • You can switch the view mode of the fields using these three buttons in the toolbar:

  • Field code: This view mode shows the MS Word field codes of the field.
  • Field text: This view mode shows the results or the field name.
  • Preview: This view mode merges the database content into the specific fields.
  • Click on the Preview button. The second database navigator toolbar gets enabled and you can navigate through the database in order to preview your template with the real data:

3. Export the document

  • Finally, click the Export button to start the mail merge process:

This opens a new form that consists of a TX Text Control and a simple toolbar. The DocumentServer.MailMerge component is used in the background to merge the created template with the data records from the selected database. The resulting document is copied into the visual TX Text Control instance on the form. The actual merge process is done in 3 lines of code:

[C#]
mailMerge.TextComponent = tx;
mailMerge.LoadTemplateFromMemory(Document,
TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);
mailMerge.Merge(DataTable, true);
[Visual Basic]
mailMerge.TextComponent = tx
mailMerge.LoadTemplateFromMemory(Document, _
    TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)
mailMerge.Merge(DataTable, True)


TX Quote Gemerator - An Advanced Example

This sample progam shows how to use Text Control in office applications. The main task of an office application typically is to create documents from information taken from a set of databases. For instance, a quote is generated from a record in an address database and one or more records in an article database.

The program is built up in two steps, starting very simple with only a single address database, and adding more features later on.

The source code for this example is contained in the subfolders Step1 and Step2 of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Quote Generator
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Quote Generator

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

chap_desc>Relevant API links:

  • TextControl.TextFields
  • TextControl.Load

Step 1: Creating a Quote from a Database

When the program is started, it displays an address database in a data grid control.

The database is a simple XML file, which is displayed with just a few lines of ADO code:

[C#]
DataSet dsAddress = new DataSet ("address");
dsAddress.ReadXml("..\\..\\address.xml");
gridAddress.DataSource = dsAddress;
gridAddress.DataMember = "address_record";
[Visual Basic]
Dim DsAddress As New DataSet("address")
DsAddress.ReadXml("..\address.xml")
GridAddress.DataSource = DsAddress
GridAddress.DataMember = "address_record"
[Delphi]
dsAddress.ReadXml('address.xml');
gridAddress.DataSource := dsAddress;
gridAddress.DataMember := 'address_record';

Selecting the File/New Quote menu item takes the current record from the database and creates a document from it. This is done in the following way:

A form containing a Text Control is opened, and a stylesheet is loaded. A stylesheet is a file that serves as a template for the final document. It contains all text parts which are equal to all documents, for instance a phrase like "In reply to your inquiry and according to our general terms of business we are pleased to..", and placeholders for information that is to be inserted from a database, like Address, Date, and so forth. It also defines the font, font size, company logo, and layout, so that all files will have the same look.

Once the stylesheet has been loaded, the placeholders are updated from the database, so that they now contain the real address, name, customer number, and date.

The stylesheet can be edited with the Advanced menu.

Step 2: Adding Articles with a Table

Before you read everything about how it is programmed, you may want to run it and see what it does, so here is a short user's guide first.

  • Start the program. You will see the main form, displaying some customer address records. Select one by clicking on it.
  • Select the File / New Quote menu item. A quote will be generated using the selected customer's name, address and customer number.
  • Click on the Insert / Article menu item. Select one of the articles displayed in the dialog box that pops up, and click OK. The product data will automatically be entered into the quote.
  • Enter the desired quantity. The total will be recalculated accordingly.
  • Repeat step 3 to enter more articles (clicking into an empty table row first). Delete the remaining empty lines by selecting them with the mouse and clicking Edit / Delete table rows.
  • Finished. Click File / Print to make a printout of the quote.

The first thing we need to do in order to add article descriptions and pricing to our quotes from Step 1 is to add another database. We call it the article database, and display it on the main form beside the address database.

That's it for the main form. On the editor form, we now add a menu item which lets us insert items from the article data into a quote.

A list of articles is best displayed in a table, and Text Control offers all required table functions to let us insert product IDs, descriptions, and prices into the respective cells, as well as to perform calculations. We therefore add a table to the style sheet and adjust its column widths, text distances, and caption text so that later only the plain text needs to be filled in.

This is what the style sheet now looks like:

A new menu item has been added to the Advanced menu, which allows to insert a table. Also, a Format/Table menu item has been created which calls Text Control's table attribute dialog box, so that we can adjust the table grid lines and background shading. The table's column widths and tabs are adjusted in the ruler bar. Note that the 2 rightmost columns have decimal tabs, so that the currency values they will contain will be properly aligned at the decimal sign.

We are now ready to fill in text from the article database into the table. Have a look at the sample program's ArticleTable class, which shows how to use the various table, row, columns and cell collections and objects.

After the user has selected a product in the article database, the program performs these steps:

  • It checks if the current input position is in a row of the article table, where a product can be inserted. If not, it uses the first row below the caption.
  • It inserts the selected product code, product description, and price.
  • Whenever Text Control sends a Changed event while the current input position was inside a table, the total is recalculated accordingly.

<< Previous


Howto: Connect to Databases

TX Text Control can be connected to any type of database, and store formatted text in any of its text formats. You can save a complete document as a record, or load text from a database into table cells and marked text fields. Typical applications which can be created are mail merge, report generators, formatted data entry masks, and all types of business applications where documents are created from information stored in a database.

This chapter shows you how to save the contents of a Text Control to a database. The data is stored as an RTF formatted string in a text field. For an advanced sample program which shows how to use databases with tables and marked text fields, please also refer to the TX Quote Generator sample program.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Database
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Database

Used TX Text Control controls:

  • TXTextControl.TextControl

Relevant API links:

  • TextControl.Load
  • TextControl.Save

The Sample Program

Saving a Record

Retrieving a Record


The Sample Program

The sample program consists of a form with two Text Controls, both of which display the same record of a database. The upper control displays it as formatted text, whereas, for demonstration purposes, the lower control shows the record's RTF source code.

Clicking the Next button will save any changes you have made in the upper window, and advance to the next record.

Next >>


Saving a Record

All data access is handled by two methods, which are Load and Save. The Save method stores formatted text to a string, which is then passed on to the database engine using Visual Studio's ADO functions.

[C#]
private void PutRecord()
{
    string sRTFData;

    textControl1.Save (out sRTFData,
        TXTextControl.StringStreamType.RichTextFormat);
    dsRTFData.Tables[0].Rows[iCurrentRow][0] = sRTFData;
}
[Visual Basic]
Private Sub PutRecord()
    Dim SRTFData As String

    TextControl1.Save(SRTFData, TXTextControl.StringStreamType.RichTextFormat)
    DsRTFData.Tables(0).Rows(ICurrentRow).Item("rtf_item") = SRTFData
End Sub
[Delphi]
procedure Form1.PutRecord();
var
    sRTFData : String;

begin
    TextControl1.Save(sRTFData,
         TXTextControl.StringStreamType.RichTextFormat);
    dsRTFData.Tables[0].Rows[iCurrentRow].Item['rtf_item'] := sRTFData;
end;

Other text formats can be used by simply changing the second parameter of the Save method.


Retrieving a Record

The TextControl.Load method is used to display RTF formatted text in Text Control 1. As Text Control 2 just displays the RTF source code without any formatting, we can simply use the Text property to load it.

[C#]
private void GetRecord()
{
    string sRTFData = dsRTFData.Tables[0].Rows[iCurrentRow].ItemArray[0].ToString() ;

    textControl1.Load(sRTFData, TXTextControl.StringStreamType.RichTextFormat);
    textControl2.Text = sRTFData;
}
[Visual Basic]
Private Sub GetRecord()
    Dim SRTFData As String = DsRTFData.Tables(0).Rows(ICurrentRow).Item("rtf_item")

    TextControl1.Load(SRTFData, TXTextControl.StringStreamType.RichTextFormat)
    TextControl2.Text = SRTFData
End Sub
[Delphi]
procedure Form1.GetRecord();
var
    sRTFData :String;
begin
    sRTFData := dsRTFData.Tables[0].Rows[iCurrentRow].Item['rtf_item'].ToString;
    TxTextControl1.Load(sRTFData, TXTextControl.StringStreamType.RichTextFormat);
    TxTextControl2.Text := sRTFData;
end;

The text format used in this example is RTF, which has the advantage of being accessible by most word processing programs. If this is not an issue, Text Control's binary format may be a better choice, as it is more compact and will take up less space in a database.

<< Previous


Howto: Edit and Format Text From Code

There are various applications which require text to be edited from program code. Report generators assemble documents from various smaller files and database fields. Web shops create order confirmations and send them out as HTML. Using TX Text Control, anything that can be done using the mouse and clicking menu items, can also be done from program code. The following chapters discuss some of the techniques involved.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Editing from code
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Editing from code

Used TX Text Control controls:

  • TXTextControl.TextControl

Relevant API links:

  • TextControl.Selection
  • TextControl.Find
  • TextControl.Load
  • TextControl.InputPosition

Selecting and Formatting Text

Find and Replace

Append and Insert Documents

Moving to a Page, Line or Column


Selecting and Formatting Text

Text editing from code works similar to using mouse and menus. To change a word to bold, you would normally select it with the mouse, and then click on the Bold button. From code, you use a Text Control's Selection object to 'highlight' a word, and then set the Selection.Bold property.

[C#]
textControl1.Text = "TX Text Control";
textControl1.Selection.Start = 3;
textControl1.Selection.Length = 4;
textControl1.Selection.Bold = true;
[Visual Basic]
TextControl1.Text = "TX Text Control"
TextControl1.Selection.Start = 3
TextControl1.Selection.Length = 4
TextControl1.Selection.Bold = True
[Delphi]
TextControl1.Text := 'TX Text Control';
TextControl1.Selection.Start := 3;
TextControl1.Selection.Length := 4;
TextControl1.Selection.Bold := True;

Next >>


Find and Replace

As an alternative to specifying start position and length of a word to be selected, the TextControl.Find method can be used to locate it. In this example, the font size of the word 'Text' is changed.

[C#]
textControl1.Text = "TX Text Control";
textControl1.Find("Text");
textControl1.Selection.FontSize = 400;
[Visual Basic]
TextControl1.Text = "TX Text Control"
TextControl1.Find("Text")
TextControl1.Selection.FontSize = 400
[Delphi]
TextControl1.Text := 'TX Text Control';
TextControl1.Find('Text');
TextControl1.Selection.FontSize := 400;

It is also possible to replace a piece of text once it has been selected. Note that there is no dedicated Replace method for this purpose, you simply use the Selection.Text property instead.


Append and Insert Documents

How to append a document

To append an existing document, the TextControl.Append method should be used.

The first thing required in order to insert a file into your document is to specify the location where it is to be inserted. This is done using the Selection.Start property. Having set the input position to the desired location, the Selection.Load method can be used to insert a file, string or image. In this sample, first an RTF file is loaded, and then a HTML file is appended to its end.

[C#]
textControl1.Load ("..\\..\\TestFiles\\Caption.rtf",
    TXTextControl.StreamType.RichTextFormat);
textControl1.Selection.Start = textControl1.Text.Length;
textControl1.Selection.Load ("..\\..\\TestFiles\\Net.htm",
TXTextControl.StreamType.HTMLFormat);
[Visual Basic]
TextControl1.Load("..\TestFiles\Caption.rtf", _
    TXTextControl.StreamType.RichTextFormat)
TextControl1.Selection.Start = TextControl1.Text.Length
TextControl1.Selection.Load("..\TestFiles\Net.htm", _
TXTextControl.StreamType.HTMLFormat)
[Delphi]
TextControl1.Load('TestFiles\Caption.rtf',
    TXTextControl.StreamType.RichTextFormat);
TextControl1.Selection.Start := TextControl1.Text.Length;
TextControl1.Selection.Load('TestFiles\Net.htm',
    TXTextControl.StreamType.HTMLFormat);


Moving to a Page, Line or Column

TX Text Control's InputPosition class informs you about which page, line and column the current input position is at. It can also be used to move the input position to a different location.

The following example shows how to create a Goto Page function. An instance of the InputPosition class is created and initialized with a previously entered page number. The new input position is then assigned to the TextControl.InputPosition property.

[C#]
frmGotoPage GotoPage = new frmGotoPage();
GotoPage.ShowDialog();
if (GotoPage.PageNo > 0 && GotoPage.PageNo <= textControl1.Pages)
{
    TXTextControl.InputPosition InputPosition =
        new TXTextControl.InputPosition(GotoPage.PageNo,1,0);
    textControl1.InputPosition = InputPosition;
}
else
{
    MessageBox.Show("Page number outside valid range.");
}
[Visual Basic]
PageNo = InputBox("Page no.", "Go to page", "1")PageNo = I
If PageNo > 0 And PageNo <= TextControl1.Pages Then
    Dim InputPosition As New TXTextControl.InputPosition(PageNo, 1, 0)
    TextControl1.InputPosition = InputPosition
Else
    MsgBox("Page number outside valid range.", MsgBoxStyle.Exclamation)
End If
[Delphi]
procedure Form1.mnuPage_Click(sender: System.Object; e: System.EventArgs);
var
    PageNo : Integer;
    InputPosition : TXTextControl.InputPosition;
begin
    PageNo := StrToInt(InputBox('Page no.', 'Go to page', '1'));
    if ((PageNo > 0) And (PageNo < TextControl1.Pages)) then begin
        InputPosition := TXTextControl.InputPosition.Create(PageNo, 1, 0);
        TextControl1.InputPosition := InputPosition;
    end
    else begin
        MessageBox.Show('Page number outside valid range.');
    end;
end;

Note that the InputPosition.Page property requires the ViewMode property to be set to PageView. In all other modes, text is displayed continuously as a single page, so the property will always have a value of 1.

<< Previous


Howto: Use the DataSourceManager

This chapter shows you how to use the DataSourceManager to create your own template designer for templates that are compatible with MailMerge.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\DataSourceManagerSample
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\DataSourceManagerSample

Used TX Text Control controls:

  • TXTextControl.TextControl

Relevant API links:

  • DocumentServer.DataSources.DataSourceManager

The DataSourceManager explained


The DataSourceManager explained

The DataSourceManager encapsulates the complete handling, logic and ready-to-use dialog boxes for the reporting template creation task. Essentially, the DataSourceManager provides all information required to create a fully-featured template designer. Like with MailMerge, a data source can be loaded from a DataSet, DataTable, Json, an object or XML. In this sample, a simple .NET class is used as a data source. The following screenshot shows this sample that illustrates the typical work-flow of a template designer.

After clicking the button Load Data Source, a new instance of the DocumentServer.DataSources.DataSourceManager is created and the data object is loaded.

[C#]
Order order = new Order()
{
    OrderID = 123,
    Customer = new Customer()
    {
        Name = "Peter Welch"
    },
    OrderItems = new List<OrderItem>()
    {
        new OrderItem() {
            Product = new Product() {
                Name = "Product A" },
            Quantity = 2 }
    }
};

dsManager = new DataSourceManager();
dsManager.LoadSingleObject(order);
[Visual Basic]
Dim order As New Order() With { _
    .OrderID = 123, _
    .Customer = New Customer() With { _
        .Name = "Peter Welch" _
    }, _
    .OrderItems = New List(Of OrderItem)() From { _
        New OrderItem() With { _
            .Product = New Product() With { _
                .Name = "Product A" _
            }, _
            .Quantity = 2 _
        } _
    } _
}

dsManager = New DataSourceManager()
dsManager.LoadSingleObject(order)

When a data source is loaded into the DocumentServer.DataSources.DataSourceManager, a ComboBox is bound to all available DataTables. Additionally, the events DocumentServer.DataSources.DataSourceManager.PossibleMergeFieldColumnsChanged and DocumentServer.DataSources.DataSourceManager.PossibleMergeBlockTablesChanged are attached to update two other ComboBoxes that list the available merge fields and merge blocks.

[C#]
dsManager.PossibleMergeFieldColumnsChanged +=
    DsManager_PossibleMergeFieldColumnsChanged;
dsManager.PossibleMergeBlockTablesChanged +=
    DsManager_PossibleMergeBlockTablesChanged;

cbMasterTable.DataSource =
    dsManager.DataTables.ToList<DataTableInfo>();
cbMasterTable.DisplayMember = "TableName";
[Visual Basic]
AddHandler dsManager.PossibleMergeFieldColumnsChanged, AddressOf DsManager_PossibleMergeFieldColumnsChanged
AddHandler dsManager.PossibleMergeBlockTablesChanged, AddressOf DsManager_PossibleMergeBlockTablesChanged

cbMasterTable.DataSource = dsManager.DataTables.ToList()
cbMasterTable.DisplayMember = "TableName"

When the internal master table is changed, the ComboBoxes are updated with the available fields and blocks:

[C#]
private void DsManager_PossibleMergeBlockTablesChanged(object sender, EventArgs e)
{
    cbMergeBlocks.Text = "";
    cbMergeBlocks.DataSource =
        dsManager.PossibleMergeBlockTables.ToList<DataTableInfo>();
    cbMergeBlocks.DisplayMember = "TableName";
}

private void DsManager_PossibleMergeFieldColumnsChanged(object sender, EventArgs e)
{
    cbMergeFields.Text = "";
    cbMergeFields.DataSource =
        dsManager.PossibleMergeFieldColumns.ToList<DataColumnInfo>();
    cbMergeFields.DisplayMember = "ColumnName";
}
[Visual Basic]
Private Sub DsManager_PossibleMergeBlockTablesChanged(sender As Object, e As EventArgs)
    cbMergeBlocks.Text = ""
    cbMergeBlocks.DataSource = dsManager.PossibleMergeBlockTables.ToList()
    cbMergeBlocks.DisplayMember = "TableName"
End Sub

Private Sub DsManager_PossibleMergeFieldColumnsChanged(sender As Object, e As EventArgs)
    cbMergeFields.Text = ""
    cbMergeFields.DataSource = dsManager.PossibleMergeFieldColumns.ToList()
    cbMergeFields.DisplayMember = "ColumnName"
End Sub

If the input position is inside a merge block, only the available fields and blocks inside this block should be available. Therefore, the TextControl.SubTextPartEntered event is used to define a new internal master table. The ComboBoxes are updated automatically through the attached events.

[C#]
private void textControl1_SubTextPartEntered(object sender,
                                             TXTextControl.SubTextPartEventArgs e)
{
    if (DataSourceManager.IsMergeBlock(e.SubTextPart))
    {
        if(dsManager.DataTables.Contains(e.SubTextPart.Name.Remove(0, 5)))
            dsManager.MasterDataTableInfo =
            dsManager.DataTables[e.SubTextPart.Name.Remove(0,5)];
    }
}

private void textControl1_SubTextPartLeft(object sender,
                                          TXTextControl.SubTextPartEventArgs e)
{
    dsManager.MasterDataTableInfo = cbMasterTable.SelectedItem as DataTableInfo;
}
[Visual Basic]
Private Sub textControl1_SubTextPartEntered(sender As Object, e As TXTextControl.SubTextPartEventArgs) Handles textControl1.SubTextPartEntered
    If DataSourceManager.IsMergeBlock(e.SubTextPart) Then
        If dsManager.DataTables.Contains(e.SubTextPart.Name.Remove(0, TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix.Length)) Then
            dsManager.MasterDataTableInfo = dsManager.DataTables(e.SubTextPart.Name.Remove(0, TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix.Length))
        End If
    End If
End Sub

Private Sub textControl1_SubTextPartLeft(sender As Object, e As TXTextControl.SubTextPartEventArgs) Handles textControl1.SubTextPartLeft
    dsManager.MasterDataTableInfo = TryCast(cbMasterTable.SelectedItem, DataTableInfo)
End Sub

When clicking the Preview button, the DocumentServer.DataSources.DataSourceManager.Merge method of the DataSourceManager is used to merge the data into the template:

[C#]
private void cbPreview_CheckedChanged(object sender, EventArgs e)
{
    if (cbPreview.Checked)
    {
        gbMergeElements.Enabled = false;
        textControl1.EditMode = TXTextControl.EditMode.ReadAndSelect;
        textControl1.Save(out previewTemplate,
            TXTextControl.BinaryStreamType.InternalUnicodeFormat);

        IList<byte[]> documents =
            dsManager.Merge(previewTemplate, textControl1);

        textControl1.Load(documents[0],
            TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    }
    else
    {
        gbMergeElements.Enabled = true;
        textControl1.EditMode = TXTextControl.EditMode.Edit;
        textControl1.Load(previewTemplate,
            TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    }
}
[Visual Basic]
Private Sub cbPreview_CheckedChanged(sender As Object, e As EventArgs) Handles cbPreview.Click
    If cbPreview.Checked Then
        gbMergeElements.Enabled = False
        textControl1.EditMode = TXTextControl.EditMode.ReadAndSelect
        textControl1.Save(previewTemplate, TXTextControl.BinaryStreamType.InternalUnicodeFormat)

        Dim documents As IList(Of Byte()) = dsManager.Merge(previewTemplate, textControl1)

        textControl1.Load(documents(0), TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    Else
        gbMergeElements.Enabled = True
        textControl1.EditMode = TXTextControl.EditMode.Edit
        textControl1.Load(previewTemplate, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    End If
End Sub

Using the DataSourceManager, the complete task of designing mail merge templates can be realized. The class encapsulates the work-flow, logic and all required dialog boxes and preview functionality.


Howto: Mail Merge

The chapter Connecting to Databases showed you how to store the entire contents of a TX Text Control in a database field. For implementing mail-merge functionality, however, the requirements are different: The contents of database fields have to be inserted at specified positions in a previously prepared document.

This chapter shows how to use the DocumentServer.MailMerge class in Windows Forms projects to merge TXTextControl.ApplicationFields in template documents with data from various data sources. The MailMerge class encapsulates powerful mail merge capabilities in a ready-to-use component. The DocumentServer.MailMerge class is part of the TXTextControl.DocumentServer namespace.

Using the DocumentServer.MailMerge component, template documents containing MS Word merge fields can be easily loaded, merged with a DataSet or DataTable of the Microsoft .NET System.Data namespace and exported to the supported file formats of TX Text Control like Adobe PDF or DOCX.

It is possible to pass a DataTable containing different columns that covers the merge field names. The data rows of the table equals the number of created documents. Optionally, it is possible to create separate documents or to append the documents to one resulting document.

Single merge fields can be inserted that will be filled with database content. Additionally, repeating blocks can be defined in the template. These blocks will be repeated according to the number of passed data rows.

The DocumentServer.MailMerge component supports the most important standard merge fields of MS Word. Supported fields are: MERGEFIELD, INCLUDETEXT, IF and DATE.

In the first step, this article explains how to connect the MailMerge component with an instance of TextControl. The source code for the examples is contained in the subfolders MailMerge_Simple, MailMerge_Blocks and MailMerge_Nested_Blocks of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\MailMerge
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\MailMerge

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar
  • DocumentServer.MailMerge

Relevant API links:

  • TextControl.ApplicationFields
  • DocumentServer.MailMerge

Connecting MailMerge to TextControl

Sample: Simple Mail Merge

Sample: Mail Merge with Repeating Blocks

Sample: Mail Merge with Nested Repeating Blocks

Creating Templates using TX Text Control Words


Connecting MailMerge to TextControl

In Visual Studio, choose Project... from the File -> New main menu in order to create a new Windows Forms Application.

DocumentServer.MailMerge is a separate component located in the TX Text Control 24.0 tab page of the Visual Studio toolbox. Drag and drop an instance of TextControl and MailMerge to the same form. DocumentServer.MailMerge will be added to the component tray area of the Designer View.

Select the MailMerge instance and find the DocumentServer.MailMerge.TextComponent property in the Properties window. In the drop down list, select the TextControl instance you want to connect to the MailMerge component.

Now that the MailMerge component and TextControl are connected, you can start a merge process by calling the DocumentServer.MailMerge.Merge method with an appropriate DataTable object. Automatically, DocumentServer.MailMerge uses the document of the connected TextControl instance as a template. Provided that the used DataTable contains fields that matches the contained ApplicationFields, they are automatically merged and the resulting document is loaded back into TextControl.

The following 3 samples give an overview of different options and usages.

Continue with the samples


Sample: Simple Mail Merge

Having loaded the sample program from the MailMerge_Simple directory, start the program and use the Add method from the ApplicationFields main menu to insert some fields. An XML file is used as a data source which is also used to insert the menu items dynamically.

The following code shows how to insert the fields into TX Text Control:

[C#]
private void InsertMergeField(string Name)
{
    MergeField mergeField = new MergeField();
    mergeField.Name = Name;
    mergeField.Text = "{ " + Name + " }";
    mergeField.ApplicationField.ShowActivated = true;
    mergeField.ApplicationField.DoubledInputPosition = true;

    textControl1.ApplicationFields.Add(mergeField.ApplicationField);
}
[Visual Basic]
Private Sub InsertMergeField(ByVal Name As String)
    Dim mergeField As New MergeField()
    mergeField.Name = Name
    mergeField.Text = "{ " & Name & " }"
    mergeField.ApplicationField.ShowActivated = True
    mergeField.ApplicationField.DoubledInputPosition = True

    textControl1.ApplicationFields.Add(mergeField.ApplicationField)
End Sub

After you created your mail merge template, choose Merge from the MailMerge main menu. The MailMerge component is used to merge the data into the ApplicationFields.

[C#]
mailMerge1.Merge(dsAddresses.Tables[0], true);
[Visual Basic]
mailMerge1.Merge(dsAddresses.Tables(0), true)

Continue with the next sample


Sample: Mail Merge with Repeating Blocks

The DocumentServer.MailMerge component can not only merge single fields in a template. Additionally, blocks can be defined that are repeated based on the number of specified data rows.

A MergeBlock is a region in a document that will be repeated in the merge process. This block can be easily inserted using the shipped TX Text Control Words. The document element SubTextPart range to define the beginning and the end of a repeating block. SubTextParts have a special naming, so that TX Text Control's MailMerge class can find the blocks and connected data. The name of the SubTextPart begins with txmb_ + the name of the merge block.

Load the sample program from the MailMerge_Blocks directory and start it. Automatically, a template is loaded that consists of simple merge fields and a repeating block which is basically the second row of the table.

Choose Merge from the MailMerge main menu to start the merge process. With a very few lines of code, the template is loaded and the data is merged using the DocumentServer.MailMerge component.

[C#]
private DataSet dsAddresses;

dsAddresses = new DataSet();
dsAddresses.ReadXml(Application.StartupPath + "\\data.xml");

TXTextControl.LoadSettings ls = new TXTextControl.LoadSettings();
ls.ApplicationFieldFormat = TXTextControl.ApplicationFieldFormat.MSWord;
ls.LoadSubTextParts = true;

textControl1.Load(Application.StartupPath + "\\template.docx", TXTextControl.StreamType.WordprocessingML, ls);

mailMerge1.MergeBlocks(dsAddresses);
mailMerge1.Merge(dsAddresses.Tables["address"], true);
[Visual Basic]
Private dsAddresses As DataSet

dsAddresses = New DataSet()
dsAddresses.ReadXml(Application.StartupPath + "\data.xml")

Dim ls As New TXTextControl.LoadSettings()
ls.ApplicationFieldFormat = TXTextControl.ApplicationFieldFormat.MSWord
ls.LoadSubTextParts = True

textControl1.Load(Application.StartupPath + "\template.docx", TXTextControl.StreamType.WordprocessingML, ls)

mailMerge1.MergeBlocks(dsAddresses)
mailMerge1.Merge(dsAddresses.Tables("address"), True)

Continue with the next sample


Sample: Mail Merge with Nested Repeating Blocks

The DocumentServer.MailMerge component supports the merging of nested blocks. The component recursively descents into the tree structure and merges the

In this sample, a report should list the "sick leave hours" and "vacation days" of all employees of a purely fictional company. The template contains static content, dynamic content for each employee and nested dynamic content for each specific employee record.

Static content

  • Heading: "Accruals Report"
  • Page number: "Page n"

Dynamic content

  • Company name: "Software Consultants, LLC"
  • Date

Dynamic content for each employee

  • Employee number
  • Employee name

Nested dynamic content for each employee

  • Date
  • Type
  • Action
  • Note
  • Hours
  • Balance

A repeating block can be any contiguous block of text in a template that is marked with a SubTextPart. The following screenshot shows such a repeating block in TX Text Control Words.

Using the MailMerge component that comes with the TX Text Control, the merge process is very easy. You don't need to iterate through the text fields and you don't need to care about the repeating blocks. The whole process is done automatically - including the nested blocks. The following code shows the required calls of the MailMerge component:

[C#]
mailMerge1.LoadTemplateFromMemory(data,
     TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);

DataSet ds = new DataSet();
ds.ReadXml(tbDatabaseFile.Tag.ToString(), XmlReadMode.Auto);

DataRelation relation_sick = new DataRelation("sick",
     ds.Tables["employee"].Columns["dyn_employee_number"],
     ds.Tables["sick"].Columns["dyn_employee_number"]);

DataRelation relation_vacation = new DataRelation("vacation",
     ds.Tables["employee"].Columns["dyn_employee_number"],
     ds.Tables["vacation"].Columns["dyn_employee_number"]);

ds.Relations.Add(relation_vacation);
ds.Relations.Add(relation_sick);

mailMerge1.MergeBlocks(ds);
mailMerge1.Merge(ds.Tables["general"], true);
[Visual Basic]
mailMerge1.LoadTemplateFromMemory(data, _
     TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)

Dim ds As New DataSet()
ds.ReadXml(tbDatabaseFile.Tag.ToString(), XmlReadMode.Auto)

Dim relation_sick As New DataRelation("sick", ds.Tables("employee").Columns("dyn_employee_number"), _
     ds.Tables("sick").Columns("dyn_employee_number"))

Dim relation_vacation As New DataRelation("vacation", _
     ds.Tables("employee").Columns("dyn_employee_number"), _
     ds.Tables("vacation").Columns("dyn_employee_number"))

ds.Relations.Add(relation_vacation)
ds.Relations.Add(relation_sick)

mailMerge1.MergeBlocks(ds)
mailMerge1.Merge(ds.Tables("general"), True)

Let's have a look at the XML file we are using as a data source. The DataSet contains 4 DataTables:

The green highlighted columns indicate that these columns are connected through a DataRelation. The MailMerge class automatically descents into the tree structure and merges the contained fields with the corresponding relational data. This process is recursive, so that unlimited levels of nested blocks are feasible.

How to use this sample?

Assuming that you loaded this project into Visual Studio and started this project, the following steps are required to create a report:

1. Click on Load XML... from the Report main menu, browse for the data.xml file that comes with the sample and Open it.

2. Click the Create Report button in the button bar to start the merge process.

The following screenshot shows the merged report document that can be printed or exported as an Adobe PDF file.

Back to the MailMerge overview


Creating Templates using TX Text Control Words

The shipped application TX Text Control Words is designed to create templates which are compatible to the DocumentServer.MailMerge component. It allows users to connect to databases and to insert valid merge fields and repeating blocks into a document. These documents can be exported to all supported file formats.

TX Text Control Words is an application based on TX Text Control .NET that helps users create fully featured templates that work properly with the DocumentServer.MailMerge class. It uses the standard MS Word MergeFields that are represented by the ApplicationField class of TX Text Control .NET.

Start TX Text Control Words and open the Reports tab page of the ribbon menu.

In the first step, you can select a data source. You can choose between Microsoft Access or SQL Server database files, an ODBC data source or a Microsoft SQL Server connection.

After you selected a data source, the available tables are listed in the Select Table dropdown button.

The Insert Merge Field dropdown button lists all available fields of the selected table. This button can be used to insert various merge fields into the template:

To preview the results from the currently selected data table, select Preview Merge Fields and browse through the records using the data source navigation buttons. Finally, you can Finish & Merge the template with the selected data source. The data can be merged into the current document, you can create separate files or you can print the resulting document.


Howto: Modify the Ribbon Bar

This chapter shows you how to modify the shipped Ribbon bar. You will learn how to remove and add buttons, groups and tabs.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\RibbonModify
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\RibbonModify

Used TX Text Control controls:

  • TXTextControl.TextControl
  • Windows.Forms.Ribbon.Ribbon

Relevant API links:

  • Windows.Forms.Ribbon.RibbonButton
  • Windows.Forms.Ribbon.RibbonGroup

Modifying the Ribbon bar


Modifying the Ribbon bar

TX Text Control .NET for Windows Forms is shipped with a fully-featured, customizable and programmable Ribbon Bar with pre-configured Ribbon Tabs for the most typical applications of TX Text Control. When clicking the buttons in the sample project, buttons are removed, ribbon groups are removed or complete tabs are created with a group and a button.

Changing the ribbon item's text

The first button Change RibbonItem Text (Paste button) uses the Windows.Forms.Ribbon.RibbonFormattingTab.FindItem method to retrieve the Paste Windows.Forms.Ribbon.RibbonSplitButton. Using the Windows.Forms.Ribbon.RibbonButton.Text property, the text of the button can be changed:

[C#]
RibbonSplitButton ribbonItem = (RibbonSplitButton)ribbonFormattingTab1.FindItem(
    RibbonFormattingTab.RibbonItem.TXITEM_Paste);

ribbonItem.Text = "New Text";
[Visual Basic]
Dim ribbonItem As RibbonSplitButton = DirectCast(
    ribbonFormattingTab1.FindItem(RibbonFormattingTab.RibbonItem.TXITEM_Paste), RibbonSplitButton)

ribbonItem.Text = "New Text"

Adding events to ribbon items

The second button adds the Windows.Forms.Ribbon.RibbonSplitButton.ButtonClick event to the split button:

[C#]
RibbonSplitButton ribbonItem = (RibbonSplitButton)ribbonFormattingTab1.FindItem(
    RibbonFormattingTab.RibbonItem.TXITEM_Paste);

ribbonItem.ButtonClick += RibbonItem_ButtonClick;
[Visual Basic]
Dim ribbonItem As RibbonSplitButton = DirectCast(
    ribbonFormattingTab1.FindItem(RibbonFormattingTab.RibbonItem.TXITEM_Paste), RibbonSplitButton)

AddHandler ribbonItem.ButtonClick, AddressOf RibbonItem_ButtonClick

Removing ribbon items

This button removes a ribbon item from it's parent container, the Windows.Forms.Ribbon.RibbonGroup:

[C#]
RibbonSplitButton ribbonItem = (RibbonSplitButton)ribbonFormattingTab1.FindItem(
    RibbonFormattingTab.RibbonItem.TXITEM_Paste);

if(ribbonItem.ParentCollection != null)
    ribbonItem.ParentCollection.Remove(ribbonItem);
[Visual Basic]
Dim ribbonItem As RibbonSplitButton = DirectCast(
    ribbonFormattingTab1.FindItem(RibbonFormattingTab.RibbonItem.TXITEM_Paste), RibbonSplitButton)

If ribbonItem.ParentCollection IsNot Nothing Then
    ribbonItem.ParentCollection.Remove(ribbonItem)
End If

Removing ribbon groups

When clicking the button Remove RibbonGroup (Font), the complete Font ribbon group gets removed:

[C#]
foreach (RibbonGroup group in ribbonFormattingTab1.RibbonGroups)
{
    if (group.Name == "TXITEM_FontGroup")
    {
        ribbonFormattingTab1.RibbonGroups.Remove(group);
        break;
    }
}
[Visual Basic]
For Each group As RibbonGroup In ribbonFormattingTab1.RibbonGroups
    If group.Name = "TXITEM_FontGroup" Then
        ribbonFormattingTab1.RibbonGroups.Remove(group)
        Exit For
    End If
Next

Removing ribbon tabs

Complete ribbon tabs can be removed using the Controls property of the Windows.Forms.Ribbon.Ribbon control:

[C#]
ribbon1.Controls.Remove(ribbonInsertTab1);
[Visual Basic]
ribbon1.Controls.Remove(ribbonInsertTab1)

Creating new ribbon tabs

The event handler of the last button creates a complete new Windows.Forms.Ribbon.RibbonTab with a new Windows.Forms.Ribbon.RibbonGroup. Additionally, a new Windows.Forms.Ribbon.RibbonButton is created and added to the created ribbon group. Finally, the ribbon tab is added to the Controls collection of the ribbon control and the selected tab is specified using the SelectedIndex property.

[C#]
// create a new RibbonTab control and set the text (tab title)
RibbonTab myRibbonTab = new RibbonTab();
myRibbonTab.Text = "MyRibbonTab";

// create a new RibbonGroup
RibbonGroup myRibbonGroup = new RibbonGroup() { Text = "My Group" };

// make the dialog launcher icon invisible
myRibbonGroup.DialogBoxLauncher.Visible = false;

// add the new RibbonGroup to the RibbonGroup collection
// of the newly created RibbonTab
myRibbonTab.RibbonGroups.Add(myRibbonGroup);

// create a new RibbonButton
RibbonButton rbtnClickMe = new RibbonButton()
{
    Text = "Click me!",
    IsAddToQuickAccessToolbarEnabled = true,
};

// set some properties of the button and attach a "Click" event
rbtnClickMe.ToolTip.Title = "Tooltip Title";
rbtnClickMe.ToolTip.Description = "Tooltip Description";
rbtnClickMe.DisplayMode = IconTextRelation.LargeIconLabeled;
rbtnClickMe.LargeIcon = Image.FromFile("previewclose.png");
rbtnClickMe.Click += RbtnClickMe_Click;
rbtnClickMe.BackColor = Color.LawnGreen;

// add the button to the RibbonGroup
myRibbonGroup.RibbonItems.Add(rbtnClickMe);

// add the newly created RibbonTab to the Ribbon control
ribbon1.Controls.Add(myRibbonTab);

// set the selected tab to the new RibbonTab
ribbon1.SelectedIndex = ribbon1.TabCount - 1;
[Visual Basic]
' create a new RibbonTab control and set the text (tab title)
Dim myRibbonTab As New RibbonTab()
myRibbonTab.Text = "MyRibbonTab"

' create a new RibbonGroup
Dim myRibbonGroup As New RibbonGroup() With { _
    .Text = "My Group" _
}

' make the dialog launcher icon invisible
myRibbonGroup.DialogBoxLauncher.Visible = False

' add the new RibbonGroup to the RibbonGroup collection
' of the newly created RibbonTab
myRibbonTab.RibbonGroups.Add(myRibbonGroup)

' create a new RibbonButton
Dim rbtnClickMe As New RibbonButton() With { _
    .Text = "Click me!", _
    .IsAddToQuickAccessToolbarEnabled = True _
}

' set some properties of the button and attach a "Click" event
rbtnClickMe.ToolTip.Title = "Tooltip Title"
rbtnClickMe.ToolTip.Description = "Tooltip Description"
rbtnClickMe.DisplayMode = IconTextRelation.LargeIconLabeled
rbtnClickMe.LargeIcon = Image.FromFile("previewclose.png")
AddHandler rbtnClickMe.Click, AddressOf RbtnClickMe_Click
rbtnClickMe.BackColor = Color.LawnGreen

' add the button to the RibbonGroup
myRibbonGroup.RibbonItems.Add(rbtnClickMe)

' add the newly created RibbonTab to the Ribbon control
ribbon1.Controls.Add(myRibbonTab)

' set the selected tab to the new RibbonTab
ribbon1.SelectedIndex = ribbon1.TabCount - 1


Howto: Use Hypertext Links

This chapter shows you how to add hypertext links and targets to your documents, and how to respond to events fired by TX Text Control when a hypertext link is clicked. For an overview of the various classes, properties, methods and events involved, please refer to the chapter Text Fields and Hypertext Links in the Technical Articles part of this manual.

The source code for this example is contained in the subfolders Step1 to Step3 of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Hyperlinks
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Hyperlinks

Used TX Text Control controls:

  • TXTextControl.TextControl

Relevant API links:

  • TextControl.DocumentTargets
  • TextControl.HypertextLinks
  • TextControl.Selection

Step 1: Inserting a Hypertext Link

Step 2: Adding a Dialog Box for Inserting Hypertext Links

Step 3: Adding Document Targets


Step 1: Inserting a Hypertext Link

In this first sample program, a hypertext link will be inserted in a text document. The document is then saved as an HTML file so that it can be displayed in a browser. This is what the sample program looks like:

To insert a hypertext link, we first need to create a HypertextLink object. The text to be displayed in the document ("Text Control Web Site") and the information about where to link to ("http://www.textcontrol.com") are passed as parameters to the constructor. The object that is thus created is then inserted at the current input position by adding it to a Text Control's HypertextLinks collection.

[C#]
private void cmdInsertHyperlink_Click(object sender, System.EventArgs e)
{
    // Create a HypertextLink object
    TXTextControl.HypertextLink MyLink =
        new TXTextControl.HypertextLink(
        "Text Control Web Site",
        "http://www.textcontrol.com");
    // Insert the hyperlink into the document
    textControl1.HypertextLinks.Add(MyLink);
}
[Visual Basic]
Private Sub cmdInsertHyperlink_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles cmdInsertHyperlink.Click
    ' Create a HypertextLink object
    Dim MyLink As New TXTextControl.HypertextLink( _
        "Text Control Web Site", _
        "http://www.textcontrol.com")
    ' Insert the hyperlink into the document
    TextControl1.HypertextLinks.Add(MyLink)
End Sub
[Delphi]
procedure Form1.cmdInsertHyperlink_Click(sender: System.Object;
    e: System.EventArgs);
var
    MyLink : TXTextControl.HypertextLink;
begin
    // Create a HypertextLink object
    MyLink := TXTextControl.HypertextLink.Create(
        'Text Control Web Site', 'http://www.textcontrol.com');
    // Insert the hyperlink into the document
    TextControl1.HypertextLinks.Add(MyLink);
end;

Note that this first sample program does not handle the Click events, so clicking on a hypertext link in the TX Text Control will have no effect. Also, the link does not yet have the typical blue and underlined formatting style. Click events and formatting will be covered in Step 2.

The TextControl.Save method is used to save the document as an HTML file:

[C#]
private void cmdSaveAs_Click(object sender, System.EventArgs e)
{
    textControl1.Save(TXTextControl.StreamType.HTMLFormat);
}
[Visual Basic]
Private Sub cmdSaveAs_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles cmdSaveAs.Click
    TextControl1.Save(TXTextControl.StreamType.HTMLFormat)
End Sub
[Delphi]
procedure Form1.cmdSaveAs_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Save(TXTextControl.StreamType.HTMLFormat);
end;

When the HTML file is opened in a web browser, the hypertext link is displayed as specified in your browser's settings.

Clicking on the link will take you to the TX Text Control web site.

Next >>


Step 2: Adding a Dialog Box for Inserting Hypertext Links

In this second sample program, a dialog box is created which enables you to insert hypertext links in a more convenient way. Additionally, hypertext links which have previously been inserted or loaded from a file, can be edited and modified. Note that, while hypertext links are usually associated with HTML files, they can as well be stored in RTF or Microsoft Word files, or in TX Text Control's proprietary format.

The dialog box contains two text boxes. The first is for the text that represents the hypertext link in the document and the second is for the address, to which the link points.

The same dialog box is used for both, inserting a new and editing an existing hypertext link. Depending on whether the current input position is inside an existing link, this link is modified. Otherwise, a new one is inserted.

[C#]
private void mnuInsert_Hyperlink_Click(object sender, System.EventArgs e)
{
    frmHyperlinks Hyperlinks = new frmHyperlinks();
    Hyperlinks.tx = textControl1;
    Hyperlinks.ShowDialog();
    HighlightHyperlinks (textControl1, mnuView_Hyperlinks.Checked);
}
[Visual Basic]
Private Sub mnuInsert_Hyperlink_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles mnuInsert_Hyperlink.Click
    Dim Hyperlinks As New frmHyperlinks
    Hyperlinks.tx = TextControl1
    Hyperlinks.ShowDialog()
    HighlightHyperlinks(TextControl1, mnuView_Hyperlinks.Checked)
End Sub
[Delphi]
procedure TWinForm1.mnuInsert_Hyperlink_Click(sender: System.Object;
    e: System.EventArgs);
var
    Hyperlinks : TfrmHyperlinks;

begin
    Hyperlinks := TfrmHyperlinks.Create;
    Hyperlinks.tx := TextControl1;
    Hyperlinks.ShowDialog;
    HighlightHyperlinks(TextControl1, mnuView_Hyperlinks.Checked);
end;

When the form is loaded, the text boxes are filled with the text and link information, provided that the current input position is inside a link:

[C#]
private void frmHyperlinks_Load(object sender, System.EventArgs e)
{
    TXTextControl.HypertextLink HyperLink = tx.HypertextLinks.GetItem();
    if (HyperLink != null)
    {
        // If there is an existing hypertext link at the input position,
        // copy its text and target to the text boxes on the form.
        txtLinkedText.Text = HyperLink.Text;
        txtLinkTo.Text = HyperLink.Target;
    }
    else
    {
        // If there is no hypertext link at the input position, but
        // some text has been selected, then copy this text to the
        // Linked Text text box.
        if  (tx.Selection.Length > 0)
            txtLinkedText.Text = tx.Selection.Text;
    }
}
[Visual Basic]
Private Sub frmHyperlinks_Load(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles MyBase.Load
    Dim HyperLink As TXTextControl.HypertextLink = tx.HypertextLinks.GetItem()
    If Not (HyperLink Is Nothing) Then
        ' If there is an existing hypertext link at the input position,
        ' copy its text and target to the text boxes on the form.
        txtLinkedText.Text = HyperLink.Text
        txtLinkTo.Text = HyperLink.Target
    Else
        ' If there is no hypertext link at the input position, but
        ' some text has been selected, then copy this text to the
        ' Linked Text text box.
        If (tx.Selection.Length > 0) Then
            txtLinkedText.Text = tx.Selection.Text
        End If
    End If
End Sub
[Delphi]
procedure TfrmHyperlinks.frmHyperlinks_Load(sender: System.Object;
    e: System.EventArgs);
var
    HyperLink : TXTextControl.HypertextLink;

begin
    HyperLink := tx.HypertextLinks.GetItem;
    if HyperLink <> NIL then begin
        // If there is an existing hypertext link at the input position,
        // copy its text and target to the text boxes on the form.
        txtLinkedText.Text := HyperLink.Text;
        txtLinkTo.Text := HyperLink.Target;
    end
    else begin
        // If there is no hypertext link at the input position, but
        // some text has been selected, then copy this text to the
        // Linked Text text box.
        if tx.Selection.Length > 0 then
            txtLinkedText.Text := tx.Selection.Text;
    end;
end;

The user then can change the displayed information. On clicking the OK button, the information is transfered to the document by either inserting a new link or modifying the existing one:

[C#]
private void cmdOK_Click(object sender, System.EventArgs e)
{
    TXTextControl.HypertextLink HyperLink = tx.HypertextLinks.GetItem();
    if (HyperLink == null)
    {
        // Insert a new link
        TXTextControl.HypertextLink NewLink =
            new TXTextControl.HypertextLink(
            txtLinkedText.Text , txtLinkTo.Text);
        tx.HypertextLinks.Add(NewLink);
    }
    else
    {
        // Update an existing link
        HyperLink.Text = txtLinkedText.Text;
        HyperLink.Target = txtLinkTo.Text;
    }
    Close();
}
[Visual Basic]
Private Sub cmdOK_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles cmdOK.Click
    Dim HyperLink As TXTextControl.HypertextLink = tx.HypertextLinks.GetItem()
    If HyperLink Is Nothing Then
        ' Insert a new link
        Dim NewLink As New TXTextControl.HypertextLink( _
            txtLinkedText.Text, txtLinkTo.Text)
        tx.HypertextLinks.Add(NewLink)
    Else
        ' Update an existing link
        HyperLink.Text = txtLinkedText.Text
        HyperLink.Target = txtLinkTo.Text
    End If
    Close()
End Sub
[Delphi]
procedure TfrmHyperlinks.cmdOK_Click(sender: System.Object;
    e: System.EventArgs);
var
    HyperLink : TXTextControl.HypertextLink;
    NewLink : TXTextControl.HypertextLink;

begin
    HyperLink := tx.HypertextLinks.GetItem;
    if HyperLink = NIL then begin
        // Insert a new link
        NewLink := TXTextControl.HypertextLink.Create(
            txtLinkedText.Text, txtLinkTo.Text);
        tx.HypertextLinks.Add(NewLink);
    end
    else begin
        // Update an existing link
        HyperLink.Text := txtLinkedText.Text;
        HyperLink.Target := txtLinkTo.Text;
    end;
    Close;
end;

Finally, there is a menu item to switch the character format of the hyperlink's text to blue colored and underlined style. The menu item calls the function HighlightHyperlinks, which is not a Text Control method, but part of the sample program. It changes each element of the Text Control's HypertextLinkCollection to the desired display style.

[C#]
void HighlightHyperlinks(TXTextControl.TextControl tx, bool bHighlight)
{
    int PreviousStart = tx.Selection.Start,
        PreviousLength = tx.Selection.Length;

    foreach (TXTextControl.HypertextLink Link in tx.HypertextLinks)
    {
        tx.Selection.Start = Link.Start-1;
        tx.Selection.Length = Link.Length;
        if (bHighlight)
        {
            tx.Selection.ForeColor = Color.Blue;
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.Single;
        }
        else
        {
            tx.Selection.ForeColor = Color.Black;
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.None;
        }
    }
    tx.Selection.Start = PreviousStart;
    tx.Selection.Length = PreviousLength;
}
[Visual Basic]
Private Sub HighlightHyperlinks(ByVal tx As TXTextControl.TextControl, _
    ByVal Highlight As Boolean)
    Dim PreviousStart As Integer = tx.Selection.Start
    Dim PreviousLength As Integer = tx.Selection.Length
    For Each Link As TXTextControl.HypertextLink In tx.HypertextLinks
        tx.Selection.Start = Link.Start - 1
        tx.Selection.Length = Link.Length
        If Highlight Then
            tx.Selection.ForeColor = Color.Blue
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.Single
        Else
            tx.Selection.ForeColor = Color.Black
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.None
        End If
        tx.Selection.Start = PreviousStart
        tx.Selection.Length = PreviousLength
    Next
End Sub
[Delphi]
procedure TWinForm1.HighlightHyperlinks(tx : TXTextControl.TextControl;
    Highlight: Boolean);
var
    PreviousStart : Integer;
    PreviousLength : Integer;
    Link : TXTextControl.HypertextLink;
    i : Integer;

begin
    PreviousStart := tx.Selection.Start;
    PreviousLength := tx.Selection.Length;
    for i := 0 to tx.HypertextLinks.Count -1  do begin
        Link := tx.HypertextLinks.GetItem(i);
        tx.Selection.Start := Link.Start - 1;
        tx.Selection.Length := Link.Length;
        if Highlight then begin
            tx.Selection.ForeColor := Color.Blue;
            tx.Selection.Underline := TXTextControl.FontUnderlineStyle.Single;
        end
        else begin
            tx.Selection.ForeColor := Color.Black;
            tx.Selection.Underline := TXTextControl.FontUnderlineStyle.None;
        end;
        tx.Selection.Start := PreviousStart;
        tx.Selection.Length := PreviousLength;
    end;
end;


Step 3: Adding Document Targets

Step 1 and 2 introduced references to external resources, i.e. addresses of web pages or files. In this step, links to positions in the same document will be discussed. These links are called document links and the positions, to which they point, are called document targets. Document targets are also refered to as anchors (in the context of HTML editors) or bookmarks (in word processors).

When running this sample program, first add some text and then one or two targets with the Insert / Target... menu item.

Finally use the Insert / Hypertext Link... menu item to add links to these targets. The names of the targets you have inserted will be displayed in the Link Location combo box.

Inserting a Target

A target is created by adding a DocumentTarget object to the DocumentTargets collection.

Unlike links, targets have no visible text. The constructor therefore has only a single parameter, which is the target's name.

[C#]
TXTextControl.DocumentTarget Target =
    new TXTextControl.DocumentTarget(InsertTarget.TargetName);
textControl1.DocumentTargets.Add(Target);
[Visual Basic]
Dim Target As New TXTextControl.DocumentTarget(InsertTarget.TargetName)
TextControl1.DocumentTargets.Add(Target)
[Delphi]
Target := TXTextControl.DocumentTarget.Create(InsertTarget.TargetName);
TextControl1.DocumentTargets.Add(Target);

Inserting Links to Targets

The Hypertext Link dialog box from Step 2 needs to be extended so that it will not only accept URLs as link targets, but also lets us select from a list of document targets. This is done by replacing the Link To text box with a combo box. The combo box is filled with targets by adding all elements from the DocumentTargets collection:

[C#]
foreach (TXTextControl.DocumentTarget Target in tx.DocumentTargets)
    cboLinkTo.Items.Add("#" + Target.TargetName);
[Visual Basic]
For Each Target As TXTextControl.DocumentTarget In tx.DocumentTargets
    cboLinkTo.Items.Add("#" + Target.TargetName)
Next
[Delphi]
for Target in tx.DocumentTargets do begin
    cboLinkTo.Items.Add('#' + Target.TargetName);
 end;

Jumping to a Target

When a document link is clicked on, text should automatically be scrolled so that the text part containing the link's target becomes visible. This is done by responding to the DocumentLinkClicked event and calling the ScrollTo method. The DocumentTarget class inherits this method from its parent class, TextField.

[C#]
private void textControl1_DocumentLinkClicked(object sender,
    TXTextControl.DocumentLinkEventArgs e)
{
    e.DocumentLink.DocumentTarget.ScrollTo();
}
[Visual Basic]
Private Sub mnuView_JumpToTargets_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles mnuView_JumpToTargets.Click
    e.DocumentLink.DocumentTarget.ScrollTo()
End Sub
[Delphi]
procedure Form1.TextControl1_DocumentLinkClicked(sender: System.Object;
    e: TXTextControl.DocumentLinkEventArgs);
begin
    e.DocumentLink.DocumentTarget.ScrollTo;
end;

Editing Links to Targets

The autoscroll feature has one drawback in that you can no longer click on a link and open the hyperlinks dialog box to edit it. This is because each time you click on a link, Text Control will scroll it out of view. However, this can be fixed by adding a Jump to targets item to the View menu, which switches the autoscroll feature on and off as required.

Displaying and Editing Targets

TX Text Control is able to display a marker to visualize the location of a target. But if targets are invisible, how can you locate them in your document, or delete one that's no longer required? The solution is a list box which displays the names of all targets a document contains, and lets you jump to or remove a selected target.

<< Previous


Howto: Use XML Files

The purpose of this chapter is to help you get started with Text Control Enterprise and its XML features. It will show you how to open an XML file, and how to use it in conjunction with a CSS stylesheet and a DTD.

There is a more detailed description of the XML related properties and methods in the Technical Articles section, see Working with XML Files.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\XMLBasics
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\XMLBasics

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar

Relevant API links:

  • TextControl.Load

The Sample Program

The XML File

The CSS File

The DTD File

Editing in XML Mode


The Sample Program

The sample program has only one menu item, which is Open File.... Looking at the source code reveals nothing unusual: The main difference to the Open File routine in other Text Control sample programs is the Load method being called with the StreamType value XMLFormat as a parameter, so that the Open File dialog box will only display XML files:

[C#]
private void mnuFile_Open_Click(object sender, System.EventArgs e)
{
    textControl1.Load(TXTextControl.StreamType.XMLFormat);
}
[Visual Basic]
Private Sub mnuFile_Open_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Open.Click
    TextControl1.Load(TXTextControl.StreamType.XMLFormat)
End Sub
[Delphi]
proedure TWinForm1.mnuFile_Open_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Load(TXTextControl.StreamType.XMLFormat);
end;

There is quite a bit happeing behind the scenes, however. If you load the TestFile.xml sample file, Text Control will not only load the xml file, but will

  • automatically validate it using the enclosed DTD, and
  • format it according to the CSS stylesheet provided.

Let us take a closer look at the 3 files involved.

Next >>


The XML File

The XML file contains a simple list of addresses:

<?xml version="1.0"?>
<?XML:stylesheet type="text/css" href="address.css"?>
<!DOCTYPE address SYSTEM "address.dtd">
<address>
   <address_record>
      <name>Paul</name>
      <street>Baker Street</street>
      <city>London</city>
      <email>paul@hotmail.com</email>
   </address_record>
   <address_record>
      <name>George</name>
      <email>george@hotmail.com</email>
   </address_record>
</address>

Note that, unlike an HTML or RTF file, an XML file does not contain any information about how the text is to be displayed or formatted.


The CSS File

In line 2 of the XML file (above), you can see a reference to a stylesheet file called address.css. This CSS file tells Text Control that an address entry should be displayed as a table, and that the individual elements are table cells, having a 1 pixel wide border and a font size of 1 point:

address { display: table }
address_record { display: table-row}
name, street, city, email { display: table-cell; border: 1px; font-size: 11pt }

When you load address.xml with the sample program, Text Control will display it according to this stylesheet.

Changing the CSS file can make the text appear in a completely different way. For instance, a list can be used instead of a table, as in this example:

name {	display: block; font-size: 14pt; color: blue }
street, city, email { display: list-item; font-size: 11pt}

This is how Text Control will display the XML data using the new sylesheet:


The DTD File

The DTD specifies which elements may occur in an XML file, and in which way the elements should be ordered or nested. The sample DTD specifies that an address contains one or more address_record elements, which in turn can contain a name, street, city, and email. street and city are defined as optional elements.

<!ELEMENT address ( address_record+ )>
<!ELEMENT address_record ( name, street?, city?, email )>
<!ELEMENT name (#PCDATA )>
<!ELEMENT street (#PCDATA )>
<!ELEMENT city (#PCDATA )>
<!ELEMENT email (#PCDATA )>

When loading an XML file, Text Control checks whether the XML code is valid, i.e. adheres to the rules specifed in the DTD. An error will occur if it does not, like in this example, where the required <name> has been removed:

<?xml version="1.0"?>
<? XML:stylesheet type="text/css" href="address.css"?>
<!DOCTYPE address SYSTEM "address.dtd">
<address>
    <address_record>
        <street>Baker Street</street>
        <city>London</city>
        <email>paul@hotmail.com</email>
    </address_record>
</address>

This strict error checking is considered one of the major strengths of XML, as it ensures that a document will always have a certain structure, and thus can be processed by other applications.


Editing in XML Mode

This chapter looks at some of the differences between normal text editing and editing an XML file.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\XMLEditing
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\XMLEditing

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar

Relevant API links:

  • TextControl.Load

The Sample Program

Run the sample program and load the demo file address_list.xml. You will notice that there is now a button bar with 3 combo boxes:

You don't need to create the combo boxes yourself, they are built into Text Control's ButtonBar.

The first combo box displays the style of the current XML field. If you move down the caret by pressing the down arrow key, the display will change from name to street, city and email, depending on what type of field you are in.

With the second combo box, additional XML fields can be inserted.

You can select to either insert a complete address record, or one of the optional elements, which are street and city. Depeding on the DTD, not all elements can be inserted at all positions. For instance, if you click on the name Paul in the first line of the document, and try to insert a street, an error will occur, because this record already contains a street. Try again with Ringo, and it will work.

The third combo box is for deleting XML fields. Again, every action is checked with the DTD, so that you can be sure not to invalidate your document by, for instance, deleting a required field.

<< Previous


Howto: Use Text Frames

This chapter describes how you can control and manipulate text using text frames.

The source code for for the sample programs shown here is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Text Frames
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Text Frames

An overview of all properties, methods and events which can be used in conjunction with text frames can be found at Images and Text Frames.

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

Relevant API links:

  • TextControl.TextFrames

Inserting a Text Frame

Printing Labels


Inserting a Text Frame

A text frame is inserted by first creating an instance of the TextFrame class, and then adding it to the TextFrameCollection:

[C#]
TXTextControl.TextFrame newFrame = new TXTextControl.TextFrame(new Size(1000,1000));
textControl1.TextFrames.Add (newFrame, TXTextControl.HorizontalAlignment.Left,
    -1,TXTextControl.TextFrameInsertionMode.DisplaceText);
[Visual Basic]
Dim NewFrame As New TXTextControl.TextFrame(New Size(1000, 1000))
TextControl1.TextFrames.Add(NewFrame, TXTextControl.HorizontalAlignment.Left, _
    -1, TXTextControl.TextFrameInsertionMode.DisplaceText)
[Delphi]
var
    NewFrame : TXTextControl.TextFrame;
    TextFrameSize : System.Drawing.Size;
begin
    TextFrameSize := System.Drawing.Size.Create(1000, 1000);
    NewFrame := TXTextControl.TextFrame.Create(TextFrameSize);
    TextControl1.TextFrames.Add(NewFrame, TXTextControl.HorizontalAlignment.Left,
         -1, TXTextControl.TextFrameInsertionMode.DisplaceText);
end;

Once a text frame has been inserted, it can be activated by clicking on its border. An activated text frame can be moved and resized by dragging its border with the mouse.

Text Control provides a built-in dialog box for changing the appearance of a text frame. The dialog box is displayed using the TextFrameAttributesDialog method:

[C#]
textControl1.TextFrameAttributesDialog();
[Visual Basic]
TextControl1.TextFrameAttributesDialog()
[Delphi]
TextControl1.TextFrameAttributesDialog;

The menu item which displays this dialog box should be disabled when no text frame is selected. This can be done in the menu's popup event, using the GetItem method of the TextFrame collection:

[C#]
mnuTextFrame_Properties.Enabled = (textControl1.TextFrames.GetItem() != null);
[Visual Basic]
mnuTextFrame_Properties.Enabled = Not IsNothing(TextControl1.TextFrames.GetItem())
[Delphi]
mnuTextFrame_Properties.Enabled := (TextControl1.TextFrames.GetItem() <> NIL);

Next >>


Printing Labels

This sample program shows how to insert multiple text frames simultaneously. The application is a label printing program, used to print, for instance, address lables or badges. The source code for this sample program can be found in the TextFrames\Printing Address Lables directory.

The sample program contains a dialog box for entering information about the label sheet to be used, e.g. the number of lables and their dimensions.

The program then creates a text frame for each of the labels.

The text frames can them be filled out, either manually by clicking on a field and typing in text, or from a file or database. When you click on the Fill in menu item, the sample program will enter the words "Address no." followed by the field identifier into each of the frames.

To load text from a file instead, simply replace the Selection.Text property with a call to the Selection.Load method.

[C#]
private void mnuLabel_FillIn_Click(object sender, System.EventArgs e)
{
    int n = 0;
    foreach (TXTextControl.TextFrame frame in textControl1.TextFrames)
    {
        frame.Selection.Text = "Text Frame #" + Convert.ToString(n++);
    }
}
[Visual Basic]
Private Sub mnuLabel_FillIn_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuLabel_FillIn.Click
    Dim N As Integer

    For Each Frame As TXTextControl.TextFrame In TextControl1.TextFrames
        Frame.Selection.Text = "Text Frame #" & N
        N = N + 1
    Next
End Sub
[Delphi]
procedure TWinForm1.mnuLabel_FillIn_Click(sender: System.Object; e: System.EventArgs);
var
    n : Integer;
    Frame : TXTextControl.TextFrame;
begin
    for Frame in TextControl1.TextFrames do begin
        Frame.Selection.Text := 'Text Frame #' + n.ToString();
        n := n + 1;
    end;
end;

<< Previous


Howto: Drag and Drop Files

This chapter describes how to handle drag and drop with TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\DragDrop
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\DragDrop

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.RulerBar
  • TXTextControl.StatusBar

Relevant API links:

  • TextControl.Load

Two Types of Drag and Drop

File Drag and Drop

Handling Drag and Drop Events


Two Types of Drag and Drop

Most word processors support two different types of Drag and Drop:

  • Text Drag and Drop, which lets you select a piece of text and move it to a different location within the text.
  • File Drag and Drop, for opening a file by dragging its file name from Windows Explorer to the word processor's window.

Text Drag and Drop is automatically supported by Text Control if the TextControl.AllowDrag and TextControl.AllowDrop properties have been set to true.

File Drag and Drop is fully supported, too, and can be fine-tuned to the requirements of your application in various ways, as described in the following chapter.

Next >>


File Drag and Drop

Three .NET events are involved when implementing File Drag and Drop:

  • DragEnter: Occurs when an object is dragged into the drop target's bounds. At this point, the application checks if it can accept the file.
  • DragOver: Occurs when the mouse is moved while over the drop target. Here, the mouse pointer is changed to inform the user if the file can be dropped.
  • DragDrop: Occurs when the user releases the mouse button over the drop target. The file is then loaded.

If you drop a file on the text window, these events will occur in TX Text Control. However, if the file is dropped outside of TX Text Control's bounds, e.g. on the application's toolbar, the events will occur in the application's form. This offers the opportunity to provide different actions, depending on where exactly a file is dropped. Microsoft Word 2007(R), for instance, will load a file that is dropped onto its toolbars, but not if dropped onto the text area.


Handling Drag and Drop Events

The following code shows you how Drag and Drop is implemented in this sample program and in the Text Control Words demo application. It allows files to be dropped on all parts of the application, including the text area. The code has been encapsulated in a class named DragDropHandler for easy re-use in your programs.

First, you need to instantiate the class:

[C#]
FileDragDropHandler fileDragDrop = new FileDragDropHandler();
[Visual Basic]
Dim FileDragDrop As New FileDragDropHandler

After that, you can use the form's and the control's events to handle files that will be dropped on the form or control. These are the TX Text Control events which have to be handled with the help of the DragDropHandler class. The form's events are handled the same way.

[C#]
private void textControl1_DragDrop(object sender, DragEventArgs e)
{
  loadFile(fileDragDrop.FileName, fileDragDrop.StreamType);
}

private void textControl1_DragEnter(object sender, DragEventArgs e)
{
  fileDragDrop.Reset();
  fileDragDrop.CheckDraggedFiles((string[])e.Data.GetData(DataFormats.FileDrop));
}

private void textControl1_DragOver(object sender, DragEventArgs e)
{
  if (fileDragDrop.CanDrop == true)
    e.Effect = fileDragDrop.GetDragDropEffect(e.AllowedEffect, e.KeyState);
}
[Visual Basic]
Private Sub TextControl1_DragDrop(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) _
Handles TextControl1.DragDrop
  LoadFile(FileDragDrop.FileName, FileDragDrop.StreamType)
End Sub

Private Sub TextControl1_DragEnter(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) _
Handles TextControl1.DragEnter
  FileDragDrop.Reset()
  FileDragDrop.CheckDraggedFiles(CType(e.Data.GetData(DataFormats.FileDrop), String()))
End Sub

Private Sub TextControl1_DragOver(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) _
Handles TextControl1.DragOver
  If FileDragDrop.CanDrop = True Then
    e.Effect = FileDragDrop.GetDragDropEffect(e.AllowedEffect, e.KeyState)
  End If
End Sub

In the DragEnter event, the file extension will be checked against the supported file types.

If the dragged file is supported, the CanDrop property returns true, which can be used to decide if the DragDrop will be allowed. As you can see, the GetDragDropEffect function returns a DragDropEffects type value based on the current Keystate, which can easily be used to control the desired cursor.

Finally, the DragDrop event is fired and the dropped file is loaded.

<< Previous


Howto: Implement Spreadsheet Functionality

This chapter describes how to add spreadsheet-like functionality to the TX Text Control tables.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Spreadsheet
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Spreadsheet

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar

Relevant API links:

  • TextControl.Tables
  • TableCell
  • TableCell.Name

Creating a spreadsheet interface using tables

Adding formulas to table cells


Creating a spreadsheet interface using tables

Tables can be used for many different applications. Whether tables are used to align text on a page, to structure data or to do some calculations - TX Text Control gives you a powerful set of table functionality to fulfill these requirements.

This sample consists of a TextControl in which a table that is used as a spreadsheet:

The first row and the first column of the spreadsheet table is used to display the cell names and therefore they are protected and can't be modified by the user. If the input position is inside one of these title cells, the TextControl.EditMode property is used to prevent the user from changing these cells:

[C#]
TXTextControl.TableCell cell = _activeTable.Cells.GetItem();

if ((cell.Column == 1) || (cell.Row == 1))
    textControl.EditMode = EditMode.ReadAndSelect;
else
    textControl.EditMode = EditMode.Edit;
[Visual Basic]
Dim cell As TXTextControl.TableCell = _activeTable.Cells.GetItem()

If (cell.Column = 1) OrElse (cell.Row = 1) Then
    TextControl1.EditMode = EditMode.ReadAndSelect
Else
    TextControl1.EditMode = EditMode.Edit
End If


Adding formulas to table cells

A core functionality of spreadsheets is the possibility to add functionality to a cell. This enables users to add a specific formula to a cell. The value of this cell is calculated based on this formula and the values of other referenced cells. In this sample, a basic sum function is implemented.

Each TableCell has text that is displayed and additional data that is stored in the TableCell.Name property.

Type in numeric values into cell B1 and B2. Now, select cell B3 and click on the Sum button.

A sum function is inserted automatically that totalizes the values of the above cells.

An identifier and the specific formula with the connected cells are stored in the TableCell.Name property:

[C#]
private const string FormulaIdentifier = "_tx_formula_";

private void CreateSumFormula(TXTextControl.TableCell tableCell)
{
    tableCell.Text = string.Empty;
    tableCell.Name
        = FormulaIdentifier + ",sum,2,"             // Identifier string, formula type ("sum") and first row (2)
        + (tableCell.Row - 1).ToString() + ","      // Last row
        + tableCell.Column.ToString();              // Column

    UpdateSumCells();
}
[Visual Basic]
Private Const FormulaIdentifier As String = "_tx_formula_"

Private Sub CreateSumFormula(ByVal tableCell As TXTextControl.TableCell)
    tableCell.Text = String.Empty
    ' Identifier string, formula type ("sum") and first row (2)
    ' Last row
    tableCell.Name = FormulaIdentifier & ",sum,2," & (tableCell.Row - 1).ToString() & "," & tableCell.Column.ToString()
    ' Column
    UpdateSumCells()
End Sub

On updating the results, the UpdateSumCells method loops through all cells looking for stored formulas. If a formula is found, the sum of the cells, which are part of the cell range defined in the formula is calculated and used as the TableCell.Text of this cell.

[C#]
private void UpdateSumCells(TXTextControl.Table table)
{
    foreach (TXTextControl.TableCell cell in table.Cells)
    {
        if (!cell.Name.StartsWith(FormulaIdentifier)) continue;

        string[] splitValues = cell.Name.Split(',');
        if ((splitValues.Length < 5) || (splitValues[1] != "sum")) continue;

        int sum = 0, column = Convert.ToInt32(splitValues[4]);

        for (int row = Convert.ToInt32(splitValues[2]); row <= Convert.ToInt32(splitValues[3]); row++)
        {
            int number;
            Int32.TryParse(textControl.Tables.GetItem().Cells.GetItem(row, column).Text, out number);

            sum += number;
        }

        cell.Text = sum.ToString();
    }
}
[Visual Basic]
Private Sub UpdateSumCells(ByVal table As TXTextControl.Table)
    For Each cell As TXTextControl.TableCell In table.Cells
        If Not cell.Name.StartsWith(FormulaIdentifier) Then
            Continue For
        End If

        Dim splitValues As String() = cell.Name.Split(","c)
        If (splitValues.Length < 5) OrElse (splitValues(1) <> "sum") Then
            Continue For
        End If

        Dim sum As Integer = 0, column As Integer = Convert.ToInt32(splitValues(4))

        For row As Integer = Convert.ToInt32(splitValues(2)) To Convert.ToInt32(splitValues(3))
            Dim number As Integer
            Int32.TryParse(TextControl1.Tables.GetItem().Cells.GetItem(row, column).Text, number)

            sum += number
        Next

        cell.Text = sum.ToString()
    Next
End Sub


Howto: Add charting support to your applications

This chapter describes how to add charting functionality to TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Charts\
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Charts\

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.StatusBar
  • TXTextControl.RulerBar

Relevant API links:

  • DataVisualization.ChartFrame

Creating a template that contains chart objects

Merging the chart objects with data


Creating a template that contains chart objects

This first step shows how to insert chart objects into a document. Like TextFields, a ChartFrame has a unique name or ID that can be used to identify the chart object.

Choose Chart from the Insert main menu in order to add a chart object to your document. It is filled with default values to visualize formatting and style changes you may apply.

In the right panel, you can change the name of the ChartFrame that should match the DataTable name in step 2 of this sample series. Use the PropertyGrid to make changes to the chart object. These changes are maintained when saving the template.

The following code is used to insert the chart object:

[C#]
Chart chart = new Chart();
chart.Series.Add("series1");
chart.ChartAreas.Add("area1");

chart.DataSource = dt;

// set series members names for the X and Y values
chart.Series[0].XValueMember = "Country";
chart.Series[0].YValueMembers = "Value";

// data bind to the selected data source
chart.DataBind();

// create new ChartFrame and add it to TX Text Control
ChartFrame chartFrame = new ChartFrame(chart);
chartFrame.Name = "points";
chartNameID++;

textControl1.Charts.Add(chartFrame, -1);
[Visual Basic]
Dim chart As New Chart
chart.Series.Add("series1")
chart.ChartAreas.Add("area1")

chart.DataSource = dt

' set series members names for the X and Y values
chart.Series(0).XValueMember = "Country"
chart.Series(0).YValueMembers = "Value"

' data bind to the selected data source
chart.DataBind()

' create new ChartFrame and add it to TX Text Control
Dim chartFrame As New ChartFrame(chart)
chartFrame.Name = "points"
chartNameID += 1

textControl1.Charts.Add(chartFrame, -1)


Merging the chart objects with data

This second step shows how to merge the pre-defined chart objects with data from an XML data source. In the first step, a chart placeholder with a unique name has been added to the document. To merge the chart objects, the ChartCollection can be used to iterate through all charts in order to merge them with data.

Choose Load... from the File main menu and select the template created in step 1. Now, click Merge from the Charts main menu to start the merge process.

In the background, the XML data file is loaded into a DataSet. If the DataSet contains a DataTable with the name of the inserted ChartFrame, the new data is applied to the chart object:

[C#]
// create a new DataSet and load the XML data
DataSet ds = new DataSet();
ds.ReadXml("data.xml");

foreach (ChartFrame chartFrame in textControl1.Charts)
{
    // check whether the DataSet contains data
    // related to the chart name
    if (ds.Tables.Contains(chartFrame.Name) == false)
        continue;

    Chart chart = chartFrame.Chart as Chart;

    // set the x and y values to the first 2 columns of the DataTable
    chart.Series[0].XValueMember = ds.Tables[chartFrame.Name].Columns[0].ColumnName;
    chart.Series[0].YValueMembers = ds.Tables[chartFrame.Name].Columns[1].ColumnName;

    // set the data to the chart
    chart.DataSource = ds.Tables[chartFrame.Name];

    // data bind to the selected data source
    chart.DataBind();
}
[Visual Basic]
' create a new DataSet and load the XML data
Dim ds As New DataSet()
ds.ReadXml("data.xml")

For Each chartFrame As TXTextControl.ChartFrame In textControl1.Charts
    ' check whether the DataSet contains data
    ' related to the chart name
    If ds.Tables.Contains(chartFrame.Name) = False Then
        Continue For
    End If

    Dim chart As DataVisualization.Charting.Chart = TryCast(chartFrame.Chart, DataVisualization.Charting.Chart)

    ' set the x and y values to the first 2 columns of the DataTable
    chart.Series(0).XValueMember = ds.Tables(chartFrame.Name).Columns(0).ColumnName
    chart.Series(0).YValueMembers = ds.Tables(chartFrame.Name).Columns(1).ColumnName

    ' set the data to the chart
    chart.DataSource = ds.Tables(chartFrame.Name)

    ' data bind to the selected data source
    chart.DataBind()
Next


Howto: Add drawings and shapes to your application

This chapter describes how to add drawings functionality to TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\VB.NET\Shapes\
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WinForms\CSharp\Shapes\

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar
  • TXTextControl.StatusBar
  • TXTextControl.RulerBar
  • TXDrawing.TXDrawingControl

Relevant API links:

  • DataVisualization.DrawingFrame

Inserting drawings as single objects

Inserting a drawings canvas


Inserting drawings as single objects

TX Text Control provides two different ways to insert a drawing object into a document: As a single object or multiple shapes in a drawing canvas. In the sample application, when choosing a shape type from the main menu Insert -> Shapes, the object is inserted as a single object:

In the following code, a DataVisualization.DrawingFrame object is created which hosts the Drawing.TXDrawingControl object. The DataVisualization.DrawingFrame object is added to the TextControl.Drawings collection of TextControl. Finally, a new Drawing.Shape object is added to the Drawing.TXDrawingControl object:

[C#]
TXTextControl.Drawing.TXDrawingControl drawingObject =
    new TXTextControl.Drawing.TXDrawingControl(5000, 5000);

// create a new DrawingFrame object that hosts the TXDrawingControl
TXTextControl.DataVisualization.DrawingFrame drawingFrame =
    new TXTextControl.DataVisualization.DrawingFrame(drawingObject);

// add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame,
    new Point(0,0),
    -1,
    TXTextControl.FrameInsertionMode.DisplaceText);

TXTextControl.Drawing.Shape newShape = new TXTextControl.Drawing.Shape(
    (ShapeType)Enum.Parse(typeof(ShapeType),
    ((ToolStripMenuItem)sender).Text));

newShape.AutoSize = true;
newShape.Sizable = false;
newShape.Movable = false;

// add shape directly to TextControl
drawingObject.Shapes.Add(newShape, ShapeCollection.AddStyle.Fill);
textControl1.Refresh();
[Visual Basic]
Dim drawingObject As New TXTextControl.Drawing.TXDrawingControl(5000, 5000)

' create a new DrawingFrame object that hosts the TXDrawingControl
Dim drawingFrame As New TXTextControl.DataVisualization.DrawingFrame(drawingObject)

' add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, New Point(0, 0), -1, TXTextControl.FrameInsertionMode.DisplaceText)

Dim newShape As New TXTextControl.Drawing.Shape(DirectCast([Enum].Parse(GetType(ShapeType), DirectCast(sender, ToolStripMenuItem).Text), ShapeType))

newShape.AutoSize = True
newShape.Sizable = False
newShape.Movable = False

' add shape directly to TextControl
drawingObject.Shapes.Add(newShape, ShapeCollection.AddStyle.Fill)
textControl1.Refresh()


Inserting a drawings canvas

The second approach to insert shape objects into TX Text Control is a drawing canvas. This canvas is a DataVisualization.DrawingFrame object that hosts the Drawing.TXDrawingControl object, but the inserted shapes don't necessarily fit the complete frame.

The following code inserts the drawing canvas that fits exactly the page width without page margins:

[C#]
// calculate the available page width
textControl1.PageUnit = TXTextControl.MeasuringUnit.Twips;
int iPageWidth = (int)(textControl1.Sections.GetItem().Format.PageSize.Width -
    textControl1.Sections.GetItem().Format.PageMargins.Left -
    textControl1.Sections.GetItem().Format.PageMargins.Right);

// create a new TXDrawingControl that fills the complete page width
TXTextControl.Drawing.TXDrawingControl drawingObject =
    new TXTextControl.Drawing.TXDrawingControl(iPageWidth, 5000);

// create a new DrawingFrame object that hosts the TXDrawingControl
TXTextControl.DataVisualization.DrawingFrame drawingFrame =
    new TXTextControl.DataVisualization.DrawingFrame(drawingObject);

// add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, -1);
drawingFrame.Activate();
[Visual Basic]
' calculate the available page width
textControl1.PageUnit = TXTextControl.MeasuringUnit.Twips
Dim iPageWidth As Integer = CInt(textControl1.Sections.GetItem().Format.PageSize.Width -
    textControl1.Sections.GetItem().Format.PageMargins.Left -
textControl1.Sections.GetItem().Format.PageMargins.Right)

' create a new TXDrawingControl that fills the complete page width
Dim drawingObject As New TXTextControl.Drawing.TXDrawingControl(iPageWidth, 5000)

' create a new DrawingFrame object that hosts the TXDrawingControl
Dim drawingFrame As New TXTextControl.DataVisualization.DrawingFrame(drawingObject)

' add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, -1)
drawingFrame.Activate()

When clicking a shape name in the main menu Insert -> Shapes while the drawing canvas is active, the mouse can be used to draw the shape on the activated drawing canvas.

[C#]
// create new Shape object from selected menu item text string
TXTextControl.Drawing.Shape newShape = new TXTextControl.Drawing.Shape(
    (ShapeType)Enum.Parse(typeof(ShapeType),
    ((ToolStripMenuItem)sender).Text));

// add Shape object to drawing canvas
((TXTextControl.Drawing.TXDrawingControl)
 textControl1.Drawings.GetActivatedItem().Drawing)
    .Shapes.Add(newShape, ShapeCollection.AddStyle.MouseCreation);
[Visual Basic]
' create new Shape object from selected menu item text string
Dim newShape As New TXTextControl.Drawing.Shape(DirectCast([Enum].Parse(GetType(ShapeType),
    DirectCast(sender, ToolStripMenuItem).Text), ShapeType))

' add Shape object to drawing canvas
DirectCast(textControl1.Drawings.GetActivatedItem().Drawing,
    TXTextControl.Drawing.TXDrawingControl).Shapes.Add(newShape, ShapeCollection.AddStyle.MouseCreation)


Link: Online Source Code Library

An entire library of source code with ample documentation that illustrates how to use TX Text Control in your own applications.

TX Text Control Source Code Library


Link: Support FAQ

Answers to commonly asked questions about the TX Text Control Support Department.

TX Text Control Support Department FAQs


Windows Presentation Foundation User's Guide

This guide describes how to create TX Text Control WPF applications (.exe) and TX Text Control WPF browser applications (.xbap) which run in Microsoft Internet Explorer. All examples are available either for Microsoft Visual Basic .NET or Microsoft Visual C# .NET. To run these examples you have to install TXTextControl .NET for WPF.

Tutorial: Starting with Microsoft Visual Studio

Tutorial: Create a Ribbon Application

Howto: Work With Files

Howto: Print

Howto: Use Text Fields

Howto: Connect to Databases

Howto: Edit and Format Text From Code

Howto: Mail Merge

Howto: Use Hypertext Links

Howto: Use XML Files

Howto: Use Text Frames

Howto: Drag and Drop Files

Howto: Implement Spreadsheet Functionality

Howto: Create a simple WPF Browser Application (XBAP)

Howto: Load a document from the server in an XBAP browser application

Howto: Add drawings and shapes to your application

Link: Online Source Code Library

Link: Support FAQ


Tutorial: Starting with Microsoft Visual Studio

This chapter shows you how to create a small word processor from scratch with just a few lines of code. It will be able to load and save files, use the clipboard and will have dialog boxes for character and paragraph formatting, a ruler, a status bar and full keyboard and mouse interface.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Simple
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Simple

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.load
  • WPF.TextControl.Save
  • WPF.TextControl.Cut
  • WPF.TextControl.Copy
  • WPF.TextControl.Paste

1. Creating the Project

2. Adding a Menu Bar


1. Creating the Project

Assuming that you have already run the TX Text Control installation program, start Visual Studio .NET and create a new project. Select either Visual Basic or Visual C# as the project type and WPF Application as the template.

In the XAML view, replace the Grid with a DockPanel control as shown in the below screenshot:

In the next steps, the order in the controls are added to the Window is important.

Double-click the ButtonBar in the toolbox to add it to the Window. Repeat this for the RulerBar, StatusBar, a second RulerBar and finally TextControl. The XAML should look like this:

Visual Studio 2008 users: In the XAML, remove the Height and the Width properties for all added elements.

Select the secondly added Ruler Bar rulerBar2 using the mouse in the Design view to change the properties in the Properties window. Browse for the DockPanel.Dock property and change it to Left.

Additionally, set the HorizontalAlignment to Left and the VerticalAlignment to Stretch. The Design view should look like this:

Now, the controls must be connected. Therefore, select textControl1 to open it's properties in the Properties window of Visual Studio. First, look for the ButtonBar property and type in the name of the added Button Bar: buttonBar1.

Set the RulerBar property to rulerBar1, StatusBar to statusBar1 and VerticalRulerBar to rulerBar2.

In the XAML, add the Loaded="textControl1_Loaded" event handler to the TextControl element as a parameter, so that the line looks like this:

<my:TextControl Name="textControl1" Loaded="textControl1_Loaded"
    ButtonBar="buttonBar1" StatusBar="statusBar1" RulerBar="rulerBar1" VerticalRulerBar="rulerBar2"/>

Now, right-click on textControl1_Loaded and choose Navigate to Event Handler from the opened context menu. Add the following code to the event handler:

[C#]
private void textControl1_Loaded(object sender, RoutedEventArgs e)
{
 textControl1.Focus();
}
[Visual Basic]
private void textControl1_Loaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Focus
}

Now, press F5 to compile and start the application:

Continue with the next step and learn how to add a menu to your application.


2. Adding a Menu Bar

The last step is to add a menu strip to the Window. Switch back to the Design/XAML view. In the toolbox, look for the Menu control in the Controls category and double-click the icon to insert it to the current Window. In the Properties window, change the DockPanel.Dock property to Top.

In the XAML, re-arrange the elements, so that the menu is the first element in the DockPanel and remove the Width and Height properties:

Instead of adding the menu entries using the Properties window, the entries are added in the XAML directly which is much faster. Replace the menu element with the following XAML code:

<Menu Name="menu1" DockPanel.Dock="Top">
 <MenuItem Header="_File">
  <MenuItem Header="Load..." Click="MenuItemLoad_Click" />
  <MenuItem Header="Save..." Click="MenuItemSave_Click" />
  <Separator />
  <MenuItem Header="Exit" Click="MenuItemExit_Click" />
 </MenuItem>
 <MenuItem Header="_Edit">
  <MenuItem Header="Cut" Click="MenuItemCut_Click" />
  <MenuItem Header="Copy" Click="MenuItemCopy_Click" />
  <MenuItem Header="Paste" Click="MenuItemPaste_Click" />
 </MenuItem>
 <MenuItem Header="_Format">
  <MenuItem Header="Character..." Click="MenuItemCharacter_Click" />
  <MenuItem Header="Paragraph..." Click="MenuItemParagraph_Click" />
 </MenuItem>
</Menu>

In the first XAML menu element Load..., right-click MenuItemLoad_Click and choose Navigate to Event Handler from the opened context menu. This opens the code view of the Window.

Add the following code, so that the complete method looks like this:

[C#]
private void MenuItemLoad_Click(object sender, RoutedEventArgs e)
{
 textControl1.Load();
}
[Visual Basic]
Private Sub MenuItemLoad_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
 TextControl1.Load
End Sub

Repeat this step for all menu items and add the following code to the code view:

[C#]
private void MenuItemSave_Click(object sender, RoutedEventArgs e)
{
 textControl1.Save();
}

private void MenuItemExit_Click(object sender, RoutedEventArgs e)
{
 this.Close();
}

private void MenuItemCut_Click(object sender, RoutedEventArgs e)
{
 textControl1.Cut();
}

private void MenuItemCopy_Click(object sender, RoutedEventArgs e)
{
 textControl1.Copy();
}

private void MenuItemPaste_Click(object sender, RoutedEventArgs e)
{
 textControl1.Paste();
}

private void MenuItemCharacter_Click(object sender, RoutedEventArgs e)
{
 textControl1.FontDialog();
}

private void MenuItemParagraph_Click(object sender, RoutedEventArgs e)
{
 textControl1.ParagraphFormatDialog();
}
[Visual Basic]
Private Sub MenuItemSave_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Save
}

Private Sub MenuItemExit_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 Me.Close
}

Private Sub MenuItemCut_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Cut
}

Private Sub MenuItemCopy_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Copy
}

Private Sub MenuItemPaste_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Paste
}

Private Sub MenuItemCharacter_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.FontDialog
}

Private Sub MenuItemParagraph_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.ParagraphFormatDialog
}

Press F5 to start the project.


Tutorial: Create a Ribbon Application

This chapter shows you how to create a small word processor with a ribbon interface from scratch with just a few lines of code. It uses the shipped, ready-to-use ribbon tabs that are connected to a System.Windows.Controls.Ribbon.Ribbon object.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Ribbon
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Ribbon

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.RibbonFormattingTab
  • TXTextControl.WPF.RibbonInsertTab
  • TXTextControl.WPF.StatusBar
  • TXTextControl.WPF.RulerBar

Prerequisites

1. Creating the Project


Prerequisites

The ready-to-use ribbon tabs are compatible to the Microsoft Ribbon for WPF 3.5 ribbon object. In order to create this tutorial, you will need to download and install this package:

http://www.microsoft.com/en-us/download/details.aspx?id=11877

Follow the instructions of the downloaded installer.


1. Creating the Project

Assuming that you have already run the TX Text Control installation program, start Visual Studio .NET and create a new project. Select either Visual Basic or Visual C# as the project type and WPF Application as the template.

1. In the XAML view, replace the Grid with a DockPanel control as shown in the below screenshot:

2. Click Choose Toolbox Items... from the Tools main menu to customize the toolbox. In the tab WPF Components, filter for Ribbon and find the Ribbon from the assembly RibbonControlsLibrary. Select the control and confirm with OK.

3. Find the recently added control Ribbon, drag and drop it into the DockPanel.

4. Find the controls RibbonFormattingTab and RibbonInsertTab in the toolbox group TX Text Control 24.0, drag and drop them into the created Ribbon tag. Add a name parameter to both controls and name them ribbonFormattingTab and ribbonInsertTab. Additionally, set the Header parameter to Home and Insert. The XAML should look like this now:

5. In the next steps, the order in the controls are added to the Window is important.

Double-click the RulerBar in the toolbox to add it to the Window. Repeat this for the StatusBar, a second RulerBar and finally TextControl. Set the DockPanel.Dock property of the first RulerBar to top, set Bottom for the StatusBar, Left for the second RulerBar and finally Top for TextControl. Make sure that all other automatically created parameters such as Width, Height or Margin is removed from the tags.

For the secondly added RulerBar, set the HorizontalAlignment to Left and the VerticalAlignment to Stretch.

Now, add a Name for each control according to the following screenshot:

6. In this step, the controls must be connected. Therefore, select textControl to open it's properties in the Properties window of Visual Studio. First, look for the RulerBar property and type in the name of the added RulerBar: rulerBar.

7. Set the StatusBar property to statusBar and VerticalRulerBar to verticalRulerBar.

8. Now, the ribbon tabs must be connected. Find the RibbonFormattingTab property and set it to ribbonFormattingTab, the name of the insert ribbon tab control. Repeat this step for the RibbonInsertTab and set it to ribbonInsertTab.

The design view of the Window should now look like in the following screenshot:

9. In the XAML, add the Loaded="textControl_Loaded" event handler to the textControl element as a parameter, so that the line looks like this:

<WPF:TextControl DockPanel.Dock="Top" Name="textControl" Loaded="textControl_Loaded" RulerBar="rulerBar" StatusBar="statusBar"
    VerticalRulerBar="verticalRulerBar" RibbonFormattingTab="ribbonFormattingTab" RibbonInsertTab="ribbonInsertTab"/>

Now, in the XAML right-click on textControl_Loaded and choose Go To Definition from the opened context menu. Add the following code to the event handler:

[C#]
private void textControl_Loaded(object sender, RoutedEventArgs e)
{
 textControl.Focus();
}
[Visual Basic]
private void textControl_Loaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl.Focus
}

Now, press F5 to compile and start the application.


Howto: Work With Files

This chapter shows you how to load and save files with TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Files
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Files

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl

Relevant API links:

  • WPF.TextControl.Load
  • WPF.TextControl.Save

Using the Built-in Dialog Boxes

Restricting File Formats

Displaying The File Name

Save and Save As...

Export to PDF and CSS


Using the Built-in Dialog Boxes

The easiest way to load and save files with Text Control is to use the Load and Save methods without a parameter, as shown in Creating a simple WPF Application with Visual Studio .NET. This way, only a single line of code is required to open a file dialog box, fill its Files of type: combo box with supported file formats, and finally load and display a file the user has selected:

You may have noticed, though, that Load and Save actually consist of 11 overloaded functions each, and thus enable you to customize TX Text Control's file handling for various types of application. You can, for instance, load data from a string instead of a file, or provide your own customized dialog box. The next sections shows you some of the options available.

Next >>


Restricting File Formats

By default, the Load and Save methods will display all file formats Text Control supports. If you wish to support a subset of these formats, or if you have a version of Text Control that does not support all of the formats, you can specify the formats to be displayed as a parameter. Several members of Text Control's StreamType enumeration can be combined to, for instance, only support HTML and RTF:

[C#]
private void mnuFile_OpenFile_Click(object sender,
    System.EventArgs e)
{
    textControl1.Load(TXTextControl.StreamType.HTMLFormat |
                        TXTextControl.StreamType.RichTextFormat);
}
[Visual Basic]
Private Sub mnuFile_OpenFile_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_OpenFile.Click
    TextControl1.Load(TXTextControl.StreamType.HTMLFormat + _
                        TXTextControl.StreamType.RichTextFormat)
End Sub


Displaying The File Name

It is convenient for the user to have the name of the file he or she is currently working with displayed as a window caption. One would normally use the FileName property of the file dialog box for this, but, as the dialog box is called from within Text Control, this option is not available.

This code sample shows how get the filename by creating and passing a LoadSettings object as a parameter to the Load method.

[C#]
private void mnuFile_OpenFile_Click(object sender, System.EventArgs e)
{
    TXTextControl.LoadSettings LoadSettings = new TXTextControl.LoadSettings();
    textControl1.Load(TXTextControl.StreamType.All, LoadSettings);
    this.Title = LoadSettings.LoadedFile;
}
[Visual Basic]
Private Sub mnuFile_OpenFile_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_OpenFile.Click
    Dim LoadSettings As New TXTextControl.LoadSettings()
    TextControl1.Load(TXTextControl.StreamType.All, LoadSettings)
    Me.Title = LoadSettings.LoadedFile
End Sub


Save and Save As...

Word processing programs typically have seperate menu items for Save... and Save As.. operations. Unless a file has been created from scratch, it can be saved with its previously assigned filename and type by just hitting Save, and without a dialog box.

The sample program maintains two variables called DocumentFileName and DocumentStreamType in which it stores the name and type of the current file. The information is updated when a file is loaded, and when it is stored under a different name.

When the user clicks Save, the file is stored using this information. A dialog box is only displayed if the file has been created from scratch, i.e. if it does not yet have a name.

[C#]
private void mnuFile_Save_Click(object sender, System.EventArgs e)
{
    TXTextControl.SaveSettings SaveSettings = new TXTextControl.SaveSettings();
    if (DocumentFileName != "" )
    {
        // save under same name and type
        textControl1.Save(DocumentFileName, DocumentStreamType);
    }
    else
    {
        // save as..
        textControl1.Save(TXTextControl.StreamType.All, SaveSettings);
        DocumentFileName = SaveSettings.SavedFile;
        DocumentStreamType = SaveSettings.SavedStreamType;
    }
}
[Visual Basic]
Private Sub mnuFile_Save_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Save.Click
    Dim SaveSettings As New TXTextControl.SaveSettings()
    If DocumentFileName <> "" Then
        ' save under same name and type
        TextControl1.Save(DocumentFileName, DocumentStreamType)
    Else
        ' save as..
        TextControl1.Save(TXTextControl.StreamType.All, SaveSettings)
        DocumentFileName = SaveSettings.SavedFile
        DocumentStreamType = SaveSettings.SavedStreamType
    End If
End Sub


Export to PDF and CSS

PDF and CSS formats require special attention, as they can be saved to, but not loaded from. The problem is that if you save a file as PDF, you cannot load it back in for further editing. CSS will not even save the text contained in a document, but only the formatting.

The best way to circumvent this is to create a seperate Export... menu item in addition to Save and Save As..., and keep the document in its original format when exporting it to a non-editable format. Note that, unlike Save As..., Export... does not change the file name and type.

[C#]
private void mnuFile_Export_Click(object sender, System.EventArgs e)
{
    textControl1.Save(TXTextControl.StreamType.AdobePDF);
}
[Visual Basic]
Private Sub mnuFile_Export_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Export.Click
    TextControl1.Save(TXTextControl.StreamType.AdobePDF)
End Sub

<< Previous


Howto: Print

This chapter shows you how to print with TX Text Control .NET for WPF.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Printing
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Printing

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.Print

Using The Built-In Print Dialog Box

Customizing The Print Dialog Box

Printing Without A Dialog Box


Using The Built-In Print Dialog Box

Sending a file to the printer in most cases only requires a single line of code. The TextControl.Print method will open a dialog box to let the user select a printer and all required options.

This code sample will open a print dialog box, and, if the user clicks OK, print the document:

[C#]
private void MenuItem_Click(object sender, RoutedEventArgs e)
{
    textControl1.Print("My Print Job");
}
[Visual Basic]
Private Sub MenuItem_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    TextControl1.Print("My Print Job")
End Sub


Customizing The Print Dialog Box

By default, the print dialog box will be displayed with default options, which is fine for most applications. Should you need to configure the print dialog, for instance to enable or disable options like AllowPrintToFile, ShowHelp, or ShowNetwork, you can use the WPF.TextControl.Print method with an application provided dialog box.

[C#]
private void MenuItem_Click_2(object sender, RoutedEventArgs e)
{
    PrintDialog pDialog = new PrintDialog();
    pDialog.PageRangeSelection = PageRangeSelection.AllPages;
    pDialog.UserPageRangeEnabled = true;

    Nullable<Boolean> print = pDialog.ShowDialog();
    PageRange prRange;

    prRange = pDialog.PageRangeSelection == PageRangeSelection.AllPages ?
        new PageRange(1, textControl1.Pages) :
        new PageRange(pDialog.PageRange.PageFrom, pDialog.PageRange.PageTo);

    if (print == true)
    {
        textControl1.Print(
        "My print job",
        pDialog.PrintQueue.Name,
        prRange,
        pDialog.PrintTicket.CopyCount.Value,
        pDialog.PrintTicket.Collation.Value);
     }
}
[Visual Basic]
Private Sub MenuItem_Click_2(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim pDialog As New PrintDialog()
    pDialog.PageRangeSelection = PageRangeSelection.AllPages
    pDialog.UserPageRangeEnabled = True

    Dim print As Nullable(Of [Boolean]) = pDialog.ShowDialog()

    Dim prRange As PageRange

    prRange = If(pDialog.PageRangeSelection = PageRangeSelection.AllPages, _
        New PageRange(1, textControl1.Pages), New PageRange(pDialog.PageRange.PageFrom, pDialog.PageRange.PageTo))

    If print = True Then
        textControl1.Print("My print job", pDialog.PrintQueue.Name, prRange, _
            pDialog.PrintTicket.CopyCount.Value, pDialog.PrintTicket.Collation.Value)
    End If
End Sub


Printing Without A Dialog Box

It is also possible to print a document without user interaction. This is done by assigning all required options to a PrintDocument object, and then passing it to the TextControl.Print method. This code sample will send page 1 of a document to the default printer:

[C#]
private void MenuItem_Click_3(object sender, RoutedEventArgs e)
{
    PageRange prRange = new PageRange(1,1);{
    textControl1.Print("My print job", prRange, 1, Collation.Uncollated);{
}
[Visual Basic]
Private Sub MenuItem_Click_3(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim prRange As New PageRange(1, 1)
    textControl1.Print("My print job", prRange, 1, Collation.Uncollated)
End Sub


Howto: Use Text Fields

Marked Text Fields are markers which are inserted in the text. They can be used to implement a wide range of special functions in a text processor. To name just a few:

  • Mail Merge functions
  • Spreadsheet-like calculation fields
  • Bookmarks
  • Automatic table of contents and index generation
  • Hypertext links and targets

Any group of characters within the text can be a marked text field. The maximum number of fields is 65,535. Text Control maintains the positions and numbers of the fields. It also takes care of loading, saving and clipboard operations.

Additional information about text fields can be found in the Technical Articles part in the chapter Text Fields and Hypertext Links.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\TextFields
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\TextFields

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.TextFields
  • WPF.TextControl.DocumentTargets
  • WPF.TextControl.DocumentLinks

A Simple Example

Bookmarks

Adding Strings to Text Fields

Importing and Exporting Fields from and to MS Word

Implementing a MERGEFIELD Class

Implementing a FORMTEXT Class

TX Quote Gemerator - An Advanced Example


A Simple Example

This first sample program will show you how fields are created and what happens when they are clicked on. The code shown here is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\TextFields\Fields1
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\TextFields\Fields1

The program consists of a form with just one menu item, Insert Field!, with an exclamation mark to say that clicking on this item will cause an immediate action instead of dropping a menu.

The following code is executed when the menu item is clicked on:

[C#]
private void MenuItem_Click(object sender, RoutedEventArgs e)
{
    TXTextControl.TextField NewField = new TXTextControl.TextField();

    // Insert a new field and increase field ID
    NewField.Text = "[TextField" + fieldID.ToString() + "]";
    NewField.ID = fieldID;
    NewField.DoubledInputPosition = true;
    fieldID += 1;

    textControl1.TextFields.Add(NewField);
}
[Visual Basic]
Private Sub MenuItem_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim NewField As New TXTextControl.TextField()

    ' Insert a new field and increase field ID
    NewField.Text = "[TextField" & fieldID.ToString() & "]"
    NewField.ID = fieldID
    NewField.DoubledInputPosition = True
    fieldID += 1

    textControl1.TextFields.Add(NewField)
End Sub

This inserts a field at the current caret position and assigns a unique number to the fields ID property. If you move the cursor over the field, Text Control changes the mouse pointer to a hand cursor to indicate that there is something to click on.

If you click on the field, the application receives a TextFieldClicked event, to which it responds by popping up a window which displays the field number.

Only two lines of code are required for this:

[C#]
private void textControl1_TextFieldClicked(object sender, TXTextControl.TextFieldEventArgs e)
{
    MessageBox.Show("Field " + fieldID.ToString() + " has been clicked.");
}
[Visual Basic]
Private Sub textControl1_TextFieldClicked(ByVal sender As Object, ByVal e As TXTextControl.TextFieldEventArgs)
    MessageBox.Show("Field " & fieldID.ToString() & " has been clicked.")
End Sub

Next >>


Bookmarks

This example shows you how to use text fields to create bookmarks. The first version will reference the bookmarks simply by their field numbers. The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\TextFields\Fields2
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\TextFields\Fields2

The sample application has a Bookmark menu with two items which are named Insert and Go to.... Clicking Insert creates a text field at the current caret position. If a text selection exists, the selected text is converted into a text field.

[C#]
private void MenuItem_Click_1(object sender, RoutedEventArgs e)
{
    if (textControl1.Text == "")
    {
        MessageBox.Show("Cannot insert a bookmark if the Text Control is empty.");
        return;
    }
    else if (textControl1.Selection.Length == 0)
    {
        textControl1.Selection.Length = 1;
    }

    // Now turn the selected text into a new field
    TXTextControl.TextField NewField = new TXTextControl.TextField();
    NewField.ID = fieldID;
    NewField.Text = textControl1.Selection.Text;
    textControl1.Selection.Text = "";
    fieldID += 1;
    textControl1.TextFields.Add(NewField);
    textControl1.Focus();
}
[Visual Basic]
Private Sub MenuItem_Click_1(ByVal sender As Object, ByVal e As RoutedEventArgs)
    If textControl1.Text = "" Then
        MessageBox.Show("Cannot insert a bookmark if the Text Control is empty.")
    ElseIf textControl1.Selection.Length = 0 Then
        textControl1.Selection.Length = 1
    Else
        ' Now turn the selected text into a new field
        Dim NewField As New TXTextControl.TextField()
        NewField.ID = fieldID
        NewField.Text = textControl1.Selection.Text
        textControl1.Selection.Text = ""
        fieldID += 1
        textControl1.TextFields.Add(NewField)
    End If
End Sub

After typing in some text and inserting a few bookmarks, select the Go To... menu item. This will launch a dialog box which allows you to enter the number of the bookmark to jump to.

Clicking the OK button executes the following procedure:

[C#]
private void button2_Click(object sender, RoutedEventArgs e)
{
    if (Convert.ToInt32(textBox1.Text) > tx.TextFields.Count)
    {
        MessageBox.Show("Invalid bookmark number!");
    }
    else
    {
        foreach (TXTextControl.TextField Field in tx.TextFields)
        {
            if (Field.ID == Convert.ToInt32(textBox1.Text))
            {
                tx.Selection.Start = Field.Start - 1;
                tx.Selection.Length = Field.Length;
            }
        }
    }
}
[Visual Basic]
Private Sub button2_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    If Convert.ToInt32(textBox1.Text) > tx.TextFields.Count Then
        MessageBox.Show("Invalid bookmark number!")
    Else
        For Each Field As TXTextControl.TextField In tx.TextFields
            If Field.ID = Convert.ToInt32(textBox1.Text) Then
                tx.Selection.Start = Field.Start - 1
                tx.Selection.Length = Field.Length
            End If
        Next
    End If
End Sub


Adding Strings to Text Fields

In commercial word processors, bookmarks are normally referenced by names, not just by numbers. The names are typed in by the user when he creates a bookmark. The Goto Bookmark dialog box then presents a listbox or combobox in which one of the strings can be selected.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\TextFields\Fields3
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\TextFields\Fields3

The Insert Bookmark... menu item in this version of the program creates a dialog box where the user can enter a label for the bookmark.

When the OK button is clicked, the following code is executed:

[C#]
private void btnOK_Click(object sender, RoutedEventArgs e)
{
    TXTextControl.TextField Field = new TXTextControl.TextField();

    Field.Name = tbFieldName.Text;
    Field.Text = tx.Selection.Text;
    tx.Selection.Text = "";

    if (!tx.TextFields.Add(Field))
        MessageBox.Show("Could not insert a bookmark. The cursor is probably inside a text field.");

    this.Close();
}
[Visual Basic]
Private Sub btnOK_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim Field As New TXTextControl.TextField()

    Field.Name = tbFieldName.Text
    Field.Text = tx.Selection.Text
    tx.Selection.Text = ""

    If Not tx.TextFields.Add(Field) Then
        MessageBox.Show("Could not insert a bookmark. The cursor is probably inside a text field.")
    End If

    Me.Close()
End Sub

First, a marked text field is created at the current caret position. Second, the name of the bookmark, which is the text that has been typed in by the user, is stored in the TextField.Name property.

The Goto Bookmark dialog box contains a combo box which lists all of the bookmarks which have been created so far.

The combo box is filled with the bookmark titles when its Window is loaded:

[C#]
private void Window_Loaded(object sender, RoutedEventArgs e)
{
    foreach (TXTextControl.TextField Field in tx.TextFields)
    {
        lbFields.Items.Add(Field.Name);
    }
}
[Visual Basic]
Private Sub Window_Loaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
    For Each Field As TXTextControl.TextField In tx.TextFields
        lbFields.Items.Add(Field.Name)
    Next
End Sub

When the OK button is clicked, the bookmark list is searched for the string which has been selected in the combo box, and the corresponding marked text field is selected.

[C#]
private void btnOK_Click(object sender, RoutedEventArgs e)
{
    foreach (TXTextControl.TextField Field in tx.TextFields)
    {
        if (Field.Name == lbFields.SelectedItem.ToString())
        {
            tx.Selection.Start = Field.Start - 1;
            tx.Selection.Length = Field.Length;
        }
    }

    this.Close();
}
[Visual Basic]
Private Sub btnOK_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    For Each Field As TXTextControl.TextField In tx.TextFields
        If Field.Name = lbFields.SelectedItem.ToString() Then
            tx.Selection.Start = Field.Start - 1
            tx.Selection.Length = Field.Length
        End If
    Next

    Me.Close()
End Sub


Importing and Exporting Fields from and to MS Word

TX Text Control imports and exports all fields that can be inserted into an MS Word document. As described in the technical article, the ApplicationField class provides a special interface to get and set the data and parameters of these fields.

The following two samples show how to use the two most common used fields of MS Word: MERGEFIELD and FORMTEXTBOX.

The source code for these samples is contained in the following directory:

  • Samples\WPF\VB.NET\ApplicationFields
  • Samples\WPF\CSharp\ApplicationFields

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar
  • TXTextControl.DocumentServer
  • TXTextControl.DocumentServer.Windows.Forms

Relevant API links:

  • WPF.TextControl.ApplicationFields
  • LoadSettings
  • DocumentServer.Fields.FieldAdapter


Implementing a MERGEFIELD Class

The MS Word MergeField is the most commonly used field in MS Word and RTF documents. It enables template designers to add additional information to a text field, such as a specific text that should be displayed before or after the field text or the format of the text.

To handle these fields and it's functionality, this sample uses the DocumentServer.Fields.FieldAdapter implemented in the TXTextControl.DocumentServer. These adapters can be used to modify the TextControl.ApplicationFields directly.

After starting the sample, click on File / Load to load a sample document, which contains several merge fields. Set the input position inside an exsiting field, for sample <<COMPANY>>.

Open the implemented merge field dialog by choosing Edit... from the MergeField main menu.

Using this dialog, it is possible to manipulate all properties of the MergeField instance. Add some text that should be inserted after the field by checking the checkbox Text to be inserted after. Type some text in the appropriate text box and close the dialog by clicking OK.

Open the customer list view form by clicking Merge fields... from the Merge menu entry. Choose a customer by clicking on a specific row and click Merge to merge all merge fields with the database content.

In this process, the ApplicationFieldCollection is used to loop through all inserted fields to replace the text. The following code shows this loop:

[C#]
DataRow drCustomer = m_customers.Tables[0].Rows[listBox1.SelectedIndex];

foreach (TXTextControl.ApplicationField curField in _tx.ApplicationFields)
{
    if (curField.TypeName != "MERGEFIELD")
        return;

    MergeField mfCurField = new MergeField(curField);

    if(drCustomer.Table.Columns.Contains(mfCurField.Name))
        mfCurField.Text = drCustomer[mfCurField.Name].ToString();
}
[Visual Basic]
Dim drCustomer As DataRow = m_customers.Tables(0).Rows(listBox1.SelectedIndex)

For Each curField As TXTextControl.ApplicationField In _tx.ApplicationFields
    If curField.TypeName <> "MERGEFIELD" Then
        Return
    End If

    Dim mfCurField As New MergeField(curField)

    If drCustomer.Table.Columns.Contains(mfCurField.Name) Then
        mfCurField.Text = drCustomer(mfCurField.Name).ToString()
    End If
Next


Implementing a FORMTEXT Class

The FormText field is used in MS Word to create fillable documents. In many applications, such documents are automated, so that these fields must be readable to be completed automatically. An ApplicationField object acts like a container for all settings (switches) of these fields.

This sample uses the DocumentServer.Fields.FormText field adapter to handle the ApplicationField. Everytime, an ApplicationField of type FORMTEXT should be edited, a new DocumentServer.Fields.FormText field is created:

[C#]
FormText curFormText = new FormText(textControl1.ApplicationFields.GetItem());
[Visual Basic]
Dim curFormText As New FormText(TextControl1.ApplicationFields.GetItem())

A reference to the ApplicationField is stored in the FormText instance. Similar to the first sample, this ApplicationField is used to get or set the parameters that are mapped to the properties of the new implemented FormText object.

A dialog box is implemented to change the properties of the specific form text field. The dialog represents the properties of the implemented FormText field:

After clicking OK, the specified values in the dialog box are set in the implemented FormText object which writes the parameters of the referenced ApplicationField automatically.


TX Quote Gemerator - An Advanced Example

This sample progam shows how to use Text Control in office applications. The main task of an office application typically is to create documents from information taken from a set of databases. For instance, a quote is generated from a record in an address database and one or more records in an article database.

The program is built up in two steps, starting very simple with only a single address database, and adding more features later on.

The source code for this example is contained in the subfolders Step1 and Step2 of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Quote Generator
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Quote Generator

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.TextFields
  • WPF.TextControl.Load

Step 1: Creating a Quote from a Database

When the program is started, it displays an address database in a list view control.

The database is a simple XML file, which is displayed with just a few lines of ADO code:

[C#]
dsAddress.ReadXml(@"..\..\..\address.xml");
dsArticle.ReadXml(@"..\..\..\article.xml");
lbCustomers.DataContext = dsAddress;
lbArticles.DataContext = dsArticle;

lbCustomers.SelectedIndex = 0;
[Visual Basic]
dsAddress.ReadXml(@"..\..\..\address.xml");
dsArticle.ReadXml(@"..\..\..\article.xml");
lbCustomers.DataContext = dsAddress;
lbArticles.DataContext = dsArticle;

lbCustomers.SelectedIndex = 0;

Selecting the File/New Quote menu item takes the current record from the database and creates a document from it. This is done in the following way:

A form containing a Text Control is opened, and a stylesheet is loaded. A stylesheet is a file that serves as a template for the final document. It contains all text parts which are equal to all documents, for instance a phrase like "In reply to your inquiry and according to our general terms of business we are pleased to..", and placeholders for information that is to be inserted from a database, like Address, Date, and so forth. It also defines the font, font size, company logo, and layout, so that all files will have the same look.

Once the stylesheet has been loaded, the placeholders are updated from the database, so that they now contain the real address, name, customer number, and date.

The stylesheet can be edited with the Advanced menu.

Step 2: Adding Articles with a Table

Before you read everything about how it is programmed, you may want to run it and see what it does, so here is a short user's guide first.

  • Start the program. You will see the main form, displaying some customer address records. Select one by clicking on it.
  • Select the File / New Quote menu item. A quote will be generated using the selected customer's name, address and customer number.
  • Click on the Insert / Article menu item. Select one of the articles displayed in the dialog box that pops up, and click OK. The product data will automatically be entered into the quote.
  • Enter the desired quantity. The total will be recalculated accordingly.
  • Repeat step 3 to enter more articles (clicking into an empty table row first). Delete the remaining empty lines by selecting them with the mouse and clicking Edit / Delete table rows.
  • Finished. Click File / Print to make a printout of the quote.

The first thing we need to do in order to add article descriptions and pricing to our quotes from Step 1 is to add another database. We call it the article database, and display it on the main form beside the address database.

That's it for the main form. On the editor form, we now add a menu item which lets us insert items from the article data into a quote.

A list of articles is best displayed in a table, and Text Control offers all required table functions to let us insert product IDs, descriptions, and prices into the respective cells, as well as to perform calculations. We therefore add a table to the style sheet and adjust its column widths, text distances, and caption text so that later only the plain text needs to be filled in.

This is what the style sheet now looks like:

A new menu item has been added to the Advanced menu, which allows to insert a table. Also, a Format/Table menu item has been created which calls Text Control's table attribute dialog box, so that we can adjust the table grid lines and background shading. The table's column widths and tabs are adjusted in the ruler bar. Note that the 2 rightmost columns have decimal tabs, so that the currency values they will contain will be properly aligned at the decimal sign.

We are now ready to fill in text from the article database into the table. Have a look at the sample program's ArticleTable class, which shows how to use the various table, row, columns and cell collections and objects.

After the user has selected a product in the article database, the program performs these steps:

  • It checks if the current input position is in a row of the article table, where a product can be inserted. If not, it uses the first row below the caption.
  • It inserts the selected product code, product description, and price.
  • Whenever Text Control sends a Changed event while the current input position was inside a table, the total is recalculated accordingly.

<< Previous


Howto: Connect to Databases

TX Text Control can be connected to any type of database, and store formatted text in any of its text formats. You can save a complete document as a record, or load text from a database into table cells and marked text fields. Typical applications which can be created are mail merge, report generators, formatted data entry masks, and all types of business applications where documents are created from information stored in a database.

This chapter shows you how to save the contents of a Text Control to a database. The data is stored as an RTF formatted string in a text field. For an advanced sample program which shows how to use databases with tables and marked text fields, please also refer to the TX Quote Generator sample program.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Database
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Database

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl

Relevant API links:

  • WPF.TextControl.Load
  • WPF.TextControl.Save

The Sample Program

Saving a Record

Retrieving a Record


The Sample Program

The sample program consists of a form with two Text Controls, both of which display the same record of a database. The upper control displays it as formatted text, whereas, for demonstration purposes, the lower control shows the record's RTF source code.

Clicking the Next button to save any changes you have made in the upper window, and advance to the next record.

Next >>


Saving a Record

All data access is handled by two methods, which are Load and Save. The Save method stores formatted text to a string, which is then passed on to the database engine using Visual Studio's ADO functions.

[C#]
private void PutRecord()
{
    string sRTFData;

    textControl1.Save(out sRTFData, TXTextControl.StringStreamType.RichTextFormat);
    dsRTFData.Tables[0].Rows[iCurrentRow][0] = sRTFData;
}
[Visual Basic]
Private Sub PutRecord()
    Dim sRTFData As String = String.Empty

    textControl1.Save(sRTFData, TXTextControl.StringStreamType.RichTextFormat)
    dsRTFData.Tables(0).Rows(iCurrentRow)(0) = sRTFData
End Sub

Other text formats can be used by simply changing the second parameter of the Save method.


Retrieving a Record

The TextControl.Load method is used to display RTF formatted text in Text Control 1. As Text Control 2 just displays the RTF source code without any formatting, we can simply use the Text property to load it.

[C#]
private void GetRecord()
{
    string sRTFData = dsRTFData.Tables[0].Rows[iCurrentRow].ItemArray[0].ToString();

    textControl1.Load(sRTFData, TXTextControl.StringStreamType.RichTextFormat);
    SetButtonState();
}
[Visual Basic]
Private Sub GetRecord()
    Dim sRTFData As String = dsRTFData.Tables(0).Rows(iCurrentRow).ItemArray(0).ToString()

    textControl1.Load(sRTFData, TXTextControl.StringStreamType.RichTextFormat)
    SetButtonState()
End Sub

The text format used in this example is RTF, which has the advantage of being accessible by most word processing programs. If this is not an issue, Text Control's binary format may be a better choice, as it is more compact and will take up less space in a database.

<< Previous


Howto: Edit and Format Text From Code

There are various applications which require text to be edited from program code. Report generators assemble documents from various smaller files and database fields. Web shops create order confirmations and send them out as HTML. Using TX Text Control, anything that can be done using the mouse and clicking menu items, can also be done from program code. The following chapters discuss some of the techniques involved.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Editing from code
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Editing from code

Used TX Text Control controls:

  • TXTextControl.TextControl

Relevant API links:

  • WPF.TextControl.Selection
  • WPF.TextControl.Find
  • WPF.TextControl.Load
  • WPF.TextControl.InputPosition

Selecting and Formatting Text

Find and Replace

Appending and Inserting Text Files

Moving to a Page, Line or Column


Selecting and Formatting Text

Text editing from code works similar to using mouse and menus. To change a word to bold, you would normally select it with the mouse, and then click on the Bold button. From code, you use a Text Control's Selection object to 'highlight' a word, and then set the Selection.Bold property.

[C#]
textControl1.Text = "TX Text Control";
textControl1.Selection.Start = 3;
textControl1.Selection.Length = 4;
textControl1.Selection.Bold = true;
[Visual Basic]
TextControl1.Text = "TX Text Control"
TextControl1.Selection.Start = 3
TextControl1.Selection.Length = 4
TextControl1.Selection.Bold = True

Next >>


Appending and Inserting Text Files

The first thing required in order to insert a file into your document is to specify the location where it is to be inserted. This is done using the Selection.Start property. Having set the input position to the desired location, the Selection.Load method can be used to insert a file, string or image. In this sample, first an RTF file is loaded, and then a HTML file is appended to its end.

[C#]
textControl1.Load ("..\\..\\TestFiles\\Caption.rtf",
    TXTextControl.StreamType.RichTextFormat);
textControl1.Selection.Start = textControl1.Text.Length;
textControl1.Selection.Load ("..\\..\\TestFiles\\Net.htm",
TXTextControl.StreamType.HTMLFormat);
[Visual Basic]
TextControl1.Load("..\TestFiles\Caption.rtf", _
    TXTextControl.StreamType.RichTextFormat)
TextControl1.Selection.Start = TextControl1.Text.Length
TextControl1.Selection.Load("..\TestFiles\Net.htm", _
TXTextControl.StreamType.HTMLFormat)


Moving to a Page, Line or Column

TX Text Control's InputPosition class informs you about which page, line and column the current input position is at. It can also be used to move the input position to a different location.

The following example shows how to create a Goto Page function. An instance of the InputPosition class is created and initialized with a previously entered page number. The new input position is then assigned to the TextControl.InputPosition property.

[C#]
winGotoPage winGotoPage = new winGotoPage();
winGotoPage.ShowDialog();

if (winGotoPage.PageNo > 0 && winGotoPage.PageNo <= textControl1.Pages)
{
    TXTextControl.InputPosition InputPosition =
        new TXTextControl.InputPosition(winGotoPage.PageNo, 1, 0);
    textControl1.InputPosition = InputPosition;
}
else
{
    MessageBox.Show("Page number outside valid range.");
}
[Visual Basic]
Dim winGotoPage As New winGotoPage()
winGotoPage.ShowDialog()

If winGotoPage.PageNo > 0 AndAlso winGotoPage.PageNo <= textControl1.Pages Then
    Dim InputPosition As New TXTextControl.InputPosition(winGotoPage.PageNo, 1, 0)
    textControl1.InputPosition = InputPosition
Else
    MessageBox.Show("Page number outside valid range.")
End If

Note that the InputPosition.Page property requires the ViewMode property to be set to PageView. In all other modes, text is displayed continuously as a single page, so the property will always have a value of 1.

<< Previous


Howto: Mail Merge

The chapter Connecting to Databases showed you how to store the entire contents of a TX Text Control in a database field. For implementing mail-merge functionality, however, the requirements are different: The contents of database fields have to be inserted at specified positions in a previously prepared document.

This chapter shows how to use the DocumentServer.MailMerge class in Windows Forms projects to merge TXTextControl.ApplicationFields in template documents with data from various data sources. The MailMerge class encapsulates powerful mail merge capabilities in a ready-to-use component. The DocumentServer.MailMerge class is part of the TXTextControl.DocumentServer namespace.

Using the DocumentServer.MailMerge component, template documents containing MS Word merge fields can be easily loaded, merged with a DataSet or DataTable of the Microsoft .NET System.Data namespace and exported to the supported file formats of TX Text Control like Adobe PDF or DOCX.

It is possible to pass a DataTable containing different columns that covers the merge field names. The data rows of the table equals the number of created documents. Optionally, it is possible to create separate documents or to append the documents to one resulting document.

Single merge fields can be inserted that will be filled with database content. Additionally, repeating blocks can be defined in the template. These blocks will be repeated according to the number of passed data rows.

The DocumentServer.MailMerge component supports the most important standard merge fields of MS Word. Supported fields are: MERGEFIELD, INCLUDETEXT, IF and DATE.

In the first step, this article explains how to connect the MailMerge component with an instance of TextControl. The source code for the examples is contained in the subfolders MailMerge_Simple, MailMerge_Blocks and MailMerge_Nested_Blocks of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\MailMerge
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\MailMerge

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar
  • DocumentServer.MailMerge

Relevant API links:

  • TextControl.ApplicationFields
  • DocumentServer.MailMerge

Sample: Simple Mail Merge

Sample: Mail Merge with Repeating Blocks

Sample: Mail Merge with Nested Repeating Blocks

Creating Templates using TX Text Control Words


Creating Templates using TX Text Control Words

The shipped application TX Text Control Words is designed to create templates which are compatible to the DocumentServer.MailMerge component. It allows users to connect to databases and to insert valid merge fields and repeating blocks into a document. These documents can be exported to all supported file formats.

TX Text Control Words is an application based on TX Text Control .NET that helps users create fully featured templates that work properly with the DocumentServer.MailMerge class. It uses the standard MS Word MergeFields that are represented by the ApplicationField class of TX Text Control .NET.

Start TX Text Control Words and open the Mailings tab page of the ribbon menu.

In the first step, you can select a data source. You can choose between Microsoft Access or SQL Server database files, an ODBC data source or a Microsoft SQL Server connection.

After you selected a data source, the available tables are listed in the Select Table dropdown button.

The Insert Merge Field dropdown button lists all available fields of the selected table. This button can be used to insert various merge fields into the template:

To preview the results from the currently selected data table, select Preview Merge Fields and browse through the records using the data source navigation buttons. Finally, you can Finish & Merge the template with the selected data source. The data can be merged into the current document, you can create separate files or you can print the resulting document.


Howto: Use Hypertext Links

This chapter shows you how to add hypertext links and targets to your documents, and how to respond to events fired by TX Text Control when a hypertext link is clicked. For an overview of the various classes, properties, methods and events involved, please refer to the chapter Text Fields and Hypertext Links in the Technical Articles part of this manual.

The source code for this example is contained in the subfolders Step1 to Step3 of the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Hyperlinks
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Hyperlinks

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl

Relevant API links:

  • WPF.TextControl.DocumentTargets
  • WPF.TextControl.HypertextLinks
  • WPF.TextControl.Selection

Step 1: Inserting a Hypertext Link

Step 2: Adding a Dialog Box for Inserting Hypertext Links


Step 1: Inserting a Hypertext Link

In this first sample program, a hypertext link will be inserted in a text document. The document is then saved as an HTML file so that it can be displayed in a browser. This is what the sample program looks like:

To insert a hypertext link, we first need to create a HypertextLink object. The text to be displayed in the document ("Text Control Web Site") and the information about where to link to ("http://www.textcontrol.com") are passed as parameters to the constructor. The object that is thus created is then inserted at the current input position by adding it to a Text Control's HypertextLinks collection.

[C#]
private void cmdInsertHyperlink_Click(object sender, System.EventArgs e)
{
    // Create a HypertextLink object
    TXTextControl.HypertextLink MyLink =
        new TXTextControl.HypertextLink(
        "Text Control Web Site",
        "http://www.textcontrol.com");
    // Insert the hyperlink into the document
    textControl1.HypertextLinks.Add(MyLink);
}
[Visual Basic]
Private Sub cmdInsertHyperlink_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles cmdInsertHyperlink.Click
    ' Create a HypertextLink object
    Dim MyLink As New TXTextControl.HypertextLink( _
        "Text Control Web Site", _
        "http://www.textcontrol.com")
    ' Insert the hyperlink into the document
    TextControl1.HypertextLinks.Add(MyLink)
End Sub

Note that this first sample program does not handle the Click events, so clicking on a hypertext link in the TX Text Control will have no effect. Also, the link does not yet have the typical blue and underlined formatting style. Click events and formatting will be covered in Step 2.

The TextControl.Save method is used to save the document as an HTML file:

[C#]
private void cmdSaveAs_Click(object sender, System.EventArgs e)
{
    textControl1.Save(TXTextControl.StreamType.HTMLFormat);
}
[Visual Basic]
Private Sub cmdSaveAs_Click(ByVal sender As System.Object, _
    ByVal e As System.EventArgs) Handles cmdSaveAs.Click
    TextControl1.Save(TXTextControl.StreamType.HTMLFormat)
End Sub
[Delphi]
procedure Form1.cmdSaveAs_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Save(TXTextControl.StreamType.HTMLFormat);
end;

When the HTML file is opened in a web browser, the hypertext link is displayed as specified in your browser's settings.

Clicking on the link will take you to the TX Text Control web site.


Step 2: Adding a Dialog Box for Inserting Hypertext Links

In this second sample program, a dialog box is created which enables you to insert hypertext links in a more convenient way. Additionally, hypertext links which have previously been inserted or loaded from a file, can be edited and modified. Note that, while hypertext links are usually associated with HTML files, they can as well be stored in RTF or Microsoft Word files, or in TX Text Control's proprietary format.

The dialog box contains two text boxes. The first is for the text that represents the hypertext link in the document and the second is for the address, to which the link points.

The same dialog box is used for both, inserting a new and editing an existing hypertext link. Depending on whether the current input position is inside an existing link, this link is modified. Otherwise, a new one is inserted.

[C#]
wndHyperlink Hyperlinks = new wndHyperlink();
Hyperlinks.tx = textControl1;
Hyperlinks.ShowDialog();
HighlightHyperlinks(textControl1, mnuView.IsChecked);
[Visual Basic]
Dim Hyperlinks As New wndHyperlink()
Hyperlinks.tx = textControl1
Hyperlinks.ShowDialog()
HighlightHyperlinks(textControl1, mnuView.IsChecked)

When the form is loaded, the text boxes are filled with the text and link information, provided that the current input position is inside a link:

[C#]
private void Window_Loaded(object sender, RoutedEventArgs e)
{
    TXTextControl.HypertextLink HyperLink = tx.HypertextLinks.GetItem();

    if (HyperLink != null)
    {
        // If there is an existing hypertext link at the input position,
        // copy its text and target to the text boxes on the form.
        tbLinkedText.Text = HyperLink.Text;
        tbLinkTo.Text = HyperLink.Target;
    }
    else
    {
        // If there is no hypertext link at the input position, but
        // some text has been selected, then copy this text to the
        // Linked Text text box.
        if (tx.Selection.Length > 0)
            tbLinkedText.Text = tx.Selection.Text;
    }
}
[Visual Basic]
Private Sub Window_Loaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Dim HyperLink As TXTextControl.HypertextLink = tx.HypertextLinks.GetItem()

    If HyperLink IsNot Nothing Then
        ' If there is an existing hypertext link at the input position,
        ' copy its text and target to the text boxes on the form.
        tbLinkedText.Text = HyperLink.Text
        tbLinkTo.Text = HyperLink.Target
    Else
        ' If there is no hypertext link at the input position, but
        ' some text has been selected, then copy this text to the
        ' Linked Text text box.
        If tx.Selection.Length > 0 Then
            tbLinkedText.Text = tx.Selection.Text
        End If
    End If
End Sub

The user then can change the displayed information. On clicking the OK button, the information is transfered to the document by either inserting a new link or modifying the existing one:

[C#]
private void btnOK_Click(object sender, RoutedEventArgs e)
{
    if (tbLinkedText.Text == "")
        MessageBox.Show("Hyperlink contains no text. Please enter the text to be shown as a hyperlink in the Linked Text field.", this.Title, MessageBoxButton.OK, MessageBoxImage.Error);
    else if (tbLinkTo.Text == "")
        MessageBox.Show("No target specified. Please enter a target URL in the Link To field.", this.Title, MessageBoxButton.OK, MessageBoxImage.Error);
    else
    {
        TXTextControl.HypertextLink HyperLink = tx.HypertextLinks.GetItem();
        if (HyperLink == null)
        {
            // Insert a new link
            TXTextControl.HypertextLink NewLink =
                new TXTextControl.HypertextLink(
                tbLinkedText.Text, tbLinkTo.Text);
            tx.HypertextLinks.Add(NewLink);
        }
        else
        {
            // Update an existing link
            HyperLink.Text = tbLinkedText.Text;
            HyperLink.Target = tbLinkTo.Text;
        }

        Close();
    }
}
[Visual Basic]
Private Sub btnOK_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
    If tbLinkedText.Text = "" Then
        MessageBox.Show("Hyperlink contains no text. Please enter the text to be shown as a hyperlink in the Linked Text field.", Me.Title, MessageBoxButton.OK, MessageBoxImage.[Error])
    ElseIf tbLinkTo.Text = "" Then
        MessageBox.Show("No target specified. Please enter a target URL in the Link To field.", Me.Title, MessageBoxButton.OK, MessageBoxImage.[Error])
    Else
        Dim HyperLink As TXTextControl.HypertextLink = tx.HypertextLinks.GetItem()
        If HyperLink Is Nothing Then
            ' Insert a new link
            Dim NewLink As New TXTextControl.HypertextLink(tbLinkedText.Text, tbLinkTo.Text)
            tx.HypertextLinks.Add(NewLink)
        Else
            ' Update an existing link
            HyperLink.Text = tbLinkedText.Text
            HyperLink.Target = tbLinkTo.Text
        End If

        Close()
    End If
End Sub

Finally, there is a menu item to switch the character format of the hyperlink's text to blue colored and underlined style. The menu item calls the function HighlightHyperlinks, which is not a Text Control method, but part of the sample program. It changes each element of the Text Control's HypertextLinkCollection to the desired display style.

[C#]
void HighlightHyperlinks(TXTextControl.WPF.TextControl tx, bool Highlight)
{
    int PreviousStart = tx.Selection.Start, PreviousLength = tx.Selection.Length;

    foreach (TXTextControl.HypertextLink Link in tx.HypertextLinks)
    {
        tx.Selection.Start = Link.Start - 1;
        tx.Selection.Length = Link.Length;
        if (Highlight)
        {
            tx.Selection.ForeColor = System.Drawing.Color.Blue;
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.Single;
        }
        else
        {
            tx.Selection.ForeColor = System.Drawing.Color.Black;
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.None;
        }
    }
    tx.Selection.Start = PreviousStart;
    tx.Selection.Length = PreviousLength;
}
[Visual Basic]
Private Sub HighlightHyperlinks(ByVal tx As TXTextControl.WPF.TextControl, ByVal Highlight As Boolean)
    Dim PreviousStart As Integer = tx.Selection.Start, PreviousLength As Integer = tx.Selection.Length

    For Each Link As TXTextControl.HypertextLink In tx.HypertextLinks
        tx.Selection.Start = Link.Start - 1
        tx.Selection.Length = Link.Length
        If Highlight Then
            tx.Selection.ForeColor = System.Drawing.Color.Blue
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.[Single]
        Else
            tx.Selection.ForeColor = System.Drawing.Color.Black
            tx.Selection.Underline = TXTextControl.FontUnderlineStyle.None
        End If
    Next
    tx.Selection.Start = PreviousStart
    tx.Selection.Length = PreviousLength
End Sub


Howto: Use XML Files

The purpose of this chapter is to help you get started with Text Control Enterprise and its XML features. It will show you how to open an XML file, and how to use it in conjunction with a CSS stylesheet and a DTD.

There is a more detailed description of the XML related properties and methods in the Technical Articles section, see Working with XML Files.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\XMLBasics
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\XMLBasics

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar

Relevant API links:

  • WPF.TextControl.Load

The Sample Program

The XML File

The CSS File

The DTD File

Editing in XML Mode


The Sample Program

The sample program has only one menu item, which is Open File.... Looking at the source code reveals nothing unusual: The main difference to the Open File routine in other Text Control sample programs is the Load method being called with the StreamType value XMLFormat as a parameter, so that the Open File dialog box will only display XML files:

[C#]
private void mnuFile_Open_Click(object sender, System.EventArgs e)
{
    textControl1.Load(TXTextControl.StreamType.XMLFormat);
}
[Visual Basic]
Private Sub mnuFile_Open_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuFile_Open.Click
    TextControl1.Load(TXTextControl.StreamType.XMLFormat)
End Sub
[Delphi]
proedure TWinForm1.mnuFile_Open_Click(sender: System.Object;
    e: System.EventArgs);
begin
    TextControl1.Load(TXTextControl.StreamType.XMLFormat);
end;

There is quite a bit happeing behind the scenes, however. If you load the TestFile.xml sample file, Text Control will not only load the xml file, but will

  • automatically validate it using the enclosed DTD, and
  • format it according to the CSS stylesheet provided.

Let us take a closer look at the 3 files involved.


Editing in XML Mode

This chapter looks at some of the differences between normal text editing and editing an XML file.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\XMLEditing
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\XMLEditing

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar

Relevant API links:

  • WPF.TextControl.Load

The Sample Program

Run the sample program and load the demo file address_list.xml. You will notice that there is now a button bar with 3 combo boxes:

You don't need to create the combo boxes yourself, they are built into Text Control's WPF.ButtonBar.

The first combo box displays the style of the current XML field. If you move down the caret by pressing the down arrow key, the display will change from name to street, city and email, depending on what type of field you are in.

With the second combo box, additional XML fields can be inserted.

You can select to either insert a complete address record, or one of the optional elements, which are street and city. Depeding on the DTD, not all elements can be inserted at all positions. For instance, if you click on the name Paul in the first line of the document, and try to insert a street, an error will occur, because this record already contains a street. Try again with Ringo, and it will work.

The third combo box is for deleting XML fields. Again, every action is checked with the DTD, so that you can be sure not to invalidate your document by, for instance, deleting a required field.


Howto: Use Text Frames

This chapter describes how you can control and manipulate text using text frames.

The source code for for the sample programs shown here is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Text Frames
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Text Frames

An overview of all properties, methods and events which can be used in conjunction with text frames can be found at Images and Text Frames.

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.TextFrames

Inserting a Text Frame

Printing Labels


Inserting a Text Frame

A text frame is inserted by first creating an instance of the TextFrame class, and then adding it to the TextFrameCollection:

[C#]
TXTextControl.TextFrame newFrame = new TXTextControl.TextFrame(new Size(1000,1000));
textControl1.TextFrames.Add (newFrame, TXTextControl.HorizontalAlignment.Left,
    -1,TXTextControl.TextFrameInsertionMode.DisplaceText);
[Visual Basic]
Dim NewFrame As New TXTextControl.TextFrame(New Size(1000, 1000))
TextControl1.TextFrames.Add(NewFrame, TXTextControl.HorizontalAlignment.Left, _
    -1, TXTextControl.TextFrameInsertionMode.DisplaceText)

Once a text frame has been inserted, it can be activated by clicking on its border. An activated text frame can be moved and resized by dragging its border with the mouse.

Text Control provides a built-in dialog box for changing the appearance of a text frame. The dialog box is displayed using the TextFrameAttributesDialog method:

[C#]
textControl1.TextFrameAttributesDialog();
[Visual Basic]
TextControl1.TextFrameAttributesDialog()

The menu item which displays this dialog box should be disabled when no text frame is selected. This can be done in the menu's popup event, using the GetItem method of the TextFrame collection:

[C#]
mnuProperties.IsEnabled = (textControl1.TextFrames.GetItem() != null);
[Visual Basic]
mnuProperties.IsEnabled = (textControl1.TextFrames.GetItem() IsNot Nothing)


Printing Labels

This sample program shows how to insert multiple text frames simultaneously. The application is a label printing program, used to print, for instance, address lables or badges. The source code for this sample program can be found in the TextFrames\Printing Address Lables directory.

The sample program contains a dialog box for entering information about the label sheet to be used, e.g. the number of lables and their dimensions.

The program then creates a text frame for each of the labels.

The text frames can them be filled out, either manually by clicking on a field and typing in text, or from a file or database. When you click on the Fill in menu item, the sample program will enter the words "Address no." followed by the field identifier into each of the frames.

To load text from a file instead, simply replace the Selection.Text property with a call to the Selection.Load method.

[C#]
private void mnuLabel_FillIn_Click(object sender, System.EventArgs e)
{
    int n = 0;
    foreach (TXTextControl.TextFrame frame in textControl1.TextFrames)
    {
        frame.Selection.Text = "Text Frame #" + Convert.ToString(n++);
    }
}
[Visual Basic]
Private Sub mnuLabel_FillIn_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles mnuLabel_FillIn.Click
    Dim N As Integer

    For Each Frame As TXTextControl.TextFrame In TextControl1.TextFrames
        Frame.Selection.Text = "Text Frame #" & N
        N = N + 1
    Next
End Sub


Howto: Drag and Drop Files

This chapter describes how to handle drag and drop with TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\DragDrop
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\DragDrop

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.Load

Two Types of Drag and Drop

File Drag and Drop

Handling Drag and Drop Events


Handling Drag and Drop Events

The following code shows you how Drag and Drop is implemented in this sample program and in the Text Control Words demo application. It allows files to be dropped on all parts of the application, including the text area. The code has been encapsulated in a class named DragDropHandler for easy re-use in your programs.

First, you need to instantiate the class:

[C#]
FileDragDropHandler fileDragDrop = new FileDragDropHandler();
[Visual Basic]
Dim FileDragDrop As New FileDragDropHandler

After that, you can use the form's and the control's events to handle files that will be dropped on the form or control. These are the TX Text Control events which have to be handled with the help of the DragDropHandler class. The form's events are handled the same way.

[C#]
private void textControl1_DragDrop(object sender, DragEventArgs e)
{
    loadFile(fileDragDrop.FileName, fileDragDrop.StreamType);
}

private void textControl1_DragEnter(object sender, DragEventArgs e)
{
    fileDragDrop.Reset();
    fileDragDrop.CheckDraggedFiles((string[])e.Data.GetData(DataFormats.FileDrop));
}

private void textControl1_DragOver(object sender, DragEventArgs e)
{
    if (fileDragDrop.CanDrop == true)
        e.Effects = fileDragDrop.GetDragDropEffect(e.AllowedEffects);
}
[Visual Basic]
Private Sub textControl1_DragDrop(ByVal sender As Object, ByVal e As DragEventArgs)
    loadFile(fileDragDrop.FileName, fileDragDrop.StreamType)
End Sub

Private Sub textControl1_DragEnter(ByVal sender As Object, ByVal e As DragEventArgs)
    fileDragDrop.Reset()
    fileDragDrop.CheckDraggedFiles(DirectCast(e.Data.GetData(DataFormats.FileDrop), String()))
End Sub

Private Sub textControl1_DragOver(ByVal sender As Object, ByVal e As DragEventArgs)
    If fileDragDrop.CanDrop = True Then
        e.Effects = fileDragDrop.GetDragDropEffect(e.AllowedEffects)
    End If
End Sub

In the DragEnter event, the file extension will be checked against the supported file types.

If the dragged file is supported, the CanDrop property returns true, which can be used to decide if the DragDrop will be allowed. As you can see, the GetDragDropEffect function returns a DragDropEffects type value based on the current Keystate, which can easily be used to control the desired cursor.

Finally, the DragDrop event is fired and the dropped file is loaded.

<< Previous


Howto: Implement Spreadsheet Functionality

This chapter describes how to add spreadsheet-like functionality to the TX Text Control tables.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WPF\VB.NET\Spreadsheet
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for Windows Forms\Samples\WPF\CSharp\Spreadsheet

Used TX Text Control controls:

  • TXTextControl.TextControl
  • TXTextControl.ButtonBar

Relevant API links:

  • TextControl.Tables
  • TableCell
  • TableCell.Name

Creating a spreadsheet interface using tables

Adding formulas to table cells


Creating a spreadsheet interface using tables

Tables can be used for many different applications. Whether tables are used to align text on a page, to structure data or to do some calculations - TX Text Control gives you a powerful set of table functionality to fulfill these requirements.

This sample consists of a WPF.TextControl in which a table that is used as a spreadsheet:

The first row and the first column of the spreadsheet table is used to display the cell names and therefore they are protected and can't be modified by the user. If the input position is inside one of these title cells, the WPF.TextControl.EditMode property is used to prevent the user from changing these cells:

[C#]
TXTextControl.TableCell cell = _activeTable.Cells.GetItem();

if ((cell.Column == 1) || (cell.Row == 1))
    textControl.EditMode = EditMode.ReadAndSelect;
else
    textControl.EditMode = EditMode.Edit;
[Visual Basic]
Dim cell As TXTextControl.TableCell = _activeTable.Cells.GetItem()

If (cell.Column = 1) OrElse (cell.Row = 1) Then
    TextControl1.EditMode = EditMode.ReadAndSelect
Else
    TextControl1.EditMode = EditMode.Edit
End If


Adding formulas to table cells

A core functionality of spreadsheets is the possibility to add functionality to a cell. This enables users to add a specific formula to a cell. The value of this cell is calculated based on this formula and the values of other referenced cells. In this sample, a basic sum function is implemented.

Each TableCell has text that is displayed and additional data that is stored in the TableCell.Name property.

Type in numeric values into cell B1 and B2. Now, select cell B3 and click on the Sum button.

A sum function is inserted automatically that totalizes the values of the above cells.

An identifier and the specific formula with the connected cells are stored in the TableCell.Name property:

[C#]
private const string FormulaIdentifier = "_tx_formula_";

private void CreateSumFormula(TXTextControl.TableCell tableCell)
{
    tableCell.Text = string.Empty;
    tableCell.Name
        = FormulaIdentifier + ",sum,2,"             // Identifier string, formula type ("sum") and first row (2)
        + (tableCell.Row - 1).ToString() + ","      // Last row
        + tableCell.Column.ToString();              // Column

    UpdateSumCells();
}
[Visual Basic]
Private Const FormulaIdentifier As String = "_tx_formula_"

Private Sub CreateSumFormula(ByVal tableCell As TXTextControl.TableCell)
    tableCell.Text = String.Empty
    ' Identifier string, formula type ("sum") and first row (2)
    ' Last row
    tableCell.Name = FormulaIdentifier & ",sum,2," & (tableCell.Row - 1).ToString() & "," & tableCell.Column.ToString()
    ' Column
    UpdateSumCells()
End Sub

On updating the results, the UpdateSumCells method loops through all cells looking for stored formulas. If a formula is found, the sum of the cells which, are part of the cell range defined in the formula is calculated and used as the TableCell.Text of this cell.

[C#]
private void UpdateSumCells(TXTextControl.Table table)
{
    foreach (TXTextControl.TableCell cell in table.Cells)
    {
        if (!cell.Name.StartsWith(FormulaIdentifier)) continue;

        string[] splitValues = cell.Name.Split(',');
        if ((splitValues.Length < 5) || (splitValues[1] != "sum")) continue;

        int sum = 0, column = Convert.ToInt32(splitValues[4]);

        for (int row = Convert.ToInt32(splitValues[2]); row <= Convert.ToInt32(splitValues[3]); row++)
        {
            int number;
            Int32.TryParse(textControl.Tables.GetItem().Cells.GetItem(row, column).Text, out number);

            sum += number;
        }

        cell.Text = sum.ToString();
    }
}
[Visual Basic]
Private Sub UpdateSumCells(ByVal table As TXTextControl.Table)
    For Each cell As TXTextControl.TableCell In table.Cells
        If Not cell.Name.StartsWith(FormulaIdentifier) Then
            Continue For
        End If

        Dim splitValues As String() = cell.Name.Split(","c)
        If (splitValues.Length < 5) OrElse (splitValues(1) <> "sum") Then
            Continue For
        End If

        Dim sum As Integer = 0, column As Integer = Convert.ToInt32(splitValues(4))

        For row As Integer = Convert.ToInt32(splitValues(2)) To Convert.ToInt32(splitValues(3))
            Dim number As Integer
            Int32.TryParse(TextControl1.Tables.GetItem().Cells.GetItem(row, column).Text, number)

            sum += number
        Next

        cell.Text = sum.ToString()
    Next
End Sub


Howto: Create a simple WPF Browser Application (XBAP)

This chapter shows you how to create a small word processor from scratch with just a few lines of code. It will be able to load and save files, use the clipboard, and will have dialog boxes for character and paragraph formatting, a ruler, a status bar and full keyboard and mouse interface.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\XBAP\VB.NET\Simple
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\XBAP\CSharp\Simple

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar

Relevant API links:

  • WPF.TextControl.load
  • WPF.TextControl.Save
  • WPF.TextControl.Cut
  • WPF.TextControl.Copy
  • WPF.TextControl.Paste

Creating the Project

Adding the Components to the Page

Adding a Menu Bar


Creating the Project

Assuming that you have already run the TX Text Control installation program, start Visual Studio .NET and create a new project. Select either Visual Basic or Visual C# as the project type and WPF Browser Application as the template.

Continue with the next step, if the TX Text Control items are in your toolbox. Otherwise, add the items to your toolbox manually as described below.

Select Tools / Choose Toolbox Items... to open the Choose Toolbox Items dialog box. Open the WPF Components tab page, sort the list by Namespace by clicking on the appropriate table header and find the TXTextControl.WPF components. If they are not listed, click on Browse... and navigate to the directory where TX Text Control has been installed (C:\Program Files\The Imaging Source Europe GmbH\TX Text Control 16.0.NET\Asm\ if you didn't change the default setup path) and double click on the file TXTextControl.WPF.dll.

Back in the Choose Toolbox Items dialog, scroll down to verify that the TextControl component has been added. If you sort the list by namespace, you will see the other 3 components, ButtonBar, StatusBar and RulerBar. Select these components by checking the appropriate checkbox.

After closing the dialog box, you will see four additional icons appear at the bottom of the toolbox, representing the Text Control and its Status Bar, Button Bar and Ruler Bar.


Adding the Components to the Page

In the XAML view, replace the Grid with a DockPanel control like shown in the below screenshot:

In the next steps, the order in how the controls are added to the Page is important.

Double-click the ButtonBar in the toolbox to add it to the Page. Repeat this for the RulerBar, StatusBar, a second RulerBar and finally TextControl. The XAML should look like this:

Visual Studio 2008 users: In the XAML, remove the Height and the Width properties for all added elements.

Select the secondly added Ruler Bar rulerBar2 using the mouse in the Design view to change the properties in the Properties window. Browse for the DockPanel.Dock property and change it to Left.

Additionally, set the HorizontalAlignment to Left and the VerticalAlignment to Stretch. The Design view should look like this:

Now, the controls must be connected. Therefore, select textControl1 to open it's properties in the Properties window of Visual Studio. First, look for ButtonBar property and type in the name of the added Button Bar: buttonBar1.

Set the RulerBar property to rulerBar1, StatusBar to statusBar1 and VerticalRulerBar to rulerBar2.

In the XAML, add the Loaded="textControl1_Loaded" event handler to the TextControl element as a parameter, so that the line looks like this:

<my:TextControl Name="textControl1" Loaded="textControl1_Loaded"
    ButtonBar="buttonBar1" StatusBar="statusBar1" RulerBar="rulerBar1" VerticalRulerBar="rulerBar2"/>

Now, right-click on textControl1_Loaded and choose Navigate to Event Handler from the opened context menu. Add the following code to the event handler:

[C#]
private void textControl1_Loaded(object sender, RoutedEventArgs e)
{
 textControl1.Focus();
}
[Visual Basic]
private void textControl1_Loaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Focus
}

Open the project properties using by selecting the Properties... menu item from Project main menu. On the Security tab page, make sure that the check box Enable ClickOnce Security Settings is checked and choose This is a full trust application.

Now, press F5 to compile and start the application:


Adding a Menu Bar

The last step is to add a menu strip to the Window. Switch back to the Design/XAML view. In the toolbox, look for the Menu control in the Controls category and double-click the icon to insert it to the current Window. In the Properties window, change the DockPanel.Dock property to Top.

In the XAML, re-arrange the elements, so that the menu is the first element in the DockPanel and remove the Width and Height properties:

Instead of adding the menu entries using the Properties window, the entries are added in the XAML directly which is much faster. Replace the menu element with the following XAML code:

<Menu Name="menu1" DockPanel.Dock="Top">
 <MenuItem Header="_File">
  <MenuItem Header="Load..." Click="MenuItemLoad_Click" />
  <MenuItem Header="Save..." Click="MenuItemSave_Click" />
  <Separator />
  <MenuItem Header="Exit" Click="MenuItemExit_Click" />
 </MenuItem>
 <MenuItem Header="_Edit">
  <MenuItem Header="Cut" Click="MenuItemCut_Click" />
  <MenuItem Header="Copy" Click="MenuItemCopy_Click" />
  <MenuItem Header="Paste" Click="MenuItemPaste_Click" />
 </MenuItem>
 <MenuItem Header="_Format">
  <MenuItem Header="Character..." Click="MenuItemCharacter_Click" />
  <MenuItem Header="Paragraph..." Click="MenuItemParagraph_Click" />
 </MenuItem>
</Menu>

In the first XAML menu element Load..., right-click MenuItemLoad_Click and choose Navigate to Event Handler from the opened context menu. This opens the code view of the Window.

Add the following code, so that the complete method looks like this:

[C#]
private void MenuItemLoad_Click(object sender, RoutedEventArgs e)
{
 textControl1.Load();
}
[Visual Basic]
Private Sub MenuItemLoad_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
 TextControl1.Load
End Sub

Repeat this step for all menu items and add the following code to the code view:

[C#]
private void MenuItemSave_Click(object sender, RoutedEventArgs e)
{
 textControl1.Save();
}

private void MenuItemExit_Click(object sender, RoutedEventArgs e)
{
 this.Close();
}

private void MenuItemCut_Click(object sender, RoutedEventArgs e)
{
 textControl1.Cut();
}

private void MenuItemCopy_Click(object sender, RoutedEventArgs e)
{
 textControl1.Copy();
}

private void MenuItemPaste_Click(object sender, RoutedEventArgs e)
{
 textControl1.Paste();
}

private void MenuItemCharacter_Click(object sender, RoutedEventArgs e)
{
 textControl1.FontDialog();
}

private void MenuItemParagraph_Click(object sender, RoutedEventArgs e)
{
 textControl1.ParagraphFormatDialog();
}
[Visual Basic]
Private Sub MenuItemSave_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Save
}

Private Sub MenuItemExit_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 Me.Close
}

Private Sub MenuItemCut_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Cut
}

Private Sub MenuItemCopy_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Copy
}

Private Sub MenuItemPaste_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.Paste
}

Private Sub MenuItemCharacter_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.FontDialog
}

Private Sub MenuItemParagraph_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
{
 TextControl1.ParagraphFormatDialog
}

Press F5 to start the project.


Howto: Load a document from the server in an XBAP browser application

This chapter shows you how to load a document from an ASP.NET web application into the XBAP browser application. This is the typical scenario when using TX Text Control .NET for WPF in an XBAP application. The documents are prepared using the ServerTextControl component and then loaded into the XBAP application.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\XBAP\VB.NET\Load document from server\
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\XBAP\CSharp\Load document from server\

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.RulerBar
  • TXTextControl.WPF.StatusBar
  • TXTextControl.ServerTextControl

Relevant API links:

  • WPF.TextControl.load
  • WPF.TextControl.Save

The WCF Service

The XBAP Application


The WCF Service

The project consists of 2 parts: A WCF service that uses the ServerTextControl component to create a new document and an XBAP application using TX Text Control .NET for WPF that consumes the service.

The service implements a simple public method to create a new document. A new instance of the ServerTextControl component is created and the document is saved into a byte array in the internal TX Text Control format.

[C#]
public byte[] GetDocument()
{
    TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl();
    tx.Create();

    tx.Text = "This document has been loaded from the server";

    byte[] data;

    tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    tx.Dispose();

    return data;
}
[Visual Basic]
Public Function GetDocument() As Byte() Implements IService1.GetDocument
    Dim tx As New TXTextControl.ServerTextControl()
    tx.Create()

    tx.Text = "This document has been loaded from the server"

    Dim data As Byte() = Nothing

    tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    tx.Dispose()

    Return data
End Function


The XBAP Application

The XBAP application contains a reference to the created WCF web service. To add a web service to an XBAP application, click on Add Service Reference... from the Project main menu. In the opened dialog, click on Discover to find the web services in the same solution. Select the service from the listed services, give it a proper name and confirm with OK.

The following code creates a new web service client in order to consume the service to get a byte array that can be loaded into the TX Text Control:

[C#]
DocumentService.Service1Client docService = new tx_wpf_xbap_basics.DocumentService.Service1Client();
byte[] data = docService.GetDocument();

textControl1.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
[Visual Basic]
Dim docService As DocumentService.Service1Client = New DocumentService.Service1Client()
Dim data As Byte() = docService.GetDocument

textControl1.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)

After the sample has been started, select Load from the File menu to load the text from the WCF web service.


Howto: Add drawings and shapes to your application

This chapter describes how to add drawings functionality to TX Text Control.

The source code for this example is contained in the following directories:

  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\VB.NET\Shapes\
  • %USERPROFILE%\My Documents\TX Text Control 24.0.NET for WPF\Samples\WPF\CSharp\Shapes\

Used TX Text Control controls:

  • TXTextControl.WPF.TextControl
  • TXTextControl.WPF.ButtonBar
  • TXTextControl.WPF.StatusBar
  • TXTextControl.WPF.RulerBar
  • TXDrawing.WPF.TXDrawingControl

Relevant API links:

  • DataVisualization.DrawingFrame

Inserting drawings as single objects

Inserting a drawings canvas


Inserting drawings as single objects

TX Text Control provides two different ways to insert a drawing object into a document: As a single object or multiple shapes in a drawing canvas. In the sample application, when choosing a shape type from the main menu Insert -> Shapes, the object is inserted as a single object:

In the following code, a DataVisualization.DrawingFrame object is created which hosts the WPF.Drawing.TXDrawingControl object. The DataVisualization.DrawingFrame object is added to the WPF.TextControl.Drawings collection of WPF.TextControl. Finally, a new Drawing.Shape object is added to the WPF.Drawing.TXDrawingControl object:

[C#]
TXTextControl.WPF.Drawing.TXDrawingControl drawingObject =
    new TXTextControl.WPF.Drawing.TXDrawingControl(5000, 5000);

// create a new DrawingFrame object that hosts the TXDrawingControl
TXTextControl.DataVisualization.DrawingFrame drawingFrame =
    new TXTextControl.DataVisualization.DrawingFrame(drawingObject);

// add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame,
    new System.Drawing.Point(0, 0),
    -1,
    TXTextControl.FrameInsertionMode.DisplaceText);

TXTextControl.Drawing.Shape newShape = new TXTextControl.Drawing.Shape(
    (ShapeType)Enum.Parse(typeof(ShapeType),
    ((MenuItem)sender).Header.ToString()));

newShape.AutoSize = true;
newShape.Sizable = false;
newShape.Movable = false;

// add shape directly to TextControl
drawingObject.Shapes.Add(newShape, ShapeCollection.AddStyle.Fill);
[Visual Basic]
Dim drawingObject As New TXTextControl.WPF.Drawing.TXDrawingControl(5000, 5000)

' create a new DrawingFrame object that hosts the TXDrawingControl
Dim drawingFrame As New TXTextControl.DataVisualization.DrawingFrame(drawingObject)

' add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, New System.Drawing.Point(0, 0), -1, TXTextControl.FrameInsertionMode.DisplaceText)

Dim newShape As New TXTextControl.Drawing.Shape(DirectCast([Enum].Parse(GetType(ShapeType), DirectCast(sender, MenuItem).Header.ToString()), ShapeType))

newShape.AutoSize = True
newShape.Sizable = False
newShape.Movable = False

' add shape directly to TextControl
drawingObject.Shapes.Add(newShape, ShapeCollection.AddStyle.Fill)


Inserting a drawings canvas

The second approach to insert shape objects into TX Text Control is a drawing canvas. This canvas is a DataVisualization.DrawingFrame object that hosts the WPF.Drawing.TXDrawingControl object, but the inserted shapes don't necessarily fit the complete frame.

The following code inserts the drawing canvas that fits exactly the page width without page margins:

[C#]
// calculate the available page width
textControl1.PageUnit = TXTextControl.MeasuringUnit.Twips;
int iPageWidth = (int)(textControl1.Sections.GetItem().Format.PageSize.Width -
    textControl1.Sections.GetItem().Format.PageMargins.Left -
    textControl1.Sections.GetItem().Format.PageMargins.Right);

// create a new TXDrawingControl that fills the complete page width
TXTextControl.WPF.Drawing.TXDrawingControl drawingObject =
    new TXTextControl.WPF.Drawing.TXDrawingControl(iPageWidth, 5000);

// create a new DrawingFrame object that hosts the TXDrawingControl
TXTextControl.DataVisualization.DrawingFrame drawingFrame =
    new TXTextControl.DataVisualization.DrawingFrame(drawingObject);

// add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, -1);
drawingFrame.Activate();
[Visual Basic]
' calculate the available page width
textControl1.PageUnit = TXTextControl.MeasuringUnit.Twips
Dim iPageWidth As Integer = CInt(textControl1.Sections.GetItem().Format.PageSize.Width - textControl1.Sections.GetItem().Format.PageMargins.Left - textControl1.Sections.GetItem().Format.PageMargins.Right)

' create a new TXDrawingControl that fills the complete page width
Dim drawingObject As New TXTextControl.WPF.Drawing.TXDrawingControl(iPageWidth, 5000)

' create a new DrawingFrame object that hosts the TXDrawingControl
Dim drawingFrame As New TXTextControl.DataVisualization.DrawingFrame(drawingObject)

' add the frame object to the Drawings collection
textControl1.Drawings.Add(drawingFrame, -1)
drawingFrame.Activate()

When clicking a shape name in the main menu Insert -> Shapes while the drawing canvas is active, the mouse can be used to draw the shape on the activated drawing canvas.

[C#]
// create new Shape object from selected menu item text string
TXTextControl.Drawing.Shape newShape = new TXTextControl.Drawing.Shape(
    (ShapeType)Enum.Parse(typeof(ShapeType), ((MenuItem)sender).Header.ToString()));

// add Shape object to drawing canvas
((TXTextControl.WPF.Drawing.TXDrawingControl)
 textControl1.Drawings.GetActivatedItem().Drawing)
    .Shapes.Add(newShape, ShapeCollection.AddStyle.MouseCreation);
[Visual Basic]
' create new Shape object from selected menu item text string
Dim newShape As New TXTextControl.Drawing.Shape(DirectCast([Enum].Parse(GetType(ShapeType), DirectCast(sender, MenuItem).Header.ToString()), ShapeType))

' add Shape object to drawing canvas
DirectCast(textControl1.Drawings.GetActivatedItem().Drawing, TXTextControl.WPF.Drawing.TXDrawingControl).Shapes.Add(newShape, ShapeCollection.AddStyle.MouseCreation)


ASP.NET User's Guide

This part describes how to create ASP.NET applications using TX Text Control .NET Server with Microsoft Visual Basic .NET and Microsoft Visual C# .NET.

General Prerequisites

Introduction - Product Information

Document Automation (TXTextControl.ServerTextControl)

Reporting and Mail Merge (DocumentServer.MailMerge)

HTML5 Web Editor (Web.TextControl)

Document Viewer (DocumentServer.Web.DocumentViewer)


General Prerequisites

In order to use the different components and controls of TX Text Control .NET Server for ASP.NET, different prerequisites are required.

Internet Information Server (IIS) needs to be installed in order to run portions of TX Text Control .NET Server for ASP.NET. It can be run on a dedicated server, or by simply activating IIS on a local developer machine. An application can be developed and tested on a single computer, and later moved to a dedicated server. TX Text Control .NET Server for ASP.NET supports IIS, version 7 or higher, running Windows Server 2003, Windows Server 2008, Windows Vista, Windows 7 and Windows 8.

In order to use the HTML5 Web editor (Web.TextControl), IIS 8 is required running on Windows 8 and Windows Server 2012.

Installing IIS on Windows 8

Installing IIS on Windows 7


Installing IIS on Windows 8

If you are running Windows 8 on your computer, you can install the included web server, Internet Information Server 8 (IIS) from the Windows 8 Turn Windows features on or off functionality.

1. Open the Control Panel and choose Turn Windows features on or off found in Programs.

2. Check Internet Information Services leaving all the default installation settings intact. Make sure that the WebSocket Protocol is activated in the World Wide Web Services/Application Development Features node. This step is shown in the screenshot below.

3. Click OK to confirm the changes.


Installing IIS on Windows 7

If you are running Windows 7 on your computer, you can install the included web server, Internet Information Server 7 (IIS) from the Windows 7 installation CD.

1. Place the Windows 7 CD-ROM into your CD-ROM drive.

2. Open the Control Panel and choose Turn Windows features on or off found in Programs and Features.

3. Check Internet Information Services leaving all the default installation settings intact. This step is shown in the screenshot below.

4. Click OK to confirm the changes.


Introduction - Product Information

TX Text Control .NET Server for ASP.NET is a fully programmable reporting and word processing engine for deployment in an ASP.NET server environment. It has primarily been designed to centralize reporting and word processing processes in Web-, Server- and Service-based applications.

TX Text Control .NET Server for ASP.NET brings together the required tools with a comprehensive API to create reporting and word processing applications. The following diagram illustrates the included features, supported platforms, available components and interoperability with optional products from Text Control.

Main Features and Typical Applications

Main classes of TX Text Control .NET Server for ASP.NET

Demos in Product Installation


Main Features and Typical Applications

TX Text Control .NET Server for ASP.NET can be used in applications targeting a variety of functionality including reporting and mail merge.

Typical Applications

Feature | Description
Reporting and Mail Merge | Text Control Reporting combines the power of a reporting tool and an easy-to-use WYSIWYG word processor - fully programmable and embeddable in your .NET application. It supports master-detail, table and mail-merge reports. The advantage of Text Control Reporting - in addition to the flow type layout reporting features - is the compatible reporting engine. You can deploy your applications to Windows Forms, WPF and ASP.NET without rewriting your code or recreating the report templates. The .NET component MailMerge can be easily instantiated in all types of .NET applications: Web services, Windows services, ASP.NET Web applications, Windows Forms or WPF Windows applications. The mail merge process is invisible to the end-user and can be done in background tasks as well as in UI applications.
Document Automation | Create, convert and modify MS Word documents in server applications. Automates document generation and PDF creation processes. Reporting and Mail Merge have become commonly used terms for automated document generation such as business reports, invoices or shipping papers. Developers and systems architects must find a fast and reliable way to automate documents for business critical processes. Using TX Text Control .NET Server for ASP.NET, you get a fully programmable API to manipulate and print documents without any third-party requirements such as Microsoft Office.
Browser WYSIWYG Document Editing and Template Creation | A WYSIWYG reporting template editor based on a word processing interface. Merge rich text documents with various data sources, create and publish reports. This concept allows developers to deploy a reporting system where end-users are able to create and modify MS Word compatible templates across all platforms, devices and browsers. This editor doesn't require any client-side browser plug-ins, but pure HTML5 and Javascript. Zero footprint - no plug-ins.


Main classes of TX Text Control .NET Server for ASP.NET

TX Text Control .NET Server for ASP.NET contains the following components and controls that are designed for Microsoft Visual Studio:

Non-Visual Classes

Class | Description
TXTextControl.ServerTextControl (TXTextControl.Server.dll) | The ServerTextControl class implements a component that provides high-level text processing features for server-based applications. It is inherited from the System.ComponentModel.Component class. This class can be used to create, load, modify and save documents in various industry standard word processing formats.
DocumentServer.MailMerge (TXDocumentServer.dll) | The MailMerge class is a .NET component that can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET Web applications, Web services or Windows services.
DocumentServer.DocumentController (TXDocumentServer.dll) | The DocumentController class is a .NET component that is be used to perform server-side document handling when using the DocumentServer.Web.DocumentViewer.

Visual Classes

Class | Description
TXTextControl.Web.TextControl (TXTextControl.Web) | The TextControl class implements an HTML5 based Web control with high-level text editing features. It is inherited from the System.Web.UI.WebControls.WebControl class.
DocumentServer.Web.DocumentViewer (TXDocumentServer.dll) | The DocumentViewer class is a .NET component that can be used to display documents in the Web browser in ASP.NET projects.


Demos in Product Installation

The installation of TX Text Control .NET Server for ASP.NET comes with a set of sample applications that provide an overview of all features and typical applications.

To see those demos in action, start the Help Center which is accessible in the Start menu (All Programs / TX Text Control 24.0.NET Server for ASP.NET / Help Center). From there navigate to Getting Started / Open Samples and choose the product TX Text Control .NET Server for ASP.NET. Or open the samples directly in your sample installation path (default: %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\).

Documentation Tutorial Samples

Each main application has a tutorial sample projects that are located here:

C#: %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\ServerTextControl\

VB.NET: %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\ServerTextControl\

The Sample Explorer - All Samples in One

All other samples are bundled in a Sample Explorer that contains all samples in one. That makes it easier for you to browse through the different classes and functionality and to get a quick overview of the overall typical applications for TX Text Control .NET Server for ASP.NET.

The Sample Explorer project sources can be found here:

C#: %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\

VB.NET: %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\


Document Automation (TXTextControl.ServerTextControl)

The ServerTextControl class implements a component that provides high-level text processing features for server-based applications. It is inherited from the System.ComponentModel.Component class. This class can be used to create, load, modify and save documents in various industry standard word processing formats.

Typical applications for ServerTextControl are document creation, conversion and automation processes. Whenever documents are created server-side or MS Office Automation should be replaced, the ServerTextControl component can be used.

Getting Started

Example - Creating an Instance

Example - Loading and Saving

Example - Creating PDF Document


Getting Started

This chapter shows how to create a small ASP.NET application from scratch with just a few lines of code. An instance of ServerTextControl is created, text is inserted, formatted and returned in HTML format.

The source code for this simple example is located in the following directories:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\ServerTextControl\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\ServerTextControl\

Used TX Text Control classes:

  • TXTextControl.ServerTextControl

Creating the application

1. Assuming that you have already run the TX Text Control .NET Server for ASP.NET installation program, start Visual Studio and create a new ASP.NET Web Application.

2. Choose Add New Item... from the Project main menu. In the opened dialog box Add New Item, select Web Form and confirm with OK.

In order to add non-visual components such as ServerTextControl to the Web form, the Component Designer surface of the ASPX page must be opened.

3. Select the newly created Web form in the Solution Explorer and choose Component Designer from the View main menu. Find the ServerTextControl in your Toolbox and drag and drop an instance onto the Component Designer view.

4. Open the Designer of the Web form using the Designer menu item of the View main menu. Add a Button control from the Toolbox to the Web form and double-click it to open the code-behind event handler.

Insert the following code to the button click event:

[C#]
using (serverTextControl1)
{
    serverTextControl1.Create();

    serverTextControl1.Text = "TX Text Control .NET Server for ASP.NET";

    TXTextControl.Selection selection = new TXTextControl.Selection(0, 15);
    selection.Bold = true;
    selection.FontSize = 300;

    serverTextControl1.Selection = selection;

    string data;
    serverTextControl1.Save(out data, TXTextControl.StringStreamType.HTMLFormat);
    Response.Write(data);
}
[Visual Basic]
Using serverTextControl1
    serverTextControl1.Create()

    serverTextControl1.Text = "TX Text Control .NET Server for ASP.NET"

    Dim selection As New TXTextControl.Selection(0, 15)
    selection.Bold = True
    selection.FontSize = 300

    serverTextControl1.Selection = selection

    Dim data As String
    serverTextControl1.Save(data, TXTextControl.StringStreamType.HTMLFormat)
    Response.Write(data)
End Using

In the same Code view, call the InitializeComponent() in the Page_Load event:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    InitializeComponent();
}
[Visual Basic]
Protected Sub Page_Load(sender As Object, e As EventArgs)
    InitializeComponent()
End Sub

Press F5 to compile and start the application. After clicking the button, the TX Text Control .NET Server creates the document and returns HTML text.

ServerTextControl should be used in a Using statement as an explicit object disposing is required.


Example - Creating an Instance

ServerTextControl is a non-UI .NET component that can be initialized in all .NET based applications.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Basics\create.aspx

Example description

1. Click the button "Create ServerTextControl" to create an instance of ServerTextControl.

On the button click event, a new ServerTextControl instance is created. Formatted text is inserted using the Selection object and saved as HTML which is returned to a DIV element.

[C#]
protected void Button1_Click(object sender, EventArgs e)
{
    // create a new instance of ServerTextControl
    using (TXTextControl.ServerTextControl tx =
        new TXTextControl.ServerTextControl())
    {
        // ServerTextControl must be "created"
        tx.Create();
        tx.Text = "TX Text Control .NET Server for ASP.NET\r\nThis HTML text " +
            "has been created by ServerTextControl at " +
            DateTime.Now.ToString() + ".";

        // create a new selection and apply some formatting
        TXTextControl.Selection selection = new TXTextControl.Selection(0, 15);
        selection.Bold = true;
        selection.ForeColor = Color.Red;

        // apply the selection to the ServerTextControl instance
        tx.Selection = selection;

        // save the content as HTML
        string sHTML;
        tx.Save(out sHTML, TXTextControl.StringStreamType.HTMLFormat);

        htmldiv.InnerHtml = sHTML;
    }
}
[Visual Basic]
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ' create a new instance of ServerTextControl
    Using tx As New TXTextControl.ServerTextControl()
        ' ServerTextControl must be "created"
        tx.Create()
        tx.Text = "TX Text Control .NET Server for ASP.NET" & _
            vbCr & vbLf & "This HTML text " + _
            "has been created by ServerTextControl at " + _
            DateTime.Now.ToString() + "."

        ' create a new selection and apply some formatting
        Dim selection As New TXTextControl.Selection(0, 15)
        selection.Bold = True
        selection.ForeColor = Color.Red

        ' apply the selection to the ServerTextControl instance
        tx.Selection = selection

        ' save the content as HTML
        Dim sHTML As String
        tx.Save(sHTML, TXTextControl.StringStreamType.HTMLFormat)

        htmldiv.InnerHtml = sHTML
    End Using
End Sub


Example - Loading and Saving

TX Text Control supports various industry standard document formats such as DOC, DOCX, RTF, HTML, PDF and XML. All of these document formats can be created, converted or modified.

This sample shows how documents can be loaded and saved using ServerTextControl. When clicking on Load DOCX document, a DOCX file is loaded into an instance of ServerTextControl and saved into a byte array to be loaded into the DocumentViewer. The document is converted to PDF when the second button Download as PDF is clicked.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Basics\loadsave.aspx

Example description

1. Click the button Load DOCX document in order to load a sample document into the ASP.NET DocumentViewer.

The used DocumentViewer is part of TX Text Control .NET Server for ASP.NET and can be used to view documents in read-only mode. The DOCX document is loaded into an instance of ServerTextControl. To show the variety of saving options, this demo saves the document as a byte array into a memory variable which is then loaded into the DocumentViewer.

[C#]
protected void Button1_Click(object sender, EventArgs e)
{
    // create a new instance of ServerTextControl
    using (TXTextControl.ServerTextControl tx =
        new TXTextControl.ServerTextControl())
    {
        // load the document
        tx.Create();
        tx.Load(Server.MapPath("/documents/sample.docx"),
            TXTextControl.StreamType.WordprocessingML);

        // save the document in the internal format to a byte array
        byte[] data;
        tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);

        // load the byte array into the read-only DocumentViewer
        DocumentViewer1.LoadDocumentFromMemory(data,
            TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);
    }

    btn_DownloadDocument.Visible = true;
}
[Visual Basic]
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ' create a new instance of ServerTextControl
    Using tx As New TXTextControl.ServerTextControl()
        ' load the document
        tx.Create()
        tx.Load(Server.MapPath("/documents/sample.docx"), TXTextControl.StreamType.WordprocessingML)

        ' save the document in the internal format to a byte array
        Dim data As Byte()
        tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)

        ' load the byte array into the read-only DocumentViewer
        DocumentViewer1.LoadDocumentFromMemory(data, TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)
    End Using

    btn_DownloadDocument.Visible = True
End Sub

2. Click the button Download as PDF to download the loaded document as a PDF document.

The document is again loaded into an instance of ServerTextControl and then saved to memory into a byte array in the Adobe PDF format. This byte array is returned to the browser as a file download.

[C#]
protected void Button2_Click(object sender, EventArgs e)
{
    byte[] data;

    // create a new instance of ServerTextControl and load the document
    using (TXTextControl.ServerTextControl tx =
        new TXTextControl.ServerTextControl())
    {
        tx.Create();
        tx.Load(Server.MapPath("/documents/sample.docx"),
            TXTextControl.StreamType.WordprocessingML);

        // save the document as PDF into a byte array
        tx.Save(out data, TXTextControl.BinaryStreamType.AdobePDF);
    }

    // return the document to the browser for download
    Response.Clear();
    Response.AddHeader("content-disposition",
        String.Format("attachment;filename={0}", "created_by_txtextcontrol.pdf"));
    Response.ContentType = "application/pdf";
    Response.BinaryWrite(data);
    Response.End();
}
[Visual Basic]
Protected Sub Button2_Click(sender As Object, e As EventArgs)
    Dim data As Byte()

    ' create a new instance of ServerTextControl and load the document
    Using tx As New TXTextControl.ServerTextControl()
        tx.Create()
        tx.Load(Server.MapPath("/documents/sample.docx"), TXTextControl.StreamType.WordprocessingML)

        ' save the document as PDF into a byte array
        tx.Save(data, TXTextControl.BinaryStreamType.AdobePDF)
    End Using

    ' return the document to the browser for download
    Response.Clear()
    Response.AddHeader("content-disposition", [String].Format("attachment;filename={0}", "created_by_txtextcontrol.pdf"))
    Response.ContentType = "application/pdf"
    Response.BinaryWrite(data)
    Response.[End]()
End Sub


Example - Creating PDF Document

TX Text Control .NET Server for ASP.NET includes a powerful PDF engine to create PDF documents in a very fast and reliable manner.

This demo shows how to convert a DOCX document to PDF and how to set various document access permissions using the SaveSettings object.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Basics\pdf.aspx

Example description

1. Check some of the checkboxes and type in a security password for the created Adobe PDF document.

2. Click the button Create PDF.

On clicking the button, a document is loaded into an instance of ServerTextControl. A new set of DocumentAccessPermissions is created that defines the access permissions of the PDF document. Based on the selected checkboxes, these settings are adjusted and passed to the Save method in the SaveSettings parameter.

Finally, the created PDF document is returned as a file download to the browser.

[C#]
protected void btnCreate_Click(object sender, EventArgs e)
{
    // create a new instance of ServerTextControl
    using (TXTextControl.ServerTextControl tx =
        new TXTextControl.ServerTextControl())
    {
        tx.Create();

        // load the sample document
        tx.Load(Server.MapPath("/documents/sample.docx"),
            TXTextControl.StreamType.WordprocessingML);

        TXTextControl.SaveSettings saveSettings = new TXTextControl.SaveSettings();

        // set the document access permissions based on the checkboxes
        TXTextControl.DocumentAccessPermissions permissions =
            new TXTextControl.DocumentAccessPermissions();

        if (cbAllowHighLevelPrinting.Checked == true)
            permissions =
                TXTextControl.DocumentAccessPermissions.AllowHighLevelPrinting;

        if (cbAllowDocumentAssembly.Checked == true)
            permissions = permissions |
                TXTextControl.DocumentAccessPermissions.AllowHighLevelPrinting;

        if (cbAllowExtractContents.Checked == true)
            permissions = permissions |
                TXTextControl.DocumentAccessPermissions.AllowExtractContents;

        if (cbAllowGeneralEditing.Checked == true)
            permissions = permissions |
                TXTextControl.DocumentAccessPermissions.AllowGeneralEditing;

        saveSettings.DocumentAccessPermissions = permissions;

        saveSettings.MasterPassword = tbPassword.Text;
        saveSettings.UserPassword = tbPassword.Text;

        // save the document as PDF in a byte array
        byte[] data;
        tx.Save(out data, TXTextControl.BinaryStreamType.AdobePDF, saveSettings);

        // return the document to the browser for download
        Response.Clear();
        Response.AddHeader("content-disposition",
            String.Format("attachment;filename={0}", "txtextcontrol.pdf"));
        Response.ContentType = "application/pdf";
        Response.BinaryWrite(data);
        Response.End();
    }
}
[Visual Basic]
Protected Sub btnCreate_Click(sender As Object, e As EventArgs)
    ' create a new instance of ServerTextControl
    Using tx As New TXTextControl.ServerTextControl()
        tx.Create()

        ' load the sample document
        tx.Load(Server.MapPath("/documents/sample.docx"), TXTextControl.StreamType.WordprocessingML)

        Dim saveSettings As New TXTextControl.SaveSettings()

        ' set the document access permissions based on the checkboxes
        Dim permissions As New TXTextControl.DocumentAccessPermissions()

        If cbAllowHighLevelPrinting.Checked = True Then
            permissions = TXTextControl.DocumentAccessPermissions.AllowHighLevelPrinting
        End If

        If cbAllowDocumentAssembly.Checked = True Then
            permissions = permissions Or TXTextControl.DocumentAccessPermissions.AllowHighLevelPrinting
        End If

        If cbAllowExtractContents.Checked = True Then
            permissions = permissions Or TXTextControl.DocumentAccessPermissions.AllowExtractContents
        End If

        If cbAllowGeneralEditing.Checked = True Then
            permissions = permissions Or TXTextControl.DocumentAccessPermissions.AllowGeneralEditing
        End If

        saveSettings.DocumentAccessPermissions = permissions

        saveSettings.MasterPassword = tbPassword.Text
        saveSettings.UserPassword = tbPassword.Text

        ' save the document as PDF in a byte array
        Dim data As Byte()
        tx.Save(data, TXTextControl.BinaryStreamType.AdobePDF, saveSettings)

        ' return the document to the browser for download
        Response.Clear()
        Response.AddHeader("content-disposition", [String].Format("attachment;filename={0}", "txtextcontrol.pdf"))
        Response.ContentType = "application/pdf"
        Response.BinaryWrite(data)
        Response.[End]()
    End Using
End Sub


Reporting and Mail Merge (DocumentServer.MailMerge)

Text Control Reporting combines the power of a reporting tool and powerful word processing functionality - fully programmable and embeddable in your ASP.NET application.

Fundamental Concepts

Getting Started

Example - Creating a Simple Mail-Merge Letter Report

Example - Creating a Table Report

Example - Creating a Master-Detail Report

Use Case - Expense Report


Fundamental Concepts

Text Control Reporting is a reporting framework that can be used with all .NET based TX Text Control classes. Text Control Reporting is included in all TX Text Control .NET versions: Windows Forms, WPF and ASP.NET. Universal fundamental concepts, report types and supported merge field types are described in the Reporting User's Guide.

TX Text Control Reporting User's Guide


Getting Started

This getting started tutorial shows how to use the Template Designer TX Text Control Words with a sample template and database and illustrates how to integrate the merging process into your ASP.NET Web application.

The source code for this simple example is located in the following directories:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\MailMerge\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\MailMerge\

Used TX Text Control classes:

  • TXTextControl.ServerTextControl
  • DocumentServer.MailMerge

Create your application

1. Open Visual Studio and create a new ASP.NET Empty Web Application application.

2. In the Solution Explorer, select the project and choose Add New Item... from the Project main menu.

In the opened dialog Add New Item, select Web Form and confirm with Add.

3. In the Solution Explorer, select the newly created Web Form and choose Component Designer from the View main menu.

Find the MailMerge component in the Toolbox and drag and drop an instance onto the Component Designer form.

Repeat this step with the ServerTextControl component.

4. Select the MailMerge component and set the TextComponent property to serverTextControl1 - the name of the inserted instance of ServerTextControl.

5. While the project is selected in the Solution Explorer, choose Add Existing Item... from the Project main menu.

In the opened dialog Add Existing Item, browse to the following sample folder:

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\MailMerge\Tutorial\

or

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\MailMerge\Tutorial\

Select the following 2 files: template.docx and sample_db.xml and click the Add button.

6. Select the Web Form in the Solution Explorer and choose Designer from the View main menu.

Find the Button control in the Toolbox and drag and drop an instance onto the Web Form.

7. Double-click the button and insert the following code to the event handler:

[C#]
protected void Button1_Click(object sender, EventArgs e)
{
    // create a DataSet from the sample XML data source
    System.Data.DataSet ds = new System.Data.DataSet();
    ds.ReadXml(Server.MapPath("sample_db.xml"), System.Data.XmlReadMode.Auto);

    // load the template
    mailMerge1.LoadTemplate(Server.MapPath("template.docx"),
        TXTextControl.DocumentServer.FileFormat.WordprocessingML);

    // merge the template with data
    mailMerge1.Merge(ds.Tables[0]);

    // save the document as PDF into a byte array
    byte[] data;
    mailMerge1.SaveDocumentToMemory(out data, TXTextControl.BinaryStreamType.AdobePDF, null);

    // return the document to the browser for download
    Response.Clear();
    Response.AddHeader("content-disposition",
        String.Format("attachment;filename={0}", "created_by_txtextcontrol.pdf"));
    Response.ContentType = "application/pdf";
    Response.BinaryWrite(data);
    Response.End();
}
[Visual Basic]
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ' create a DataSet from the sample XML data source
    Dim ds As New System.Data.DataSet()
    ds.ReadXml(Server.MapPath("sample_db.xml"), System.Data.XmlReadMode.Auto)

    ' load the template
    mailMerge1.LoadTemplate(Server.MapPath("template.docx"), TXTextControl.DocumentServer.FileFormat.WordprocessingML)

    ' merge the template with data
    mailMerge1.Merge(ds.Tables(0))

    ' save the document as PDF into a byte array
    Dim data As Byte()
    mailMerge1.SaveDocumentToMemory(data, TXTextControl.BinaryStreamType.AdobePDF, Nothing)

    ' return the document to the browser for download
    Response.Clear()
    Response.AddHeader("content-disposition", [String].Format("attachment;filename={0}", "created_by_txtextcontrol.pdf"))
    Response.ContentType = "application/pdf"
    Response.BinaryWrite(data)
    Response.[End]()
End Sub

8. In the same code view, add the following code to the Page_Load event:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    InitializeComponent();
}
[Visual Basic]
Protected Sub Page_Load(sender As Object, e As EventArgs)
    InitializeComponent()
End Sub

Compile and start the application. Press the button to create the report that is returned as a PDF file.


Example - Creating a Simple Mail-Merge Letter Report

The class MailMerge encapsulates typical reporting tasks and can be connected to an instance of ServerTextControl. A template is simply loaded and data is passed from a DataSet, DataTable or an IEnumerable object. All merge fields and merge blocks are populated automatically using existing data relations.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Reporting\create.aspx

Example description

In this demo, a MailMerge instance is connected to a ServerTextControl to create a simple report. A Mail-Merge report is a fully featured word processing document with merge fields, image placeholders or barcodes that is merged with data from one or many data sources.

For this demo, the data source, that contains merge field data such as address details, is an IEnumerable object.

This business object is created based on data that is completed using HTML form fields. Change the pre-populated field values and click Create Report to start the merge process.

A template is loaded into an instance of MailMerge. The created business object is used as the data source in the MergeObjects method. The created document is finally loaded into the UI component DocumentViewer.

[C#]
protected void btnCreateReport_Click(object sender, EventArgs e)
{
    // build a data object for the merge process
    Reports.Add(CreateBusinessObject());

    // load the template
    mailMerge1.LoadTemplate(Server.MapPath("/documents/template.docx"),
        TXTextControl.DocumentServer.FileFormat.WordprocessingML);

    // merge the template with the IEnumerable business object
    mailMerge1.MergeObjects(Reports, true);

    // save the document to memory for preview purposes
    // in the DocumentViewer
    mailMerge1.SaveDocumentToMemory(out data,
        TXTextControl.BinaryStreamType.InternalUnicodeFormat, null);
    DocumentViewer1.LoadDocumentFromMemory(data,
        TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);

    btn_DownloadReport.Visible = true;
}
[Visual Basic]
Protected Sub btnCreateReport_Click(sender As Object, e As EventArgs)
    ' build a data object for the merge process
    Reports.Add(CreateBusinessObject())

    ' load the template
    mailMerge1.LoadTemplate(Server.MapPath("/documents/template.docx"), _
        TXTextControl.DocumentServer.FileFormat.WordprocessingML)

    ' merge the template with the IEnumerable business object
    mailMerge1.MergeObjects(Reports, True)

    ' save the document to memory for preview purposes
    ' in the DocumentViewer
    mailMerge1.SaveDocumentToMemory(data, _
        TXTextControl.BinaryStreamType.InternalUnicodeFormat, Nothing)
    DocumentViewer1.LoadDocumentFromMemory(data, _
        TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)

    btn_DownloadReport.Visible = True
End Sub


Example - Creating a Table Report

Table reports display 1-dimensional, not hierarchical data in tabular form. Typically, the data that is used to merge a table report is stored in a single DataTable. Typically, this concept is used to present product lists, check lists or inventory items in a flat table form.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Reporting\table.aspx

Example description

The data source in this sample is the same sample database that is used in the tutorial. The used template consists of a table that is part of a merge block. This block is repeated based on the number of data rows. The table itself contains two data rows with the same merge fields and a NEXT field at the end. With this setup, alternating table row colors are enabled.

Uncheck some of the listed company names in the GridView control and click Create table report to start the merge process. Only the selected company names are added to the resulting table report which is returned as a PDF file.


Example - Creating a Master-Detail Report

A Master-Detail report renders data from a hierarchical data source such as related tables or nested objects.

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Reporting\masterdetail.aspx

Example description

Nested related tables are recognized automatically and merged based on the merge block names in the template. The following report lists all sales and the sold products for each sale. Each sale is rendered on a new page in the final report.

Click on the button Create report to start the merge process.

The sample database from the tutorial is used in this sample as well. The template consists of a table with 3 rows. The last row is a merge block (indicated through the red overlay background color) that should list all products.

The complete template is repeated based on the number rows of the master table. The master table is passed in the Merge method and TX Text Control is matching the related tables automatically.

The resulting document is loaded into a DocumentViewer instance on the ASPX page.

[C#]
protected void btn_CreateReport_Click(object sender, EventArgs e)
{
    // open the sample XML file and create DataSet
    DataSet ds = new DataSet();
    ds.ReadXml(Server.MapPath("/datasource/sample_db.xml"), XmlReadMode.Auto);

    // load the template
    mailMerge1.LoadTemplate(Server.MapPath("/documents/template_master.docx"),
        TXTextControl.DocumentServer.FileFormat.WordprocessingML);

    // pass the master table to start the merge process
    mailMerge1.Merge(ds.Tables["Sales_SalesOrderHeader"]);

    byte[] data;

    // save the document to memory as PDF
    mailMerge1.SaveDocumentToMemory(out data,
        TXTextControl.BinaryStreamType.InternalUnicodeFormat, null);

    DocumentViewer2.LoadDocumentFromMemory(data,
        TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);

    // store document for a later download
    Session["data"] = data;
    btnDownloadPDF.Visible = true;
}
[Visual Basic]
Protected Sub btn_CreateReport_Click(sender As Object, e As EventArgs)
    ' open the sample XML file and create DataSet
    Dim ds As New DataSet()
    ds.ReadXml(Server.MapPath("/datasource/sample_db.xml"), XmlReadMode.Auto)

    ' load the template
    mailMerge1.LoadTemplate(Server.MapPath("/documents/template_master.docx"), _
        TXTextControl.DocumentServer.FileFormat.WordprocessingML)

    ' pass the master table to start the merge process
    mailMerge1.Merge(ds.Tables("Sales_SalesOrderHeader"))

    Dim data As Byte()

    ' save the document to memory as PDF
    mailMerge1.SaveDocumentToMemory(data, _
        TXTextControl.BinaryStreamType.InternalUnicodeFormat, Nothing)

    DocumentViewer2.LoadDocumentFromMemory(data, _
        TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)

    ' store document for a later download
    Session("data") = data
    btnDownloadPDF.Visible = True
End Sub


Use Case - Expense Report

This demo shows a master-detail report use case with a business object as the data source. The template contains master data (the purpose of the expense report, dates), employee information and the expenses in form of a table (detail information).

This example is part the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: Reporting\expenses.aspx

Example description

Simply Select a report from the GridView and click on Create report to start the merge process.

An expense report contains general data such as the purpose of the expense, the pay period and a statement number. Additionally, it should list the employee details and finally, the expenses itself. The class diagram of the business object is illustrated below:

  • Expenses: This is an IEnumerable wrapper object for the separate Expense reports. This object is passed to Text Control Reporting.
  • Expense: The expense report itself.
  • Employee: Information about the employee referenced in Expense.
  • LineItem: Details of each expense referenced in Expense.

The business object Expenses has some useful features. It contains XML Serialization attributes which allows us to use an XML data source that is deserialized into the business object automatically.

[C#]
[XmlType("expenses", IncludeInSchema = true)]
public class Expenses : List<Expense>
{
    [XmlElement("expense")]
    public List<Expense> expenses { get; set; }
}

//...
[Visual Basic]
<XmlType("expenses", IncludeInSchema := True)> _
Public Class Expenses
    Inherits List(Of Expense)
    <XmlElement("expense")> _
    Public Property expenses() As List(Of Expense)
        Get
            Return m_expenses
        End Get
        Set
            m_expenses = Value
        End Set
    End Property
    Private m_expenses As List(Of Expense)
End Class
'...

The attributes define which XML element is mapped to which member of the object. An XmlSerializer is used to deserialize the XML in order to create a new instance of the business object.

[C#]
XmlSerializer serializer = new XmlSerializer(typeof(Expenses));
Expenses expenses = (Expenses)serializer.Deserialize(
    new StreamReader("expense_report_data.xml"));
[Visual Basic]
Dim serializer As New XmlSerializer(GetType(Expenses))
Dim expenses As Expenses = DirectCast(serializer.Deserialize( _
    New StreamReader("expense_report_data.xml")), Expenses)

Additionally, we don't need to store all values in our XML file (or database in real life applications). The business object contains the logic and the code to calculate specific field values internally. All inverted members in the above illustration are not imported from the XML, but calculated on the fly in the business object itself.

The following code shows how the Total value is calculated based on existing values:

[C#]
public double Total
{
    get
    {
        double dTotal = 0;

        foreach (LineItem item in this.LineItems)
        {
            dTotal += item.line_total;
        }

        return dTotal - this.Advances;
    }
}
[Visual Basic]
Public ReadOnly Property Total() As Double
    Get
        Dim dTotal As Double = 0

        For Each item As LineItem In Me.LineItems
            dTotal += item.line_total
        Next

        Return dTotal - Me.Advances
    End Get
End Property

In order to start the merge process itself, only 1 line of code is required:

[C#]
mailMerge1.MergeObjects(expenses);
[Visual Basic]
mailMerge1.MergeObjects(expenses)

Text Control's Reporting engine MailMerge is mapping the merge fields to the business object members and related objects automatically.


HTML5 Web Editor (Web.TextControl)

The HTML5 Web Editor is an ASP.NET server control that allows the integration of a fully-featured WYSIWYG word processor and template designer in ASP.NET Web applications.

System Requirements

Technical Considerations - The Concept Explained

Typical Applications - When to use it?

Fundamental Concepts: Loading and Saving Documents

Fundamental Concepts: The Data Source

Fundamental Concepts: Creating Templates

Fundamental Concepts: Programming API

Getting Started with ASP.NET Web Forms

Getting Started with ASP.NET MVC Razor

Example - Full Screen Editor

Example - Embedded Editor

Example - Loading and Saving

Example - Merging Templates

Example - Customize RibbonBar

Example - Customize Toolbars

Example - Programming API

Redistribution and Deployment


System Requirements

TX Text Control .NET Server for ASP.NET requires one of the following Windows versions:

  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows Server 2012
  • Windows Server 2012 R2

The following development environments are supported by TX Text Control .NET Server for ASP.NET:

  • Visual Studio 2012
  • Visual Studio 2013
  • Visual Studio 2015

The following .NET Frameworks are required to use the HTML5 Web Editor:

  • .NET 4.5

The following browsers have been tested and are officially supported (older and newer versions might work without any problems):

  • Firefox 31.0
  • Chrome 36.0
  • Safari 5.0
  • Internet Explorer 10 and 11
  • Microsoft Edge

Additionally, Internet Information Services (IIS) 8.0 or 8.5 (Windows Server 2012 R2) is required.


Technical Considerations - The Concept Explained

True WYSIWYG - server document synchronization

The HTML5 Web Editor consists of two parts: The ASP.NET server control Web.TextControl that provides the client-interface and user experience and the TX Text Control Web Server running as a Windows Service hosted on a Web server. The TX Text Control Web Server engine is used to synchronize the document with the server in order to provide a consistent WYSIWYG text rendering.

Zero footprint - no plug-ins

The client side control is completely based on HTML5 and Javascript and doesn't require any client-side plug-ins. No browser or system security settings are required to run the control. The end-user does not need to confirm any downloads or settings and requires only an HTML5-enabled browser such as Firefox, Chrome, Safari or Internet Explorer.

Users want to seamlessly access and share content with others without any limitations when it comes to devices, hardware or software. A zero footprint editor addresses those requirements using the client-server visualization and synchronization architecture and uses the standard, modern browsers to enable editing in real-time.

  • Zero installation: No application, plug-in or applet must be installed on the client. The native browser and the integrated hardware-accelerated HTML5 Canvas is enough to provide the editing capabilities.
  • No requirements: There are no OS specific requirements for the HTML5 Web Editor that uses the browser to provide the optimal view and editing capabilities.
  • Document streaming: The document itself won't be downloaded to the client. Built on a streaming concept, it loads content on-demand, instead of downloading the complete document. This enables users to access documents with hundreds of pages at the same performance like for smaller documents.

Supported file formats

In contrast to HTML-based editors, the documents do not need to be converted to HTML for editing. HTML is limited and doesn't provide page-oriented features such as headers and footers or sections. Using the TX Text Control HTML5 Web Editor, documents of all supported formats such as DOC, RTF, DOCX, HTML or PDF can be directly loaded and edited. It gives end-users a consistent, MS Word-like interface for all document types and platforms. The HTML5 Web Editor provides the same user experience like TX Text Control for other platforms including Windows Forms and WPF. This enables developers to provide the same look and feel for Windows and ASP.NET Web applications.

Security considerations - Secure your documents

Security is a major concern when editing documents on the Internet. Web.TextControl supports the Secure Sockets Layer (SSL) to provide communication security. Additionally, thanks to the client-server visualization and synchronization architecture, the document is never available client-side. If not required, the user has no access to the content of the document and the document doesn't exist client-side. This enables developers to provide a secure interface to manipulate highly confidential documents in browsers without sending those documents and the content using the Internet.


Typical Applications - When to use it?

The HTML5 Web Editor is used in all types of applications where documents and templates are being created. The MS Word-like interface gives users a consistent and well known user experience.

Reporting and mail merge template creation

The most typical application is the creation of templates for the Text Control Reporting engine DocumentServer.MailMerge. The ribbon tab Reports is designed to insert merge fields and merge blocks compatible to the reporting classes of TX Text Control.

Conventional banded report designers are complex - Text Control reporting is easy to understand and thanks to WYSIWYG, the template is rendered exactly the same like on paper or in an Adobe PDF. This concept allows developers to deploy a reporting system where end-users are able to create and modify MS Word compatible templates across all platforms, devices and browsers.

The following illustration gives an overview of the typical process: Templates are created in Windows or Web applications, stored and merged on a server using the Text Control Reporting engine DocumentServer.MailMerge. Resulting documents can be exported to Adobe PDF or all other supported formats, printed and displayed in a browser.

Online document editing

Create, modify and access your documents wherever you go — simply using a browser. Integrate a true WYSIWYG word processor into your ASP.NET Web applications and provide your users an MS Word-like interface to edit documents.

In combination with the non-UI component ServerTextControl, you can prepare documents in 'code-behind', present it to your users and process the final document in your application. Pre-populate merge fields, let the user modify the resulting document online and create an Adobe PDF document on your server. The possibilities are endless once you start using it.


Fundamental Concepts: Loading and Saving Documents

Documents can be easily loaded in the ASP.NET code-behind code using the Web.TextControl.LoadText and Web.TextControl.SaveText methods that accepts file names, FileStreams and memory variables such as byte and string arrays.

To load a document from a physical file, the following code is required:

[C#]
TextControl1.LoadText(Server.MapPath("/documents/sample.docx"),
    TXTextControl.Web.StreamType.WordprocessingML);
[Visual Basic]
TextControl1.LoadText(Server.MapPath("/documents/sample.docx"), _
    TXTextControl.Web.StreamType.WordprocessingML)

In order to save a document, the SaveText method is used:

[C#]
TextControl1.SaveText(Server.MapPath("/output/" + sFilename),
    TXTextControl.Web.StreamType.WordprocessingML);
[Visual Basic]
TextControl1.SaveText(Server.MapPath("/output/" + sFilename), _
    TXTextControl.Web.StreamType.WordprocessingML)

Web.TextControl must be initialized completely in order to accept LoadText calls. Therefore, it exposes another Load method: Web.TextControl.LoadTextAsync. This method loads the text asynchronously when the HTML5 Web Editor is initialized and loaded completely.

In order to load a document in the Page_Load event of an ASPX Web Form, the following code is used:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    TextControl1.LoadTextAsync(Server.MapPath("/documents/template.docx"),
        TXTextControl.Web.StreamType.WordprocessingML);
}
[Visual Basic]
Protected Sub Page_Load(sender As Object, e As EventArgs)
    TextControl1.LoadTextAsync(Server.MapPath("/documents/template.docx"), _
        TXTextControl.Web.StreamType.WordprocessingML)
End Sub

Web.TextControl is updated and synchronized with the server automatically using the Web Sockets protocol. In case, you want to use other server-side (runat="server") elements such as buttons on the same form, make sure that they are embedded in an AJAX UpdatePanel and doesn't post back the complete page. A typical body would look like this:

<body>
 <form id="form1" runat="server">
  <div>
   <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>
   <asp:UpdatePanel ID="UpdatePanel1" runat="server">
    <ContentTemplate>
     <asp:Button ID="Button1" runat="server" Text="Load Document" />
    </ContentTemplate>
   </asp:UpdatePanel>
   <cc1:TextControl ID="TextControl1" runat="server" />
  </div>
 </form>
</body>

Loading and saving documents is shown in detail in the Sample Explorer that is explained in the article Example - Loading and Saving.


Fundamental Concepts: The Data Source

The most typical application is the creation of templates for the Text Control Reporting engine DocumentServer.MailMerge. The ribbon tab Reports is designed to insert merge fields and merge blocks compatible to the reporting classes of TX Text Control.

The drop-down buttons Select Master Table, Insert Merge Field and Insert Merge Block are pre-filled with items of a specific Database Excerpt XML file that can be loaded programmatically.

This XML database file contains table definitions, relations and row excerpts to provide a preview of the report. This XML file can be easily created using the Windows version of the template designer TX Text Control Words. To create such an XML file, follow the next easy steps:

1. Open TX Text Control Words that is located in your Windows start menu or start screen

2. Open the Reports tab and choose Data Source from the Data Source drop-down button.

4. Follow the next steps and instructions of the Choose Data Source dialog to open your preferred data source.

5. If your data source has been added successfully, you can save the excerpt using the Save Excerpt menu item of the Data Source drop-down button. In the opened dialog Save Data Base Excerpt, select the root table and set the maximum number of exported rows. Then select an export file name and confirm with OK.

6. This XML file can be loaded using the LoadXMLDatabase method of Web.TextControl:

[C#]
TextControl1.LoadXMLDatabase("datasource_excerpt.xml");
[Visual Basic]
TextControl1.LoadXMLDatabase("datasource_excerpt.xml")

Additionally, the data source can be also loaded from an XMLDocument or FileStream and a DataSet can be directly loaded using the LoadDataSet method.


Fundamental Concepts: Creating Templates

Once a data source is added, the drop-down buttons are active and pre-filled with the available merge fields, merge blocks and master tables.

1. Select your master table using the drop-down button Select Master Table.

2. Select a merge field from the Insert Merge Field drop-down button to insert the field at the current input position.

Repeat step 2 with all your required fields. Design your template, insert your headers and footers, sections or other document elements as desired.

3. Press the Preview Merge Fields toggle button to preview your template.

4. Save the document in the formats RTF, DOC, DOCX or TX.

This template can be merged using the Text Control Reporting engine DocumentServer.MailMerge. The reporting concept, required classes and examples are explained in the chapter Reporting and Mail Merge (DocumentServer.MailMerge).


Fundamental Concepts: Programming API

The Web.TextControl editor offers an API that helps to manipulate the content programmatically. In combination with a server-side ServerTextControl instance, a Web.Selection object can be edited and passed back the editor.

Additionally, several client-side events are available to interact with merge fields. This allows the insertion and manipulation of merge fields using your own interface.

Server-side API (Selection class)

Server-side, the Web.TextControl provides a Web.Selection object that is used to get and set the current selection in the document. A Selection object is available for each TextPart object including the Web.MainText, Web.TextFrame and Web.HeaderFooter objects.

In order to activate the HeaderFooter of a document, the following code can be used:

[C#]
foreach (IFormattedText textPart in TextControl1.TextParts)
{
    if (textPart.GetType() == typeof(TXTextControl.Web.HeaderFooter))
    {
        TextControl1.TextParts.Activate(textPart);
        break;
    }
}
[Visual Basic]
For Each textPart As IFormattedText In TextControl1.TextParts
    If textPart.[GetType]() = GetType(TXTextControl.Web.HeaderFooter) Then
        TextControl1.TextParts.Activate(textPart)
        Exit For
    End If
Next

The following code shows the combination of the Web.Selection and the ServerTextControl. A new ServerTextControl instance is created and a new MergeField is added to the document. The results are loaded back into the current selection of the Web.TextControl.

[C#]
using (TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl())
{
    tx.Create();

    MergeField newField = new MergeField();
    newField.Name = "TextField1";
    newField.Text = "New TextField";

    tx.ApplicationFields.Add(newField.ApplicationField);

    byte[] data;
    tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);
}
[Visual Basic]
Using tx As New TXTextControl.ServerTextControl()
    tx.Create()

    Dim newField As New MergeField()
    newField.Name = "TextField1"
    newField.Text = "New TextField"

    tx.ApplicationFields.Add(newField.ApplicationField)

    Dim data As Byte()
    tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)
End Using

In order to manipulate a Selection, the content is loaded into a temporary ServerTextControl, manipulated and loaded back into the Web.TextControl. The following code shows how to format an existing range of text:

[C#]
using (TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl())
{
    byte[] data = null;
    TextControl1.Selection.Save(out data, BinaryStreamType.InternalUnicodeFormat);

    tx.Create();
    tx.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);

    tx.SelectAll();
    tx.Selection.Bold = true;

    tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);
}
[Visual Basic]
Using tx As New TXTextControl.ServerTextControl()
    Dim data As Byte() = Nothing
    TextControl1.Selection.Save(data, BinaryStreamType.InternalUnicodeFormat)

    tx.Create()
    tx.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)

    tx.SelectAll()
    tx.Selection.Bold = True

    tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)
End Using

In order to select a range of text in the Web.TextControl, a new Selection object is created and passed to the Selection property.

[C#]
TextControl1.Selection = new Selection(1, 5);
[Visual Basic]
TextControl1.Selection = New Selection(1, 5)

Client-side, Javascript events

In order manipulate merge fields and to provide your own interface to insert and interact with merge fields, client-side Javascript events are available:

Event name | Description
textFieldEntered | Is fired when the input position enters a text field.
textFieldLeft | Is fired when the input position leaves a text field.

These events can be easily attached using Javascript in your ASPX page:

<script>
    TX.addEventListener('textFieldEntered', function (e) {
        fieldEntered(e.fieldName, e.fieldType);
    });

    function fieldEntered(fieldName, fieldType) {
        alert(fieldName);
    }

    TX.addEventListener('textFieldLeft', function (e) {
        fieldLeft();
    });

    function fieldLeft() {
        alert('Field left');
    }
</script>


Getting Started with ASP.NET Web Forms

This tutorial shows how to use the HTML5 based TextControl to create a Web based word processor and template designer. Using the built-in File menu, you can load and save documents from and to a specified folder.

The source code for this simple example is located in the following directories:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\HTML5 Web Editor\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\HTML5 Web Editor\

Used TX Text Control classes:

  • Web.TextControl

Create your application

1. Open Visual Studio and create a new ASP.NET Empty Web Application.

2. In the Solution Explorer, select the project and choose Add New Item... from the Project main menu. In the opened dialog Add New Item, select Web Form and confirm with Add.

3. In the Solution Explorer, select the newly created Web Form and choose Designer from the View main menu.

Find the TextControl component in the Toolbox and drag and drop an instance onto the Designer form.

4. Select TextControl1 on the form and browse for the Dock property in the Properties window and set this to Window.

5. In the Solution Explorer, select the project and choose New Folder from the Project main menu. Type in a name for the folder (e.g. "documents").

6. Select the newly created folder and choose Add Existing Item... from the Project main menu. In the opened dialog box, navigate to the following folder:

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\HTML5 Web Editor\Tutorial\documents

Select all files and and confirm with Add.

7. Repeat the above 2 steps with another folder for the images (e.g. "images"). Sample images can be found in the following directory:

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\HTML5 Web Editor\Tutorial\images

8. Select the Web Form and switch to code view using the Code menu item from the View main menu. Add the following event handler code:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    TextControl1.SetFileDirectoryAsync(Server.MapPath("documents"),
        TXTextControl.Web.FileType.Document);
}
[Visual Basic]
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) _
    Handles Me.Load
        TextControl1.SetFileDirectoryAsync(Server.MapPath("documents"),
            TXTextControl.Web.FileType.Document)
End Sub

9. Compile and start the application.

Using the integrated File ribbon menu, you can load and save documents from and to your specified documents folder.


Getting Started with ASP.NET MVC Razor

This tutorial shows how to integrate TextControl.Web into an MVC application with Razor.

Used TX Text Control classes:

  • Web.MVC.TextControl

Create your application

1. Make sure that you installed at least a trial version of TX Text Control .NET Server for ASP.NET on your development machine.

2. Open Visual Studio and create a new ASP.NET Web Application. Make sure to select .NET Framework 4.5 as the .NET Framework project version.

3. In the next dialog New ASP.NET Project, select Empty as your project template. Check the checkboxes MVC and Web API to add the folders and core references. Close the dialog with OK.

4. Click Manage NuGet Packages... from the Project main menu. Select nuget.org from the Online package source panel. In the upper right corner, search for TXTextControl.Web. Find the latest version and click on Install.

Make sure to update the Microsoft ASP.NET MVC packages, if they are available in the Updates panel. Close the dialog with Close.

5. In the Solution Explorer, select App_Data and choose New Folder from the Project main menu and name the folder Documents. Select the newly created folder Documents and click Add Existing Item... from the Project main menu.

Browse to the following TX Text Control installation folder:

C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET Server for ASP.NET\Samples\Demo\

Select the two files invoice.docx and sample_db.xml and confirm with Add.

6. In the Solution Explorer, select the Controllers folder and choose Add New Item... from the Project main menu. In the opened dialog Add New Item, select MVC 5 Controller - Empty and confirm with Add. Set the name to HomeController and insert it by clicking the Add button.

7. In the Solution Explorer, select the newly created folder Home and choose Add New Item... from the Project main menu. Select MVC 5 View Page (Razor), name it Index and confirm with Add.

8. Open the Index.cshtml view from the Views -> Home folder. Add the following Razor code to the top of the view:

[C#]
@using TXTextControl.Web
@using TXTextControl.Web.MVC

9. Add the following HtmlHelper code to the end of the view page:

[C#]
@Html.TXTextControl().TextControl(settings => {
    settings.DocumentFileDirectory = Server.MapPath("~/App_Data/Documents");
}).LoadXMLDatabase(
    Server.MapPath("~/App_Data/Documents/sample_db.xml")).LoadText(
    Server.MapPath("~/App_Data/Documents/invoice.docx"),
        StreamType.WordprocessingML).Render()

The complete Index.cshtml should now look like this:

[C#]
@using TXTextControl.Web
@using TXTextControl.Web.MVC

@{
    ViewBag.Title = "Index";
}

<h2>Index</h2>

@Html.TXTextControl().TextControl(settings =>
{
    settings.DocumentFileDirectory = Server.MapPath("~/App_Data/Documents");
}).LoadXMLDatabase(
    Server.MapPath("~/App_Data/Documents/sample_db.xml")).LoadText(
    Server.MapPath("~/App_Data/Documents/invoice.docx"),
        StreamType.WordprocessingML).Render()

10. Compile and start the application.


Example - Full Screen Editor

The HTML5 Web Editor has three docking modes: None, Fill and Window. If set to None, the control size itself is used to render the editor. Fill fills the wrapping container and Window fills the complete browser Window. This sample is basically the tutorial that is launched on a button click in the Sample Explorer.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\fullwindow.aspx

Example description

The demo has a simple button Launch editor that opens another Web Form with a Web.TextControl on it.

[C#]
<a target="_blank" href="/HTML5/html5_fullwindowform.aspx"><p class="button_back">Launch editor</p></a>

Click the button Launch editor to open the second Web Form.

The opened Web Form simply contains an instance of the Web.TextControl with the property Dock set to Window to fill the complete Web Form:

[C#]
<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="html5_fullwindowform.aspx.cs"
    Inherits="tx_aspnet_samples.HTML5.html5_fullwindowform" %>

<%@ Register Assembly="TXTextControl.Web,
    Version=24.0.400.500, Culture=neutral,
    PublicKeyToken=6b83fe9a75cfb638" Namespace="TXTextControl.Web" TagPrefix="cc1" %>

<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>

        <cc1:TextControl ID="TextControl1" runat="server" Dock="Window" />

    </div>
    </form>
</body>
</html>


Example - Embedded Editor

The HTML5 Web editor can be embedded in all types of containers such as a DIV element. When the Dock property is set to Fill, the editor fills the wrapping container element automatically.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\embedded.aspx

Example description

This demo shows the default setup of the HTML5 Web editor ASP.NET control for Web Forms. All ribbons, context menus and dialog boxes are coming out-of-the-box and are ready to use.

The Web.TextControl is embedded in a DIV element with a defined size in the style parameter. The Dock property of Web.TextControl is set to Fill to fill the complete container DIV.

[C#]
<div style="height: 600px;" class="sample">
    <cc1:TextControl style="border-bottom: 1px solid #999999;" ID="TextControl1" runat="server" Dock="Fill" />
</div>


Example - Loading and Saving

Documents can be loaded from files on the server, from memory variables or memory streams in various formats including DOC, DOCX, RTF, HTML and the internal TX Text Control format.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\loadingsaving.aspx

Example description

This demo shows how to load files from the server and how to upload and load files from the client.

Loading files asynchronously

When the sample Web Form is opened, a document is loaded automatically asynchronously on the Form_Load event:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
    TextControl1.LoadTextAsync(Server.MapPath("/documents/template.docx"),
        TXTextControl.Web.StreamType.WordprocessingML);
}
[Visual Basic]
Protected Sub Page_Load(sender As Object, e As EventArgs)
    TextControl1.LoadTextAsync(Server.MapPath("/documents/template.docx"), TXTextControl.Web.StreamType.WordprocessingML)
End Sub

Loading server-side files

On clicking the button Load document from file, a document is loaded using the LoadText method:

[C#]
protected void btnLoadFromServer_Click(object sender, EventArgs e)
{
    // load a physical document from the server
    TextControl1.LoadText(Server.MapPath("/documents/sample.docx"),
        TXTextControl.Web.StreamType.WordprocessingML);
}
[Visual Basic]
Protected Sub btnLoadFromServer_Click(sender As Object, e As EventArgs)
    ' load a physical document from the server
    TextControl1.LoadText(Server.MapPath("/documents/sample.docx"), TXTextControl.Web.StreamType.WordprocessingML)
End Sub

Loading files from memory

The button Load document from memory loads a document into the non-UI ServerTextControl that saves the document into a byte array in the internal unicode format. This byte array is then loaded into the Web.TextControl:

[C#]
protected void btnLoadFromServerMemory_Click(object sender, EventArgs e)
{
    // open a document using a temporary instance of ServerTextControl
    // and save it into a byte array
    // load the document from the byte array into the Web editor
    using (TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl())
    {
        tx.Create();
        TXTextControl.LoadSettings ls = new TXTextControl.LoadSettings();
        ls.ApplicationFieldFormat = TXTextControl.ApplicationFieldFormat.MSWord;

        tx.Load(Server.MapPath("/documents/template.docx"),
            TXTextControl.StreamType.WordprocessingML, ls);

        byte[] data;

        tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
        TextControl1.LoadText(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);
    }
}
[Visual Basic]
Protected Sub btnLoadFromServerMemory_Click(sender As Object, e As EventArgs)
    ' open a document using a temporary instance of ServerTextControl
    ' and save it into a byte array
    ' load the document from the byte array into the Web editor
    Using tx As New TXTextControl.ServerTextControl()
        tx.Create()
        Dim ls As New TXTextControl.LoadSettings()
        ls.ApplicationFieldFormat = TXTextControl.ApplicationFieldFormat.MSWord

        tx.Load(Server.MapPath("/documents/template.docx"), TXTextControl.StreamType.WordprocessingML, ls)

        Dim data As Byte()

        tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
        TextControl1.LoadText(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)
    End Using
End Sub

Loading client-side files

The file upload control uploads a document in the binary formats DOC and DOCX. The content is stored in a byte array and loaded using the LoadText method:

[C#]
protected void AjaxFileUpload1_UploadComplete(object sender,
    AjaxControlToolkit.AjaxFileUploadEventArgs e)
{
    // load the uploaded document from a byte array
    byte[] data = e.GetContents();

    TXTextControl.Web.BinaryStreamType streamType =
        TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat;

    if (e.FileName.EndsWith("doc") == true)
        streamType = TXTextControl.Web.BinaryStreamType.MSWord;
    else if (e.FileName.EndsWith("docx") == true)
        streamType = TXTextControl.Web.BinaryStreamType.WordprocessingML;
    else
        return;

    try
    {
        TextControl1.LoadText(data, streamType);
    }
    catch { }
}
[Visual Basic]
Protected Sub AjaxFileUpload1_UploadComplete(sender As Object, e As AjaxControlToolkit.AjaxFileUploadEventArgs)
    ' load the uploaded document from a byte array
    Dim data As Byte() = e.GetContents()

    Dim streamType As TXTextControl.Web.BinaryStreamType = TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat

    If e.FileName.EndsWith("doc") = True Then
        streamType = TXTextControl.Web.BinaryStreamType.MSWord
    ElseIf e.FileName.EndsWith("docx") = True Then
        streamType = TXTextControl.Web.BinaryStreamType.WordprocessingML
    Else
        Return
    End If

    Try
        TextControl1.LoadText(data, streamType)
    Catch
    End Try
End Sub

Saving server-side files

When clicking the button Save document as a file on the server, the SaveText method is used to save a physical file server-side:

[C#]
protected void btnSaveToServer_Click(object sender, EventArgs e)
{
    // save the document to a physical file on the server
    string sFilename = "results_" + Guid.NewGuid().ToString() + ".docx";
    TextControl1.SaveText(Server.MapPath("/output/" + sFilename),
        TXTextControl.Web.StreamType.WordprocessingML);
    lblStatusSave.Text = "Document has been saved:<br />" + sFilename;
}
[Visual Basic]
Protected Sub btnSaveToServer_Click(sender As Object, e As EventArgs)
    ' save the document to a physical file on the server
    Dim sFilename As String = "results_" + Guid.NewGuid().ToString() + ".docx"
    TextControl1.SaveText(Server.MapPath(Convert.ToString("/output/") & sFilename), TXTextControl.Web.StreamType.WordprocessingML)
    lblStatusSave.Text = Convert.ToString("Document has been saved:<br />") & sFilename
End Sub

Saving files to memory

When the last button Save document to the memory on the server is clicked, the SaveText method is used to save the current document into a byte array in the internal unicode format. This byte array is loaded into an instance of the ServerTextControl:

[C#]
protected void btnSaveToServerMemory_Click(object sender, EventArgs e)
{
    // save the document into a byte array
    byte[] data;
    TextControl1.SaveText(out data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);

    // load the byte array into a temporary ServerTextControl
    // sample use case: store document in a database
    using (TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl())
    {
        tx.Create();
        tx.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
    }

    lblStatusSave0.Text = "Document has been temporary saved at " +
        String.Format("{0:T}", DateTime.Now);
}
[Visual Basic]
Protected Sub btnSaveToServerMemory_Click(sender As Object, e As EventArgs)
    ' save the document into a byte array
    Dim data As Byte()
    TextControl1.SaveText(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)

    ' load the byte array into a temporary ServerTextControl
    ' sample use case: store document in a database
    Using tx As New TXTextControl.ServerTextControl()
        tx.Create()
        tx.Load(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
    End Using

    lblStatusSave0.Text = "Document has been temporary saved at " + [String].Format("{0:T}", DateTime.Now)
End Sub


Example - Merging Templates

The most typical application for the HTML5 Web editor is creating templates for the Text Control Reporting engine MailMerge. Using TX Text Control .NET Server for ASP.NET, you can easily deploy a cross-browser, cross-platform template editor with an MS Word look and feel.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\template.aspx

Example description

Simply click the button Load template, add some text or fields and start the merge process by clicking the Merge template server-side button.

On server-side, the sample database XML file is loaded into a new DataSet instance. This DataSet is used as the data source for the MailMerge component. The template is saved into a byte array using the SaveText method and loaded into the MailMerge instance using the LoadTemplateFromMemory method. Finally, the Merge method is called with the created DataSet. The resulting document is saved to memory and from there loaded back into the editor using LoadText.

[C#]
protected void Button1_Click(object sender, EventArgs e)
{
    // load the data source (sample database)
    DataSet ds = new DataSet();
    ds.ReadXml(Server.MapPath("/datasource/sample_db.xml"), XmlReadMode.Auto);

    // save the template
    byte[] data;
    TextControl1.SaveText(out data,
        TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);

    // load the template into the MailMerge reporting engine
    mailMerge1.LoadTemplateFromMemory(data,
        TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat);

    // merge the template
    mailMerge1.Merge(ds.Tables["Sales_SalesOrderHeader"]);

    // save the resulting document to a byte array
    mailMerge1.SaveDocumentToMemory(out data,
        TXTextControl.BinaryStreamType.InternalUnicodeFormat, null);

    // load the document back into the Web editor
    TextControl1.LoadText(data,
        TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);
}
[Visual Basic]
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ' load the data source (sample database)
    Dim ds As New DataSet()
    ds.ReadXml(Server.MapPath("/datasource/sample_db.xml"), XmlReadMode.Auto)

    ' save the template
    Dim data As Byte()
    TextControl1.SaveText(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)

    ' load the template into the MailMerge reporting engine
    mailMerge1.LoadTemplateFromMemory(data, TXTextControl.DocumentServer.FileFormat.InternalUnicodeFormat)

    ' merge the template
    mailMerge1.Merge(ds.Tables("Sales_SalesOrderHeader"))

    ' save the resulting document to a byte array
    mailMerge1.SaveDocumentToMemory(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat, Nothing)

    ' load the document back into the Web editor
    TextControl1.LoadText(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)
End Sub


Example - Customize RibbonBar

The TX Text Control RibbonBar consists of pure HTML and CSS and can be completely customized by changing the CSS.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\ribbon.aspx

Example description

The TX Text Control RibbonBar consists of pure HTML and CSS and can be completely customized by changing the CSS. The following screenshot shows the modified style of the RibbonBar. The background color, borders, active button colors and hover colors have been modified.

This demo comes with a complete CSS file that contains all ribbon tabs, groups and buttons for customization. The RibbonBar in this demo has changed colors, font sizes and only one active ribbon tab (Home). Additionally, the last ribbon group of the ribbon tab is disabled (Editing).

All you need to do to customize the ribbon bar is to include the tx.css into your HTML HEAD tag. In the CSS file, you will find all classes of ribbon tabs, groups, icons and other elements. Each class has a commented line that can be uncommented to hide this element in the ribbon bar.

/* Make ribbon titles normal (default: uppercase) */
#txTemplateDesignerContainer ul.tabs li {
    text-transform: none !important;
}

/* Set background color of ribbon */
#txRibbonContentArea {
    background: -webkit-linear-gradient(#FFF, #a5a5a5); /* For Safari 5.1 to 6.0 */
    background: -o-linear-gradient(#FFF, #a5a5a5); /* For Opera 11.1 to 12.0 */
    background: -moz-linear-gradient(#FFF, #a5a5a5); /* For Firefox 3.6 to 15 */
    background: linear-gradient(#FFF, #a5a5a5); /* Standard syntax */
    color: white;
}


Example - Customize Toolbars

Web.TextControl provides client-side methods to show and hide the various toolbars including the vertical and horizontal ruler bars, the status bar and the ribbon bar.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\toolbars.aspx

Example description

To provide client-side, Javascript applications, those methods are available as Javascript methods and can be adjusted without any server requests. Additionally, the ribbon bar can be collapsed and expanded programmatically.

In order show or hide the different toolbars, Web.TextControl provides methods that can be called at run-time using client-side Javascript. In order to hide all toobars on creating the control, the event ribbonTabsLoaded can be used.

The demo consists of a Web.TextControl and 4 check boxes that can be used to show and hide the toolbars. On creating the Web.TextControl, all toolbars are hidden by default.

<script type="text/javascript">

    // client-side Javascript events

    TX.addEventListener('ribbonTabsLoaded', function (e) {
        TX.showRibbonBar(false);
        TX.showStatusBar(false);
        TX.showVerticalRuler(false);
        TX.showHorizontalRuler(false);

        document.getElementById('verticalRuler').checked = false;
        document.getElementById('horizontalRuler').checked = false;
        document.getElementById('statusBar').checked = false;
        document.getElementById('ribbonBar').checked = false;
    });

    function toggleVerticalRuler() {
        TX.showVerticalRuler(document.getElementById('verticalRuler').checked);
    }

    function toggleHorizontalRuler() {
        TX.showHorizontalRuler(document.getElementById('horizontalRuler').checked);
    }

    function toggleStatusBar() {
        TX.showStatusBar(document.getElementById('statusBar').checked);
    }

    function toggleRibbonBar() {
        TX.showRibbonBar(document.getElementById('ribbonBar').checked);
    }

</script>


Example - Programming API

Web.TextControl provides the same interface to the TextParts such as the ServerTextControl. You can iterate through all TextParts including the MainText, TextFrames and HeaderFooter objects. These TextPart objects provide a Selection object that can be used to get and set formatted text and to interact with the content.

This example is part of the Sample Explorer project which includes all samples in one. The sources for this sample project can be found here:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Sample Explorer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Sample Explorer\

You will find the source code and the ASPX page of this sample in the Solution structure tree under: HTML5\selection.aspx

Example description

A temporary ServerTextControl is used to modify the content of Web.TextControl. The Selection is loaded into a ServerTextControl, modified and loaded back to Web.TextControl.

The following screenshot shows a custom TreeView control to insert merge fields and reusable text blocks programmatically.

The following code snipped shows how to insert a new merge field. A temporary ServerTextControl is created and a new merge field is inserted using the ApplicationFieldCollection. The content is temporary saved to a byte array and loaded into the current selection of the Web.TextControl. Using this approach, any element, text block or other word processing elements can be added to the Web.TextControl.

[C#]
protected void Button1_Click(object sender, EventArgs e)
{
    // insert a new text field into Web.TextControl
    using (TXTextControl.ServerTextControl tx = new TXTextControl.ServerTextControl())
    {
        tx.Create();

        MergeField newField = new MergeField();
        newField.Name = TextBox2.Text;
        newField.Text = "Text Field: " + TextBox2.Text; ;

        tx.ApplicationFields.Add(newField.ApplicationField);

        byte[] data;
        tx.Save(out data, TXTextControl.BinaryStreamType.InternalUnicodeFormat);
        TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat);

        TextBox2.Text = "";
    }
}
[Visual Basic]
Protected Sub Button1_Click(sender As Object, e As EventArgs)
' insert a new text field into Web.TextControl
    Using tx As New TXTextControl.ServerTextControl()
        tx.Create()

        Dim newField As New MergeField()
        newField.Name = TextBox2.Text
        newField.Text = "Text Field: " + TextBox2.Text

        tx.ApplicationFields.Add(newField.ApplicationField)

        Dim data As Byte()
        tx.Save(data, TXTextControl.BinaryStreamType.InternalUnicodeFormat)
        TextControl1.Selection.Load(data, TXTextControl.Web.BinaryStreamType.InternalUnicodeFormat)

        TextBox2.Text = ""
    End Using
End Sub

Additionally, several events are available to interact with merge fields. This allows the insertion and manipulation of merge fields using your own interface.

<script type="text/javascript">

    // client-side Javascript events for merge fields

    TX.addEventListener('textFieldEntered', function (e) {
        fieldEntered(e.fieldName, e.fieldType);
    });

    TX.addEventListener('textFieldLeft', function (e) {
        fieldLeft();
    });

    function fieldEntered(fieldName, fieldType) {
        document.getElementById('TextBox1').value = fieldName;
    }

    function fieldLeft() {
        document.getElementById('TextBox1').value = '';
    }

</script>


Redistribution and Deployment

Deploying the ASP.NET Web application

The ASP.NET Web application can be deployed just like any other ASP.NET application using the Publish Web functionality of Visual Studio. The following steps are required to publish your created project to your local file system that can be manually copied to your server. Optionally, you can directly publish your Web application to your server, a Windows Azure server or an FTP location. Refer to your Visual Studio documentation to learn how to use the Publish Web feature.

1. In your created ASP.NET Web application, select the reference TXTextControl.Web located in the References folder in the Solution Explorer Window. In the Properties Window, set the Copy Local property to true.

2. Select Publish %WebApplicationName% from the Build main menu. In the opened dialog Publish Web, select Custom as the publish target. In the opened dialog New Custom Profile, type in a name and confirm with OK.

3. In the next page of the dialog, select File System as your Publish method, set the target location and confirm with Next >.

4. Confirm the next page with Next > and finally click Publish to start the publishing process.

All of your required files are copied to your specific target location. Copy all of those files to your destination server.

Deploying the TX Text Control Web Server

All necessary files must be copied into the same folder on your server. You will find the distributable files in the following default folder:

C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET Server for ASP.NET\Assembly

and

C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET Server for ASP.NET\Assembly\bin64

The following files from the Assembly folder are required:

  • TXTextControl.dll
  • TXTextControl.Server.dll
  • TXDocumentServer.dll
  • TXTextControl.Web.Server.exe
  • TXTextControl.Web.Server.Process.exe

The following files from the bin64 folder are required:

  • tx24_css.dll
  • tx24_doc.dll
  • tx24_dox.dll
  • tx24_htm.dll
  • tx24_rtf.dll
  • tx24_pdf.dll
  • tx24_xml.dll
  • txkernel.dll
  • txic.dll
  • txpdf.dll
  • txtools.dll

1. Copy the created folder with all of the above files to a preferred location on your destination server.

2. Copy the command line tool txregwebsvr.exe from the following folder to your destination folder on your server:

C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET Server for ASP.NET\Tools

3. On your server, open a Command Prompt explicitly as an administrator and change the directory to the destination folder.

4. Type in and execute the following command:

txregwebsvr.exe /i /e /w

This command will register the TXTextControl.Web.Server.exe service on your server. The optional switches /e and /w will activate interactive services and WebSockets on your server.


Document Viewer (DocumentServer.Web.DocumentViewer)

This chapter shows how to use the DocumentServer.Web.DocumentViewer control in ASP.NET projects to display documents of the supported types in Web browsers. When viewing documents in Web applications is the only requirement, the DocumentServer.Web.DocumentViewer comes as a simple alternative to the Web.TextControl. The DocumentServer.Web.DocumentViewer is part of the TXTextControl.DocumentServer.Web namespace.

Introduction

Getting Started


Introduction

The DocumentServer.Web.DocumentViewer is a ASP.NET server control that can be used to display documents in the Web browser in ASP.NET projects. The document handling is done by an instance of the DocumentServer.DocumentController component that must be bound to the control.

The cooperation of the DocumentServer.Web.DocumentViewer and the DocumentServer.DocumentController resemble that of the view and the controller parts of the well-known Model-view-controller (MVC) pattern, while the document plays the part of the model. This means the user never modifies the document directly. The controller acts as mediator between the view and the model. Thus, the user only sees what the controller routes from the document to the viewer, and only the actions that the controller routes back from the viewer are applied to the document. Thanks to this setup, it is possible to control which parts of the document the user sees and which actions the user is allowed to take up to a great deal of detail.

The DocumentServer.DocumentController and thus the DocumentServer.Web.DocumentViewer can handle all the document formats that can contain application fields. These formats are summarized in the DocumentServer.FileFormat enumeration.


Getting Started

This tutorial shows how to create a simple ASP.NET Web application project using the DocumentViewer component.

The source code for this simple example is located in the following directories:

Language | Project Location
C# | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\DocumentViewer\
VB.NET | %USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\DocumentViewer\

Used TX Text Control classes:

  • TXDocumentServer.Web.DocumentViewer
  • TXDocumentServer.Web.DocumentController
  • TXTextControl.ServerTextControl

Create your application

1. Open Visual Studio and create a new ASP.NET Empty Web Application.

In the opened dialog Add New Item, select Web Form and confirm with Add.

2. In the Solution Explorer, select the newly created Web Form and choose Designer from the View main menu.

Find the DocumentController component in the Toolbox and drag and drop an instance onto the Designer form.

Repeat the same with an instance of the ServerTextControl component.

3. Select the DocumentController and find the TextComponent property in the Properties Window. Set the property value to serverTextControl1 - the name of the created ServerTextControl instance.

4. In the Solution Explorer, select the newly created Web Form and choose Designer from the View main menu.

Find the DocumentViewer component in the Toolbox and drag and drop an instance onto the form.

5. While the project is selected in the Solution Explorer, choose Add Existing Item... from the Project main menu.

In the opened dialog Add Existing Item, browse to the following sample folder:

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\CSharp\Documentation Tutorials\DocumentViewer\

or

%USERPROFILE%\Documents\TX Text Control 24.0.NET Server for ASP.NET\Samples\ASP.NET\VB.NET\Documentation Tutorials\DocumentViewer\

Select the following file: demo.rtf and click the Add button.

6. Switch to Code view using the Code menu item of the View main menu.

Add the following code to the Form_Load event:

[C#]
protected void Page_Load(object sender, EventArgs e)
{
  InitializeComponent();
  DocumentViewer1.DocumentController = documentController1;
  DocumentViewer1.LoadDocument(Server.MapPath("Demo.rtf"));
}
[Visual Basic]
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
  InitializeComponent()
  DocumentViewer1.DocumentController = documentController1
  DocumentViewer1.LoadDocument(Server.MapPath("Demo.rtf"))
End Sub

Compile and start the application.


Text Control Reporting User's Guide

This guide describes how to use the Reporting and Mail Merge features of TX Text Control within Windows Forms, WPF and ASP.NET applications.

Text Control Reporting Introduction

Getting Started

Concepts: Merge Fields

Concepts: Merge Blocks

Concepts: Conditional Fields

Concepts: Master-Detail Views - Nested Repeating Blocks

Concepts: Include Text Fields - Insert Sub-Templates

Concepts: Date Fields

Technical Article: Using Objects as Data Sources

Technical Article: Define the Textual Representation in your Classes

Technical Article: Prefixed Merge Fields

Technical Article: Image and Barcode Placeholder Merging

Technical Article: Report Data Source Configuration Files


Text Control Reporting Introduction

Reporting and Mail Merge have become wide-sweeping terms for automated document, report and label creation. Creating invoices, proposals, generated covering letters or shipping labels was never that easy - simply using word processing skills. This chapter shows how to use the DocumentServer.MailMerge class to merge ApplicationFields in template documents with data from various data sources. The MailMerge class encapsulates powerful mail merge capabilities of TX Text Control .NET in a ready-to-use component. MailMerge is part of the TXTextControl.DocumentServer namespace and can be used in Windows Forms, WPF and ASP.NET in all available editions.

Instead of utilizing complex reporting tools and designers to create business documents, TX Text Control offers an easy-to-use and powerful way to create reports in your .NET based applications.

Combine the easiness of a word processor with the power of a reporting tool - The MailMerge component

The DocumentServer.MailMerge class is a .NET component that can be used to merge template documents with database content effortlessly in .NET projects such as Windows Forms or WPF client applications, ASP.NET Web applications, Web services or Windows services. Internally, TX Text Control is used which must be connected to the MailMerge component. The MailMerge component can be connected with the classes TextControl and ServerTextControl.

Using the DocumentServer.MailMerge component, template documents containing MS Word merge fields can be easily loaded, merged with a DataSet or DataTable of the Microsoft .NET System.Data namespace or all kind of business objects and enumerable classes and exported to supported file format types of TX Text Control such as Adobe PDF or DOCX.

WYSIWYG Template Designing

Instead of utilizing complex reporting tools and designers to create business documents, TX Text Control offers an easy-to-use and powerful way to create reports in your Windows Forms, WPF or ASP.NET applications. Text Control Reporting combines the power of a reporting tool and an easy-to-use word processor - fully programmable and embeddable in your application.

With Text Control Reporting, your users create templates with typical word processing features such as page columns, tables, images and headers and footers. In contrast to complex report designers, users can use their MS Word skills to create beautiful reports - no steep learning curve.

Add 2D and 3D Charting to your Reports

Powerful data visualization in a report or any other documents is essential to get the "big picture". Charts indicate trends and can be used to attractively visualize large volumes of data.

Bars, donuts, pies or financial series - more than 30 fully programmable diagram types can be added. This concept allows you to create true WYSIWYG templates for your reports. The size and style of charts are added at design-time and merged dynamically.

Powerful Data Connection

Text Control Reporting implements an out-of-the-box data connection wizard to connect to all types of databases including MS SQL, Access, ADO.NET or ODBC. You can easily insert Merge Fields and Merge Blocks from recognized database tables.

When merging the created templates in your own .NET application, you simply need to pass the filled DataSet, DataTable or your business objects.

Master-Detail Nested Blocks

Creating powerful hierarchical reports is the strength of TX Text Control. Nested repeating blocks with master-detail relationship views can be easily inserted. It doesn't matter what's repeated in the block: A table row, paragraphs, images or text frames.

Typically, these hierarchical views are used in invoices, inventory lists and all kinds of complex textual lists and reports.

1D and 2D Barcodes

1D and 2D barcodes make the reporting solution complete. TX Text Control can be easily used to create invoices, sales sheets and delivery notes with industry standard barcodes to connect the digital world and the paper-oriented world.

Text Control Reporting supports all typical industry standard 1D and 2D barcode types such as QRCode, DataMatrix, MaxiCode, EAN or IntelligentMail.

Export to PDF, MS Word and Print

Text Control Reporting supports the most important industry standard document formats such as DOC, DOCX, RTF, HTML, PDF and PDF/A. You can digitally sign and encrypt Adobe PDF and PDF/A documents or print them directly from your application.


Getting Started

This very easy-to-use getting started tutorial shows how to use the Template Designer TX Text Control Words with a sample template and database and illustrates how to integrate the merging process into your .NET based application.

Add Reporting to your Applications in 3 Easy Steps

Used TX Text Control controls:

  • TXTextControl.DocumentServer.MailMerge
  • TXTextControl.TextControl

Relevant API links:

  • DocumentServer.MailMerge
  • DocumentServer.MailMerge.Merge
  • DocumentServer.Fields.MergeField

This very easy-to-use getting started tutorial shows how to use the Template Designer with a sample database and templates and how to integrate the merging process into your .NET application.

Step 1: Create your application

1. Open Visual Studio and create a new Windows Forms application.

  • From the Toolbox, drag and drop an instance of TextControl onto your form.
  • Open the SmartTag in the upper right corner of the TextControl object and visit each wizard link to add additional controls (button bar, rulers, status bar) and connect them by clicking Arrange Controls Automatically.
  • Add a MailMerge component from the toolbox to the form.

2. Find the SmartTag of the MailMerge component in the component tray. Click Connect to Text Component to connect MailMerge with the TextControl instance.

3. In the same SmartTag of MailMerge, click Start Template Designer to open TX Text Control Words.

Step 2: Open sample database and template

1. Load the sample template Invoice using the Open Sample Template menu entry from the main menu File.

2. Open the Select Data Source drop-down button of the Reports ribbon tab and click Load Sample Database.

3. Make sure that the table Sales_SalesOrderHeader is selected from the drop-down list button Select Master Table.

4. Now select Preview Merge Fields from the Preview ribbon tab. Confirm the opened dialog with OK to select the number of records for the preview process.

5. Uncheck Preview Merge Fields and save the template as a DOCX document using the Save As... menu entry from the main menu File.

Step 3: Integrate into application

1. Back in Visual Studio, open the MailMerge SmartTag, click TemplateFile... and browse for the saved template from Step 2.5 in the opened dialog box.

2. Add a MenuStrip to the form, create a menu item called Merge and double-click this item to open the event handler.

Add the following code and change the XML file location in line 1 to match your TX Text Control installation path:

[C#]
string sDBPath =
    @"C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET for Windows Forms\Samples\Demo\sample_db.xml";

DataSet ds = new DataSet();
ds.ReadXml(sDBPath);

mailMerge1.Merge(ds.Tables["Sales_SalesOrderHeader"], true);
[Visual Basic]
Dim sDBPath As String = "C:\Program Files\Text Control GmbH\TX Text Control 24.0.NET for Windows Forms\Samples\Demo\sample_db.xml"

Dim ds As New DataSet()
ds.ReadXml(sDBPath)

mailMerge1.Merge(ds.Tables("Sales_SalesOrderHeader"), True)

3. Compile and start the application, click the menu item Merge to start the merge process.


Concepts: Merge Fields

The merge field represents the basic concept of Text Control's reporting engine. Merge fields are textual, formatted placeholders in a template that are populated with data from connected data sources. Such fields are compatible to MS Word which makes existing templates created in Microsoft Office compatible to Text Control Reporting.

Merge Fields

Merge fields have a specific name that is used to match the associated data source column. Text Control Reporting is matching those fields with associated column data content automatically.

In order to insert a field, open the Insert Merge Field drop-down list from the Merge Fields group of the Reports ribbon tab and choose a table.

In the opened dialog box, select the field from the tree view control and confirm with Insert Field.

The formatting of the field is preserved when data is merged. This gives designers the ability to create templates in a true WYSIWYG (what-you-see-is-what-you-get) manner.

Merge fields have various switches that can be adjusted in the Merge Field Options dialog:

The Format of a field defines the string format of the merge field and can be set to one of the following options:

  • (none)
  • UPPERCASE
  • lowercase
  • First capital
  • Title Case

Merge fields can have a date/time format or a numeric format. Example: A field Price is formatted as a currency string with the format $#,###.00 which renders the results with a currency symbol and 2 decimal places: Input: 2.4m, Output: $2.40.

Additionally, optional text can be defined that is inserted before and after the field during the merge process.

Related events:

  • DocumentServer.MailMerge.FieldMerged
  • DocumentServer.MailMerge.DataRowMerged


Concepts: Merge Blocks

Merge blocks are used to repeat content bound to a specific data source. For each data row in the defined data source, the merge block is repeated.

Repeating Merge Blocks: Repeat content

Each merge block can contain merge fields that are populated with data from a specified data source. The block is repeated based on the number of data rows that apply.

A merge block is not limited to it's content - it can consist of a table row, a complete table, paragraphs, images or text frames.

Given that a data source is selected in the Template Designer, the following steps show how to insert a merge block:

1. Open TX Text Control Words and open the sample database.

2. Click the Insert Merge Block drop-down button to open the list of available tables and select your desired table.

3. In the opened dialog, choose the included table columns and confirm with OK.

The Template Designer automatically inserts a table row with the required SubTextPart range to define the beginning and the end of a repeating block.

SubTextParts have a special naming, so that TX Text Control's MailMerge class can find the blocks and connected data. The name of the SubTextPart begins with txmb_ + the name of the merge block.

You can apply some formatting to the text and the table. The whole block is cloned including it's formatting and style.

Related events:

  • DocumentServer.MailMerge.FieldMerged
  • DocumentServer.MailMerge.DataRowMerged
  • DocumentServer.MailMerge.BlockRowMerged


Concepts: Conditional Fields

The conditional IF field adds true or false text under a specific condition.

Conditional IF Fields

Text Control's reporting engine MailMerge compares two values and inserts the text appropriate to the result of the given comparison. The first expression must be a Merge Field name. On merging the document, the MergeField value is compared to the second expression in order to insert the appropriate text value. The format of the field is shows below:

{ IF Expression1 Operator Expression2 TrueText FalseText }

The following operators are supported:

  • Equal to
  • Not equal to
  • Greater than
  • Less than
  • Greater than or equal to
  • Less than or equal to

To insert a conditional field, choose IF from the Insert Special Field drop-down box of the Reports ribbon tab. Type in the field name, conditions and the true and false text and confirm with OK.

Related events:

  • DocumentServer.MailMerge.FieldMerged
  • DocumentServer.MailMerge.BlockRowMerged


Concepts: Master-Detail Views - Nested Repeating Blocks

A master-detail relationship is a 1:n (one-to-many) type relationship.

Nested Repeating Blocks

A typical example for such a relationship is a purchase order and a set of items that belongs to each purchase order. This allows you to create complex nested reports in a very easy way.

TX Text Control's repeating blocks can be nested in unlimited levels and are inserted in the same way like usual merge blocks.

Each block has an unique name that matches the name of a DataTable in the merge data. If nested blocks with an existing DataRelation are recognized, they are combined automatically. The following screenshot shows the concept of nested blocks and the data relations:

The complete table is the outer block representing article groups. The inner block is marked in darker red which represents the articles.

Looking at the merged results show that the articles are mapped automatically:

The merge data structure

In the above sample, the block data consists of two tables with an unique relationship (article_group_id):

Related events:

  • DocumentServer.MailMerge.FieldMerged
  • DocumentServer.MailMerge.DataRowMerged
  • DocumentServer.MailMerge.BlockRowMerged


Concepts: Include Text Fields - Insert Sub-Templates

IncludeText fields contain a reference to external documents that are included during the mail merge process.

Include Text Fields

This allows the separate storage of specific sub-templates in order to reuse them in other templates. The field refers the name of a sub-template that must exist in the path given by the SearchPath property.

In order to insert an IncludeText field, choose IncludeText from the Insert Special Field drop-box box of the Reports tab. Type in the name of the sub-template and confirm with OK.

Related events:

  • DocumentServer.MailMerge.IncludeTextMerging


Concepts: Date Fields

The Date field includes the current date in a specified format.

Date Fields

While merging the template, the current date is merged into this field. The format can be defined using a string formatter. In order to insert the field, choose Date from the Insert Special Field drop-box box of the Reports tab.

Related events:

  • DocumentServer.MailMerge.FieldMerged


Technical Article: Using Objects as Data Sources

The direct use of enumerable business objects as a data source to merge templates is one of the typical scenarios with TX Text Control Reporting.

Use IEnumerable Objects as Data Sources

MailMerge interprets all public properties of objects in the collection as table columns and child tables. Properties of type IEnumerable are automatically instantiated as relations and are used for merge blocks and nested merge blocks.

Consider the following class structure as a data source:

Below is the C# code that represents the above UML class design:

[C#]
public class Invoice
{
    public List<Product> Products
    {
        get;
        set;
    }

    public Customer Customer
    {
        get;
        set;
    }
}

public class Product
{
    public Product(string Name, Decimal Price)
    {
        this.Name = Name;
        this.Price = Price;
    }

    public string Name
    {
        get;
        set;
    }

    public Decimal Price
    {
        get;
        set;
    }
}

The template consists of a merge block named Products. The merge fields in the block are named Name and Price.

The following code shows how to create the data source object and how to start the merge process using MergeObjects:

[C#]
Invoice invoice = new Invoice();

invoice.Products = new List<Product>();
invoice.Products.Add(new Product("Apple", 3.55m));
invoice.Products.Add(new Product("Banana", 2.4m));
invoice.Products.Add(new Product("Pineapple", 2.99m));

var invoices = new List<Invoice>();
invoices.Add(invoice);

mailMerge1.MergeObjects(invoices);


Technical Article: Define the Textual Representation in your Classes

TX Text Control Reporting allows the textual formatting to be done in business objects. For example: The ToString() method can be overridden to return a well formatted address block directly from your business object.

Override the ToString method of your classes

Consider a class to represent a Customer:

The following code is the C# implementation of the above class:

[C#]
public class Customer
{
    public Customer(string firstName, string lastName, string address, string phone)
        {
            FirstName = firstName;
            LastName = lastName;
            Address = address;
            Phone = phone;
        }

    public string FirstName { get; set; }
    public string LastName { get; set; }
    public string Address { get; set; }
    public string Phone { get; set; }

    public override string ToString()
    {
        return String.Format("Customer Details: \nFirst Name - {0} \nLast Name - {1} \nAddress - {2} \nPhone - {3}", FirstName, LastName, Address, Phone);
    }
}

TX Text Control MailMerge calls the ToString() method to get the text from your class that returns a pre-formatted string with carriage returns. The following screenshot shows the results of the above-described concept:


Technical Article: Prefixed Merge Fields

The easy creation of pixel-perfect reports using a flow type layout design is the core concept of Text Control Reporting. But at the same time, this word processing concept is combined with the power of reporting tools. Creating nested repeating blocks with Master-Detail relationships is the strength of the MailMerge component.

Prefixed merge fields

Data relations and data source connection strings can be defined in TX Text Control Words - the customizable template designer. Those settings can be exported to Report Data Source Configuration Files and directly loaded into the used MailMerge instance.

The data relation can be prefixed onto the field name. Consider the following data source structure of our sample database that somes with TX Text Control Words:

In this sample, an invoice for an order should be created. The master table is Sales_SalesOrderHeader which contains general information about the order and relations to sub-tables. It is connected to Sales_SalesOrderDetail through the SalesOrderID. These order details consist of sold products defined in another table named Production_Product.

During the merge process, you simply need to specify the master table and TX Text Control's Reporting engine is getting the related tables automatically. The following screenshot shows the repeating block Sales_SalesOrderDetail with merge fields from sub-tables:

The fields OrderQty, UnitPrice and LineTotal are coming directly from the table Sales_SalesOrderDetail. They don't have a prefix as the surrounded block is filled from Sales_SalesOrderDetail.

The fields Production_Product.ProductNumber and Production_Product.Name are coming from a sub-table which is defined by the prefix Production_Product.

Even the image placeholder is named with a prefix sub-table: Production_Product.Production_ProductProductPhoto.Production_ProductPhoto.ThumbNailPhoto.

In TX Text Control Words, a dialog is available that enables the easy creation of such nested fields.

The dialog displays possible relations in form of a tree view to help with the navigation through possible field names.

The following screenshot shows the merged invoice including image fields, repeating blocks prefixed nested merge fields.


Technical Article: Image and Barcode Placeholder Merging

Images and barcodes can be merged in the same way like merge fields in a reporting template. An image or barcode placeholder is added at design-time to the template and merged with data from files, databases or memory.

Image placeholder objects

An image object can be added to the template with a given name. The data column must contain either the binary image data as a byte array, an object of type System.Drawing.Image, a file name, a hex or Bass64 encoded string. These options cover most typical image representations in databases.

Merged images are scaled up or down to match the width of the placeholder image in the template. The following screenshot shows a placeholder image and the Object Data Source context menu:

The same dialog like for merge fields is opened and you can choose the specific data column that contains the image data:

After the template is merged, the image is scaled to match the placeholder image size:

Merging Barcodes

Analogically with images, barcodes are inserted as a placeholder. You define the type, barcode text length, size and position in your template at design-time in order to merge data dynamically.


Technical Article: Report Data Source Configuration Files

Report Data Source Configuration files are created in the shipped Template Designer TX Text Control Words and include data connections and created data relations. It is not required to define data relations for Master-Detail blocks in your code. All you need to do is to open a data source in the Template Designer, create the relations and to save these settings as a Report Data Source Configuration file.

Create Data Relation

In the Template Designer, there is a dialog to define the relations between several tables that are used in the designer for the preview of the report. Those settings can be directly saved as the XML based configuration files.

The unique advantage of this approach is the flexibility you gain with separate files that hold the data source information. You can easily use the same configuration file with different templates. Consider a situation when the data source is changed - maybe a new SQL Server. In this case, you don't need to change all your templates, but only one configuration file.

In the Template Designer, you simply save the configuration file and your template.

In Visual Studio, only one line of code is required to merge the template with the given data source and all defined relations. All you need to do is to drag and drop a TextControl and a MailMerge component onto your form in order to:

  • Connect MailMerge with the TextControl instance using the TextComponent property
  • Specify your data source configuration file path
  • Specify your template file path

Finally, in your code, you simply need to call the Merge method of MailMerge to start the merge process.


Distributing your Applications

This chapter describes how to create a setup program for your application.

Configure your Project for 32 bit and 64bit

Creating a Setup Project with Visual Studio .NET

Redistributable Files

Distributing a TX Text Control .NET Server Project


Configure your Project for 32 bit and 64bit

TX Text Control .NET is shipped with separate sets of distributable files developed and compiled for 32bit and 64bit processors. To create a 64bit application, the project must be compiled with an x64 build configuration. To create an application that runs on both 32bit and 64bit platforms, the project must be compiled with an x86 build configuration. This article explains how to create two different build configurations with Visual Studio 2005.

1. Create a Visual Studio project as described in the tutorial.

2. Open the Configuration Manager dialog by choosing Configuration Manager from the Build main menu.

3. Select the <New...> item from the Active solution platform dropdown box to open the New Solution Platform dialog.

4. Confirm the settings in the dialog by clicking OK. A new configuration for x64 is created.

5. Repeat step 3 and 4 for an x86 configuration. The Active solution platform dropdown box of the Configuration Manager dialog box should now look like this:

6. Select <Edit...> from the dropdown box to open the edit Solution Platforms dialog.

7. Select Any CPU and click Remove to remove this configuration.

8. Close both dialogs by clicking Close.

The Solution Platform dropdown box of Visual Studio should now look like this:

To compile your application for a specific processor, choose the appropriate platform from this toolbox.

In Visual Studio 2005, a project is automatically compiled for 'Any CPU'. When loading a .NET assembly, the .NET Framework decides which version of the CLR (Common Language Runtime) must be loaded based on the assembly type. System processes based on assemblies compiled for 'Any CPU' will load in the native CLR for the host system. Therefore a TX Text Control application compiled for 'Any CPU' only runs on 32bit systems.


Creating a Setup Project with Visual Studio .NET

If you create a setup program for your application with a Visual Studio .NET setup project, all redistributable files will be included automatically. TX Text Control installs two separate merge modules for the 32bit and the 64bit edition. If you configure your project as described in the chapter Configure your Project for 32bit and 64bit, TX Text Control .NET chooses the proper merge module automatically. In case you wish to use a different setup toolkit, refer to the chapter Redistributable Files.

In Visual Studio .NET, a setup program is created by adding a setup project to your solution. The following is a step-by-step guide to create a setup project:

  • Open the solution in Visual Studio .NET for which you wish to create a setup program. The following example uses the VB version of the Simple sample program.
  • In the File menu, click New Project. In the New Project dialog box which pops up, make the following settings:
  • Select Setup and Deployment Projects in the Project Types window to the left.
  • Select Setup Wizard in the Templates window to the right.
  • Select a name and location where you want the setup files to be placed.
  • Select the Add to Solution option.
  • Click OK.
  • Follow the instructions in the remaining 4 dialog boxes and enter additional options as required for your application. Don't forget to include Primary Output from .. in the third dialog box.
  • Before you compile the setup project by selecting Build Setup1 from the Build menu, you may want to fine tune the options for creating start menu entries and desktop icons. Note that the setup wizard will not automatically create an entry in the start menu, you need to add a shortcut to User's Programs Menu.

The setup program should now be created in the folder you have specified. All of TX Text Control's redistributable files are contained in a merge module and will be included automatically.


Redistributable Files

To use a setup toolkit other than Visual Studio .NET the tables below show all the files necessary for TX Text Control to operate properly. You must ensure that all necessary files exist on your client's machine. For 32bit applications, the files in the following lists can be found in the \Assembly and the \Assembly\bin subdirectories of your TX Text Control installation directory. For 64bit applications, the files can be found in the \Assembly and the \Assembly\bin64 subdirectories.

For a Windows Forms or a WPF application all necessary files must be copied into the same folder as your application's executable program file. For a browser-based ASP.NET Web application using the HTML5 Web Editor the installation is described in the chapters Redistribution and Deployment and Distributing a TX Text Control .NET Server Project.

TX Text Control Windows Forms Components (\Assembly subdirectory):

  • TXTextControl.Windows.Forms.dll (24.0.900.500)
  • TXDocumentServer.Windows.Forms.dll (24.0.700.500)

TX Text Control WPF Components (\Assembly subdirectory):

  • TXTextControl.WPF.dll (24.0.900.500)
  • TXDocumentServer.WPF.dll (24.0.700.500)

TX Text Control Server Component (\Assembly subdirectory):

  • TXTextControl.Server.dll (24.0.900.500)

TX Text Control core assemblies (\Assembly\bin and \Assembly\bin64 subdirectory). These files are necessary for all components:

  • TXTextControl.dll (24.0.1700.500)
  • TXDocumentServer.dll (24.0.1000.500)
  • txkernel.dll (24.0.2400.500)
  • txtools.dll (24.0.700.500)
  • txic.dll (24.0.800.500)
  • txpdf.dll (24.0.1100.500)

TX Text Control text filters (\Assembly\bin and \Assembly\bin64 subdirectory) These files are necessary for all components:

  • tx24_rtf.dll
  • tx24_htm.dll
  • tx24_doc.dll
  • tx24_dox.dll
  • tx24_xml.dll
  • tx24_css.dll
  • tx24_pdf.dll

To use TX Text Control's XML features the Microsoft XML parser must be installed in the Windows system directory. The following lists the necessary files. Please refer to Microsoft's redistribution policy if you need to redistribute them.

  • MSXML3.DLL (8.00.7820.0)
  • MSXML3A.DLL (8.00.7820.0)
  • MSXML3R.DLL (8.00.7820.0)


Distributing a TX Text Control .NET Server Project

Internet Information Server (IIS) needs to be installed in order to run TX Text Control .NET Server. It can be run on a dedicated server, or by simply activating IIS on the developer's computer. This way, a server application can be developed and tested on the same computer, without requiring access to a seperate server.

At some point, an application will be transfered to a 'real', dedicated production server. The following steps are required to transfer your TX Text Control license.

Assuming that you have an ASP.NET project opened in Visual Studio .NET:

  • Click on Publish Project... from the Build main menu entry.
  • Choose a target location for your application and confirm with OK.

An application folder will now be created at the server location that you previously specified. Copy all of the used TX Text Control .NET Server Redistributable Files from \Assembly (TXTextControl.Server.dll and TXDocumentServer.dll) and the appropriate files from the \Assembly\bin or \Assembly\bin64 folder into the Bin folder of the web application.


Technical Articles

This part informs about TX Text Control's programming capabilities in more depth.

Using Text Fields and Hypertext Links

Using Images, Text Frames, Charts, Barcodes and Drawings

Using Document Sections

Data binding with TX Text Control

PDF Import and Export

Using the Resource Kit

Working with XML Files

How-To Guide


Using Text Fields and Hypertext Links

TX Text Control offers a set of classes to define text positions or pieces of text in the document with a special meaning. These pieces of text are called marked text fields. They can be used to create hypertext features, to realize database embedding while text of different datasets can be included into the text or to combine several fields with formulas as in spreadsheet applications. Code examples can be found in the User's Guide chapters Using Marked Text Fields, Using Hypertext Links, Mail Merge and Connecting to Databases.

Overview of the TextField and Hypertext Link Classes

Editing Text Fields

Inserting and Deleting Text Fields

Identifiers and Names for Text Fields and Hypertext Links

Programming Hypertext Links

Inserting Page Numbers

Importing Fields from Microsoft Word


Overview of the TextField and Hypertext Link Classes

The base class for all types of text fields is the TextField class. It implements the base functionality of marked text fields like text and position, editing features, and data and event handling. These base features are explained later in this article. Additional classes, all of which are derived from the TextField class, are available for special types of marked text fields. These are listed in the following table:

Class | Description
TextField Class | Implements a general text field. It can be used to handle database fields, spreadsheet features or bookmarks.
HypertextLink Class | Derived class that implements a hypertext link. It can be used for links that point to targets outside of the current document.
DocumentLink Class | Derived class that can be used for links that point to targets inside of the current document.
DocumentTarget Class | Derived class that implements a target in a document.
PageNumberField Class | Derived class that implements a field that automatically shows the current page number. This field can only be used in a header or a footer.
ApplicationField Class | Derived class that implements a field providing an interface to retrieve and change the data and parameters of Microsoft Word fields and Heiler HighEdit fields.

For each type of text field, a Text Control manages a collection containing all fields of the same type. The collections can be used to add or remove fields, to get a individual item or to enumerate all fields of a certain type. Each collection is available through a readonly property of the TextControl, WPF.TextControl and ServerTextControl classes. The collection of page number fields can only be obtained through a property of the HeaderFooter class. The following table lists all available collections and their corresponding properties:

Collection Class | Obtaining Property
TextFieldCollection | TextControl.TextFields, WPF.TextControl.TextFields, ServerTextControl.TextFields, HeaderFooter.TextFields
HypertextLinkCollection | TextControl.HypertextLinks, WPF.TextControl.HypertextLinks, ServerTextControl.HypertextLinks
DocumentLinkCollection | TextControl.DocumentLinks, WPF.TextControl.DocumentLinks, ServerTextControl.DocumentLinks
DocumentTargetCollection | TextControl.DocumentTargets, WPF.TextControl.DocumentTargets, ServerTextControl.DocumentTargets
PageNumberFieldCollection | HeaderFooter.PageNumberFields
ApplicationFieldCollection | TextControl.ApplicationFields, WPF.TextControl.ApplicationFields, ServerTextControl.ApplicationFields


Editing Text Fields

Text fields can be edited by the end-user like any other text in the document. To prevent changing the text of a text field, the TextField.Editable property can be used. If the text of a text field may be changed by the end-user but the text field itself must not be deleted, the TextField.Deleteable property can be set to false. In this case, the text of the field can be altered but a selection containing the field in the middle, cannot be deleted or replaced.

If a marked text field is fully editable, the two text input positions at the beginning and the end of a marked text field have a special meaning. If an end-user inserts text at one of these positions, it is not unique whether or not the newly inserted text belongs to the field. To solve this problem, the TextField class offers the DoubledInputPosition property. This implements a second input position, which the end-user can reach with the Left Arrow and Right Arrow keyboard keys.

Additionally, a visual feedback for the end-user can be set with the TextField.ShowActivated property. If this property is set to true, an actived text field is displayed with a gray background. A text field is defined as activated, if the current text input position is inside the field so that the next inserted character is added to the text of the field. If the mouse cursor is moved over a text field, it is changed to a hand cursor to indicate that there is a field. The hand cursor can be changed to another shape using the TextControl.FieldCursor property.

During editing, the application is informed through the following events of the TextControl class:

Event | Description
TextControl.TextFieldChanged Event | Occurs when the text of a text field has been changed. It does not occur, if formatting attributes of the field's text have been altered or if the text of the field has been changed from program code with the TextField.Text property.
TextControl.TextFieldClicked Event | Occurs when a text field has been clicked with the mouse.
TextControl.TextFieldDoubleClicked Event | Occurs when a text field has been double-clicked with the mouse. It does not occur, if the TextField.DoubleClickEvent property has been set to false.
TextControl.TextFieldEntered Event | Occurs when the current input position has been moved from a position outside of a field to a position that belongs to a field. This only occurs, if an end-user has entered a field using the keyboard or a mouse-click. It does not occur, if the field has been entered through program code.
TextControl.TextFieldLeft Event | Occurs when the current input position has left a text field. It occurs only, if a field has been left trough an end-user with the keyboard or a mouse-click. It does not occur if the field has been left through program code.

All event handlers for these events receive an argument of the type TextFieldEventArgs. This class has a TextField property through which the field that has caused the event can be obtained.

All derived classes of the TextField class mentioned above inherit the editing features so that these are also available for hypertext links and page number fields. Each of the described attributes can be defined for a single field in any combination, which means that different kinds of marked text fields can be implemented in a single Text Control.


Inserting and Deleting Text Fields

Text fields can be inserted into a Text Control either by adding them to one of the field collections or with the TextControl.Load method as a part of a document. The following programming code creates a new text field, obtains the TextFieldCollection object and adds the field using the TextFieldCollection.Add method:

[Visual Basic]
Dim NewField As New TextField("new field")
NewField.ShowActivated = True
NewField.DoubledInputPosition = True
TextControl1.TextFields.Add(NewField)
[C#]
TextField newField = new TextField("new field");
newField.ShowActivated = true;
newField.DoubledInputPosition = true;
textControl1.TextFields.Add(newField);

This code inserts a text field that is shown with a gray background and with a doubled input position at the beginning and the end as explained in the chapter Editing Marked Text Fields.

A new field is always inserted at the current input position. If there is already a field an error occurs. To get the information whether a text field can be inserted at the current input position the CanAdd property can be used. To insert a field at a position other than the current one, first move the input position using the following code:

[Visual Basic]
Dim NewField As New TextField("new field")
TextControl1.InputPosition = New InputPosition(1, 3, 0)
TextControl1.TextFields.Add(NewField)
[C#]
TextField newField = new TextField("new field");
textControl1.InputPosition = new InputPosition(1, 3, 0);
textControl1.TextFields.Add(newField);

This code inserts the field on the first page, in the third line, at position zero. position zero is the position in front of the first character.

To remove a marked text field from the document use the collection's Remove method as shown with the following code:

[Visual Basic]
Dim tfc As TextFieldCollection = TextControl1.TextFields
Dim Field As TextField = tfc.GetItem(200)
If Not Field Is Nothing Then
    tfc.Remove(Field)
End If
[C#]
TextFieldCollection tfc = textControl1.TextFields;
TextField textField = tfc.GetItem(200);
if (textField != null) {
    tfc.Remove(textField);
}

This code removes the text field with the identifier 200. How to relate and use identifiers for text fields is described in the chapter Identifiers and Names.

If a text field is added during editing, a TextControl.TextFieldCreated event occurs. This can happen, if a piece of text containing a field is inserted from the clipboard, or if a field is restored through an undo/redo operation. This event does not occur, if a document containing fields is loaded, or if a field is added from programming code.

If a text field is deleted during editing, a TextControl.TextFieldDeleted event occurs. This can happen, if a selection of text containing a field is deleted, or if a field is deleted through an undo/redo operation. The event does not occur, if a field is deleted from program code.

The event handlers for these events also receive an argument of type TextFieldEventArgs. The TextField object that can be obtained through the TextField property identifies the field that has caused the event. If a field has been deleted, only the TextField.ID and the Textfield.Name properties provide valid values.


Identifiers and Names for Text Fields and Hypertext Links

A Text Control can manage an identfier and/or a name for each text field. These data can be specified with the TextField.ID and TextField.Name properties. For example, when a Text Control is used to show the contents of a database, a marked text field can be created for each database field. The database's field names can then be related to the text fields using the TextField.Name property. If something then happens with the field and an event occurs, the TextField.Name property informs, which field has caused the event. The following code inserts a field presenting a price:

[C#]
TextField newField = new TextField("$ 22.45");
newField.Name = "Price";
txTextControl1.TextFields.Add(newField);
[Visual Basic]
Dim NewField As New TextField("$ 22.45")
NewField.Name = "Price"
TextControl1.TextFields.Add(NewField)

When a marked text field is copied via the clipboard or saved to a file, the id and/or name belonging to the field are also copied or saved. If a field is copied via the clipboard, a TextControl.TextFieldCreated event occurs so that the programmer has the opportunity to change the id and/or name to avoid multiple occurrences. The following code shows an installed event handler for the TextFieldCreated event. This event occurs after the end-user has copied via the clipboard the field created above. The Name property of the created field is changed so that other code can distinguish between the two fields:

[C#]
textControl1.TextFieldCreated
        += new TextFieldEventHandler(textControl1_TextFieldCreated);
private void textControl1_TextFieldCreated(object sender, TextFieldEventArgs e) {
    if (e.TextField.Name == "Price") {
        e.TextField.Name = "Copy of Price";
    }
}
[Visual Basic]
Private Sub TextControl1_TextFieldCreated(ByVal sender As Object, _
        ByVal e As TextFieldEventArgs) Handles TextControl1.TextFieldCreated
    If e.TextField.Name = "Price" Then
        e.TextField.Name = "Copy of Price"
    End If
End Sub

Any string data can be assigned to the Name property. The number of characters is not limited so that even a large text can be related to a field.


Programming Hypertext Links

Hypertext links are connection points with other text positions in the same or another document. TX Text Control distinguishes between links that point to text positions in the same document and links that point to other documents. Links that point to another document are called hypertext links and are encapsulated through the HypertextLink class.

A link to another position in the same document is called a document link, encapsulated through the DocumentLink class. The position to which the link points can also be defined through the programmer. It is called a document target and can be specified with the DocumentTarget class.

For each type of these objects, a Text Control maintains a collection to enable the programmer to add, remove or manipulate an item. An appropriate property of the TextControl class as described in the chapter TextField Classes enables access to the collection.

The following code defines a link and a target inside a TextControl document. It first defines a target at the top of the document's second page and then creates a hypertext link that points to this target:

[C#]
int curPosition = textControl1.InputPosition.TextPosition;
DocumentTarget target = new DocumentTarget("Second Page");
textControl1.InputPosition = new InputPosition(2, 1, 0);
textControl1.DocumentTargets.Add(target);

textControl1.InputPosition = new InputPosition(curPosition);
DocumentLink link = new DocumentLink("Goto second page", target);
textControl1.DocumentLinks.Add(link);
[Visual Basic]
Dim curPosition As Integer = TextControl1.InputPosition.TextPosition
Dim Target As New DocumentTarget("Second Page")
TextControl1.InputPosition = New InputPosition(2, 1, 0)
TextControl1.DocumentTargets.Add(Target)

TextControl1.InputPosition = New InputPosition(curPosition)
Dim Link As New DocumentLink("Goto second page", Target)
TextControl1.DocumentLinks.Add(Link)

Before setting the input position to the second page, the old position is saved. The old position is restored before inserting the link. The target's constructor receives a name for the target, which is independent of the Name property inherited from the TextField class. Therefore, in addition to the target name, other string data can still be stored, using the document target's Name property.

There is no automatic linking implemented for a link-target pair in a Text Control document, because applications handle clicks differently depending on whether additional keyboard keys are pressed. To implement linking use the target's ScrollTo method when a user has clicked onto a link as shown with the following code example:

[C#]
textControl1.DocumentLinkClicked
         += new DocumentLinkEventHandler(textControl1_DocumentLinkClicked);
private void textControl1_DocumentLinkClicked(object sender, DocumentLinkEventArgs e) {
    if (Control.ModifierKeys == Keys.Control) {
        e.DocumentLink.DocumentTarget.ScrollTo();
    }
}
[Visual Basic]
Private Sub TextControl1_DocumentLinkClicked(ByVal sender As Object, _
        ByVal e As DocumentLinkEventArgs) Handles TextControl1.DocumentLinkClicked
    If Control.ModifierKeys = Keys.Control Then
        e.DocumentLink.DocumentTarget.ScrollTo()
    End If
End Sub

This code implements an event handler for the TextControl.DocumentLinkClicked event. The handler's code scrolls to the target that is connected with the link that has caused the event. This occurs only, if the CTRL keyboard key is pressed.

Hypertext links to other documents are treated similarly. They are inserted or deleted with the HypertextLinkCollection class. A click on such a link results in a TextControl.HypertextLinkClicked event. The application has to provide the code for the linking action.

All editing features, as described in the chapter Editing Marked Text Fields, can also be used for hypertext links. But a document target is handled like a text position, therefore editing a target is not possible and using the Text property with the DocumentTarget class results in an error. Relating string data and identifiers as described in the chapter Names and Identifiers is possible for links and targets. Further code examples can be found in the User's Guide chapter Using Hypertext Links.


Inserting Page Numbers

In a header or footer, accessible through the HeaderFooter class, special placeholders for page numbers can be inserted. Such a placeholder is defined through the PageNumberField class, also derived from the TextField class. Using such a field, a header or footer automatically shows the current page number or the total number of pages on every page.

Page number fields inherit the editing features of the TextField class and have additionally a NumberFormat, a StartNumber and a ShowNumberOfPages property. The NumberFormat property specifies the kind of numbers used to display the page numbers. Possible values are Arabic numbers, small and large Roman numbers, letters and capital letters. The StartNumber property defines the starting page number for the first page of the section. The ShowNumberOfPages property specifies whether the field shows the page number or the total number of pages.

For each section in the document, page numbers can either be continued from the previous section or can be restarted with a certain start number. The SectionFormat class provides the SectionFormat.RestartPageNumbering property to adjust this setting.

The following code adds a header to the current section. After insertion, the header receives a text, the current page number and total number of pages fields:

[C#]
HeaderFooterCollection hfc = textControl1.Sections.GetItem().HeadersAndFooters;

hfc.Add(HeaderFooterType.Header);

HeaderFooter h = hfc.GetItem(HeaderFooterType.Header);
if (h != null)
{
    h.Selection.Text = "Page  of ";
    h.Selection.Start = 5;
    h.Selection.Length = 0;

    PageNumberField page = new PageNumberField(1, NumberFormat.ArabicNumbers);
    page.Editable = false;
    page.DoubledInputPosition = true;
    h.PageNumberFields.Add(page);

    h.Selection.Start = 9;
    h.Selection.Length = 0;

    PageNumberField totalPages = new PageNumberField();
    totalPages.Editable = false;
    totalPages.DoubledInputPosition = true;
    totalPages.ShowNumberOfPages = true;
    h.PageNumberFields.Add(totalPages);
}
[Visual Basic]
Dim hfc As HeaderFooterCollection = textControl1.Sections.GetItem().HeadersAndFooters

hfc.Add(HeaderFooterType.Header)

Dim h As HeaderFooter = hfc.GetItem(HeaderFooterType.Header)
If h IsNot Nothing Then
    h.Selection.Text = "Page  of "
    h.Selection.Start = 5
    h.Selection.Length = 0

    Dim page As New PageNumberField(1, NumberFormat.ArabicNumbers)
    page.Editable = False
    page.DoubledInputPosition = True
    h.PageNumberFields.Add(page)

    h.Selection.Start = 9
    h.Selection.Length = 0

    Dim totalPages As New PageNumberField()
    totalPages.Editable = False
    totalPages.DoubledInputPosition = True
    totalPages.ShowNumberOfPages = True
    h.PageNumberFields.Add(totalPages)
End If

After the header has been inserted in the document, it receives the text Page of with a space after Page and at the end. Because a header has no Text property, this is done by replacing the text of the current text selection using the Selection class. Initially, a newly inserted header has no text, therefore the initial text selection has a length of zero so that the new text is inserted.

Afterwards, the current text input position is set between Page and of where the page number field is inserted. This field is set to not editable, so that an end-user cannot change its current text. To enable text insertion right of the page number, a second input position is needed. This can be reached by pressing the Right Arrow key at the text end.

After that, the input position is set to the end to insert the total number of pages field.


Importing Fields from Microsoft Word

TX Text Control supports field formats of other applications such as Microsoft Word. The ApplicationField class provides an interface to retrieve and change the data and parameters of such fields. Currently supported formats are the Microsoft Word Field Format, the format of Microsoft Word Form Fields and the field format of the Heiler HighEdit component. Because these formats are not compatible, the user must specify the format when a document is loaded. The following code imports all MergeField and PrintDate fields contained in a RTF document that has been created with Microsoft Word:

[C#]
LoadSettings ls = new LoadSettings();
ls.ApplicationFieldFormat = ApplicationFieldFormat.MSWord;
ls.ApplicationFieldTypeNames = new string[] { "MERGEFIELD", "PRINTDATE" };
textControl1.Load("c:\\test.rtf", TXTextControl.StreamType.RichTextFormat, ls);
[Visual Basic]
Dim ls As New LoadSettings
ls.ApplicationFieldFormat = ApplicationFieldFormat.MSWord
ls.ApplicationFieldTypeNames = New String() {"MERGEFIELD", "PRINTDATE"}
TextControl1.Load("c:\test.rtf", TXTextControl.StreamType.RichTextFormat, ls)

After the document has been loaded all MergeField and PrintDate fields are available through the TextControl.ApplicationFields collection. The collection contains objects of the type ApplicationField. The ApplicationField class has a TypeName property specifying the field's type and a Parameters property specifying the field's parameters as an array of strings. The following is the format of a MergeField defined through Microsoft Word:

MERGEFIELD FieldName [Switches]

For example: MERGEFIELD Address \* Upper \v

For further information about the switches and it's meaning, please refer to Microsoft's Field Reference:

http://www.textcontrol.com/in/msofficefieldreference.htm

In this example the FieldName is Address and there are two switches specifying some formatting options. The ApplicationField.Parameters array then contains three elements, the first of which is the FieldName and the others are the switches.

The following code iterates through all fields imported with the example above and sets the visible text of the address field:

[C#]
foreach (ApplicationField appField in textControl1.ApplicationFields) {
    if (appField.TypeName == "MERGEFIELD" && appField.Parameters[0] == "Address") {
        appField.Text = "Bakerstreet, London";
    }
}
[Visual Basic]
For Each appField As ApplicationField In TextControl1.ApplicationFields
    If appField.TypeName = "MERGEFIELD" And appField.Parameters(0) = "Address" Then
        appField.Text = "Bakerstreet, London"
    End If
Next

To add to or remove elements from the Parameters string array a new array must be constructed because .NET arrays have a fixed size. The following code looks for a \v switch and removes it from the parameters array. First a new array is created and the remaining strings that can be in front or behind the searched string are copied:

[C#]
foreach (ApplicationField appField in textControl1.ApplicationFields) {
  string[] params = appField.Parameters;
  int index = Array.IndexOf(params, "\\v");
  if (index >= 0) {
    string[] newParams = new string[params.Length-1];
    if (index > 0) {
      Array.Copy(params, newParams, index);
    }
    if (params.Length-index-1 > 0) {
      Array.Copy(params, index+1, newParams, index, params.Length-index-1);
    }
    appField.Parameters = newParams;
  }
}
[Visual Basic]
For Each appField As TXTextControl.ApplicationField In TextControl1.ApplicationFields
  Dim params() As String = appField.Parameters
  Dim index As Integer = Array.IndexOf(params, "\v")

  If index >= 0 Then
    Dim newParams(params.Length - 2) As String
    If index > 0 Then
      Array.Copy(params, newParams, index)
    End If
    If params.Length - index - 1 > 0 Then
      Array.Copy(params, index + 1, newParams, index, params.Length - index - 1)
    End If

    appField.Parameters = newParams
  End If
Next

TX Text Control also supports importing and exporting of Microsoft Word form fields. These fields can be imported specifying FORMCHECKBOX, FORMDROPDOWN or FORMTEXTBOX with the LoadSettings.ApplicationFieldTypeNames property. Microsoft Word form fields also have parameters, that can be edited in Microsoft Word with the Form Field Options dialog box. TX Text Control provides these parameters through the ApplicationField.Parameters property using the XML syntax of the Office Open XML Format.

To learn more about the Office Open XML Format, please refer to the official ECMA standard:

http://www.textcontrol.com/in/ecmaofficeopenxmlfileformats.htm

MS Word implements another feature to support individual controls like form elements in templates or forms: Content Controls. The following controls are available since MS Word 2007: Rich Text, Text, Picture, Combo Box, Drop-Down List and Check Box.

Just like for the merge and form fields, TX Text Control imports these fields as ApplicationFields available in the ApplicationField collection. TX Text Control provides parameters through the ApplicationField.Parameters property using the XML syntax of the Office Open XML Format. The content controls have the ApplicationField.TypeName SDTBLOCK. The type of the control is defined in the XML of the ApplicationField.Parameters property. The w:val parameter of the w:tag defines the type. The following types are available:

Content Control | Description
Rich Text Control | Text content that contains formatting.
Plain Text Control | Limited to content that cannot contain any formatting, only plain text.
picture | Fills the content control with a single picture.
Combo Box | Contains a list that can be edited directly.
Check Box | Provides a check box users can check and uncheck. The checked value is stored in the XML data.
dropDownList | Contains a list of restricted choices defined by the template author when the user activates the drop-down box.

Please refer to the official Microsoft Office documentation to learn more about the various content controls:

http://www.textcontrol.com/in/msofficecontentcontrols.htm


Using Images, Text Frames, Charts, Barcodes and Drawings

Images, text frames, charts, barcodes and drawings are represented through Image, TextFrame, ChartFrame, BarcodeFrame and DrawingFrame objects. The FrameBase class which is the base class of these objects handles the alignment in the text implementing properties like Location, TextDistances, InsertionMode, TextPosition and ChangeZOrder. All objects of the same kind are contained in collections, named ImageCollection, TextFrameCollection, ChartCollection, BarcodeCollection and DrawingCollection, which can be used to add and to remove items or to get a particular item from the collection. Furthermore a FrameCollection has been defined containing all images, text frames, charts, barcodes and drawings. This collection is useful to get a particular item, regardless of the kind of object.

A chart frame is always associated with a chart control of the type System.Windows.Forms.DataVisualization.Charting.Chart. Therefore charts can only be used, when the assembly which implements this control is available. The Charting namespace is part of the .net Framework since version 4 and can be downloaded and installed for the .net Framework version 3.5.

A barcode frame is associated with a barcode control of the type TXTextControl.Barcode.TXBarcodeControl or TXTextControl.WPF.Barcode.TXBarcodeControl and can be only used, if the optional product assemblies for TX Barcode .NET are available.

A drawing frame is associated with a drawing control of the type TXTextControl.Drawing.TXDrawingControl or TXTextControl.WPF.Drawing.TXDrawingControl, which are located in the TXDrawing.dll, TXDrawing.Windows.Forms.dll and TXDrawing.WPF.dll assemblies.

TX Text Control supports three ways of inserting an image, a text frame, a chart, a barcode or a drawing into a document:

  • Inline, which means that it is treated in the text like a single character.
  • Anchored to a paragraph, which means that it is moved with the paragraph it is anchored to. Text can either flow around the item or the item is displayed above or below the text. The frame's location is calculated from the top-left corner of the paragraph. If the image, text frame, chart, barcode or drawing is selected and moved by the end-user, the anchor position is also moved. The new anchor position becomes the top-left corner of the nearest paragraph.
  • At a fixed geometric position of the document. Text can either flow around around the item or the item is displayed above or below the text. The frame is not moved with the text and there is no anchor position in the text. The location is calculated from the top-left corner of a certain page or of the complete document.

Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings

Loading, Saving and Exporting Images


Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings

For each kind of object, image, textframe, chart, barcode and drawing, Text Control manages one collection containing all objects of that kind. The following describes the collection of images, the collections of the other work in the same way.

The image collection can be used to add and to remove images and to get a particular image from the collection. There are several Add methods which can be used to insert an image in the document.

The following two methods insert an image inline, which means that it is treated in the text like a single character:

[C#]
public bool Add();
public bool Add(Image image, int textPosition);
[Visual Basic]
Public Function Add() As Boolean
Public Function Add(ByVal image As Image, ByVal textPosition As Integer) As Boolean

The first version has no parameters and opens a File Open dialog box providing all image formats TX Text Control supports. The user can select an image, close the dialog box and the image is added to the collection and automatically inserted in the document at the current input position. The second method works in the same way, but inserts the image at the specified text position. To avoid, that a dialog box is opened, the Image.FileName and the Image.FilterIndex property of the specified Image object must be set.

The following two methods insert an image anchored to a paragraph, which means that it is moved with the paragraph it is anchored to:

[C#]
public bool Add(Image image, HorizontalAlignment alignment, int textPosition, ImageInsertionMode insertionMode);
public bool Add(Image image, Point location, int textPosition, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal alignment As HorizontalAlignment, ByVal textPosition As Integer, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Public Function Add(ByVal image As Image, ByVal location As Point, ByVal textPosition As Integer, _
  ByVal insertionMode As ImageInsertionMode) As Boolean

The text position can be any position in the paragraph. If -1 is specified, the image is anchored to the paragraph containing the current text input position. The location of the image relative to the paragraph is determined through a horizontal alignment or through a horizontal and a vertical offset. The position and extension of a paragraph is determined through its left and its right paragraph indent. The insertionMode parameter determines the textflow. The following values are possible:

  • AboveTheText: The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
  • BelowTheText: The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
  • DisplaceCompleteLines: The text stops at the top and continues at the bottom of the image.
  • DisplaceText: The text flows around the image and empty areas at the left and right side are filled.

Both methods open a file open dialog box only, when the Image.FileName and the Image.FilterIndex property of the specified Image object has not been set. The Image.Alignment property is only available for images anchored to a paragraph, for inline images and fixed positioned images a horizontal alignment is not defined.

The following code shows an example for inserting an image anchored to the fifth paragraph of a document:

[C#]
Paragraph p = textControl1.Paragraphs[5];
textControl1.Images.Add(new Image(), HorizontalAlignment.Left, p.Start-1, ImageInsertionMode.DisplaceText);
[Visual Basic]
Dim p As Paragraph = TextControl1.Paragraphs.Item(5)
TextControl1.Images.Add(New Image(), HorizontalAlignment.Left, p.Start - 1, ImageInsertionMode.DisplaceText)

The remaining two methods insert an image at a fixed geometric position in the document, which means that there is no anchor position and the image remains always at the same location:

[C#]
public bool Add(Image image, int page, Point location, ImageInsertionMode insertionMode);
public bool Add(Image image, Point location, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal page As Integer, ByVal location As Point, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Public Function Add(ByVal image As Image, ByVal location As Point, _
  ByVal insertionMode As ImageInsertionMode) As Boolean

The first method defines the geometric position through a certain page and a location relative to the top-left corner on that page. The second method defines the position relative to the top-left corner of the complete document. This also includes all gaps between the pages. The horizontal value is relative to the left edge of all pages and the vertical value is relative to the top of the document including the gap above the first page. Regardless of which method has been used to insert the image the Image.Location property returns the location relative to the complete document. The insertionMode parameter determines the textflow with the same values as descibed for images anchored to a paragraph. Both methods open a file open dialog box only, when the Image.FileName and the Image.FilterIndex property of the specified Image object has not been set.


Loading, Saving and Exporting Images

TX Text Control can load images saved with the following image formats:

  • FilterIndex 1: Windows Bitmap (.BMP)
  • FilterIndex 2: Tagged Image Format (.TIF)
  • FilterIndex 3: Windows Metafile (.WMF)
  • FilterIndex 4: Portable Network Graphics (.PNG)
  • FilterIndex 5: JPEG File Interchange Format (.JPG, .JPEG)
  • FilterIndex 6: Graphics Interchange Format (.GIF)
  • FilterIndex 7: Windows Enhanced Metafile (.EMF)

If an image has been added to a document with one of the ImageCollection.Add methods and this document is saved, a reference to the image file is saved. This reference is the image's file name including its absolute path on the file system. If such a document is loaded and the image to where the saved file reference points cannot be found, a rectangle with the image's size and a text string with the file name is displayed. The LoadSettings.ImageSearchPath property determines an additional path where to find images.

Images which are pasted from the clipboard have no file reference, therefore these images are saved in a document with their binary data. By default TX Text Control saves the image's binary data in its original file format.

Alternatively, a programmer can specify with the SaveSettings.ImageSaveMode or with the Image.SaveMode property whether images are saved through a file reference or with their binary data. The SaveSettings.ImageSaveMode property determines this for all images of the document and the Image.SaveMode property determines it for a certain image. If ImageSaveMode.SaveAsFileReference is specified for an image and a file for this image does not exist, a new file is created.

The SaveSettings.ImageExportFilterIndex and the Image.ExportFilterIndex properties can be used to save images in another than their original format. The SaveSettings.ImageExportFilterIndex property determines the export format for all images of the document and the Image.ExportFilterIndex property determines the export format for a certain image. TX Text Control supports the following formats to export images:

  • ExportFilterIndex 1: Windows Bitmap (.BMP)
  • ExportFilterIndex 2: Windows Metafile (.WMF)
  • ExportFilterIndex 3: Portable Network Graphics (.PNG)
  • ExportFilterIndex 4: JPEG File Interchange Format (.JPG, .JPEG)
  • ExportFilterIndex 5: Windows Enhanced Metafile (.EMF)
  • ExportFilterIndex 6: Tagged Image Format (.TIF)
  • ExportFilterIndex 7: Graphics Interchange Format (.GIF)

If an export format has been specified and a text filter does not support this format, the image is stored in the default format of the text filter. The following lists the image formats supported by each text filter. The first format (in bold) is the default format, used when the specified format is not possible:

  • RTF Format (Rich Text Format): PNG, BMP, JPG, WMF, EMF
  • Microsoft Word Format (.DOC version): WMF, EMF, BMP, PNG, JPG
  • Microsoft Word Format (Office Open XML version): PNG, WMF, EMF, BMP, JPG, GIF
  • HTML Format (Hypertext Markup Language): PNG, JPEG, GIF
  • Adobe Portable Document Format (PDF): BMP, JPG
  • TX Text Control Format: WMF, EMF, BMP, PNG, JPG, GIF

If images are exported in another format, either the binary data is embedded in the document or new files are created and references to these files are embedded in the document. TX Text Control creates these files with the following rules:

  • The SaveSettings.ImageSavePath property determines the location on the file system where the image files are created.
  • If the SaveSettings.ImageSavePath property has not been set, TX Text Control creates a sub-directory of the directory where the text document is stored. The name of this directory has the same name as the text document and _Images is appended. For example if the text document is c:\temp\sample.rtf, the name of the sub-directory is c:\temp\sample_Images\.
  • The image's filename is determined through the Image.ExportFileName property or can be set through the built-in TextControl.ImageAttributesDialog dialog box by the end-user.
  • If an export filename has not been specified, TX Text Control uses the original filename and exchanges the extension according to the exported format.
  • If a filename does not exist, TX Text Control uses the text document's filename and appends a number. For the example above, if the export format is Windows Bitmap, the images' filenames are sample_1.bmp, sample_2.bmp and so on.


Using Document Sections

Document sections allows you to split a document into separate sections to enable different page sizes, margins or headers and footers. Since version 15.0, page columns can be adjusted separately for each inserted section.

When you are not used to word processing, sections might not be self-explanatory. For instance, sections enable users to create documents with mixed page orientation, so that parts are inserted as portrait and other parts as landscape. It is possible to add different headers and footers to specific sections or to include page numbering only for the main part of a document and omit it in an appendix.

Accessing Document Sections

The Page Setup Dialog


Accessing Document Sections

All sections are listed in the SectionCollection class that can be accessed using the Sections property.

By inserting a new section using the Add method, a section break character is inserted at the current input position. Using TX Text Control, it is possible to insert a new section that starts at a new page or at a new line. The page size and different headers and footers can only be changed when inserting a new page.

All settings of the previous section are inherited when creating a new document section. In other words, if a specific header is inserted to the previous section, this header will be displayed in the new section as well. To avoid that, the ConnectedToPrevious property of the HeaderFooter object can be set to false. In this case, the new section is getting it's own header.

To modify the headers and footers of a specific section, the HeadersAndFooters property of the specific section must be manipulated. In previous versions of TX Text Control, the headers and footers were accessed through the HeadersAndFooters property of the main control which is no longer recommended. It is still possible, but if more than 1 section is inserted, most of the other collections in the HeaderFooter object are NULL. Example:

The text of each header in every section must be changed. Therefore, all sections and their specific headers and footers must be iterated. The following code snippet shows this approach:

[C#]
foreach (Section sec in textControl1.Sections)
{
    foreach (HeaderFooter hed in sec.HeadersAndFooters)
    {
        hed.Selection.Text = "New Text";
    }
}
[Visual Basic]
For Each sec As TXTextControl.Section In TextControl1.Sections
    For Each hf As TXTextControl.HeaderFooter In sec.HeadersAndFooters
        hf.Selection.Text = "New Text"
    Next
Next

Sections is a layer wrapped over the text and its pages. The text, images, tables and all other elements can be accessed using the normal collections of the main TX Text Control. Only the content in the different headers and footes must be accessed through the specific section.


The Page Setup Dialog

TX Text Control is shipped with a dialog box that can be used to manipulate the section settings. The first screenshot shows the section format dialog that comes with TX Text Control. It allows users to change the page format for the complete document or the current section.

The following screenshot shows the second tab of the same dialog box. On this tab page, it is possible to specify whether headers and footers are added to the current section, if they should be connected to the previous one and to adjust the different settings for headers and footers.

In the combo boxes, you have three possibilities for headers and footers when applying the changes to the complete document:

  • None: No header or footer is inserted
  • All sections equal: All sections are getting the same header or footer
  • All sections different: Each section is getting it's own header or footer

When applying the settings to the current section, the following possibilities are available:

  • None: No header or footer is inserted
  • Same as previous section: The new header or footer is connected to the previous one
  • This section different: The new header or footer is not connected to the previous one


Data binding with TX Text Control

TX Text Control .NET for WPF and TX Text Control .NET for Windows Forms offer a new concept of binding WPF.TextControl or TextControl to a button bar or any ribbon bar. The WPF.InputFormat or TextControl.InputFormat class represent all formatting attributes at the current text input position.

XAML data binding with TX Text Control .NET for WPF

Data binding with TX Text Control .NET for Windows Forms


XAML data binding with TX Text Control .NET for WPF

One of the major motivations to port Windows Forms applications to WPF is WPF's powerful data binding capabilities using XAML. Using TX Text Control .NET for WPF, interface controls like buttons or dropdown menus of a Ribbon bar can be easily connected to TX Text Control without writing one line of C# or VB.NET code. The connection can be completely done in XAML, making such bindings quick, flexible and easy.

To implement WPF data binding, a target and a source is required. The target can be any public property or element which is derived from DependencyProperty. The source of a WPF binding can be any property or other objects.

An example:

A ToggleButton should visualize, whether the character formatting at the current input position is bold or not and it should change this state when the button is clicked. In this case, the target of the data binding is the IsChecked property of the ToggleButton. The source is the Bold property of the new TX Text Control WPF.InputFormat class. This class represents all formatting attributes at the current text input position. The properties of this class are updated automatically when the input position changes.

The following XAML code shows the ToggleButton and it's binding:

<ToggleButton Name="tbtnBold" Content="Bold" Focusable="False"
              IsChecked="{Binding
                ElementName=textControl1,
                Path=InputFormat.Bold, Mode=TwoWay}" />

The Mode attribute has been set to TwoWay in the Binding statement. This attribute specifies how the data flows between the source and the target. The following methods are available:

  • OneWay: The data flows from the source to target each time a change is made on the source.
  • TwoWay: The data flows from the source to target and vice versa each time a change is made on the source or target.
  • OneTime: The data flows from the source to target when the application is started.
  • OneWayToSource: The data flows from the target to source each time a change is made on the target.

In this sample, a textual ToggleButton is used and text can be changed when the button is checked. Also for this action we do not need any code behind and it can be done directly in XAML. A Trigger can be used to listen to the IsChecked property in order to change the text accordingly. If you bind the Value of the Content property, it must not be set as a parameter in the ToggleButton element directly:

<ToggleButton Name="tbtnBold" Focusable="False"
              IsChecked="{Binding
                ElementName=textControl1,
                Path=InputFormat.Bold, Mode=TwoWay}">

    <ToggleButton.Style>
        <Style TargetType="{x:Type ToggleButton}">
            <Setter Property="Content" Value="Bold"/>
            <Style.Triggers>
                <Trigger Property="IsChecked" Value="True">
                    <Setter Property="Content" Value="UnBold"/>
                </Trigger>
            </Style.Triggers>
        </Style>
    </ToggleButton.Style>

</ToggleButton>


Data binding with TX Text Control .NET for Windows Forms

The same functionality is available in the Windows Forms version as well. Windows Forms offers a similar way of binding properties to data sources or other properties. But the binding is not added in XAML (which is a concept of WPF), but the code itself. But the advantage is still valid: The presentation layer can be abstracted and no additional event handling is required to update the state of specific buttons or menu entries.

The TextControl.InputFormat class is available in the Windows Forms version as well. The properties of this class can be bound to other controls.

The following code shows how to bind a CheckBox that is displayed as a toggle button to the Bold property of the TextControl.InputFormat class:

[C#]
checkBox1.DataBindings.Add("Checked", textControl1.InputFormat, "Bold", true, DataSourceUpdateMode.OnPropertyChanged);
[Visual Basic]
CheckBox1.DataBindings.Add("Checked", TextControl1.InputFormat, "Bold", True, DataSourceUpdateMode.OnPropertyChanged)


PDF Import and Export

The Portable Document Format (PDF) is mainly used to provide a way to exchange documents between systems without changes to the document formatting. Using PDF, a document will retain it's formatting and layout when being printed or displayed on different machines or operating systems. TX Text Control can import PDF file as text and export all supported formats to PDF and PDF/A.

Importing Text from a PDF File

Loading Encrypted PDF files

Exporting Documents as PDF Files


Importing Text from a PDF File

PDF, like its close relative, PostScript, is a page description format. Its original purpose was to display documents on different platforms, preserving the layout and formatting to the greatest possible detail. Loading a PDF file back into a word processor, except for making very small changes, was never planned.

A PDF file therefore contains detailed information about the appearance of text characters, but not necessarily about their meaning. In other words, it specifies exactly what a character should look like and where on a page it is to be positioned, but not which Ansi or Unicode character it actually is. Because of that, it is not always possible to extract text from a PDF file.

Besides this, there is no information about text order or text flow or whether a piece of text is a header or a table cell. Although recent enhancements to the PDF specification allow for including this type of information, it is rarely used. Fortunately, the majority of PDF files contain one or another form of character mapping, which enables a PDF reader to convert the contained text to a Unicode string.

TX Text Control extracts and converts all of the text it can find, adds missing spaces and paragraph breaks, and resorts the various text blocks so that they appear in their logical order.

The resulting text will be formatted according to the setting of the LoadSettings.PDFImportSettings property.

Features of TX Text Control's PDF import:

  • Text can be imported from PDF and PDF/A files, and saved in any of the formats supported by TX Text Control
  • Logical text order and missing spaces are restored
  • Text formatting, including font names, sizes and styles
  • Unicode support
  • Adobe Acrobat(R) is not required


Loading Encrypted PDF files

A PDF may be encrypted, and may optionally be protected by a user password and an owner password. TX Text Control handles encryption internally, but the application is responsible for acquiring the respective passwords from the user, and to restrict access to certain operations, like printing or editing, if the passwords are not specified or do not match.

1. User Password

The user password is required to open the document. A FilterException exception with the Reason property set to FilterError.InvalidPassword is thrown when attempting to load a PDF that is protected with a user password. If this exception occurs, the application should ask the user for the password and retry loading the PDF with the password specified in LoadSettings.UserPassword.

If the PDF has been loaded, the LoadSettings.DocumentAccessPermissions flags specify which operations are allowed.

End user applications should disable all operations that are not allowed, for instance by graying out the Print menu item if DocumentAccessPermissions.AllowLowLevelPrinting is not included.

2. Owner Password

The owner password is required to change a PDF files's security settings. Without the correct owner password, a PDF file can be displayed, but editing or printing may be prohibited. If the correct owner password is specified in LoadSettings.MasterPassword, DocumentAccessPermissions.AllowAll will be set after the file has been loaded, and no restrictions apply.

3. Permissions

Access permissions are described in LoadSettings.DocumentAccessPermissions.

4. Encryption Algorithms

PDF files can be encrypted with a variety of encryption algorithms. Supported are:

  • Acrobat 3.0 and later 40-bit RC4
  • Acrobat 5.0 and later 128-bit RC4
  • Acrobat 6.0 and later 128-bit RC4
  • Acrobat 7.0 and later 128-bit AES

Not supported are:

  • Acrobat 9.0 and later 256-bit AES
  • Certificates

A FilterException exception with the Reason property set to FilterError.Encrypted is thrown, if one of the unsupported algorithms is encountered.


Exporting Documents as PDF Files

TX Text Control offers two different PDF versions to save a document to:

  • Standard PDF version 1.3, compatible to Acrobat 4.x and higher
  • PDF/A-1b, OSI standard

PDF/A is a format that has been created for long-term archiving of electronic documents. This PDF standard states that the created PDF file must be 100 % self-contained, e.g. all the information, that is necessary to display the content must be embedded in the file. Furthermore, audio and video content is forbidden as well as JavaScript and any executable code. Also, encryption is not allowed.

The PDF/A standard is based on the PDF Reference Version 1.4 from Adobe Systems Inc. and has been published as an ISO standard on October 1, 2005.

TX Text Control's PDF filter can export documents to PDF/A-1b, so that documents can be archived in compliance to ISO standards.

Using PDF/A in TX Text Control

To export any content in TX Text Control to a PDF/A-1b file, the Save method has to be used with the AdobePDFA StreamType enumeration. To export the page size of a document to PDF, the TextControl.ViewMode must be set to PageView.

Basic Steps to Create a PDF/A Document in an Application

1. The ViewMode property has to be set to PageView

2. FontSettings.EmbeddableFontsOnly has to be set to true.

3. The document can now be saved to PDF/A with the TextControl.Save method.

The usage of fonts can be restricted with the properties FontSettings.EmbeddableFontsOnly, FontSettings.ScalableFontsOnly and FontSettings.TrueTypeFontsOnly. The first property triggers if only embedabble can be used in a document, the second if only free scalable fonts and the latter if only TrueType (TTF) fonts are allowed to be used.

Please note that not every font can be embedded using PDF/A, which may have different reasons: Either a font's license forbids embedding or a device dependent font is used.

TX Text Control includes an advanced algorithm to replace any font that can not be embedded. For this purpose, the AdaptFont event has been implemented to provide means to programmatically set the font, that will be used to replace a non-embeddable font. The event itself must be activated with the FontSettings.AdaptFontEvent property.

In the event, the AdaptFontEventArgs.FontName property represents the original font, that can not be embedded. The AdaptFontEventArgs.AdaptedFontName property is the font name, that will be used to replace the original font and SupportedFonts is an array of all supported fonts that can be used in a document.

For each font, that can not be embedded, the AdaptFont event will be fired if FontSettings.AdaptFontEvent has been set previously to true.


Using the Resource Kit

TX Text Control .NET offers a Resource Kit that enables developers to display TX Text Control's user interface parts in languages other than English and German. English and German are the built-in resources and cannot be changed. All other languages are possible with the satellite assembly mechanism the prefered mechanism for localization within the .NET Framework. The following describes how to build a satellite assembly.

TX Text Control Resources

Resource Kit Files

Building the Satellite Assembly

Installing the Satellite Assembly


TX Text Control Resources

TX Text Control has built-in dialog boxes and error strings. Additionally, it uses resources which are part of the .NET Framework such as the Load File... or Save File... dialog boxes. The language used for the parts of the .NET Framework depend on the current system language. Therefore, the built-in Text Control resources follow this mechanism and also depend on the current system language. For example, if a developer builds a satellite assembly for French, the French resources are only loaded if the current system language is also French.


Resource Kit Files

The ResourceKit directory, which is a subdirectory of your TX Text Control.NET main installation directory, contains all necessary files. The TextControl.resx file contains all built-in resources in a human readable XML format. All parts of dialog boxes appear as strings.

The buildres.bat file is a command line batch file that calls the command line tools of the .NET Framework SDK necessary to build the satellite assembly.

The txtextcontrol.public.snk file contains TX Text Control's public key also necessary to build the satellite assembly.


Building the Satellite Assembly

To build a satellite assembly for TX Text Control, perform the following tasks:

1. Install at least the .NET Framework SDK.

2. Translate all the text resources in the TextControl.resx file. The text resources are the contents of the value tags.

3. Call the buildres.bat batch file with the two letter language code specified through ISO 639 as parameter (for example French: buildres fr). The batch process builds the satellite assembly file txtextcontrol.resources.dll.


Installing the Satellite Assembly

The newly created assembly must be located in a subdirectory of your application's installation directory, which must contain all necessary TX Text Control files. The name of the subdirectory must be the two letter language code. For example to install a French satellite assembly create a subdirectory fr and copy txtextcontrol.resources.dll to this directory.

Additionally, create the following registry key to ensure that the .NET Framework uses custom builds of satellite assemblies with your application:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\StrongName\Verification\txtextcontrol.resources,6B83FE9A75CFB638]


Working with XML Files

Loading and Saving XML Files

Editing XML Files

Programming XML Documents

Inserting and Deleting XML Elements


Loading and Saving XML Files

TX Text Control offers several built-in features to edit and to manipulate XML files. XML files can be loaded and saved like all other files using the Load and Save methods.

When an XML file is loaded TX Text Control considers the corresponding document type description file (DTD) and checks the document for validity. If the document is invalid (which means that it does not fulfill the rules in the DTD), a TextControl.XmlInvalid event occurs. However, the document's text including its formatting styles is still loaded. The document can then be edited as a normal text document with all the editing features TX Text Control offers.

Otherwise, if the document is valid according to the corresponding DTD, Text Control loads the document's text and formatting styles and switches to a special XML editor mode which guarantees that the document remains valid during editing. This article describes how the XML editor mode works and how an application can manipulate an XML document. The TextControl.XmlEditMode property informs about the state of the XML editor.

If an XML document is not well-formed (which means that it contains invalid XML syntax) a TextControl.XmlNotWellFormed event occurs and the document is not loaded. Both the XmlInvalid and the XmlNotWellFormed event informs the application about the positon in the file where the error occurs and the cause of the error.

During loading, a Text Control looks for corresponding formatting styles contained in a CSS file. If such a file is found, the styles are loaded and all formatting attributes are displayed. All further editing and manipulation of the XML document can be performed in WYSIWYG mode.

Because an XML document becomes invalid if it is inserted into another existing document, XML documents cannot be loaded or saved with the Selection.Load and the Selection.Save methods.

If an XML document is saved using the TextControl.Save method, only the document's text is saved to the XML file. To save the document's formatting styles to the corresponding CSS file, a second call of the TextControl.Save method must be performed. Changing and saving the document's DTD is not supported. Neither is it supported to create completely new XML documents.


Editing XML Files

XML documents consist of elements. Some of these elements contain the document's text, other elements represent the document's structure. Consider the following XML document that contains a list of addresses:

<?xml version="1.0"?>
<?XML:stylesheet type="text/css" href="addresses.css"?>
<!DOCTYPE Addresses SYSTEM "addresses.dtd">
<Addresses>
   <DocumentHeadline>Addresses</DocumentHeadline>
   <AddressTable>
      <Address>
         <Name>Jack Miller</Name>
         <Street>Baker Street</Street>
         <City>New York</City>
      </Address>
      <Address>
         <Name>Tom Baker</Name>
         <Street>Miller Street</Street>
         <City>Los Angeles</City>
      </Address>
      <Address>
         <Name>Bill Taylor</Name>
         <Street>Old Street</Street>
         <City>Washington</City>
      </Address>
   </AddressTable>
</Addresses>

In this example, the elements DocumentHeadline, Name, Street and City contain the document's text, the other elements Addresses, AddressTable and Address are structural elements without any text. After this document has been loaded, a Text Control displays it WYSIWYG with the formatting styles found in the specified CSS file and automatically switches to the XML editor mode. In this mode, text can be inserted or deleted like in any other document. Text selections are possible only inside single XML elements. If a user tries to select more than one element, the selection is expanded to its maximum, which is the complete text of the single element.

Like in tables, the TAB (Shift TAB) key can be used to select the complete text of the next (previous) element. Clipboard operations are possible as in any other document, but if text is inserted from another document, it is inserted without any formatting attributes.

Because XML documents do not contain formatting attributes they can be changed only via formatting styles. Formatting via the Button Bar changes the attributes of the current style. Formatting via formatting functions is disabled in XML documents. To change formatting attributes either the built-in style dialog boxes available through the TextControl.FormattingStylesDialog method or the InlineStyle and the ParagraphStyle collections can be used. To make these changes permanent, the new attributes must explicitly be saved in the CSS file.


Programming XML Documents

TX Text Control exposes the elements of an XML document through collections of XmlElement objects. The TextControl.GetXmlElements property returns an element collection. There is one collection for each kind of elements. In the example document above there is a collection for all Address elements and another collection for all Name elements. The following line of code gets the collection of the Name elements:

[Visual Basic]
Dim NameElements As XmlElementCollection
NameElements = TextControl1.GetXmlElements("Name")
[C#]
XmlElementCollection nameElements = textControl1.GetXmlElements("Name");

The collection object has the XmlElementCollection.GetItem method to access a single element. With the XmlElement.Text method, the following line of code displays the content of the second Name element:

[Visual Basic]
Console.WriteLine(NameElements.GetItem(2).Text)
[C#]
Console.WriteLine(nameElements.GetItem(2).Text);

The contents of elements containing sub-elements is the complete text of all sub-elements separated through new line characters (character value 10). For example the line of code:

[Visual Basic]
Console.WriteLine(TextControl1.GetXmlElements("Address").GetItem(2).Text)
[C#]
Console.WriteLine(textControl1.GetXmlElements("Address").GetItem(2).Text);

in the example above displays:

Tom Baker
Miller Street
Los Angeles

To set a new text with the Text property, the specified text string must be separated through new line characters:

[Visual Basic]
TextControl1.GetXmlElements("Address").GetItem(2).Text() _
    = "Paul Baskerville" + Chr(10) + "Jackson Street" + Chr(10) + "London"
[C#]
textControl1.GetXmlElements("Address").GetItem(2).Text
    = "Paul Baskerville\nJackson Street\nLondon";

With a For Each statement a program can iterate through an XML element collection. The following example displays all names:

[Visual Basic]
Dim NameElement As XmlElement
For Each NameElement In TextControl1.GetXmlElements("Name")
   Console.WriteLine(NameElement.Text)
Next NameElement
[C#]
foreach (XmlElement element in textControl1.GetXmlElements("Name")) {
    Console.WriteLine(element.Text);
}

This code is equivalent to the following code using the collection's Count property:

[Visual Basic]
Dim I As Integer
Dim NameElements As XmlElementCollection
NameElements = TextControl1.GetXmlElements("Name")
For I = 1 To NameElements.Count
   Console.WriteLine(NameElements.GetItem(I).Text)
Next I
[C#]
XmlElementCollection nameElements = textControl1.GetXmlElements("Name");
for (int i = 1; i <= nameElements.Count; i++) {
    Console.WriteLine(nameElements.GetItem(i).Text);
}

An XML element collection also has an Add and a Remove method to insert or delete elements. These are explained in the following section.


Inserting and Deleting XML Elements

The structure of an XML document is described through a document type description (DTD) either contained inline, in the XML file or in a separate DTD file. The following is an example of a DTD file belonging to the XML example above (addresses.dtd):

<!ELEMENT Addresses (DocumentHeadline, AddressTable)>
<!ELEMENT DocumentHeadline (#PCDATA)>
<!ELEMENT AddressTable (Address+)>
<!ELEMENT Address (Name, Street, City)>
<!ELEMENT Name (#PCDATA)>
<!ELEMENT Street (#PCDATA)>
<!ELEMENT City (#PCDATA)>

A DTD allows text only for elements with the #PCDATA statement. Furthermore, this DTD defines that the document must have a single document headline and a single address table. The address table can have one or more addresses and each address must have three sub-elements: Name Street and City.

With all of these instructions, inserting or removing elements is allowed only for complete addresses. Should a program try to insert or remove one of the other elements, an invalid document and an XmlInvalid event occurs.

To insert an address, first create a new XmlElement object, initialize it with a name and a text and then use the Address collection's Add method as shown in the following piece of code:

[Visual Basic]
Dim NewAddress As New XmlElement("Address", _
        "Paul Baskerville" + Chr(10) + "Jackson Street" + Chr(10) + "London")
TextControl1.GetXmlElements("Address").Add(NewAddress, -1, 2)
[C#]
XmlElement newAddress =
    new XmlElement("Address", "Paul Baskerville\nJackson Street\nLondon");
textControl1.GetXmlElements("Address").Add(newAddress, -1, 2);

This code inserts the new address after the second address in the document. Using the Add method's before parameter an element can also be inserted before a certain element.

The following line of code removes the address just inserted:

[Visual Basic]
TextControl1.GetXmlElements("Address").Remove(3)
[C#]
textControl1.GetXmlElements("Address").Remove(3);

Because the DTD enforces at least one address, trying to remove the last address also results in an invalid document and an XmlInvalid event occurs.


How-To Guide

This chapter contains a collection of how-to guides for specific typical tasks that can be realized with TX Text Control. In contrast to the shipped sample applications that are described in the different user's guides, this chapter describes the non-basic functionality of TX Text Control.

Creating Multipage TIFF Images

Importing MS Word Merge Fields

Inserting a Table with Text Fields

Adding a Header and a Footer with Data to a Document

Replacing a Paragraph with a Line Break on Enter Key

Scrolling programmatically to a Text Position

Printing without the Status Dialog

TXTextControl.Selection and Undo

Removing empty Pages

Inserting Columns programmatically using TX Text Control .NET

Getting the Page Number at the Current Scroll Location

Printing into a PrintDocument


Creating Multipage TIFF Images

TX Text Control .NET 15.0 introduced the page rendering engine that allows you to export a metafile or a bitmap of each separate page. This enables developers to create thumbnails of the pages or to export images to view them in a browser. This sample shows how to create a multipage TIFF image from all pages of a document.

Two significant steps are required to create these images:

  • Create a TIFF image using the page rendering engine
  • Combine those images to a single TIFF image

First, it is required to iterate through all pages of TX Text Control to create separate TIFF images:

[C#]
ArrayList inputImages = new ArrayList();

foreach (Page page in textControl1.GetPages())
{
  MemoryStream image = new MemoryStream();
  Bitmap mf = page.GetImage(100, TXTextControl.Page.PageContent.All);
  mf.Save(image, ImageFormat.Tiff);
  inputImages.Add(image);
}
[Visual Basic]
Dim inputImages As New ArrayList()

For Each page As Page In textControl1.GetPages()
  Dim image As New MemoryStream()
  Dim mf As Bitmap = page.GetImage(100, TXTextControl.Page.PageContent.All)
  mf.Save(image, ImageFormat.Tiff)
  inputImages.Add(image)
Next

Each TIFF image is stored in a memory stream which is added to an ArrayList for an easier handling when combining them.

In a second step, the TIFF images are combined to a single image. Therefore, a new image is created in order to append all other images from the ArrayList to a new frame of the new image using the SaveAdd method.

[C#]
public static void CreateMultipageTIF(ArrayList InputImages, string Filename)
{
 // set the image codec
 ImageCodecInfo info = null;
 foreach (ImageCodecInfo ice in ImageCodecInfo.GetImageEncoders())
 {
   if (ice.MimeType == "image/tiff")
   {
     info = ice;
     break;
   }
 }

 EncoderParameters ep = new EncoderParameters(2);

 bool firstPage = true;

 System.Drawing.Image img = null;

 // create a image instance from the 1st image
 for (int nLoopfile = 0; nLoopfile < InputImages.Count; nLoopfile++)

 {
   //get image from src file
   System.Drawing.Image img_src = System.Drawing.Image.FromStream((Stream)InputImages[nLoopfile]);

   Guid guid = img_src.FrameDimensionsList[0];
   System.Drawing.Imaging.FrameDimension dimension = new System.Drawing.Imaging.FrameDimension(guid);

   //get the frames from src file
   for (int nLoopFrame = 0; nLoopFrame < img_src.GetFrameCount(dimension); nLoopFrame++)
   {
     img_src.SelectActiveFrame(dimension, nLoopFrame);

     ep.Param[0] = new EncoderParameter(System.Drawing.Imaging.Encoder.Compression, Convert.ToInt32(EncoderValue.CompressionLZW));

     // if first page, then create the initial image
     if (firstPage)
     {
       img = img_src;

       ep.Param[1] = new EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.MultiFrame));
       img.Save(Filename, info, ep);

       firstPage = false;
       continue;
     }

     // add image to the next frame
     ep.Param[1] = new EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.FrameDimensionPage));
     img.SaveAdd(img_src, ep);
   }
 }

 ep.Param[1] = new EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.Flush));
 img.SaveAdd(ep);
}
[Visual Basic]
Public Shared Sub CreateMultipageTIF(InputImages As ArrayList, Filename As String)
  ' set the image codec
  Dim info As ImageCodecInfo = Nothing
  For Each ice As ImageCodecInfo In ImageCodecInfo.GetImageEncoders()
    If ice.MimeType = "image/tiff" Then
      info = ice
      Exit For
    End If
  Next

  Dim ep As New EncoderParameters(2)

  Dim firstPage As Boolean = True

  Dim img As System.Drawing.Image = Nothing

 ' create a image instance from the 1st image
 For nLoopfile As Integer = 0 To InputImages.Count - 1
   ' get image from src file
   Dim img_src As System.Drawing.Image = System.Drawing.Image.FromStream(DirectCast(InputImages(nLoopfile), Stream))

   Dim guid As Guid = img_src.FrameDimensionsList(0)
   Dim dimension As New System.Drawing.Imaging.FrameDimension(guid)

   ' get the frames from src file
   For nLoopFrame As Integer = 0 To img_src.GetFrameCount(dimension) - 1
     img_src.SelectActiveFrame(dimension, nLoopFrame)

     ep.Param(0) = New EncoderParameter(System.Drawing.Imaging.Encoder.Compression, Convert.ToInt32(EncoderValue.CompressionLZW))

     ' if first page, then create the initial image
     If firstPage Then
       img = img_src

       ep.Param(1) = New EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.MultiFrame))
       img.Save(Filename, info, ep)

       firstPage = False
       Continue For
     End If

     ' add image to the next frame
      ep.Param(1) = New EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.FrameDimensionPage))
     img.SaveAdd(img_src, ep)
   Next
 Next

 ep.Param(1) = New EncoderParameter(System.Drawing.Imaging.Encoder.SaveFlag, Convert.ToInt32(EncoderValue.Flush))
 img.SaveAdd(ep)
End Sub

<< Back


Importing MS Word Merge Fields

Starting with TX Text Control .NET 14.0, MS Word Merge Fields can be imported into the TextControl or ServerTextControl with the LoadSettings class. The LoadSettings.ApplicationFieldFormat property is used to enable TX Text Control to load the ApplicationField type text fields.

For MS Word merge fields, it must be set to ApplicationFieldFormat.MSWord.

The LoadSettings.ApplicationFieldTypeNames property sets the type name of each field. For MS Word Merge Fields and Form Fields, it is MERGEFIELD.

The ApplicationField.Parameters property defines the field's parameters, e.g. its functionality.

It has the format MERGEFIELD FieldName [switches]

The following code imports MS Word merge fields from a DOCX file:

[C#]
TXTextControl.LoadSettings ls = new TXTextControl.LoadSettings();
ls.ApplicationFieldFormat = ApplicationFieldFormat.MSWord;
ls.ApplicationFieldTypeNames = new string[] { "MERGEFIELD" };
textControl1.Load(@"C:\test.docx", TXTextControl.StreamType.WordprocessingML, ls);
[Visual Basic]
Dim LS As New TXTextControl.LoadSettings()
LS.ApplicationFieldFormat = ApplicationFieldFormat.MSWord
LS.ApplicationFieldTypeNames = New String() {"MERGEFIELD"}
TextControl1.Load("C:\test.docx", TXTextControl.StreamType.WordprocessingML, LS)

Each MS Word merge field has been imported into the TextControl.ApplicationFields collection after that.

<< Back


Inserting a Table with Text Fields

Tables are often used to display data and TX Text Control's ApplicationField type text fields are the perfect tool to merge data into tables. The whole procedure can be divided into three simple steps:

  • Insert a table
  • Fill the table with text and fields
  • Apply text formatting to the table cells

The following code inserts a 6 x 3 table and adds the header texts to the first table row.

To format the first table row's text bold, the cursor is set to the first text position in the first table cell with

textControl1.Selection.Start = table.Cells.GetItem(1, 1).Start - 1;.

The lenght of the selection is calculated with

textControl1.Selection.Length = table.Cells.GetItem(1, 3).Start - 1 + table.Cells.GetItem(1, 3).Length;.

As the Selection class is zero-based and the TableCell text index one-based, it is necessary to subtract one from the TableCell text index.

[C#]
int tableID = 10;
textControl1.Tables.Add(6, 3, tableID);
TXTextControl.Table table = textControl1.Tables.GetItem(tableID);
table.Cells.GetItem(1, 1).Text = "Date / Time";
table.Cells.GetItem(1, 2).Text = "Customer data";
table.Cells.GetItem(1, 3).Text = "Result";
textControl1.Selection.Start = table.Cells.GetItem(1, 1).Start - 1;
textControl1.Selection.Length = table.Cells.GetItem(1, 3).Start - 1
                               + table.Cells.GetItem(1, 3).Length;
textControl1.Selection.Bold = true;
textControl1.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center;
textControl1.Selection.Length = 0;
[Visual Basic]
Dim TableID As Integer = 10
TextControl1.Tables.Add(6, 3, tableID)
Dim Table As TXTextControl.Table = TextControl1.Tables.GetItem(TableID)
Table.Cells.GetItem(1, 1).Text = "Date / Time"
Table.Cells.GetItem(1, 2).Text = "Customer data"
Table.Cells.GetItem(1, 3).Text = "Result"
TextControl1.Selection.Start = Table.Cells.GetItem(1, 1).Start - 1
TextControl1.Selection.Length = Table.Cells.GetItem(1, 3).Start - 1 _
                               + Table.Cells.GetItem(1, 3).Length
TextControl1.Selection.Bold = True
TextControl1.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center
TextControl1.Selection.Length = 0

Next, the TableCellCollection is looped to insert variable data, like date, customer number and result. The customer number will be inserted in an ApplicationField text field.

[C#]
foreach (TXTextControl.TableCell cell in table.Cells)
{
  if (cell.Row == 1)
    continue;
  if (cell.Column == 1)
    cell.Text = DateTime.UtcNow.ToString();
  if (cell.Column == 2)
  {
    textControl1.Selection.Start = cell.Start - 1;
    TXTextControl.ApplicationField appField = new TXTextControl.ApplicationField(
                                             TXTextControl.ApplicationFieldFormat.MSWord,
                                             "MERGEFIELD",
                                             cell.Row.ToString(),
                                             new string[] { "FieldName" });
    appField.DoubledInputPosition = true;
    appField.ShowActivated = true;
    textControl1.ApplicationFields.Add(appField);
    textControl1.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center;
  }
  if (cell.Column == 3)
    cell.Text = Guid.NewGuid().ToString().Substring(1, 10);
}
[Visual Basic]
For Each cell As TXTextControl.TableCell In table.Cells
  If cell.Row = 1 Then
    Continue For
  End If
  If cell.Column = 1 Then
    cell.Text = DateTime.UtcNow.ToString()
  End If
  If cell.Column = 2 Then
    textControl1.Selection.Start = cell.Start - 1
    Dim appField As New TXTextControl.ApplicationField(
            TXTextControl.ApplicationFieldFormat.MSWord, _
            "MERGEFIELD", _
            cell.Row.ToString(), _
            New String() {"FieldName"})
    appField.DoubledInputPosition = True
    appField.ShowActivated = True
    textControl1.ApplicationFields.Add(appField)
    textControl1.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center
  End If
  If cell.Column = 3 Then
    cell.Text = Guid.NewGuid().ToString().Substring(1, 10)
  End If
Next

<< Back


Adding a Header and a Footer with Data to a Document

To insert and access headers and footers in a document, the SectionCollection.GetItem method must be used. The following code sample explains how to add a header and a footer to a document. After that, text and an image will be placed in the header and a page number will be added to the footer.

To begin with, it must be checked if there are already a header and footer in the current section. If not, add a header and footer and add content to both. Please note that a dialog will pop up to ask you for the image file. You can of course provide an Image object which will be inserted without any file dialog.

[C#]
// Get the current section to work with.
TXTextControl.Section currentSection = textControl1.Sections.GetItem();

// Get the current header.
TXTextControl.HeaderFooter currentHeader =
      currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header);

// Check if there is already a header present.
if (currentHeader == null)
{ // no header found in the current section, so we will add one.
  currentSection.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header);
  currentHeader = currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header);
}

// Add image to the header with alignment to the right page border.
currentHeader.Images.Add(new TXTextControl.Image(),
                TXTextControl.HorizontalAlignment.Right,
                0,
                TXTextControl.ImageInsertionMode.DisplaceText);

// Add some text to the header, left aligned.
currentHeader.Selection.Text = "This is a header with an image aligned to the right.";

TXTextControl.HeaderFooter currentFooter =
      currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Footer);
if (currentFooter == null)
{
  currentSection.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Footer);
  currentFooter = currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Footer);
}
currentFooter.Selection.Text = "Page ";

// Add PageNumberField text field to the footer to display the current page number.
currentFooter.PageNumberFields.Add(new TXTextControl.PageNumberField(1, TXTextControl.NumberFormat.ArabicNumbers));

// Add static page count to the footer.
// PLEASE NOTE: You will have to update this number programmatically if the page count changes!
// Best solution would be to do that in the Changed event.
currentFooter.Selection.Text = " of " + textControl1.Pages.ToString();

// Center the footer content.
currentFooter.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center;
[Visual Basic]
' Get the current section to work with.
Dim currentSection As TXTextControl.Section = TextControl1.Sections.GetItem()

' Get the current header.
Dim currentHeader As TXTextControl.HeaderFooter =
      currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header)

' Check if there is already a header present.
If currentHeader Is Nothing Then
' no header found in the current section, so we will add one.
  currentSection.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header)
  currentHeader = currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header)
End If

' Add image to the header with alignment to the right page border.
                currentHeader.Images.Add(New TXTextControl.Image(), _
                TXTextControl.HorizontalAlignment.Right, _
                0, _
                TXTextControl.ImageInsertionMode.DisplaceText)

' Add some text to the header, left aligned.
currentHeader.Selection.Text = "This is a header with an image aligned to the right."

Dim currentFooter As TXTextControl.HeaderFooter =
      currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Footer)
If currentFooter Is Nothing Then
  currentSection.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Footer)
  currentFooter = currentSection.HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Footer)
End If
currentFooter.Selection.Text = "Page "

' Add PageNumberField text field to the footer to display the current page number.
currentFooter.PageNumberFields.Add(New TXTextControl.PageNumberField(1, TXTextControl.NumberFormat.ArabicNumbers))

' Add static page count to the footer.
' PLEASE NOTE: You will have to update this number programmatically if the page count changes!
'Best solution would be to do that in the Changed event.
currentFooter.Selection.Text = " of " & TextControl1.Pages.ToString()

' Center the footer content.
currentFooter.Selection.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center

As noted in the source code, the total page number textControl1.Pages.ToString() must be updated each time the number of pages has changed.

<< Back


Replacing a Paragraph with a Line Break on Enter Key

For some applications, it is necessary to replace the default keys with another key or action. The following code intercepts the Enter key and inserts a line break instead of a paragraph.

[C#]
private void textControl1_KeyPress(object sender, KeyPressEventArgs e)
{
  if(e.KeyChar.Equals('\r'))
  {
    e.Handled = true;
    textControl1.Selection.Text = "\v";
  }
}
[Visual Basic]
Private Sub textControl1_KeyPress(sender As Object, e As KeyPressEventArgs)
  If e.KeyChar.Equals(ControlChars.Cr) Then
    e.Handled = True
    textControl1.Selection.Text = vbVerticalTab
  End If
End Sub


Scrolling programmatically to a Text Position

Scrolling in TX Text Control .NET is pretty easy when working with text fields. However, if you want to scroll to a certain text position, it is not that easy. The following method shows a way how to do that.

Please note: The textPosition value is zero-based (like the Selection.Start or the InputPosition.TextPosition property) and has to be increased by 1 to get the requested character of the TextCharCollection. If the increased value is greater than the number of TextChars of the TextCharCollection, the Y-coordinate of the last line in the TextControl will be used to set the TextControl.ScrollLocation.

[C#]
private void scrollToTextPosition(int textPosition)
{
  Point newScrollLocation = textControl1.ScrollLocation;
  if (textPosition & 1 <= textControl1.TextChars.Count)
  {
    newScrollLocation = new Point(0, textControl1.TextChars[textPosition + 1].Bounds.Y);
  }
  else
  {
    newScrollLocation = new Point(0, textControl1.Lines[textControl1.Lines.Count].TextBounds.Y);
  }
  textControl1.ScrollLocation = newScrollLocation;
}
[Visual Basic]
Private Sub scrollToTextPosition(ByVal textPosition As Integer)
  Dim newScrollLocation As Point = textControl1.ScrollLocation
  If textPosition + 1 <= textControl1.TextChars.Count Then
    newScrollLocation = New Point(0, textControl1.TextChars(textPosition + 1).Bounds.Y)
  Else
    newScrollLocation = New Point(0, textControl1.Lines(textControl1.Lines.Count).TextBounds.Y)
  End If
  textControl1.ScrollLocation = newScrollLocation
End Sub

<< Back


Printing without the Status Dialog

The default print controller of .NET displays a status dialog that shows the status of the printing process like this:

'Page 5 of document'

If you want to print without such a print status dialog, you will need to use the StandardPrintController instead of the default PrintControllerWithStatusDialog.

The StandardPrintController is part of the System.Drawing.Printing namespace. The following code prints the content of TX Text Control without such print status dialog:

[C#]
PrintDocument printDoc = new PrintDocument();
PrintController printCtl = new StandardPrintController();
printDoc.PrintController = printCtl;
textControl1.Print(printDoc);
[Visual Basic]
Dim PrintDoc As New PrintDocument()
Dim PrintCtl As PrintController = New StandardPrintController()
PrintDoc.PrintController = PrintCtl
TextControl1.Print(PrintDoc)

<< Back


TXTextControl.Selection and Undo

There are two ways to manipulate a range of text:

  • A text range is selected using TextControl.Select. This selection is changed using the TextControl.Selection property that manipulates the current selection.
  • A new Selection object is created and assigned to the TextControl.Selection property.

Most users are going with the first, more obvious approach. A range of text is selected and changed using a sequence of Selection properties:

[C#]
textControl1.Select(0, 5);
textControl1.Selection.Bold = true;
textControl1.Selection.Italic = true;
textControl1.Selection.Text = "New Text";

This works very reliably and can be used in most scenarios. But this approach has two drawbacks:

  • A selection is visible on the screen. The text is visually selected with the transparent blue background in order to be formatted.
  • Each change of the selection is counted as a single Undo history step.

In the above code, three undo steps are required to revert to the previous state.

So, what if we could modify the Selection virtually before applying to our TextControl instance? This is what the second approach below does.

A new virtual Selection object is created and manipulated using the same properties. After the object is finished, it will be assigned to the Selection property of our TextControl instance.

[C#]
TXTextControl.Selection sel = new TXTextControl.Selection();
sel.Text = "New Text";
sel.Bold = true;
sel.Italic = true;
textControl1.Selection = sel;
[Visual Basic]
Dim sel As New TXTextControl.Selection()
sel.Text = "New Text"
sel.Bold = True
sel.Italic = True
textControl1.Selection = sel

This is counted as a single Undo step and there is no visible selection background.

<< Back


Removing empty Pages

Cleaning up documents might be neccessary when building documents dynamically. Various document sections are added, forced page breaks are inserted at different positions and end-users can modify the resulting document. A typical task is to remove all empty pages from a document that consist only of a page break or section break character.

The following method uses the PageEnumerator to loop through all pages. If the Length of a page equals 1, the page is removed.

[C#]
private void RemoveEmptyPages()
{
  TXTextControl.PageCollection.PageEnumerator pageEnum =
                 textControl1.GetPages().GetEnumerator();
  pageEnum.MoveNext();
  int pageCounter = textControl1.GetPages().Count;
  for (int i = 0; i < pageCounter; i++)
  {
    TXTextControl.Page curPage = (TXTextControl.Page)pageEnum.Current;
    if (curPage.Length == 1)
    {
      textControl1.Select(curPage.Start - 1, 1);
      textControl1.Selection.Text = "";
    }
    else
      pageEnum.MoveNext();
  }
}
[Visual Basic]
Private Sub RemoveEmptyPages()
  Dim pageEnum As TXTextControl.PageCollection.PageEnumerator =
                 textControl1.GetPages().GetEnumerator()
  pageEnum.MoveNext()
  Dim pageCounter As Integer = textControl1.GetPages().Count
  For i As Integer = 0 To pageCounter - 1
    Dim curPage As TXTextControl.Page =
                 DirectCast(pageEnum.Current, TXTextControl.Page)
    If curPage.Length = 1 Then
      textControl1.[Select](curPage.Start - 1, 1)
      textControl1.Selection.Text = ""
    Else
      pageEnum.MoveNext()
    End If
  Next
End Sub

<< Back


Inserting Columns programmatically using TX Text Control .NET

Generally, inserting page columns is a very easy task. Using the SectionFormat.Columns property, you can define the number of columns. TX Text Control will then automatically adjust the width of the columns based on the page size and number of columns.

But if the columns should have a different size and should not be averaged and spread out on the page, we need to set the width of each column. This can be done in the SectionFormat constructor:

[C#]
public SectionFormat(int columns, int[] columnWidths, int[] columnDistances);
[Visual Basic]
Public Sub New(ByVal columns As Integer, columnWidths As Integer(), columnDistances As Integer())

The second column width is calculated based on the first width, the distance between the columns, the page size and margins. This formula shows the calculation:

SecondColumnWidth = PageSize - PageMargins - FirstColumnWidth - ColumnDistance

The following code shows how to insert a new section with two columns where you just need to pass the first column width:

[C#]
private void InsertColumns(int FirstColumnWidth, int ColumnDistance)
{
  textControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewLine);
  TXTextControl.SectionFormat currentFormat =
        textControl1.Sections.GetItem().Format;

  int iSecondColumnWidth = (int)(
        (currentFormat.PageSize.Width * 14.4) -
        (currentFormat.PageMargins.Left * 14.4) -
        (currentFormat.PageMargins.Right * 14.4) -
        FirstColumnWidth -
        ColumnDistance
        );

  TXTextControl.SectionFormat newSectionFormat =
        new TXTextControl.SectionFormat(
        2,
        new int[] { FirstColumnWidth, iSecondColumnWidth },
        new int[] { ColumnDistance });

  textControl1.Sections.GetItem().Format = newSectionFormat;
}
[Visual Basic]
Private Sub InsertColumns(FirstColumnWidth As Integer, ColumnDistance As Integer)
  textControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewLine)
  Dim currentFormat As TXTextControl.SectionFormat = textControl1.Sections.GetItem().Format
  Dim iSecondColumnWidth As Integer = CInt(Math.Truncate(
        (currentFormat.PageSize.Width * 14.4) -
        (currentFormat.PageMargins.Left * 14.4) -
        (currentFormat.PageMargins.Right * 14.4) -
        FirstColumnWidth -
        ColumnDistance))

        Dim newSectionFormat As New TXTextControl.SectionFormat(
        2,
        New Integer() {FirstColumnWidth, iSecondColumnWidth},
        New Integer() {ColumnDistance})

  textControl1.Sections.GetItem().Format = newSectionFormat
End Sub

<< Back


Getting the Page Number at the Current Scroll Location

When using TX Text Control in read-only mode, it might be required to display the page number of the currently visible page. In order to get the page number at the current input position, you just need to get the appropriate property from the InputPosition object.

But when scrolling through the pages, the actual input position is not changed, so that this property can't be used to get the page number.

But thanks to the flexible and powerful class library, it is very easy to retrieve the page number of the currently visible page.

In order to get the page number, we use the LineCollection to get the line in the middle of the visible TextControl. TX Text Control automatically factors the current scroll location into the calculation, so that we just need to pass the half of the control size to the GetItem method. It returns the Line object in the middle of the visible document part. And the Line object provides the according page number among other information.

[C#]
private int GetPageAtScrollPosition()
{
  return textControl1.Lines.GetItem(
      new Point(0, textControl1.Height / 2)).Page;
}
[Visual Basic]
Private Function GetPageAtScrollPosition() As Integer
  Return textControl1.Lines.GetItem(New Point(0, textControl1.Height / 2)).Page
End Function

We just need to update the information using the VScroll event:

[C#]
private void textControl1_VScroll(object sender, EventArgs e)
{
  int iPageNumber = GetPageAtScrollPosition();
      Console.WriteLine("Page " +
      iPageNumber.ToString() +
      " of " +
      textControl1.Pages.ToString());

  Console.WriteLine("Section " +
      textControl1.GetPages()[iPageNumber].Section +
      " of " +
      textControl1.Sections.Count.ToString());
}
[Visual Basic]
Private Sub textControl1_VScroll(sender As Object, e As EventArgs)
  Dim iPageNumber As Integer = GetPageAtScrollPosition()
  Console.WriteLine("Page " +
      iPageNumber.ToString() +
      " of " +
      textControl1.Pages.ToString())

  Console.WriteLine("Section " +
      textControl1.GetPages()(iPageNumber).Section +
      " of " +
      textControl1.Sections.Count.ToString())
End Sub

<< Back


Printing into a PrintDocument

TX Text Control .NET for Windows Forms's Print method introduces many advantages over the Print method of the ActiveX control. It enables you to print into a PrintDocument of the System.Drawing.Printing namespace.

TX Text Control .NET for Windows Forms's Print method uses the following settings of this object:

  • DocumentName
  • PrintController
  • PrinterSettings.FromPage
  • PrinterSettings.ToPage
  • PrinterSettings.Copies
  • PrinterSettings.Collate
  • PrinterSettings.PrinterName
  • PrinterSettings.PrintToFile
  • PrinterSettings.PrintRange
  • DefaultPageSettings.Color

If you would like to print one specific page of the document, not only FromPage and ToPage must be specified, but also the PrintRange property.

The following code sample prints page 2 of TX Text Control and sets the current page size.

[C#]
int m_curPage = 2;
PrintDocument myPrintDoc = new PrintDocument();
myPrintDoc.DefaultPageSettings.PaperSize = new PaperSize("default",
                                                         textControl1.PageSize.Width,
                                                         textControl1.PageSize.Height);
myPrintDoc.DefaultPageSettings.Margins = new Margins(textControl1.PageMargins.Left,
                                                     textControl1.PageMargins.Right,
                                                     textControl1.PageMargins.Top,
                                                     textControl1.PageMargins.Bottom);
myPrintDoc.PrinterSettings.PrintRange = PrintRange.SomePages;
myPrintDoc.PrinterSettings.FromPage = m_curPage;
myPrintDoc.PrinterSettings.ToPage = m_curPage;
textControl1.Print(myPrintDoc);
[Visual Basic]
Dim CurrentPage As Integer = 2
Dim MyPrintDoc As PrintDocument = New PrintDocument()
MyPrintDoc.DefaultPageSettings.PaperSize = New PaperSize("default",
                                                         TextControl1.PageSize.Width,
                                                         TextControl1.PageSize.Height)
MyPrintDoc.DefaultPageSettings.Margins = New Margins(TextControl1.PageMargins.Left,
                                                     TextControl1.PageMargins.Right,
                                                     TextControl1.PageMargins.Top,
                                                     TextControl1.PageMargins.Bottom)
MyPrintDoc.PrinterSettings.PrintRange = PrintRange.SomePages
MyPrintDoc.PrinterSettings.FromPage = CurrentPage
MyPrintDoc.PrinterSettings.ToPage = CurrentPage
TextControl1.Print(MyPrintDoc)

As you can see, the PrintPage property must be specified with SomePages which indicates that the FromPage and ToPage is considered.

<< Back


Class Library Overview

This part contains an overview of the TX Text Control Class Library sorted by programming categories. Graphical charts give an overview how the different classes work together. A porting reference helps to port an application using TX Text Control from the ActiveX to the .NET technology.

Graphical Overview

Class Hierarchy

Programming Categories

Porting ActiveX to .NET

Mouse and Keyboard Assignment


Graphical Overview

The following provides a complete graphical overview of TX Text Control's classes, properties, methods and events sorted by the categories listed below. Displayed are all of the properties, methods and events of the TextControl, WPF.TextControl and the ServerTextControl class and their connection to other classes.

Graphical Charts

Document Formatting

Graphic | Description
General Control Settings | General control settings include features like viewing modes, page and document settings, edit modes, foreground and background colors, zooming, printing and finding and replacing text.
Text Formatting | Shows all interface parts that have to do with character formats, paragraph formatting and list formatting. All features are both accessible from program code and through built-in dialog boxes.
Loading and Saving | Includes all that have to do with data input and output like loading and saving from and to files or blocks of memory, using the clipboard and using undo.
Style Formatting | Shows all interface parts that have to do with style formatting. All features are both accessible from program code and through built-in dialog boxes.
Sections and Pages | Shows how section attributes like page settings and headers and footers can be programmed.
Headers and Footers | Shows how headers and footers can be accessed and programmed.
Paragraphs | Shows how paragraph attributes can be programmed for a certain paragraph.

Programmable Objects

Graphic | Description
Tables | Shows all classes that enable a programmer to insert, handle and format tables.
Images | Images in different formats can be inserted via a dialog box. They can be positioned as characters within a line of text, or at a given position in a paragraph or on a page.
Drawings and Shapes | Drawings and preset shapes can be inserted representing a single shape or a canvas including a number of shapes. A drawing can be activated and changed by the built-in mouse interface.
Text Frames | Text frames are rectangles that can be filled with text through an end-user and that can be edited like the main text. Like images they can be positioned as characters within a line of text, or at a given position in a paragraph or on a page.
Barcodes | TX TextControl supports 10 different types of barcodes, which can be displayed with a TXTextControl.Barcode.TXBarcodeControl. Like images and text frames they can be positioned as characters within a line of text, or at a given position in a paragraph or on a page.
Charts | Charts can be inserted and designed in many different types. Like images and text frames they can be positioned as characters within a line of text, or at a given position in a paragraph or on a page. Charts can only be used with the Windows Forms TextControl.
Toolbars | Shows TX Text Control's toolbar classes.
Text Fields | Text fields are marked pieces of text that can have several properties, like a name, an identifier, text and several editing features. TX Text Control supports the formats of other applications through the ApplicationField class.
Hypertext Links | Special types of text fields act as sources and destinations of hypertext links.

Reporting

Graphic | Description
Data Source Manager | The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class.
Mail Merge | A MailMerge class can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET web applications, web services or Windows services.

Server Programming

Graphic | Description
Document Viewer | The DocumentViewer class is a .NET component that can be used to display documents in a web browser in ASP.NET projects.
Web Editor | The Web.TextControl (HTML5 Web Editor) is an ASP.NET server control that allows the integration of a fully-featured WYSIWYG word processor in ASP.NET Web applications. This control works together with the TX Text Control Web Server running as a Windows Service hosted on a Web server. The TX Text Control Web Server engine is used to synchronize the document with the server in order to provide consistent WYSIWYG text rendering. The technical concept is explained in HTML5 Web Editor - Technical Considerations. All programming elements belonging to the HTML5 Web Editor can be found in the TXTextControl.Web namespace.
Server Visualisation | The TextViewGenerator class is a special kind of ServerTextControl, which can be used to generate an image of the document contained in a ServerTextControl.

Additional Features

Graphic | Description
Windows Forms Ribbons | The TXTextControl class library offers classes to build Windows Forms applications with a ribbon instead of a menu and toolbars. All programming elements belonging to the Windows Forms Ribbons can be found in the TXTextControl.Windows.Forms.Ribbon namespace.
Spell Checking | Text Control offers spellchecking with the Proofing.TXSpellChecker component including a powerful spellchecking dialog box and automatic spellchecking during editing.
Programming Formatted Text | A TX Text Control document consists of the document's main text and additional pieces of text such as text frames and headers and footers. To provide easy access to all of these text parts TX Text Control offers the TextPartCollection class and the IFormattedText interface. Additional user-defined textparts can be added with the SubTextPartCollection class. The FrameCollection class provides access to all images, text frames, drawings, barcodes and charts of a document.
Lines and Characters | Text Control offers geometrical and other information of every single line and every single character.
XML Elements | The XML classes offer access and manipulation of the XML elements contained in an XML document.


Class Hierarchy

The following graphic shows the inheritance hierarchy of the TX Text Control .NET class library.


Programming Categories

The following provides a complete list of TX Text Control's classes, properties, methods and events sorted by category. All classes are listed and all properties, methods and events of the TextControl, WPF.TextControl and the ServerTextControl class.

Character Formatting

Paragraph Formatting

Stylesheet Formatting

Sections and Pages

Bullets and Numbered Lists

Integrated Dialog Boxes

Tool Bars

Loading, Saving and Database Support

Printing and Print Preview

Tables

Headers and Footers

Images

Text Frames

Charts

Barcodes

Drawings and Shapes

Hypertext Links

Text Selections and Character Input

Text Fields

Spell Checking

Clipboard Operations

Undo

Search and Replace

Zooming

Control Settings

Paragraph Programming

Line and Character Operations

Programming Formatted Textparts

Stylesheet Programming

Windows Forms Ribbons

Web Editor

Mail Merge

Document Viewer

Reporting

WPF Programming

XML Programming

Visualize the ServerTextControl

Exceptions


Character Formatting

Classes

Class | Description
TXTextControl.InputFormat | The InputFormat class represents all formatting attributes at the current text input position.

Properties

Property | Description
TXTextControl.ServerTextControl.Baseline | Gets or sets the baseline alignment, in twips, of the control.
TXTextControl.ServerTextControl.Font | Gets or sets the control's font.
TXTextControl.ServerTextControl.FontUnderlineStyle | Gets or sets underlining style for the text displayed by the control.
TXTextControl.ServerTextControl.ForeColor | Gets or sets the foreground color of the control.
TXTextControl.ServerTextControl.TextBackColor | Gets or sets the background color for the text.
TXTextControl.TextControl.Baseline | Gets or sets the baseline alignment, in twips, of the Text Control.
TXTextControl.TextControl.FontUnderlineStyle | Gets or sets underlining style for the text displayed by the control.
TXTextControl.TextControl.ForeColor | Overridden. Gets or sets the foreground color of the control which is the color of the document's text.
TXTextControl.TextControl.InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
TXTextControl.TextControl.TextBackColor | Gets or sets the background color for the text.
TXTextControl.WPF.TextControl.Baseline | Gets or sets the baseline alignment, in twips, of the Text Control.
TXTextControl.WPF.TextControl.FontFamily | Gets or sets the font family of the text control.
TXTextControl.WPF.TextControl.FontSize | Gets or sets the font size of the text control in device-independent units (1/96th inch).
TXTextControl.WPF.TextControl.FontStyle | Gets or sets the font style of the text control.
TXTextControl.WPF.TextControl.FontUnderlineStyle | Gets or sets the underlining style for the text displayed by the control.
TXTextControl.WPF.TextControl.FontWeight | Gets or sets the weight or thickness of the text control's font.
TXTextControl.WPF.TextControl.InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.

Methods

Method | Description
TXTextControl.ServerTextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.ServerTextControl.ResetFont | Resets the Font property to its default value.
TXTextControl.ServerTextControl.ResetForeColor | Resets the ForeColor property to its default value.
TXTextControl.ServerTextControl.ResetTextBackColor | Resets the TextBackColor property to its default value.
TXTextControl.TextControl.FontDialog | Invokes the built-in font dialog box.
TXTextControl.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.TextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.TextControl.OnCharFormatChanged | Raises the CharFormatChanged event.
TXTextControl.TextControl.OnFontChanged | Overridden. See Control.OnFontChanged.
TXTextControl.TextControl.ResetForeColor | Overridden. Resets the ForeColor property to its default value.
TXTextControl.TextControl.ResetTextBackColor | Resets the TextBackColor property to its default value.
TXTextControl.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TXTextControl.WPF.TextControl.FontDialog | Invokes the built-in font dialog box.
TXTextControl.WPF.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.WPF.TextControl.GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
TXTextControl.WPF.TextControl.OnCharFormatChanged | Raises the CharFormatChanged event.
TXTextControl.WPF.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.

Events

Event | Description
TXTextControl.TextControl.CharFormatChanged | Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed.
TXTextControl.WPF.TextControl.CharFormatChanged | Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed.


Paragraph Formatting

Classes

Class | Description
TXTextControl.InputFormat | The InputFormat class represents all formatting attributes at the current text input position.
TXTextControl.ParagraphFormat | An instance of the ParagraphFormat class represents the formatting attributes of a paragraph.

Properties

Property | Description
TXTextControl.ServerTextControl.ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.
TXTextControl.TextControl.InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
TXTextControl.TextControl.ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.
TXTextControl.WPF.TextControl.InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
TXTextControl.WPF.TextControl.ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.

Methods

Method | Description
TXTextControl.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.TextControl.OnInputParagraphChanged | Raises the InputParagraphChanged event.
TXTextControl.TextControl.OnParagraphFormatChanged | Raises the ParagraphFormatChanged event.
TXTextControl.TextControl.ParagraphFormatDialog | Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
TXTextControl.TextControl.TabDialog | Invokes the built-in dialog box for setting tabs.
TXTextControl.WPF.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.WPF.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.WPF.TextControl.OnInputParagraphChanged | Raises the InputParagraphChanged event.
TXTextControl.WPF.TextControl.OnParagraphFormatChanged | Raises the ParagraphFormatChanged event.
TXTextControl.WPF.TextControl.ParagraphFormatDialog | Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
TXTextControl.WPF.TextControl.TabDialog | Invokes the built-in dialog box for setting tabs.

Events

Event | Description
TXTextControl.TextControl.InputParagraphChanged | Occurs when the text input position has been moved to another paragraph.
TXTextControl.TextControl.ParagraphFormatChanged | Occurs when the formatting attributes of the selected paragraphs have been changed.
TXTextControl.WPF.TextControl.InputParagraphChanged | Occurs when the text input position has been moved to another paragraph.
TXTextControl.WPF.TextControl.ParagraphFormatChanged | Occurs when the formatting attributes of the selected paragraphs have been changed.


Stylesheet Formatting

Methods

Method | Description
TXTextControl.TextControl.FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
TXTextControl.TextControl.OnFormattingStyleListChanged | Raises the FormattingStyleListChanged event.
TXTextControl.TextControl.OnInputFormattingStyleChanged | Raises the InputFormattingStyleChanged event.
TXTextControl.WPF.TextControl.FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
TXTextControl.WPF.TextControl.OnFormattingStyleListChanged | Raises the FormattingStyleListChanged event.
TXTextControl.WPF.TextControl.OnInputFormattingStyleChanged | Raises the InputFormattingStyleChanged event.

Events

Event | Description
TXTextControl.TextControl.FormattingStyleListChanged | Occurs after one or more formatting styles have been added or removed.
TXTextControl.TextControl.InputFormattingStyleChanged | Occurs after the text input position has been moved to a text part formatted with another style.
TXTextControl.WPF.TextControl.FormattingStyleListChanged | Occurs after one or more formatting styles have been added or removed.
TXTextControl.WPF.TextControl.InputFormattingStyleChanged | Occurs after the text input position has been moved to a text part formatted with another style.


Sections and Pages

A document can be split into several sections to enable different page sizes and margins and different headers and footers in the same document. An end-user can use the Page Setup dialog box available through the TextControl.SectionFormatDialog method. All section attributes and headers and footers can be set either for a single section or for the complete document. A SectionCollection available through the TextControl.Sections property enables a programmer to alter the formatting attributes of a section from programming code. The sections of a document are numbered beginning with 1. The StatusBar shows the section number at the text input position. Additionally, it shows the number of pages and the number of sections contained in the document. Because a document can have pages with different sizes a PageCollection informs about the alignment of the page and the page's text contents. Furthermore, a Page object has properties to inform about its character index, number of characters, section number and the number of the page in the section. The PageCollection is available through the TextControl.GetPages method.

Classes

Class | Description
TXTextControl.Page | An object of the Page class represents a formatted page of a document.
TXTextControl.PageBorder | An instance of the PageBorder class represents the attributes of a border, which is drawn in the margin area of a page.
TXTextControl.PageCollection | An instance of the PageCollection class contains all pages of a document.
TXTextControl.PageMargins | An instance of the PageMargins class represents the page margins of a TX Text Control document or document section.
TXTextControl.PageSize | An instance of the PageSize class represents the page size of a TX Text Control document or document section.
TXTextControl.PaperSize | The PaperSize class is used with the TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods, which return the names and the sizes of all currently supported paper sizes.
TXTextControl.Section | An object of the Section class represents a section of a document.
TXTextControl.SectionCollection | An instance of the SectionCollection class contains all sections of a document.
TXTextControl.SectionFormat | An instance of the SectionFormat class represents the formatting attributes of a section.

Properties

Property | Description
TXTextControl.ServerTextControl.GetPages | Gets a collection of all pages in the document.
TXTextControl.ServerTextControl.Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
TXTextControl.ServerTextControl.PageMargins | Gets or sets the margins for the pages of the current document.
TXTextControl.ServerTextControl.Pages | Gets the number of pages contained in the current document.
TXTextControl.ServerTextControl.PageSize | Specifies the width and height of the pages for the current document.
TXTextControl.ServerTextControl.PageUnit | Gets or sets the measure used for page sizes and page margins.
TXTextControl.ServerTextControl.Sections | Gets a collection of all sections in the document.
TXTextControl.TextControl.GetPages | Gets a collection of all pages in the document.
TXTextControl.TextControl.Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
TXTextControl.TextControl.PageMargins | Gets or sets the margins for the pages of the current document.
TXTextControl.TextControl.Pages | Gets the number of pages contained in the current document.
TXTextControl.TextControl.PageSize | Specifies the width and height of the pages for the current document.
TXTextControl.TextControl.PageUnit | Gets or sets the measure used for page sizes and page margins.
TXTextControl.TextControl.Sections | Gets a collection of all sections in the document.
TXTextControl.WPF.TextControl.GetPages | Gets a collection of all pages in the document.
TXTextControl.WPF.TextControl.Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
TXTextControl.WPF.TextControl.PageMargins | Gets or sets the margins for the pages of the current document.
TXTextControl.WPF.TextControl.Pages | Gets the number of pages contained in the current document.
TXTextControl.WPF.TextControl.PageSize | Specifies the width and height of the pages for the current document.
TXTextControl.WPF.TextControl.PageUnit | Gets or sets the measure used for page sizes and page margins.
TXTextControl.WPF.TextControl.Sections | Gets a collection of all sections in the document.

Methods

Method | Description
TXTextControl.ServerTextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.ServerTextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.ServerTextControl.ResetPageMargins | Resets the PageMargins property to its default value.
TXTextControl.ServerTextControl.ResetPageSize | Resets the PageSize property to its default value.
TXTextControl.TextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.TextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.TextControl.OnPageChanged | Raises the PageChanged event.
TXTextControl.TextControl.OnPageFormatChanged | Raises the PageFormatChanged event.
TXTextControl.TextControl.OnSectionChanged | Raises the SectionChanged event.
TXTextControl.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.TextControl.ResetPageMargins | Resets the PageMargins property to its default value.
TXTextControl.TextControl.ResetPageSize | Resets the PageSize property to its default value.
TXTextControl.TextControl.SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.
TXTextControl.WPF.TextControl.GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
TXTextControl.WPF.TextControl.OnDocumentLoaded | Raises the DocumentLoaded event.
TXTextControl.WPF.TextControl.OnPageChanged | Raises the PageChanged event.
TXTextControl.WPF.TextControl.OnPageFormatChanged | Raises the PageFormatChanged event.
TXTextControl.WPF.TextControl.OnSectionChanged | Raises the SectionChanged event.
TXTextControl.WPF.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.WPF.TextControl.SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.

Events

Event | Description
TXTextControl.ServerTextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.TextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.TextControl.PageChanged | Occurs when the text input position has been moved to another page.
TXTextControl.TextControl.PageFormatChanged | Occurs when the page format settings have been changed.
TXTextControl.TextControl.SectionChanged | Occurs when the text input position has been moved to another section.
TXTextControl.WPF.TextControl.DocumentLoaded | Occurs when a new document has been loaded.
TXTextControl.WPF.TextControl.PageChanged | Occurs when the text input position has been moved to another page.
TXTextControl.WPF.TextControl.PageFormatChanged | Occurs when the page format settings have been changed.
TXTextControl.WPF.TextControl.SectionChanged | Occurs when the text input position has been moved to another section.


Bullets and Numbered Lists

Classes

Class | Description
TXTextControl.ListFormat | An instance of the ListFormat class represents the formatting attributes of a bulleted or numbered list.

Properties

Property | Description
TXTextControl.ServerTextControl.ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.
TXTextControl.TextControl.ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.
TXTextControl.WPF.TextControl.ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.

Methods

Method | Description
TXTextControl.TextControl.ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.
TXTextControl.WPF.TextControl.ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.


Integrated Dialog Boxes

Classes

Class | Description
TXTextControl.BookmarkDialog | The BookmarkDialog class implements a Windows Forms dialog box to insert a DocumentTarget at the current input position.
TXTextControl.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a Windows Forms dialog box which shows all targets in the current document.
TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog | The DatabaseConnectionDialog class allows the user to build connection strings and to connect to specific data sources.
TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog | The DataSourceExtractionDialog class allows the user to save an excerpt from the currently loaded data source.
TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.
TXTextControl.DocumentServer.WPF.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.
TXTextControl.GotoDialog | The GotoDialog class implements a Windows Forms dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.
TXTextControl.HyperlinkDialog | The HyperlinkDialog class implements a Windows Forms dialog box for inserting and editing a hyperlink at the current text input position.
TXTextControl.WPF.BookmarkDialog | The WPF.BookmarkDialog class implements a dialog box to insert a DocumentTarget at the current input position.
TXTextControl.WPF.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a dialog box which shows all targets in the current document.
TXTextControl.WPF.GotoDialog | The GotoDialog class implements a dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.
TXTextControl.WPF.HyperlinkDialog | The WPF.HyperlinkDialog class implements a built-in dialog box for inserting and editing a hyperlink at the current text input position.

Properties

Property | Description
TXTextControl.TextControl.SpellCheckContextMenuStrip | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
TXTextControl.WPF.TextControl.SpellCheckContextMenu | Specifies the context menu which is used when the end-user right-clicks a misspelled word.

Methods

Method | Description
TXTextControl.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
TXTextControl.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.TextControl.ChartLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a chart.
TXTextControl.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.TextControl.Find | Finds a text string in the text part with the input focus.
TXTextControl.TextControl.FontDialog | Invokes the built-in font dialog box.
TXTextControl.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.TextControl.FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
TXTextControl.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.TextControl.ImageAttributesDialog | Invokes the built-in dialog box for setting attributes of images.
TXTextControl.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.TextControl.ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.
TXTextControl.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.TextControl.ParagraphFormatDialog | Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
TXTextControl.TextControl.Replace | Opens the built-in Replace dialog box.
TXTextControl.TextControl.SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.
TXTextControl.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.
TXTextControl.TextControl.TabDialog | Invokes the built-in dialog box for setting tabs.
TXTextControl.TextControl.TableFormatDialog | Invokes the built-in dialog box for setting formatting attributes of tables.
TXTextControl.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TXTextControl.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.
TXTextControl.WPF.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
TXTextControl.WPF.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.WPF.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.WPF.TextControl.Find | Finds a text string in the text part with the input focus.
TXTextControl.WPF.TextControl.FontDialog | Invokes the built-in font dialog box.
TXTextControl.WPF.TextControl.ForeColorDialog | Invokes the built-in dialog box for setting the text color.
TXTextControl.WPF.TextControl.FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
TXTextControl.WPF.TextControl.FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
TXTextControl.WPF.TextControl.FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
TXTextControl.WPF.TextControl.ImageAttributesDialog | Invokes the built-in dialog box for setting attributes of images.
TXTextControl.WPF.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.WPF.TextControl.ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.
TXTextControl.WPF.TextControl.PageColorDialog | Invokes the built-in dialog box for setting the page color.
TXTextControl.WPF.TextControl.ParagraphFormatDialog | Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
TXTextControl.WPF.TextControl.Replace | Opens the built-in Replace dialog box.
TXTextControl.WPF.TextControl.SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.
TXTextControl.WPF.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.
TXTextControl.WPF.TextControl.TabDialog | Invokes the built-in dialog box for setting tabs.
TXTextControl.WPF.TextControl.TableFormatDialog | Invokes the built-in dialog box for setting formatting attributes of tables.
TXTextControl.WPF.TextControl.TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TXTextControl.WPF.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.


Tool Bars

Classes

Class | Description
TXTextControl.ButtonBar | The ButtonBar class represents a Windows Forms tool bar which can be used to show or to set font and paragraph attributes of a Windows Forms TextControl.
TXTextControl.ButtonBar.Colors | The ButtonBar.Colors class gets, sets or resets the display colors of a Windows Forms ButtonBar control.
TXTextControl.RulerBar | The RulerBar class represents a Windows Forms tool bar which can be used to show or to set indents, margins and tabs of a Windows Forms TextControl.
TXTextControl.RulerBar.Colors | The RulerBar.Colors class gets, sets or resets the display colors of a Windows Forms RulerBar control.
TXTextControl.StatusBar | The StatusBar class represents a Windows Forms tool bar which can be used to show the position of the curent text input position and other status information of a Windows Forms TextControl.
TXTextControl.StatusBar.Colors | The StatusBar.Colors class gets, sets or resets the display colors of a Windows Forms StatusBar control.
TXTextControl.WPF.ButtonBar | The WPF.ButtonBar class represents a tool bar which can be used to show or to set font and paragraph attributes of a WPF.TextControl.
TXTextControl.WPF.RibbonFormattingTab | The WPF.RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard.
TXTextControl.WPF.RibbonFrameLayoutTab | The RibbonFrameLayoutTab class represents a ribbon tab for editing objects of type Image, TextFrame, DrawingFrame and BarcodeFrame.
TXTextControl.WPF.RibbonInsertTab | The WPF.RibbonInsertTab class represents a ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols.
TXTextControl.WPF.RibbonPageLayoutTab | The RibbonPageLayoutTab class represents a tab for editing the page setup and layout.
TXTextControl.WPF.RibbonProofingTab | The RibbonProofingTab class represents a tab for setting proofing options such as spelling, hypheantion or language detection.
TXTextControl.WPF.RibbonReportingTab | The RibbonReportingTab class represents a WPF ribbon tab to integrate mail merge and reporting functionality.
TXTextControl.WPF.RibbonTableLayoutTab | The RibbonTableLayoutTab class represents a ribbon tab for editing tables.
TXTextControl.WPF.RibbonViewTab | The RibbonViewTab class represents a tab for customizing the view settings.
TXTextControl.WPF.RulerBar | The WPF.RulerBar class represents a tool bar which can be used to show or to set indents, margins and tabs of a WPF.TextControl.
TXTextControl.WPF.RulerBar.Colors | The WPF.RulerBarColors class gets, sets or resets the display colors of a WPF.RulerBar control.
TXTextControl.WPF.StatusBar | The WPF.StatusBar class represents a tool bar which can be used to show the position of the curent text input position and other status information of a WPF.TextControl.
TXTextControl.WPF.StatusBarColors | The WPF.StatusBarColors class gets, sets or resets the display colors of a WPF.StatusBar control.
TXTextControl.WPF.TextControlToolBar | The WPF.TextControlToolBar class is the base class of the WPF.RulerBar and the WPF.StatusBar classes.
TXTextControl.WPF.TextControlToolBarPresenter | A WPF.TextControlToolBarPresenter object is part of the template of a WPF.TextControlToolBar.

Properties

Property | Description
TXTextControl.TextControl.ButtonBar | Specifies the button bar control to be used with a TextControl.
TXTextControl.TextControl.RulerBar | Specifies the horizontal ruler bar control to be used with a TextControl.
TXTextControl.TextControl.StatusBar | Specifies the status bar control to be used with a TextControl.
TXTextControl.TextControl.VerticalRulerBar | Specifies the vertical ruler bar control to be used with a TextControl.
TXTextControl.WPF.TextControl.ButtonBar | Specifies the button bar control to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonFormattingTab | Specifies the name of the WPF.RibbonFormattingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonFrameLayoutTab | Specifies the name of the WPF.RibbonFrameLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonInsertTab | Specifies the name of the WPF.RibbonInsertTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonPageLayoutTab | Specifies the name of the WPF.RibbonPageLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonProofingTab | Specifies the name of the WPF.RibbonProofingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonReportingTab | Specifies the name of the WPF.RibbonReportingTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonTableLayoutTab | Specifies the name of the WPF.RibbonTableLayoutTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RibbonViewTab | Specifies the name of the WPF.RibbonViewTab object to be used with a TextControl.
TXTextControl.WPF.TextControl.RulerBar | Specifies the horizontal ruler bar control to be used with a TextControl.
TXTextControl.WPF.TextControl.StatusBar | Specifies the status bar control to be used with a TextControl.
TXTextControl.WPF.TextControl.VerticalRulerBar | Specifies the vertical ruler bar control to be used with a TextControl.


Loading, Saving and Database Support

Classes

Class | Description
TXTextControl.DigitalSignature | An instance of the DigitalSignature class represents an X.509 certificate which can be used to digitally sign a PDF or PDF/A document.
TXTextControl.LoadSettings | The LoadSettings class provides properties for advanced settings and information during load operations.
TXTextControl.SaveSettings | The SaveSettings class provides properties for advanced settings and information during save operations.
TXTextControl.UserDefinedPropertyDictionary | An instance of the UserDefinedPropertyDictionary class contains all user-defined document properties contained in a loaded document or which will be saved in a document.

Properties

Property | Description
TXTextControl.ServerTextControl.Text | Gets or sets the control's text.
TXTextControl.WPF.TextControl.Text | Gets or sets the text contents of the text control.

Methods

Method | Description
TXTextControl.ServerTextControl.Append | Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
TXTextControl.ServerTextControl.Clear | Clears the selected text or the character right from the current input position.
TXTextControl.ServerTextControl.Load | Loads text in a certain format.
TXTextControl.ServerTextControl.ResetContents | Deletes the entire contents of the control.
TXTextControl.ServerTextControl.Save | Saves the complete contents of a document with the specified format.
TXTextControl.TextControl.Append | Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
TXTextControl.TextControl.Clear | Clears the selected text or the character right from the current input position from the Text Control.
TXTextControl.TextControl.Load | Loads text in a certain format.
TXTextControl.TextControl.OnChanged | Raises the Changed event.
TXTextControl.TextControl.ResetContents | Deletes the entire contents of a Text Control.
TXTextControl.TextControl.Save | Saves the complete contents of a document with the specified format.
TXTextControl.WPF.TextControl.Append | Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
TXTextControl.WPF.TextControl.Clear | Clears the selected text or the character right from the current input position from the Text Control.
TXTextControl.WPF.TextControl.Load | Loads text in a certain format.
TXTextControl.WPF.TextControl.OnChanged | Raises the Changed event.
TXTextControl.WPF.TextControl.ResetContents | Deletes the entire contents of a Text Control.
TXTextControl.WPF.TextControl.Save | Saves the complete contents of a document with the specified format.

Events

Event | Description
TXTextControl.TextControl.Changed | Indicates that the contents of a document have been changed.
TXTextControl.WPF.TextControl.Changed | Indicates that the contents of a document have been changed.


Printing and Print Preview

Methods

Method | Description
TXTextControl.ServerTextControl.Print | Prints a Text Control document or a part of a document.
TXTextControl.TextControl.Print | Prints a Text Control document or a part of a document.
TXTextControl.TextControl.PrintPreview | Shows a print preview of the current document.
TXTextControl.WPF.TextControl.Print | Prints a Text Control document or a part of a document.


Tables

Classes

Class | Description
TXTextControl.Table | An instance of the Table class represents a table in a Text Control document.
TXTextControl.TableBaseCollection | The TableBaseCollection class is the base class for the table collection classes.
TXTextControl.TableCell | An instance of the TableCell class represents a single cell of a table in a Text Control document.
TXTextControl.TableCellCollection | An instance of the TableCellCollection class contains all cells of a table in a Text Control document represented through TableCell objects.
TXTextControl.TableCellFormat | An instance of the TableCellFormat class represents the formatting attributes of a table cell.
TXTextControl.TableCollection | An instance of the TableCollection class contains all tables of a Text Control document or part of the document represented through objects of the type Table.
TXTextControl.TableColumn | An instance of the TableColumn class represents a single column of a table in a Text Control document.
TXTextControl.TableColumnCollection | An instance of the TableColumnCollection class contains all columns of a table in a Text Control document represented through objects of the type TableColumn.
TXTextControl.TableEventArgs | The TableEventArgs class provides data for the TextControl.TableCreated, TextControl.TableDeleted and TextControl.TableFormatChanged events.
TXTextControl.TablePartCollection | The TablePartCollection class is the base class of the TableRowCollection, TableColumnCollection and TableCellCollection classes.
TXTextControl.TableRow | An instance of the TableRow class represents a single row of a table in a Text Control document.
TXTextControl.TableRowCollection | An instance of the TableRowCollection class contains all rows of a table in a Text Control document represented through objects of the type TableRow.

Properties

Property | Description
TXTextControl.ServerTextControl.Tables | Gets a collection of all tables contained in the document.
TXTextControl.TextControl.Tables | Gets a collection of all tables contained in the text part with the input focus.
TXTextControl.WPF.TextControl.Tables | Gets a collection of all tables contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.OnTableCreated | Raises the TableCreated event.
TXTextControl.ServerTextControl.OnTableDeleted | Raises the TableDeleted event.
TXTextControl.TextControl.OnTableCreated | Raises the TableCreated event.
TXTextControl.TextControl.OnTableDeleted | Raises the TableDeleted event.
TXTextControl.TextControl.OnTableFormatChanged | Raises the TableFormatChanged event.
TXTextControl.TextControl.TableFormatDialog | Invokes the built-in dialog box for setting formatting attributes of tables.
TXTextControl.WPF.TextControl.OnTableCreated | Raises the TableCreated event.
TXTextControl.WPF.TextControl.OnTableDeleted | Raises the TableDeleted event.
TXTextControl.WPF.TextControl.OnTableFormatChanged | Raises the TableFormatChanged event.
TXTextControl.WPF.TextControl.TableFormatDialog | Invokes the built-in dialog box for setting formatting attributes of tables.

Events

Event | Description
TXTextControl.ServerTextControl.TableCreated | Occurs after a new table has been created when loading a document which contains a table without an identifier.
TXTextControl.ServerTextControl.TableDeleted | Occurs after a table has been deleted.
TXTextControl.TextControl.TableCreated | Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier.
TXTextControl.TextControl.TableDeleted | Occurs after a table has been deleted.
TXTextControl.TextControl.TableFormatChanged | Occurs when the design attributes of a selected table have been changed.
TXTextControl.WPF.TextControl.TableCreated | Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier.
TXTextControl.WPF.TextControl.TableDeleted | Occurs after a table has been deleted.
TXTextControl.WPF.TextControl.TableFormatChanged | Occurs when the design attributes of a selected table have been changed.


Headers and Footers

Classes

Class | Description
TXTextControl.HeaderFooter | An instance of the HeaderFooter class represents a header or footer in a Text Control document.
TXTextControl.HeaderFooterCollection | An instance of the HeaderFooterCollection class contains the headers and footers in a Text Control document represented through objects of the type HeaderFooter.
TXTextControl.HeaderFooterEventArgs | The HeaderFooterEventArgs class provides data for the TextControl.HeaderFooterActivated and TextControl.HeaderFooterDeactivated events.
TXTextControl.PageNumberField | The PageNumberField class represents a field in a header or footer of a Text Control document that automatically displays the current page number.
TXTextControl.PageNumberFieldCollection | An instance of the PageNumberFieldCollection class contains the page number fields in a header or footer of a Text Control document.

Properties

Property | Description
TXTextControl.ServerTextControl.HeadersAndFooters | Gets a collection of all headers and footers the current document contains.
TXTextControl.TextControl.HeaderFooterActivationStyle | Gets or sets a value specifying the activation style for headers and footers.
TXTextControl.TextControl.HeaderFooterFrameStyle | Gets or sets a value specifying the frame for activated headers and footers.
TXTextControl.TextControl.HeadersAndFooters | Gets a collection of all headers and footers the current document contains.
TXTextControl.WPF.TextControl.HeaderFooterActivationStyle | Gets or sets a value specifying the activation style for headers and footers.
TXTextControl.WPF.TextControl.HeaderFooterFrameStyle | Gets or sets a value specifying the frame for activated headers and footers.
TXTextControl.WPF.TextControl.HeadersAndFooters | Gets a collection of all headers and footers the current document contains.

Methods

Method | Description
TXTextControl.TextControl.OnHeaderFooterActivated | Raises the HeaderFooterActivated event.
TXTextControl.TextControl.OnHeaderFooterDeactivated | Raises the HeaderFooterDeactivated event.
TXTextControl.WPF.TextControl.OnHeaderFooterActivated | Raises the HeaderFooterActivated event.
TXTextControl.WPF.TextControl.OnHeaderFooterDeactivated | Raises the HeaderFooterDeactivated event.

Events

Event | Description
TXTextControl.TextControl.HeaderFooterActivated | Occurs when a header or footer has been activated.
TXTextControl.TextControl.HeaderFooterDeactivated | Occurs when a header or footer has been deactivated.
TXTextControl.WPF.TextControl.HeaderFooterActivated | Occurs when a header or footer has been activated.
TXTextControl.WPF.TextControl.HeaderFooterDeactivated | Occurs when a header or footer has been deactivated.


Images

Classes

Class | Description
TXTextControl.FrameBase | The FrameBase class is the base class of the Image, TextFrame, ChartFrame, BarcodeFrame and DrawingFrame classes.
TXTextControl.FrameBaseCollection | The FrameBaseCollection class is the base class of the ImageCollection and TextFrameCollection classes.
TXTextControl.Image | An instance of the Image class represents an image in a Text Control document.
TXTextControl.ImageCollection | An instance of the ImageCollection class contains all images in a Text Control document or part of the document represented through objects of the type Image.
TXTextControl.ImageEventArgs | The ImageEventArgs class provides data for all events that occur with images.

Properties

Property | Description
TXTextControl.ServerTextControl.Images | Gets a collection of all images contained in the main text of the document.
TXTextControl.TextControl.Images | Gets a collection of all images contained in the text part with the input focus.
TXTextControl.WPF.TextControl.Images | Gets a collection of all images contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.OnImageCreated | Raises the ImageCreated event.
TXTextControl.ServerTextControl.OnImageDeleted | Raises the ImageDeleted event.
TXTextControl.TextControl.ImageAttributesDialog | Invokes the built-in dialog box for setting attributes of images.
TXTextControl.TextControl.OnImageClicked | Raises the ImageClicked event.
TXTextControl.TextControl.OnImageCreated | Raises the ImageCreated event.
TXTextControl.TextControl.OnImageDeleted | Raises the ImageDeleted event.
TXTextControl.TextControl.OnImageDeselected | Raises the ImageDeselected event.
TXTextControl.TextControl.OnImageDoubleClicked | Raises the ImageDoubleClicked event.
TXTextControl.TextControl.OnImageMoved | Raises the ImageMoved event.
TXTextControl.TextControl.OnImageRightClicked | Raises the ImageRightClicked event.
TXTextControl.TextControl.OnImageSelected | Raises the ImageSelected event.
TXTextControl.TextControl.OnImageSized | Raises the ImageSized event.
TXTextControl.WPF.TextControl.ImageAttributesDialog | Invokes the built-in dialog box for setting attributes of images.
TXTextControl.WPF.TextControl.OnImageClicked | Raises the ImageClicked event.
TXTextControl.WPF.TextControl.OnImageCreated | Raises the ImageCreated event.
TXTextControl.WPF.TextControl.OnImageDeleted | Raises the ImageDeleted event.
TXTextControl.WPF.TextControl.OnImageDeselected | Raises the ImageDeselected event.
TXTextControl.WPF.TextControl.OnImageDoubleClicked | Raises the ImageDoubleClicked event.
TXTextControl.WPF.TextControl.OnImageMoved | Raises the ImageMoved event.
TXTextControl.WPF.TextControl.OnImageRightClicked | Raises the ImageRightClicked event.
TXTextControl.WPF.TextControl.OnImageSelected | Raises the ImageSelected event.
TXTextControl.WPF.TextControl.OnImageSized | Raises the ImageSized event.

Events

Event | Description
TXTextControl.ServerTextControl.ImageCreated | Occurs when a new image has been created.
TXTextControl.ServerTextControl.ImageDeleted | Occurs when an image has been deleted.
TXTextControl.TextControl.ImageClicked | Occurs when an image has been clicked on.
TXTextControl.TextControl.ImageCreated | Occurs when a new image has been created.
TXTextControl.TextControl.ImageDeleted | Occurs when an image has been deleted.
TXTextControl.TextControl.ImageDeselected | Occurs when an image has been deselected.
TXTextControl.TextControl.ImageDoubleClicked | Occurs when an image has been doubleclicked on.
TXTextControl.TextControl.ImageMoved | Occurs when an inserted image has been moved.
TXTextControl.TextControl.ImageRightClicked | Occurs when an image has been clicked on with the right mouse button.
TXTextControl.TextControl.ImageSelected | Occurs when an image has been selected.
TXTextControl.TextControl.ImageSized | Occurs when an inserted image has been sized.
TXTextControl.WPF.TextControl.ImageClicked | Occurs when an image has been clicked on.
TXTextControl.WPF.TextControl.ImageCreated | Occurs when a new image has been created.
TXTextControl.WPF.TextControl.ImageDeleted | Occurs when an image has been deleted.
TXTextControl.WPF.TextControl.ImageDeselected | Occurs when an image has been deselected.
TXTextControl.WPF.TextControl.ImageDoubleClicked | Occurs when an image has been doubleclicked on.
TXTextControl.WPF.TextControl.ImageMoved | Occurs when an inserted image has been moved.
TXTextControl.WPF.TextControl.ImageRightClicked | Occurs when an image has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.ImageSelected | Occurs when an image has been selected.
TXTextControl.WPF.TextControl.ImageSized | Occurs when an inserted image has been sized.


Text Frames

A text frame is a rectangle that can be filled with text by an end-user and that can be edited like the main text. A text frame can be positioned like an image, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to a document's page. Text frames can be inserted, deleted and manipulated through the TextFrameCollection class that can be obtained through the TextControl.TextFrames Property. A text frame is fully programable from program code. The TextFrame class provides properties and methods that enable a programmer to manipulate a text frame's text in the same way as the document's main text. Further properties set text frame attributes, such as the width of the border line, internal margins and the background color.

Classes

Class | Description
TXTextControl.FrameBase | The FrameBase class is the base class of the Image, TextFrame, ChartFrame, BarcodeFrame and DrawingFrame classes.
TXTextControl.FrameBaseCollection | The FrameBaseCollection class is the base class of the ImageCollection and TextFrameCollection classes.
TXTextControl.TextFrame | An instance of the TextFrame class represents a text frame in a Text Control document.
TXTextControl.TextFrameCollection | An instance of the TextFrameCollection class contains all text frames in a Text Control document or part of the document represented through objects of the type TextFrame.
TXTextControl.TextFrameEventArgs | The TextFrameEventArgs class provides data for all events that occur with text frames.

Properties

Property | Description
TXTextControl.ServerTextControl.TextFrames | Gets a collection of all text frames the current document contains.
TXTextControl.TextControl.TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TXTextControl.TextControl.TextFrames | Gets a collection of all text frames contained in the text part with the input focus.
TXTextControl.WPF.TextControl.TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TXTextControl.WPF.TextControl.TextFrames | Gets a collection of all text frames contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.OnTextFrameCreated | Raises the TextFrameCreated event.
TXTextControl.ServerTextControl.OnTextFrameDeleted | Raises the TextFrameDeleted event.
TXTextControl.TextControl.OnTextFrameActivated | Raises the TextFrameActivated event.
TXTextControl.TextControl.OnTextFrameClicked | Raises the TextFrameClicked event.
TXTextControl.TextControl.OnTextFrameCreated | Raises the TextFrameCreated event.
TXTextControl.TextControl.OnTextFrameDeactivated | Raises the TextFrameDeactivated event.
TXTextControl.TextControl.OnTextFrameDeleted | Raises the TextFrameDeleted event.
TXTextControl.TextControl.OnTextFrameDeselected | Raises the TextFrameDeselected event.
TXTextControl.TextControl.OnTextFrameDoubleClicked | Raises the TextFrameDoubleClicked event.
TXTextControl.TextControl.OnTextFrameMoved | Raises the TextFrameMoved event.
TXTextControl.TextControl.OnTextFrameRightClicked | Raises the TextFrameRightClicked event.
TXTextControl.TextControl.OnTextFrameSelected | Raises the TextFrameSelected event.
TXTextControl.TextControl.OnTextFrameSized | Raises the TextFrameSized event.
TXTextControl.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.
TXTextControl.WPF.TextControl.OnTextFrameActivated | Raises the TextFrameActivated event.
TXTextControl.WPF.TextControl.OnTextFrameClicked | Raises the TextFrameClicked event.
TXTextControl.WPF.TextControl.OnTextFrameCreated | Raises the TextFrameCreated event.
TXTextControl.WPF.TextControl.OnTextFrameDeactivated | Raises the TextFrameDeactivated event.
TXTextControl.WPF.TextControl.OnTextFrameDeleted | Raises the TextFrameDeleted event.
TXTextControl.WPF.TextControl.OnTextFrameDeselected | Raises the TextFrameDeselected event.
TXTextControl.WPF.TextControl.OnTextFrameDoubleClicked | Raises the TextFrameDoubleClicked event.
TXTextControl.WPF.TextControl.OnTextFrameMoved | Raises the TextFrameMoved event.
TXTextControl.WPF.TextControl.OnTextFrameRightClicked | Raises the TextFrameRightClicked event.
TXTextControl.WPF.TextControl.OnTextFrameSelected | Raises the TextFrameSelected event.
TXTextControl.WPF.TextControl.OnTextFrameSized | Raises the TextFrameSized event.
TXTextControl.WPF.TextControl.TextFrameAttributesDialog | Invokes the built-in dialog box for setting attributes of text frames.

Events

Event | Description
TXTextControl.ServerTextControl.TextFrameCreated | Occurs when a new text frame has been created.
TXTextControl.ServerTextControl.TextFrameDeleted | Occurs when a text frame has been deleted.
TXTextControl.TextControl.TextFrameActivated | Occurs when a text frame has been activated.
TXTextControl.TextControl.TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.
TXTextControl.TextControl.TextFrameClicked | Occurs when a text frame has been clicked on.
TXTextControl.TextControl.TextFrameCreated | Occurs when a new text frame has been created.
TXTextControl.TextControl.TextFrameDeactivated | Occurs when a text frame has been deactivated.
TXTextControl.TextControl.TextFrameDeleted | Occurs when a text frame has been deleted.
TXTextControl.TextControl.TextFrameDeselected | Occurs when a text frame has been deselected.
TXTextControl.TextControl.TextFrameDoubleClicked | Occurs when a text frame has been doubleclicked on.
TXTextControl.TextControl.TextFrameMoved | Occurs when a text frame has been moved.
TXTextControl.TextControl.TextFrameRightClicked | Occurs when a text frame has been clicked on with the right mouse button.
TXTextControl.TextControl.TextFrameSelected | Occurs when a text frame has been selected.
TXTextControl.TextControl.TextFrameSized | Occurs when a text frame has been sized.
TXTextControl.WPF.TextControl.TextFrameActivated | Occurs when a text frame has been activated.
TXTextControl.WPF.TextControl.TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.
TXTextControl.WPF.TextControl.TextFrameClicked | Occurs when a text frame has been clicked on.
TXTextControl.WPF.TextControl.TextFrameCreated | Occurs when a new text frame has been created.
TXTextControl.WPF.TextControl.TextFrameDeactivated | Occurs when a text frame has been deactivated.
TXTextControl.WPF.TextControl.TextFrameDeleted | Occurs when a text frame has been deleted.
TXTextControl.WPF.TextControl.TextFrameDeselected | Occurs when a text frame has been deselected.
TXTextControl.WPF.TextControl.TextFrameDoubleClicked | Occurs when a text frame has been doubleclicked on.
TXTextControl.WPF.TextControl.TextFrameMoved | Occurs when a text frame has been moved.
TXTextControl.WPF.TextControl.TextFrameRightClicked | Occurs when a text frame has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.TextFrameSelected | Occurs when a text frame has been selected.
TXTextControl.WPF.TextControl.TextFrameSized | Occurs when a text frame has been sized.


Charts

TX Text Control for Windows Forms supports the insertion of chart controls of the type System.Windows.Forms.DataVisualization.Charting.Chart. This control is part of the .net framework since version 4, but can be added to prior versions. A chart can be positioned like an image or textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The ChartFrame class handles the positioning of the chart in the document. A chart frame is always associated with a chart control which handles the appearance and the data of the chart. All charts in a document are contained in a ChartCollection. The collection can also be used to add charts to or to remove charts from the document. The chart collection can be obtained from a TextControl or ServerTextControl through the Charts property. The TextControl.ChartLayoutDialog method opens a dialog box which offers layout settings like positioning, size and text distances. A chart can be saved with the TX Text Control and the RTF format and is reconstructed during a loading process. With other formats the chart image is saved. If a document with charts is loaded on a system where no chart controls are installed, the chart's image is inserted.

Classes

Class | Description
TXTextControl.DataVisualization.ChartCollection | An instance of the ChartCollection class contains all charts in a document represented through objects of the type DataVisualization.ChartFrame.
TXTextControl.DataVisualization.ChartEventArgs | The ChartEventArgs class provides data for all events that occur with charts.
TXTextControl.DataVisualization.ChartFrame | An instance of the ChartFrame class represents a chart and its layout in a Text Control document.

Properties

Property | Description
TXTextControl.ServerTextControl.Charts | Gets a collection of all charts in a document.
TXTextControl.TextControl.Charts | Gets a collection of all charts contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.TextControl.ChartLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a chart.
TXTextControl.TextControl.OnChartClicked | Raises the ChartClicked event.
TXTextControl.TextControl.OnChartCreated | Raises the ChartCreated event.
TXTextControl.TextControl.OnChartDeleted | Raises the ChartDeleted event.
TXTextControl.TextControl.OnChartDeselected | Raises the ChartDeselected event.
TXTextControl.TextControl.OnChartDoubleClicked | Raises the ChartDoubleClicked event.
TXTextControl.TextControl.OnChartMoved | Raises the ChartMoved event.
TXTextControl.TextControl.OnChartRightClicked | Raises the ChartRightClicked event.
TXTextControl.TextControl.OnChartSelected | Raises the ChartSelected event.
TXTextControl.TextControl.OnChartSized | Raises the ChartSized event.

Events

Event | Description
TXTextControl.ServerTextControl.ChartCreated | Occurs when a new chart has been created.
TXTextControl.ServerTextControl.ChartDeleted | Occurs when a chart has been deleted.
TXTextControl.TextControl.ChartClicked | Occurs when a chart has been clicked on.
TXTextControl.TextControl.ChartCreated | Occurs when a new chart has been created.
TXTextControl.TextControl.ChartDeleted | Occurs when a chart has been deleted.
TXTextControl.TextControl.ChartDeselected | Occurs when a chart has been deselected.
TXTextControl.TextControl.ChartDoubleClicked | Occurs when a chart has been doubleclicked on.
TXTextControl.TextControl.ChartMoved | Occurs when a chart has been moved.
TXTextControl.TextControl.ChartRightClicked | Occurs when a chart has been clicked on with the right mouse button.
TXTextControl.TextControl.ChartSelected | Occurs when a chart has been selected.
TXTextControl.TextControl.ChartSized | Occurs when a chart has been sized.


Barcodes

TX Text Control supports the insertion of barcode controls of the type TXTextControl.Barcode.TXBarcodeControl. A barcode can be positioned like an image or textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The BarcodeFrame class handles the positioning of the barcode in the document. A barcode frame is always associated with a barcode control which handles the appearance and the data of the barcode. All barcodes in a document are contained in a BarcodeCollection. The collection can also be used to add barcodes to or to remove barcodes from the document. The barcode collection can be obtained from a TextControl or ServerTextControl through the Barcodes property. The TextControl.BarcodeLayoutDialog method opens a dialog box which offers layout settings like positioning, size and text distances. A barcode can be saved with the TX Text Control and the RTF format and is reconstructed during a loading process. With other formats the barcode image is saved. If a document with barcodes is loaded on a system where no barcode controls are installed, the barcode's image is inserted.

Classes

Class | Description
TXTextControl.DataVisualization.BarcodeCollection | An instance of the BarcodeCollection class contains all barcodes in a document represented through objects of the type DataVisualization.BarcodeFrame.
TXTextControl.DataVisualization.BarcodeEventArgs | The BarcodeEventArgs class provides data for all events that occur with barcodes.
TXTextControl.DataVisualization.BarcodeFrame | An instance of the BarcodeFrame class represents a barcode and its layout in a Text Control document.

Properties

Property | Description
TXTextControl.ServerTextControl.Barcodes | Gets a collection of all barcodes in a document.
TXTextControl.TextControl.Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.
TXTextControl.WPF.TextControl.Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.ServerTextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.TextControl.OnBarcodeClicked | Raises the BarcodeClicked event.
TXTextControl.TextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.TextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.TextControl.OnBarcodeDeselected | Raises the BarcodeDeselected event.
TXTextControl.TextControl.OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
TXTextControl.TextControl.OnBarcodeMoved | Raises the BarcodeMoved event.
TXTextControl.TextControl.OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
TXTextControl.TextControl.OnBarcodeSelected | Raises the BarcodeSelected event.
TXTextControl.TextControl.OnBarcodeSized | Raises the BarcodeSized event.
TXTextControl.WPF.TextControl.BarcodeLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
TXTextControl.WPF.TextControl.OnBarcodeClicked | Raises the BarcodeClicked event.
TXTextControl.WPF.TextControl.OnBarcodeCreated | Raises the BarcodeCreated event.
TXTextControl.WPF.TextControl.OnBarcodeDeleted | Raises the BarcodeDeleted event.
TXTextControl.WPF.TextControl.OnBarcodeDeselected | Raises the BarcodeDeselected event.
TXTextControl.WPF.TextControl.OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
TXTextControl.WPF.TextControl.OnBarcodeMoved | Raises the BarcodeMoved event.
TXTextControl.WPF.TextControl.OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
TXTextControl.WPF.TextControl.OnBarcodeSelected | Raises the BarcodeSelected event.
TXTextControl.WPF.TextControl.OnBarcodeSized | Raises the BarcodeSized event.

Events

Event | Description
TXTextControl.ServerTextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.ServerTextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.TextControl.BarcodeClicked | Occurs when a barcode has been clicked on.
TXTextControl.TextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.TextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.TextControl.BarcodeDeselected | Occurs when a barcode has been deselected.
TXTextControl.TextControl.BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
TXTextControl.TextControl.BarcodeMoved | Occurs when a barcode has been moved.
TXTextControl.TextControl.BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
TXTextControl.TextControl.BarcodeSelected | Occurs when a barcode has been selected.
TXTextControl.TextControl.BarcodeSized | Occurs when a barcode has been sized.
TXTextControl.WPF.TextControl.BarcodeClicked | Occurs when a barcode has been clicked on.
TXTextControl.WPF.TextControl.BarcodeCreated | Occurs when a new barcode has been created.
TXTextControl.WPF.TextControl.BarcodeDeleted | Occurs when a barcode has been deleted.
TXTextControl.WPF.TextControl.BarcodeDeselected | Occurs when a barcode has been deselected.
TXTextControl.WPF.TextControl.BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
TXTextControl.WPF.TextControl.BarcodeMoved | Occurs when a barcode has been moved.
TXTextControl.WPF.TextControl.BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.BarcodeSelected | Occurs when a barcode has been selected.
TXTextControl.WPF.TextControl.BarcodeSized | Occurs when a barcode has been sized.


Drawings and Shapes

TX Text Control supports the insertion of drawings and shapes. A drawing can be positioned like an image or textframe, either geometrically or as a single character. Geometrically, its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The DrawingFrame class handles the positioning of the drawing in the document. A drawing frame is always associated with a Drawing.TXDrawingControl or WPF.Drawing.TXDrawingControl which handles the appearance and the data of the drawing. A drawing can be activated and its contained shapes can be altered through the user with built-in mouse and keyboard interfaces. A drawing control is also fully programmable, its contained shapes are accessible through a Drawing.ShapeCollection. All drawings in a document are contained in a DrawingCollection. The collection can also be used to add drawings to or to remove drawings from the document. The drawing collection can be obtained through the TextControl.Drawings, WPF.TextControl.Drawings or ServerTextControl.Drawings property. The TextControl.DrawingLayoutDialog and WPF.TextControl.DrawingLayoutDialog methods opens a dialog box, which offers layout settings such as positioning, size and text distances. A drawing can be saved and loaded with the TX Text Control format and the Microsoft Word format (.docx). With other formats the drawing's bitmap image is saved.

Classes

Class | Description
TXTextControl.DataVisualization.DrawingCollection | An instance of the DrawingCollection class contains all drawings in a document represented through objects of the type DataVisualization.DrawingFrame.
TXTextControl.DataVisualization.DrawingEventArgs | The DrawingEventArgs class provides data for all events that occur with drawings.
TXTextControl.DataVisualization.DrawingFrame | An instance of the DrawingFrame class represents a drawing and its layout in a Text Control document.
TXTextControl.Drawing.MenuItem | The Drawing.MenuItem class represents a bindable Windows Forms ToolStripMenuItem.
TXTextControl.Drawing.Selection | The Drawing.Selection class represents all selected shapes.
TXTextControl.Drawing.Shape | The Drawing.Shape class represents a shape which can be displayed inside the TX Drawing Control.
TXTextControl.Drawing.Shape.Fill | The Drawing.Shape.Fill class determines the fill properties of a shape.
TXTextControl.Drawing.Shape.Outline | The Drawing.Shape.Outline class determines the line properties of a shape.
TXTextControl.Drawing.ShapeCollection | An instance of the ShapeCollection class contains all displayed shapes represented through objects of type Shape.
TXTextControl.Drawing.ShapeEventArgs | The ShapeEventArgs class provides data for all events that occur with shapes.
TXTextControl.Drawing.ShapesContextMenuStrip | The Drawing.ShapesContextMenuStrip class represents the default context menu of the Windows Forms TXDrawingControl.
TXTextControl.Drawing.TXDrawingControl | The TXDrawingControl class implements a Windows Forms control with features to draw custom or predefined shapes.
TXTextControl.Drawing.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the TXDrawingControl.ViewChanged event.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemEventArgs | The RibbonListViewItemEventArgs class provides data for the RibbonListView.ItemClick, ItemMouseEnter or ItemMouseLeave event.
TXTextControl.WPF.Drawing.ShapesContextMenu | The WPF.Drawing.ShapesContextMenu class represents the default context menu of the WPF TXDrawingControl.
TXTextControl.WPF.Drawing.TXDrawingControl | The WPF.TXDrawingControl class implements a WPF FrameworkElement with features to draw custom or predefined shapes.

Properties

Property | Description
TXTextControl.ServerTextControl.Drawings | Gets a collection of all drawings in a document.
TXTextControl.TextControl.DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
TXTextControl.TextControl.Drawings | Gets a collection of all drawings contained in the text part with the input focus.
TXTextControl.WPF.TextControl.DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
TXTextControl.WPF.TextControl.Drawings | Gets a collection of all drawings contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.ServerTextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.TextControl.OnDrawingActivated | Raises the DrawingActivated event.
TXTextControl.TextControl.OnDrawingClicked | Raises the DrawingClicked event.
TXTextControl.TextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.TextControl.OnDrawingDeactivated | Raises the DrawingDeactivated event.
TXTextControl.TextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.TextControl.OnDrawingDeselected | Raises the DrawingDeselected event.
TXTextControl.TextControl.OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
TXTextControl.TextControl.OnDrawingMoved | Raises the DrawingMoved event.
TXTextControl.TextControl.OnDrawingRightClicked | Raises the DrawingRightClicked event.
TXTextControl.TextControl.OnDrawingSelected | Raises the DrawingSelected event.
TXTextControl.TextControl.OnDrawingSized | Raises the DrawingSized event.
TXTextControl.WPF.TextControl.DrawingLayoutDialog | Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
TXTextControl.WPF.TextControl.OnDrawingActivated | Raises the DrawingActivated event.
TXTextControl.WPF.TextControl.OnDrawingClicked | Raises the DrawingClicked event.
TXTextControl.WPF.TextControl.OnDrawingCreated | Raises the DrawingCreated event.
TXTextControl.WPF.TextControl.OnDrawingDeactivated | Raises the DrawingDeactivated event.
TXTextControl.WPF.TextControl.OnDrawingDeleted | Raises the DrawingDeleted event.
TXTextControl.WPF.TextControl.OnDrawingDeselected | Raises the DrawingDeselected event.
TXTextControl.WPF.TextControl.OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
TXTextControl.WPF.TextControl.OnDrawingMoved | Raises the DrawingMoved event.
TXTextControl.WPF.TextControl.OnDrawingRightClicked | Raises the DrawingRightClicked event.
TXTextControl.WPF.TextControl.OnDrawingSelected | Raises the DrawingSelected event.
TXTextControl.WPF.TextControl.OnDrawingSized | Raises the DrawingSized event.

Events

Event | Description
TXTextControl.ServerTextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.ServerTextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.TextControl.DrawingActivated | Occurs when a drawing has been activated.
TXTextControl.TextControl.DrawingClicked | Occurs when a drawing has been clicked on.
TXTextControl.TextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.TextControl.DrawingDeactivated | Occurs when a drawing has been deactivated.
TXTextControl.TextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.TextControl.DrawingDeselected | Occurs when a drawing has been deselected.
TXTextControl.TextControl.DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
TXTextControl.TextControl.DrawingMoved | Occurs when a drawing has been moved.
TXTextControl.TextControl.DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
TXTextControl.TextControl.DrawingSelected | Occurs when a drawing has been selected.
TXTextControl.TextControl.DrawingSized | Occurs when a drawing has been sized.
TXTextControl.WPF.TextControl.DrawingActivated | Occurs when a drawing has been activated.
TXTextControl.WPF.TextControl.DrawingClicked | Occurs when a drawing has been clicked on.
TXTextControl.WPF.TextControl.DrawingCreated | Occurs when a new drawing has been created.
TXTextControl.WPF.TextControl.DrawingDeactivated | Occurs when a drawing has been deactivated.
TXTextControl.WPF.TextControl.DrawingDeleted | Occurs when a drawing has been deleted.
TXTextControl.WPF.TextControl.DrawingDeselected | Occurs when a drawing has been deselected.
TXTextControl.WPF.TextControl.DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
TXTextControl.WPF.TextControl.DrawingMoved | Occurs when a drawing has been moved.
TXTextControl.WPF.TextControl.DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.DrawingSelected | Occurs when a drawing has been selected.
TXTextControl.WPF.TextControl.DrawingSized | Occurs when a drawing has been sized.


Hypertext Links

Classes

Class | Description
TXTextControl.BookmarkDialog | The BookmarkDialog class implements a Windows Forms dialog box to insert a DocumentTarget at the current input position.
TXTextControl.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a Windows Forms dialog box which shows all targets in the current document.
TXTextControl.DocumentLink | The DocumentLink class represents a link in a Text Control document that points to a target in the same document.
TXTextControl.DocumentLinkCollection | An instance of the DocumentLinkCollection class contains all links in a Text Control document that point to targets in the same document.
TXTextControl.DocumentLinkEventArgs | The DocumentLinkEventArgs class provides data for the TextControl.DocumentLinkClicked event.
TXTextControl.DocumentTarget | The DocumentTarget class represents a text position in a Text Control document that is a target of a document link.
TXTextControl.DocumentTargetCollection | An instance of the DocumentTargetCollection class contains all targets in a Text Control document represented through objects of the type DocumentTarget.
TXTextControl.HyperlinkDialog | The HyperlinkDialog class implements a Windows Forms dialog box for inserting and editing a hyperlink at the current text input position.
TXTextControl.HypertextLink | The HypertextLink class represents a hypertext link in a Text Control document that points to a target outside of the document.
TXTextControl.HypertextLinkCollection | An instance of the HypertextLinkCollection class contains all hypertext links in a Text Control document represented through objects of the type HypertextLink.
TXTextControl.HypertextLinkEventArgs | The HypertextLinkEventArgs class provides data for the TextControl.HypertextLinkClicked event.
TXTextControl.WPF.BookmarkDialog | The WPF.BookmarkDialog class implements a dialog box to insert a DocumentTarget at the current input position.
TXTextControl.WPF.DeleteBookmarksDialog | The DeleteBookmarksDialog class implements a dialog box which shows all targets in the current document.
TXTextControl.WPF.HyperlinkDialog | The WPF.HyperlinkDialog class implements a built-in dialog box for inserting and editing a hyperlink at the current text input position.

Properties

Property | Description
TXTextControl.ServerTextControl.DocumentLinks | Gets a collection of all links that point to targets in the same document.
TXTextControl.ServerTextControl.DocumentTargets | Gets a collection of all targets in the document.
TXTextControl.ServerTextControl.HypertextLinks | Gets a collection of all hypertext links contained in the main text of the document.
TXTextControl.TextControl.DocumentLinks | Gets a collection of all document links contained in the text part with the input focus.
TXTextControl.TextControl.DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.
TXTextControl.TextControl.DocumentTargets | Gets a collection of all targets contained in the text part with the input focus.
TXTextControl.TextControl.HypertextLinks | Gets a collection of all hypertext links contained in the text part with the input focus.
TXTextControl.WPF.TextControl.DocumentLinks | Gets a collection of all document links contained in the text part with the input focus.
TXTextControl.WPF.TextControl.DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.
TXTextControl.WPF.TextControl.DocumentTargets | Gets a collection of all targets contained in the text part with the input focus.
TXTextControl.WPF.TextControl.HypertextLinks | Gets a collection of all hypertext links contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.TextControl.OnDocumentLinkClicked | Raises the DocumentLinkClicked event.
TXTextControl.TextControl.OnHypertextLinkClicked | Raises the HypertextLinkClicked event.
TXTextControl.WPF.TextControl.OnDocumentLinkClicked | Raises the DocumentLinkClicked event.
TXTextControl.WPF.TextControl.OnHypertextLinkClicked | Raises the HypertextLinkClicked event.

Events

Event | Description
TXTextControl.TextControl.DocumentLinkClicked | Occurs when a text field has been clicked on that represents a link to a target in the document.
TXTextControl.TextControl.HypertextLinkClicked | Occurs when a text field has been clicked on that represents the source of a hypertext link.
TXTextControl.WPF.TextControl.DocumentLinkClicked | Occurs when a text field has been clicked on that represents a link to a target in the document.
TXTextControl.WPF.TextControl.HypertextLinkClicked | Occurs when a text field has been clicked on that represents the source of a hypertext link.


Text Selections and Character Input

Classes

Class | Description
TXTextControl.GotoDialog | The GotoDialog class implements a Windows Forms dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.
TXTextControl.InputPosition | An instance of the InputPosition class represents the current text input position of a TXTextControl document.
TXTextControl.Selection | The Selection class describes and handles the attributes of a text selection.
TXTextControl.WPF.GotoDialog | The GotoDialog class implements a dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark.

Properties

Property | Description
TXTextControl.ServerTextControl.InputPosition | Gets or sets the current text input position.
TXTextControl.ServerTextControl.Selection | Gets or sets the current selection in the main text of the document.
TXTextControl.TextControl.CaretWidth | Gets or sets the width of the caret in pixels.
TXTextControl.TextControl.HideSelection | Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.
TXTextControl.TextControl.InputPosition | Gets or sets the current text input position.
TXTextControl.TextControl.InsertionMode | Specifies whether text is inserted or overwrites existing text.
TXTextControl.TextControl.Selection | Gets or sets the current selection in the text part with the input focus.
TXTextControl.TextControl.SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.
TXTextControl.WPF.TextControl.CaretWidth | Gets or sets the width of the caret in pixels.
TXTextControl.WPF.TextControl.HideSelection | Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.
TXTextControl.WPF.TextControl.InputPosition | Gets or sets the current text input position.
TXTextControl.WPF.TextControl.InsertionMode | Specifies whether text is inserted or overwrites existing text.
TXTextControl.WPF.TextControl.Selection | Gets or sets the current selection in the text part with the input focus.
TXTextControl.WPF.TextControl.SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.

Methods

Method | Description
TXTextControl.ServerTextControl.Select | Selects text within the control.
TXTextControl.ServerTextControl.SelectAll | Selects all text in the control.
TXTextControl.TextControl.OnInputPositionChanged | Raises the InputPositionChanged event.
TXTextControl.TextControl.Select | Selects text within the Text Control.
TXTextControl.TextControl.SelectAll | Selects all text in the Text Control.
TXTextControl.WPF.TextControl.OnInputPositionChanged | Raises the InputPositionChanged event.
TXTextControl.WPF.TextControl.Select | Selects text within the Text Control.
TXTextControl.WPF.TextControl.SelectAll | Selects all text in the Text Control.

Events

Event | Description
TXTextControl.TextControl.InputPositionChanged | Occurs when the text input position has been changed.
TXTextControl.WPF.TextControl.InputPositionChanged | Occurs when the text input position has been changed.


Text Fields

Classes

Class | Description
TXTextControl.ApplicationField | The ApplicationField class supports text field formats of applications such as Microsoft Word.
TXTextControl.ApplicationFieldCollection | An instance of the ApplicationFieldCollection class contains all created or imported Microsoft Word or Heiler HighEdit fields represented through objects of the type ApplicationField.
TXTextControl.TextField | An instance of the TextField class represents a text field in a Text Control document.
TXTextControl.TextFieldCollection | An instance of the TextFieldCollection class contains all standard text fields in a Text Control document or part of the document represented through objects of the type TextField.
TXTextControl.TextFieldCollectionBase | The TextFieldCollectionBase class is the base class of the TextFieldCollection, HypertextLinkCollection, DocumentTargetCollection, DocumentLinkCollection, PageNumberFieldCollection and ApplicationFieldCollection classes.
TXTextControl.TextFieldEventArgs | The TextFieldEventArgs class provides data for the TextControl.TextFieldClicked, TextControl.TextFieldCreated, TextControl.TextFieldDoubleClicked, TextControl.TextFieldDeleted, TextControl.TextFieldChanged, TextControl.TextFieldEntered and TextControl.TextFieldLeft events.

Properties

Property | Description
TXTextControl.ServerTextControl.ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
TXTextControl.ServerTextControl.TextFields | Gets a collection of all standard text fields contained in the main text of the document.
TXTextControl.TextControl.ApplicationFields | Gets a collection of all application fields contained in the text part with the input focus.
TXTextControl.TextControl.FieldCursor | Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.
TXTextControl.TextControl.TextFields | Gets a collection of all standard text fields contained in the text part with the input focus.
TXTextControl.WPF.TextControl.ApplicationFields | Gets a collection of all application fields contained in the text part with the input focus.
TXTextControl.WPF.TextControl.FieldCursor | Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.
TXTextControl.WPF.TextControl.TextFields | Gets a collection of all standard text fields contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.ServerTextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.TextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.TextControl.OnTextFieldChanged | Raises the TextFieldChanged event.
TXTextControl.TextControl.OnTextFieldClicked | Raises the TextFieldClicked event.
TXTextControl.TextControl.OnTextFieldCreated | Raises the TextFieldCreated event.
TXTextControl.TextControl.OnTextFieldDeleted | Raises the TextFieldDeleted event.
TXTextControl.TextControl.OnTextFieldDoubleClicked | Raises the TextFieldDoubleClicked event.
TXTextControl.TextControl.OnTextFieldEntered | Raises the TextFieldEntered event.
TXTextControl.TextControl.OnTextFieldLeft | Raises the TextFieldLeft event.
TXTextControl.TextControl.ResetFieldCursor | Resets the FieldCursor property to its default value.
TXTextControl.WPF.TextControl.GetTextFields | Returns a collection containing text fields of the specified types.
TXTextControl.WPF.TextControl.OnTextFieldChanged | Raises the TextFieldChanged event.
TXTextControl.WPF.TextControl.OnTextFieldClicked | Raises the TextFieldClicked event.
TXTextControl.WPF.TextControl.OnTextFieldCreated | Raises the TextFieldCreated event.
TXTextControl.WPF.TextControl.OnTextFieldDeleted | Raises the TextFieldDeleted event.
TXTextControl.WPF.TextControl.OnTextFieldDoubleClicked | Raises the TextFieldDoubleClicked event.
TXTextControl.WPF.TextControl.OnTextFieldEntered | Raises the TextFieldEntered event.
TXTextControl.WPF.TextControl.OnTextFieldLeft | Raises the TextFieldLeft event.

Events

Event | Description
TXTextControl.TextControl.TextFieldChanged | Occurs when the text of a text field has been changed.
TXTextControl.TextControl.TextFieldClicked | Occurs when a text field has been clicked on.
TXTextControl.TextControl.TextFieldCreated | Occurs when a text field has been pasted from the clipboard.
TXTextControl.TextControl.TextFieldDeleted | Occurs when a text field has been deleted.
TXTextControl.TextControl.TextFieldDoubleClicked | Occurs when a text field has been double-clicked on.
TXTextControl.TextControl.TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TXTextControl.TextControl.TextFieldLeft | Occurs when the current input position has left a text field.
TXTextControl.WPF.TextControl.TextFieldChanged | Occurs when the text of a text field has been changed.
TXTextControl.WPF.TextControl.TextFieldClicked | Occurs when a text field has been clicked on.
TXTextControl.WPF.TextControl.TextFieldCreated | Occurs when a text field has been pasted from the clipboard.
TXTextControl.WPF.TextControl.TextFieldDeleted | Occurs when a text field has been deleted.
TXTextControl.WPF.TextControl.TextFieldDoubleClicked | Occurs when a text field has been double-clicked on.
TXTextControl.WPF.TextControl.TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TXTextControl.WPF.TextControl.TextFieldLeft | Occurs when the current input position has left a text field.


Spell Checking

Classes

Class | Description
TXTextControl.HyphenateWordEventArgs | The HyphenateWordEventArgs class provides data for the TextControl.HyphenateWord, ServerTextControl.HyphenateWord and WPF.TextControl.HyphenateWord events.
TXTextControl.MisspelledWord | The MisspelledWord class represents a misspelled word in a document's text.
TXTextControl.MisspelledWordCollection | An instance of the MisspelledWordCollection class contains all misspelled words in the main part of a Text Control document.
TXTextControl.SpellCheckTextEventArgs | The SpellCheckTextEventArgs class provides data for the TextControl.SpellCheckText and WPF.TextControl.SpellCheckText events.

Properties

Property | Description
TXTextControl.ServerTextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
TXTextControl.ServerTextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
TXTextControl.ServerTextControl.IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
TXTextControl.ServerTextControl.MisspelledWords | Gets a collection of all misspelled words in the main text of the document.
TXTextControl.ServerTextControl.SpellChecker | Specifies the spell checking component to be used with a ServerTextControl.
TXTextControl.TextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
TXTextControl.TextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
TXTextControl.TextControl.IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
TXTextControl.TextControl.MisspelledWords | Gets a collection of all misspelled words contained in the text part with the input focus.
TXTextControl.TextControl.SpellCheckContextMenuStrip | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
TXTextControl.TextControl.SpellChecker | Specifies the spell checking component to be used with a TextControl.
TXTextControl.WPF.TextControl.IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
TXTextControl.WPF.TextControl.IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
TXTextControl.WPF.TextControl.IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
TXTextControl.WPF.TextControl.MisspelledWords | Gets a collection of all misspelled words contained in the text part with the input focus.
TXTextControl.WPF.TextControl.SpellCheckContextMenu | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
TXTextControl.WPF.TextControl.SpellChecker | Specifies the spell checking component to be used with a TextControl.

Methods

Method | Description
TXTextControl.ServerTextControl.OnHyphenateWord | Raises the HyphenateWord event.
TXTextControl.ServerTextControl.OnSpellCheckText | Raises the SpellCheckText event.
TXTextControl.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.TextControl.OnHyphenateWord | Raises the HyphenateWord event.
TXTextControl.TextControl.OnSpellCheckText | Raises the SpellCheckText event.
TXTextControl.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.
TXTextControl.WPF.TextControl.LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
TXTextControl.WPF.TextControl.OnHyphenateWord | Raises the HyphenateWord event.
TXTextControl.WPF.TextControl.OnSpellCheckText | Raises the SpellCheckText event.
TXTextControl.WPF.TextControl.SpellCheckDialog | Invokes the built-in dialog box for correcting misspelled words.

Events

Event | Description
TXTextControl.ServerTextControl.HyphenateWord | Occurs, if a word does not fit on the line and must be hyphenated.
TXTextControl.ServerTextControl.SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
TXTextControl.TextControl.HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.
TXTextControl.TextControl.SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
TXTextControl.WPF.TextControl.HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.
TXTextControl.WPF.TextControl.SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.


Clipboard Operations

Properties

Property | Description
TXTextControl.TextControl.CanCopy | Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.
TXTextControl.TextControl.CanPaste | Informs whether the clipboard contains a format that can be pasted into a Text Control document.
TXTextControl.WPF.TextControl.CanCopy | Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.
TXTextControl.WPF.TextControl.CanPaste | Informs whether the clipboard contains a format that can be pasted into a Text Control document.

Methods

Method | Description
TXTextControl.TextControl.Copy | Copies the current selection in the Text Control to the Clipboard.
TXTextControl.TextControl.Cut | Moves the current selection in the Text Control to the Clipboard.
TXTextControl.TextControl.GetClipboardFormats | Returns an array of ClipboardFormat values.
TXTextControl.TextControl.Paste | Replaces the current selection in the Text Control with the contents of the Clipboard.
TXTextControl.WPF.TextControl.Copy | Copies the current selection in the Text Control to the Clipboard.
TXTextControl.WPF.TextControl.Cut | Moves the current selection in the Text Control to the Clipboard.
TXTextControl.WPF.TextControl.GetClipboardFormats | Returns an array of ClipboardFormat values.
TXTextControl.WPF.TextControl.Paste | Replaces the current selection in the Text Control with the contents of the Clipboard.


Undo

Properties

Property | Description
TXTextControl.TextControl.AllowUndo | Gets or sets a value indicating whether the undo buffer is active or not.
TXTextControl.TextControl.CanRedo | Informs whether an operation can be re-done using the Redo method.
TXTextControl.TextControl.CanUndo | Gets a value indicating whether the user can undo the previous operation in a Text Control.
TXTextControl.TextControl.RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
TXTextControl.TextControl.UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.
TXTextControl.WPF.TextControl.CanRedo | Informs whether an operation can be re-done using the Redo method.
TXTextControl.WPF.TextControl.CanUndo | Gets a value indicating whether the user can undo the previous operation in a Text Control.
TXTextControl.WPF.TextControl.IsUndoEnabled | Gets or sets a value indicating whether the undo buffer is active or not.
TXTextControl.WPF.TextControl.RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
TXTextControl.WPF.TextControl.UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.

Methods

Method | Description
TXTextControl.TextControl.BeginUndoAction | Begins a user-defined undo operation.
TXTextControl.TextControl.ClearUndo | Clears the undo buffer of the Text Control.
TXTextControl.TextControl.EndUndoAction | Ends a user-defined undo operation.
TXTextControl.TextControl.Redo | Redoes the last Text Control operation.
TXTextControl.TextControl.Undo | Undoes the last edit operation in the Text Control.
TXTextControl.WPF.TextControl.BeginUndoAction | Begins a user-defined undo operation.
TXTextControl.WPF.TextControl.ClearUndo | Clears the undo buffer of the Text Control.
TXTextControl.WPF.TextControl.EndUndoAction | Ends a user-defined undo operation.
TXTextControl.WPF.TextControl.Redo | Redoes the last Text Control operation.
TXTextControl.WPF.TextControl.Undo | Undoes the last edit operation in the Text Control.


Search and Replace

Methods

Method | Description
TXTextControl.ServerTextControl.Find | Finds a text string in the main text of the document.
TXTextControl.TextControl.Find | Finds a text string in the text part with the input focus.
TXTextControl.TextControl.Replace | Opens the built-in Replace dialog box.
TXTextControl.WPF.TextControl.Find | Finds a text string in the text part with the input focus.
TXTextControl.WPF.TextControl.Replace | Opens the built-in Replace dialog box.


Zooming

Properties

Property | Description
TXTextControl.TextControl.ZoomFactor | Gets or sets the zoom factor, in percent, for a Text Control.
TXTextControl.WPF.TextControl.ZoomFactor | Gets or sets the zoom factor, in percent, for a Text Control.

Methods

Method | Description
TXTextControl.TextControl.OnZoomed | Raises the Zoomed event.
TXTextControl.TextControl.Zoom | Zooms the contents of the TextControl.
TXTextControl.WPF.TextControl.Zoom | Zooms the contents of the TextControl.

Events

Event | Description
TXTextControl.TextControl.Zoomed | Occurs when the Text Control has been zoomed.


Control Settings

Classes

Class | Description
TXTextControl.AdaptFontEventArgs | The AdaptFontEventArgs class provides data for the TextControl.AdaptFont, WPF.TextControl.AdaptFont and ServerTextControl.AdaptFont events.
TXTextControl.AutoSize | The AutoSize class is used with the TextControl.AutoControlSize property, to enable automatic expansion or shrinking of a Text Control's width or height.
TXTextControl.FontSettings | The FontSettings class provides settings determining which fonts can be used in a document.
TXTextControl.TextContextMenuEventArgs | The TextContextMenuEventArgs class provides data for the TextControl.TextContextMenuOpening event of a Windows Forms TextControl.
TXTextControl.TextControl.Colors | The TextControl.Colors class gets, sets or resets the display colors of a Windows Forms TextControl control.
TXTextControl.VersionInfo | The VersionInfo class provides information about the running TX Text Control version, such as the version number, the installed service pack number and the product level.
TXTextControl.WPF.TextContextMenuEventArgs | The WPF.TextContextMenuEventArgs class provides data for the WPF.TextControl.TextContextMenuOpening event.
TXTextControl.WPF.TextControlColors | The WPF.TextControlColors class gets, sets or resets the display colors of a WPF.TextControl control.
TXTextControl.WPF.TextControlDocument | An object of the WPF.TextControlDocument class represents a document and is part of the template of a WPF.TextControl.

Properties

Property | Description
TXTextControl.ServerTextControl.BackColor | Gets or sets the background color of the control.
TXTextControl.ServerTextControl.FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
TXTextControl.ServerTextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.ServerTextControl.IsCreated | Gets a value indicating whether the control is completely created.
TXTextControl.TextControl.AcceptsTab | Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order.
TXTextControl.TextControl.AllowDrag | Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation.
TXTextControl.TextControl.AllowDrop | Overridden. Gets or sets a value indicating whether the control can accept data that the user drags onto it.
TXTextControl.TextControl.AutoControlSize | Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text.
TXTextControl.TextControl.BackColor | Overridden. Gets or sets the background color of the control.
TXTextControl.TextControl.BackgroundStyle | Defines the kind of view to display the page background.
TXTextControl.TextControl.BorderStyle | Gets or sets the border type of the Text Control.
TXTextControl.TextControl.ControlChars | Specifies if control characters are visible or not.
TXTextControl.TextControl.DisplayColors | Gets or sets the colors of the text control.
TXTextControl.TextControl.DropFormats | Gets or sets the formats of data the control can accept when the user drags it onto the control.
TXTextControl.TextControl.EditMode | Gets or sets a value indicating whether the document's text is read-only, can be selected or is editable.
TXTextControl.TextControl.FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
TXTextControl.TextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.TextControl.PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
TXTextControl.TextControl.ScrollBars | Gets or sets a value indicating whether a Text Control has horizontal or vertical scroll bars.
TXTextControl.TextControl.ScrollLocation | Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.
TXTextControl.TextControl.ViewMode | Gets or sets the mode in which Text Control displays its contents.
TXTextControl.WPF.TextControl.AcceptsTab | Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order.
TXTextControl.WPF.TextControl.AllowDrag | Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation.
TXTextControl.WPF.TextControl.AllowDrop | Inherited from System.Windows.UIElement.
TXTextControl.WPF.TextControl.AutoControlSize | Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text.
TXTextControl.WPF.TextControl.BorderThickness | Gets or sets the border thickness of the Text Control.
TXTextControl.WPF.TextControl.ControlChars | Specifies if control characters are visible or not.
TXTextControl.WPF.TextControl.DisplayColors | Gets or sets the colors of the text control.
TXTextControl.WPF.TextControl.DropFormats | Gets or sets the formats of data the control can accept when the user drags it onto the control.
TXTextControl.WPF.TextControl.EditMode | Gets or sets a value indicating whether text in the Text Control is read-only, can be selected or is editable.
TXTextControl.WPF.TextControl.FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
TXTextControl.WPF.TextControl.FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
TXTextControl.WPF.TextControl.HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown.
TXTextControl.WPF.TextControl.IsTabStop | Gets or sets a value that indicates whether a text control is included in tab navigation.
TXTextControl.WPF.TextControl.PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
TXTextControl.WPF.TextControl.ScrollLocation | Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.
TXTextControl.WPF.TextControl.TabIndex | Gets or sets the tab index of the text control.
TXTextControl.WPF.TextControl.VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown.
TXTextControl.WPF.TextControl.ViewMode | Gets or sets the mode in which Text Control displays its contents.

Methods

Method | Description
TXTextControl.ServerTextControl.Create | Initializes the resources of a newly instantiated object.
TXTextControl.ServerTextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
TXTextControl.ServerTextControl.OnAdaptFont | Raises the AdaptFont event.
TXTextControl.ServerTextControl.ResetBackColor | Resets the BackColor property to its default value.
TXTextControl.TextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
TXTextControl.TextControl.OnAcceptsTabChanged | Raises the AcceptsTabChanged event.
TXTextControl.TextControl.OnAdaptFont | Raises the AdaptFont event.
TXTextControl.TextControl.OnBorderStyleChanged | Raises the BorderStyleChanged event.
TXTextControl.TextControl.OnHandleCreated | Overridden. See Control.OnHandleCreated.
TXTextControl.TextControl.OnHExpanded | Raises the HExpanded event.
TXTextControl.TextControl.OnHScroll | Raises the HScroll event.
TXTextControl.TextControl.OnHShrunk | Raises the HShrunk event.
TXTextControl.TextControl.OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
TXTextControl.TextControl.OnVExpanded | Raises the VExpanded event.
TXTextControl.TextControl.OnVScroll | Raises the VScroll event.
TXTextControl.TextControl.OnVShrunk | Raises the VShrunk event.
TXTextControl.TextControl.ResetAutoControlSize | Resets the AutoControlSize property to its default values.
TXTextControl.TextControl.ResetBackColor | Overridden. Resets the BackColor property to its default value.
TXTextControl.TextControl.ResetCursor | Overridden. Resets the Cursor property to its default value.
TXTextControl.WPF.TextControl.GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
TXTextControl.WPF.TextControl.OnAdaptFont | Raises the AdaptFont event.
TXTextControl.WPF.TextControl.OnHExpanded | Raises the HExpanded event.
TXTextControl.WPF.TextControl.OnHScroll | Raises the HScroll event.
TXTextControl.WPF.TextControl.OnHShrunk | Raises the HShrunk event.
TXTextControl.WPF.TextControl.OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
TXTextControl.WPF.TextControl.OnVExpanded | Raises the VExpanded event.
TXTextControl.WPF.TextControl.OnVScroll | Raises the VScroll event.
TXTextControl.WPF.TextControl.OnVShrunk | Raises the VShrunk event.

Events

Event | Description
TXTextControl.ServerTextControl.AdaptFont | Occurs for each font that must be adapted, because it is not supported.
TXTextControl.TextControl.AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed.
TXTextControl.TextControl.AdaptFont | Occurs for each font that must be adapted, because it is not supported.
TXTextControl.TextControl.BorderStyleChanged | Occurs when the value of the BorderStyle property has changed.
TXTextControl.TextControl.HExpanded | Occurs when the Text Control has automatically expanded its size horizontally.
TXTextControl.TextControl.HScroll | Occurs when the horizontal scroll position has been changed.
TXTextControl.TextControl.HShrunk | Occurs when the Text Control has automatically shrunk its size horizontally.
TXTextControl.TextControl.TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TXTextControl.TextControl.VExpanded | Occurs when the Text Control has automatically expanded its size vertically.
TXTextControl.TextControl.VScroll | Occurs when the vertical scroll position has been changed.
TXTextControl.TextControl.VShrunk | Occurs when the Text Control has automatically shrunk its size vertically.
TXTextControl.WPF.TextControl.AdaptFont | Occurs for each font that must be adapted, because it is not supported.
TXTextControl.WPF.TextControl.HExpanded | Occurs when the Text Control has automatically expanded its size horizontally.
TXTextControl.WPF.TextControl.HScroll | Occurs when the horizontal scroll position has been changed.
TXTextControl.WPF.TextControl.HShrunk | Occurs when the Text Control has automatically shrunk its size horizontally.
TXTextControl.WPF.TextControl.TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TXTextControl.WPF.TextControl.VExpanded | Occurs when the Text Control has automatically expanded its size vertically.
TXTextControl.WPF.TextControl.VScroll | Occurs when the vertical scroll position has been changed.
TXTextControl.WPF.TextControl.VShrunk | Occurs when the Text Control has automatically shrunk its size vertically.


Paragraph Programming

Classes

Class | Description
TXTextControl.Paragraph | An instance of the Paragraph class represents a single paragraph in a Text Control document.
TXTextControl.ParagraphCollection | An instance of the ParagraphCollection class contains all paragraphs in a Text Control document or part of the document represented through objects of the type Paragraph.

Properties

Property | Description
TXTextControl.ServerTextControl.Paragraphs | Gets a collection of all paragraphs contained in the main text of the document.
TXTextControl.TextControl.Paragraphs | Gets a collection of all paragraphs contained in the text part with the input focus.
TXTextControl.WPF.TextControl.Paragraphs | Gets a collection of all paragraphs contained in the text part with the input focus.


Line and Character Operations

Classes

Class | Description
TXTextControl.Line | An instance of the Line class represents a single line in a Text Control document.
TXTextControl.LineCollection | An instance of the LineCollection class contains all text lines in a Text Control document or part of the document represented through objects of the type Line.
TXTextControl.TextChar | An instance of the TextChar class represents a single character in a Text Control document.
TXTextControl.TextCharCollection | An instance of the TextCharCollection class contains all characters in a Text Control document or part of the document represented through objects of the type TextChar.

Properties

Property | Description
TXTextControl.ServerTextControl.Lines | Gets a collection of all lines contained in the main text of the document.
TXTextControl.ServerTextControl.TextChars | Gets a collection of all characters contained in the main text of the document.
TXTextControl.TextControl.Lines | Gets a collection of all lines contained in the text part with the input focus.
TXTextControl.TextControl.TextChars | Gets a collection of all characters contained in the text part with the input focus.
TXTextControl.WPF.TextControl.Lines | Gets a collection of all lines contained in the text part with the input focus.
TXTextControl.WPF.TextControl.TextChars | Gets a collection of all characters contained in the text part with the input focus.

Methods

Method | Description
TXTextControl.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
TXTextControl.WPF.TextControl.AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.


Programming Formatted Textparts

A TX Text Control document consists of the document's main text and additional pieces of text like text frames and headers and footers. To provide easy access to all of these text parts TX Text Control offers the TextPartCollection class. An instance of this class contains all text parts in a TX Text Control document. A text part can either be the document's main text, a text frame or a header or footer. A text frame is represented through a TextFrame object, a header or footer through a HeaderFooter object and the document's main text is represented through a MainText object. A TextPartCollection object contains all these objects in a geometric order. The first object in the collection is the main text, followed by all text frames in geometric order. At the end of the collection all headers and footers are contained also geometrically ordered. All objects in a text part collection implement the IFormattedText interface. The collection can be obtained with the TextControl.TextParts, WPF.TextControl.TextParts or ServerTextControl.TextParts property. The collection provides an Activate method to set the current input position to a certain text part and the GetItem method to get the currently activated part. Additionally, a programmer can define smaller parts called subtextparts to perform operations on smaller pieces of text. A SubTextPart can be defined through a start character index and a length or through a selection. All subtextparts are contained in a SubTextPartCollection which can be obtained with the TextControl.SubTextParts, TextFrame.SubTextParts or HeaderFooter.SubTextParts property. The collection can be used to add or to remove a subtextpart. A SubTextPart can be programmatically identified through a name or an identifier and it can be highlighted on the screen either permanently or only when it contains the current text input position. Each subtextpart can contain further nested subtextparts, but subtextparts cannot overlap. Its contents can be saved in a byte array or a string with all formats which TX Text Control supports. The IFormattedText interface contains properties and methods common to all text parts in a TX Text Control document. A single text part has lines, paragraphs, characters and a selection which can be used to assign character and paragraph formatting attributes to a piece of text. Additionally, a text part can contain tables, images, text fields, hypertext links and misspelled words. The following classes implement this interface: TextControl, ServerTextControl, WPF.TextControl, TextFrame, HeaderFooter and MainText. A common collection containing all images, text frames and charts of a document is the FrameCollection. It can be obtained with the TextControl.Frames, WPF.TextControl.Frames or ServerTextControl.Frames property. It can be used to alter common attributes or to get the currently selected item. The objects in this collection are of the type Image, TextFrame, ChartFrame, DrawingFrame or BarcodeFrame.

Classes

Class | Description
TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection | An instance of the DataColumnInfoCollection class contains all data columns of a data table in a data source represented through objects of the type DataColumnInfo.
TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection | An instance of the DataRelationInfoCollection class contains all data relations in a data source represented through objects of the type DataRelationInfo.
TXTextControl.DocumentServer.DataSources.DataTableInfoCollection | An instance of the DataTableInfoCollection class contains all data tables in a data source represented through objects of the type DataTableInfo.
TXTextControl.FrameCollection | An instance of the FrameCollection class contains all images, text frames and charts in a document.
TXTextControl.FrameEventArgs | The FrameEventArgs class provides data for all events that occur with frames.
TXTextControl.IFormattedText | The IFormattedText interface contains properties and methods common to all text parts in a TX Text Control document.
TXTextControl.MainText | The MainText class represents the main text of a TX Text Control document.
TXTextControl.SubTextPart | A SubTextPart object represents a user-defined part of a TX Text Control document.
TXTextControl.SubTextPartCollection | Contains all subtextparts in the main text or another main part of a document.
TXTextControl.SubTextPartEventArgs | The SubTextPartEventArgs class provides data for the TextControl.SubTextPartClicked, TextControl.SubTextPartDoubleClicked, TextControl.SubTextPartEntered and TextControl.SubTextPartLeft events.
TXTextControl.TextPartCollection | An instance of the TextPartCollection class contains all text parts in a TX Text Control document.

Properties

Property | Description
TXTextControl.ServerTextControl.Frames | Gets a collection of all images, textframes, charts and barcodes in a document.
TXTextControl.ServerTextControl.SubTextParts | Gets a collection of all subtextparts contained in the document.
TXTextControl.ServerTextControl.TextParts | Gets a collection of all text parts the current document contains.
TXTextControl.TextControl.Frames | Gets a collection of all images, textframes, charts, barcodes and drawings contained in the text part with the input focus.
TXTextControl.TextControl.SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.
TXTextControl.TextControl.TextParts | Gets a collection of all main text parts the current document contains.
TXTextControl.WPF.TextControl.Frames | Gets a collection of all images, textframes, barcodes and drawings contained in the text part with the input focus.
TXTextControl.WPF.TextControl.SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.
TXTextControl.WPF.TextControl.TextParts | Gets a collection of all main text parts the current document contains.

Methods

Method | Description
TXTextControl.TextControl.OnFrameClicked | Raises the FrameClicked event.
TXTextControl.TextControl.OnFrameDeselected | Raises the FrameDeselected event.
TXTextControl.TextControl.OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
TXTextControl.TextControl.OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
TXTextControl.TextControl.OnFrameMoved | Raises the FrameMoved event.
TXTextControl.TextControl.OnFrameRightClicked | Raises the FrameRightClicked event.
TXTextControl.TextControl.OnFrameSelected | Raises the FrameSelected event.
TXTextControl.TextControl.OnFrameSized | Raises the FrameSized event.
TXTextControl.TextControl.OnSubTextPartClicked | Raises the SubTextPartClicked event.
TXTextControl.TextControl.OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
TXTextControl.TextControl.OnSubTextPartEntered | Raises the SubTextPartEntered event.
TXTextControl.TextControl.OnSubTextPartLeft | Raises the SubTextPartLeft event.
TXTextControl.TextControl.OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.
TXTextControl.WPF.TextControl.OnFrameClicked | Raises the FrameClicked event.
TXTextControl.WPF.TextControl.OnFrameDeselected | Raises the FrameDeselected event.
TXTextControl.WPF.TextControl.OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
TXTextControl.WPF.TextControl.OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
TXTextControl.WPF.TextControl.OnFrameMoved | Raises the FrameMoved event.
TXTextControl.WPF.TextControl.OnFrameRightClicked | Raises the FrameRightClicked event.
TXTextControl.WPF.TextControl.OnFrameSelected | Raises the FrameSelected event.
TXTextControl.WPF.TextControl.OnFrameSized | Raises the FrameSized event.
TXTextControl.WPF.TextControl.OnSubTextPartClicked | Raises the SubTextPartClicked event.
TXTextControl.WPF.TextControl.OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
TXTextControl.WPF.TextControl.OnSubTextPartEntered | Raises the SubTextPartEntered event.
TXTextControl.WPF.TextControl.OnSubTextPartLeft | Raises the SubTextPartLeft event.
TXTextControl.WPF.TextControl.OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.

Events

Event | Description
TXTextControl.TextControl.FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
TXTextControl.TextControl.FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
TXTextControl.TextControl.FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
TXTextControl.TextControl.FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
TXTextControl.TextControl.FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
TXTextControl.TextControl.FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
TXTextControl.TextControl.FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
TXTextControl.TextControl.FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
TXTextControl.TextControl.SubTextPartClicked | Occurs when a subtextpart has been clicked on.
TXTextControl.TextControl.SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
TXTextControl.TextControl.SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
TXTextControl.TextControl.SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TXTextControl.WPF.TextControl.FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
TXTextControl.WPF.TextControl.FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
TXTextControl.WPF.TextControl.FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
TXTextControl.WPF.TextControl.FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
TXTextControl.WPF.TextControl.FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
TXTextControl.WPF.TextControl.FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
TXTextControl.WPF.TextControl.FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
TXTextControl.WPF.TextControl.FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
TXTextControl.WPF.TextControl.SubTextPartClicked | Occurs when a subtextpart has been clicked on.
TXTextControl.WPF.TextControl.SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
TXTextControl.WPF.TextControl.SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
TXTextControl.WPF.TextControl.SubTextPartLeft | Occurs when the current input position has left a subtextpart.


Stylesheet Programming

Classes

Class | Description
TXTextControl.FormattingStyle | The FormattingStyle class is the base class for the InlineStyle and ParagraphStyle classes.
TXTextControl.FormattingStyleCollection | The FormattingStyleCollection class is the base class of the ParagraphStyleCollection and InlineStyleCollection classes.
TXTextControl.InlineStyle | The InlineStyle class defines a formatting style that can be used to format single words in a line of text.
TXTextControl.InlineStyleCollection | An instance of the InlineStyleCollection class contains all inline formatting styles in the current document represented through objects of the type InlineStyle.
TXTextControl.ParagraphStyle | The ParagraphStyle class defines a formatting style for paragraphs.
TXTextControl.ParagraphStyleCollection | An instance of the ParagraphStyleCollection class contains all paragraph formatting styles in the current document represented through objects of the type ParagraphStyle.

Properties

Property | Description
TXTextControl.ServerTextControl.InlineStyles | Gets a collection of all inline styles the current document contains.
TXTextControl.ServerTextControl.ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
TXTextControl.TextControl.InlineStyles | Gets a collection of all inline styles the current document contains.
TXTextControl.TextControl.ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
TXTextControl.WPF.TextControl.InlineStyles | Gets a collection of all inline styles the current document contains.
TXTextControl.WPF.TextControl.ParagraphStyles | Gets a collection of all paragraph styles the current document contains.


Windows Forms Ribbons

The TXTextControl class library offers classes to build Windows Forms applications with a ribbon instead of a menu and toolbars. The main window must inherit from the RibbonForm class which can draw a Ribbon Quick Access Toolbar and contextual tabs in its border. An instance of the Ribbon, docked at the top of the main window, hosts an Application Menu as its first tab and organizes the features of an application into a series of tabs, presented through RibbonTab controls. These controls then host a variety of button and menu controls, organized in groups, that enable access to application commands. Predefined tabs, such as the RibbonFormattingTab or the RibbonInsertTab support all generic features of a TextControl, so that an application with rich text editing features can quickly be developed. A Ribbon can also contain groups of contextual tabs which dynamically displays controls that are only relevant in a particular context. A group can be added to the ContextualTabGroupCollection available through the ribbon's ContextualTabGroups property.

Classes

Class | Description
TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup | An object of the ContextualTabGroup class represents a group of ribbon tabs which are only shown in a certain context.
TXTextControl.Windows.Forms.Ribbon.ContextualTabGroupCollection | The ContextualTabGroupCollection class represents all groups of ribbon tabs which are only shown in a certain context.
TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup | The HorizontalRibbonGroup class represents a logical group of controls as they appear on a RibbonTab.
TXTextControl.Windows.Forms.Ribbon.Ribbon | The Ribbon class is a command bar that organizes the features of an application into a series of tabs at the top of the application window.
TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors | The Ribbon.Colors class gets, sets or resets the display colors of a Windows Forms Ribbon control.
TXTextControl.Windows.Forms.Ribbon.RibbonButton | The RibbonButton class is a button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu.
TXTextControl.Windows.Forms.Ribbon.RibbonComboBox | The RibbonComboBox class represents a combobox which is inherited from the System.Windows.Forms.ComboBox class.
TXTextControl.Windows.Forms.Ribbon.RibbonForm | The RibbonForm class represents a Windows Forms form that can draw a Ribbon Quick Access Toolbar and contextual tabs in its border.
TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab | The RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard.
TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab | The RibbonFrameLayoutTab class represents a Windows Forms ribbon tab for editing objects of type Image, TextFrame, DrawingFrame, BarcodeFrame and ChartFrame.
TXTextControl.Windows.Forms.Ribbon.RibbonGroup | The RibbonGroup class represents a logical group of controls as they appear on a RibbonTab and is the base class of the HorizontalRibbonGroup class.
TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher | The DialogBoxLauncher class represents the dialog box launcher item of a RibbonGroup.
TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection | An instance of the RibbonGroupCollection class contains objects of type RibbonGroup and can be obtained with the RibbonTab.RibbonGroups property.
TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab | The RibbonInsertTab class represents a Windows Forms ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols.
TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection | An instance of the RibbonItemCollection class contains controls of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator and can be obtained with the RibbonGroup.RibbonItems, Ribbon.ApplicationMenuHelpPaneItems, Ribbon.ApplicationMenuItems, RibbonMenuButton.DropDownItems or RibbonListView.DropDownItems property.
TXTextControl.Windows.Forms.Ribbon.RibbonLabel | The RibbonLabel class represents a label which is inherited from the System.Windows.Forms.Control class.
TXTextControl.Windows.Forms.Ribbon.RibbonListView | The RibbonListView class is a list view control, which displays a collection of items that can be displayed using one of three different views.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem | The RibbonListViewItem class represents an item in a RibbonListView control.
TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection | An instance of the RibbonListViewItemCollection class contains controls of type RibbonListViewItem and can be obtained with the RibbonListView.RibbonListViewItems property.
TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton | The RibbonMenuButton class is a button control that displays a drop-down menu when clicked.
TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab | The RibbonPageLayoutTab class represents a Windows Forms ribbon tab for editing the page setup and layout.
TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab | The RibbonProofingTab class represents a Windows Forms ribbon tab for setting proofing options such as spelling, hyphenation or language settings.
TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab | The RibbonReportingTab class represents a Windows Forms ribbon tab to integrate mail merge and reporting functionality.
TXTextControl.Windows.Forms.Ribbon.RibbonSeperator | The RibbonSeperator class represents a control that provides a seperator between elements in a HorizontalRibbonGroup, an ApplicationMenu or a drop-down menu of a RibbonMenuButton.
TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton | The RibbonSplitButton class is a control that has a primary button that responds to a Click event and a secondary button that displays a drop-down menu when clicked.
TXTextControl.Windows.Forms.Ribbon.RibbonTab | The RibbonTab class represents a tab in a Ribbon.
TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab | The RibbonTableLayoutTab class represents a Windows Forms ribbon tab for editing tables.
TXTextControl.Windows.Forms.Ribbon.RibbonTextBox | The RibbonTextBox class is a control that can be used to display or edit unformatted text.
TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton | The RibbonToggleButton class is a checkable button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu.
TXTextControl.Windows.Forms.Ribbon.RibbonToolTip | The RibbonToolTip class represents a small rectangular pop-up window that displays the title and/or a brief description of a ribbon item's purpose when the user rests the pointer on the control.
TXTextControl.Windows.Forms.Ribbon.RibbonViewTab | The RibbonViewTab class represents a Windows Forms ribbon tab for customizing the view settings.

Properties

Property | Description
TXTextControl.TextControl.Ribbon | Specifies the ribbon control to be used with a TextControl.


Web Editor

The Web.TextControl (HTML5 Web Editor) is an ASP.NET server control that allows the integration of a fully-featured WYSIWYG word processor in ASP.NET Web applications. This control works together with the TX Text Control Web Server running as a Windows Service hosted on a Web server. The TX Text Control Web Server engine is used to synchronize the document with the server in order to provide consistent WYSIWYG text rendering. The technical concept is explained in HTML5 Web Editor - Technical Considerations. All programming elements belonging to the HTML5 Web Editor can be found in the TXTextControl.Web namespace.

Classes

Class | Description
Javascript: TXTextControl | The TXTextControl JavaScript object provides a public API to manipulate the web editor via JavaScript functions in the browser.
Javascript: TXTextControl.CultureSettings | An object of this type is returned by the function getCultures.
Javascript: TXTextControl.DocumentLoadedEventArgs | The event argument object for the documentLoaded event.
Javascript: TXTextControl.HyperlinkClickedEventArgs | The event argument object for the hyperlinkClicked event.
Javascript: TXTextControl.InputPositionChangedEventArgs | The event argument object for the inputPositionChanged event.
Javascript: TXTextControl.Ribbon | The type of the ribbon property of the TXTextControl object.
Javascript: TXTextControl.RibbonTabIndexChangedEventArgs | The event argument object for the ribbonTabIndexChanged event.
Javascript: TXTextControl.SaveDocumentResult | The callback function argument for the saveDocument and the saveSelection functions.
Javascript: TXTextControl.Selection | Describes and handles the position and length of a text selection.
Javascript: TXTextControl.SelectionBounds | Is used with the setter of the selection property of the TextPart object.
Javascript: TXTextControl.SubTextPartEventArgs | The event argument for the SubTextPart related events.
Javascript: TXTextControl.TextDroppedEventArgs | The event argument object for the textDropped event.
Javascript: TXTextControl.TextFieldEventArgs | The event argument object for text field related events.
Javascript: TXTextControl.TextPart | The callback function argument for the getTextParts function.
Javascript: TXTextControl.WebSocketClosedEventArgs | The event argument object for the webSocketClosed event.
TXTextControl.Web.HeaderFooter | An instance of the Web.HeaderFooter class represents a header or footer in a Text Control document.
TXTextControl.Web.IFormattedText | The Web.IFormattedText interface contains properties common to all text parts in a TX Text Control document.
TXTextControl.Web.MainText | The Web.MainText class represents the main text of a TX Text Control document.
TXTextControl.Web.Selection | The Web.Selection class describes and handles the position and length of a text selection.
TXTextControl.Web.TextControl | The TextControl class implements a control with high-level text editing features.
TXTextControl.Web.TextFrame | An instance of the Web.TextFrame class represents a text frame in a Text Control document.
TXTextControl.Web.TextPart | The Web.TextPart class implements the Web.IFormattedText interface as well as public properties and internal functionality common to all text parts in a TX Text Control document.
TXTextControl.Web.TextPartCollection | An instance of the Web.TextPartCollection class contains all text parts in a TX Text Control document.


Mail Merge

Classes

Class | Description
TXTextControl.DocumentServer.DataSources.IDataRowAdapter | The IDataRowAdapter interface contains properties and methods implemented by data row instances used in the BlockMerging event.
TXTextControl.DocumentServer.DataSources.IDataTableAdapter | The IDataTableAdapter interface contains properties and methods implemented by data table instances used in the BlockMerging event.
TXTextControl.DocumentServer.Json.InvalidCodePointException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an invalid hexadecimal unicode code point.
TXTextControl.DocumentServer.Json.InvalidNumberFormatException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing a number with an invalid number format.
TXTextControl.DocumentServer.Json.ParserException | Base class of all JSON parser related exceptions which can be thrown when calling method MailMerge.MergeJsonData with an incorrect JSON string.
TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException | Is thrown when calling method MailMerge.MergeJsonData with an incomplete JSON string.
TXTextControl.DocumentServer.Json.UnexpectedTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unexpected character.
TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException | Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unknown character sequence at a position where one of the strings "true", "false" or "null" are expected.
TXTextControl.DocumentServer.Json.UnknownParseErrorException | Is thrown when calling method MailMerge.MergeJsonData and the internal JSON parser encounters an unknown error.
TXTextControl.DocumentServer.MailMerge | The MailMerge class is a .NET component that can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET web applications, web services or Windows services.
TXTextControl.DocumentServer.MailMerge.BarcodeMergedEventArgs | The BarcodeMergedEventArgs class provides data for the BarcodeMerged event.
TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs | The BlockMergingEventArgs class provides data for the BlockMerging event.
TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs | The BlockRowMergedEventArgs class provides data for the BlockRowMerged event.
TXTextControl.DocumentServer.MailMerge.ChartMergedEventArgs | The ChartMergedEventArgs class provides data for the ChartMerged event.
TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs | The DataRowMergedEventArgs class provides data for the DataRowMerged event.
TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs | The FieldMergedEventArgs class provides data for the FieldMerged event.
TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs | The ImageFieldMergedEventArgs class provides data for the ImageFieldMerged event.
TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs | The ImageMergedEventArgs class provides data for the ImageMerged event.
TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs | The IncludeTextMergingEventArgs class provides data for the IncludeTextMerging event.
TXTextControl.DocumentServer.MergeCanceledException | A MergeCanceledException is thrown through the Merge method when the current merge process was canceled through the DataRowMergedEventArgs.Cancel property.


Document Viewer

Classes

Class | Description
TXTextControl.DocumentServer.DocumentController | The DocumentController class is a .NET component that can be used to perform the necessary document handling on the server, when using a control such as the DocumentServer.Web.DocumentViewer.
TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection | An instance of the FieldAdapterCollection class contains adapters for all application fields of the page it belongs to.
TXTextControl.DocumentServer.Fields.CheckBoxContentControl | The CheckBoxContentControl implements the MS Word specific check box content control field.
TXTextControl.DocumentServer.Fields.ComboBoxContentControl | The ComboBoxContentControl implements the MS Word specific combo box content control field.
TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter | The abstract ContentControlFieldAdapter class is the base class of all Microsoft Word content control field adapter classes.
TXTextControl.DocumentServer.Fields.DateContentControl | The DateContentControl implements the MS Word specific date content control field.
TXTextControl.DocumentServer.Fields.DateField | The DateField implements the MS Word specific DATEFIELD field.
TXTextControl.DocumentServer.Fields.DropDownListContentControl | The DropDownListContentControl implements the MS Word specific drop down list content control field.
TXTextControl.DocumentServer.Fields.FieldAdapter | The abstract FieldAdapter class is the base class of all special DocumentServer field adapters.
TXTextControl.DocumentServer.Fields.FormCheckBox | The FormText implements the MS Word specific FORMCHECKBOX field.
TXTextControl.DocumentServer.Fields.FormDropDown | The FormDropDown class implements the MS Word specific FORMDROPDOWN field.
TXTextControl.DocumentServer.Fields.FormFieldAdapter | The abstract FormFieldAdapter class is the base class of all special DocumentServer form field adapters.
TXTextControl.DocumentServer.Fields.FormText | The FormText class implements the MS Word specific FORMTEXT field.
TXTextControl.DocumentServer.Fields.IfField | The IfField class implements the MS Word specific IF field.
TXTextControl.DocumentServer.Fields.IncludeText | The IncludeText class implements the MS Word specific INCLUDETEXT field.
TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter | The abstract MailMergeFieldAdapter class is the base class of all special DocumentServer mail merge field adapters.
TXTextControl.DocumentServer.Fields.MergeField | The MergeField class implements the MS Word specific MERGEFIELD field.
TXTextControl.DocumentServer.Fields.NextField | The NextField class implements the MS Word specific NEXT field.
TXTextControl.DocumentServer.Fields.NextIfField | The NextIfField class implements the MS Word specific NEXTIF field.
TXTextControl.DocumentServer.Fields.PlainTextContentControl | The PlainTextContentControl implements the MS Word specific plain text content control field.
TXTextControl.DocumentServer.Fields.RichTextContentControl | The RichTextContentControl implements the MS Word specific plain text content control field.
TXTextControl.DocumentServer.Web.DocumentViewer | The DocumentViewer class is a .NET component that can be used to display documents in the web browser in ASP.NET projects.
TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs | The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveDocument event.
TXTextControl.DocumentServer.Web.DocumentViewer.SaveFormDataEventArgs | The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveFormData event.


Reporting

Classes

Class | Description
TXTextControl.DocumentServer.DataSources.DataColumnInfo | The DataColumnInfo class provides basic information about a table column in a data source.
TXTextControl.DocumentServer.DataSources.DataRelationInfo | The DataRelationInfo class provides all necessary information about parent-child-relations between data tables.
TXTextControl.DocumentServer.DataSources.DataSourceManager | The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class.
TXTextControl.DocumentServer.DataSources.DataTableInfo | The DataTableInfo class provides basic information about a data table in a data source.
TXTextControl.DocumentServer.DataSources.MergeBlockInfo | The MergeBlockInfo class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.DataSources.MergeBlockSettings | The MergeBlockSettings class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.
TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog | The DatabaseConnectionDialog class allows the user to build connection strings and to connect to specific data sources.
TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog | The DataSourceExtractionDialog class allows the user to save an excerpt from the currently loaded data source.
TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.
TXTextControl.DocumentServer.WPF.EditDataRelationsDialog | The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source.
TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog | The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document.
TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog | The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table.


WPF Programming

Classes

Class | Description
TXTextControl.WPF.BooleanConverter | The BooleanConverter class provides a way to convert a value to a boolean value.
TXTextControl.WPF.ColorConverter | The WPF.ColorConverter class provides a way to convert a System.Drawing.Color value to System.Windows.Media.Color value.
TXTextControl.WPF.LogarithmicConverter | The class WPF.LogarithmicConverter Converts a numeric value from a linear scale to a logarithmic scale.
TXTextControl.WPF.MeasureConverter | The MeasureConverter class provides a way to convert a measure in twips (twentieth of a point) to a value in another measuring unit.


XML Programming

Classes

Class | Description
TXTextControl.XmlElement | An instance of this class represents an element in a XML document.
TXTextControl.XmlElementCollection | An instance of this class contains all elements of an XML document that have the same element name.
TXTextControl.XmlErrorEventArgs | The XmlErrorEventArgs class provides data for the TextControl.XmlNotWellFormed and TextControl.XmlInvalid events.

Properties

Property | Description
TXTextControl.TextControl.XmlEditMode | Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.
TXTextControl.WPF.TextControl.XmlEditMode | Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.

Methods

Method | Description
TXTextControl.ServerTextControl.GetXmlElements | Returns a collection of XML elements.
TXTextControl.ServerTextControl.OnXmlInvalid | Raises the XmlInvalid event.
TXTextControl.ServerTextControl.OnXmlNotWellFormed | Raises the XmlNotWellFormed event.
TXTextControl.TextControl.GetXmlElements | Returns a collection of XML elements.
TXTextControl.TextControl.OnXmlInvalid | Raises the XmlInvalid event.
TXTextControl.TextControl.OnXmlNotWellFormed | Raises the XmlNotWellFormed event.
TXTextControl.WPF.TextControl.GetXmlElements | Returns a collection of XML elements.
TXTextControl.WPF.TextControl.OnXmlInvalid | Raises the XmlInvalid event.
TXTextControl.WPF.TextControl.OnXmlNotWellFormed | Raises the XmlNotWellFormed event.

Events

Event | Description
TXTextControl.ServerTextControl.XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
TXTextControl.ServerTextControl.XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.
TXTextControl.TextControl.XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
TXTextControl.TextControl.XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.
TXTextControl.WPF.TextControl.XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
TXTextControl.WPF.TextControl.XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.


Visualize the ServerTextControl

The ServerVisualization.TextViewGenerator class, a special kind of ServerTextControl, can be used to generate an image of the text which is contained in a ServerTextControl. It provides a ServerVisualization.View object, which provides the image and which defines the part of the document for which the image is generated. Furthermore, it offers a ServerVisualization.UserInput object which can be used to simulate keyboard and mouse input. If this user-input affects the image defined through the View object, the image is automatically updated and a View.Changed event occurs. The ServerVisualization.RulerBarViewGenerator and ServerVisualization.StatusBarViewGenerator classes work in the same way to generate images of a status bar and of horizontal and vertical ruler bars. Images of all built-in dialog boxes can be generated through the ServerVisualization.DialogViewGenerator class. Objects of this class can be obtained through the TextViewGenerator.GetDialogBox property. All of these classes can be found in the TXTextControl.ServerVisualization namespace.

Classes

Class | Description
TXTextControl.ServerVisualization.CaretStateEventArgs | The CaretStateEventArgs class provides data about the state of the caret, such as position, size and visibility.
TXTextControl.ServerVisualization.DialogViewGenerator | An instance of the DialogViewGenerator class can be used to visualize a built-in dialog box through an image.
TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs | The DocumentSizeChangedEventArgs class informs about a changed document size.
TXTextControl.ServerVisualization.DrawShapeEventArgs | The DrawShapeEventArgs class contains information to draw additional parts necessary when the user interacts with the document.
TXTextControl.ServerVisualization.MenuItem | The MenuItem class provides all data necessary to visualize a menu item, such as the menu's text and the menu's image.
TXTextControl.ServerVisualization.RulerBarViewGenerator | An instance of the RulerBarViewGenerator class can be used to visualize a ruler bar through an image.
TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors | The ServerVisualization.RulerBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.RulerBarViewGenerator component.
TXTextControl.ServerVisualization.ShowDialogBoxEventArgs | The ShowDialogBoxEventArgs class provides a DialogViewGenerator object which can be used to show a further dialog box from a parent dialog box.
TXTextControl.ServerVisualization.ShowErrorMessageEventArgs | The ShowErrorMessageEventArgs class provides a string which should be shown as an error message for the end-user.
TXTextControl.ServerVisualization.StatusBarViewGenerator | An instance of the StatusBarViewGenerator class can be used to visualize a status bar through an image.
TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors | The StatusBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.StatusBarViewGenerator component.
TXTextControl.ServerVisualization.TextContextMenuEventArgs | The TextContextMenuEventArgs class provides data for the ServerVisualization.TextViewGenerator.TextContextMenuOpening event.
TXTextControl.ServerVisualization.TextViewGenerator | The TextViewGenerator class is a special ServerTextControl, which can be used to visualize the control's text contents through a generated image.
TXTextControl.ServerVisualization.TextViewGenerator.Colors | The TextViewGenerator.Colors class gets, sets or resets the display colors of a TextViewGenerator component.
TXTextControl.ServerVisualization.UserInput | An instance of the UserInput class can be used to inform a view generator about user input.
TXTextControl.ServerVisualization.View | An instance of the View class represents a part of a document for which an image can be generated.
TXTextControl.ServerVisualization.ViewChangedEventArgs | The ViewChangedEventArgs class provides data for the View.Changed event.


Exceptions

The TX Text Control class library explizitly throws an ArgumentException, an ArgumentNullException or an ArgumentOutOfRangeException, when the parameter of a called method or the value of a set property has a wrong value. Furthermore, an InvalidOperationException is thrown when a method call is invalid for the object's current state. In Addition, the class library defines and throws the TextEditorException when an error occurs during text editing and a FilterException, if an error occurs when a text filter is used to convert a document to or from another format. The LicenseLevelException is thrown, when a feature is not contained in the currently licensed product level.

Classes

Class | Description
TXTextControl.FilterException | The FilterException class informs about errors which can occur when a text filter is used to convert a document to or from another format.
TXTextControl.LicenseLevelException | A LicenseLevelException is thrown when a feature is not contained in the currently licensed product level.
TXTextControl.TextEditorException | The TextEditorException class informs about errors which can occur during editing text.


Porting ActiveX to .NET

The following gives an overview how to port the properties, methods and events of the TX Text Control ActiveX controls to TX Text Control .NET.

Porting TX Text Control ActiveX to a Windows Forms Application

Porting the TX Text Control ActiveX Tool Bars to a Windows Forms Application

Porting TX Text Control ActiveX Server to an ASP.NET Application


Porting TX Text Control ActiveX to a Windows Forms Application

The following lists all properties, methods and events of the ActiveX text component and the corresponding implementations in TX Text Control .NET, grouped by categories.

Character Formatting

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BaseLine Property | TextControl.Baseline Property, Selection.Baseline Property
CharFormatChange Event | TextControl.CharFormatChanged Event
FontBold Property | TextControl.Font Property, Selection.Bold Property
FontDialog Method | TextControl.FontDialog Method
FontItalic Property | TextControl.Font Property, Selection.Italic Property
FontName Property | TextControl.Font Property, Selection.FontName Property
FontSize Property | TextControl.Font Property, Selection.FontSize Property
FontStrikethru Property | TextControl.Font Property, Selection.StrikeOut Property
FontUnderline Property | TextControl.Font Property, Selection.Underline Property
FontUnderlineStyle Property | TextControl.FontUnderlineStyle Property, Selection.Underline Property
ForeColor Property | TextControl.ForeColor Property, Selection.ForeColor Property
TextBkColor Property | TextControl.TextBackColor Property, Selection.TextBackColor Property

Paragraph Formatting

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Alignment Property | ParagraphFormat.Alignment Property
FrameDistance Property | ParagraphFormat.FrameDistance Property
FrameLineWidth Property | ParagraphFormat.FrameLineWidth Property
FrameStyle Property | ParagraphFormat.FrameStyle Property
IndentB Property | ParagraphFormat.BottomDistance Property
IndentFL Property | ParagraphFormat.LeftIndent Property
IndentL Property | ParagraphFormat.HangingIndent Property
IndentR Property | ParagraphFormat.RightIndent Property
IndentT Property | ParagraphFormat.TopDistance Property
LineSpacing Property | ParagraphFormat.LineSpacing Property
LineSpacingT Property | ParagraphFormat.AbsoluteLineSpacing Property
ParagraphDialog Method | TextControl.ParagraphFormatDialog Method
ParagraphFormatChange Event | TextControl.ParagraphFormatChanged Event
TabCurrent Property | No longer necessary, because positions and types of tabs are implemented with arrays.
TabDialog Method | TextControl.TabDialog Method
TabPos Property | ParagraphFormat.TabPositions Property
TabType Property | ParagraphFormat.TabTypes Property
KeepLinesTogether Property | ParagraphFormat.KeepLinesTogether Property
KeepWithNext Property | ParagraphFormat.KeepWithNext Property
PageBreakBefore Property | ParagraphFormat.PageBreakBefore Property
WidowOrphanLines Property | ParagraphFormat.WidowOrphanLines Property

Bullets and Numbered Lists

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BulletAttribute Property | ListFormat Class Properties, TextControl.ListFormat Property, Selection.ListFormat Property.
ListAttrDialog Method | TextControl.FormattingStylesDialog Method
ListType Property | ListFormat.Type Property
NumberingAttribute Property | ListFormat Class Properties, TextControl.ListFormat Property, Selection.ListFormat Property.

Headers and Footers

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
HeaderFooter Property | TextControl.HeadersAndFooters Property, HeaderFooterCollection Class
HeaderFooterActivate Method | HeaderFooter.Activate Method, HeaderFooter.Deactivate Method
HeaderFooterActivated Event | TextControl.HeaderFooterActivated Event
HeaderFooterDeactivated Event | TextControl.HeaderFooterDeactivated Event
HeaderFooterPosition Property | HeaderFooter.Distance Property
HeaderFooterSelect Method | No longer necessary, because the HeaderFooter class implements its own properties.
HeaderFooterStyle Property | TextControl.HeaderFooterActivationStyle Property, TextControl.HeaderFooterFrameStyle Property.

Text Frames

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
TextFrameActivated Event | TextControl.TextFrameActivated Event
TextFrameBackColor Property | TextFrame.BackColor Property
TextFrameBorderWidth Property | TextFrame.BorderWidth Property
TextFrameDeactivated Event | TextControl.TextFrameDeactivated Event
TextFrameInsert Method | TextFrameCollection.Add Method
TextFrameInsertAsChar Method | TextFrameCollection.Add Method
TextFrameInsertFixed Method | TextFrameCollection.Add Method
TextFrameInternalMargin Property | TextFrame.InternalMargins Property
TextFrameMarkerLines Property | TextControl.TextFrameMarkerLines Property
TextFrameSelect Method | TextFrameCollection Method
TextFrameActivated Event | TextControl.TextFrameActivated Event
TextFrameBackColor Property | TextFrame.BackColor Property
TextFrameBorderWidth Property | TextFrame.BorderWidth Property
TextFrameDeactivated Event | TextControl.TextFrameDeactivated Event
TextFrameInsert Method | TextFrameCollection.Add Method
TextFrameInsertAsChar Method | TextFrameCollection.Add Method
TextFrameInsertFixed Method | TextFrameCollection.Add Method
TextFrameInternalMargin Property | TextFrame.InternalMargins Property
TextFrameMarkerLines Property | TextControl.TextFrameMarkerLines Property
TextFrameSelect Method | TextFrameCollection Method

Page and Document Settings

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Change Event | TextControl.Changed Event
CurrentPages Property | TextControl.Pages Property
Device Property | Currently not implemented. Will be available in a future version.
HScroll Event | TextControl.HScroll Event
PageFormatChange Event | TextControl.PageFormatChanged Event
PageHeight Property | TextControl.PageSize Property
PageMarginB Property | TextControl.PageMargins Property, PageMargins Class
PageMarginL Property | TextControl.PageMargins Property, PageMargins Class
PageMarginR Property | TextControl.PageMargins Property, PageMargins Class
PageMarginT Property | TextControl.PageMargins Property, PageMargins Class
PageWidth Property | TextControl.PageSize Property
ScrollBars Property | TextControl.ScrollBars Property
ScrollPosX Property | TextControl.ScrollLocation Property
ScrollPosY Property | TextControl.ScrollLocation Property
ViewMode Property | TextControl.ViewMode Property
VScroll Event | TextControl.VScroll Event
PageChanged Event | TextControl.PageChanged Event
PageOrientation Property | SectionFormat.Landscape Property

Stylesheets

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Style Object | FormattingStyle Class, InlineStyle Class, ParagraphStyle Class
StyleChanged Event | TextControl.InputFormattingStyleChanged Event
StyleCurrent Property | Selection.FormattingStyle Property
StyleDialog Method | TextControl.FormattingStylesDialog Method
StyleListChanged Event | TextControl.FormattingStyleListChanged Event
Styles Collection | InlineStyleCollection Class, ParagraphStyleCollection Class
Styles Property | TextControl.InlineStyles Property, TextControl.ParagraphStyles Property.
Style.Alignment Property | ParagraphFormat.Alignment Property
Style.Apply Method | FormattingStyle.Apply Method
Style.Baseline Property | FormattingStyle.Baseline Property
Style.BaselineType Property | FormattingStyle.Baseline Property
Style.BulletAttribute Property | ListFormat.BulletCharacter, ListFormat.BulletSize Property
Style.FontBold Property | FormattingStyle.Bold Property
Style.FontItalic Property | FormattingStyle.Italic Property
Style.FontName Property | FormattingStyle.FontName Property
Style.FontSize Property | FormattingStyle.FontSize Property
Style.FontStrikethru Property | FormattingStyle.Strikeout Property
Style.FontUnderline Property | FormattingStyle.Underline Property
Style.ForeColor Property | FormattingStyle.ForeColor Property
Style.FrameDistance Property | ParagraphFormat.FrameDistance Property
Style.FrameLineWidth Property | ParagraphFormat.FrameLineWidth Property
Style.FrameStyle Property | ParagraphFormat.FrameStyle Property
Style.IndentB Property | ParagraphFormat.BottomDistance Property
Style.IndentFL Property | ParagraphFormat.HangingIndent Property
Style.IndentL Property | ParagraphFormat.LeftIndent Property
Style.IndentR Property | ParagraphFormat.RightIndent Property
Style.IndentT Property | ParagraphFormat.TopDistance Property
Style.KeepLinesTogether Property | ParagraphFormat.KeepLinesTogether Property
Style.KeepWithNext Property | ParagraphFormat.KeepWithNext Property
Style.LineSpacing Property | ParagraphFormat.LineSpacing Property
Style.LineSpacingT Property | ParagraphFormat.LineSpacing Property
Style.ListType Property | ListFormat.Type Property
Style.NextParaStyle Property | ParagraphStyle.FollowingStyle Property
Style.NumberingAttribute Property | ListFormat.NumberFormat Property
Style.PageBreakBefore Property | ParagraphFormat.PageBreakBefore Property
Style.StyleName Property | FormattingStyle.Name Property
Style.StyleType Property | The FormattingStyle class is the base class for the InlineStyle and ParagraphStyle classes.
Style.TabPos Property | ParagraphFormat.TabPositions Property
Style.TabType Property | ParagraphFormat.TabTypes Property
Style.TextBkColor Property | FormattingStyle.TextBackColor Property
Style.WidowOrphanLines Property | ParagraphFormat.WidowOrphanLines Property
Styles Collection Object | InlineStyle, ParagraphStyle Object
Styles.Count Property | FormattingStyleCollection.Count Property
Styles.Item Method | ParagraphStyleCollection.GetItem Method

Tables

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
TableAtInputPos Property | TableCollection.GetItem Method
TableAttrDialog Method | TextControl.TableFormatDialog Method
TableCanChangeAttr Property | TableCollection.CanAdd Property
TableCanDeleteColumn Property | TableColumnCollection.CanRemove Property
TableCanDeleteLines Property | TableRowCollection.CanRemove Property
TableCanInsert Property | TableCollection.CanAdd Property
TableCanInsertColumn Property | TableColumnCollection.CanAdd Property
TableCanInsertLines Property | TableRowCollection.CanAdd Property
TableCellAttribute Property | TableCellFormat Class Properties, TableCell.CellFormat Property, TableRow.CellFormat Property, TableColumn.CellFormat Property, TableCell.Width Property, TableCell.Position Property
TableCellLength Property | TableCell.Length Property
TableCellStart Property | TableCell.Start Property
TableCellText Property | TableCell.Text Property
TableColAtInputPos Property | TableColumnCollection.GetItem Method
TableColumns Property | TablePartCollection.Count Property
TableCreated Event | TextControl.TableCreated Event.
TableDeleteColumn Method | TableColumnCollection.Remove Method
TableDeleted Event | TextControl.TableDeleted Event.
TableDeleteLines Method | TableRowCollection.Remove Method
TableFormatChanged Event | TextControl.TableFormatChanged Event.
TableGridLines Property | TableCollection.GridLines Property
TableInsert Method | TableCollection.Add Method
TableInsertColumn Method | TableColumnCollection.Add Method
TableInsertLines Method | TableRowCollection.Add Method
TableNext Method | TableCollection Class (enumeration with for-each)
TableRowAtInputPos Property | TableRowCollection.GetItem Method
TableRows Property | TablePartCollection.Count Property
TableCanSplit Property | Table.CanSplit Property
TableGetOuter Method | Table.OuterTable Method
TableGetOuterMost Method | Table.OuterMostTable Method
TableNestedLevel Property | Table.NestedLevel Property
TableSplit Method | Table.Split Method

Zooming

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Zoomed Event | TextControl.Zoomed Event
ZoomFactor Property | TextControl.ZoomFactor Property

Loading, Saving and Database Support

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
DataTextFormat Property | Not supported in Text Control.NET.
Load Method | TextControl.Load Method, Selection.Load Method.
LoadFromMemory Method | TextControl.Load Method, Selection.Load Method.
LoadSaveAttribute Property | LoadSettings Class Properties, SaveSettings Class Properties.
Save Method | TextControl.Save Method, Selection.Save Method.
SaveToMemory Method | TextControl.Save Method, Selection.Save Method.
SaveToMemoryBuffer Method | TextControl.Save Method, Selection.Save Method.
Text Property | TextControl.Text Property, Selection.Text Property
TextExport Method (Obsolete) | TextControl.Save
TextImport Method (Obsolete) | TextControl.Load

Images and OLE Objects

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
ImageDisplayMode Property | Not supported in Text Control.NET.
ImageExportFilename Property | Image.ExportFileName Property
ImageExportFilters Property | ImageCollection.ExportFilters Property
ImageExportFormat Property | Image.ExportFilterIndex Property
ImageFilename Property | Image.FileName Property
ImageFilters Property | ImageCollection.ImportFilters Property
ImageSaveMode Property | Image.SaveMode Property
ObjectClicked Event | TextControl.ImageClicked Event
ObjectCreated Event | TextControl.ImageCreated Event
ObjectCurrent Property | No longer necessary, because the Image class implements the properties for setting the attributes of an image.
ObjectDblClicked Event | TextControl.ImageDoubleClicked Event
ObjectDelete Method | ImageCollection.Remove Method
ObjectDeleted Event | TextControl.ImageDeleted Event
ObjectDistance Property | Image.TextDistances Property
ObjectGetData Event | Not supported in Text Control.NET.
ObjectGethWnd Event | Not supported in Text Control.NET.
ObjectGetZoom Event | Not supported in Text Control.NET.
ObjectInsertAsChar Method | ImageCollection.Add Method
ObjectInsertFixed Method | ImageCollection.Add Method
ObjectItem Property | Not supported in Text Control.NET.
ObjectMoved Event | TextControl.ImageMoved Event
ObjectNext Method | ImageCollection Class (enumeration with for-each)
ObjectPrint Event | Not supported in Text Control.NET.
ObjectScaleX Property | Image.HorizontalScaling Property
ObjectScaleY Property | Image.VerticalScaling Property
ObjectScrollOut Event | Not supported in Text Control.NET.
ObjectSetData Event | Not supported in Text Control.NET.
ObjectSetZoom Event | Not supported in Text Control.NET.
ObjectSized Event | TextControl.ImageSized Event
ObjectSizeMode Property | Image.Moveable Property, Image.Sizeable Property
ObjectTextflow Property | Image.InsertionMode Property
ObjectGetFromName Method | FrameCollection.GetItem Method
ObjectGetFromUserId Method | FrameCollection.GetItem Method
ObjectGetSelected Method | FrameCollection.GetItem Method
ObjectHeight Property | FrameBase.Size Property
ObjectInsert Method | ImageCollection.Add, TextFrameCollection.Add Method
ObjectInsertionMode Property | FrameBase.InsertionMode Property
ObjectName Property | FrameBase.Name Property
ObjectPosX Property | FrameBase.Location Property
ObjectPosY Property | FrameBase.Location Property
ObjectRightClicked Event | TextControl.FrameRightClicked Event
ObjectUserId Property | FrameBase.ID Property
ObjectWidth Property | FrameBase.Size Property

Hypertext Links

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
FieldLinkClicked Event | TextControl.HypertextLinkClicked Event
FieldType Property | DocumentLink Class, DocumentTarget Class, HypertextLink Class, PageNumberField Class
FieldTypeData Property | DocumentLink.DocumentTarget Property, DocumentTarget.TargetName Property, HypertextLink.Target Property, PageNumberField.NumberFormat Property, PageNumberField.StartNumber Property

Clipboard Operations

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
CanCopy Property | TextControl.CanCopy Property
CanPaste Property | TextControl.CanPaste Property
Clip Method | TextControl.Copy Method, TextControl.Cut Method, TextControl.Paste Method

Undo

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
CanRedo Property | TextControl.CanRedo Property
CanUndo Property | TextControl.CanUndo Property
Redo Method | TextControl.Redo Method
Undo Method | TextControl.Undo Method
AllowUndo Property | TextControl.AllowUndo Property
EndUndoAction Method | TextControl.EndUndoAction Method
StartUndoAction Method | TextControl.BeginUndoAction Method

Printing

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
PrintColors Property | TextControl.Print Method, PrintDocument.DafaultPageSettings.Color Property
PrintDevice Property | TextControl.Print Method, PrintDocument.PrinterSettings.PrinterName
PrintDoc Method | TextControl.Print Method
PrintOffset Property | Not supported in Text Control.NET.
PrintPage Method | TextControl.Print Method.
PrintZoom Property | Not supported in Text Control.NET.

Search and Replace

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Find Method | TextControl.Find Method
FindReplace Method | TextControl.Find Method, TextControl.Replace Method

Columns

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
ColumnDistance Property | SectionFormat.ColumnDistances Property
ColumnLineColor Property | SectionFormat.ColumnLineColor Property
ColumnLineWidth Property | SectionFormat.ColumnLineWidth Property
Columns Property | SectionFormat.Columns Property
ColumnWidthsAndDistances Property | SectionFormat.ColumnDistances, SectionFormat.ColumnWidths Property

Sections

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
SectionAtInputPos Property | SectionCollection.GetItem Property
SectionBreakKind Property | SectionFormat.BreakKind Property
SectionChanged Event | TextControl.SectionChanged Event
SectionCount Property | SectionCollection.Count Property
SectionCurrent Property | Not required anymore. SectionCollection Property
SectionFormatDialog Method | TextControl.SectionFormatDialog Method
SectionInsert Method | SectionCollection.Add Method

Control Styles and Mode Settings

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BackColor Property | TextControl.BackColor Property
BackStyle Property | Set the TextControl.BackColor Property to Color.Transparent.
BorderStyle Property | TextControl.BorderStyle Property
ClipChildren Property | Not supported in Text Control.NET.
ClipSiblings Property | Not supported in Text Control.NET.
ControlChars Property | TextControl.ControlChars Property
EditMode Property | TextControl.EditMode Property
Enabled Property | TextControl.Enabled Property
HideSelection Property | TextControl.HideSelection Property
InsertionMode Property | TextControl.InsertionMode Property
LockWindowUpdate Property | No longer necessary, because attributes are grouped through classes and can be applied in one step.
WordWrapMode Property | Currently not implemented. Will be available in a future version.
AllowDrag Property | TextControl.AllowDrag Property
AllowDrop Property | TextControl.AllowDrop Property
DisplayColor Property | TextControl.DisplayColors Property
EnableAutomationServer Method | Use ServerTextControl class.
FontSettings Property | FontSettings Property
PageViewStyle Property | TextControl.DisplayColors Property

Line Operations

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
GetBaseLinePos Method | Line.Baseline Property
GetCharFromLine Method | Line.Start Property
GetLineCount Method | LineCollection.Count Property
GetLineFromChar Method | LineCollection.GetItem Property
GetLineFromPoint Method | LineCollection.GetItem Property
GetLineRect Method | Line.TextBounds Property

Using Text Controls without built-in Scroll Interface

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
AutoExpand Property | AutoSize Class, TextControl.AutoControlSize Property.
AutoScroll Event | Not supported in Text Control.NET.
CaretOut Event | Not supported in Text Control.NET.
CaretOutBottom Event | Not supported in Text Control.NET.
CaretOutLeft Event | Not supported in Text Control.NET.
CaretOutRight Event | Not supported in Text Control.NET.
CaretOutTop Event | Not supported in Text Control.NET.
HExpand Event | TextControl.HExpanded Event.
Move Event | Not supported in Text Control.NET.
Size Event | Not supported in Text Control.NET.
SizeMode Property | Not supported in Text Control.NET.
VExpand Event | TextControl.VExpanded Event.

Selections and Character Input

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
CaretWidth Property | TextControl.CaretWidth Property.
Click Event | TextControl.Click Event
CurrentInputPosition Property | InputPosition Class, TextControl.InputPosition Property.
DblClick Event | TextControl.DoubleClick Event
FormatSelection Property | Selection Class, TextControl.Selection Property
InputPosFromPoint Method | InputPosition Class, TextControl.InputPosition Property, TextCharCollection.GetItem method.
KeyDown Event | TextControl.KeyDown Event
KeyPress Event | TextControl.KeyPress Event
KeyStateChange Event | Not supported in Text Control.NET.
KeyUp Event | TextControl.KeyUp Event
MouseDown Event | TextControl.MouseDown Event
MouseMove Event | TextControl.MouseMove Event
MouseUp Event | TextControl.MouseUp Event
MousePointer Property | TextControl.Cursor Property
ParagraphChange Event | InputParagraphChanged Event
PosChange Event | InputPositionChanged Event
RTFSelText Property | Selection.Load Method, Selection.Save Method
SelLength Property | Selection.Length Property
SelStart Property | Selection.Start Property.
SelText Property | Selection.Text Property.
TabKey Property | TextControl.AcceptsTab Property

Marked Text Fields

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
FieldAtInputPos Property | TextFieldCollection.GetItem Method
FieldChangeable Property | TextField.Editable Property
FieldChanged Event | TextControl.TextFieldChanged Event
FieldClicked Event | TextControl.TextFieldClicked Event
FieldCreated Event | TextControl.TextFieldCreated Event
FieldCurrent Property | No longer necessary, because the TextField class implements the properties for setting the attributes of a text field.
FieldData Property | TextField.Name Property, TextField.ID Property
FieldDblClicked Event | TextControl.TextFieldDoubleClicked Event
FieldDelete Method | TextFieldCollection.Remove Method
FieldDeleteable Property | TextField.Deleteable Property
FieldDeleted Event | TextControl.TextFieldDeleted Event
FieldEditAttr Property | TextField.DoubleClickEvent Property, TextField.DoubledInputPosition Property, TextField.ShowActivated Property
FieldEnd Property | TextField.Length Property
FieldEntered Event | TextControl.TextFieldEntered Event
FieldGoto Method | TextField.ScrollTo Method
FieldInsert Method | TextFieldCollection.Add Method
FieldLeft Event | TextControl.TextFieldLeft Event
FieldNext Method | TextFieldCollection Class (enumeration with for-each)
FieldPosX Property | TextChar.Bounds Property, TextCharCollection.GetItem Method, TextField.Start Property.
FieldPosY Property | TextChar.Bounds Property, TextCharCollection.GetItem Method, TextField.Start Property.
FieldSetCursor Event | TextControl.FieldCursor Property
FieldStart Property | TextField.Start Property
FieldText Property | TextField.Text Property

Integrated Dialogboxes

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
FontDialog Method | TextControl.FontDialog Method
FindReplace Method | TextControl.Find Method, TextControl.Replace Method
ListAttrDialog Method | TextControl.ListFormatDialog Method
ParagraphDialog Method | TextControl.ParagraphFormatDialog Method
StyleDialog Method | TextControl.FormattingStylesDialog Method
TabDialog Method | TextControl.TabDialog Method
TableAttrDialog Method | TextControl.TableFormatDialog Method

Handling XML Documents

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
XMLEditMode Property | TextControl.XmlEditMode Property
XMLElement Object | XmlElement Class
XMLElements Collection | XmlElementCollection Class
XMLElements Property | TextControl.GetXmlElements Method
XMLInvalid Event | TextControl.XmlInvalid Event
XMLNotWellFormed Event | TextControl.XmlNotWellFormed Event

Tool Bar Support

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
StatusBarHandle Property | TextControl.StatusBar Property
RulerHandle Property | TextControl.RulerBar Property
ButtonBarHandle Property | TextControl.ButtonBar Property
ConnectTools Event | No longer necessary, because a valid window handle must not be created for connecting a tool bar with a Text Control.
VerticalRulerHandle Property | TextControl.VerticalRulerBar Property

Chains of Linked Text Controls

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
AutoLink Event | Not supported in Text Control.NET.
NextWindow Property | Not supported in Text Control.NET.

Multi-Language Support

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Language Property | The language is automatically selected through the system.
ResourceFile Property | Implemented through satellite assemblies.

Miscellaneous

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Error Event | Implemented through exceptions.
GetTextExtent Method | Not supported in Text Control.NET.
hWnd Property | TextControl.Handle Property
Refresh Method | TextControl.Refresh Method
ResetContents Method | TextControl.ResetContents Method


Porting the TX Text Control ActiveX Tool Bars to a Windows Forms Application

The following lists all properties and events of the ActiveX tool bars and the corresponding implementations in TX Text Control .NET.

Button Bar

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Appearance Property | ButtonBar.BorderStyle Property
BorderStyle Property | ButtonBar.BorderStyle Property
Enabled Property | ButtonBar.Enabled Property
hWnd Property | ButtonBar.Handle Property
Language Property | The language is automatically selected through the system.
MouseDown Event | ButtonBar.MouseDown Event
MouseMove Event | ButtonBar.MouseMove Event
MouseUp Event | ButtonBar.MouseUp Event
Posxxx Property | ButtonBar.ButtonOffsets Property, ButtonBar.ButtonPositions Property, ButtonBar.ButtonSeparators Property
ResourceFile Property | Implemented through satellite assemblies.
Style Property | ButtonBar.ButtonStyle Property

Ruler Bar

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BorderStyle Property | RulerBar.BorderStyle Property
Enabled Property | RulerBar.Enabled Property
hWnd Property | RulerBar.Handle Property
Language Property | The language is automatically selected through the system.
MouseDown Event | RulerBar.MouseDown Event
MouseMove Event | RulerBar.MouseMove Event
MouseUp Event | RulerBar.MouseUp Event
ResourceFile Property | Implemented through satellite assemblies.
ScaleUnits Property | RulerBar.ScaleUnit Property

Status Bar

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BorderStyle Property | StatusBar.BorderStyle Property
Enabled Property | StatusBar.Enabled Property
Font Property | StatusBar.Font Property
FontBold Property | StatusBar.Font Property
FontItalic Property | StatusBar.Font Property
FontName Property | StatusBar.Font Property
FontSize Property | StatusBar.Font Property
FontStrikethru Property | StatusBar.Font Property
FontUnderline Property | StatusBar.Font Property
hWnd Property | StatusBar.Handle Property
Language Property | The language is automatically selected through the system.
MouseDown Event | StatusBar.MouseDown Event
MouseMove Event | StatusBar.MouseMove Event
MouseUp Event | StatusBar.MouseUp Event
PageMode Property | Is automatically selected depending on the TextControl.ViewMode Property.
ResourceFile Property | Implemented through satellite assemblies.
Text Property | StatusBar.Text Property
TextColumn Property | StatusBar.ColumnText Property
TextLine Property | StatusBar.LineText Property
TextPage Property | StatusBar.PageText Property


Porting TX Text Control ActiveX Server to an ASP.NET Application

The following lists all properties, methods and events of the ActiveX server text compenent and its corresponding implementations in TX Text Control .NET, grouped by categories.

Character Formatting

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BaseLine Property | ServerTextControl.Baseline Property, Selection.Baseline Property
FontBold Property | ServerTextControl.Font Property, Selection.Bold Property
FontItalic Property | ServerTextControl.Font Property, Selection.Italic Property
FontName Property | ServerTextControl.Font Property, Selection.FontName Property
FontSize Property | ServerTextControl.Font Property, Selection.FontSize Property
FontStrikethru Property | ServerTextControl.Font Property, Selection.StrikeOut Property
FontUnderline Property | ServerTextControl.Font Property, Selection.Underline Property
FontUnderlineStyle Property | ServerTextControl.FontUnderlineStyle Property, Selection.Underline Property
ForeColor Property | ServerTextControl.ForeColor Property, Selection.ForeColor Property
TextBkColor Property | ServerTextControl.TextBackColor Property, Selection.TextBackColor Property

Paragraph Formatting

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Alignment Property | ParagraphFormat.Alignment Property
FrameDistance Property | ParagraphFormat.FrameDistance Property
FrameLineWidth Property | ParagraphFormat.FrameLineWidth Property
FrameStyle Property | ParagraphFormat.FrameStyle Property
IndentB Property | ParagraphFormat.BottomDistance Property
IndentFL Property | ParagraphFormat.LeftIndent Property
IndentL Property | ParagraphFormat.HangingIndent Property
IndentR Property | ParagraphFormat.RightIndent Property
IndentT Property | ParagraphFormat.TopDistance Property
LineSpacing Property | ParagraphFormat.LineSpacing Property
LineSpacingT Property | ParagraphFormat.AbsoluteLineSpacing Property
TabCurrent Property | No longer necessary, because positions and types of tabs are implemented with arrays.
TabPos Property | ParagraphFormat.TabPositions Property
TabType Property | ParagraphFormat.TabTypes Property

Bullets and Numbered Lists

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BulletAttribute Property | ListFormat Class Properties, ServerTextControl.ListFormat Property, Selection.ListFormat Property.
ListType Property | ListFormat.Type Property
NumberingAttribute Property | ListFormat Class Properties, ServerTextControl.ListFormat Property, Selection.ListFormat Property.

Headers and Footers

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
HeaderFooter Property | ServerTextControl.HeadersAndFooters Property, HeaderFooterCollection Class
HeaderFooterPosition Property | HeaderFooter.Distance Property
HeaderFooterSelect Method | No longer necessary, because the HeaderFooter class implements its own properties.
HeaderFooterAtInputPos Property | TextPartCollection.GetItem Property
HeaderFooterConnectedToPrevious Property | HeaderFooter.ConnectedToPrevious Property

Page and Document Settings

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
CurrentPages Property | ServerTextControl.Pages Property
Device Property | Currently not implemented. Will be available in a future version.
PageHeight Property | ServerTextControl.PageSize Property
PageMarginB Property | ServerTextControl.PageMargins Property, PageMargins Class
PageMarginL Property | ServerTextControl.PageMargins Property, PageMargins Class
PageMarginR Property | ServerTextControl.PageMargins Property, PageMargins Class
PageMarginT Property | ServerTextControl.PageMargins Property, PageMargins Class
PageWidth Property | ServerTextControl.PageSize Property
ViewMode Property | No longer necessary, because the ServerTextControl class automatically works with pages.

Stylesheets

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Style Object | FormattingStyle Class, InlineStyle Class, ParagraphStyle Class
StyleCurrent Property | Selection.FormattingStyle Property
Styles Collection | InlineStyleCollection Class, ParagraphStyleCollection Class
Styles Property | ServerTextControl.InlineStyles Property, ServerTextControl.ParagraphStyles Property.

Tables

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
TableAtInputPos Property | TableCollection.GetItem Method
TableCanChangeAttr Property | TableCollection.CanAdd Property
TableCanDeleteColumn Property | TableColumnCollection.CanRemove Property
TableCanDeleteLines Property | TableRowCollection.CanRemove Property
TableCanInsert Property | TableCollection.CanAdd Property
TableCanInsertColumn Property | TableColumnCollection.CanAdd Property
TableCanInsertLines Property | TableRowCollection.CanAdd Property
TableCellAttribute Property | TableCellFormat Class Properties, TableCell.CellFormat Property, TableRow.CellFormat Property, TableColumn.CellFormat Property, TableCell.Width Property, TableCell.Position Property
TableCellLength Property | TableCell.Length Property
TableCellStart Property | TableCell.Start Property
TableCellText Property | TableCell.Text Property
TableColAtInputPos Property | TableColumnCollection.GetItem Method
TableColumns Property | TablePartCollection.Count Property
TableDeleteColumn Method | TableColumnCollection.Remove Method
TableDeleteLines Method | TableRowCollection.Remove Method
TableGridLines Property | TableCollection.GridLines Property
TableInsert Method | TableCollection.Add Method
TableInsertColumn Method | TableColumnCollection.Add Method
TableInsertLines Method | TableRowCollection.Add Method
TableNext Method | TableCollection Class (enumeration with for-each)
TableRowAtInputPos Property | TableRowCollection.GetItem Method
TableRows Property | TablePartCollection.Count Property

Loading, Saving and Database Support

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
DataTextFormat Property | Not supported in Text Control.NET.
Load Method | ServerTextControl.Load Method, Selection.Load Method.
LoadFromMemory Method | ServerTextControl.Load Method, Selection.Load Method.
LoadSaveAttribute Property | LoadSettings Class Properties, SaveSettings Class Properties.
Save Method | ServerTextControl.Save Method, Selection.Save Method.
SaveToMemory Method | ServerTextControl.Save Method, Selection.Save Method.
SaveToMemoryBuffer Method | ServerTextControl.Save Method, Selection.Save Method.
Text Property | ServerTextControl.Text Property, Selection.Text Property

Images and OLE Objects

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
ImageDisplayMode Property | Not supported in Text Control.NET.
ImageExportFilename Property | Image.ExportFileName Property
ImageExportFilters Property | ImageCollection.ExportFilters Property
ImageExportFormat Property | Image.ExportFilterIndex Property
ImageFilename Property | Image.FileName Property
ImageFilters Property | ImageCollection.ImportFilters Property
ImageSaveMode Property | Image.SaveMode Property
ObjectCurrent Property | No longer necessary, because the Image class implements the properties for setting the attributes of an image.
ObjectDelete Method | ImageCollection.Remove Method
ObjectDistance Property | Image.TextDistances Property
ObjectInsertAsChar Method | ImageCollection.Add Method
ObjectInsertFixed Method | ImageCollection.Add Method
ObjectItem Property | Not supported in Text Control.NET.
ObjectNext Method | ImageCollection Class (enumeration with for-each)
ObjectScaleX Property | Image.HorizontalScaling Property
ObjectScaleY Property | Image.VerticalScaling Property
ObjectSizeMode Property | Image.Moveable Property, Image.Sizeable Property
ObjectTextflow Property | Image.InsertionMode Property
ImageExportCompressionQuality Property | Image.ExportCompressionQuality Property
ImageExportMaxResolution Property | Image.ExportMaxResolution Property
ImageInsert Method | ImageCollection.Add Method
ImageInsertAsChar Method | ImageCollection.Add Method
ImageInsertFixed Method | ImageCollection.Add Method

Hypertext Links

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
FieldType Property | DocumentLink Class, DocumentTarget Class, HypertextLink Class, PageNumberField Class
FieldTypeData Property | DocumentLink.DocumentTarget Property, DocumentTarget.TargetName Property, HypertextLink.Target Property, PageNumberField.NumberFormat Property, PageNumberField.StartNumber Property

Printing

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
PrintColors Property | ServerTextControl.Print Method, PrintDocument.DafaultPageSettings.Color Property
PrintDevice Property | ServerTextControl.Print Method, PrintDocument.PrinterSettings.PrinterName
PrintDoc Method | ServerTextControl.Print Method
PrintOffset Property | Not supported in Text Control.NET.
PrintPage Method | ServerTextControl.Print Method.
PrintZoom Property | Not supported in Text Control.NET.

Search and Replace

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
Find Method | ServerTextControl.Find Method

Control Styles and Mode Settings

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
BackColor Property | ServerTextControl.BackColor Property
WordWrapMode Property | Currently not implemented. Will be available in a future version.

Line Operations

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
GetBaseLinePos Method | Line.Baseline Property
GetCharFromLine Method | Line.Start Property
GetLineCount Method | LineCollection.Count Property
GetLineFromChar Method | LineCollection.GetItem Property
GetLineFromPoint Method | LineCollection.GetItem Property
GetLineRect Method | Line.TextBounds Property

Selections and Character Input

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
CurrentInputPosition Property | InputPosition Class, ServerTextControl.InputPosition Property.
FormatSelection Property | Selection Class, ServerTextControl.Selection Property
InputPosFromPoint Method | InputPosition Class, ServerTextControl.InputPosition Property, TextCharCollection.GetItem method.
RTFSelText Property | Selection.Load Method, Selection.Save Method
SelLength Property | Selection.Length Property
SelStart Property | Selection.Start Property.
SelText Property | Selection.Text Property.

Marked Text Fields

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
FieldAtInputPos Property | TextFieldCollection.GetItem Method
FieldChangeable Property | TextField.Editable Property
FieldCurrent Property | No longer necessary, because the TextField class implements the properties for setting the attributes of a text field.
FieldData Property | TextField.Name Property, TextField.ID Property
FieldDelete Method | TextFieldCollection.Remove Method
FieldDeleteable Property | TextField.Deleteable Property
FieldEditAttr Property | TextField.DoubleClickEvent Property, TextField.DoubledInputPosition Property, TextField.ShowActivated Property
FieldEnd Property | TextField.Length Property
FieldGoto Method | TextField.ScrollTo Method
FieldInsert Method | TextFieldCollection.Add Method
FieldNext Method | TextFieldCollection Class (enumeration with for-each)
FieldPosX Property | TextChar.Bounds Property, TextCharCollection.GetItem Method, TextField.Start Property.
FieldPosY Property | TextChar.Bounds Property, TextCharCollection.GetItem Method, TextField.Start Property.
FieldStart Property | TextField.Start Property
FieldText Property | TextField.Text Property

Handling XML Documents

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
XMLElement Object | XmlElement Class
XMLElements Collection | XmlElementCollection Class
XMLElements Property | ServerTextControl.GetXmlElements Method

Miscellaneous

ActiveX Property/Method/Event | .NET Class/Property/Method/Event
GetTextExtent Method | Not supported in Text Control.NET.
ResetContents Method | ServerTextControl.ResetContents Method


Mouse and Keyboard Assignment

Mouse Assignment

Keyboard Assignment

Additional Mouse and Keyboard Assignment in Tables

Keyboard Assignment for Hyphens


Mouse Assignment

Mouse Action | Reaction of Text Control
Click | Moves cursor to point of click or selects an image or text frame.
Click and Drag | Selects text from point of button down to point where button is released or moves an illustration or a text frame.
SHIFT + Click | Extends the selection to the point of click.
Double-click | Selects the word that is clicked on.
Double-click and drag | Extends the selection from word to word.
Triple-click | Selects the paragraph that is clicked on.
Triple-click and drag | Extends the selection from paragraph to paragraph.
PgUp / PgDown | Scrolls the text up or down one client area height minus the height of one line of text. Active only if a vertical scrollbar exists.
CTRL + PgUp / PgDown | Zooms up or down the current document.
SHIFT + PgUp / PgDown | Scrolls the document horizontally.
Drag and Drop on selected text | Selected text is moved to the drop position of the mouse (text drag and drop).
CTRL + Drag and Drop on selected text | Selected text is copied to the drop position of the mouse (text drag and drop).
Click on the selection bar (left or right margin) | Selects the complete row.


Keyboard Assignment

Key Type | Reaction of Text Control
HOME | Moves the caret to the beginning of the line.
END | Moves the caret to the end of the line.
(Left Arrow) | Moves the caret one character to the left.
(Right Arrow) | Moves the caret one character to the right.
(Up Arrow) | Moves the caret one line up.
(Down Arrow) | Moves the caret one line down.
CTRL+(Left Arrow) | Moves the caret to the beginning of the current word.
CTRL+(Right Arrow) | Moves the caret to the beginning of the next word.
CTRL+HOME | Moves the caret to start of text.
CTRL+END | Moves the caret to end of text.
CTRL + ENTER | Inserts a new page.
SHIFT + ENTER | Creates a line feed without beginning a new paragraph.
CTRL + (-) | Inserts an end-of-line hyphen.
DEL | Deletes selected text.
CTRL + X | Copies selected text to the Clipboard and deletes the selection.
CTRL + C | Copies selected text to the clipboard.
CTRL + V | Pastes the copied text into the selection.
CTRL + Z | Undos the last action.
CTRL + Y | Restores the last action.
CTRL + SHIFT + (Spacebar) | Inserts a non-breaking space.
CTRL +(Backspace) | Deletes the previous word.
SHIFT +(Backspace) | Deletes the previous word.
CTRL + SHIFT + ENTER | Inserts a page column break.

Pressing a key while SHIFT is pressed extends the current selection to the new caret position.


Additional Mouse and Keyboard Assignment in Tables

Key Type or Mouse Action | Reaction of Text Control
TAB | Selects the next table cell.
SHIFT + TAB | Selects the previous table cell.
CTRL + TAB | Inserts a tab character.
Click top of a column (first row) | Selects the complete table column.
Click on the selection bar (left or right margin) | Selects the complete table row.
Double-click table cell | Selects the complete table cell.


Keyboard Assignment for Hyphens

Key Type | Inserted Hyphen [Divide Position]
(-) | Hyphen, minus sign [Yes]
CTRL + (-) | Non-visible hyphen [Yes]
CTRL + SHIFT + (-) | Compound word [No]
CTRL + (-) [NUMPAD] | EN dash [Yes]
CTRL + ALT + (-) [NUMPAD] | EM dash [Yes]


Class Library Reference

The Text Control .NET class library in detail and alphabetical order.

JavaScript API

TXTextControl namespace

TXTextControl.DataVisualization namespace

TXTextControl.DocumentServer namespace

TXTextControl.DocumentServer.DataSources namespace

TXTextControl.DocumentServer.Fields namespace

TXTextControl.DocumentServer.Json namespace

TXTextControl.DocumentServer.WPF namespace

TXTextControl.DocumentServer.Web namespace

TXTextControl.DocumentServer.Windows.Forms namespace

TXTextControl.Drawing namespace

TXTextControl.ServerVisualization namespace

TXTextControl.WPF namespace

TXTextControl.WPF.Drawing namespace

TXTextControl.Web namespace

TXTextControl.Windows.Forms.Ribbon namespace


JavaScript API

TXTextControl Object

TXTextControl.CultureSettings Object

TXTextControl.DocumentLoadedEventArgs Object

TXTextControl.HyperlinkClickedEventArgs Object

TXTextControl.InputPositionChangedEventArgs Object

TXTextControl.Ribbon Object

TXTextControl.RibbonTabIndexChangedEventArgs Object

TXTextControl.SaveDocumentResult Object

TXTextControl.Selection Object

TXTextControl.SelectionBounds Object

TXTextControl.SubTextPartEventArgs Object

TXTextControl.TextDroppedEventArgs Object

TXTextControl.TextFieldEventArgs Object

TXTextControl.TextPart Object

TXTextControl.WebSocketClosedEventArgs Object


TXTextControl Object

The TXTextControl JavaScript object provides a public API to manipulate the web editor via JavaScript functions in the browser.

Syntax

TXTextControl

Properties

Property | Description
contextMenusEnabled | Gets or sets if a right click into the text area opens a context menu or not.
controlChars | Gets or sets if control characters are visible.
documentTargetMarkers | Gets or sets if document target markers are visible.
editMode | Gets or sets the edit mode the control is in.
isHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
isLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
isLoadingDialogEnabled | Gets or sets if a wait dialog is shown while a document is being loaded.
isSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
ribbon | Gets the control's ribbon bar object.
saveDocumentQuestionDialogEnabled | Gets or sets if a confirmation dialog should be shown before discarding unsaved changes.
selection | Gets the current selection.
tableGridLines | Gets or sets if table grid lines are visible.
textFieldsEditable | Gets or sets if text fields are editable or not.
textFrameMarkerLines | Gets or sets if text frame marker lines are visible.

Methods

Method | Description
addEventListener | The addEventListener function registers event listener functions on the TXTextControl object.
focus | The focus function sets the text input focus to the web editor.
getBackColor | Returns the background color of the main text area and the ruler bars by calling a provided callback function.
getCultures | Returns the culture and the UI culture of the control.
getFileDirectory | Requests the directory path where the files of a specific file type are stored on the web server.
getFormattingPrinter | Returns the name of the currently selected formatting printer by calling a provided callback function.
getInstalledPrinters | Gets the names of the printers installed on the server which are usable by Text Control.
getStatusBarColor | Returns the background color of the status bar by calling a provided callback function.
getTextParts | Requests a collection of all text parts the current document contains from the server and returns the collection by calling a callback function which has to be provided as a parameter to the function.
loadDocument | Loads text in a certain format.
loadSelection | Loads text in a certain format into the current selection.
loadXMLDatabase | Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.
removeEventListener | The removeListener function removes the specified listener from the TXTextControl object.
removeFromDom | The removeFromDom function closes the WebSocket connection gracefully and removes the whole editor from the DOM.
resetContents | Deletes the entire contents of the control.
saveDocument | Saves the current document in a certain format and sends the result back asynchronously by calling a given callback function.
saveSelection | Saves the current selection in a certain format and sends the result back asynchronously by calling a given callback function.
setBackColor | Sets the background color of the main text area and the ruler bars.
setFileDirectory | Sets the directory path where the files of a specific file type are stored on the web server.
setFormattingPrinter | Sets the name of a printer the text dimensions and capabilities of which are used to format the document.
setStatusBarColor | Sets the background color of the status bar.
showHorizontalRuler | Shows or hides the web editor's horizontal ruler bar.
showRibbonBar | Shows or hides the ribbon bar.
showStatusBar | Shows or hides the web editor's status bar.
showVerticalRuler | Shows or hides the web editor's vertical ruler bar.

Enumerations

Enumeration | Description
EditMode | Determines the possible document edit modes.
FileType | Specifies the kind of file types.
StreamType | Determines a certain text format.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.addEventListener Method

The addEventListener function registers event listener functions on the TXTextControl object.

Syntax

TXTextControl.addEventListener(<String> eventName, <function> callback);
Parameter Description
eventName

A string representing the name of the event to listen for.

Value | Meaning
"ribbonTabsLoaded" | Is fired after the ribbon bar content has been loaded completely and the server supplied string resources have been applied.
"textFieldEntered" | Is fired when the input position enters a text field.
"textFieldLeft" | Is fired when the input position leaves a text field.
"textFieldClicked" | Is fired when the user clicks into a text field.
"textDropped" | Is fired when RTF text, HTML text or plain text is dragged and dropped onto the control.
"documentLoaded" | Is fired after a document has been loaded.
"webSocketClosed" | Is fired if the websocket connection is closed.
"textControlLoaded" | Is fired after the TextContol instance has been properly initialized and is ready to be used / manipulated programmatically.
"ribbonTabIndexChanged" | Is fired after the current ribbon tab index has changed.
"subTextPartEntered" | Is fired when the input position enters a sub text part.
"subTextPartLeft" | Is fired when the input position leaves a sub text part.
"subTextPartClicked" | Is Fired when the user clicks into a sub text part.
"subTextPartDoubleClicked" | Is Fired when the user double clicks into a sub text part.
"hyperlinkClicked" | Is fired when the user clicks on a hyperlink.
"textControlChanged" | Is fired when the content of the current document has changed.
"inputPositionChanged" | Is fired when the text input position has changed.
callback

The event listener. Depending on the event specified in parameter eventName the event listener function is called with different event argument objects (or none at all).

Event Name | Event Argument
"ribbonTabsLoaded" | None.
"textFieldEntered" | An object of type TextFieldEventArgs.
"textFieldLeft" | None.
"textDropped" | An object of type TextDroppedEventArgs.
"textFieldClicked" | An object of type TextFieldEventArgs.
"documentLoaded" | An object of type DocumentLoadedEventArgs.
"webSocketClosed" | An object of type WebSocketClosedEventArgs.
"textControlLoaded" | None.
"ribbonTabIndexChanged" | An object of type RibbonTabIndexChangedEventArgs.
"subTextPartEntered" | An object of type SubTextPartEventArgs.
"subTextPartLeft" | An object of type SubTextPartEventArgs.
"subTextPartClicked" | An object of type SubTextPartEventArgs.
"subTextPartDoubleClicked" | An object of type SubTextPartEventArgs.
"hyperlinkClicked" | An object of type HyperlinkClickedEventArgs
"textControlChanged" | None.
"inputPositionChanged" | An object of type InputPositionChangedEventArgs

Example

The following example shows how to attach an event handler to the "textFieldClicked" event:

function fieldClickedHandler(e) {
    console.log("Field type: " + e.fieldType);
    console.log("Field name: " + e.fieldName);
    console.log("Merge field type: " + e.typeName);
}

TXTextControl.addEventListener("textFieldClicked", fieldClickedHandler);

Possible console output after clicking into a merge field:

> Field type: APPLICATIONFIELD
> Field name: SalesOrderID
> Merge field type: MERGEFIELD

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.contextMenusEnabled Property

Gets or sets if a right click into the text area opens a context menu or not.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.contextMenusEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.controlChars Property

Gets or sets if control characters are visible.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.controlChars

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.documentTargetMarkers Property

Gets or sets if document target markers are visible.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.documentTargetMarkers

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.editMode Property

Gets or sets the edit mode the control is in. Must be set with one of the EditMode values.

Introduced: 24.0.

Syntax

<EditMode> TXTextControl.editMode

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.EditMode Object

Determines the possible document edit modes. The object has the following properties:

Introduced: 24.0.

Member | Description
Edit | The document's text can be edited.
ReadAndSelect | The document's text is read only but can be selected.
ReadOnly | The document's text is read only.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.FileType Object

Specifies the kind of file types. The enumeration contains the following values:

Introduced: 24.0.

Member | Description
Document | Specifies document file types.
Image | Specifies image file types.
DataBase | Specifies database file types.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.focus Method

The focus function sets the text input focus to the web editor.

Syntax

<void> TXTextControl.focus();

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getBackColor Method

Returns the background color of the main text area and the ruler bars by calling a provided callback function.

Introduced: 24.0.

Syntax

<void> TXTextControl.getBackColor(<function> callback);
Parameter | Description
callback | A function with one parameter. Is called with the background color as the parameter value as soon as the information has been retrieved from the server. The color is given as a hexadecimal CSS color string. (e. g. "#FFABC3")

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getCultures Method

Returns the culture and the UI culture of the control. The UI culture affects the string resource language. The culture represents date and time string formats, for example.

Introduced: 24.0.

Syntax

<CultureSettings> TXTextControl.getCultures();

Return Value

Returns an object of type CultureSettings.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getFileDirectory Method

Requests the directory path where the files of a specific file type are stored on the web server.

Introduced: 24.0.

Syntax

<void> TXTextControl.getFileDirectory(<FileType> fileType, <function> callback);
Parameter | Description
fileType | A number. Must be one of the FileType values.
callback | A function with one parameter. Is called with a string containing the file directory of the requested file type on the web server as soon as the information has been retrieved from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getFormattingPrinter Method

Returns the name of the currently selected formatting printer by calling a provided callback function. For more information on the formatting printer see function setFormattingPrinter.

Introduced: 24.0.

Syntax

<void> TXTextControl.getFormattingPrinter(<function> callback);
Parameter | Description
callback | A function with one string parameter. Is called with the name of the currently selected formatting printer as soon as the information has been retrieved from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getInstalledPrinters Method

Gets the names of the printers installed on the server which are usable by Text Control.

Introduced: 24.0.

Syntax

<void> TXTextControl.getInstalledPrinters(<function> callback);
Parameter | Description
callback | A function with one parameter of type String[]. Is called with the names of the installed printers which can be used by Text Control as soon as the information has been retrieved from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getStatusBarColor Method

Returns the background color of the status bar by calling a provided callback function.

Introduced: 24.0.

Syntax

<void> TXTextControl.getStatusBarColor(<function> callback);
Parameter | Description
callback | A function with one String parameter. Is called with the status bar color as a hexadecimal CSS color string (e. g. "#FFABC3") as soon as the information has been retrieved from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.getTextParts Method

Requests a collection of all text parts the current document contains from the server and returns the collection by calling a callback function which has to be provided as a parameter to the function.

Introdued: 24.0.

Syntax

<void> TXTextControl.getTextParts(<function> callback);
Parameter | Description
callback | A function with one parameter. Is called with an array of TextParts as a parameter containing all text parts of the current document as soon as the information has been retrieved from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.isHyphenationEnabled Property

Gets or sets a value indicating whether hyphenation is active or not.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.isHyphenationEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.isLanguageDetectionEnabled Property

Gets or sets a value indicating whether language detection is active or not.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.isLanguageDetectionEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.isLoadingDialogEnabled Property

Gets or sets if a wait dialog is shown while a document is being loaded.

Introduced: 23.0.

Syntax

<boolean> TXTextControl.isLoadingDialogEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.isSpellCheckingEnabled Property

Gets or sets a value indicating whether spell checking is active or not.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.isSpellCheckingEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.loadDocument Method

Loads text in a certain format. The complete contents of the web editor are replaced.

Syntax

<void> TXTextControl.loadDocument(<StreamType> streamType, <String> base64Data);
Parameter | Description
streamType | Specifies one of the numerical StreamType values.
base64Data | Base64 encoded document data.

Example

The following example shows how to load a short HTML document into the web editor.

var html = "This is some <b>HTML</b> text.";
var encoded = btoa(html);  // btoa base-64-encodes strings.
TXTextControl.loadDocument(TXTextControl.StreamType.HTMLFormat, encoded);

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.loadSelection Method

Loads text in a certain format into the current selection.

Introduced: 23.0.

Syntax

<void> TXTextControl.loadSelection(<StreamType> streamType, <String> base64Data);
Parameter | Description
streamType | Specifies one of the numerical StreamType values.
base64Data | Base64 encoded document data.

Example

For an example on how to use this function have a look at the description of the loadDocument function.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.loadXMLDatabase Method

Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.

Introduced: 24.0.

Syntax

<void> TXTextControl.loadXMLDatabase(<String> xmlData);
Parameter | Description
xmlData | Specifies the xml document content from which the database is loaded.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.removeEventListener Method

The removeListener function removes the specified listener from the TXTextControl object.

Syntax

<void> TXTextControl.removeEventListener(<String> eventName, <function> callback);
Parameter | Description
eventName | The event name. (For possible event names see addEventListener)
callback | The event listener function to remove from the internal list of registered event listeners.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.removeFromDom Method

The removeFromDom function closes the WebSocket connection gracefully and removes the whole editor from the DOM.

Introduced: 24.0.

Syntax

<void> TXTextControl.removeFromDom();

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.resetContents Method

Deletes the entire contents of the control.

Introduced: 23.0.

Syntax

<void> TXTextControl.resetContents();

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.ribbon Property

Gets the control's ribbon bar object. Use this property to manipulate the ribbon bar.

Introduced: 24.0.

Syntax

<Ribbon> TXTextControl.ribbon

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.saveDocument Method

Saves the current document in a certain format and sends the result back asynchronously by calling a given callback function.

Introduced: 23.0.

Syntax

<void> TXTextControl.saveDocument(<StreamType> streamType, <function> callback);
Parameter | Description
streamType | Specifies one of the numerical StreamType values.
callback | A function with one parameter. Is called with an argument object of type SaveDocumentResult containing the document data after the document has been saved successfully.

Example

The following example shows how to save the current document and display the received document data in the console.

TXTextControl.saveDocument(TXTextControl.StreamType.HTMLFormat, function (e) {
    console.log(e.data);
});

Possible console output:

<?xml version="1.0" ?>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
[...]

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.saveDocumentQuestionDialogEnabled Property

Gets or sets if a confirmation dialog should be shown before discarding unsaved changes.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.saveDocumentQuestionDialogEnabled

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.saveSelection Method

Saves the current selection in a certain format and sends the result back asynchronously by calling a given callback function.

Introduced: 23.0.

Syntax

<void> TXTextControl.saveSelection(<StreamType> streamType, <function> callback);
Parameter | Description
streamType | Type: Number. Specifies one of the StreamType values.
callback | A function with one parameter. Is called with an argument object of type SaveDocumentResult containing the selection content after the selection has been saved successfully.

Example

For an example on how to use this function have a look at the description of the saveDocument function.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.selection Property

Gets the current selection.

Introduced: 24.0.

Syntax

<Selection> TXTextControl.selection

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.setBackColor Method

Sets the background color of the main text area and the ruler bars.

Introduced: 24.0.

Syntax

<void> TXTextControl.setBackColor(<String> hexColor);
Parameter | Description
hexColor | The color value. Must be a hexadecimal CSS color string. Valid values are "#AAA" or "#b634a2", for example.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.setFileDirectory Method

Sets the directory path where the files of a specific file type are stored on the web server.

Introduced: 24.0.

Syntax

<void> TXTextControl.setFileDirectory(<FileType> fileType, <String> directory);
Parameter | Description
fileType | The file type to set the directory for. Must be one of the numerical FileType values.
directory | The directory path where the files of the given file type are to be stored on the web server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.setFormattingPrinter Method

Sets the name of a printer the text dimensions and capabilities of which are used to format the document. If the document is printed with this printer the displayed and the printed document have the same dimensions. If the property is set to "Standard", the system installed standard printer is used to format the document. If the property is set to "Display", the font dimensions of the display device are used to format the document. If the specified printer is not installed, the standard printer is used.

Introduced: 24.0.

Syntax

<void> TXTextControl.setFormattingPrinter(<String> printerName);
Parameter | Description
printerName | The printer name.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.setStatusBarColor Method

Sets the background color of the status bar.

Introduced: 24.0.

Syntax

<void> TXTextControl.setStatusBarColor(<String> hexColor);
Parameter | Description
hexColor | The color value. Must be a hexadecimal CSS color string. Valid values are "#AAA" or "#b634a2", for example.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.showHorizontalRuler Method

Shows or hides the web editor's horizontal ruler bar.

Syntax

<void> TXTextControl.showHorizontalRuler(<boolean> show);
Parameter | Description
show | Determines if the horizontal ruler bar is shown or hidden.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.showRibbonBar Method

Shows or hides the ribbon bar.

Syntax

<void> TXTextControl.showRibbonBar(<boolean> show);
Parameter | Description
show | Determines if the ribbon bar is shown or hidden.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.showStatusBar Method

Shows or hides the web editor's status bar.

Syntax

<void> TXTextControl.showStatusBar(<boolean> show);
Parameter | Description
show | Determines if the status bar is shown or hidden.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.showVerticalRuler Method

Shows or hides the web editor's vertical ruler bar.

Syntax

<void> TXTextControl.showVerticalRuler(<boolean> show);
Parameter | Description
show | Determines if the vertical ruler bar is shown or hidden.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.StreamType Object

Determines a certain text format. The object has the following properties:

Member | Description
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
RichTextFormat | Specifies RTF format (Rich Text Format).
PlainText | Specifies text in Unicode format.
InternalUnicodeFormat | Specifies the internal Text Control format (Unicode).
MSWord | Specifies Microsoft Word format (.DOC version).
AdobePDF | Specifies Adobe Portable Document Format (PDF).
WordprocessingML | Specifies Microsoft Word format (.DOCX version).

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.tableGridLines Property

Gets or sets if table grid lines are visible.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.tableGridLines

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.textFieldsEditable Property

Gets or sets if text fields are editable or not.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.textFieldsEditable

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.textFrameMarkerLines Property

Gets or sets if text frame marker lines are visible.

Introduced: 24.0.

Syntax

<boolean> TXTextControl.textFrameMarkerLines

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.CultureSettings Object

An object of this type is returned by the function getCultures. It contains the currently used language culture names. (e. g. "de-DE" or "en-US")

Introduced: 24.0.

Syntax

{
    culture: <String>,
    uiCulture: <String>
}

Properties

Property | Description
culture | The control's culture.
uiCulture | The control's user interface culture.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.CultureSettings.culture Property

The control's culture. Affects date and time string formats. Type: String.

Syntax

<String> CultureSettings.culture

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.CultureSettings.uiCulture Property

The control's user interface culture. Affects the string resource language. Type: String.

Syntax

<String> CultureSettings.uiCulture

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.DocumentLoadedEventArgs Object

The event argument object for the documentLoaded event.

Introduced: 23.0.

Syntax

{
    fileName: <String>,
}

Properties

Property | Description
fileName | The file name of the loaded document.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.DocumentLoadedEventArgs.fileName Property

The file name of the loaded document.

Syntax

<String> DocumentLoadedEventArgs.fileName

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.HyperlinkClickedEventArgs Object

The event argument object for the hyperlinkClicked event.

Introduced: 24.0.

Syntax

{
    target: <String>
}

Properties

Property | Description
target | The Link.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.HyperlinkClickedEventArgs.target Property

The Link.

Syntax

<String> HyperlinkClickedEventArgs.target

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.InputPositionChangedEventArgs Object

The event argument object for the inputPositionChanged event.

Introduced: 24.0.

Syntax

{
    column: <number>,
    line: <number>,
    page: <number>,
    section: <number>,
    textPosition: <number>
}

Properties

Property | Description
column | The column number of the current text input position.
line | The line number of the current text input position.
page | The page number of the current text input position.
section | The section number of the current text input position.
textPosition | The 0-based text position of the current text input position.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.InputPositionChangedEventArgs.column Property

The column number of the current text input position.

Syntax

<number> InputPositionChangedEventArgs.column

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.InputPositionChangedEventArgs.line Property

The line number of the current text input position.

Syntax

<number> InputPositionChangedEventArgs.line

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.InputPositionChangedEventArgs.page Property

The page number of the current text input position.

Syntax

<number> InputPositionChangedEventArgs.page

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.InputPositionChangedEventArgs.section Property

The section number of the current text input position.

Syntax

<number> InputPositionChangedEventArgs.section

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.InputPositionChangedEventArgs.textPosition Property

The 0-based text position of the current text input position.

Syntax

<number> InputPositionChangedEventArgs.textPosition

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Ribbon Object

The type of the ribbon property of the TXTextControl object. Provides functions and properties for manipulating the control's ribbon bar.

Introduced: 24.0.

Syntax

{
    minimize: <Method>,
    expand: <Method>,
    selectedTab: <Property>
}

Properties

Property | Description
selectedTab | Gets or sets the currently selected ribbon tab name.

Methods

Method | Description
expand | Expands the ribbon bar if it is currently minimized.
minimize | Minimizes the ribbon bar so that only the tab names stay visible.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Ribbon.minimize Method

Minimizes the ribbon bar so that only the tab names stay visible.

Syntax

<void> Ribbon.minimize();

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Ribbon.expand Method

Expands the ribbon bar if it is currently minimized.

Syntax

<void> Ribbon.expand();

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Ribbon.selectedTab Property

Gets or sets the currently selected ribbon tab name. Possible values are: "tabDefault", "tabInsert", "tabPageLayout", "tabMailings", "tabView", "tabTableLayout", "tabObjectFormat" and "tabShapeFormat".

Syntax

<String> Ribbon.selectedTab {
   get: function () { ... },
   set: function (<String> tabName) { ... }
}

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.RibbonTabIndexChangedEventArgs Object

The event argument object for the ribbonTabIndexChanged event.

Introduced: 24.0.

Syntax

{
    name: <String>
}

Properties

Property | Description
name | The name of the ribbon tab which is now active.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.RibbonTabIndexChangedEventArgs.name Property

The name of the ribbon tab which is now active. Possible values are: "tabFile", "tabDefault", "tabInsert", "tabPageLayout", "tabMailings", "tabView", "tabTableLayout", "tabObjectFormat" and "tabShapeFormat".

Syntax

<String> RibbonTabIndexChangedEventArgs.name

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.SaveDocumentResult Object

The callback function argument for the saveDocument and the saveSelection functions.

Introduced: 23.0.

Syntax

{
    data: <String>,
    streamType: <number>
}

Properties

Property | Description
data | The Document data.
streamType | Specifies one of the StreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SaveDocumentResult.data Property

The Document data. Contains base64 encoded binary data in case of binary document formats (PDF or DOCX, for example) and plain text in case of text based document formats (HTML or RTF, for example).

Syntax

<String> SaveDocumentResult.data

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SaveDocumentResult.streamType Property

Specifies one of the StreamType values.

Syntax

<number> SaveDocumentResult.streamType

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Selection Object

Describes and handles the position and length of a text selection. It also provides the possibility to replace the currently selected text with text in a certain document format.

Introduced: 24.0.

Syntax

{
    getBounds: <function>,
    setBounds: <function>,
    load: <function>,
    save: <function>,
    getCulture: <function>,
    setCulture: <function>
}

Methods

Method | Description
getBounds | Takes a callback function with one parameter as a parameter.
getCulture | Takes a callback function as a parameter which is called with a languagecode2-country/regioncode2 string ("de-DE", "en-US" or "en", for example) as a parameter upon receiving the selection information from the server.
load | For a detailed description of this function see loadSelection.
save | For a detailed description of this function see saveSelection.
setBounds | Sets the selection start and length.
setCulture | Sets the selection culture.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.getBounds Method

Takes a callback function with one parameter as a parameter. The callback function is called with a SelectionBounds object as a parameter upon receiving the selection information from the server.

Syntax

<void> Selection.getBounds(<function> callback);
Parameter | Description
callback | A function with one parameter. Is called with a SelectionBounds object as a parameter upon receiving the selection information from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.setBounds Method

Sets the selection start and length. Takes a SelectionBounds object as a parameter.

Syntax

<void> Selection.setBounds(<SelectionBounds> bounds);
Parameter | Description
bounds | A SelectionBounds object.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.load Method

For a detailed description of this function see loadSelection.

Syntax

<void> Selection.load(<number> streamType, <String> base64Data);
Parameter | Description
streamType | Specifies one of the StreamType values.
base64Data | Base64 encoded document data.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.save Method

For a detailed description of this function see saveSelection.

Syntax

<void> Selection.save(<StreamType> streamType, <function> callback);
Parameter | Description
streamType | Specifies one of the StreamType values.
callback | A function with one parameter. Is called with an object of type SaveDocumentResult containing the selection content after the selection has been saved successfully.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.getCulture Method

Takes a callback function as a parameter which is called with a languagecode2-country/regioncode2 string ("de-DE", "en-US" or "en", for example) as a parameter upon receiving the selection information from the server.

Syntax

<void> Selection.getCulture(<function> callback);
Parameter | Description
callback | A function with one parameter. Is called with a languagecode2-country/regioncode2 string ("de-DE", "en-US" or "en", for example) upon receiving the selection information from the server.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.Selection.setCulture Method

Sets the selection culture. Takes a languagecode2-country/regioncode2 string ("de-DE", "en-US" or "en", for example) as a parameter.

Syntax

<void> Selection.setCulture(<String> culture);
Parameter | Description
culture | A languagecode2-country/regioncode2 string. (e. g. "de-DE", "en-US", "en" etc.)

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.SelectionBounds Object

Is used with the setter of the selection property of the TextPart object.

Introduced: 24.0.

Syntax

{
    start: <number>,
    length: <number>
}

Properties

Property | Description
length | The length of the selection in characters.
start | The 0-based start character position of the selection.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SelectionBounds.start Property

The 0-based start character position of the selection.

Syntax

<number> SelectionBounds.start

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SelectionBounds.length Property

The length of the selection in characters.

Syntax

<number> SelectionBounds.length

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.SubTextPartEventArgs Object

The event argument for the SubTextPart related events. (e. g. the subTextPartEntered event)

Introduced: 24.0.

Syntax

{
    id: <number>,
    start: <number>,
    length: <number>,
    name: <String>,
    number: <number>,
    nestedLevel: <number>
}

Properties

Property | Description
id | The subtextpart's identifier.
length | The length of the SubTextPart in characters.
name | The name of the subtextpart.
nestedLevel | The subtextpart's nested level.
number | The subtextpart's number.
start | The 1-based position of the first character which belongs to the subtextpart.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.id Property

The subtextpart's identifier. Must be a one-based value. A value of zero indicates that the subtextpart has no identifier.

Syntax

<number> SubTextPartEventArgs.id

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.start Property

The 1-based position of the first character which belongs to the subtextpart.

Syntax

<number> SubTextPartEventArgs.start

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.length Property

The length of the SubTextPart in characters.

Syntax

<number> SubTextPartEventArgs.length

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.name Property

The name of the subtextpart. An empty string indicates that the subtextpart has no name.

Syntax

<String> SubTextPartEventArgs.name

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.number Property

The subtextpart's number. The first subtextpart has the number 1. The number is defined through the textflow. A textpart with a smaller start position has a smaller number. When an outer subtextpart has the same start position than one of its nested textparts the outer textpart has a smaller number.

Syntax

<number> SubTextPartEventArgs.number

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.SubTextPartEventArgs.nestedLevel Property

The subtextpart's nested level. The top level is 1.

Syntax

<number> SubTextPartEventArgs.nestedLevel

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.TextDroppedEventArgs Object

The event argument object for the textDropped event.

Introduced: 23.0.

Syntax

{
    text: <String>,
    textType: <String>,   // "text/html", "text/rtf", "text/plain"
    cancel: <boolean>
}

Properties

Property | Description
cancel | Set this property to true to cancel the event.
text | The dropped text.
textType | The MIME type of the text.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextDroppedEventArgs.text Property

The dropped text.

Syntax

<String> TextDroppedEventArgs.text

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextDroppedEventArgs.textType Property

The MIME type of the text. (e. g. "text/html" or "text/plain")

Syntax

<String> TextDroppedEventArgs.textType

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextDroppedEventArgs.cancel Property

Set this property to true to cancel the event.

Syntax

<boolean> TextDroppedEventArgs.cancel

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.TextFieldEventArgs Object

The event argument object for text field related events. (e. g. the textFieldClicked event)

Introduced: 23.0.

Syntax

{
    fieldType: <String>    // "APPLICATIONFIELD" / "TEXTFIELD",
    fieldName: <String>,
    typeName: <String>,    // null / "MERGEFIELD" / "DATE" / "NEXTIF" etc.,
    start: <number>,
    length: <number>,
    id: <number>,
    parameters: <String[]>
}

Properties

Property | Description
fieldName | The field's name.
fieldType | The field type ("APPLICATIONFIELD" or "TEXTFIELD").
id | The identifier of the text field.
length | The number of characters in the text field.
parameters | A string array of the field's parameters, if fieldType is "APPLICATIONFIELD".
start | The 1-based first character position of the text field.
typeName | The merge field type in case of field type "APPLICATIONFIELD" ("MERGEFIELD", "DATE", "NEXTIF" etc.).

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.fieldType Property

The field type ("APPLICATIONFIELD" or "TEXTFIELD").

Syntax

<String> TextFieldEventArgs.fieldType

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.fieldName Property

The field's name.

Syntax

<String> TextFieldEventArgs.fieldName

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.typeName Property

The merge field type in case of field type "APPLICATIONFIELD" ("MERGEFIELD", "DATE", "NEXTIF" etc.). Is null in case of field type "TEXTFIELD".

Syntax

<String> TextFieldEventArgs.typeName

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.start Property

The 1-based first character position of the text field.

Syntax

<number> TextFieldEventArgs.start

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.length Property

The number of characters in the text field.

Syntax

<number> TextFieldEventArgs.length

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.id Property

The identifier of the text field.

Syntax

<number> TextFieldEventArgs.length

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextFieldEventArgs.parameters Property

A string array of the field's parameters, if fieldType is "APPLICATIONFIELD". Otherwise this array is empty.

Syntax

<String[]> TextFieldEventArgs.parameters

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.TextPart Object

The callback function argument for the getTextParts function.

Introduced: 24.0.

Syntax

{
    type: <String>,     // "mainText", "headerFooter", "textFrame"
    index: <number>,
    selection: <Property>
}

Properties

Property | Description
index | The 0-based index of the text part.
selection | The getter returns an object of type Selection.
type | The Text part type.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextPart.type Property

The Text part type. Possible values are "mainText", "headerFooter" and "textFrame".

Syntax

<Strign> TextPart.type

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextPart.index Property

The 0-based index of the text part.

Syntax

<number> TextPart.index

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.TextPart.selection Property

The getter returns an object of type Selection. The setter changes the selection to a given start position and a given length using an object of type SelectionBounds.

Syntax

<Selection> TextPart.selection {
   get: function () { ... }
   set: function (<SelectionBounds> bounds) { ... }
}

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.WebSocketClosedEventArgs Object

The event argument object for the webSocketClosed event.

Introduced: 24.0.

Syntax

{
    code: <number>,
    reason: <String>,
    wasClean: <boolean>
}

Properties

Property | Description
code | The close code sent by the server.
reason | The reason the server closed the connection.
wasClean | Indicates whether or not the connection was cleanly closed.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.WebSocketClosedEventArgs.code Property

The close code sent by the server.

Syntax

<number> WebSocketClosedEventArgs.code

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.WebSocketClosedEventArgs.reason Property

The reason the server closed the connection. This is specific to the particular server and sub-protocol.

Syntax

<String> WebSocketClosedEventArgs.reason

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Javascript: TXTextControl.WebSocketClosedEventArgs.wasClean Property

Indicates whether or not the connection was cleanly closed.

Syntax

<boolean> WebSocketClosedEventArgs.wasClean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl namespace

Enumerations

TXTextControl.AdaptFontEventArgs Class

TXTextControl.ApplicationField Class

TXTextControl.ApplicationFieldCollection Class

TXTextControl.AutoSize Class

TXTextControl.BookmarkDialog Class

TXTextControl.ButtonBar Class

TXTextControl.ButtonBar.Colors Class

TXTextControl.DeleteBookmarksDialog Class

TXTextControl.DigitalSignature Class

TXTextControl.DocumentLink Class

TXTextControl.DocumentLinkCollection Class

TXTextControl.DocumentLinkEventArgs Class

TXTextControl.DocumentTarget Class

TXTextControl.DocumentTargetCollection Class

TXTextControl.FilterException Class

TXTextControl.FontSettings Class

TXTextControl.FormattingStyle Class

TXTextControl.FormattingStyleCollection Class

TXTextControl.FrameBase Class

TXTextControl.FrameBaseCollection Class

TXTextControl.FrameCollection Class

TXTextControl.FrameEventArgs Class

TXTextControl.GotoDialog Class

TXTextControl.HeaderFooter Class

TXTextControl.HeaderFooterCollection Class

TXTextControl.HeaderFooterEventArgs Class

TXTextControl.HyperlinkDialog Class

TXTextControl.HypertextLink Class

TXTextControl.HypertextLinkCollection Class

TXTextControl.HypertextLinkEventArgs Class

TXTextControl.HyphenateWordEventArgs Class

TXTextControl.IFormattedText Interface

TXTextControl.Image Class

TXTextControl.ImageCollection Class

TXTextControl.ImageEventArgs Class

TXTextControl.InlineStyle Class

TXTextControl.InlineStyleCollection Class

TXTextControl.InputFormat class

TXTextControl.InputPosition Class

TXTextControl.LicenseLevelException Class

TXTextControl.Line Class

TXTextControl.LineCollection Class

TXTextControl.ListFormat Class

TXTextControl.LoadSettings Class

TXTextControl.MainText

TXTextControl.MisspelledWord Class

TXTextControl.MisspelledWordCollection Class

TXTextControl.Page Class

TXTextControl.PageBorder class

TXTextControl.PageCollection Class

TXTextControl.PageMargins Class

TXTextControl.PageNumberField Class

TXTextControl.PageNumberFieldCollection Class

TXTextControl.PageSize Class

TXTextControl.PaperSize Class

TXTextControl.Paragraph Class

TXTextControl.ParagraphCollection Class

TXTextControl.ParagraphFormat class

TXTextControl.ParagraphStyle Class

TXTextControl.ParagraphStyleCollection Class

TXTextControl.RulerBar Class

TXTextControl.RulerBar.Colors Class

TXTextControl.SaveSettings Class

TXTextControl.Section Class

TXTextControl.SectionCollection Class

TXTextControl.SectionFormat class

TXTextControl.Selection Class

TXTextControl.ServerTextControl Class

TXTextControl.SpellCheckTextEventArgs Class

TXTextControl.StatusBar Class

TXTextControl.StatusBar.Colors Class

TXTextControl.SubTextPart Class

TXTextControl.SubTextPartCollection Class

TXTextControl.SubTextPartEventArgs Class

TXTextControl.Table Class

TXTextControl.TableBaseCollection Class

TXTextControl.TableCell Class

TXTextControl.TableCellCollection Class

TXTextControl.TableCellFormat Class

TXTextControl.TableCollection Class

TXTextControl.TableColumn Class

TXTextControl.TableColumnCollection Class

TXTextControl.TableEventArgs Class

TXTextControl.TablePartCollection Class

TXTextControl.TableRow Class

TXTextControl.TableRowCollection Class

TXTextControl.TextChar Class

TXTextControl.TextCharCollection Class

TXTextControl.TextContextMenuEventArgs Class

TXTextControl.TextControl Class

TXTextControl.TextControl.Colors Class

TXTextControl.TextEditorException Class

TXTextControl.TextField Class

TXTextControl.TextFieldCollection Class

TXTextControl.TextFieldCollectionBase Class

TXTextControl.TextFieldEventArgs Class

TXTextControl.TextFrame Class

TXTextControl.TextFrameCollection Class

TXTextControl.TextFrameEventArgs Class

TXTextControl.TextPartCollection Class

TXTextControl.UserDefinedPropertyDictionary Class

TXTextControl.VersionInfo Class

TXTextControl.XmlElement Class

TXTextControl.XmlElementCollection Class

TXTextControl.XmlErrorEventArgs Class


Enumerations

TXTextControl.AppendSettings Enumeration

TXTextControl.ApplicationFieldFormat Enumeration

TXTextControl.AutoSizeDirection Enumeration

TXTextControl.BinaryStreamType Enumeration

TXTextControl.ContextMenuLocation Enumeration

TXTextControl.ControlChars Enumeration

TXTextControl.CursorKind Enumeration

TXTextControl.FrameInsertionMode Enumeration

TXTextControl.ClipboardFormat Enumeration

TXTextControl.Direction Enumeration

TXTextControl.FindOptions Enumeration

TXTextControl.HeaderFooterType Enumeration

TXTextControl.HorizontalAlignment Enumeration

TXTextControl.ImageInsertionMode Enumeration

TXTextControl.ListType Enumeration

TXTextControl.MisspelledWordKind Enumeration

TXTextControl.NumberFormat Enumeration

TXTextControl.PageContent Enumeration

TXTextControl.PermanentControlChar Enumeration

TXTextControl.SectionBreakKind Enumeration

TXTextControl.StreamType Enumeration

TXTextControl.StringStreamType Enumeration

TXTextControl.TableAddPosition Enumeration

TXTextControl.TextFieldPosition Enumeration

TXTextControl.TextFieldType Enumeration

TXTextControl.TextFrameInsertionMode Enumeration

TXTextControl.ZoomOption Enumeration

TXTextControl.ZOrder Enumeration


TXTextControl.AppendSettings Enumeration

Determines how text is appended to the document. The enumeration contains the following values:

Member | Description
None | The loaded text is inserted at the end of the last paragraph of the existing document.
StartWithNewParagraph | A new paragraph is created at the end of the document and the text is inserted in this paragraph.
StartWithNewSection | A new section is created at the end of the document and the text is inserted in this section.

See Also

  • TextControl.Append Method
  • WPF.TextControl.Append Method
  • ServerTextControl.Append Method


TXTextControl.ApplicationFieldFormat Enumeration

Determines the format of an ApplicationField. It depends on the application that supports the field. The enumeration contains the following values:

Member | Description
MSWord | The field is supported and defined through Microsoft Word.
HighEdit | The field is supported and defined through the Heiler HighEdit component.

See Also

  • ApplicationField Class
  • ApplicationField Constructor
  • ApplicationField.Format Property


TXTextControl.AutoSizeDirection Enumeration

Determines values for the AutoSize.AutoExpand and AutoSize.AutoShrink properties. The enumeration contains the following values:

Member | Description
None | The control does not shrink automatically.
Vertical | The control automatically shrinks vertically.
Horizontal | The control automatically shrinks horizontally.
Both | The control automatically shrinks in both directions.


TXTextControl.BinaryStreamType Enumeration

Determines a certain text format that must tbe stored in a one-dimensional byte array. The enumeration contains the following values:

Member | Description
AdobePDF | Specifies Adobe Portable Document Format (PDF). If a document is loaded, only the text is imported.
AdobePDFA | Specifies Adobe Portable Document Format Archive (PDF/A). This format can only be used in saving operations.
InternalFormat | Specifies the internal Text Control format. Text is stored in ANSI format.
InternalUnicodeFormat | Specifies the internal Text Control format. Text is stored in Unicode format.
MSWord | Specifies Microsoft Word format.
WordprocessingML | Specifies Microsoft Word format (Office Open XML version).

See Also

  • TextControl.Load Method
  • WPF.TextControl.Load Method
  • ServerTextControl.Load Method
  • TextControl.Save Method
  • WPF.TextControl.Save Method
  • ServerTextControl.Save Method


TXTextControl.ContextMenuLocation Enumeration

Determines the location in the document where a context menu will be shown. The enumeration contains the following values:

Introduced: 19.0.

Member | Description
TextSelection | The menu context is a text selection.
TextInputPosition | The menu context is the text input position.
Header | The menu context is the top page margin which contains a header.
NoHeader | The menu context is the top page margin which contains no header.
Footer | The menu context is the bottom page margin which contains a footer.
NoFooter | The menu context is the bottom page margin which contains no footer.
PageMargin | The menu context is the top or the bottom page margin.
PageNumberField | The menu context is a PageNumberField.
SelectedFrame | The menu context is a selected frame (text frame, image, chart or barcode).
Table | The menu context is a text selection or a text input position in a Table.
Field | The menu context is a text selection or a text input position in a TextField.
MisspelledWord | The menu context is a MisspelledWord.

See Also

  • TextContextMenuEventArgs class
  • TextControl.TextContextMenuOpening Event
  • WPF.TextControl.TextContextMenuOpening Event


TXTextControl.ControlChars Enumeration

Determines values for the control characters used in a TextControl document. The enumeration contains the following values:

Introduced: 23.0.

Member | Description
ParagraphEnd | Defines the end of a paragraph (Keyboard: ENTER).
LineBreak | Defines a line break without beginning a new paragraph (Keyboard: SHIFT+ENTER).
PageBreak | Defines a page break (Keyboard: CTRL+ENTER).
ColumnBreak | Defines a page column break (Keyboard: CTRL+SHIFT+ENTER).
Tab | Defines a tabulator (Keyboard: TAB).
NonBreakingSpace | Defines a non-breaking space (Keyboard: CTRL+SHIFT+Space).
NonVisibleHyphen | Defines a non-visible hyphen (Keyboard: CTRL+(-)).

See Also

  • TextCharCollection.Add Method


TXTextControl.CursorKind Enumeration

Determines the kind of the cursor at a certain location in a document. The enumeration contains the following values:

Introduced: 21.0.

Member | Description
IBeam | The cursor is an I-beam.
ArrowNE | The cursor is an arrow cursor pointing to northeast.
VSplit | The cursor is a vertical splitting cursor.
UpArrow | The cursor is an up arrow cursor.
Arrow | The cursor is a standard arrow cursor pointing to northwest.
DownArrow | The cursor is a down arrow cursor.
SizeWE | The cursor is a two-headed horizontal (west/east) sizing cursor.
SizeNS | The cursor is the two-headed vertical (north/south) sizing cursor.
SizeNWSE | The cursor is the two-headed diagonal (northwest/southeast) sizing cursor.
SizeNESW | The cursor is the two-headed diagonal (northeast/southwest) sizing cursor.
SizeAll | The cursor is the four-headed sizing cursor, which consists of four joined arrows that point north, south, east, and west.
Cross | The cursor is the crosshair cursor.
No | The cursor is the cursor that indicates that a particular region is invalid for the current operation.
DragDropCopy | The cursor is the standard cursor for copying data during a drag and drop operation.
DragDropMove | The cursor is the standard cursor for moving data during a drag and drop operation.

See Also

  • ServerVisualization.View.GetCursorKind Method


TXTextControl.FrameInsertionMode Enumeration

Determines how the frame of an image, text frame, chart, barcode or drawing can be inserted in the text. The enumeration contains the following values:

Member | Description
AsCharacter | The frame is inserted in the text as a single character.
DisplaceCompleteLines | The frame is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the frame.
DisplaceText | The frame is inserted at a certain geometrical location. The text flows around the frame and empty areas at the left and right side are filled.
AboveTheText | The frame is inserted at a certain geometrical location above the text. This means that the frame overwrites the text.
BelowTheText | The frame is inserted at a certain geometrical location below the text. This means that the text overwrites the frame.
MoveWithText | The frame is anchored to a paragraph and moved with the text.
FixedOnPage | The frame is fixed positioned on a page.

See Also

  • ChartCollection.Add Methods
  • BarcodeCollection.Add Methods
  • DrawingCollection.Add Methods
  • FrameBase.InsertionMode Property


TXTextControl.ClipboardFormat Enumeration

Determines a certain clipboard format that can be pasted into a TextControl document. The enumeration contains the following values:

Member | Description
Barcode | Specifies a barcode.
Chart | Specifies a chart.
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
Image | Specifies an image. An image can be pasted, if it is a device dependent or a device independent bitmap, a TIFF image or a Windows metafile.
PlainText | Specifies unformatted text.
RichTextFormat | Specifies RTF format (Rich Text Format).
TXTextControlFormat | Specifies formatted text in the internal TX Text Control format.
TXTextControlImage | Specifies an image including information about how the image is positioned in the document (inline or geometrically positioned).
TXTextControlTextframe | Specifies a TX Text Control textframe including its contents. The clipbord contains also information about how the textframe is positioned in the document (inline or geometrically positioned).

See Also

  • TextControl.GetClipboardFormats Method
  • WPF.TextControl.GetClipboardFormats Method
  • TextControl.Paste Method
  • WPF.TextControl.Paste Method


TXTextControl.Direction Enumeration

Determines the writing direction of a paragraph. The enumeration contains the following values:

Introduced: 20.0.

Member | Description
LeftToRight | The writing direction is left to right, which means that blocks of text with left to right and right to left characters are ordered from left to right.
RightToLeft | The writing direction is right to left, which means that blocks of text with left to right and right to left characters are ordered from right to left.

See Also

  • Selection.ChangeDirection Method
  • ParagraphFormat.Direction Property


TXTextControl.FindOptions Enumeration

Determines search options for the Find methods. The enumeration contains the following values:

Member | Description
MatchCase | Locates only instances of the search text that have the exact casing.
MatchWholeWord | Locates only instances of the search text which are whole words.
NoHighlight | The search text, if found, is not highlighted.
NoMessageBox | Does not display message boxes to inform about search results.
Reverse | The search starts at the end of the control's document and searches to the beginning of the document.

See Also

  • TextControl.Find Method
  • WPF.TextControl.Find Method
  • ServerTextControl.Find Method
  • HeaderFooter.Find Method
  • TextFrame.Find Method


TXTextControl.HeaderFooterType Enumeration

Determines the type of a header or footer. The enumeration contains the following values:

Member | Description
Header | The object is a header. When an even header exists, the object represents the odd header. Otherwise it represents the header of all pages.
FirstPageHeader | The object represents a special header of the document's or section's first page.
Footer | The object is a footer. When an even footer exists, this member represents the odd footer. Otherwise it represents the footer of all pages.
FirstPageFooter | The object represents a special footer of the document's or section's first page.
EvenHeader | The object represents an even header.
EvenFooter | The object represents an even footer.

See Also

  • HeaderFooter.Type Property
  • HeaderFooterCollection.Add Method
  • HeaderFooterCollection.GetItem Method
  • HeaderFooterCollection.Remove Method


TXTextControl.HorizontalAlignment Enumeration

Determines values for the horizontal alignment of the text or of text frames, images and charts. The enumeration contains the following values:

Member | Description
Left | The alignment is left aligned.
Right | The alignment right aligned.
Center | The alignment is centered.
Justify | The alignment is justified. This value is only used with text. It cannot be used with text frames, images and charts.

See Also

  • ParagraphFormat.Alignment Property
  • FrameBase.Alignment Property
  • ChartCollection.Add Method
  • ImageCollection.Add Method
  • TextFrameCollection.Add Method


TXTextControl.ImageInsertionMode Enumeration

Determines how an Image can be inserted in the text. The enumeration contains the following values:

Member | Description
AsCharacter | The image is inserted in the text as a single character.
DisplaceCompleteLines | The image is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the image.
DisplaceText | The image is inserted at a certain geometrical location. The text flows around the image and empty areas at the left and right side are filled.
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
MoveWithText | The image is anchored to a paragraph and moved with the text. This member cannot be used with the ImageCollection.Add methods.
FixedOnPage | The image is fixed positioned on a page. This member cannot be used with the ImageCollection.Add methods.

See Also

  • ImageCollection.Add Methods
  • Image.InsertionMode Property


TXTextControl.ListType Enumeration

Specifies the kind of a bulleted or numbered list. The enumeration contains the following values:

Member | Description
None | The text is neither a bulleted nor a numbered list.
Bulleted | The list is a bulleted list.
Numbered | The list is a numbered list.
Structured | The list is a structured list. All numbers of higher levels (lower level numbers) are displayed in front of the list number. The additional text of all levels in front and behind the list numbers is also displayed.

See Also

  • ListFormat Constructor
  • ListFormat.Type Property


TXTextControl.MisspelledWordKind Enumeration

Specifies the kind of a misspelled word. It is used to get misspelled words of a special kind from the TextControl.MisspelledWords collection. Special kinds of misspelled words are words which are marked as ignored or as duplicate. The enumeration contains the following values:

Introduced: 18.0.

Member | Description
All | Specifies all misspelled words.
Duplicate | Specifies all misspelled words which are marked as duplicate.
Ignored | Specifies all misspelled words which are marked as ignored.
Normal | Specifies all misspelled words which do not have a special meaning.

See Also

  • MisspelledWordCollection.GetItem Method


TXTextControl.NumberFormat Enumeration

Specifies the format of a numbered list. The enumeration contains the following values:

Member | Description
ArabicNumbers | The list is numbered with Arabic numbers (1, 2, 3...).
Letters | The list is numbered with letters (a, b, c...).
CapitalLetters | The list is numbered with capital letters (A, B, C...).
RomanNumbers | The list is numbered with Roman numbers (I, II, III...).
SmallRomanNumbers | The list is numbered with small Roman numbers (i, ii, iii...).
None | A text selection contains different number formats.

See Also

  • ListFormat.NumberFormat Property
  • InputFormat.NumberedListFormat Property
  • InputFormat.StructuredListFormat Property
  • PageNumberField.NumberFormat Property


TXTextControl.PageContent Enumeration

Defines the contents of a page's image returned from the Page.GetImage method. The enumeration contains the following values:

Member | Description
All | The image contains all parts without the screen elements.
Background | The image contains the background of the page.
HeadersAndFooters | The image contains the header and the footer of the page.
MainText | The image contains the page's text contents.
ScreenElements | The image contains all elements which are additionally displayed on a screen, such as the selection, the control characters and helper lines.

See Also

  • Page.GetImage Method


TXTextControl.PermanentControlChar Enumeration

Defines a control character which is shown permanently on the screen. The enumeration contains the following values, which can be combined with the bitwise OR operator:

Introduced: 19.0.

Member | Description
Space | Shows the control character of a space.
Tab | Shows the control character of a tabstop.
ParagraphEnd | Shows the control character for the end of a paragraph.
ForcedLineBreak | Shows the control character of a forced line break.
ObjectAnchor | Shows the anchor position of an image, text frame, chart, barcode or drawing.
ForcedPageBreak | Marks a forced page break.
SectionBreak | Marks a section break.
Hyphen | Shows the control character of a hyphen.
NonBreakingSpace | Shows the control character of a non-breaking space.
TableCellEnd | Shows the control character for the end of a table cell.
All | Shows all control characters.

See Also

  • TextControl.PermanentControlChars Property
  • WPF.TextControl.PermanentControlChars Property


TXTextControl.SectionBreakKind Enumeration

Specifies the kind of the section break. The enumeration contains the following values:

Member | Description
BeginAtNewLine | The section begins on the next line with a new paragraph.
BeginAtNewPage | The section begins on the next page with a new paragraph.

See Also

  • SectionCollection.Add Method
  • SectionFormat.BreakKind Property


TXTextControl.StreamType Enumeration

Determines a certain text format. The enumeration contains the following values:

Member | Description
AdobePDF | Specifies Adobe Portable Document Format (PDF). If a document is loaded, only the text is imported.
AdobePDFA | Specifies Adobe Portable Document Format Archive (PDF/A). This format can only be used in saving operations.
CascadingStylesheet | Specifies CSS format (Cascading Style Sheet). This format can only be used in saving operations.
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
InternalFormat | Specifies the internal Text Control format. Text is stored in ANSI format.
InternalUnicodeFormat | Specifies the internal Text Control format. Text is stored in Unicode format.
MSWord | Specifies Microsoft Word format (.DOC version).
PlainAnsiText | Specifies text in Windows ANSI format (an end of a paragraph is marked with the control characters 13 and 10).
PlainText | Specifies text in Windows Unicode format (an end of a paragraph is marked with the control characters 13 and 10).
RichTextFormat | Specifies RTF format (Rich Text Format).
WordprocessingML | Specifies Microsoft Word format (Office Open XML version).
XMLFormat | Specifies XML format (Extensible Markup Language).

See Also

  • TextControl.Load Method
  • WPF.TextControl.Load Method
  • ServerTextControl.Load Method
  • TextControl.Save Method
  • WPF.TextControl.Save Method
  • ServerTextControl.Save Method


TXTextControl.StringStreamType Enumeration

Determines a certain text format that can be stored as a string. The enumeration contains the following values:

Member | Description
CascadingStylesheet | Specifies CSS format (Cascading Style Sheet). This format can only be used in saving operations.
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
PlainText | Specifies Text in Windows Unicode format (an end of a paragraph is marked with the control characters 13 and 10).
RichTextFormat | Specifies RTF format (Rich Text Format).
XMLFormat | Specifies XML format (Extensible Markup Language).

See Also

  • TextControl.Load Method
  • WPF.TextControl.Load Method
  • ServerTextControl.Load Method
  • TextControl.Save Method
  • WPF.TextControl.Save Method
  • ServerTextControl.Save Method


TXTextControl.TableAddPosition Enumeration

Specifies the position where to add table rows and columns or where to split a table. The enumeration contains the following values:

Member | Description
Before | Table rows or columns are inserted or the table is split in front of the row or column with the current input position.
After | Table rows or columns are inserted or the table is split behind the row or column with the current input position.

See Also

  • Table.Split Method
  • TableColumnCollection.Add Method
  • TableRowCollection.Add Method


TXTextControl.TextFieldPosition Enumeration

Specifies special text input positions at the beginning and the end of a TextField. The enumeration contains the following values:

Member | Description
InsideTextField | The specified position is inside the field.
OutsideTextField | The specified position is outside the field.
InsideNextTextField | The specified position is inside the next field. This member is only possible, if there are two following text fields without any character bewteen the fields. In this case InsideTextField is in the first field, OutsideTextField is between the fields and InsideNextTextField is in the second field.

See Also

  • InputPosition Constructor


TXTextControl.TextFieldType Enumeration

Specifies types of text fields. The enumeration contains the following values:

Introduced: 24.0.

Member | Description
DocumentTarget | The field type is TXTextControl.DocumentTarget.
HypertextLink | The field type is TXTextControl.HypertextLink.
DocumentLink | The field type is TXTextControl.DocumentLink.
PageNumberField | The field type is TXTextControl.PageNumberField.
TextField | The field type is TXTextControl.TextField.
ApplicationField | The field type is TXTextControl.ApplicationField.
All | Specifies all types of text fields.

See Also

  • IFormattedText.GetTextFields Method


TXTextControl.TextFrameInsertionMode Enumeration

Determines how a TextFrame can be inserted in the text. The enumeration contains the following values:

Member | Description
AsCharacter | The text frame is inserted in the text as a single character.
DisplaceCompleteLines | The text frame is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the text frame.
DisplaceText | The text frame is inserted at a certain geometrical location. The text flows around the text frame and empty areas at the left and right side are filled.
AboveTheText | The text frame is inserted at a certain geometrical location above the text. This means that the text frame overwrites the text.
BelowTheText | The text frame is inserted at a certain geometrical location below the text. This means that the text overwrites the text frame.
MoveWithText | The text frame is anchored to a paragraph and moved with the text.
FixedOnPage | The text frame is fixed positioned on a page.

See Also

  • TextFrameCollection.Add Methods
  • TextFrame.InsertionMode Property


TXTextControl.ZoomOption Enumeration

Specifies options how to set the zoom factor of a TextControl.

Introduced: 24.0.

Member | Description
PageWidth | The zoom factor is calculated so that the complete width of a page becomes visible.
TextWidth | The zoom factor is calculated so that the complete text of a line becomes visible.
WholePage | The zoom factor is calculated so that the current visible page becomes completely visible.

See Also

  • TextControl.Zoom Method
  • WPF.TextControl.Zoom Method


TXTextControl.ZOrder Enumeration

Specifies how the z-order of a frame (image, text frame, chart, barcode or drawing) can be changed. The enumeration contains the following values:

Introduced: 18.0.

Member | Description
Bottom | If the frame is in front of the text, it becomes the bottommost of all objects in front of the text. If it is behind the text, it is becomes the bottommost of all objects.
BottomMost | The frame is moved behind the text below all other objects. This member is only possible, if the insertion mode is BehindTheText.
Down | The frame is moved down one plane. If it is the bottommost object in front of the text, it is not moved behind the text.
TopMost | The frame is moved in front of the text at the top of all other objects.
Top | If the frame is behind the text, it becomes the topmost of all objects behind the text. If it is in front of the text, it becomes the topmost of all objects.
Up | The frame is moved up one plane. If it is the topmost object behind the text, it is not moved in front of the text.

See Also

  • FrameBase.ChangeZOrder Method


TXTextControl.AdaptFontEventArgs Class

The AdaptFontEventArgs class provides data for the TextControl.AdaptFont, WPF.TextControl.AdaptFont and ServerTextControl.AdaptFont events.

Introduced: 15.0.

Syntax

[C#]
public class AdaptFontEventArgs: EventArgs
[Visual Basic]
Public Class AdaptFontEventArgs
  Inherits EventArgs

Properties

Property | Description
AdaptedFontName | Gets or sets the adapted font.
FontName | Gets the name of the original font which must be adapted.
SupportedFonts | Gets a list of all fonts currently supported.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AdaptFontEventArgs.AdaptedFontName Property

Gets or sets the adapted font. When the event occurs the property contains the name of the font which replaces the original font. If the property is changed, TextControl uses the changed font to replace the original font. The font must be one of the fonts listed in the array of supported fonts. This array can be obtained with the AdaptFontEventArgs.SupportedFonts property.

Syntax

[C#]
public string AdaptedFontName { get; set; }
[Visual Basic]
Public Property AdaptedFontName() As String

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AdaptFontEventArgs.FontName Property

Gets the name of the original font which must be adapted.

Syntax

[C#]
public string FontName { get; }
[Visual Basic]
Public ReadOnly Property FontName() As String

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AdaptFontEventArgs.SupportedFonts Property

Gets a list of all fonts currently supported.

Syntax

[C#]
public string[] SupportedFonts { get; }
[Visual Basic]
Public ReadOnly Property SupportedFonts() As String()

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ApplicationField Class

The ApplicationField class supports text field formats of applications such as Microsoft Word. The class only provides an interface to retrieve and change the data and parameters of such fields. The field logic itself is not implemented. Currently supported applications and components are Microsoft Word and Heiler HeighEdit. For more information see the technical article Text Fields and Hypertext Links - Importing Fields from Microsoft Word.

Introduced: 14.0.

Syntax

[C#]
public class ApplicationField : TextField
[Visual Basic]
Public Class ApplicationField
  Inherits TextField

Constructors

Constructor | Description
ApplicationField | Initializes a new instance of the ApplicationField class.

Properties

Property | Description
Bounds | Gets the bounding rectangle of a text field. (Inherited from TextField.)
ContainsInputPosition | Returns true, if the Textfield contains the current text input position. (Inherited from TextField.)
Deleteable | Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
DoubleClickEvent | Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field. (Inherited from TextField.)
DoubledInputPosition | Specifies whether a text field has a doubled input position in front of its first character and behind its last character. (Inherited from TextField.)
Editable | Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
Format | Gets or sets the field's format.
FormattingBounds | Gets the formatting rectangle of a text field. (Inherited from TextField.)
ID | Gets or sets an identifier for a text field. (Inherited from TextField.)
IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words. (Inherited from TextField.)
Length | Gets the number of characters in a text field. (Inherited from TextField.)
Name | Relates a user-defined name to a text field. (Inherited from TextField.)
Parameters | Gets or sets the field's parameters.
ShowActivated | Specifies whether a text field toggles its background to gray, if the current input position is in the field. (Inherited from TextField.)
Start | Gets the first character position (one-based) of a text field. (Inherited from TextField.)
Text | Returns or sets the text which is contained within a text field. (Inherited from TextField.)
TypeName | Gets or sets the field's type name.

Methods

Method | Description
ScrollTo | Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document. (Inherited from TextField.)

Example

The following example shows how to insert a new ApplicationField of type Microsoft Word.

[C#]
TXTextControl.ApplicationField myAppField = new TXTextControl.ApplicationField(
  TXTextControl.ApplicationFieldFormat.MSWord,
  "MERGEFIELD",
  "New ApplicationField",
  new string[] {"FieldName"});

textControl1.ApplicationFields.Add(myAppField);

[Visual Basic]
Dim MyAppField As TXTextControl.ApplicationField = New TXTextControl.ApplicationField( _
  TXTextControl.ApplicationFieldFormat.MSWord, _
  "MERGEFIELD", _
  "New ApplicationField", _
  New String() {"FieldName"})

TextControl1.ApplicationFields.Add(MyAppField)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationField Constructor

Initializes a new instance of the ApplicationField class. The format of the parameters depends on the application that supports the field. The field is initialized without syntax check.

Syntax

[C#]
public ApplicationField(ApplicationFieldFormat format, string typeName, string text, string[] parameters);
[Visual Basic]
Public Sub New(ByVal format As ApplicationFieldFormat, ByVal typeName As String, ByVal text As String, ByVal parameters As String())
Parameter | Description
format | Specifies the format of the field. The format depends on the application that supports the field. It can be a one of the ApplicationFieldFormat values.
typeName | Specifies the type name of the field. For example the type name of a Microsoft Word MergeField is MERGEFIELD.
text | Specifies the visible text of the field.
parameters | Specifies an array of strings which are the field's parameters. The order and format of the strings depend on the field's format. For example a Microsoft Word MergeField has the following format: MERGEFIELD FieldName [switches]. In this case the first string of the array is the FieldName and the following strings are possible switches. If a field has no parameters, null can be specified.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationField.Format Property

Gets or sets the field's format. The property's value can be one of the ApplicationFieldFormat values. If the format of the field is changed, its type name and parameters must also be changed.

Syntax

[C#]
public ApplicationFieldFormat Format { get; set; }
[Visual Basic]
Public Property Format() As ApplicationFieldFormat
Value | Description
MSWord | The field is supported and defined through Microsoft Word.
HighEdit | The field is supported and defined through the Heiler HighEdit component.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationField.TypeName Property

Gets or sets the field's type name. For example for the type name of a Microsoft Word MergeField is MERGEFIELD. If the type name of the field is changed, its parameters must also be changed.

Syntax

[C#]
public string TypeName { get; set; }
[Visual Basic]
Public Property TypeName() As String

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationField.Parameters Property

Gets or sets the field's parameters. The order and format of the strings depend on the field's format. For example a Microsoft Word MergeField has the following format: MERGEFIELD FieldName [switches]. In this case the first string of the array is the FieldName and the following strings are possible switches. The string MERGEFIELD is the type name of the field and can be obtained through the ApplicationField.TypeName property. If a field has no parameters, this array is null.

Syntax

[C#]
public string[] Parameters { get; set; }
[Visual Basic]
Public Property Parameters() As String()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection Class

An instance of the ApplicationFieldCollection class contains all created or imported Microsoft Word or Heiler HighEdit fields represented through objects of the type ApplicationField. An instance of this class can be obtained with the TextControl.ApplicationFields property. The collection can contain fields in different formats. Currently supported formats are Microsoft Word fields and Heiler HighEdit fields. The ApplicationFieldCollection class implements the IEnumerable and the ICollection interfaces. For more information see the technical article Text Fields and Hypertext Links - Importing Fields from Microsoft Word.

Introduced: 14.0.

Syntax

[C#]
public sealed class ApplicationFieldCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class ApplicationFieldCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts a new object of the type ApplicationField at the current input position.
Clear | Removes all fields of the type ApplicationField from a TX Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular field of the type ApplicationField from the collection.
Remove | Overloaded. Removes a field of the type ApplicationField from a TX Text Control document.

Example

The following example iterates through all fields and sets the visible text of the address field:

[C#]
foreach (TXTextControl.ApplicationField myApplicationField in textControl1.ApplicationFields)
{
  if (myApplicationField.TypeName == "MERGEFIELD" && myApplicationField.Parameters[0] == "Address")
  {
    myApplicationField.Text = "Bakerstreet, London";
  }
}
[Visual Basic]
For Each MyApplicationField As TXTextControl.ApplicationField In TextControl1.ApplicationFields
  If MyApplicationField.TypeName = "MERGEFIELD" And MyApplicationField.Parameters(0) = "Address" Then
    MyApplicationField.Text = "Bakerstreet, London"
  End If
Next

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection.Add Method

Inserts a new object of the type ApplicationField at the current input position.

Syntax

[C#]
public bool Add(ApplicationField applicationField);
[Visual Basic]
Public Function Add(ByVal applicationField As ApplicationField) As Boolean
Parameter | Description
applicationField | Specifies the field to add.

Return Value

The return value is true, if the field could be added. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection.Clear Method

Removes all fields of the type ApplicationField from a TX Text Control document.

Syntax

[C#]
public void Clear(bool keepText);
[Visual Basic]
Public Sub Clear(ByVal keepText As Boolean)
Parameter | Description
keepText | If this parameter is set to true, all fields are removed without deleting their visible text. Otherwise, the visible text is also deleted.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection.GetItem Method

Gets a particular field of the type ApplicationField from the collection.

GetItem()

Gets the field at the current input position or null, if there is no such field at the current input position.

[C#]
public ApplicationField GetItem();
[Visual Basic]
Public Function GetItem() As ApplicationField

GetItem(Int32)

Gets the field with the specified id, previously set with the ID property.

[C#]
public ApplicationField GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As ApplicationField
Parameter | Description
id | Specifies the field's identifier set with the ID property. The method returns null, if a field of the type ApplicationField with the specified identifier does not exist.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ApplicationFieldCollection.Remove Method

Removes a field of the type ApplicationField from a TX Text Control document.

Remove(ApplicationField)

Removes a field of the type ApplicationField including its visible text from a TX Text Control document.

[C#]
public bool Remove(ApplicationField applicationField);
[Visual Basic]
Public Function Remove(ByVal applicationField As ApplicationField) As Boolean
Parameter | Description
applicationField | Specifies the field to remove.

Remove(ApplicationField, Boolean)

Removes a field of the type ApplicationField from a TX Text Control document. The visible text is deleted depending on the keepText parameter.

[C#]
public bool Remove(ApplicationField applicationField, bool keepText);
[Visual Basic]
Public Function Remove(ByVal applicationField As ApplicationField, ByVal keepText As Boolean) As Boolean
Parameter | Description
applicationField | Specifies the field to remove.
keepText | If this parameter is set to true, the field is removed without deleting its visible text. Otherwise, the field's text is also deleted.

Return Value

The return value is true, if the field could be removed. Otherwise, it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.AutoSize Class

The AutoSize class is used with the TextControl.AutoControlSize property, to enable automatic expansion or shrinking of a Text Control's width or height. Additionally, it contains properties for setting maximum and minimum values. Automatic expansion or shrinking is only possible, if the TextControl.ViewMode property has been set to SimpleControl.

Introduced: 11.0.

Syntax

[C#]
public class AutoSize
[Visual Basic]
Public Class AutoSize

Constructors

Constructor | Description
AutoSize | Initializes a new instance of the AutoSize class.

Properties

Property | Description
AutoExpand | Gets or sets possible directions for expanding the control.
AutoShrink | Gets or sets possible directions for shrinking the control.
MaxSize | Gets or sets the maximum size, in pixels, for expanding the control.
MinSize | Gets or sets the minimum size, in pixels, for shrinking the control.

Example

The following example shows how to set up a TextControl that expands and shrinks horizontally with a maximum size of 600 pixels.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.SimpleControl;
textControl1.AutoControlSize.AutoExpand = TXTextControl.AutoSizeDirection.Horizontal;
textControl1.AutoControlSize.AutoShrink = TXTextControl.AutoSizeDirection.Horizontal;
textControl1.AutoControlSize.MaxSize = new Size(600, 600);
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.SimpleControl
TextControl1.AutoControlSize.AutoExpand = TXTextControl.AutoSizeDirection.Horizontal
TextControl1.AutoControlSize.AutoShrink = TXTextControl.AutoSizeDirection.Horizontal
TextControl1.AutoControlSize.MaxSize = New Size(600, 600)

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AutoSize Constructor

Initializes a new instance of the AutoSize class. The constructor offers the individual setting of all features.

Syntax

[C#]
public AutoSize(AutoSizeDirection expand, AutoSizeDirection shrink, System.Drawing.Size maxSize, System.Drawing.Size minSize);
[Visual Basic]
Public Sub New(ByVal expand As AutoSizeDirection, ByVal shrink As AutoSizeDirection, ByVal maxSize As System.Drawing.Size, ByVal minSize As System.Drawing.Size)
Parameter | Description
expand | Specifies possible directions for expanding the control. It can be one of the AutoSizeDirection values.
shrink | Specifies possible directions for shrinking the control. It can be one of the AutoSizeDirection values.
maxSize | Specifies the maximum size, in twips, for expanding the control.
minSize | Specifies the minimum size, in twips, for shrinking the control.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AutoSize.AutoExpand Property

Gets or sets possible directions for expanding the control.

Syntax

[C#]
public AutoSizeDirection AutoExpand { get; set; }
[Visual Basic]
Public Property AutoExpand() As AutoSizeDirection
Value | Description
None | The control does not expand automatically.
Vertical | The control automatically expands vertically.
Horizontal | The control automatically expands horizontally.
Both | The control automatically expands in both directions.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AutoSize.AutoShrink Property

Gets or sets possible directions for shrinking the control.

Syntax

[C#]
public AutoSizeDirection AutoShrink { get; set; }
[Visual Basic]
Public Property AutoShrink() As AutoSizeDirection
Value | Description
None | The control does not shrink automatically.
Vertical | The control automatically shrinks vertically.
Horizontal | The control automatically shrinks horizontally.
Both | The control automatically shrinks in both directions.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AutoSize.MaxSize Property

Gets or sets the maximum size, in pixels, for expanding the control. A control's width or hight cannot be larger than short.MaxValue.

Syntax

[C#]
public System.Drawing.Size MaxSize { get; set; }
[Visual Basic]
Public Property MaxSize() As System.Drawing.Size

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.AutoSize.MinSize Property

Gets or sets the minimum size, in pixels, for shrinking the control. A control's width or hight cannot be smaller than the region covered by one character, so that at least one character remains visible.

Syntax

[C#]
public System.Drawing.Size MinSize { get; set; }
[Visual Basic]
Public Property MinSize() As System.Drawing.Size

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.BookmarkDialog Class

The BookmarkDialog class implements a Windows Forms dialog box to insert a DocumentTarget at the current input position. If there is a target at the current input position, the name of the target is shown and can be edited. The dialog box can only be opened, if either DocumentTargetCollection.CanAdd returns true or if DocumentTargetCollection.GetItem() does not return null. Otherwise, an exception occurs. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the BookmarkDialog.DialogItem enumeration. The BookmarkDialog.FindItem method can be used to get a certain item and manipulate, move or delete it. The BookmarkDialog is a modal dialog box which must be shown with the BookmarkDialog.ShowDialog method.

Introduced: 23.0.

Syntax

[C#]
public class BookmarkDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class BookmarkDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
BookmarkDialog | Creates a BookmarkDialog object for the specified Windows Forms TextControl.

Methods

Method | Description
FindItem | Finds a control that has the provided identifier name.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a BookmarkDialog dialog box.

Example

The following example creates an BookmarkDialog object and shows the dialog box:

[C#]
BookmarkDialog dlg = new BookmarkDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New BookmarkDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.BookmarkDialog Constructor

Creates a BookmarkDialog object for the specified Windows Forms TextControl.

Syntax

[C#]
public BookmarkDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.BookmarkDialog.DialogItem Enumeration

Each DialogItem represents an item in a BookmarkDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The DialogItem enumeration can be used with the BookmarkDialog.FindItem method to get the item and manipulate it.

Member | Description
TXITEM_BookmarkNameLabel | Identifies the Bookmark Name label.
TXITEM_BookmarkName | Identifies the Bookmark Name text box.
TXITEM_Deletable | Identifies the Deletable check box.
TXITEM_OK | Identifies the OK button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.BookmarkDialog.FindItem Method

Finds a control that has the provided identifier name.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(BookmarkDialog.DialogItem dialogItem);
[Visual Basic]
Public Sub FindItem(ByVal dialogItem  As BookmarkDialog.DialogItem) As System.Windows.Forms.Control
Member | Description
dialogItem | The name of the requested control represented by an enum of type BookmarkDialog.DialogItem.

Return Value

The requested control if found. Otherwise null.

Example

The following example removes the 'Can be deleted during editing' check box from the BookmarkDialog object:

[C#]
Control ctrl = dlg.FindItem(TXTextControl.BookmarkDialog.DialogItem.TXITEM_Deletable);
ctrl.Parent.Controls.Remove(ctrl);
[Visual Basic]
Dim ctrl As Control = dlg.FindItem(TXTextControl.BookmarkDialog.DialogItem.TXITEM_Deletable)
ctrl.Parent.Controls.Remove(ctrl)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.ButtonBar Class

The ButtonBar class represents a Windows Forms tool bar which can be used to show or to set font and paragraph attributes of a Windows Forms TextControl. It is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the ButtonBar class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Syntax

[C#]
public class ButtonBar : Control
[Visual Basic]
Public Class ButtonBar
  Inherits Control

Properties

Property | Description
BorderStyle | Gets or sets the border style of the button bar.
ButtonOffsets | Gets or sets an array of additional offsets, in pixels, between the buttons.
ButtonPositions | Gets or sets an array of buttons the button bar consists of.
ButtonSeparators | Gets or sets an array of boolean values specifying whether or not a separator is drawn between two buttons.
ButtonStyle | Gets or sets the painting style of the buttons.
DisplayColors | Gets or sets the colors of the button bar.
ReadOnly | Gets or sets a value determining the button bar's read only mode.

Methods

Method | Description
ResetButtonOffsets | Resets the offset array to its default state.
ResetButtonPositions | Resets the button array to its default state.
ResetButtonSeparators | Resets the separator array to its default state.
ResetDisplayColors | Resets all display colors of a button bar to their system dependent default values.

Example

The following example shows how to set up a ButtonBar with just 2 specific buttons.

[C#]
buttonBar1.ButtonPositions = new TXTextControl.Button[] {
                             TXTextControl.Button.FontBoldButton,
                             TXTextControl.Button.FontItalicButton };
[Visual Basic]
ButtonBar1.ButtonPositions = New TXTextControl.Button() { _
                             TXTextControl.Button.FontBoldButton, _
                             TXTextControl.Button.FontItalicButton }

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.BorderStyle Property

Gets or sets the border style of the button bar.

Syntax

[C#]
public ButtonBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle() As ButtonBarBorderStyle
Value | Description
ColorScheme | The button bar has no border and a light to dark variation in background color. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Fixed3D | The button bar has a border with a single line and a 3D visual effect.
FixedSingle | The button bar has a border with a single line.
Flat | The button bar has no border.
Simple3D | The button bar has a no border but a 3D visual effect.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ButtonOffsets Property

Gets or sets an array of additional offsets, in pixels, between the buttons. The maximum size of the array is 31.

Syntax

[C#]
public int[] ButtonOffsets { get; set; }
[Visual Basic]
Public Property ButtonOffsets() As Integer()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ButtonPositions Property

Gets or sets an array of buttons the button bar consists of. The maximum size of the array is 31 buttons.

Syntax

[C#]
public Button[] ButtonPositions { get; set; }
[Visual Basic]
Public Property ButtonPositions() As Button()
Value | Description
StyleComboBox | Specifies a combobox containing the document's formatting styles.
FontNameComboBox | Specifies a combobox containing all fonts of the current formatting device.
FontSizeComboBox | Specifies a combobox containing all sizes of the current font.
FontBoldButton | Specifies a button for setting the font bold attribute.
FontItalicButton | Specifies a button for setting the font italic attribute.
FontUnderlineButton | Specifies a button for setting the font underline attribute.
AlignmentLeftButton | Specifies a button for setting a left aligned paragraph.
AlignmentRightButton | Specifies a button for setting a right aligned paragraph.
AlignmentCenteredButton | Specifies a button for setting a centered paragraph.
AlignmentJustifiedButton | Specifies a button for setting a justified paragraph.
ListBulletedButton | Specifies a button for setting a bulleted list.
ListNumberedButton | Specifies a button for setting a numbered list.
ListStructuredButton | Specifies a button for setting a structured numbered list.
ZoomComboBox | Specifies a combobox for setting the current zoom factor.
ControlCharsButton | Specifies a button for showing or hiding control characters.
TabLeftButton | Specifies a button for selecting a left aligned tab.
TabRightButton | Specifies a button for selecting a right aligned tab.
TabCenteredButton | Specifies a button for selecting a centered tab.
TabDecimalButton | Specifies a button for selecting a decimal tab.
XMLAddElementComboBox | Specifies a combobox for inserting XML elements.
XMLRemoveElementComboBox | Specifies a combobox for deleting XML elements.
StrikeOutButton | Specifies a button for setting the font strike out attribute.
SubscriptButton | Specifies a button for setting the baseline of selected text to subscript.
SuperscriptButton | Specifies a button for setting the baseline of selected text to superscript.
GrowFontSizeButton | Specifies a button for growing the font size.
ShrinkFontSizeButton | Specifies a button for shrinking the font size.
IncreaseIndentButton | Specifies a button for increasing a paragraph's indent.
DecreaseIndentButton | Specifies a button for decreasing a paragraph's indent.
LeftToRightButton | Specifies a button to set a paragraph's text direction from left to right.
RightToLeftButton | Specifies a button to set a paragraph's text direction from right to left.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ButtonSeparators Property

Gets or sets an array of boolean values specifying whether or not a separator is drawn between two buttons. The maximum size of the array is 31.

Syntax

[C#]
public bool[] ButtonSeparators { get; set; }
[Visual Basic]
Public Property ButtonSeparators() As Boolean()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ButtonStyle Property

Gets or sets the painting style of the buttons.

Syntax

[C#]
public ButtonStyle ButtonStyle { get; set; }
[Visual Basic]
Public Property ButtonStyle() As ButtonStyle
Value | Description
ColorScheme | Paints the button bar's buttons with a light to dark variation in color. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
FlatButtons | Paints the button bar's buttons without visual effects.
ThreeDimensionalButtons | Paints the button bar's buttons with 3D effects.
XPButtons | Paints the button bar's buttons in Windows XP look.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.DisplayColors Property

Gets or sets the colors of the button bar. These colors are only used when the BorderStyle and ButtonStyle properties have been set to ColorScheme. The property value is an object of the type ButtonBar.Colors.

Introduced: 15.1.

Syntax

[C#]
public ButtonBar.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As ButtonBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ReadOnly Property

Gets or sets a value determining the button bar's read only mode. When the button bar is set to read only, it still shows all formatting attributes of the connected TextControl, but formatting attributes cannot be changed.

Introduced: 24.0.

Syntax

[C#]
public bool ReadOnly { get; set; }
[Visual Basic]
Public Property ReadOnly As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ResetButtonOffsets Method

Resets the offset array to its default state.

Syntax

[C#]
public void ResetButtonOffsets();
[Visual Basic]
Public Sub ResetButtonOffsets()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ResetButtonPositions Method

Resets the button array to its default state.

Syntax

[C#]
public void ResetButtonPositions();
[Visual Basic]
Public Sub ResetButtonPositions()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ResetButtonSeparators Method

Resets the separator array to its default state.

Syntax

[C#]
public void ResetButtonSeparators();
[Visual Basic]
Public Sub ResetButtonSeparators()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.ResetDisplayColors Method

Resets all display colors of a button bar to their system dependent default values.

Introduced: 15.1.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors Class

The ButtonBar.Colors class gets, sets or resets the display colors of a Windows Forms ButtonBar control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the button bar's BorderStyle and ButtonStyle property have been set to ColorScheme.

Introduced: 15.1.

Syntax

[C#]
public class ButtonBar.Colors
[Visual Basic]
Public Class ButtonBar.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the ButtonBar.Colors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left edge of the button bar.
ButtonBackColorBottom | Gets or sets the background color at the bottom of a button.
ButtonBackColorMiddle | Gets or sets the background color in the middle of a button.
ButtonBackColorTop | Gets or sets the background color at the top of a button.
ButtonFrameColor | Gets or sets the frame color of a selected or pressed button.
ButtonHotTrackBottom | Gets or sets the background color at the bottom of a button, if the mouse cursor is over the button.
ButtonHotTrackTop | Gets or sets the background color at the top of a button, if the mouse cursor is over the button.
ButtonPressedBottom | Gets or sets the background color at the bottom of a button used when the button is pressed down.
ButtonPressedTop | Gets or sets the background color at the top of a button used when the button is pressed down.
ButtonSelectedBottom | Gets or sets the background color at the bottom of a button used when the button is selected.
ButtonSelectedTop | Gets or sets the background color at the top of a button used when the button is selected.
ComboBoxBackColor | Gets or sets the background color of the combo boxes.
ForeColor | Gets or sets the color used for text and the button images.
GradientBackColor | Gets or sets the background color at the right edge of the button bar.
SeparatorColorDark | Gets or sets the color of the dark part of a separator.
SeparatorColorLight | Gets or sets the color of the light part of a separator.

Methods

Method | Description
ResetBackColor | Resets the button bar's BackColor to its system dependent default value.
ResetButtonBackColorBottom | Resets the button bar's ButtonBackColorBottom to its system dependent default value.
ResetButtonBackColorMiddle | Resets the button bar's ButtonBackColorMiddle to its system dependent default value.
ResetButtonBackColorTop | Resets the button bar's ButtonBackColorTop to its system dependent default value.
ResetButtonFrameColor | Resets the button bar's ButtonFrameColor to its system dependent default value.
ResetButtonHotTrackBottom | Resets the button bar's ButtonHotTrackBottom to its system dependent default value.
ResetButtonHotTrackTop | Resets the button bar's ButtonHotTrackTop to its system dependent default value.
ResetButtonPressedBottom | Resets the button bar's ButtonPressedBottom to its system dependent default value.
ResetButtonPressedTop | Resets the button bar's ButtonPressedTop to its system dependent default value.
ResetButtonSelectedBottom | Resets the button bar's ButtonSelectedBottom to its system dependent default value.
ResetButtonSelectedTop | Resets the button bar's ButtonSelectedTop to its system dependent default value.
ResetComboBoxBackColor | Resets the button bar's ComboBoxBackColor to its system dependent default value.
ResetForeColor | Resets the button bar's ForeColor to its system dependent default value.
ResetGradientBackColor | Resets the button bar's GradientBackColor to its system dependent default value.
ResetSeparatorColorDark | Resets the button bar's SeparatorColorDark to its system dependent default value.
ResetSeparatorColorLight | Resets the button bar's SeparatorColorLight to its system dependent default value.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors Constructor

Initializes a new instance of the ButtonBar.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the ButtonBar.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public ButtonBar.Colors();
[Visual Basic]
Public Class ButtonBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.BackColor Property

Gets or sets the background color at the left edge of the button bar.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonBackColorBottom Property

Gets or sets the background color at the bottom of a button.

Syntax

[C#]
public Color ButtonBackColorBottom { get; set; }
[Visual Basic]
Public Property ButtonBackColorBottom As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonBackColorMiddle Property

Gets or sets the background color in the middle of a button.

Syntax

[C#]
public Color ButtonBackColorMiddle { get; set; }
[Visual Basic]
Public Property ButtonBackColorMiddle As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonBackColorTop Property

Gets or sets the background color at the top of a button.

Syntax

[C#]
public Color ButtonBackColorTop { get; set; }
[Visual Basic]
Public Property ButtonBackColorTop As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonHotTrackBottom Property

Gets or sets the background color at the bottom of a button, if the mouse cursor is over the button.

Syntax

[C#]
public Color ButtonHotTrackBottom { get; set; }
[Visual Basic]
Public Property ButtonHotTrackBottom As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonHotTrackTop Property

Gets or sets the background color at the top of a button, if the mouse cursor is over the button.

Syntax

[C#]
public Color ButtonHotTrackTop { get; set; }
[Visual Basic]
Public Property ButtonHotTrackTop As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonSelectedBottom Property

Gets or sets the background color at the bottom of a button used when the button is selected.

Syntax

[C#]
public Color ButtonSelectedBottom { get; set; }
[Visual Basic]
Public Property ButtonSelectedBottom As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonSelectedTop Property

Gets or sets the background color at the top of a button used when the button is selected.

Syntax

[C#]
public Color ButtonSelectedTop { get; set; }
[Visual Basic]
Public Property ButtonSelectedTop As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonPressedBottom Property

Gets or sets the background color at the bottom of a button used when the button is pressed down.

Syntax

[C#]
public Color ButtonPressedBottom { get; set; }
[Visual Basic]
Public Property ButtonPressedBottom As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonPressedTop Property

Gets or sets the background color at the top of a button used when the button is pressed down.

Syntax

[C#]
public Color ButtonPressedTop { get; set; }
[Visual Basic]
Public Property ButtonPressedTop As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ButtonFrameColor Property

Gets or sets the frame color of a selected or pressed button.

Syntax

[C#]
public Color ButtonFrameColor { get; set; }
[Visual Basic]
Public Property ButtonFrameColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ComboBoxBackColor Property

Gets or sets the background color of the combo boxes.

Syntax

[C#]
public Color ComboBoxBackColor { get; set; }
[Visual Basic]
Public Property ComboBoxBackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ForeColor Property

Gets or sets the color used for text and the button images.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.GradientBackColor Property

Gets or sets the background color at the right edge of the button bar.

Syntax

[C#]
public Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetBackColor Method

Resets the button bar's BackColor to its system dependent default value.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonBackColorBottom Method

Resets the button bar's ButtonBackColorBottom to its system dependent default value.

Syntax

[C#]
public void ResetButtonBackColorBottom();
[Visual Basic]
Public Sub ResetButtonBackColorBottom()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonBackColorMiddle Method

Resets the button bar's ButtonBackColorMiddle to its system dependent default value.

Syntax

[C#]
public void ResetButtonBackColorMiddle();
[Visual Basic]
Public Sub ResetButtonBackColorMiddle()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonBackColorTop Method

Resets the button bar's ButtonBackColorTop to its system dependent default value.

Syntax

[C#]
public void ResetButtonBackColorTop();
[Visual Basic]
Public Sub ResetButtonBackColorTop()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonHotTrackBottom Method

Resets the button bar's ButtonHotTrackBottom to its system dependent default value.

Syntax

[C#]
public void ResetButtonHotTrackBottom();
[Visual Basic]
Public Sub ResetButtonHotTrackBottom()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonHotTrackTop Method

Resets the button bar's ButtonHotTrackTop to its system dependent default value.

Syntax

[C#]
public void ResetButtonHotTrackTop();
[Visual Basic]
Public Sub ResetButtonHotTrackTop()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonSelectedBottom Method

Resets the button bar's ButtonSelectedBottom to its system dependent default value.

Syntax

[C#]
public void ResetButtonSelectedBottom();
[Visual Basic]
Public Sub ResetButtonSelectedBottom()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonSelectedTop Method

Resets the button bar's ButtonSelectedTop to its system dependent default value.

Syntax

[C#]
public void ResetButtonSelectedTop();
[Visual Basic]
Public Sub ResetButtonSelectedTop()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonPressedBottom Method

Resets the button bar's ButtonPressedBottom to its system dependent default value.

Syntax

[C#]
public void ResetButtonPressedBottom();
[Visual Basic]
Public Sub ResetButtonPressedBottom()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonPressedTop Method

Resets the button bar's ButtonPressedTop to its system dependent default value.

Syntax

[C#]
public void ResetButtonPressedTop();
[Visual Basic]
Public Sub ResetButtonPressedTop()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetButtonFrameColor Method

Resets the button bar's ButtonFrameColor to its system dependent default value.

Syntax

[C#]
public void ResetButtonFrameColor();
[Visual Basic]
Public Sub ResetButtonFrameColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetComboBoxBackColor Method

Resets the button bar's ComboBoxBackColor to its system dependent default value.

Syntax

[C#]
public void ResetComboBoxBackColor();
[Visual Basic]
Public Sub ResetComboBoxBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetForeColor Method

Resets the button bar's ForeColor to its system dependent default value.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetGradientBackColor Method

Resets the button bar's GradientBackColor to its system dependent default value.

Syntax

[C#]
public void ResetGradientBackColor();
[Visual Basic]
Public Sub ResetGradientBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetSeparatorColorDark Method

Resets the button bar's SeparatorColorDark to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorDark();
[Visual Basic]
Public Sub ResetSeparatorColorDark()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.ResetSeparatorColorLight Method

Resets the button bar's SeparatorColorLight to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorLight();
[Visual Basic]
Public Sub ResetSeparatorColorLight()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.SeparatorColorDark Property

Gets or sets the color of the dark part of a separator.

Syntax

[C#]
public Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.ButtonBar.Colors.SeparatorColorLight Property

Gets or sets the color of the light part of a separator.

Syntax

[C#]
public Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.DeleteBookmarksDialog Class

The DeleteBookmarksDialog class implements a Windows Forms dialog box which shows all targets in the current document. The user can jump to a target or can delete one or more targets. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the DeleteBookmarksDialog.DialogItem enumeration. The DeleteBookmarksDialog.FindItem method can be used to get a certain item and manipulate, move or delete it. The DeleteBookmarksDialog is a modal dialog box which must be shown with the DeleteBookmarksDialog.ShowDialog method.

Introduced: 23.0.

Syntax

[C#]
public class DeleteBookmarksDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class DeleteBookmarksDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
DeleteBookmarksDialog | Creates a DeleteBookmarksDialog object for the specified Windows Forms TextControl.

Methods

Method | Description
FindItem | Finds a control that has the provided identifier name.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a DeleteBookmarksDialog dialog box.

Example

The following example creates an DeleteBookmarksDialog object and shows the dialog box:

[C#]
DeleteBookmarksDialog dlg = new DeleteBookmarksDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New DeleteBookmarksDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DeleteBookmarksDialog Constructor

Creates a DeleteBookmarksDialog object for the specified Windows Forms TextControl.

Syntax

[C#]
public DeleteBookmarksDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DeleteBookmarksDialog.DialogItem Enumeration

Each DialogItem represents an item in a DeleteBookmarksDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The DialogItem enumeration can be used with the DeleteBookmarksDialog.FindItem method to get the item and manipulate it.

Member | Description
TXITEM_BookmarkListLabel | Identifies the bookmark list label.
TXITEM_BookmarkList | Identifies the bookmark listbox.
TXITEM_DeleteBookmark | Identifies the Delete button.
TXITEM_GotoBookmark | Identifies the Goto button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DeleteBookmarksDialog.FindItem Method

Finds a control that has the provided identifier name.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(DeleteBookmarksDialog.DialogItem dialogItem);
[Visual Basic]
Public Sub FindItem(ByVal dialogItem  As DeleteBookmarksDialog.DialogItem) As System.Windows.Forms.Control
Member | Description
dialogItem | The name of the requested control represented by an enum of type DeleteBookmarksDialog.DialogItem.

Return Value

The requested control if found. Otherwise null.

Example

The following example removes the 'Go To' button from the DeleteBookmarksDialog object:

[C#]
Control ctrl = dlg.FindItem(TXTextControl.DeleteBookmarksDialog.DialogItem.TXITEM_GotoBookmark);
ctrl.Parent.Controls.Remove(ctrl);
[Visual Basic]
Dim ctrl As Control = dlg.FindItem(TXTextControl.DeleteBookmarksDialog.DialogItem.TXITEM_GotoBookmark)
ctrl.Parent.Controls.Remove(ctrl)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DigitalSignature Class

An instance of the DigitalSignature class represents an X.509 certificate which can be used to digitally sign a PDF or PDF/A document. The DigitalSignature class is used with the SaveSettings.DigitalSignature property.

Introduced: 17.0.

Syntax

[C#]
public class DigitalSignature
[Visual Basic]
Public Class DigitalSignature

Constructors

Constructor | Description
DigitalSignature | Initializes a new instance of the DigitalSignature class.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.DigitalSignature Constructor

Initializes a new instance of the DigitalSignature class.

Syntax

[C#]
public DigitalSignature(System.Security.Cryptography.X509Certificates.X509Certificate2 x509, string timeServerURL);
[Visual Basic]
Public Sub New(ByVal x509 As System.Security.Cryptography.X509Certificates.X509Certificate2, ByVal timeServerURL As String)
Parameter | Description
x509 | Specifies an X509Certificate2 object which represents an X.509 certificate. This class can be found in the .net Framework in the namespace System.Security.Cryptography.
timeServerURL | Specifies the URL of a time server which is used to get a time stamp for the certification. If an empty string is specified, the current date and time on the computer is used.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.DocumentLink Class

The DocumentLink class represents a link in a Text Control document that points to a target in the same document. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public class DocumentLink : TextField
[Visual Basic]
Public Class DocumentLink
  Inherits TextField

Constructors

Constructor | Description
DocumentLink | Initializes a new instance of the DocumentLink class.

Properties

Property | Description
Bounds | Gets the bounding rectangle of a text field. (Inherited from TextField.)
ContainsInputPosition | Returns true, if the Textfield contains the current text input position. (Inherited from TextField.)
Deleteable | Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
DocumentTarget | Gets or sets an object of the type DocumentTarget specifying to where the link points.
DoubleClickEvent | Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field. (Inherited from TextField.)
DoubledInputPosition | Specifies whether a text field has a doubled input position in front of its first character and behind its last character. (Inherited from TextField.)
Editable | Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
FormattingBounds | Gets the formatting rectangle of a text field. (Inherited from TextField.)
ID | Gets or sets an identifier for a text field. (Inherited from TextField.)
IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words. (Inherited from TextField.)
Length | Gets the number of characters in a text field. (Inherited from TextField.)
Name | Relates a user-defined name to a text field. (Inherited from TextField.)
ShowActivated | Specifies whether a text field toggles its background to gray, if the current input position is in the field. (Inherited from TextField.)
Start | Gets the first character position (one-based) of a text field. (Inherited from TextField.)
Text | Returns or sets the text which is contained within a text field. (Inherited from TextField.)

Methods

Method | Description
ScrollTo | Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document. (Inherited from TextField.)

Example

The following example shows how to insert a DocumentTarget and a corresponding DocumentLink into a document.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.PageView;
textControl1.Text = "Page 1\fPage 2\fPage 3";
textControl1.Select(3, 0);

TXTextControl.DocumentTarget newTarget = new TXTextControl.DocumentTarget("Page1");

textControl1.DocumentTargets.Add(newTarget);
textControl1.InputPosition = new TXTextControl.InputPosition(2, 1, 3);
TXTextControl.DocumentLink newLink = new TXTextControl.DocumentLink("Jump to page 1", newTarget);
textControl1.DocumentLinks.Add(newLink);
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.PageView
TextControl1.Text = "Page 1" + Chr(12) + "Page 2" + Chr(12) + "Page 3"
TextControl1.Select(3, 0)

Dim newTarget As TXTextControl.DocumentTarget = New TXTextControl.DocumentTarget("Page1")

TextControl1.DocumentTargets.Add(newTarget)
TextControl1.InputPosition = New TXTextControl.InputPosition(2, 1, 3)
Dim newLink As TXTextControl.DocumentLink = New TXTextControl.DocumentLink("Jump to page 1", newTarget)
TextControl1.DocumentLinks.Add(newLink)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLink Constructor

Initializes a new instance of the DocumentLink class.

Syntax

[C#]
public DocumentLink(string text, DocumentTarget documentTarget);
[Visual Basic]
Public Sub New(ByVal text As String, ByVal documentTarget As DocumentTarget)
Parameter | Description
text | Specifies the visible text of the link.
documentTarget | Specifies an object of the type DocumentTarget specifying to where the link points.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLink.DocumentTarget Property

Gets or sets an object of the type DocumentTarget specifying to where the link points.

Syntax

[C#]
public DocumentTarget DocumentTarget { get; set; }
[Visual Basic]
Public Property DocumentTarget() As DocumentTarget

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection Class

An instance of the DocumentLinkCollection class contains all links in a Text Control document that point to targets in the same document. An instance of this class can be obtained with the TextControl.DocumentLinks property. The DocumentLinkCollection class implements the IEnumerable and the ICollection interfaces. Document links are represented through the DocumentLink class. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public sealed class DocumentLinkCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class DocumentLinkCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts a new document link at the current input position.
Clear | Removes all document links from a Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular document link from the collection.
Remove | Overloaded. Removes a document link from a Text Control document.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection.Add Method

Inserts a new document link at the current input position.

Syntax

[C#]
public bool Add(DocumentLink documentLink);
[Visual Basic]
Public Function Add(ByVal documentLink As DocumentLink) As Boolean
Parameter | Description
documentLink | Specifies the document link to add.

Return Value

The return value is true, if the document link could be added. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection.Clear Method

Removes all document links from a Text Control document.

Introduced: 13.0.

Syntax

[C#]
public void Clear(bool keepText);
[Visual Basic]
Public Sub Clear(ByVal keepText As Boolean)
Parameter | Description
keepText | If this parameter is set to true, all document links are removed without deleting their texts. Otherwise, the texts are also deleted.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection.GetItem Method

Gets a particular document link from the collection.

GetItem()

Gets the document link at the current input position or null if there is no document link at the current input position.

[C#]
public DocumentLink GetItem();
[Visual Basic]
Public Function GetItem() As DocumentLink

GetItem(Int32)

Gets the document link with the specified id, previously set with the DocumentLink.ID property.

[C#]
public DocumentLink GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As DocumentLink
Parameter | Description
id | Specifies the document link's identifier. The method returns null if a document link with the specified identifier does not exist.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkCollection.Remove Method

Removes a document link from a Text Control document.

Remove(DocumentLink)

Removes a document link including its visible text from a Text Control document.

[C#]
public bool Remove(DocumentLink documentLink);
[Visual Basic]
Public Function Remove(ByVal documentLink As DocumentLink) As Boolean
Parameter | Description
documentLink | Specifies the document link to remove.

Remove(DocumentLink, Boolean)

Removes a document link from a Text Control document. The visible text is deleted depending on the keepText parameter.

[C#]
public bool Remove(DocumentLink documentLink, bool keepText);
[Visual Basic]
Public Function Remove(ByVal documentLink As DocumentLink, ByVal keepText As Boolean) As Boolean
Parameter | Description
documentLink | Specifies the document link to remove.
keepText | If this parameter is set to true, the document link is removed without deleting its text. Otherwise, the link's text is also deleted.

Return Value

The return value is true, if the document link could be removed. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkEventArgs Class

The DocumentLinkEventArgs class provides data for the TextControl.DocumentLinkClicked event.

Syntax

[C#]
public class DocumentLinkEventArgs: EventArgs
[Visual Basic]
Public Class DocumentLinkEventArgs
  Inherits EventArgs

Properties

Property | Description
DocumentLink | Gets an object that represents the clicked document link.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentLinkEventArgs.DocumentLink Property

Gets an object that represents the clicked document link. It is of the type DocumentLink.

Syntax

[C#]
public DocumentLink DocumentLink { get; }
[Visual Basic]
Public ReadOnly Property DocumentLink() As DocumentLink

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTarget Class

The DocumentTarget class represents a text position in a Text Control document that is a target of a document link. Because a target cannot have visible text, the Textfield.Text property is not supported for this class. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public class DocumentTarget : TextField
[Visual Basic]
Public Class DocumentTarget
  Inherits TextField

Constructors

Constructor | Description
DocumentTarget | Initializes a new instance of the DocumentTarget class.

Properties

Property | Description
Bounds | Gets the bounding rectangle of a text field. (Inherited from TextField.)
ContainsInputPosition | Returns true, if the Textfield contains the current text input position. (Inherited from TextField.)
Deleteable | Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
DoubleClickEvent | Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field. (Inherited from TextField.)
DoubledInputPosition | Specifies whether a text field has a doubled input position in front of its first character and behind its last character. (Inherited from TextField.)
Editable | Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
FormattingBounds | Gets the formatting rectangle of a text field. (Inherited from TextField.)
ID | Gets or sets an identifier for a text field. (Inherited from TextField.)
IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words. (Inherited from TextField.)
Length | Gets the number of characters in a text field. (Inherited from TextField.)
Name | Relates a user-defined name to a text field. (Inherited from TextField.)
ShowActivated | Specifies whether a text field toggles its background to gray, if the current input position is in the field. (Inherited from TextField.)
Start | Gets the first character position (one-based) of a text field. (Inherited from TextField.)
TargetName | Gets or sets the name of the target.
Text | Returns or sets the text which is contained within a text field. (Inherited from TextField.)

Methods

Method | Description
ScrollTo | Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document. (Inherited from TextField.)

Example

The following example shows how to insert a DocumentTarget and a corresponding DocumentLink into a document.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.PageView;
textControl1.Text = "Page 1\fPage 2\fPage 3";
textControl1.Select(3, 0);

TXTextControl.DocumentTarget newTarget = new TXTextControl.DocumentTarget("Page1");

textControl1.DocumentTargets.Add(newTarget);
textControl1.InputPosition = new TXTextControl.InputPosition(2, 1, 3);
TXTextControl.DocumentLink newLink = new TXTextControl.DocumentLink("Jump to page 1", newTarget);
textControl1.DocumentLinks.Add(newLink);
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.PageView
TextControl1.Text = "Page 1" + Chr(12) + "Page 2" + Chr(12) + "Page 3"
TextControl1.Select(3, 0)

Dim newTarget As TXTextControl.DocumentTarget = New TXTextControl.DocumentTarget("Page1")

TextControl1.DocumentTargets.Add(newTarget)
TextControl1.InputPosition = New TXTextControl.InputPosition(2, 1, 3)
Dim newLink As TXTextControl.DocumentLink = New TXTextControl.DocumentLink("Jump to page 1", newTarget)
TextControl1.DocumentLinks.Add(newLink)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTarget Constructor

Initializes a new instance of the DocumentTarget class.

Syntax

[C#]
public DocumentTarget(string targetName);
[Visual Basic]
Public Sub New(ByVal targetName As String)
Parameter | Description
targetName | Specifies the name of the target.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTarget.TargetName Property

Gets or sets the name of the target.

Syntax

[C#]
public string TargetName { get; set; }
[Visual Basic]
Public Property TargetName() As String

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection Class

An instance of the DocumentTargetCollection class contains all targets in a Text Control document represented through objects of the type DocumentTarget. An instance of this class can only be obtained with the TextControl.DocumentTargets property. The DocumentTargetCollection class implements the IEnumerable and the ICollection interface. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public sealed class DocumentTargetCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class DocumentTargetCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts the specified target at the current input position.
Clear | Removes all document targets from a Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular document target from the collection.
Remove | Removes the specified target from a Text Control document.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection.Add Method

Inserts the specified target at the current input position.

Syntax

[C#]
public bool Add(DocumentTarget documentTarget);
[Visual Basic]
public function Add(DocumentTarget As documentTarget) As Boolean
Parameter | Description
documentTarget | Specifies the document target to add.

Return Value

The return value is true, if the document target could be added. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection.Clear Method

Removes all document targets from a Text Control document.

Introduced: 13.0.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection.GetItem Method

Gets a particular document target from the collection.

GetItem()

Gets the document target at the current input position or null if there is no document target at the current input position.

[C#]
public DocumentTarget GetItem();
[Visual Basic]
Public Function GetItem() As DocumentTarget

GetItem(Int32)

Gets the document target with the specified id, previously set with the DocumentTarget.ID property.

[C#]
public DocumentTarget GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As DocumentTarget
Parameter | Description
id | Specifies the document target's identifier. The method returns null if a document target with the specified identifier does not exist.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.DocumentTargetCollection.Remove Method

Removes the specified target from a Text Control document.

Syntax

[C#]
public bool Remove(DocumentTarget documentTarget);
[Visual Basic]
Public Function Remove(ByVal documentTarget As DocumentTarget) As Boolean
Parameter | Description
documentTarget | Specifies the document target to remove.

Return Value

The return value is true, if the document target could be removed. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.FilterException Class

The FilterException class informs about errors which can occur when a text filter is used to convert a document to or from another format.

Introduced: 24.0.

Syntax

[C#]
public class FilterException : Exception
[Visual Basic]
Public Class FilterException
  Inherits EventArgs

Constructors

Constructor | Description
FilterException | Overloaded. Initializes a new instance of the FilterException class.

Properties

Property | Description
Reason | Gets the error which is the cause of this exception.

Enumerations

Enumeration | Description
FilterError | Enumerates errors which can occur when a text filter is used to convert a TX Text Control document to or from another format.

See Also

  • Programming Category: Exceptions


TXTextControl.FilterException Constructor

Initializes a new instance of the FilterException class.

FilterException(FilterError)

Initializes a new instance of the FilterException class with a specified error.

[C#]
public FilterException(FilterException.FilterError error);
[Visual Basic]
Public Sub New(error as FilterException.FilterError)
Parameter | Description
error | The error that is the cause of the current exception.

FilterException(FilterError, String)

Initializes a new instance of the FilterException class with a specified error and a specified error message.

[C#]
public FilterException(FilterException.FilterError error, string message);
[Visual Basic]
Public Sub New(error as FilterException.FilterError, message as String)
Parameter | Description
error | The error that is the cause of the current exception.
message | The error message that explains the reason for the exception.

See Also

  • Programming Category: Exceptions


TXTextControl.FilterException.Reason Property

Gets the error which is the cause of this exception. It can be one of the FilterException.FilterError values.

Syntax

[C#]
public FilterError Error { get; }
[Visual Basic]
Public ReadOnly Property Error() As FilterError

See Also

  • Programming Category: Exceptions


TXTextControl.FilterException.FilterError Enumeration

Enumerates errors which can occur when a text filter is used to convert a TX Text Control document to or from another format. It contains the following values:

Member | Description
WrongFileType | The file type is not supported through the filter.
BadToken | There is a logical error in the file.
OutOfMemory | Unable to allocate enough memory.
CannotRead | File read error.
CannotWrite | File write error.
CannotOpen | Unable to open the file.
FileTooBig | The input file is too big.
Unsupported | Unsupported format version.
Internal | Unspecified internal error.
Obsolete | The filter is obsolete.
NotWellFormed | The file contains not well-formed syntax.
Encrypted | The document cannot be imported because the used encryption scheme is not supported.
NonEmbeddableFont | The document cannot be saved, because it contains a non-embeddable font.
InvalidCertificate | The specified certificate is invalid or has no private key.
InvalidTimeServer | The specified time server does not exist or retrieves invalid data.
InvalidPassword | The specified user-password is invalid.

See Also

  • Programming Category: Exceptions


TXTextControl.FontSettings Class

The FontSettings class provides settings determining which fonts can be used in a document.

Introduced: 15.0.

Syntax

[C#]
public class FontSettings
[Visual Basic]
Public Class FontSettings

Properties

Property | Description
AdaptFontEvent | Specifies whether a TextControl.AdaptFont event is raised, if a font must be adapted.
EmbeddableFontsOnly | Gets or sets a value specifying that only embeddable fonts can be used in a document.
ScalableFontsOnly | Gets or sets a value specifying that only free scalable fonts can be used in a document.
TrueTypeFontsOnly | Gets or sets a value specifying that only TrueType and OpenType fonts can be used in a document.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.FontSettings.AdaptFontEvent Property

Specifies whether a TextControl.AdaptFont event is raised, if a font must be adapted. The default setting of this property is false.

Syntax

[C#]
public bool AdaptFontsEvent { get; set; }
[Visual Basic]
Public Property AdaptFontsEvent() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.FontSettings.EmbeddableFontsOnly Property

Gets or sets a value specifying that only embeddable fonts can be used in a document. Embeddable fonts may be stored in a document without violating its font embedding licensing rights. When a document with embedded fonts is opened on a system that does not have the font installed, the embedded font may be loaded for temporary use on that system. TX Text Control allows only OpenType and TrueType fonts to be embeddable. This property must be set to true, if a document is to be saved in Adobe PDF/A format. The default setting of this property is false.

Syntax

[C#]
public bool EmbeddableFontsOnly { get; set; }
[Visual Basic]
Public Property EmbeddableFontsOnly() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.FontSettings.ScalableFontsOnly Property

Gets or sets a value specifying that only free scalable fonts can be used in a document. The default setting of this property is false.

Syntax

[C#]
public bool ScalableFontsOnly { get; set; }
[Visual Basic]
Public Property ScalableFontsOnly() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.FontSettings.TrueTypeFontsOnly Property

Gets or sets a value specifying that only TrueType and OpenType fonts can be used in a document. The default setting of this property is false.

Syntax

[C#]
public bool TrueTypeFontsOnly { get; set; }
[Visual Basic]
Public Property TrueTypeFontsOnly() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.FormattingStyle Class

The FormattingStyle class is the base class for the InlineStyle and ParagraphStyle classes. It implements the functionality common to all formatting styles.

Introduced: 10.1.

Syntax

[C#]
public class FormattingStyle
[Visual Basic]
# Public Class FormattingStyle

Properties

Property | Description
Baseline | Gets or sets the baseline alignment, in twips, of the style.
BaseStyle | Gets the FormattingStyle which is the base style of this style.
Bold | Gets or sets the bold attribute of the style.
FontName | Gets or sets the font of the style.
FontSize | Gets or sets the font's size of the style.
ForeColor | Gets or sets the style's color used to display the text.
Italic | Gets or sets the italic attribute of the style.
Name | Gets or sets the name of the style.
Strikeout | Gets or sets the strikeout attribute of the style.
TextBackColor | Gets or sets the style's text background color.
Underline | Gets or sets underlining styles for the style.

Methods

Method | Description
Apply | Applies all set attributes of the style to the current document.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Apply Method

Applies all set attributes of the style to the current document.

Syntax

[C#]
public bool Apply();
[Visual Basic]
Public Function Apply() As Boolean

Return Value

The return value is true, if all attributes could be set. Otherwise it is false.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Baseline Property

Gets or sets the baseline alignment, in twips, of the style. Positive values moves the baseline to superscript, negative values move the baseline to subscript.

Syntax

[C#]
public int Baseline { get; set; }
[Visual Basic]
Public Property Baseline() As Integer

Limitations

The property's value must be between -960 twips and 960 twips (48 pt).

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.BaseStyle Property

Gets the FormattingStyle which is the base style of this style. If this style is the TextControl's root style this property returns null. The property's value can be either a ParagraphStyle or an InlineStyle.

Introduced: 24.0.

Syntax

[C#]
public FormattingStyle BaseStyle { get; }
[Visual Basic]
Public ReadOnly Property BaseStyle() As FormattingStyle

Limitations

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Bold Property

Gets or sets the bold attribute of the style.

Syntax

[C#]
public bool Bold { get; set; }
[Visual Basic]
Public Property Bold() As Boolean

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.FontName Property

Gets or sets the font of the style.

Syntax

[C#]
public string FontName { get; set; }
[Visual Basic]
Public Property FontName() As String

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.FontSize Property

Gets or sets the font's size of the style.

Syntax

[C#]
public int FontSize { get; set; }
[Visual Basic]
Public Property FontSize() As Integer

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.ForeColor Property

Gets or sets the style's color used to display the text.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor() As Color

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Italic Property

Gets or sets the italic attribute of the style.

Syntax

[C#]
public bool Italic { get; set; }
[Visual Basic]
Public Property Italic() As Boolean

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Name Property

Gets or sets the name of the style.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Strikeout Property

Gets or sets the strikeout attribute of the style.

Syntax

[C#]
public bool Strikeout { get; set; }
[Visual Basic]
Public Property Strikeout() As Boolean

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.TextBackColor Property

Gets or sets the style's text background color.

Syntax

[C#]
public Color TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor() As Color

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyle.Underline Property

Gets or sets underlining styles for the style.

Syntax

[C#]
public FontUnderlineStyle Underline { get; set; }
[Visual Basic]
Public Property Underline() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection Class

The FormattingStyleCollection class is the base class of the ParagraphStyleCollection and InlineStyleCollection classes. It implements their base functionality and the IEnumerable and the ICollection interface.

Introduced: 10.1.

Syntax

[C#]
public abstract class FormattingStyleCollection : ICollection, IEnumerable
[Visual Basic]
Public MustInherit Class FormattingStyleCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
Remove | Removes a formatting style from a Text Control document.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection.Remove Method

Removes a formatting style from a Text Control document.

Syntax

[C#]
public bool Remove(string styleName);
[Visual Basic]
Public Function Remove(ByVal styleName As String) As Boolean
Parameter | Description
styleName | Specifies the name of the style to remove.

Return Value

The return value is true, if the style could be removed. Otherwise it is false.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FormattingStyleCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.FrameBase Class

The FrameBase class is the base class of the Image, TextFrame, ChartFrame, BarcodeFrame and DrawingFrame classes. It implements general frame features like the position in the text, the insertion mode or the distances between the text and the frame.

Syntax

[C#]
public class FrameBase
[Visual Basic]
Public Class FrameBase

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph.
ID | Gets or sets an identifier for the frame.
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame.
Location | Gets or sets, in twips, the frame's current location.
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface.
Name | Gets or sets a name for the frame.
Size | Gets or sets the frame's size in twips.
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface.
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text.
TextPosition | Read only. Gets the frame's character position in the document's text (one-based).

Methods

Method | Description
ChangeZOrder | Changes the frame's z-order.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Alignment Property

Gets or sets the frame's horizontal alignment when it is anchored to a paragraph.

Introduced: 15.1.

Syntax

[C#]
public HorizontalAlignment Alignment { get; set; }
[Visual Basic]
Public Property Alignment() As HorizontalAlignment
Value | Description
Left | The frame is left aligned.
Right | The frame is right aligned.
Center | The frame is centered.
Justify | This value cannot be used with this property.

Remarks

If the image or text frame has another Location than left, right or center, this property returns zero.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.ChangeZOrder Method

Changes the frame's z-order.

Introduced: 18.0.

Syntax

[C#]
public bool ChangeZOrder(ZOrder zOrder);
[Visual Basic]
Public Function ChangeZOrder(ByVal zOrder As ZOrder)
Parameter | Description
zOrder | Specifies how the z-order is changed. It can be a value of the ZOrder enumeration.

Return Value

The return value is true, if the z-order could be changed. Otherwise, it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.ID Property

Gets or sets an identifier for the frame. It must be a one-based value. A value of zero indicates that the image, text frame, chart, barcode or drawing has no identifier. Zero can also be used to delete a previously set identifier.

Introduced: 15.1.

Syntax

[C#]
public int ID { get; set; }
[Visual Basic]
Public Property ID() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.InsertionMode Property

Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. If the document's text flows around or overwrites the frame, this property also determines whether the image, text frame, chart, barcode or drawing is moved with the text or fixed positioned on a page.

Syntax

[C#]
public FrameInsertionMode InsertionMode { get; set; }
[Visual Basic]
Public Property InsertionMode() As FrameInsertionMode
Value | Description
AsCharacter | The frame is inserted in the text as a single character.
DisplaceCompleteLines | The frame is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the frame.
DisplaceText | The frame is inserted at a certain geometrical location. The text flows around the frame and empty areas at the left and right side are filled.
AboveTheText | The frame is inserted at a certain geometrical location above the text. This means that the frame overwrites the text.
BelowTheText | The frame is inserted at a certain geometrical location below the text. This means that the text overwrites the frame.
MoveWithText | The frame is connected with a paragraph and moved with the text.
FixedOnPage | The frame is fixed positioned on a page.

Remarks

The values of the FrameInsertionMode enumeration can be combined. The following combinations are possible:

DisplaceCompleteLines and MoveWithText

DisplaceCompleteLines and FixedOnPage

DisplaceText and MoveWithText

DisplaceText and FixedOnPage

AboveTheText and MoveWithText

AboveTheText and FixedOnPage

BelowTheText and MoveWithText

BelowTheText and FixedOnPage

AsCharacter

For all other combinations an exception is thrown.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Location Property

Gets or sets, in twips, the frame's current location. If the image, text frame, chart, barcode or drawing is anchored to a paragraph, the location is relative to the paragraph. Otherwise, it is relative to the document. If the frame has a horizontal alignment or if it is inserted inline, this property returns zero. This property cannot be set for images, text frames, charts, barcodes or drawings which are inserted inline.

Syntax

[C#]
public System.Drawing.Point Location { get; set; }
[Visual Basic]
Public Property Location() As System.Drawing.Point

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Moveable Property

Determines whether a frame can be moved in the document at run time with the built-in mouse interface.

Syntax

[C#]
public bool Moveable { get; set; }
[Visual Basic]
Public Property Moveable() As Boolean

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Name Property

Gets or sets a name for the frame. An empty string indicates that the frame has no name. An empty string can also be used to delete a previously set name.

Introduced: 15.1.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Size Property

Gets or sets the frame's size in twips. For images this property is read only.

Syntax

[C#]
public System.Drawing.Size Size { get; }
[Visual Basic]
Public ReadOnly Property Size() As System.Drawing.Size

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.Sizeable Property

Determines whether the frame can be resized at run time with the built-in mouse interface.

Syntax

[C#]
public bool Sizeable { get; set; }
[Visual Basic]
Public Property Sizeable() As Boolean

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.TextDistances Property

Gets or sets the distances, in twips, between the frame and the document's text. The property's value is an array of four variables specifying the distances in the following order: left, top, right and bottom. If a value is set to -1, it is not changed.

Syntax

[C#]
public int[] TextDistances { get; set; }
[Visual Basic]
Public Property TextDistances() As Integer()

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBase.TextPosition Property

Read only. Gets the frame's character position in the document's text (one-based).

Syntax

[C#]
public int TextPosition { get; }
[Visual Basic]
Public ReadOnly Property TextPosition() As Integer

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection Class

The FrameBaseCollection class is the base class of the ImageCollection and TextFrameCollection classes. It contains their base functionality. The FrameBaseCollection class implements the IEnumerable and the ICollection interfaces.

Syntax

[C#]
public abstract class FrameBaseCollection: ICollection, IEnumerable
[Visual Basic]
Public MustInherit Class FrameBaseCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
Clear | Removes all objects from the collection and from the document.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection.Clear Method

Removes all objects from the collection and from the document.

Introduced: 13.0.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameBaseCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.FrameCollection Class

An instance of the FrameCollection class contains all images, text frames and charts in a document. The collection consists of objects of the types Image, TextFrame, ChartFrame and BarcodeFrame. An instance of this class can be obtained with the TextControl.Frames, WPF.TextControl.Frames and ServerTextControl.Frames properties. The FrameCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 18.0.

Syntax

[C#]
public sealed class FrameCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class FrameCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular image, text frame, chart, barcode or drawing from the collection.
Remove | Removes a frame (image, text frame, chart, barcode or drawing) from a document.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.FrameCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.FrameCollection.GetItem Method

Gets a particular image, text frame, chart, barcode or drawing from the collection.

GetItem()

Gets the image, text frame, chart, barcode or drawing selected by the user.

[C#]
public FrameBase GetItem();
[Visual Basic]
Public Function GetItem() As FrameBase

GetItem(Int32)

Gets the image, text frame, chart, barcode or drawing with the specified identifier. An identifier can be set with the FrameBase.ID property.

[C#]
public FrameBase GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As FrameBase
Parameter | Description
id | Specifies the frame's identifier. The method returns null if a frame with the specified identifier does not exist.

GetItem(String)

Gets the image, text frame, chart, barcode or drawing with the specified name. A name can be set with the FrameBase.Name property.

[C#]
public FrameBase GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As FrameBase
Parameter | Description
name | Specifies the frame's name. The method returns null if a frame with the specified name does not exist.

Return Value

The return value is null, if an object with the specified parameters could not be found. Otherwise, it is an object of the type Image, TextFrame, ChartFrame or BarcodeFrame.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.FrameCollection.Remove Method

Removes a frame (image, text frame, chart, barcode or drawing) from a document.

Syntax

[C#]
public bool Remove(FrameBase frame);
[Visual Basic]
Public Function Remove(ByVal frame As FrameBase) As Boolean
Parameter | Description
frame | Specifies the image, text frame, chart, barcode or drawing to remove.

Return Value

The return value is true, if the frame could be removed. Otherwise, it is false.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.FrameEventArgs Class

The FrameEventArgs class provides data for all events that occur with frames. A frame can be an image, a text frame, a chart, a barcode or a drawing.

Introduced: 24.0.

Syntax

[C#]
public class FrameEventArgs: EventArgs
[Visual Basic]
Public Class FrameEventArgs
  Inherits EventArgs

Properties

Property | Description
Frame | Gets an object that represents the frame which causes the event.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.FrameEventArgs.Frame Property

Gets an object that represents the frame which causes the event. It is of the type Image, TextFrame, DataVisualization.ChartFrame, DataVisualization.BarcodeFrame or DataVisualization.DrawingFrame.

Syntax

[C#]
public FrameBase Frame { get; }
[Visual Basic]
Public ReadOnly Property Frame() As Frame

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.GotoDialog Class

The GotoDialog class implements a Windows Forms dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark. The new input position is shown with a marker. The dialog can be opened as a modeless dialog box. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the GotoDialog.DialogItem enumeration. The GotoDialog.FindItem method can be used to get a certain item and manipulate, move or delete it. The GotoDialog is a modeless dialog box which must be shown with the GotoDialog.Show method.

Introduced: 23.0.

Syntax

[C#]
public class GotoDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class GotoDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
GotoDialog | Creates a GotoDialog object for the specified Windows Forms TextControl.

Methods

Method | Description
FindItem | Finds a control that has the provided identifier name.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a GotoDialog dialog box.

Example

The following example creates a GotoDialog object and shows the dialog box:

[C#]
GotoDialog dlg = new GotoDialog(textControl1);
dlg.Show();
[Visual Basic]
Dim dlg As New GotoDialog(textControl1)
dlg.Show()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.GotoDialog Constructor

Creates a GotoDialog object for the specified Windows Forms TextControl.

Syntax

[C#]
public GotoDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the TextControl for which the dialog box is opened.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.GotoDialog.DialogItem Enumeration

Each DialogItem represents an item in a GotoDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The DialogItem enumeration can be used with the GotoDialog.FindItem method to get the item and manipulate it.

Member | Description
TXITEM_GotoLabel | Identifies the label of the Go to listbox.
TXITEM_GotoList | Identifies the Go to listbox.
TXITEM_NumberLabel | Identifies the label of the Number textbox.
TXITEM_Number | Identifies the Number respectively Bookmark combobox.
TXITEM_GotoPrevious | Identifies Previous button.
TXITEM_GotoNext | Identifies the Next button.
TXITEM_Close | Identifies the Close button.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.GotoDialog.FindItem Method

Finds a control that has the provided identifier name.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(GotoDialog.DialogItem dialogItem);
[Visual Basic]
Public Sub FindItem(ByVal dialogItem  As GotoDialog.DialogItem) As System.Windows.Forms.Control
Member | Description
dialogItem | The name of the requested control represented by an enum of type GotoDialog.DialogItem.

Return Value

The requested control if found. Otherwise null.

Example

The following example removes the 'Table' item from the GotoDialog's 'Go to what' list:

[C#]
ListBox ctrl = (ListBox)dlg.FindItem(TXTextControl.GotoDialog.DialogItem.TXITEM_GotoList);
ctrl.Items.RemoveAt(3);
[Visual Basic]
Dim ctrl As ListBox = DirectCast(dlg.FindItem(TXTextControl.GotoDialog.DialogItem.TXITEM_GotoList), ListBox)
ctrl.Items.RemoveAt(3)

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.HeaderFooter Class

An instance of the HeaderFooter class represents a header or footer in a Text Control document. A header or footer can be obtained through the TextControl.HeadersAndFooters or through the Section.HeadersAndFooters property. The collection obtained through the TextControl.HeadersAndFooters property contains headers and footers which are common to all sections of the document. If a header or footer is added to this collection all sections of the document have the same header or footer. These headers and footers are connected, which means that changing the contents of such a header or footer also changes the content of all other section's headers or footers. The HeaderFooter.ConnectedToPrevious property of these headers and footers is set to true. The collection obtained through the Section.HeadersAndFooters property contains headers and footers which are single to this section. Changing the contents of such a header or footer does not change the contents of other headers and footers.

The TextControl class has events that inform about different occurrences like activation or deactivation of a header or footer. The HeaderFooter class implements the IFormattedText interface.

Syntax

[C#]
public class HeaderFooter : IFormattedText
[Visual Basic]
Public Class HeaderFooter
  Implements IFormattedText

Properties

Property | Description
ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
Barcodes | Gets a collection of all barcodes contained in a header or footer.
Charts | Gets a collection of all charts contained in a header or footer.
ConnectedToPrevious | Gets or sets a value specifying whether the header or footer is connected with the header or footer of the previous section.
Distance | Gets or sets the distance, in twips, of a header or footer to the top or bottom of the page.
DocumentLinks | Gets a collection of all links in a header or footer which point to targets in the same document.
DocumentTargets | Gets a collection of all targets in a header or footer.
Drawings | Gets a collection of all drawings contained in a header or footer.
Frames | Gets a collection of all images, textframes, charts, barcodes and drawings in a header or footer.
HypertextLinks | Gets a collection of all hypertext links the header or footer contains.
Images | Gets a collection of all images the header or footer contains.
Lines | Gets a collection of all text lines the header or footer contains.
MisspelledWords | Gets a collection of all misspelled words the header or footer contains.
PageNumberFields | Gets a collection of page number fields in the header or footer.
Paragraphs | Gets a collection of all paragraphs the header or footer contains.
SectionNumber | Returns the number of the section to which the header or footer belongs.
Selection | Gets or sets the current selection in a header or footer.
SubTextParts | Gets a collection of all subtextparts in the header or footer.
Tables | Gets a collection of all tables in the header or footer.
TextChars | Gets a collection of all characters the header or footer contains.
TextFields | Gets a collection of all standard text fields in the header or footer.
TextFrames | Gets a collection of all text frames contained in a header or footer.
Type | Gets the type of the header or footer.

Methods

Method | Description
Activate | Activates a header or a footer.
Deactivate | Deactivates a header or a footer.
Find | Finds a text string in a header or footer.
GetTextFields | Returns a collection containing text fields of the specified types.

Example

The following example shows how to insert a header to the first section.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.PageView;
textControl1.Sections[1].HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header);

TXTextControl.HeaderFooter header = textControl1.Sections[1].HeadersAndFooters.GetItem(
    TXTextControl.HeaderFooterType.Header);
header.Selection.Text = "TX Text Control";
header.Selection.Start = 3;
header.Selection.Length = 4;
header.Selection.Bold = true;
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.PageView
TextControl1.Sections(1).HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header)

Dim header As TXTextControl.HeaderFooter = TextControl1.Sections(1).HeadersAndFooters.GetItem( _
    TXTextControl.HeaderFooterType.Header)
header.Selection.Text = "TX Text Control"
header.Selection.Start = 3
header.Selection.Length = 4
header.Selection.Bold = True

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Activate Method

Activates a header or a footer.

Syntax

[C#]
public bool Activate();
[Visual Basic]
Public Function Activate() As Boolean

Return Value

The return value is true, if the header or footer could be activated. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.ApplicationFields Property

Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set, otherwise this collection is empty.

Introduced: 14.0.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Text Fields and Hypertext Links - Programming Hypertext Links
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Barcodes Property

Gets a collection of all barcodes contained in a header or footer. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from a header or footer.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Charts Property

Gets a collection of all charts contained in a header or footer. The property value is an object of the type DataVisualization.ChartCollection. The collection can be used to get or to alter a chart's attributes and to add charts to or to remove charts from a header or footer.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.ChartCollection Charts { get; }
[Visual Basic]
Public ReadOnly Property Charts() As DataVisualization.ChartCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.ConnectedToPrevious Property

Gets or sets a value specifying whether the header or footer is connected with the header or footer of the previous section. If headers or footers are connected, they have always the same contents.

Introduced: 14.0.

Syntax

[C#]
public bool ConnectedToPrevious { get; set; }
[Visual Basic]
Public Property ConnectedToPrevious() As Boolean

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Deactivate Method

Deactivates a header or a footer.

Syntax

[C#]
public bool Deactivate();
[Visual Basic]
Public Function Deactivate() As Boolean

Return Value

The return value is true, if the header or footer could be deactivated. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Distance Property

Gets or sets the distance, in twips, of a header or footer to the top or bottom of the page. For headers it is the distance between the top of the header and the top of the page. For footers it is the distance between the bottom of the footer and the bottom of the page. The default value is 567 twips = 1 cm.

Syntax

[C#]
public int Distance { get; set; }
[Visual Basic]
Public Property Distance() As Integer

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.DocumentLinks Property

Gets a collection of all links in a header or footer which point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.DocumentTargets Property

Gets a collection of all targets in a header or footer. The property value is an object of the type DocumentTargetCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Drawings Property

Gets a collection of all drawings contained in a header or footer. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from a header or footer.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Find Method

Finds a text string in a header or footer.

Introduced: 16.0.

Syntax

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Frames Property

Gets a collection of all images, textframes, charts, barcodes and drawings in a header or footer. The property value is an object of the type FrameCollection. The collection can be used to get or to alter common attributes.

Introduced: 23.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.HypertextLinks Property

Gets a collection of all hypertext links the header or footer contains. The property's value is an object of the type HypertextLinkCollection.

Introduced: 16.0.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Images Property

Gets a collection of all images the header or footer contains. The property value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Lines Property

Gets a collection of all text lines the header or footer contains. The property value is an object of the type LineCollection.

Introduced: 10.1.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.MisspelledWords Property

Gets a collection of all misspelled words the header or footer contains. The property value is an object of the type MisspelledWordCollection.

Introduced: 16.0.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.PageNumberFields Property

Gets a collection of page number fields in the header or footer. The property's value is an object of the type PageNumberFieldCollection.

Syntax

[C#]
public PageNumberFieldCollection PageNumberFields { get; }
[Visual Basic]
Public ReadOnly Property PageNumberFields() As PageNumberFieldCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Text Fields and Hypertext Links - Inserting Page Numbers
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Paragraphs Property

Gets a collection of all paragraphs the header or footer contains. The property value is an object of the type ParagraphCollection.

Introduced: 15.0.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.SectionNumber Property

Returns the number of the section to which the header or footer belongs. The sections of the document are numbered beginning with 1. This property returns zero, if the header or footer object does not represent a single header or footer.

Introduced: 14.0.

Syntax

[C#]
public int SectionNumber { get; }
[Visual Basic]
Public ReadOnly Property SectionNumber() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Selection Property

Gets or sets the current selection in a header or footer. The property value is an object of the type Selection. For more information see the description of the Selection class.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.SubTextParts Property

Gets a collection of all subtextparts in the header or footer. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Tables Property

Gets a collection of all tables in the header or footer. The property's value is an object of the type TableCollection.

Introduced: 10.1.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.TextChars Property

Gets a collection of all characters the header or footer contains. The property value is an object of the type TextCharCollection.

Introduced: 10.1.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.TextFields Property

Gets a collection of all standard text fields in the header or footer. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.TextFrames Property

Gets a collection of all text frames contained in a header or footer. The property value is an object of the type TextFrameCollection.

Introduced: 12.0.

Syntax

[C#]
public TextFrameCollection TextFrames { get; }
[Visual Basic]
Public ReadOnly Property TextFrames() As TextFrameCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooter.Type Property

Gets the type of the header or footer. It is a value of the HeaderFooterType enumeration.

Syntax

[C#]
HeaderFooterType Type { get; }
[Visual Basic]
Private ReadOnly Property Type() As HeaderFooterType
Value | Description
Header | The object represents a header. When an even header exists the object represents the odd header. Otherwise it represents the header of all pages.
FirstPageHeader | The object represents a special header of the document's or section's first page.
Footer | The object represents a footer. When an even footer exists the object represents the odd footer. Otherwise it represents the footer of all pages.
FirstPageFooter | The object represents a special footer of the document's or section's first page.
EvenHeader | The object represents an even header.
EvenFooter | The object represents an even footer.

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection Class

An instance of the HeaderFooterCollection class contains the headers and footers in a Text Control document represented through objects of the type HeaderFooter. An instance of this class can be either obtained through the TextControl.HeadersAndFooters or through the Section.HeadersAndFooters property. The first collection represents headers and footers common to all sections of the document and the second collection represents the headers and footers of a certain section. The HeaderFooterCollection class implements the IEnumerable and the ICollection interface.

Syntax

[C#]
public class HeaderFooterCollection: ICollection, IEnumerable
[Visual Basic]
Public Class HeaderFooterCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
Add | Adds a new header or footer to a Text Control document or to a certain section of the document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Gets a particular header or footer from the collection.
Remove | Removes a header or footer from a Text Control document or from a certain section.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.Add Method

Adds a new header or footer to a Text Control document or to a certain section of the document. If a header or footer is added to the complete document the first section receives the header or footer and all other sections receive headers or footers which are connected to their previous section. To add more than one header or footer a combination of the HeaderFooterType enumeration values can be used.

Syntax

[C#]
public bool Add(HeaderFooterType headerFooterType);
[Visual Basic]
Public Function Add(ByVal headerFooterType As HeaderFooterType) As Boolean
Parameter Description
headerFooterType

Specifies the headers and/or footers to add. A combination of the following values of the HeaderFooterType enumeration is possible:

Value | Meaning
Header | Adds a header to the document.
FirstPageHeader | Adds a special header to the document's first page.
Footer | Adds a footer to the document.
FirstPageFooter | Adds a special footer to the document's first page.
EvenHeader | Adds an even header to the document. Even and odd headers can only exist together. If a header already exists, the existing header becomes the odd header. Otherwise an odd header is also created.
EvenFooter | Adds an even footer to the document. Even and odd footers can only exist together. If a footer already exists, the existing footer becomes the odd footer. Otherwise an odd footer is also created.
All | Adds all headers and footers.

Return Value

The return value is true, if the header or footer could be added. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.GetItem Method

Gets a particular header or footer from the collection. If the specified header or footer does not exist in the collection an ArgumentException is thrown.

Syntax

[C#]
public HeaderFooter GetItem(HeaderFooterType headerFooterType);
[Visual Basic]
Public Function GetItem(ByVal headerFooterType As HeaderFooterType) As HeaderFooter
Parameter Description
headerFooterType

Specifies the header or footer to return. It can be a value of the HeaderFooterType enumeration:

Value | Meaning
Header | Returns the header. If an even header exists, the returned object represents the odd header. Otherwise, it represents the header of all pages.
FirstPageHeader | Returns the special header of the document's first page.
Footer | Returns the footer. If an even footer exists, the returned object represents the odd footer. Otherwise, it represents the footer of all pages.
FirstPageFooter | Returns the special footer of the document's first page.
EvenHeader | Returns the even header.
EvenFooter | Returns the even footer.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterCollection.Remove Method

Removes a header or footer from a Text Control document or from a certain section. To remove more than one header or footer a combination of the HeaderFooterType enumeration can be used.

Syntax

[C#]
public bool Remove(HeaderFooterType headerFooterType);
[Visual Basic]
Public Function Remove(ByVal headerFooterType As HeaderFooterType) As Boolean
Parameter Description
headerFooterType

Specifies the headers and/or footers to remove. A combination of the following values are possible:

Value | Meaning
Header | Removes the header from the document. If an even header exists, both headers are removed.
FirstPageHeader | Removes the special header from the document's first page.
Footer | Removes the footer from the document. If an even footer exists, both footers are removed.
FirstPageFooter | Removes the special footer from the document's first page.
EvenHeader | Removes the even header from the document. The odd header becomes the header of all pages.
EvenFooter | Removes the even footer from the document. The odd footer becomes the footer of all pages.
All | Removes all headers and footers.

Return Value

The return value is true, if the header or footer could be removed. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterEventArgs Class

The HeaderFooterEventArgs class provides data for the TextControl.HeaderFooterActivated and TextControl.HeaderFooterDeactivated events.

Syntax

[C#]
public class HeaderFooterEventArgs: EventArgs
[Visual Basic]
Public Class HeaderFooterEventArgs
  Inherits EventArgs

Properties

Property | Description
HeaderFooter | Gets an object that represents the header or footer which causes the event.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HeaderFooterEventArgs.HeaderFooter Property

Gets an object that represents the header or footer which causes the event. It is of the type HeaderFooter.

Syntax

[C#]
public HeaderFooter HeaderFooter { get; }
[Visual Basic]
Public ReadOnly Property HeaderFooter() As HeaderFooter

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.HyperlinkDialog Class

The HyperlinkDialog class implements a Windows Forms dialog box for inserting and editing a hyperlink at the current text input position. The dialog box inserts either a HypertextLink to an external location or a DocumentLink to a location in the same document. If there is such a link at the current input position, the data of the link is shown and can be edited. Furthermore the hyperlink at the current input position can be deleted. The dialog box can only be opened, if either HypertextLinkCollection.CanAdd returns true or if DocumentLinkCollection.GetItem() or HypertextLinkCollection.GetItem() does not return null. Otherwise, an exception occurs. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the HyperlinkDialog.DialogItem enumeration. The HyperlinkDialog.FindItem method can be used to get a certain item and manipulate, move or delete it. The HyperlinkDialog is a modal dialog box which must be shown with the HyperlinkDialog.ShowDialog method.

Introduced: 23.0.

Syntax

[C#]
public class HyperlinkDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class HyperlinkDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
HyperlinkDialog | Creates a HyperlinkDialog object for the specified Windows Forms TextControl.

Methods

Method | Description
FindItem | Finds a control that has the provided identifier name.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a HyperlinkDialog dialog box.

Example

The following example creates an HyperlinkDialog object and shows the dialog box:

[C#]
HyperlinkDialog dlg = new HyperlinkDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New HyperlinkDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.HyperlinkDialog Constructor

Creates a HyperlinkDialog object for the specified Windows Forms TextControl.

Syntax

[C#]
public HyperlinkDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.HyperlinkDialog.DialogItem Enumeration

Each DialogItem represents an item in a HyperlinkDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The DialogItem enumeration can be used with the HyperlinkDialog.FindItem method to get the item and manipulate it.

Member | Description
TXITEM_HyperlinkTextLabel | Identifies the Hyperlink text label.
TXITEM_HyperlinkText | Identifies the Hyperlink text edit control.
TXITEM_HyperlinkLabel | Identifies the Hyperlink label.
TXITEM_Hyperlink | Identifies the Hyperlink edit control.
TXITEM_SelectFile | Identifies the Select File button.
TXITEM_BookmarkListLabel | Identifies the bookmark list label.
TXITEM_BookmarkList | Identifies the bookmark listbox.
TXITEM_ShowBookmarks | Identifies the Show Bookmarks label.
TXITEM_CurrentDocument | Identifies the Current Document radio button.
TXITEM_SelectedFile | Identifies the Selected File radio button.
TXITEM_DeleteHyperlink | Identifies the Delete Hyperlink button.
TXITEM_OK | Identifies the OK button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.HyperlinkDialog.FindItem Method

Finds a control that has the provided identifier name.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(HyperlinkDialog.DialogItem dialogItem);
[Visual Basic]
Public Sub FindItem(ByVal dialogItem  As HyperlinkDialog.DialogItem) As System.Windows.Forms.Control
Member | Description
dialogItem | The name of the requested control represented by an enum of type HyperlinkDialog.DialogItem.

Return Value

The requested control if found. Otherwise null.

Example

The following example removes the 'Go To' button from the HyperlinkDialog object:

[C#]
Control ctrl = dlg.FindItem(TXTextControl.HyperlinkDialog.DialogItem.TXITEM_DeleteHyperlink);
ctrl.Parent.Controls.Remove(ctrl);
[Visual Basic]
Dim ctrl As Control = dlg.FindItem(TXTextControl.HyperlinkDialog.DialogItem.TXITEM_DeleteHyperlink)
ctrl.Parent.Controls.Remove(ctrl)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.HypertextLink Class

The HypertextLink class represents a hypertext link in a Text Control document that points to a target outside of the document. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public class HypertextLink : TextField
[Visual Basic]
Public Class HypertextLink
  Inherits TextField

Constructors

Constructor | Description
HypertextLink | Initializes a new instance of the HypertextLink class.

Properties

Property | Description
Bounds | Gets the bounding rectangle of a text field. (Inherited from TextField.)
ContainsInputPosition | Returns true, if the Textfield contains the current text input position. (Inherited from TextField.)
Deleteable | Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
DoubleClickEvent | Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field. (Inherited from TextField.)
DoubledInputPosition | Specifies whether a text field has a doubled input position in front of its first character and behind its last character. (Inherited from TextField.)
Editable | Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited. (Inherited from TextField.)
FormattingBounds | Gets the formatting rectangle of a text field. (Inherited from TextField.)
ID | Gets or sets an identifier for a text field. (Inherited from TextField.)
IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words. (Inherited from TextField.)
Length | Gets the number of characters in a text field. (Inherited from TextField.)
Name | Relates a user-defined name to a text field. (Inherited from TextField.)
ShowActivated | Specifies whether a text field toggles its background to gray, if the current input position is in the field. (Inherited from TextField.)
Start | Gets the first character position (one-based) of a text field. (Inherited from TextField.)
Target | Gets or sets a string that specifies the target to where the hypertext link points.
Text | Returns or sets the text which is contained within a text field. (Inherited from TextField.)

Methods

Method | Description
ScrollTo | Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document. (Inherited from TextField.)

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLink Constructor

Initializes a new instance of the HypertextLink class.

Syntax

[C#]
public HypertextLink(string text, string target);
[Visual Basic]
Public Sub New(ByVal text As String, ByVal target As String)
Parameter | Description
text | Specifies the visible text of the hypertext link.
target | Specifies a string specifying to where the hypertext link points.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLink.Target Property

Gets or sets a string that specifies the target to where the hypertext link points.

Syntax

[C#]
public string Target { get; set; }
[Visual Basic]
Public Property Target() As String

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection Class

An instance of the HypertextLinkCollection class contains all hypertext links in a Text Control document represented through objects of the type HypertextLink. An instance of this class can be obtained with the TextControl.HypertextLinks property. The HypertextLinkCollection class implements the IEnumerable and the ICollection interfaces. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public sealed class HypertextLinkCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class HypertextLinkCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts a new hypertext link at the current input position.
Clear | Removes all hypertext links from a Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular hypertext link from the collection.
Remove | Overloaded. Removes a hypertext link from a Text Control document.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection.Add Method

Inserts a new hypertext link at the current input position.

Syntax

[C#]
public bool Add(HypertextLink hypertextLink);
[Visual Basic]
Public Function Add(ByVal hypertextLink As HypertextLink) As Boolean
Parameter | Description
hypertextLink | Specifies the hypertext link to add.

Return Value

The return value is true, if the hypertext link could be added. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection.Clear Method

Removes all hypertext links from a Text Control document.

Introduced: 13.0.

Syntax

[C#]
public void Clear(bool keepText);
[Visual Basic]
Public Sub Clear(ByVal keepText As Boolean)
Parameter | Description
keepText | If this parameter is set to true, all hypertext links are removed without deleting their texts. Otherwise, the texts are also deleted.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection.GetItem Method

Gets a particular hypertext link from the collection.

GetItem()

Gets the hypertext link at the current input position or null if there is no hypertext link at the current input position.

[C#]
public HypertextLink GetItem();
[Visual Basic]
Public Function GetItem() As HypertextLink

GetItem(Int32)

Gets the hypertext link with the specified id. An id can be set with the HypertextLink.ID property.

[C#]
public HypertextLink GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As HypertextLink
Parameter | Description
id | Specifies the hypertext link's identifier. The method returns null if a hypertext link with the specified identifier does not exist.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkCollection.Remove Method

Removes a hypertext link from a Text Control document.

Remove(HypertextLink)

Removes a hypertext link including its visible text from a Text Control document.

[C#]
public bool Remove(HypertextLink hypertextLink);
[Visual Basic]
Public Function Remove(ByVal hypertextLink As HypertextLink) As Boolean
Parameter | Description
hypertextLink | Specifies the hypertext link to remove.

Remove(HypertextLink, Boolean)

Removes a hypertext link from a Text Control document. The visible text is deleted depending on the keepText parameter.

[C#]
public bool Remove(HypertextLink hypertextLink, bool keepText);
[Visual Basic]
Public Function Remove(ByVal hypertextLink As HypertextLink, ByVal keepText As Boolean) As Boolean
Parameter | Description
hypertextLink | Specifies the hypertext link to remove.
keepText | If this parameter is set to true, the hypertext link is removed without deleting its text. Otherwise, the link's text is also deleted.

Return Value

The return value is true, if the hypertext link could be removed. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkEventArgs Class

The HypertextLinkEventArgs class provides data for the TextControl.HypertextLinkClicked event.

Syntax

[C#]
public class HypertextLinkEventArgs: EventArgs
[Visual Basic]
Public Class HypertextLinkEventArgs
  Inherits EventArgs

Properties

Property | Description
HypertextLink | Gets an object that represents the clicked hypertext link.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HypertextLinkEventArgs.HypertextLink Property

Gets an object that represents the clicked hypertext link. It is of the type HypertextLink.

Syntax

[C#]
public HypertextLink HypertextLink { get; }
[Visual Basic]
Public ReadOnly Property HypertextLink() As HypertextLink

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.HyphenateWordEventArgs Class

The HyphenateWordEventArgs class provides data for the TextControl.HyphenateWord, ServerTextControl.HyphenateWord and WPF.TextControl.HyphenateWord events.

Introduced: 20.0.

Syntax

[C#]
public class HyphenateWordEventArgs: EventArgs
[Visual Basic]
Public Class HyphenateWordEventArgs
  Inherits EventArgs

Properties

Property | Description
Culture | Gets the culture of the word to hyphenate.
DividePos | Gets or sets the position at which the word should be divided.
MaxDividePos | Gets the maximum dividing position.
Word | Gets the word to hyphenate.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.HyphenateWordEventArgs.Culture Property

Gets the culture of the word to hyphenate.

Syntax

[C#]
public System.Globalization.CultureInfo Culture { get; }
[Visual Basic]
Public ReadOnly Property Culture As System.Globalization.CultureInfo

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.HyphenateWordEventArgs.DividePos Property

Gets or sets the position at which the word should be divided. When a spellchecker has been connected with the SpellChecker property, this value has been calculated through the spellchecker. Otherwise it is zero. A TextControl uses this position to divide the word, when it is less or equal then MaxDividePos.

Syntax

[C#]
public int DividePos { get; }
[Visual Basic]
Public ReadOnly Property DividePos As Integer

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.HyphenateWordEventArgs.MaxDividePos Property

Gets the maximum dividing position. For example, when this value is 3, the first 3 characters of the word is the maximum part of the word which fit on the line.

Syntax

[C#]
public int MaxDividePos { get; }
[Visual Basic]
Public ReadOnly Property MaxDividePos As Integer

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.HyphenateWordEventArgs.Word Property

Gets the word to hyphenate.

Syntax

[C#]
public string Word { get; }
[Visual Basic]
Public ReadOnly Property Word As String

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.IFormattedText Interface

The IFormattedText interface contains properties and methods common to all text parts in a TX Text Control document. A TX Text Control document consists of the document's main text and additional pieces of text like text frames and headers and footers. A single text part has lines, paragraphs, characters and a selection which can be used to assign character and paragraph formatting attributes to a piece of text. Additionally a text part can contain tables, images, text fields, hypertext links and misspelled words. The following classes implement this interface: TextControl, ServerTextControl, WPF.TextControl, TextFrame, HeaderFooter and MainText.

Introduced: 16.0.

Syntax

[C#]
public interface IFormattedText
[Visual Basic]
Public Interface IFormattedText

Properties

Property | Description
ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
Barcodes | Gets a collection of all barcodes.
DocumentLinks | Gets a collection of all links which point to targets in the same document.
DocumentTargets | Gets a collection of all targets.
Drawings | Gets a collection of all drawings.
Frames | Gets a collection of all images, textframes, charts, barcodes and drawings.
HypertextLinks | Gets a collection of all hypertext links.
Images | Gets a collection of all images.
Lines | Gets a collection of all lines the text consists of.
MisspelledWords | Gets a collection of all misspelled words.
Paragraphs | Gets a collection of all paragraphs the text consists of.
Selection | Gets or sets the current selection.
SubTextParts | Gets a collection of all subtextparts.
Tables | Gets a collection of all tables.
TextChars | Gets a collection of all characters the text consists of.
TextFields | Gets a collection of all standard text fields.

Methods

Method | Description
Find | Finds a text string.
GetTextFields | Returns a collection containing text fields of the specified types.

Example

The following example shows how to loop through all text parts to get the first line of each part.

[C#]
foreach (object obj in textControl1.TextParts)
{
    Console.WriteLine("First Line: " + ((IFormattedText)obj).Lines[1].Text);
}

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.ApplicationFields Property

Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Barcodes Property

Gets a collection of all barcodes. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.DocumentLinks Property

Gets a collection of all links which point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.DocumentTargets Property

Gets a collection of all targets. The property value is an object of the type DocumentTargetCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Drawings Property

Gets a collection of all drawings. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Find Method

Finds a text string.

Syntax

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Frames Property

Gets a collection of all images, textframes, charts, barcodes and drawings. The property value is an object of the type FrameCollection. The collection can be used to get or to alter common attributes.

Introduced: 23.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.HypertextLinks Property

Gets a collection of all hypertext links. The property's value is an object of the type HypertextLinkCollection.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Images Property

Gets a collection of all images. The property value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Lines Property

Gets a collection of all lines the text consists of. The property value is an object of the type LineCollection.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.MisspelledWords Property

Gets a collection of all misspelled words. The property value is an object of the type MisspelledWordCollection.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Paragraphs Property

Gets a collection of all paragraphs the text consists of. The property value is an object of the type ParagraphCollection.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Selection Property

Gets or sets the current selection. The property value is an object of the type Selection. A selection can be used to assign character and paragraph formatting attributes to a piece of text.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.SubTextParts Property

Gets a collection of all subtextparts. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.Tables Property

Gets a collection of all tables. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.TextChars Property

Gets a collection of all characters the text consists of. The property value is an object of the type TextCharCollection.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.IFormattedText.TextFields Property

Gets a collection of all standard text fields. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.Image Class

An instance of the Image class represents an image in a Text Control document. The TextControl class has several events that inform about different occurrences.

Syntax

[C#]
public class Image : FrameBase
[Visual Basic]
Public Class Image
  Inherits FrameBase

Constructors

Constructor | Description
Image | Overloaded. Initializes a new instance of the Image class.

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph. (Inherited from FrameBase.)
ExportCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy data compression used if this image is saved.
ExportFileName | Gets or sets the file name of an image used, if a Text Control document is saved.
ExportFilterIndex | Gets or sets the format used if an image is saved.
ExportMaxResolution | Gets or sets the maximum resolution in dots per inch used if this image is saved.
FileName | Gets or sets the corresponding file name and path from which an inserted image is loaded.
FilterIndex | Gets or sets the format used, if an image is inserted.
HorizontalScaling | Gets or sets an images's horizontal scaling factor in percent.
ID | Gets or sets an identifier for the frame. (Inherited from FrameBase.)
InsertionMode | (Only for compatibility) Gets or sets a value determining whether an image is treated as a single character or the document's text either flows around or overwrites the image.
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. (Inherited from FrameBase.)
Location | Gets or sets, in twips, the frame's current location. (Inherited from FrameBase.)
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface. (Inherited from FrameBase.)
Name | Gets or sets a name for the frame. (Inherited from FrameBase.)
SaveMode | Determines whether the image is stored through its data or through its file reference.
Size | Gets or sets the frame's size in twips. (Inherited from FrameBase.)
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface. (Inherited from FrameBase.)
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text. (Inherited from FrameBase.)
TextPosition | Read only. Gets the frame's character position in the document's text (one-based). (Inherited from FrameBase.)
VerticalScaling | Gets or sets an images's vertical scaling factor in percent.

Methods

Method | Description
ChangeZOrder | Changes the frame's z-order. (Inherited from FrameBase.)

Example

The following example inserts a new image into the document, which will be treated as a character. The image's size will be reduced to 75% and it will not be sizeable:

[C#]
TXTextControl.Image myImage = new TXTextControl.Image();
myImage.Sizeable = false;
myImage.HorizontalScaling = 75;
myImage.VerticalScaling = 75;

textControl1.Images.Add(myImage, -1);
[Visual Basic]
Dim MyImage As New TXTextControl.Image()
MyImage.Sizeable = False
MyImage.HorizontalScaling = 75
MyImage.VerticalScaling = 75

TextControl1.Images.Add(MyImage, -1)

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image Constructor

Initializes a new instance of the Image class.

Image()

Creates an empty instance of the Image class.

[C#]
public Image();
[Visual Basic]
Public Sub New()

Image(String, Int32)

Initializes a new image from the specified image file and filter.

[C#]
public Image(string fileName, int filterIndex);
[Visual Basic]
Public Sub New(ByVal fileName As String, ByVal filterIndex As Integer)
Parameter Description
fileName

Specifies the name and the path of the file from which the image is loaded.
filterIndex

Specifies the index of the filter used to load the image. It is an index in the string returned through the ImageCollection.ImportFilters property starting with 1. Possible values are:

Value | Description
1 | Windows Bitmap (.BMP)
2 | Tagged Image Format (.TIF)
3 | Windows Metafile (.WMF)
4 | Portable Network Graphics (.PNG)
5 | JPEG File Interchange Format (.JPG, .JPEG)
6 | Graphics Interchange Format (.GIF)
7 | Windows Enhanced Metafile (.EMF)

Image(Image)

Initializes a new image from the specified System.Drawing.Image.

[C#]
public Image(System.Drawing.Image image);
[Visual Basic]
Public Sub New(ByVal image As System.Drawing.Image)
Parameter | Description
image | Specifies a System.Drawing.Image object which is used to initialize the TXTextControl image.

Image(MemoryStream)

Initializes a new image from the specified memory stream.

[C#]
public Image(System.IO.MemoryStream memoryStream);
[Visual Basic]
Public Sub New(ByVal memoryStream As System.IO.MemoryStream)
Parameter | Description
memoryStream | Specifies a memory stream from which the data for the TXTextControl image is read.

Image(UnmanagedMemoryStream)

Initializes a new image from the specified unmanaged memory stream.

[C#]
public Image(System.IO.UnmanagedMemoryStream unmanagedStream);
[Visual Basic]
Public Sub New(ByVal unmanagedStream As System.IO.MemoryStream)
Parameter | Description
unmanagedStream | Specifies an unmanaged memory stream from which the data for the TXTextControl image is read.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.ExportCompressionQuality Property

Sets a value between 1 and 100, which is the quality of a lossy data compression used if this image is saved. It is only used if the image data is compressed with a lossy compression algorithm. A value of 100 indicates the maximum quality, a value of 1 indicates the minimum quality. If this property is set to zero, which is the default value, Text Control uses the quality value set with the SaveSettings.ImageCompressionQuality property or a compression specific default value.

Introduced: 11.0.

Syntax

[C#]
public int ExportCompressionQuality { get; set; }
[Visual Basic]
Public Property ExportCompressionQuality() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.ExportFileName Property

Gets or sets the file name of an image used, if a Text Control document is saved. An empty string indicates that no export filename has currently be specified for the image. In this case either the original or a constructed filename is used. A filename is constructed in the following form: <document_filename>_<number>.<extension>

Syntax

[C#]
public string ExportFileName { get; set; }
[Visual Basic]
Public Property ExportFileName() As String

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.ExportFilterIndex Property

Gets or sets the format used if an image is saved. This is the number of the filter in the string returned through the ImageCollection.ExportFilters property, beginning with number one. If the ImageCollection.ExportFilters property is used to initialize the FileDialog.Filter property of a Framework dialog, the FileDialog.FilterIndex property can be used as value for this property. A value of zero indicates that no export format has currently be specified for the image. In this case the original format is used that can be obtained with the Image.FilterIndex property. The technical article Loading and Saving Images describes how images can be loaded and saved.

Syntax

[C#]
public int ExportFilterIndex { get; set; }
[Visual Basic]
Public Property ExportFilterIndex() As Integer
Value | Description
1 | Windows Bitmap (.BMP)
2 | Windows Metafile (.WMF)
3 | Portable Network Graphics (.PNG)
4 | JPEG File Interchange Format (.JPG, .JPEG)
5 | Windows Enhanced Metafile (.EMF)
6 | Tagged Image Format (.TIF)
7 | Graphics Interchange Format (.GIF)

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.ExportMaxResolution Property

Gets or sets the maximum resolution in dots per inch used if this image is saved. If the image's resolution is larger than this property's value, it is reduced; otherwise, it is not changed. If this property's value is zero, which is the default value, Text Control uses the maximum resolution set with the SaveSettings.ImageMaxResolution property or the image's default resolution.

Introduced: 11.0.

Syntax

[C#]
public int ExportMaxResolution { get; set; }
[Visual Basic]
Public Property ExportMaxResolution() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.FileName Property

Gets or sets the corresponding file name and path from which an inserted image is loaded.

Syntax

[C#]
public string FileName { get; set; }
[Visual Basic]
Public Property FileName() As String

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.FilterIndex Property

Gets or sets the format used, if an image is inserted. This is the number of the filter in the string returned through the ImageCollection.ImportFilters property, beginning with number one. If the ImageCollection.ImportFilters property is used to initialize the FileDialog.Filter property of a Framework dialog, the FileDialog.FilterIndex property can be used as value for this property. The technical article Loading and Saving Images describes how images can be loaded and saved.

Syntax

[C#]
public int FilterIndex { get; set; }
[Visual Basic]
Public Property FilterIndex() As Integer
Value | Description
1 | Windows Bitmap (.BMP)
2 | Tagged Image Format (.TIF)
3 | Windows Metafile (.WMF)
4 | Portable Network Graphics (.PNG)
5 | JPEG File Interchange Format (.JPG, .JPEG)
6 | Graphics Interchange Format (.GIF)
7 | Windows Enhanced Metafile (.EMF)

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.HorizontalScaling Property

Gets or sets an images's horizontal scaling factor in percent.

Syntax

[C#]
public int HorizontalScaling { get; set; }
[Visual Basic]
Public Property HorizontalScaling() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.InsertionMode Property

(Only for compatibility) Gets or sets a value determining whether an image is treated as a single character or the document's text either flows around or overwrites the image. If the document's text flows around or overwrites the image, this property also determines whether the image is moved with the text or is fixed positioned on a page.

Syntax

[C#]
public new ImageInsertionMode InsertionMode { get; set; }
[Visual Basic]
Public Property InsertionMode() As ImageInsertionMode
Value | Description
AsCharacter | The image is inserted in the text as a single character.
DisplaceCompleteLines | The image is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the image.
DisplaceText | The image is inserted at a certain geometrical location. The text flows around the image and empty areas at the left and right side are filled.
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
MoveWithText | The image is connected with a paragraph and moved with the text.
FixedOnPage | The image is fixed positioned on a page.

Remarks

The values of the ImageInsertionMode enumeration can be combined. The following combinations are possible:

DisplaceCompleteLines and MoveWithText

DisplaceCompleteLines and FixedOnPage

DisplaceText and MoveWithText

DisplaceText and FixedOnPage

AboveTheText and MoveWithText

AboveTheText and FixedOnPage

BelowTheText and MoveWithText

BelowTheText and FixedOnPage

AsCharacter

For all other combinations an exception is thrown.

Example

The following example iterates through all images and sets the insertion mode to DisplaceText and MoveWithText.

[C#]
foreach (TXTextControl.Image image in textControl1.Images)
{
  image.InsertionMode = TXTextControl.ImageInsertionMode.DisplaceText |
                        TXTextControl.ImageInsertionMode.MoveWithText;
}
[Visual Basic]
For Each Image As TXTextControl.Image In TextControl1.Images
  Image.InsertionMode = TXTextControl.ImageInsertionMode.DisplaceText + _
                        TXTextControl.ImageInsertionMode.MoveWithText
Next

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.SaveMode Property

Determines whether the image is stored through its data or through its file reference. By default an image is stored through a file reference if a file reference exist. Otherwise, if the image has been pasted from the clipboard, it is stored with its complete binary data.

Syntax

[C#]
public ImageSaveMode SaveMode { get; set; }
[Visual Basic]
Public Property SaveMode() As ImageSaveMode
Value | Description
Auto | The image is saved as specified with the SaveSettings.ImageSaveMode property.
SaveAsData | The image is saved in a Text Control document with its complete binary data.
SaveAsFileReference | The image is saved in a Text Control document through a file reference.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.Image.VerticalScaling Property

Gets or sets an images's vertical scaling factor in percent.

Syntax

[C#]
public int VerticalScaling { get; set; }
[Visual Basic]
Public Property VerticalScaling() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection Class

An instance of the ImageCollection class contains all images in a Text Control document or part of the document represented through objects of the type Image. An instance of this class can be obtained with the TextControl.Images, HeaderFooter.Images or TextFrame.Images property. The ImageCollection class implements the IEnumerable and the ICollection interfaces.

Syntax

[C#]
public sealed class ImageCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class ImageCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
ExportFilters | Gets all available filters for exporting images.
ImportFilters | Gets all available filters for importing images.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Add | Overloaded. Inserts a new image in a Text Control document.
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular image from the collection.
Remove | Removes an image from a Text Control document.

Example

The following example iterates all images and sets the Image.SaveMode to SaveAsFileReference, so that all images will be exported the next time the document is saved. The images, will be saved in a subfolder called "'document name'_Images" of the location where the document has been saved to. The additional properties can be used to set the image's quality, format and maximum resolution.

[C#]
foreach (TXTextControl.Image myImage in textControl1.Images)
{
  myImage.SaveMode = TXTextControl.ImageSaveMode.SaveAsFileReference;
  myImage.ExportCompressionQuality = 100; //Export with maximum quality
  myImage.ExportFilterIndex = 4; //Export as PNG format
  myImage.ExportMaxResolution = 96; //Export with 96 DPI max
}
[Visual Basic]
For Each MyImage As TXTextControl.Image In TextControl1.Images
  MyImage.SaveMode = TXTextControl.ImageSaveMode.SaveAsFileReference
  MyImage.ExportCompressionQuality = 100 'Export with maximum quality
  MyImage.ExportFilterIndex = 3 'Export as PNG
  MyImage.ExportMaxResolution = 96 'Export with 96 DPI max
Next

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.Add Method

Inserts a new image in a Text Control document.

Add()

Inserts an image inline, which means that it is treated in the text like a single character. The image is inserted at the current text input position. A file open dialog box is shown to get the image's file name and filter.

[C#]
public bool Add();
[Visual Basic]
Public Function Add() As Boolean

Add(Image, Int32)

Inserts an image inline, which means that it is treated in the text like a single character. The image is inserted at the specified text input position. A file open dialog box is shown to get the image's file name and filter. To avoid opening the dialog box set the Image.FileName and the Image.FilterIndex properties of the specified Image object.

[C#]
public bool Add(Image image, int textPosition);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal textPosition As Integer) As Boolean
Parameter | Description
image | Specifies the image to add.
textPosition | Specifies the text position at which the image is to be inserted. If -1 is specified, the image is inserted at the current input position.

Add(Image, HorizontalAlignment, Int32, ImageInsertionMode)

Inserts a new image which is anchored to the specified text position. It has the specified horizontal alignment and a textflow which is given through the insertionMode parameter. Anchored images are moved with the text. A file open dialog box is shown to get the image's file name and filter. To avoid opening the dialog box set the Image.FileName and the Image.FilterIndex properties of the specified Image object.

[C#]
public bool Add(Image image, HorizontalAlignment alignment, int textPosition, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal alignment As HorizontalAlignment, ByVal textPosition As Integer, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Parameter Description
image

Specifies the image to add.
alignment

Specifies the image's horizontal alignment. It can be one of the HorizontalAlignment values:

Value | Meaning
Left | The image is left aligned, relative to the paragraph to which it is anchored.
Right | The image is right aligned, relative to the paragraph to which it is anchored.
Centered | The image is centered, relative to the paragraph to which it is anchored.
Justify | This value is not supported for images.
textPosition

Specifies the text position at which the image is to be inserted. If -1 is specified, the image is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the ImageInsertionMode enumeration:

Value | Meaning
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the image.
DisplaceText | The text flows around the image and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ImageCollection.Add method.

Add(Image, Point, Int32, ImageInsertionMode)

Inserts a new image which is anchored to the specified text position. It has the specified location relative to the paragraph it is anchored to and a textflow which is given through the insertionMode parameter. Anchored images are moved with the text. A file open dialog box is shown to get the image's file name and filter. To avoid opening the dialog box set the Image.FileName and the Image.FilterIndex properties of the specified Image object.

[C#]
public bool Add(Image image, System.Drawing.Point location, int textPosition, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal location As System.Drawing.Point, ByVal textPosition As Integer, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Parameter Description
image

Specifies the image to add.
location

Specifies the location, in twips, at which the image is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
textPosition

Specifies the text position at which the image is to be inserted. If -1 is specified, the image is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the ImageInsertionMode enumeration:

Value | Meaning
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the image.
DisplaceText | The text flows around the image and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ImageCollection.Add method.

Add(Image, Int32, Point, ImageInsertionMode)

Inserts a new image which has a fixed geometrical position in the document. This position is specified through a page number and a location on this page. A file open dialog box is shown to get the image's file name and filter. To avoid opening the dialog box set the Image.FileName and the Image.FilterIndex properties of the specified Image object.

[C#]
public bool Add(Image image, int pageNumber, System.Drawing.Point location, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal pageNumber As Integer, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Parameter Description
image

Specifies the image to add.
pageNumber

Specifies the number of a page beginning with 1 where the image is located.
location

Specifies the location, in twips, at which the image is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the ImageInsertionMode enumeration:

Value | Meaning
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the image.
DisplaceText | The text flows around the image and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ImageCollection.Add method.

Add(Image, Point, ImageInsertionMode)

Inserts a new image which has a fixed geometrical position in the document. This position is specified through a location relative to the top left corner of the complete document. All gaps between the pages must be included. A file open dialog box is shown to get the image's file name and filter. To avoid opening the dialog box set the Image.FileName and the Image.FilterIndex properties of the specified Image object.

[C#]
public bool Add(Image image, System.Drawing.Point location, ImageInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal image As Image, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As ImageInsertionMode) As Boolean
Parameter Description
image

Specifies the image to add.
location

Specifies the location, in twips, at which the image is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the ImageInsertionMode enumeration:

Value | Meaning
AboveTheText | The image is inserted at a certain geometrical location above the text. This means that the image overwrites the text.
BelowTheText | The image is inserted at a certain geometrical location below the text. This means that the text overwrites the image.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the image.
DisplaceText | The text flows around the image and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ImageCollection.Add method.

Return Value

The return value is true, if the image could be added. Otherwise, it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.ExportFilters Property

Gets all available filters for exporting images. This property can be used to set the FileDialog.Filter property.

Syntax

[C#]
public string ExportFilters { get; }
[Visual Basic]
Public ReadOnly Property ExportFilters() As String

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.GetItem Method

Gets a particular image from the collection.

Introduced: 15.1.

GetItem()

Gets the image selected by the user.

[C#]
public Image GetItem();
[Visual Basic]
Public Function GetItem() As Image

GetItem(Int32)

Gets the image with the specified identifier. An identifier can be set with the Image.ID property.

[C#]
public Image GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As Image
Parameter | Description
id | Specifies the image's identifier. The method returns null if an image with the specified identifier does not exist.

GetItem(String)

Gets the image with the specified name. A name can be set with the Image.Name property.

[C#]
public Image GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As Image
Parameter | Description
name | Specifies the image's name. The method returns null if an image with the specified name does not exist.

Return Value

The return value is null, if an image with the specified parameters could not be found. Otherwise, it is an object of the type Image.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.ImportFilters Property

Gets all available filters for importing images. This property can be used to set the FileDialog.Filter property.

Syntax

[C#]
public string ImportFilters { get; }
[Visual Basic]
Public ReadOnly Property ImportFilters() As String

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageCollection.Remove Method

Removes an image from a Text Control document.

Syntax

[C#]
public bool Remove(Image image);
[Visual Basic]
Public Function Remove(ByVal image As Image) As Boolean
Parameter | Description
image | Specifies the image to remove.

Return Value

The return value is true, if the image could be removed. Otherwise, it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageEventArgs Class

The ImageEventArgs class provides data for all events that occur with images. These are the TextControl.ImageCreated, TextControl.ImageDeleted, TextControl.ImageClicked, TextControl.ImageDoubleClicked, TextControl.ImageRightClicked, TextControl.ImageMoved, TextControl.ImageSelected, TextControl.ImageDeselected and TextControl.ImageSized events.

Syntax

[C#]
public class ImageEventArgs: EventArgs
[Visual Basic]
Public Class ImageEventArgs
  Inherits EventArgs

Properties

Property | Description
Image | Gets an object that represents the image which causes the event.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ImageEventArgs.Image Property

Gets an object that represents the image which causes the event. It is of the type Image.

Syntax

[C#]
public Image Image { get; }
[Visual Basic]
Public ReadOnly Property Image() As Image

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.InlineStyle Class

The InlineStyle class defines a formatting style that can be used to format single words in a line of text. In addition to the methods described here, it inherits all properties and methods of the FormattingStyle class.

Introduced: 10.1.

Syntax

[C#]
public sealed class InlineStyle : FormattingStyle
[Visual Basic]
Public NotInheritable Class InlineStyle
  Inherits FormattingStyle

Constructors

Constructor | Description
InlineStyle | Overloaded. Creates a new instance of the InlineStyle class.

Properties

Property | Description
Baseline | Gets or sets the baseline alignment, in twips, of the style. (Inherited from FormattingStyle.)
BaseStyle | Gets the FormattingStyle which is the base style of this style. (Inherited from FormattingStyle.)
Bold | Gets or sets the bold attribute of the style. (Inherited from FormattingStyle.)
FontName | Gets or sets the font of the style. (Inherited from FormattingStyle.)
FontSize | Gets or sets the font's size of the style. (Inherited from FormattingStyle.)
ForeColor | Gets or sets the style's color used to display the text. (Inherited from FormattingStyle.)
Italic | Gets or sets the italic attribute of the style. (Inherited from FormattingStyle.)
Name | Gets or sets the name of the style. (Inherited from FormattingStyle.)
Strikeout | Gets or sets the strikeout attribute of the style. (Inherited from FormattingStyle.)
TextBackColor | Gets or sets the style's text background color. (Inherited from FormattingStyle.)
Underline | Gets or sets underlining styles for the style. (Inherited from FormattingStyle.)

Methods

Method | Description
Apply | Applies all set attributes of the style to the current document. (Inherited from FormattingStyle.)
IsInheritedFromParagraph | Informs about whether one or more of the style's attributes are inherited from the surrounding paragraph.
ResetToParagraph | Resets one or more of the style's attributes to its default value which is the same value as defined for the surrounding paragraph.

Enumerations

Enumeration | Description
Attributes | Determines the style's attributes.

Example

The following example shows how to add and apply an InlineStyle.

[C#]
textControl1.Text = "TX Text Control";

TXTextControl.InlineStyle inline = new TXTextControl.InlineStyle("ArialBold16");
inline.Bold = true;
inline.FontSize = 320;
inline.FontName = "Arial";
textControl1.InlineStyles.Add(inline);

textControl1.Select(3, 4);
textControl1.Selection.FormattingStyle = "ArialBold16";
[Visual Basic]
TextControl1.Text = "TX Text Control"

Dim inline As TXTextControl.InlineStyle = New TXTextControl.InlineStyle("ArialBold16")
inline.Bold = True
inline.FontSize = 320
inline.FontName = "Arial"
TextControl1.InlineStyles.Add(inline)

TextControl1.Select(3, 4)
TextControl1.Selection.FormattingStyle = "ArialBold16"

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyle Constructor

Creates a new instance of the InlineStyle class.

InlineStyle(String)

Creates a new instance of the InlineStyle class based on the TextControl root style named [Normal].

[C#]
public InlineStyle(string name);
[Visual Basic]
Public Sub New(ByVal name As String)
Parameter | Description
name | Specifies the new style's name.

InlineStyle(String, String)

Creates a new instance of the InlineStyle class based on the specified base style.

[C#]
public InlineStyle(string name, string baseStyle);
[Visual Basic]
Public Sub New(ByVal name As String, ByVal baseStyle As String)
Parameter | Description
name | Specifies the new style's name.
baseStyle | Specifies the name of the style the new style based on.

InlineStyle(InlineStyle)

Creates a new root style that has all attributes of the specified style.

[C#]
public InlineStyle(InlineStyle style);
[Visual Basic]
Public Sub New(ByVal style As InlineStyle)
Parameter | Description
style | Is a style the attributes of which are used to initialize the new style.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyle.Attributes Enumeration

Determines the style's attributes. This enumeration is used with the IsInheritedFromParagraph and ResetToParagraph methods.

Member | Description
Baseline | Specifies the attribute set through the style's Baseline property.
Bold | Specifies the attribute set through the style's Bold property.
FontName | Specifies the attribute set through the style's FontName property.
FontSize | Specifies the attribute set through the style's FontSize property.
ForeColor | Specifies the attribute set through the style's ForeColor property.
Italic | Specifies the attribute set through the style's Italic property.
Strikeout | Specifies the attribute set through the style's Strikeout property.
TextBackColor | Specifies the attribute set through the style's TextBackColor property.
Underline | Specifies the attribute set through the style's Underline property.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyle.IsInheritedFromParagraph Method

Informs about whether one or more of the style's attributes are inherited from the surrounding paragraph. Text formatted through an inline style has all the attributes defined through the surrounding paragraph except the attributes explicitly defined through the inline style.

Syntax

[C#]
public bool IsInheritedFromParagraph(InlineStyle.Attributes attributes);
[Visual Basic]
Public Function IsInheritedFromParagraph(ByVal attributes As InlineStyle.Attributes) As Boolean
Parameter | Description
attributes | Specifies one or more attributes. It can be a bitwise combination of values from the Attributes enumeration contained in this class.

Return Value

The return value is true, if the specified attributes are inherited from the paragraph. Otherwise it is false.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyle.ResetToParagraph Method

Resets one or more of the style's attributes to its default value which is the same value as defined for the surrounding paragraph. Text formatted through an inline style has all the attributes defined through the surrounding paragraph except the attributes explicitly defined through the inline style.

Syntax

[C#]
public void ResetToParagraph(InlineStyle.Attributes attributes);
[Visual Basic]
Public Sub ResetToParagraph(ByVal attributes As InlineStyle.Attributes)
Parameter | Description
attributes | Specifies one or more attributes to reset. It can be a bitwise combination of values from the Attributes enumeration contained in this class.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyleCollection Class

An instance of the InlineStyleCollection class contains all inline formatting styles in the current document represented through objects of the type InlineStyle. An inline style is a character-based formatting style that can be used to format single words in a line of text. The InlineStyleCollection class implements the IEnumerable and the ICollection interfaces. An instance of this class can be obtained with the TextControl.InlineStyles property.

Introduced: 10.1.

Syntax

[C#]
public sealed class InlineStyleCollection : FormattingStyleCollection
[Visual Basic]
Public NotInheritable Class InlineStyleCollection
  Inherits FormattingStyleCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FormattingStyleCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FormattingStyleCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FormattingStyleCollection.)

Methods

Method | Description
Add | Adds to new formatting style to the current document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FormattingStyleCollection.)
GetItem | Gets a particular style from the collection.
Remove | Removes a formatting style from a Text Control document. (Inherited from FormattingStyleCollection.)

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyleCollection.Add Method

Adds to new formatting style to the current document.

Syntax

[C#]
public bool Add(InlineStyle inlineStyle);
[Visual Basic]
Public Function Add(ByVal inlineStyle As InlineStyle) As Boolean
Parameter | Description
inlineStyle | Specifies the style to add.

Return Value

The return value is true, if the style could be added. Otherwise it is false.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyleCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InlineStyleCollection.GetItem Method

Gets a particular style from the collection.

Syntax

[C#]
public InlineStyle GetItem(string styleName);
[Visual Basic]
Public Function GetItem(ByVal styleName As String) As InlineStyle
Parameter | Description
styleName | Specifies the name of the style.

Return Value

The return value is null, if a style with the specified name is not contained in the collection. Otherwise it is an object of the type InlineStyle.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.InputFormat class

The InputFormat class represents all formatting attributes at the current text input position. All properties are automatically updated, when the input position changes so that the class can be used in a XAML data binding without code behind. This is useful when a TextControl or WPF.TextControl is connected with other controls which show the current state at the input position. If text is selected and the selection has no common value for a certain attribute, the corresponding property is null.

Introduced: 16.0.

Syntax

[C#]
public class InputFormat
[Visual Basic]
Public Class InputFormat

Properties

Property | Description
AllFrameLines | Gets or sets a value specifying whether all frame lines, including all inner frame lines, are set for the selected text.
Bold | Gets or sets a value specifying whether text is bold at the current input position.
BottomAligned | Gets or sets a value specifying whether text is bottom aligned at the current input position.
BottomDistance | Gets or sets a bottom paragraph distance, in twips, at the current input position.
BottomFrameLine | Gets or sets a value specifying whether there is a frame line at the bottom of the text.
BoxFrame | Gets or sets a value specifying whether there is a complete frame around the text.
BulletCharacter | Gets or sets the bullet character at the current input position.
BulletedList | Gets or sets a value specifying whether there is a bulleted list at the current input position.
Centered | Gets or sets a value specifying whether text is centered at the current input position.
FontFamily | Gets or sets the font family at the current input position.
FontSize | Gets or sets the font's size, in twips, at the current input position.
FrameFillColor | Gets or sets the color used to display the frame fill color at the current input position.
FrameLineColor | Gets or sets the color used to display the color of frame lines at the current text input position.
FrameLineWidth | Gets or sets the line width, in twips, of the paragraph's or table's frame at the current input position.
HangingIndent | Gets or sets the hanging indent, in twips, at the current input position.
InnerHorizontalFrameLines | Gets or sets a value specifying whether all inner horizontal frame lines are set for the selected text.
InnerVerticalFrameLines | Gets or sets a value specifying whether all inner vertical frame lines are set for the selected text.
Italic | Gets or sets a value specifying whether the text is italic at the current input position.
Justified | Gets or sets a value specifying whether text is justified at the current input position.
LeftAligned | Gets or sets a value specifying whether text is left aligned at the current input position.
LeftFrameLine | Gets or sets a value specifying whether there is a frame line at the left side of the text.
LeftIndent | Gets or sets the left indent, in twips, at the current input position.
LeftToRight | Gets or sets a value specifying whether the writung direction is left-to-right at the current input position.
LineSpacing | Gets or sets the line spacing, in percent, at the current input position.
NumberedList | Gets or sets a value specifying whether there is a numbered list at the current input position.
NumberedListFormat | Gets or sets the number format for a numbered list at the current input position.
NumberFormats | Returns an array of all supported number formats for numbered and structured lists.
RightAligned | Gets or sets a value specifying whether text is right aligned at the current input position.
RightFrameLine | Gets or sets a value specifying whether there is a frame line at the right side of the text.
RightIndent | Gets or sets the right indent, in twips, at the current input position.
RightToLeft | Gets or sets a value specifying whether the writing direction is right-to-left at the current input position.
Strikeout | Gets or sets a value specifying whether the text is strikeout at the current input position.
StructuredList | Gets or sets a value specifying whether there is a structured list at the current input position.
StructuredListFormat | Gets or sets the number format for a structured list at the current input position.
StyleName | Gets or sets the formatting style name at the current input position.
StyleNames | Returns an array of the names of all formatting styles, the document contains.
Subscript | Gets or sets a value specifying whether text is subscript at the current input position.
Superscript | Gets or sets a value specifying whether text is superscript at the current input position.
TextBackColor | Gets or sets the color used to display the text background color at the current input position.
TextColor | Returns or sets the color used to display the text at the current input position.
TopAligned | Gets or sets a value specifying whether text is top aligned at the current input position.
TopDistance | Gets or sets a top paragraph distance, in twips, at the current input position.
TopFrameLine | Gets or sets a value specifying whether there is a frame line at the top of the text.
Underline | Gets or sets a value specifying whether text is underlined at the current input position.
UnderlineStyle | Gets or sets the underline style at the current input position.
UnderlineStyles | Returns an array of all supported underline styles.
VerticallyCentered | Gets or sets a value specifying whether text is vertically centered at the current text input position.

Methods

Method | Description
GetFontFamilies | Returns an array of strings specifying all supported fonts.
GetFontSizes | Overloaded. Returns all possible font sizes of a certain font.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.AllFrameLines Property

Gets or sets a value specifying whether all frame lines, including all inner frame lines, are set for the selected text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool AllFrameLines { get; set; }
[Visual Basic]
Public Property AllFrameLines() Boolean

Example

The following XAML example shows how to bind the AllFrameLines property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="All Frame Lines"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.AllFrameLines}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.FrameFillColor Property

Gets or sets the color used to display the frame fill color at the current input position. If text is selected, the property specifies the fill color of the whole selected text. A background color can be set for table cells and paragraphs. If the fill color is transparent, a TextControl uses the control's background color.

Introduced: 24.0.

Syntax

[C#]
public System.Drawing.Color? FrameFillColor { get; set; }
[Visual Basic]
Public Property FrameFillColor() As Nullable(Of System.Drawing.Color)

Remarks

The property returns null when the text selection contains multiple table cells or paragraphs with mixed colors.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Bold Property

Gets or sets a value specifying whether text is bold at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Bold { get; set; }
[Visual Basic]
Public Property Bold() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed setting.

Example

The following XAML example binds the Bold property to a check box:

<CheckBox
   Height="20"
   Name="checkBoxBold"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Bold, Mode=TwoWay}">
   Bold</CheckBox>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BottomAligned Property

Gets or sets a value specifying whether text is bottom aligned at the current input position. If text is selected, the property specifies this attribute for the whole selected text. In table cells text can be vertically aligned, at the top, at the bottom and centered. Outside of table cells, the vertical alignment is always at the top.

Introduced: 24.0.

Syntax

[C#]
public bool? BottomAligned { get; set; }
[Visual Basic]
Public Property BottomAligned() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple table cells with mixed setting.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.VerticallyCentered Property

Gets or sets a value specifying whether text is vertically centered at the current text input position. If text is selected, the property specifies this attribute for the whole selected text. In table cells text can be vertically aligned, at the top, at the bottom and centered. Outside of table cells, the vertical alignment is always at the top.

Introduced: 24.0.

Syntax

[C#]
public bool? VerticallyCentered { get; set; }
[Visual Basic]
Public Property VerticallyCentered() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple table cells with mixed setting.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BottomDistance Property

Gets or sets a bottom paragraph distance, in twips, at the current input position. If text is selected, the property specifies the bottom distance of the whole selected text.

Syntax

[C#]
public int? BottomDistance { get; set; }
[Visual Basic]
Public Property BottomDistance() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different bottom distances.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the BottomDistance property to a text box using the WPF.MeasureConverter class. The value of the bottom distance is converted to centimeter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Centimeter" x:Key="twipsConv" />
</Window.Resources>
…
<TextBox
   Text="{Binding
      ElementName=textControl1,
      Path=InputFormat.BottomDistance,
      Converter={StaticResource twipsConv},
      Mode=TwoWay}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BottomFrameLine Property

Gets or sets a value specifying whether there is a frame line at the bottom of the text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool BottomFrameLine { get; set; }
[Visual Basic]
Public Property BottomFrameLine() Boolean

Example

The following XAML example shows how to bind the BottomFrameLine property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Bottom Frame Line"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.BottomFrameLine}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BoxFrame Property

Gets or sets a value specifying whether there is a complete frame around the text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool BoxFrame { get; set; }
[Visual Basic]
Public Property BoxFrame() Boolean

Example

The following XAML example shows how to bind the BoxFrame property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Box Frame"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.BoxFrame}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BulletCharacter Property

Gets or sets the bullet character at the current input position. If text is selected, the property specifies the bullet character of the whole selected text.

Syntax

[C#]
public char? BulletCharacter { get; set; }
[Visual Basic]
Public Property BulletCharacter() As Nullable(Of Char)

Remarks

The property returns null when the text selection contains several lists with different bullet characters.

Example

The following XAML example shows how to bind the BulletCharacter property to a checkable menu item showing a diamond shaped bullet using the WPF.BooleanConverter class. (For other possible bullet characters see character codes of the "Symbol" font)

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<MenuItem
   Header="&#x00A8;"
   FontFamily="Symbol"
   IsCheckable="True"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.BulletCharacter,
      Converter={StaticResource boolConv},
      ConverterParameter=&#x00A8;}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.BulletedList Property

Gets or sets a value specifying whether there is a bulleted list at the current input position. The bullet character is determined through the BulletCharacter property. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? BulletedList { get; set; }
[Visual Basic]
Public Property BulletedList() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains different list settings.

Example

The following XAML example shows how to bind the BulletedList property to a checkable menu item.

<MenuItem
   Header="Bulleted List"
   IsCheckable="True"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.BulletedList}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Centered Property

Gets or sets a value specifying whether text is centered at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Centered { get; set; }
[Visual Basic]
Public Property Centered() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the Centered property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonCentered"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Centered, Mode=TwoWay}">
   Centered</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.FontFamily Property

Gets or sets the font family at the current input position. If text is selected, the property specifies the font family of the whole selected text.

Syntax

[C#]
public string FontFamily { get; set; }
[Visual Basic]
Public Property FontFamily() As String

Remarks

The property returns null when the text selection contains multiple characters with mixed font names.

Example

The following XAML example shows how to bind a combo box to the FontFamily property using GetFontFamilies to fill the combo box with available font names.

<ComboBox
   Name="cbFontFamily"
   IsEditable="True"
   IsReadOnly="True"
   Width="150"
   DropDownOpened="cbFontFamily_DropDownOpened"
   Text="{Binding ElementName=textControl1, Path=InputFormat.FontFamily}" />
[C#]
private void cbFontFamily_DropDownOpened(object sender, EventArgs e) {
   cbFontFamily.ItemsSource = textControl1.InputFormat.GetFontFamilies();
}
[Visual Basic]
Private Sub cbFontFamily_DropDownOpened(sender As Object, e As EventArgs)
   cbFontFamily.ItemsSource = textControl1.InputFormat.GetFontFamilies()
End Sub

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.FontSize Property

Gets or sets the font's size, in twips, at the current input position. If text is selected, the property specifies the font size of the whole selected text.

Syntax

[C#]
public int? FontSize { get; set; }
[Visual Basic]
Public Property FontSize() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple characters with mixed font sizes.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the FontSize property to a text box. The size is converted to Point:

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Point" Decimals="1" x:Key="twipsconv" />
</Window.Resources>
…
<TextBox
   Height="21"
   Name="textBoxFontSize"
   Text="{Binding ElementName=textControl1,
      Path=InputFormat.FontSize,
      Converter={StaticResource twipsconv},
      Mode=TwoWay}"/>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.FrameLineColor Property

Gets or sets the color used to display the color of frame lines at the current text input position. If text is selected, the property specifies the color of frame lines used in the whole selected text. A frame line color can be set for table cells and paragraphs.

Introduced: 24.0.

Syntax

[C#]
public System.Drawing.Color? FrameLineColor { get; set; }
[Visual Basic]
Public Property FrameLineColor() As Nullable(Of System.Drawing.Color)

Remarks

The property returns null when the text selection contains multiple frame lines with mixed colors.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.FrameLineWidth Property

Gets or sets the line width, in twips, of the paragraph's or table's frame at the current input position. If text is selected, the property specifies the line width of the whole selected text.

Introduced: 24.0.

Syntax

[C#]
public int? FrameLineWidth { get; set; }
[Visual Basic]
Public Property FrameLineWidth() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs or table cells with different frames.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.GetFontFamilies Method

Returns an array of strings specifying all supported fonts. These fonts depend on the formatting device set with the WPF.TextControl.FormattingPrinter or TextControl.FormattingPrinter property and on attributes set with the WPF.TextControl.FontSettings or TextControl.FontSettings property.

Syntax

[C#]
public string[] GetFontFamilies()
[Visual Basic]
Public Function GetFontFamilies() As String()

Return Value

The return value is the list of available fonts.

Example

The following XAML example shows how to bind a combo box to the FontFamily property using GetFontFamilies to fill the combo box with available font names.

<ComboBox
   Name="cbFontFamily"
   IsEditable="True"
   IsReadOnly="True"
   Width="150"
   DropDownOpened="cbFontFamily_DropDownOpened"
   Text="{Binding ElementName=textControl1, Path=InputFormat.FontFamily}" />
[C#]
private void cbFontFamily_DropDownOpened(object sender, EventArgs e) {
   cbFontFamily.ItemsSource = textControl1.InputFormat.GetFontFamilies();
}
[Visual Basic]
Private Sub cbFontFamily_DropDownOpened(sender As Object, e As EventArgs)
   cbFontFamily.ItemsSource = textControl1.InputFormat.GetFontFamilies()
End Sub

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.GetFontSizes Method

Returns all possible font sizes of a certain font.

GetFontSizes()

Returns an array of strings specifying all possible font sizes for the font at the text input position. If the font is free scalable, standard sizes are returned.

[C#]
public string[] GetFontSizes()
[Visual Basic]
Public Function GetFontSizes() As String()

GetFontSizes(String)

Returns an array of strings specifying all possible font sizes for specified font. If the font is free scalable, standard sizes are returned.

[C#]
public string[] GetFontSizes(string fontFamily)
[Visual Basic]
Public Function GetFontSizes(ByVal Font As String) As String()
Member | Description
fontFamily | Specifies the font the possible sizes of which are returned. It must be a font in the list of supported fonts which are returned through the GetFontFamilies method.

Return Value

The return value is the list of possible font sizes. Null is returned, if the specified font is not supported or if text is selected and the selection contains several different fonts.

Example

The following XAML example shows how to bind a combo box to the FontSize property using GetFontSizes to fill the combo box with available font sizes.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Point" Decimals="1" x:Key="twipsConv" />
</Window.Resources>
…
<ComboBox
   Name="cbFontSize"
   IsEditable="True"
   IsReadOnly="True"
   Width="50"
   DropDownOpened="cbFontSize_DropDownOpened"
   Text="{Binding
   ElementName=textControl1,
   Path=InputFormat.FontSize,
   Converter={StaticResource twipsConv}}" />
[C#]
private void cbFontSize_DropDownOpened(object sender, EventArgs e) {
   cbFontSize.ItemsSource = textControl1.InputFormat.GetFontSizes();
}
[Visual Basic]
Private Sub cbFontSize_DropDownOpened(sender As Object, e As EventArgs)
   cbFontSize.ItemsSource = textControl1.InputFormat.GetFontSizes()
End Sub

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.HangingIndent Property

Gets or sets the hanging indent, in twips, at the current input position. If text is selected, the property specifies the hanging indent of the whole selected text. A negative value indicates an additional indent of the paragraph's first line.

Syntax

[C#]
public int? HangingIndent { get; set; }
[Visual Basic]
Public Property HangingIndent() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different hanging indents.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the HangingIndent property to a text box using the WPF.MeasureConverter class. The value of the hanging indent is converted to centimeter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Centimeter" x:Key="twipsConv" />
</Window.Resources>
…
<TextBox
   Text="{Binding
      ElementName=textControl1,
      Path=InputFormat.HangingIndent,
      Converter={StaticResource twipsConv},
      Mode=TwoWay}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.InnerHorizontalFrameLines Property

Gets or sets a value specifying whether all inner horizontal frame lines are set for the selected text. This can be either table frame lines or lines between paragraphs.

Syntax

[C#]
public bool InnerHorizontalFrameLines { get; set; }
[Visual Basic]
Public Property InnerHorizontalFrameLines() Boolean

Example

The following XAML example shows how to bind the InnerHorizontalFrameLines property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Inner Horizontal Frame Lines"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.InnerHorizontalFrameLines}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.InnerVerticalFrameLines Property

Gets or sets a value specifying whether all inner vertical frame lines are set for the selected text. If the selected text contains no table, this property has no meaning.

Syntax

[C#]
public bool InnerVerticalFrameLines { get; set; }
[Visual Basic]
Public Property InnerVerticalFrameLines() Boolean

Example

The following XAML example shows how to bind the InnerVerticalFrameLines property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Inner Vertical Frame Lines"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.InnerVerticalFrameLines}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Italic Property

Gets or sets a value specifying whether the text is italic at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Italic { get; set; }
[Visual Basic]
Public Property Italic() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed setting.

Example

The following XAML example binds the Italic property to a check box:

<CheckBox
   Height="20"
   Name="checkBoxItalic"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Italic, Mode=TwoWay}">
   Italic</CheckBox>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Justified Property

Gets or sets a value specifying whether text is justified at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Justified { get; set; }
[Visual Basic]
Public Property Justified() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the Justified property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonJustified"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Justified, Mode=TwoWay}">
   Justified</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.LeftAligned Property

Gets or sets a value specifying whether text is left aligned at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? LeftAligned { get; set; }
[Visual Basic]
Public Property LeftAligned() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the LeftAligned property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonLeftAligned"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.LeftAligned, Mode=TwoWay}">
   Left Aligned</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.LeftFrameLine Property

Gets or sets a value specifying whether there is a frame line at the left side of the text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool LeftFrameLine { get; set; }
[Visual Basic]
Public Property LeftFrameLine() Boolean

Example

The following XAML example shows how to bind the LeftFrameLine property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Left Frame Line"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.LeftFrameLine}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.LeftIndent Property

Gets or sets the left indent, in twips, at the current input position. If text is selected, the property specifies the left indent of the whole selected text.

Syntax

[C#]
public int? LeftIndent { get; set; }
[Visual Basic]
Public Property LeftIndent() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different left indents.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the LeftIndent property to a text box. The value of the left indent is converted to centimeter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Centimeter" x:Key="twipsconv" />
</Window.Resources>
…
<TextBox
   Height="21"
   Name="textBoxLeftIndent"
   Text="{Binding ElementName=textControl1,
      Path=InputFormat.LeftIndent,
      Converter={StaticResource twipsconv},
      Mode=TwoWay}"/>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.LeftToRight Property

Gets or sets a value specifying whether the writung direction is left-to-right at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Introduced: 20.0.

Syntax

[C#]
public bool? LeftToRight { get; set; }
[Visual Basic]
Public Property LeftToRight() As Nullable(Of Boolean)

Remarks

The property returns null, if the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the LeftToRight property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonLeftToRight"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.LeftToRight, Mode=TwoWay}">
   Left to Right</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.LineSpacing Property

Gets or sets the line spacing, in percent, at the current input position. If text is selected, the property specifies the line spacing of the whole selected text.

Syntax

[C#]
public int? LineSpacing { get; set; }
[Visual Basic]
Public Property LineSpacing() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different line spacing.

Example

The following XAML example shows how to bind the LineSpacing property to a checkable menu item using the WPF.BooleanConverter class.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<MenuItem
   Header="1.5"
   IsCheckable="True"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.LineSpacing,
      Converter={StaticResource boolConv},
      ConverterParameter=150}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.NumberedList Property

Gets or sets a value specifying whether there is a numbered list at the current input position. The number format is determined through the NumberedListFormat property. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? NumberedList { get; set; }
[Visual Basic]
Public Property NumberedList() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains different list settings.

Example

The following XAML example shows how to bind the NumberedList property to a checkable menu item.

<MenuItem
   Header="Numbered List"
   IsCheckable="True"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.NumberedList}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.NumberedListFormat Property

Gets or sets the number format for a numbered list at the current input position. If text is selected, the property specifies this attribute for the whole selected text. This property determines the number format for the NumberedList property. The property's value is a member of the NumberFormat enumeration.

Syntax

[C#]
public NumberFormat NumberedListFormat { get; set; }
[Visual Basic]
Public Property NumberedListFormat() As NumberFormat
Value | Description
ArabicNumbers | The list is numbered with Arabic numbers (1, 2, 3...).
Letters | The list is numbered with letters (a, b, c...).
CapitalLetters | The list is numbered with capital letters (A, B, C...).
RomanNumbers | The list is numbered with Roman numbers (I, II, III...).
SmallRomanNumbers | The list is numbered with small Roman numbers (i, ii, iii...).

Remarks

The property's default value is NumberFormat.ArabicNumbers.

The property returns NumberFormat.None, if the text selection has no common number format.

Example

The following XAML example shows how to bind radio buttons to the NumberedListFormat property using the WPF.BooleanConverter class and the NumberFormats property.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[0], Mode=OneTime}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=ArabicNumbers}" />
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[1], Mode=OneTime}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=Letters}" />
…

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.NumberFormats Property

Returns an array of all supported number formats for numbered and structured lists. This property can be used to fill a combo box or a menu.

Syntax

[C#]
public NumberFormat[] NumberFormats { get; }
[Visual Basic]
Public ReadOnly Property NumberFormats() As NumberFormat()
Value | Description
ArabicNumbers | The list is numbered with Arabic numbers (1, 2, 3...).
Letters | The list is numbered with letters (a, b, c...).
CapitalLetters | The list is numbered with capital letters (A, B, C...).
RomanNumbers | The list is numbered with Roman numbers (I, II, III...).
SmallRomanNumbers | The list is numbered with small Roman numbers (i, ii, iii...).

Limitations

Read only.

Example

The following XAML example shows how to bind radio buttons to the NumberedListFormat property using the WPF.BooleanConverter class and the NumberFormats property.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[0], Mode=OneTime}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=ArabicNumbers}" />
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[1], Mode=OneTime}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=Letters}" />
…

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.RightAligned Property

Gets or sets a value specifying whether text is right aligned at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? RightAligned { get; set; }
[Visual Basic]
Public Property RightAligned() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the RightAligned property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonRightAligned"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.RightAligned, Mode=TwoWay}">
   Right Aligned</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.RightFrameLine Property

Gets or sets a value specifying whether there is a frame line at the right side of the text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool RightFrameLine { get; set; }
[Visual Basic]
Public Property RightFrameLine() Boolean

Example

The following XAML example shows how to bind the RightFrameLine property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Right Frame Line"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.RightFrameLine}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.RightIndent Property

Gets or sets the right indent, in twips, at the current input position. If text is selected, the property specifies the right indent of the whole selected text.

Syntax

[C#]
public int? RightIndent { get; set; }
[Visual Basic]
Public Property RightIndent() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different right indents.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the RightIndent property to a text box. The value of the right indent is converted to centimeter:

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
  <tx:MeasureConverter Unit="Centimeter" x:Key="twipsconv" />
</Window.Resources>
…
<TextBox
   Height="21"
   Name="textBoxRightIndent"
   Text="{Binding ElementName=textControl1,
      Path=InputFormat.RightIndent,
      Converter={StaticResource twipsconv},
      Mode=TwoWay}"/>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.RightToLeft Property

Gets or sets a value specifying whether the writing direction is right-to-left at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Introduced: 20.0.

Syntax

[C#]
public bool? RightToLeft { get; set; }
[Visual Basic]
Public Property RightToLeft() As Nullable(Of Boolean)

Remarks

The property returns null, if the text selection contains multiple paragraphs with mixed setting.

Example

The following XAML example binds the RightToLeft property to a ToggleButton:

<ToggleButton
   Height="29"
   Name="buttonRightToLeft"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.RightToLeft, Mode=TwoWay}">
   Right to Left</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Strikeout Property

Gets or sets a value specifying whether the text is strikeout at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Strikeout { get; set; }
[Visual Basic]
Public Property Strikeout() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed setting.

Example

The following XAML example binds the Strikeout property to a check box:

<CheckBox
   Height="20"
   Name="checkBoxStrikeout"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Strikeout, Mode=TwoWay}">
   Strikeout</CheckBox>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.StructuredList Property

Gets or sets a value specifying whether there is a structured list at the current input position. The number format is determined through the StructuredListFormat property. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? StructuredList { get; set; }
[Visual Basic]
Public Property StructuredList() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains different list settings.

Example

The following XAML example shows how to bind the StructuredList property to a checkable menu item.

<MenuItem
   Header="Structured List"
   IsCheckable="True"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.StructuredList}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.StructuredListFormat Property

Gets or sets the number format for a structured list at the current input position. If text is selected, the property specifies this attribute for the whole selected text. This property determines the number format for the StructuredList property. The property's value is a member of the NumberFormat enumeration.

Syntax

[C#]
public NumberFormat StructuredListFormat { get; set; }
[Visual Basic]
Public Property StructuredListFormat() As NumberFormat
Value | Description
ArabicNumbers | The list is numbered with Arabic numbers (1, 2, 3...).
Letters | The list is numbered with letters (a, b, c...).
CapitalLetters | The list is numbered with capital letters (A, B, C...).
RomanNumbers | The list is numbered with Roman numbers (I, II, III...).
SmallRomanNumbers | The list is numbered with small Roman numbers (i, ii, iii...).

Remarks

The property's default value is NumberFormat.ArabicNumbers.

The property returns NumberFormat.None, if the text selection has no common number format.

Example

The following XAML example shows how to bind radio buttons to the StructuredListFormat property using the WPF.BooleanConverter class and the NumberFormats property.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[0], Mode=OneTime}"
   GroupName="structuredListFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.StructuredListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=ArabicNumbers}" />
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[1], Mode=OneTime}"
   GroupName="structuredListFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.StructuredListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=Letters}" />
…

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.StyleName Property

Gets or sets the formatting style name at the current input position. If text is selected, the property specifies the style of the whole selected text.

Syntax

[C#]
public string StyleName { get; set; }
[Visual Basic]
Public Property StyleName() As String

Remarks

The property returns null when the text selection contains multiple characters with different styles.

Example

The following XAML example shows how to bind the StyleName property to a combo box which contains all style names returned by the StyleNames property.

<ComboBox
   Width="200"
   IsEditable="True"
   IsReadOnly="True"
   Text="{Binding ElementName=textControl1, Path=InputFormat.StyleName}"
   ItemsSource="{Binding ElementName=textControl1, Path=InputFormat.StyleNames}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.StyleNames Property

Returns an array of the names of all formatting styles, the document contains. This property can be used to fill a combo box or a menu.

Syntax

[C#]
public string[] StyleNames { get; }
[Visual Basic]
Public ReadOnly Property StyleNames() As String()

Limitations

Read only.

Example

The following XAML example shows how to bind the StyleName property to a combo box which contains all style names returned by the StyleNames property.

<ComboBox
   Width="200"
   IsEditable="True"
   IsReadOnly="True"
   Text="{Binding ElementName=textControl1, Path=InputFormat.StyleName}"
   ItemsSource="{Binding ElementName=textControl1, Path=InputFormat.StyleNames}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Subscript Property

Gets or sets a value specifying whether text is subscript at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Subscript { get; set; }
[Visual Basic]
Public Property Subscript() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed setting.

Example

The following XAML example binds the Subscript property to a toggle button:

<ToggleButton
   Height="20"
   Name="buttonSubscript"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Subscript, Mode=TwoWay}">
   Subscript</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Superscript Property

Gets or sets a value specifying whether text is superscript at the current input position. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Superscript { get; set; }
[Visual Basic]
Public Property Superscript() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed setting.

Example

The following XAML example binds the Superscript property to a toggle button:

<ToggleButton
   Height="20"
   Name="buttonSuperscript"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Superscript, Mode=TwoWay}">
   Superscript</ToggleButton>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.TextBackColor Property

Gets or sets the color used to display the text background color at the current input position. If text is selected, the property specifies the background color of the whole selected text.

Syntax

[C#]
public System.Drawing.Color? TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor() As Nullable(Of System.Drawing.Color)

Remarks

The property returns null when the text selection contains multiple characters with mixed colors.

Example

The following XAML example shows how to bind the TextBackColor property to the fill color of a rectangle using the WPF.ColorConverter class.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:ColorConverter x:Key="colorConv" />
</Window.Resources>
…
<Rectangle
   Width="20"
   Height="20">
   <Rectangle.Fill>
      <SolidColorBrush
         Color="{Binding
            ElementName=textControl1,
            Path=InputFormat.TextBackColor,
            Converter={StaticResource colorConv}}" />
   </Rectangle.Fill>
</Rectangle>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.TextColor Property

Returns or sets the color used to display the text at the current input position. If text is selected, the property specifies the text color of the whole selected text.

Syntax

[C#]
public System.Drawing.Color? TextColor { get; set; }
[Visual Basic]
Public Property TextColor() As Nullable(Of System.Drawing.Color)

Remarks

The property returns null when the text selection contains multiple characters with mixed colors.

Example

The following XAML example shows how to bind the TextColor property to the fill color of a rectangle using the WPF.ColorConverter class.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:ColorConverter x:Key="colorConv" />
</Window.Resources>
…
<Rectangle
   Width="20"
   Height="20">
   <Rectangle.Fill>
      <SolidColorBrush
         Color="{Binding
            ElementName=textControl1,
            Path=InputFormat.TextColor,
            Converter={StaticResource colorConv}}" />
   </Rectangle.Fill>
</Rectangle>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.TopAligned Property

Gets or sets a value specifying whether text is top aligned at the current input position. If text is selected, the property specifies this attribute for the whole selected text. In table cells text can be vertically aligned, at the top, at the bottom and centered. Outside of table cells, the vertical alignment is always at the top.

Introduced: 24.0.

Syntax

[C#]
public bool? TopAligned { get; set; }
[Visual Basic]
Public Property TopAligned() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple table cells with mixed setting.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.TopDistance Property

Gets or sets a top paragraph distance, in twips, at the current input position. If text is selected, the property specifies the top distance of the whole selected text.

Syntax

[C#]
public int? TopDistance { get; set; }
[Visual Basic]
Public Property TopDistance() As Nullable(Of Integer)

Remarks

The property returns null when the text selection contains multiple paragraphs with different top distances.

The WPF.MeasureConverter can be used to convert the property value to another measuring unit.

Example

The following XAML example binds the TopDistance property to a text box using the WPF.MeasureConverter class. The value of the top distance is converted to centimeter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Centimeter" x:Key="twipsConv" />
</Window.Resources>
…
<TextBox
   Text="{Binding
      ElementName=textControl1,
      Path=InputFormat.TopDistance,
      Converter={StaticResource twipsConv},
      Mode=TwoWay}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.TopFrameLine Property

Gets or sets a value specifying whether there is a frame line at the top of the text. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool TopFrameLine { get; set; }
[Visual Basic]
Public Property TopFrameLine() Boolean

Example

The following XAML example shows how to bind the TopFrameLine property to a checkable menu item.

<MenuItem
   IsCheckable="True"
   Header="Top Frame Line"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.TopFrameLine}" />

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.Underline Property

Gets or sets a value specifying whether text is underlined at the current input position. The underlining style is determined through the UnderlineStyle property. If text is selected, the property specifies this attribute for the whole selected text.

Syntax

[C#]
public bool? Underline { get; set; }
[Visual Basic]
Public Property Underline() As Nullable(Of Boolean)

Remarks

The property returns null when the text selection contains multiple characters with mixed styles.

Example

The following XAML example binds the Underline property to a check box:

<CheckBox
   Height="20"
   Name="checkBoxUnderline"
   IsChecked="{Binding ElementName=textControl1, Path=InputFormat.Underline, Mode=TwoWay}">
   Underline</CheckBox>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.UnderlineStyle Property

Gets or sets the underline style at the current input position. If text is selected, the property specifies this attribute for the whole selected text. This property determines the style for the Underline property.

Syntax

[C#]
public FontUnderlineStyle UnderlineStyle { get; set; }
[Visual Basic]
Public Property UnderlineStyle() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

Remarks

The property's default value is FontUnderlineStyle.Single.

The property returns FontUnderlineStyle.None, if the text selection has no common underline style.

Example

The following XAML example binds the UnderlineStyle property to the selected value of a combo box. The combo box is filled with all supported styles:

<ComboBox
   Height="24"
   Name="comboboxUnderlineStyle"
   ItemsSource="{Binding ElementName=textControl1, Path=InputFormat.UnderlineStyles, Mode=OneTime}"
   SelectedValue="{Binding ElementName=textControl1, Path=InputFormat.UnderlineStyle, Mode=TwoWay}"/>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputFormat.UnderlineStyles Property

Returns an array of all supported underline styles. This property can be used to fill a combo box or a menu.

Syntax

[C#]
public FontUnderlineStyle[] UnderlineStyles { get; }
[Visual Basic]
Public ReadOnly Property UnderlineStyles() As FontUnderlineStyle()
Value | Description
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

Limitations

Read only.

Example

The following XAML example binds the UnderlineStyle property to a menu item. The menu's header is bind to the UnderlineStyles property. The WPF.BooleanConverter returns true, if the UnderlineStyle property has the value specified through the ConverterParameter:

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
  <tx:BooleanConverter x:Key="enumboolconv" />
</Window.Resources>
…
<MenuItem
   IsCheckable="true"
   Header="{Binding ElementName=textControl1, Path=InputFormat.UnderlineStyles[0], Mode=OneTime}"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.UnderlineStyle,
      Converter={StaticResource enumboolconv}, ConverterParameter=Single}"/>

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.InputPosition Class

An instance of the InputPosition class represents the current text input position of a TXTextControl document.

Introduced: 10.1.

Syntax

[C#]
public class InputPosition
[Visual Basic]
Public Class InputPosition

Constructors

Constructor | Description
InputPosition | Overloaded. Creates a new instance of the InputPosition class.

Properties

Property | Description
CaretSize | Gets the size of the caret, in pixels, at the current text input position.
Column | Gets the column number of the current text input position.
InactiveMarker | Shows or hides a marker which indicates the current text input position when the TextControl is inactive and the blinking caret is not visible.
Line | Gets the line number of the current text input position.
Location | Gets the geometric location of the current text input position.
Page | Gets the page number of the current text input position.
PageInSection | Gets the page number in the section containing the current text input position.
Section | Gets the section number of the current text input position.
TextPosition | Gets the text position of the current text input position.

Methods

Method | Description
ScrollTo | Scrolls the contents of a Text Control so that the current input position becomes visible.

Example

The following example shows how to add a TextField to the document and how to set the input position right after the field.

[C#]
textControl1.Selection.Text = "Name: ";
TXTextControl.TextField field = new TXTextControl.TextField("%name%");
field.DoubledInputPosition = true;
field.ShowActivated = true;

textControl1.TextFields.Add(field);
textControl1.InputPosition = new TXTextControl.InputPosition(
                             field.Start + field.Length - 1,
                             TXTextControl.TextFieldPosition.OutsideTextField);
[Visual Basic]
TextControl1.Selection.Text = "Name: "
Dim field As TXTextControl.TextField = New TXTextControl.TextField("%name%")
field.DoubledInputPosition = True
field.ShowActivated = True

TextControl1.TextFields.Add(field)
TextControl1.InputPosition = New TXTextControl.InputPosition( _
                             field.Start + field.Length - 1, _
                             TXTextControl.TextFieldPosition.OutsideTextField)

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition Constructor

Creates a new instance of the InputPosition class.

InputPosition(Int32, Int32, Int32)

Creates a new input position from a page, line and column number.

[C#]
public InputPosition(int page, int line, int column);
[Visual Basic]
Public Sub New(ByVal page As Integer, ByVal line As Integer, ByVal column As Integer)
Parameter | Description
page | Specifies a page number.
line | Specifies a line number.
column | Specifies a column number. The first column is zero.

InputPosition(Int32)

Creates a new input position from a text position.

[C#]
public InputPosition(int textPosition);
[Visual Basic]
Public Sub New(ByVal textPosition As Integer)
Parameter | Description
textPosition | Specifies a text position. The first position is zero.

InputPosition(Int32, TextFieldPosition)

Creates a new input position from a text position with a special handling at the beginning and the end of a TextField.

[C#]
public InputPosition(int textPosition, TextFieldPosition textFieldPosition);
[Visual Basic]
Public Sub New(ByVal textPosition As Integer, ByVal textFieldPosition As TextFieldPosition)
Parameter | Description
textPosition | Specifies a text position. The first position is zero.
textFieldPosition | If the textPosition parameter is a position at the beginning or at the end of a TextField with a doubled input position, this parameter can be used to define whether the position is inside or outside the field. It can be one of the values of the TextFieldPosition enumeration.

InputPosition(Point)

Creates a new input position from a geometric location.

[C#]
public InputPosition(System.Drawing.Point location);
[Visual Basic]
Public Sub New(ByVal location As System.Drawing.Point)
Parameter | Description
location | Specifies a geometric location. The point must be specified in pixels with an origin at the top left corner of the control.

See Also

  • TXTextControl.Selection and Undo
  • Selection Class
  • TextField Class
  • TextField.DoubledInputPosition Property
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.CaretSize Property

Gets the size of the caret, in pixels, at the current text input position.

Introduced: 20.0.

Syntax

[C#]
public System.Drawing.Size CaretSize { get; }
[Visual Basic]
Public ReadOnly Property CaretSize() As System.Drawing.Size

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.Column Property

Gets the column number of the current text input position. The first column in front of the text is zero.

Syntax

[C#]
public int Column { get; }
[Visual Basic]
Public ReadOnly Property Column() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.InactiveMarker Property

Shows or hides a marker which indicates the current text input position when the TextControl is inactive and the blinking caret is not visible. If the property value is true, the marker is shown.

Introduced: 22.0.

Syntax

[C#]
public bool InactiveMarker { get; set; }
[Visual Basic]
Public Property InactiveMarker() As Boolean

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.Line Property

Gets the line number of the current text input position. The first line on top of the page is 1.

Syntax

[C#]
public int Line { get; }
[Visual Basic]
Public ReadOnly Property Line() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.Location Property

Gets the geometric location of the current text input position. The location is given in twips with an origin at the upper left corner of the document. The relationship between the upper left corner of the document and the upper left corner of the visible portion of the document can be obtained with the TextControl.ScrollLocation property.

Syntax

[C#]
public System.Drawing.Point Location { get; }
[Visual Basic]
Public ReadOnly Property Location() As System.Drawing.Point

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.Page Property

Gets the page number of the current text input position. This property returns the page number only if the TextControl.ViewMode property has been set to ViewMode.PageView.

Syntax

[C#]
public int Page { get; }
[Visual Basic]
Public ReadOnly Property Page() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.PageInSection Property

Gets the page number in the section containing the current text input position. This property returns the page number only if the TextControl.ViewMode property has been set to ViewMode.PageView.

Introduced: 14.0.

Syntax

[C#]
public int PageInSection { get; }
[Visual Basic]
Public ReadOnly Property PageInSection() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.ScrollTo Method

Scrolls the contents of a Text Control so that the current input position becomes visible.

Introduced: 22.0.

Syntax

[C#]
public void ScrollTo();
[Visual Basic]
Public Sub ScrollTo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.Section Property

Gets the section number of the current text input position. The first section in the document has the number 1.

Introduced: 14.0.

Syntax

[C#]
public int Section { get; }
[Visual Basic]
Public ReadOnly Property Section() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.InputPosition.TextPosition Property

Gets the text position of the current text input position. The first text position of a document is zero.

Syntax

[C#]
public int TextPosition { get; }
[Visual Basic]
Public ReadOnly Property TextPosition() As Integer

Limitations

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.LicenseLevelException Class

A LicenseLevelException is thrown when a feature is not contained in the currently licensed product level.

Introduced: 24.0.

Syntax

[C#]
public class LicenseLevelException : Exception
[Visual Basic]
Public Class LicenseLevelException
  Inherits EventArgs

Constructors

Constructor | Description
LicenseLevelException | Overloaded. Initializes a new instance of the LicenseLevelException class.

See Also

  • Programming Category: Exceptions


TXTextControl.LicenseLevelException Constructor

Initializes a new instance of the LicenseLevelException class.

LicenseLevelException()

Initializes a new instance of the LicenseLevelException class.

[C#]
public LicenseLevelException();
[Visual Basic]
Public Sub New

LicenseLevelException(String)

Initializes a new instance of the LicenseLevelException class with a specified error message.

[C#]
public LicenseLevelException(string message);
[Visual Basic]
Public Sub New(message as String)
Parameter | Description
message | The error message that explains the reason for the exception.

LicenseLevelException(String, Exception)

Initializes a new instance of the LicenseLevelException class with a specified error message and a reference to the inner exception that is the cause of this exception.

[C#]
public LicenseLevelException(string message, Exception innerException);
[Visual Basic]
Public Sub New(message as String, innerException as Exception)
Parameter | Description
message | The error message that explains the reason for the exception.
innerException | The exception that is the cause of the current exception.

See Also

  • Programming Category: Exceptions


TXTextControl.Line Class

An instance of the Line class represents a single line in a Text Control document.

Introduced: 10.1.

Syntax

[C#]
public class Line
[Visual Basic]
Public Class Line

Properties

Property | Description
Baseline | Gets the line's baseline position.
Length | Gets the number of characters in the line including the break character.
Number | Gets the line's number.
Page | Gets the number of the page to which the line belongs.
Start | Gets the number (one-based) of the first character in the line.
Text | Gets the line's text.
TextBounds | Gets the bounding rectangle of the text belonging to the line.

Methods

Method | Description
Save | Overloaded. Saves the line's text with the specified format.

Example

The following example shows how to read the document line by line.

[C#]
textControl1.Text = "Line 1\nLine 2\nLine 3";

foreach (TXTextControl.Line line in textControl1.Lines)
{
    Console.WriteLine("Line #" + line.Number.ToString() + " starts at: " +
        line.Start.ToString() + ". Text: " + line.Text);
}
[Visual Basic]
TextControl1.Text = "Line 1" + vbCrLf + "Line 2" + vbCrLf + "Line 3"

For Each line As TXTextControl.Line In TextControl1.Lines
    Console.WriteLine("Line #" + line.Number.ToString() + " starts at: " + _
            line.Start.ToString() + ". Text: " + line.Text)
Next

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Baseline Property

Gets the line's baseline position. The value is given in twips with an origin at the upper left corner of the document. The relationship between the upper left corner of the document and the upper left corner of the visible portion of the document can be obtained with the TextControl.ScrollLocation property.

Syntax

[C#]
public int Baseline { get; }
[Visual Basic]
Public ReadOnly Property Baseline() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Length Property

Gets the number of characters in the line including the break character.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Number Property

Gets the line's number. The first line has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Page Property

Gets the number of the page to which the line belongs. The first page has the number 1.

Introduced: 14.0.

Syntax

[C#]
public int Page { get; }
[Visual Basic]
Public ReadOnly Property Page() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Save Method

Saves the line's text with the specified format.

Save(Byte[], BinaryStreamType)

Saves the line's text in a byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the line's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the line's text as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the line's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the line's text in a byte array with the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the line's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the line's text as a string with the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the line's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Start Property

Gets the number (one-based) of the first character in the line.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.Text Property

Gets the line's text.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.Line.TextBounds Property

Gets the bounding rectangle of the text belonging to the line. The values are given in twips with an origin at the upper left corner of the document. The relationship between the upper left corner of the document and the upper left corner of the visible portion of the document can be obtained with the TextControl.ScrollLocation property.

Syntax

[C#]
public Rectangle TextBounds { get; }
[Visual Basic]
Public ReadOnly Property TextBounds() As Rectangle

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection Class

An instance of the LineCollection class contains all text lines in a Text Control document or part of the document represented through objects of the type Line. An instance of this class can be obtained with the TextControl.Lines, HeaderFooter.Lines or TextFrame.Lines property. The LineCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 10.1.

Syntax

[C#]
public class LineCollection : ICollection, IEnumerable
[Visual Basic]
Public Class LineCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Gets a particular line from the collection.
Item | Gets the line from the collection.

Example

The following example shows how to loop through all lines and how to get the according page number of that line.

[C#]
foreach (TXTextControl.Line line in textControl1.Lines)
{
    Console.WriteLine("Line " + line.Number.ToString() +
                  " is on page " + line.Page.ToString());
}
[Visual Basic]
For Each line As TXTextControl.Line In TextControl1.Lines
    Console.WriteLine("Line " + line.Number.ToString() + _
                          " is on page " + line.Page.ToString())
Next

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection.GetItem Method

Gets a particular line from the collection.

GetItem(Point)

Gets the line at a certain geometrical position.

[C#]
public Line GetItem(System.Drawing.Point location);
[Visual Basic]
Public Function GetItem(ByVal location As System.Drawing.Point) As Line
Parameter | Description
location | Specifies the line's location. The point must be specified in pixels with an origin at the top left corner of the control.

GetItem(Int32)

Gets the line at a certain text position.

[C#]
public Line GetItem(int textPosition);
[Visual Basic]
Public Function GetItem(ByVal textPosition As Integer) As Line
Parameter | Description
textPosition | Specifies a zero-based text position.

Return Value

The return value is null, if a line could not be found. Otherwise, it is an object of the type Line.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.LineCollection.Item Property

Gets the line from the collection. In C# this property is the indexer for the LineCollection class.

Syntax

[C#]
public Line this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As Line
Parameter | Description
number | Specifies a line number. The first line has the number 1.

Return Value

The return value is null, if the line could not be found. Otherwise, it is an object of the type Line.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.ListFormat Class

An instance of the ListFormat class represents the formatting attributes of a bulleted or numbered list.

Syntax

[C#]
public class ListFormat
[Visual Basic]
Public Class ListFormat

Constructors

Constructor | Description
ListFormat | Overloaded. Creates a new instance of the ListFormat class.

Properties

Property | Description
BulletCharacter | Gets or sets the symbol character for a bulleted list.
BulletSize | Gets or sets the size of the symbol character for a bulleted list.
CharAfterNumber | Obsolete. Gets or sets a character that is displayed behind the number in a numbered list.
CharBeforeNumber | Obsolete. Gets or sets a character that is displayed in front of the number in a numbered list.
FirstNumber | Gets or sets the starting number for a numbered list.
FontName | Gets or sets the font used for the bullet character.
FormatCharacter | Gets or sets the formatting character for a bulleted or numbered list.
HangingIndent | Gets or sets the hanging indent of a numbered list.
LeftIndent | Gets or sets the left indent for a numbered list.
Level | Gets or sets the level for a bulleted or numbered list.
NumberFormat | Gets or sets the number format for a numbered list.
RestartNumbering | Gets or sets a value determining whether a new numbered list begins.
TextAfterNumber | Gets or sets the text that is displayed behind the number in a numbered list.
TextBeforeNumber | Gets or sets the text that is displayed in front of the number in a numbered list.
Type | Gets or sets the type of the list, bulleted, numbered or none.

Enumerations

Enumeration | Description
Attribute | Determines a certain list format attribute.

Fields

Field | Description
MaxLevel | Represents the maximum of levels for bulleted and numbered lists.
MaxText | Represents the maximum number of charcters for the additinal text in front and behind the number of a numbered list.

Example

The following example shows how to create a new ListFormat and how to apply it at the current input position.

[C#]
TXTextControl.ListFormat lf = new TXTextControl.ListFormat();
lf.Type = TXTextControl.ListType.Numbered;
lf.FirstNumber = 5;

textControl1.Selection.ListFormat = lf;
[Visual Basic]
Dim lf As TXTextControl.ListFormat = New TXTextControl.ListFormat()
lf.Type = TXTextControl.ListType.Numbered
lf.FirstNumber = 5

TextControl1.Selection.ListFormat = lf

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat Constructor

Creates a new instance of the ListFormat class.

ListFormat()

Creates a new empty instance of the ListFormat class.

[C#]
public ListFormat();
[Visual Basic]
Public Sub New()

ListFormat(ListType)

Creates a new instance of the ListFormat class which has the specified list type.

[C#]
public ListFormat(ListType type);
[Visual Basic]
Public Sub New(ByVal type As ListType)
Parameter Description
type

Specifies one of the ListType values. The following values are possible:

Value | Meaning
None | The text is neither a bulleted nor a numbered list.
Bulleted | The list is a bulleted list.
Numbered | The list is a numbered list.
Structured | The list is a structured list. All numbers of higher levels (lower level numbers) are displayed in front of the list number. The additional text of all levels in front and behind the list numbers is also displayed.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.Attribute Enumeration

Determines a certain list format attribute. This enumeration is used with the Selection.IsCommonValueSelected method.

Member | Description
BulletCharacter | Specifies the attribute set through the BulletCharacter property.
BulletSize | Specifies the attribute set through the BulletSize property.
CharAfterNumber | Obsolete. Use the TextAfterNumber attribute instead.
CharBeforeNumber | Obsolete. Use the TextBeforeNumber attribute instead.
FirstNumber | Specifies the attribute set through the FirstNumber property.
FontName | Specifies the attribute set through the FontName property.
FormatCharacter | Specifies the attribute set through the FormatChar property.
HangingIndent | Specifies the attribute set through the HangingIndent property.
Level | Specifies the attribute set through the Level property.
LeftIndent | Specifies the attribute set through the LeftIndent property.
NumberFormat | Specifies the attribute set through the NumberFormat property.
RestartNumbering | Specifies the attribute set through the RestartNumbering property.
TextAfterNumber | Specifies the attribute set through the TextAfterNumber property.
TextBeforeNumber | Specifies the attribute set through the TextBeforeNumber property.
Type | Specifies the attribute set through the Type property.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.BulletCharacter Property

Gets or sets the symbol character for a bulleted list. It must be a value from the Windows Symbol character set.

Syntax

[C#]
public char BulletCharacter { get; set; }
[Visual Basic]
Public Property BulletCharacter() As Char

Remarks

The property's default value is the B7 (hexadecimal) character of the Windows Symbol character set.

The property returns its default value when the text selection contains multiple paragraphs with different bullet characters or when the text selection does not contain a bulleted list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.BulletSize Property

Gets or sets the size of the symbol character for a bulleted list. If this property is 0, the size of the font for the list text is used.

Syntax

[C#]
public int BulletSize { get; set; }
[Visual Basic]
Public Property BulletSize() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed bullet sizes or when the text selection does not contain a bulleted list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.CharAfterNumber Property

Obsolete. Gets or sets a character that is displayed behind the number in a numbered list. If this property is zero, no additional character is diplayed behind the number character. This property is obsolete and only available for compatibility. A new application should use the TextAfterNumber property.

Syntax

[C#]
public char CharAfterNumber { get; set; }
[Visual Basic]
Public Property CharAfterNumber() As Char

Remarks

The property returns 0 when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.CharBeforeNumber Property

Obsolete. Gets or sets a character that is displayed in front of the number in a numbered list. If this property is zero, no additional character is diplayed in front of the number character. This property is obsolete and only available for compatibility. A new application should use the TextBeforeNumber property.

Syntax

[C#]
public char CharBeforeNumber { get; set; }
[Visual Basic]
Public Property CharBeforeNumber() As Char

Remarks

The property returns 0 when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.FirstNumber Property

Gets or sets the starting number for a numbered list.

Syntax

[C#]
public int FirstNumber { get; set; }
[Visual Basic]
Public Property FirstNumber() As Integer

Remarks

The property's default value is 1.

The property returns its default value when the text selection contains multiple paragraphs with mixed starting numbers or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.FontName Property

Gets or sets the font used for the bullet character. When a new bullet character is set without specifying a font, the Windows Symbol font is assumed.

Introduced: 23.0.

Syntax

[C#]
public string FontName { get; set; }
[Visual Basic]
Public Property FontName() As String

Remarks

The property returns an empty string when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.FormatCharacter Property

Gets or sets the formatting character for a bulleted or numbered list.

Syntax

[C#]
public ListFormatCharacter FormatCharacter { get; set; }
[Visual Basic]
Public Property FormatCharacter() As ListFormatCharacter
Value | Description
Tab | The text of the list follows the bullet or number character at the next tab position.
Space | The text of the list follows the bullet or number character seperated through a space character.
None | The text of the list immediately follows the bullet or number character.

Remarks

The property's default value is ListFormatCharacter.Tab.

The property returns its default value when the text selection contains multiple paragraphs with mixed formatting characters or when the text selection does not contain a bulleted or a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.HangingIndent Property

Gets or sets the hanging indent of a numbered list.

Syntax

[C#]
public int HangingIndent { get; set; }
[Visual Basic]
Public Property HangingIndent() As Integer

Remarks

The property's default value is 360 twips.

The property returns 0 when the text selection contains multiple paragraphs with mixed hanging indents or when the text selection does not contain a bulleted or a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.LeftIndent Property

Gets or sets the left indent for a numbered list.

Syntax

[C#]
int LeftIndent { get; set; }
[Visual Basic]
Private Property LeftIndent() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed left indents or when the text selection does not contain a bulleted or a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.Level Property

Gets or sets the level for a bulleted or numbered list.

Syntax

[C#]
public int Level { get; set; }
[Visual Basic]
Public Property Level() As Integer

Remarks

The property's default value is 1.

The property returns its default value when the text selection contains multiple paragraphs with different levels or when the text selection does not contain a bulleted or a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

The level of a list must be between 1 and ParagraphFormat.MaxLevel.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.MaxLevel Field

Represents the maximum of levels for bulleted and numbered lists. The value of this constant is 10.

Syntax

[C#]
public const int MaxLevel;
[Visual Basic]
Public MaxLevel As Integer

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.MaxText Field

Represents the maximum number of charcters for the additinal text in front and behind the number of a numbered list. The value of this constant is 20.

Syntax

[C#]
public const int MaxText;
[Visual Basic]
Public MaxText As Integer

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.NumberFormat Property

Gets or sets the number format for a numbered list. The property's value is a member of the NumberFormat enumeration.

Syntax

[C#]
public NumberFormat NumberFormat { get; set; }
[Visual Basic]
Public Property NumberFormat() As NumberFormat
Value | Description
ArabicNumbers | The list is numbered with Arabic numbers (1, 2, 3...).
Letters | The list is numbered with letters (a, b, c...).
CapitalLetters | The list is numbered with capital letters (A, B, C...).
RomanNumbers | The list is numbered with Roman numbers (I, II, III...).
SmallRomanNumbers | The list is numbered with small Roman numbers (i, ii, iii...).

Remarks

The property's default value is NumberFormat.ArabicNumbers.

The property returns its default value when the text selection contains multiple paragraphs with mixed number formats or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.RestartNumbering Property

Gets or sets a value determining whether a new numbered list begins.

Syntax

[C#]
public bool RestartNumbering { get; set; }
[Visual Basic]
Public Property RestartNumbering() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.TextAfterNumber Property

Gets or sets the text that is displayed behind the number in a numbered list. If this property is an empty string, no additional text is diplayed behind the number. This property replaces the CharAfterNumber property of this class.

Introduced: 15.0.

Syntax

[C#]
public string TextAfterNumber { get; set; }
[Visual Basic]
Public Property TextAfterNumber() As String

Remarks

The property returns an empty string when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.TextBeforeNumber Property

Gets or sets the text that is displayed in front of the number in a numbered list. If this property is an empty string, no additional text is diplayed in front of the number. This property replaces the CharBeforeNumber property of this class.

Introduced: 15.0.

Syntax

[C#]
public string TextBeforeNumber { get; set; }
[Visual Basic]
Public Property TextBeforeNumber() As String

Remarks

The property returns an empty string when the text selection contains multiple paragraphs with mixed settings or when the text selection does not contain a numbered list. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ListFormat.Type Property

Gets or sets the type of the list, bulleted, numbered or none. The property's value is one of the values of the ListType enumeration.

Syntax

[C#]
public ListType Type { get; set; }
[Visual Basic]
Public Property Type() As ListType
Value | Description
None | The text is neither a bulleted nor a numbered list.
Bulleted | The list is a bulleted list.
Numbered | The list is a numbered list.
Structured | The list is a structured list. All numbers of higher levels (lower level numbers) are displayed in front of the list number. The additional text of all levels in front and behind the list numbers is also displayed.

Remarks

The property's default value is ListType.None.

The property returns its default value when the text selection contains multiple paragraphs with mixed types. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.LoadSettings Class

The LoadSettings class provides properties for advanced settings and information during load operations. See the TextControl.Load method for more information.

Syntax

[C#]
public sealed class LoadSettings
[Visual Basic]
Public NotInheritable Class LoadSettings

Properties

Property | Description
ApplicationFieldFormat | Specifies the format of text fields which are imported.
ApplicationFieldTypeNames | Specifies an array of strings containing the type names of fields which are to be imported.
Author | Gets the document's author.
BytesRead | Gets the number of bytes read during the load operation.
CreationDate | Gets the document's creation date.
CreatorApplication | Gets the application, which has created the document.
CssFileName | Gets the path and filename of the CSS file belonging to a HTML or XML document.
DocumentAccessPermissions | Specifies how a document can be accessed after it has been loaded.
DocumentBasePath | Sets a file path that is used to search for resources like images or hypertext links.
DocumentKeywords | Gets the document's keywords.
DocumentSubject | Gets the document's subject string.
DocumentTitle | Gets the document's title.
ImageSearchPath | Sets a file path that is used to search for resources like images or hypertext links.
LastModificationDate | Gets the date the document is last modified.
LoadDocumentBackColor | Specifies whether or not the document background color is loaded.
LoadedFile | Gets the name and path of the file that has been loaded.
LoadedStreamType | Gets the StreamType of the file that has been loaded.
LoadHypertextLinks | Specifies whether or not hypertext links are loaded.
LoadImages | Specifies whether or not images are loaded.
LoadSubTextParts | DOCX Format only: Specifies whether or not bookmarks which extend over several characters are converted to SubTextParts.
MasterPassword | Specifies the password when the document is restricted with access permissions.
PageMargins | Gets the margins of the loaded document's pages.
PageSize | Gets the width and height of the loaded document's pages.
PDFImportSettings | Specifies how the document structure is generated when a PDF document is imported.
ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is loaded.
UserDefinedDocumentProperties | Gets a dictionary with all user-defined document properties contained in the loaded document.
UserPassword | Specifies the password for the user to open a password protected document.

Example

The following example shows how to use the LoadSettings to get the filename and the read bytes of a loaded document.

[C#]
TXTextControl.LoadSettings ls = new TXTextControl.LoadSettings();

if (textControl1.Load(TXTextControl.StreamType.All, ls) == DialogResult.OK)
{
    MessageBox.Show(ls.LoadedFile + " has been loaded. " + ls.BytesRead.ToString() + " bytes read.");
}
[Visual Basic]
Dim ls As TXTextControl.LoadSettings = New TXTextControl.LoadSettings()

If TextControl1.Load(TXTextControl.StreamType.All, ls) = DialogResult.OK Then
    MessageBox.Show(ls.LoadedFile + " has been loaded. " + ls.BytesRead.ToString() + " bytes read.")
End If

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.ApplicationFieldFormat Property

Specifies the format of text fields which are imported. The property's value can be one of the ApplicationFieldFormat values.

Introduced: 14.0.

Syntax

[C#]
public ApplicationFieldFormat ApplicationFieldFormat { get; set; }
[Visual Basic]
Public Property ApplicationFieldFormat() As ApplicationFieldFormat
Value | Description
None | No field supported through another application is imported. This is the default value.
MSWord | Fields which are supported and defined through Microsoft Word are imported. The LoadSettings.ApplicationFieldTypeNames property can be used to select particular types of fields.
HighEdit | Fields which are supported and defined through the Heiler HighEdit component are imported.

Limitations

Microsoft Word and RTF only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.ApplicationFieldTypeNames Property

Specifies an array of strings containing the type names of fields which are to be imported. This property is only taken into account, if the LoadSettings.ApplicationFieldFormat property is set to ApplicationFieldFormat.MSWord or ApplicationFieldFormat.HighEdit. For example, if the LoadSettings.ApplicationFieldFormat is set to ApplicationFieldFormat.MSWord and this array has the single string MERGEFIELD only Microsoft Word Merge Fields are loaded. If this property is null, which is the default value, all fields with the format specified through the LoadSettings.ApplicationFieldFormat are loaded.

Introduced: 14.0.

Syntax

[C#]
public string[] ApplicationFieldTypeNames { get; set; }
[Visual Basic]
Public Property ApplicationFieldTypeNames() As String()

Limitations

Microsoft Word and RTF only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.Author Property

Gets the document's author. It is an empty string, if there is no author saved in the loaded document.

Introduced: 23.0.

Syntax

[C#]
public string Author { get; }
[Visual Basic]
Public ReadOnly Property Author() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.BytesRead Property

Gets the number of bytes read during the load operation.

Syntax

[C#]
public long BytesRead { get; }
[Visual Basic]
Public ReadOnly Property BytesRead() As Long

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.CreationDate Property

Gets the document's creation date. It is January 1, 0001 in the Gregorian calendar, if there is no creation date saved in the loaded document.

Introduced: 23.0.

Syntax

[C#]
public System.DateTime CreationDate { get; }
[Visual Basic]
Public ReadOnly Property CreationDate() As System.DateTime

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.CreatorApplication Property

Gets the application, which has created the document. It is an empty string, if a creator application is not saved in the loaded document.

Introduced: 23.0.

Syntax

[C#]
public string CreatorApplication { get; }
[Visual Basic]
Public ReadOnly Property CreatorApplication() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.CssFileName Property

Gets the path and filename of the CSS file belonging to a HTML or XML document.

Syntax

[C#]
public string CssFileName { get; }
[Visual Basic]
Public ReadOnly Property CssFileName() As String

Limitations

Read only.

HTML and XML only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.DocumentAccessPermissions Property

Specifies how a document can be accessed after it has been loaded. If a valid master password has been specified with the LoadSettings.MasterPassword property, the document can be accessed without any restrictions. The property's value can be a bitwise combination of more than one of the described values.

Introduced: 24.0.

Syntax

[C#]
public DocumentAccessPermissions DocumentAccessPermissions { get; }
[Visual Basic]
Public Property DocumentAccessPermissions() As DocumentAccessPermissions
Value | Description
None | Allows none of the possible permissions.
AllowAll | Allows all of the possible permissions.
AllowAuthoring | Allows authoring comments and fill in interactive form fields (including signature fields).
AllowAuthoringFields | Fill-in existing interactive form fields (including signature fields) is allowed.
AllowContentAccessibility | Allows content access for the visually impaired only.
AllowDocumentAssembly | Allows to assemble the document (insert, rotate or delete pages and create bookmarks or thumbnails).
AllowExtractContents | Copying or otherwise extracting text and/or graphics is allowed.
AllowGeneralEditing | Allows modifying the document's contents.
AllowHighLevelPrinting | Printing the document is fully allowed.
AllowLowLevelPrinting | Printing the document is allowed (low-level).

Limitations

Read only.

PDF only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.DocumentBasePath Property

Sets a file path that is used to search for resources like images or hypertext links. This path is added to all relative file paths used in the document.

Syntax

[C#]
public string DocumentBasePath { get; set; }
[Visual Basic]
Public Property DocumentBasePath() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.DocumentKeywords Property

Gets the document's keywords. The property value is null, if there are no keywords saved in the document.

Introduced: 23.0.

Syntax

[C#]
public string[] DocumentKeywords { get; }
[Visual Basic]
Public ReadOnly Property DocumentKeywords() As String()

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.DocumentSubject Property

Gets the document's subject string. It is an empty string, if there is no subject saved in the loaded document.

Introduced: 23.0.

Syntax

[C#]
public string DocumentSubject { get; }
[Visual Basic]
Public ReadOnly Property DocumentSubject() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.DocumentTitle Property

Gets the document's title. It is an empty string, if there is no title saved in the loaded document.

Syntax

[C#]
public string DocumentTitle { get; }
[Visual Basic]
Public ReadOnly Property DocumentTitle() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.ImageSearchPath Property

Sets a file path that is used to search for resources like images or hypertext links. This path replaces all absolute file paths used in the document.

Syntax

[C#]
public string ImageSearchPath { get; set; }
[Visual Basic]
Public Property ImageSearchPath() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LastModificationDate Property

Gets the date the document is last modified. It is January 1, 0001 in the Gregorian calendar, if such a date is not saved in the loaded document.

Introduced: 23.0.

Syntax

[C#]
public System.DateTime LastModificationDate { get; }
[Visual Basic]
Public ReadOnly Property LastModificationDate() As System.DateTime

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadDocumentBackColor Property

Specifies whether or not the document background color is loaded. By default it is loaded.

Introduced: 24.0.

Syntax

[C#]
public bool LoadDocumentBackColor { get; set; }
[Visual Basic]
Public Property LoadDocumentBackColor() As Boolean

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadedFile Property

Gets the name and path of the file that has been loaded.

Syntax

[C#]
public string LoadedFile { get; }
[Visual Basic]
Public ReadOnly Property LoadedFile() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadedStreamType Property

Gets the StreamType of the file that has been loaded.

Syntax

[C#]
public StreamType LoadedStreamType { get; }
[Visual Basic]
Public ReadOnly Property LoadedStreamType() As StreamType

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadHypertextLinks Property

Specifies whether or not hypertext links are loaded. By default hypertext links are loaded.

Syntax

[C#]
public bool LoadHypertextLinks { get; set; }
[Visual Basic]
Public Property LoadHypertextLinks() As Boolean

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadImages Property

Specifies whether or not images are loaded. If set to false images are displayed through a rectangle and the image's name. By default images are loaded.

Syntax

[C#]
public bool LoadImages { get; set; }
[Visual Basic]
Public Property LoadImages() As Boolean

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.LoadSubTextParts Property

DOCX Format only: Specifies whether or not bookmarks which extend over several characters are converted to SubTextParts. By default bookmarks are converted to DocumentTargets and when a bookmark extend over several characters, the first character is used as the target position.

Introduced: 23.0.

Syntax

[C#]
public bool LoadSubTextParts { get; set; }
[Visual Basic]
Public Property LoadSubTextParts() As Boolean

Limitations

DOCX Format only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.MasterPassword Property

Specifies the password when the document is restricted with access permissions. If the password is valid, the document is not restricted after loading. If the password is invalid or not specified, the access permissions are given through the LoadSettings.DocumentAccessPermissions property.

Introduced: 24.0.

Syntax

[C#]
public string MasterPassword { get; set; }
[Visual Basic]
Public Property MasterPassword() As String

Limitations

PDF only. The encryption key length is 128 bits.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.PageMargins Property

Gets the margins of the loaded document's pages. If the document does not contain margins the values are set to -1.

Syntax

[C#]
public PageMargins PageMargins { get; }
[Visual Basic]
Public ReadOnly Property PageMargins() As PageMargins

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.PageSize Property

Gets the width and height of the loaded document's pages. If the document does not contain a page size the Width and Height is set to 0.

Syntax

[C#]
public System.Drawing.Size PageSize { get; }
[Visual Basic]
Public ReadOnly Property PageSize() As System.Drawing.Size

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.PDFImportSettings Property

Specifies how the document structure is generated when a PDF document is imported. Adobe PDF format is a low-level output format. In most cases in contains only geometrical information about the single characters. A high-level document structure specifying paragraphs, tables, sections and styles is not available. The TXTextControl PDF import filter will reconstruct the original document according to the value of the PDFImportSettigs property.

Introduced: 15.0.

Syntax

[C#]
public PDFImportSettings PDFImportSettings { get; set; }
[Visual Basic]
Public Property PDFImportSettings() As PDFImportSettings
Value | Description
GenerateLines | Text only,images and paragraph formatting are discarded. This option is best suited for searching PDF files.
GenerateParagraphs | Generates paragraphs from the text flow. Images are discarded.
GenerateTextFrames | Default. Uses tables, images and text frames to create a document that best matches the original document's appearance.
GenerateXML | Creates an XML format where each line of text has attributes like page number and geometrical position.

Limitations

PDF only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.ReportingMergeBlockFormat Property

Specifies how reporting merge blocks are handled when a document is loaded. Reporting merge blocks can be saved in a document either through special document targets represented through DocumentTarget objects or through special subtextparts represented through SubTextPart objects. When a merge block is marked with document targets, the name of the starting marker begins with blockstart_ and the name of the ending marker begins with blockend_. When a merge block is marked through a subtextpart, its name begins with txmb_.

Introduced: 24.0.

Syntax

[C#]
public ReportingMergeBlockFormat ReportingMergeBlockFormat { get; set; }
[Visual Basic]
Public Property ReportingMergeBlockFormat() As ReportingMergeBlockFormat
Value | Description
Default | The document is loaded as it is. Reporting merge blocks are not converted.
DocumentTargets | This member is not used, when a document is loaded.
SubTextParts | If the document contains reporting merge blocks marked with document targets, these targets are converted to subtextparts.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.UserDefinedDocumentProperties Property

Gets a dictionary with all user-defined document properties contained in the loaded document. The property's value is an object of the type UserDefinedPropertyDictionary or null, if the document does not contain any user-defined property.

Introduced: 24.0.

Syntax

[C#]
public UserDefinedPropertyDictionary UserDefinedDocumentProperties { get; }
[Visual Basic]
Public ReadOnly Property UserDefinedDocumentProperties() As UserDefinedPropertyDictionary

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.LoadSettings.UserPassword Property

Specifies the password for the user to open a password protected document. When the password is invalid or not specified, an exception is thrown.

Introduced: 24.0.

Syntax

[C#]
public string UserPassword { get; set; }
[Visual Basic]
Public Property UserPassword() As String

Limitations

PDF only. The encryption key length is 128 bits.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.MainText

The MainText class represents the main text of a TX Text Control document. A TX Text Control document consists of the main text, and additionally other pieces of text such as text frames and headers or footers. The MainText class implements the IFormattedText interface. Differently from the TextControl or WPF.TextControl classes the MainText object's collections of the IFormattedText interface do not depend on the input focus. For example, the TextControl.Tables collection contains the tables of the main text, if the main text has the input focus, but it contains the tables of the text frame, if a text frame has the input focus. The MainText.Tables collection always contains the tables of the main text regardless of the input focus.

Introduced: 16.0.

Syntax

[C#]
public class MainText
[Visual Basic]
Public Class MainText

Properties

Property | Description
ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
Barcodes | Gets a collection of all barcodes contained in the main text of the document.
Charts | Gets a collection of all charts contained in the main text of the document.
DocumentLinks | Gets a collection of all links in the main text of the document which point to targets in the same document.
DocumentTargets | Gets a collection of all targets in the main text of the document.
Drawings | Gets a collection of all drawings contained in the main text of the document.
Frames | Gets a collection of all images, textframes, charts, barcodes and drawings contained in the main text of the document.
HypertextLinks | Gets a collection of all hypertext links contained in the main text of the document.
Images | Gets a collection of all images contained in the main text of the document.
Lines | Gets a collection of all text lines contained in the main text of the document.
MisspelledWords | Gets a collection of all misspelled words contained in the main text of the document.
Paragraphs | Gets a collection of all paragraphs contained in the main text of the document.
Selection | Gets or sets the current selection in the main text of the document.
SubTextParts | Gets a collection of all subtextparts contained in the main text of the document.
Tables | Gets a collection of all tables contained in the main text of the document.
TextChars | Gets a collection of all characters contained in the main text of the document.
TextFields | Gets a collection of all standard text fields contained in the main text of the document.
TextFrames | Gets a collection of all text frames contained in the main text of the document.

Methods

Method | Description
Find | Finds a text string in the main text of the document.
GetTextFields | Returns a collection containing text fields of the specified types.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.ApplicationFields Property

Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. The collection contains all fields contained in the main text of the document.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Barcodes Property

Gets a collection of all barcodes contained in the main text of the document. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from the main text of the document.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Charts Property

Gets a collection of all charts contained in the main text of the document. The property value is an object of the type DataVisualization.ChartCollection. The collection can be used to get or to alter a chart's attributes and to add charts to or to remove charts from the main text of the document.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.ChartCollection Charts { get; }
[Visual Basic]
Public ReadOnly Property Charts() As DataVisualization.ChartCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.DocumentLinks Property

Gets a collection of all links in the main text of the document which point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.DocumentTargets Property

Gets a collection of all targets in the main text of the document. The property value is an object of the type DocumentTargetCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Drawings Property

Gets a collection of all drawings contained in the main text of the document. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from the main text.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Find Method

Finds a text string in the main text of the document.

Syntax

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Frames Property

Gets a collection of all images, textframes, charts, barcodes and drawings contained in the main text of the document. The property value is an object of the type FrameCollection. The collection can be used to get or to alter common attributes.

Introduced: 23.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.HypertextLinks Property

Gets a collection of all hypertext links contained in the main text of the document. The property's value is an object of the type HypertextLinkCollection.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Images Property

Gets a collection of all images contained in the main text of the document. The property value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Lines Property

Gets a collection of all text lines contained in the main text of the document. The property value is an object of the type LineCollection.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.MisspelledWords Property

Gets a collection of all misspelled words contained in the main text of the document. The property value is an object of the type MisspelledWordCollection.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Paragraphs Property

Gets a collection of all paragraphs contained in the main text of the document. The property value is an object of the type ParagraphCollection.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Selection Property

Gets or sets the current selection in the main text of the document. The property value is an object of the type Selection. A selection can be used to assign character and paragraph formatting attributes to a piece of text.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.SubTextParts Property

Gets a collection of all subtextparts contained in the main text of the document. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.Tables Property

Gets a collection of all tables contained in the main text of the document. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.TextChars Property

Gets a collection of all characters contained in the main text of the document. The property value is an object of the type TextCharCollection.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.TextFields Property

Gets a collection of all standard text fields contained in the main text of the document. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MainText.TextFrames Property

Gets a collection of all text frames contained in the main text of the document. The property's value is an object of the type TextFrameCollection. If a text frame contains further text frames, the inner frames are not contained in this collection.

Syntax

[C#]
public TextFrameCollection TextFrames { get; }
[Visual Basic]
Public ReadOnly Property TextFrames() As TextFrameCollection

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.MisspelledWord Class

The MisspelledWord class represents a misspelled word in a document's text.

Introduced: 16.0.

Syntax

[C#]
public class MisspelledWord
[Visual Basic]
Public Class MisspelledWord

Constructors

Constructor | Description
MisspelledWord | Initializes a new instance of the MisspelledWord class with the specified starting position and length.

Properties

Property | Description
Culture | Gets the culture of the misspelled word.
IsDuplicate | Gets or sets a value which marks the misspelled word as duplicate.
IsIgnored | Gets or sets a value which marks the misspelled word as ignored.
Length | Gets the length of a misspelled word.
Number | Gets the number of this misspelled word.
Start | Gets the starting position of a misspelled word.
Text | Gets the text of the misspelled word.

Methods

Method | Description
Select | Selects the misspelled word in the text.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord Constructor

Initializes a new instance of the MisspelledWord class with the specified starting position and length.

Syntax

[C#]
public MisspelledWord(int start, int length);
[Visual Basic]
Public Sub New(start As Integer, length As Integer)
Parameter | Description
start | Specifies the starting position of the misspelled word. It is a one-based index of the word's first character.
length | Specifies the length of the misspelled word.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Culture Property

Gets the culture of the misspelled word. If there is no specific culture, the property value is null.

Introduced: 20.0.

Syntax

[C#]
public System.Globalization.CultureInfo Culture { get; }
[Visual Basic]
Public ReadOnly Property Culture As System.Globalization.CultureInfo

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.IsDuplicate Property

Gets or sets a value which marks the misspelled word as duplicate. A duplicate word is not misspelled, but it has the same text as the word in front of it.

Introduced: 18.0.

Syntax

[C#]
public bool IsDuplicate { get; set; }
[Visual Basic]
Public Property IsDuplicate() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.IsIgnored Property

Gets or sets a value which marks the misspelled word as ignored. An ignored misspelled word remains in the collection of misspelled words, but it is not underlined in the text with a red zigzag line.

Introduced: 18.0.

Syntax

[C#]
public bool IsIgnored { get; set; }
[Visual Basic]
Public Property IsIgnored() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Length Property

Gets the length of a misspelled word.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length As Integer

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Number Property

Gets the number of this misspelled word. All misspelled words are counted from the beginning to the end of a document. The first word has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Start Property

Gets the starting position of a misspelled word. It is a one-based index of the word's first character.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start As Integer

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Select Method

Selects the misspelled word in the text.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWord.Text Property

Gets the text of the misspelled word.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection Class

An instance of the MisspelledWordCollection class contains all misspelled words in the main part of a Text Control document. An instance of this class can be obtained with the TextControl.MisspelledWords, WPF.TextControl.MisspelledWords, HeaderFooter.MisspelledWords or TextFrame.MisspelledWords property. The MisspelledWordCollection class implements the IEnumerable and the ICollection interfaces. Misspelled words are represented through objects of the type MisspelledWord.

Introduced: 16.0.

Syntax

[C#]
public class MisspelledWordCollection : ICollection, IEnumerable
[Visual Basic]
Public Class MisspelledWordCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetCount | Returns the number of misspelled words with a special meaning from the collection.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Gets a particular item from the collection.
Ignore | Changes the text of the specified misspelled word and marks it as ignored.
Item | Gets a misspelled word from the collection.
Remove | Overloaded. Removes the specified misspelled word from a Text Control document.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.GetCount Method

Returns the number of misspelled words with a special meaning from the collection.

Introduced: 18.0.

Syntax

[C#]
public int GetCount(MisspelledWordKind kind);
[Visual Basic]
Public Function GetEnumerator() As IEnumerator
Parameter | Description
kind | Specifies the word's kind. It must be one or more values of the MisspelledWordKind enumeration.

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.GetItem Method

Gets a particular item from the collection.

GetItem()

Gets the misspelled word at the current text input position. If there is no misspelled word, the next possible word is returned. If there is no misspelled word between the current input position and the end of the text, the first word is returned.

[C#]
public MisspelledWord GetItem();
[Visual Basic]
Public Function GetItem() As MisspelledWord

GetItem(MisspelledWordKind)

Gets the misspelled word of the specified kind at the current text input position. If there is no misspelled word, the next possible word of is returned. If there is no misspelled word of the specified kind between the current input position and the end of the text, the first word of the specified kind is returned.

[C#]
public MisspelledWord GetItem(MisspelledWordKind kind);
[Visual Basic]
Public Function GetItem(ByVal kind As MisspelledWordKind) As MisspelledWord
Parameter | Description
kind | Specifies the word's kind. It must be one or more values of the MisspelledWordKind enumeration.

GetItem(Point)

Gets the misspelled word at a certain geometrical location. If there is no misspelled word, null is returned.

[C#]
public MisspelledWord GetItem(System.Drawing.Point location);
[Visual Basic]
Public Function GetItem(ByVal location As System.Drawing.Point) As MisspelledWord
Parameter | Description
location | Specifies the word's location. The point must be specified in pixels with an origin at the top left corner of the control. If there is no misspelled word at the specified location, null is returned.

GetItem(Int32)

Gets the misspelled word at the specified text input position. If there is no misspelled word, the next possible word is returned. If there is no misspelled word between the specified input position and the end of the text, the first word is returned.

[C#]
public MisspelledWord GetItem(int textPosition);
[Visual Basic]
Public Function GetItem(ByVal textPosition As Integer) As MisspelledWord
Parameter | Description
textPosition | Specifies a zero-based text postion. The text positions in front of a word and behind a word belong to the word. If there is no misspelled word, the next possible word is returned. If there is no misspelled word between the specified text position and the end of the text, the first word is returned.

GetItem(Int32, MisspelledWordKind)

Gets the misspelled word of the specified kind at the specified text input position. If there is no misspelled word, the next possible word is returned. If there is no misspelled word of the specified kind between the specified input position and the end of the text, the first word of the specified kind is returned.

[C#]
public MisspelledWord GetItem(int textPosition, MisspelledWordKind kind);
[Visual Basic]
Public Function GetItem(ByVal textPosition As Integer, ByVal kind As MisspelledWordKind) As MisspelledWord
Parameter | Description
textPosition | Specifies a zero-based text postion. The text positions in front of a word and behind a word belong to the word. If there is no misspelled word, the next possible word is returned. If there is no misspelled word between the specified text position and the end of the text, the first word is returned.
kind | Specifies the word's kind. It must be one or more values of the MisspelledWordKind enumeration.

Return Value

The return value is null, if a misspelled word could not be found. Otherwise, it is an object of the type MisspelledWord.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.Ignore Method

Changes the text of the specified misspelled word and marks it as ignored. Ignored misspelled words are not underlined with a red zigzag line.

Introduced: 18.0.

Syntax

[C#]
public bool Ignore(MisspelledWord misspelledWord, string changedText);
[Visual Basic]
Public Function Ignore(ByVal misspelledWord As MisspelledWord, changedText As String) As Boolean
Parameter | Description
misspelledWord | Specifies the misspelled word to change.
changedText | Specifies the changed text. The current text of the word is replaced with this text.

Return Value

The return value is true, if the misspelled word could be changed. Otherwise, it is false.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.Item Property

Gets a misspelled word from the collection. In C# this property is the indexer for the MisspelledWordCollection class.

Syntax

[C#]
public MisspelledWord this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As MisspelledWord
Parameter | Description
number | Specifies a number. Misspelled words are counted from the beginning to the end of the text beginning with number 1.

Return Value

The return value is null, if there is no misspelled word with the specified number. Otherwise, it is an object of the type MisspelledWord.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.MisspelledWordCollection.Remove Method

Removes the specified misspelled word from a Text Control document. The method removes the word's reference in the list of misspelled words, but not the word's text in the document. If text is specified, this text replaces the word's text.

Remove(MisspelledWord)

Removes the specified misspelled word from a Text Control document. The method removes the word's reference in the list of misspelled words, but not the word's text in the document.

[C#]
public bool Remove(MisspelledWord misspelledWord);
[Visual Basic]
Public Function Remove(ByVal misspelledWord As MisspelledWord) As Boolean
Parameter | Description
misspelledWord | Specifies the misspelled word to remove.

Remove(MisspelledWord, String)

Removes the specified misspelled word from a Text Control document. The method removes the word's reference in the list of misspelled words and replaces the word's text with the specified text.

[C#]
public bool Remove(MisspelledWord misspelledWord, string correctedText);
[Visual Basic]
Public Function Remove(ByVal misspelledWord As MisspelledWord, correctedText As String) As Boolean
Parameter | Description
misspelledWord | Specifies the misspelled word to remove.
correctedText | Specifies the corrected text. The current text of the word is replaced with this text.

Return Value

The return value is true, if the misspelled word could be removed. Otherwise, it is false.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.Page Class

An object of the Page class represents a formatted page of a document. Pages are numbered from the beginning to the end of the document beginning with 1. A document has at least one page. Each section of a document can have one or more pages depending on the text that is contained in the section. A section does not have to begin at the top of a page. Therefore more than one section can be on one page. A page object can be obtained from the page collection available through the TextControl.GetPages method. This collection is only available, if the TextControl.ViewMode property has been set to PageView.

Introduced: 14.0.

Syntax

[C#]
public class Page
[Visual Basic]
Public Class Page

Properties

Property | Description
Bounds | Gets the bounding rectangle of the page, in twips, relative to the top of the document.
Footer | Gets the footer of the page.
Header | Gets the header of the page.
Length | Gets the number of characters of the page, including the page break character at the end of the page.
Number | Gets the page's number.
NumberInSection | Gets the page number relative to the beginning of the section the page belongs to.
Section | Gets the number, one-based, of the section the page belongs to.
Start | Gets the number (one-based) of the page's first character.
TextBounds | Gets the bounding rectangle of the page's text, in twips, relative to the top of the document.

Methods

Method | Description
GetImage | Overloaded. Gets an image of the page's contents.
Select | Selects the text of the page.

Example

The following example shows how to scroll to a specific page.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.PageView;

for (int i = 0; i < 100; i++)
    textControl1.Selection.Text = new string('a', 200);

textControl1.ScrollLocation = new Point(textControl1.ScrollLocation.X,
                              textControl1.GetPages()[2].Bounds.Top);
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.PageView

For i = 1 To 100
    TextControl1.Selection.Text = New String("a", 200)
    i = i + 1
Next

TextControl1.ScrollLocation = New Point(TextControl1.ScrollLocation.X, _
                              TextControl1.GetPages()(2).Bounds.Top)

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Bounds Property

Gets the bounding rectangle of the page, in twips, relative to the top of the document.

Syntax

[C#]
public Rectangle Bounds { get; }
[Visual Basic]
Public ReadOnly Property Bounds() As Rectangle

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Footer Property

Gets the footer of the page. If there is no footer, null is returned.

Introduced: 22.0.

Syntax

[C#]
public HeaderFooter Footer { get; }
[Visual Basic]
Public ReadOnly Property Footer() As HeaderFooter

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.GetImage Method

Gets an image of the page's contents.

Introduced: 15.0.

GetImage(PageContent)

Gets an image of the page's contents as an enhanced metafile.

[C#]
public System.Drawing.Imaging.Metafile GetImage(PageContent contents)
[Visual Basic]
Public Function GetImage(ByVal Contents As PageContent) As System.Drawing.Imaging.Metafile
Parameter | Description
contents | Specifies the image's contents. It can be one or more of the values of the PageContent enumeration.

GetImage(Int32, PageContent)

Gets an image of the page's contents as a bitmap in screen resolution.

[C#]
public System.Drawing.Imaging.Bitmap GetImage(int zoomFactor, PageContent contents)
[Visual Basic]
Public Function GetImage(ByVal ZoomFactor As Integer, ByVal Contents As PageContent) As System.Drawing.Imaging.Bitmap
Parameter | Description
zoomFactor | Specifies a zooming factor in percent. It can be a value between 10 and 400 percent.
contents | Specifies the image's contents. It can be one or more of the values of the PageContent enumeration.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Header Property

Gets the header of the page. If there is no header, null is returned.

Introduced: 22.0.

Syntax

[C#]
public HeaderFooter Header { get; }
[Visual Basic]
Public ReadOnly Property Header() As HeaderFooter

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Length Property

Gets the number of characters of the page, including the page break character at the end of the page.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Number Property

Gets the page's number. The first page has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.NumberInSection Property

Gets the page number relative to the beginning of the section the page belongs to. The first page of the section has the number 1.

Syntax

[C#]
public int NumberInSection { get; }
[Visual Basic]
Public ReadOnly Property NumberInSection() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Section Property

Gets the number, one-based, of the section the page belongs to. If there are more than one section on the page, the number of the first section is returned. The first section determines the page's size and orientation.

Syntax

[C#]
public int Section { get; }
[Visual Basic]
Public ReadOnly Property Section() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Select Method

Selects the text of the page. The page break characters bounding the page and the header and/or footer belonging to the page are not selected.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.Start Property

Gets the number (one-based) of the page's first character.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Page.TextBounds Property

Gets the bounding rectangle of the page's text, in twips, relative to the top of the document.

Syntax

[C#]
public Rectangle TextBounds { get; }
[Visual Basic]
Public ReadOnly Property TextBounds() As Rectangle

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder class

An instance of the PageBorder class represents the attributes of a border, which is drawn in the margin area of a page. A page border can have a top, left, right or bottom line or a combination of these lines. The line width and the color can be defined for each line separately. For each line a distance can be specified, which is either a distance to the edge of the page or to the text. The page border can surround the text including page headers and footers or only the text of the page. The border can be defined for the first page, for all pages or beginning with the second page.

Introduced: 17.0.

Syntax

[C#]
public class PageBorder
[Visual Basic]
Public Class PageBorder

Constructors

Constructor | Description
PageBorder | Overloaded. Creates a new instance of the PageBorder class.

Properties

Property | Description
BottomDistance | Gets or sets the distance, in twips, of the bottom border line either from the edge of the page or from the text, depending on the MeasureFromText property.
BottomLineColor | Gets or sets the color of the bottom border line.
BottomLineWidth | Gets or sets the width of the bottom border line.
FirstPageOnly | Gets or sets a value indicating whether the page border is drawn only on the first page of the section.
LeftDistance | Gets or sets the distance, in twips, of the left border line either from the edge of the page or from the text, depending on the MeasureFromText property.
LeftLineColor | Gets or sets the color of the left border line.
LeftLineWidth | Gets or sets the width of the left border line.
MeasureFromText | Gets or sets a value indicating whether the page border's distances are measured from the text.
OmitFirstPage | Gets or sets a value indicating whether the page border is not drawn on the first page of the section.
RightDistance | Gets or sets the distance, in twips, of the right border line either from the edge of the page or from the text, depending on the MeasureFromText property.
RightLineColor | Gets or sets the color of the right border line.
RightLineWidth | Gets or sets the width of the right border line.
SurroundFooter | Gets or sets a value indicating whether the page border surrounds the section's footer.
SurroundHeader | Gets or sets a value indicating whether the page border surrounds the section's header.
TopDistance | Gets or sets the distance, in twips, of the top border line either from the edge of the page or from the text, depending on the MeasureFromText property.
TopLineColor | Gets or sets the color of the top border line.
TopLineWidth | Gets or sets the width of the top border line.

Enumerations

Enumeration | Description
Attribute | Determines a certain page border attribute.

Fields

Field | Description
DefaultDistance | Represents the default distance of a page border from the edge of the page.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder Constructor

Creates a new instance of the PageBorder class.

PageBorder()

Creates an empty PageBorder object. Further properties must be set.

[C#]
public PageBorder();
[Visual Basic]
Public Sub New()

PageBorder(Int32, Int32, Color)

Creates a PageBorder object with equal line widths, colors and distances from the edge of the page.

[C#]
public PageBorder(int lineWidth, int distance, System.Drawing.Color lineColor);
[Visual Basic]
Public Sub New(ByVal lineWidth As Integer, ByVal distance As Integer, ByVal lineColor As System.Drawing.Color)
Parameter | Description
lineWidth | Specifies the width for all border lines.
distance | Specifies the distance of the border lines from the edge of the page.
lineColor | Specifies the color for all border lines.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.Attribute Enumeration

Determines a certain page border attribute. This enumeration is used with the Selection.IsCommonValueSelected method. It contains the following values:

Member | Description
BottomDistance | Specifies the attribute set through the BottomDistance property.
BottomLineColor | Specifies the attribute set through the BottomLineColor property.
BottomLineWidth | Specifies the attribute set through the BottomLineWidth property.
FirstPageOnly | Specifies the attribute set through the FirstPageOnly property.
LeftDistance | Specifies the attribute set through the LeftDistance property.
LeftLineColor | Specifies the attribute set through the LeftLineColor property.
LeftLineWidth | Specifies the attribute set through the LeftLineWidth property.
MeasureFromText | Specifies the attribute set through the MeasureFromText property.
OmitFirstPage | Specifies the attribute set through the OmitFirstPage property.
RightDistance | Specifies the attribute set through the RightDistance property.
RightLineColor | Specifies the attribute set through the RightLineColor property.
RightLineWidth | Specifies the attribute set through the RightLineWidth property.
SurroundFooter | Specifies the attribute set through the SurroundFooter property.
SurroundHeader | Specifies the attribute set through the SurroundHeader property.
TopDistance | Specifies the attribute set through the TopDistance property.
TopLineColor | Specifies the attribute set through the TopLineColor property.
TopLineWidth | Specifies the attribute set through the TopLineWidth property.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.BottomDistance Property

Gets or sets the distance, in twips, of the bottom border line either from the edge of the page or from the text, depending on the MeasureFromText property.

Syntax

[C#]
public int BottomDistance { get; set; }
[Visual Basic]
Public Property BottomDistance() As Integer

Remarks

The property's default value is PageBorder.DefaultDistance.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.BottomLineColor Property

Gets or sets the color of the bottom border line.

Syntax

[C#]
public Color BottomLineColor { get; set; }
[Visual Basic]
Public Property BottomLineColor() As Color

Remarks

The property's default value is the system color for text.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.BottomLineWidth Property

Gets or sets the width of the bottom border line. If this property's value is zero there is no bottom border line. Otherwise it is a value in twips.

Syntax

[C#]
public int BottomLineWidth { get; set; }
[Visual Basic]
Public Property BottomLineWidth() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.DefaultDistance Field

Represents the default distance of a page border from the edge of the page. The value of this constant is 454 twips = 8 mm.

Syntax

[C#]
public const int DefaultDistance;
[Visual Basic]
Public DefaultDistance As Integer

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.FirstPageOnly Property

Gets or sets a value indicating whether the page border is drawn only on the first page of the section. If this property is set to true, the page border is drawn only on the first page, otherwise it is drawn on all pages of the section.

Syntax

[C#]
public bool FirstPageOnly { get; set; }
[Visual Basic]
Public Property FirstPageOnly() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.LeftDistance Property

Gets or sets the distance, in twips, of the left border line either from the edge of the page or from the text, depending on the MeasureFromText property.

Syntax

[C#]
public int LeftDistance { get; set; }
[Visual Basic]
Public Property LeftDistance() As Integer

Remarks

The property's default value is PageBorder.DefaultDistance.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.LeftLineColor Property

Gets or sets the color of the left border line.

Syntax

[C#]
public Color LeftLineColor { get; set; }
[Visual Basic]
Public Property LeftLineColor() As Color

Remarks

The property's default value is the system color for text.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.LeftLineWidth Property

Gets or sets the width of the left border line. If this property's value is zero, there is no left border line. Otherwise it is a value in twips.

Syntax

[C#]
public int LeftLineWidth { get; set; }
[Visual Basic]
Public Property LeftLineWidth() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.MeasureFromText Property

Gets or sets a value indicating whether the page border's distances are measured from the text. If this property is set to true, the page border's distances are measured from the text, otherwise they are measured from the edge of the page.

Syntax

[C#]
public bool MeasureFromText { get; set; }
[Visual Basic]
Public Property MeasureFromText() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.OmitFirstPage Property

Gets or sets a value indicating whether the page border is not drawn on the first page of the section. If this property is set to true, the page border is not drawn on the first page but on all other pages, otherwise it is drawn on all pages of the section.

Syntax

[C#]
public bool OmitFirstPage { get; set; }
[Visual Basic]
Public Property OmitFirstPage() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.RightDistance Property

Gets or sets the distance, in twips, of the right border line either from the edge of the page or from the text, depending on the MeasureFromText property.

Syntax

[C#]
public int RightDistance { get; set; }
[Visual Basic]
Public Property RightDistance() As Integer

Remarks

The property's default value is PageBorder.DefaultDistance.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.RightLineColor Property

Gets or sets the color of the right border line.

Syntax

[C#]
public Color RightLineColor { get; set; }
[Visual Basic]
Public Property RightLineColor() As Color

Remarks

The property's default value is the system color for text.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.RightLineWidth Property

Gets or sets the width of the right border line. If this property's value is zero there is no right border line. Otherwise it is a value in twips.

Syntax

[C#]
public int RightLineWidth { get; set; }
[Visual Basic]
Public Property RightLineWidth() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.SurroundFooter Property

Gets or sets a value indicating whether the page border surrounds the section's footer. If this property is set to true, the page border surrounds the footer, otherwise it surrounds only the text. This property only has a meaning, if the MeasureFromText property has been set to true.

Syntax

[C#]
public bool SurroundFooter { get; set; }
[Visual Basic]
Public Property SurroundFooter() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.SurroundHeader Property

Gets or sets a value indicating whether the page border surrounds the section's header. If this property is set to true, the page border surrounds the header, otherwise it surrounds only the text. This property only has a meaning, if the MeasureFromText property has been set to true.

Syntax

[C#]
public bool SurroundHeader { get; set; }
[Visual Basic]
Public Property SurroundHeader() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.TopDistance Property

Gets or sets the distance, in twips, of the top border line either from the edge of the page or from the text, depending on the MeasureFromText property.

Syntax

[C#]
public int TopDistance { get; set; }
[Visual Basic]
Public Property TopDistance() As Integer

Remarks

The property's default value is PageBorder.DefaultDistance.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.TopLineColor Property

Gets or sets the color of the top border line.

Syntax

[C#]
public Color TopLineColor { get; set; }
[Visual Basic]
Public Property TopLineColor() As Color

Remarks

The property's default value is the system color for text.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageBorder.TopLineWidth Property

Gets or sets the width of the top border line. If this property's value is zero there is no top border line. Otherwise it is a value in twips.

Syntax

[C#]
public int TopLineWidth { get; set; }
[Visual Basic]
Public Property TopLineWidth() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection Class

An instance of the PageCollection class contains all pages of a document. A document has at least one page. An instance of this class can be obtained with the TextControl.GetPages method. The PageCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 14.0.

Syntax

[C#]
public sealed class PageCollection: ICollection, IEnumerable
[Visual Basic]
Public NotInheritable Class PageCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Gets the Page with the current text input position from the collection.
Item | Gets a page from the collection.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection.GetItem Method

Gets the Page with the current text input position from the collection.

Syntax

[C#]
public Page GetItem();
[Visual Basic]
Public Function GetItem() As Page

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageCollection.Item Property

Gets a page from the collection. In C# this property is the indexer for the PageCollection class.

Syntax

[C#]
public Page this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As Page
Parameter | Description
number | Specifies a page number. The first page has the number 1.

Return Value

The return value is null, if the page could not be found. Otherwise, it is an object of the type Page.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins Class

An instance of the PageMargins class represents the page margins of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public class PageMargins
[Visual Basic]
Public Class PageMargins

Constructors

Constructor | Description
PageMargins | Overloaded. Creates a new instance of the PageMargins class.

Properties

Property | Description
Bottom | Specifies the bottom margin of a TX Text Control document or document section.
Left | Specifies the left margin of a TX Text Control document or document section.
Right | Specifies the right margin of a TX Text Control document or document section.
Top | Specifies the top margin of a TX Text Control document or document section.

Enumerations

Enumeration | Description
Attribute | Determines a certain attribute.

Example

The following example shows how to set the page margins for the current section.

[C#]
TXTextControl.Section section = textControl1.Sections.GetItem();
TXTextControl.PageMargins margins =
    new TXTextControl.PageMargins(200, 100, 200, 100);

section.Format.PageMargins = margins;
[Visual Basic]
Dim section As TXTextControl.Section = TextControl1.Sections.GetItem()
Dim margins As TXTextControl.PageMargins = _
    New TXTextControl.PageMargins(200, 100, 200, 100)

section.Format.PageMargins = margins

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins Constructor

Creates a new instance of the PageMargins class.

PageMargins()

Creates a new instance of the PageMargins class with a left, top, right and bottom margin of 1 inch.

[C#]
public PageMargins();
[Visual Basic]
Public Sub New()

PageMargins(Double, Double, Double, Double)

Creates a new instance of the PageMargins class with the specified margins.

[C#]
public PageMargins(double left, double top, double right, double bottom);
[Visual Basic]
Public Sub New(ByVal left As Double, ByVal top As Double, ByVal right As Double, ByVal bottom As Double)
Parameter | Description
left | Specifies the left page margin.
top | Specifies the top page margin.
right | Specifies the right page margin.
bottom | Specifies the bottom page margin.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins.Attribute Enumeration

Determines a certain attribute. This enumeration is used with the Selection.IsCommonValueSelected method.

Member | Description
Bottom | Specifies the attribute set through the Bottom property.
Left | Specifies the attribute set through the Left property.
Right | Specifies the attribute set through the Right property.
Top | Specifies the attribute set through the Top property.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins.Left Property

Specifies the left margin of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Left { get; set; }
[Visual Basic]
Public Property Left() As Double

Remarks

The margin's default value is 1 inch.

The property returns its default value when the text selection contains multiple sections with mixed margins. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins.Top Property

Specifies the top margin of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Top { get; set; }
[Visual Basic]
Public Property Top() As Double

Remarks

The margin's default value is 1 inch.

The property returns its default value when the text selection contains multiple sections with mixed margins. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins.Right Property

Specifies the right margin of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Right { get; set; }
[Visual Basic]
Public Property Right() As Double

Remarks

The margin's default value is 1 inch.

The property returns its default value when the text selection contains multiple sections with mixed margins. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageMargins.Bottom Property

Specifies the bottom margin of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Bottom { get; set; }
[Visual Basic]
Public Property Bottom() As Double

Remarks

The margin's default value is 1 inch.

The property returns its default value when the text selection contains multiple sections with mixed margins. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageNumberField Class

The PageNumberField class represents a field in a header or footer of a Text Control document that automatically displays the current page number. The class inherits all properties and methods from the TextField class. Additionally it implements the properties in the following list. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public class PageNumberField : TextField
[Visual Basic]
Public Class PageNumberField
  Inherits TextField

Constructors

Constructor | Description
PageNumberField | Overloaded. Creates a new instance of the PageNumberField class.

Properties

Property | Description
NumberFormat | Gets or sets the number format.
ShowNumberOfPages | Gets or sets a value indicating whether the field shows the page number or the total number of pages.
StartNumber | Gets or sets the page number for the first page.

Methods

Method | Description
PageNumberDialog | Opens a dialog box to alter the formatting and numbering attributes of the page number field.

Example

The following example shows how to add a page number field to a header.

[C#]
textControl1.ViewMode = TXTextControl.ViewMode.PageView;

textControl1.Sections.GetItem().HeadersAndFooters.Add(
    TXTextControl.HeaderFooterType.Header);
TXTextControl.HeaderFooter header =
    textControl1.Sections.GetItem().HeadersAndFooters.GetItem(
    TXTextControl.HeaderFooterType.Header);

header.Selection.Text = "Page ";
header.PageNumberFields.Add(new TXTextControl.PageNumberField(
    1, TXTextControl.NumberFormat.ArabicNumbers));
[Visual Basic]
TextControl1.ViewMode = TXTextControl.ViewMode.PageView

TextControl1.Sections.GetItem().HeadersAndFooters.Add( _
    TXTextControl.HeaderFooterType.Header)
Dim header As TXTextControl.HeaderFooter = _
    TextControl1.Sections.GetItem().HeadersAndFooters.GetItem( _
    TXTextControl.HeaderFooterType.Header)

header.Selection.Text = "Page "
header.PageNumberFields.Add(New TXTextControl.PageNumberField( _
    1, TXTextControl.NumberFormat.ArabicNumbers))

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberField Constructor

Creates a new instance of the PageNumberField class.

PageNumberField()

Creates a new PageNumberField which displays Arabic numbers starting with 1.

[C#]
public PageNumberField();
[Visual Basic]
Public Sub New()

PageNumberField(Int32, NumberFormat)

Creates a new PageNumberField which displays page numbers with the specified number format starting with the specified start number.

[C#]
public PageNumberField(int startNumber, NumberFormat numberFormat);
[Visual Basic]
Public Sub New(ByVal startNumber As Integer, ByVal numberFormat As NumberFormat)
Parameter Description
startNumber

Specifies the page number for the first page.
numberFormat

Specifies the number format. It can be one of the following values:

Value | Meaning
ArabicNumbers | The page numbers are displayed with Arabic numbers (1, 2, 3...).
Letters | The page numbers are displayed with letters (a, b, c...).
CapitalLetters | The page numbers are displayed with capital letters (A, B, C...).
RomanNumbers | The page numbers are displayed with Roman numbers (I, II, III...).
SmallRomanNumbers | The page numbers are displayed with small Roman numbers (i, ii, iii...).

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberField.NumberFormat Property

Gets or sets the number format. The property's value is a member of the NumberFormat enumeration.

Syntax

[C#]
public NumberFormat NumberFormat { get; set; }
[Visual Basic]
Public Property NumberFormat() As NumberFormat
Value | Description
ArabicNumbers | The page numbers are displayed with Arabic numbers (1, 2, 3...).
Letters | The page numbers are displayed with letters (a, b, c...).
CapitalLetters | The page numbers are displayed with capital letters (A, B, C...).
RomanNumbers | The page numbers are displayed with Roman numbers (I, II, III...).
SmallRomanNumbers | The page numbers are displayed with small Roman numbers (i, ii, iii...).

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberField.PageNumberDialog Method

Opens a dialog box to alter the formatting and numbering attributes of the page number field.

Introduced: 19.0.

Syntax

[C#]
public Selection.DialogResult PageNumberDialog();
[Visual Basic]
Public Function PageNumberDialog() As Selection.DialogResult

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberField.ShowNumberOfPages Property

Gets or sets a value indicating whether the field shows the page number or the total number of pages.

Introduced: 19.0.

Syntax

[C#]
public bool ShowNumberOfPages { get; set; }
[Visual Basic]
Public Property ShowNumberOfPages() As Boolean

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberField.StartNumber Property

Gets or sets the page number for the first page.

Syntax

[C#]
public int StartNumber { get; set; }
[Visual Basic]
Public Property StartNumber() As Integer

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection Class

An instance of the PageNumberFieldCollection class contains the page number fields in a header or footer of a Text Control document. Page number fields are represented through objects of the type PageNumberField. An instance of this class can be obtained with the HeaderFooter.PageNumberFields property. The PageNumberFieldCollection class implements the IEnumerable and the ICollection interfaces. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public sealed class PageNumberFieldCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class PageNumberFieldCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts a new page number field at the current input position of a header or footer.
Clear | Removes all page number fields contained in the collection from the document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular page number field from the collection.
Remove | Removes a page number from a header or footer of a Text control document.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection.Add Method

Inserts a new page number field at the current input position of a header or footer.

Syntax

[C#]
public bool Add(PageNumberField pageNumberField);
[Visual Basic]
Public Function Add(ByVal pageNumberField As PageNumberField) As Boolean
Parameter | Description
pageNumberField | Specifies the page number field to add.

Return Value

The return value is true, if the page number field could be added. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection.Clear Method

Removes all page number fields contained in the collection from the document.

Introduced: 13.0.

Syntax

[C#]
public void Clear(bool keepText);
[Visual Basic]
Public Sub Clear(ByVal keepText As Boolean)
Parameter | Description
keepText | If this parameter is set to true, all page number fields are removed without deleting their texts. Otherwise, the texts are also deleted.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection.GetItem Method

Gets a particular page number field from the collection.

Introduced: 24.0.

GetItem()

Gets the page number field at the current input position or null if there is no page number field at the current input position.

[C#]
public PageNumberField GetItem();
[Visual Basic]
Public Function GetItem() As PageNumberField

GetItem(Int32)

Gets the page number field with the specified id. An id can be set with the PageNumberField.ID property.

[C#]
public PageNumberField GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As PageNumberField
Parameter | Description
id | Specifies the page number field's identifier. The method returns null, if a page number field with the specified identifier does not exist.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageNumberFieldCollection.Remove Method

Removes a page number from a header or footer of a Text control document.

Syntax

[C#]
public bool Remove(PageNumberField pageNumberField);
[Visual Basic]
Public Function Remove(ByVal pageNumberField As PageNumberField) As Boolean
Parameter | Description
pageNumberField | Specifies the page number field to remove.

Return Value

The return value is true, if the page number field could be removed. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.PageSize Class

An instance of the PageSize class represents the page size of a TX Text Control document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Introduced: 16.0.

Syntax

[C#]
public class PageSize
[Visual Basic]
Public Class PageSize

Constructors

Constructor | Description
PageSize | Overloaded. Creates a new instance of the PageSize class.

Properties

Property | Description
Height | Specifies the page height of a document or document section.
Width | Specifies the page width of a document or document section.

Enumerations

Enumeration | Description
Attribute | Determines a certain attribute.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageSize Constructor

Creates a new instance of the PageSize class. The measure for the width and height parameters depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

PageSize()

Creates a new PageSize object representing an US Letter page size (8.5 x 11 inch).

[C#]
public PageSize();
[Visual Basic]
Public Sub New()

PageSize(Double, Double)

Creates a new PageSize object representing a page size with the specified width and height. The measure for the width and height parameters depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

[C#]
public PageSize(double width, double height);
[Visual Basic]
Public Sub New(ByVal width As Double, ByVal height As Double)
Parameter | Description
width | Specifies the width of the page.
height | Specifies the height of the page.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageSize.Attribute Enumeration

Determines a certain attribute. This enumeration is used with the Selection.IsCommonValueSelected method.

Member | Description
Height | Specifies the attribute set through the Height property.
Width | Specifies the attribute set through the Width property.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageSize.Height Property

Specifies the page height of a document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Height { get; set; }
[Visual Basic]
Public Property Height() As Double

Remarks

The height's default value is 11 inch.

The property returns its default value when the text selection contains multiple sections with mixed page heights. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

The maximum value depends on the capabilities of the selected printer and must not exceed 22.75 inch.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PageSize.Width Property

Specifies the page width of a document or document section. The measure depends on the TextControl.PageUnit, WPF.TextControl.PageUnit or ServerTextControl.PageUnit property.

Syntax

[C#]
public double Width { get; set; }
[Visual Basic]
Public Property Width() As Double

Remarks

The width's default value is 8.5 inch.

The property returns its default value when the text selection contains multiple sections with mixed page widths. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

The maximum value depends on the capabilities of the selected printer and must not exceed 22.75 inch.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PaperSize Class

The PaperSize class is used with the TextControl.GetSupportedPaperSizes and WPF.TextControl.GetSupportedPaperSizes methods, which return the names and the sizes of all currently supported paper sizes. These paper sizes depend on the formatting device set with the TextControl.FormattingPrinter or WPF.TextControl.FormattingPrinter property.

Introduced: 24.0.

Syntax

[C#]
public class PaperSize
[Visual Basic]
Public Class PaperSize

Properties

Property | Description
Height | Gets the height of the paper size, in twips.
Name | Gets the name of the paper size.
Width | Gets the width of the paper size, in twips.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PaperSize.Height Property

Gets the height of the paper size, in twips. The value of this property is the height (y-dimension) of the paper size as if the paper were in the portrait orientation.

Syntax

[C#]
public int Height { get; }
[Visual Basic]
Public ReadOnly Property Height() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PaperSize.Name Property

Gets the name of the paper size.

Syntax

[C#]
public string Name { get; }
[Visual Basic]
Public ReadOnly Property Name() As String

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.PaperSize.Width Property

Gets the width of the paper size, in twips. The value of this property is the width (x-dimension) of the paper size as if the paper were in the portrait orientation.

Syntax

[C#]
public int Width { get; }
[Visual Basic]
Public ReadOnly Property Width() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Paragraph Class

An instance of the Paragraph class represents a single paragraph in a Text Control document. Paragraphs are numbered from the beginning to the end of the document beginning with 1. A document has at least one paragraph. A Paragraph object can be obtained from the paragraphs collection available through the TextControl.Paragraphs property.

Introduced: 15.0.

Syntax

[C#]
public class Paragraph
[Visual Basic]
Public Class Paragraph

Properties

Property | Description
Format | Gets or sets the paragraph's formatting attributes.
FormattingStyle | Gets or sets the paragraph's formatting style.
Length | Gets the number of characters in the paragraph including the paragraph end character.
Lines | Gets the number of lines the paragraph consists of.
ListFormat | Gets or sets the paragraph's bulleted or numbered list and/or its formatting attributes.
ListNumber | Gets the paragraph's list number.
ListNumberText | Gets the paragraph's list number text.
Number | Gets the paragraph's number.
Start | Gets the number (one-based) of the paragraph's first character.
StartLine | Gets the number (one-based) of the paragraph's first line.
Text | Gets the paragraph's text.

Methods

Method | Description
Save | Overloaded. Saves the paragraph's text with the specified format.
Select | Selects the paragraph.

Example

The following example shows how to use the Paragraph class to add paragraph numbers and apply a format to each paragraph, that holds text, e.g. is longer than 3 characters.

[C#]
TXTextControl.ParagraphFormat numberedParagraphFormat = new TXTextControl.ParagraphFormat();
numberedParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Left;
numberedParagraphFormat.LeftIndent = 200;
numberedParagraphFormat.RightIndent = 500;
numberedParagraphFormat.HangingIndent = 100;
foreach (TXTextControl.Paragraph p in textControl1.Paragraphs)
{
  textControl1.InputPosition = new TXTextControl.InputPosition(p.Start - 1);
    if (p.Length >= 3)
    {
      textControl1.Selection.Text = p.Number.ToString() + ". ";
      p.Format = numberedParagraphFormat;
    }
}
[Visual Basic]
Dim numberedParagraphFormat As New TXTextControl.ParagraphFormat(TXTextControl.HorizontalAlignment.Left)
numberedParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Left
numberedParagraphFormat.KeepLinesTogether = True
numberedParagraphFormat.LeftIndent = 200
numberedParagraphFormat.RightIndent = 500
numberedParagraphFormat.HangingIndent = 100
For Each p As TXTextControl.Paragraph In TextControl1.Paragraphs
  TextControl1.InputPosition = New TXTextControl.InputPosition(p.Start - 1)
  If p.Length >= 3 Then
    TextControl1.Selection.Text = p.Number.ToString() + ". "
    p.Format = numberedParagraphFormat
  End If
Next

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.FormattingStyle Property

Gets or sets the paragraph's formatting style. The specified style must be the name of a style contained in the ParagraphStyles collection of a Text Control document.

Syntax

[C#]
public string FormattingStyle { get; set; }
[Visual Basic]
Public Property FormattingStyle() As String

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Format Property

Gets or sets the paragraph's formatting attributes. The property's value is an object of the type ParagraphFormat.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Length Property

Gets the number of characters in the paragraph including the paragraph end character.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.ListFormat Property

Gets or sets the paragraph's bulleted or numbered list and/or its formatting attributes. The property's value is an object of the type ListFormat.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Lines Property

Gets the number of lines the paragraph consists of.

Syntax

[C#]
public int Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.ListNumber Property

Gets the paragraph's list number. It is zero, if the paragraph does not belong to a numbered list.

Syntax

[C#]
public int ListNumber { get; }
[Visual Basic]
Public ReadOnly Property ListNumber() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.ListNumberText Property

Gets the paragraph's list number text. The text consists of the text in front of the number, the number itself and the text behind the list number. It is an empty string, if the paragraph does not belong to a numbered list.

Syntax

[C#]
public String ListNumber´Text { get; }
[Visual Basic]
Public ReadOnly Property ListNumberText() As String

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Number Property

Gets the paragraph's number. The first paragraph has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Save Method

Saves the paragraph's text with the specified format.

Save(Byte[], BinaryStreamType)

Saves the paragraph's text in a byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the paragraph's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the paragraph's text as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the paragraph's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the paragraph's text in a byte array with the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the paragraph's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the paragraph's text as a string with the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the paragraph's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Select Method

Selects the paragraph. The paragraph break characters bounding the paragraph are not selected.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Start Property

Gets the number (one-based) of the paragraph's first character.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.StartLine Property

Gets the number (one-based) of the paragraph's first line.

Syntax

[C#]
public int StartLine { get; }
[Visual Basic]
Public ReadOnly Property StartLine() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.Paragraph.Text Property

Gets the paragraph's text.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection Class

An instance of the ParagraphCollection class contains all paragraphs in a Text Control document or part of the document represented through objects of the type Paragraph. An instance of this class can be obtained with the TextControl.Paragraphs, HeaderFooter.Paragraphs or TextFrame.Paragraphs property. The ParagraphCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 15.0.

Syntax

[C#]
public class ParagraphCollection : ICollection, IEnumerable
[Visual Basic]
Public Class ParagraphCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Gets a particular paragraph from the collection.
Item | Gets a paragraph from the collection.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection.GetItem Method

Gets a particular paragraph from the collection.

GetItem(Point)

Gets the paragraph at a certain geometrical position.

[C#]
public Paragraph GetItem(System.Drawing.Point location);
[Visual Basic]
Public Function GetItem(ByVal location As System.Drawing.Point) As Paragraph
Parameter | Description
location | Specifies the paragraph's location. The point must be specified in pixels with an origin at the top left corner of the control.

GetItem(Int32)

Gets the paragraph at a certain text position.

[C#]
public Paragraph GetItem(int textPosition);
[Visual Basic]
Public Function GetItem(ByVal textPosition As Integer) As Paragraph
Parameter | Description
textPosition | Specifies a zero-based text position.

Return Value

The return value is null, if a paragraph could not be found. Otherwise, it is an object of the type Paragraph.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphCollection.Item Property

Gets a paragraph from the collection. In C# this property is the indexer for the ParagraphCollection class.

Syntax

[C#]
public Paragraph this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As Paragraph
Parameter | Description
number | Specifies a paragraph number. The first paragraph has the number 1.

Return Value

The return value is null, if the paragraph could not be found. Otherwise, it is an object of the type Paragraph.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ParagraphFormat class

An instance of the ParagraphFormat class represents the formatting attributes of a paragraph.

Syntax

[C#]
public class ParagraphFormat
[Visual Basic]
Public Class ParagraphFormat

Constructors

Constructor | Description
ParagraphFormat | Overloaded. Creates a new instance of the ParagraphFormat class.

Properties

Property | Description
AbsoluteLineSpacing | Gets or sets the line spacing of a paragraph in twips.
Alignment | Gets or sets the horizontal text alignment.
BackColor | Gets or sets the background color of a paragraph.
BottomDistance | Gets or sets the bottom distance, in twips, between this and the next paragraph.
Direction | Gets or sets the writing direction.
Frame | Gets or sets a frame around the paragraph.
FrameDistance | Gets or sets the distance, in twips, between the text and the paragraph's frame.
FrameLineColor | Gets or sets the color used for the frame lines of a paragraph.
FrameLineWidth | Gets or sets the line width, in twips, of the paragraph's frame.
FrameStyle | Gets or sets the style of the paragraph's frame.
HangingIndent | Gets or sets the distance, in twips, for the hanging indent.
Justification | Gets or sets the kind of justification in documents containing Arabic or Hebrew characters.
KeepLinesTogether | Gets or sets a value indicating whether a page break is allowed within the paragraph.
KeepWithNext | If this property is set to true, the paragraph is displayed on the same page as its following paragraph.
LeftIndent | Gets or sets the distance, in twips, between the left edge of the Text Control and the left edge of the text.
LineSpacing | Specifies the line spacing of a paragraph as a percentage of the font size.
PageBreakBefore | If this property is set to true, the paragraph is always displayed on top of a page.
RightIndent | Gets or sets the distance, in twips, between the right edge of a Text Control document and the right edge of the text.
TabPositions | Gets or sets an array containing the absolute tab stop positions, in twips, in a paragraph.
TabTypes | Gets or sets an array containing the tab types in a paragraph.
TopDistance | Gets or sets a top distance, in twips, between this and the previous paragraph.
WidowOrphanLines | Gets or sets the number of lines for widow/orphan control.

Enumerations

Enumeration | Description
Attribute | Determines a certain paragraph format attribute.

Fields

Field | Description
MaxTabs | Represents the maximum number of tabs in a line.

Example

The following example shows how to add a specific paragraph format to the current paragraph. The text will be centered and a boxed frame is displayed.

[C#]
TXTextControl.ParagraphFormat format = new TXTextControl.ParagraphFormat();
format.Alignment = TXTextControl.HorizontalAlignment.Center;
format.Frame = TXTextControl.Frame.Box;
format.FrameStyle = TXTextControl.FrameStyle.Double;

textControl1.Selection.ParagraphFormat = format;
[Visual Basic]
Dim format As TXTextControl.ParagraphFormat = New TXTextControl.ParagraphFormat()
format.Alignment = TXTextControl.HorizontalAlignment.Center
format.Frame = TXTextControl.Frame.Box
format.FrameStyle = TXTextControl.FrameStyle.Double

TextControl1.Selection.ParagraphFormat = format

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat Constructor

Creates a new instance of the ParagraphFormat class.

ParagraphFormat()

Creates an empty ParagraphFormat object with all properties set to their default values.

[C#]
public ParagraphFormat();
[Visual Basic]
Public Class ParagraphFormat

ParagraphFormat(HorizontalAlignment)

Creates a new ParagraphFormat object with the specified horizontal alignment. All other properties are set to their default values.

[C#]
public ParagraphFormat(HorizontalAlignment alignment);
[Visual Basic]
Public Sub New(ByVal alignment As HorizontalAlignment)
Parameter Description
alignment

Specifies one of the HorizontalAlignment values. The following values are possible:

Value | Meaning
Center | Text is centered.
Justify | Text is fully justified.
Left | Text is left aligned.
Right | Text is right aligned.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.AbsoluteLineSpacing Property

Gets or sets the line spacing of a paragraph in twips.

Syntax

[C#]
public int AbsoluteLineSpacing { get; set; }
[Visual Basic]
Public Property AbsoluteLineSpacing() As Integer

Remarks

The property's default value is 0, indicating that the line spacing depends on the font height.

The property returns its default value when the text selection contains multiple paragraphs with mixed line spacing. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

The property's value must be between 20 twips (1 pt) and 32000 twips (1600 pt).

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • ParagraphFormat.LineSpacing
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.Alignment Property

Gets or sets the horizontal text alignment.

Syntax

[C#]
public HorizontalAlignment Alignment { get; set; }
[Visual Basic]
Public Property Alignment() As HorizontalAlignment
Value | Description
Left | Text is left aligned.
Right | Text is right aligned.
Center | Text is centered.
Justify | Text is justified.

Remarks

The property's default value is HorizontalAlignment.Left.

The property returns its default value when the text selection contains multiple paragraphs with mixed alignment. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.Attribute Enumeration

Determines a certain paragraph format attribute. This enumeration is used with the Selection.IsCommonValueSelected method. It contains the following values:

Member | Description
AbsoluteLineSpacing | Specifies the attribute set through the AbsoluteLineSpacing property.
Alignment | Specifies the attribute set through the Alignment property.
BackColor | Specifies the attribute set through the BackColor property.
BottomDistance | Specifies the attribute set through the BottomDistance property.
Direction | Specifies the attribute set through the Direction property.
Frame | Specifies the attribute set through the Frame property.
FrameDistance | Specifies the attribute set through the FrameDistance property.
FrameLineColor | Specifies the attribute set through the FrameLineColor property.
FrameLineWidth | Specifies the attribute set through the FrameLineWidth property.
FrameStyle | Specifies the attribute set through the FrameStyle property.
HangingIndent | Specifies the attribute set through the HangingIndent property.
Direction | Specifies the attribute set through the Direction property.
Justification | Specifies the attribute set through the Justification property.
KeepWithNext | Specifies the attribute set through the KeepWithNext property.
LeftIndent | Specifies the attribute set through the LeftIndent property.
LineSpacing | Specifies the attribute set through the LineSpacing property.
PageBreakBefore | Specifies the attribute set through the PageBreakBefore property.
RightIndent | Specifies the attribute set through the RightIndent property.
TabPositions | Specifies the attribute set through the TabPositions property.
TabTypes | Specifies the attribute set through the TabTypes property.
TopDistance | Specifies the attribute set through the TopDistance property.
WidowOrphanLines | Specifies the attribute set through the WidowOrphanLines property.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.BackColor Property

Gets or sets the background color of a paragraph. If the background color is transparent, the paragraph's background is the same as the control's background color.

Introduced: 24.0.

Syntax

[C#]
public System.Drawing.Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor() As System.Drawing.Color

Remarks

The property's default value is Color.Transparent.

The property returns its default value when the text selection contains multiple paragraphs with mixed background colors. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.FrameLineColor Property

Gets or sets the color used for the frame lines of a paragraph.

Introduced: 24.0.

Syntax

[C#]
public System.Drawing.Color FrameLineColor { get; set; }
[Visual Basic]
Public Property FrameLineColor() As System.Drawing.Color

Remarks

The property's default value is SystemColors.WindowText.

The property returns its default value when the text selection contains multiple paragraphs with mixed frame colors. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.BottomDistance Property

Gets or sets the bottom distance, in twips, between this and the next paragraph.

Syntax

[C#]
public int BottomDistance { get; set; }
[Visual Basic]
Public Property BottomDistance() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed bottom distances. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.Direction Property

Gets or sets the writing direction. A paragraph's writing direction can be either left to right or right to left.

Introduced: 20.0.

Syntax

[C#]
public Direction Direction { get; set; }
[Visual Basic]
Public Property Direction() As Direction
Value | Description
LeftToRight | The writing direction is left to right, which means that blocks of text with left to right and right to left characters are ordered from left to right.
RightToLeft | The writing direction is right to left, which means that blocks of text with left to right and right to left characters are ordered from right to left.

Remarks

The property's default value is Direction.LeftToRight.

The property returns its default value, if the text selection contains multiple paragraphs with mixed direction. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.Frame Property

Gets or sets a frame around the paragraph.

Syntax

[C#]
public Frame Frame { get; set; }
[Visual Basic]
Public Property Frame() As Frame
Value | Description
None | The paragraph has no frame.
LeftLine | The paragraph has a left frame line.
RightLine | The paragraph has a right frame line.
TopLine | The paragraph has a frame line at the top.
BottomLine | The paragraph has frame line at the bottom.
Box | The paragraph has a complete frame.
MergedBox | The paragraph has a complete frame. If the following or the previous paragraph also has a frame, the frames are merged to a single frame.

Remarks

The property's default value is Frame.None.

The property returns its default value when the text selection contains multiple paragraphs with mixed frames. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.FrameDistance Property

Gets or sets the distance, in twips, between the text and the paragraph's frame.

Syntax

[C#]
public int FrameDistance { get; set; }
[Visual Basic]
Public Property FrameDistance() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed distances. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.FrameLineWidth Property

Gets or sets the line width, in twips, of the paragraph's frame.

Syntax

[C#]
public int FrameLineWidth { get; set; }
[Visual Basic]
Public Property FrameLineWidth() As Integer

Remarks

The property's default value is 20 twips (1 pt).

The property returns its default value when the text selection contains multiple paragraphs with mixed widths. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.FrameStyle Property

Gets or sets the style of the paragraph's frame.

Syntax

[C#]
public FrameStyle FrameStyle { get; set; }
[Visual Basic]
Public Property FrameStyle() As FrameStyle
Value | Description
Single | The paragraph's frame is drawn with a single line.
Double | The paragraph's frame is drawn with a doubled line.

Remarks

The property's default value is FrameStyle.Single.

The property returns its default value when the text selection contains multiple paragraphs with mixed style. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.HangingIndent Property

Gets or sets the distance, in twips, for the hanging indent. A negative value indicates an additional indent of the paragraph's first line.

Syntax

[C#]
public int HangingIndent { get; set; }
[Visual Basic]
Public Property HangingIndent() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed hanging indents. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.Justification Property

Gets or sets the kind of justification in documents containing Arabic or Hebrew characters. If a paragraph is justified, the additional space to justify the line is added to the spaces between the words. If the line contains Arabic or Hebrew characters the line can also be justified though the insertion of Kashida lines.

Introduced: 20.0.

Syntax

[C#]
public Justification Justification { get; set; }
[Visual Basic]
Public Property Justification() As Justification
Value | Description
Spaces | To justify a line additional space is added to the spaces between the words.
Kashida | To justify a line Kashida lines are inserted.
SpacesAndKashida | To justify a line both kinds of justification are used.

Remarks

The property's default value is Justification.Spaces.

The property returns its default value, if the text selection contains multiple paragraphs with mixed justification settings. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.KeepLinesTogether Property

Gets or sets a value indicating whether a page break is allowed within the paragraph. If the property's value is true, a page break is not allowed. Otherwise, it is allowed.

Introduced: 13.0.

Syntax

[C#]
public bool KeepLinesTogether { get; set; }
[Visual Basic]
Public Property KeepLinesTogether() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple paragraphs with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.KeepWithNext Property

If this property is set to true, the paragraph is displayed on the same page as its following paragraph.

Introduced: 13.0.

Syntax

[C#]
public bool KeepWithNext { get; set; }
[Visual Basic]
Public Property KeepWithNext() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple paragraphs with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.LeftIndent Property

Gets or sets the distance, in twips, between the left edge of the Text Control and the left edge of the text.

Syntax

[C#]
public int LeftIndent { get; set; }
[Visual Basic]
Public Property LeftIndent() As Integer

Remarks

The property's default value is zero.

The property returns its default value when the text selection contains multiple paragraphs with mixed left indents. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.LineSpacing Property

Specifies the line spacing of a paragraph as a percentage of the font size.

Syntax

[C#]
public int LineSpacing { get; set; }
[Visual Basic]
Public Property LineSpacing() As Integer

Remarks

The property's default value is 100 percent.

The property returns its default value when the text selection contains multiple paragraphs with mixed line spacing. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

The property's value must be between 1 and 10000 percent (0.01 to 100 lines).

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • ParagraphFormat.AbsoluteLineSpacing
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.MaxTabs Field

Represents the maximum number of tabs in a line. The value of this constant is 14.

Syntax

[C#]
public const int MaxTabs;
[Visual Basic]
Public MaxTabs As Integer

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.PageBreakBefore Property

If this property is set to true, the paragraph is always displayed on top of a page.

Introduced: 13.0.

Syntax

[C#]
public bool PageBreakBefore { get; set; }
[Visual Basic]
Public Property PageBreakBefore() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple paragraphs with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.RightIndent Property

Gets or sets the distance, in twips, between the right edge of a Text Control document and the right edge of the text.

Syntax

[C#]
public int RightIndent { get; set; }
[Visual Basic]
Public Property RightIndent() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed right indents. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.TabPositions Property

Gets or sets an array containing the absolute tab stop positions, in twips, in a paragraph.

Syntax

[C#]
public int[] TabPositions { get; set; }
[Visual Basic]
Public Property TabPositions() As Integer()

Remarks

The default positions are multiple of 1134 twips (2 cm).

The property returns an array with common values when the text selection contains multiple paragraphs with mixed positions. The remaining not common values are set to zero. If all values are different, the Selection.IsCommonValueSelected method returns false.

Limitations

The maximum number of tabs in a line is 14.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.TabTypes Property

Gets or sets an array containing the tab types in a paragraph.

Syntax

[C#]
public TabType[] TabTypes { get; set; }
[Visual Basic]
Public Property TabTypes() As TabType()
Value | Description
LeftTab | The tab position is at the left side of the text.
RightTab | The tab position is at the right side of the text.
CenterTab | The text is centered to the tab position.
DecimalTab | The decimal sign is aligned at the tab position.
RightBorderTab | The tab is positioned right most and the text is diplayed at the left of this position. The tab position set with the TabPositions property is ignored. Only one tab of this kind is possible in a paragraph.

Remarks

The default type is TabType.LeftTab.

The property returns an array with common values when the text selection contains multiple paragraphs with mixed types. The remaining not common values are set to zero. If all values are different, the Selection.IsCommonValueSelected method returns false.

Limitations

The maximum number of tabs in a parapgraph is 14.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.TopDistance Property

Gets or sets a top distance, in twips, between this and the previous paragraph.

Syntax

[C#]
public int TopDistance { get; set; }
[Visual Basic]
Public Property TopDistance() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed top distances. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphFormat.WidowOrphanLines Property

Gets or sets the number of lines for widow/orphan control. Widow/orphan control avoids that a paragraph is started at the bottom of a page and that either, the majority of its lines, or only a few lines are displayed on the next page. This property's value determines how many lines must not be separated from the rest of the paragraph. For example, if this property is set to two, there must be at least three lines of the paragraph at the bottom of the previous page and at least three lines at the top of the next page. Otherwise, the complete paragraph is displayed on the next page. If this property is set to zero, widow/orphan control is disabled.

Introduced: 13.0.

Syntax

[C#]
public int WidowOrphanLines { get; set; }
[Visual Basic]
Public Property WidowOrphanLines() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple paragraphs with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

The property's value must be between 0 and 3.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ParagraphStyle Class

The ParagraphStyle class defines a formatting style for paragraphs. In addition to the properties described here, it inherits all properties and methods of the FormattingStyle class.

Introduced: 10.1.

Syntax

[C#]
public sealed class ParagraphStyle : FormattingStyle
[Visual Basic]
Public NotInheritable Class ParagraphStyle
  Inherits FormattingStyle

Constructors

Constructor | Description
ParagraphStyle | Overloaded. Creates a new instance of the ParagraphStyle class.

Properties

Property | Description
Baseline | Gets or sets the baseline alignment, in twips, of the style. (Inherited from FormattingStyle.)
BaseStyle | Gets the FormattingStyle which is the base style of this style. (Inherited from FormattingStyle.)
Bold | Gets or sets the bold attribute of the style. (Inherited from FormattingStyle.)
FollowingStyle | Gets or sets the name of the style that TextControl automatically selects for the following paragraph after the user has pressed the ENTER key.
FontName | Gets or sets the font of the style. (Inherited from FormattingStyle.)
FontSize | Gets or sets the font's size of the style. (Inherited from FormattingStyle.)
ForeColor | Gets or sets the style's color used to display the text. (Inherited from FormattingStyle.)
Italic | Gets or sets the italic attribute of the style. (Inherited from FormattingStyle.)
ListFormat | Gets or sets the style's bulleted or numbered list and/or its formatting attributes.
Name | Gets or sets the name of the style. (Inherited from FormattingStyle.)
ParagraphFormat | Gets or sets the style's paragraph attributes.
Strikeout | Gets or sets the strikeout attribute of the style. (Inherited from FormattingStyle.)
TextBackColor | Gets or sets the style's text background color. (Inherited from FormattingStyle.)
Underline | Gets or sets underlining styles for the style. (Inherited from FormattingStyle.)

Methods

Method | Description
Apply | Applies all set attributes of the style to the current document. (Inherited from FormattingStyle.)

Example

The following example shows how to add and apply a ParagraphStyle.

[C#]
textControl1.Text = "TX Text Control";

TXTextControl.ParagraphStyle par = new TXTextControl.ParagraphStyle("CenterBold");
par.Bold = true;
par.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center;
textControl1.ParagraphStyles.Add(par);

textControl1.Select(0,0);
textControl1.Selection.FormattingStyle = "CenterBold";
[Visual Basic]
TextControl1.Text = "TX Text Control"

Dim par As TXTextControl.ParagraphStyle = New TXTextControl.ParagraphStyle("CenterBold")
par.Bold = True
par.ParagraphFormat.Alignment = TXTextControl.HorizontalAlignment.Center
TextControl1.ParagraphStyles.Add(par)

TextControl1.Select(0, 0)
TextControl1.Selection.FormattingStyle = "CenterBold"

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyle Constructor

Creates a new instance of the ParagraphStyle class.

ParagraphStyle(String)

Creates a new instance of the ParagraphStyle class based on the TextControl root style named [Normal].

[C#]
public ParagraphStyle(string name);
[Visual Basic]
Public Sub New(ByVal name As String)
Parameter | Description
name | Specifies the new style's name.

ParagraphStyle(String, String)

Creates a new instance of the ParagraphStyle class based on the specified base style.

[C#]
public ParagraphStyle(string name, string baseStyle);
[Visual Basic]
Public Sub New(ByVal name As String, ByVal baseStyle As String)
Parameter | Description
name | Specifies the new style's name.
baseStyle | Specifies the name of the style the new style is based on.

ParagraphStyle(ParagraphStyle)

Creates a new root style that has all attributes of the specified style.

[C#]
public ParagraphStyle(ParagraphStyle style);
[Visual Basic]
Public Sub New(ByVal style As ParagraphStyle)
Parameter | Description
style | Is a style the attributes of which are used to initialize the new style.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyle.FollowingStyle Property

Gets or sets the name of the style that TextControl automatically selects for the following paragraph after the user has pressed the ENTER key.

Syntax

[C#]
public string FollowingStyle { get; set; }
[Visual Basic]
Public Property FollowingStyle() As String

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyle.ListFormat Property

Gets or sets the style's bulleted or numbered list and/or its formatting attributes. The property's value is an object of the type ListFormat.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyle.ParagraphFormat Property

Gets or sets the style's paragraph attributes. The property's value is an object of the type ParagraphFormat.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyleCollection Class

An instance of the ParagraphStyleCollection class contains all paragraph formatting styles in the current document represented through objects of the type ParagraphStyle. A paragraph style is a formatting style that can be used to format blocks of text. The ParagraphStyleCollection class implements the IEnumerable and the ICollection interfaces. An instance of this class can be obtained with the TextControl.ParagraphStyles property.

Introduced: 10.1.

Syntax

[C#]
public sealed class ParagraphStyleCollection : FormattingStyleCollection
[Visual Basic]
Public NotInheritable Class ParagraphStyleCollection
  Inherits FormattingStyleCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FormattingStyleCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FormattingStyleCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FormattingStyleCollection.)

Methods

Method | Description
Add | Adds to new formatting style to the current document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FormattingStyleCollection.)
GetItem | Gets a particular style from the collection.
Remove | Removes a formatting style from a Text Control document. (Inherited from FormattingStyleCollection.)

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyleCollection.Add Method

Adds to new formatting style to the current document.

Syntax

[C#]
public bool Add(ParagraphStyle paragraphStyle);
[Visual Basic]
Public Function Add(ByVal paragraphStyle As ParagraphStyle) As Boolean
Parameter | Description
paragraphStyle | Specifies the style to add.

Return Value

The return value is true, if the style could be added. Otherwise it is false.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyleCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ParagraphStyleCollection.GetItem Method

Gets a particular style from the collection.

Syntax

[C#]
public ParagraphStyle GetItem(string styleName);
[Visual Basic]
Public Function GetItem(ByVal styleName As String) As ParagraphStyle
Parameter | Description
styleName | Specifies the name of the style.

Return Value

The return value is null, if a style with the specified name is not contained in the collection. Otherwise it is an object of the type ParagraphStyle.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.RulerBar Class

The RulerBar class represents a Windows Forms tool bar which can be used to show or to set indents, margins and tabs of a Windows Forms TextControl. It is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the RulerBar class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Syntax

[C#]
public class RulerBar : Control
[Visual Basic]
Public Class RulerBar
  Inherits Control

Properties

Property | Description
Alignment | Gets or sets a value specifying the alignment of the ruler bar in the document.
BorderStyle | Gets or sets the border style of the ruler bar.
DisplayColors | Gets or sets the colors of the ruler bar.
EnablePageMargins | Enables or disables the setting of page margins.
ReadOnly | Gets or sets a value determining the ruler bar's read only mode.
ScaleUnit | Gets or sets the unit of the ruler bar's scale.

Methods

Method | Description
ResetDisplayColors | Resets all display colors of a ruler bar to their system dependent default values.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Alignment Property

Gets or sets a value specifying the alignment of the ruler bar in the document. Depending on the alignment either a horizontal or a vertical ruler is displayed. This property is automatically set to Top, if the control's Dock property is set to to Top or Bottom. It is automatically set to Left, if the control's Dock property is set to to Left or Right.

Introduced: 13.0.

Syntax

[C#]
public RulerBarAlignment Alignment { get; set; }
[Visual Basic]
Public Property Alignment As RulerBarAlignment
Value | Description
Left | The ruler bar is displayed with a vertical ruler.
Top | The ruler bar is displayed with a horizontal ruler.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.BorderStyle Property

Gets or sets the border style of the ruler bar.

Introduced: 11.0.

Syntax

[C#]
public RulerBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle As RulerBarBorderStyle
Value | Description
ColorScheme | The ruler bar has a flat design without a border. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The ruler bar has a flat design and no border.
FixedSingle | The ruler bar has has a flat design and a border with a single line.
Simple3D | The ruler bar has a 3D design and no border.
Fixed3D | The ruler bar has a 3D design and a border with a single line.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.DisplayColors Property

Gets or sets the colors of the ruler bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type RulerBar.Colors.

Introduced: 15.1.

Syntax

[C#]
public RulerBar.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As RulerBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.EnablePageMargins Property

Enables or disables the setting of page margins. If the property's value is true, the setting of page margins is enabled.

Introduced: 13.0.

Syntax

[C#]
public bool EnablePageMargins { get; set; }
[Visual Basic]
Public Property EnablePageMargins As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.ReadOnly Property

Gets or sets a value determining the ruler bar's read only mode. When the ruler bar is set to read only, it still shows all formatting attributes of the connected TextControl, but formatting attributes cannot be changed.

Introduced: 24.0.

Syntax

[C#]
public bool ReadOnly { get; set; }
[Visual Basic]
Public Property ReadOnly As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.ResetDisplayColors Method

Resets all display colors of a ruler bar to their system dependent default values.

Introduced: 15.1.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.ScaleUnit Property

Gets or sets the unit of the ruler bar's scale.

Syntax

[C#]
public RulerBarScaleUnit ScaleUnit { get; set; }
[Visual Basic]
Public Property ScaleUnit As RulerBarScaleUnit
Value | Description
Auto | The ruler is automatically scaled in inch or in millimeter depending on the currently set culture.
Centimeter | The ruler bar is scaled in centimeter without millimeter marks.
Inch | The ruler bar is scaled in inch.
Millimeter | The ruler bar is scaled in centimeter including millimeter marks.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors Class

The RulerBar.Colors class gets, sets or resets the display colors of a Windows Forms RulerBar control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the ruler bar's BorderStyle property has been set to ColorScheme.

Introduced: 15.1.

Syntax

[C#]
public class RulerBar.Colors
[Visual Basic]
Public Class RulerBar.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the RulerBar.Colors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left or top edge of the ruler bar.
ForeColor | Gets or sets the color used for the numbers of the ruler.
GradientBackColor | Gets or sets the background color at the right or bottom edge of the ruler bar.
RulerColor | Gets or sets the color of the ruler.
SeparatorColorDark | Gets or sets the color of dark separators.
SeparatorColorLight | Gets or sets the color of light separators.

Methods

Method | Description
ResetBackColor | Resets the ruler bar's BackColor to its system dependent default value.
ResetForeColor | Resets the ruler bar's ForeColor to its system dependent default value.
ResetGradientBackColor | Resets the ruler bar's GradientBackColor to its system dependent default value.
ResetRulerColor | Resets the ruler bar's RulerColor to its system dependent default value.
ResetSeparatorColorDark | Resets the ruler bar's SeparatorColorDark to its system dependent default value.
ResetSeparatorColorLight | Resets the ruler bar's SeparatorColorLight to its system dependent default value.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors Constructor

Initializes a new instance of the RulerBar.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the RulerBar.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public RulerBar.Colors();
[Visual Basic]
Public Class RulerBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.BackColor Property

Gets or sets the background color at the left or top edge of the ruler bar.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ForeColor Property

Gets or sets the color used for the numbers of the ruler.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.GradientBackColor Property

Gets or sets the background color at the right or bottom edge of the ruler bar.

Syntax

[C#]
public Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetBackColor Method

Resets the ruler bar's BackColor to its system dependent default value.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetForeColor Method

Resets the ruler bar's ForeColor to its system dependent default value.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetGradientBackColor Method

Resets the ruler bar's GradientBackColor to its system dependent default value.

Syntax

[C#]
public void ResetGradientBackColor();
[Visual Basic]
Public Sub ResetGradientBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetRulerColor Method

Resets the ruler bar's RulerColor to its system dependent default value.

Syntax

[C#]
public void ResetRulerColor();
[Visual Basic]
Public Sub ResetRulerColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetSeparatorColorDark Method

Resets the ruler bar's SeparatorColorDark to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorDark();
[Visual Basic]
Public Sub ResetSeparatorColorDark()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.ResetSeparatorColorLight Method

Resets the ruler bar's SeparatorColorLight to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorLight();
[Visual Basic]
Public Sub ResetSeparatorColorLight()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.RulerColor Property

Gets or sets the color of the ruler.

Syntax

[C#]
public Color RulerColor { get; set; }
[Visual Basic]
public Property RulerColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.SeparatorColorDark Property

Gets or sets the color of dark separators.

Syntax

[C#]
public Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.RulerBar.Colors.SeparatorColorLight Property

Gets or sets the color of light separators.

Syntax

[C#]
public Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.SaveSettings Class

The SaveSettings class provides properties for advanced settings and information during save operations. See the TextControl.Save method for more information.

Syntax

[C#]
public sealed class SaveSettings
[Visual Basic]
Public NotInheritable Class SaveSettings

Properties

Property | Description
Author | Sets the document's author which will be saved in the document.
BytesWritten | Gets the number of bytes written during a save operation.
CreationDate | Sets the document's creation date which will be saved in the document.
CreatorApplication | Sets the application, which has created the document.
CssFileName | HTML only. Sets the path and filename of a CSS file belonging to a HTML document.
CssSaveMode | HTML only. Specifies how to save stylesheet data with a HTML document.
DigitalSignature | Specifies a DigitalSignature object, which defines an X.509 certificate.
DocumentAccessPermissions | Specifies how a document can be accessed after it has been opened.
DocumentBasePath | Sets a base path saved in the document that is used to resolve relative file paths.
DocumentKeywords | Sets the document's keywords which will be saved in the document.
DocumentLevelJavaScriptActions | Specifies an array of strings containing Javascript.
DocumentSubject | Sets the document's subject string which will be saved in the document.
DocumentTitle | Sets the document's title that will be saved in the document.
ImageCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy image compression used when a document is saved.
ImageExportFilterIndex | Sets the format used for saving all images contained in the document.
ImageMaxResolution | Sets the maximum resolution for all images in the document in dots per inch when the document is saved.
ImageSaveMode | Determines whether the document's images are stored through its data or through its file reference.
ImageSavePath | Sets a file path that is used to save resources like images when images are saved as file link.
LastModificationDate | Sets the date the document is last modified.
MasterPassword | Specifies the password for the document's access permissions.
PageMargins | Sets the margins saved for the document's pages.
PageSize | Sets the width and height saved for the document's pages.
ReportingMergeBlockFormat | Specifies how reporting merge blocks are handled when a document is saved.
SavedFile | Read only. Gets the name and path of the file that has been saved.
SaveDocumentBackColor | Specifies whether or not the document background color is saved.
SavedStreamType | Read only. Gets the StreamType of the file that has been saved.
UserDefinedDocumentProperties | Sets a dictionary with all user-defined document properties which will be saved in the document.
UserPassword | Specifies the password for the user when the document is reopened.

Example

The following example shows how to use the SaveSettings to create a password protected PDF document.

[C#]
TXTextControl.SaveSettings save = new TXTextControl.SaveSettings();
save.UserPassword = "TX Text Control";

textControl1.Save("test.pdf", TXTextControl.StreamType.AdobePDF, save);
[Visual Basic]
Dim save As TXTextControl.SaveSettings = New TXTextControl.SaveSettings()
save.UserPassword = "TX Text Control"

TextControl1.Save("test.pdf", TXTextControl.StreamType.AdobePDF, save)

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.Author Property

Sets the document's author which will be saved in the document.

Introduced: 23.0.

Syntax

[C#]
public string Author { get; set; }
[Visual Basic]
Public Property Author() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.BytesWritten Property

Gets the number of bytes written during a save operation.

Syntax

[C#]
public long BytesWritten { get; }
[Visual Basic]
Public ReadOnly Property BytesWritten() As Long

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.CreationDate Property

Sets the document's creation date which will be saved in the document.

Introduced: 23.0.

Syntax

[C#]
public System.DateTime CreationDate { get; set; }
[Visual Basic]
Public Property CreationDate() As System.DateTime

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.CreatorApplication Property

Sets the application, which has created the document.

Introduced: 23.0.

Syntax

[C#]
public string CreatorApplication { get; set; }
[Visual Basic]
Public Property CreatorApplication() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.CssFileName Property

HTML only. Sets the path and filename of a CSS file belonging to a HTML document.

Syntax

[C#]
public string CssFileName { get; set; }
[Visual Basic]
Public Property CssFileName() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.CssSaveMode Property

HTML only. Specifies how to save stylesheet data with a HTML document.

Syntax

[C#]
public CssSaveMode CssSaveMode { get; set; }
[Visual Basic]
Public Property CssSaveMode() As CssSaveMode
Value | Description
None | All format information is saved in the body of the HTML document through HTML tags.
Inline | Stylesheets are saved in the head of the HTML document.
CreateFile | Stylesheets are saved in a newly created CSS file. This file has the same name and location as the corresponding HTML file or is specified through the SaveSettings.CssFileName property. The file is only created if it does not exist. If the HTML document is saved in a memory buffer, this setting cannot be used.
OverwriteFile | Stylesheets are saved in a newly created CSS file. This file has the same name and location as the corresponding HTML file or is specified through the SaveSettings.CssFileName property. If the file already exists, it is overridden. If the HTML document is saved in a memory buffer, this setting cannot be used.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DigitalSignature Property

Specifies a DigitalSignature object, which defines an X.509 certificate. This certificate can be used to digitally sign a PDF or a PDF/A file. For other formats this property has no meaning.

Introduced: 17.0.

Syntax

[C#]
public DigitalSignature DigitalSignature { get; set; }
[Visual Basic]
Public Property DigitalSignature() As DigitalSignature

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentAccessPermissions Property

Specifies how a document can be accessed after it has been opened. This property has only an effect if also a password has been specified with the SaveSettings.MasterPassword property. If no password has been specified the document can be accessed without any restrictions. The property's value can be a bitwise combination of more than one of the described values.

Introduced: 11.0.

Syntax

[C#]
public DocumentAccessPermissions DocumentAccessPermissions { get; set; }
[Visual Basic]
Public Property DocumentAccessPermissions() As DocumentAccessPermissions
Value | Description
None | Allows none of the possible permissions.
AllowAll | Allows all of the possible permissions.
AllowAuthoring | Allows authoring comments and fill in interactive form fields (including signature fields).
AllowAuthoringFields | Fill-in existing interactive form fields (including signature fields) is allowed.
AllowContentAccessibility | Allows content access for the visually impaired only.
AllowDocumentAssembly | Allows to assemble the document (insert, rotate or delete pages and create bookmarks or thumbnails).
AllowExtractContents | Copying or otherwise extracting text and/or graphics is allowed.
AllowGeneralEditing | Allows modifying the document's contents.
AllowHighLevelPrinting | Printing the document is fully allowed.
AllowLowLevelPrinting | Printing the document is allowed (low-level).

Limitations

PDF only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentKeywords Property

Sets the document's keywords which will be saved in the document.

Introduced: 23.0.

Syntax

[C#]
public string[] DocumentKeywords { get; set; }
[Visual Basic]
Public Property DocumentKeywords() As String()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentLevelJavaScriptActions Property

Specifies an array of strings containing Javascript. The scripts are embedded in a PDF document at document level and they are executed, when the PDF document is opened. When the document is saved as PDF/A the scripts are not embedded.

Introduced: 22.0.

Syntax

[C#]
public string[] DocumentLevelJavaScriptActions { get; set; }
[Visual Basic]
Public Property DocumentLevelJavaScriptActions() As String()

Limitations

PDF only, not PDF/A.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentSubject Property

Sets the document's subject string which will be saved in the document.

Introduced: 23.0.

Syntax

[C#]
public string DocumentSubject { get; set; }
[Visual Basic]
Public Property DocumentSubject() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentTitle Property

Sets the document's title that will be saved in the document.

Syntax

[C#]
public string DocumentTitle { get; set; }
[Visual Basic]
Public Property DocumentTitle() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.DocumentBasePath Property

Sets a base path saved in the document that is used to resolve relative file paths.

Syntax

[C#]
public string DocumentBasePath { get; set; }
[Visual Basic]
Public Property DocumentBasePath() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ImageCompressionQuality Property

Sets a value between 1 and 100, which is the quality of a lossy image compression used when a document is saved. It is used for all images in the document the data of which is compressed with a lossy compression algorithm. A value of 100 indicates the maximum quality, a value of 1 indicates the minimum quality. A value of zero selects a compression specific default value. For a single image the value of this property can be overwritten using the Image.ExportCompressionQuality property.

Introduced: 11.0.

Syntax

[C#]
public int ImageCompressionQuality { get; set; }
[Visual Basic]
Public Property ImageCompressionQuality() As Integer

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ImageExportFilterIndex Property

Sets the format used for saving all images contained in the document. This is the number of the filter in the string returned through the ImageCollection.ExportFilters property, beginning with number one. If the ImageCollection.ExportFilters property is used to initialize the FileDialog.Filter property of a Framework dialog, the FileDialog.FilterIndex property can be used as value for this property. A value of zero indicates that the original format of each image is used. The original format can be obtained with the Image.FilterIndex property. For a single image the value of this property can be overwritten with the Image.ExportFilterIndex property. The technical article Loading and Saving Images describes how images can be loaded and saved.

Introduced: 15.1.

Syntax

[C#]
public int ImageExportFilterIndex { get; set; }
[Visual Basic]
Public Property ImageExportFilterIndex() As Integer
Value | Description
1 | Windows Bitmap (.BMP)
2 | Windows Metafile (.WMF)
3 | Portable Network Graphics (.PNG)
4 | JPEG File Interchange Format (.JPG, .JPEG)
5 | Windows Enhanced Metafile (.EMF)
6 | Tagged Image Format (.TIF)
7 | Graphics Interchange Format (.GIF)

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ImageMaxResolution Property

Sets the maximum resolution for all images in the document in dots per inch when the document is saved. If an image's resolution is larger than this property's value it is reduced otherwise it is not changed. If this property's value is zero, which is the default value, the default resolution of each image is used. For a single image the value of this property can be overwritten using the Image.ExportMaxResolution property.

Introduced: 11.0.

Syntax

[C#]
public int ImageMaxResolution { get; set; }
[Visual Basic]
Public Property ImageMaxResolution() As Integer

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ImageSaveMode Property

Determines whether the document's images are stored through its data or through its file reference. By default images are stored through a file reference, when a file reference exists. Otherwise, if an image has been pasted from the clipboard, it is stored with its binary data. For a single image the value of this property can be overwritten with the Image.SaveMode property. The technical article Loading and Saving Images gives an overview how to export images.

Introduced: 15.1.

Syntax

[C#]
public ImageSaveMode ImageSaveMode { get; set; }
[Visual Basic]
Public Property ImageSaveMode() As ImageSaveMode
Value | Description
Auto | An image is saved with a file reference, when a file reference exists. Otherwise it is saved with its binary data.
SaveAsData | The document's images are saved with their binary data.
SaveAsFileReference | The document's images are saved through file references.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ImageSavePath Property

Sets a file path that is used to save resources like images when images are saved as file link. If this location does not exists it is generated.

Syntax

[C#]
public string ImageSavePath { get; set; }
[Visual Basic]
Public Property ImageSavePath() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.LastModificationDate Property

Sets the date the document is last modified.

Introduced: 23.0.

Syntax

[C#]
public System.DateTime LastModificationDate { get; set; }
[Visual Basic]
Public Property LastModificationDate() As System.DateTime

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.MasterPassword Property

Specifies the password for the document's access permissions. If the password is an empty string, accessing the document is not restricted. If a password is specified, the access permissions are given through the SaveSettings.DocumentAccessPermissions property.

Introduced: 11.0.

Syntax

[C#]
public string MasterPassword { get; set; }
[Visual Basic]
Public Property MasterPassword() As String

Limitations

PDF only. The encryption key length is 128 bits.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.PageMargins Property

Sets the margins saved for the document's pages.

Syntax

[C#]
public PageMargins PageMargins { set; }
[Visual Basic]
Public WriteOnly Property PageMargins() As PageMargins

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.PageSize Property

Sets the width and height saved for the document's pages.

Syntax

[C#]
public System.Drawing.Size PageSize { set; }
[Visual Basic]
Public WriteOnly Property PageSize() As System.Drawing.Size

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.ReportingMergeBlockFormat Property

Specifies how reporting merge blocks are handled when a document is saved. Reporting merge blocks can be saved in a document either through special document targets represented through DocumentTarget objects or through special subtextparts represented through SubTextPart objects. When a merge block is marked with document targets, the name of the starting marker begins with blockstart_ and the name of the ending marker begins with blockend_. When a merge block is marked through a subtextpart, its name begins with txmb_.

Introduced: 24.0.

Syntax

[C#]
public ReportingMergeBlockFormat ReportingMergeBlockFormat { get; set; }
[Visual Basic]
Public Property ReportingMergeBlockFormat() As ReportingMergeBlockFormat
Value | Description
Default | The document is saved as it is. Reporting merge blocks are not converted.
DocumentTargets | If the document contains reporting merge blocks marked with subtextparts, these subtextparts are converted to document targets.
SubTextParts | This member is not used, when a document is saved.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.SavedFile Property

Read only. Gets the name and path of the file that has been saved. It is set to an empty string, if text has been saved in a byte array or as a string.

Syntax

[C#]
public string SavedFile { get; }
[Visual Basic]
Public ReadOnly Property SavedFile() As String

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.SaveDocumentBackColor Property

Specifies whether or not the document background color is saved. By default it is saved.

Introduced: 24.0.

Syntax

[C#]
public bool SaveDocumentBackColor { get; set; }
[Visual Basic]
Public Property SaveDocumentBackColor() As Boolean

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.SavedStreamType Property

Read only. Gets the StreamType of the file that has been saved.

Syntax

[C#]
public StreamType SavedStreamType { get; }
[Visual Basic]
Public ReadOnly Property SavedStreamType() As StreamType

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.UserDefinedDocumentProperties Property

Sets a dictionary with all user-defined document properties which will be saved in the document. The property's value must be an object of the type UserDefinedPropertyDictionary.

Introduced: 24.0.

Syntax

[C#]
public UserDefinedPropertyDictionary UserDefinedDocumentProperties { get; set; }
[Visual Basic]
Public Property UserDefinedDocumentProperties() As UserDefinedPropertyDictionary

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.SaveSettings.UserPassword Property

Specifies the password for the user when the document is reopened. If the password is an empty string the document can be reopened by every user.

Introduced: 11.0.

Syntax

[C#]
public string UserPassword { get; set; }
[Visual Basic]
Public Property UserPassword() As String

Limitations

PDF only. The encryption key length is 128 bits.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.Section Class

An object of the Section class represents a section of a document. Sections are numbered from the beginning to the end of the document beginning with 1. A document has at least one section. A section is a part of the document that specifies the page size, the page margins and the headers and footers. A section object can be obtained from the section collection available through the TextControl.Sections property.

Introduced: 14.0.

Syntax

[C#]
public class Section
[Visual Basic]
Public Class Section

Properties

Property | Description
Format | Gets or sets the section's formatting attributes.
HeadersAndFooters | Gets a collection of all headers and footers of the section.
Length | Gets the number of characters in the section.
Number | Gets the section's number.
Start | Gets the number (one-based) of the first character in the section.

Methods

Method | Description
Select | Selects the section.

Example

The following example shows how to use the SectionClass to insert a new section with a different header and page orientation than the previous one:

[C#]
textControl1.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header);
textControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage);
textControl1.Sections[2].Format.Landscape = true;
textControl1.Sections[2].HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header).ConnectedToPrevious = false;
TXTextControl.Selection mySelection = new TXTextControl.Selection(0, -1);
mySelection.Text = "New Section";
textControl1.Sections[2].HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header).Selection = mySelection;
[Visual Basic]
TextControl1.HeadersAndFooters.Add(TXTextControl.HeaderFooterType.Header)
TextControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage)
TextControl1.Sections(2).Format.Landscape = True
TextControl1.Sections(2).HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header).ConnectedToPrevious = False
Dim MySelection = New TXTextControl.Selection(0, -1)
MySelection.Text = "New Section"
TextControl1.Sections(2).HeadersAndFooters.GetItem(TXTextControl.HeaderFooterType.Header).Selection = MySelection

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.Format Property

Gets or sets the section's formatting attributes. The property's value is an object of the type SectionFormat which defines the page size and the page margins.

Syntax

[C#]
public SectionFormat Format { get; set; }
[Visual Basic]
Public Property Format() As SectionFormat

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.HeadersAndFooters Property

Gets a collection of all headers and footers of the section. The property's value is an object of the type HeaderFooterCollection.

Syntax

[C#]
public HeaderFooterCollection HeadersAndFooters { get; }
[Visual Basic]
Public ReadOnly Property HeadersAndFooters() As HeaderFooterCollection

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.Length Property

Gets the number of characters in the section. The section break character is not included.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.Number Property

Gets the section's number. The first section has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.Select Method

Selects the section. The section break characters bounding the section are not selected.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Section.Start Property

Gets the number (one-based) of the first character in the section.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection Class

An instance of the SectionCollection class contains all sections of a document. A document has at least one section. An instance of this class can be obtained with the TextControl.Sections property. The SectionCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 14.0.

Syntax

[C#]
public sealed class SectionCollection: ICollection, IEnumerable
[Visual Basic]
Public NotInheritable Class SectionCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
Add | Overloaded. Adds a new section to a document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Gets the Section with the current text input position from the collection.
Item | Gets a section from the collection.

Example

The following example shows how to add a new section and get the actual section number:

[C#]
textControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage);
Console.WriteLine("Section " + textControl1.Sections.GetItem().Number.ToString()
  + " of " + textControl1.Sections.Count.ToString());
[Visual Basic]
TextControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage)
Console.WriteLine("Section " + TextControl1.Sections.GetItem().Number.ToString() _
  + " of " + TextControl1.Sections.Count.ToString())

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.Add Method

Adds a new section to a document.

Add(SectionBreakKind)

Adds a new section at the current text input position. The new section ends at the end position of the section containing the input position. If a new section is inserted in a paragraph or table, the paragraph or table is split into two paragraphs or tables.

[C#]
public bool Add(SectionBreakKind sectionBreakKind);
[Visual Basic]
Public Function Add(ByVal sectionBreakKind As SectionBreakKind) As Boolean
Parameter Description
sectionBreakKind

Specifies the kind of the section break. It can be one of the SectionBreakKind values. The following values are possible:

Value | Meaning
BeginAtNewLine | The section begins on the next line with a new paragraph.
BeginAtNewPage | The section begins on the next page with a new paragraph.

Add(SectionBreakKind, Int32)

Adds a new section at the specified text input position. The new section ends at the end position of the section containing the input position. If a new section is inserted in a paragraph or table, the paragraph or table is split into two paragraphs or tables.

[C#]
public bool Add(SectionBreakKind sectionBreakKind, int textPosition);
[Visual Basic]
Public Function Add(ByVal sectionBreakKind As SectionBreakKind, ByVal textPosition As Integer) As Boolean
Parameter Description
sectionBreakKind

Specifies the kind of the section break. It can be one of the SectionBreakKind values. The following values are possible:

Value | Meaning
BeginAtNewLine | The section begins on the next line with a new paragraph.
BeginAtNewPage | The section begins on the next page with a new paragraph.
textPosition

Specifies the text position at which the section is to be inserted.

Return Value

The return value is true, if the section could be added. Otherwise it is false.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.GetItem Method

Gets the Section with the current text input position from the collection.

Syntax

[C#]
public Section GetItem();
[Visual Basic]
Public Function GetItem() As Section

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionCollection.Item Property

Gets a section from the collection. In C# this property is the indexer for the SectionCollection class.

Syntax

[C#]
public Section this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As Section
Parameter | Description
number | Specifies a section number. The first section has the number 1.

Return Value

The return value is null, if the section could not be found. Otherwise, it is an object of the type Section.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat class

An instance of the SectionFormat class represents the formatting attributes of a section.

Introduced: 14.0.

Syntax

[C#]
public class SectionFormat
[Visual Basic]
Public Class SectionFormat

Constructors

Constructor | Description
SectionFormat | Overloaded. Creates a new instance of the SectionFormat class.

Properties

Property | Description
BreakKind | Gets or sets the kind of the section break the section starts with.
ColumnDistances | Gets the distances, in twips, between the columns on a page.
ColumnLineColor | Gets or sets the color of a dividing line between two columns.
ColumnLineWidth | Gets or sets the width of a dividing line between two columns.
Columns | Gets or sets the number of columns on a page.
ColumnWidths | Gets the widths, in twips, of the columns on a page.
EqualColumnWidth | Gets or sets a value indicating whether the columns on a page have all the same width and the same distance between them.
Landscape | Gets or sets a value indicating whether the section's page size is in landscape orientation.
PageBorder | Gets or sets the attributes of a section's page border.
PageMargins | Gets or sets the section's page margins.
PageSize | Gets or sets the section's page size.
RestartPageNumbering | Gets or sets a value indicating whether page numbering is restarted at the section's beginning.

Enumerations

Enumeration | Description
Attribute | Determines a certain section format attribute.

Example

The following example shows how to add a new section with a specific page size, orientation and margins into an existing document. Additionally, the section is devided into 3 columns with different column widths and column distances:

[C#]
TXTextControl.SectionFormat sf = new TXTextControl.SectionFormat(3, new int[] { 1500, 2500, 5000 }, new int[] { 250, 500 });
sf.ColumnLineColor = Color.Black;
sf.ColumnLineWidth = 50;
sf.PageSize = new Size(500, 1000);
sf.Landscape = true;
sf.PageMargins = new TXTextControl.PageMargins(100, 100, 100, 100);
textControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage);
textControl1.Sections.GetItem().Format = sf;
[Visual Basic]
Dim sf As New TXTextControl.SectionFormat(3, New Integer() {1500, 2500, 5000}, New Integer() {250, 500})
sf.ColumnLineColor = Color.Black
sf.ColumnLineWidth = 50
sf.PageSize = New Size(500, 1000)
sf.Landscape = True
sf.PageMargins = New TXTextControl.PageMargins(100, 100, 100, 100)
TextControl1.Sections.Add(TXTextControl.SectionBreakKind.BeginAtNewPage)
TextControl1.Sections.GetItem().Format = sf

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat Constructor

Creates a new instance of the SectionFormat class.

SectionFormat()

Creates an empty SectionFormat object. Further properties must be set.

[C#]
public SectionFormat();
[Visual Basic]
Public Sub New()

SectionFormat(Int32, Int32)

Creates a SectionFormat object for a section with equal column widths. The SectionFormat.EqualColumnWidth property is automatically set to true.

[C#]
public SectionFormat(int columns, int columnDistance);
[Visual Basic]
Public Sub New(ByVal columns As Integer, ByVal columnDistance As Integer)
Parameter | Description
columns | Specifies the number of columns for the section.
columnDistance | Specifies the distance between equal columns.

SectionFormat(Int32, Int32[], Int32[])

Creates a SectionFormat object for a section with individual column widths and distances. The SectionFormat.EqualColumnWidth property is automatically set to false.

[C#]
public SectionFormat(int columns, int[] columnWidths, int[] columnDistances);
[Visual Basic]
Public Sub New(ByVal columns As Integer, columnWidths As Integer(), columnDistances As Integer())
Parameter | Description
columns | Specifies the number of columns for the section.
columnWidths | Specifies the widths of the columns. The array must contain exactly an element for each column.
columnDistances | Specifies the distances between the columns. The array must contain exactly an element for each distance. The size of this array must be one less the size of the columnWidths array. The sum of all widths and distances must not exceed the width of the page's text area. Otherwise an exception occurs. The width of the text area is the page width less the left and the right page margin.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.Attribute Enumeration

Determines a certain section format attribute. This enumeration is used with the Selection.IsCommonValueSelected method. It contains the following values:

Member | Description
BreakKind | Specifies the attribute set through the BreakKind property.
ColumnDistances | Specifies the attribute set through the ColumnDistances property.
ColumnLineColor | Specifies the attribute set through the ColumnLineColor property.
ColumnLineWidth | Specifies the attribute set through the ColumnLineWidth property.
Columns | Specifies the attribute set through the Columns property.
ColumnWidths | Specifies the attribute set through the ColumnWidths property.
EqualColumnWidth | Specifies the attribute set through the EqualColumnWidth property.
Landscape | Specifies the attribute set through the Landscape property.
PageSize | Specifies the attribute set through the PageSize property.
RestartPageNumbering | Specifies the attribute set through the RestartPageNumbering property.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.BreakKind Property

Gets or sets the kind of the section break the section starts with. The property's value is a member of the SectionBreakKind enumeration.

Syntax

[C#]
public SectionBreakKind BreakKind { get; set; }
[Visual Basic]
Public Property BreakKind() As SectionBreakKind
Value | Description
BeginAtNewLine | The section begins on the next line with a new paragraph.
BeginAtNewPage | The section begins on the next page with a new paragraph.

Remarks

The property's default value is SectionBreakKind.BeginAtNewPage.

The property returns its default value when the text selection contains multiple sections with mixed alignment. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.ColumnDistances Property

Gets the distances, in twips, between the columns on a page. This property is read only, to set new distances one of the SectionFormat constructors must be used.

Introduced: 15.0.

Syntax

[C#]
public int[] ColumnDistances { get; }
[Visual Basic]
Public ReadOnly Property ColumnDistances() As Integer()

Remarks

The size of the array is: number of columns - 1

The property returns null when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.ColumnLineColor Property

Gets or sets the color of a dividing line between two columns.

Introduced: 15.0.

Syntax

[C#]
public Color ColumnLineColor { get; set; }
[Visual Basic]
Public Property ColumnLineColor() As Color

Remarks

The property's default value is the system color for text.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.ColumnLineWidth Property

Gets or sets the width of a dividing line between two columns. If this property's value is zero there is no dividing line. Otherwise it is a value in twips.

Introduced: 15.0.

Syntax

[C#]
public int ColumnLineWidth { get; set; }
[Visual Basic]
Public Property ColumnLineWidth() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.Columns Property

Gets or sets the number of columns on a page.

Introduced: 15.0.

Syntax

[C#]
public int Columns { get; set; }
[Visual Basic]
Public Property Columns() As Integer

Remarks

The property's default value is 1.

The property returns 0 when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.ColumnWidths Property

Gets the widths, in twips, of the columns on a page. This property is read only, to set new widths one of the SectionFormat constructors must be used.

Introduced: 15.0.

Syntax

[C#]
public int[] ColumnWidths { get; }
[Visual Basic]
Public ReadOnly Property ColumnWidths() As Integer()

Remarks

The size of the array is the number of columns.

The property returns null when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.EqualColumnWidth Property

Gets or sets a value indicating whether the columns on a page have all the same width and the same distance between them. If this property is set to true, the width of the columns are automatically calculated from the page size. The common distance can be specified with the SectionFormat.ColumnDistances property.

Introduced: 15.0.

Syntax

[C#]
public bool EqualColumnWidth { get; set; }
[Visual Basic]
Public Property EqualColumnWidth() As Boolean

Remarks

The property's default value is true.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.Landscape Property

Gets or sets a value indicating whether the section's page size is in landscape orientation.

Syntax

[C#]
public bool Landscape { get; set; }
[Visual Basic]
Public Property Landscape() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.PageBorder Property

Gets or sets the attributes of a section's page border. The property's value is an object of the type PageBorder.

Introduced: 17.0.

Syntax

[C#]
public PageBorder PageBorder { get; set; }
[Visual Basic]
Public Property PageBorder() As PageBorder

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.PageMargins Property

Gets or sets the section's page margins. The property's value is an object of the type PageMargins.

Syntax

[C#]
public PageMargins PageMargins { get; set; }
[Visual Basic]
Public Property PageMargins() As PageMargins

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.PageSize Property

Gets or sets the section's page size. The width and height are always the values in portrait orientation.

Syntax

[C#]
public System.Drawing.Size PageSize { get; set; }
[Visual Basic]
Public Property PageSize() As System.Drawing.Size

Remarks

The property returns a width and a height of zero when the text selection contains multiple sections with mixed sizes. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.SectionFormat.RestartPageNumbering Property

Gets or sets a value indicating whether page numbering is restarted at the section's beginning. The starting number is determined through the PageNumberField.StartNumber property.

Introduced: 19.0.

Syntax

[C#]
public bool RestartPageNumbering { get; set; }
[Visual Basic]
Public Property RestartPageNumbering() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple sections with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.Selection Class

The Selection class describes and handles the attributes of a text selection. Each of the properties of this class returns the property's default value if the selection does not contain a common value. In this case the IsCommonValueSelected method returns false.

Syntax

[C#]
public class Selection
[Visual Basic]
Public Class Selection

Constructors

Constructor | Description
Selection | Overloaded. Creates a new instance of the Selection class.

Properties

Property | Description
Baseline | Gets or sets the baseline alignment, in twips, of the selected text.
Bold | Gets or sets the bold attribute of the selected text.
Culture | Gets or sets the culture of the selected text.
FontName | Gets or sets the font of the selected text.
FontSize | Gets or sets the font's size, in twips, of the selected text.
ForeColor | Returns or sets the color used to display the selected text.
FormattingStyle | Gets or sets the formatting style of the selected text.
Italic | Gets or sets the italic attribute of the selected text.
Length | Returns or sets the number of characters selected.
ListFormat | Gets or sets a bulleted or numbered list and/or its formatting attributes for the selected text.
ParagraphFormat | Gets or sets the formatting attributes of the selected paragraphs.
SectionFormat | Gets or sets page settings such as margins, size and orientation for the selected text.
Start | Gets or sets the starting point of selected text.
Strikeout | Gets or sets the strikeout attribute of the selected text.
Text | Gets or sets a string containing the currently selected text.
TextBackColor | Gets or sets the background color for selected text.
Underline | Gets or sets underlining styles for the selected text.

Methods

Method | Description
ChangeDirection | Changes the writing direction of all selected paragraphs.
DecreaseIndent | Decreases the left indent of all paragraphs contained in the current text selection.
GrowFont | Increases the font size of each font contained in the current text selection.
IncreaseIndent | Increases the left indent of all paragraphs contained in the current text selection.
IsCommonValueSelected | Overloaded. Informs about whether a certain attribute has the same value for the complete selection.
Load | Overloaded. Exchanges the currently selected text with text in a certain format.
RemoveInlineStyles | Removes all character based styles of the selected text so that all attributes are reset to the attributes of the paragraph style.
Save | Overloaded. Saves the selected text of a document with the specified format.
ShrinkFont | Decreases the font size of each font contained in the current text selection.

Enumerations

Enumeration | Description
Attribute | Determines a certain attribute.
DialogResult | Specifies identifiers to indicate the return value of a dialog box.

Example

The following example shows how to select and format a piece of text.

[C#]
textControl1.Text = "TX Text Control";

TXTextControl.Selection mySel = new TXTextControl.Selection(3, 4);
mySel.Bold = true;
mySel.Italic = true;

textControl1.Selection = mySel;
[Visual Basic]
TextControl1.Text = "TX Text Control"

Dim mySel as TXTextControl.Selection = New TXTextControl.Selection(3, 4)
mySel.Bold = True
mySel.Italic = True

TextControl1.Selection = mySel

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection Constructor

Creates a new instance of the Selection class.

Selection()

Creates an empty Selection object with all properties set to their default values.

[C#]
public Selection();
[Visual Basic]
Public Sub New()

Selection(Int32, Int32)

Creates an instance of the Selection class with the specified start value and length. All other properties are set to their default values.

[C#]
public Selection(int start, int length);
[Visual Basic]
Public Sub New(ByVal start As Integer, ByVal length As Integer)
Parameter | Description
start | Specifies the selection's start position.
length | Specifies the number of selected characters.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Attribute Enumeration

Determines a certain attribute. This enumeration is used with the IsCommonValueSelected method.

Member | Description
Baseline | Specifies the attribute set through the Baseline property.
Bold | Specifies the attribute set through the Bold property.
FontName | Specifies the attribute set through the FontName property.
FontSize | Specifies the attribute set through the FontSize property.
ForeColor | Specifies the attribute set through the ForeColor property.
FormattingStyle | Specifies the attribute set through the FormattingStyle property.
Italic | Specifies the attribute set through the Italic property.
Strikeout | Specifies the attribute set through the Strikeout property.
TextBackColor | Specifies the attribute set through the TextBackColor property.
Underline | Specifies the attribute set through the Underline property.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Baseline Property

Gets or sets the baseline alignment, in twips, of the selected text. Positive values moves the baseline to superscript, negative values move the baseline to subscript.

Syntax

[C#]
public int Baseline { get; set; }
[Visual Basic]
Public Property Baseline() As Integer

Remarks

The property's default value is 0.

The property returns its default value when the text selection contains multiple characters with mixed baseline settings. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

The property's value must be between -960 twips and 960 twips (48 pt).

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Bold Property

Gets or sets the bold attribute of the selected text.

Syntax

[C#]
public bool Bold { get; set; }
[Visual Basic]
Public Property Bold() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple characters with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.ChangeDirection Method

Changes the writing direction of all selected paragraphs. When the direction of a paragraph is changed, this paragraph's alignment is toggled from left to right or from right to left. The alignment of centered and justified paragraphs is not changed. Left and right tabulators are also toggled.

Introduced: 20.0.

Syntax

[C#]
public bool ChangeDirection(Direction direction);
[Visual Basic]
Public Function ChangeDirection() As Direction
Parameter Description
direction

Specifies the writing direction. It can be one of the Direction values:

Value | Meaning
LeftToRight | The writing direction is left to right, which means that blocks of text with left to right and right to left characters are ordered from left to right.
RightToLeft | The writing direction is right to left, which means that blocks of text with left to right and right to left characters are ordered from right to left.

Return Value

The return value is true, if at least one paragraph has been changed. Otherwise is is false.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Culture Property

Gets or sets the culture of the selected text.

Introduced: 20.0.

Syntax

[C#]
public CultureInfo Culture { get; set; }
[Visual Basic]
Public Property Culture() As CultureInfo

Remarks

The property's default value is null, which means a neutral culture.

The property returns its default value when the text selection contains multiple characters with mixed culture settings. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.DecreaseIndent Method

Decreases the left indent of all paragraphs contained in the current text selection. If no text is selected, this method decreases the left indent at the text input position. Left indent positions are defined through the paragraphs' tab positions and the indents of the paragraphs in front and behind the paragraph with the text input position.

Introduced: 16.0.

Syntax

[C#]
public bool DecreaseIndent();
[Visual Basic]
Public Function DecreaseIndent() As Boolean

Return Value

The return value is true, if at least one indent could be changed. It is false, if the minimum value has been reached.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.DialogResult Enumeration

Specifies identifiers to indicate the return value of a dialog box.

Member | Description
Cancel | Specifies that the dialog box has been canceled.
None | Specifies that the dialog box has been left with the Escape key.
OK | Specifies that the dialog box has been left with OK.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.FontName Property

Gets or sets the font of the selected text.

Syntax

[C#]
public string FontName { get; set; }
[Visual Basic]
Public Property FontName() As String

Remarks

The property returns an empty string when the text selection contains multiple characters with mixed font names. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.FontSize Property

Gets or sets the font's size, in twips, of the selected text.

Syntax

[C#]
public int FontSize { get; set; }
[Visual Basic]
Public Property FontSize() As Integer

Remarks

The property's default value is 200 twips, which equals 10 point.

The property returns its default value when the text selection contains multiple characters with mixed font sizes. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.ForeColor Property

Returns or sets the color used to display the selected text.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor() As Color

Remarks

The property's default value is the system color for window text.

The property returns its default value when the text selection contains multiple characters with mixed colors. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.FormattingStyle Property

Gets or sets the formatting style of the selected text.

Introduced: 10.1.

Syntax

[C#]
public string FormattingStyle { get; set; }
[Visual Basic]
Public Property FormattingStyle() As String

Remarks

The property returns an empty string when the text selection contains multiple characters with different styles. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.GrowFont Method

Increases the font size of each font contained in the current text selection. If no text is selected, this method increases the font size at the text input position. The font sizes used with this method are the same as shown through the ButtonBar or the built-in font dialog.

Introduced: 16.0.

Syntax

[C#]
public bool GrowFont();
[Visual Basic]
Public Function GrowFont() As Boolean

Return Value

The return value is true, if at least one font size could be changed. It is false, if the maximum value has been reached.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.IncreaseIndent Method

Increases the left indent of all paragraphs contained in the current text selection. If no text is selected, this method increases the left indent at the text input position. left indent positions are defined through the paragraphs' tab positions and the indents of the paragraphs in front and behind the paragraph with the text input position.

Introduced: 16.0.

Syntax

[C#]
public bool IncreaseIndent();
[Visual Basic]
Public Function IncreaseIndent() As Boolean

Return Value

The return value is true, if at least one indent could be changed. It is false, if the maximum value has been reached.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.IsCommonValueSelected Method

Informs about whether a certain attribute has the same value for the complete selection.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the Selection.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(Selection.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As Selection.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the ParagraphFormat.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(ParagraphFormat.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As ParagraphFormat.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the ListFormat.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(ListFormat.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As ListFormat.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the SectionFormat.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(SectionFormat.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As SectionFormat.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the PageMargins.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(PageMargins.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As PageMargins.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the PageSize.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(PageSize.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As PageSize.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

IsCommonValueSelected(Attribute)

Informs about whether an attribute from the PageBorder.Attribute enumeration has the same value for the complete selection.

[C#]
public bool IsCommonValueSelected(PageBorder.Attribute attribute);
[Visual Basic]
Public Function IsCommonValueSelected(ByVal attribute As PageBorder.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the enumeration.

Return Value

The return value is true if the complete selection is formatted with the same value of the specified attribute. Otherwise it is false.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Italic Property

Gets or sets the italic attribute of the selected text.

Syntax

[C#]
public bool Italic { get; set; }
[Visual Basic]
Public Property Italic() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple characters with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Length Property

Returns or sets the number of characters selected. If this property is zero, no text is selected and the Start property determines the current text input position. To select parts of a table, the Table.Select, TableRow.Select, TableColumn.Select and TableCell.Select methods must be used.

Syntax

[C#]
public int Length { get; set; }
[Visual Basic]
Public Property Length() As Integer

Remarks

If the Start property is set to zero and the Length property is set to int.MaxValue all the text is selected.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.ListFormat Property

Gets or sets a bulleted or numbered list and/or its formatting attributes for the selected text. The property's value is an object of the type ListFormat.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Load Method

Exchanges the currently selected text with text in a certain format.

Load()

Opens a dialog box to select a file and exchanges the currently selected text with the text from that file.

[C#]
public DialogResult Load();
[Visual Basic]
Public Function Load() As DialogResult

Load(StreamType)

Opens a dialog box to select a file in the specified format and exchanges the currently selected text with the text from that file.

[C#]
public DialogResult Load(StreamType streamType);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Load(String, StreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file.

[C#]
public void Load(string path, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

Load(FileStream, StreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file stream.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

Load(Byte[], BinaryStreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified byte array.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

Load(String, StringStreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified string.

[C#]
public void Load(string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

Load(StreamType, LoadSettings)

Opens a dialog box to select a file in the specified format and exchanges the currently selected text with the text from that file using the specified special settings.

[C#]
public DialogResult Load(StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType, ByVal loadSettings As LoadSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StreamType, LoadSettings)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file and loaded using the given special settings.

[C#]
public void Load(string path, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(FileStream, StreamType, LoadSettings)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file stream and loaded using the given special settings.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(Byte[], BinaryStreamType, LoadSettings)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified byte array and loaded using the given special settings.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StringStreamType, LoadSettings)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified string and loaded using the given special settings.

[C#]
public void Load(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Return Value

The implementations which open a dialog box return a Selection.DialogResult value.

Remarks

The methods opening a dialog box are not available through the Selection object of a ServerTextControl.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.ParagraphFormat Property

Gets or sets the formatting attributes of the selected paragraphs. The property's value is an object of the type ParagraphFormat.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.RemoveInlineStyles Method

Removes all character based styles of the selected text so that all attributes are reset to the attributes of the paragraph style.

Introduced: 24.0.

Syntax

[C#]
public bool RemoveInlineStyles();
[Visual Basic]
Public Function RemoveInlineStyles() As Boolean

Return Value

The return value is true, if the operation was successful. Otherwise, it is false.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Save Method

Saves the selected text of a document with the specified format.

Save()

Opens a file save dialogbox and saves the selected text of a document in a file.

[C#]
public DialogResult Save();
[Visual Basic]
Public Function Save() As DialogResult

Save(StreamType)

Opens a file save dialogbox and saves the selected text of a document in a file with the specified format.

[C#]
public DialogResult Save(StreamType streamType);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Save(String, StreamType)

Saves the selected text of a document in the specified file with the specified format.

[C#]
public void Save(string path, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file into which the selection is saved. If the file does not exist, it is created. If the file exists, its contents are overwritten.
streamType | Specifies one of the StreamType values.

Save(FileStream, StreamType)

Saves the selected text of a document in the specified file stream with the specified format.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file into which the selection is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.

Save(Byte[], BinaryStreamType)

Saves the selected text of a document in the specified byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the selection is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the selected text of a document as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the selection is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(StreamType, SaveSettings)

Opens a file save dialogbox and saves the selected text of a document in a file with the specified format and special settings.

[C#]
public DialogResult Save(StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType, ByVal saveSettings As SaveSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StreamType, SaveSettings)

Saves the selected text of a document in the specified file using the specified format and special settings.

[C#]
public void Save(string path, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
path | Specifies a file into which the selection is saved. If the file does not exist, it is created. If the file exists, its contents are overwritten.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(FileStream, StreamType, SaveSettings)

Saves the selected text of a document in the specified file stream using the specified format and special settings.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
fileStream | Specifies a file into which the selection is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the selected text of a document in the specified byte array using the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the selection is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the selected text of a document as a string using the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the selection is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Return Value

The implementations which open a dialog box return a Selection.DialogResult value.

Remarks

The methods opening a dialog box are not available through the Selection object of a ServerTextControl.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.SectionFormat Property

Gets or sets page settings such as margins, size and orientation for the selected text. The property's value is an object of the type SectionFormat.

Introduced: 14.0.

Syntax

[C#]
public SectionFormat SectionFormat { get; set; }
[Visual Basic]
Public Property SectionFormat() As SectionFormat

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.ShrinkFont Method

Decreases the font size of each font contained in the current text selection. If no text is selected, this method decreases the font size at the text input position. The font sizes used with this method are the same as shown through the ButtonBar or the built-in font dialog.

Introduced: 16.0.

Syntax

[C#]
public bool ShrinkFont();
[Visual Basic]
Public Function ShrinkFont() As Boolean

Return Value

The return value is true, if at least one font size could be changed. It is false, if the minimum value has been reached.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Start Property

Gets or sets the starting point of selected text. The first possible position is 0. If the starting point of a selection is set to a new value, the selection's current length remains the same. To set a new starting point and a length simultaneously, use either the TextControl.Select method or create a new Selection object. To select parts of a table, use the Table.Select, TableRow.Select, TableColumn.Select and TableCell.Select methods.

Syntax

[C#]
public int Start { get; set; }
[Visual Basic]
Public Property Start() As Integer

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Strikeout Property

Gets or sets the strikeout attribute of the selected text.

Syntax

[C#]
public bool Strikeout { get; set; }
[Visual Basic]
Public Property Strikeout() As Boolean

Remarks

The property's default value is false.

The property returns its default value when the text selection contains multiple characters with mixed setting. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Text Property

Gets or sets a string containing the currently selected text.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.TextBackColor Property

Gets or sets the background color for selected text.

Syntax

[C#]
public Color TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor() As Color

Remarks

The property's default value is the system color for the window background.

The property returns its default value when the text selection contains multiple characters with mixed colors. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.Selection.Underline Property

Gets or sets underlining styles for the selected text.

Syntax

[C#]
public FontUnderlineStyle Underline { get; set; }
[Visual Basic]
Public Property Underline() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

Remarks

The property's default value is FontUnderlineStyle.None.

The property returns its default value when the text selection contains multiple characters with mixed styles. The Selection.IsCommonValueSelected method can be used to check for mixed attributes.

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.ServerTextControl Class

The ServerTextControl class implements a component that provide high-level text processing features for server-based applications. It is inherited from the System.ComponentModel.Component class. The following describes only the properties, methods and events defined through the ServerTextControl class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference. The ServerTextControl class implements the IFormattedText interface.

Introduced: 12.0.

Syntax

[C#]
public class ServerTextControl : Component, IFormattedText
[Visual Basic]
Public Class ServerTextControl
  Inherits Component
  Implements IFormattedText

Constructors

Constructor | Description
ServerTextControl | Initializes a new instance of the ServerTextControl class.

Properties

Property | Description
ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
BackColor | Gets or sets the background color of the control.
Barcodes | Gets a collection of all barcodes in a document.
Baseline | Gets or sets the baseline alignment, in twips, of the control.
Charts | Gets a collection of all charts in a document.
DocumentLinks | Gets a collection of all links that point to targets in the same document.
DocumentTargets | Gets a collection of all targets in the document.
Drawings | Gets a collection of all drawings in a document.
Font | Gets or sets the control's font.
FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
FontUnderlineStyle | Gets or sets underlining style for the text displayed by the control.
ForeColor | Gets or sets the foreground color of the control.
FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
Frames | Gets a collection of all images, textframes, charts and barcodes in a document.
GetPages | Gets a collection of all pages in the document.
HeadersAndFooters | Gets a collection of all headers and footers the current document contains.
HypertextLinks | Gets a collection of all hypertext links contained in the main text of the document.
Images | Gets a collection of all images contained in the main text of the document.
InlineStyles | Gets a collection of all inline styles the current document contains.
InputPosition | Gets or sets the current text input position.
IsCreated | Gets a value indicating whether the control is completely created.
IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
Lines | Gets a collection of all lines contained in the main text of the document.
ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.
MisspelledWords | Gets a collection of all misspelled words in the main text of the document.
PageMargins | Gets or sets the margins for the pages of the current document.
Pages | Gets the number of pages contained in the current document.
PageSize | Specifies the width and height of the pages for the current document.
PageUnit | Gets or sets the measure used for page sizes and page margins.
ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.
Paragraphs | Gets a collection of all paragraphs contained in the main text of the document.
ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
Sections | Gets a collection of all sections in the document.
Selection | Gets or sets the current selection in the main text of the document.
SpellChecker | Specifies the spell checking component to be used with a ServerTextControl.
SubTextParts | Gets a collection of all subtextparts contained in the document.
Tables | Gets a collection of all tables contained in the document.
Text | Gets or sets the control's text.
TextBackColor | Gets or sets the background color for the text.
TextChars | Gets a collection of all characters contained in the main text of the document.
TextFields | Gets a collection of all standard text fields contained in the main text of the document.
TextFrames | Gets a collection of all text frames the current document contains.
TextParts | Gets a collection of all text parts the current document contains.

Methods

Method | Description
Append | Overloaded. Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
Clear | Clears the selected text or the character right from the current input position.
Create | Initializes the resources of a newly instantiated object.
Find | Overloaded. Finds a text string in the main text of the document.
GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
GetTextFields | Returns a collection containing text fields of the specified types.
GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
GetXmlElements | Returns a collection of XML elements.
Load | Overloaded. Loads text in a certain format.
OnAdaptFont | Raises the AdaptFont event.
OnBarcodeCreated | Raises the BarcodeCreated event.
OnBarcodeDeleted | Raises the BarcodeDeleted event.
OnDocumentLoaded | Raises the DocumentLoaded event.
OnDrawingCreated | Raises the DrawingCreated event.
OnDrawingDeleted | Raises the DrawingDeleted event.
OnHyphenateWord | Raises the HyphenateWord event.
OnImageCreated | Raises the ImageCreated event.
OnImageDeleted | Raises the ImageDeleted event.
OnSpellCheckText | Raises the SpellCheckText event.
OnTableCreated | Raises the TableCreated event.
OnTableDeleted | Raises the TableDeleted event.
OnTextFrameCreated | Raises the TextFrameCreated event.
OnTextFrameDeleted | Raises the TextFrameDeleted event.
OnXmlInvalid | Raises the XmlInvalid event.
OnXmlNotWellFormed | Raises the XmlNotWellFormed event.
Print | Overloaded. Prints a Text Control document or a part of a document.
ResetBackColor | Resets the BackColor property to its default value.
ResetContents | Deletes the entire contents of the control.
ResetFont | Resets the Font property to its default value.
ResetForeColor | Resets the ForeColor property to its default value.
ResetPageMargins | Resets the PageMargins property to its default value.
ResetPageSize | Resets the PageSize property to its default value.
ResetTextBackColor | Resets the TextBackColor property to its default value.
Save | Overloaded. Saves the complete contents of a document with the specified format.
Select | Selects text within the control.
SelectAll | Selects all text in the control.

Events

Event | Description
AdaptFont | Occurs for each font that must be adapted, because it is not supported.
BarcodeCreated | Occurs when a new barcode has been created.
BarcodeDeleted | Occurs when a barcode has been deleted.
ChartCreated | Occurs when a new chart has been created.
ChartDeleted | Occurs when a chart has been deleted.
DocumentLoaded | Occurs when a new document has been loaded.
DrawingCreated | Occurs when a new drawing has been created.
DrawingDeleted | Occurs when a drawing has been deleted.
HyphenateWord | Occurs, if a word does not fit on the line and must be hyphenated.
ImageCreated | Occurs when a new image has been created.
ImageDeleted | Occurs when an image has been deleted.
SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
TableCreated | Occurs after a new table has been created when loading a document which contains a table without an identifier.
TableDeleted | Occurs after a table has been deleted.
TextFrameCreated | Occurs when a new text frame has been created.
TextFrameDeleted | Occurs when a text frame has been deleted.
XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.


TXTextControl.ServerTextControl Constructor

Initializes a new instance of the ServerTextControl class. After initialization the Create method must be called to enable further resources.

Syntax

[C#]
public ServerTextControl();
[Visual Basic]
Public Sub New()


TXTextControl.ServerTextControl.AdaptFont Event

Occurs for each font that must be adapted, because it is not supported. The event can occur if another printer is set with the ServerTextControl.FormattingPrinter property, if a document is loaded that contains a font which is not supported or if fonts have been restricted with the FontSettings.EmbeddableFontsOnly or the FontSettings.TrueTypeFontsOnly property. The event occurs only, if the FontSettings.AdaptFontEvent property has been set to true. The event handler receives an argument of type AdaptFontEventArgs containing data related to this event.

Introduced: 15.0.

Syntax

[C#]
public event AdaptFontEventHandler AdaptFont;
[Visual Basic]
Public Event AdaptFont As AdaptFontEventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.ApplicationFields Property

Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set, otherwise this collection is empty. The collection contains the fields contained in the main text of the document.

Introduced: 14.0.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ServerTextControl.Append Method

Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.

Introduced: 14.0.

Append(String, StreamType, AppendSettings)

Loads text with the specified format from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, AppendSettings)

Loads text with the specified format from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, AppendSettings)

Loads text with the specified format from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal appendSettings As AppendSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(String, StringStreamType, AppendSettings)

Loads text with the specified format from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(String, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, LoadSettings)

Loads text with the specified format and special settings from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Append(String, StringStreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings how the document is appended. It can be one of the AppendSettings values.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.BackColor Property

Gets or sets the background color of the control. The property value can be set to Color.Transparent to have a transparent background. A transparent background is only possible if the ViewMode property has been set to SimpleControl.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor() As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.BarcodeCreated Event

Occurs when a new barcode has been created. It occurs, when a file containing barcodes has been loaded. It does not occur, when a barcode has been added with the BarcodeCollection.Add method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeCreated;
[Visual Basic]
Public Event BarcodeCreated As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.ServerTextControl.BarcodeDeleted Event

Occurs when a barcode has been deleted. It occurs, when a barcode has been deleted with the BarcodeCollection.Remove method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeleted;
[Visual Basic]
Public Event BarcodeDeleted As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.ServerTextControl.Barcodes Property

Gets a collection of all barcodes in a document. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from a document.

Introduced: 19.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.ServerTextControl.Baseline Property

Gets or sets the baseline alignment, in twips, of the control. Positive values moves the baseline to superscript, negative values moves the baseline to subscript.

Syntax

[C#]
public int Baseline { get; set; }
[Visual Basic]
Public Property Baseline() As Integer

Limitations

The property's value must be between -960 twips and 960 twips (48 pt).

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.ChartCreated Event

Occurs when a new chart has been created. It occurs, when a file containing charts has been loaded. It does not occur, when a chart has been added with the ChartCollection.Add method. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartCreated;
[Visual Basic]
Public Event ChartCreated As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.ServerTextControl.ChartDeleted Event

Occurs when a chart has been deleted. It occurs, when a chart has been deleted with the ChartCollection.Remove method. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartDeleted;
[Visual Basic]
Public Event ChartDeleted As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.ServerTextControl.Charts Property

Gets a collection of all charts in a document. The property value is an object of the type DataVisualization.ChartCollection. The collection can be used to get or to alter a chart's attributes and to add charts to or to remove charts from a document.

Introduced: 18.0.

Syntax

[C#]
public DataVisualization.ChartCollection Charts { get; }
[Visual Basic]
Public ReadOnly Property Charts() As DataVisualization.ChartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.ServerTextControl.Clear Method

Clears the selected text or the character right from the current input position.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.Create Method

Initializes the resources of a newly instantiated object. This method must be called before using the object.

Syntax

[C#]
public bool Create();
[Visual Basic]
Public Function Create() As Boolean

Return Value

The return value is true, if the object could be initialized. Otherwise, it is false.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.DocumentLinks Property

Gets a collection of all links that point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.ServerTextControl.DocumentLoaded Event

Occurs when a new document has been loaded. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event EventHandler DocumentLoaded;
[Visual Basic]
Public Event DocumentLoaded As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.DocumentTargets Property

Gets a collection of all targets in the document. The property value is an object of the type DocumentTargetCollection.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.ServerTextControl.DrawingCreated Event

Occurs when a new drawing has been created. It occurs, when a drawing has been inserted in the document via the clipboard and when a file containing drawings has been loaded. It does not occur, when a drawing has been added with the DrawingCollection.Add method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingCreated;
[Visual Basic]
Public Event DrawingCreated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerTextControl.DrawingDeleted Event

Occurs when a drawing has been deleted. It occurs, when a drawing has been deleted while editing a document and when a drawing has been deleted with the DrawingCollection.Remove method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeleted;
[Visual Basic]
Public Event DrawingDeleted As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerTextControl.Drawings Property

Gets a collection of all drawings in a document. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from a document.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerTextControl.Find Method

Finds a text string in the main text of the document.

Find(String)

Finds the specified text string in the main text of the document. The search starts at the beginning of the document.

[C#]
public int Find(string text);
[Visual Basic]
Public Function Find(ByVal text As String) As Integer
Parameter | Description
text | Specifies the text to search for.

Find(String, Int32, FindOptions)

Finds the specified text string in the main text of the document using the specified find options. The search starts at the specified position.

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Programming Category: Search and Replace
  • Graphical Overview: Search and Replace


TXTextControl.ServerTextControl.Font Property

Gets or sets the control's font.

Syntax

[C#]
public Font Font { get; set; }
[Visual Basic]
Public Property Font() As Font

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.FontSettings Property

Gets a FontSettings object which provides properties determining which fonts can be used in a document.

Introduced: 15.0.

Syntax

[C#]
public FontSettings FontSettings { get; }
[Visual Basic]
Public ReadOnly Property FontSettings() As FontSettings

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.FontUnderlineStyle Property

Gets or sets underlining style for the text displayed by the control. This property only determines the style. The ServerTextControl.Font property determines whether text is underlined or not.

Syntax

[C#]
public FontUnderlineStyle FontUnderlineStyle { get; set; }
[Visual Basic]
Public Property FontUnderlineStyle() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.ForeColor Property

Gets or sets the foreground color of the control.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor() As Color

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.FormattingPrinter Property

Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document. If the document is printed with this printer the displayed and the printed document have the same dimensions. If the property is set to Standard, the system installed standard printer is used to format the document. If the property is set to Display, the font dimensions of the display device are used to format the document. If the specified printer is not installed, the standard printer is used.

Introduced: 14.0.

Syntax

[C#]
public string FormattingPrinter { get; set; }
[Visual Basic]
Public Property FormattingPrinter() As String

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.Frames Property

Gets a collection of all images, textframes, charts and barcodes in a document. The property value is an object of the type FrameCollection. The collection can be used to get or to alter common attributes.

Introduced: 18.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.ServerTextControl.GetPages Method

Gets a collection of all pages in the document. The property's value is an object of the type PageCollection.

Introduced: 14.0.

Syntax

[C#]
public PageCollection GetPages();
[Visual Basic]
Public Function GetPages() As PageCollection

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.GetSupportedFonts Method

Gets an array of strings specifying the names of all currently supported fonts. These fonts depend on the formatting device set with the ServerTextControl.FormattingPrinter property. The method returns null if the ServerTextControl has not been completely initialized.

Introduced: 15.1.

Syntax

[C#]
public string[] GetSupportedFonts();
[Visual Basic]
Public Function GetSupportedFonts() As String()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.GetSupportedPaperSizes Method

Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes. These paper sizes depend on the formatting device set with the ServerTextControl.FormattingPrinter property. The method returns null, if the ServerTextControl has not been completely initialized.

Introduced: 24.0.

Syntax

[C#]
public PaperSize[] GetSupportedPaperSizes();
[Visual Basic]
Public Function GetSupportedPaperSizes() As PaperSize()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ServerTextControl.GetXmlElements Method

Returns a collection of XML elements. It is an object of the type XmlElementCollection.

Syntax

[C#]
public XmlElementCollection GetXmlElements(string elementName);
[Visual Basic]
Public Function GetXmlElements(ByVal elementName As String) As XmlElementCollection
Parameter | Description
elementName | Specifies the XML element's name.

Return Value

The return value is a collection containing all XML elements of the specified name.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.ServerTextControl.GetVersionInfo Method

Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.

Introduced: 21.0.

Syntax

[C#]
public VersionInfo GetVersionInfo();
[Visual Basic]
Public Sub GetVersionInfo() As VersionInfo

Return Value

The return value is a VersionInfo object.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.HeadersAndFooters Property

Gets a collection of all headers and footers the current document contains. The property's value is an object of the type HeaderFooterCollection.

Syntax

[C#]
public HeaderFooterCollection HeadersAndFooters { get; }
[Visual Basic]
Public ReadOnly Property HeadersAndFooters() As HeaderFooterCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.ServerTextControl.HypertextLinks Property

Gets a collection of all hypertext links contained in the main text of the document. The property's value is an object of the type HypertextLinkCollection.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.ServerTextControl.HyphenateWord Event

Occurs, if a word does not fit on the line and must be hyphenated. This event occurs only, if the IsHyphenationEnabled property has been set to true. The event handler receives an argument of type HyphenateWordEventArgs containing data related to this event.

Introduced: 20.0.

Syntax

[C#]
public event HyphenateWordEventHandler HyphenateWord;
[Visual Basic]
Public Event HyphenateWord As HyphenateWordEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.ImageCreated Event

Occurs when a new image has been created. It occurs if a file containing images has been loaded. It does not occur if an image has been added with the ImageCollection.Add method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageCreated;
[Visual Basic]
Public Event ImageCreated As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ServerTextControl.ImageDeleted Event

Occurs when an image has been deleted. It occurs if an image has been deleted while removing parts of a document or if an image has been deleted with the ImageCollection.Remove method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDeleted;
[Visual Basic]
Public Event ImageDeleted As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ServerTextControl.Images Property

Gets a collection of all images contained in the main text of the document. The property's value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ServerTextControl.InlineStyles Property

Gets a collection of all inline styles the current document contains. The property's value is an object of the type InlineStyleCollection.

Syntax

[C#]
public InlineStyleCollection InlineStyles { get; }
[Visual Basic]
Public ReadOnly Property InlineStyles() As InlineStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ServerTextControl.InputPosition Property

Gets or sets the current text input position. The property's value is an object of the type InputPosition.

Syntax

[C#]
public InputPosition InputPosition { get; set; }
[Visual Basic]
Public Property InputPosition() As InputPosition

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.ServerTextControl.IsHyphenationEnabled Property

Gets or sets a value indicating whether hyphenation is active or not. If hyphenation is enabled, a word at the end of a line is automatically divided with a connected spell checking component. A spell checking component can be connected with the SpellChecker property. Additionally, the ServerTextControl.HyphenateWord event is raised with the calculated divide position. This position can be changed through a connected event handler.

Introduced: 20.0.

Syntax

[C#]
public bool IsHyphenationEnabled { get; set; }
[Visual Basic]
Public Property IsHyphenationEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.IsLanguageDetectionEnabled Property

Gets or sets a value indicating whether language detection is active or not. If language detection is enabled, a language is automatically set for all pieces of text with a neutral language. To use this feature, at least the TXSpell 5.0 spell checking component must be connected with the ServerTextControl through the SpellChecker property.

Introduced: 21.0.

Syntax

[C#]
public bool IsLanguageDetectionEnabled { get; set; }
[Visual Basic]
Public Property IsLanguageDetectionEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.IsSpellCheckingEnabled Property

Gets or sets a value indicating whether spell checking is active or not. If spell checking is enabled either the text is automatically checked with a connected spell checking component or the ServerTextControl.SpellCheckText event is raised when the text of a document changes. The event handler can then be used to check the text on misspelled words. A spell checking component can be connected with the SpellChecker property.

Introduced: 16.0.

Syntax

[C#]
public bool IsSpellCheckingEnabled { get; set; }
[Visual Basic]
Public Property IsSpellCheckingEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.IsCreated Property

Gets a value indicating whether the control is completely created.

Introduced: 18.0.

Syntax

[C#]
public bool IsCreated { get; }
[Visual Basic]
Public ReadOnly Property IsCreated() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.Landscape Property

Gets or sets a value indicating whether the page orientation is landscape or portrait.

Introduced: 14.0.

Syntax

[C#]
public bool Landscape { get; set; }
[Visual Basic]
Public Property Landscape() As Boolean

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.Lines Property

Gets a collection of all lines contained in the main text of the document. The property value is an object of the type LineCollection.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.ServerTextControl.ListFormat Property

Gets or sets the type and the formatting attributes of a bulleted or numbered list. The property value is an object of the type ListFormat. For more information see the description of the ListFormat class.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.ServerTextControl.Load Method

Loads text in a certain format. The complete contents of a Text Control are replaced.

Load(String, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file.

[C#]
public void Load(string path, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

Load(FileStream, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file stream.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

Load(Byte[], BinaryStreamType)

Loads text formatted with the specified format. The new text is read from the specified byte array.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

Load(String, StringStreamType)

Loads text formatted with the specified format. The new text is read from the specified string.

[C#]
public void Load(string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

Load(String, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file and loaded using the given special settings.

[C#]
public void Load(string path, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(FileStream, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file stream and loaded using the given special settings.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(Byte[], BinaryStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified byte array and loaded using the given special settings.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StringStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified string and loaded using the given special settings.

[C#]
public void Load(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.MisspelledWords Property

Gets a collection of all misspelled words in the main text of the document. Lists of misspelled words of a header or footer or of a text frame are provided through the HeaderFooter.MisspelledWords and TextFrame.MisspelledWords properties. The property value is an object of the type MisspelledWordCollection.

Introduced: 16.0.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.OnAdaptFont Method

Raises the AdaptFont event.

Introduced: 15.0.

Syntax

[C#]
protected virtual void OnAdaptFont(AdaptFontEventArgs e);
[Visual Basic]
Protected Overridable Sub OnAdaptFont(ByVal e As AdaptFontEventArgs)
Parameter | Description
e | Specifies an AdaptFontEventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.OnBarcodeCreated Method

Raises the BarcodeCreated event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeCreated(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeCreated(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.ServerTextControl.OnBarcodeDeleted Method

Raises the BarcodeDeleted event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDeleted(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeleted(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.ServerTextControl.OnDocumentLoaded Method

Raises the DocumentLoaded event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnDocumentLoaded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLoaded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.OnDrawingCreated Method

Raises the DrawingCreated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingCreated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingCreated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerTextControl.OnDrawingDeleted Method

Raises the DrawingDeleted event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeleted(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeleted(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerTextControl.OnHyphenateWord Method

Raises the HyphenateWord event.

Introduced: 20.0.

Syntax

[C#]
protected virtual void OnHyphenateWord(HyphenateWordEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHyphenateWord(ByVal e As HyphenateWordEventArgs)
Parameter | Description
e | Specifies an HyphenateWordEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.OnImageCreated Method

Raises the ImageCreated event.

Syntax

[C#]
protected virtual void OnImageCreated(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageCreated(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ServerTextControl.OnImageDeleted Method

Raises the ImageDeleted event.

Syntax

[C#]
protected virtual void OnImageDeleted(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeleted(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.ServerTextControl.OnSpellCheckText Method

Raises the SpellCheckText event.

Introduced: 16.0.

Syntax

[C#]
protected virtual void OnSpellCheckText(SpellCheckTextEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSpellCheckText(ByVal e As SpellCheckTextEventArgs)
Parameter | Description
e | Specifies an SpellCheckTextEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.OnTableCreated Method

Raises the TableCreated event.

Syntax

[C#]
protected virtual void OnTableCreated(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableCreated(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.ServerTextControl.OnTableDeleted Method

Raises the TableDeleted event.

Syntax

[C#]
protected virtual void OnTableDeleted(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableDeleted(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.ServerTextControl.OnTextFrameCreated Method

Raises the TextFrameCreated event.

Syntax

[C#]
protected virtual void OnTextFrameCreated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameCreated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.ServerTextControl.OnTextFrameDeleted Method

Raises the TextFrameDeleted event.

Syntax

[C#]
protected virtual void OnTextFrameDeleted(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeleted(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.ServerTextControl.OnXmlInvalid Method

Raises the XmlInvalid event.

Syntax

[C#]
protected virtual void OnXmlInvalid(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlInvalid(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.ServerTextControl.OnXmlNotWellFormed Method

Raises the XmlNotWellFormed event.

Syntax

[C#]
protected virtual void OnXmlNotWellFormed(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlNotWellFormed(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.ServerTextControl.PageMargins Property

Gets or sets the margins for the pages of the current document. The measure depends on the ServerTextControl.PageUnit property. The default measure is 1/100th inch. The property value is an object of the type PageMargins. For more information see the description of the PageMargins class.

Syntax

[C#]
public PageMargins PageMargins { get; set; }
[Visual Basic]
Public Property PageMargins() As PageMargins

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.Pages Property

Gets the number of pages contained in the current document.

Syntax

[C#]
public int Pages { get; }
[Visual Basic]
Public ReadOnly Property Pages() As Integer

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.PageSize Property

Specifies the width and height of the pages for the current document. The measure depends on the ServerTextControl.PageUnit property. The default measure is 1/100th inch. The property value is an object of the type PageSize. For more information see the description of the PageSize class.

Syntax

[C#]
public System.Drawing.Size PageSize { get; set; }
[Visual Basic]
Public Property PageSize() As System.Drawing.Size

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.PageUnit Property

Gets or sets the measure used for page sizes and page margins.

Introduced: 16.0.

Syntax

[C#]
public PageUnit PageUnit { get; set; }
[Visual Basic]
Public Property PageUnit() As PageUnit
Value | Description
Millimeter | The measure for page sizes and page margins is millimeter.
CentiInch | The measure for page sizes and page margins is 1/100th inch.
StandardWPF | The measure for page sizes and page margins is 1/96th inch.
Twips | The measure for page sizes and page margins is Twips (1/1440th inch). This is the internally used TXTextControl measure.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.ParagraphFormat Property

Gets or sets the paragraph formatting attributes of the text displayed by the control. The property value is an object of the type ParagraphFormat. For more information see the description of the ParagraphFormat class.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.ServerTextControl.Paragraphs Property

Gets a collection of all paragraphs contained in the main text of the document. The property value is an object of the type ParagraphCollection.

Introduced: 15.0.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.ServerTextControl.ParagraphStyles Property

Gets a collection of all paragraph styles the current document contains. The property's value is an object of the type ParagraphStyleCollection.

Syntax

[C#]
public ParagraphStyleCollection ParagraphStyles { get; }
[Visual Basic]
Public ReadOnly Property ParagraphStyles() As ParagraphStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.ServerTextControl.Print Method

Prints a Text Control document or a part of a document.

Print(PrintDocument)

Prints the document using the printer settings of the specified PrintDocument.

[C#]
public void Print(System.Drawing.Printing.PrintDocument printDocument);
[Visual Basic]
Public Sub Print(ByVal printDocument As System.Drawing.Printing.PrintDocument)
Member Description
printDocument

Specifies an instance of the PrintDocument class. The following settings of the PrintDocument object are used:

Setting | Meaning
DocumentName | Specifies the document's name.
PrintController | Specifies the document's print controller.
PrinterSettings.FromPage | The first page to print.
PrinterSettings.ToPage | The last page to print.
PrinterSettings.Copies | The number of copies to print.
PrinterSettings.Collate | Specifies how the printed pages are sorted.
PrinterSettings.PrinterName | Specifies the name of the printer.
PrinterSettings.PrintToFile | Specifies whether the printed pages are saved in a file.
PrinterSettings.PrintRange | Specifies the range of pages to print.
DefaultPageSettings.Color | Specifies whether the printed pages are printed colored.

Print(Int32, PrintPageEventArgs)

Prints a single page. This method can be called from the PrintPage event handler.

[C#]
public void Print(int page, System.Drawing.Printing.PrintPageEventArgs ppe);
[Visual Basic]
Public Sub Print(ByVal page As Integer, ByVal ppe As System.Drawing.Printing.PrintPageEventArgs)
Member | Description
page | Specifies a page number to print.
ppe | Specifies the event arguments of the print document's PrintPage event.

See Also

  • Printing into a PrintDocument
  • Printing without the Status Dialog
  • Programming Category: Printing and Print Preview
  • Graphical Overview: Printing and Print Preview


TXTextControl.ServerTextControl.ResetBackColor Method

Resets the BackColor property to its default value. The default value is the system color for the window background.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.ServerTextControl.ResetContents Method

Deletes the entire contents of the control.

Syntax

[C#]
public void ResetContents();
[Visual Basic]
Public Sub ResetContents()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.ResetFont Method

Resets the Font property to its default value. The default value is 10 pt Arial.

Syntax

[C#]
public void ResetFont();
[Visual Basic]
Public Sub ResetFont()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.ResetForeColor Method

Resets the ForeColor property to its default value. The default value is the system color for the window text.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.ResetPageMargins Method

Resets the PageMargins property to its default value. The default page margins are 1 inch.

Syntax

[C#]
public void ResetPageMargins();
[Visual Basic]
Public Sub ResetPageMargins()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.ResetPageSize Method

Resets the PageSize property to its default value. The default page size is US letter (8,5 x 11 inch).

Syntax

[C#]
public void ResetPageSize();
[Visual Basic]
Public Sub ResetPageSize()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.ResetTextBackColor Method

Resets the TextBackColor property to its default value. The default value is the setting of the BackColor property.

Syntax

[C#]
public void ResetTextBackColor();
[Visual Basic]
Public Sub ResetTextBackColor()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.Save Method

Saves the complete contents of a document with the specified format.

Save(String, StreamType)

Saves the complete contents of a document in the specified file with the specified format.

[C#]
public void Save(string path, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.

Save(FileStream, StreamType)

Saves the complete contents of a document in the specified file stream with the specified format.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.

Save(Byte[], BinaryStreamType)

Saves the complete contents of a document in the specified byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the complete contents of a document as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(String, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file using the specified format and special settings.

[C#]
public void Save(string path, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(FileStream, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file stream using the specified format and special settings.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the complete contents of a document in the specified byte array using the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the complete contents of a document as a string using the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.Sections Property

Gets a collection of all sections in the document. The property's value is an object of the type SectionCollection.

Introduced: 14.0.

Syntax

[C#]
public SectionCollection Sections { get; }
[Visual Basic]
Public ReadOnly Property Sections() As SectionCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.ServerTextControl.Select Method

Selects text within the control.

Syntax

[C#]
public void Select(int start, int length);
[Visual Basic]
Public Sub Select(ByVal start As Integer, ByVal length As Integer)
Parameter | Description
start | Specifies the selection's start position.
length | Specifies the number of selected characters.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.ServerTextControl.SelectAll Method

Selects all text in the control.

Syntax

[C#]
public void SelectAll();
[Visual Basic]
Public Sub SelectAll()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.ServerTextControl.Selection Property

Gets or sets the current selection in the main text of the document. The property value is an object of the type Selection. A selection can be used to assign character and paragraph formatting attributes to a piece of text.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.ServerTextControl.SpellChecker Property

Specifies the spell checking component to be used with a ServerTextControl. The property value is null if there is no spell checking component connected. Otherwise it must be an object of the type TXSpell. When a spell checking component is connected and the IsSpellCheckingEnabled property has been set to true, the MisspelledWords collection is automatically filled with all misspelled words contained in the current document. When a spell checking component is connected and the IsHyphenationEnabled property has been set to true, a document is automatically hyphenated. If the IsLanguageDetectionEnabled property has been set to true, a language is automatically detected for all text parts with a neutral language.

Introduced: 17.0.

Syntax

[C#]
public Component SpellChecker { get; set; }
[Visual Basic]
Public Property SpellChecker() As Component

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.SpellCheckText Event

Occurs, if the document's text has been altered and the spelling of the new text must be checked. This event occurs only, if the SpellChecker property has been set to null and if the IsSpellCheckingEnabled property has been set to true. If a spell checking component has been connected with the ServerTextControl, this event is handled internally. The event handler receives an argument of type SpellCheckTextEventArgs containing data related to this event.

Introduced: 16.0.

Syntax

[C#]
public event SpellCheckTextEventHandler SpellCheckText;
[Visual Basic]
Public Event SpellCheckText As SpellCheckTextEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.ServerTextControl.TableCreated Event

Occurs after a new table has been created when loading a document which contains a table without an identifier. It does not occur when the table is inserted with the TableInsert method or for tables that have a previously set identifier when loading a document. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableCreated;
[Visual Basic]
Public Event TableCreated As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.ServerTextControl.TableDeleted Event

Occurs after a table has been deleted. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableDeleted;
[Visual Basic]
Public Event TableDeleted As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.ServerTextControl.SubTextParts Property

Gets a collection of all subtextparts contained in the document. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.ServerTextControl.Tables Property

Gets a collection of all tables contained in the document. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Runtime only.

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.ServerTextControl.Text Property

Gets or sets the control's text.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.ServerTextControl.TextBackColor Property

Gets or sets the background color for the text.

Syntax

[C#]
public Color TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor() As Color

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.ServerTextControl.TextChars Property

Gets a collection of all characters contained in the main text of the document. The property value is an object of the type TextCharCollection.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.ServerTextControl.TextFields Property

Gets a collection of all standard text fields contained in the main text of the document. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.ServerTextControl.TextFrameCreated Event

Occurs when a new text frame has been created. It occurs for each text frame if a file containing text frames has been loaded. It does not occur if an text frame has been added with the TextFrameCollection.Add method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameCreated;
[Visual Basic]
Public Event TextFrameCreated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.ServerTextControl.TextFrameDeleted Event

Occurs when a text frame has been deleted. It occurs if a text frame has been deleted while changing a document or if an text frame has been deleted with the TextFrameCollection.Remove method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeleted;
[Visual Basic]
Public Event TextFrameDeleted As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.ServerTextControl.TextFrames Property

Gets a collection of all text frames the current document contains. The property's value is an object of the type TextFrameCollection. If a text frame contains further text frames, the inner frames are not contained in this collection.

Syntax

[C#]
public TextFrameCollection TextFrames { get; }
[Visual Basic]
Public ReadOnly Property TextFrames() As TextFrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.ServerTextControl.TextParts Property

Gets a collection of all text parts the current document contains. The property's value is an object of the type TextPartCollection. A text part can be the main text, a text frame or a header or footer.

Introduced: 16.0.

Syntax

[C#]
public TextPartCollection TextParts { get; }
[Visual Basic]
Public ReadOnly Property TextParts() As TextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.ServerTextControl.XmlInvalid Event

Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.ServerTextControl.XmlNotWellFormed Event

Occurs when a loaded XML document is not well-formed. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.SpellCheckTextEventArgs Class

The SpellCheckTextEventArgs class provides data for the TextControl.SpellCheckText and WPF.TextControl.SpellCheckText events.

Introduced: 16.0.

Syntax

[C#]
public class SpellCheckTextEventArgs: EventArgs
[Visual Basic]
Public Class SpellCheckTextEventArgs
  Inherits EventArgs

Properties

Property | Description
Culture | Gets the culture of the text to check.
MisspelledWords | Gets or sets an array of MisspelledWord objects.
Text | Gets the text to check.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.SpellCheckTextEventArgs.Culture Property

Gets the culture of the text to check.

Introduced: 20.0.

Syntax

[C#]
public System.Globalization.CultureInfo Culture { get; }
[Visual Basic]
Public ReadOnly Property Culture As System.Globalization.CultureInfo

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.SpellCheckTextEventArgs.MisspelledWords Property

Gets or sets an array of MisspelledWord objects. After checking the text which can be obtained with the SpellCheckTextEventArgs.Text property, this property must be set to inform the TextControl about the starting position and length of all misspelled words the text contains.

Syntax

[C#]
public MisspelledWord[] MisspelledWords { get; set; }
[Visual Basic]
Public Property MisspelledWords() As MisspelledWord()

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.SpellCheckTextEventArgs.Text Property

Gets the text to check. After checking the text, the SpellCheckTextEventArgs.MisspelledWords property must be set to inform the TextControl about the starting and ending positions of all misspelled words this text contains.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.StatusBar Class

The StatusBar class represents a Windows Forms tool bar which can be used to show the position of the curent text input position and other status information of a Windows Forms TextControl. It is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the StatusBar class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Syntax

[C#]
public class StatusBar : Control
[Visual Basic]
Public Class StatusBar
  Inherits Control

Properties

Property | Description
BorderStyle | Gets or sets the border style of the status bar.
ColumnText | Gets or sets the text in the 'Column' area of the status bar.
DisplayColors | Gets or sets the colors of the status bar.
LineText | Gets or sets the text in the 'Line' area of the status bar.
PageCounterText | Gets or sets the text in the 'Page counter' area of the status bar.
PageText | Gets or sets the text in the 'Page' area of the status bar.
SectionCounterText | Gets or sets the text in the 'Section counter' area of the status bar.
SectionText | Gets or sets the text in the 'Section' area of the status bar.
ShowColumn | Specifies whether the status bar shows the column number of the current text input position.
ShowKeyStates | Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.
ShowLanguage | Specifies whether the status bar shows the language of the text selection or the text input position.
ShowLine | Specifies whether the status bar shows the line number of the current text input position.
ShowPage | Specifies whether the status bar shows the page number of the current text input position.
ShowPageCounter | Specifies whether the status bar shows the number of pages the document consists of.
ShowSection | Specifies whether the status bar shows the section number of the current text input position.
ShowSectionCounter | Specifies whether the status bar shows the number of sections the document consists of.
ShowZoom | Specifies whether the status bar shows the current zoom factor.
ShowZoomTrackBar | Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.

Methods

Method | Description
ResetDisplayColors | Resets all display colors of a status bar to their system dependent default values.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.BorderStyle Property

Gets or sets the border style of the status bar.

Introduced: 11.0.

Syntax

[C#]
public StatusBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle() As StatusBarBorderStyle
Value | Description
ColorScheme | The status bar has a flat design without a border and with a horizontal color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The status bar has a flat design and no border.
FixedSingle | The status bar has a flat design and a border with a single line.
Simple3D | The status bar has a 3D design and no border.
Fixed3D | The status bar has a 3D design and a border with a single line.
VerticalColorScheme | The status bar has a flat design without a border and with a vertical color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ColumnText Property

Gets or sets the text in the 'Column' area of the status bar.

Syntax

[C#]
public string ColumnText { get; set; }
[Visual Basic]
Public Property ColumnText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.DisplayColors Property

Gets or sets the colors of the status bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type StatusBar.Colors.

Introduced: 15.1.

Syntax

[C#]
public StatusBar.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As StatusBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.LineText Property

Gets or sets the text in the 'Line' area of the status bar.

Syntax

[C#]
public string LineText { get; set; }
[Visual Basic]
Public Property LineText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.PageCounterText Property

Gets or sets the text in the 'Page counter' area of the status bar.

Introduced: 14.0.

Syntax

[C#]
public string PageCounterText { get; set; }
[Visual Basic]
Public Property PageCounterText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.PageText Property

Gets or sets the text in the 'Page' area of the status bar.

Syntax

[C#]
public string PageText { get; set; }
[Visual Basic]
Public Property PageText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ResetDisplayColors Method

Resets all display colors of a status bar to their system dependent default values.

Introduced: 15.1.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.SectionCounterText Property

Gets or sets the text in the 'Section counter' area of the status bar.

Introduced: 14.0.

Syntax

[C#]
public string SectionCounterText { get; set; }
[Visual Basic]
Public Property SectionCounterText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.SectionText Property

Gets or sets the text in the 'Section' area of the status bar.

Introduced: 14.0.

Syntax

[C#]
public string SectionText { get; set; }
[Visual Basic]
Public Property SectionText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowColumn Property

Specifies whether the status bar shows the column number of the current text input position.

Introduced: 14.0.

Syntax

[C#]
public bool ShowColumn { get; set; }
[Visual Basic]
Public Property ShowColumn() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowKeyStates Property

Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.

Introduced: 14.0.

Syntax

[C#]
public bool ShowKeyStates { get; set; }
[Visual Basic]
Public Property ShowKeyStates() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowLanguage Property

Specifies whether the status bar shows the language of the text selection or the text input position.

Introduced: 20.0.

Syntax

[C#]
public bool ShowLanguage { get; set; }
[Visual Basic]
Public Property ShowLanguage() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowLine Property

Specifies whether the status bar shows the line number of the current text input position.

Introduced: 14.0.

Syntax

[C#]
public bool ShowLine { get; set; }
[Visual Basic]
Public Property ShowLine() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowPage Property

Specifies whether the status bar shows the page number of the current text input position.

Introduced: 14.0.

Syntax

[C#]
public bool ShowPage { get; set; }
[Visual Basic]
Public Property ShowPage() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowPageCounter Property

Specifies whether the status bar shows the number of pages the document consists of.

Introduced: 14.0.

Syntax

[C#]
public bool ShowPageCounter { get; set; }
[Visual Basic]
Public Property ShowPageCounter() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowSection Property

Specifies whether the status bar shows the section number of the current text input position.

Introduced: 14.0.

Syntax

[C#]
public bool ShowSection { get; set; }
[Visual Basic]
Public Property ShowSection() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowSectionCounter Property

Specifies whether the status bar shows the number of sections the document consists of.

Introduced: 14.0.

Syntax

[C#]
public bool ShowSectionCounter { get; set; }
[Visual Basic]
Public Property ShowSectionCounter() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowZoom Property

Specifies whether the status bar shows the current zoom factor.

Introduced: 14.0.

Syntax

[C#]
public bool ShowZoom { get; set; }
[Visual Basic]
Public Property ShowZoom() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.ShowZoomTrackBar Property

Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.

Introduced: 18.0.

Syntax

[C#]
public bool ShowZoomTrackBar { get; set; }
[Visual Basic]
Public Property ShowZoomTrackBar() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors Class

The StatusBar.Colors class gets, sets or resets the display colors of a Windows Forms StatusBar control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the status bar's BorderStyle property has been set to ColorScheme.

Introduced: 15.1.

Syntax

[C#]
public class StatusBar.Colors
[Visual Basic]
Public Class StatusBar.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the StatusBar.Colors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left edge of the status bar.
BackColorBottom | Gets or sets the background color at the bottom of the status bar.
BackColorMiddle | Gets or sets the background color in the middle of the status bar.
BackColorTop | Gets or sets the background color at the top of the status bar.
ForeColor | Gets or sets the color used for text and numbers.
FrameColor | Gets or sets the color of the status bar's frames.
GradientBackColor | Gets or sets the background color at the right edge of the status bar.
SeparatorColorDark | Gets or sets the color of the dark part of a separator.
SeparatorColorLight | Gets or sets the color of the light part of a separator.

Methods

Method | Description
ResetBackColor | Resets the status bar's BackColor to its system dependent default value.
ResetBackColorBottom | Resets the status bar's BackColorBottom to its system dependent default value.
ResetBackColorMiddle | Resets the status bar's BackColorMiddle to its system dependent default value.
ResetBackColorTop | Resets the status bar's BackColorTop to its system dependent default value.
ResetForeColor | Resets the status bar's ForeColor to its system dependent default value.
ResetFrameColor | Resets the status bar's FrameColor to its system dependent default value.
ResetGradientBackColor | Resets the status bar's GradientBackColor to its system dependent default value.
ResetSeparatorColorDark | Resets the status bar's SeparatorColorDark to its system dependent default value.
ResetSeparatorColorLight | Resets the status bar's SeparatorColorLight to its system dependent default value.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors Constructor

Initializes a new instance of the StatusBar.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the StatusBar.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public StatusBar.Colors();
[Visual Basic]
Public Class StatusBar.Colors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.BackColor Property

Gets or sets the background color at the left edge of the status bar. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.BackColorBottom Property

Gets or sets the background color at the bottom of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public Color BackColorBottom { get; set; }
[Visual Basic]
Public Property BackColorBottom As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.BackColorMiddle Property

Gets or sets the background color in the middle of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public Color BackColorMiddle { get; set; }
[Visual Basic]
Public Property BackColorMiddle As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.BackColorTop Property

Gets or sets the background color at the top of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public Color BackColorTop { get; set; }
[Visual Basic]
Public Property BackColorTop As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ForeColor Property

Gets or sets the color used for text and numbers.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.FrameColor Property

Gets or sets the color of the status bar's frames. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color FrameColor { get; set; }
[Visual Basic]
Public Property FrameColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.GradientBackColor Property

Gets or sets the background color at the right edge of the status bar. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetBackColor Method

Resets the status bar's BackColor to its system dependent default value.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetBackColorBottom Method

Resets the status bar's BackColorBottom to its system dependent default value.

Introduced: 18.0.

Syntax

[C#]
public void ResetBackColorBottom();
[Visual Basic]
Public Sub ResetBackColorBottom()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetBackColorMiddle Method

Resets the status bar's BackColorMiddle to its system dependent default value.

Introduced: 18.0.

Syntax

[C#]
public void ResetBackColorMiddle();
[Visual Basic]
Public Sub ResetBackColorMiddle()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetBackColorTop Method

Resets the status bar's BackColorTop to its system dependent default value.

Introduced: 18.0.

Syntax

[C#]
public void ResetBackColorTop();
[Visual Basic]
Public Sub ResetBackColorTop()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetForeColor Method

Resets the status bar's ForeColor to its system dependent default value.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetFrameColor Method

Resets the status bar's FrameColor to its system dependent default value.

Syntax

[C#]
public void ResetFrameColor();
[Visual Basic]
Public Sub ResetFrameColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetGradientBackColor Method

Resets the status bar's GradientBackColor to its system dependent default value.

Syntax

[C#]
public void ResetGradientBackColor();
[Visual Basic]
Public Sub ResetGradientBackColor()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetSeparatorColorDark Method

Resets the status bar's SeparatorColorDark to its system dependent default value.

Introduced: 18.0.

Syntax

[C#]
public void ResetSeparatorColorDark();
[Visual Basic]
Public Sub ResetSeparatorColorDark()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.ResetSeparatorColorLight Method

Resets the status bar's SeparatorColorLight to its system dependent default value.

Introduced: 18.0.

Syntax

[C#]
public void ResetSeparatorColorLight();
[Visual Basic]
Public Sub ResetSeparatorColorLight()

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.SeparatorColorDark Property

Gets or sets the color of the dark part of a separator. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.StatusBar.Colors.SeparatorColorLight Property

Gets or sets the color of the light part of a separator. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.SubTextPart Class

A SubTextPart object represents a user-defined part of a TX Text Control document. A TX Text Control document consists of the main text, and additionally other pieces of text such as text frames and headers or footers, called textparts. A programmer can define further parts called subtextparts to perform operations on smaller pieces of text. Each of the main textparts has a SubTextPartCollection which can be used to add and remove subtextparts or to save the subtextpart's text.

Introduced: 23.0.

Syntax

[C#]
public class SubTextPart
[Visual Basic]
Public Class SubTextPart

Constructors

Constructor | Description
SubTextPart | Overloaded. Initializes a new instance of the SubTextPart class.

Properties

Property | Description
HighlightColor | Gets or sets the highlight color for the subtextpart.
HighlightMode | Gets or sets a value indicating when the subtextpart is highlighted.
ID | Gets or sets the subtextpart's identifier.
Length | Gets the number of characters which belong to the subtextpart.
Name | Gets or sets the name of the subtextpart.
NestedLevel | Gets the subtextpart's nested level.
Number | Gets the subtextpart's number.
OuterMostSubTextPart | Gets a subtextpart's outermost subtextpart.
OuterSubTextPart | Gets a subtextpart's outer subtextpart.
Start | Gets the index (one-based) of the first character which belongs to the subtextpart.
Text | Gets the subtextpart's text.

Methods

Method | Description
Save | Overloaded. Saves the subtextpart's text with the specified format.
ScrollTo | Sets the current input position to the beginning of a subtextpart and scrolls it into the visible part of the document.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart Constructor

Initializes a new instance of the SubTextPart class.

SubTextPart(String, Int32)

Creates a subtextpart with the specified name and/or id. The start and length of the subtextpart are initialized to zero. When a zero-length subtextpart is inserted, the current text selection defines it position and length.

[C#]
public SubTextPart(string name, int id);
[Visual Basic]
Public Sub New(ByVal name As String, ByVal id As Integer)
Parameter | Description
name | Specifies the name of the subtextpart. This parameter can be null or an empty string to indicate, that the subtextpart has no name.
id | Specifies an identifier for the subtextpart. This parameter can be 0 to indicate, that the subtextpart has no identifier.

SubTextPart(String, Int32, Int32, Int32)

Creates a subtextpart with the specified name, id, start position and length.

[C#]
public SubTextPart(string name, int id, int start, int length);
[Visual Basic]
Public Sub New(ByVal name As String, ByVal id As Integer, ByVal start As Integer, ByVal length As Integer)
Parameter | Description
name | Specifies the name of the subtextpart. This parameter can be null or an empty string to indicate, that the subtextpart has no name.
id | Specifies an identifier for the subtextpart. This parameter can be 0 to indicate, that the subtextpart has no identifier.
start | Specifies the index (one-based) of the first character which belongs to the subtextpart.
length | Specifies the number of characters which belong to the subtextpart.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.HighlightColor Property

Gets or sets the highlight color for the subtextpart. A subtextpart is highlighted, if it contains the current text input position. The color's alpha value must be less than 255 (opaque) so that the textpart's text remains visible. The default value is red with an alpha value of 60.

Syntax

[C#]
public System.Drawing.Color HighlightColor { get; set; }
[Visual Basic]
Public Property HighlightColor() As System.Drawing.Color

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.HighlightMode Property

Gets or sets a value indicating when the subtextpart is highlighted.

Syntax

[C#]
public HighlightMode HighlightMode { get; set; }
[Visual Basic]
Public Property Name() As String
Value | Description
Activated | The subtextpart is only highlighted, when it contains the current text input position and when the control has the input focus.
Always | The subtextpart is always highlighted.
Never | The subtextpart is never highlighted.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.ID Property

Gets or sets the subtextpart's identifier. It must be a one-based value. A value of zero indicates that the subtextpart has no identifier.

Syntax

[C#]
public int ID { get; set; }
[Visual Basic]
Public Property ID() As Integer

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Length Property

Gets the number of characters which belong to the subtextpart.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Name Property

Gets or sets the name of the subtextpart. An empty string indicates that the subtextpart has no name.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.NestedLevel Property

Gets the subtextpart's nested level. The top level is 1.

Syntax

[C#]
public int NestedLevel { get; }
[Visual Basic]
Public ReadOnly Property NestedLevel() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Number Property

Gets the subtextpart's number. The first subtextpart has the number 1. The number is defined through the textflow. A textpart with a smaller start position has a smaller number. When an outer subtextpart has the same start position than one of its nested textparts the outer textpart has a smaller number.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.OuterSubTextPart Property

Gets a subtextpart's outer subtextpart. The property's value is an object of the type SubTextPart or null if this subtextpart is a top-level subtextpart.

Syntax

[C#]
public SubTextPart OuterSubTextPart { get; }
[Visual Basic]
Public ReadOnly Property OuterSubTextPart() As SubTextPart

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.OuterMostSubTextPart Property

Gets a subtextpart's outermost subtextpart. This is a top-level subtextpart with a nested level of 1. The property's value is an object of the type SubTextPart or null if this subtextpart is already a top-level subtextpart.

Syntax

[C#]
public SubTextPart OuterMostSubTextPart { get; }
[Visual Basic]
Public ReadOnly Property OuterMostSubTextPart() As SubTextPart

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Save Method

Saves the subtextpart's text with the specified format.

Save(Byte[], BinaryStreamType)

Saves the subtextpart's text in a byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the subtextpart's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the subtextpart's text as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the subtextpart's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the subtextpart's text in a byte array with the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the subtextpart's text is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the subtextpart's text as a string with the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the subtextpart's text is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.ScrollTo Method

Sets the current input position to the beginning of a subtextpart and scrolls it into the visible part of the document.

Syntax

[C#]
public bool ScrollTo();
[Visual Basic]
Public Function ScrollTo() As Boolean

Return Value

The return value is true, if the subtextpart could be scrolled. Otherwise it is non-zero.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Start Property

Gets the index (one-based) of the first character which belongs to the subtextpart.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPart.Text Property

Gets the subtextpart's text.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection Class

Contains all subtextparts in the main text or another main part of a document. It is a collection of objects of the type SubTextPart. A collection object can be obtained with the TextControl.SubTextParts, the HeaderFooter.SubTextParts or the TextFrame.SubTextParts property. The SubTextPartCollection class implements the IEnumerable and the ICollection interfaces. The text of each main part of the document, which are the main text, a header or footer or a textframe, can be divided in further parts, called subtextparts. A subtextpart must be a selectable part of the document. It can immediately follow its previous textpart. The position between two textparts belongs to the following textpart. Subtextparts can be nested. A nested textpart must be smaller than its outer textpart. A nested textpart can start or end at the same position as its outer textpart, but a nested textpart cannot have the same length as its outer textpart. To insert a nested textpart its outer textpart must be inserted first. A textpart cannot have a length of zero. When the last character of a textpart is deleted, the textpart itself is also deleted.

Introduced: 23.0.

Syntax

[C#]
public sealed class SubTextPartCollection
[Visual Basic]
Public NotInheritable Class SubTextPartCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
Add | Adds a new subtextpart to the document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Gets a particular subtextpart from the collection.
Item | Gets the subtextpart with the specified number from the collection.
Remove | Removes a subtextpart from the collection including all its nested subtextparts.

Enumerations

Enumeration | Description
AddResult | Specifies the result when a subtextpart has been added to the document.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.Add Method

Adds a new subtextpart to the document. Its position is defined through the SubTextPart.Start and SubTextPart.Length properties. If the subtextpart's length is zero, the current text selection is used to define the position.

Syntax

[C#]
public SubTextPartCollection.AddResult Add(SubTextPart subTextPart);
[Visual Basic]
Public Function Add(ByVal subTextPart As SubTextPart) As SubTextPartCollection.AddResult
Parameter | Description
subTextPart | Specifies the subtextpart to add.

Return Value

The return value specifies whether the new textpart has successfully been inserted. It can be one of the SubTextPartCollection.AddResult values.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.AddResult Enumeration

Specifies the result when a subtextpart has been added to the document.

Member | Description
AlreadyExists | The subtextpart wasn't inserted because it already exists.
Combined | The subtextpart wasn't inserted but it was combined with an existing one. A subtextpart is combined with an existing one, when it immediately follows it and has the same name and id.
Error | An unexpected error has occurred.
NoSelection | The subtextpart wasn't inserted because there is no selection.
Overlapping | The subtextpart wasn't inserted because it overlaps with an existing textpart.
PositionInvalid | The subtextpart wasn't inserted because the specified position values are invalid. Invalid start and/or length values have been specified.
SelectionTooComplex | The subtextpart wasn't inserted because the selection is too complex. It is not a continuous sequence of characters.
Successful | The subtextpart has successfully been inserted.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.GetItem Method

Gets a particular subtextpart from the collection.

GetItem()

Gets the subtextpart at the current text input position. If there is more than one textpart at the current input position the textpart with the highest level is returned.

[C#]
public SubTextPart GetItem();
[Visual Basic]
Public Function GetItem() As SubTextPart

GetItem(String)

Gets the subtextpart with the specified name. The method returns null, if such a textpart does not exist. If more than one textpart with this name exists, the first found textpart is returned.

[C#]
public SubTextPart GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As SubTextPart
Parameter | Description
name | Specifies the textpart's name set with the Name property. The method returns null if a textpart with the specified name does not exist.

GetItem(Int32)

Gets the subtextpart with the specified id. The method returns null, if such a textpart does not exist. If more than one textpart with this id exists, the first found textpart is returned.

[C#]
public SubTextPart GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As SubTextPart
Parameter | Description
id | Specifies the textpart's identifier. The method returns null if a textpart with the specified identifier does not exist.

Return Value

The return value is null, if a subtextpart with the specified parameters could not be found. Otherwise, it is an object of the type SubTextPart.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.Item Property

Gets the subtextpart with the specified number from the collection. The number must be between 1 and Count. In C# this property is the indexer for the SubTextPartCollection class.

Syntax

[C#]
public SubTextPart this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As SubTextPart
Parameter | Description
number | Specifies a subtextpart number. The first subtextpart has the number 1.

Return Value

The return value is null, if the subtextpart could not be found. Otherwise, it is an object of the type SubTextPart.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.Remove Method

Removes a subtextpart from the collection including all its nested subtextparts.

Syntax

[C#]
public bool Remove(SubTextPart subTextPart, bool keepText, bool keepNested);
[Visual Basic]
Public Function Remove(ByVal subTextPart As SubTextPart, ByVal keepText As Boolean, ByVal keepNested As Boolean) As Boolean
Parameter | Description
subTextPart | Specifies the subtextpart to remove.
keepText | If this parameter is set to true, the subtextpart is removed without deleting its visible text. Otherwise, the visible text is also removed.
keepNested | If this parameter is set to true, nested subtextparts are preserved. When the keepText parameter is set to false, this parameter is ignored.

Return Value

The return value is true, if the textpart could be removed. Otherwise, it is false.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartEventArgs Class

The SubTextPartEventArgs class provides data for the TextControl.SubTextPartClicked, TextControl.SubTextPartDoubleClicked, TextControl.SubTextPartEntered and TextControl.SubTextPartLeft events.

Introduced: 23.0.

Syntax

[C#]
public class SubTextPartEventArgs: EventArgs
[Visual Basic]
Public Class SubTextPartEventArgs
  Inherits EventArgs

Properties

Property | Description
SubTextPart | Gets an object that represents the subtextpart which causes the event.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.SubTextPartEventArgs.SubTextPart Property

Gets an object that represents the subtextpart which causes the event. It is of the type SubTextPart.

Syntax

[C#]
public SubTextPart SubTextPart { get; }
[Visual Basic]
Public ReadOnly Property SubTextPart() As SubTextPart

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.Table Class

An instance of the Table class represents a table in a Text Control document. It can be obtained from the document's table collection.

Syntax

[C#]
public class Table
[Visual Basic]
Public Class Table

Properties

Property | Description
CanMergeCells | Checks whether table cells can be merged.
CanSplit | Checks whether this table can be split.
CanSplitCells | Checks whether previously merged table cells in this table can be split.
Cells | Gets a collection of all table cells the table consists of.
Columns | Gets a collection of all columns the table consists of.
ID | Gets or sets the table's identifier.
NestedLevel | Gets the nested level for the specified table.
NestedTables | Gets a collection of all tables nested in this table.
OuterMostTable | Gets a table's outermost table.
OuterTable | Gets a table's outer table.
Rows | Gets a collection of all rows the table consists of.

Methods

Method | Description
MergeCells | Merges all selected table cells in this table.
Select | Overloaded. Selects the table or a part of the table.
Split | Splits a table below or above the current input position.
SplitCells | Splits all selected table cells in this table.

Example

The following example shows how to split a table.

[C#]
textControl1.ResetContents();
int myTableId = 10;

textControl1.Tables.Add(10, 3, myTableId);
TXTextControl.Table myTable = textControl1.Tables.GetItem(myTableId);
textControl1.InputPosition =
  new TXTextControl.InputPosition(myTable.Cells.GetItem(3, 1).Start);

if (myTable.CanSplit)
  myTable.Split(TXTextControl.TableAddPosition.After);

// Correct the table IDs after splitting the original table.
foreach (TXTextControl.Table myCurrentTable in textControl1.Tables)
  myCurrentTable.ID = myTableId++;
[Visual Basic]
TextControl1.ResetContents()
Dim MyTableId As Integer = 10

TextControl1.Tables.Add(10, 3, MyTableId)
Dim MyTable As TXTextControl.Table = TextControl1.Tables.GetItem(MyTableId)
TextControl1.InputPosition = _
  New TXTextControl.InputPosition(MyTable.Cells.GetItem(3, 1).Start)

If MyTable.CanSplit Then
  MyTable.Split(TXTextControl.TableAddPosition.After)
End If

' Correct the table IDs after splitting the original table.
For Each MyCurrentTable As TXTextControl.Table In TextControl1.Tables
  MyCurrentTable.ID = MyTableId
  MyTableId = MyTableId + 1
Next

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.CanMergeCells Property

Checks whether table cells can be merged. Table cells can only be merged, if more than one cell in this table is selected.

Introduced: 17.0.

Syntax

[C#]
public bool CanMergeCells { get; }
[Visual Basic]
Public ReadOnly Property CanMergeCells() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.CanSplit Property

Checks whether this table can be split. A table can only be split if it contains the current input position and no further text is selected.

Introduced: 11.0.

Syntax

[C#]
public bool CanSplit { get; }
[Visual Basic]
Public ReadOnly Property CanSplit() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.CanSplitCells Property

Checks whether previously merged table cells in this table can be split. Only selected table cells can be split.

Introduced: 17.0.

Syntax

[C#]
public bool CanSplitCells { get; }
[Visual Basic]
Public ReadOnly Property CanSplitCells() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.Cells Property

Gets a collection of all table cells the table consists of. The property's value is an object of the type TableCellCollection.

Syntax

[C#]
public TableCellCollection Cells { get; }
[Visual Basic]
Public ReadOnly Property Cells() As TableCellCollection

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.Columns Property

Gets a collection of all columns the table consists of. The property's value is an object of the type TableColumnCollection.

Syntax

[C#]
public TableColumnCollection Columns { get; }
[Visual Basic]
Public ReadOnly Property Columns() As TableColumnCollection

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.ID Property

Gets or sets the table's identifier. It must be between 10 and short.MaxValue.

Syntax

[C#]
public int ID { get; set; }
[Visual Basic]
Public Property ID() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.NestedLevel Property

Gets the nested level for the specified table. Top level tables have a level of 1.

Introduced: 11.0.

Syntax

[C#]
public int NestedLevel { get; }
[Visual Basic]
Public ReadOnly Property NestedLevel() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.NestedTables Property

Gets a collection of all tables nested in this table. The property's value is an object of the type TableBaseCollection.

Introduced: 11.0.

Syntax

[C#]
public TableBaseCollection NestedTables { get; }
[Visual Basic]
Public ReadOnly Property NestedTables() As TableBaseCollection

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.OuterTable Property

Gets a table's outer table. The property's value is an object of the type Table or null if this table is a top-level table.

Introduced: 11.0.

Syntax

[C#]
public Table OuterTable { get; }
[Visual Basic]
Public ReadOnly Property OuterTable() As Table

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.OuterMostTable Property

Gets a table's outermost table. This is a top-level table with a nested level of 1. The property's value is an object of the type Table or null if this table is already a top-level table.

Introduced: 11.0.

Syntax

[C#]
public Table OuterMostTable { get; }
[Visual Basic]
Public ReadOnly Property OuterMostTable() As Table

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.Rows Property

Gets a collection of all rows the table consists of. The property's value is an object of the type TableRowCollection.

Syntax

[C#]
public TableRowCollection Rows { get; }
[Visual Basic]
Public ReadOnly Property Rows() As TableRowCollection

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.MergeCells Method

Merges all selected table cells in this table. The Table.CanMergeCells property can be used to determine, if table cells can be merged or not.

Introduced: 17.0.

Syntax

[C#]
public bool MergeCells();
[Visual Basic]
Public Sub MergeCells()

Return Value

The return value is true, if table cells could be merged. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.Select Method

Selects the table or a part of the table.

Introduced: 10.1.

Select()

Selects the complete table.

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

Select(Int32, Int32, Int32, Int32)

Selects the part of the table defined through two table cells.

[C#]
public void Select(int startRow, int startColumn, int stopRow, int stopColumn);
[Visual Basic]
Public Sub Select(ByVal startRow As Integer, ByVal startColumn As Integer, ByVal stopRow As Integer, ByVal stopColumn As Integer)
Member | Description
startRow | Specifies the row number where the selection begins.
startColumn | Specifies the column number where the selection begins.
stopRow | Specifies the row number where the selection ends.
stopColumn | Specifies the column number where the selection ends.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.Split Method

Splits a table below or above the current input position. If the table does not contain the current input position it cannot be split. The Table.CanSplit property can be used to determine if a table can be split or not. If a table is split above the first row a new line is inserted above the table and if a table is split below the last row a new line is inserted below the table. This is useful to insert text above or below a nested table that immediately starts and/or ends at the beginning or the end of the cell in which it is nested.

Introduced: 11.0.

Syntax

[C#]
public bool Split(TableAddPosition position);
[Visual Basic]
Public Function Split(ByVal position As TableAddPosition) As Boolean
Parameter Description
position

Specifies the position where to split the table. It can be one of the TableAddPosition values:

Value | Meaning
Before | The table is split in front of the row with the current input position.
After | The table is split behind the row with the current input position.

Return Value

The return value is true, if the table could be split. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.Table.SplitCells Method

Splits all selected table cells in this table. Only previously merged cells can be split. The Table.CanSplitCells property can be used to determine, if table cells can be split or not.

Introduced: 17.0.

Syntax

[C#]
public bool SplitCells();
[Visual Basic]
Public Sub SplitCells()

Return Value

The return value is true, if table cells could be split. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection Class

The TableBaseCollection class is the base class for the table collection classes. It contains the generic enumeration features for all tables of a document or for the nested tables embedded in a single table. It implements the IEnumerable and the ICollection interfaces.

Introduced: 11.0.

Syntax

public class TableBaseCollection: ICollection, IEnumerable
[C#]
public class TableBaseCollection: ICollection, IEnumerable
[Visual Basic]
Public Class TableBaseCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of tables contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
Clear | Removes all tables contained in the collection from a Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Gets a particular table from the collection.
Remove | Removes a particular table from the collection.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.Clear Method

Removes all tables contained in the collection from a Text Control document.

Introduced: 13.0.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.Count Property

Gets the number of tables contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.GetItem Method

Gets a particular table from the collection.

Syntax

[C#]
public Table GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As Table
Parameter | Description
id | Specifies the table's identifier.

Return Value

The return value is the requested table. It is null if the requested table could not be found.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.Remove Method

Removes a particular table from the collection.

Syntax

[C#]
public bool Remove(int id);
[Visual Basic]
Public Function Remove(ByVal id As Integer) As Boolean
Parameter | Description
id | Specifies the table's identifier.

Return Value

The return value is true, if a table could be removed. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableBaseCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell Class

An instance of the TableCell class represents a single cell of a table in a Text Control document. It can be obtained from the table's cell collection.

Syntax

[C#]
public class TableCell
[Visual Basic]
Public Class TableCell

Properties

Property | Description
CellFormat | Gets or sets the formatting attributes of a table cell.
Column | Gets the table cell's column number.
Length | Gets the number of characters in the table cell.
Name | Gets or sets the cell's name.
Position | Gets or sets, in twips, the horizontal position of the cell.
Row | Gets the table cell's row number.
Start | Gets the index (one-based) of the first character in the table cell.
Text | Gets or sets the cell's text.
Width | Gets or sets, in twips, the width of the cell.

Methods

Method | Description
Select | Selects the table cell.

Example

The following example shows how to handle table cells.

[C#]
TableCell myCell = myTable.Cells.GetItem(1, 1);
myCell.Width = 2 * 1440; // 2 inches
myCell.Text = "Some sample text";
myCell.Select();

textControl1.Selection.FontSize = 8 * 20; // 8pt
textControl1.Selection.ParagraphFormat.Alignment = HorizontalAlignment.Right;
[Visual Basic]
Dim MyCell As TableCell = MyTable.Cells.GetItem(1, 1)
MyCell.Width = 2 * 1440 ' 2 inches
MyCell.Text = "Some sample text"
MyCell.Select()

TextControl1.Selection.FontSize = 8 * 20 ' 8pt
TextControl1.Selection.ParagraphFormat.Alignment = HorizontalAlignment.Right

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.CellFormat Property

Gets or sets the formatting attributes of a table cell. The property's value is an object of the type TableCellFormat.

Syntax

[C#]
public TableCellFormat CellFormat { get; set; }
[Visual Basic]
Public Property CellFormat() As TableCellFormat

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Column Property

Gets the table cell's column number.

Syntax

[C#]
public int Column { get; }
[Visual Basic]
Public ReadOnly Property Column() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Length Property

Gets the number of characters in the table cell. If the table cell is merged, the property returns -1.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Name Property

Gets or sets the cell's name. Each table cell can have a name, which can be used to store any string data associated with the cell.

Introduced: 17.0.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Position Property

Gets or sets, in twips, the horizontal position of the cell.

Syntax

[C#]
public int Position { get; set; }
[Visual Basic]
Public Property Position() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Row Property

Gets the table cell's row number.

Syntax

[C#]
public int Row { get; }
[Visual Basic]
Public ReadOnly Property Row() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Select Method

Selects the table cell.

Introduced: 10.1.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Text Property

Gets or sets the cell's text.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Start Property

Gets the index (one-based) of the first character in the table cell.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCell.Width Property

Gets or sets, in twips, the width of the cell.

Syntax

[C#]
public int Width { get; set; }
[Visual Basic]
Public Property Width() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellCollection Class

An instance of the TableCellCollection class contains all cells of a table in a Text Control document represented through TableCell objects. It can be obtained with the Table.Cells property. The TableCellCollection class implements the IEnumerable and the ICollection interfaces.

Syntax

[C#]
public sealed class TableCellCollection: TablePartCollection
[Visual Basic]
Public NotInheritable Class TableCellCollection
  Inherits TablePartCollection

Properties

Property | Description
CanRemove | Gets a value indicating whether table cells can be removed.
Count | Gets the number of elements contained in the collection. (Inherited from TablePartCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TablePartCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TablePartCollection.)

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TablePartCollection.)
GetItem | Overloaded. Gets a particular table cell from the collection.
Remove | Removes the table cell at the current text input position or all selected table cells when a text selection exists.

Example

The following example shows how to iterate over the table cell collection.

[C#]
foreach (TXTextControl.TableCell myCell in myTable.Cells)
{
  string myRow = myCell.Row.ToString();
  string myCol = myCell.Column.ToString();
  string myText = myCell.Text;
  Console.WriteLine("({0},{1}): {2}", myRow, myCol, myText);
}
[Visual Basic]
For Each MyCell As TXTextControl.TableCell In MyTable.Cells
  Dim MyRow As String = MyCell.Row.ToString()
  Dim MyCol As String = MyCell.Column.ToString()
  Dim MyText As String = MyCell.Text
  Console.WriteLine("({0},{1}): {2}", MyRow, MyCol, MyText)
Next

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellCollection.CanRemove Property

Gets a value indicating whether table cells can be removed. Table cells can be removed, if either the current text input position is in a table, or if a part of a table is selected.

Introduced: 17.0.

Syntax

[C#]
public bool CanRemove { get; }
[Visual Basic]
Public ReadOnly Property CanRemove() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellCollection.GetItem Method

Gets a particular table cell from the collection.

GetItem()

Gets the table cell at the current input position.

[C#]
public TableCell GetItem();
[Visual Basic]
Public Function GetItem() As TableCell

GetItem(Int32, Int32)

Gets the cell with the specified row and column number.

[C#]
public TableCell GetItem(int row, int column);
[Visual Basic]
Public Function GetItem(ByVal row As Integer, ByVal column As Integer) As TableCell
Parameter | Description
row | Specifies the row number. It must be between 1 and the value returned through the TableRowCollection.Count property.
column | Specifies the column number. It must be between 1 and the value returned through the TableColumnCollection.Count property.

Return Value

The return value is the requested cell.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellCollection.Remove Method

Removes the table cell at the current text input position or all selected table cells when a text selection exists.

Introduced: 17.0.

Syntax

[C#]
public bool Remove();
[Visual Basic]
Public Function Remove() As Boolean

Return Value

The return value is true, if table cells could be removed. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat Class

An instance of the TableCellFormat class represents the formatting attributes of a table cell.

Syntax

[C#]
public class TableCellFormat
[Visual Basic]
Public Class TableCellFormat

Properties

Property | Description
BackColor | Gets or sets the table cell's background color.
BottomBorderColor | Gets or sets the color of the table cell's bottom border.
BottomBorderWidth | Gets or sets the width of the table cell's bottom border.
BottomTextDistance | Gets or sets, in twips, the distance between the table cell's bottom border and its text.
LeftBorderColor | Gets or sets the color of the table cell's left border.
LeftBorderWidth | Gets or sets the width of the table cell's left border.
LeftTextDistance | Gets or sets, in twips, the distance between the table cell's left border and its text.
RightBorderColor | Gets or sets the color of the table cell's right border.
RightBorderWidth | Gets or sets the width of the table cell's right border.
RightTextDistance | Gets or sets, in twips, the distance between the table cell's right border and its text.
TopBorderColor | Gets or sets the color of the table cell's top border.
TopBorderWidth | Gets or sets the width of the table cell's top border.
TopTextDistance | Gets or sets, in twips, the distance between the table cell's top border and its text.
VerticalAlignment | Gets or sets the vertical alignment of the text in the table cell.

Example

The following example shows how to format a table cell.

[C#]
TXTextControl.TableCellFormat myCellFormat = new TXTextControl.TableCellFormat();

myCellFormat.BackColor = System.Drawing.Color.LightBlue;
myCellFormat.BottomBorderWidth = 150;
myCellFormat.VerticalAlignment = TXTextControl.VerticalAlignment.Bottom;

myTable.Cells.GetItem(1, 1).CellFormat = myCellFormat;
[Visual Basic]
Dim MyCellFormat As New TXTextControl.TableCellFormat()

MyCellFormat.BackColor = System.Drawing.Color.LightBlue
MyCellFormat.BottomBorderWidth = 150
MyCellFormat.VerticalAlignment = TXTextControl.VerticalAlignment.Bottom

MyTable.Cells.GetItem(1, 1).CellFormat = MyCellFormat

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.BackColor Property

Gets or sets the table cell's background color.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor() As Color

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.BottomBorderColor Property

Gets or sets the color of the table cell's bottom border.

Introduced: 17.0.

Syntax

[C#]
public Color BottomBorderColor { get; set; }
[Visual Basic]
Public Property BottomBorderColor() As Color

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.BottomBorderWidth Property

Gets or sets the width of the table cell's bottom border.

Syntax

[C#]
public int BottomBorderWidth { get; set; }
[Visual Basic]
Public Property BottomBorderWidth() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.BottomTextDistance Property

Gets or sets, in twips, the distance between the table cell's bottom border and its text.

Syntax

[C#]
public int BottomTextDistance { get; set; }
[Visual Basic]
Public Property BottomTextDistance() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.LeftBorderColor Property

Gets or sets the color of the table cell's left border.

Introduced: 17.0.

Syntax

[C#]
public Color LeftBorderColor { get; set; }
[Visual Basic]
Public Property LeftBorderColor() As Color

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.LeftBorderWidth Property

Gets or sets the width of the table cell's left border.

Syntax

[C#]
public int LeftBorderWidth { get; set; }
[Visual Basic]
Public Property LeftBorderWidth() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.LeftTextDistance Property

Gets or sets, in twips, the distance between the table cell's left border and its text.

Syntax

[C#]
public int LeftTextDistance { get; set; }
[Visual Basic]
Public Property LeftTextDistance() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.RightBorderColor Property

Gets or sets the color of the table cell's right border.

Introduced: 17.0.

Syntax

[C#]
public Color RightBorderColor { get; set; }
[Visual Basic]
Public Property RightBorderColor() As Color

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.RightBorderWidth Property

Gets or sets the width of the table cell's right border.

Syntax

[C#]
public int RightBorderWidth { get; set; }
[Visual Basic]
Public Property RightBorderWidth() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.RightTextDistance Property

Gets or sets, in twips, the distance between the table cell's right border and its text.

Syntax

[C#]
public int RightTextDistance { get; set; }
[Visual Basic]
Public Property RightTextDistance() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.TopBorderColor Property

Gets or sets the color of the table cell's top border.

Introduced: 17.0.

Syntax

[C#]
public Color TopBorderColor { get; set; }
[Visual Basic]
Public Property TopBorderColor() As Color

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.TopBorderWidth Property

Gets or sets the width of the table cell's top border.

Syntax

[C#]
public int TopBorderWidth { get; set; }
[Visual Basic]
Public Property TopBorderWidth() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.TopTextDistance Property

Gets or sets, in twips, the distance between the table cell's top border and its text.

Syntax

[C#]
public int TopTextDistance { get; set; }
[Visual Basic]
Public Property TopTextDistance() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCellFormat.VerticalAlignment Property

Gets or sets the vertical alignment of the text in the table cell.

Syntax

[C#]
public VerticalAlignment VerticalAlignment { get; set; }
[Visual Basic]
Public Property VerticalAlignment() As VerticalAlignment
Value | Description
Top | Text is aligned at the top of the table cell.
Center | Text is aligned in the center of the table cell.
Bottom | Text is aligned at the bottom of the table cell.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection Class

An instance of the TableCollection class contains all tables of a Text Control document or part of the document represented through objects of the type Table. It can be obtained with the TextControl.Tables, HeaderFooter.Tables or TextFrame.Tables property. The TableCollection class is derived from the TableBaseCollection class and implements therefore the IEnumerable and the ICollection interfaces. Additionally to the properties and methods inherited it implements the following:

Syntax

[C#]
public sealed class TableCollection: TableBaseCollection
[Visual Basic]
Public NotInheritable Class TableCollection
  Inherits TableBaseCollection

Properties

Property | Description
CanAdd | Gets a value indicating whether a new table can be inserted at the current input position.
GridLines | Gets or sets a value indicating wether table grid lines are shown or not.

Methods

Method | Description
Add | Overloaded. Adds a new table at the current text input position.
GetItem | Gets the table at the current input position.
Remove | Removes the table at the current text input position.

Example

The following example shows how to handle the table collection.

[C#]
int myTableId = 10;
textControl1.Tables.GridLines = false;

if(textControl1.Tables.CanAdd)
  textControl1.Tables.Add(5, 3, myTableId);

TXTextControl.Table myTable = textControl1.Tables.GetItem(myTableId);
textControl1.Tables.Remove(myTableId);
[Visual Basic]
Dim MyTableId As Integer = 10
TextControl1.Tables.GridLines = False

If TextControl1.Tables.CanAdd Then
  TextControl1.Tables.Add(5, 3, MyTableId)
End If

Dim MyTable As TXTextControl.Table = TextControl1.Tables.GetItem(MyTableId)
TextControl1.Tables.Remove(MyTableId)

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection.Add Method

Adds a new table at the current text input position.

Add()

Opens a dialog box and, when left with Ok, adds a new table with the specified attributes.

[C#]
public bool Add();
[Visual Basic]
Public Function Add() As Boolean

Add(Int32, Int32)

Adds a new table at the current text input position. The new table has the specified number of rows and columns.

[C#]
public bool Add(int rows, int columns);
[Visual Basic]
Public Function Add(ByVal rows As Integer, ByVal columns As Integer) As Boolean
Parameter | Description
rows | Specifies the number of rows the table consists of.
columns | Specifies the number of columns the table consists of.

Add(Int32, Int32, Int32)

Adds a new table at the current text input position. The new table has the specified number of rows and columns. The specified identifier can be used to get the table from the collection.

[C#]
public bool Add(int rows, int columns, int id);
[Visual Basic]
Public Function Add(ByVal rows As Integer, ByVal columns As Integer, ByVal id As Integer) As Boolean
Parameter | Description
rows | Specifies the number of rows the table consists of.
columns | Specifies the number of columns the table consists of.
id | Specifies the table's id.

Return Value

The return value is true, if the table could be added. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection.CanAdd Property

Gets a value indicating whether a new table can be inserted at the current input position.

Syntax

[C#]
public bool CanAdd { get; }
[Visual Basic]
Public ReadOnly Property CanAdd() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection.GetItem Method

Gets the table at the current input position. To get a particular table with a certain identifier use the base class's implementation TableBaseCollection.GetItem.

Syntax

[C#]
public Table GetItem();
[Visual Basic]
Public Function GetItem() As Table

Return Value

The return value is the requested table. It is null if there is no table at the current input position.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection.GridLines Property

Gets or sets a value indicating wether table grid lines are shown or not.

Syntax

[C#]
public bool GridLines { get; set; }
[Visual Basic]
Public Property GridLines() As Boolean

Example

The following XAML example shows how to bind the GridLines property to a check box.

<CheckBox
    Content="Show table grid lines"
    IsChecked="{Binding ElementName=textControl1, Path=Tables.GridLines}" />

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableCollection.Remove Method

Removes the table at the current text input position. To remove a particular table with a certain identifier use the base class's implementation TableBaseCollection.Remove.

Syntax

[C#]
public bool Remove();
[Visual Basic]
Public Function Remove() As Boolean

Return Value

The return value is true, if a table could be removed. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn Class

An instance of the TableColumn class represents a single column of a table in a Text Control document. It can be obtained from the table's column collection.

Syntax

[C#]
public class TableColumn
[Visual Basic]
Public Class TableColumn

Properties

Property | Description
CellFormat | Gets or sets the formatting attributes of a table column.
Column | Gets the number of the table column represented through this table column object.
Position | Gets or sets, in twips, the horizontal position of the column.
Width | Gets or sets, in twips, the width of the column.

Methods

Method | Description
Select | Selects the table column.

Example

The following example shows how to handle table columns.

[C#]
TXTextControl.TableColumn myCol = myTable.Columns.GetItem(1);
int myDelta = (int)(myCol.Width / 5);
myCol.Width -= myDelta;
myCol.Position += myDelta;
[Visual Basic]
Dim MyCol As TXTextControl.TableColumn = MyTable.Columns.GetItem(1)
Dim MyDelta As Integer = CInt(MyCol.Width / 5)
MyCol.Width -= MyDelta
MyCol.Position += MyDelta

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn.CellFormat Property

Gets or sets the formatting attributes of a table column. The property's value is an object of the type TableCellFormat.

Syntax

[C#]
public TableCellFormat CellFormat { get; set; }
[Visual Basic]
Public Property CellFormat() As TableCellFormat

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn.Column Property

Gets the number of the table column represented through this table column object.

Syntax

[C#]
public int Column { get; }
[Visual Basic]
Public ReadOnly Property Column() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn.Position Property

Gets or sets, in twips, the horizontal position of the column.

Syntax

[C#]
public int Position { get; set; }
[Visual Basic]
Public Property Position() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn.Select Method

Selects the table column.

Introduced: 17.0.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumn.Width Property

Gets or sets, in twips, the width of the column. If the cells of the column have different widths, the property returns 0.

Syntax

[C#]
public int Width { get; set; }
[Visual Basic]
Public Property Width() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection Class

An instance of the TableColumnCollection class contains all columns of a table in a Text Control document represented through objects of the type TableColumn. It can be obtained with the Table.Columns property. The TableColumnCollection class implements the IEnumerable and the ICollection interfaces.

Syntax

[C#]
public sealed class TableColumnCollection: TablePartCollection
[Visual Basic]
Public NotInheritable Class TableColumnCollection
  Inherits TablePartCollection

Properties

Property | Description
CanAdd | Gets a value indicating whether a new column can be inserted at the current input position.
CanRemove | Gets a value indicating whether table columns can be removed.
Count | Gets the number of elements contained in the collection. (Inherited from TablePartCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TablePartCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TablePartCollection.)

Methods

Method | Description
Add | Adds a new table column at the current text input position.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TablePartCollection.)
GetItem | Overloaded. Gets a particular table column from the collection.
Remove | Removes the table column at the current text input position or all selected table columns when a text selection exists.

Example

The following example shows how to use the table column collection.

[C#]
int myLastCol = myTable.Columns.Count;
TXTextControl.TableColumn myCol = myTable.Columns.GetItem(myLastCol);
TXTextControl.TableCell myCell = myTable.Cells.GetItem(1, myLastCol);
int myNewWidth = (int)(myCol.Width / 2);

textControl1.InputPosition = new TXTextControl.InputPosition(myCell.Start - 1);

if (myTable.Columns.CanAdd)
{
  myCol.Width = myNewWidth;
  myTable.Columns.Add(TXTextControl.TableAddPosition.After);
}
[Visual Basic]
Dim MyLastCol As Integer = MyTable.Columns.Count
Dim MyCol As TXTextControl.TableColumn = MyTable.Columns.GetItem(MyLastCol)
Dim MyCell As TXTextControl.TableCell = MyTable.Cells.GetItem(1, MyLastCol)
Dim MyNewWidth As Integer = CInt(MyCol.Width / 2)

TextControl1.InputPosition = New TXTextControl.InputPosition(MyCell.Start - 1)

If MyTable.Columns.CanAdd Then
  MyCol.Width = MyNewWidth
  MyTable.Columns.Add(TXTextControl.TableAddPosition.After)
End If

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.Add Method

Adds a new table column at the current text input position.

Syntax

[C#]
public bool Add(TableAddPosition position);
[Visual Basic]
Public Function Add(ByVal position As TableAddPosition) As Boolean
Parameter Description
position

Specifies the position where to add the column. It can be one of the TableAddPosition values:

Value | Meaning
Before | The column is inserted left of the column with the current input position.
After | The column is inserted right of the column with the current input position.

Return Value

The return value is true, if the column could be added. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.CanAdd Property

Gets a value indicating whether a new column can be inserted at the current input position.

Syntax

[C#]
public bool CanAdd { get; }
[Visual Basic]
Public ReadOnly Property CanAdd() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.CanRemove Property

Gets a value indicating whether table columns can be removed. Columns can be removed if either the current text input position is in a table or if a part of a table is selected.

Syntax

[C#]
public bool CanRemove { get; }
[Visual Basic]
Public ReadOnly Property CanRemove() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.GetItem Method

Gets a particular table column from the collection.

GetItem()

Gets the table column at the current input position.

[C#]
public TableColumn GetItem();
[Visual Basic]
Public Function GetItem() As TableColumn

GetItem(Int32)

Gets the table column with the specified number.

[C#]
public TableColumn GetItem(int column);
[Visual Basic]
Public Function GetItem(ByVal column As Integer) As TableColumn
Parameter | Description
column | Specifies the column number. It must be between 1 and the value returned through the collection's Count property.

Return Value

The return value is the requested column. It is null if the requested column could not be found.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableColumnCollection.Remove Method

Removes the table column at the current text input position or all selected table columns when a text selection exists.

Syntax

[C#]
public bool Remove();
[Visual Basic]
Public Function Remove() As Boolean

Return Value

The return value is true, if table columns could be removed. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableEventArgs Class

The TableEventArgs class provides data for the TextControl.TableCreated, TextControl.TableDeleted and TextControl.TableFormatChanged events.

Syntax

public class TableEventArgs: EventArgs
[C#]
public class TableEventArgs: EventArgs
[Visual Basic]
Public Class TableEventArgs
  Inherits EventArgs

Properties

Property | Description
Table | Gets an object that represents the table which causes the event.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableEventArgs.Table Property

Gets an object that represents the table which causes the event. It is of the type Table. If this object has been obtained through the TableDeleted event, only the Table.ID property has a valid value.

Syntax

[C#]
public Table Table { get; }
[Visual Basic]
Public ReadOnly Property Table() As Table

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TablePartCollection Class

The TablePartCollection class is the base class of the TableRowCollection, TableColumnCollection and TableCellCollection classes. It implements their base functionality and the IEnumerable and the ICollection interface.

Syntax

[C#]
public abstract class TablePartCollection: ICollection, IEnumerable
[Visual Basic]
Public MustInherit Class TablePartCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TablePartCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TablePartCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TablePartCollection.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TablePartCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow Class

An instance of the TableRow class represents a single row of a table in a Text Control document. It can be obtained from the table's row collection.

Syntax

public class TableRow
[C#]
public class TableRow
[Visual Basic]
Public Class TableRow

Properties

Property | Description
AllowPageBreak | Gets or sets a value specifying how the table row is formatted at page breaks.
CellFormat | Gets or sets the formatting attributes of a table row.
IsHeader | Gets or sets a value specifying whether the table row is part of the table's header.
MinimumHeight | Gets or sets the minimum height, in twips, of the table row.
Row | Gets the number of the table row represented through this table row object.

Methods

Method | Description
Select | Selects the table row.

Example

The following example shows how to handle table rows.

[C#]
TXTextControl.TableCellFormat myCellFormat = new TXTextControl.TableCellFormat();
myCellFormat.BackColor = System.Drawing.Color.LightGreen;
myCellFormat.BottomBorderWidth = 40;

TXTextControl.TableRow myRow = myTable.Rows.GetItem(1);
myRow.MinimumHeight = 1440; // 1 inch
myRow.AllowPageBreak = false;
myRow.CellFormat = myCellFormat;
[Visual Basic]
Dim MyCellFormat As New TXTextControl.TableCellFormat()
MyCellFormat.BackColor = System.Drawing.Color.LightGreen
MyCellFormat.BottomBorderWidth = 40

Dim MyRow As TXTextControl.TableRow = MyTable.Rows.GetItem(1)
MyRow.MinimumHeight = 1440 ' 1 inch
MyRow.AllowPageBreak = False
MyRow.CellFormat = MyCellFormat

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.AllowPageBreak Property

Gets or sets a value specifying how the table row is formatted at page breaks. The property value is True, if the table row can be formatted across page breaks. The property value is False, if the table row must not be formatted across page breaks.

Introduced: 12.0.

Syntax

[C#]
public bool AllowPageBreak { get; set; }
[Visual Basic]
Public Property AllowPageBreak() As Boolean

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.CellFormat Property

Gets or sets the formatting attributes of a table row. The property's value is an object of the type TableCellFormat.

Syntax

[C#]
public TableCellFormat CellFormat { get; set; }
[Visual Basic]
Public Property CellFormat() As TableCellFormat

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.IsHeader Property

Gets or sets a value specifying whether the table row is part of the table's header. The property value is true, if the table row belongs to the header. Otherwise, it is false. A table header consists of one or more table rows which are repeated on top of each page when a single table extends over several pages.

Introduced: 16.0.

Syntax

[C#]
public bool IsHeader { get; set; }
[Visual Basic]
Public Property IsHeader() As Boolean

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.MinimumHeight Property

Gets or sets the minimum height, in twips, of the table row. The table row is formatted with this height if the text is smaler. Otherwise the row grows as necessary. If the property value is zero, the table row's height is always determined through the containing text.

Introduced: 12.0.

Syntax

[C#]
public int MinimumHeight { get; set; }
[Visual Basic]
Public Property MinimumHeight() As Integer

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.Row Property

Gets the number of the table row represented through this table row object.

Syntax

[C#]
public int Row { get; }
[Visual Basic]
Public ReadOnly Property Row() As Integer

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRow.Select Method

Selects the table row.

Introduced: 10.1.

Syntax

[C#]
public void Select();
[Visual Basic]
Public Sub Select()

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection Class

An instance of the TableRowCollection class contains all rows of a table in a Text Control document represented through objects of the type TableRow. It can be obtained with the Table.Rows property. The TableRowCollection class implements the IEnumerable and the ICollection interfaces.

Syntax

[C#]
public sealed class TableRowCollection: TablePartCollection
[Visual Basic]
Public NotInheritable Class TableRowCollection
  Inherits TablePartCollection

Properties

Property | Description
CanAdd | Gets a value indicating whether a new row can be inserted at the current input position.
CanRemove | Gets a value indicating whether selected rows can be removed.
Count | Gets the number of elements contained in the collection. (Inherited from TablePartCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TablePartCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TablePartCollection.)

Methods

Method | Description
Add | Adds new table rows at the current text input position.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TablePartCollection.)
GetItem | Overloaded. Gets a particular table row from the collection.
Remove | Removes the selected table rows or the row at the current text input position.

Example

The following example shows how to handle the table row collection.

[C#]
int myLastRow = myTable.Rows.Count;
TXTextControl.TableRow myRow = myTable.Rows.GetItem(myLastRow);
myRow.Select();

if(myTable.Rows.CanRemove)
  myTable.Rows.Remove();
[Visual Basic]
Dim MyLastRow As Integer = myTable.Rows.Count
Dim MyRow As TXTextControl.TableRow = MyTable.Rows.GetItem(MyLastRow)
MyRow.Select()

If MyTable.Rows.CanRemove Then
  MyTable.Rows.Remove()
End If

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.Add Method

Adds new table rows at the current text input position.

Syntax

[C#]
public bool Add(TableAddPosition position, int count);
[Visual Basic]
Public Function Add(ByVal position As TableAddPosition, ByVal count As Integer) As Boolean
Parameter Description
position

Specifies the position where to add the rows. It can be one of the TableAddPosition values:

Value | Meaning
Before | The rows are inserted in front of the row with the current input position.
After | The rows are inserted behind the row with the current input position.
count

Specifies the number of rows to add.

Return Value

The return value is true, if the rows could be added. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.CanAdd Property

Gets a value indicating whether a new row can be inserted at the current input position.

Syntax

[C#]
public bool CanAdd { get; }
[Visual Basic]
Public ReadOnly Property CanAdd() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.CanRemove Property

Gets a value indicating whether selected rows can be removed.

Syntax

[C#]
public bool CanRemove { get; }
[Visual Basic]
Public ReadOnly Property CanRemove() As Boolean

Limitations

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.GetItem Method

Gets a particular table row from the collection.

GetItem()

Gets the table row at the current input position.

[C#]
public TableRow GetItem();
[Visual Basic]
Public Function GetItem() As TableRow

GetItem(Int32)

Gets the table row with the specified number.

[C#]
public TableRow GetItem(int row);
[Visual Basic]
Public Function GetItem(ByVal row As Integer) As TableRow
Parameter | Description
row | Specifies the row number. It must be between 1 and the value returned through the collection's Count property.

Return Value

The return value is the requested row. It is null if the requested row could not be found.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TableRowCollection.Remove Method

Removes the selected table rows or the row at the current text input position.

Syntax

[C#]
public bool Remove();
[Visual Basic]
Public Function Remove() As Boolean

Return Value

The return value is true, if the rows could be removed. Otherwise it is false.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextChar Class

An instance of the TextChar class represents a single character in a Text Control document.

Introduced: 10.1.

Syntax

[C#]
public class TextChar
[Visual Basic]
# Public Class TextChar

Properties

Property | Description
Bounds | Gets the bounding rectangle of the character.
Char | Gets the value of the character.
Number | Gets the character's number.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextChar.Bounds Property

Gets the bounding rectangle of the character. The values are given in twips with an origin at the upper left corner of the document. The relationship between the upper left corner of the document and the upper left corner of the visible portion of the document can be obtained with the TextControl.ScrollLocation property.

Syntax

[C#]
public Rectangle Bounds { get; }
[Visual Basic]
Public ReadOnly Property Bounds() As Rectangle

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextChar.Char Property

Gets the value of the character.

Syntax

[C#]
public char Char { get; }
[Visual Basic]
Public ReadOnly Property [Char]() As Char

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextChar.Number Property

Gets the character's number. The first character has the number 1.

Syntax

[C#]
public int Number { get; }
[Visual Basic]
Public ReadOnly Property Number() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection Class

An instance of the TextCharCollection class contains all characters in a Text Control document or part of the document represented through objects of the type TextChar. An instance of this class can be obtained with the TextControl.TextChars, HeaderFooter.TextChars or TextFrame.TextChars property. The TextCharCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 10.1.

Syntax

[C#]
public class TextCharCollection : ICollection, IEnumerable
[Visual Basic]
Public Class TextCharCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
Add | Overloaded. Adds a character to the document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Gets a particular character from the collection specified through a certain geometrical position.
Item | Gets the character from the collection.
Remove | Removes a character from a Text Control document.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.Add Method

Adds a character to the document.

Introduced: 23.0.

Add(Char)

Inserts a character at the current text input position.

[C#]
public bool Add(char character);
[Visual Basic]
Public Function Add(character As Char) As Boolean
Member | Description
character | Specifies the character to insert.

Add(Char, String)

Inserts a character at the current text input position using the specified font.

[C#]
public bool Add(char character, string fontName);
[Visual Basic]
Public Function Add(character As Char, fontName As String) As Boolean
Member | Description
character | Specifies the character to insert.
fontName | Specifies the name of the font which is used for the specified character.

Add(Char, String, Int32)

Inserts a character at the specified position using the specified font.

[C#]
public bool Add(char character, string fontName, int textPosition);
[Visual Basic]
Public Function Add(character As Char, fontName As String, textPosition As Integer) As Boolean
Member | Description
character | Specifies the character to insert.
fontName | Specifies the name of the font which is used for the specified character.
textPosition | Specifies a text input position. The first input position in a document is 0.

Add(ControlChars)

Inserts a control character at the current text input position.

[C#]
public bool Add(ControlChars controlChar);
[Visual Basic]
Public Function Add(controlChar As ControlChars) As Boolean
Member | Description
controlChar | Specifies a control character to insert. It can be one of the ControlChars values.

Add(ControlChars, Int32)

Inserts a control character at the specified text input position.

[C#]
public bool Add(ControlChars controlChar, int textPosition);
[Visual Basic]
Public Function Add(controlChar As ControlChars, textPosition As Integer) As Boolean
Member | Description
controlChar | Specifies a control character to insert. It can be one of the ControlChars values.
textPosition | Specifies a text input position. The first input position in a document is 0.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.GetItem Method

Gets a particular character from the collection specified through a certain geometrical position.

Syntax

[C#]
public TextChar GetItem(System.Drawing.Point location, bool getNearest);
[Visual Basic]
Public Function GetItem(ByVal location As System.Drawing.Point, ByVal getNearest As Boolean) As TextChar
Parameter | Description
location | Specifies the character's location. The point must be specified in pixels with an origin at the top left corner of the control.
getNearest | Specifies whether the nearest character is returned. If this parameter is set to true, the nearest character is returned. Otherwise, if set to false, a character is only returned, if the specified location is inside the bounding rectangle of an existing character.

Return Value

The return value is null, if a character could not be found. Otherwise, it is an object of the type TextChar.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.Item Property

Gets the character from the collection. In C# this property is the indexer for the TextCharCollection class.

Syntax

[C#]
public TextChar this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal number As Integer) As TextChar
Parameter | Description
number | Specifies a character number. The first character has the number 1.

Return Value

The return value is null, if the character could not be found. Otherwise, it is an object of the type TextChar.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextCharCollection.Remove Method

Removes a character from a Text Control document. The method can also be used to remove control characters. Single control characters which are important for other formatting attributes, i.e. a table cell end character, cannot be removed through this method.

Introduced: 23.0.

Syntax

[C#]
public bool Remove(TextChar textChar);
[Visual Basic]
Public Function Remove(ByVal textChar As TextChar) As Boolean
Parameter | Description
textChar | Specifies the character to remove.

Return Value

The return value is true, if the character could be removed. Otherwise, it is false.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextContextMenuEventArgs Class

The TextContextMenuEventArgs class provides data for the TextControl.TextContextMenuOpening event of a Windows Forms TextControl. This event occurs, immediately before a built-in context menu will be opened. A TextControl provides context menus for different parts of a document. The ContextMenuLocation property informs for which part the menu will be opened. The pre-defined menu provided with the TextContextMenu property can be altered or expanded.

Introduced: 19.0.

Syntax

[C#]
public class TextContextMenuEventArgs: CancelEventArgs
[Visual Basic]
Public Class TextContextMenuEventArgs
  Inherits EventArgs

Properties

Property | Description
ContextMenuLocation | Gets the location in the document for which the context menu will be opened.
Location | Gets the location, in pixels, where the context menu is displayed.
TextContextMenu | Gets or sets the context menu, which will be shown.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextContextMenuEventArgs.ContextMenuLocation Property

Gets the location in the document for which the context menu will be opened. The context menu items, which will be shown, depend on this location. The property value can be a combination (bitwise or) of the ContextMenuLocation values.

Syntax

[C#]
public ContextMenuLocation ContextMenuLocation { get; }
[Visual Basic]
Public ReadOnly Property ContextMenuLocation() As ContextMenuLocation

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextContextMenuEventArgs.Location Property

Gets the location, in pixels, where the context menu is displayed. The coordinates are relative to the top-left corner of the screen.

Syntax

[C#]
public System.Drawing.Point Location { get; }
[Visual Basic]
Public ReadOnly Property Location() As System.Drawing.Point

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextContextMenuEventArgs.TextContextMenu Property

Gets or sets the context menu, which will be shown. The items depend on the document location where the mouse click occurs. The menu can be altered, extended or completely replaced. When this property is set to null, the TextControl uses system menu items. To completely suppress a context menu, the Cancel Property must be set the true.

Syntax

[C#]
public System.Windows.Forms.ContextMenuStrip TextContextMenu { get; set; }
[Visual Basic]
Public Property TextContextMenu() As System.Windows.Forms.ContextMenuStrip

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl Class

The TextControl class implements a Windows Forms control with high-level text editing features. It is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the TextControl class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference. The TextControl class implements the IFormattedText interface.

Syntax

[C#]
public class TextControl : Control, IFormattedText
[Visual Basic]
Public Class TextControl
  Inherits Control
  Implements IFormattedText

Constructors

Constructor | Description
TextControl | Initializes a new instance of the TextControl class.

Properties

Property | Description
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order.
AllowDrag | Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation.
AllowDrop | Overridden. Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowUndo | Gets or sets a value indicating whether the undo buffer is active or not.
ApplicationFields | Gets a collection of all application fields contained in the text part with the input focus.
AutoControlSize | Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text.
BackColor | Overridden. Gets or sets the background color of the control.
BackgroundStyle | Defines the kind of view to display the page background.
Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.
Baseline | Gets or sets the baseline alignment, in twips, of the Text Control.
BorderStyle | Gets or sets the border type of the Text Control.
ButtonBar | Specifies the button bar control to be used with a TextControl.
CanCopy | Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.
CanPaste | Informs whether the clipboard contains a format that can be pasted into a Text Control document.
CanRedo | Informs whether an operation can be re-done using the Redo method.
CanUndo | Gets a value indicating whether the user can undo the previous operation in a Text Control.
CaretWidth | Gets or sets the width of the caret in pixels.
Charts | Gets a collection of all charts contained in the text part with the input focus.
ControlChars | Specifies if control characters are visible or not.
DisplayColors | Gets or sets the colors of the text control.
DocumentLinks | Gets a collection of all document links contained in the text part with the input focus.
DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.
DocumentTargets | Gets a collection of all targets contained in the text part with the input focus.
DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
Drawings | Gets a collection of all drawings contained in the text part with the input focus.
DropFormats | Gets or sets the formats of data the control can accept when the user drags it onto the control.
EditMode | Gets or sets a value indicating whether the document's text is read-only, can be selected or is editable.
FieldCursor | Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.
FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
FontUnderlineStyle | Gets or sets underlining style for the text displayed by the control.
ForeColor | Overridden. Gets or sets the foreground color of the control which is the color of the document's text.
FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
Frames | Gets a collection of all images, textframes, charts, barcodes and drawings contained in the text part with the input focus.
GetPages | Gets a collection of all pages in the document.
HeaderFooterActivationStyle | Gets or sets a value specifying the activation style for headers and footers.
HeaderFooterFrameStyle | Gets or sets a value specifying the frame for activated headers and footers.
HeadersAndFooters | Gets a collection of all headers and footers the current document contains.
HideSelection | Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.
HypertextLinks | Gets a collection of all hypertext links contained in the text part with the input focus.
Images | Gets a collection of all images contained in the text part with the input focus.
InlineStyles | Gets a collection of all inline styles the current document contains.
InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
InputPosition | Gets or sets the current text input position.
InsertionMode | Specifies whether text is inserted or overwrites existing text.
IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
Lines | Gets a collection of all lines contained in the text part with the input focus.
ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.
MisspelledWords | Gets a collection of all misspelled words contained in the text part with the input focus.
PageMargins | Gets or sets the margins for the pages of the current document.
Pages | Gets the number of pages contained in the current document.
PageSize | Specifies the width and height of the pages for the current document.
PageUnit | Gets or sets the measure used for page sizes and page margins.
ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.
Paragraphs | Gets a collection of all paragraphs contained in the text part with the input focus.
ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
Ribbon | Specifies the ribbon control to be used with a TextControl.
RulerBar | Specifies the horizontal ruler bar control to be used with a TextControl.
ScrollBars | Gets or sets a value indicating whether a Text Control has horizontal or vertical scroll bars.
ScrollLocation | Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.
Sections | Gets a collection of all sections in the document.
Selection | Gets or sets the current selection in the text part with the input focus.
SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.
SpellCheckContextMenuStrip | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
SpellChecker | Specifies the spell checking component to be used with a TextControl.
StatusBar | Specifies the status bar control to be used with a TextControl.
SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.
Tables | Gets a collection of all tables contained in the text part with the input focus.
TextBackColor | Gets or sets the background color for the text.
TextChars | Gets a collection of all characters contained in the text part with the input focus.
TextFields | Gets a collection of all standard text fields contained in the text part with the input focus.
TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TextFrames | Gets a collection of all text frames contained in the text part with the input focus.
TextParts | Gets a collection of all main text parts the current document contains.
UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.
VerticalRulerBar | Specifies the vertical ruler bar control to be used with a TextControl.
ViewMode | Gets or sets the mode in which Text Control displays its contents.
XmlEditMode | Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.
ZoomFactor | Gets or sets the zoom factor, in percent, for a Text Control.

Methods

Method | Description
AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
Append | Overloaded. Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
BarcodeLayoutDialog | Overloaded. Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
BeginUndoAction | Begins a user-defined undo operation.
ChartLayoutDialog | Overloaded. Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a chart.
Clear | Clears the selected text or the character right from the current input position from the Text Control.
ClearUndo | Clears the undo buffer of the Text Control.
Copy | Copies the current selection in the Text Control to the Clipboard.
Cut | Moves the current selection in the Text Control to the Clipboard.
DrawingLayoutDialog | Overloaded. Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
EndUndoAction | Ends a user-defined undo operation.
Find | Overloaded. Finds a text string in the text part with the input focus.
FontDialog | Invokes the built-in font dialog box.
ForeColorDialog | Invokes the built-in dialog box for setting the text color.
FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
GetClipboardFormats | Returns an array of ClipboardFormat values.
GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
GetTextFields | Returns a collection containing text fields of the specified types.
GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
GetXmlElements | Returns a collection of XML elements.
ImageAttributesDialog | Overloaded. Invokes the built-in dialog box for setting attributes of images.
LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.
Load | Overloaded. Loads text in a certain format.
OnAcceptsTabChanged | Raises the AcceptsTabChanged event.
OnAdaptFont | Raises the AdaptFont event.
OnBarcodeClicked | Raises the BarcodeClicked event.
OnBarcodeCreated | Raises the BarcodeCreated event.
OnBarcodeDeleted | Raises the BarcodeDeleted event.
OnBarcodeDeselected | Raises the BarcodeDeselected event.
OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
OnBarcodeMoved | Raises the BarcodeMoved event.
OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
OnBarcodeSelected | Raises the BarcodeSelected event.
OnBarcodeSized | Raises the BarcodeSized event.
OnBorderStyleChanged | Raises the BorderStyleChanged event.
OnChanged | Raises the Changed event.
OnCharFormatChanged | Raises the CharFormatChanged event.
OnChartClicked | Raises the ChartClicked event.
OnChartCreated | Raises the ChartCreated event.
OnChartDeleted | Raises the ChartDeleted event.
OnChartDeselected | Raises the ChartDeselected event.
OnChartDoubleClicked | Raises the ChartDoubleClicked event.
OnChartMoved | Raises the ChartMoved event.
OnChartRightClicked | Raises the ChartRightClicked event.
OnChartSelected | Raises the ChartSelected event.
OnChartSized | Raises the ChartSized event.
OnDocumentLinkClicked | Raises the DocumentLinkClicked event.
OnDocumentLoaded | Raises the DocumentLoaded event.
OnDrawingActivated | Raises the DrawingActivated event.
OnDrawingClicked | Raises the DrawingClicked event.
OnDrawingCreated | Raises the DrawingCreated event.
OnDrawingDeactivated | Raises the DrawingDeactivated event.
OnDrawingDeleted | Raises the DrawingDeleted event.
OnDrawingDeselected | Raises the DrawingDeselected event.
OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
OnDrawingMoved | Raises the DrawingMoved event.
OnDrawingRightClicked | Raises the DrawingRightClicked event.
OnDrawingSelected | Raises the DrawingSelected event.
OnDrawingSized | Raises the DrawingSized event.
OnFontChanged | Overridden. See Control.OnFontChanged.
OnFormattingStyleListChanged | Raises the FormattingStyleListChanged event.
OnFrameClicked | Raises the FrameClicked event.
OnFrameDeselected | Raises the FrameDeselected event.
OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
OnFrameMoved | Raises the FrameMoved event.
OnFrameRightClicked | Raises the FrameRightClicked event.
OnFrameSelected | Raises the FrameSelected event.
OnFrameSized | Raises the FrameSized event.
OnHandleCreated | Overridden. See Control.OnHandleCreated.
OnHeaderFooterActivated | Raises the HeaderFooterActivated event.
OnHeaderFooterDeactivated | Raises the HeaderFooterDeactivated event.
OnHExpanded | Raises the HExpanded event.
OnHScroll | Raises the HScroll event.
OnHShrunk | Raises the HShrunk event.
OnHypertextLinkClicked | Raises the HypertextLinkClicked event.
OnHyphenateWord | Raises the HyphenateWord event.
OnImageClicked | Raises the ImageClicked event.
OnImageCreated | Raises the ImageCreated event.
OnImageDeleted | Raises the ImageDeleted event.
OnImageDeselected | Raises the ImageDeselected event.
OnImageDoubleClicked | Raises the ImageDoubleClicked event.
OnImageMoved | Raises the ImageMoved event.
OnImageRightClicked | Raises the ImageRightClicked event.
OnImageSelected | Raises the ImageSelected event.
OnImageSized | Raises the ImageSized event.
OnInputFormattingStyleChanged | Raises the InputFormattingStyleChanged event.
OnInputParagraphChanged | Raises the InputParagraphChanged event.
OnInputPositionChanged | Raises the InputPositionChanged event.
OnPageChanged | Raises the PageChanged event.
OnPageFormatChanged | Raises the PageFormatChanged event.
OnParagraphFormatChanged | Raises the ParagraphFormatChanged event.
OnSectionChanged | Raises the SectionChanged event.
OnSpellCheckText | Raises the SpellCheckText event.
OnSubTextPartClicked | Raises the SubTextPartClicked event.
OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
OnSubTextPartEntered | Raises the SubTextPartEntered event.
OnSubTextPartLeft | Raises the SubTextPartLeft event.
OnTableCreated | Raises the TableCreated event.
OnTableDeleted | Raises the TableDeleted event.
OnTableFormatChanged | Raises the TableFormatChanged event.
OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
OnTextFieldChanged | Raises the TextFieldChanged event.
OnTextFieldClicked | Raises the TextFieldClicked event.
OnTextFieldCreated | Raises the TextFieldCreated event.
OnTextFieldDeleted | Raises the TextFieldDeleted event.
OnTextFieldDoubleClicked | Raises the TextFieldDoubleClicked event.
OnTextFieldEntered | Raises the TextFieldEntered event.
OnTextFieldLeft | Raises the TextFieldLeft event.
OnTextFrameActivated | Raises the TextFrameActivated event.
OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.
OnTextFrameClicked | Raises the TextFrameClicked event.
OnTextFrameCreated | Raises the TextFrameCreated event.
OnTextFrameDeactivated | Raises the TextFrameDeactivated event.
OnTextFrameDeleted | Raises the TextFrameDeleted event.
OnTextFrameDeselected | Raises the TextFrameDeselected event.
OnTextFrameDoubleClicked | Raises the TextFrameDoubleClicked event.
OnTextFrameMoved | Raises the TextFrameMoved event.
OnTextFrameRightClicked | Raises the TextFrameRightClicked event.
OnTextFrameSelected | Raises the TextFrameSelected event.
OnTextFrameSized | Raises the TextFrameSized event.
OnVExpanded | Raises the VExpanded event.
OnVScroll | Raises the VScroll event.
OnVShrunk | Raises the VShrunk event.
OnXmlInvalid | Raises the XmlInvalid event.
OnXmlNotWellFormed | Raises the XmlNotWellFormed event.
OnZoomed | Raises the Zoomed event.
PageColorDialog | Invokes the built-in dialog box for setting the page color.
ParagraphFormatDialog | Overloaded. Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
Paste | Overloaded. Replaces the current selection in the Text Control with the contents of the Clipboard.
Print | Overloaded. Prints a Text Control document or a part of a document.
PrintPreview | Overloaded. Shows a print preview of the current document.
Redo | Redoes the last Text Control operation.
Replace | Opens the built-in Replace dialog box.
ResetAutoControlSize | Resets the AutoControlSize property to its default values.
ResetBackColor | Overridden. Resets the BackColor property to its default value.
ResetContents | Deletes the entire contents of a Text Control.
ResetCursor | Overridden. Resets the Cursor property to its default value.
ResetDisplayColors | Resets all display colors of a text control to their system dependent default values.
ResetFieldCursor | Resets the FieldCursor property to its default value.
ResetForeColor | Overridden. Resets the ForeColor property to its default value.
ResetPageMargins | Resets the PageMargins property to its default value.
ResetPageSize | Resets the PageSize property to its default value.
ResetTextBackColor | Resets the TextBackColor property to its default value.
Save | Overloaded. Saves the complete contents of a document with the specified format.
SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.
Select | Selects text within the Text Control.
SelectAll | Selects all text in the Text Control.
SpellCheckDialog | Overloaded. Invokes the built-in dialog box for correcting misspelled words.
TabDialog | Invokes the built-in dialog box for setting tabs.
TableFormatDialog | Overloaded. Invokes the built-in dialog box for setting formatting attributes of tables.
TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TextFrameAttributesDialog | Overloaded. Invokes the built-in dialog box for setting attributes of text frames.
Undo | Undoes the last edit operation in the Text Control.
Zoom | Overloaded. Zooms the contents of the TextControl.

Events

Event | Description
AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed.
AdaptFont | Occurs for each font that must be adapted, because it is not supported.
BarcodeClicked | Occurs when a barcode has been clicked on.
BarcodeCreated | Occurs when a new barcode has been created.
BarcodeDeleted | Occurs when a barcode has been deleted.
BarcodeDeselected | Occurs when a barcode has been deselected.
BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
BarcodeMoved | Occurs when a barcode has been moved.
BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
BarcodeSelected | Occurs when a barcode has been selected.
BarcodeSized | Occurs when a barcode has been sized.
BorderStyleChanged | Occurs when the value of the BorderStyle property has changed.
Changed | Indicates that the contents of a document have been changed.
CharFormatChanged | Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed.
ChartClicked | Occurs when a chart has been clicked on.
ChartCreated | Occurs when a new chart has been created.
ChartDeleted | Occurs when a chart has been deleted.
ChartDeselected | Occurs when a chart has been deselected.
ChartDoubleClicked | Occurs when a chart has been doubleclicked on.
ChartMoved | Occurs when a chart has been moved.
ChartRightClicked | Occurs when a chart has been clicked on with the right mouse button.
ChartSelected | Occurs when a chart has been selected.
ChartSized | Occurs when a chart has been sized.
DocumentLinkClicked | Occurs when a text field has been clicked on that represents a link to a target in the document.
DocumentLoaded | Occurs when a new document has been loaded.
DrawingActivated | Occurs when a drawing has been activated.
DrawingClicked | Occurs when a drawing has been clicked on.
DrawingCreated | Occurs when a new drawing has been created.
DrawingDeactivated | Occurs when a drawing has been deactivated.
DrawingDeleted | Occurs when a drawing has been deleted.
DrawingDeselected | Occurs when a drawing has been deselected.
DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
DrawingMoved | Occurs when a drawing has been moved.
DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
DrawingSelected | Occurs when a drawing has been selected.
DrawingSized | Occurs when a drawing has been sized.
FormattingStyleListChanged | Occurs after one or more formatting styles have been added or removed.
FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
HeaderFooterActivated | Occurs when a header or footer has been activated.
HeaderFooterDeactivated | Occurs when a header or footer has been deactivated.
HExpanded | Occurs when the Text Control has automatically expanded its size horizontally.
HScroll | Occurs when the horizontal scroll position has been changed.
HShrunk | Occurs when the Text Control has automatically shrunk its size horizontally.
HypertextLinkClicked | Occurs when a text field has been clicked on that represents the source of a hypertext link.
HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.
ImageClicked | Occurs when an image has been clicked on.
ImageCreated | Occurs when a new image has been created.
ImageDeleted | Occurs when an image has been deleted.
ImageDeselected | Occurs when an image has been deselected.
ImageDoubleClicked | Occurs when an image has been doubleclicked on.
ImageMoved | Occurs when an inserted image has been moved.
ImageRightClicked | Occurs when an image has been clicked on with the right mouse button.
ImageSelected | Occurs when an image has been selected.
ImageSized | Occurs when an inserted image has been sized.
InputFormattingStyleChanged | Occurs after the text input position has been moved to a text part formatted with another style.
InputParagraphChanged | Occurs when the text input position has been moved to another paragraph.
InputPositionChanged | Occurs when the text input position has been changed.
PageChanged | Occurs when the text input position has been moved to another page.
PageFormatChanged | Occurs when the page format settings have been changed.
ParagraphFormatChanged | Occurs when the formatting attributes of the selected paragraphs have been changed.
SectionChanged | Occurs when the text input position has been moved to another section.
SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
SubTextPartClicked | Occurs when a subtextpart has been clicked on.
SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TableCreated | Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier.
TableDeleted | Occurs after a table has been deleted.
TableFormatChanged | Occurs when the design attributes of a selected table have been changed.
TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TextFieldChanged | Occurs when the text of a text field has been changed.
TextFieldClicked | Occurs when a text field has been clicked on.
TextFieldCreated | Occurs when a text field has been pasted from the clipboard.
TextFieldDeleted | Occurs when a text field has been deleted.
TextFieldDoubleClicked | Occurs when a text field has been double-clicked on.
TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TextFieldLeft | Occurs when the current input position has left a text field.
TextFrameActivated | Occurs when a text frame has been activated.
TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.
TextFrameClicked | Occurs when a text frame has been clicked on.
TextFrameCreated | Occurs when a new text frame has been created.
TextFrameDeactivated | Occurs when a text frame has been deactivated.
TextFrameDeleted | Occurs when a text frame has been deleted.
TextFrameDeselected | Occurs when a text frame has been deselected.
TextFrameDoubleClicked | Occurs when a text frame has been doubleclicked on.
TextFrameMoved | Occurs when a text frame has been moved.
TextFrameRightClicked | Occurs when a text frame has been clicked on with the right mouse button.
TextFrameSelected | Occurs when a text frame has been selected.
TextFrameSized | Occurs when a text frame has been sized.
VExpanded | Occurs when the Text Control has automatically expanded its size vertically.
VScroll | Occurs when the vertical scroll position has been changed.
VShrunk | Occurs when the Text Control has automatically shrunk its size vertically.
XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.
Zoomed | Occurs when the Text Control has been zoomed.


TXTextControl.TextControl Constructor

Initializes a new instance of the TextControl class.

Syntax

[C#]
public TextControl();
[Visual Basic]
Public Sub New()


TXTextControl.TextControl.AcceptsTab Property

Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order.

Syntax

[C#]
public bool AcceptsTab { get; set; }
[Visual Basic]
Public Property AcceptsTab() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.AcceptsTabChanged Event

Occurs when the value of the AcceptsTab property has changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler AcceptsTabChanged;
[Visual Basic]
Public Event AcceptsTabChanged As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.AdaptFont Event

Occurs for each font that must be adapted, because it is not supported. The event can occur, if another printer is set with the TextControl.FormattingPrinter property, if a document is loaded that contains a font which is not supported, or if fonts have been restricted with the FontSettings.EmbeddableFontsOnly or the FontSettings.TrueTypeFontsOnly property. The event occurs only, if the FontSettings.AdaptFontEvent property has been set to true. The event handler receives an argument of type AdaptFontEventArgs containing data related to this event.

Introduced: 15.0.

Syntax

[C#]
public event AdaptFontEventHandler AdaptFont;
[Visual Basic]
Public Event AdaptFont As AdaptFontEventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.AddSymbolDialog Method

Invokes a built-in dialog box for inserting symbol characters.

Introduced: 23.0.

Syntax

[C#]
public void AddSymbolDialog();
[Visual Basic]
Public Sub AddSymbolDialog()

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.AllowDrag Property

Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation. To allow the control to accept data that the user drags onto it, the TextControl.AllowDrop property must be set to true.

Introduced: 15.1.

Syntax

[C#]
public bool AllowDrag { get; set; }
[Visual Basic]
Public Property AllowDrag() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.AllowDrop Property

Overridden. Gets or sets a value indicating whether the control can accept data that the user drags onto it. This property allows the control to be a target for drop operations. To allow the control to be a source of a Drag&Drop operation the TextControl.AllowDrag property must be set to true. The TextControl.DropFormats property determines which formats the control accepts automatically.

Introduced: 15.1.

Syntax

[C#]
public bool AllowDrop { get; set; }
[Visual Basic]
Public Property AllowDrop() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.AllowUndo Property

Gets or sets a value indicating whether the undo buffer is active or not. If a Text Control is used for tasks like generating reports it can be useful to deactivate the undo buffer to save time and memory.

Introduced: 11.0.

Syntax

[C#]
public bool AllowUndo { get; set; }
[Visual Basic]
Public Property AllowUndo() As Boolean

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.Append Method

Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.

Introduced: 14.0.

Append(AppendSettings)

Opens a file open dialogbox and appends the selected file to the existing document.

[C#]
public DialogResult Append(AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(StreamType, AppendSettings)

Opens a file open dialogbox and appends the selected file with the specified format to the existing document.

[C#]
public DialogResult Append(StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal streamType As StreamType, ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StreamType, AppendSettings)

Loads text with the specified format from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, AppendSettings)

Loads text with the specified format from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, AppendSettings)

Loads text with the specified format from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal appendSettings As AppendSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StringStreamType, AppendSettings)

Loads text with the specified format from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(StreamType, LoadSettings, AppendSettings)

Opens a file open dialogbox and appends the selected file with the specified format and special settings to the existing document.

[C#]
public DialogResult Append(StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, LoadSettings)

Loads text with the specified format and special settings from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Append(String, StringStreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Return Value

The implementations that open a dialog box return the dialog's result value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.ApplicationFields Property

Gets a collection of all application fields contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. Application fields are Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set, otherwise this collection is empty. The collection contains the fields of the text part with the input focus. This can be the main text, a text frame or a header or footer.

Introduced: 14.0.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.AutoControlSize Property

Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text. These features are only possible, if the TextControl.ViewMode property has been set to SimpleControl. The property value is an object of the type AutoSize.

Introduced: 11.0.

Syntax

[C#]
public AutoSize AutoControlSize { get; set; }
[Visual Basic]
Public Property AutoControlSize() As AutoSize

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.BackColor Property

Overridden. Gets or sets the background color of the control. The property value can be set to Color.Transparent to have a transparent background. A transparent background is only possible if the ViewMode property has been set to SimpleControl. A TextControl uses the ControlStyles.SupportsTransparentBackColor style to enable transparency. This style shows the contents of the control's parent in the control's background. If there is another control between the control and its parent, the TextControl will not show the control in the middle. See the description of the ControlStyles enumeration in the .net Framework documentation.

Syntax

[C#]
public override Color BackColor { get; set; }
[Visual Basic]
Public Overloads Overrides Property BackColor() As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.BackgroundStyle Property

Defines the kind of view to display the page background. The settings have only effect, if the ViewMode property has been set to PageView.

Introduced: 14.0.

Syntax

[C#]
public BackgroundStyle BackgroundStyle { get; set; }
[Visual Basic]
Public Property BackgroundStyle() As BackgroundStyle
Value | Description
ColorScheme | The page background colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
ClassicColors | The page background color is dark gray.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.BarcodeClicked Event

Occurs when a barcode has been clicked on. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeClicked;
[Visual Basic]
Public Event BarcodeClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeCreated Event

Occurs when a new barcode has been created. It occurs, when a barcode has been inserted in the document via the clipboard and when a file containing barcodes has been loaded. It does not occur, when a barcode has been added with the BarcodeCollection.Add method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeCreated;
[Visual Basic]
Public Event BarcodeCreated As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeDeleted Event

Occurs when a barcode has been deleted. It occurs, when a barcode has been deleted while editing a document and when a barcode has been deleted with the BarcodeCollection.Remove method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeleted;
[Visual Basic]
Public Event BarcodeDeleted As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeDoubleClicked Event

Occurs when a barcode has been doubleclicked on. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDoubleClicked;
[Visual Basic]
Public Event BarcodeDoubleClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeMoved Event

Occurs when a barcode has been moved. It does not occur, if an inline or anchored barcode has been moved because text has been inserted. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeMoved;
[Visual Basic]
Public Event BarcodeMoved As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeRightClicked Event

Occurs when a barcode has been clicked on with the right mouse button. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeRightClicked;
[Visual Basic]
Public Event BarcodeRightClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeSelected Event

Occurs when a barcode has been selected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeSelected;
[Visual Basic]
Public Event BarcodeSelected As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeDeselected Event

Occurs when a barcode has been deselected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeselected;
[Visual Basic]
Public Event BarcodeDeselected As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeLayoutDialog Method

Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode. This dialog can only be invoked, if a barcode has been selected.

Introduced: 19.0.

BarcodeLayoutDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult BarcodeLayoutDialog();
[Visual Basic]
Public Function BarcodeLayoutDialog() As DialogResult

BarcodeLayoutDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult BarcodeLayoutDialog(int activeTab);
[Visual Basic]
Public Function BarcodeLayoutDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further barcode attributes such as fore- and background color and the barcode's type and text.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Barcodes Property

Gets a collection of all barcodes contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from a document.

Introduced: 19.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.BarcodeSized Event

Occurs when a barcode has been sized. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeSized;
[Visual Basic]
Public Event BarcodeSized As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.Baseline Property

Gets or sets the baseline alignment, in twips, of the Text Control. Positive values moves the baseline to superscript, negative values moves the baseline to subscript.

Syntax

[C#]
public int Baseline { get; set; }
[Visual Basic]
Public Property Baseline() As Integer

Limitations

The property's value must be between -960 twips and 960 twips (48 pt).

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.BeginUndoAction Method

Begins a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step. The specified user-defined name is available with the UndoActionName property.

Introduced: 23.0.

Syntax

[C#]
public void BeginUndoAction(string actionName);
[Visual Basic]
Public Sub BeginUndoAction(ByVal actionName As String)
Parameter | Description
actionName | Specifies the undo action's name. If an action name is not necessary, this parameter can be null or an empty string.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.BorderStyle Property

Gets or sets the border type of the Text Control.

Syntax

[C#]
public BorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle() As BorderStyle
Value | Description
None | The Text Control has no border.
FixedSingle | The Text Control has a border with a single line.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.BorderStyleChanged Event

Occurs when the value of the BorderStyle property has changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler BorderStyleChanged;
[Visual Basic]
Public Event BorderStyleChanged As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ButtonBar Property

Specifies the button bar control to be used with a TextControl. The property value is null if there is no button bar connected. Otherwise it is an object of the type ButtonBar.

Syntax

[C#]
public ButtonBar ButtonBar { get; set; }
[Visual Basic]
Public Property ButtonBar() As ButtonBar

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.TextControl.CanCopy Property

Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.

Syntax

[C#]
public bool CanCopy { get; }
[Visual Basic]
Public ReadOnly Property CanCopy() As Boolean

Limitations

Runtime only.

Read only.

Example

The following XAML example shows how to bind the CanCopy property to the IsEnabled attribute of a menu item.

<MenuItem
   Header="Copy"
   Command="ApplicationCommands.Copy"
   IsEnabled="{Binding ElementName=textControl1, Path=CanCopy}" />

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.CanPaste Property

Informs whether the clipboard contains a format that can be pasted into a Text Control document.

Syntax

[C#]
public bool CanPaste { get; }
[Visual Basic]
Public ReadOnly Property CanPaste() As Boolean

Limitations

Runtime only.

Read only.

Example

The following XAML example shows how to bind the CanPaste property to the IsEnabled attribute of a menu item.

<MenuItem
   Header="Paste"
   Command="ApplicationCommands.Paste"
   IsEnabled="{Binding ElementName=textControl1, Path=CanPaste}" />

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.CanRedo Property

Informs whether an operation can be re-done using the Redo method.

Syntax

[C#]
public bool CanRedo { get; }
[Visual Basic]
Public ReadOnly Property CanRedo() As Boolean

Limitations

Runtime only.

Read only.

Example

The following XAML example shows how to bind the CanRedo property to the IsEnabled attribute of a menu item.

<MenuItem
   Header="Redo"
   Command="ApplicationCommands.Redo"
   IsEnabled="{Binding ElementName=textControl1, Path=CanRedo}" />

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.CanUndo Property

Gets a value indicating whether the user can undo the previous operation in a Text Control.

Syntax

[C#]
public bool CanUndo { get; }
[Visual Basic]
Public ReadOnly Property CanUndo() As Boolean

Limitations

Runtime only.

Read only.

Example

The following XAML example shows how to bind the CanUndo property to the IsEnabled attribute of a menu item.

<MenuItem
   Header="Undo"
   Command="ApplicationCommands.Undo"
   IsEnabled="{Binding ElementName=textControl1, Path=CanUndo}" />

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.CaretWidth Property

Gets or sets the width of the caret in pixels. If this property is zero, the width is set to its default value which is the system-defined window border width.

Syntax

[C#]
public int CaretWidth { get; set; }
[Visual Basic]
Public Property CaretWidth() As Integer

Limitations

The maximum width is 255 pixels.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.Changed Event

Indicates that the contents of a document have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Changed;
[Visual Basic]
Public Event Changed As EventHandler

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.CharFormatChanged Event

Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed. Formatting attributes that can be asigned to single characters are the font, the font attributes, text colors and the baseline. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler CharFormatChanged;
[Visual Basic]
Public Event CharFormatChanged As EventHandler

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.ChartClicked Event

Occurs when a chart has been clicked on. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartClicked;
[Visual Basic]
Public Event ChartClicked As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartCreated Event

Occurs when a new chart has been created. It occurs, when a chart has been inserted in the document with the clipboard and when a file containing charts has been loaded. It does not occur, when a chart has been added with the ChartCollection.Add method. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartCreated;
[Visual Basic]
Public Event ChartCreated As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartDeleted Event

Occurs when a chart has been deleted. It occurs, when a chart has been deleted while editing a document and when a chart has been deleted with the ChartCollection.Remove method. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartDeleted;
[Visual Basic]
Public Event ChartDeleted As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartDoubleClicked Event

Occurs when a chart has been doubleclicked on. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartDoubleClicked;
[Visual Basic]
Public Event ChartDoubleClicked As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartMoved Event

Occurs when a chart has been moved. It does not occur, if an inline or anchored chart has been moved because text has been inserted. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartMoved;
[Visual Basic]
Public Event ChartMoved As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartRightClicked Event

Occurs when a chart has been clicked on with the right mouse button. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartRightClicked;
[Visual Basic]
Public Event ChartRightClicked As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartSelected Event

Occurs when a chart has been selected. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ChartEventHandler ChartSelected;
[Visual Basic]
Public Event ChartSelected As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartDeselected Event

Occurs when a chart has been deselected. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ChartEventHandler ChartDeselected;
[Visual Basic]
Public Event ChartDeselected As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartLayoutDialog Method

Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a chart. This dialog can only be invoked, if a chart has been selected.

Introduced: 18.0.

ChartLayoutDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult ChartLayoutDialog();
[Visual Basic]
Public Function ChartLayoutDialog() As DialogResult

ChartLayoutDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult ChartLayoutDialog(int activeTab);
[Visual Basic]
Public Function ChartLayoutDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Charts Property

Gets a collection of all charts contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DataVisualization.ChartCollection. The collection can be used to get or to alter a chart's attributes and to add charts to or to remove charts from a document.

Introduced: 18.0.

Syntax

[C#]
public DataVisualization.ChartCollection Charts { get; }
[Visual Basic]
Public ReadOnly Property Charts() As DataVisualization.ChartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.ChartSized Event

Occurs when a chart has been sized. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Introduced: 18.0.

Syntax

[C#]
public event ChartEventHandler ChartSized;
[Visual Basic]
Public Event ChartSized As ChartEventHandler

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.Clear Method

Clears the selected text or the character right from the current input position from the Text Control. This method works only if the Text Control has the focus.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.ClearUndo Method

Clears the undo buffer of the Text Control.

Syntax

[C#]
public void ClearUndo();
[Visual Basic]
Public Sub ClearUndo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.ControlChars Property

Specifies if control characters are visible or not.

Syntax

[C#]
public bool ControlChars { get; set; }
[Visual Basic]
Public Property ControlChars() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Copy Method

Copies the current selection in the Text Control to the Clipboard.

Syntax

[C#]
public void Copy();
[Visual Basic]
Public Sub Copy()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.Cut Method

Moves the current selection in the Text Control to the Clipboard.

Syntax

[C#]
public void Cut();
[Visual Basic]
Public Sub Cut()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.DisplayColors Property

Gets or sets the colors of the text control. These colors are only used when the BackgroundStyle property has been set to ColorScheme. The property value is an object of the type TextControl.Colors.

Introduced: 15.1.

Syntax

[C#]
public TextControl.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As TextControl.Colors

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.DocumentLinkClicked Event

Occurs when a text field has been clicked on that represents a link to a target in the document. The event handler receives an argument of type DocumentLinkEventArgs containing data related to this event.

Syntax

[C#]
public event DocumentLinkEventHandler DocumentLinkClicked;
[Visual Basic]
Public Event DocumentLinkClicked As DocumentLinkEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.DocumentLinks Property

Gets a collection of all document links contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. Document links point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.DocumentLoaded Event

Occurs when a new document has been loaded. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event EventHandler DocumentLoaded;
[Visual Basic]
Public Event DocumentLoaded As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.DocumentTargetMarkers Property

Gets or sets a value indicating that markers for hypertext targets are shown or not.

Introduced: 13.0.

Syntax

[C#]
public bool DocumentTargetMarkers { get; set; }
[Visual Basic]
Public Property DocumentTargetMarkers() As Boolean

Example

The following XAML example shows how to bind the DocumentTargetMarkers property to a check box.

<CheckBox
   Content="Show document target markers"
   IsChecked="{Binding ElementName=textControl1, Path=DocumentTargetMarkers}" />

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.DocumentTargets Property

Gets a collection of all targets contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DocumentTargetCollection.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.DrawingActivated Event

Occurs when a drawing has been activated. The event handler receives an argument of type DrawingEventArgs containing data related to this event. A drawing is activated, when the user clicks the drawing with the mouse. The user can alter the drawing's contents, when it is activated. When the user clicks on the drawing's border, it is selected. A selected drawing can be sized, moved or copied to the clipboard.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingActivated;
[Visual Basic]
Public Event DrawingActivated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingClicked Event

Occurs when a drawing has been clicked on. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingClicked;
[Visual Basic]
Public Event DrawingClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingCreated Event

Occurs when a new drawing has been created. It occurs, when a drawing has been inserted in the document via the clipboard and when a file containing drawings has been loaded. It does not occur, when a drawing has been added with the DrawingCollection.Add method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingCreated;
[Visual Basic]
Public Event DrawingCreated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingDeleted Event

Occurs when a drawing has been deleted. It occurs, when a drawing has been deleted while editing a document and when a drawing has been deleted with the DrawingCollection.Remove method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeleted;
[Visual Basic]
Public Event DrawingDeleted As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingDeactivated Event

Occurs when a drawing has been deactivated. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeactivated;
[Visual Basic]
Public Event DrawingDeactivated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingDeselected Event

Occurs when a drawing has been deselected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeselected;
[Visual Basic]
Public Event DrawingDeselected As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingDoubleClicked Event

Occurs when a drawing has been doubleclicked on. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDoubleClicked;
[Visual Basic]
Public Event DrawingDoubleClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingLayoutDialog Method

Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing. This dialog can only be invoked, if a drawing has been selected.

Introduced: 23.0.

DrawingLayoutDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult DrawingLayoutDialog();
[Visual Basic]
Public Function DrawingLayoutDialog() As DialogResult

DrawingLayoutDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult DrawingLayoutDialog(int activeTab);
[Visual Basic]
Public Function DrawingLayoutDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further drawing attributes such as line- and background color, rotation and transparency.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.DrawingMarkerLines Property

Specifies whether a marker frame is shown around a drawing to indicate its position and size.

Introduced: 23.0.

Syntax

[C#]
public bool DrawingMarkerLines { get; set; }
[Visual Basic]
Public Property DrawingMarkerLines() As Boolean

Example

The following XAML example shows how to bind the DrawingMarkerLines property to a check box.

<CheckBox
   Content="Show drawing marker lines"
   IsChecked="{Binding ElementName=textControl1, Path=DrawingMarkerLines}" />

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingMoved Event

Occurs when a drawing has been moved. It does not occur, if an inline or anchored drawing has been moved because text has been inserted. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingMoved;
[Visual Basic]
Public Event DrawingMoved As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingRightClicked Event

Occurs when a drawing has been clicked on with the right mouse button. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingRightClicked;
[Visual Basic]
Public Event DrawingRightClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.Drawings Property

Gets a collection of all drawings contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from a document.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingSelected Event

Occurs when a drawing has been selected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingSelected;
[Visual Basic]
Public Event DrawingSelected As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DrawingSized Event

Occurs when a drawing has been sized. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingSized;
[Visual Basic]
Public Event DrawingSized As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.DropFormats Property

Gets or sets the formats of data the control can accept when the user drags it onto the control. The property's value can be a bitwise OR combination of the values listed below. The bitwise AND operator can be used to test for a given format.

Introduced: 15.1.

Syntax

[C#]
public DropFormat DropFormats { get; set; }
[Visual Basic]
Public Property DropFormats() As DropFormat
Value | Description
HTMLFormat | The control accepts HTML Format.
Image | The control accepts images (Device dependent or device independent bitmaps, TIFF images or Windows metafiles).
PlainText | The control accepts plain text.
RichTextFormat | The control accepts Rich Text Format.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.EditMode Property

Gets or sets a value indicating whether the document's text is read-only, can be selected or is editable.

Syntax

[C#]
public EditMode EditMode { get; set; }
[Visual Basic]
Public Property EditMode() As EditMode
Value | Description
Edit | The document's text can be edited.
ReadAndSelect | The document's text is read only but can be selected.
ReadOnly | The document's text is read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.EndUndoAction Method

Ends a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step.

Introduced: 23.0.

Syntax

[C#]
public void EndUndoAction();
[Visual Basic]
Public Sub EndUndoAction()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.FieldCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.

Syntax

[C#]
public Cursor FieldCursor { get; set; }
[Visual Basic]
Public Property FieldCursor() As Cursor

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.Find Method

Finds a text string in the text part with the input focus. This can be the main text, a text frame or a header or footer.

Find()

Opens the built-in Find dialog box to search for a text string in the text part with the input focus. This can be the main text, a text frame or a header or footer.

[C#]
public void Find();
[Visual Basic]
Public Sub Find()

Find(String)

Searches for the specified text string in the text part with the input focus. This can be the main text, a text frame or a header or footer. The search starts at the beginning of the text.

[C#]
public int Find(string text);
[Visual Basic]
Public Function Find(ByVal text As String) As Integer
Parameter | Description
text | Specifies the text to search for.

Find(String, Int32, FindOptions)

Searches for the specified text string in the text part with the input focus. This can be the main text, a text frame or a header or footer. The search is done with the specified find options and starts at the specified position.

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Programming Category: Search and Replace
  • Graphical Overview: Search and Replace
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.FontDialog Method

Invokes the built-in font dialog box.

Syntax

[C#]
public DialogResult FontDialog();
[Visual Basic]
Public Function FontDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.FontSettings Property

Gets a FontSettings object which provides properties determining which fonts can be used in a document.

Introduced: 15.0.

Syntax

[C#]
public FontSettings FontSettings { get; }
[Visual Basic]
Public ReadOnly Property FontSettings() As FontSettings

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.FontUnderlineStyle Property

Gets or sets underlining style for the text displayed by the control. This property only determines the style. The Font property determines whether text is underlined or not.

Syntax

[C#]
public FontUnderlineStyle FontUnderlineStyle { get; set; }
[Visual Basic]
Public Property FontUnderlineStyle() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.ForeColor Property

Overridden. Gets or sets the foreground color of the control which is the color of the document's text.

Syntax

[C#]
public override Color ForeColor { get; set; }
[Visual Basic]
Public Overloads Overrides Property ForeColor() As Color

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.ForeColorDialog Method

Invokes the built-in dialog box for setting the text color.

Introduced: 22.0.

Syntax

[C#]
public DialogResult ForeColorDialog();
[Visual Basic]
Public Function ForeColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.FormattingPrinter Property

Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document. If the document is printed with this printer the displayed and the printed document have the same dimensions. If the property is set to Standard, the system installed standard printer is used to format the document. If the property is set to Display, the font dimensions of the display device are used to format the document. If the specified printer is not installed, the standard printer is used.

Introduced: 14.0.

Syntax

[C#]
public string FormattingPrinter { get; set; }
[Visual Basic]
Public Property FormattingPrinter() As String

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.FormattingStylesDialog Method

Invokes the built-in dialog box for creating, deleting and modifying formatting styles.

Syntax

[C#]
public DialogResult FormattingStylesDialog();
[Visual Basic]
Public Function FormattingStylesDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.FormattingStyleListChanged Event

Occurs after one or more formatting styles have been added or removed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler FormattingStyleListChanged;
[Visual Basic]
Public Event FormattingStyleListChanged As EventHandler

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.TextControl.FrameClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameClicked;
[Visual Basic]
Public Event FrameClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameDeselected Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameDeselected;
[Visual Basic]
Public Event FrameDeselected As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameDoubleClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameDoubleClicked;
[Visual Basic]
Public Event FrameDoubleClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameLayoutChanged Event

Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed. Layout attributes are insertion mode, textflow and z-order. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameLayoutChanged;
[Visual Basic]
Public Event FrameLayoutChanged As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameMoved Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved. It does not occur, if an inline or anchored frame has been moved because text has been inserted. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameMoved;
[Visual Basic]
Public Event FrameMoved As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameRightClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameRightClicked;
[Visual Basic]
Public Event FrameRightClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameSelected Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameSelected;
[Visual Basic]
Public Event FrameSelected As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameSized Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameSized;
[Visual Basic]
Public Event FrameSized As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.FrameFillColorDialog Method

Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.

Introduced: 24.0.

Syntax

[C#]
public DialogResult FrameFillColorDialog();
[Visual Basic]
Public Function FrameFillColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.FrameLineColorDialog Method

Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.

Introduced: 24.0.

Syntax

[C#]
public DialogResult FrameLineColorDialog();
[Visual Basic]
Public Function FrameLineColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Frames Property

Gets a collection of all images, textframes, charts, barcodes and drawings contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type FrameCollection. The collection can be used to get or to alter attributes common to all frames.

Introduced: 18.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.GetClipboardFormats Method

Returns an array of ClipboardFormat values. These values specify all the data formats which are currently available in the clipboard and which can be pasted into a TextControl document. If there is no data format available, this method returns null.

Introduced: 15.0.

Syntax

[C#]
public ClipboardFormat[] GetClipboardFormats();
[Visual Basic]
Public Sub GetClipboardFormats() As ClipboardFormat()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.GetPages Method

Gets a collection of all pages in the document. The property's value is an object of the type PageCollection. This collection is only available, if the TextControl.ViewMode property has been set to ViewMode.PageView. Otherwise, the method returns null.

Introduced: 14.0.

Syntax

[C#]
public PageCollection GetPages();
[Visual Basic]
Public Function GetPages() As PageCollection

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.GetSupportedFonts Method

Gets an array of strings specifying the names of all currently supported fonts. These fonts depend on the formatting device set with the TextControl.FormattingPrinter property. The method returns null, if the TextControl has not been completely initialized.

Introduced: 15.1.

Syntax

[C#]
public string[] GetSupportedFonts();
[Visual Basic]
Public Sub GetSupportedFonts() As String()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.GetSupportedPaperSizes Method

Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes. These paper sizes depend on the formatting device set with the TextControl.FormattingPrinter property. The method returns null, if the TextControl has not been completely initialized.

Introduced: 24.0.

Syntax

[C#]
public PaperSize[] GetSupportedPaperSizes();
[Visual Basic]
Public Function GetSupportedPaperSizes() As PaperSize()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.GetXmlElements Method

Returns a collection of XML elements. It is an object of the type XmlElementCollection.

Syntax

[C#]
public XmlElementCollection GetXmlElements(string elementName);
[Visual Basic]
Public Function GetXmlElements(ByVal elementName As String) As XmlElementCollection
Parameter | Description
elementName | Specifies the XML element's name.

Return Value

The return value is a collection containing all XML elements of the specified name.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.GetVersionInfo Method

Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.

Introduced: 21.0.

Syntax

[C#]
public VersionInfo GetVersionInfo();
[Visual Basic]
Public Sub GetVersionInfo() As VersionInfo

Return Value

The return value is a VersionInfo object.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.HeaderFooterActivated Event

Occurs when a header or footer has been activated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterActivated;
[Visual Basic]
Public Event HeaderFooterActivated As HeaderFooterEventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.HeaderFooterActivationStyle Property

Gets or sets a value specifying the activation style for headers and footers.

Introduced: 14.0.

Syntax

[C#]
public HeaderFooterActivationStyle HeaderFooterActivationStyle { get; set; }
[Visual Basic]
Public Property HeaderFooterActivationStyle() As HeaderFooterActivationStyle
Value | Description
ActivateClick | Headers and footers are activated with a single mouse click.
ActivateDoubleClick | Headers and footers are activated with a double mouse click.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.HeaderFooterDeactivated Event

Occurs when a header or footer has been deactivated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterDeactivated;
[Visual Basic]
Public Event HeaderFooterDeactivated As HeaderFooterEventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.HeaderFooterFrameStyle Property

Gets or sets a value specifying the frame for activated headers and footers.

Introduced: 14.0.

Syntax

[C#]
public HeaderFooterFrameStyle HeaderFooterFrameStyle { get; set; }
[Visual Basic]
Public Property HeaderFooterFrameStyle() As HeaderFooterFrameStyle
Value | Description
DividingLine | Draws a dividing line between an activated header or footer and the main text.
DottedFrame | Activated headers and footers have a dotted frame.
NoFrame | Activated headers and footers have no frame.
SingleFrame | Activated headers and footers have single frame.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.HeadersAndFooters Property

Gets a collection of all headers and footers the current document contains. The property's value is an object of the type HeaderFooterCollection.

Syntax

[C#]
public HeaderFooterCollection HeadersAndFooters { get; }
[Visual Basic]
Public ReadOnly Property HeadersAndFooters() As HeaderFooterCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.HExpanded Event

Occurs when the Text Control has automatically expanded its size horizontally. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 11.0.

Syntax

[C#]
public event EventHandler HExpanded;
[Visual Basic]
Public Event HExpanded As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.HideSelection Property

Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.

Syntax

[C#]
public bool HideSelection { get; set; }
[Visual Basic]
Public Property HideSelection() As Boolean

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.HScroll Event

Occurs when the horizontal scroll position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler HScroll;
[Visual Basic]
Public Event HScroll As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.HShrunk Event

Occurs when the Text Control has automatically shrunk its size horizontally. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 11.0.

Syntax

[C#]
public event EventHandler HShrunk;
[Visual Basic]
Public Event HShrunk As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.HypertextLinkClicked Event

Occurs when a text field has been clicked on that represents the source of a hypertext link. The event handler receives an argument of type HypertextLinkEventArgs containing data related to this event.

Syntax

[C#]
public event HypertextLinkEventHandler HypertextLinkClicked;
[Visual Basic]
Public Event HypertextLinkClicked As HypertextLinkEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.HypertextLinks Property

Gets a collection of all hypertext links contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type HypertextLinkCollection.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.HyphenateWord Event

Occurs, if a word does not fit in the line and must be hyphenated. This event occurs only, if the IsHyphenationEnabled property has been set to true. The event handler receives an argument of type HyphenateWordEventArgs containing data related to this event.

Introduced: 20.0.

Syntax

[C#]
public event HyphenateWordEventHandler HyphenateWord;
[Visual Basic]
Public Event HyphenateWord As HyphenateWordEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.ImageAttributesDialog Method

Invokes the built-in dialog box for setting attributes of images. This dialog box is only shown, if an image is currently selected. The ImageCollection.GetItem method can be used to test whether an image is selected or not.

Introduced: 12.0.

ImageAttributesDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult ImageAttributesDialog();
[Visual Basic]
Public Function ImageAttributesDialog() As DialogResult

ImageAttributesDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult ImageAttributesDialog(int activeTab);
[Visual Basic]
Public Function ImageAttributesDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting an image's saving attributes.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.ImageClicked Event

Occurs when an image has been clicked on. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageClicked;
[Visual Basic]
Public Event ImageClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageCreated Event

Occurs when a new image has been created. It occurs if an image has been inserted in the document with the clipboard or if a file containing images has been loaded. It does not occur if an image has been added with the ImageCollection.Add method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageCreated;
[Visual Basic]
Public Event ImageCreated As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageDeleted Event

Occurs when an image has been deleted. It occurs if an image has been deleted while editing a document or if an image has been deleted with the ImageCollection.Remove method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDeleted;
[Visual Basic]
Public Event ImageDeleted As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageDeselected Event

Occurs when an image has been deselected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ImageEventHandler ImageDeselected;
[Visual Basic]
Public Event ImageDeselected As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageDoubleClicked Event

Occurs when an image has been doubleclicked on. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDoubleClicked;
[Visual Basic]
Public Event ImageDoubleClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageMoved Event

Occurs when an inserted image has been moved. It does not occur, if an inline or anchored image has been moved because text has been inserted. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageMoved;
[Visual Basic]
Public Event ImageMoved As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageRightClicked Event

Occurs when an image has been clicked on with the right mouse button. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event ImageEventHandler ImageRightClicked;
[Visual Basic]
Public Event ImageRightClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.Images Property

Gets a collection of all images contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageSelected Event

Occurs when an image has been selected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ImageEventHandler ImageSelected;
[Visual Basic]
Public Event ImageSelected As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.ImageSized Event

Occurs when an inserted image has been sized. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageSized;
[Visual Basic]
Public Event ImageSized As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.InlineStyles Property

Gets a collection of all inline styles the current document contains. The property's value is an object of the type InlineStyleCollection.

Introduced: 10.1.

Syntax

[C#]
public InlineStyleCollection InlineStyles { get; }
[Visual Basic]
Public ReadOnly Property InlineStyles() As InlineStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.TextControl.InputFormat Property

Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.

Introduced: 16.0.

Syntax

[C#]
public InputFormat InputFormat { get; }
[Visual Basic]
Public ReadOnly Property InputFormat() As InputFormat

Limitations

Runtime only.

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.InputFormattingStyleChanged Event

Occurs after the text input position has been moved to a text part formatted with another style. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputFormattingStyleChanged;
[Visual Basic]
Public Event InputFormattingStyleChanged As EventHandler

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.TextControl.InputParagraphChanged Event

Occurs when the text input position has been moved to another paragraph. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputParagraphChanged;
[Visual Basic]
Public Event InputParagraphChanged As EventHandler

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.InputPosition Property

Gets or sets the current text input position. The property's value is an object of the type InputPosition.

Introduced: 10.1.

Syntax

[C#]
public InputPosition InputPosition { get; set; }
[Visual Basic]
Public Property InputPosition() As InputPosition

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.InputPositionChanged Event

Occurs when the text input position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputPositionChanged;
[Visual Basic]
Public Event InputPositionChanged As EventHandler

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.InsertionMode Property

Specifies whether text is inserted or overwrites existing text.

Syntax

[C#]
public InsertionMode InsertionMode { get; set; }
[Visual Basic]
Public Property InsertionMode() As InsertionMode
Value | Description
Insert | Text is inserted at the current text input position.
Overwrite | Text is overwritten at the current text input position.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.IsHyphenationEnabled Property

Gets or sets a value indicating whether hyphenation is active or not. If hyphenation is enabled, a word at the end of a line is automatically divided with a connected spell checking component. A spell checking component can be connected with the SpellChecker property. Additionally, the TextControl.HyphenateWord event is raised with the calculated divide position. This position can be changed through a connected event handler.

Introduced: 20.0.

Syntax

[C#]
public bool IsHyphenationEnabled { get; set; }
[Visual Basic]
Public Property IsHyphenationEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.IsLanguageDetectionEnabled Property

Gets or sets a value indicating whether language detection is active or not. If language detection is enabled, a language is automatically set for all pieces of text with a neutral language. To use this feature, at least the TXSpell 5.0 spell checking component must be connected with the TextControl through the SpellChecker property.

Introduced: 21.0.

Syntax

[C#]
public bool IsLanguageDetectionEnabled { get; set; }
[Visual Basic]
Public Property IsLanguageDetectionEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.IsSpellCheckingEnabled Property

Gets or sets a value indicating whether spell checking is active or not. If spell checking is enabled either the text is automatically checked with a connected spell checking component or the TextControl.SpellCheckText event is raised when the text of a document changes. The event handler can then be used to check the text on misspelled words. A spell checking component can be connected with the SpellChecker property.

Introduced: 16.0.

Syntax

[C#]
public bool IsSpellCheckingEnabled { get; set; }
[Visual Basic]
Public Property IsSpellCheckingEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.Landscape Property

Gets or sets a value indicating whether the page orientation is landscape or portrait.

Introduced: 14.0.

Syntax

[C#]
public bool Landscape { get; set; }
[Visual Basic]
Public Property Landscape() As Boolean

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.LanguageDialog Method

Invokes the built-in dialog box for setting the language of the selected text.

Introduced: 20.0.

Syntax

[C#]
public DialogResult LanguageDialog();
[Visual Basic]
Public Function LanguageDialog() As DialogResult

Return Value

The return value can be one of the following values:

Result | Meaning
DialogResult.OK | The dialog has been left with the OK button and the selected language could be set.
DialogResult.Cancel | The dialog has been left with the Cancel button.
DialogResult.None | The selected language could not be set.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Lines Property

Gets a collection of all lines contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type LineCollection.

Introduced: 10.1.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextControl.ListFormat Property

Gets or sets the type and the formatting attributes of a bulleted or numbered list. The property value is an object of the type ListFormat. For more information see the description of the ListFormat class.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.TextControl.ListFormatDialog Method

Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.

Syntax

[C#]
public DialogResult ListFormatDialog();
[Visual Basic]
Public Function ListFormatDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Load Method

Loads text in a certain format. The complete contents of a Text Control are replaced.

Load()

Opens a dialog box to select a file and loads the text from that file.

[C#]
public DialogResult Load();
[Visual Basic]
Public Function Load() As DialogResult

Load(StreamType)

Opens a dialog box to select a file in the specified format and loads the text from that file.

[C#]
public DialogResult Load(StreamType streamType);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Load(String, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file.

[C#]
public void Load(string path, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

Load(FileStream, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file stream.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

Load(Byte[], BinaryStreamType)

Loads text formatted with the specified format. The new text is read from the specified byte array.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

Load(String, StringStreamType)

Loads text formatted with the specified format. The new text is read from the specified string.

[C#]
public void Load(string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

Load(StreamType, LoadSettings)

Opens a dialog box to select a file in the specified format and loads the text from that file using the specified special settings.

[C#]
public DialogResult Load(StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType, ByVal loadSettings As LoadSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file and loaded using the given special settings.

[C#]
public void Load(string path, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(FileStream, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file stream and loaded using the given special settings.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(Byte[], BinaryStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified byte array and loaded using the given special settings.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StringStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified string and loaded using the given special settings.

[C#]
public void Load(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Return Value

The implementations that open a dialog box return the dialog's result value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.MisspelledWords Property

Gets a collection of all misspelled words contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type MisspelledWordCollection. Misspelled words can be corrected with the SpellCheckDialog method when a spell checking component is connected with the TextControl.

Introduced: 16.0.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.OnAcceptsTabChanged Method

Raises the AcceptsTabChanged event.

Syntax

[C#]
protected virtual void OnAcceptsTabChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnAcceptsTabChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnAdaptFont Method

Raises the AdaptFont event.

Introduced: 15.0.

Syntax

[C#]
protected virtual void OnAdaptFont(AdaptFontEventArgs e);
[Visual Basic]
Protected Overridable Sub OnAdaptFont(ByVal e As AdaptFontEventArgs)
Parameter | Description
e | Specifies an AdaptFontEventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnBarcodeClicked Method

Raises the BarcodeClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeCreated Method

Raises the BarcodeCreated event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeCreated(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeCreated(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeDeleted Method

Raises the BarcodeDeleted event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDeleted(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeleted(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeDeselected Method

Raises the BarcodeDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDeselected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeselected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeDoubleClicked Method

Raises the BarcodeDoubleClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDoubleClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDoubleClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeMoved Method

Raises the BarcodeMoved event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeMoved(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeMoved(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeRightClicked Method

Raises the BarcodeRightClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeRightClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeRightClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeSelected Method

Raises the BarcodeSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeSelected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeSelected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBarcodeSized Method

Raises the BarcodeSized event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeSized(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeSized(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.TextControl.OnBorderStyleChanged Method

Raises the BorderStyleChanged event.

Syntax

[C#]
protected virtual void OnBorderStyleChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnBorderStyleChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnChanged Method

Raises the Changed event.

Syntax

[C#]
protected virtual void OnChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.OnCharFormatChanged Method

Raises the CharFormatChanged event.

Syntax

[C#]
protected virtual void OnCharFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnCharFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.OnChartClicked Method

Raises the ChartClicked event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartClicked(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartClicked(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartCreated Method

Raises the ChartCreated event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartCreated(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartCreated(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartDeleted Method

Raises the ChartDeleted event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartDeleted(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartDeleted(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartDeselected Method

Raises the ChartDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnChartDeselected(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartDeselected(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartDoubleClicked Method

Raises the ChartDoubleClicked event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartDoubleClicked(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartDoubleClicked(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartMoved Method

Raises the ChartMoved event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartMoved(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartMoved(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartRightClicked Method

Raises the ChartRightClicked event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartRightClicked(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartRightClicked(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartSelected Method

Raises the ChartSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnChartSelected(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartSelected(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnChartSized Method

Raises the ChartSized event.

Introduced: 18.0.

Syntax

[C#]
protected virtual void OnChartSized(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartSized(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.TextControl.OnDocumentLinkClicked Method

Raises the DocumentLinkClicked event.

Syntax

[C#]
protected virtual void OnDocumentLinkClicked(DocumentLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLinkClicked(ByVal e As DocumentLinkEventArgs)
Parameter | Description
e | Specifies an DocumentLinkEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.OnDocumentLoaded Method

Raises the DocumentLoaded event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnDocumentLoaded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLoaded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.OnDrawingActivated Method

Raises the DrawingActivated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingActivated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingActivated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingClicked Method

Raises the DrawingClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingCreated Method

Raises the DrawingCreated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingCreated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingCreated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingDeactivated Method

Raises the DrawingDeactivated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeactivated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeactivated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingDeleted Method

Raises the DrawingDeleted event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeleted(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeleted(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingDeselected Method

Raises the DrawingDeselected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeselected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeselected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingDoubleClicked Method

Raises the DrawingDoubleClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDoubleClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDoubleClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingMoved Method

Raises the DrawingMoved event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingMoved(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingMoved(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingRightClicked Method

Raises the DrawingRightClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingRightClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingRightClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingSelected Method

Raises the DrawingSelected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingSelected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingSelected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnDrawingSized Method

Raises the DrawingSized event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingSized(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingSized(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.TextControl.OnFontChanged Method

Overridden. See Control.OnFontChanged.

Syntax

[C#]
protected override void OnFontChanged(EventArgs e);
[Visual Basic]
Protected Overloads Overrides Sub OnFontChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.OnFormattingStyleListChanged Method

Raises the FormattingStyleListChanged event.

Syntax

[C#]
protected virtual void OnFormattingStyleListChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnFormattingStyleListChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.TextControl.OnFrameClicked Method

Raises the FrameClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameDeselected Method

Raises the FrameDeselected event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameDeselected(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameDeselected(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameDoubleClicked Method

Raises the FrameDoubleClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameDoubleClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameDoubleClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameLayoutChanged Method

Raises the FrameLayoutChanged event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameLayoutChanged(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameLayoutChanged(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameMoved Method

Raises the FrameMoved event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameMoved(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameMoved(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameRightClicked Method

Raises the FrameRightClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameRightClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameRightClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameSelected Method

Raises the FrameSelected event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameSelected(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameSelected(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnFrameSized Method

Raises the FrameSized event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameSized(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameSized(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnHandleCreated Method

Overridden. See Control.OnHandleCreated.

Syntax

[C#]
protected override void OnHandleCreated(EventArgs e);
[Visual Basic]
Protected Overloads Overrides Sub OnHandleCreated(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnHeaderFooterActivated Method

Raises the HeaderFooterActivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterActivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterActivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.OnHeaderFooterDeactivated Method

Raises the HeaderFooterDeactivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterDeactivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterDeactivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.TextControl.OnHExpanded Method

Raises the HExpanded event.

Introduced: 11.0.

Syntax

[C#]
protected virtual void OnHExpanded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHExpanded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnHScroll Method

Raises the HScroll event.

Syntax

[C#]
protected virtual void OnHScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnHShrunk Method

Raises the HShrunk event.

Introduced: 11.0.

Syntax

[C#]
protected virtual void OnHShrunk(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHShrunk(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnHypertextLinkClicked Method

Raises the HypertextLinkClicked event.

Syntax

[C#]
protected virtual void OnHypertextLinkClicked(HypertextLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHypertextLinkClicked(ByVal e As HypertextLinkEventArgs)
Parameter | Description
e | Specifies an HypertextLinkEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.TextControl.OnHyphenateWord Method

Raises the HyphenateWord event.

Introduced: 20.0.

Syntax

[C#]
protected virtual void OnHyphenateWord(HyphenateWordEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHyphenateWord(ByVal e As HyphenateWordEventArgs)
Parameter | Description
e | Specifies an HyphenateWordEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.OnImageClicked Method

Raises the ImageClicked event.

Syntax

[C#]
protected virtual void OnImageClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageCreated Method

Raises the ImageCreated event.

Syntax

[C#]
protected virtual void OnImageCreated(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageCreated(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageDeleted Method

Raises the ImageDeleted event.

Syntax

[C#]
protected virtual void OnImageDeleted(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeleted(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageDeselected Method

Raises the ImageDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnImageDeselected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeselected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageDoubleClicked Method

Raises the ImageDoubleClicked event.

Syntax

[C#]
protected virtual void OnImageDoubleClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDoubleClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageMoved Method

Raises the ImageMoved event.

Syntax

[C#]
protected virtual void OnImageMoved(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageMoved(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageRightClicked Method

Raises the ImageRightClicked event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnImageRightClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageRightClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageSelected Method

Raises the ImageSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnImageSelected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageSelected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnImageSized Method

Raises the ImageSized event.

Syntax

[C#]
protected virtual void OnImageSized(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageSized(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.TextControl.OnInputFormattingStyleChanged Method

Raises the InputFormattingStyleChanged event.

Syntax

[C#]
protected virtual void OnInputFormattingStyleChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputFormattingStyleChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.TextControl.OnInputParagraphChanged Method

Raises the InputParagraphChanged event.

Syntax

[C#]
protected virtual void OnInputParagraphChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputParagraphChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.OnInputPositionChanged Method

Raises the InputPositionChanged event.

Syntax

[C#]
protected virtual void OnInputPositionChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputPositionChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.OnPageChanged Method

Raises the PageChanged event.

Introduced: 14.0.

Syntax

[C#]
protected virtual void OnPageChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnPageChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.OnPageFormatChanged Method

Raises the PageFormatChanged event.

Syntax

[C#]
protected virtual void OnPageFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnPageFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.OnParagraphFormatChanged Method

Raises the ParagraphFormatChanged event.

Syntax

[C#]
protected virtual void OnParagraphFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnParagraphFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.OnSectionChanged Method

Raises the SectionChanged event.

Introduced: 14.0.

Syntax

[C#]
protected virtual void OnSectionChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnSectionChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.OnSpellCheckText Method

Raises the SpellCheckText event.

Introduced: 16.0.

Syntax

[C#]
protected virtual void OnSpellCheckText(SpellCheckTextEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSpellCheckText(ByVal e As SpellCheckTextEventArgs)
Parameter | Description
e | Specifies an SpellCheckTextEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.OnSubTextPartClicked Method

Raises the SubTextPartClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnSubTextPartDoubleClicked Method

Raises the SubTextPartDoubleClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartDoubleClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartDoubleClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnSubTextPartEntered Method

Raises the SubTextPartEntered event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartEntered(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartEntered(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnSubTextPartLeft Method

Raises the SubTextPartLeft event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartLeft(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartLeft(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnTableCreated Method

Raises the TableCreated event.

Syntax

[C#]
protected virtual void OnTableCreated(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableCreated(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.OnTableDeleted Method

Raises the TableDeleted event.

Syntax

[C#]
protected virtual void OnTableDeleted(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableDeleted(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.OnTableFormatChanged Method

Raises the TableFormatChanged event.

Syntax

[C#]
protected virtual void OnTableFormatChanged(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableFormatChanged(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.OnTextContextMenuOpening Method

Raises the TextContextMenuOpening event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextContextMenuOpening(TextContextMenuEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextContextMenuOpening(ByVal e As TextContextMenuEventArgs)
Parameter | Description
e | Specifies an TextContextMenuEventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnTextFieldChanged Method

Raises the TextFieldChanged event.

Syntax

[C#]
protected virtual void OnTextFieldChanged(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldChanged(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldClicked Method

Raises the TextFieldClicked event.

Syntax

[C#]
protected virtual void OnTextFieldClicked(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldClicked(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldCreated Method

Raises the TextFieldCreated event.

Syntax

[C#]
protected virtual void OnTextFieldCreated(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldCreated(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldDoubleClicked Method

Raises the TextFieldDoubleClicked event.

Syntax

[C#]
protected virtual void OnTextFieldDoubleClicked(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldDoubleClicked(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldDeleted Method

Raises the TextFieldDeleted event.

Syntax

[C#]
protected virtual void OnTextFieldDeleted(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldDeleted(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldEntered Method

Raises the TextFieldEntered event.

Syntax

[C#]
protected virtual void OnTextFieldEntered(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldEntered(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFieldLeft Method

Raises the TextFieldLeft event.

Syntax

[C#]
protected virtual void OnTextFieldLeft(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldLeft(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.OnTextFrameActivated Method

Raises the TextFrameActivated event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameActivated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameActivated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameAppearanceChanged Method

Raises the TextFrameAppearanceChanged event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnTextFrameAppearanceChanged(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameAppearanceChanged(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies a TextFrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.OnTextFrameClicked Method

Raises the TextFrameClicked event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameCreated Method

Raises the TextFrameCreated event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameCreated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameCreated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameDeactivated Method

Raises the TextFrameDeactivated event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameDeactivated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeactivated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameDeleted Method

Raises the TextFrameDeleted event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameDeleted(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeleted(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameDeselected Method

Raises the TextFrameDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextFrameDeselected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeselected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameDoubleClicked Method

Raises the TextFrameDoubleClicked event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameDoubleClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDoubleClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameMoved Method

Raises the TextFrameMoved event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameMoved(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameMoved(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameRightClicked Method

Raises the TextFrameRightClicked event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameRightClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameRightClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameSelected Method

Raises the TextFrameSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextFrameSelected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameSelected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnTextFrameSized Method

Raises the TextFrameSized event.

Introduced: 12.0.

Syntax

[C#]
protected virtual void OnTextFrameSized(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameSized(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.OnVExpanded Method

Raises the VExpanded event.

Introduced: 11.0.

Syntax

[C#]
protected virtual void OnVExpanded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVExpanded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnVScroll Method

Raises the VScroll event.

Syntax

[C#]
protected virtual void OnVScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnVShrunk Method

Raises the VShrunk event.

Introduced: 11.0.

Syntax

[C#]
protected virtual void OnVShrunk(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVShrunk(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.OnXmlInvalid Method

Raises the XmlInvalid event.

Syntax

[C#]
protected virtual void OnXmlInvalid(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlInvalid(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.OnXmlNotWellFormed Method

Raises the XmlNotWellFormed event.

Syntax

[C#]
protected virtual void OnXmlNotWellFormed(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlNotWellFormed(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.OnZoomed Method

Raises the Zoomed event.

Syntax

[C#]
protected virtual void OnZoomed(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnZoomed(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.TextControl.PageChanged Event

Occurs when the text input position has been moved to another page. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 14.0.

Syntax

[C#]
public event EventHandler PageChanged;
[Visual Basic]
Public Event PageChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.PageColorDialog Method

Invokes the built-in dialog box for setting the page color.

Introduced: 24.0.

Syntax

[C#]
public DialogResult PageColorDialog();
[Visual Basic]
Public Function PageColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.PageFormatChanged Event

Occurs when the page format settings have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler PageFormatChanged;
[Visual Basic]
Public Event PageFormatChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.PageMargins Property

Gets or sets the margins for the pages of the current document. The measure depends on the TextControl.PageUnit property. The default measure is 1/100th inch. The property value is an object of the type PageMargins. For more information see the description of the PageMargins class.

Syntax

[C#]
public PageMargins PageMargins { get; set; }
[Visual Basic]
Public Property PageMargins() As PageMargins

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.Pages Property

Gets the number of pages contained in the current document.

Syntax

[C#]
public int Pages { get; }
[Visual Basic]
Public ReadOnly Property Pages() As Integer

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.PageSize Property

Specifies the width and height of the pages for the current document. The measure depends on the TextControl.PageUnit property. The default measure is 1/100th inch. The property value is an object of the type PageSize. For more information see the description of the PageSize class.

Syntax

[C#]
public System.Drawing.Size PageSize { get; set; }
[Visual Basic]
Public Property PageSize() As System.Drawing.Size

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.PageUnit Property

Gets or sets the measure used for page sizes and page margins.

Introduced: 16.0.

Syntax

[C#]
public PageUnit PageUnit { get; set; }
[Visual Basic]
Public Property PageUnit() As PageUnit
Value | Description
Millimeter | The measure for page sizes and page margins is millimeter.
CentiInch | The measure for page sizes and page margins is 1/100th inch.
StandardWPF | The measure for page sizes and page margins is 1/96th inch.
Twips | The measure for page sizes and page margins is Twips (1/1440th inch). This is the internally used TXTextControl measure.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.ParagraphFormat Property

Gets or sets the paragraph formatting attributes of the text displayed by the control. The property value is an object of the type ParagraphFormat. For more information see the description of the ParagraphFormat class.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.ParagraphFormatChanged Event

Occurs when the formatting attributes of the selected paragraphs have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler ParagraphFormatChanged;
[Visual Basic]
Public Event ParagraphFormatChanged As EventHandler

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.TextControl.ParagraphFormatDialog Method

Invokes the built-in dialog box for setting the formatting attributes of a paragraph.

ParagraphFormatDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult ParagraphFormatDialog();
[Visual Basic]
Public Function ParagraphFormatDialog() As DialogResult

ParagraphFormatDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult ParagraphFormatDialog(int activeTab);
[Visual Basic]
Public Function ParagraphFormatDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting alignment, line spacing, indentation and Distances, and if this parameter is 1, the dialog box shows the tab for setting a frame and pagination.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Paragraphs Property

Gets a collection of all paragraphs contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type ParagraphCollection.

Introduced: 15.0.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.TextControl.ParagraphStyles Property

Gets a collection of all paragraph styles the current document contains. The property's value is an object of the type ParagraphStyleCollection.

Introduced: 10.1.

Syntax

[C#]
public ParagraphStyleCollection ParagraphStyles { get; }
[Visual Basic]
Public ReadOnly Property ParagraphStyles() As ParagraphStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.TextControl.Paste Method

Replaces the current selection in the Text Control with the contents of the Clipboard.

Introduced: 15.0.

Paste()

Replaces the current selection in the Text Control with the contents of the Clipboard. If the data in the clipboard are provided in several formats, the format with the maximum of information is used.

[C#]
public void Paste();
[Visual Basic]
Public Sub Paste()

Paste(ClipboardFormat)

Replaces the current selection in the Text Control with the contents of the Clipboard. Only data provided in the specified format is inserted.

[C#]
public void Paste(ClipboardFormat format);
[Visual Basic]
Public Sub Paste(ByVal format As ClipboardFormat)
Member | Description
format | Specifies the format to paste. It must be one of the ClipboardFormat values contained in the array returned through the TextControl.GetClipboardFormats method. This parameter can be used to change the default behaviour, if the clipboard contains the data in more than one format. By default, TXTextControl inserts data from the clipboard in the following order: textframe, formatted image, formatted text (TXTextControl format), formatted text (RTF format), formatted text (HTML format), plain text, image.

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.TextControl.PermanentControlChars Property

Gets or sets a value indicating which control characters are shown permanently on the screen. The property's value can be a bitwise OR combination of the PermanentControlChar enumeration. The bitwise AND operator can be used to test for a given format.

Introduced: 19.0.

Syntax

[C#]
public PermanentControlChar PermanentControlChars { get; set; }
[Visual Basic]
Public Property PermanentControlChars() As PermanentControlChar

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Print Method

Prints a Text Control document or a part of a document.

Print(String)

Opens the standard print dialog to get printer settings and prints the document.

[C#]
public void Print(string docName);
[Visual Basic]
Public Sub Print(ByVal docName As String)
Member | Description
docName | Specifies the document's name.

Print(PrintDocument)

Prints the document using the printer settings of the specified PrintDocument.

[C#]
public void Print(System.Drawing.Printing.PrintDocument printDocument);
[Visual Basic]
Public Sub Print(ByVal printDocument As System.Drawing.Printing.PrintDocument)
Member Description
printDocument

Specifies an instance of the PrintDocument class. Text Control uses the following settings of this object:

Setting | Meaning
DocumentName | Specifies the document's name.
PrintController | Specifies the document's print controller.
PrinterSettings.FromPage | The first page to print.
PrinterSettings.ToPage | The last page to print.
PrinterSettings.Copies | The number of copies to print.
PrinterSettings.Collate | Specifies how the printed pages are sorted.
PrinterSettings.PrinterName | Specifies the name of the printer.
PrinterSettings.PrintToFile | Specifies whether the printed pages are saved in a file.
PrinterSettings.PrintRange | Specifies the range of pages to print.
DefaultPageSettings.Color | Specifies whether the printed pages are printed colored.

Print(Int32, PrintPageEventArgs)

Prints a single page. This method can be called from the PrintPage event handler.

[C#]
public void Print(int page, System.Drawing.Printing.PrintPageEventArgs ppe);
[Visual Basic]
Public Sub Print(ByVal page As Integer, ByVal ppe As System.Drawing.Printing.PrintPageEventArgs)
Member | Description
page | Specifies a page number to print.
ppe | Specifies the event arguments of the print document's PrintPage event.

See Also

  • Printing into a PrintDocument
  • Printing without the Status Dialog
  • Programming Category: Printing and Print Preview
  • Graphical Overview: Printing and Print Preview


TXTextControl.TextControl.PrintPreview Method

Shows a print preview of the current document.

PrintPreview(String)

Shows a print preview of the current document.

[C#]
public void PrintPreview(string docName);
[Visual Basic]
Public Sub PrintPreview(ByVal docName As String)
Member | Description
docName | Specifies the document's name.

PrintPreview(PrintDocument)

Shows a print preview of the current document using settings from the specified PrintDocument object.

[C#]
public void PrintPreview(System.Drawing.Printing.PrintDocument printDocument);
[Visual Basic]
Public Sub PrintPreview(ByVal printDocument As System.Drawing.Printing.PrintDocument)
Member | Description
printDocument | Specifies an instance of the PrintDocument class.

See Also

  • Printing into a PrintDocument
  • Printing without the Status Dialog
  • Programming Category: Printing and Print Preview
  • Graphical Overview: Printing and Print Preview


TXTextControl.TextControl.Redo Method

Redoes the last Text Control operation.

Syntax

[C#]
public void Redo();
[Visual Basic]
Public Sub Redo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.RedoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Redo method is made. The property's value is null if there is no action that can be redone.

Introduced: 11.0.

Syntax

[C#]
public string RedoActionName { get; }
[Visual Basic]
Public ReadOnly Property RedoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.Replace Method

Opens the built-in Replace dialog box.

Syntax

[C#]
public void Replace();
[Visual Basic]
Public Sub Replace()

See Also

  • Programming Category: Search and Replace
  • Graphical Overview: Search and Replace
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.ResetAutoControlSize Method

Resets the AutoControlSize property to its default values. The default of the AutoControlSize property is a TextControl object that does not automatically expand or shrink its width or height.

Introduced: 11.0.

Syntax

[C#]
public void ResetAutoControlSize();
[Visual Basic]
Public Sub ResetAutoControlSize()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ResetBackColor Method

Overridden. Resets the BackColor property to its default value. The default value is the system color for the window background.

Syntax

[C#]
public override void ResetBackColor();
[Visual Basic]
Public Overloads Overrides Sub ResetBackColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ResetContents Method

Deletes the entire contents of a Text Control.

Syntax

[C#]
public void ResetContents();
[Visual Basic]
Public Sub ResetContents()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.ResetCursor Method

Overridden. Resets the Cursor property to its default value. The default value is the IBeam cursor.

Syntax

[C#]
public override void ResetCursor();
[Visual Basic]
Public Overloads Overrides Sub ResetCursor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ResetDisplayColors Method

Resets all display colors of a text control to their system dependent default values.

Introduced: 15.1.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()


TXTextControl.TextControl.ResetFieldCursor Method

Resets the FieldCursor property to its default value. The default value is the Hand cursor.

Syntax

[C#]
public void ResetFieldCursor();
[Visual Basic]
Public Sub ResetFieldCursor()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.ResetForeColor Method

Overridden. Resets the ForeColor property to its default value. The default value is the system color for the window text.

Syntax

[C#]
public override void ResetForeColor();
[Visual Basic]
Public Overloads Overrides Sub ResetForeColor()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.ResetPageMargins Method

Resets the PageMargins property to its default value. The default page margins are 1 inch.

Syntax

[C#]
public void ResetPageMargins();
[Visual Basic]
Public Sub ResetPageMargins()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.ResetPageSize Method

Resets the PageSize property to its default value. The default page size is US letter (8,5 x 11 inch).

Syntax

[C#]
public void ResetPageSize();
[Visual Basic]
Public Sub ResetPageSize()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.ResetTextBackColor Method

Resets the TextBackColor property to its default value. The default value is the setting of the BackColor property.

Syntax

[C#]
public void ResetTextBackColor();
[Visual Basic]
Public Sub ResetTextBackColor()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.Ribbon Property

Specifies the ribbon control to be used with a TextControl. The property value is null if there is no ribbon connected. Otherwise it is an object of the type Ribbon.

Introduced: 24.0.

Syntax

[C#]
public Windows.Forms.Ribbon.Ribbon Ribbon { get; set; }
[Visual Basic]
Public Property Ribbon() As Windows.Forms.Ribbon.Ribbon

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.TextControl.RulerBar Property

Specifies the horizontal ruler bar control to be used with a TextControl. The property value is null if there is no ruler bar connected. Otherwise it is an object of the type RulerBar.

Syntax

[C#]
public RulerBar RulerBar { get; set; }
[Visual Basic]
Public Property RulerBar() As RulerBar

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.TextControl.Save Method

Saves the complete contents of a document with the specified format.

Save()

Opens a file save dialogbox and saves the complete contents of a document in a file.

[C#]
public DialogResult Save();
[Visual Basic]
Public Function Save() As DialogResult

Save(StreamType)

Opens a file save dialogbox and saves the complete contents of a document in a file with the specified format.

[C#]
public DialogResult Save(StreamType streamType);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Save(String, StreamType)

Saves the complete contents of a document in the specified file with the specified format.

[C#]
public void Save(string path, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.

Save(FileStream, StreamType)

Saves the complete contents of a document in the specified file stream with the specified format.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.

Save(Byte[], BinaryStreamType)

Saves the complete contents of a document in the specified byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the complete contents of a document as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(StreamType, SaveSettings)

Opens a file save dialogbox and saves the complete contents of a document in a file with the specified format and special settings.

[C#]
public DialogResult Save(StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType, ByVal saveSettings As SaveSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file using the specified format and special settings.

[C#]
public void Save(string path, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(FileStream, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file stream using the specified format and special settings.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the complete contents of a document in the specified byte array using the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the complete contents of a document as a string using the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Return Value

The implementations that open a dialog box return the dialog's result value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.TextControl.ScrollBars Property

Gets or sets a value indicating whether a Text Control has horizontal or vertical scroll bars.

Syntax

[C#]
public ScrollBars ScrollBars { get; set; }
[Visual Basic]
Public Property ScrollBars() As ScrollBars
Value | Description
None | The Text Control has no scrollbars.
Horizontal | The Text Control has a horizontal scrollbar.
Vertical | The Text Control has a vertical scrollbar.
Both | The Text Control has a horizontal and a vertical scrollbar.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ScrollLocation Property

Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.

Syntax

[C#]
public System.Drawing.Point ScrollLocation { get; set; }
[Visual Basic]
Public Property ScrollLocation() As System.Drawing.Point

Limitations

Runtime only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.SectionChanged Event

Occurs when the text input position has been moved to another section. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 14.0.

Syntax

[C#]
public event EventHandler SectionChanged;
[Visual Basic]
Public Event SectionChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.SectionFormatDialog Method

Invokes the built-in tabbed dialog box for setting section attributes. These are page settings such as margins, size and orientation and all settings concerning headers and footers.

Introduced: 14.0.

Syntax

[C#]
public DialogResult SectionFormatDialog(int activeTab);
[Visual Basic]
Public Function SectionFormatDialog(ByVal activeTab As Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting page margins, page size and orientation, if this parameter is 1, the dialog box shows the tab for setting headers and footers and if it is 2, the dialog shows the tab for setting column attributes.

Return Value

If the dialog is left with the Cancel button, the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Sections Property

Gets a collection of all sections in the document. The property's value is an object of the type SectionCollection.

Introduced: 14.0.

Syntax

[C#]
public SectionCollection Sections { get; }
[Visual Basic]
Public ReadOnly Property Sections() As SectionCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.TextControl.Select Method

Selects text within the Text Control.

Syntax

[C#]
public void Select(int start, int length);
[Visual Basic]
Public Sub Select(ByVal start As Integer, ByVal length As Integer)
Parameter | Description
start | Specifies the selection's start position.
length | Specifies the number of selected characters.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.SelectAll Method

Selects all text in the Text Control.

Syntax

[C#]
public void SelectAll();
[Visual Basic]
Public Sub SelectAll()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.Selection Property

Gets or sets the current selection in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type Selection. A selection can be used to assign character and paragraph formatting attributes to a piece of text.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.SelectionViewMode Property

Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.

Introduced: 17.0.

Syntax

[C#]
public SelectionViewMode SelectionViewMode { get; set; }
[Visual Basic]
Public Property SelectionViewMode() As SelectionViewMode
Value | Description
Classic | When text is selected, this text is inverted on the screen.
TransparentBitmap | When text is selected, a transparent bitmap is used to display the selection.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.TextControl.SpellCheckContextMenuStrip Property

Specifies the context menu which is used when the end-user right-clicks a misspelled word. A context menu is only available when a spell checking component has been connected with the SpellChecker property.

Introduced: 17.0.

Syntax

[C#]
public string SpellCheckContextMenuStrip { get; set; }
[Visual Basic]
Public Property SpellCheckContextMenuStrip() As String
Value | Description
(none) | No context menu is displayed when the end-user right-clicks a misspelled word.
(Default) | The TXTextControl built-in context menu is displayed when the end-user right-clicks a misspelled word.
other | The property value must be the name of a user-defined context menu.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.SpellCheckDialog Method

Invokes the built-in dialog box for correcting misspelled words. The dialog steps through all misspelled words in the current document. It begins with the main text following by all headers, footers and textframes. This dialog is only available when a spell checking component has been connected with the SpellChecker property.

Introduced: 17.0.

SpellCheckDialog()

Invokes the built-in dialog box for correcting misspelled words.

[C#]
public void SpellCheckDialog();
[Visual Basic]
Public Sub SpellCheckDialog()

SpellCheckDialog(Object)

Invokes the built-in dialog box for correcting misspelled words using the specified dictionary for making suggestions.

[C#]
public void SpellCheckDialog(object suggestionDictionary);
[Visual Basic]
Public Sub SpellCheckDialog(ByVal suggestionDictionary As Object)
Parameter | Description
suggestionDictionary | Specifies the dictionary used for making suggestions. This parameter is only useful, if more than one dictionary has been added to the spellchecker.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.SpellChecker Property

Specifies the spell checking component to be used with a TextControl. The property value is null, if there is no spell checking component connected. Otherwise it must be an object of the type TXSpellChecker. When a spell checking component is connected and the IsSpellCheckingEnabled property has been set to true, misspelled words are automatically underlined with a red zigzag line. The SpellCheckDialog method can be used to correct the misspelled words contained in the document. When a spell checking component is connected and the IsHyphenationEnabled property has been set to true, a document is automatically hyphenated. If the IsLanguageDetectionEnabled property has been set to true, a language is automatically detected for all text parts with a neutral language.

Introduced: 17.0.

Syntax

[C#]
public Component SpellChecker { get; set; }
[Visual Basic]
Public Property SpellChecker() As Component

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.SpellCheckText Event

Occurs, if the document's text has been altered and the spelling of the new text must be checked. This event occurs only, if the SpellChecker property has been set to null and if the IsSpellCheckingEnabled property has been set to true. If a spell checking component has been connected with the TextControl, this event is handled internally. The event handler receives an argument of type SpellCheckTextEventArgs containing data related to this event.

Introduced: 16.0.

Syntax

[C#]
public event SpellCheckTextEventHandler SpellCheckText;
[Visual Basic]
Public Event SpellCheckText As SpellCheckTextEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.TextControl.StatusBar Property

Specifies the status bar control to be used with a TextControl. The property value is null if there is no status bar connected. Otherwise it is an object of the type StatusBar.

Syntax

[C#]
public StatusBar StatusBar { get; set; }
[Visual Basic]
Public Property StatusBar() As StatusBar

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.TextControl.SubTextPartClicked Event

Occurs when a subtextpart has been clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartClicked;
[Visual Basic]
Public Event SubTextPartClicked As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.SubTextPartDoubleClicked Event

Occurs when a subtextpart has been double-clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartDoubleClicked;
[Visual Basic]
Public Event SubTextPartDoubleClicked As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.SubTextPartEntered Event

Occurs when the current input position has been moved to a position that belongs to a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartEntered;
[Visual Basic]
Public Event SubTextPartEntered As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.SubTextPartLeft Event

Occurs when the current input position has left a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartLeft;
[Visual Basic]
Public Event SubTextPartLeft As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.SubTextParts Property

Gets a collection of all subtextparts contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.TabDialog Method

Invokes the built-in dialog box for setting tabs.

Syntax

[C#]
public DialogResult TabDialog();
[Visual Basic]
Public Function TabDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.TableCreated Event

Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier. It does not occur when the table is inserted with the TableInsert method or for tables that have a previously set identifier when loading a document. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableCreated;
[Visual Basic]
Public Event TableCreated As TableEventHandler

Remarks

The TableCreated event is always fired, if a table is inserted from the clipboard and is not next to another table. If the table has an identifier, it will be kept. If a previously existent table has the same identifier, the identifier will point to the already present table.

The TableCreated event is not fired, if a table is inserted from the clipboard next to another table. The table will be merged with the existent table and the resulting table inherits the identifier from the already existent one.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.TableDeleted Event

Occurs after a table has been deleted. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableDeleted;
[Visual Basic]
Public Event TableDeleted As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.TableFormatChanged Event

Occurs when the design attributes of a selected table have been changed. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableFormatChanged;
[Visual Basic]
Public Event TableFormatChanged As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.TableFormatDialog Method

Invokes the built-in dialog box for setting formatting attributes of tables. The TableCollection.GetItem method can be used to test whether a table is selected or not.

TableFormatDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult TableFormatDialog();
[Visual Basic]
Public Function TableFormatDialog() As DialogResult

TableFormatDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult TableFormatDialog(int activeTab);
[Visual Basic]
Public Function TableFormatDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting frame lines, color and distances, and if this parameter is 1, the dialog box shows the tab for setting vertical size and alignment.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.Tables Property

Gets a collection of all tables contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Runtime only.

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.TextControl.TextBackColor Property

Gets or sets the background color for the text.

Syntax

[C#]
public Color TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor() As Color

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.TextControl.TextBackColorDialog Method

Invokes the built-in dialog box for setting the background color of the text.

Introduced: 22.0.

Syntax

[C#]
public DialogResult TextBackColorDialog();
[Visual Basic]
Public Function TextBackColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.TextChars Property

Gets a collection of all characters contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TextCharCollection.

Introduced: 10.1.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.TextControl.TextContextMenuOpening Event

Occurs immedialtely before a built-in context menu will be opened. The event handler receives an argument of type TextContextMenuEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextContextMenuHandler TextContextMenuOpening;
[Visual Basic]
Public Event TextContextMenuOpening As TextContextMenuEventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.TextFieldChanged Event

Occurs when the text of a text field has been changed. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldChanged;
[Visual Basic]
Public Event TextFieldChanged As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldClicked Event

Occurs when a text field has been clicked on. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldClicked;
[Visual Basic]
Public Event TextFieldClicked As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldCreated Event

Occurs when a text field has been pasted from the clipboard. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldCreated;
[Visual Basic]
Public Event TextFieldCreated As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldDoubleClicked Event

Occurs when a text field has been double-clicked on. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldDoubleClicked;
[Visual Basic]
Public Event TextFieldDoubleClicked As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldDeleted Event

Occurs when a text field has been deleted. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldDeleted;
[Visual Basic]
Public Event TextFieldDeleted As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldEntered Event

Occurs when the current input position has been moved to a position that belongs to a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldEntered;
[Visual Basic]
Public Event TextFieldEntered As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFieldLeft Event

Occurs when the current input position has left a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldLeft;
[Visual Basic]
Public Event TextFieldLeft As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFields Property

Gets a collection of all standard text fields contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextControl.TextFrameActivated Event

Occurs when a text frame has been activated. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameActivated;
[Visual Basic]
Public Event TextFrameActivated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameAppearanceChanged Event

Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameAppearanceChanged;
[Visual Basic]
Public Event TextFrameAppearanceChanged As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameAttributesDialog Method

Invokes the built-in dialog box for setting attributes of text frames. This dialog box is only shown, if a text frame is currently selected. The TextFrameCollection.GetItem method can be used to test whether a text frame is selected or not.

Introduced: 12.0.

TextFrameAttributesDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult TextFrameAttributesDialog();
[Visual Basic]
Public Function TextFrameAttributesDialog() As DialogResult

TextFrameAttributesDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult TextFrameAttributesDialog(int activeTab);
[Visual Basic]
Public Function TextFrameAttributesDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further textframe attributes such as a frame line or a background color.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames
  • Programming Category: Integrated Dialog Boxes


TXTextControl.TextControl.TextFrameClicked Event

Occurs when a text frame has been clicked on. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameClicked;
[Visual Basic]
Public Event TextFrameClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameCreated Event

Occurs when a new text frame has been created. It occurs if a text frame has been inserted in the document with the clipboard or if a file containing text frames has been loaded. It does not occur if an text frame has been added with the TextFrameCollection.Add method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameCreated;
[Visual Basic]
Public Event TextFrameCreated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameDeactivated Event

Occurs when a text frame has been deactivated. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeactivated;
[Visual Basic]
Public Event TextFrameDeactivated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameDeleted Event

Occurs when a text frame has been deleted. It occurs if a text frame has been deleted while editing a document or if an text frame has been deleted with the TextFrameCollection.Remove method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeleted;
[Visual Basic]
Public Event TextFrameDeleted As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameDeselected Event

Occurs when a text frame has been deselected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeselected;
[Visual Basic]
Public Event TextFrameDeselected As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameDoubleClicked Event

Occurs when a text frame has been doubleclicked on. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDoubleClicked;
[Visual Basic]
Public Event TextFrameDoubleClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameMarkerLines Property

Specifies whether text frames that have no border line are shown with marker lines.

Introduced: 12.0.

Syntax

[C#]
public bool TextFrameMarkerLines { get; set; }
[Visual Basic]
Public Property TextFrameMarkerLines() As Boolean

Example

The following XAML example shows how to bind the TextFrameMarkerLines property to a check box.

<CheckBox
   Content="Show text frame marker lines"
   IsChecked="{Binding ElementName=textControl1, Path=TextFrameMarkerLines}" />

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameMoved Event

Occurs when a text frame has been moved. It does not occur, if an inline or anchored text frame has been move because text has been inserted. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameMoved;
[Visual Basic]
Public Event TextFrameMoved As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameRightClicked Event

Occurs when a text frame has been clicked on with the right mouse button. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameRightClicked;
[Visual Basic]
Public Event TextFrameRightClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrames Property

Gets a collection of all text frames contained in the text part with the input focus. This can be the main text, a text frame or a header or footer.. The property's value is an object of the type TextFrameCollection. If a text frame contains further text frames, the inner frames are not contained in this collection.

Introduced: 12.0.

Syntax

[C#]
public TextFrameCollection TextFrames { get; }
[Visual Basic]
Public ReadOnly Property TextFrames() As TextFrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameSelected Event

Occurs when a text frame has been selected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameSelected;
[Visual Basic]
Public Event TextFrameSelected As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextFrameSized Event

Occurs when a text frame has been sized. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 12.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameSized;
[Visual Basic]
Public Event TextFrameSized As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextControl.TextParts Property

Gets a collection of all main text parts the current document contains. The property's value is an object of the type TextPartCollection. The main text parts are the main text, text frames and headers and footers.

Introduced: 16.0.

Syntax

[C#]
public TextPartCollection TextParts { get; }
[Visual Basic]
Public ReadOnly Property TextParts() As TextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextControl.Undo Method

Undoes the last edit operation in the Text Control.

Syntax

[C#]
public void Undo();
[Visual Basic]
Public Sub Undo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.UndoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Undo method is made. The property's value is null if there is no action that can be undone.

Introduced: 11.0.

Syntax

[C#]
public string UndoActionName { get; }
[Visual Basic]
Public ReadOnly Property UndoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.TextControl.VerticalRulerBar Property

Specifies the vertical ruler bar control to be used with a TextControl. The property value is null if there is no ruler bar connected. Otherwise it is an object of the type RulerBar.

Syntax

[C#]
public RulerBar VerticalRulerBar { get; set; }
[Visual Basic]
Public Property VerticalRulerBar() As RulerBar

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.TextControl.VExpanded Event

Occurs when the Text Control has automatically expanded its size vertically. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 11.0.

Syntax

[C#]
public event EventHandler VExpanded;
[Visual Basic]
Public Event VExpanded As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.ViewMode Property

Gets or sets the mode in which Text Control displays its contents.

Syntax

[C#]
public ViewMode ViewMode { get; set; }
[Visual Basic]
Public Property ViewMode() As ViewMode
Value | Description
FloatingText | The Text Control has a vertical scrollbar to enable unlimited text content. The maximum horizontal text extent is the horizontal size of the control. The values of the PageSize and PageMargins properties are ignored. Headers and footers are not displayed.
Normal | The Text Control has scrollbars and text is formatted according to the settings of the PageSize and the PageMargins properties. Headers and footers can be inserted but they are not displayed.
PageView | Text is formatted like in Normal view mode, and additionally the Text Control displays the pages in 3D view with gaps and a desktop background. Headers and footers are displayed in WYSIWYG mode.
SimpleControl | The Text Control formats the text according to the horizontal and vertical extent of the control. If the control is 'full', no further text can be inserted.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.VScroll Event

Occurs when the vertical scroll position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler VScroll;
[Visual Basic]
Public Event VScroll As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.VShrunk Event

Occurs when the Text Control has automatically shrunk its size vertically. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 11.0.

Syntax

[C#]
public event EventHandler VShrunk;
[Visual Basic]
Public Event VShrunk As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Zoomed Event

Occurs when the Text Control has been zoomed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Zoomed;
[Visual Basic]
Public Event Zoomed As EventHandler

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.TextControl.XmlEditMode Property

Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.

Syntax

[C#]
public XmlEditMode XmlEditMode { get; set; }
[Visual Basic]
Public Property XmlEditMode() As XmlEditMode
Value | Description
Validate | Every operation that manipulates an XML document is validated according to the document's DTD. This mode is read only and is automatically switched on after loading a valid XML document.
NoValidate | Text Control operates in its normal editor mode. No validation of an XML document occurs. Because the document can be invalid after every operation the document cannot be saved in XML format.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.XmlInvalid Event

Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.XmlNotWellFormed Event

Occurs when a loaded XML document is not well-formed. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.TextControl.Zoom Method

Zooms the contents of the TextControl.

Introduced: 24.0.

Zoom(Int32)

Zooms the contents of the TextControl using the specified zoom factor.

[C#]
public void Zoom(int zoomFactor);
[Visual Basic]
Public Sub Zoom(ByVal zoomFactor As Integer)
Parameter | Description
zoomFactor | Specifies the zoom factor, in percent.

Zoom(ZoomOption)

Zooms the contents of the TextControl using the specified option.

[C#]
public void Zoom(ZoomOption zoomOption);
[Visual Basic]
Public Sub Zoom(ByVal zoomOption As ZoomOption)
Parameter | Description
zoomOption | Specifies one of the ZoomOption values.

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent, when the TextControl.ViewMode property has been set to PageView or Normal. For the other modes the zoom factor must be between 10 and 400 percent.

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.TextControl.ZoomFactor Property

Gets or sets the zoom factor, in percent, for a Text Control.

Syntax

[C#]
public int ZoomFactor { get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent, when the TextControl.ViewMode property has been set to PageView or Normal. For the other modes the zoom factor must be between 10 and 400 percent.

Example

The following XAML example shows how to Bind the ZoomFactor property to a slider using the WPF.LogarithmicConverter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:LogarithmicConverter
      x:Key="logConv"
      InputMinimum="10"
      InputCenter="100"
      InputMaximum="400"
      OutputMinimum="0"
      OutputMaximum="100" />
</Window.Resources>
…
<Slider
   Minimum="0"
   Maximum="100"
   Value="{Binding ElementName=textControl1, Path=ZoomFactor, Converter={StaticResource logConv}}" />

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.TextControl.Colors Class

The TextControl.Colors class gets, sets or resets the display colors of a Windows Forms TextControl control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the text control's BackgroundStyle property has been set to ColorScheme.

Introduced: 15.1.

Syntax

[C#]
public class TextControl.Colors
[Visual Basic]
Public Class TextControl.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the TextControl.Colors class.

Properties

Property | Description
DarkShadowColor | Gets or sets the display color for the shadow at the right and the bottom edge of the pages.
DesktopColor | Gets or sets the display color for the area around the pages.
HeaderFooterLabelColor | Gets or sets the display color for the label showing which header or footer is activated.
HeaderFooterLineColor | Gets or sets the display color for the dividing line between headers and footers and the main text.
LightShadowColor | Gets or sets the display color for the shadow at the left and the top edge of the pages.

Methods

Method | Description
ResetDarkShadowColor | Resets the text control's DarkShadowColor to its system dependent default value.
ResetDesktopColor | Resets the text control's DesktopColor to its system dependent default value.
ResetHeaderFooterLabelColor | Resets the text control's HeaderFooterLabelColor to its system dependent default value.
ResetHeaderFooterLineColor | Resets the text control's HeaderFooterLineColor to its system dependent default value.
ResetLightShadowColor | Resets the text control's LightShadowColor to its system dependent default value.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors Constructor

Initializes a new instance of the TextControl.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the TextControl.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public TextControl.Colors();
[Visual Basic]
Public Class TextControl.Colors

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.DarkShadowColor Property

Gets or sets the display color for the shadow at the right and the bottom edge of the pages.

Syntax

[C#]
public Color DarkShadowColor { get; set; }
[Visual Basic]
Public Property DarkShadowColor As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.DesktopColor Property

Gets or sets the display color for the area around the pages.

Syntax

[C#]
public Color DesktopColor { get; set; }
[Visual Basic]
Public Property DesktopColor As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.HeaderFooterLabelColor Property

Gets or sets the display color for the label showing which header or footer is activated.

Introduced: 19.0.

Syntax

[C#]
public Color HeaderFooterLabelColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLabelColor As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.HeaderFooterLineColor Property

Gets or sets the display color for the dividing line between headers and footers and the main text.

Introduced: 19.0.

Syntax

[C#]
public Color HeaderFooterLineColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLineColor As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.LightShadowColor Property

Gets or sets the display color for the shadow at the left and the top edge of the pages.

Syntax

[C#]
public Color LightShadowColor { get; set; }
[Visual Basic]
Public Property LightShadowColor As Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.ResetDarkShadowColor Method

Resets the text control's DarkShadowColor to its system dependent default value.

Syntax

[C#]
public void ResetDarkShadowColor();
[Visual Basic]
Public Sub ResetDarkShadowColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.ResetDesktopColor Method

Resets the text control's DesktopColor to its system dependent default value.

Syntax

[C#]
public void ResetDesktopColor();
[Visual Basic]
Public Sub ResetDesktopColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.ResetHeaderFooterLabelColor Method

Resets the text control's HeaderFooterLabelColor to its system dependent default value.

Introduced: 19.0.

Syntax

[C#]
public void ResetHeaderFooterLabelColor();
[Visual Basic]
Public Sub ResetHeaderFooterLabelColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.ResetHeaderFooterLineColor Method

Resets the text control's HeaderFooterLineColor to its system dependent default value.

Introduced: 19.0.

Syntax

[C#]
public void ResetHeaderFooterLineColor();
[Visual Basic]
Public Sub ResetHeaderFooterLineColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextControl.Colors.ResetLightShadowColor Method

Resets the text control's LightShadowColor to its system dependent default value.

Syntax

[C#]
public void ResetLightShadowColor();
[Visual Basic]
Public Sub ResetLightShadowColor()

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.TextEditorException Class

The TextEditorException class informs about errors which can occur during editing text.

Introduced: 24.0.

Syntax

[C#]
public class TextEditorException : Exception
[Visual Basic]
Public Class TextEditorException
  Inherits EventArgs

Constructors

Constructor | Description
TextEditorException | Overloaded. Initializes a new instance of the TextEditorException class.

See Also

  • Programming Category: Exceptions


TXTextControl.TextEditorException Constructor

Initializes a new instance of the TextEditorException class.

TextEditorException()

Initializes a new instance of the TextEditorException class.

[C#]
public TextEditorException();
[Visual Basic]
Public Sub New

TextEditorException(String)

Initializes a new instance of the TextEditorException class with a specified error message.

[C#]
public TextEditorException(string message);
[Visual Basic]
Public Sub New(message as String)
Parameter | Description
message | The error message that explains the reason for the exception.

TextEditorException(String, Exception)

Initializes a new instance of the TextEditorException class with a specified error message and a reference to the inner exception that is the cause of this exception.

[C#]
public TextEditorException(string message, Exception innerException);
[Visual Basic]
Public Sub New(message as String, innerException as Exception)
Parameter | Description
message | The error message that explains the reason for the exception.
innerException | The exception that is the cause of the current exception.

See Also

  • Programming Category: Exceptions


TXTextControl.TextField Class

An instance of the TextField class represents a text field in a Text Control document. A text field is a marked piece of text that has properties like text or a name. The TextControl class has several events that inform about different occurrences. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public class TextField
[Visual Basic]
Public Class TextField

Constructors

Constructor | Description
TextField | Overloaded. Creates a new instance of the TextField class.

Properties

Property | Description
Bounds | Gets the bounding rectangle of a text field.
ContainsInputPosition | Returns true, if the Textfield contains the current text input position.
Deleteable | Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited.
DoubleClickEvent | Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field.
DoubledInputPosition | Specifies whether a text field has a doubled input position in front of its first character and behind its last character.
Editable | Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited.
FormattingBounds | Gets the formatting rectangle of a text field.
ID | Gets or sets an identifier for a text field.
IsSpellCheckingEnabled | Specifies whether a text field's text is checked on misspelled words.
Length | Gets the number of characters in a text field.
Name | Relates a user-defined name to a text field.
ShowActivated | Specifies whether a text field toggles its background to gray, if the current input position is in the field.
Start | Gets the first character position (one-based) of a text field.
Text | Returns or sets the text which is contained within a text field.

Methods

Method | Description
ScrollTo | Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document.

Example

The following example shows how to insert and populate a text field.

[C#]
TXTextControl.TextField field = new TXTextControl.TextField("Product");
field.Name = "product";
textControl1.TextFields.Add(field);

foreach (TXTextControl.TextField curfield in textControl1.TextFields)
{
    if (curfield.Name == "product")
        curfield.Text = "TX Text Control";
}
[Visual Basic]
Dim field As TXTextControl.TextField = New TXTextControl.TextField("Product")
field.Name = "product"
TextControl1.TextFields.Add(field)

For Each curField As TXTextControl.TextField In TextControl1.TextFields
    If curField.Name = "product" Then
        curField.Text = "TX Text Control"
    End If
Next

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField Constructor

Creates a new instance of the TextField class.

TextField()

Creates an empty TextField object.

[C#]
public TextField();
[Visual Basic]
Public Sub New()

TextField(String)

Creates a TextField object with the specified visible text.

[C#]
public TextField(string text);
[Visual Basic]
Public Sub New(ByVal text As String)
Parameter | Description
text | Specifies the visible text of the text field.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Bounds Property

Gets the bounding rectangle of a text field. The bounding rectangle is the smallest rectangle which contains all characters of the field's text. The rectangle is given in twips with an origin at the upper left corner of the document.

Introduced: 15.0.

Syntax

[C#]
public Rectangle Bounds { get; }
[Visual Basic]
Public ReadOnly Property Bounds() As Rectangle

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.ContainsInputPosition Property

Returns true, if the Textfield contains the current text input position.

Introduced: 22.0.

Syntax

[C#]
public bool ContainsInputPosition { get; }
[Visual Basic]
Public ReadOnly Property ContainsInputPosition() As Boolean

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Deleteable Property

Specifies whether a text field can be deleted by the end-user while a TX Text Control document is being edited. The default setting of this property is true.

Syntax

[C#]
public bool Deleteable { get; set; }
[Visual Basic]
Public Property Deleteable() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.DoubleClickEvent Property

Specifies whether a TextControl.TextFieldDoubleClicked event is raised, if the end-user doubleclicks the text field. If an event is raised, the normal double-click processing, which selects a single word in the text is suppressed. The default setting of this property is true.

Syntax

[C#]
public bool DoubleClickEvent { get; set; }
[Visual Basic]
Public Property DoubleClickEvent() As Boolean

Remarks

If this property is set to true, the default double-click processing is disabled for the text field's text.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.DoubledInputPosition Property

Specifies whether a text field has a doubled input position in front of its first character and behind its last character. This enables an end-user to decide whether inserted text at these positions will belong to the text field or not. The default setting of this property is false.

Syntax

[C#]
public bool DoubledInputPosition { get; set; }
[Visual Basic]
Public Property DoubledInputPosition() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Editable Property

Specifies whether the text of a text field can be changed by the end-user while a TX Text Control document is being edited. The default setting of this property is true.

Syntax

[C#]
public bool Editable { get; set; }
[Visual Basic]
Public Property Editable() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.FormattingBounds Property

Gets the formatting rectangle of a text field. The formatting rectangle is the largest rectangle to which the area covered by the field can grow. The rectangle is given in twips with an origin at the upper left corner of the document.

Introduced: 15.0.

Syntax

[C#]
public Rectangle FormattingBounds { get; }
[Visual Basic]
Public ReadOnly Property FormattingBounds() As Rectangle

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.ID Property

Gets or sets an identifier for a text field. This identifier can be used to uniquely identify a text field.

Syntax

[C#]
public int ID { get; set; }
[Visual Basic]
Public Property ID() As Integer

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Identifiers and Names
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.IsSpellCheckingEnabled Property

Specifies whether a text field's text is checked on misspelled words. The default setting of this property is true.

Introduced: 16.0.

Syntax

[C#]
public bool IsSpellCheckingEnabled { get; set; }
[Visual Basic]
Public Property IsSpellCheckingEnabled() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Length Property

Gets the number of characters in a text field.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Name Property

Relates a user-defined name to a text field. This can be any kind of text. This name can be used to uniquely identify a text field.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Identifiers and Names
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.ScrollTo Method

Sets the current input position to the beginning of a text field and scrolls it into the visible part of the document.

Syntax

[C#]
public bool ScrollTo();
[Visual Basic]
Public Function ScrollTo() As Boolean

Return Value

The return value is true, if the text field could be scrolled. Otherwise it is non-zero.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.ShowActivated Property

Specifies whether a text field toggles its background to gray, if the current input position is in the field. The default setting of this property is false.

Syntax

[C#]
public bool ShowActivated { get; set; }
[Visual Basic]
Public Property ShowActivated() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Start Property

Gets the first character position (one-based) of a text field.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextField.Text Property

Returns or sets the text which is contained within a text field. This property is not supported for the DocumentTarget class.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection Class

An instance of the TextFieldCollection class contains all standard text fields in a Text Control document or part of the document represented through objects of the type TextField. An instance of this class can be obtained with the TextControl.TextFields, HeaderFooter.TextFields or TextFrame.TextFields property. The TextFieldCollection class implements the IEnumerable and the ICollection interface. For more information see the technical article Text Fields and Hypertext Links.

Syntax

[C#]
public sealed class TextFieldCollection: TextFieldCollectionBase
[Visual Basic]
Public NotInheritable Class TextFieldCollection
  Inherits TextFieldCollectionBase

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position. (Inherited from TextFieldCollectionBase.)
Count | Gets the number of elements contained in the collection. (Inherited from TextFieldCollectionBase.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from TextFieldCollectionBase.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from TextFieldCollectionBase.)

Methods

Method | Description
Add | Inserts a new standard text field at the current input position.
Clear | Removes all text fields from a Text Control document.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from TextFieldCollectionBase.)
GetItem | Overloaded. Gets a particular text field from the collection.
Remove | Overloaded. Removes a text field from a Text Control document.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection.Add Method

Inserts a new standard text field at the current input position.

Syntax

[C#]
public bool Add(TextField textField);
[Visual Basic]
Public Function Add(ByVal textField As TextField) As Boolean
Parameter | Description
textField | Specifies the text field to add.

Return Value

The return value is true, if the text field could be added. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection.Clear Method

Removes all text fields from a Text Control document.

Introduced: 13.0.

Syntax

[C#]
public void Clear(bool keepText);
[Visual Basic]
Public Sub Clear(ByVal keepText As Boolean)
Parameter | Description
keepText | If this parameter is set to true, all text fields are removed without deleting their texts. Otherwise, the texts are also deleted.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection.GetItem Method

Gets a particular text field from the collection.

GetItem()

Gets the text field at the current text input position or null, if there is no text field at the current text input position.

[C#]
public TextField GetItem();
[Visual Basic]
Public Function GetItem() As TextField

GetItem(Int32)

Gets the text field with the specified id, previously set with the ID property.

[C#]
public TextField GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As TextField
Parameter | Description
id | Specifies the text field's identifier set with the ID property. The method returns null if a text field with the specified identifier does not exist.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollection.Remove Method

Removes a text field from a Text Control document.

Remove(TextField)

Removes the specified text field from the Text Control document.

[C#]
public bool Remove(TextField textField);
[Visual Basic]
Public Function Remove(ByVal textField As TextField) As Boolean
Parameter | Description
textField | Specifies the text field to remove.

Remove(TextField, Boolean)

Removes the specified text field from the Text Control document. The field's visible text remains in the document, when the keepText parameter is set to true.

[C#]
public bool Remove(TextField textField, bool keepText);
[Visual Basic]
Public Function Remove(ByVal textField As TextField, ByVal keepText As Boolean) As Boolean
Parameter | Description
textField | Specifies the text field to remove.
keepText | If this parameter is set to true, the field is removed without deleting its text. Otherwise, the field's text is also deleted.

Return Value

The return value is true, if the text field could be removed. Otherwise it is false.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase Class

The TextFieldCollectionBase class is the base class of the TextFieldCollection, HypertextLinkCollection, DocumentTargetCollection, DocumentLinkCollection, PageNumberFieldCollection and ApplicationFieldCollection classes. It implements their base functionality. The TextFieldCollectionBase class implements the IEnumerable and the ICollection interface.

Syntax

[C#]
public abstract class TextFieldCollectionBase: ICollection, IEnumerable
[Visual Basic]
Public MustInherit Class TextFieldCollectionBase
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
CanAdd | Gets a value indicating whether a new text field can be inserted at the current input position.
Count | Gets the number of elements contained in the collection.
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase.CanAdd Property

Gets a value indicating whether a new text field can be inserted at the current input position. It is true if a text field can be inserted, otherwise it is false. Text Control cannot insert a text field inside of another text field.

Syntax

[C#]
public bool CanAdd { get; }
[Visual Basic]
Public ReadOnly Property CanAdd() As Boolean

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase.IsSynchronized Property

Returns true if the collection is designed to be thread safe, otherwise, it returns false.

Syntax

[C#]
public bool IsSynchronized { get; }
[Visual Basic]
Public ReadOnly Property IsSynchronized() As Boolean

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldCollectionBase.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

[C#]
public object SyncRoot { get; }
[Visual Basic]
Public ReadOnly Property SyncRoot() As Object

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldEventArgs Class

The TextFieldEventArgs class provides data for the TextControl.TextFieldClicked, TextControl.TextFieldCreated, TextControl.TextFieldDoubleClicked, TextControl.TextFieldDeleted, TextControl.TextFieldChanged, TextControl.TextFieldEntered and TextControl.TextFieldLeft events.

Syntax

[C#]
public class TextFieldEventArgs: EventArgs
[Visual Basic]
Public Class TextFieldEventArgs
  Inherits EventArgs

Properties

Property | Description
TextField | Gets an object that represents the text field which causes the event.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFieldEventArgs.TextField Property

Gets an object that represents the text field which causes the event. It is of the type TextField. If the text field has been deleted, only the ID and the Name property are available.

Syntax

[C#]
public TextField TextField { get; }
[Visual Basic]
Public ReadOnly Property TextField() As TextField

Limitations

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.TextFrame Class

An instance of the TextFrame class represents a text frame in a Text Control document. A text frame is a rectangle that can be filled with text through an end-user and that can be edited like the main text. The TextControl class has several events that inform about different occurrences. A text frame can be added to the document through the TextFrameCollection class. The TextFrame class implements the IFormattedText interface.

Introduced: 12.0.

Syntax

[C#]
public class TextFrame : FrameBase, IFormattedText
[Visual Basic]
Public Class TextFrame
  Inherits FrameBase
  Implements IFormattedText

Constructors

Constructor | Description
TextFrame | Initializes a new instance of the TextFrame class.

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph. (Inherited from FrameBase.)
ApplicationFields | Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document.
BackColor | Gets or sets the background color of a text frame.
Barcodes | Gets a collection of all barcodes contained in a text frame.
BorderWidth | Gets or sets the width, in twips, of a text frame's border line.
Charts | Gets a collection of all charts contained in a text frame.
DocumentLinks | Gets a collection of all links in a text frame which point to targets in the same document.
DocumentTargets | Gets a collection of all targets in a text frame.
Drawings | Gets a collection of all drawings contained in a text frame.
Frames | Gets a collection of all images, textframes, charts, barcodes and drawings in a text frame.
HypertextLinks | Gets a collection of all hypertext links in a text frame.
ID | Gets or sets an identifier for the frame. (Inherited from FrameBase.)
Images | Gets a collection of all images contained in a text frame.
InsertionMode | (Only for compatibility) Gets or sets a value determining whether a text frame is treated as a single character or the document's text either flows around or overwrites the text frame.
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. (Inherited from FrameBase.)
InternalMargins | Gets or sets the distances, in twips, between the text frame's border line and the text.
Lines | Gets a collection of all text lines contained in a text frame.
Location | Gets or sets, in twips, the frame's current location. (Inherited from FrameBase.)
MisspelledWords | Gets a collection of all misspelled words the text frame contains.
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface. (Inherited from FrameBase.)
Name | Gets or sets a name for the frame. (Inherited from FrameBase.)
Paragraphs | Gets a collection of all paragraphs contained in a text frame.
Selection | Gets or sets the current selection in a text frame.
Size | Gets or sets the frame's size in twips. (Inherited from FrameBase.)
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface. (Inherited from FrameBase.)
SubTextParts | Gets a collection of all subtextparts in a text frame.
Tables | Gets a collection of all tables in a text frame.
TextChars | Gets a collection of all characters contained in a text frame.
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text. (Inherited from FrameBase.)
TextFields | Gets a collection of all standard text fields in a text frame.
TextPosition | Read only. Gets the frame's character position in the document's text (one-based). (Inherited from FrameBase.)
Transparency | Gets or sets the text frame's transparency.

Methods

Method | Description
Activate | Activates the text frame.
ChangeZOrder | Changes the frame's z-order. (Inherited from FrameBase.)
Find | Finds a text string in a text frame.
GetTextFields | Returns a collection containing text fields of the specified types.

Example

The following example inserts a new text frame and changes the back color to blue:

[C#]
TXTextControl.TextFrame myFrame = new TXTextControl.TextFrame(new Size(3000, 2000));
myFrame.BackColor = Color.Blue;
textControl1.TextFrames.Add(myFrame, -1);
[Visual Basic]
Dim MyFrame As New TXTextControl.TextFrame(New Size(3000, 2000))
MyFrame.BackColor = Color.Blue
TextControl1.TextFrames.Add(MyFrame, -1)

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame Constructor

Initializes a new instance of the TextFrame class.

Syntax

[C#]
public TextFrame(System.Drawing.Size size);
[Visual Basic]
Public Sub New(ByVal size As System.Drawing.Size)
Parameter | Description
size | Specifies the text frame's size in twips.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Activate Method

Activates the text frame. The text frame receives the input focus. A text frame can only be activated, if the text part that contains the text frame has the input focus.

Introduced: 13.0.

Syntax

[C#]
public bool Activate();
[Visual Basic]
Public Function Activate() as Boolean

Return Value

The return value is true, if the text frame could be activated. Otherwise it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.ApplicationFields Property

Gets a collection of all Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set, otherwise this collection is empty.

Introduced: 14.0.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As TXTextControl.ApplicationFieldCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.BackColor Property

Gets or sets the background color of a text frame.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor() As Color

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Barcodes Property

Gets a collection of all barcodes contained in a text frame. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from a text frame.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.BorderWidth Property

Gets or sets the width, in twips, of a text frame's border line. To alter the distance between the border line and the text, use the InternalMargins property. If this property is set to zero, the text frame has no border line.

Syntax

[C#]
public int BorderWidth { get; set; }
[Visual Basic]
Public Property BorderWidth() As Integer

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Charts Property

Gets a collection of all charts contained in a text frame. The property value is an object of the type DataVisualization.ChartCollection. The collection can be used to get or to alter a chart's attributes and to add charts to or to remove charts from a text frame.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.ChartCollection Charts { get; }
[Visual Basic]
Public ReadOnly Property Charts() As DataVisualization.ChartCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.DocumentLinks Property

Gets a collection of all links in a text frame which point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.DocumentTargets Property

Gets a collection of all targets in a text frame. The property value is an object of the type DocumentTargetCollection.

Introduced: 23.0.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Drawings Property

Gets a collection of all drawings contained in a text frame. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from a text frame.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Find Method

Finds a text string in a text frame.

Introduced: 13.0.

Syntax

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

Example

The following example counts all occurrences of the specified string in all text frames of a TX Text Control document:

[C#]
int position = 0, count = 0;

foreach (TextFrame tf in textControl1.TextFrames)
{
  for (position=0;
  (position = tf.Find("test", position, FindOptions.NoHighlight | FindOptions.NoMessageBox)) != -1;
  count++, position++);
}
[Visual Basic]
Dim position As Integer = 0, count As Integer = 0

For Each tf As TextFrame In textControl1.TextFrames
  position = 0
  While (position = tf.Find("test", position, FindOptions.NoHighlight Or FindOptions.NoMessageBox)) <> -1
    count += 1
    position += 1
  End While
Next

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Frames Property

Gets a collection of all images, textframes, charts, barcodes and drawings in a text frame. The property value is an object of the type FrameCollection. The collection can be used to get or to alter common attributes.

Introduced: 23.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.HypertextLinks Property

Gets a collection of all hypertext links in a text frame. The property's value is an object of the type HypertextLinkCollection.

Introduced: 16.0.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Images Property

Gets a collection of all images contained in a text frame. The property value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.InsertionMode Property

(Only for compatibility) Gets or sets a value determining whether a text frame is treated as a single character or the document's text either flows around or overwrites the text frame. If the documents text flows around or overwrites the text frame, this property also determines whether the text frame is moved with the text or fixed positioned on a page.

Syntax

[C#]
public new TextFrameInsertionMode InsertionMode { get; }
[Visual Basic]
Public ReadOnly Property InsertionMode As TextFrameInsertionMode
Value | Description
AsCharacter | The text frame is inserted in the text as a single character.
DisplaceCompleteLines | The text frame is inserted at a certain geometrical location. The text stops at the top and continues at the bottom of the text frame.
DisplaceText | The text frame is inserted at a certain geometrical location. The text flows around the text frame and empty areas at the left and right side are filled.
AboveTheText | The text frame is inserted at a certain geometrical location above the text. This means that the text frame overwrites the text.
BelowTheText | The text frame is inserted at a certain geometrical location below the text. This means that the text overwrites the text frame.
MoveWithText | The text frame is connected with a paragraph and moved with the text.
FixedOnPage | The text frame is fixed positioned on a page.

Remarks

The values of the TextFrameInsertionMode enumeration can be combined. The following combinations are possible:

DisplaceCompleteLines and MoveWithText

DisplaceCompleteLines and FixedOnPage

DisplaceText and MoveWithText

DisplaceText and FixedOnPage

AboveTheText and MoveWithText

AboveTheText and FixedOnPage

BelowTheText and MoveWithText

BelowTheText and FixedOnPage

AsCharacter

For all other combinations an exception is thrown.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.InternalMargins Property

Gets or sets the distances, in twips, between the text frame's border line and the text. The property's value is an array of four variables specifying the distances in the following order: left, top, right and bottom. If a value is set to -1, it is not changed.

Syntax

[C#]
public int[] InternalMargins { get; set; }
[Visual Basic]
Public Property InternalMargins() As Integer()

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Lines Property

Gets a collection of all text lines contained in a text frame. The property value is an object of the type LineCollection.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.MisspelledWords Property

Gets a collection of all misspelled words the text frame contains. The property value is an object of the type MisspelledWordCollection.

Introduced: 16.0.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Paragraphs Property

Gets a collection of all paragraphs contained in a text frame. The property value is an object of the type ParagraphCollection.

Introduced: 15.0.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Selection Property

Gets or sets the current selection in a text frame. The property value is an object of the type Selection. For more information see the description of the Selection class.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.SubTextParts Property

Gets a collection of all subtextparts in a text frame. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Tables Property

Gets a collection of all tables in a text frame. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.TextChars Property

Gets a collection of all characters contained in a text frame. The property value is an object of the type TextCharCollection.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.TextFields Property

Gets a collection of all standard text fields in a text frame. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrame.Transparency Property

Gets or sets the text frame's transparency. It must be a value between 0 and 255. Zero means opaque and 255 means completely transparent.

Introduced: 18.0.

Syntax

[C#]
public byte Transparency { get; set; }
[Visual Basic]
Public Property Transparency() As Byte

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection Class

An instance of the TextFrameCollection class contains all text frames in a Text Control document or part of the document represented through objects of the type TextFrame. An instance of this class can be obtained with the TextControl.TextFrames or the HeaderFooter.TextFrames property. The TextFrameCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 12.0.

Syntax

[C#]
public sealed class TextFrameCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class TextFrameCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Add | Overloaded. Inserts a new text frame in a Text Control document.
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
DeactivateItem | Deactivates the activated text frame and sets the input focus back to the text part that contains the text frame.
GetActivatedItem | Returns the currently activated text frame.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular text frame from the collection.
Remove | Removes a text frame from a Text Control document.

Example

The following example checks all text frames in the collection and adds text field if the back color is blue:

[C#]
foreach (TXTextControl.TextFrame myFrame in textControl1.TextFrames)
{
  if (myFrame.BackColor == Color.Blue)
  {
    myFrame.TextFields.Add(new TXTextControl.TextField("Text field"));
  }
}
[Visual Basic]
For Each MyFrame As TXTextControl.TextFrame In TextControl1.TextFrames
  If MyFrame.BackColor = Color.Blue Then
    MyFrame.TextFields.Add(New TXTextControl.TextField("Text field"))
  End If
Next

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.Add Method

Inserts a new text frame in a Text Control document.

Add(TextFrame, Int32)

Inserts a text frame inline, which means that it is treated in the text like a single character. The frame is inserted at the specified text position.

[C#]
public bool Add(TextFrame textFrame, int textPosition);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal textPosition As Integer) As Boolean
Parameter | Description
textFrame | Specifies the text frame to add.
textPosition | Specifies the text position at which the text frame is to be inserted. If -1 is specified, the text frame is inserted at the current input position.

Add(TextFrame, HorizontalAlignment, Int32, TextFrameInsertionMode)

Inserts a text frame which is anchored to the paragraph containing the specified text position. The frame has the specified horizontal alignment. TextFrameInsertionMode.FixedOnPage and TextFrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(TextFrame textFrame, HorizontalAlignment alignment, int textPosition, TextFrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal alignment As HorizontalAlignment, _
  ByVal textPosition As Integer, ByVal insertionMode As TextFrameInsertionMode) As Boolean
Parameter Description
textFrame

Specifies the text frame to add.
alignment

Specifies the text frame's horizontal alignment. It can be one of the HorizontalAlignment values:

Value | Meaning
Left | The text frame is left aligned relative to the paragraph to which it is anchored.
Right | The text frame is right aligned relative to the paragraph to which it is anchored.
Centered | The text frame is centered relative to the paragraph to which it is anchored.
Justify | This value is not possible for the alignment of text frames.
textPosition

Specifies the text position at which the text frame is to be inserted. If -1 is specified, the text frame is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the values of the TextFrameInsertionMode enumeration.

Add(TextFrame, Point, Int32, TextFrameInsertionMode)

Inserts a text frame which is anchored to the paragraph containing the specified text position. The frame has the specified position relative to the paragraph containing its anchor position. TextFrameInsertionMode.FixedOnPage and TextFrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(TextFrame textFrame, System.Drawing.Point location, int textPosition, TextFrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal location As System.Drawing.Point, ByVal textPosition As Integer, _
  ByVal insertionMode As TextFrameInsertionMode) As Boolean
Parameter | Description
textFrame | Specifies the text frame to add.
location | Specifies the location, in twips, at which the text frame is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
textPosition | Specifies the text position at which the text frame is to be inserted. If -1 is specified, the text frame is inserted at the current input position.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the TextFrameInsertionMode enumeration.

Add(TextFrame, Int32, Point, TextFrameInsertionMode)

Inserts a text frame that has a fixed geometrical position in the document. This position is specified through a page number and a location on this page. TextFrameInsertionMode.MoveWithText and TextFrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(TextFrame textFrame, int page, System.Drawing.Point location, TextFrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal page As Integer, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As TextFrameInsertionMode) As Boolean
Parameter | Description
textFrame | Specifies the text frame to add.
page | Specifies the number of a page beginning with 1 where the text frame is located.
location | Specifies the location, in twips, at which the text frame is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the TextFrameInsertionMode enumeration.

Add(TextFrame, Point, TextFrameInsertionMode)

Inserts a text frame that has a fixed geometrical position in the document. This location is specified through a document position relative to the top left corner of the complete document. TextFrameInsertionMode.MoveWithText and TextFrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(TextFrame textFrame, System.Drawing.Point location, TextFrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As TextFrameInsertionMode) As Boolean
Parameter | Description
textFrame | Specifies the text frame to add.
location | Specifies the location, in twips, at which the text frame is to be inserted. This is a location relative to the top left corner either of a page or of a paragraph.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the TextFrameInsertionMode enumeration.

Add(TextFrame, TextFrameInsertionMode)

Inserts a text frame with the built-in mouse interface. The text frame's size is determined through the end-user. A cross cursor indicates where the text frame can be inserted. Changing the document or pressing the ESC key aborts the insertion process.

[C#]
public bool Add(TextFrame textFrame, TextFrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal textFrame As TextFrame, ByVal insertionMode As TextFrameInsertionMode) As Boolean
Parameter | Description
textFrame | Specifies the text frame to add.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the TextFrameInsertionMode enumeration.

Return Value

The return value is true, if the text frame could be added. Otherwise, it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.DeactivateItem Method

Deactivates the activated text frame and sets the input focus back to the text part that contains the text frame.

Introduced: 13.0.

Syntax

[C#]
public bool DeactivateItem();
[Visual Basic]
Public Function DeactivateItem() As Boolean

Return Value

The return value is true, if a text frame has been deactivated. Otherwise it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.GetActivatedItem Method

Returns the currently activated text frame. An activated text frame has the input focus and can be edited. The method returns null, if no text frame is activated.

Introduced: 23.0.

Syntax

[C#]
public TextFrame GetActivatedItem();
[Visual Basic]
Public Function GetActivatedItem() As TextFrame

Return Value

The return value is null, if an activated text frame could not be found. Otherwise, it is an object of the type TextFrame.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.GetItem Method

Gets a particular text frame from the collection.

Introduced: 15.1.

GetItem()

Gets the text frame selected by the user or null if no text frame is selected.

[C#]
public TextFrame GetItem();
[Visual Basic]
Public Function GetItem() As TextFrame

GetItem(Int32)

Gets the text frame with the specified identifier.

[C#]
public TextFrame GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As TextFrame
Parameter | Description
id | Specifies the text frame's identifier set with the ID property. The method returns null if a text frame with the specified identifier does not exist.

GetItem(String)

Gets the text frame with the specified name.

[C#]
public TextFrame GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As TextFrame
Parameter | Description
name | Specifies the text frame's name set with the Name property. The method returns null if a text frame with the specified name does not exist.

Return Value

The return value is null, if a text frame with the specified parameters could not be found. Otherwise, it is an object of the type TextFrame.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameCollection.Remove Method

Removes a text frame from a Text Control document.

Syntax

[C#]
public bool Remove(TextFrame textFrame);
[Visual Basic]
Public Function Remove(ByVal textFrame As TextFrame) As Boolean
Parameter | Description
textFrame | Specifies the text frame to remove.

Return Value

The return value is true, if the text frame could be removed. Otherwise, it is false.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameEventArgs Class

The TextFrameEventArgs class provides data for all events that occur with text frames. These are the TextControl.TextFrameActivated, TextControl.TextFrameDeactivated, TextControl.TextFrameCreated, TextControl.TextFrameDeleted, TextControl.TextFrameClicked,TextControl.TextFrameDoubleClicked, TextControl.TextFrameRightClicked, TextControl.TextFrameMoved, TextControl.TextFrameSelected, TextControl.TextFrameDeselected, and TextControl.TextFrameSized events.

Introduced: 12.0.

Syntax

[C#]
public class TextFrameEventArgs: EventArgs
[Visual Basic]
Public Class TextFrameEventArgs
  Inherits EventArgs

Properties

Property | Description
TextFrame | Gets an object that represents the text frame which causes the event.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextFrameEventArgs.TextFrame Property

Gets an object that represents the text frame which causes the event. It is of the type TextFrame.

Syntax

[C#]
public TextFrame TextFrame { get; }
[Visual Basic]
Public ReadOnly Property TextFrame() As TextFrame

Limitations

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.TextPartCollection Class

An instance of the TextPartCollection class contains all text parts in a TX Text Control document. A text part can either be the document's main text, a text frame or a header or footer. A text frame is represented through a TextFrame object, a header or footer through a HeaderFooter object and the document's main text is represented through a MainText object. A TextPartCollection object contains all these objects in a geometric order. The first object in the collection is the main text, followed by all text frames in geometric order. At the end of the collection all headers and footers are contained also geometrically ordered. All objects in a text part collection implement the IFormattedText interface. The collection can be obtained with the TextControl.TextParts, WPF.TextControl.TextParts or ServerTextControl.TextParts property. The TextPartCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 16.0.

Syntax

[C#]
public class TextPartCollection : ICollection, IEnumerable
[Visual Basic]
Public Class TextPartCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.

Methods

Method | Description
Activate | Sets the input focus to the specified text part.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Gets a certain text part from the collection.
GetMainText | Gets the main text part of the document.

Example

The following example shows how to loop through all text parts a get the first line of each part.

[C#]
foreach (object obj in textControl1.TextParts)
{
    Console.WriteLine("First Line: " + ((IFormattedText)obj).Lines[1].Text);
}

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.Activate Method

Sets the input focus to the specified text part. If the activated text part is not in the visible part of the document, the document is scrolled.

Syntax

[C#]
public bool Activate(object textPart);
[Visual Basic]
Public Function Activate(TextPart As System.Object) As Boolean
Parameter | Description
textPart | Specifies the object to activate. It must be an object of the type MainText, TextFrame or HeaderFooter.

Return Value

The return value is true, if the specified text part could be activated. Otherwise it is false.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.GetItem Method

Gets a certain text part from the collection.

GetItem()

Gets the text part with the input focus.

[C#]
public object GetItem();
[Visual Basic]
Public Function GetItem() As System.Object

GetItem(Point)

Gets the text part with the input focus informing about the offset of the text part in the TextControl's client area.

[C#]
public object GetItem(out System.Drawing.Point clientOffset);
[Visual Basic]
Public Function GetItem(ByRef clientOffset As System.Drawing.Point) As System.Object
Member | Description
clientOffset | Retrieves the text part's offset, in pixels, in the TextControl's client area.

GetItem(Point, Point)

Gets the text part at the specified geometric location.

[C#]
public object GetItem(System.Drawing.Point location, out System.Drawing.Point clientOffset);
[Visual Basic]
Public Function GetItem(ByVal location As System.Drawing.Point, ByRef clientOffset As System.Drawing.Point) As System.Object
Member | Description
location | Specifies a location where to search for a text part. The point must be specified in pixels with an origin at the top left corner of the control.
clientOffset | Retrieves the text part's offset, in pixels, in the TextControl's client area.

Return Value

The return value is the found text part, which is either the text part with the input focus or the text part at the specified location. It can be an object of the type MainText, TextFrame or HeaderFooter. All of these objects implement the IFormattedText interface. The first and the second implementation return null, if there is no text part with the input focus. This can happen, if an image is selected, or if another application or component has the input focus.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.TextPartCollection.GetMainText Method

Gets the main text part of the document.

Syntax

[C#]
public MainText GetMainText();
[Visual Basic]
Public Function GetMainText() As MainText

Return Value

The return value is the main text part of the document. It is an object of the type MainText.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.UserDefinedPropertyDictionary Class

An instance of the UserDefinedPropertyDictionary class contains all user-defined document properties contained in a loaded document or which will be saved in a document. The UserDefinedPropertyDictionary class is used with the LoadSettings.UserDefinedDocumentProperties and SaveSettings.UserDefinedDocumentProperties properties. Each entry in the dictionary is a key/value pair, where the key is the name of the document property and the value is the document property's value. The foreach statement of the C# language (for each in Visual Basic) returns an object of the type of the elements in the collection. Since each element is a key/value pair, the element type is System.Collections.DictionaryEntry. The name must be of the type System.String and is limited to 255 characters. The value can be of the type System.String, System.Boolean, System.Int32 or System.Double.

Introduced: 24.0.

Syntax

[C#]
public class UserDefinedPropertyDictionary : System.Collections.DictionaryBase
[Visual Basic]
Public Class UserDefinedPropertyDictionary : System.Collections.DictionaryBase

Constructors

Constructor | Description
UserDefinedPropertyDictionary | Initializes a new instance of the UserDefinedPropertyDictionary class.

Properties

Property | Description
Names | Gets a collection of all property names the dictionary contains.
Values | Gets a collection of all property values the dictionary contains.

Methods

Method | Description
Add | Adds a new property to the dictionary.
Contains | Determines whether the dictionary contains a property with the specified name.
Item | Gets a document property from the dictionary.
Remove | Removes a document property from the dictionary.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary Constructor

Initializes a new instance of the UserDefinedPropertyDictionary class.

Syntax

[C#]
public UserDefinedPropertyDictionary();
[Visual Basic]
Public Sub New()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Add Method

Adds a new property to the dictionary.

Syntax

[C#]
public void Add(string name, object value);
[Visual Basic]
Public Sub Add(ByVal name As String, ByVal value As System.Object)
Parameter | Description
name | Specifies the document property's name. The name is limited to 255 characters.
value | Specifies the document property's value. It can be of the type System.String, System.Boolean, System.Int32 or System.Double.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Contains Method

Determines whether the dictionary contains a property with the specified name.

Syntax

[C#]
public bool Contains(string name);
[Visual Basic]
Public Function Contains(ByVal name As String) As Boolean
Parameter | Description
name | Specifies a document property's name.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Item Property

Gets a document property from the dictionary. In C# this property is the indexer for the UserDefinedPropertyDictionary class.

Syntax

[C#]
public object this[string name] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal name As String) As System.Object
Parameter | Description
name | Specifies the name of the document property.

Return Value

The return value is null, if the property could not be found. Otherwise, it is an object of the type System.String, System.Boolean, System.Int32 or System.Double which is the value associated with the specified name.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Names Property

Gets a collection of all property names the dictionary contains.

Syntax

[C#]
public System.Collections.ICollection Names { get; }
[Visual Basic]
Public ReadOnly Property Names() As System.Collections.ICollection

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Remove Method

Removes a document property from the dictionary.

Syntax

[C#]
public void Remove(string name);
[Visual Basic]
Public Sub Remove(ByVal name As String)
Parameter | Description
name | Specifies the name of the document property to remove.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.UserDefinedPropertyDictionary.Values Property

Gets a collection of all property values the dictionary contains.

Syntax

[C#]
public System.Collections.ICollection Values { get; }
[Visual Basic]
Public ReadOnly Property Values() As System.Collections.ICollection

Limitations

Read only.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.VersionInfo Class

The VersionInfo class provides information about the running TX Text Control version, such as the version number, the installed service pack number and the product level.

Introduced: 21.0.

Syntax

[C#]
public class VersionInfo
[Visual Basic]
Public Class VersionInfo

Properties

Property | Description
Major | Gets the major version number.
Minor | Gets the minor version number.
ProductLevel | Gets the installed product level.
ServicePack | Gets the number of the installed service pack.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.VersionInfo.Major Property

Gets the major version number.

Syntax

[C#]
public int Major { get; }
[Visual Basic]
Public ReadOnly Property Major() As Integer

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.VersionInfo.Minor Property

Gets the minor version number.

Syntax

[C#]
public int Minor { get; }
[Visual Basic]
Public ReadOnly Property Minor() As Integer

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.VersionInfo.ServicePack Property

Gets the number of the installed service pack. The original version has the service pack number 0.

Syntax

[C#]
public int ServicePack { get; }
[Visual Basic]
Public ReadOnly Property ServicePack() As Integer

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.VersionInfo.ProductLevel Property

Gets the installed product level.

Syntax

[C#]
public ProductLevel ProductLevel { get; }
[Visual Basic]
Public ReadOnly Property ProductLevel() As ProductLevel
Value | Description
Standard | The Standard version (Express Version in Windows Forms) is installed.
Professional | The Professional version is installed.
Enterprise | The Enterprise version is installed.
Server | The Server version is installed.
Trial | The Trial version is installed.

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.XmlElement Class

An instance of this class represents an element in a XML document. To iterate through all occurrences of an XML element in a Text Control document the XmlElementCollection class can be used.

Syntax

[C#]
public class XmlElement
[Visual Basic]
Public Class XmlElement

Constructors

Constructor | Description
XmlElement | Overloaded. Initializes a new instance of the XmlElement class.

Properties

Property | Description
AutoSelect | Determines whether the text of a newly added XML element is automatically selected.
AutoText | Determines whether text is automatically created for a newly added XML element that has no text contents.
ElementName | Gets the name of an XML element.
Text | Specifies the text of the XML element.

Methods

Method | Description
AddChild | Overloaded. Adds a new XML element as a sub-element of this element.
GetChildItem | Overloaded. Returns an XML Element object that represents a child element of this element.
RemoveChild | Overloaded. Removes an XML child element.
Select | Selects the text of the XML element.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement Constructor

Initializes a new instance of the XmlElement class.

XmlElement(String)

Creates an XmlElement object with the specified name.

[C#]
public XmlElement(string name);
[Visual Basic]
Public Sub New(ByVal name As String)
Parameter | Description
name | Specifies the element's name.

XmlElement(String, String)

Creates an XmlElement object with the specified name and text.

[C#]
public XmlElement(string name, string text);
[Visual Basic]
Public Sub New(ByVal name As String, ByVal text As String)
Parameter | Description
name | Specifies the element's name.
text | Specifies the element's text.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.AddChild Method

Adds a new XML element as a sub-element of this element. The new element is placed at the position specified through the document's DTD.

AddChild(XmlElement)

Adds the specified XML element as a sub-element of this element. The new element is placed at the position specified through the document's DTD.

[C#]
public bool AddChild(XmlElement element);
[Visual Basic]
Public Function AddChild(ByVal element As XmlElement) As Boolean
Parameter | Description
element | Specifies the XML element to add.

AddChild(XmlElement, Int32, Int32)

Adds the specified XML element as a sub-element of this element. The new element is placed at the position specified through the document's DTD. If this element can have more than one child of the specified type, the before or after parameters can be used to specify a position.

[C#]
public bool AddChild(XmlElement element, int before, int after);
[Visual Basic]
Public Function AddChild(ByVal element As XmlElement, ByVal before As Integer, ByVal after As Integer) As Boolean
Parameter | Description
element | Specifies the XML element to add.
before | Specifies a relative position in the list of child elements of the specified type beginning with 1. The XML element to be added is placed before the child identified by the before parameter. You can specify before or after positions but not both. If this parameter is -1, it is ignored.
after | Specifies a relative position in the list of child elements of the specified type beginning with 1. The XML element to be added is placed after the child identified by the after parameter. You can specify before or after positions but not both. If this parameter is -1, it is ignored.

Return Value

The return is false, if the new element could not be added because the document becomes invalid according to the document's DTD. In this case an XmlInvalid event occurs. The return value is true, if the new element could successfully been added.

Example

The following example creates a new Telephone element and adds it to the second address in an XML document that contains adresses consisting of the sub-elements Name, Street, City and Telephone:

[C#]
TXTextControl.XmlElement newElement = new TXTextControl.XmlElement("Telephone", "046798 / 3459786");
textControl1.GetXmlElements("Adress").GetItem(2).AddChild(newElement);
[Visual Basic]
Dim NewElement As New TXTextControl.XmlElement("Telephone", "046798 / 3459786")
TextControl1.GetXmlElements("Adress").GetItem(2).AddChild(NewElement)

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.AutoSelect Property

Determines whether the text of a newly added XML element is automatically selected.

Syntax

[C#]
public bool AutoSelect { get; set; }
[Visual Basic]
Public Property AutoSelect() As Boolean

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.AutoText Property

Determines whether text is automatically created for a newly added XML element that has no text contents. The created text consists of the element's name enclosed in square brackets and is created only if no text has been set with the XML element's Text property.

Syntax

[C#]
public bool AutoText { get; set; }
[Visual Basic]
Public Property AutoText() As Boolean

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.ElementName Property

Gets the name of an XML element.

Syntax

[C#]
public string ElementName { get; }
[Visual Basic]
Public ReadOnly Property ElementName() As String

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.GetChildItem Method

Returns an XML Element object that represents a child element of this element.

GetChildItem(String)

Returns the first XML child element with the specified name.

[C#]
public XmlElement GetChildItem(string name);
[Visual Basic]
Public Function GetChildItem(ByVal name As String) As XmlElement
Parameter | Description
name | Specifies the name of the sub-element.

GetChildItem(String, Int32)

Returns the XML child element with the specified name and index.

[C#]
public XmlElement GetChildItem(string name, int index);
[Visual Basic]
Public Function GetChildItem(ByVal name As String, ByVal index As Integer) As XmlElement
Parameter | Description
name | Specifies the name of the sub-element.
index | Specifies the number of the sub-element beginning with 1. If this value does not match any existing sub-element, an error occurs.

Return Value

The return value is a valid XmlElement object.

Example

The following example gets the Telephone element from the second address in an XML document that contains adresses consisting of the sub-elements Name, Street, City and Telephone:

[C#]
XmlElement element = textControl1.GetXmlElements("Adress").GetItem(2).GetChildItem("Telephone");
[Visual Basic]
Dim Element As XmlElement = TextControl1.GetXmlElements("Adress").GetItem(2).GetChildItem("Telephone")

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.RemoveChild Method

Removes an XML child element.

RemoveChild(String)

Removes the first XML child element with the specified name.

[C#]
public bool RemoveChild(string name);
[Visual Basic]
Public Function RemoveChild(ByVal name As String) As Boolean
Parameter | Description
name | Specifies the name of the sub-element to remove.

RemoveChild(String, Int32)

Removes the XML child element with the specified name and index.

[C#]
public bool RemoveChild(string name, int index);
[Visual Basic]
Public Function RemoveChild(ByVal name As String, ByVal index As Integer) As Boolean
Parameter | Description
name | Specifies the name of the sub-element to remove.
index | Specifies the number of the sub-element beginning with 1. If this value does not match any existing sub-element, an error occurs.

Return Value

The return value is false, if the element could not be removed because the document becomes invalid according to the document's DTD. In this case, an XmlInvalid event occurs. The return value is true, if the sub-element could successfully be removed.

Example

The following example removes the second Telephone element of the second address in an XML document that contains adresses consisting of the sub-elements Name, Street, City and Telephone:

[C#]
textControl1.GetXmlElements("Adress").GetItem(2).RemoveChild("Telephone", 2);
[Visual Basic]
TextControl1.GetXmlElements("Adress").GetItem(2).RemoveChild("Telephone", 2)

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.Select Method

Selects the text of the XML element. The text can only be selected, if the element belongs to the document.

Syntax

[C#]
public bool Select();
[Visual Basic]
Public Function [Select]() As Boolean

Return Value

The return value is true, if the text could be selected. Otherwise it is false.

Remarks

If the element consists of several sub-elements Text Control selects the text of the first sub-element.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElement.Text Property

Specifies the text of the XML element. If the element consists of several sub-elements, the text parts are seperated through paragraph end characters (0x0A).

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection Class

An instance of this class contains all elements of an XML document that have the same element name. It can be obtained with the TextControl.GetXmlElements method.

Syntax

[C#]
public class XmlElementCollection : ICollection, IEnumerable
[Visual Basic]
Public Class XmlElementCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of XML elements in the collection.

Methods

Method | Description
Add | Adds the specified XML element to the collection.
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
GetItem | Overloaded. Returns a particular XML element from the collection.
Remove | Removes an XML element from an XML document.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.Add Method

Adds the specified XML element to the collection.

Syntax

[C#]
public bool Add(XmlElement element, int before, int after);
[Visual Basic]
Public Function Add(ByVal element As XmlElement, ByVal before As Integer, ByVal after As Integer) As Boolean
Parameter | Description
element | Specified an instance of the XmlElement object.
before | Specifies a relative position in the collection. The XmlElement to be added is placed in the collection before the member identified by the before parameter. If this parameter is zero, the new element is inserted before the element at the current input position. If this parameter is -1, it is ignored.
after | Specifies a relative position in the collection. The XML element to be added is placed in the collection after the member identified by the after parameter. If this parameter is zero, the new element is inserted after the element at the current input position. If this parameter is -1, it is ignored.

Return Value

The return value is false, if the new element could not be added because the document becomes invalid according to the document's DTD. In this case an XmlInvalid event occurs. The return value is true, if the new element could successfully been added.

Example

The following example inserts a new Address element into an XML document that contains adresses consisting of the sub-elements Name, Street and City. The new address is inserted after the second address:

[C#]
TXTextControl.XmlElement newElement = new TXTextControl.XmlElement("Telephone", "46798 / 3459786");
newElement.Text("Jack Brown\nBaker Street\nNew York");
textControl1.GetXmlElements("Adress").Add(newElement, -1, 2);
[Visual Basic]
Dim NewElement As New TXTextControl.XmlElement("Telephone", "46798 / 3459786")
NewElement.Text("Jack Brown" & Chr(10) & "Baker Street" & Chr(10) & "New York")
TextControl1.GetXmlElements("Adress").Add(NewElement, -1, 2)

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.Count Property

Gets the number of XML elements in the collection.

Syntax

[C#]
public int Count { get; };
[Visual Basic]
Public ReadOnly Property Count() As Integer

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.GetItem Method

Returns a particular XML element from the collection.

GetItem()

Returns the item with the current input position.

[C#]
public XmlElement GetItem();
[Visual Basic]
Public Function GetItem() As XmlElement

GetItem(Int32)

Returns the item with the specified index.

[C#]
public XmlElement GetItem(int index);
[Visual Basic]
Public Function GetItem(ByVal index As Integer) As XmlElement
Parameter | Description
index | The one based index of the XmlElement.

Return Value

The return value is the requested element or null, if the element does not exist.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlElementCollection.Remove Method

Removes an XML element from an XML document.

Syntax

[C#]
public bool Remove(int index);
[Visual Basic]
Public Function Remove(ByVal index As Integer) As Boolean
Parameter | Description
index | Specifies the one-based index of the XML element in the collection. If this parameter is zero, the element at the current input position is removed.

Return Value

The return value is false, if the element could not be removed because the document becomes invalid according to the document's DTD. In this case an XmlInvalid event occurs. The return value is true, if the element could successfully be removed.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs Class

The XmlErrorEventArgs class provides data for the TextControl.XmlNotWellFormed and TextControl.XmlInvalid events.

Syntax

[C#]
public class XmlErrorEventArgs: EventArgs
[Visual Basic]
Public Class XmlErrorEventArgs
  Inherits EventArgs

Properties

Property | Description
FilePosition | Gets the absolute file position in the XML document where the error occurred.
LineNumber | Gets the line number in the XML document that contains the error.
LinePosition | Gets the character position within the line where the error occurred.
Reason | Gets the reason for the error.
URL | Gets the URL of the XML document containing the error.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs.FilePosition Property

Gets the absolute file position in the XML document where the error occurred. If the property value is zero, there is no information about the file position.

Syntax

[C#]
public int FilePosition { get; }
[Visual Basic]
Public ReadOnly Property FilePosition() As Integer

Limitations

Read only.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs.LineNumber Property

Gets the line number in the XML document that contains the error. If the property value is zero, there is no information about the line number.

Syntax

[C#]
public int LineNumber { get; }
[Visual Basic]
Public ReadOnly Property LineNumber() As Integer

Limitations

Read only.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs.LinePosition Property

Gets the character position within the line where the error occurred. If the property value is zero, there is no information about the line position.

Syntax

[C#]
public int LinePosition { get; }
[Visual Basic]
Public ReadOnly Property LinePosition() As Integer

Limitations

Read only.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs.Reason Property

Gets the reason for the error.

Syntax

[C#]
public string Reason { get; }
[Visual Basic]
Public ReadOnly Property Reason() As String

Limitations

Read only.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.XmlErrorEventArgs.URL Property

Gets the URL of the XML document containing the error. If the property value is an empty string there is no information about the URL.

Syntax

[C#]
public string URL { get; }
[Visual Basic]
Public ReadOnly Property URL() As String

Limitations

Read only.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.DataVisualization namespace

TXTextControl.DataVisualization.BarcodeCollection Class

TXTextControl.DataVisualization.BarcodeEventArgs Class

TXTextControl.DataVisualization.BarcodeFrame Class

TXTextControl.DataVisualization.ChartCollection Class

TXTextControl.DataVisualization.ChartEventArgs Class

TXTextControl.DataVisualization.ChartFrame Class

TXTextControl.DataVisualization.DrawingCollection Class

TXTextControl.DataVisualization.DrawingEventArgs Class

TXTextControl.DataVisualization.DrawingFrame Class


TXTextControl.DataVisualization.BarcodeCollection Class

An instance of the BarcodeCollection class contains all barcodes in a document represented through objects of the type DataVisualization.BarcodeFrame. An instance of this class can be obtained with the TextControl.Barcodes, WPF.TextControl.Barcodes or ServerTextControl.Barcodes property. The BarcodeCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 19.0.

Syntax

[C#]
public sealed class BarcodeCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class BarcodeCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Add | Overloaded. Inserts a new barcode in a Text Control document.
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular barcode from the collection.
Remove | Removes a barcode from a Text Control document.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeCollection.Add Method

Inserts a new barcode in a Text Control document.

Add(BarcodeFrame, Int32)

Inserts a barcode inline, which means that it is treated in the text like a single character.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, int textPosition);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal textPosition As Integer) As Boolean
Parameter | Description
barcodeFrame | Specifies the barcode and its frame to add.
textPosition | Specifies the text position at which the barcode is to be inserted. If -1 is specified, the barcode is inserted at the current input position.

Add(BarcodeFrame, HorizontalAlignment, Int32, FrameInsertionMode)

Inserts a barcode, which is anchored to the specified text position. It has the specified horizontal alignment relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored barcode is moved with the text.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, HorizontalAlignment alignment, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal alignment As HorizontalAlignment, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
barcodeFrame

Specifies the barcode and its frame to add.
alignment

Specifies the barcode's horizontal alignment. It can be one of the HorizontalAlignment values:

Value | Meaning
Left | The barcode is left aligned, relative to the paragraph to which it is anchored.
Right | The barcode is right aligned, relative to the paragraph to which it is anchored.
Centered | The barcode is centered, relative to the paragraph to which it is anchored.
Justify | This value is not supported for barcodes.
textPosition

Specifies the text position at which the barcode is to be inserted. If -1 is specified, the barcode is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The barcode is inserted at a certain geometrical location above the text. This means that the barcode overwrites the text.
BelowTheText | The barcode is inserted at a certain geometrical location below the text. This means that the text overwrites the barcode.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the barcode.
DisplaceText | The text flows around the barcode and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the BarcodeCollection.Add method.

Add(BarcodeFrame, Point, Int32, FrameInsertionMode)

Inserts a barcode, which is anchored to the specified text position. The specified location is relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored barcode is moved with the text.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, System.Drawing.Point location, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal location As System.Drawing.Point, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
barcodeFrame

Specifies the barcode and its frame to add.
location

Specifies the location, in twips, at which the barcode is to be inserted.
textPosition

Specifies the text position at which the barcode is to be inserted. If -1 is specified, the barcode is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The barcode is inserted at a certain geometrical location above the text. This means that the barcode overwrites the text.
BelowTheText | The barcode is inserted at a certain geometrical location below the text. This means that the text overwrites the barcode.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the barcode.
DisplaceText | The text flows around the barcode and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the BarcodeCollection.Add method.

Add(BarcodeFrame, Int32, Point, FrameInsertionMode)

Inserts a barcode, which has a fixed geometrical position in the document. This position is specified through a page number and a location on this page and the textflow is given through the insertionMode parameter.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, int page, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal page As Integer, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
barcodeFrame

Specifies the barcode and its frame to add.
page

Specifies the number of a page beginning with 1 where the barcode is located.
location

Specifies the location, in twips, at which the barcode is to be inserted.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The barcode is inserted at a certain geometrical location above the text. This means that the barcode overwrites the text.
BelowTheText | The barcode is inserted at a certain geometrical location below the text. This means that the text overwrites the barcode.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the barcode.
DisplaceText | The text flows around the barcode and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the BarcodeCollection.Add method.

Add(BarcodeFrame, Point, FrameInsertionMode)

Inserts a barcode, which has a fixed geometrical position in the document. This position is specified relative to the complete document and the textflow is given through the insertionMode parameter.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
barcodeFrame

Specifies the barcode and its frame to add.
location

Specifies the location, in twips, at which the barcode is to be inserted.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The barcode is inserted at a certain geometrical location above the text. This means that the barcode overwrites the text.
BelowTheText | The barcode is inserted at a certain geometrical location below the text. This means that the text overwrites the barcode.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the barcode.
DisplaceText | The text flows around the barcode and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the BarcodeCollection.Add method.

Add(BarcodeFrame, FrameInsertionMode)

Inserts a barcode with the built-in mouse interface. The barcode's size is determined through the end-user. A cross cursor indicates where the barcode can be inserted. Changing the document or pressing the ESC key aborts the insertion process.

[C#]
public bool Add(DataVisualization.BarcodeFrame barcodeFrame, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal barcodeFrame As DataVisualization.BarcodeFrame, ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
barcodeFrame

Specifies the barcode and its frame to add.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The barcode is inserted at a certain geometrical location above the text. This means that the barcode overwrites the text.
BelowTheText | The barcode is inserted at a certain geometrical location below the text. This means that the text overwrites the barcode.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the barcode.
DisplaceText | The text flows around the barcode and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the BarcodeCollection.Add method.

Return Value

The return value is true, if the barcode could be added. Otherwise, it is false.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to which to copy.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeCollection.GetItem Method

Gets a particular barcode from the collection.

GetItem()

Gets the barcode selected by the user.

[C#]
public DataVisualization.BarcodeFrame GetItem();
[Visual Basic]
Public Function GetItem() As DataVisualization.BarcodeFrame

GetItem(Int32)

Gets the barcode with the specified identifier. An id can be set with the ID property.

[C#]
public DataVisualization.BarcodeFrame GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As DataVisualization.BarcodeFrame
Parameter | Description
id | Specifies the barcode's identifier. The method returns null, if a barcode with the specified identifier does not exist.

GetItem(String)

Gets the barcode with the specified name. A name can be set with the Name property.

[C#]
public DataVisualization.BarcodeFrame GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As DataVisualization.BarcodeFrame
Parameter | Description
name | Specifies the barcode's name. The method returns null, if a barcode with the specified name does not exist.

Return Value

The return value is null, if a barcode with the specified parameters could not be found. Otherwise, it is an object of the type DataVisualization.BarcodeFrame.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeCollection.Remove Method

Removes a barcode from a Text Control document.

Syntax

[C#]
public bool Remove(DataVisualization.BarcodeFrame barcodeFrame);
[Visual Basic]
Public Function Remove(ByVal barcodeFrame As DataVisualization.BarcodeFrame) As Boolean
Parameter | Description
barcodeFrame | Specifies the barcode to remove.

Return Value

The return value is true, if the barcode could be removed. Otherwise, it is false.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeEventArgs Class

The BarcodeEventArgs class provides data for all events that occur with barcodes. These are the TextControl.BarcodeCreated, TextControl.BarcodeDeleted, TextControl.BarcodeClicked, TextControl.BarcodeDoubleClicked, TextControl.BarcodeRightClicked, TextControl.BarcodeMoved TextControl.BarcodeSelected, TextControl.BarcodeDeselected and TextControl.BarcodeSized events.

Introduced: 19.0.

Syntax

[C#]
public class BarcodeEventArgs: EventArgs
[Visual Basic]
Public Class BarcodeEventArgs
  Inherits EventArgs

Properties

Property | Description
BarcodeFrame | Gets an object that represents the barcode which causes the event.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeEventArgs.BarcodeFrame Property

Gets an object that represents the barcode which causes the event. It is of the type DataVisualization.BarcodeFrame.

Syntax

[C#]
public DataVisualization.BarcodeFrame BarcodeFrame { get; }
[Visual Basic]
Public ReadOnly Property BarcodeFrame() As DataVisualization.BarcodeFrame

Limitations

Read only.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame Class

An instance of the BarcodeFrame class represents a barcode and its layout in a Text Control document. A barcode can be positioned in the document like an image or a textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The BarcodeFrame class handles the positioning of the barcode in the document. A barcode frame is always associated with a barcode control of the type TXTextControl.Barcode.TXBarcodeControl or TXTextControl.WPF.Barcode.TXBarcodeControl. This barcode control handles the appearance and the data of the barcode. All barcodes in a document are contained in a BarcodeCollection. The collection can also be used to add barcodes to or to remove barcodes from the document. The barcode collection can be obtained through the TextControl.Barcodes, WPF.TextControl.Barcodes or ServerTextControl.Barcodes property.

Introduced: 19.0.

Syntax

[C#]
public class BarcodeFrame : FrameBase
[Visual Basic]
Public Class BarcodeFrame
  Inherits FrameBase

Constructors

Constructor | Description
BarcodeFrame | Initializes a new instance of the BarcodeFrame class.

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph. (Inherited from FrameBase.)
Barcode | Gets the barcode control associated with the barcode frame.
ExportCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the barcode's image is exported.
ExportFileName | Gets or sets the file name, when the barcode's image is exported.
ExportFilterIndex | Gets or sets the format used, if a barcode's image is exported.
ExportResolution | Gets or sets the maximum resolution in dots per inch in which the barcode's image is saved.
ID | Gets or sets an identifier for the frame. (Inherited from FrameBase.)
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. (Inherited from FrameBase.)
Location | Gets or sets, in twips, the frame's current location. (Inherited from FrameBase.)
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface. (Inherited from FrameBase.)
Name | Gets or sets a name for the frame. (Inherited from FrameBase.)
SaveMode | Determines whether the barcode's image is stored through its binary data or through a file reference.
Size | Gets or sets the frame's size in twips. (Inherited from FrameBase.)
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface. (Inherited from FrameBase.)
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text. (Inherited from FrameBase.)
TextPosition | Read only. Gets the frame's character position in the document's text (one-based). (Inherited from FrameBase.)

Methods

Method | Description
AddUndoUnit | Add the current state of the barcode which is connected with this BarcodeFrame to the undo stack.
ChangeZOrder | Changes the frame's z-order. (Inherited from FrameBase.)
Refresh | Refreshes the barcode.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame Constructor

Initializes a new instance of the BarcodeFrame class.

Syntax

[C#]
public BarcodeFrame(object barcode);
[Visual Basic]
Public Sub New(ByVal barcode As System.Object)
Parameter | Description
barcode | Specifies the barcode control associated with the barcode frame. It must be of the type TXTextControl.Barcode.TXBarcodeControl or TXTextControl.WPF.Barcode.TXBarcodeControl.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.AddUndoUnit Method

Add the current state of the barcode which is connected with this BarcodeFrame to the undo stack. Programmatic changes performed with the barcode's properties and methods are not automatically added to a TextControl's undo stack. Calling this method is not necessary, when the barcode frame's layout in the text is changed.

Syntax

[C#]
public void AddUndoUnit();
[Visual Basic]
Public Sub AddUndoUnit()

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.Barcode Property

Gets the barcode control associated with the barcode frame. It must be of the type TXTextControl.Barcode.TXBarcodeControl or TXTextControl.WPF.Barcode.TXBarcodeControl.

Syntax

[C#]
public object Barcode { get; }
[Visual Basic]
Public ReadOnly Property Barcode() As System.Object

Limitations

Read only.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.ExportCompressionQuality Property

Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the barcode's image is exported. It is only used, if the image data is compressed with a lossy compression algorithm. A value of 100 indicates the maximum quality, a value of 1 indicates the minimum quality. If this property is set to zero, which is the default value, Text Control uses the quality value set with the SaveSettings.ImageCompressionQuality property.

Syntax

[C#]
public int ExportCompressionQuality { get; set; }
[Visual Basic]
Public Property ExportCompressionQuality() As Integer

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.ExportFileName Property

Gets or sets the file name, when the barcode's image is exported. An empty string indicates that no export filename has currently be specified for the barcode's image. In this case a constructed filename is used. A filename is constructed in the following form: <document_filename>_<number>.<extension>. The technical article Loading and Saving Images describes where newly created image files are stored.

Syntax

[C#]
public string ExportFileName { get; set; }
[Visual Basic]
Public Property ExportFileName() As String

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.ExportFilterIndex Property

Gets or sets the format used, if a barcode's image is exported. This is the number of the filter in the string returned through the ImageCollection.ExportFilters property, beginning with number one. A value of zero indicates that no export format has currently be specified for the barcode. In this case the barcode's image is saved in Windows Bitmap format. The technical article Loading and Saving Images lists the currently possible values for this property.

Syntax

[C#]
public int ExportFilterIndex { get; set; }
[Visual Basic]
Public Property ExportFilterIndex() As Integer

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.ExportResolution Property

Gets or sets the maximum resolution in dots per inch in which the barcode's image is saved. If this property's value is zero, which is the default value, Text Control uses the resolution value set with the SaveSettings.ImageMaxResolution property.

Syntax

[C#]
public int ExportResolution { get; set; }
[Visual Basic]
Public Property ExportResolution() As Integer

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.Refresh Method

Refreshes the barcode. Programmatic changes performed with the barcode's properties and methods are not automatically refreshed. Calling this method is not necessary, when the barcode frame's layout in the text is changed.

Syntax

[C#]
public void Refresh();
[Visual Basic]
Public Sub Refresh()

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.BarcodeFrame.SaveMode Property

Determines whether the barcode's image is stored through its binary data or through a file reference. By default a barcode's image is stored with its binary data.

Syntax

[C#]
public ImageSaveMode SaveMode { get; set; }
[Visual Basic]
Public Property SaveMode() As ImageSaveMode
Value | Description
Auto | The image is saved as specified with the SaveSettings.ImageSaveMode property.
SaveAsData | The image is saved in a Text Control document with its complete binary data.
SaveAsFileReference | The image is saved in a Text Control document through a file reference. The technical article Loading and Saving Images describes where newly created image files are stored.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.DataVisualization.ChartCollection Class

An instance of the ChartCollection class contains all charts in a document represented through objects of the type DataVisualization.ChartFrame. An instance of this class can be obtained with the TextControl.Charts or ServerTextControl.Charts property. The ChartCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 18.0.

Syntax

[C#]
public sealed class ChartCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class ChartCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Add | Overloaded. Inserts a new chart in a Text Control document.
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular chart from the collection.
Remove | Removes a chart from a Text Control document.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartCollection.Add Method

Inserts a new chart in a Text Control document.

Add(ChartFrame, Int32)

Inserts a chart inline, which means that it is treated in the text like a single character.

[C#]
public bool Add(DataVisualization.ChartFrame chartFrame, int textPosition);
[Visual Basic]
Public Function Add(ByVal chartFrame As DataVisualization.ChartFrame, ByVal textPosition As Integer) As Boolean
Parameter | Description
chartFrame | Specifies the chart and its frame to add.
textPosition | Specifies the text position at which the chart is to be inserted. If -1 is specified, the chart is inserted at the current input position.

Add(ChartFrame, HorizontalAlignment, Int32, FrameInsertionMode)

Inserts a chart which is anchored to the specified text position. It has the specified horizontal alignment relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored chart is moved with the text.

[C#]
public bool Add(DataVisualization.ChartFrame chartFrame, HorizontalAlignment alignment, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal chartFrame As DataVisualization.ChartFrame, ByVal alignment As HorizontalAlignment, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
chartFrame

Specifies the chart and its frame to add.
alignment

Specifies the chart's horizontal alignment. It can be one of the HorizontalAlignment values:

Value | Meaning
Left | The chart is left aligned, relative to the paragraph to which it is anchored.
Right | The chart is right aligned, relative to the paragraph to which it is anchored.
Centered | The chart is centered, relative to the paragraph to which it is anchored.
Justify | This value is not supported for charts.
textPosition

Specifies the text position at which the chart is to be inserted. If -1 is specified, the chart is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The chart is inserted at a certain geometrical location above the text. This means that the chart overwrites the text.
BelowTheText | The chart is inserted at a certain geometrical location below the text. This means that the text overwrites the chart.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the chart.
DisplaceText | The text flows around the chart and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ChartCollection.Add method.

Add(ChartFrame, Point, Int32, FrameInsertionMode)

Inserts a chart which is anchored to the specified text position. The specified location is relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored chart is moved with the text.

[C#]
public bool Add(DataVisualization.ChartFrame chartFrame, System.Drawing.Point location, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal chartFrame As DataVisualization.ChartFrame, ByVal location As System.Drawing.Point, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
chartFrame

Specifies the chart and its frame to add.
location

Specifies the location, in twips, at which the chart is to be inserted.
textPosition

Specifies the text position at which the chart is to be inserted. If -1 is specified, the chart is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The chart is inserted at a certain geometrical location above the text. This means that the chart overwrites the text.
BelowTheText | The chart is inserted at a certain geometrical location below the text. This means that the text overwrites the chart.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the chart.
DisplaceText | The text flows around the chart and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ChartCollection.Add method.

Add(ChartFrame, Int32, Point, FrameInsertionMode)

Inserts a chart which has a fixed geometrical position in the document. This position is specified through a page number and a location on this page and the textflow is given through the insertionMode parameter.

[C#]
public bool Add(DataVisualization.ChartFrame chartFrame, int page, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal chartFrame As DataVisualization.ChartFrame, ByVal page As Integer, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
chartFrame

Specifies the chart and its frame to add.
page

Specifies the number of a page beginning with 1 where the chart is located.
location

Specifies the location, in twips, at which the chart is to be inserted.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The chart is inserted at a certain geometrical location above the text. This means that the chart overwrites the text.
BelowTheText | The chart is inserted at a certain geometrical location below the text. This means that the text overwrites the chart.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the chart.
DisplaceText | The text flows around the chart and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ChartCollection.Add method.

Add(ChartFrame, Point, FrameInsertionMode)

Inserts a chart which has a fixed geometrical position in the document. This position is specified relative to the complete document and the textflow is given through the insertionMode parameter.

[C#]
public bool Add(DataVisualization.ChartFrame chartFrame, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal chartFrame As DataVisualization.ChartFrame, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
chartFrame

Specifies the chart and its frame to add.
location

Specifies the location, in twips, at which the chart is to be inserted.
insertionMode

Specifies how the text flow is handled. It can be one of the following values of the FrameInsertionMode enumeration:

Value | Meaning
AboveTheText | The chart is inserted at a certain geometrical location above the text. This means that the chart overwrites the text.
BelowTheText | The chart is inserted at a certain geometrical location below the text. This means that the text overwrites the chart.
DisplaceCompleteLines | The text stops at the top and continues at the bottom of the chart.
DisplaceText | The text flows around the chart and empty areas at the left and right side are filled.
Other Vaues | All other values cannot be used with the ChartCollection.Add method.

Return Value

The return value is true, if the chart could be added. Otherwise, it is false.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to which to copy.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartCollection.GetItem Method

Gets a particular chart from the collection.

GetItem()

Gets the chart selected by the user.

[C#]
public DataVisualization.ChartFrame GetItem();
[Visual Basic]
Public Function GetItem() As DataVisualization.ChartFrame

GetItem(Int32)

Gets the chart with the specified identifier. An id can be set with the ID property.

[C#]
public DataVisualization.ChartFrame GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As DataVisualization.ChartFrame
Parameter | Description
id | Specifies the chart's identifier. The method returns null if a chart with the specified identifier does not exist.

GetItem(String)

Gets the chart with the specified name. A name can be set with the Name property.

[C#]
public DataVisualization.ChartFrame GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As DataVisualization.ChartFrame
Parameter | Description
name | Specifies the chart's name. The method returns null if a chart with the specified name does not exist.

Return Value

The return value is null, if a chart with the specified parameters could not be found. Otherwise, it is an object of the type DataVisualization.ChartFrame.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartCollection.Remove Method

Removes a chart from a Text Control document.

Syntax

[C#]
public bool Remove(DataVisualization.ChartFrame chartFrame);
[Visual Basic]
Public Function Remove(ByVal chartFrame As DataVisualization.ChartFrame) As Boolean
Parameter | Description
chartFrame | Specifies the chart to remove.

Return Value

The return value is true, if the chart could be removed. Otherwise, it is false.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartEventArgs Class

The ChartEventArgs class provides data for all events that occur with charts. These are the TextControl.ChartCreated, TextControl.ChartDeleted, TextControl.ChartClicked, TextControl.ChartDoubleClicked, TextControl.ChartRightClicked, TextControl.ChartMoved TextControl.ChartSelected, TextControl.ChartDeselected and TextControl.ChartSized events.

Introduced: 18.0.

Syntax

[C#]
public class ChartEventArgs: EventArgs
[Visual Basic]
Public Class ChartEventArgs
  Inherits EventArgs

Properties

Property | Description
ChartFrame | Gets an object that represents the chart which causes the event.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartEventArgs.ChartFrame Property

Gets an object that represents the chart which causes the event. It is of the type DataVisualization.ChartFrame.

Syntax

[C#]
public DataVisualization.ChartFrame ChartFrame { get; }
[Visual Basic]
Public ReadOnly Property ChartFrame() As DataVisualization.ChartFrame

Limitations

Read only.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame Class

An instance of the ChartFrame class represents a chart and its layout in a Text Control document. A chart can be positioned in the document like an image or a textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The ChartFrame class handles the positioning of the chart in the document. A chart frame is always associated with a chart control of the type System.Windows.Forms.DataVisualization.Charting.Chart. This chart control handles the appearance and the data of the chart. All charts in a document are contained in a ChartCollection. The collection can also be used to add charts to or to remove charts from the document. The chart collection can be obtained from a TextControl or ServerTextControl through the Charts property.

Introduced: 18.0.

Syntax

[C#]
public class ChartFrame : FrameBase
[Visual Basic]
Public Class ChartFrame
  Inherits FrameBase

Constructors

Constructor | Description
ChartFrame | Initializes a new instance of the ChartFrame class.

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph. (Inherited from FrameBase.)
Chart | Gets the chart control associated with the chart frame.
ExportCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the chart's image is exported.
ExportFileName | Gets or sets the file name, when the chart's image is exported.
ExportFilterIndex | Gets or sets the format used, if a chart's image is exported.
ExportResolution | Gets or sets the maximum resolution in dots per inch in which the chart's image is saved.
ID | Gets or sets an identifier for the frame. (Inherited from FrameBase.)
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. (Inherited from FrameBase.)
Location | Gets or sets, in twips, the frame's current location. (Inherited from FrameBase.)
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface. (Inherited from FrameBase.)
Name | Gets or sets a name for the frame. (Inherited from FrameBase.)
SaveMode | Determines whether the chart's image is stored through its binary data or through a file reference.
Size | Gets or sets the frame's size in twips. (Inherited from FrameBase.)
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface. (Inherited from FrameBase.)
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text. (Inherited from FrameBase.)
TextPosition | Read only. Gets the frame's character position in the document's text (one-based). (Inherited from FrameBase.)

Methods

Method | Description
AddUndoUnit | Add the current state of the chart which is connected with this ChartFrame to the undo stack.
ChangeZOrder | Changes the frame's z-order. (Inherited from FrameBase.)
Refresh | Refreshes the chart.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame Constructor

Initializes a new instance of the ChartFrame class.

Syntax

[C#]
public ChartFrame(System.ComponentModel.Component chart);
[Visual Basic]
Public Sub New(ByVal chart As System.ComponentModel.Component)
Parameter | Description
chart | Specifies the chart control associated with the chart frame. It must be of the type System.Windows.Forms.DataVisualization.Charting.Chart.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.AddUndoUnit Method

Add the current state of the chart which is connected with this ChartFrame to the undo stack. Programmatic changes performed with the chart's properties and methods are not automatically added to a TextControl's undo stack. Calling this method is not necessary, when the chart frame's layout in the text is changed.

Syntax

[C#]
public void AddUndoUnit();
[Visual Basic]
Public Sub AddUndoUnit()

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.Chart Property

Gets the chart control associated with the chart frame. It must be of the type System.Windows.Forms.DataVisualization.Charting.Chart.

Syntax

[C#]
public System.ComponentModel.Component Chart { get; }
[Visual Basic]
Public ReadOnly Property Chart() As System.ComponentModel.Component

Limitations

Read only.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.ExportCompressionQuality Property

Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the chart's image is exported. It is only used, if the image data is compressed with a lossy compression algorithm. A value of 100 indicates the maximum quality, a value of 1 indicates the minimum quality. If this property is set to zero, which is the default value, Text Control uses the quality value set with the SaveSettings.ImageCompressionQuality property.

Syntax

[C#]
public int ExportCompressionQuality { get; set; }
[Visual Basic]
Public Property ExportCompressionQuality() As Integer

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.ExportFileName Property

Gets or sets the file name, when the chart's image is exported. An empty string indicates that no export filename has currently be specified for the chart's image. In this case a constructed filename is used. A filename is constructed in the following form: <document_filename>_<number>.<extension>. The technical article Loading and Saving Images describes where newly created image files are stored.

Syntax

[C#]
public string ExportFileName { get; set; }
[Visual Basic]
Public Property ExportFileName() As String

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.ExportFilterIndex Property

Gets or sets the format used, if a chart's image is exported. This is the number of the filter in the string returned through the ImageCollection.ExportFilters property, beginning with number one. A value of zero indicates that no export format has currently be specified for the chart. In this case the chart's image is saved in Windows Bitmap format. The technical article Loading and Saving Images lists the currently possible values for this property.

Syntax

[C#]
public int ExportFilterIndex { get; set; }
[Visual Basic]
Public Property ExportFilterIndex() As Integer

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.ExportResolution Property

Gets or sets the maximum resolution in dots per inch in which the chart's image is saved. If this property's value is zero, which is the default value, Text Control uses the resolution value set with the SaveSettings.ImageMaxResolution property.

Syntax

[C#]
public int ExportResolution { get; set; }
[Visual Basic]
Public Property ExportResolution() As Integer

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.Refresh Method

Refreshes the chart. Programmatic changes performed with the chart's properties and methods are not automatically refreshed. Calling this method is not necessary, when the chart frame's layout in the text is changed.

Syntax

[C#]
public void Refresh();
[Visual Basic]
Public Sub Refresh()

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.ChartFrame.SaveMode Property

Determines whether the chart's image is stored through its binary data or through a file reference. By default a chart's image is stored with its binary data.

Syntax

[C#]
public ImageSaveMode SaveMode { get; set; }
[Visual Basic]
Public Property SaveMode() As ImageSaveMode
Value | Description
Auto | The image is saved as specified with the SaveSettings.ImageSaveMode property.
SaveAsData | The image is saved in a Text Control document with its complete binary data.
SaveAsFileReference | The image is saved in a Text Control document through a file reference. The technical article Loading and Saving Images describes where newly created image files are stored.

See Also

  • Programming Category: Charts
  • Graphical Overview: Charts


TXTextControl.DataVisualization.DrawingCollection Class

An instance of the DrawingCollection class contains all drawings in a document represented through objects of the type DataVisualization.DrawingFrame. An instance of this class can be obtained with the TextControl.Drawings, WPF.TextControl.Drawings or ServerTextControl.Drawings property. The DrawingCollection class implements the IEnumerable and the ICollection interfaces.

Introduced: 23.0.

Syntax

[C#]
public sealed class DrawingCollection: FrameBaseCollection
[Visual Basic]
Public NotInheritable Class DrawingCollection
  Inherits FrameBaseCollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection. (Inherited from FrameBaseCollection.)
IsSynchronized | Returns true if the collection is designed to be thread safe, otherwise, it returns false. (Inherited from FrameBaseCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from FrameBaseCollection.)

Methods

Method | Description
Add | Overloaded. Inserts a new drawing in a Text Control document.
Clear | Removes all objects from the collection and from the document. (Inherited from FrameBaseCollection.)
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
DeactivateItem | Deactivates the activated drawing and sets the input focus back to the text part that contains the drawing.
GetActivatedItem | Returns the currently activated drawing.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection. (Inherited from FrameBaseCollection.)
GetItem | Overloaded. Gets a particular drawing from the collection.
Remove | Removes a drawing from a Text Control document.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.Add Method

Inserts a new drawing in a Text Control document.

Add(DrawingFrame, Int32)

Inserts a drawing inline, which means that it is treated in the text like a single character.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, int textPosition);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal textPosition As Integer) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing and its frame to add.
textPosition | Specifies the text position at which the drawing is to be inserted. If -1 is specified, the drawing is inserted at the current input position.

Add(DrawingFrame, HorizontalAlignment, Int32, FrameInsertionMode)

Inserts a drawing, which is anchored to the specified text position. It has the specified horizontal alignment relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored drawing is moved with the text. FrameInsertionMode.FixedOnPage and FrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, HorizontalAlignment alignment, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal alignment As HorizontalAlignment, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter Description
drawingFrame

Specifies the drawing and its frame to add.
alignment

Specifies the drawing's horizontal alignment. It can be one of the HorizontalAlignment values:

Value | Meaning
Left | The drawing is left aligned, relative to the paragraph to which it is anchored.
Right | The drawing is right aligned, relative to the paragraph to which it is anchored.
Centered | The drawing is centered, relative to the paragraph to which it is anchored.
Justify | This value is not supported for the alignment of drawings.
textPosition

Specifies the text position at which the drawing is to be inserted. If -1 is specified, the drawing is inserted at the current input position.
insertionMode

Specifies how the text flow is handled. It can be one of the values of the FrameInsertionMode enumeration.

Add(DrawingFrame, Point, Int32, FrameInsertionMode)

Inserts a drawing, which is anchored to the specified text position. The specified location is relative to the paragraph into which it is inserted and the textflow is given through the insertionMode parameter. An anchored drawing is moved with the text. FrameInsertionMode.FixedOnPage and FrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, System.Drawing.Point location, int textPosition, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal location As System.Drawing.Point, ByVal textPosition As Integer, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing and its frame to add.
location | Specifies the location, in twips, at which the drawing is to be inserted.
textPosition | Specifies the text position at which the drawing is to be inserted. If -1 is specified, the drawing is inserted at the current input position.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the FrameInsertionMode enumeration.

Add(DrawingFrame, Int32, Point, FrameInsertionMode)

Inserts a drawing, which has a fixed geometrical position in the document. This position is specified through a page number and a location on this page and the textflow is given through the insertionMode parameter. FrameInsertionMode.MoveWithText and FrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, int page, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal page As Integer, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing and its frame to add.
page | Specifies the number of a page beginning with 1 where the drawing is located.
location | Specifies the location, in twips, at which the drawing is to be inserted.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the FrameInsertionMode enumeration.

Add(DrawingFrame, Point, FrameInsertionMode)

Inserts a drawing, which has a fixed geometrical position in the document. This position is specified relative to the complete document and the textflow is given through the insertionMode parameter. FrameInsertionMode.MoveWithText and FrameInsertionMode.AsCharacter cannot be specified with this overload.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, System.Drawing.Point location, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal location As System.Drawing.Point, _
  ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing and its frame to add.
location | Specifies the location, in twips, at which the drawing is to be inserted.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the FrameInsertionMode enumeration.

Add(DrawingFrame, FrameInsertionMode)

Inserts a drawing with the built-in mouse interface. The drawing's size is determined through the end-user. A cross cursor indicates where the drawing can be inserted. Changing the document or pressing the ESC key aborts the insertion process.

[C#]
public bool Add(DataVisualization.DrawingFrame drawingFrame, FrameInsertionMode insertionMode);
[Visual Basic]
Public Function Add(ByVal drawingFrame As DataVisualization.DrawingFrame, ByVal insertionMode As FrameInsertionMode) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing and its frame to add.
insertionMode | Specifies how the text flow is handled. It can be one of the values of the FrameInsertionMode enumeration.

Return Value

The return value is true, if the drawing could be added. Otherwise, it is false.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(Array array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to which to copy.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.DeactivateItem Method

Deactivates the activated drawing and sets the input focus back to the text part that contains the drawing.

Syntax

[C#]
public bool DeactivateItem();
[Visual Basic]
Public Function DeactivateItem() As Boolean

Return Value

The return value is true, if a drawing has been deactivated. Otherwise it is false.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.GetActivatedItem Method

Returns the currently activated drawing. An activated drawing has the input focus and can be edited. The method returns null, if no drawing is activated.

Syntax

[C#]
public DataVisualization.DrawingFrame GetActivatedItem();
[Visual Basic]
Public Function GetActivatedItem() As DataVisualization.DrawingFrame

Return Value

The return value is null, if an activated drawing could not be found. Otherwise, it is an object of the type DataVisualization.DrawingFrame.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.GetItem Method

Gets a particular drawing from the collection.

GetItem()

Gets the drawing selected by the user.

[C#]
public DataVisualization.DrawingFrame GetItem();
[Visual Basic]
Public Function GetItem() As DataVisualization.DrawingFrame

GetItem(Int32)

Gets the drawing with the specified identifier. An id can be set with the ID property.

[C#]
public DataVisualization.DrawingFrame GetItem(int id);
[Visual Basic]
Public Function GetItem(ByVal id As Integer) As DataVisualization.DrawingFrame
Parameter | Description
id | Specifies the drawing's identifier. The method returns null, if a drawing with the specified identifier does not exist.

GetItem(String)

Gets the drawing with the specified name. A name can be set with the Name property.

[C#]
public DataVisualization.DrawingFrame GetItem(string name);
[Visual Basic]
Public Function GetItem(ByVal name As String) As DataVisualization.DrawingFrame
Parameter | Description
name | Specifies the drawing's name. The method returns null, if a drawing with the specified name does not exist.

Return Value

The return value is null, if a drawing with the specified parameters could not be found. Otherwise, it is an object of the type DataVisualization.DrawingFrame.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingCollection.Remove Method

Removes a drawing from a Text Control document.

Syntax

[C#]
public bool Remove(DataVisualization.DrawingFrame drawingFrame);
[Visual Basic]
Public Function Remove(ByVal drawingFrame As DataVisualization.DrawingFrame) As Boolean
Parameter | Description
drawingFrame | Specifies the drawing to remove.

Return Value

The return value is true, if the drawing could be removed. Otherwise, it is false.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingEventArgs Class

The DrawingEventArgs class provides data for all events that occur with drawings. These are the TextControl.DrawingCreated, TextControl.DrawingDeleted, TextControl.DrawingClicked, TextControl.DrawingDoubleClicked, TextControl.DrawingRightClicked, TextControl.DrawingMoved TextControl.DrawingSelected, TextControl.DrawingDeselected TextControl.DrawingActivated, TextControl.DrawingDeactivated and TextControl.DrawingSized events.

Introduced: 23.0.

Syntax

[C#]
public class DrawingEventArgs: EventArgs
[Visual Basic]
Public Class DrawingEventArgs
  Inherits EventArgs

Properties

Property | Description
DrawingFrame | Gets an object that represents the drawing which causes the event.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingEventArgs.DrawingFrame Property

Gets an object that represents the drawing which causes the event. It is of the type DataVisualization.DrawingFrame.

Syntax

[C#]
public DataVisualization.DrawingFrame DrawingFrame { get; }
[Visual Basic]
Public ReadOnly Property DrawingFrame() As DataVisualization.DrawingFrame

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame Class

An instance of the DrawingFrame class represents a drawing and its layout in a Text Control document. A drawing can be positioned in the document like an image or a textframe, either geometrically or as a single character. Geometrically its position can either be relative to a paragraph to which it is anchored or relative to the complete document. The DrawingFrame class handles the positioning of the drawing in the document. A drawing frame is always associated with a drawing control of the type TXTextControl.Drawing.TXDrawingControl or TXTextControl.WPF.Drawing.TXDrawingControl. This drawing control handles the appearance and the data of the drawing. A drawing control can be activated so that its contents can be edited. Activation occurs either through a mouse double-click or through programming code with the Activate method. All drawings in a document are contained in a DrawingCollection. The collection can also be used to add drawings to or to remove drawings from the document. The drawing collection can be obtained through the TextControl.Drawings, WPF.TextControl.Drawings or ServerTextControl.Drawings property.

Introduced: 23.0.

Syntax

[C#]
public class DrawingFrame : FrameBase
[Visual Basic]
Public Class DrawingFrame
  Inherits FrameBase

Constructors

Constructor | Description
DrawingFrame | Initializes a new instance of the DrawingFrame class.

Properties

Property | Description
Alignment | Gets or sets the frame's horizontal alignment when it is anchored to a paragraph. (Inherited from FrameBase.)
Drawing | Gets the drawing control associated with the drawing frame.
ExportCompressionQuality | Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the drawing's bitmap image is exported.
ExportFileName | Gets or sets the file name, when the drawing's bitmap image is exported.
ExportFilterIndex | Gets or sets the format used, if a drawing's bitmap image is exported.
ExportResolution | Gets or sets the maximum resolution in dots per inch in which the drawing's bitmap image is saved.
ID | Gets or sets an identifier for the frame. (Inherited from FrameBase.)
InsertionMode | Gets or sets a value determining whether the frame is treated as a single character or the document's text either flows around or overwrites the frame. (Inherited from FrameBase.)
Location | Gets or sets, in twips, the frame's current location. (Inherited from FrameBase.)
Moveable | Determines whether a frame can be moved in the document at run time with the built-in mouse interface. (Inherited from FrameBase.)
Name | Gets or sets a name for the frame. (Inherited from FrameBase.)
SaveMode | Determines whether the drawing's bitmap image is stored through its binary data or through a file reference.
Size | Gets or sets the frame's size in twips. (Inherited from FrameBase.)
Sizeable | Determines whether the frame can be resized at run time with the built-in mouse interface. (Inherited from FrameBase.)
TextDistances | Gets or sets the distances, in twips, between the frame and the document's text. (Inherited from FrameBase.)
TextPosition | Read only. Gets the frame's character position in the document's text (one-based). (Inherited from FrameBase.)

Methods

Method | Description
Activate | Activates the drawing so that its contents can be edited.
AddUndoUnit | Add the current state of the drawing which is connected with this DrawingFrame to the undo stack.
ChangeZOrder | Changes the frame's z-order. (Inherited from FrameBase.)
Refresh | Overloaded. Refreshes the drawing.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame Constructor

Initializes a new instance of the DrawingFrame class.

Syntax

[C#]
public DrawingFrame(object drawing);
[Visual Basic]
Public Sub New(ByVal drawing As System.Object)
Parameter | Description
drawing | Specifies the drawing control associated with the drawing frame. It must be of the type TXTextControl.Drawing.TXDrawingControl or TXTextControl.WPF.Drawing.TXDrawingControl.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.Activate Method

Activates the drawing so that its contents can be edited. A drawing can only be activated, if the text part that contains the drawing has the input focus.

Syntax

[C#]
public bool Activate();
[Visual Basic]
Public Function Activate() as Boolean

Return Value

The return value is true, if the drawing could be activated. Otherwise it is false.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.AddUndoUnit Method

Add the current state of the drawing which is connected with this DrawingFrame to the undo stack. Programmatic changes performed with the drawing's properties and methods are not automatically added to a TextControl's undo stack. Calling this method is not necessary, when the drawing frame's layout in the text is changed.

Syntax

[C#]
public void AddUndoUnit();
[Visual Basic]
Public Sub AddUndoUnit()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.Drawing Property

Gets the drawing control associated with the drawing frame. It must be of the type TXTextControl.Drawing.TXDrawingControl or TXTextControl.WPF.Drawing.TXDrawingControl.

Syntax

[C#]
public object Drawing { get; }
[Visual Basic]
Public ReadOnly Property Drawing() As System.Object

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.ExportCompressionQuality Property

Sets a value between 1 and 100, which is the quality of a lossy data compression used, if the drawing's bitmap image is exported. It is only used, if the image data is compressed with a lossy compression algorithm. A value of 100 indicates the maximum quality, a value of 1 indicates the minimum quality. If this property is set to zero, which is the default value, Text Control uses the quality value set with the SaveSettings.ImageCompressionQuality property.

Syntax

[C#]
public int ExportCompressionQuality { get; set; }
[Visual Basic]
Public Property ExportCompressionQuality() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.ExportFileName Property

Gets or sets the file name, when the drawing's bitmap image is exported. An empty string indicates that no export filename has currently be specified for the drawing's image. In this case a constructed filename is used. A filename is constructed in the following form: <document_filename>_<number>.<extension>. The technical article Loading and Saving Images describes where newly created image files are stored.

Syntax

[C#]
public string ExportFileName { get; set; }
[Visual Basic]
Public Property ExportFileName() As String

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.ExportFilterIndex Property

Gets or sets the format used, if a drawing's bitmap image is exported. This is the number of the filter in the string returned through the ImageCollection.ExportFilters property, beginning with number one. A value of zero indicates that no export format has currently be specified for the drawing. In this case the drawing's image is saved in Windows Bitmap format. The technical article Loading and Saving Images lists the currently possible values for this property.

Syntax

[C#]
public int ExportFilterIndex { get; set; }
[Visual Basic]
Public Property ExportFilterIndex() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.ExportResolution Property

Gets or sets the maximum resolution in dots per inch in which the drawing's bitmap image is saved. If this property's value is zero, which is the default value, Text Control uses the resolution value set with the SaveSettings.ImageMaxResolution property.

Syntax

[C#]
public int ExportResolution { get; set; }
[Visual Basic]
Public Property ExportResolution() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.Refresh Method

Refreshes the drawing.

Refresh()

Refreshes the complete drawing. Programmatic changes performed with the drawing's properties and methods are not automatically refreshed. Calling this method is not necessary, when the drawing frame's layout in the text is changed.

[C#]
public void Refresh();
[Visual Basic]
Public Sub Refresh()

Refresh(Rectangle)

Refreshes the specified part of drawing. Programmatic changes performed with the drawing's properties and methods are not automatically refreshed. Calling this method is not necessary, when the drawing frame's layout in the text is changed.

[C#]
public void Refresh(System.Drawing.Rectangle clipRectangle);
[Visual Basic]
Public Sub Refresh(ByVal clipRectangle As System.Drawing.Rectangle)
Parameter | Description
clipRectangle | Specifies the rectangular part of the drawing to refresh, in pixels, relative to the top-left corner of the drawing.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DataVisualization.DrawingFrame.SaveMode Property

Determines whether the drawing's bitmap image is stored through its binary data or through a file reference. By default a drawing's image is stored with its binary data.

Syntax

[C#]
public ImageSaveMode SaveMode { get; set; }
[Visual Basic]
Public Property SaveMode() As ImageSaveMode
Value | Description
Auto | The image is saved as specified with the SaveSettings.ImageSaveMode property.
SaveAsData | The image is saved in a Text Control document with its complete binary data.
SaveAsFileReference | The image is saved in a Text Control document through a file reference. The technical article Loading and Saving Images describes where newly created image files are stored.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.DocumentServer namespace

DocumentServer Enumerations

TXTextControl.DocumentServer.DocumentController Class

TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection Class

TXTextControl.DocumentServer.MailMerge Class

TXTextControl.DocumentServer.MailMerge.BarcodeMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs Class

TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.ChartMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs Class

TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs Class

TXTextControl.DocumentServer.MergeCanceledException Class


DocumentServer Enumerations

TXTextControl.DocumentServer.FileFormat Enumeration


TXTextControl.DocumentServer.FileFormat Enumeration

Determines a certain text format. These formats can be used to load templates containing text fields of type ApplicationField. The enumeration contains the following values:

Member | Description
MSWord | Specifies Microsoft Word format.
RichTextFormat | Specifies RTF format (Rich Text Format).
WordprocessingML | Specifies Microsoft Office Open XML format.
InternalUnicodeFormat | Specifies the internal TX Text Control format. Text is stored in Unicode format.


TXTextControl.DocumentServer.DocumentController Class

The DocumentController class is a .NET component that can be used to perform the necessary document handling on the server, when using a control such as the DocumentServer.Web.DocumentViewer. The DocumentController class can be found in the TXTextControl.DocumentServer namespace. It is derived from the System.ComponentModel.Component class. The following describes only the properties and methods defined directly by the DocumentController class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 15.0.

Syntax

[C#]
public class DocumentController : Component
[Visual Basic]
Public Class DocumentController
  Inherits Component

Constructors

Constructor | Description
DocumentController | Initializes a new instance of the DocumentController class.

Properties

Property | Description
CharCodeChecked | Gets or sets the character's code that is used to render checked check boxes.
CharCodeUnchecked | Gets or sets the character's code that is used to render unchecked check boxes.
CheckBoxFont | Gets or sets the font used for rendering check boxes.
DpiX | Gets or sets the horizontal DPI value used for display-related calculations.
DpiY | Gets or sets the vertical DPI value used for display-related calculations.
Pages | Gets a collection of all pages contained in the currently loaded document.
TextComponent | Gets or sets the object of type ServerTextControl that is associated with the DocumentController component.

Methods

Method | Description
Dispose | Frees all resources used by the DocumentController instance.
GetBlockFieldNames | Gets a list of the names of all the application fields which are contained inside the specified merge block.
GetBlockNames | Gets a list of the names of all the merge blocks contained in the document.
GetFieldAdapters | Overloaded. Gets a collection of adapters for all application fields in the specified scope.
GetFieldNames | Get field names.
Load | Loads a document from a file that is used for further processing.
LoadFromMemory | Loads a document from memory that is used for further processing.
MergeField | Sets the value of the form field specified through the given adapter to the submitted value.
Save | Saves the document that is currently loaded in the DocumentController to a file.
SaveToMemory | Overloaded. Saves the document that is currently loaded in the DocumentController.
Twips2Pixels | Converts a value in twips to a value in pixels according to a specified resolution.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController Constructor

Initializes a new instance of the DocumentController class.

Syntax

[C#]
public DocumentController();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.CharCodeChecked Property

Gets or sets the character's code that is used to render checked check boxes.

Syntax

[C#]
public int CharCodeChecked { get; set; }
[Visual Basic]
Public Property CharCodeChecked() As Integer

Remarks

The value of this property relates to the setting of DocumentServer.DocumentController.CheckBoxFont. The property's default value is 254, which is the code for 'ballot box with check' in Wingdings. The character codes can be looked up using the system tool Character Map. The hexadecimal character codes shown there simply have to be converted to decimal values.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.CharCodeUnchecked Property

Gets or sets the character's code that is used to render unchecked check boxes.

Syntax

[C#]
public int CharCodeUnchecked { get; set; }
[Visual Basic]
Public Property CharCodeUnchecked() As Integer

Remarks

The value of this property relates to the setting of DocumentServer.DocumentController.CheckBoxFont. The property's default value is 168, which is the code for 'ballot box' in Wingdings. The character codes can be looked up using the system tool Character Map. The hexadecimal character codes shown there simply have to be converted to decimal values.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.CheckBoxFont Property

Gets or sets the font used for rendering check boxes.

Syntax

[C#]
public Font CheckBoxFont { get; set; }
[Visual Basic]
Public Property CheckeBoxFont() As Font

Remarks

The default check box font is Wingdings.

Example

The following example sets a new check box font:

[C#]
TXTextControl.DocumentController documentController1 = new TXTextControl.DocumentController();
documentController1.CheckBoxFont = new System.Drawing.Font(new FontFamily("Symbol"), 1f);
[Visual Basic]
Dim DocumentController1 As TXTextControl.DocumentController = New TXTextControl.DocumentController
DocumentController1.CheckBoxFont = New System.Drawing.Font(New FontFamily("Symbol"), 1F)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.Dispose Method

Frees all resources used by the DocumentController instance.

Syntax

[C#]
new public virtual void Dispose()
[Visual Basic]
Public Overridable Shadows Sub Dispose()

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.DpiX Property

Gets or sets the horizontal DPI value used for display-related calculations.

Syntax

[C#]
public static float DpiX { get; set; }
[Visual Basic]
Public Shared Property DpiX() As Single

Remarks

The property's default value is 96.0.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.DpiY Property

Gets or sets the vertical DPI value used for display-related calculations.

Syntax

[C#]
public static float DpiY { get; set; }
[Visual Basic]
Public Shared Property DpiY() As Single

Remarks

The property's default value is 96.0.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.MergeField Method

Sets the value of the form field specified through the given adapter to the submitted value.

Syntax

[C#]
public void MergeField(DocumentServer.Fields.FormFieldAdapter fieldAdapter, string value)
[Visual Basic]
Public Sub GetBlockFieldNames(ByRef fieldAdapter As DocumentServer.Fields.FormFieldAdapter, ByVal value As String)
Parameter | Description
fieldAdapter | The adapter for the form field whose value is to be set.
value | Specifies the value the form field is to be set to.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.Pages Property

Gets a collection of all pages contained in the currently loaded document.

Syntax

[C#]
public PageCollection Pages { get; }
[Visual Basic]
Public ReadOnly Property Pages() As PageCollection

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.TextComponent Property

Gets or sets the object of type ServerTextControl that is associated with the DocumentController component. Invoking one of the DocumentController's instance methods will result in an exception being thrown, if the TextComponent property is left unset.

Syntax

[C#]
public Component TextComponent { get; set; }
[Visual Basic]
Public Property TextComponent() As Component

Example

The following example creates a new DocumentServer.DocumentController object and associates a ServerTextControl with it:

[C#]
TXTextControl.DocumentController documentController1 = new TXTextControl.DocumentController();
TXTextControl.ServerTextControl serverTextControl1 = new TXTextControl.ServerTextControl();

documentController1.TextComponent = serverTextControl1;
[Visual Basic]
Dim DocumentController1 As TXTextControl.DocumentController = New TXTextControl.DocumentController
Dim ServerTextControl1 As TXTextControl.ServerTextControl = New TXTextControl.ServerTextControl

DocumentController1.TextComponent = ServerTextControl1

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.GetBlockFieldNames Method

Gets a list of the names of all the application fields which are contained inside the specified merge block.

Syntax

[C#]
public string[] GetBlockFieldNames(string block)
[Visual Basic]
Public Function GetBlockFieldNames(ByRef block As String) As String[]
Parameter | Description
block | Specifies the name of the merge block whose field names are to be returned.

Return Value

A list of the fields' names contained in the specified merge block.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.GetBlockNames Method

Gets a list of the names of all the merge blocks contained in the document.

Syntax

[C#]
public string[] GetBlockNames()
[Visual Basic]
Public Function GetBlockNames() As String[]

Return Value

A list of the name of all merge blocks contained in the document.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.GetFieldAdapters Method

Gets a collection of adapters for all application fields in the specified scope.

GetFieldAdapters()

Gets all adapters for all application fields.

[C#]
public FieldAdapterCollection GetFieldAdapters()
[Visual Basic]
Public Function GetFieldAdapters() As FieldAdapterCollection

GetFieldAdapters(Page)

Gets a collection of adapters for all application fields in the specified scope. Returns a collection of adapters for the fields located on the given page.

[C#]
public FieldAdapterCollection GetFieldAdapters(Page page)
[Visual Basic]
Public Function GetFieldAdapters(ByRef page As Page) As FieldAdapterCollection
Parameter | Description
page | Specifies the page for whose fields a collection of adapters is to be returned.

Return Value

Returns a collection of adapters for the fields located on the given page. If no page is specified, a collection of the adapters for all fields in the currently loaded document are returned.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.GetFieldNames Method

Get field names.

Syntax

[C#]
public string[] GetFieldNames();
[Visual Basic]
Public Function GetFieldNames() As String[]

Return Value

Returns a list of the names of the application fields in the loaded document.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.Load Method

Loads a document from a file that is used for further processing.

Syntax

[C#]
public bool Load(string filename, DocumentServer.FileFormat documentFormat);
[Visual Basic]
Public Function Load(ByVal filename As String, ByVal documentFormat As DocumentServer.FileFormat) As Boolean
Parameter | Description
filename | Specifies the document file to be loaded.
documentFormat | Specifies one of the DocumentServer.FileFormat values.

Return Value

Returns true, if the document was loaded successfully and false, if the document is invalid or could not be loaded properly.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.LoadFromMemory Method

Loads a document from memory that is used for further processing.

Syntax

[C#]
public bool LoadFromMemory(object document, DocumentServer.FileFormat documentFormat);
[Visual Basic]
Public Function LoadFromMemory(ByVal document As Object, ByVal documentFormat As DocumentServer.FileFormat) As Boolean
Parameter | Description
document | Specifies a document memory variable from which the data is loaded.
documentFormat | Specifies one of the DocumentServer.FileFormat values.

Return Value

Returns true, if the document was loaded successfully and false, if the document is invalid or could not be loaded properly.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.Save Method

Saves the document that is currently loaded in the DocumentController to a file.

Syntax

[C#]
public void Save(string filename, TXTextControl.StreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal filename As String, ByVal fileFormat As TXTextControl.StreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
filename | Specifies a file into which the data is saved. If the file does not exist, it is created. If the file exists, its contents are overwritten.
fileFormat | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.SaveToMemory Method

Saves the document that is currently loaded in the DocumentController.

SaveToMemory(Byte[], BinaryStreamType, SaveSettings)

Saves the document that is currently loaded in the DocumentController to a byte array.

[C#]
public void SaveToMemory(out byte[] data, TXTextControl.BinaryStreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub SaveToMemory(ByRef data As Byte(), ByVal fileFormat As TXTextControl.BinaryStreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
data | Specifies a byte array or a string into which the data is saved. No memory needs to be allocated through the caller.
fileFormat | Specifies one of the BinaryStreamType or the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

SaveToMemory(String, StringStreamType, SaveSettings)

Saves the document that is currently loaded in the DocumentController to a string.

[C#]
public void SaveToMemory(out string data, TXTextControl.StringStreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub SaveToMemory(ByRef data As String, ByVal fileFormat As TXTextControl.StringStreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
data | Specifies a byte array or a string into which the data is saved. No memory needs to be allocated through the caller.
fileFormat | Specifies one of the BinaryStreamType or the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.Twips2Pixels Method

Converts a value in twips to a value in pixels according to a specified resolution. This is a helper method that is useful when implementing pixel-based document viewers.

Syntax

[C#]
public static int Twips2Pixels(int twips, float dpi)
[Visual Basic]
Public Shared Function Twips2Pixels(ByVal twips As Integer, ByVal dpi As Single) As Integer
Parameter | Description
twips | The value in twips to be converted.
dpi | The resolution the conversion is based on.

Return Value

Returns the value converted to pixels according to the specified resolution.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection Class

An instance of the FieldAdapterCollection class contains adapters for all application fields of the page it belongs to. An instance of this class can be obtained via the DocumentController.Page.FieldAdapters property. The FieldAdapterCollection that can be accessed via the DocumentController.FieldAdapters property contains adapters for all the application fields in the currently loaded document, of course. The FieldAdapterCollection class implements the IEnumerable and the ICollection interfaces and is part of the TXTextControl.DocumentServer.DocumentController namespace.

Introduced: 15.0.

Syntax

[C#]
public sealed class FieldAdapterCollection: ICollection, IEnumerable
[Visual Basic]
Public NotInheritable Class PageCollection
  Implements ICollection
  Implements IEnumerable

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
Item | Gets the DocumentServer.Fields.FieldAdapter instance at the specified index from the collection.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at the specified index.
GetEnumerator | Returns an enumerator that can be used to iterate over the collection's items.
IndexOf | Gets the index of the specified field adapter in the collection.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection.Item Property

Gets the DocumentServer.Fields.FieldAdapter instance at the specified index from the collection. In C# this property is the indexer for the FieldAdapterCollection class.

Syntax

[C#]
public DocumentServer.Fields.FieldAdapter this [int index] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(ByVal index As Integer) As DocumentServer.Fields.FieldAdapter
Parameter | Description
index | Specifies a field adapter index. The first field adapter has the index 0.

Remarks

If there is no adapter for the type of field at the given index, the property returns null. Otherwise, it is an object of type DocumentServer.Fields.FieldAdapter

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection.CopyTo Method

Copies the elements of the collection to an array, starting at the specified index.

Syntax

[C#]
public void CopyTo(Array array, int index);
[Visual Basic]
Public Sub CopyTo(ByVal array As Array, ByVal index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate over the collection's items.

Syntax

[C#]
public IEnumerator GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.DocumentController.FieldAdapterCollection.IndexOf Method

Gets the index of the specified field adapter in the collection.

Syntax

[C#]
public int IndexOf(DocumentServer.Fields.FieldAdapter fieldAdapter);
[Visual Basic]
Public Function IndexOf(ByRef fieldAdapter As DocumentServer.Fields.FieldAdapter)
Parameter | Description
fieldAdapter | Specifies the field adapter whose index should be looked up.

Return Value

The integer returned by the function represents the field adapter's position in the collection. If the specified field adapter is not in the collection, a negative value is returned.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.MailMerge Class

The MailMerge class is a .NET component that can be used to effortlessly merge template documents with database content in .NET projects, such as ASP.NET web applications, web services or Windows services. The MailMerge class can be found in the TXTextControl.DocumentServer namespace. It is inherited from the System.ComponentModel.Component class. The following describes only the properties and methods defined through the MailMerge class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 14.0.

Syntax

[C#]
public class MailMerge : Component
[Visual Basic]
Public Class MailMerge
  Inherits Component

Constructors

Constructor | Description
MailMerge | Initializes a new instance of the MailMerge class.

Properties

Property | Description
MergeBlockNamePrefix | A static property returning the internal merge block name prefix “txmb_”.
RemoveEmptyBlocks | Specifies whether the content of empty merge blocks should be removed from the template or not.
RemoveEmptyFields | Specifies whether empty fields should be removed from the template or not.
RemoveEmptyImages | Specifies whether images which don't have merge data should be removed from the template or not.
RemoveTrailingWhitespace | Specifies whether trailing whitespace should be removed before saving a document.
ReportDataSourceConfig | Specifies the Report Data Source Configuration as an XML string.
ReportDataSourceConfigFile | Gets or sets the file path of a Report Data Source Configuration file (*.rdsc) which has been created with TX Text Control Words.
SearchPath | Specifies a directory name where sub-templates and images (for image merging) should be searched.
TemplateFile | Specifies the template file path.
TextComponent | Gets or sets the TextComponent object which is associated with the MailMerge component.
UseTemplateFormat | Specifies whether the template page size and margins should be used or not.

Methods

Method | Description
GetBlockFieldNames | Returns the names of all merge fields inside the merge block with the specified name.
GetBlockNames | Lists the names of all merge blocks contained in the currently loaded template.
LoadTemplate | Loads a template from a file that is used for the merge process.
LoadTemplateFromMemory | Loads a template from memory that is used for the merge process.
Merge | Overloaded. Merges given data into the loaded document template.
MergeBlocks | Merges all repeating blocks that are contained in the loaded template with the System.Data.DataTable instances contained in the given System.Data.DataSet.
MergeJsonData | Overloaded. Merges data given as a JSON string into a document template.
MergeObject | Merges a single instance of an arbitrary type into the loaded document template.
MergeObjects | Overloaded. Merges a collection of type System.Collections.IEnumerable containing objects of any type or instances of type System.Collections.Generic.Dictionary with string keys into the loaded document template.
Print | Overloaded. Prints the merged document.
SaveDocument | Saves the merged document to a file.
SaveDocumentToMemory | Overloaded. Saves the merged document.

Events

Event | Description
BarcodeMerged | Occurs when a barcode has been merged successfully.
BlockMerging | Occurs when a merge block is about to be merged.
BlockRowMerged | Occurs when a merge block row has been merged successfully.
ChartMerged | Occurs when a chart has been merged successfully.
DataRowMerged | Occurs when a data row has been merged successfully.
FieldMerged | Occurs when a field has been merged.
ImageFieldMerged | Occurs when an image field, i.e., a merge field whose name is prefixed with "image:" has been merged.
ImageMerged | Occurs when an image has been merged successfully.
IncludeTextMerging | Occurs when an IncludeText field has been merged.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge Constructor

Initializes a new instance of the MailMerge class.

Syntax

[C#]
public MailMerge();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BarcodeMerged Event

Occurs when a barcode has been merged successfully. The event handler receives an argument of type BarcodeMergedEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeMergedHandler BarcodeMerged;
[Visual Basic]
Public Event BarcodeMerged As BarcodeMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockMerging Event

Occurs when a merge block is about to be merged. The event handler receives an argument of type BlockMergingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event BlockMergingHandler BlockMerging;
[Visual Basic]
Public Event BlockMerging As BlockMergingHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMerged Event

Occurs when a merge block row has been merged successfully. The event handler receives an argument of type BlockRowMergedEventArgs containing data related to this event. This event can be used to change the content or formatting of a merged row in the repeating block.

Syntax

[C#]
public event BlockRowMergedHandler BlockRowMerged;
[Visual Basic]
Public Event BlockRowMerged As BlockRowMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ChartMerged Event

Occurs when a chart has been merged successfully. The event handler receives an argument of type ChartMergedEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ChartMergedHandler ChartMerged;
[Visual Basic]
Public Event ChartMerged As ChartMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMerged Event

Occurs when a data row has been merged successfully. The event handler receives an argument of type DataRowMergedEventArgs containing data related to this event.

Syntax

[C#]
public event DataRowMergedHandler DataRowMerged;
[Visual Basic]
Public Event DataRowMerged As DataRowMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMerged Event

Occurs when a field has been merged. The event handler receives an argument of type FieldMergedEventArgs containing data related to this event. This event can be used to change the field text and to determine whether the field has been merged successfully.

Introduced: 15.0.

Syntax

[C#]
public event FieldMergedHandler FieldMerged;
[Visual Basic]
Public Event FieldMerged As FieldMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.GetBlockFieldNames Method

Returns the names of all merge fields inside the merge block with the specified name.

Introduced: 19.0.

Syntax

[C#]
public string[] GetBlockFieldNames(string blockName);
[Visual Basic]
Public Function GetBlockFieldNames(ByVal blockName As String) As String()
Parameter | Description
blockName | Specifies the name of the block for which the field names are returned.

Return Value

Returns an array of strings specifying the field names.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.GetBlockNames Method

Lists the names of all merge blocks contained in the currently loaded template.

Introduced: 16.0.

Syntax

[C#]
public string[] GetBlockNames();
[Visual Basic]
Public Function GetBlockNames() As String()

Return Value

Returns a list of the blocks contained in the currently loaded template.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMerged Event

Occurs when an image field, i.e., a merge field whose name is prefixed with "image:" has been merged. The event handler receives an argument of type ImageFieldMergedEventArgs containing data related to this event. This event can be used to change the image and to determine whether the field has been merged successfully.

Introduced: 16.0.

Syntax

[C#]
public event ImageFieldMergedHandler ImageFieldMerged;
[Visual Basic]
Public Event ImageFieldMerged As ImageFieldMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMerged Event

Occurs when an image has been merged successfully. The event handler receives an argument of type ImageMergedEventArgs containing data related to this event.

Introduced: 20.0.

Syntax

[C#]
public event ImageMergedHandler ImageMerged;
[Visual Basic]
Public Event ImageMerged As ImageMergedHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.IncludeTextMerging Event

Occurs when an IncludeText field has been merged. The event handler receives an argument of type IncludeTextMergingEventArgs containing data related to this event.

Introduced: 15.0.

Syntax

[C#]
public event IncludeTextMergingHandler IncludeTextMerging;
[Visual Basic]
Public Event IncludeTextMerging As IncludeTextMergingHandler

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.LoadTemplate Method

Loads a template from a file that is used for the merge process.

Syntax

[C#]
public bool LoadTemplate(string filename, DocumentServer.FileFormat documentFormat);
[Visual Basic]
Public Function LoadTemplate(ByVal filename As String, ByVal documentFormat As DocumentServer.FileFormat) As Boolean
Parameter | Description
filename | Specifies a template file from which the data is loaded.
documentFormat | Specifies one of the DocumentServer.FileFormat values.

Return Value

Returns true, if the template could be loaded successfully and false, if the template is invalid or could not be loaded properly.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.LoadTemplateFromMemory Method

Loads a template from memory that is used for the merge process.

Syntax

[C#]
public bool LoadTemplateFromMemory(object template, DocumentServer.FileFormat documentFormat);
[Visual Basic]
Public Function LoadTemplateFromMemory(ByVal template As Object, ByVal documentFormat As DocumentServer.FileFormat) As Boolean
Parameter | Description
template | Specifies a template memory variable from which the data is loaded.
documentFormat | Specifies one of the DocumentServer.FileFormat values.

Return Value

Returns true, if the template could be loaded successfully and false, if the template is invalid or could not be loaded properly.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.Merge Method

Merges given data into the loaded document template. The supported format of the merge fields can be found in the ASP.NET User's Guide.

Merge(DataTable, Boolean)

Merges the loaded template with the data of a specific System.Data.DataTable. The second parameter specifies whether the single documents should be merged into one document or splitted into separate documents.

[C#]
public void Merge(System.Data.DataTable mergeData, bool append);
[Visual Basic]
Public Sub Merge(ByVal mergeData As System.Data.DataTable, ByVal append As Boolean)
Parameter | Description
mergeData | Specifies a System.Data.DataTable that contains the merge data.
append | Specifies whether the single documents should be merged into one document or split into separate documents.

Merge(DataTable)

Does the same as Merge(System.Data.DataTable mergeData, bool append) with parameter “append” set to true.

[C#]
public void Merge(System.Data.DataTable mergeData);
[Visual Basic]
Public Sub Merge(ByVal mergeData As System.Data.DataTable)
Parameter | Description
mergeData | Specifies a System.Data.DataTable that contains the merge data.

Merge(Boolean)

Merges data into the template using a data base connection given through a data source configuration file or data source configuration XML data. (See also ReportDataSourceConfigFile property and ReportDataSourceConfig property)

[C#]
public void Merge(bool append);
[Visual Basic]
Public Sub Merge(ByVal append As Boolean)
Parameter | Description
append | Specifies whether the single documents should be merged into one document or split into separate documents.

Merge()

Does the same as method Merge(bool append) with parameter “append” set to true.

[C#]
public void Merge();
[Visual Basic]
Public Sub Merge()

Example

The following example merges a template that contains two merge fields: name and company.

[C#]
DataTable mergeData = new DataTable();
mergeData.Columns.Add("name");
mergeData.Columns.Add("company");

mergeData.Rows.Add(new object[] { "Peter Jackson", "Text Control GmbH" });
mergeData.Rows.Add(new object[] { "Jack Petersen", "The Imaging Source LLC" });

mailMerge1.LoadTemplate("template.doc", TXTextControl.DocumentServer.FileFormat.MSWord);

mailMerge1.Merge(mergeData, true);

TXTextControl.SaveSettings sSettings = new TXTextControl.SaveSettings();
mailMerge1.SaveDocument("results.pdf", TXTextControl.StreamType.AdobePDF, sSettings);
[Visual Basic]
Dim MergeData As New DataTable()
MergeData.Columns.Add("name")
MergeData.Columns.Add("company")

MergeData.Rows.Add(New Object() {"Peter Jackson", "Text Control GmbH"})
MergeData.Rows.Add(New Object() {"Jack Petersen", "The Imaging Source LLC"})

MailMerge1.LoadTemplate("template.doc", TXTextControl.DocumentServer.FileFormat.MSWord)

MailMerge1.Merge(MergeData, True)

Dim SSettings As New TXTextControl.SaveSettings()
MailMerge1.SaveDocument("results.pdf", TXTextControl.StreamType.AdobePDF, SSettings)

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.MergeBlocks Method

Merges all repeating blocks that are contained in the loaded template with the System.Data.DataTable instances contained in the given System.Data.DataSet. The name of the System.Data.DataTable must match the name of the block in the template. The supported format of the repeating blocks can be found in the ASP.NET User's Guide.

Syntax

[C#]
public int MergeBlocks(System.Data.DataSet mergeData);
[Visual Basic]
Public Function MergeBlocks(ByVal mergeData As System.Data.DataSet) As Integer
Parameter | Description
mergeData | Specifies a System.Data.DataSet that contains the merge data.

Return Value

Returns the number of successfully merged blocks.

Example

The following example merges a block in a template.

[C#]
DataSet mergeData = new DataSet();

DataTable blockData = new DataTable("section1");
blockData.Columns.Add("name");
blockData.Columns.Add("company");
blockData.Rows.Add(new object[] { "Peter Jackson", "Text Control GmbH" });
blockData.Rows.Add(new object[] { "Jack Peterson", "The Imaging Source LLC" });

mergeData.Tables.Add(blockData);
mailMerge1.MergeBlocks(mergeData);
[Visual Basic]
Dim MergeData As New DataSet()

Dim BlockData As New DataTable("section1")
BlockData.Columns.Add("name")
BlockData.Columns.Add("company")
BlockData.Rows.Add(New Object() {"Peter Jackson", "Text Control GmbH"})
BlockData.Rows.Add(New Object() {"Jack Peterson", "The Imaging Source LLC"})

MergeData.Tables.Add(BlockData)
MailMerge1.MergeBlocks(MergeData)

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.MergeJsonData Method

Merges data given as a JSON string into a document template. The JSON string has to contain either a single object or an array of equally structured objects. Analyzes and uses the given object(s) as merge data in the same way as the method MergeObjects.

Introduced: 24.0.

MergeJsonData(String, Boolean)

Merges data given as a JSON string into a document template. The JSON string has to contain either a single object or an array of equally structured objects.

[C#]
public void MergeJsonData(string json, bool append);
[Visual Basic]
Public Sub MergeJsonData(ByVal json As String, ByVal append As Boolean)
Parameter | Description
json | The JSON string containing the merge data.
append | Specifies whether the merge result should be merged into one document or split into separate documents.

MergeJsonData(String)

Does the same as MergeJsonData with the parameter “append” set to true.

[C#]
public void MergeJsonData(string json);
[Visual Basic]
Public Sub MergeJsonData(ByVal json As String)
Parameter | Description
json | The JSON string containing the merge data.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.MergeObject Method

Merges a single instance of an arbitrary type into the loaded document template. For more information about .NET reflection based object merging read the documentation of the MergeObjects method.

Introduced: 23.0.

Syntax

[C#]
public void MergeObject(object mergeData);
[Visual Basic]
Public Sub MergeObject(mergeData As Object)
Parameter | Description
mergeData | Specifies the object to merge into the template.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.MergeObjects Method

Merges a collection of type System.Collections.IEnumerable containing objects of any type or instances of type System.Collections.Generic.Dictionary with string keys into the loaded document template.

Introduced: 20.0.

MergeObjects(IEnumerable, Boolean)

Interprets all public properties of the objects or the key names of the dictionaries in the collection as possible table columns and / or child tables. The type of the first object (or the key names and types of the first dictionary) in the collection is analyzed via .NET reflection and used as the basis of the assumed table structure. (In case of the collection containing objects of different types, the merge process is successful nevertheless, but some fields will be empty.) Properties of simple data types (e. g. string, int, enum) are converted to text using the ToString method. The textual representation of enum values can be specified using the System.ComponentModel.DescriptionAttribute. (For example: enum FoodCategory { [Description("Grains / Cereals")] Grains_Cereals, ... }.) The name by which Properties are mapped to field names can be adjusted using the System.ComponentModel.DisplayNameAttribute. (For example: [DisplayName("Name")] public string ProductName { get; set; }.) Complex properties which are themselves of type System.Collections.IEnumerable are interpreted as child Tables and used for merging merge blocks and nested merge blocks. This way data relations can be represented. Properties of a type itself having public properties are either interpreted as a simple table column (the merged text then is determined using the ToString() method) or they are treated as if they were a child table containing only one data row with the properties being the table columns. The second parameter specifies whether the single documents should be merged into one document or split into separate documents. The supported format of the merge fields can be found in the ASP.NET User's Guide.

[C#]
public void MergeObjects(System.Collections.IEnumerable mergeData, bool append);
[Visual Basic]
Public Sub MergeObjects(ByVal mergeData As System.Collections.IEnumerable, ByVal append As Boolean)
Parameter | Description
mergeData | Specifies a System.Collections.IEnumerable that contains the merge data.
append | Specifies whether the single documents should be merged into one document or split into separate documents.

MergeObjects(IEnumerable)

Does the same as MergeObjects with the parameter “append” set to true.

[C#]
public void MergeObjects(System.Collections.IEnumerable mergeData);
[Visual Basic]
Public Sub MergeObjects(ByVal mergeData As System.Collections.IEnumerable)
Parameter | Description
mergeData | Specifies a System.Collections.IEnumerable that contains the merge data.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.Print Method

Prints the merged document.

Print(PrintDocument)

Prints the merged document. It uses the settings of the specified PrintDocument.

[C#]
public void Print(System.Drawing.Printing.PrintDocument printDocument);
[Visual Basic]
Public Sub Print(ByVal printDocument As System.Drawing.Printing.PrintDocument)
Member Description
printDocument

Specifies an instance of the PrintDocument class. Text Control uses the following settings of this object:

Setting | Meaning
DocumentName | Specifies the document's name.
PrintController | Specifies the document's print controller.
PrinterSettings.FromPage | The first page to print.
PrinterSettings.ToPage | The last page to print.
PrinterSettings.Copies | The number of copies to print.
PrinterSettings.Collate | Specifies how the printed pages are sorted.
PrinterSettings.PrinterName | Specifies the name of the printer.
PrinterSettings.PrintToFile | Specifies whether the printed pages are saved in a file.
PrinterSettings.PrintRange | Specifies the range of pages to print.
DefaultPageSettings.Color | Specifies whether the printed pages are printed colored.

Print(String, String, Int32, Boolean)

Prints the merged document with specific settings for the document name, the printer name, the number of copies and whether it should be collated or not.

[C#]
public void  Print(string docName, string printerName, int copyCount, bool collate);
[Visual Basic]
Public Sub Print(ByVal docName As String, ByVal printerName As String, ByVal copyCount As Integer, ByVal collate As Boolean)
Member | Description
docName | Specifies the document's name.
printerName | Specifies the name of the printer to which the output is sent.
copyCount | Specifies the number of copies to print.
collate | Collates output by printing every page of the first copy, then every page of the second copy, and so on. When collate is set to false, the printer prints every copy of the first page, then every copy of the second page, and so on.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.RemoveEmptyBlocks Property

Specifies whether the content of empty merge blocks should be removed from the template or not. The default value is true.

Introduced: 23.0.

Syntax

[C#]
public bool RemoveEmptyBlocks { get; set; }
[Visual Basic]
Public Property RemoveEmptyBlocks() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.RemoveEmptyFields Property

Specifies whether empty fields should be removed from the template or not. The default value is true.

Syntax

[C#]
public bool RemoveEmptyFields { get; set; }
[Visual Basic]
Public Property RemoveEmptyFields() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.RemoveEmptyImages Property

Specifies whether images which don't have merge data should be removed from the template or not. The default value is false.

Introduced: 23.0.

Syntax

[C#]
public bool RemoveEmptyImages { get; set; }
[Visual Basic]
Public Property RemoveEmptyImages() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.RemoveTrailingWhitespace Property

Specifies whether trailing whitespace should be removed before saving a document. The default value is true.

Introduced: 16.0.

Syntax

[C#]
public bool RemoveTrailingWhitespace { get; set; }
[Visual Basic]
Public Property RemoveTrailingWhitespace() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ReportDataSourceConfig Property

Specifies the Report Data Source Configuration as an XML string. Must be in the same form as the content of a Report Data Source Configuration file created by TX Text Control Words.

Introduced: 20.0.

Syntax

[C#]
public string ReportDataSourceConfig { get; set; }
[Visual Basic]
Public Property ReportDataSourceConfig() as String

See Also

  • ReportDataSourceConfigFile property
  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ReportDataSourceConfigFile Property

Gets or sets the file path of a Report Data Source Configuration file (*.rdsc) which has been created with TX Text Control Words.

Introduced: 20.0.

Syntax

[C#]
public string ReportDataSourceConfigFile { get; set; }
[Visual Basic]
Public Property ReportDataSourceConfigFile() as String

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.SaveDocument Method

Saves the merged document to a file.

Syntax

[C#]
public void SaveDocument(string filename, TXTextControl.StreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub SaveDocument(ByVal filename As String, ByVal fileFormat As TXTextControl.StreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
filename | Specifies a file into which the data is saved. If the file does not exist, it is created. If the file exists, its contents are overwritten.
fileFormat | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.SaveDocumentToMemory Method

Saves the merged document.

SaveDocumentToMemory(Byte[], BinaryStreamType, SaveSettings)

Saves the merged document to a byte array.

[C#]
public void SaveDocumentToMemory(out byte[] data, TXTextControl.BinaryStreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub SaveDocumentToMemory(ByRef data As Byte(), ByVal fileFormat As TXTextControl.BinaryStreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
data | Specifies a byte array or a string into which the data is saved. No memory needs to be allocated through the caller.
fileFormat | Specifies one of the BinaryStreamType or the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

SaveDocumentToMemory(String, StringStreamType, SaveSettings)

Saves the merged document to a string.

[C#]
public void SaveDocumentToMemory(out string data, TXTextControl.StringStreamType fileFormat, TXTextControl.SaveSettings saveSettings);
[Visual Basic]
Public Sub SaveDocumentToMemory(ByRef data As String, ByVal fileFormat As TXTextControl.StringStreamType, ByVal saveSettings As TXTextControl.SaveSettings)
Parameter | Description
data | Specifies a byte array or a string into which the data is saved. No memory needs to be allocated through the caller.
fileFormat | Specifies one of the BinaryStreamType or the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.SearchPath Property

Specifies a directory name where sub-templates and images (for image merging) should be searched. If SearchPath is empty, the root directory is used.

Introduced: 15.0.

Syntax

[C#]
public string SearchPath { get; set; }
[Visual Basic]
Public Property SearchPath() As String

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.TemplateFile Property

Specifies the template file path. Can be used instead of the LoadTemplate method. The document format is deduced from the file extension automatically.

Introduced: 20.0.

Syntax

[C#]
public string TemplateFile { get; set; }
[Visual Basic]
Public Property TemplateFile() As String

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.MergeBlockNamePrefix Property

A static property returning the internal merge block name prefix “txmb_”. The name of a SubTextPart has to start with this prefix if it should be recognized as a repeating mail merge block by the merge methods of class MailMerge.

Introduced: 24.0.

Syntax

[C#]
public static string MergeBlockNamePrefix { get; }
[Visual Basic]
Public Shared ReadOnly Property MergeBlockNamePrefix() As String

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.TextComponent Property

Gets or sets the TextComponent object which is associated with the MailMerge component. It must be of the type ServerTextControl, TextControl or WPF.TextControl. The PageSize, PageMargins and Landscape properties will be used, if UseTemplateFormat has been set to false. The ServerTextControl.FormattingPrinter property will be used internally to format the text. It returns null when not specified.

Syntax

[C#]
public object TextComponent { get; set; }
[Visual Basic]
Public Property TextComponent() As System.Object

Example

The following example creates a new MailMerge object and associates a ServerTextControl with it:

[C#]
TXTextControl.MailMerge mailMerge1 = new TXTextControl.MailMerge();
TXTextControl.ServerTextControl serverTextControl1 = new TXTextControl.ServerTextControl();

mailMerge1.TextComponent = serverTextControl1;
[Visual Basic]
Dim MailMerge1 As TXTextControl.MailMerge = New TXTextControl.MailMerge
Dim ServerTextControl1 As TXTextControl.ServerTextControl = New TXTextControl.ServerTextControl

MailMerge1.TextComponent = ServerTextControl1

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.UseTemplateFormat Property

Specifies whether the template page size and margins should be used or not. The default value is false.

Syntax

[C#]
public bool UseTemplateFormat { get; set; }
[Visual Basic]
Public Property UseTemplateFormat() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BarcodeMergedEventArgs Class

The BarcodeMergedEventArgs class provides data for the BarcodeMerged event.

Introduced: 19.0.

Syntax

[C#]
public class BarcodeMergedEventArgs: EventArgs
[Visual Basic]
Public Class BarcodeMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
BarcodeFrame | Gets a BarcodeFrame object representing the merged barcode in the document.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BarcodeMergedEventArgs.BarcodeFrame Property

Gets a BarcodeFrame object representing the merged barcode in the document.

Syntax

[C#]
public DataVisualization.BarcodeFrame BarcodeFrame { get; }
[Visual Basic]
Public ReadOnly Property BarcodeFrame() As DataVisualization.BarcodeFrame

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs Class

The BlockMergingEventArgs class provides data for the BlockMerging event.

Introduced: 23.0.

Syntax

[C#]
public class BlockMergingEventArgs : CancelEventArgs
[Visual Basic]
Public Class BlockMergingEventArgs
  Inherits CancelEventArgs

Properties

Property | Description
BlockData | Gets the block data as an array of data rows.
BlockName | Gets the name of the merge block the event was fired for.
ColumnNames | Gets the column names of the table supplying the data for the block.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs.ColumnNames Property

Gets the column names of the table supplying the data for the block.

Syntax

[C#]
public string[] ColumnNames { get; }
[Visual Basic]
Public ReadOnly Property ColumnNames() As String()

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs.BlockName Property

Gets the name of the merge block the event was fired for.

Syntax

[C#]
public string BlockName { get; }
[Visual Basic]
Public ReadOnly Property BlockName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockMergingEventArgs.BlockData Property

Gets the block data as an array of data rows. Each data row implements the IDataRowAdapter interface.

Syntax

[C#]
public IDataRowAdapter[] BlockData { get; }
[Visual Basic]
Public ReadOnly Property BlockData() As IDataRowAdapter()

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs Class

The BlockRowMergedEventArgs class provides data for the BlockRowMerged event.

Introduced: 14.0.

Syntax

[C#]
public class BlockRowMergedEventArgs: EventArgs
[Visual Basic]
Public Class BlockRowMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
DataRowCount | Gets an int value that indicates the total number of data rows.
DataRowNumber | Gets an int value that indicates the currently merged data row in the merge block.
MergeBlockName | Gets a string value that indicates current merge block name.
MergedBlockRow | Gets or sets a byte[] array that contains the complete data of the merged block row.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.DataRowNumber Property

Gets an int value that indicates the currently merged data row in the merge block.

Syntax

[C#]
public int DataRowNumber { get; }
[Visual Basic]
Public ReadOnly Property DataRowNumber() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.DataRowCount Property

Gets an int value that indicates the total number of data rows.

Introduced: 15.0.

Syntax

[C#]
public int DataRowCount { get; }
[Visual Basic]
Public ReadOnly Property DataRowCount() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.MergeBlockName Property

Gets a string value that indicates current merge block name.

Introduced: 15.0.

Syntax

[C#]
public string MergeBlockName { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.BlockRowMergedEventArgs.MergedBlockRow Property

Gets or sets a byte[] array that contains the complete data of the merged block row. The used format is the internal TX Text Control Unicode format.

Syntax

[C#]
public byte[] MergedBlockRow { get; set; }
[Visual Basic]
Public Property MergedBlockRow() As Byte()

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ChartMergedEventArgs Class

The ChartMergedEventArgs class provides data for the ChartMerged event.

Introduced: 19.0.

Syntax

[C#]
public class ChartMergedEventArgs: EventArgs
[Visual Basic]
Public Class ChartMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
ChartFrame | Gets a ChartFrame object representing the merged chart in the document.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ChartMergedEventArgs.ChartFrame Property

Gets a ChartFrame object representing the merged chart in the document.

Syntax

[C#]
public DataVisualization.ChartFrame ChartFrame { get; }
[Visual Basic]
Public ReadOnly Property ChartFrame() As DataVisualization.ChartFrame

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs Class

The DataRowMergedEventArgs class provides data for the DataRowMerged event.

Introduced: 14.0.

Syntax

[C#]
public class DataRowMergedEventArgs: EventArgs
[Visual Basic]
Public Class DataRowMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
Cancel | Gets or sets a value indicating whether the current merge process should be canceled.
DataRow | Gets the current data row's content.
DataRowNumber | Gets an int value that indicates the currently merged data row.
MergedRow | Gets or sets a byte array that contains the complete data of the merged data row.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.Cancel Property

Gets or sets a value indicating whether the current merge process should be canceled.

Introduced: 19.0.

Syntax

[C#]
public bool Cancel { get; set; }
[Visual Basic]
Public Property Cancel() As Boolean

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.DataRow Property

Gets the current data row's content.

Introduced: 24.0.

Syntax

[C#]
public DocumentServer.DataSources.IDataRowAdapter DataRow { get; }
[Visual Basic]
Public ReadOnly Property DataRow() As DocumentServer.DataSources.IDataRowAdapter

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.DataRowNumber Property

Gets an int value that indicates the currently merged data row.

Syntax

[C#]
public int DataRowNumber { get; }
[Visual Basic]
Public ReadOnly Property DataRowNumber() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.DataRowMergedEventArgs.MergedRow Property

Gets or sets a byte array that contains the complete data of the merged data row. The used format is the internal TX Text Control Unicode format.

Introduced: 16.0.

Syntax

[C#]
public byte[] MergedRow { get; set; }
[Visual Basic]
Public Property MergedRow() As Byte()

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs Class

The FieldMergedEventArgs class provides data for the FieldMerged event.

Introduced: 15.0.

Syntax

[C#]
public class FieldMergedEventArgs: EventArgs
[Visual Basic]
Public Class FieldMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
DataRow | Gets the data row which is used to supply the current field with merge content.
MailMergeFieldAdapter | Gets or sets a MailMergeFieldAdapter that contains the already merged field.
MergeBlockName | If the merge field is part of a merge block, this property returns the name of the block.
Merged | Gets a bool value that indicates whether the current field has been merged successfully or not.
MergedField | Gets or sets a byte array that contains the complete data of the merged field.
NestingDepth | If the merge field is part of a merge block, this property returns the one-based nesting depth of the block.
TableCell | If the merge field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.DataRow Property

Gets the data row which is used to supply the current field with merge content.

Introduced: 24.0.

Syntax

[C#]
public DocumentServer.DataSources.IDataRowAdapter DataRow { get; }
[Visual Basic]
Public ReadOnly Property DataRow() As DocumentServer.DataSources.IDataRowAdapter

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MailMergeFieldAdapter Property

Gets or sets a MailMergeFieldAdapter that contains the already merged field. The complete field can be changed in this event.

Syntax

[C#]
public MailMergeFieldAdapter MailMergeField { get; set; }
[Visual Basic]
Public Property MailMergeField() As MailMergeFieldAdapter

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergeBlockName Property

If the merge field is part of a merge block, this property returns the name of the block. If not, an empty string is returned.

Introduced: 24.0.

Syntax

[C#]
public string MergeBlockName { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.Merged Property

Gets a bool value that indicates whether the current field has been merged successfully or not.

Syntax

[C#]
public bool Merged { get; }
[Visual Basic]
Public ReadOnly Property Merged() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.MergedField Property

Gets or sets a byte array that contains the complete data of the merged field. The used format is the internal TX Text Control Unicode format.

Introduced: 16.0.

Syntax

[C#]
public byte[] MergedField { get; set; }
[Visual Basic]
Public Property MergedField() As Byte()

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.NestingDepth Property

If the merge field is part of a merge block, this property returns the one-based nesting depth of the block. Otherwise 0 is returned.

Introduced: 24.0.

Syntax

[C#]
public int NestingDepth { get; }
[Visual Basic]
Public ReadOnly Property NestingDepth() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.FieldMergedEventArgs.TableCell Property

If the merge field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.

Introduced: 24.0.

Syntax

[C#]
public TXTextControl.TableCell TableCell { get; }
[Visual Basic]
Public ReadOnly Property TableCell() As TXTextControl.TableCell

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs Class

The ImageFieldMergedEventArgs class provides data for the ImageFieldMerged event.

Introduced: 16.0.

Syntax

[C#]
public class ImageFieldMergedEventArgs: EventArgs
[Visual Basic]
Public Class ImageFieldMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
FieldName | Gets the name of the merged field.
Filename | Gets the filename of the merged image.
Image | Gets or sets the image that has been merged into the field.
MergeBlockName | If the image field is part of a merge block, this property returns the name of the block.
Merged | Gets a bool value that indicates whether the current field has been merged successfully or not.
NestingDepth | If the image field is part of a merge block, this property returns the one-based nesting depth of the block.
TableCell | If the image field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.FieldName Property

Gets the name of the merged field.

Syntax

[C#]
public string FieldName { get; }
[Visual Basic]
Public ReadOnly Property FieldName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.Filename Property

Gets the filename of the merged image.

Syntax

[C#]
public string Filename { get; }
[Visual Basic]
Public ReadOnly Property Filename() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.Image Property

Gets or sets the image that has been merged into the field. This allows to subsequently change the merge result.

Syntax

[C#]
public TXTextControl.Image Image { get; set; }
[Visual Basic]
Public Property Image() As TXTextControl.Image

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.MergeBlockName Property

If the image field is part of a merge block, this property returns the name of the block. If not, an empty string is returned.

Introduced: 24.0.

Syntax

[C#]
public string MergeBlockName { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.Merged Property

Gets a bool value that indicates whether the current field has been merged successfully or not.

Syntax

[C#]
public bool Merged { get; }
[Visual Basic]
Public ReadOnly Property Merged() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.NestingDepth Property

If the image field is part of a merge block, this property returns the one-based nesting depth of the block. Otherwise 0 is returned.

Introduced: 24.0.

Syntax

[C#]
public int NestingDepth { get; }
[Visual Basic]
Public ReadOnly Property NestingDepth() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageFieldMergedEventArgs.TableCell Property

If the image field is inside of a table, this property returns the containing table cell as a TXTextControl.TableCell instance or null otherwise.

Introduced: 24.0.

Syntax

[C#]
public TXTextControl.TableCell TableCell { get; }
[Visual Basic]
Public ReadOnly Property TableCell() As TXTextControl.TableCell

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs Class

The ImageMergedEventArgs class provides data for the ImageMerged event.

Introduced: 20.0.

Syntax

[C#]
public class ImageMergedEventArgs: EventArgs
[Visual Basic]
Public Class ImageMergedEventArgs
  Inherits EventArgs

Properties

Property | Description
DataRow | Gets the data row which is used to supply the current image with merge content.
ID | Gets the ID of the merged image.
Image | Gets or sets the merged image.
MergeBlockName | If the image is part of a merge block, this property returns the name of the block.
Merged | Gets a boolean value that indicates whether the current image has been merged successfully or not.
Name | Gets the name of the merged image.
NestingDepth | If the image is part of a merge block, this property returns the one-based nesting depth of the block.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.DataRow Property

Gets the data row which is used to supply the current image with merge content.

Introduced: 24.0.

Syntax

[C#]
public DocumentServer.DataSources.IDataRowAdapter DataRow { get; }
[Visual Basic]
Public ReadOnly Property DataRow() As DocumentServer.DataSources.IDataRowAdapter

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.ID Property

Gets the ID of the merged image.

Syntax

[C#]
public int ID { get; }
[Visual Basic]
Public ReadOnly Property ID() As Integer

Limitations

Read only.

See Also

  • TXTextControl.FrameBase.ID Property
  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.Image Property

Gets or sets the merged image. This allows the merge result to be subsequently changed.

Syntax

[C#]
public System.Drawing.Image Image { get; set; }
[Visual Basic]
Public Property Image() As System.Drawing.Image

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.MergeBlockName Property

If the image is part of a merge block, this property returns the name of the block. If not, an empty string is returned.

Introduced: 24.0.

Syntax

[C#]
public string MergeBlockName { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.Merged Property

Gets a boolean value that indicates whether the current image has been merged successfully or not.

Introduced: 23.0.

Syntax

[C#]
public bool Merged { get; }
[Visual Basic]
Public ReadOnly Property Merged() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.Name Property

Gets the name of the merged image.

Syntax

[C#]
public string Name { get; }
[Visual Basic]
Public ReadOnly Property Name() As String

Limitations

Read only.

See Also

  • TXTextControl.FrameBase.Name Property
  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.ImageMergedEventArgs.NestingDepth Property

If the image is part of a merge block, this property returns the one-based nesting depth of the block. Otherwise 0 is returned.

Introduced: 24.0.

Syntax

[C#]
public int NestingDepth { get; }
[Visual Basic]
Public ReadOnly Property NestingDepth() As Integer

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs Class

The IncludeTextMergingEventArgs class provides data for the IncludeTextMerging event.

Introduced: 15.0.

Syntax

[C#]
public class IncludeTextMergingEventArgs: EventArgs
[Visual Basic]
Public Class IncludeTextMergingEventArgs
  Inherits EventArgs

Properties

Property | Description
Filename | Gets a string that indicates the file name of the IncludeText field to be merged.
IncludeTextDocument | Sets a byte[] array that contains the complete data of the IncludeText document.
IncludeTextField | Represents the currently merged INCLUDETEXT field.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs.Filename Property

Gets a string that indicates the file name of the IncludeText field to be merged.

Syntax

[C#]
public string Filename { get; }
[Visual Basic]
Public ReadOnly Property Filename() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs.IncludeTextDocument Property

Sets a byte[] array that contains the complete data of the IncludeText document. The used format is the internal TX Text Control Unicode format.

Syntax

[C#]
public int IncludeTextDocument { get; set; }
[Visual Basic]
Public Property IncludeTextDocument() As Integer

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MailMerge.IncludeTextMergingEventArgs.IncludeTextField Property

Represents the currently merged INCLUDETEXT field.

Introduced: 19.0.

Syntax

[C#]
public DocumentServer.Fields.IncludeText IncludeTextField { get; }
[Visual Basic]
Public ReadOnly Property IncludeTextField() As DocumentServer.Fields.IncludeText

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.MergeCanceledException Class

A MergeCanceledException is thrown through the Merge method when the current merge process was canceled through the DataRowMergedEventArgs.Cancel property.

Introduced: 19.0.

Syntax

[C#]
public class MergeCanceledException : Exception
[Visual Basic]
Public Class MergeCanceledException
  Inherits Exception

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources namespace

DocumentServer.DataSources Enumerations

TXTextControl.DocumentServer.DataSources.DataColumnInfo Class

TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection Class

TXTextControl.DocumentServer.DataSources.DataRelationInfo Class

TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection Class

TXTextControl.DocumentServer.DataSources.DataSourceManager Class

TXTextControl.DocumentServer.DataSources.DataTableInfo Class

TXTextControl.DocumentServer.DataSources.DataTableInfoCollection Class

TXTextControl.DocumentServer.DataSources.IDataRowAdapter Interface

TXTextControl.DocumentServer.DataSources.IDataTableAdapter Interface

TXTextControl.DocumentServer.DataSources.MergeBlockInfo Class

TXTextControl.DocumentServer.DataSources.MergeBlockSettings Class


DocumentServer.DataSources Enumerations

TXTextControl.DocumentServer.DataSources.BlockTemplateType Enumeration

TXTextControl.DocumentServer.DataSources.DialogResult Enumeration

TXTextControl.DocumentServer.DataSources.FieldDisplayMode Enumeration


TXTextControl.DocumentServer.DataSources.BlockTemplateType Enumeration

Determines the type of repeating merge block which is inserted when using the DataSourceManager.InsertMergeBlock method.

Member | Description
TableRow | Insert a table row based repeating merge block.
PlainParagraph | Insert a paragraph based repeating merge block.


TXTextControl.DocumentServer.DataSources.DialogResult Enumeration

Specifies identifiers to indicate the return value of a dialog box.

Member | Description
None | Nothing is returned from the dialog box. This means that the modal dialog continues running.
OK | The dialog box return value is OK (usually sent from a button labeled OK).
Cancel | The dialog box return value is Cancel (usually sent from a button labeled Cancel).


TXTextControl.DocumentServer.DataSources.FieldDisplayMode Enumeration

Specifies identifiers to indicate the field display mode.

Member | Description
ShowFieldText | The field text is displayed.
ShowFieldCodes | The field codes are displayed.


TXTextControl.DocumentServer.DataSources.DataColumnInfo Class

The DataColumnInfo class provides basic information about a table column in a data source.

Introduced: 24.0.

Syntax

[C#]
public class DataColumnInfo
[Visual Basic]
Public Class DataColumnInfo

Properties

Property | Description
DataType | Gets the data type of this table column.
FriendlyName | Gets a descriptive or friendly column name.
Name | Gets the column name.
Table | Gets an object of type DataTableInfo which represents the table this column belongs to.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataColumnInfo.DataType Property

Gets the data type of this table column.

Syntax

[C#]
public System.Type DataType { get; }
[Visual Basic]
Public ReadOnly Property DataType() As System.Type

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataColumnInfo.FriendlyName Property

Gets a descriptive or friendly column name. Returns the same value as the Name property if not set explicitly.

Syntax

[C#]
public string Name { get; }
[Visual Basic]
Public ReadOnly Property Name() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataColumnInfo.Name Property

Gets the column name.

Syntax

[C#]
public string Name { get; }
[Visual Basic]
Public ReadOnly Property Name() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataColumnInfo.Table Property

Gets an object of type DataTableInfo which represents the table this column belongs to.

Syntax

[C#]
public DocumentServer.DataSources.TableInfo Table { get; }
[Visual Basic]
Public ReadOnly Property Table() As DocumentServer.DataSources.TableInfo

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection Class

An instance of the DataColumnInfoCollection class contains all data columns of a data table in a data source represented through objects of the type DataColumnInfo. The DataColumnInfoCollection class implements the interface ICollection<DocumentServer.DataSources.DataColumnInfo> and therefore also IEnumerable<DocumentServer.DataSources.DataColumnInfo>. This collection class is meant to be read only. For this reason all ICollection members which would cause changes to the collection content (e. g. Add(), Clear() or Remove()) throw a NotSupportedException.

Introduced: 24.0.

Syntax

[C#]
public sealed class DataColumnInfoCollection : ICollection
[Visual Basic]
Public NotInheritable Class DataColumnInfoCollection
  Inherits ICollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read only.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
Item | Gets the DataColumnInfo instance with the specified 0-based index from the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator<DocumentServer.DataSources.DataColumnInfo> GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator(Of DocumentServer.DataSources.DataColumnInfo)

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection.Item Property

Gets the DataColumnInfo instance with the specified 0-based index from the collection. In C# this property is the indexer for the DataColumnInfoCollection class.

Syntax

[C#]
public DocumentServer.DataSources.DataColumnInfo this[int index] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(index As Integer) As DocumentServer.DataSources.DataColumnInfo
Parameter | Description
index | The 0-based index.

Return Value

The DataColumnInfo object at the given index in the collection.

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataColumnInfoCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only. Always returns true.

Syntax

[C#]
public bool IsReadOnly { get; }
[Visual Basic]
Public ReadOnly Property IsReadOnly() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfo Class

The DataRelationInfo class provides all necessary information about parent-child-relations between data tables.

Introduced: 24.0.

Syntax

[C#]
public class DataRelationInfo
[Visual Basic]
Public Class DataRelationInfo

Properties

Property | Description
ChildColumnName | Gets the name of the child column which is part of this data relation.
ChildTableName | Gets the name of the child table which is part of this data relation.
ParentColumnName | Gets the name of the parent column which is part of this data relation.
ParentTableName | Gets the name of the parent table which is part of this data relation.
RelationName | Gets the data relation name if one was defined.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfo.ChildColumnName Property

Gets the name of the child column which is part of this data relation.

Syntax

[C#]
public string ChildColumnName { get; }
[Visual Basic]
Public ReadOnly Property ChildColumnName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfo.ChildTableName Property

Gets the name of the child table which is part of this data relation.

Syntax

[C#]
public string ChildTableName { get; }
[Visual Basic]
Public ReadOnly Property ChildTableName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfo.ParentColumnName Property

Gets the name of the parent column which is part of this data relation.

Syntax

[C#]
public string ParentColumnName { get; }
[Visual Basic]
Public ReadOnly Property ParentColumnName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfo.ParentTableName Property

Gets the name of the parent table which is part of this data relation.

Syntax

[C#]
public string ParentTableName { get; }
[Visual Basic]
Public ReadOnly Property ParentTableName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfo.RelationName Property

Gets the data relation name if one was defined.

Syntax

[C#]
public string RelationName { get; }
[Visual Basic]
Public ReadOnly Property RelationName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection Class

An instance of the DataRelationInfoCollection class contains all data relations in a data source represented through objects of the type DataRelationInfo. The DataRelationInfoCollection class implements the interface ICollection<DataRelationInfo> and therefore also IEnumerable<DataRelationInfo>. This collection class is meant to be read only. For this reason all ICollection members which would cause changes to the collection content (e. g. Add(), Clear() or Remove()) throw a NotSupportedException.

Introduced: 24.0.

Syntax

[C#]
public sealed class DataRelationInfoCollection : ICollection
[Visual Basic]
Public NotInheritable Class DataRelationInfoCollection
  Inherits ICollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read only.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
Item | Gets the DataRelationInfo instance with the specified 0-based index from the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(DocumentServer.DataSources.DataRelationInfo[] array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(array As DocumentServer.DataSources.DataRelationInfo(), index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator<DocumentServer.DataSources.DataRelationInfo> GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator(Of DocumentServer.DataSources.DataRelationInfo)

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection.Item Property

Gets the DataRelationInfo instance with the specified 0-based index from the collection. In C# this property is the indexer for the DataRelationInfoCollection class.

Syntax

[C#]
public DocumentServer.DataSources.DataRelationInfo this[int index] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(index As Integer) As DocumentServer.DataSources.DataRelationInfo
Parameter | Description
index | The 0-based index.

Return Value

The DataRelationInfo object at the given index in the collection.

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataRelationInfoCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only. Always returns true.

Syntax

[C#]
public bool IsReadOnly { get; }
[Visual Basic]
Public ReadOnly Property IsReadOnly() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataSourceManager Class

The DataSourceManager class is designed for handling all existing kinds of data sources which can be used together with the MailMerge class. Use this class to determine which data tables, column names and data relations a data source contains and to insert merge block templates into documents.

Introduced: 24.0.

Syntax

[C#]
public class DataSourceManager
[Visual Basic]
Public Class DataSourceManager

Constructors

Constructor | Description
DataSourceManager | Initializes a new instance of the DataSourceManager class.

Properties

Property | Description
ConnectionString | Gets the connection string of the connection selected with the DatabaseConnectionDialog.
DataProviderName | Gets the name of the data provider selected with the DatabaseConnectionDialog.
DataRelations | Gets a DataRelationInfoCollection of DataRelationInfo objects which represent the data relations in the data source.
DataTables | Gets a DataTableInfoCollection of DataTableInfo objects which represent the data tables in the data source.
IsMergingPossible | Gets a value indicating whether all requirements are met and the method Merge can be called.
MasterDataTableInfo | Gets or sets a DataTableInfo object representing the table which is used as a master table when merging data into the document.
PossibleMergeBlockTables | Gets a DataTableInfoCollection of DataTableInfo objects representing the tables which can be used as merge blocks using the currently selected master table.
PossibleMergeFieldColumns | Gets a DataColumnInfoCollection of DataColumnInfo objects representing the table columns which can be used as merge fields using the currently selected master table.

Methods

Method | Description
InsertMergeBlock | Inserts a repeating merge block into a TextControl instance, a WPF.TextControl instance or a ServerTextControl instance at the current input position.
IsMergeBlock | Checks if a given SubTextPart is a merge block.
LoadAssembly | Loads an assembly file as a data source.
LoadDataSet | Loads a System.Data.DataSet object as a data source.
LoadDataSourceConfig | Overloaded. Loads an XML string or a file containing "report data source configuration" data.
LoadDataTable | Loads a System.Data.DataTable object as a data source.
LoadJson | Loads a JSON string containing an array of objects or a single object as a data source.
LoadObjects | Loads a collection implementing the interface IEnumerable as a data source and deduces the data tables, column names and data relations from the public properties and used classes of the first contained object using .NET reflection or, in case of the first contained object being a Dictionary with string keys, from the key names and value types.
LoadSingleObject | Loads a single object which is either a Dictionary with string keys or an object of an arbitrary type as a data source.
LoadXmlFile | Loads the contents of an XML file as a data source.
LoadXmlString | Loads XML data, given as a string, as a data source.
Merge | Merges a binary TX internal unicode format document with the currently loaded data source.
SaveDataSourceConfig | Overloaded. Saves an XML string or a file containing "report data source config" data.

Events

Event | Description
ConnectionStringChanged | Is fired when the contents of the ConnectionString property change.
DataProviderNameChanged | Is fired when the contents of the DataProviderName property change.
DataRelationsChanged | Is fired when the contents of the DataRelations property change.
DataTablesChanged | Is fired when the contents of the DataTables property change.
IsMergingPossibleChanged | Is fired when the value of the IsMergingPossible property changes.
MasterDataTableInfoChanged | Is fired when the contents of the MasterDataTableInfo property change.
PossibleMergeBlockTablesChanged | Is fired when the contents of the PossibleMergeBlockTables property change.
PossibleMergeFieldColumnsChanged | Is fired when the contents of the PossibleMergeFieldColumns property change.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager Constructor

Initializes a new instance of the DataSourceManager class.

Syntax

[C#]
public DataSourceManager();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.ConnectionString Property

Gets the connection string of the connection selected with the DatabaseConnectionDialog. If no data connection was selected, this property returns an empty string.

Syntax

[C#]
public string ConnectionString { get; }
[Visual Basic]
Public ReadOnly Property ConnectionString() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.ConnectionStringChanged Event

Is fired when the contents of the ConnectionString property change.

Syntax

[C#]
public event EventHandler ConnectionStringChanged;
[Visual Basic]
Public Event ConnectionStringChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataProviderName Property

Gets the name of the data provider selected with the DatabaseConnectionDialog. If no data connection was selected, this property returns an empty string.

Syntax

[C#]
public string DataProviderName { get; }
[Visual Basic]
Public ReadOnly Property DataProviderName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataProviderNameChanged Event

Is fired when the contents of the DataProviderName property change.

Syntax

[C#]
public event EventHandler DataProviderNameChanged;
[Visual Basic]
Public Event DataProviderNameChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataRelations Property

Gets a DataRelationInfoCollection of DataRelationInfo objects which represent the data relations in the data source.

Syntax

[C#]
public DocumentServer.DataSources.DataRelationInfoCollection DataRelations { get; }
[Visual Basic]
Public ReadOnly Property DataRelations() As DocumentServer.DataSources.DataRelationInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataRelationsChanged Event

Is fired when the contents of the DataRelations property change.

Syntax

[C#]
public event EventHandler DataRelationsChanged;
[Visual Basic]
Public Event DataRelationsChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataTables Property

Gets a DataTableInfoCollection of DataTableInfo objects which represent the data tables in the data source.

Syntax

[C#]
public DocumentServer.DataSources.DataTableInfoCollection DataTables { get; }
[Visual Basic]
Public ReadOnly Property DataTables() As DocumentServer.DataSources.DataTableInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.DataTablesChanged Event

Is fired when the contents of the DataTables property change.

Syntax

[C#]
public event EventHandler DataTablesChanged;
[Visual Basic]
Public Event DataTablesChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.InsertMergeBlock Method

Inserts a repeating merge block into a TextControl instance, a WPF.TextControl instance or a ServerTextControl instance at the current input position.

Syntax

[C#]
public void InsertMergeBlock(
   object textControl,
   DocumentServer.DataSources.MergeBlockInfo mergeBlockInfo,
   DocumentServer.DataSources.MergeBlockSettings settings);
[Visual Basic]
Public Sub InsertMergeBlock( _
   textControl As Object, _
   mergeBlockInfo As DocumentServer.DataSources.MergeBlockInfo)
   settings As DocumentServer.DataSources.MergeBlockSettings)
Parameter | Description
textControl | A TextControl instance, a WPF.TextControl instance or a ServerTextControl instance.
mergeBlockInfo | A MergeBlockInfo object which describes the merge block to insert into the TextControl instance.
settings | A MergeBlockSettings object which describes the settings of the merge block to insert into the TextControl instance.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.IsMergeBlock Method

Checks if a given SubTextPart is a merge block.

Syntax

[C#]
public static bool IsMergeBlock(SubTextPart subTextPart);
[Visual Basic]
Public Shared Function IsMergeBlock(subTextPart As SubTextPart) As Boolean
Parameter | Description
subTextPart | The SubTextPart to be checked.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.IsMergingPossible Property

Gets a value indicating whether all requirements are met and the method Merge can be called.

Syntax

[C#]
public bool IsMergingPossible { get; }
[Visual Basic]
Public ReadOnly Property IsMergingPossible() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.IsMergingPossibleChanged Event

Is fired when the value of the IsMergingPossible property changes.

Syntax

[C#]
public event EventHandler IsMergingPossibleChanged;
[Visual Basic]
Public Event IsMergingPossibleChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadAssembly Method

Loads an assembly file as a data source. Automatically deduces table and column names as well as data relations from the public properties of all public classes found in the assembly.

Syntax

[C#]
public void LoadAssembly(string fileName);
[Visual Basic]
Public Sub LoadAssembly(fileName As String)
Parameter | Description
fileName | The assembly file name.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadDataSet Method

Loads a System.Data.DataSet object as a data source.

Syntax

[C#]
public void LoadDataSet(System.Data.DataSet dataSet);
[Visual Basic]
Public Sub LoadDataSet(dataSet As System.Data.DataSet)
Parameter | Description
dataSet | The System.Data.DataSet object to use as a data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadDataSourceConfig Method

Loads an XML string or a file containing "report data source configuration" data. Data Source Configuration Files can only be used in Windows Forms applications. When calling this method from a WPF Application, an exception is thrown. For more information about data source configuration files see method SaveDataSourceConfig.

LoadDataSourceConfig()

Shows the system's default open file dialog where a configuration file can be selected.

[C#]
public void LoadDataSourceConfig();
[Visual Basic]
Public Sub LoadDataSourceConfig()

LoadDataSourceConfig(Object)

Shows the system's default open file dialog where a configuration file can be selected.

[C#]
public void LoadDataSourceConfig(object owner);
[Visual Basic]
Public Sub LoadDataSourceConfig(owner As Object)
Parameter | Description
owner | An object that represents the top-level window that will own the modal dialog box.

LoadDataSourceConfig(String)

Loads XML configuration data given as a string.

[C#]
public void LoadDataSourceConfig(string configData);
[Visual Basic]
Public Sub LoadDataSourceConfig(configData As String)
Parameter | Description
configData | A string containing XML configuration data.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadDataTable Method

Loads a System.Data.DataTable object as a data source.

Syntax

[C#]
public void LoadDataTable(System.Data.DataTable dataTable);
[Visual Basic]
Public Sub LoadDataTable(dataTable As System.Data.DataTable)
Parameter | Description
dataTable | The DataTable object to use as a data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadJson Method

Loads a JSON string containing an array of objects or a single object as a data source. Automatically deduces table and column names as well as data relations from property names and nested objects in the given single object or, in case of an array, the first object.

Syntax

[C#]
public void LoadJson(string json);
[Visual Basic]
Public Sub LoadJson(json As String)
Parameter | Description
json | A JSON string containing a single object or an array of objects.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadObjects Method

Loads a collection implementing the interface IEnumerable as a data source and deduces the data tables, column names and data relations from the public properties and used classes of the first contained object using .NET reflection or, in case of the first contained object being a Dictionary with string keys, from the key names and value types.

Syntax

[C#]
public void LoadObjects(System.Collections.IEnumerable objects);
[Visual Basic]
Public Sub LoadObjects(objects As System.Collections.IEnumerable)
Parameter | Description
objects | A collection implementing interface System.Collections.IEnumerable containing objects of any type. The existing tables, ccolumns and data relations are deduced from the the first contained object.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadSingleObject Method

Loads a single object which is either a Dictionary with string keys or an object of an arbitrary type as a data source. The data tables, column names are deduced either from the key names or the public property names and types using .NET reflection.

Syntax

[C#]
public void LoadSingleObject(object obj);
[Visual Basic]
Public Sub LoadSingleObject(obj As Object)
Parameter | Description
obj | A single object which is either a Dictionary with string keys or an object of an arbitrary type as a data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadXmlFile Method

Loads the contents of an XML file as a data source.

Syntax

[C#]
public void LoadXmlFile(string fileName);
[Visual Basic]
Public Sub LoadXmlFile(fileName As String)
Parameter | Description
fileName | The file name.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.LoadXmlString Method

Loads XML data, given as a string, as a data source.

Syntax

[C#]
public void LoadXmlString(string xml);
[Visual Basic]
Public Sub LoadXmlString(xml As String)
Parameter | Description
xml | A string containing XML data.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.MasterDataTableInfo Property

Gets or sets a DataTableInfo object representing the table which is used as a master table when merging data into the document. Changing the master table with this property influences the return values of the PossibleMergeBlockTables and the PossibleMergeFieldColumns properties.

Syntax

[C#]
public DocumentServer.DataSources.DataTableInfo MasterDataTableInfo { get; set; }
[Visual Basic]
Public Property MasterDataTableInfo() As DocumentServer.DataSources.DataTableInfo

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.MasterDataTableInfoChanged Event

Is fired when the contents of the MasterDataTableInfo property change.

Syntax

[C#]
public event EventHandler MasterDataTableInfoChanged;
[Visual Basic]
Public Event MasterDataTableInfoChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.Merge Method

Merges a binary TX internal unicode format document with the currently loaded data source.

Syntax

[C#]
public IList<byte[]> Merge(byte[] template, int maxDocuments, object textControl);
[Visual Basic]
Public Function Merge(template As Byte(), maxDocuments As Integer, textControl As Object) As IList(Of Byte())
Parameter | Description
template | A binary TX internal unicode format document into which the data is merged.
maxDocuments | Specifies the maximum number of merged documents.
textControl | A TextControl instance needed for licensing purposes. Must be of one of the following types: ServerTextControl, TextControl or WPF.TextControl.

Return Value

An IList of byte arrays containing one binary TX internal unicode format document for each merged data row.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.PossibleMergeBlockTables Property

Gets a DataTableInfoCollection of DataTableInfo objects representing the tables which can be used as merge blocks using the currently selected master table.

Syntax

[C#]
public DocumentServer.DataSources.DataTableInfoCollection PossibleMergeBlockTables { get; }
[Visual Basic]
Public ReadOnly Property PossibleMergeBlockTables() As DocumentServer.DataSources.DataTableInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.PossibleMergeBlockTablesChanged Event

Is fired when the contents of the PossibleMergeBlockTables property change.

Syntax

[C#]
public event EventHandler PossibleMergeBlockTablesChanged;
[Visual Basic]
Public Event PossibleMergeBlockTablesChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.PossibleMergeFieldColumns Property

Gets a DataColumnInfoCollection of DataColumnInfo objects representing the table columns which can be used as merge fields using the currently selected master table.

Syntax

[C#]
public DocumentServer.DataSources.DataColumnInfoCollection PossibleMergeFieldColumns { get; }
[Visual Basic]
Public ReadOnly Property PossibleMergeFieldColumns() As DocumentServer.DataSources.DataColumnInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.PossibleMergeFieldColumnsChanged Event

Is fired when the contents of the PossibleMergeFieldColumns property change.

Syntax

[C#]
public event EventHandler PossibleMergeFieldColumnsChanged;
[Visual Basic]
Public Event PossibleMergeFieldColumnsChanged As EventHandler

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataSourceManager.SaveDataSourceConfig Method

Saves an XML string or a file containing "report data source config" data. Can only be called when a data provider based data source was loaded via the DatabaseConnectionDialog. The XML string contains information about the data provider, the connection string, the selected master table and existing data relations. Data Source Configuration Files can only be used in Windows Forms applications. When calling this method from a WPF Application, an exception is thrown.

SaveDataSourceConfig()

Shows the system's default save file dialog where a file name and location can be selected.

[C#]
public void SaveDataSourceConfig();
[Visual Basic]
Public Sub SaveDataSourceConfig()

SaveDataSourceConfig(Object)

Shows the system's default save file dialog where a file name and location can be selected.

[C#]
public void SaveDataSourceConfig(object owner);
[Visual Basic]
Public Sub SaveDataSourceConfig(owner As Object)
Parameter | Description
owner | An object that represents the top-level window that will own the modal dialog box.

SaveDataSourceConfig(String)

Saves the configuration data into a given string.

[C#]
public void SaveDataSourceConfig(out string configData);
[Visual Basic]
Public Sub SaveDataSourceConfig(ByRef configData As String)
Parameter | Description
configData | A string into which the config file content will be written when the method is called.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfo Class

The DataTableInfo class provides basic information about a data table in a data source.

Introduced: 24.0.

Syntax

[C#]
public class DataTableInfo
[Visual Basic]
Public Class DataTableInfo

Properties

Property | Description
ChildRelations | Gets a DataRelationInfoCollection representing the parent-child-relationships this table has with other data tables.
ChildTables | Gets a DataTableInfoCollection representing the child-tables this table has.
Columns | Gets a DataColumnInfoCollection representing the columns of this data table.
TableName | Gets the table name.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfo.ChildRelations Property

Gets a DataRelationInfoCollection representing the parent-child-relationships this table has with other data tables. Is empty in case of the data source being an object, an IEnumerable or an assembly.

Syntax

[C#]
public DocumentServer.DataSources.DataRelationInfoCollection ChildRelations { get; }
[Visual Basic]
Public ReadOnly Property ChildRelations() As DocumentServer.DataSources.DataRelationInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfo.ChildTables Property

Gets a DataTableInfoCollection representing the child-tables this table has. (Either according to the known data relations or, in case of an assembly or an object as a data source, to the properties of the involved classes)

Syntax

[C#]
public DocumentServer.DataSources.DataTableInfoCollection ChildTables { get; }
[Visual Basic]
Public ReadOnly Property ChildTables() As DocumentServer.DataSources.DataTableInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfo.Columns Property

Gets a DataColumnInfoCollection representing the columns of this data table.

Syntax

[C#]
public DocumentServer.DataSources.DataColumnInfoCollection Columns { get; }
[Visual Basic]
Public ReadOnly Property Columns() As DocumentServer.DataSources.DataColumnInfoCollection

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfo.TableName Property

Gets the table name.

Syntax

[C#]
public string TableName { get; }
[Visual Basic]
Public ReadOnly Property TableName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection Class

An instance of the DataTableInfoCollection class contains all data tables in a data source represented through objects of the type DataTableInfo. The DataTableInfoCollection class implements the interface ICollection<DocumentServer.DataSources.DataTableInfo> and therefore also IEnumerable<DocumentServer.DataSources.DataTableInfo>. This collection class is meant to be read only. For this reason all ICollection members which would cause changes to the collection content (e. g. Add(), Clear() or Remove()) throw a NotSupportedException.

Introduced: 24.0.

Syntax

[C#]
public sealed class DataTableInfoCollection : ICollection
[Visual Basic]
Public NotInheritable Class DataTableInfoCollection
  Inherits ICollection

Properties

Property | Description
Count | Gets the number of elements contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read only.

Methods

Method | Description
CopyTo | Copies the elements of the collection to an array, starting at a particular index.
GetEnumerator | Returns an enumerator that can be used to iterate through the collection.
Item | Overloaded. Gets a DataTableInfo instance from the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection.CopyTo Method

Copies the elements of the collection to an array, starting at a particular index.

Syntax

[C#]
override public void CopyTo(DocumentServer.DataSources.DataTableInfo[] array, int index);
[Visual Basic]
Public Overloads Overrides Sub CopyTo(array As DocumentServer.DataSources.DataTableInfo(), index As Integer)
Parameter | Description
array | Specifies the array to copy to.
index | Specifies the index of the destination array at which to begin copying.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection.Count Property

Gets the number of elements contained in the collection.

Syntax

[C#]
public int Count { get; }
[Visual Basic]
Public ReadOnly Property Count() As Integer

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the collection.

Syntax

[C#]
public IEnumerator<DocumentServer.DataSources.DataTableInfo> GetEnumerator();
[Visual Basic]
Public Function GetEnumerator() As IEnumerator(Of DocumentServer.DataSources.DataTableInfo)

Return Value

The return value is an IEnumerator that represents the collection.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection.Item Property

Gets a DataTableInfo instance from the collection. In C# this property is the indexer for the DataTableInfoCollection class.

Item()

Gets the DataTableInfo instance with the specified 0-based index from the collection.

[C#]
public DocumentServer.DataSources.DataTableInfo this[int index] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(index As Integer) As DocumentServer.DataSources.DataTableInfo

Item()

Gets the DataTableInfo instance with the specified name from the collection. Returns null if the given name does not exist.

[C#]
public DocumentServer.DataSources.DataTableInfo this[string name] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(name As String) As DocumentServer.DataSources.DataTableInfo

Return Value

The DataTableInfo object at the given index / with the given name in the collection.

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.DataTableInfoCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only. Always returns true.

Syntax

[C#]
public bool IsReadOnly { get; }
[Visual Basic]
Public ReadOnly Property IsReadOnly() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.DocumentServer.DataSources.IDataRowAdapter Interface

The IDataRowAdapter interface contains properties and methods implemented by data row instances used in the BlockMerging event.

Introduced: 23.0.

Syntax

[C#]
public interface IDataRowAdapter
[Visual Basic]
Public Interface IDataRowAdapter

Properties

Property | Description
Indexer | The indexer of the IDataRowAdapter interface returns the content of the row's column with the given name.
Table | Gets the table the data row belongs to as an instance of a class implementing the IDataTableAdapter interface.

Methods

Method | Description
GetChildRows | Returns the data of a child relation with a given name as an array of IDataRowAdapter instances.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.Indexer

The indexer of the IDataRowAdapter interface returns the content of the row's column with the given name.

Syntax

[C#]
object this[string key] { get; }
[Visual Basic]
Default Public ReadOnly Property Item(ByVal key as String) As Object

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataRowAdapter.Table Property

Gets the table the data row belongs to as an instance of a class implementing the IDataTableAdapter interface.

Syntax

[C#]
IDataTableAdapter Table { get; }
[Visual Basic]
ReadOnly Property Table() As IDataTableAdapter

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataRowAdapter.GetChildRows Method

Returns the data of a child relation with a given name as an array of IDataRowAdapter instances.

Syntax

[C#]
IDataRowAdapter[] GetChildRows(string childTableName);
[Visual Basic]
GetChildRows(ByVal childTableName As String) As IDataRowAdapter()
Parameter | Description
childTableName | The name of the child table / the child relation.

Return Value

An array of data rows if the relation with the given name exists or null.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataTableAdapter Interface

The IDataTableAdapter interface contains properties and methods implemented by data table instances used in the BlockMerging event.

Introduced: 23.0.

Syntax

[C#]
public interface IDataTableAdapter
[Visual Basic]
Public Interface IDataTableAdapter

Properties

Property | Description
ChildTableNames | Returns the names of the child relations in this table as a string array.
ColumnNames | Returns the table's column names as a string array.
Rows | Returns the table's data as an array of objects implementing the IDataRowAdapter interface.
TableName | Returns the name of the table.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataTableAdapter.TableName Property

Returns the name of the table.

Syntax

[C#]
string TableName { get; }
[Visual Basic]
ReadOnly Property TableName() As String

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataTableAdapter.ColumnNames Property

Returns the table's column names as a string array.

Syntax

[C#]
string[] ColunNames { get; }
[Visual Basic]
ReadOnly Property ColumnNames() As String()

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataTableAdapter.Rows Property

Returns the table's data as an array of objects implementing the IDataRowAdapter interface.

Syntax

[C#]
IDataRowAdapter[] Rows { get; }
[Visual Basic]
ReadOnly Property Rows() As IDataRowAdapter()

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.IDataTableAdapter.ChildTableNames Property

Returns the names of the child relations in this table as a string array.

Syntax

[C#]
string[] ChildTableNames { get; }
[Visual Basic]
ReadOnly Property ChildTableNames() As String()

Limitations

Read only.

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.DataSources.MergeBlockInfo Class

The MergeBlockInfo class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.

Introduced: 24.0.

Syntax

[C#]
public class MergeBlockInfo
[Visual Basic]
Public Class MergeBlockInfo

Constructors

Constructor | Description
MergeBlockInfo | Initializes a new instance of the MergeBlockInfo class and sets the table name.

Properties

Property | Description
ChildBlocks | Gets or sets the list of merge blocks nested inside this merge block.
ColumnNames | Gets or sets the list of data column names which represent the merge fields this merge block consists of.
TableName | Gets the table name of this merge block.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockInfo Constructor

Initializes a new instance of the MergeBlockInfo class and sets the table name.

Syntax

[C#]
public MergeBlockInfo(string tableName);
[Visual Basic]
Public Sub New(tableName As String)
Parameter | Description
tableName | The name of the table which is the data source for this merge block.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockInfo.ChildBlocks Property

Gets or sets the list of merge blocks nested inside this merge block.

Syntax

[C#]
public List<DocumentServer.DataSources.MergeBlockInfo> ChildBlocks { get; set; }
[Visual Basic]
Public Property ChildBlocks() As List(Of DocumentServer.DataSources.MergeBlockInfo)

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockInfo.ColumnNames Property

Gets or sets the list of data column names which represent the merge fields this merge block consists of.

Syntax

[C#]
public List<string> ColumnNames { get; set; }
[Visual Basic]
Public Property ColumnNames() As List(Of String)

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockInfo.TableName Property

Gets the table name of this merge block.

Syntax

[C#]
public string TableName { get; }
[Visual Basic]
Public ReadOnly Property TableName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockSettings Class

The MergeBlockSettings class is used to insert a table or paragraph based repeating merge block into a TextControl instance using the DataSourceManager.InsertMergeBlock method.

Introduced: 24.0.

Syntax

[C#]
public class MergeBlockSettings
[Visual Basic]
Public Class MergeBlockSettings

Constructors

Constructor | Description
MergeBlockSettings | Overloaded. Initializes a new instance of the MergeBlockSettings class.

Properties

Property | Description
BlockTemplateType | Gets or sets a value of type BlockTemplateType which specifies the type of the inserted repeating block.
CreateHeaderRow | If this property is true and property BlockTemplateType is set to BlockTemplateType.TableRow, a table header row is automatically generated.
FieldDisplayMode | Gets or sets a value of type FieldDisplayMode which specifies the content display mode of the inserted fields.
HighlightColor | Specifies the color the inserted merge block is highlighted with if the input position is inside the block.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.DataSources.MergeBlockSettings Constructor

Initializes a new instance of the MergeBlockSettings class.

MergeBlockSettings()

Initializes a new instance of the MergeBlockSettings class.

[C#]
public MergeBlockSettings();
[Visual Basic]
Public Sub New()

MergeBlockSettings(BlockTemplateType)

Initializes a new instance of the MergeBlockSettings class.

[C#]
public MergeBlockSettings(DocumentServer.DataSources.BlockTemplateType blockTemplateType);
[Visual Basic]
Public Sub New(blockTemplateType As DocumentServer.DataSources.BlockTemplateType)
Parameter | Description
blockTemplateType | A value of type BlockTemplateType specifying the block type. (paragraph or table row based)

MergeBlockSettings(BlockTemplateType, Boolean)

Initializes a new instance of the MergeBlockSettings class.

[C#]
public MergeBlockSettings(
   DocumentServer.DataSources.BlockTemplateType blockTemplateType,
   bool createHeaderRow);
[Visual Basic]
Public Sub New( _
   blockTemplateType As DocumentServer.DataSources.BlockTemplateType, _
   createHeaderRow As Boolean)
Parameter | Description
blockTemplateType | A value of type BlockTemplateType specifying the block type. (paragraph or table row based)
createHeaderRow | If parameter blockTemplateType is set to BlockTemplateType.TableRow and this parameter is set to true, a table header row is automatically generated.

MergeBlockSettings(BlockTemplateType, Boolean, Color, FieldDisplayMode)

Initializes a new instance of the MergeBlockSettings class.

[C#]
public MergeBlockSettings(
   DocumentServer.DataSources.BlockTemplateType blockTemplateType,
   bool createHeaderRow,
   System.Drawing.Color highlightColor,
   DocumentServer.DataSources.FieldDisplayMode fieldDisplayMode);
[Visual Basic]
Public Sub New( _
   blockTemplateType As DocumentServer.DataSources.BlockTemplateType, _
   createHeaderRow As Boolean, _
   highlightColor As System.Drawing.Color, _
   fieldDisplayMode As DocumentServer.DataSources.FieldDisplayMode)
Parameter | Description
blockTemplateType | A value of type BlockTemplateType specifying the block type. (paragraph or table row based)
createHeaderRow | If parameter blockTemplateType is set to BlockTemplateType.TableRow and this parameter is set to true, a table header row is automatically generated.
highlightColor | The color the merge block is highlighted with if the input position is inside the block boundaries.
fieldDisplayMode | A value of type FieldDisplayMode which specifies if field text or field codes are shown.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.BlockTemplateType Property

Gets or sets a value of type BlockTemplateType which specifies the type of the inserted repeating block. (paragraph based or table row based)

Syntax

[C#]
public DocumentServer.DataSources.BlockTemplateType BlockTemplateType { get; set; }
[Visual Basic]
Public Property BlockTemplateType() As DocumentServer.DataSources.BlockTemplateType

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.CreateHeaderRow Property

If this property is true and property BlockTemplateType is set to BlockTemplateType.TableRow, a table header row is automatically generated.

Syntax

[C#]
public bool CreateHeaderRow { get; set; }
[Visual Basic]
Public Property CreateHeaderRow() As Boolean

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.HighlightColor Property

Specifies the color the inserted merge block is highlighted with if the input position is inside the block. The alpha value of the provided color is used.

Syntax

[C#]
public System.Drawing.Color HighlightColor { get; set; }
[Visual Basic]
Public Property HighlightColor() As System.Drawing.Color

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.FieldDisplayMode Property

Gets or sets a value of type FieldDisplayMode which specifies the content display mode of the inserted fields. Either the field text or the field codes can be displayed.

Syntax

[C#]
public DocumentServer.DataSources.FieldDisplayMode FieldDisplayMode { get; set; }
[Visual Basic]
Public Property FieldDisplayMode() As DocumentServer.DataSources.FieldDisplayMode

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting


TXTextControl.DocumentServer.Fields namespace

TXTextControl.DocumentServer.Fields.CheckBoxContentControl Class

TXTextControl.DocumentServer.Fields.ComboBoxContentControl Class

TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter Class

TXTextControl.DocumentServer.Fields.DateContentControl Class

TXTextControl.DocumentServer.Fields.DateField Class

TXTextControl.DocumentServer.Fields.DropDownListContentControl Class

TXTextControl.DocumentServer.Fields.FieldAdapter Class

TXTextControl.DocumentServer.Fields.FormCheckBox Class

TXTextControl.DocumentServer.Fields.FormDropDown Class

TXTextControl.DocumentServer.Fields.FormFieldAdapter Class

TXTextControl.DocumentServer.Fields.FormText Class

TXTextControl.DocumentServer.Fields.IfField Class

TXTextControl.DocumentServer.Fields.IncludeText Class

TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter Class

TXTextControl.DocumentServer.Fields.MergeField Class

TXTextControl.DocumentServer.Fields.NextField Class

TXTextControl.DocumentServer.Fields.NextIfField Class

TXTextControl.DocumentServer.Fields.PlainTextContentControl Class

TXTextControl.DocumentServer.Fields.RichTextContentControl Class


TXTextControl.DocumentServer.Fields.CheckBoxContentControl Class

The CheckBoxContentControl implements the MS Word specific check box content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class CheckBoxContentControl : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class CheckBoxContentControl
  Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
CheckBoxContentControl | Overloaded. Initializes a new instance of the CheckBoxContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Checked | Specifies whether the field is checked or not.
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.CheckBoxContentControl Constructor

Initializes a new instance of the CheckBoxContentControl class.

CheckBoxContentControl()

Initializes complete new instance of the CheckBoxContentControl class without a connection to an existing ApplicationField.

[C#]
public CheckBoxContentControl()
[Visual Basic]
Public Sub New()

CheckBoxContentControl(ApplicationField)

Initializes a new instance of the CheckBoxContentControl class with a connection to an existing ApplicationField.

[C#]
public CheckBoxContentControl(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.CheckBoxContentControl.Checked Property

Specifies whether the field is checked or not.

Syntax

[C#]
public bool Checked
[Visual Basic]
Public Property Checked() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ComboBoxContentControl Class

The ComboBoxContentControl implements the MS Word specific combo box content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class ComboBoxContentControl  : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class ComboBoxContentControl
  Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
ComboBoxContentControl | Overloaded. Initializes a new instance of the ComboBoxContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ListItems | Gets or sets the list items of the combo box content control field.
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ComboBoxContentControl Constructor

Initializes a new instance of the ComboBoxContentControl class.

ComboBoxContentControl()

Initializes complete new instance of the ComboBoxContentControl class without a connection to an existing ApplicationField.

[C#]
public ComboBoxContentControl()
[Visual Basic]
Public Sub New()

ComboBoxContentControl(ApplicationField)

Initializes a new instance of the ComboBoxContentControl class with a connection to an existing ApplicationField.

[C#]
public ComboBoxContentControl (ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ComboBoxContentControl.ListItems Property

Gets or sets the list items of the combo box content control field.

Syntax

[C#]
public List<ComboBoxListItem> Checked
[Visual Basic]
Public Property ListItems() As List(Of ComboBoxListItem)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter Class

The abstract ContentControlFieldAdapter class is the base class of all Microsoft Word content control field adapter classes. It implements general features like the adapted ApplicationField or the specific content control type name. These special fields can be only used in combination with the ApplicationField class.

Introduced: 21.0.

Syntax

[C#]
public abstract class ContentControlFieldAdapter : FieldAdapter
[Visual Basic]
Public MustInherit Class ContentControlFieldAdaper
  Inherits FieldAdapter

Constructors

Constructor | Description
ContentControlFieldAdapter | Overloaded. Initializes a new instance of the ContentControlFieldAdapter class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FieldAdapter.)
ContentDeletable | Specifies whether the content of the content control field should be deletable or not.
ContentEditable | Specifies whether the content of the content control field should be editable or not.
Id | Gets or sets the content control's id.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field.
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Tag | Gets or sets the content control's tag.
Title | Gets or sets the content control's title.
Type | Gets or sets the type of the content control field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter Constructor

Initializes a new instance of the ContentControlFieldAdapter class.

ContentControlFieldAdapter()

Initializes a complete new instance of the ContentControlFieldAdapter class without a connection to an existing ApplicationField.

[C#]
public ContentControlFieldAdapter()
[Visual Basic]
public Sub New

ContentControlFieldAdapter(ApplicationField)

Initializes a new instance of the ContentControlFieldAdapter class with a connection to an existing ApplicationField.

[C#]
public ContentControlFieldAdapter(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.Title Property

Gets or sets the content control's title.

Syntax

[C#]
public string Title { get; set; }
[Visual Basic]
Public Property Title() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.Tag Property

Gets or sets the content control's tag.

Syntax

[C#]
public string Tag { get; set; }
[Visual Basic]
Public Property Tag() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.Id Property

Gets or sets the content control's id.

Syntax

[C#]
public long Id { get; set; }
[Visual Basic]
Public Property Id() As Long

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.ContentDeletable Property

Specifies whether the content of the content control field should be deletable or not.

Syntax

[C#]
public bool ContentDeletable { get; set; }
[Visual Basic]
Public Property ContentDeletable() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.ContentEditable Property

Specifies whether the content of the content control field should be editable or not.

Syntax

[C#]
public bool ContentEditable { get; set; }
[Visual Basic]
Public Property ContentEditable() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.Type Property

Gets or sets the type of the content control field.

Syntax

[C#]
public string Type { get; set; }
[Visual Basic]
Public Property Type() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.ContentControlFieldAdapter.Placeholder Property

Gets or sets the placeholder field part of the content control field.

Syntax

[C#]
public List<DocPart> Placeholder { get; set; }
[Visual Basic]
Public Property Placeholder() As List(Of DocPart)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl Class

The DateContentControl implements the MS Word specific date content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class DateContentControl : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class DateContentControl
  Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
DateContentControl | Overloaded. Initializes a new instance of the DateContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Calendar | Gets or sets the calendar type of the content control field.
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Date | Gets or sets the date of the content control field.
DateFormat | Gets or sets the date format of the content control field.
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
LanguageID | Gets or sets the language ID of the content control field.
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
StoreMappedDataAs | Gets or sets the translation that shall be performed on the displayed date in a date picker structured document tag.
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl Constructor

Initializes a new instance of the DateContentControl class.

DateContentControl()

Initializes complete new instance of the DateContentControl class without a connection to an existing ApplicationField.

[C#]
public DateContentControl()
[Visual Basic]
Public Sub New()

DateContentControl(ApplicationField)

Initializes a new instance of the DateContentControl class with a connection to an existing ApplicationField.

[C#]
public DateContentControl(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.Date Property

Gets or sets the date of the content control field.

Syntax

[C#]
public DateTime Date
[Visual Basic]
Public Property Date() As DateTime

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.DateFormat Property

Gets or sets the date format of the content control field.

Syntax

[C#]
public string DateFormat
[Visual Basic]
Public Property DateFormat() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.LanguageID Property

Gets or sets the language ID of the content control field.

Syntax

[C#]
public string LanguageID
[Visual Basic]
Public Property LanguageID() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.StoreMappedDataAs Property

Gets or sets the translation that shall be performed on the displayed date in a date picker structured document tag.

Syntax

[C#]
public string StoreMappedDataAs
[Visual Basic]
Public Property StoreMappedDataAs() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.Calendar Property

Gets or sets the calendar type of the content control field.

Syntax

[C#]
public string Calendar
[Visual Basic]
Public Property Calendar() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateField Class

The DateField implements the MS Word specific DATEFIELD field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class DateField : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class DateField
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
DateField | Overloaded. Initializes a new instance of the DateField class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Date | Sets the date of the field.
Format | Gets and sets the format of the field.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Text | Gets and sets the displayed text of the field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateField Constructor

Initializes a new instance of the DateField class.

DateField()

Initializes a complete new instance of the DateField class without a connection to an existing ApplicationField.

[C#]
public DateField()
[Visual Basic]
Public Sub New()

DateField(ApplicationField)

Initializes new instance of the DateField class with a connection to an existing ApplicationField.

[C#]
public DateField(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateField.Text Property

Gets and sets the displayed text of the field.

Syntax

[C#]
public string Text
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateField.Date Property

Sets the date of the field.

Syntax

[C#]
public DateTime Date { set; }
[Visual Basic]
Public WriteOnly Property Date() As DateTime

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateField.Format Property

Gets and sets the format of the field. It must be a standard DateTime format string of the .NET Framework.

Syntax

[C#]
public string Format
[Visual Basic]
Public Property Format() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DropDownListContentControl Class

The DropDownListContentControl implements the MS Word specific drop down list content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class DropDownListContentControl : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class DropDownListContentControl
  Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
DropDownListContentControl | Overloaded. Initializes a new instance of the DropDownListContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
DocumentServer.Fields.DateContentControl.ListItems | Gets or sets the list items of the content control field.
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DropDownListContentControl Constructor

Initializes a new instance of the DropDownListContentControl class.

DropDownListContentControl()

Initializes complete new instance of the DropDownListContentControl class without a connection to an existing ApplicationField.

[C#]
public DropDownListContentControl()
[Visual Basic]
Public Sub New()

DropDownListContentControl(ApplicationField)

Initializes a new instance of the DropDownListContentControl class with a connection to an existing ApplicationField.

[C#]
public DropDownListContentControl(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.DateContentControl.ListItems Property

Gets or sets the list items of the content control field.

Syntax

[C#]
public List<DropDownListItem> ListItems
[Visual Basic]
Public Property ListItems() As List(Of DropDownListItem)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter Class

The abstract FieldAdapter class is the base class of all special DocumentServer field adapters. It implements general features like the adapted ApplicationField or the specific TypeName. These special fields can be only used in combination with the ApplicationField class.

Introduced: 15.0.

Syntax

[C#]
public abstract class FieldAdapter
[Visual Basic]
Public MustInherit Class FieldAdapter

Constructors

Constructor | Description
FieldAdapter | Overloaded. Initializes a new instance of the FieldAdapter class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field.
ID | Gets the ID of the specific field through its adapter.
Length | Gets the number of characters in a text field through its adapter.
Start | Gets the first character position (one-based) of the field through its adapter.
TypeName | Gets the field's type name of the specific field through its adapter.

Methods

Method | Description
ShowDialog | Overloaded. Opens the specific field options dialog box.

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.FieldAdapter.TYPE_NAME Field

Represents the name of the respective field type. Every subclass of FieldAdapter overwrites this with its respective type name.

Syntax

[C#]
const string TYPE_NAME;
[Visual Basic]
Public TYPE_NAME As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter Constructor

Initializes a new instance of the FieldAdapter class.

FieldAdapter()

Initializes a complete new instance of the FieldAdapter class without a connection to an existing ApplicationField.

[C#]
public FieldAdapter()
[Visual Basic]
public Sub New

FieldAdapter(ApplicationField)

Initializes a new instance of the FieldAdapter class with a connection to an existing ApplicationField.

[C#]
public FieldAdapter(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.ApplicationField Property

Gets the adapted ApplicationField of the field. Each special field acts like an adapter for the specific ApplicationField.

Syntax

[C#]
public ApplicationField ApplicationField{ get; protected set; }
[Visual Basic]
Public ReadOnly Property ApplicationField() As ApplicationField

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.ID Property

Gets the ID of the specific field through its adapter.

Syntax

[C#]
public int ID
[Visual Basic]
Public Property ID() As Integer

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.TypeName Property

Gets the field's type name of the specific field through its adapter. For example for the type name of a Microsoft Word MergeField is MERGEFIELD. If the type name of the field is changed, its parameters must also be changed.

Syntax

[C#]
public string TypeName
[Visual Basic]
Public Property TypeName() As String

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.Start Property

Gets the first character position (one-based) of the field through its adapter.

Syntax

[C#]
public virtual int Start
[Visual Basic]
Public Overridable ReadOnly Property Start() As Integer

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.Length Property

Gets the number of characters in a text field through its adapter.

Syntax

[C#]
public virtual int Length
[Visual Basic]
Public Overridable ReadOnly Property Length() As Integer

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FieldAdapter.ShowDialog Method

Opens the specific field options dialog box.

ShowDialog()

Opens the specific field options dialog box with LTR flow direction.

[C#]
public DialogResult ShowDialog()
[Visual Basic]
Public Function ShowDialog() As DialogResult

ShowDialog(Boolean)

Opens the specific field options dialog box with the flow direction (RTL or LTR) set according to the boolean parameter value.

[C#]
public DialogResult ShowDialog(bool rightToLeft);
[Visual Basic]
Public Function ShowDialog(ByVal rightToLeft As Boolean) As DialogResult
Parameter | Description
rightToLeft | Sets the dialog layout flow direction. True sets the layout to RTL, false sets the layout to LTR.

ShowDialog(Object)

Opens the specific field options dialog box with a specified owner window.

[C#]
public DialogResult ShowDialog(object owner);
[Visual Basic]
Public Function ShowDialog(ByVal owner As Object) As DialogResult
Parameter | Description
owner | Sets the dialog's owner window. For WPF dialogs this must be an object of type System.Windows.Window. For Windows Forms dialogs this must be an object implementing the interface System.Windows.Forms.IWin32Window (e. g. a Form).

ShowDialog(Object, Boolean)

Opens the specific field options dialog box with an owner window and a flow direction.

[C#]
public DialogResult ShowDialog(object owner, bool rightToLeft);
[Visual Basic]
Public Function ShowDialog(ByVal owner As Object, ByVal rightToLeft As Boolean) As DialogResult
Parameter | Description
owner | Sets the dialog's owner window. For WPF dialogs this must be an object of type System.Windows.Window. For Windows Forms dialogs this must be an object implementing the interface System.Windows.Forms.IWin32Window (e. g. a Form).
rightToLeft | Sets the dialog layout flow direction. True sets the layout to RTL, false sets the layout to LTR.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormCheckBox Class

The FormText implements the MS Word specific FORMCHECKBOX field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class FormCheckBox : FormFieldAdapter
[Visual Basic]
Public NotInheritable Class FormCheckBox
  Inherits FormFieldAdapter

Constructors

Constructor | Description
FormCheckBox | Overloaded. Initializes a new instance of the FormText class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Bounds | Gets and sets the bounds of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
CalcOnExit | Gets or sets the CalcOnExit property of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Checked | Specifies whether the field is checked or not.
Enabled | Specifies whether the field is enabled or not. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Font | Gets and sets the font of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
HelpText | Gets and sets the help text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Name | Gets and sets the name of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Size | Specifies the maximum length of the field.
SizeAuto | Specifies whether the field is automatically resized or not.
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
StatusText | Gets and sets the status text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Text | Gets and sets the text of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormCheckBox Constructor

Initializes a new instance of the FormText class.

FormCheckBox()

Initializes complete new instance of the FormText class without a connection to an existing ApplicationField.

[C#]
public FormCheckBox()
[Visual Basic]
Public Sub New()

FormCheckBox(ApplicationField)

Initializes a new instance of the FormText class with a connection to an existing ApplicationField.

[C#]
public FormCheckBox(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormCheckBox.Size Property

Specifies the maximum length of the field.

Syntax

[C#]
public int Size
[Visual Basic]
Public Property Size() As Integer

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormCheckBox.SizeAuto Property

Specifies whether the field is automatically resized or not.

Syntax

[C#]
public bool SizeAuto
[Visual Basic]
Public Property SizeAuto() As Boolean

Limitations

This property is not used by the DocumentServer.Web.DocumentViewer component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormCheckBox.Checked Property

Specifies whether the field is checked or not.

Syntax

[C#]
public bool Checked
[Visual Basic]
Public Property Checked() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormDropDown Class

The FormDropDown class implements the MS Word specific FORMDROPDOWN field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class FormDropDown : FormFieldAdapter
[Visual Basic]
Public NotInheritable Class FormDropDown
  Inherits FormFieldAdapter

Constructors

Constructor | Description
FormDropDown | Overloaded. Initializes a new instance of the FormDropDown class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Bounds | Gets and sets the bounds of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
CalcOnExit | Gets or sets the CalcOnExit property of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Enabled | Specifies whether the field is enabled or not. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Font | Gets and sets the font of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
HelpText | Gets and sets the help text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
ListEntries | Gets and sets the list entries of the drop down field.
Name | Gets and sets the name of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
StatusText | Gets and sets the status text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Text | Gets and sets the text of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormDropDown Constructor

Initializes a new instance of the FormDropDown class.

FormDropDown()

Initializes a complete new instance of the FormDropDown class without a connection to an existing ApplicationField.

[C#]
public FormDropDown()
[Visual Basic]
Public Sub New()

FormDropDown(ApplicationField)

Initializes a new instance of the FormDropDown class with a connection to an existing ApplicationField.

[C#]
public FormDropDown(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormDropDown.ListEntries Property

Gets and sets the list entries of the drop down field.

Syntax

[C#]
public IEnumerable<string> ListEntries
[Visual Basic]
Public Property ListEntries() As IEnumerable(Of String)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter Class

The abstract FormFieldAdapter class is the base class of all special DocumentServer form field adapters. It implements the necessary means to access field properties such as the name or the text of a field.

Introduced: 15.0.

Syntax

[C#]
public abstract class FormFieldAdapter : FieldAdapter
[Visual Basic]
Public MustInherit Class FormFieldAdapter
  Inherits FieldAdapter

Constructors

Constructor | Description
FormFieldAdapter | Overloaded. Initializes a new instance of the FormFieldAdapter class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FieldAdapter.)
Bounds | Gets and sets the bounds of the form field.
CalcOnExit | Gets or sets the CalcOnExit property of the field.
Enabled | Specifies whether the field is enabled or not.
Font | Gets and sets the font of the form field.
HelpText | Gets and sets the help text of the field.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Name | Gets and sets the name of the form field.
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
StatusText | Gets and sets the status text of the field.
Text | Gets and sets the text of the form field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter Constructor

Initializes a new instance of the FormFieldAdapter class.

FormFieldAdapter()

Initializes a complete new instance of the FormFieldAdapter class without a connection to an existing ApplicationField.

[C#]
public FormFieldAdapter()
[Visual Basic]
Public Sub New()

FormFieldAdapter(ApplicationField)

Initializes a new instance of the FormFieldAdapter class with a connection to an existing ApplicationField.

[C#]
public FormFieldAdapter(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the to-be-adapted ApplicationField.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.HelpText Property

Gets and sets the help text of the field.

Syntax

[C#]
public string HelpText
[Visual Basic]
Public Property HelpText() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.StatusText Property

Gets and sets the status text of the field.

Syntax

[C#]
public string StatusText
[Visual Basic]
Public Property StatusText() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.Enabled Property

Specifies whether the field is enabled or not.

Syntax

[C#]
public bool Enabled
[Visual Basic]
Public Property Enabled() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.CalcOnExit Property

Gets or sets the CalcOnExit property of the field.

Syntax

[C#]
public bool Enabled
[Visual Basic]
Public Property Enabled() As Boolean

Limitations

This property is not used by the DocumentServer.Web.DocumentViewer component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.Name Property

Gets and sets the name of the form field.

Syntax

[C#]
public string Name
[Visual Basic]
Public Property Name() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.Text Property

Gets and sets the text of the form field.

Syntax

[C#]
public string Text
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.Font Property

Gets and sets the font of the form field.

Syntax

[C#]
public Font Font
[Visual Basic]
Public Property Font() As Font

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormFieldAdapter.Bounds Property

Gets and sets the bounds of the form field. The rectangle's location and the size are specified in twips.

Syntax

[C#]
public Rectangle Bounds
[Visual Basic]
Public Property Bounds() As Rectangle

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormText Class

The FormText class implements the MS Word specific FORMTEXT field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class FormText : FormFieldAdapter
[Visual Basic]
Public NotInheritable Class FormText
  Inherits FormFieldAdapter

Constructors

Constructor | Description
FormText | Overloaded. Initializes a new instance of the FormText class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Bounds | Gets and sets the bounds of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
CalcOnExit | Gets or sets the CalcOnExit property of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Enabled | Specifies whether the field is enabled or not. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Font | Gets and sets the font of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Format | Gets or sets the TextFormatOptions of the field.
HelpText | Gets and sets the help text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
MaxLength | Gets and sets the maximum length of the field.
Name | Gets and sets the name of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
StatusText | Gets and sets the status text of the field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Text | Gets and sets the text of the form field. (Inherited from DocumentServer.Fields.FormFieldAdapter.)
Type | Gets or sets the type of the field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FormFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormText Constructor

Initializes a new instance of the FormText class.

FormText()

Initializes a complete new instance of the FormText class without a connection to an existing ApplicationField.

[C#]
public FormText()
[Visual Basic]
Public Sub New()

FormText(ApplicationField)

Initializes a new instance of the FormText class with a connection to an existing ApplicationField.

[C#]
public FormText(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormText.MaxLength Property

Gets and sets the maximum length of the field.

Syntax

[C#]
public int MaxLength
[Visual Basic]
Public Property MaxLength() As Integer

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormText.Format Property

Gets or sets the TextFormatOptions of the field.

Syntax

[C#]
public TextFormatOptions Format
[Visual Basic]
Public Property Format() As TextFormatOptions

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.FormText.Type Property

Gets or sets the type of the field.

Syntax

[C#]
public FormTextBoxType Type
[Visual Basic]
Public Property Type() As FormTextBoxType
Value | Description
RegularText | Regular text is allowed.
Number | Only numeric values are allowed.
Date | A valid date format is allowed.
CurrentDate | The current date will be inserted.
CurrentTime | The current time will be inserted.
Calculation | A calculation is allowed.

Limitations

This property is not used by the DocumentServer.Web.DocumentViewer component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField Class

The IfField class implements the MS Word specific IF field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class IfField : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class IfField
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
IfField | Overloaded. Initializes a new instance of the IfField class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Expression1 | Gets and sets the first expression text that should be compared.
Expression2 | Gets and sets the second expression text that should be compared to Expression1.
FalseText | Gets and sets the text that should be displayed when the comparison is false.
FieldValue | Gets or sets the field's value of the field that has been specified in Expression1.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Operator | Gets and sets the operator of the field.
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Text | Gets and sets the displayed text of the field.
TrueText | Gets and sets the text that should be displayed when the comparison is true.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField Constructor

Initializes a new instance of the IfField class.

IfField()

Initializes a complete new instance of the IfField class without a connection to an existing ApplicationField.

[C#]
public IfField()
[Visual Basic]
Public Sub New()

IfField(ApplicationField)

Initializes a new instance of the IfField class with a connection to an existing ApplicationField.

[C#]
public IfField(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.Text Property

Gets and sets the displayed text of the field.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.Operator Property

Gets and sets the operator of the field.

Syntax

[C#]
public RelationalOperator Operator { get; set; }
[Visual Basic]
Public Property Operator() As RelationalOperator
Value | Description
Equals | The expression values must be equal.
NotEqual | The expression values must be not equal.
LessThan | Expression 1 is less than expression 2.
GreaterThan | Expression 1 is greater than expression 2.
GreaterThanOrEqualTo | Expression 1 is greater than or equal to expression 2.
LessThanOrEqualTo | Expression 1 is less than or equal to expression 2.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.Expression1 Property

Gets and sets the first expression text that should be compared. To use this field in the MailMerge component, this property must be a valid field name.

Syntax

[C#]
public string Expression1 { get; set; }
[Visual Basic]
Public Property Expression1() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.Expression2 Property

Gets and sets the second expression text that should be compared to Expression1.

Syntax

[C#]
public string Expression2 { get; set; }
[Visual Basic]
Public Property Expression2() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.TrueText Property

Gets and sets the text that should be displayed when the comparison is true.

Syntax

[C#]
public string TrueText { get; set; }
[Visual Basic]
Public Property TrueText() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.FalseText Property

Gets and sets the text that should be displayed when the comparison is false.

Syntax

[C#]
public string FalseText { get; set; }
[Visual Basic]
Public Property FalseText() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IfField.FieldValue Property

Gets or sets the field's value of the field that has been specified in Expression1.

Syntax

[C#]
public string FieldValue { get; set; }
[Visual Basic]
Public Property FieldValue() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IncludeText Class

The IncludeText class implements the MS Word specific INCLUDETEXT field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class IncludeText : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class IncludeText
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
IncludeText | Overloaded. Initializes a new instance of the IncludeText class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Bookmark | Gets and sets the bookmark switch of the field.
Filename | Gets and sets the file name of the document that should be inserted.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
TextFormat | Gets and sets the text format of the field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IncludeText Constructor

Initializes a new instance of the IncludeText class.

IncludeText()

Initializes a complete new instance of the IncludeText class without a connection to an existing ApplicationField.

[C#]
public IncludeText()
[Visual Basic]
Public Sub New()

IncludeText(ApplicationField)

Initializes a new instance of the IncludeText class with a connection to an existing ApplicationField.

[C#]
public IncludeText(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IncludeText.Filename Property

Gets and sets the file name of the document that should be inserted. In the MailMerge component, the search path for the documents can be set using the DocumentServer.MailMerge.SearchPath property.

Syntax

[C#]
public string Filename
[Visual Basic]
Public Property Filename() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IncludeText.Bookmark Property

Gets and sets the bookmark switch of the field.

Syntax

[C#]
public string Bookmark
[Visual Basic]
Public Property Bookmark() As String

Limitations

This property is not used by the MailMerge component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.IncludeText.TextFormat Property

Gets and sets the text format of the field.

Syntax

[C#]
public TextFormatOptions TextFormat
[Visual Basic]
Public Property TextFormat() As TextFormatOptions
Value | Description
Uppercase | The text is displayed in uppercase.
Lowercase | The text is displayed in lowercase.
FirstCapital | The first character is displayed in uppercase.
TitleCase | The text is displayed in title case.
None | The text is displayed with a special format.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter Class

The abstract MailMergeFieldAdapter class is the base class of all special DocumentServer mail merge field adapters. It implements the necessary means to access field properties.

Introduced: 15.0.

Syntax

[C#]
public abstract class MailMergeFieldAdapter : FieldAdapter
[Visual Basic]
Public MustInherit Class MailMergeFieldAdapter
  Inherits FieldAdapter

Constructors

Constructor | Description
MailMergeFieldAdapter | Overloaded. Initializes a new instance of the MailMergeFieldAdapter class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.FieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
PreserveFormatting | Specifies whether the field's formatting should be preserved.
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.FieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.FieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.FieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter Constructor

Initializes a new instance of the MailMergeFieldAdapter class.

MailMergeFieldAdapter()

Initializes a complete new instance of the MailMergeFieldAdapter class without a connection to an existing ApplicationField.

[C#]
public MailMergeFieldAdapter()
[Visual Basic]
Public Sub New()

MailMergeFieldAdapter(ApplicationField)

Initializes a new instance of the MailMergeFieldAdapter class with a connection to an existing ApplicationField.

[C#]
public MailMergeFieldAdapter(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the to-be-adapted ApplicationField.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MailMergeFieldAdapter.PreserveFormatting Property

Specifies whether the field's formatting should be preserved.

Syntax

[C#]
public bool PreserveFormatting
[Visual Basic]
Public Property PreserveFormatting() As Boolean

Limitations

This property is not used by the MailMerge component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField Class

The MergeField class implements the MS Word specific MERGEFIELD field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 15.0.

Syntax

[C#]
public sealed class MergeField : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class MergeField
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
MergeField | Overloaded. Initializes a new instance of the MergeField class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
DateTimeFormat | Specifies a string format which is applied to date / time values.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Mapped | Specifies whether the field is a mapped field.
Name | Gets and sets the name of the field.
NumericFormat | Specifies a string format which is applied to numeric values.
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Text | Gets and sets the text of the field.
TextAfter | Gets and sets the text of the field that is displayed after the field's text.
TextBefore | Gets and sets the text of the field that is displayed before the field's text.
TextFormat | Gets and sets the text format of the field.
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
VerticalFormatting | Specifies whether the field's formatting is vertical.

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField Constructor

Initializes a new instance of the MergeField class.

MergeField()

Initializes a complete new instance of the MergeField class without a connection to an existing ApplicationField.

[C#]
public MergeField()
[Visual Basic]
Public Sub New()

MergeField(ApplicationField)

nitializes a new instance of the MergeField class with a connection to an existing ApplicationField.

[C#]
public MergeField(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.DateTimeFormat Property

Specifies a string format which is applied to date / time values. Is equivalent to the MS Word field flag “\@”.

Introduced: 20.0.

Syntax

[C#]
public string DateTimeFormat { get; set; }
[Visual Basic]
Public Property DateTimeFormat() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.Mapped Property

Specifies whether the field is a mapped field.

Syntax

[C#]
public bool Mapped
[Visual Basic]
Public Property Mapped() As Boolean

Limitations

This property is not used by the MailMerge component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.Name Property

Gets and sets the name of the field.

Syntax

[C#]
public string Name
[Visual Basic]
Public Property Name() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.NumericFormat Property

Specifies a string format which is applied to numeric values. Is equivalent to the MS Word field flag “\#”.

Introduced: 20.0.

Syntax

[C#]
public string NumericFormat { get; set; }
[Visual Basic]
Public Property NumericFormat() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.Text Property

Gets and sets the text of the field.

Syntax

[C#]
public string Text
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.TextAfter Property

Gets and sets the text of the field that is displayed after the field's text.

Syntax

[C#]
public string TextAfter
[Visual Basic]
Public Property TextAfter() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.TextBefore Property

Gets and sets the text of the field that is displayed before the field's text.

Syntax

[C#]
public string TextBefore
[Visual Basic]
Public Property TextBefore() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.TextFormat Property

Gets and sets the text format of the field.

Syntax

[C#]
public TextFormatOptions TextFormat
[Visual Basic]
Public Property TextFormat() As TextFormatOptions
Value | Description
Uppercase | The text is displayed in uppercase.
Lowercase | The text is displayed in lowercase.
FirstCapital | The first character is displayed in uppercase.
TitleCase | The text is displayed in title case.
None | The text is displayed with a special format.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.MergeField.VerticalFormatting Property

Specifies whether the field's formatting is vertical.

Syntax

[C#]
public bool VerticalFormatting
[Visual Basic]
Public Property VerticalFormatting() As Boolean

Limitations

This property is not used by the MailMerge component.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextField Class

The NextField class implements the MS Word specific NEXT field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 20.0.

Syntax

[C#]
public sealed class NextField : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class NextField
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
NextField | Overloaded. Initializes a new instance of the NextField class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextField Constructor

Initializes a new instance of the NextField class.

NextField()

Initializes a complete new instance of the NextField class without a connection to an existing ApplicationField.

[C#]
public NextField()
[Visual Basic]
Public Sub New()

NextField(ApplicationField)

Initializes a new instance of the NextField class with a connection to an existing ApplicationField.

[C#]
public NextField(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField Class

The NextIfField class implements the MS Word specific NEXTIF field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 20.0.

Syntax

[C#]
public sealed class NextIfField : MailMergeFieldAdapter
[Visual Basic]
Public NotInheritable Class NextIfField
  Inherits MailMergeFieldAdapter

Constructors

Constructor | Description
NextIfField | Overloaded. Initializes a new instance of the NextIfField class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Expression1 | Gets and sets the first expression text that should be compared.
Expression2 | Gets and sets the second expression text that should be compared to Expression1.
FieldValue | Gets or sets the field's value of the field that has been specified in Expression1.
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Operator | Gets and sets the comparison operator the field.
PreserveFormatting | Specifies whether the field's formatting should be preserved. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
Result | Gets the evaluation result of the two field expressions and the specified comparison operator.
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.MailMergeFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField Constructor

Initializes a new instance of the NextIfField class.

NextIfField()

Initializes a complete new instance of the NextIfField class without a connection to an existing ApplicationField.

[C#]
public NextIfField()
[Visual Basic]
Public Sub New()

NextIfField(ApplicationField)

Initializes a new instance of the NextIfField class with a connection to an existing ApplicationField.

[C#]
public NextIfField(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField.Result Property

Gets the evaluation result of the two field expressions and the specified comparison operator.

Syntax

[C#]
public bool Result { get; }
[Visual Basic]
Public ReadOnly Property Result() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField.Operator Property

Gets and sets the comparison operator the field.

Syntax

[C#]
public RelationalOperator Operator { get; set; }
[Visual Basic]
Public Property Operator() As RelationalOperator
Value | Description
Equals | The expression values must be equal.
NotEqual | The expression values must be not equal.
LessThan | Expression 1 is less than expression 2.
GreaterThan | Expression 1 is greater than expression 2.
GreaterThanOrEqualTo | Expression 1 is greater than or equal to expression 2.
LessThanOrEqualTo | Expression 1 is less than or equal to expression 2.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField.Expression1 Property

Gets and sets the first expression text that should be compared. To use this field in the MailMerge component, this property must be a valid field name.

Syntax

[C#]
public string Expression1 { get; set; }
[Visual Basic]
Public Property Expression1() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField.Expression2 Property

Gets and sets the second expression text that should be compared to Expression1.

Syntax

[C#]
public string Expression2 { get; set; }
[Visual Basic]
Public Property Expression2() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.NextIfField.FieldValue Property

Gets or sets the field's value of the field that has been specified in Expression1.

Syntax

[C#]
public string FieldValue { get; set; }
[Visual Basic]
Public Property FieldValue() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.PlainTextContentControl Class

The PlainTextContentControl implements the MS Word specific plain text content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class PlainTextContentControl : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class PlainTextContentControl
  Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
PlainTextContentControl | Overloaded. Initializes a new instance of the PlainTextContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Text | Gets or sets the text of the content control field.
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.PlainTextContentControl Constructor

Initializes a new instance of the PlainTextContentControl class.

PlainTextContentControl()

Initializes complete new instance of the PlainTextContentControl class without a connection to an existing ApplicationField.

[C#]
public PlainTextContentControl()
[Visual Basic]
Public Sub New()

PlainTextContentControl(ApplicationField)

Initializes a new instance of the PlainTextContentControl class with a connection to an existing ApplicationField.

[C#]
public PlainTextContentControl(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.PlainTextContentControl.Text Property

Gets or sets the text of the content control field.

Syntax

[C#]
public string Text
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.RichTextContentControl Class

The RichTextContentControl implements the MS Word specific plain text content control field. This field must be used in combination with an ApplicationField that should be modified using this adapter.

Introduced: 21.0.

Syntax

[C#]
public sealed class RichTextContentControl : ContentControlFieldAdapter
[Visual Basic]
Public NotInheritable Class RichTextContentControl
     Inherits ContentControlFieldAdapter

Constructors

Constructor | Description
RichTextContentControl | Overloaded. Initializes a new instance of the RichTextContentControl class.

Properties

Property | Description
ApplicationField | Gets the adapted ApplicationField of the field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentDeletable | Specifies whether the content of the content control field should be deletable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ContentEditable | Specifies whether the content of the content control field should be editable or not. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Id | Gets or sets the content control's id. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
ID | Gets the ID of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Length | Gets the number of characters in a text field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Placeholder | Gets or sets the placeholder field part of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Start | Gets the first character position (one-based) of the field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Tag | Gets or sets the content control's tag. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Text | Gets or sets the text of the content control field.
Title | Gets or sets the content control's title. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
Type | Gets or sets the type of the content control field. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)
TypeName | Gets the field's type name of the specific field through its adapter. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Methods

Method | Description
ShowDialog | Opens the specific field options dialog box. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

Fields

Field | Description
FieldAdapter.TYPE_NAME | Represents the name of the respective field type. (Inherited from DocumentServer.Fields.ContentControlFieldAdapter.)

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.RichTextContentControl Constructor

Initializes a new instance of the RichTextContentControl class.

RichTextContentControl()

Initializes complete new instance of the RichTextContentControl class without a connection to an existing ApplicationField.

[C#]
public RichTextContentControl()
[Visual Basic]
Public Sub New()

RichTextContentControl(ApplicationField)

Initializes a new instance of the RichTextContentControl class with a connection to an existing ApplicationField.

[C#]
public RichTextContentControl(ApplicationField appField)
[Visual Basic]
Public Sub New(ByVal appField As ApplicationField)
Parameter | Description
appField | Specifies the ApplicationField to be adapted.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Fields.RichTextContentControl.Text Property

Gets or sets the text of the content control field.

Syntax

[C#]
public string Text
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Json namespace

TXTextControl.DocumentServer.Json.InvalidCodePointException Class

TXTextControl.DocumentServer.Json.InvalidNumberFormatException Class

TXTextControl.DocumentServer.Json.ParserException Class

TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException Class

TXTextControl.DocumentServer.Json.UnexpectedTokenException Class

TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException Class

TXTextControl.DocumentServer.Json.UnknownParseErrorException Class


TXTextControl.DocumentServer.Json.InvalidCodePointException Class

Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an invalid hexadecimal unicode code point.

Introduced: 24.0.

Syntax

[C#]
public class InvalidCodePointException : ParserException
[Visual Basic]
Public Class InvalidCodePointException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.InvalidNumberFormatException Class

Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing a number with an invalid number format.

Introduced: 24.0.

Syntax

[C#]
public class InvalidNumberFormatException : ParserException
[Visual Basic]
Public Class InvalidNumberFormatException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.ParserException Class

Base class of all JSON parser related exceptions which can be thrown when calling method MailMerge.MergeJsonData with an incorrect JSON string.

Introduced: 24.0.

Syntax

[C#]
public abstract class ParserException : Exception
[Visual Basic]
Public MustInherit Class ParserException
  Inherits Exception

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.UnexpectedEndOfInputException Class

Is thrown when calling method MailMerge.MergeJsonData with an incomplete JSON string.

Introduced: 24.0.

Syntax

[C#]
public class UnexpectedEndOfInputException : ParserException
[Visual Basic]
Public Class UnexpectedEndOfInputException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.UnexpectedTokenException Class

Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unexpected character.

Introduced: 24.0.

Syntax

[C#]
public class UnexpectedTokenException : ParserException
[Visual Basic]
Public Class UnexpectedTokenException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.UnknownLiteralNameTokenException Class

Is thrown when calling method MailMerge.MergeJsonData with a JSON string containing an unknown character sequence at a position where one of the strings "true", "false" or "null" are expected.

Introduced: 24.0.

Syntax

[C#]
public class UnknownLiteralNameTokenException : ParserException
[Visual Basic]
Public Class UnknownLiteralNameTokenException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.Json.UnknownParseErrorException Class

Is thrown when calling method MailMerge.MergeJsonData and the internal JSON parser encounters an unknown error.

Introduced: 24.0.

Syntax

[C#]
public class UnknownParseErrorException : ParserException
[Visual Basic]
Public Class UnknownParseErrorException
  Inherits ParserException

See Also

  • Programming Category: Mail Merge
  • Graphical Overview: Mail Merge


TXTextControl.DocumentServer.WPF namespace

TXTextControl.DocumentServer.WPF.EditDataRelationsDialog Class

TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog Class

TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog Class


TXTextControl.DocumentServer.WPF.EditDataRelationsDialog Class

The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source. The EditDataRelationsDialog is a modal dialog box which must be shown with the DocumentServer.WPF.EditDataRelationsDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class EditDataRelationsDialog : System.Windows.Window
[Visual Basic]
Public Class EditDataRelationsDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
EditDataRelationsDialog | Creates a EditDataRelationsDialog object for the specified DocumentServer.DataSources.DataSourceManager.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.EditDataRelationsDialog Constructor

Creates a EditDataRelationsDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public EditDataRelationsDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog Class

The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document. The EditMergeBlocksDialog is a modal dialog box which must be shown with the EditMergeBlocksDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class EditMergeBlocksDialog : System.Windows.Window
[Visual Basic]
Public Class EditMergeBlocksDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
EditMergeBlocksDialog | Creates a EditMergeBlocksDialog object for the specified DocumentServer.DataSources.DataSourceManager.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.EditMergeBlocksDialog Constructor

Creates a EditMergeBlocksDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public EditMergeBlocksDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager, object textControl);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager, textControl As Object)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.
textControl | A TextControl or a ServerTextControl instance containing the merge blocks which are shown in the dialog box.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog Class

The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table. It is inserted at the current input position of a given Text Control instance. The InsertMergeBlockDialog is a modal dialog box which must be shown with the InsertMergeBlockDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class InsertMergeBlockDialog : System.Windows.Window
[Visual Basic]
Public Class InsertMergeBlockDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
InsertMergeBlockDialog | Creates a InsertMergeBlockDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Properties

Property | Description
AddTableHeaderRow | Indicates whether a separate header row has to be added to the table containing the repeating merge block.
BlockType | Indicates the type of the merge block to be created.
HighlightColor | Returns the selected highlight color to be used for the sub text part representing the merge block.
MergeBlockInfo | Returns a MergeBlockInfo object describing the merge block to be inserted.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog Constructor

Creates a InsertMergeBlockDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public InsertMergeBlockDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager, object textControl);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager, textControl As Object)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.
textControl | A TextControl or a ServerTextControl instance containing the document into which the merge block is inserted.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog.AddTableHeaderRow Property

Indicates whether a separate header row has to be added to the table containing the repeating merge block. In case of a paragraph based merge block the value of this property can be ignored.

Syntax

[C#]
public bool AddTableHeaderRow { get; }
[Visual Basic]
Public ReadOnly Property AddTableHeaderRow() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog.BlockType Property

Indicates the type of the merge block to be created.

Syntax

[C#]
public DocumentServer.DataSources.BlockTemplateType BlockType { get; }
[Visual Basic]
Public ReadOnly Property BlockType() As DocumentServer.DataSources.BlockTemplateType
Value | Description
TableRow | Create a table row containing the repeating merge block.
PlainParagraph | Create a paragraph containing the repeating merge block.

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog.HighlightColor Property

Returns the selected highlight color to be used for the sub text part representing the merge block.

Syntax

[C#]
public System.Drawing.Color HighlightColor { get; }
[Visual Basic]
Public ReadOnly Property HighlightColor() As System.Drawing.Color

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.WPF.InsertMergeBlockDialog.MergeBlockInfo Property

Returns a MergeBlockInfo object describing the merge block to be inserted.

Syntax

[C#]
public DocumentServer.DataSources.MergeBlockInfo MergeBlockInfo { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockInfo() As DocumentServer.DataSources.MergeBlockInfo

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Web namespace

TXTextControl.DocumentServer.Web.DocumentViewer Class

TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs Class

TXTextControl.DocumentServer.Web.DocumentViewer.SaveFormDataEventArgs Class


TXTextControl.DocumentServer.Web.DocumentViewer Class

The DocumentViewer class is a .NET component that can be used to display documents in the web browser in ASP.NET projects. The DocumentViewer class can be found in the TXTextControl.DocumentViewer.Web namespace. It is derived from the System.Web.UI.WebControls.CompositeControl class. The following describes only the properties and methods directly defined by the DocumentViewer class. For a list of properties, methods and events inherited from the System.Web.UI.WebControls.CompositeControl class see the .NET Framework reference.

Introduced: 15.0.

Syntax

[C#]
public class DocumentViewer : CompositeControl
[Visual Basic]
Public Class DocumentViewer
  Inherits CompositeControl

Constructors

Constructor | Description
DocumentViewer | Initializes a new instance of the DocumentViewer class.

Properties

Property | Description
DocumentController | Gets or sets the DocumentServer.DocumentController object that is associated with the DocumentServer.Web.DocumentViewer component.
DocumentPath | Gets or sets the path to the document, which will be displayed in the DocumentServer.Web.DocumentViewer.
EditMode | Gets or sets whether the document viewer renders forms editable, i.e.
FieldBorderColor | Gets or sets the color of the field borders, that is used when FieldBorderStyle is not None.
FieldBorderStyle | Gets or sets whether and if so how the field borders are rendered, when EditMode is set to Edit.
Interpolation | Gets or sets whether the rendered document is interpolated during the process.
InterpolationMode | Gets or sets the interpolation mode which is used for rendering the document.
PageAnimationDuration | Gets or sets the duration of the page animations in seconds.
PageAnimations | Specifies whether CSS transition animations should be used or not when navigating through pages.
PageNumber | Gets or sets the page number that the DocumentServer.Web.DocumentViewer is displaying or should display respectively.
RoundedPageCorners | Specifies whether rounded document page corners should be used or not.
ShowEditButton | Specifies whether the edit button is shown or not.
ToolBar | Specifies whether the document viewer's tool bar is displayed or not.
TotalPages | Gets the total number of pages the loaded document contains.
ZoomFactor | Gets or sets the zoom factor in percent.
ZoomTo | Gets or sets the zoom behavior of the DocumentServer.Web.DocumentViewer.

Methods

Method | Description
Dispose | Frees all resources used by the DocumentViewer instance.
LoadDocument | Overloaded. Loads a document that is used for further processing.
LoadDocumentFromMemory | Loads a document from a file that is used for further processing.
Save | Overloaded. Initiates saving the currently loaded document.
SaveUserInput | Initiates saving the currently loaded form's user input.

Events

Event | Description
SaveDocument | Occurs when DocumentServer.Web.DocumentViewer.Save has been called, while specifying the format parameter only.
SaveFormData | Occurs when DocumentServer.Web.DocumentViewer.SaveUserInput has been called.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer Constructor

Initializes a new instance of the DocumentViewer class.

Syntax

[C#]
public DocumentViewer();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.Dispose Method

Frees all resources used by the DocumentViewer instance.

Syntax

[C#]
public virtual void Dispose()
[Visual Basic]
Public Overridable Sub Dispose()

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.DocumentController Property

Gets or sets the DocumentServer.DocumentController object that is associated with the DocumentServer.Web.DocumentViewer component.

Syntax

[C#]
public DocumentController DocumentController { get; set; }
[Visual Basic]
Public Property DocumentController() As DocumentController

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.DocumentPath Property

Gets or sets the path to the document, which will be displayed in the DocumentServer.Web.DocumentViewer. The document will be processed and displayed the next time the DocumentServer.Web.DocumentViewer is initialized. Please note that the extension of the specified filename must match the file's type, since the viewer determines the file type based on its extension and passes this information on to the DocumentServer.DocumentController which then in turn will try to load the document. Obviously, this process will fail, if the file extension suggests the wrong file type.

Syntax

[C#]
public string DocumentPath { get; set; }
[Visual Basic]
Public Property DocumentPath() As String

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.EditMode Property

Gets or sets whether the document viewer renders forms editable, i.e. with input fields at every form field's location, or read-only.

Syntax

[C#]
public EditMode EditMode { get; set; }
[Visual Basic]
Public Property EditMode() As EditMode
Value | Description
Edit | Documents are rendered editable, i.e. input fields are displayed at every form field's location.
ReadOnly | Documents are rendered read-only. This is the default.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.FieldBorderStyle Property

Gets or sets whether and if so how the field borders are rendered, when EditMode is set to Edit.

Syntax

[C#]
public FieldBorderStyle FieldBorderStyle { get; set; }
[Visual Basic]
Public Property FieldBorderStyle() As FieldBorderStyle
Value | Description
None | Fields are rendered without borders.
Dashed | Fields are rendered with dashed borders.
Dotted | Fields are rendered with dotted borders.
Solid | Fields are rendered with solid borders. This is the default.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.PageAnimations Property

Specifies whether CSS transition animations should be used or not when navigating through pages.

Introduced: 23.0.

Syntax

[C#]
public bool PageAnimations { get; set; }
[Visual Basic]
Public Property PageAnimations() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.PageAnimationDuration Property

Gets or sets the duration of the page animations in seconds.

Introduced: 23.0.

Syntax

[C#]
public double PageAnimationDuration { get; set; }
[Visual Basic]
Public Property PageAnimationDuration() As Double

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.ShowEditButton Property

Specifies whether the edit button is shown or not.

Introduced: 23.0.

Syntax

[C#]
public bool ShowEditButton { get; set; }
[Visual Basic]
Public Property ShowEditButton() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.RoundedPageCorners Property

Specifies whether rounded document page corners should be used or not.

Introduced: 23.0.

Syntax

[C#]
public bool RoundedPageCorners { get; set; }
[Visual Basic]
Public Property RoundedPageCorners() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.FieldBorderColor Property

Gets or sets the color of the field borders, that is used when FieldBorderStyle is not None.

Syntax

[C#]
public System.Drawing.Color FieldBorderColor { get; set; }
[Visual Basic]
Public Property FieldBorderColor() As System.Drawing.Color

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.Interpolation Property

Gets or sets whether the rendered document is interpolated during the process. The higher the value, the better the quality, but also the slower the rendering process and vice versa.

Syntax

[C#]
public Interpolation Interpolation { get; set; }
[Visual Basic]
Public Property Interpolation() As Interpolation
Value | Description
None | Documents are rendered without interpolation. This is the default.
Interpolation2x | Documents are rendered using 2x interpolation.
Interpolation3x | Documents are rendered using 3x interpolation.
Interpolation4x | Documents are rendered using 4x interpolation. This option is the most time-consuming one.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.InterpolationMode Property

Gets or sets the interpolation mode which is used for rendering the document. This like DocumentServer.Web.DocumentViewer.Interpolation, this setting affects the rendering result.

Syntax

[C#]
public InterpolationMode InterpolationMode { get; set; }
[Visual Basic]
Public Property InterpolationMode() As InterpolationMode

Remarks

Please see System.Drawing.Drawing2D.InterpolationMode for valid values. The property's default value is InterpolationMode.Default.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.LoadDocument Method

Loads a document that is used for further processing.

LoadDocument(String)

Loads a document from a specific path.

[C#]
public void LoadDocument(string path);
[Visual Basic]
Public Sub LoadDocument(ByVal path As String)
Parameter | Description
path | Specifies the document file to be loaded.

LoadDocument(String, FileFormat)

Loads a document from a specific path and a specific document format.

[C#]
public void LoadDocument(string path, DocumentServer.FileFormat format);
[Visual Basic]
Public Sub LoadDocument(ByVal path As String, ByVal format As DocumentServer.FileFormat)
Parameter | Description
path | Specifies the document file to be loaded.
format | Specifies one of the DocumentServer.FileFormat values.

Remarks

If only the path parameter is specified, the file type is determined by the file's extension.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.LoadDocumentFromMemory Method

Loads a document from a file that is used for further processing.

Syntax

[C#]
public void LoadDocumentFromMemory(object data, DocumentServer.FileFormat format);
[Visual Basic]
Public Sub LoadDocumentFromMemory(ByRef data As Object, ByVal format As DocumentServer.FileFormat)
Parameter | Description
data | Specifies a memory variable from which the document is loaded.
format | Specifies one of the DocumentServer.FileFormat values.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.PageNumber Property

Gets or sets the page number that the DocumentServer.Web.DocumentViewer is displaying or should display respectively. Returns 0, if no document is loaded.

Syntax

[C#]
public int PageNumber { get; set; }
[Visual Basic]
Public Property PageNumber() As Integer

Limitations

Valid values for setting the page number are between 1 and the total number of pages, which is dependent on the loaded document, of course.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.ToolBar Property

Specifies whether the document viewer's tool bar is displayed or not.

Syntax

[C#]
public bool ToolBar { get; set; }
[Visual Basic]
Public Property ToolBar() As Boolean

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.TotalPages Property

Gets the total number of pages the loaded document contains. Returns 0 if no document is loaded.

Syntax

[C#]
public int TotalPages { get; }
[Visual Basic]
Public ReadOnly Property TotalPages() As Integer

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.Save Method

Initiates saving the currently loaded document. The actual saving is performed by a method which has to be bound to the DocumentServer.Web.DocumentViewer.SaveDocument event.

Save(FileFormat)

Saves the document in a specific document format.

[C#]
public void Save(DocumentServer.FileFormat format);
[Visual Basic]
Public Sub Save(ByVal format As DocumentServer.FileFormat)
Parameter | Description
format | Specifies one of the DocumentServer.FileFormat values.

Save(String)

Saves the document to a specific path.

[C#]
public void Save(string path);
[Visual Basic]
Public Sub Save(ByVal path As String)
Parameter | Description
path | Specifies where the document should be saved.

Save(String, FileFormat)

Saves the document to a specific path in a specific document format.

[C#]
public void Save(string path, DocumentServer.FileFormat format);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal format As DocumentServer.FileFormat)
Parameter | Description
path | Specifies where the document should be saved.
format | Specifies one of the DocumentServer.FileFormat values.

Remarks

A given path is always relating to the server the document viewer is runnig on. Thus, it is good practice to define the path parameter using the HttpServerUtility.MapPath() method.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocument Event

Occurs when DocumentServer.Web.DocumentViewer.Save has been called, while specifying the format parameter only. The event handler receives an argument of type DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs containing data related to this event.

Syntax

[C#]
public event SaveDocumentEventHandler SaveDocument;
[Visual Basic]
Public Event SaveDocument As SaveDocumentEventHandler

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveFormData Event

Occurs when DocumentServer.Web.DocumentViewer.SaveUserInput has been called. The event handler receives an argument of type DocumentServer.Web.DocumentViewer.SaveFormDataEventArgs containing data related to this event.

Syntax

[C#]
public event SaveFormDataEventHandler SaveFormData;
[Visual Basic]
Public Event SaveFormData As SaveFormDataEventHandler

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveUserInput Method

Initiates saving the currently loaded form's user input. The actual saving is performed by a method which has to be bound to the DocumentServer.Web.DocumentViewer.SaveFormData event.

Syntax

[C#]
public void SaveUserInput();
[Visual Basic]
Public Sub SaveUserInput()

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.ZoomFactor Property

Gets or sets the zoom factor in percent.

Syntax

[C#]
public int ZoomFactor { get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

Limitations

The zoom factor must be between 10 and 400 percent. Also, setting the zoom factor only has an effect, if the DocumentServer.Web.DocumentViewer.ZoomTo property is set to ZoomLevel.FixedSize.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.ZoomTo Property

Gets or sets the zoom behavior of the DocumentServer.Web.DocumentViewer.

Syntax

[C#]
public ZoomLevel ZoomTo { get; set; }
[Visual Basic]
Public Property ZoomTo() As ZoomLevel
Value | Description
ControlWidth | The current page is zoomed to a size, which makes the horizontal scroll bar unnecessary.
FixedSize | The document is zoomed to the value specified by the DocumentServer.Web.DocumentViewer.ZoomFactor property.
WholePage | The current page is zoomed to a size that allows to view it as a whole.

Remarks

The property's default value is ControlWidth.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs Class

The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveDocument event.

Introduced: 15.0.

Syntax

[C#]
public class SaveDocumentEventArgs : EventArgs
[Visual Basic]
Public Class SaveDocumentEventArgs
  Inherits EventArgs

Properties

Property | Description
Document | Gets a snapshot of the currently loaded document for further processing.
FileFormat | Specifies the format of DocumentViewer.SaveDocumentEventArgs.Document.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs.Document Property

Gets a snapshot of the currently loaded document for further processing.

Syntax

[C#]
public byte[] Document { get; }
[Visual Basic]
Public ReadOnly Property Document() As Byte()

Remarks

For a given string path and SaveDocumentEventArgs e you can save the document depending on its file format: For FileFormat.RichTextFormat System.IO.File.WriteAllText(path, new System.Text.ASCIIEncoding().GetString(e.Document)) can be used and System.IO.File.WriteAllBytes(path, e.Document) for all other formats. The document's file format is specified in DocumentViewer.SaveDocumentEventArgs.FileFormat.

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs.FileFormat Property

Specifies the format of DocumentViewer.SaveDocumentEventArgs.Document.

Syntax

[C#]
public DocumentServer.FileFormat FileFormat { get; }
[Visual Basic]
Public ReadOnly Property FileFormat() As DocumentServer.FileFormat

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveFormDataEventArgs Class

The SaveDocumentEventArgs class provides data for the DocumentViewer.SaveFormData event.

Introduced: 15.0.

Syntax

[C#]
public class SaveFormDataEventArgs : EventArgs
[Visual Basic]
Public Class SaveFormDataEventArgs
  Inherits EventArgs

Properties

Property | Description
DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs.FormData | Gets a snapshot of the currently loaded form's user input.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Web.DocumentViewer.SaveDocumentEventArgs.FormData Property

Gets a snapshot of the currently loaded form's user input.

Syntax

[C#]
public System.Data.DataTable FormData { get; }
[Visual Basic]
Public ReadOnly Property FormData() As System.Data.DataTable

Remarks

The DataTable object allows for a variety of different ways of processing the contained data. For instance, exporting the form data as xml string is as simple as calling the DataTable.WriteXml() method.

Limitations

Read only.

See Also

  • Programming Category: Document Viewer
  • Graphical Overview: Document Viewer


TXTextControl.DocumentServer.Windows.Forms namespace

TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog Class

TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog Class

TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog Class

TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog Class

TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog Class


TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog Class

The DataSourceExtractionDialog class allows the user to save an excerpt from the currently loaded data source. An upper limit of extracted data rows can be specified in the dialog. It works only with data provider based data sources and throws an exception when called with any other loaded data source type. The DataSourceExtractionDialog is a modal dialog box which must be shown with the DataSourceExtractionDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class DataSourceExtractionDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class DataSourceExtractionDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
DataSourceExtractionDialog | Creates a DataSourceExtractionDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Properties

Property | Description
FileName | Returns the file name of the file into which the data source excerpt has been saved.
MaxRows | Returns the maximum number of data rows from the selected table which were saved into the excerpt file.
SelectedTable | Returns a description of the table which was selected by the user to be exported.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog Constructor

Creates a DataSourceExtractionDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public DataSourceExtractionDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog.FileName Property

Returns the file name of the file into which the data source excerpt has been saved.

Syntax

[C#]
public string FileName { get; }
[Visual Basic]
Public ReadOnly Property FileName() As String

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog.MaxRows Property

Returns the maximum number of data rows from the selected table which were saved into the excerpt file.

Syntax

[C#]
public int MaxRows { get; }
[Visual Basic]
Public ReadOnly Property MaxRows() As Integer

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DataSourceExtractionDialog.SelectedTable Property

Returns a description of the table which was selected by the user to be exported.

Syntax

[C#]
public DocumentServer.DataSources.DataTableInfo SelectedTable { get; }
[Visual Basic]
Public ReadOnly Property SelectedTable() As DocumentServer.DataSources.DataTableInfo

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog Class

The DatabaseConnectionDialog class allows the user to build connection strings and to connect to specific data sources. The DatabaseConnectionDialog is a modal dialog box which must be shown with the DatabaseConnectionDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class DatabaseConnectionDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class DatabaseConnectionDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
DatabaseConnectionDialog | Creates a DatabaseConnectionDialog object for the specified DocumentServer.DataSources.DataSourceManager.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.DatabaseConnectionDialog Constructor

Creates a DatabaseConnectionDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public DatabaseConnectionDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which handles the selected connection to a data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog Class

The EditDataRelationsDialog class allows the user to add or remove data relations to or from the current data source. The EditDataRelationsDialog is a modal dialog box which must be shown with the EditDataRelationsDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class EditDataRelationsDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class EditDataRelationsDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
EditDataRelationsDialog | Creates a EditDataRelationsDialog object for the specified DocumentServer.DataSources.DataSourceManager.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.EditDataRelationsDialog Constructor

Creates a EditDataRelationsDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public EditDataRelationsDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog Class

The EditMergeBlocksDialog class allows the user to remove or rename merge blocks contained in the current document. The EditMergeBlocksDialog is a modal dialog box which must be shown with the EditMergeBlocksDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class EditMergeBlocksDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class EditMergeBlocksDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
EditMergeBlocksDialog | Creates a EditMergeBlocksDialog object for the specified DocumentServer.DataSources.DataSourceManager.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.EditMergeBlocksDialog Constructor

Creates a EditMergeBlocksDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public EditMergeBlocksDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager, object textControl);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager, textControl As Object)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.
textControl | A TextControl or a ServerTextControl instance containing the merge blocks which are shown in the dialog box.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog Class

The InsertMergeBlockDialog class allows the user to design and insert a merge block based on the currently selected master table. It is inserted at the current input position of a given Text Control instance. The InsertMergeBlockDialog is a modal dialog box which must be shown with the InsertMergeBlockDialog.ShowDialog method.

Introduced: 24.0.

Syntax

[C#]
public class InsertMergeBlockDialog : System.Windows.Forms.Form
[Visual Basic]
Public Class InsertMergeBlockDialog
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
InsertMergeBlockDialog | Creates a InsertMergeBlockDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Properties

Property | Description
AddTableHeaderRow | Indicates whether a separate header row has to be added to the table containing the repeating merge block.
BlockType | Indicates the type of the merge block to be created.
HighlightColor | Returns the selected highlight color to be used for the sub text part representing the merge block.
MergeBlockInfo | Returns a MergeBlockInfo object describing the merge block to be inserted.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog Constructor

Creates a InsertMergeBlockDialog object for the specified DocumentServer.DataSources.DataSourceManager.

Syntax

[C#]
public InsertMergeBlockDialog(DocumentServer.DataSources.DataSourceManager dataSourceManager, object textControl);
[Visual Basic]
Public Sub New(dataSourceManager As DocumentServer.DataSources.DataSourceManager, textControl As Object)
Parameter | Description
dataSourceManager | Specifies the DataSourceManager, which manages the current data source.
textControl | A TextControl or a ServerTextControl instance containing the document into which the merge block is inserted.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog.AddTableHeaderRow Property

Indicates whether a separate header row has to be added to the table containing the repeating merge block. In case of a paragraph based merge block the value of this property can be ignored.

Syntax

[C#]
public bool AddTableHeaderRow { get; }
[Visual Basic]
Public ReadOnly Property AddTableHeaderRow() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog.BlockType Property

Indicates the type of the merge block to be created.

Syntax

[C#]
public DocumentServer.DataSources.BlockTemplateType BlockType { get; }
[Visual Basic]
Public ReadOnly Property BlockType() As DocumentServer.DataSources.BlockTemplateType
Value | Description
TableRow | Create a table row containing the repeating merge block.
PlainParagraph | Create a paragraph containing the repeating merge block.

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog.HighlightColor Property

Returns the selected highlight color to be used for the sub text part representing the merge block.

Syntax

[C#]
public System.Drawing.Color HighlightColor { get; }
[Visual Basic]
Public ReadOnly Property HighlightColor() As System.Drawing.Color

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.DocumentServer.Windows.Forms.InsertMergeBlockDialog.MergeBlockInfo Property

Returns a MergeBlockInfo object describing the merge block to be inserted.

Syntax

[C#]
public DocumentServer.DataSources.MergeBlockInfo MergeBlockInfo { get; }
[Visual Basic]
Public ReadOnly Property MergeBlockInfo() As DocumentServer.DataSources.MergeBlockInfo

Limitations

Read only.

See Also

  • Programming Category: Reporting
  • Graphical Overview: Reporting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.Drawing namespace

Enumerations

TXTextControl.Drawing.MenuItem Class

TXTextControl.Drawing.Selection Class

TXTextControl.Drawing.Shape Class

TXTextControl.Drawing.Shape.Fill Class

TXTextControl.Drawing.Shape.Outline Class

TXTextControl.Drawing.ShapeCollection Class

TXTextControl.Drawing.ShapeEventArgs Class

TXTextControl.Drawing.ShapesContextMenuStrip Class

TXTextControl.Drawing.TXDrawingControl Class

TXTextControl.Drawing.ViewChangedEventArgs Class


Enumerations

TXTextControl.Drawing.Flip Enumeration

TXTextControl.Drawing.Selection.Attribute Enumeration

TXTextControl.Drawing.ShapeCollection.AddStyle Enumeration

TXTextControl.Drawing.ShapeType Enumeration


TXTextControl.Drawing.Flip Enumeration

Determines whether and in which form the shape is flip. The enumeration contains the following values:

Member | Description
Horizontal | Flips the shape horizontally.
Vertical | Flips the shape vertically.
None | The shape is not flipped.


TXTextControl.Drawing.Selection.Attribute Enumeration

Determines a certain shape class attribute. This enumeration is used with the IsCommonValueSelected method and contains the following values:

Member | Description
Angle | Specifies the attribute set through the Shape.Angle property.
AutoSize | Specifies the attribute set through the Shape.AutoSize property.
CanFitToCanvas | Specifies the attribute set through the Shape.CanFitToCanvas property.
FillColor | Specifies the attribute set through the Shape.ShapeFill.Color property.
FlipHorizontal | Specifies the horizontal attribute set through the Shape.Flip property.
FlipVertical | Specifies the vertical attribute set through the Shape.Flip property.
Movable | Specifies the attribute set through the Shape.Movable property.
LineColor | Specifies the attribute set through the Shape.ShapeOutline.Color property.
LineWidth | Specifies the attribute set through the Shape.ShapeOutline.Width property.
LocationX | Specifies the x attribute set through the Shape.Location.X property.
LocationY | Specifies the y attribute set through the Shape.Location.Y property.
Sizable | Specifies the attribute set through the Shape.Sizable property.
SizeHeight | Specifies the height attribute set through the Shape.Size.Height property.
SizeWidth | Specifies the width attribute set through the Shape.Size.Width property.


TXTextControl.Drawing.ShapeCollection.AddStyle Enumeration

Determines the location and size in which a shape is added to the TX Drawing Control. The enumeration contains the following values:

Member | Description
Fill | The shape fills the complete control, no matter which location and size was defined before.
MouseCreation | The shape is added on the next mouse up handling and gets the bounds which are defined by the previous mouse down click and the following mouse movement. If a considering side value is less than 150 twips, the side gets a length of 1134 twips.
None | No specific style is set. The shape is located at its defined location with its defined size.


TXTextControl.Drawing.ShapeType Enumeration

Determines the type a shape can have. All types are similar to the preset shapes defined by ISO/IEC 29500-1 in section 20.1.10.55. The enumeration contains the following values:

Member | Description
Line | Line Shape. When the item is serialized out as xml, its value is "line".
LineInverse | Line Inverse Shape. When the item is serialized out as xml, its value is "lineInv".
Triangle | Triangle Shape. When the item is serialized out as xml, its value is "triangle".
RightTriangle | Right Triangle Shape. When the item is serialized out as xml, its value is "rtTriangle".
Rectangle | Rectangle Shape. When the item is serialized out as xml, its value is "rect".
Diamond | Diamond Shape. When the item is serialized out as xml, its value is "diamond".
Parallelogram | Parallelogram Shape. When the item is serialized out as xml, its value is "parallelogram".
Trapezoid | Trapezoid Shape. When the item is serialized out as xml, its value is "trapezoid".
NonIsoscelesTrapezoid | Non-Isosceles Trapezoid Shape. When the item is serialized out as xml, its value is "nonIsoscelesTrapezoid".
Pentagon | Pentagon Shape. When the item is serialized out as xml, its value is "pentagon".
Hexagon | Hexagon Shape. When the item is serialized out as xml, its value is "hexagon".
Heptagon | Heptagon Shape. When the item is serialized out as xml, its value is "heptagon".
Octagon | Octagon Shape. When the item is serialized out as xml, its value is "octagon".
Decagon | Decagon Shape. When the item is serialized out as xml, its value is "decagon".
Dodecagon | Dodecagon Shape. When the item is serialized out as xml, its value is "dodecagon".
Star4 | Four Pointed Star Shape. When the item is serialized out as xml, its value is "star4".
Star5 | Five Pointed Star Shape. When the item is serialized out as xml, its value is "star5".
Star6 | Six Pointed Star Shape. When the item is serialized out as xml, its value is "star6".
Star7 | Seven Pointed Star Shape. When the item is serialized out as xml, its value is "star7".
Star8 | Eight Pointed Star Shape. When the item is serialized out as xml, its value is "star8".
Star10 | Ten Pointed Star Shape. When the item is serialized out as xml, its value is "star10".
Star12 | Twelve Pointed Star Shape. When the item is serialized out as xml, its value is "star12".
Star16 | Sixteen Pointed Star Shape. When the item is serialized out as xml, its value is "star16".
Star24 | Twenty Four Pointed Star Shape. When the item is serialized out as xml, its value is "star24".
Star32 | Thirty Two Pointed Star Shape. When the item is serialized out as xml, its value is "star32".
RoundRectangle | Round Corner Rectangle Shape. When the item is serialized out as xml, its value is "roundRect".
Round1Rectangle | One Round Corner Rectangle Shape. When the item is serialized out as xml, its value is "round1Rect".
Round2SameRectangle | Two Same-side Round Corner Rectangle Shape. When the item is serialized out as xml, its value is "round2SameRect".
Round2DiagonalRectangle | Two Diagonal Round Corner Rectangle Shape. When the item is serialized out as xml, its value is "round2DiagRect".
SnipRoundRectangle | One Snip One Round Corner Rectangle Shape. When the item is serialized out as xml, its value is "snipRoundRect".
Snip1Rectangle | One Snip Corner Rectangle Shape. When the item is serialized out as xml, its value is "snip1Rect".
Snip2SameRectangle | Two Same-side Snip Corner Rectangle Shape. When the item is serialized out as xml, its value is "snip2SameRect".
Snip2DiagonalRectangle | Two Diagonal Snip Corner Rectangle Shape. When the item is serialized out as xml, its value is "snip2DiagRect".
Plaque | Plaque Shape. When the item is serialized out as xml, its value is "plaque".
Ellipse | Ellipse Shape. When the item is serialized out as xml, its value is "ellipse".
Teardrop | Teardrop Shape. When the item is serialized out as xml, its value is "teardrop".
HomePlate | Home Plate Shape. When the item is serialized out as xml, its value is "homePlate".
Chevron | Chevron Shape. When the item is serialized out as xml, its value is "chevron".
PieWedge | Pie Wedge Shape. When the item is serialized out as xml, its value is "pieWedge".
Pie | Pie Shape. When the item is serialized out as xml, its value is "pie".
BlockArc | Block Arc Shape. When the item is serialized out as xml, its value is "blockArc".
Donut | Donut Shape. When the item is serialized out as xml, its value is "donut".
NoSmoking | No Smoking Shape. When the item is serialized out as xml, its value is "noSmoking".
RightArrow | Right Arrow Shape. When the item is serialized out as xml, its value is "rightArrow".
LeftArrow | Left Arrow Shape. When the item is serialized out as xml, its value is "leftArrow".
UpArrow | Up Arrow Shape. When the item is serialized out as xml, its value is "upArrow".
DownArrow | Down Arrow Shape. When the item is serialized out as xml, its value is "downArrow".
StripedRightArrow | Striped Right Arrow Shape. When the item is serialized out as xml, its value is "stripedRightArrow".
NotchedRightArrow | Notched Right Arrow Shape. When the item is serialized out as xml, its value is "notchedRightArrow".
BentUpArrow | Bent Up Arrow Shape. When the item is serialized out as xml, its value is "bentUpArrow".
LeftRightArrow | Left Right Arrow Shape. When the item is serialized out as xml, its value is "leftRightArrow".
UpDownArrow | Up Down Arrow Shape. When the item is serialized out as xml, its value is "upDownArrow".
LeftUpArrow | Left Up Arrow Shape. When the item is serialized out as xml, its value is "leftUpArrow".
LeftRightUpArrow | Left Right Up Arrow Shape. When the item is serialized out as xml, its value is "leftRightUpArrow".
QuadArrow | Quad-Arrow Shape. When the item is serialized out as xml, its value is "quadArrow".
LeftArrowCallout | Callout Left Arrow Shape. When the item is serialized out as xml, its value is "leftArrowCallout".
RightArrowCallout | Callout Right Arrow Shape. When the item is serialized out as xml, its value is "rightArrowCallout".
UpArrowCallout | Callout Up Arrow Shape. When the item is serialized out as xml, its value is "upArrowCallout".
DownArrowCallout | Callout Down Arrow Shape. When the item is serialized out as xml, its value is "downArrowCallout".
LeftRightArrowCallout | Callout Left Right Arrow Shape. When the item is serialized out as xml, its value is "leftRightArrowCallout".
UpDownArrowCallout | Callout Up Down Arrow Shape. When the item is serialized out as xml, its value is "upDownArrowCallout".
QuadArrowCallout | Callout Quad-Arrow Shape. When the item is serialized out as xml, its value is "quadArrowCallout".
BentArrow | Bent Arrow Shape. When the item is serialized out as xml, its value is "bentArrow".
UTurnArrow | U-Turn Arrow Shape. When the item is serialized out as xml, its value is "uturnArrow".
CircularArrow | Circular Arrow Shape. When the item is serialized out as xml, its value is "circularArrow".
LeftCircularArrow | Left Circular Arrow Shape. When the item is serialized out as xml, its value is "leftCircularArrow".
LeftRightCircularArrow | Left Right Circular Arrow Shape. When the item is serialized out as xml, its value is "leftRightCircularArrow".
CurvedRightArrow | Curved Right Arrow Shape. When the item is serialized out as xml, its value is "curvedRightArrow".
CurvedLeftArrow | Curved Left Arrow Shape. When the item is serialized out as xml, its value is "curvedLeftArrow".
CurvedUpArrow | Curved Up Arrow Shape. When the item is serialized out as xml, its value is "curvedUpArrow".
CurvedDownArrow | Curved Down Arrow Shape. When the item is serialized out as xml, its value is "curvedDownArrow".
SwooshArrow | Swoosh Arrow Shape. When the item is serialized out as xml, its value is "swooshArrow".
Cube | Cube Shape. When the item is serialized out as xml, its value is "cube".
Can | Can Shape. When the item is serialized out as xml, its value is "can".
LightningBolt | Lightning Bolt Shape. When the item is serialized out as xml, its value is "lightningBolt".
Heart | Heart Shape. When the item is serialized out as xml, its value is "heart".
Sun | Sun Shape. When the item is serialized out as xml, its value is "sun".
Moon | Moon Shape. When the item is serialized out as xml, its value is "moon".
SmileyFace | Smiley Face Shape. When the item is serialized out as xml, its value is "smileyFace".
IrregularSeal1 | Irregular Seal 1 Shape. When the item is serialized out as xml, its value is "irregularSeal1".
IrregularSeal2 | Irregular Seal 2 Shape. When the item is serialized out as xml, its value is "irregularSeal2".
FoldedCorner | Folded Corner Shape. When the item is serialized out as xml, its value is "foldedCorner".
Bevel | Bevel Shape. When the item is serialized out as xml, its value is "bevel".
Frame | Frame Shape. When the item is serialized out as xml, its value is "frame".
HalfFrame | Half Frame Shape. When the item is serialized out as xml, its value is "halfFrame".
Corner | Corner Shape. When the item is serialized out as xml, its value is "corner".
DiagonalStripe | Diagonal Stripe Shape. When the item is serialized out as xml, its value is "diagStripe".
Chord | Chord Shape. When the item is serialized out as xml, its value is "chord".
Arc | Curved Arc Shape. When the item is serialized out as xml, its value is "arc".
LeftBracket | Left Bracket Shape. When the item is serialized out as xml, its value is "leftBracket".
RightBracket | Right Bracket Shape. When the item is serialized out as xml, its value is "rightBracket".
LeftBrace | Left Brace Shape. When the item is serialized out as xml, its value is "leftBrace".
RightBrace | Right Brace Shape. When the item is serialized out as xml, its value is "rightBrace".
BracketPair | Bracket Pair Shape. When the item is serialized out as xml, its value is "bracketPair".
BracePair | Brace Pair Shape. When the item is serialized out as xml, its value is "bracePair".
StraightConnector1 | Straight Connector 1 Shape. When the item is serialized out as xml, its value is "straightConnector1".
BentConnector2 | Bent Connector 2 Shape. When the item is serialized out as xml, its value is "bentConnector2".
BentConnector3 | Bent Connector 3 Shape. When the item is serialized out as xml, its value is "bentConnector3".
BentConnector4 | Bent Connector 4 Shape. When the item is serialized out as xml, its value is "bentConnector4".
BentConnector5 | Bent Connector 5 Shape. When the item is serialized out as xml, its value is "bentConnector5".
CurvedConnector2 | Curved Connector 2 Shape. When the item is serialized out as xml, its value is "curvedConnector2".
CurvedConnector3 | Curved Connector 3 Shape. When the item is serialized out as xml, its value is "curvedConnector3".
CurvedConnector4 | Curved Connector 4 Shape. When the item is serialized out as xml, its value is "curvedConnector4".
CurvedConnector5 | Curved Connector 5 Shape. When the item is serialized out as xml, its value is "curvedConnector5".
Callout1 | Callout 1 Shape. When the item is serialized out as xml, its value is "callout1".
Callout2 | Callout 2 Shape. When the item is serialized out as xml, its value is "callout2".
Callout3 | Callout 3 Shape. When the item is serialized out as xml, its value is "callout3".
AccentCallout1 | Callout 1 Shape. When the item is serialized out as xml, its value is "accentCallout1".
AccentCallout2 | Callout 2 Shape. When the item is serialized out as xml, its value is "accentCallout2".
AccentCallout3 | Callout 3 Shape. When the item is serialized out as xml, its value is "accentCallout3".
BorderCallout1 | Callout 1 with Border Shape. When the item is serialized out as xml, its value is "borderCallout1".
BorderCallout2 | Callout 2 with Border Shape. When the item is serialized out as xml, its value is "borderCallout2".
BorderCallout3 | Callout 3 with Border Shape. When the item is serialized out as xml, its value is "borderCallout3".
AccentBorderCallout1 | Callout 1 with Border and Accent Shape. When the item is serialized out as xml, its value is "accentBorderCallout1".
AccentBorderCallout2 | Callout 2 with Border and Accent Shape. When the item is serialized out as xml, its value is "accentBorderCallout2".
AccentBorderCallout3 | Callout 3 with Border and Accent Shape. When the item is serialized out as xml, its value is "accentBorderCallout3".
WedgeRectangleCallout | Callout Wedge Rectangle Shape. When the item is serialized out as xml, its value is "wedgeRectCallout".
WedgeRoundRectangleCallout | Callout Wedge Round Rectangle Shape. When the item is serialized out as xml, its value is "wedgeRoundRectCallout".
WedgeEllipseCallout | Callout Wedge Ellipse Shape. When the item is serialized out as xml, its value is "wedgeEllipseCallout".
CloudCallout | Callout Cloud Shape. When the item is serialized out as xml, its value is "cloudCallout".
Cloud | Cloud Shape. When the item is serialized out as xml, its value is "cloud".
Ribbon | Ribbon Shape. When the item is serialized out as xml, its value is "ribbon".
Ribbon2 | Ribbon 2 Shape. When the item is serialized out as xml, its value is "ribbon2".
EllipseRibbon | Ellipse Ribbon Shape. When the item is serialized out as xml, its value is "ellipseRibbon".
EllipseRibbon2 | Ellipse Ribbon 2 Shape. When the item is serialized out as xml, its value is "ellipseRibbon2".
LeftRightRibbon | Left Right Ribbon Shape. When the item is serialized out as xml, its value is "leftRightRibbon".
VerticalScroll | Vertical Scroll Shape. When the item is serialized out as xml, its value is "verticalScroll".
HorizontalScroll | Horizontal Scroll Shape. When the item is serialized out as xml, its value is "horizontalScroll".
Wave | Wave Shape. When the item is serialized out as xml, its value is "wave".
DoubleWave | Double Wave Shape. When the item is serialized out as xml, its value is "doubleWave".
Plus | Plus Shape. When the item is serialized out as xml, its value is "plus".
FlowChartProcess | Process Flow Shape. When the item is serialized out as xml, its value is "flowChartProcess".
FlowChartDecision | Decision Flow Shape. When the item is serialized out as xml, its value is "flowChartDecision".
FlowChartInputOutput | Input Output Flow Shape. When the item is serialized out as xml, its value is "flowChartInputOutput".
FlowChartPredefinedProcess | Predefined Process Flow Shape. When the item is serialized out as xml, its value is "flowChartPredefinedProcess".
FlowChartInternalStorage | Internal Storage Flow Shape. When the item is serialized out as xml, its value is "flowChartInternalStorage".
FlowChartDocument | Document Flow Shape. When the item is serialized out as xml, its value is "flowChartDocument".
FlowChartMultidocument | Multi-Document Flow Shape. When the item is serialized out as xml, its value is "flowChartMultidocument".
FlowChartTerminator | Terminator Flow Shape. When the item is serialized out as xml, its value is "flowChartTerminator".
FlowChartPreparation | Preparation Flow Shape. When the item is serialized out as xml, its value is "flowChartPreparation".
FlowChartManualInput | Manual Input Flow Shape. When the item is serialized out as xml, its value is "flowChartManualInput".
FlowChartManualOperation | Manual Operation Flow Shape. When the item is serialized out as xml, its value is "flowChartManualOperation".
FlowChartConnector | Connector Flow Shape. When the item is serialized out as xml, its value is "flowChartConnector".
FlowChartPunchedCard | Punched Card Flow Shape. When the item is serialized out as xml, its value is "flowChartPunchedCard".
FlowChartPunchedTape | Punched Tape Flow Shape. When the item is serialized out as xml, its value is "flowChartPunchedTape".
FlowChartSummingJunction | Summing Junction Flow Shape. When the item is serialized out as xml, its value is "flowChartSummingJunction".
FlowChartOr | Or Flow Shape. When the item is serialized out as xml, its value is "flowChartOr".
FlowChartCollate | Collate Flow Shape. When the item is serialized out as xml, its value is "flowChartCollate".
FlowChartSort | Sort Flow Shape. When the item is serialized out as xml, its value is "flowChartSort".
FlowChartExtract | Extract Flow Shape. When the item is serialized out as xml, its value is "flowChartExtract".
FlowChartMerge | Merge Flow Shape. When the item is serialized out as xml, its value is "flowChartMerge".
FlowChartOfflineStorage | Offline Storage Flow Shape. When the item is serialized out as xml, its value is "flowChartOfflineStorage".
FlowChartOnlineStorage | Online Storage Flow Shape. When the item is serialized out as xml, its value is "flowChartOnlineStorage".
FlowChartMagneticTape | Magnetic Tape Flow Shape. When the item is serialized out as xml, its value is "flowChartMagneticTape".
FlowChartMagneticDisk | Magnetic Disk Flow Shape. When the item is serialized out as xml, its value is "flowChartMagneticDisk".
FlowChartMagneticDrum | Magnetic Drum Flow Shape. When the item is serialized out as xml, its value is "flowChartMagneticDrum".
FlowChartDisplay | Display Flow Shape. When the item is serialized out as xml, its value is "flowChartDisplay".
FlowChartDelay | Delay Flow Shape. When the item is serialized out as xml, its value is "flowChartDelay".
FlowChartAlternateProcess | Alternate Process Flow Shape. When the item is serialized out as xml, its value is "flowChartAlternateProcess".
FlowChartOffpageConnector | Off-Page Connector Flow Shape. When the item is serialized out as xml, its value is "flowChartOffpageConnector".
ActionButtonBlank | Blank Button Shape. When the item is serialized out as xml, its value is "actionButtonBlank".
ActionButtonHome | Home Button Shape. When the item is serialized out as xml, its value is "actionButtonHome".
ActionButtonHelp | Help Button Shape. When the item is serialized out as xml, its value is "actionButtonHelp".
ActionButtonInformation | Information Button Shape. When the item is serialized out as xml, its value is "actionButtonInformation".
ActionButtonForwardNext | Forward or Next Button Shape. When the item is serialized out as xml, its value is "actionButtonForwardNext".
ActionButtonBackPrevious | Back or Previous Button Shape. When the item is serialized out as xml, its value is "actionButtonBackPrevious".
ActionButtonEnd | End Button Shape. When the item is serialized out as xml, its value is "actionButtonEnd".
ActionButtonBeginning | Beginning Button Shape. When the item is serialized out as xml, its value is "actionButtonBeginning".
ActionButtonReturn | Return Button Shape. When the item is serialized out as xml, its value is "actionButtonReturn".
ActionButtonDocument | Document Button Shape. When the item is serialized out as xml, its value is "actionButtonDocument".
ActionButtonSound | Sound Button Shape. When the item is serialized out as xml, its value is "actionButtonSound".
ActionButtonMovie | Movie Button Shape. When the item is serialized out as xml, its value is "actionButtonMovie".
Gear6 | Gear 6 Shape. When the item is serialized out as xml, its value is "gear6".
Gear9 | Gear 9 Shape. When the item is serialized out as xml, its value is "gear9".
Funnel | Funnel Shape. When the item is serialized out as xml, its value is "funnel".
MathPlus | Plus Math Shape. When the item is serialized out as xml, its value is "mathPlus".
MathMinus | Minus Math Shape. When the item is serialized out as xml, its value is "mathMinus".
MathMultiply | Multiply Math Shape. When the item is serialized out as xml, its value is "mathMultiply".
MathDivide | Divide Math Shape. When the item is serialized out as xml, its value is "mathDivide".
MathEqual | Equal Math Shape. When the item is serialized out as xml, its value is "mathEqual".
MathNotEqual | Not Equal Math Shape. When the item is serialized out as xml, its value is "mathNotEqual".
CornerTabs | Corner Tabs Shape. When the item is serialized out as xml, its value is "cornerTabs".
SquareTabs | Square Tabs Shape. When the item is serialized out as xml, its value is "squareTabs".
PlaqueTabs | Plaque Tabs Shape. When the item is serialized out as xml, its value is "plaqueTabs".
ChartX | Chart X Shape. When the item is serialized out as xml, its value is "chartX".
ChartStar | Chart Star Shape. When the item is serialized out as xml, its value is "chartStar".
ChartPlus | Chart Plus Shape. When the item is serialized out as xml, its value is "chartPlus".


TXTextControl.Drawing.MenuItem Class

The Drawing.MenuItem class represents a bindable Windows Forms ToolStripMenuItem. The MenuItem class is inherited from the System.Windows.Forms.ToolStripMenuItem class and implements the System.Windows.Forms.IBindableComponent interface. The following describes only the properties, methods and events defined through the MenuItem class. For a list of properties, methods and events inherited from the System.Windows.Forms.ToolStripMenuItem calss and System.Windows.Forms.IBindableComponent interface see the .NET Framework reference.

Introduced: 23.0.

Syntax

[C#]
public class MenuItem : System.Windows.Forms.ToolStripMenuItem, System.Windows.Forms.IBindableComponent
[Visual Basic]
Public Class MenuItem
  Inherits System.Windows.Forms.ToolStripMenuItem
  Implements System.Windows.Forms.IBindableComponent

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection Class

The Drawing.Selection class represents all selected shapes.

Introduced: 23.0.

Syntax

[C#]
public class Selection : System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class Dictionary
  Implements System.ComponentModel.INotifyPropertyChanged

Properties

Property | Description
CanBringForward | Gets value that indicates whether the selected shapes' levels can be increased by one.
CanBringToFront | Gets value that indicates whether the selected shape can be displayed as the uppermost shape of all shapes.
CanSendBackward | Gets value that indicates whether the selected shapes' levels can be decreased by one.
CanSendToBack | Gets value that indicates whether the selected shape can be displayed as the lowest shape of all shapes.
Shapes | Gets or set the selected shapes .

Methods

Method | Description
BringForward | Increases the selected shapes' levels by one.
BringToFront | Displays the selected shape as the uppermost shape of all shapes.
IsCommonValueSelected | Informs about whether an attribute from the Drawing.Selection.Attribute enumeration has the same value for the complete shapes selection.
SendBackward | Decreases the selected shapes' levels by one.
SendToBack | Displays the selected shape as the lowest shape of all shapes.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.CanBringForward Property

Gets value that indicates whether the selected shapes' levels can be increased by one. The property returns false if no shape is selected or one of the selected shapes is already the uppermost shape. In all other cases the property returns true.

Syntax

[C#]
public bool CanBringForward{ get; }
[Visual Basic]
Public ReadOnly Property CanBringForward() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.CanBringToFront Property

Gets value that indicates whether the selected shape can be displayed as the uppermost shape of all shapes. The property returns false if no or more than one shape are selected or one of the selected shape is already the uppermost shape. In all other cases the property returns true.

Syntax

[C#]
public bool CanBringToFront{ get; }
[Visual Basic]
Public ReadOnly Property CanBringToFront() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.CanSendBackward Property

Gets value that indicates whether the selected shapes' levels can be decreased by one. The property returns false if no shape is selected or one of the selected shapes is already the lowest shape. In all other cases the property returns true.

Syntax

[C#]
public bool CanSendBackward { get; }
[Visual Basic]
Public ReadOnly Property CanSendBackward() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.CanSendToBack Property

Gets value that indicates whether the selected shape can be displayed as the lowest shape of all shapes. The property returns false if no or more than one shape are selected or one of the selected shape is already the lowest shape. In all other cases the property returns true.

Syntax

[C#]
public bool CanSendToBack{ get; }
[Visual Basic]
Public ReadOnly Property CanSendToBack() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.Shapes Property

Gets or set the selected shapes .

Syntax

[C#]
public Drawing.Shape[] Shapes{ get; set;}
[Visual Basic]
Public Property Shapes() As Drawing.Shape()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.BringForward Method

Increases the selected shapes' levels by one. The method has no effect if the CanBringForward property returns false.

Syntax

[C#]
public void BringForward();
[Visual Basic]
Public Sub BringForward()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.BringToFront Method

Displays the selected shape as the uppermost shape of all shapes. The method has no effect if the CanBringToFront property returns false.

Syntax

[C#]
public void BringToFront();
[Visual Basic]
Public Sub BringToFront()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.SendBackward Method

Decreases the selected shapes' levels by one. The method has no effect if the CanSendBackward property returns false.

Syntax

[C#]
public void SendBackward();
[Visual Basic]
Public Sub SendBackward()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.SendToBack Method

Displays the selected shape as the lowest shape of all shapes. The method has no effect if the CanSendToBack property returns false.

Syntax

[C#]
public void SendToBack();
[Visual Basic]
Public Sub SendToBack()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Selection.IsCommonValueSelected Method

Informs about whether an attribute from the Drawing.Selection.Attribute enumeration has the same value for the complete shapes selection.

Syntax

[C#]
public bool IsCommonValueSelected(Drawing.Selection.Attribute attribute);
[Visual Basic]
Public Sub IsCommonValueSelected(ByVal attribute As Drawing.Selection.Attribute) As Boolean
Parameter | Description
attribute | Specifies a possible value from the Drawing.Selection.Attribute enumeration.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape Class

The Drawing.Shape class represents a shape which can be displayed inside the TX Drawing Control. The Outline class implements the System.ComponentModel.INotifyPropertyChanged interface.

Introduced: 23.0.

Syntax

[C#]
public class Shape : System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class Shape
  Implements System.ComponentModel.INotifyPropertyChanged

Constructors

Constructor | Description
Shape | Overloaded. Initializes a new instance of the Shape class.

Properties

Property | Description
Angle | Gets or sets the angle of the shape inside the TX Drawing Control.
AutoSize | Gets or sets a value indicating whether the shape is automatically resized with the TX Drawing Control.
Bounds | Gets or sets the bounding rectangle of the shape.
CanFitToCanvas | Gets a value which indicates whether the FitToCanvas method can be used or not.
Flip | Gets or sets whether and in what form the shape is flipped.
Index | Represents the index of the shape inside control's shape collection.
IsSelected | Gets a value which indicates whether the shape is selected or not.
Location | Gets or sets shape's current location.
Movable | Gets or sets a value which indicates whether the shape is movable or not.
ShapeFill | Gets the shape's fill properties.
ShapeOutline | Gets the shape's outline properties.
Sizable | Gets or sets a value which indicates whether the shape is sizable or not.
Size | Gets or sets the shape's current size.
Type | Gets or sets the shape's type.

Methods

Method | Description
FitToCanvas | Expands the shape to the control's canvas size.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape Constructor

Initializes a new instance of the Shape class.

Shape()

Creates a new instance of the Shape class by the ShapeType type ShapeType.Custom.

[C#]
public Shape();
[Visual Basic]
Public Sub New()

Shape(ShapeType)

Initializes a new instance of the Shape class by a specific ShapeType type.

[C#]
public Shape(Drawing.ShapeType type);
[Visual Basic]
Public Sub New(type As Drawing.ShapeType)
Parameter | Description
type | Specifies the shape's type.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Angle Property

Gets or sets the angle of the shape inside the TX Drawing Control. The default value is 0.

Syntax

[C#]
public int Angle{ get; set; }
[Visual Basic]
Public Property Angle() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.AutoSize Property

Gets or sets a value indicating whether the shape is automatically resized with the TX Drawing Control. The default value is false.

Syntax

[C#]
public bool AutoSize{ get; set; }
[Visual Basic]
Public Property AutoSize() As Boolean

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Bounds Property

Gets or sets the bounding rectangle of the shape. The values are given in twips with an origin at the upper left corner of the TX Drawing Control. The default value correspond to the shape's default Location and Size values.

Syntax

[C#]
public System.Drawing.Rectangle Bounds{ get; set; }
[Visual Basic]
Public Property Bounds() As System.Drawing.Rectangle

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.CanFitToCanvas Property

Gets a value which indicates whether the FitToCanvas method can be used or not.

Syntax

[C#]
public bool CanFitToCanvas{ get; }
[Visual Basic]
Public ReadOnly Property CanFitToCanvas() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Flip Property

Gets or sets whether and in what form the shape is flipped. The default value is Flip.None

Syntax

[C#]
public Drawing.Flip Flip{ get; set; }
[Visual Basic]
Public Property Flip() As Drawing.Flip

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Index Property

Represents the index of the shape inside control's shape collection.

Syntax

[C#]
public int Index{ get; }
[Visual Basic]
Public ReadOnly Property Index() As Integer

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Movable Property

Gets or sets a value which indicates whether the shape is movable or not. The default value is true.

Syntax

[C#]
public bool Movable{ get; set; }
[Visual Basic]
Public Property Movable() As Boolean

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.IsSelected Property

Gets a value which indicates whether the shape is selected or not. The default value is false.

Syntax

[C#]
public bool IsSelected{ get; }
[Visual Basic]
Public ReadOnly Property IsSelected() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Sizable Property

Gets or sets a value which indicates whether the shape is sizable or not. The default value is true.

Syntax

[C#]
public bool Sizable{ get; set; }
[Visual Basic]
Public Property Sizable() As Boolean

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Location Property

Gets or sets shape's current location. The values are given in twips with an origin at the upper left corner of the TX Drawing Control. The default values for Location.X and Location.Y correspond to one quarter the smallest control side.

Syntax

[C#]
public System.Drawing.Point Location{ get; set; }
[Visual Basic]
Public Property Location() As System.Drawing.Point

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.ShapeFill Property

Gets the shape's fill properties.

Syntax

[C#]
public Drawing.Shape.Fill ShapeFill{ get; }
[Visual Basic]
Public ReadOnly Property ShapeFill() As Drawing.Shape.Fill

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.ShapeOutline Property

Gets the shape's outline properties.

Syntax

[C#]
public Drawing.Shape.Outline Outline{ get; }
[Visual Basic]
Public ReadOnly Property Outline() As Drawing.Shape.Outline

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Size Property

Gets or sets the shape's current size. The values are given in twips. The default values for Size.Width and Size.Height correspond to one half the smallest control side.

Syntax

[C#]
public System.Drawing.Size Size{ get; set; }
[Visual Basic]
Public Property Size() As System.Drawing.Size

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Type Property

Gets or sets the shape's type. The default value is Drawing.ShapeType.Custom.

Syntax

[C#]
public Drawing.ShapeType Type{ get; set; }
[Visual Basic]
Public Property Type() As Drawing.ShapeType

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.FitToCanvas Method

Expands the shape to the control's canvas size. The method has no effect if the CanFitToCanvas property returns false.

Syntax

[C#]
public void FitToCanvas();
[Visual Basic]
Public Sub FitToCanvas()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Fill Class

The Drawing.Shape.Fill class determines the fill properties of a shape. The Fill class implements the System.ComponentModel.INotifyPropertyChanged interface.

Introduced: 23.0.

Syntax

[C#]
public class Fill : System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class Fill
  Implements System.ComponentModel.INotifyPropertyChanged

Properties

Property | Description
Color | Gets or sets the shape's fill color.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Fill.Color Property

Gets or sets the shape's fill color. The default value is a structure of type Systen.Drawing.Color with the values A=255, R=91, G=155 and B=213.

Syntax

[C#]
public System.Drawing.Color Color{ get; set; }
[Visual Basic]
Public Property Color() As System.Drawing.Color

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Outline Class

The Drawing.Shape.Outline class determines the line properties of a shape. The Outline class implements the System.ComponentModel.INotifyPropertyChanged interface.

Introduced: 23.0.

Syntax

[C#]
public class Outline : System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class Outline
  Implements System.ComponentModel.INotifyPropertyChanged

Properties

Property | Description
Color | Gets or sets the shape's line color.
Width | Gets or sets the shape's line width.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Outline.Color Property

Gets or sets the shape's line color. The default value is System.Drawing.Color.Black.

Syntax

[C#]
public System.Drawing.Color Color{ get; set; }
[Visual Basic]
Public Property Color() As System.Drawing.Color

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.Shape.Outline.Width Property

Gets or sets the shape's line width. The value is given in twips. The default value is 20.

Syntax

[C#]
public int Width{ get; set; }
[Visual Basic]
Public Property Width() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeCollection Class

An instance of the ShapeCollection class contains all displayed shapes represented through objects of type Shape. It is inherited from the abstract class System.Collections.CollectionBase and implements the System.Collections.IEnumerable and System.Collections.IEnumerator interfaces. For a list of properties, methods and events of these classes and interfaces see the .NET Framework reference.

Introduced: 23.0.

Syntax

[C#]
public class ShapeCollection: CollectionBase, IEnumerable, IEnumerator
[Visual Basic]
Public Class ShapeCollection
  Inherits CollectionBase
  Implements IEnumerable
  Implements IEnumerator

Methods

Method | Description
Add | Overloaded. Adds an object of the type Shape to the collection.
Insert | Inserts an object of the type Shape to the collection at a specified index.
Item | Gets an object of type Shape from the collection.
Remove | Removes an object of the type Shape from the collection.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeCollection.Add Method

Adds an object of the type Shape to the collection.

Add(Shape)

Adds an object of the type Shape to the collection. The shape is drawn at its defined location with its defined size.

[C#]
public int Add(Drawing.Shape shape);
[Visual Basic]
Public Function Add(shape As Drawing.Shape) As Integer
Parameter | Description
shape | Specifies the shape.

Add(Shape, AddStyle)

Adds an object of the type Shape to the collection. The addStyle parameter determines the location and size in which the shape is added.

[C#]
public int Add(Drawing.Shape shape, Drawing.ShapeCollection.AddStyle addStyle);
[Visual Basic]
Public Function Add(shape As Drawing.Shape, addStyle As Drawing.ShapeCollection.AddStyle) As Integer
Parameter | Description
shape | Specifies the shape.
addStyle | Specifies style how to add the shape to the collection.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeCollection.Insert Method

Inserts an object of the type Shape to the collection at a specified index.

Syntax

[C#]
public void Insert(int index, Drawing.Shape shape);
[Visual Basic]
Public Sub Insert(index As Integer, shape As Drawing.Shape)
Parameter | Description
index | Specifies the index where to insert the speicified shape.
shape | Specifies the shape to insert at the specified index.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeCollection.Item Property

Gets an object of type Shape from the collection. This property is the indexer for the ShapeCollection class.

Syntax

[C#]
public Drawing.Shape this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(number As Integer) As Drawing.Shape
Parameter | Description
number | The zero-based index of the shape.

Return Value

The object of the type Shape at the specified index.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeCollection.Remove Method

Removes an object of the type Shape from the collection.

Syntax

[C#]
public void Remove(Drawing.Shape shape);
[Visual Basic]
Public Sub Remove(shape As Drawing.Shape)
Parameter | Description
shape | Specifies the shape to remove.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeEventArgs Class

The ShapeEventArgs class provides data for all events that occur with shapes. These are the TXDrawingControl.ShapeAdjusted, TXDrawingControl.ShapeClicked, TXDrawingControl.ShapeCreated, TXDrawingControl.ShapeDeleted, TXDrawingControl.ShapeDeselected, TXDrawingControl.ShapeFlipped, TXDrawingControl.ShapeFormatChanged, TXDrawingControl.ShapeMoved, TXDrawingControl.ShapeSelected and TXDrawingControl.ShapeSized events.

Introduced: 23.0.

Syntax

[C#]
public class ShapeEventArgs: EventArgs
[Visual Basic]
Public Class ShapeEventArgs
  Inherits EventArgs

Properties

Property | Description
Shape | Gets an object of type Shape that represents the shape which causes the event.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapeEventArgs.Shape Property

Gets an object of type Shape that represents the shape which causes the event.

Syntax

[C#]
public Drawing.Shape Shape { get; }
[Visual Basic]
Public ReadOnly Property Shape() As Drawing.Shape

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapesContextMenuStrip Class

The Drawing.ShapesContextMenuStrip class represents the default context menu of the Windows Forms TXDrawingControl.

Introduced: 23.0.

Syntax

[C#]
public class ShapesContextMenuStrip : System.Windows.Forms.ContextMenuStrip
[Visual Basic]
Public Class ShapesContextMenuStrip
  Inherits System.Windows.Forms.ContextMenuStrip

Properties

Property | Description
SelectedShapesMenuItems | Returns an array of System.Windows.Forms.ToolStripItem objects that represents those items which are displayed in the context menu strip when the control is right clicked inside a shape.
StandardMenuItems | Returns an array of System.Windows.Forms.ToolStripItem objects that represents those items which are displayed in the context menu strip when the control is right clicked outside a shape.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapesContextMenuStrip.SelectedShapesMenuItems Property

Returns an array of System.Windows.Forms.ToolStripItem objects that represents those items which are displayed in the context menu strip when the control is right clicked inside a shape.

Syntax

[C#]
public System.Windows.Forms.ToolStripItem[] SelectedShapesMenuItems{ get; set; }
[Visual Basic]
Public Property SelectedShapesMenuItems() As System.Windows.Forms.ToolStripItem()

Default Values

Index 0: "Cut" (TXTextControl.Drawing.MenuItem)

Index 1: "Copy" (TXTextControl.Drawing.MenuItem)

Index 2: "Paste" (TXTextControl.Drawing.MenuItem)

Index 3: Separator (System.Windows.Forms.ToolStripSeparator)

Index 4: "Bring to Front" (TXTextControl.Drawing.MenuItem)

Index 5: "Send to Back" (TXTextControl.Drawing.MenuItem)

Index 6: "Flip" (TXTextControl.Drawing.MenuItem)

Index 7: Separator (System.Windows.Forms.ToolStripSeparator)

Index 8: "Movable" (TXTextControl.Drawing.MenuItem)

Index 9: "Sizable" (TXTextControl.Drawing.MenuItem)

Index 10: "Auto size" (TXTextControl.Drawing.MenuItem)

Index 11: "Fit to Canvas" (TXTextControl.Drawing.MenuItem)

Index 12: Separator (System.Windows.Forms.ToolStripSeparator)

Index 13: "Format..." (TXTextControl.Drawing.MenuItem)

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ShapesContextMenuStrip.StandardMenuItems Property

Returns an array of System.Windows.Forms.ToolStripItem objects that represents those items which are displayed in the context menu strip when the control is right clicked outside a shape.

Syntax

[C#]
public ToolStripItem[] StandardMenuItems{ get; set; }
[Visual Basic]
Public Property StandardMenuItems() As ToolStripItem()

Default Values

Index 0: "Paste" (TXTextControl.Drawing.MenuItem)

Index 1: "Select All" (TXTextControl.Drawing.MenuItem)

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl Class

The TXDrawingControl class implements a Windows Forms control with features to draw custom or predefined shapes. It can be added to a document with the TextControl.Drawings property. The TXDrawingControl class is inherited from the System.Windows.Forms.Control class and implements the System.ComponentModel.INotifyPropertyChanged interface. The following describes only the properties, methods and events defined through the TXDrawingControl class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class and the System.ComponentModel.INotifyPropertyChanged interface see the .NET Framework reference.

Introduced: 23.0.

Syntax

[C#]
public class TXDrawingControl : System.Windows.Forms.Control, System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class TXDrawingControl
  Inherits System.Windows.Forms.Control
  Implements System.ComponentModel.INotifyPropertyChanged

Constructors

Constructor | Description
TXDrawingControl | Initializes a new instance of the TXDrawingControl class.

Properties

Property | Description
BackColor | Gets or sets the TX Drawing Control's back color.
BorderColor | Gets or sets the TX Drawing Control's border line color.
BorderWidth | Gets or sets the TX Drawing Control's border line width.
CanCopy | Informs whether shapes are selected which can be copied to the internal clipboard.
CanPaste | Informs whether the internal clipboard contains shapes that can be pasted into the TX Drawing Control.
CanRedo | Informs whether an operation can be re-done using the Redo method.
CanUndo | Gets a value indicating whether the user can undo the previous operation in the TX Drawing Control.
IsCanvasVisible | Gets a value whether the TX Drawing Control is interpreted as canvas or not.
Selection | Gets an object of type Drawing.Selection that represents the current selected shapes inside the TX Drawing Control.
Shapes | Gets an object of type ShapeCollection that represents those shapes which are displayed inside the TX Drawing Control.
ZoomFactor | Gets or sets the zoom factor, in percent, for the TX Drawing Control.

Methods

Method | Description
ClearUndo | Clears the undo buffer of the TX Drawing Control.
Copy | Copies the current selected shapes of the TX Drawing Control to the Clipboard.
Cut | Moves the current selected shapes of the TX Drawing Control to the Clipboard.
FormatShapesDialog | Opens a dialog to format selected shapes.
Load | Loads shapes data into the TX Drawing Control from a specified object of type System.IO.Stream.
Paste | Pastes the content of the clipboard into the TX Drawing Control
PrintPaint | Overloaded. Renders the displayed shapes on the specified System.Drawing.Graphics object.
Redo | Redoes the last TX Drawing Control operation.
Save | Saves the shapes data to the given object of type System.IO.Stream.
SaveImage | Overloaded. Saves the displayed shapes as an image.
SelectAll | Selects all shapes in the TX Drawing Control.
SizeToContent | If any changes of the the displayed shapes' visible bounds require an adaption of the TX Drawing Control bounds, the size and/or location of the control is expanded respectively decreased by the considering value of the considering shape's side(s).
Undo | Undoes the last edit operation in the TX Drawing Control.

Events

Event | Description
AdaptBounds | Indicates that the visible bounds of the displayed shapes have been changed (by changing the shape's angle, outline width, yellow adjust rectangles or the control's border width) in so far that the control requires an update of its bounds.
Changed | Indicates that the number or formatting of the displayed shapes has been changed.
ShapeAdjusted | Occurs when a shape has been adjusted by using its yellow adjust rectangle.
ShapeClicked | Occurs when a shape has been clicked on.
ShapeCreated | Occurs when a new shape has been created.
ShapeDeleted | Occurs when a shape has been deleted from the TX Drawing Control's shapes collection.
ShapeDeselected | Occurs when a shape has been deselected.
ShapeFlipped | Occurs when a shape has been flipped.
ShapeFormatChanged | Occurs when shape formatting attributes which cannot be handled with the built-in mouse interface have been changed.
ShapeMoved | Occurs when a shape has been moved with the built-in mouse interface.
ShapeSelected | Occurs when a shape has been selected.
ShapeSized | Occurs when a shape has been sized with the built-in mouse interface.
ViewChanged | Occurs when UI manipulations such as shape moving or selection changing have caused the view to change.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl Constructor

Initializes a new instance of the TXDrawingControl class.

Syntax

[C#]
public TXDrawingControl();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.BackColor Property

Gets or sets the TX Drawing Control's back color. The default value is System.Drawing.Transparent.

Syntax

[C#]
public System.Drawing.Color BackColor{ get; set; }
[Visual Basic]
Public Property BackColor() As System.Drawing.Color

Limitations

A control's back color that differs to the default back color is only drawn if the control's IsCanvasVisible property return true. Otherwise the default value is used.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.BorderColor Property

Gets or sets the TX Drawing Control's border line color. The default value is System.Drawing.SystemColors.WindowText.

Syntax

[C#]
public System.Drawing.Color BorderColor{ get; set; }
[Visual Basic]
Public Property BorderColor() As System.Drawing.Color

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.BorderWidth Property

Gets or sets the TX Drawing Control's border line width. The value is given in twips. The default value is 0.

Syntax

[C#]
public int BorderWidth{ get; set; }
[Visual Basic]
Public Property BorderWidth() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.CanCopy Property

Informs whether shapes are selected which can be copied to the internal clipboard.

Syntax

[C#]
public bool CanCopy{ get; }
[Visual Basic]
Public ReadOnly Property CanCopy() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.CanPaste Property

Informs whether the internal clipboard contains shapes that can be pasted into the TX Drawing Control.

Syntax

[C#]
public bool CanPaste{ get; }
[Visual Basic]
Public ReadOnly Property CanPaste() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.CanRedo Property

Informs whether an operation can be re-done using the Redo method.

Syntax

[C#]
public bool CanRedo { get; }
[Visual Basic]
Public ReadOnly Property CanRedo() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.CanUndo Property

Gets a value indicating whether the user can undo the previous operation in the TX Drawing Control.

Syntax

[C#]
public bool CanUndo { get; }
[Visual Basic]
Public ReadOnly Property CanUndo() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.IsCanvasVisible Property

Gets a value whether the TX Drawing Control is interpreted as canvas or not. The control is not interpreted as canvas if it contains only one shape, the shape's CanFitToCanvas property is set to false, its AutoSize property is set to true and the control's BorderWidth property is 0. If the property's value is false the control can be thought of as a representation of the containing shape where bounds changes of the control lead to considering changes of the shape and vise versa.

Syntax

[C#]
public bool IsCanvasVisible{ get; }
[Visual Basic]
Public ReadOnly Property IsCanvasVisible() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Selection Property

Gets an object of type Drawing.Selection that represents the current selected shapes inside the TX Drawing Control.

Syntax

[C#]
public Drawing.Selection Selection{ get; }
[Visual Basic]
Public ReadOnly Property Selection()) As Drawing.Selection

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Shapes Property

Gets an object of type ShapeCollection that represents those shapes which are displayed inside the TX Drawing Control.

Syntax

[C#]
public Drawing.ShapeCollection Shapes{ get; }
[Visual Basic]
Public ReadOnly Property Shapes()) As Drawing.ShapeCollection

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ZoomFactor Property

Gets or sets the zoom factor, in percent, for the TX Drawing Control. When the value is changed both all drawn shapes and the control itself are resized considering to the specified zoom factor. To change the property value the control's Dock property has been set to DockStyle.None. Otherwise an exception is thrown. The default value is 100.

Syntax

[C#]
public int ZoomFactor{ get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ClearUndo Method

Clears the undo buffer of the TX Drawing Control.

Syntax

[C#]
public void ClearUndo();
[Visual Basic]
Public Sub ClearUndo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Copy Method

Copies the current selected shapes of the TX Drawing Control to the Clipboard.

Syntax

[C#]
public void Copy();
[Visual Basic]
Public Sub Copy()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Cut Method

Moves the current selected shapes of the TX Drawing Control to the Clipboard.

Syntax

[C#]
public void Cut();
[Visual Basic]
Public Sub Cut()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.FormatShapesDialog Method

Opens a dialog to format selected shapes.

Syntax

[C#]
public System.Windows.Forms.DialogResult FormatShapesDialog();
[Visual Basic]
Public Function FormatShapesDialog() As System.Windows.Forms.DialogResult

Return Value

The return value is DialogResult.OK if the OK button was pressed, DialogResult.Cancel if the dialog was cancelled and DialogResult.None if the dialog was not opened because no shape to format was selected.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Load Method

Loads shapes data into the TX Drawing Control from a specified object of type System.IO.Stream.

Syntax

[C#]
public void Load(System.IO.Stream stream);
[Visual Basic]
Public Sub Load(ByVal stream As System.IO.Stream)
Parameter | Description
stream | Specifies an object of type System.IO.Stream the data is loaded from. The data is loaded from the stream's current position.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Paste Method

Pastes the content of the clipboard into the TX Drawing Control

Syntax

[C#]
public void Paste();
[Visual Basic]
Public Sub Paste()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.PrintPaint Method

Renders the displayed shapes on the specified System.Drawing.Graphics object.

PrintPaint(Graphics, Rectangle)

Renders only the displayed shapes on the specified System.Drawing.Graphics object. No activated UI elements are rendered.

[C#]
public void PrintPaint(System.Drawing.Graphics graphics, System.Drawing.Rectangle position);
[Visual Basic]
Public Sub PrintPaint(ByVal graphics As System.Drawing.Graphics, ByVal position As System.Drawing.Rectangle)
Parameter | Description
graphics | Specifies the object of type System.Drawing.Graphics the displayed shapes are rendered to.
position | Specifies the position to draw on the specified System.Drawing.Graphics object.

PrintPaint(Graphics, Rectangle, Boolean)

Renders the displayed shapes on the specified System.Drawing.Graphics object with or without activated UI elements.

[C#]
public void PrintPaint(System.Drawing.Graphics graphics, System.Drawing.Rectangle position, bool showUIElements);
[Visual Basic]
Public Sub PrintPaint(ByVal graphics As System.Drawing.Graphics, ByVal position As System.Drawing.Rectangle, ByVal showUIElements As Boolean)
Parameter | Description
graphics | Specifies the object of type System.Drawing.Graphics the displayed shapes are rendered to.
position | Specifies the position to draw on the specified System.Drawing.Graphics object.
showUIElements | Specifies whether the activated UI elements are rendered on the specified System.Drawing.Graphics object or not.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Redo Method

Redoes the last TX Drawing Control operation.

Syntax

[C#]
public void Redo();
[Visual Basic]
Public Sub Redo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Save Method

Saves the shapes data to the given object of type System.IO.Stream.

Syntax

[C#]
public void Save(System.IO.Stream stream);
[Visual Basic]
Public Sub Save(ByVal stream As System.IO.Stream)
Parameter | Description
stream | Specifies an object of type System.IO.Stream the data is saved to.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.SaveImage Method

Saves the displayed shapes as an image.

SaveImage(Stream, ImageFormat)

Saves the displayed shapes as an image to the specified object of type System.IO.Stream.

[C#]
public void SaveImage(System.IO.Stream imageStream, System.Drawing.Imaging.ImageFormat format);
[Visual Basic]
Public Sub SaveImage(ByVal imageStream As System.IO.Stream, ByVal format As System.Drawing.Imaging.ImageFormat)
Parameter | Description
imageStream | Specifies an object of type System.IO.Stream the image is saved to.
format | Specifies the format used to save the image.

SaveImage(String, ImageFormat)

Saves the displayed shapes as an image to the specified file using the specified format.

[C#]
public void SaveImage(string imageFileName, System.Drawing.Imaging.ImageFormat format);
[Visual Basic]
ublic Sub SaveImage(ByVal imageFileName As String, ByVal format As System.Drawing.Imaging.ImageFormat)
Parameter | Description
imageFileName | Specifies a file the image is saved to.
format | Specifies the format used to save the image.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.SelectAll Method

Selects all shapes in the TX Drawing Control.

Syntax

[C#]
public void SelectAll();
[Visual Basic]
Public Sub SelectAll()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.SizeToContent Method

If any changes of the the displayed shapes' visible bounds require an adaption of the TX Drawing Control bounds, the size and/or location of the control is expanded respectively decreased by the considering value of the considering shape's side(s). The method returns an array of doubles which represent the effected alteration for each control's side (left, top, right, bottom) in Twips.

Syntax

[C#]
public int[] SizeToContent();
[Visual Basic]
Public Sub SizeToContent() As Integer()

Return Value

An array of integers which represent the effected extension for each control's side (left, top, right, bottom) in Twips.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Undo Method

Undoes the last edit operation in the TX Drawing Control.

Syntax

[C#]
public void Undo();
[Visual Basic]
Public Sub Undo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.AdaptBounds Event

Indicates that the visible bounds of the displayed shapes have been changed (by changing the shape's angle, outline width, yellow adjust rectangles or the control's border width) in so far that the control requires an update of its bounds. The event always raises if the visible bounds exceed the control's bounds. If IsCanvasVisible is false, AdaptBounds is also raised if considering changes lead to a decreasing of the visible shape bounds. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler AdaptBounds;
[Visual Basic]
Public Event AdaptBounds As EventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.Changed Event

Indicates that the number or formatting of the displayed shapes has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Changed;
[Visual Basic]
Public Event Changed As EventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeAdjusted Event

Occurs when a shape has been adjusted by using its yellow adjust rectangle. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeAdjusted;
[Visual Basic]
Public Event ShapeAdjusted As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeClicked Event

Occurs when a shape has been clicked on. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeClicked;
[Visual Basic]
Public Event ShapeClicked As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeCreated Event

Occurs when a new shape has been created. It occurs, when a shape has been inserted in TX Drawing Control's shapes collection by pasting or using the shape collection's Add method. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeCreated;
[Visual Basic]
Public Event ShapeCreated As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeDeleted Event

Occurs when a shape has been deleted from the TX Drawing Control's shapes collection. It occurs by cutting or using the shape collection's Remove, RemoveAt or Clear method. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeDeleted;
[Visual Basic]
Public Event ShapeDeleted As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeDeselected Event

Occurs when a shape has been deselected. It occurs by removing a shape from the TXDrawingControl.Selection.Shapes property or, if the number of selected shapes is greater than 0, clicking on a location inside the TX Drawing Control where no shape is located. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeDeselected;
[Visual Basic]
Public Event ShapeDeselected As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeFlipped Event

Occurs when a shape has been flipped. It occurs by using the shape's Flip property or sizing a shape manually by mouse in so far as the shape is flipped horizontally or vertically. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeFlipped;
[Visual Basic]
Public Event ShapeFlipped As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeFormatChanged Event

Occurs when shape formatting attributes which cannot be handled with the built-in mouse interface have been changed. The corresponding attributes are the shape's ShapeFill, ShapeOutline are Type properties. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeFormatChanged;
[Visual Basic]
Public Event ShapeFormatChanged As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeMoved Event

Occurs when a shape has been moved with the built-in mouse interface. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeMoved;
[Visual Basic]
Public Event ShapeMoved As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeSelected Event

Occurs when a shape has been selected. It occurs by using the select all method, changing the TXDrawingControl.Selection.Shapes property or selecting shapes manually by the built-in mouse interface . The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeSelected;
[Visual Basic]
Public Event ShapeSelected As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ShapeSized Event

Occurs when a shape has been sized with the built-in mouse interface. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventArgs ShapeSized;
[Visual Basic]
Public Event ShapeSized As Drawing.ShapeEventArgs

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.TXDrawingControl.ViewChanged Event

Occurs when UI manipulations such as shape moving or selection changing have caused the view to change. The event handler receives an argument of type ViewChangedEventArgs containing data related to this event.

Syntax

[C#]
public event ViewChangedEventArgs ViewChanged;
[Visual Basic]
Public Event ViewChanged As ViewChangedEventArgs

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ViewChangedEventArgs Class

The ViewChangedEventArgs class provides data for the TXDrawingControl.ViewChanged event.

Introduced: 24.0.

Syntax

[C#]
public class ViewChangedEventArgs: EventArgs
[Visual Basic]
Public Class ViewChangedEventArgs
  Inherits EventArgs

Properties

Property | Description
ClipRectangle | Gets an object of type System.Drawing.Rectangle that represents the region where the control view is changed by UI editing.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Drawing.ViewChangedEventArgs.ClipRectangle Property

Gets an object of type System.Drawing.Rectangle that represents the region where the control view is changed by UI editing.

Syntax

[C#]
public System.Drawing.Rectangle ClipRectangle { get; }
[Visual Basic]
Public ReadOnly Property ClipRectangle() As System.Drawing.Rectangle

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.ServerVisualization namespace

TXTextControl.ServerVisualization.CaretStateEventArgs Class

TXTextControl.ServerVisualization.DialogViewGenerator Class

TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs Class

TXTextControl.ServerVisualization.DrawShapeEventArgs Class

TXTextControl.ServerVisualization.MenuItem Class

TXTextControl.ServerVisualization.RulerBarViewGenerator Class

TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors Class

TXTextControl.ServerVisualization.ShowDialogBoxEventArgs Class

TXTextControl.ServerVisualization.ShowErrorMessageEventArgs Class

TXTextControl.ServerVisualization.StatusBarViewGenerator Class

TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors Class

TXTextControl.ServerVisualization.TextContextMenuEventArgs Class

TXTextControl.ServerVisualization.TextViewGenerator Class

TXTextControl.ServerVisualization.TextViewGenerator.Colors Class

TXTextControl.ServerVisualization.UserInput Class

TXTextControl.ServerVisualization.View Class

TXTextControl.ServerVisualization.ViewChangedEventArgs Class


TXTextControl.ServerVisualization.CaretStateEventArgs Class

The CaretStateEventArgs class provides data about the state of the caret, such as position, size and visibility. It is used with the CaretStateChanged event of the ServerVisualization.TextViewGenerator and the ServerVisualization.DialogViewGenerator class.

Introduced: 21.0.

Syntax

[C#]
public class CaretStateEventArgs: EventArgs
[Visual Basic]
Public Class CaretStateEventArgs
  Inherits EventArgs

Properties

Property | Description
Direction | Gets the caret's direction.
Location | Gets the caret's location in pixels.
Size | Gets the caret's visibility.
Visibility | Gets the caret's visibility.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.CaretStateEventArgs.Direction Property

Gets the caret's direction.

Syntax

[C#]
public Direction Direction { get; }
[Visual Basic]
Public ReadOnly Property Direction() As Direction
Value | Description
LeftToRight | The writing direction is left to right.
RightToLeft | The writing direction is right to left.

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.CaretStateEventArgs.Location Property

Gets the caret's location in pixels.

Syntax

[C#]
public System.Drawing.Point Location { get; }
[Visual Basic]
Public ReadOnly Property Location() As System.Drawing.Point

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.CaretStateEventArgs.Size Property

Gets the caret's visibility.

Syntax

[C#]
public System.Drawing.Size Size { get; }
[Visual Basic]
Public ReadOnly Property Size() As System.Drawing.Size

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.CaretStateEventArgs.Visibility Property

Gets the caret's visibility.

Syntax

[C#]
public bool Visibility { get; }
[Visual Basic]
Public ReadOnly Property Visibility() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator Class

An instance of the DialogViewGenerator class can be used to visualize a built-in dialog box through an image. It manages a ServerVisualization.UserInput and a ServerVisualization.View object. These objects can be used to inform the generator about user input and to get a generated view depending on the input.

Introduced: 21.0.

Syntax

[C#]
public class DialogViewGenerator : Component
[Visual Basic]
Public Class DialogViewGenerator
Inherits Component

Properties

Property | Description
ActivationState | Gets or sets a value indicating the dialog box's activation state.
Caption | Gets the dialog box's caption.
UserInput | Gets the dialog box's UserInput object, which can be used to inform the dialog box about user input.
View | Gets the dialog box's View object, which informs about view changes and provides an image of the dialog box's current state.

Events

Event | Description
CaretStateChanged | Occurs when the state of the caret (size, position, visibility) has been changed.
Closed | Occurs after the dialog box has been closed through clicking the Ok or Cancel button.
ShowDialogBox | Occurs when the dialog box should show a further dialog box.
ShowErrorMessage | Occurs when the dialog box should show an error message.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.ActivationState Property

Gets or sets a value indicating the dialog box's activation state. It can be activated, deactivated or disabled.

Syntax

[C#]
public ActivationState ActivationState { get; set; }
[Visual Basic]
Public Property ActivationState() As ActivationState
Value | Description
Activated | The dialog box is activated, which means that it has the keyboard input focus.
Deactivated | The dialog box is deactivated, which means that it does not have the keyboard input focus.
Disabled | The dialog box is disabled, which means that it cannot get the keyboard input focus.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.Caption Property

Gets the dialog box's caption.

Syntax

[C#]
public string Caption { get; }
[Visual Basic]
Public ReadOnly Property Caption() As String

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.CaretStateChanged Event

Occurs when the state of the caret (size, position, visibility) has been changed. The event handler receives an argument of type ServerVisualization.CaretStateEventArgs containing data related to this event.

Syntax

[C#]
public event CaretStateEventHandler CaretStateChanged;
[Visual Basic]
Public Event CaretStateChanged As CaretStateEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.Closed Event

Occurs after the dialog box has been closed through clicking the Ok or Cancel button. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Closed;
[Visual Basic]
Public Event Closed As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.ShowDialogBox Event

Occurs when the dialog box should show a further dialog box. The event handler receives an argument of type ServerVisualization.ShowDialogBoxEventArgs containing data related to this event.

Syntax

[C#]
public event ShowDialogBoxEventHandler ShowDialogBox;
[Visual Basic]
Public Event ShowDialogBox As ShowDialogBoxEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.ShowErrorMessage Event

Occurs when the dialog box should show an error message. The event handler receives an argument of type ServerVisualization.ShowErrorMessageEventArgs containing data related to this event.

Syntax

[C#]
public event ShowErrorMessageEventHandler ShowErrorMessage;
[Visual Basic]
Public Event ShowErrorMessage As ShowErrorMessageEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.UserInput Property

Gets the dialog box's UserInput object, which can be used to inform the dialog box about user input. The generator uses this information to generate a new view.

Syntax

[C#]
public UserInput UserInput { get; }
[Visual Basic]
Public ReadOnly Property UserInput() As UserInput

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DialogViewGenerator.View Property

Gets the dialog box's View object, which informs about view changes and provides an image of the dialog box's current state.

Syntax

[C#]
public View View { get; }
[Visual Basic]
Public ReadOnly Property View() As View

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs Class

The DocumentSizeChangedEventArgs class informs about a changed document size. The size of the document changes, if there are more or less pages, or if the size of the pages has been changed.

Introduced: 21.0.

Syntax

[C#]
public class DocumentSizeChangedEventArgs: EventArgs
[Visual Basic]
Public Class DocumentSizeChangedEventArgs
  Inherits EventArgs

Properties

Property | Description
Height | Gets the document's height, in twips.
Width | Gets the document's width, in twips.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs.Height Property

Gets the document's height, in twips.

Syntax

[C#]
public int Height { get; }
[Visual Basic]
Public ReadOnly Property Height() As Integer

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DocumentSizeChangedEventArgs.Width Property

Gets the document's width, in twips.

Syntax

[C#]
public int Width { get; }
[Visual Basic]
Public ReadOnly Property Width() As Integer

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DrawShapeEventArgs Class

The DrawShapeEventArgs class contains information to draw additional parts necessary when the user interacts with the document. These additional parts are the frame shown during an image or textframe is moved or sized and the line shown during the width of a table cell is changed. This class is used with the ServerVisualization.TextViewGenerator.DrawShape event.

Introduced: 21.0.

Syntax

[C#]
public class DrawShapeEventArgs: EventArgs
[Visual Basic]
Public Class DrawShapeEventArgs
  Inherits EventArgs

Properties

Property | Description
Kind | Gets the kind of the shape.
Location | Gets the location of the shape, in pixels.
Size | Gets the size of the shape, in pixels.

Enumerations

Enumeration | Description
Shape | Determines a shape to be drawn during the DrawShape event.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DrawShapeEventArgs.Kind Property

Gets the kind of the shape. It can be one of the ServerVisualization.DrawShapeEventArgs.Shape values.

Syntax

[C#]
public Shape Kind { get; }
[Visual Basic]
Public ReadOnly Property Kind() As Shape

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DrawShapeEventArgs.Location Property

Gets the location of the shape, in pixels.

Syntax

[C#]
public System.Drawing.Point Location { get; }
[Visual Basic]
Public ReadOnly Property Location() As System.Drawing.Point

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DrawShapeEventArgs.Shape Enumeration

Determines a shape to be drawn during the DrawShape event. It contains the following values:

Member | Description
DropCaret | Determines the rectangle indicating the text input position where text is inserted during a drag and drop operation.
MoveAndSizeFrame | Determines the frame which is drawn when an image or textframe is moved or sized.
TableBorderMovingLine | Determines the line which is drawn when the width of a table cell is changed. This shape's horizontal size is set to 1 pixel.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.DrawShapeEventArgs.Size Property

Gets the size of the shape, in pixels.

Syntax

[C#]
public System.Drawing.Size Size { get; }
[Visual Basic]
Public ReadOnly Property Size() As System.Drawing.Size

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem Class

The MenuItem class provides all data necessary to visualize a menu item, such as the menu's text and the menu's image. An item has an Items property specifying a submenu. If there is no text specified, the menu item is a separator.

Introduced: 21.0.

Syntax

[C#]
public class MenuItem
[Visual Basic]
Public Class MenuItem

Properties

Property | Description
Checked | Gets a value indicating whether the menu item is checked.
Enabled | Gets a value indicating whether the menu item is enabled.
Image | Gets the menu item's image.
Items | Gets an array of ServerVisualization.MenuItem objects specifying a submenu.
Text | Gets the menu item's text.

Methods

Method | Description
Execute | Executes the menu item.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Checked Property

Gets a value indicating whether the menu item is checked.

Syntax

[C#]
public bool Checked { get; }
[Visual Basic]
Public ReadOnly Property Checked() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Enabled Property

Gets a value indicating whether the menu item is enabled.

Syntax

[C#]
public bool Enabled { get; }
[Visual Basic]
Public ReadOnly Property Enabled() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Execute Method

Executes the menu item. When the menu item opens a dialog box, the method creates and returns a DialogViewGenerator object. Otherwise it performs changes in the document.

Syntax

[C#]
public DialogViewGenerator Execute();
[Visual Basic]
Public Sub Execute() As DialogViewGenerator

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Image Property

Gets the menu item's image. If the property's value is null, the menu item has no image.

Syntax

[C#]
public System.Drawing.Bitmap Image { get; }
[Visual Basic]
Public ReadOnly Property Image() As System.Drawing.Bitmap

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Items Property

Gets an array of ServerVisualization.MenuItem objects specifying a submenu. These objects contain all data necessary to display the submenu. If the property's value is null, the item has no submenu.

Syntax

[C#]
public MenuItem[] Items { get; }
[Visual Basic]
Public ReadOnly Property Items() As MenuItem()

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.MenuItem.Text Property

Gets the menu item's text. If the property's value is null, the menu item is a separator.

Syntax

[C#]
public string Text { get; }
[Visual Basic]
Public ReadOnly Property Text() As String

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator Class

An instance of the RulerBarViewGenerator class can be used to visualize a ruler bar through an image. It manages a ServerVisualization.UserInput and a ServerVisualization.View object. These objects can be used to inform the generator about user input and to get a generated view depending on the input. A RulerBarViewGenerator object can be connected with a TextViewGenerator object to show the formatting attributes at the curent text input position. The RulerBarViewGenerator class is inherited from the System.ComponentModel.Component class. The following describes only the properties, methods and events defined through the RulerBarViewGenerator class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 21.0.

Syntax

[C#]
public class RulerBarViewGenerator : System.ComponentModel.Component
[Visual Basic]
Public Class RulerBarViewGenerator
  Inherits System.ComponentModel.Component

Constructors

Constructor | Description
RulerBarViewGenerator | Initializes a new instance of the RulerBarViewGenerator class.

Properties

Property | Description
Alignment | Gets or sets a value specifying the alignment of the ruler bar in the document.
BorderStyle | Gets or sets the border style of the ruler bar.
DisplayColors | Gets or sets the colors of the ruler bar.
EnablePageMargins | Enables or disables the setting of page margins.
Location | Gets or sets a location, in pixels.
ReadOnly | Gets or sets a value determining the ruler bar's read only mode.
ScaleUnit | Gets or sets the unit of the ruler bar's scale.
UserInput | Gets the UserInput object, which can be used to inform the RulerBarViewGenerator about user input.
View | Gets the View object, which informs about view changes and provides an image of the RulerBarViewGenerator's current state.

Methods

Method | Description
Create | Initializes the resources of a newly instantiated object.
ResetDisplayColors | Resets all display colors of a ruler bar to their system dependent default values.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator Constructor

Initializes a new instance of the RulerBarViewGenerator class. After initialization the Create method must be called to enable further resources.

Syntax

[C#]
public RulerBarViewGenerator();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Alignment Property

Gets or sets a value specifying the alignment of the ruler bar in the document. Depending on the alignment either a horizontal or a vertical ruler is displayed.

Syntax

[C#]
public RulerBarAlignment Alignment { get; set; }
[Visual Basic]
Public Property Alignment As RulerBarAlignment
Value | Description
Left | The ruler bar is displayed with a vertical ruler.
Top | The ruler bar is displayed with a horizontal ruler.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.BorderStyle Property

Gets or sets the border style of the ruler bar.

Syntax

[C#]
public RulerBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle As RulerBarBorderStyle
Value | Description
ColorScheme | The ruler bar has a flat design without a border. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The ruler bar has a flat design and no border.
FixedSingle | The ruler bar has has a flat design and a border with a single line.
Simple3D | The ruler bar has a 3D design and no border.
Fixed3D | The ruler bar has a 3D design and a border with a single line.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Create Method

Initializes the resources of a newly instantiated object. This method must be called before using the object. To release created resources, Dispose should be called after using the object.

Syntax

[C#]
public bool Create();
[Visual Basic]
Public Function Create() As Boolean

Return Value

The return value is true, if the object could be initialized. Otherwise, it is false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.DisplayColors Property

Gets or sets the colors of the ruler bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type ServerVisualization.RulerBarViewGenerator.Colors.

Syntax

[C#]
public RulerBarViewGenerator.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As RulerBarViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.EnablePageMargins Property

Enables or disables the setting of page margins. If the property's value is true, the setting of page margins is enabled.

Syntax

[C#]
public bool EnablePageMargins { get; set; }
[Visual Basic]
Public Property EnablePageMargins As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Location Property

Gets or sets a location, in pixels. When a RulerBarViewGenerator object is connected with a TextViewGenerator object, this location is used to adjust the ruler with the text. It determines the position of the ruler image relative to the text image.

Syntax

[C#]
public System.Drawing.Point Location { get; set; }
[Visual Basic]
Public Property Location() As System.Drawing.Point

Limitations

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.ReadOnly Property

Gets or sets a value determining the ruler bar's read only mode. When the ruler bar is set to read only, it still shows all formatting attributes of the connected TextControl, but formatting attributes cannot be changed.

Introduced: 24.0.

Syntax

[C#]
public bool ReadOnly { get; set; }
[Visual Basic]
Public Property ReadOnly As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.ResetDisplayColors Method

Resets all display colors of a ruler bar to their system dependent default values.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.ScaleUnit Property

Gets or sets the unit of the ruler bar's scale.

Syntax

[C#]
public RulerBarScaleUnit ScaleUnit { get; set; }
[Visual Basic]
Public Property ScaleUnit As RulerBarScaleUnit
Value | Description
Auto | The ruler is automatically scaled in inch or in millimeter depending on the currently set culture.
Centimeter | The ruler bar is scaled in centimeter without millimeter marks.
Inch | The ruler bar is scaled in inch.
Millimeter | The ruler bar is scaled in centimeter including millimeter marks.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.UserInput Property

Gets the UserInput object, which can be used to inform the RulerBarViewGenerator about user input. The generator uses this information to generate a new view.

Syntax

[C#]
public UserInput UserInput { get; }
[Visual Basic]
Public ReadOnly Property UserInput() As UserInput

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.View Property

Gets the View object, which informs about view changes and provides an image of the RulerBarViewGenerator's current state.

Syntax

[C#]
public View View { get; }
[Visual Basic]
Public ReadOnly Property View() As View

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors Class

The ServerVisualization.RulerBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.RulerBarViewGenerator component. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the ruler bar's BorderStyle property has been set to ColorScheme.

Introduced: 21.0.

Syntax

[C#]
public class RulerBarViewGenerator.Colors
[Visual Basic]
Public Class RulerBarViewGenerator.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the RulerBarViewGenerator.Colors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left or top edge of the ruler bar.
ForeColor | Gets or sets the color used for the numbers of the ruler.
GradientBackColor | Gets or sets the background color at the right or bottom edge of the ruler bar.
RulerColor | Gets or sets the color of the ruler.
SeparatorColorDark | Gets or sets the color of dark separators.
SeparatorColorLight | Gets or sets the color of light separators.

Methods

Method | Description
ResetBackColor | Resets the ruler bar's BackColor to its system dependent default value.
ResetForeColor | Resets the ruler bar's ForeColor to its system dependent default value.
ResetGradientBackColor | Resets the ruler bar's GradientBackColor to its system dependent default value.
ResetRulerColor | Resets the ruler bar's RulerColor to its system dependent default value.
ResetSeparatorColorDark | Resets the ruler bar's SeparatorColorDark to its system dependent default value.
ResetSeparatorColorLight | Resets the ruler bar's SeparatorColorLight to its system dependent default value.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors Constructor

Initializes a new instance of the RulerBarViewGenerator.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public RulerBarViewGenerator.Colors();
[Visual Basic]
Public Class RulerBarViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.BackColor Property

Gets or sets the background color at the left or top edge of the ruler bar.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ForeColor Property

Gets or sets the color used for the numbers of the ruler.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.GradientBackColor Property

Gets or sets the background color at the right or bottom edge of the ruler bar.

Syntax

[C#]
public Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetBackColor Method

Resets the ruler bar's BackColor to its system dependent default value.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetForeColor Method

Resets the ruler bar's ForeColor to its system dependent default value.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetGradientBackColor Method

Resets the ruler bar's GradientBackColor to its system dependent default value.

Syntax

[C#]
public void ResetGradientBackColor();
[Visual Basic]
Public Sub ResetGradientBackColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetRulerColor Method

Resets the ruler bar's RulerColor to its system dependent default value.

Syntax

[C#]
public void ResetRulerColor();
[Visual Basic]
Public Sub ResetRulerColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetSeparatorColorDark Method

Resets the ruler bar's SeparatorColorDark to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorDark();
[Visual Basic]
Public Sub ResetSeparatorColorDark()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.ResetSeparatorColorLight Method

Resets the ruler bar's SeparatorColorLight to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorLight();
[Visual Basic]
Public Sub ResetSeparatorColorLight()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.RulerColor Property

Gets or sets the color of the ruler.

Syntax

[C#]
public Color RulerColor { get; set; }
[Visual Basic]
public Property RulerColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.SeparatorColorDark Property

Gets or sets the color of dark separators.

Syntax

[C#]
public Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.RulerBarViewGenerator.Colors.SeparatorColorLight Property

Gets or sets the color of light separators.

Syntax

[C#]
public Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ShowDialogBoxEventArgs Class

The ShowDialogBoxEventArgs class provides a DialogViewGenerator object which can be used to show a further dialog box from a parent dialog box. It is used with the ServerVisualization.DialogViewGenerator.ShowDialogBox event.

Introduced: 21.0.

Syntax

[C#]
public class ShowDialogBoxEventArgs: EventArgs
[Visual Basic]
Public Class ShowDialogBoxEventArgs
  Inherits EventArgs

Properties

Property | Description
DialogBox | Gets a DialogViewGenerator object which can be used to show the child dialog box.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ShowDialogBoxEventArgs.DialogBox Property

Gets a DialogViewGenerator object which can be used to show the child dialog box.

Syntax

[C#]
public DialogViewGenerator DialogBox { get; }
[Visual Basic]
Public ReadOnly Property DialogBox() As DialogViewGenerator

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ShowErrorMessageEventArgs Class

The ShowErrorMessageEventArgs class provides a string which should be shown as an error message for the end-user. It is used with the ServerVisualization.DialogViewGenerator.ShowErrorMessage event.

Introduced: 21.0.

Syntax

[C#]
public class ShowErrorMessageEventArgs: EventArgs
[Visual Basic]
Public Class ShowErrorMessageEventArgs
  Inherits EventArgs

Properties

Property | Description
ErrorMessage | Gets the error message.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ShowErrorMessageEventArgs.ErrorMessage Property

Gets the error message.

Syntax

[C#]
public string ErrorMessage { get; }
[Visual Basic]
Public ReadOnly Property ErrorMessage() As String

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator Class

An instance of the StatusBarViewGenerator class can be used to visualize a status bar through an image. It manages a ServerVisualization.UserInput and a ServerVisualization.View object. These objects can be used to inform the generator about user input and to get a generated view depending on the input. A StatusBarViewGenerator object can be connected with a TextViewGenerator object to show the position of the curent text input position and other status information. The StatusBarViewGenerator class is inherited from the System.ComponentModel.Component class. The following describes only the properties, methods and events defined through the StatusBarViewGenerator class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 21.0.

Syntax

[C#]
public class StatusBarViewGenerator : System.ComponentModel.Component
[Visual Basic]
Public Class StatusBarViewGenerator
  Inherits System.ComponentModel.Component

Constructors

Constructor | Description
StatusBarViewGenerator | Initializes a new instance of the StatusBarViewGenerator class.

Properties

Property | Description
BorderStyle | Gets or sets the border style of the status bar.
ColumnText | Gets or sets the text in the 'Column' area of the status bar.
DisplayColors | Gets or sets the colors of the status bar.
Font | Gets or sets the font which is used to display text.
LineText | Gets or sets the text in the 'Line' area of the status bar.
PageCounterText | Gets or sets the text in the 'Page counter' area of the status bar.
PageText | Gets or sets the text in the 'Page' area of the status bar.
SectionCounterText | Gets or sets the text in the 'Section counter' area of the status bar.
SectionText | Gets or sets the text in the 'Section' area of the status bar.
ShowColumn | Specifies whether the status bar shows the column number of the current text input position.
ShowKeyStates | Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.
ShowLanguage | Specifies whether the status bar shows the language of the text selection or the text input position.
ShowLine | Specifies whether the status bar shows the line number of the current text input position.
ShowPage | Specifies whether the status bar shows the page number of the current text input position.
ShowPageCounter | Specifies whether the status bar shows the number of pages the document consists of.
ShowSection | Specifies whether the status bar shows the section number of the current text input position.
ShowSectionCounter | Specifies whether the status bar shows the number of sections the document consists of.
ShowZoom | Specifies whether the status bar shows the current zoom factor.
ShowZoomTrackBar | Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.
UserInput | Gets the UserInput object, which can be used to inform the StatusBarViewGenerator about user input.
View | Gets the View object, which informs about view changes and provides an image of the StatusBarViewGenerator's current state.

Methods

Method | Description
Create | Initializes the resources of a newly instantiated object.
ResetDisplayColors | Resets all display colors of a status bar to their system dependent default values.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator Constructor

Initializes a new instance of the StatusBarViewGenerator class. After initialization the Create method must be called to enable further resources.

Syntax

[C#]
public StatusBarViewGenerator();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.BorderStyle Property

Gets or sets the border style of the status bar.

Syntax

[C#]
public StatusBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle() As StatusBarBorderStyle
Value | Description
ColorScheme | The status bar has a flat design without a border and with a horizontal color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The status bar has a flat design and no border.
FixedSingle | The status bar has a flat design and a border with a single line.
Simple3D | The status bar has a 3D design and no border.
Fixed3D | The status bar has a 3D design and a border with a single line.
VerticalColorScheme | The status bar has a flat design without a border and with a vertical color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ColumnText Property

Gets or sets the text in the 'Column' area of the status bar.

Syntax

[C#]
public string ColumnText { get; set; }
[Visual Basic]
Public Property ColumnText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Create Method

Initializes the resources of a newly instantiated object. This method must be called before using the object. To release created resources, Dispose should be called after using the object.

Syntax

[C#]
public bool Create();
[Visual Basic]
Public Function Create() As Boolean

Return Value

The return value is true, if the object could be initialized. Otherwise, it is false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.DisplayColors Property

Gets or sets the colors of the status bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type ServerVisualization.StatusBarViewGenerator.Colors.

Syntax

[C#]
public ServerVisualization.StatusBarViewGenerator.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As ServerVisualization.StatusBarViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Font Property

Gets or sets the font which is used to display text.

Syntax

[C#]
public System.Drawing.Font Font { get; set; }
[Visual Basic]
Public Property Font() As System.Drawing.Font

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.LineText Property

Gets or sets the text in the 'Line' area of the status bar.

Syntax

[C#]
public string LineText { get; set; }
[Visual Basic]
Public Property LineText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.PageCounterText Property

Gets or sets the text in the 'Page counter' area of the status bar.

Syntax

[C#]
public string PageCounterText { get; set; }
[Visual Basic]
Public Property PageCounterText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.PageText Property

Gets or sets the text in the 'Page' area of the status bar.

Syntax

[C#]
public string PageText { get; set; }
[Visual Basic]
Public Property PageText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ResetDisplayColors Method

Resets all display colors of a status bar to their system dependent default values.

Syntax

[C#]
public void ResetDisplayColors();
[Visual Basic]
Public Sub ResetDisplayColors()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.SectionCounterText Property

Gets or sets the text in the 'Section counter' area of the status bar.

Syntax

[C#]
public string SectionCounterText { get; set; }
[Visual Basic]
Public Property SectionCounterText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.SectionText Property

Gets or sets the text in the 'Section' area of the status bar.

Syntax

[C#]
public string SectionText { get; set; }
[Visual Basic]
Public Property SectionText() As String

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowColumn Property

Specifies whether the status bar shows the column number of the current text input position.

Syntax

[C#]
public bool ShowColumn { get; set; }
[Visual Basic]
Public Property ShowColumn() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowKeyStates Property

Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.

Syntax

[C#]
public bool ShowKeyStates { get; set; }
[Visual Basic]
Public Property ShowKeyStates() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowLanguage Property

Specifies whether the status bar shows the language of the text selection or the text input position.

Syntax

[C#]
public bool ShowLanguage { get; set; }
[Visual Basic]
Public Property ShowLanguage() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowLine Property

Specifies whether the status bar shows the line number of the current text input position.

Syntax

[C#]
public bool ShowLine { get; set; }
[Visual Basic]
Public Property ShowLine() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowPage Property

Specifies whether the status bar shows the page number of the current text input position.

Syntax

[C#]
public bool ShowPage { get; set; }
[Visual Basic]
Public Property ShowPage() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowPageCounter Property

Specifies whether the status bar shows the number of pages the document consists of.

Syntax

[C#]
public bool ShowPageCounter { get; set; }
[Visual Basic]
Public Property ShowPageCounter() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowSection Property

Specifies whether the status bar shows the section number of the current text input position.

Syntax

[C#]
public bool ShowSection { get; set; }
[Visual Basic]
Public Property ShowSection() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowSectionCounter Property

Specifies whether the status bar shows the number of sections the document consists of.

Syntax

[C#]
public bool ShowSectionCounter { get; set; }
[Visual Basic]
Public Property ShowSectionCounter() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowZoom Property

Specifies whether the status bar shows the current zoom factor.

Syntax

[C#]
public bool ShowZoom { get; set; }
[Visual Basic]
Public Property ShowZoom() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.ShowZoomTrackBar Property

Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.

Syntax

[C#]
public bool ShowZoomTrackBar { get; set; }
[Visual Basic]
Public Property ShowZoomTrackBar() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.UserInput Property

Gets the UserInput object, which can be used to inform the StatusBarViewGenerator about user input. The generator uses this information to generate a new view.

Syntax

[C#]
public UserInput UserInput { get; }
[Visual Basic]
Public ReadOnly Property UserInput() As UserInput

Limitations

Read only.

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.View Property

Gets the View object, which informs about view changes and provides an image of the StatusBarViewGenerator's current state.

Syntax

[C#]
public View View { get; }
[Visual Basic]
Public ReadOnly Property View() As View

Limitations

Read only.

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors Class

The StatusBarViewGenerator.Colors class gets, sets or resets the display colors of a ServerVisualization.StatusBarViewGenerator component. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the status bar's BorderStyle property has been set to ColorScheme.

Introduced: 21.0.

Syntax

[C#]
public class StatusBarViewGenerator.Colors
[Visual Basic]
Public Class StatusBarViewGenerator.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the StatusBarViewGenerator.Colors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left edge of the status bar.
BackColorBottom | Gets or sets the background color at the bottom of the status bar.
BackColorMiddle | Gets or sets the background color in the middle of the status bar.
BackColorTop | Gets or sets the background color at the top of the status bar.
ForeColor | Gets or sets the color used for text and numbers.
FrameColor | Gets or sets the color of the status bar's frames.
GradientBackColor | Gets or sets the background color at the right edge of the status bar.
SeparatorColorDark | Gets or sets the color of the dark part of a separator.
SeparatorColorLight | Gets or sets the color of the light part of a separator.

Methods

Method | Description
ResetBackColor | Resets the status bar's BackColor to its system dependent default value.
ResetBackColorBottom | Resets the status bar's BackColorBottom to its system dependent default value.
ResetBackColorMiddle | Resets the status bar's BackColorMiddle to its system dependent default value.
ResetBackColorTop | Resets the status bar's BackColorTop to its system dependent default value.
ResetForeColor | Resets the status bar's ForeColor to its system dependent default value.
ResetFrameColor | Resets the status bar's FrameColor to its system dependent default value.
ResetGradientBackColor | Resets the status bar's GradientBackColor to its system dependent default value.
ResetSeparatorColorDark | Resets the status bar's SeparatorColorDark to its system dependent default value.
ResetSeparatorColorLight | Resets the status bar's SeparatorColorLight to its system dependent default value.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors Constructor

Initializes a new instance of the StatusBarViewGenerator.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public StatusBarViewGenerator.Colors();
[Visual Basic]
Public Class StatusBarViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.BackColor Property

Gets or sets the background color at the left edge of the status bar. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.BackColorBottom Property

Gets or sets the background color at the bottom of the status bar. This color is only used with the VerticalColorScheme border style.

Syntax

[C#]
public Color BackColorBottom { get; set; }
[Visual Basic]
Public Property BackColorBottom As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.BackColorMiddle Property

Gets or sets the background color in the middle of the status bar. This color is only used with the VerticalColorScheme border style.

Syntax

[C#]
public Color BackColorMiddle { get; set; }
[Visual Basic]
Public Property BackColorMiddle As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.BackColorTop Property

Gets or sets the background color at the top of the status bar. This color is only used with the VerticalColorScheme border style.

Syntax

[C#]
public Color BackColorTop { get; set; }
[Visual Basic]
Public Property BackColorTop As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ForeColor Property

Gets or sets the color used for text and numbers.

Syntax

[C#]
public Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.FrameColor Property

Gets or sets the color of the status bar's frames. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color FrameColor { get; set; }
[Visual Basic]
Public Property FrameColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.GradientBackColor Property

Gets or sets the background color at the right edge of the status bar. This color is only used with the ColorScheme border style.

Syntax

[C#]
public Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetBackColor Method

Resets the status bar's BackColor to its system dependent default value.

Syntax

[C#]
public void ResetBackColor();
[Visual Basic]
Public Sub ResetBackColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetBackColorBottom Method

Resets the status bar's BackColorBottom to its system dependent default value.

Syntax

[C#]
public void ResetBackColorBottom();
[Visual Basic]
Public Sub ResetBackColorBottom()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetBackColorMiddle Method

Resets the status bar's BackColorMiddle to its system dependent default value.

Syntax

[C#]
public void ResetBackColorMiddle();
[Visual Basic]
Public Sub ResetBackColorMiddle()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetBackColorTop Method

Resets the status bar's BackColorTop to its system dependent default value.

Syntax

[C#]
public void ResetBackColorTop();
[Visual Basic]
Public Sub ResetBackColorTop()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetForeColor Method

Resets the status bar's ForeColor to its system dependent default value.

Syntax

[C#]
public void ResetForeColor();
[Visual Basic]
Public Sub ResetForeColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetFrameColor Method

Resets the status bar's FrameColor to its system dependent default value.

Syntax

[C#]
public void ResetFrameColor();
[Visual Basic]
Public Sub ResetFrameColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetGradientBackColor Method

Resets the status bar's GradientBackColor to its system dependent default value.

Syntax

[C#]
public void ResetGradientBackColor();
[Visual Basic]
Public Sub ResetGradientBackColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetSeparatorColorDark Method

Resets the status bar's SeparatorColorDark to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorDark();
[Visual Basic]
Public Sub ResetSeparatorColorDark()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.ResetSeparatorColorLight Method

Resets the status bar's SeparatorColorLight to its system dependent default value.

Syntax

[C#]
public void ResetSeparatorColorLight();
[Visual Basic]
Public Sub ResetSeparatorColorLight()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.SeparatorColorDark Property

Gets or sets the color of the dark part of a separator. This color is only used with the VerticalColorScheme border style.

Syntax

[C#]
public Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.StatusBarViewGenerator.Colors.SeparatorColorLight Property

Gets or sets the color of the light part of a separator. This color is only used with the VerticalColorScheme border style.

Syntax

[C#]
public Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextContextMenuEventArgs Class

The TextContextMenuEventArgs class provides data for the ServerVisualization.TextViewGenerator.TextContextMenuOpening event. It provides an array of menu items for a certain location in a document. The ContextMenuLocation property informs for which part of the document the items have been generated.

Introduced: 21.0.

Syntax

[C#]
public class TextContextMenuEventArgs: EventArgs
[Visual Basic]
Public Class TextContextMenuEventArgs
  Inherits EventArgs

Properties

Property | Description
ContextMenuLocation | Gets the location in the document for which the menu items have been generated.
Items | Gets an array of ServerVisualization.MenuItem objects.
Location | Gets the location, in pixels, where the context menu should be displayed.
RightToLeft | Gets a value indicating whether the context menu must be shown from right to left.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextContextMenuEventArgs.ContextMenuLocation Property

Gets the location in the document for which the menu items have been generated. The generated items depend on this location. The property value can be a combination (bitwise or) of the ContextMenuLocation values.

Syntax

[C#]
public ContextMenuLocation ContextMenuLocation { get; }
[Visual Basic]
Public ReadOnly Property ContextMenuLocation() As ContextMenuLocation

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextContextMenuEventArgs.Items Property

Gets an array of ServerVisualization.MenuItem objects. These objects contain all data necessary to display a context menu.

Syntax

[C#]
public MenuItem[] Items { get; }
[Visual Basic]
Public ReadOnly Property Items() As MenuItem()

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextContextMenuEventArgs.Location Property

Gets the location, in pixels, where the context menu should be displayed. The coordinates are relative to the top-left corner of the screen.

Syntax

[C#]
public System.Drawing.Point Location { get; }
[Visual Basic]
Public ReadOnly Property Location() As System.Drawing.Point

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextContextMenuEventArgs.RightToLeft Property

Gets a value indicating whether the context menu must be shown from right to left.

Syntax

[C#]
public bool RightToLeft { get; }
[Visual Basic]
Public ReadOnly Property RightToLeft() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator Class

The TextViewGenerator class is a special ServerTextControl, which can be used to visualize the control's text contents through a generated image. It manages a ServerVisualization.UserInput and a ServerVisualization.View object. These objects can be used to inform the generator about user input and to get a generated view depending on the input. A TextViewGenerator object can be connected with a StatusBarViewGenerator and with a RulerBarViewGenerator object to show formatting attributes and status information at the curent text input position.

Introduced: 21.0.

Syntax

[C#]
public class TextViewGenerator : ServerTextControl
[Visual Basic]
Public Class TextViewGenerator
  Inherits ServerTextControl

Properties

Property | Description
ActivationState | Gets or sets a value indicating the current activation state.
AllowDrag | Gets or sets a value indicating whether the view generator can be a source of a Drag&Drop operation.
AllowDrop | Gets or sets a value indicating whether the view generator can accept data that the user drags onto it.
AllowUndo | Gets or sets a value indicating whether the undo buffer is active or not.
CanCopy | Informs whether a part of a document has been selected and can be copied to the clipboard.
CanPaste | Informs whether the clipboard contains a format that can be pasted into a document.
CanRedo | Informs whether an operation can be re-done.
CanUndo | Gets a value indicating whether the user can undo the previous operation.
ControlChars | Specifies if control characters are visible or not.
DisplayColors | Gets or sets display colors.
DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.
DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
EditMode | Gets or sets a value indicating whether the document's text is read-only, can be selected or is editable.
InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
Location | Gets or sets a location, in pixels.
RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
RulerBar | Specifies the horizontal ruler bar to be used with the TextViewGenerator.
StatusBar | Specifies the status bar to be used with the TextViewGenerator.
TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.
UserInput | Gets the UserInput object, which can be used to inform the TextViewGenerator about user input.
VerticalRulerBar | Specifies the vertical ruler bar to be used with the TextViewGenerator.
View | Gets the View object, which informs about view changes and provides an image of the TextViewGenerator's current state.

Methods

Method | Description
BeginUndoAction | Begins a user-defined undo operation.
EndUndoAction | Ends a user-defined undo operation.
GetDialogBox | Overloaded. Returns a view generator for the specified built-in dialog box.
OnBarcodeDeselected | Raises the BarcodeDeselected event.
OnBarcodeSelected | Raises the BarcodeSelected event.
OnCaretStateChanged | Raises the CaretStateChanged event.
OnChanged | Raises the Changed event.
OnCharFormatChanged | Raises the CharFormatChanged event.
OnChartDeselected | Raises the ChartDeselected event.
OnChartSelected | Raises the ChartSelected event.
OnDocumentLinkClicked | Raises the DocumentLinkClicked event.
OnDocumentSizeChanged | Raises the DocumentSizeChanged event.
OnDrawingDeselected | Raises the DrawingDeselected event.
OnDrawingSelected | Raises the DrawingSelected event.
OnDrawShape | Raises the DrawShape event.
OnHeaderFooterActivated | Raises the HeaderFooterActivated event.
OnHeaderFooterDeactivated | Raises the HeaderFooterDeactivated event.
OnHypertextLinkClicked | Raises the HypertextLinkClicked event.
OnImageDeselected | Raises the ImageDeselected event.
OnImageSelected | Raises the ImageSelected event.
OnInputPositionChanged | Raises the InputPositionChanged event.
OnPageFormatChanged | Raises the PageFormatChanged event.
OnParagraphFormatChanged | Raises the ParagraphFormatChanged event.
OnSubTextPartClicked | Raises the SubTextPartClicked event.
OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
OnSubTextPartEntered | Raises the SubTextPartEntered event.
OnSubTextPartLeft | Raises the SubTextPartLeft event.
OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
OnTextFieldClicked | Raises the TextFieldClicked event.
OnTextFieldEntered | Raises the TextFieldEntered event.
OnTextFieldLeft | Raises the TextFieldLeft event.
OnTextFrameDeselected | Raises the TextFrameDeselected event.
OnTextFrameSelected | Raises the TextFrameSelected event.
Redo | Redoes the last TextViewGenerator operation.
Undo | Undoes the last edit operation in the TextViewGenerator.
Zoom | Overloaded. Zooms the contents of the TextViewGenerator.

Events

Event | Description
BarcodeDeselected | Occurs when a barcode has been deselected.
BarcodeSelected | Occurs when a barcode has been selected.
CaretStateChanged | Occurs when the state of the caret (size, position, visibility) has been changed.
Changed | Indicates that the contents of a document have been changed.
CharFormatChanged | Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed.
ChartDeselected | Occurs when a chart has been deselected.
ChartSelected | Occurs when a chart has been selected.
DocumentLinkClicked | Occurs when a text field has been clicked on that represents a link to a target in the document.
DocumentSizeChanged | Occurs when the size of the document has been changed.
DrawingDeselected | Occurs when a drawing has been deselected.
DrawingSelected | Occurs when a drawing has been selected.
DrawShape | Occurs when additional user-interaction parts must be drawn.
HeaderFooterActivated | Occurs when a header or footer has been activated.
HeaderFooterDeactivated | Occurs when a header or footer has been deactivated.
HypertextLinkClicked | Occurs when a text field has been clicked on that represents the source of a hypertext link.
ImageDeselected | Occurs when an image has been deselected.
ImageSelected | Occurs when an image has been selected.
InputPositionChanged | Occurs when the text input position has been changed.
PageFormatChanged | Occurs when the page format settings have been changed.
ParagraphFormatChanged | Occurs when the formatting attributes of the selected paragraphs have been changed.
SubTextPartClicked | Occurs when a subtextpart has been clicked on.
SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TextContextMenuOpening | Occurs when a right mouse click is sent as user input and a context menu should be opened.
TextControl.TextFieldClicked | Occurs when a text field has been clicked on.
TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TextFieldLeft | Occurs when the current input position has left a text field.
TextFrameDeselected | Occurs when a text frame has been deselected.
TextFrameSelected | Occurs when a text frame has been selected.

Enumerations

Enumeration | Description
DialogBoxKind | Determines a built-in dialog box.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ActivationState Property

Gets or sets a value indicating the current activation state. It can be activated, deactivated or disabled.

Syntax

[C#]
public ActivationState ActivationState { get; set; }
[Visual Basic]
Public Property ActivationState() As ActivationState
Value | Description
Activated | The dialog box is activated, which means that it has the keyboard input focus.
Deactivated | The dialog box is deactivated, which means that it has not the keyboard input focus.
Disabled | The dialog box is disabled, which means that it cannot get the keyboard input focus.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.AllowDrag Property

Gets or sets a value indicating whether the view generator can be a source of a Drag&Drop operation. To allow the view generator to accept data, the TextControl.AllowDrop property must be set to true.

Introduced: 24.0.

Syntax

[C#]
public bool AllowDrag { get; set; }
[Visual Basic]
Public Property AllowDrag() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.AllowDrop Property

Gets or sets a value indicating whether the view generator can accept data that the user drags onto it. This property allows the view generator to be a target for drop operations. To allow the view generator to be a source of a Drag&Drop operation the TextControl.AllowDrag property must be set to true.

Introduced: 24.0.

Syntax

[C#]
public bool AllowDrop { get; set; }
[Visual Basic]
Public Property AllowDrop() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.AllowUndo Property

Gets or sets a value indicating whether the undo buffer is active or not.

Syntax

[C#]
public bool AllowUndo { get; set; }
[Visual Basic]
Public Property AllowUndo() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.BarcodeDeselected Event

Occurs when a barcode has been deselected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeselected;
[Visual Basic]
Public Event BarcodeDeselected As BarcodeEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.BarcodeSelected Event

Occurs when a barcode has been selected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Syntax

[C#]
public event BarcodeEventHandler BarcodeSelected;
[Visual Basic]
Public Event BarcodeSelected As BarcodeEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.BeginUndoAction Method

Begins a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step. The specified user-defined name is available with the UndoActionName property.

Introduced: 23.0.

Syntax

[C#]
public void BeginUndoAction(string actionName);
[Visual Basic]
Public Sub BeginUndoAction(ByVal actionName As String)
Parameter | Description
actionName | Specifies the undo action's name. If an action name is not necessary, this parameter can be null or an empty string.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Changed Event

Indicates that the contents of a document have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Changed;
[Visual Basic]
Public Event Changed As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ChartDeselected Event

Occurs when a chart has been deselected. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Syntax

[C#]
public event ChartEventHandler ChartDeselected;
[Visual Basic]
Public Event ChartDeselected As ChartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ChartSelected Event

Occurs when a chart has been selected. The event handler receives an argument of type ChartEventArgs containing data related to this event.

Syntax

[C#]
public event ChartEventHandler ChartSelected;
[Visual Basic]
Public Event ChartSelected As ChartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CanCopy Property

Informs whether a part of a document has been selected and can be copied to the clipboard.

Syntax

[C#]
public bool CanCopy { get; }
[Visual Basic]
Public ReadOnly Property CanCopy() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CanPaste Property

Informs whether the clipboard contains a format that can be pasted into a document.

Syntax

[C#]
public bool CanPaste { get; }
[Visual Basic]
Public ReadOnly Property CanPaste() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CanRedo Property

Informs whether an operation can be re-done.

Syntax

[C#]
public bool CanRedo { get; }
[Visual Basic]
Public ReadOnly Property CanRedo() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CanUndo Property

Gets a value indicating whether the user can undo the previous operation.

Syntax

[C#]
public bool CanUndo { get; }
[Visual Basic]
Public ReadOnly Property CanUndo() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CaretStateChanged Event

Occurs when the state of the caret (size, position, visibility) has been changed. The event handler receives an argument of type ServerVisualization.CaretStateEventArgs containing data related to this event.

Syntax

[C#]
public event CaretStateEventHandler CaretStateChanged;
[Visual Basic]
Public Event CaretStateChanged As CaretStateEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.CharFormatChanged Event

Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed. Formatting attributes that can be asigned to single characters are the font, the font attributes, text colors and the baseline. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler CharFormatChanged;
[Visual Basic]
Public Event CharFormatChanged As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ControlChars Property

Specifies if control characters are visible or not.

Syntax

[C#]
public bool ControlChars { get; set; }
[Visual Basic]
Public Property ControlChars() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DialogBoxKind Enumeration

Determines a built-in dialog box. It contains the following values:

Member | Description
AddSymbolDialog | Determines the dialog box for inserting symbol characters.
BarcodeLayoutDialog | Determines the dialog box for layouting and setting attributes of barcodes.
ChartLayoutDialog | Determines the dialog box for layouting charts.
DrawingLayoutDialog | Determines the dialog box for layouting drawings.
FontDialog | Determines the dialog box for setting character attributes like font attributes, text fore- and background color, baseline alignment and underlining.
ForeColorDialog | Determines the dialog box for defining a text foreground color.
FormattingStylesDialog | Determines the dialog box for defining formatting styles.
FrameFillColorDialog | Determines the dialog box for defining a color for the background of a paragraph or a table cell.
FrameLineColorDialog | Determines the dialog box for defining a color for the frame of a paragraph or a table.
ImageAttributesDialog | Determines the dialog box for setting image attributes like layout options and position, size, scaling, text distances and saving options.
InsertTableDialog | Determines the dialog box for inserting tables.
LanguageDialog | Determines the dialog box for setting languages.
ListFormatDialog | Determines the dialog box for setting attributes of bulleted and numbered lists.
PageColorDialog | Determines the dialog box for defining a page color.
ParagraphFormatDialog | Determines the dialog box for setting paragraph attributes like alignment, indents, distances, frames and pagination.
SectionFormatDialog | Determines the dialog box for setting section attributes like page size and orientation, page margins, headers and footers, page columns and page frames.
TabDialog | Determines the dialog box for defining tabulators.
TableFormatDialog | Determines the dialog box for setting table attributes like frame width and frame color, text distances, cell height and vertical alignment.
TextBackColorDialog | Determines the dialog box for defining a text background color.
TextFrameAttributesDialog | Determines the dialog box for setting textframe attributes like layout options and position, size, scaling, text distances and frame options.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DisplayColors Property

Gets or sets display colors. The property value is an object of the type ServerVisualization.TextViewGenerator.Colors.

Syntax

[C#]
public TextViewGenerator.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As TextViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DocumentLinkClicked Event

Occurs when a text field has been clicked on that represents a link to a target in the document. The event handler receives an argument of type DocumentLinkEventArgs containing data related to this event.

Syntax

[C#]
public event DocumentLinkEventHandler DocumentLinkClicked;
[Visual Basic]
Public Event DocumentLinkClicked As DocumentLinkEventHandler

See Also

  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DocumentSizeChanged Event

Occurs when the size of the document has been changed. When an external scroll interface has been implemented, this event can be used to adapt the scroll bar range. The event handler receives an argument of type DocumentSizeChangedEventArgs containing data related to this event.

Syntax

[C#]
public event DocumentSizeChangedEventHandler DocumentSizeChanged;
[Visual Basic]
Public Event DocumentSizeChanged As DocumentSizeChangedEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DocumentTargetMarkers Property

Gets or sets a value indicating that markers for hypertext targets are shown or not.

Syntax

[C#]
public bool DocumentTargetMarkers { get; set; }
[Visual Basic]
Public Property DocumentTargetMarkers() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DrawingDeselected Event

Occurs when a drawing has been deselected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeselected;
[Visual Basic]
Public Event DrawingDeselected As DrawingEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DrawingMarkerLines Property

Specifies whether a marker frame is shown around a drawing to indicate its position and size.

Introduced: 23.0.

Syntax

[C#]
public bool DrawingMarkerLines { get; set; }
[Visual Basic]
Public Property DrawingMarkerLines() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DrawingSelected Event

Occurs when a drawing has been selected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingSelected;
[Visual Basic]
Public Event DrawingSelected As DrawingEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.DrawShape Event

Occurs when additional user-interaction parts must be drawn. These parts are the frame shown during an image or textframe is moved or sized and the line shown during the width of a table cell is changed. The event handler receives an argument of type DrawShapeEventArgs containing data related to this event.

Syntax

[C#]
public event DrawShapeEventHandler DrawShape;
[Visual Basic]
Public Event DrawShape As DrawShapeEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.EditMode Property

Gets or sets a value indicating whether the document's text is read-only, can be selected or is editable.

Syntax

[C#]
public EditMode EditMode { get; set; }
[Visual Basic]
Public Property EditMode() As EditMode
Value | Description
Edit | The document's text can be edited.
ReadAndSelect | The document's text is read only but can be selected.
ReadOnly | The document's text is read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.EndUndoAction Method

Ends a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step.

Introduced: 23.0.

Syntax

[C#]
public void EndUndoAction();
[Visual Basic]
Public Sub EndUndoAction()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.GetDialogBox Method

Returns a view generator for the specified built-in dialog box.

GetDialogBox(DialogBoxKind)

Returns a view generator for the specified built-in dialog box.

[C#]
public DialogViewGenerator GetDialogBox(ServerVisualization.TextViewGenerator.DialogBoxKind kind);
[Visual Basic]
Public Function GetDialogBox(ByVal kind As ServerVisualization.TextViewGenerator.DialogBoxKind) As DialogViewGenerator
Member | Description
kind | Specifies which kind of dialog box is represented through the view generator. It can be one of the values specified through the DialogBoxKind enumeration.

GetDialogBox(DialogBoxKind, Int32)

Returns a view generator for the specified built-in dialog box and selects the specified dialog box tab.

[C#]
public DialogViewGenerator GetDialogBox(ServerVisualization.TextViewGenerator.DialogBoxKind kind, int selectedTab);
[Visual Basic]
Public Function GetDialogBox(ByVal kind As ServerVisualization.TextViewGenerator.DialogBoxKind, ByVal selectedTab As Integer) As DialogViewGenerator
Member Description
kind

Specifies which kind of dialog box is represented through the view generator. It can be one of the values specified through the DialogBoxKind enumeration.
selectedTab

Specifies an zero-based index indicating which dialog box tab is selected. This parameter can only be used for the following dialog boxes:

Dialog Box | Possible Tabs
ImageAttributesDialog | Tab 0: Layout and position, tab 1: Size, scaling and distances, tab 2: Saving options.
TextFrameAttributesDialog | Tab 0: Layout and position, tab 1: Size, scaling and distances, tab 2: frame width and color.
BarcodeLayoutDialog | Tab 0: Layout and position, tab 1: Size, scaling and distances, tab 2: barcode options like type, text, rotation and colors.
ChartLayoutDialog | Tab 0: Layout and position, tab 1: Size, scaling and distances.
DrawingLayoutDialog | Tab 0: Layout and position, tab 1: Size, scaling and distances.
TableFormatDialog | Tab 0: Frame width and color, background color and text distances, tab 1: Cell height, vertical alignment and formatting options.
ParagraphFormatDialog | Tab 0: Alignment, text direction, indents and distances, tab 1: Frames and pagination.
SectionFormatDialog | Tab 0: Page size, orientation and page margins, tab 1: Defining headers and footers, tab 2: Attributes of page columns, tab 3: Attributes of page frames.

GetDialogBox(PageNumberField)

Returns a view generator for a dialog box handling the attributes of the specified pagenumber field.

[C#]
public DialogViewGenerator GetDialogBox(PageNumberField pageNumberField);
[Visual Basic]
Public Function GetDialogBox(ByVal pageNumberField As PageNumberField) As DialogViewGenerator
Member | Description
pageNumberField | Specifies the PageNumberField for which the dialog box is opened.

Return Value

The method returns a DialogViewGenerator object which can be used to manage and display a built-in dialog box. The return value is null, if a previously returned view generator has not yet been disposed.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.HeaderFooterActivated Event

Occurs when a header or footer has been activated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterActivated;
[Visual Basic]
Public Event HeaderFooterActivated As HeaderFooterEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.HeaderFooterDeactivated Event

Occurs when a header or footer has been deactivated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterDeactivated;
[Visual Basic]
Public Event HeaderFooterDeactivated As HeaderFooterEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.HypertextLinkClicked Event

Occurs when a text field has been clicked on that represents the source of a hypertext link. The event handler receives an argument of type HypertextLinkEventArgs containing data related to this event.

Syntax

[C#]
public event HypertextLinkEventHandler HypertextLinkClicked;
[Visual Basic]
Public Event HypertextLinkClicked As HypertextLinkEventHandler

See Also

  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ImageDeselected Event

Occurs when an image has been deselected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDeselected;
[Visual Basic]
Public Event ImageDeselected As ImageEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ImageSelected Event

Occurs when an image has been selected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageSelected;
[Visual Basic]
Public Event ImageSelected As ImageEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.InputFormat Property

Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.

Syntax

[C#]
public InputFormat InputFormat { get; }
[Visual Basic]
Public ReadOnly Property InputFormat() As InputFormat

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.InputPositionChanged Event

Occurs when the text input position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputPositionChanged;
[Visual Basic]
Public Event InputPositionChanged As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Location Property

Gets or sets a location, in pixels. When a RulerBarViewGenerator object is connected with a TextViewGenerator object, this location is used to adjust the ruler with the text. It determines the position of the text image relative to the ruler image.

Syntax

[C#]
public System.Drawing.Point Location { get; set; }
[Visual Basic]
Public Property Location() As System.Drawing.Point

Limitations

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.PageFormatChanged Event

Occurs when the page format settings have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler PageFormatChanged;
[Visual Basic]
Public Event PageFormatChanged As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.ParagraphFormatChanged Event

Occurs when the formatting attributes of the selected paragraphs have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler ParagraphFormatChanged;
[Visual Basic]
Public Event ParagraphFormatChanged As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnBarcodeDeselected Method

Raises the BarcodeDeselected event.

Syntax

[C#]
protected virtual void OnBarcodeDeselected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeselected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnBarcodeSelected Method

Raises the BarcodeSelected event.

Syntax

[C#]
protected virtual void OnBarcodeSelected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeSelected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnChartDeselected Method

Raises the ChartDeselected event.

Syntax

[C#]
protected virtual void OnChartDeselected(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartDeselected(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnChartSelected Method

Raises the ChartSelected event.

Syntax

[C#]
protected virtual void OnChartSelected(DataVisualization.ChartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChartSelected(ByVal e As DataVisualization.ChartEventArgs)
Parameter | Description
e | Specifies an ChartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnCaretStateChanged Method

Raises the CaretStateChanged event.

Syntax

[C#]
protected virtual void OnCaretStateChanged(ServerVisualization.CaretStateEventArgs e);
[Visual Basic]
Protected Overridable Sub OnCaretStateChanged(ByVal e As ServerVisualization.CaretStateEventArgs)
Parameter | Description
e | Specifies a ServerVisualization.CaretStateEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnChanged Method

Raises the Changed event.

Syntax

[C#]
protected virtual void OnChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnCharFormatChanged Method

Raises the CharFormatChanged event.

Syntax

[C#]
protected virtual void OnCharFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnCharFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnDocumentLinkClicked Method

Raises the DocumentLinkClicked event.

Syntax

[C#]
protected virtual void OnDocumentLinkClicked(DocumentLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLinkClicked(ByVal e As DocumentLinkEventArgs)
Parameter | Description
e | Specifies an DocumentLinkEventArgs object that contains the event data.

See Also

  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnDocumentSizeChanged Method

Raises the DocumentSizeChanged event.

Syntax

[C#]
protected virtual void OnDocumentSizeChanged(ServerVisualization.DocumentSizeChangedEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentSizeChanged(ByVal e As ServerVisualization.DocumentSizeChangedEventArgs)
Parameter | Description
e | Specifies a ServerVisualization.DocumentSizeChangedEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnDrawingDeselected Method

Raises the DrawingDeselected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeselected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeselected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnDrawingSelected Method

Raises the DrawingSelected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingSelected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingSelected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnDrawShape Method

Raises the DrawShape event.

Syntax

[C#]
protected virtual void OnDrawShape(ServerVisualization.DrawShapeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawShape(ByVal e As ServerVisualization.DrawShapeEventArgs)
Parameter | Description
e | Specifies a ServerVisualization.DrawShapeEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnHeaderFooterActivated Method

Raises the HeaderFooterActivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterActivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterActivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnHeaderFooterDeactivated Method

Raises the HeaderFooterDeactivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterDeactivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterDeactivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnHypertextLinkClicked Method

Raises the HypertextLinkClicked event.

Syntax

[C#]
protected virtual void OnHypertextLinkClicked(HypertextLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHypertextLinkClicked(ByVal e As HypertextLinkEventArgs)
Parameter | Description
e | Specifies an HypertextLinkEventArgs object that contains the event data.

See Also

  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnImageDeselected Method

Raises the ImageDeselected event.

Syntax

[C#]
protected virtual void OnImageDeselected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeselected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnImageSelected Method

Raises the ImageSelected event.

Syntax

[C#]
protected virtual void OnImageSelected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageSelected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnInputPositionChanged Method

Raises the InputPositionChanged event.

Syntax

[C#]
protected virtual void OnInputPositionChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputPositionChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnPageFormatChanged Method

Raises the PageFormatChanged event.

Syntax

[C#]
protected virtual void OnPageFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnPageFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnParagraphFormatChanged Method

Raises the ParagraphFormatChanged event.

Syntax

[C#]
protected virtual void OnParagraphFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnParagraphFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartClicked Method

Raises the SubTextPartClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartDoubleClicked Method

Raises the SubTextPartDoubleClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartDoubleClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartDoubleClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartEntered Method

Raises the SubTextPartEntered event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartEntered(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartEntered(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnSubTextPartLeft Method

Raises the SubTextPartLeft event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartLeft(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartLeft(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextContextMenuOpening Method

Raises the TextContextMenuOpening event.

Syntax

[C#]
protected virtual void OnTextContextMenuOpening(TextContextMenuEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextContextMenuOpening(ByVal e As TextContextMenuEventArgs)
Parameter | Description
e | Specifies an ServerVisualization.TextContextMenuEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldClicked Method

Raises the TextFieldClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnTextFieldClicked(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldClicked(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldEntered Method

Raises the TextFieldEntered event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnTextFieldEntered(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldEntered(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextFieldLeft Method

Raises the TextFieldLeft event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnTextFieldLeft(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldLeft(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextFrameDeselected Method

Raises the TextFrameDeselected event.

Syntax

[C#]
protected virtual void OnTextFrameDeselected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeselected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.OnTextFrameSelected Method

Raises the TextFrameSelected event.

Syntax

[C#]
protected virtual void OnTextFrameSelected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameSelected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Redo Method

Redoes the last TextViewGenerator operation.

Syntax

[C#]
public void Redo();
[Visual Basic]
Public Sub Redo()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.RedoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Redo method is made. The property's value is null if there is no action that can be redone.

Introduced: 23.0.

Syntax

[C#]
public string RedoActionName { get; }
[Visual Basic]
Public ReadOnly Property RedoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.RulerBar Property

Specifies the horizontal ruler bar to be used with the TextViewGenerator. The property value is null, if there is no ruler bar connected. Otherwise it is an object of the type RulerBarViewGenerator. It automatically shows formatting attributes at the current text input position.

Syntax

[C#]
public RulerBarViewGenerator RulerBar { get; set; }
[Visual Basic]
Public Property RulerBar() As RulerBarViewGenerator

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.StatusBar Property

Specifies the status bar to be used with the TextViewGenerator. The property value is null, if there is no status bar connected. Otherwise it is an object of the type StatusBarViewGenerator. It automatically shows status information of the current text input position.

Syntax

[C#]
public StatusBarViewGenerator StatusBar { get; set; }
[Visual Basic]
Public Property StatusBar() As StatusBarViewGenerator

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartClicked Event

Occurs when a subtextpart has been clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartClicked;
[Visual Basic]
Public Event SubTextPartClicked As SubTextPartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartDoubleClicked Event

Occurs when a subtextpart has been double-clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartDoubleClicked;
[Visual Basic]
Public Event SubTextPartDoubleClicked As SubTextPartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartEntered Event

Occurs when the current input position has been moved to a position that belongs to a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartEntered;
[Visual Basic]
Public Event SubTextPartEntered As SubTextPartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.SubTextPartLeft Event

Occurs when the current input position has left a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartLeft;
[Visual Basic]
Public Event SubTextPartLeft As SubTextPartEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextContextMenuOpening Event

Occurs when a right mouse click is sent as user input and a context menu should be opened. The event handler receives an argument of type TextContextMenuEventArgs containing data related to this event. The event data contains a list of possible menu items which can be shown for the location where the click occurs.

Syntax

[C#]
public event TextContextMenuEventHandler TextContextMenuOpening;
[Visual Basic]
Public Event TextContextMenuOpening As TextContextMenuEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextControl.TextFieldClicked Event

Occurs when a text field has been clicked on. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event TextFieldEventHandler TextFieldClicked;
[Visual Basic]
Public Event TextFieldClicked As TextFieldEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextFieldEntered Event

Occurs when the current input position has been moved to a position that belongs to a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event TextFieldEventHandler TextFieldEntered;
[Visual Basic]
Public Event TextFieldEntered As TextFieldEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextFieldLeft Event

Occurs when the current input position has left a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event TextFieldEventHandler TextFieldLeft;
[Visual Basic]
Public Event TextFieldLeft As TextFieldEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextFrameDeselected Event

Occurs when a text frame has been deselected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeselected;
[Visual Basic]
Public Event TextFrameDeselected As TextFrameEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextFrameMarkerLines Property

Specifies whether text frames that have no border line are shown with marker lines.

Syntax

[C#]
public bool TextFrameMarkerLines { get; set; }
[Visual Basic]
Public Property TextFrameMarkerLines() As Boolean

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.TextFrameSelected Event

Occurs when a text frame has been selected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameSelected;
[Visual Basic]
Public Event TextFrameSelected As TextFrameEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.UndoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Undo method is made. The property's value is null if there is no action that can be undone.

Introduced: 23.0.

Syntax

[C#]
public string UndoActionName { get; }
[Visual Basic]
Public ReadOnly Property UndoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Undo Method

Undoes the last edit operation in the TextViewGenerator.

Syntax

[C#]
public void Undo();
[Visual Basic]
Public Sub Undo()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.UserInput Property

Gets the UserInput object, which can be used to inform the TextViewGenerator about user input. The generator uses this information to generate a new view.

Syntax

[C#]
public UserInput UserInput { get; }
[Visual Basic]
Public ReadOnly Property UserInput() As UserInput

Limitations

Read only.

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.VerticalRulerBar Property

Specifies the vertical ruler bar to be used with the TextViewGenerator. The property value is null, if there is no ruler bar connected. Otherwise it is an object of the type RulerBarViewGenerator. It automatically shows formatting attributes at the current text input position.

Syntax

[C#]
public RulerBarViewGenerator VerticalRulerBar { get; set; }
[Visual Basic]
Public Property VerticalRulerBar() As RulerBarViewGenerator

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.View Property

Gets the View object, which informs about view changes and provides an image of the TextViewGenerator's current state.

Syntax

[C#]
public View View { get; }
[Visual Basic]
Public ReadOnly Property View() As View

Limitations

Read only.

Runtime only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Zoom Method

Zooms the contents of the TextViewGenerator.

Introduced: 24.0.

Zoom(Int32)

Zooms the contents of the TextViewGenerator using the specified zoom factor.

[C#]
public void Zoom(int zoomFactor);
[Visual Basic]
Public Sub Zoom(ByVal zoomFactor As Integer)
Parameter | Description
zoomFactor | Specifies the zoom factor, in percent.

Zoom(ZoomOption)

Zooms the contents of the TextViewGenerator using the specified option.

[C#]
public void Zoom(ZoomOption zoomOption);
[Visual Basic]
Public Sub Zoom(ByVal zoomOption As ZoomOption)
Parameter | Description
zoomOption | Specifies one of the ZoomOption values.

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent, when the TextControl.ViewMode property has been set to PageView or Normal. For the other modes the zoom factor must be between 10 and 400 percent.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors Class

The TextViewGenerator.Colors class gets, sets or resets the display colors of a TextViewGenerator component. By default the display colors depend on sytem colors. With this class all colors can be individually designed.

Introduced: 21.0.

Syntax

[C#]
public class TextViewGenerator.Colors
[Visual Basic]
Public Class TextViewGenerator.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the TextViewGenerator.Colors class.

Properties

Property | Description
DarkShadowColor | Gets or sets the display color for the shadow at the right and the bottom edge of the pages.
DesktopColor | Gets or sets the display color for the area around the pages.
HeaderFooterLabelColor | Gets or sets the display color for the label showing which header or footer is activated.
HeaderFooterLineColor | Gets or sets the display color for the dividing line between headers and footers and the main text.
LightShadowColor | Gets or sets the display color for the shadow at the left and the top edge of the pages.

Methods

Method | Description
ResetDarkShadowColor | Resets the text control's DarkShadowColor to its system dependent default value.
ResetDesktopColor | Resets the text control's DesktopColor to its system dependent default value.
ResetHeaderFooterLabelColor | Resets the text control's HeaderFooterLabelColor to its system dependent default value.
ResetHeaderFooterLineColor | Resets the text control's HeaderFooterLineColor to its system dependent default value.
ResetLightShadowColor | Resets the text control's LightShadowColor to its system dependent default value.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors Constructor

Initializes a new instance of the TextViewGenerator.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public TextViewGenerator.Colors();
[Visual Basic]
Public Class TextViewGenerator.Colors

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.DarkShadowColor Property

Gets or sets the display color for the shadow at the right and the bottom edge of the pages.

Syntax

[C#]
public Color DarkShadowColor { get; set; }
[Visual Basic]
Public Property DarkShadowColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.DesktopColor Property

Gets or sets the display color for the area around the pages.

Syntax

[C#]
public Color DesktopColor { get; set; }
[Visual Basic]
Public Property DesktopColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.HeaderFooterLabelColor Property

Gets or sets the display color for the label showing which header or footer is activated.

Syntax

[C#]
public Color HeaderFooterLabelColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLabelColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.HeaderFooterLineColor Property

Gets or sets the display color for the dividing line between headers and footers and the main text.

Syntax

[C#]
public Color HeaderFooterLineColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLineColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.LightShadowColor Property

Gets or sets the display color for the shadow at the left and the top edge of the pages.

Syntax

[C#]
public Color LightShadowColor { get; set; }
[Visual Basic]
Public Property LightShadowColor As Color

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.ResetDarkShadowColor Method

Resets the text control's DarkShadowColor to its system dependent default value.

Syntax

[C#]
public void ResetDarkShadowColor();
[Visual Basic]
Public Sub ResetDarkShadowColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.ResetDesktopColor Method

Resets the text control's DesktopColor to its system dependent default value.

Syntax

[C#]
public void ResetDesktopColor();
[Visual Basic]
Public Sub ResetDesktopColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.ResetHeaderFooterLabelColor Method

Resets the text control's HeaderFooterLabelColor to its system dependent default value.

Syntax

[C#]
public void ResetHeaderFooterLabelColor();
[Visual Basic]
Public Sub ResetHeaderFooterLabelColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.ResetHeaderFooterLineColor Method

Resets the text control's HeaderFooterLineColor to its system dependent default value.

Syntax

[C#]
public void ResetHeaderFooterLineColor();
[Visual Basic]
Public Sub ResetHeaderFooterLineColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.TextViewGenerator.Colors.ResetLightShadowColor Method

Resets the text control's LightShadowColor to its system dependent default value.

Syntax

[C#]
public void ResetLightShadowColor();
[Visual Basic]
Public Sub ResetLightShadowColor()

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput Class

An instance of the UserInput class can be used to inform a view generator about user input. It can be obtained through the ServerVisualization.TextViewGenerator.UserInput, ServerVisualization.RulerBarViewGenerator.UserInput, ServerVisualization.StatusBarViewGenerator.UserInput and ServerVisualization.DialogViewGenerator.UserInput properties.

Introduced: 21.0.

Syntax

[C#]
public class UserInput : MarshalByRefObject
[Visual Basic]
Public Class UserInput
Inherits MarshalByRefObject

Methods

Method | Description
SendKeyDown | Informs the view generator about a key down event.
SendKeyPress | Informs the view generator about a key press event.
SendKeyUp | Informs the view generator about a key up event.
SendMouseDoubleClick | Informs the view generator about a mouse double click event.
SendMouseDown | Informs the view generator about a mouse down event.
SendMouseMove | Informs the view generator about a mouse move event.
SendMouseUp | Informs the view generator about a mouse up event.
SendMouseWheel | Informs the view generator about a mouse wheel event.

Enumerations

Enumeration | Description
ModifierKeys | Determines a pressed modifier key.
MouseButtons | Determines a pressed mouse button.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.MouseButtons Enumeration

Determines a pressed mouse button. It contains the following values:

Member | Description
None | No mouse button was pressed.
Left | The left mouse button was pressed.
Right | The right mouse button was pressed.
Middle | The middle mouse button was pressed.
XButton1 | The first XButton button was pressed.
XButton2 | The second XButton button was pressed.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.ModifierKeys Enumeration

Determines a pressed modifier key. It contains the following values:

Member | Description
None | No modifier key was pressed.
Shift | The SHIFT key was pressed.
Control | The CTRL key was pressed.
Alt | The ALT key was pressed.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendKeyDown Method

Informs the view generator about a key down event.

Syntax

[C#]
public bool SendKeyDown(int keyCode, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendKeyDown(ByVal keyCode As Integer, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
keyCode | Specifies the virtual key code for the pressed key.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendKeyPress Method

Informs the view generator about a key press event.

Syntax

[C#]
public bool SendKeyPress(int keyChar, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendKeyPress(ByVal keyChar As Integer, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
keyChar | Specifies the translated character code for the pressed key.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendKeyUp Method

Informs the view generator about a key up event.

Syntax

[C#]
public bool SendKeyUp(int keyCode, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendKeyUp(ByVal keyCode As Integer, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
keyCode | Specifies the virtual key code for the pressed key.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendMouseDoubleClick Method

Informs the view generator about a mouse double click event.

Syntax

[C#]
public bool SendMouseDoubleClick(System.Drawing.Point viewLocation, ServerVisualization.UserInput.MouseButtons button, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendMouseDoubleClick(ByVal viewLocation As System.Drawing.Point, ByVal button As ServerVisualization.UserInput.MouseButtons, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
viewLocation | Specifies the location, where the mouse double click event occurs. The coordinates must be in pixels with an origin at the top-left corner of the view's location.
button | Specifies the pressed mouse button. It can be a value from the ServerVisualization.UserInput.MouseButtons enumeration.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendMouseDown Method

Informs the view generator about a mouse down event.

Syntax

[C#]
public bool SendMouseDown(System.Drawing.Point viewLocation, ServerVisualization.UserInput.MouseButtons button, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendMouseDown(ByVal viewLocation As System.Drawing.Point, ByVal button As ServerVisualization.UserInput.MouseButtons, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
viewLocation | Specifies the location, where the mouse down event occurs. The coordinates must be in pixels with an origin at the top-left corner of the view's location.
button | Specifies the pressed mouse button. It can be a value from the ServerVisualization.UserInput.MouseButtons enumeration.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendMouseMove Method

Informs the view generator about a mouse move event.

Syntax

[C#]
public bool SendMouseMove(System.Drawing.Point viewLocation, ServerVisualization.UserInput.MouseButtons button, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendMouseMove(ByVal viewLocation As System.Drawing.Point, ByVal button As ServerVisualization.UserInput.MouseButtons, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
viewLocation | Specifies the location, where the mouse move event occurs. The coordinates must be in pixels with an origin at the top-left corner of the view's location.
button | Specifies a pressed mouse button. It can be a value from the ServerVisualization.UserInput.MouseButtons enumeration.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendMouseUp Method

Informs the view generator about a mouse up event.

Syntax

[C#]
public bool SendMouseUp(System.Drawing.Point viewLocation, ServerVisualization.UserInput.MouseButtons button, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendMouseUp(ByVal viewLocation As System.Drawing.Point, ByVal button As ServerVisualization.UserInput.MouseButtons, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
viewLocation | Specifies the location, where the mouse up event occurs. The coordinates must be in pixels with an origin at the top-left corner of the view's location.
button | Specifies a pressed mouse button. It can be a value from the ServerVisualization.UserInput.MouseButtons enumeration.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.UserInput.SendMouseWheel Method

Informs the view generator about a mouse wheel event.

Syntax

[C#]
public bool SendMouseWheel(System.Drawing.Point viewLocation, int delta, ServerVisualization.UserInput.MouseButtons button, ServerVisualization.UserInput.ModifierKeys modifierKeys);
[Visual Basic]
Public Function SendMouseWheel(ByVal viewLocation As System.Drawing.Point, ByVal delta As Integer, ByVal button As ServerVisualization.UserInput.MouseButtons, ByVal modifierKeys As ServerVisualization.UserInput.ModifierKeys) As Boolean
Parameter | Description
viewLocation | Specifies the location, where the mouse wheel event occurs. The coordinates must be in pixels with an origin at the top-left corner of the view's location.
delta | Indicates the distance the wheel is rotated, expressed in multiples or divisions of 120. A positive value indicates that the wheel was rotated forward, away from the user; a negative value indicates that the wheel was rotated backward, toward the user.
button | Specifies a pressed mouse button. It can be a value from the ServerVisualization.UserInput.MouseButtons enumeration.
modifierKeys | Specifies modifier keys. It can be a combination of the ServerVisualization.UserInput.ModifierKeys values.

Return Value

If the event has been handled, the method returns true. Otherwise, it returns false.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View Class

An instance of the View class represents a part of a document for which an image can be generated. The part is defined through the view's location and size. It can be obtained through the ServerVisualization.TextViewGenerator.View, ServerVisualization.RulerBarViewGenerator.View, ServerVisualization.StatusBarViewGenerator.View and ServerVisualization.DialogViewGenerator.View properties.

Introduced: 21.0.

Syntax

[C#]
public class View : MarshalByRefObject
[Visual Basic]
Public Class View
Inherits MarshalByRefObject

Properties

Property | Description
Location | Gets or sets the view's location, in twips.
Size | Gets or sets the view's size, in twips.
ZoomFactor | Gets or sets the zoom factor, in percent, with which the View object generates the image.

Methods

Method | Description
GetCursorKind | Returns the cursor kind for a certain location in a document.
GetImage | Overloaded. Gets a part of a document as an image.
GetUpdateRectangle | Returns the coordinates of the smallest rectangle that completely encloses the update region.
OnAutoHScroll | Raises the AutoHScroll event.
OnAutoVScroll | Raises the AutoVScroll event.
OnChanged | Raises the view's Changed event.
OnZoomed | Raises the View's Zoomed event.

Events

Event | Description
AutoHScroll | Occurs when the horizontal location of the view has been changed automatically.
AutoVScroll | Occurs when the vertical location of the view has been changed automatically.
Changed | Occurs after the contents of the View object's image have been changed.
Zoomed | Occurs after the View object's zoom factor has been changed.

Fields

Field | Description
ScrollPadding | This property gets the minimum amout of the visible page background.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.AutoHScroll Event

Occurs when the horizontal location of the view has been changed automatically. This can be happen, if the input position is moved outside of the document part which is defined through the View object. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler AutoHScroll;
[Visual Basic]
Public Event AutoHScroll As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.AutoVScroll Event

Occurs when the vertical location of the view has been changed automatically. This can be happen, if the input position is moved outside of the document part which is defined through the View object. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler AutoVScroll;
[Visual Basic]
Public Event AutoVScroll As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.Changed Event

Occurs after the contents of the View object's image have been changed. The event handler receives an argument of type ViewChangedEventArgs containing data related to this event.

Syntax

[C#]
public event ViewChangedEventHandler Changed;
[Visual Basic]
Public Event Changed As ViewChangedEventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.GetCursorKind Method

Returns the cursor kind for a certain location in a document.

Syntax

[C#]
public CursorKind GetCursorKind(System.Drawing.Point viewLocation);
[Visual Basic]
Public Function GetCursorKind(ByVal viewLocation As System.Drawing.Point) As CursorKind
Member | Description
viewLocation | Specifies the location for which the cursor kind is returned. The coordinates must be in pixels with an origin at the top-left corner of the view's location.

Return Value

The return value specifies the kind of the cursor at the specified location. It can be one of the CursorKind values.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.GetImage Method

Gets a part of a document as an image.

GetImage()

Gets an image as a System.Drawing.Imaging.Bitmap.

[C#]
public System.Drawing.Imaging.Bitmap GetImage()
[Visual Basic]
Public Function GetImage() As System.Drawing.Imaging.Bitmap

GetImage(Rectangle)

Gets a clipping of the image as a System.Drawing.Imaging.Bitmap.

[C#]
public System.Drawing.Imaging.Bitmap GetImage(System.Drawing.Rectangle clipRectangle)
[Visual Basic]
Public Function GetImage(ByVal clipRectangle As System.Drawing.Rectangle) As System.Drawing.Imaging.Bitmap
Parameter | Description
clipRectangle | Specifies the clipping, in pixels, relative to the top-left corner of the image, determined through the View.Location and View.Size properties.

GetImage(Byte[])

Gets an image as an array of bytes.

[C#]
public bool GetImage(out byte[] arImage)
[Visual Basic]
Public Function GetImage(ByRef arImage As Byte()) As Boolean
Parameter | Description
arImage | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.

GetImage(Byte[], Rectangle)

Gets a clipping of the image as an array of bytes.

[C#]
public bool GetImage(out byte[] arImage, System.Drawing.Rectangle clipRectangle)
[Visual Basic]
Public Function GetImage(ByRef arImage As Byte(), ByVal clipRectangle As System.Drawing.Rectangle) As Boolean
Parameter | Description
arImage | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
clipRectangle | Specifies the clipping, in pixels, relative to the top-left corner of the image, determined through the View.Location and View.Size properties.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.GetUpdateRectangle Method

Returns the coordinates of the smallest rectangle that completely encloses the update region. When the document's visible part changes, a Changed event occurs and the changed part is added to the view's update region. The bValidate parameter can be used to reset the current update region to an empty rectangle. When the document's visible part changes because the document has been scrolled, the Changed event informs about the changed part, but it is not added to the update region.

Introduced: 24.0.

Syntax

[C#]
public Rectangle GetUpdateRectangle(bool bValidate);
[Visual Basic]
Public Function GetUpdateRectangle(ByVal bValidate As Boolean) As Rectangle
Member | Description
bValidate | Validates the current update region and resets it to an empty rectangle.

Return Value

The return value specifies the smallest rectangle that completely encloses the current update region.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.Location Property

Gets or sets the view's location, in twips.

Syntax

[C#]
public System.Drawing.Point Location { get; set; }
[Visual Basic]
Public Property Location() As System.Drawing.Point

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.OnAutoHScroll Method

Raises the AutoHScroll event.

Syntax

[C#]
protected virtual void OnAutoHScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnAutoHScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.OnAutoVScroll Method

Raises the AutoVScroll event.

Syntax

[C#]
protected virtual void OnAutoVScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnAutoVScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.OnChanged Method

Raises the view's Changed event.

Syntax

[C#]
protected virtual void OnChanged(ServerVisualization.ViewChangedEventArgs e);
[Visual Basic]
Protected Overridable Sub OnChanged(ByVal e As ServerVisualization.ViewChangedEventArgs)
Parameter | Description
e | Specifies an ViewChangedEventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.OnZoomed Method

Raises the View's Zoomed event.

Syntax

[C#]
protected virtual void OnZoomed(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnZoomed(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.ScrollPadding Property

This property gets the minimum amout of the visible page background. In the PageView view mode a TextControl displays pages with a border and a background outside of the pages.

Syntax

[C#]
public int ScrollPadding { get; }
[Visual Basic]
Public ReadOnly Property ScrollPadding As Integer

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.Size Property

Gets or sets the view's size, in twips.

Syntax

[C#]
public System.Drawing.Size Size { get; set; }
[Visual Basic]
Public Property Size() As System.Drawing.Size

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.Zoomed Event

Occurs after the View object's zoom factor has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Zoomed;
[Visual Basic]
Public Event Zoomed As EventHandler

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.View.ZoomFactor Property

Gets or sets the zoom factor, in percent, with which the View object generates the image.

Syntax

[C#]
public int ZoomFactor { get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ViewChangedEventArgs Class

The ViewChangedEventArgs class provides data for the View.Changed event. This event occurs when a part of the view's image must be updated.

Introduced: 24.0.

Syntax

[C#]
public class ViewChangedEventArgs: EventArgs
[Visual Basic]
Public Class ViewChangedEventArgs
  Inherits EventArgs

Properties

Property | Description
ClipRectangle | Gets the rectangular area, in pixels, which is affected through the changes.
ScrollDistance | Gets the amount the document has been scrolled.
ScrollOrientation | Gets a value which determines whether the change is the result of scrolling, either through setting the view's location in the document or through autoscrolling initiated through the control when the input position leaves the visible part of the document.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ViewChangedEventArgs.ClipRectangle Property

Gets the rectangular area, in pixels, which is affected through the changes. The coordinates are relative to the top-left corner of the view's image, which is determined through the View.Location and View.Size properties.

Syntax

[C#]
public System.Drawing.Rectangle ClipRectangle { get; }
[Visual Basic]
Public ReadOnly Property ClipRectangle() As System.Drawing.Rectangle

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ViewChangedEventArgs.ScrollDistance Property

Gets the amount the document has been scrolled. The direction is determined through the ScrollOrientation property. When the distance is less than zero the document is scrolled down or to the right, otherwise the document is scrolled up or to the left.

Syntax

[C#]
public int ScrollDistance { get; }
[Visual Basic]
Public ReadOnly Property ScrollDistance() As Integer

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.ServerVisualization.ViewChangedEventArgs.ScrollOrientation Property

Gets a value which determines whether the change is the result of scrolling, either through setting the view's location in the document or through autoscrolling initiated through the control when the input position leaves the visible part of the document.

Syntax

[C#]
public ServerVisualization.ScrollOrientation ScrollOrientation { get; }
[Visual Basic]
Public ReadOnly Property ScrollOrientation() As ServerVisualization.ScrollOrientation
Value | Description
None | The changes are not the result of a scroll operation. The rectangular area is added to the view's update region.
HorizontalScroll | The view has been scrolled horizontally. The ScrollDistance property determines the amount. When the system, which shows the view's image allows scrolling, the appropriate scrolling function can be used to avoid repainting the complete view. The ClipRectangle property gets the clipping rectangle of the part which must be repainted.
VerticalScroll | The view has been scrolled vertically.

Limitations

Read only.

See Also

  • Programming Category: Visualize the ServerTextControl
  • Graphical Overview: Visualize the ServerTextControl


TXTextControl.WPF namespace

Enumerations

TXTextControl.WPF.BookmarkDialog Class

TXTextControl.WPF.BooleanConverter Class

TXTextControl.WPF.ButtonBar Class

TXTextControl.WPF.ColorConverter Class

TXTextControl.WPF.DeleteBookmarksDialog Class

TXTextControl.WPF.GotoDialog Class

TXTextControl.WPF.HyperlinkDialog Class

TXTextControl.WPF.LogarithmicConverter Class

TXTextControl.WPF.MeasureConverter Class

TXTextControl.WPF.RibbonFormattingTab Class

TXTextControl.WPF.RibbonFrameLayoutTab Class

TXTextControl.WPF.RibbonInsertTab Class

TXTextControl.WPF.RibbonPageLayoutTab Class

TXTextControl.WPF.RibbonProofingTab Class

TXTextControl.WPF.RibbonReportingTab Class

TXTextControl.WPF.RibbonTableLayoutTab Class

TXTextControl.WPF.RibbonViewTab Class

TXTextControl.WPF.RulerBar Class

TXTextControl.WPF.RulerBar.Colors Class

TXTextControl.WPF.StatusBar Class

TXTextControl.WPF.StatusBarColors Class

TXTextControl.WPF.TextContextMenuEventArgs Class

TXTextControl.WPF.TextControl Class

TXTextControl.WPF.TextControlColors Class

TXTextControl.WPF.TextControlDocument Class

TXTextControl.WPF.TextControlToolBar Class

TXTextControl.WPF.TextControlToolBarPresenter Class


Enumerations

TXTextControl.WPF.DialogResult Enumeration


TXTextControl.WPF.DialogResult Enumeration

Specifies identifiers to indicate the return value of a dialog box.

Member | Description
Cancel | Specifies that the dialog box has been canceled.
None | Specifies that the dialog box has been left with the Escape key.
OK | Specifies that the dialog box has been left with OK.


TXTextControl.WPF.BookmarkDialog Class

The WPF.BookmarkDialog class implements a dialog box to insert a DocumentTarget at the current input position. If there is a target at the current input position, the name of the target is shown and can be edited. The dialog box can only be opened, if either DocumentTargetCollection.CanAdd returns true or if DocumentTargetCollection.GetItem() does not return null. Otherwise, an exception occurs. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the WPF.BookmarkDialog.DialogItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. The WPF.BookmarkDialog is a modal dialog box which must be shown with the WPF.BookmarkDialog.ShowDialog method.

Introduced: 22.0.

Syntax

[C#]
public class BookmarkDialog : System.Windows.Window
[Visual Basic]
Public Class BookmarkDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
BookmarkDialog | Creates a BookmarkDialog object for the specified WPF.TextControl.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a WPF.BookmarkDialog dialog box.

Example

The following example creates an BookmarkDialog object and shows the dialog box:

[C#]
BookmarkDialog dlg = new BookmarkDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New BookmarkDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.BookmarkDialog Constructor

Creates a BookmarkDialog object for the specified WPF.TextControl.

Syntax

[C#]
public BookmarkDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the WPF.TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.BookmarkDialog.DialogItem Enumeration

Each DialogItem represents an item in a WPF.BookmarkDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_BookmarkNameLabel | Identifies the Bookmark Name label.
TXITEM_BookmarkName | Identifies the Bookmark Name text box.
TXITEM_Deletable | Identifies the Deletable check box.
TXITEM_OK | Identifies the OK button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.BooleanConverter Class

The BooleanConverter class provides a way to convert a value to a boolean value. The converter returns true when the specified parameter is the string representation of the value. This is useful with data binding to place a checkmark in menus or to check or uncheck a toggle button. The class can be used in XAML as a static resource to automatically convert bound property values. Supported types are: System.Enum, int, int?, bool?, char and char?.

Introduced: 16.0.

Syntax

[C#]
[ValueConversion(typeof(int), typeof(bool))]
[ValueConversion(typeof(int?), typeof(bool))]
[ValueConversion(typeof(System.Enum), typeof(bool))]
[ValueConversion(typeof(bool?), typeof(bool))]
[ValueConversion(typeof(char), typeof(bool))]
[ValueConversion(typeof(char?), typeof(bool))]
public class BooleanConverter : IValueConverter
[Visual Basic]
Public Class BooleanConverter
  Implements IValueConverter

Methods

Method | Description
Convert | Converts a value to a boolean.
ConvertBack | Converts a boolean to a value of the type specified through the targetType parameter.

Example

The following XAML example shows how to bind radio buttons to the InputFormat.NumberedListFormat property using the BooleanConverter class and the InputFormat.NumberFormats property.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:BooleanConverter x:Key="boolConv" />
</Window.Resources>
…
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[0]}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=ArabicNumbers}" />
<RadioButton
   Content="{Binding ElementName=textControl1, Path=InputFormat.NumberFormats[1]}"
   GroupName="numberFormat"
   IsChecked="{Binding
      ElementName=textControl1,
      Path=InputFormat.NumberedListFormat,
      Converter={StaticResource boolConv},
      ConverterParameter=Letters}" />
…

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.BooleanConverter.Convert Method

Converts a value to a boolean. True is returned, if the specified parameter is the string representation of value.

Syntax

[C#]
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function Convert(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The value produced by the binding source. Supported types are: System.Enum, int, int?, bool?, char and char?.
targetType | The type of the binding target property. It must be a boolean.
parameter | The converter parameter to use. It must be a string. The converter returns true, if this value is the string representation of value. To convert a bool? to a bool, this parameter is not used and can be set to null.
culture | The culture to use in the converter.

Return Value

The converted value, true or false. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.BooleanConverter.ConvertBack Method

Converts a boolean to a value of the type specified through the targetType parameter.

Syntax

[C#]
public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function ConvertBack(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The boolean value that is produced by the binding target.
targetType | The type to convert to.
parameter | The converter parameter to use. It must be a string representation of the value to return. If value is true this value is returned. If value is false, DependencyProperty.UnsetValue is returned.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible or if value is false.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.ButtonBar Class

The WPF.ButtonBar class represents a tool bar which can be used to show or to set font and paragraph attributes of a WPF.TextControl. It is inherited from the System.Windows.Controls.ToolBar class, containing default buttons and comboboxes as items, accessible through the Items property. These items can be sorted, deleted or moved through programming code, additional items can be added through programming code or the design time collection editor. Each item has a name, available through its Name property, which corresponds with a member of the WPF.ButtonBar.ButtonBarItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it.

Syntax

[C#]
public class ButtonBar : System.Windows.Controls.ToolBar
[Visual Basic]
Public Class ButtonBar
  Inherits System.Windows.Controls.ToolBar

Enumerations

Enumeration | Description
ButtonBarItem | Each ButtonBarItem represents an item in a WPF.ButtonBar.

Example

The ButtonBar can be configured. The following example removes the Bold button from a ButtonBar:

[C#]
ToggleButton toggleButton = buttonBar1.FindName(ButtonBar.ButtonBarItem.TXITEM_Bold.ToString()) as ToggleButton;
buttonBar1.Items.Remove(toggleButton);
[Visual Basic]
Dim toggleButton As ToggleButton = TryCast(buttonBar1.FindName(ButtonBar.ButtonBarItem.TXITEM_Bold.ToString()), ToggleButton)
buttonBar1.Items.Remove(toggleButton)

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.ButtonBar.ButtonBarItem Enumeration

Each ButtonBarItem represents an item in a WPF.ButtonBar. The corresponding string of a ButtonBarItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_StyleName | Identifies the StyleName combobox.
TXITEM_FontFamily | Identifies the FontFamily combobox.
TXITEM_FontSize | Identifies the FontSize combobox.
TXITEM_ZoomFactor | Identifies the ZoomFactor combobox.
TXITEM_Bold | Identifies the Bold button.
TXITEM_Italic | Identifies the Italic button.
TXITEM_Underline | Identifies the Underline button.
TXITEM_Strikeout | Identifies the Strikeout button.
TXITEM_Subscript | Identifies the Subscript button.
TXITEM_Superscript | Identifies the Superscript button.
TXITEM_IncreaseFont | Identifies the IncreaseFont button.
TXITEM_DecreaseFont | Identifies the DecreaseFont button.
TXITEM_LeftAligned | Identifies the LeftAligned button.
TXITEM_Centered | Identifies the Centered button.
TXITEM_RightAligned | Identifies the RightAligned button.
TXITEM_Justified | Identifies the Justified button.
TXITEM_DecreaseIndent | Identifies the DecreaseIndent button.
TXITEM_IncreaseIndent | Identifies the IncreaseIndent button.
TXITEM_LeftToRight | Identifies the LeftToRight button.
TXITEM_RightToLeft | Identifies the RightToLeft button.
TXITEM_BulletedList | Identifies the BulletedList button.
TXITEM_NumberedList | Identifies the NumberedList button.
TXITEM_StructuredList | Identifies the StructuredList button.
TXITEM_ControlChars | Identifies the ControlChars button.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.ColorConverter Class

The WPF.ColorConverter class provides a way to convert a System.Drawing.Color value to System.Windows.Media.Color value. With this converter a property with a System.Drawing.Color type can be used in a XAML data binding.

Introduced: 16.0.

Syntax

[C#]
[ValueConversion(typeof(System.Drawing.Color), typeof(System.Windows.Media.Color))]
public class ColorConverter : IValueConverter
[Visual Basic]
Public Class ColorConverter
  Implements IValueConverter

Methods

Method | Description
Convert | Converts a System.Drawing.Color value to System.Windows.Media.Color value.
ConvertBack | Converts a System.Windows.Media.Color to a System.Drawing.Color value.

Example

The following XAML example shows how to bind the InputFormat.TextColor property to the fill color of a rectangle using the ColorConverter class.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:ColorConverter x:Key="colorConv" />
</Window.Resources>
…
<Rectangle
   Width="20"
   Height="20">
   <Rectangle.Fill>
      <SolidColorBrush
         Color="{Binding
            ElementName=textControl1,
            Path=InputFormat.TextColor,
            Converter={StaticResource colorConv}}" />
   </Rectangle.Fill>
</Rectangle>

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.ColorConverter.Convert Method

Converts a System.Drawing.Color value to System.Windows.Media.Color value.

Syntax

[C#]
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function Convert(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The value produced by the binding source. It must be a System.Drawing.Color value.
targetType | The type of the binding target property. It must be System.Windows.Media.Color.
parameter | This parameter is not used and can be set to null.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.ColorConverter.ConvertBack Method

Converts a System.Windows.Media.Color to a System.Drawing.Color value.

Syntax

[C#]
public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function ConvertBack(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The System.Windows.Media.Color value that is produced by the binding target.
targetType | The type to convert to. It must be System.Drawing.Color.
parameter | This parameter is not used and can be set to null.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.DeleteBookmarksDialog Class

The DeleteBookmarksDialog class implements a dialog box which shows all targets in the current document. The user can jump to a target or can delete one or more targets. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the WPF.DeleteBookmarksDialog.DialogItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. The WPF.DeleteBookmarksDialog is a modal dialog box which must be shown with the WPF.DeleteBookmarksDialog.ShowDialog method.

Introduced: 22.0.

Syntax

[C#]
public class DeleteBookmarksDialog : System.Windows.Window
[Visual Basic]
Public Class DeleteBookmarksDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
DeleteBookmarksDialog | Creates a DeleteBookmarksDialog object for the specified WPF.TextControl.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a WPF.DeleteBookmarksDialog dialog box.

Example

The following example creates an DeleteBookmarksDialog object and shows the dialog box:

[C#]
DeleteBookmarksDialog dlg = new DeleteBookmarksDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New DeleteBookmarksDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.DeleteBookmarksDialog Constructor

Creates a DeleteBookmarksDialog object for the specified WPF.TextControl.

Syntax

[C#]
public DeleteBookmarksDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the WPF.TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.DeleteBookmarksDialog.DialogItem Enumeration

Each DialogItem represents an item in a WPF.DeleteBookmarksDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_BookmarkListLabel | Identifies the bookmark list label.
TXITEM_BookmarkList | Identifies the bookmark listbox.
TXITEM_DeleteBookmark | Identifies the Delete button.
TXITEM_GotoBookmark | Identifies the Goto button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.GotoDialog Class

The GotoDialog class implements a dialog box which can be used to move the current input position to a certain page, section, line, table or bookmark. The new input position is shown with a marker. The dialog can be opened as a modeless dialog box. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the WPF.GotoDialog.DialogItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. The WPF.GotoDialog is a modeless dialog box which must be shown with the WPF.GotoDialog.Show method.

Introduced: 22.0.

Syntax

[C#]
public class GotoDialog : System.Windows.Window
[Visual Basic]
Public Class GotoDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
GotoDialog | Creates a GotoDialog object for the specified WPF.TextControl.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a WPF.GotoDialog dialog box.

Example

The following example creates a GotoDialog object and shows the dialog box:

[C#]
GotoDialog dlg = new GotoDialog(textControl1);
dlg.Show();
[Visual Basic]
Dim dlg As New GotoDialog(textControl1)
dlg.Show()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.GotoDialog Constructor

Creates a GotoDialog object for the specified WPF.TextControl.

Syntax

[C#]
public GotoDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the WPF.TextControl for which the dialog box is opened.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.GotoDialog.DialogItem Enumeration

Each DialogItem represents an item in a WPF.GotoDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_GotoLabel | Identifies the label of the Go to listbox.
TXITEM_GotoList | Identifies the Go to listbox.
TXITEM_NumberLabel | Identifies the label of the Number textbox.
TXITEM_Number | Identifies the Number textbox.
TXITEM_NameList | Identifies the Bookmark listbox.
TXITEM_GotoPrevious | Identifies Previous button.
TXITEM_GotoNext | Identifies the Next button.
TXITEM_Close | Identifies the Close button.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.HyperlinkDialog Class

The WPF.HyperlinkDialog class implements a built-in dialog box for inserting and editing a hyperlink at the current text input position. The dialog box inserts either a HypertextLink to an external location or a DocumentLink to a location in the same document. If there is such a link at the current input position, the data of the link is shown and can be edited. Furthermore the hyperlink at the current input position can be deleted. The dialog box can only be opened, if either HypertextLinkCollection.CanAdd returns true or if DocumentLinkCollection.GetItem() or HypertextLinkCollection.GetItem() does not return null. Otherwise, an exception occurs. Each item of the dialog box has a name, available through its Name property, which corresponds with a member of the WPF.HyperlinkDialog.DialogItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. The WPF.HyperlinkDialog is a modal dialog box which must be shown with the WPF.HyperlinkDialog.ShowDialog method.

Introduced: 22.0.

Syntax

[C#]
public class HyperlinkDialog : System.Windows.Window
[Visual Basic]
Public Class HyperlinkDialog
  Inherits System.Windows.Window

Constructors

Constructor | Description
HyperlinkDialog | Creates a HyperlinkDialog object for the specified WPF.TextControl.

Enumerations

Enumeration | Description
DialogItem | Each DialogItem represents an item in a WPF.HyperlinkDialog dialog box.

Example

The following example creates an HyperlinkDialog object and shows the dialog box:

[C#]
HyperlinkDialog dlg = new HyperlinkDialog(textControl1);
dlg.ShowDialog();
[Visual Basic]
Dim dlg As New HyperlinkDialog(textControl1)
dlg.ShowDialog()

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.HyperlinkDialog Constructor

Creates a HyperlinkDialog object for the specified WPF.TextControl.

Syntax

[C#]
public HyperlinkDialog(TextControl textControl);
[Visual Basic]
Public Sub New(textControl As TextControl)
Parameter | Description
textControl | Specifies the WPF.TextControl for which the dialog box is opened.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.HyperlinkDialog.DialogItem Enumeration

Each DialogItem represents an item in a WPF.HyperlinkDialog dialog box. The corresponding string of a DialogItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_HyperlinkTextLabel | Identifies the Hyperlink text label.
TXITEM_HyperlinkText | Identifies the Hyperlink text edit control.
TXITEM_HyperlinkLabel | Identifies the Hyperlink label.
TXITEM_Hyperlink | Identifies the Hyperlink edit control.
TXITEM_SelectFile | Identifies the Select File button.
TXITEM_BookmarkListLabel | Identifies the bookmark list label.
TXITEM_BookmarkList | Identifies the bookmark listbox.
TXITEM_ShowBookmarks | Identifies the Show Bookmarks label.
TXITEM_CurrentDocument | Identifies the Current Document radio button.
TXITEM_SelectedFile | Identifies the Selected File radio button.
TXITEM_DeleteHyperlink | Identifies the Delete Hyperlink button.
TXITEM_OK | Identifies the OK button.
TXITEM_Cancel | Identifies the Cancel button.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.LogarithmicConverter Class

The class WPF.LogarithmicConverter Converts a numeric value from a linear scale to a logarithmic scale. It can be used to provide better usability when mapping a zoom factor to a slider, for example. The range of values of the linear as well as the logarithmic scale have to be defined with the given "Minimum"- and "Maximum"-properties. Provides a possibility to define an input value which should be mapped to the center of the output range of values. The class can be used in XAML as a static resource to automatically convert bound property values.

Introduced: 16.0.

Syntax

[C#]
[ValueConversion(typeof(double), typeof(double))]
[ValueConversion(typeof(double), typeof(int))]
[ValueConversion(typeof(int), typeof(double))]
[ValueConversion(typeof(int), typeof(int))]
public class LogarithmicConverter : IValueConverter
[Visual Basic]
Public Class LogarithmicConverter
  Implements IValueConverter

Properties

Property | Description
InputCenter | Sets or gets the numeric value of the source value range which will be mapped to the center of the target value range.
InputMaximum | Sets or gets the upper bound of the source value range.
InputMinimum | Sets or gets the lower bound of the source value range.
OutputMaximum | Sets or gets the upper bound of the target value range.
OutputMinimum | Sets or gets the lower bound of the target value range.

Methods

Method | Description
Convert | Converts an integer or a double precision floating point value to an integer or a double precision floating point value.
ConvertBack | Converts an integer or a double precision floating point value to an integer or a double precision floating point value.

Example

The following XAML example shows how to bind the TextControl.ZoomFactor property to a slider using the LogarithmicConverter mapping a zoom range from 10 to 400 percent to a value range from 0 to 100.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:LogarithmicConverter
      x:Key="logConv"
      InputMinimum="10"
      InputCenter="100"
      InputMaximum="400"
      OutputMinimum="0"
      OutputMaximum="100" />
</Window.Resources>
…
<Slider
   Minimum="0"
   Maximum="100"
   Value="{Binding ElementName=textControl1, Path=ZoomFactor, Converter={StaticResource logConv}}" />

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.InputMinimum Property

Sets or gets the lower bound of the source value range. Smaller input values coming from the binding source are handled as if they were equal to this value.

Syntax

[C#]
public double InputMinimum { get; set; }
[Visual Basic]
Public Property InputMinimum() As Double

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.InputCenter Property

Sets or gets the numeric value of the source value range which will be mapped to the center of the target value range.

Syntax

[C#]
public double InputCenter { get; set; }
[Visual Basic]
Public Property InputCenter() As Double

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.InputMaximum Property

Sets or gets the upper bound of the source value range. Larger input values coming from the binding source are handled as if they were equal to this value.

Syntax

[C#]
public double InputMaximum { get; set; }
[Visual Basic]
Public Property InputMaximum() As Double

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.OutputMinimum Property

Sets or gets the lower bound of the target value range. Smaller values coming from the binding target are handled as if they were equal to this value.

Syntax

[C#]
public double OutputMinimum { get; set; }
[Visual Basic]
Public Property OutputMinimum() As Double

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.OutputMaximum Property

Sets or gets the upper bound of the target value range. Larger values coming from the binding target are handled as if they were equal to this value.

Syntax

[C#]
public double OutputMaximum { get; set; }
[Visual Basic]
Public Property OutputMaximum() As Double

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.Convert Method

Converts an integer or a double precision floating point value to an integer or a double precision floating point value.

Syntax

[C#]
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function Convert(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The value produced by the binding source. It must be either a double precision floating point value or an integer.
targetType | The type of the binding target property. It must be either a double precision floating point value or an integer.
parameter | The converter parameter. Is not used by this converter.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.LogarithmicConverter.ConvertBack Method

Converts an integer or a double precision floating point value to an integer or a double precision floating point value.

Syntax

[C#]
public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function ConvertBack(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The numeric value that is produced by the binding target.
targetType | The type of the binding source. It must be either a double precision floating point value or an integer.
parameter | The converter parameter. Is not used by this converter.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter Class

The MeasureConverter class provides a way to convert a measure in twips (twentieth of a point) to a value in another measuring unit. Twips are the measuring unit used by TXTextControl. Possible conversions are handled through the Unit property. The result of the conversion is a string or a double, which can be used to display the value for the user. This class can be used in XAML as a static resource to automatically convert bound property values.

Introduced: 16.0.

Syntax

[C#]
[ValueConversion(typeof(int), typeof(string))]
[ValueConversion(typeof(int), typeof(double))]
public class MeasureConverter : IValueConverter
[Visual Basic]
Public Class MeasureConverter
  Implements IValueConverter

Properties

Property | Description
Decimals | Gets or sets the number of decimals for the converted value.
ShowAllDecimals | Gets or sets a value specifying whether all decimals set with the Decimals property are shown, when the result is a string.
Unit | Gets or sets the measuring unit for the conversion.

Methods

Method | Description
Convert | Converts a value from twips to another meaasuring unit.
ConvertBack | Converts a value from another measuring unit to twips.

Example

The following XAML example binds the InputFormat.TopDistance property to a text box using the WPF.MeasureConverter class. The value of the top distance is converted to centimeter.

…
xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
…
<Window.Resources>
   <tx:MeasureConverter Unit="Centimeter" x:Key="twipsConv" />
</Window.Resources>
…
<TextBox
   Text="{Binding
      ElementName=textControl1,
      Path=InputFormat.TopDistance,
      Converter={StaticResource twipsConv},
      Mode=TwoWay}" />

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter.Convert Method

Converts a value from twips to another meaasuring unit.

Syntax

[C#]
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function Convert(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The value produced by the binding source. It must be an object of the type System.Int32 and the measuring unit must be twips (1/20 point).
targetType | The type of the binding target property. It must be a string or a double.
parameter | The converter parameter to use. This converter does not use parameter.
culture | The culture to use in the converter.

Return Value

A converted value, a string or a double. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter.ConvertBack Method

Converts a value from another measuring unit to twips.

Syntax

[C#]
public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture);
[Visual Basic]
Public Function ConvertBack(value As Object, targetType As Type, parameter As Object, culture As CultureInfo) As Object
Member | Description
value | The value that is produced by the binding target. It must be a string or a double.
targetType | The type to convert to. It is an object of the type System.Int32 and the measuring unit is twips (1/20 point).
parameter | The converter parameter to use. This converter does not use parameter.
culture | The culture to use in the converter.

Return Value

The converted value. The method returns DependencyProperty.UnsetValue, if the conversion is not possible.

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter.Decimals Property

Gets or sets the number of decimals for the converted value.

Syntax

[C#]
public int Decimals { get; set; }
[Visual Basic]
Public Property Decimals() As Integer

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter.Unit Property

Gets or sets the measuring unit for the conversion.

Syntax

[C#]
public MeasuringUnit Unit { get; set; }
[Visual Basic]
Public Property Unit() As MeasuringUnit
Value | Description
CentiInch | The resulting string is a value in 1/100 inch.
Centimeter | The resulting string is a value in cm.
Millimeter | The resulting string is a value in mm.
Point | The resulting string is a value in point (1/72 inch).
StandardWPF | The resulting string is a value in 1/96 inch, which are device independent units in WPF.
Twips | The resulting string is a value in twips (1/1440 inch).

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.MeasureConverter.ShowAllDecimals Property

Gets or sets a value specifying whether all decimals set with the Decimals property are shown, when the result is a string. If 3 decimals are set and the value is 15.5, the resulting string contains 15.500 when ShowAllDecimals is true and 15.5 when ShowAllDecimals is false. If the result is a double, this property has no meaning.

Syntax

[C#]
public bool ShowAllDecimals { get; set; }
[Visual Basic]
Public Property ShowAllDecimals() As Boolean

See Also

  • Data binding with TX Text Control
  • Programming Category: WPF Programming


TXTextControl.WPF.RibbonFormattingTab Class

The WPF.RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonFormattingTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonFormattingTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonFormattingTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 22.0.

Syntax

[C#]
public class RibbonFormattingTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonFormattingTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonFormattingTab.

Example

The RibbonFormattingTab can be configured. The following example removes the Bold button from a RibbonFormattingTab and inserts a simple button instead:

[C#]
FrameworkElement boldButton = ribbonFormattingTab1.FindName(RibbonFormattingTab.RibbonItem.TXITEM_Bold.ToString()) as FrameworkElement;
ItemsControl ic = boldButton.Parent as ItemsControl;
if (ic != null) {
    ic.Items.Remove(boldButton);
    RibbonButton ribbonButton = new RibbonButton();
    ribbonButton.Label = "New Button";
    ic.Items.Insert(0, ribbonButton);
}
[Visual Basic]
Dim boldButton As FrameworkElement = TryCast(ribbonFormattingTab1.FindName(RibbonFormattingTab.RibbonItem.TXITEM_Bold.ToString()), FrameworkElement)
Dim ic As ItemsControl = TryCast(boldButton.Parent, ItemsControl)
If ic IsNot Nothing Then
    ic.Items.Remove(boldButton)
    Dim ribbonButton As New RibbonButton()
    ribbonButton.Label = "New Button"
    ic.Items.Insert(0, ribbonButton)
End If

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonFormattingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonFormattingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_FontFamily | Identifies the FontFamily combobox.
TXITEM_FontSize | Identifies the FontSize combobox.
TXITEM_Bold | Identifies the Bold button.
TXITEM_Italic | Identifies the Italic button.
TXITEM_Underline | Identifies the Underline button.
TXITEM_Strikeout | Identifies the Strikeout button.
TXITEM_Subscript | Identifies the Subscript button.
TXITEM_Superscript | Identifies the Superscript button.
TXITEM_IncreaseFont | Identifies the IncreaseFont button.
TXITEM_DecreaseFont | Identifies the DecreaseFont button.
TXITEM_LeftAligned | Identifies the LeftAligned button.
TXITEM_Centered | Identifies the Centered button.
TXITEM_RightAligned | Identifies the RightAligned button.
TXITEM_Justified | Identifies the Justified button.
TXITEM_DecreaseIndent | Identifies the DecreaseIndent button.
TXITEM_IncreaseIndent | Identifies the IncreaseIndent button.
TXITEM_LeftToRight | Identifies the LeftToRight button.
TXITEM_RightToLeft | Identifies the RightToLeft button.
TXITEM_BulletedList | Identifies the BulletedList button.
TXITEM_NumberedList | Identifies the NumberedList button.
TXITEM_StructuredList | Identifies the StructuredList button.
TXITEM_ControlChars | Identifies the ControlChars button.
TXITEM_Paste | Identifies the Paste button.
TXITEM_Cut | Identifies the Cut button.
TXITEM_Copy | Identifies the Copy button.
TXITEM_ClearFormatting | Identifies the ClearFormatting button.
TXITEM_CharacterFormatting | Identifies the CharacterFormatting button.
TXITEM_EditTabs | Identifies the EditTabs button.
TXITEM_ParagraphFormatting | Identifies the ParagraphFormatting button.
TXITEM_Find | Identifies the Find button.
TXITEM_Replace | Identifies the Replace button.
TXITEM_Goto | Identifies the Goto button.
TXITEM_LeftFrameLine | Identifies the LeftFrameLine menu item.
TXITEM_TopFrameLine | Identifies the TopFrameLine menu item.
TXITEM_RightFrameLine | Identifies the RightFrameLine menu item.
TXITEM_BottomFrameLine | Identifies the BottomFrameLine menu item.
TXITEM_BoxFrame | Identifies the BoxFrame menu item.
TXITEM_AllFrameLines | Identifies the AllFrameLines menu item.
TXITEM_InnerHorizontalFrameLines | Identifies the InnerHorizontalFrameLines menu item.
TXITEM_InnerVerticalFrameLines | Identifies the InnerVerticalFrameLines menu item.
TXITEM_ChangeCase | Identifies the ChangeCase button.
TXITEM_TextBackColor | Identifies the TextBackColor button.
TXITEM_TextColor | Identifies the TextColor button.
TXITEM_Border | Identifies the Border button.
TXITEM_StyleName | Identifies the StyleName button.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonFrameLayoutTab Class

The RibbonFrameLayoutTab class represents a ribbon tab for editing objects of type Image, TextFrame, DrawingFrame and BarcodeFrame. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonFrameLayoutTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonFrameLayoutTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonFrameLayoutTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 24.0.

Syntax

[C#]
public class RibbonFrameLayoutTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonFrameLayoutTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonFrameLayoutTab | Initializes a new instance of the RibbonFrameLayoutTab class.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonFrameLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonFrameLayoutTab Constructor

Initializes a new instance of the RibbonFrameLayoutTab class.

Syntax

[C#]
public RibbonFrameLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonFrameLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonFrameLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_WrapText | Identifies the WrapText button of the RibbonFrameLayoutTab.
TXITEM_BringToFront | Identifies the BringToFront button of the RibbonFrameLayoutTab.
TXITEM_SendToBack | Identifies the SendToBack button of the RibbonFrameLayoutTab.
TXITEM_Position | Identifies the Position button of the RibbonFrameLayoutTab.
TXITEM_ObjectHeight | Identifies the ObjectHeight text box of the RibbonFrameLayoutTab.
TXITEM_ObjectWidth | Identifies the ObjectWidth text box of the RibbonFrameLayoutTab.
TXITEM_ObjectName | Identifies the ObjectName text box of the RibbonFrameLayoutTab.
TXITEM_ObjectID | Identifies the ObjectID text box of the RibbonFrameLayoutTab.
TXITEM_TextFrameBackColor | Identifies the TextFrameBackColor button of the RibbonFrameLayoutTab.
TXITEM_TextFrameTransparency | Identifies the TextFrameTransparency button of the RibbonFrameLayoutTab.
TXITEM_TextFrameLineWidth | Identifies the TextFrameLineWidth button of the RibbonFrameLayoutTab.
TXITEM_DrawingLineColor | Identifies the DrawingLineColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingBackColor | Identifies the DrawingBackColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingLineWidth | Identifies the DrawingLineWidth button of the RibbonFrameLayoutTab.
TXITEM_DrawingTransparency | Identifies the DrawingTransparency button of the RibbonFrameLayoutTab.
TXITEM_TableBackColor | Identifies the TableBackColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingRotation | Identifies the DrawingRotation button of the RibbonFrameLayoutTab.
TXITEM_BarcodeForeColor | Identifies the BarcodeForeColor button of the RibbonFrameLayoutTab.
TXITEM_BarcodeBackColor | Identifies the BarcodeBackColor button of the RibbonFrameLayoutTab.
TXITEM_BarcodeTransparency | Identifies the BarcodeTransparency button of the RibbonFrameLayoutTab.
TXITEM_BarcodeHorizontalAlignment | Identifies the BarcodeHorizontalAlignment button of the RibbonFrameLayoutTab.
TXITEM_BarcodeVerticalAlignment | Identifies the BarcodeVerticalAlignment button of the RibbonFrameLayoutTab.
TXITEM_BarcodeRotation | Identifies the BarcodeRotation button of the RibbonFrameLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonInsertTab Class

The WPF.RibbonInsertTab class represents a ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonInsertTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonInsertTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonInsertTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 22.0.

Syntax

[C#]
public class RibbonInsertTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonInsertTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonInsertTab.

Example

The WPF.RibbonInsertTab can be configured in the same way as the WPF.RibbonFormattingTab. See the Example section of the WPF.RibbonFormattingTab for more information

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonInsertTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonInsertTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_InsertPage | Identifies the InsertPage button of the RibbonInsertTab.
TXITEM_InsertPageBreak | Identifies the InsertPageBreak button of the RibbonInsertTab.
TXITEM_InsertTable | Identifies the InsertTable button of the RibbonInsertTab.
TXITEM_InsertImage | Identifies the InsertImage button of the RibbonInsertTab.
TXITEM_InsertShape | Identifies the InsertShape button of the RibbonInsertTab.
TXITEM_InsertBarcode | Identifies the InsertBarcode button of the RibbonInsertTab.
TXITEM_InsertHyperlink | Identifies the InsertHyperlink button of the RibbonInsertTab.
TXITEM_InsertBookmark | Identifies the InsertBookmark button of the RibbonInsertTab.
TXITEM_InsertHeader | Identifies the InsertHeader button of the RibbonInsertTab.
TXITEM_InsertFooter | Identifies the InsertFooter button of the RibbonInsertTab.
TXITEM_InsertPageNumber | Identifies the InsertPageNumber button of the RibbonInsertTab.
TXITEM_InsertTextFrame | Identifies the InsertTextFrame button of the RibbonInsertTab.
TXITEM_InsertFile | Identifies the InsertFile button of the RibbonInsertTab.
TXITEM_InsertSymbol | Identifies the InsertSymbol button of the RibbonInsertTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonPageLayoutTab Class

The RibbonPageLayoutTab class represents a tab for editing the page setup and layout. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonPageLayoutTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonPageLayoutTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonPageLayoutTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 24.0.

Syntax

[C#]
public class RibbonPageLayoutTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonPageLayoutTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonPageLayoutTab | Initializes a new instance of the RibbonPageLayoutTab class.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonPageLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonPageLayoutTab Constructor

Initializes a new instance of the RibbonPageLayoutTab class.

Syntax

[C#]
public RibbonPageLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonPageLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonPageLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_PageMargins | Identifies the PageMargins button of the RibbonPageLayoutTab.
TXITEM_Orientation | Identifies the Orientation button of the RibbonPageLayoutTab.
TXITEM_PageSize | Identifies the PageSize button of the RibbonPageLayoutTab.
TXITEM_Columns | Identifies the Columns button of the RibbonPageLayoutTab.
TXITEM_Breaks | Identifies the Breaks button of the RibbonPageLayoutTab.
TXITEM_PageColor | Identifies the PageColor button of the RibbonPageLayoutTab.
TXITEM_PageBorders | Identifies the PageBorders button of the RibbonPageLayoutTab.
TXITEM_PageLineColor | Identifies the PageLineColor button of the RibbonPageLayoutTab.
TXITEM_PageLineWidth | Identifies the PageLineWidth button of the RibbonPageLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonProofingTab Class

The RibbonProofingTab class represents a tab for setting proofing options such as spelling, hypheantion or language detection. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonProofingTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonProofingTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonProofingTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 24.0.

Syntax

[C#]
public class RibbonProofingTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonProofingTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonProofingTab | Initializes a new instance of the RibbonProofingTab class.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonProofingTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonProofingTab Constructor

Initializes a new instance of the RibbonProofingTab class.

Syntax

[C#]
public RibbonProofingTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonProofingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonProofingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_EnableSpellChecking | Identifies the EnableSpellChecking button of the RibbonProofingTab.
TXITEM_EnableHyphenations | Identifies the button of the RibbonProofingTab.
TXITEM_Spelling | Identifies the Spelling button of the RibbonProofingTab.
TXITEM_LoadDictionary | Identifies the LoadDictionary button of the RibbonProofingTab.
TXITEM_SpellingOptions | Identifies the SpellingOptions button of the RibbonProofingTab.
TXITEM_EnableLanguageDetection | Identifies the EnableLanguageDetection button of the RibbonProofingTab.
TXITEM_SetLanguage | Identifies the SetLanguage button of the RibbonProofingTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonReportingTab Class

The RibbonReportingTab class represents a WPF ribbon tab to integrate mail merge and reporting functionality. To modify a document by using these options the TextControl must be connected through the WPF.TextControl.RibbonReportingTab property.

Introduced: 24.0.

Syntax

[C#]
public class RibbonReportingTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonReportingTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonReportingTab | Initializes a new instance of the RibbonReportingTab class.

Properties

Property | Description
DataSourceManager | Provides the DataSourceManager that is connected with the RibbonReportingTab.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonReportingTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonReportingTab Constructor

Initializes a new instance of the RibbonReportingTab class.

Syntax

[C#]
public RibbonReportingTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonReportingTab.DataSourceManager Property

Provides the DataSourceManager that is connected with the RibbonReportingTab.

Syntax

[C#]
public DocumentServer.DataSources.DataSourceManager DataSourceManager { get; }
[Visual Basic]
Public ReadOnly Property DataSourceManager() As DocumentServer.DataSources.DataSourceManager

Limitations

Read only.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonReportingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonReportingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_DataSource | Identifies the DataSource button of the RibbonReportingTab.
TXITEM_SelectMasterTable | Identifies the SelectMasterTable button of the RibbonReportingTab.
TXITEM_EditDataRelations | Identifies the EditDataRelations button of the RibbonReportingTab.
TXITEM_InsertMergeField | Identifies the InsertMergeField button of the RibbonReportingTab.
TXITEM_InsertSpecialField | Identifies the InsertSpecialField button of the RibbonReportingTab.
TXITEM_FieldProperties | Identifies the FieldProperties button of the RibbonReportingTab.
TXITEM_DeleteField | Identifies the DeleteField button of the RibbonReportingTab.
TXITEM_InsertMergeBlock | Identifies the InsertMergeBlock button of the RibbonReportingTab.
TXITEM_EditMergeBlocks | Identifies the EditMergeBlocks button of the RibbonReportingTab.
TXITEM_ShowFieldCodes | Identifies the ShowFieldCodes button of the RibbonReportingTab.
TXITEM_ShowFieldText | Identifies the ShowFieldText button of the RibbonReportingTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonTableLayoutTab Class

The RibbonTableLayoutTab class represents a ribbon tab for editing tables. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonTableLayoutTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonTableLayoutTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonTableLayoutTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 24.0.

Syntax

[C#]
public class RibbonTableLayoutTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonTableLayoutTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonTableLayoutTab | Initializes a new instance of the RibbonTableLayoutTab class.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonTableLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonTableLayoutTab Constructor

Initializes a new instance of the RibbonTableLayoutTab class.

Syntax

[C#]
public RibbonTableLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonTableLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonTableLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_SelectTable | Identifies the SelectTable button of the RibbonTableLayoutTab.
TXITEM_TableGridLines | Identifies the TableGridLines button of the RibbonTableLayoutTab.
TXITEM_TableProperties | Identifies the TableProperties button of the RibbonTableLayoutTab.
TXITEM_DeleteTable | Identifies the DeleteTable button of the RibbonTableLayoutTab.
TXITEM_InsertTableRowAbove | Identifies the InsertTableRowAbove button of the RibbonTableLayoutTab.
TXITEM_InsertTableRowBelow | Identifies the InsertTableRowBelow button of the RibbonTableLayoutTab.
TXITEM_InsertTableColLeft | Identifies the InsertTableColLeft button of the RibbonTableLayoutTab.
TXITEM_InsertTableColRight | Identifies the InsertTableColRight button of the RibbonTableLayoutTab.
TXITEM_MergeTableCells | Identifies the MergeTableCells button of the RibbonTableLayoutTab.
TXITEM_SplitTableCells | Identifies the SplitTableCells button of the RibbonTableLayoutTab.
TXITEM_SplitTable | Identifies the SplitTable button of the RibbonTableLayoutTab.
TXITEM_TableFrameLines | Identifies the TableFrameLines button of the RibbonTableLayoutTab.
TXITEM_TableLineColor | Identifies the TableLineColor button of the RibbonTableLayoutTab.
TXITEM_TableBackColor | Identifies the TableBackColor button of the RibbonTableLayoutTab.
TXITEM_TableLineWidth | Identifies the TableLineWidth button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopLeft | Identifies the CellAlignTopLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopCentered | Identifies the CellAlignTopCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopRight | Identifies the CellAlignTopRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopJustified | Identifies the CellAlignTopJustified button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleLeft | Identifies the CellAlignMiddleLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleCentered | Identifies the CellAlignMiddleCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleRight | Identifies the CellAlignMiddleRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleJustified | Identifies the CellAlignMiddleJustified button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomLeft | Identifies the CellAlignBottomLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomCentered | Identifies the CellAlignBottomCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomRight | Identifies the CellAlignBottomRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomJustified | Identifies the CellAlignBottomJustified button of the RibbonTableLayoutTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonViewTab Class

The RibbonViewTab class represents a tab for customizing the view settings. It is inherited from the System.Windows.Controls.Ribbon.RibbonTab class and must be hosted in a System.Windows.Controls.Ribbon.Ribbon object. It can be connected with a WPF.TextControl through the WPF.TextControl.RibbonViewTab property. Each item has a name, available through its Name property, which corresponds with a member of the WPF.RibbonViewTab.RibbonItem enumeration. The FrameworkElement.FindName method can be used to get a certain item and manipulate, move or delete it. To use the WPF.RibbonViewTab class, Microsoft Ribbon for WPF 3.5 must be installed.

Introduced: 24.0.

Syntax

[C#]
public class RibbonViewTab : System.Windows.Controls.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonViewTab
  Inherits System.Windows.Controls.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonViewTab | Initializes a new instance of the RibbonViewTab class.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a WPF.RibbonViewTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.Windows.Forms.Ribbon.RibbonViewTab Constructor

Initializes a new instance of the RibbonViewTab class.

Syntax

[C#]
public RibbonViewTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RibbonViewTab.RibbonItem Enumeration

Each RibbonItem represents an item in a WPF.RibbonViewTab. The corresponding string of a RibbonItem is the same as the item's Name property. The string can be used with the FrameworkElement.FindName method to get the item and manipulate, move or delete it.

Member | Description
TXITEM_PrintLayout | Identifies the PrintLayout button of the RibbonViewTab.
TXITEM_Draft | Identifies the Draft button of the RibbonViewTab.
TXITEM_ZoomFactor | Identifies the ZoomFactor button of the RibbonViewTab.
TXITEM_Zoom100 | Identifies the Zoom100 button of the RibbonViewTab.
TXITEM_FullPage | Identifies the FullPage button of the RibbonViewTab.
TXITEM_PageWidth | Identifies the PageWidth button of the RibbonViewTab.
TXITEM_TextWidth | Identifies the TextWidth button of the RibbonViewTab.
TXITEM_HorizontalRuler | Identifies the HorizontalRuler button of the RibbonViewTab.
TXITEM_VerticalRuler | Identifies the VerticalRuler button of the RibbonViewTab.
TXITEM_StatusBar | Identifies the StatusBar button of the RibbonViewTab.
TXITEM_ShowTableGridlines | Identifies the TableGridlines button of the RibbonViewTab.
TXITEM_ShowBookmarkMarkers | Identifies the BookmarkMarkers button of the RibbonViewTab.
TXITEM_ShowTextFrameMarkersLines | Identifies the TextFrameMarkersLines button of the RibbonViewTab.
TXITEM_ShowDrawingFrameMarkersLines | Identifies the DrawingFrameMarkersLines button of the RibbonViewTab.
TXITEM_ShowControlChars | Identifies the ControlChars button of the RibbonViewTab.
TXITEM_ShowFrameAnchors | Identifies the FrameAnchors button of the RibbonViewTab.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar Class

The WPF.RulerBar class represents a tool bar which can be used to show or to set indents, margins and tabs of a WPF.TextControl. It can be connected with a WPF.TextControl through the WPF.TextControl.RulerBar or WPF.TextControl.VerticalRulerBar properties.

Introduced: 16.0.

Syntax

[C#]
public class RulerBar : TextControlToolBar
[Visual Basic]
Public Class RulerBar
  Inherits TextControlToolBar

Properties

Property | Description
BorderStyle | Gets or sets the border style of the ruler bar.
DisplayColors | Gets or sets the colors of the ruler bar.
EnablePageMargins | Enables or disables the setting of page margins.
ScaleUnit | Gets or sets the unit of the ruler bar's scale.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar.BorderStyle Property

Gets or sets the border style of the ruler bar.

Syntax

[C#]
public RulerBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle As RulerBarBorderStyle
Value | Description
ColorScheme | The ruler bar has a flat design without a border. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The ruler bar has a flat design and no border.
FixedSingle | The ruler bar has has a flat design and a border with a single line.
Simple3D | The ruler bar has a 3D design and no border.
Fixed3D | The ruler bar has a 3D design and a border with a single line.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar.DisplayColors Property

Gets or sets the colors of the ruler bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type WPF.RulerBarColors.

Syntax

[C#]
public RulerBarColors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As RulerBarColors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar.EnablePageMargins Property

Enables or disables the setting of page margins. If the property's value is true, the setting of page margins is enabled.

Syntax

[C#]
public bool EnablePageMargins { get; set; }
[Visual Basic]
Public Property EnablePageMargins As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar.ScaleUnit Property

Gets or sets the unit of the ruler bar's scale.

Syntax

[C#]
public RulerBarScaleUnit ScaleUnit { get; set; }
[Visual Basic]
Public Property ScaleUnit As RulerBarScaleUnit
Value | Description
Auto | The ruler is automatically scaled in inch or in millimeter depending on the currently set culture.
Centimeter | The ruler bar is scaled in centimeter without millimeter marks.
Inch | The ruler bar is scaled in inch.
Millimeter | The ruler bar is scaled in centimeter including millimeter marks.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBar.Colors Class

The WPF.RulerBarColors class gets, sets or resets the display colors of a WPF.RulerBar control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the ruler bar's BorderStyle property has been set to ColorScheme.

Introduced: 16.0.

Syntax

[C#]
public class RulerBarColors
[Visual Basic]
Public Class RulerBarColors

Constructors

Constructor | Description
Colors | Initializes a new instance of the WPF.RulerBarColors class.

Properties

Property | Description
WPF.RulerBarColors.BackColor | Gets or sets the background color at the left or top edge of the ruler bar.
WPF.RulerBarColors.ForeColor | Gets or sets the color used for the numbers of the ruler.
WPF.RulerBarColors.GradientBackColor | Gets or sets the background color at the right or bottom edge of the ruler bar.
WPF.RulerBarColors.RulerColor | Gets or sets the color of the ruler.
WPF.RulerBarColors.SeparatorColorDark | Gets or sets the color of dark separators.
WPF.RulerBarColors.SeparatorColorLight | Gets or sets the color of light separators.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors Constructor

Initializes a new instance of the WPF.RulerBarColors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the WPF.RulerBar.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public RulerBarColors();
[Visual Basic]
Public Class RulerBarColors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.BackColor Property

Gets or sets the background color at the left or top edge of the ruler bar.

Syntax

[C#]
public System.Windows.Media.Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.ForeColor Property

Gets or sets the color used for the numbers of the ruler.

Syntax

[C#]
public System.Windows.Media.Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.GradientBackColor Property

Gets or sets the background color at the right or bottom edge of the ruler bar.

Syntax

[C#]
public System.Windows.Media.Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.RulerColor Property

Gets or sets the color of the ruler.

Syntax

[C#]
public System.Windows.Media.Color RulerColor { get; set; }
[Visual Basic]
public Property RulerColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.SeparatorColorDark Property

Gets or sets the color of dark separators.

Syntax

[C#]
public System.Windows.Media.Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.RulerBarColors.SeparatorColorLight Property

Gets or sets the color of light separators.

Syntax

[C#]
public System.Windows.Media.Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar Class

The WPF.StatusBar class represents a tool bar which can be used to show the position of the curent text input position and other status information of a WPF.TextControl. It can be connected with a WPF.TextControl through the WPF.TextControl.StatusBar property.

Introduced: 16.0.

Syntax

[C#]
public class StatusBar : TextControlToolBar
[Visual Basic]
Public Class StatusBar
Inherits TextControlToolBar

Properties

Property | Description
BorderStyle | Gets or sets the border style of the status bar.
ColumnText | Gets or sets the text in the 'Column' area of the status bar.
DisplayColors | Gets or sets the colors of the status bar.
FontFamily | Gets or sets the font family of the status bar.
FontSize | Gets or sets the font size of the status bar in device-independent units (1/96th inch).
FontStyle | Gets or sets the font style of the status bar.
FontWeight | Gets or sets the weight or thickness of the status bar's font.
LineText | Gets or sets the text in the 'Line' area of the status bar.
PageCounterText | Gets or sets the text in the 'Page counter' area of the status bar.
PageText | Gets or sets the text in the 'Page' area of the status bar.
SectionCounterText | Gets or sets the text in the 'Section counter' area of the status bar.
SectionText | Gets or sets the text in the 'Section' area of the status bar.
ShowColumn | Specifies whether the status bar shows the column number of the current text input position.
ShowKeyStates | Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.
ShowLanguage | Specifies whether the status bar shows the language of the text selection or the text input position.
ShowLine | Specifies whether the status bar shows the line number of the current text input position.
ShowPage | Specifies whether the status bar shows the page number of the current text input position.
ShowPageCounter | Specifies whether the status bar shows the number of pages the document consists of.
ShowSection | Specifies whether the status bar shows the section number of the current text input position.
ShowSectionCounter | Specifies whether the status bar shows the number of sections the document consists of.
ShowZoom | Specifies whether the status bar shows the current zoom factor.
ShowZoomTrackBar | Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.
Text | Gets or sets the text of the status bar.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.BorderStyle Property

Gets or sets the border style of the status bar.

Syntax

[C#]
public StatusBarBorderStyle BorderStyle { get; set; }
[Visual Basic]
Public Property BorderStyle() As StatusBarBorderStyle
Value | Description
ColorScheme | The status bar has a flat design without a border and with a horizontal color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.
Flat | The status bar has a flat design and no border.
FixedSingle | The status bar has a flat design and a border with a single line.
Simple3D | The status bar has a 3D design and no border.
Fixed3D | The status bar has a 3D design and a border with a single line.
VerticalColorScheme | The status bar has a flat design without a border and with a horizontal color gradient in the background. The colors depend on the color scheme currently set through the system or on the colors set with the DisplayColors property.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ColumnText Property

Gets or sets the text in the 'Column' area of the status bar.

Syntax

[C#]
public string ColumnText { get; set; }
[Visual Basic]
Public Property ColumnText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.DisplayColors Property

Gets or sets the colors of the status bar. These colors are only used when the BorderStyle property has been set to ColorScheme. The property value is an object of the type WPF.StatusBarColors.

Syntax

[C#]
public StatusBarColors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As StatusBarColors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.FontFamily Property

Gets or sets the font family of the status bar. This is a dependency property. The property value has the type System.Windows.Media.FontFamily.

Syntax

[C#]
public FontFamily FontFamily { get; set; }
[Visual Basic]
Public Property FontFamily() As FontFamily

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.FontSize Property

Gets or sets the font size of the status bar in device-independent units (1/96th inch). This is a dependency property.

Syntax

[C#]
public double FontSize { get; set; }
[Visual Basic]
Public Property FontSize() As Double

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.FontStyle Property

Gets or sets the font style of the status bar. This is a dependency property. The property value has the type System.Windows.FontStyle. The default value is FontStyles.Normal.

Syntax

[C#]
public FontStyle FontStyle { get; set; }
[Visual Basic]
Public Property FontStyle() As FontStyle

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.FontWeight Property

Gets or sets the weight or thickness of the status bar's font. This is a dependency property. The property value has the type System.Windows.FontWeight. The default value is FontWeights.Normal.

Syntax

[C#]
public FontWeight FontWeight { get; set; }
[Visual Basic]
Public Property FontWeight() As FontWeight

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.LineText Property

Gets or sets the text in the 'Line' area of the status bar.

Syntax

[C#]
public string LineText { get; set; }
[Visual Basic]
Public Property LineText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.PageCounterText Property

Gets or sets the text in the 'Page counter' area of the status bar.

Syntax

[C#]
public string PageCounterText { get; set; }
[Visual Basic]
Public Property PageCounterText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.PageText Property

Gets or sets the text in the 'Page' area of the status bar.

Syntax

[C#]
public string PageText { get; set; }
[Visual Basic]
Public Property PageText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.SectionCounterText Property

Gets or sets the text in the 'Section counter' area of the status bar.

Syntax

[C#]
public string SectionCounterText { get; set; }
[Visual Basic]
Public Property SectionCounterText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.SectionText Property

Gets or sets the text in the 'Section' area of the status bar.

Syntax

[C#]
public string SectionText { get; set; }
[Visual Basic]
Public Property SectionText() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowColumn Property

Specifies whether the status bar shows the column number of the current text input position.

Syntax

[C#]
public bool ShowColumn { get; set; }
[Visual Basic]
Public Property ShowColumn() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowKeyStates Property

Specifies whether the status bar shows the key state of the CAPSLOCK and the NUMLOCK key and the current insertion mode, insert or overwrite.

Syntax

[C#]
public bool ShowKeyStates { get; set; }
[Visual Basic]
Public Property ShowKeyStates() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowLanguage Property

Specifies whether the status bar shows the language of the text selection or the text input position.

Introduced: 20.0.

Syntax

[C#]
public bool ShowLanguage { get; set; }
[Visual Basic]
Public Property ShowLanguage() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowLine Property

Specifies whether the status bar shows the line number of the current text input position.

Syntax

[C#]
public bool ShowLine { get; set; }
[Visual Basic]
Public Property ShowLine() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowPage Property

Specifies whether the status bar shows the page number of the current text input position.

Syntax

[C#]
public bool ShowPage { get; set; }
[Visual Basic]
Public Property ShowPage() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowPageCounter Property

Specifies whether the status bar shows the number of pages the document consists of.

Syntax

[C#]
public bool ShowPageCounter { get; set; }
[Visual Basic]
Public Property ShowPageCounter() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowSection Property

Specifies whether the status bar shows the section number of the current text input position.

Syntax

[C#]
public bool ShowSection { get; set; }
[Visual Basic]
Public Property ShowSection() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowSectionCounter Property

Specifies whether the status bar shows the number of sections the document consists of.

Syntax

[C#]
public bool ShowSectionCounter { get; set; }
[Visual Basic]
Public Property ShowSectionCounter() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowZoom Property

Specifies whether the status bar shows the current zoom factor.

Syntax

[C#]
public bool ShowZoom { get; set; }
[Visual Basic]
Public Property ShowZoom() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.ShowZoomTrackBar Property

Specifies whether the status bar displays a track bar instead of a simple number to show and to set the zooming factor.

Introduced: 18.0.

Syntax

[C#]
public bool ShowZoomTrackBar { get; set; }
[Visual Basic]
Public Property ShowZoomTrackBar() As Boolean

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBar.Text Property

Gets or sets the text of the status bar. When a text is set, the status bar shows this text until a status of a connected WPF.TextControl changes.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors Class

The WPF.StatusBarColors class gets, sets or resets the display colors of a WPF.StatusBar control. By default the display colors depend on sytem colors. With this class all colors can be individually designed. The colors are only used when the status bar's BorderStyle property has been set to ColorScheme.

Introduced: 16.0.

Syntax

[C#]
public class StatusBarColors
[Visual Basic]
Public Class StatusBarColors

Constructors

Constructor | Description
StatusBarColors | Initializes a new instance of the WPF.StatusBarColors class.

Properties

Property | Description
BackColor | Gets or sets the background color at the left edge of the status bar.
BackColorBottom | Gets or sets the background color at the bottom of the status bar.
BackColorMiddle | Gets or sets the background color in the middle of the status bar.
BackColorTop | Gets or sets the background color at the top of the status bar.
ForeColor | Gets or sets the color used for text and numbers.
FrameColor | Gets or sets the color of the status bar's frames.
GradientBackColor | Gets or sets the background color at the right edge of the status bar.
SeparatorColorDark | Gets or sets the color of the dark part of a separator.
SeparatorColorLight | Gets or sets the color of the light part of a separator.

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors Constructor

Initializes a new instance of the WPF.StatusBarColors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the WPF.StatusBar.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public StatusBarColors();
[Visual Basic]
Public Class StatusBarColors

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.BackColor Property

Gets or sets the background color at the left edge of the status bar. This color is only used with the ColorScheme border style.

Syntax

[C#]
public System.Windows.Media.Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.BackColorBottom Property

Gets or sets the background color at the bottom of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public System.Windows.Media.Color BackColorBottom { get; set; }
[Visual Basic]
Public Property BackColorBottom As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.BackColorMiddle Property

Gets or sets the background color in the middle of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public System.Windows.Media.Color BackColorMiddle { get; set; }
[Visual Basic]
Public Property BackColorMiddle As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.BackColorTop Property

Gets or sets the background color at the top of the status bar. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public System.Windows.Media.Color BackColorTop { get; set; }
[Visual Basic]
Public Property BackColorTop As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.ForeColor Property

Gets or sets the color used for text and numbers.

Syntax

[C#]
public System.Windows.Media.Color ForeColor { get; set; }
[Visual Basic]
Public Property ForeColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.FrameColor Property

Gets or sets the color of the status bar's frames.

Syntax

[C#]
public System.Windows.Media.Color FrameColor { get; set; }
[Visual Basic]
Public Property FrameColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.GradientBackColor Property

Gets or sets the background color at the right edge of the status bar.

Syntax

[C#]
public System.Windows.Media.Color GradientBackColor { get; set; }
[Visual Basic]
Public Property GradientBackColor As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.SeparatorColorDark Property

Gets or sets the color of the dark part of a separator. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public System.Windows.Media.Color SeparatorColorDark { get; set; }
[Visual Basic]
public Property SeparatorColorDark As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.StatusBarColors.SeparatorColorLight Property

Gets or sets the color of the light part of a separator. This color is only used with the VerticalColorScheme border style.

Introduced: 18.0.

Syntax

[C#]
public System.Windows.Media.Color SeparatorColorLight { get; set; }
[Visual Basic]
public Property SeparatorColorLight As System.Windows.Media.Color

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextContextMenuEventArgs Class

The WPF.TextContextMenuEventArgs class provides data for the WPF.TextControl.TextContextMenuOpening event. This event occurs, immediately before a built-in context menu will be opened. A TextControl provides context menus for different parts of a document. The ContextMenuLocation property informs for which part the menu will be opened. The pre-defined menu provided with the TextContextMenu property can be altered or expanded.

Introduced: 19.0.

Syntax

[C#]
public class TextContextMenuEventArgs: CancelEventArgs
[Visual Basic]
Public Class TextContextMenuEventArgs
  Inherits EventArgs

Properties

Property | Description
ContextMenuLocation | Gets the location in the document for which the context menu will be opened.
HorizontalOffset | Gets the horizontal distance between the top-left corner of the screen and the location where the menu is displayed.
TextContextMenu | Gets or sets the context menu, which will be shown.
VerticalOffset | Gets the vertical distance between the top-left corner of the screen and the location where the menu is displayed.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextContextMenuEventArgs.ContextMenuLocation Property

Gets the location in the document for which the context menu will be opened. The context menu items, which will be shown, depend on this location. The property value can be a combination (bitwise or) of the ContextMenuLocation values.

Syntax

[C#]
public ContextMenuLocation ContextMenuLocation { get; }
[Visual Basic]
Public ReadOnly Property ContextMenuLocation() As ContextMenuLocation

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextContextMenuEventArgs.HorizontalOffset Property

Gets the horizontal distance between the top-left corner of the screen and the location where the menu is displayed.

Syntax

[C#]
public double HorizontalOffset { get; }
[Visual Basic]
Public ReadOnly Property HorizontalOffset() As Double

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextContextMenuEventArgs.TextContextMenu Property

Gets or sets the context menu, which will be shown. The items depend on the document location where the mouse click occurs. The menu can be altered, extended or completely replaced. When this property is set to null, the WPF.TextControl uses system menu items. To completely suppress a context menu, the Cancel Property must be set the true.

Syntax

[C#]
public System.Windows.Controls.ContextMenu TextContextMenu { get; set; }
[Visual Basic]
Public Property TextContextMenu() As System.Windows.Controls.ContextMenu

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextContextMenuEventArgs.VerticalOffset Property

Gets the vertical distance between the top-left corner of the screen and the location where the menu is displayed.

Syntax

[C#]
public double VerticalOffset { get; }
[Visual Basic]
Public ReadOnly Property VerticalOffset() As Double

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl Class

The WPF.TextControl class class implements a control with high-level text editing features. It is inherited from the System.Windows.Controls.Control class. The following describes only the properties, methods and events defined through this class. For a list of inherited properties, methods and events see the .NET Framework reference. The WPF.TextControl class implements the IFormattedText interface.

Introduced: 16.0.

Syntax

[C#]
[TemplatePart(Name = "TXPART_Border", Type = typeof(Border))]
[TemplatePart(Name = "TXPART_ScrollViewer", Type = typeof(ScrollViewer))]
[TemplatePart(Name = "TXPART_Document", Type = typeof(TextControlDocument))]
public class TextControl : System.Windows.Controls.Control, IFormattedText
[Visual Basic]
<TemplatePartAttribute(Name := "TXPART_Border", Type := GetType(Border))> _
<TemplatePartAttribute(Name := "TXPART_ScrollViewer", Type := GetType(ScrollViewer))> _
<TemplatePartAttribute(Name := "TXPART_Document", Type := GetType(TextControlDocument))> _
Public Class TextControl _
  Inherits System.Windows.Controls.Control _
  Implements IFormattedText

Constructors

Constructor | Description
TextControl | Initializes a new instance of the WPF.TextControl class.

Properties

Property | Description
AcceptsTab | Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order.
AllowDrag | Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation.
AllowDrop | Inherited from System.Windows.UIElement.
ApplicationFields | Gets a collection of all application fields contained in the text part with the input focus.
AutoControlSize | Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text.
Barcodes | Gets a collection of all barcodes contained in the text part with the input focus.
Baseline | Gets or sets the baseline alignment, in twips, of the Text Control.
BorderThickness | Gets or sets the border thickness of the Text Control.
ButtonBar | Specifies the button bar control to be used with a TextControl.
CanCopy | Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.
CanPaste | Informs whether the clipboard contains a format that can be pasted into a Text Control document.
CanRedo | Informs whether an operation can be re-done using the Redo method.
CanUndo | Gets a value indicating whether the user can undo the previous operation in a Text Control.
CaretWidth | Gets or sets the width of the caret in pixels.
ControlChars | Specifies if control characters are visible or not.
DisplayColors | Gets or sets the colors of the text control.
DocumentLinks | Gets a collection of all document links contained in the text part with the input focus.
DocumentTargetMarkers | Gets or sets a value indicating that markers for hypertext targets are shown or not.
DocumentTargets | Gets a collection of all targets contained in the text part with the input focus.
DrawingMarkerLines | Specifies whether a marker frame is shown around a drawing to indicate its position and size.
Drawings | Gets a collection of all drawings contained in the text part with the input focus.
DropFormats | Gets or sets the formats of data the control can accept when the user drags it onto the control.
EditMode | Gets or sets a value indicating whether text in the Text Control is read-only, can be selected or is editable.
FieldCursor | Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.
FontFamily | Gets or sets the font family of the text control.
FontSettings | Gets a FontSettings object which provides properties determining which fonts can be used in a document.
FontSize | Gets or sets the font size of the text control in device-independent units (1/96th inch).
FontStyle | Gets or sets the font style of the text control.
FontUnderlineStyle | Gets or sets the underlining style for the text displayed by the control.
FontWeight | Gets or sets the weight or thickness of the text control's font.
FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
Frames | Gets a collection of all images, textframes, barcodes and drawings contained in the text part with the input focus.
GetPages | Gets a collection of all pages in the document.
HeaderFooterActivationStyle | Gets or sets a value specifying the activation style for headers and footers.
HeaderFooterFrameStyle | Gets or sets a value specifying the frame for activated headers and footers.
HeadersAndFooters | Gets a collection of all headers and footers the current document contains.
HideSelection | Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown.
HypertextLinks | Gets a collection of all hypertext links contained in the text part with the input focus.
Images | Gets a collection of all images contained in the text part with the input focus.
InlineStyles | Gets a collection of all inline styles the current document contains.
InputFormat | Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.
InputPosition | Gets or sets the current text input position.
InsertionMode | Specifies whether text is inserted or overwrites existing text.
IsHyphenationEnabled | Gets or sets a value indicating whether hyphenation is active or not.
IsLanguageDetectionEnabled | Gets or sets a value indicating whether language detection is active or not.
IsSpellCheckingEnabled | Gets or sets a value indicating whether spell checking is active or not.
IsTabStop | Gets or sets a value that indicates whether a text control is included in tab navigation.
IsUndoEnabled | Gets or sets a value indicating whether the undo buffer is active or not.
Landscape | Gets or sets a value indicating whether the page orientation is landscape or portrait.
Lines | Gets a collection of all lines contained in the text part with the input focus.
ListFormat | Gets or sets the type and the formatting attributes of a bulleted or numbered list.
MisspelledWords | Gets a collection of all misspelled words contained in the text part with the input focus.
PageMargins | Gets or sets the margins for the pages of the current document.
Pages | Gets the number of pages contained in the current document.
PageSize | Specifies the width and height of the pages for the current document.
PageUnit | Gets or sets the measure used for page sizes and page margins.
ParagraphFormat | Gets or sets the paragraph formatting attributes of the text displayed by the control.
Paragraphs | Gets a collection of all paragraphs contained in the text part with the input focus.
ParagraphStyles | Gets a collection of all paragraph styles the current document contains.
PermanentControlChars | Gets or sets a value indicating which control characters are shown permanently on the screen.
RedoActionName | Gets a string that represents the name of the action that will be performed when a call to the Redo method is made.
RibbonFormattingTab | Specifies the name of the WPF.RibbonFormattingTab object to be used with a TextControl.
RibbonFrameLayoutTab | Specifies the name of the WPF.RibbonFrameLayoutTab object to be used with a TextControl.
RibbonInsertTab | Specifies the name of the WPF.RibbonInsertTab object to be used with a TextControl.
RibbonPageLayoutTab | Specifies the name of the WPF.RibbonPageLayoutTab object to be used with a TextControl.
RibbonProofingTab | Specifies the name of the WPF.RibbonProofingTab object to be used with a TextControl.
RibbonReportingTab | Specifies the name of the WPF.RibbonReportingTab object to be used with a TextControl.
RibbonTableLayoutTab | Specifies the name of the WPF.RibbonTableLayoutTab object to be used with a TextControl.
RibbonViewTab | Specifies the name of the WPF.RibbonViewTab object to be used with a TextControl.
RulerBar | Specifies the horizontal ruler bar control to be used with a TextControl.
ScrollLocation | Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.
Sections | Gets a collection of all sections in the document.
Selection | Gets or sets the current selection in the text part with the input focus.
SelectionViewMode | Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.
SpellCheckContextMenu | Specifies the context menu which is used when the end-user right-clicks a misspelled word.
SpellChecker | Specifies the spell checking component to be used with a TextControl.
StatusBar | Specifies the status bar control to be used with a TextControl.
SubTextParts | Gets a collection of all subtextparts contained in the text part with the input focus.
TabIndex | Gets or sets the tab index of the text control.
Tables | Gets a collection of all tables contained in the text part with the input focus.
Text | Gets or sets the text contents of the text control.
TextChars | Gets a collection of all characters contained in the text part with the input focus.
TextFields | Gets a collection of all standard text fields contained in the text part with the input focus.
TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TextFrames | Gets a collection of all text frames contained in the text part with the input focus.
TextParts | Gets a collection of all main text parts the current document contains.
UndoActionName | Gets a string that represents the name of the action that will be performed when a call to the Undo method is made.
VerticalRulerBar | Specifies the vertical ruler bar control to be used with a TextControl.
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown.
ViewMode | Gets or sets the mode in which Text Control displays its contents.
XmlEditMode | Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.
ZoomFactor | Gets or sets the zoom factor, in percent, for a Text Control.

Methods

Method | Description
AddSymbolDialog | Invokes a built-in dialog box for inserting symbol characters.
Append | Overloaded. Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.
BarcodeLayoutDialog | Overloaded. Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode.
BeginUndoAction | Begins a user-defined undo operation.
Clear | Clears the selected text or the character right from the current input position from the Text Control.
ClearUndo | Clears the undo buffer of the Text Control.
Copy | Copies the current selection in the Text Control to the Clipboard.
Cut | Moves the current selection in the Text Control to the Clipboard.
DrawingLayoutDialog | Overloaded. Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing.
EndUndoAction | Ends a user-defined undo operation.
Find | Overloaded. Finds a text string in the text part with the input focus.
FontDialog | Invokes the built-in font dialog box.
ForeColorDialog | Invokes the built-in dialog box for setting the text color.
FormattingStylesDialog | Invokes the built-in dialog box for creating, deleting and modifying formatting styles.
FrameFillColorDialog | Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.
FrameLineColorDialog | Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.
GetClipboardFormats | Returns an array of ClipboardFormat values.
GetSupportedFonts | Gets an array of strings specifying the names of all currently supported fonts.
GetSupportedPaperSizes | Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes.
GetTextFields | Returns a collection containing text fields of the specified types.
GetVersionInfo | Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.
GetXmlElements | Returns a collection of XML elements.
ImageAttributesDialog | Overloaded. Invokes the built-in dialog box for setting attributes of images.
LanguageDialog | Invokes the built-in dialog box for setting the language of the selected text.
ListFormatDialog | Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.
Load | Overloaded. Loads text in a certain format.
OnAdaptFont | Raises the AdaptFont event.
OnBarcodeClicked | Raises the BarcodeClicked event.
OnBarcodeCreated | Raises the BarcodeCreated event.
OnBarcodeDeleted | Raises the BarcodeDeleted event.
OnBarcodeDeselected | Raises the BarcodeDeselected event.
OnBarcodeDoubleClicked | Raises the BarcodeDoubleClicked event.
OnBarcodeMoved | Raises the BarcodeMoved event.
OnBarcodeRightClicked | Raises the BarcodeRightClicked event.
OnBarcodeSelected | Raises the BarcodeSelected event.
OnBarcodeSized | Raises the BarcodeSized event.
OnChanged | Raises the Changed event.
OnCharFormatChanged | Raises the CharFormatChanged event.
OnDocumentLinkClicked | Raises the DocumentLinkClicked event.
OnDocumentLoaded | Raises the DocumentLoaded event.
OnDrawingActivated | Raises the DrawingActivated event.
OnDrawingClicked | Raises the DrawingClicked event.
OnDrawingCreated | Raises the DrawingCreated event.
OnDrawingDeactivated | Raises the DrawingDeactivated event.
OnDrawingDeleted | Raises the DrawingDeleted event.
OnDrawingDeselected | Raises the DrawingDeselected event.
OnDrawingDoubleClicked | Raises the DrawingDoubleClicked event.
OnDrawingMoved | Raises the DrawingMoved event.
OnDrawingRightClicked | Raises the DrawingRightClicked event.
OnDrawingSelected | Raises the DrawingSelected event.
OnDrawingSized | Raises the DrawingSized event.
OnFormattingStyleListChanged | Raises the FormattingStyleListChanged event.
OnFrameClicked | Raises the FrameClicked event.
OnFrameDeselected | Raises the FrameDeselected event.
OnFrameDoubleClicked | Raises the FrameDoubleClicked event.
OnFrameLayoutChanged | Raises the FrameLayoutChanged event.
OnFrameMoved | Raises the FrameMoved event.
OnFrameRightClicked | Raises the FrameRightClicked event.
OnFrameSelected | Raises the FrameSelected event.
OnFrameSized | Raises the FrameSized event.
OnHeaderFooterActivated | Raises the HeaderFooterActivated event.
OnHeaderFooterDeactivated | Raises the HeaderFooterDeactivated event.
OnHExpanded | Raises the HExpanded event.
OnHScroll | Raises the HScroll event.
OnHShrunk | Raises the HShrunk event.
OnHypertextLinkClicked | Raises the HypertextLinkClicked event.
OnHyphenateWord | Raises the HyphenateWord event.
OnImageClicked | Raises the ImageClicked event.
OnImageCreated | Raises the ImageCreated event.
OnImageDeleted | Raises the ImageDeleted event.
OnImageDeselected | Raises the ImageDeselected event.
OnImageDoubleClicked | Raises the ImageDoubleClicked event.
OnImageMoved | Raises the ImageMoved event.
OnImageRightClicked | Raises the ImageRightClicked event.
OnImageSelected | Raises the ImageSelected event.
OnImageSized | Raises the ImageSized event.
OnInputFormattingStyleChanged | Raises the InputFormattingStyleChanged event.
OnInputParagraphChanged | Raises the InputParagraphChanged event.
OnInputPositionChanged | Raises the InputPositionChanged event.
OnPageChanged | Raises the PageChanged event.
OnPageFormatChanged | Raises the PageFormatChanged event.
OnParagraphFormatChanged | Raises the ParagraphFormatChanged event.
OnSectionChanged | Raises the SectionChanged event.
OnSpellCheckText | Raises the SpellCheckText event.
OnSubTextPartClicked | Raises the SubTextPartClicked event.
OnSubTextPartDoubleClicked | Raises the SubTextPartDoubleClicked event.
OnSubTextPartEntered | Raises the SubTextPartEntered event.
OnSubTextPartLeft | Raises the SubTextPartLeft event.
OnTableCreated | Raises the TableCreated event.
OnTableDeleted | Raises the TableDeleted event.
OnTableFormatChanged | Raises the TableFormatChanged event.
OnTextContextMenuOpening | Raises the TextContextMenuOpening event.
OnTextFieldChanged | Raises the TextFieldChanged event.
OnTextFieldClicked | Raises the TextFieldClicked event.
OnTextFieldCreated | Raises the TextFieldCreated event.
OnTextFieldDeleted | Raises the TextFieldDeleted event.
OnTextFieldDoubleClicked | Raises the TextFieldDoubleClicked event.
OnTextFieldEntered | Raises the TextFieldEntered event.
OnTextFieldLeft | Raises the TextFieldLeft event.
OnTextFrameActivated | Raises the TextFrameActivated event.
OnTextFrameAppearanceChanged | Raises the TextFrameAppearanceChanged event.
OnTextFrameClicked | Raises the TextFrameClicked event.
OnTextFrameCreated | Raises the TextFrameCreated event.
OnTextFrameDeactivated | Raises the TextFrameDeactivated event.
OnTextFrameDeleted | Raises the TextFrameDeleted event.
OnTextFrameDeselected | Raises the TextFrameDeselected event.
OnTextFrameDoubleClicked | Raises the TextFrameDoubleClicked event.
OnTextFrameMoved | Raises the TextFrameMoved event.
OnTextFrameRightClicked | Raises the TextFrameRightClicked event.
OnTextFrameSelected | Raises the TextFrameSelected event.
OnTextFrameSized | Raises the TextFrameSized event.
OnVExpanded | Raises the VExpanded event.
OnVScroll | Raises the VScroll event.
OnVShrunk | Raises the VShrunk event.
OnXmlInvalid | Raises the XmlInvalid event.
OnXmlNotWellFormed | Raises the XmlNotWellFormed event.
PageColorDialog | Invokes the built-in dialog box for setting the page color.
ParagraphFormatDialog | Overloaded. Invokes the built-in dialog box for setting the formatting attributes of a paragraph.
Paste | Overloaded. Replaces the current selection in the Text Control with the contents of the Clipboard.
Print | Overloaded. Prints a Text Control document or a part of a document.
Redo | Redoes the last Text Control operation.
Replace | Opens the built-in Replace dialog box.
ResetContents | Deletes the entire contents of a Text Control.
Save | Overloaded. Saves the complete contents of a document with the specified format.
SectionFormatDialog | Invokes the built-in tabbed dialog box for setting section attributes.
Select | Selects text within the Text Control.
SelectAll | Selects all text in the Text Control.
SpellCheckDialog | Overloaded. Invokes the built-in dialog box for correcting misspelled words.
TabDialog | Invokes the built-in dialog box for setting tabs.
TableFormatDialog | Overloaded. Invokes the built-in dialog box for setting formatting attributes of tables.
TextBackColorDialog | Invokes the built-in dialog box for setting the background color of the text.
TextFrameAttributesDialog | Overloaded. Invokes the built-in dialog box for setting attributes of text frames.
Undo | Undoes the last edit operation in the Text Control.
Zoom | Overloaded. Zooms the contents of the TextControl.

Events

Event | Description
AdaptFont | Occurs for each font that must be adapted, because it is not supported.
BarcodeClicked | Occurs when a barcode has been clicked on.
BarcodeCreated | Occurs when a new barcode has been created.
BarcodeDeleted | Occurs when a barcode has been deleted.
BarcodeDeselected | Occurs when a barcode has been deselected.
BarcodeDoubleClicked | Occurs when a barcode has been doubleclicked on.
BarcodeMoved | Occurs when a barcode has been moved.
BarcodeRightClicked | Occurs when a barcode has been clicked on with the right mouse button.
BarcodeSelected | Occurs when a barcode has been selected.
BarcodeSized | Occurs when a barcode has been sized.
Changed | Indicates that the contents of a document have been changed.
CharFormatChanged | Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed.
DocumentLinkClicked | Occurs when a text field has been clicked on that represents a link to a target in the document.
DocumentLoaded | Occurs when a new document has been loaded.
DrawingActivated | Occurs when a drawing has been activated.
DrawingClicked | Occurs when a drawing has been clicked on.
DrawingCreated | Occurs when a new drawing has been created.
DrawingDeactivated | Occurs when a drawing has been deactivated.
DrawingDeleted | Occurs when a drawing has been deleted.
DrawingDeselected | Occurs when a drawing has been deselected.
DrawingDoubleClicked | Occurs when a drawing has been doubleclicked on.
DrawingMoved | Occurs when a drawing has been moved.
DrawingRightClicked | Occurs when a drawing has been clicked on with the right mouse button.
DrawingSelected | Occurs when a drawing has been selected.
DrawingSized | Occurs when a drawing has been sized.
FormattingStyleListChanged | Occurs after one or more formatting styles have been added or removed.
FrameClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on.
FrameDeselected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected.
FrameDoubleClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on.
FrameLayoutChanged | Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed.
FrameMoved | Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved.
FrameRightClicked | Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button.
FrameSelected | Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected.
FrameSized | Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized.
HeaderFooterActivated | Occurs when a header or footer has been activated.
HeaderFooterDeactivated | Occurs when a header or footer has been deactivated.
HExpanded | Occurs when the Text Control has automatically expanded its size horizontally.
HScroll | Occurs when the horizontal scroll position has been changed.
HShrunk | Occurs when the Text Control has automatically shrunk its size horizontally.
HypertextLinkClicked | Occurs when a text field has been clicked on that represents the source of a hypertext link.
HyphenateWord | Occurs, if a word does not fit in the line and must be hyphenated.
ImageClicked | Occurs when an image has been clicked on.
ImageCreated | Occurs when a new image has been created.
ImageDeleted | Occurs when an image has been deleted.
ImageDeselected | Occurs when an image has been deselected.
ImageDoubleClicked | Occurs when an image has been doubleclicked on.
ImageMoved | Occurs when an inserted image has been moved.
ImageRightClicked | Occurs when an image has been clicked on with the right mouse button.
ImageSelected | Occurs when an image has been selected.
ImageSized | Occurs when an inserted image has been sized.
InputFormattingStyleChanged | Occurs after the text input position has been moved to a text part formatted with another style.
InputParagraphChanged | Occurs when the text input position has been moved to another paragraph.
InputPositionChanged | Occurs when the text input position has been changed.
PageChanged | Occurs when the text input position has been moved to another page.
PageFormatChanged | Occurs when the page format settings have been changed.
ParagraphFormatChanged | Occurs when the formatting attributes of the selected paragraphs have been changed.
SectionChanged | Occurs when the text input position has been moved to another section.
SpellCheckText | Occurs, if the document's text has been altered and the spelling of the new text must be checked.
SubTextPartClicked | Occurs when a subtextpart has been clicked on.
SubTextPartDoubleClicked | Occurs when a subtextpart has been double-clicked on.
SubTextPartEntered | Occurs when the current input position has been moved to a position that belongs to a subtextpart.
SubTextPartLeft | Occurs when the current input position has left a subtextpart.
TableCreated | Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier.
TableDeleted | Occurs after a table has been deleted.
TableFormatChanged | Occurs when the design attributes of a selected table have been changed.
TextContextMenuOpening | Occurs immedialtely before a built-in context menu will be opened.
TextFieldChanged | Occurs when the text of a text field has been changed.
TextFieldClicked | Occurs when a text field has been clicked on.
TextFieldCreated | Occurs when a text field has been pasted from the clipboard.
TextFieldDeleted | Occurs when a text field has been deleted.
TextFieldDoubleClicked | Occurs when a text field has been double-clicked on.
TextFieldEntered | Occurs when the current input position has been moved to a position that belongs to a text field.
TextFieldLeft | Occurs when the current input position has left a text field.
TextFrameActivated | Occurs when a text frame has been activated.
TextFrameAppearanceChanged | Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed.
TextFrameClicked | Occurs when a text frame has been clicked on.
TextFrameCreated | Occurs when a new text frame has been created.
TextFrameDeactivated | Occurs when a text frame has been deactivated.
TextFrameDeleted | Occurs when a text frame has been deleted.
TextFrameDeselected | Occurs when a text frame has been deselected.
TextFrameDoubleClicked | Occurs when a text frame has been doubleclicked on.
TextFrameMoved | Occurs when a text frame has been moved.
TextFrameRightClicked | Occurs when a text frame has been clicked on with the right mouse button.
TextFrameSelected | Occurs when a text frame has been selected.
TextFrameSized | Occurs when a text frame has been sized.
VExpanded | Occurs when the Text Control has automatically expanded its size vertically.
VScroll | Occurs when the vertical scroll position has been changed.
VShrunk | Occurs when the Text Control has automatically shrunk its size vertically.
XmlInvalid | Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document.
XmlNotWellFormed | Occurs when a loaded XML document is not well-formed.


TXTextControl.WPF.TextControl Constructor

Initializes a new instance of the WPF.TextControl class.

Syntax

[C#]
public TextControl();
[Visual Basic]
Public Sub New()


TXTextControl.WPF.TextControl.AcceptsTab Property

Gets or sets a value indicating whether pressing the TAB key types a TAB character in the control instead of moving the focus to the next control in the tab order. This is a dependency property.

Syntax

[C#]
public bool AcceptsTab { get; set; }
[Visual Basic]
Public Property AcceptsTab() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.AdaptFont Event

Occurs for each font that must be adapted, because it is not supported. The event can occur, if another printer is set with the FormattingPrinter property, if a document is loaded that contains a font which is not supported, or if fonts have been restricted with the FontSettings.EmbeddableFontsOnly or the FontSettings.TrueTypeFontsOnly property. The event occurs only, if the FontSettings.AdaptFontEvent property has been set to true. The event handler receives an argument of type AdaptFontEventArgs containing data related to this event.

Syntax

[C#]
public event AdaptFontEventHandler AdaptFont;
[Visual Basic]
Public Event AdaptFont As AdaptFontEventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.AddSymbolDialog Method

Invokes a built-in dialog box for inserting symbol characters.

Introduced: 23.0.

Syntax

[C#]
public void AddSymbolDialog();
[Visual Basic]
Public Sub AddSymbolDialog()

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.AllowDrag Property

Gets or sets a value indicating whether the control can be a source of a Drag&Drop operation. To allow the control to accept data that the user drags onto it, the AllowDrop property must be set to true.

Syntax

[C#]
public bool AllowDrag { get; set; }
[Visual Basic]
Public Property AllowDrag() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.AllowDrop Property

Inherited from System.Windows.UIElement. Gets or sets a value indicating whether the control can accept data that the user drags onto it. This property allows the control to be a target for drop operations. To allow the control to be a source of a Drag&Drop operation the AllowDrag property must be set to true. The DropFormats property determines which formats the control accepts automatically.

Syntax

[C#]
public bool AllowDrop { get; set; }
[Visual Basic]
Public Property AllowDrop() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.Append Method

Loads text in a certain format from a file, a byte array or a string and appends it to the existing document.

Append(AppendSettings)

Opens a file open dialogbox and appends the selected file to the existing document.

[C#]
public DialogResult Append(AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(StreamType, AppendSettings)

Opens a file open dialogbox and appends the selected file with the specified format to the existing document.

[C#]
public DialogResult Append(StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal streamType As StreamType, ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StreamType, AppendSettings)

Loads text with the specified format from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, AppendSettings)

Loads text with the specified format from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, AppendSettings)

Loads text with the specified format from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal appendSettings As AppendSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StringStreamType, AppendSettings)

Loads text with the specified format from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(StreamType, LoadSettings, AppendSettings)

Opens a file open dialogbox and appends the selected file with the specified format and special settings to the existing document.

[C#]
public DialogResult Append(StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Function Append(ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(String, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file and appends it to the existing document.

[C#]
public void Append(string path, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(FileStream, StreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified file stream and appends it to the existing document.

[C#]
public void Append(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Append(Byte[], BinaryStreamType, LoadSettings)

Loads text with the specified format and special settings from the specified byte array and appends it to the existing document.

[C#]
public void Append(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Append(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Append(String, StringStreamType, LoadSettings, AppendSettings)

Loads text with the specified format and special settings from the specified string and appends it to the existing document.

[C#]
public void Append(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings, AppendSettings appendSettings);
[Visual Basic]
Public Sub Append(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings, ByVal appendSettings As AppendSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.
appendSettings | Specifies settings on how the document is appended. It can be one of the AppendSettings values.

Return Value

The implementations which open a dialog box return a WPF.DialogResult value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.ApplicationFields Property

Gets a collection of all application fields contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. Application fields are Microsoft Word or Heiler HighEdit fields that have been created or imported from a Microsoft Word or RTF document. The property value is an object of the type ApplicationFieldCollection. Before loading a document the LoadSettings.ApplicationFieldFormat property must be set, otherwise this collection is empty. The collection contains the fields of the text part with the input focus. This can be the main text, a text frame or a header or footer.

Syntax

[C#]
public ApplicationFieldCollection ApplicationFields { get; }
[Visual Basic]
Public ReadOnly Property ApplicationFields() As ApplicationFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.AutoControlSize Property

Gets or sets values that enable automatic expansion or shrinking of a Text Control's width or height depending on the currently contained text. These features are only possible, if the ViewMode property has been set to SimpleControl. The property value is an object of the type AutoSize.

Syntax

[C#]
public AutoSize AutoControlSize { get; set; }
[Visual Basic]
Public Property AutoControlSize() As AutoSize

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.BarcodeClicked Event

Occurs when a barcode has been clicked on. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeClicked;
[Visual Basic]
Public Event BarcodeClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeCreated Event

Occurs when a new barcode has been created. It occurs, when a barcode has been inserted in the document via the clipboard and when a file containing barcodes has been loaded. It does not occur, when a barcode has been added with the BarcodeCollection.Add method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeCreated;
[Visual Basic]
Public Event BarcodeCreated As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeDeleted Event

Occurs when a barcode has been deleted. It occurs, when a barcode has been deleted while editing a document and when a barcode has been deleted with the BarcodeCollection.Remove method. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeleted;
[Visual Basic]
Public Event BarcodeDeleted As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeDoubleClicked Event

Occurs when a barcode has been doubleclicked on. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDoubleClicked;
[Visual Basic]
Public Event BarcodeDoubleClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeMoved Event

Occurs when a barcode has been moved. It does not occur, if an inline or anchored barcode has been moved because text has been inserted. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeMoved;
[Visual Basic]
Public Event BarcodeMoved As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeRightClicked Event

Occurs when a barcode has been clicked on with the right mouse button. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeRightClicked;
[Visual Basic]
Public Event BarcodeRightClicked As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeSelected Event

Occurs when a barcode has been selected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeSelected;
[Visual Basic]
Public Event BarcodeSelected As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeDeselected Event

Occurs when a barcode has been deselected. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeDeselected;
[Visual Basic]
Public Event BarcodeDeselected As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeLayoutDialog Method

Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a barcode. This dialog can only be invoked, if a barcode has been selected.

Introduced: 19.0.

BarcodeLayoutDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult BarcodeLayoutDialog();
[Visual Basic]
Public Function BarcodeLayoutDialog() As DialogResult

BarcodeLayoutDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult BarcodeLayoutDialog(int activeTab);
[Visual Basic]
Public Function BarcodeLayoutDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further barcode attributes such as fore- and background color and the barcode's type and text.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Barcodes Property

Gets a collection of all barcodes contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DataVisualization.BarcodeCollection. The collection can be used to get or to alter a barcode's attributes and to add barcodes to or to remove barcodes from a document.

Introduced: 19.0.

Syntax

[C#]
public DataVisualization.BarcodeCollection Barcodes { get; }
[Visual Basic]
Public ReadOnly Property Barcodes() As DataVisualization.BarcodeCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.BarcodeSized Event

Occurs when a barcode has been sized. The event handler receives an argument of type BarcodeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event BarcodeEventHandler BarcodeSized;
[Visual Basic]
Public Event BarcodeSized As BarcodeEventHandler

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.Baseline Property

Gets or sets the baseline alignment, in twips, of the Text Control. Positive values moves the baseline to superscript, negative values moves the baseline to subscript.

Syntax

[C#]
public int Baseline { get; set; }
[Visual Basic]
Public Property Baseline() As Integer

Limitations

The property's value must be between -960 twips and 960 twips (48 pt).

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.BeginUndoAction Method

Begins a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step. The specified user-defined name is available with the UndoActionName property.

Introduced: 23.0.

Syntax

[C#]
public void BeginUndoAction(string actionName);
[Visual Basic]
Public Sub BeginUndoAction(ByVal actionName As String)
Parameter | Description
actionName | Specifies the undo action's name. If an action name is not necessary, this parameter can be null or an empty string.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.BorderThickness Property

Gets or sets the border thickness of the Text Control. Four double values, in device-independent units (1/96th inch), describe the left, top, right, and bottom sides of the border, respectively. If only a single measure is specified, that measure is applied to all of the left, top, right, bottom values of a Thickness. If only a pair of left,top measures are specified, these measures are applied symmetrically to a Thickness: the left value is used for right; the top value is used for bottom. This is a dependency property.

Syntax

[C#]
public System.Windows.Thickness BorderThickness { get; set; }
[Visual Basic]
Public Property BorderThickness() As System.Windows.Thickness

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.ButtonBar Property

Specifies the button bar control to be used with a TextControl. The property value is null if there is no button bar connected. Otherwise it must be the name of an existing WPF.ButtonBar object.

Syntax

[C#]
public string ButtonBar { get; set; }
[Visual Basic]
Public Property ButtonBar() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.CanCopy Property

Informs whether a part of a Text Control document has been selected and can be copied to the clipboard.

Syntax

[C#]
public bool CanCopy { get; }
[Visual Basic]
Public ReadOnly Property CanCopy() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.CanPaste Property

Informs whether the clipboard contains a format that can be pasted into a Text Control document.

Syntax

[C#]
public bool CanPaste { get; }
[Visual Basic]
Public ReadOnly Property CanPaste() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.CanRedo Property

Informs whether an operation can be re-done using the Redo method.

Syntax

[C#]
public bool CanRedo { get; }
[Visual Basic]
Public ReadOnly Property CanRedo() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.CanUndo Property

Gets a value indicating whether the user can undo the previous operation in a Text Control.

Syntax

[C#]
public bool CanUndo { get; }
[Visual Basic]
Public ReadOnly Property CanUndo() As Boolean

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.CaretWidth Property

Gets or sets the width of the caret in pixels. If this property is zero, the width is set to its default value which is the system-defined window border width.

Syntax

[C#]
public int CaretWidth { get; set; }
[Visual Basic]
Public Property CaretWidth() As Integer

Limitations

The maximum width is 255 pixels.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.Changed Event

Indicates that the contents of a document have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Changed;
[Visual Basic]
Public Event Changed As EventHandler

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.CharFormatChanged Event

Occurs when the character formatting attributes either of the selected characters or the current text input position have been changed. Formatting attributes that can be asigned to single characters are the font, the font attributes, text colors and the baseline. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler CharFormatChanged;
[Visual Basic]
Public Event CharFormatChanged As EventHandler

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.Clear Method

Clears the selected text or the character right from the current input position from the Text Control.

Syntax

[C#]
public void Clear();
[Visual Basic]
Public Sub Clear()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.ClearUndo Method

Clears the undo buffer of the Text Control.

Syntax

[C#]
public void ClearUndo();
[Visual Basic]
Public Sub ClearUndo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.ControlChars Property

Specifies if control characters are visible or not. This is a dependency property.

Syntax

[C#]
public bool ControlChars { get; set; }
[Visual Basic]
Public Property ControlChars() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.Copy Method

Copies the current selection in the Text Control to the Clipboard.

Syntax

[C#]
public void Copy();
[Visual Basic]
Public Sub Copy()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.Cut Method

Moves the current selection in the Text Control to the Clipboard.

Syntax

[C#]
public void Cut();
[Visual Basic]
Public Sub Cut()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.DisplayColors Property

Gets or sets the colors of the text control. The property value is an object of the type WPF.TextControlColors.

Syntax

[C#]
public TextControlColors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As TextControlColors

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.DocumentLinkClicked Event

Occurs when a text field has been clicked on that represents a link to a target in the document. The event handler receives an argument of type DocumentLinkEventArgs containing data related to this event.

Syntax

[C#]
public event DocumentLinkEventHandler DocumentLinkClicked;
[Visual Basic]
Public Event DocumentLinkClicked As DocumentLinkEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.DocumentLinks Property

Gets a collection of all document links contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. Document links point to targets in the same document. The property value is an object of the type DocumentLinkCollection.

Syntax

[C#]
public DocumentLinkCollection DocumentLinks { get; }
[Visual Basic]
Public ReadOnly Property DocumentLinks() As DocumentLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.DocumentLoaded Event

Occurs when a new document has been loaded. The event handler receives an argument of type EventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event EventHandler DocumentLoaded;
[Visual Basic]
Public Event DocumentLoaded As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.DocumentTargetMarkers Property

Gets or sets a value indicating that markers for hypertext targets are shown or not. This is a dependency property.

Syntax

[C#]
public bool DocumentTargetMarkers { get; set; }
[Visual Basic]
Public Property DocumentTargetMarkers() As Boolean

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.DocumentTargets Property

Gets a collection of all targets contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DocumentTargetCollection.

Syntax

[C#]
public DocumentTargetCollection DocumentTargets { get; }
[Visual Basic]
Public ReadOnly Property DocumentTargets() As DocumentTargetCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.DrawingActivated Event

Occurs when a drawing has been activated. The event handler receives an argument of type DrawingEventArgs containing data related to this event. A drawing is activated, when the user clicks the drawing with the mouse. The user can alter the drawing's contents, when it is activated. When the user clicks on the drawing's border, it is selected. A selected drawing can be sized, moved or copied to the clipboard.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingActivated;
[Visual Basic]
Public Event DrawingActivated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingClicked Event

Occurs when a drawing has been clicked on. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingClicked;
[Visual Basic]
Public Event DrawingClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingCreated Event

Occurs when a new drawing has been created. It occurs, when a drawing has been inserted in the document via the clipboard and when a file containing drawings has been loaded. It does not occur, when a drawing has been added with the DrawingCollection.Add method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingCreated;
[Visual Basic]
Public Event DrawingCreated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingDeleted Event

Occurs when a drawing has been deleted. It occurs, when a drawing has been deleted while editing a document and when a drawing has been deleted with the DrawingCollection.Remove method. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeleted;
[Visual Basic]
Public Event DrawingDeleted As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingDeactivated Event

Occurs when a drawing has been deactivated. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeactivated;
[Visual Basic]
Public Event DrawingDeactivated As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingDeselected Event

Occurs when a drawing has been deselected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDeselected;
[Visual Basic]
Public Event DrawingDeselected As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingDoubleClicked Event

Occurs when a drawing has been doubleclicked on. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingDoubleClicked;
[Visual Basic]
Public Event DrawingDoubleClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingLayoutDialog Method

Invokes the built-in dialog box for alter the layout settings, the size and the text distances of a drawing. This dialog can only be invoked, if a drawing has been selected.

Introduced: 23.0.

DrawingLayoutDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult DrawingLayoutDialog();
[Visual Basic]
Public Function DrawingLayoutDialog() As DialogResult

DrawingLayoutDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult DrawingLayoutDialog(int activeTab);
[Visual Basic]
Public Function DrawingLayoutDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further drawing attributes such as line- and background color, rotation and transparency.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.DrawingMarkerLines Property

Specifies whether a marker frame is shown around a drawing to indicate its position and size. This is a dependency property.

Introduced: 23.0.

Syntax

[C#]
public bool DrawingMarkerLines { get; set; }
[Visual Basic]
Public Property DrawingMarkerLines() As Boolean

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingMoved Event

Occurs when a drawing has been moved. It does not occur, if an inline or anchored drawing has been moved because text has been inserted. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingMoved;
[Visual Basic]
Public Event DrawingMoved As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingRightClicked Event

Occurs when a drawing has been clicked on with the right mouse button. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingRightClicked;
[Visual Basic]
Public Event DrawingRightClicked As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.Drawings Property

Gets a collection of all drawings contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type DataVisualization.DrawingCollection. The collection can be used to get or to alter a drawing's attributes and to add drawings to or to remove drawings from a document.

Introduced: 23.0.

Syntax

[C#]
public DataVisualization.DrawingCollection Drawings { get; }
[Visual Basic]
Public ReadOnly Property Drawings() As DataVisualization.DrawingCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingSelected Event

Occurs when a drawing has been selected. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingSelected;
[Visual Basic]
Public Event DrawingSelected As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DrawingSized Event

Occurs when a drawing has been sized. The event handler receives an argument of type DrawingEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event DrawingEventHandler DrawingSized;
[Visual Basic]
Public Event DrawingSized As DrawingEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.DropFormats Property

Gets or sets the formats of data the control can accept when the user drags it onto the control. The property's value can be a bitwise OR combination of the values listed below. The bitwise AND operator can be used to test for a given format.

Syntax

[C#]
public DropFormat DropFormats { get; set; }
[Visual Basic]
Public Property DropFormats() As DropFormat
Value | Description
HTMLFormat | The control accepts HTML Format.
Image | The control accepts images (Device dependent or device independent bitmaps, TIFF images or Windows metafiles).
PlainText | The control accepts plain text.
RichTextFormat | The control accepts Rich Text Format.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.EditMode Property

Gets or sets a value indicating whether text in the Text Control is read-only, can be selected or is editable.

Syntax

[C#]
public EditMode EditMode { get; set; }
[Visual Basic]
Public Property EditMode() As EditMode
Value | Description
Edit | The text of the Text Control can be edited.
ReadAndSelect | The text of the Text Control is read only but can be selected.
ReadOnly | The text of the Text Control is read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.EndUndoAction Method

Ends a user-defined undo operation. All editing and fomatting changes made between BeginUndoAction and EndUndoAction belong to the undo operation. These changes are undone or redone in a single step.

Introduced: 23.0.

Syntax

[C#]
public void EndUndoAction();
[Visual Basic]
Public Sub EndUndoAction()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.FieldCursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over a marked text field.

Syntax

[C#]
public Cursor FieldCursor { get; set; }
[Visual Basic]
Public Property FieldCursor() As Cursor

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.Find Method

Finds a text string in the text part with the input focus. This can be the main text, a text frame or a header or footer.

Find()

Opens the built-in Find dialog box to search for a text string in the text part with the input focus. This can be the main text, a text frame or a header or footer.

[C#]
public void Find();
[Visual Basic]
Public Sub Find()

Find(String)

Searches for the specified text string in the text part with the input focus. This can be the main text, a text frame or a header or footer. The search starts at the beginning of the text.

[C#]
public int Find(string text);
[Visual Basic]
Public Function Find(ByVal text As String) As Integer
Parameter | Description
text | Specifies the text to search for.

Find(String, Int32, FindOptions)

Searches for the specified text string in the text part with the input focus. This can be the main text, a text frame or a header or footer. The search is done with the specified find options and starts at the specified position.

[C#]
public int Find(string text, int start, FindOptions options);
[Visual Basic]
Public Function Find(ByVal text As String, ByVal start As Integer, ByVal options As FindOptions) As Integer
Parameter | Description
text | Specifies the text to search for.
start | Specifies the text position where the search starts, beginning with 0. If this value is -1, the search begins at the current text input position.
options | Specifies search options. It can be a combination of the FindOptions values.

Return Value

If the text searched for is found, the method returns the index (zero-based) of the first character of the search string. If the specified text is not found the method returns -1.

See Also

  • Programming Category: Search and Replace
  • Graphical Overview: Search and Replace
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.FontDialog Method

Invokes the built-in font dialog box.

Syntax

[C#]
public DialogResult FontDialog();
[Visual Basic]
Public Function FontDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.FontFamily Property

Gets or sets the font family of the text control. This is a dependency property. The property value has the type System.Windows.Media.FontFamily.

Syntax

[C#]
public FontFamily FontFamily { get; set; }
[Visual Basic]
Public Property FontFamily() As FontFamily

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.FontSettings Property

Gets a FontSettings object which provides properties determining which fonts can be used in a document.

Syntax

[C#]
public FontSettings FontSettings { get; }
[Visual Basic]
Public ReadOnly Property FontSettings() As FontSettings

Limitations

Read only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.FontSize Property

Gets or sets the font size of the text control in device-independent units (1/96th inch). This is a dependency property.

Syntax

[C#]
public double FontSize { get; set; }
[Visual Basic]
Public Property FontSize() As Double

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.FontStyle Property

Gets or sets the font style of the text control. This is a dependency property. The property value has the type System.Windows.FontStyle. The default value is FontStyles.Normal.

Syntax

[C#]
public FontStyle FontStyle { get; set; }
[Visual Basic]
Public Property FontStyle() As FontStyle

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.FontUnderlineStyle Property

Gets or sets the underlining style for the text displayed by the control.

Syntax

[C#]
public FontUnderlineStyle FontUnderlineStyle { get; set; }
[Visual Basic]
Public Property FontUnderlineStyle() As FontUnderlineStyle
Value | Description
None | Text is not underlined.
Single | Text is underlined with a single line.
Doubled | Text is underlined with a doubled line.
SingleWordsOnly | Only the words of the text are underlined with a single line.
DoubledWordsOnly | Only the words of the text are underlined with a doubled line.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.FontWeight Property

Gets or sets the weight or thickness of the text control's font. This is a dependency property. The property value has the type System.Windows.FontWeight. The default value is FontWeights.Normal.

Syntax

[C#]
public FontWeight FontWeight { get; set; }
[Visual Basic]
Public Property FontWeight() As FontWeight

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.ForeColorDialog Method

Invokes the built-in dialog box for setting the text color.

Introduced: 22.0.

Syntax

[C#]
public DialogResult ForeColorDialog();
[Visual Basic]
Public Function ForeColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.FormattingPrinter Property

Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document. If the document is printed with this printer the displayed and the printed document have the same dimensions. If the property is set to Standard, the system installed standard printer is used to format the document. If the property is set to Display, the font dimensions of the display device are used to format the document. If the specified printer is not installed, the standard printer is used.

Syntax

[C#]
public string FormattingPrinter { get; set; }
[Visual Basic]
Public Property FormattingPrinter() As String

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.FormattingStylesDialog Method

Invokes the built-in dialog box for creating, deleting and modifying formatting styles.

Syntax

[C#]
public DialogResult FormattingStylesDialog();
[Visual Basic]
Public Function FormattingStylesDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.FormattingStyleListChanged Event

Occurs after one or more formatting styles have been added or removed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler FormattingStyleListChanged;
[Visual Basic]
Public Event FormattingStyleListChanged As EventHandler

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.WPF.TextControl.FrameClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameClicked;
[Visual Basic]
Public Event FrameClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameDeselected Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been deselected. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameDeselected;
[Visual Basic]
Public Event FrameDeselected As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameDoubleClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been doubleclicked on. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameDoubleClicked;
[Visual Basic]
Public Event FrameDoubleClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameLayoutChanged Event

Occurs when the layout of a frame (image, text frame, chart, barcode or drawing) has been changed. Layout attributes are insertion mode, textflow and z-order. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameLayoutChanged;
[Visual Basic]
Public Event FrameLayoutChanged As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameMoved Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been moved. It does not occur, if an inline or anchored frame has been moved because text has been inserted. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameMoved;
[Visual Basic]
Public Event FrameMoved As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameRightClicked Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been clicked on with the right mouse button. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameRightClicked;
[Visual Basic]
Public Event FrameRightClicked As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameSelected Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been selected. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameSelected;
[Visual Basic]
Public Event FrameSelected As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameSized Event

Occurs when a frame (image, text frame, chart, barcode or drawing) has been sized. The event handler receives an argument of type FrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event FrameEventHandler FrameSized;
[Visual Basic]
Public Event FrameSized As FrameEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.FrameFillColorDialog Method

Invokes the built-in dialog box for choosing a color for the background of a paragraph or a table cell.

Introduced: 24.0.

Syntax

[C#]
public DialogResult FrameFillColorDialog();
[Visual Basic]
Public Function FrameFillColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.FrameLineColorDialog Method

Invokes the built-in dialog box for choosing a color for the frame of a paragraph or a table.

Introduced: 24.0.

Syntax

[C#]
public DialogResult FrameLineColorDialog();
[Visual Basic]
Public Function FrameLineColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Frames Property

Gets a collection of all images, textframes, barcodes and drawings contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type FrameCollection. The collection can be used to get or to alter attributes common to all frames.

Introduced: 18.0.

Syntax

[C#]
public FrameCollection Frames { get; }
[Visual Basic]
Public ReadOnly Property Frames() As FrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.GetClipboardFormats Method

Returns an array of ClipboardFormat values. These values specify all the data formats which are currently available in the clipboard and which can be pasted into a document. If there is no data format available, this method returns null.

Syntax

[C#]
public ClipboardFormat[] GetClipboardFormats();
[Visual Basic]
Public Sub GetClipboardFormats() As ClipboardFormat()

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.GetPages Method

Gets a collection of all pages in the document. The property's value is an object of the type PageCollection. This collection is only available, if the property has been set to ViewMode.PageView. Otherwise, the method returns null.

Syntax

[C#]
public PageCollection GetPages();
[Visual Basic]
Public Function GetPages() As PageCollection

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.GetSupportedFonts Method

Gets an array of strings specifying the names of all currently supported fonts. These fonts depend on the formatting device set with the WPF.TextControl.FormattingPrinter property. The method returns null if the WPF.TextControl has not been completely initialized.

Introduced: 24.0.

Syntax

[C#]
public string[] GetSupportedFonts();
[Visual Basic]
Public Sub GetSupportedFonts() As String()

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.GetSupportedPaperSizes Method

Gets an array of PaperSize structures specifying the names and the size of all currently supported paper sizes. These paper sizes depend on the formatting device set with the WPF.TextControl.FormattingPrinter property.

Introduced: 24.0.

Syntax

[C#]
public PaperSize[] GetSupportedPaperSizes();
[Visual Basic]
Public Function GetSupportedPaperSizes() As PaperSize()

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.GetTextFields Method

Returns a collection containing text fields of the specified types.

Introduced: 24.0.

Syntax

[C#]
public TextFieldCollection GetTextFields(TextFieldType fieldType);
[Visual Basic]
Public Function GetTextFields(ByVal fieldType As TextFieldType) As TextFieldCollection
Parameter | Description
fieldType | Specifies types of text fields. It can be a combination of the TextFieldType values.

Return Value

The return value is a collection of all fields of the specified types.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.GetXmlElements Method

Returns a collection of XML elements. It is an object of the type XmlElementCollection.

Syntax

[C#]
public XmlElementCollection GetXmlElements(string elementName);
[Visual Basic]
Public Function GetXmlElements(ByVal elementName As String) As XmlElementCollection
Parameter | Description
elementName | Specifies the XML element's name.

Return Value

The return value is a collection containing all XML elements of the specified name.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.GetVersionInfo Method

Returns an object of the type VersionInfo, which provides information about the installed TX Text Control version.

Introduced: 21.0.

Syntax

[C#]
public VersionInfo GetVersionInfo();
[Visual Basic]
Public Sub GetVersionInfo() As VersionInfo

Return Value

The return value is a VersionInfo object.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.HeaderFooterActivated Event

Occurs when a header or footer has been activated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterActivated;
[Visual Basic]
Public Event HeaderFooterActivated As HeaderFooterEventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.HeaderFooterActivationStyle Property

Gets or sets a value specifying the activation style for headers and footers.

Syntax

[C#]
public HeaderFooterActivationStyle HeaderFooterActivationStyle { get; set; }
[Visual Basic]
Public Property HeaderFooterActivationStyle() As HeaderFooterActivationStyle
Value | Description
ActivateClick | Headers and footers are activated with a single mouse click.
ActivateDoubleClick | Headers and footers are activated with a double mouse click.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.HeaderFooterDeactivated Event

Occurs when a header or footer has been deactivated. The event handler receives an argument of type HeaderFooterEventArgs containing data related to this event.

Syntax

[C#]
public event HeaderFooterEventHandler HeaderFooterDeactivated;
[Visual Basic]
Public Event HeaderFooterDeactivated As HeaderFooterEventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.HeaderFooterFrameStyle Property

Gets or sets a value specifying the frame for activated headers and footers.

Syntax

[C#]
public HeaderFooterFrameStyle HeaderFooterFrameStyle { get; set; }
[Visual Basic]
Public Property HeaderFooterFrameStyle() As HeaderFooterFrameStyle
Value | Description
DividingLine | Draws a dividing line between an activated header or footer and the main text.
DottedFrame | Activated headers and footers have a dotted frame.
NoFrame | Activated headers and footers have no frame.
SingleFrame | Activated headers and footers have single frame.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.HeadersAndFooters Property

Gets a collection of all headers and footers the current document contains. The property's value is an object of the type HeaderFooterCollection.

Syntax

[C#]
public HeaderFooterCollection HeadersAndFooters { get; }
[Visual Basic]
Public ReadOnly Property HeadersAndFooters() As HeaderFooterCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.HExpanded Event

Occurs when the Text Control has automatically expanded its size horizontally. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler HExpanded;
[Visual Basic]
Public Event HExpanded As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.HideSelection Property

Gets or sets a value indicating whether the selected text in the Text Control remains highlighted when the control loses focus.

Syntax

[C#]
public bool HideSelection { get; set; }
[Visual Basic]
Public Property HideSelection() As Boolean

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.HorizontalScrollBarVisibility Property

Gets or sets a value that indicates whether a horizontal scroll bar is shown. The property's value is of the type System.Windows.Controls.ScrollBarVisibility. This is a dependency property.

Syntax

[C#]
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
[Visual Basic]
Public Property HorizontalScrollBarVisibility() As ScrollBarVisibility
Value | Description
Auto | A horizontal scroll bar is shown when the document is not completely visible in the horizontal direction.
Disabled | A horizontal scroll bar is not shown even if the document is not completely visible.
Hidden | Same as Disabled.
Visible | Same as Auto.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.HScroll Event

Occurs when the horizontal scroll position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler HScroll;
[Visual Basic]
Public Event HScroll As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.HShrunk Event

Occurs when the Text Control has automatically shrunk its size horizontally. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler HShrunk;
[Visual Basic]
Public Event HShrunk As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.HypertextLinkClicked Event

Occurs when a text field has been clicked on that represents the source of a hypertext link. The event handler receives an argument of type HypertextLinkEventArgs containing data related to this event.

Syntax

[C#]
public event HypertextLinkEventHandler HypertextLinkClicked;
[Visual Basic]
Public Event HypertextLinkClicked As HypertextLinkEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.HypertextLinks Property

Gets a collection of all hypertext links contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type HypertextLinkCollection.

Syntax

[C#]
public HypertextLinkCollection HypertextLinks { get; }
[Visual Basic]
Public ReadOnly Property HypertextLinks() As HypertextLinkCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.HyphenateWord Event

Occurs, if a word does not fit in the line and must be hyphenated. This event occurs only, if the IsHyphenationEnabled property has been set to true. The event handler receives an argument of type HyphenateWordEventArgs containing data related to this event.

Introduced: 20.0.

Syntax

[C#]
public event HyphenateWordEventHandler HyphenateWord;
[Visual Basic]
Public Event HyphenateWord As HyphenateWordEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.ImageAttributesDialog Method

Invokes the built-in dialog box for setting attributes of images. This dialog box is only shown, if an image is currently selected. The ImageCollection.GetItem method can be used to test whether an image is selected or not.

ImageAttributesDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult ImageAttributesDialog();
[Visual Basic]
Public Function ImageAttributesDialog() As DialogResult

ImageAttributesDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult ImageAttributesDialog(int activeTab);
[Visual Basic]
Public Function ImageAttributesDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting an image's saving attributes.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.ImageClicked Event

Occurs when an image has been clicked on. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageClicked;
[Visual Basic]
Public Event ImageClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageCreated Event

Occurs when a new image has been created. It occurs if an image has been inserted in the document with the clipboard or if a file containing images has been loaded. It does not occur if an image has been added with the ImageCollection.Add method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageCreated;
[Visual Basic]
Public Event ImageCreated As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageDeleted Event

Occurs when an image has been deleted. It occurs if an image has been deleted while editing a document or if an image has been deleted with the ImageCollection.Remove method. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDeleted;
[Visual Basic]
Public Event ImageDeleted As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageDeselected Event

Occurs when an image has been deselected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ImageEventHandler ImageDeselected;
[Visual Basic]
Public Event ImageDeselected As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageDoubleClicked Event

Occurs when an image has been doubleclicked on. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageDoubleClicked;
[Visual Basic]
Public Event ImageDoubleClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageMoved Event

Occurs when an inserted image has been moved. It does not occur, if an inline or anchored image has been moved because text has been inserted. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageMoved;
[Visual Basic]
Public Event ImageMoved As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageRightClicked Event

Occurs when an image has been clicked on with the right mouse button. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageRightClicked;
[Visual Basic]
Public Event ImageRightClicked As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.Images Property

Gets a collection of all images contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type ImageCollection.

Syntax

[C#]
public ImageCollection Images { get; }
[Visual Basic]
Public ReadOnly Property Images() As ImageCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageSelected Event

Occurs when an image has been selected. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event ImageEventHandler ImageSelected;
[Visual Basic]
Public Event ImageSelected As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.ImageSized Event

Occurs when an inserted image has been sized. The event handler receives an argument of type ImageEventArgs containing data related to this event.

Syntax

[C#]
public event ImageEventHandler ImageSized;
[Visual Basic]
Public Event ImageSized As ImageEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.InlineStyles Property

Gets a collection of all inline styles the current document contains. The property's value is an object of the type InlineStyleCollection.

Syntax

[C#]
public InlineStyleCollection InlineStyles { get; }
[Visual Basic]
Public ReadOnly Property InlineStyles() As InlineStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.WPF.TextControl.InputFormat Property

Gets an object of the type InputFormat which represents all formatting attributes at the current text input position.

Syntax

[C#]
public InputFormat InputFormat { get; }
[Visual Basic]
Public ReadOnly Property InputFormat() As InputFormat

Limitations

Runtime only.

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.InputFormattingStyleChanged Event

Occurs after the text input position has been moved to a text part formatted with another style. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputFormattingStyleChanged;
[Visual Basic]
Public Event InputFormattingStyleChanged As EventHandler

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.WPF.TextControl.InputParagraphChanged Event

Occurs when the text input position has been moved to another paragraph. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputParagraphChanged;
[Visual Basic]
Public Event InputParagraphChanged As EventHandler

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.InputPosition Property

Gets or sets the current text input position. The property's value is an object of the type InputPosition.

Syntax

[C#]
public InputPosition InputPosition { get; set; }
[Visual Basic]
Public Property InputPosition() As InputPosition

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.InputPositionChanged Event

Occurs when the text input position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler InputPositionChanged;
[Visual Basic]
Public Event InputPositionChanged As EventHandler

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.InsertionMode Property

Specifies whether text is inserted or overwrites existing text.

Syntax

[C#]
public InsertionMode InsertionMode { get; set; }
[Visual Basic]
Public Property InsertionMode() As InsertionMode
Value | Description
Insert | Text is inserted at the current text input position.
Overwrite | Text is overwritten at the current text input position.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.IsHyphenationEnabled Property

Gets or sets a value indicating whether hyphenation is active or not. If hyphenation is enabled, a word at the end of a line is automatically divided with a connected spell checking component. A spell checking component can be connected with the SpellChecker property. Additionally, the WPF.TextControl.HyphenateWord event is raised with the calculated divide position. This position can be changed through a connected event handler.

Introduced: 20.0.

Syntax

[C#]
public bool IsHyphenationEnabled { get; set; }
[Visual Basic]
Public Property IsHyphenationEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.IsLanguageDetectionEnabled Property

Gets or sets a value indicating whether language detection is active or not. If language detection is enabled, a language is automatically set for all pieces of text with a neutral language. To use this feature, at least the TXSpell 5.0 spell checking component must be connected with the WPF.TextControl through the SpellChecker property.

Introduced: 21.0.

Syntax

[C#]
public bool IsLanguageDetectionEnabled { get; set; }
[Visual Basic]
Public Property IsLanguageDetectionEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.IsSpellCheckingEnabled Property

Gets or sets a value indicating whether spell checking is active or not. If spell checking is enabled the WPF.TextControl.SpellCheckText event is raised when the text of a document changes. The event handler can be used to check the text on misspelled words.

Syntax

[C#]
public bool IsSpellCheckingEnabled { get; set; }
[Visual Basic]
Public Property IsSpellCheckingEnabled() As Boolean

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.IsTabStop Property

Gets or sets a value that indicates whether a text control is included in tab navigation. This is a dependency property.

Syntax

[C#]
public bool IsTabStop { get; set; }
[Visual Basic]
Public Property IsTabStop() As Boolean

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.IsUndoEnabled Property

Gets or sets a value indicating whether the undo buffer is active or not. If a Text Control is used for tasks like generating reports it can be useful to deactivate the undo buffer to save time and memory. This is a dependency property.

Syntax

[C#]
public bool IsUndoEnabled { get; set; }
[Visual Basic]
Public Property IsUndoEnabled() As Boolean

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.Landscape Property

Gets or sets a value indicating whether the page orientation is landscape or portrait.

Syntax

[C#]
public bool Landscape { get; set; }
[Visual Basic]
Public Property Landscape() As Boolean

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.LanguageDialog Method

Invokes the built-in dialog box for setting the language of the selected text.

Introduced: 20.0.

Syntax

[C#]
public DialogResult LanguageDialog();
[Visual Basic]
Public Function LanguageDialog() As DialogResult

Return Value

The return value can be one of the following values:

Result | Meaning
DialogResult.OK | The dialog has been left with the OK button and the selected language could be set.
DialogResult.Cancel | The dialog has been left with the Cancel button.
DialogResult.None | The selected language could not be set.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Lines Property

Gets a collection of all lines contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type LineCollection.

Syntax

[C#]
public LineCollection Lines { get; }
[Visual Basic]
Public ReadOnly Property Lines() As LineCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.WPF.TextControl.ListFormat Property

Gets or sets the type and the formatting attributes of a bulleted or numbered list. The property value is an object of the type ListFormat. For more information see the description of the ListFormat class.

Syntax

[C#]
public ListFormat ListFormat { get; set; }
[Visual Basic]
Public Property ListFormat() As ListFormat

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists


TXTextControl.WPF.TextControl.ListFormatDialog Method

Invokes the built-in dialog box for setting formatting attributes of bulleted and numbered lists.

Syntax

[C#]
public DialogResult ListFormatDialog();
[Visual Basic]
Public Function ListFormatDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Bullets and Numbered Lists
  • Graphical Overview: Bullets and Numbered Lists
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Load Method

Loads text in a certain format. The complete contents of a Text Control are replaced.

Load()

Opens a dialog box to select a file and loads the text from that file.

[C#]
public DialogResult Load();
[Visual Basic]
Public Function Load() As DialogResult

Load(StreamType)

Opens a dialog box to select a file in the specified format and loads the text from that file.

[C#]
public DialogResult Load(StreamType streamType);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Load(String, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file.

[C#]
public void Load(string path, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

Load(FileStream, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file stream.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

Load(Byte[], BinaryStreamType)

Loads text formatted with the specified format. The new text is read from the specified byte array.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

Load(String, StringStreamType)

Loads text formatted with the specified format. The new text is read from the specified string.

[C#]
public void Load(string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

Load(StreamType, LoadSettings)

Opens a dialog box to select a file in the specified format and loads the text from that file using the specified special settings.

[C#]
public DialogResult Load(StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Function Load(ByVal streamType As StreamType, ByVal loadSettings As LoadSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file and loaded using the given special settings.

[C#]
public void Load(string path, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(FileStream, StreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified file stream and loaded using the given special settings.

[C#]
public void Load(System.IO.FileStream fileStream, StreamType streamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal loadSettings As LoadSettings)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(Byte[], BinaryStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified byte array and loaded using the given special settings.

[C#]
public void Load(byte[] binaryData, BinaryStreamType binaryStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal loadSettings As LoadSettings)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Load(String, StringStreamType, LoadSettings)

Loads text formatted with the specified format. The new text is read from the specified string and loaded using the given special settings.

[C#]
public void Load(string stringData, StringStreamType stringStreamType, LoadSettings loadSettings);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As StringStreamType, ByVal loadSettings As LoadSettings)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.
loadSettings | Specifies a LoadSettings object with additional information and settings for the load operation.

Return Value

The implementations which open a dialog box return a WPF.DialogResult value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.MisspelledWords Property

Gets a collection of all misspelled words contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type MisspelledWordCollection.

Syntax

[C#]
public MisspelledWordCollection MisspelledWords { get; }
[Visual Basic]
Public ReadOnly Property MisspelledWords() As MisspelledWordCollection

Limitations

Read only.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.OnAdaptFont Method

Raises the AdaptFont event.

Syntax

[C#]
protected virtual void OnAdaptFont(AdaptFontEventArgs e);
[Visual Basic]
Protected Overridable Sub OnAdaptFont(ByVal e As AdaptFontEventArgs)
Parameter | Description
e | Specifies an AdaptFontEventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnBarcodeClicked Method

Raises the BarcodeClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeCreated Method

Raises the BarcodeCreated event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeCreated(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeCreated(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeDeleted Method

Raises the BarcodeDeleted event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDeleted(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeleted(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeDeselected Method

Raises the BarcodeDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDeselected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDeselected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeDoubleClicked Method

Raises the BarcodeDoubleClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeDoubleClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeDoubleClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeMoved Method

Raises the BarcodeMoved event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeMoved(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeMoved(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeRightClicked Method

Raises the BarcodeRightClicked event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeRightClicked(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeRightClicked(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeSelected Method

Raises the BarcodeSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeSelected(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeSelected(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnBarcodeSized Method

Raises the BarcodeSized event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnBarcodeSized(DataVisualization.BarcodeEventArgs e);
[Visual Basic]
Protected Overridable Sub OnBarcodeSized(ByVal e As DataVisualization.BarcodeEventArgs)
Parameter | Description
e | Specifies an BarcodeEventArgs object that contains the event data.

See Also

  • Programming Category: Barcodes
  • Graphical Overview: Barcodes


TXTextControl.WPF.TextControl.OnChanged Method

Raises the Changed event.

Syntax

[C#]
protected virtual void OnChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.OnCharFormatChanged Method

Raises the CharFormatChanged event.

Syntax

[C#]
protected virtual void OnCharFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnCharFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting


TXTextControl.WPF.TextControl.OnDocumentLinkClicked Method

Raises the DocumentLinkClicked event.

Syntax

[C#]
protected virtual void OnDocumentLinkClicked(DocumentLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLinkClicked(ByVal e As DocumentLinkEventArgs)
Parameter | Description
e | Specifies an DocumentLinkEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.OnDocumentLoaded Method

Raises the DocumentLoaded event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnDocumentLoaded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnDocumentLoaded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.OnDrawingActivated Method

Raises the DrawingActivated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingActivated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingActivated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingClicked Method

Raises the DrawingClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingCreated Method

Raises the DrawingCreated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingCreated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingCreated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingDeactivated Method

Raises the DrawingDeactivated event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeactivated(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeactivated(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingDeleted Method

Raises the DrawingDeleted event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeleted(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeleted(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingDeselected Method

Raises the DrawingDeselected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDeselected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDeselected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingDoubleClicked Method

Raises the DrawingDoubleClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingDoubleClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingDoubleClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingMoved Method

Raises the DrawingMoved event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingMoved(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingMoved(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingRightClicked Method

Raises the DrawingRightClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingRightClicked(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingRightClicked(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingSelected Method

Raises the DrawingSelected event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingSelected(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingSelected(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnDrawingSized Method

Raises the DrawingSized event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnDrawingSized(DataVisualization.DrawingEventArgs e);
[Visual Basic]
Protected Overridable Sub OnDrawingSized(ByVal e As DataVisualization.DrawingEventArgs)
Parameter | Description
e | Specifies an DrawingEventArgs object that contains the event data.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.TextControl.OnFormattingStyleListChanged Method

Raises the FormattingStyleListChanged event.

Syntax

[C#]
protected virtual void OnFormattingStyleListChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnFormattingStyleListChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.WPF.TextControl.OnFrameClicked Method

Raises the FrameClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameDeselected Method

Raises the FrameDeselected event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameDeselected(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameDeselected(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameDoubleClicked Method

Raises the FrameDoubleClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameDoubleClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameDoubleClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameLayoutChanged Method

Raises the FrameLayoutChanged event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameLayoutChanged(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameLayoutChanged(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameMoved Method

Raises the FrameMoved event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameMoved(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameMoved(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameRightClicked Method

Raises the FrameRightClicked event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameRightClicked(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameRightClicked(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameSelected Method

Raises the FrameSelected event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameSelected(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameSelected(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnFrameSized Method

Raises the FrameSized event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnFrameSized(FrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnFrameSized(ByVal e As FrameEventArgs)
Parameter | Description
e | Specifies an FrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnHeaderFooterActivated Method

Raises the HeaderFooterActivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterActivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterActivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.OnHeaderFooterDeactivated Method

Raises the HeaderFooterDeactivated event.

Syntax

[C#]
protected virtual void OnHeaderFooterDeactivated(HeaderFooterEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHeaderFooterDeactivated(ByVal e As HeaderFooterEventArgs)
Parameter | Description
e | Specifies an HeaderFooterEventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Inserting Page Numbers
  • The Page Setup Dialog
  • Programming Category: Headers and Footers
  • Graphical Overview: Headers and Footers


TXTextControl.WPF.TextControl.OnHExpanded Method

Raises the HExpanded event.

Syntax

[C#]
protected virtual void OnHExpanded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHExpanded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnHScroll Method

Raises the HScroll event.

Syntax

[C#]
protected virtual void OnHScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnHShrunk Method

Raises the HShrunk event.

Syntax

[C#]
protected virtual void OnHShrunk(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnHShrunk(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnHypertextLinkClicked Method

Raises the HypertextLinkClicked event.

Syntax

[C#]
protected virtual void OnHypertextLinkClicked(HypertextLinkEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHypertextLinkClicked(ByVal e As HypertextLinkEventArgs)
Parameter | Description
e | Specifies an HypertextLinkEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Inserting and Deleting Text Fields
  • Overview of the TextField and Hypertext Link Classes
  • Programming Hypertext Links
  • Text Fields and Hypertext Links - Hypertext Links
  • Programming Category: Hypertext Links
  • Graphical Overview: Hypertext Links


TXTextControl.WPF.TextControl.OnHyphenateWord Method

Raises the HyphenateWord event.

Introduced: 20.0.

Syntax

[C#]
protected virtual void OnHyphenateWord(HyphenateWordEventArgs e);
[Visual Basic]
Protected Overridable Sub OnHyphenateWord(ByVal e As HyphenateWordEventArgs)
Parameter | Description
e | Specifies an HyphenateWordEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.OnImageClicked Method

Raises the ImageClicked event.

Syntax

[C#]
protected virtual void OnImageClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageCreated Method

Raises the ImageCreated event.

Syntax

[C#]
protected virtual void OnImageCreated(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageCreated(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageDeleted Method

Raises the ImageDeleted event.

Syntax

[C#]
protected virtual void OnImageDeleted(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeleted(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageDeselected Method

Raises the ImageDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnImageDeselected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDeselected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageDoubleClicked Method

Raises the ImageDoubleClicked event.

Syntax

[C#]
protected virtual void OnImageDoubleClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageDoubleClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageMoved Method

Raises the ImageMoved event.

Syntax

[C#]
protected virtual void OnImageMoved(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageMoved(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageRightClicked Method

Raises the ImageRightClicked event.

Syntax

[C#]
protected virtual void OnImageRightClicked(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageRightClicked(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageSelected Method

Raises the ImageSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnImageSelected(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageSelected(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnImageSized Method

Raises the ImageSized event.

Syntax

[C#]
protected virtual void OnImageSized(ImageEventArgs e);
[Visual Basic]
Protected Overridable Sub OnImageSized(ByVal e As ImageEventArgs)
Parameter | Description
e | Specifies an ImageEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Creating Multipage TIFF Images
  • Loading, Saving and Exporting Images
  • Programming Category: Images
  • Graphical Overview: Images


TXTextControl.WPF.TextControl.OnInputFormattingStyleChanged Method

Raises the InputFormattingStyleChanged event.

Syntax

[C#]
protected virtual void OnInputFormattingStyleChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputFormattingStyleChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Stylesheet Formatting
  • Graphical Overview: Stylesheet Formatting


TXTextControl.WPF.TextControl.OnInputParagraphChanged Method

Raises the InputParagraphChanged event.

Syntax

[C#]
protected virtual void OnInputParagraphChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputParagraphChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.OnInputPositionChanged Method

Raises the InputPositionChanged event.

Syntax

[C#]
protected virtual void OnInputPositionChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnInputPositionChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.OnPageChanged Method

Raises the PageChanged event.

Syntax

[C#]
protected virtual void OnPageChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnPageChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.OnPageFormatChanged Method

Raises the PageFormatChanged event.

Syntax

[C#]
protected virtual void OnPageFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnPageFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.OnParagraphFormatChanged Method

Raises the ParagraphFormatChanged event.

Syntax

[C#]
protected virtual void OnParagraphFormatChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnParagraphFormatChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.OnSectionChanged Method

Raises the SectionChanged event.

Syntax

[C#]
protected virtual void OnSectionChanged(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnSectionChanged(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.OnSpellCheckText Method

Raises the SpellCheckText event.

Introduced: 16.0.

Syntax

[C#]
protected virtual void OnSpellCheckText(SpellCheckTextEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSpellCheckText(ByVal e As SpellCheckTextEventArgs)
Parameter | Description
e | Specifies an SpellCheckTextEventArgs object that contains the event data.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.OnSubTextPartClicked Method

Raises the SubTextPartClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnSubTextPartDoubleClicked Method

Raises the SubTextPartDoubleClicked event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartDoubleClicked(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartDoubleClicked(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnSubTextPartEntered Method

Raises the SubTextPartEntered event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartEntered(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartEntered(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnSubTextPartLeft Method

Raises the SubTextPartLeft event.

Introduced: 23.0.

Syntax

[C#]
protected virtual void OnSubTextPartLeft(SubTextPartEventArgs e);
[Visual Basic]
Protected Overridable Sub OnSubTextPartLeft(ByVal e As SubTextPartEventArgs)
Parameter | Description
e | Specifies an SubTextPartEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnTableCreated Method

Raises the TableCreated event.

Syntax

[C#]
protected virtual void OnTableCreated(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableCreated(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.OnTableDeleted Method

Raises the TableDeleted event.

Syntax

[C#]
protected virtual void OnTableDeleted(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableDeleted(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.OnTableFormatChanged Method

Raises the TableFormatChanged event.

Syntax

[C#]
protected virtual void OnTableFormatChanged(TableEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTableFormatChanged(ByVal e As TableEventArgs)
Parameter | Description
e | Specifies an TableEventArgs object that contains the event data.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.OnTextContextMenuOpening Method

Raises the TextContextMenuOpening event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextContextMenuOpening(TextContextMenuEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextContextMenuOpening(ByVal e As TextContextMenuEventArgs)
Parameter | Description
e | Specifies an WPF.TextContextMenuEventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnTextFieldChanged Method

Raises the TextFieldChanged event.

Syntax

[C#]
protected virtual void OnTextFieldChanged(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldChanged(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldClicked Method

Raises the TextFieldClicked event.

Syntax

[C#]
protected virtual void OnTextFieldClicked(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldClicked(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldCreated Method

Raises the TextFieldCreated event.

Syntax

[C#]
protected virtual void OnTextFieldCreated(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldCreated(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldDoubleClicked Method

Raises the TextFieldDoubleClicked event.

Syntax

[C#]
protected virtual void OnTextFieldDoubleClicked(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldDoubleClicked(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldDeleted Method

Raises the TextFieldDeleted event.

Syntax

[C#]
protected virtual void OnTextFieldDeleted(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldDeleted(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldEntered Method

Raises the TextFieldEntered event.

Syntax

[C#]
protected virtual void OnTextFieldEntered(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldEntered(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFieldLeft Method

Raises the TextFieldLeft event.

Syntax

[C#]
protected virtual void OnTextFieldLeft(TextFieldEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFieldLeft(ByVal e As TextFieldEventArgs)
Parameter | Description
e | Specifies an TextFieldEventArgs object that contains the event data.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.OnTextFrameActivated Method

Raises the TextFrameActivated event.

Syntax

[C#]
protected virtual void OnTextFrameActivated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameActivated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameAppearanceChanged Method

Raises the TextFrameAppearanceChanged event.

Introduced: 24.0.

Syntax

[C#]
protected virtual void OnTextFrameAppearanceChanged(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameAppearanceChanged(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies a TextFrameEventArgs object that contains the event data.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.OnTextFrameClicked Method

Raises the TextFrameClicked event.

Syntax

[C#]
protected virtual void OnTextFrameClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameCreated Method

Raises the TextFrameCreated event.

Syntax

[C#]
protected virtual void OnTextFrameCreated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameCreated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameDeactivated Method

Raises the TextFrameDeactivated event.

Syntax

[C#]
protected virtual void OnTextFrameDeactivated(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeactivated(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameDeleted Method

Raises the TextFrameDeleted event.

Syntax

[C#]
protected virtual void OnTextFrameDeleted(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeleted(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameDeselected Method

Raises the TextFrameDeselected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextFrameDeselected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDeselected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameDoubleClicked Method

Raises the TextFrameDoubleClicked event.

Syntax

[C#]
protected virtual void OnTextFrameDoubleClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameDoubleClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameMoved Method

Raises the TextFrameMoved event.

Syntax

[C#]
protected virtual void OnTextFrameMoved(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameMoved(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameRightClicked Method

Raises the TextFrameRightClicked event.

Syntax

[C#]
protected virtual void OnTextFrameRightClicked(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameRightClicked(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameSelected Method

Raises the TextFrameSelected event.

Introduced: 19.0.

Syntax

[C#]
protected virtual void OnTextFrameSelected(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameSelected(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnTextFrameSized Method

Raises the TextFrameSized event.

Syntax

[C#]
protected virtual void OnTextFrameSized(TextFrameEventArgs e);
[Visual Basic]
Protected Overridable Sub OnTextFrameSized(ByVal e As TextFrameEventArgs)
Parameter | Description
e | Specifies an TextFrameEventArgs object that contains the event data.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.OnVExpanded Method

Raises the VExpanded event.

Syntax

[C#]
protected virtual void OnVExpanded(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVExpanded(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnVScroll Method

Raises the VScroll event.

Syntax

[C#]
protected virtual void OnVScroll(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVScroll(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnVShrunk Method

Raises the VShrunk event.

Syntax

[C#]
protected virtual void OnVShrunk(EventArgs e);
[Visual Basic]
Protected Overridable Sub OnVShrunk(ByVal e As EventArgs)
Parameter | Description
e | Specifies an EventArgs object that contains the event data.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.OnXmlInvalid Method

Raises the XmlInvalid event.

Syntax

[C#]
protected virtual void OnXmlInvalid(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlInvalid(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.OnXmlNotWellFormed Method

Raises the XmlNotWellFormed event.

Syntax

[C#]
protected virtual void OnXmlNotWellFormed(XmlErrorEventArgs e);
[Visual Basic]
Protected Overridable Sub OnXmlNotWellFormed(ByVal e As XmlErrorEventArgs)
Parameter | Description
e | Specifies an XmlErrorEventArgs object that contains the event data.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.PageChanged Event

Occurs when the text input position has been moved to another page. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler PageChanged;
[Visual Basic]
Public Event PageChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.PageColorDialog Method

Invokes the built-in dialog box for setting the page color.

Introduced: 24.0.

Syntax

[C#]
public DialogResult PageColorDialog();
[Visual Basic]
Public Function PageColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.PageFormatChanged Event

Occurs when the page format settings have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler PageFormatChanged;
[Visual Basic]
Public Event PageFormatChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.PageMargins Property

Gets or sets the margins for the pages of the current document. The measure depends on the WPF.TextControl.PageUnit property. The default measure is device-independent units (1/96th inch). The property value is an object of the type PageMargins. For more information see the description of the PageMargins class.

Syntax

[C#]
public PageMargins PageMargins { get; set; }
[Visual Basic]
Public Property PageMargins() As PageMargins

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.Pages Property

Gets the number of pages contained in the current document.

Syntax

[C#]
public int Pages { get; }
[Visual Basic]
Public ReadOnly Property Pages() As Integer

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.PageSize Property

Specifies the width and height of the pages for the current document. The measure depends on the WPF.TextControl.PageUnit property. The default measure is device-independent units (1/96th inch). The property value is an object of the type PageSize. For more information see the description of the PageSize class.

Syntax

[C#]
public PageSize PageSize { get; set; }
[Visual Basic]
Public Property PageSize() As PageSize

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.PageUnit Property

Gets or sets the measure used for page sizes and page margins.

Syntax

[C#]
public PageUnit PageUnit { get; set; }
[Visual Basic]
Public Property PageUnit() As PageUnit
Value | Description
Millimeter | The measure for page sizes and page margins is millimeter.
CentiInch | The measure for page sizes and page margins is 1/100th inch.
StandardWPF | The measure for page sizes and page margins is 1/96th inch.
Twips | The measure for page sizes and page margins is Twips (1/1440th inch). This is the internally used TXTextControl measure.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.ParagraphFormat Property

Gets or sets the paragraph formatting attributes of the text displayed by the control. The property value is an object of the type ParagraphFormat. For more information see the description of the ParagraphFormat class.

Syntax

[C#]
public ParagraphFormat ParagraphFormat { get; set; }
[Visual Basic]
Public Property ParagraphFormat() As ParagraphFormat

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.ParagraphFormatChanged Event

Occurs when the formatting attributes of the selected paragraphs have been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler ParagraphFormatChanged;
[Visual Basic]
Public Event ParagraphFormatChanged As EventHandler

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting


TXTextControl.WPF.TextControl.ParagraphFormatDialog Method

Invokes the built-in dialog box for setting the formatting attributes of a paragraph.

ParagraphFormatDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult ParagraphFormatDialog();
[Visual Basic]
Public Function ParagraphFormatDialog() As DialogResult

ParagraphFormatDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult ParagraphFormatDialog(int activeTab);
[Visual Basic]
Public Function ParagraphFormatDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting alignment, line spacing, indentation and Distances, and if this parameter is 1, the dialog box shows the tab for setting a frame and pagination.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Paragraphs Property

Gets a collection of all paragraphs contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type ParagraphCollection.

Syntax

[C#]
public ParagraphCollection Paragraphs { get; }
[Visual Basic]
Public ReadOnly Property Paragraphs() As ParagraphCollection

Limitations

Read only.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Programming
  • Graphical Overview: Paragraph Programming


TXTextControl.WPF.TextControl.ParagraphStyles Property

Gets a collection of all paragraph styles the current document contains. The property's value is an object of the type ParagraphStyleCollection.

Syntax

[C#]
public ParagraphStyleCollection ParagraphStyles { get; }
[Visual Basic]
Public ReadOnly Property ParagraphStyles() As ParagraphStyleCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Stylesheet Programming
  • Graphical Overview: Stylesheet Programming


TXTextControl.WPF.TextControl.Paste Method

Replaces the current selection in the Text Control with the contents of the Clipboard.

Paste()

Replaces the current selection in the Text Control with the contents of the Clipboard. If the data in the clipboard are provided in several formats, the format with the maximum of information is used.

[C#]
public void Paste();
[Visual Basic]
Public Sub Paste()

Paste(ClipboardFormat)

Replaces the current selection in the Text Control with the contents of the Clipboard. Only data provided in the specified format is inserted.

[C#]
public void Paste(ClipboardFormat format);
[Visual Basic]
Public Sub Paste(ByVal format As ClipboardFormat)
Member | Description
format | Specifies the format to paste. It must be one of the ClipboardFormat values contained in the array returned through the GetClipboardFormats method. This parameter can be used to change the default behaviour, if the clipboard contains the data in more than one format. By default, TXTextControl inserts data from the clipboard in the following order: textframe, formatted image, formatted text (TXTextControl format), formatted text (RTF format), formatted text (HTML format), plain text, image.

See Also

  • Programming Category: Clipboard Operations
  • Graphical Overview: Clipboard Operations


TXTextControl.WPF.TextControl.PermanentControlChars Property

Gets or sets a value indicating which control characters are shown permanently on the screen. The property's value can be a bitwise OR combination of the PermanentControlChar enumeration. The bitwise AND operator can be used to test for a given format.

Introduced: 19.0.

Syntax

[C#]
public PermanentControlChar PermanentControlChars { get; set; }
[Visual Basic]
Public Property PermanentControlChars() As PermanentControlChar

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.Print Method

Prints a Text Control document or a part of a document.

Print(String, Boolean)

Opens the standard print dialog to get printer settings and prints the document.

[C#]
public void Print(string docName, bool useLastPrinterSettings);
[Visual Basic]
Public Sub Print(ByVal DocName As String, ByVal UseLastPrinterSettings As Boolean)
Member | Description
docName | Specifies the document's name.
useLastPrinterSettings | If this parameter is set to true, the dialog box is initialized with the user settings of the previous call.

Print(String, PageRange, Int32, Collation)

Prints a Text Control document with the standard printer using the specified page range, copy count and collation settings.

[C#]
public void Print(string docName, System.Windows.Controls.PageRange pageRange, int copyCount, System.Printing.Collation collation);
[Visual Basic]
Public Sub Print(ByVal DocName As String, ByVal pageRange As System.Windows.Controls.PageRange, ByVal copyCount As Integer, ByVal collation As System.Printing.Collation)
Member | Description
docName | Specifies the document's name.
pageRange | Specifies a System.Windows.Controls.PageRange structure specifying the range of pages to print.
copyCount | Specifies the number of copies to print.
collation | Specifies a System.Printing.Collation member specifying whether the printer collates output.

Print(String, String, PageRange, Int32, Collation)

Prints a Text Control document with the specified printer using the specified page range, copy count and collation settings.

[C#]
public void Print(string docName, string printerName, System.Windows.Controls.PageRange pageRange, int copyCount, System.Printing.Collation collation);
[Visual Basic]
Public Sub Print(ByVal DocName As String, ByVal PrinterName As String, ByVal pageRange As System.Windows.Controls.PageRange, ByVal copyCount As Integer, ByVal collation As System.Printing.Collation)
Member | Description
docName | Specifies the document's name.
printerName | Specifies the name of the printer to which the output is sent.
pageRange | Specifies a System.Windows.Controls.PageRange structure specifying the range of pages to print.
copyCount | Specifies the number of copies to print.
collation | Specifies a System.Printing.Collation member specifying whether the printer collates output.

See Also

  • Printing into a PrintDocument
  • Printing without the Status Dialog
  • Programming Category: Printing and Print Preview
  • Graphical Overview: Printing and Print Preview


TXTextControl.WPF.TextControl.Redo Method

Redoes the last Text Control operation.

Syntax

[C#]
public void Redo();
[Visual Basic]
Public Sub Redo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.RedoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Redo method is made. The property's value is null if there is no action that can be redone.

Syntax

[C#]
public string RedoActionName { get; }
[Visual Basic]
Public ReadOnly Property RedoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.Replace Method

Opens the built-in Replace dialog box.

Syntax

[C#]
public void Replace();
[Visual Basic]
Public Sub Replace()

See Also

  • Programming Category: Search and Replace
  • Graphical Overview: Search and Replace
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.ResetContents Method

Deletes the entire contents of a Text Control.

Syntax

[C#]
public void ResetContents();
[Visual Basic]
Public Sub ResetContents()

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.RibbonFormattingTab Property

Specifies the name of the WPF.RibbonFormattingTab object to be used with a TextControl. The elements of the ribbon tab can be used to alter character and paragraph attributes. The property value is null, if there is no ribbon tab connected.

Introduced: 22.0.

Syntax

[C#]
public string RibbonFormattingTab { get; set; }
[Visual Basic]
Public Property RibbonFormattingTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonFrameLayoutTab Property

Specifies the name of the WPF.RibbonFrameLayoutTab object to be used with a TextControl. The elements of the ribbon tab can be used to alter attributes of images, text frames, barcodes and drawings. The property value is null, if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonFrameLayoutTab { get; set; }
[Visual Basic]
Public Property RibbonFrameLayoutTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonInsertTab Property

Specifies the name of the WPF.RibbonInsertTab object to be used with a TextControl. The parts of the ribbon tab can be used to insert elements such as illustrations, tables, text frames, hyperlinks and headers and footers. The property value is null, if there is no ribbon tab connected.

Introduced: 22.0.

Syntax

[C#]
public string RibbonInsertTab { get; set; }
[Visual Basic]
Public Property RibbonInsertTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonPageLayoutTab Property

Specifies the name of the WPF.RibbonPageLayoutTab object to be used with a TextControl. The elements of the ribbon tab can be used to set page formatting attributes such as margins, page size, columns and document frames. The property value is null, if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonPageLayoutTab { get; set; }
[Visual Basic]
Public Property RibbonPageLayoutTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonReportingTab Property

Specifies the name of the WPF.RibbonReportingTab object to be used with a TextControl. The elements of the ribbon tab can be used to integrate mail merge and reporting functionality. The property value is null if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonReportingTab { get; set; }
[Visual Basic]
Public Property RibbonReportingTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonProofingTab Property

Specifies the name of the WPF.RibbonProofingTab object to be used with a TextControl. The elements of the ribbon tab can be used to check spelling and hyphenation. The property value is null if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonProofingTab { get; set; }
[Visual Basic]
Public Property RibbonProofingTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonTableLayoutTab Property

Specifies the name of the WPF.RibbonTableLayoutTab object to be used with a TextControl. The elements of the ribbon tab can be used to set the attributes and the layout of a table. The property value is null, if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonTableLayoutTab { get; set; }
[Visual Basic]
Public Property RibbonTableLayoutTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RibbonViewTab Property

Specifies the name of the WPF.RibbonViewTab object to be used with a TextControl. The elements of the ribbon tab can be used to alter the document's view. The property value is null, if there is no ribbon tab connected.

Introduced: 24.0.

Syntax

[C#]
public string RibbonViewTab { get; set; }
[Visual Basic]
Public Property RibbonViewTab() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.RulerBar Property

Specifies the horizontal ruler bar control to be used with a TextControl. The property value is null if there is no ruler bar connected. Otherwise it must be the name of an existing WPF.RulerBar object.

Syntax

[C#]
public string RulerBar { get; set; }
[Visual Basic]
Public Property RulerBar() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.Save Method

Saves the complete contents of a document with the specified format.

Save()

Opens a file save dialogbox and saves the complete contents of a document in a file.

[C#]
public DialogResult Save();
[Visual Basic]
Public Function Save() As DialogResult

Save(StreamType)

Opens a file save dialogbox and saves the complete contents of a document in a file with the specified format.

[C#]
public DialogResult Save(StreamType streamType);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.

Save(String, StreamType)

Saves the complete contents of a document in the specified file with the specified format.

[C#]
public void Save(string path, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.

Save(FileStream, StreamType)

Saves the complete contents of a document in the specified file stream with the specified format.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.

Save(Byte[], BinaryStreamType)

Saves the complete contents of a document in the specified byte array with the specified format.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

Save(String, StringStreamType)

Saves the complete contents of a document as a string with the specified format.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

Save(StreamType, SaveSettings)

Opens a file save dialogbox and saves the complete contents of a document in a file with the specified format and special settings.

[C#]
public DialogResult Save(StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Function Save(ByVal streamType As StreamType, ByVal saveSettings As SaveSettings) As DialogResult
Member | Description
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file using the specified format and special settings.

[C#]
public void Save(string path, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal path As String, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(FileStream, StreamType, SaveSettings)

Saves the complete contents of a document in the specified file stream using the specified format and special settings.

[C#]
public void Save(System.IO.FileStream fileStream, StreamType streamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As StreamType, ByVal saveSettings As SaveSettings)
Member | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(Byte[], BinaryStreamType, SaveSettings)

Saves the complete contents of a document in the specified byte array using the specified format and special settings.

[C#]
public void Save(out byte[] binaryData, BinaryStreamType binaryStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef binaryData As Byte(), ByVal binaryStreamType As BinaryStreamType, ByVal saveSettings As SaveSettings)
Member | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Save(String, StringStreamType, SaveSettings)

Saves the complete contents of a document as a string using the specified format and special settings.

[C#]
public void Save(out string stringData, StringStreamType stringStreamType, SaveSettings saveSettings);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal stringStreamType As StringStreamType, ByVal saveSettings As SaveSettings)
Member | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.
saveSettings | Specifies a SaveSettings object with additional information and settings for the save operation.

Return Value

The implementations which open a dialog box return a WPF.DialogResult value.

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.ScrollLocation Property

Gets or sets the coordinates, in twips, of the upper-left corner of the document's visible part relative to the upper-left corner of the complete document.

Syntax

[C#]
public System.Windows.Point ScrollLocation { get; set; }
[Visual Basic]
Public Property ScrollLocation() As System.Windows.Point

Limitations

Runtime only.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.SectionChanged Event

Occurs when the text input position has been moved to another section. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler SectionChanged;
[Visual Basic]
Public Event SectionChanged As EventHandler

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.SectionFormatDialog Method

Invokes the built-in tabbed dialog box for setting section attributes. These are page settings such as margins, size and orientation and all settings concerning headers and footers.

Syntax

[C#]
public DialogResult SectionFormatDialog(int activeTab);
[Visual Basic]
Public Function SectionFormatDialog(ByVal activeTab As Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting page margins, page size and orientation, if this parameter is 1, the dialog box shows the tab for setting headers and footers and if it is 2, the dialog shows the tab for setting column attributes.

Return Value

If the dialog is left with the Cancel button, the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Sections Property

Gets a collection of all sections in the document. The property's value is an object of the type SectionCollection.

Syntax

[C#]
public SectionCollection Sections { get; }
[Visual Basic]
Public ReadOnly Property Sections() As SectionCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Document Sections
  • Accessing Document Sections
  • Adding a Header and a Footer with Data to a Document
  • Getting the Page Number at the Current Scroll Location
  • Inserting Columns programmatically using TX Text Control .NET
  • Removing empty Pages
  • Scrolling programmatically to a Text Position
  • The Page Setup Dialog
  • Programming Category: Sections and Pages
  • Graphical Overview: Sections and Pages


TXTextControl.WPF.TextControl.Select Method

Selects text within the Text Control.

Syntax

[C#]
public void Select(int start, int length);
[Visual Basic]
Public Sub Select(ByVal start As Integer, ByVal length As Integer)
Parameter | Description
start | Specifies the selection's start position.
length | Specifies the number of selected characters.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.SelectAll Method

Selects all text in the Text Control.

Syntax

[C#]
public void SelectAll();
[Visual Basic]
Public Sub SelectAll()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.Selection Property

Gets or sets the current selection in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property value is an object of the type Selection. A selection can be used to assign character and paragraph formatting attributes to a piece of text.

Syntax

[C#]
public Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Selection

Limitations

Runtime only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.SelectionViewMode Property

Specifies whether text selections are displayed with a transparent bitmap or through inverting the text.

Introduced: 17.0.

Syntax

[C#]
public SelectionViewMode SelectionViewMode { get; set; }
[Visual Basic]
Public Property SelectionViewMode() As SelectionViewMode
Value | Description
Classic | When text is selected, this text is inverted on the screen.
TransparentBitmap | When text is selected, a transparent bitmap is used to display the selection.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Text Selections and Character Input
  • Graphical Overview: Text Selections and Character Input


TXTextControl.WPF.TextControl.SpellCheckContextMenu Property

Specifies the context menu which is used when the end-user right-clicks a misspelled word. A context menu is only available when a spell checking component has been connected with the SpellChecker property.

Introduced: 18.0.

Syntax

[C#]
public string SpellCheckContextMenu { get; set; }
[Visual Basic]
Public Property SpellCheckContextMenu() As String
Value | Description
(none) | No context menu is displayed when the end-user right-clicks a misspelled word.
(Default) | The TXTextControl built-in context menu is displayed when the end-user right-clicks a misspelled word.
other | The property value must be the key of a user-defined context menu. Such a context menu must be added to the Resources dictionary of a TextControl or a parent of a TextControl in the logical element tree of the application. The resource key of the resource must be specified as property value of this property. The example below shows how to add a user-defined spell check context menu in XAML.

Example

The following XAML example shows how to add a user-defined ContextMenu to the Resources dictionary of a TextControl:

<Window xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
    xmlns:txspell="clr-namespace:TXTextControl.WPF.Proofing;assembly=TXSpell.WPF">
  <tx:TextControl Name="textControl1">
    <tx:TextControl.Resources>
      <ContextMenu x:Key="UserSpellCheckMenu">
        <MenuItem Click="MenuItem1_Clicked" Header="MenuItem1"/>
        <MenuItem Click="MenuItem2_Clicked" Header="MenuItem2"/>
        <MenuItem Click="MenuItem3_Clicked" Header="MenuItem3"/>
      </ContextMenu>
    </tx:TextControl.Resources>
  </tx:TextControl>
</Window>

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.SpellCheckDialog Method

Invokes the built-in dialog box for correcting misspelled words. The dialog steps through all misspelled words in the current document. It begins with the main text following by all headers, footers and textframes. This dialog is only available when a spell checking component has been connected with the SpellChecker property.

Introduced: 17.0.

SpellCheckDialog()

Invokes the built-in dialog box for correcting misspelled words.

[C#]
public void SpellCheckDialog();
[Visual Basic]
Public Sub SpellCheckDialog()

SpellCheckDialog(Object)

Invokes the built-in dialog box for correcting misspelled words using the specified dictionary for making suggestions.

[C#]
public void SpellCheckDialog(object suggestionDictionary);
[Visual Basic]
Public Sub SpellCheckDialog(ByVal suggestionDictionary As Object)
Parameter | Description
suggestionDictionary | Specifies the dictionary used for making suggestions. This parameter is only useful, if more than one dictionary has been added to the spellchecker.

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.SpellChecker Property

Specifies the spell checking component to be used with a TextControl. The property value must be the key of a resource added to the Resources dictionary of a TextControl or a parent of a TextControl in the logical element tree of the application. The resource key must be a string. Specifying an empty string, a connected spellchecker can be disconnected. When a spell checking component is connected and the IsSpellCheckingEnabled property has been set to true, misspelled words are automatically underlined with a red zigzag line. The SpellCheckDialog method can be used to correct the misspelled words contained in the document. When a spell checking component is connected and the IsHyphenationEnabled property has been set to true, a document is automatically hyphenated. If the IsLanguageDetectionEnabled property has been set to true, a language is automatically detected for all text parts with a neutral language.

Introduced: 17.0.

Syntax

[C#]
public string SpellChecker { get; set; }
[Visual Basic]
Public Property SpellChecker() As String

Example

The following XAML example shows how to add a TXSpellChecker component to the Resources dictionary of a TextControl:

<Window xmlns:tx="clr-namespace:TXTextControl.WPF;assembly=TXTextControl.WPF"
    xmlns:txspell="clr-namespace:TXTextControl.WPF.Proofing;assembly=TXSpell.WPF">
  <tx:TextControl Name="textControl1">
    <tx:TextControl.Resources>
      <txspell:TXSpellChecker x:Key="txspellChecker1"/>
    </tx:TextControl.Resources>
  </tx:TextControl>
</Window>

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.SpellCheckText Event

Occurs, if the document's text has been altered and the spelling of the new text must be checked. This event occurs only, if the WPF.TextControl.IsSpellCheckingEnabled property has been set to true. The event handler receives an argument of type SpellCheckTextEventArgs containing data related to this event.

Syntax

[C#]
public event SpellCheckTextEventHandler SpellCheckText;
[Visual Basic]
Public Event SpellCheckText As SpellCheckTextEventHandler

See Also

  • Programming Category: Spell Checking
  • Graphical Overview: Spell Checking


TXTextControl.WPF.TextControl.StatusBar Property

Specifies the status bar control to be used with a TextControl. The property value is null if there is no status bar connected. Otherwise it must be the name of an existing WPF.StatusBar object.

Syntax

[C#]
public string StatusBar { get; set; }
[Visual Basic]
Public Property StatusBar() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.SubTextPartClicked Event

Occurs when a subtextpart has been clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartClicked;
[Visual Basic]
Public Event SubTextPartClicked As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.SubTextPartDoubleClicked Event

Occurs when a subtextpart has been double-clicked on. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartDoubleClicked;
[Visual Basic]
Public Event SubTextPartDoubleClicked As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.SubTextPartEntered Event

Occurs when the current input position has been moved to a position that belongs to a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartEntered;
[Visual Basic]
Public Event SubTextPartEntered As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.SubTextPartLeft Event

Occurs when the current input position has left a subtextpart. The event handler receives an argument of type SubTextPartEventArgs containing data related to this event.

Introduced: 23.0.

Syntax

[C#]
public event SubTextPartEventHandler SubTextPartLeft;
[Visual Basic]
Public Event SubTextPartLeft As SubTextPartEventHandler

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.SubTextParts Property

Gets a collection of all subtextparts contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type SubTextPartCollection.

Introduced: 23.0.

Syntax

[C#]
public SubTextPartCollection SubTextParts { get; }
[Visual Basic]
Public ReadOnly Property SubTextParts() As SubTextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.TabDialog Method

Invokes the built-in dialog box for setting tabs.

Syntax

[C#]
public DialogResult TabDialog();
[Visual Basic]
Public Function TabDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Replacing a Paragraph with a Line Break on Enter Key
  • Programming Category: Paragraph Formatting
  • Graphical Overview: Paragraph Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.TabIndex Property

Gets or sets the tab index of the text control.

Syntax

[C#]
public int TabIndex { get; set; }
[Visual Basic]
Public Property TabIndex() As Integer

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.TableCreated Event

Occurs after a new table has been created as a result of a text insertion via the clipboard or when loading a document which contains a table without an identifier. It does not occur when the table is inserted with the TableInsert method or for tables that have a previously set identifier when loading a document. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableCreated;
[Visual Basic]
Public Event TableCreated As TableEventHandler

Remarks

The TableCreated event is always fired, if a table is inserted from the clipboard and is not next to another table. If the table has an identifier, it will be kept. If a previously existent table has the same identifier, the identifier will point to the already present table.

The TableCreated event is not fired, if a table is inserted from the clipboard next to another table. The table will be merged with the existent table and the resulting table inherits the identifier from the already existent one.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.TableDeleted Event

Occurs after a table has been deleted. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableDeleted;
[Visual Basic]
Public Event TableDeleted As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.TableFormatChanged Event

Occurs when the design attributes of a selected table have been changed. The event handler receives an argument of type TableEventArgs containing data related to this event.

Syntax

[C#]
public event TableEventHandler TableFormatChanged;
[Visual Basic]
Public Event TableFormatChanged As TableEventHandler

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.TableFormatDialog Method

Invokes the built-in dialog box for setting formatting attributes of tables. The TableCollection.GetItem method can be used to test whether a table is selected or not.

TableFormatDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult TableFormatDialog();
[Visual Basic]
Public Function TableFormatDialog() As DialogResult

TableFormatDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult TableFormatDialog(int activeTab);
[Visual Basic]
Public Function TableFormatDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting frame lines, color and distances, and if this parameter is 1, the dialog box shows the tab for setting vertical size and alignment.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.Tables Property

Gets a collection of all tables contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TableCollection.

Syntax

[C#]
public TableCollection Tables { get; }
[Visual Basic]
Public ReadOnly Property Tables() As TableCollection

Limitations

Runtime only.

Read only.

See Also

  • Inserting a Table with Text Fields
  • Programming Category: Tables
  • Graphical Overview: Tables


TXTextControl.WPF.TextControl.Text Property

Gets or sets the text contents of the text control.

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • PDF Import and Export
  • Programming Category: Loading, Saving and Database Support
  • Graphical Overview: Loading, Saving and Database Support


TXTextControl.WPF.TextControl.TextBackColorDialog Method

Invokes the built-in dialog box for setting the background color of the text.

Introduced: 22.0.

Syntax

[C#]
public DialogResult TextBackColorDialog();
[Visual Basic]
Public Function TextBackColorDialog() As DialogResult

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Programming Category: Character Formatting
  • Graphical Overview: Character Formatting
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.TextChars Property

Gets a collection of all characters contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TextCharCollection.

Syntax

[C#]
public TextCharCollection TextChars { get; }
[Visual Basic]
Public ReadOnly Property TextChars() As TextCharCollection

Limitations

Read only.

See Also

  • Programming Category: Line and Character Operations
  • Graphical Overview: Line and Character Operations


TXTextControl.WPF.TextControl.TextContextMenuOpening Event

Occurs immedialtely before a built-in context menu will be opened. The event handler receives an argument of type WPF.TextContextMenuEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextContextMenuHandler TextContextMenuOpening;
[Visual Basic]
Public Event TextContextMenuOpening As TextContextMenuEventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.TextFieldChanged Event

Occurs when the text of a text field has been changed. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldChanged;
[Visual Basic]
Public Event TextFieldChanged As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldClicked Event

Occurs when a text field has been clicked on. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldClicked;
[Visual Basic]
Public Event TextFieldClicked As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldCreated Event

Occurs when a text field has been pasted from the clipboard. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldCreated;
[Visual Basic]
Public Event TextFieldCreated As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldDoubleClicked Event

Occurs when a text field has been double-clicked on. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldDoubleClicked;
[Visual Basic]
Public Event TextFieldDoubleClicked As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldDeleted Event

Occurs when a text field has been deleted. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldDeleted;
[Visual Basic]
Public Event TextFieldDeleted As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Inserting and Deleting Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldEntered Event

Occurs when the current input position has been moved to a position that belongs to a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldEntered;
[Visual Basic]
Public Event TextFieldEntered As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFieldLeft Event

Occurs when the current input position has left a text field. The event handler receives an argument of type TextFieldEventArgs containing data related to this event.

Syntax

[C#]
public event TextFieldEventHandler TextFieldLeft;
[Visual Basic]
Public Event TextFieldLeft As TextFieldEventHandler

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Text Fields and Hypertext Links - Editing Marked Text Fields
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFields Property

Gets a collection of all standard text fields contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TextFieldCollection.

Syntax

[C#]
public TextFieldCollection TextFields { get; }
[Visual Basic]
Public ReadOnly Property TextFields() As TextFieldCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Text Fields and Hypertext Links
  • Editing Text Fields
  • Identifiers and Names for Text Fields and Hypertext Links
  • Importing Fields from Microsoft Word
  • Importing MS Word Merge Fields
  • Inserting a Table with Text Fields
  • Inserting and Deleting Text Fields
  • Inserting Page Numbers
  • Overview of the TextField and Hypertext Link Classes
  • Programming Category: Text Fields
  • Graphical Overview: Text Fields


TXTextControl.WPF.TextControl.TextFrameActivated Event

Occurs when a text frame has been activated. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameActivated;
[Visual Basic]
Public Event TextFrameActivated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameAppearanceChanged Event

Occurs when the appearance of a text frame (background color, transparency, border, inner margins) has been changed. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 24.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameAppearanceChanged;
[Visual Basic]
Public Event TextFrameAppearanceChanged As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameAttributesDialog Method

Invokes the built-in dialog box for setting attributes of text frames. This dialog box is only shown, if a text frame is currently selected. The TextFrameCollection.GetItem method can be used to test whether a text frame is selected or not.

Introduced: 12.0.

TextFrameAttributesDialog()

Opens the dialog box showing its first tab.

[C#]
public DialogResult TextFrameAttributesDialog();
[Visual Basic]
Public Function TextFrameAttributesDialog() As DialogResult

TextFrameAttributesDialog(Int32)

Opens the dialog box showing the specified tab.

[C#]
public DialogResult TextFrameAttributesDialog(int activeTab);
[Visual Basic]
Public Function TextFrameAttributesDialog(activeTab as Integer) As DialogResult
Parameter | Description
activeTab | Specifies the index of the tab, zero-based, that is displayed when the tabbed dialog box is opened. If this parameter is 0, the dialog box shows the tab for setting text wrapping and layout attributes, if this parameter is 1, the dialog box shows the tab for setting size and distances and if it is 2, the dialog shows the tab for setting further textframe attributes such as a frame line or a background color.

Return Value

If the dialog has been left with the Cancel button the return value is DialogResult.Cancel. Otherwise, it is DialogResult.OK.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames
  • Programming Category: Integrated Dialog Boxes


TXTextControl.WPF.TextControl.TextFrameClicked Event

Occurs when a text frame has been clicked on. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameClicked;
[Visual Basic]
Public Event TextFrameClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameCreated Event

Occurs when a new text frame has been created. It occurs if a text frame has been inserted in the document with the clipboard or if a file containing text frames has been loaded. It does not occur if an text frame has been added with the TextFrameCollection.Add method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameCreated;
[Visual Basic]
Public Event TextFrameCreated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameDeactivated Event

Occurs when a text frame has been deactivated. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeactivated;
[Visual Basic]
Public Event TextFrameDeactivated As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameDeleted Event

Occurs when a text frame has been deleted. It occurs if a text frame has been deleted while editing a document or if an text frame has been deleted with the TextFrameCollection.Remove method. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeleted;
[Visual Basic]
Public Event TextFrameDeleted As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameDeselected Event

Occurs when a text frame has been deselected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDeselected;
[Visual Basic]
Public Event TextFrameDeselected As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameDoubleClicked Event

Occurs when a text frame has been doubleclicked on. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameDoubleClicked;
[Visual Basic]
Public Event TextFrameDoubleClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameMarkerLines Property

Specifies whether text frames that have no border line are shown with marker lines. This is a dependency property.

Syntax

[C#]
public bool TextFrameMarkerLines { get; set; }
[Visual Basic]
Public Property TextFrameMarkerLines() As Boolean

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameMoved Event

Occurs when a text frame has been moved. It does not occur, if an inline or anchored text frame has been moved because text has been inserted. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameMoved;
[Visual Basic]
Public Event TextFrameMoved As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameRightClicked Event

Occurs when a text frame has been clicked on with the right mouse button. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameRightClicked;
[Visual Basic]
Public Event TextFrameRightClicked As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrames Property

Gets a collection of all text frames contained in the text part with the input focus. This can be the main text, a text frame or a header or footer. The property's value is an object of the type TextFrameCollection. If a text frame contains further text frames, the inner frames are not contained in this collection.

Syntax

[C#]
public TextFrameCollection TextFrames { get; }
[Visual Basic]
Public ReadOnly Property TextFrames() As TextFrameCollection

Limitations

Runtime only.

Read only.

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameSelected Event

Occurs when a text frame has been selected. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event TextFrameEventHandler TextFrameSelected;
[Visual Basic]
Public Event TextFrameSelected As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextFrameSized Event

Occurs when a text frame has been sized. The event handler receives an argument of type TextFrameEventArgs containing data related to this event.

Syntax

[C#]
public event TextFrameEventHandler TextFrameSized;
[Visual Basic]
Public Event TextFrameSized As TextFrameEventHandler

See Also

  • Using Images, Text Frames, Charts, Barcodes and Drawings
  • Adding and Removing Images, Text Frames, Charts, Barcodes and Drawings
  • Programming Category: Text Frames
  • Graphical Overview: Text Frames


TXTextControl.WPF.TextControl.TextParts Property

Gets a collection of all main text parts the current document contains. The property's value is an object of the type TextPartCollection. The main text parts are the main text, text frames and headers and footers.

Syntax

[C#]
public TextPartCollection TextParts { get; }
[Visual Basic]
Public ReadOnly Property TextParts() As TextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Programming Formatted Textparts
  • Graphical Overview: Programming Formatted Textparts


TXTextControl.WPF.TextControl.Undo Method

Undoes the last edit operation in the Text Control.

Syntax

[C#]
public void Undo();
[Visual Basic]
Public Sub Undo()

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.UndoActionName Property

Gets a string that represents the name of the action that will be performed when a call to the Undo method is made. The property's value is null if there is no action that can be undone.

Syntax

[C#]
public string UndoActionName { get; }
[Visual Basic]
Public ReadOnly Property UndoActionName() As String

Limitations

Runtime only.

Read only.

See Also

  • TXTextControl.Selection and Undo
  • Programming Category: Undo
  • Graphical Overview: Undo


TXTextControl.WPF.TextControl.VerticalRulerBar Property

Specifies the vertical ruler bar control to be used with a TextControl. The property value is null if there is no ruler bar connected. Otherwise it must be the name of an existing WPF.RulerBar object.

Syntax

[C#]
public string VerticalRulerBar { get; set; }
[Visual Basic]
Public Property VerticalRulerBar() As String

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControl.VerticalScrollBarVisibility Property

Gets or sets a value that indicates whether a vertical scroll bar is shown. The property's value is of the type System.Windows.Controls.ScrollBarVisibility. This is a dependency property.

Syntax

[C#]
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
[Visual Basic]
Public Property VerticalScrollBarVisibility() As ScrollBarVisibility
Value | Description
Auto | A vertical scroll bar is shown when the document is not completely visible in the vertical direction.
Disabled | A vertical scroll bar is not shown even if the document is not completely visible.
Hidden | Same as Disabled.
Visible | Same as Auto.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.VExpanded Event

Occurs when the Text Control has automatically expanded its size vertically. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler VExpanded;
[Visual Basic]
Public Event VExpanded As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.ViewMode Property

Gets or sets the mode in which Text Control displays its contents.

Syntax

[C#]
public ViewMode ViewMode { get; set; }
[Visual Basic]
Public Property ViewMode() As ViewMode
Value | Description
FloatingText | The Text Control has a vertical scrollbar to enable unlimited text content. The maximum horizontal text extent is the horizontal size of the control. The values of the PageSize and PageMargins properties are ignored. Headers and footers are not displayed.
Normal | The Text Control has scrollbars and text is formatted according to the settings of the PageSize and the PageMargins properties. Headers and footers can be inserted but they are not displayed.
PageView | Text is formatted like in Normal view mode, and additionally the Text Control displays the pages in 3D view with gaps and a desktop background. Headers and footers are displayed in WYSIWYG mode.
SimpleControl | The Text Control formats the text according to the horizontal and vertical extent of the control. If the control is 'full', no further text can be inserted.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.VScroll Event

Occurs when the vertical scroll position has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler VScroll;
[Visual Basic]
Public Event VScroll As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.VShrunk Event

Occurs when the Text Control has automatically shrunk its size vertically. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler VShrunk;
[Visual Basic]
Public Event VShrunk As EventHandler

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControl.XmlEditMode Property

Gets or sets a value specifying whether Text Control operates in an edit mode that validates the XML document according to the document's DTD.

Syntax

[C#]
public XmlEditMode XmlEditMode { get; set; }
[Visual Basic]
Public Property XmlEditMode() As XmlEditMode
Value | Description
Validate | Every operation that manipulates an XML document is validated according to the document's DTD. This mode is read only and is automatically switched on after loading a valid XML document.
NoValidate | Text Control operates in its normal editor mode. No validation of an XML document occurs. Because the document can be invalid after every operation the document cannot be saved in XML format.

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.XmlInvalid Event

Occurs when a loaded or changed XML document cannot be validated with the document type definition (DTD) referenced in the document. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.XmlNotWellFormed Event

Occurs when a loaded XML document is not well-formed. The event handler receives an argument of type XmlErrorEventArgs containing data related to this event.

Syntax

[C#]
public event XmlErrorEventHandler XmlInvalid;
[Visual Basic]
Public Event XmlInvalid As XmlErrorEventHandler

See Also

  • Working with XML Files
  • Editing XML Files
  • Inserting and Deleting XML Elements
  • Loading and Saving XML Files
  • Programming XML Documents
  • Programming Category: XML Programming
  • Graphical Overview: XML Programming


TXTextControl.WPF.TextControl.Zoom Method

Zooms the contents of the TextControl.

Introduced: 24.0.

Zoom(Int32)

Zooms the contents of the TextControl using the specified zoom factor.

[C#]
public void Zoom(int zoomFactor);
[Visual Basic]
Public Sub Zoom(ByVal zoomFactor As Integer)
Parameter | Description
zoomFactor | Specifies the zoom factor, in percent.

Zoom(ZoomOption)

Zooms the contents of the TextControl using the specified option.

[C#]
public void Zoom(ZoomOption zoomOption);
[Visual Basic]
Public Sub Zoom(ByVal zoomOption As ZoomOption)
Parameter | Description
zoomOption | Specifies one of the ZoomOption values.

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent, when the TextControl.ViewMode property has been set to PageView or Normal. For the other modes the zoom factor must be between 10 and 400 percent.

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.WPF.TextControl.ZoomFactor Property

Gets or sets the zoom factor, in percent, for a Text Control. This is a dependency property.

Syntax

[C#]
public int ZoomFactor { get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

Limitations

The zoom factor must be between 10 and ushort.MaxValue percent, when the ViewMode property has been set to PageView or Normal. For the other modes the zoom factor must be between 10 and 400 percent.

See Also

  • Programming Category: Zooming
  • Graphical Overview: Zooming


TXTextControl.WPF.TextControlColors Class

The WPF.TextControlColors class gets, sets or resets the display colors of a WPF.TextControl control. By default the display colors depend on sytem colors. With this class all colors can be individually designed.

Introduced: 16.0.

Syntax

[C#]
public class TextControlColors
[Visual Basic]
Public Class TextControlColors

Constructors

Constructor | Description
TextControlColors | Initializes a new instance of the WPF.TextControlColors class.

Properties

Property | Description
DarkShadowColor | Gets or sets the display color for the shadow at the right and the bottom edge of the pages.
DesktopColor | Gets or sets the display color for the area around the pages.
HeaderFooterLabelColor | Gets or sets the display color for the label showing which header or footer is activated.
HeaderFooterLineColor | Gets or sets the display color for the dividing line between headers and footers and the main text.
LightShadowColor | Gets or sets the display color for the shadow at the left and the top edge of the pages.
PageBackColor | Gets or sets the display color for the page background.
TextBackColor | Gets or sets the background color for the text.
TextColor | Gets or sets the color for the text.

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors Constructor

Initializes a new instance of the WPF.TextControlColors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the WPF.TextControl.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public TextControlColors();
[Visual Basic]
Public Class TextControlColors

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.DarkShadowColor Property

Gets or sets the display color for the shadow at the right and the bottom edge of the pages.

Syntax

[C#]
public System.Windows.Media.Color DarkShadowColor { get; set; }
[Visual Basic]
Public Property DarkShadowColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.DesktopColor Property

Gets or sets the display color for the area around the pages.

Syntax

[C#]
public System.Windows.Media.Color DesktopColor { get; set; }
[Visual Basic]
Public Property DesktopColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.HeaderFooterLabelColor Property

Gets or sets the display color for the label showing which header or footer is activated.

Introduced: 19.0.

Syntax

[C#]
public System.Windows.Media.Color HeaderFooterLabelColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLabelColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.HeaderFooterLineColor Property

Gets or sets the display color for the dividing line between headers and footers and the main text.

Introduced: 19.0.

Syntax

[C#]
public System.Windows.Media.Color HeaderFooterLineColor { get; set; }
[Visual Basic]
Public Property HeaderFooterLineColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.LightShadowColor Property

Gets or sets the display color for the shadow at the left and the top edge of the pages.

Syntax

[C#]
public System.Windows.Media.Color LightShadowColor { get; set; }
[Visual Basic]
Public Property LightShadowColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.PageBackColor Property

Gets or sets the display color for the page background.

Syntax

[C#]
public System.Windows.Media.Color PageBackColor { get; set; }
[Visual Basic]
Public Property PageBackColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.TextBackColor Property

Gets or sets the background color for the text.

Syntax

[C#]
public System.Windows.Media.Color TextBackColor { get; set; }
[Visual Basic]
Public Property TextBackColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlColors.TextColor Property

Gets or sets the color for the text.

Syntax

[C#]
public System.Windows.Media.Color TextColor { get; set; }
[Visual Basic]
Public Property TextColor As System.Windows.Media.Color

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlDocument Class

An object of the WPF.TextControlDocument class represents a document and is part of the template of a WPF.TextControl. It is a System.Windows.Controls.Canvas element and its size is exactly the size of the document. The document is contained in a System.Windows.Controls.ScrollViewer which is responsible for displaying the document's visible part.

Introduced: 22.0.

Syntax

[C#]
public class TextControlDocument : System.Windows.Controls.Canvas
[Visual Basic]
Public Class TextControlDocument
  Inherits System.Windows.Controls.Canvas

Example

To obtain the TextControlDocument object in a WPF.TextControl the following code can be used:

[C#]
TextControlDocument document = textControl1.Template.FindName("TXPART_Document", textControl1) as TextControlDocument;
[Visual Basic]
Dim document As TextControlDocument = TryCast(textControl1.Template.FindName("TXPART_Document", textControl1), TextControlDocument)

See Also

  • Programming Category: Control Settings
  • Graphical Overview: Control Settings


TXTextControl.WPF.TextControlToolBar Class

The WPF.TextControlToolBar class is the base class of the WPF.RulerBar and the WPF.StatusBar classes. It is inherited from the System.Windows.Controls.Control class and implements a template which consists of a System.Windows.Controls.Border element and a WPF.TextControlToolBarPresenter.

Introduced: 22.0.

Syntax

[C#]
[TemplatePart(Name = "TXPART_Border", Type = typeof(Border))]
[TemplatePart(Name = "TXPART_ToolBarPresenter", Type = typeof(TextControlToolBarPresenter))]
public class TextControlToolBar : System.Windows.Controls.Control
[Visual Basic]
<TemplatePartAttribute(Name := "TXPART_Border", Type := GetType(Border))> _
<TemplatePartAttribute(Name := "TXPART_ToolBarPresenter", Type := GetType(TextControlToolBarPresenter))> _
Public Class TextControlToolBar _
  Inherits System.Windows.Controls.Control

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.TextControlToolBarPresenter Class

A WPF.TextControlToolBarPresenter object is part of the template of a WPF.TextControlToolBar. It is responsible for rendering the toolbar's content.

Introduced: 22.0.

Syntax

[C#]
public class TextControlToolBarPresenter : System.Windows.Controls.Canvas
[Visual Basic]
Public Class TextControlToolBarPresenter
  Inherits System.Windows.Controls.Canvas

See Also

  • Programming Category: Tool Bars
  • Graphical Overview: Tool Bars


TXTextControl.WPF.Drawing namespace

TXTextControl.WPF.Drawing.ShapesContextMenu Class

TXTextControl.WPF.Drawing.TXDrawingControl Class


TXTextControl.WPF.Drawing.ShapesContextMenu Class

The WPF.Drawing.ShapesContextMenu class represents the default context menu of the WPF TXDrawingControl.

Introduced: 23.0.

Syntax

[C#]
public class ShapesContextMenu : System.Windows.Controls.ContextMenu
[Visual Basic]
Public Class ShapesContextMenu
  Inherits System.Windows.Controls.ContextMenu

Properties

Property | Description
SelectedShapesMenuItems | Returns an array of System.Windows.Controls.Control objects that represents those items which are displayed in the context menu strip when the control is right clicked inside a shape.
StandardMenuItems | Returns an array of System.Windows.Controls.Control objects that represents those items which are displayed in the context menu strip when the control is right clicked outside a shape.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.ShapesContextMenu.SelectedShapesMenuItems Property

Returns an array of System.Windows.Controls.Control objects that represents those items which are displayed in the context menu strip when the control is right clicked inside a shape.

Syntax

[C#]
public System.Windows.Controls.Control[] SelectedShapesMenuItems{ get; set; }
[Visual Basic]
Public Property SelectedShapesMenuItems() As System.Windows.Controls.Control()

Default Values

Index 0: "Cut" (System.Windows.Controls.MenuItem)

Index 1: "Copy" (System.Windows.Controls.MenuItem)

Index 2: "Paste" (System.Windows.Controls.MenuItem)

Index 3: Separator (System.Windows.Controls.Separator)

Index 4: "Bring to Front" (System.Windows.Controls.MenuItem)

Index 5: "Send to Back" (System.Windows.Controls.MenuItem)

Index 6: "Flip" (System.Windows.Controls.MenuItem)

Index 7: Separator (System.Windows.Controls.Separator)

Index 8: "Movable" (System.Windows.Controls.MenuItem)

Index 9: "Sizable" (System.Windows.Controls.MenuItem)

Index 10: "Auto size" (System.Windows.Controls.MenuItem)

Index 11: "Fit to Canvas" (System.Windows.Controls.MenuItem)

Index 12: Separator (System.Windows.Controls.Separator)

Index 13: "Format..." (System.Windows.Controls.MenuItem)

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.ShapesContextMenu.StandardMenuItems Property

Returns an array of System.Windows.Controls.Control objects that represents those items which are displayed in the context menu strip when the control is right clicked outside a shape.

Syntax

[C#]
public System.Windows.Controls.ContextMenu[] StandardMenuItems{ get; set; }
[Visual Basic]
Public Property StandardMenuItems() As System.Windows.Controls.ContextMenu()

Default Values

Index 0: "Paste" (System.Windows.Controls.MenuItem)

Index 1: "Select All" (System.Windows.Controls.MenuItem)

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl Class

The WPF.TXDrawingControl class implements a WPF FrameworkElement with features to draw custom or predefined shapes. It can be added to a document with the WPF.TextControl.Drawings property. The WPF.TXDrawingControl class is inherited from the System.Windows.FrameworkElement class. The following describes only the properties, methods and events defined through the WPF.TXDrawingControl class. For a list of properties, methods and events inherited from the System.Windows.FrameworkElement class see the .NET Framework reference.

Introduced: 23.0.

Syntax

[C#]
public class TXDrawingControl : System.Windows.FrameworkElement
[Visual Basic]
Public Class TXDrawingControl
  Inherits System.Windows.FrameworkElement

Constructors

Constructor | Description
TXDrawingControl | Initializes a new instance of the TXDrawingControl class.

Properties

Property | Description
BackColor | Gets or sets the TX Drawing Control's back color.
BorderColor | Gets or sets the TX Drawing Control's border line color.The default value is null and represents the color System.Windows.SystemColors.WindowTextColor.
BorderWidth | Gets or sets the TX Drawing Control's border line width.
CanCopy | Informs whether shapes are selected which can be copied to the internal clipboard.
CanPaste | Informs whether the internal clipboard contains shapes that can be pasted into the TX Drawing Control.
CanRedo | Informs whether an operation can be re-done using the Redo method.
CanUndo | Gets a value indicating whether the user can undo the previous operation in the TX Drawing Control.
IsCanvasVisible | Gets a value whether the TX Drawing Control is interpreted as canvas or not.
Selection | Gets an object of type Drawing.Selection that represents the current selected shapes inside the TX Drawing Control.
Shapes | Gets an object of type ShapeCollection that represents those shapes which are displayed inside the TX Drawing Control.
ZoomFactor | Gets or sets the zoom factor, in percent, for the TX Drawing Control.

Methods

Method | Description
ClearUndo | Clears the undo buffer of the TX Drawing Control.
Copy | Copies the current selected shapes of the TX Drawing Control to the Clipboard.
Cut | Moves the current selected shapes of the TX Drawing Control to the Clipboard.
FormatShapesDialog | Opens a dialog to format selected shapes.
Load | Loads shapes data into the TX Drawing Control from a specified object of type System.IO.Stream.
Paste | Pastes the content of the clipboard into the TX Drawing Control
PrintPaint | Overloaded. Renders the displayed shapes on the specified System.Drawing.Graphics object.
Redo | Redoes the last TX Drawing Control operation.
Save | Saves the shapes data to the given object of type System.IO.Stream.
SaveImage | Overloaded. Saves the displayed shapes as an image.
SelectAll | Selects all shapes in the TX Drawing Control.
SetCanvasSize | Specifies, pursuant to a ZoomFactor value of 100, the height and width of the canvas.
SizeToContent | If any changes of the the displayed shapes' visible bounds require an adaption of the TX Drawing Control bounds, the size and/or location of the control is expanded respectively decreased by the considering value of the considering shape's side(s).
Undo | Undoes the last edit operation in the TX Drawing Control.

Events

Event | Description
AdaptBounds | Indicates that the visible bounds of the displayed shapes have been changed (by changing the shape's angle, outline width, yellow adjust rectangles or the control's border width) in so far that the control requires an update of its bounds.
Changed | Indicates that the number or formatting of the displayed shapes has been changed.
ShapeAdjusted | Occurs when a shape has been adjusted by using its yellow adjust rectangle.
ShapeClicked | Occurs when a shape has been clicked on.
ShapeCreated | Occurs when a new shape has been created.
ShapeDeleted | Occurs when a shape has been deleted from the TX Drawing Control's shapes collection.
ShapeDeselected | Occurs when a shape has been deselected.
ShapeFlipped | Occurs when a shape has been flipped.
ShapeFormatChanged | Occurs when shape formatting attributes which cannot be handled with the built-in mouse interface have been changed.
ShapeMoved | Occurs when a shape has been moved with the built-in mouse interface.
ShapeSelected | Occurs when a shape has been selected.
ShapeSized | Occurs when a shape has been sized with the built-in mouse interface.
ViewChanged | Occurs when UI manipulations such as shape moving or selection changing have caused the view to change.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl Constructor

Initializes a new instance of the TXDrawingControl class.

Syntax

[C#]
public TXDrawingControl();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.BackColor Property

Gets or sets the TX Drawing Control's back color. The default value is the color System.Windows.Media.Colors.Transparent. If the property is set to null the current System.Windows.SystemColors.WindowColor is used.

Syntax

[C#]
public System.Windows.Media.Color? BackColor{ get; set; }
[Visual Basic]
Public Property BackColor() As Nullable(Of System.Windows.Media.Color)

Limitations

A control's back color that differs to the default back color is only drawn if the control's IsCanvasVisible property return true. Otherwise the default value is used.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.BorderColor Property

Gets or sets the TX Drawing Control's border line color.The default value is null and represents the color System.Windows.SystemColors.WindowTextColor.

Syntax

[C#]
public System.Windows.Media.Color? BorderColor{ get; set; }
[Visual Basic]
Public Property BorderColor() As Nullable(Of System.Windows.Media.Color)

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.BorderWidth Property

Gets or sets the TX Drawing Control's border line width. The value is given in twips. The default value is 0.

Syntax

[C#]
public int BorderWidth{ get; set; }
[Visual Basic]
Public Property BorderWidth() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.CanCopy Property

Informs whether shapes are selected which can be copied to the internal clipboard.

Syntax

[C#]
public bool CanCopy{ get; }
[Visual Basic]
Public ReadOnly Property CanCopy() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.CanPaste Property

Informs whether the internal clipboard contains shapes that can be pasted into the TX Drawing Control.

Syntax

[C#]
public bool CanPaste{ get; }
[Visual Basic]
Public ReadOnly Property CanPaste() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.CanRedo Property

Informs whether an operation can be re-done using the Redo method.

Syntax

[C#]
public bool CanRedo { get; }
[Visual Basic]
Public ReadOnly Property CanRedo() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.CanUndo Property

Gets a value indicating whether the user can undo the previous operation in the TX Drawing Control.

Syntax

[C#]
public bool CanUndo { get; }
[Visual Basic]
Public ReadOnly Property CanUndo() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.IsCanvasVisible Property

Gets a value whether the TX Drawing Control is interpreted as canvas or not. The control is not interpreted as canvas if it contains only one shape, the shape's CanFitToCanvas property is set to false, its AutoSize property is set to true and the control's BorderWidth property is 0. If the property's value is false the control can be thought of as a representation of the containing shape where bounds changes of the control lead to considering changes of the shape and vise versa.

Syntax

[C#]
public bool IsCanvasVisible{ get; }
[Visual Basic]
Public ReadOnly Property IsCanvasVisible() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Selection Property

Gets an object of type Drawing.Selection that represents the current selected shapes inside the TX Drawing Control.

Syntax

[C#]
public Drawing.Selection Selection{ get; }
[Visual Basic]
Public ReadOnly Property Selection()) As Drawing.Selection

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Shapes Property

Gets an object of type ShapeCollection that represents those shapes which are displayed inside the TX Drawing Control.

Syntax

[C#]
public Drawing.ShapeCollection Shapes{ get; }
[Visual Basic]
Public ReadOnly Property Shapes()) As Drawing.ShapeCollection

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ZoomFactor Property

Gets or sets the zoom factor, in percent, for the TX Drawing Control. When the value is changed both all drawn shapes and the control itself are resized considering to the specified zoom factor. The default value is 100.

Syntax

[C#]
public int ZoomFactor{ get; set; }
[Visual Basic]
Public Property ZoomFactor() As Integer

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ClearUndo Method

Clears the undo buffer of the TX Drawing Control.

Syntax

[C#]
public void ClearUndo();
[Visual Basic]
Public Sub ClearUndo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Copy Method

Copies the current selected shapes of the TX Drawing Control to the Clipboard.

Syntax

[C#]
public void Copy();
[Visual Basic]
Public Sub Copy()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Cut Method

Moves the current selected shapes of the TX Drawing Control to the Clipboard.

Syntax

[C#]
public void Cut();
[Visual Basic]
Public Sub Cut()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.FormatShapesDialog Method

Opens a dialog to format selected shapes.

Syntax

[C#]
public bool? FormatShapesDialog();
[Visual Basic]
Public Function FormatShapesDialog() As Nullable(Of Boolean)

Return Value

The return value is true if the OK button was pressed, false if the dialog was cancelled and Null if the dialog was not opened because no shape to format was selected.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Load Method

Loads shapes data into the TX Drawing Control from a specified object of type System.IO.Stream.

Syntax

[C#]
public void Load(System.IO.Stream stream);
[Visual Basic]
Public Sub Load(ByVal stream As System.IO.Stream)
Parameter | Description
stream | Specifies an object of type System.IO.Stream the data is loaded from. The data is loaded from the stream's current position.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Paste Method

Pastes the content of the clipboard into the TX Drawing Control

Syntax

[C#]
public void Paste();
[Visual Basic]
Public Sub Paste()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.PrintPaint Method

Renders the displayed shapes on the specified System.Drawing.Graphics object.

PrintPaint(Graphics, Rectangle)

Renders only the displayed shapes on the specified System.Drawing.Graphics object. No activated UI elements are rendered.

[C#]
public void PrintPaint(System.Drawing.Graphics graphics, System.Drawing.Rectangle position);
[Visual Basic]
Public Sub PrintPaint(ByVal graphics As System.Drawing.Graphics, ByVal position As System.Drawing.Rectangle)
Parameter | Description
graphics | Specifies the object of type System.Drawing.Graphics the displayed shapes are rendered to.
position | Specifies the position to draw on the specified System.Drawing.Graphics object.

PrintPaint(Graphics, Rectangle, Boolean)

Renders the displayed shapes on the specified System.Drawing.Graphics object with or without activated UI elements.

[C#]
public void PrintPaint(System.Drawing.Graphics graphics, System.Drawing.Rectangle position, bool showUIElements);
[Visual Basic]
Public Sub PrintPaint(ByVal graphics As System.Drawing.Graphics, ByVal position As System.Drawing.Rectangle, ByVal showUIElements As Boolean)
Parameter | Description
graphics | Specifies the object of type System.Drawing.Graphics the displayed shapes are rendered to.
position | Specifies the position to draw on the specified System.Drawing.Graphics object.
showUIElements | Specifies whether the activated UI elements are rendered on the specified System.Drawing.Graphics object or not.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Redo Method

Redoes the last TX Drawing Control operation.

Syntax

[C#]
public void Redo();
[Visual Basic]
Public Sub Redo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Save Method

Saves the shapes data to the given object of type System.IO.Stream.

Syntax

[C#]
public void Save(System.IO.Stream stream);
[Visual Basic]
Public Sub Save(ByVal stream As System.IO.Stream)
Parameter | Description
stream | Specifies an object of type System.IO.Stream the data is saved to.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.SaveImage Method

Saves the displayed shapes as an image.

SaveImage(Stream, ImageFormat)

Saves the displayed shapes as an image to the specified object of type System.IO.Stream.

[C#]
public void SaveImage(System.IO.Stream imageStream, System.Drawing.Imaging.ImageFormat format);
[Visual Basic]
Public Sub SaveImage(ByVal imageStream As System.IO.Stream, ByVal format As System.Drawing.Imaging.ImageFormat)
Parameter | Description
imageStream | Specifies an object of type System.IO.Stream the image is saved to.
format | Specifies the format used to save the image.

SaveImage(String, ImageFormat)

Saves the displayed shapes as an image to the specified file using the specified format.

[C#]
public void SaveImage(string imageFileName, System.Drawing.Imaging.ImageFormat format);
[Visual Basic]
ublic Sub SaveImage(ByVal imageFileName As String, ByVal format As System.Drawing.Imaging.ImageFormat)
Parameter | Description
imageFileName | Specifies a file the image is saved to.
format | Specifies the format used to save the image.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.SelectAll Method

Selects all shapes in the TX Drawing Control.

Syntax

[C#]
public void SelectAll();
[Visual Basic]
Public Sub SelectAll()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.SetCanvasSize Method

Specifies, pursuant to a ZoomFactor value of 100, the height and width of the canvas. The parameters must be given in twips.

Syntax

[C#]
public void SetCanvasSize(double width, double height);
[Visual Basic]
Public Sub SetCanvasSize(ByVal width As Double, ByVal height As Double)
Parameter | Description
width | Specifies the width of the canvas.
height | Specifies the height of the canvas.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.SizeToContent Method

If any changes of the the displayed shapes' visible bounds require an adaption of the TX Drawing Control bounds, the size and/or location of the control is expanded respectively decreased by the considering value of the considering shape's side(s). The method returns an array of doubles which represent the effected alteration for each control's side (left, top, right, bottom) in twips.

Syntax

[C#]
public double[] SizeToContent();
[Visual Basic]
Public Sub SizeToContent() As Double()

Return Value

An array of doubles which represent the effected alteration for each control's side (left, top, right, bottom) in Twips.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Undo Method

Undoes the last edit operation in the TX Drawing Control.

Syntax

[C#]
public void Undo();
[Visual Basic]
Public Sub Undo()

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.AdaptBounds Event

Indicates that the visible bounds of the displayed shapes have been changed (by changing the shape's angle, outline width, yellow adjust rectangles or the control's border width) in so far that the control requires an update of its bounds. The event always raises if the visible bounds exceed the control's bounds. If IsCanvasVisible is false, AdaptBounds is also raised if considering changes lead to a decreasing of the visible shape bounds. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler AdaptBounds;
[Visual Basic]
Public Event AdaptBounds As EventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.Changed Event

Indicates that the number or formatting of the displayed shapes has been changed. The event handler receives an argument of type EventArgs containing data related to this event.

Syntax

[C#]
public event EventHandler Changed;
[Visual Basic]
Public Event Changed As EventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeAdjusted Event

Occurs when a shape has been adjusted by using its yellow adjust rectangle. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeAdjusted;
[Visual Basic]
Public Event ShapeAdjusted As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeClicked Event

Occurs when a shape has been clicked on. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeClicked;
[Visual Basic]
Public Event ShapeClicked As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeCreated Event

Occurs when a new shape has been created. It occurs, when a shape has been inserted in TX Drawing Control's shapes collection by pasting or using the shape collection's Add method. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeCreated;
[Visual Basic]
Public Event ShapeCreated As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeDeleted Event

Occurs when a shape has been deleted from the TX Drawing Control's shapes collection. It occurs by cutting or using the shape collection's Remove, RemoveAt or Clear method. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Introduced: 19.0.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeDeleted;
[Visual Basic]
Public Event ShapeDeleted As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeDeselected Event

Occurs when a shape has been deselected. It occurs by removing a shape from the WPF.TXDrawingControl.Selection.Shapes property or, if the number of selected shapes is greater than 0, clicking on a location inside the TX Drawing Control where no shape is located. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeDeselected;
[Visual Basic]
Public Event ShapeDeselected As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeFlipped Event

Occurs when a shape has been flipped. It occurs by using the shape's Flip property or sizing a shape manually by mouse in so far as the shape is flipped horizontally or vertically. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeFlipped;
[Visual Basic]
Public Event ShapeFlipped As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeFormatChanged Event

Occurs when shape formatting attributes which cannot be handled with the built-in mouse interface have been changed. The corresponding attributes are the shape's ShapeFill, ShapeOutline are Type properties. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeFormatChanged;
[Visual Basic]
Public Event ShapeFormatChanged As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeMoved Event

Occurs when a shape has been moved with the built-in mouse interface. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeMoved;
[Visual Basic]
Public Event ShapeMoved As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeSelected Event

Occurs when a shape has been selected. It occurs by using the select all method, changing the TXDrawingControl.Selection.Shapes property or selecting shapes manually by the built-in mouse interface . The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventHandler ShapeSelected;
[Visual Basic]
Public Event ShapeSelected As Drawing.ShapeEventHandler

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ShapeSized Event

Occurs when a shape has been sized with the built-in mouse interface. The event handler receives an argument of type ShapeEventArgs containing data related to this event.

Syntax

[C#]
public event Drawing.ShapeEventArgs ShapeSized;
[Visual Basic]
Public Event ShapeSized As Drawing.ShapeEventArgs

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.WPF.Drawing.TXDrawingControl.ViewChanged Event

Occurs when UI manipulations such as shape moving or selection changing have caused the view to change. The event handler receives an argument of type ViewChangedEventArgs containing data related to this event.

Syntax

[C#]
public event ViewChangedEventArgs ViewChanged;
[Visual Basic]
Public Event ViewChanged As ViewChangedEventArgs

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Web namespace

TXTextControl.Web.HeaderFooter Class

TXTextControl.Web.IFormattedText Class

TXTextControl.Web.MainText Class

TXTextControl.Web.Selection Class

TXTextControl.Web.TextControl Class

TXTextControl.Web.TextFrame Class

TXTextControl.Web.TextPart Class

TXTextControl.Web.TextPartCollection Class

Web Enumerations


TXTextControl.Web.HeaderFooter Class

An instance of the Web.HeaderFooter class represents a header or footer in a Text Control document. The Web.HeaderFooter class inherits from the Web.TextPart class.

Introduced: 22.0.

Syntax

[C#]
public class HeaderFooter : Web.TextPart
[Visual Basic]
Public class HeaderFooter
  Inherits Web.TextPart

Properties

Property | Description
Section | Returns the number of the section to which the header or footer belongs.
Selection | Gets or sets the current selection in a text part. (Inherited from Web.TextPart.)
Type | Gets the type of the header or footer.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.HeaderFooter.Section Property

Returns the number of the section to which the header or footer belongs. The sections of the document are numbered beginning with 1. This property returns zero, if the header or footer object does not represent a single header or footer.

Syntax

[C#]
public int Section { get; }
[Visual Basic]
Public ReadOnly Property Section() As Integer

Limitations

Read only.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.HeaderFooter.Type Property

Gets the type of the header or footer. It is a value of the Web.HeaderFooterType enumeration.

Syntax

[C#]
Web.HeaderFooterType Type { get; }
[Visual Basic]
Private ReadOnly Property Type() As Web.HeaderFooterType
Value | Description
Header | The object represents a header. When an even header exists the object represents the odd header. Otherwise it represents the header of all pages.
FirstPageHeader | The object represents a special header of the document's or section's first page.
Footer | The object represents a footer. When an even footer exists the object represents the odd footer. Otherwise it represents the footer of all pages.
FirstPageFooter | The object represents a special footer of the document's or section's first page.
EvenHeader | The object represents an even header.
EvenFooter | The object represents an even footer.

Limitations

Read only.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.IFormattedText Class

The Web.IFormattedText interface contains properties common to all text parts in a TX Text Control document. The following classes implement this interface: Web.TextPart.

Introduced: 22.0.

Syntax

[C#]
public interface IFormattedText
[Visual Basic]
Public Interface IFormattedText

Properties

Property | Description
Selection | Gets or sets the current selection.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.IFormattedText.Selection Property

Gets or sets the current selection. The property value is an object of the type Web.Selection. For more information see the description of the Web.Selection class.

Syntax

[C#]
public Web.Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Web.Selection

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.MainText Class

The Web.MainText class represents the main text of a TX Text Control document. The Web.MainText class inherits from the Web.TextPart class.

Introduced: 22.0.

Syntax

[C#]
public class MainText : Web.TextPart
[Visual Basic]
Public Class MainText
  Inherits Web.TextPart

Properties

Property | Description
Selection | Gets or sets the current selection in a text part. (Inherited from Web.TextPart.)

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection Class

The Web.Selection class describes and handles the position and length of a text selection. It also provides the possibility to replace the currently selected text with text in a certain document format.

Introduced: 22.0.

Syntax

[C#]
public class Selection
[Visual Basic]
Public Class Selection

Constructors

Constructor | Description
Selection | Overloaded. Creates a new instance of the Web.Selection class.

Properties

Property | Description
Length | Returns the number of characters selected.
Start | Gets the starting point of selected text.

Methods

Method | Description
Load | Overloaded. Exchanges the currently selected text with text in a certain format.
Save | Overloaded. Saves the selected text of a document with the specified format.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection Constructor

Creates a new instance of the Web.Selection class.

Selection()

Creates an empty Selection object with all properties set to their default values.

[C#]
public Selection();
[Visual Basic]
Public Sub New()

Selection(Int32, Int32)

Creates an instance of the Web.Selection class with the specified start value and length.

[C#]
public Selection(int start, int length);
[Visual Basic]
public New(ByVal start As Integer, ByVal length As Integer)
Parameter | Description
start | Specifies the selection's start position.
length | Specifies the number of selected characters.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection.Start Property

Gets the starting point of selected text. The first possible position is 0.

Syntax

[C#]
public int Start { get; }
[Visual Basic]
Public ReadOnly Property Start() As Integer

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection.Length Property

Returns the number of characters selected. If this property is zero, no text is selected and the Start property determines the current text input position.

Syntax

[C#]
public int Length { get; }
[Visual Basic]
Public ReadOnly Property Length() As Integer

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection.Load Method

Exchanges the currently selected text with text in a certain format.

Load(String, StreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file.

[C#]
public void Load(string path, Web.StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path As String, ByVal streamType As Web.StreamType)
Member | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

Load(FileStream, StreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified file stream.

[C#]
public void Load(System.IO.FileStream fileStream, Web.StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal fileStream As System.IO.FileStream, ByVal streamType As Web.StreamType)
Member | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

Load(Byte[], BinaryStreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified byte array.

[C#]
public void Load(byte[] binaryData, Web.BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub Load(ByVal binaryData As Byte(), ByVal binaryStreamType As Web.BinaryStreamType)
Member | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

Load(String, StringStreamType)

Exchanges the currently selected text with text in the specified format. The new text is read from the specified string.

[C#]
public void Load(string stringData, Web.StringStreamType stringStreamType);
[Visual Basic]
Public Sub Load(ByVal stringData As String, ByVal stringStreamType As Web.StringStreamType)
Member | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.Selection.Save Method

Saves the selected text of a document with the specified format.

Save(String, StreamType)

Saves the selected text of a document in the specified file with the specified format.

[C#]
public void Save(string path, Web.StreamType streamType);
[Visual Basic]
Public Sub Load(ByVal path as String, ByVal streamType as Web.StreamType)
Member | Description
path | Saves the selected text of a document in the specified file with the specified format.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the BinaryStreamType values.
streamType | Specifies one of the StringStreamType values.

Save(FileStream, StreamType)

Saves the selected text of a document in the specified file stream with the specified format.

[C#]
public void Save(System.IO.FileStream fileStream, Web.StreamType streamType);
[Visual Basic]
Public Sub Save(ByVal fileStream As System.IO.FileStream, ByVal streamType As Web.StreamType)
Member | Description
fileStream | Specifies a file into which the selection is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the BinaryStreamType values.
streamType | Specifies one of the StringStreamType values.

Save(Byte[], BinaryStreamType)

Saves the selected text of a document in the specified byte array with the specified format.

[C#]
public void Save(out byte[] data, Web.BinaryStreamType streamType);
[Visual Basic]
Public Sub Save(ByRef data As Byte(), ByVal streamType As Web.BinaryStreamType)
Member | Description
data | Specifies a byte array into which the selection is saved. No memory needs to be allocated through the caller.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the BinaryStreamType values.
streamType | Specifies one of the StringStreamType values.

Save(String, StringStreamType)

Saves the selected text of a document as a string with the specified format.

[C#]
public void Save(out string stringData, Web.StringStreamType streamType);
[Visual Basic]
Public Sub Save(ByRef stringData As String, ByVal streamType As Web.StringStreamType)
Member | Description
stringData | Specifies a string into which the selection is saved. No memory needs to be allocated through the caller.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the StreamType values.
streamType | Specifies one of the BinaryStreamType values.
streamType | Specifies one of the StringStreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl Class

The TextControl class implements a control with high-level text editing features. It is inherited from the System.Web.UI.WebControls.WebControl class. The following describes only the properties, methods and events defined through the TextControl class. For a list of properties, methods and events inherited from the System.Web.UI.WebControls.WebControl class see the .NET Framework reference.

Introduced: 21.0.

Syntax

[C#]
public class TextControl : WebControl
[Visual Basic]
Public Class TextControl
  Inherits WebControl

Constructors

Constructor | Description
TextControl | Initializes a new instance of the TextControl class.

Properties

Property | Description
BackColor | Specifies or returns the background color of the main text area and the ruler bars.
ContextMenusEnabled | Specifies or returns a value indicating if a right click opens a context menu or not.
ControlChars | Specifies if control characters are visible or not.
Culture | Gets or sets the control's culture.
Dock | Gets or sets a value how the control is docked to its container or web site.
DocumentTargetMarkers | Specifies or returns a value indicating if markers for hypertext targets are shown in the editor or not.
EditMode | Specifies or returns a value of type Web.EditMode indicating whether the document's text is read-only, can be selected or is editable.
FormattingPrinter | Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document.
IsReady | Gets a value indicating whether all TX Text Control components are completely loaded in the service's worker process.
SaveDocumentQuestionDialogEnabled | Specifies or returns a value indicating if a confirmation dialog should be shown before discarding unsaved changes.
Selection | Gets or sets the current selection in the text part with the input focus.
ServiceAddress | Gets or sets the IP address at which the websocket handler tries to connect to the Service.
ServicePort | Gets or sets the Port at which the websocket handler tries to connect to the Service.
StatusBarColor | Specifies or returns the background color of the status bar.
TableGridLines | Specifies or returns a value indicating wether table grid lines are shown in the editor or not.
TextFieldsEditable | Gets or sets if text fields are editable or not.
TextFrameMarkerLines | Specifies whether text frames that have no border line are shown with marker lines.
TextParts | Gets a collection of all text parts the current document contains.
UICulture | Gets or sets the control's user interface culture.
WebSocketHandlerPath | Specifies the path to the WebSocket handler (TXWebSocketHandler.ashx).

Methods

Method | Description
GetFileDirectory | Returns the directory path where the files of a specific file type are stored.
GetFileDirectoryAsync | Returns the directory path where the files of a specific file type are stored.
LoadDataFromJson | Uses data given as a JSON string as a data source.
LoadDataFromJsonAsync | Uses data given as a JSON string as a data source.
LoadDataFromModel | Overloaded. Loads a collection implementing interface System.Collections.IEnumerable as a data source.
LoadDataFromModelAsync | Overloaded. Loads a collection implementing interface System.Collections.IEnumerable as a data source.
LoadDataSet | Loads a database which is used to create table and field name menu items in the mailings ribbon tab from an existing DataSet object.
LoadDataSetAsync | Loads a database which is used to create table and field name menu items in the mailings ribbon tab from an existing DataSet object.
LoadText | Overloaded. Loads text in a certain format.
LoadTextAsync | Overloaded. Loads text in a certain format.
LoadXMLDatabase | Overloaded. Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.
LoadXMLDatabaseAsync | Overloaded. Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.
ResetContents | Deletes the entire contents of the control.
SaveText | Overloaded. Saves the complete contents of a document with the specified format.
SetFileDirectory | Determines the directory path where the files of a specific file type are stored.
SetFileDirectoryAsync | Determines the directory path where the files of a specific file type are stored.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl Constructor

Initializes a new instance of the TextControl class.

Syntax

[C#]
public TextControl();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.BackColor Property

Specifies or returns the background color of the main text area and the ruler bars.

Introduced: 22.0.

Syntax

[C#]
public System.Drawing.Color Backcolor { get; set; }
[Visual Basic]
Public Property BackColor() As System.Drawing.Color

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.ContextMenusEnabled Property

Specifies or returns a value indicating if a right click opens a context menu or not.

Introduced: 22.0.

Syntax

[C#]
public bool ContextMenusEnabled { get; set; }
[Visual Basic]
Public Property ContextMenusEnabled() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.ControlChars Property

Specifies if control characters are visible or not.

Introduced: 22.0.

Syntax

[C#]
public bool ControlChars { get; set; }
[Visual Basic]
Public Property ControlChars() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.Culture Property

Gets or sets the control's culture. Affects date and time string formats, for example.

Introduced: 23.0.

Syntax

[C#]
public System.Globalization.CultureInfo Culture { get; set; }
[Visual Basic]
Public Property Culture() As System.Globalization.CultureInfo

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.Dock Property

Gets or sets a value how the control is docked to its container or web site.

Syntax

[C#]
public Web.DockStyle Dock { get; set; }
[Visual Basic]
Public Property Dock() As Web.DockStyle

See Also

  • Web.DockStyle Enumeration
  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.DocumentTargetMarkers Property

Specifies or returns a value indicating if markers for hypertext targets are shown in the editor or not.

Introduced: 22.0.

Syntax

[C#]
public bool DocumentTargetMarkers { get; set; }
[Visual Basic]
Public Property DocumentTargetMarkers() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.EditMode Property

Specifies or returns a value of type Web.EditMode indicating whether the document's text is read-only, can be selected or is editable.

Introduced: 22.0.

Syntax

[C#]
public Web.EditMode EditMode { get; set; }
[Visual Basic]
Public Property EditMode() As Web.EditMode

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.FormattingPrinter Property

Gets or sets the name of a printer the text dimensions and capabilities of which are used to format the document. If the document is printed with this printer the displayed and the printed document have the same dimensions. If the property is set to Standard, the system installed standard printer is used to format the document. If the property is set to Display, the font dimensions of the display device are used to format the document. If the specified printer is not installed, the standard printer is used.

Introduced: 23.0.

Syntax

[C#]
public string FormattingPrinter { get; set; }
[Visual Basic]
Public Property FormattingPrinter() As String

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.GetFileDirectory Method

Returns the directory path where the files of a specific file type are stored.

Syntax

[C#]
public string GetFileDirectory(Web.FileType type);
[Visual Basic]
Public Function GetFileDirectory(ByVal type As Web.FileType) As String
Parameter | Description
type | Specifies one of the FileType values.

Return Value

Returns the directory path where the files of a specific file type are stored. The return value is null, if no directory path was specified.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.GetFileDirectoryAsync Method

Returns the directory path where the files of a specific file type are stored.

Syntax

[C#]
public async System.Threading.Tasks.Task<string> GetFileDirectoryAsync(Web.FileType type);
[Visual Basic]
Public Async Function GetFileDirectoryAsync(ByVal type As Web.FileType) As System.Threading.Tasks.Task(Of String)
Parameter | Description
type | Specifies one of the FileType values.

Return Value

Returns a System.Threading.Tasks.Task object containing the directory path where the files of a specific file type are stored. The return value is null, if no directory path was specified.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.IsReady Property

Gets a value indicating whether all TX Text Control components are completely loaded in the service's worker process.

Syntax

[C#]
public bool IsReady { get; }
[Visual Basic]
Public ReadOnly Property IsReady() As Boolean

Limitations

Read only.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataFromJson Method

Uses data given as a JSON string as a data source. The JSON string has to contain an array of equally structured objects. Analyzes and uses the given objects as merge data in the same way as the method LoadDataFromModel.

Introduced: 24.0.

Syntax

[C#]
public void LoadDataFromJson(string json);
[Visual Basic]
Public Sub LoadDataFromJson(json As String)
Parameter | Description
json | The JSON string containing the merge data.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataFromJsonAsync Method

Uses data given as a JSON string as a data source. The JSON string has to contain an array of equally structured objects. Analyzes and uses the given objects as merge data in the same way as the method LoadDataFromModel. The method returns immediately.

Introduced: 24.0.

Syntax

[C#]
public async System.Threading.Tasks.Task LoadDataFromJsonAsync(string json);
[Visual Basic]
Public Async Function LoadDataFromJsonAsync(json As String) As System.Threading.Tasks.Task
Parameter | Description
json | The JSON string containing the merge data.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataFromModel Method

Loads a collection implementing interface System.Collections.IEnumerable as a data source.

Introduced: 24.0.

LoadDataFromModel(IEnumerable)

Interprets all public properties of the objects in the collection as possible table columns and / or child tables. The type of the first object in the collection is analyzed via .NET reflection and used as the basis of the assumed table structure. For more information about using object based data sources see DocumentServer.MailMerge.MergeObjects. The method returns immediately.

[C#]
public void LoadDataFromModel(System.Collections.IEnumerable model);
[Visual Basic]
Public Sub LoadDataFromModel(model As System.Collections.IEnumerable)
Parameter | Description
model | Specifies a System.Collections.IEnumerable that contains the merge data.

LoadDataFromModel(IEnumerable, IFormatProvider)

Allows to additionally specify a format which should be applied when converting date / time values and numerical values to strings.

[C#]
public void LoadDataFromModel(System.Collections.IEnumerable model, System.IFormatProvider numberAndDateTimeFormat);
[Visual Basic]
Public Sub LoadDataFromModel(model As System.Collections.IEnumerable, numberAndDateTimeFormat As System.IFormatProvider)
Parameter | Description
model | Specifies a System.Collections.IEnumerable that contains the merge data.
numberAndDateTimeFormat | The format which should be applied when converting date / time values and numerical values to strings.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataFromModelAsync Method

Loads a collection implementing interface System.Collections.IEnumerable as a data source.

Introduced: 24.0.

LoadDataFromModelAsync(IEnumerable)

Interprets all public properties of the objects in the collection as possible table columns and / or child tables. The type of the first object in the collection is analyzed via .NET reflection and used as the basis of the assumed table structure. For more information about using object based data sources see DocumentServer.MailMerge.MergeObjects. The method returns immediately.

[C#]
public async System.Threading.Tasks.Task LoadDataFromModelAsync(System.Collections.IEnumerable model);
[Visual Basic]
Public Async Function LoadDataFromModelAsync(model As System.Collections.IEnumerable) As System.Threading.Tasks.Task
Parameter | Description
model | Specifies a System.Collections.IEnumerable that contains the merge data.

LoadDataFromModelAsync(IEnumerable, IFormatProvider)

Allows to additionally specify a format which should be applied when converting date / time values and numerical values to strings.

[C#]
public async System.Threading.Tasks.Task LoadDataFromModelAsync(System.Collections.IEnumerable model, System.IFormatProvider numberAndDateTimeFormat);
[Visual Basic]
Public Async Function LoadDataFromModelAsync(model As System.Collections.IEnumerable, numberAndDateTimeFormat As System.IFormatProvider) As System.Threading.Tasks.Task
Parameter | Description
model | Specifies a System.Collections.IEnumerable that contains the merge data.
numberAndDateTimeFormat | The format which should be applied when converting date / time values and numerical values to strings.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataSet Method

Loads a database which is used to create table and field name menu items in the mailings ribbon tab from an existing DataSet object.

Syntax

[C#]
public void LoadDataSet(System.Data.DataSet dataSet);
[Visual Basic]
Public Sub LoadDataSet(dataSet As System.Data.DataSet)
Parameter | Description
dataSet | Specifies a System.Data.DataSet object from which table and field names and existing data relations are loaded.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadDataSetAsync Method

Loads a database which is used to create table and field name menu items in the mailings ribbon tab from an existing DataSet object. This method returns immediately and does not wait for the DataSet to be loaded completely.

Syntax

[C#]
public async System.Threading.Tasks.Task LoadDataSetAsync(System.Data.DataSet dataSet);
[Visual Basic]
Public Async Function LoadDataSetAsync(dataSet As System.Data.DataSet) As System.Threading.Tasks.Task
Parameter | Description
dataSet | Specifies a System.Data.DataSet object from which table and field names and existing data relations are loaded.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadText Method

Loads text in a certain format. The complete contents of a TextControl are replaced.

LoadText(String, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file.

[C#]
public void LoadText(string path, Web.StreamType streamType);
[Visual Basic]
Public Sub LoadText(ByVal path As String, ByVal streamType As Web.StreamType)
Parameter | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

LoadText(FileStream, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file stream.

[C#]
public void LoadText(System.IO.FileStream fileStream, Web.StreamType streamType);
[Visual Basic]
Public Sub LoadText(ByVal fileStream As System.IO.FileStream, ByVal streamType As Web.StreamType)
Parameter | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

LoadText(Byte[], BinaryStreamType)

Loads text formatted with the specified format. The new text is read from the specified byte array.

[C#]
public void LoadText(byte[] binaryData, Web.BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub LoadText(ByVal binaryData As Byte(), ByVal binaryStreamType As Web.BinaryStreamType)
Parameter | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

LoadText(String, StringStreamType)

Loads text formatted with the specified format. The new text is read from the specified string.

[C#]
public void LoadText(string stringData, Web.StringStreamType stringStreamType);
[Visual Basic]
Public Sub LoadText(ByVal stringData As String, ByVal stringStreamType As Web.StringStreamType)
Parameter | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadTextAsync Method

Loads text in a certain format. The complete contents of a Text Control are replaced. This method returns immediately and does not wait for the text to be completely loaded.

LoadTextAsync(String, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file.

[C#]
public async System.Threading.Tasks.Task LoadTextAsync(string path,  Web.StreamType streamType);
[Visual Basic]
Public Async Function LoadTextAsync(ByVal path As String, ByVal streamType As  Web.StreamType) As System.Threading.Tasks.Task
Parameter | Description
path | Specifies a file from which the data is loaded.
streamType | Specifies one of the StreamType values.

LoadTextAsync(FileStream, StreamType)

Loads text formatted with the specified format. The new text is read from the specified file stream.

[C#]
public async System.Threading.Tasks.Task LoadTextAsync(System.IO.FileStream fileStream, Web.StreamType streamType);
[Visual Basic]
Public Async Function LoadTextAsync(ByVal fileStream As System.IO.FileStream, ByVal streamType As  Web.StreamType) As System.Threading.Tasks.Task
Parameter | Description
fileStream | Specifies a file from which the data is loaded. The data is loaded from the stream's current position.
streamType | Specifies one of the StreamType values.

LoadTextAsync(Byte[], BinaryStreamType)

Loads text formatted with the specified format. The new text is read from the specified byte array.

[C#]
public async System.Threading.Tasks.Task LoadTextAsync(byte[] binaryData, Web.BinaryStreamType binaryStreamType);
[Visual Basic]
Public Async Function LoadTextAsync(ByVal binaryData As Byte(), ByVal binaryStreamType As Web.BinaryStreamType) As System.Threading.Tasks.Task
Parameter | Description
binaryData | Specifies a byte array from which the data is loaded.
binaryStreamType | Specifies one of the BinaryStreamType values.

LoadTextAsync(String, StringStreamType)

Loads text formatted with the specified format. The new text is read from the specified string.

[C#]
public async System.Threading.Tasks.Task LoadTextAsync(string stringData,  Web.StringStreamType stringStreamType);
[Visual Basic]
Public Async Function LoadTextAsync(ByVal stringData As String, ByVal stringStreamType As  Web.StringStreamType) As System.Threading.Tasks.Task
Parameter | Description
stringData | Specifies a string from which the data is loaded.
stringStreamType | Specifies one of the StringStreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadXMLDatabase Method

Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab.

LoadXMLDatabase(String)

Loads an XML database from a file.

[C#]
public void LoadXMLDatabase(string fileName);
[Visual Basic]
Public Sub LoadXMLDatabase(ByVal fileName as String)
Parameter | Description
fileName | Specifies an xml file from which the database is loaded.

LoadXMLDatabase(XmlDocument)

Loads an XML database from an XmlDocument object.

[C#]
public void LoadXMLDatabase(System.Xml.XmlDocument xmlDocument);
[Visual Basic]
Public Sub LoadXMLDatabase(ByVal xmlDocument as System.Xml.XmlDocument)
Parameter | Description
xmlDocument | Specifies an XmlDocument object from which the database is loaded.

LoadXMLDatabase(FileStream)

Loads an XML database from a file stream.

[C#]
public void LoadXMLDatabase(System.IO.FileStream fileStream);
[Visual Basic]
Public Sub LoadXMLDatabase(ByVal fileStream as System.IO.FileStream)
Parameter | Description
fileStream | Specifies an xml file from which the database is loaded. The data is loaded from the stream's current position.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.LoadXMLDatabaseAsync Method

Loads an XML database which is used to create table and field name menu items in the mailings ribbon tab. The method returns immediately and does not wait for the database to be completely loaded.

LoadXMLDatabaseAsync(String)

Loads an XML database from a file.

[C#]
public async System.Threading.Tasks.Task LoadXMLDatabaseAsync(string fileName);
[Visual Basic]
Public Async Function LoadXMLDatabaseAsync(ByVal fileName as String) As System.Threading.Tasks.Task
Parameter | Description
fileName | Specifies an xml file from which the database is loaded.

LoadXMLDatabaseAsync(XmlDocument)

Loads an XML database from an XmlDocument object.

[C#]
public async System.Threading.Tasks.Task LoadXMLDatabaseAsync(System.Xml.XmlDocument xmlDocument);
[Visual Basic]
Public Async Function LoadXMLDatabaseAsync(ByVal xmlDocument as System.Xml.XmlDocument) As System.Threading.Tasks.Task
Parameter | Description
xmlDocument | Specifies an XmlDocument object from which the database is loaded.

LoadXMLDatabaseAsync(FileStream)

Loads an XML database from a file stream.

[C#]
public async System.Threading.Tasks.Task LoadXMLDatabaseAsync(System.IO.FileStream fileStream);
[Visual Basic]
Public Async Function LoadXMLDatabaseAsync(ByVal fileStream as System.IO.FileStream) As System.Threading.Tasks.Task
Parameter | Description
fileStream | Specifies an xml file from which the database is loaded. The data is loaded from the stream's current position.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.ResetContents Method

Deletes the entire contents of the control.

Introduced: 23.0.

Syntax

[C#]
public void ResetContents();
[Visual Basic]
Public Sub ResetContents()

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.SaveDocumentQuestionDialogEnabled Property

Specifies or returns a value indicating if a confirmation dialog should be shown before discarding unsaved changes.

Introduced: 22.0.

Syntax

[C#]
public bool SaveDocumentQuestionDialogEnabled { get; set; }
[Visual Basic]
Public Property SaveDocumentQuestionDialogEnabled() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.SaveText Method

Saves the complete contents of a document with the specified format.

SaveText(String, StreamType)

Saves the complete contents of a document in the specified file with the specified format.

[C#]
public void SaveText(string path,  Web.StreamType streamType);
[Visual Basic]
Public Sub SaveText(ByVal path As String, ByVal streamType As  Web.StreamType)
Parameter | Description
path | Specifies a file into which the data is saved. If the file does not exist it is created. If the file exists its contents are overwritten.
streamType | Specifies one of the StreamType values.

SaveText(FileStream, StreamType)

Saves the complete contents of a document in the specified file stream with the specified format.

[C#]
public void SaveText(System.IO.FileStream fileStream,  Web.StreamType streamType);
[Visual Basic]
Public Sub SaveText(ByVal fileStream As System.IO.FileStream, ByVal streamType As  Web.StreamType)
Parameter | Description
fileStream | Specifies a file into which the data is saved. The data is saved at the stream's current position.
streamType | Specifies one of the StreamType values.

SaveText(Byte[], BinaryStreamType)

Saves the complete contents of a document in the specified byte array with the specified format.

[C#]
public void SaveText(out byte[] binaryData, Web.BinaryStreamType binaryStreamType);
[Visual Basic]
Public Sub SaveText(ByRef binaryData As Byte(), ByVal binaryStreamType As Web.BinaryStreamType)
Parameter | Description
binaryData | Specifies a byte array into which the data is saved. No memory needs to be allocated through the caller.
binaryStreamType | Specifies one of the BinaryStreamType values.

SaveText(String, StringStreamType)

Saves the complete contents of a document as a string with the specified format.

[C#]
public void SaveText(out string stringData, Web.StringStreamType stringStreamType);
[Visual Basic]
Public Sub SaveText(ByRef stringData As String, ByVal stringStreamType As Web.StringStreamType)
Parameter | Description
stringData | Specifies a string into which the data is saved. No memory needs to be allocated through the caller.
stringStreamType | Specifies one of the StringStreamType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.Selection Property

Gets or sets the current selection in the text part with the input focus. The property value is an object of the type Web.Selection.

Introduced: 22.0.

Syntax

[C#]
public TXTextControl.Web.Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As TXTextControl.Web.Selection

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.ServiceAddress Property

Gets or sets the IP address at which the websocket handler tries to connect to the Service. The default value is 127.0.0.1 (the local computer). Important: setting this property affects all instances of class Web.TextControl. It was not made static so it shows up in the Visual Studio designer.

Introduced: 23.0.

Syntax

[C#]
public System.Net.IPAddress ServiceAddress { get; set; }
[Visual Basic]
Public Property ServiceAddress() As System.Net.IPAddress

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.ServicePort Property

Gets or sets the Port at which the websocket handler tries to connect to the Service. Important: setting this property affects all instances of class Web.TextControl. It was not made static so it shows up in the Visual Studio designer.

Introduced: 23.0.

Syntax

[C#]
public int ServicePort { get; set; }
[Visual Basic]
Public Property ServicePort() As Integer

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.SetFileDirectory Method

Determines the directory path where the files of a specific file type are stored.

Syntax

[C#]
public void SetFileDirectory(string directory, Web.FileType type);
[Visual Basic]
Public Sub SetFileDirectory(ByVal directory As String, ByVal type As Web.FileType)
Parameter | Description
directory | Specifies the directory path where the files of a specific file type are stored.
type | Specifies one of the FileType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.SetFileDirectoryAsync Method

Determines the directory path where the files of a specific file type are stored.

Syntax

[C#]
public async System.Threading.Tasks.Task SetFileDirectory(string directory, Web.FileType type);
[Visual Basic]
Public Async Function SetFileDirectory(ByVal directory As String, ByVal type As Web.FileType) As System.Threading.Tasks.Task
Parameter | Description
directory | Specifies the directory path where the files of a specific file type are stored.
type | Specifies one of the FileType values.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.StatusBarColor Property

Specifies or returns the background color of the status bar.

Introduced: 22.0.

Syntax

[C#]
public System.Drawing.Color StatusBarColor { get; set; }
[Visual Basic]
Public Property StatusBarColor() As System.Drawing.Color

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.TableGridLines Property

Specifies or returns a value indicating wether table grid lines are shown in the editor or not.

Introduced: 22.0.

Syntax

[C#]
public bool TableGridLines { get; set; }
[Visual Basic]
Public Property TableGridLines() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.TextFieldsEditable Property

Gets or sets if text fields are editable or not.

Introduced: 22.0.

Syntax

[C#]
public bool TextFieldsEditable { get; set; }
[Visual Basic]
Public Property TextFieldsEditable() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.TextFrameMarkerLines Property

Specifies whether text frames that have no border line are shown with marker lines.

Introduced: 22.0.

Syntax

[C#]
public bool TextFrameMarkerLines { get; set; }
[Visual Basic]
Public Property TextFrameMarkerLines() As Boolean

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.TextParts Property

Gets a collection of all text parts the current document contains. The property's value is an object of the type Web.TextPartCollection. A text part can be the main text, a text frame or a header or footer.

Introduced: 22.0.

Syntax

[C#]
public Web.TextPartCollection TextParts { get; }
[Visual Basic]
Public ReadOnly Property TextParts() As Web.TextPartCollection

Limitations

Runtime only.

Read only.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.UICulture Property

Gets or sets the control's user interface culture. Affects the string resource language.

Introduced: 23.0.

Syntax

[C#]
public System.Globalization.CultureInfo UICulture { get; set; }
[Visual Basic]
Public Property UICulture() As System.Globalization.CultureInfo

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextControl.WebSocketHandlerPath Property

Specifies the path to the WebSocket handler (TXWebSocketHandler.ashx). If set to null (the default value) or an empty string, the browser derives the WebSocket handler URL from the current page's URL. This property sets the portion of the path BETWEEN the web site root and the handler-ashx-file (e. g. "/foo/bar/" in case of the handler listening at ws://www.website.com/foo/bar/TXWebSocketHandler.ashx). In most cases this property doesn't need to be set and the browser generated URL works fine. However, if the web control is used in an ASP.Net MVC application and the web page containing the editor resides in a virtual directory, the WebSocket handler URL generated by the browser will be invalid. This makes it impossible for the web app to connect to the web server. Use this property to correct the WebSocket handler URL in that case. Absolute (e. g. "/editor/") and relative directories (e. g. "../../") are possible.

Introduced: 22.0.

Syntax

[C#]
public string WebSocketHandlerPath { get; set; }
[Visual Basic]
Public Property WebSocketHandlerPath() As String

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextFrame Class

An instance of the Web.TextFrame class represents a text frame in a Text Control document. A text frame is a rectangle that can be filled with text through an end-user and that can be edited like the main text. The Web.TextFrame class inherits from the Web.TextPart class.

Introduced: 22.0.

Syntax

[C#]
public class TextFrame : Web.TextPart
[Visual Basic]
Public Class TextFrame
  Inherits Web.TextPart

Properties

Property | Description
Selection | Gets or sets the current selection in a text part. (Inherited from Web.TextPart.)

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextPart Class

The Web.TextPart class implements the Web.IFormattedText interface as well as public properties and internal functionality common to all text parts in a TX Text Control document. The following classes inherit from this class: Web.MainText, Web.HeaderFooter and Web.TextFrame.

Introduced: 22.0.

Syntax

[C#]
public class TextPart : Web.IFormattedText
[Visual Basic]
Public Class TextPart
  Inherits Web.IFormattedText

Properties

Property | Description
Selection | Gets or sets the current selection in a text part.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextPart.Selection Property

Gets or sets the current selection in a text part. The property value is an object of the type Web.Selection. For more information see the description of the Web.Selection class.

Syntax

[C#]
public Web.Selection Selection { get; set; }
[Visual Basic]
Public Property Selection() As Web.Selection

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextPartCollection Class

An instance of the Web.TextPartCollection class contains all text parts in a TX Text Control document. A text part can either be the document's main text, a text frame or a header or footer. A text frame is represented through a Web.TextFrame object, a header or footer through a Web.HeaderFooter object and the document's main text is represented through a Web.MainText object. A Web.TextPartCollection object contains all these objects in a geometric order. The first object in the collection is the main text, followed by all text frames in geometric order. At the end of the collection all headers and footers are contained also geometrically ordered. All objects in a text part collection implement the Web.IFormattedText interface. The collection can be obtained with the Web.TextControl.TextParts property. The Web.TextPartCollection class implements the interface ICollection<Web.IFormattedText>.

Introduced: 22.0.

Syntax

[C#]
public class TextPartCollection : ICollection<Web.IFormattedText>
[Visual Basic]
Public Class TextPartCollection
  Inherits ICollection(Of Web.IFormattedText)

Methods

Method | Description
Activate | Sets the input focus to the specified text part.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


TXTextControl.Web.TextPartCollection.Activate Method

Sets the input focus to the specified text part. If the activated text part is not in the visible part of the document, the document is scrolled.

Syntax

[C#]
public bool Activate(Web.IFormattedText textPart);
[Visual Basic]
Public Function Activate(TextPart As Web.IFormattedText) As Boolean
Parameter | Description
textPart | Specifies the text part to activate. Must be an object of the type Web.MainText, Web.TextFrame or Web.HeaderFooter.

Return Value

The return value is true, if the specified text part could be activated. Otherwise it is false.

See Also

  • Programming Category: Web Editor
  • Graphical Overview: Web Editor


Web Enumerations

TXTextControl.Web.BinaryStreamType Enumeration

TXTextControl.Web.DockStyle Enumeration

TXTextControl.Web.FileType Enumeration

TXTextControl.Web.StreamType Enumeration

TXTextControl.Web.StringStreamType Enumeration

TXTextControl.Web.EditMode Enumeration

TXTextControl.Web.HeaderFooterType Enumeration


TXTextControl.Web.BinaryStreamType Enumeration

Determines a certain text format that must tbe stored in a one-dimensional byte array. The enumeration contains the following values:

Member | Description
AdobePDF | Specifies Adobe Portable Document Format (PDF). If a document is loaded, only the text is imported.
AdobePDFA | Specifies Adobe Portable Document Format Archive (PDF/A). This format can only be used in saving operations.
InternalFormat | Specifies the internal Text Control format. Text is stored in ANSI format.
InternalUnicodeFormat | Specifies the internal Text Control format. Text is stored in Unicode format.
MSWord | Specifies Microsoft Word format.
WordprocessingML | Specifies Microsoft Word format (Office Open XML version).

See Also

  • Web.TextControl.LoadText Method
  • Web.TextControl.SaveText Method


TXTextControl.Web.DockStyle Enumeration

Specifies the manner in which a Web.TextControl is docked. The enumeration contains the following values:

Member | Description
Fill | All the control's edges are docked to the all edges of its container and sized appropriately.
None | The control is not docked.
Window | The control fills the browser window.

See Also

  • Web.TextControl.Dock Property


TXTextControl.Web.FileType Enumeration

Specifies the kind of file types. The enumeration contains the following values:

Member | Description
Database | Specifies database file types.
Document | Specifies document file types.
Image | Specifies image file types.

See Also

  • Web.TextControl.SetFileDirectory Method
  • Web.TextControl.GetFileDirectory Method


TXTextControl.Web.StreamType Enumeration

Determines a certain text format. The enumeration contains the following values:

Member | Description
AdobePDF | Specifies Adobe Portable Document Format (PDF). If a document is loaded, only the text is imported.
AdobePDFA | Specifies Adobe Portable Document Format Archive (PDF/A). This format can only be used in saving operations.
CascadingStylesheet | Specifies CSS format (Cascading Style Sheet). This format can only be used in saving operations.
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
InternalFormat | Specifies the internal Text Control format. Text is stored in ANSI format.
InternalUnicodeFormat | Specifies the internal Text Control format. Text is stored in Unicode format.
MSWord | Specifies Microsoft Word format (.DOC version).
PlainAnsiText | Specifies text in Windows ANSI format (an end of a paragraph is marked with the control characters 13 and 10).
PlainText | Specifies text in Windows Unicode format (an end of a paragraph is marked with the control characters 13 and 10).
RichTextFormat | Specifies RTF format (Rich Text Format).
WordprocessingML | Specifies Microsoft Word format (Office Open XML version).
XMLFormat | Specifies XML format (Extensible Markup Language).

See Also

  • Web.TextControl.LoadText Method
  • Web.TextControl.SaveText Method


TXTextControl.Web.StringStreamType Enumeration

Determines a certain text format that can be stored as a string. The enumeration contains the following values:

Member | Description
CascadingStylesheet | Specifies CSS format (Cascading Style Sheet). This format can only be used in saving operations.
HTMLFormat | Specifies HTML format (Hypertext Markup Language).
PlainText | Specifies Text in Windows Unicode format (an end of a paragraph is marked with the control characters 13 and 10).
RichTextFormat | Specifies RTF format (Rich Text Format).
XMLFormat | Specifies XML format (Extensible Markup Language).

See Also

  • Web.TextControl.LoadText Method
  • Web.TextControl.SaveText Method


TXTextControl.Web.EditMode Enumeration

Specifies possible edit modes a Web.TextControl can be in.

Introduced: 22.0.

Member | Description
Edit | The document's text can be edited.
ReadAndSelect | The document's text is read only but can be selected.
ReadOnly | The document's text is read only.


TXTextControl.Web.HeaderFooterType Enumeration

Determines the type of a header or footer. The enumeration contains the following values:

Introduced: 22.0.

Member | Description
Header | The object is a header. When an even header exists, the object represents the odd header. Otherwise it represents the header of all pages.
FirstPageHeader | The object represents a special header of the document's or section's first page.
Footer | The object is a footer. When an even footer exists, this member represents the odd footer. Otherwise it represents the footer of all pages.
FirstPageFooter | The object represents a special footer of the document's or section's first page.
EvenHeader | The object represents an even header.
EvenFooter | The object represents an even footer.

See Also

  • Web.HeaderFooter.Type Property


TXTextControl.Windows.Forms.Ribbon namespace

Enumerations

TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup Class

TXTextControl.Windows.Forms.Ribbon.ContextualTabGroupCollection Class

TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup Class

TXTextControl.Windows.Forms.Ribbon.Ribbon Class

TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors Class

TXTextControl.Windows.Forms.Ribbon.RibbonButton Class

TXTextControl.Windows.Forms.Ribbon.RibbonComboBox Class

TXTextControl.Windows.Forms.Ribbon.RibbonForm Class

TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonGroup Class

TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher Class

TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection Class

TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection Class

TXTextControl.Windows.Forms.Ribbon.RibbonLabel Class

TXTextControl.Windows.Forms.Ribbon.RibbonListView Class

TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem Class

TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection Class

TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemEventArgs Class

TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton Class

TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonSeperator Class

TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton Class

TXTextControl.Windows.Forms.Ribbon.RibbonTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab Class

TXTextControl.Windows.Forms.Ribbon.RibbonTextBox Class

TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton Class

TXTextControl.Windows.Forms.Ribbon.RibbonToolTip Class

TXTextControl.Windows.Forms.Ribbon.RibbonViewTab Class


Enumerations

TXTextControl.Windows.Forms.Ribbon.IconTextRelation Enumeration

TXTextControl.Windows.Forms.Ribbon.RibbonListView.ListViewMode Enumeration

TXTextControl.Windows.Forms.Ribbon.RibbonSeperator.SeperatorAlignment Enumeration

TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.InputValidationMode Enumeration


TXTextControl.Windows.Forms.Ribbon.IconTextRelation Enumeration

Specifies the position of the text and the kind of icon relative to each other on objects of type RibbonButton and RibbonTextBox:

Member | Description
LargeIconLabeled | If the object is part of a RibbonGroup the item displayes its large icon above its text. If the item is an object of type RibbonButton and inserted as a drop-down item, the image is displayed horizontally before the text and the description text.
SmallIconLabeled | The item displayes its small icon horizontally before the text.
SmallIconUnlabeled | The item's small icon is displayed, but not its text.
NoIconLabeled | Only the item's text is displayed.


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ListViewMode Enumeration

Determines the view mode of the RibbonListView:

Member | Description
Icon | A RibbonListViewItem displayes its icon.
Text | A RibbonListViewItem displayes its text.


TXTextControl.Windows.Forms.Ribbon.RibbonSeperator.SeperatorAlignment Enumeration

Determines the alignment of the RibbonSeperator:

Member | Description
Horizontal | The seperator is aligned horizontally.
Vertical | The seperator is aligned vertically.


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.InputValidationMode Enumeration

Determines the validation mode that is used to validate the inserted text in the RibbonTextBox:

Member | Description
All | All characters are valid to be inserted into the text box.
LettersOrDigits | Only letters or digits are valid text box characters.
OnlyLetters | Only letters or digits are valid text box characters.
OnlyDigits | Only digits are valid text box characters.


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup Class

An object of the ContextualTabGroup class represents a group of ribbon tabs which are only shown in a certain context. A Ribbon control manages a ContextualTabGroupCollection object, which is available through the ContextualTabGroups property. It contains all tab groups belonging to the ribbon.

Introduced: 24.0.

Syntax

[C#]
public class ContextualTabGroup
[Visual Basic]
Public Class ContextualTabGroup

Constructors

Constructor | Description
ContextualTabGroup | Initializes a new instance of the ContextualTabGroup class.

Properties

Property | Description
BackColor | Gets or sets the background color of the group's label.
ContextualTabs | Gets a list of all RibbonTab objects contained in this group.
Header | Gets or sets the group's header.
Name | Gets or sets the group's name.
Visible | Gets or sets the group's visibility.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup Constructor

Initializes a new instance of the ContextualTabGroup class.

Syntax

[C#]
public ContextualTabGroup();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup.BackColor Property

Gets or sets the background color of the group's label.

Syntax

[C#]
public System.Drawing.Color BackColor { get; set; }
[Visual Basic]
Public Property BackColor() As System.Drawing.Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup.ContextualTabs Property

Gets a list of all RibbonTab objects contained in this group.

Syntax

[C#]
public System.Collections.Generic.List<RibbonTab> ContextualTabs { get; }
[Visual Basic]
Public ReadOnly Property ContextualTabs() As System.Collections.Generic.List(Of RibbonTab)

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup.Header Property

Gets or sets the group's header. The header's text is shown in the application's caption, when the group is visible.

Syntax

[C#]
public string Header { get; set; }
[Visual Basic]
Public Property Header() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup.Name Property

Gets or sets the group's name.

Syntax

[C#]
public string Name { get; set; }
[Visual Basic]
Public Property Name() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroup.Visible Property

Gets or sets the group's visibility.

Syntax

[C#]
public bool Visible { get; set; }
[Visual Basic]
Public Property Visible() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.ContextualTabGroupCollection Class

The ContextualTabGroupCollection class represents all groups of ribbon tabs which are only shown in a certain context. Each ContextualTabGroup object contained in the collection represents one group of tabs. A Ribbon control manages a collection of contextual tab groups, which is available through the ContextualTabGroups property.

Introduced: 24.0.

Syntax

[C#]
public class ContextualTabGroupCollection : System.Collections.Generic.List<ContextualTabGroup>
[Visual Basic]
Public Class ContextualTabGroupCollection
  Inherits System.Collections.Generic.List(Of ContextualTabGroup)

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup Class

The HorizontalRibbonGroup class represents a logical group of controls as they appear on a RibbonTab. An instance of a HorizontalRibbonGroup can be added to a RibbonTab by using the Add method of its RibbonGroupCollection which is represented by the RibbonTab.RibbonGroups property. The controls of a HorizontalRibbonGroup are arranged in rows. To arrange them in columns it is recommend to use an instance of type RibbonGroup. A HorizontalRibbonGroup is inherited from the RibbonGroup class. The following describes only the properties, methods and events defined through the HorizontalRibbonGroup class.

Introduced: 24.0.

Syntax

[C#]
public class HorizontalRibbonGroup : RibbonGroup
[Visual Basic]
Public Class HorizontalRibbonGroup
  Inherits RibbonGroup

Constructors

Constructor | Description
HorizontalRibbonGroup | Initializes a new instance of the HorizontalRibbonGroup class.

Properties

Property | Description
DialogBoxLauncher | Gets an object of type DialogBoxLauncher which represents the RibbonGroup's dialog box launcher item. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
IsAddToQuickAccessToolbarEnabled | Gets or sets a value whether the RibbonGroup can be added to the quick access toolbar. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
LargeIcon | Gets or sets a 32x32 icon for this RibbonGroup. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
RibbonItems | Gets a collection of all items contained in this group. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
RowCount | Gets or sets the number of rows in the RibbonGroup. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
ShowSeperator | Gets or sets a value whether the RibbonGroup's seperator is shown. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
SmallIcon | Gets or sets a 16x16 icon for this RibbonGroup. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
Text | Overridden. Gets or sets the RibbonGroup's footer text. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over this RibbonGroup. (Inherited from Windows.Forms.Ribbon.RibbonGroup.)

Methods

Method | Description
Add | Adds a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator to the end of a specific row inside the horizontal ribbon group.
AddRange | Adds an array of controls to the end of a specific row.
Insert | Inserts a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator at the specified index.
InsertRange | Inserts an array of controls at the specified index.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup Constructor

Initializes a new instance of the HorizontalRibbonGroup class.

Syntax

[C#]
public HorizontalRibbonGroup();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup.Add Method

Adds a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator to the end of a specific row inside the horizontal ribbon group.

Syntax

[C#]
public int Add(System.Windows.Forms.Control item, int row);
[Visual Basic]
Public Function Add(ByVal item As System.Windows.Forms.Control, ByVal row As Integer) As Integer
Parameter | Description
item | The control to be added to this group.
row | The row where to add the control. Valid values are 0, 1 or 2.

Return Value

The RibbonItems property's collection index at which the value has been added.

Limitations

RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added to a horizontal ribbon group.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup.AddRange Method

Adds an array of controls to the end of a specific row. These controls must be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public void AddRange(System.Windows.Forms.Control[] items, int row);
[Visual Basic]
Public Sub AddRange(ByVal items() As System.Windows.Forms.Control, ByVal row As Integer)
Parameter | Description
items | An array of controls to be added to this group.
row | The row where to add the controls. Valid values are 0, 1 or 2.

Limitations

RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added to a horizontal ribbon group.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup.Insert Method

Inserts a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator at the specified index.

Syntax

[C#]
public int Insert(int index, System.Windows.Forms.Control item, int row);
[Visual Basic]
Public Function Insert(ByVal index As Integer, ByVal item As System.Windows.Forms.Control, ByVal row As Integer) As Integer
Parameter | Description
index | The zero-based index at which the control should be inserted.
item | The control to be inserted to this group.
row | The row where to insert the control. Valid values are 0, 1 or 2.

Limitations

RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added to a horizontal ribbon group.

If the number of rows, that contain ribbon items, is larger than the defined number of rows, only those rows are displayed that are in this defined range.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.HorizontalRibbonGroup.InsertRange Method

Inserts an array of controls at the specified index. These controls must be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public void InsertRange(int index, System.Windows.Forms.Control[] items, int row);
[Visual Basic]
Public Sub InsertRange(ByVal index As Integer, ByVal items() As System.Windows.Forms.Control, ByVal row As Integer)
Parameter | Description
index | The zero-based index at which the controls should be inserted.
items | An array of controls to be inserted to this group.
row | The row where to insert the controls. Valid values are 0, 1 or 2.

Limitations

RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added to a horizontal ribbon group.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon Class

The Ribbon class is a command bar that organizes the features of an application into a series of tabs at the top of the application window. It replaces both the traditional menu bar and toolbars. It hosts an Application Menu, and one or more RibbonTab controls. These controls then host a variety of button and menu controls that enable access to application commands. To add or remove objects of type RibbonTab it is recommended to use the Ribbon's Controls property. The Ribbon class is inherited from the System.Windows.Forms.TabControl class. The following describes only the properties, methods and events defined through the Ribbon class. For a list of properties, methods and events inherited from the System.Windows.Forms.TabControl class see the .NET Framework reference. A ribbon can be connected with a TextControl through the TextControl.Ribbon property.

Introduced: 24.0.

Syntax

[C#]
public class Ribbon : System.Windows.Forms.TabControl
[Visual Basic]
Public Class Ribbon
  Inherits System.Windows.Forms.TabControl

Constructors

Constructor | Description
Ribbon | Initializes a new instance of the Ribbon class.

Properties

Property | Description
ApplicationMenuHelpPaneItems | Gets a collection of all items which are displayed on the help pane of the Application Menu.
ApplicationMenuItems | Gets a collection of all items which are displayed on the Application Menu.
ContextualTabGroups | Gets a collection of all contextual tab groups of this ribbon.
DisplayColors | Gets or sets the colors of the ribbon.
ReadOnly | Gets or sets a value determining the ribbon's read only mode.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon Constructor

Initializes a new instance of the Ribbon class.

Syntax

[C#]
public Ribbon();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.ApplicationMenuHelpPaneItems Property

Gets a collection of all items which are displayed on the help pane of the Application Menu. The Application Menu has a help pane that can host additional content and is typically used to display a list of recent documents. The collection can be used to add or remove items and to set item properties. The property value is an object of the type Windows.Forms.Ribbon.RibbonItemCollection.

Syntax

[C#]
public RibbonItemCollection ApplicationMenuHelpPaneItems { get; }
[Visual Basic]
Public ReadOnly Property ApplicationMenuHelpPaneItems() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.ApplicationMenuItems Property

Gets a collection of all items which are displayed on the Application Menu. Every ribbon includes an Application Menu as the first tab in the ribbon. Other ribbon tabs contain controls for working with the document content. In contrast, the Application Menu presents a menu of commands for working with the file. The collection can be used to add or remove items and to set item properties. The property value is an object of the type Windows.Forms.Ribbon.RibbonItemCollection.

Syntax

[C#]
public  RibbonItemCollection ApplicationMenuItems { get; }
[Visual Basic]
Public ReadOnly Property ApplicationMenuItems() As  RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.ContextualTabGroups Property

Gets a collection of all contextual tab groups of this ribbon. The collection can be used to add or remove items and to set item properties. The property value is an object of the type Windows.Forms.Ribbon.ContextualTabGroupCollection

Syntax

[C#]
public ContextualTabGroupCollection ContextualTabGroups { get; }
[Visual Basic]
Public ReadOnly Property ContextualTabGroups() As ContextualTabGroupCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.DisplayColors Property

Gets or sets the colors of the ribbon. The property value is an object of the type Windows.Forms.Ribbon.Ribbon.Colors.

Syntax

[C#]
public Ribbon.Colors DisplayColors { get; set; }
[Visual Basic]
Public Property DisplayColors As Ribbon.Colors

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.ReadOnly Property

Gets or sets a value determining the ribbon's read only mode. When the ribbon is set to read only, it still shows all formatting attributes of the connected TextControl, but formatting attributes cannot be changed.

Syntax

[C#]
public bool ReadOnly { get; set; }
[Visual Basic]
Public Property ReadOnly As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors Class

The Ribbon.Colors class gets, sets or resets the display colors of a Windows Forms Ribbon control. By default the display colors depend on sytem colors. With this class all colors can be individually designed.

Introduced: 24.0.

Syntax

[C#]
public class Ribbon.Colors
[Visual Basic]
Public Class Ribbon.Colors

Constructors

Constructor | Description
Colors | Initializes a new instance of the Ribbon.Colors class.

Properties

Property | Description
ApplicationMenuColor | Gets or sets the background color of a ribbon's application menu.
ApplicationMenuTabColor | Gets or sets the color of a ribbon's first tab, which opens the application menu.
ApplicationMenuTabHighlightColor | Gets or sets the highlight color of a ribbon's first tab which is used, when the mouse pointer is moved over it.
HighlightTabColor | Gets or sets the highlight color of a ribbon tab which is used when a tab is selected.
MenuColor | Gets or sets the menu color of a ribbon.
TabColor | Gets or sets the background color of a ribbon tab.

Methods

Method | Description
ResetApplicationMenuColor | Resets the ribbon's ApplicationMenuColor to its system dependent default value.
ResetApplicationMenuTabColor | Resets the ribbon's ApplicationMenuTabColor to its system dependent default value.
ResetApplicationMenuTabHighlightColor | Resets the ribbon's ApplicationMenuTabHighlightColor to its system dependent default value.
ResetHighlightTabColor | Resets the ribbon's HighlightTabColor to its system dependent default value.
ResetMenuColor | Resets the ribbon's MenuColor to its system dependent default value.
ResetTabColor | Resets the ribbon's TabColor to its system dependent default value.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors Constructor

Initializes a new instance of the Ribbon.Colors class. After creating the object with this constuctor, individual colors can be set. If the Colors object is assigned to the Windows.Forms.Ribbon.Ribbon.DisplayColors property, non-set colors are reset to their system dependent default values.

Syntax

[C#]
public Ribbon.Colors();
[Visual Basic]
Public Class Ribbon.Colors

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ApplicationMenuColor Property

Gets or sets the background color of a ribbon's application menu.

Syntax

[C#]
public Color ApplicationMenuColor { get; set; }
[Visual Basic]
Public Property ApplicationMenuColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ApplicationMenuTabColor Property

Gets or sets the color of a ribbon's first tab, which opens the application menu.

Syntax

[C#]
public Color ApplicationMenuTabColor { get; set; }
[Visual Basic]
Public Property ApplicationMenuTabColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ApplicationMenuTabHighlightColor Property

Gets or sets the highlight color of a ribbon's first tab which is used, when the mouse pointer is moved over it.

Syntax

[C#]
public Color ApplicationMenuTabHighlightColor { get; set; }
[Visual Basic]
Public Property ApplicationMenuTabHighlightColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.HighlightTabColor Property

Gets or sets the highlight color of a ribbon tab which is used when a tab is selected.

Syntax

[C#]
public Color HighlightTabColor { get; set; }
[Visual Basic]
Public Property HighlightTabColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.MenuColor Property

Gets or sets the menu color of a ribbon.

Syntax

[C#]
public Color MenuColor { get; set; }
[Visual Basic]
Public Property MenuColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.TabColor Property

Gets or sets the background color of a ribbon tab.

Syntax

[C#]
public Color TabColor { get; set; }
[Visual Basic]
Public Property TabColor As Color

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetApplicationMenuColor Method

Resets the ribbon's ApplicationMenuColor to its system dependent default value.

Syntax

[C#]
public void ResetApplicationMenuColor();
[Visual Basic]
Public Sub ResetApplicationMenuColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetApplicationMenuTabHighlightColor Method

Resets the ribbon's ApplicationMenuTabHighlightColor to its system dependent default value.

Syntax

[C#]
public void ResetApplicationMenuTabHighlightColor();
[Visual Basic]
Public Sub ResetApplicationMenuTabHighlightColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetApplicationMenuTabColor Method

Resets the ribbon's ApplicationMenuTabColor to its system dependent default value.

Syntax

[C#]
public void ResetApplicationMenuTabColor();
[Visual Basic]
Public Sub ResetApplicationMenuTabColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetHighlightTabColor Method

Resets the ribbon's HighlightTabColor to its system dependent default value.

Syntax

[C#]
public void ResetHighlightTabColor();
[Visual Basic]
Public Sub ResetHighlightTabColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetMenuColor Method

Resets the ribbon's MenuColor to its system dependent default value.

Syntax

[C#]
public void ResetMenuColor();
[Visual Basic]
Public Sub ResetMenuColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.Ribbon.Colors.ResetTabColor Method

Resets the ribbon's TabColor to its system dependent default value.

Syntax

[C#]
public void ResetTabColor();
[Visual Basic]
Public Sub ResetTabColor()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton Class

The RibbonButton class is a button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu. Furthermore it is the base class of the RibbonToggleButton and RibbonMenuButton classes. The RibbonButton class is inherited from the System.Windows.Forms.Control class and implements the System.ComponentModel.INotifyPropertyChanged interface. The following describes only the properties, methods and events defined through the RibbonButton class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class and the System.ComponentModel.INotifyPropertyChanged interface see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonButton : System.Windows.Forms.Control, System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class RibbonButton
  Inherits System.Windows.Forms.Control
  Implements System.ComponentModel.INotifyPropertyChanged

Constructors

Constructor | Description
RibbonButton | Initializes a new instance of the RibbonButton class.

Properties

Property | Description
Description | Gets or sets the description text that appears on this button in a RibbonMenuButton's drop down menu when the DisplayMode property of the button is set to IconTextRelation.LargeIconLabeled.
DisplayMode | Sets the RibbonButton's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width.
IsAddToQuickAccessToolbarEnabled | Gets or sets value whether the RibbonButton can be added to the quick access toolbar.
KeyTip | Gets or sets the keyboard shortcut of the RibbonButton.
LargeIcon | Gets or sets a 32x32 icon for this RibbonButton.
ParentCollection | Gets the RibbonItemCollection that contains this RibbonButton.
SmallIcon | Gets or sets a 16x16 icon for this RibbonButton.
Text | Overridden. Gets or sets the RibbonButton's text.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton Constructor

Initializes a new instance of the RibbonButton class.

Syntax

[C#]
public RibbonButton();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.Description Property

Gets or sets the description text that appears on this button in a RibbonMenuButton's drop down menu when the DisplayMode property of the button is set to IconTextRelation.LargeIconLabeled.

Syntax

[C#]
public string Description { get; set; }
[Visual Basic]
Public Property Description() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.DisplayMode Property

Sets the RibbonButton's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width.

Syntax

[C#]
public IconTextRelation DisplayMode { get; set; }
[Visual Basic]
Public Property DisplayMode() As IconTextRelation

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.IsAddToQuickAccessToolbarEnabled Property

Gets or sets value whether the RibbonButton can be added to the quick access toolbar.

Syntax

[C#]
public bool IsAddToQuickAccessToolbarEnabled { get; set; }
[Visual Basic]
Public Property IsAddToQuickAccessToolbarEnabled() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.KeyTip Property

Gets or sets the keyboard shortcut of the RibbonButton.

Syntax

[C#]
public string KeyTip { get; }
[Visual Basic]
Public ReadOnly Property KeyTip() As String

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.LargeIcon Property

Gets or sets a 32x32 icon for this RibbonButton. This icon is shown when the DisplayMode property is set to IconTextRelation.LargeIconLabeled. The default value is IconTextRelation.LargeIconLabeled.

Syntax

[C#]
public System.Drawing.Image LargeIcon { get; set; }
[Visual Basic]
Public Property LargeIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonButton.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.SmallIcon Property

Gets or sets a 16x16 icon for this RibbonButton. This icon is shown when the DisplayMode property is set to IconTextRelation.SmallIconLabeled or IconTextRelation.SmallIconUnlabeled.

Syntax

[C#]
public System.Drawing.Image SmallIcon { get; set; }
[Visual Basic]
Public Property SmallIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.Text Property

Overridden. Gets or sets the RibbonButton's text.

Syntax

[C#]
public override string Text { get; set; }
[Visual Basic]
Public Overrides Property Text() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonButton.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonComboBox Class

The RibbonComboBox class represents a combobox which is inherited from the System.Windows.Forms.ComboBox class. For a list of properties, methods and events inherited from the System.Windows.Forms.ComboBox class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonComboBox : System.Windows.Forms.ComboBox
[Visual Basic]
Public Class RibbonComboBox
  Inherits System.Windows.Forms.ComboBox

Constructors

Constructor | Description
RibbonComboBox | Initializes a new instance of the RibbonComboBox class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonComboBox.
ParentCollection | Gets the RibbonItemCollection that contains this RibbonComboBox.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonComboBox Constructor

Initializes a new instance of the RibbonComboBox class.

Syntax

[C#]
public RibbonComboBox();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonComboBox.KeyTip Property

Gets or sets the keyboard shortcut of the RibbonComboBox.

Syntax

[C#]
public string KeyTip { get; }
[Visual Basic]
Public ReadOnly Property KeyTip() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonComboBox.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonComboBox.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonComboBox.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonForm Class

The RibbonForm class represents a Windows Forms form that can draw a Ribbon Quick Access Toolbar and contextual tabs in its border. It is inherited from the System.Windows.Forms.Form class. The following describes only the properties, methods and events defined through the RibbonForm class. For a list of properties, methods and events inherited from the System.Windows.Forms.Form class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonForm : System.Windows.Forms.Form
[Visual Basic]
Public Class RibbonForm
  Inherits System.Windows.Forms.Form

Constructors

Constructor | Description
RibbonForm | Initializes a new instance of the RibbonForm class.

Methods

Method | Description
SetQuickAccessToolbarStandardItems | Specifies the standard items of the Quick Access Toolbar.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonForm Constructor

Initializes a new instance of the RibbonForm class.

Syntax

[C#]
public RibbonForm();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonForm.SetQuickAccessToolbarStandardItems Method

Specifies the standard items of the Quick Access Toolbar. Additional items can be added and removed through a context menu.

Syntax

[C#]
public void SetQuickAccessToolbarStandardItems(System.Windows.Forms.ToolStripItem[] items);
[Visual Basic]
Public Sub SetQuickAccessToolbarStandardItems(items As System.Windows.Forms.ToolStripItem())
Member | Description
items | An array of ToolStripItem objects which act as the standard items of the Quick Access Toolbar.

Example

The following example defines 6 buttons as Quick Access Toolbar standard items:

[C#]
private string[] strQATImages = {"save.png", "open.png", "newpage.png", "undo.png", "redo.png", "print.png" };
int iButtons = strQATImages.Length;
ToolStripButton[] buttons = new ToolStripButton[iButtons];
for (int i=0; i<iButtons; i++) {
    buttons[i] = new ToolStripButton();
    buttons[i].Image = new Bitmap(typeof(RibbonApp), strQATImages[i]);
    switch (i) {
    case 0: buttons[i].Click += OnSaveFile; break;
    case 1: buttons[i].Click += OnOpenFile; break;
    case 2: buttons[i].Click += OnNewDocument; break;
    case 3: buttons[i].Click += OnUndo; break;
    case 4: buttons[i].Click += OnRedo; break;
    case 5: buttons[i].Click += OnPrint; break;
    }
}
SetQuickAccessToolbarStandardItems(buttons);
[Visual Basic]
Dim strQATImages As String() = {"save.png", "open.png", "newpage.png", "undo.png", "redo.png", "print.png"}
Dim iButtons As Integer = strQATImages.Length
Dim buttons As ToolStripButton() = New ToolStripButton(iButtons - 1) {}
For i As Integer = 0 To iButtons - 1
    buttons(i) = New ToolStripButton()
    buttons(i).Image = New Bitmap(GetType(RibbonApp), strQATImages(i))
    Select Case i
        Case 0
            buttons(i).Click += OnSaveFile
            Exit Select
        Case 1
            buttons(i).Click += OnOpenFile
            Exit Select
        Case 2
            buttons(i).Click += OnNewDocument
            Exit Select
        Case 3
            buttons(i).Click += OnUndo
            Exit Select
        Case 4
            buttons(i).Click += OnRedo
            Exit Select
        Case 5
            buttons(i).Click += OnPrint
            Exit Select
    End Select
Next
SetQuickAccessToolbarStandardItems(buttons)

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab Class

The RibbonFormattingTab class represents a ribbon tab for setting font and paragraph attributes, formatting styles and for handling the clipboard. To show the formatting attributes of a document the TextControl must be connected with the Ribbon that hosts the RibbonFormattingTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonFormattingTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonFormattingTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonFormattingTab | Initializes a new instance of the RibbonFormattingTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonFormattingTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonFormattingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab Constructor

Initializes a new instance of the RibbonFormattingTab class.

Syntax

[C#]
public RibbonFormattingTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab.FindItem Method

Finds a control that has the provided RibbonFormattingTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonFormattingTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonFormattingTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFormattingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonFormattingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_Paste | Identifies the Paste button of the RibbonFormattingTab.
TXITEM_Cut | Identifies the Cut button of the RibbonFormattingTab.
TXITEM_Copy | Identifies the Copy button of the RibbonFormattingTab.
TXITEM_FontFamily | Identifies the FontFamily combobox of the RibbonFormattingTab.
TXITEM_FontSize | Identifies the FontSize combobox of the RibbonFormattingTab.
TXITEM_IncreaseFont | Identifies the IncreaseFont button of the RibbonFormattingTab.
TXITEM_DecreaseFont | Identifies the DecreaseFont button of the RibbonFormattingTab.
TXITEM_ClearFormatting | Identifies the ClearFormatting button of the RibbonFormattingTab.
TXITEM_Bold | Identifies the Bold button of the RibbonFormattingTab.
TXITEM_Italic | Identifies the Italic button of the RibbonFormattingTab.
TXITEM_Underline | Identifies the Underline button of the RibbonFormattingTab.
TXITEM_Strikeout | Identifies the Strikeout button of the RibbonFormattingTab.
TXITEM_Subscript | Identifies the Subscript button of the RibbonFormattingTab.
TXITEM_Superscript | Identifies the Superscript button of the RibbonFormattingTab.
TXITEM_ChangeCase | Identifies the ChangeCase button of the RibbonFormattingTab.
TXITEM_TextBackColor | Identifies the TextBackColor button of the RibbonFormattingTab.
TXITEM_TextColor | Identifies the TextColor button of the RibbonFormattingTab.
TXITEM_BulletedList | Identifies the BulletedList button of the RibbonFormattingTab.
TXITEM_NumberedList | Identifies the NumberedList button of the RibbonFormattingTab.
TXITEM_StructuredList | Identifies the StructuredList button of the RibbonFormattingTab.
TXITEM_DecreaseIndent | Identifies the DecreaseIndent button of the RibbonFormattingTab.
TXITEM_IncreaseIndent | Identifies the IncreaseIndent button of the RibbonFormattingTab.
TXITEM_LeftToRight | Identifies the LeftToRight button of the RibbonFormattingTab.
TXITEM_RightToLeft | Identifies the RightToLeft button of the RibbonFormattingTab.
TXITEM_EditTabs | Identifies the EditTabs button of the RibbonFormattingTab.
TXITEM_ControlChars | Identifies the ControlChars button of the RibbonFormattingTab.
TXITEM_LeftAligned | Identifies the LeftAligned button of the RibbonFormattingTab.
TXITEM_Centered | Identifies the Centered button of the RibbonFormattingTab.
TXITEM_RightAligned | Identifies the RightAligned button of the RibbonFormattingTab.
TXITEM_Justified | Identifies the Justified button of the RibbonFormattingTab.
TXITEM_LineSpacing | Identifies the LineSpacing button of the RibbonFormattingTab.
TXITEM_Borders | Identifies the Borders button of the RibbonFormattingTab.
TXITEM_LeftFrameLine | Identifies the LeftFrameLine menu item of the RibbonFormattingTab.
TXITEM_TopFrameLine | Identifies the TopFrameLine menu item of the RibbonFormattingTab.
TXITEM_RightFrameLine | Identifies the RightFrameLine menu item of the RibbonFormattingTab.
TXITEM_BottomFrameLine | Identifies the BottomFrameLine menu item of the RibbonFormattingTab.
TXITEM_BoxFrame | Identifies the BoxFrame menu item of the RibbonFormattingTab.
TXITEM_AllFrameLines | Identifies the AllFrameLines menu item of the RibbonFormattingTab.
TXITEM_InnerHorizontalFrameLines | Identifies the InnerHorizontalFrameLines menu item of the RibbonFormattingTab.
TXITEM_InnerVerticalFrameLines | Identifies the InnerVerticalFrameLines menu item of the RibbonFormattingTab.
TXITEM_BackColor | Identifies the BackColor button of the RibbonFormattingTab.
TXITEM_FrameLineColor | Identifies the FrameLineColor button of the RibbonFormattingTab.
TXITEM_FrameLineWidth | Identifies the FrameLineWidth button of the RibbonFormattingTab.
TXITEM_StyleName | Identifies the StyleName gallery of the RibbonFormattingTab.
TXITEM_Find | Identifies the Find button of the RibbonFormattingTab.
TXITEM_Replace | Identifies the Replace button of the RibbonFormattingTab.
TXITEM_Goto | Identifies the Goto button of the RibbonFormattingTab.
TXITEM_SelectAll | Identifies the SelectAll button of the RibbonFormattingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab Class

The RibbonFrameLayoutTab class represents a Windows Forms ribbon tab for editing objects of type Image, TextFrame, DrawingFrame, BarcodeFrame and ChartFrame. To modify one of these objects, a TextControl must be connected with the Ribbon which hosts the RibbonFrameLayoutTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonFrameLayoutTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonFrameLayoutTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonFrameLayoutTab | Initializes a new instance of the RibbonFrameLayoutTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonFrameLayoutTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonFrameLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab Constructor

Initializes a new instance of the RibbonFrameLayoutTab class.

Syntax

[C#]
public RibbonFrameLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab.FindItem Method

Finds a control that has the provided RibbonFrameLayoutTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonFrameLayoutTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonFrameLayoutTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonFrameLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonFrameLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_WrapText | Identifies the WrapText button of the RibbonFrameLayoutTab.
TXITEM_BringToFront | Identifies the BringToFront button of the RibbonFrameLayoutTab.
TXITEM_SendToBack | Identifies the SendToBack button of the RibbonFrameLayoutTab.
TXITEM_Position | Identifies the Position button of the RibbonFrameLayoutTab.
TXITEM_ObjectHeight | Identifies the ObjectHeight text box of the RibbonFrameLayoutTab.
TXITEM_ObjectWidth | Identifies the ObjectWidth text box of the RibbonFrameLayoutTab.
TXITEM_ObjectName | Identifies the ObjectName text box of the RibbonFrameLayoutTab.
TXITEM_ObjectID | Identifies the ObjectID text box of the RibbonFrameLayoutTab.
TXITEM_TextFrameBackColor | Identifies the TextFrameBackColor button of the RibbonFrameLayoutTab.
TXITEM_TextFrameTransparency | Identifies the TextFrameTransparency button of the RibbonFrameLayoutTab.
TXITEM_TextFrameLineWidth | Identifies the TextFrameLineWidth button of the RibbonFrameLayoutTab.
TXITEM_DrawingLineColor | Identifies the DrawingLineColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingBackColor | Identifies the DrawingBackColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingLineWidth | Identifies the DrawingLineWidth button of the RibbonFrameLayoutTab.
TXITEM_DrawingTransparency | Identifies the DrawingTransparency button of the RibbonFrameLayoutTab.
TXITEM_TableBackColor | Identifies the TableBackColor button of the RibbonFrameLayoutTab.
TXITEM_DrawingRotation | Identifies the DrawingRotation button of the RibbonFrameLayoutTab.
TXITEM_BarcodeForeColor | Identifies the BarcodeForeColor button of the RibbonFrameLayoutTab.
TXITEM_BarcodeBackColor | Identifies the BarcodeBackColor button of the RibbonFrameLayoutTab.
TXITEM_BarcodeTransparency | Identifies the BarcodeTransparency button of the RibbonFrameLayoutTab.
TXITEM_BarcodeHorizontalAlignment | Identifies the BarcodeHorizontalAlignment button of the RibbonFrameLayoutTab.
TXITEM_BarcodeVerticalAlignment | Identifies the BarcodeVerticalAlignment button of the RibbonFrameLayoutTab.
TXITEM_BarcodeRotation | Identifies the BarcodeRotation button of the RibbonFrameLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup Class

The RibbonGroup class represents a logical group of controls as they appear on a RibbonTab and is the base class of the HorizontalRibbonGroup class. An instance of a RibbonGroup can be added to a RibbonTab by using the Add method of its RibbonGroupCollection which is represented by the RibbonTab.RibbonGroups property. The controls of a RibbonGroup are arranged in columns. To arrange them in rows it is recommend to use an instance of type HorizontalRibbonGroup. A RibbonGroup is inherited from the System.Windows.Forms.Panel class. The following describes only the properties, methods and events defined through the RibbonGroup class. For a list of properties, methods and events inherited from the System.Windows.Forms.Panel class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonGroup : System.Windows.Forms.Panel
[Visual Basic]
Public Class RibbonGroup
  Inherits System.Windows.Forms.Panel

Constructors

Constructor | Description
RibbonGroup | Initializes a new instance of the RibbonGroup class.

Properties

Property | Description
DialogBoxLauncher | Gets an object of type DialogBoxLauncher which represents the RibbonGroup's dialog box launcher item.
IsAddToQuickAccessToolbarEnabled | Gets or sets a value whether the RibbonGroup can be added to the quick access toolbar.
LargeIcon | Gets or sets a 32x32 icon for this RibbonGroup.
RibbonItems | Gets a collection of all items contained in this group.
RowCount | Gets or sets the number of rows in the RibbonGroup.
ShowSeperator | Gets or sets a value whether the RibbonGroup's seperator is shown.
SmallIcon | Gets or sets a 16x16 icon for this RibbonGroup.
Text | Overridden. Gets or sets the RibbonGroup's footer text.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over this RibbonGroup.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup Constructor

Initializes a new instance of the RibbonGroup class.

Syntax

[C#]
public RibbonGroup();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher Property

Gets an object of type DialogBoxLauncher which represents the RibbonGroup's dialog box launcher item.

Syntax

[C#]
public RibbonGroup.DialogBoxLauncher DialogBoxLauncher { get;}
[Visual Basic]
Public ReadOnly Property DialogBoxLauncher() As RibbonGroup.DialogBoxLauncher

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.IsAddToQuickAccessToolbarEnabled Property

Gets or sets a value whether the RibbonGroup can be added to the quick access toolbar.

Syntax

[C#]
public bool IsAddToQuickAccessToolbarEnabled { get; set; }
[Visual Basic]
Public Property IsAddToQuickAccessToolbarEnabled() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.LargeIcon Property

Gets or sets a 32x32 icon for this RibbonGroup. This icon is displayed by the RibbonGroup's menu button which appears when the RibbonGroup shrinks to a width where its items cannot be displayed anymore.

Syntax

[C#]
public System.Drawing.Image LargeIcon { get; set; }
[Visual Basic]
Public Property LargeIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.RibbonItems Property

Gets a collection of all items contained in this group. These controls can be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView or RibbonTextBox. RibbonGroups of type HorizontalRibbonGroup can also add objects of type RibbonSeperator.

Syntax

[C#]
public RibbonItemCollection RibbonItems { get; }
[Visual Basic]
Public ReadOnly Property RibbonItems() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.RowCount Property

Gets or sets the number of rows in the RibbonGroup.

Syntax

[C#]
public int RowCount { get; set; }
[Visual Basic]
Public Property RowCount() As Integer

Limitations

Valid values are 0, 1, 2 or 3.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.SmallIcon Property

Gets or sets a 16x16 icon for this RibbonGroup. This icon is displayed by the RibbonGroup's quick access toolbar tool strip item.

Syntax

[C#]
public System.Drawing.Image SmallIcon { get; set; }
[Visual Basic]
Public Property SmallIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.ShowSeperator Property

Gets or sets a value whether the RibbonGroup's seperator is shown. The default value is true.

Syntax

[C#]
public bool ShowSeperator { get; set; }
[Visual Basic]
Public Property ShowSeperator() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.Text Property

Overridden. Gets or sets the RibbonGroup's footer text.

Syntax

[C#]
public override string Text { get; set; }
[Visual Basic]
Public Overloads Overrides Property Text() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over this RibbonGroup.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher Class

The DialogBoxLauncher class represents the dialog box launcher item of a RibbonGroup. A DialogBoxLauncher is inherited from the System.ComponentModel.Component class. The following describes only the properties, methods and events defined through the DialogBoxLauncher class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class DialogBoxLauncher : System.ComponentModel.Component
[Visual Basic]
Public Class DialogBoxLauncher
  Inherits System.ComponentModel.Component

Properties

Property | Description
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this dialog box launcher.
Enabled | Gets or sets a value indicating whether this dialog box launcher is enabled.
ToolStripItemImage | Gets or sets a 16x16 icon for this dialog box launcher's quick access toolbar tool strip item.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.
Visible | Gets or sets a value indicating whether this dialog box launcher is visible.

Events

Event | Description
Click | Occurs as the dialog box launcher is clicked.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.ContextMenuStrip Property

Gets or sets the ContextMenuStrip associated with this dialog box launcher.

Syntax

[C#]
public System.Windows.Forms.ContextMenuStrip ContextMenuStrip { get; set; }
[Visual Basic]
Public Property ContextMenuStrip() As System.Windows.Forms.ContextMenuStrip

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.Enabled Property

Gets or sets a value indicating whether this dialog box launcher is enabled.

Syntax

[C#]
public bool Enabled { get; set; }
[Visual Basic]
Public Property Enabled() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.Visible Property

Gets or sets a value indicating whether this dialog box launcher is visible.

Syntax

[C#]
public bool Visible { get; set; }
[Visual Basic]
Public Property Visible() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.ToolStripItemImage Property

Gets or sets a 16x16 icon for this dialog box launcher's quick access toolbar tool strip item.

Syntax

[C#]
public System.Drawing.Image ToolStripItemImage { get; set; }
[Visual Basic]
Public Property ToolStripItemImage() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroup.DialogBoxLauncher.Click Event

Occurs as the dialog box launcher is clicked.

Syntax

[C#]
public event EventHandler Click;
[Visual Basic]
Public Event Click As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection Class

An instance of the RibbonGroupCollection class contains objects of type RibbonGroup and can be obtained with the RibbonTab.RibbonGroups property. It is inherited from the abstract class System.Collections.CollectionBase and implements the System.Collections.IEnumerable and System.Collections.IEnumerator interfaces. The following describes only the properties, methods and events defined through the RibbonGroupCollection class. For a list of properties, methods and events of these classes and interfaces see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonGroupCollection : CollectionBase, IEnumerable, IEnumerator
[Visual Basic]
Public Class RibbonGroupCollection
  Inherits CollectionBase
  Implements IEnumerable
  Implements IEnumerator

Methods

Method | Description
Add | Adds an object of the type RibbonGroup to the end of the collection.
Insert | Inserts an object of the type RibbonGroup at the specified index of the collection.
Item | Gets an object of type RibbonGroup from the collection.
Remove | Removes an object of the type RibbonGroup from the collection.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection.Add Method

Adds an object of the type RibbonGroup to the end of the collection.

Syntax

[C#]
public int Add(Windows.Forms.Ribbon.RibbonGroup ribbonGroup);
[Visual Basic]
Public Function Add(ribbonGroup item As Windows.Forms.Ribbon.RibbonGroup) As Integer
Parameter | Description
ribbonGroup | The RibbonGroup to be added to the end of the collection.

Return Value

The collection's index at which the value has been added.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection.Insert Method

Inserts an object of the type RibbonGroup at the specified index of the collection.

Syntax

[C#]
public void Insert(int index, Windows.Forms.Ribbon.RibbonGroup ribbonGroup);
[Visual Basic]
Public Sub Insert(ByVal index As Integer, ByVal ribbonGroup As Windows.Forms.Ribbon.RibbonGroup)
Parameter | Description
index | The zero-based index at which the RibbonGroup should be inserted.
ribbonGroup | The RibbonGroup to be inserted.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection.Remove Method

Removes an object of the type RibbonGroup from the collection.

Syntax

[C#]
public void Remove(Windows.Forms.Ribbon.RibbonGroup ribbonGroup);
[Visual Basic]
Public Sub Remove(ribbonGroup item As Windows.Forms.Ribbon.RibbonGroup)
Parameter | Description
ribbonGroup | The RibbonGroup to be removed from the collection.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonGroupCollection.Item Property

Gets an object of type RibbonGroup from the collection. This property is the indexer for the RibbonItemCollection class.

Syntax

[C#]
public RibbonGroup this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(number As Integer) As RibbonGroup
Parameter | Description
number | The zero-based index of the RibbonGroup.

Return Value

The RibbonGroup at the specified index.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab Class

The RibbonInsertTab class represents a Windows Forms ribbon tab for inserting pages, images, hyperlinks, bookmarks, headers and footers, textframes and symbols. To insert text elements in a document, a TextControl must be connected with the Ribbon that hosts the RibbonInsertTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonInsertTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonInsertTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonInsertTab | Initializes a new instance of the RibbonInsertTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonInsertTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonInsertTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab Constructor

Initializes a new instance of the RibbonInsertTab class.

Syntax

[C#]
public RibbonInsertTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab.FindItem Method

Finds a control that has the provided RibbonInsertTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonInsertTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonInsertTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonInsertTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonInsertTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_InsertPage | Identifies the InsertPage button of the RibbonInsertTab.
TXITEM_InsertPageBreak | Identifies the InsertPageBreak button of the RibbonInsertTab.
TXITEM_InsertTable | Identifies the InsertTable button of the RibbonInsertTab.
TXITEM_InsertImage | Identifies the InsertImage button of the RibbonInsertTab.
TXITEM_InsertShape | Identifies the InsertShape button of the RibbonInsertTab.
TXITEM_InsertBarcode | Identifies the InsertBarcode button of the RibbonInsertTab.
TXITEM_InsertHyperlink | Identifies the InsertHyperlink button of the RibbonInsertTab.
TXITEM_InsertBookmark | Identifies the InsertBookmark button of the RibbonInsertTab.
TXITEM_InsertHeader | Identifies the InsertHeader button of the RibbonInsertTab.
TXITEM_InsertFooter | Identifies the InsertFooter button of the RibbonInsertTab.
TXITEM_InsertPageNumber | Identifies the InsertPageNumber button of the RibbonInsertTab.
TXITEM_InsertTextFrame | Identifies the InsertTextFrame button of the RibbonInsertTab.
TXITEM_InsertFile | Identifies the InsertFile button of the RibbonInsertTab.
TXITEM_InsertSymbol | Identifies the InsertSymbol button of the RibbonInsertTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection Class

An instance of the RibbonItemCollection class contains controls of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator and can be obtained with the RibbonGroup.RibbonItems, Ribbon.ApplicationMenuHelpPaneItems, Ribbon.ApplicationMenuItems, RibbonMenuButton.DropDownItems or RibbonListView.DropDownItems property. It is inherited from the abstract class System.Collections.CollectionBase and implements the System.Collections.IEnumerable and System.Collections.IEnumerator interfaces. The following describes only the properties, methods and events defined through the RibbonItemCollection class. For a list of properties, methods and events of these classes and interfaces see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonItemCollection: CollectionBase, IEnumerable, IEnumerator
[Visual Basic]
Public Class RibbonItemCollection
  Inherits CollectionBase
  Implements IEnumerable
  Implements IEnumerator

Methods

Method | Description
Add | Adds a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator to the end of the collection.
AddRange | Adds an array of controls to the end of the collection.
Contains | Determines whether a control is in the collection.
Insert | Inserts a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator at the specified index.
InsertRange | Inserts an array of controls at the specified index.
Item | Gets a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator from the collection.
Remove | Removes a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator from this collection.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.Add Method

Adds a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator to the end of the collection.

Syntax

[C#]
public int Add(System.Windows.Forms.Control item);
[Visual Basic]
Public Function Add(ByVal item As System.Windows.Forms.Control) As Integer
Parameter | Description
item | The control to be added to the end of this collection.

Return Value

The collection's index at which the value has been added.

Limitations

If the RibbonItemCollection is optained by a HorizontalRibbonGroup controls are added to the group's first row.

If the RibbonItemCollection is optained by a HorizontalRibbonGroup RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.AddRange Method

Adds an array of controls to the end of the collection. These controls must be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public void AddRange(System.Windows.Forms.Control[] items);
[Visual Basic]
Public Sub AddRange(ByVal items() As System.Windows.Forms.Control)
Parameter | Description
items | An array of controls to be added to the end of this collection.

Limitations

If the RibbonItemCollection is optained by a HorizontalRibbonGroup controls are added to the group's first row.

If the RibbonItemCollection is optained by a HorizontalRibbonGroup RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be added.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.Contains Method

Determines whether a control is in the collection.

Syntax

[C#]
public bool Contains(System.Windows.Forms.Control item);
[Visual Basic]
Public Function Contains(ByVal item As System.Windows.Forms.Control) As Boolean
Parameter | Description
item | The item to locate in this collection.

Return Value

True if item is found in this collection. Otherwise, false.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.Insert Method

Inserts a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator at the specified index.

Syntax

[C#]
public void Insert(int index, System.Windows.Forms.Control item);
[Visual Basic]
Public Sub Insert(ByVal index As Integer, ByVal item As System.Windows.Forms.Control)
Parameter | Description
index | The zero-based index at which the control should be inserted.
item | The control to be inserted.

Limitations

If the RibbonItemCollection is optained by a HorizontalRibbonGroup controls are inserted to the group's first row.

If the RibbonItemCollection is optained by a HorizontalRibbonGroup RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be inserted.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.InsertRange Method

Inserts an array of controls at the specified index. These controls must be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public void InsertRange(int index, System.Windows.Forms.Control[] items);
[Visual Basic]
Public Sub InsertRange(ByVal index As Integer, ByVal items() As System.Windows.Forms.Control)
Parameter | Description
index | The zero-based index at which the controls should be inserted.
items | An array of controlsto be inserted.

Limitations

If the RibbonItemCollection is optained by a HorizontalRibbonGroup controls are inserted to the group's first row.

If the RibbonItemCollection is optained by a HorizontalRibbonGroup RibbonButtons where the DisplayMode property is set to IconTextRelation.LargeIconLabeled cannot be inserted.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.Item Property

Gets a control of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator from the collection. This property is the indexer for the RibbonItemCollection class.

Syntax

[C#]
public System.Windows.Forms.Control this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(number As Integer) As System.Windows.Forms.Control
Parameter | Description
number | The zero-based index of the control.

Return Value

The control at the specified index.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonItemCollection.Remove Method

Removes a control of the type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator from this collection.

Syntax

[C#]
public void Remove(System.Windows.Forms.Control item);
[Visual Basic]
Public Sub Remove(ByVal item As System.Windows.Forms.Control)
Parameter | Description
item | The control to be removed from this collection.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel Class

The RibbonLabel class represents a label which is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the RibbonLabel class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonLabel : System.Windows.Forms.Control
[Visual Basic]
Public Class RibbonLabel
  Inherits System.Windows.Forms.Control

Constructors

Constructor | Description
RibbonLabel | Initializes a new instance of the RibbonLabel class.

Properties

Property | Description
ParentCollection | Gets the RibbonItemCollection that contains this RibbonLabel.
SmallIcon | Gets or sets a 16x16 icon for this RibbonLabel.
Text | Overridden. Gets or sets the RibbonLabel's text.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel Constructor

Initializes a new instance of the RibbonLabel class.

Syntax

[C#]
public RibbonLabel();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonLabel.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel.SmallIcon Property

Gets or sets a 16x16 icon for this RibbonLabel. If no icon is set, only the RibbonLabel's text is displayed.

Syntax

[C#]
public System.Drawing.Image SmallIcon { get; set; }
[Visual Basic]
Public Property SmallIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel.Text Property

Overridden. Gets or sets the RibbonLabel's text. If no text is set, only the RibbonLabel's icon is displayed.

Syntax

[C#]
public override string Text { get; set; }
[Visual Basic]
Public Overrides Property Text() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonLabel.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView Class

The RibbonListView class is a list view control, which displays a collection of items that can be displayed using one of three different views. The RibbonListView class is inherited from the System.Windows.Forms.Control class and implements the System.ComponentModel.INotifyPropertyChanged interface. The following describes only the properties, methods and events defined through the RibbonListView class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class and the System.ComponentModel.INotifyPropertyChanged interface see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonListView : System.Windows.Forms.Control, System.ComponentModel.INotifyPropertyChanged
[Visual Basic]
Public Class RibbonListView
  Inherits System.Windows.Forms.Control
  Implements System.ComponentModel.INotifyPropertyChanged

Constructors

Constructor | Description
RibbonListView | Initializes a new instance of the RibbonListView class.

Properties

Property | Description
CellPadding | Gets or sets the amount of space between the cell's item and the cell's border.
ColumnCount | Gets the number of columns in this RibbonListView.
ColumnWidth | Gets the width for each column in this RibbonListView.
Deselectable | Gets or sets a value whether a selected RibbonListViewItem can be deselected by clicking into a cell that does not contain a RibbonListViewItem or clicking on it in combination with the pressed Ctrl key.
DropDownItems | Gets the collection of controls in the drop-down menu that is associated with this RibbonListView.
HideItems | Gets or sets a value indicating whether the RibbonListViewItems are displayed inside the RibbonListView or not.
HideSelectedItems | Gets or sets a value indicating whether the selected RibbonListViewItems are highlighted inside the RibbonListView or not.
ItemsSource | Gets or sets an array of RibbonListViewItems used to generate the content of this RibbonListView.
KeyTip | Gets or sets the keyboard shortcut of the RibbonListView.
MaxVisibleRows | Gets or sets a value specifying the maximum number of rows that are displayed by the RibbonListView.
MinColumnCount | Gets or sets the minimum number of columns in this RibbonListView.
MultiSelect | Gets or sets a value indicating whether multiple items can be selected.
ParentCollection | Gets the RibbonItemCollection that contains this RibbonListView.
RibbonListViewItems | Gets a collection containing all items in this RibbonListView.
RowCount | Gets the number of rows in this RibbonListView.
RowHeight | Gets the height for each row in this RibbonListView.
ScrollButtonsVisible | Gets or sets a value whether the scroll bars buttons should be displayed or not.
SelectedIndices | Gets the indexes of the selected items in this RibbonListView.
SelectedItems | Gets the items that are selected in this RibbonListView.
ShowBorder | Gets or sets a value indicating whether this RibbonListView is surrounded by a border or not.
ShowItemsInDropDown | Gets or sets a value indicating whether this RibbonListView's drop down menu displays additionally to the drop down items the control's RibbonListViewItems or not.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over RibbonListView's scroll bar or drop-down button.
ViewMode | Gets or sets the mode in which this RibbonListView displays its items.

Methods

Method | Description
ScrollTo | Scrolls the contents of the RibbonListView to a specified RibbonListViewItem.

Events

Event | Description
DropDownClosed | Occurs as the RibbonListView's drop-down menu is closed.
DropDownOpening | Occurs as the RibbonListView's drop-down menu is opening.
ItemClick | Occurs as an RibbonListViewItem is clicked.
ItemMouseEnter | Occurs when the mouse pointer enters a RibbonListViewItem.
ItemMouseLeave | Occurs when the mouse pointer leaves a RibbonListViewItem.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView Constructor

Initializes a new instance of the RibbonListView class.

Syntax

[C#]
public RibbonListView();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.CellPadding Property

Gets or sets the amount of space between the cell's item and the cell's border.

Syntax

[C#]
public System.Windows.Forms.Padding CellPadding { get; set; }
[Visual Basic]
Public Property CellPadding() As System.Windows.Forms.Padding

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ColumnCount Property

Gets the number of columns in this RibbonListView. This value is the larger of the RibbonListView.MinColumnCount property value and the maximum number of columns which can be displayed inside the control.

Syntax

[C#]
public int ColumnCount { get;}
[Visual Basic]
Public ReadOnly Property ColumnCount() As Integer

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ColumnWidth Property

Gets the width for each column in this RibbonListView. This value equals to the width of the RibbonListView's broadest RibbonListViewItem plus the horizontal cell padding value.

Syntax

[C#]
public int ColumnWidth { get;}
[Visual Basic]
Public ReadOnly Property ColumnWidth() As Integer

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.Deselectable Property

Gets or sets a value whether a selected RibbonListViewItem can be deselected by clicking into a cell that does not contain a RibbonListViewItem or clicking on it in combination with the pressed Ctrl key.

Syntax

[C#]
public bool Deselectable { get; set; }
[Visual Basic]
Public Property Deselectable() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.DropDownItems Property

Gets the collection of controls in the drop-down menu that is associated with this RibbonListView. These controls can be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public RibbonItemCollection DropDownItems { get; }
[Visual Basic]
Public ReadOnly Property DropDownItems() As RibbonItemCollection

Limitations & Remarks

Read only.

The RibbonListView is extended by a drop-down button to right if this collection not empty.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.HideItems Property

Gets or sets a value indicating whether the RibbonListViewItems are displayed inside the RibbonListView or not. The default value is false.

Syntax

[C#]
public bool HideItems { get; set; }
[Visual Basic]
Public Property HideItems() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.HideSelectedItems Property

Gets or sets a value indicating whether the selected RibbonListViewItems are highlighted inside the RibbonListView or not. The default value is false.

Syntax

[C#]
public bool HideSelectedItems { get; set; }
[Visual Basic]
Public Property HideSelectedItems() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ItemsSource Property

Gets or sets an array of RibbonListViewItems used to generate the content of this RibbonListView. The default value is null.

Syntax

[C#]
public RibbonListView.RibbonListViewItem[] ItemsSource { get; set; }
[Visual Basic]
Public Property ItemsSource() As RibbonListView.RibbonListViewItem()

Remarks

If this property is set to a value that is not null, all RibbonListViewItemCollection methods which can be used to change the RibbonListView's items collection are disabled.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.KeyTip Property

Gets or sets the keyboard shortcut of the RibbonListView.

Syntax

[C#]
public string KeyTip { get; }
[Visual Basic]
Public ReadOnly Property KeyTip() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.MaxVisibleRows Property

Gets or sets a value specifying the maximum number of rows that are displayed by the RibbonListView. If the value is set to null, the number of rows is not limited and the RibbonListView's height bound to the actual number of rows. The default value is null.

Syntax

[C#]
public int? MaxVisibleRows { get; set; }
[Visual Basic]
Public Property MaxVisibleRows() As Nullable(Of Integer)

Remarks

If the actual number of rows is greater than the specified maximum number of rows, the RibbonListView is extended by a scroll bar to the right. Otherwise no scroll bar is displayed.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.MinColumnCount Property

Gets or sets the minimum number of columns in this RibbonListView.

Syntax

[C#]
public int MinColumnCount { get; set; }
[Visual Basic]
Public Property MinColumnCount() As Integer

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.MultiSelect Property

Gets or sets a value indicating whether multiple items can be selected.

Syntax

[C#]
public bool MultiSelect { get; set; }
[Visual Basic]
Public Property MultiSelect() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonListView.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItems Property

Gets a collection containing all items in this RibbonListView.

Syntax

[C#]
public RibbonListView.RibbonListViewItemCollection RibbonListViewItems { get;}
[Visual Basic]
Public ReadOnly Property RibbonListViewItems() As RibbonListView.RibbonListViewItemCollection

Limitations

Read only.

If the ItemsSource property is set to a value which is not null, all RibbonListViewItemCollection methods which can be used to change this collection are disabled.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RowCount Property

Gets the number of rows in this RibbonListView.

Syntax

[C#]
public int RowCount { get;}
[Visual Basic]
Public ReadOnly Property RowCount() As Integer

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RowHeight Property

Gets the height for each row in this RibbonListView. This value equals to the height of the RibbonListView's highest RibbonListViewItem plus the vertical cell padding value.

Syntax

[C#]
public int RowHeight { get;}
[Visual Basic]
Public ReadOnly Property RowHeight() As Integer

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.SelectedIndices Property

Gets the indexes of the selected items in this RibbonListView.

Syntax

[C#]
public int[] SelectedIndices { get; set; }
[Visual Basic]
Public Property SelectedIndices() As Integer()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.SelectedItems Property

Gets the items that are selected in this RibbonListView.

Syntax

[C#]
public RibbonListView.RibbonListViewItem[] SelectedItems { get; set; }
[Visual Basic]
Public Property SelectedItems() As RibbonListView.RibbonListViewItem()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ShowBorder Property

Gets or sets a value indicating whether this RibbonListView is surrounded by a border or not. The default value is false.

Syntax

[C#]
public bool ShowBorder { get; set; }
[Visual Basic]
Public Property ShowBorder() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ShowItemsInDropDown Property

Gets or sets a value indicating whether this RibbonListView's drop down menu displays additionally to the drop down items the control's RibbonListViewItems or not. The default value is false.

Syntax

[C#]
public bool ShowItemsInDropDown { get; set; }
[Visual Basic]
Public Property ShowItemsInDropDown() As Boolean

Remarks

The RibbonListView is extended by a drop-down button to the right if this property is set to true and the actual number of rows is greater than the specified maximum number of rows.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ScrollButtonsVisible Property

Gets or sets a value whether the scroll bars buttons should be displayed or not. The default value is true.

Syntax

[C#]
public bool ShowBorder { get; set; }
[Visual Basic]
Public Property ShowBorder() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over RibbonListView's scroll bar or drop-down button.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ViewMode Property

Gets or sets the mode in which this RibbonListView displays its items. Possible values are ListViewMode.Icon, ListViewMode.Text and ListViewMode.Icon | ListViewMode.Text. The default value is ListViewMode.Icon.

Syntax

[C#]
public RibbonListView.ListViewMode ViewMode { get; set; }
[Visual Basic]
Public Property ViewMode() As RibbonListView.ListViewMode

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ScrollTo Method

Scrolls the contents of the RibbonListView to a specified RibbonListViewItem.

Syntax

[C#]
public void ScrollTo(RibbonListView.RibbonListViewItem item);
[Visual Basic]
Public Sub ScrollTo(ByVal item As RibbonListView.RibbonListViewItem)
Member | Description
item | The specified RibbonListViewItem where to scroll to.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.DropDownClosed Event

Occurs as the RibbonListView's drop-down menu is closed.

Syntax

[C#]
public event EventHandler DropDownClosed;
[Visual Basic]
Public Event DropDownClosed As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.DropDownOpening Event

Occurs as the RibbonListView's drop-down menu is opening.

Syntax

[C#]
public event EventHandler DropDownOpening;
[Visual Basic]
Public Event DropDownOpening As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ItemClick Event

Occurs as an RibbonListViewItem is clicked.

Syntax

[C#]
public event RibbonListView.RibbonListViewItemEventArgs ItemClick;
[Visual Basic]
Public Event ItemClick As RibbonListView.RibbonListViewItemEventArgs

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ItemMouseEnter Event

Occurs when the mouse pointer enters a RibbonListViewItem.

Syntax

[C#]
public event RibbonListView.RibbonListViewItemEventArgs ItemMouseEnter;
[Visual Basic]
Public Event ItemMouseEnter As RibbonListView.RibbonListViewItemEventArgs

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.ItemMouseLeave Event

Occurs when the mouse pointer leaves a RibbonListViewItem.

Syntax

[C#]
public event RibbonListView.RibbonListViewItemEventArgs ItemMouseLeave;
[Visual Basic]
Public Event ItemMouseLeave As RibbonListView.RibbonListViewItemEventArgs

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem Class

The RibbonListViewItem class represents an item in a RibbonListView control.

Introduced: 24.0.

Syntax

[C#]
public class RibbonListViewItem
[Visual Basic]
Public Class RibbonListViewItem

Constructors

Constructor | Description
RibbonListViewItem | Initializes a new instance of the RibbonListViewItem class.

Properties

Property | Description
Icon | Gets or sets the icon for this RibbonListViewItem.
Tag | Gets or sets the data associated with this RibbonListViewItem.
Text | Gets or sets the RibbonListViewItem's text
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem Constructor

Initializes a new instance of the RibbonListViewItem class.

Syntax

[C#]
public RibbonListViewItem();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem.Tag Property

Gets or sets the data associated with this RibbonListViewItem.

Syntax

[C#]
public object Tag { get; set; }
[Visual Basic]
Public Property Tag() As Object

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem.Icon Property

Gets or sets the icon for this RibbonListViewItem.

Syntax

[C#]
public System.Drawing.Image Icon { get; set; }
[Visual Basic]
Public Property Icon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem.Text Property

Gets or sets the RibbonListViewItem's text

Syntax

[C#]
public string Text { get; set; }
[Visual Basic]
Public Property Text() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItem.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection Class

An instance of the RibbonListViewItemCollection class contains controls of type RibbonListViewItem and can be obtained with the RibbonListView.RibbonListViewItems property. It is inherited from the abstract class System.Collections.CollectionBase and implements the System.Collections.IEnumerable and System.Collections.IEnumerator interfaces. The following describes only the properties, methods and events defined through the RibbonListViewItemCollection class. For a list of properties, methods and events of these classes and interfaces see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonListViewItemCollection: CollectionBase, IEnumerable, IEnumerator
[Visual Basic]
Public Class RibbonListViewItemCollection
  Inherits CollectionBase
  Implements IEnumerable
  Implements IEnumerator

Methods

Method | Description
Add | Adds an item of the type RibbonListViewItem to the end of this collection.
Item | Gets an item of type RibbonListViewItem from this collection.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection.Add Method

Adds an item of the type RibbonListViewItem to the end of this collection.

Syntax

[C#]
public int Add(RibbonListView.RibbonListViewItem item);
[Visual Basic]
Public Function Add(ByVal item As RibbonListView.RibbonListViewItem) As Integer
Parameter | Description
item | The item to be added to the end of this collection.

Return Value

The collection's index at which the value has been added.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemCollection.Item Property

Gets an item of type RibbonListViewItem from this collection. This property is the indexer for the RibbonListViewItemCollection class.

Syntax

[C#]
public RibbonListView.RibbonListViewItem this [int number] { get; }
[Visual Basic]
Public Default ReadOnly Property Item(number As Integer) As RibbonListView.RibbonListViewItem
Parameter | Description
number | The zero-based index of the item.

Return Value

The item at the specified index.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemEventArgs Class

The RibbonListViewItemEventArgs class provides data for the RibbonListView.ItemClick, ItemMouseEnter or ItemMouseLeave event. The RibbonListViewItemEventArgs class is inherited from the System.EventArgs class. The following describes only the properties, methods and events defined through the RibbonListViewItemEventArgs class. For a list of properties, methods and events inherited from the System.EventArgs class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonListViewItemEventArgs: EventArgs
[Visual Basic]
Public Class RibbonListViewItemEventArgs
  Inherits EventArgs

Properties

Property | Description
Item | Gets an object of type RibbonListViewItem that represents the handled item.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Windows.Forms.Ribbon.RibbonListView.RibbonListViewItemEventArgs.Item Property

Gets an object of type RibbonListViewItem that represents the handled item.

Syntax

[C#]
public RibbonListView.RibbonListViewItem Item { get; }
[Visual Basic]
Public ReadOnly Property Item() As RibbonListView.RibbonListViewItem

Limitations

Read only.

See Also

  • Programming Category: Drawings and Shapes
  • Graphical Overview: Drawings and Shapes


TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton Class

The RibbonMenuButton class is a button control that displays a drop-down menu when clicked. It can be added to a RibbonGroup or to another RibbonMenuButton where it is stored as an item of the drop-down menu. The drop-down menu is opened below the button if the RibbonMenuButton is part of a RibbonGroup. RibbonMenuButtons inside a drop-down menu of another RibbonMenuButton opens their drop-down menu to the right of the button. Furthermore it is the base class of the RibbonSplitButton class. The RibbonMenuButton class is inherited from the RibbonButton class. The following describes only the properties, methods and events defined through the RibbonMenuButton class.

Introduced: 24.0.

Syntax

[C#]
public class RibbonMenuButton : RibbonButton
[Visual Basic]
Public Class RibbonMenuButton
  Inherits RibbonButton

Constructors

Constructor | Description
RibbonMenuButton | Initializes a new instance of the RibbonMenuButton class.

Properties

Property | Description
Description | Gets or sets the description text that appears on this button in a RibbonMenuButton's drop down menu when the DisplayMode property of the button is set to IconTextRelation.LargeIconLabeled. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
DisplayMode | Sets the RibbonButton's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
DropDownItems | Gets the collection of controls in the drop-down menu that is associated with this RibbonMenuButton.
IsAddToQuickAccessToolbarEnabled | Gets or sets value whether the RibbonButton can be added to the quick access toolbar. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
KeyTip | Gets or sets the keyboard shortcut of the RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
LargeIcon | Gets or sets a 32x32 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
ParentCollection | Gets the RibbonItemCollection that contains this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
SmallIcon | Gets or sets a 16x16 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
Text | Overridden. Gets or sets the RibbonButton's text. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item. (Inherited from Windows.Forms.Ribbon.RibbonButton.)

Events

Event | Description
DropDownClosed | Occurs as the RibbonMenuButton's drop-down menu is closed.
DropDownOpening | Occurs as the RibbonMenuButton's drop-down menu is opening.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton Constructor

Initializes a new instance of the RibbonMenuButton class.

Syntax

[C#]
public RibbonMenuButton();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton.DropDownItems Property

Gets the collection of controls in the drop-down menu that is associated with this RibbonMenuButton. These controls can be objects of type RibbonButton, RibbonComboBox, RibbonLabel, RibbonListView, RibbonTextBox or RibbonSeperator.

Syntax

[C#]
public RibbonItemCollection DropDownItems { get; }
[Visual Basic]
Public ReadOnly Property DropDownItems() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton.DropDownClosed Event

Occurs as the RibbonMenuButton's drop-down menu is closed.

Syntax

[C#]
public event EventHandler DropDownClosed;
[Visual Basic]
Public Event DropDownClosed As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonMenuButton.DropDownOpening Event

Occurs as the RibbonMenuButton's drop-down menu is opening.

Syntax

[C#]
public event EventHandler DropDownOpening;
[Visual Basic]
Public Event DropDownOpening As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab Class

The RibbonPageLayoutTab class represents a Windows Forms ribbon tab for editing the page setup and layout. To modify a document by using these options the TextControl must be connected with the Ribbon which hosts the RibbonPageLayoutTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonPageLayoutTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonPageLayoutTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonPageLayoutTab | Initializes a new instance of the RibbonPageLayoutTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonPageLayoutTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonPageLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab Constructor

Initializes a new instance of the RibbonPageLayoutTab class.

Syntax

[C#]
public RibbonPageLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab.FindItem Method

Finds a control that has the provided RibbonPageLayoutTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonPageLayoutTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonPageLayoutTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonPageLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonPageLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_PageMargins | Identifies the PageMargins button of the RibbonPageLayoutTab.
TXITEM_Orientation | Identifies the Orientation button of the RibbonPageLayoutTab.
TXITEM_PageSize | Identifies the PageSize button of the RibbonPageLayoutTab.
TXITEM_Columns | Identifies the Columns button of the RibbonPageLayoutTab.
TXITEM_Breaks | Identifies the Breaks button of the RibbonPageLayoutTab.
TXITEM_PageColor | Identifies the PageColor button of the RibbonPageLayoutTab.
TXITEM_PageBorders | Identifies the PageBorders button of the RibbonPageLayoutTab.
TXITEM_PageLineColor | Identifies the PageLineColor button of the RibbonPageLayoutTab.
TXITEM_PageLineWidth | Identifies the PageLineWidth button of the RibbonPageLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab Class

The RibbonProofingTab class represents a Windows Forms ribbon tab for setting proofing options such as spelling, hyphenation or language settings. To enable the set language button, the TextControl must be connected with the Ribbon that hosts the RibbonProofingTab. To enable all other buttons of this tab, additionally the TextControl.SpellChecker property must be connected to an object of type TXSpellChecker

Introduced: 24.0.

Syntax

[C#]
public class RibbonProofingTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonProofingTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonProofingTab | Initializes a new instance of the RibbonProofingTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonProofingTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonProofingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab Constructor

Initializes a new instance of the RibbonProofingTab class.

Syntax

[C#]
public RibbonProofingTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab.FindItem Method

Finds a control that has the provided RibbonProofingTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonProofingTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonProofingTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonProofingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonProofingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_EnableSpellChecking | Identifies the EnableSpellChecking button of the RibbonProofingTab.
TXITEM_EnableHyphenations | Identifies the button of the RibbonProofingTab.
TXITEM_Spelling | Identifies the Spelling button of the RibbonProofingTab.
TXITEM_LoadDictionary | Identifies the LoadDictionary button of the RibbonProofingTab.
TXITEM_SpellingOptions | Identifies the SpellingOptions button of the RibbonProofingTab.
TXITEM_EnableLanguageDetection | Identifies the EnableLanguageDetection button of the RibbonProofingTab.
TXITEM_SetLanguage | Identifies the SetLanguage button of the RibbonProofingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab Class

The RibbonReportingTab class represents a Windows Forms ribbon tab to integrate mail merge and reporting functionality. To modify a document by using these options the TextControl must be connected with the Ribbon that hosts the RibbonReportingTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonReportingTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonReportingTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonReportingTab | Initializes a new instance of the RibbonReportingTab class.

Properties

Property | Description
DataSourceManager | Provides the DataSourceManager that is connected with the RibbonReportingTab.
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonReportingTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonReportingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab Constructor

Initializes a new instance of the RibbonReportingTab class.

Syntax

[C#]
public RibbonReportingTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab.DataSourceManager Property

Provides the DataSourceManager that is connected with the RibbonReportingTab.

Syntax

[C#]
public DocumentServer.DataSources.DataSourceManager DataSourceManager { get; }
[Visual Basic]
Public ReadOnly Property DataSourceManager() As DocumentServer.DataSources.DataSourceManager

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab.FindItem Method

Finds a control that has the provided RibbonReportingTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonReportingTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonReportingTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonReportingTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonReportingTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TTXITEM_DataSource | Identifies the DataSource button of the RibbonReportingTab.
TTXITEM_SelectMasterTable | Identifies the SelectMasterTable button of the RibbonReportingTab.
TTXITEM_EditDataRelations | Identifies the EditDataRelations button of the RibbonReportingTab.
TTXITEM_ConfigFile | Identifies the ConfigFile button of the RibbonReportingTab.
TTXITEM_InsertMergeField | Identifies the InsertMergeField button of the RibbonReportingTab.
TTXITEM_InsertSpecialField | Identifies the InsertSpecialField button of the RibbonReportingTab.
TTXITEM_FieldProperties | Identifies the FieldProperties button of the RibbonReportingTab.
TTXITEM_DeleteField | Identifies the DeleteField button of the RibbonReportingTab.
TTXITEM_InsertMergeBlock | Identifies the InsertMergeBlock button of the RibbonReportingTab.
TTXITEM_EditMergeBlocks | Identifies the EditMergeBlocks button of the RibbonReportingTab.
TTXITEM_ShowFieldCodes | Identifies the ShowFieldCodes button of the RibbonReportingTab.
TTXITEM_ShowFieldText | Identifies the ShowFieldText button of the RibbonReportingTab.
TTXITEM_FieldNavigation | Identifies the FieldNavigation button of the RibbonReportingTab.
TTXITEM_PreviewMergeFields | Identifies the PreviewMergeFields button of the RibbonReportingTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSeperator Class

The RibbonSeperator class represents a control that provides a seperator between elements in a HorizontalRibbonGroup, an ApplicationMenu or a drop-down menu of a RibbonMenuButton. The seperator cannot be added to the RibbonItems collection of a RibbonGroup which is not an object of type HorizontalRibbonGroup. The RibbonSeperator class is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the RibbonSeperator class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonSeperator : System.Windows.Forms.Control
[Visual Basic]
Public Class RibbonSeperator
  Inherits System.Windows.Forms.Control

Constructors

Constructor | Description
RibbonSeperator | Initializes a new instance of the RibbonSeperator class.

Properties

Property | Description
Alignment | Gets the alignment of this RibbonSeperator.
ParentCollection | Gets the RibbonItemCollection that contains this RibbonSeperator.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSeperator Constructor

Initializes a new instance of the RibbonSeperator class.

Syntax

[C#]
public RibbonSeperator();
[Visual Basic]
Public Sub New()

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSeperator.Alignment Property

Gets the alignment of this RibbonSeperator. If the seperator is added to the drop down menu of a RibbonMenuButton or to the Ribbon.ApplicationMenuItems collection the seperator is aligned horizontally. Adding the seperator to a HorizontalRibbonGroup the seperator causes a vertical alignment.

Syntax

[C#]
public RibbonSeperator.SeperatorAlignment Alignment { get; }
[Visual Basic]
Public ReadOnly Property Alignment() As RibbonSeperator.SeperatorAlignment

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSeperator.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonSeperator.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton Class

The RibbonSplitButton class is a control that has a primary button that responds to a Click event and a secondary button that displays a drop-down menu when clicked. Furthermore optionally the primary button can be used as checkable button. The RibbonSplitButton can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu. The RibbonSplitButton class is inherited from the RibbonMenuButton class. The following describes only the properties, methods and events defined through theRibbonSplitButton class.

Introduced: 24.0.

Syntax

[C#]
public class RibbonSplitButton : RibbonMenuButton
[Visual Basic]
Public Class RibbonSplitButton
  Inherits RibbonMenuButton

Constructors

Constructor | Description
RibbonSplitButton | Initializes a new instance of the RibbonSplitButton class.

Properties

Property | Description
ButtonEnabled | Gets or set a value indicating whether the primary button is enabled.
Checkable | Gets or set a value indicating whether the primary button is checkable.
Checked | Gets or set a value indicating whether the primary button is checked.
Description | Gets or sets the description text that appears on this button in a RibbonMenuButton's drop down menu when the DisplayMode property of the button is set to IconTextRelation.LargeIconLabeled. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
DisplayMode | Sets the RibbonButton's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
DropDownItems | Gets the collection of controls in the drop-down menu that is associated with this RibbonMenuButton. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
IsAddToQuickAccessToolbarEnabled | Gets or sets value whether the RibbonButton can be added to the quick access toolbar. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
KeyTip | Gets or sets the keyboard shortcut of the RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
LargeIcon | Gets or sets a 32x32 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
ParentCollection | Gets the RibbonItemCollection that contains this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
SmallIcon | Gets or sets a 16x16 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
Text | Overridden. Gets or sets the RibbonButton's text. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)

Events

Event | Description
ButtonClick | Occurs as the primary button is clicked.
CheckedChanged | Occurs when the value of the Checked property changes.
DropDownClosed | Occurs as the RibbonMenuButton's drop-down menu is closed. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)
DropDownOpening | Occurs as the RibbonMenuButton's drop-down menu is opening. (Inherited from Windows.Forms.Ribbon.RibbonMenuButton.)

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton Constructor

Initializes a new instance of the RibbonSplitButton class.

Syntax

[C#]
public RibbonSplitButton();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton.ButtonEnabled Property

Gets or set a value indicating whether the primary button is enabled.

Syntax

[C#]
public bool ButtonEnabled { get; set; }
[Visual Basic]
Public Property ButtonEnabled() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton.Checkable Property

Gets or set a value indicating whether the primary button is checkable.

Syntax

[C#]
public bool Checkable { get; set; }
[Visual Basic]
Public Property Checkable() As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton.Checked Property

Gets or set a value indicating whether the primary button is checked.

Syntax

[C#]
public bool Checked { get; set; }
[Visual Basic]
Public Property Checked() As Boolean

Remarks

A check mark icon is displayed if the SmallIcon property is set to null, the DisplayMode property value is IconTextRelation.SmallIconLabeled and the Checked property value is set to true.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton.ButtonClick Event

Occurs as the primary button is clicked.

Syntax

[C#]
public event EventHandler ButtonClick;
[Visual Basic]
Public Event ButtonClick As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonSplitButton.CheckedChanged Event

Occurs when the value of the Checked property changes.

Syntax

[C#]
public event EventHandler CheckedChanged;
[Visual Basic]
Public Event CheckedChanged As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTab Class

The RibbonTab class represents a tab in a Ribbon. A RibbonTab can be used to organize related groups of commands in a Ribbon. The RibbonTab hosts one or more RibbonGroup instances and is the base class of predefined tabs such as the RibbonFormattingTab, RibbonInsertTab, RibbonPageLayoutTab, RibbonViewTab, RibbonProofingTab, RibbonReportingTab, RibbonTableLayoutTab and the RibbonFrameLayoutTab. A RibbonGroup then hosts controls that represent application commands. A RibbonTab is inherited from the System.Windows.Forms.TabPage class. The following describes only the properties, methods and events defined through the RibbonTab class. For a list of properties, methods and events inherited from the System.Windows.Forms.TabPage class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonTab : System.Windows.Forms.TabPage
[Visual Basic]
Public Class RibbonTab
  Inherits System.Windows.Forms.TabPage

Constructors

Constructor | Description
RibbonTab | Initializes a new instance of the RibbonTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab.
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTab Constructor

Initializes a new instance of the RibbonTab class.

Syntax

[C#]
public RibbonTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTab.KeyTip Property

Gets or sets the keyboard shortcut of the RibbonTab.

Syntax

[C#]
public string KeyTip { get; }
[Visual Basic]
Public ReadOnly Property KeyTip() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTab.RibbonGroups Property

Gets a collection of all RibbonGroups in a RibbonTab. A RibbonGroup then hosts controls that represent application commands. The property value is of the type RibbonGroupCollection.

Syntax

[C#]
public RibbonGroupCollection RibbonGroups { get; }
[Visual Basic]
Public ReadOnly Property RibbonGroups() As RibbonGroupCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab Class

The RibbonTableLayoutTab class represents a Windows Forms ribbon tab for editing tables. To modify a table, a TextControl must be connected with the Ribbon which hosts the RibbonTableLayoutTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonTableLayoutTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonTableLayoutTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonTableLayoutTab | Initializes a new instance of the RibbonTableLayoutTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonTableLayoutTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonTableLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab Constructor

Initializes a new instance of the RibbonTableLayoutTab class.

Syntax

[C#]
public RibbonTableLayoutTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab.FindItem Method

Finds a control that has the provided RibbonTableLayoutTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonTableLayoutTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonTableLayoutTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTableLayoutTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonTableLayoutTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_SelectTable | Identifies the SelectTable button of the RibbonTableLayoutTab.
TXITEM_TableGridLines | Identifies the TableGridLines button of the RibbonTableLayoutTab.
TXITEM_TableProperties | Identifies the TableProperties button of the RibbonTableLayoutTab.
TXITEM_DeleteTable | Identifies the DeleteTable button of the RibbonTableLayoutTab.
TXITEM_InsertTableRowAbove | Identifies the InsertTableRowAbove button of the RibbonTableLayoutTab.
TXITEM_InsertTableRowBelow | Identifies the InsertTableRowBelow button of the RibbonTableLayoutTab.
TXITEM_InsertTableColLeft | Identifies the InsertTableColLeft button of the RibbonTableLayoutTab.
TXITEM_InsertTableColRight | Identifies the InsertTableColRight button of the RibbonTableLayoutTab.
TXITEM_MergeTableCells | Identifies the MergeTableCells button of the RibbonTableLayoutTab.
TXITEM_SplitTableCells | Identifies the SplitTableCells button of the RibbonTableLayoutTab.
TXITEM_SplitTable | Identifies the SplitTable button of the RibbonTableLayoutTab.
TXITEM_TableFrameLines | Identifies the TableFrameLines button of the RibbonTableLayoutTab.
TXITEM_TableLineColor | Identifies the TableLineColor button of the RibbonTableLayoutTab.
TXITEM_TableBackColor | Identifies the TableBackColor button of the RibbonTableLayoutTab.
TXITEM_TableLineWidth | Identifies the TableLineWidth button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopLeft | Identifies the CellAlignTopLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopCentered | Identifies the CellAlignTopCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopRight | Identifies the CellAlignTopRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignTopJustified | Identifies the CellAlignTopJustified button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleLeft | Identifies the CellAlignMiddleLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleCentered | Identifies the CellAlignMiddleCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleRight | Identifies the CellAlignMiddleRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignMiddleJustified | Identifies the CellAlignMiddleJustified button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomLeft | Identifies the CellAlignBottomLeft button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomCentered | Identifies the CellAlignBottomCentered button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomRight | Identifies the CellAlignBottomRight button of the RibbonTableLayoutTab.
TXITEM_CellAlignBottomJustified | Identifies the CellAlignBottomJustified button of the RibbonTableLayoutTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox Class

The RibbonTextBox class is a control that can be used to display or edit unformatted text. The control is inherited from the System.Windows.Forms.Control class. The following describes only the properties, methods and events defined through the RibbonTextBox class. For a list of properties, methods and events inherited from the System.Windows.Forms.Control class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonTextBox : System.Windows.Forms.Control
[Visual Basic]
Public Class RibbonTextBox
  Inherits System.Windows.Forms.Control

Constructors

Constructor | Description
RibbonTextBox | Initializes a new instance of the RibbonTextBox class.

Properties

Property | Description
DisplayMode | Sets the RibbonTextBox's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width.
KeyTip | Gets or sets the keyboard shortcut of the RibbonTextBox.
Label | Gets or sets the text that is displayed before the text box.
LargeIcon | Gets or sets a 32x32 icon for this RibbonTextBox.
ParentCollection | Gets the RibbonItemCollection that contains this RibbonTextBox.
ShowUpDownButtons | Gets or sets a value whether the text box's up down buttons are shown or not.
SmallIcon | Gets or sets a 16x16 icon for this RibbonTextBox.
Text | Overridden. Gets or sets the text that is inserted in the text box.
TextAlign | Gets or sets how text is aligned in the text box.
TextBoxLabel | Gets or sets the text that is displayed behind the text box.
TextBoxWidth | Gets or sets width of the text box.
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.
ValidationMode | Gets or sets the RibbonTextBox's input validation mode that is used to validate the inserted text in the text box.

Events

Event | Description
DownButtonClicked | Occurs as the text box's down button is clicked.
TextValidated | Occurs when text box's text is validated.
UpButtonClicked | Occurs as the text box's up button is clicked.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox Constructor

Initializes a new instance of the RibbonTextBox class.

Syntax

[C#]
public RibbonTextBox();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.DisplayMode Property

Sets the RibbonTextBox's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width. The default value is IconTextRelation.SmallIconLabeled.

Syntax

[C#]
public IconTextRelation DisplayMode { get; set; }
[Visual Basic]
Public Property DisplayMode() As IconTextRelation

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.KeyTip Property

Gets or sets the keyboard shortcut of the RibbonTextBox.

Syntax

[C#]
public string KeyTip { get; }
[Visual Basic]
Public ReadOnly Property KeyTip() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.Label Property

Gets or sets the text that is displayed before the text box.

Syntax

[C#]
public string Label { get; set; }
[Visual Basic]
Public Property Label() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.LargeIcon Property

Gets or sets a 32x32 icon for this RibbonTextBox. This icon is shown when the DisplayMode property is set to IconTextRelation.LargeIconLabeled.

Syntax

[C#]
public System.Drawing.Image LargeIcon { get; set; }
[Visual Basic]
Public Property LargeIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.ParentCollection Property

Gets the RibbonItemCollection that contains this RibbonTextBox.

Syntax

[C#]
public RibbonItemCollection ParentCollection { get}
[Visual Basic]
Public ReadOnly Property ParentCollection() As RibbonItemCollection

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.SmallIcon Property

Gets or sets a 16x16 icon for this RibbonTextBox. This icon is shown when the DisplayMode property is set to IconTextRelation.SmallIconLabeled or IconTextRelation.SmallIconUnlabeled.

Syntax

[C#]
public System.Drawing.Image SmallIcon { get; set; }
[Visual Basic]
Public Property SmallIcon() As System.Drawing.Image

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.ShowUpDownButtons Property

Gets or sets a value whether the text box's up down buttons are shown or not.

Syntax

[C#]
public bool ShowUpDownButtons  { get; set; }
[Visual Basic]
Public Property ShowUpDownButtons () As Boolean

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.Text Property

Overridden. Gets or sets the text that is inserted in the text box.

Syntax

[C#]
public override string Text { get; set; }
[Visual Basic]
Public Overrides Property Text() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.TextAlign Property

Gets or sets how text is aligned in the text box. The default value is HorizontalAlignment.Left.

Syntax

[C#]
public System.Windows.Forms.HorizontalAlignment TextAlign { get; set; }
[Visual Basic]
Public Property TextAlign() As System.Windows.Forms.HorizontalAlignment

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.TextBoxLabel Property

Gets or sets the text that is displayed behind the text box.

Syntax

[C#]
public string TextBoxLabel { get; set; }
[Visual Basic]
Public Property TextBoxLabel() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.TextBoxWidth Property

Gets or sets width of the text box. The default value is 50 px.

Syntax

[C#]
public int TextBoxWidth { get; set; }
[Visual Basic]
Public Property TextBoxWidth() As Integer

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.ToolTip Property

Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item.

Syntax

[C#]
public RibbonToolTip ToolTip { get;}
[Visual Basic]
Public ReadOnly Property ToolTip() As RibbonToolTip

Limitations

Read only.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.ValidationMode Property

Gets or sets the RibbonTextBox's input validation mode that is used to validate the inserted text in the text box.

Syntax

[C#]
public InputValidationMode ValidationMode { get; set; }
[Visual Basic]
Public Property ValidationMode() As InputValidationMode

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.DownButtonClicked Event

Occurs as the text box's down button is clicked.

Syntax

[C#]
public event EventHandler DownButtonClicked;
[Visual Basic]
Public Event DownButtonClicked As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.TextValidated Event

Occurs when text box's text is validated.

Syntax

[C#]
public event EventHandler TextValidated;
[Visual Basic]
Public Event TextValidated As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonTextBox.UpButtonClicked Event

Occurs as the text box's up button is clicked.

Syntax

[C#]
public event EventHandler UpButtonClicked;
[Visual Basic]
Public Event UpButtonClicked As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton Class

The RibbonToggleButton class is a checkable button control which can be added to a RibbonGroup or to a RibbonMenuButton where it is stored as an item of the drop-down menu. The RibbonToggleButton class is inherited from the RibbonButton class. The following describes only the properties, methods and events defined through the RibbonToggleButton class.

Introduced: 24.0.

Syntax

[C#]
public class RibbonToggleButton : RibbonButton
[Visual Basic]
Public Class RibbonToggleButton
  Inherits RibbonButton

Constructors

Constructor | Description
RibbonToggleButton | Initializes a new instance of the RibbonToggleButton class.

Properties

Property | Description
Checked | Gets or set a value indicating whether this RibbonToggleButton is checked.
Description | Gets or sets the description text that appears on this button in a RibbonMenuButton's drop down menu when the DisplayMode property of the button is set to IconTextRelation.LargeIconLabeled. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
DisplayMode | Sets the RibbonButton's superordinate display settings and gets its corresponding text icon relation rendering to the current group's width. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
IsAddToQuickAccessToolbarEnabled | Gets or sets value whether the RibbonButton can be added to the quick access toolbar. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
KeyTip | Gets or sets the keyboard shortcut of the RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
LargeIcon | Gets or sets a 32x32 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
ParentCollection | Gets the RibbonItemCollection that contains this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
SmallIcon | Gets or sets a 16x16 icon for this RibbonButton. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
Text | Overridden. Gets or sets the RibbonButton's text. (Inherited from Windows.Forms.Ribbon.RibbonButton.)
ToolTip | Gets an object of type RibbonToolTip that displays text when the mouse pointer hovers over the item. (Inherited from Windows.Forms.Ribbon.RibbonButton.)

Events

Event | Description
CheckedChanged | Occurs when the value of the Checked property changes.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton Constructor

Initializes a new instance of the RibbonToggleButton class.

Syntax

[C#]
public RibbonToggleButton();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton.Checked Property

Gets or set a value indicating whether this RibbonToggleButton is checked.

Syntax

[C#]
public bool Checked { get; set; }
[Visual Basic]
Public Property Checked() As Boolean

Remarks

A check mark icon is displayed if the SmallIcon property is set to null, the DisplayMode property value is IconTextRelation.SmallIconLabeled and the Checked property value is set to true.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToggleButton.CheckedChanged Event

Occurs when the value of the Checked property changes.

Syntax

[C#]
public event EventHandler CheckedChanged;
[Visual Basic]
Public Event CheckedChanged As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToolTip Class

The RibbonToolTip class represents a small rectangular pop-up window that displays the title and/or a brief description of a ribbon item's purpose when the user rests the pointer on the control. If neither the Title nor the Description property is set, the tool tip is not displayed. A RibbonToolTip is inherited from the System.ComponentModel.Component class. The following describes only the properties, methods and events defined through the RibbonToolTip class. For a list of properties, methods and events inherited from the System.ComponentModel.Component class see the .NET Framework reference.

Introduced: 24.0.

Syntax

[C#]
public class RibbonToolTip : System.ComponentModel.Component
[Visual Basic]
Public Class RibbonToolTip
  Inherits System.ComponentModel.Component

Properties

Property | Description
Description | Gets or sets the description for the RibbonToolTip window.
Title | Gets or sets the title for the RibbonToolTip window.

Events

Event | Description
Opening | Occurs as the the RibbonToolTip window is opening.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToolTip.Description Property

Gets or sets the description for the RibbonToolTip window.

Syntax

[C#]
public string Description { get; set; }
[Visual Basic]
Public Property Description() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToolTip.Title Property

Gets or sets the title for the RibbonToolTip window.

Syntax

[C#]
public string Title { get; set; }
[Visual Basic]
Public Property Title() As String

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonToolTip.Opening Event

Occurs as the the RibbonToolTip window is opening.

Syntax

[C#]
public event EventHandler Opening;
[Visual Basic]
Public Event Opening As EventHandler

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonViewTab Class

The RibbonViewTab class represents a Windows Forms ribbon tab for customizing the view settings. To enable these settings the TextControl must be connected with the Ribbon that hosts the RibbonViewTab.

Introduced: 24.0.

Syntax

[C#]
public class RibbonViewTab : Windows.Forms.Ribbon.RibbonTab
[Visual Basic]
Public Class RibbonViewTab
  Inherits Windows.Forms.Ribbon.RibbonTab

Constructors

Constructor | Description
RibbonViewTab | Initializes a new instance of the RibbonViewTab class.

Properties

Property | Description
KeyTip | Gets or sets the keyboard shortcut of the RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)
RibbonGroups | Gets a collection of all RibbonGroups in a RibbonTab. (Inherited from Windows.Forms.Ribbon.RibbonTab.)

Methods

Method | Description
FindItem | Finds a control that has the provided RibbonViewTab.RibbonItem identifier.

Enumerations

Enumeration | Description
RibbonItem | Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonViewTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonViewTab Constructor

Initializes a new instance of the RibbonViewTab class.

Syntax

[C#]
public RibbonViewTab();
[Visual Basic]
Public Sub New

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonViewTab.FindItem Method

Finds a control that has the provided RibbonViewTab.RibbonItem identifier.

Syntax

[C#]
public System.Windows.Forms.Control FindItem(Windows.Forms.Ribbon.RibbonViewTab.RibbonItem ribbonItem);
[Visual Basic]
Public Sub FindItem(ByVal ribbonItem  As Windows.Forms.Ribbon.RibbonViewTab.RibbonItem) As System.Windows.Forms.Control
Member | Description
ribbonItem | Specifies the identifier of the requested control.

Return Value

The requested control, if found. Otherwise null.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons


TXTextControl.Windows.Forms.Ribbon.RibbonViewTab.RibbonItem Enumeration

Each RibbonItem represents an item in a Windows.Forms.Ribbon.RibbonViewTab. The corresponding string of a RibbonItem is the same as the item's Name property. The RibbonItem enumeration can be used with the FindItem method to get an item and manipulate it.

Member | Description
TXITEM_PrintLayout | Identifies the PrintLayout button of the RibbonViewTab.
TXITEM_Draft | Identifies the Draft button of the RibbonViewTab.
TXITEM_ZoomFactor | Identifies the ZoomFactor button of the RibbonViewTab.
TXITEM_Zoom100 | Identifies the Zoom100 button of the RibbonViewTab.
TXITEM_FullPage | Identifies the FullPage button of the RibbonViewTab.
TXITEM_PageWidth | Identifies the PageWidth button of the RibbonViewTab.
TXITEM_TextWidth | Identifies the TextWidth button of the RibbonViewTab.
TXITEM_HorizontalRuler | Identifies the HorizontalRuler button of the RibbonViewTab.
TXITEM_VerticalRuler | Identifies the VerticalRuler button of the RibbonViewTab.
TXITEM_StatusBar | Identifies the StatusBar button of the RibbonViewTab.
TXITEM_ShowTableGridlines | Identifies the TableGridlines button of the RibbonViewTab.
TXITEM_ShowBookmarkMarkers | Identifies the BookmarkMarkers button of the RibbonViewTab.
TXITEM_ShowTextFrameMarkersLines | Identifies the TextFrameMarkersLines button of the RibbonViewTab.
TXITEM_ShowDrawingFrameMarkersLines | Identifies the DrawingFrameMarkersLines button of the RibbonViewTab.
TXITEM_ShowControlChars | Identifies the ControlChars button of the RibbonViewTab.
TXITEM_ShowFrameAnchors | Identifies the FrameAnchors button of the RibbonViewTab.

See Also

  • Programming Category: Windows Forms Ribbons
  • Graphical Overview: Windows Forms Ribbons