This help file is distributed to

Converter

Vector Draw Ray Tracing Engine -vdRay- is a component that can create photorealistic images using ray tracing algorithms. Simulating the behavior of natural light, vdRay converts simple lines and surfaces into vivid, natural looking objects. Through the Vector Draw component, all the existing documents and drawings VectorDraw supports can be rendered taking into consideration certain properties such as reflection, transparency, surface roughness etc. thus exporting images and videos that look realistic. New effects, that weren't possible so far(shadows, glass or diamond looking objects, mirrors and more) can now be created and demonstrated. The vdRay component is very easy to use and the visual benefits are more than impressive.

  • You can take your first taste of vdRay by reading the Introduction Step by Step pdf help file, located in the vdRay\HelpFiles\Tutorials directory, inside your Vector Draw installation folder.
  • Or you can use one of the example applications provided with your setup, located in the vdRay\HelpFiles\Samples directory, inside your Vector Draw installation folder.


%%phrase%%

vdRay Send comments on this topic.
vdRay Assembly

Namespaces

Namespace | Description
vdRay |
vdRay.Dialogs |

© MyCompany. All Rights Reserved.


%%ItemTitle%%

vdRay Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
Radiosity | Radiosity is an algorithm that simulates the natural light when illuminating the objects of a scene, creating more realistic images. What Radiosity does is taking into consideration all of the neighbor objects' lighting amount when calculating how bright or dark a specific object will be. Thus said, it's understandable that Radiosity is a quite heavy algorithm that can take many minutes or even hours to render a mid sized bitmap. Radiosity has many properties that affect the quality and time consumption. The benefit of this technique is a big improvement in terms of photorealism, since the output picture can be very realistic. A side benefit is that the ambient light of all the objects of the scene don't have to be set (optional), saving time out of constant testing.
vdPointView | Represents the camera position, direction and twist angle when rendering an image or creating a video.
vdPointViews | An vdArray of vdPointVies objects.
vdRayComponent | The main class of the vdRay component that stores all the properties and calls the necessary methods in order to create photorealistic bitmaps.
vdRayComponent.ErrorMessages |
vdRayComponent.RefreshFrameParams | The parameters passed every time a refresh event is fired.
vdRayGlobals | Contains global constant values of the component.
VdVideo | The class used to store the bitmaps (frames) created by vdRay, when a video is created.

Enumerations

Enumeration | Description
Radiosity.OnOff |
Radiosity.RadiosityPredefined | Predefined settings for use of Radiosity;
vdRayComponent.ErrorMessages.errorNo |
vdRayComponent.RenderFlagsEnum | The various flags of the rendering.
vdRayComponent.RenderState |

See Also

Reference

vdRay Assembly


%%PageItemTitle%%

Radiosity Class
See Also Members
[image]
vdRay Namespace : Radiosity Class

Radiosity is an algorithm that simulates the natural light when illuminating the objects of a scene, creating more realistic images. What Radiosity does is taking into consideration all of the neighbor objects' lighting amount when calculating how bright or dark a specific object will be. Thus said, it's understandable that Radiosity is a quite heavy algorithm that can take many minutes or even hours to render a mid sized bitmap. Radiosity has many properties that affect the quality and time consumption. The benefit of this technique is a big improvement in terms of photorealism, since the output picture can be very realistic. A side benefit is that the ambient light of all the objects of the scene don't have to be set (optional), saving time out of constant testing.

Syntax

Visual Basic (Declaration)
Public Class Radiosity
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
C#
public class Radiosity

Inheritance Hierarchy

System.Object
vdRay.Radiosity

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

Radiosity Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

Radiosity Class Members
See Also Properties Methods
[image]
vdRay Namespace : Radiosity Class

The following tables list the members exposed by Radiosity.

Public Constructors

 | Name | Description
Public Constructor | Radiosity Constructor |
Top

Public Properties

Name | Description
Public Property | adc_bailout | In scenes with many reflective and transparent surfaces, vdRay can get bogged down tracing multiple reflections and refractions that contribute very little to the color of a particular pixel. The program uses a system called Adaptive Depth Control (ADC) to stop computing additional reflected or refracted rays when their contribution is insignificant. You may use the adc_bailout property set to a float value to specify the point at which a ray's contribution is considered insignificant. The default value is 1/255, or approximately 0.0039, since a change smaller than that could not be visible in a 24 bit image. Generally this setting is perfectly adequate and should be left alone.
Public Property | always_sample | You can force POV-Ray to only use the data from the pretrace step and not gather any new samples during the final radiosity pass. This may reduce splotchiness. To do this, set always_sample to off (the default value is on).
Public Property | brightness | The brightness property specifies a float value that is the degree to which objects are brightened before being returned upwards to the rest of the system. The default value is 1.0. Brightness should be balanced with your ambient and diffuse values as well as your light_source intensity. Remember that brightness doesn't refer directly to the overall scene brightness, it refers to the radiosity calculation which affects the overall scene brightness. This distinction is important, because we can use it to change the contrast of some indirectly lit areas.
Public Property | count | The number of rays sent out whenever a new radiosity value has to be calculated. Count is ont of the main speed/quality factors (higher count values result in higher rendering times). Max value 1600;
Public Property | error_bound | The error_bound float value is one of the two main speed/quality tuning values (the other is count, the number of rays shot). It is intended to mean the fraction of error tolerated. For example, if it were set to 1 the algorithm would not calculate a new value until the error on the last one was estimated to be 100%. Ignoring the error introduced by rotation for the moment, on flat surfaces this is equal to the fraction of the reuse distance, which in turn is the distance to the closest item hit. If you have an old sample on the floor 10 distance units from a wall, an error bound of 0.5 will get you a new sample at a distance of about 5 distance units from the wall. The default value of 1.8 is good for a smooth general lighting effect, but may render corners or smaller shadows incorrectly. Using lower values is more accurate, but it will increase the danger of artifacts and therefore require a higher count value. You can use values lower than 0.1 but both render time and memory use can become extremely high then.
Public Property | gray_threshold | Diffusely inter-reflected light is a function of the objects around the point in question. Since this is recursively defined to millions of levels of recursion in any real-life scene, every point is illuminated at least in part by every other part of the scene. Since we cannot afford to compute this, if we only do one bounce, the calculated ambient light is very strongly affected by the colors of the objects near it. This is known as color bleed. The gray_threshold float value desaturates the colored light a little to make your scene more visually correct. A value of 0.6 means to calculate the ambient value as 60 of the equivalent gray value calculated, plus 40 of the actual value calculated. At 0.0, this feature does nothing. At 1.0, you will get 100% pure white/gray ambient light, with no hue.
Public Property | low_error_factor | If you calculate just enough samples, but no more, you will get an image which has slightly blotchy lighting. What you want is just a few extra samples interspersed, so that the blending will be nice and smooth. The solution to this is the mosaic preview, controlled by pretrace: it goes over the image one or more times beforehand, calculating radiosity values. To ensure that you get a few extra samples, the radiosity algorithm lowers the error bound during the initial pass or passes, then sets it back just before the final pass. The low_error_factor is a float tuning value which sets the amount that the error bound is dropped during the preliminary image passes. If the low error factor is 0.8 and the error bound is set to 0.4 it will use an error bound of 0.32 (0.4 × 0.8) during the initial passes and 0.4 on the final pass. The default value for low_error_factor is 0.5.
Public Property | max_sample | Sometimes very bright objects can cause problems with splotchiness. The max_sample keyword attempts to address this. Max_sample takes a float parameter which specifies the brightest that any gathered sample is allowed to be. Any samples brighter than this will have their brightness decreased (without affecting color). Specifying a non-positive value for max_sample will allow samples to have any brightness level.
Public Property | minimum_reuse | This is the fraction of the screen width which sets the minimum radius of reuse for each sample point. For example, if the value is 0.02, the radius of maximum reuse for every sample is set to whatever ground distance corresponds to 2% of the width of the screen.
Public Property | nearest_count | The nearest_count integer value is the minimum number of old ambient values blended together to create a new interpolated value. The total number blended will vary depending on error_bound. All previous values that fit within the specified error_bound will be used in the average. The default is 5, and the maximum is 20. Raising nearest_count can significantly reduce or smooth out splotchiness, since more nearby values will be averaged. As always, there is a corresponding speed penalty, but using higher values like 10 or even 20 for the final trace may help remove artifacts. Some artifacts can also be removed by adjusting the count parameter.
Public Property | normal | Radiosity estimation can be affected by normals. To enable this feature, set normal to on. The default is off.
Public Property | PredefinedQuality | A collection of predefined setting to use Radiosity easily.
Public Property | pretrace_end | To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.
Public Property | pretrace_start | To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.
Public Property | recursion_limit | The recursion_limit is an integer value which determines how many recursion levels are used to calculate the diffuse inter-reflection. The default value is 3, the upper limit is 20. This represents the number of times light bounces off objects before reaching your eye. In the real world, this could be a very high number. In POV-Ray, higher is not always better. Values between 2 and 4 tend to give good results for most scenes. Higher values can have a significant speed penalty. It is recommended that you use the lowest value that gets the look you want in your scene. Note that the number of recursions can affect both the brightness and contrast of your indirectly-lit objects, which means that test tuning with a significantly different recursion level than what you intend to do the final trace with may have unexpected results.
Public Property | UseAmbientLight | If false, the Ambient value of objects' pencolor will be ignored and the illumination of these objects will be calculated by the Radiosity algorithm.
Public Property | UseRadiosity | If true, the Radiosity algorithm will be used to calculate the illumination of every object in the scene.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Radiosity Class
vdRay Namespace


%%PageItemTitle%%

Radiosity Constructor
See Also
[image]
vdRay Namespace > Radiosity Class : Radiosity Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Radiosity()
C#
public Radiosity()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%% $$Methods$$

Radiosity Class Methods
[image]
vdRay Namespace : Radiosity Class

For a list of all members of this type, see Radiosity members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

Radiosity Class
vdRay Namespace


%%PageItemTitle%%

ToString Method
[image]
vdRay Namespace > Radiosity Class : ToString Method

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As String

value = instance.ToString()
C#
public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%% $$Properties$$

Radiosity Class Properties
[image]
vdRay Namespace : Radiosity Class

For a list of all members of this type, see Radiosity members.

Public Properties

Name | Description
Public Property | adc_bailout | In scenes with many reflective and transparent surfaces, vdRay can get bogged down tracing multiple reflections and refractions that contribute very little to the color of a particular pixel. The program uses a system called Adaptive Depth Control (ADC) to stop computing additional reflected or refracted rays when their contribution is insignificant. You may use the adc_bailout property set to a float value to specify the point at which a ray's contribution is considered insignificant. The default value is 1/255, or approximately 0.0039, since a change smaller than that could not be visible in a 24 bit image. Generally this setting is perfectly adequate and should be left alone.
Public Property | always_sample | You can force POV-Ray to only use the data from the pretrace step and not gather any new samples during the final radiosity pass. This may reduce splotchiness. To do this, set always_sample to off (the default value is on).
Public Property | brightness | The brightness property specifies a float value that is the degree to which objects are brightened before being returned upwards to the rest of the system. The default value is 1.0. Brightness should be balanced with your ambient and diffuse values as well as your light_source intensity. Remember that brightness doesn't refer directly to the overall scene brightness, it refers to the radiosity calculation which affects the overall scene brightness. This distinction is important, because we can use it to change the contrast of some indirectly lit areas.
Public Property | count | The number of rays sent out whenever a new radiosity value has to be calculated. Count is ont of the main speed/quality factors (higher count values result in higher rendering times). Max value 1600;
Public Property | error_bound | The error_bound float value is one of the two main speed/quality tuning values (the other is count, the number of rays shot). It is intended to mean the fraction of error tolerated. For example, if it were set to 1 the algorithm would not calculate a new value until the error on the last one was estimated to be 100%. Ignoring the error introduced by rotation for the moment, on flat surfaces this is equal to the fraction of the reuse distance, which in turn is the distance to the closest item hit. If you have an old sample on the floor 10 distance units from a wall, an error bound of 0.5 will get you a new sample at a distance of about 5 distance units from the wall. The default value of 1.8 is good for a smooth general lighting effect, but may render corners or smaller shadows incorrectly. Using lower values is more accurate, but it will increase the danger of artifacts and therefore require a higher count value. You can use values lower than 0.1 but both render time and memory use can become extremely high then.
Public Property | gray_threshold | Diffusely inter-reflected light is a function of the objects around the point in question. Since this is recursively defined to millions of levels of recursion in any real-life scene, every point is illuminated at least in part by every other part of the scene. Since we cannot afford to compute this, if we only do one bounce, the calculated ambient light is very strongly affected by the colors of the objects near it. This is known as color bleed. The gray_threshold float value desaturates the colored light a little to make your scene more visually correct. A value of 0.6 means to calculate the ambient value as 60 of the equivalent gray value calculated, plus 40 of the actual value calculated. At 0.0, this feature does nothing. At 1.0, you will get 100% pure white/gray ambient light, with no hue.
Public Property | low_error_factor | If you calculate just enough samples, but no more, you will get an image which has slightly blotchy lighting. What you want is just a few extra samples interspersed, so that the blending will be nice and smooth. The solution to this is the mosaic preview, controlled by pretrace: it goes over the image one or more times beforehand, calculating radiosity values. To ensure that you get a few extra samples, the radiosity algorithm lowers the error bound during the initial pass or passes, then sets it back just before the final pass. The low_error_factor is a float tuning value which sets the amount that the error bound is dropped during the preliminary image passes. If the low error factor is 0.8 and the error bound is set to 0.4 it will use an error bound of 0.32 (0.4 × 0.8) during the initial passes and 0.4 on the final pass. The default value for low_error_factor is 0.5.
Public Property | max_sample | Sometimes very bright objects can cause problems with splotchiness. The max_sample keyword attempts to address this. Max_sample takes a float parameter which specifies the brightest that any gathered sample is allowed to be. Any samples brighter than this will have their brightness decreased (without affecting color). Specifying a non-positive value for max_sample will allow samples to have any brightness level.
Public Property | minimum_reuse | This is the fraction of the screen width which sets the minimum radius of reuse for each sample point. For example, if the value is 0.02, the radius of maximum reuse for every sample is set to whatever ground distance corresponds to 2% of the width of the screen.
Public Property | nearest_count | The nearest_count integer value is the minimum number of old ambient values blended together to create a new interpolated value. The total number blended will vary depending on error_bound. All previous values that fit within the specified error_bound will be used in the average. The default is 5, and the maximum is 20. Raising nearest_count can significantly reduce or smooth out splotchiness, since more nearby values will be averaged. As always, there is a corresponding speed penalty, but using higher values like 10 or even 20 for the final trace may help remove artifacts. Some artifacts can also be removed by adjusting the count parameter.
Public Property | normal | Radiosity estimation can be affected by normals. To enable this feature, set normal to on. The default is off.
Public Property | PredefinedQuality | A collection of predefined setting to use Radiosity easily.
Public Property | pretrace_end | To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.
Public Property | pretrace_start | To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.
Public Property | recursion_limit | The recursion_limit is an integer value which determines how many recursion levels are used to calculate the diffuse inter-reflection. The default value is 3, the upper limit is 20. This represents the number of times light bounces off objects before reaching your eye. In the real world, this could be a very high number. In POV-Ray, higher is not always better. Values between 2 and 4 tend to give good results for most scenes. Higher values can have a significant speed penalty. It is recommended that you use the lowest value that gets the look you want in your scene. Note that the number of recursions can affect both the brightness and contrast of your indirectly-lit objects, which means that test tuning with a significantly different recursion level than what you intend to do the final trace with may have unexpected results.
Public Property | UseAmbientLight | If false, the Ambient value of objects' pencolor will be ignored and the illumination of these objects will be calculated by the Radiosity algorithm.
Public Property | UseRadiosity | If true, the Radiosity algorithm will be used to calculate the illumination of every object in the scene.
Top

See Also

Reference

Radiosity Class
vdRay Namespace


%%PageItemTitle%%

adc_bailout Property
[image]
vdRay Namespace > Radiosity Class : adc_bailout Property

In scenes with many reflective and transparent surfaces, vdRay can get bogged down tracing multiple reflections and refractions that contribute very little to the color of a particular pixel. The program uses a system called Adaptive Depth Control (ADC) to stop computing additional reflected or refracted rays when their contribution is insignificant. You may use the adc_bailout property set to a float value to specify the point at which a ray's contribution is considered insignificant. The default value is 1/255, or approximately 0.0039, since a change smaller than that could not be visible in a 24 bit image. Generally this setting is perfectly adequate and should be left alone.

Syntax

Visual Basic (Declaration)
Public Property adc_bailout As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.adc_bailout = value

value = instance.adc_bailout
C#
public double adc_bailout {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

always_sample Property
[image]
vdRay Namespace > Radiosity Class : always_sample Property

You can force POV-Ray to only use the data from the pretrace step and not gather any new samples during the final radiosity pass. This may reduce splotchiness. To do this, set always_sample to off (the default value is on).

Syntax

Visual Basic (Declaration)
Public Property always_sample As Radiosity.OnOff
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Radiosity.OnOff

instance.always_sample = value

value = instance.always_sample
C#
public Radiosity.OnOff always_sample {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

brightness Property
[image]
vdRay Namespace > Radiosity Class : brightness Property

The brightness property specifies a float value that is the degree to which objects are brightened before being returned upwards to the rest of the system. The default value is 1.0. Brightness should be balanced with your ambient and diffuse values as well as your light_source intensity. Remember that brightness doesn't refer directly to the overall scene brightness, it refers to the radiosity calculation which affects the overall scene brightness. This distinction is important, because we can use it to change the contrast of some indirectly lit areas.

Syntax

Visual Basic (Declaration)
Public Property brightness As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.brightness = value

value = instance.brightness
C#
public double brightness {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

count Property
[image]
vdRay Namespace > Radiosity Class : count Property

The number of rays sent out whenever a new radiosity value has to be calculated. Count is ont of the main speed/quality factors (higher count values result in higher rendering times). Max value 1600;

Syntax

Visual Basic (Declaration)
Public Property count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Integer

instance.count = value

value = instance.count
C#
public int count {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

error_bound Property
[image]
vdRay Namespace > Radiosity Class : error_bound Property

The error_bound float value is one of the two main speed/quality tuning values (the other is count, the number of rays shot). It is intended to mean the fraction of error tolerated. For example, if it were set to 1 the algorithm would not calculate a new value until the error on the last one was estimated to be 100%. Ignoring the error introduced by rotation for the moment, on flat surfaces this is equal to the fraction of the reuse distance, which in turn is the distance to the closest item hit. If you have an old sample on the floor 10 distance units from a wall, an error bound of 0.5 will get you a new sample at a distance of about 5 distance units from the wall. The default value of 1.8 is good for a smooth general lighting effect, but may render corners or smaller shadows incorrectly. Using lower values is more accurate, but it will increase the danger of artifacts and therefore require a higher count value. You can use values lower than 0.1 but both render time and memory use can become extremely high then.

Syntax

Visual Basic (Declaration)
Public Property error_bound As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.error_bound = value

value = instance.error_bound
C#
public double error_bound {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

gray_threshold Property
[image]
vdRay Namespace > Radiosity Class : gray_threshold Property

Diffusely inter-reflected light is a function of the objects around the point in question. Since this is recursively defined to millions of levels of recursion in any real-life scene, every point is illuminated at least in part by every other part of the scene. Since we cannot afford to compute this, if we only do one bounce, the calculated ambient light is very strongly affected by the colors of the objects near it. This is known as color bleed. The gray_threshold float value desaturates the colored light a little to make your scene more visually correct. A value of 0.6 means to calculate the ambient value as 60 of the equivalent gray value calculated, plus 40 of the actual value calculated. At 0.0, this feature does nothing. At 1.0, you will get 100% pure white/gray ambient light, with no hue.

Syntax

Visual Basic (Declaration)
Public Property gray_threshold As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.gray_threshold = value

value = instance.gray_threshold
C#
public double gray_threshold {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

low_error_factor Property
[image]
vdRay Namespace > Radiosity Class : low_error_factor Property

If you calculate just enough samples, but no more, you will get an image which has slightly blotchy lighting. What you want is just a few extra samples interspersed, so that the blending will be nice and smooth. The solution to this is the mosaic preview, controlled by pretrace: it goes over the image one or more times beforehand, calculating radiosity values. To ensure that you get a few extra samples, the radiosity algorithm lowers the error bound during the initial pass or passes, then sets it back just before the final pass. The low_error_factor is a float tuning value which sets the amount that the error bound is dropped during the preliminary image passes. If the low error factor is 0.8 and the error bound is set to 0.4 it will use an error bound of 0.32 (0.4 × 0.8) during the initial passes and 0.4 on the final pass. The default value for low_error_factor is 0.5.

Syntax

Visual Basic (Declaration)
Public Property low_error_factor As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.low_error_factor = value

value = instance.low_error_factor
C#
public double low_error_factor {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

max_sample Property
[image]
vdRay Namespace > Radiosity Class : max_sample Property

Sometimes very bright objects can cause problems with splotchiness. The max_sample keyword attempts to address this. Max_sample takes a float parameter which specifies the brightest that any gathered sample is allowed to be. Any samples brighter than this will have their brightness decreased (without affecting color). Specifying a non-positive value for max_sample will allow samples to have any brightness level.

Syntax

Visual Basic (Declaration)
Public Property max_sample As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.max_sample = value

value = instance.max_sample
C#
public double max_sample {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

minimum_reuse Property
[image]
vdRay Namespace > Radiosity Class : minimum_reuse Property

This is the fraction of the screen width which sets the minimum radius of reuse for each sample point. For example, if the value is 0.02, the radius of maximum reuse for every sample is set to whatever ground distance corresponds to 2% of the width of the screen.

Syntax

Visual Basic (Declaration)
Public Property minimum_reuse As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.minimum_reuse = value

value = instance.minimum_reuse
C#
public double minimum_reuse {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

nearest_count Property
[image]
vdRay Namespace > Radiosity Class : nearest_count Property

The nearest_count integer value is the minimum number of old ambient values blended together to create a new interpolated value. The total number blended will vary depending on error_bound. All previous values that fit within the specified error_bound will be used in the average. The default is 5, and the maximum is 20. Raising nearest_count can significantly reduce or smooth out splotchiness, since more nearby values will be averaged. As always, there is a corresponding speed penalty, but using higher values like 10 or even 20 for the final trace may help remove artifacts. Some artifacts can also be removed by adjusting the count parameter.

Syntax

Visual Basic (Declaration)
Public Property nearest_count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Integer

instance.nearest_count = value

value = instance.nearest_count
C#
public int nearest_count {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

normal Property
[image]
vdRay Namespace > Radiosity Class : normal Property

Radiosity estimation can be affected by normals. To enable this feature, set normal to on. The default is off.

Syntax

Visual Basic (Declaration)
Public Property normal As Radiosity.OnOff
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Radiosity.OnOff

instance.normal = value

value = instance.normal
C#
public Radiosity.OnOff normal {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

PredefinedQuality Property
[image]
vdRay Namespace > Radiosity Class : PredefinedQuality Property

A collection of predefined setting to use Radiosity easily.

Syntax

Visual Basic (Declaration)
Public Property PredefinedQuality As Radiosity.RadiosityPredefined
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Radiosity.RadiosityPredefined

instance.PredefinedQuality = value

value = instance.PredefinedQuality
C#
public Radiosity.RadiosityPredefined PredefinedQuality {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

pretrace_end Property
[image]
vdRay Namespace > Radiosity Class : pretrace_end Property

To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.

Syntax

Visual Basic (Declaration)
Public Property pretrace_end As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.pretrace_end = value

value = instance.pretrace_end
C#
public double pretrace_end {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

pretrace_start Property
[image]
vdRay Namespace > Radiosity Class : pretrace_start Property

To control the radiosity pre-trace gathering step, use the pretrace_start and pretrace_end properties of radiosity. Each of these is defined by a float value between 0.0 and 1.0 which specifies the size of the blocks in the mosaic preview as a percentage of the image size. The defaults are 0.08 for pretrace_start and 0.04 for pretrace_end. These pretrace settings can be used to balance speed against quality. The pretrace parameters help POV-Ray determine where more radiosity samples are needed. For a final high-quality render, it's generally best to keep the pretrace_start setting around the default value, but have a much smaller pretrace_end setting, such as 0.005.

Syntax

Visual Basic (Declaration)
Public Property pretrace_start As Double
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Double

instance.pretrace_start = value

value = instance.pretrace_start
C#
public double pretrace_start {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

recursion_limit Property
[image]
vdRay Namespace > Radiosity Class : recursion_limit Property

The recursion_limit is an integer value which determines how many recursion levels are used to calculate the diffuse inter-reflection. The default value is 3, the upper limit is 20. This represents the number of times light bounces off objects before reaching your eye. In the real world, this could be a very high number. In POV-Ray, higher is not always better. Values between 2 and 4 tend to give good results for most scenes. Higher values can have a significant speed penalty. It is recommended that you use the lowest value that gets the look you want in your scene. Note that the number of recursions can affect both the brightness and contrast of your indirectly-lit objects, which means that test tuning with a significantly different recursion level than what you intend to do the final trace with may have unexpected results.

Syntax

Visual Basic (Declaration)
Public Property recursion_limit As Integer
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Integer

instance.recursion_limit = value

value = instance.recursion_limit
C#
public int recursion_limit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

UseAmbientLight Property
[image]
vdRay Namespace > Radiosity Class : UseAmbientLight Property

If false, the Ambient value of objects' pencolor will be ignored and the illumination of these objects will be calculated by the Radiosity algorithm.

Syntax

Visual Basic (Declaration)
Public Property UseAmbientLight As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Boolean

instance.UseAmbientLight = value

value = instance.UseAmbientLight
C#
public bool UseAmbientLight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

UseRadiosity Property
[image]
vdRay Namespace > Radiosity Class : UseRadiosity Property

If true, the Radiosity algorithm will be used to calculate the illumination of every object in the scene.

Syntax

Visual Basic (Declaration)
Public Property UseRadiosity As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Radiosity
Dim value As Boolean

instance.UseRadiosity = value

value = instance.UseRadiosity
C#
public bool UseRadiosity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Radiosity Class
Radiosity Members


%%PageItemTitle%%

vdPointView Class
See Also Members
[image]
vdRay Namespace : vdPointView Class

Represents the camera position, direction and twist angle when rendering an image or creating a video.

Syntax

Visual Basic (Declaration)
Public Class vdPointView
   Implements IvdPointView
Visual Basic (Usage) Copy Code
Dim instance As vdPointView
C#
public class vdPointView : IvdPointView

Inheritance Hierarchy

System.Object
vdRay.vdPointView

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdPointView Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdPointView Class Members
See Also Properties
[image]
vdRay Namespace : vdPointView Class

The following tables list the members exposed by vdPointView.

Public Constructors

 | Name | Description
Public Constructor | vdPointView Constructor | Overloaded. Initializes a new instance of the vdPointView class.
Top

Public Properties

 | Name | Description
Public Property | CameraPosition | The position of the camera.
Public Property | TargetDirection | The direction, the camera will face.
Public Property | TwistAngle | The angle that the camera is twisted.
Top

See Also

Reference

vdPointView Class
vdRay Namespace


%%PageItemTitle%%

vdPointView Constructor
[image]
vdRay Namespace > vdPointView Class : vdPointView Constructor

Initializes a new instance of the vdPointView class.

Overload List

Overload | Description
vdPointView Constructor() | Initializes a new instance of the vdPointView class.
vdPointView Constructor(gPoint,gPoint) | Initializes a new instance of the vdPointView class.
vdPointView Constructor(gPoint,Vector) | Initializes a new instance of the vdPointView class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members


%%PageItemTitle%%

vdPointView Constructor()
See Also
[image]
vdRay Namespace > vdPointView Class > vdPointView Constructor : vdPointView Constructor()

Initializes a new instance of the vdPointView class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As vdPointView()
C#
public vdPointView()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members
Overload List


%%PageItemTitle%%

vdPointView Constructor(gPoint,gPoint)
See Also
[image]
vdRay Namespace > vdPointView Class > vdPointView Constructor : vdPointView Constructor(gPoint,gPoint)

cameraposition
The position of the camera.
targetPosition
The point, the camera will look towards.
Initializes a new instance of the vdPointView class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cameraposition As gPoint, _
   ByVal targetPosition As gPoint _
)
Visual Basic (Usage) Copy Code
Dim cameraposition As gPoint
Dim targetPosition As gPoint

Dim instance As vdPointView(cameraposition, targetPosition)
C#
public vdPointView(
   gPoint cameraposition,
   gPoint targetPosition
)

Parameters

cameraposition
The position of the camera.
targetPosition
The point, the camera will look towards.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members
Overload List


%%PageItemTitle%%

vdPointView Constructor(gPoint,Vector)
See Also
[image]
vdRay Namespace > vdPointView Class > vdPointView Constructor : vdPointView Constructor(gPoint,Vector)

cameraposition
The position of the camera.
targetDirection
The direction, the camera will face.
Initializes a new instance of the vdPointView class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cameraposition As gPoint, _
   ByVal targetDirection As Vector _
)
Visual Basic (Usage) Copy Code
Dim cameraposition As gPoint
Dim targetDirection As Vector

Dim instance As vdPointView(cameraposition, targetDirection)
C#
public vdPointView(
   gPoint cameraposition,
   Vector targetDirection
)

Parameters

cameraposition
The position of the camera.
targetDirection
The direction, the camera will face.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members
Overload List


%%PageItemTitle%% $$Properties$$

vdPointView Class Properties
[image]
vdRay Namespace : vdPointView Class

For a list of all members of this type, see vdPointView members.

Public Properties

 | Name | Description
Public Property | CameraPosition | The position of the camera.
Public Property | TargetDirection | The direction, the camera will face.
Public Property | TwistAngle | The angle that the camera is twisted.
Top

See Also

Reference

vdPointView Class
vdRay Namespace


%%PageItemTitle%%

CameraPosition Property
[image]
vdRay Namespace > vdPointView Class : CameraPosition Property

The position of the camera.

Syntax

Visual Basic (Declaration)
Public Property CameraPosition As gPoint
Visual Basic (Usage) Copy Code
Dim instance As vdPointView
Dim value As gPoint

instance.CameraPosition = value

value = instance.CameraPosition
C#
public gPoint CameraPosition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members


%%PageItemTitle%%

TargetDirection Property
[image]
vdRay Namespace > vdPointView Class : TargetDirection Property

The direction, the camera will face.

Syntax

Visual Basic (Declaration)
Public Property TargetDirection As Vector
Visual Basic (Usage) Copy Code
Dim instance As vdPointView
Dim value As Vector

instance.TargetDirection = value

value = instance.TargetDirection
C#
public Vector TargetDirection {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members


%%PageItemTitle%%

TwistAngle Property
[image]
vdRay Namespace > vdPointView Class : TwistAngle Property

The angle that the camera is twisted.

Syntax

Visual Basic (Declaration)
Public Property TwistAngle As Double
Visual Basic (Usage) Copy Code
Dim instance As vdPointView
Dim value As Double

instance.TwistAngle = value

value = instance.TwistAngle
C#
public double TwistAngle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointView Class
vdPointView Members


%%PageItemTitle%%

vdPointViews Class
See Also Members
[image]
vdRay Namespace : vdPointViews Class

An vdArray of vdPointVies objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class vdPointViews
   Implements IvdPointViews
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
C#
public class vdPointViews : IvdPointViews

Inheritance Hierarchy

System.Object
vdRay.vdPointViews

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdPointViews Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdPointViews Class Members
See Also Properties Methods
[image]
vdRay Namespace : vdPointViews Class

The following tables list the members exposed by vdPointViews.

Public Constructors

 | Name | Description
Public Constructor | vdPointViews Constructor | Overloaded. Initializes a new instance of the vdPointViews class.
Top

Public Properties

 | Name | Description
Public Property | Count | The ammount of vdPointView items in the Array.
Public Property | Item | The vdPointView item in the specified position.
Public Property | Last | The last item in the array.
Top

Public Methods

 | Name | Description
Public Method | AddItem | Adds a new vdPointView item in the array.
Public Method | GetEnumerator | Returns the Enumerator of the vdArray of the object.
Public Method | InsertAt | Inserts an item at the specified index.
Public Method | RemoveAll | Clears the vdPointViews array of all its items.
Public Method | RemoveAt | Removes the item at the specified index.
Top

See Also

Reference

vdPointViews Class
vdRay Namespace


%%PageItemTitle%%

vdPointViews Constructor
[image]
vdRay Namespace > vdPointViews Class : vdPointViews Constructor

Initializes a new instance of the vdPointViews class.

Overload List

Overload | Description
vdPointViews Constructor() | Initializes a new instance of the vdPointViews class.
vdPointViews Constructor(gPoint[]) | Initializes a new instance of the vdPointViews class.
vdPointViews Constructor(vdPointView[]) | Initializes a new instance of the vdPointViews class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

vdPointViews Constructor()
See Also
[image]
vdRay Namespace > vdPointViews Class > vdPointViews Constructor : vdPointViews Constructor()

Initializes a new instance of the vdPointViews class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews()
C#
public vdPointViews()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members
Overload List


%%PageItemTitle%%

vdPointViews Constructor(gPoint[])
See Also
[image]
vdRay Namespace > vdPointViews Class > vdPointViews Constructor : vdPointViews Constructor(gPoint[])

items
An array of gPoint objects to be added in the new vdPointViews instance. Direction of the each vdPointView will be set the direction between the current and the next gPoint.
Initializes a new instance of the vdPointViews class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As gPoint _
)
Visual Basic (Usage) Copy Code
Dim items() As gPoint

Dim instance As vdPointViews(items)
C#
public vdPointViews(
   gPoint[] items
)

Parameters

items
An array of gPoint objects to be added in the new vdPointViews instance. Direction of the each vdPointView will be set the direction between the current and the next gPoint.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members
Overload List


%%PageItemTitle%%

vdPointViews Constructor(vdPointView[])
See Also
[image]
vdRay Namespace > vdPointViews Class > vdPointViews Constructor : vdPointViews Constructor(vdPointView[])

items
An array of vdPointView objects to be added in the new vdPointViews instance.
Initializes a new instance of the vdPointViews class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items() As vdPointView _
)
Visual Basic (Usage) Copy Code
Dim items() As vdPointView

Dim instance As vdPointViews(items)
C#
public vdPointViews(
   vdPointView[] items
)

Parameters

items
An array of vdPointView objects to be added in the new vdPointViews instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members
Overload List


%%PageItemTitle%% $$Methods$$

vdPointViews Class Methods
[image]
vdRay Namespace : vdPointViews Class

For a list of all members of this type, see vdPointViews members.

Public Methods

 | Name | Description
Public Method | AddItem | Adds a new vdPointView item in the array.
Public Method | GetEnumerator | Returns the Enumerator of the vdArray of the object.
Public Method | InsertAt | Inserts an item at the specified index.
Public Method | RemoveAll | Clears the vdPointViews array of all its items.
Public Method | RemoveAt | Removes the item at the specified index.
Top

See Also

Reference

vdPointViews Class
vdRay Namespace


%%PageItemTitle%%

AddItem Method
[image]
vdRay Namespace > vdPointViews Class : AddItem Method

item
The vdPointView item to be added.
Adds a new vdPointView item in the array.

Syntax

Visual Basic (Declaration)
Public Sub AddItem( _
   ByVal item As vdPointView _
)
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim item As vdPointView

instance.AddItem(item)
C#
public void AddItem(
   vdPointView item
)

Parameters

item
The vdPointView item to be added.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

GetEnumerator Method
[image]
vdRay Namespace > vdPointViews Class : GetEnumerator Method

Returns the Enumerator of the vdArray of the object.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()

Return Value

The Enumerator of the vdArray of the object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

InsertAt Method
[image]
vdRay Namespace > vdPointViews Class : InsertAt Method

index
The position where the item will be inserted.
item
The item to be inserted in the vdArray.
Inserts an item at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub InsertAt( _
   ByVal index As Integer, _
   ByVal item As vdPointView _
)
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim index As Integer
Dim item As vdPointView

instance.InsertAt(index, item)
C#
public void InsertAt(
   int index,
   vdPointView item
)

Parameters

index
The position where the item will be inserted.
item
The item to be inserted in the vdArray.

Exceptions

Exception | Description
ArgumentOutOfRangeException | If the index is less than 0 or bigger or equal to Count property.

Remarks

Every object after the index position are shifted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

RemoveAll Method
[image]
vdRay Namespace > vdPointViews Class : RemoveAll Method

Clears the vdPointViews array of all its items.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAll()
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews

instance.RemoveAll()
C#
public void RemoveAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

RemoveAt Method
[image]
vdRay Namespace > vdPointViews Class : RemoveAt Method

index
The position from which the item will be removed.
Removes the item at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)

Parameters

index
The position from which the item will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%% $$Properties$$

vdPointViews Class Properties
[image]
vdRay Namespace : vdPointViews Class

For a list of all members of this type, see vdPointViews members.

Public Properties

 | Name | Description
Public Property | Count | The ammount of vdPointView items in the Array.
Public Property | Item | The vdPointView item in the specified position.
Public Property | Last | The last item in the array.
Top

See Also

Reference

vdPointViews Class
vdRay Namespace


%%PageItemTitle%%

Count Property
[image]
vdRay Namespace > vdPointViews Class : Count Property

The ammount of vdPointView items in the Array.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim value As Integer

value = instance.Count
C#
public int Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

Item Property
[image]
vdRay Namespace > vdPointViews Class : Item Property

index
The vdPointView item in the specified position.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As vdPointView
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim index As Integer
Dim value As vdPointView

value = instance.Item(index)
C#
public vdPointView this[
   int index
]; {get;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

Last Property
[image]
vdRay Namespace > vdPointViews Class : Last Property

The last item in the array.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Last As vdPointView
Visual Basic (Usage) Copy Code
Dim instance As vdPointViews
Dim value As vdPointView

value = instance.Last
C#
public vdPointView Last {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdPointViews Class
vdPointViews Members


%%PageItemTitle%%

vdRayComponent Class
See Also Members
[image]
vdRay Namespace : vdRayComponent Class

The main class of the vdRay component that stores all the properties and calls the necessary methods in order to create photorealistic bitmaps.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class vdRayComponent
   Inherits UserControl
   Implements IvdRayComponent
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
C#
public sealed class vdRayComponent : UserControl, IvdRayComponent

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
vdRay.vdRayComponent

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRayComponent Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdRayComponent Class Members
See Also Properties Methods Events
[image]
vdRay Namespace : vdRayComponent Class

The following tables list the members exposed by vdRayComponent.

Public Constructors

 | Name | Description
Public Constructor | vdRayComponent Constructor | The consructor of the Class.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AntialiasDepth | The depth of the Antialiasing of the object.
Public Property | Antialiasing | Whether or not the render will use an Antialiasing algorithm.
Public Property | AntialiasThreshold | The Threshold (limit) of the Antialiasing.
Public Property | AutoFitBitmap | If true, the component's Width and Height will be used as RenderWidht and RenderHeight.
Public Property | AutoRegen | If true, the Regen method is called automatically whenever needed.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentImage | The Bitmap last rendered with the vdRayComponent.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Document | The vdDocument that will be rendered to Bitmap.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | FocalLength | The focal length used by the camera in the rendering procedure.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FreezeEvents | If true, no Event is fired.
Public Property | FreezeRefreshEvents | If true, no refresh Event is fired.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | KeepFiles | Whether or not, the temporary files used for the rendering will be deleted.
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LensAngle | The lens' angle used by the camera in the rendering procedure.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | Radiosity | Controls the use of Radiosity. Radiosity is an algorithm that simulates the natural light when illuminating the objects of a scene, creating more realistic images. What Radiosity does is taking into consideration all of the neighbor objects' lighting amount when calculating how bright or dark a specific object will be. Thus said, it's understandable that Radiosity is a quite heavy algorithm that can take many minutes or even hours to render a mid sized bitmap. Radiosity has many properties that affect the quality and time consumption. The benefit of this technique is a big improvement in terms of photorealism, since the output picture can be very realistic. A side benefit is that the ambient light of all the objects of the scene don't have to be set (optional), saving time out of constant testing. By default UseRadiosity property of Radiosity is set to false.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RenderFlags | The flags defining if Text and Lines will be included in the rendering.
Public Property | RenderHeight | Height of Bitmap that will be created.
Public Property | RenderWidth | Width of Bitmap that will be created.
Public Property | ResourcesDllName | The name of the DLL that contains the edited dialogs of the document.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | createVideo | Creates a walkthrough vdVideo using the vdRay component.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | getSaveVideoFileDialog | Shows the standard windows SaveDialog.
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | OpenVideo | Overloaded. Opens a VdVideo object.
Public Method | Pause | Pauses the rendering procedure.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Play | Resumes the rendering procedure if it's paused.
Public Method | PlayVideo | Displays the frames of the selected VdVideo object with the set framerate. If framerate is set to -1, default framerate will be used instead. The frames will be displayed in the control.
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | Regen | Clears the primitve collection of the component, forcing it to re-export them. Used whenever there was a change in the document being rendered.
Public Method | Render | Renders the passed vdDocument using the vdRay Engine.
Public Method | RenderDocumentModel | Renders the document set in the vdRayComponent using the view properties set by the document (viewAngle, focalLenght etc.).
Public Method | RenderOrthographic | Renders the document set in the vdRayComponent in orthrographic mode.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | Stop | Cancels the rendering procedure.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | OnError | Fired whenever an error occurs during the rendering.
Public Event | OnNextFrame | Fired every time a new bitmap is rendered when creating a video.
Public Event | OnProgress | Fired whenever progress is made in every of the stages of the rendering.
Public Event | OnProgressStart | Fired when the Progress meter is initialized.
Public Event | OnProgressStop | Fired when the Progress meter is terminated.
Public Event | OnRefresh | Fired every time the bitmap of the rendered image is refreshed.
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

vdRayComponent Class
vdRay Namespace


%%PageItemTitle%%

vdRayComponent Constructor
[image]
vdRay Namespace > vdRayComponent Class : vdRayComponent Constructor

The consructor of the Class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent()
C#
public vdRayComponent()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%% $$Methods$$

vdRayComponent Class Methods
[image]
vdRay Namespace : vdRayComponent Class

For a list of all members of this type, see vdRayComponent members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | createVideo | Creates a walkthrough vdVideo using the vdRay component.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | getSaveVideoFileDialog | Shows the standard windows SaveDialog.
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | OpenVideo | Overloaded. Opens a VdVideo object.
Public Method | Pause | Pauses the rendering procedure.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Play | Resumes the rendering procedure if it's paused.
Public Method | PlayVideo | Displays the frames of the selected VdVideo object with the set framerate. If framerate is set to -1, default framerate will be used instead. The frames will be displayed in the control.
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | Regen | Clears the primitve collection of the component, forcing it to re-export them. Used whenever there was a change in the document being rendered.
Public Method | Render | Renders the passed vdDocument using the vdRay Engine.
Public Method | RenderDocumentModel | Renders the document set in the vdRayComponent using the view properties set by the document (viewAngle, focalLenght etc.).
Public Method | RenderOrthographic | Renders the document set in the vdRayComponent in orthrographic mode.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | Stop | Cancels the rendering procedure.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

vdRayComponent Class
vdRay Namespace


%%PageItemTitle%%

createVideo Method
[image]
vdRay Namespace > vdRayComponent Class : createVideo Method

filename
The filename of the vdVideo that will be created.
pointViews
The collection of objects defining position, twist and direction of the camera on every step.
testVideo
Set true if to create a test video using OpenGL.
Creates a walkthrough vdVideo using the vdRay component.

Syntax

Visual Basic (Declaration)
Public Function createVideo( _
   ByVal filename As String, _
   ByVal pointViews As vdPointViews, _
   ByVal testVideo As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim filename As String
Dim pointViews As vdPointViews
Dim testVideo As Boolean
Dim value As Boolean

value = instance.createVideo(filename, pointViews, testVideo)
C#
public bool createVideo(
   string filename,
   vdPointViews pointViews,
   bool testVideo
)

Parameters

filename
The filename of the vdVideo that will be created.
pointViews
The collection of objects defining position, twist and direction of the camera on every step.
testVideo
Set true if to create a test video using OpenGL.

Return Value

True if the creation of the video is completed successfully, false if it is unterrupted.

Remarks

Creation of a video can be a very time consuming procedure, use the test video to preview the result before creating a vdray video. Vdray videos have a frame rate of 25 frames per second, while test videos a frame rate of 10.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

getSaveVideoFileDialog Method
[image]
vdRay Namespace > vdRayComponent Class : getSaveVideoFileDialog Method

defaultVideoFileName
The default filename of the dialog.
Shows the standard windows SaveDialog.

Syntax

Visual Basic (Declaration)
Public Function getSaveVideoFileDialog( _
   ByVal defaultVideoFileName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim defaultVideoFileName As String
Dim value As String

value = instance.getSaveVideoFileDialog(defaultVideoFileName)
C#
public string getSaveVideoFileDialog(
   string defaultVideoFileName
)

Parameters

defaultVideoFileName
The default filename of the dialog.

Return Value

The filename the user selected.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OpenVideo Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class : OpenVideo Method

Opens a VdVideo object.

Overload List

Overload | Description
OpenVideo(Stream) | Opens a VdVideo object.
OpenVideo(String) | Opens a VdVideo object.

Example

Open a vdVideo file.

C# Copy Code
OpenFileDialog ofd = new OpenFileDialog();
    if (ofd.ShowDialog() == DialogResult.OK)
    {
        Stream stream = File.Open(ofd.FileName, FileMode.Open);
        vdRay.VdVideo video = vdray.OpenVideo(stream);
        video.getFrame(7);
    }
                    *

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OpenVideo(Stream) Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class > OpenVideo Method : OpenVideo(Stream) Method

stream
The stream from wich the VdVideo will be opened.
Opens a VdVideo object.

Syntax

Visual Basic (Declaration)
Overloads Public Function OpenVideo( _
   ByVal stream As Stream _
) As VdVideo
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim stream As Stream
Dim value As VdVideo

value = instance.OpenVideo(stream)
C#
public VdVideo OpenVideo(
   Stream stream
)

Parameters

stream
The stream from wich the VdVideo will be opened.

Return Value

The VdVideo object opened.

Example

Open a vdVideo file.

C# Copy Code
OpenFileDialog ofd = new OpenFileDialog();
    if (ofd.ShowDialog() == DialogResult.OK)
    {
        Stream stream = File.Open(ofd.FileName, FileMode.Open);
        vdRay.VdVideo video = vdray.OpenVideo(stream);
        video.getFrame(7);
    }
                    *

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members
Overload List


%%PageItemTitle%%

OpenVideo(String) Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class > OpenVideo Method : OpenVideo(String) Method

videoFileName
The filename of the VdVideo to be opened.
Opens a VdVideo object.

Syntax

Visual Basic (Declaration)
Overloads Public Function OpenVideo( _
   ByVal videoFileName As String _
) As VdVideo
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim videoFileName As String
Dim value As VdVideo

value = instance.OpenVideo(videoFileName)
C#
public VdVideo OpenVideo(
   string videoFileName
)

Parameters

videoFileName
The filename of the VdVideo to be opened.

Return Value

The VdVideo object opened.

Example

Open a vdVideo file.

C# Copy Code
OpenFileDialog ofd = new OpenFileDialog();
    if (ofd.ShowDialog() == DialogResult.OK)
    {
        vdRay.VdVideo video = vdray.OpenVideo(ofd.FileName);
        video.getFrame(7);
    }
                    *

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members
Overload List


%%PageItemTitle%%

Pause Method
[image]
vdRay Namespace > vdRayComponent Class : Pause Method

Pauses the rendering procedure.

Syntax

Visual Basic (Declaration)
Public Sub Pause()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent

instance.Pause()
C#
public void Pause()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Play Method
[image]
vdRay Namespace > vdRayComponent Class : Play Method

Resumes the rendering procedure if it's paused.

Syntax

Visual Basic (Declaration)
Public Sub Play()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent

instance.Play()
C#
public void Play()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

PlayVideo Method
[image]
vdRay Namespace > vdRayComponent Class : PlayVideo Method

Video
The VdVideo to be played.
frameRate
The amount of frames to be displayed per second.
Displays the frames of the selected VdVideo object with the set framerate. If framerate is set to -1, default framerate will be used instead. The frames will be displayed in the control.

Syntax

Visual Basic (Declaration)
Public Sub PlayVideo( _
   ByVal Video As VdVideo, _
   ByVal frameRate As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim Video As VdVideo
Dim frameRate As Integer

instance.PlayVideo(Video, frameRate)
C#
public void PlayVideo(
   VdVideo Video,
   int frameRate
)

Parameters

Video
The VdVideo to be played.
frameRate
The amount of frames to be displayed per second.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Regen Method
[image]
vdRay Namespace > vdRayComponent Class : Regen Method

Clears the primitve collection of the component, forcing it to re-export them. Used whenever there was a change in the document being rendered.

Syntax

Visual Basic (Declaration)
Public Sub Regen()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent

instance.Regen()
C#
public void Regen()

Remarks

Regen is automatically called if AutoRegen property is set to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Render Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class : Render Method

pointview
The vdPointView object that defines the Position, direction, twist, etc., of the camera.
Renders the passed vdDocument using the vdRay Engine.

Syntax

Visual Basic (Declaration)
Public Function Render( _
   ByVal pointview As vdPointView _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim pointview As vdPointView
Dim value As Object

value = instance.Render(pointview)
C#
public object Render(
   vdPointView pointview
)

Parameters

pointview
The vdPointView object that defines the Position, direction, twist, etc., of the camera.

Return Value

The rendered bitmap as object.

Example

Rendering and saving an image.

C# Copy Code
vdRayComponent1.Document = vdFramedControl1.BaseControl.ActiveDocument;
vdRayComponent1.RenderWidth = vdRayComponent1.Width;
vdRayComponent1.RenderHeight = vdRayComponent1.Height;
//You can also use the AutoFitBitmap property in order to use the component's Width and Height as RenderWidth and RenderHeight.
vdRay.vdPointView pointView = new vdRay.vdPointView(new VectorDraw.Geometry.gPoint(0, 0, 0), new VectorDraw.Geometry.Vector(0, 1, 0));
Bitmap bmp = vdRayComponent1.Render(pointView) as Bitmap;
bmp.Save("image.bmp");

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

RenderDocumentModel Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class : RenderDocumentModel Method

inputParams
Currently you can only pass null as parameter.
Renders the document set in the vdRayComponent using the view properties set by the document (viewAngle, focalLenght etc.).

Syntax

Visual Basic (Declaration)
Public Function RenderDocumentModel( _
   ByVal inputParams As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim inputParams As Object
Dim value As Object

value = instance.RenderDocumentModel(inputParams)
C#
public object RenderDocumentModel(
   object inputParams
)

Parameters

inputParams
Currently you can only pass null as parameter.

Return Value

The rendered bitmap as object

Example

Rendering and saving an image.

C# Copy Code
vdRayComponent1.Document = vdFramedControl1.BaseControl.ActiveDocument;
vdRayComponent1.RenderWidth = vdRayComponent1.Width;
vdRayComponent1.RenderHeight = vdRayComponent1.Height;
//You can also use the AutoFitBitmap property in order to use the component's Width and Height as RenderWidth and RenderHeight.
Bitmap bmp = vdRayComponent1.RenderDocumentModel(null) as Bitmap;
bmp.Save("image.bmp");

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

RenderOrthographic Method
See Also Example
[image]
vdRay Namespace > vdRayComponent Class : RenderOrthographic Method

pointview
The vdPointView object defining the view properties (viewAngle, focalLenght etc.).
ViewSize
The desired ViewSize.
Renders the document set in the vdRayComponent in orthrographic mode.

Syntax

Visual Basic (Declaration)
Public Function RenderOrthographic( _
   ByVal pointview As vdPointView, _
   ByVal ViewSize As Double _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim pointview As vdPointView
Dim ViewSize As Double
Dim value As Object

value = instance.RenderOrthographic(pointview, ViewSize)
C#
public object RenderOrthographic(
   vdPointView pointview,
   double ViewSize
)

Parameters

pointview
The vdPointView object defining the view properties (viewAngle, focalLenght etc.).
ViewSize
The desired ViewSize.

Return Value

The rendered bitmap as object

Example

Rendering and saving an image.

C# Copy Code
vdRayComponent1.Document = vdFramedControl1.BaseControl.ActiveDocument;
vdRayComponent1.RenderWidth = vdRayComponent1.Width;
vdRayComponent1.RenderHeight = vdRayComponent1.Height;
//You can also use the AutoFitBitmap property in order to use the component's Width and Height as RenderWidth and RenderHeight.
vdRay.vdPointView pointView = new vdRay.vdPointView(new VectorDraw.Geometry.gPoint(0, 0, 0), new VectorDraw.Geometry.Vector(0, 1, 0));
Bitmap bmp = vdRayComponent1.RenderOrthographic(pointView, vdFramedControl1.BaseControl.ActiveDocument.ViewSize) as Bitmap;
bmp.Save("image.bmp");

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Stop Method
[image]
vdRay Namespace > vdRayComponent Class : Stop Method

Cancels the rendering procedure.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent

instance.Stop()
C#
public void Stop()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%% $$Properties$$

vdRayComponent Class Properties
[image]
vdRay Namespace : vdRayComponent Class

For a list of all members of this type, see vdRayComponent members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AntialiasDepth | The depth of the Antialiasing of the object.
Public Property | Antialiasing | Whether or not the render will use an Antialiasing algorithm.
Public Property | AntialiasThreshold | The Threshold (limit) of the Antialiasing.
Public Property | AutoFitBitmap | If true, the component's Width and Height will be used as RenderWidht and RenderHeight.
Public Property | AutoRegen | If true, the Regen method is called automatically whenever needed.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentImage | The Bitmap last rendered with the vdRayComponent.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Document | The vdDocument that will be rendered to Bitmap.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | FocalLength | The focal length used by the camera in the rendering procedure.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FreezeEvents | If true, no Event is fired.
Public Property | FreezeRefreshEvents | If true, no refresh Event is fired.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | KeepFiles | Whether or not, the temporary files used for the rendering will be deleted.
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LensAngle | The lens' angle used by the camera in the rendering procedure.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | Radiosity | Controls the use of Radiosity. Radiosity is an algorithm that simulates the natural light when illuminating the objects of a scene, creating more realistic images. What Radiosity does is taking into consideration all of the neighbor objects' lighting amount when calculating how bright or dark a specific object will be. Thus said, it's understandable that Radiosity is a quite heavy algorithm that can take many minutes or even hours to render a mid sized bitmap. Radiosity has many properties that affect the quality and time consumption. The benefit of this technique is a big improvement in terms of photorealism, since the output picture can be very realistic. A side benefit is that the ambient light of all the objects of the scene don't have to be set (optional), saving time out of constant testing. By default UseRadiosity property of Radiosity is set to false.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RenderFlags | The flags defining if Text and Lines will be included in the rendering.
Public Property | RenderHeight | Height of Bitmap that will be created.
Public Property | RenderWidth | Width of Bitmap that will be created.
Public Property | ResourcesDllName | The name of the DLL that contains the edited dialogs of the document.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

vdRayComponent Class
vdRay Namespace


%%PageItemTitle%%

AntialiasDepth Property
[image]
vdRay Namespace > vdRayComponent Class : AntialiasDepth Property

The depth of the Antialiasing of the object.

Syntax

Visual Basic (Declaration)
Public Property AntialiasDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Integer

instance.AntialiasDepth = value

value = instance.AntialiasDepth
C#
public int AntialiasDepth {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Antialiasing Property
[image]
vdRay Namespace > vdRayComponent Class : Antialiasing Property

Whether or not the render will use an Antialiasing algorithm.

Syntax

Visual Basic (Declaration)
Public Property Antialiasing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.Antialiasing = value

value = instance.Antialiasing
C#
public bool Antialiasing {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

AntialiasThreshold Property
[image]
vdRay Namespace > vdRayComponent Class : AntialiasThreshold Property

The Threshold (limit) of the Antialiasing.

Syntax

Visual Basic (Declaration)
Public Property AntialiasThreshold As Double
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Double

instance.AntialiasThreshold = value

value = instance.AntialiasThreshold
C#
public double AntialiasThreshold {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

AutoFitBitmap Property
[image]
vdRay Namespace > vdRayComponent Class : AutoFitBitmap Property

If true, the component's Width and Height will be used as RenderWidht and RenderHeight.

Syntax

Visual Basic (Declaration)
Public Property AutoFitBitmap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.AutoFitBitmap = value

value = instance.AutoFitBitmap
C#
public bool AutoFitBitmap {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

AutoRegen Property
[image]
vdRay Namespace > vdRayComponent Class : AutoRegen Property

If true, the Regen method is called automatically whenever needed.

Syntax

Visual Basic (Declaration)
Public Property AutoRegen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.AutoRegen = value

value = instance.AutoRegen
C#
public bool AutoRegen {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

CurrentImage Property
[image]
vdRay Namespace > vdRayComponent Class : CurrentImage Property

The Bitmap last rendered with the vdRayComponent.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentImage As Object
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Object

value = instance.CurrentImage
C#
public object CurrentImage {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Document Property
[image]
vdRay Namespace > vdRayComponent Class : Document Property

The vdDocument that will be rendered to Bitmap.

Syntax

Visual Basic (Declaration)
Public Property Document As vdDocument
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As vdDocument

instance.Document = value

value = instance.Document
C#
public vdDocument Document {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

FocalLength Property
[image]
vdRay Namespace > vdRayComponent Class : FocalLength Property

The focal length used by the camera in the rendering procedure.

Syntax

Visual Basic (Declaration)
Public Property FocalLength As Double
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Double

instance.FocalLength = value

value = instance.FocalLength
C#
public double FocalLength {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

FreezeEvents Property
[image]
vdRay Namespace > vdRayComponent Class : FreezeEvents Property

If true, no Event is fired.

Syntax

Visual Basic (Declaration)
Public Property FreezeEvents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.FreezeEvents = value

value = instance.FreezeEvents
C#
public bool FreezeEvents {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

FreezeRefreshEvents Property
[image]
vdRay Namespace > vdRayComponent Class : FreezeRefreshEvents Property

If true, no refresh Event is fired.

Syntax

Visual Basic (Declaration)
Public Property FreezeRefreshEvents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.FreezeRefreshEvents = value

value = instance.FreezeRefreshEvents
C#
public bool FreezeRefreshEvents {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

KeepFiles Property
[image]
vdRay Namespace > vdRayComponent Class : KeepFiles Property

Whether or not, the temporary files used for the rendering will be deleted.

Syntax

Visual Basic (Declaration)
Public Property KeepFiles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Boolean

instance.KeepFiles = value

value = instance.KeepFiles
C#
public bool KeepFiles {get; set;}

Remarks

Default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

LensAngle Property
[image]
vdRay Namespace > vdRayComponent Class : LensAngle Property

The lens' angle used by the camera in the rendering procedure.

Syntax

Visual Basic (Declaration)
Public Property LensAngle As Double
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Double

instance.LensAngle = value

value = instance.LensAngle
C#
public double LensAngle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

Radiosity Property
[image]
vdRay Namespace > vdRayComponent Class : Radiosity Property

Controls the use of Radiosity. Radiosity is an algorithm that simulates the natural light when illuminating the objects of a scene, creating more realistic images. What Radiosity does is taking into consideration all of the neighbor objects' lighting amount when calculating how bright or dark a specific object will be. Thus said, it's understandable that Radiosity is a quite heavy algorithm that can take many minutes or even hours to render a mid sized bitmap. Radiosity has many properties that affect the quality and time consumption. The benefit of this technique is a big improvement in terms of photorealism, since the output picture can be very realistic. A side benefit is that the ambient light of all the objects of the scene don't have to be set (optional), saving time out of constant testing. By default UseRadiosity property of Radiosity is set to false.

Syntax

Visual Basic (Declaration)
Public Property Radiosity As Radiosity
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Radiosity

instance.Radiosity = value

value = instance.Radiosity
C#
public Radiosity Radiosity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

RenderFlags Property
[image]
vdRay Namespace > vdRayComponent Class : RenderFlags Property

The flags defining if Text and Lines will be included in the rendering.

Syntax

Visual Basic (Declaration)
Public Property RenderFlags As vdRayComponent.RenderFlagsEnum
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As vdRayComponent.RenderFlagsEnum

instance.RenderFlags = value

value = instance.RenderFlags
C#
public vdRayComponent.RenderFlagsEnum RenderFlags {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

RenderHeight Property
[image]
vdRay Namespace > vdRayComponent Class : RenderHeight Property

Height of Bitmap that will be created.

Syntax

Visual Basic (Declaration)
Public Property RenderHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Integer

instance.RenderHeight = value

value = instance.RenderHeight
C#
public int RenderHeight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

RenderWidth Property
[image]
vdRay Namespace > vdRayComponent Class : RenderWidth Property

Width of Bitmap that will be created.

Syntax

Visual Basic (Declaration)
Public Property RenderWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As Integer

instance.RenderWidth = value

value = instance.RenderWidth
C#
public int RenderWidth {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

ResourcesDllName Property
[image]
vdRay Namespace > vdRayComponent Class : ResourcesDllName Property

The name of the DLL that contains the edited dialogs of the document.

Syntax

Visual Basic (Declaration)
Public Property ResourcesDllName As String
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim value As String

instance.ResourcesDllName = value

value = instance.ResourcesDllName
C#
public string ResourcesDllName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%% $$Events$$

vdRayComponent Class Events
[image]
vdRay Namespace : vdRayComponent Class

For a list of all members of this type, see vdRayComponent members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | OnError | Fired whenever an error occurs during the rendering.
Public Event | OnNextFrame | Fired every time a new bitmap is rendered when creating a video.
Public Event | OnProgress | Fired whenever progress is made in every of the stages of the rendering.
Public Event | OnProgressStart | Fired when the Progress meter is initialized.
Public Event | OnProgressStop | Fired when the Progress meter is terminated.
Public Event | OnRefresh | Fired every time the bitmap of the rendered image is refreshed.
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

vdRayComponent Class
vdRay Namespace


%%PageItemTitle%%

OnError Event
[image]
vdRay Namespace > vdRayComponent Class : OnError Event

Fired whenever an error occurs during the rendering.

Syntax

Visual Basic (Declaration)
Public Event OnError() As vdDocument.GenericErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdDocument.GenericErrorEventHandler

AddHandler instance.OnError, handler
C#
public event vdDocument.GenericErrorEventHandler OnError()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OnNextFrame Event
[image]
vdRay Namespace > vdRayComponent Class : OnNextFrame Event

Fired every time a new bitmap is rendered when creating a video.

Syntax

Visual Basic (Declaration)
Public Event OnNextFrame() As vdRayComponent.NextFrame
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdRayComponent.NextFrame

AddHandler instance.OnNextFrame, handler
C#
public event vdRayComponent.NextFrame OnNextFrame()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OnProgress Event
[image]
vdRay Namespace > vdRayComponent Class : OnProgress Event

Fired whenever progress is made in every of the stages of the rendering.

Syntax

Visual Basic (Declaration)
Public Event OnProgress() As vdRayComponent.ProgressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdRayComponent.ProgressEventHandler

AddHandler instance.OnProgress, handler
C#
public event vdRayComponent.ProgressEventHandler OnProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OnProgressStart Event
[image]
vdRay Namespace > vdRayComponent Class : OnProgressStart Event

Fired when the Progress meter is initialized.

Syntax

Visual Basic (Declaration)
Public Event OnProgressStart() As vdRayComponent.ProgressStartEventHandler
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdRayComponent.ProgressStartEventHandler

AddHandler instance.OnProgressStart, handler
C#
public event vdRayComponent.ProgressStartEventHandler OnProgressStart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OnProgressStop Event
[image]
vdRay Namespace > vdRayComponent Class : OnProgressStop Event

Fired when the Progress meter is terminated.

Syntax

Visual Basic (Declaration)
Public Event OnProgressStop() As vdRayComponent.ProgressStopEventHandler
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdRayComponent.ProgressStopEventHandler

AddHandler instance.OnProgressStop, handler
C#
public event vdRayComponent.ProgressStopEventHandler OnProgressStop()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

OnRefresh Event
[image]
vdRay Namespace > vdRayComponent Class : OnRefresh Event

Fired every time the bitmap of the rendered image is refreshed.

Syntax

Visual Basic (Declaration)
Public Event OnRefresh() As vdRayComponent.RefreshDelegate
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent
Dim handler As vdRayComponent.RefreshDelegate

AddHandler instance.OnRefresh, handler
C#
public event vdRayComponent.RefreshDelegate OnRefresh()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent Class
vdRayComponent Members


%%PageItemTitle%%

vdRayComponent.ErrorMessages Class
See Also Members
[image]
vdRay Namespace : vdRayComponent.ErrorMessages Class

Syntax

Visual Basic (Declaration)
Private Class vdRayComponent.ErrorMessages
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.ErrorMessages
C#
private class vdRayComponent.ErrorMessages

Inheritance Hierarchy

System.Object
vdRay.vdRayComponent.ErrorMessages

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRayComponent.ErrorMessages Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdRayComponent.ErrorMessages Class Members
See Also Properties
[image]
vdRay Namespace : vdRayComponent.ErrorMessages Class

The following tables list the members exposed by vdRayComponent.ErrorMessages.

Public Constructors

 | Name | Description
Public Constructor | vdRayComponent.ErrorMessages Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

vdRayComponent.ErrorMessages Class
vdRay Namespace


%%PageItemTitle%%

vdRayComponent.ErrorMessages Constructor
[image]
vdRay Namespace > vdRayComponent.ErrorMessages Class : vdRayComponent.ErrorMessages Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.ErrorMessages()
C#
public vdRayComponent.ErrorMessages()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.ErrorMessages Class
vdRayComponent.ErrorMessages Members


%%PageItemTitle%% $$Properties$$

vdRayComponent.ErrorMessages Class Properties
[image]
vdRay Namespace : vdRayComponent.ErrorMessages Class

For a list of all members of this type, see vdRayComponent.ErrorMessages members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

vdRayComponent.ErrorMessages Class
vdRay Namespace


%%PageItemTitle%%

Item Property
[image]
vdRay Namespace > vdRayComponent.ErrorMessages Class : Item Property

item

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal item As vdRayComponent.ErrorMessages.errorNo _
) As String
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.ErrorMessages
Dim item As vdRayComponent.ErrorMessages.errorNo
Dim value As String

value = instance.Item(item)
C#
public string this[
   vdRayComponent.ErrorMessages.errorNo item
]; {get;}

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.ErrorMessages Class
vdRayComponent.ErrorMessages Members


%%PageItemTitle%%

vdRayComponent.RefreshFrameParams Class
See Also Members
[image]
vdRay Namespace : vdRayComponent.RefreshFrameParams Class

The parameters passed every time a refresh event is fired.

Syntax

Visual Basic (Declaration)
Public Class vdRayComponent.RefreshFrameParams
   Implements IRefreshFrameParams
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RefreshFrameParams
C#
public class vdRayComponent.RefreshFrameParams : IRefreshFrameParams

Inheritance Hierarchy

System.Object
vdRay.vdRayComponent.RefreshFrameParams

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRayComponent.RefreshFrameParams Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdRayComponent.RefreshFrameParams Class Members
See Also Properties
[image]
vdRay Namespace : vdRayComponent.RefreshFrameParams Class

The following tables list the members exposed by vdRayComponent.RefreshFrameParams.

Public Properties

 | Name | Description
Public Property | Cancel | If set to true, cancels the execution of the event.
Public Property | CurrentFrame | The bitmap created by the rendering procedure.
Public Property | CurrentFrameIndex | The index of the bitmap created when creating a video.
Public Property | TotalFrames | The total amount of bitmaps to be rendered when creating a video.
Top

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRay Namespace


%%PageItemTitle%% $$Properties$$

vdRayComponent.RefreshFrameParams Class Properties
[image]
vdRay Namespace : vdRayComponent.RefreshFrameParams Class

For a list of all members of this type, see vdRayComponent.RefreshFrameParams members.

Public Properties

 | Name | Description
Public Property | Cancel | If set to true, cancels the execution of the event.
Public Property | CurrentFrame | The bitmap created by the rendering procedure.
Public Property | CurrentFrameIndex | The index of the bitmap created when creating a video.
Public Property | TotalFrames | The total amount of bitmaps to be rendered when creating a video.
Top

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRay Namespace


%%PageItemTitle%%

Cancel Property
[image]
vdRay Namespace > vdRayComponent.RefreshFrameParams Class : Cancel Property

If set to true, cancels the execution of the event.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RefreshFrameParams
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRayComponent.RefreshFrameParams Members


%%PageItemTitle%%

CurrentFrame Property
[image]
vdRay Namespace > vdRayComponent.RefreshFrameParams Class : CurrentFrame Property

The bitmap created by the rendering procedure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentFrame As Object
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RefreshFrameParams
Dim value As Object

value = instance.CurrentFrame
C#
public object CurrentFrame {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRayComponent.RefreshFrameParams Members


%%PageItemTitle%%

CurrentFrameIndex Property
[image]
vdRay Namespace > vdRayComponent.RefreshFrameParams Class : CurrentFrameIndex Property

The index of the bitmap created when creating a video.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentFrameIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RefreshFrameParams
Dim value As Integer

value = instance.CurrentFrameIndex
C#
public int CurrentFrameIndex {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRayComponent.RefreshFrameParams Members


%%PageItemTitle%%

TotalFrames Property
[image]
vdRay Namespace > vdRayComponent.RefreshFrameParams Class : TotalFrames Property

The total amount of bitmaps to be rendered when creating a video.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalFrames As Integer
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RefreshFrameParams
Dim value As Integer

value = instance.TotalFrames
C#
public int TotalFrames {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayComponent.RefreshFrameParams Class
vdRayComponent.RefreshFrameParams Members


%%PageItemTitle%%

vdRayGlobals Class
See Also Members
[image]
vdRay Namespace : vdRayGlobals Class

Contains global constant values of the component.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class vdRayGlobals
Visual Basic (Usage) Copy Code
Dim instance As vdRayGlobals
C#
public static class vdRayGlobals

Inheritance Hierarchy

System.Object
vdRay.vdRayGlobals

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRayGlobals Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

vdRayGlobals Class Members
See Also Properties
[image]
vdRay Namespace : vdRayGlobals Class

The following tables list the members exposed by vdRayGlobals.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ResourcesDllName | The DLL name from which the component's forms will be loaded.
Top

See Also

Reference

vdRayGlobals Class
vdRay Namespace


%%PageItemTitle%% $$Properties$$

vdRayGlobals Class Properties
[image]
vdRay Namespace : vdRayGlobals Class

For a list of all members of this type, see vdRayGlobals members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ResourcesDllName | The DLL name from which the component's forms will be loaded.
Top

See Also

Reference

vdRayGlobals Class
vdRay Namespace


%%PageItemTitle%%

ResourcesDllName Property
[image]
vdRay Namespace > vdRayGlobals Class : ResourcesDllName Property

The DLL name from which the component's forms will be loaded.

Syntax

Visual Basic (Declaration)
Public Shared Property ResourcesDllName As String
Visual Basic (Usage) Copy Code
Dim value As String

vdRayGlobals.ResourcesDllName = value

value = vdRayGlobals.ResourcesDllName
C#
public static string ResourcesDllName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

vdRayGlobals Class
vdRayGlobals Members


%%PageItemTitle%%

VdVideo Class
See Also Members
[image]
vdRay Namespace : VdVideo Class

The class used to store the bitmaps (frames) created by vdRay, when a video is created.

Syntax

Visual Basic (Declaration)
Public Class VdVideo
   Implements IVdVideo
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
C#
public class VdVideo : IVdVideo

Inheritance Hierarchy

System.Object
vdRay.VdVideo

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

VdVideo Members
vdRay Namespace


%%PageItemTitle%% $$Members$$

VdVideo Class Members
See Also Properties Methods
[image]
vdRay Namespace : VdVideo Class

The following tables list the members exposed by VdVideo.

Public Properties

 | Name | Description
Public Property | FrameNum | The total amount of bitmaps this video should contain.
Public Property | FrameRate | The amount of frames per second this video was designed to display when played.
Public Property | Height | The height of the bitmaps used in this video.
Public Property | Width | The width of the bitmaps used in this video.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the VdVideo.
Public Method | getFrame | Get the frame of the specified position in the video.
static (Shared in Visual Basic) | Open | Opens a VdVideo object.
Top

See Also

Reference

VdVideo Class
vdRay Namespace


%%PageItemTitle%% $$Methods$$

VdVideo Class Methods
[image]
vdRay Namespace : VdVideo Class

For a list of all members of this type, see VdVideo members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the VdVideo.
Public Method | getFrame | Get the frame of the specified position in the video.
static (Shared in Visual Basic) | Open | Opens a VdVideo object.
Top

See Also

Reference

VdVideo Class
vdRay Namespace


%%PageItemTitle%%

Dispose Method
[image]
vdRay Namespace > VdVideo Class : Dispose Method

Disposes the VdVideo.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As VdVideo

instance.Dispose()
C#
public void Dispose()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

getFrame Method
See Also Example
[image]
vdRay Namespace > VdVideo Class : getFrame Method

position
The index of the frame to be returned.
Get the frame of the specified position in the video.

Syntax

Visual Basic (Declaration)
Public Function getFrame( _
   ByVal position As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
Dim position As Integer
Dim value As Object

value = instance.getFrame(position)
C#
public object getFrame(
   int position
)

Parameters

position
The index of the frame to be returned.

Return Value

The bitmap from the specified position.The frame is returned as an object.

Example

C# Copy Code
OpenFileDialog ofd = new OpenFileDialog();
vdRay.VdVideo video;
if (ofd.ShowDialog() == DialogResult.OK)
{
    video = vdRay.VdVideo.Open(ofd.FileName);
    Bitmap bmp = video.getFrame(7) as Bitmap;
}

                    *

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

Open Method
See Also Example
[image]
vdRay Namespace > VdVideo Class : Open Method

videoFileName
The filename of the VdVideo to be opened.
Opens a VdVideo object.

Syntax

Visual Basic (Declaration)
Public Shared Function Open( _
   ByVal videoFileName As String _
) As VdVideo
Visual Basic (Usage) Copy Code
Dim videoFileName As String
Dim value As VdVideo

value = VdVideo.Open(videoFileName)
C#
public static VdVideo Open(
   string videoFileName
)

Parameters

videoFileName
The filename of the VdVideo to be opened.

Return Value

The VdVideo object to be opened.

Example

Open a vdVideo file.

C# Copy Code
OpenFileDialog ofd = new OpenFileDialog();
vdRay.VdVideo video;
if (ofd.ShowDialog() == DialogResult.OK)
{
    video = vdRay.VdVideo.Open(ofd.FileName);
    Bitmap bmp = video.getFrame(7) as Bitmap;
}
                    *

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%% $$Properties$$

VdVideo Class Properties
[image]
vdRay Namespace : VdVideo Class

For a list of all members of this type, see VdVideo members.

Public Properties

 | Name | Description
Public Property | FrameNum | The total amount of bitmaps this video should contain.
Public Property | FrameRate | The amount of frames per second this video was designed to display when played.
Public Property | Height | The height of the bitmaps used in this video.
Public Property | Width | The width of the bitmaps used in this video.
Top

See Also

Reference

VdVideo Class
vdRay Namespace


%%PageItemTitle%%

FrameNum Property
[image]
vdRay Namespace > VdVideo Class : FrameNum Property

The total amount of bitmaps this video should contain.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FrameNum As Integer
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
Dim value As Integer

value = instance.FrameNum
C#
public int FrameNum {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

FrameRate Property
[image]
vdRay Namespace > VdVideo Class : FrameRate Property

The amount of frames per second this video was designed to display when played.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FrameRate As Integer
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
Dim value As Integer

value = instance.FrameRate
C#
public int FrameRate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

Height Property
[image]
vdRay Namespace > VdVideo Class : Height Property

The height of the bitmaps used in this video.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
Dim value As Integer

value = instance.Height
C#
public int Height {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

Width Property
[image]
vdRay Namespace > VdVideo Class : Width Property

The width of the bitmaps used in this video.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As VdVideo
Dim value As Integer

value = instance.Width
C#
public int Width {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

VdVideo Class
VdVideo Members


%%PageItemTitle%%

Radiosity.OnOff Enumeration
[image]
vdRay Namespace : Radiosity.OnOff Enumeration

Syntax

Visual Basic (Declaration)
Public Enum Radiosity.OnOff
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Radiosity.OnOff
C#
public enum Radiosity.OnOff : Enum

Members

Member | Description
on |
off |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
vdRay.Radiosity.OnOff

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRay Namespace


%%PageItemTitle%%

Radiosity.RadiosityPredefined Enumeration
[image]
vdRay Namespace : Radiosity.RadiosityPredefined Enumeration

Predefined settings for use of Radiosity;

Syntax

Visual Basic (Declaration)
Public Enum Radiosity.RadiosityPredefined
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Radiosity.RadiosityPredefined
C#
public enum Radiosity.RadiosityPredefined : Enum

Members

Member | Description
Debug | Run it fast, don't try to make it look good, make sure that you can actually see where the radiosity boundaries are.
Fast | Make it look as good as you can, but I'm in a hurry.
Normal |
TwoBounce |
Final |
OutdoorLQ |
OutdoorHQ |
OutdoorLight |
IndoorLQ |
IndoorHQ |
Custom |
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
vdRay.Radiosity.RadiosityPredefined

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRay Namespace


%%PageItemTitle%%

vdRayComponent.ErrorMessages.errorNo Enumeration
[image]
vdRay Namespace : vdRayComponent.ErrorMessages.errorNo Enumeration

Syntax

Visual Basic (Declaration)
Private Enum vdRayComponent.ErrorMessages.errorNo
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.ErrorMessages.errorNo
C#
private enum vdRayComponent.ErrorMessages.errorNo : Enum

Members

Member | Description
Stopped_by_user |
File_nonexistant |
File_incorrect_extension |
Library_method_nonexistant |
Bitmap_not_24_32_BPP |
Less_filled_rows_than_height |
Null_bitmap |
Output_folder_nonexist |
Rprops_null |
Renderwidth_0 |
Renderheight_0 |
Render_Width_Renderheight_0 |
Bad_frame |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
vdRay.vdRayComponent.ErrorMessages.errorNo

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRay Namespace


%%PageItemTitle%%

vdRayComponent.RenderFlagsEnum Enumeration
[image]
vdRay Namespace : vdRayComponent.RenderFlagsEnum Enumeration

The various flags of the rendering.

Syntax

Visual Basic (Declaration)
Public Enum vdRayComponent.RenderFlagsEnum
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RenderFlagsEnum
C#
public enum vdRayComponent.RenderFlagsEnum : Enum

Members

Member | Description
None | Nore strings, neither lines will be drawn in the rendered image.
DrawStrings | Strings will be drawn in the rendered image.
DrawLines | Lines will be drawn in the rendered image.
DrawAll | Both strings and lines will be drawn in the rendered image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
vdRay.vdRayComponent.RenderFlagsEnum

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRay Namespace


%%PageItemTitle%%

vdRayComponent.RenderState Enumeration
[image]
vdRay Namespace : vdRayComponent.RenderState Enumeration

Syntax

Visual Basic (Declaration)
Private Enum vdRayComponent.RenderState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As vdRayComponent.RenderState
C#
private enum vdRayComponent.RenderState : Enum

Members

Member | Description
ExportingPrimitives |
CreatingPov |
ReadingPov |
RenderingView |
CreatingVideo |
PlayingVideo |
Idle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
vdRay.vdRayComponent.RenderState

Requirements

Namespace: vdRay

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

vdRay Namespace


%%ItemTitle%%

vdRay.Dialogs Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
FrmMaterials | The dialog used to preview and edit the Material Properties of an object.
SaveImageDialog | Contains methods regarding image file save dialogs.

See Also

Reference

vdRay Assembly


%%PageItemTitle%%

FrmMaterials Class
See Also Members
[image]
vdRay.Dialogs Namespace : FrmMaterials Class

The dialog used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Public Class FrmMaterials
   Inherits Form
Visual Basic (Usage) Copy Code
Dim instance As FrmMaterials
C#
public class FrmMaterials : Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
vdRay.Dialogs.FrmMaterials

Requirements

Namespace: vdRay.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

FrmMaterials Members
vdRay.Dialogs Namespace


%%PageItemTitle%% $$Members$$

FrmMaterials Class Members
See Also Properties Methods Events
[image]
vdRay.Dialogs Namespace : FrmMaterials Class

The following tables list the members exposed by FrmMaterials.

Public Constructors

 | Name | Description
Public Constructor | FrmMaterials Constructor | Initializes a new instance of the FrmMaterials class.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
static (Shared in Visual Basic) | Show | Overloaded. Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FrmMaterials Class
vdRay.Dialogs Namespace


%%PageItemTitle%%

FrmMaterials Constructor
[image]
vdRay.Dialogs Namespace > FrmMaterials Class : FrmMaterials Constructor

Initializes a new instance of the FrmMaterials class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FrmMaterials()
C#
public FrmMaterials()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members


%%PageItemTitle%% $$Methods$$

FrmMaterials Class Methods
[image]
vdRay.Dialogs Namespace : FrmMaterials Class

For a list of all members of this type, see FrmMaterials members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
static (Shared in Visual Basic) | Show | Overloaded. Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

FrmMaterials Class
vdRay.Dialogs Namespace


%%PageItemTitle%%

Show Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class : Show Method

Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Overload List

Overload | Description
Show(IWin32Window) | Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Show(vdColor,Boolean,IWin32Window) | Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Show(vdColor,Double,Boolean,IWin32Window) | Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Show(vdFigure,Boolean,IWin32Window) | Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Show(vdFigure,Double,Boolean,IWin32Window) | Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.
Show() | (Inherited from System.Windows.Forms.Control)

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned. In case you define a material image, make sure to add the picBoxMaterialImage in the images collection of the Document, as described in the code sample.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members


%%PageItemTitle%%

Show(IWin32Window) Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class > Show Method : Show(IWin32Window) Method

owner
The owner of the dialog.
Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Show( _
   ByVal owner As IWin32Window _
) As vdColor
Visual Basic (Usage) Copy Code
Dim owner As IWin32Window
Dim value As vdColor

value = FrmMaterials.Show(owner)
C#
public static vdColor Show(
   IWin32Window owner
)

Parameters

owner
The owner of the dialog.

Return Value

The vdColor the user has selected.

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned. In case you define a material image, make sure to add the picBoxMaterialImage in the images collection of the Document, as described in the code sample.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members
Overload List


%%PageItemTitle%%

Show(vdColor,Boolean,IWin32Window) Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class > Show Method : Show(vdColor,Boolean,IWin32Window) Method

color
The vdColor used as the initial color in the dialog.
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.
Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Show( _
   ByVal color As vdColor, _
   ByVal saveImageToDocument As Boolean, _
   ByVal owner As IWin32Window _
) As vdColor
Visual Basic (Usage) Copy Code
Dim color As vdColor
Dim saveImageToDocument As Boolean
Dim owner As IWin32Window
Dim value As vdColor

value = FrmMaterials.Show(color, saveImageToDocument, owner)
C#
public static vdColor Show(
   vdColor color,
   bool saveImageToDocument,
   IWin32Window owner
)

Parameters

color
The vdColor used as the initial color in the dialog.
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.

Return Value

The vdColor the user has selected.

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members
Overload List


%%PageItemTitle%%

Show(vdColor,Double,Boolean,IWin32Window) Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class > Show Method : Show(vdColor,Double,Boolean,IWin32Window) Method

color
The vdColor used as the initial color in the dialog.
sceneDrawingUnit
The size of the scene's Cube/Sphere/Square dimensions. The default size is 2 (With this parameter you can make the scene similar to your drawing's size).
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.
Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Show( _
   ByVal color As vdColor, _
   ByVal sceneDrawingUnit As Double, _
   ByVal saveImageToDocument As Boolean, _
   ByVal owner As IWin32Window _
) As vdColor
Visual Basic (Usage) Copy Code
Dim color As vdColor
Dim sceneDrawingUnit As Double
Dim saveImageToDocument As Boolean
Dim owner As IWin32Window
Dim value As vdColor

value = FrmMaterials.Show(color, sceneDrawingUnit, saveImageToDocument, owner)
C#
public static vdColor Show(
   vdColor color,
   double sceneDrawingUnit,
   bool saveImageToDocument,
   IWin32Window owner
)

Parameters

color
The vdColor used as the initial color in the dialog.
sceneDrawingUnit
The size of the scene's Cube/Sphere/Square dimensions. The default size is 2 (With this parameter you can make the scene similar to your drawing's size).
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.

Return Value

The vdColor the user has selected.

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members
Overload List


%%PageItemTitle%%

Show(vdFigure,Boolean,IWin32Window) Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class > Show Method : Show(vdFigure,Boolean,IWin32Window) Method

figure
The VectorDraw object which's color will be used as the initial color in the dialog.
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.
Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Show( _
   ByVal figure As vdFigure, _
   ByVal saveImageToDocument As Boolean, _
   ByVal owner As IWin32Window _
) As vdColor
Visual Basic (Usage) Copy Code
Dim figure As vdFigure
Dim saveImageToDocument As Boolean
Dim owner As IWin32Window
Dim value As vdColor

value = FrmMaterials.Show(figure, saveImageToDocument, owner)
C#
public static vdColor Show(
   vdFigure figure,
   bool saveImageToDocument,
   IWin32Window owner
)

Parameters

figure
The VectorDraw object which's color will be used as the initial color in the dialog.
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.

Return Value

The vdColor the user has selected.

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members
Overload List


%%PageItemTitle%%

Show(vdFigure,Double,Boolean,IWin32Window) Method
[image]
vdRay.Dialogs Namespace > FrmMaterials Class > Show Method : Show(vdFigure,Double,Boolean,IWin32Window) Method

figure
The VectorDraw object which's color will be used as the initial color in the dialog.
sceneDrawingUnit
The size of the scene's Cube/Sphere/Square dimensions. The default size is 2 (With this parameter you can make the scene similar to your drawing's size).
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.
Show displays the material properties dialog. This dialog is used to preview and edit the Material Properties of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function Show( _
   ByVal figure As vdFigure, _
   ByVal sceneDrawingUnit As Double, _
   ByVal saveImageToDocument As Boolean, _
   ByVal owner As IWin32Window _
) As vdColor
Visual Basic (Usage) Copy Code
Dim figure As vdFigure
Dim sceneDrawingUnit As Double
Dim saveImageToDocument As Boolean
Dim owner As IWin32Window
Dim value As vdColor

value = FrmMaterials.Show(figure, sceneDrawingUnit, saveImageToDocument, owner)
C#
public static vdColor Show(
   vdFigure figure,
   double sceneDrawingUnit,
   bool saveImageToDocument,
   IWin32Window owner
)

Parameters

figure
The VectorDraw object which's color will be used as the initial color in the dialog.
sceneDrawingUnit
The size of the scene's Cube/Sphere/Square dimensions. The default size is 2 (With this parameter you can make the scene similar to your drawing's size).
saveImageToDocument
If true, the image used as material image is added to the images collection of the vdColor's document.
owner
The owner of the dialog.

Return Value

The vdColor the user has selected.

Remarks

When ok is pressed a vdColor with the properties specified is returned. When cancel is pressed, null is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FrmMaterials Class
FrmMaterials Members
Overload List


%%PageItemTitle%%

SaveImageDialog Class
See Also Members
[image]
vdRay.Dialogs Namespace : SaveImageDialog Class

Contains methods regarding image file save dialogs.

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class SaveImageDialog
Visual Basic (Usage) Copy Code
Dim instance As SaveImageDialog
C#
public static class SaveImageDialog

Inheritance Hierarchy

System.Object
vdRay.Dialogs.SaveImageDialog

Requirements

Namespace: vdRay.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: vdRay (in vdRay.dll)

See Also

Reference

SaveImageDialog Members
vdRay.Dialogs Namespace


%%PageItemTitle%% $$Members$$

SaveImageDialog Class Members
See Also Methods
[image]
vdRay.Dialogs Namespace : SaveImageDialog Class

The following tables list the members exposed by SaveImageDialog.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSaveImageDialog | Shows an image file save dialog with all the available image file types.
Top

See Also

Reference

SaveImageDialog Class
vdRay.Dialogs Namespace


%%PageItemTitle%% $$Methods$$

SaveImageDialog Class Methods
[image]
vdRay.Dialogs Namespace : SaveImageDialog Class

For a list of all members of this type, see SaveImageDialog members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSaveImageDialog | Shows an image file save dialog with all the available image file types.
Top

See Also

Reference

SaveImageDialog Class
vdRay.Dialogs Namespace


%%PageItemTitle%%

GetSaveImageDialog Method
[image]
vdRay.Dialogs Namespace > SaveImageDialog Class : GetSaveImageDialog Method

control
The parent of the dialog.
document
The active document.
defaultFileName
The default filename that appears in the dialog.
version
Currently not used.
Shows an image file save dialog with all the available image file types.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSaveImageDialog( _
   ByVal control As Control, _
   ByVal document As vdDocument, _
   ByVal defaultFileName As String, _
   ByRef version As String _
) As String
Visual Basic (Usage) Copy Code
Dim control As Control
Dim document As vdDocument
Dim defaultFileName As String
Dim version As String
Dim value As String

value = SaveImageDialog.GetSaveImageDialog(control, document, defaultFileName, version)
C#
public static string GetSaveImageDialog(
   Control control,
   vdDocument document,
   string defaultFileName,
   out string version
)

Parameters

control
The parent of the dialog.
document
The active document.
defaultFileName
The default filename that appears in the dialog.
version
Currently not used.

Return Value

The full path of the selected filename.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SaveImageDialog Class
SaveImageDialog Members


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%PageItemTitle%% $$Events$$

FrmMaterials Class Events
[image]
vdRay.Dialogs Namespace : FrmMaterials Class

For a list of all members of this type, see FrmMaterials members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

FrmMaterials Class
vdRay.Dialogs Namespace


%%PageItemTitle%% $$Properties$$

FrmMaterials Class Properties
[image]
vdRay.Dialogs Namespace : FrmMaterials Class

For a list of all members of this type, see FrmMaterials members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

FrmMaterials Class
vdRay.Dialogs Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

vdRay.Dialogs Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
vdRay.Dialogs.FrmMaterials
vdRay.Dialogs.SaveImageDialog

See Also

Reference

vdRay Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

vdRay Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
vdRay.vdRayComponent
vdRay.Radiosity
vdRay.vdPointView
vdRay.vdPointViews
vdRay.vdRayComponent.ErrorMessages
vdRay.vdRayComponent.RefreshFrameParams
vdRay.vdRayGlobals
vdRay.VdVideo

See Also

Reference

vdRay Assembly