See Also

See Also Converter 3.0 Help

Converter

Description

VectorDraw File Converter is an end-user application utility that gives you the ability to convert the most commonly used drawing documents (DWG, DGN and DXF) to the new VectorDraw format standards (VDCL, VDML) and vice versa.

VectorDraw Converter Full handles the following formats:
DWG/DXF (version 9 up to 2007), DGN (ver 8) and VDF/VDI/VDP (ver 5x1).
Also can export files to DWF (ver 4.2 to 6.0) and SVG. VectorDraw Converter Lite does not support export to DWF and SVG files
The utility exports the above files to SVG and DWF formats. VectorDraw File Converter Full can also undertake multiple file conversions (e.g. *.dwg to *.vdf or *.dxf and vise versa).

VectorDraw Converter Lite handles the following formats:
DWG/DXF (version 2000 up to 2007), DGN (ver 8), VDCL/VDML and VDF/VDI (5x1).

Usage: (Some features below are not supported in Lite version)
Open a Single File:
If selected, the source file will be a single file.

Save To a Single File:
If selected, the source file must be a single filename (not *.* or *.extension) and the source file will be converted into the specific Destination file format. Using the FileConverter Full then you can easily convert a DGN file directly in a DWG file. The Lite version cannot do that in one step. You will have to convert the DGN to a VDCL/VDML file (step 1) and then this new VDCL/VDML file to a DWG file (step 2)

Open Files on Folder: (This feature is not supported in Lite version)
If selected, the source files will be from a specific folder with a specific file type format.

Source File/Folder:
- can be a file of the following extensions (VDCL/VDML/VDF/VDI/VDP/DWG/DXF/DGN)
- can be a directory in the following form: (This feature is not supported in Lite version)
-example: c:\mydrawings\*.*
in this case VectorDraw Converter Full will try to convert all Known file extension in the directory.
-example: c:\mydrawings\*.DWG
in this case VectorDraw Converter Full will try to convert all DWG file extension in the directory.

Convert SubFolders: (This feature is not supported in Lite version)
If selected, all the files in the the folder and it's subfolders , will be converted.

Export Distribution files: (This feature is not supported in Lite version)
If selected, the destination file must be a folder in the following form:
-example: c:\mydrawings\Converter\VDF\*.VDF
In this case the Source(s) files will be saved in the destination directory (c:\mydrawings\Converter\VDF\) and all dependencies files of the source file will be saved also in the destination folder. The converted drawing extension in this example will have the extension VDF. For example if the source file has XRef(s) attached or images (BMP/JPG/PNG/TIF/GIF) or SHX fonts.

Destination File/Folder:
Selects the destination file (Lite version) or folder see <Export Distribution files> (Only Full version)
It can also have the following form:
-example: c:\mydrawings\Converter\VDF\>.VDF
In this case the Source(s) files will be saved in the destination directory (c:\mydrawings\Converter\VDF\) without checking for dependency files. The converted drawing extension in this example will have the extension VDF.

File Version:
Specifies the version of the files in which they will be saved.

SavePreviewImage:
If selected, the saved drawings will include the preview image also.
Note: By selecting this, saving will be slower.

DWG/DXF SPECIFICATIONS
VectorDraw differences on opening and saving DWG/DXF 2004 files
ACIS Objects like :
• 3D Solids
• Region
• Body
Are now converted and shown as vdPolyface objects.
Not supported objects :
• Leader
• OleFrame
• Ray
• RText
• Shape
• XLine
• Some minor Dimension's & DimStyles Properties (See DimStyles, Dimensions and DimStyles Overwrites for more)
• Hatch objects are converted to PolyHatch Objects.
• Multi ViewPorts in Model Space
• Dictionary - XRecord Objects (You can use XProperties)
• Group of objects
Our development team is currently working on these issues.

DGN SPECIFICATIONS

OPEN DGN FILE:
Solid | SUPPORTED
Single Hatch | SUPPORTED
Double Hatch | SUPPORTED (with one angle and scale).
Pattern | NOT SUPPORTED (Converted to single hatch). NOTE: If saved from VectorDraw all filltypes supported (xproperty is added to the entity and then opened again as it was.
Linetypes | SUPPORTED (some converted to vdlinetypes and some not supported).
Levels | SUPPORTED as Layers
Dimstyles | NOT SUPPORTED
Textstyles | NOT SUPPORTED
Weights | SUPPORTED
Models | SUPPORTED as Layouts
ViewGroup | NOT SUPPORTED
Views | NOT SUPPORTED (View 1 is shown).
Cells | SUPPORTED as Blocks.
Custom Palette | SUPPORTED (The Palette is loaded from the drawing and attached to the vdcolor palette) Custom palette files NOT SUPPORTED.
Tooltip,URL | SUPPORTED (if saved from VectorDraw).
XPROPERTIES | SUPPORTED (if saved from VectorDraw).
Fonts | SUPPORTED

Entities:

Line | SUPPORTED (converted to vdline).
Ellipse | SUPPORTED (converted to vdellipse).
Arc | SUPPORTED (converted to vdarc).
Circle | SUPPORTED (converted to vdcircle).
Shape | SUPPORTED (converted to closed polyline).
Cells | SUPPORTED (converted to vdinsert).
Text | SUPPORTED (converted to vdtext).
Line String | SUPPORTED (converted to (open) polyline).
Complex Shapes | SUPPORTED (converted to polyline,divided to multipoints and added to a single polyline).
Cylinder,Cone | SUPPORTED (converted to vdpolyface).
B-spline Curve | SUPPORTED (converted to polyline).
Raster References | SUPPORTED (converted to vdimage).
Textnode | SUPPORTED (exploded to texts).
B-spline Surface | converted to vdpolyface (B-spline Surface with weigths not supported).
Solid | SUPPORTED (exploded to its elements).
Dimensions | SUPPORTED (converted to vddimension (rotated, diameter, radial, angular and some (basically radial,diameter) exploded to dimension and lines,text)
References | SUPPORTED (converted to xRef). Refence to same file if it is on a model converted to vdviewport.
Tag | SUPPORTED (converted to text).
Mesh | SUPPORTED (converted to polyface).

SAVE DGN FILE:

Linetypes | SUPPORTED
Layers | SUPPORTED (converted to levels).
Weigths | SUPPORTED
Layouts | SUPPORTED (converted to models).
Custom Palette | SUPPORTED (VectorDraw Palette is saved).
Blocks | SUPPORTED (converted to shared cells).
DimStyles | NOT SUPPORTED.
TextStyles | NOT SUPPORTED.
Fonts | NOT SUPPORTED.
Tooltip,URL | SUPPORTED (tooltip and URL are added to the entities as attributes and opened again from VectorDraw ).
XPROPERTIES | SUPPORTED (XProperties are added to the entities as attributes and opened again from VectorDraw ).
FILL | SUPPORTED. ALL fillmodes other than VdFillModeHatchBlock,VdFillModeImage are supported and converted into inserts containing lines and filled shapes for solid hatches.

Entities:

VDLINE | SUPPORTED (converted to line).
VDCIRCLE | SUPPORTED (converted to ellipse).
VDELLIPSE | SUPPORTED (converted to arc).
VDARC | SUPPORTED (converted to arc).
VDPOLYLINE | SUPPORTED (converted to line string if is opened to shape if closed or filled exploded to line string if it is a SPline or it has bulges).
VDINSERT | SUPPORTED (converted to cell).
VDTEXT | SUPPORTED (converted to text).
VDDIMENSION | SUPPORTED (converted to dimension).
VDPOLYFACE | SUPPORTED (converted to cell with shapes).
VD3DFACE | SUPPORTED (converted to shape).
VDATTRIB | SUPPORTED (converted to text).
VDPOINT | SUPPORTED (converted to line with 0.00001 length).
VDIMAGE | SUPPORTED (converted to raster reference).
VDVIEWPORT | SUPPORTED (converted to xref to the same drawing).
VDPOLYHATCH | NOT SUPPORTED

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Thursday, December 16, 2004


See Also

See Also Converter 3.0 Help

Licences and Warranties

Description

VECTORDRAW FILE CONVERTER COPYRIGHT NOTICE, LICENSE AND DISCLAIMER.

Copyright (c) 2004 by VectorDraw Inc.

Permission to use, copy and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both the copyright notice and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of VectorDraw not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission.

VectorDraw Inc. disclaims all warranties with regard to this software, including all implied warranties of merchantability and fitness. In no event shall VectorDraw be liable for any special, indirect or consequential damages or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use or performance of this software.

VectorDraw Inc. hereby expressly declares that does not grant to the user any permission or license, direct or implied to use, modify, edit, port, reproduce or create any kind of distributable applications and/or derivative works, or any intellectual property right of the Open Design Alliance Inc. Libraries and in case the user does, is the sole responsible for any intellectual property rights violation. In no event shall VectorDraw be liable for any damage resulting from such use etc.

DWGdirectX © 2004-2007 by Open Design Alliance Inc. All rights reserved.

Remarks

Send comments on this topic.

© 2004 VectorDraw Corporation. All rights reserved.
Last updated : Thursday, December 16, 2004