VelocityDb Namespace

The VelocityDb name space contains classes for the VelocityDB Object Database.
Classes
 | Class | Description
Public class | AllObjectsT | An object of this type is returned by AllObjectsT(Boolean, Boolean) or AllObjectsT(Boolean)
Public class | AllObjectsTAllObjectsIterator | Iterator of type AllObjectsT
Public class | AllObjectsExtension | A few extensions to improve performance of Linq for Objects queries
Public class | AutoPlacement | This is the placement manager of objects persisted using Persist(Object), it is automatically created when the first object of a type is persisted. It is the first object in the database of each type mapped Database.
Public class | Database | Represents a Database which corresponds to file system file.
Public class | DatabaseLocation | Represents a host and a directory in which a range of databases are stored. The range is a database number range.
Public class | DatabaseLocations | Maintains collections of all existing DatabaseLocations.
Public class | DataCache | Object maintains a list of pages accessed by a session, pages are removed from the list when there is not enough memory available. This makes such pages eligible for garbage collection while in list pages are prevented from being garbage collected.
Public class | License | Contains a list of possible license attributes for licensing VelocityDb class library and server
Public class | OfType | An object of this type is a base class of type returned by AllObjectsT(Boolean, Boolean) or AllObjectsT(Boolean)
Public class | OfTypeOfTypeIterator | Iterator for type OfType
Public class | OfTypeExtension | A few extensions to improve performance of Linq for Objects queries
Public class | OptimizedPersistable | Base class for all persistent capable classes except for embedded objects which do not need to be subclasses of this class.
Public class | Page | Each Database consist of a number of variable sized pages. A page can be compressed and may be encrypted and contains one or more objects. Page compression is controlled by the DatabaseLocation of the Database containing a page. Each page has a PageInfo that provides info about a page and can be updated to turn on/off compression and encryption for a specific page.
Public class | PageCache | Maintains string references to Pages within a Database
Public class | PageInfo | Each Page has a PageInfo that provides info about a page and can be used to turn on/off compression and encryption for a page.
Public class | Placement | This class is used when deciding where to place a new object persistently. That is we have a choice of database number, page number and page number. There is other ways to control the placement including ObjectsPerPage, PagesPerDatabase, and it is also possible to override Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).
Public class | ReferenceTracked | Tracks references to this object and signals ReferentialIntegrityException if unpersisted before while still being referenced.
Public class | WeakIOptimizedPersistableReferenceT | When a persistent object is opened, all its referenced objects are opened as well. In order to limit the number of opened objects, you need to use this class. A reference from an instance of this class will not cause the referenced object to be opened. It will be opened when you ask for it.
Public class | WeakIOptimizedPersistableReferenceBase | This is the base class for all weak references.
Public class | WeakIOptimizedPersistableReferenceXT | Obsolete. Deprecated, use WeakIOptimizedPersistableReference instead (so name conflict can be avoided) When a persistent object is opened, all its referenced objects are opened as well. In order to limit the number of opened objects, you need to use this class. A reference from an instance of this class will not cause the referenced object to be opened. It will be opened when you ask for it. The Type of the weak referenced object, must be OptimizedPersistable
Structures
 | Structure | Description
Public structure | Oid | The object identifier containing a 32 bit database part, a 16 bit page part and a 16 bit page part. These parts are combined into a 64bit unsigned number Id.
Public structure | OidShort | The short object identifier containing a 16 bit page part and a 16 bit page part. This is used for short references within a single databases.
Interfaces
 | Interface | Description
Public interface | IOptimizedPersistable | add optimized persistence by implementing this interface. We provide OptimizedPersistable as a base class that implements this interface.
Public interface | IReferenceTracked | Maintains a set of all References to this object
Enumerations
 | Enumeration | Description
Public enumeration | CacheEnum | Choices for object caching
Public enumeration | OpFlags | Flag bits for a persistent object
Public enumeration | PageInfocompressionKind | Selection of choices foe Page compression.
Public enumeration | PageInfoencryptionKind | Use desEncrypted for encrypted pages, set encryption private key in DatabaseLocation. Use noEncryption when no encryption is desired. Other choices in this enum are not yet publicly available. Other kinds of encryption can be provided upon request. We can even make the interface public allowing application defined encryption.


AllObjects(T) Class

VelocityDB Class Library

AllObjectsT Class

An object of this type is returned by AllObjectsT(Boolean, Boolean) or AllObjectsT(Boolean)
Inheritance Hierarchy
SystemObject
VelocityDbOfType
VelocityDbAllObjectsT

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class AllObjects<T> : OfType,
    IEnumerable<T>, IEnumerable

Public Class AllObjects(Of T)
    Inherits OfType
    Implements IEnumerable(Of T), IEnumerable
generic<typename T>
public ref class AllObjects : public OfType,
    IEnumerable<T>, IEnumerable
type AllObjects<'T> =
    class
        inherit OfType
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The object type we are looking for in the iteration (enumeration)

The AllObjectsT type exposes the following members.

Constructors
 | Name | Description
Public method | AllObjectsT(BTreeSetT) | Constructs this enumeration wrapper object
Public method | AllObjectsT(Database, Boolean) | Constructs this enumeration wrapper object
Public method | AllObjectsT(SessionBase, Boolean, Boolean) | Constructs this enumeration wrapper object
Top
Properties
 | Name | Description
Public property | Count | Get a count of instances of the given type
Top
Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of type T
Top
Extension Methods
 | Name | Description
Public Extension Method | CountT | Override to improve performance over IEnumerable LINQ extension (Defined by AllObjectsExtension.)
Public Extension Method | ElementAt(Int32) | Overloaded. Override LINQ for faster access (Defined by OfTypeExtension.)
Public Extension Method | ElementAtT(Int32) | Overloaded. Override LINQ for faster access (Defined by AllObjectsExtension.)
Public Extension Method | Skip(Int32) | Overloaded. Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by OfTypeExtension.)
Public Extension Method | SkipTSource(Int32) | Overloaded. Bypasses a specified number of elements in a sequence and then returns the remaining elements. Overrides SkipTSource(IEnumerableTSource, Int32) for improved performance (Defined by AllObjectsExtension.)
Top
See Also

Reference

VelocityDb Namespace


AllObjects(T) Constructor

AllObjectsT Constructor

Overload List
 | Name | Description
Public method | AllObjectsT(BTreeSetT) | Constructs this enumeration wrapper object
Public method | AllObjectsT(Database, Boolean) | Constructs this enumeration wrapper object
Public method | AllObjectsT(SessionBase, Boolean, Boolean) | Constructs this enumeration wrapper object
Top
See Also

Reference

AllObjectsT Class
VelocityDb Namespace


AllObjects(T) Constructor (BTreeSet(T))

AllObjectsT Constructor (BTreeSetT)

Constructs this enumeration wrapper object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AllObjects(
    BTreeSet<T> bTree
)
Public Sub New (
    bTree As BTreeSet(Of T)
)
public:
AllObjects(
    BTreeSet<T>^ bTree
)
new :
        bTree : BTreeSet<'T> -> AllObjects

Parameters

bTree
Type: VelocityDb.Collection.BTreeBTreeSet T
A collection
See Also

Reference

AllObjectsT Class
AllObjectsT Overload
VelocityDb Namespace


AllObjects(T) Constructor (Database, Boolean)

AllObjectsT Constructor (Database, Boolean)

Constructs this enumeration wrapper object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AllObjects(
    Database db,
    bool includeSubclasses = false
)
Public Sub New (
    db As Database,
    Optional includeSubclasses As Boolean = false
)
public:
AllObjects(
    Database^ db,
    bool includeSubclasses = false
)
new :
        db : Database *
        ?includeSubclasses : bool
(* Defaults:
        let _includeSubclasses = defaultArg includeSubclasses false
*)
-> AllObjects

Parameters

db
Type: VelocityDbDatabase
The active db
includeSubclasses (Optional)
Type: SystemBoolean
Also return instances of sub classes
See Also

Reference

AllObjectsT Class
AllObjectsT Overload
VelocityDb Namespace


AllObjects(T) Constructor (SessionBase, Boolean, Boolean)

AllObjectsT Constructor (SessionBase, Boolean, Boolean)

Constructs this enumeration wrapper object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AllObjects(
    SessionBase session,
    bool includeSubclasses,
    bool databasePerType
)
Public Sub New (
    session As SessionBase,
    includeSubclasses As Boolean,
    databasePerType As Boolean
)
public:
AllObjects(
    SessionBase^ session,
    bool includeSubclasses,
    bool databasePerType
)
new :
        session : SessionBase *
        includeSubclasses : bool *
        databasePerType : bool -> AllObjects

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session
includeSubclasses
Type: SystemBoolean
Also return instances of sub classes
databasePerType
Type: SystemBoolean
Assume that persisted objects where made persistent the simple way using Persist(IOptimizedPersistable, NullableUInt16). When persisting this way, each object type gets its own Database which makes finding these objects easier and faster
See Also

Reference

AllObjectsT Class
AllObjectsT Overload
VelocityDb Namespace


AllObjects(T) Properties

AllObjectsT Properties

The AllObjectsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get a count of instances of the given type
Top
See Also

Reference

AllObjectsT Class
VelocityDb Namespace


AllObjects(T).Count Property

AllObjectsTCount Property

Get a count of instances of the given type

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Count { get; }
Public ReadOnly Property Count As ULong
    Get
public:
property unsigned long long Count {
    unsigned long long get ();
}
member Count : uint64 with get

Property Value

Type: UInt64
See Also

Reference

AllObjectsT Class
VelocityDb Namespace


AllObjects(T) Methods

AllObjectsT Methods

The AllObjectsT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of type T
Top
Extension Methods
 | Name | Description
Public Extension Method | CountT | Override to improve performance over IEnumerable LINQ extension (Defined by AllObjectsExtension.)
Public Extension Method | ElementAt(Int32) | Overloaded. Override LINQ for faster access (Defined by OfTypeExtension.)
Public Extension Method | ElementAtT(Int32) | Overloaded. Override LINQ for faster access (Defined by AllObjectsExtension.)
Public Extension Method | Skip(Int32) | Overloaded. Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by OfTypeExtension.)
Public Extension Method | SkipTSource(Int32) | Overloaded. Bypasses a specified number of elements in a sequence and then returns the remaining elements. Overrides SkipTSource(IEnumerableTSource, Int32) for improved performance (Defined by AllObjectsExtension.)
Top
See Also

Reference

AllObjectsT Class
VelocityDb Namespace


AllObjects(T).GetEnumerator Method

AllObjectsTGetEnumerator Method

Enumeration of all objects of type T

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumerator T
The enumerator of T

Implements

IEnumerableTGetEnumerator
See Also

Reference

AllObjectsT Class
VelocityDb Namespace


AllObjects(T).AllObjectsIterator Class

AllObjectsTAllObjectsIterator Class

Iterator of type AllObjectsT
Inheritance Hierarchy
SystemObject
VelocityDbOfTypeOfTypeIterator
VelocityDbAllObjectsTAllObjectsIterator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class AllObjectsIterator : OfTypeOfTypeIterator,
    IEnumerable<T>, IEnumerable
Public Class AllObjectsIterator
    Inherits OfTypeOfTypeIterator
    Implements IEnumerable(Of T), IEnumerable
public ref class AllObjectsIterator : public OfTypeOfTypeIterator,
    IEnumerable<T>, IEnumerable
type AllObjectsIterator =
    class
        inherit OfTypeOfTypeIterator
        interface IEnumerable<'T>
        interface IEnumerable
    end

The AllObjectsTAllObjectsIterator generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Top
See Also

Reference

VelocityDb Namespace


AllObjectsIterator Methods

The AllObjectsTAllObjectsIterator type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Top
See Also

Reference

AllObjectsTAllObjectsIterator Class
VelocityDb Namespace


AllObjects(T).AllObjectsIterator.GetEnumerator Method

AllObjectsTAllObjectsIteratorGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumerator T
An enumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

AllObjectsTAllObjectsIterator Class
VelocityDb Namespace


AllObjectsExtension Class

A few extensions to improve performance of Linq for Objects queries
Inheritance Hierarchy
SystemObject
VelocityDbAllObjectsExtension

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class AllObjectsExtension
<ExtensionAttribute>
Public NotInheritable Class AllObjectsExtension
[ExtensionAttribute]
public ref class AllObjectsExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type AllObjectsExtension =  class end

The AllObjectsExtension type exposes the following members.

Methods
Name | Description
CountT | Override to improve performance over IEnumerable LINQ extension
ElementAtT | Override LINQ for faster access
SkipTSource | Bypasses a specified number of elements in a sequence and then returns the remaining elements. Overrides SkipTSource(IEnumerableTSource, Int32) for improved performance
Top
See Also

Reference

VelocityDb Namespace


AllObjectsExtension Methods

The AllObjectsExtension type exposes the following members.

Methods
Name | Description
CountT | Override to improve performance over IEnumerable LINQ extension
ElementAtT | Override LINQ for faster access
SkipTSource | Bypasses a specified number of elements in a sequence and then returns the remaining elements. Overrides SkipTSource(IEnumerableTSource, Int32) for improved performance
Top
See Also

Reference

AllObjectsExtension Class
VelocityDb Namespace


AllObjectsExtension.Count(T) Method

AllObjectsExtensionCountT Method

Override to improve performance over IEnumerable LINQ extension

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int Count<T>(
    this AllObjects<T> sourceCollection
)

<ExtensionAttribute>
Public Shared Function Count(Of T) (
    sourceCollection As AllObjects(Of T)
) As Integer
public:
[ExtensionAttribute]
generic<typename T>
static int Count(
    AllObjects<T>^ sourceCollection
)
[<ExtensionAttribute>]
static member Count :
        sourceCollection : AllObjects<'T> -> int

Parameters

sourceCollection
Type: VelocityDbAllObjects T
the collection

Type Parameters

T
key type

Return Value

Type: Int32
Size of the collection

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AllObjects T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AllObjectsExtension Class
VelocityDb Namespace


AllObjectsExtension.ElementAt(T) Method

AllObjectsExtensionElementAtT Method

Override LINQ for faster access

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static T ElementAt<T>(
    this AllObjects<T> source,
    int index
)

<ExtensionAttribute>
Public Shared Function ElementAt(Of T) (
    source As AllObjects(Of T),
    index As Integer
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T ElementAt(
    AllObjects<T>^ source,
    int index
)
[<ExtensionAttribute>]
static member ElementAt :
        source : AllObjects<'T> *
        index : int -> 'T

Parameters

source
Type: VelocityDbAllObjects T
The source enumeration
index
Type: SystemInt32
The index requested

Type Parameters

T
The type of element requested

Return Value

Type: T
Element at requested index

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AllObjects T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AllObjectsExtension Class
VelocityDb Namespace


AllObjectsExtension.Skip(TSource) Method

AllObjectsExtensionSkipTSource Method

Bypasses a specified number of elements in a sequence and then returns the remaining elements. Overrides SkipTSource(IEnumerableTSource, Int32) for improved performance

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<TSource> Skip<TSource>(
    this AllObjects<TSource> source,
    int count
)

<ExtensionAttribute>
Public Shared Function Skip(Of TSource) (
    source As AllObjects(Of TSource),
    count As Integer
) As IEnumerable(Of TSource)
public:
[ExtensionAttribute]
generic<typename TSource>
static IEnumerable<TSource>^ Skip(
    AllObjects<TSource>^ source,
    int count
)
[<ExtensionAttribute>]
static member Skip :
        source : AllObjects<'TSource> *
        count : int -> IEnumerable<'TSource>

Parameters

source
Type: VelocityDbAllObjects TSource
Source collection
count
Type: SystemInt32
The number of elements to skip before returning the remaining elements.

Type Parameters

TSource
The type of the elements of source

Return Value

Type: IEnumerable TSource
An IEnumerableTthat contains the elements that occur after the specified index in the input sequence.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type AllObjects TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AllObjectsExtension Class
VelocityDb Namespace


AutoPlacement Class

This is the placement manager of objects persisted using Persist(Object), it is automatically created when the first object of a type is persisted. It is the first object in the database of each type mapped Database.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbPlacement
VelocityDbAutoPlacement

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AutoPlacement : Placement
<SerializableAttribute>
Public Class AutoPlacement
    Inherits Placement
[SerializableAttribute]
public ref class AutoPlacement : public Placement
[<SerializableAttribute>]
type AutoPlacement =
    class
        inherit Placement
    end

The AutoPlacement type exposes the following members.

Properties
 | Name | Description
Public property | Cache | We want to cache all AutoPlacement objects (small and frequently used) (Overrides OptimizedPersistableCache.)
Public property | Count | Get the total number of created objects of this type
Public property | Counter | Get the total number of created objects of this type
Top
Methods
 | Name | Description
Public method | IncrementTryDatabaseNumber | Moves to a new Database number used when placing (persisting) objects (Overrides PlacementIncrementTryDatabaseNumber.)
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
 | Open | Tries to open AutoPlacement object for a given database
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


AutoPlacement Properties

The AutoPlacement type exposes the following members.

Properties
 | Name | Description
Public property | Cache | We want to cache all AutoPlacement objects (small and frequently used) (Overrides OptimizedPersistableCache.)
Public property | Count | Get the total number of created objects of this type
Public property | Counter | Get the total number of created objects of this type
Top
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.Cache Property

AutoPlacementCache Property

We want to cache all AutoPlacement objects (small and frequently used)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.Count Property

AutoPlacementCount Property

Get the total number of created objects of this type

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Count { get; }
Public ReadOnly Property Count As ULong
    Get
public:
property unsigned long long Count {
    unsigned long long get ();
}
member Count : uint64 with get

Property Value

Type: UInt64
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.Counter Property

AutoPlacementCounter Property

Get the total number of created objects of this type

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Counter { get; set; }
Public Property Counter As ULong
    Get
    Set
public:
property unsigned long long Counter {
    unsigned long long get ();
    void set (unsigned long long value);
}
member Counter : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement Methods

The AutoPlacement type exposes the following members.

Methods
 | Name | Description
Public method | IncrementTryDatabaseNumber | Moves to a new Database number used when placing (persisting) objects (Overrides PlacementIncrementTryDatabaseNumber.)
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
 | Open | Tries to open AutoPlacement object for a given database
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.IncrementTryDatabaseNumber Method

AutoPlacementIncrementTryDatabaseNumber Method

Moves to a new Database number used when placing (persisting) objects

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint IncrementTryDatabaseNumber()
Public Overrides Function IncrementTryDatabaseNumber As UInteger
public:
virtual unsigned int IncrementTryDatabaseNumber() override
abstract IncrementTryDatabaseNumber : unit -> uint32
override IncrementTryDatabaseNumber : unit -> uint32

Return Value

Type: UInt32
The Database number before incrementing
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.InitializeAfterRead Method

AutoPlacementInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.AutoPlacement.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.AutoPlacement.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


AutoPlacement.Open Method

AutoPlacementOpen Method

Tries to open AutoPlacement object for a given database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IOptimizedPersistable Open(
    SessionBase session,
    uint databaseNumber,
    ushort objectsPerPage,
    bool usesAutoIncrement
)
Public Shared Function Open (
    session As SessionBase,
    databaseNumber As UInteger,
    objectsPerPage As UShort,
    usesAutoIncrement As Boolean
) As IOptimizedPersistable
public:
static IOptimizedPersistable^ Open(
    SessionBase^ session,
    unsigned int databaseNumber,
    unsigned short objectsPerPage,
    bool usesAutoIncrement
)
static member Open :
        session : SessionBase *
        databaseNumber : uint32 *
        objectsPerPage : uint16 *
        usesAutoIncrement : bool -> IOptimizedPersistable

Parameters

session
Type: VelocityDb.SessionSessionBase
Active session
databaseNumber
Type: SystemUInt32
Database number used by Type using this AutoPlacement
objectsPerPage
Type: SystemUInt16
Requested max number of objects per page
usesAutoIncrement
Type: SystemBoolean
Type for which AutoPlacement is used must not use any auto increment fields or else parallel add of this object type is not possible with simple persist.

Return Value

Type: IOptimizedPersistable
null if doesn't exist, the persistent AutoPlacement object if we able to read it from the Database without a lock conflict, a transient AutoPlacement if auto increment isn't used and we get a lock conflict; otherwise throw lock conflict exception
See Also

Reference

AutoPlacement Class
VelocityDb Namespace


CacheEnum Enumeration

Choices for object caching

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum CacheEnum
Public Enumeration CacheEnum
public enum class CacheEnum
type CacheEnum
Members
Member name | Value | Description
No | 0 | Do not cache
Yes | 1 | Always cache
is64Bit | 2 | Cache if running as 64 bit process
RamAvailable5Gb | 3 | Cache if at least 5GB memory is available
RamAvailable10Gb | 4 | Cache if at least 10GB memory is available
RamAvailable20Gb | 5 | Cache if at least 20GB memory is available
Available100Gb | 6 | Cache if at least 100GB memory is available
See Also

Reference

VelocityDb Namespace


Database Class

Represents a Database which corresponds to file system file.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbDatabase

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Database : OptimizedPersistable, IEnumerable<Page>,
    IEnumerable, IEqualityComparer<Database>, IDisposable
<SerializableAttribute>
Public Class Database
    Inherits OptimizedPersistable
    Implements IEnumerable(Of Page), IEnumerable,
    IEqualityComparer(Of Database), IDisposable
[SerializableAttribute]
public ref class Database : public OptimizedPersistable,
    IEnumerable<Page^>, IEnumerable, IEqualityComparer<Database^>,
    IDisposable
[<SerializableAttribute>]
type Database =
    class
        inherit OptimizedPersistable
        interface IEnumerable<Page>
        interface IEnumerable
        interface IEqualityComparer<Database>
        interface IDisposable
    end

The Database type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We want to be sure that the object representing a Database can share its page with other objects so override AllowOtherTypesOnSamePage and return true. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | CachedVerified | Setting this property to false will trigger a comparison of the cached version of the Database with the on disk version. Each new transaction also sets this property to false for all cached databases. You may alternatively use the session API ForceDatabaseCacheValidation() to trigger validation of all cached databases. Setting it to false when the Database has been updated in the current transaction is ignored.
Public property | FileInfo | FileInfo for this Database, not set for ServerClientSession
Public property | FileStream | Stream used for reading and writing this Database
Public property | HighestPageNumber | Indicates the highest tryPageNumber number currently in use for this database.
Public property | IsDeleted | Gets info about this Database about to be deleted or not.
Public property | IsLocal | Gets info about this Database being on the local host or not.
Public property | IsNew | Indicates if database was created in the current transactionNumber
Public property | IsUpdated | Gets the updated state of the object (Overrides OptimizedPersistableIsUpdated.)
Public property | Location | The DatabaseLocation of this Database
Public property | Name | Optional name associated with a Database
Public property | NumberOfPages | Indicates how many pages this database contains.
Public property | ObjectCachingDefaultPolicy | Default strategy for this Database, defaults to ObjectCachingDefaultPolicy. (strategy is not persisted)
Public property | PageCacheEnabled | Turns on or off Page caching for this Database
Top
Methods
 | Name | Description
Public method | AllObjectsT | Gets an object used for enumerating all objects in this Database
Public method | Bytes | Avoid using this one for now, internal use.
Public method | CachedPage | Try to retrieve a cached Page
Public method | CloneAs | Any Database that only uses OidShort references can be cloned without changing any of the internals of the Database. This function simply copies the Database file. It is the user's responsibility to know that only OidShort references are used within the Database or else such references will still keep the original Database number.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals(Database) | Compares by version and page 0 offset
Public method | Equals(Database, Database) | Determines whether the specified objects are equal.
Public method | GetEnumerator | Gets an enumerable sequence of all the pages in this database.
Public method | GetHashCode | Returns a hash code for the specified object.
Public method | OfType | Gets an object used for enumerating all objects in this Database."/>
Public method | Pages | Gets an enumerable sequence of all the pages in this database.
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | ToString | Displays class name plus object id (Overrides OptimizedPersistableToString.)
Top
Fields
 | Name | Description
 | InitialReservedDatabaseNumbers |
Public field | m_guid |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


Database Properties

The Database type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We want to be sure that the object representing a Database can share its page with other objects so override AllowOtherTypesOnSamePage and return true. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | CachedVerified | Setting this property to false will trigger a comparison of the cached version of the Database with the on disk version. Each new transaction also sets this property to false for all cached databases. You may alternatively use the session API ForceDatabaseCacheValidation() to trigger validation of all cached databases. Setting it to false when the Database has been updated in the current transaction is ignored.
Public property | FileInfo | FileInfo for this Database, not set for ServerClientSession
Public property | FileStream | Stream used for reading and writing this Database
Public property | HighestPageNumber | Indicates the highest tryPageNumber number currently in use for this database.
Public property | IsDeleted | Gets info about this Database about to be deleted or not.
Public property | IsLocal | Gets info about this Database being on the local host or not.
Public property | IsNew | Indicates if database was created in the current transactionNumber
Public property | IsUpdated | Gets the updated state of the object (Overrides OptimizedPersistableIsUpdated.)
Public property | Location | The DatabaseLocation of this Database
Public property | Name | Optional name associated with a Database
Public property | NumberOfPages | Indicates how many pages this database contains.
Public property | ObjectCachingDefaultPolicy | Default strategy for this Database, defaults to ObjectCachingDefaultPolicy. (strategy is not persisted)
Public property | PageCacheEnabled | Turns on or off Page caching for this Database
Top
See Also

Reference

Database Class
VelocityDb Namespace


Database.AllowOtherTypesOnSamePage Property

DatabaseAllowOtherTypesOnSamePage Property

We want to be sure that the object representing a Database can share its page with other objects so override AllowOtherTypesOnSamePage and return true.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

Database Class
VelocityDb Namespace


Database.CachedVerified Property

DatabaseCachedVerified Property

Setting this property to false will trigger a comparison of the cached version of the Database with the on disk version. Each new transaction also sets this property to false for all cached databases. You may alternatively use the session API ForceDatabaseCacheValidation() to trigger validation of all cached databases. Setting it to false when the Database has been updated in the current transaction is ignored.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool CachedVerified { get; set; }
Public Property CachedVerified As Boolean
    Get
    Set
public:
property bool CachedVerified {
    bool get ();
    void set (bool value);
}
member CachedVerified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Database Class
VelocityDb Namespace


Database.FileInfo Property

DatabaseFileInfo Property

FileInfo for this Database, not set for ServerClientSession

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FileInfo FileInfo { get; set; }
Public Property FileInfo As FileInfo
    Get
    Set
public:
property FileInfo^ FileInfo {
    FileInfo^ get ();
    void set (FileInfo^ value);
}
member FileInfo : FileInfo with get, set

Property Value

Type: FileInfo
See Also

Reference

Database Class
VelocityDb Namespace


Database.FileStream Property

DatabaseFileStream Property

Stream used for reading and writing this Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Stream FileStream { get; set; }
Public Property FileStream As Stream
    Get
    Set
public:
property Stream^ FileStream {
    Stream^ get ();
    void set (Stream^ value);
}
member FileStream : Stream with get, set

Property Value

Type: Stream
See Also

Reference

Database Class
VelocityDb Namespace


Database.HighestPageNumber Property

DatabaseHighestPageNumber Property

Indicates the highest tryPageNumber number currently in use for this database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort HighestPageNumber { get; }
Public ReadOnly Property HighestPageNumber As UShort
    Get
public:
property unsigned short HighestPageNumber {
    unsigned short get ();
}
member HighestPageNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Database Class
VelocityDb Namespace


Database.IsDeleted Property

DatabaseIsDeleted Property

Gets info about this Database about to be deleted or not.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get
public:
property bool IsDeleted {
    bool get ();
}
member IsDeleted : bool with get

Property Value

Type: Boolean
See Also

Reference

Database Class
VelocityDb Namespace


Database.IsLocal Property

DatabaseIsLocal Property

Gets info about this Database being on the local host or not.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; }
Public ReadOnly Property IsLocal As Boolean
    Get
public:
property bool IsLocal {
    bool get ();
}
member IsLocal : bool with get

Return Value

Type: Boolean
true if this Database is located on the local host; otherwise, false.
See Also

Reference

Database Class
VelocityDb Namespace


Database.IsNew Property

DatabaseIsNew Property

Indicates if database was created in the current transactionNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsNew { get; }
Public ReadOnly Property IsNew As Boolean
    Get
public:
property bool IsNew {
    bool get ();
}
member IsNew : bool with get

Property Value

Type: Boolean
See Also

Reference

Database Class
VelocityDb Namespace


Database.IsUpdated Property

DatabaseIsUpdated Property

Gets the updated state of the object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool IsUpdated { get; set; }
Public Overrides Property IsUpdated As Boolean
    Get
    Set
public:
virtual property bool IsUpdated {
    bool get () override;
    void set (bool value) override;
}
abstract IsUpdated : bool with get, set
override IsUpdated : bool with get, set

Property Value

Type: Boolean
true if updated; otherwise false

Implements

IOptimizedPersistableIsUpdated
See Also

Reference

Database Class
VelocityDb Namespace


Database.Location Property

DatabaseLocation Property

The DatabaseLocation of this Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation Location { get; }
Public ReadOnly Property Location As DatabaseLocation
    Get
public:
property DatabaseLocation^ Location {
    DatabaseLocation^ get ();
}
member Location : DatabaseLocation with get

Property Value

Type: DatabaseLocation
See Also

Reference

Database Class
VelocityDb Namespace


Database.Name Property

DatabaseName Property

Optional name associated with a Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Database Class
VelocityDb Namespace


Database.NumberOfPages Property

DatabaseNumberOfPages Property

Indicates how many pages this database contains.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort NumberOfPages { get; }
Public ReadOnly Property NumberOfPages As UShort
    Get
public:
property unsigned short NumberOfPages {
    unsigned short get ();
}
member NumberOfPages : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Database Class
VelocityDb Namespace


Database.ObjectCachingDefaultPolicy Property

DatabaseObjectCachingDefaultPolicy Property

Default strategy for this Database, defaults to ObjectCachingDefaultPolicy. (strategy is not persisted)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public CacheEnum ObjectCachingDefaultPolicy { get; set; }
Public Property ObjectCachingDefaultPolicy As CacheEnum
    Get
    Set
public:
property CacheEnum ObjectCachingDefaultPolicy {
    CacheEnum get ();
    void set (CacheEnum value);
}
member ObjectCachingDefaultPolicy : CacheEnum with get, set

Property Value

Type: CacheEnum
See Also

Reference

Database Class
VelocityDb Namespace


Database.PageCacheEnabled Property

DatabasePageCacheEnabled Property

Turns on or off Page caching for this Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool PageCacheEnabled { get; set; }
Public Property PageCacheEnabled As Boolean
    Get
    Set
public:
property bool PageCacheEnabled {
    bool get ();
    void set (bool value);
}
member PageCacheEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Database Class
VelocityDb Namespace


Database Methods

The Database type exposes the following members.

Methods
 | Name | Description
Public method | AllObjectsT | Gets an object used for enumerating all objects in this Database
Public method | Bytes | Avoid using this one for now, internal use.
Public method | CachedPage | Try to retrieve a cached Page
Public method | CloneAs | Any Database that only uses OidShort references can be cloned without changing any of the internals of the Database. This function simply copies the Database file. It is the user's responsibility to know that only OidShort references are used within the Database or else such references will still keep the original Database number.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals(Database) | Compares by version and page 0 offset
Public method | Equals(Database, Database) | Determines whether the specified objects are equal.
Public method | GetEnumerator | Gets an enumerable sequence of all the pages in this database.
Public method | GetHashCode | Returns a hash code for the specified object.
Public method | OfType | Gets an object used for enumerating all objects in this Database."/>
Public method | Pages | Gets an enumerable sequence of all the pages in this database.
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | ToString | Displays class name plus object id (Overrides OptimizedPersistableToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Database Class
VelocityDb Namespace


Database.AllObjects(T) Method

DatabaseAllObjectsT Method

Gets an object used for enumerating all objects in this Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AllObjects<T> AllObjects<T>(
    bool includeSubClasses = true
)

Public Function AllObjects(Of T) (
    Optional includeSubClasses As Boolean = true
) As AllObjects(Of T)
public:
generic<typename T>
AllObjects<T>^ AllObjects(
    bool includeSubClasses = true
)
member AllObjects :
        ?includeSubClasses : bool
(* Defaults:
        let _includeSubClasses = defaultArg includeSubClasses true
*)
-> AllObjects<'T>

Parameters

includeSubClasses (Optional)
Type: SystemBoolean
Also return instances of sub classes

Type Parameters

T
The type of object we are looking for

Return Value

Type: AllObjects T
The enumeration wrapper object
See Also

Reference

Database Class
VelocityDb Namespace


Database.Bytes Method

DatabaseBytes Method

Avoid using this one for now, internal use.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public byte[] Bytes()
Public Function Bytes As Byte()
public:
array<unsigned char>^ Bytes()
member Bytes : unit -> byte[]

Return Value

Type: Byte
The bytes of the Database
See Also

Reference

Database Class
VelocityDb Namespace


Database.CachedPage Method

DatabaseCachedPage Method

Try to retrieve a cached Page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Page CachedPage(
    ushort pageNumber
)
Public Function CachedPage (
    pageNumber As UShort
) As Page
public:
Page^ CachedPage(
    unsigned short pageNumber
)
member CachedPage :
        pageNumber : uint16 -> Page

Parameters

pageNumber
Type: SystemUInt16
Page number of page to look for in cache

Return Value

Type: Page
Page if found in cache; otherwise null
See Also

Reference

Database Class
VelocityDb Namespace


Database.CloneAs Method

DatabaseCloneAs Method

Any Database that only uses OidShort references can be cloned without changing any of the internals of the Database. This function simply copies the Database file. It is the user's responsibility to know that only OidShort references are used within the Database or else such references will still keep the original Database number.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Database CloneAs(
    uint otherAvaialbleDatabaseNumber
)
Public Function CloneAs (
    otherAvaialbleDatabaseNumber As UInteger
) As Database
public:
Database^ CloneAs(
    unsigned int otherAvaialbleDatabaseNumber
)
member CloneAs :
        otherAvaialbleDatabaseNumber : uint32 -> Database

Parameters

otherAvaialbleDatabaseNumber
Type: SystemUInt32
The desired Id of the Database clone

Return Value

Type: Database
The Database clone
See Also

Reference

Database Class
VelocityDb Namespace


Database.Dispose Method

DatabaseDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Database Class
VelocityDb Namespace


Database.Equals Method

DatabaseEquals Method

Overload List
 | Name | Description
Public method | Equals(Database) | Compares by version and page 0 offset
Public method | Equals(Database, Database) | Determines whether the specified objects are equal.
Top
See Also

Reference

Database Class
VelocityDb Namespace


Database.Equals Method (Database)

DatabaseEquals Method (Database)

Compares by version and page 0 offset

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Database other
)
Public Function Equals (
    other As Database
) As Boolean
public:
bool Equals(
    Database^ other
)
member Equals :
        other : Database -> bool

Parameters

other
Type: VelocityDbDatabase
Other Database object

Return Value

Type: Boolean
true if matching; otherwise false
See Also

Reference

Database Class
Equals Overload
VelocityDb Namespace


Database.Equals Method (Database, Database)

DatabaseEquals Method (Database, Database)

Determines whether the specified objects are equal.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Database x,
    Database y
)
Public Function Equals (
    x As Database,
    y As Database
) As Boolean
public:
virtual bool Equals(
    Database^ x,
    Database^ y
) sealed
abstract Equals :
        x : Database *
        y : Database -> bool
override Equals :
        x : Database *
        y : Database -> bool

Parameters

x
Type: VelocityDbDatabase
The first object of type T to compare.
y
Type: VelocityDbDatabase
The second object of type T to compare.

Return Value

Type: Boolean
true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

Database Class
Equals Overload
VelocityDb Namespace


Database.GetEnumerator Method

DatabaseGetEnumerator Method

Gets an enumerable sequence of all the pages in this database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<Page> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Page)
public:
virtual IEnumerator<Page^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Page>
override GetEnumerator : unit -> IEnumerator<Page>

Return Value

Type: IEnumerator Page
Enumeration of pages in a Database

Implements

IEnumerableTGetEnumerator
See Also

Reference

Database Class
VelocityDb Namespace


Database.GetHashCode Method

DatabaseGetHashCode Method

Returns a hash code for the specified object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Database db
)
Public Function GetHashCode (
    db As Database
) As Integer
public:
virtual int GetHashCode(
    Database^ db
) sealed
abstract GetHashCode :
        db : Database -> int
override GetHashCode :
        db : Database -> int

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDb.Database.GetHashCode(VelocityDb.Database)"]

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
Exceptions
Exception | Condition
ArgumentNullException | The type of obj is a reference type and obj is null.
See Also

Reference

Database Class
VelocityDb Namespace


Database.OfType Method

DatabaseOfType Method

Gets an object used for enumerating all objects in this Database."/>

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OfType OfType(
    Type type,
    bool includeSubClasses = true
)
Public Function OfType (
    type As Type,
    Optional includeSubClasses As Boolean = true
) As OfType
public:
OfType^ OfType(
    Type^ type,
    bool includeSubClasses = true
)
member OfType :
        type : Type *
        ?includeSubClasses : bool
(* Defaults:
        let _includeSubClasses = defaultArg includeSubClasses true
*)
-> OfType

Parameters

type
Type: SystemType
Type to look for
includeSubClasses (Optional)
Type: SystemBoolean
Also return instances of sub classes

Return Value

Type: OfType
The enumeration wrapper OfType(Type, Boolean)object
See Also

Reference

Database Class
VelocityDb Namespace


Database.Pages Method

DatabasePages Method

Gets an enumerable sequence of all the pages in this database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Page> Pages(
    bool stubsOnly = true
)
Public Function Pages (
    Optional stubsOnly As Boolean = true
) As IEnumerable(Of Page)
public:
IEnumerable<Page^>^ Pages(
    bool stubsOnly = true
)
member Pages :
        ?stubsOnly : bool
(* Defaults:
        let _stubsOnly = defaultArg stubsOnly true
*)
-> IEnumerable<Page>

Parameters

stubsOnly (Optional)
Type: SystemBoolean
Load page stub only?

Return Value

Type: IEnumerable Page
Enumeration of pages in a Database
See Also

Reference

Database Class
VelocityDb Namespace


Database.ReadMe Method

DatabaseReadMe Method

[Missing <summary> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.Database.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

Database Class
VelocityDb Namespace


Database.ToString Method

DatabaseToString Method

Displays class name plus object id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String containing class name and object id.
See Also

Reference

Database Class
VelocityDb Namespace


Database Fields

The Database type exposes the following members.

Fields
 | Name | Description
 | InitialReservedDatabaseNumbers |
Public field | m_guid |
Top
See Also

Reference

Database Class
VelocityDb Namespace


Database.InitialReservedDatabaseNumbers Field

DatabaseInitialReservedDatabaseNumbers Field

[Missing <summary> documentation for "F:VelocityDb.Database.InitialReservedDatabaseNumbers"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint InitialReservedDatabaseNumbers = 9
Public Const InitialReservedDatabaseNumbers As UInteger = 9
public:
literal unsigned int InitialReservedDatabaseNumbers = 9
static val mutable InitialReservedDatabaseNumbers: uint32

Field Value

Type: UInt32
See Also

Reference

Database Class
VelocityDb Namespace


Database.m_guid Field

Databasem_guid Field

[Missing <summary> documentation for "F:VelocityDb.Database.m_guid"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[NonSerializedAttribute]
public Guid m_guid
<NonSerializedAttribute>
Public m_guid As Guid
public:
[NonSerializedAttribute]
Guid m_guid
[<NonSerializedAttribute>]
val mutable m_guid: Guid

Field Value

Type: Guid
See Also

Reference

Database Class
VelocityDb Namespace


DatabaseLocation Class

Represents a host and a directory in which a range of databases are stored. The range is a database number range.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbDatabaseLocation

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DatabaseLocation : OptimizedPersistable,
    IComparable
<SerializableAttribute>
Public Class DatabaseLocation
    Inherits OptimizedPersistable
    Implements IComparable
[SerializableAttribute]
public ref class DatabaseLocation : public OptimizedPersistable,
    IComparable
[<SerializableAttribute>]
type DatabaseLocation =
    class
        inherit OptimizedPersistable
        interface IComparable
    end

The DatabaseLocation type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseLocation(String, String, UInt32, UInt32, SessionBase) | Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)
Public method | DatabaseLocation(String, String, UInt32, UInt32, SessionBase, PageInfocompressionKind, PageInfoencryptionKind, Boolean, DatabaseLocation) | Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)
Top
Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | BackupOfOrForLocation | Gets a linked DatabaseLocation that is either backup of location or is the location being backup up which is decided by IsBackupLocation
Public property | Cache | We do want to cache this kind of object since they are likely to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | CompressPages | Gets page compression info
Public property | DesKey | Gets the Des encryption key from a .des file in user Documents folder. (Environment.SpecialFolder.MyDocuments)
Public property | DirectoryPath | Gets the full path to the directory hosting databases
Public property | EndDatabaseNumber | Gets or sets the last database number within the range of databases for this location
Public property | HostName | Gets the host name of this database location
Public property | IsBackupLocation | Tells if this is a location used for backing up databases.
Public property | IsDefaultLocation | Is this the default DatabaseLocation where Database 0, 1, 2, 3, 4 may be stored?
Public property | IsLocal | Gets info about this location being on the local host or not.
Public property | PageEncryption | Gets the encryption kind attribute.
Public property | PlacementDatabaseNumber | Hint about where to persist DatabaseLocation (Overrides OptimizedPersistablePlacementDatabaseNumber.)
Public property | Replicas |
Public property | RsaPrivateXmlKey | The rsaPrivateXmlKey data field is not persisted but can be set and read with this property
Public property | RsaPublicXmlKey | The rsaPublicXmlKey data field is not persisted but can be set and read with this property
Public property | RsaSignature | The rsaSignature data field is not persisted but can be set and read with this property
Public property | StartDatabaseNumber | Gets and sets the start of the range of Database numbers for this location.
Top
Methods
 | Name | Description
Public method | CompareTo | The default compare of two DatabaseLocation is by host name and directory (Overrides OptimizedPersistableCompareTo(Object).)
Public method | ContainsDatabase | Check if this location contains a particular Database
Public method | ContainsNewDatabase | Check if this location contains a particular new database (not yet committed) Database
Public method | DatabasePath | Get the full path to a Database
Public method | Databases | Enumerates all Databases of this location
Public method | InitializeAfterRead | Sets the desKey field for desEncrypted locations by reading .des file in Environment.SpecialFolder.MyDocuments (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


DatabaseLocation Constructor

Overload List
 | Name | Description
Public method | DatabaseLocation(String, String, UInt32, UInt32, SessionBase) | Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)
Public method | DatabaseLocation(String, String, UInt32, UInt32, SessionBase, PageInfocompressionKind, PageInfoencryptionKind, Boolean, DatabaseLocation) | Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)
Top
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation Constructor (String, String, UInt32, UInt32, SessionBase)

Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation(
    string inHost,
    string dir,
    uint dbStartNum,
    uint dbEndNum,
    SessionBase session
)
Public Sub New (
    inHost As String,
    dir As String,
    dbStartNum As UInteger,
    dbEndNum As UInteger,
    session As SessionBase
)
public:
DatabaseLocation(
    String^ inHost,
    String^ dir,
    unsigned int dbStartNum,
    unsigned int dbEndNum,
    SessionBase^ session
)
new :
        inHost : string *
        dir : string *
        dbStartNum : uint32 *
        dbEndNum : uint32 *
        session : SessionBase -> DatabaseLocation

Parameters

inHost
Type: SystemString
Hostname of the computer with the DatabaseLocation directory.
dir
Type: SystemString
The full path of the directory
dbStartNum
Type: SystemUInt32
The first Database Id number for this location
dbEndNum
Type: SystemUInt32
The last Database Id number for this location.
session
Type: VelocityDb.SessionSessionBase
The active session used for creating the location.
See Also

Reference

DatabaseLocation Class
DatabaseLocation Overload
VelocityDb Namespace


DatabaseLocation Constructor (String, String, UInt32, UInt32, SessionBase, PageInfo.compressionKind, PageInfo.encryptionKind, Boolean, DatabaseLocation)

DatabaseLocation Constructor (String, String, UInt32, UInt32, SessionBase, PageInfocompressionKind, PageInfoencryptionKind, Boolean, DatabaseLocation)

Creates a transient Database location. A transient DatabaseLocation is made persistent by NewLocation(DatabaseLocation)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation(
    string inHost,
    string dir,
    uint dbStartNum,
    uint dbEndNum,
    SessionBase session,
    PageInfocompressionKind compressPages,
    PageInfoencryptionKind pageEncryption = PageInfoencryptionKind.noEncryption,
    bool isAbackupLocation = false,
    DatabaseLocation backupOfOrForLocation = null
)
Public Sub New (
    inHost As String,
    dir As String,
    dbStartNum As UInteger,
    dbEndNum As UInteger,
    session As SessionBase,
    compressPages As PageInfocompressionKind,
    Optional pageEncryption As PageInfoencryptionKind = PageInfoencryptionKind.noEncryption,
    Optional isAbackupLocation As Boolean = false,
    Optional backupOfOrForLocation As DatabaseLocation = Nothing
)
public:
DatabaseLocation(
    String^ inHost,
    String^ dir,
    unsigned int dbStartNum,
    unsigned int dbEndNum,
    SessionBase^ session,
    PageInfocompressionKind compressPages,
    PageInfoencryptionKind pageEncryption = PageInfoencryptionKind::noEncryption,
    bool isAbackupLocation = false,
    DatabaseLocation^ backupOfOrForLocation = nullptr
)
new :
        inHost : string *
        dir : string *
        dbStartNum : uint32 *
        dbEndNum : uint32 *
        session : SessionBase *
        compressPages : PageInfocompressionKind *
        ?pageEncryption : PageInfoencryptionKind *
        ?isAbackupLocation : bool *
        ?backupOfOrForLocation : DatabaseLocation
(* Defaults:
        let _pageEncryption = defaultArg pageEncryption PageInfoencryptionKind.noEncryption
        let _isAbackupLocation = defaultArg isAbackupLocation false
        let _backupOfOrForLocation = defaultArg backupOfOrForLocation null
*)
-> DatabaseLocation

Parameters

inHost
Type: SystemString
Hostname of the computer with the DatabaseLocation directory.
dir
Type: SystemString
The full path of the directory
dbStartNum
Type: SystemUInt32
The first Database Id number for this location
dbEndNum
Type: SystemUInt32
The last Database Id number for this location.
session
Type: VelocityDb.SessionSessionBase
The active session used for creating the location.
compressPages
Type: VelocityDbPageInfocompressionKind
Compress Database pages in this location?
pageEncryption (Optional)
Type: VelocityDbPageInfoencryptionKind
Specify what kind of Page encryption to use (if any)
isAbackupLocation (Optional)
Type: SystemBoolean
Is this location a backup location for another location?
backupOfOrForLocation (Optional)
Type: VelocityDbDatabaseLocation
The other location being backed up or the location contain the backups
See Also

Reference

DatabaseLocation Class
DatabaseLocation Overload
VelocityDb Namespace


DatabaseLocation Properties

The DatabaseLocation type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | BackupOfOrForLocation | Gets a linked DatabaseLocation that is either backup of location or is the location being backup up which is decided by IsBackupLocation
Public property | Cache | We do want to cache this kind of object since they are likely to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | CompressPages | Gets page compression info
Public property | DesKey | Gets the Des encryption key from a .des file in user Documents folder. (Environment.SpecialFolder.MyDocuments)
Public property | DirectoryPath | Gets the full path to the directory hosting databases
Public property | EndDatabaseNumber | Gets or sets the last database number within the range of databases for this location
Public property | HostName | Gets the host name of this database location
Public property | IsBackupLocation | Tells if this is a location used for backing up databases.
Public property | IsDefaultLocation | Is this the default DatabaseLocation where Database 0, 1, 2, 3, 4 may be stored?
Public property | IsLocal | Gets info about this location being on the local host or not.
Public property | PageEncryption | Gets the encryption kind attribute.
Public property | PlacementDatabaseNumber | Hint about where to persist DatabaseLocation (Overrides OptimizedPersistablePlacementDatabaseNumber.)
Public property | Replicas |
Public property | RsaPrivateXmlKey | The rsaPrivateXmlKey data field is not persisted but can be set and read with this property
Public property | RsaPublicXmlKey | The rsaPublicXmlKey data field is not persisted but can be set and read with this property
Public property | RsaSignature | The rsaSignature data field is not persisted but can be set and read with this property
Public property | StartDatabaseNumber | Gets and sets the start of the range of Database numbers for this location.
Top
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.AllowOtherTypesOnSamePage Property

DatabaseLocationAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.BackupOfOrForLocation Property

DatabaseLocationBackupOfOrForLocation Property

Gets a linked DatabaseLocation that is either backup of location or is the location being backup up which is decided by IsBackupLocation

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation BackupOfOrForLocation { get; set; }
Public Property BackupOfOrForLocation As DatabaseLocation
    Get
    Set
public:
property DatabaseLocation^ BackupOfOrForLocation {
    DatabaseLocation^ get ();
    void set (DatabaseLocation^ value);
}
member BackupOfOrForLocation : DatabaseLocation with get, set

Property Value

Type: DatabaseLocation
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.Cache Property

DatabaseLocationCache Property

We do want to cache this kind of object since they are likely to be frequently used.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.CompressPages Property

DatabaseLocationCompressPages Property

Gets page compression info

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageInfocompressionKind CompressPages { get; set; }
Public Property CompressPages As PageInfocompressionKind
    Get
    Set
public:
property PageInfocompressionKind CompressPages {
    PageInfocompressionKind get ();
    void set (PageInfocompressionKind value);
}
member CompressPages : PageInfocompressionKind with get, set

Return Value

Type: PageInfocompressionKind
true if the databases in this location uses compression; otherwise, false.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.DesKey Property

DatabaseLocationDesKey Property

Gets the Des encryption key from a .des file in user Documents folder. (Environment.SpecialFolder.MyDocuments)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public byte[] DesKey { get; set; }
Public Property DesKey As Byte()
    Get
    Set
public:
property array<unsigned char>^ DesKey {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member DesKey : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.DirectoryPath Property

DatabaseLocationDirectoryPath Property

Gets the full path to the directory hosting databases

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string DirectoryPath { get; }
Public ReadOnly Property DirectoryPath As String
    Get
public:
property String^ DirectoryPath {
    String^ get ();
}
member DirectoryPath : string with get

Property Value

Type: String
The path as a string
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.EndDatabaseNumber Property

DatabaseLocationEndDatabaseNumber Property

Gets or sets the last database number within the range of databases for this location

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint EndDatabaseNumber { get; set; }
Public Property EndDatabaseNumber As UInteger
    Get
    Set
public:
property unsigned int EndDatabaseNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member EndDatabaseNumber : uint32 with get, set

Property Value

Type: UInt32
The last database number within the range of databases for this location
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.HostName Property

DatabaseLocationHostName Property

Gets the host name of this database location

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string HostName { get; }
Public ReadOnly Property HostName As String
    Get
public:
property String^ HostName {
    String^ get ();
}
member HostName : string with get

Property Value

Type: String
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.IsBackupLocation Property

DatabaseLocationIsBackupLocation Property

Tells if this is a location used for backing up databases.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsBackupLocation { get; set; }
Public Property IsBackupLocation As Boolean
    Get
    Set
public:
property bool IsBackupLocation {
    bool get ();
    void set (bool value);
}
member IsBackupLocation : bool with get, set

Property Value

Type: Boolean
true if it is this location is used for backups; otherwise false.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.IsDefaultLocation Property

DatabaseLocationIsDefaultLocation Property

Is this the default DatabaseLocation where Database 0, 1, 2, 3, 4 may be stored?

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefaultLocation { get; }
Public ReadOnly Property IsDefaultLocation As Boolean
    Get
public:
property bool IsDefaultLocation {
    bool get ();
}
member IsDefaultLocation : bool with get

Property Value

Type: Boolean
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.IsLocal Property

DatabaseLocationIsLocal Property

Gets info about this location being on the local host or not.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; }
Public ReadOnly Property IsLocal As Boolean
    Get
public:
property bool IsLocal {
    bool get ();
}
member IsLocal : bool with get

Return Value

Type: Boolean
true if the location is located on the local host; otherwise, false.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.PageEncryption Property

DatabaseLocationPageEncryption Property

Gets the encryption kind attribute.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageInfoencryptionKind PageEncryption { get; set; }
Public Property PageEncryption As PageInfoencryptionKind
    Get
    Set
public:
property PageInfoencryptionKind PageEncryption {
    PageInfoencryptionKind get ();
    void set (PageInfoencryptionKind value);
}
member PageEncryption : PageInfoencryptionKind with get, set

Property Value

Type: PageInfoencryptionKind
The PageInfoencryptionKind used in this location
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.PlacementDatabaseNumber Property

DatabaseLocationPlacementDatabaseNumber Property

Hint about where to persist DatabaseLocation

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint PlacementDatabaseNumber { get; }
Public Overrides ReadOnly Property PlacementDatabaseNumber As UInteger
    Get
public:
virtual property unsigned int PlacementDatabaseNumber {
    unsigned int get () override;
}
abstract PlacementDatabaseNumber : uint32 with get
override PlacementDatabaseNumber : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistablePlacementDatabaseNumber
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.Replicas Property

DatabaseLocationReplicas Property

[Missing <summary> documentation for "P:VelocityDb.DatabaseLocation.Replicas"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<string> Replicas { get; }
Public ReadOnly Property Replicas As List(Of String)
    Get
public:
property List<String^>^ Replicas {
    List<String^>^ get ();
}
member Replicas : List<string> with get

Property Value

Type: List String
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.RsaPrivateXmlKey Property

DatabaseLocationRsaPrivateXmlKey Property

The rsaPrivateXmlKey data field is not persisted but can be set and read with this property

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string RsaPrivateXmlKey { get; set; }
Public Property RsaPrivateXmlKey As String
    Get
    Set
public:
property String^ RsaPrivateXmlKey {
    String^ get ();
    void set (String^ value);
}
member RsaPrivateXmlKey : string with get, set

Property Value

Type: String
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.RsaPublicXmlKey Property

DatabaseLocationRsaPublicXmlKey Property

The rsaPublicXmlKey data field is not persisted but can be set and read with this property

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string RsaPublicXmlKey { get; set; }
Public Property RsaPublicXmlKey As String
    Get
    Set
public:
property String^ RsaPublicXmlKey {
    String^ get ();
    void set (String^ value);
}
member RsaPublicXmlKey : string with get, set

Property Value

Type: String
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.RsaSignature Property

DatabaseLocationRsaSignature Property

The rsaSignature data field is not persisted but can be set and read with this property

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public byte[] RsaSignature { get; set; }
Public Property RsaSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ RsaSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member RsaSignature : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.StartDatabaseNumber Property

DatabaseLocationStartDatabaseNumber Property

Gets and sets the start of the range of Database numbers for this location.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint StartDatabaseNumber { get; set; }
Public Property StartDatabaseNumber As UInteger
    Get
    Set
public:
property unsigned int StartDatabaseNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member StartDatabaseNumber : uint32 with get, set

Property Value

Type: UInt32
The first database number within the range of databases for this location
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation Methods

The DatabaseLocation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | The default compare of two DatabaseLocation is by host name and directory (Overrides OptimizedPersistableCompareTo(Object).)
Public method | ContainsDatabase | Check if this location contains a particular Database
Public method | ContainsNewDatabase | Check if this location contains a particular new database (not yet committed) Database
Public method | DatabasePath | Get the full path to a Database
Public method | Databases | Enumerates all Databases of this location
Public method | InitializeAfterRead | Sets the desKey field for desEncrypted locations by reading .des file in Environment.SpecialFolder.MyDocuments (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.CompareTo Method

DatabaseLocationCompareTo Method

The default compare of two DatabaseLocation is by host name and directory

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object obj
)
Public Overrides Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) override
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject
The location to compare with

Return Value

Type: Int32
-1 if this location is less than the other, 0 if equal, otherwise 1

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.ContainsDatabase Method

DatabaseLocationContainsDatabase Method

Check if this location contains a particular Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsDatabase(
    uint dbNum,
    string extension = ".odb"
)
Public Function ContainsDatabase (
    dbNum As UInteger,
    Optional extension As String = ".odb"
) As Boolean
public:
bool ContainsDatabase(
    unsigned int dbNum,
    String^ extension = L".odb"
)
member ContainsDatabase :
        dbNum : uint32 *
        ?extension : string
(* Defaults:
        let _extension = defaultArg extension ".odb"
*)
-> bool

Parameters

dbNum
Type: SystemUInt32
The database number to look for
extension (Optional)
Type: SystemString
File name extension/id

Return Value

Type: Boolean
true if the location contains this database; otherwise, false.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.ContainsNewDatabase Method

DatabaseLocationContainsNewDatabase Method

Check if this location contains a particular new database (not yet committed) Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsNewDatabase(
    uint dbNum
)
Public Function ContainsNewDatabase (
    dbNum As UInteger
) As Boolean
public:
bool ContainsNewDatabase(
    unsigned int dbNum
)
member ContainsNewDatabase :
        dbNum : uint32 -> bool

Parameters

dbNum
Type: SystemUInt32
The database number to look for

Return Value

Type: Boolean
true if the location contains this new uncommitted database; otherwise, false.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.DatabasePath Method

DatabaseLocationDatabasePath Method

Get the full path to a Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string DatabasePath(
    uint dbNum
)
Public Function DatabasePath (
    dbNum As UInteger
) As String
public:
String^ DatabasePath(
    unsigned int dbNum
)
member DatabasePath :
        dbNum : uint32 -> string

Parameters

dbNum
Type: SystemUInt32
The database number to look for

Return Value

Type: String
A String containing the full Database path.
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.Databases Method

DatabaseLocationDatabases Method

Enumerates all Databases of this location

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Database> Databases()
Public Function Databases As IEnumerable(Of Database)
public:
IEnumerable<Database^>^ Databases()
member Databases : unit -> IEnumerable<Database>

Return Value

Type: IEnumerable Database

[Missing <returns> documentation for "M:VelocityDb.DatabaseLocation.Databases"]

See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.InitializeAfterRead Method

DatabaseLocationInitializeAfterRead Method

Sets the desKey field for desEncrypted locations by reading .des file in Environment.SpecialFolder.MyDocuments

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.InitializeAfterRecreate Method

DatabaseLocationInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.Persist Method

DatabaseLocationPersist Method

Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
The placement rules to follow when persisting this object
session
Type: VelocityDb.SessionSessionBase
The session managing this object
persistRefs (Optional)
Type: SystemBoolean
If true, objects referenced from this object will also be persisted
disableFlush (Optional)
Type: SystemBoolean
If true, disables possible flushing of updated pages while persisting this object; otherwise page flushing may occur
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A queue of objects remaining to be persisted. Pass as a parameter to session.Persist

Return Value

Type: UInt64
The object id of this persistent object

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocation.ReadMe Method

DatabaseLocationReadMe Method

[Missing <summary> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.DatabaseLocation.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

DatabaseLocation Class
VelocityDb Namespace


DatabaseLocations Class

Maintains collections of all existing DatabaseLocations.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbDatabaseLocations

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DatabaseLocations : OptimizedPersistable,
    IEnumerable<DatabaseLocation>, IEnumerable
<SerializableAttribute>
Public Class DatabaseLocations
    Inherits OptimizedPersistable
    Implements IEnumerable(Of DatabaseLocation), IEnumerable
[SerializableAttribute]
public ref class DatabaseLocations : public OptimizedPersistable,
    IEnumerable<DatabaseLocation^>, IEnumerable
[<SerializableAttribute>]
type DatabaseLocations =
    class
        inherit OptimizedPersistable
        interface IEnumerable<DatabaseLocation>
        interface IEnumerable
    end

The DatabaseLocations type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Top
Methods
 | Name | Description
Public method | Default | Returns the DatabaseLocation of the startup/system Databases.
Public method | GetEnumerator | Enumerates all DatabaseLocations
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | LocateDb | Returns the DatabaseLocation for which a Database exists in.
Public method | LocationForDb | Returns the DatabaseLocation for which a Database belongs to.
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


DatabaseLocations Properties

The DatabaseLocations type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Top
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.AllowOtherTypesOnSamePage Property

DatabaseLocationsAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations Methods

The DatabaseLocations type exposes the following members.

Methods
 | Name | Description
Public method | Default | Returns the DatabaseLocation of the startup/system Databases.
Public method | GetEnumerator | Enumerates all DatabaseLocations
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | LocateDb | Returns the DatabaseLocation for which a Database exists in.
Public method | LocationForDb | Returns the DatabaseLocation for which a Database belongs to.
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.Default Method

DatabaseLocationsDefault Method

Returns the DatabaseLocation of the startup/system Databases.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation Default()
Public Function Default As DatabaseLocation
public:
DatabaseLocation^ Default()
member Default : unit -> DatabaseLocation

Return Value

Type: DatabaseLocation
The default DatabaseLocation
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.GetEnumerator Method

DatabaseLocationsGetEnumerator Method

Enumerates all DatabaseLocations

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<DatabaseLocation> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DatabaseLocation)
public:
virtual IEnumerator<DatabaseLocation^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<DatabaseLocation>
override GetEnumerator : unit -> IEnumerator<DatabaseLocation>

Return Value

Type: IEnumerator DatabaseLocation
An IEnumeratorT object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.InitializeAfterRecreate Method

DatabaseLocationsInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.LocateDb Method

DatabaseLocationsLocateDb Method

Returns the DatabaseLocation for which a Database exists in.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation LocateDb(
    uint dbNum
)
Public Function LocateDb (
    dbNum As UInteger
) As DatabaseLocation
public:
DatabaseLocation^ LocateDb(
    unsigned int dbNum
)
member LocateDb :
        dbNum : uint32 -> DatabaseLocation

Parameters

dbNum
Type: SystemUInt32
The Database number to lookup location for

Return Value

Type: DatabaseLocation
The looked up DatabaseLocation or null if the Database does not exist
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.LocationForDb Method

DatabaseLocationsLocationForDb Method

Returns the DatabaseLocation for which a Database belongs to.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation LocationForDb(
    uint dbNum
)
Public Function LocationForDb (
    dbNum As UInteger
) As DatabaseLocation
public:
DatabaseLocation^ LocationForDb(
    unsigned int dbNum
)
member LocationForDb :
        dbNum : uint32 -> DatabaseLocation

Parameters

dbNum
Type: SystemUInt32
The Database number to lookup location for

Return Value

Type: DatabaseLocation
The looked up DatabaseLocation
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DatabaseLocations.ReadMe Method

DatabaseLocationsReadMe Method

Used by code generator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
memberBytes
Type: SystemByte
offset
Type: SystemInt32
session
Type: VelocityDb.SessionSessionBase
page
Type: VelocityDbPage
useOidShort
Type: SystemBoolean
schema
Type: VelocityDb.TypeInfoSchema
openRefs
Type: SystemBoolean
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
graphDepth
Type: SystemInt32
graphDepthToLoad
Type: SystemInt32
primitivesOnly
Type: SystemBoolean

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

DatabaseLocations Class
VelocityDb Namespace


DataCache Class

Object maintains a list of pages accessed by a session, pages are removed from the list when there is not enough memory available. This makes such pages eligible for garbage collection while in list pages are prevented from being garbage collected.
Inheritance Hierarchy
SystemObject
VelocityDbDataCache

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class DataCache
Public Class DataCache
public ref class DataCache
type DataCache =  class end

The DataCache type exposes the following members.

Properties
 | Name | Description
 | AvailableRamMB | Current available memory in MB as calculated by using PerformanceCounter or current use relative to MaximumMemoryUse
 | MaximumMemoryUse | Maximum number of bytes to allow for this Process (reduces cached objects and pages when memory allocated reaches this soft limit)
 | MemoryRamSize | Get the size of RAM memory on this computer.
 | MemoryUsedByThisProcess | The amount of virtual memory, in bytes, allocated for this process.
Public property | MinimumAvailableMegaBytes | Decide the minimum amount of available memory before reducing page caching and flushing updated pages. Only used by 32-bit process.
Public property | PageCacheEnabled | Enable or disable page cache. In cases where pages are not going to be revisited, performance may be improved by disabling the page cache. In other cases leave the page cache enabled (the default)
Top
Methods
 | Name | Description
Public method | Clear | Clear cache of cached pages
Top
Fields
Name | Description
s_computerInfo |
Top
See Also

Reference

VelocityDb Namespace


DataCache Properties

The DataCache type exposes the following members.

Properties
 | Name | Description
 | AvailableRamMB | Current available memory in MB as calculated by using PerformanceCounter or current use relative to MaximumMemoryUse
 | MaximumMemoryUse | Maximum number of bytes to allow for this Process (reduces cached objects and pages when memory allocated reaches this soft limit)
 | MemoryRamSize | Get the size of RAM memory on this computer.
 | MemoryUsedByThisProcess | The amount of virtual memory, in bytes, allocated for this process.
Public property | MinimumAvailableMegaBytes | Decide the minimum amount of available memory before reducing page caching and flushing updated pages. Only used by 32-bit process.
Public property | PageCacheEnabled | Enable or disable page cache. In cases where pages are not going to be revisited, performance may be improved by disabling the page cache. In other cases leave the page cache enabled (the default)
Top
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.AvailableRamMB Property

DataCacheAvailableRamMB Property

Current available memory in MB as calculated by using PerformanceCounter or current use relative to MaximumMemoryUse

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static uint AvailableRamMB { get; }
Public Shared ReadOnly Property AvailableRamMB As UInteger
    Get
public:
static property unsigned int AvailableRamMB {
    unsigned int get ();
}
static member AvailableRamMB : uint32 with get

Property Value

Type: UInt32
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.MaximumMemoryUse Property

DataCacheMaximumMemoryUse Property

Maximum number of bytes to allow for this Process (reduces cached objects and pages when memory allocated reaches this soft limit)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static long MaximumMemoryUse { get; set; }
Public Shared Property MaximumMemoryUse As Long
    Get
    Set
public:
static property long long MaximumMemoryUse {
    long long get ();
    void set (long long value);
}
static member MaximumMemoryUse : int64 with get, set

Property Value

Type: Int64
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.MemoryRamSize Property

DataCacheMemoryRamSize Property

Get the size of RAM memory on this computer.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong MemoryRamSize { get; }
Public Shared ReadOnly Property MemoryRamSize As ULong
    Get
public:
static property unsigned long long MemoryRamSize {
    unsigned long long get ();
}
static member MemoryRamSize : uint64 with get

Property Value

Type: UInt64
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.MemoryUsedByThisProcess Property

DataCacheMemoryUsedByThisProcess Property

The amount of virtual memory, in bytes, allocated for this process.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static long MemoryUsedByThisProcess { get; }
Public Shared ReadOnly Property MemoryUsedByThisProcess As Long
    Get
public:
static property long long MemoryUsedByThisProcess {
    long long get ();
}
static member MemoryUsedByThisProcess : int64 with get

Property Value

Type: Int64
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.MinimumAvailableMegaBytes Property

DataCacheMinimumAvailableMegaBytes Property

Decide the minimum amount of available memory before reducing page caching and flushing updated pages. Only used by 32-bit process.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong MinimumAvailableMegaBytes { get; set; }
Public Property MinimumAvailableMegaBytes As ULong
    Get
    Set
public:
property unsigned long long MinimumAvailableMegaBytes {
    unsigned long long get ();
    void set (unsigned long long value);
}
member MinimumAvailableMegaBytes : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.PageCacheEnabled Property

DataCachePageCacheEnabled Property

Enable or disable page cache. In cases where pages are not going to be revisited, performance may be improved by disabling the page cache. In other cases leave the page cache enabled (the default)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool PageCacheEnabled { get; set; }
Public Property PageCacheEnabled As Boolean
    Get
    Set
public:
property bool PageCacheEnabled {
    bool get ();
    void set (bool value);
}
member PageCacheEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache Methods

The DataCache type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear cache of cached pages
Top
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.Clear Method

DataCacheClear Method

Clear cache of cached pages

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache Fields

The DataCache type exposes the following members.

Fields
Name | Description
s_computerInfo |
Top
See Also

Reference

DataCache Class
VelocityDb Namespace


DataCache.s_computerInfo Field

DataCaches_computerInfo Field

[Missing <summary> documentation for "F:VelocityDb.DataCache.s_computerInfo"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ComputerInfo s_computerInfo
Public Shared s_computerInfo As ComputerInfo
public:
static ComputerInfo^ s_computerInfo
static val mutable s_computerInfo: ComputerInfo

Field Value

Type: ComputerInfo
See Also

Reference

DataCache Class
VelocityDb Namespace


IOptimizedPersistable Interface

add optimized persistence by implementing this interface. We provide OptimizedPersistable as a base class that implements this interface.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public interface IOptimizedPersistable : IComparable
Public Interface IOptimizedPersistable
    Inherits IComparable
public interface class IOptimizedPersistable : IComparable
type IOptimizedPersistable =
    interface
        interface IComparable
    end

The IOptimizedPersistable type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | By default true but override as returning false so that this type of objects isn't sharing pages with other type of objects.
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.
Public property | FieldsLoaded | Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]
Public property | FlushIfPageFull | By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)
Public property | Id | Gets the id of this object. The id is structured as Oid
Public property | IsPersistent | Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0
Public property | IsUpdated | Gets the updated state of the object
Public property | LazyLoadFields | By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).
Public property | MaxNumberOfDatabases | Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.
Public property | ObjectsPerPage | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PagesPerDatabase | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisting using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PlacementDatabaseNumber | Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.
Public property | RemovedFromIndices | true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices
Top
Methods
 | Name | Description
Public method | FlushTransients | Flushes batched up objects such as objects added with AddFast(Key)
Public method | GetPage | Get the persistent storage Page of this object
Public method | GetTypeVersion | The database engine needs this internally
Public method | GetWrappedObject | Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable
Public method | InitializeAfterRead | This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object.
Public method | PersistMyReferences | Persists references from this object
Public method | ReadMe | Provides a way to customize how an object is read. Used by a code generator
Public method | SetPage | Sets the persistent storage Page of this object
Public method | SetTypeVersion | The database engine needs this internally
Public method | ShallowCopyTo | Copies current object to a page
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.
Public method | Update | Call this function before updating any fields of this object
Public method | WriteMe | Provides a way to customize how an object is written. Used by a code generator
Top
See Also

Reference

VelocityDb Namespace


IOptimizedPersistable Properties

The IOptimizedPersistable type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | By default true but override as returning false so that this type of objects isn't sharing pages with other type of objects.
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.
Public property | FieldsLoaded | Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]
Public property | FlushIfPageFull | By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)
Public property | Id | Gets the id of this object. The id is structured as Oid
Public property | IsPersistent | Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0
Public property | IsUpdated | Gets the updated state of the object
Public property | LazyLoadFields | By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).
Public property | MaxNumberOfDatabases | Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.
Public property | ObjectsPerPage | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PagesPerDatabase | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisting using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PlacementDatabaseNumber | Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.
Public property | RemovedFromIndices | true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices
Top
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.AllowOtherTypesOnSamePage Property

IOptimizedPersistableAllowOtherTypesOnSamePage Property

By default true but override as returning false so that this type of objects isn't sharing pages with other type of objects.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool AllowOtherTypesOnSamePage { get; }
ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
property bool AllowOtherTypesOnSamePage {
    bool get ();
}
abstract AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Cache Property

IOptimizedPersistableCache Property

By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
CacheEnum Cache { get; }
ReadOnly Property Cache As CacheEnum
    Get
property CacheEnum Cache {
    CacheEnum get ();
}
abstract Cache : CacheEnum with get

Property Value

Type: CacheEnum
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.FieldsLoaded Property

IOptimizedPersistableFieldsLoaded Property

Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool FieldsLoaded { get; set; }
Property FieldsLoaded As Boolean
    Get
    Set
property bool FieldsLoaded {
    bool get ();
    void set (bool value);
}
abstract FieldsLoaded : bool with get, set

Property Value

Type: Boolean
true if all members are loaded; otherwise false
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.FlushIfPageFull Property

IOptimizedPersistableFlushIfPageFull Property

By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool FlushIfPageFull { get; }
ReadOnly Property FlushIfPageFull As Boolean
    Get
property bool FlushIfPageFull {
    bool get ();
}
abstract FlushIfPageFull : bool with get

Property Value

Type: Boolean
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Id Property

IOptimizedPersistableId Property

Gets the id of this object. The id is structured as Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
ulong Id { get; set; }
Property Id As ULong
    Get
    Set
property unsigned long long Id {
    unsigned long long get ();
    void set (unsigned long long value);
}
abstract Id : uint64 with get, set

Property Value

Type: UInt64
The id of this object or 0 if object is not persistent
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.IsPersistent Property

IOptimizedPersistableIsPersistent Property

Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool IsPersistent { get; }
ReadOnly Property IsPersistent As Boolean
    Get
property bool IsPersistent {
    bool get ();
}
abstract IsPersistent : bool with get

Property Value

Type: Boolean
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.IsUpdated Property

IOptimizedPersistableIsUpdated Property

Gets the updated state of the object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool IsUpdated { get; set; }
Property IsUpdated As Boolean
    Get
    Set
property bool IsUpdated {
    bool get ();
    void set (bool value);
}
abstract IsUpdated : bool with get, set

Property Value

Type: Boolean
true if updated; otherwise false
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.LazyLoadFields Property

IOptimizedPersistableLazyLoadFields Property

By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool LazyLoadFields { get; }
ReadOnly Property LazyLoadFields As Boolean
    Get
property bool LazyLoadFields {
    bool get ();
}
abstract LazyLoadFields : bool with get

Property Value

Type: Boolean
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.MaxNumberOfDatabases Property

IOptimizedPersistableMaxNumberOfDatabases Property

Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
uint MaxNumberOfDatabases { get; }
ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
property unsigned int MaxNumberOfDatabases {
    unsigned int get ();
}
abstract MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.ObjectsPerPage Property

IOptimizedPersistableObjectsPerPage Property

A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
ushort ObjectsPerPage { get; }
ReadOnly Property ObjectsPerPage As UShort
    Get
property unsigned short ObjectsPerPage {
    unsigned short get ();
}
abstract ObjectsPerPage : uint16 with get

Return Value

Type: UInt16
The requested number of objects per page.
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.PagesPerDatabase Property

IOptimizedPersistablePagesPerDatabase Property

A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisting using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
ushort PagesPerDatabase { get; }
ReadOnly Property PagesPerDatabase As UShort
    Get
property unsigned short PagesPerDatabase {
    unsigned short get ();
}
abstract PagesPerDatabase : uint16 with get

Return Value

Type: UInt16
The requested number of pages per database
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.PlacementDatabaseNumber Property

IOptimizedPersistablePlacementDatabaseNumber Property

Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
uint PlacementDatabaseNumber { get; }
ReadOnly Property PlacementDatabaseNumber As UInteger
    Get
property unsigned int PlacementDatabaseNumber {
    unsigned int get ();
}
abstract PlacementDatabaseNumber : uint32 with get

Property Value

Type: UInt32
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.RemovedFromIndices Property

IOptimizedPersistableRemovedFromIndices Property

true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool RemovedFromIndices { get; set; }
Property RemovedFromIndices As Boolean
    Get
    Set
property bool RemovedFromIndices {
    bool get ();
    void set (bool value);
}
abstract RemovedFromIndices : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable Methods

The IOptimizedPersistable type exposes the following members.

Methods
 | Name | Description
Public method | FlushTransients | Flushes batched up objects such as objects added with AddFast(Key)
Public method | GetPage | Get the persistent storage Page of this object
Public method | GetTypeVersion | The database engine needs this internally
Public method | GetWrappedObject | Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable
Public method | InitializeAfterRead | This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object.
Public method | PersistMyReferences | Persists references from this object
Public method | ReadMe | Provides a way to customize how an object is read. Used by a code generator
Public method | SetPage | Sets the persistent storage Page of this object
Public method | SetTypeVersion | The database engine needs this internally
Public method | ShallowCopyTo | Copies current object to a page
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.
Public method | Update | Call this function before updating any fields of this object
Public method | WriteMe | Provides a way to customize how an object is written. Used by a code generator
Top
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.FlushTransients Method

IOptimizedPersistableFlushTransients Method

Flushes batched up objects such as objects added with AddFast(Key)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void FlushTransients()
Sub FlushTransients
void FlushTransients()
abstract FlushTransients : unit -> unit
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.GetPage Method

IOptimizedPersistableGetPage Method

Get the persistent storage Page of this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
Page GetPage()
Function GetPage As Page
Page^ GetPage()
abstract GetPage : unit -> Page

Return Value

Type: Page
The persistent storage Pageof this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.GetTypeVersion Method

IOptimizedPersistableGetTypeVersion Method

The database engine needs this internally

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
TypeVersion GetTypeVersion()
Function GetTypeVersion As TypeVersion
TypeVersion^ GetTypeVersion()
abstract GetTypeVersion : unit -> TypeVersion

Return Value

Type: TypeVersion
The TypeVersion of this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.GetWrappedObject Method

IOptimizedPersistableGetWrappedObject Method

Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
Object GetWrappedObject()
Function GetWrappedObject As Object
Object^ GetWrappedObject()
abstract GetWrappedObject : unit -> Object

Return Value

Type: Object
Wrapped object if set; otherwise this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.InitializeAfterRead Method

IOptimizedPersistableInitializeAfterRead Method

This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void InitializeAfterRead(
    SessionBase session
)
Sub InitializeAfterRead (
    session As SessionBase
)
void InitializeAfterRead(
    SessionBase^ session
)
abstract InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.InitializeAfterRecreate Method

IOptimizedPersistableInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void InitializeAfterRecreate(
    SessionBase session
)
Sub InitializeAfterRecreate (
    session As SessionBase
)
void InitializeAfterRecreate(
    SessionBase^ session
)
abstract InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Persist Method

IOptimizedPersistablePersist Method

Overload List
 | Name | Description
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object.
Top
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Persist Method (SessionBase, IOptimizedPersistable, Boolean, Boolean)

IOptimizedPersistablePersist Method (SessionBase, IOptimizedPersistable, Boolean, Boolean)

Persists this object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
ulong Persist(
    SessionBase session,
    IOptimizedPersistable placeHint,
    bool persistRefs = true,
    bool disableFlush = false
)
Function Persist (
    session As SessionBase,
    placeHint As IOptimizedPersistable,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false
) As ULong
unsigned long long Persist(
    SessionBase^ session,
    IOptimizedPersistable^ placeHint,
    bool persistRefs = true,
    bool disableFlush = false
)
abstract Persist :
        session : SessionBase *
        placeHint : IOptimizedPersistable *
        ?persistRefs : bool *
        ?disableFlush : bool
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
*)
-> uint64

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object
placeHint
Type: VelocityDbIOptimizedPersistable
Use placement as specified by this object type, see PlacementDatabaseNumber, ObjectsPerPage and PagesPerDatabase
persistRefs (Optional)
Type: SystemBoolean
Persist any referenced object now or delay until flush/commit
disableFlush (Optional)
Type: SystemBoolean
Controls possible flushing of updated pages. Set to true if you want to prevent updated pages from being flushed to disk and setting such pages to a non updated state.

Return Value

Type: UInt64
The object id of the persistent object
See Also

Reference

IOptimizedPersistable Interface
Persist Overload
VelocityDb Namespace


IOptimizedPersistable.Persist Method (Placement, SessionBase, Boolean, Boolean, Queue(IOptimizedPersistable))

IOptimizedPersistablePersist Method (Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)

Persists this object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
)
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
The placement rules to follow when persisting this object
session
Type: VelocityDb.SessionSessionBase
The session managing this object
persistRefs (Optional)
Type: SystemBoolean
If true, objects referenced from this object will also be persisted
disableFlush (Optional)
Type: SystemBoolean
If true, disables possible flushing of updated pages while persisting this object; otherwise page flushing may occur
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A queue of objects remaining to be persisted. Pass as a parameter to session.Persist

Return Value

Type: UInt64
The object id of the persistent object
See Also

Reference

IOptimizedPersistable Interface
Persist Overload
VelocityDb Namespace


IOptimizedPersistable.PersistMyReferences Method

IOptimizedPersistablePersistMyReferences Method

Persists references from this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void PersistMyReferences(
    SessionBase session,
    bool inFlush
)
Sub PersistMyReferences (
    session As SessionBase,
    inFlush As Boolean
)
void PersistMyReferences(
    SessionBase^ session,
    bool inFlush
)
abstract PersistMyReferences :
        session : SessionBase *
        inFlush : bool -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object
inFlush
Type: SystemBoolean
are we in a page flush
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.ReadMe Method

IOptimizedPersistableReadMe Method

Provides a way to customize how an object is read. Used by a code generator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
the type version of the object being read
memberBytes
Type: SystemByte
the raw bytes to read the object from
offset
Type: SystemInt32
current offset into the raw object bytes
session
Type: VelocityDb.SessionSessionBase
the active session
page
Type: VelocityDbPage
the page of the object
useOidShort
Type: SystemBoolean
is object using short references
schema
Type: VelocityDb.TypeInfoSchema
the active schema
openRefs
Type: SystemBoolean
open references objects
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
a list of field members to load
graphDepth
Type: SystemInt32
current depth in object read
graphDepthToLoad
Type: SystemInt32
requested max object depth to read
primitivesOnly
Type: SystemBoolean
if true, only load primitive members (not referenced objects)
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.SetPage Method

IOptimizedPersistableSetPage Method

Sets the persistent storage Page of this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void SetPage(
    Page page
)
Sub SetPage (
    page As Page
)
void SetPage(
    Page^ page
)
abstract SetPage :
        page : Page -> unit

Parameters

page
Type: VelocityDbPage
A persistent storage Page
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.SetTypeVersion Method

IOptimizedPersistableSetTypeVersion Method

The database engine needs this internally

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void SetTypeVersion(
    TypeVersion shape
)
Sub SetTypeVersion (
    shape As TypeVersion
)
void SetTypeVersion(
    TypeVersion^ shape
)
abstract SetTypeVersion :
        shape : TypeVersion -> unit

Parameters

shape
Type: VelocityDb.TypeInfoTypeVersion
The TypeVersion to use for this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.ShallowCopyTo Method

IOptimizedPersistableShallowCopyTo Method

Copies current object to a page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
IOptimizedPersistable ShallowCopyTo(
    Page page
)
Function ShallowCopyTo (
    page As Page
) As IOptimizedPersistable
IOptimizedPersistable^ ShallowCopyTo(
    Page^ page
)
abstract ShallowCopyTo :
        page : Page -> IOptimizedPersistable

Parameters

page
Type: VelocityDbPage
The page to copy to

Return Value

Type: IOptimizedPersistable
Id of object copy
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Unpersist Method

IOptimizedPersistableUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
void Unpersist(
    SessionBase session
)
Sub Unpersist (
    session As SessionBase
)
void Unpersist(
    SessionBase^ session
)
abstract Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.Update Method

IOptimizedPersistableUpdate Method

Call this function before updating any fields of this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool Update()
Function Update As Boolean
bool Update()
abstract Update : unit -> bool

Return Value

Type: Boolean
true if update was successful; otherwise false
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IOptimizedPersistable.WriteMe Method

IOptimizedPersistableWriteMe Method

Provides a way to customize how an object is written. Used by a code generator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
byte[] WriteMe(
    TypeVersion typeVersion,
    bool addShapeNumber,
    PageInfo pageInfo,
    IOptimizedPersistable owner,
    SessionBase session,
    bool inFlush
)
Function WriteMe (
    typeVersion As TypeVersion,
    addShapeNumber As Boolean,
    pageInfo As PageInfo,
    owner As IOptimizedPersistable,
    session As SessionBase,
    inFlush As Boolean
) As Byte()
array<unsigned char>^ WriteMe(
    TypeVersion^ typeVersion,
    bool addShapeNumber,
    PageInfo^ pageInfo,
    IOptimizedPersistable^ owner,
    SessionBase^ session,
    bool inFlush
)
abstract WriteMe :
        typeVersion : TypeVersion *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
the type version of the object being written
addShapeNumber
Type: SystemBoolean
add type version number to object bytes
pageInfo
Type: VelocityDbPageInfo
the page info for the page to written to
owner
Type: VelocityDbIOptimizedPersistable
owning object
session
Type: VelocityDb.SessionSessionBase
the active session
inFlush
Type: SystemBoolean
are we in a page flush

Return Value

Type: Byte
Bytes representing this object
See Also

Reference

IOptimizedPersistable Interface
VelocityDb Namespace


IReferenceTracked Interface

Maintains a set of all References to this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public interface IReferenceTracked : IOptimizedPersistable,
    IComparable
Public Interface IReferenceTracked
    Inherits IOptimizedPersistable, IComparable
public interface class IReferenceTracked : IOptimizedPersistable,
    IComparable
type IReferenceTracked =
    interface
        interface IOptimizedPersistable
        interface IComparable
    end

The IReferenceTracked type exposes the following members.

Properties
 | Name | Description
Public property | References | Get a collection of references to this object
Top
See Also

Reference

VelocityDb Namespace


IReferenceTracked Properties

The IReferenceTracked type exposes the following members.

Properties
 | Name | Description
Public property | References | Get a collection of references to this object
Top
See Also

Reference

IReferenceTracked Interface
VelocityDb Namespace


IReferenceTracked.References Property

IReferenceTrackedReferences Property

Get a collection of references to this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
BTreeSet<Reference> References { get; }
ReadOnly Property References As BTreeSet(Of Reference)
    Get
property BTreeSet<Reference^>^ References {
    BTreeSet<Reference^>^ get ();
}
abstract References : BTreeSet<Reference> with get

Property Value

Type: BTreeSet Reference
See Also

Reference

IReferenceTracked Interface
VelocityDb Namespace


License Class

Contains a list of possible license attributes for licensing VelocityDb class library and server
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbLicense

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class License : OptimizedPersistable
<SerializableAttribute>
Public Class License
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class License : public OptimizedPersistable
[<SerializableAttribute>]
type License =
    class
        inherit OptimizedPersistable
    end

The License type exposes the following members.

Properties
 | Name | Description
Public property | DateTimeCreated | Gets the time of license creation.
Public property | DomainName | Gets the restricted domain name
Public property | ExpireDate | Gets expire time.
Public property | HostName | Gets the restricted host name
Public property | MajorVersion | Gets/set the major version attribute of a license
Public property | MaxNumberOfClients | Gets the maximum number of Server clients permitted by this license
Public property | MinorVersion | Gets/set the minor version attribute of a license
Public property | ObjectsPerPage | Store one License per Page (Overrides OptimizedPersistableObjectsPerPage.)
Public property | PlacementDatabaseNumber | Gets the preferred Database number for licenses (Overrides OptimizedPersistablePlacementDatabaseNumber.)
Public property | ProcessorCount | Gets/sets maximum number of processors for which license is valid.
Public property | UserName | Gets the user name restriction
Top
Methods
 | Name | Description
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | WriteMe | (Overrides OptimizedPersistableWriteMe(TypeVersion, Boolean, PageInfo, IOptimizedPersistable, SessionBase, Boolean).)
Top
Fields
Name | Description
LicenseCheckDatabase | The Database number of the database containing a VelocityDb license(s)
PlaceInDatabase | Hint about a Database location for this type of object.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


License Properties

The License type exposes the following members.

Properties
 | Name | Description
Public property | DateTimeCreated | Gets the time of license creation.
Public property | DomainName | Gets the restricted domain name
Public property | ExpireDate | Gets expire time.
Public property | HostName | Gets the restricted host name
Public property | MajorVersion | Gets/set the major version attribute of a license
Public property | MaxNumberOfClients | Gets the maximum number of Server clients permitted by this license
Public property | MinorVersion | Gets/set the minor version attribute of a license
Public property | ObjectsPerPage | Store one License per Page (Overrides OptimizedPersistableObjectsPerPage.)
Public property | PlacementDatabaseNumber | Gets the preferred Database number for licenses (Overrides OptimizedPersistablePlacementDatabaseNumber.)
Public property | ProcessorCount | Gets/sets maximum number of processors for which license is valid.
Public property | UserName | Gets the user name restriction
Top
See Also

Reference

License Class
VelocityDb Namespace


License.DateTimeCreated Property

LicenseDateTimeCreated Property

Gets the time of license creation.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTimeCreated { get; }
Public ReadOnly Property DateTimeCreated As DateTime
    Get
public:
property DateTime DateTimeCreated {
    DateTime get ();
}
member DateTimeCreated : DateTime with get

Property Value

Type: DateTime
See Also

Reference

License Class
VelocityDb Namespace


License.DomainName Property

LicenseDomainName Property

Gets the restricted domain name

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
member DomainName : string with get, set

Property Value

Type: String
See Also

Reference

License Class
VelocityDb Namespace


License.ExpireDate Property

LicenseExpireDate Property

Gets expire time.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DateTime ExpireDate { get; set; }
Public Property ExpireDate As DateTime
    Get
    Set
public:
property DateTime ExpireDate {
    DateTime get ();
    void set (DateTime value);
}
member ExpireDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

License Class
VelocityDb Namespace


License.HostName Property

LicenseHostName Property

Gets the restricted host name

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string HostName { get; set; }
Public Property HostName As String
    Get
    Set
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
member HostName : string with get, set

Property Value

Type: String
See Also

Reference

License Class
VelocityDb Namespace


License.MajorVersion Property

LicenseMajorVersion Property

Gets/set the major version attribute of a license

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
member MajorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

License Class
VelocityDb Namespace


License.MaxNumberOfClients Property

LicenseMaxNumberOfClients Property

Gets the maximum number of Server clients permitted by this license

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint MaxNumberOfClients { get; set; }
Public Property MaxNumberOfClients As UInteger
    Get
    Set
public:
property unsigned int MaxNumberOfClients {
    unsigned int get ();
    void set (unsigned int value);
}
member MaxNumberOfClients : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

License Class
VelocityDb Namespace


License.MinorVersion Property

LicenseMinorVersion Property

Gets/set the minor version attribute of a license

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
member MinorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

License Class
VelocityDb Namespace


License.ObjectsPerPage Property

LicenseObjectsPerPage Property

Store one License per Page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Return Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

License Class
VelocityDb Namespace


License.PlacementDatabaseNumber Property

LicensePlacementDatabaseNumber Property

Gets the preferred Database number for licenses

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint PlacementDatabaseNumber { get; }
Public Overrides ReadOnly Property PlacementDatabaseNumber As UInteger
    Get
public:
virtual property unsigned int PlacementDatabaseNumber {
    unsigned int get () override;
}
abstract PlacementDatabaseNumber : uint32 with get
override PlacementDatabaseNumber : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistablePlacementDatabaseNumber
See Also

Reference

License Class
VelocityDb Namespace


License.ProcessorCount Property

LicenseProcessorCount Property

Gets/sets maximum number of processors for which license is valid.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int ProcessorCount { get; set; }
Public Property ProcessorCount As Integer
    Get
    Set
public:
property int ProcessorCount {
    int get ();
    void set (int value);
}
member ProcessorCount : int with get, set

Property Value

Type: Int32
See Also

Reference

License Class
VelocityDb Namespace


License.UserName Property

LicenseUserName Property

Gets the user name restriction

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

License Class
VelocityDb Namespace


License Methods

The License type exposes the following members.

Methods
 | Name | Description
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | WriteMe | (Overrides OptimizedPersistableWriteMe(TypeVersion, Boolean, PageInfo, IOptimizedPersistable, SessionBase, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

License Class
VelocityDb Namespace


License.ReadMe Method

LicenseReadMe Method

[Missing <summary> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.License.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

License Class
VelocityDb Namespace


License.WriteMe Method

LicenseWriteMe Method

[Missing <summary> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override byte[] WriteMe(
    TypeVersion typeVersion,
    bool addShapeNumber,
    PageInfo pageInfo,
    IOptimizedPersistable owner,
    SessionBase session,
    bool inFlush
)
Public Overrides Function WriteMe (
    typeVersion As TypeVersion,
    addShapeNumber As Boolean,
    pageInfo As PageInfo,
    owner As IOptimizedPersistable,
    session As SessionBase,
    inFlush As Boolean
) As Byte()
public:
virtual array<unsigned char>^ WriteMe(
    TypeVersion^ typeVersion,
    bool addShapeNumber,
    PageInfo^ pageInfo,
    IOptimizedPersistable^ owner,
    SessionBase^ session,
    bool inFlush
) override
abstract WriteMe :
        typeVersion : TypeVersion *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]
override WriteMe :
        typeVersion : TypeVersion *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

addShapeNumber
Type: SystemBoolean

[Missing <param name="addShapeNumber"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

pageInfo
Type: VelocityDbPageInfo

[Missing <param name="pageInfo"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

owner
Type: VelocityDbIOptimizedPersistable

[Missing <param name="owner"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

inFlush
Type: SystemBoolean

[Missing <param name="inFlush"/> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:VelocityDb.License.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Implements

IOptimizedPersistableWriteMe(TypeVersion, Boolean, PageInfo, IOptimizedPersistable, SessionBase, Boolean)
See Also

Reference

License Class
VelocityDb Namespace


License Fields

The License type exposes the following members.

Fields
Name | Description
LicenseCheckDatabase | The Database number of the database containing a VelocityDb license(s)
PlaceInDatabase | Hint about a Database location for this type of object.
Top
See Also

Reference

License Class
VelocityDb Namespace


License.LicenseCheckDatabase Field

LicenseLicenseCheckDatabase Field

The Database number of the database containing a VelocityDb license(s)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint LicenseCheckDatabase = 4
Public Const LicenseCheckDatabase As UInteger = 4
public:
literal unsigned int LicenseCheckDatabase = 4
static val mutable LicenseCheckDatabase: uint32

Field Value

Type: UInt32
See Also

Reference

License Class
VelocityDb Namespace


License.PlaceInDatabase Field

LicensePlaceInDatabase Field

Hint about a Database location for this type of object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint PlaceInDatabase = 20
Public Const PlaceInDatabase As UInteger = 20
public:
literal unsigned int PlaceInDatabase = 20
static val mutable PlaceInDatabase: uint32

Field Value

Type: UInt32
See Also

Reference

License Class
VelocityDb Namespace


OfType Class

An object of this type is a base class of type returned by AllObjectsT(Boolean, Boolean) or AllObjectsT(Boolean)
Inheritance Hierarchy
SystemObject
VelocityDbOfType
VelocityDbAllObjectsT

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class OfType : IEnumerable
Public Class OfType
    Implements IEnumerable
public ref class OfType : IEnumerable
type OfType =
    class
        interface IEnumerable
    end

The OfType type exposes the following members.

Constructors
 | Name | Description
Public method | OfType(Type, Database, Boolean) | Constructs this enumeration wrapper object
Public method | OfType(Type, SessionBase, Boolean, Boolean) | Constructs this enumeration wrapper object
Top
Methods
 | Name | Description
Public method | Count | Get a count of instances of the given type. This value is computed by a quick iteration over all objects of the requested type.
Public method | GetEnumerator | Enumeration of all objects of the selected Type
Top
Extension Methods
 | Name | Description
Public Extension Method | ElementAt | Override LINQ for faster access (Defined by OfTypeExtension.)
Public Extension Method | Skip | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by OfTypeExtension.)
Top
See Also

Reference

VelocityDb Namespace


OfType Constructor

Overload List
 | Name | Description
Public method | OfType(Type, Database, Boolean) | Constructs this enumeration wrapper object
Public method | OfType(Type, SessionBase, Boolean, Boolean) | Constructs this enumeration wrapper object
Top
See Also

Reference

OfType Class
VelocityDb Namespace


OfType Constructor (Type, Database, Boolean)

Constructs this enumeration wrapper object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OfType(
    Type type,
    Database db,
    bool includeSubClasses = false
)
Public Sub New (
    type As Type,
    db As Database,
    Optional includeSubClasses As Boolean = false
)
public:
OfType(
    Type^ type,
    Database^ db,
    bool includeSubClasses = false
)
new :
        type : Type *
        db : Database *
        ?includeSubClasses : bool
(* Defaults:
        let _includeSubClasses = defaultArg includeSubClasses false
*)
-> OfType

Parameters

type
Type: SystemType
The Type to look for.
db
Type: VelocityDbDatabase
The active db
includeSubClasses (Optional)
Type: SystemBoolean
Also return instances of sub classes
See Also

Reference

OfType Class
OfType Overload
VelocityDb Namespace


OfType Constructor (Type, SessionBase, Boolean, Boolean)

Constructs this enumeration wrapper object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OfType(
    Type type,
    SessionBase session,
    bool includeSubclasses,
    bool databasePerType
)
Public Sub New (
    type As Type,
    session As SessionBase,
    includeSubclasses As Boolean,
    databasePerType As Boolean
)
public:
OfType(
    Type^ type,
    SessionBase^ session,
    bool includeSubclasses,
    bool databasePerType
)
new :
        type : Type *
        session : SessionBase *
        includeSubclasses : bool *
        databasePerType : bool -> OfType

Parameters

type
Type: SystemType
The Type of persisted objects to enumerate
session
Type: VelocityDb.SessionSessionBase
The active session
includeSubclasses
Type: SystemBoolean
Also return instances of sub classes
databasePerType
Type: SystemBoolean
Assume that persisted objects where made persistent the simple way using Persist(IOptimizedPersistable, NullableUInt16). When persisting this way, each object type gets its own Database which makes finding these objects easier and faster
See Also

Reference

OfType Class
OfType Overload
VelocityDb Namespace


OfType Methods

The OfType type exposes the following members.

Methods
 | Name | Description
Public method | Count | Get a count of instances of the given type. This value is computed by a quick iteration over all objects of the requested type.
Public method | GetEnumerator | Enumeration of all objects of the selected Type
Top
Extension Methods
 | Name | Description
Public Extension Method | ElementAt | Override LINQ for faster access (Defined by OfTypeExtension.)
Public Extension Method | Skip | Bypasses a specified number of elements in a sequence and then returns the remaining elements. (Defined by OfTypeExtension.)
Top
See Also

Reference

OfType Class
VelocityDb Namespace


OfType.Count Method

OfTypeCount Method

Get a count of instances of the given type. This value is computed by a quick iteration over all objects of the requested type.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ulong Count()
Public Overridable Function Count As ULong
public:
virtual unsigned long long Count()
abstract Count : unit -> uint64
override Count : unit -> uint64

Return Value

Type: UInt64
Number of instances found of the given Type
See Also

Reference

OfType Class
VelocityDb Namespace


OfType.GetEnumerator Method

OfTypeGetEnumerator Method

Enumeration of all objects of the selected Type

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
The enumeration

Implements

IEnumerableGetEnumerator
See Also

Reference

OfType Class
VelocityDb Namespace


OfType.OfTypeIterator Class

OfTypeOfTypeIterator Class

Iterator for type OfType
Inheritance Hierarchy
SystemObject
VelocityDbOfTypeOfTypeIterator
VelocityDbAllObjectsTAllObjectsIterator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class OfTypeIterator : IEnumerable
Public Class OfTypeIterator
    Implements IEnumerable
public ref class OfTypeIterator : IEnumerable
type OfTypeIterator =
    class
        interface IEnumerable
    end

The OfTypeOfTypeIterator type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of type T
Public method | GetObjects |
Public method | SkipIterator | Bypasses a specified number of elements in a sequence and then returns the remaining elements.
Public method | TakeIterator | Returns a specified number of contiguous elements from the start of a sequence.
Top
See Also

Reference

VelocityDb Namespace


OfTypeIterator Methods

The OfTypeOfTypeIterator type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of type T
Public method | GetObjects |
Public method | SkipIterator | Bypasses a specified number of elements in a sequence and then returns the remaining elements.
Public method | TakeIterator | Returns a specified number of contiguous elements from the start of a sequence.
Top
See Also

Reference

OfTypeOfTypeIterator Class
VelocityDb Namespace


OfType.OfTypeIterator.GetEnumerator Method

OfTypeOfTypeIteratorGetEnumerator Method

Enumeration of all objects of type T

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
The enumerator of T

Implements

IEnumerableGetEnumerator
See Also

Reference

OfTypeOfTypeIterator Class
VelocityDb Namespace


OfType.OfTypeIterator.GetObjects Method

OfTypeOfTypeIteratorGetObjects Method

[Missing <summary> documentation for "M:VelocityDb.OfType.OfTypeIterator.GetObjects"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable GetObjects()
Public Function GetObjects As IEnumerable
public:
IEnumerable^ GetObjects()
member GetObjects : unit -> IEnumerable

Return Value

Type: IEnumerable

[Missing <returns> documentation for "M:VelocityDb.OfType.OfTypeIterator.GetObjects"]

See Also

Reference

OfTypeOfTypeIterator Class
VelocityDb Namespace


OfType.OfTypeIterator.SkipIterator Method

OfTypeOfTypeIteratorSkipIterator Method

Bypasses a specified number of elements in a sequence and then returns the remaining elements.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable SkipIterator(
    int count
)
Public Function SkipIterator (
    count As Integer
) As IEnumerable
public:
IEnumerable^ SkipIterator(
    int count
)
member SkipIterator :
        count : int -> IEnumerable

Parameters

count
Type: SystemInt32
The number of elements to skip before returning the remaining elements.

Return Value

Type: IEnumerable
An IEnumerable that contains the elements that occur after the specified index in the input sequence.
See Also

Reference

OfTypeOfTypeIterator Class
VelocityDb Namespace


OfType.OfTypeIterator.TakeIterator Method

OfTypeOfTypeIteratorTakeIterator Method

Returns a specified number of contiguous elements from the start of a sequence.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable TakeIterator(
    int count
)
Public Function TakeIterator (
    count As Integer
) As IEnumerable
public:
IEnumerable^ TakeIterator(
    int count
)
member TakeIterator :
        count : int -> IEnumerable

Parameters

count
Type: SystemInt32
The number of elements to return.

Return Value

Type: IEnumerable
An IEnumerable that contains the specified number of elements from the start of the input sequence.
See Also

Reference

OfTypeOfTypeIterator Class
VelocityDb Namespace


OfTypeExtension Class

A few extensions to improve performance of Linq for Objects queries
Inheritance Hierarchy
SystemObject
VelocityDbOfTypeExtension

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class OfTypeExtension
<ExtensionAttribute>
Public NotInheritable Class OfTypeExtension
[ExtensionAttribute]
public ref class OfTypeExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type OfTypeExtension =  class end

The OfTypeExtension type exposes the following members.

Methods
Name | Description
ElementAt | Override LINQ for faster access
Skip | Bypasses a specified number of elements in a sequence and then returns the remaining elements.
Top
See Also

Reference

VelocityDb Namespace


OfTypeExtension Methods

The OfTypeExtension type exposes the following members.

Methods
Name | Description
ElementAt | Override LINQ for faster access
Skip | Bypasses a specified number of elements in a sequence and then returns the remaining elements.
Top
See Also

Reference

OfTypeExtension Class
VelocityDb Namespace


OfTypeExtension.ElementAt Method

OfTypeExtensionElementAt Method

Override LINQ for faster access

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Object ElementAt(
    this OfType source,
    int index
)
<ExtensionAttribute>
Public Shared Function ElementAt (
    source As OfType,
    index As Integer
) As Object
public:
[ExtensionAttribute]
static Object^ ElementAt(
    OfType^ source,
    int index
)
[<ExtensionAttribute>]
static member ElementAt :
        source : OfType *
        index : int -> Object

Parameters

source
Type: VelocityDbOfType
The source enumeration
index
Type: SystemInt32
The index requested

Return Value

Type: Object
Element at requested index

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OfType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OfTypeExtension Class
VelocityDb Namespace


OfTypeExtension.Skip Method

OfTypeExtensionSkip Method

Bypasses a specified number of elements in a sequence and then returns the remaining elements.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable Skip(
    this OfType source,
    int count
)
<ExtensionAttribute>
Public Shared Function Skip (
    source As OfType,
    count As Integer
) As IEnumerable
public:
[ExtensionAttribute]
static IEnumerable^ Skip(
    OfType^ source,
    int count
)
[<ExtensionAttribute>]
static member Skip :
        source : OfType *
        count : int -> IEnumerable

Parameters

source
Type: VelocityDbOfType
The Type being extended
count
Type: SystemInt32
The number of elements to skip before returning the remaining elements.

Return Value

Type: IEnumerable
An IEnumerable that contains the elements that occur after the specified index in the input sequence.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OfType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OfTypeExtension Class
VelocityDb Namespace


Oid Structure

The object identifier containing a 32 bit database part, a 16 bit page part and a 16 bit page part. These parts are combined into a 64bit unsigned number Id.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct Oid : IComparable<Oid>, IEqualityComparer<Oid>
<SerializableAttribute>
Public Structure Oid
    Implements IComparable(Of Oid), IEqualityComparer(Of Oid)
[SerializableAttribute]
public value class Oid : IComparable<Oid>,
    IEqualityComparer<Oid>
[<SealedAttribute>]
[<SerializableAttribute>]
type Oid =
    struct
        interface IComparable<Oid>
        interface IEqualityComparer<Oid>
    end

The Oid type exposes the following members.

Constructors
 | Name | Description
Public method | Oid(UInt64) | Creates an Oid
Public method | Oid(UInt32, UInt32) | Creates an Oid given a Database number and an OidShort (page-slot)
Public method | Oid(UInt32, OidShort) | Creates an Oid given a Database number and an OidShort (page-slot)
Top
Properties
 | Name | Description
Public property | Database | Gets the database number part of the Oid
Public property | Id | Gets the underlaying UInt64 that contains the encoded Oid.
Public property | IdShort | Gets the page-slot parts of the underlaying UInt64 that contains the encoded Oid.
Public property | Page | Gets the page number part of the Oid
Public property | Slot | Gets the slot number part of the Oid
Top
Methods
 | Name | Description
 | AsString | Builds a string with DatabaseNumber-PageNumber-SlotNumber
Public method | CompareTo | Compares two Oid objects by id
 | DatabaseNumber | Extracts the Database number
 | Encode(UInt32, UInt32) | Constructs a UInt64 from the components Database number and an encoded UInt32 contains page and slot number
 | Encode(UInt32, UInt16, UInt16) | Constructs a UInt64 from the components Database number, Page number and page number
Public method | Equals | Compares by Id
Public method | GetHashCode | Computes a hash code based on Id. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(Oid) | Returns a hash code for the specified object.
 | IdFromString |
 | PageNumber | Extracts the Page number
 | SamePageAs | Find out if Page number is the same in two different UInt64 numbers (encoded Oid)
 | SlotNumber(UInt64) | Extracts the page number
 | SlotNumber(UInt64, UInt16) | Sets the page number
Public method | ToString | Builds a string with DatabaseNumber-PageNumber-SlotNumber (Overrides ValueTypeToString.)
Top
Operators
Name | Description
GreaterThan | Compares the id of two Oid's
GreaterThanOrEqual | Compares the id of two Oid's
LessThan | Compares the id of two Oid's
LessThanOrEqual | Compares the id of two Oid's
Top
See Also

Reference

VelocityDb Namespace


Oid Constructor

Overload List
 | Name | Description
Public method | Oid(UInt64) | Creates an Oid
Public method | Oid(UInt32, UInt32) | Creates an Oid given a Database number and an OidShort (page-slot)
Public method | Oid(UInt32, OidShort) | Creates an Oid given a Database number and an OidShort (page-slot)
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid Constructor (UInt64)

Creates an Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid(
    ulong id
)
Public Sub New (
    id As ULong
)
public:
Oid(
    unsigned long long id
)
new :
        id : uint64 -> Oid

Parameters

id
Type: SystemUInt64
Higest 32 bit is Database number, then follows the 16 bit Page number and the 16 bit page number
See Also

Reference

Oid Structure
Oid Overload
VelocityDb Namespace


Oid Constructor (UInt32, UInt32)

Creates an Oid given a Database number and an OidShort (page-slot)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid(
    uint dbId,
    uint pageSlotId
)
Public Sub New (
    dbId As UInteger,
    pageSlotId As UInteger
)
public:
Oid(
    unsigned int dbId,
    unsigned int pageSlotId
)
new :
        dbId : uint32 *
        pageSlotId : uint32 -> Oid

Parameters

dbId
Type: SystemUInt32
The Database number
pageSlotId
Type: SystemUInt32
The page and slot numbers as a UInt32
See Also

Reference

Oid Structure
Oid Overload
VelocityDb Namespace


Oid Constructor (UInt32, OidShort)

Creates an Oid given a Database number and an OidShort (page-slot)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid(
    uint dbId,
    OidShort pageSlotId
)
Public Sub New (
    dbId As UInteger,
    pageSlotId As OidShort
)
public:
Oid(
    unsigned int dbId,
    OidShort pageSlotId
)
new :
        dbId : uint32 *
        pageSlotId : OidShort -> Oid

Parameters

dbId
Type: SystemUInt32
The Database number
pageSlotId
Type: VelocityDbOidShort
The page and slot numbers as an OidShort
See Also

Reference

Oid Structure
Oid Overload
VelocityDb Namespace


Oid Properties

The Oid type exposes the following members.

Properties
 | Name | Description
Public property | Database | Gets the database number part of the Oid
Public property | Id | Gets the underlaying UInt64 that contains the encoded Oid.
Public property | IdShort | Gets the page-slot parts of the underlaying UInt64 that contains the encoded Oid.
Public property | Page | Gets the page number part of the Oid
Public property | Slot | Gets the slot number part of the Oid
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Database Property

OidDatabase Property

Gets the database number part of the Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint Database { get; }
Public ReadOnly Property Database As UInteger
    Get
public:
property unsigned int Database {
    unsigned int get ();
}
member Database : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Id Property

OidId Property

Gets the underlaying UInt64 that contains the encoded Oid.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Id { get; }
Public ReadOnly Property Id As ULong
    Get
public:
property unsigned long long Id {
    unsigned long long get ();
}
member Id : uint64 with get

Property Value

Type: UInt64
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.IdShort Property

OidIdShort Property

Gets the page-slot parts of the underlaying UInt64 that contains the encoded Oid.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint IdShort { get; }
Public ReadOnly Property IdShort As UInteger
    Get
public:
property unsigned int IdShort {
    unsigned int get ();
}
member IdShort : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Page Property

OidPage Property

Gets the page number part of the Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort Page { get; }
Public ReadOnly Property Page As UShort
    Get
public:
property unsigned short Page {
    unsigned short get ();
}
member Page : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Slot Property

OidSlot Property

Gets the slot number part of the Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort Slot { get; }
Public ReadOnly Property Slot As UShort
    Get
public:
property unsigned short Slot {
    unsigned short get ();
}
member Slot : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid Methods

The Oid type exposes the following members.

Methods
 | Name | Description
 | AsString | Builds a string with DatabaseNumber-PageNumber-SlotNumber
Public method | CompareTo | Compares two Oid objects by id
 | DatabaseNumber | Extracts the Database number
 | Encode(UInt32, UInt32) | Constructs a UInt64 from the components Database number and an encoded UInt32 contains page and slot number
 | Encode(UInt32, UInt16, UInt16) | Constructs a UInt64 from the components Database number, Page number and page number
Public method | Equals | Compares by Id
Public method | GetHashCode | Computes a hash code based on Id. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(Oid) | Returns a hash code for the specified object.
 | IdFromString |
 | PageNumber | Extracts the Page number
 | SamePageAs | Find out if Page number is the same in two different UInt64 numbers (encoded Oid)
 | SlotNumber(UInt64) | Extracts the page number
 | SlotNumber(UInt64, UInt16) | Sets the page number
Public method | ToString | Builds a string with DatabaseNumber-PageNumber-SlotNumber (Overrides ValueTypeToString.)
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.AsString Method

OidAsString Method

Builds a string with DatabaseNumber-PageNumber-SlotNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string AsString(
    ulong id
)
Public Shared Function AsString (
    id As ULong
) As String
public:
static String^ AsString(
    unsigned long long id
)
static member AsString :
        id : uint64 -> string

Parameters

id
Type: SystemUInt64
A combined Database number, Page number and page number

Return Value

Type: String
DatabaseNumber-PageNumber-SlotNumber
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.CompareTo Method

OidCompareTo Method

Compares two Oid objects by id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Oid otherOid
)
Public Function CompareTo (
    otherOid As Oid
) As Integer
public:
virtual int CompareTo(
    Oid otherOid
) sealed
abstract CompareTo :
        otherOid : Oid -> int
override CompareTo :
        otherOid : Oid -> int

Parameters

otherOid
Type: VelocityDbOid

[Missing <param name="otherOid"/> documentation for "M:VelocityDb.Oid.CompareTo(VelocityDb.Oid)"]

Return Value

Type: Int32
a negative number if less, 0 if equal or else a positive number

Implements

IComparableTCompareTo(T)
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.DatabaseNumber Method

OidDatabaseNumber Method

Extracts the Database number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static uint DatabaseNumber(
    ulong id
)
Public Shared Function DatabaseNumber (
    id As ULong
) As UInteger
public:
static unsigned int DatabaseNumber(
    unsigned long long id
)
static member DatabaseNumber :
        id : uint64 -> uint32

Parameters

id
Type: SystemUInt64
The combined Database number, Page number and page number

Return Value

Type: UInt32
The Database number
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Encode Method

OidEncode Method

Overload List
Name | Description
Encode(UInt32, UInt32) | Constructs a UInt64 from the components Database number and an encoded UInt32 contains page and slot number
Encode(UInt32, UInt16, UInt16) | Constructs a UInt64 from the components Database number, Page number and page number
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.Encode Method (UInt32, UInt32)

OidEncode Method (UInt32, UInt32)

Constructs a UInt64 from the components Database number and an encoded UInt32 contains page and slot number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong Encode(
    uint db,
    uint pageSlot
)
Public Shared Function Encode (
    db As UInteger,
    pageSlot As UInteger
) As ULong
public:
static unsigned long long Encode(
    unsigned int db,
    unsigned int pageSlot
)
static member Encode :
        db : uint32 *
        pageSlot : uint32 -> uint64

Parameters

db
Type: SystemUInt32
Database number
pageSlot
Type: SystemUInt32
Encoded page and slot number

Return Value

Type: UInt64
A number containing the full object identifier
See Also

Reference

Oid Structure
Encode Overload
VelocityDb Namespace


Oid.Encode Method (UInt32, UInt16, UInt16)

OidEncode Method (UInt32, UInt16, UInt16)

Constructs a UInt64 from the components Database number, Page number and page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong Encode(
    uint db,
    ushort page,
    ushort slot
)
Public Shared Function Encode (
    db As UInteger,
    page As UShort,
    slot As UShort
) As ULong
public:
static unsigned long long Encode(
    unsigned int db,
    unsigned short page,
    unsigned short slot
)
static member Encode :
        db : uint32 *
        page : uint16 *
        slot : uint16 -> uint64

Parameters

db
Type: SystemUInt32
A Database number
page
Type: SystemUInt16
A Page number
slot
Type: SystemUInt16
A slot number

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDb.Oid.Encode(System.UInt32,System.UInt16,System.UInt16)"]

See Also

Reference

Oid Structure
Encode Overload
VelocityDb Namespace


Oid.Equals Method

OidEquals Method

Compares by Id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Oid x,
    Oid y
)
Public Function Equals (
    x As Oid,
    y As Oid
) As Boolean
public:
virtual bool Equals(
    Oid x,
    Oid y
) sealed
abstract Equals :
        x : Oid *
        y : Oid -> bool
override Equals :
        x : Oid *
        y : Oid -> bool

Parameters

x
Type: VelocityDbOid
First object
y
Type: VelocityDbOid
Second object

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Oid.Equals(VelocityDb.Oid,VelocityDb.Oid)"]

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.GetHashCode Method

OidGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Computes a hash code based on Id. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(Oid) | Returns a hash code for the specified object.
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.GetHashCode Method

OidGetHashCode Method

Computes a hash code based on Id.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Oid.GetHashCode"]

See Also

Reference

Oid Structure
GetHashCode Overload
VelocityDb Namespace


Oid.GetHashCode Method (Oid)

OidGetHashCode Method (Oid)

Returns a hash code for the specified object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Oid a
)
Public Function GetHashCode (
    a As Oid
) As Integer
public:
virtual int GetHashCode(
    Oid a
) sealed
abstract GetHashCode :
        a : Oid -> int
override GetHashCode :
        a : Oid -> int

Parameters

a
Type: VelocityDbOid

[Missing <param name="a"/> documentation for "M:VelocityDb.Oid.GetHashCode(VelocityDb.Oid)"]

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
Exceptions
Exception | Condition
ArgumentNullException | The type of obj is a reference type and obj is null.
See Also

Reference

Oid Structure
GetHashCode Overload
VelocityDb Namespace


Oid.IdFromString Method

OidIdFromString Method

[Missing <summary> documentation for "M:VelocityDb.Oid.IdFromString(System.String)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong IdFromString(
    string oidAsString
)
Public Shared Function IdFromString (
    oidAsString As String
) As ULong
public:
static unsigned long long IdFromString(
    String^ oidAsString
)
static member IdFromString :
        oidAsString : string -> uint64

Parameters

oidAsString
Type: SystemString

[Missing <param name="oidAsString"/> documentation for "M:VelocityDb.Oid.IdFromString(System.String)"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDb.Oid.IdFromString(System.String)"]

See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.PageNumber Method

OidPageNumber Method

Extracts the Page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort PageNumber(
    ulong id
)
Public Shared Function PageNumber (
    id As ULong
) As UShort
public:
static unsigned short PageNumber(
    unsigned long long id
)
static member PageNumber :
        id : uint64 -> uint16

Parameters

id
Type: SystemUInt64
The combined Database number, Page number and page number

Return Value

Type: UInt16
The Page number
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.SamePageAs Method

OidSamePageAs Method

Find out if Page number is the same in two different UInt64 numbers (encoded Oid)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool SamePageAs(
    ulong id,
    ulong anId
)
Public Shared Function SamePageAs (
    id As ULong,
    anId As ULong
) As Boolean
public:
static bool SamePageAs(
    unsigned long long id,
    unsigned long long anId
)
static member SamePageAs :
        id : uint64 *
        anId : uint64 -> bool

Parameters

id
Type: SystemUInt64
A combined Database number, Page number and page number
anId
Type: SystemUInt64
Another combined Database number, Page number and skot number

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Oid.SamePageAs(System.UInt64,System.UInt64)"]

See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.SlotNumber Method

OidSlotNumber Method

Overload List
Name | Description
SlotNumber(UInt64) | Extracts the page number
SlotNumber(UInt64, UInt16) | Sets the page number
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.SlotNumber Method (UInt64)

OidSlotNumber Method (UInt64)

Extracts the page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort SlotNumber(
    ulong id
)
Public Shared Function SlotNumber (
    id As ULong
) As UShort
public:
static unsigned short SlotNumber(
    unsigned long long id
)
static member SlotNumber :
        id : uint64 -> uint16

Parameters

id
Type: SystemUInt64
A combined Database number, Page number and page number

Return Value

Type: UInt16
A page number
See Also

Reference

Oid Structure
SlotNumber Overload
VelocityDb Namespace


Oid.SlotNumber Method (UInt64, UInt16)

OidSlotNumber Method (UInt64, UInt16)

Sets the page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong SlotNumber(
    ulong oid,
    ushort slotNumber
)
Public Shared Function SlotNumber (
    oid As ULong,
    slotNumber As UShort
) As ULong
public:
static unsigned long long SlotNumber(
    unsigned long long oid,
    unsigned short slotNumber
)
static member SlotNumber :
        oid : uint64 *
        slotNumber : uint16 -> uint64

Parameters

oid
Type: SystemUInt64
A combined Database number, Page number and page number
slotNumber
Type: SystemUInt16
A slot number to use in the combined UInt64 value

Return Value

Type: UInt64
A combined Database number, Page number and an updated page number
See Also

Reference

Oid Structure
SlotNumber Overload
VelocityDb Namespace


Oid.ToString Method

OidToString Method

Builds a string with DatabaseNumber-PageNumber-SlotNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
DatabaseNumber-PageNumber-SlotNumber
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid Operators

The Oid type exposes the following members.

Operators
Name | Description
GreaterThan | Compares the id of two Oid's
GreaterThanOrEqual | Compares the id of two Oid's
LessThan | Compares the id of two Oid's
LessThanOrEqual | Compares the id of two Oid's
Top
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.GreaterThan Operator

OidGreaterThan Operator

Compares the id of two Oid's

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    Oid a,
    Oid b
)
Public Shared Operator > (
    a As Oid,
    b As Oid
) As Boolean
public:
static bool operator >(
    Oid a,
    Oid b
)
static let inline (>)
        a : Oid *
        b : Oid  : bool

Parameters

a
Type: VelocityDbOid
First Oid
b
Type: VelocityDbOid
Second Oid

Return Value

Type: Boolean
a.id > b.id
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.GreaterThanOrEqual Operator

OidGreaterThanOrEqual Operator

Compares the id of two Oid's

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    Oid a,
    Oid b
)
Public Shared Operator >= (
    a As Oid,
    b As Oid
) As Boolean
public:
static bool operator >=(
    Oid a,
    Oid b
)
static let inline (>=)
        a : Oid *
        b : Oid  : bool

Parameters

a
Type: VelocityDbOid
First Oid
b
Type: VelocityDbOid
Second Oid

Return Value

Type: Boolean
a.id >= b.id
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.LessThan Operator

OidLessThan Operator

Compares the id of two Oid's

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    Oid a,
    Oid b
)
Public Shared Operator < (
    a As Oid,
    b As Oid
) As Boolean
public:
static bool operator <(
    Oid a,
    Oid b
)
static let inline (<)
        a : Oid *
        b : Oid  : bool

Parameters

a
Type: VelocityDbOid
First Oid
b
Type: VelocityDbOid
Second Oid

Return Value

Type: Boolean
a.id less than b.id
See Also

Reference

Oid Structure
VelocityDb Namespace


Oid.LessThanOrEqual Operator

OidLessThanOrEqual Operator

Compares the id of two Oid's

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    Oid a,
    Oid b
)
Public Shared Operator <= (
    a As Oid,
    b As Oid
) As Boolean
public:
static bool operator <=(
    Oid a,
    Oid b
)
static let inline (<=)
        a : Oid *
        b : Oid  : bool

Parameters

a
Type: VelocityDbOid
First Oid
b
Type: VelocityDbOid
Second Oid

Return Value

Type: Boolean
a.id less or equal to b.id
See Also

Reference

Oid Structure
VelocityDb Namespace


OidShort Structure

The short object identifier containing a 16 bit page part and a 16 bit page part. This is used for short references within a single databases.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct OidShort : IComparable<OidShort>,
    IEqualityComparer<OidShort>
<SerializableAttribute>
Public Structure OidShort
    Implements IComparable(Of OidShort), IEqualityComparer(Of OidShort)
[SerializableAttribute]
public value class OidShort : IComparable<OidShort>,
    IEqualityComparer<OidShort>
[<SealedAttribute>]
[<SerializableAttribute>]
type OidShort =
    struct
        interface IComparable<OidShort>
        interface IEqualityComparer<OidShort>
    end

The OidShort type exposes the following members.

Constructors
 | Name | Description
Public method | OidShort(UInt32) | Constructs an OidShort given a 32bit number
Public method | OidShort(UInt64) | Constructs an OidShort given a 64bit number by using the 32 lower bits
Top
Properties
 | Name | Description
Public property | Id | Gets the OidShort encoded as a UInt32
Top
Methods
 | Name | Description
 | AsString | Builds a string with DatabaseNumber-PageNumber-SlotNumber
 | Compare | Compares by Id
Public method | CompareTo | Compares two OidShort objects by id
 | Encode | Merges a page number and a page number into a single number
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(OidShort, OidShort) | Determines whether the specified objects are equal.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(OidShort) | Returns a hash code for the specified object.
 | PageNumber | Extracts a Page number from a combined Page-Slot number
 | SamePageAs | Determines if two encoded OidShort have the same Page number
 | SlotNumber(UInt32) | Extracts a page number
 | SlotNumber(UInt32, UInt16) | Sets a page number
Public method | ToString | Builds a string with PageNumber-SlotNumber (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Compares id of two OidShort
Inequality | Compares id of two OidShort
Top
See Also

Reference

VelocityDb Namespace


OidShort Constructor

Overload List
 | Name | Description
Public method | OidShort(UInt32) | Constructs an OidShort given a 32bit number
Public method | OidShort(UInt64) | Constructs an OidShort given a 64bit number by using the 32 lower bits
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort Constructor (UInt32)

Constructs an OidShort given a 32bit number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OidShort(
    uint id
)
Public Sub New (
    id As UInteger
)
public:
OidShort(
    unsigned int id
)
new :
        id : uint32 -> OidShort

Parameters

id
Type: SystemUInt32
The page and slot encoded Id from which to construct the OidShort
See Also

Reference

OidShort Structure
OidShort Overload
VelocityDb Namespace


OidShort Constructor (UInt64)

Constructs an OidShort given a 64bit number by using the 32 lower bits

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OidShort(
    ulong id
)
Public Sub New (
    id As ULong
)
public:
OidShort(
    unsigned long long id
)
new :
        id : uint64 -> OidShort

Parameters

id
Type: SystemUInt64
The full encoded Id from which to construct the OidShort
See Also

Reference

OidShort Structure
OidShort Overload
VelocityDb Namespace


OidShort Properties

The OidShort type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the OidShort encoded as a UInt32
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Id Property

OidShortId Property

Gets the OidShort encoded as a UInt32

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint Id { get; }
Public ReadOnly Property Id As UInteger
    Get
public:
property unsigned int Id {
    unsigned int get ();
}
member Id : uint32 with get

Property Value

Type: UInt32
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort Methods

The OidShort type exposes the following members.

Methods
 | Name | Description
 | AsString | Builds a string with DatabaseNumber-PageNumber-SlotNumber
 | Compare | Compares by Id
Public method | CompareTo | Compares two OidShort objects by id
 | Encode | Merges a page number and a page number into a single number
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(OidShort, OidShort) | Determines whether the specified objects are equal.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(OidShort) | Returns a hash code for the specified object.
 | PageNumber | Extracts a Page number from a combined Page-Slot number
 | SamePageAs | Determines if two encoded OidShort have the same Page number
 | SlotNumber(UInt32) | Extracts a page number
 | SlotNumber(UInt32, UInt16) | Sets a page number
Public method | ToString | Builds a string with PageNumber-SlotNumber (Overrides ValueTypeToString.)
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.AsString Method

OidShortAsString Method

Builds a string with DatabaseNumber-PageNumber-SlotNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string AsString(
    uint id
)
Public Shared Function AsString (
    id As UInteger
) As String
public:
static String^ AsString(
    unsigned int id
)
static member AsString :
        id : uint32 -> string

Parameters

id
Type: SystemUInt32
A combined Page number and page number

Return Value

Type: String
PageNumber-SlotNumber
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Compare Method

OidShortCompare Method

Compares by Id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int Compare(
    OidShort aId,
    OidShort bId
)
Public Shared Function Compare (
    aId As OidShort,
    bId As OidShort
) As Integer
public:
static int Compare(
    OidShort aId,
    OidShort bId
)
static member Compare :
        aId : OidShort *
        bId : OidShort -> int

Parameters

aId
Type: VelocityDbOidShort
First object
bId
Type: VelocityDbOidShort
Second object

Return Value

Type: Int32
Comparison value, -1 for less, 0 for equal and 1 for greater than
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.CompareTo Method

OidShortCompareTo Method

Compares two OidShort objects by id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    OidShort obj
)
Public Function CompareTo (
    obj As OidShort
) As Integer
public:
virtual int CompareTo(
    OidShort obj
) sealed
abstract CompareTo :
        obj : OidShort -> int
override CompareTo :
        obj : OidShort -> int

Parameters

obj
Type: VelocityDbOidShort
The object to compare with

Return Value

Type: Int32
a negative number if less, 0 if equal or else a positive number

Implements

IComparableTCompareTo(T)
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Encode Method

OidShortEncode Method

Merges a page number and a page number into a single number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static uint Encode(
    ushort page,
    ushort slot
)
Public Shared Function Encode (
    page As UShort,
    slot As UShort
) As UInteger
public:
static unsigned int Encode(
    unsigned short page,
    unsigned short slot
)
static member Encode :
        page : uint16 *
        slot : uint16 -> uint32

Parameters

page
Type: SystemUInt16
A Page number
slot
Type: SystemUInt16
A slot number

Return Value

Type: UInt32
The combined Page and page number
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Equals Method

OidShortEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(OidShort, OidShort) | Determines whether the specified objects are equal.
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Equals Method (Object)

OidShortEquals Method (Object)

Indicates whether this instance and a specified object are equal.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current instance.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

OidShort Structure
Equals Overload
VelocityDb Namespace


OidShort.Equals Method (OidShort, OidShort)

OidShortEquals Method (OidShort, OidShort)

Determines whether the specified objects are equal.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    OidShort x,
    OidShort y
)
Public Function Equals (
    x As OidShort,
    y As OidShort
) As Boolean
public:
virtual bool Equals(
    OidShort x,
    OidShort y
) sealed
abstract Equals :
        x : OidShort *
        y : OidShort -> bool
override Equals :
        x : OidShort *
        y : OidShort -> bool

Parameters

x
Type: VelocityDbOidShort
The first object of type T to compare.
y
Type: VelocityDbOidShort
The second object of type T to compare.

Return Value

Type: Boolean
true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

OidShort Structure
Equals Overload
VelocityDb Namespace


OidShort.GetHashCode Method

OidShortGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetHashCode(OidShort) | Returns a hash code for the specified object.
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.GetHashCode Method

OidShortGetHashCode Method

Returns the hash code for this instance.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

OidShort Structure
GetHashCode Overload
VelocityDb Namespace


OidShort.GetHashCode Method (OidShort)

OidShortGetHashCode Method (OidShort)

Returns a hash code for the specified object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    OidShort a
)
Public Function GetHashCode (
    a As OidShort
) As Integer
public:
virtual int GetHashCode(
    OidShort a
) sealed
abstract GetHashCode :
        a : OidShort -> int
override GetHashCode :
        a : OidShort -> int

Parameters

a
Type: VelocityDbOidShort

[Missing <param name="a"/> documentation for "M:VelocityDb.OidShort.GetHashCode(VelocityDb.OidShort)"]

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
Exceptions
Exception | Condition
ArgumentNullException | The type of obj is a reference type and obj is null.
See Also

Reference

OidShort Structure
GetHashCode Overload
VelocityDb Namespace


OidShort.PageNumber Method

OidShortPageNumber Method

Extracts a Page number from a combined Page-Slot number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort PageNumber(
    uint id
)
Public Shared Function PageNumber (
    id As UInteger
) As UShort
public:
static unsigned short PageNumber(
    unsigned int id
)
static member PageNumber :
        id : uint32 -> uint16

Parameters

id
Type: SystemUInt32
Combined Page and page number

Return Value

Type: UInt16
A Page number
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.SamePageAs Method

OidShortSamePageAs Method

Determines if two encoded OidShort have the same Page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool SamePageAs(
    uint id,
    uint anId
)
Public Shared Function SamePageAs (
    id As UInteger,
    anId As UInteger
) As Boolean
public:
static bool SamePageAs(
    unsigned int id,
    unsigned int anId
)
static member SamePageAs :
        id : uint32 *
        anId : uint32 -> bool

Parameters

id
Type: SystemUInt32

[Missing <param name="id"/> documentation for "M:VelocityDb.OidShort.SamePageAs(System.UInt32,System.UInt32)"]

anId
Type: SystemUInt32

[Missing <param name="anId"/> documentation for "M:VelocityDb.OidShort.SamePageAs(System.UInt32,System.UInt32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.OidShort.SamePageAs(System.UInt32,System.UInt32)"]

See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.SlotNumber Method

OidShortSlotNumber Method

Overload List
Name | Description
SlotNumber(UInt32) | Extracts a page number
SlotNumber(UInt32, UInt16) | Sets a page number
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.SlotNumber Method (UInt32)

OidShortSlotNumber Method (UInt32)

Extracts a page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort SlotNumber(
    uint id
)
Public Shared Function SlotNumber (
    id As UInteger
) As UShort
public:
static unsigned short SlotNumber(
    unsigned int id
)
static member SlotNumber :
        id : uint32 -> uint16

Parameters

id
Type: SystemUInt32
Combined Page and page number

Return Value

Type: UInt16
A page number
See Also

Reference

OidShort Structure
SlotNumber Overload
VelocityDb Namespace


OidShort.SlotNumber Method (UInt32, UInt16)

OidShortSlotNumber Method (UInt32, UInt16)

Sets a page number

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong SlotNumber(
    uint oid,
    ushort slotNumber
)
Public Shared Function SlotNumber (
    oid As UInteger,
    slotNumber As UShort
) As ULong
public:
static unsigned long long SlotNumber(
    unsigned int oid,
    unsigned short slotNumber
)
static member SlotNumber :
        oid : uint32 *
        slotNumber : uint16 -> uint64

Parameters

oid
Type: SystemUInt32
Combined Page and page number
slotNumber
Type: SystemUInt16
Slot number to use

Return Value

Type: UInt64
A combined Page number with an updated page number
See Also

Reference

OidShort Structure
SlotNumber Overload
VelocityDb Namespace


OidShort.ToString Method

OidShortToString Method

Builds a string with PageNumber-SlotNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
PageNumber-SlotNumber
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort Operators

The OidShort type exposes the following members.

Operators
Name | Description
Equality | Compares id of two OidShort
Inequality | Compares id of two OidShort
Top
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Equality Operator

OidShortEquality Operator

Compares id of two OidShort

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    OidShort a,
    OidShort b
)
Public Shared Operator = (
    a As OidShort,
    b As OidShort
) As Boolean
public:
static bool operator ==(
    OidShort a,
    OidShort b
)
static let inline (=)
        a : OidShort *
        b : OidShort  : bool

Parameters

a
Type: VelocityDbOidShort
first OidShort
b
Type: VelocityDbOidShort
other OidShort

Return Value

Type: Boolean
true if id's are ==
See Also

Reference

OidShort Structure
VelocityDb Namespace


OidShort.Inequality Operator

OidShortInequality Operator

Compares id of two OidShort

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    OidShort a,
    OidShort b
)
Public Shared Operator <> (
    a As OidShort,
    b As OidShort
) As Boolean
public:
static bool operator !=(
    OidShort a,
    OidShort b
)
static let inline (<>)
        a : OidShort *
        b : OidShort  : bool

Parameters

a
Type: VelocityDbOidShort
first OidShort
b
Type: VelocityDbOidShort
other OidShort

Return Value

Type: Boolean
true if id's are !=
See Also

Reference

OidShort Structure
VelocityDb Namespace


OpFlags Enumeration

Flag bits for a persistent object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum OpFlags
Public Enumeration OpFlags
public enum class OpFlags
type OpFlags
Members
Member name | Value | Description
IsUpdated | 1 | Object is updated
MembersLoaded | 2 | All members have been loaded
RemovedFromIndices | 4 | Call to Update() removed object from indices. If UpdateObject(IOptimizedPersistable, Boolean, Boolean) was used with 3rd parameter false, object is not removed from indices (flag value set accordingly)
See Also

Reference

VelocityDb Namespace


OptimizedPersistable Class

Base class for all persistent capable classes except for embedded objects which do not need to be subclasses of this class.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
More...

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class OptimizedPersistable : IOptimizedPersistable,
    IComparable, ICloneable
<SerializableAttribute>
Public Class OptimizedPersistable
    Implements IOptimizedPersistable, IComparable, ICloneable
[SerializableAttribute]
public ref class OptimizedPersistable : IOptimizedPersistable,
    IComparable, ICloneable
[<SerializableAttribute>]
type OptimizedPersistable =
    class
        interface IOptimizedPersistable
        interface IComparable
        interface ICloneable
    end

The OptimizedPersistable type exposes the following members.

Constructors
 | Name | Description
Public method | OptimizedPersistable | The default constructor can be used to create simple OptimizedPersistable objects.
Public method | OptimizedPersistable(UInt64) | This constructor can be used in cases where the object id is known but you don't want to open the object, maybe you just want to add this object to a BTreeSet.
Top
Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.
Public property | DatabaseNumber | Gets the database number of this object.
Public property | FieldsLoaded | Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]
Public property | FlushIfPageFull | By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)
Public property | Id | Gets the id of this object. The id is structured as Oid
Public property | IsPersistent | Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0
Public property | IsUpdated | Gets the updated state of the object
Public property | LazyLoadFields | By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).
Public property | MaxNumberOfDatabases | Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.
Public property | ObjectsPerPage | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | Oid | Gets the object identifier represented as an Oid.
Public property | OidShort | Gets the OidShort part of the object Oid
Public property | PageNumber | Gets the page number part of the object Oid (Id)
Public property | PagesPerDatabase | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PlacementDatabaseNumber | Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.
Public property | RemovedFromIndices | true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices
Public property | ShortId | Gets the short id of this object. The id is structured as OidShort
Public property | SlotNumber | Gets the page number from the object identifier
Top
Methods
 | Name | Description
Public method | Clone | See MemberwiseClone
Public method | CompareTo | Compares objects using the object Id
Public method | Equals | Determines whether the specified Object is equal to the current Object. If this object or other object isn't persistent we call Equals(Object) (Overrides ObjectEquals(Object).)
Public method | FlushTransients | Process data in transient fields (if any), do whatever is required to persist such data if needed. By default does nothing.
Public method | GetDataMembers | Gets a list of the fields meta data objects
Public method | GetFieldValues | Returns a list of field values of this object or returns it as an array (if this is an array)
Public method | GetHashCode | Computes a hash code based on Oid of object. Make sure to persist objects before using GetHashCode() or override GetHashCode() (Overrides ObjectGetHashCode.)
Public method | GetPage | Get the persistent storage Page of this object
Public method | GetSession | Gets the session of this object or null if this object isn't yet persisted.
Public method | GetTypeVersion | The database engine needs this internally
Public method | GetWrappedObject | Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable
Public method | InitializeAfterRead | This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.
 | ListToString | This is a support function for the VelocityDbBrowser
Public method | OidOf | Gets the Oid (encoded as an UInt64) of a non OptimizedPersistable object or 0 if the object isn't persistent on the same page as this object.
Public method | Open(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Public method | OpenT(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Public method | OptimizedPersistableFieldValues | Gets a list of all field values of the current object that are subclasses of OptimizedPersistable
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.
Public method | PersistentVersion | Gets the page version of a persistent object
Public method | PersistMyReferences | Persists references from this object
Public method | ReadMe | Used by code generator
 | ReadMeUsingSchemaReflection | Used by code generator. By default objects are read and written using persisted schema information and reflection.
Public method | SetPage | Sets the persistent storage Page of this object
Public method | SetTypeVersion | The database engine needs this internally
Public method | ShallowCopyTo | Internal use for now
Public method | ToString | Displays class name plus object id (Overrides ObjectToString.)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.
Public method | Update | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes!
Public method | Update(Action) | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes! Add code to update object in Action parameter.
Public method | UpdateNonIndexField | Marks an object as being updated so that object will be written at commit transaction. Call before updating a NON indexed field. Same as Update but avoids deleting object from indices (if any). If updating a field used in any index, call Update instead or you may end up with one or more corrupt indices.
Public method | UpdateTypeVersion | Updates the object and make this object use the latest Type definition for its class. The object now will now adjust for data attribute changes.
Public method | Write | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page will also be written.
Public method | WriteMe | Used by code generator.
 | WriteMeUsingSchemaReflection | Used by code generator. This is the default way of writing objects using schema information and .NET reflection info.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeByteArray
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.ComparerVelocityDbComparerKey
VelocityDb.CollectionSortedSetBaseKey
VelocityDb.CollectionVelocityDbHashSetT
VelocityDb.CollectionVelocityDbListT
VelocityDb.CollectionWeakReferenceListBaseT
VelocityDbDatabase
VelocityDbDatabaseLocation
VelocityDbDatabaseLocations
VelocityDbLicense
VelocityDbPlacement
VelocityDbReferenceTracked
VelocityDb.SyncChange
VelocityDb.SyncChanges
VelocityDb.SyncReplicaSync
VelocityDb.SyncTransactionChanges
VelocityDb.TypeInfoDataMember
VelocityDb.TypeInfoReference
VelocityDb.TypeInfoRelation
VelocityDb.TypeInfoSchema
VelocityDb.TypeInfoTypeVersion
VelocityDb.TypeInfoVelocityDbType
VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray
VelocityDBExtensions.CompressedBitArrayRunningLengthWord
VelocityDBExtensions.SpatialRTree
VelocityDBExtensions2.AspNet.IdentityAspNetIdentity
VelocityDBExtensions2.AspNet.IdentityIdentityRole
VelocityDBExtensions2.AspNet.IdentityIdentityUser
VelocityDBExtensions2.AspNet.IdentityUserLoginInfoAdapter
VelocityGraphEdgeType
VelocityGraphGraph
VelocityGraphPropertyType
VelocityGraphVertexType


OptimizedPersistable Constructor

Overload List
 | Name | Description
Public method | OptimizedPersistable | The default constructor can be used to create simple OptimizedPersistable objects.
Public method | OptimizedPersistable(UInt64) | This constructor can be used in cases where the object id is known but you don't want to open the object, maybe you just want to add this object to a BTreeSet.
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable Constructor

The default constructor can be used to create simple OptimizedPersistable objects.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OptimizedPersistable()
Public Sub New
public:
OptimizedPersistable()
new : unit -> OptimizedPersistable
See Also

Reference

OptimizedPersistable Class
OptimizedPersistable Overload
VelocityDb Namespace


OptimizedPersistable Constructor (UInt64)

This constructor can be used in cases where the object id is known but you don't want to open the object, maybe you just want to add this object to a BTreeSet.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OptimizedPersistable(
    ulong id
)
Public Sub New (
    id As ULong
)
public:
OptimizedPersistable(
    unsigned long long id
)
new :
        id : uint64 -> OptimizedPersistable

Parameters

id
Type: SystemUInt64
Object id to use for this object
See Also

Reference

OptimizedPersistable Class
OptimizedPersistable Overload
VelocityDb Namespace


OptimizedPersistable Properties

The OptimizedPersistable type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.
Public property | DatabaseNumber | Gets the database number of this object.
Public property | FieldsLoaded | Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]
Public property | FlushIfPageFull | By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)
Public property | Id | Gets the id of this object. The id is structured as Oid
Public property | IsPersistent | Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0
Public property | IsUpdated | Gets the updated state of the object
Public property | LazyLoadFields | By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).
Public property | MaxNumberOfDatabases | Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.
Public property | ObjectsPerPage | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | Oid | Gets the object identifier represented as an Oid.
Public property | OidShort | Gets the OidShort part of the object Oid
Public property | PageNumber | Gets the page number part of the object Oid (Id)
Public property | PagesPerDatabase | A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.
Public property | PlacementDatabaseNumber | Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.
Public property | RemovedFromIndices | true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices
Public property | ShortId | Gets the short id of this object. The id is structured as OidShort
Public property | SlotNumber | Gets the page number from the object identifier
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.AllowOtherTypesOnSamePage Property

OptimizedPersistableAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowOtherTypesOnSamePage { get; }
Public Overridable ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get ();
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Cache Property

OptimizedPersistableCache Property

By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual CacheEnum Cache { get; }
Public Overridable ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get ();
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.DatabaseNumber Property

OptimizedPersistableDatabaseNumber Property

Gets the database number of this object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint DatabaseNumber { get; }
Public ReadOnly Property DatabaseNumber As UInteger
    Get
public:
property unsigned int DatabaseNumber {
    unsigned int get ();
}
member DatabaseNumber : uint32 with get

Property Value

Type: UInt32
The database number of this object or 0 if object is not persistent
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.FieldsLoaded Property

OptimizedPersistableFieldsLoaded Property

Gets the field members load state. By default, all members are loaded when a persistent object is opened but if an overrode of LazyLoadFields returns true then the object members are loaded by calling [!:OptimizedPersistable.LoadFields]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool FieldsLoaded { get; set; }
Public Property FieldsLoaded As Boolean
    Get
    Set
public:
virtual property bool FieldsLoaded {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FieldsLoaded : bool with get, set
override FieldsLoaded : bool with get, set

Property Value

Type: Boolean
true if all members are loaded; otherwise false

Implements

IOptimizedPersistableFieldsLoaded
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.FlushIfPageFull Property

OptimizedPersistableFlushIfPageFull Property

By default we flush (write) any updated page we find when looking for an object placement page and the page is considered full (depends on how many objects we permit/page)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FlushIfPageFull { get; }
Public Overridable ReadOnly Property FlushIfPageFull As Boolean
    Get
public:
virtual property bool FlushIfPageFull {
    bool get ();
}
abstract FlushIfPageFull : bool with get
override FlushIfPageFull : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableFlushIfPageFull
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Id Property

OptimizedPersistableId Property

Gets the id of this object. The id is structured as Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Id { get; set; }
Public Property Id As ULong
    Get
    Set
public:
virtual property unsigned long long Id {
    unsigned long long get () sealed;
    void set (unsigned long long value) sealed;
}
abstract Id : uint64 with get, set
override Id : uint64 with get, set

Property Value

Type: UInt64
The id of this object or 0 if object is not persistent

Implements

IOptimizedPersistableId
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.IsPersistent Property

OptimizedPersistableIsPersistent Property

Gets the persistent state of an object. An object is considered persistent when it has an Oid, that is the Id is not 0

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsPersistent { get; }
Public ReadOnly Property IsPersistent As Boolean
    Get
public:
virtual property bool IsPersistent {
    bool get () sealed;
}
abstract IsPersistent : bool with get
override IsPersistent : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableIsPersistent
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.IsUpdated Property

OptimizedPersistableIsUpdated Property

Gets the updated state of the object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsUpdated { get; set; }
Public Overridable Property IsUpdated As Boolean
    Get
    Set
public:
virtual property bool IsUpdated {
    bool get ();
    void set (bool value);
}
abstract IsUpdated : bool with get, set
override IsUpdated : bool with get, set

Property Value

Type: Boolean
true if updated; otherwise false

Implements

IOptimizedPersistableIsUpdated
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.LazyLoadFields Property

OptimizedPersistableLazyLoadFields Property

By default all fields are loaded when opening a persistent object but an option is provided to load members on demand (lazy loading).

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LazyLoadFields { get; }
Public Overridable ReadOnly Property LazyLoadFields As Boolean
    Get
public:
virtual property bool LazyLoadFields {
    bool get ();
}
abstract LazyLoadFields : bool with get
override LazyLoadFields : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableLazyLoadFields
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.MaxNumberOfDatabases Property

OptimizedPersistableMaxNumberOfDatabases Property

Possibly restrict instances of to a single Database. By default this property is UInt32.MaxValue but classes like BTreeSetOidShort, BTreeMapShortOid ... override this property to return 1 since short references are restricted to a single Database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual uint MaxNumberOfDatabases { get; }
Public Overridable ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get ();
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ObjectsPerPage Property

OptimizedPersistableObjectsPerPage Property

A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ushort ObjectsPerPage { get; }
Public Overridable ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get ();
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Return Value

Type: UInt16
The requested number of objects per page.

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Oid Property

OptimizedPersistableOid Property

Gets the object identifier represented as an Oid.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid Oid { get; }
Public ReadOnly Property Oid As Oid
    Get
public:
property Oid Oid {
    Oid get ();
}
member Oid : Oid with get

Property Value

Type: Oid
The Oid of the object
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.OidShort Property

OptimizedPersistableOidShort Property

Gets the OidShort part of the object Oid

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OidShort OidShort { get; }
Public ReadOnly Property OidShort As OidShort
    Get
public:
property OidShort OidShort {
    OidShort get ();
}
member OidShort : OidShort with get

Property Value

Type: OidShort
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.PageNumber Property

OptimizedPersistablePageNumber Property

Gets the page number part of the object Oid (Id)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort PageNumber { get; }
Public ReadOnly Property PageNumber As UShort
    Get
public:
property unsigned short PageNumber {
    unsigned short get ();
}
member PageNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.PagesPerDatabase Property

OptimizedPersistablePagesPerDatabase Property

A default for number of objects per database page used when persisting objects without an explicit Placement object or if persisted using Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) This happens when objects are persisted by reachability from a persistent object. All objects reachable from a persistent object are automatically made persistent.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ushort PagesPerDatabase { get; }
Public Overridable ReadOnly Property PagesPerDatabase As UShort
    Get
public:
virtual property unsigned short PagesPerDatabase {
    unsigned short get ();
}
abstract PagesPerDatabase : uint16 with get
override PagesPerDatabase : uint16 with get

Return Value

Type: UInt16
The requested number of pages per database

Implements

IOptimizedPersistablePagesPerDatabase
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.PlacementDatabaseNumber Property

OptimizedPersistablePlacementDatabaseNumber Property

Gets the Database Id number to use when placing (persisting) an instance of this class when no other placement directive has been given.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual uint PlacementDatabaseNumber { get; }
Public Overridable ReadOnly Property PlacementDatabaseNumber As UInteger
    Get
public:
virtual property unsigned int PlacementDatabaseNumber {
    unsigned int get ();
}
abstract PlacementDatabaseNumber : uint32 with get
override PlacementDatabaseNumber : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistablePlacementDatabaseNumber
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.RemovedFromIndices Property

OptimizedPersistableRemovedFromIndices Property

true if call to [!:Update(bool)] or UpdateObject(IOptimizedPersistable, Boolean, Boolean) caused this object to be removed from possible indices

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool RemovedFromIndices { get; set; }
Public Property RemovedFromIndices As Boolean
    Get
    Set
public:
virtual property bool RemovedFromIndices {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract RemovedFromIndices : bool with get, set
override RemovedFromIndices : bool with get, set

Property Value

Type: Boolean

Implements

IOptimizedPersistableRemovedFromIndices
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ShortId Property

OptimizedPersistableShortId Property

Gets the short id of this object. The id is structured as OidShort

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint ShortId { get; }
Public ReadOnly Property ShortId As UInteger
    Get
public:
property unsigned int ShortId {
    unsigned int get ();
}
member ShortId : uint32 with get

Property Value

Type: UInt32
The short id of this object or 0 if object is not persistent
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.SlotNumber Property

OptimizedPersistableSlotNumber Property

Gets the page number from the object identifier

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort SlotNumber { get; }
Public ReadOnly Property SlotNumber As UShort
    Get
public:
property unsigned short SlotNumber {
    unsigned short get ();
}
member SlotNumber : uint16 with get

Property Value

Type: UInt16
the page number of this object
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable Methods

The OptimizedPersistable type exposes the following members.

Methods
 | Name | Description
Public method | Clone | See MemberwiseClone
Public method | CompareTo | Compares objects using the object Id
Public method | Equals | Determines whether the specified Object is equal to the current Object. If this object or other object isn't persistent we call Equals(Object) (Overrides ObjectEquals(Object).)
Public method | FlushTransients | Process data in transient fields (if any), do whatever is required to persist such data if needed. By default does nothing.
Public method | GetDataMembers | Gets a list of the fields meta data objects
Public method | GetFieldValues | Returns a list of field values of this object or returns it as an array (if this is an array)
Public method | GetHashCode | Computes a hash code based on Oid of object. Make sure to persist objects before using GetHashCode() or override GetHashCode() (Overrides ObjectGetHashCode.)
Public method | GetPage | Get the persistent storage Page of this object
Public method | GetSession | Gets the session of this object or null if this object isn't yet persisted.
Public method | GetTypeVersion | The database engine needs this internally
Public method | GetWrappedObject | Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable
Public method | InitializeAfterRead | This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.
 | ListToString | This is a support function for the VelocityDbBrowser
Public method | OidOf | Gets the Oid (encoded as an UInt64) of a non OptimizedPersistable object or 0 if the object isn't persistent on the same page as this object.
Public method | Open(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Public method | OpenT(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Public method | OptimizedPersistableFieldValues | Gets a list of all field values of the current object that are subclasses of OptimizedPersistable
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.
Public method | PersistentVersion | Gets the page version of a persistent object
Public method | PersistMyReferences | Persists references from this object
Public method | ReadMe | Used by code generator
 | ReadMeUsingSchemaReflection | Used by code generator. By default objects are read and written using persisted schema information and reflection.
Public method | SetPage | Sets the persistent storage Page of this object
Public method | SetTypeVersion | The database engine needs this internally
Public method | ShallowCopyTo | Internal use for now
Public method | ToString | Displays class name plus object id (Overrides ObjectToString.)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.
Public method | Update | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes!
Public method | Update(Action) | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes! Add code to update object in Action parameter.
Public method | UpdateNonIndexField | Marks an object as being updated so that object will be written at commit transaction. Call before updating a NON indexed field. Same as Update but avoids deleting object from indices (if any). If updating a field used in any index, call Update instead or you may end up with one or more corrupt indices.
Public method | UpdateTypeVersion | Updates the object and make this object use the latest Type definition for its class. The object now will now adjust for data attribute changes.
Public method | Write | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page will also be written.
Public method | WriteMe | Used by code generator.
 | WriteMeUsingSchemaReflection | Used by code generator. This is the default way of writing objects using schema information and .NET reflection info.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Clone Method

OptimizedPersistableClone Method

See MemberwiseClone

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A non persisted clone

Implements

ICloneableClone
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.CompareTo Method

OptimizedPersistableCompareTo Method

Compares objects using the object Id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
)
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDb.OptimizedPersistable.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Equals Method

OptimizedPersistableEquals Method

Determines whether the specified Object is equal to the current Object. If this object or other object isn't persistent we call Equals(Object)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Object to compare with

Field Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.Equals(System.Object)"]

See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.FlushTransients Method

OptimizedPersistableFlushTransients Method

Process data in transient fields (if any), do whatever is required to persist such data if needed. By default does nothing.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void FlushTransients()
Public Overridable Sub FlushTransients
public:
virtual void FlushTransients()
abstract FlushTransients : unit -> unit
override FlushTransients : unit -> unit

Implements

IOptimizedPersistableFlushTransients
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetDataMembers Method

OptimizedPersistableGetDataMembers Method

Gets a list of the fields meta data objects

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<DataMember> GetDataMembers()
Public Function GetDataMembers As List(Of DataMember)
public:
List<DataMember^>^ GetDataMembers()
member GetDataMembers : unit -> List<DataMember>

Return Value

Type: List DataMember
List of DataMember
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetFieldValues Method

OptimizedPersistableGetFieldValues Method

Returns a list of field values of this object or returns it as an array (if this is an array)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<Object> GetFieldValues()
Public Function GetFieldValues As List(Of Object)
public:
List<Object^>^ GetFieldValues()
member GetFieldValues : unit -> List<Object>

Return Value

Type: List Object

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.GetFieldValues"]

See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetHashCode Method

OptimizedPersistableGetHashCode Method

Computes a hash code based on Oid of object. Make sure to persist objects before using GetHashCode() or override GetHashCode()

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.GetHashCode"]

See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetPage Method

OptimizedPersistableGetPage Method

Get the persistent storage Page of this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Page GetPage()
Public Function GetPage As Page
public:
virtual Page^ GetPage() sealed
abstract GetPage : unit -> Page
override GetPage : unit -> Page

Return Value

Type: Page
The persistent storage Pageof this object

Implements

IOptimizedPersistableGetPage
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetSession Method

OptimizedPersistableGetSession Method

Gets the session of this object or null if this object isn't yet persisted.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionBase GetSession()
Public Function GetSession As SessionBase
public:
SessionBase^ GetSession()
member GetSession : unit -> SessionBase

Return Value

Type: SessionBase
The active SessionBase of this object
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetTypeVersion Method

OptimizedPersistableGetTypeVersion Method

The database engine needs this internally

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion GetTypeVersion()
Public Function GetTypeVersion As TypeVersion
public:
virtual TypeVersion^ GetTypeVersion() sealed
abstract GetTypeVersion : unit -> TypeVersion
override GetTypeVersion : unit -> TypeVersion

Return Value

Type: TypeVersion
The TypeVersion of this object

Implements

IOptimizedPersistableGetTypeVersion
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.GetWrappedObject Method

OptimizedPersistableGetWrappedObject Method

Internally used when IOptimizedPersistable is a wrapper for a non IOptimizedPersistable

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object GetWrappedObject()
Public Function GetWrappedObject As Object
public:
virtual Object^ GetWrappedObject() sealed
abstract GetWrappedObject : unit -> Object
override GetWrappedObject : unit -> Object

Return Value

Type: Object
Wrapped object if set; otherwise this object

Implements

IOptimizedPersistableGetWrappedObject
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.InitializeAfterRead Method

OptimizedPersistableInitializeAfterRead Method

This function is called when an object has been read from disk and all data members (fields) have been loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void InitializeAfterRead(
    SessionBase session
)
Public Overridable Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
)
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.InitializeAfterRecreate Method

OptimizedPersistableInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void InitializeAfterRecreate(
    SessionBase session
)
Public Overridable Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
)
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ListToString Method

OptimizedPersistableListToString Method

This is a support function for the VelocityDbBrowser

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ListToString(
    IList list,
    Page page
)
Public Shared Function ListToString (
    list As IList,
    page As Page
) As String
public:
static String^ ListToString(
    IList^ list,
    Page^ page
)
static member ListToString :
        list : IList *
        page : Page -> string

Parameters

list
Type: System.CollectionsIList
A list to output as a string
page
Type: VelocityDbPage
The page containing the list

Return Value

Type: String
A string representing the input list.
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.OidOf Method

OptimizedPersistableOidOf Method

Gets the Oid (encoded as an UInt64) of a non OptimizedPersistable object or 0 if the object isn't persistent on the same page as this object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong OidOf(
    Object obj
)
Public Function OidOf (
    obj As Object
) As ULong
public:
unsigned long long OidOf(
    Object^ obj
)
member OidOf :
        obj : Object -> uint64

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDb.OptimizedPersistable.OidOf(System.Object)"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.OidOf(System.Object)"]

See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Open Method

OptimizedPersistableOpen Method

Overload List
 | Name | Description
Public method | Open(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Public method | OpenT(UInt32, Boolean, Boolean) | Opens a persistent object located in the same Database as this object
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Open Method (UInt32, Boolean, Boolean)

OptimizedPersistableOpen Method (UInt32, Boolean, Boolean)

Opens a persistent object located in the same Database as this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object Open(
    uint pageSlot,
    bool update = false,
    bool inFlush = false
)
Public Function Open (
    pageSlot As UInteger,
    Optional update As Boolean = false,
    Optional inFlush As Boolean = false
) As Object
public:
Object^ Open(
    unsigned int pageSlot,
    bool update = false,
    bool inFlush = false
)
member Open :
        pageSlot : uint32 *
        ?update : bool *
        ?inFlush : bool
(* Defaults:
        let _update = defaultArg update false
        let _inFlush = defaultArg inFlush false
*)
-> Object

Parameters

pageSlot
Type: SystemUInt32
The OidShort encoded as a UInt32 of the object to open within the same Database as this object
update (Optional)
Type: SystemBoolean
Open the object for update?
inFlush (Optional)
Type: SystemBoolean
if true, disallow page flushing while opening the object

Return Value

Type: Object
The opened object or null if it does not exist
See Also

Reference

OptimizedPersistable Class
Open Overload
VelocityDb Namespace


OptimizedPersistable.Open(T) Method (UInt32, Boolean, Boolean)

OptimizedPersistableOpenT Method (UInt32, Boolean, Boolean)

Opens a persistent object located in the same Database as this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T Open<T>(
    uint pageSlot,
    bool update = false,
    bool inFlush = false
)

Public Function Open(Of T) (
    pageSlot As UInteger,
    Optional update As Boolean = false,
    Optional inFlush As Boolean = false
) As T
public:
generic<typename T>
T Open(
    unsigned int pageSlot,
    bool update = false,
    bool inFlush = false
)
member Open :
        pageSlot : uint32 *
        ?update : bool *
        ?inFlush : bool
(* Defaults:
        let _update = defaultArg update false
        let _inFlush = defaultArg inFlush false
*)
-> 'T

Parameters

pageSlot
Type: SystemUInt32
The OidShort encoded as a UInt32 of the object to open within the same Database as this object
update (Optional)
Type: SystemBoolean
Open the object for update?
inFlush (Optional)
Type: SystemBoolean
if true, disallow page flushing while opening the object

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityDb.OptimizedPersistable.Open``1(System.UInt32,System.Boolean,System.Boolean)"]

Return Value

Type: T
The opened object or null if it does not exist
See Also

Reference

OptimizedPersistable Class
Open Overload
VelocityDb Namespace


OptimizedPersistable.OptimizedPersistableFieldValues Method

OptimizedPersistableOptimizedPersistableFieldValues Method

Gets a list of all field values of the current object that are subclasses of OptimizedPersistable

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<OptimizedPersistable> OptimizedPersistableFieldValues()
Public Function OptimizedPersistableFieldValues As List(Of OptimizedPersistable)
public:
List<OptimizedPersistable^>^ OptimizedPersistableFieldValues()
member OptimizedPersistableFieldValues : unit -> List<OptimizedPersistable>

Return Value

Type: List OptimizedPersistable
List of OptimizedPersistable
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Persist Method

OptimizedPersistablePersist Method

Overload List
 | Name | Description
Public method | Persist(SessionBase, IOptimizedPersistable, Boolean, Boolean) | Persists this object.
Public method | Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable) | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Persist Method (SessionBase, IOptimizedPersistable, Boolean, Boolean)

OptimizedPersistablePersist Method (SessionBase, IOptimizedPersistable, Boolean, Boolean)

Persists this object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ulong Persist(
    SessionBase session,
    IOptimizedPersistable placeHint,
    bool persistRefs = true,
    bool disableFlush = false
)
Public Overridable Function Persist (
    session As SessionBase,
    placeHint As IOptimizedPersistable,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false
) As ULong
public:
virtual unsigned long long Persist(
    SessionBase^ session,
    IOptimizedPersistable^ placeHint,
    bool persistRefs = true,
    bool disableFlush = false
)
abstract Persist :
        session : SessionBase *
        placeHint : IOptimizedPersistable *
        ?persistRefs : bool *
        ?disableFlush : bool
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
*)
-> uint64
override Persist :
        session : SessionBase *
        placeHint : IOptimizedPersistable *
        ?persistRefs : bool *
        ?disableFlush : bool
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
*)
-> uint64

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object
placeHint
Type: VelocityDbIOptimizedPersistable
Use placement as specified by this object type, see PlacementDatabaseNumber, ObjectsPerPage and PagesPerDatabaseFor best performance this should be a recently created object that you want the current object to be persisted near.
persistRefs (Optional)
Type: SystemBoolean
Persist any referenced object now or delay until flush/commit
disableFlush (Optional)
Type: SystemBoolean
Controls possible flushing of updated pages. Set to true if you want to prevent updated pages from being flushed to disk and setting such pages to a non updated state.

Return Value

Type: UInt64
The object id of the persistent object

Implements

IOptimizedPersistablePersist(SessionBase, IOptimizedPersistable, Boolean, Boolean)
See Also

Reference

OptimizedPersistable Class
Persist Overload
VelocityDb Namespace


OptimizedPersistable.Persist Method (Placement, SessionBase, Boolean, Boolean, Queue(IOptimizedPersistable))

OptimizedPersistablePersist Method (Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)

Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overridable Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
)
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
The placement rules to follow when persisting this object
session
Type: VelocityDb.SessionSessionBase
The session managing this object
persistRefs (Optional)
Type: SystemBoolean
If true, objects referenced from this object will also be persisted
disableFlush (Optional)
Type: SystemBoolean
If true, disables possible flushing of updated pages while persisting this object; otherwise page flushing may occur
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A queue of objects remaining to be persisted. Pass as a parameter to session.Persist

Return Value

Type: UInt64
The object id of this persistent object

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

OptimizedPersistable Class
Persist Overload
VelocityDb Namespace


OptimizedPersistable.PersistentVersion Method

OptimizedPersistablePersistentVersion Method

Gets the page version of a persistent object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong PersistentVersion()
Public Function PersistentVersion As ULong
public:
unsigned long long PersistentVersion()
member PersistentVersion : unit -> uint64

Return Value

Type: UInt64
The page version.
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.PersistMyReferences Method

OptimizedPersistablePersistMyReferences Method

Persists references from this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void PersistMyReferences(
    SessionBase session,
    bool inFlush
)
Public Overridable Sub PersistMyReferences (
    session As SessionBase,
    inFlush As Boolean
)
public:
virtual void PersistMyReferences(
    SessionBase^ session,
    bool inFlush
)
abstract PersistMyReferences :
        session : SessionBase *
        inFlush : bool -> unit
override PersistMyReferences :
        session : SessionBase *
        inFlush : bool -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object
inFlush
Type: SystemBoolean
are we in a page flush

Implements

IOptimizedPersistablePersistMyReferences(SessionBase, Boolean)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ReadMe Method

OptimizedPersistableReadMe Method

Used by code generator

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overridable Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ReadMeUsingSchemaReflection Method

OptimizedPersistableReadMeUsingSchemaReflection Method

Used by code generator. By default objects are read and written using persisted schema information and reflection.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void ReadMeUsingSchemaReflection(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    IOptimizedPersistable pObj,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Shared Sub ReadMeUsingSchemaReflection (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    pObj As IOptimizedPersistable,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
static void ReadMeUsingSchemaReflection(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    IOptimizedPersistable^ pObj,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
static member ReadMeUsingSchemaReflection :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        pObj : IOptimizedPersistable *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
Version of a type
memberBytes
Type: SystemByte
Bytes containing object to read
offset
Type: SystemInt32
Offset into memberBytes
pObj
Type: VelocityDbIOptimizedPersistable
The object being read in
session
Type: VelocityDb.SessionSessionBase
The active session
page
Type: VelocityDbPage
Page of object being read
useOidShort
Type: SystemBoolean
Does object use short object references (32bit)?
schema
Type: VelocityDb.TypeInfoSchema
Schema information
openRefs
Type: SystemBoolean
Shall references from object also be filled in now
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
Members remaining to be read
graphDepth
Type: SystemInt32
Current graph depth read
graphDepthToLoad
Type: SystemInt32
Stop reading at this graph depth
primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.OptimizedPersistable.ReadMeUsingSchemaReflection(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.SetPage Method

OptimizedPersistableSetPage Method

Sets the persistent storage Page of this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetPage(
    Page page
)
Public Sub SetPage (
    page As Page
)
public:
virtual void SetPage(
    Page^ page
) sealed
abstract SetPage :
        page : Page -> unit
override SetPage :
        page : Page -> unit

Parameters

page
Type: VelocityDbPage
A persistent storage Page

Implements

IOptimizedPersistableSetPage(Page)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.SetTypeVersion Method

OptimizedPersistableSetTypeVersion Method

The database engine needs this internally

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetTypeVersion(
    TypeVersion typeVersion
)
Public Sub SetTypeVersion (
    typeVersion As TypeVersion
)
public:
virtual void SetTypeVersion(
    TypeVersion^ typeVersion
) sealed
abstract SetTypeVersion :
        typeVersion : TypeVersion -> unit
override SetTypeVersion :
        typeVersion : TypeVersion -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.OptimizedPersistable.SetTypeVersion(VelocityDb.TypeInfo.TypeVersion)"]

Implements

IOptimizedPersistableSetTypeVersion(TypeVersion)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ShallowCopyTo Method

OptimizedPersistableShallowCopyTo Method

Internal use for now

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IOptimizedPersistable ShallowCopyTo(
    Page page
)
Public Function ShallowCopyTo (
    page As Page
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ ShallowCopyTo(
    Page^ page
) sealed
abstract ShallowCopyTo :
        page : Page -> IOptimizedPersistable
override ShallowCopyTo :
        page : Page -> IOptimizedPersistable

Parameters

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.OptimizedPersistable.ShallowCopyTo(VelocityDb.Page)"]

Return Value

Type: IOptimizedPersistable

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.ShallowCopyTo(VelocityDb.Page)"]

Implements

IOptimizedPersistableShallowCopyTo(Page)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.ToString Method

OptimizedPersistableToString Method

Displays class name plus object id

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String containing class name and object id.
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Unpersist Method

OptimizedPersistableUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Unpersist(
    SessionBase session
)
Public Overridable Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
)
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Update Method

OptimizedPersistableUpdate Method

Overload List
 | Name | Description
Public method | Update | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes!
Public method | Update(Action) | Marks an object as being updated so that object will be written at commit transaction. Call before making object changes! Add code to update object in Action parameter.
Top
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Update Method

OptimizedPersistableUpdate Method

Marks an object as being updated so that object will be written at commit transaction. Call before making object changes!

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Update()
Public Function Update As Boolean
public:
virtual bool Update() sealed
abstract Update : unit -> bool
override Update : unit -> bool

Return Value

Type: Boolean
true if update successful

Implements

IOptimizedPersistableUpdate
See Also

Reference

OptimizedPersistable Class
Update Overload
VelocityDb Namespace


OptimizedPersistable.Update Method (Action)

OptimizedPersistableUpdate Method (Action)

Marks an object as being updated so that object will be written at commit transaction. Call before making object changes! Add code to update object in Action parameter.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Update(
    Action codeBlock
)
Public Function Update (
    codeBlock As Action
) As Boolean
public:
bool Update(
    Action^ codeBlock
)
member Update :
        codeBlock : Action -> bool

Parameters

codeBlock
Type: SystemAction
Block of code doing actual update to the object

Return Value

Type: Boolean
true if update successful
See Also

Reference

OptimizedPersistable Class
Update Overload
VelocityDb Namespace


OptimizedPersistable.UpdateNonIndexField Method

OptimizedPersistableUpdateNonIndexField Method

Marks an object as being updated so that object will be written at commit transaction. Call before updating a NON indexed field. Same as Update but avoids deleting object from indices (if any). If updating a field used in any index, call Update instead or you may end up with one or more corrupt indices.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool UpdateNonIndexField()
Public Function UpdateNonIndexField As Boolean
public:
bool UpdateNonIndexField()
member UpdateNonIndexField : unit -> bool

Return Value

Type: Boolean
true if update successful
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.UpdateTypeVersion Method

OptimizedPersistableUpdateTypeVersion Method

Updates the object and make this object use the latest Type definition for its class. The object now will now adjust for data attribute changes.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void UpdateTypeVersion()
Public Sub UpdateTypeVersion
public:
void UpdateTypeVersion()
member UpdateTypeVersion : unit -> unit
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.Write Method

OptimizedPersistableWrite Method

By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page will also be written.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Write()
Public Sub Write
public:
void Write()
member Write : unit -> unit
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.WriteMe Method

OptimizedPersistableWriteMe Method

Used by code generator.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual byte[] WriteMe(
    TypeVersion typeVersion,
    bool addShapeNumber,
    PageInfo pageInfo,
    IOptimizedPersistable owner,
    SessionBase session,
    bool inFlush
)
Public Overridable Function WriteMe (
    typeVersion As TypeVersion,
    addShapeNumber As Boolean,
    pageInfo As PageInfo,
    owner As IOptimizedPersistable,
    session As SessionBase,
    inFlush As Boolean
) As Byte()
public:
virtual array<unsigned char>^ WriteMe(
    TypeVersion^ typeVersion,
    bool addShapeNumber,
    PageInfo^ pageInfo,
    IOptimizedPersistable^ owner,
    SessionBase^ session,
    bool inFlush
)
abstract WriteMe :
        typeVersion : TypeVersion *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]
override WriteMe :
        typeVersion : TypeVersion *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

addShapeNumber
Type: SystemBoolean

[Missing <param name="addShapeNumber"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

pageInfo
Type: VelocityDbPageInfo

[Missing <param name="pageInfo"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

owner
Type: VelocityDbIOptimizedPersistable

[Missing <param name="owner"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

inFlush
Type: SystemBoolean

[Missing <param name="inFlush"/> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:VelocityDb.OptimizedPersistable.WriteMe(VelocityDb.TypeInfo.TypeVersion,System.Boolean,VelocityDb.PageInfo,VelocityDb.IOptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Implements

IOptimizedPersistableWriteMe(TypeVersion, Boolean, PageInfo, IOptimizedPersistable, SessionBase, Boolean)
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


OptimizedPersistable.WriteMeUsingSchemaReflection Method

OptimizedPersistableWriteMeUsingSchemaReflection Method

Used by code generator. This is the default way of writing objects using schema information and .NET reflection info.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static byte[] WriteMeUsingSchemaReflection(
    TypeVersion typeVersion,
    IOptimizedPersistable pObj,
    bool addShapeNumber,
    PageInfo pageInfo,
    IOptimizedPersistable owner,
    SessionBase session,
    bool inFlush
)
Public Shared Function WriteMeUsingSchemaReflection (
    typeVersion As TypeVersion,
    pObj As IOptimizedPersistable,
    addShapeNumber As Boolean,
    pageInfo As PageInfo,
    owner As IOptimizedPersistable,
    session As SessionBase,
    inFlush As Boolean
) As Byte()
public:
static array<unsigned char>^ WriteMeUsingSchemaReflection(
    TypeVersion^ typeVersion,
    IOptimizedPersistable^ pObj,
    bool addShapeNumber,
    PageInfo^ pageInfo,
    IOptimizedPersistable^ owner,
    SessionBase^ session,
    bool inFlush
)
static member WriteMeUsingSchemaReflection :
        typeVersion : TypeVersion *
        pObj : IOptimizedPersistable *
        addShapeNumber : bool *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> byte[]

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
pObj
Type: VelocityDbIOptimizedPersistable
The object being written
addShapeNumber
Type: SystemBoolean
Shall we include bytes containing the type version of the object?
pageInfo
Type: VelocityDbPageInfo
PageInfo for the current page
owner
Type: VelocityDbIOptimizedPersistable
Owner of object being written
session
Type: VelocityDb.SessionSessionBase
The active session
inFlush
Type: SystemBoolean
Is page flushing OK while preparing this object to be written?

Return Value

Type: Byte
Bytes of this object
See Also

Reference

OptimizedPersistable Class
VelocityDb Namespace


Page Class

Each Database consist of a number of variable sized pages. A page can be compressed and may be encrypted and contains one or more objects. Page compression is controlled by the DatabaseLocation of the Database containing a page. Each page has a PageInfo that provides info about a page and can be updated to turn on/off compression and encryption for a specific page.
Inheritance Hierarchy
SystemObject
VelocityDbPage

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Page : IComparable<Page>, IEnumerable<IOptimizedPersistable>,
    IEnumerable, IDisposable
Public Class Page
    Implements IComparable(Of Page), IEnumerable(Of IOptimizedPersistable),
    IEnumerable, IDisposable
public ref class Page : IComparable<Page^>,
    IEnumerable<IOptimizedPersistable^>, IEnumerable, IDisposable
type Page =
    class
        interface IComparable<Page>
        interface IEnumerable<IOptimizedPersistable>
        interface IEnumerable
        interface IDisposable
    end

The Page type exposes the following members.

Constructors
 | Name | Description
Public method | Page | Internal use and usage in VelocityDbExteanions project
Top
Properties
 | Name | Description
Public property | Database | The Database of this Page.
Public property | Id | The Oid (encoded as UInt64) of this page
Public property | IsUpdated | Is this Page updated?
Public property | Offset | Current page version starts at this offset in conatining Database.
Public property | Oid | The Oid of this page
Public property | OnlyStub | Is this Page fully read into memory or just the PageInfo?
Public property | PageInfo | Gets the PageInfo for this Page
Public property | PageNumber | The page number of this Page in the containing Database
Public property | ShortId | The OidShort (encoded as UInt32) of this page
Top
Methods
 | Name | Description
Public method | ClearCashedObjects | Clears all objects cached on the page but does not clear objects cached by weak references.
Public method | CompareTo | Compares Pages by PageNumber
Public method | DeleteObject | Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | FinishUpCsvImport | Schema page requires special handling in Import from CSV files
Public method | GetEnumerator | Enumerates all objects on this Page
Public method | ObjectsLazyLoaded | Enumerates all objects on this Page. Object graph loaded up to specified max depth.
Public method | PageShortIds | Enumerates all objects short ids on this Page
Public method | Slot | Retrieves an object from persistent storage
 | StringToByteArray | Converts a string into an UTF8 encoded byte array
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | UnpersistObject | Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable
Top
See Also

Reference

VelocityDb Namespace


Page Constructor

Internal use and usage in VelocityDbExteanions project

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Page(
    Database db,
    ushort pageNumber,
    uint shapeNumber,
    ushort objectsPerPage,
    bool doCache = true
)
Public Sub New (
    db As Database,
    pageNumber As UShort,
    shapeNumber As UInteger,
    objectsPerPage As UShort,
    Optional doCache As Boolean = true
)
public:
Page(
    Database^ db,
    unsigned short pageNumber,
    unsigned int shapeNumber,
    unsigned short objectsPerPage,
    bool doCache = true
)
new :
        db : Database *
        pageNumber : uint16 *
        shapeNumber : uint32 *
        objectsPerPage : uint16 *
        ?doCache : bool
(* Defaults:
        let _doCache = defaultArg doCache true
*)
-> Page

Parameters

db
Type: VelocityDbDatabase
Database this Page belongs to
pageNumber
Type: SystemUInt16
Page number of this page
shapeNumber
Type: SystemUInt32
Short Id of object schema type if page contains just a single type of objects
objectsPerPage
Type: SystemUInt16
Max how many objects to store on this page
doCache (Optional)
Type: SystemBoolean
Cache this page in its database?
See Also

Reference

Page Class
VelocityDb Namespace


Page Properties

The Page type exposes the following members.

Properties
 | Name | Description
Public property | Database | The Database of this Page.
Public property | Id | The Oid (encoded as UInt64) of this page
Public property | IsUpdated | Is this Page updated?
Public property | Offset | Current page version starts at this offset in conatining Database.
Public property | Oid | The Oid of this page
Public property | OnlyStub | Is this Page fully read into memory or just the PageInfo?
Public property | PageInfo | Gets the PageInfo for this Page
Public property | PageNumber | The page number of this Page in the containing Database
Public property | ShortId | The OidShort (encoded as UInt32) of this page
Top
See Also

Reference

Page Class
VelocityDb Namespace


Page.Database Property

PageDatabase Property

The Database of this Page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}
member Database : Database with get

Property Value

Type: Database
See Also

Reference

Page Class
VelocityDb Namespace


Page.Id Property

PageId Property

The Oid (encoded as UInt64) of this page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Id { get; }
Public ReadOnly Property Id As ULong
    Get
public:
property unsigned long long Id {
    unsigned long long get ();
}
member Id : uint64 with get

Property Value

Type: UInt64
See Also

Reference

Page Class
VelocityDb Namespace


Page.IsUpdated Property

PageIsUpdated Property

Is this Page updated?

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsUpdated { get; }
Public ReadOnly Property IsUpdated As Boolean
    Get
public:
property bool IsUpdated {
    bool get ();
}
member IsUpdated : bool with get

Property Value

Type: Boolean
See Also

Reference

Page Class
VelocityDb Namespace


Page.Offset Property

PageOffset Property

Current page version starts at this offset in conatining Database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long Offset { get; }
Public ReadOnly Property Offset As Long
    Get
public:
property long long Offset {
    long long get ();
}
member Offset : int64 with get

Property Value

Type: Int64
See Also

Reference

Page Class
VelocityDb Namespace


Page.Oid Property

PageOid Property

The Oid of this page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid Oid { get; }
Public ReadOnly Property Oid As Oid
    Get
public:
property Oid Oid {
    Oid get ();
}
member Oid : Oid with get

Property Value

Type: Oid
See Also

Reference

Page Class
VelocityDb Namespace


Page.OnlyStub Property

PageOnlyStub Property

Is this Page fully read into memory or just the PageInfo?

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool OnlyStub { get; }
Public ReadOnly Property OnlyStub As Boolean
    Get
public:
property bool OnlyStub {
    bool get ();
}
member OnlyStub : bool with get

Property Value

Type: Boolean
See Also

Reference

Page Class
VelocityDb Namespace


Page.PageInfo Property

PagePageInfo Property

Gets the PageInfo for this Page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageInfo PageInfo { get; }
Public ReadOnly Property PageInfo As PageInfo
    Get
public:
property PageInfo^ PageInfo {
    PageInfo^ get ();
}
member PageInfo : PageInfo with get

Property Value

Type: PageInfo
See Also

Reference

Page Class
VelocityDb Namespace


Page.PageNumber Property

PagePageNumber Property

The page number of this Page in the containing Database

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort PageNumber { get; }
Public ReadOnly Property PageNumber As UShort
    Get
public:
property unsigned short PageNumber {
    unsigned short get ();
}
member PageNumber : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Page Class
VelocityDb Namespace


Page.ShortId Property

PageShortId Property

The OidShort (encoded as UInt32) of this page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint ShortId { get; }
Public ReadOnly Property ShortId As UInteger
    Get
public:
property unsigned int ShortId {
    unsigned int get ();
}
member ShortId : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Page Class
VelocityDb Namespace


Page Methods

The Page type exposes the following members.

Methods
 | Name | Description
Public method | ClearCashedObjects | Clears all objects cached on the page but does not clear objects cached by weak references.
Public method | CompareTo | Compares Pages by PageNumber
Public method | DeleteObject | Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | FinishUpCsvImport | Schema page requires special handling in Import from CSV files
Public method | GetEnumerator | Enumerates all objects on this Page
Public method | ObjectsLazyLoaded | Enumerates all objects on this Page. Object graph loaded up to specified max depth.
Public method | PageShortIds | Enumerates all objects short ids on this Page
Public method | Slot | Retrieves an object from persistent storage
 | StringToByteArray | Converts a string into an UTF8 encoded byte array
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | UnpersistObject | Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable
Top
See Also

Reference

Page Class
VelocityDb Namespace


Page.ClearCashedObjects Method

PageClearCashedObjects Method

Clears all objects cached on the page but does not clear objects cached by weak references.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort ClearCashedObjects(
    SessionBase session
)
Public Function ClearCashedObjects (
    session As SessionBase
) As UShort
public:
unsigned short ClearCashedObjects(
    SessionBase^ session
)
member ClearCashedObjects :
        session : SessionBase -> uint16

Parameters

session
Type: VelocityDb.SessionSessionBase

Return Value

Type: UInt16

[Missing <returns> documentation for "M:VelocityDb.Page.ClearCashedObjects(VelocityDb.Session.SessionBase)"]

See Also

Reference

Page Class
VelocityDb Namespace


Page.CompareTo Method

PageCompareTo Method

Compares Pages by PageNumber

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Page otherPage
)
Public Function CompareTo (
    otherPage As Page
) As Integer
public:
virtual int CompareTo(
    Page^ otherPage
) sealed
abstract CompareTo :
        otherPage : Page -> int
override CompareTo :
        otherPage : Page -> int

Parameters

otherPage
Type: VelocityDbPage
The Page to compare with

Return Value

Type: Int32
-1 if this PageNumber is less than obj.PageNumber, 0 if equal and 1 if greater than

Implements

IComparableTCompareTo(T)
See Also

Reference

Page Class
VelocityDb Namespace


Page.DeleteObject Method

PageDeleteObject Method

Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeleteObject(
    ulong id
)
Public Sub DeleteObject (
    id As ULong
)
public:
void DeleteObject(
    unsigned long long id
)
member DeleteObject :
        id : uint64 -> unit

Parameters

id
Type: SystemUInt64
The object Id of the object to be deleted
See Also

Reference

Page Class
VelocityDb Namespace


Page.Dispose Method

PageDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Page Class
VelocityDb Namespace


Page.FinishUpCsvImport Method

PageFinishUpCsvImport Method

Schema page requires special handling in Import from CSV files

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void FinishUpCsvImport()
Public Sub FinishUpCsvImport
public:
void FinishUpCsvImport()
member FinishUpCsvImport : unit -> unit
See Also

Reference

Page Class
VelocityDb Namespace


Page.GetEnumerator Method

PageGetEnumerator Method

Enumerates all objects on this Page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<IOptimizedPersistable> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IOptimizedPersistable)
public:
virtual IEnumerator<IOptimizedPersistable^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<IOptimizedPersistable>
override GetEnumerator : unit -> IEnumerator<IOptimizedPersistable>

Return Value

Type: IEnumerator IOptimizedPersistable
Enumeration of all slots on this Page

Implements

IEnumerableTGetEnumerator
See Also

Reference

Page Class
VelocityDb Namespace


Page.ObjectsLazyLoaded Method

PageObjectsLazyLoaded Method

Enumerates all objects on this Page. Object graph loaded up to specified max depth.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IOptimizedPersistable> ObjectsLazyLoaded(
    int depthToLoad = 0
)
Public Function ObjectsLazyLoaded (
    Optional depthToLoad As Integer = 0
) As IEnumerable(Of IOptimizedPersistable)
public:
IEnumerable<IOptimizedPersistable^>^ ObjectsLazyLoaded(
    int depthToLoad = 0
)
member ObjectsLazyLoaded :
        ?depthToLoad : int
(* Defaults:
        let _depthToLoad = defaultArg depthToLoad 0
*)
-> IEnumerable<IOptimizedPersistable>

Parameters

depthToLoad (Optional)
Type: SystemInt32
Max how many levels deep to load each object

Return Value

Type: IEnumerable IOptimizedPersistable
Enumeration of all slots on this Page
See Also

Reference

Page Class
VelocityDb Namespace


Page.PageShortIds Method

PagePageShortIds Method

Enumerates all objects short ids on this Page

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<uint> PageShortIds()
Public Function PageShortIds As IEnumerable(Of UInteger)
public:
IEnumerable<unsigned int>^ PageShortIds()
member PageShortIds : unit -> IEnumerable<uint32>

Return Value

Type: IEnumerable UInt32
Enumeration of all slot short ids on this Page
See Also

Reference

Page Class
VelocityDb Namespace


Page.Slot Method

PageSlot Method

Retrieves an object from persistent storage

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IOptimizedPersistable Slot(
    ulong oid,
    bool openRefs,
    SessionBase session,
    Schema schema,
    bool iteration,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad = 2147483647,
    TypeVersion shape = null
)
Public Function Slot (
    oid As ULong,
    openRefs As Boolean,
    session As SessionBase,
    schema As Schema,
    iteration As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    Optional graphDepthToLoad As Integer = 2147483647,
    Optional shape As TypeVersion = Nothing
) As IOptimizedPersistable
public:
IOptimizedPersistable^ Slot(
    unsigned long long oid,
    bool openRefs,
    SessionBase^ session,
    Schema^ schema,
    bool iteration,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad = 2147483647,
    TypeVersion^ shape = nullptr
)
member Slot :
        oid : uint64 *
        openRefs : bool *
        session : SessionBase *
        schema : Schema *
        iteration : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        ?graphDepthToLoad : int *
        ?shape : TypeVersion
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
        let _shape = defaultArg shape null
*)
-> IOptimizedPersistable

Parameters

oid
Type: SystemUInt64
Id of object to retrieve
openRefs
Type: SystemBoolean
Shall we open references from this object?
session
Type: VelocityDb.SessionSessionBase
The active session
schema
Type: VelocityDb.TypeInfoSchema
The active schema
iteration
Type: SystemBoolean
Is this called as part of an iteration
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
List of members to load
graphDepth
Type: SystemInt32
The current load graph depth
graphDepthToLoad (Optional)
Type: SystemInt32
Max graph depth to load
shape (Optional)
Type: VelocityDb.TypeInfoTypeVersion
The type version of the object to retrieve

Return Value

Type: IOptimizedPersistable
The retrieved object
See Also

Reference

Page Class
VelocityDb Namespace


Page.StringToByteArray Method

PageStringToByteArray Method

Converts a string into an UTF8 encoded byte array

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static byte[] StringToByteArray(
    string str
)
Public Shared Function StringToByteArray (
    str As String
) As Byte()
public:
static array<unsigned char>^ StringToByteArray(
    String^ str
)
static member StringToByteArray :
        str : string -> byte[]

Parameters

str
Type: SystemString
a string to convert

Return Value

Type: Byte
a UTF8 encoding
See Also

Reference

Page Class
VelocityDb Namespace


Page.ToString Method

PageToString Method

Returns a string that represents the current object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the current object.
See Also

Reference

Page Class
VelocityDb Namespace


Page.UnpersistObject Method

PageUnpersistObject Method

Use this as an alternative to Unpersist(SessionBase) or when using the interface class IOptimizedPersistable

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void UnpersistObject(
    IOptimizedPersistable pObj
)
Public Sub UnpersistObject (
    pObj As IOptimizedPersistable
)
public:
void UnpersistObject(
    IOptimizedPersistable^ pObj
)
member UnpersistObject :
        pObj : IOptimizedPersistable -> unit

Parameters

pObj
Type: VelocityDbIOptimizedPersistable
The object to be unpersisted
See Also

Reference

Page Class
VelocityDb Namespace


PageCache Class

Maintains string references to Pages within a Database
Inheritance Hierarchy
SystemObject
VelocityDbPageCache

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class PageCache : IEnumerable<Page>,
    IEnumerable
Public Class PageCache
    Implements IEnumerable(Of Page), IEnumerable
public ref class PageCache : IEnumerable<Page^>,
    IEnumerable
type PageCache =
    class
        interface IEnumerable<Page>
        interface IEnumerable
    end

The PageCache type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get or set a page in the page cache
Public property | Length | Max number of pages in page cache
Top
Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of the cached Pages
Top
See Also

Reference

VelocityDb Namespace


PageCache Properties

The PageCache type exposes the following members.

Properties
 | Name | Description
Public property | Item | Get or set a page in the page cache
Public property | Length | Max number of pages in page cache
Top
See Also

Reference

PageCache Class
VelocityDb Namespace


PageCache.Item Property

PageCacheItem Property

Get or set a page in the page cache

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Page this[
    ushort pageNumber
] { get; set; }
Public Default Property Item (
    pageNumber As UShort
) As Page
    Get
    Set
public:
property Page^ default[unsigned short pageNumber] {
    Page^ get (unsigned short pageNumber);
    void set (unsigned short pageNumber, Page^ value);
}
member Item : Page with get, set

Parameters

pageNumber
Type: SystemUInt16
Page number within a database for requested page

Return Value

Type: Page
A page if it exist in the page cache
See Also

Reference

PageCache Class
VelocityDb Namespace


PageCache.Length Property

PageCacheLength Property

Max number of pages in page cache

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Property Value

Type: Int32
See Also

Reference

PageCache Class
VelocityDb Namespace


PageCache Methods

The PageCache type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Enumeration of all objects of the cached Pages
Top
See Also

Reference

PageCache Class
VelocityDb Namespace


PageCache.GetEnumerator Method

PageCacheGetEnumerator Method

Enumeration of all objects of the cached Pages

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
The enumeration

Implements

IEnumerableGetEnumerator
See Also

Reference

PageCache Class
VelocityDb Namespace


PageInfo Class

Each Page has a PageInfo that provides info about a page and can be used to turn on/off compression and encryption for a page.
Inheritance Hierarchy
SystemObject
VelocityDbPageInfo

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class PageInfo
Public Class PageInfo
public ref class PageInfo
type PageInfo =  class end

The PageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | A Page can be compressed or not.
Public property | Encryption | A Page can be encrypted with DES or not.
Public property | FirstFreeSlot | The first available page on the Page.
Public property | NoFreeSlotInBetweenInUseSlots | Is there no gaps of unused slots in between the in use slots (all contigous in use slots)?
Public property | NumberOfSlots | The number of objects/slots on the Page.
Public property | OnDiskSize | The byte size of the Page when it was last written to disk.
Public property | ShapeNumber | If non 0, all objects on the page have the same Type.
Public property | UncompressedSize | The byte size of the Page when it was last written to disk (before any compression was applied).
Public property | VersionNumber | Each Page gets its page version incremented in every transaction where the it is updated.
Top
Fields
Name | Description
s_pageInfoByteCount | The size of the PageInfo at the start of each Page.
s_pageInfoByteCountV1 |
Top
See Also

Reference

VelocityDb Namespace


PageInfo Properties

The PageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Compressed | A Page can be compressed or not.
Public property | Encryption | A Page can be encrypted with DES or not.
Public property | FirstFreeSlot | The first available page on the Page.
Public property | NoFreeSlotInBetweenInUseSlots | Is there no gaps of unused slots in between the in use slots (all contigous in use slots)?
Public property | NumberOfSlots | The number of objects/slots on the Page.
Public property | OnDiskSize | The byte size of the Page when it was last written to disk.
Public property | ShapeNumber | If non 0, all objects on the page have the same Type.
Public property | UncompressedSize | The byte size of the Page when it was last written to disk (before any compression was applied).
Public property | VersionNumber | Each Page gets its page version incremented in every transaction where the it is updated.
Top
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.Compressed Property

PageInfoCompressed Property

A Page can be compressed or not.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageInfocompressionKind Compressed { get; set; }
Public Property Compressed As PageInfocompressionKind
    Get
    Set
public:
property PageInfocompressionKind Compressed {
    PageInfocompressionKind get ();
    void set (PageInfocompressionKind value);
}
member Compressed : PageInfocompressionKind with get, set

Property Value

Type: PageInfocompressionKind
The Boolean
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.Encryption Property

PageInfoEncryption Property

A Page can be encrypted with DES or not.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageInfoencryptionKind Encryption { get; set; }
Public Property Encryption As PageInfoencryptionKind
    Get
    Set
public:
property PageInfoencryptionKind Encryption {
    PageInfoencryptionKind get ();
    void set (PageInfoencryptionKind value);
}
member Encryption : PageInfoencryptionKind with get, set

Property Value

Type: PageInfoencryptionKind
The PageInfoencryptionKind
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.FirstFreeSlot Property

PageInfoFirstFreeSlot Property

The first available page on the Page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort FirstFreeSlot { get; set; }
Public Property FirstFreeSlot As UShort
    Get
    Set
public:
property unsigned short FirstFreeSlot {
    unsigned short get ();
    void set (unsigned short value);
}
member FirstFreeSlot : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.NoFreeSlotInBetweenInUseSlots Property

PageInfoNoFreeSlotInBetweenInUseSlots Property

Is there no gaps of unused slots in between the in use slots (all contigous in use slots)?

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool NoFreeSlotInBetweenInUseSlots { get; }
Public ReadOnly Property NoFreeSlotInBetweenInUseSlots As Boolean
    Get
public:
property bool NoFreeSlotInBetweenInUseSlots {
    bool get ();
}
member NoFreeSlotInBetweenInUseSlots : bool with get

Property Value

Type: Boolean
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.NumberOfSlots Property

PageInfoNumberOfSlots Property

The number of objects/slots on the Page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort NumberOfSlots { get; set; }
Public Property NumberOfSlots As UShort
    Get
    Set
public:
property unsigned short NumberOfSlots {
    unsigned short get ();
    void set (unsigned short value);
}
member NumberOfSlots : uint16 with get, set

Property Value

Type: UInt16
The UInt16 of objects/slots on the page
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.OnDiskSize Property

PageInfoOnDiskSize Property

The byte size of the Page when it was last written to disk.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint OnDiskSize { get; }
Public ReadOnly Property OnDiskSize As UInteger
    Get
public:
property unsigned int OnDiskSize {
    unsigned int get ();
}
member OnDiskSize : uint32 with get

Property Value

Type: UInt32
The UInt32 of bytes
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.ShapeNumber Property

PageInfoShapeNumber Property

If non 0, all objects on the page have the same Type.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint ShapeNumber { get; }
Public ReadOnly Property ShapeNumber As UInteger
    Get
public:
property unsigned int ShapeNumber {
    unsigned int get ();
}
member ShapeNumber : uint32 with get

Property Value

Type: UInt32
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.UncompressedSize Property

PageInfoUncompressedSize Property

The byte size of the Page when it was last written to disk (before any compression was applied).

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint UncompressedSize { get; }
Public ReadOnly Property UncompressedSize As UInteger
    Get
public:
property unsigned int UncompressedSize {
    unsigned int get ();
}
member UncompressedSize : uint32 with get

Property Value

Type: UInt32
The UInt32 of bytes
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.VersionNumber Property

PageInfoVersionNumber Property

Each Page gets its page version incremented in every transaction where the it is updated.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong VersionNumber { get; set; }
Public Property VersionNumber As ULong
    Get
    Set
public:
property unsigned long long VersionNumber {
    unsigned long long get ();
    void set (unsigned long long value);
}
member VersionNumber : uint64 with get, set

Property Value

Type: UInt64
The current UInt64 page version
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo Fields

The PageInfo type exposes the following members.

Fields
Name | Description
s_pageInfoByteCount | The size of the PageInfo at the start of each Page.
s_pageInfoByteCountV1 |
Top
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.s_pageInfoByteCount Field

PageInfos_pageInfoByteCount Field

The size of the PageInfo at the start of each Page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_pageInfoByteCount
Public Shared ReadOnly s_pageInfoByteCount As UShort
public:
static initonly unsigned short s_pageInfoByteCount
static val s_pageInfoByteCount: uint16

Field Value

Type: UInt16
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.s_pageInfoByteCountV1 Field

PageInfos_pageInfoByteCountV1 Field

[Missing <summary> documentation for "F:VelocityDb.PageInfo.s_pageInfoByteCountV1"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_pageInfoByteCountV1
Public Shared ReadOnly s_pageInfoByteCountV1 As UShort
public:
static initonly unsigned short s_pageInfoByteCountV1
static val s_pageInfoByteCountV1: uint16

Field Value

Type: UInt16
See Also

Reference

PageInfo Class
VelocityDb Namespace


PageInfo.compressionKind Enumeration

PageInfocompressionKind Enumeration

Selection of choices foe Page compression.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum compressionKind
Public Enumeration compressionKind
public enum class compressionKind
type compressionKind
Members
Member name | Value | Description
None | 0 | No Page compression
GZip | 1 | GZipStream Page compression
LZ4 | 2 | LZ4 (safe) Page compression LZ4 - Fast LZ compression algorithm Copyright (C) 2011-2012, Yann Collet. BSD 2-Clause License (http://www.opensource.org/licenses/bsd-license.php) Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: * Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. * Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. You can contact the author at : - LZ4 homepage : http://fastcompression.blogspot.com/p/lz4.html - LZ4 source repository : http://code.google.com/p/lz4/ Port to .NET https://lz4net.codeplex.com/ Copyright (c) 2013, Milosz Krajewski
See Also

Reference

VelocityDb Namespace


PageInfo.encryptionKind Enumeration

PageInfoencryptionKind Enumeration

Use desEncrypted for encrypted pages, set encryption private key in DatabaseLocation. Use noEncryption when no encryption is desired. Other choices in this enum are not yet publicly available. Other kinds of encryption can be provided upon request. We can even make the interface public allowing application defined encryption.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum encryptionKind
Public Enumeration encryptionKind
public enum class encryptionKind
type encryptionKind
Members
Member name | Value | Description
noEncryption | 0 | No Page encryption
desEncrypted | 1 | Use DES Page encryption
rsaEncrypted2048 | 2 | Use RSA 2048bits Page encryption (not yet made publicly available)
rsaSigned2048 | 3 | Use RSA 2048bits Page signing (not yet made publicly available)
See Also

Reference

VelocityDb Namespace


Placement Class

This class is used when deciding where to place a new object persistently. That is we have a choice of database number, page number and page number. There is other ways to control the placement including ObjectsPerPage, PagesPerDatabase, and it is also possible to override Persist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbPlacement
VelocityDbAutoPlacement

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Placement : OptimizedPersistable
<SerializableAttribute>
Public Class Placement
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class Placement : public OptimizedPersistable
[<SerializableAttribute>]
type Placement =
    class
        inherit OptimizedPersistable
    end

The Placement type exposes the following members.

Constructors
 | Name | Description
Public method | Placement(SessionBase, IOptimizedPersistable, IOptimizedPersistable, Boolean, UInt32, Boolean) | Creates a Placement used for choosing a place to persist objects
Public method | Placement(UInt32, UInt16, UInt16, UInt16, UInt16, Boolean, Boolean, UInt32, Boolean, Boolean) | Creates a Placement used for choosing a place to persist objects
Top
Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Gets/sets permission to create multiple types on the same page.
Public property | EndDatabaseNumber | The last Database number acceptable for placement
Public property | MaxObjectsPerPage | Gets/Sets the limit on how many objects to create on a single page.
Public property | MaxPagesPerDatabase | Gets/sets the limit on the number of pages per database.
Public property | StartDatabaseNumber | The first/original Database number used by this Placement
Public property | StartPageNumber | The first/original Page number used by this Placement
Public property | TryDatabaseNumber | Gets the current Database number to try with first for object placement.
Public property | TryPageNumber | Gets/sets the page number to try with first when persisting a new object.
Public property | TrySlotNumber | Gets/sets the page number to try next when persisting an object.
Top
Methods
 | Name | Description
Public method | IncrementTryDatabaseNumber | Incremnts the Database number used when placing (persisting) objects
Public method | IncrementTryPageNumber | Increments the tryPageNumber by 1
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Fields
Name | Description
DefaultPlacementDatabaseNumber | If no other Database number is selected when persisting an object then this number is choosen.
DefaultPlacementPage | If no other Page number is selected when persisting an object then this number is choosen.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


Placement Constructor

Overload List
 | Name | Description
Public method | Placement(SessionBase, IOptimizedPersistable, IOptimizedPersistable, Boolean, UInt32, Boolean) | Creates a Placement used for choosing a place to persist objects
Public method | Placement(UInt32, UInt16, UInt16, UInt16, UInt16, Boolean, Boolean, UInt32, Boolean, Boolean) | Creates a Placement used for choosing a place to persist objects
Top
See Also

Reference

Placement Class
VelocityDb Namespace


Placement Constructor (SessionBase, IOptimizedPersistable, IOptimizedPersistable, Boolean, UInt32, Boolean)

Creates a Placement used for choosing a place to persist objects

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Placement(
    SessionBase session,
    IOptimizedPersistable placementProviderObject,
    IOptimizedPersistable objectToPlace,
    bool persistRefs = false,
    uint maxNumberOfDatabases = 4294967295,
    bool flushFullPages = true
)
Public Sub New (
    session As SessionBase,
    placementProviderObject As IOptimizedPersistable,
    objectToPlace As IOptimizedPersistable,
    Optional persistRefs As Boolean = false,
    Optional maxNumberOfDatabases As UInteger = 4294967295,
    Optional flushFullPages As Boolean = true
)
public:
Placement(
    SessionBase^ session,
    IOptimizedPersistable^ placementProviderObject,
    IOptimizedPersistable^ objectToPlace,
    bool persistRefs = false,
    unsigned int maxNumberOfDatabases = 4294967295,
    bool flushFullPages = true
)
new :
        session : SessionBase *
        placementProviderObject : IOptimizedPersistable *
        objectToPlace : IOptimizedPersistable *
        ?persistRefs : bool *
        ?maxNumberOfDatabases : uint32 *
        ?flushFullPages : bool
(* Defaults:
        let _persistRefs = defaultArg persistRefs false
        let _maxNumberOfDatabases = defaultArg maxNumberOfDatabases 4294967295
        let _flushFullPages = defaultArg flushFullPages true
*)
-> Placement

Parameters

session
Type: VelocityDb.SessionSessionBase
The session being used
placementProviderObject
Type: VelocityDbIOptimizedPersistable
If persistent, placement uses thid objects db, page and slot as a atarting point for placements
objectToPlace
Type: VelocityDbIOptimizedPersistable
An object of the type we are going to persist with this placement object
persistRefs (Optional)
Type: SystemBoolean
Is the placement going to request that referenced objects also gets persisted?
maxNumberOfDatabases (Optional)
Type: SystemUInt32
Maximum numner of databases to try for placement
flushFullPages (Optional)
Type: SystemBoolean
Shall a detected full page be flushed if such page is found while persisting an object with this placement
See Also

Reference

Placement Class
Placement Overload
VelocityDb Namespace


Placement Constructor (UInt32, UInt16, UInt16, UInt16, UInt16, Boolean, Boolean, UInt32, Boolean, Boolean)

Creates a Placement used for choosing a place to persist objects

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Placement(
    uint db,
    ushort page = 1,
    ushort slot = 1,
    ushort objectsPerPage = 10000,
    ushort pagesPerDatabase = 10000,
    bool persistRefs = false,
    bool tryOtherDatabaseIfLockConflict = true,
    uint maxNumberOfDatabases = 4294967295,
    bool allowOtherTypesOnSamePage = true,
    bool flushFullPages = true
)
Public Sub New (
    db As UInteger,
    Optional page As UShort = 1,
    Optional slot As UShort = 1,
    Optional objectsPerPage As UShort = 10000,
    Optional pagesPerDatabase As UShort = 10000,
    Optional persistRefs As Boolean = false,
    Optional tryOtherDatabaseIfLockConflict As Boolean = true,
    Optional maxNumberOfDatabases As UInteger = 4294967295,
    Optional allowOtherTypesOnSamePage As Boolean = true,
    Optional flushFullPages As Boolean = true
)
public:
Placement(
    unsigned int db,
    unsigned short page = 1,
    unsigned short slot = 1,
    unsigned short objectsPerPage = 10000,
    unsigned short pagesPerDatabase = 10000,
    bool persistRefs = false,
    bool tryOtherDatabaseIfLockConflict = true,
    unsigned int maxNumberOfDatabases = 4294967295,
    bool allowOtherTypesOnSamePage = true,
    bool flushFullPages = true
)
new :
        db : uint32 *
        ?page : uint16 *
        ?slot : uint16 *
        ?objectsPerPage : uint16 *
        ?pagesPerDatabase : uint16 *
        ?persistRefs : bool *
        ?tryOtherDatabaseIfLockConflict : bool *
        ?maxNumberOfDatabases : uint32 *
        ?allowOtherTypesOnSamePage : bool *
        ?flushFullPages : bool
(* Defaults:
        let _page = defaultArg page 1
        let _slot = defaultArg slot 1
        let _objectsPerPage = defaultArg objectsPerPage 10000
        let _pagesPerDatabase = defaultArg pagesPerDatabase 10000
        let _persistRefs = defaultArg persistRefs false
        let _tryOtherDatabaseIfLockConflict = defaultArg tryOtherDatabaseIfLockConflict true
        let _maxNumberOfDatabases = defaultArg maxNumberOfDatabases 4294967295
        let _allowOtherTypesOnSamePage = defaultArg allowOtherTypesOnSamePage true
        let _flushFullPages = defaultArg flushFullPages true
*)
-> Placement

Parameters

db
Type: SystemUInt32
Database number requested for placement
page (Optional)
Type: SystemUInt16
Page number requested for placement
slot (Optional)
Type: SystemUInt16
Slot number requested for placement
objectsPerPage (Optional)
Type: SystemUInt16
Limit the number of objects per page
pagesPerDatabase (Optional)
Type: SystemUInt16
Limit the number of pages per database
persistRefs (Optional)
Type: SystemBoolean
When persisting an object, shall references be persisted at the same time or later when flushing pages to disk
tryOtherDatabaseIfLockConflict (Optional)
Type: SystemBoolean
Is another Database acceptable
maxNumberOfDatabases (Optional)
Type: SystemUInt32
Maximum numner of databases to try for placement
allowOtherTypesOnSamePage (Optional)
Type: SystemBoolean
Is it OK to place object on a page which contains other types
flushFullPages (Optional)
Type: SystemBoolean
Is it OK toflush encounteted full pages?
See Also

Reference

Placement Class
Placement Overload
VelocityDb Namespace


Placement Properties

The Placement type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Gets/sets permission to create multiple types on the same page.
Public property | EndDatabaseNumber | The last Database number acceptable for placement
Public property | MaxObjectsPerPage | Gets/Sets the limit on how many objects to create on a single page.
Public property | MaxPagesPerDatabase | Gets/sets the limit on the number of pages per database.
Public property | StartDatabaseNumber | The first/original Database number used by this Placement
Public property | StartPageNumber | The first/original Page number used by this Placement
Public property | TryDatabaseNumber | Gets the current Database number to try with first for object placement.
Public property | TryPageNumber | Gets/sets the page number to try with first when persisting a new object.
Public property | TrySlotNumber | Gets/sets the page number to try next when persisting an object.
Top
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.AllowOtherTypesOnSamePage Property

PlacementAllowOtherTypesOnSamePage Property

Gets/sets permission to create multiple types on the same page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AllowOtherTypesOnSamePage { get; set; }
Public Property AllowOtherTypesOnSamePage As Boolean
    Get
    Set
public:
property bool AllowOtherTypesOnSamePage {
    bool get ();
    void set (bool value);
}
member AllowOtherTypesOnSamePage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.EndDatabaseNumber Property

PlacementEndDatabaseNumber Property

The last Database number acceptable for placement

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint EndDatabaseNumber { get; }
Public ReadOnly Property EndDatabaseNumber As UInteger
    Get
public:
property unsigned int EndDatabaseNumber {
    unsigned int get ();
}
member EndDatabaseNumber : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.MaxObjectsPerPage Property

PlacementMaxObjectsPerPage Property

Gets/Sets the limit on how many objects to create on a single page.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort MaxObjectsPerPage { get; set; }
Public Property MaxObjectsPerPage As UShort
    Get
    Set
public:
property unsigned short MaxObjectsPerPage {
    unsigned short get ();
    void set (unsigned short value);
}
member MaxObjectsPerPage : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.MaxPagesPerDatabase Property

PlacementMaxPagesPerDatabase Property

Gets/sets the limit on the number of pages per database.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort MaxPagesPerDatabase { get; set; }
Public Property MaxPagesPerDatabase As UShort
    Get
    Set
public:
property unsigned short MaxPagesPerDatabase {
    unsigned short get ();
    void set (unsigned short value);
}
member MaxPagesPerDatabase : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.StartDatabaseNumber Property

PlacementStartDatabaseNumber Property

The first/original Database number used by this Placement

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint StartDatabaseNumber { get; }
Public ReadOnly Property StartDatabaseNumber As UInteger
    Get
public:
property unsigned int StartDatabaseNumber {
    unsigned int get ();
}
member StartDatabaseNumber : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.StartPageNumber Property

PlacementStartPageNumber Property

The first/original Page number used by this Placement

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint StartPageNumber { get; }
Public ReadOnly Property StartPageNumber As UInteger
    Get
public:
property unsigned int StartPageNumber {
    unsigned int get ();
}
member StartPageNumber : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.TryDatabaseNumber Property

PlacementTryDatabaseNumber Property

Gets the current Database number to try with first for object placement.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint TryDatabaseNumber { get; set; }
Public Property TryDatabaseNumber As UInteger
    Get
    Set
public:
property unsigned int TryDatabaseNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member TryDatabaseNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.TryPageNumber Property

PlacementTryPageNumber Property

Gets/sets the page number to try with first when persisting a new object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort TryPageNumber { get; set; }
Public Property TryPageNumber As UShort
    Get
    Set
public:
property unsigned short TryPageNumber {
    unsigned short get ();
    void set (unsigned short value);
}
member TryPageNumber : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.TrySlotNumber Property

PlacementTrySlotNumber Property

Gets/sets the page number to try next when persisting an object.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort TrySlotNumber { get; set; }
Public Property TrySlotNumber As UShort
    Get
    Set
public:
property unsigned short TrySlotNumber {
    unsigned short get ();
    void set (unsigned short value);
}
member TrySlotNumber : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Placement Class
VelocityDb Namespace


Placement Methods

The Placement type exposes the following members.

Methods
 | Name | Description
Public method | IncrementTryDatabaseNumber | Incremnts the Database number used when placing (persisting) objects
Public method | IncrementTryPageNumber | Increments the tryPageNumber by 1
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.IncrementTryDatabaseNumber Method

PlacementIncrementTryDatabaseNumber Method

Incremnts the Database number used when placing (persisting) objects

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual uint IncrementTryDatabaseNumber()
Public Overridable Function IncrementTryDatabaseNumber As UInteger
public:
virtual unsigned int IncrementTryDatabaseNumber()
abstract IncrementTryDatabaseNumber : unit -> uint32
override IncrementTryDatabaseNumber : unit -> uint32

Return Value

Type: UInt32
The Database number before incrementing
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.IncrementTryPageNumber Method

PlacementIncrementTryPageNumber Method

Increments the tryPageNumber by 1

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort IncrementTryPageNumber()
Public Function IncrementTryPageNumber As UShort
public:
unsigned short IncrementTryPageNumber()
member IncrementTryPageNumber : unit -> uint16

Return Value

Type: UInt16
The tryPageNumber before the increment
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.InitializeAfterRecreate Method

PlacementInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.ReadMe Method

PlacementReadMe Method

[Missing <summary> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.Placement.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

Placement Class
VelocityDb Namespace


Placement Fields

The Placement type exposes the following members.

Fields
Name | Description
DefaultPlacementDatabaseNumber | If no other Database number is selected when persisting an object then this number is choosen.
DefaultPlacementPage | If no other Page number is selected when persisting an object then this number is choosen.
Top
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.DefaultPlacementDatabaseNumber Field

PlacementDefaultPlacementDatabaseNumber Field

If no other Database number is selected when persisting an object then this number is choosen.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint DefaultPlacementDatabaseNumber = 10
Public Const DefaultPlacementDatabaseNumber As UInteger = 10
public:
literal unsigned int DefaultPlacementDatabaseNumber = 10
static val mutable DefaultPlacementDatabaseNumber: uint32

Field Value

Type: UInt32
See Also

Reference

Placement Class
VelocityDb Namespace


Placement.DefaultPlacementPage Field

PlacementDefaultPlacementPage Field

If no other Page number is selected when persisting an object then this number is choosen.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const ushort DefaultPlacementPage = 1
Public Const DefaultPlacementPage As UShort = 1
public:
literal unsigned short DefaultPlacementPage = 1
static val mutable DefaultPlacementPage: uint16

Field Value

Type: UInt16
See Also

Reference

Placement Class
VelocityDb Namespace


ReferenceTracked Class

Tracks references to this object and signals ReferentialIntegrityException if unpersisted before while still being referenced.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDbReferenceTracked

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceTracked : OptimizedPersistable,
    IReferenceTracked, IOptimizedPersistable, IComparable
Public Class ReferenceTracked
    Inherits OptimizedPersistable
    Implements IReferenceTracked, IOptimizedPersistable, IComparable
public ref class ReferenceTracked : public OptimizedPersistable,
    IReferenceTracked, IOptimizedPersistable, IComparable
type ReferenceTracked =
    class
        inherit OptimizedPersistable
        interface IReferenceTracked
        interface IOptimizedPersistable
        interface IComparable
    end

The ReferenceTracked type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceTracked | Initializes a new instance of the ReferenceTracked class
Top
Properties
 | Name | Description
Public property | References | Get a collection of references to this object
Top
Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb Namespace


ReferenceTracked Constructor

Initializes a new instance of the ReferenceTracked class

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ReferenceTracked()
Public Sub New
public:
ReferenceTracked()
new : unit -> ReferenceTracked
See Also

Reference

ReferenceTracked Class
VelocityDb Namespace


ReferenceTracked Properties

The ReferenceTracked type exposes the following members.

Properties
 | Name | Description
Public property | References | Get a collection of references to this object
Top
See Also

Reference

ReferenceTracked Class
VelocityDb Namespace


ReferenceTracked.References Property

ReferenceTrackedReferences Property

Get a collection of references to this object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<Reference> References { get; }
Public ReadOnly Property References As BTreeSet(Of Reference)
    Get
public:
virtual property BTreeSet<Reference^>^ References {
    BTreeSet<Reference^>^ get () sealed;
}
abstract References : BTreeSet<Reference> with get
override References : BTreeSet<Reference> with get

Property Value

Type: BTreeSet Reference

Implements

IReferenceTrackedReferences
See Also

Reference

ReferenceTracked Class
VelocityDb Namespace


ReferenceTracked Methods

The ReferenceTracked type exposes the following members.

Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

ReferenceTracked Class
VelocityDb Namespace


ReferenceTracked.Unpersist Method

ReferenceTrackedUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

ReferenceTracked Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Class

WeakIOptimizedPersistableReferenceT Class

When a persistent object is opened, all its referenced objects are opened as well. In order to limit the number of opened objects, you need to use this class. A reference from an instance of this class will not cause the referenced object to be opened. It will be opened when you ask for it.
Inheritance Hierarchy
SystemObject
VelocityDbWeakIOptimizedPersistableReferenceBase
VelocityDbWeakIOptimizedPersistableReferenceT

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WeakIOptimizedPersistableReference<T> : WeakIOptimizedPersistableReferenceBase
where T : IOptimizedPersistable

<SerializableAttribute>
Public Class WeakIOptimizedPersistableReference(Of T As IOptimizedPersistable)
    Inherits WeakIOptimizedPersistableReferenceBase
[SerializableAttribute]
generic<typename T>
where T : IOptimizedPersistable
public ref class WeakIOptimizedPersistableReference : public WeakIOptimizedPersistableReferenceBase
[<SerializableAttribute>]
type WeakIOptimizedPersistableReference<'T when 'T : IOptimizedPersistable> =
    class
        inherit WeakIOptimizedPersistableReferenceBase
    end

Type Parameters

T
The Type of the weak referenced object, must be OptimizedPersistable

The WeakIOptimizedPersistableReferenceT type exposes the following members.

Constructors
 | Name | Description
Public method | WeakIOptimizedPersistableReferenceT(UInt64) | Creates a weak reference to some OptimizedPersistable object
Public method | WeakIOptimizedPersistableReferenceT(T) | Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.
Public method | WeakIOptimizedPersistableReferenceT(Oid) | Creates a weak reference to some OptimizedPersistable object
Top
Properties
 | Name | Description
Public property | Id | Id of weak referenced object (Overrides WeakIOptimizedPersistableReferenceBaseId.)
Public property | ShortId | Short reference ID of weak reference (Overrides WeakIOptimizedPersistableReferenceBaseShortId.)
Top
Methods
 | Name | Description
Public method | GetTarget | Gets the persistent object referenced by the weak reference
Public method | ToString | Append the Oid of the referenced object to the string. (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Constructor

WeakIOptimizedPersistableReferenceT Constructor

Overload List
 | Name | Description
Public method | WeakIOptimizedPersistableReferenceT(UInt64) | Creates a weak reference to some OptimizedPersistable object
Public method | WeakIOptimizedPersistableReferenceT(T) | Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.
Public method | WeakIOptimizedPersistableReferenceT(Oid) | Creates a weak reference to some OptimizedPersistable object
Top
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Constructor (UInt64)

WeakIOptimizedPersistableReferenceT Constructor (UInt64)

Creates a weak reference to some OptimizedPersistable object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReference(
    ulong oid
)
Public Sub New (
    oid As ULong
)
public:
WeakIOptimizedPersistableReference(
    unsigned long long oid
)
new :
        oid : uint64 -> WeakIOptimizedPersistableReference

Parameters

oid
Type: SystemUInt64
Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
WeakIOptimizedPersistableReferenceT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Constructor (T)

WeakIOptimizedPersistableReferenceT Constructor (T)

Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReference(
    T obj
)
Public Sub New (
    obj As T
)
public:
WeakIOptimizedPersistableReference(
    T obj
)
new :
        obj : 'T -> WeakIOptimizedPersistableReference

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:VelocityDb.WeakIOptimizedPersistableReference`1.#ctor(`0)"]

See Also

Reference

WeakIOptimizedPersistableReferenceT Class
WeakIOptimizedPersistableReferenceT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Constructor (Oid)

WeakIOptimizedPersistableReferenceT Constructor (Oid)

Creates a weak reference to some OptimizedPersistable object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReference(
    Oid oid
)
Public Sub New (
    oid As Oid
)
public:
WeakIOptimizedPersistableReference(
    Oid oid
)
new :
        oid : Oid -> WeakIOptimizedPersistableReference

Parameters

oid
Type: VelocityDbOid
Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
WeakIOptimizedPersistableReferenceT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Properties

WeakIOptimizedPersistableReferenceT Properties

The WeakIOptimizedPersistableReferenceT generic type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of weak referenced object (Overrides WeakIOptimizedPersistableReferenceBaseId.)
Public property | ShortId | Short reference ID of weak reference (Overrides WeakIOptimizedPersistableReferenceBaseShortId.)
Top
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T).Id Property

WeakIOptimizedPersistableReferenceTId Property

Id of weak referenced object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Id { get; set; }
Public Overrides Property Id As ULong
    Get
    Set
public:
virtual property unsigned long long Id {
    unsigned long long get () override;
    void set (unsigned long long value) override;
}
abstract Id : uint64 with get, set
override Id : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T).ShortId Property

WeakIOptimizedPersistableReferenceTShortId Property

Short reference ID of weak reference

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint ShortId { get; set; }
Public Overrides Property ShortId As UInteger
    Get
    Set
public:
virtual property unsigned int ShortId {
    unsigned int get () override;
    void set (unsigned int value) override;
}
abstract ShortId : uint32 with get, set
override ShortId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T) Methods

WeakIOptimizedPersistableReferenceT Methods

The WeakIOptimizedPersistableReferenceT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetTarget | Gets the persistent object referenced by the weak reference
Public method | ToString | Append the Oid of the referenced object to the string. (Overrides ObjectToString.)
Top
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T).GetTarget Method

WeakIOptimizedPersistableReferenceTGetTarget Method

Gets the persistent object referenced by the weak reference

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T GetTarget(
    bool update,
    SessionBase session
)
Public Function GetTarget (
    update As Boolean,
    session As SessionBase
) As T
public:
T GetTarget(
    bool update,
    SessionBase^ session
)
member GetTarget :
        update : bool *
        session : SessionBase -> 'T

Parameters

update
Type: SystemBoolean
Open the persistent object for update?
session
Type: VelocityDb.SessionSessionBase
The session managing the persistent object

Return Value

Type: T
The object referenced by this weak reference
See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReference(T).ToString Method

WeakIOptimizedPersistableReferenceTToString Method

Append the Oid of the referenced object to the string.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDb.WeakIOptimizedPersistableReference`1.ToString"]

See Also

Reference

WeakIOptimizedPersistableReferenceT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceBase Class

This is the base class for all weak references.
Inheritance Hierarchy
SystemObject
VelocityDbWeakIOptimizedPersistableReferenceBase
VelocityDbWeakIOptimizedPersistableReferenceT
VelocityDbWeakIOptimizedPersistableReferenceXT

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class WeakIOptimizedPersistableReferenceBase
<SerializableAttribute>
Public MustInherit Class WeakIOptimizedPersistableReferenceBase
[SerializableAttribute]
public ref class WeakIOptimizedPersistableReferenceBase abstract
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WeakIOptimizedPersistableReferenceBase =  class end

The WeakIOptimizedPersistableReferenceBase type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of weak referenced object
Public property | ShortId | Short reference ID of weak reference
Top
See Also

Reference

VelocityDb Namespace


WeakIOptimizedPersistableReferenceBase Properties

The WeakIOptimizedPersistableReferenceBase type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of weak referenced object
Public property | ShortId | Short reference ID of weak reference
Top
See Also

Reference

WeakIOptimizedPersistableReferenceBase Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceBase.Id Property

WeakIOptimizedPersistableReferenceBaseId Property

Id of weak referenced object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract ulong Id { get; set; }
Public MustOverride Property Id As ULong
    Get
    Set
public:
virtual property unsigned long long Id {
    unsigned long long get () abstract;
    void set (unsigned long long value) abstract;
}
abstract Id : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

WeakIOptimizedPersistableReferenceBase Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceBase.ShortId Property

WeakIOptimizedPersistableReferenceBaseShortId Property

Short reference ID of weak reference

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract uint ShortId { get; set; }
Public MustOverride Property ShortId As UInteger
    Get
    Set
public:
virtual property unsigned int ShortId {
    unsigned int get () abstract;
    void set (unsigned int value) abstract;
}
abstract ShortId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

WeakIOptimizedPersistableReferenceBase Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Class

WeakIOptimizedPersistableReferenceXT Class

Note: This API is now obsolete.

Deprecated, use WeakIOptimizedPersistableReference instead (so name conflict can be avoided) When a persistent object is opened, all its referenced objects are opened as well. In order to limit the number of opened objects, you need to use this class. A reference from an instance of this class will not cause the referenced object to be opened. It will be opened when you ask for it. The Type of the weak referenced object, must be OptimizedPersistable
Inheritance Hierarchy
SystemObject
VelocityDbWeakIOptimizedPersistableReferenceBase
VelocityDbWeakIOptimizedPersistableReferenceXT

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Use WeakIOptimizedPersistableReference instead (so name conflict can be avoided)",
    false)]
public class WeakIOptimizedPersistableReferenceX<T> : WeakIOptimizedPersistableReferenceBase
where T : IOptimizedPersistable

<SerializableAttribute>
<ObsoleteAttribute("Use WeakIOptimizedPersistableReference instead (so name conflict can be avoided)",
    false)>
Public Class WeakIOptimizedPersistableReferenceX(Of T As IOptimizedPersistable)
    Inherits WeakIOptimizedPersistableReferenceBase
[SerializableAttribute]
[ObsoleteAttribute(L"Use WeakIOptimizedPersistableReference instead (so name conflict can be avoided)",
    false)]
generic<typename T>
where T : IOptimizedPersistable
public ref class WeakIOptimizedPersistableReferenceX : public WeakIOptimizedPersistableReferenceBase
[<SerializableAttribute>]
[<ObsoleteAttribute("Use WeakIOptimizedPersistableReference instead (so name conflict can be avoided)",
    false)>]
type WeakIOptimizedPersistableReferenceX<'T when 'T : IOptimizedPersistable> =
    class
        inherit WeakIOptimizedPersistableReferenceBase
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:VelocityDb.WeakIOptimizedPersistableReferenceX`1"]

The WeakIOptimizedPersistableReferenceXT type exposes the following members.

Constructors
 | Name | Description
Public method | WeakIOptimizedPersistableReferenceXT(UInt64) | Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
Public method | WeakIOptimizedPersistableReferenceXT(T) | Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.
Public method | WeakIOptimizedPersistableReferenceXT(Oid) | Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
Top
Properties
 | Name | Description
Public property | Id | Id of weak referenced object (Overrides WeakIOptimizedPersistableReferenceBaseId.)
Public property | ShortId | Short reference ID of weak reference (Overrides WeakIOptimizedPersistableReferenceBaseShortId.)
Top
Methods
 | Name | Description
Public method | GetTarget | Gets the persistent object referenced by the weak reference
Public method | ToString | Append the Oid of the referenced object to the string. (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Constructor

WeakIOptimizedPersistableReferenceXT Constructor

Overload List
 | Name | Description
Public method | WeakIOptimizedPersistableReferenceXT(UInt64) | Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
Public method | WeakIOptimizedPersistableReferenceXT(T) | Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.
Public method | WeakIOptimizedPersistableReferenceXT(Oid) | Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)
Top
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Constructor (UInt64)

WeakIOptimizedPersistableReferenceXT Constructor (UInt64)

Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReferenceX(
    ulong oid
)
Public Sub New (
    oid As ULong
)
public:
WeakIOptimizedPersistableReferenceX(
    unsigned long long oid
)
new :
        oid : uint64 -> WeakIOptimizedPersistableReferenceX

Parameters

oid
Type: SystemUInt64

[Missing <param name="oid"/> documentation for "M:VelocityDb.WeakIOptimizedPersistableReferenceX`1.#ctor(System.UInt64)"]

See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
WeakIOptimizedPersistableReferenceXT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Constructor (T)

WeakIOptimizedPersistableReferenceXT Constructor (T)

Creates a weak reference to some OptimizedPersistable object. This object must be persisted before adding as a weak reference.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReferenceX(
    T obj
)
Public Sub New (
    obj As T
)
public:
WeakIOptimizedPersistableReferenceX(
    T obj
)
new :
        obj : 'T -> WeakIOptimizedPersistableReferenceX

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:VelocityDb.WeakIOptimizedPersistableReferenceX`1.#ctor(`0)"]

See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
WeakIOptimizedPersistableReferenceXT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Constructor (Oid)

WeakIOptimizedPersistableReferenceXT Constructor (Oid)

Creates a weak reference to some OptimizedPersistable object Can be created using Oid.Encode(databaseNumber, pageNumber, pageNumber)

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakIOptimizedPersistableReferenceX(
    Oid oid
)
Public Sub New (
    oid As Oid
)
public:
WeakIOptimizedPersistableReferenceX(
    Oid oid
)
new :
        oid : Oid -> WeakIOptimizedPersistableReferenceX

Parameters

oid
Type: VelocityDbOid

[Missing <param name="oid"/> documentation for "M:VelocityDb.WeakIOptimizedPersistableReferenceX`1.#ctor(VelocityDb.Oid)"]

See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
WeakIOptimizedPersistableReferenceXT Overload
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Properties

WeakIOptimizedPersistableReferenceXT Properties

The WeakIOptimizedPersistableReferenceXT generic type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of weak referenced object (Overrides WeakIOptimizedPersistableReferenceBaseId.)
Public property | ShortId | Short reference ID of weak reference (Overrides WeakIOptimizedPersistableReferenceBaseShortId.)
Top
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T).Id Property

WeakIOptimizedPersistableReferenceXTId Property

Id of weak referenced object

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Id { get; set; }
Public Overrides Property Id As ULong
    Get
    Set
public:
virtual property unsigned long long Id {
    unsigned long long get () override;
    void set (unsigned long long value) override;
}
abstract Id : uint64 with get, set
override Id : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T).ShortId Property

WeakIOptimizedPersistableReferenceXTShortId Property

Short reference ID of weak reference

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint ShortId { get; set; }
Public Overrides Property ShortId As UInteger
    Get
    Set
public:
virtual property unsigned int ShortId {
    unsigned int get () override;
    void set (unsigned int value) override;
}
abstract ShortId : uint32 with get, set
override ShortId : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T) Methods

WeakIOptimizedPersistableReferenceXT Methods

The WeakIOptimizedPersistableReferenceXT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetTarget | Gets the persistent object referenced by the weak reference
Public method | ToString | Append the Oid of the referenced object to the string. (Overrides ObjectToString.)
Top
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T).GetTarget Method

WeakIOptimizedPersistableReferenceXTGetTarget Method

Gets the persistent object referenced by the weak reference

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T GetTarget(
    bool update,
    SessionBase session
)
Public Function GetTarget (
    update As Boolean,
    session As SessionBase
) As T
public:
T GetTarget(
    bool update,
    SessionBase^ session
)
member GetTarget :
        update : bool *
        session : SessionBase -> 'T

Parameters

update
Type: SystemBoolean
Open the persistent object for update?
session
Type: VelocityDb.SessionSessionBase
The session managing the persistent object

Return Value

Type: T
The object referenced by this weak reference
See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


WeakIOptimizedPersistableReferenceX(T).ToString Method

WeakIOptimizedPersistableReferenceXTToString Method

Append the Oid of the referenced object to the string.

Namespace: VelocityDb
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDb.WeakIOptimizedPersistableReferenceX`1.ToString"]

See Also

Reference

WeakIOptimizedPersistableReferenceXT Class
VelocityDb Namespace


VelocityDb.Collection Namespace

The VelocityDb.Collection namespace contains classes for the VelocityDb collections optimized for persistent storage in VelocityDb databases
Classes
 | Class | Description
Public class | SortedMapKey, Value | A sorted map
Public class | SortedMapBaseKey, Value | A base class for sorted maps.
Public class | SortedMapOidShortKey, Value | A sorted map where all keys and values and the map are contained within a single Database
Public class | SortedMapValueOidShortKey, Value | A sorted map where all values are located within a single Database
Public class | SortedSetAnyKey | A sorted set of objects of any Type (not just subclasses of OptimizedPersistable
Public class | SortedSetBaseKey | A base class for sorted sets
Public class | SortedSetOidShortKey | A sorted set where the set and all its elements are contained in a single Database
Public class | VelocityDbHashSetT | A hash code based set
Public class | VelocityDbListT | A list with an Oid containing objects ordered by index.
Public class | VelocityDbListOidShortT | List of objects where list and all elements of a list are contained within a single Database
Public class | WeakReferenceListT | List with an Id containing object Ids ordered by index.
Public class | WeakReferenceListBaseT | List with an Id containing object Ids ordered by index.
Public class | WeakShortReferenceListT | List with an Id containing object short Ids (page and slot) ordered by index.
Structures
 | Structure | Description
Public structure | VelocityDbHashSetTEnumerator | Enumerates the elements of a VelocityDbHashSet(Of T).


SortedMap(Key, Value) Class

SortedMapKey, Value Class

A sorted map
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedMapBase Key, Value
VelocityDb.CollectionSortedMapKey, Value

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortedMap<Key, Value> : SortedMapBase<Key, Value>

<SerializableAttribute>
Public Class SortedMap(Of Key, Value)
    Inherits SortedMapBase(Of Key, Value)
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class SortedMap : public SortedMapBase<Key, Value>
[<SerializableAttribute>]
type SortedMap<'Key, 'Value> =
    class
        inherit SortedMapBase<'Key, 'Value>
    end

Type Parameters

Key
Element key type
Value
Element value type

The SortedMapKey, Value type exposes the following members.

Constructors
 | Name | Description
Public method | SortedMapKey, Value(Int32) | Constructs a new map
Public method | SortedMapKey, Value(VelocityDbComparerKey) | Constructs a new map with a given comparator
Top
Properties
 | Name | Description
Public property | Comparer | Gets the Key comparator of the map (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of NodeKeys (Overrides SortedSetBaseKeyKeys.)
Public property | Values | Gets the internal list of NodeValues (Overrides SortedMapBaseKey, ValueValues.)
Top
Methods
 | Name | Description
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedMap(Key, Value) Constructor

SortedMapKey, Value Constructor

Overload List
 | Name | Description
Public method | SortedMapKey, Value(Int32) | Constructs a new map
Public method | SortedMapKey, Value(VelocityDbComparerKey) | Constructs a new map with a given comparator
Top
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value) Constructor (Int32)

SortedMapKey, Value Constructor (Int32)

Constructs a new map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMap(
    int capacity = 0
)
Public Sub New (
    Optional capacity As Integer = 0
)
public:
SortedMap(
    int capacity = 0
)
new :
        ?capacity : int
(* Defaults:
        let _capacity = defaultArg capacity 0
*)
-> SortedMap

Parameters

capacity (Optional)
Type: SystemInt32
Presizes internal list to a requested size
See Also

Reference

SortedMapKey, Value Class
SortedMapKey, Value Overload
VelocityDb.Collection Namespace


SortedMap(Key, Value) Constructor (VelocityDbComparer(Key))

SortedMapKey, Value Constructor (VelocityDbComparerKey)

Constructs a new map with a given comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMap(
    VelocityDbComparer<Key> comparer
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key)
)
public:
SortedMap(
    VelocityDbComparer<Key>^ comparer
)
new :
        comparer : VelocityDbComparer<'Key> -> SortedMap

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
The comaparator is referenced by a OidShort so it must exist within the same Database as the SortedMap
See Also

Reference

SortedMapKey, Value Class
SortedMapKey, Value Overload
VelocityDb.Collection Namespace


SortedMap(Key, Value) Properties

SortedMapKey, Value Properties

The SortedMapKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the Key comparator of the map (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of NodeKeys (Overrides SortedSetBaseKeyKeys.)
Public property | Values | Gets the internal list of NodeValues (Overrides SortedMapBaseKey, ValueValues.)
Top
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value).Comparer Property

SortedMapKey, ValueComparer Property

Gets the Key comparator of the map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value).Keys Property

SortedMapKey, ValueKeys Property

Gets the internal list of NodeKeys

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Key> Keys { get; }
Public Overrides ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () override;
}
abstract Keys : IList<'Key> with get
override Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value).Values Property

SortedMapKey, ValueValues Property

Gets the internal list of NodeValues

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Value> Values { get; }
Public Overrides ReadOnly Property Values As IList(Of Value)
    Get
public:
virtual property IList<Value>^ Values {
    IList<Value>^ get () override;
}
abstract Values : IList<'Value> with get
override Values : IList<'Value> with get

Property Value

Type: IList Value
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value) Methods

SortedMapKey, Value Methods

The SortedMapKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMap(Key, Value).Persist Method

SortedMapKey, ValuePersist Method

Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
The placement rules to follow when persisting this object
session
Type: VelocityDb.SessionSessionBase
The session managing this object
persistRefs (Optional)
Type: SystemBoolean
If true, objects referenced from this object will also be persisted
disableFlush (Optional)
Type: SystemBoolean
If true, disables possible flushing of updated pages while persisting this object; otherwise page flushing may occur
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A queue of objects remaining to be persisted. Pass as a parameter to session.Persist

Return Value

Type: UInt64
The object id of this persistent object

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

SortedMapKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value) Class

SortedMapBaseKey, Value Class

A base class for sorted maps.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedMapBaseKey, Value
VelocityDb.CollectionSortedMapKey, Value
VelocityDb.CollectionSortedMapOidShortKey, Value
VelocityDb.CollectionSortedMapValueOidShortKey, Value

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class SortedMapBase<Key, Value> : SortedSetBase<Key>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable

<SerializableAttribute>
Public MustInherit Class SortedMapBase(Of Key, Value)
    Inherits SortedSetBase(Of Key)
    Implements IEnumerable(Of KeyValuePair(Of Key, Value)),
    IEnumerable
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class SortedMapBase abstract : public SortedSetBase<Key>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type SortedMapBase<'Key, 'Value> =
    class
        inherit SortedSetBase<'Key>
        interface IEnumerable<KeyValuePair<'Key, 'Value>>
        interface IEnumerable
    end

Type Parameters

Key
A key type for a map
Value
A value type for a map

The SortedMapBaseKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the value associated with a key
Public property | Values | The map values as a list
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairKey, Value) | Add to a map
Public method | Add(Key, Value) | Add to a map
Public method | Clear | Removes all keys and values from the map, leaving the map empty (Overrides SortedSetBaseKeyClear.)
Public method | Contains | Check if map contains a key value pair
Public method | ContainsKey | Checks if map contains a key
Public method | CopyTo | throw new NotImplementedException();
Public method | GetEnumerator |
Public method | isEmpty | Check if map is empty
Public method | Remove(KeyValuePairKey, Value) | Removes a key value pair from the map (if found)
Public method | Remove(Key) | Removes a key from the map (if found) (Overrides SortedSetBaseKeyRemove(Key).)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedMapBase(Key, Value) Properties

SortedMapBaseKey, Value Properties

The SortedMapBaseKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the value associated with a key
Public property | Values | The map values as a list
Top
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Item Property

SortedMapBaseKey, ValueItem Property

Gets or sets the value associated with a key

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Value this[
    Key key
] { get; set; }
Public Default Property Item (
    key As Key
) As Value
    Get
    Set
public:
property Value default[Key key] {
    Value get (Key key);
    void set (Key key, Value value);
}
member Item : 'Value with get, set

Parameters

key
Type: Key
The lookup key

Return Value

Type: Value
The value associated with a key or throws KeyNotFoundException
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Values Property

SortedMapBaseKey, ValueValues Property

The map values as a list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IList<Value> Values { get; }
Public MustOverride ReadOnly Property Values As IList(Of Value)
    Get
public:
virtual property IList<Value>^ Values {
    IList<Value>^ get () abstract;
}
abstract Values : IList<'Value> with get

Property Value

Type: IList Value
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value) Methods

SortedMapBaseKey, Value Methods

The SortedMapBaseKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairKey, Value) | Add to a map
Public method | Add(Key, Value) | Add to a map
Public method | Clear | Removes all keys and values from the map, leaving the map empty (Overrides SortedSetBaseKeyClear.)
Public method | Contains | Check if map contains a key value pair
Public method | ContainsKey | Checks if map contains a key
Public method | CopyTo | throw new NotImplementedException();
Public method | GetEnumerator |
Public method | isEmpty | Check if map is empty
Public method | Remove(KeyValuePairKey, Value) | Removes a key value pair from the map (if found)
Public method | Remove(Key) | Removes a key from the map (if found) (Overrides SortedSetBaseKeyRemove(Key).)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Add Method

SortedMapBaseKey, ValueAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairKey, Value) | Add to a map
Public method | Add(Key, Value) | Add to a map
Top
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Add Method (KeyValuePair(Key, Value))

SortedMapBaseKey, ValueAdd Method (KeyValuePairKey, Value)

Add to a map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    KeyValuePair<Key, Value> keyValue
)
Public Sub Add (
    keyValue As KeyValuePair(Of Key, Value)
)
public:
void Add(
    KeyValuePair<Key, Value> keyValue
)
member Add :
        keyValue : KeyValuePair<'Key, 'Value> -> unit

Parameters

keyValue
Type: System.Collections.GenericKeyValuePair Key, Value
key and value being added
See Also

Reference

SortedMapBaseKey, Value Class
Add Overload
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Add Method (Key, Value)

SortedMapBaseKey, ValueAdd Method (Key, Value)

Add to a map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Key key,
    Value value
)
Public Sub Add (
    key As Key,
    value As Value
)
public:
void Add(
    Key key,
    Value value
)
member Add :
        key : 'Key *
        value : 'Value -> unit

Parameters

key
Type: Key
key added
value
Type: Value
value added
See Also

Reference

SortedMapBaseKey, Value Class
Add Overload
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Clear Method

SortedMapBaseKey, ValueClear Method

Removes all keys and values from the map, leaving the map empty

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Contains Method

SortedMapBaseKey, ValueContains Method

Check if map contains a key value pair

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    KeyValuePair<Key, Value> keyValue
)
Public Function Contains (
    keyValue As KeyValuePair(Of Key, Value)
) As Boolean
public:
bool Contains(
    KeyValuePair<Key, Value> keyValue
)
member Contains :
        keyValue : KeyValuePair<'Key, 'Value> -> bool

Parameters

keyValue
Type: System.Collections.GenericKeyValuePair Key, Value

[Missing <param name="keyValue"/> documentation for "M:VelocityDb.Collection.SortedMapBase`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Type: Boolean
true if map contains the key value pair
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).ContainsKey Method

SortedMapBaseKey, ValueContainsKey Method

Checks if map contains a key

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    Key aKey
)
Public Function ContainsKey (
    aKey As Key
) As Boolean
public:
bool ContainsKey(
    Key aKey
)
member ContainsKey :
        aKey : 'Key -> bool

Parameters

aKey
Type: Key

[Missing <param name="aKey"/> documentation for "M:VelocityDb.Collection.SortedMapBase`2.ContainsKey(`0)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.SortedMapBase`2.ContainsKey(`0)"]

See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).CopyTo Method

SortedMapBaseKey, ValueCopyTo Method

throw new NotImplementedException();

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    KeyValuePair<Key, Value>[] array,
    int index
)
Public Sub CopyTo (
    array As KeyValuePair(Of Key, Value)(),
    index As Integer
)
public:
void CopyTo(
    array<KeyValuePair<Key, Value>>^ array,
    int index
)
member CopyTo :
        array : KeyValuePair<'Key, 'Value>[] *
        index : int -> unit

Parameters

array
Type: System.Collections.GenericKeyValuePair Key, Value
The destination array
index
Type: SystemInt32
The start index
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).GetEnumerator Method

SortedMapBaseKey, ValueGetEnumerator Method

[Missing <summary> documentation for "M:VelocityDb.Collection.SortedMapBase`2.GetEnumerator"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<KeyValuePair<Key, Value>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Key, Value))
public:
virtual IEnumerator<KeyValuePair<Key, Value>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<'Key, 'Value>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<'Key, 'Value>>

Return Value

Type: IEnumerator KeyValuePair Key, Value

[Missing <returns> documentation for "M:VelocityDb.Collection.SortedMapBase`2.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).isEmpty Method

SortedMapBaseKey, ValueisEmpty Method

Check if map is empty

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool isEmpty()
Public Function isEmpty As Boolean
public:
bool isEmpty()
member isEmpty : unit -> bool

Return Value

Type: Boolean
true if map is empty; otherwise false
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Remove Method

SortedMapBaseKey, ValueRemove Method

Overload List
 | Name | Description
Public method | Remove(KeyValuePairKey, Value) | Removes a key value pair from the map (if found)
Public method | Remove(Key) | Removes a key from the map (if found) (Overrides SortedSetBaseKeyRemove(Key).)
Top
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Remove Method (KeyValuePair(Key, Value))

SortedMapBaseKey, ValueRemove Method (KeyValuePairKey, Value)

Removes a key value pair from the map (if found)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    KeyValuePair<Key, Value> keyValue
)
Public Function Remove (
    keyValue As KeyValuePair(Of Key, Value)
) As Boolean
public:
bool Remove(
    KeyValuePair<Key, Value> keyValue
)
member Remove :
        keyValue : KeyValuePair<'Key, 'Value> -> bool

Parameters

keyValue
Type: System.Collections.GenericKeyValuePair Key, Value

[Missing <param name="keyValue"/> documentation for "M:VelocityDb.Collection.SortedMapBase`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Type: Boolean
true if key was found and removed; otherwise false
See Also

Reference

SortedMapBaseKey, Value Class
Remove Overload
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).Remove Method (Key)

SortedMapBaseKey, ValueRemove Method (Key)

Removes a key from the map (if found)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Remove(
    Key key
)
Public Overrides Function Remove (
    key As Key
) As Boolean
public:
virtual bool Remove(
    Key key
) override
abstract Remove :
        key : 'Key -> bool
override Remove :
        key : 'Key -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.SortedMapBase`2.Remove(`0)"]

Return Value

Type: Boolean
true if key was found and removed; otherwise false
See Also

Reference

SortedMapBaseKey, Value Class
Remove Overload
VelocityDb.Collection Namespace


SortedMapBase(Key, Value).TryGetValue Method

SortedMapBaseKey, ValueTryGetValue Method

Gets the value associated with the specified key.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    Key key,
    out Value value
)
Public Function TryGetValue (
    key As Key,
    <OutAttribute> ByRef value As Value
) As Boolean
public:
bool TryGetValue(
    Key key,
    [OutAttribute] Value% value
)
member TryGetValue :
        key : 'Key *
        value : 'Value byref -> bool

Parameters

key
Type: Key
The key of the value to get.
value
Type: Value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the set contains an element with the specified key; otherwise, false.
See Also

Reference

SortedMapBaseKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Class

SortedMapOidShortKey, Value Class

A sorted map where all keys and values and the map are contained within a single Database
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedMapBase Key, Value
VelocityDb.CollectionSortedMapOidShortKey, Value

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortedMapOidShort<Key, Value> : SortedMapBase<Key, Value>
where Key : OptimizedPersistable
where Value : OptimizedPersistable

<SerializableAttribute>
Public Class SortedMapOidShort(Of Key As OptimizedPersistable, Value As OptimizedPersistable)
    Inherits SortedMapBase(Of Key, Value)
[SerializableAttribute]
generic<typename Key, typename Value>
where Key : OptimizedPersistable
where Value : OptimizedPersistable
public ref class SortedMapOidShort : public SortedMapBase<Key, Value>
[<SerializableAttribute>]
type SortedMapOidShort<'Key, 'Value when 'Key : OptimizedPersistable when 'Value : OptimizedPersistable> =
    class
        inherit SortedMapBase<'Key, 'Value>
    end

Type Parameters

Key
The Type of keys of this map
Value
The Type of values of this map

The SortedMapOidShortKey, Value type exposes the following members.

Constructors
 | Name | Description
Public method | SortedMapOidShortKey, Value | Constructs a new empty map
Public method | SortedMapOidShortKey, Value(VelocityDbComparerKey) | Constructs a new empty map with a given object comparator
Top
Properties
 | Name | Description
Public property | Comparer | Gets comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of keys (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | Values | Gets the internal list of values (Overrides SortedMapBaseKey, ValueValues.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Constructor

SortedMapOidShortKey, Value Constructor

Overload List
 | Name | Description
Public method | SortedMapOidShortKey, Value | Constructs a new empty map
Public method | SortedMapOidShortKey, Value(VelocityDbComparerKey) | Constructs a new empty map with a given object comparator
Top
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Constructor

SortedMapOidShortKey, Value Constructor

Constructs a new empty map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMapOidShort()
Public Sub New
public:
SortedMapOidShort()
new : unit -> SortedMapOidShort
See Also

Reference

SortedMapOidShortKey, Value Class
SortedMapOidShortKey, Value Overload
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Constructor (VelocityDbComparer(Key))

SortedMapOidShortKey, Value Constructor (VelocityDbComparerKey)

Constructs a new empty map with a given object comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMapOidShort(
    VelocityDbComparer<Key> comparer
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key)
)
public:
SortedMapOidShort(
    VelocityDbComparer<Key>^ comparer
)
new :
        comparer : VelocityDbComparer<'Key> -> SortedMapOidShort

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
See Also

Reference

SortedMapOidShortKey, Value Class
SortedMapOidShortKey, Value Overload
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Properties

SortedMapOidShortKey, Value Properties

The SortedMapOidShortKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of keys (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | Values | Gets the internal list of values (Overrides SortedMapBaseKey, ValueValues.)
Top
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value).Comparer Property

SortedMapOidShortKey, ValueComparer Property

Gets comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value).Keys Property

SortedMapOidShortKey, ValueKeys Property

Gets the internal list of keys

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Key> Keys { get; }
Public Overrides ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () override;
}
abstract Keys : IList<'Key> with get
override Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value).MaxNumberOfDatabases Property

SortedMapOidShortKey, ValueMaxNumberOfDatabases Property

[Missing <summary> documentation for "P:VelocityDb.Collection.SortedMapOidShort`2.MaxNumberOfDatabases"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value).Values Property

SortedMapOidShortKey, ValueValues Property

Gets the internal list of values

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Value> Values { get; }
Public Overrides ReadOnly Property Values As IList(Of Value)
    Get
public:
virtual property IList<Value>^ Values {
    IList<Value>^ get () override;
}
abstract Values : IList<'Value> with get
override Values : IList<'Value> with get

Property Value

Type: IList Value
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapOidShort(Key, Value) Methods

SortedMapOidShortKey, Value Methods

The SortedMapOidShortKey, Value generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedMapOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Class

SortedMapValueOidShortKey, Value Class

A sorted map where all values are located within a single Database
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedMapBase Key, Value
VelocityDb.CollectionSortedMapValueOidShortKey, Value

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortedMapValueOidShort<Key, Value> : SortedMapBase<Key, Value>
where Value : OptimizedPersistable

<SerializableAttribute>
Public Class SortedMapValueOidShort(Of Key, Value As OptimizedPersistable)
    Inherits SortedMapBase(Of Key, Value)
[SerializableAttribute]
generic<typename Key, typename Value>
where Value : OptimizedPersistable
public ref class SortedMapValueOidShort : public SortedMapBase<Key, Value>
[<SerializableAttribute>]
type SortedMapValueOidShort<'Key, 'Value when 'Value : OptimizedPersistable> =
    class
        inherit SortedMapBase<'Key, 'Value>
    end

Type Parameters

Key
Value

The SortedMapValueOidShortKey, Value type exposes the following members.

Constructors
 | Name | Description
Public method | SortedMapValueOidShortKey, Value | Constructs a new map with OidShort based values
Public method | SortedMapValueOidShortKey, Value(Int32) | Constructs a new map with OidShort based values
Public method | SortedMapValueOidShortKey, Value(VelocityDbComparerKey) | Constructs a new map with a given comparator
Top
Properties
 | Name | Description
Public property | Comparer | Gets the Key comparator of the map (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of NodeKeys (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | Values | Gets the internal list of NodeValues (Overrides SortedMapBaseKey, ValueValues.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Constructor

SortedMapValueOidShortKey, Value Constructor

Overload List
 | Name | Description
Public method | SortedMapValueOidShortKey, Value | Constructs a new map with OidShort based values
Public method | SortedMapValueOidShortKey, Value(Int32) | Constructs a new map with OidShort based values
Public method | SortedMapValueOidShortKey, Value(VelocityDbComparerKey) | Constructs a new map with a given comparator
Top
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Constructor

SortedMapValueOidShortKey, Value Constructor

Constructs a new map with OidShort based values

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMapValueOidShort()
Public Sub New
public:
SortedMapValueOidShort()
new : unit -> SortedMapValueOidShort
See Also

Reference

SortedMapValueOidShortKey, Value Class
SortedMapValueOidShortKey, Value Overload
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Constructor (Int32)

SortedMapValueOidShortKey, Value Constructor (Int32)

Constructs a new map with OidShort based values

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMapValueOidShort(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
SortedMapValueOidShort(
    int capacity
)
new :
        capacity : int -> SortedMapValueOidShort

Parameters

capacity
Type: SystemInt32
Presizes internal list to a requested size
See Also

Reference

SortedMapValueOidShortKey, Value Class
SortedMapValueOidShortKey, Value Overload
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Constructor (VelocityDbComparer(Key))

SortedMapValueOidShortKey, Value Constructor (VelocityDbComparerKey)

Constructs a new map with a given comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedMapValueOidShort(
    VelocityDbComparer<Key> comparer
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key)
)
public:
SortedMapValueOidShort(
    VelocityDbComparer<Key>^ comparer
)
new :
        comparer : VelocityDbComparer<'Key> -> SortedMapValueOidShort

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
See Also

Reference

SortedMapValueOidShortKey, Value Class
SortedMapValueOidShortKey, Value Overload
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Properties

SortedMapValueOidShortKey, Value Properties

The SortedMapValueOidShortKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the Key comparator of the map (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal list of NodeKeys (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | Values | Gets the internal list of NodeValues (Overrides SortedMapBaseKey, ValueValues.)
Top
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value).Comparer Property

SortedMapValueOidShortKey, ValueComparer Property

Gets the Key comparator of the map

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value).Keys Property

SortedMapValueOidShortKey, ValueKeys Property

Gets the internal list of NodeKeys

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Key> Keys { get; }
Public Overrides ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () override;
}
abstract Keys : IList<'Key> with get
override Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value).MaxNumberOfDatabases Property

SortedMapValueOidShortKey, ValueMaxNumberOfDatabases Property

[Missing <summary> documentation for "P:VelocityDb.Collection.SortedMapValueOidShort`2.MaxNumberOfDatabases"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value).Values Property

SortedMapValueOidShortKey, ValueValues Property

Gets the internal list of NodeValues

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Value> Values { get; }
Public Overrides ReadOnly Property Values As IList(Of Value)
    Get
public:
virtual property IList<Value>^ Values {
    IList<Value>^ get () override;
}
abstract Values : IList<'Value> with get
override Values : IList<'Value> with get

Property Value

Type: IList Value
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedMapValueOidShort(Key, Value) Methods

SortedMapValueOidShortKey, Value Methods

The SortedMapValueOidShortKey, Value generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedMapValueOidShortKey, Value Class
VelocityDb.Collection Namespace


SortedSetAny(Key) Class

SortedSetAnyKey Class

A sorted set of objects of any Type (not just subclasses of OptimizedPersistable
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedSetAnyKey

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortedSetAny<Key> : SortedSetBase<Key>,
    ISet<Key>, ICollection<Key>, IEnumerable<Key>, IEnumerable

<SerializableAttribute>
Public Class SortedSetAny(Of Key)
    Inherits SortedSetBase(Of Key)
    Implements ISet(Of Key), ICollection(Of Key),
    IEnumerable(Of Key), IEnumerable
[SerializableAttribute]
generic<typename Key>
public ref class SortedSetAny : public SortedSetBase<Key>,
    ISet<Key>, ICollection<Key>, IEnumerable<Key>, IEnumerable
[<SerializableAttribute>]
type SortedSetAny<'Key> =
    class
        inherit SortedSetBase<'Key>
        interface ISet<'Key>
        interface ICollection<'Key>
        interface IEnumerable<'Key>
        interface IEnumerable
    end

Type Parameters

Key
The type of element for this list.

The SortedSetAnyKey type exposes the following members.

Constructors
 | Name | Description
Public method | SortedSetAnyKey | Constructs the set
Public method | SortedSetAnyKey(Int32) | Constructs a set with a given initial capacity
Public method | SortedSetAnyKey(VelocityDbComparerKey) | Constructs a set with a given object comparator
Top
Properties
 | Name | Description
Public property | Comparer | Gets the set comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal Key list of the set (Overrides SortedSetBaseKeyKeys.)
Top
Methods
 | Name | Description
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedSetAny(Key) Constructor

SortedSetAnyKey Constructor

Overload List
 | Name | Description
Public method | SortedSetAnyKey | Constructs the set
Public method | SortedSetAnyKey(Int32) | Constructs a set with a given initial capacity
Public method | SortedSetAnyKey(VelocityDbComparerKey) | Constructs a set with a given object comparator
Top
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetAny(Key) Constructor

SortedSetAnyKey Constructor

Constructs the set

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetAny()
Public Sub New
public:
SortedSetAny()
new : unit -> SortedSetAny
See Also

Reference

SortedSetAnyKey Class
SortedSetAnyKey Overload
VelocityDb.Collection Namespace


SortedSetAny(Key) Constructor (Int32)

SortedSetAnyKey Constructor (Int32)

Constructs a set with a given initial capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetAny(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
SortedSetAny(
    int capacity
)
new :
        capacity : int -> SortedSetAny

Parameters

capacity
Type: SystemInt32
See Also

Reference

SortedSetAnyKey Class
SortedSetAnyKey Overload
VelocityDb.Collection Namespace


SortedSetAny(Key) Constructor (VelocityDbComparer(Key))

SortedSetAnyKey Constructor (VelocityDbComparerKey)

Constructs a set with a given object comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetAny(
    VelocityDbComparer<Key> comparer
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key)
)
public:
SortedSetAny(
    VelocityDbComparer<Key>^ comparer
)
new :
        comparer : VelocityDbComparer<'Key> -> SortedSetAny

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
A comparator of Key objects
See Also

Reference

SortedSetAnyKey Class
SortedSetAnyKey Overload
VelocityDb.Collection Namespace


SortedSetAny(Key) Properties

SortedSetAnyKey Properties

The SortedSetAnyKey generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the set comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal Key list of the set (Overrides SortedSetBaseKeyKeys.)
Top
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetAny(Key).Comparer Property

SortedSetAnyKeyComparer Property

Gets the set comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetAny(Key).Keys Property

SortedSetAnyKeyKeys Property

Gets the internal Key list of the set

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Key> Keys { get; }
Public Overrides ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () override;
}
abstract Keys : IList<'Key> with get
override Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetAny(Key) Methods

SortedSetAnyKey Methods

The SortedSetAnyKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetAny(Key).Persist Method

SortedSetAnyKeyPersist Method

[Missing <summary> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement

[Missing <param name="place"/> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

persistRefs (Optional)
Type: SystemBoolean

[Missing <param name="persistRefs"/> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

disableFlush (Optional)
Type: SystemBoolean

[Missing <param name="disableFlush"/> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable

[Missing <param name="toPersist"/> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDb.Collection.SortedSetAny`1.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

SortedSetAnyKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key) Class

SortedSetBaseKey Class

A base class for sorted sets
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBaseKey
VelocityDb.CollectionSortedMapBaseKey, Value
VelocityDb.CollectionSortedSetAnyKey
VelocityDb.CollectionSortedSetOidShortKey

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class SortedSetBase<Key> : OptimizedPersistable,
    IEnumerable<Key>, IEnumerable

<SerializableAttribute>
Public MustInherit Class SortedSetBase(Of Key)
    Inherits OptimizedPersistable
    Implements IEnumerable(Of Key), IEnumerable
[SerializableAttribute]
generic<typename Key>
public ref class SortedSetBase abstract : public OptimizedPersistable,
    IEnumerable<Key>, IEnumerable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type SortedSetBase<'Key> =
    class
        inherit OptimizedPersistable
        interface IEnumerable<'Key>
        interface IEnumerable
    end

Type Parameters

Key
A key type for a set.

The SortedSetBaseKey type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IComparer that is used to determine the order of the items in the sorted set
Public property | Count | Number of elements in this SortedSetBase
Public property | IsEmpty | Returns true if 0 elements are in the set.
Public property | IsReadOnly | Returns false
Public property | Item | Given a lookup key, returns the corresponding key within the collection or null if not found
Public property | Keys | Gets the internal list of NodeKeys
Top
Methods
 | Name | Description
Public method | Add | Add item to this sorted set.
Public method | Clear | Remove all items from this set.
Public method | Contains | Checks if this sorted set contains the item
Public method | CopyTo | Copy items in this sorted set to array, starting at arrayIndex
Public method | IndexOf | Get the index of a given key
Public method | Remove | Remove item from this set
Public method | RemoveWhere | Remove elements that match specified predicate. Returns the number of elements removed
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedSetBase(Key) Properties

SortedSetBaseKey Properties

The SortedSetBaseKey generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IComparer that is used to determine the order of the items in the sorted set
Public property | Count | Number of elements in this SortedSetBase
Public property | IsEmpty | Returns true if 0 elements are in the set.
Public property | IsReadOnly | Returns false
Public property | Item | Given a lookup key, returns the corresponding key within the collection or null if not found
Public property | Keys | Gets the internal list of NodeKeys
Top
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Comparer Property

SortedSetBaseKeyComparer Property

Gets the IComparer that is used to determine the order of the items in the sorted set

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract VelocityDbComparer<Key> Comparer { get; }
Public MustOverride ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () abstract;
}
abstract Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Count Property

SortedSetBaseKeyCount Property

Number of elements in this SortedSetBase

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).IsEmpty Property

SortedSetBaseKeyIsEmpty Property

Returns true if 0 elements are in the set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).IsReadOnly Property

SortedSetBaseKeyIsReadOnly Property

Returns false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Item Property

SortedSetBaseKeyItem Property

Given a lookup key, returns the corresponding key within the collection or null if not found

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key this[
    Key key
] { get; set; }
Public Default Property Item (
    key As Key
) As Key
    Get
    Set
public:
property Key default[Key key] {
    Key get (Key key);
    void set (Key key, Key value);
}
member Item : 'Key with get, set

Parameters

key
Type: Key
The lookup key

Return Value

Type: Key
The key matching the lookup key or null if not found
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Keys Property

SortedSetBaseKeyKeys Property

Gets the internal list of NodeKeys

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IList<Key> Keys { get; }
Public MustOverride ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () abstract;
}
abstract Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key) Methods

SortedSetBaseKey Methods

The SortedSetBaseKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to this sorted set.
Public method | Clear | Remove all items from this set.
Public method | Contains | Checks if this sorted set contains the item
Public method | CopyTo | Copy items in this sorted set to array, starting at arrayIndex
Public method | IndexOf | Get the index of a given key
Public method | Remove | Remove item from this set
Public method | RemoveWhere | Remove elements that match specified predicate. Returns the number of elements removed
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Add Method

SortedSetBaseKeyAdd Method

Add item to this sorted set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    Key key
)
Public Function Add (
    key As Key
) As Boolean
public:
virtual bool Add(
    Key key
) sealed
abstract Add :
        key : 'Key -> bool
override Add :
        key : 'Key -> bool

Parameters

key
Type: Key
item to add

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.SortedSetBase`1.Add(`0)"]

See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Clear Method

SortedSetBaseKeyClear Method

Remove all items from this set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Contains Method

SortedSetBaseKeyContains Method

Checks if this sorted set contains the item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Key aKey
)
Public Function Contains (
    aKey As Key
) As Boolean
public:
virtual bool Contains(
    Key aKey
) sealed
abstract Contains :
        aKey : 'Key -> bool
override Contains :
        aKey : 'Key -> bool

Parameters

aKey
Type: Key
item to check for containment

Return Value

Type: Boolean
true if item contained; false if not
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).CopyTo Method

SortedSetBaseKeyCopyTo Method

Copy items in this sorted set to array, starting at arrayIndex

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    Key[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    array As Key(),
    arrayIndex As Integer,
    count As Integer
)
public:
void CopyTo(
    array<Key>^ array,
    int arrayIndex,
    int count
)
member CopyTo :
        array : 'Key[] *
        arrayIndex : int *
        count : int -> unit

Parameters

array
Type: Key
array to add items to
arrayIndex
Type: SystemInt32
index to start at
count
Type: SystemInt32
number of elements to copy
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).IndexOf Method

SortedSetBaseKeyIndexOf Method

Get the index of a given key

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    Key aKey
)
Public Function IndexOf (
    aKey As Key
) As Integer
public:
int IndexOf(
    Key aKey
)
member IndexOf :
        aKey : 'Key -> int

Parameters

aKey
Type: Key
The lookup key

Return Value

Type: Int32
The index of key or -1 if a matching key was not found.
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).Remove Method

SortedSetBaseKeyRemove Method

Remove item from this set

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Remove(
    Key key
)
Public Overridable Function Remove (
    key As Key
) As Boolean
public:
virtual bool Remove(
    Key key
)
abstract Remove :
        key : 'Key -> bool
override Remove :
        key : 'Key -> bool

Parameters

key
Type: Key
item to remove

Return Value

Type: Boolean
true if removed; false if not (i.e. if the item wasn't in the SortedSetBase)
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).RemoveWhere Method

SortedSetBaseKeyRemoveWhere Method

Remove elements that match specified predicate. Returns the number of elements removed

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int RemoveWhere(
    Predicate<Key> match
)
Public Function RemoveWhere (
    match As Predicate(Of Key)
) As Integer
public:
int RemoveWhere(
    Predicate<Key>^ match
)
member RemoveWhere :
        match : Predicate<'Key> -> int

Parameters

match
Type: SystemPredicate Key

[Missing <param name="match"/> documentation for "M:VelocityDb.Collection.SortedSetBase`1.RemoveWhere(System.Predicate{`0})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Collection.SortedSetBase`1.RemoveWhere(System.Predicate{`0})"]

See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetBase(Key).TryGetValue Method

SortedSetBaseKeyTryGetValue Method

Gets the value associated with the specified key.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    Key key,
    ref Key value
)
Public Function TryGetValue (
    key As Key,
    ByRef value As Key
) As Boolean
public:
bool TryGetValue(
    Key key,
    Key% value
)
member TryGetValue :
        key : 'Key *
        value : 'Key byref -> bool

Parameters

key
Type: Key
The key of the value to get.
value
Type: Key
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the set contains an element with the specified key; otherwise, false.
See Also

Reference

SortedSetBaseKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Class

SortedSetOidShortKey Class

A sorted set where the set and all its elements are contained in a single Database
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionSortedSetBase Key
VelocityDb.CollectionSortedSetOidShortKey

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortedSetOidShort<Key> : SortedSetBase<Key>
where Key : OptimizedPersistable

<SerializableAttribute>
Public Class SortedSetOidShort(Of Key As OptimizedPersistable)
    Inherits SortedSetBase(Of Key)
[SerializableAttribute]
generic<typename Key>
where Key : OptimizedPersistable
public ref class SortedSetOidShort : public SortedSetBase<Key>
[<SerializableAttribute>]
type SortedSetOidShort<'Key when 'Key : OptimizedPersistable> =
    class
        inherit SortedSetBase<'Key>
    end

Type Parameters

Key
The type of elements in the set.

The SortedSetOidShortKey type exposes the following members.

Constructors
 | Name | Description
Public method | SortedSetOidShortKey | Constructs an OidShort based sorted set.
Public method | SortedSetOidShortKey(Int32) | Constructs an OidShort based sorted set with an initial presized capacity
Public method | SortedSetOidShortKey(VelocityDbComparerKey) | Constructs a new sorted set with a given object comparator.
Top
Properties
 | Name | Description
Public property | Comparer | Gets the object comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal sorted list of objects contained in the set. (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


SortedSetOidShort(Key) Constructor

SortedSetOidShortKey Constructor

Overload List
 | Name | Description
Public method | SortedSetOidShortKey | Constructs an OidShort based sorted set.
Public method | SortedSetOidShortKey(Int32) | Constructs an OidShort based sorted set with an initial presized capacity
Public method | SortedSetOidShortKey(VelocityDbComparerKey) | Constructs a new sorted set with a given object comparator.
Top
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Constructor

SortedSetOidShortKey Constructor

Constructs an OidShort based sorted set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetOidShort()
Public Sub New
public:
SortedSetOidShort()
new : unit -> SortedSetOidShort
See Also

Reference

SortedSetOidShortKey Class
SortedSetOidShortKey Overload
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Constructor (Int32)

SortedSetOidShortKey Constructor (Int32)

Constructs an OidShort based sorted set with an initial presized capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetOidShort(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
SortedSetOidShort(
    int capacity
)
new :
        capacity : int -> SortedSetOidShort

Parameters

capacity
Type: SystemInt32
See Also

Reference

SortedSetOidShortKey Class
SortedSetOidShortKey Overload
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Constructor (VelocityDbComparer(Key))

SortedSetOidShortKey Constructor (VelocityDbComparerKey)

Constructs a new sorted set with a given object comparator.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SortedSetOidShort(
    VelocityDbComparer<Key> comparer
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key)
)
public:
SortedSetOidShort(
    VelocityDbComparer<Key>^ comparer
)
new :
        comparer : VelocityDbComparer<'Key> -> SortedSetOidShort

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
See Also

Reference

SortedSetOidShortKey Class
SortedSetOidShortKey Overload
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Properties

SortedSetOidShortKey Properties

The SortedSetOidShortKey generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the object comparator (Overrides SortedSetBaseKeyComparer.)
Public property | Keys | Gets the internal sorted list of objects contained in the set. (Overrides SortedSetBaseKeyKeys.)
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Top
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key).Comparer Property

SortedSetOidShortKeyComparer Property

Gets the object comparator

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key).Keys Property

SortedSetOidShortKeyKeys Property

Gets the internal sorted list of objects contained in the set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Key> Keys { get; }
Public Overrides ReadOnly Property Keys As IList(Of Key)
    Get
public:
virtual property IList<Key>^ Keys {
    IList<Key>^ get () override;
}
abstract Keys : IList<'Key> with get
override Keys : IList<'Key> with get

Property Value

Type: IList Key
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key).MaxNumberOfDatabases Property

SortedSetOidShortKeyMaxNumberOfDatabases Property

[Missing <summary> documentation for "P:VelocityDb.Collection.SortedSetOidShort`1.MaxNumberOfDatabases"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


SortedSetOidShort(Key) Methods

SortedSetOidShortKey Methods

The SortedSetOidShortKey generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SortedSetOidShortKey Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Class

VelocityDbHashSetT Class

A hash code based set
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionVelocityDbHashSetT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VelocityDbHashSet<T> : OptimizedPersistable,
    ICollection<T>, IEnumerable<T>, IEnumerable

<SerializableAttribute>
Public Class VelocityDbHashSet(Of T)
    Inherits OptimizedPersistable
    Implements ICollection(Of T), IEnumerable(Of T),
    IEnumerable
[SerializableAttribute]
generic<typename T>
public ref class VelocityDbHashSet : public OptimizedPersistable,
    ICollection<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type VelocityDbHashSet<'T> =
    class
        inherit OptimizedPersistable
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The object type of objects in the hashset

The VelocityDbHashSetT type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityDbHashSetT | Creates a hashset using a default equality comparer
Public method | VelocityDbHashSetT(IEnumerableT) | Creates a new hashset using the default equlaity comparer
Public method | VelocityDbHashSetT(IEqualityComparerT) | Creates hashset with a given equality comparer
Public method | VelocityDbHashSetT(IEnumerableT, IEqualityComparerT) | Implementation Notes: Since resizes are relatively expensive (require rehashing), this attempts to minimize the need to resize by setting the initial capacity based on size of collection.
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparer that is used to determine equality of keys for the VelocityDbHashSet.
Public property | Count | Number of elements in this hashset
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
Methods
 | Name | Description
Public method | Add | Add item to this VelocityDbHashSet. Returns bool indicating whether item was added (won't be added if already present)
Public method | Clear | Remove all items from this set. This clears the elements but not the underlying buckets and slots array. Follow this call by TrimExcess to release these.
Public method | Contains | Checks if this hashset contains the item
Public method | CopyTo(T) | Copies the entire List to a compatible one-dimensional array, starting at the beginning of the target array.
Public method | CopyTo(T, Int32) | Copy items in this hashset to array, starting at arrayIndex
Public method | CopyTo(T, Int32, Int32) | Copies a range of elements from the List(Of T) to a compatible one-dimensional array, starting at the specified index of the target array.
 | CreateSetComparer | Used for deep equality of VelocityDbHashSet testing
Public method | ExceptWith | Remove items in other from this set. Modifies this set.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection
Public method | GetObjectData | Serialization usage other than VelocityDb serialization
Public method | IntersectWith | Takes the intersection of this set with other. Modifies this set. Implementation Notes: We get better perf if other is a hashset using same equality comparer, because we get constant contains check in other. Resulting cost is O(n1) to iterate over this. If we can't go above route, iterate over the other and mark intersection by checking contains in this. Then loop over and delete any unmarked elements. Total cost is n2+n1. Attempts to return early based on counts alone, using the property that the intersection of anything with the empty set is the empty set.
Public method | IsProperSubsetOf | Checks if this is a proper subset of other (i.e. strictly contained in) Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a proper subset of a set that contains at least one element, but it's not a proper subset of the empty set. 2. If other has unique elements according to this equality comparer, and this has >= the number of elements in other, then this can't be a proper subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.
Public method | IsProperSupersetOf | Checks if this is a proper superset of other (i.e. other strictly contained in this) Implementation Notes: This is slightly more complicated than above because we have to keep track if there was at least one element not contained in other. The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it can't be a proper superset of any set, even if other is the empty set. 2. If other is an empty set and this contains at least 1 element, then this is a proper superset. 3. If other has unique elements according to this equality comparer, and other's count is greater than or equal to this count, then this can't be a proper superset Furthermore, if other has unique elements according to this equality comparer, we can use a faster element-wise check.
Public method | IsSubsetOf | Checks if this is a subset of other. Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a subset of anything, including the empty set 2. If other has unique elements according to this equality comparer, and this has more elements than other, then it can't be a subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.
Public method | IsSupersetOf | Checks if this is a superset of other Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If other has no elements (it's the empty set), then this is a superset, even if this is also the empty set. 2. If other has unique elements according to this equality comparer, and this has less than the number of elements in other, then this can't be a superset
Public method | Overlaps | Checks if this set overlaps other (i.e. they share at least one item)
Public method | Remove | Remove item from this hashset
Public method | RemoveWhere | Remove elements that match specified predicate. Returns the number of elements removed
Public method | SetEquals | Checks if this and other contain the same elements. This is set equality: duplicates and order are ignored
Public method | SymmetricExceptWith | Takes symmetric difference (XOR) with other and this set. Modifies this set.
Public method | TrimExcess | Sets the capacity of this list to the size of the list (rounded up to nearest prime), unless count is 0, in which case we release references. This method can be used to minimize a list's memory overhead once it is known that no new elements will be added to the list. To completely clear a list and release all memory referenced by the list, execute the following statements: list.Clear(); list.TrimExcess();
Public method | UnionWith | Take the union of this VelocityDbHashSet with other. Modifies this set. Implementation note: GetSuggestedCapacity (to increase capacity in advance avoiding multiple resizes ended up not being useful in practice; quickly gets to the point where it's a wasteful check.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


VelocityDbHashSet(T) Constructor

VelocityDbHashSetT Constructor

Overload List
 | Name | Description
Public method | VelocityDbHashSetT | Creates a hashset using a default equality comparer
Public method | VelocityDbHashSetT(IEnumerableT) | Creates a new hashset using the default equlaity comparer
Public method | VelocityDbHashSetT(IEqualityComparerT) | Creates hashset with a given equality comparer
Public method | VelocityDbHashSetT(IEnumerableT, IEqualityComparerT) | Implementation Notes: Since resizes are relatively expensive (require rehashing), this attempts to minimize the need to resize by setting the initial capacity based on size of collection.
Top
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Constructor

VelocityDbHashSetT Constructor

Creates a hashset using a default equality comparer

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbHashSet()
Public Sub New
public:
VelocityDbHashSet()
new : unit -> VelocityDbHashSet
See Also

Reference

VelocityDbHashSetT Class
VelocityDbHashSetT Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Constructor (IEnumerable(T))

VelocityDbHashSetT Constructor (IEnumerableT)

Creates a new hashset using the default equlaity comparer

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbHashSet(
    IEnumerable<T> collection
)
Public Sub New (
    collection As IEnumerable(Of T)
)
public:
VelocityDbHashSet(
    IEnumerable<T>^ collection
)
new :
        collection : IEnumerable<'T> -> VelocityDbHashSet

Parameters

collection
Type: System.Collections.GenericIEnumerable T
Initial objects added to the hashset
See Also

Reference

VelocityDbHashSetT Class
VelocityDbHashSetT Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Constructor (IEqualityComparer(T))

VelocityDbHashSetT Constructor (IEqualityComparerT)

Creates hashset with a given equality comparer

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbHashSet(
    IEqualityComparer<T> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of T)
)
public:
VelocityDbHashSet(
    IEqualityComparer<T>^ comparer
)
new :
        comparer : IEqualityComparer<'T> -> VelocityDbHashSet

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer T

[Missing <param name="comparer"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.#ctor(System.Collections.Generic.IEqualityComparer{`0})"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDbHashSetT Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Constructor (IEnumerable(T), IEqualityComparer(T))

VelocityDbHashSetT Constructor (IEnumerableT, IEqualityComparerT)

Implementation Notes: Since resizes are relatively expensive (require rehashing), this attempts to minimize the need to resize by setting the initial capacity based on size of collection.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbHashSet(
    IEnumerable<T> collection,
    IEqualityComparer<T> comparer
)
Public Sub New (
    collection As IEnumerable(Of T),
    comparer As IEqualityComparer(Of T)
)
public:
VelocityDbHashSet(
    IEnumerable<T>^ collection,
    IEqualityComparer<T>^ comparer
)
new :
        collection : IEnumerable<'T> *
        comparer : IEqualityComparer<'T> -> VelocityDbHashSet

Parameters

collection
Type: System.Collections.GenericIEnumerable T

[Missing <param name="collection"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.#ctor(System.Collections.Generic.IEnumerable{`0},System.Collections.Generic.IEqualityComparer{`0})"]

comparer
Type: System.Collections.GenericIEqualityComparer T

[Missing <param name="comparer"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.#ctor(System.Collections.Generic.IEnumerable{`0},System.Collections.Generic.IEqualityComparer{`0})"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDbHashSetT Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Properties

VelocityDbHashSetT Properties

The VelocityDbHashSetT generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparer that is used to determine equality of keys for the VelocityDbHashSet.
Public property | Count | Number of elements in this hashset
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Comparer Property

VelocityDbHashSetTComparer Property

Gets the IEqualityComparer that is used to determine equality of keys for the VelocityDbHashSet.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEqualityComparer<T> Comparer { get; }
Public ReadOnly Property Comparer As IEqualityComparer(Of T)
    Get
public:
property IEqualityComparer<T>^ Comparer {
    IEqualityComparer<T>^ get ();
}
member Comparer : IEqualityComparer<'T> with get

Property Value

Type: IEqualityComparer T
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Count Property

VelocityDbHashSetTCount Property

Number of elements in this hashset

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).ObjectsPerPage Property

VelocityDbHashSetTObjectsPerPage Property

Limit to 1000 per page (instead of default 40000)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T) Methods

VelocityDbHashSetT Methods

The VelocityDbHashSetT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to this VelocityDbHashSet. Returns bool indicating whether item was added (won't be added if already present)
Public method | Clear | Remove all items from this set. This clears the elements but not the underlying buckets and slots array. Follow this call by TrimExcess to release these.
Public method | Contains | Checks if this hashset contains the item
Public method | CopyTo(T) | Copies the entire List to a compatible one-dimensional array, starting at the beginning of the target array.
Public method | CopyTo(T, Int32) | Copy items in this hashset to array, starting at arrayIndex
Public method | CopyTo(T, Int32, Int32) | Copies a range of elements from the List(Of T) to a compatible one-dimensional array, starting at the specified index of the target array.
 | CreateSetComparer | Used for deep equality of VelocityDbHashSet testing
Public method | ExceptWith | Remove items in other from this set. Modifies this set.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection
Public method | GetObjectData | Serialization usage other than VelocityDb serialization
Public method | IntersectWith | Takes the intersection of this set with other. Modifies this set. Implementation Notes: We get better perf if other is a hashset using same equality comparer, because we get constant contains check in other. Resulting cost is O(n1) to iterate over this. If we can't go above route, iterate over the other and mark intersection by checking contains in this. Then loop over and delete any unmarked elements. Total cost is n2+n1. Attempts to return early based on counts alone, using the property that the intersection of anything with the empty set is the empty set.
Public method | IsProperSubsetOf | Checks if this is a proper subset of other (i.e. strictly contained in) Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a proper subset of a set that contains at least one element, but it's not a proper subset of the empty set. 2. If other has unique elements according to this equality comparer, and this has >= the number of elements in other, then this can't be a proper subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.
Public method | IsProperSupersetOf | Checks if this is a proper superset of other (i.e. other strictly contained in this) Implementation Notes: This is slightly more complicated than above because we have to keep track if there was at least one element not contained in other. The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it can't be a proper superset of any set, even if other is the empty set. 2. If other is an empty set and this contains at least 1 element, then this is a proper superset. 3. If other has unique elements according to this equality comparer, and other's count is greater than or equal to this count, then this can't be a proper superset Furthermore, if other has unique elements according to this equality comparer, we can use a faster element-wise check.
Public method | IsSubsetOf | Checks if this is a subset of other. Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a subset of anything, including the empty set 2. If other has unique elements according to this equality comparer, and this has more elements than other, then it can't be a subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.
Public method | IsSupersetOf | Checks if this is a superset of other Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If other has no elements (it's the empty set), then this is a superset, even if this is also the empty set. 2. If other has unique elements according to this equality comparer, and this has less than the number of elements in other, then this can't be a superset
Public method | Overlaps | Checks if this set overlaps other (i.e. they share at least one item)
Public method | Remove | Remove item from this hashset
Public method | RemoveWhere | Remove elements that match specified predicate. Returns the number of elements removed
Public method | SetEquals | Checks if this and other contain the same elements. This is set equality: duplicates and order are ignored
Public method | SymmetricExceptWith | Takes symmetric difference (XOR) with other and this set. Modifies this set.
Public method | TrimExcess | Sets the capacity of this list to the size of the list (rounded up to nearest prime), unless count is 0, in which case we release references. This method can be used to minimize a list's memory overhead once it is known that no new elements will be added to the list. To completely clear a list and release all memory referenced by the list, execute the following statements: list.Clear(); list.TrimExcess();
Public method | UnionWith | Take the union of this VelocityDbHashSet with other. Modifies this set. Implementation note: GetSuggestedCapacity (to increase capacity in advance avoiding multiple resizes ended up not being useful in practice; quickly gets to the point where it's a wasteful check.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Add Method

VelocityDbHashSetTAdd Method

Add item to this VelocityDbHashSet. Returns bool indicating whether item was added (won't be added if already present)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    T item
)
Public Function Add (
    item As T
) As Boolean
public:
bool Add(
    T item
)
member Add :
        item : 'T -> bool

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.Add(`0)"]

Return Value

Type: Boolean
true if added, false if already present
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Clear Method

VelocityDbHashSetTClear Method

Remove all items from this set. This clears the elements but not the underlying buckets and slots array. Follow this call by TrimExcess to release these.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Contains Method

VelocityDbHashSetTContains Method

Checks if this hashset contains the item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
public:
virtual bool Contains(
    T item
) sealed
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool

Parameters

item
Type: T
item to check for containment

Return Value

Type: Boolean
true if item contained; false if not

Implements

ICollectionTContains(T)
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).CopyTo Method

VelocityDbHashSetTCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(T) | Copies the entire List to a compatible one-dimensional array, starting at the beginning of the target array.
Public method | CopyTo(T, Int32) | Copy items in this hashset to array, starting at arrayIndex
Public method | CopyTo(T, Int32, Int32) | Copies a range of elements from the List(Of T) to a compatible one-dimensional array, starting at the specified index of the target array.
Top
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).CopyTo Method (T[])

VelocityDbHashSetTCopyTo Method (T)

Copies the entire List to a compatible one-dimensional array, starting at the beginning of the target array.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    T[] array
)
Public Sub CopyTo (
    array As T()
)
public:
void CopyTo(
    array<T>^ array
)
member CopyTo :
        array : 'T[] -> unit

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from List. The Array must have zero-based indexing.
See Also

Reference

VelocityDbHashSetT Class
CopyTo Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T).CopyTo Method (T[], Int32)

VelocityDbHashSetTCopyTo Method (T, Int32)

Copy items in this hashset to array, starting at arrayIndex

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit

Parameters

array
Type: T
array to add items to
arrayIndex
Type: SystemInt32
index to start at

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

VelocityDbHashSetT Class
CopyTo Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T).CopyTo Method (T[], Int32, Int32)

VelocityDbHashSetTCopyTo Method (T, Int32, Int32)

Copies a range of elements from the List(Of T) to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    T[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer,
    count As Integer
)
public:
void CopyTo(
    array<T>^ array,
    int arrayIndex,
    int count
)
member CopyTo :
        array : 'T[] *
        arrayIndex : int *
        count : int -> unit

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from List(Of T). The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in the source List(Of T) at which copying begins.
count
Type: SystemInt32
The number of elements to copy.
See Also

Reference

VelocityDbHashSetT Class
CopyTo Overload
VelocityDb.Collection Namespace


VelocityDbHashSet(T).CreateSetComparer Method

VelocityDbHashSetTCreateSetComparer Method

Used for deep equality of VelocityDbHashSet testing

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEqualityComparer<VelocityDbHashSet<T>> CreateSetComparer()
Public Shared Function CreateSetComparer As IEqualityComparer(Of VelocityDbHashSet(Of T))
public:
static IEqualityComparer<VelocityDbHashSet<T>^>^ CreateSetComparer()
static member CreateSetComparer : unit -> IEqualityComparer<VelocityDbHashSet<'T>>

Return Value

Type: IEqualityComparer VelocityDbHashSet T

[Missing <returns> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.CreateSetComparer"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).ExceptWith Method

VelocityDbHashSetTExceptWith Method

Remove items in other from this set. Modifies this set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExceptWith(
    IEnumerable<T> other
)
Public Sub ExceptWith (
    other As IEnumerable(Of T)
)
public:
void ExceptWith(
    IEnumerable<T>^ other
)
member ExceptWith :
        other : IEnumerable<'T> -> unit

Parameters

other
Type: System.Collections.GenericIEnumerable T
enumerable with items to remove
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).GetEnumerator Method

VelocityDbHashSetTGetEnumerator Method

Returns an enumerator that iterates through a collection

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbHashSetTEnumerator GetEnumerator()
Public Function GetEnumerator As VelocityDbHashSetTEnumerator
public:
VelocityDbHashSetTEnumerator GetEnumerator()
member GetEnumerator : unit -> VelocityDbHashSetTEnumerator

Return Value

Type: VelocityDbHashSetTEnumerator
An Enumerator object that can be used to iterate through the collection.
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).GetObjectData Method

VelocityDbHashSetTGetObjectData Method

Serialization usage other than VelocityDb serialization

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

[Missing <param name="info"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.SerializationStreamingContext

[Missing <param name="context"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).IntersectWith Method

VelocityDbHashSetTIntersectWith Method

Takes the intersection of this set with other. Modifies this set. Implementation Notes: We get better perf if other is a hashset using same equality comparer, because we get constant contains check in other. Resulting cost is O(n1) to iterate over this. If we can't go above route, iterate over the other and mark intersection by checking contains in this. Then loop over and delete any unmarked elements. Total cost is n2+n1. Attempts to return early based on counts alone, using the property that the intersection of anything with the empty set is the empty set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void IntersectWith(
    IEnumerable<T> other
)
Public Sub IntersectWith (
    other As IEnumerable(Of T)
)
public:
void IntersectWith(
    IEnumerable<T>^ other
)
member IntersectWith :
        other : IEnumerable<'T> -> unit

Parameters

other
Type: System.Collections.GenericIEnumerable T
enumerable with items to add
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).IsProperSubsetOf Method

VelocityDbHashSetTIsProperSubsetOf Method

Checks if this is a proper subset of other (i.e. strictly contained in) Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a proper subset of a set that contains at least one element, but it's not a proper subset of the empty set. 2. If other has unique elements according to this equality comparer, and this has >= the number of elements in other, then this can't be a proper subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsProperSubsetOf(
    IEnumerable<T> other
)
Public Function IsProperSubsetOf (
    other As IEnumerable(Of T)
) As Boolean
public:
bool IsProperSubsetOf(
    IEnumerable<T>^ other
)
member IsProperSubsetOf :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.IsProperSubsetOf(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean
true if this is a proper subset of other; false if not
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).IsProperSupersetOf Method

VelocityDbHashSetTIsProperSupersetOf Method

Checks if this is a proper superset of other (i.e. other strictly contained in this) Implementation Notes: This is slightly more complicated than above because we have to keep track if there was at least one element not contained in other. The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it can't be a proper superset of any set, even if other is the empty set. 2. If other is an empty set and this contains at least 1 element, then this is a proper superset. 3. If other has unique elements according to this equality comparer, and other's count is greater than or equal to this count, then this can't be a proper superset Furthermore, if other has unique elements according to this equality comparer, we can use a faster element-wise check.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsProperSupersetOf(
    IEnumerable<T> other
)
Public Function IsProperSupersetOf (
    other As IEnumerable(Of T)
) As Boolean
public:
bool IsProperSupersetOf(
    IEnumerable<T>^ other
)
member IsProperSupersetOf :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.IsProperSupersetOf(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean
true if this is a proper superset of other; false if not
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).IsSubsetOf Method

VelocityDbHashSetTIsSubsetOf Method

Checks if this is a subset of other. Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If this is the empty set, then it's a subset of anything, including the empty set 2. If other has unique elements according to this equality comparer, and this has more elements than other, then it can't be a subset. Furthermore, if other is a hashset using the same equality comparer, we can use a faster element-wise check.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsSubsetOf(
    IEnumerable<T> other
)
Public Function IsSubsetOf (
    other As IEnumerable(Of T)
) As Boolean
public:
bool IsSubsetOf(
    IEnumerable<T>^ other
)
member IsSubsetOf :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.IsSubsetOf(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean
true if this is a subset of other; false if not
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).IsSupersetOf Method

VelocityDbHashSetTIsSupersetOf Method

Checks if this is a superset of other Implementation Notes: The following properties are used up-front to avoid element-wise checks: 1. If other has no elements (it's the empty set), then this is a superset, even if this is also the empty set. 2. If other has unique elements according to this equality comparer, and this has less than the number of elements in other, then this can't be a superset

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsSupersetOf(
    IEnumerable<T> other
)
Public Function IsSupersetOf (
    other As IEnumerable(Of T)
) As Boolean
public:
bool IsSupersetOf(
    IEnumerable<T>^ other
)
member IsSupersetOf :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.IsSupersetOf(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean
true if this is a superset of other; false if not
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Overlaps Method

VelocityDbHashSetTOverlaps Method

Checks if this set overlaps other (i.e. they share at least one item)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Overlaps(
    IEnumerable<T> other
)
Public Function Overlaps (
    other As IEnumerable(Of T)
) As Boolean
public:
bool Overlaps(
    IEnumerable<T>^ other
)
member Overlaps :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.Overlaps(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean
true if these have at least one common element; false if disjoint
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Remove Method

VelocityDbHashSetTRemove Method

Remove item from this hashset

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean
public:
virtual bool Remove(
    T item
) sealed
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool

Parameters

item
Type: T
item to remove

Return Value

Type: Boolean
true if removed; false if not (i.e. if the item wasn't in the VelocityDbHashSet)

Implements

ICollectionTRemove(T)
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).RemoveWhere Method

VelocityDbHashSetTRemoveWhere Method

Remove elements that match specified predicate. Returns the number of elements removed

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int RemoveWhere(
    Predicate<T> match
)
Public Function RemoveWhere (
    match As Predicate(Of T)
) As Integer
public:
int RemoveWhere(
    Predicate<T>^ match
)
member RemoveWhere :
        match : Predicate<'T> -> int

Parameters

match
Type: SystemPredicate T

[Missing <param name="match"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.RemoveWhere(System.Predicate{`0})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.RemoveWhere(System.Predicate{`0})"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).SetEquals Method

VelocityDbHashSetTSetEquals Method

Checks if this and other contain the same elements. This is set equality: duplicates and order are ignored

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool SetEquals(
    IEnumerable<T> other
)
Public Function SetEquals (
    other As IEnumerable(Of T)
) As Boolean
public:
bool SetEquals(
    IEnumerable<T>^ other
)
member SetEquals :
        other : IEnumerable<'T> -> bool

Parameters

other
Type: System.Collections.GenericIEnumerable T

[Missing <param name="other"/> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.SetEquals(System.Collections.Generic.IEnumerable{`0})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.VelocityDbHashSet`1.SetEquals(System.Collections.Generic.IEnumerable{`0})"]

See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).SymmetricExceptWith Method

VelocityDbHashSetTSymmetricExceptWith Method

Takes symmetric difference (XOR) with other and this set. Modifies this set.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SymmetricExceptWith(
    IEnumerable<T> other
)
Public Sub SymmetricExceptWith (
    other As IEnumerable(Of T)
)
public:
void SymmetricExceptWith(
    IEnumerable<T>^ other
)
member SymmetricExceptWith :
        other : IEnumerable<'T> -> unit

Parameters

other
Type: System.Collections.GenericIEnumerable T
enumerable with items to XOR
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).TrimExcess Method

VelocityDbHashSetTTrimExcess Method

Sets the capacity of this list to the size of the list (rounded up to nearest prime), unless count is 0, in which case we release references. This method can be used to minimize a list's memory overhead once it is known that no new elements will be added to the list. To completely clear a list and release all memory referenced by the list, execute the following statements: list.Clear(); list.TrimExcess();

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void TrimExcess()
Public Sub TrimExcess
public:
void TrimExcess()
member TrimExcess : unit -> unit
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).UnionWith Method

VelocityDbHashSetTUnionWith Method

Take the union of this VelocityDbHashSet with other. Modifies this set. Implementation note: GetSuggestedCapacity (to increase capacity in advance avoiding multiple resizes ended up not being useful in practice; quickly gets to the point where it's a wasteful check.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void UnionWith(
    IEnumerable<T> other
)
Public Sub UnionWith (
    other As IEnumerable(Of T)
)
public:
void UnionWith(
    IEnumerable<T>^ other
)
member UnionWith :
        other : IEnumerable<'T> -> unit

Parameters

other
Type: System.Collections.GenericIEnumerable T
enumerable with items to add
See Also

Reference

VelocityDbHashSetT Class
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Enumerator Structure

VelocityDbHashSetTEnumerator Structure

Enumerates the elements of a VelocityDbHashSet(Of T).

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
[HostProtectionAttribute(SecurityAction.LinkDemand, MayLeakOnAbort = true)]
public struct Enumerator : IEnumerator<T>,
    IDisposable, IEnumerator
<SerializableAttribute>
<HostProtectionAttribute(SecurityAction.LinkDemand, MayLeakOnAbort := true)>
Public Structure Enumerator
    Implements IEnumerator(Of T), IDisposable, IEnumerator
[SerializableAttribute]
[HostProtectionAttribute(SecurityAction::LinkDemand, MayLeakOnAbort = true)]
public value class Enumerator : IEnumerator<T>,
    IDisposable, IEnumerator
[<SealedAttribute>]
[<SerializableAttribute>]
[<HostProtectionAttribute(SecurityAction.LinkDemand, MayLeakOnAbort = true)>]
type Enumerator =
    struct
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end

The VelocityDbHashSetTEnumerator generic type exposes the following members.

Properties
 | Name | Description
Public property | Current | The iterator current Key object
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

VelocityDb.Collection Namespace


Enumerator Properties

The VelocityDbHashSetTEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | The iterator current Key object
Top
See Also

Reference

VelocityDbHashSetTEnumerator Structure
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Enumerator.Current Property

VelocityDbHashSetTEnumeratorCurrent Property

The iterator current Key object

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T Current { get; }
Public ReadOnly Property Current As T
    Get
public:
virtual property T Current {
    T get () sealed;
}
abstract Current : 'T with get
override Current : 'T with get

Property Value

Type: T

Implements

IEnumeratorTCurrent
See Also

Reference

VelocityDbHashSetTEnumerator Structure
VelocityDb.Collection Namespace


Enumerator Methods

The VelocityDbHashSetTEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Top
See Also

Reference

VelocityDbHashSetTEnumerator Structure
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Enumerator.Dispose Method

VelocityDbHashSetTEnumeratorDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

VelocityDbHashSetTEnumerator Structure
VelocityDb.Collection Namespace


VelocityDbHashSet(T).Enumerator.MoveNext Method

VelocityDbHashSetTEnumeratorMoveNext Method

Advances the enumerator to the next element of the collection.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumeratorMoveNext
See Also

Reference

VelocityDbHashSetTEnumerator Structure
VelocityDb.Collection Namespace


VelocityDbList(T) Class

VelocityDbListT Class

A list with an Oid containing objects ordered by index.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionVelocityDbListT
VelocityDb.CollectionVelocityDbListOidShortT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VelocityDbList<T> : OptimizedPersistable,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

<SerializableAttribute>
Public Class VelocityDbList(Of T)
    Inherits OptimizedPersistable
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
public ref class VelocityDbList : public OptimizedPersistable,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type VelocityDbList<'T> =
    class
        inherit OptimizedPersistable
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of objects contained in this kind of list

The VelocityDbListT type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityDbListT | Constructs an empty list
Public method | VelocityDbListT(Int32) | Constructs a new list with a presized capacity
Top
Properties
 | Name | Description
Public property | Count | Number of items in list
Public property | IsFixedSize | Always false
Public property | IsReadOnly | Always false
Public property | IsSynchronized | Always false
Public property | Item | Gets or sets an item at a certain index
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Public property | SyncRoot | Used for thread safety
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an item to a list
Public method | Add(T, Int32) | Adds an item to a list and if array needs to grow to hold new item, it grows to a given max size.
Public method | BinarySearch | Assuming list elements are sorted by default sort order, finds the position of a an element or position where it would belong
Public method | Clear | Removes all items from the list and frees the array
Public method | Contains | Checks if an item is contained in the list
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Public method | GetEnumerator |
Public method | IndexOf | Finds the first index of an item
Public method | Insert(Int32, T) | Inserts an item at a specified index
Public method | Insert(Int32, T, Int32) | Inserts an item at a specified index
Public method | Last | Get the value at the last position in the list
Public method | PersistMyReferences | (Overrides OptimizedPersistablePersistMyReferences(SessionBase, Boolean).)
Public method | Remove | Remove an item
Public method | RemoveAt | Removes an item at a specified index
Public method | RemoveRange | Removes a range of items
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


VelocityDbList(T) Constructor

VelocityDbListT Constructor

Overload List
 | Name | Description
Public method | VelocityDbListT | Constructs an empty list
Public method | VelocityDbListT(Int32) | Constructs a new list with a presized capacity
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T) Constructor

VelocityDbListT Constructor

Constructs an empty list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbList()
Public Sub New
public:
VelocityDbList()
new : unit -> VelocityDbList
See Also

Reference

VelocityDbListT Class
VelocityDbListT Overload
VelocityDb.Collection Namespace


VelocityDbList(T) Constructor (Int32)

VelocityDbListT Constructor (Int32)

Constructs a new list with a presized capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
VelocityDbList(
    int capacity
)
new :
        capacity : int -> VelocityDbList

Parameters

capacity
Type: SystemInt32

[Missing <param name="capacity"/> documentation for "M:VelocityDb.Collection.VelocityDbList`1.#ctor(System.Int32)"]

See Also

Reference

VelocityDbListT Class
VelocityDbListT Overload
VelocityDb.Collection Namespace


VelocityDbList(T) Properties

VelocityDbListT Properties

The VelocityDbListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of items in list
Public property | IsFixedSize | Always false
Public property | IsReadOnly | Always false
Public property | IsSynchronized | Always false
Public property | Item | Gets or sets an item at a certain index
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Public property | SyncRoot | Used for thread safety
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Count Property

VelocityDbListTCount Property

Number of items in list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).IsFixedSize Property

VelocityDbListTIsFixedSize Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}
member IsFixedSize : bool with get

Property Value

Type: Boolean
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).IsReadOnly Property

VelocityDbListTIsReadOnly Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).IsSynchronized Property

VelocityDbListTIsSynchronized Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}
member IsSynchronized : bool with get

Property Value

Type: Boolean
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Item Property

VelocityDbListTItem Property

Gets or sets an item at a certain index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual T this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As T
    Get
    Set
public:
virtual property T default[int index] {
    T get (int index);
    void set (int index, T value);
}
abstract Item : 'T with get, set
override Item : 'T with get, set

Parameters

index
Type: SystemInt32
the item index

Return Value

Type: T
the item at the specified index

Implements

IListTItemInt32
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).ObjectsPerPage Property

VelocityDbListTObjectsPerPage Property

Limit to 1000 per page (instead of default 40000)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).SyncRoot Property

VelocityDbListTSyncRoot Property

Used for thread safety

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}
member SyncRoot : Object with get

Property Value

Type: Object
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T) Methods

VelocityDbListT Methods

The VelocityDbListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an item to a list
Public method | Add(T, Int32) | Adds an item to a list and if array needs to grow to hold new item, it grows to a given max size.
Public method | BinarySearch | Assuming list elements are sorted by default sort order, finds the position of a an element or position where it would belong
Public method | Clear | Removes all items from the list and frees the array
Public method | Contains | Checks if an item is contained in the list
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Public method | GetEnumerator |
Public method | IndexOf | Finds the first index of an item
Public method | Insert(Int32, T) | Inserts an item at a specified index
Public method | Insert(Int32, T, Int32) | Inserts an item at a specified index
Public method | Last | Get the value at the last position in the list
Public method | PersistMyReferences | (Overrides OptimizedPersistablePersistMyReferences(SessionBase, Boolean).)
Public method | Remove | Remove an item
Public method | RemoveAt | Removes an item at a specified index
Public method | RemoveRange | Removes a range of items
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Add Method

VelocityDbListTAdd Method

Overload List
 | Name | Description
Public method | Add(T) | Adds an item to a list
Public method | Add(T, Int32) | Adds an item to a list and if array needs to grow to hold new item, it grows to a given max size.
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Add Method (T)

VelocityDbListTAdd Method (T)

Adds an item to a list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    T item
)
Public Overridable Sub Add (
    item As T
)
public:
virtual void Add(
    T item
)
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit

Parameters

item
Type: T
item being added

Implements

ICollectionTAdd(T)
See Also

Reference

VelocityDbListT Class
Add Overload
VelocityDb.Collection Namespace


VelocityDbList(T).Add Method (T, Int32)

VelocityDbListTAdd Method (T, Int32)

Adds an item to a list and if array needs to grow to hold new item, it grows to a given max size.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    T item,
    int maxArraySize
)
Public Overridable Sub Add (
    item As T,
    maxArraySize As Integer
)
public:
virtual void Add(
    T item,
    int maxArraySize
)
abstract Add :
        item : 'T *
        maxArraySize : int -> unit
override Add :
        item : 'T *
        maxArraySize : int -> unit

Parameters

item
Type: T
item being added
maxArraySize
Type: SystemInt32
the maximum size to use as internal array size
See Also

Reference

VelocityDbListT Class
Add Overload
VelocityDb.Collection Namespace


VelocityDbList(T).BinarySearch Method

VelocityDbListTBinarySearch Method

Assuming list elements are sorted by default sort order, finds the position of a an element or position where it would belong

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int BinarySearch(
    T aKey,
    out bool isEqual
)
Public Function BinarySearch (
    aKey As T,
    <OutAttribute> ByRef isEqual As Boolean
) As Integer
public:
int BinarySearch(
    T aKey,
    [OutAttribute] bool% isEqual
)
member BinarySearch :
        aKey : 'T *
        isEqual : bool byref -> int

Parameters

aKey
Type: T
Element to look for
isEqual
Type: SystemBoolean
true if match found; otherwise false

Return Value

Type: Int32
Index position
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Clear Method

VelocityDbListTClear Method

Removes all items from the list and frees the array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Contains Method

VelocityDbListTContains Method

Checks if an item is contained in the list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
public:
virtual bool Contains(
    T item
) sealed
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool

Parameters

item
Type: T
the item to look for

Return Value

Type: Boolean
true if item was found; otherwise false

Implements

ICollectionTContains(T)
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).CopyTo Method

VelocityDbListTCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).CopyTo Method (Array, Int32)

VelocityDbListTCopyTo Method (Array, Int32)

Copies list to an array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    Array array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Array,
    arrayIndex As Integer
)
public:
void CopyTo(
    Array^ array,
    int arrayIndex
)
member CopyTo :
        array : Array *
        arrayIndex : int -> unit

Parameters

array
Type: SystemArray
the array to copy to
arrayIndex
Type: SystemInt32
start index in array for copy
See Also

Reference

VelocityDbListT Class
CopyTo Overload
VelocityDb.Collection Namespace


VelocityDbList(T).CopyTo Method (T[], Int32)

VelocityDbListTCopyTo Method (T, Int32)

Copies list items to an array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit

Parameters

array
Type: T
the array to copy to
arrayIndex
Type: SystemInt32
start array index of copy

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

VelocityDbListT Class
CopyTo Overload
VelocityDb.Collection Namespace


VelocityDbList(T).GetEnumerator Method

VelocityDbListTGetEnumerator Method

[Missing <summary> documentation for "M:VelocityDb.Collection.VelocityDbList`1.GetEnumerator"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumerator T

[Missing <returns> documentation for "M:VelocityDb.Collection.VelocityDbList`1.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).IndexOf Method

VelocityDbListTIndexOf Method

Finds the first index of an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
public:
virtual int IndexOf(
    T item
) sealed
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int

Parameters

item
Type: T
item to look for

Return Value

Type: Int32
-1 if item was not found or first index of item

Implements

IListTIndexOf(T)
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Insert Method

VelocityDbListTInsert Method

Overload List
 | Name | Description
Public method | Insert(Int32, T) | Inserts an item at a specified index
Public method | Insert(Int32, T, Int32) | Inserts an item at a specified index
Top
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Insert Method (Int32, T)

VelocityDbListTInsert Method (Int32, T)

Inserts an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    int index,
    T item
)
Public Overridable Sub Insert (
    index As Integer,
    item As T
)
public:
virtual void Insert(
    int index,
    T item
)
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
insert at this index
item
Type: T
the item being inserted

Implements

IListTInsert(Int32, T)
See Also

Reference

VelocityDbListT Class
Insert Overload
VelocityDb.Collection Namespace


VelocityDbList(T).Insert Method (Int32, T, Int32)

VelocityDbListTInsert Method (Int32, T, Int32)

Inserts an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    int index,
    T item,
    int maxArraySize
)
Public Overridable Sub Insert (
    index As Integer,
    item As T,
    maxArraySize As Integer
)
public:
virtual void Insert(
    int index,
    T item,
    int maxArraySize
)
abstract Insert :
        index : int *
        item : 'T *
        maxArraySize : int -> unit
override Insert :
        index : int *
        item : 'T *
        maxArraySize : int -> unit

Parameters

index
Type: SystemInt32
insert at this index
item
Type: T
the item being inserted
maxArraySize
Type: SystemInt32
Restrict array growth to this maximum size (if array needs to grow)
See Also

Reference

VelocityDbListT Class
Insert Overload
VelocityDb.Collection Namespace


VelocityDbList(T).Last Method

VelocityDbListTLast Method

Get the value at the last position in the list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T Last()
Public Function Last As T
public:
T Last()
member Last : unit -> 'T

Return Value

Type: T
The value at the last position in the list
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).PersistMyReferences Method

VelocityDbListTPersistMyReferences Method

[Missing <summary> documentation for "M:VelocityDb.Collection.VelocityDbList`1.PersistMyReferences(VelocityDb.Session.SessionBase,System.Boolean)"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void PersistMyReferences(
    SessionBase session,
    bool inFlush
)
Public Overrides Sub PersistMyReferences (
    session As SessionBase,
    inFlush As Boolean
)
public:
virtual void PersistMyReferences(
    SessionBase^ session,
    bool inFlush
) override
abstract PersistMyReferences :
        session : SessionBase *
        inFlush : bool -> unit
override PersistMyReferences :
        session : SessionBase *
        inFlush : bool -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.VelocityDbList`1.PersistMyReferences(VelocityDb.Session.SessionBase,System.Boolean)"]

inFlush
Type: SystemBoolean

[Missing <param name="inFlush"/> documentation for "M:VelocityDb.Collection.VelocityDbList`1.PersistMyReferences(VelocityDb.Session.SessionBase,System.Boolean)"]

Implements

IOptimizedPersistablePersistMyReferences(SessionBase, Boolean)
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).Remove Method

VelocityDbListTRemove Method

Remove an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean
public:
virtual bool Remove(
    T item
)
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool

Parameters

item
Type: T
the item to remove

Return Value

Type: Boolean
true if item was found and removed; otherwise false

Implements

ICollectionTRemove(T)
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).RemoveAt Method

VelocityDbListTRemoveAt Method

Removes an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
the index of the item to remove

Implements

IListTRemoveAt(Int32)
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbList(T).RemoveRange Method

VelocityDbListTRemoveRange Method

Removes a range of items

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveRange(
    int index,
    int howMany
)
Public Overridable Sub RemoveRange (
    index As Integer,
    howMany As Integer
)
public:
virtual void RemoveRange(
    int index,
    int howMany
)
abstract RemoveRange :
        index : int *
        howMany : int -> unit
override RemoveRange :
        index : int *
        howMany : int -> unit

Parameters

index
Type: SystemInt32
start index
howMany
Type: SystemInt32
how many to remove
See Also

Reference

VelocityDbListT Class
VelocityDb.Collection Namespace


VelocityDbListOidShort(T) Class

VelocityDbListOidShortT Class

List of objects where list and all elements of a list are contained within a single Database
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionVelocityDbList T
VelocityDb.CollectionVelocityDbListOidShortT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VelocityDbListOidShort<T> : VelocityDbList<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

<SerializableAttribute>
Public Class VelocityDbListOidShort(Of T)
    Inherits VelocityDbList(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
public ref class VelocityDbListOidShort : public VelocityDbList<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type VelocityDbListOidShort<'T> =
    class
        inherit VelocityDbList<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The element type of a list.

The VelocityDbListOidShortT type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityDbListOidShortT | Creates a new list with a presized capacity
Top
Properties
 | Name | Description
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


VelocityDbListOidShort(T) Constructor

VelocityDbListOidShortT Constructor

Creates a new list with a presized capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbListOidShort(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
VelocityDbListOidShort(
    int capacity
)
new :
        capacity : int -> VelocityDbListOidShort

Parameters

capacity
Type: SystemInt32
See Also

Reference

VelocityDbListOidShortT Class
VelocityDb.Collection Namespace


VelocityDbListOidShort(T) Properties

VelocityDbListOidShortT Properties

The VelocityDbListOidShortT generic type exposes the following members.

Properties
 | Name | Description
Public property | MaxNumberOfDatabases | (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Top
See Also

Reference

VelocityDbListOidShortT Class
VelocityDb.Collection Namespace


VelocityDbListOidShort(T).MaxNumberOfDatabases Property

VelocityDbListOidShortTMaxNumberOfDatabases Property

[Missing <summary> documentation for "P:VelocityDb.Collection.VelocityDbListOidShort`1.MaxNumberOfDatabases"]

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

VelocityDbListOidShortT Class
VelocityDb.Collection Namespace


VelocityDbListOidShort(T) Methods

VelocityDbListOidShortT Methods

The VelocityDbListOidShortT generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDbListOidShortT Class
VelocityDb.Collection Namespace


WeakReferenceList(T) Class

WeakReferenceListT Class

List with an Id containing object Ids ordered by index.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionWeakReferenceListBase T
VelocityDb.CollectionWeakReferenceListT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WeakReferenceList<T> : WeakReferenceListBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
where T : IOptimizedPersistable

<SerializableAttribute>
Public Class WeakReferenceList(Of T As IOptimizedPersistable)
    Inherits WeakReferenceListBase(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
where T : IOptimizedPersistable
public ref class WeakReferenceList : public WeakReferenceListBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type WeakReferenceList<'T when 'T : IOptimizedPersistable> =
    class
        inherit WeakReferenceListBase<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of objects contained in this kind of list

The WeakReferenceListT type exposes the following members.

Constructors
 | Name | Description
Public method | WeakReferenceListT | Constructs a new list with a presized capacity
Top
Properties
 | Name | Description
Public property | Count | Number of items in list (Overrides WeakReferenceListBaseTCount.)
Public property | Item | Gets or sets an item at a certain index (Overrides WeakReferenceListBaseTItemInt32.)
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to a list (Overrides WeakReferenceListBaseTAdd(T).)
Public method | Clear | Removes all items from the list and frees the array (Overrides WeakReferenceListBaseTClear.)
Public method | Insert | Inserts an item at a specified index (Overrides WeakReferenceListBaseTInsert(Int32, T).)
Public method | Remove | Remove an item (Overrides WeakReferenceListBaseTRemove(T).)
Public method | RemoveAt | Removes an item at a specified index (Overrides WeakReferenceListBaseTRemoveAt(Int32).)
Public method | RemoveRange | Removes a range of items (Overrides WeakReferenceListBaseTRemoveRange(Int32, Int32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


WeakReferenceList(T) Constructor

WeakReferenceListT Constructor

Constructs a new list with a presized capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakReferenceList(
    int capacity = 1,
    SessionBase session = null
)
Public Sub New (
    Optional capacity As Integer = 1,
    Optional session As SessionBase = Nothing
)
public:
WeakReferenceList(
    int capacity = 1,
    SessionBase^ session = nullptr
)
new :
        ?capacity : int *
        ?session : SessionBase
(* Defaults:
        let _capacity = defaultArg capacity 1
        let _session = defaultArg session null
*)
-> WeakReferenceList

Parameters

capacity (Optional)
Type: SystemInt32
Reserve space for this many elements
session (Optional)
Type: VelocityDb.SessionSessionBase
Active session
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T) Properties

WeakReferenceListT Properties

The WeakReferenceListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of items in list (Overrides WeakReferenceListBaseTCount.)
Public property | Item | Gets or sets an item at a certain index (Overrides WeakReferenceListBaseTItemInt32.)
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Count Property

WeakReferenceListTCount Property

Number of items in list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () override;
}
abstract Count : int with get
override Count : int with get

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
ICollectionTCount
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Item Property

WeakReferenceListTItem Property

Gets or sets an item at a certain index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override T this[
    int index
] { get; set; }
Public Overrides Default Property Item (
    index As Integer
) As T
    Get
    Set
public:
virtual property T default[int index] {
    T get (int index) override;
    void set (int index, T value) override;
}
abstract Item : 'T with get, set
override Item : 'T with get, set

Parameters

index
Type: SystemInt32
the item index

Return Value

Type: T
the item at the specified index

Implements

IListTItemInt32
IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The property is set and the IListT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).ObjectsPerPage Property

WeakReferenceListTObjectsPerPage Property

Limit to 1000 per page (instead of default 40000)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T) Methods

WeakReferenceListT Methods

The WeakReferenceListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to a list (Overrides WeakReferenceListBaseTAdd(T).)
Public method | Clear | Removes all items from the list and frees the array (Overrides WeakReferenceListBaseTClear.)
Public method | Insert | Inserts an item at a specified index (Overrides WeakReferenceListBaseTInsert(Int32, T).)
Public method | Remove | Remove an item (Overrides WeakReferenceListBaseTRemove(T).)
Public method | RemoveAt | Removes an item at a specified index (Overrides WeakReferenceListBaseTRemoveAt(Int32).)
Public method | RemoveRange | Removes a range of items (Overrides WeakReferenceListBaseTRemoveRange(Int32, Int32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Add Method

WeakReferenceListTAdd Method

Adds an item to a list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Add(
    T item
)
Public Overrides Sub Add (
    item As T
)
public:
virtual void Add(
    T item
) override
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit

Parameters

item
Type: T
item being added

Implements

ICollectionTAdd(T)
ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Clear Method

WeakReferenceListTClear Method

Removes all items from the list and frees the array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Insert Method

WeakReferenceListTInsert Method

Inserts an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Insert(
    int index,
    T item
)
Public Overrides Sub Insert (
    index As Integer,
    item As T
)
public:
virtual void Insert(
    int index,
    T item
) override
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
insert at this index
item
Type: T
the item being inserted

Implements

IListTInsert(Int32, T)
IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).Remove Method

WeakReferenceListTRemove Method

Remove an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Remove(
    T item
)
Public Overrides Function Remove (
    item As T
) As Boolean
public:
virtual bool Remove(
    T item
) override
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool

Parameters

item
Type: T
the item to remove

Return Value

Type: Boolean
true if item was found and removed; otherwise false

Implements

ICollectionTRemove(T)
ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).RemoveAt Method

WeakReferenceListTRemoveAt Method

Removes an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) override
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
the index of the item to remove

Implements

IListTRemoveAt(Int32)
IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceList(T).RemoveRange Method

WeakReferenceListTRemoveRange Method

Removes a range of items

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RemoveRange(
    int index,
    int howMany
)
Public Overrides Sub RemoveRange (
    index As Integer,
    howMany As Integer
)
public:
virtual void RemoveRange(
    int index,
    int howMany
) override
abstract RemoveRange :
        index : int *
        howMany : int -> unit
override RemoveRange :
        index : int *
        howMany : int -> unit

Parameters

index
Type: SystemInt32
start index
howMany
Type: SystemInt32
how many to remove
See Also

Reference

WeakReferenceListT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T) Class

WeakReferenceListBaseT Class

List with an Id containing object Ids ordered by index.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionWeakReferenceListBaseT
VelocityDb.CollectionWeakReferenceListT
VelocityDb.CollectionWeakShortReferenceListT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class WeakReferenceListBase<T> : OptimizedPersistable,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
where T : IOptimizedPersistable

<SerializableAttribute>
Public MustInherit Class WeakReferenceListBase(Of T As IOptimizedPersistable)
    Inherits OptimizedPersistable
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
where T : IOptimizedPersistable
public ref class WeakReferenceListBase abstract : public OptimizedPersistable,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type WeakReferenceListBase<'T when 'T : IOptimizedPersistable> =
    class
        inherit OptimizedPersistable
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of objects contained in this kind of list

The WeakReferenceListBaseT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of items in list
Public property | IsFixedSize | Always false
Public property | IsReadOnly | Always false
Public property | IsSynchronized | Always false
Public property | Item | Gets or sets an item at a certain index
Public property | SyncRoot | Used for thread safety
Top
Methods
 | Name | Description
Public method | Add | Adds an item to a list
Public method | BinarySearch | Searches the entire sorted list for an element using the default comparer and returns the zero-based index of the element.
Public method | Clear | Removes all items from the list and frees the array
Public method | ClearAndUnpersistContainedObjects | Removes all items from the list and unpersists all contained objects
Public method | Contains | Checks if an item is contained in the list
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf | Finds the first index of an item
Public method | Insert | Inserts an item at a specified index
Public method | Last | Get the value at the last position in the list
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | Remove | Remove an item
Public method | RemoveAt | Removes an item at a specified index
Public method | RemoveRange | Removes a range of items
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


WeakReferenceListBase(T) Properties

WeakReferenceListBaseT Properties

The WeakReferenceListBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of items in list
Public property | IsFixedSize | Always false
Public property | IsReadOnly | Always false
Public property | IsSynchronized | Always false
Public property | Item | Gets or sets an item at a certain index
Public property | SyncRoot | Used for thread safety
Top
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Count Property

WeakReferenceListBaseTCount Property

Number of items in list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract int Count { get; }
Public MustOverride ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () abstract;
}
abstract Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).IsFixedSize Property

WeakReferenceListBaseTIsFixedSize Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}
member IsFixedSize : bool with get

Property Value

Type: Boolean
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).IsReadOnly Property

WeakReferenceListBaseTIsReadOnly Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).IsSynchronized Property

WeakReferenceListBaseTIsSynchronized Property

Always false

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}
member IsSynchronized : bool with get

Property Value

Type: Boolean
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Item Property

WeakReferenceListBaseTItem Property

Gets or sets an item at a certain index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract T this[
    int index
] { get; set; }
Public MustOverride Default Property Item (
    index As Integer
) As T
    Get
    Set
public:
virtual property T default[int index] {
    T get (int index) abstract;
    void set (int index, T value) abstract;
}
abstract Item : 'T with get, set

Parameters

index
Type: SystemInt32
the item index

Return Value

Type: T
the item at the specified index

Implements

IListTItemInt32
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).SyncRoot Property

WeakReferenceListBaseTSyncRoot Property

Used for thread safety

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}
member SyncRoot : Object with get

Property Value

Type: Object
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T) Methods

WeakReferenceListBaseT Methods

The WeakReferenceListBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to a list
Public method | BinarySearch | Searches the entire sorted list for an element using the default comparer and returns the zero-based index of the element.
Public method | Clear | Removes all items from the list and frees the array
Public method | ClearAndUnpersistContainedObjects | Removes all items from the list and unpersists all contained objects
Public method | Contains | Checks if an item is contained in the list
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | IndexOf | Finds the first index of an item
Public method | Insert | Inserts an item at a specified index
Public method | Last | Get the value at the last position in the list
Public method | Persist | Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way. (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | Remove | Remove an item
Public method | RemoveAt | Removes an item at a specified index
Public method | RemoveRange | Removes a range of items
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Add Method

WeakReferenceListBaseTAdd Method

Adds an item to a list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void Add(
    T item
)
Public MustOverride Sub Add (
    item As T
)
public:
virtual void Add(
    T item
) abstract
abstract Add :
        item : 'T -> unit

Parameters

item
Type: T
item being added

Implements

ICollectionTAdd(T)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).BinarySearch Method

WeakReferenceListBaseTBinarySearch Method

Searches the entire sorted list for an element using the default comparer and returns the zero-based index of the element.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int BinarySearch(
    T aKey,
    out bool isEqual
)
Public Function BinarySearch (
    aKey As T,
    <OutAttribute> ByRef isEqual As Boolean
) As Integer
public:
int BinarySearch(
    T aKey,
    [OutAttribute] bool% isEqual
)
member BinarySearch :
        aKey : 'T *
        isEqual : bool byref -> int

Parameters

aKey
Type: T
The object to locate
isEqual
Type: SystemBoolean
True if match is found; otherwise false

Return Value

Type: Int32
The index of the object if found; otherwise index at which located would be located
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Clear Method

WeakReferenceListBaseTClear Method

Removes all items from the list and frees the array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void Clear()
Public MustOverride Sub Clear
public:
virtual void Clear() abstract
abstract Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).ClearAndUnpersistContainedObjects Method

WeakReferenceListBaseTClearAndUnpersistContainedObjects Method

Removes all items from the list and unpersists all contained objects

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearAndUnpersistContainedObjects(
    SessionBase session
)
Public Overridable Sub ClearAndUnpersistContainedObjects (
    session As SessionBase
)
public:
virtual void ClearAndUnpersistContainedObjects(
    SessionBase^ session
)
abstract ClearAndUnpersistContainedObjects :
        session : SessionBase -> unit
override ClearAndUnpersistContainedObjects :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.WeakReferenceListBase`1.ClearAndUnpersistContainedObjects(VelocityDb.Session.SessionBase)"]

See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Contains Method

WeakReferenceListBaseTContains Method

Checks if an item is contained in the list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
public:
virtual bool Contains(
    T item
) sealed
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool

Parameters

item
Type: T
the item to look for

Return Value

Type: Boolean
true if item was found; otherwise false

Implements

ICollectionTContains(T)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).CopyTo Method

WeakReferenceListBaseTCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(Array, Int32) | Copies list to an array
Public method | CopyTo(T, Int32) | Copies list items to an array
Top
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).CopyTo Method (Array, Int32)

WeakReferenceListBaseTCopyTo Method (Array, Int32)

Copies list to an array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    Array array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Array,
    arrayIndex As Integer
)
public:
void CopyTo(
    Array^ array,
    int arrayIndex
)
member CopyTo :
        array : Array *
        arrayIndex : int -> unit

Parameters

array
Type: SystemArray
the array to copy to
arrayIndex
Type: SystemInt32
start index in array for copy
See Also

Reference

WeakReferenceListBaseT Class
CopyTo Overload
VelocityDb.Collection Namespace


WeakReferenceListBase(T).CopyTo Method (T[], Int32)

WeakReferenceListBaseTCopyTo Method (T, Int32)

Copies list items to an array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit

Parameters

array
Type: T
the array to copy to
arrayIndex
Type: SystemInt32
start array index of copy

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

WeakReferenceListBaseT Class
CopyTo Overload
VelocityDb.Collection Namespace


WeakReferenceListBase(T).GetEnumerator Method

WeakReferenceListBaseTGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumerator T
An enumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).IndexOf Method

WeakReferenceListBaseTIndexOf Method

Finds the first index of an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
public:
virtual int IndexOf(
    T item
) sealed
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int

Parameters

item
Type: T
item to look for

Return Value

Type: Int32
-1 if item was not found or first index of item

Implements

IListTIndexOf(T)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Insert Method

WeakReferenceListBaseTInsert Method

Inserts an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void Insert(
    int index,
    T item
)
Public MustOverride Sub Insert (
    index As Integer,
    item As T
)
public:
virtual void Insert(
    int index,
    T item
) abstract
abstract Insert :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
insert at this index
item
Type: T
the item being inserted

Implements

IListTInsert(Int32, T)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Last Method

WeakReferenceListBaseTLast Method

Get the value at the last position in the list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public T Last()
Public Function Last As T
public:
T Last()
member Last : unit -> 'T

Return Value

Type: T
The value at the last position in the list
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Persist Method

WeakReferenceListBaseTPersist Method

Persists this object. Override in your subclasses when you want fields of your class to be persisted in some special way.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
The placement rules to follow when persisting this object
session
Type: VelocityDb.SessionSessionBase
The session managing this object
persistRefs (Optional)
Type: SystemBoolean
If true, objects referenced from this object will also be persisted
disableFlush (Optional)
Type: SystemBoolean
If true, disables possible flushing of updated pages while persisting this object; otherwise page flushing may occur
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A queue of objects remaining to be persisted. Pass as a parameter to session.Persist

Return Value

Type: UInt64
The object id of this persistent object

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Remove Method

WeakReferenceListBaseTRemove Method

Remove an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract bool Remove(
    T item
)
Public MustOverride Function Remove (
    item As T
) As Boolean
public:
virtual bool Remove(
    T item
) abstract
abstract Remove :
        item : 'T -> bool

Parameters

item
Type: T
the item to remove

Return Value

Type: Boolean
true if item was found and removed; otherwise false

Implements

ICollectionTRemove(T)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).RemoveAt Method

WeakReferenceListBaseTRemoveAt Method

Removes an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void RemoveAt(
    int index
)
Public MustOverride Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) abstract
abstract RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
the index of the item to remove

Implements

IListTRemoveAt(Int32)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).RemoveRange Method

WeakReferenceListBaseTRemoveRange Method

Removes a range of items

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void RemoveRange(
    int index,
    int howMany
)
Public MustOverride Sub RemoveRange (
    index As Integer,
    howMany As Integer
)
public:
virtual void RemoveRange(
    int index,
    int howMany
) abstract
abstract RemoveRange :
        index : int *
        howMany : int -> unit

Parameters

index
Type: SystemInt32
start index
howMany
Type: SystemInt32
how many to remove
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakReferenceListBase(T).Unpersist Method

WeakReferenceListBaseTUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

WeakReferenceListBaseT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T) Class

WeakShortReferenceListT Class

List with an Id containing object short Ids (page and slot) ordered by index.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.CollectionWeakReferenceListBase T
VelocityDb.CollectionWeakShortReferenceListT

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WeakShortReferenceList<T> : WeakReferenceListBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
where T : IOptimizedPersistable

<SerializableAttribute>
Public Class WeakShortReferenceList(Of T As IOptimizedPersistable)
    Inherits WeakReferenceListBase(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
where T : IOptimizedPersistable
public ref class WeakShortReferenceList : public WeakReferenceListBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
[<SerializableAttribute>]
type WeakShortReferenceList<'T when 'T : IOptimizedPersistable> =
    class
        inherit WeakReferenceListBase<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of objects contained in this kind of list

The WeakShortReferenceListT type exposes the following members.

Constructors
 | Name | Description
Public method | WeakShortReferenceListT | Constructs a new list with a presized capacity
Top
Properties
 | Name | Description
Public property | Count | Number of items in list (Overrides WeakReferenceListBaseTCount.)
Public property | Item | Gets or sets an item at a certain index (Overrides WeakReferenceListBaseTItemInt32.)
Public property | ObjectsPerPage | Limit to 10000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to a list (Overrides WeakReferenceListBaseTAdd(T).)
Public method | Clear | Removes all items from the list and frees the array (Overrides WeakReferenceListBaseTClear.)
Public method | Insert | Inserts an item at a specified index (Overrides WeakReferenceListBaseTInsert(Int32, T).)
Public method | Remove | Remove an item (Overrides WeakReferenceListBaseTRemove(T).)
Public method | RemoveAt | Removes an item at a specified index (Overrides WeakReferenceListBaseTRemoveAt(Int32).)
Public method | RemoveRange | Removes a range of items (Overrides WeakReferenceListBaseTRemoveRange(Int32, Int32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection Namespace


WeakShortReferenceList(T) Constructor

WeakShortReferenceListT Constructor

Constructs a new list with a presized capacity

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakShortReferenceList(
    int capacity = 1,
    SessionBase session = null
)
Public Sub New (
    Optional capacity As Integer = 1,
    Optional session As SessionBase = Nothing
)
public:
WeakShortReferenceList(
    int capacity = 1,
    SessionBase^ session = nullptr
)
new :
        ?capacity : int *
        ?session : SessionBase
(* Defaults:
        let _capacity = defaultArg capacity 1
        let _session = defaultArg session null
*)
-> WeakShortReferenceList

Parameters

capacity (Optional)
Type: SystemInt32
Reserve space for this many elements
session (Optional)
Type: VelocityDb.SessionSessionBase
Active session
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T) Properties

WeakShortReferenceListT Properties

The WeakShortReferenceListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of items in list (Overrides WeakReferenceListBaseTCount.)
Public property | Item | Gets or sets an item at a certain index (Overrides WeakReferenceListBaseTItemInt32.)
Public property | ObjectsPerPage | Limit to 10000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Top
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Count Property

WeakShortReferenceListTCount Property

Number of items in list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () override;
}
abstract Count : int with get
override Count : int with get

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
ICollectionTCount
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Item Property

WeakShortReferenceListTItem Property

Gets or sets an item at a certain index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override T this[
    int index
] { get; set; }
Public Overrides Default Property Item (
    index As Integer
) As T
    Get
    Set
public:
virtual property T default[int index] {
    T get (int index) override;
    void set (int index, T value) override;
}
abstract Item : 'T with get, set
override Item : 'T with get, set

Parameters

index
Type: SystemInt32
the item index

Return Value

Type: T
the item at the specified index

Implements

IListTItemInt32
IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The property is set and the IListT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).ObjectsPerPage Property

WeakShortReferenceListTObjectsPerPage Property

Limit to 10000 per page (instead of default 40000)

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T) Methods

WeakShortReferenceListT Methods

The WeakShortReferenceListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to a list (Overrides WeakReferenceListBaseTAdd(T).)
Public method | Clear | Removes all items from the list and frees the array (Overrides WeakReferenceListBaseTClear.)
Public method | Insert | Inserts an item at a specified index (Overrides WeakReferenceListBaseTInsert(Int32, T).)
Public method | Remove | Remove an item (Overrides WeakReferenceListBaseTRemove(T).)
Public method | RemoveAt | Removes an item at a specified index (Overrides WeakReferenceListBaseTRemoveAt(Int32).)
Public method | RemoveRange | Removes a range of items (Overrides WeakReferenceListBaseTRemoveRange(Int32, Int32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Add Method

WeakShortReferenceListTAdd Method

Adds an item to a list

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Add(
    T item
)
Public Overrides Sub Add (
    item As T
)
public:
virtual void Add(
    T item
) override
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit

Parameters

item
Type: T
item being added

Implements

ICollectionTAdd(T)
ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Clear Method

WeakShortReferenceListTClear Method

Removes all items from the list and frees the array

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Insert Method

WeakShortReferenceListTInsert Method

Inserts an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Insert(
    int index,
    T item
)
Public Overrides Sub Insert (
    index As Integer,
    item As T
)
public:
virtual void Insert(
    int index,
    T item
) override
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit

Parameters

index
Type: SystemInt32
insert at this index
item
Type: T
the item being inserted

Implements

IListTInsert(Int32, T)
IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).Remove Method

WeakShortReferenceListTRemove Method

Remove an item

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Remove(
    T item
)
Public Overrides Function Remove (
    item As T
) As Boolean
public:
virtual bool Remove(
    T item
) override
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool

Parameters

item
Type: T
the item to remove

Return Value

Type: Boolean
true if item was found and removed; otherwise false

Implements

ICollectionTRemove(T)
ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).RemoveAt Method

WeakShortReferenceListTRemoveAt Method

Removes an item at a specified index

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RemoveAt(
    int index
)
Public Overrides Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) override
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
the index of the item to remove

Implements

IListTRemoveAt(Int32)
IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


WeakShortReferenceList(T).RemoveRange Method

WeakShortReferenceListTRemoveRange Method

Removes a range of items

Namespace: VelocityDb.Collection
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RemoveRange(
    int index,
    int howMany
)
Public Overrides Sub RemoveRange (
    index As Integer,
    howMany As Integer
)
public:
virtual void RemoveRange(
    int index,
    int howMany
) override
abstract RemoveRange :
        index : int *
        howMany : int -> unit
override RemoveRange :
        index : int *
        howMany : int -> unit

Parameters

index
Type: SystemInt32
start index
howMany
Type: SystemInt32
how many to remove
See Also

Reference

WeakShortReferenceListT Class
VelocityDb.Collection Namespace


VelocityDb.Collection.BTree Namespace

The VelocityDb.Collection.BTree namespace contains classes for the VelocityDb BTrees optimized for persistent storage in VelocityDb databases
Classes
 | Class | Description
Public class | AssemblyExtensions |
Public class | BTreeBaseKey, Value | Represents a collection of objects that is maintained in sorted order.
Public class | BTreeByteArray | Wrapper object for a byte[] of data for comparing objects within a BTreeSet. Wrapper is used so that this data can be placed on a seperate Page
Public class | BTreeInternalKey, Value | Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Public class | BTreeInternalBaseKey, Value | Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Public class | BTreeLeafKey, Value | Creates a leaf level node in the BTree
Public class | BTreeLeafBaseKey, Value | Internal class used with BTreeSet and BTreeMap
Public class | BTreeMapKey, Value | Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Public class | BTreeMapBaseKey, Value | Represents a collection of objects that is maintained in sorted order.
Public class | BTreeMapIteratorKey, Value | Iterates all the elements of a BTreeSet
Public class | BTreeMapOidShortKey, Value | Represents a collection of objects that is maintained in sorted order. Collection and all objects must be within a single Database (since references uses OidShort persistently)
Public class | BTreeNode | A BTree consists of a tree of nodes. Each BTree node has this class a base class.
Public class | BTreeSetKey | Represents a collection of objects that is maintained in sorted order. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time.
Public class | BTreeSetIteratorKey | Iterates all the elements of a BTreeSet
Public class | BTreeSetOidShortKey | Represents a collection of objects that is maintained in sorted order. Collection and all objects must be within a single Database (since references uses OidShort persistently)


AssemblyExtensions Class

[Missing <summary> documentation for "T:VelocityDb.Collection.BTree.AssemblyExtensions"]

Inheritance Hierarchy
SystemObject
VelocityDb.Collection.BTreeAssemblyExtensions

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class AssemblyExtensions
<ExtensionAttribute>
Public NotInheritable Class AssemblyExtensions
[ExtensionAttribute]
public ref class AssemblyExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type AssemblyExtensions =  class end

The AssemblyExtensions type exposes the following members.

Methods
Name | Description
GetLoadableTypes |
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


AssemblyExtensions Methods

The AssemblyExtensions type exposes the following members.

Methods
Name | Description
GetLoadableTypes |
Top
See Also

Reference

AssemblyExtensions Class
VelocityDb.Collection.BTree Namespace


AssemblyExtensions.GetLoadableTypes Method

AssemblyExtensionsGetLoadableTypes Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.AssemblyExtensions.GetLoadableTypes(System.Reflection.Assembly)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Type> GetLoadableTypes(
    this Assembly assembly
)
<ExtensionAttribute>
Public Shared Function GetLoadableTypes (
    assembly As Assembly
) As IEnumerable(Of Type)
public:
[ExtensionAttribute]
static IEnumerable<Type^>^ GetLoadableTypes(
    Assembly^ assembly
)
[<ExtensionAttribute>]
static member GetLoadableTypes :
        assembly : Assembly -> IEnumerable<Type>

Parameters

assembly
Type: System.ReflectionAssembly

[Missing <param name="assembly"/> documentation for "M:VelocityDb.Collection.BTree.AssemblyExtensions.GetLoadableTypes(System.Reflection.Assembly)"]

Return Value

Type: IEnumerable Type

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.AssemblyExtensions.GetLoadableTypes(System.Reflection.Assembly)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value) Class

BTreeBaseKey, Value Class

Represents a collection of objects that is maintained in sorted order.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBaseKey, Value
VelocityDb.Collection.BTreeBTreeMapBaseKey, Value
VelocityDb.Collection.BTreeBTreeSetKey
VelocityDb.Collection.BTreeBTreeSetOidShortKey

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BTreeBase<Key, Value> : BTreeNode,
    IEnumerable<Key>, IEnumerable

<SerializableAttribute>
Public MustInherit Class BTreeBase(Of Key, Value)
    Inherits BTreeNode
    Implements IEnumerable(Of Key), IEnumerable
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeBase abstract : public BTreeNode,
    IEnumerable<Key>, IEnumerable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BTreeBase<'Key, 'Value> =
    class
        inherit BTreeNode
        interface IEnumerable<'Key>
        interface IEnumerable
    end

Type Parameters

Key
The type of key objects in this BTree
Value
The type of value objects in a BTreeMap or BTreeMapOidShort

The BTreeBaseKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer(Of Key) that is used to determine the order of the items in the sorted set
Public property | ComparisonArraySize | Gets the size of a comparison array used by this set.
Public property | Count | Gets the number of elements in the set.
Public property | Depth | Gets the depth of the BTreeSet
Public property | FlushIfPageFull | We don't want to flush other BTree pages while looking for a placement page (Overrides OptimizedPersistableFlushIfPageFull.)
Public property | GetAlternateComparer | If comparer isn't set then if Key type is string use SessionBase.DefaultStringComparer or ...
Public property | IsLeaf | Is the root a leaf node or not?
Public property | KeyPlacement | Set the key placement to be used for all key objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key)
Public property | NodeSize | The size of the nodeList or the keyList (if depth is 1) of the root node.
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Public property | ToDoBatchAddCount | Gets the number of objects that are not yet added to the collection
Public property | TransientBatchSize | Get/Set the max batch size used in API such as AddFast(Key)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references?
Top
Methods
 | Name | Description
Public method | Add(Key) | Adds an element to the set and returns a value that indicates if it was successfully added
Public method | Add(Key, Value) | Add a key with an associated value to a BTreeMap
Public method | Add(Key, Value, Byte) | Adds a key and value to the map and returns a value that indicates if it was successfully added
Public method | AddFast | Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is committed and/or flushed to disk or when the array is full. The array size is by default currently BTreeAddFastTransientBatchSize but you can get/set the desired size with TransientBatchSize
Public method | AddWithComparisonArray | Adds an element to the set and returns a value that indicates if it was successfully added
Public method | Clear | Removes all elements from the set.
Public method | Contains(Key) | Determines whether the set contains a specific element.
Public method | Contains(Key, Byte) | Determines whether the set contains a specific element.
Public method | CopyTo | Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.
Public method | FlushTransients | Adds all queued up to be added objects after presorting them transiently (Overrides OptimizedPersistableFlushTransients.)
Public method | GetEnumerator | Enumerates all contained Key objects in sorted order
Public method | GetKeyId(Key) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Public method | GetKeyId(Key, Byte) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Public method | InitializeAfterRead | Sets up some transient variables (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | InitNew | Internal use only
Public method | Iterator | Initializes an iterator to find the keys of this set
Public method | Remove(Key) | Removes a specified item from the set.
Public method | Remove(Key, Byte) | Removes a specified item from the set.
Public method | SearchTransients |
Public method | TryGetKey(Key, Key) | Gets the value matching persistent key with the specified key.
Public method | TryGetKey(Key, Byte, Key) | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value) Properties

BTreeBaseKey, Value Properties

The BTreeBaseKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer(Of Key) that is used to determine the order of the items in the sorted set
Public property | ComparisonArraySize | Gets the size of a comparison array used by this set.
Public property | Count | Gets the number of elements in the set.
Public property | Depth | Gets the depth of the BTreeSet
Public property | FlushIfPageFull | We don't want to flush other BTree pages while looking for a placement page (Overrides OptimizedPersistableFlushIfPageFull.)
Public property | GetAlternateComparer | If comparer isn't set then if Key type is string use SessionBase.DefaultStringComparer or ...
Public property | IsLeaf | Is the root a leaf node or not?
Public property | KeyPlacement | Set the key placement to be used for all key objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key)
Public property | NodeSize | The size of the nodeList or the keyList (if depth is 1) of the root node.
Public property | ObjectsPerPage | Limit to 1000 per page (instead of default 40000) (Overrides OptimizedPersistableObjectsPerPage.)
Public property | ToDoBatchAddCount | Gets the number of objects that are not yet added to the collection
Public property | TransientBatchSize | Get/Set the max batch size used in API such as AddFast(Key)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references?
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Comparer Property

BTreeBaseKey, ValueComparer Property

Gets the VelocityDbComparer(Of Key) that is used to determine the order of the items in the sorted set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract VelocityDbComparer<Key> Comparer { get; }
Public MustOverride ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () abstract;
}
abstract Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).ComparisonArraySize Property

BTreeBaseKey, ValueComparisonArraySize Property

Gets the size of a comparison array used by this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort ComparisonArraySize { get; }
Public ReadOnly Property ComparisonArraySize As UShort
    Get
public:
property unsigned short ComparisonArraySize {
    unsigned short get ();
}
member ComparisonArraySize : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Count Property

BTreeBaseKey, ValueCount Property

Gets the number of elements in the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Depth Property

BTreeBaseKey, ValueDepth Property

Gets the depth of the BTreeSet

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort Depth { get; }
Public ReadOnly Property Depth As UShort
    Get
public:
property unsigned short Depth {
    unsigned short get ();
}
member Depth : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).FlushIfPageFull Property

BTreeBaseKey, ValueFlushIfPageFull Property

We don't want to flush other BTree pages while looking for a placement page

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool FlushIfPageFull { get; }
Public Overrides ReadOnly Property FlushIfPageFull As Boolean
    Get
public:
virtual property bool FlushIfPageFull {
    bool get () override;
}
abstract FlushIfPageFull : bool with get
override FlushIfPageFull : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableFlushIfPageFull
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).GetAlternateComparer Property

BTreeBaseKey, ValueGetAlternateComparer Property

If comparer isn't set then if Key type is string use SessionBase.DefaultStringComparer or ...

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IComparer<Key> GetAlternateComparer { get; }
Public ReadOnly Property GetAlternateComparer As IComparer(Of Key)
    Get
public:
property IComparer<Key>^ GetAlternateComparer {
    IComparer<Key>^ get ();
}
member GetAlternateComparer : IComparer<'Key> with get

Property Value

Type: IComparer Key
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).IsLeaf Property

BTreeBaseKey, ValueIsLeaf Property

Is the root a leaf node or not?

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsLeaf { get; }
Public ReadOnly Property IsLeaf As Boolean
    Get
public:
property bool IsLeaf {
    bool get ();
}
member IsLeaf : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).KeyPlacement Property

BTreeBaseKey, ValueKeyPlacement Property

Set the key placement to be used for all key objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Placement KeyPlacement { get; set; }
Public Property KeyPlacement As Placement
    Get
    Set
public:
property Placement^ KeyPlacement {
    Placement^ get ();
    void set (Placement^ value);
}
member KeyPlacement : Placement with get, set

Property Value

Type: Placement
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).NodeSize Property

BTreeBaseKey, ValueNodeSize Property

The size of the nodeList or the keyList (if depth is 1) of the root node.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int NodeSize { get; }
Public ReadOnly Property NodeSize As Integer
    Get
public:
property int NodeSize {
    int get ();
}
member NodeSize : int with get

Property Value

Type: Int32
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).ObjectsPerPage Property

BTreeBaseKey, ValueObjectsPerPage Property

Limit to 1000 per page (instead of default 40000)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).ToDoBatchAddCount Property

BTreeBaseKey, ValueToDoBatchAddCount Property

Gets the number of objects that are not yet added to the collection

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint ToDoBatchAddCount { get; }
Public ReadOnly Property ToDoBatchAddCount As UInteger
    Get
public:
property unsigned int ToDoBatchAddCount {
    unsigned int get ();
}
member ToDoBatchAddCount : uint32 with get

Property Value

Type: UInt32
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).TransientBatchSize Property

BTreeBaseKey, ValueTransientBatchSize Property

Get/Set the max batch size used in API such as AddFast(Key)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual uint TransientBatchSize { get; set; }
Public Overridable Property TransientBatchSize As UInteger
    Get
    Set
public:
virtual property unsigned int TransientBatchSize {
    unsigned int get ();
    void set (unsigned int value);
}
abstract TransientBatchSize : uint32 with get, set
override TransientBatchSize : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).UsesOidShort Property

BTreeBaseKey, ValueUsesOidShort Property

Does this BTree use short object references (32 bit) for its internal references?

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract bool UsesOidShort { get; }
Public MustOverride ReadOnly Property UsesOidShort As Boolean
    Get
public:
virtual property bool UsesOidShort {
    bool get () abstract;
}
abstract UsesOidShort : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value) Methods

BTreeBaseKey, Value Methods

The BTreeBaseKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(Key) | Adds an element to the set and returns a value that indicates if it was successfully added
Public method | Add(Key, Value) | Add a key with an associated value to a BTreeMap
Public method | Add(Key, Value, Byte) | Adds a key and value to the map and returns a value that indicates if it was successfully added
Public method | AddFast | Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is committed and/or flushed to disk or when the array is full. The array size is by default currently BTreeAddFastTransientBatchSize but you can get/set the desired size with TransientBatchSize
Public method | AddWithComparisonArray | Adds an element to the set and returns a value that indicates if it was successfully added
Public method | Clear | Removes all elements from the set.
Public method | Contains(Key) | Determines whether the set contains a specific element.
Public method | Contains(Key, Byte) | Determines whether the set contains a specific element.
Public method | CopyTo | Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.
Public method | FlushTransients | Adds all queued up to be added objects after presorting them transiently (Overrides OptimizedPersistableFlushTransients.)
Public method | GetEnumerator | Enumerates all contained Key objects in sorted order
Public method | GetKeyId(Key) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Public method | GetKeyId(Key, Byte) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Public method | InitializeAfterRead | Sets up some transient variables (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | InitNew | Internal use only
Public method | Iterator | Initializes an iterator to find the keys of this set
Public method | Remove(Key) | Removes a specified item from the set.
Public method | Remove(Key, Byte) | Removes a specified item from the set.
Public method | SearchTransients |
Public method | TryGetKey(Key, Key) | Gets the value matching persistent key with the specified key.
Public method | TryGetKey(Key, Byte, Key) | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Add Method

BTreeBaseKey, ValueAdd Method

Overload List
 | Name | Description
Public method | Add(Key) | Adds an element to the set and returns a value that indicates if it was successfully added
Public method | Add(Key, Value) | Add a key with an associated value to a BTreeMap
Public method | Add(Key, Value, Byte) | Adds a key and value to the map and returns a value that indicates if it was successfully added
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Add Method (Key)

BTreeBaseKey, ValueAdd Method (Key)

Adds an element to the set and returns a value that indicates if it was successfully added

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    Key key
)
Public Function Add (
    key As Key
) As Boolean
public:
virtual bool Add(
    Key key
) sealed
abstract Add :
        key : 'Key -> bool
override Add :
        key : 'Key -> bool

Parameters

key
Type: Key
The object being added

Return Value

Type: Boolean
true if an element was added; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
Add Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Add Method (Key, Value)

BTreeBaseKey, ValueAdd Method (Key, Value)

Add a key with an associated value to a BTreeMap

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Key key,
    Value value
)
Public Sub Add (
    key As Key,
    value As Value
)
public:
virtual void Add(
    Key key,
    Value value
) sealed
abstract Add :
        key : 'Key *
        value : 'Value -> unit
override Add :
        key : 'Key *
        value : 'Value -> unit

Parameters

key
Type: Key
The key added
value
Type: Value
The associated value added
See Also

Reference

BTreeBaseKey, Value Class
Add Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Add Method (Key, Value, Byte[])

BTreeBaseKey, ValueAdd Method (Key, Value, Byte)

Adds a key and value to the map and returns a value that indicates if it was successfully added

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Key key,
    Value value,
    byte[] comparisonArrayIn
)
Public Sub Add (
    key As Key,
    value As Value,
    comparisonArrayIn As Byte()
)
public:
void Add(
    Key key,
    Value value,
    array<unsigned char>^ comparisonArrayIn
)
member Add :
        key : 'Key *
        value : 'Value *
        comparisonArrayIn : byte[] -> unit

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Add(`0,`1,System.Byte[])"]

value
Type: Value

[Missing <param name="value"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Add(`0,`1,System.Byte[])"]

comparisonArrayIn
Type: SystemByte

[Missing <param name="comparisonArrayIn"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Add(`0,`1,System.Byte[])"]

Return Value

Type:
true if an element was added; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
Add Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).AddFast Method

BTreeBaseKey, ValueAddFast Method

Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is committed and/or flushed to disk or when the array is full. The array size is by default currently BTreeAddFastTransientBatchSize but you can get/set the desired size with TransientBatchSize

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void AddFast(
    Key key
)
Public Sub AddFast (
    key As Key
)
public:
void AddFast(
    Key key
)
member AddFast :
        key : 'Key -> unit

Parameters

key
Type: Key
The object being added
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).AddWithComparisonArray Method

BTreeBaseKey, ValueAddWithComparisonArray Method

Adds an element to the set and returns a value that indicates if it was successfully added

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AddWithComparisonArray(
    Key key,
    byte[] comparisonArrayIn
)
Public Function AddWithComparisonArray (
    key As Key,
    comparisonArrayIn As Byte()
) As Boolean
public:
bool AddWithComparisonArray(
    Key key,
    array<unsigned char>^ comparisonArrayIn
)
member AddWithComparisonArray :
        key : 'Key *
        comparisonArrayIn : byte[] -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.AddWithComparisonArray(`0,System.Byte[])"]

comparisonArrayIn
Type: SystemByte

[Missing <param name="comparisonArrayIn"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.AddWithComparisonArray(`0,System.Byte[])"]

Return Value

Type: Boolean
true if an element was added; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Clear Method

BTreeBaseKey, ValueClear Method

Removes all elements from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Contains Method

BTreeBaseKey, ValueContains Method

Overload List
 | Name | Description
Public method | Contains(Key) | Determines whether the set contains a specific element.
Public method | Contains(Key, Byte) | Determines whether the set contains a specific element.
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Contains Method (Key)

BTreeBaseKey, ValueContains Method (Key)

Determines whether the set contains a specific element.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Key key
)
Public Function Contains (
    key As Key
) As Boolean
public:
virtual bool Contains(
    Key key
) sealed
abstract Contains :
        key : 'Key -> bool
override Contains :
        key : 'Key -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Contains(`0)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Contains(`0)"]

See Also

Reference

BTreeBaseKey, Value Class
Contains Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Contains Method (Key, Byte[])

BTreeBaseKey, ValueContains Method (Key, Byte)

Determines whether the set contains a specific element.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Key key,
    byte[] comparisonArray
)
Public Function Contains (
    key As Key,
    comparisonArray As Byte()
) As Boolean
public:
bool Contains(
    Key key,
    array<unsigned char>^ comparisonArray
)
member Contains :
        key : 'Key *
        comparisonArray : byte[] -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Contains(`0,System.Byte[])"]

comparisonArray
Type: SystemByte

[Missing <param name="comparisonArray"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Contains(`0,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Contains(`0,System.Byte[])"]

See Also

Reference

BTreeBaseKey, Value Class
Contains Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).CopyTo Method

BTreeBaseKey, ValueCopyTo Method

Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    Key[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    array As Key(),
    arrayIndex As Integer,
    count As Integer
)
public:
void CopyTo(
    array<Key>^ array,
    int arrayIndex,
    int count
)
member CopyTo :
        array : 'Key[] *
        arrayIndex : int *
        count : int -> unit

Parameters

array
Type: Key
The one-dimensional Array that is the destination of the elements copied from BTreeBase. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in the array at which copying begins.
count
Type: SystemInt32
The number of elements to copy.
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).FlushTransients Method

BTreeBaseKey, ValueFlushTransients Method

Adds all queued up to be added objects after presorting them transiently

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushTransients()
Public Overrides Sub FlushTransients
public:
virtual void FlushTransients() override
abstract FlushTransients : unit -> unit
override FlushTransients : unit -> unit

Implements

IOptimizedPersistableFlushTransients
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).GetEnumerator Method

BTreeBaseKey, ValueGetEnumerator Method

Enumerates all contained Key objects in sorted order

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<Key> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Key)
public:
virtual IEnumerator<Key>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'Key>
override GetEnumerator : unit -> IEnumerator<'Key>

Return Value

Type: IEnumerator Key

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).GetKeyId Method

BTreeBaseKey, ValueGetKeyId Method

Overload List
 | Name | Description
Public method | GetKeyId(Key) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Public method | GetKeyId(Key, Byte) | When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).GetKeyId Method (Key)

BTreeBaseKey, ValueGetKeyId Method (Key)

When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetKeyId(
    Key key
)
Public Function GetKeyId (
    key As Key
) As ULong
public:
unsigned long long GetKeyId(
    Key key
)
member GetKeyId :
        key : 'Key -> uint64

Parameters

key
Type: Key
Transient lookup object of type Key (which in this case must be implementing IOptimizedPersistable

Return Value

Type: UInt64
The Id of the corresponding persistent object or 0 if not persistent or not implementing IOptimizedPersistable
See Also

Reference

BTreeBaseKey, Value Class
GetKeyId Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).GetKeyId Method (Key, Byte[])

BTreeBaseKey, ValueGetKeyId Method (Key, Byte)

When Key type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired. To avoid opening the object, a comparison array which is flagged as complete key must be used.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetKeyId(
    Key key,
    byte[] comparisonArray
)
Public Function GetKeyId (
    key As Key,
    comparisonArray As Byte()
) As ULong
public:
unsigned long long GetKeyId(
    Key key,
    array<unsigned char>^ comparisonArray
)
member GetKeyId :
        key : 'Key *
        comparisonArray : byte[] -> uint64

Parameters

key
Type: Key
Transient lookup object of type Key (which in this case must be implementing IOptimizedPersistable
comparisonArray
Type: SystemByte
A byte containing bytes to be compared with.

Return Value

Type: UInt64
The Id of the corresponding persistent object or 0 if not persistent or not implementing IOptimizedPersistable
See Also

Reference

BTreeBaseKey, Value Class
GetKeyId Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).InitializeAfterRead Method

BTreeBaseKey, ValueInitializeAfterRead Method

Sets up some transient variables

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).InitializeAfterRecreate Method

BTreeBaseKey, ValueInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).InitNew Method

BTreeBaseKey, ValueInitNew Method

Internal use only

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void InitNew(
    SessionBase session,
    ushort maxEntriesPerNode,
    ushort comparisonArraySize,
    bool comparisonArrayIsCompleteKey,
    bool isMap
)
Public Sub InitNew (
    session As SessionBase,
    maxEntriesPerNode As UShort,
    comparisonArraySize As UShort,
    comparisonArrayIsCompleteKey As Boolean,
    isMap As Boolean
)
public:
void InitNew(
    SessionBase^ session,
    unsigned short maxEntriesPerNode,
    unsigned short comparisonArraySize,
    bool comparisonArrayIsCompleteKey,
    bool isMap
)
member InitNew :
        session : SessionBase *
        maxEntriesPerNode : uint16 *
        comparisonArraySize : uint16 *
        comparisonArrayIsCompleteKey : bool *
        isMap : bool -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.InitNew(VelocityDb.Session.SessionBase,System.UInt16,System.UInt16,System.Boolean,System.Boolean)"]

maxEntriesPerNode
Type: SystemUInt16

[Missing <param name="maxEntriesPerNode"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.InitNew(VelocityDb.Session.SessionBase,System.UInt16,System.UInt16,System.Boolean,System.Boolean)"]

comparisonArraySize
Type: SystemUInt16

[Missing <param name="comparisonArraySize"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.InitNew(VelocityDb.Session.SessionBase,System.UInt16,System.UInt16,System.Boolean,System.Boolean)"]

comparisonArrayIsCompleteKey
Type: SystemBoolean

[Missing <param name="comparisonArrayIsCompleteKey"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.InitNew(VelocityDb.Session.SessionBase,System.UInt16,System.UInt16,System.Boolean,System.Boolean)"]

isMap
Type: SystemBoolean

[Missing <param name="isMap"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.InitNew(VelocityDb.Session.SessionBase,System.UInt16,System.UInt16,System.Boolean,System.Boolean)"]

See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Iterator Method

BTreeBaseKey, ValueIterator Method

Initializes an iterator to find the keys of this set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual BTreeSetIterator<Key> Iterator()
Public Overridable Function Iterator As BTreeSetIterator(Of Key)
public:
virtual BTreeSetIterator<Key>^ Iterator()
abstract Iterator : unit -> BTreeSetIterator<'Key>
override Iterator : unit -> BTreeSetIterator<'Key>

Return Value

Type: BTreeSetIterator Key

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Iterator"]

See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Remove Method

BTreeBaseKey, ValueRemove Method

Overload List
 | Name | Description
Public method | Remove(Key) | Removes a specified item from the set.
Public method | Remove(Key, Byte) | Removes a specified item from the set.
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Remove Method (Key)

BTreeBaseKey, ValueRemove Method (Key)

Removes a specified item from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    Key key
)
Public Function Remove (
    key As Key
) As Boolean
public:
virtual bool Remove(
    Key key
) sealed
abstract Remove :
        key : 'Key -> bool
override Remove :
        key : 'Key -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Remove(`0)"]

Return Value

Type: Boolean
true if an element was removed; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
Remove Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).Remove Method (Key, Byte[])

BTreeBaseKey, ValueRemove Method (Key, Byte)

Removes a specified item from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    Key key,
    byte[] comparisonArray
)
Public Function Remove (
    key As Key,
    comparisonArray As Byte()
) As Boolean
public:
bool Remove(
    Key key,
    array<unsigned char>^ comparisonArray
)
member Remove :
        key : 'Key *
        comparisonArray : byte[] -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Remove(`0,System.Byte[])"]

comparisonArray
Type: SystemByte

[Missing <param name="comparisonArray"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.Remove(`0,System.Byte[])"]

Return Value

Type: Boolean
true if an element was removed; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
Remove Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).SearchTransients Method

BTreeBaseKey, ValueSearchTransients Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.SearchTransients(`0,`0@)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SearchTransients(
    Key key,
    ref Key value
)
Public Overridable Function SearchTransients (
    key As Key,
    ByRef value As Key
) As Boolean
public:
virtual bool SearchTransients(
    Key key,
    Key% value
)
abstract SearchTransients :
        key : 'Key *
        value : 'Key byref -> bool
override SearchTransients :
        key : 'Key *
        value : 'Key byref -> bool

Parameters

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.SearchTransients(`0,`0@)"]

value
Type: Key

[Missing <param name="value"/> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.SearchTransients(`0,`0@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeBase`2.SearchTransients(`0,`0@)"]

See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).TryGetKey Method

BTreeBaseKey, ValueTryGetKey Method

Overload List
 | Name | Description
Public method | TryGetKey(Key, Key) | Gets the value matching persistent key with the specified key.
Public method | TryGetKey(Key, Byte, Key) | Gets the value associated with the specified key.
Top
See Also

Reference

BTreeBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).TryGetKey Method (Key, Key)

BTreeBaseKey, ValueTryGetKey Method (Key, Key)

Gets the value matching persistent key with the specified key.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetKey(
    Key key,
    ref Key value
)
Public Function TryGetKey (
    key As Key,
    ByRef value As Key
) As Boolean
public:
bool TryGetKey(
    Key key,
    Key% value
)
member TryGetKey :
        key : 'Key *
        value : 'Key byref -> bool

Parameters

key
Type: Key
The key of the value to get.
value
Type: Key
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the set contains an element with the specified key; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
TryGetKey Overload
VelocityDb.Collection.BTree Namespace


BTreeBase(Key, Value).TryGetKey Method (Key, Byte[], Key)

BTreeBaseKey, ValueTryGetKey Method (Key, Byte, Key)

Gets the value associated with the specified key.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetKey(
    Key key,
    byte[] comparisonArray,
    ref Key value
)
Public Function TryGetKey (
    key As Key,
    comparisonArray As Byte(),
    ByRef value As Key
) As Boolean
public:
bool TryGetKey(
    Key key,
    array<unsigned char>^ comparisonArray,
    Key% value
)
member TryGetKey :
        key : 'Key *
        comparisonArray : byte[] *
        value : 'Key byref -> bool

Parameters

key
Type: Key
The key of the value to get.
comparisonArray
Type: SystemByte
The comparison array associated with the key to get.
value
Type: Key
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the BTreeBase(Of Key) contains an element with the specified key; otherwise, false.
See Also

Reference

BTreeBaseKey, Value Class
TryGetKey Overload
VelocityDb.Collection.BTree Namespace


BTreeByteArray Class

Wrapper object for a byte[] of data for comparing objects within a BTreeSet. Wrapper is used so that this data can be placed on a seperate Page
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeByteArray

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeByteArray : OptimizedPersistable
<SerializableAttribute>
Public Class BTreeByteArray
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class BTreeByteArray : public OptimizedPersistable
[<SerializableAttribute>]
type BTreeByteArray =
    class
        inherit OptimizedPersistable
    end

The BTreeByteArray type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | We do want to cache this kind of object since they are likely to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | ObjectsPerPage | Place this type of of object on its own page (Overrides OptimizedPersistableObjectsPerPage.)
Public property | PagesPerDatabase | Use the max limit for this type (Overrides OptimizedPersistablePagesPerDatabase.)
Top
Methods
 | Name | Description
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeByteArray Properties

The BTreeByteArray type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | We do want to cache this kind of object since they are likely to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | ObjectsPerPage | Place this type of of object on its own page (Overrides OptimizedPersistableObjectsPerPage.)
Public property | PagesPerDatabase | Use the max limit for this type (Overrides OptimizedPersistablePagesPerDatabase.)
Top
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray.AllowOtherTypesOnSamePage Property

BTreeByteArrayAllowOtherTypesOnSamePage Property

We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray.Cache Property

BTreeByteArrayCache Property

We do want to cache this kind of object since they are likely to be frequently used.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray.ObjectsPerPage Property

BTreeByteArrayObjectsPerPage Property

Place this type of of object on its own page

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Return Value

Type: UInt16
The default maximum number of objects per page

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray.PagesPerDatabase Property

BTreeByteArrayPagesPerDatabase Property

Use the max limit for this type

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort PagesPerDatabase { get; }
Public Overrides ReadOnly Property PagesPerDatabase As UShort
    Get
public:
virtual property unsigned short PagesPerDatabase {
    unsigned short get () override;
}
abstract PagesPerDatabase : uint16 with get
override PagesPerDatabase : uint16 with get

Return Value

Type: UInt16
The choosen limit

Implements

IOptimizedPersistablePagesPerDatabase
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray Methods

The BTreeByteArray type exposes the following members.

Methods
 | Name | Description
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeByteArray.ReadMe Method

BTreeByteArrayReadMe Method

Used by code generator

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
memberBytes
Type: SystemByte
offset
Type: SystemInt32
session
Type: VelocityDb.SessionSessionBase
page
Type: VelocityDbPage
useOidShort
Type: SystemBoolean
schema
Type: VelocityDb.TypeInfoSchema
openRefs
Type: SystemBoolean
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
graphDepth
Type: SystemInt32
graphDepthToLoad
Type: SystemInt32
primitivesOnly
Type: SystemBoolean

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

BTreeByteArray Class
VelocityDb.Collection.BTree Namespace


BTreeInternal(Key, Value) Class

BTreeInternalKey, Value Class

Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeInternalBase Key, Value
VelocityDb.Collection.BTreeBTreeInternalKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeInternal<Key, Value> : BTreeInternalBase<Key, Value>

<SerializableAttribute>
Public Class BTreeInternal(Of Key, Value)
    Inherits BTreeInternalBase(Of Key, Value)
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeInternal : public BTreeInternalBase<Key, Value>
[<SerializableAttribute>]
type BTreeInternal<'Key, 'Value> =
    class
        inherit BTreeInternalBase<'Key, 'Value>
    end

Type Parameters

Key
The key type of this collection
Value
The value type of this collection

The BTreeInternalKey, Value type exposes the following members.

Methods
 | Name | Description
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeInternal(Key, Value) Methods

BTreeInternalKey, Value Methods

The BTreeInternalKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeInternalKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeInternal(Key, Value).InitializeAfterRead Method

BTreeInternalKey, ValueInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeInternal`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeInternal`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeInternalKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeInternalBase(Key, Value) Class

BTreeInternalBaseKey, Value Class

Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeInternalBaseKey, Value
VelocityDb.Collection.BTreeBTreeInternalKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BTreeInternalBase<Key, Value> : BTreeNode

<SerializableAttribute>
Public MustInherit Class BTreeInternalBase(Of Key, Value)
    Inherits BTreeNode
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeInternalBase abstract : public BTreeNode
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BTreeInternalBase<'Key, 'Value> =
    class
        inherit BTreeNode
    end

Type Parameters

Key
The key type of this collection
Value
The value type of this collection

The BTreeInternalBaseKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | Cache | We do want to cache this kind of object since they are likly to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | NodeSize | Gets size of node (how many child nodes this node has)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeInternalBase(Key, Value) Properties

BTreeInternalBaseKey, Value Properties

The BTreeInternalBaseKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Cache | We do want to cache this kind of object since they are likly to be frequently used. (Overrides OptimizedPersistableCache.)
Public property | NodeSize | Gets size of node (how many child nodes this node has)
Top
See Also

Reference

BTreeInternalBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeInternalBase(Key, Value).Cache Property

BTreeInternalBaseKey, ValueCache Property

We do want to cache this kind of object since they are likly to be frequently used.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

BTreeInternalBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeInternalBase(Key, Value).NodeSize Property

BTreeInternalBaseKey, ValueNodeSize Property

Gets size of node (how many child nodes this node has)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int NodeSize { get; }
Public ReadOnly Property NodeSize As Integer
    Get
public:
property int NodeSize {
    int get ();
}
member NodeSize : int with get

Property Value

Type: Int32
See Also

Reference

BTreeInternalBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeInternalBase(Key, Value) Methods

BTreeInternalBaseKey, Value Methods

The BTreeInternalBaseKey, Value generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeInternalBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeaf(Key, Value) Class

BTreeLeafKey, Value Class

Creates a leaf level node in the BTree
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeLeafBase Key, Value
VelocityDb.Collection.BTreeBTreeLeafKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeLeaf<Key, Value> : BTreeLeafBase<Key, Value>

<SerializableAttribute>
Public Class BTreeLeaf(Of Key, Value)
    Inherits BTreeLeafBase(Of Key, Value)
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeLeaf : public BTreeLeafBase<Key, Value>
[<SerializableAttribute>]
type BTreeLeaf<'Key, 'Value> =
    class
        inherit BTreeLeafBase<'Key, 'Value>
    end

Type Parameters

Key
Type of keys used
Value
Type of Values used

The BTreeLeafKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides BTreeLeafBaseKey, ValueCache.)
Public property | ObjectsPerPage | (Overrides BTreeLeafBaseKey, ValueObjectsPerPage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeLeaf(Key, Value) Properties

BTreeLeafKey, Value Properties

The BTreeLeafKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides BTreeLeafBaseKey, ValueCache.)
Public property | ObjectsPerPage | (Overrides BTreeLeafBaseKey, ValueObjectsPerPage.)
Top
See Also

Reference

BTreeLeafKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeaf(Key, Value).Cache Property

BTreeLeafKey, ValueCache Property

By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

BTreeLeafKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeaf(Key, Value).ObjectsPerPage Property

BTreeLeafKey, ValueObjectsPerPage Property

[Missing <summary> documentation for "P:VelocityDb.Collection.BTree.BTreeLeaf`2.ObjectsPerPage"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

BTreeLeafKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeaf(Key, Value) Methods

BTreeLeafKey, Value Methods

The BTreeLeafKey, Value generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeLeafKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value) Class

BTreeLeafBaseKey, Value Class

Internal class used with BTreeSet and BTreeMap
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeLeafBaseKey, Value
VelocityDb.Collection.BTreeBTreeLeafKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BTreeLeafBase<Key, Value> : BTreeNode

<SerializableAttribute>
Public MustInherit Class BTreeLeafBase(Of Key, Value)
    Inherits BTreeNode
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeLeafBase abstract : public BTreeNode
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BTreeLeafBase<'Key, 'Value> =
    class
        inherit BTreeNode
    end

Type Parameters

Key
key type
Value
value type

The BTreeLeafBaseKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides OptimizedPersistableCache.)
Public property | FlushIfPageFull | We don't want to flush other BTreeLeaf pages while looking for a placement page (Overrides OptimizedPersistableFlushIfPageFull.)
Public property | KeysCount | Get the number of keys that are in use for this leaf node.
Public property | ObjectsPerPage | (Overrides OptimizedPersistableObjectsPerPage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value) Properties

BTreeLeafBaseKey, Value Properties

The BTreeLeafBaseKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides OptimizedPersistableCache.)
Public property | FlushIfPageFull | We don't want to flush other BTreeLeaf pages while looking for a placement page (Overrides OptimizedPersistableFlushIfPageFull.)
Public property | KeysCount | Get the number of keys that are in use for this leaf node.
Public property | ObjectsPerPage | (Overrides OptimizedPersistableObjectsPerPage.)
Top
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value).AllowOtherTypesOnSamePage Property

BTreeLeafBaseKey, ValueAllowOtherTypesOnSamePage Property

[Missing <summary> documentation for "P:VelocityDb.Collection.BTree.BTreeLeafBase`2.AllowOtherTypesOnSamePage"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value).Cache Property

BTreeLeafBaseKey, ValueCache Property

By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value).FlushIfPageFull Property

BTreeLeafBaseKey, ValueFlushIfPageFull Property

We don't want to flush other BTreeLeaf pages while looking for a placement page

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool FlushIfPageFull { get; }
Public Overrides ReadOnly Property FlushIfPageFull As Boolean
    Get
public:
virtual property bool FlushIfPageFull {
    bool get () override;
}
abstract FlushIfPageFull : bool with get
override FlushIfPageFull : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableFlushIfPageFull
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value).KeysCount Property

BTreeLeafBaseKey, ValueKeysCount Property

Get the number of keys that are in use for this leaf node.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort KeysCount { get; }
Public ReadOnly Property KeysCount As UShort
    Get
public:
property unsigned short KeysCount {
    unsigned short get ();
}
member KeysCount : uint16 with get

Property Value

Type: UInt16
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value).ObjectsPerPage Property

BTreeLeafBaseKey, ValueObjectsPerPage Property

[Missing <summary> documentation for "P:VelocityDb.Collection.BTree.BTreeLeafBase`2.ObjectsPerPage"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeLeafBase(Key, Value) Methods

BTreeLeafBaseKey, Value Methods

The BTreeLeafBaseKey, Value generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeLeafBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value) Class

BTreeMapKey, Value Class

Represents a collection of keys that is maintained in sorted order. Each key has an associated value. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time. Exceptions are ValueType keys and values.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBase Key, Value
VelocityDb.Collection.BTreeBTreeMapBase Key, Value
VelocityDb.Collection.BTreeBTreeMapKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeMap<Key, Value> : BTreeMapBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>,
    IDictionary<Key, Value>, ICollection<KeyValuePair<Key, Value>>

<SerializableAttribute>
Public Class BTreeMap(Of Key, Value)
    Inherits BTreeMapBase(Of Key, Value)
    Implements IEnumerable(Of KeyValuePair(Of Key, Value)),
    IEnumerable, IEnumerable(Of Key), IDictionary(Of Key, Value),
    ICollection(Of KeyValuePair(Of Key, Value))
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeMap : public BTreeMapBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>,
    IDictionary<Key, Value>, ICollection<KeyValuePair<Key, Value>>
[<SerializableAttribute>]
type BTreeMap<'Key, 'Value> =
    class
        inherit BTreeMapBase<'Key, 'Value>
        interface IEnumerable<KeyValuePair<'Key, 'Value>>
        interface IEnumerable
        interface IEnumerable<'Key>
        interface IDictionary<'Key, 'Value>
        interface ICollection<KeyValuePair<'Key, 'Value>>
    end

Type Parameters

Key
The key type of objects in this BTreeMap
Value
The value type of objects in this BTreeMap

The BTreeMapKey, Value type exposes the following members.

Constructors
 | Name | Description
Public method | BTreeMapKey, Value | Creates a new BTreeSet
Top
Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? NO it does not. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | CopyTo | Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value) Constructor

BTreeMapKey, Value Constructor

Creates a new BTreeSet

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMap(
    VelocityDbComparer<Key> comparer,
    SessionBase session,
    ushort maxEntriesPerNode = 10000,
    ushort comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key),
    session As SessionBase,
    Optional maxEntriesPerNode As UShort = 10000,
    Optional comparisonArraySize As UShort = 0,
    Optional comparisonArrayIsCompleteKey As Boolean = false
)
public:
BTreeMap(
    VelocityDbComparer<Key>^ comparer,
    SessionBase^ session,
    unsigned short maxEntriesPerNode = 10000,
    unsigned short comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
new :
        comparer : VelocityDbComparer<'Key> *
        session : SessionBase *
        ?maxEntriesPerNode : uint16 *
        ?comparisonArraySize : uint16 *
        ?comparisonArrayIsCompleteKey : bool
(* Defaults:
        let _maxEntriesPerNode = defaultArg maxEntriesPerNode 10000
        let _comparisonArraySize = defaultArg comparisonArraySize 0
        let _comparisonArrayIsCompleteKey = defaultArg comparisonArrayIsCompleteKey false
*)
-> BTreeMap

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
An object comparer. Try using CompareByField
session
Type: VelocityDb.SessionSessionBase
The session managing this object
maxEntriesPerNode (Optional)
Type: SystemUInt16
Determines internal array and Page sizes
comparisonArraySize (Optional)
Type: SystemUInt16
Determine how many bytes to reserve for each object within a BTree node as a way to avoid actual object compares.
comparisonArrayIsCompleteKey (Optional)
Type: SystemBoolean
If the comparison array bytes are all that needs to be compared to determine ordering then set this to true; otherwise false
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value) Properties

BTreeMapKey, Value Properties

The BTreeMapKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? NO it does not. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).Comparer Property

BTreeMapKey, ValueComparer Property

Gets the VelocityDbComparer object that is used to compare Key objects.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).Keys Property

BTreeMapKey, ValueKeys Property

Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ICollection<Key> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of Key)
    Get
public:
virtual property ICollection<Key>^ Keys {
    ICollection<Key>^ get () sealed;
}
abstract Keys : ICollection<'Key> with get
override Keys : ICollection<'Key> with get

Return Value

Type: ICollection Key
An ICollectionT containing the keys of the object that implements IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).UsesOidShort Property

BTreeMapKey, ValueUsesOidShort Property

Does this BTree use short object references (32 bit) for its internal references? NO it does not.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UsesOidShort { get; }
Public Overrides ReadOnly Property UsesOidShort As Boolean
    Get
public:
virtual property bool UsesOidShort {
    bool get () override;
}
abstract UsesOidShort : bool with get
override UsesOidShort : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value) Methods

BTreeMapKey, Value Methods

The BTreeMapKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | CopyTo | Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).Clear Method

BTreeMapKey, ValueClear Method

Removes all elements from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).CopyTo Method

BTreeMapKey, ValueCopyTo Method

Copies a range of elements from the BTreeBase to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    KeyValuePair<Key, Value>[] array,
    int arrayIndex,
    int count
)
Public Sub CopyTo (
    array As KeyValuePair(Of Key, Value)(),
    arrayIndex As Integer,
    count As Integer
)
public:
void CopyTo(
    array<KeyValuePair<Key, Value>>^ array,
    int arrayIndex,
    int count
)
member CopyTo :
        array : KeyValuePair<'Key, 'Value>[] *
        arrayIndex : int *
        count : int -> unit

Parameters

array
Type: System.Collections.GenericKeyValuePair Key, Value
The one-dimensional Array that is the destination of the elements copied from BTreeBase. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in the array at which copying begins.
count
Type: SystemInt32
The number of elements to copy.
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMap(Key, Value).InitializeAfterRead Method

BTreeMapKey, ValueInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeMap`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeMap`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeMapKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value) Class

BTreeMapBaseKey, Value Class

Represents a collection of objects that is maintained in sorted order.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBase Key, Value
VelocityDb.Collection.BTreeBTreeMapBaseKey, Value
VelocityDb.Collection.BTreeBTreeMapKey, Value
VelocityDb.Collection.BTreeBTreeMapOidShortKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BTreeMapBase<Key, Value> : BTreeBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>

<SerializableAttribute>
Public MustInherit Class BTreeMapBase(Of Key, Value)
    Inherits BTreeBase(Of Key, Value)
    Implements IEnumerable(Of KeyValuePair(Of Key, Value)),
    IEnumerable, IEnumerable(Of Key)
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeMapBase abstract : public BTreeBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BTreeMapBase<'Key, 'Value> =
    class
        inherit BTreeBase<'Key, 'Value>
        interface IEnumerable<KeyValuePair<'Key, 'Value>>
        interface IEnumerable
        interface IEnumerable<'Key>
    end

Type Parameters

Key
The type of key objects in this BTree
Value
The type of value objects in a BTreeMap or BTreeMapOidShort

The BTreeMapBaseKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | Item | Given a lookup key, returns the corresponding value within the map or null if not found
Public property | TransientBatchSize | Get/Set the max batch size used in API such as AddFast(Key) (Overrides BTreeBaseKey, ValueTransientBatchSize.)
Public property | ValuePlacement | Set the value placement to be used for all value objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key, Value)
Public property | Values | Gets a collection containing the values of this object
Top
Methods
 | Name | Description
Public method | AddFast | Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is commited and/or flushed to disk or when the array is full. The array size is by default currently [!:BTreeBase<Key, Value>.transientBatchBufferDefaultSize] but you can get/set the desired size with TransientBatchSize
Public method | EnumerateValues | Enumerates all contained Value objects in corresponding key sorted order
Public method | FlushTransients | Adds all queued up to be added objects after presorting them transiently (Overrides BTreeBaseKey, ValueFlushTransients.)
Public method | GetEnumerator | Enumerates all contained Key objects in sorted order
Public method | GetValueId(Key) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Public method | GetValueId(Key, Byte) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Public method | Iterator | Initializes an iterator to find the keys and values of this map
Public method | Last | Returns the last KeyValue object in this set.
Public method | LastValue | Returns the last value in this map.
Public method | TryGetValue(Key, Value) | Gets the value associated with the specified key.
Public method | TryGetValue(Key, Byte, Value) | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value) Properties

BTreeMapBaseKey, Value Properties

The BTreeMapBaseKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Given a lookup key, returns the corresponding value within the map or null if not found
Public property | TransientBatchSize | Get/Set the max batch size used in API such as AddFast(Key) (Overrides BTreeBaseKey, ValueTransientBatchSize.)
Public property | ValuePlacement | Set the value placement to be used for all value objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key, Value)
Public property | Values | Gets a collection containing the values of this object
Top
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).Item Property

BTreeMapBaseKey, ValueItem Property

Given a lookup key, returns the corresponding value within the map or null if not found

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Value this[
    Key key
] { get; set; }
Public Default Property Item (
    key As Key
) As Value
    Get
    Set
public:
virtual property Value default[Key key] {
    Value get (Key key) sealed;
    void set (Key key, Value value) sealed;
}
abstract Item : 'Value with get, set
override Item : 'Value with get, set

Parameters

key
Type: Key
The lookup key

Return Value

Type: Value
The value matching the lookup key or null if not found
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).TransientBatchSize Property

BTreeMapBaseKey, ValueTransientBatchSize Property

Get/Set the max batch size used in API such as AddFast(Key)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint TransientBatchSize { get; set; }
Public Overrides Property TransientBatchSize As UInteger
    Get
    Set
public:
virtual property unsigned int TransientBatchSize {
    unsigned int get () override;
    void set (unsigned int value) override;
}
abstract TransientBatchSize : uint32 with get, set
override TransientBatchSize : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).ValuePlacement Property

BTreeMapBaseKey, ValueValuePlacement Property

Set the value placement to be used for all value objects added to this. This setting is not persisted, it is mainly to be used with objects added with AddFast(Key, Value)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Placement ValuePlacement { get; set; }
Public Property ValuePlacement As Placement
    Get
    Set
public:
property Placement^ ValuePlacement {
    Placement^ get ();
    void set (Placement^ value);
}
member ValuePlacement : Placement with get, set

Property Value

Type: Placement
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).Values Property

BTreeMapBaseKey, ValueValues Property

Gets a collection containing the values of this object

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ICollection<Value> Values { get; }
Public ReadOnly Property Values As ICollection(Of Value)
    Get
public:
virtual property ICollection<Value>^ Values {
    ICollection<Value>^ get () sealed;
}
abstract Values : ICollection<'Value> with get
override Values : ICollection<'Value> with get

Property Value

Type: ICollection Value
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value) Methods

BTreeMapBaseKey, Value Methods

The BTreeMapBaseKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | AddFast | Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is commited and/or flushed to disk or when the array is full. The array size is by default currently [!:BTreeBase<Key, Value>.transientBatchBufferDefaultSize] but you can get/set the desired size with TransientBatchSize
Public method | EnumerateValues | Enumerates all contained Value objects in corresponding key sorted order
Public method | FlushTransients | Adds all queued up to be added objects after presorting them transiently (Overrides BTreeBaseKey, ValueFlushTransients.)
Public method | GetEnumerator | Enumerates all contained Key objects in sorted order
Public method | GetValueId(Key) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Public method | GetValueId(Key, Byte) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Public method | Iterator | Initializes an iterator to find the keys and values of this map
Public method | Last | Returns the last KeyValue object in this set.
Public method | LastValue | Returns the last value in this map.
Public method | TryGetValue(Key, Value) | Gets the value associated with the specified key.
Public method | TryGetValue(Key, Byte, Value) | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).AddFast Method

BTreeMapBaseKey, ValueAddFast Method

Adds an element to an array of to be added objects. The objects in this array are added when a call toFlushTransients is triggered by multiple events such as calling Count and when collection is commited and/or flushed to disk or when the array is full. The array size is by default currently [!:BTreeBase<Key, Value>.transientBatchBufferDefaultSize] but you can get/set the desired size with TransientBatchSize

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void AddFast(
    Key key,
    Value value
)
Public Sub AddFast (
    key As Key,
    value As Value
)
public:
void AddFast(
    Key key,
    Value value
)
member AddFast :
        key : 'Key *
        value : 'Value -> unit

Parameters

key
Type: Key
The object beeing added
value
Type: Value
The associated value added
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).EnumerateValues Method

BTreeMapBaseKey, ValueEnumerateValues Method

Enumerates all contained Value objects in corresponding key sorted order

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Value> EnumerateValues()
Public Function EnumerateValues As IEnumerable(Of Value)
public:
IEnumerable<Value>^ EnumerateValues()
member EnumerateValues : unit -> IEnumerable<'Value>

Return Value

Type: IEnumerable Value
The enumeration
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).FlushTransients Method

BTreeMapBaseKey, ValueFlushTransients Method

Adds all queued up to be added objects after presorting them transiently

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushTransients()
Public Overrides Sub FlushTransients
public:
virtual void FlushTransients() override
abstract FlushTransients : unit -> unit
override FlushTransients : unit -> unit

Implements

IOptimizedPersistableFlushTransients
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).GetEnumerator Method

BTreeMapBaseKey, ValueGetEnumerator Method

Enumerates all contained Key objects in sorted order

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<KeyValuePair<Key, Value>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Key, Value))
public:
IEnumerator<KeyValuePair<Key, Value>>^ GetEnumerator()
member GetEnumerator : unit -> IEnumerator<KeyValuePair<'Key, 'Value>>

Return Value

Type: IEnumerator KeyValuePair Key, Value

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeMapBase`2.GetEnumerator"]

See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).GetValueId Method

BTreeMapBaseKey, ValueGetValueId Method

Overload List
 | Name | Description
Public method | GetValueId(Key) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Public method | GetValueId(Key, Byte) | When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.
Top
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).GetValueId Method (Key)

BTreeMapBaseKey, ValueGetValueId Method (Key)

When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetValueId(
    Key key
)
Public Function GetValueId (
    key As Key
) As ULong
public:
unsigned long long GetValueId(
    Key key
)
member GetValueId :
        key : 'Key -> uint64

Parameters

key
Type: Key
Lookup object of type Key where Value must be implementing IOptimizedPersistable

Return Value

Type: UInt64
The Id of the corresponding value object or 0 if not persistant or not mplementing IOptimizedPersistable
See Also

Reference

BTreeMapBaseKey, Value Class
GetValueId Overload
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).GetValueId Method (Key, Byte[])

BTreeMapBaseKey, ValueGetValueId Method (Key, Byte)

When Value type implements IOptimizedPersistable, you can use this function to get the Id of the persistent object instead of the entire object. Use for performance reasons in certain cases where reading the object isn't desired.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetValueId(
    Key key,
    byte[] comparisonArray
)
Public Function GetValueId (
    key As Key,
    comparisonArray As Byte()
) As ULong
public:
unsigned long long GetValueId(
    Key key,
    array<unsigned char>^ comparisonArray
)
member GetValueId :
        key : 'Key *
        comparisonArray : byte[] -> uint64

Parameters

key
Type: Key
Lookup object of type Key where Value must be implementing IOptimizedPersistable
comparisonArray
Type: SystemByte
A byte containing bytes to be compared with.

Return Value

Type: UInt64
The Id of the corresponding value object or 0 if not persistant or not mplementing IOptimizedPersistable
See Also

Reference

BTreeMapBaseKey, Value Class
GetValueId Overload
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).Iterator Method

BTreeMapBaseKey, ValueIterator Method

Initializes an iterator to find the keys and values of this map

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMapIterator<Key, Value> Iterator()
Public Function Iterator As BTreeMapIterator(Of Key, Value)
public:
BTreeMapIterator<Key, Value>^ Iterator()
member Iterator : unit -> BTreeMapIterator<'Key, 'Value>

Return Value

Type: BTreeMapIterator Key, Value
An iterator
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).Last Method

BTreeMapBaseKey, ValueLast Method

Returns the last KeyValue object in this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<Key, Value> Last()
Public Function Last As KeyValuePair(Of Key, Value)
public:
KeyValuePair<Key, Value> Last()
member Last : unit -> KeyValuePair<'Key, 'Value>

Return Value

Type: KeyValuePair Key, Value
The last KeyValue in the collection according to the sort order used
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).LastValue Method

BTreeMapBaseKey, ValueLastValue Method

Returns the last value in this map.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Value LastValue()
Public Function LastValue As Value
public:
Value LastValue()
member LastValue : unit -> 'Value

Return Value

Type: Value
The last value in the collection according to the sort order used
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).TryGetValue Method

BTreeMapBaseKey, ValueTryGetValue Method

Overload List
 | Name | Description
Public method | TryGetValue(Key, Value) | Gets the value associated with the specified key.
Public method | TryGetValue(Key, Byte, Value) | Gets the value associated with the specified key.
Top
See Also

Reference

BTreeMapBaseKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).TryGetValue Method (Key, Value)

BTreeMapBaseKey, ValueTryGetValue Method (Key, Value)

Gets the value associated with the specified key.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    Key key,
    out Value value
)
Public Function TryGetValue (
    key As Key,
    <OutAttribute> ByRef value As Value
) As Boolean
public:
virtual bool TryGetValue(
    Key key,
    [OutAttribute] Value% value
) sealed
abstract TryGetValue :
        key : 'Key *
        value : 'Value byref -> bool
override TryGetValue :
        key : 'Key *
        value : 'Value byref -> bool

Parameters

key
Type: Key
The key of the value to get.
value
Type: Value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the set contains an element with the specified key; otherwise, false.
See Also

Reference

BTreeMapBaseKey, Value Class
TryGetValue Overload
VelocityDb.Collection.BTree Namespace


BTreeMapBase(Key, Value).TryGetValue Method (Key, Byte[], Value)

BTreeMapBaseKey, ValueTryGetValue Method (Key, Byte, Value)

Gets the value associated with the specified key.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetValue(
    Key key,
    byte[] comparisonArray,
    out Value value
)
Public Function TryGetValue (
    key As Key,
    comparisonArray As Byte(),
    <OutAttribute> ByRef value As Value
) As Boolean
public:
bool TryGetValue(
    Key key,
    array<unsigned char>^ comparisonArray,
    [OutAttribute] Value% value
)
member TryGetValue :
        key : 'Key *
        comparisonArray : byte[] *
        value : 'Value byref -> bool

Parameters

key
Type: Key
The key of the value to get.
comparisonArray
Type: SystemByte
The comparison array associated with the key to get.
value
Type: Value
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the BTreeBase(Of Key) contains an element with the specified key; otherwise, false.
See Also

Reference

BTreeMapBaseKey, Value Class
TryGetValue Overload
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value) Class

BTreeMapIteratorKey, Value Class

Iterates all the elements of a BTreeSet
Inheritance Hierarchy
SystemObject
VelocityDb.Collection.BTreeBTreeMapIteratorKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class BTreeMapIterator<Key, Value>

Public Class BTreeMapIterator(Of Key, Value)
generic<typename Key, typename Value>
public ref class BTreeMapIterator
type BTreeMapIterator<'Key, 'Value> =  class end

Type Parameters

Key
The key type of this collection
Value
The value type of this collection

The BTreeMapIteratorKey, Value type exposes the following members.

Properties
 | Name | Description
Public property | IndexInTree | Gets the index of the current iterator element in the iterated collection
Top
Methods
 | Name | Description
Public method | Current | The iterator current Key object
Public method | CurrentKey | Returns the Key at the current iterator position
Public method | CurrentValue | Returns the Value at the current iterator position
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Public method | GoToLast | Positions iterator at the last object in the set.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | MovePrevious | Advances the enumerator to the previous element of the map.
Public method | Next | Positions the iterator at the next KeyValuePair in the map. Only use this one with nullable Key type.
Public method | Previous | Positions the iterator at the previous Key in the set
Public method | ReplaceValue | Replaces a value in map
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value) Properties

BTreeMapIteratorKey, Value Properties

The BTreeMapIteratorKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | IndexInTree | Gets the index of the current iterator element in the iterated collection
Top
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).IndexInTree Property

BTreeMapIteratorKey, ValueIndexInTree Property

Gets the index of the current iterator element in the iterated collection

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long IndexInTree { get; }
Public ReadOnly Property IndexInTree As Long
    Get
public:
property long long IndexInTree {
    long long get ();
}
member IndexInTree : int64 with get

Property Value

Type: Int64
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value) Methods

BTreeMapIteratorKey, Value Methods

The BTreeMapIteratorKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Current | The iterator current Key object
Public method | CurrentKey | Returns the Key at the current iterator position
Public method | CurrentValue | Returns the Value at the current iterator position
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Public method | GoToLast | Positions iterator at the last object in the set.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | MovePrevious | Advances the enumerator to the previous element of the map.
Public method | Next | Positions the iterator at the next KeyValuePair in the map. Only use this one with nullable Key type.
Public method | Previous | Positions the iterator at the previous Key in the set
Public method | ReplaceValue | Replaces a value in map
Top
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).Current Method

BTreeMapIteratorKey, ValueCurrent Method

The iterator current Key object

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<Key, Value> Current()
Public Function Current As KeyValuePair(Of Key, Value)
public:
KeyValuePair<Key, Value> Current()
member Current : unit -> KeyValuePair<'Key, 'Value>

Return Value

Type: KeyValuePair Key, Value
The Ket at the current iterator position
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).CurrentKey Method

BTreeMapIteratorKey, ValueCurrentKey Method

Returns the Key at the current iterator position

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key CurrentKey()
Public Function CurrentKey As Key
public:
Key CurrentKey()
member CurrentKey : unit -> 'Key

Return Value

Type: Key
Key at current position
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).CurrentValue Method

BTreeMapIteratorKey, ValueCurrentValue Method

Returns the Value at the current iterator position

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Value CurrentValue()
Public Function CurrentValue As Value
public:
Value CurrentValue()
member CurrentValue : unit -> 'Value

Return Value

Type: Value
Value at current position
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).GoTo Method

BTreeMapIteratorKey, ValueGoTo Method

Overload List
 | Name | Description
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Top
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).GoTo Method (Key)

BTreeMapIteratorKey, ValueGoTo Method (Key)

Positions iterator at Key object or where Key would be inserted if added to the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool GoTo(
    Key key
)
Public Function GoTo (
    key As Key
) As Boolean
public:
bool GoTo(
    Key key
)
member GoTo :
        key : 'Key -> bool

Parameters

key
Type: Key
The object to position iterator near

Return Value

Type: Boolean
true if an exact match was found; otherwise false
See Also

Reference

BTreeMapIteratorKey, Value Class
GoTo Overload
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).GoTo Method (Key, Byte[])

BTreeMapIteratorKey, ValueGoTo Method (Key, Byte)

Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool GoTo(
    Key key,
    byte[] comparisonArray
)
Public Function GoTo (
    key As Key,
    comparisonArray As Byte()
) As Boolean
public:
bool GoTo(
    Key key,
    array<unsigned char>^ comparisonArray
)
member GoTo :
        key : 'Key *
        comparisonArray : byte[] -> bool

Parameters

key
Type: Key
The object to position iterator near
comparisonArray
Type: SystemByte
Contains bytes used for comparing with other arrays for NodeKeys within the set

Return Value

Type: Boolean
true if an exact match was found; otherwise false
See Also

Reference

BTreeMapIteratorKey, Value Class
GoTo Overload
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).GoToLast Method

BTreeMapIteratorKey, ValueGoToLast Method

Positions iterator at the last object in the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void GoToLast()
Public Sub GoToLast
public:
void GoToLast()
member GoToLast : unit -> unit
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).MoveNext Method

BTreeMapIteratorKey, ValueMoveNext Method

Advances the enumerator to the next element of the collection.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
bool MoveNext()
member MoveNext : unit -> bool

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).MovePrevious Method

BTreeMapIteratorKey, ValueMovePrevious Method

Advances the enumerator to the previous element of the map.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool MovePrevious()
Public Function MovePrevious As Boolean
public:
bool MovePrevious()
member MovePrevious : unit -> bool

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the previous element; false if the enumerator has reached the position prior to the start of the map.
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).Next Method

BTreeMapIteratorKey, ValueNext Method

Positions the iterator at the next KeyValuePair in the map. Only use this one with nullable Key type.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<Key, Value> Next()
Public Function Next As KeyValuePair(Of Key, Value)
public:
KeyValuePair<Key, Value> Next()
member Next : unit -> KeyValuePair<'Key, 'Value>

Return Value

Type: KeyValuePair Key, Value
The next Key or null if we iterated past the the end of the set.
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).Previous Method

BTreeMapIteratorKey, ValuePrevious Method

Positions the iterator at the previous Key in the set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public KeyValuePair<Key, Value> Previous()
Public Function Previous As KeyValuePair(Of Key, Value)
public:
KeyValuePair<Key, Value> Previous()
member Previous : unit -> KeyValuePair<'Key, 'Value>

Return Value

Type: KeyValuePair Key, Value
The previous Key or null if we iterated to a postion before the first Key in the set.
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapIterator(Key, Value).ReplaceValue Method

BTreeMapIteratorKey, ValueReplaceValue Method

Replaces a value in map

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceValue(
    ref Value value
)
Public Sub ReplaceValue (
    ByRef value As Value
)
public:
void ReplaceValue(
    Value% value
)
member ReplaceValue :
        value : 'Value byref -> unit

Parameters

value
Type: Value
the value to replace with
See Also

Reference

BTreeMapIteratorKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value) Class

BTreeMapOidShortKey, Value Class

Represents a collection of objects that is maintained in sorted order. Collection and all objects must be within a single Database (since references uses OidShort persistently)
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBase Key, Value
VelocityDb.Collection.BTreeBTreeMapBase Key, Value
VelocityDb.Collection.BTreeBTreeMapOidShortKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeMapOidShort<Key, Value> : BTreeMapBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>

<SerializableAttribute>
Public Class BTreeMapOidShort(Of Key, Value)
    Inherits BTreeMapBase(Of Key, Value)
    Implements IEnumerable(Of KeyValuePair(Of Key, Value)),
    IEnumerable, IEnumerable(Of Key)
[SerializableAttribute]
generic<typename Key, typename Value>
public ref class BTreeMapOidShort : public BTreeMapBase<Key, Value>,
    IEnumerable<KeyValuePair<Key, Value>>, IEnumerable, IEnumerable<Key>
[<SerializableAttribute>]
type BTreeMapOidShort<'Key, 'Value> =
    class
        inherit BTreeMapBase<'Key, 'Value>
        interface IEnumerable<KeyValuePair<'Key, 'Value>>
        interface IEnumerable
        interface IEnumerable<'Key>
    end

Type Parameters

Key
The object type of keys in this BTreeMapOidShort/>
Value
The value type of values in this BTreeMapOidShort

The BTreeMapOidShortKey, Value type exposes the following members.

Constructors
 | Name | Description
Public method | BTreeMapOidShortKey, Value | Creates a new BTreeMapOidShort
Top
Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | MaxNumberOfDatabases | Allow only a single database for this short id (32bit) references collection (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? YES it does. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value) Constructor

BTreeMapOidShortKey, Value Constructor

Creates a new BTreeMapOidShort

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMapOidShort(
    VelocityDbComparer<Key> comparer,
    SessionBase session,
    ushort maxEntriesPerNode = 10000,
    ushort comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
Public Sub New (
    comparer As VelocityDbComparer(Of Key),
    session As SessionBase,
    Optional maxEntriesPerNode As UShort = 10000,
    Optional comparisonArraySize As UShort = 0,
    Optional comparisonArrayIsCompleteKey As Boolean = false
)
public:
BTreeMapOidShort(
    VelocityDbComparer<Key>^ comparer,
    SessionBase^ session,
    unsigned short maxEntriesPerNode = 10000,
    unsigned short comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
new :
        comparer : VelocityDbComparer<'Key> *
        session : SessionBase *
        ?maxEntriesPerNode : uint16 *
        ?comparisonArraySize : uint16 *
        ?comparisonArrayIsCompleteKey : bool
(* Defaults:
        let _maxEntriesPerNode = defaultArg maxEntriesPerNode 10000
        let _comparisonArraySize = defaultArg comparisonArraySize 0
        let _comparisonArrayIsCompleteKey = defaultArg comparisonArrayIsCompleteKey false
*)
-> BTreeMapOidShort

Parameters

comparer
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
An object comparer. Try using CompareByField
session
Type: VelocityDb.SessionSessionBase
The session managing this object
maxEntriesPerNode (Optional)
Type: SystemUInt16
Determines internal array and Page sizes
comparisonArraySize (Optional)
Type: SystemUInt16
Determine how many bytes to reserve for each object within a BTree node as a way to avoid actual object compares.
comparisonArrayIsCompleteKey (Optional)
Type: SystemBoolean
If the comparison array bytes are all that needs to be compared to determine ordering then set this to true; otherwise false
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value) Properties

BTreeMapOidShortKey, Value Properties

The BTreeMapOidShortKey, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | MaxNumberOfDatabases | Allow only a single database for this short id (32bit) references collection (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? YES it does. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value).Comparer Property

BTreeMapOidShortKey, ValueComparer Property

Gets the VelocityDbComparer object that is used to compare Key objects.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value).MaxNumberOfDatabases Property

BTreeMapOidShortKey, ValueMaxNumberOfDatabases Property

Allow only a single database for this short id (32bit) references collection

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value).UsesOidShort Property

BTreeMapOidShortKey, ValueUsesOidShort Property

Does this BTree use short object references (32 bit) for its internal references? YES it does.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UsesOidShort { get; }
Public Overrides ReadOnly Property UsesOidShort As Boolean
    Get
public:
virtual property bool UsesOidShort {
    bool get () override;
}
abstract UsesOidShort : bool with get
override UsesOidShort : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value) Methods

BTreeMapOidShortKey, Value Methods

The BTreeMapOidShortKey, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value).Clear Method

BTreeMapOidShortKey, ValueClear Method

Removes all elements from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeMapOidShort(Key, Value).InitializeAfterRead Method

BTreeMapOidShortKey, ValueInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeMapOidShort`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeMapOidShort`2.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeMapOidShortKey, Value Class
VelocityDb.Collection.BTree Namespace


BTreeNode Class

A BTree consists of a tree of nodes. Each BTree node has this class a base class.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBaseKey, Value
VelocityDb.Collection.BTreeBTreeInternalBaseKey, Value
VelocityDb.Collection.BTreeBTreeLeafBaseKey, Value

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BTreeNode : OptimizedPersistable
<SerializableAttribute>
Public MustInherit Class BTreeNode
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class BTreeNode abstract : public OptimizedPersistable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BTreeNode =
    class
        inherit OptimizedPersistable
    end
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeSet(Key) Class

BTreeSetKey Class

Represents a collection of objects that is maintained in sorted order. A persistent BTree references its contained objects by Oid instead of direct object references. This way, we will only open the referenced objects on demand which reduces memory usage and initial BTree load time.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBase Key, Key
VelocityDb.Collection.BTreeBTreeSetKey

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeSet<Key> : BTreeBase<Key, Key>,
    ISet<Key>, ICollection<Key>, IEnumerable<Key>, IEnumerable

<SerializableAttribute>
Public Class BTreeSet(Of Key)
    Inherits BTreeBase(Of Key, Key)
    Implements ISet(Of Key), ICollection(Of Key),
    IEnumerable(Of Key), IEnumerable
[SerializableAttribute]
generic<typename Key>
public ref class BTreeSet : public BTreeBase<Key, Key>,
    ISet<Key>, ICollection<Key>, IEnumerable<Key>, IEnumerable
[<SerializableAttribute>]
type BTreeSet<'Key> =
    class
        inherit BTreeBase<'Key, 'Key>
        interface ISet<'Key>
        interface ICollection<'Key>
        interface IEnumerable<'Key>
        interface IEnumerable
    end

Type Parameters

Key
The key type of objects in this BTree

The BTreeSetKey type exposes the following members.

Constructors
 | Name | Description
Public method | BTreeSetKey | Creates a new BTreeSet
Top
Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? NO it does not. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | First | Returns the first Key object in this set.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Public method | Iterator | Initializes an iterator to find the keys of this set (Overrides BTreeBaseKey, ValueIterator.)
Public method | Last | Returns the last Key object in this set.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeSet(Key) Constructor

BTreeSetKey Constructor

Creates a new BTreeSet

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet(
    VelocityDbComparer<Key> comparer = null,
    SessionBase session = null,
    ushort maxEntriesPerNode = 10000,
    ushort comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
Public Sub New (
    Optional comparer As VelocityDbComparer(Of Key) = Nothing,
    Optional session As SessionBase = Nothing,
    Optional maxEntriesPerNode As UShort = 10000,
    Optional comparisonArraySize As UShort = 0,
    Optional comparisonArrayIsCompleteKey As Boolean = false
)
public:
BTreeSet(
    VelocityDbComparer<Key>^ comparer = nullptr,
    SessionBase^ session = nullptr,
    unsigned short maxEntriesPerNode = 10000,
    unsigned short comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
new :
        ?comparer : VelocityDbComparer<'Key> *
        ?session : SessionBase *
        ?maxEntriesPerNode : uint16 *
        ?comparisonArraySize : uint16 *
        ?comparisonArrayIsCompleteKey : bool
(* Defaults:
        let _comparer = defaultArg comparer null
        let _session = defaultArg session null
        let _maxEntriesPerNode = defaultArg maxEntriesPerNode 10000
        let _comparisonArraySize = defaultArg comparisonArraySize 0
        let _comparisonArrayIsCompleteKey = defaultArg comparisonArrayIsCompleteKey false
*)
-> BTreeSet

Parameters

comparer (Optional)
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
An object comparer. Try using CompareByField
session (Optional)
Type: VelocityDb.SessionSessionBase
The session managing this object
maxEntriesPerNode (Optional)
Type: SystemUInt16
Determines internal array and Page sizes
comparisonArraySize (Optional)
Type: SystemUInt16
Determine how many bytes to reserve for each object within a BTree node as a way to avoid actual object compares.
comparisonArrayIsCompleteKey (Optional)
Type: SystemBoolean
If the comparison array bytes are all that needs to be compared to determine ordering then set this to true; otherwise false
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key) Properties

BTreeSetKey Properties

The BTreeSetKey generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? NO it does not. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).Comparer Property

BTreeSetKeyComparer Property

Gets the VelocityDbComparer object that is used to compare Key objects.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).UsesOidShort Property

BTreeSetKeyUsesOidShort Property

Does this BTree use short object references (32 bit) for its internal references? NO it does not.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UsesOidShort { get; }
Public Overrides ReadOnly Property UsesOidShort As Boolean
    Get
public:
virtual property bool UsesOidShort {
    bool get () override;
}
abstract UsesOidShort : bool with get
override UsesOidShort : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key) Methods

BTreeSetKey Methods

The BTreeSetKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | First | Returns the first Key object in this set.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Public method | Iterator | Initializes an iterator to find the keys of this set (Overrides BTreeBaseKey, ValueIterator.)
Public method | Last | Returns the last Key object in this set.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).Clear Method

BTreeSetKeyClear Method

Removes all elements from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).First Method

BTreeSetKeyFirst Method

Returns the first Key object in this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key First()
Public Function First As Key
public:
Key First()
member First : unit -> 'Key

Return Value

Type: Key
The first Key in the collection according to the sort order used
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).InitializeAfterRead Method

BTreeSetKeyInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeSet`1.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeSet`1.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).Iterator Method

BTreeSetKeyIterator Method

Initializes an iterator to find the keys of this set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override BTreeSetIterator<Key> Iterator()
Public Overrides Function Iterator As BTreeSetIterator(Of Key)
public:
virtual BTreeSetIterator<Key>^ Iterator() override
abstract Iterator : unit -> BTreeSetIterator<'Key>
override Iterator : unit -> BTreeSetIterator<'Key>

Return Value

Type: BTreeSetIterator Key
iterator
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSet(Key).Last Method

BTreeSetKeyLast Method

Returns the last Key object in this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key Last()
Public Function Last As Key
public:
Key Last()
member Last : unit -> 'Key

Return Value

Type: Key
The last Key in the collection according to the sort order used
See Also

Reference

BTreeSetKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key) Class

BTreeSetIteratorKey Class

Iterates all the elements of a BTreeSet
Inheritance Hierarchy
SystemObject
VelocityDb.Collection.BTreeBTreeSetIteratorKey

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class BTreeSetIterator<Key>

Public Class BTreeSetIterator(Of Key)
generic<typename Key>
public ref class BTreeSetIterator
type BTreeSetIterator<'Key> =  class end

Type Parameters

Key
The type of the elements contained in the BTreeSet

The BTreeSetIteratorKey type exposes the following members.

Properties
 | Name | Description
Public property | IndexInTree | Gets the index of the current iterator element in the iterated collection
Top
Methods
 | Name | Description
Public method | Current | The iterator current Key object
Public method | CurrentComparisonArray | The iterator current Key comparison array
Public method | ElementAt | Gets an item at a certain index
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Public method | GoToLast | Positions iterator at the last object in the set.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | MovePrevious | Advances the enumerator to the previous element of the collection.
Public method | Next | Positions the iterator at the next Key in the set. Only use this one with nullable Key type.
Public method | Previous | Positions the iterator at the previous Key in the set
Public method | Remove | Not yet ready for public use (testing internally first)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key) Properties

BTreeSetIteratorKey Properties

The BTreeSetIteratorKey generic type exposes the following members.

Properties
 | Name | Description
Public property | IndexInTree | Gets the index of the current iterator element in the iterated collection
Top
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).IndexInTree Property

BTreeSetIteratorKeyIndexInTree Property

Gets the index of the current iterator element in the iterated collection

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long IndexInTree { get; }
Public ReadOnly Property IndexInTree As Long
    Get
public:
property long long IndexInTree {
    long long get ();
}
member IndexInTree : int64 with get

Property Value

Type: Int64
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key) Methods

BTreeSetIteratorKey Methods

The BTreeSetIteratorKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Current | The iterator current Key object
Public method | CurrentComparisonArray | The iterator current Key comparison array
Public method | ElementAt | Gets an item at a certain index
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Public method | GoToLast | Positions iterator at the last object in the set.
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | MovePrevious | Advances the enumerator to the previous element of the collection.
Public method | Next | Positions the iterator at the next Key in the set. Only use this one with nullable Key type.
Public method | Previous | Positions the iterator at the previous Key in the set
Public method | Remove | Not yet ready for public use (testing internally first)
Top
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).Current Method

BTreeSetIteratorKeyCurrent Method

The iterator current Key object

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key Current()
Public Function Current As Key
public:
Key Current()
member Current : unit -> 'Key

Return Value

Type: Key
The Ket at the current iterator position
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).CurrentComparisonArray Method

BTreeSetIteratorKeyCurrentComparisonArray Method

The iterator current Key comparison array

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public byte[] CurrentComparisonArray()
Public Function CurrentComparisonArray As Byte()
public:
array<unsigned char>^ CurrentComparisonArray()
member CurrentComparisonArray : unit -> byte[]

Return Value

Type: Byte
The Key comparison array at the current iterator position
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).ElementAt Method

BTreeSetIteratorKeyElementAt Method

Gets an item at a certain index

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key ElementAt(
    long i
)
Public Function ElementAt (
    i As Long
) As Key
public:
Key ElementAt(
    long long i
)
member ElementAt :
        i : int64 -> 'Key

Parameters

i
Type: SystemInt64
the item index

Return Value

Type: Key
the item at the specified index
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).GoTo Method

BTreeSetIteratorKeyGoTo Method

Overload List
 | Name | Description
Public method | GoTo(Key) | Positions iterator at Key object or where Key would be inserted if added to the set.
Public method | GoTo(Key, Byte) | Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.
Top
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).GoTo Method (Key)

BTreeSetIteratorKeyGoTo Method (Key)

Positions iterator at Key object or where Key would be inserted if added to the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool GoTo(
    Key key
)
Public Function GoTo (
    key As Key
) As Boolean
public:
bool GoTo(
    Key key
)
member GoTo :
        key : 'Key -> bool

Parameters

key
Type: Key
The object to position iterator near

Return Value

Type: Boolean
true if an exact match was found; otherwise false
See Also

Reference

BTreeSetIteratorKey Class
GoTo Overload
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).GoTo Method (Key, Byte[])

BTreeSetIteratorKeyGoTo Method (Key, Byte)

Positions iterator at Key object or where Key would be inserted if added to the set. This function is normally only used internally by VelocityDb.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool GoTo(
    Key key,
    byte[] comparisonArray
)
Public Function GoTo (
    key As Key,
    comparisonArray As Byte()
) As Boolean
public:
bool GoTo(
    Key key,
    array<unsigned char>^ comparisonArray
)
member GoTo :
        key : 'Key *
        comparisonArray : byte[] -> bool

Parameters

key
Type: Key
The object to position iterator near
comparisonArray
Type: SystemByte
Contains bytes used for comparing with other arrays for NodeKeys within the set

Return Value

Type: Boolean
true if an exact match was found; otherwise false
See Also

Reference

BTreeSetIteratorKey Class
GoTo Overload
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).GoToLast Method

BTreeSetIteratorKeyGoToLast Method

Positions iterator at the last object in the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void GoToLast()
Public Sub GoToLast
public:
void GoToLast()
member GoToLast : unit -> unit
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).MoveNext Method

BTreeSetIteratorKeyMoveNext Method

Advances the enumerator to the next element of the collection.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
bool MoveNext()
member MoveNext : unit -> bool

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).MovePrevious Method

BTreeSetIteratorKeyMovePrevious Method

Advances the enumerator to the previous element of the collection.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool MovePrevious()
Public Function MovePrevious As Boolean
public:
bool MovePrevious()
member MovePrevious : unit -> bool

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the previous element; false if the enumerator has reached the position prior to the the start of the collection.
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).Next Method

BTreeSetIteratorKeyNext Method

Positions the iterator at the next Key in the set. Only use this one with nullable Key type.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key Next()
Public Function Next As Key
public:
Key Next()
member Next : unit -> 'Key

Return Value

Type: Key
The next Key or null if we iterated past the the end of the set.
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).Previous Method

BTreeSetIteratorKeyPrevious Method

Positions the iterator at the previous Key in the set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key Previous()
Public Function Previous As Key
public:
Key Previous()
member Previous : unit -> 'Key

Return Value

Type: Key
The previous Key or null if we iterated to a postion before the first Key in the set.
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetIterator(Key).Remove Method

BTreeSetIteratorKeyRemove Method

Not yet ready for public use (testing internally first)

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

BTreeSetIteratorKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key) Class

BTreeSetOidShortKey Class

Represents a collection of objects that is maintained in sorted order. Collection and all objects must be within a single Database (since references uses OidShort persistently)
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.BTreeBTreeNode
VelocityDb.Collection.BTreeBTreeBase Key, Key
VelocityDb.Collection.BTreeBTreeSetOidShortKey

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BTreeSetOidShort<Key> : BTreeBase<Key, Key>,
    IEnumerable<Key>, IEnumerable

<SerializableAttribute>
Public Class BTreeSetOidShort(Of Key)
    Inherits BTreeBase(Of Key, Key)
    Implements IEnumerable(Of Key), IEnumerable
[SerializableAttribute]
generic<typename Key>
public ref class BTreeSetOidShort : public BTreeBase<Key, Key>,
    IEnumerable<Key>, IEnumerable
[<SerializableAttribute>]
type BTreeSetOidShort<'Key> =
    class
        inherit BTreeBase<'Key, 'Key>
        interface IEnumerable<'Key>
        interface IEnumerable
    end

Type Parameters

Key
The object type of objects in this BTree, currently must be a subclass of OptimizedPersistable

The BTreeSetOidShortKey type exposes the following members.

Constructors
 | Name | Description
Public method | BTreeSetOidShortKey | Creates a new BTreeSetOidShort
Top
Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | MaxNumberOfDatabases | Allow only a single database for this short id (32bit) references collection (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? YES it does. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | First | Returns the first Key object in this set.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Public method | Iterator | Initializes an iterator to find the keys of this set (Overrides BTreeBaseKey, ValueIterator.)
Public method | Last | Returns the last Key object in this set.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key) Constructor

BTreeSetOidShortKey Constructor

Creates a new BTreeSetOidShort

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSetOidShort(
    VelocityDbComparer<Key> comparer = null,
    SessionBase session = null,
    ushort maxEntriesPerNode = 10000,
    ushort comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
Public Sub New (
    Optional comparer As VelocityDbComparer(Of Key) = Nothing,
    Optional session As SessionBase = Nothing,
    Optional maxEntriesPerNode As UShort = 10000,
    Optional comparisonArraySize As UShort = 0,
    Optional comparisonArrayIsCompleteKey As Boolean = false
)
public:
BTreeSetOidShort(
    VelocityDbComparer<Key>^ comparer = nullptr,
    SessionBase^ session = nullptr,
    unsigned short maxEntriesPerNode = 10000,
    unsigned short comparisonArraySize = 0,
    bool comparisonArrayIsCompleteKey = false
)
new :
        ?comparer : VelocityDbComparer<'Key> *
        ?session : SessionBase *
        ?maxEntriesPerNode : uint16 *
        ?comparisonArraySize : uint16 *
        ?comparisonArrayIsCompleteKey : bool
(* Defaults:
        let _comparer = defaultArg comparer null
        let _session = defaultArg session null
        let _maxEntriesPerNode = defaultArg maxEntriesPerNode 10000
        let _comparisonArraySize = defaultArg comparisonArraySize 0
        let _comparisonArrayIsCompleteKey = defaultArg comparisonArrayIsCompleteKey false
*)
-> BTreeSetOidShort

Parameters

comparer (Optional)
Type: VelocityDb.Collection.ComparerVelocityDbComparer Key
An object comparer. Try using CompareByField
session (Optional)
Type: VelocityDb.SessionSessionBase
The session managing this object
maxEntriesPerNode (Optional)
Type: SystemUInt16
Determines internal array and Page sizes
comparisonArraySize (Optional)
Type: SystemUInt16
Determine how many bytes to reserve for each object within a BTree node as a way to avoid actual object compares.
comparisonArrayIsCompleteKey (Optional)
Type: SystemBoolean
If the comparison array bytes are all that needs to be compared to determine ordering then set this to true; otherwise false
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key) Properties

BTreeSetOidShortKey Properties

The BTreeSetOidShortKey generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the VelocityDbComparer object that is used to compare Key objects. (Overrides BTreeBaseKey, ValueComparer.)
Public property | MaxNumberOfDatabases | Allow only a single database for this short id (32bit) references collection (Overrides OptimizedPersistableMaxNumberOfDatabases.)
Public property | UsesOidShort | Does this BTree use short object references (32 bit) for its internal references? YES it does. (Overrides BTreeBaseKey, ValueUsesOidShort.)
Top
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).Comparer Property

BTreeSetOidShortKeyComparer Property

Gets the VelocityDbComparer object that is used to compare Key objects.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override VelocityDbComparer<Key> Comparer { get; }
Public Overrides ReadOnly Property Comparer As VelocityDbComparer(Of Key)
    Get
public:
virtual property VelocityDbComparer<Key>^ Comparer {
    VelocityDbComparer<Key>^ get () override;
}
abstract Comparer : VelocityDbComparer<'Key> with get
override Comparer : VelocityDbComparer<'Key> with get

Property Value

Type: VelocityDbComparer Key
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).MaxNumberOfDatabases Property

BTreeSetOidShortKeyMaxNumberOfDatabases Property

Allow only a single database for this short id (32bit) references collection

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override uint MaxNumberOfDatabases { get; }
Public Overrides ReadOnly Property MaxNumberOfDatabases As UInteger
    Get
public:
virtual property unsigned int MaxNumberOfDatabases {
    unsigned int get () override;
}
abstract MaxNumberOfDatabases : uint32 with get
override MaxNumberOfDatabases : uint32 with get

Property Value

Type: UInt32

Implements

IOptimizedPersistableMaxNumberOfDatabases
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).UsesOidShort Property

BTreeSetOidShortKeyUsesOidShort Property

Does this BTree use short object references (32 bit) for its internal references? YES it does.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UsesOidShort { get; }
Public Overrides ReadOnly Property UsesOidShort As Boolean
    Get
public:
virtual property bool UsesOidShort {
    bool get () override;
}
abstract UsesOidShort : bool with get
override UsesOidShort : bool with get

Property Value

Type: Boolean
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key) Methods

BTreeSetOidShortKey Methods

The BTreeSetOidShortKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all elements from the set. (Overrides BTreeBaseKey, ValueClear.)
Public method | First | Returns the first Key object in this set.
Public method | InitializeAfterRead | (Overrides BTreeBaseKey, ValueInitializeAfterRead(SessionBase).)
Public method | Iterator | Initializes an iterator to find the keys of this set (Overrides BTreeBaseKey, ValueIterator.)
Public method | Last | Returns the last Key object in this set.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).Clear Method

BTreeSetOidShortKeyClear Method

Removes all elements from the set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).First Method

BTreeSetOidShortKeyFirst Method

Returns the first Key object in this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key First()
Public Function First As Key
public:
Key First()
member First : unit -> 'Key

Return Value

Type: Key
The first Key in the collection according to the sort order used
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).InitializeAfterRead Method

BTreeSetOidShortKeyInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDb.Collection.BTree.BTreeSetOidShort`1.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.Collection.BTree.BTreeSetOidShort`1.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).Iterator Method

BTreeSetOidShortKeyIterator Method

Initializes an iterator to find the keys of this set

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override BTreeSetIterator<Key> Iterator()
Public Overrides Function Iterator As BTreeSetIterator(Of Key)
public:
virtual BTreeSetIterator<Key>^ Iterator() override
abstract Iterator : unit -> BTreeSetIterator<'Key>
override Iterator : unit -> BTreeSetIterator<'Key>

Return Value

Type: BTreeSetIterator Key

[Missing <returns> documentation for "M:VelocityDb.Collection.BTree.BTreeSetOidShort`1.Iterator"]

See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


BTreeSetOidShort(Key).Last Method

BTreeSetOidShortKeyLast Method

Returns the last Key object in this set.

Namespace: VelocityDb.Collection.BTree
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Key Last()
Public Function Last As Key
public:
Key Last()
member Last : unit -> 'Key

Return Value

Type: Key
The last Key in the collection according to the sort order used
See Also

Reference

BTreeSetOidShortKey Class
VelocityDb.Collection.BTree Namespace


VelocityDb.Collection.BTree.Extensions Namespace

The VelocityDb.Collection.BTree.Extensions namespace contains a few extensions to improve performance of Linq for Objects queries. The same code can also be found in open source as VelocityDBExtensions.Extensions.BTree
Classes
 | Class | Description
Public class | BTreeExtensions | A few extensions to improve performance of Linq for Objects queries We need your HELP to improve it to cover more use cases of queries!


BTreeExtensions Class

A few extensions to improve performance of Linq for Objects queries We need your HELP to improve it to cover more use cases of queries!
Inheritance Hierarchy
SystemObject
VelocityDb.Collection.BTree.ExtensionsBTreeExtensions

Namespace: VelocityDb.Collection.BTree.Extensions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class BTreeExtensions
<ExtensionAttribute>
Public NotInheritable Class BTreeExtensions
[ExtensionAttribute]
public ref class BTreeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type BTreeExtensions =  class end

The BTreeExtensions type exposes the following members.

Methods
Name | Description
CountKey | Override to improve performance over IEnumerable LINQ extension
WhereKey | Override to improve performance over IEnumerable LINQ extension
Top
See Also

Reference

VelocityDb.Collection.BTree.Extensions Namespace


BTreeExtensions Methods

The BTreeExtensions type exposes the following members.

Methods
Name | Description
CountKey | Override to improve performance over IEnumerable LINQ extension
WhereKey | Override to improve performance over IEnumerable LINQ extension
Top
See Also

Reference

BTreeExtensions Class
VelocityDb.Collection.BTree.Extensions Namespace


BTreeExtensions.Count(Key) Method

BTreeExtensionsCountKey Method

Override to improve performance over IEnumerable LINQ extension

Namespace: VelocityDb.Collection.BTree.Extensions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int Count<Key>(
    this BTreeBase<Key, Key> sourceCollection
)

<ExtensionAttribute>
Public Shared Function Count(Of Key) (
    sourceCollection As BTreeBase(Of Key, Key)
) As Integer
public:
[ExtensionAttribute]
generic<typename Key>
static int Count(
    BTreeBase<Key, Key>^ sourceCollection
)
[<ExtensionAttribute>]
static member Count :
        sourceCollection : BTreeBase<'Key, 'Key> -> int

Parameters

sourceCollection
Type: VelocityDb.Collection.BTreeBTreeBase Key, Key
the collection

Type Parameters

Key
key type

Return Value

Type: Int32
Size of the collection

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BTreeBase Key, Key. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BTreeExtensions Class
VelocityDb.Collection.BTree.Extensions Namespace


BTreeExtensions.Where(Key) Method

BTreeExtensionsWhereKey Method

Override to improve performance over IEnumerable LINQ extension

Namespace: VelocityDb.Collection.BTree.Extensions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Key> Where<Key>(
    this BTreeBase<Key, Key> sourceCollection,
    Expression<Func<Key, bool>> expr
)

<ExtensionAttribute>
Public Shared Function Where(Of Key) (
    sourceCollection As BTreeBase(Of Key, Key),
    expr As Expression(Of Func(Of Key, Boolean))
) As IEnumerable(Of Key)
public:
[ExtensionAttribute]
generic<typename Key>
static IEnumerable<Key>^ Where(
    BTreeBase<Key, Key>^ sourceCollection,
    Expression<Func<Key, bool>^>^ expr
)
[<ExtensionAttribute>]
static member Where :
        sourceCollection : BTreeBase<'Key, 'Key> *
        expr : Expression<Func<'Key, bool>> -> IEnumerable<'Key>

Parameters

sourceCollection
Type: VelocityDb.Collection.BTreeBTreeBase Key, Key
the collection
expr
Type: System.Linq.ExpressionsExpression Func Key, Boolean
an expression

Type Parameters

Key
key type

Return Value

Type: IEnumerable Key
Enumeration of collection where the expression evaluates to true

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BTreeBase Key, Key. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BTreeExtensions Class
VelocityDb.Collection.BTree.Extensions Namespace


VelocityDb.Collection.Comparer Namespace

The VelocityDb.Collection.Comparer namespace contains classes for the VelocityDb Comparer classes optimized for persistent storage in VelocityDb databases
Classes
 | Class | Description
Public class | ByteArrayComparer | Compares two byte arrays
Public class | CompareByFieldKey | Use this predefined comparator whenever the sorting can be defined by specifying one or more fields of the sorted Key type.
Public class | HashCodeComparerT | When the type of object being compared is a simple type like a string and you don't care about the sort order, then this comparator is what you want to use. It is similar to using a hash based collection but with less overhead (more compact) This kind of comparator especially shines when you create the BTreeSet/BTreeMap using a comparisonByteArray size of 4
Public class | SimpleComparerT | When the type of object being compared is a simple type like string, int, ..., this is the comparator you probably want to use.
Public class | VelocityDbComparerKey | The base class of for comparing persistent objects. If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared


ByteArrayComparer Class

Compares two byte arrays
Inheritance Hierarchy
SystemObject
VelocityDb.Collection.ComparerByteArrayComparer

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ByteArrayComparer : IComparer<byte[]>
<SerializableAttribute>
Public Class ByteArrayComparer
    Implements IComparer(Of Byte())
[SerializableAttribute]
public ref class ByteArrayComparer : IComparer<array<unsigned char>^>
[<SerializableAttribute>]
type ByteArrayComparer =
    class
        interface IComparer<byte[]>
    end

The ByteArrayComparer type exposes the following members.

Constructors
 | Name | Description
Public method | ByteArrayComparer | Initializes a new instance of the ByteArrayComparer class
Top
Methods
 | Name | Description
Public method | Compare |
 | memcmp |
Top
See Also

Reference

VelocityDb.Collection.Comparer Namespace


ByteArrayComparer Constructor

Initializes a new instance of the ByteArrayComparer class

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ByteArrayComparer()
Public Sub New
public:
ByteArrayComparer()
new : unit -> ByteArrayComparer
See Also

Reference

ByteArrayComparer Class
VelocityDb.Collection.Comparer Namespace


ByteArrayComparer Methods

The ByteArrayComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare |
 | memcmp |
Top
See Also

Reference

ByteArrayComparer Class
VelocityDb.Collection.Comparer Namespace


ByteArrayComparer.Compare Method

ByteArrayComparerCompare Method

[Missing <summary> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.Compare(System.Byte[],System.Byte[])"]

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    byte[] a,
    byte[] b
)
Public Function Compare (
    a As Byte(),
    b As Byte()
) As Integer
public:
virtual int Compare(
    array<unsigned char>^ a,
    array<unsigned char>^ b
) sealed
abstract Compare :
        a : byte[] *
        b : byte[] -> int
override Compare :
        a : byte[] *
        b : byte[] -> int

Parameters

a
Type: SystemByte

[Missing <param name="a"/> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.Compare(System.Byte[],System.Byte[])"]

b
Type: SystemByte

[Missing <param name="b"/> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.Compare(System.Byte[],System.Byte[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.Compare(System.Byte[],System.Byte[])"]

Implements

IComparerTCompare(T, T)
See Also

Reference

ByteArrayComparer Class
VelocityDb.Collection.Comparer Namespace


ByteArrayComparer.memcmp Method

ByteArrayComparermemcmp Method

[Missing <summary> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.memcmp(System.Byte[],System.Byte[],System.Int32)"]

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int memcmp(
    byte[] b1,
    byte[] b2,
    int count
)
Public Shared Function memcmp (
    b1 As Byte(),
    b2 As Byte(),
    count As Integer
) As Integer
public:
static int memcmp(
    array<unsigned char>^ b1,
    array<unsigned char>^ b2,
    int count
)
static member memcmp :
        b1 : byte[] *
        b2 : byte[] *
        count : int -> int

Parameters

b1
Type: SystemByte

[Missing <param name="b1"/> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.memcmp(System.Byte[],System.Byte[],System.Int32)"]

b2
Type: SystemByte

[Missing <param name="b2"/> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.memcmp(System.Byte[],System.Byte[],System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.memcmp(System.Byte[],System.Byte[],System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Collection.Comparer.ByteArrayComparer.memcmp(System.Byte[],System.Byte[],System.Int32)"]

See Also

Reference

ByteArrayComparer Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Class

CompareByFieldKey Class

Use this predefined comparator whenever the sorting can be defined by specifying one or more fields of the sorted Key type.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.ComparerVelocityDbComparer Key
VelocityDb.Collection.ComparerCompareByFieldKey

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class CompareByField<Key> : VelocityDbComparer<Key>

<SerializableAttribute>
Public Class CompareByField(Of Key)
    Inherits VelocityDbComparer(Of Key)
[SerializableAttribute]
generic<typename Key>
public ref class CompareByField : public VelocityDbComparer<Key>
[<SerializableAttribute>]
type CompareByField<'Key> =
    class
        inherit VelocityDbComparer<'Key>
    end

Type Parameters

Key
The type of object being compared (containing field(s) to compare)

The CompareByFieldKey type exposes the following members.

Constructors
 | Name | Description
Public method | CompareByFieldKey(SessionBase) | This special constructor is provided so that VelocityDb can instantiate the object after reading it from disk. This is also the place to initialize transient variables of the object.
Public method | CompareByFieldKey(String, SessionBase, Boolean, Boolean, Boolean) | Compares objects by comparing one or more data fields of type Key
Top
Properties
 | Name | Description
Public property | AddOidCompare | Is the object Oid going to be compared when all the compared fields are equal? (Overrides VelocityDbComparerKeyAddOidCompare.)
Public property | FieldsToCompare |
Public property | OidPartOfComparisonBytes | Is the Oid (or OidShort) included in the comparison array bytes? (Overrides VelocityDbComparerKeyOidPartOfComparisonBytes.)
Top
Methods
 | Name | Description
Public method | AddFieldToCompare | Add an additional field to compare when prior fields all are equal
Public method | Compare(Key, Key) | Compares field(s) of Key a with field(s) of Key b (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Public method | Compare(Byte, Int32, Byte, Key) | (Overrides VelocityDbComparerKeyCompare(Byte, Int32, Byte, Key).)
Public method | CompareField | For internal use. Compares a field value in two objects
 | GetHashCode32 | Microsoft messed up the 64 bit version of GetHashCode. Use this original 32-bit version to get consistent String hash codes across 32 bit and 64 bit builds. See remarks in https://msdn.microsoft.com/en-us/library/system.string.gethashcode(v=vs.110).aspx
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | SetComparisonArrayFromObject | Sets a byte array equivalent to the field values to compare. Using this bypasses object compares, instead the byte arrays are compared byte by byte until a diff is found. If a byte diff isn't found then object compares may happen. Field types currently supported: byte, bool, Char, string, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, DateTime, TimeSpan (Overrides VelocityDbComparerKeySetComparisonArrayFromObject(Key, Byte, Boolean).)
Public method | SetupFieldsToCompare | Initializes data used to compare fields as specified with this comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Constructor

CompareByFieldKey Constructor

Overload List
 | Name | Description
Public method | CompareByFieldKey(SessionBase) | This special constructor is provided so that VelocityDb can instantiate the object after reading it from disk. This is also the place to initialize transient variables of the object.
Public method | CompareByFieldKey(String, SessionBase, Boolean, Boolean, Boolean) | Compares objects by comparing one or more data fields of type Key
Top
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Constructor (SessionBase)

CompareByFieldKey Constructor (SessionBase)

This special constructor is provided so that VelocityDb can instantiate the object after reading it from disk. This is also the place to initialize transient variables of the object.

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public CompareByField(
    SessionBase session
)
Public Sub New (
    session As SessionBase
)
public:
CompareByField(
    SessionBase^ session
)
new :
        session : SessionBase -> CompareByField

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object.
See Also

Reference

CompareByFieldKey Class
CompareByFieldKey Overload
VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Constructor (String, SessionBase, Boolean, Boolean, Boolean)

CompareByFieldKey Constructor (String, SessionBase, Boolean, Boolean, Boolean)

Compares objects by comparing one or more data fields of type Key

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public CompareByField(
    string field,
    SessionBase session,
    bool doIdCompareIfEqual = false,
    bool sortStringsByHashCode = false,
    bool ascendingSort = true
)
Public Sub New (
    field As String,
    session As SessionBase,
    Optional doIdCompareIfEqual As Boolean = false,
    Optional sortStringsByHashCode As Boolean = false,
    Optional ascendingSort As Boolean = true
)
public:
CompareByField(
    String^ field,
    SessionBase^ session,
    bool doIdCompareIfEqual = false,
    bool sortStringsByHashCode = false,
    bool ascendingSort = true
)
new :
        field : string *
        session : SessionBase *
        ?doIdCompareIfEqual : bool *
        ?sortStringsByHashCode : bool *
        ?ascendingSort : bool
(* Defaults:
        let _doIdCompareIfEqual = defaultArg doIdCompareIfEqual false
        let _sortStringsByHashCode = defaultArg sortStringsByHashCode false
        let _ascendingSort = defaultArg ascendingSort true
*)
-> CompareByField

Parameters

field
Type: SystemString
Primary field to use for comparison.
session
Type: VelocityDb.SessionSessionBase
The managing session
doIdCompareIfEqual (Optional)
Type: SystemBoolean
Optionally compare Oid's when fields are equal between compared objects
sortStringsByHashCode (Optional)
Type: SystemBoolean
Sort string fields by hash code first then secondly as normal string compare
ascendingSort (Optional)
Type: SystemBoolean
If (default), sort in ascending order, otherwise in descending order
See Also

Reference

CompareByFieldKey Class
CompareByFieldKey Overload
VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Properties

CompareByFieldKey Properties

The CompareByFieldKey generic type exposes the following members.

Properties
 | Name | Description
Public property | AddOidCompare | Is the object Oid going to be compared when all the compared fields are equal? (Overrides VelocityDbComparerKeyAddOidCompare.)
Public property | FieldsToCompare |
Public property | OidPartOfComparisonBytes | Is the Oid (or OidShort) included in the comparison array bytes? (Overrides VelocityDbComparerKeyOidPartOfComparisonBytes.)
Top
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).AddOidCompare Property

CompareByFieldKeyAddOidCompare Property

Is the object Oid going to be compared when all the compared fields are equal?

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AddOidCompare { get; }
Public Overrides ReadOnly Property AddOidCompare As Boolean
    Get
public:
virtual property bool AddOidCompare {
    bool get () override;
}
abstract AddOidCompare : bool with get
override AddOidCompare : bool with get

Property Value

Type: Boolean
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).FieldsToCompare Property

CompareByFieldKeyFieldsToCompare Property

[Missing <summary> documentation for "P:VelocityDb.Collection.Comparer.CompareByField`1.FieldsToCompare"]

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DataMember[] FieldsToCompare { get; }
Public ReadOnly Property FieldsToCompare As DataMember()
    Get
public:
property array<DataMember^>^ FieldsToCompare {
    array<DataMember^>^ get ();
}
member FieldsToCompare : DataMember[] with get

Property Value

Type: DataMember
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).OidPartOfComparisonBytes Property

CompareByFieldKeyOidPartOfComparisonBytes Property

Is the Oid (or OidShort) included in the comparison array bytes?

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool OidPartOfComparisonBytes { get; }
Public Overrides ReadOnly Property OidPartOfComparisonBytes As Boolean
    Get
public:
virtual property bool OidPartOfComparisonBytes {
    bool get () override;
}
abstract OidPartOfComparisonBytes : bool with get
override OidPartOfComparisonBytes : bool with get

Property Value

Type: Boolean
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key) Methods

CompareByFieldKey Methods

The CompareByFieldKey generic type exposes the following members.

Methods
 | Name | Description
Public method | AddFieldToCompare | Add an additional field to compare when prior fields all are equal
Public method | Compare(Key, Key) | Compares field(s) of Key a with field(s) of Key b (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Public method | Compare(Byte, Int32, Byte, Key) | (Overrides VelocityDbComparerKeyCompare(Byte, Int32, Byte, Key).)
Public method | CompareField | For internal use. Compares a field value in two objects
 | GetHashCode32 | Microsoft messed up the 64 bit version of GetHashCode. Use this original 32-bit version to get consistent String hash codes across 32 bit and 64 bit builds. See remarks in https://msdn.microsoft.com/en-us/library/system.string.gethashcode(v=vs.110).aspx
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | SetComparisonArrayFromObject | Sets a byte array equivalent to the field values to compare. Using this bypasses object compares, instead the byte arrays are compared byte by byte until a diff is found. If a byte diff isn't found then object compares may happen. Field types currently supported: byte, bool, Char, string, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, DateTime, TimeSpan (Overrides VelocityDbComparerKeySetComparisonArrayFromObject(Key, Byte, Boolean).)
Public method | SetupFieldsToCompare | Initializes data used to compare fields as specified with this comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).AddFieldToCompare Method

CompareByFieldKeyAddFieldToCompare Method

Add an additional field to compare when prior fields all are equal

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void AddFieldToCompare(
    string field,
    bool ascendingSort = true
)
Public Sub AddFieldToCompare (
    field As String,
    Optional ascendingSort As Boolean = true
)
public:
void AddFieldToCompare(
    String^ field,
    bool ascendingSort = true
)
member AddFieldToCompare :
        field : string *
        ?ascendingSort : bool
(* Defaults:
        let _ascendingSort = defaultArg ascendingSort true
*)
-> unit

Parameters

field
Type: SystemString
Field name of field to compare
ascendingSort (Optional)
Type: SystemBoolean
If (default), sort in ascending order, otherwise in descending order
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).Compare Method

CompareByFieldKeyCompare Method

Overload List
 | Name | Description
Public method | Compare(Key, Key) | Compares field(s) of Key a with field(s) of Key b (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Public method | Compare(Byte, Int32, Byte, Key) | (Overrides VelocityDbComparerKeyCompare(Byte, Int32, Byte, Key).)
Top
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).Compare Method (Key, Key)

CompareByFieldKeyCompare Method (Key, Key)

Compares field(s) of Key a with field(s) of Key b

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Compare(
    Key a,
    Key b
)
Public Overrides Function Compare (
    a As Key,
    b As Key
) As Integer
public:
virtual int Compare(
    Key a,
    Key b
) override
abstract Compare :
        a : 'Key *
        b : 'Key -> int
override Compare :
        a : 'Key *
        b : 'Key -> int

Parameters

a
Type: Key
the first object
b
Type: Key
the second object

Return Value

Type: Int32
-1 if a less than b, 0 if equal and 1 if a greater than b

Implements

IComparerTCompare(T, T)
See Also

Reference

CompareByFieldKey Class
Compare Overload
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).Compare Method (Byte[], Int32, Byte[], Key)

CompareByFieldKeyCompare Method (Byte, Int32, Byte, Key)

[Missing <summary> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Compare(
    byte[] nodeComparisonArray,
    int nodeArraySkip,
    byte[] comparisonArray,
    Key key
)
Public Overrides Function Compare (
    nodeComparisonArray As Byte(),
    nodeArraySkip As Integer,
    comparisonArray As Byte(),
    key As Key
) As Integer
public:
virtual int Compare(
    array<unsigned char>^ nodeComparisonArray,
    int nodeArraySkip,
    array<unsigned char>^ comparisonArray,
    Key key
) override
abstract Compare :
        nodeComparisonArray : byte[] *
        nodeArraySkip : int *
        comparisonArray : byte[] *
        key : 'Key -> int
override Compare :
        nodeComparisonArray : byte[] *
        nodeArraySkip : int *
        comparisonArray : byte[] *
        key : 'Key -> int

Parameters

nodeComparisonArray
Type: SystemByte

[Missing <param name="nodeComparisonArray"/> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

nodeArraySkip
Type: SystemInt32

[Missing <param name="nodeArraySkip"/> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

comparisonArray
Type: SystemByte

[Missing <param name="comparisonArray"/> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

key
Type: Key

[Missing <param name="key"/> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDb.Collection.Comparer.CompareByField`1.Compare(System.Byte[],System.Int32,System.Byte[],`0)"]

See Also

Reference

CompareByFieldKey Class
Compare Overload
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).CompareField Method

CompareByFieldKeyCompareField Method

For internal use. Compares a field value in two objects

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareField(
    DataMember member,
    Object a,
    Object b,
    int fieldIndex
)
Public Function CompareField (
    member As DataMember,
    a As Object,
    b As Object,
    fieldIndex As Integer
) As Integer
public:
int CompareField(
    DataMember^ member,
    Object^ a,
    Object^ b,
    int fieldIndex
)
member CompareField :
        member : DataMember *
        a : Object *
        b : Object *
        fieldIndex : int -> int

Parameters

member
Type: VelocityDb.TypeInfoDataMember
Field meta data
a
Type: SystemObject
First object
b
Type: SystemObject
Second object
fieldIndex
Type: SystemInt32
indicates which of the fields in this comparer

Return Value

Type: Int32
A 32-bit signed integer that indicates whether this instance precedes, follows, or appears in the same position in the sort order as the value parameter.
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).GetHashCode32 Method

CompareByFieldKeyGetHashCode32 Method

Microsoft messed up the 64 bit version of GetHashCode. Use this original 32-bit version to get consistent String hash codes across 32 bit and 64 bit builds. See remarks in https://msdn.microsoft.com/en-us/library/system.string.gethashcode(v=vs.110).aspx

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int GetHashCode32(
    string s
)
Public Shared Function GetHashCode32 (
    s As String
) As Integer
public:
static int GetHashCode32(
    String^ s
)
static member GetHashCode32 :
        s : string -> int

Parameters

s
Type: SystemString
String to compute hash code for.

Return Value

Type: Int32
A 32-bit hash code
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).InitializeAfterRecreate Method

CompareByFieldKeyInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).SetComparisonArrayFromObject Method

CompareByFieldKeySetComparisonArrayFromObject Method

Sets a byte array equivalent to the field values to compare. Using this bypasses object compares, instead the byte arrays are compared byte by byte until a diff is found. If a byte diff isn't found then object compares may happen. Field types currently supported: byte, bool, Char, string, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, DateTime, TimeSpan

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetComparisonArrayFromObject(
    Key key,
    byte[] comparisonArray,
    bool oidShort
)
Public Overrides Sub SetComparisonArrayFromObject (
    key As Key,
    comparisonArray As Byte(),
    oidShort As Boolean
)
public:
virtual void SetComparisonArrayFromObject(
    Key key,
    array<unsigned char>^ comparisonArray,
    bool oidShort
) override
abstract SetComparisonArrayFromObject :
        key : 'Key *
        comparisonArray : byte[] *
        oidShort : bool -> unit
override SetComparisonArrayFromObject :
        key : 'Key *
        comparisonArray : byte[] *
        oidShort : bool -> unit

Parameters

key
Type: Key
A key from which to extract a comparison byte array based on field(s) to compare
comparisonArray
Type: SystemByte
The array to set bytes of
oidShort
Type: SystemBoolean
If oidShort is true then only the page and slot numbers need to be compared if the comparator bytes includes any Oid bytes
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


CompareByField(Key).SetupFieldsToCompare Method

CompareByFieldKeySetupFieldsToCompare Method

Initializes data used to compare fields as specified with this comparer.

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetupFieldsToCompare()
Public Overridable Sub SetupFieldsToCompare
public:
virtual void SetupFieldsToCompare()
abstract SetupFieldsToCompare : unit -> unit
override SetupFieldsToCompare : unit -> unit
See Also

Reference

CompareByFieldKey Class
VelocityDb.Collection.Comparer Namespace


HashCodeComparer(T) Class

HashCodeComparerT Class

When the type of object being compared is a simple type like a string and you don't care about the sort order, then this comparator is what you want to use. It is similar to using a hash based collection but with less overhead (more compact) This kind of comparator especially shines when you create the BTreeSet/BTreeMap using a comparisonByteArray size of 4
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.ComparerVelocityDbComparer T
VelocityDb.Collection.ComparerHashCodeComparerT

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class HashCodeComparer<T> : VelocityDbComparer<T>
where T : IComparable

<SerializableAttribute>
Public Class HashCodeComparer(Of T As IComparable)
    Inherits VelocityDbComparer(Of T)
[SerializableAttribute]
generic<typename T>
where T : IComparable
public ref class HashCodeComparer : public VelocityDbComparer<T>
[<SerializableAttribute>]
type HashCodeComparer<'T when 'T : IComparable> =
    class
        inherit VelocityDbComparer<'T>
    end

Type Parameters

T
The type of object to compare which must implement IComparable

The HashCodeComparerT type exposes the following members.

Constructors
 | Name | Description
Public method | HashCodeComparerT | Initializes a new instance of the HashCodeComparerT class
Top
Methods
 | Name | Description
Public method | Compare | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Public method | SetComparisonArrayFromObject | Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes (Overrides VelocityDbComparerKeySetComparisonArrayFromObject(Key, Byte, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.Comparer Namespace


HashCodeComparer(T) Constructor

HashCodeComparerT Constructor

Initializes a new instance of the HashCodeComparerT class

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public HashCodeComparer()
Public Sub New
public:
HashCodeComparer()
new : unit -> HashCodeComparer
See Also

Reference

HashCodeComparerT Class
VelocityDb.Collection.Comparer Namespace


HashCodeComparer(T) Methods

HashCodeComparerT Methods

The HashCodeComparerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Compare | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Public method | SetComparisonArrayFromObject | Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes (Overrides VelocityDbComparerKeySetComparisonArrayFromObject(Key, Byte, Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

HashCodeComparerT Class
VelocityDb.Collection.Comparer Namespace


HashCodeComparer(T).Compare Method

HashCodeComparerTCompare Method

If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Compare(
    T a,
    T b
)
Public Overrides Function Compare (
    a As T,
    b As T
) As Integer
public:
virtual int Compare(
    T a,
    T b
) override
abstract Compare :
        a : 'T *
        b : 'T -> int
override Compare :
        a : 'T *
        b : 'T -> int

Parameters

a
Type: T
object a to compare
b
Type: T
object b to compare with

Return Value

Type: Int32
-1 if a less than b, 0 if == and 1 if a is greater than b

Implements

IComparerTCompare(T, T)
See Also

Reference

HashCodeComparerT Class
VelocityDb.Collection.Comparer Namespace


HashCodeComparer(T).SetComparisonArrayFromObject Method

HashCodeComparerTSetComparisonArrayFromObject Method

Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetComparisonArrayFromObject(
    T key,
    byte[] comparisonArray,
    bool oidShort
)
Public Overrides Sub SetComparisonArrayFromObject (
    key As T,
    comparisonArray As Byte(),
    oidShort As Boolean
)
public:
virtual void SetComparisonArrayFromObject(
    T key,
    array<unsigned char>^ comparisonArray,
    bool oidShort
) override
abstract SetComparisonArrayFromObject :
        key : 'T *
        comparisonArray : byte[] *
        oidShort : bool -> unit
override SetComparisonArrayFromObject :
        key : 'T *
        comparisonArray : byte[] *
        oidShort : bool -> unit

Parameters

key
Type: T
The object from which to extract the comparison array bytes
comparisonArray
Type: SystemByte
The array containing the object comparison bytes
oidShort
Type: SystemBoolean
If oidShort is true then only the page and slot numbers need to be compared if the comparator bytes includes any Oid bytes
See Also

Reference

HashCodeComparerT Class
VelocityDb.Collection.Comparer Namespace


SimpleComparer(T) Class

SimpleComparerT Class

When the type of object being compared is a simple type like string, int, ..., this is the comparator you probably want to use.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.ComparerVelocityDbComparer T
VelocityDb.Collection.ComparerSimpleComparerT

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SimpleComparer<T> : VelocityDbComparer<T>
where T : IComparable

<SerializableAttribute>
Public Class SimpleComparer(Of T As IComparable)
    Inherits VelocityDbComparer(Of T)
[SerializableAttribute]
generic<typename T>
where T : IComparable
public ref class SimpleComparer : public VelocityDbComparer<T>
[<SerializableAttribute>]
type SimpleComparer<'T when 'T : IComparable> =
    class
        inherit VelocityDbComparer<'T>
    end

Type Parameters

T
The type of object to compare which must implement IComparable

The SimpleComparerT type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleComparerT | Initializes a new instance of the SimpleComparerT class
Top
Methods
 | Name | Description
Public method | Compare | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.Comparer Namespace


SimpleComparer(T) Constructor

SimpleComparerT Constructor

Initializes a new instance of the SimpleComparerT class

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SimpleComparer()
Public Sub New
public:
SimpleComparer()
new : unit -> SimpleComparer
See Also

Reference

SimpleComparerT Class
VelocityDb.Collection.Comparer Namespace


SimpleComparer(T) Methods

SimpleComparerT Methods

The SimpleComparerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Compare | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared (Overrides VelocityDbComparerKeyCompare(Key, Key).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

SimpleComparerT Class
VelocityDb.Collection.Comparer Namespace


SimpleComparer(T).Compare Method

SimpleComparerTCompare Method

If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int Compare(
    T a,
    T b
)
Public Overrides Function Compare (
    a As T,
    b As T
) As Integer
public:
virtual int Compare(
    T a,
    T b
) override
abstract Compare :
        a : 'T *
        b : 'T -> int
override Compare :
        a : 'T *
        b : 'T -> int

Parameters

a
Type: T
object a to compare
b
Type: T
object b to compare with

Return Value

Type: Int32
-1 if a less than b, 0 if == and 1 if a is greater than b

Implements

IComparerTCompare(T, T)
See Also

Reference

SimpleComparerT Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key) Class

VelocityDbComparerKey Class

The base class of for comparing persistent objects. If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.Collection.ComparerVelocityDbComparerKey
VelocityDb.Collection.ComparerCompareByFieldKey
VelocityDb.Collection.ComparerHashCodeComparerT
VelocityDb.Collection.ComparerSimpleComparerT

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VelocityDbComparer<Key> : OptimizedPersistable,
    IComparer<Key>

<SerializableAttribute>
Public Class VelocityDbComparer(Of Key)
    Inherits OptimizedPersistable
    Implements IComparer(Of Key)
[SerializableAttribute]
generic<typename Key>
public ref class VelocityDbComparer : public OptimizedPersistable,
    IComparer<Key>
[<SerializableAttribute>]
type VelocityDbComparer<'Key> =
    class
        inherit OptimizedPersistable
        interface IComparer<'Key>
    end

Type Parameters

Key
The type of keys to compare

The VelocityDbComparerKey type exposes the following members.

Constructors
 | Name | Description
Public method | VelocityDbComparerKey | Initializes a new instance of the VelocityDbComparerKey class
Top
Properties
 | Name | Description
Public property | AddOidCompare | The default compare compares the object Oid's but subclasses may not want to do so as a last compare before declaring objects as being equal.
Public property | OidPartOfComparisonBytes | Is the Oid part of the comparison bytes? If so, we don't need to do a separate Oid compare when Oid is part of compare
Top
Methods
 | Name | Description
Public method | Compare(Key, Key) | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared
Public method | Compare(Byte, Int32, Byte, Key) | Internal use, compares comparison array bytes
Public method | SetComparisonArrayFromObject | Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key) Constructor

VelocityDbComparerKey Constructor

Initializes a new instance of the VelocityDbComparerKey class

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbComparer()
Public Sub New
public:
VelocityDbComparer()
new : unit -> VelocityDbComparer
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key) Properties

VelocityDbComparerKey Properties

The VelocityDbComparerKey generic type exposes the following members.

Properties
 | Name | Description
Public property | AddOidCompare | The default compare compares the object Oid's but subclasses may not want to do so as a last compare before declaring objects as being equal.
Public property | OidPartOfComparisonBytes | Is the Oid part of the comparison bytes? If so, we don't need to do a separate Oid compare when Oid is part of compare
Top
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).AddOidCompare Property

VelocityDbComparerKeyAddOidCompare Property

The default compare compares the object Oid's but subclasses may not want to do so as a last compare before declaring objects as being equal.

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AddOidCompare { get; }
Public Overridable ReadOnly Property AddOidCompare As Boolean
    Get
public:
virtual property bool AddOidCompare {
    bool get ();
}
abstract AddOidCompare : bool with get
override AddOidCompare : bool with get

Property Value

Type: Boolean
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).OidPartOfComparisonBytes Property

VelocityDbComparerKeyOidPartOfComparisonBytes Property

Is the Oid part of the comparison bytes? If so, we don't need to do a separate Oid compare when Oid is part of compare

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OidPartOfComparisonBytes { get; }
Public Overridable ReadOnly Property OidPartOfComparisonBytes As Boolean
    Get
public:
virtual property bool OidPartOfComparisonBytes {
    bool get ();
}
abstract OidPartOfComparisonBytes : bool with get
override OidPartOfComparisonBytes : bool with get

Property Value

Type: Boolean
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key) Methods

VelocityDbComparerKey Methods

The VelocityDbComparerKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Compare(Key, Key) | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared
Public method | Compare(Byte, Int32, Byte, Key) | Internal use, compares comparison array bytes
Public method | SetComparisonArrayFromObject | Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).Compare Method

VelocityDbComparerKeyCompare Method

Overload List
 | Name | Description
Public method | Compare(Key, Key) | If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared
Public method | Compare(Byte, Int32, Byte, Key) | Internal use, compares comparison array bytes
Top
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).Compare Method (Key, Key)

VelocityDbComparerKeyCompare Method (Key, Key)

If the Key objects implements IComparable then the NodeKeys are compared that way, otherwise the Id are compared

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual int Compare(
    Key a,
    Key b
)
Public Overridable Function Compare (
    a As Key,
    b As Key
) As Integer
public:
virtual int Compare(
    Key a,
    Key b
)
abstract Compare :
        a : 'Key *
        b : 'Key -> int
override Compare :
        a : 'Key *
        b : 'Key -> int

Parameters

a
Type: Key
object a to compare
b
Type: Key
object b to compare with

Return Value

Type: Int32
-1 if a less than b, 0 if == and 1 if a is greater than b

Implements

IComparerTCompare(T, T)
See Also

Reference

VelocityDbComparerKey Class
Compare Overload
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).Compare Method (Byte[], Int32, Byte[], Key)

VelocityDbComparerKeyCompare Method (Byte, Int32, Byte, Key)

Internal use, compares comparison array bytes

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual int Compare(
    byte[] nodeComparisonArray,
    int index,
    byte[] comparisonArray,
    Key key
)
Public Overridable Function Compare (
    nodeComparisonArray As Byte(),
    index As Integer,
    comparisonArray As Byte(),
    key As Key
) As Integer
public:
virtual int Compare(
    array<unsigned char>^ nodeComparisonArray,
    int index,
    array<unsigned char>^ comparisonArray,
    Key key
)
abstract Compare :
        nodeComparisonArray : byte[] *
        index : int *
        comparisonArray : byte[] *
        key : 'Key -> int
override Compare :
        nodeComparisonArray : byte[] *
        index : int *
        comparisonArray : byte[] *
        key : 'Key -> int

Parameters

nodeComparisonArray
Type: SystemByte
BTree node array of Byte for all current objects in node
index
Type: SystemInt32
Object index in node to compare with
comparisonArray
Type: SystemByte
Bytes to compare with
key
Type: Key
Object compared with

Return Value

Type: Int32
-1 if this node bytes is less than comparisonArray bytes, 0 if equal, otherwise 1
See Also

Reference

VelocityDbComparerKey Class
Compare Overload
VelocityDb.Collection.Comparer Namespace


VelocityDbComparer(Key).SetComparisonArrayFromObject Method

VelocityDbComparerKeySetComparisonArrayFromObject Method

Comparators that use comparison arrays need to override this function. Given a Key object, set the comparisonArray bytes

Namespace: VelocityDb.Collection.Comparer
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetComparisonArrayFromObject(
    Key key,
    byte[] comparisonArray,
    bool oidShort
)
Public Overridable Sub SetComparisonArrayFromObject (
    key As Key,
    comparisonArray As Byte(),
    oidShort As Boolean
)
public:
virtual void SetComparisonArrayFromObject(
    Key key,
    array<unsigned char>^ comparisonArray,
    bool oidShort
)
abstract SetComparisonArrayFromObject :
        key : 'Key *
        comparisonArray : byte[] *
        oidShort : bool -> unit
override SetComparisonArrayFromObject :
        key : 'Key *
        comparisonArray : byte[] *
        oidShort : bool -> unit

Parameters

key
Type: Key
The object from which to extract the comparison array bytes
comparisonArray
Type: SystemByte
The array containing the object comparison bytes
oidShort
Type: SystemBoolean
If oidShort is true then only the page and slot numbers need to be compared if the comparator bytes includes any Oid bytes
See Also

Reference

VelocityDbComparerKey Class
VelocityDb.Collection.Comparer Namespace


VelocityDb.Exceptions Namespace

The VelocityDb.Session namespace contains all exceptions that may be thrown by VelocityDB code.
Classes
 | Class | Description
Public class | AlreadyInCommitException | Exception thrown when attempting to commit a transaction when we already are within transaction commit code.
Public class | AlreadyInTransactionException | Exception thrown when attempting to start a transaction when an active transaction already exist.
Public class | DatabaseAlreadyExistsException | Exception thrown when trying to create a Database that already exist (file system file exist).
Public class | DatabaseDoesNotExistException | Exception thrown when the requested >Database does not exist.
Public class | DatabaseReadLockException | Exception thrown when a Database level read lock failed.
Public class | DesKeyMissingException | Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Public class | FieldDoesNotExistException | Exception thrown when specifying a field name that does not exist in the given class/struct.
Public class | IndexDatabaseNotSpecifiedException | Exception thrown when attempting to open an in database index without specifying a database.
Public class | IndexDatabaseOrBTreeMissingException | Exception thrown when attempting to open an in database index without specifying a database.
Public class | IndexDatabaseSpecifiedForGlobalIndexException | Exception thrown when attempting to open a global index and specifying a database.
Public class | InternalErrorException | Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Public class | InTransactionException | Exception thrown when calling certain SessionBase api that requires that session IS NOT in an active transaction.
Public class | InUpdateTransactionException | Exception thrown when calling certain SessionBase api that requires that session IS NOT in an active update transaction.
Public class | InvalidChangeOfDatabaseLocation | Exception thrown when trying to do an invalid change of a DatabaseLocation. It could be a change to the start database number that if permitted skips one or more other DatabaseLocations.
Public class | InvalidChangeOfDefaultLocationException | Exception thrown when trying to do an invalid change of the startup DatabaseLocation.
Public class | MaxNumberOfDatabasesException | Exception thrown when trying to create a Database but no more Database numbers are available. The Maximum Database number is MaxValue or 13 if no valid license is found.
Public class | NotInTransactionException | Exception thrown when trying to do persistent operations without first starting a transaction.
Public class | NoValidVelocityDBLicenseFoundException | Exception thrown when trying to add/update database schema and no valid VelocityDB license is found in license database (4.odb).
Public class | NullObjectException | Exception thrown when an object unexpectedly is null.
Public class | ObjectDoesNotExistException | Exception thrown when the requested >IOptimizedPersistable does not exist.
Public class | ObjectNotInSameDatabaseAsOidShortCollectionException | Exception thrown when object is not in the same database as a ShortOid collection Database failed.
Public class | OpenDatabaseException | Exception thrown when openeing a Database failed.
Public class | OptimisticLockingFailed | Exception thrown when a optimistic locking failed due to another transcation having updated a Page or Database.
Public class | PageDeadLockException | Exception thrown when a Page level lock failed due to a deadlock with another transaction
Public class | PageDoesNotExistException | Exception thrown when the requested >Page does not exist.
Public class | PageReadLockException | Exception thrown when failing to get a Page level read lock.
Public class | PageUpdateLockException | Exception thrown when a Page level update lock failed.
Public class | PersistedObjectExcpectedException | Exception thrown when a persisted object wsa expected but was not.
Public class | ReferentialIntegrityException | Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Public class | RequestedPlacementDatabaseNumberNotValidException | Exception thrown when a requested placement Database number is invalid.
Public class | RequestedPlacementPageNumberNotValidException | Exception thrown when a requested placement Page number is invalid.
Public class | SubscriptionsNotAvailableWithNoServerSessionException | Exception thrown when trying to use event subscription api with NON server session. Subscriptions require use of server.
Public class | SystemDatabaseNotFoundWithReadonlyTransactionException | Exception thrown when a read only transaction try to open a non existing Database 0
Public class | TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException | Exception thrown when attempting to start a read only transaction while in an update transaction.
Public class | TryingToDeleteDeletedDatabaseException | Exception thrown when attempting to delete a Database that already was deleted in the same transaction
Public class | UnexpectedException | Exception thrown when something unexpected happened and no specific exception exist for it.
Public class | UniqueConstraintException | Exception thrown when attempting to open an in database index without specifying a database.
Public class | UpdateLockFailedException | Exception thrown when an update lock failed.
Public class | WeakIOptimizedPersistableReferenceMustBePersistentException | Exception thrown when a persisted object wsa expected but was not.


AlreadyInCommitException Class

Exception thrown when attempting to commit a transaction when we already are within transaction commit code.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsAlreadyInCommitException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AlreadyInCommitException : Exception
<SerializableAttribute>
Public Class AlreadyInCommitException
    Inherits Exception
[SerializableAttribute]
public ref class AlreadyInCommitException : public Exception
[<SerializableAttribute>]
type AlreadyInCommitException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


AlreadyInTransactionException Class

Exception thrown when attempting to start a transaction when an active transaction already exist.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsAlreadyInTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AlreadyInTransactionException : Exception
<SerializableAttribute>
Public Class AlreadyInTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class AlreadyInTransactionException : public Exception
[<SerializableAttribute>]
type AlreadyInTransactionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Class

Exception thrown when trying to create a Database that already exist (file system file exist).
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsDatabaseAlreadyExistsException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DatabaseAlreadyExistsException : Exception
<SerializableAttribute>
Public Class DatabaseAlreadyExistsException
    Inherits Exception
[SerializableAttribute]
public ref class DatabaseAlreadyExistsException : public Exception
[<SerializableAttribute>]
type DatabaseAlreadyExistsException =
    class
        inherit Exception
    end
Constructors
 | Name | Description
Public method | DatabaseAlreadyExistsException | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(String) | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(SerializationInfo, StreamingContext) | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(String, Exception) | Initializes a new instance of the DatabaseAlreadyExistsException class
Top
See Also

Reference

VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Constructor

Overload List
 | Name | Description
Public method | DatabaseAlreadyExistsException | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(String) | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(SerializationInfo, StreamingContext) | Initializes a new instance of the DatabaseAlreadyExistsException class
Public method | DatabaseAlreadyExistsException(String, Exception) | Initializes a new instance of the DatabaseAlreadyExistsException class
Top
See Also

Reference

DatabaseAlreadyExistsException Class
VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Constructor

Initializes a new instance of the DatabaseAlreadyExistsException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseAlreadyExistsException()
Public Sub New
public:
DatabaseAlreadyExistsException()
new : unit -> DatabaseAlreadyExistsException
See Also

Reference

DatabaseAlreadyExistsException Class
DatabaseAlreadyExistsException Overload
VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Constructor (String)

Initializes a new instance of the DatabaseAlreadyExistsException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseAlreadyExistsException(
    string message
)
Public Sub New (
    message As String
)
public:
DatabaseAlreadyExistsException(
    String^ message
)
new :
        message : string -> DatabaseAlreadyExistsException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.DatabaseAlreadyExistsException.#ctor(System.String)"]

See Also

Reference

DatabaseAlreadyExistsException Class
DatabaseAlreadyExistsException Overload
VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the DatabaseAlreadyExistsException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseAlreadyExistsException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
DatabaseAlreadyExistsException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DatabaseAlreadyExistsException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

[Missing <param name="info"/> documentation for "M:VelocityDb.Exceptions.DatabaseAlreadyExistsException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.SerializationStreamingContext

[Missing <param name="context"/> documentation for "M:VelocityDb.Exceptions.DatabaseAlreadyExistsException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

Reference

DatabaseAlreadyExistsException Class
DatabaseAlreadyExistsException Overload
VelocityDb.Exceptions Namespace


DatabaseAlreadyExistsException Constructor (String, Exception)

Initializes a new instance of the DatabaseAlreadyExistsException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseAlreadyExistsException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
DatabaseAlreadyExistsException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> DatabaseAlreadyExistsException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.DatabaseAlreadyExistsException.#ctor(System.String,System.Exception)"]

inner
Type: SystemException

[Missing <param name="inner"/> documentation for "M:VelocityDb.Exceptions.DatabaseAlreadyExistsException.#ctor(System.String,System.Exception)"]

See Also

Reference

DatabaseAlreadyExistsException Class
DatabaseAlreadyExistsException Overload
VelocityDb.Exceptions Namespace


DatabaseDoesNotExistException Class

Exception thrown when the requested >Database does not exist.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsDatabaseDoesNotExistException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DatabaseDoesNotExistException : Exception
<SerializableAttribute>
Public Class DatabaseDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class DatabaseDoesNotExistException : public Exception
[<SerializableAttribute>]
type DatabaseDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


DatabaseReadLockException Class

Exception thrown when a Database level read lock failed.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsDatabaseReadLockException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DatabaseReadLockException : Exception
<SerializableAttribute>
Public Class DatabaseReadLockException
    Inherits Exception
[SerializableAttribute]
public ref class DatabaseReadLockException : public Exception
[<SerializableAttribute>]
type DatabaseReadLockException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


DesKeyMissingException Class

Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsDesKeyMissingException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DesKeyMissingException : Exception
<SerializableAttribute>
Public Class DesKeyMissingException
    Inherits Exception
[SerializableAttribute]
public ref class DesKeyMissingException : public Exception
[<SerializableAttribute>]
type DesKeyMissingException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


FieldDoesNotExistException Class

Exception thrown when specifying a field name that does not exist in the given class/struct.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsFieldDoesNotExistException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FieldDoesNotExistException : Exception
<SerializableAttribute>
Public Class FieldDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class FieldDoesNotExistException : public Exception
[<SerializableAttribute>]
type FieldDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


IndexDatabaseNotSpecifiedException Class

Exception thrown when attempting to open an in database index without specifying a database.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsIndexDatabaseNotSpecifiedException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class IndexDatabaseNotSpecifiedException : Exception
<SerializableAttribute>
Public Class IndexDatabaseNotSpecifiedException
    Inherits Exception
[SerializableAttribute]
public ref class IndexDatabaseNotSpecifiedException : public Exception
[<SerializableAttribute>]
type IndexDatabaseNotSpecifiedException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


IndexDatabaseOrBTreeMissingException Class

Exception thrown when attempting to open an in database index without specifying a database.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsIndexDatabaseOrBTreeMissingException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class IndexDatabaseOrBTreeMissingException : Exception
<SerializableAttribute>
Public Class IndexDatabaseOrBTreeMissingException
    Inherits Exception
[SerializableAttribute]
public ref class IndexDatabaseOrBTreeMissingException : public Exception
[<SerializableAttribute>]
type IndexDatabaseOrBTreeMissingException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


IndexDatabaseSpecifiedForGlobalIndexException Class

Exception thrown when attempting to open a global index and specifying a database.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsIndexDatabaseSpecifiedForGlobalIndexException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class IndexDatabaseSpecifiedForGlobalIndexException : Exception
<SerializableAttribute>
Public Class IndexDatabaseSpecifiedForGlobalIndexException
    Inherits Exception
[SerializableAttribute]
public ref class IndexDatabaseSpecifiedForGlobalIndexException : public Exception
[<SerializableAttribute>]
type IndexDatabaseSpecifiedForGlobalIndexException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


InternalErrorException Class

Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsInternalErrorException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InternalErrorException : Exception
<SerializableAttribute>
Public Class InternalErrorException
    Inherits Exception
[SerializableAttribute]
public ref class InternalErrorException : public Exception
[<SerializableAttribute>]
type InternalErrorException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


InTransactionException Class

Exception thrown when calling certain SessionBase api that requires that session IS NOT in an active transaction.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsInTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InTransactionException : Exception
<SerializableAttribute>
Public Class InTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class InTransactionException : public Exception
[<SerializableAttribute>]
type InTransactionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


InUpdateTransactionException Class

Exception thrown when calling certain SessionBase api that requires that session IS NOT in an active update transaction.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsInUpdateTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InUpdateTransactionException : Exception
<SerializableAttribute>
Public Class InUpdateTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class InUpdateTransactionException : public Exception
[<SerializableAttribute>]
type InUpdateTransactionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


InvalidChangeOfDatabaseLocation Class

Exception thrown when trying to do an invalid change of a DatabaseLocation. It could be a change to the start database number that if permitted skips one or more other DatabaseLocations.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsInvalidChangeOfDatabaseLocation

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidChangeOfDatabaseLocation : Exception
<SerializableAttribute>
Public Class InvalidChangeOfDatabaseLocation
    Inherits Exception
[SerializableAttribute]
public ref class InvalidChangeOfDatabaseLocation : public Exception
[<SerializableAttribute>]
type InvalidChangeOfDatabaseLocation =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


InvalidChangeOfDefaultLocationException Class

Exception thrown when trying to do an invalid change of the startup DatabaseLocation.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsInvalidChangeOfDefaultLocationException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidChangeOfDefaultLocationException : Exception
<SerializableAttribute>
Public Class InvalidChangeOfDefaultLocationException
    Inherits Exception
[SerializableAttribute]
public ref class InvalidChangeOfDefaultLocationException : public Exception
[<SerializableAttribute>]
type InvalidChangeOfDefaultLocationException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


MaxNumberOfDatabasesException Class

Exception thrown when trying to create a Database but no more Database numbers are available. The Maximum Database number is MaxValue or 13 if no valid license is found.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsMaxNumberOfDatabasesException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class MaxNumberOfDatabasesException : Exception
<SerializableAttribute>
Public Class MaxNumberOfDatabasesException
    Inherits Exception
[SerializableAttribute]
public ref class MaxNumberOfDatabasesException : public Exception
[<SerializableAttribute>]
type MaxNumberOfDatabasesException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


NotInTransactionException Class

Exception thrown when trying to do persistent operations without first starting a transaction.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsNotInTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NotInTransactionException : Exception
<SerializableAttribute>
Public Class NotInTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class NotInTransactionException : public Exception
[<SerializableAttribute>]
type NotInTransactionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


NoValidVelocityDBLicenseFoundException Class

Exception thrown when trying to add/update database schema and no valid VelocityDB license is found in license database (4.odb).
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsNoValidVelocityDBLicenseFoundException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NoValidVelocityDBLicenseFoundException : Exception
<SerializableAttribute>
Public Class NoValidVelocityDBLicenseFoundException
    Inherits Exception
[SerializableAttribute]
public ref class NoValidVelocityDBLicenseFoundException : public Exception
[<SerializableAttribute>]
type NoValidVelocityDBLicenseFoundException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


NullObjectException Class

Exception thrown when an object unexpectedly is null.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsNullObjectException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NullObjectException : Exception
<SerializableAttribute>
Public Class NullObjectException
    Inherits Exception
[SerializableAttribute]
public ref class NullObjectException : public Exception
[<SerializableAttribute>]
type NullObjectException =
    class
        inherit Exception
    end
Constructors
 | Name | Description
Public method | NullObjectException | Initializes a new instance of the NullObjectException class
Public method | NullObjectException(String) | Initializes a new instance of the NullObjectException class
Top
See Also

Reference

VelocityDb.Exceptions Namespace


NullObjectException Constructor

Overload List
 | Name | Description
Public method | NullObjectException | Initializes a new instance of the NullObjectException class
Public method | NullObjectException(String) | Initializes a new instance of the NullObjectException class
Top
See Also

Reference

NullObjectException Class
VelocityDb.Exceptions Namespace


NullObjectException Constructor

Initializes a new instance of the NullObjectException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public NullObjectException()
Public Sub New
public:
NullObjectException()
new : unit -> NullObjectException
See Also

Reference

NullObjectException Class
NullObjectException Overload
VelocityDb.Exceptions Namespace


NullObjectException Constructor (String)

Initializes a new instance of the NullObjectException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public NullObjectException(
    string message
)
Public Sub New (
    message As String
)
public:
NullObjectException(
    String^ message
)
new :
        message : string -> NullObjectException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.NullObjectException.#ctor(System.String)"]

See Also

Reference

NullObjectException Class
NullObjectException Overload
VelocityDb.Exceptions Namespace


ObjectDoesNotExistException Class

Exception thrown when the requested >IOptimizedPersistable does not exist.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsObjectDoesNotExistException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ObjectDoesNotExistException : Exception
<SerializableAttribute>
Public Class ObjectDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class ObjectDoesNotExistException : public Exception
[<SerializableAttribute>]
type ObjectDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


ObjectNotInSameDatabaseAsOidShortCollectionException Class

Exception thrown when object is not in the same database as a ShortOid collection Database failed.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsObjectNotInSameDatabaseAsOidShortCollectionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ObjectNotInSameDatabaseAsOidShortCollectionException : Exception
<SerializableAttribute>
Public Class ObjectNotInSameDatabaseAsOidShortCollectionException
    Inherits Exception
[SerializableAttribute]
public ref class ObjectNotInSameDatabaseAsOidShortCollectionException : public Exception
[<SerializableAttribute>]
type ObjectNotInSameDatabaseAsOidShortCollectionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


OpenDatabaseException Class

Exception thrown when openeing a Database failed.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsOpenDatabaseException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class OpenDatabaseException : Exception
<SerializableAttribute>
Public Class OpenDatabaseException
    Inherits Exception
[SerializableAttribute]
public ref class OpenDatabaseException : public Exception
[<SerializableAttribute>]
type OpenDatabaseException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


OptimisticLockingFailed Class

Exception thrown when a optimistic locking failed due to another transcation having updated a Page or Database.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsOptimisticLockingFailed

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class OptimisticLockingFailed : Exception
<SerializableAttribute>
Public Class OptimisticLockingFailed
    Inherits Exception
[SerializableAttribute]
public ref class OptimisticLockingFailed : public Exception
[<SerializableAttribute>]
type OptimisticLockingFailed =
    class
        inherit Exception
    end

The OptimisticLockingFailed type exposes the following members.

Constructors
 | Name | Description
Public method | OptimisticLockingFailed | Initializes a new instance of the OptimisticLockingFailed class
Top
See Also

Reference

VelocityDb.Exceptions Namespace


OptimisticLockingFailed Constructor

Initializes a new instance of the OptimisticLockingFailed class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OptimisticLockingFailed(
    string message
)
Public Sub New (
    message As String
)
public:
OptimisticLockingFailed(
    String^ message
)
new :
        message : string -> OptimisticLockingFailed

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.OptimisticLockingFailed.#ctor(System.String)"]

See Also

Reference

OptimisticLockingFailed Class
VelocityDb.Exceptions Namespace


PageDeadLockException Class

Exception thrown when a Page level lock failed due to a deadlock with another transaction
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsPageDeadLockException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PageDeadLockException : Exception
<SerializableAttribute>
Public Class PageDeadLockException
    Inherits Exception
[SerializableAttribute]
public ref class PageDeadLockException : public Exception
[<SerializableAttribute>]
type PageDeadLockException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


PageDoesNotExistException Class

Exception thrown when the requested >Page does not exist.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsPageDoesNotExistException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PageDoesNotExistException : Exception
<SerializableAttribute>
Public Class PageDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class PageDoesNotExistException : public Exception
[<SerializableAttribute>]
type PageDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


PageReadLockException Class

Exception thrown when failing to get a Page level read lock.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsPageReadLockException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PageReadLockException : Exception
<SerializableAttribute>
Public Class PageReadLockException
    Inherits Exception
[SerializableAttribute]
public ref class PageReadLockException : public Exception
[<SerializableAttribute>]
type PageReadLockException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


PageUpdateLockException Class

Exception thrown when a Page level update lock failed.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsPageUpdateLockException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PageUpdateLockException : Exception
<SerializableAttribute>
Public Class PageUpdateLockException
    Inherits Exception
[SerializableAttribute]
public ref class PageUpdateLockException : public Exception
[<SerializableAttribute>]
type PageUpdateLockException =
    class
        inherit Exception
    end

The PageUpdateLockException type exposes the following members.

Constructors
 | Name | Description
Public method | PageUpdateLockException | Initializes a new instance of the PageUpdateLockException class
Top
See Also

Reference

VelocityDb.Exceptions Namespace


PageUpdateLockException Constructor

Initializes a new instance of the PageUpdateLockException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PageUpdateLockException(
    string message
)
Public Sub New (
    message As String
)
public:
PageUpdateLockException(
    String^ message
)
new :
        message : string -> PageUpdateLockException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.PageUpdateLockException.#ctor(System.String)"]

See Also

Reference

PageUpdateLockException Class
VelocityDb.Exceptions Namespace


PersistedObjectExcpectedException Class

Exception thrown when a persisted object wsa expected but was not.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsPersistedObjectExcpectedException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PersistedObjectExcpectedException : Exception
<SerializableAttribute>
Public Class PersistedObjectExcpectedException
    Inherits Exception
[SerializableAttribute]
public ref class PersistedObjectExcpectedException : public Exception
[<SerializableAttribute>]
type PersistedObjectExcpectedException =
    class
        inherit Exception
    end

The PersistedObjectExcpectedException type exposes the following members.

Constructors
 | Name | Description
Public method | PersistedObjectExcpectedException | Initializes a new instance of the PersistedObjectExcpectedException class
Top
See Also

Reference

VelocityDb.Exceptions Namespace


PersistedObjectExcpectedException Constructor

Initializes a new instance of the PersistedObjectExcpectedException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PersistedObjectExcpectedException(
    string message
)
Public Sub New (
    message As String
)
public:
PersistedObjectExcpectedException(
    String^ message
)
new :
        message : string -> PersistedObjectExcpectedException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:VelocityDb.Exceptions.PersistedObjectExcpectedException.#ctor(System.String)"]

See Also

Reference

PersistedObjectExcpectedException Class
VelocityDb.Exceptions Namespace


ReferentialIntegrityException Class

Exception thrown when an internal error was detected. This type of error is most likly due to a bug in VelocityDb.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsReferentialIntegrityException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReferentialIntegrityException : Exception
<SerializableAttribute>
Public Class ReferentialIntegrityException
    Inherits Exception
[SerializableAttribute]
public ref class ReferentialIntegrityException : public Exception
[<SerializableAttribute>]
type ReferentialIntegrityException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


RequestedPlacementDatabaseNumberNotValidException Class

Exception thrown when a requested placement Database number is invalid.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsRequestedPlacementDatabaseNumberNotValidException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RequestedPlacementDatabaseNumberNotValidException : Exception
<SerializableAttribute>
Public Class RequestedPlacementDatabaseNumberNotValidException
    Inherits Exception
[SerializableAttribute]
public ref class RequestedPlacementDatabaseNumberNotValidException : public Exception
[<SerializableAttribute>]
type RequestedPlacementDatabaseNumberNotValidException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


RequestedPlacementPageNumberNotValidException Class

Exception thrown when a requested placement Page number is invalid.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsRequestedPlacementPageNumberNotValidException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RequestedPlacementPageNumberNotValidException : Exception
<SerializableAttribute>
Public Class RequestedPlacementPageNumberNotValidException
    Inherits Exception
[SerializableAttribute]
public ref class RequestedPlacementPageNumberNotValidException : public Exception
[<SerializableAttribute>]
type RequestedPlacementPageNumberNotValidException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


SubscriptionsNotAvailableWithNoServerSessionException Class

Exception thrown when trying to use event subscription api with NON server session. Subscriptions require use of server.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsSubscriptionsNotAvailableWithNoServerSessionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SubscriptionsNotAvailableWithNoServerSessionException : Exception
<SerializableAttribute>
Public Class SubscriptionsNotAvailableWithNoServerSessionException
    Inherits Exception
[SerializableAttribute]
public ref class SubscriptionsNotAvailableWithNoServerSessionException : public Exception
[<SerializableAttribute>]
type SubscriptionsNotAvailableWithNoServerSessionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


SystemDatabaseNotFoundWithReadonlyTransactionException Class

Exception thrown when a read only transaction try to open a non existing Database 0
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsSystemDatabaseNotFoundWithReadonlyTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SystemDatabaseNotFoundWithReadonlyTransactionException : Exception
<SerializableAttribute>
Public Class SystemDatabaseNotFoundWithReadonlyTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class SystemDatabaseNotFoundWithReadonlyTransactionException : public Exception
[<SerializableAttribute>]
type SystemDatabaseNotFoundWithReadonlyTransactionException =
    class
        inherit Exception
    end

The SystemDatabaseNotFoundWithReadonlyTransactionException type exposes the following members.

Constructors
 | Name | Description
Public method | SystemDatabaseNotFoundWithReadonlyTransactionException | Use for unexpected events
Top
See Also

Reference

VelocityDb.Exceptions Namespace


SystemDatabaseNotFoundWithReadonlyTransactionException Constructor

Use for unexpected events

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SystemDatabaseNotFoundWithReadonlyTransactionException(
    string message
)
Public Sub New (
    message As String
)
public:
SystemDatabaseNotFoundWithReadonlyTransactionException(
    String^ message
)
new :
        message : string -> SystemDatabaseNotFoundWithReadonlyTransactionException

Parameters

message
Type: SystemString
Describe the unexpected event
See Also

Reference

SystemDatabaseNotFoundWithReadonlyTransactionException Class
VelocityDb.Exceptions Namespace


TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException Class

Exception thrown when attempting to start a read only transaction while in an update transaction.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsTryingToBeginReadOnlyTransactionWhileInUpdateTransactionException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException : Exception
<SerializableAttribute>
Public Class TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException
    Inherits Exception
[SerializableAttribute]
public ref class TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException : public Exception
[<SerializableAttribute>]
type TryingToBeginReadOnlyTransactionWhileInUpdateTransactionException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


TryingToDeleteDeletedDatabaseException Class

Exception thrown when attempting to delete a Database that already was deleted in the same transaction
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsTryingToDeleteDeletedDatabaseException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TryingToDeleteDeletedDatabaseException : Exception
<SerializableAttribute>
Public Class TryingToDeleteDeletedDatabaseException
    Inherits Exception
[SerializableAttribute]
public ref class TryingToDeleteDeletedDatabaseException : public Exception
[<SerializableAttribute>]
type TryingToDeleteDeletedDatabaseException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


UnexpectedException Class

Exception thrown when something unexpected happened and no specific exception exist for it.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsUnexpectedException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UnexpectedException : Exception
<SerializableAttribute>
Public Class UnexpectedException
    Inherits Exception
[SerializableAttribute]
public ref class UnexpectedException : public Exception
[<SerializableAttribute>]
type UnexpectedException =
    class
        inherit Exception
    end
Constructors
 | Name | Description
Public method | UnexpectedException | Initializes a new instance of the UnexpectedException class
Public method | UnexpectedException(String) | Use for unexpected events
Top
See Also

Reference

VelocityDb.Exceptions Namespace


UnexpectedException Constructor

Overload List
 | Name | Description
Public method | UnexpectedException | Initializes a new instance of the UnexpectedException class
Public method | UnexpectedException(String) | Use for unexpected events
Top
See Also

Reference

UnexpectedException Class
VelocityDb.Exceptions Namespace


UnexpectedException Constructor

Initializes a new instance of the UnexpectedException class

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UnexpectedException()
Public Sub New
public:
UnexpectedException()
new : unit -> UnexpectedException
See Also

Reference

UnexpectedException Class
UnexpectedException Overload
VelocityDb.Exceptions Namespace


UnexpectedException Constructor (String)

Use for unexpected events

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UnexpectedException(
    string message
)
Public Sub New (
    message As String
)
public:
UnexpectedException(
    String^ message
)
new :
        message : string -> UnexpectedException

Parameters

message
Type: SystemString
Describe the unexpected event
See Also

Reference

UnexpectedException Class
UnexpectedException Overload
VelocityDb.Exceptions Namespace


UniqueConstraintException Class

Exception thrown when attempting to open an in database index without specifying a database.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsUniqueConstraintException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UniqueConstraintException : Exception
<SerializableAttribute>
Public Class UniqueConstraintException
    Inherits Exception
[SerializableAttribute]
public ref class UniqueConstraintException : public Exception
[<SerializableAttribute>]
type UniqueConstraintException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


UpdateLockFailedException Class

Exception thrown when an update lock failed.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsUpdateLockFailedException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UpdateLockFailedException : Exception
<SerializableAttribute>
Public Class UpdateLockFailedException
    Inherits Exception
[SerializableAttribute]
public ref class UpdateLockFailedException : public Exception
[<SerializableAttribute>]
type UpdateLockFailedException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


WeakIOptimizedPersistableReferenceMustBePersistentException Class

Exception thrown when a persisted object wsa expected but was not.
Inheritance Hierarchy
SystemObject
SystemException
VelocityDb.ExceptionsWeakIOptimizedPersistableReferenceMustBePersistentException

Namespace: VelocityDb.Exceptions
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WeakIOptimizedPersistableReferenceMustBePersistentException : Exception
<SerializableAttribute>
Public Class WeakIOptimizedPersistableReferenceMustBePersistentException
    Inherits Exception
[SerializableAttribute]
public ref class WeakIOptimizedPersistableReferenceMustBePersistentException : public Exception
[<SerializableAttribute>]
type WeakIOptimizedPersistableReferenceMustBePersistentException =
    class
        inherit Exception
    end
See Also

Reference

VelocityDb.Exceptions Namespace


VelocityDb.Indexing Namespace

The VelocityDB.Indexing namespace contains classes for the VelocityDB indexing feature
Classes
 | Class | Description
Public class | Index | Use only with IOptimizedPersistable See http://www.velocitydb.com/UserGuide.aspx#_Toc430849968
Public class | IndexStringByHashCode | Sort string field by a computed hash instead of normal string ordering.
Public class | OnePerDatabase | Use this attribute if you want each index to contain objects of a single database, this type of index is stored within the same database as its indexed objects.
Public class | UniqueConstraint | Unique index values can be required by using the UniqueConstraint attribute


Index Class

Use only with IOptimizedPersistable See http://www.velocitydb.com/UserGuide.aspx#_Toc430849968
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.IndexingIndex

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class Index : Attribute
Public NotInheritable Class Index
    Inherits Attribute
public ref class Index sealed : public Attribute
[<SealedAttribute>]
type Index =
    class
        inherit Attribute
    end

The Index type exposes the following members.

Constructors
 | Name | Description
Public method | Index | Index by default field which is Id
Public method | Index(String) | Create index by one or more field names separated by comma. First field is used first in lookups then when there is multiple matches, field 2 is used and so on.
Top
Properties
 | Name | Description
Public property | FieldNames | Field names used by this index.
Top
See Also

Reference

VelocityDb.Indexing Namespace


Index Constructor

Overload List
 | Name | Description
Public method | Index | Index by default field which is Id
Public method | Index(String) | Create index by one or more field names separated by comma. First field is used first in lookups then when there is multiple matches, field 2 is used and so on.
Top
See Also

Reference

Index Class
VelocityDb.Indexing Namespace


Index Constructor

Index by default field which is Id

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Index()
Public Sub New
public:
Index()
new : unit -> Index
See Also

Reference

Index Class
Index Overload
VelocityDb.Indexing Namespace


Index Constructor (String)

Create index by one or more field names separated by comma. First field is used first in lookups then when there is multiple matches, field 2 is used and so on.

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Index(
    string fieldNames
)
Public Sub New (
    fieldNames As String
)
public:
Index(
    String^ fieldNames
)
new :
        fieldNames : string -> Index

Parameters

fieldNames
Type: SystemString
Field names in lookup order separated by comma.
See Also

Reference

Index Class
Index Overload
VelocityDb.Indexing Namespace


Index Properties

The Index type exposes the following members.

Properties
 | Name | Description
Public property | FieldNames | Field names used by this index.
Top
See Also

Reference

Index Class
VelocityDb.Indexing Namespace


Index.FieldNames Property

IndexFieldNames Property

Field names used by this index.

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string FieldNames { get; }
Public ReadOnly Property FieldNames As String
    Get
public:
property String^ FieldNames {
    String^ get ();
}
member FieldNames : string with get

Property Value

Type: String
See Also

Reference

Index Class
VelocityDb.Indexing Namespace


IndexStringByHashCode Class

Sort string field by a computed hash instead of normal string ordering.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.IndexingIndexStringByHashCode

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class IndexStringByHashCode : Attribute
Public NotInheritable Class IndexStringByHashCode
    Inherits Attribute
public ref class IndexStringByHashCode sealed : public Attribute
[<SealedAttribute>]
type IndexStringByHashCode =
    class
        inherit Attribute
    end

The IndexStringByHashCode type exposes the following members.

Constructors
 | Name | Description
Public method | IndexStringByHashCode | Initializes a new instance of the IndexStringByHashCode class
Top
See Also

Reference

VelocityDb.Indexing Namespace


IndexStringByHashCode Constructor

Initializes a new instance of the IndexStringByHashCode class

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IndexStringByHashCode()
Public Sub New
public:
IndexStringByHashCode()
new : unit -> IndexStringByHashCode
See Also

Reference

IndexStringByHashCode Class
VelocityDb.Indexing Namespace


OnePerDatabase Class

Use this attribute if you want each index to contain objects of a single database, this type of index is stored within the same database as its indexed objects.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.IndexingOnePerDatabase

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class OnePerDatabase : Attribute
Public NotInheritable Class OnePerDatabase
    Inherits Attribute
public ref class OnePerDatabase sealed : public Attribute
[<SealedAttribute>]
type OnePerDatabase =
    class
        inherit Attribute
    end

The OnePerDatabase type exposes the following members.

Constructors
 | Name | Description
Public method | OnePerDatabase | Initializes a new instance of the OnePerDatabase class
Top
See Also

Reference

VelocityDb.Indexing Namespace


OnePerDatabase Constructor

Initializes a new instance of the OnePerDatabase class

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OnePerDatabase()
Public Sub New
public:
OnePerDatabase()
new : unit -> OnePerDatabase
See Also

Reference

OnePerDatabase Class
VelocityDb.Indexing Namespace


UniqueConstraint Class

Unique index values can be required by using the UniqueConstraint attribute
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.IndexingUniqueConstraint

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class UniqueConstraint : Attribute
Public NotInheritable Class UniqueConstraint
    Inherits Attribute
public ref class UniqueConstraint sealed : public Attribute
[<SealedAttribute>]
type UniqueConstraint =
    class
        inherit Attribute
    end

The UniqueConstraint type exposes the following members.

Constructors
 | Name | Description
Public method | UniqueConstraint | Constructor
Top
See Also

Reference

VelocityDb.Indexing Namespace


UniqueConstraint Constructor

Constructor

Namespace: VelocityDb.Indexing
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UniqueConstraint()
Public Sub New
public:
UniqueConstraint()
new : unit -> UniqueConstraint
See Also

Reference

UniqueConstraint Class
VelocityDb.Indexing Namespace


VelocityDb.Session Namespace

The VelocityDb.Session namespace contains session classes for interfacing with VelocityDb
Classes
 | Class | Description
Public class | ReplicaInfo | Specifies a location for a replica of primary DatabaseLocation containing at least the system databases (0.odb, 1.odb, 2.odb ...)
Public class | ServerClientSession | Use this session class when Page level locking is required and/or not all Databases are local and not reachable by UNC paths.
Public class | ServerClientSessionShared | Use as a shared session for multiple reader threads connected to one or more VelocityDBServer(s).
Public class | SessionBase | Transaction control, database creation and special persistent object api. Each session can use 4,294,967,295 Databases. Each Database may have up to 65,535 Pages and a page can be up to 2 GB in size (.Net restriction of a byte array). The maximum data size a single session can manage is: 4,294,967,295 * 65,535 * 2147483648 = 604453686294542391705600 bytes or about half a Yottabyte http://en.wikipedia.org/wiki/Yottabyte
Public class | SessionBaseTransaction | Helper object to enable automatic rollback/abort of transaction if transaction isn't committed within it's scope.
Public class | SessionNoServer | Use this session class when Database level locking is acceptable and Databases are local or reachable by UNC paths.
Public class | SessionNoServerShared | Same as SessionNoServer but SessionNoServerShared is thread safe so it can be shared between threads.
Public class | SessionPool | Provides a pool of sessions for reuse instead of creating new session instances every time a session is needed. The pooled sessions includes cached databases, pages and objects. Keep the pool size to a minimum too avoid excessive memory usage.
Public class | TypeExtensions | Some extensions to Type


ReplicaInfo Class

Specifies a location for a replica of primary DatabaseLocation containing at least the system databases (0.odb, 1.odb, 2.odb ...)
Inheritance Hierarchy
SystemObject
VelocityDb.SessionReplicaInfo

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class ReplicaInfo : IComparable<ReplicaInfo>
Public Class ReplicaInfo
    Implements IComparable(Of ReplicaInfo)
public ref class ReplicaInfo : IComparable<ReplicaInfo^>
type ReplicaInfo =
    class
        interface IComparable<ReplicaInfo>
    end

The ReplicaInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaInfo | Initializes a new instance of the ReplicaInfo class
Top
Properties
 | Name | Description
Public property | Host | Host name (defaults to local host)
Public property | Path | Directory path to databases
Top
See Also

Reference

VelocityDb.Session Namespace


ReplicaInfo Constructor

Initializes a new instance of the ReplicaInfo class

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ReplicaInfo()
Public Sub New
public:
ReplicaInfo()
new : unit -> ReplicaInfo
See Also

Reference

ReplicaInfo Class
VelocityDb.Session Namespace


ReplicaInfo Properties

The ReplicaInfo type exposes the following members.

Properties
 | Name | Description
Public property | Host | Host name (defaults to local host)
Public property | Path | Directory path to databases
Top
See Also

Reference

ReplicaInfo Class
VelocityDb.Session Namespace


ReplicaInfo.Host Property

ReplicaInfoHost Property

Host name (defaults to local host)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
member Host : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaInfo Class
VelocityDb.Session Namespace


ReplicaInfo.Path Property

ReplicaInfoPath Property

Directory path to databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaInfo Class
VelocityDb.Session Namespace


ServerClientSession Class

Use this session class when Page level locking is required and/or not all Databases are local and not reachable by UNC paths.
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionServerClientSession
VelocityDb.SessionServerClientSessionShared

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class ServerClientSession : SessionBase
Public Class ServerClientSession
    Inherits SessionBase
public ref class ServerClientSession : public SessionBase
type ServerClientSession =
    class
        inherit SessionBase
    end

The ServerClientSession type exposes the following members.

Constructors
 | Name | Description
Public method | ServerClientSession(ListReplicaInfo, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean) | Initializes a new instance of the ServerClientSession class
Public method | ServerClientSession(String, String, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean) | Creates a new session.
Top
Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Indexing thread not yet available with ServerClientSession. (Overrides SessionBaseAddToIndexInSeperateThread.)
Public property | WriteToDiskInSeperateDatabaseThreads | Write threads not yet available with ServerClientSession. (Overrides SessionBaseWriteToDiskInSeperateDatabaseThreads.)
Top
Methods
 | Name | Description
Public method | Abort | Aborts a transaction, it undoes all persistent changes made within the transaction (Overrides SessionBaseAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides SessionBaseBeginRead(Boolean).)
Public method | BeginReadWithEvents | Start a read only transaction and gets a list of created/updated objects as subscribed to by this session
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides SessionBaseBeginUpdate(Boolean).)
Public method | BeginUpdateWithEvents | Starts a transaction that may be creating new persistent data and/or updating persistent data and gets a list of created/updated objects as subscribed to by this session
Public method | ClearServerCache | Used as an aid when debugging server data, internal use, avoid using for now.
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides SessionBaseCopyAllDatabasesTo(String, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides SessionBaseDeleteLocation(DatabaseLocation, Boolean).)
Public method | FlushUpdates | Send all updated pages to the server(s) managing those pages, freeing up memory in client. (Overrides SessionBaseFlushUpdates.)
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s) (Overrides SessionBaseFlushUpdatesServers.)
Public method | InUseNumberOfPages | Gets the number of pages currently in use by a Database (Overrides SessionBaseInUseNumberOfPages(Database).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides SessionBaseNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides SessionBaseNewLocation(DatabaseLocation).)
Public method | OpenAllDatabases | Open all databases (Overrides SessionBaseOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides SessionBaseOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides SessionBaseOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides SessionBaseRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides SessionBaseSubscribeToChanges(Type, String).)
Public method | UnsubscribeToChanges | Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides SessionBaseUnsubscribeToChanges(Type, String).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionBaseUpdateDatabase(Database).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDb.Session Namespace


ServerClientSession Constructor

Overload List
 | Name | Description
Public method | ServerClientSession(ListReplicaInfo, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean) | Initializes a new instance of the ServerClientSession class
Public method | ServerClientSession(String, String, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean) | Creates a new session.
Top
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession Constructor (List(ReplicaInfo), Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean)

ServerClientSession Constructor (ListReplicaInfo, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean)

Initializes a new instance of the ServerClientSession class

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ServerClientSession(
    List<ReplicaInfo> systemHostPath,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes,
    bool enableDatabaseCache = true
)
Public Sub New (
    systemHostPath As List(Of ReplicaInfo),
    Optional waitForLockMilliseconds As Integer = 2000,
    Optional optimisticLocking As Boolean = true,
    Optional inMemoryOnly As Boolean = false,
    Optional enablePageCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes,
    Optional enableDatabaseCache As Boolean = true
)
public:
ServerClientSession(
    List<ReplicaInfo^>^ systemHostPath,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes,
    bool enableDatabaseCache = true
)
new :
        systemHostPath : List<ReplicaInfo> *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?inMemoryOnly : bool *
        ?enablePageCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum *
        ?enableDatabaseCache : bool
(* Defaults:
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 2000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _inMemoryOnly = defaultArg inMemoryOnly false
        let _enablePageCache = defaultArg enablePageCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
        let _enableDatabaseCache = defaultArg enableDatabaseCache true
*)
-> ServerClientSession

Parameters

systemHostPath
Type: System.Collections.GenericList ReplicaInfo

[Missing <param name="systemHostPath"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

waitForLockMilliseconds (Optional)
Type: SystemInt32

[Missing <param name="waitForLockMilliseconds"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

optimisticLocking (Optional)
Type: SystemBoolean

[Missing <param name="optimisticLocking"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

inMemoryOnly (Optional)
Type: SystemBoolean

[Missing <param name="inMemoryOnly"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

enablePageCache (Optional)
Type: SystemBoolean

[Missing <param name="enablePageCache"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum

[Missing <param name="objectCachingDefaultPolicy"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

enableDatabaseCache (Optional)
Type: SystemBoolean

[Missing <param name="enableDatabaseCache"/> documentation for "M:VelocityDb.Session.ServerClientSession.#ctor(System.Collections.Generic.List{VelocityDb.Session.ReplicaInfo},System.Int32,System.Boolean,System.Boolean,System.Boolean,VelocityDb.CacheEnum,System.Boolean)"]

See Also

Reference

ServerClientSession Class
ServerClientSession Overload
VelocityDb.Session Namespace


ServerClientSession Constructor (String, String, Int32, Boolean, Boolean, Boolean, CacheEnum, Boolean)

Creates a new session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ServerClientSession(
    string systemDir,
    string systemHost = null,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes,
    bool enableDatabaseCache = true
)
Public Sub New (
    systemDir As String,
    Optional systemHost As String = Nothing,
    Optional waitForLockMilliseconds As Integer = 2000,
    Optional optimisticLocking As Boolean = true,
    Optional inMemoryOnly As Boolean = false,
    Optional enablePageCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes,
    Optional enableDatabaseCache As Boolean = true
)
public:
ServerClientSession(
    String^ systemDir,
    String^ systemHost = nullptr,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes,
    bool enableDatabaseCache = true
)
new :
        systemDir : string *
        ?systemHost : string *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?inMemoryOnly : bool *
        ?enablePageCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum *
        ?enableDatabaseCache : bool
(* Defaults:
        let _systemHost = defaultArg systemHost null
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 2000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _inMemoryOnly = defaultArg inMemoryOnly false
        let _enablePageCache = defaultArg enablePageCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
        let _enableDatabaseCache = defaultArg enableDatabaseCache true
*)
-> ServerClientSession

Parameters

systemDir
Type: SystemString
The startup location directory path (do not use UNC path). Use path as it is on the host owning the directory. Path can be an absolute (full) path or a path relative to s_baseDatabasePath. Change default of s_baseDatabasePath on server by starting server with a forth parameter specifying the base path
systemHost (Optional)
Type: SystemString
Hostname of the host owning the systemDir
waitForLockMilliseconds (Optional)
Type: SystemInt32
The desired maximum lock wait time
optimisticLocking (Optional)
Type: SystemBoolean
Use optimistic locking. With optimistic locking, readers are always permitted and multiple updaters are permitted to update the same Databases/Pages but only the first transaction to commit or flush an updated Database/Page will be successful in making the commit change. Other updaters will get an OptimisticLockingException if they try to commit/flush updates to the same Pages/Database. See http://en.wikipedia.org/wiki/Optimistic_concurrency_control for further explanation of optimistic locking. If optimistic locking is not enabled then pessimistic locking is used. See: http://en.wikipedia.org/wiki/Concurrency_control
inMemoryOnly (Optional)
Type: SystemBoolean
Disable all disk access by using this option. Best if used in combination with backup DatabaseLocation. See High availability sample application
enablePageCache (Optional)
Type: SystemBoolean
If strong reference page caching isn't desired, turn it of by setting to false
objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum
Determines default value of Cache
enableDatabaseCache (Optional)
Type: SystemBoolean
Is this session going to enable strong reference Database caching?
See Also

Reference

ServerClientSession Class
ServerClientSession Overload
VelocityDb.Session Namespace


ServerClientSession Properties

The ServerClientSession type exposes the following members.

Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Indexing thread not yet available with ServerClientSession. (Overrides SessionBaseAddToIndexInSeperateThread.)
Public property | WriteToDiskInSeperateDatabaseThreads | Write threads not yet available with ServerClientSession. (Overrides SessionBaseWriteToDiskInSeperateDatabaseThreads.)
Top
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.AddToIndexInSeperateThread Property

ServerClientSessionAddToIndexInSeperateThread Property

Indexing thread not yet available with ServerClientSession.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AddToIndexInSeperateThread { get; set; }
Public Overrides Property AddToIndexInSeperateThread As Boolean
    Get
    Set
public:
virtual property bool AddToIndexInSeperateThread {
    bool get () override;
    void set (bool value) override;
}
abstract AddToIndexInSeperateThread : bool with get, set
override AddToIndexInSeperateThread : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.WriteToDiskInSeperateDatabaseThreads Property

ServerClientSessionWriteToDiskInSeperateDatabaseThreads Property

Write threads not yet available with ServerClientSession.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool WriteToDiskInSeperateDatabaseThreads { get; set; }
Public Overrides Property WriteToDiskInSeperateDatabaseThreads As Boolean
    Get
    Set
public:
virtual property bool WriteToDiskInSeperateDatabaseThreads {
    bool get () override;
    void set (bool value) override;
}
abstract WriteToDiskInSeperateDatabaseThreads : bool with get, set
override WriteToDiskInSeperateDatabaseThreads : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession Methods

The ServerClientSession type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts a transaction, it undoes all persistent changes made within the transaction (Overrides SessionBaseAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides SessionBaseBeginRead(Boolean).)
Public method | BeginReadWithEvents | Start a read only transaction and gets a list of created/updated objects as subscribed to by this session
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides SessionBaseBeginUpdate(Boolean).)
Public method | BeginUpdateWithEvents | Starts a transaction that may be creating new persistent data and/or updating persistent data and gets a list of created/updated objects as subscribed to by this session
Public method | ClearServerCache | Used as an aid when debugging server data, internal use, avoid using for now.
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides SessionBaseCopyAllDatabasesTo(String, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides SessionBaseDeleteLocation(DatabaseLocation, Boolean).)
Public method | FlushUpdates | Send all updated pages to the server(s) managing those pages, freeing up memory in client. (Overrides SessionBaseFlushUpdates.)
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s) (Overrides SessionBaseFlushUpdatesServers.)
Public method | InUseNumberOfPages | Gets the number of pages currently in use by a Database (Overrides SessionBaseInUseNumberOfPages(Database).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides SessionBaseNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides SessionBaseNewLocation(DatabaseLocation).)
Public method | OpenAllDatabases | Open all databases (Overrides SessionBaseOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides SessionBaseOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides SessionBaseOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides SessionBaseRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides SessionBaseSubscribeToChanges(Type, String).)
Public method | UnsubscribeToChanges | Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides SessionBaseUnsubscribeToChanges(Type, String).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionBaseUpdateDatabase(Database).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.Abort Method

ServerClientSessionAbort Method

Aborts a transaction, it undoes all persistent changes made within the transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Abort()
Public Overrides Sub Abort
public:
virtual void Abort() override
abstract Abort : unit -> unit
override Abort : unit -> unit
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.BeginRead Method

ServerClientSessionBeginRead Method

Transaction control, begin a read only transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginRead(
    bool doRecoveryCheck = false
)
Public Overrides Function BeginRead (
    Optional doRecoveryCheck As Boolean = false
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginRead(
    bool doRecoveryCheck = false
) override
abstract BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction
override BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
By default we do not check for a failed update transaction that requires reverting one or more database changes. We don't do it by default because it can be a little costly. Change this parameter to true if you prefer ensured consistency over better performance or make change only if you encounter an exception in the transaction.

Return Value

Type: SessionBaseTransaction
A transaction helper object.
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.BeginReadWithEvents Method

ServerClientSessionBeginReadWithEvents Method

Start a read only transaction and gets a list of created/updated objects as subscribed to by this session

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<Oid> BeginReadWithEvents(
    bool doRecoveryCheck = true
)
Public Function BeginReadWithEvents (
    Optional doRecoveryCheck As Boolean = true
) As List(Of Oid)
public:
List<Oid>^ BeginReadWithEvents(
    bool doRecoveryCheck = true
)
member BeginReadWithEvents :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck true
*)
-> List<Oid>

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
If true a recovery check is done, otherwise recovery check is bypassed.

Return Value

Type: List Oid
list of object Oid of objects updated by other sessions
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.BeginUpdate Method

ServerClientSessionBeginUpdate Method

Transaction control, begin an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginUpdate(
    bool doRecoveryCheck = true
)
Public Overrides Function BeginUpdate (
    Optional doRecoveryCheck As Boolean = true
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginUpdate(
    bool doRecoveryCheck = true
) override
abstract BeginUpdate :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck true
*)
-> SessionBaseTransaction
override BeginUpdate :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck true
*)
-> SessionBaseTransaction

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
Set to false only when moving system databases to a new directory

Return Value

Type: SessionBaseTransaction
A SessionBaseTransaction helper object.
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.BeginUpdateWithEvents Method

ServerClientSessionBeginUpdateWithEvents Method

Starts a transaction that may be creating new persistent data and/or updating persistent data and gets a list of created/updated objects as subscribed to by this session

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<Oid> BeginUpdateWithEvents(
    bool doRecoveryCheck = true
)
Public Function BeginUpdateWithEvents (
    Optional doRecoveryCheck As Boolean = true
) As List(Of Oid)
public:
List<Oid>^ BeginUpdateWithEvents(
    bool doRecoveryCheck = true
)
member BeginUpdateWithEvents :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck true
*)
-> List<Oid>

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
If true a recovery check is done, otherwise recovery check is bypassed.

Return Value

Type: List Oid
list of object Oid of objects updated by other sessions
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.ClearServerCache Method

ServerClientSessionClearServerCache Method

Used as an aid when debugging server data, internal use, avoid using for now.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ClearServerCache()
Public Sub ClearServerCache
public:
void ClearServerCache()
member ClearServerCache : unit -> unit
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.Compact Method

ServerClientSessionCompact Method

Overload List
 | Name | Description
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Top
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.Compact Method

ServerClientSessionCompact Method

Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact()
Public Overrides Sub Compact
public:
virtual void Compact() override
abstract Compact : unit -> unit
override Compact : unit -> unit
See Also

Reference

ServerClientSession Class
Compact Overload
VelocityDb.Session Namespace


ServerClientSession.Compact Method (Database)

ServerClientSessionCompact Method (Database)

Reduce size of database, if possible, by truncating file where unused space begins

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact(
    Database db
)
Public Overrides Sub Compact (
    db As Database
)
public:
virtual void Compact(
    Database^ db
) override
abstract Compact :
        db : Database -> unit
override Compact :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
Database to compact
See Also

Reference

ServerClientSession Class
Compact Overload
VelocityDb.Session Namespace


ServerClientSession.CopyAllDatabasesTo Method

ServerClientSessionCopyAllDatabasesTo Method

Copies all databases to a selected directory on the local host.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void CopyAllDatabasesTo(
    string directory,
    bool systemDatabaseLocationOnly = false
)
Public Overrides Sub CopyAllDatabasesTo (
    directory As String,
    Optional systemDatabaseLocationOnly As Boolean = false
)
public:
virtual void CopyAllDatabasesTo(
    String^ directory,
    bool systemDatabaseLocationOnly = false
) override
abstract CopyAllDatabasesTo :
        directory : string *
        ?systemDatabaseLocationOnly : bool
(* Defaults:
        let _systemDatabaseLocationOnly = defaultArg systemDatabaseLocationOnly false
*)
-> unit
override CopyAllDatabasesTo :
        directory : string *
        ?systemDatabaseLocationOnly : bool
(* Defaults:
        let _systemDatabaseLocationOnly = defaultArg systemDatabaseLocationOnly false
*)
-> unit

Parameters

directory
Type: SystemString
Path to a directory
systemDatabaseLocationOnly (Optional)
Type: SystemBoolean
Only copy databases in system database location
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.DeleteLocation Method

ServerClientSessionDeleteLocation Method

Deletes a DatabaseLocation, location must first mot have any Databases in it

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void DeleteLocation(
    DatabaseLocation location,
    bool catalogOnly = false
)
Public Overrides Sub DeleteLocation (
    location As DatabaseLocation,
    Optional catalogOnly As Boolean = false
)
public:
virtual void DeleteLocation(
    DatabaseLocation^ location,
    bool catalogOnly = false
) override
abstract DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit
override DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit

Parameters

location
Type: VelocityDbDatabaseLocation
The DatabaseLocation to delete
catalogOnly (Optional)
Type: SystemBoolean
Of true, only delete catalog entry. Leave the directory as is.
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.FlushUpdates Method

ServerClientSessionFlushUpdates Method

Send all updated pages to the server(s) managing those pages, freeing up memory in client.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushUpdates()
Public Overrides Sub FlushUpdates
public:
virtual void FlushUpdates() override
abstract FlushUpdates : unit -> unit
override FlushUpdates : unit -> unit
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.FlushUpdatesServers Method

ServerClientSessionFlushUpdatesServers Method

Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushUpdatesServers()
Public Overrides Sub FlushUpdatesServers
public:
virtual void FlushUpdatesServers() override
abstract FlushUpdatesServers : unit -> unit
override FlushUpdatesServers : unit -> unit
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.InUseNumberOfPages Method

ServerClientSessionInUseNumberOfPages Method

Gets the number of pages currently in use by a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort InUseNumberOfPages(
    Database db
)
Public Overrides Function InUseNumberOfPages (
    db As Database
) As UShort
public:
virtual unsigned short InUseNumberOfPages(
    Database^ db
) override
abstract InUseNumberOfPages :
        db : Database -> uint16
override InUseNumberOfPages :
        db : Database -> uint16

Parameters

db
Type: VelocityDbDatabase
The Database to request info about

Return Value

Type: UInt16
The number of pages currently in use
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.NewDatabase Method

ServerClientSessionNewDatabase Method

Create a new Database with a given database number

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database NewDatabase(
    uint dbNum,
    uint megaBytesPresize = 0,
    string name = null,
    bool signalError = true
)
Public Overrides Function NewDatabase (
    dbNum As UInteger,
    Optional megaBytesPresize As UInteger = 0,
    Optional name As String = Nothing,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ NewDatabase(
    unsigned int dbNum,
    unsigned int megaBytesPresize = 0,
    String^ name = nullptr,
    bool signalError = true
) override
abstract NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database
override NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
Database number of the database to create
megaBytesPresize (Optional)
Type: SystemUInt32
If you know that the Database will be large, presizing it may avoid file fragmentation. Default value is 0
name (Optional)
Type: SystemString
Optionally name the new Database
signalError (Optional)
Type: SystemBoolean
Optionally signal an error if creation of new Database fails

Return Value

Type: Database
The newly created Database or throws and exception if the Database already exist
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.NewLocation Method

ServerClientSessionNewLocation Method

Creates a new DatabaseLocation or updates existing ones

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override DatabaseLocation NewLocation(
    DatabaseLocation location
)
Public Overrides Function NewLocation (
    location As DatabaseLocation
) As DatabaseLocation
public:
virtual DatabaseLocation^ NewLocation(
    DatabaseLocation^ location
) override
abstract NewLocation :
        location : DatabaseLocation -> DatabaseLocation
override NewLocation :
        location : DatabaseLocation -> DatabaseLocation

Parameters

location
Type: VelocityDbDatabaseLocation
The input location

Return Value

Type: DatabaseLocation
The new DatabaseLocation or an existing one
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.OpenAllDatabases Method

ServerClientSessionOpenAllDatabases Method

Open all databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenAllDatabases(
    bool update = false
)
Public Overrides Function OpenAllDatabases (
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenAllDatabases(
    bool update = false
) override
abstract OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

update (Optional)
Type: SystemBoolean
Open for update?

Return Value

Type: List Database

[Missing <returns> documentation for "M:VelocityDb.Session.ServerClientSession.OpenAllDatabases(System.Boolean)"]

See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.OpenDatabase Method

ServerClientSessionOpenDatabase Method

Opens a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database OpenDatabase(
    uint dbNum,
    bool update = false,
    bool signalError = true
)
Public Overrides Function OpenDatabase (
    dbNum As UInteger,
    Optional update As Boolean = false,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ OpenDatabase(
    unsigned int dbNum,
    bool update = false,
    bool signalError = true
) override
abstract OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database
override OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
The Database number of the database to open
update (Optional)
Type: SystemBoolean
Open the Database for update?
signalError (Optional)
Type: SystemBoolean
Signal errors if errors found when opening the Database?

Return Value

Type: Database
The opened Database
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.OpenLocationDatabases Method

ServerClientSessionOpenLocationDatabases Method

Opens all the databases in a given location

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenLocationDatabases(
    DatabaseLocation location,
    bool update = false
)
Public Overrides Function OpenLocationDatabases (
    location As DatabaseLocation,
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenLocationDatabases(
    DatabaseLocation^ location,
    bool update = false
) override
abstract OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

location
Type: VelocityDbDatabaseLocation
The location for which to open databases
update (Optional)
Type: SystemBoolean
Shall each database be opened for update?

Return Value

Type: List Database
A list of opened databases
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.RestoreFrom Method

ServerClientSessionRestoreFrom Method

Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreFrom(
    DatabaseLocation backupLocation,
    DateTime upToTime
)
Public Overrides Sub RestoreFrom (
    backupLocation As DatabaseLocation,
    upToTime As DateTime
)
public:
virtual void RestoreFrom(
    DatabaseLocation^ backupLocation,
    DateTime upToTime
) override
abstract RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit
override RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit

Parameters

backupLocation
Type: VelocityDbDatabaseLocation
The location to restore from
upToTime
Type: SystemDateTime
Restore location up to a given DateTime. Data backed up after this time will not be restored.
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.SubscribeToChanges Method

ServerClientSessionSubscribeToChanges Method

Subscribe to committed database changes of instances of a type when an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overrides Sub SubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void SubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
) override
abstract SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a boolean property. When property returns true, a change notification is send otherwise no notification is send. Leave as null to get a notification any time any instance of the selected type changes
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.UnsubscribeToChanges Method

ServerClientSessionUnsubscribeToChanges Method

Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void UnsubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overrides Sub UnsubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void UnsubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
) override
abstract UnsubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override UnsubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are no longer interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a Boolean property.
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSession.UpdateDatabase Method

ServerClientSessionUpdateDatabase Method

Request an update lock on a database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateDatabase(
    Database db
)
Public Overrides Function UpdateDatabase (
    db As Database
) As Boolean
public:
virtual bool UpdateDatabase(
    Database^ db
) override
abstract UpdateDatabase :
        db : Database -> bool
override UpdateDatabase :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database to update

Return Value

Type: Boolean
true if Database was updated, otherwise throws an exception
See Also

Reference

ServerClientSession Class
VelocityDb.Session Namespace


ServerClientSessionShared Class

Use as a shared session for multiple reader threads connected to one or more VelocityDBServer(s).
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionServerClientSession
VelocityDb.SessionServerClientSessionShared

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class ServerClientSessionShared : ServerClientSession
Public Class ServerClientSessionShared
    Inherits ServerClientSession
public ref class ServerClientSessionShared : public ServerClientSession
type ServerClientSessionShared =
    class
        inherit ServerClientSession
    end

The ServerClientSessionShared type exposes the following members.

Constructors
 | Name | Description
Public method | ServerClientSessionShared | Creates a new session.
Top
Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Allow adding objects to indices to be done in a worker thread instead of in main thread. (Overrides ServerClientSessionAddToIndexInSeperateThread.)
Public property | Databases | Gets a list of the currently opened databases (Overrides SessionBaseDatabases.)
Public property | WriteToDiskInSeperateDatabaseThreads | Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work. (Overrides ServerClientSessionWriteToDiskInSeperateDatabaseThreads.)
Top
Methods
 | Name | Description
Public method | Abort | Aborts a transaction, it undoes all persistent changes made within the transaction (Overrides ServerClientSessionAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides ServerClientSessionBeginRead(Boolean).)
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides ServerClientSessionBeginUpdate(Boolean).)
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate (Overrides SessionBaseCheckpoint.)
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now. (Overrides SessionBaseClearCache.)
Public method | ClearCashedPages | Clear cache of cached pages (Overrides SessionBaseClearCashedPages.)
Public method | ClearPageCache | Clears cached pages from cache including page weak references. (Overrides SessionBaseClearPageCache.)
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides ServerClientSessionCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides ServerClientSessionCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides ServerClientSessionCopyAllDatabasesTo(String, Boolean).)
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened. (Overrides SessionBaseCrossTransactionCache(Database, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides ServerClientSessionDeleteLocation(DatabaseLocation, Boolean).)
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written. (Overrides SessionBaseFlushPageOf(OptimizedPersistable).)
Public method | FlushUpdates | Send all updated pages to the server(s) managing those pages, freeing up memory in client. (Overrides ServerClientSessionFlushUpdates.)
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s) (Overrides ServerClientSessionFlushUpdatesServers.)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction. (Overrides SessionBaseForceDatabaseCacheValidation.)
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object (Overrides SessionBaseGlobalObjWrapperGet(Object, IOptimizedPersistable).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides ServerClientSessionNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides ServerClientSessionNewLocation(DatabaseLocation).)
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Public method | OpenAllDatabases | Open all databases (Overrides ServerClientSessionOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides ServerClientSessionOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides ServerClientSessionOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | OpenSchema | Get the session active schema (Overrides SessionBaseOpenSchema(Boolean).)
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use. (Overrides SessionBasePossiblyFlushUpdatedPages(UInt32).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides ServerClientSessionRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides ServerClientSessionSubscribeToChanges(Type, String).)
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable (Overrides SessionBaseUnpersist(Object).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides ServerClientSessionUpdateDatabase(Database).)
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found. (Overrides SessionBaseVerify.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDb.Session Namespace


ServerClientSessionShared Constructor

Creates a new session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ServerClientSessionShared(
    string systemDir,
    string systemHost = null,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes,
    bool enableDatabaseCache = true
)
Public Sub New (
    systemDir As String,
    Optional systemHost As String = Nothing,
    Optional waitForLockMilliseconds As Integer = 2000,
    Optional optimisticLocking As Boolean = true,
    Optional inMemoryOnly As Boolean = false,
    Optional enablePageCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes,
    Optional enableDatabaseCache As Boolean = true
)
public:
ServerClientSessionShared(
    String^ systemDir,
    String^ systemHost = nullptr,
    int waitForLockMilliseconds = 2000,
    bool optimisticLocking = true,
    bool inMemoryOnly = false,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes,
    bool enableDatabaseCache = true
)
new :
        systemDir : string *
        ?systemHost : string *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?inMemoryOnly : bool *
        ?enablePageCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum *
        ?enableDatabaseCache : bool
(* Defaults:
        let _systemHost = defaultArg systemHost null
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 2000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _inMemoryOnly = defaultArg inMemoryOnly false
        let _enablePageCache = defaultArg enablePageCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
        let _enableDatabaseCache = defaultArg enableDatabaseCache true
*)
-> ServerClientSessionShared

Parameters

systemDir
Type: SystemString
The startup location directory path (do not use UNC path). Use path as it is on the host owning the directory. Path can be an absolute (full) path or a path relative to s_baseDatabasePath. Change default of s_baseDatabasePath on server by starting server with a forth parameter specifying the base path
systemHost (Optional)
Type: SystemString
Hostname of the host owning the systemDir
waitForLockMilliseconds (Optional)
Type: SystemInt32
The desired maximum lock wait time
optimisticLocking (Optional)
Type: SystemBoolean
Use optimistic locking. With optimistic locking, readers are always permitted and multiple updaters are permitted to update the same Databases/Pages but only the first transaction to commit or flush an updated Database/Page will be successful in making the commit change. Other updaters will get an OptimisticLockingException if they try to commit/flush updates to the same Pages/Database. See http://en.wikipedia.org/wiki/Optimistic_concurrency_control for further explanation of optimistic locking. If optimistic locking is not enabled then pessimistic locking is used. See: http://en.wikipedia.org/wiki/Concurrency_control
inMemoryOnly (Optional)
Type: SystemBoolean
Disable all disk access by using this option. Best if used in combination with backup DatabaseLocation. See High availability sample application
enablePageCache (Optional)
Type: SystemBoolean
If strong reference page caching isn't desired, turn it of by setting to false
objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum
Determines default value of Cache
enableDatabaseCache (Optional)
Type: SystemBoolean
Is this session going to enable strong reference Database caching?
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared Properties

The ServerClientSessionShared type exposes the following members.

Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Allow adding objects to indices to be done in a worker thread instead of in main thread. (Overrides ServerClientSessionAddToIndexInSeperateThread.)
Public property | Databases | Gets a list of the currently opened databases (Overrides SessionBaseDatabases.)
Public property | WriteToDiskInSeperateDatabaseThreads | Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work. (Overrides ServerClientSessionWriteToDiskInSeperateDatabaseThreads.)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.AddToIndexInSeperateThread Property

ServerClientSessionSharedAddToIndexInSeperateThread Property

Allow adding objects to indices to be done in a worker thread instead of in main thread.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AddToIndexInSeperateThread { get; set; }
Public Overrides Property AddToIndexInSeperateThread As Boolean
    Get
    Set
public:
virtual property bool AddToIndexInSeperateThread {
    bool get () override;
    void set (bool value) override;
}
abstract AddToIndexInSeperateThread : bool with get, set
override AddToIndexInSeperateThread : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Databases Property

ServerClientSessionSharedDatabases Property

Gets a list of the currently opened databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Database> Databases { get; }
Public Overrides ReadOnly Property Databases As IList(Of Database)
    Get
public:
virtual property IList<Database^>^ Databases {
    IList<Database^>^ get () override;
}
abstract Databases : IList<Database> with get
override Databases : IList<Database> with get

Property Value

Type: IList Database
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.WriteToDiskInSeperateDatabaseThreads Property

ServerClientSessionSharedWriteToDiskInSeperateDatabaseThreads Property

Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool WriteToDiskInSeperateDatabaseThreads { get; set; }
Public Overrides Property WriteToDiskInSeperateDatabaseThreads As Boolean
    Get
    Set
public:
virtual property bool WriteToDiskInSeperateDatabaseThreads {
    bool get () override;
    void set (bool value) override;
}
abstract WriteToDiskInSeperateDatabaseThreads : bool with get, set
override WriteToDiskInSeperateDatabaseThreads : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared Methods

The ServerClientSessionShared type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts a transaction, it undoes all persistent changes made within the transaction (Overrides ServerClientSessionAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides ServerClientSessionBeginRead(Boolean).)
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides ServerClientSessionBeginUpdate(Boolean).)
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate (Overrides SessionBaseCheckpoint.)
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now. (Overrides SessionBaseClearCache.)
Public method | ClearCashedPages | Clear cache of cached pages (Overrides SessionBaseClearCashedPages.)
Public method | ClearPageCache | Clears cached pages from cache including page weak references. (Overrides SessionBaseClearPageCache.)
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides ServerClientSessionCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides ServerClientSessionCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides ServerClientSessionCopyAllDatabasesTo(String, Boolean).)
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened. (Overrides SessionBaseCrossTransactionCache(Database, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides ServerClientSessionDeleteLocation(DatabaseLocation, Boolean).)
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written. (Overrides SessionBaseFlushPageOf(OptimizedPersistable).)
Public method | FlushUpdates | Send all updated pages to the server(s) managing those pages, freeing up memory in client. (Overrides ServerClientSessionFlushUpdates.)
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s) (Overrides ServerClientSessionFlushUpdatesServers.)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction. (Overrides SessionBaseForceDatabaseCacheValidation.)
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object (Overrides SessionBaseGlobalObjWrapperGet(Object, IOptimizedPersistable).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides ServerClientSessionNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides ServerClientSessionNewLocation(DatabaseLocation).)
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Public method | OpenAllDatabases | Open all databases (Overrides ServerClientSessionOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides ServerClientSessionOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides ServerClientSessionOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | OpenSchema | Get the session active schema (Overrides SessionBaseOpenSchema(Boolean).)
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use. (Overrides SessionBasePossiblyFlushUpdatedPages(UInt32).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides ServerClientSessionRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an optional property evaluates to true. (Overrides ServerClientSessionSubscribeToChanges(Type, String).)
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable (Overrides SessionBaseUnpersist(Object).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides ServerClientSessionUpdateDatabase(Database).)
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found. (Overrides SessionBaseVerify.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Abort Method

ServerClientSessionSharedAbort Method

Aborts a transaction, it undoes all persistent changes made within the transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Abort()
Public Overrides Sub Abort
public:
virtual void Abort() override
abstract Abort : unit -> unit
override Abort : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.BeginRead Method

ServerClientSessionSharedBeginRead Method

Transaction control, begin a read only transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginRead(
    bool doRecoveryCheck = false
)
Public Overrides Function BeginRead (
    Optional doRecoveryCheck As Boolean = false
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginRead(
    bool doRecoveryCheck = false
) override
abstract BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction
override BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
By default we do not check for a failed update transaction that requires reverting one or more database changes. We don't do it by default because it can be a little costly. Change this parameter to true if you prefer ensured consistency over better performance or make change only if you encounter an exception in the transaction.

Return Value

Type: SessionBaseTransaction
A transaction helper object.
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.BeginUpdate Method

ServerClientSessionSharedBeginUpdate Method

Transaction control, begin an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginUpdate(
    bool doRecoveryCheck
)
Public Overrides Function BeginUpdate (
    doRecoveryCheck As Boolean
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginUpdate(
    bool doRecoveryCheck
) override
abstract BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction
override BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction

Parameters

doRecoveryCheck
Type: SystemBoolean
Set to false only when moving system databases to a new directory

Return Value

Type: SessionBaseTransaction
A SessionBaseTransaction helper object.
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Checkpoint Method

ServerClientSessionSharedCheckpoint Method

Same as Commit(Boolean, Boolean) followed by BeginUpdate

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction Checkpoint()
Public Overrides Function Checkpoint As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ Checkpoint() override
abstract Checkpoint : unit -> SessionBaseTransaction
override Checkpoint : unit -> SessionBaseTransaction

Return Value

Type: SessionBaseTransaction
SessionBaseTransaction started
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.ClearCache Method

ServerClientSessionSharedClearCache Method

Clears page cache and closes databases. Avoid using this one for now.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearCache()
Public Overrides Sub ClearCache
public:
virtual void ClearCache() override
abstract ClearCache : unit -> unit
override ClearCache : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.ClearCashedPages Method

ServerClientSessionSharedClearCashedPages Method

Clear cache of cached pages

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearCashedPages()
Public Overrides Sub ClearCashedPages
public:
virtual void ClearCashedPages() override
abstract ClearCashedPages : unit -> unit
override ClearCashedPages : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.ClearPageCache Method

ServerClientSessionSharedClearPageCache Method

Clears cached pages from cache including page weak references.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearPageCache()
Public Overrides Sub ClearPageCache
public:
virtual void ClearPageCache() override
abstract ClearPageCache : unit -> unit
override ClearPageCache : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Compact Method

ServerClientSessionSharedCompact Method

Overload List
 | Name | Description
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides ServerClientSessionCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides ServerClientSessionCompact(Database).)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Compact Method

ServerClientSessionSharedCompact Method

Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact()
Public Overrides Sub Compact
public:
virtual void Compact() override
abstract Compact : unit -> unit
override Compact : unit -> unit
See Also

Reference

ServerClientSessionShared Class
Compact Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Compact Method (Database)

ServerClientSessionSharedCompact Method (Database)

Reduce size of database, if possible, by truncating file where unused space begins

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact(
    Database db
)
Public Overrides Sub Compact (
    db As Database
)
public:
virtual void Compact(
    Database^ db
) override
abstract Compact :
        db : Database -> unit
override Compact :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
Database to compact
See Also

Reference

ServerClientSessionShared Class
Compact Overload
VelocityDb.Session Namespace


ServerClientSessionShared.CopyAllDatabasesTo Method

ServerClientSessionSharedCopyAllDatabasesTo Method

Copies all databases to a selected directory on the local host.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void CopyAllDatabasesTo(
    string directory,
    bool systemDatabaseLocationOnly
)
Public Overrides Sub CopyAllDatabasesTo (
    directory As String,
    systemDatabaseLocationOnly As Boolean
)
public:
virtual void CopyAllDatabasesTo(
    String^ directory,
    bool systemDatabaseLocationOnly
) override
abstract CopyAllDatabasesTo :
        directory : string *
        systemDatabaseLocationOnly : bool -> unit
override CopyAllDatabasesTo :
        directory : string *
        systemDatabaseLocationOnly : bool -> unit

Parameters

directory
Type: SystemString
Path to a directory
systemDatabaseLocationOnly
Type: SystemBoolean
Only copy databases in system database location
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.CrossTransactionCache Method

ServerClientSessionSharedCrossTransactionCache Method

By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void CrossTransactionCache(
    Database db,
    bool enable = true
)
Public Overrides Sub CrossTransactionCache (
    db As Database,
    Optional enable As Boolean = true
)
public:
virtual void CrossTransactionCache(
    Database^ db,
    bool enable = true
) override
abstract CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit
override CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit

Parameters

db
Type: VelocityDbDatabase
The Database to cache
enable (Optional)
Type: SystemBoolean
Add or remove strong reference. If true, add a strong reference
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.DeleteLocation Method

ServerClientSessionSharedDeleteLocation Method

Deletes a DatabaseLocation, location must first mot have any Databases in it

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void DeleteLocation(
    DatabaseLocation location,
    bool catalogOnly = false
)
Public Overrides Sub DeleteLocation (
    location As DatabaseLocation,
    Optional catalogOnly As Boolean = false
)
public:
virtual void DeleteLocation(
    DatabaseLocation^ location,
    bool catalogOnly = false
) override
abstract DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit
override DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit

Parameters

location
Type: VelocityDbDatabaseLocation
The DatabaseLocation to delete
catalogOnly (Optional)
Type: SystemBoolean
Of true, only delete catalog entry. Leave the directory as is.
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.FlushPageOf Method

ServerClientSessionSharedFlushPageOf Method

By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushPageOf(
    OptimizedPersistable pObj
)
Public Overrides Sub FlushPageOf (
    pObj As OptimizedPersistable
)
public:
virtual void FlushPageOf(
    OptimizedPersistable^ pObj
) override
abstract FlushPageOf :
        pObj : OptimizedPersistable -> unit
override FlushPageOf :
        pObj : OptimizedPersistable -> unit

Parameters

pObj
Type: VelocityDbOptimizedPersistable
An object indicating what Page to flush
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.FlushUpdates Method

ServerClientSessionSharedFlushUpdates Method

Send all updated pages to the server(s) managing those pages, freeing up memory in client.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushUpdates()
Public Overrides Sub FlushUpdates
public:
virtual void FlushUpdates() override
abstract FlushUpdates : unit -> unit
override FlushUpdates : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.FlushUpdatesServers Method

ServerClientSessionSharedFlushUpdatesServers Method

Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushUpdatesServers()
Public Overrides Sub FlushUpdatesServers
public:
virtual void FlushUpdatesServers() override
abstract FlushUpdatesServers : unit -> unit
override FlushUpdatesServers : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.ForceDatabaseCacheValidation Method

ServerClientSessionSharedForceDatabaseCacheValidation Method

Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ForceDatabaseCacheValidation()
Public Overrides Sub ForceDatabaseCacheValidation
public:
virtual void ForceDatabaseCacheValidation() override
abstract ForceDatabaseCacheValidation : unit -> unit
override ForceDatabaseCacheValidation : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.GlobalObjWrapperGet Method

ServerClientSessionSharedGlobalObjWrapperGet Method

Lookup wrapper object for a non IOptimizedPersistable object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool GlobalObjWrapperGet(
    Object lookupObj,
    out IOptimizedPersistable pObj
)
Public Overrides Function GlobalObjWrapperGet (
    lookupObj As Object,
    <OutAttribute> ByRef pObj As IOptimizedPersistable
) As Boolean
public:
virtual bool GlobalObjWrapperGet(
    Object^ lookupObj,
    [OutAttribute] IOptimizedPersistable^% pObj
) override
abstract GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool
override GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool

Parameters

lookupObj
Type: SystemObject
object to look for
pObj
Type: VelocityDbIOptimizedPersistable
wrapper object

Return Value

Type: Boolean
Wrapper object
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.NewDatabase Method

ServerClientSessionSharedNewDatabase Method

Create a new Database with a given database number

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database NewDatabase(
    uint dbNum,
    uint megaBytesPresize = 0,
    string name = null,
    bool signalError = true
)
Public Overrides Function NewDatabase (
    dbNum As UInteger,
    Optional megaBytesPresize As UInteger = 0,
    Optional name As String = Nothing,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ NewDatabase(
    unsigned int dbNum,
    unsigned int megaBytesPresize = 0,
    String^ name = nullptr,
    bool signalError = true
) override
abstract NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database
override NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
Database number of the database to create
megaBytesPresize (Optional)
Type: SystemUInt32
If you know that the Database will be large, presizing it may avoid file fragmentation. Default value is 0
name (Optional)
Type: SystemString
Optionally name the new Database
signalError (Optional)
Type: SystemBoolean
Optionally signal an error if creation of new Database fails

Return Value

Type: Database
The newly created Database or throws and exception if the Database already exist
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.NewLocation Method

ServerClientSessionSharedNewLocation Method

Creates a new DatabaseLocation or updates existing ones

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override DatabaseLocation NewLocation(
    DatabaseLocation location
)
Public Overrides Function NewLocation (
    location As DatabaseLocation
) As DatabaseLocation
public:
virtual DatabaseLocation^ NewLocation(
    DatabaseLocation^ location
) override
abstract NewLocation :
        location : DatabaseLocation -> DatabaseLocation
override NewLocation :
        location : DatabaseLocation -> DatabaseLocation

Parameters

location
Type: VelocityDbDatabaseLocation
The input location

Return Value

Type: DatabaseLocation
The new DatabaseLocation or an existing one
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Open Method

ServerClientSessionSharedOpen Method

Overload List
 | Name | Description
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Open Method (UInt64, Boolean, Boolean, Int32)

ServerClientSessionSharedOpen Method (UInt64, Boolean, Boolean, Int32)

Opens a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Open(
    ulong oid,
    bool update,
    bool inFlush,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    oid As ULong,
    update As Boolean,
    inFlush As Boolean,
    Optional graphDepthToLoad As Integer = 2147483647
) As Object
public:
virtual Object^ Open(
    unsigned long long oid,
    bool update,
    bool inFlush,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        oid : uint64 *
        update : bool *
        inFlush : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> Object
override Open :
        oid : uint64 *
        update : bool *
        inFlush : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> Object

Parameters

oid
Type: SystemUInt64
The Id of the object to open
update
Type: SystemBoolean
Open the object for update?
inFlush
Type: SystemBoolean
if true, disallow page flushing while opening the object
graphDepthToLoad (Optional)
Type: SystemInt32
Set this if you want to limit the depth of the graph loaded by this open.

Return Value

Type: Object
A persistent object
See Also

Reference

ServerClientSessionShared Class
Open Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Open Method (UInt32, UInt16, UInt16, Boolean, Int32)

ServerClientSessionSharedOpen Method (UInt32, UInt16, UInt16, Boolean, Int32)

Opens a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    uint dbNum,
    ushort pageNum,
    ushort slotNum,
    bool update,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    dbNum As UInteger,
    pageNum As UShort,
    slotNum As UShort,
    update As Boolean,
    Optional graphDepthToLoad As Integer = 2147483647
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    unsigned int dbNum,
    unsigned short pageNum,
    unsigned short slotNum,
    bool update,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        dbNum : uint32 *
        pageNum : uint16 *
        slotNum : uint16 *
        update : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable
override Open :
        dbNum : uint32 *
        pageNum : uint16 *
        slotNum : uint16 *
        update : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable

Parameters

dbNum
Type: SystemUInt32
Database number of the object to open
pageNum
Type: SystemUInt16
Page number of the object to open
slotNum
Type: SystemUInt16
Slot number of the object to open
update
Type: SystemBoolean
Open the object for update?
graphDepthToLoad (Optional)
Type: SystemInt32
Limit depth of graph to open

Return Value

Type: IOptimizedPersistable
The opened object or null if it does not exist
See Also

Reference

ServerClientSessionShared Class
Open Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Open Method (Database, UInt64, Boolean, List(IOptimizedPersistable), Boolean, Int32, Int32)

ServerClientSessionSharedOpen Method (Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32)

For internal usage only, used in generated code

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    Database db,
    ulong oid,
    bool update,
    List<IOptimizedPersistable> toLoadMembers,
    bool inFlush,
    int graphDepth = 0,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    db As Database,
    oid As ULong,
    update As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    inFlush As Boolean,
    Optional graphDepth As Integer = 0,
    Optional graphDepthToLoad As Integer = 2147483647
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    Database^ db,
    unsigned long long oid,
    bool update,
    List<IOptimizedPersistable^>^ toLoadMembers,
    bool inFlush,
    int graphDepth = 0,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        ?graphDepth : int *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepth = defaultArg graphDepth 0
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable
override Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        ?graphDepth : int *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepth = defaultArg graphDepth 0
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

oid
Type: SystemUInt64

[Missing <param name="oid"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

update
Type: SystemBoolean

[Missing <param name="update"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

inFlush
Type: SystemBoolean

[Missing <param name="inFlush"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

graphDepth (Optional)
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

graphDepthToLoad (Optional)
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

Return Value

Type: IOptimizedPersistable

[Missing <returns> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

See Also

Reference

ServerClientSessionShared Class
Open Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Open Method (Database, UInt64, Boolean, List(IOptimizedPersistable), Boolean, Int32, Int32, Boolean)

ServerClientSessionSharedOpen Method (Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean)

For internal use only in generated code

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    Database db,
    ulong oid,
    bool update,
    List<IOptimizedPersistable> toLoadMembers,
    bool inFlush,
    int graphDepth,
    int graphDepthToLoad,
    bool signalNotExistError = false
)
Public Overrides Function Open (
    db As Database,
    oid As ULong,
    update As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    inFlush As Boolean,
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    Optional signalNotExistError As Boolean = false
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    Database^ db,
    unsigned long long oid,
    bool update,
    List<IOptimizedPersistable^>^ toLoadMembers,
    bool inFlush,
    int graphDepth,
    int graphDepthToLoad,
    bool signalNotExistError = false
) override
abstract Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        graphDepth : int *
        graphDepthToLoad : int *
        ?signalNotExistError : bool
(* Defaults:
        let _signalNotExistError = defaultArg signalNotExistError false
*)
-> IOptimizedPersistable
override Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        graphDepth : int *
        graphDepthToLoad : int *
        ?signalNotExistError : bool
(* Defaults:
        let _signalNotExistError = defaultArg signalNotExistError false
*)
-> IOptimizedPersistable

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDb.Session.ServerClientSessionShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32,System.Boolean)"]

oid
Type: SystemUInt64
Id of the object to open, must match with Database id
update
Type: SystemBoolean
Update object when opening it
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
Internal list of objects to be loaded as part of graph load
inFlush
Type: SystemBoolean
Permit page flushes as side affect of opening object?
graphDepth
Type: SystemInt32
Current graph depth of graph load
graphDepthToLoad
Type: SystemInt32
Max graph depth to load
signalNotExistError (Optional)
Type: SystemBoolean
Signal an exception if object/page/database does not exist.

Return Value

Type: IOptimizedPersistable
a persistent object
See Also

Reference

ServerClientSessionShared Class
Open Overload
VelocityDb.Session Namespace


ServerClientSessionShared.OpenAllDatabases Method

ServerClientSessionSharedOpenAllDatabases Method

Open all databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenAllDatabases(
    bool update = false
)
Public Overrides Function OpenAllDatabases (
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenAllDatabases(
    bool update = false
) override
abstract OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

update (Optional)
Type: SystemBoolean
Open for update?

Return Value

Type: List Database

[Missing <returns> documentation for "M:VelocityDb.Session.ServerClientSessionShared.OpenAllDatabases(System.Boolean)"]

See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.OpenDatabase Method

ServerClientSessionSharedOpenDatabase Method

Opens a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database OpenDatabase(
    uint dbNum,
    bool update = false,
    bool signalError = true
)
Public Overrides Function OpenDatabase (
    dbNum As UInteger,
    Optional update As Boolean = false,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ OpenDatabase(
    unsigned int dbNum,
    bool update = false,
    bool signalError = true
) override
abstract OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database
override OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
The Database number of the database to open
update (Optional)
Type: SystemBoolean
Open the Database for update?
signalError (Optional)
Type: SystemBoolean
Signal errors if errors found when opening the Database?

Return Value

Type: Database
The opened Database
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.OpenLocationDatabases Method

ServerClientSessionSharedOpenLocationDatabases Method

Opens all the databases in a given location

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenLocationDatabases(
    DatabaseLocation location,
    bool update = false
)
Public Overrides Function OpenLocationDatabases (
    location As DatabaseLocation,
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenLocationDatabases(
    DatabaseLocation^ location,
    bool update = false
) override
abstract OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

location
Type: VelocityDbDatabaseLocation
The location for which to open databases
update (Optional)
Type: SystemBoolean
Shall each database be opened for update?

Return Value

Type: List Database
A list of opened databases
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.OpenSchema Method

ServerClientSessionSharedOpenSchema Method

Get the session active schema

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Schema OpenSchema(
    bool update
)
Public Overrides Function OpenSchema (
    update As Boolean
) As Schema
public:
virtual Schema^ OpenSchema(
    bool update
) override
abstract OpenSchema :
        update : bool -> Schema
override OpenSchema :
        update : bool -> Schema

Parameters

update
Type: SystemBoolean
Do update the schema?

Return Value

Type: Schema
The active schema
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Persist Method

ServerClientSessionSharedPersist Method

Overload List
 | Name | Description
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Persist Method (IOptimizedPersistable, Nullable(UInt16))

ServerClientSessionSharedPersist Method (IOptimizedPersistable, NullableUInt16)

This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    IOptimizedPersistable ipObj,
    Nullable<ushort> objectsPerPage = null
)
Public Overrides Function Persist (
    ipObj As IOptimizedPersistable,
    Optional objectsPerPage As Nullable(Of UShort) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    IOptimizedPersistable^ ipObj,
    Nullable<unsigned short> objectsPerPage = nullptr
) override
abstract Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64
override Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64

Parameters

ipObj
Type: VelocityDbIOptimizedPersistable
The object to make persistent
objectsPerPage (Optional)
Type: SystemNullable UInt16
Override of objects per page, only respected when persisting first object of some type

Return Value

Type: UInt64
The Id of the persisted object
See Also

Reference

ServerClientSessionShared Class
Persist Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Persist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, Queue(IOptimizedPersistable))

ServerClientSessionSharedPersist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable)

Persists an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    IOptimizedPersistable pObj,
    Schema schema,
    ushort slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    pObj As IOptimizedPersistable,
    schema As Schema,
    Optional slotLimitPerPage As UShort = 0,
    Optional inFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    IOptimizedPersistable^ pObj,
    Schema^ schema,
    unsigned short slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
Placement object determining where to persist the object
pObj
Type: VelocityDbIOptimizedPersistable
The object to persist
schema
Type: VelocityDb.TypeInfoSchema
The active session schema
slotLimitPerPage (Optional)
Type: SystemUInt16
Override of how many slots per page to permit
inFlush (Optional)
Type: SystemBoolean
Set to true to disallow page flushes as a side affect
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A list of objects waiting to be persisted

Return Value

Type: UInt64
Id of persisted object
See Also

Reference

ServerClientSessionShared Class
Persist Overload
VelocityDb.Session Namespace


ServerClientSessionShared.PossiblyFlushUpdatedPages Method

ServerClientSessionSharedPossiblyFlushUpdatedPages Method

Call this function if you may have updated many pages to possibly free up memory if too much memory is in use.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void PossiblyFlushUpdatedPages(
    uint numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
)
Public Overrides Sub PossiblyFlushUpdatedPages (
    Optional numberOfUpdatedPagesPermittedWithoutFlushCheck As UInteger = 100
)
public:
virtual void PossiblyFlushUpdatedPages(
    unsigned int numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
) override
abstract PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit
override PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit

Parameters

numberOfUpdatedPagesPermittedWithoutFlushCheck (Optional)
Type: SystemUInt32
Only do check if the number of updated pages is greater than this number
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.RestoreFrom Method

ServerClientSessionSharedRestoreFrom Method

Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreFrom(
    DatabaseLocation backupLocation,
    DateTime upToTime
)
Public Overrides Sub RestoreFrom (
    backupLocation As DatabaseLocation,
    upToTime As DateTime
)
public:
virtual void RestoreFrom(
    DatabaseLocation^ backupLocation,
    DateTime upToTime
) override
abstract RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit
override RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit

Parameters

backupLocation
Type: VelocityDbDatabaseLocation
The location to restore from
upToTime
Type: SystemDateTime
Restore location up to a given DateTime. Data backed up after this time will not be restored.
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.SubscribeToChanges Method

ServerClientSessionSharedSubscribeToChanges Method

Subscribe to committed database changes of instances of a type when an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overrides Sub SubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void SubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
) override
abstract SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a boolean property. When property returns true, a change notification is send otherwise no notification is send. Leave as null to get a notification any time any instance of the selected type changes
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.Unpersist Method

ServerClientSessionSharedUnpersist Method

Use this when you want to delete objects that are not assignable as IOptimizedPersistable

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Unpersist(
    Object obj
)
Public Overrides Function Unpersist (
    obj As Object
) As Boolean
public:
virtual bool Unpersist(
    Object^ obj
) override
abstract Unpersist :
        obj : Object -> bool
override Unpersist :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to be deleted from persistent storage

Return Value

Type: Boolean
true if object found and deleted; otherwise false
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.UpdateDatabase Method

ServerClientSessionSharedUpdateDatabase Method

Request an update lock on a database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateDatabase(
    Database db
)
Public Overrides Function UpdateDatabase (
    db As Database
) As Boolean
public:
virtual bool UpdateDatabase(
    Database^ db
) override
abstract UpdateDatabase :
        db : Database -> bool
override UpdateDatabase :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database to update

Return Value

Type: Boolean
true if Database was updated, otherwise throws an exception
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.UpdateObject Method

ServerClientSessionSharedUpdateObject Method

Overload List
 | Name | Description
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Top
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


ServerClientSessionShared.UpdateObject Method (Object)

ServerClientSessionSharedUpdateObject Method (Object)

Tag an object as updated so that it will be updated persistently

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateObject(
    Object obj
)
Public Overrides Function UpdateObject (
    obj As Object
) As Boolean
public:
virtual bool UpdateObject(
    Object^ obj
) override
abstract UpdateObject :
        obj : Object -> bool
override UpdateObject :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to update.

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

ServerClientSessionShared Class
UpdateObject Overload
VelocityDb.Session Namespace


ServerClientSessionShared.UpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

ServerClientSessionSharedUpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

Updates an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateObject(
    IOptimizedPersistable obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
)
Public Overrides Function UpdateObject (
    obj As IOptimizedPersistable,
    inFlush As Boolean,
    Optional deleteObjFromIndexes As Boolean = true
) As Boolean
public:
virtual bool UpdateObject(
    IOptimizedPersistable^ obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
) override
abstract UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool
override UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool

Parameters

obj
Type: VelocityDbIOptimizedPersistable
Object to be updated
inFlush
Type: SystemBoolean
Are we doing this as part of a page flush? Set to true to avoid a recursive page flush
deleteObjFromIndexes (Optional)
Type: SystemBoolean
Set to false if you know that this object is not part of any index. Safe to leave set to true in any case

Return Value

Type: Boolean
True if object is updated; otherwise false
See Also

Reference

ServerClientSessionShared Class
UpdateObject Overload
VelocityDb.Session Namespace


ServerClientSessionShared.Verify Method

ServerClientSessionSharedVerify Method

Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Verify()
Public Overrides Sub Verify
public:
virtual void Verify() override
abstract Verify : unit -> unit
override Verify : unit -> unit
See Also

Reference

ServerClientSessionShared Class
VelocityDb.Session Namespace


SessionBase Class

Transaction control, database creation and special persistent object api. Each session can use 4,294,967,295 Databases. Each Database may have up to 65,535 Pages and a page can be up to 2 GB in size (.Net restriction of a byte array). The maximum data size a single session can manage is: 4,294,967,295 * 65,535 * 2147483648 = 604453686294542391705600 bytes or about half a Yottabyte http://en.wikipedia.org/wiki/Yottabyte
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionServerClientSession
VelocityDb.SessionSessionNoServer

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract class SessionBase : IEnumerable<Database>,
    IEnumerable, IDisposable, IEnlistmentNotification
Public MustInherit Class SessionBase
    Implements IEnumerable(Of Database), IEnumerable,
    IDisposable, IEnlistmentNotification
public ref class SessionBase abstract : IEnumerable<Database^>,
    IEnumerable, IDisposable, IEnlistmentNotification
[<AbstractClassAttribute>]
type SessionBase =
    class
        interface IEnumerable<Database>
        interface IEnumerable
        interface IDisposable
        interface IEnlistmentNotification
    end

The SessionBase type exposes the following members.

Properties
Name Description
Public property AddToIndexInSeperateThread
Allow adding objects to indices to be done in a worker thread instead of in main thread.
Public property AssumeLocalHost
SessionNoServer ignores DatabaseLocation host value, it assumes localhost, ServerSessionClient does not assume local host, it follows the DatabaseLocation HostName value.
BaseDatabasePath
If specified boot path (system database path) in session constructor isn't an absolute path then this base path is prefixed to make an absolute path.
BTreeAddFastTransientBatchSize
Default batch size for BTree AddFast api, initially set to 100
ClearAllCachedObjectsWhenDetectingUpdatedDatabase
By default we clear all cached object when at the beginning of a transaction we detect an updated Database within our cached databases. Same logic is applied when calling ForceDatabaseCacheValidation. We do so because most of the time an object in one database have (strong) references to objects in other databases. If Database A is NOT updated but database B is and an object in database A is cached with a strong reference to an object in database B then our cached object in database A may contain a stale/incorrect reference to object in database B. This is why we, by default, invalidate all cached objects when we detect a modified database within our cached databases. However, if you design your database schema without strong references between databases then you do not need to invalidate cached objects for other databases, only the ones that have changed. By consistently using WeakIOptimizedPersistableReferenceT, BTreeSetKey and BTreeMapKey, Value, you can keep references weak between databases. In such cases, set this property to false.
Public property ClientCache
Gets the client page cache object
Public property DatabaseLocations
Gets the DatabaseLocationsDatabaseLocations for the session.
Public property Databases
Gets a list of the currently opened databases
DefaultCompressPages
By default false, set to true if you want to change the default for newly created DatabaseLocation.
DefaultNumberOfObjectsPerPage
Default number of objects per page is 9999
DefaultStringComparer
Set the StringComparer to use when no application provided comparator is provided. By default we will then use StringComparer.Ordinal.
Public property DeletedOids
Collected Oid for unpersisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
DoWindowsAuthentication
By default do not use windows authentication when talking to VelocitydbServer's on other hosts.
EmbedISerializableLists
Starting in version 7.1.6, ListT bits are NOT by default stored with its parent object, instead each such ListT is stored with its own object Id. This change was necessary in order to handle circular references via ListT objects within an ISerializable serialization. Set this value to true if you have existing persisted ISerializable with ListT or else we will try to read the lists as non embedded when they are not.
Public property EnableAutoPageFlush
Pages may be flushed when memory available is low unless you set tis property to false. You would want it to be enabled unless you are trying to share a non SessionNoServerShared session by working on different databases in multiple threads. As in Wikipedia sample application.
Public property EnableSyncByTrackingChanges
Enable database and page change tracking. Turn off within an update transaction so that prior change set can be deleted.
FileBytesChunkSize
When transferring complete files from a server, we send the file bytes in chunks of this size.
Public property FileShareReader
FileShare for reader is ReadWrite with optimistic locking; otherwise Read
Public property FileShareUpdater
FileShare for updater is Read with optimistic locking; otherwise None
Public property InCommit
Indicates if we are within a transaction commit.
Public property InMemoryOnly
Gets information about this session, is it an in-memory only session or a session that persists data
Public property InTransaction
Indicates if we are within an active transaction.
Public property InUpdateTransaction
Indicates if we are within an active update transaction.
Public property IsDisposed
Check if session has been disposed
LocalHost
Get the host name of your local host (the machine you are using)
MaxStringLengthToIntern
Get the maximum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.
MaxUpdateTransactionLogHistory
Determines max number of UpdateTransaction objects we maintain in update transaction log in Database 0, initially set to 9990
MinStringLengthToIntern
Get the minimum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.
Public property NewDatabases
Get a list of all new databases created within this transaction
Public property NewOids
Collected Oid for newly persisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
Public property NotifyBeforeCommit
Set to an Action of your choice if you want to get notified right before commit of an update transaction.
Public property ObjectCachingDefaultPolicy
Get/Set default value for Cache
Public property OptimisticLocking
Is the active Database and/or Page locking using optimistic locking model or not? See https://en.wikipedia.org/wiki/Optimistic_concurrency_control and https://en.wikipedia.org/wiki/Record_locking
Public property StrongReferenceDatabaseCaching
Is current session caching Databases using strong references or just by weak references. Set in session constructor or by calling CrossTransactionCacheAllDatabases(Boolean).
Public property SystemDirectory
Get the path to the directory of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.
Public property SystemHostName
Get the host name of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.
TextEncoding
All text encoding is done with utf8
Public property TraceIndexUsage
If set to true, each time an index (BTreeSet) is used in a LINQ query expression, we output a line about that to the console output.
Public property TransactionNumber
Gets the transaction number of the current session
Public property UpdatedOids
Collected Oid for updated objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
Public property UseExternalStorageApi
This is specifically for Windows Phone API, set to true when you want to access databases from a memory card.
Public property WaitForLockMilliseconds
Get/Set the max time waiting for a lock to clear with pessimistic locking
Public property WriteToDiskInSeperateDatabaseThreads
Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work.
Top
Methods
 | Name | Description
Public method | Abort | Transaction control, abort the current transaction
Public method | AllObjectsT | Gets an object used for enumerating all objects in all Databases
Public method | AnyPageWritten | Find out if any pages have been written for a given database in this update transaction
Public method | BeginRead | Transaction control, begin a read only transaction
Public method | BeginUpdate | Transaction control, begin an update transaction.
Public method | BeginUpdate(Boolean) | Transaction control, begin an update transaction.
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now.
Public method | ClearCachedObjects | Clears the cache of cached objects.
Public method | ClearCachedObjects(Database) | Clears the cache of cached objects within a Database.
Public method | ClearCashedPages | Clear cache of cached pages
Public method | ClearPageCache | Clears cached pages from cache including page weak references.
Public method | CloseDatabase | Closes a Database
Public method | Commit | Transaction control, commit the current transaction
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins
Public method | CompareTo | The defualt compare of two SessionBase is by system (bootup) host name and directory
Public method | ContainsDatabase | Check if database file exist in a given DatabaseLocation
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host.
Public method | CreateDirectory | Creates a directory
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened.
Public method | CrossTransactionCacheAllDatabases | By default databases are referenced by strong references instead of WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to all Databases so the cached Database may be used if version wasn't changed by a different thread since prior transaction. A strong reference is removed for any database that get invalidated due to a transaction abort or if another transaction commits a change to it. Check current session state with StrongReferenceDatabaseCaching
Public method | DatabaseNumberOf | Get the database number associated with a specific type. Your application can store any type of object in any database but if the application exclusively use Persist(IOptimizedPersistable, NullableUInt16) or Persist(Object) then this is the database Id that will be used given a type.
Public method | DatabaseStillExist | Check if Database still exist
Public method | DefaultDatabaseLocation | Gets the default (startup) DatabaseLocation
Public method | DeleteDatabase | Delete a database, actual database file delete happens after a successful transaction commit.
Public method | DeleteFile | Delete a file. For internal use.
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it
Public method | DeleteObject | A way to delete an object without requiring that the object be opened first
Public method | DeletePage | Deletes a page from a database. (part of database Sync beta version - not yet fully designed and tested) Used by SyncWith when syncing databases with another replica of the current databases
Public method | DeployGenerateReaderWriter | Part of code generator, not yet ready for public release
Public method | DeployInternalTypes | For internal use only
Public method | Dispose | Closes this session
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | Opens a Databasefile for read/update. Internal use only.
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | For internal use.
Public method | FirstFreePage | Gets the page number of the first unallocated page in the specified Database
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written.
Public method | FlushUpdates | Write all updated data. This may free up some memory.
Public method | FlushUpdates(Database) | Write any updated/new pages for a specific Database
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction.
Public method | GetEnumerator | Enumerates all open databases for this session
Public method | GetVersion | Gets the version of Database 0
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object
Public method | HighestInUseDatabaseNumber | Figure out what the highest in use database number is and return it.
Public method | HighestInUseLocalDatabaseNumber | Figure out what the highest in use database number is on the local host and return it.
Public method | IdOf | Finds the object id of a persistent object
Public method | IndexT | Gets an index of all objects of a certain type
Public method | IndexT(String) | Gets an index of all objects of a certain type
Public method | IndexT(Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used). If you have updated objects persisted in a prior transaction that you want part of an index. Call FlushUpdates or call Write/> to add such an object to index before querying using an index./>
Public method | IndexT(String, Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used)
Public method | InUseNumberOfPages | Gets the number of pages currently in use by a Database
 | IsSameHost | Determine if two host names represent the same tcp/ip host
Public method | IsWorkerThread | Tell if code is executed by index or page write worker thread
Public method | LoadFields | Loads all field values of an object if they are not already loaded.
Public method | LocateDb | Lookup the DatabaseLocation of a Database with a specified database number.
Public method | NewDatabase | Create a new Database with a given database number
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones
Public method | ObjectsT | Enumerates all the objects of a given type
Public method | OfType | Gets an object used for enumerating all objects in all Databases
Public method | OidOf | Finds the object id of a persistent object
Public method | OidShortOf | Finds the object id of a persistent object
Public method | OpenAllDatabases | Open all databases
Public method | OpenDatabase | Opens a Database
Public method | OpenDatabaseLocations | Open the DatabaseLocations object and store it in the session.
Public method | OpenLocationDatabases | Opens all the databases in a given location
Public method | OpenPage | Opens a page for read, used by DatabaseManager for page browsing
Public method | OpenSchema | Get the session active schema
 | ParseCsvRow | Parses a row in a csv file and returns an iterator of column string values
Public method | Persist(Object) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database.
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.
Public method | Persist(Placement, IOptimizedPersistable) | Persist an object that is an OptimizedPersistable or a subclass
Public method | Persist(Object, IOptimizedPersistable, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Object, Placement, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use.
Public method | RegisterClass | Register a class in the persistent schema. It is a good idea to do this explicitly instead of having it happen the first time an object of an unregistered class is made persistent
Public method | RelocateDatabaseLocationFor | After moving/copying directory containing your Database with id dbId call this before starting a transaction to update host and directory of the associated DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.
Public method | RelocateDefaultDatabaseLocation | After moving/copying directory containing your Databases 0.odb, 1.odb ... call this before starting a transaction to update host and directory of the default DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.
Public method | ReplacePage | Only to be used in VelocityDbExtensions while syncing databases
Public method | ReplacePersistedType(String, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Public method | ReplacePersistedType(Type, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Public method | RestoreFrom(DatabaseLocation, DateTime) | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.
Public method | RestoreFrom(String, String, UInt32, DateTime) | Restores a DatabaseLocation
 | SetMinMaxStringIntern | A persistent string read into memory from a Database is interned using Intern(String) to speed up comparisons and conserve memory (when the same string occurs in many places)
Public method | SetTraceAllDbActivity | Enable some console output about persistent events related to all databases and pages.
Public method | SetTraceDbActivity | Enable some console output about persistent events related to a Database.
 | StringToType | Gets a Type given a string representation of a type
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an an optional property evaluates to true.
Public method | TryDatabase | Gets the current database to try
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable
Public method | UnsubscribeToChanges | Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true.
Public method | UpdateClass | Let VelocityDB know that changes have been made to a class so that the schema manager will create a new TypeVersion and use the new version for all new objects of the specified Type.
Public method | UpdateDatabase | Request an update lock on a database
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(IOptimizedPersistable) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(Object, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object
Public method | UpdatePage | Update a Page. Used by VelocityDBExtensions project
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found.
Public method | WaitForIndexUpdates | Internal Use and in VelocityDBExtensions
Top
Fields
Name | Description
Assembly |
IndexDescriptorDatabaseNumber | Database 3 is dedicated to keeping track of index usage
s_serverTcpIpPortNumber | By default port number 7031 is used for communication with VelocityDBServer. Change the value here and also in VelocityDbServer.exe.config if you need to use a different port number.
s_typeDatabaseIdOffsetFromTypeShortId | Determines database Id to use for a certain VelocityDbType instance
s_typeDatabaseIdOverflowIndexCollisionOffset | If additional databases are required for storing instances of some index, start by attempting creating database at this offset from original
s_typeDatabaseIdOverflowOffset | If additional databases are required for storing instances of some type, start by attempting creating database at this offset from original
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDb.Session Namespace


SessionBase Properties

The SessionBase type exposes the following members.

Properties
Name Description
Public property AddToIndexInSeperateThread
Allow adding objects to indices to be done in a worker thread instead of in main thread.
Public property AssumeLocalHost
SessionNoServer ignores DatabaseLocation host value, it assumes localhost, ServerSessionClient does not assume local host, it follows the DatabaseLocation HostName value.
BaseDatabasePath
If specified boot path (system database path) in session constructor isn't an absolute path then this base path is prefixed to make an absolute path.
BTreeAddFastTransientBatchSize
Default batch size for BTree AddFast api, initially set to 100
ClearAllCachedObjectsWhenDetectingUpdatedDatabase
By default we clear all cached object when at the beginning of a transaction we detect an updated Database within our cached databases. Same logic is applied when calling ForceDatabaseCacheValidation. We do so because most of the time an object in one database have (strong) references to objects in other databases. If Database A is NOT updated but database B is and an object in database A is cached with a strong reference to an object in database B then our cached object in database A may contain a stale/incorrect reference to object in database B. This is why we, by default, invalidate all cached objects when we detect a modified database within our cached databases. However, if you design your database schema without strong references between databases then you do not need to invalidate cached objects for other databases, only the ones that have changed. By consistently using WeakIOptimizedPersistableReferenceT, BTreeSetKey and BTreeMapKey, Value, you can keep references weak between databases. In such cases, set this property to false.
Public property ClientCache
Gets the client page cache object
Public property DatabaseLocations
Gets the DatabaseLocationsDatabaseLocations for the session.
Public property Databases
Gets a list of the currently opened databases
DefaultCompressPages
By default false, set to true if you want to change the default for newly created DatabaseLocation.
DefaultNumberOfObjectsPerPage
Default number of objects per page is 9999
DefaultStringComparer
Set the StringComparer to use when no application provided comparator is provided. By default we will then use StringComparer.Ordinal.
Public property DeletedOids
Collected Oid for unpersisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
DoWindowsAuthentication
By default do not use windows authentication when talking to VelocitydbServer's on other hosts.
EmbedISerializableLists
Starting in version 7.1.6, ListT bits are NOT by default stored with its parent object, instead each such ListT is stored with its own object Id. This change was necessary in order to handle circular references via ListT objects within an ISerializable serialization. Set this value to true if you have existing persisted ISerializable with ListT or else we will try to read the lists as non embedded when they are not.
Public property EnableAutoPageFlush
Pages may be flushed when memory available is low unless you set tis property to false. You would want it to be enabled unless you are trying to share a non SessionNoServerShared session by working on different databases in multiple threads. As in Wikipedia sample application.
Public property EnableSyncByTrackingChanges
Enable database and page change tracking. Turn off within an update transaction so that prior change set can be deleted.
FileBytesChunkSize
When transferring complete files from a server, we send the file bytes in chunks of this size.
Public property FileShareReader
FileShare for reader is ReadWrite with optimistic locking; otherwise Read
Public property FileShareUpdater
FileShare for updater is Read with optimistic locking; otherwise None
Public property InCommit
Indicates if we are within a transaction commit.
Public property InMemoryOnly
Gets information about this session, is it an in-memory only session or a session that persists data
Public property InTransaction
Indicates if we are within an active transaction.
Public property InUpdateTransaction
Indicates if we are within an active update transaction.
Public property IsDisposed
Check if session has been disposed
LocalHost
Get the host name of your local host (the machine you are using)
MaxStringLengthToIntern
Get the maximum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.
MaxUpdateTransactionLogHistory
Determines max number of UpdateTransaction objects we maintain in update transaction log in Database 0, initially set to 9990
MinStringLengthToIntern
Get the minimum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.
Public property NewDatabases
Get a list of all new databases created within this transaction
Public property NewOids
Collected Oid for newly persisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
Public property NotifyBeforeCommit
Set to an Action of your choice if you want to get notified right before commit of an update transaction.
Public property ObjectCachingDefaultPolicy
Get/Set default value for Cache
Public property OptimisticLocking
Is the active Database and/or Page locking using optimistic locking model or not? See https://en.wikipedia.org/wiki/Optimistic_concurrency_control and https://en.wikipedia.org/wiki/Record_locking
Public property StrongReferenceDatabaseCaching
Is current session caching Databases using strong references or just by weak references. Set in session constructor or by calling CrossTransactionCacheAllDatabases(Boolean).
Public property SystemDirectory
Get the path to the directory of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.
Public property SystemHostName
Get the host name of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.
TextEncoding
All text encoding is done with utf8
Public property TraceIndexUsage
If set to true, each time an index (BTreeSet) is used in a LINQ query expression, we output a line about that to the console output.
Public property TransactionNumber
Gets the transaction number of the current session
Public property UpdatedOids
Collected Oid for updated objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.
Public property UseExternalStorageApi
This is specifically for Windows Phone API, set to true when you want to access databases from a memory card.
Public property WaitForLockMilliseconds
Get/Set the max time waiting for a lock to clear with pessimistic locking
Public property WriteToDiskInSeperateDatabaseThreads
Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work.
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.AddToIndexInSeperateThread Property

SessionBaseAddToIndexInSeperateThread Property

Allow adding objects to indices to be done in a worker thread instead of in main thread.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AddToIndexInSeperateThread { get; set; }
Public Overridable Property AddToIndexInSeperateThread As Boolean
    Get
    Set
public:
virtual property bool AddToIndexInSeperateThread {
    bool get ();
    void set (bool value);
}
abstract AddToIndexInSeperateThread : bool with get, set
override AddToIndexInSeperateThread : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.AssumeLocalHost Property

SessionBaseAssumeLocalHost Property

SessionNoServer ignores DatabaseLocation host value, it assumes localhost, ServerSessionClient does not assume local host, it follows the DatabaseLocation HostName value.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AssumeLocalHost { get; }
Public Overridable ReadOnly Property AssumeLocalHost As Boolean
    Get
public:
virtual property bool AssumeLocalHost {
    bool get ();
}
abstract AssumeLocalHost : bool with get
override AssumeLocalHost : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.BaseDatabasePath Property

SessionBaseBaseDatabasePath Property

If specified boot path (system database path) in session constructor isn't an absolute path then this base path is prefixed to make an absolute path.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string BaseDatabasePath { get; set; }
Public Shared Property BaseDatabasePath As String
    Get
    Set
public:
static property String^ BaseDatabasePath {
    String^ get ();
    void set (String^ value);
}
static member BaseDatabasePath : string with get, set

Property Value

Type: String
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.BTreeAddFastTransientBatchSize Property

SessionBaseBTreeAddFastTransientBatchSize Property

Default batch size for BTree AddFast api, initially set to 100

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static uint BTreeAddFastTransientBatchSize { get; set; }
Public Shared Property BTreeAddFastTransientBatchSize As UInteger
    Get
    Set
public:
static property unsigned int BTreeAddFastTransientBatchSize {
    unsigned int get ();
    void set (unsigned int value);
}
static member BTreeAddFastTransientBatchSize : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClearAllCachedObjectsWhenDetectingUpdatedDatabase Property

SessionBaseClearAllCachedObjectsWhenDetectingUpdatedDatabase Property

By default we clear all cached object when at the beginning of a transaction we detect an updated Database within our cached databases. Same logic is applied when calling ForceDatabaseCacheValidation. We do so because most of the time an object in one database have (strong) references to objects in other databases. If Database A is NOT updated but database B is and an object in database A is cached with a strong reference to an object in database B then our cached object in database A may contain a stale/incorrect reference to object in database B. This is why we, by default, invalidate all cached objects when we detect a modified database within our cached databases. However, if you design your database schema without strong references between databases then you do not need to invalidate cached objects for other databases, only the ones that have changed. By consistently using WeakIOptimizedPersistableReferenceT, BTreeSetKey and BTreeMapKey, Value, you can keep references weak between databases. In such cases, set this property to false.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool ClearAllCachedObjectsWhenDetectingUpdatedDatabase { get; set; }
Public Shared Property ClearAllCachedObjectsWhenDetectingUpdatedDatabase As Boolean
    Get
    Set
public:
static property bool ClearAllCachedObjectsWhenDetectingUpdatedDatabase {
    bool get ();
    void set (bool value);
}
static member ClearAllCachedObjectsWhenDetectingUpdatedDatabase : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClientCache Property

SessionBaseClientCache Property

Gets the client page cache object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DataCache ClientCache { get; }
Public ReadOnly Property ClientCache As DataCache
    Get
public:
property DataCache^ ClientCache {
    DataCache^ get ();
}
member ClientCache : DataCache with get

Property Value

Type: DataCache
The DataCache
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DatabaseLocations Property

SessionBaseDatabaseLocations Property

Gets the DatabaseLocationsDatabaseLocations for the session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocations DatabaseLocations { get; }
Public ReadOnly Property DatabaseLocations As DatabaseLocations
    Get
public:
property DatabaseLocations^ DatabaseLocations {
    DatabaseLocations^ get ();
}
member DatabaseLocations : DatabaseLocations with get

Property Value

Type: DatabaseLocations
The DatabaseLocations
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Databases Property

SessionBaseDatabases Property

Gets a list of the currently opened databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<Database> Databases { get; }
Public Overridable ReadOnly Property Databases As IList(Of Database)
    Get
public:
virtual property IList<Database^>^ Databases {
    IList<Database^>^ get ();
}
abstract Databases : IList<Database> with get
override Databases : IList<Database> with get

Property Value

Type: IList Database
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DefaultCompressPages Property

SessionBaseDefaultCompressPages Property

By default false, set to true if you want to change the default for newly created DatabaseLocation.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static PageInfocompressionKind DefaultCompressPages { get; set; }
Public Shared Property DefaultCompressPages As PageInfocompressionKind
    Get
    Set
public:
static property PageInfocompressionKind DefaultCompressPages {
    PageInfocompressionKind get ();
    void set (PageInfocompressionKind value);
}
static member DefaultCompressPages : PageInfocompressionKind with get, set

Property Value

Type: PageInfocompressionKind
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DefaultNumberOfObjectsPerPage Property

SessionBaseDefaultNumberOfObjectsPerPage Property

Default number of objects per page is 9999

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort DefaultNumberOfObjectsPerPage { get; }
Public Shared ReadOnly Property DefaultNumberOfObjectsPerPage As UShort
    Get
public:
static property unsigned short DefaultNumberOfObjectsPerPage {
    unsigned short get ();
}
static member DefaultNumberOfObjectsPerPage : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DefaultStringComparer Property

SessionBaseDefaultStringComparer Property

Set the StringComparer to use when no application provided comparator is provided. By default we will then use StringComparer.Ordinal.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static StringComparer DefaultStringComparer { get; set; }
Public Shared Property DefaultStringComparer As StringComparer
    Get
    Set
public:
static property StringComparer^ DefaultStringComparer {
    StringComparer^ get ();
    void set (StringComparer^ value);
}
static member DefaultStringComparer : StringComparer with get, set

Property Value

Type: StringComparer
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeletedOids Property

SessionBaseDeletedOids Property

Collected Oid for unpersisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public HashSet<Oid> DeletedOids { get; }
Public ReadOnly Property DeletedOids As HashSet(Of Oid)
    Get
public:
property HashSet<Oid>^ DeletedOids {
    HashSet<Oid>^ get ();
}
member DeletedOids : HashSet<Oid> with get

Property Value

Type: HashSet Oid
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DoWindowsAuthentication Property

SessionBaseDoWindowsAuthentication Property

By default do not use windows authentication when talking to VelocitydbServer's on other hosts.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool DoWindowsAuthentication { get; set; }
Public Shared Property DoWindowsAuthentication As Boolean
    Get
    Set
public:
static property bool DoWindowsAuthentication {
    bool get ();
    void set (bool value);
}
static member DoWindowsAuthentication : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.EmbedISerializableLists Property

SessionBaseEmbedISerializableLists Property

Starting in version 7.1.6, ListT bits are NOT by default stored with its parent object, instead each such ListT is stored with its own object Id. This change was necessary in order to handle circular references via ListT objects within an ISerializable serialization. Set this value to true if you have existing persisted ISerializable with ListT or else we will try to read the lists as non embedded when they are not.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool EmbedISerializableLists { get; set; }
Public Shared Property EmbedISerializableLists As Boolean
    Get
    Set
public:
static property bool EmbedISerializableLists {
    bool get ();
    void set (bool value);
}
static member EmbedISerializableLists : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.EnableAutoPageFlush Property

SessionBaseEnableAutoPageFlush Property

Pages may be flushed when memory available is low unless you set tis property to false. You would want it to be enabled unless you are trying to share a non SessionNoServerShared session by working on different databases in multiple threads. As in Wikipedia sample application.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool EnableAutoPageFlush { get; set; }
Public Property EnableAutoPageFlush As Boolean
    Get
    Set
public:
property bool EnableAutoPageFlush {
    bool get ();
    void set (bool value);
}
member EnableAutoPageFlush : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.EnableSyncByTrackingChanges Property

SessionBaseEnableSyncByTrackingChanges Property

Enable database and page change tracking. Turn off within an update transaction so that prior change set can be deleted.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool EnableSyncByTrackingChanges { get; set; }
Public Property EnableSyncByTrackingChanges As Boolean
    Get
    Set
public:
property bool EnableSyncByTrackingChanges {
    bool get ();
    void set (bool value);
}
member EnableSyncByTrackingChanges : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FileBytesChunkSize Property

SessionBaseFileBytesChunkSize Property

When transferring complete files from a server, we send the file bytes in chunks of this size.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static uint FileBytesChunkSize { get; }
Public Shared ReadOnly Property FileBytesChunkSize As UInteger
    Get
public:
static property unsigned int FileBytesChunkSize {
    unsigned int get ();
}
static member FileBytesChunkSize : uint32 with get

Property Value

Type: UInt32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FileShareReader Property

SessionBaseFileShareReader Property

FileShare for reader is ReadWrite with optimistic locking; otherwise Read

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FileShare FileShareReader { get; }
Public ReadOnly Property FileShareReader As FileShare
    Get
public:
property FileShare FileShareReader {
    FileShare get ();
}
member FileShareReader : FileShare with get

Property Value

Type: FileShare
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FileShareUpdater Property

SessionBaseFileShareUpdater Property

FileShare for updater is Read with optimistic locking; otherwise None

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FileShare FileShareUpdater { get; }
Public ReadOnly Property FileShareUpdater As FileShare
    Get
public:
property FileShare FileShareUpdater {
    FileShare get ();
}
member FileShareUpdater : FileShare with get

Property Value

Type: FileShare
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.InCommit Property

SessionBaseInCommit Property

Indicates if we are within a transaction commit.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InCommit { get; }
Public Overridable ReadOnly Property InCommit As Boolean
    Get
public:
virtual property bool InCommit {
    bool get ();
}
abstract InCommit : bool with get
override InCommit : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.InMemoryOnly Property

SessionBaseInMemoryOnly Property

Gets information about this session, is it an in-memory only session or a session that persists data

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool InMemoryOnly { get; }
Public ReadOnly Property InMemoryOnly As Boolean
    Get
public:
property bool InMemoryOnly {
    bool get ();
}
member InMemoryOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.InTransaction Property

SessionBaseInTransaction Property

Indicates if we are within an active transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InTransaction { get; }
Public Overridable ReadOnly Property InTransaction As Boolean
    Get
public:
virtual property bool InTransaction {
    bool get ();
}
abstract InTransaction : bool with get
override InTransaction : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.InUpdateTransaction Property

SessionBaseInUpdateTransaction Property

Indicates if we are within an active update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InUpdateTransaction { get; }
Public Overridable ReadOnly Property InUpdateTransaction As Boolean
    Get
public:
virtual property bool InUpdateTransaction {
    bool get ();
}
abstract InUpdateTransaction : bool with get
override InUpdateTransaction : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.IsDisposed Property

SessionBaseIsDisposed Property

Check if session has been disposed

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.LocalHost Property

SessionBaseLocalHost Property

Get the host name of your local host (the machine you are using)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string LocalHost { get; }
Public Shared ReadOnly Property LocalHost As String
    Get
public:
static property String^ LocalHost {
    String^ get ();
}
static member LocalHost : string with get

Property Value

Type: String
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.MaxStringLengthToIntern Property

SessionBaseMaxStringLengthToIntern Property

Get the maximum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort MaxStringLengthToIntern { get; }
Public Shared ReadOnly Property MaxStringLengthToIntern As UShort
    Get
public:
static property unsigned short MaxStringLengthToIntern {
    unsigned short get ();
}
static member MaxStringLengthToIntern : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.MaxUpdateTransactionLogHistory Property

SessionBaseMaxUpdateTransactionLogHistory Property

Determines max number of UpdateTransaction objects we maintain in update transaction log in Database 0, initially set to 9990

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int MaxUpdateTransactionLogHistory { get; set; }
Public Shared Property MaxUpdateTransactionLogHistory As Integer
    Get
    Set
public:
static property int MaxUpdateTransactionLogHistory {
    int get ();
    void set (int value);
}
static member MaxUpdateTransactionLogHistory : int with get, set

Property Value

Type: Int32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.MinStringLengthToIntern Property

SessionBaseMinStringLengthToIntern Property

Get the minimum size a string must have before VelocityDB internals interns, Intern(String), string when read from a Database.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ushort MinStringLengthToIntern { get; }
Public Shared ReadOnly Property MinStringLengthToIntern As UShort
    Get
public:
static property unsigned short MinStringLengthToIntern {
    unsigned short get ();
}
static member MinStringLengthToIntern : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.NewDatabases Property

SessionBaseNewDatabases Property

Get a list of all new databases created within this transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<Database> NewDatabases { get; }
Public ReadOnly Property NewDatabases As List(Of Database)
    Get
public:
property List<Database^>^ NewDatabases {
    List<Database^>^ get ();
}
member NewDatabases : List<Database> with get

Property Value

Type: List Database
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.NewOids Property

SessionBaseNewOids Property

Collected Oid for newly persisted objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public HashSet<Oid> NewOids { get; }
Public ReadOnly Property NewOids As HashSet(Of Oid)
    Get
public:
property HashSet<Oid>^ NewOids {
    HashSet<Oid>^ get ();
}
member NewOids : HashSet<Oid> with get

Property Value

Type: HashSet Oid
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.NotifyBeforeCommit Property

SessionBaseNotifyBeforeCommit Property

Set to an Action of your choice if you want to get notified right before commit of an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Action<SessionBase> NotifyBeforeCommit { get; set; }
Public Property NotifyBeforeCommit As Action(Of SessionBase)
    Get
    Set
public:
property Action<SessionBase^>^ NotifyBeforeCommit {
    Action<SessionBase^>^ get ();
    void set (Action<SessionBase^>^ value);
}
member NotifyBeforeCommit : Action<SessionBase> with get, set

Property Value

Type: Action SessionBase
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ObjectCachingDefaultPolicy Property

SessionBaseObjectCachingDefaultPolicy Property

Get/Set default value for Cache

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public CacheEnum ObjectCachingDefaultPolicy { get; set; }
Public Property ObjectCachingDefaultPolicy As CacheEnum
    Get
    Set
public:
property CacheEnum ObjectCachingDefaultPolicy {
    CacheEnum get ();
    void set (CacheEnum value);
}
member ObjectCachingDefaultPolicy : CacheEnum with get, set

Property Value

Type: CacheEnum
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OptimisticLocking Property

SessionBaseOptimisticLocking Property

Is the active Database and/or Page locking using optimistic locking model or not? See https://en.wikipedia.org/wiki/Optimistic_concurrency_control and https://en.wikipedia.org/wiki/Record_locking

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool OptimisticLocking { get; }
Public ReadOnly Property OptimisticLocking As Boolean
    Get
public:
property bool OptimisticLocking {
    bool get ();
}
member OptimisticLocking : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.StrongReferenceDatabaseCaching Property

SessionBaseStrongReferenceDatabaseCaching Property

Is current session caching Databases using strong references or just by weak references. Set in session constructor or by calling CrossTransactionCacheAllDatabases(Boolean).

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool StrongReferenceDatabaseCaching { get; }
Public ReadOnly Property StrongReferenceDatabaseCaching As Boolean
    Get
public:
property bool StrongReferenceDatabaseCaching {
    bool get ();
}
member StrongReferenceDatabaseCaching : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.SystemDirectory Property

SessionBaseSystemDirectory Property

Get the path to the directory of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SystemDirectory { get; }
Public ReadOnly Property SystemDirectory As String
    Get
public:
property String^ SystemDirectory {
    String^ get ();
}
member SystemDirectory : string with get

Property Value

Type: String
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.SystemHostName Property

SessionBaseSystemHostName Property

Get the host name of the system Databases (0.odb, 1.odb, 2.odb ...) of this session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SystemHostName { get; }
Public ReadOnly Property SystemHostName As String
    Get
public:
property String^ SystemHostName {
    String^ get ();
}
member SystemHostName : string with get

Property Value

Type: String
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.TextEncoding Property

SessionBaseTextEncoding Property

All text encoding is done with utf8

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Encoding TextEncoding { get; }
Public Shared ReadOnly Property TextEncoding As Encoding
    Get
public:
static property Encoding^ TextEncoding {
    Encoding^ get ();
}
static member TextEncoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.TraceIndexUsage Property

SessionBaseTraceIndexUsage Property

If set to true, each time an index (BTreeSet) is used in a LINQ query expression, we output a line about that to the console output.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TraceIndexUsage { get; set; }
Public Property TraceIndexUsage As Boolean
    Get
    Set
public:
property bool TraceIndexUsage {
    bool get ();
    void set (bool value);
}
member TraceIndexUsage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.TransactionNumber Property

SessionBaseTransactionNumber Property

Gets the transaction number of the current session

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong TransactionNumber { get; }
Public ReadOnly Property TransactionNumber As ULong
    Get
public:
property unsigned long long TransactionNumber {
    unsigned long long get ();
}
member TransactionNumber : uint64 with get

Property Value

Type: UInt64
The transaction number
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UpdatedOids Property

SessionBaseUpdatedOids Property

Collected Oid for updated objects within an update transaction. Ids are only collected if NotifyBeforeCommit is non null.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public HashSet<Oid> UpdatedOids { get; }
Public ReadOnly Property UpdatedOids As HashSet(Of Oid)
    Get
public:
property HashSet<Oid>^ UpdatedOids {
    HashSet<Oid>^ get ();
}
member UpdatedOids : HashSet<Oid> with get

Property Value

Type: HashSet Oid
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UseExternalStorageApi Property

SessionBaseUseExternalStorageApi Property

This is specifically for Windows Phone API, set to true when you want to access databases from a memory card.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool UseExternalStorageApi { get; set; }
Public Property UseExternalStorageApi As Boolean
    Get
    Set
public:
property bool UseExternalStorageApi {
    bool get ();
    void set (bool value);
}
member UseExternalStorageApi : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.WaitForLockMilliseconds Property

SessionBaseWaitForLockMilliseconds Property

Get/Set the max time waiting for a lock to clear with pessimistic locking

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int WaitForLockMilliseconds { get; set; }
Public Property WaitForLockMilliseconds As Integer
    Get
    Set
public:
property int WaitForLockMilliseconds {
    int get ();
    void set (int value);
}
member WaitForLockMilliseconds : int with get, set

Property Value

Type: Int32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.WriteToDiskInSeperateDatabaseThreads Property

SessionBaseWriteToDiskInSeperateDatabaseThreads Property

Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WriteToDiskInSeperateDatabaseThreads { get; set; }
Public Overridable Property WriteToDiskInSeperateDatabaseThreads As Boolean
    Get
    Set
public:
virtual property bool WriteToDiskInSeperateDatabaseThreads {
    bool get ();
    void set (bool value);
}
abstract WriteToDiskInSeperateDatabaseThreads : bool with get, set
override WriteToDiskInSeperateDatabaseThreads : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase Methods

The SessionBase type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Transaction control, abort the current transaction
Public method | AllObjectsT | Gets an object used for enumerating all objects in all Databases
Public method | AnyPageWritten | Find out if any pages have been written for a given database in this update transaction
Public method | BeginRead | Transaction control, begin a read only transaction
Public method | BeginUpdate | Transaction control, begin an update transaction.
Public method | BeginUpdate(Boolean) | Transaction control, begin an update transaction.
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now.
Public method | ClearCachedObjects | Clears the cache of cached objects.
Public method | ClearCachedObjects(Database) | Clears the cache of cached objects within a Database.
Public method | ClearCashedPages | Clear cache of cached pages
Public method | ClearPageCache | Clears cached pages from cache including page weak references.
Public method | CloseDatabase | Closes a Database
Public method | Commit | Transaction control, commit the current transaction
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins
Public method | CompareTo | The defualt compare of two SessionBase is by system (bootup) host name and directory
Public method | ContainsDatabase | Check if database file exist in a given DatabaseLocation
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host.
Public method | CreateDirectory | Creates a directory
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened.
Public method | CrossTransactionCacheAllDatabases | By default databases are referenced by strong references instead of WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to all Databases so the cached Database may be used if version wasn't changed by a different thread since prior transaction. A strong reference is removed for any database that get invalidated due to a transaction abort or if another transaction commits a change to it. Check current session state with StrongReferenceDatabaseCaching
Public method | DatabaseNumberOf | Get the database number associated with a specific type. Your application can store any type of object in any database but if the application exclusively use Persist(IOptimizedPersistable, NullableUInt16) or Persist(Object) then this is the database Id that will be used given a type.
Public method | DatabaseStillExist | Check if Database still exist
Public method | DefaultDatabaseLocation | Gets the default (startup) DatabaseLocation
Public method | DeleteDatabase | Delete a database, actual database file delete happens after a successful transaction commit.
Public method | DeleteFile | Delete a file. For internal use.
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it
Public method | DeleteObject | A way to delete an object without requiring that the object be opened first
Public method | DeletePage | Deletes a page from a database. (part of database Sync beta version - not yet fully designed and tested) Used by SyncWith when syncing databases with another replica of the current databases
Public method | DeployGenerateReaderWriter | Part of code generator, not yet ready for public release
Public method | DeployInternalTypes | For internal use only
Public method | Dispose | Closes this session
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | Opens a Databasefile for read/update. Internal use only.
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | For internal use.
Public method | FirstFreePage | Gets the page number of the first unallocated page in the specified Database
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written.
Public method | FlushUpdates | Write all updated data. This may free up some memory.
Public method | FlushUpdates(Database) | Write any updated/new pages for a specific Database
Public method | FlushUpdatesServers | Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction.
Public method | GetEnumerator | Enumerates all open databases for this session
Public method | GetVersion | Gets the version of Database 0
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object
Public method | HighestInUseDatabaseNumber | Figure out what the highest in use database number is and return it.
Public method | HighestInUseLocalDatabaseNumber | Figure out what the highest in use database number is on the local host and return it.
Public method | IdOf | Finds the object id of a persistent object
Public method | IndexT | Gets an index of all objects of a certain type
Public method | IndexT(String) | Gets an index of all objects of a certain type
Public method | IndexT(Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used). If you have updated objects persisted in a prior transaction that you want part of an index. Call FlushUpdates or call Write/> to add such an object to index before querying using an index./>
Public method | IndexT(String, Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used)
Public method | InUseNumberOfPages | Gets the number of pages currently in use by a Database
 | IsSameHost | Determine if two host names represent the same tcp/ip host
Public method | IsWorkerThread | Tell if code is executed by index or page write worker thread
Public method | LoadFields | Loads all field values of an object if they are not already loaded.
Public method | LocateDb | Lookup the DatabaseLocation of a Database with a specified database number.
Public method | NewDatabase | Create a new Database with a given database number
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones
Public method | ObjectsT | Enumerates all the objects of a given type
Public method | OfType | Gets an object used for enumerating all objects in all Databases
Public method | OidOf | Finds the object id of a persistent object
Public method | OidShortOf | Finds the object id of a persistent object
Public method | OpenAllDatabases | Open all databases
Public method | OpenDatabase | Opens a Database
Public method | OpenDatabaseLocations | Open the DatabaseLocations object and store it in the session.
Public method | OpenLocationDatabases | Opens all the databases in a given location
Public method | OpenPage | Opens a page for read, used by DatabaseManager for page browsing
Public method | OpenSchema | Get the session active schema
 | ParseCsvRow | Parses a row in a csv file and returns an iterator of column string values
Public method | Persist(Object) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database.
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.
Public method | Persist(Placement, IOptimizedPersistable) | Persist an object that is an OptimizedPersistable or a subclass
Public method | Persist(Object, IOptimizedPersistable, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Object, Placement, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use.
Public method | RegisterClass | Register a class in the persistent schema. It is a good idea to do this explicitly instead of having it happen the first time an object of an unregistered class is made persistent
Public method | RelocateDatabaseLocationFor | After moving/copying directory containing your Database with id dbId call this before starting a transaction to update host and directory of the associated DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.
Public method | RelocateDefaultDatabaseLocation | After moving/copying directory containing your Databases 0.odb, 1.odb ... call this before starting a transaction to update host and directory of the default DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.
Public method | ReplacePage | Only to be used in VelocityDbExtensions while syncing databases
Public method | ReplacePersistedType(String, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Public method | ReplacePersistedType(Type, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Public method | RestoreFrom(DatabaseLocation, DateTime) | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.
Public method | RestoreFrom(String, String, UInt32, DateTime) | Restores a DatabaseLocation
 | SetMinMaxStringIntern | A persistent string read into memory from a Database is interned using Intern(String) to speed up comparisons and conserve memory (when the same string occurs in many places)
Public method | SetTraceAllDbActivity | Enable some console output about persistent events related to all databases and pages.
Public method | SetTraceDbActivity | Enable some console output about persistent events related to a Database.
 | StringToType | Gets a Type given a string representation of a type
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an an optional property evaluates to true.
Public method | TryDatabase | Gets the current database to try
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable
Public method | UnsubscribeToChanges | Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true.
Public method | UpdateClass | Let VelocityDB know that changes have been made to a class so that the schema manager will create a new TypeVersion and use the new version for all new objects of the specified Type.
Public method | UpdateDatabase | Request an update lock on a database
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(IOptimizedPersistable) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(Object, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object
Public method | UpdatePage | Update a Page. Used by VelocityDBExtensions project
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found.
Public method | WaitForIndexUpdates | Internal Use and in VelocityDBExtensions
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Abort Method

SessionBaseAbort Method

Transaction control, abort the current transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Abort()
Public Overridable Sub Abort
public:
virtual void Abort()
abstract Abort : unit -> unit
override Abort : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.AllObjects(T) Method

SessionBaseAllObjectsT Method

Gets an object used for enumerating all objects in all Databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AllObjects<T> AllObjects<T>(
    bool includeSubclasses = true,
    bool databasePerType = true
)

Public Function AllObjects(Of T) (
    Optional includeSubclasses As Boolean = true,
    Optional databasePerType As Boolean = true
) As AllObjects(Of T)
public:
generic<typename T>
AllObjects<T>^ AllObjects(
    bool includeSubclasses = true,
    bool databasePerType = true
)
member AllObjects :
        ?includeSubclasses : bool *
        ?databasePerType : bool
(* Defaults:
        let _includeSubclasses = defaultArg includeSubclasses true
        let _databasePerType = defaultArg databasePerType true
*)
-> AllObjects<'T>

Parameters

includeSubclasses (Optional)
Type: SystemBoolean
Also return instances of sub classes or classes that implements the specified interface class
databasePerType (Optional)
Type: SystemBoolean
Assume that persisted objects where made persistent the simple way using Persist(IOptimizedPersistable, NullableUInt16). When persisting this way, each object type gets its own Database which makes finding these objects easier and faster

Type Parameters

T
The type of object we are looking for

Return Value

Type: AllObjects T
The enumeration wrapper object
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.AnyPageWritten Method

SessionBaseAnyPageWritten Method

Find out if any pages have been written for a given database in this update transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AnyPageWritten(
    Database db
)
Public Function AnyPageWritten (
    db As Database
) As Boolean
public:
bool AnyPageWritten(
    Database^ db
)
member AnyPageWritten :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database of interest

Return Value

Type: Boolean
true if any pages have been written, otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.BeginRead Method

SessionBaseBeginRead Method

Transaction control, begin a read only transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual SessionBaseTransaction BeginRead(
    bool doRecoveryCheck = false
)
Public Overridable Function BeginRead (
    Optional doRecoveryCheck As Boolean = false
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginRead(
    bool doRecoveryCheck = false
)
abstract BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction
override BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
By default we do not check for a failed update transaction that requires reverting one or more database changes. We don't do it by default because it can be a little costly. Change this parameter to true if you prefer ensured consistency over better performance or make change only if you encounter an exception in the transaction.

Return Value

Type: SessionBaseTransaction
A transaction helper object.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.BeginUpdate Method

SessionBaseBeginUpdate Method

Overload List
 | Name | Description
Public method | BeginUpdate | Transaction control, begin an update transaction.
Public method | BeginUpdate(Boolean) | Transaction control, begin an update transaction.
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.BeginUpdate Method

SessionBaseBeginUpdate Method

Transaction control, begin an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionBaseTransaction BeginUpdate()
Public Function BeginUpdate As SessionBaseTransaction
public:
SessionBaseTransaction^ BeginUpdate()
member BeginUpdate : unit -> SessionBaseTransaction

Return Value

Type: SessionBaseTransaction
A SessionBaseTransaction helper object.
See Also

Reference

SessionBase Class
BeginUpdate Overload
VelocityDb.Session Namespace


SessionBase.BeginUpdate Method (Boolean)

SessionBaseBeginUpdate Method (Boolean)

Transaction control, begin an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual SessionBaseTransaction BeginUpdate(
    bool doRecoveryCheck
)
Public Overridable Function BeginUpdate (
    doRecoveryCheck As Boolean
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginUpdate(
    bool doRecoveryCheck
)
abstract BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction
override BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction

Parameters

doRecoveryCheck
Type: SystemBoolean
Set to false only when moving system databases to a new directory

Return Value

Type: SessionBaseTransaction
A SessionBaseTransaction helper object.
See Also

Reference

SessionBase Class
BeginUpdate Overload
VelocityDb.Session Namespace


SessionBase.Checkpoint Method

SessionBaseCheckpoint Method

Same as Commit(Boolean, Boolean) followed by BeginUpdate

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual SessionBaseTransaction Checkpoint()
Public Overridable Function Checkpoint As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ Checkpoint()
abstract Checkpoint : unit -> SessionBaseTransaction
override Checkpoint : unit -> SessionBaseTransaction

Return Value

Type: SessionBaseTransaction
SessionBaseTransaction started
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClearCache Method

SessionBaseClearCache Method

Clears page cache and closes databases. Avoid using this one for now.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearCache()
Public Overridable Sub ClearCache
public:
virtual void ClearCache()
abstract ClearCache : unit -> unit
override ClearCache : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClearCachedObjects Method

SessionBaseClearCachedObjects Method

Overload List
 | Name | Description
Public method | ClearCachedObjects | Clears the cache of cached objects.
Public method | ClearCachedObjects(Database) | Clears the cache of cached objects within a Database.
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClearCachedObjects Method

SessionBaseClearCachedObjects Method

Clears the cache of cached objects.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ClearCachedObjects()
Public Sub ClearCachedObjects
public:
void ClearCachedObjects()
member ClearCachedObjects : unit -> unit
See Also

Reference

SessionBase Class
ClearCachedObjects Overload
VelocityDb.Session Namespace


SessionBase.ClearCachedObjects Method (Database)

SessionBaseClearCachedObjects Method (Database)

Clears the cache of cached objects within a Database.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ClearCachedObjects(
    Database db
)
Public Sub ClearCachedObjects (
    db As Database
)
public:
void ClearCachedObjects(
    Database^ db
)
member ClearCachedObjects :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
Clear cached objects within this database.
See Also

Reference

SessionBase Class
ClearCachedObjects Overload
VelocityDb.Session Namespace


SessionBase.ClearCashedPages Method

SessionBaseClearCashedPages Method

Clear cache of cached pages

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearCashedPages()
Public Overridable Sub ClearCashedPages
public:
virtual void ClearCashedPages()
abstract ClearCashedPages : unit -> unit
override ClearCashedPages : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ClearPageCache Method

SessionBaseClearPageCache Method

Clears cached pages from cache including page weak references.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearPageCache()
Public Overridable Sub ClearPageCache
public:
virtual void ClearPageCache()
abstract ClearPageCache : unit -> unit
override ClearPageCache : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.CloseDatabase Method

SessionBaseCloseDatabase Method

Closes a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CloseDatabase(
    Database db
)
Public Sub CloseDatabase (
    db As Database
)
public:
void CloseDatabase(
    Database^ db
)
member CloseDatabase :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
The Database to close
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Commit Method

SessionBaseCommit Method

Transaction control, commit the current transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Commit(
    bool doRecoveryCheck = true,
    bool isRestore = false
)
Public Sub Commit (
    Optional doRecoveryCheck As Boolean = true,
    Optional isRestore As Boolean = false
)
public:
void Commit(
    bool doRecoveryCheck = true,
    bool isRestore = false
)
member Commit :
        ?doRecoveryCheck : bool *
        ?isRestore : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck true
        let _isRestore = defaultArg isRestore false
*)
-> unit

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
Only case for not doing it is when committing a RestoreFrom(String, String, UInt32, DateTime)
isRestore (Optional)
Type: SystemBoolean
Inform session that this is part of a restore
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Compact Method

SessionBaseCompact Method

Overload List
 | Name | Description
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Compact Method

SessionBaseCompact Method

Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Compact()
Public Overridable Sub Compact
public:
virtual void Compact()
abstract Compact : unit -> unit
override Compact : unit -> unit
See Also

Reference

SessionBase Class
Compact Overload
VelocityDb.Session Namespace


SessionBase.Compact Method (Database)

SessionBaseCompact Method (Database)

Reduce size of database, if possible, by truncating file where unused space begins

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Compact(
    Database db
)
Public Overridable Sub Compact (
    db As Database
)
public:
virtual void Compact(
    Database^ db
)
abstract Compact :
        db : Database -> unit
override Compact :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
Database to compact
See Also

Reference

SessionBase Class
Compact Overload
VelocityDb.Session Namespace


SessionBase.CompareTo Method

SessionBaseCompareTo Method

The defualt compare of two SessionBase is by system (bootup) host name and directory

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    SessionBase otherSession
)
Public Function CompareTo (
    otherSession As SessionBase
) As Integer
public:
int CompareTo(
    SessionBase^ otherSession
)
member CompareTo :
        otherSession : SessionBase -> int

Parameters

otherSession
Type: VelocityDb.SessionSessionBase
The session to compare with

Return Value

Type: Int32
-1 if this session is less than the other, 0 if equal, otherwise 1
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ContainsDatabase Method

SessionBaseContainsDatabase Method

Check if database file exist in a given DatabaseLocation

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ContainsDatabase(
    DatabaseLocation location,
    uint dbNum,
    string extension = ".odb"
)
Public Overridable Function ContainsDatabase (
    location As DatabaseLocation,
    dbNum As UInteger,
    Optional extension As String = ".odb"
) As Boolean
public:
virtual bool ContainsDatabase(
    DatabaseLocation^ location,
    unsigned int dbNum,
    String^ extension = L".odb"
)
abstract ContainsDatabase :
        location : DatabaseLocation *
        dbNum : uint32 *
        ?extension : string
(* Defaults:
        let _extension = defaultArg extension ".odb"
*)
-> bool
override ContainsDatabase :
        location : DatabaseLocation *
        dbNum : uint32 *
        ?extension : string
(* Defaults:
        let _extension = defaultArg extension ".odb"
*)
-> bool

Parameters

location
Type: VelocityDbDatabaseLocation
Location to check
dbNum
Type: SystemUInt32
Database number/id
extension (Optional)
Type: SystemString
File name extension/id

Return Value

Type: Boolean
true if exist; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.CopyAllDatabasesTo Method

SessionBaseCopyAllDatabasesTo Method

Copies all databases to a selected directory on the local host.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyAllDatabasesTo(
    string directory,
    bool systemDatabaseLocationOnly = false
)
Public Overridable Sub CopyAllDatabasesTo (
    directory As String,
    Optional systemDatabaseLocationOnly As Boolean = false
)
public:
virtual void CopyAllDatabasesTo(
    String^ directory,
    bool systemDatabaseLocationOnly = false
)
abstract CopyAllDatabasesTo :
        directory : string *
        ?systemDatabaseLocationOnly : bool
(* Defaults:
        let _systemDatabaseLocationOnly = defaultArg systemDatabaseLocationOnly false
*)
-> unit
override CopyAllDatabasesTo :
        directory : string *
        ?systemDatabaseLocationOnly : bool
(* Defaults:
        let _systemDatabaseLocationOnly = defaultArg systemDatabaseLocationOnly false
*)
-> unit

Parameters

directory
Type: SystemString
Path to a directory
systemDatabaseLocationOnly (Optional)
Type: SystemBoolean

[Missing <param name="systemDatabaseLocationOnly"/> documentation for "M:VelocityDb.Session.SessionBase.CopyAllDatabasesTo(System.String,System.Boolean)"]

See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.CreateDirectory Method

SessionBaseCreateDirectory Method

Creates a directory

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CreateDirectory(
    string path
)
Public Overridable Function CreateDirectory (
    path As String
) As Boolean
public:
virtual bool CreateDirectory(
    String^ path
)
abstract CreateDirectory :
        path : string -> bool
override CreateDirectory :
        path : string -> bool

Parameters

path
Type: SystemString

Return Value

Type: Boolean
true if path exist; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.CrossTransactionCache Method

SessionBaseCrossTransactionCache Method

By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void CrossTransactionCache(
    Database db,
    bool enable = true
)
Public Overridable Sub CrossTransactionCache (
    db As Database,
    Optional enable As Boolean = true
)
public:
virtual void CrossTransactionCache(
    Database^ db,
    bool enable = true
)
abstract CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit
override CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit

Parameters

db
Type: VelocityDbDatabase
The Database to cache
enable (Optional)
Type: SystemBoolean
Add or remove strong reference. If true, add a strong reference
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.CrossTransactionCacheAllDatabases Method

SessionBaseCrossTransactionCacheAllDatabases Method

By default databases are referenced by strong references instead of WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to all Databases so the cached Database may be used if version wasn't changed by a different thread since prior transaction. A strong reference is removed for any database that get invalidated due to a transaction abort or if another transaction commits a change to it. Check current session state with StrongReferenceDatabaseCaching

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void CrossTransactionCacheAllDatabases(
    bool enable = true
)
Public Sub CrossTransactionCacheAllDatabases (
    Optional enable As Boolean = true
)
public:
void CrossTransactionCacheAllDatabases(
    bool enable = true
)
member CrossTransactionCacheAllDatabases :
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit

Parameters

enable (Optional)
Type: SystemBoolean
Add or remove strong reference. If true, add a strong reference
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DatabaseNumberOf Method

SessionBaseDatabaseNumberOf Method

Get the database number associated with a specific type. Your application can store any type of object in any database but if the application exclusively use Persist(IOptimizedPersistable, NullableUInt16) or Persist(Object) then this is the database Id that will be used given a type.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint DatabaseNumberOf(
    Type type
)
Public Function DatabaseNumberOf (
    type As Type
) As UInteger
public:
unsigned int DatabaseNumberOf(
    Type^ type
)
member DatabaseNumberOf :
        type : Type -> uint32

Parameters

type
Type: SystemType
The type for which you want to get the associated database number (Id)

Return Value

Type: UInt32
The database number associated with the provided type
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DatabaseStillExist Method

SessionBaseDatabaseStillExist Method

Check if Database still exist

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DatabaseStillExist(
    Database db
)
Public Overridable Function DatabaseStillExist (
    db As Database
) As Boolean
public:
virtual bool DatabaseStillExist(
    Database^ db
)
abstract DatabaseStillExist :
        db : Database -> bool
override DatabaseStillExist :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
Database to check

Return Value

Type: Boolean
true if exists; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DefaultDatabaseLocation Method

SessionBaseDefaultDatabaseLocation Method

Gets the default (startup) DatabaseLocation

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual DatabaseLocation DefaultDatabaseLocation()
Public Overridable Function DefaultDatabaseLocation As DatabaseLocation
public:
virtual DatabaseLocation^ DefaultDatabaseLocation()
abstract DefaultDatabaseLocation : unit -> DatabaseLocation
override DefaultDatabaseLocation : unit -> DatabaseLocation

Return Value

Type: DatabaseLocation
The DatabaseLocation containing at least the system Databases (0.odb, 1.odb, 2.odb, 3.odb and 4.odb)
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeleteDatabase Method

SessionBaseDeleteDatabase Method

Delete a database, actual database file delete happens after a successful transaction commit.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeleteDatabase(
    Database db
)
Public Sub DeleteDatabase (
    db As Database
)
public:
void DeleteDatabase(
    Database^ db
)
member DeleteDatabase :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
The Database to delete
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeleteFile Method

SessionBaseDeleteFile Method

Delete a file. For internal use.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteFile(
    FileInfo fileInfo
)
Public Overridable Sub DeleteFile (
    fileInfo As FileInfo
)
public:
virtual void DeleteFile(
    FileInfo^ fileInfo
)
abstract DeleteFile :
        fileInfo : FileInfo -> unit
override DeleteFile :
        fileInfo : FileInfo -> unit

Parameters

fileInfo
Type: System.IOFileInfo
info about file to delete
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeleteLocation Method

SessionBaseDeleteLocation Method

Deletes a DatabaseLocation, location must first mot have any Databases in it

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteLocation(
    DatabaseLocation location,
    bool catalogOnly = false
)
Public Overridable Sub DeleteLocation (
    location As DatabaseLocation,
    Optional catalogOnly As Boolean = false
)
public:
virtual void DeleteLocation(
    DatabaseLocation^ location,
    bool catalogOnly = false
)
abstract DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit
override DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit

Parameters

location
Type: VelocityDbDatabaseLocation
The DatabaseLocation to delete
catalogOnly (Optional)
Type: SystemBoolean
Of true, only delete catalog entry. Leave the directory as is.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeleteObject Method

SessionBaseDeleteObject Method

A way to delete an object without requiring that the object be opened first

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeleteObject(
    ulong id
)
Public Sub DeleteObject (
    id As ULong
)
public:
void DeleteObject(
    unsigned long long id
)
member DeleteObject :
        id : uint64 -> unit

Parameters

id
Type: SystemUInt64
The Id of the object to delete
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeletePage Method

SessionBaseDeletePage Method

Deletes a page from a database. (part of database Sync beta version - not yet fully designed and tested) Used by SyncWith when syncing databases with another replica of the current databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeletePage(
    Database db,
    Page page
)
Public Sub DeletePage (
    db As Database,
    page As Page
)
public:
void DeletePage(
    Database^ db,
    Page^ page
)
member DeletePage :
        db : Database *
        page : Page -> unit

Parameters

db
Type: VelocityDbDatabase
Database containing page to delete
page
Type: VelocityDbPage
Page to delete
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeployGenerateReaderWriter Method

SessionBaseDeployGenerateReaderWriter Method

Part of code generator, not yet ready for public release

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeployGenerateReaderWriter(
    Type type,
    string directory
)
Public Sub DeployGenerateReaderWriter (
    type As Type,
    directory As String
)
public:
void DeployGenerateReaderWriter(
    Type^ type,
    String^ directory
)
member DeployGenerateReaderWriter :
        type : Type *
        directory : string -> unit

Parameters

type
Type: SystemType
Type to generate reader and writer code for
directory
Type: SystemString
A directory for generated code
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.DeployInternalTypes Method

SessionBaseDeployInternalTypes Method

For internal use only

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void DeployInternalTypes(
    string outputDirectory
)
Public Sub DeployInternalTypes (
    outputDirectory As String
)
public:
void DeployInternalTypes(
    String^ outputDirectory
)
member DeployInternalTypes :
        outputDirectory : string -> unit

Parameters

outputDirectory
Type: SystemString
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Dispose Method

SessionBaseDispose Method

Closes this session

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FileOpen Method

SessionBaseFileOpen Method

Overload List
 | Name | Description
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | Opens a Databasefile for read/update. Internal use only.
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | For internal use.
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FileOpen Method (Database, FileAccess, String, FileMode, Boolean, Int32, Boolean)

SessionBaseFileOpen Method (Database, FileAccess, String, FileMode, Boolean, Int32, Boolean)

Opens a Databasefile for read/update. Internal use only.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Stream FileOpen(
    Database db,
    FileAccess fileAccess,
    ref string errorMessage,
    FileMode fileMode = FileMode.Open,
    bool excusiveAccess = false,
    int waitOverride = -1,
    bool signalError = true
)
Public Overridable Function FileOpen (
    db As Database,
    fileAccess As FileAccess,
    ByRef errorMessage As String,
    Optional fileMode As FileMode = FileMode.Open,
    Optional excusiveAccess As Boolean = false,
    Optional waitOverride As Integer = -1,
    Optional signalError As Boolean = true
) As Stream
public:
virtual Stream^ FileOpen(
    Database^ db,
    FileAccess fileAccess,
    String^% errorMessage,
    FileMode fileMode = FileMode::Open,
    bool excusiveAccess = false,
    int waitOverride = -1,
    bool signalError = true
)
abstract FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride -1
        let _signalError = defaultArg signalError true
*)
-> Stream
override FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride -1
        let _signalError = defaultArg signalError true
*)
-> Stream

Parameters

db
Type: VelocityDbDatabase
Database for which we want to open Stream
fileAccess
Type: System.IOFileAccess
Opening for read or update?
errorMessage
Type: SystemString
Used for passing error messages back to caller
fileMode (Optional)
Type: System.IOFileMode
FileMode used for opening file
excusiveAccess (Optional)
Type: SystemBoolean
Do we want exclusive access to file?
waitOverride (Optional)
Type: SystemInt32
How long are we willing to wait for a file lock to clear?
signalError (Optional)
Type: SystemBoolean
Throw exception if we can't open file within wait time?

Return Value

Type: Stream
A Stream used for accessing Database data
See Also

Reference

SessionBase Class
FileOpen Overload
VelocityDb.Session Namespace


SessionBase.FileOpen Method (FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean)

SessionBaseFileOpen Method (FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean)

For internal use.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Stream FileOpen(
    FileInfo fileInfo,
    FileAccess fileAccess,
    ref string errorMessage,
    FileShare fileShare,
    FileMode fileMode,
    int waitForLockMilliseconds,
    bool useExternalStorage,
    bool signalError = true
)
Public Overridable Function FileOpen (
    fileInfo As FileInfo,
    fileAccess As FileAccess,
    ByRef errorMessage As String,
    fileShare As FileShare,
    fileMode As FileMode,
    waitForLockMilliseconds As Integer,
    useExternalStorage As Boolean,
    Optional signalError As Boolean = true
) As Stream
public:
virtual Stream^ FileOpen(
    FileInfo^ fileInfo,
    FileAccess fileAccess,
    String^% errorMessage,
    FileShare fileShare,
    FileMode fileMode,
    int waitForLockMilliseconds,
    bool useExternalStorage,
    bool signalError = true
)
abstract FileOpen :
        fileInfo : FileInfo *
        fileAccess : FileAccess *
        errorMessage : string byref *
        fileShare : FileShare *
        fileMode : FileMode *
        waitForLockMilliseconds : int *
        useExternalStorage : bool *
        ?signalError : bool
(* Defaults:
        let _signalError = defaultArg signalError true
*)
-> Stream
override FileOpen :
        fileInfo : FileInfo *
        fileAccess : FileAccess *
        errorMessage : string byref *
        fileShare : FileShare *
        fileMode : FileMode *
        waitForLockMilliseconds : int *
        useExternalStorage : bool *
        ?signalError : bool
(* Defaults:
        let _signalError = defaultArg signalError true
*)
-> Stream

Parameters

fileInfo
Type: System.IOFileInfo
Info about file to open
fileAccess
Type: System.IOFileAccess
Option for file access
errorMessage
Type: SystemString
Error messages stored in this string
fileShare
Type: System.IOFileShare
Option for file share
fileMode
Type: System.IOFileMode
Option for file mode
waitForLockMilliseconds
Type: SystemInt32
How long to wait for file to become available for open
useExternalStorage
Type: SystemBoolean
Parameter used for WindowsPhone API for accessing memory cards
signalError (Optional)
Type: SystemBoolean
If true, signal error if we fail to open file; otherwise ignore errors and return null

Return Value

Type: Stream
File stream of opened file
See Also

Reference

SessionBase Class
FileOpen Overload
VelocityDb.Session Namespace


SessionBase.FirstFreePage Method

SessionBaseFirstFreePage Method

Gets the page number of the first unallocated page in the specified Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ushort FirstFreePage(
    Database db,
    ushort pageNumber
)
Public Overridable Function FirstFreePage (
    db As Database,
    pageNumber As UShort
) As UShort
public:
virtual unsigned short FirstFreePage(
    Database^ db,
    unsigned short pageNumber
)
abstract FirstFreePage :
        db : Database *
        pageNumber : uint16 -> uint16
override FirstFreePage :
        db : Database *
        pageNumber : uint16 -> uint16

Parameters

db
Type: VelocityDbDatabase
The database to query
pageNumber
Type: SystemUInt16
The page number to start search from

Return Value

Type: UInt16
The first available page number.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FlushPageOf Method

SessionBaseFlushPageOf Method

By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void FlushPageOf(
    OptimizedPersistable pObj
)
Public Overridable Sub FlushPageOf (
    pObj As OptimizedPersistable
)
public:
virtual void FlushPageOf(
    OptimizedPersistable^ pObj
)
abstract FlushPageOf :
        pObj : OptimizedPersistable -> unit
override FlushPageOf :
        pObj : OptimizedPersistable -> unit

Parameters

pObj
Type: VelocityDbOptimizedPersistable
An object indicating what Page to flush
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FlushUpdates Method

SessionBaseFlushUpdates Method

Overload List
 | Name | Description
Public method | FlushUpdates | Write all updated data. This may free up some memory.
Public method | FlushUpdates(Database) | Write any updated/new pages for a specific Database
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.FlushUpdates Method

SessionBaseFlushUpdates Method

Write all updated data. This may free up some memory.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void FlushUpdates()
Public Overridable Sub FlushUpdates
public:
virtual void FlushUpdates()
abstract FlushUpdates : unit -> unit
override FlushUpdates : unit -> unit
See Also

Reference

SessionBase Class
FlushUpdates Overload
VelocityDb.Session Namespace


SessionBase.FlushUpdates Method (Database)

SessionBaseFlushUpdates Method (Database)

Write any updated/new pages for a specific Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void FlushUpdates(
    Database db
)
Public Sub FlushUpdates (
    db As Database
)
public:
void FlushUpdates(
    Database^ db
)
member FlushUpdates :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
The database for which we want to write all updated pages
See Also

Reference

SessionBase Class
FlushUpdates Overload
VelocityDb.Session Namespace


SessionBase.FlushUpdatesServers Method

SessionBaseFlushUpdatesServers Method

Make servers Write all updated data. This may free up some memory on the servers. Only effects sessions using VelocityDbServer(s)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void FlushUpdatesServers()
Public Overridable Sub FlushUpdatesServers
public:
virtual void FlushUpdatesServers()
abstract FlushUpdatesServers : unit -> unit
override FlushUpdatesServers : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ForceDatabaseCacheValidation Method

SessionBaseForceDatabaseCacheValidation Method

Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ForceDatabaseCacheValidation()
Public Overridable Sub ForceDatabaseCacheValidation
public:
virtual void ForceDatabaseCacheValidation()
abstract ForceDatabaseCacheValidation : unit -> unit
override ForceDatabaseCacheValidation : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.GetEnumerator Method

SessionBaseGetEnumerator Method

Enumerates all open databases for this session

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<Database> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Database)
public:
virtual IEnumerator<Database^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Database>
override GetEnumerator : unit -> IEnumerator<Database>

Return Value

Type: IEnumerator Database
Enumeration of open databases

Implements

IEnumerableTGetEnumerator
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.GetVersion Method

SessionBaseGetVersion Method

Gets the version of Database 0

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetVersion()
Public Function GetVersion As ULong
public:
unsigned long long GetVersion()
member GetVersion : unit -> uint64

Return Value

Type: UInt64
Database 0 version
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.GlobalObjWrapperGet Method

SessionBaseGlobalObjWrapperGet Method

Lookup wrapper object for a non IOptimizedPersistable object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GlobalObjWrapperGet(
    Object lookupObj,
    out IOptimizedPersistable pObj
)
Public Overridable Function GlobalObjWrapperGet (
    lookupObj As Object,
    <OutAttribute> ByRef pObj As IOptimizedPersistable
) As Boolean
public:
virtual bool GlobalObjWrapperGet(
    Object^ lookupObj,
    [OutAttribute] IOptimizedPersistable^% pObj
)
abstract GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool
override GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool

Parameters

lookupObj
Type: SystemObject
object to look for
pObj
Type: VelocityDbIOptimizedPersistable
wrapper object

Return Value

Type: Boolean
Wrapper object
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.HighestInUseDatabaseNumber Method

SessionBaseHighestInUseDatabaseNumber Method

Figure out what the highest in use database number is and return it.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint HighestInUseDatabaseNumber()
Public Function HighestInUseDatabaseNumber As UInteger
public:
unsigned int HighestInUseDatabaseNumber()
member HighestInUseDatabaseNumber : unit -> uint32

Return Value

Type: UInt32
The currently largest Database Id in use reachable from this session
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.HighestInUseLocalDatabaseNumber Method

SessionBaseHighestInUseLocalDatabaseNumber Method

Figure out what the highest in use database number is on the local host and return it.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint HighestInUseLocalDatabaseNumber()
Public Function HighestInUseLocalDatabaseNumber As UInteger
public:
unsigned int HighestInUseLocalDatabaseNumber()
member HighestInUseLocalDatabaseNumber : unit -> uint32

Return Value

Type: UInt32
The currently largest Database Id in use reachable from this session located on localhost
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.IdOf Method

SessionBaseIdOf Method

Finds the object id of a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong IdOf(
    Object obj
)
Public Function IdOf (
    obj As Object
) As ULong
public:
unsigned long long IdOf(
    Object^ obj
)
member IdOf :
        obj : Object -> uint64

Parameters

obj
Type: SystemObject
The object to find the id for

Return Value

Type: UInt64
The object id or 0 if object was not found
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Index Method

SessionBaseIndex Method

Overload List
 | Name | Description
Public method | IndexT | Gets an index of all objects of a certain type
Public method | IndexT(String) | Gets an index of all objects of a certain type
Public method | IndexT(Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used). If you have updated objects persisted in a prior transaction that you want part of an index. Call FlushUpdates or call Write/> to add such an object to index before querying using an index./>
Public method | IndexT(String, Database) | Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used)
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Index(T) Method

SessionBaseIndexT Method

Gets an index of all objects of a certain type

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<T> Index<T>()

Public Function Index(Of T) As BTreeSet(Of T)
public:
generic<typename T>
BTreeSet<T>^ Index()
member Index : unit -> BTreeSet<'T>

Type Parameters

T
The type of object indexed

Return Value

Type: BTreeSet T
The index
See Also

Reference

SessionBase Class
Index Overload
VelocityDb.Session Namespace


SessionBase.Index(T) Method (String)

SessionBaseIndexT Method (String)

Gets an index of all objects of a certain type

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<T> Index<T>(
    string indexedByFieldName
)

Public Function Index(Of T) (
    indexedByFieldName As String
) As BTreeSet(Of T)
public:
generic<typename T>
BTreeSet<T>^ Index(
    String^ indexedByFieldName
)
member Index :
        indexedByFieldName : string -> BTreeSet<'T>

Parameters

indexedByFieldName
Type: SystemString
The field used for sorting the indexed objects

Type Parameters

T
The type of object indexed

Return Value

Type: BTreeSet T
The index
See Also

Reference

SessionBase Class
Index Overload
VelocityDb.Session Namespace


SessionBase.Index(T) Method (Database)

SessionBaseIndexT Method (Database)

Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used). If you have updated objects persisted in a prior transaction that you want part of an index. Call FlushUpdates or call Write/> to add such an object to index before querying using an index./>

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSetOidShort<T> Index<T>(
    Database inDatabase
)

Public Function Index(Of T) (
    inDatabase As Database
) As BTreeSetOidShort(Of T)
public:
generic<typename T>
BTreeSetOidShort<T>^ Index(
    Database^ inDatabase
)
member Index :
        inDatabase : Database -> BTreeSetOidShort<'T>

Parameters

inDatabase
Type: VelocityDbDatabase
Use index as created within this Database

Type Parameters

T
The type of object indexed

Return Value

Type: BTreeSetOidShort T
The index
See Also

Reference

SessionBase Class
Index Overload
VelocityDb.Session Namespace


SessionBase.Index(T) Method (String, Database)

SessionBaseIndexT Method (String, Database)

Gets an index of all objects of a certain type within a given database (attribute OnePerDatabase must be used)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSetOidShort<T> Index<T>(
    string indexedByFieldName,
    Database inDatabase
)

Public Function Index(Of T) (
    indexedByFieldName As String,
    inDatabase As Database
) As BTreeSetOidShort(Of T)
public:
generic<typename T>
BTreeSetOidShort<T>^ Index(
    String^ indexedByFieldName,
    Database^ inDatabase
)
member Index :
        indexedByFieldName : string *
        inDatabase : Database -> BTreeSetOidShort<'T>

Parameters

indexedByFieldName
Type: SystemString
The field used for sorting the indexed objects
inDatabase
Type: VelocityDbDatabase
Database containing index

Type Parameters

T
The type of object indexed

Return Value

Type: BTreeSetOidShort T
The index
See Also

Reference

SessionBase Class
Index Overload
VelocityDb.Session Namespace


SessionBase.InUseNumberOfPages Method

SessionBaseInUseNumberOfPages Method

Gets the number of pages currently in use by a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ushort InUseNumberOfPages(
    Database db
)
Public Overridable Function InUseNumberOfPages (
    db As Database
) As UShort
public:
virtual unsigned short InUseNumberOfPages(
    Database^ db
)
abstract InUseNumberOfPages :
        db : Database -> uint16
override InUseNumberOfPages :
        db : Database -> uint16

Parameters

db
Type: VelocityDbDatabase
The Database to request info about

Return Value

Type: UInt16
The number of pages currently in use
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.IsSameHost Method

SessionBaseIsSameHost Method

Determine if two host names represent the same tcp/ip host

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSameHost(
    string host1,
    string host2
)
Public Shared Function IsSameHost (
    host1 As String,
    host2 As String
) As Boolean
public:
static bool IsSameHost(
    String^ host1,
    String^ host2
)
static member IsSameHost :
        host1 : string *
        host2 : string -> bool

Parameters

host1
Type: SystemString
Host name 1
host2
Type: SystemString
Host name 2

Return Value

Type: Boolean
True if host is the same; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.IsWorkerThread Method

SessionBaseIsWorkerThread Method

Tell if code is executed by index or page write worker thread

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorkerThread()
Public Function IsWorkerThread As Boolean
public:
bool IsWorkerThread()
member IsWorkerThread : unit -> bool

Return Value

Type: Boolean
True, if worker thread is active thread; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.LoadFields Method

SessionBaseLoadFields Method

Loads all field values of an object if they are not already loaded.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void LoadFields(
    IOptimizedPersistable pObj,
    int depth = 2147483647
)
Public Sub LoadFields (
    pObj As IOptimizedPersistable,
    Optional depth As Integer = 2147483647
)
public:
void LoadFields(
    IOptimizedPersistable^ pObj,
    int depth = 2147483647
)
member LoadFields :
        pObj : IOptimizedPersistable *
        ?depth : int
(* Defaults:
        let _depth = defaultArg depth 2147483647
*)
-> unit

Parameters

pObj
Type: VelocityDbIOptimizedPersistable
Persistent object for which to load field values.
depth (Optional)
Type: SystemInt32
Set this if you want to limit the depth of the graph loaded by this open.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.LocateDb Method

SessionBaseLocateDb Method

Lookup the DatabaseLocation of a Database with a specified database number.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation LocateDb(
    uint dbNum
)
Public Function LocateDb (
    dbNum As UInteger
) As DatabaseLocation
public:
DatabaseLocation^ LocateDb(
    unsigned int dbNum
)
member LocateDb :
        dbNum : uint32 -> DatabaseLocation

Parameters

dbNum
Type: SystemUInt32
Database id to look for

Return Value

Type: DatabaseLocation
The current DatabaseLocation containing the requested Database.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.NewDatabase Method

SessionBaseNewDatabase Method

Create a new Database with a given database number

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Database NewDatabase(
    uint dbNum,
    uint megaBytesPresize = 0,
    string name = null,
    bool signalError = true
)
Public Overridable Function NewDatabase (
    dbNum As UInteger,
    Optional megaBytesPresize As UInteger = 0,
    Optional name As String = Nothing,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ NewDatabase(
    unsigned int dbNum,
    unsigned int megaBytesPresize = 0,
    String^ name = nullptr,
    bool signalError = true
)
abstract NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database
override NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
Database number of the database to create
megaBytesPresize (Optional)
Type: SystemUInt32
If you know that the Database will be large, presizing it may avoid file fragmentation. Default value is 0
name (Optional)
Type: SystemString
Optionally name the new Database
signalError (Optional)
Type: SystemBoolean
Optionally signal an error if creation of new Database fails

Return Value

Type: Database
The newly created Database or throws and exception if the Database already exist
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.NewLocation Method

SessionBaseNewLocation Method

Creates a new DatabaseLocation or updates existing ones

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual DatabaseLocation NewLocation(
    DatabaseLocation location
)
Public Overridable Function NewLocation (
    location As DatabaseLocation
) As DatabaseLocation
public:
virtual DatabaseLocation^ NewLocation(
    DatabaseLocation^ location
)
abstract NewLocation :
        location : DatabaseLocation -> DatabaseLocation
override NewLocation :
        location : DatabaseLocation -> DatabaseLocation

Parameters

location
Type: VelocityDbDatabaseLocation
The input location

Return Value

Type: DatabaseLocation
The new DatabaseLocation or an existing one
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Objects(T) Method

SessionBaseObjectsT Method

Enumerates all the objects of a given type

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> Objects<T>()
where T : OptimizedPersistable

Public Function Objects(Of T As OptimizedPersistable) As IEnumerator(Of T)
public:
generic<typename T>
where T : OptimizedPersistable
IEnumerator<T>^ Objects()
member Objects : unit -> IEnumerator<'T>  when 'T : OptimizedPersistable

Type Parameters

T
The type of object we are looking for

Return Value

Type: IEnumerator T
An enumeration of type T
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OfType Method

SessionBaseOfType Method

Gets an object used for enumerating all objects in all Databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public OfType OfType(
    Type type,
    bool includeSubclasses = true,
    bool databasePerType = true
)
Public Function OfType (
    type As Type,
    Optional includeSubclasses As Boolean = true,
    Optional databasePerType As Boolean = true
) As OfType
public:
OfType^ OfType(
    Type^ type,
    bool includeSubclasses = true,
    bool databasePerType = true
)
member OfType :
        type : Type *
        ?includeSubclasses : bool *
        ?databasePerType : bool
(* Defaults:
        let _includeSubclasses = defaultArg includeSubclasses true
        let _databasePerType = defaultArg databasePerType true
*)
-> OfType

Parameters

type
Type: SystemType
Type to look for
includeSubclasses (Optional)
Type: SystemBoolean
Also return instances of sub classes or classes that implements the specified interface class
databasePerType (Optional)
Type: SystemBoolean
Assume that persisted objects where made persistent the simple way using Persist(IOptimizedPersistable, NullableUInt16). When persisting this way, each object type gets its own Database which makes finding these objects easier and faster

Return Value

Type: OfType
The enumeration wrapper OfType(Type, Boolean, Boolean)object
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OidOf Method

SessionBaseOidOf Method

Finds the object id of a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Oid OidOf(
    Object obj
)
Public Function OidOf (
    obj As Object
) As Oid
public:
Oid OidOf(
    Object^ obj
)
member OidOf :
        obj : Object -> Oid

Parameters

obj
Type: SystemObject
The object to find the id for

Return Value

Type: Oid
The object id or 0 if object was not found
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OidShortOf Method

SessionBaseOidShortOf Method

Finds the object id of a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint OidShortOf(
    Object obj
)
Public Function OidShortOf (
    obj As Object
) As UInteger
public:
unsigned int OidShortOf(
    Object^ obj
)
member OidShortOf :
        obj : Object -> uint32

Parameters

obj
Type: SystemObject
The object to find the id for

Return Value

Type: UInt32
The object id or 0 if object was not found
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenAllDatabases Method

SessionBaseOpenAllDatabases Method

Open all databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Database> OpenAllDatabases(
    bool update = false
)
Public Overridable Function OpenAllDatabases (
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenAllDatabases(
    bool update = false
)
abstract OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

update (Optional)
Type: SystemBoolean
Open for update?

Return Value

Type: List Database
List of Database
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenDatabase Method

SessionBaseOpenDatabase Method

Opens a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Database OpenDatabase(
    uint dbNum,
    bool update = false,
    bool signalError = true
)
Public Overridable Function OpenDatabase (
    dbNum As UInteger,
    Optional update As Boolean = false,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ OpenDatabase(
    unsigned int dbNum,
    bool update = false,
    bool signalError = true
)
abstract OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database
override OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
The Database number of the database to open
update (Optional)
Type: SystemBoolean
Open the Database for update?
signalError (Optional)
Type: SystemBoolean
Signal errors if errors found when opening the Database?

Return Value

Type: Database
The opened Database
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenDatabaseLocations Method

SessionBaseOpenDatabaseLocations Method

Open the DatabaseLocations object and store it in the session.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocations OpenDatabaseLocations()
Public Function OpenDatabaseLocations As DatabaseLocations
public:
DatabaseLocations^ OpenDatabaseLocations()
member OpenDatabaseLocations : unit -> DatabaseLocations

Return Value

Type: DatabaseLocations
The DatabaseLocations used by this session
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenLocationDatabases Method

SessionBaseOpenLocationDatabases Method

Opens all the databases in a given location

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual List<Database> OpenLocationDatabases(
    DatabaseLocation location,
    bool update = false
)
Public Overridable Function OpenLocationDatabases (
    location As DatabaseLocation,
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenLocationDatabases(
    DatabaseLocation^ location,
    bool update = false
)
abstract OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

location
Type: VelocityDbDatabaseLocation
The location for which to open databases
update (Optional)
Type: SystemBoolean
Shall each database be opened for update?

Return Value

Type: List Database
A list of opened databases
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenPage Method

SessionBaseOpenPage Method

Opens a page for read, used by DatabaseManager for page browsing

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Page OpenPage(
    Database db,
    ushort pageNumber,
    bool stubOnly = false
)
Public Function OpenPage (
    db As Database,
    pageNumber As UShort,
    Optional stubOnly As Boolean = false
) As Page
public:
Page^ OpenPage(
    Database^ db,
    unsigned short pageNumber,
    bool stubOnly = false
)
member OpenPage :
        db : Database *
        pageNumber : uint16 *
        ?stubOnly : bool
(* Defaults:
        let _stubOnly = defaultArg stubOnly false
*)
-> Page

Parameters

db
Type: VelocityDbDatabase
Database containing the requested page
pageNumber
Type: SystemUInt16
Page number of the requested page
stubOnly (Optional)
Type: SystemBoolean
Open page but don't retrieve slot bytes? (lazy load)

Return Value

Type: Page
The requested page
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.OpenSchema Method

SessionBaseOpenSchema Method

Get the session active schema

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Schema OpenSchema(
    bool update
)
Public Overridable Function OpenSchema (
    update As Boolean
) As Schema
public:
virtual Schema^ OpenSchema(
    bool update
)
abstract OpenSchema :
        update : bool -> Schema
override OpenSchema :
        update : bool -> Schema

Parameters

update
Type: SystemBoolean
Do update the schema?

Return Value

Type: Schema
The active schema
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ParseCsvRow Method

SessionBaseParseCsvRow Method

Parses a row in a csv file and returns an iterator of column string values

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerator<string> ParseCsvRow(
    string r
)
Public Shared Function ParseCsvRow (
    r As String
) As IEnumerator(Of String)
public:
static IEnumerator<String^>^ ParseCsvRow(
    String^ r
)
static member ParseCsvRow :
        r : string -> IEnumerator<string>

Parameters

r
Type: SystemString
Csv row string data to be parsed

Return Value

Type: IEnumerator String
Iterator of column values
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Persist Method

SessionBasePersist Method

Overload List
 | Name | Description
Public method | Persist(Object) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database.
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.
Public method | Persist(Placement, IOptimizedPersistable) | Persist an object that is an OptimizedPersistable or a subclass
Public method | Persist(Object, IOptimizedPersistable, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Object, Placement, Boolean) | Persist an object that may or may not be a subclass of OptimizedPersistable
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Persist Method (Object)

SessionBasePersist Method (Object)

This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Persist(
    Object obj
)
Public Function Persist (
    obj As Object
) As ULong
public:
unsigned long long Persist(
    Object^ obj
)
member Persist :
        obj : Object -> uint64

Parameters

obj
Type: SystemObject
The object to make persistent

Return Value

Type: UInt64
The Id of the persisted object
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.Persist Method (IOptimizedPersistable, Nullable(UInt16))

SessionBasePersist Method (IOptimizedPersistable, NullableUInt16)

This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ulong Persist(
    IOptimizedPersistable ipObj,
    Nullable<ushort> objectsPerPage = null
)
Public Overridable Function Persist (
    ipObj As IOptimizedPersistable,
    Optional objectsPerPage As Nullable(Of UShort) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    IOptimizedPersistable^ ipObj,
    Nullable<unsigned short> objectsPerPage = nullptr
)
abstract Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64
override Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64

Parameters

ipObj
Type: VelocityDbIOptimizedPersistable
The object to make persistent
objectsPerPage (Optional)
Type: SystemNullable UInt16
Override of objects per page, only respected when persisting first object of some type

Return Value

Type: UInt64
The Id of the persisted object
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.Persist Method (Placement, IOptimizedPersistable)

SessionBasePersist Method (Placement, IOptimizedPersistable)

Persist an object that is an OptimizedPersistable or a subclass

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Persist(
    Placement place,
    IOptimizedPersistable obj
)
Public Function Persist (
    place As Placement,
    obj As IOptimizedPersistable
) As ULong
public:
unsigned long long Persist(
    Placement^ place,
    IOptimizedPersistable^ obj
)
member Persist :
        place : Placement *
        obj : IOptimizedPersistable -> uint64

Parameters

place
Type: VelocityDbPlacement
Provides placement guidance
obj
Type: VelocityDbIOptimizedPersistable
The object to persist

Return Value

Type: UInt64
The Id of the persistent object
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.Persist Method (Object, IOptimizedPersistable, Boolean)

SessionBasePersist Method (Object, IOptimizedPersistable, Boolean)

Persist an object that may or may not be a subclass of OptimizedPersistable

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Persist(
    Object obj,
    IOptimizedPersistable parent,
    bool inFlush = false
)
Public Function Persist (
    obj As Object,
    parent As IOptimizedPersistable,
    Optional inFlush As Boolean = false
) As ULong
public:
unsigned long long Persist(
    Object^ obj,
    IOptimizedPersistable^ parent,
    bool inFlush = false
)
member Persist :
        obj : Object *
        parent : IOptimizedPersistable *
        ?inFlush : bool
(* Defaults:
        let _inFlush = defaultArg inFlush false
*)
-> uint64

Parameters

obj
Type: SystemObject
The object to persist.
parent
Type: VelocityDbIOptimizedPersistable
A parent object of the object to persist.
inFlush (Optional)
Type: SystemBoolean
If true, disallow page flushing

Return Value

Type: UInt64
The Id of the persisted object.
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.Persist Method (Object, Placement, Boolean)

SessionBasePersist Method (Object, Placement, Boolean)

Persist an object that may or may not be a subclass of OptimizedPersistable

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Persist(
    Object obj,
    Placement place,
    bool inFlush = false
)
Public Function Persist (
    obj As Object,
    place As Placement,
    Optional inFlush As Boolean = false
) As ULong
public:
unsigned long long Persist(
    Object^ obj,
    Placement^ place,
    bool inFlush = false
)
member Persist :
        obj : Object *
        place : Placement *
        ?inFlush : bool
(* Defaults:
        let _inFlush = defaultArg inFlush false
*)
-> uint64

Parameters

obj
Type: SystemObject
The object to persist.
place
Type: VelocityDbPlacement
A placement guidance
inFlush (Optional)
Type: SystemBoolean
If true, disallow page flushing

Return Value

Type: UInt64
The Id of the persisted object.
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.Persist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, Queue(IOptimizedPersistable))

SessionBasePersist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable)

Persists an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual ulong Persist(
    Placement place,
    IOptimizedPersistable pObj,
    Schema schema,
    ushort slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overridable Function Persist (
    place As Placement,
    pObj As IOptimizedPersistable,
    schema As Schema,
    Optional slotLimitPerPage As UShort = 0,
    Optional inFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    IOptimizedPersistable^ pObj,
    Schema^ schema,
    unsigned short slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
)
abstract Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
Placement object determining where to persist the object
pObj
Type: VelocityDbIOptimizedPersistable
The object to persist
schema
Type: VelocityDb.TypeInfoSchema
The active session schema
slotLimitPerPage (Optional)
Type: SystemUInt16
Override of how many slots per page to permit
inFlush (Optional)
Type: SystemBoolean
Set to true to disallow page flushes as a side affect
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A list of objects waiting to be persisted

Return Value

Type: UInt64
Id of persisted object
See Also

Reference

SessionBase Class
Persist Overload
VelocityDb.Session Namespace


SessionBase.PossiblyFlushUpdatedPages Method

SessionBasePossiblyFlushUpdatedPages Method

Call this function if you may have updated many pages to possibly free up memory if too much memory is in use.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void PossiblyFlushUpdatedPages(
    uint numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
)
Public Overridable Sub PossiblyFlushUpdatedPages (
    Optional numberOfUpdatedPagesPermittedWithoutFlushCheck As UInteger = 100
)
public:
virtual void PossiblyFlushUpdatedPages(
    unsigned int numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
)
abstract PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit
override PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit

Parameters

numberOfUpdatedPagesPermittedWithoutFlushCheck (Optional)
Type: SystemUInt32
Only do check if the number of updated pages is greater than this number
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.RegisterClass Method

SessionBaseRegisterClass Method

Register a class in the persistent schema. It is a good idea to do this explicitly instead of having it happen the first time an object of an unregistered class is made persistent

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion RegisterClass(
    Type type
)
Public Function RegisterClass (
    type As Type
) As TypeVersion
public:
TypeVersion^ RegisterClass(
    Type^ type
)
member RegisterClass :
        type : Type -> TypeVersion

Parameters

type
Type: SystemType
The type to register in the persistent schema

Return Value

Type: TypeVersion
TypeVersion corresponding to type registered
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.RelocateDatabaseLocationFor Method

SessionBaseRelocateDatabaseLocationFor Method

After moving/copying directory containing your Database with id dbId call this before starting a transaction to update host and directory of the associated DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation RelocateDatabaseLocationFor(
    uint dbId,
    string hostName,
    string directory
)
Public Function RelocateDatabaseLocationFor (
    dbId As UInteger,
    hostName As String,
    directory As String
) As DatabaseLocation
public:
DatabaseLocation^ RelocateDatabaseLocationFor(
    unsigned int dbId,
    String^ hostName,
    String^ directory
)
member RelocateDatabaseLocationFor :
        dbId : uint32 *
        hostName : string *
        directory : string -> DatabaseLocation

Parameters

dbId
Type: SystemUInt32
Id of one of the Databases in location being relocated
hostName
Type: SystemString
New host name
directory
Type: SystemString
New directory path

Return Value

Type: DatabaseLocation
Updated DatabaseLocation
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.RelocateDefaultDatabaseLocation Method

SessionBaseRelocateDefaultDatabaseLocation Method

After moving/copying directory containing your Databases 0.odb, 1.odb ... call this before starting a transaction to update host and directory of the default DatabaseLocation. This function does not move the database files, it only updates the DatabaseLocation.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DatabaseLocation RelocateDefaultDatabaseLocation()
Public Function RelocateDefaultDatabaseLocation As DatabaseLocation
public:
DatabaseLocation^ RelocateDefaultDatabaseLocation()
member RelocateDefaultDatabaseLocation : unit -> DatabaseLocation

Return Value

Type: DatabaseLocation
The default DatabaseLocation
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ReplacePage Method

SessionBaseReplacePage Method

Only to be used in VelocityDbExtensions while syncing databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReplacePage(
    Database databaseToUpdate,
    Page pageToUpdate,
    Page pageToRead
)
Public Overridable Sub ReplacePage (
    databaseToUpdate As Database,
    pageToUpdate As Page,
    pageToRead As Page
)
public:
virtual void ReplacePage(
    Database^ databaseToUpdate,
    Page^ pageToUpdate,
    Page^ pageToRead
)
abstract ReplacePage :
        databaseToUpdate : Database *
        pageToUpdate : Page *
        pageToRead : Page -> unit
override ReplacePage :
        databaseToUpdate : Database *
        pageToUpdate : Page *
        pageToRead : Page -> unit

Parameters

databaseToUpdate
Type: VelocityDbDatabase
Database being synced
pageToUpdate
Type: VelocityDbPage
Page to sync
pageToRead
Type: VelocityDbPage
Page to sync from
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ReplacePersistedType Method

SessionBaseReplacePersistedType Method

Overload List
 | Name | Description
Public method | ReplacePersistedType(String, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Public method | ReplacePersistedType(Type, Type) | Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.ReplacePersistedType Method (String, Type)

SessionBaseReplacePersistedType Method (String, Type)

Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool ReplacePersistedType(
    string oldTypeFullAssemblyName,
    Type newType
)
Public Function ReplacePersistedType (
    oldTypeFullAssemblyName As String,
    newType As Type
) As Boolean
public:
bool ReplacePersistedType(
    String^ oldTypeFullAssemblyName,
    Type^ newType
)
member ReplacePersistedType :
        oldTypeFullAssemblyName : string *
        newType : Type -> bool

Parameters

oldTypeFullAssemblyName
Type: SystemString
The assembly qualified name of the Type currently used within the Schema
newType
Type: SystemType
The Type you want to replace with in the Schema. This new Type must NOT already be part of the schema.

Return Value

Type: Boolean
true if old type name was found; otherwise false
See Also

Reference

SessionBase Class
ReplacePersistedType Overload
VelocityDb.Session Namespace


SessionBase.ReplacePersistedType Method (Type, Type)

SessionBaseReplacePersistedType Method (Type, Type)

Updates the Type assocuiated with a VelocityDbType. This can be used when you want to rename a class or move a class to a different namespace. You will need to have the prior Type loaded as it it is defined in the current Schema for this to work. Once the update has been done, you should no longer need to keep the old Type loaded. Be sure to backup all your data before doing this.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ReplacePersistedType(
    Type oldType,
    Type newType
)
Public Sub ReplacePersistedType (
    oldType As Type,
    newType As Type
)
public:
void ReplacePersistedType(
    Type^ oldType,
    Type^ newType
)
member ReplacePersistedType :
        oldType : Type *
        newType : Type -> unit

Parameters

oldType
Type: SystemType
The Type currently used within the Schema
newType
Type: SystemType
The Type you want to replace with in the Schema. This new Type must NOT already be part of the schema.
See Also

Reference

SessionBase Class
ReplacePersistedType Overload
VelocityDb.Session Namespace


SessionBase.RestoreFrom Method

SessionBaseRestoreFrom Method

Overload List
 | Name | Description
Public method | RestoreFrom(DatabaseLocation, DateTime) | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.
Public method | RestoreFrom(String, String, UInt32, DateTime) | Restores a DatabaseLocation
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.RestoreFrom Method (DatabaseLocation, DateTime)

SessionBaseRestoreFrom Method (DatabaseLocation, DateTime)

Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreFrom(
    DatabaseLocation backupLocation,
    DateTime upToTime
)
Public Overridable Sub RestoreFrom (
    backupLocation As DatabaseLocation,
    upToTime As DateTime
)
public:
virtual void RestoreFrom(
    DatabaseLocation^ backupLocation,
    DateTime upToTime
)
abstract RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit
override RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit

Parameters

backupLocation
Type: VelocityDbDatabaseLocation
The location to restore from
upToTime
Type: SystemDateTime
Restore location up to a given DateTime. Data backed up after this time will not be restored.
See Also

Reference

SessionBase Class
RestoreFrom Overload
VelocityDb.Session Namespace


SessionBase.RestoreFrom Method (String, String, UInt32, DateTime)

SessionBaseRestoreFrom Method (String, String, UInt32, DateTime)

Restores a DatabaseLocation

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreFrom(
    string host,
    string path,
    uint backupDbNum,
    DateTime upToTime
)
Public Overridable Sub RestoreFrom (
    host As String,
    path As String,
    backupDbNum As UInteger,
    upToTime As DateTime
)
public:
virtual void RestoreFrom(
    String^ host,
    String^ path,
    unsigned int backupDbNum,
    DateTime upToTime
)
abstract RestoreFrom :
        host : string *
        path : string *
        backupDbNum : uint32 *
        upToTime : DateTime -> unit
override RestoreFrom :
        host : string *
        path : string *
        backupDbNum : uint32 *
        upToTime : DateTime -> unit

Parameters

host
Type: SystemString
Host name of backup
path
Type: SystemString
Directory path to backup
backupDbNum
Type: SystemUInt32
Initial database number used by backup DatabaseLocation
upToTime
Type: SystemDateTime
Restore data up to this time
See Also

Reference

SessionBase Class
RestoreFrom Overload
VelocityDb.Session Namespace


SessionBase.SetMinMaxStringIntern Method

SessionBaseSetMinMaxStringIntern Method

A persistent string read into memory from a Database is interned using Intern(String) to speed up comparisons and conserve memory (when the same string occurs in many places)

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void SetMinMaxStringIntern(
    ushort minSize,
    ushort maxSize
)
Public Shared Sub SetMinMaxStringIntern (
    minSize As UShort,
    maxSize As UShort
)
public:
static void SetMinMaxStringIntern(
    unsigned short minSize,
    unsigned short maxSize
)
static member SetMinMaxStringIntern :
        minSize : uint16 *
        maxSize : uint16 -> unit

Parameters

minSize
Type: SystemUInt16
Selected minimum plus one string length of a string to be interned
maxSize
Type: SystemUInt16
Selected maximum string length for a string to be interned
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.SetTraceAllDbActivity Method

SessionBaseSetTraceAllDbActivity Method

Enable some console output about persistent events related to all databases and pages.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetTraceAllDbActivity(
    bool enable = true
)
Public Sub SetTraceAllDbActivity (
    Optional enable As Boolean = true
)
public:
void SetTraceAllDbActivity(
    bool enable = true
)
member SetTraceAllDbActivity :
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit

Parameters

enable (Optional)
Type: SystemBoolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.SetTraceDbActivity Method

SessionBaseSetTraceDbActivity Method

Enable some console output about persistent events related to a Database.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetTraceDbActivity(
    uint dbId
)
Public Sub SetTraceDbActivity (
    dbId As UInteger
)
public:
void SetTraceDbActivity(
    unsigned int dbId
)
member SetTraceDbActivity :
        dbId : uint32 -> unit

Parameters

dbId
Type: SystemUInt32
The Database number of the Database to enable persistent trace information for.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.StringToType Method

SessionBaseStringToType Method

Gets a Type given a string representation of a type

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Type StringToType(
    string typeAsString
)
Public Shared Function StringToType (
    typeAsString As String
) As Type
public:
static Type^ StringToType(
    String^ typeAsString
)
static member StringToType :
        typeAsString : string -> Type

Parameters

typeAsString
Type: SystemString
The string representation of a Type

Return Value

Type: Type
Type from string
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.SubscribeToChanges Method

SessionBaseSubscribeToChanges Method

Subscribe to committed database changes of instances of a type when an an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void SubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overridable Sub SubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void SubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
)
abstract SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a Boolean property. When property returns true, a change notification is send otherwise no notification is send. Leave as null to get a notification any time any instance of the selected type changes
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.TryDatabase Method

SessionBaseTryDatabase Method

Gets the current database to try

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Database TryDatabase(
    Placement place
)
Public Function TryDatabase (
    place As Placement
) As Database
public:
Database^ TryDatabase(
    Placement^ place
)
member TryDatabase :
        place : Placement -> Database

Parameters

place
Type: VelocityDbPlacement
the placement object to retrieve from

Return Value

Type: Database
A database or null if not cached
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Unpersist Method

SessionBaseUnpersist Method

Use this when you want to delete objects that are not assignable as IOptimizedPersistable

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Unpersist(
    Object obj
)
Public Overridable Function Unpersist (
    obj As Object
) As Boolean
public:
virtual bool Unpersist(
    Object^ obj
)
abstract Unpersist :
        obj : Object -> bool
override Unpersist :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to be deleted from persistent storage

Return Value

Type: Boolean
true if object found and deleted; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UnsubscribeToChanges Method

SessionBaseUnsubscribeToChanges Method

Unsubscribe to committed database changes of instances of a type when an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnsubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overridable Sub UnsubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void UnsubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
)
abstract UnsubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override UnsubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are no longer interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a Boolean property.
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UpdateClass Method

SessionBaseUpdateClass Method

Let VelocityDB know that changes have been made to a class so that the schema manager will create a new TypeVersion and use the new version for all new objects of the specified Type.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion UpdateClass(
    Type type
)
Public Function UpdateClass (
    type As Type
) As TypeVersion
public:
TypeVersion^ UpdateClass(
    Type^ type
)
member UpdateClass :
        type : Type -> TypeVersion

Parameters

type
Type: SystemType
The type that has been updated (new/removed/modified fields)

Return Value

Type: TypeVersion
The new Type description
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UpdateDatabase Method

SessionBaseUpdateDatabase Method

Request an update lock on a database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateDatabase(
    Database db
)
Public Overridable Function UpdateDatabase (
    db As Database
) As Boolean
public:
virtual bool UpdateDatabase(
    Database^ db
)
abstract UpdateDatabase :
        db : Database -> bool
override UpdateDatabase :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database to update

Return Value

Type: Boolean
true if Database was updated, otherwise throws an exception
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UpdateObject Method

SessionBaseUpdateObject Method

Overload List
 | Name | Description
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(IOptimizedPersistable) | Tag an object as updated so that it will be updated persistently
Public method | UpdateObject(Object, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Action) | Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.UpdateObject Method (Object)

SessionBaseUpdateObject Method (Object)

Tag an object as updated so that it will be updated persistently

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateObject(
    Object obj
)
Public Overridable Function UpdateObject (
    obj As Object
) As Boolean
public:
virtual bool UpdateObject(
    Object^ obj
)
abstract UpdateObject :
        obj : Object -> bool
override UpdateObject :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to update.

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

SessionBase Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionBase.UpdateObject Method (IOptimizedPersistable)

SessionBaseUpdateObject Method (IOptimizedPersistable)

Tag an object as updated so that it will be updated persistently

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateObject(
    IOptimizedPersistable obj
)
Public Overridable Function UpdateObject (
    obj As IOptimizedPersistable
) As Boolean
public:
virtual bool UpdateObject(
    IOptimizedPersistable^ obj
)
abstract UpdateObject :
        obj : IOptimizedPersistable -> bool
override UpdateObject :
        obj : IOptimizedPersistable -> bool

Parameters

obj
Type: VelocityDbIOptimizedPersistable
The object to update.

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

SessionBase Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionBase.UpdateObject Method (Object, Action)

SessionBaseUpdateObject Method (Object, Action)

Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateObject(
    Object obj,
    Action codeBlock
)
Public Overridable Function UpdateObject (
    obj As Object,
    codeBlock As Action
) As Boolean
public:
virtual bool UpdateObject(
    Object^ obj,
    Action^ codeBlock
)
abstract UpdateObject :
        obj : Object *
        codeBlock : Action -> bool
override UpdateObject :
        obj : Object *
        codeBlock : Action -> bool

Parameters

obj
Type: SystemObject
Object to update
codeBlock
Type: SystemAction
Block of code doing actual update to the object

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

SessionBase Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionBase.UpdateObject Method (IOptimizedPersistable, Action)

SessionBaseUpdateObject Method (IOptimizedPersistable, Action)

Provides a way to update an object in a multi thraeded scenario where we must make sure that object page isn't flushed until updates to object are done.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateObject(
    IOptimizedPersistable obj,
    Action codeBlock
)
Public Overridable Function UpdateObject (
    obj As IOptimizedPersistable,
    codeBlock As Action
) As Boolean
public:
virtual bool UpdateObject(
    IOptimizedPersistable^ obj,
    Action^ codeBlock
)
abstract UpdateObject :
        obj : IOptimizedPersistable *
        codeBlock : Action -> bool
override UpdateObject :
        obj : IOptimizedPersistable *
        codeBlock : Action -> bool

Parameters

obj
Type: VelocityDbIOptimizedPersistable
Object to update
codeBlock
Type: SystemAction
Block of code doing actual update to the object

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

SessionBase Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionBase.UpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

SessionBaseUpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

Updates an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateObject(
    IOptimizedPersistable obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
)
Public Overridable Function UpdateObject (
    obj As IOptimizedPersistable,
    inFlush As Boolean,
    Optional deleteObjFromIndexes As Boolean = true
) As Boolean
public:
virtual bool UpdateObject(
    IOptimizedPersistable^ obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
)
abstract UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool
override UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool

Parameters

obj
Type: VelocityDbIOptimizedPersistable
Object to be updated
inFlush
Type: SystemBoolean
Are we doing this as part of a page flush? Set to true to avoid a recursive page flush
deleteObjFromIndexes (Optional)
Type: SystemBoolean
Set to false if you know that this object is not part of any index. Safe to leave set to true in any case

Return Value

Type: Boolean
True if object is updated; otherwise false
See Also

Reference

SessionBase Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionBase.UpdatePage Method

SessionBaseUpdatePage Method

Update a Page. Used by VelocityDBExtensions project

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool UpdatePage(
    ref Page page
)
Public Function UpdatePage (
    ByRef page As Page
) As Boolean
public:
bool UpdatePage(
    Page^% page
)
member UpdatePage :
        page : Page byref -> bool

Parameters

page
Type: VelocityDbPage
Page to update

Return Value

Type: Boolean
true if updated OK; otherwise false
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Verify Method

SessionBaseVerify Method

Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Verify()
Public Overridable Sub Verify
public:
virtual void Verify()
abstract Verify : unit -> unit
override Verify : unit -> unit
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.WaitForIndexUpdates Method

SessionBaseWaitForIndexUpdates Method

Internal Use and in VelocityDBExtensions

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void WaitForIndexUpdates(
    bool throwIfError = true
)
Public Sub WaitForIndexUpdates (
    Optional throwIfError As Boolean = true
)
public:
void WaitForIndexUpdates(
    bool throwIfError = true
)
member WaitForIndexUpdates :
        ?throwIfError : bool
(* Defaults:
        let _throwIfError = defaultArg throwIfError true
*)
-> unit

Parameters

throwIfError (Optional)
Type: SystemBoolean
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase Fields

The SessionBase type exposes the following members.

Fields
Name | Description
Assembly |
IndexDescriptorDatabaseNumber | Database 3 is dedicated to keeping track of index usage
s_serverTcpIpPortNumber | By default port number 7031 is used for communication with VelocityDBServer. Change the value here and also in VelocityDbServer.exe.config if you need to use a different port number.
s_typeDatabaseIdOffsetFromTypeShortId | Determines database Id to use for a certain VelocityDbType instance
s_typeDatabaseIdOverflowIndexCollisionOffset | If additional databases are required for storing instances of some index, start by attempting creating database at this offset from original
s_typeDatabaseIdOverflowOffset | If additional databases are required for storing instances of some type, start by attempting creating database at this offset from original
Top
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Assembly Field

SessionBaseAssembly Field

[Missing <summary> documentation for "F:VelocityDb.Session.SessionBase.Assembly"]

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Assembly Assembly
Public Shared ReadOnly Assembly As Assembly
public:
static initonly Assembly^ Assembly
static val Assembly: Assembly

Field Value

Type: Assembly
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.IndexDescriptorDatabaseNumber Field

SessionBaseIndexDescriptorDatabaseNumber Field

Database 3 is dedicated to keeping track of index usage

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint IndexDescriptorDatabaseNumber = 3
Public Const IndexDescriptorDatabaseNumber As UInteger = 3
public:
literal unsigned int IndexDescriptorDatabaseNumber = 3
static val mutable IndexDescriptorDatabaseNumber: uint32

Field Value

Type: UInt32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.s_serverTcpIpPortNumber Field

SessionBases_serverTcpIpPortNumber Field

By default port number 7031 is used for communication with VelocityDBServer. Change the value here and also in VelocityDbServer.exe.config if you need to use a different port number.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int s_serverTcpIpPortNumber
Public Shared s_serverTcpIpPortNumber As Integer
public:
static int s_serverTcpIpPortNumber
static val mutable s_serverTcpIpPortNumber: int

Field Value

Type: Int32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.s_typeDatabaseIdOffsetFromTypeShortId Field

SessionBases_typeDatabaseIdOffsetFromTypeShortId Field

Determines database Id to use for a certain VelocityDbType instance

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly int s_typeDatabaseIdOffsetFromTypeShortId
Public Shared ReadOnly s_typeDatabaseIdOffsetFromTypeShortId As Integer
public:
static initonly int s_typeDatabaseIdOffsetFromTypeShortId
static val s_typeDatabaseIdOffsetFromTypeShortId: int

Field Value

Type: Int32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.s_typeDatabaseIdOverflowIndexCollisionOffset Field

SessionBases_typeDatabaseIdOverflowIndexCollisionOffset Field

If additional databases are required for storing instances of some index, start by attempting creating database at this offset from original

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly uint s_typeDatabaseIdOverflowIndexCollisionOffset
Public Shared ReadOnly s_typeDatabaseIdOverflowIndexCollisionOffset As UInteger
public:
static initonly unsigned int s_typeDatabaseIdOverflowIndexCollisionOffset
static val s_typeDatabaseIdOverflowIndexCollisionOffset: uint32

Field Value

Type: UInt32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.s_typeDatabaseIdOverflowOffset Field

SessionBases_typeDatabaseIdOverflowOffset Field

If additional databases are required for storing instances of some type, start by attempting creating database at this offset from original

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly uint s_typeDatabaseIdOverflowOffset
Public Shared ReadOnly s_typeDatabaseIdOverflowOffset As UInteger
public:
static initonly unsigned int s_typeDatabaseIdOverflowOffset
static val s_typeDatabaseIdOverflowOffset: uint32

Field Value

Type: UInt32
See Also

Reference

SessionBase Class
VelocityDb.Session Namespace


SessionBase.Transaction Class

SessionBaseTransaction Class

Helper object to enable automatic rollback/abort of transaction if transaction isn't committed within it's scope.
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBaseTransaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Transaction : IDisposable
Public Class Transaction
    Implements IDisposable
public ref class Transaction : IDisposable
type Transaction =
    class
        interface IDisposable
    end

The SessionBaseTransaction type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the active transaction
Public method | Dispose | If in update transaction; rollback (abort) transaction. If in read only transaction; commit transaction.
Public method | Rollback | Aborts the current transaction and rolls it back. Same as Abort
Top
See Also

Reference

VelocityDb.Session Namespace


Transaction Methods

The SessionBaseTransaction type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the active transaction
Public method | Dispose | If in update transaction; rollback (abort) transaction. If in read only transaction; commit transaction.
Public method | Rollback | Aborts the current transaction and rolls it back. Same as Abort
Top
See Also

Reference

SessionBaseTransaction Class
VelocityDb.Session Namespace


SessionBase.Transaction.Commit Method

SessionBaseTransactionCommit Method

Commits the active transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Commit()
Public Sub Commit
public:
void Commit()
member Commit : unit -> unit
See Also

Reference

SessionBaseTransaction Class
VelocityDb.Session Namespace


SessionBase.Transaction.Dispose Method

SessionBaseTransactionDispose Method

If in update transaction; rollback (abort) transaction. If in read only transaction; commit transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SessionBaseTransaction Class
VelocityDb.Session Namespace


SessionBase.Transaction.Rollback Method

SessionBaseTransactionRollback Method

Aborts the current transaction and rolls it back. Same as Abort

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Rollback()
Public Sub Rollback
public:
void Rollback()
member Rollback : unit -> unit
See Also

Reference

SessionBaseTransaction Class
VelocityDb.Session Namespace


SessionNoServer Class

Use this session class when Database level locking is acceptable and Databases are local or reachable by UNC paths.
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionSessionNoServer
VelocityDb.SessionSessionNoServerShared
VelocityDBExtensions2AzureSession

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class SessionNoServer : SessionBase,
    IDisposable
Public Class SessionNoServer
    Inherits SessionBase
    Implements IDisposable
public ref class SessionNoServer : public SessionBase,
    IDisposable
type SessionNoServer =
    class
        inherit SessionBase
        interface IDisposable
    end

The SessionNoServer type exposes the following members.

Constructors
 | Name | Description
Public method | SessionNoServer | Creates a new session. For a thread safe version of this class, use SessionNoServerShared
Top
Properties
 | Name | Description
Public property | AssumeLocalHost | SessionNoServer ignores DatabaseLocation HostName since it cannot connect to a VelocityDbServer. (Overrides SessionBaseAssumeLocalHost.)
Top
Methods
 | Name | Description
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionBaseUpdateDatabase(Database).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDb.Session Namespace


SessionNoServer Constructor

Creates a new session. For a thread safe version of this class, use SessionNoServerShared

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionNoServer(
    string systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes,
    bool enableDatabaseCache = true
)
Public Sub New (
    systemDir As String,
    Optional waitForLockMilliseconds As Integer = 5000,
    Optional optimisticLocking As Boolean = true,
    Optional enablePageCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes,
    Optional enableDatabaseCache As Boolean = true
)
public:
SessionNoServer(
    String^ systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes,
    bool enableDatabaseCache = true
)
new :
        systemDir : string *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?enablePageCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum *
        ?enableDatabaseCache : bool
(* Defaults:
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 5000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _enablePageCache = defaultArg enablePageCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
        let _enableDatabaseCache = defaultArg enableDatabaseCache true
*)
-> SessionNoServer

Parameters

systemDir
Type: SystemString
The startup location directory path. Path can be an absolute (full) path or a path relative to s_baseDatabasePath
waitForLockMilliseconds (Optional)
Type: SystemInt32
The desired maximum lock wait time
optimisticLocking (Optional)
Type: SystemBoolean
Use optimistic locking. With optimistic locking, readers are always permitted and multiple updaters are permitted to update the same Databases/Pages but only the first transaction to commit or flush an updated Database/Page will be successful in making the commited chane. Other updaters will get an OptimisticLockingException if they try to commit/flush updates to the same Pages/Database. See http://en.wikipedia.org/wiki/Optimistic_concurrency_control for further explanation of optimistic locking. If optimistic locking is not enabled then pessimistic locking is used. See: http://en.wikipedia.org/wiki/Concurrency_control
enablePageCache (Optional)
Type: SystemBoolean
If strong reference page caching isn't desired, turn it off by setting to false
objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum
Determines default value of Cache
enableDatabaseCache (Optional)
Type: SystemBoolean
Is this session going to enable strong reference Database caching?
See Also

Reference

SessionNoServer Class
VelocityDb.Session Namespace


SessionNoServer Properties

The SessionNoServer type exposes the following members.

Properties
 | Name | Description
Public property | AssumeLocalHost | SessionNoServer ignores DatabaseLocation HostName since it cannot connect to a VelocityDbServer. (Overrides SessionBaseAssumeLocalHost.)
Top
See Also

Reference

SessionNoServer Class
VelocityDb.Session Namespace


SessionNoServer.AssumeLocalHost Property

SessionNoServerAssumeLocalHost Property

SessionNoServer ignores DatabaseLocation HostName since it cannot connect to a VelocityDbServer.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AssumeLocalHost { get; }
Public Overrides ReadOnly Property AssumeLocalHost As Boolean
    Get
public:
virtual property bool AssumeLocalHost {
    bool get () override;
}
abstract AssumeLocalHost : bool with get
override AssumeLocalHost : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionNoServer Class
VelocityDb.Session Namespace


SessionNoServer Methods

The SessionNoServer type exposes the following members.

Methods
 | Name | Description
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionBaseUpdateDatabase(Database).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

SessionNoServer Class
VelocityDb.Session Namespace


SessionNoServer.UpdateDatabase Method

SessionNoServerUpdateDatabase Method

Request an update lock on a database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateDatabase(
    Database db
)
Public Overrides Function UpdateDatabase (
    db As Database
) As Boolean
public:
virtual bool UpdateDatabase(
    Database^ db
) override
abstract UpdateDatabase :
        db : Database -> bool
override UpdateDatabase :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database to update

Return Value

Type: Boolean
true if Database was updated, otherwise throws an exception
See Also

Reference

SessionNoServer Class
VelocityDb.Session Namespace


SessionNoServerShared Class

Same as SessionNoServer but SessionNoServerShared is thread safe so it can be shared between threads.
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionSessionNoServer
VelocityDb.SessionSessionNoServerShared

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class SessionNoServerShared : SessionNoServer,
    IDisposable
Public Class SessionNoServerShared
    Inherits SessionNoServer
    Implements IDisposable
public ref class SessionNoServerShared : public SessionNoServer,
    IDisposable
type SessionNoServerShared =
    class
        inherit SessionNoServer
        interface IDisposable
    end

The SessionNoServerShared type exposes the following members.

Constructors
 | Name | Description
Public method | SessionNoServerShared | Creates a new session. For a thread safe version of this class, use SessionNoServerShared
Top
Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Allow adding objects to indices to be done in a worker thread instead of in main thread. (Overrides SessionBaseAddToIndexInSeperateThread.)
Public property | Databases | Gets a list of the currently opened databases (Overrides SessionBaseDatabases.)
Public property | WriteToDiskInSeperateDatabaseThreads | Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work. (Overrides SessionBaseWriteToDiskInSeperateDatabaseThreads.)
Top
Methods
 | Name | Description
Public method | Abort | Transaction control, abort the current transaction (Overrides SessionBaseAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides SessionBaseBeginRead(Boolean).)
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides SessionBaseBeginUpdate(Boolean).)
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate (Overrides SessionBaseCheckpoint.)
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now. (Overrides SessionBaseClearCache.)
Public method | ClearCashedPages | Clear cache of cached pages (Overrides SessionBaseClearCashedPages.)
Public method | ClearPageCache | Clears cached pages from cache including page weak references. (Overrides SessionBaseClearPageCache.)
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides SessionBaseCopyAllDatabasesTo(String, Boolean).)
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened. (Overrides SessionBaseCrossTransactionCache(Database, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides SessionBaseDeleteLocation(DatabaseLocation, Boolean).)
Public method | FileOpen | Opens a Databasefile for read/update. Internal use only. (Overrides SessionBaseFileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean).)
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written. (Overrides SessionBaseFlushPageOf(OptimizedPersistable).)
Public method | FlushUpdates | Write all updated data. This may free up some memory. (Overrides SessionBaseFlushUpdates.)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction. (Overrides SessionBaseForceDatabaseCacheValidation.)
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object (Overrides SessionBaseGlobalObjWrapperGet(Object, IOptimizedPersistable).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides SessionBaseNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides SessionBaseNewLocation(DatabaseLocation).)
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Public method | OpenAllDatabases | Open all databases (Overrides SessionBaseOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides SessionBaseOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides SessionBaseOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | OpenSchema | Get the session active schema (Overrides SessionBaseOpenSchema(Boolean).)
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use. (Overrides SessionBasePossiblyFlushUpdatedPages(UInt32).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides SessionBaseRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an an optional property evaluates to true. (Overrides SessionBaseSubscribeToChanges(Type, String).)
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable (Overrides SessionBaseUnpersist(Object).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionNoServerUpdateDatabase(Database).)
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found. (Overrides SessionBaseVerify.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDb.Session Namespace


SessionNoServerShared Constructor

Creates a new session. For a thread safe version of this class, use SessionNoServerShared

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionNoServerShared(
    string systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes,
    bool enableDatabaseCache = true
)
Public Sub New (
    systemDir As String,
    Optional waitForLockMilliseconds As Integer = 5000,
    Optional optimisticLocking As Boolean = true,
    Optional enablePageCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes,
    Optional enableDatabaseCache As Boolean = true
)
public:
SessionNoServerShared(
    String^ systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enablePageCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes,
    bool enableDatabaseCache = true
)
new :
        systemDir : string *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?enablePageCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum *
        ?enableDatabaseCache : bool
(* Defaults:
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 5000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _enablePageCache = defaultArg enablePageCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
        let _enableDatabaseCache = defaultArg enableDatabaseCache true
*)
-> SessionNoServerShared

Parameters

systemDir
Type: SystemString
The startup location directory path. Path can be an absolute (full) path or a path relative to s_baseDatabasePath
waitForLockMilliseconds (Optional)
Type: SystemInt32
The desired maximum lock wait time
optimisticLocking (Optional)
Type: SystemBoolean
Use optimistic locking. With optimistic locking, readers are always permitted and multiple updaters are permitted to update the same Databases/Pages but only the first transaction to commit or flush an updated Database/Page will be successful in making the commited chane. Other updaters will get an OptimisticLockingException if they try to commit/flush updates to the same Pages/Database. See http://en.wikipedia.org/wiki/Optimistic_concurrency_control for further explanation of optimistic locking. If optimistic locking is not enabled then pessimistic locking is used. See: http://en.wikipedia.org/wiki/Concurrency_control
enablePageCache (Optional)
Type: SystemBoolean
If strong reference page caching isn't desired, turn it off by setting to false
objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum
Determines default value of Cache
enableDatabaseCache (Optional)
Type: SystemBoolean
Is this session going to enable strong reference Database caching?
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared Properties

The SessionNoServerShared type exposes the following members.

Properties
 | Name | Description
Public property | AddToIndexInSeperateThread | Allow adding objects to indices to be done in a worker thread instead of in main thread. (Overrides SessionBaseAddToIndexInSeperateThread.)
Public property | Databases | Gets a list of the currently opened databases (Overrides SessionBaseDatabases.)
Public property | WriteToDiskInSeperateDatabaseThreads | Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work. (Overrides SessionBaseWriteToDiskInSeperateDatabaseThreads.)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.AddToIndexInSeperateThread Property

SessionNoServerSharedAddToIndexInSeperateThread Property

Allow adding objects to indices to be done in a worker thread instead of in main thread.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AddToIndexInSeperateThread { get; set; }
Public Overrides Property AddToIndexInSeperateThread As Boolean
    Get
    Set
public:
virtual property bool AddToIndexInSeperateThread {
    bool get () override;
    void set (bool value) override;
}
abstract AddToIndexInSeperateThread : bool with get, set
override AddToIndexInSeperateThread : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Databases Property

SessionNoServerSharedDatabases Property

Gets a list of the currently opened databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IList<Database> Databases { get; }
Public Overrides ReadOnly Property Databases As IList(Of Database)
    Get
public:
virtual property IList<Database^>^ Databases {
    IList<Database^>^ get () override;
}
abstract Databases : IList<Database> with get
override Databases : IList<Database> with get

Property Value

Type: IList Database
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.WriteToDiskInSeperateDatabaseThreads Property

SessionNoServerSharedWriteToDiskInSeperateDatabaseThreads Property

Allow object serialization and page writes to happen in worker threads, one per database, instead of in main session thread. AddToIndexInSeperateThread must also be enabled for this to work.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool WriteToDiskInSeperateDatabaseThreads { get; set; }
Public Overrides Property WriteToDiskInSeperateDatabaseThreads As Boolean
    Get
    Set
public:
virtual property bool WriteToDiskInSeperateDatabaseThreads {
    bool get () override;
    void set (bool value) override;
}
abstract WriteToDiskInSeperateDatabaseThreads : bool with get, set
override WriteToDiskInSeperateDatabaseThreads : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared Methods

The SessionNoServerShared type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Transaction control, abort the current transaction (Overrides SessionBaseAbort.)
Public method | BeginRead | Transaction control, begin a read only transaction (Overrides SessionBaseBeginRead(Boolean).)
Public method | BeginUpdate | Transaction control, begin an update transaction. (Overrides SessionBaseBeginUpdate(Boolean).)
Public method | Checkpoint | Same as Commit(Boolean, Boolean) followed by BeginUpdate (Overrides SessionBaseCheckpoint.)
Public method | ClearCache | Clears page cache and closes databases. Avoid using this one for now. (Overrides SessionBaseClearCache.)
Public method | ClearCashedPages | Clear cache of cached pages (Overrides SessionBaseClearCashedPages.)
Public method | ClearPageCache | Clears cached pages from cache including page weak references. (Overrides SessionBaseClearPageCache.)
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Public method | CopyAllDatabasesTo | Copies all databases to a selected directory on the local host. (Overrides SessionBaseCopyAllDatabasesTo(String, Boolean).)
Public method | CrossTransactionCache | By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened. (Overrides SessionBaseCrossTransactionCache(Database, Boolean).)
Public method | DeleteLocation | Deletes a DatabaseLocation, location must first mot have any Databases in it (Overrides SessionBaseDeleteLocation(DatabaseLocation, Boolean).)
Public method | FileOpen | Opens a Databasefile for read/update. Internal use only. (Overrides SessionBaseFileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean).)
Public method | FlushPageOf | By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written. (Overrides SessionBaseFlushPageOf(OptimizedPersistable).)
Public method | FlushUpdates | Write all updated data. This may free up some memory. (Overrides SessionBaseFlushUpdates.)
Public method | ForceDatabaseCacheValidation | Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction. (Overrides SessionBaseForceDatabaseCacheValidation.)
Public method | GlobalObjWrapperGet | Lookup wrapper object for a non IOptimizedPersistable object (Overrides SessionBaseGlobalObjWrapperGet(Object, IOptimizedPersistable).)
Public method | NewDatabase | Create a new Database with a given database number (Overrides SessionBaseNewDatabase(UInt32, UInt32, String, Boolean).)
Public method | NewLocation | Creates a new DatabaseLocation or updates existing ones (Overrides SessionBaseNewLocation(DatabaseLocation).)
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Public method | OpenAllDatabases | Open all databases (Overrides SessionBaseOpenAllDatabases(Boolean).)
Public method | OpenDatabase | Opens a Database (Overrides SessionBaseOpenDatabase(UInt32, Boolean, Boolean).)
Public method | OpenLocationDatabases | Opens all the databases in a given location (Overrides SessionBaseOpenLocationDatabases(DatabaseLocation, Boolean).)
Public method | OpenSchema | Get the session active schema (Overrides SessionBaseOpenSchema(Boolean).)
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Public method | PossiblyFlushUpdatedPages | Call this function if you may have updated many pages to possibly free up memory if too much memory is in use. (Overrides SessionBasePossiblyFlushUpdatedPages(UInt32).)
Public method | RestoreFrom | Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore. (Overrides SessionBaseRestoreFrom(DatabaseLocation, DateTime).)
Public method | SubscribeToChanges | Subscribe to committed database changes of instances of a type when an an optional property evaluates to true. (Overrides SessionBaseSubscribeToChanges(Type, String).)
Public method | Unpersist | Use this when you want to delete objects that are not assignable as IOptimizedPersistable (Overrides SessionBaseUnpersist(Object).)
Public method | UpdateDatabase | Request an update lock on a database (Overrides SessionNoServerUpdateDatabase(Database).)
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Public method | Verify | Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found. (Overrides SessionBaseVerify.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Abort Method

SessionNoServerSharedAbort Method

Transaction control, abort the current transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Abort()
Public Overrides Sub Abort
public:
virtual void Abort() override
abstract Abort : unit -> unit
override Abort : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.BeginRead Method

SessionNoServerSharedBeginRead Method

Transaction control, begin a read only transaction

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginRead(
    bool doRecoveryCheck = false
)
Public Overrides Function BeginRead (
    Optional doRecoveryCheck As Boolean = false
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginRead(
    bool doRecoveryCheck = false
) override
abstract BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction
override BeginRead :
        ?doRecoveryCheck : bool
(* Defaults:
        let _doRecoveryCheck = defaultArg doRecoveryCheck false
*)
-> SessionBaseTransaction

Parameters

doRecoveryCheck (Optional)
Type: SystemBoolean
By default we do not check for a failed update transaction that requires reverting one or more database changes. We don't do it by default because it can be a little costly. Change this parameter to true if you prefer ensured consistency over better performance or make change only if you encounter an exception in the transaction.

Return Value

Type: SessionBaseTransaction
A transaction helper object.
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.BeginUpdate Method

SessionNoServerSharedBeginUpdate Method

Transaction control, begin an update transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction BeginUpdate(
    bool doRecoveryCheck
)
Public Overrides Function BeginUpdate (
    doRecoveryCheck As Boolean
) As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ BeginUpdate(
    bool doRecoveryCheck
) override
abstract BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction
override BeginUpdate :
        doRecoveryCheck : bool -> SessionBaseTransaction

Parameters

doRecoveryCheck
Type: SystemBoolean
Set to false only when moving system databases to a new directory

Return Value

Type: SessionBaseTransaction
A SessionBaseTransaction helper object.
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Checkpoint Method

SessionNoServerSharedCheckpoint Method

Same as Commit(Boolean, Boolean) followed by BeginUpdate

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SessionBaseTransaction Checkpoint()
Public Overrides Function Checkpoint As SessionBaseTransaction
public:
virtual SessionBaseTransaction^ Checkpoint() override
abstract Checkpoint : unit -> SessionBaseTransaction
override Checkpoint : unit -> SessionBaseTransaction

Return Value

Type: SessionBaseTransaction
SessionBaseTransaction started
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.ClearCache Method

SessionNoServerSharedClearCache Method

Clears page cache and closes databases. Avoid using this one for now.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearCache()
Public Overrides Sub ClearCache
public:
virtual void ClearCache() override
abstract ClearCache : unit -> unit
override ClearCache : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.ClearCashedPages Method

SessionNoServerSharedClearCashedPages Method

Clear cache of cached pages

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearCashedPages()
Public Overrides Sub ClearCashedPages
public:
virtual void ClearCashedPages() override
abstract ClearCashedPages : unit -> unit
override ClearCashedPages : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.ClearPageCache Method

SessionNoServerSharedClearPageCache Method

Clears cached pages from cache including page weak references.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ClearPageCache()
Public Overrides Sub ClearPageCache
public:
virtual void ClearPageCache() override
abstract ClearPageCache : unit -> unit
override ClearPageCache : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Compact Method

SessionNoServerSharedCompact Method

Overload List
 | Name | Description
Public method | Compact | Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction. (Overrides SessionBaseCompact.)
Public method | Compact(Database) | Reduce size of database, if possible, by truncating file where unused space begins (Overrides SessionBaseCompact(Database).)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Compact Method

SessionNoServerSharedCompact Method

Reduce size of databases, if possible, by first attempting to relocate pages to free areas towards the beginning of each Database file and then by truncating files where unused space begins. Run Compact() outside the scope of any transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact()
Public Overrides Sub Compact
public:
virtual void Compact() override
abstract Compact : unit -> unit
override Compact : unit -> unit
See Also

Reference

SessionNoServerShared Class
Compact Overload
VelocityDb.Session Namespace


SessionNoServerShared.Compact Method (Database)

SessionNoServerSharedCompact Method (Database)

Reduce size of database, if possible, by truncating file where unused space begins

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Compact(
    Database db
)
Public Overrides Sub Compact (
    db As Database
)
public:
virtual void Compact(
    Database^ db
) override
abstract Compact :
        db : Database -> unit
override Compact :
        db : Database -> unit

Parameters

db
Type: VelocityDbDatabase
Database to compact
See Also

Reference

SessionNoServerShared Class
Compact Overload
VelocityDb.Session Namespace


SessionNoServerShared.CopyAllDatabasesTo Method

SessionNoServerSharedCopyAllDatabasesTo Method

Copies all databases to a selected directory on the local host.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void CopyAllDatabasesTo(
    string directory,
    bool systemDatabaseLocationOnly
)
Public Overrides Sub CopyAllDatabasesTo (
    directory As String,
    systemDatabaseLocationOnly As Boolean
)
public:
virtual void CopyAllDatabasesTo(
    String^ directory,
    bool systemDatabaseLocationOnly
) override
abstract CopyAllDatabasesTo :
        directory : string *
        systemDatabaseLocationOnly : bool -> unit
override CopyAllDatabasesTo :
        directory : string *
        systemDatabaseLocationOnly : bool -> unit

Parameters

directory
Type: SystemString
Path to a directory
systemDatabaseLocationOnly
Type: SystemBoolean

[Missing <param name="systemDatabaseLocationOnly"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.CopyAllDatabasesTo(System.String,System.Boolean)"]

See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.CrossTransactionCache Method

SessionNoServerSharedCrossTransactionCache Method

By default databases are only referenced by a WeakReference across transaction boundaries. This means that such Database may or may not be available as a cached database depending on garbage collection activity and if such database also has a strong reference. This function lets you add a strong reference to a Database so the cached Database may be used if version wasn't changed by a different thread since prior transaction. The strong reference is removed once the Database is reopened.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void CrossTransactionCache(
    Database db,
    bool enable = true
)
Public Overrides Sub CrossTransactionCache (
    db As Database,
    Optional enable As Boolean = true
)
public:
virtual void CrossTransactionCache(
    Database^ db,
    bool enable = true
) override
abstract CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit
override CrossTransactionCache :
        db : Database *
        ?enable : bool
(* Defaults:
        let _enable = defaultArg enable true
*)
-> unit

Parameters

db
Type: VelocityDbDatabase
The Database to cache
enable (Optional)
Type: SystemBoolean
Add or remove strong reference. If true, add a strong reference
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.DeleteLocation Method

SessionNoServerSharedDeleteLocation Method

Deletes a DatabaseLocation, location must first mot have any Databases in it

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void DeleteLocation(
    DatabaseLocation location,
    bool catalogOnly = false
)
Public Overrides Sub DeleteLocation (
    location As DatabaseLocation,
    Optional catalogOnly As Boolean = false
)
public:
virtual void DeleteLocation(
    DatabaseLocation^ location,
    bool catalogOnly = false
) override
abstract DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit
override DeleteLocation :
        location : DatabaseLocation *
        ?catalogOnly : bool
(* Defaults:
        let _catalogOnly = defaultArg catalogOnly false
*)
-> unit

Parameters

location
Type: VelocityDbDatabaseLocation
The DatabaseLocation to delete
catalogOnly (Optional)
Type: SystemBoolean
Of true, only delete catalog entry. Leave the directory as is.
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.FileOpen Method

SessionNoServerSharedFileOpen Method

Opens a Databasefile for read/update. Internal use only.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Stream FileOpen(
    Database db,
    FileAccess fileAccess,
    ref string errorMessage,
    FileMode fileMode = FileMode.Open,
    bool excusiveAccess = false,
    int waitOverride = 0,
    bool signalError = true
)
Public Overrides Function FileOpen (
    db As Database,
    fileAccess As FileAccess,
    ByRef errorMessage As String,
    Optional fileMode As FileMode = FileMode.Open,
    Optional excusiveAccess As Boolean = false,
    Optional waitOverride As Integer = 0,
    Optional signalError As Boolean = true
) As Stream
public:
virtual Stream^ FileOpen(
    Database^ db,
    FileAccess fileAccess,
    String^% errorMessage,
    FileMode fileMode = FileMode::Open,
    bool excusiveAccess = false,
    int waitOverride = 0,
    bool signalError = true
) override
abstract FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride 0
        let _signalError = defaultArg signalError true
*)
-> Stream
override FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride 0
        let _signalError = defaultArg signalError true
*)
-> Stream

Parameters

db
Type: VelocityDbDatabase
Database for which we want to open Stream
fileAccess
Type: System.IOFileAccess
Opening for read or update?
errorMessage
Type: SystemString
Used for passing error messages back to caller
fileMode (Optional)
Type: System.IOFileMode
FileMode used for opening file
excusiveAccess (Optional)
Type: SystemBoolean
Do we want exclusive access to file?
waitOverride (Optional)
Type: SystemInt32
How long are we willing to wait for a file lock to clear?
signalError (Optional)
Type: SystemBoolean
Throw exception if we can't open file within wait time?

Return Value

Type: Stream
A Stream used for accessing Database data
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.FlushPageOf Method

SessionNoServerSharedFlushPageOf Method

By calling this you force a persisted (has an Id) object to be written to disk (if updated) and indices (if any) to be updated. Other objects on the same page page will also be written.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushPageOf(
    OptimizedPersistable pObj
)
Public Overrides Sub FlushPageOf (
    pObj As OptimizedPersistable
)
public:
virtual void FlushPageOf(
    OptimizedPersistable^ pObj
) override
abstract FlushPageOf :
        pObj : OptimizedPersistable -> unit
override FlushPageOf :
        pObj : OptimizedPersistable -> unit

Parameters

pObj
Type: VelocityDbOptimizedPersistable
An object indicating what Page to flush
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.FlushUpdates Method

SessionNoServerSharedFlushUpdates Method

Write all updated data. This may free up some memory.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void FlushUpdates()
Public Overrides Sub FlushUpdates
public:
virtual void FlushUpdates() override
abstract FlushUpdates : unit -> unit
override FlushUpdates : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.ForceDatabaseCacheValidation Method

SessionNoServerSharedForceDatabaseCacheValidation Method

Cached data is set to be validated whenever a new transaction is started. This function is provided as a way to force cache validation within a transaction without requiring a commit followed by a new transaction.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ForceDatabaseCacheValidation()
Public Overrides Sub ForceDatabaseCacheValidation
public:
virtual void ForceDatabaseCacheValidation() override
abstract ForceDatabaseCacheValidation : unit -> unit
override ForceDatabaseCacheValidation : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.GlobalObjWrapperGet Method

SessionNoServerSharedGlobalObjWrapperGet Method

Lookup wrapper object for a non IOptimizedPersistable object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool GlobalObjWrapperGet(
    Object lookupObj,
    out IOptimizedPersistable pObj
)
Public Overrides Function GlobalObjWrapperGet (
    lookupObj As Object,
    <OutAttribute> ByRef pObj As IOptimizedPersistable
) As Boolean
public:
virtual bool GlobalObjWrapperGet(
    Object^ lookupObj,
    [OutAttribute] IOptimizedPersistable^% pObj
) override
abstract GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool
override GlobalObjWrapperGet :
        lookupObj : Object *
        pObj : IOptimizedPersistable byref -> bool

Parameters

lookupObj
Type: SystemObject
object to look for
pObj
Type: VelocityDbIOptimizedPersistable
wrapper object

Return Value

Type: Boolean
Wrapper object
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.NewDatabase Method

SessionNoServerSharedNewDatabase Method

Create a new Database with a given database number

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database NewDatabase(
    uint dbNum,
    uint megaBytesPresize = 0,
    string name = null,
    bool signalError = true
)
Public Overrides Function NewDatabase (
    dbNum As UInteger,
    Optional megaBytesPresize As UInteger = 0,
    Optional name As String = Nothing,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ NewDatabase(
    unsigned int dbNum,
    unsigned int megaBytesPresize = 0,
    String^ name = nullptr,
    bool signalError = true
) override
abstract NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database
override NewDatabase :
        dbNum : uint32 *
        ?megaBytesPresize : uint32 *
        ?name : string *
        ?signalError : bool
(* Defaults:
        let _megaBytesPresize = defaultArg megaBytesPresize 0
        let _name = defaultArg name null
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
Database number of the database to create
megaBytesPresize (Optional)
Type: SystemUInt32
If you know that the Database will be large, presizing it may avoid file fragmentation. Default value is 0
name (Optional)
Type: SystemString
Optionally name the new Database
signalError (Optional)
Type: SystemBoolean
Optionally signal an error if creation of new Database fails

Return Value

Type: Database
The newly created Database or throws and exception if the Database already exist
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.NewLocation Method

SessionNoServerSharedNewLocation Method

Creates a new DatabaseLocation or updates existing ones

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override DatabaseLocation NewLocation(
    DatabaseLocation location
)
Public Overrides Function NewLocation (
    location As DatabaseLocation
) As DatabaseLocation
public:
virtual DatabaseLocation^ NewLocation(
    DatabaseLocation^ location
) override
abstract NewLocation :
        location : DatabaseLocation -> DatabaseLocation
override NewLocation :
        location : DatabaseLocation -> DatabaseLocation

Parameters

location
Type: VelocityDbDatabaseLocation
The input location

Return Value

Type: DatabaseLocation
The new DatabaseLocation or an existing one
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Open Method

SessionNoServerSharedOpen Method

Overload List
 | Name | Description
Public method | Open(UInt64, Boolean, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt64, Boolean, Boolean, Int32).)
Public method | Open(UInt32, UInt16, UInt16, Boolean, Int32) | Opens a persistent object (Overrides SessionBase.Open(UInt32, UInt16, UInt16, Boolean, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32) | For internal usage only, used in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32).)
Public method | Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean) | For internal use only in generated code (Overrides SessionBase.Open(Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean).)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Open Method (UInt64, Boolean, Boolean, Int32)

SessionNoServerSharedOpen Method (UInt64, Boolean, Boolean, Int32)

Opens a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Open(
    ulong oid,
    bool update,
    bool inFlush,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    oid As ULong,
    update As Boolean,
    inFlush As Boolean,
    Optional graphDepthToLoad As Integer = 2147483647
) As Object
public:
virtual Object^ Open(
    unsigned long long oid,
    bool update,
    bool inFlush,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        oid : uint64 *
        update : bool *
        inFlush : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> Object
override Open :
        oid : uint64 *
        update : bool *
        inFlush : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> Object

Parameters

oid
Type: SystemUInt64
The Id of the object to open
update
Type: SystemBoolean
Open the object for update?
inFlush
Type: SystemBoolean
if true, disallow page flushing while opening the object
graphDepthToLoad (Optional)
Type: SystemInt32
Set this if you want to limit the depth of the graph loaded by this open.

Return Value

Type: Object
A persistent object
See Also

Reference

SessionNoServerShared Class
Open Overload
VelocityDb.Session Namespace


SessionNoServerShared.Open Method (UInt32, UInt16, UInt16, Boolean, Int32)

SessionNoServerSharedOpen Method (UInt32, UInt16, UInt16, Boolean, Int32)

Opens a persistent object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    uint dbNum,
    ushort pageNum,
    ushort slotNum,
    bool update,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    dbNum As UInteger,
    pageNum As UShort,
    slotNum As UShort,
    update As Boolean,
    Optional graphDepthToLoad As Integer = 2147483647
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    unsigned int dbNum,
    unsigned short pageNum,
    unsigned short slotNum,
    bool update,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        dbNum : uint32 *
        pageNum : uint16 *
        slotNum : uint16 *
        update : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable
override Open :
        dbNum : uint32 *
        pageNum : uint16 *
        slotNum : uint16 *
        update : bool *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable

Parameters

dbNum
Type: SystemUInt32
Database number of the object to open
pageNum
Type: SystemUInt16
Page number of the object to open
slotNum
Type: SystemUInt16
Slot number of the object to open
update
Type: SystemBoolean
Open the object for update?
graphDepthToLoad (Optional)
Type: SystemInt32
Limit depth of graph to open

Return Value

Type: IOptimizedPersistable
The opened object or null if it does not exist
See Also

Reference

SessionNoServerShared Class
Open Overload
VelocityDb.Session Namespace


SessionNoServerShared.Open Method (Database, UInt64, Boolean, List(IOptimizedPersistable), Boolean, Int32, Int32)

SessionNoServerSharedOpen Method (Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32)

For internal usage only, used in generated code

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    Database db,
    ulong oid,
    bool update,
    List<IOptimizedPersistable> toLoadMembers,
    bool inFlush,
    int graphDepth = 0,
    int graphDepthToLoad = 2147483647
)
Public Overrides Function Open (
    db As Database,
    oid As ULong,
    update As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    inFlush As Boolean,
    Optional graphDepth As Integer = 0,
    Optional graphDepthToLoad As Integer = 2147483647
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    Database^ db,
    unsigned long long oid,
    bool update,
    List<IOptimizedPersistable^>^ toLoadMembers,
    bool inFlush,
    int graphDepth = 0,
    int graphDepthToLoad = 2147483647
) override
abstract Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        ?graphDepth : int *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepth = defaultArg graphDepth 0
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable
override Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        ?graphDepth : int *
        ?graphDepthToLoad : int
(* Defaults:
        let _graphDepth = defaultArg graphDepth 0
        let _graphDepthToLoad = defaultArg graphDepthToLoad 2147483647
*)
-> IOptimizedPersistable

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

oid
Type: SystemUInt64

[Missing <param name="oid"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

update
Type: SystemBoolean

[Missing <param name="update"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

inFlush
Type: SystemBoolean

[Missing <param name="inFlush"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

graphDepth (Optional)
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

graphDepthToLoad (Optional)
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

Return Value

Type: IOptimizedPersistable

[Missing <returns> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32)"]

See Also

Reference

SessionNoServerShared Class
Open Overload
VelocityDb.Session Namespace


SessionNoServerShared.Open Method (Database, UInt64, Boolean, List(IOptimizedPersistable), Boolean, Int32, Int32, Boolean)

SessionNoServerSharedOpen Method (Database, UInt64, Boolean, ListIOptimizedPersistable, Boolean, Int32, Int32, Boolean)

For internal use only in generated code

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IOptimizedPersistable Open(
    Database db,
    ulong oid,
    bool update,
    List<IOptimizedPersistable> toLoadMembers,
    bool inFlush,
    int graphDepth,
    int graphDepthToLoad,
    bool signalNotExistError = false
)
Public Overrides Function Open (
    db As Database,
    oid As ULong,
    update As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    inFlush As Boolean,
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    Optional signalNotExistError As Boolean = false
) As IOptimizedPersistable
public:
virtual IOptimizedPersistable^ Open(
    Database^ db,
    unsigned long long oid,
    bool update,
    List<IOptimizedPersistable^>^ toLoadMembers,
    bool inFlush,
    int graphDepth,
    int graphDepthToLoad,
    bool signalNotExistError = false
) override
abstract Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        graphDepth : int *
        graphDepthToLoad : int *
        ?signalNotExistError : bool
(* Defaults:
        let _signalNotExistError = defaultArg signalNotExistError false
*)
-> IOptimizedPersistable
override Open :
        db : Database *
        oid : uint64 *
        update : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        inFlush : bool *
        graphDepth : int *
        graphDepthToLoad : int *
        ?signalNotExistError : bool
(* Defaults:
        let _signalNotExistError = defaultArg signalNotExistError false
*)
-> IOptimizedPersistable

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDb.Session.SessionNoServerShared.Open(VelocityDb.Database,System.UInt64,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Boolean,System.Int32,System.Int32,System.Boolean)"]

oid
Type: SystemUInt64
Id of the object to open, must match with Database id
update
Type: SystemBoolean
Update object when opening it
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
Internal list of objects to be loaded as part of graph load
inFlush
Type: SystemBoolean
Permit page flushes as side affect of opening object?
graphDepth
Type: SystemInt32
Current graph depth of graph load
graphDepthToLoad
Type: SystemInt32
Max graph depth to load
signalNotExistError (Optional)
Type: SystemBoolean
Signal an exception if object/page/database does not exist.

Return Value

Type: IOptimizedPersistable
a persistent object
See Also

Reference

SessionNoServerShared Class
Open Overload
VelocityDb.Session Namespace


SessionNoServerShared.OpenAllDatabases Method

SessionNoServerSharedOpenAllDatabases Method

Open all databases

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenAllDatabases(
    bool update = false
)
Public Overrides Function OpenAllDatabases (
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenAllDatabases(
    bool update = false
) override
abstract OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

update (Optional)
Type: SystemBoolean
Open for update?

Return Value

Type: List Database
List of Database
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.OpenDatabase Method

SessionNoServerSharedOpenDatabase Method

Opens a Database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Database OpenDatabase(
    uint dbNum,
    bool update = false,
    bool signalError = true
)
Public Overrides Function OpenDatabase (
    dbNum As UInteger,
    Optional update As Boolean = false,
    Optional signalError As Boolean = true
) As Database
public:
virtual Database^ OpenDatabase(
    unsigned int dbNum,
    bool update = false,
    bool signalError = true
) override
abstract OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database
override OpenDatabase :
        dbNum : uint32 *
        ?update : bool *
        ?signalError : bool
(* Defaults:
        let _update = defaultArg update false
        let _signalError = defaultArg signalError true
*)
-> Database

Parameters

dbNum
Type: SystemUInt32
The Database number of the database to open
update (Optional)
Type: SystemBoolean
Open the Database for update?
signalError (Optional)
Type: SystemBoolean
Signal errors if errors found when opening the Database?

Return Value

Type: Database
The opened Database
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.OpenLocationDatabases Method

SessionNoServerSharedOpenLocationDatabases Method

Opens all the databases in a given location

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenLocationDatabases(
    DatabaseLocation location,
    bool update = false
)
Public Overrides Function OpenLocationDatabases (
    location As DatabaseLocation,
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenLocationDatabases(
    DatabaseLocation^ location,
    bool update = false
) override
abstract OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenLocationDatabases :
        location : DatabaseLocation *
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

location
Type: VelocityDbDatabaseLocation
The location for which to open databases
update (Optional)
Type: SystemBoolean
Shall each database be opened for update?

Return Value

Type: List Database
A list of opened databases
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.OpenSchema Method

SessionNoServerSharedOpenSchema Method

Get the session active schema

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Schema OpenSchema(
    bool update
)
Public Overrides Function OpenSchema (
    update As Boolean
) As Schema
public:
virtual Schema^ OpenSchema(
    bool update
) override
abstract OpenSchema :
        update : bool -> Schema
override OpenSchema :
        update : bool -> Schema

Parameters

update
Type: SystemBoolean
Do update the schema?

Return Value

Type: Schema
The active schema
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Persist Method

SessionNoServerSharedPersist Method

Overload List
 | Name | Description
Public method | Persist(IOptimizedPersistable, NullableUInt16) | This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber. (Overrides SessionBasePersist(IOptimizedPersistable, NullableUInt16).)
Public method | Persist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable) | Persists an object (Overrides SessionBasePersist(Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable).)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Persist Method (IOptimizedPersistable, Nullable(UInt16))

SessionNoServerSharedPersist Method (IOptimizedPersistable, NullableUInt16)

This is the recommended way of persisting objects, it is simple and efficient. Each type is stored in its own database unless object class overrides PlacementDatabaseNumber and returns something other than DefaultPlacementDatabaseNumber.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    IOptimizedPersistable ipObj,
    Nullable<ushort> objectsPerPage = null
)
Public Overrides Function Persist (
    ipObj As IOptimizedPersistable,
    Optional objectsPerPage As Nullable(Of UShort) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    IOptimizedPersistable^ ipObj,
    Nullable<unsigned short> objectsPerPage = nullptr
) override
abstract Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64
override Persist :
        ipObj : IOptimizedPersistable *
        ?objectsPerPage : Nullable<uint16>
(* Defaults:
        let _objectsPerPage = defaultArg objectsPerPage null
*)
-> uint64

Parameters

ipObj
Type: VelocityDbIOptimizedPersistable
The object to make persistent
objectsPerPage (Optional)
Type: SystemNullable UInt16
Override of objects per page, only respected when persisting first object of some type

Return Value

Type: UInt64
The Id of the persisted object
See Also

Reference

SessionNoServerShared Class
Persist Overload
VelocityDb.Session Namespace


SessionNoServerShared.Persist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, Queue(IOptimizedPersistable))

SessionNoServerSharedPersist Method (Placement, IOptimizedPersistable, Schema, UInt16, Boolean, QueueIOptimizedPersistable)

Persists an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    IOptimizedPersistable pObj,
    Schema schema,
    ushort slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    pObj As IOptimizedPersistable,
    schema As Schema,
    Optional slotLimitPerPage As UShort = 0,
    Optional inFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    IOptimizedPersistable^ pObj,
    Schema^ schema,
    unsigned short slotLimitPerPage = 0,
    bool inFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        pObj : IOptimizedPersistable *
        schema : Schema *
        ?slotLimitPerPage : uint16 *
        ?inFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _slotLimitPerPage = defaultArg slotLimitPerPage 0
        let _inFlush = defaultArg inFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement
Placement object determining where to persist the object
pObj
Type: VelocityDbIOptimizedPersistable
The object to persist
schema
Type: VelocityDb.TypeInfoSchema
The active session schema
slotLimitPerPage (Optional)
Type: SystemUInt16
Override of how many slots per page to permit
inFlush (Optional)
Type: SystemBoolean
Set to true to disallow page flushes as a side affect
toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable
A list of objects waiting to be persisted

Return Value

Type: UInt64
Id of persisted object
See Also

Reference

SessionNoServerShared Class
Persist Overload
VelocityDb.Session Namespace


SessionNoServerShared.PossiblyFlushUpdatedPages Method

SessionNoServerSharedPossiblyFlushUpdatedPages Method

Call this function if you may have updated many pages to possibly free up memory if too much memory is in use.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void PossiblyFlushUpdatedPages(
    uint numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
)
Public Overrides Sub PossiblyFlushUpdatedPages (
    Optional numberOfUpdatedPagesPermittedWithoutFlushCheck As UInteger = 100
)
public:
virtual void PossiblyFlushUpdatedPages(
    unsigned int numberOfUpdatedPagesPermittedWithoutFlushCheck = 100
) override
abstract PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit
override PossiblyFlushUpdatedPages :
        ?numberOfUpdatedPagesPermittedWithoutFlushCheck : uint32
(* Defaults:
        let _numberOfUpdatedPagesPermittedWithoutFlushCheck = defaultArg numberOfUpdatedPagesPermittedWithoutFlushCheck 100
*)
-> unit

Parameters

numberOfUpdatedPagesPermittedWithoutFlushCheck (Optional)
Type: SystemUInt32
Only do check if the number of updated pages is greater than this number
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.RestoreFrom Method

SessionNoServerSharedRestoreFrom Method

Restores Databases and pages from a backup DatabaseLocation. Existing data will be merged with the restored data unless existing Databases to restore are deleted before the restore.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreFrom(
    DatabaseLocation backupLocation,
    DateTime upToTime
)
Public Overrides Sub RestoreFrom (
    backupLocation As DatabaseLocation,
    upToTime As DateTime
)
public:
virtual void RestoreFrom(
    DatabaseLocation^ backupLocation,
    DateTime upToTime
) override
abstract RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit
override RestoreFrom :
        backupLocation : DatabaseLocation *
        upToTime : DateTime -> unit

Parameters

backupLocation
Type: VelocityDbDatabaseLocation
The location to restore from
upToTime
Type: SystemDateTime
Restore location up to a given DateTime. Data backed up after this time will not be restored.
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.SubscribeToChanges Method

SessionNoServerSharedSubscribeToChanges Method

Subscribe to committed database changes of instances of a type when an an optional property evaluates to true.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SubscribeToChanges(
    Type aType,
    string notifyIfTrueProperty = null
)
Public Overrides Sub SubscribeToChanges (
    aType As Type,
    Optional notifyIfTrueProperty As String = Nothing
)
public:
virtual void SubscribeToChanges(
    Type^ aType,
    String^ notifyIfTrueProperty = nullptr
) override
abstract SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit
override SubscribeToChanges :
        aType : Type *
        ?notifyIfTrueProperty : string
(* Defaults:
        let _notifyIfTrueProperty = defaultArg notifyIfTrueProperty null
*)
-> unit

Parameters

aType
Type: SystemType
The type you are interested in being notified about when persistent instances changes within a database.
notifyIfTrueProperty (Optional)
Type: SystemString
The name of a property part of the type specified as aType, this should be a Boolean property. When property returns true, a change notification is send otherwise no notification is send. Leave as null to get a notification any time any instance of the selected type changes
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.Unpersist Method

SessionNoServerSharedUnpersist Method

Use this when you want to delete objects that are not assignable as IOptimizedPersistable

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Unpersist(
    Object obj
)
Public Overrides Function Unpersist (
    obj As Object
) As Boolean
public:
virtual bool Unpersist(
    Object^ obj
) override
abstract Unpersist :
        obj : Object -> bool
override Unpersist :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to be deleted from persistent storage

Return Value

Type: Boolean
true if object found and deleted; otherwise false
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.UpdateDatabase Method

SessionNoServerSharedUpdateDatabase Method

Request an update lock on a database

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateDatabase(
    Database db
)
Public Overrides Function UpdateDatabase (
    db As Database
) As Boolean
public:
virtual bool UpdateDatabase(
    Database^ db
) override
abstract UpdateDatabase :
        db : Database -> bool
override UpdateDatabase :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase
The database to update

Return Value

Type: Boolean
true if Database was updated, otherwise throws an exception
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.UpdateObject Method

SessionNoServerSharedUpdateObject Method

Overload List
 | Name | Description
Public method | UpdateObject(Object) | Tag an object as updated so that it will be updated persistently (Overrides SessionBaseUpdateObject(Object).)
Public method | UpdateObject(IOptimizedPersistable, Boolean, Boolean) | Updates an object (Overrides SessionBaseUpdateObject(IOptimizedPersistable, Boolean, Boolean).)
Top
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionNoServerShared.UpdateObject Method (Object)

SessionNoServerSharedUpdateObject Method (Object)

Tag an object as updated so that it will be updated persistently

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateObject(
    Object obj
)
Public Overrides Function UpdateObject (
    obj As Object
) As Boolean
public:
virtual bool UpdateObject(
    Object^ obj
) override
abstract UpdateObject :
        obj : Object -> bool
override UpdateObject :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to update.

Return Value

Type: Boolean
true if object updated; otherwise false
See Also

Reference

SessionNoServerShared Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionNoServerShared.UpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

SessionNoServerSharedUpdateObject Method (IOptimizedPersistable, Boolean, Boolean)

Updates an object

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool UpdateObject(
    IOptimizedPersistable obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
)
Public Overrides Function UpdateObject (
    obj As IOptimizedPersistable,
    inFlush As Boolean,
    Optional deleteObjFromIndexes As Boolean = true
) As Boolean
public:
virtual bool UpdateObject(
    IOptimizedPersistable^ obj,
    bool inFlush,
    bool deleteObjFromIndexes = true
) override
abstract UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool
override UpdateObject :
        obj : IOptimizedPersistable *
        inFlush : bool *
        ?deleteObjFromIndexes : bool
(* Defaults:
        let _deleteObjFromIndexes = defaultArg deleteObjFromIndexes true
*)
-> bool

Parameters

obj
Type: VelocityDbIOptimizedPersistable
Object to be updated
inFlush
Type: SystemBoolean
Are we doing this as part of a page flush? Set to true to avoid a recursive page flush
deleteObjFromIndexes (Optional)
Type: SystemBoolean
Set to false if you know that this object is not part of any index. Safe to leave set to true in any case

Return Value

Type: Boolean
True if object is updated; otherwise false
See Also

Reference

SessionNoServerShared Class
UpdateObject Overload
VelocityDb.Session Namespace


SessionNoServerShared.Verify Method

SessionNoServerSharedVerify Method

Verifies that databases are valid by reading and following references. An exception is thrown if an issue is found.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Verify()
Public Overrides Sub Verify
public:
virtual void Verify() override
abstract Verify : unit -> unit
override Verify : unit -> unit
See Also

Reference

SessionNoServerShared Class
VelocityDb.Session Namespace


SessionPool Class

Provides a pool of sessions for reuse instead of creating new session instances every time a session is needed. The pooled sessions includes cached databases, pages and objects. Keep the pool size to a minimum too avoid excessive memory usage.
Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionPool

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class SessionPool : IDisposable,
    IComparable<SessionPool>
Public Class SessionPool
    Implements IDisposable, IComparable(Of SessionPool)
public ref class SessionPool : IDisposable,
    IComparable<SessionPool^>
type SessionPool =
    class
        interface IDisposable
        interface IComparable<SessionPool>
    end

The SessionPool type exposes the following members.

Constructors
 | Name | Description
Public method | SessionPool | Creates a session pool, store this pool somewhere where tour application threads can get to it.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes all sessions in this pool
Public method | FreeSession | Always call this function so that your session is unlocked and becomes available to others
Public method | GetSession | Get a session locked for use by caller.
Top
See Also

Reference

VelocityDb.Session Namespace


SessionPool Constructor

Creates a session pool, store this pool somewhere where tour application threads can get to it.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionPool(
    int poolSize,
    Func<SessionBase> createSessionFunc
)
Public Sub New (
    poolSize As Integer,
    createSessionFunc As Func(Of SessionBase)
)
public:
SessionPool(
    int poolSize,
    Func<SessionBase^>^ createSessionFunc
)
new :
        poolSize : int *
        createSessionFunc : Func<SessionBase> -> SessionPool

Parameters

poolSize
Type: SystemInt32
The maximum number of session maintained in the pool
createSessionFunc
Type: SystemFunc SessionBase
A function provided by you that creates a session of your choice with your choice of parameters. Could be something as simple as: () => new SessionNoServer("MyDbDir")
See Also

Reference

SessionPool Class
VelocityDb.Session Namespace


SessionPool Methods

The SessionPool type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes all sessions in this pool
Public method | FreeSession | Always call this function so that your session is unlocked and becomes available to others
Public method | GetSession | Get a session locked for use by caller.
Top
See Also

Reference

SessionPool Class
VelocityDb.Session Namespace


SessionPool.Dispose Method

SessionPoolDispose Method

Disposes all sessions in this pool

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SessionPool Class
VelocityDb.Session Namespace


SessionPool.FreeSession Method

SessionPoolFreeSession Method

Always call this function so that your session is unlocked and becomes available to others

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void FreeSession(
    int identifier,
    SessionBase session
)
Public Sub FreeSession (
    identifier As Integer,
    session As SessionBase
)
public:
void FreeSession(
    int identifier,
    SessionBase^ session
)
member FreeSession :
        identifier : int *
        session : SessionBase -> unit

Parameters

identifier
Type: SystemInt32
The identifier provided by GetSession(Int32)
session
Type: VelocityDb.SessionSessionBase
The session provided by GetSession(Int32)
See Also

Reference

SessionPool Class
VelocityDb.Session Namespace


SessionPool.GetSession Method

SessionPoolGetSession Method

Get a session locked for use by caller.

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SessionBase GetSession(
    out int identifier
)
Public Function GetSession (
    <OutAttribute> ByRef identifier As Integer
) As SessionBase
public:
SessionBase^ GetSession(
    [OutAttribute] int% identifier
)
member GetSession :
        identifier : int byref -> SessionBase

Parameters

identifier
Type: SystemInt32
The id of the returned session. Make sure you always call FreeSession with this id provided or else session is locked forever. One way is to call FreeSession in a finally block.

Return Value

Type: SessionBase
A reserved/locked session
See Also

Reference

SessionPool Class
VelocityDb.Session Namespace


TypeExtensions Class

Some extensions to Type
Inheritance Hierarchy
SystemObject
VelocityDb.SessionTypeExtensions

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class TypeExtensions
<ExtensionAttribute>
Public NotInheritable Class TypeExtensions
[ExtensionAttribute]
public ref class TypeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type TypeExtensions =  class end

The TypeExtensions type exposes the following members.

Methods
Name | Description
ExpandsToNonPrimitiveTypes | Used by Database Manager
GetTypeCode |
ToGenericTypeString | Gets a string representation of a Type corresponding to how it looks in C# code
Top
See Also

Reference

VelocityDb.Session Namespace


TypeExtensions Methods

The TypeExtensions type exposes the following members.

Methods
Name | Description
ExpandsToNonPrimitiveTypes | Used by Database Manager
GetTypeCode |
ToGenericTypeString | Gets a string representation of a Type corresponding to how it looks in C# code
Top
See Also

Reference

TypeExtensions Class
VelocityDb.Session Namespace


TypeExtensions.ExpandsToNonPrimitiveTypes Method

TypeExtensionsExpandsToNonPrimitiveTypes Method

Used by Database Manager

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool ExpandsToNonPrimitiveTypes(
    this Type t
)
<ExtensionAttribute>
Public Shared Function ExpandsToNonPrimitiveTypes (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool ExpandsToNonPrimitiveTypes(
    Type^ t
)
[<ExtensionAttribute>]
static member ExpandsToNonPrimitiveTypes :
        t : Type -> bool

Parameters

t
Type: SystemType
Type examined

Return Value

Type: Boolean
true if type does; otherwise false

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
VelocityDb.Session Namespace


TypeExtensions.GetTypeCode Method

TypeExtensionsGetTypeCode Method

[Missing <summary> documentation for "M:VelocityDb.Session.TypeExtensions.GetTypeCode(System.Type)"]

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static TypeCode GetTypeCode(
    this Type t
)
<ExtensionAttribute>
Public Shared Function GetTypeCode (
    t As Type
) As TypeCode
public:
[ExtensionAttribute]
static TypeCode GetTypeCode(
    Type^ t
)
[<ExtensionAttribute>]
static member GetTypeCode :
        t : Type -> TypeCode

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:VelocityDb.Session.TypeExtensions.GetTypeCode(System.Type)"]

Return Value

Type: TypeCode

[Missing <returns> documentation for "M:VelocityDb.Session.TypeExtensions.GetTypeCode(System.Type)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
VelocityDb.Session Namespace


TypeExtensions.ToGenericTypeString Method

TypeExtensionsToGenericTypeString Method

Gets a string representation of a Type corresponding to how it looks in C# code

Namespace: VelocityDb.Session
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ToGenericTypeString(
    this Type t,
    params Type[] arg
)
<ExtensionAttribute>
Public Shared Function ToGenericTypeString (
    t As Type,
    ParamArray arg As Type()
) As String
public:
[ExtensionAttribute]
static String^ ToGenericTypeString(
    Type^ t,
    ... array<Type^>^ arg
)
[<ExtensionAttribute>]
static member ToGenericTypeString :
        t : Type *
        arg : Type[] -> string

Parameters

t
Type: SystemType
The type to get the string for
arg
Type: SystemType
Internally used parameter (optional)

Return Value

Type: String
A string representation of a type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
VelocityDb.Session Namespace


VelocityDb.Sync Namespace

The VelocityDb.Sync namespace contains classes for enabling data sync between different sets of databases
Classes
 | Class | Description
Public class | Change | Used for tracking changes for use with syncing database sessions
Public class | Changes | Keeps track of changes within a set of databases (a federation). Preliminary version.
Public class | ReplicaSync | Contains info of latest transaction synced with databases at a specified host and path
Public class | TransactionChanges | A log of all changes made within a certain transaction.


Change Class

Used for tracking changes for use with syncing database sessions
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.SyncChange

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Change : OptimizedPersistable, IComparable<Change>,
    IComparable
<SerializableAttribute>
Public Class Change
    Inherits OptimizedPersistable
    Implements IComparable(Of Change), IComparable
[SerializableAttribute]
public ref class Change : public OptimizedPersistable,
    IComparable<Change^>, IComparable
[<SerializableAttribute>]
type Change =
    class
        inherit OptimizedPersistable
        interface IComparable<Change>
        interface IComparable
    end

The Change type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | DatabaseId | Database number of changed Database
Public property | Deleted | Is this a change involving a database/page delete
Public property | PageId | Page number of changed Page
Public property | Version | Version of page being updated
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares objects using the object Id (Overrides OptimizedPersistableCompareTo(Object).)
Public method | CompareTo(Change) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Sync Namespace


Change Properties

The Change type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | DatabaseId | Database number of changed Database
Public property | Deleted | Is this a change involving a database/page delete
Public property | PageId | Page number of changed Page
Public property | Version | Version of page being updated
Top
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.AllowOtherTypesOnSamePage Property

ChangeAllowOtherTypesOnSamePage Property

We only want this type of object on any page containing this type so don't use pages with other type of objects when placing an object of this type

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.DatabaseId Property

ChangeDatabaseId Property

Database number of changed Database

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public uint DatabaseId { get; }
Public ReadOnly Property DatabaseId As UInteger
    Get
public:
property unsigned int DatabaseId {
    unsigned int get ();
}
member DatabaseId : uint32 with get

Property Value

Type: UInt32
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.Deleted Property

ChangeDeleted Property

Is this a change involving a database/page delete

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Deleted { get; set; }
Public Property Deleted As Boolean
    Get
    Set
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
member Deleted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.PageId Property

ChangePageId Property

Page number of changed Page

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort PageId { get; }
Public ReadOnly Property PageId As UShort
    Get
public:
property unsigned short PageId {
    unsigned short get ();
}
member PageId : uint16 with get

Property Value

Type: UInt16
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.Version Property

ChangeVersion Property

Version of page being updated

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Version { get; }
Public ReadOnly Property Version As ULong
    Get
public:
property unsigned long long Version {
    unsigned long long get ();
}
member Version : uint64 with get

Property Value

Type: UInt64
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change Methods

The Change type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares objects using the object Id (Overrides OptimizedPersistableCompareTo(Object).)
Public method | CompareTo(Change) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.CompareTo Method

ChangeCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares objects using the object Id (Overrides OptimizedPersistableCompareTo(Object).)
Public method | CompareTo(Change) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Top
See Also

Reference

Change Class
VelocityDb.Sync Namespace


Change.CompareTo Method (Object)

ChangeCompareTo Method (Object)

Compares objects using the object Id

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object change
)
Public Overrides Function CompareTo (
    change As Object
) As Integer
public:
virtual int CompareTo(
    Object^ change
) override
abstract CompareTo :
        change : Object -> int
override CompareTo :
        change : Object -> int

Parameters

change
Type: SystemObject

[Missing <param name="change"/> documentation for "M:VelocityDb.Sync.Change.CompareTo(System.Object)"]

Return Value

Type: Int32
A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance precedes obj in the sort order. Zero This instance occurs in the same position in the sort order as obj. Greater than zero This instance follows obj in the sort order.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | obj is not the same type as this instance.
See Also

Reference

Change Class
CompareTo Overload
VelocityDb.Sync Namespace


Change.CompareTo Method (Change)

ChangeCompareTo Method (Change)

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Change change
)
Public Function CompareTo (
    change As Change
) As Integer
public:
virtual int CompareTo(
    Change^ change
) sealed
abstract CompareTo :
        change : Change -> int
override CompareTo :
        change : Change -> int

Parameters

change
Type: VelocityDb.SyncChange

[Missing <param name="change"/> documentation for "M:VelocityDb.Sync.Change.CompareTo(VelocityDb.Sync.Change)"]

Return Value

Type: Int32
A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance precedes other in the sort order. Zero This instance occurs in the same position in the sort order as other. Greater than zero This instance follows other in the sort order.

Implements

IComparableTCompareTo(T)
See Also

Reference

Change Class
CompareTo Overload
VelocityDb.Sync Namespace


Changes Class

Keeps track of changes within a set of databases (a federation). Preliminary version.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.SyncChanges

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Changes : OptimizedPersistable
Public Class Changes
    Inherits OptimizedPersistable
public ref class Changes : public OptimizedPersistable
type Changes =
    class
        inherit OptimizedPersistable
    end

The Changes type exposes the following members.

Properties
 | Name | Description
Public property | ChangeList | A list of TransactionChanges made to the federation
Top
Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Sync Namespace


Changes Properties

The Changes type exposes the following members.

Properties
 | Name | Description
Public property | ChangeList | A list of TransactionChanges made to the federation
Top
See Also

Reference

Changes Class
VelocityDb.Sync Namespace


Changes.ChangeList Property

ChangesChangeList Property

A list of TransactionChanges made to the federation

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakReferenceList<TransactionChanges> ChangeList { get; }
Public ReadOnly Property ChangeList As WeakReferenceList(Of TransactionChanges)
    Get
public:
property WeakReferenceList<TransactionChanges^>^ ChangeList {
    WeakReferenceList<TransactionChanges^>^ get ();
}
member ChangeList : WeakReferenceList<TransactionChanges> with get

Property Value

Type: WeakReferenceList TransactionChanges
See Also

Reference

Changes Class
VelocityDb.Sync Namespace


Changes Methods

The Changes type exposes the following members.

Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Changes Class
VelocityDb.Sync Namespace


Changes.Unpersist Method

ChangesUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

Changes Class
VelocityDb.Sync Namespace


ReplicaSync Class

Contains info of latest transaction synced with databases at a specified host and path
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.SyncReplicaSync

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class ReplicaSync : OptimizedPersistable
Public Class ReplicaSync
    Inherits OptimizedPersistable
public ref class ReplicaSync : public OptimizedPersistable
type ReplicaSync =
    class
        inherit OptimizedPersistable
    end

The ReplicaSync type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaSync | Creates sync log object
Top
Properties
 | Name | Description
Public property | SyncFromHost | Host of databases synced with
Public property | SyncFromPath | Path to databases synced with
Public property | TransactionNumber | Last transaction number synced with
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Sync Namespace


ReplicaSync Constructor

Creates sync log object

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ReplicaSync(
    SessionBase syncFromSession,
    ulong transaction
)
Public Sub New (
    syncFromSession As SessionBase,
    transaction As ULong
)
public:
ReplicaSync(
    SessionBase^ syncFromSession,
    unsigned long long transaction
)
new :
        syncFromSession : SessionBase *
        transaction : uint64 -> ReplicaSync

Parameters

syncFromSession
Type: VelocityDb.SessionSessionBase
The sync from session
transaction
Type: SystemUInt64
Last transaction synced
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


ReplicaSync Properties

The ReplicaSync type exposes the following members.

Properties
 | Name | Description
Public property | SyncFromHost | Host of databases synced with
Public property | SyncFromPath | Path to databases synced with
Public property | TransactionNumber | Last transaction number synced with
Top
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


ReplicaSync.SyncFromHost Property

ReplicaSyncSyncFromHost Property

Host of databases synced with

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SyncFromHost { get; }
Public ReadOnly Property SyncFromHost As String
    Get
public:
property String^ SyncFromHost {
    String^ get ();
}
member SyncFromHost : string with get

Property Value

Type: String
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


ReplicaSync.SyncFromPath Property

ReplicaSyncSyncFromPath Property

Path to databases synced with

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SyncFromPath { get; }
Public ReadOnly Property SyncFromPath As String
    Get
public:
property String^ SyncFromPath {
    String^ get ();
}
member SyncFromPath : string with get

Property Value

Type: String
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


ReplicaSync.TransactionNumber Property

ReplicaSyncTransactionNumber Property

Last transaction number synced with

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong TransactionNumber { get; set; }
Public Property TransactionNumber As ULong
    Get
    Set
public:
property unsigned long long TransactionNumber {
    unsigned long long get ();
    void set (unsigned long long value);
}
member TransactionNumber : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


ReplicaSync Methods

The ReplicaSync type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

ReplicaSync Class
VelocityDb.Sync Namespace


TransactionChanges Class

A log of all changes made within a certain transaction.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.SyncTransactionChanges

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class TransactionChanges : OptimizedPersistable
Public Class TransactionChanges
    Inherits OptimizedPersistable
public ref class TransactionChanges : public OptimizedPersistable
type TransactionChanges =
    class
        inherit OptimizedPersistable
    end

The TransactionChanges type exposes the following members.

Properties
 | Name | Description
Public property | ChangeList | List of changes made
Public property | TransactionNumber | Transaction id for these changes.
Top
Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.Sync Namespace


TransactionChanges Properties

The TransactionChanges type exposes the following members.

Properties
 | Name | Description
Public property | ChangeList | List of changes made
Public property | TransactionNumber | Transaction id for these changes.
Top
See Also

Reference

TransactionChanges Class
VelocityDb.Sync Namespace


TransactionChanges.ChangeList Property

TransactionChangesChangeList Property

List of changes made

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WeakReferenceList<Change> ChangeList { get; }
Public ReadOnly Property ChangeList As WeakReferenceList(Of Change)
    Get
public:
property WeakReferenceList<Change^>^ ChangeList {
    WeakReferenceList<Change^>^ get ();
}
member ChangeList : WeakReferenceList<Change> with get

Property Value

Type: WeakReferenceList Change
See Also

Reference

TransactionChanges Class
VelocityDb.Sync Namespace


TransactionChanges.TransactionNumber Property

TransactionChangesTransactionNumber Property

Transaction id for these changes.

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong TransactionNumber { get; }
Public ReadOnly Property TransactionNumber As ULong
    Get
public:
property unsigned long long TransactionNumber {
    unsigned long long get ();
}
member TransactionNumber : uint64 with get

Property Value

Type: UInt64
See Also

Reference

TransactionChanges Class
VelocityDb.Sync Namespace


TransactionChanges Methods

The TransactionChanges type exposes the following members.

Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

TransactionChanges Class
VelocityDb.Sync Namespace


TransactionChanges.Unpersist Method

TransactionChangesUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.Sync
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

TransactionChanges Class
VelocityDb.Sync Namespace


VelocityDb.TypeInfo Namespace

The VelocityDb.TypeInfo namespace contains classes for Type information of persistently stored data
Classes
 | Class | Description
Public class | Association | A field attribute that controls what to do when deleting object and other end of association exist.
Public class | AutoIncrement | A field attribute that enables a field to get a unique number for each persisted object of a certain type. This only works for objects persisted (directly or indirectly) with Persist(IOptimizedPersistable, NullableUInt16)
Public class | CommonTypes | A cache of commonly instantiated Types and their size in bytes
Public class | DataMember | Info about a data Field of a persistent object
Public class | FieldAccessor | A field attribute that controls how many objects that will be placed on the same page as the object of the field.
Public class | ObjectsPerPage | A field attribute that controls how many objects that will be placed on the same page as the object of the field.
Public class | Reference |
Public class | Relation | The relation classes exist as an aid to maintain referential integrity, that is no dangling references (references to deleted objects). NOTE: These classes may change as they are still in a prototype phase. Let us know how we can improve them? Any ideas are appreciated!
Public class | RelationManyToManyFrom, To | Use for many to many relations
Public class | RelationOneToManyFrom, To | Use for one to many (and many to one) relations.
Public class | RelationOneToOneFrom, To | Use for one to one relations.
Public class | Schema | Holds information about persistently stored types. Used internally by VelocityDb.
Public class | TypeVersion | Contains info about a version of a VelocityDbType. The info is used when reading/writing an object of the
Public class | UseOidShort | Indicates that every field or selected fields of a serializable class should be referenced using a OidShort instead of a full Oid. This means that the referenced object is located in the same database as the object containing the reference. A ShortOid uses less space and references are not tied to a certain database number.
Public class | VelocityDbType | Contains persistent info for a Type
Enumerations
 | Enumeration | Description
Public enumeration | AssociationReverseReferenceTypeEnum | What type of reference is used by reverse reference?


Association Class

A field attribute that controls what to do when deleting object and other end of association exist.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.TypeInfoAssociation

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class Association : Attribute
Public NotInheritable Class Association
    Inherits Attribute
public ref class Association sealed : public Attribute
[<SealedAttribute>]
type Association =
    class
        inherit Attribute
    end

The Association type exposes the following members.

Constructors
 | Name | Description
Public method | Association(String) | Initializes a new instance of the Association class
Public method | Association(String, AssociationReverseReferenceTypeEnum) | Initializes a new instance of the Association class
Top
Properties
 | Name | Description
Public property | ReversePropertyName | Name of property that retrieves other side of association
Public property | ReverseReferenceType | Type of reference to this object at other end of association
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


Association Constructor

Overload List
 | Name | Description
Public method | Association(String) | Initializes a new instance of the Association class
Public method | Association(String, AssociationReverseReferenceTypeEnum) | Initializes a new instance of the Association class
Top
See Also

Reference

Association Class
VelocityDb.TypeInfo Namespace


Association Constructor (String)

Initializes a new instance of the Association class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Association(
    string reversePropertyName
)
Public Sub New (
    reversePropertyName As String
)
public:
Association(
    String^ reversePropertyName
)
new :
        reversePropertyName : string -> Association

Parameters

reversePropertyName
Type: SystemString

[Missing <param name="reversePropertyName"/> documentation for "M:VelocityDb.TypeInfo.Association.#ctor(System.String)"]

See Also

Reference

Association Class
Association Overload
VelocityDb.TypeInfo Namespace


Association Constructor (String, Association.ReverseReferenceTypeEnum)

Association Constructor (String, AssociationReverseReferenceTypeEnum)

Initializes a new instance of the Association class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Association(
    string reversePropertyName,
    AssociationReverseReferenceTypeEnum reverseReferenceType
)
Public Sub New (
    reversePropertyName As String,
    reverseReferenceType As AssociationReverseReferenceTypeEnum
)
public:
Association(
    String^ reversePropertyName,
    AssociationReverseReferenceTypeEnum reverseReferenceType
)
new :
        reversePropertyName : string *
        reverseReferenceType : AssociationReverseReferenceTypeEnum -> Association

Parameters

reversePropertyName
Type: SystemString

[Missing <param name="reversePropertyName"/> documentation for "M:VelocityDb.TypeInfo.Association.#ctor(System.String,VelocityDb.TypeInfo.Association.ReverseReferenceTypeEnum)"]

reverseReferenceType
Type: VelocityDb.TypeInfoAssociationReverseReferenceTypeEnum

[Missing <param name="reverseReferenceType"/> documentation for "M:VelocityDb.TypeInfo.Association.#ctor(System.String,VelocityDb.TypeInfo.Association.ReverseReferenceTypeEnum)"]

See Also

Reference

Association Class
Association Overload
VelocityDb.TypeInfo Namespace


Association Properties

The Association type exposes the following members.

Properties
 | Name | Description
Public property | ReversePropertyName | Name of property that retrieves other side of association
Public property | ReverseReferenceType | Type of reference to this object at other end of association
Top
See Also

Reference

Association Class
VelocityDb.TypeInfo Namespace


Association.ReversePropertyName Property

AssociationReversePropertyName Property

Name of property that retrieves other side of association

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ReversePropertyName { get; }
Public ReadOnly Property ReversePropertyName As String
    Get
public:
property String^ ReversePropertyName {
    String^ get ();
}
member ReversePropertyName : string with get

Property Value

Type: String
See Also

Reference

Association Class
VelocityDb.TypeInfo Namespace


Association.ReverseReferenceType Property

AssociationReverseReferenceType Property

Type of reference to this object at other end of association

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AssociationReverseReferenceTypeEnum ReverseReferenceType { get; }
Public ReadOnly Property ReverseReferenceType As AssociationReverseReferenceTypeEnum
    Get
public:
property AssociationReverseReferenceTypeEnum ReverseReferenceType {
    AssociationReverseReferenceTypeEnum get ();
}
member ReverseReferenceType : AssociationReverseReferenceTypeEnum with get

Property Value

Type: AssociationReverseReferenceTypeEnum
See Also

Reference

Association Class
VelocityDb.TypeInfo Namespace


Association.ReverseReferenceTypeEnum Enumeration

AssociationReverseReferenceTypeEnum Enumeration

What type of reference is used by reverse reference?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum ReverseReferenceTypeEnum
Public Enumeration ReverseReferenceTypeEnum
public enum class ReverseReferenceTypeEnum
type ReverseReferenceTypeEnum
Members
Member name | Value | Description
ToOne | 0 | A direct reference.
InSet | 1 | Reference is within a ISetT
InList | 2 | Reference is within a IListT
InArray | 3 | Reference is within a Array
See Also

Reference

VelocityDb.TypeInfo Namespace


AutoIncrement Class

A field attribute that enables a field to get a unique number for each persisted object of a certain type. This only works for objects persisted (directly or indirectly) with Persist(IOptimizedPersistable, NullableUInt16)
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.TypeInfoAutoIncrement

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class AutoIncrement : Attribute
Public NotInheritable Class AutoIncrement
    Inherits Attribute
public ref class AutoIncrement sealed : public Attribute
[<SealedAttribute>]
type AutoIncrement =
    class
        inherit Attribute
    end

The AutoIncrement type exposes the following members.

Constructors
 | Name | Description
Public method | AutoIncrement | Use in class definition preceding a field declaration, i.e. [AutoIncrement(1)]
Top
Properties
 | Name | Description
Public property | Start | Gets the requested start number of the auto increment sequence
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


AutoIncrement Constructor

Use in class definition preceding a field declaration, i.e. [AutoIncrement(1)]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AutoIncrement(
    ushort start = 0
)
Public Sub New (
    Optional start As UShort = 0
)
public:
AutoIncrement(
    unsigned short start = 0
)
new :
        ?start : uint16
(* Defaults:
        let _start = defaultArg start 0
*)
-> AutoIncrement

Parameters

start (Optional)
Type: SystemUInt16
The requested start number of the auto increment sequence. Default is 0 so that first persisted object is assigned number 1, second number 2 and so on.
See Also

Reference

AutoIncrement Class
VelocityDb.TypeInfo Namespace


AutoIncrement Properties

The AutoIncrement type exposes the following members.

Properties
 | Name | Description
Public property | Start | Gets the requested start number of the auto increment sequence
Top
See Also

Reference

AutoIncrement Class
VelocityDb.TypeInfo Namespace


AutoIncrement.Start Property

AutoIncrementStart Property

Gets the requested start number of the auto increment sequence

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong Start { get; }
Public ReadOnly Property Start As ULong
    Get
public:
property unsigned long long Start {
    unsigned long long get ();
}
member Start : uint64 with get

Property Value

Type: UInt64
The UInt64 sequence start number.
See Also

Reference

AutoIncrement Class
VelocityDb.TypeInfo Namespace


CommonTypes Class

A cache of commonly instantiated Types and their size in bytes
Inheritance Hierarchy
SystemObject
VelocityDb.TypeInfoCommonTypes

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class CommonTypes
Public NotInheritable Class CommonTypes
public ref class CommonTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CommonTypes =  class end

The CommonTypes type exposes the following members.

Fields
Name | Description
s_sizeOfBoolean | Cache of sizeof(Boolean)
s_sizeOfByte | Cache of sizeof(Byte)
s_sizeOfChar | Cache of sizeof(Char)
s_sizeOfDecimal | Cache of sizeof(Decimal)
s_sizeOfDouble | Cache of sizeof(Double)
s_sizeOfInt16 | Cache of sizeof(Int16)
s_sizeOfInt32 | Cache of sizeof(Int32)
s_sizeOfInt64 | Cache of sizeof(Int64)
s_sizeOfSByte | Cache of sizeof(SByte)
s_sizeOfSingle | Cache of sizeof(Single)
s_sizeOfUInt16 | Cache of sizeof(UInt16)
s_sizeOfUInt32 | Cache of sizeof(UInt32)
s_sizeOfUInt64 | Cache of sizeof(UInt64)
s_typeOfArray | Cache of typeof(Array)
s_typeOfArrayList | Cache of typeof(ArrayList)
s_typeOfBoolean | Cache of typeof(Boolean)
s_typeOfBTreeInternal | Cache of typeof(BTreeInternalKey, Value)
s_typeOfBTreeInternalOidShort | Cache of typeof(BTreeInternalOidShort)
s_typeOfBTreeLeaf | Cache of typeof(BTreeLeafKey, Value)
s_typeOfBTreeLeafBase | Cache of typeof(BTreeLeafBaseKey, Value)
s_typeOfBTreeLeafOidShort | Cache of typeof(BTreeLeafOidShort)
s_typeOfBTreeMap | Cache of typeof(BTreeMapKey, Value)
s_typeOfBTreeMapOidShort | Cache of typeof(BTreeMapOidShortKey, Value)
s_typeOfBTreeSet | Cache of typeof(BTreeSetKey)
s_typeOfBTreeSetOidShort | Cache of typeof(BTreeSetOidShortKey)
s_typeOfByte | Cache of typeof(Byte)
s_typeOfByteArray | Cache of typeof(Byte[])
s_typeOfChar | Cache of typeof(Char)
s_typeOfCompareByFieldIndex | Cache of typeof(CompareByFieldIndex)
s_typeOfDataForISerializable | Cache of typeof(DataForISerializable)
s_typeOfDateTime | Cache of typeof(DateTime)
s_typeOfDecimal | Cache of typeof(Decimal)
s_typeOfDelegate | Cache of typeof(Delegate)
s_typeOfDouble | Cache of typeof(Double)
s_typeOfEmbed | Cache of typeof(Embed)
s_typeOfFunc | Cache of typeof(Func{})
s_typeOfGetHandler | Cache of typeof(Func{object, object});
s_typeOfGuid | Cache of typeof(Guid)
s_typeOfIndex | Cache of typeof(Index)
s_typeOfIndexStringByHashCode | Cache of typeof(IndexStringByHashCode)
s_typeOfInt16 | Cache of typeof(Int16)
s_typeOfInt32 | Cache of typeof(Int32)
s_typeOfInt64 | Cache of typeof(Int64)
s_typeOfIOptimizedPersistable | Cache of typeof(IOptimizedPersistable)
s_typeOfISet | Cache of typeof(ISetT)
s_typeOfList | Cache of typeof(List{})
s_typeOfLong | Cache of typeof(Int64)
s_typeOfNonSerializedAttribute | Cache of typeof(NonSerializedAttribute)
s_typeOfNullable | Cache of typeof(Nullable)
s_typeOfObject | Cache of typeof(Object)
s_typeOfObjectActivator | Cache of typeof(ObjectActivator)
s_typeOfObjectArray | Cache of typeof(Object[])
s_typeOfOid | Cache of typeof(Oid)
s_typeOfOidShort | Cache of typeof(OidShort)
s_typeOfOnePerDatabase | Cache of typeof(OnePerDatabase)
s_typeOfOptimizedPersistable | Cache of typeof(OptimizedPersistable)
s_typeOfSByte | Cache of typeof(SByte)
s_typeOfSchema | Cache of typeof(Schema)
s_typeOfSessionBase | Cache of typeof(SessionBase)
s_typeOfSetHandler | Cache of typeof(Action{object, object});
s_typeOfSingle | Cache of typeof(Single)
s_typeOfString | Cache of typeof(String)
s_typeOfStringArray | Cache of typeof(String[])
s_typeOfTimeSpan | Cache of typeof(TimeSpan)
s_typeOfType | Cache of typeof(Type)
s_typeOfTypeArray | Cache of typeof(Type[])
s_typeOfTypeVersionArray | Cache of typeof(TypeVersion[])
s_typeOfUInt16 | Cache of typeof(UInt16)
s_typeOfUInt32 | Cache of typeof(UInt32)
s_typeOfUInt64 | Cache of typeof(UInt64)
s_typeOfUniqueConstraint | Cache of typeof(UniqueConstraint)
s_typeOfUseOidShort | Cache of typeof(UseOidShort)
s_typeOfValueType | Cache of typeof(ValueType)
s_typeOfVelocityDbComparer | Cache of typeof(VelocityDbComparerKey)
s_typeOfVelocityDbList | Cache of typeof(VelocityDbListT)
s_typeOfVelocityDbListOidShort | Cache of typeof(VelocityDbListOidShortT)
s_typeOfWeakIOptimizedPersistableReference | Cache of typeof(WeakIOptimizedPersistableReference)
s_typeOfWeakIOptimizedPersistableReferenceBase | Cache of typeof(WeakIOptimizedPersistableReferenceBase)
s_typeOfWeakReferenceList | Cache of typeof(WeakReferenceListT)
s_typeOfWeakShortReferenceList | Cache of typeof(WeakShortReferenceListT)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


CommonTypes Fields

The CommonTypes type exposes the following members.

Fields
Name | Description
s_sizeOfBoolean | Cache of sizeof(Boolean)
s_sizeOfByte | Cache of sizeof(Byte)
s_sizeOfChar | Cache of sizeof(Char)
s_sizeOfDecimal | Cache of sizeof(Decimal)
s_sizeOfDouble | Cache of sizeof(Double)
s_sizeOfInt16 | Cache of sizeof(Int16)
s_sizeOfInt32 | Cache of sizeof(Int32)
s_sizeOfInt64 | Cache of sizeof(Int64)
s_sizeOfSByte | Cache of sizeof(SByte)
s_sizeOfSingle | Cache of sizeof(Single)
s_sizeOfUInt16 | Cache of sizeof(UInt16)
s_sizeOfUInt32 | Cache of sizeof(UInt32)
s_sizeOfUInt64 | Cache of sizeof(UInt64)
s_typeOfArray | Cache of typeof(Array)
s_typeOfArrayList | Cache of typeof(ArrayList)
s_typeOfBoolean | Cache of typeof(Boolean)
s_typeOfBTreeInternal | Cache of typeof(BTreeInternalKey, Value)
s_typeOfBTreeInternalOidShort | Cache of typeof(BTreeInternalOidShort)
s_typeOfBTreeLeaf | Cache of typeof(BTreeLeafKey, Value)
s_typeOfBTreeLeafBase | Cache of typeof(BTreeLeafBaseKey, Value)
s_typeOfBTreeLeafOidShort | Cache of typeof(BTreeLeafOidShort)
s_typeOfBTreeMap | Cache of typeof(BTreeMapKey, Value)
s_typeOfBTreeMapOidShort | Cache of typeof(BTreeMapOidShortKey, Value)
s_typeOfBTreeSet | Cache of typeof(BTreeSetKey)
s_typeOfBTreeSetOidShort | Cache of typeof(BTreeSetOidShortKey)
s_typeOfByte | Cache of typeof(Byte)
s_typeOfByteArray | Cache of typeof(Byte[])
s_typeOfChar | Cache of typeof(Char)
s_typeOfCompareByFieldIndex | Cache of typeof(CompareByFieldIndex)
s_typeOfDataForISerializable | Cache of typeof(DataForISerializable)
s_typeOfDateTime | Cache of typeof(DateTime)
s_typeOfDecimal | Cache of typeof(Decimal)
s_typeOfDelegate | Cache of typeof(Delegate)
s_typeOfDouble | Cache of typeof(Double)
s_typeOfEmbed | Cache of typeof(Embed)
s_typeOfFunc | Cache of typeof(Func{})
s_typeOfGetHandler | Cache of typeof(Func{object, object});
s_typeOfGuid | Cache of typeof(Guid)
s_typeOfIndex | Cache of typeof(Index)
s_typeOfIndexStringByHashCode | Cache of typeof(IndexStringByHashCode)
s_typeOfInt16 | Cache of typeof(Int16)
s_typeOfInt32 | Cache of typeof(Int32)
s_typeOfInt64 | Cache of typeof(Int64)
s_typeOfIOptimizedPersistable | Cache of typeof(IOptimizedPersistable)
s_typeOfISet | Cache of typeof(ISetT)
s_typeOfList | Cache of typeof(List{})
s_typeOfLong | Cache of typeof(Int64)
s_typeOfNonSerializedAttribute | Cache of typeof(NonSerializedAttribute)
s_typeOfNullable | Cache of typeof(Nullable)
s_typeOfObject | Cache of typeof(Object)
s_typeOfObjectActivator | Cache of typeof(ObjectActivator)
s_typeOfObjectArray | Cache of typeof(Object[])
s_typeOfOid | Cache of typeof(Oid)
s_typeOfOidShort | Cache of typeof(OidShort)
s_typeOfOnePerDatabase | Cache of typeof(OnePerDatabase)
s_typeOfOptimizedPersistable | Cache of typeof(OptimizedPersistable)
s_typeOfSByte | Cache of typeof(SByte)
s_typeOfSchema | Cache of typeof(Schema)
s_typeOfSessionBase | Cache of typeof(SessionBase)
s_typeOfSetHandler | Cache of typeof(Action{object, object});
s_typeOfSingle | Cache of typeof(Single)
s_typeOfString | Cache of typeof(String)
s_typeOfStringArray | Cache of typeof(String[])
s_typeOfTimeSpan | Cache of typeof(TimeSpan)
s_typeOfType | Cache of typeof(Type)
s_typeOfTypeArray | Cache of typeof(Type[])
s_typeOfTypeVersionArray | Cache of typeof(TypeVersion[])
s_typeOfUInt16 | Cache of typeof(UInt16)
s_typeOfUInt32 | Cache of typeof(UInt32)
s_typeOfUInt64 | Cache of typeof(UInt64)
s_typeOfUniqueConstraint | Cache of typeof(UniqueConstraint)
s_typeOfUseOidShort | Cache of typeof(UseOidShort)
s_typeOfValueType | Cache of typeof(ValueType)
s_typeOfVelocityDbComparer | Cache of typeof(VelocityDbComparerKey)
s_typeOfVelocityDbList | Cache of typeof(VelocityDbListT)
s_typeOfVelocityDbListOidShort | Cache of typeof(VelocityDbListOidShortT)
s_typeOfWeakIOptimizedPersistableReference | Cache of typeof(WeakIOptimizedPersistableReference)
s_typeOfWeakIOptimizedPersistableReferenceBase | Cache of typeof(WeakIOptimizedPersistableReferenceBase)
s_typeOfWeakReferenceList | Cache of typeof(WeakReferenceListT)
s_typeOfWeakShortReferenceList | Cache of typeof(WeakShortReferenceListT)
Top
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfBoolean Field

CommonTypess_sizeOfBoolean Field

Cache of sizeof(Boolean)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfBoolean
Public Shared ReadOnly s_sizeOfBoolean As UShort
public:
static initonly unsigned short s_sizeOfBoolean
static val s_sizeOfBoolean: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfByte Field

CommonTypess_sizeOfByte Field

Cache of sizeof(Byte)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfByte
Public Shared ReadOnly s_sizeOfByte As UShort
public:
static initonly unsigned short s_sizeOfByte
static val s_sizeOfByte: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfChar Field

CommonTypess_sizeOfChar Field

Cache of sizeof(Char)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfChar
Public Shared ReadOnly s_sizeOfChar As UShort
public:
static initonly unsigned short s_sizeOfChar
static val s_sizeOfChar: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfDecimal Field

CommonTypess_sizeOfDecimal Field

Cache of sizeof(Decimal)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfDecimal
Public Shared ReadOnly s_sizeOfDecimal As UShort
public:
static initonly unsigned short s_sizeOfDecimal
static val s_sizeOfDecimal: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfDouble Field

CommonTypess_sizeOfDouble Field

Cache of sizeof(Double)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfDouble
Public Shared ReadOnly s_sizeOfDouble As UShort
public:
static initonly unsigned short s_sizeOfDouble
static val s_sizeOfDouble: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfInt16 Field

CommonTypess_sizeOfInt16 Field

Cache of sizeof(Int16)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfInt16
Public Shared ReadOnly s_sizeOfInt16 As UShort
public:
static initonly unsigned short s_sizeOfInt16
static val s_sizeOfInt16: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfInt32 Field

CommonTypess_sizeOfInt32 Field

Cache of sizeof(Int32)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfInt32
Public Shared ReadOnly s_sizeOfInt32 As UShort
public:
static initonly unsigned short s_sizeOfInt32
static val s_sizeOfInt32: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfInt64 Field

CommonTypess_sizeOfInt64 Field

Cache of sizeof(Int64)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfInt64
Public Shared ReadOnly s_sizeOfInt64 As UShort
public:
static initonly unsigned short s_sizeOfInt64
static val s_sizeOfInt64: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfSByte Field

CommonTypess_sizeOfSByte Field

Cache of sizeof(SByte)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfSByte
Public Shared ReadOnly s_sizeOfSByte As UShort
public:
static initonly unsigned short s_sizeOfSByte
static val s_sizeOfSByte: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfSingle Field

CommonTypess_sizeOfSingle Field

Cache of sizeof(Single)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfSingle
Public Shared ReadOnly s_sizeOfSingle As UShort
public:
static initonly unsigned short s_sizeOfSingle
static val s_sizeOfSingle: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfUInt16 Field

CommonTypess_sizeOfUInt16 Field

Cache of sizeof(UInt16)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfUInt16
Public Shared ReadOnly s_sizeOfUInt16 As UShort
public:
static initonly unsigned short s_sizeOfUInt16
static val s_sizeOfUInt16: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfUInt32 Field

CommonTypess_sizeOfUInt32 Field

Cache of sizeof(UInt32)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfUInt32
Public Shared ReadOnly s_sizeOfUInt32 As UShort
public:
static initonly unsigned short s_sizeOfUInt32
static val s_sizeOfUInt32: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_sizeOfUInt64 Field

CommonTypess_sizeOfUInt64 Field

Cache of sizeof(UInt64)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_sizeOfUInt64
Public Shared ReadOnly s_sizeOfUInt64 As UShort
public:
static initonly unsigned short s_sizeOfUInt64
static val s_sizeOfUInt64: uint16

Field Value

Type: UInt16
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfArray Field

CommonTypess_typeOfArray Field

Cache of typeof(Array)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfArray
Public Shared ReadOnly s_typeOfArray As Type
public:
static initonly Type^ s_typeOfArray
static val s_typeOfArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfArrayList Field

CommonTypess_typeOfArrayList Field

Cache of typeof(ArrayList)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfArrayList
Public Shared ReadOnly s_typeOfArrayList As Type
public:
static initonly Type^ s_typeOfArrayList
static val s_typeOfArrayList: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBoolean Field

CommonTypess_typeOfBoolean Field

Cache of typeof(Boolean)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBoolean
Public Shared ReadOnly s_typeOfBoolean As Type
public:
static initonly Type^ s_typeOfBoolean
static val s_typeOfBoolean: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeInternal Field

CommonTypess_typeOfBTreeInternal Field

Cache of typeof(BTreeInternalKey, Value)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeInternal
Public Shared ReadOnly s_typeOfBTreeInternal As Type
public:
static initonly Type^ s_typeOfBTreeInternal
static val s_typeOfBTreeInternal: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeInternalOidShort Field

CommonTypess_typeOfBTreeInternalOidShort Field

Cache of typeof(BTreeInternalOidShort)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeInternalOidShort
Public Shared ReadOnly s_typeOfBTreeInternalOidShort As Type
public:
static initonly Type^ s_typeOfBTreeInternalOidShort
static val s_typeOfBTreeInternalOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeLeaf Field

CommonTypess_typeOfBTreeLeaf Field

Cache of typeof(BTreeLeafKey, Value)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeLeaf
Public Shared ReadOnly s_typeOfBTreeLeaf As Type
public:
static initonly Type^ s_typeOfBTreeLeaf
static val s_typeOfBTreeLeaf: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeLeafBase Field

CommonTypess_typeOfBTreeLeafBase Field

Cache of typeof(BTreeLeafBaseKey, Value)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeLeafBase
Public Shared ReadOnly s_typeOfBTreeLeafBase As Type
public:
static initonly Type^ s_typeOfBTreeLeafBase
static val s_typeOfBTreeLeafBase: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeLeafOidShort Field

CommonTypess_typeOfBTreeLeafOidShort Field

Cache of typeof(BTreeLeafOidShort)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeLeafOidShort
Public Shared ReadOnly s_typeOfBTreeLeafOidShort As Type
public:
static initonly Type^ s_typeOfBTreeLeafOidShort
static val s_typeOfBTreeLeafOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeMap Field

CommonTypess_typeOfBTreeMap Field

Cache of typeof(BTreeMapKey, Value)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeMap
Public Shared ReadOnly s_typeOfBTreeMap As Type
public:
static initonly Type^ s_typeOfBTreeMap
static val s_typeOfBTreeMap: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeMapOidShort Field

CommonTypess_typeOfBTreeMapOidShort Field

Cache of typeof(BTreeMapOidShortKey, Value)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeMapOidShort
Public Shared ReadOnly s_typeOfBTreeMapOidShort As Type
public:
static initonly Type^ s_typeOfBTreeMapOidShort
static val s_typeOfBTreeMapOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeSet Field

CommonTypess_typeOfBTreeSet Field

Cache of typeof(BTreeSetKey)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeSet
Public Shared ReadOnly s_typeOfBTreeSet As Type
public:
static initonly Type^ s_typeOfBTreeSet
static val s_typeOfBTreeSet: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfBTreeSetOidShort Field

CommonTypess_typeOfBTreeSetOidShort Field

Cache of typeof(BTreeSetOidShortKey)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfBTreeSetOidShort
Public Shared ReadOnly s_typeOfBTreeSetOidShort As Type
public:
static initonly Type^ s_typeOfBTreeSetOidShort
static val s_typeOfBTreeSetOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfByte Field

CommonTypess_typeOfByte Field

Cache of typeof(Byte)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfByte
Public Shared ReadOnly s_typeOfByte As Type
public:
static initonly Type^ s_typeOfByte
static val s_typeOfByte: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfByteArray Field

CommonTypess_typeOfByteArray Field

Cache of typeof(Byte[])

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfByteArray
Public Shared ReadOnly s_typeOfByteArray As Type
public:
static initonly Type^ s_typeOfByteArray
static val s_typeOfByteArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfChar Field

CommonTypess_typeOfChar Field

Cache of typeof(Char)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfChar
Public Shared ReadOnly s_typeOfChar As Type
public:
static initonly Type^ s_typeOfChar
static val s_typeOfChar: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfCompareByFieldIndex Field

CommonTypess_typeOfCompareByFieldIndex Field

Cache of typeof(CompareByFieldIndex)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfCompareByFieldIndex
Public Shared ReadOnly s_typeOfCompareByFieldIndex As Type
public:
static initonly Type^ s_typeOfCompareByFieldIndex
static val s_typeOfCompareByFieldIndex: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfDataForISerializable Field

CommonTypess_typeOfDataForISerializable Field

Cache of typeof(DataForISerializable)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfDataForISerializable
Public Shared ReadOnly s_typeOfDataForISerializable As Type
public:
static initonly Type^ s_typeOfDataForISerializable
static val s_typeOfDataForISerializable: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfDateTime Field

CommonTypess_typeOfDateTime Field

Cache of typeof(DateTime)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfDateTime
Public Shared ReadOnly s_typeOfDateTime As Type
public:
static initonly Type^ s_typeOfDateTime
static val s_typeOfDateTime: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfDecimal Field

CommonTypess_typeOfDecimal Field

Cache of typeof(Decimal)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfDecimal
Public Shared ReadOnly s_typeOfDecimal As Type
public:
static initonly Type^ s_typeOfDecimal
static val s_typeOfDecimal: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfDelegate Field

CommonTypess_typeOfDelegate Field

Cache of typeof(Delegate)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfDelegate
Public Shared ReadOnly s_typeOfDelegate As Type
public:
static initonly Type^ s_typeOfDelegate
static val s_typeOfDelegate: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfDouble Field

CommonTypess_typeOfDouble Field

Cache of typeof(Double)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfDouble
Public Shared ReadOnly s_typeOfDouble As Type
public:
static initonly Type^ s_typeOfDouble
static val s_typeOfDouble: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfEmbed Field

CommonTypess_typeOfEmbed Field

Cache of typeof(Embed)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfEmbed
Public Shared ReadOnly s_typeOfEmbed As Type
public:
static initonly Type^ s_typeOfEmbed
static val s_typeOfEmbed: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfFunc Field

CommonTypess_typeOfFunc Field

Cache of typeof(Func{})

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfFunc
Public Shared ReadOnly s_typeOfFunc As Type
public:
static initonly Type^ s_typeOfFunc
static val s_typeOfFunc: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfGetHandler Field

CommonTypess_typeOfGetHandler Field

Cache of typeof(Func{object, object});

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfGetHandler
Public Shared ReadOnly s_typeOfGetHandler As Type
public:
static initonly Type^ s_typeOfGetHandler
static val s_typeOfGetHandler: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfGuid Field

CommonTypess_typeOfGuid Field

Cache of typeof(Guid)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfGuid
Public Shared ReadOnly s_typeOfGuid As Type
public:
static initonly Type^ s_typeOfGuid
static val s_typeOfGuid: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfIndex Field

CommonTypess_typeOfIndex Field

Cache of typeof(Index)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfIndex
Public Shared ReadOnly s_typeOfIndex As Type
public:
static initonly Type^ s_typeOfIndex
static val s_typeOfIndex: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfIndexStringByHashCode Field

CommonTypess_typeOfIndexStringByHashCode Field

Cache of typeof(IndexStringByHashCode)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfIndexStringByHashCode
Public Shared ReadOnly s_typeOfIndexStringByHashCode As Type
public:
static initonly Type^ s_typeOfIndexStringByHashCode
static val s_typeOfIndexStringByHashCode: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfInt16 Field

CommonTypess_typeOfInt16 Field

Cache of typeof(Int16)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfInt16
Public Shared ReadOnly s_typeOfInt16 As Type
public:
static initonly Type^ s_typeOfInt16
static val s_typeOfInt16: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfInt32 Field

CommonTypess_typeOfInt32 Field

Cache of typeof(Int32)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfInt32
Public Shared ReadOnly s_typeOfInt32 As Type
public:
static initonly Type^ s_typeOfInt32
static val s_typeOfInt32: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfInt64 Field

CommonTypess_typeOfInt64 Field

Cache of typeof(Int64)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfInt64
Public Shared ReadOnly s_typeOfInt64 As Type
public:
static initonly Type^ s_typeOfInt64
static val s_typeOfInt64: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfIOptimizedPersistable Field

CommonTypess_typeOfIOptimizedPersistable Field

Cache of typeof(IOptimizedPersistable)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfIOptimizedPersistable
Public Shared ReadOnly s_typeOfIOptimizedPersistable As Type
public:
static initonly Type^ s_typeOfIOptimizedPersistable
static val s_typeOfIOptimizedPersistable: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfISet Field

CommonTypess_typeOfISet Field

Cache of typeof(ISetT)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfISet
Public Shared ReadOnly s_typeOfISet As Type
public:
static initonly Type^ s_typeOfISet
static val s_typeOfISet: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfList Field

CommonTypess_typeOfList Field

Cache of typeof(List{})

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfList
Public Shared ReadOnly s_typeOfList As Type
public:
static initonly Type^ s_typeOfList
static val s_typeOfList: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfLong Field

CommonTypess_typeOfLong Field

Cache of typeof(Int64)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfLong
Public Shared ReadOnly s_typeOfLong As Type
public:
static initonly Type^ s_typeOfLong
static val s_typeOfLong: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfNonSerializedAttribute Field

CommonTypess_typeOfNonSerializedAttribute Field

Cache of typeof(NonSerializedAttribute)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfNonSerializedAttribute
Public Shared ReadOnly s_typeOfNonSerializedAttribute As Type
public:
static initonly Type^ s_typeOfNonSerializedAttribute
static val s_typeOfNonSerializedAttribute: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfNullable Field

CommonTypess_typeOfNullable Field

Cache of typeof(Nullable)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfNullable
Public Shared ReadOnly s_typeOfNullable As Type
public:
static initonly Type^ s_typeOfNullable
static val s_typeOfNullable: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfObject Field

CommonTypess_typeOfObject Field

Cache of typeof(Object)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfObject
Public Shared ReadOnly s_typeOfObject As Type
public:
static initonly Type^ s_typeOfObject
static val s_typeOfObject: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfObjectActivator Field

CommonTypess_typeOfObjectActivator Field

Cache of typeof(ObjectActivator)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfObjectActivator
Public Shared ReadOnly s_typeOfObjectActivator As Type
public:
static initonly Type^ s_typeOfObjectActivator
static val s_typeOfObjectActivator: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfObjectArray Field

CommonTypess_typeOfObjectArray Field

Cache of typeof(Object[])

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfObjectArray
Public Shared ReadOnly s_typeOfObjectArray As Type
public:
static initonly Type^ s_typeOfObjectArray
static val s_typeOfObjectArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfOid Field

CommonTypess_typeOfOid Field

Cache of typeof(Oid)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfOid
Public Shared ReadOnly s_typeOfOid As Type
public:
static initonly Type^ s_typeOfOid
static val s_typeOfOid: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfOidShort Field

CommonTypess_typeOfOidShort Field

Cache of typeof(OidShort)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfOidShort
Public Shared ReadOnly s_typeOfOidShort As Type
public:
static initonly Type^ s_typeOfOidShort
static val s_typeOfOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfOnePerDatabase Field

CommonTypess_typeOfOnePerDatabase Field

Cache of typeof(OnePerDatabase)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfOnePerDatabase
Public Shared ReadOnly s_typeOfOnePerDatabase As Type
public:
static initonly Type^ s_typeOfOnePerDatabase
static val s_typeOfOnePerDatabase: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfOptimizedPersistable Field

CommonTypess_typeOfOptimizedPersistable Field

Cache of typeof(OptimizedPersistable)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfOptimizedPersistable
Public Shared ReadOnly s_typeOfOptimizedPersistable As Type
public:
static initonly Type^ s_typeOfOptimizedPersistable
static val s_typeOfOptimizedPersistable: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfSByte Field

CommonTypess_typeOfSByte Field

Cache of typeof(SByte)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfSByte
Public Shared ReadOnly s_typeOfSByte As Type
public:
static initonly Type^ s_typeOfSByte
static val s_typeOfSByte: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfSchema Field

CommonTypess_typeOfSchema Field

Cache of typeof(Schema)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfSchema
Public Shared ReadOnly s_typeOfSchema As Type
public:
static initonly Type^ s_typeOfSchema
static val s_typeOfSchema: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfSessionBase Field

CommonTypess_typeOfSessionBase Field

Cache of typeof(SessionBase)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfSessionBase
Public Shared ReadOnly s_typeOfSessionBase As Type
public:
static initonly Type^ s_typeOfSessionBase
static val s_typeOfSessionBase: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfSetHandler Field

CommonTypess_typeOfSetHandler Field

Cache of typeof(Action{object, object});

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfSetHandler
Public Shared ReadOnly s_typeOfSetHandler As Type
public:
static initonly Type^ s_typeOfSetHandler
static val s_typeOfSetHandler: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfSingle Field

CommonTypess_typeOfSingle Field

Cache of typeof(Single)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfSingle
Public Shared ReadOnly s_typeOfSingle As Type
public:
static initonly Type^ s_typeOfSingle
static val s_typeOfSingle: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfString Field

CommonTypess_typeOfString Field

Cache of typeof(String)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfString
Public Shared ReadOnly s_typeOfString As Type
public:
static initonly Type^ s_typeOfString
static val s_typeOfString: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfStringArray Field

CommonTypess_typeOfStringArray Field

Cache of typeof(String[])

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfStringArray
Public Shared ReadOnly s_typeOfStringArray As Type
public:
static initonly Type^ s_typeOfStringArray
static val s_typeOfStringArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfTimeSpan Field

CommonTypess_typeOfTimeSpan Field

Cache of typeof(TimeSpan)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfTimeSpan
Public Shared ReadOnly s_typeOfTimeSpan As Type
public:
static initonly Type^ s_typeOfTimeSpan
static val s_typeOfTimeSpan: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfType Field

CommonTypess_typeOfType Field

Cache of typeof(Type)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfType
Public Shared ReadOnly s_typeOfType As Type
public:
static initonly Type^ s_typeOfType
static val s_typeOfType: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfTypeArray Field

CommonTypess_typeOfTypeArray Field

Cache of typeof(Type[])

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfTypeArray
Public Shared ReadOnly s_typeOfTypeArray As Type
public:
static initonly Type^ s_typeOfTypeArray
static val s_typeOfTypeArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfTypeVersionArray Field

CommonTypess_typeOfTypeVersionArray Field

Cache of typeof(TypeVersion[])

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfTypeVersionArray
Public Shared ReadOnly s_typeOfTypeVersionArray As Type
public:
static initonly Type^ s_typeOfTypeVersionArray
static val s_typeOfTypeVersionArray: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfUInt16 Field

CommonTypess_typeOfUInt16 Field

Cache of typeof(UInt16)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfUInt16
Public Shared ReadOnly s_typeOfUInt16 As Type
public:
static initonly Type^ s_typeOfUInt16
static val s_typeOfUInt16: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfUInt32 Field

CommonTypess_typeOfUInt32 Field

Cache of typeof(UInt32)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfUInt32
Public Shared ReadOnly s_typeOfUInt32 As Type
public:
static initonly Type^ s_typeOfUInt32
static val s_typeOfUInt32: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfUInt64 Field

CommonTypess_typeOfUInt64 Field

Cache of typeof(UInt64)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfUInt64
Public Shared ReadOnly s_typeOfUInt64 As Type
public:
static initonly Type^ s_typeOfUInt64
static val s_typeOfUInt64: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfUniqueConstraint Field

CommonTypess_typeOfUniqueConstraint Field

Cache of typeof(UniqueConstraint)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfUniqueConstraint
Public Shared ReadOnly s_typeOfUniqueConstraint As Type
public:
static initonly Type^ s_typeOfUniqueConstraint
static val s_typeOfUniqueConstraint: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfUseOidShort Field

CommonTypess_typeOfUseOidShort Field

Cache of typeof(UseOidShort)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfUseOidShort
Public Shared ReadOnly s_typeOfUseOidShort As Type
public:
static initonly Type^ s_typeOfUseOidShort
static val s_typeOfUseOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfValueType Field

CommonTypess_typeOfValueType Field

Cache of typeof(ValueType)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfValueType
Public Shared ReadOnly s_typeOfValueType As Type
public:
static initonly Type^ s_typeOfValueType
static val s_typeOfValueType: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfVelocityDbComparer Field

CommonTypess_typeOfVelocityDbComparer Field

Cache of typeof(VelocityDbComparerKey)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfVelocityDbComparer
Public Shared ReadOnly s_typeOfVelocityDbComparer As Type
public:
static initonly Type^ s_typeOfVelocityDbComparer
static val s_typeOfVelocityDbComparer: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfVelocityDbList Field

CommonTypess_typeOfVelocityDbList Field

Cache of typeof(VelocityDbListT)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfVelocityDbList
Public Shared ReadOnly s_typeOfVelocityDbList As Type
public:
static initonly Type^ s_typeOfVelocityDbList
static val s_typeOfVelocityDbList: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfVelocityDbListOidShort Field

CommonTypess_typeOfVelocityDbListOidShort Field

Cache of typeof(VelocityDbListOidShortT)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfVelocityDbListOidShort
Public Shared ReadOnly s_typeOfVelocityDbListOidShort As Type
public:
static initonly Type^ s_typeOfVelocityDbListOidShort
static val s_typeOfVelocityDbListOidShort: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfWeakIOptimizedPersistableReference Field

CommonTypess_typeOfWeakIOptimizedPersistableReference Field

Cache of typeof(WeakIOptimizedPersistableReference)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfWeakIOptimizedPersistableReference
Public Shared ReadOnly s_typeOfWeakIOptimizedPersistableReference As Type
public:
static initonly Type^ s_typeOfWeakIOptimizedPersistableReference
static val s_typeOfWeakIOptimizedPersistableReference: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfWeakIOptimizedPersistableReferenceBase Field

CommonTypess_typeOfWeakIOptimizedPersistableReferenceBase Field

Cache of typeof(WeakIOptimizedPersistableReferenceBase)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfWeakIOptimizedPersistableReferenceBase
Public Shared ReadOnly s_typeOfWeakIOptimizedPersistableReferenceBase As Type
public:
static initonly Type^ s_typeOfWeakIOptimizedPersistableReferenceBase
static val s_typeOfWeakIOptimizedPersistableReferenceBase: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfWeakReferenceList Field

CommonTypess_typeOfWeakReferenceList Field

Cache of typeof(WeakReferenceListT)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfWeakReferenceList
Public Shared ReadOnly s_typeOfWeakReferenceList As Type
public:
static initonly Type^ s_typeOfWeakReferenceList
static val s_typeOfWeakReferenceList: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


CommonTypes.s_typeOfWeakShortReferenceList Field

CommonTypess_typeOfWeakShortReferenceList Field

Cache of typeof(WeakShortReferenceListT)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly Type s_typeOfWeakShortReferenceList
Public Shared ReadOnly s_typeOfWeakShortReferenceList As Type
public:
static initonly Type^ s_typeOfWeakShortReferenceList
static val s_typeOfWeakShortReferenceList: Type

Field Value

Type: Type
See Also

Reference

CommonTypes Class
VelocityDb.TypeInfo Namespace


DataMember Class

Info about a data Field of a persistent object
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoDataMember

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DataMember : OptimizedPersistable, IEquatable<DataMember>
<SerializableAttribute>
Public Class DataMember
    Inherits OptimizedPersistable
    Implements IEquatable(Of DataMember)
[SerializableAttribute]
public ref class DataMember : public OptimizedPersistable,
    IEquatable<DataMember^>
[<SerializableAttribute>]
type DataMember =
    class
        inherit OptimizedPersistable
        interface IEquatable<DataMember>
    end

The DataMember type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Field | The managed field
Public property | FieldName | Name of managed field
Public property | FieldType | Declared Type of this field
Public property | GetTypeCode | Get the type code for a field
Public property | HasId | Does this field have an Oid?
Public property | IsGuid | true if field is of type Guid
Public property | IsInterface | true if field is if type interface
Public property | WeakIOptimizedPersistableReference | Is this field a VelocityDb.WeakIOptimizedPersistableReference
Top
Methods
 | Name | Description
 | DecodeToArray | Used by code generator for reading objects.
 | DecodeToString | Used by code generator.
Public method | Equals | Determines whether two DataMember instances are equal.
Public method | GetField | Get FieldInfo for the fields VelocityDB cares about
Public method | GetMemberValue | Gets the value of a member within a specified object
 | GetTypeFromAnyAssemblyVersion | Load type using GetType(String), and if fails, attempt to load same type from an assembly by assembly name, without specifying assembly version or any other part of the signature
Public method | InitializeAfterRead | Sets up some transient fields (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
 | isNull | Determines if given bytes represents null
 | isShortOidNull | Determines if given bytes represent a null short reference
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | SetMemberValue | Sets the value of a field within an object
Public method | SetMemberValueWithPossibleConvert | Internal Use and in VelocityDBExtensions
 | StringToType | Used by code generator.
Public method | ToString | Override to provide more internal info in browser (Overrides OptimizedPersistableToString.)
 | TypeToString | Converts a type to a string the way VelocityDB represents it internally
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


DataMember Properties

The DataMember type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Field | The managed field
Public property | FieldName | Name of managed field
Public property | FieldType | Declared Type of this field
Public property | GetTypeCode | Get the type code for a field
Public property | HasId | Does this field have an Oid?
Public property | IsGuid | true if field is of type Guid
Public property | IsInterface | true if field is if type interface
Public property | WeakIOptimizedPersistableReference | Is this field a VelocityDb.WeakIOptimizedPersistableReference
Top
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.AllowOtherTypesOnSamePage Property

DataMemberAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.Field Property

DataMemberField Property

The managed field

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FieldInfo Field { get; }
Public ReadOnly Property Field As FieldInfo
    Get
public:
property FieldInfo^ Field {
    FieldInfo^ get ();
}
member Field : FieldInfo with get

Property Value

Type: FieldInfo
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.FieldName Property

DataMemberFieldName Property

Name of managed field

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Property Value

Type: String
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.FieldType Property

DataMemberFieldType Property

Declared Type of this field

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Type FieldType { get; }
Public ReadOnly Property FieldType As Type
    Get
public:
property Type^ FieldType {
    Type^ get ();
}
member FieldType : Type with get

Property Value

Type: Type
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.GetTypeCode Property

DataMemberGetTypeCode Property

Get the type code for a field

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeCode GetTypeCode { get; }
Public ReadOnly Property GetTypeCode As TypeCode
    Get
public:
property TypeCode GetTypeCode {
    TypeCode get ();
}
member GetTypeCode : TypeCode with get

Property Value

Type: TypeCode
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.HasId Property

DataMemberHasId Property

Does this field have an Oid?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool HasId { get; }
Public ReadOnly Property HasId As Boolean
    Get
public:
property bool HasId {
    bool get ();
}
member HasId : bool with get

Property Value

Type: Boolean
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.IsGuid Property

DataMemberIsGuid Property

true if field is of type Guid

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsGuid { get; }
Public ReadOnly Property IsGuid As Boolean
    Get
public:
property bool IsGuid {
    bool get ();
}
member IsGuid : bool with get

Property Value

Type: Boolean
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.IsInterface Property

DataMemberIsInterface Property

true if field is if type interface

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsInterface { get; }
Public ReadOnly Property IsInterface As Boolean
    Get
public:
property bool IsInterface {
    bool get ();
}
member IsInterface : bool with get

Property Value

Type: Boolean
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.WeakIOptimizedPersistableReference Property

DataMemberWeakIOptimizedPersistableReference Property

Is this field a VelocityDb.WeakIOptimizedPersistableReference

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool WeakIOptimizedPersistableReference { get; }
Public ReadOnly Property WeakIOptimizedPersistableReference As Boolean
    Get
public:
property bool WeakIOptimizedPersistableReference {
    bool get ();
}
member WeakIOptimizedPersistableReference : bool with get

Property Value

Type: Boolean
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember Methods

The DataMember type exposes the following members.

Methods
 | Name | Description
 | DecodeToArray | Used by code generator for reading objects.
 | DecodeToString | Used by code generator.
Public method | Equals | Determines whether two DataMember instances are equal.
Public method | GetField | Get FieldInfo for the fields VelocityDB cares about
Public method | GetMemberValue | Gets the value of a member within a specified object
 | GetTypeFromAnyAssemblyVersion | Load type using GetType(String), and if fails, attempt to load same type from an assembly by assembly name, without specifying assembly version or any other part of the signature
Public method | InitializeAfterRead | Sets up some transient fields (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
 | isNull | Determines if given bytes represents null
 | isShortOidNull | Determines if given bytes represent a null short reference
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | SetMemberValue | Sets the value of a field within an object
Public method | SetMemberValueWithPossibleConvert | Internal Use and in VelocityDBExtensions
 | StringToType | Used by code generator.
Public method | ToString | Override to provide more internal info in browser (Overrides OptimizedPersistableToString.)
 | TypeToString | Converts a type to a string the way VelocityDB represents it internally
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.DecodeToArray Method

DataMemberDecodeToArray Method

Used by code generator for reading objects.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Object DecodeToArray(
    byte[] memberBytes,
    Type type,
    ref int offset,
    IOptimizedPersistable o,
    Page page,
    bool useOidShort,
    bool openRefs,
    Schema schema,
    SessionBase session,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly,
    bool embed
)
Public Shared Function DecodeToArray (
    memberBytes As Byte(),
    type As Type,
    ByRef offset As Integer,
    o As IOptimizedPersistable,
    page As Page,
    useOidShort As Boolean,
    openRefs As Boolean,
    schema As Schema,
    session As SessionBase,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean,
    embed As Boolean
) As Object
public:
static Object^ DecodeToArray(
    array<unsigned char>^ memberBytes,
    Type^ type,
    int% offset,
    IOptimizedPersistable^ o,
    Page^ page,
    bool useOidShort,
    bool openRefs,
    Schema^ schema,
    SessionBase^ session,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly,
    bool embed
)
static member DecodeToArray :
        memberBytes : byte[] *
        type : Type *
        offset : int byref *
        o : IOptimizedPersistable *
        page : Page *
        useOidShort : bool *
        openRefs : bool *
        schema : Schema *
        session : SessionBase *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool *
        embed : bool -> Object

Parameters

memberBytes
Type: SystemByte
Bytes of the object to be read
type
Type: SystemType
The Type of the array.
offset
Type: SystemInt32
Current offset into array of bytes
o
Type: VelocityDbIOptimizedPersistable
Object containing the array
page
Type: VelocityDbPage
The Page that the array belongs to.
useOidShort
Type: SystemBoolean
Use short id (page-slot) for object references
openRefs
Type: SystemBoolean
Open referenced objects?
schema
Type: VelocityDb.TypeInfoSchema
The active Schema
session
Type: VelocityDb.SessionSessionBase
The active session to use
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
Keeps track of fields to load
graphDepth
Type: SystemInt32
Current graph depth
graphDepthToLoad
Type: SystemInt32
How many levels to load
primitivesOnly
Type: SystemBoolean
Load only primitive fields>
embed
Type: SystemBoolean

[Missing <param name="embed"/> documentation for "M:VelocityDb.TypeInfo.DataMember.DecodeToArray(System.Byte[],System.Type,System.Int32@,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean,System.Boolean,VelocityDb.TypeInfo.Schema,VelocityDb.Session.SessionBase,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean,System.Boolean)"]

Return Value

Type: Object
The decoded array
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.DecodeToString Method

DataMemberDecodeToString Method

Used by code generator.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string DecodeToString(
    byte[] member,
    ref int offset,
    int numberOfBytes
)
Public Shared Function DecodeToString (
    member As Byte(),
    ByRef offset As Integer,
    numberOfBytes As Integer
) As String
public:
static String^ DecodeToString(
    array<unsigned char>^ member,
    int% offset,
    int numberOfBytes
)
static member DecodeToString :
        member : byte[] *
        offset : int byref *
        numberOfBytes : int -> string

Parameters

member
Type: SystemByte
Bytes for an object field
offset
Type: SystemInt32
Offset into bytes
numberOfBytes
Type: SystemInt32
Length of field

Return Value

Type: String
A string representing the field value
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.Equals Method

DataMemberEquals Method

Determines whether two DataMember instances are equal.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    DataMember other
)
Public Function Equals (
    other As DataMember
) As Boolean
public:
virtual bool Equals(
    DataMember^ other
) sealed
abstract Equals :
        other : DataMember -> bool
override Equals :
        other : DataMember -> bool

Parameters

other
Type: VelocityDb.TypeInfoDataMember
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified DataMember is equal to the current DataMember; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.GetField Method

DataMemberGetField Method

Get FieldInfo for the fields VelocityDB cares about

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FieldInfo GetField(
    Type t
)
Public Function GetField (
    t As Type
) As FieldInfo
public:
FieldInfo^ GetField(
    Type^ t
)
member GetField :
        t : Type -> FieldInfo

Parameters

t
Type: SystemType
The type we are requesting it for

Return Value

Type: FieldInfo
FieldInfo for the fields VelocityDB cares about
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.GetMemberValue Method

DataMemberGetMemberValue Method

Gets the value of a member within a specified object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object GetMemberValue(
    Object obj
)
Public Function GetMemberValue (
    obj As Object
) As Object
public:
Object^ GetMemberValue(
    Object^ obj
)
member GetMemberValue :
        obj : Object -> Object

Parameters

obj
Type: SystemObject
The object containing the field

Return Value

Type: Object
The value of the field
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.GetTypeFromAnyAssemblyVersion Method

DataMemberGetTypeFromAnyAssemblyVersion Method

Load type using GetType(String), and if fails, attempt to load same type from an assembly by assembly name, without specifying assembly version or any other part of the signature

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Type GetTypeFromAnyAssemblyVersion(
    string typeName
)
Public Shared Function GetTypeFromAnyAssemblyVersion (
    typeName As String
) As Type
public:
static Type^ GetTypeFromAnyAssemblyVersion(
    String^ typeName
)
static member GetTypeFromAnyAssemblyVersion :
        typeName : string -> Type

Parameters

typeName
Type: SystemString
The assembly-qualified name of the type to get. See System.Type.AssemblyQualifiedName. If the type is in the currently executing assembly or in Mscorlib.dll, it is sufficient to supply the type name qualified by its namespace.

Return Value

Type: Type
A Type as decoded from String.
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.InitializeAfterRead Method

DataMemberInitializeAfterRead Method

Sets up some transient fields

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The session managing this object.

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.isNull Method

DataMemberisNull Method

Determines if given bytes represents null

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool isNull(
    byte[] memberBytes,
    int offset
)
Public Shared Function isNull (
    memberBytes As Byte(),
    offset As Integer
) As Boolean
public:
static bool isNull(
    array<unsigned char>^ memberBytes,
    int offset
)
static member isNull :
        memberBytes : byte[] *
        offset : int -> bool

Parameters

memberBytes
Type: SystemByte
bytes to check
offset
Type: SystemInt32
offset into bytes

Return Value

Type: Boolean
true if bytes represent null; otherwise false
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.isShortOidNull Method

DataMemberisShortOidNull Method

Determines if given bytes represent a null short reference

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static bool isShortOidNull(
    byte[] memberBytes,
    int offset
)
Public Shared Function isShortOidNull (
    memberBytes As Byte(),
    offset As Integer
) As Boolean
public:
static bool isShortOidNull(
    array<unsigned char>^ memberBytes,
    int offset
)
static member isShortOidNull :
        memberBytes : byte[] *
        offset : int -> bool

Parameters

memberBytes
Type: SystemByte
bytes to check
offset
Type: SystemInt32
offset into bytes

Return Value

Type: Boolean
true if bytes represent null; otherwise false
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.ReadMe Method

DataMemberReadMe Method

Used by code generator

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.TypeInfo.DataMember.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.SetMemberValue Method

DataMemberSetMemberValue Method

Sets the value of a field within an object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetMemberValue(
    Object obj,
    Object value
)
Public Sub SetMemberValue (
    obj As Object,
    value As Object
)
public:
void SetMemberValue(
    Object^ obj,
    Object^ value
)
member SetMemberValue :
        obj : Object *
        value : Object -> unit

Parameters

obj
Type: SystemObject
Object to set field value for
value
Type: SystemObject
The field value
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.SetMemberValueWithPossibleConvert Method

DataMemberSetMemberValueWithPossibleConvert Method

Internal Use and in VelocityDBExtensions

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetMemberValueWithPossibleConvert(
    Object obj,
    Object value
)
Public Sub SetMemberValueWithPossibleConvert (
    obj As Object,
    value As Object
)
public:
void SetMemberValueWithPossibleConvert(
    Object^ obj,
    Object^ value
)
member SetMemberValueWithPossibleConvert :
        obj : Object *
        value : Object -> unit

Parameters

obj
Type: SystemObject
Object for which to set a value
value
Type: SystemObject
Value to set to
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.StringToType Method

DataMemberStringToType Method

Used by code generator.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Type StringToType(
    string typeAsString,
    SessionBase session,
    out bool typeUpdated
)
Public Shared Function StringToType (
    typeAsString As String,
    session As SessionBase,
    <OutAttribute> ByRef typeUpdated As Boolean
) As Type
public:
static Type^ StringToType(
    String^ typeAsString,
    SessionBase^ session,
    [OutAttribute] bool% typeUpdated
)
static member StringToType :
        typeAsString : string *
        session : SessionBase *
        typeUpdated : bool byref -> Type

Parameters

typeAsString
Type: SystemString
A Type encoded as a String.
session
Type: VelocityDb.SessionSessionBase
The active session
typeUpdated
Type: SystemBoolean
Was a Type change detected?

Return Value

Type: Type
Decoded Type.
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.ToString Method

DataMemberToString Method

Override to provide more internal info in browser

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
"DataMember " + fieldName + " " + Oid.AsString(id)
See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


DataMember.TypeToString Method

DataMemberTypeToString Method

Converts a type to a string the way VelocityDB represents it internally

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string TypeToString(
    Type type
)
Public Shared Function TypeToString (
    type As Type
) As String
public:
static String^ TypeToString(
    Type^ type
)
static member TypeToString :
        type : Type -> string

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:VelocityDb.TypeInfo.DataMember.TypeToString(System.Type)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDb.TypeInfo.DataMember.TypeToString(System.Type)"]

See Also

Reference

DataMember Class
VelocityDb.TypeInfo Namespace


FieldAccessor Class

A field attribute that controls how many objects that will be placed on the same page as the object of the field.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.TypeInfoFieldAccessor

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class FieldAccessor : Attribute
Public NotInheritable Class FieldAccessor
    Inherits Attribute
public ref class FieldAccessor sealed : public Attribute
[<SealedAttribute>]
type FieldAccessor =
    class
        inherit Attribute
    end

The FieldAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | FieldAccessor | Use in class definition preceding a property declaration, i.e. [FieldAccessor("myProtectedField")] where myProtectedField is the field name of the field returned by the property.
Top
Properties
 | Name | Description
Public property | FieldName | Gets the field name of the field being accessed by the property
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


FieldAccessor Constructor

Use in class definition preceding a property declaration, i.e. [FieldAccessor("myProtectedField")] where myProtectedField is the field name of the field returned by the property.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FieldAccessor(
    string fieldName
)
Public Sub New (
    fieldName As String
)
public:
FieldAccessor(
    String^ fieldName
)
new :
        fieldName : string -> FieldAccessor

Parameters

fieldName
Type: SystemString
Name of field.
See Also

Reference

FieldAccessor Class
VelocityDb.TypeInfo Namespace


FieldAccessor Properties

The FieldAccessor type exposes the following members.

Properties
 | Name | Description
Public property | FieldName | Gets the field name of the field being accessed by the property
Top
See Also

Reference

FieldAccessor Class
VelocityDb.TypeInfo Namespace


FieldAccessor.FieldName Property

FieldAccessorFieldName Property

Gets the field name of the field being accessed by the property

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Property Value

Type: String
The name of the field.
See Also

Reference

FieldAccessor Class
VelocityDb.TypeInfo Namespace


ObjectsPerPage Class

A field attribute that controls how many objects that will be placed on the same page as the object of the field.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.TypeInfoObjectsPerPage

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class ObjectsPerPage : Attribute
Public NotInheritable Class ObjectsPerPage
    Inherits Attribute
public ref class ObjectsPerPage sealed : public Attribute
[<SealedAttribute>]
type ObjectsPerPage =
    class
        inherit Attribute
    end

The ObjectsPerPage type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectsPerPage | Use in class definition preceding a field declaration, i.e. [ObjectsPerPage(1)]
Top
Properties
 | Name | Description
Public property | LimitPerPage | Gets the requested maximum number of objects on the page
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


ObjectsPerPage Constructor

Use in class definition preceding a field declaration, i.e. [ObjectsPerPage(1)]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ObjectsPerPage(
    ushort limitPerPage
)
Public Sub New (
    limitPerPage As UShort
)
public:
ObjectsPerPage(
    unsigned short limitPerPage
)
new :
        limitPerPage : uint16 -> ObjectsPerPage

Parameters

limitPerPage
Type: SystemUInt16
The requested maximum number of objects on the page.
See Also

Reference

ObjectsPerPage Class
VelocityDb.TypeInfo Namespace


ObjectsPerPage Properties

The ObjectsPerPage type exposes the following members.

Properties
 | Name | Description
Public property | LimitPerPage | Gets the requested maximum number of objects on the page
Top
See Also

Reference

ObjectsPerPage Class
VelocityDb.TypeInfo Namespace


ObjectsPerPage.LimitPerPage Property

ObjectsPerPageLimitPerPage Property

Gets the requested maximum number of objects on the page

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ushort LimitPerPage { get; }
Public ReadOnly Property LimitPerPage As UShort
    Get
public:
property unsigned short LimitPerPage {
    unsigned short get ();
}
member LimitPerPage : uint16 with get

Property Value

Type: UInt16
The UInt16 number of objects.
See Also

Reference

ObjectsPerPage Class
VelocityDb.TypeInfo Namespace


Reference Class

[Missing <summary> documentation for "T:VelocityDb.TypeInfo.Reference"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoReference

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Reference : OptimizedPersistable, IComparable<Reference>
Public Class Reference
    Inherits OptimizedPersistable
    Implements IComparable(Of Reference)
public ref class Reference : public OptimizedPersistable,
    IComparable<Reference^>
type Reference =
    class
        inherit OptimizedPersistable
        interface IComparable<Reference>
    end

The Reference type exposes the following members.

Constructors
 | Name | Description
Public method | Reference | Initializes a new instance of the Reference class
Top
Properties
 | Name | Description
Public property | RefFieldName | Field name in To object that contains reference
Public property | To | Persistent object being referenced
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


Reference Constructor

Initializes a new instance of the Reference class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Reference(
    IOptimizedPersistable aRef,
    string refFieldName
)
Public Sub New (
    aRef As IOptimizedPersistable,
    refFieldName As String
)
public:
Reference(
    IOptimizedPersistable^ aRef,
    String^ refFieldName
)
new :
        aRef : IOptimizedPersistable *
        refFieldName : string -> Reference

Parameters

aRef
Type: VelocityDbIOptimizedPersistable

[Missing <param name="aRef"/> documentation for "M:VelocityDb.TypeInfo.Reference.#ctor(VelocityDb.IOptimizedPersistable,System.String)"]

refFieldName
Type: SystemString

[Missing <param name="refFieldName"/> documentation for "M:VelocityDb.TypeInfo.Reference.#ctor(VelocityDb.IOptimizedPersistable,System.String)"]

See Also

Reference

Reference Class
VelocityDb.TypeInfo Namespace


Reference Properties

The Reference type exposes the following members.

Properties
 | Name | Description
Public property | RefFieldName | Field name in To object that contains reference
Public property | To | Persistent object being referenced
Top
See Also

Reference

Reference Class
VelocityDb.TypeInfo Namespace


Reference.RefFieldName Property

ReferenceRefFieldName Property

Field name in To object that contains reference

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string RefFieldName { get; }
Public ReadOnly Property RefFieldName As String
    Get
public:
property String^ RefFieldName {
    String^ get ();
}
member RefFieldName : string with get

Property Value

Type: String
See Also

Reference

Reference Class
VelocityDb.TypeInfo Namespace


Reference.To Property

ReferenceTo Property

Persistent object being referenced

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IOptimizedPersistable To { get; }
Public ReadOnly Property To As IOptimizedPersistable
    Get
public:
property IOptimizedPersistable^ To {
    IOptimizedPersistable^ get ();
}
member To : IOptimizedPersistable with get

Property Value

Type: IOptimizedPersistable
See Also

Reference

Reference Class
VelocityDb.TypeInfo Namespace


Reference Methods

The Reference type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Reference Class
VelocityDb.TypeInfo Namespace


Relation Class

The relation classes exist as an aid to maintain referential integrity, that is no dangling references (references to deleted objects). NOTE: These classes may change as they are still in a prototype phase. Let us know how we can improve them? Any ideas are appreciated!
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoRelation
VelocityDb.TypeInfoRelationManyToManyFrom, To
VelocityDb.TypeInfoRelationOneToManyFrom, To
VelocityDb.TypeInfoRelationOneToOneFrom, To

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class Relation : OptimizedPersistable
<SerializableAttribute>
Public MustInherit Class Relation
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class Relation abstract : public OptimizedPersistable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type Relation =
    class
        inherit OptimizedPersistable
    end
See Also

Reference

VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To) Class

RelationManyToManyFrom, To Class

Use for many to many relations
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoRelation
VelocityDb.TypeInfoRelationManyToManyFrom, To

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RelationManyToMany<From, To> : Relation
where From : IOptimizedPersistable
where To : IOptimizedPersistable

<SerializableAttribute>
Public Class RelationManyToMany(Of From As IOptimizedPersistable, To As IOptimizedPersistable)
    Inherits Relation
[SerializableAttribute]
generic<typename From, typename To>
where From : IOptimizedPersistable
where To : IOptimizedPersistable
public ref class RelationManyToMany : public Relation
[<SerializableAttribute>]
type RelationManyToMany<'From, 'To when 'From : IOptimizedPersistable when 'To : IOptimizedPersistable> =
    class
        inherit Relation
    end

Type Parameters

From
Type of From objects
To
Type of To objects

The RelationManyToManyFrom, To type exposes the following members.

Constructors
 | Name | Description
Public method | RelationManyToManyFrom, To | Use for many to many relations
Top
Properties
 | Name | Description
Public property | RelatedFrom | Returns the From objects
Public property | RelatedTo | Returns the To objects
Top
Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To) Constructor

RelationManyToManyFrom, To Constructor

Use for many to many relations

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RelationManyToMany(
    string fromFieldName,
    string toFieldName,
    SessionBase session,
    BTreeSet<From> from = null,
    BTreeSet<To> to = null
)
Public Sub New (
    fromFieldName As String,
    toFieldName As String,
    session As SessionBase,
    Optional from As BTreeSet(Of From) = Nothing,
    Optional to As BTreeSet(Of To) = Nothing
)
public:
RelationManyToMany(
    String^ fromFieldName,
    String^ toFieldName,
    SessionBase^ session,
    BTreeSet<From>^ from = nullptr,
    BTreeSet<To>^ to = nullptr
)
new :
        fromFieldName : string *
        toFieldName : string *
        session : SessionBase *
        ?from : BTreeSet<'From> *
        ?to : BTreeSet<'To>
(* Defaults:
        let _from = defaultArg from null
        let _to = defaultArg to null
*)
-> RelationManyToMany

Parameters

fromFieldName
Type: SystemString
Field name in from object that references this relation
toFieldName
Type: SystemString
Field name in to object that references this relation
session
Type: VelocityDb.SessionSessionBase
The active session
from (Optional)
Type: VelocityDb.Collection.BTreeBTreeSet From
Collection of From objects. If null, default BTreeSetKey is created.
to (Optional)
Type: VelocityDb.Collection.BTreeBTreeSet To
Collection of To objects. If null, default is created.
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To) Properties

RelationManyToManyFrom, To Properties

The RelationManyToManyFrom, To generic type exposes the following members.

Properties
 | Name | Description
Public property | RelatedFrom | Returns the From objects
Public property | RelatedTo | Returns the To objects
Top
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To).RelatedFrom Property

RelationManyToManyFrom, ToRelatedFrom Property

Returns the From objects

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<From> RelatedFrom { get; }
Public ReadOnly Property RelatedFrom As BTreeSet(Of From)
    Get
public:
property BTreeSet<From>^ RelatedFrom {
    BTreeSet<From>^ get ();
}
member RelatedFrom : BTreeSet<'From> with get

Property Value

Type: BTreeSet From
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To).RelatedTo Property

RelationManyToManyFrom, ToRelatedTo Property

Returns the To objects

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<To> RelatedTo { get; }
Public ReadOnly Property RelatedTo As BTreeSet(Of To)
    Get
public:
property BTreeSet<To>^ RelatedTo {
    BTreeSet<To>^ get ();
}
member RelatedTo : BTreeSet<'To> with get

Property Value

Type: BTreeSet To
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To) Methods

RelationManyToManyFrom, To Methods

The RelationManyToManyFrom, To generic type exposes the following members.

Methods
 | Name | Description
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationManyToMany(From, To).Unpersist Method

RelationManyToManyFrom, ToUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

RelationManyToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To) Class

RelationOneToManyFrom, To Class

Use for one to many (and many to one) relations.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoRelation
VelocityDb.TypeInfoRelationOneToManyFrom, To

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RelationOneToMany<From, To> : Relation
where From : IOptimizedPersistable
where To : IOptimizedPersistable

<SerializableAttribute>
Public Class RelationOneToMany(Of From As IOptimizedPersistable, To As IOptimizedPersistable)
    Inherits Relation
[SerializableAttribute]
generic<typename From, typename To>
where From : IOptimizedPersistable
where To : IOptimizedPersistable
public ref class RelationOneToMany : public Relation
[<SerializableAttribute>]
type RelationOneToMany<'From, 'To when 'From : IOptimizedPersistable when 'To : IOptimizedPersistable> =
    class
        inherit Relation
    end

Type Parameters

From
Type of From object
To
Type of To object

The RelationOneToManyFrom, To type exposes the following members.

Constructors
 | Name | Description
Public method | RelationOneToManyFrom, To | Creates the relations between From and To objects.
Top
Properties
 | Name | Description
Public property | FromFieldName | Name of field referencing this object from From object
Public property | RelatedFrom | Gets or sets the From object
Public property | RelatedTo | Returns the To objects
Top
Methods
 | Name | Description
Public method | AddRelationTo | Adds a new relations to a To object. Added to "many" collection.
Public method | RemoveRelationTo | Removes relation to a To object. Removed from "many" collection.
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To) Constructor

RelationOneToManyFrom, To Constructor

Creates the relations between From and To objects.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RelationOneToMany(
    string fromFieldName,
    SessionBase session,
    From from,
    BTreeSet<To> to = null
)
Public Sub New (
    fromFieldName As String,
    session As SessionBase,
    from As From,
    Optional to As BTreeSet(Of To) = Nothing
)
public:
RelationOneToMany(
    String^ fromFieldName,
    SessionBase^ session,
    From from,
    BTreeSet<To>^ to = nullptr
)
new :
        fromFieldName : string *
        session : SessionBase *
        from : 'From *
        ?to : BTreeSet<'To>
(* Defaults:
        let _to = defaultArg to null
*)
-> RelationOneToMany

Parameters

fromFieldName
Type: SystemString
Field name in from object that references this relation
session
Type: VelocityDb.SessionSessionBase
The active session
from
Type: From
From object
to (Optional)
Type: VelocityDb.Collection.BTreeBTreeSet To
Collection of To objects. If null, default BTreeSetKey is created.
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To) Properties

RelationOneToManyFrom, To Properties

The RelationOneToManyFrom, To generic type exposes the following members.

Properties
 | Name | Description
Public property | FromFieldName | Name of field referencing this object from From object
Public property | RelatedFrom | Gets or sets the From object
Public property | RelatedTo | Returns the To objects
Top
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).FromFieldName Property

RelationOneToManyFrom, ToFromFieldName Property

Name of field referencing this object from From object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string FromFieldName { get; }
Public ReadOnly Property FromFieldName As String
    Get
public:
property String^ FromFieldName {
    String^ get ();
}
member FromFieldName : string with get

Property Value

Type: String
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).RelatedFrom Property

RelationOneToManyFrom, ToRelatedFrom Property

Gets or sets the From object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public From RelatedFrom { get; set; }
Public Property RelatedFrom As From
    Get
    Set
public:
property From RelatedFrom {
    From get ();
    void set (From value);
}
member RelatedFrom : 'From with get, set

Property Value

Type: From
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).RelatedTo Property

RelationOneToManyFrom, ToRelatedTo Property

Returns the To objects

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<To> RelatedTo { get; }
Public ReadOnly Property RelatedTo As BTreeSet(Of To)
    Get
public:
property BTreeSet<To>^ RelatedTo {
    BTreeSet<To>^ get ();
}
member RelatedTo : BTreeSet<'To> with get

Property Value

Type: BTreeSet To
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To) Methods

RelationOneToManyFrom, To Methods

The RelationOneToManyFrom, To generic type exposes the following members.

Methods
 | Name | Description
Public method | AddRelationTo | Adds a new relations to a To object. Added to "many" collection.
Public method | RemoveRelationTo | Removes relation to a To object. Removed from "many" collection.
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).AddRelationTo Method

RelationOneToManyFrom, ToAddRelationTo Method

Adds a new relations to a To object. Added to "many" collection.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void AddRelationTo(
    To to
)
Public Sub AddRelationTo (
    to As To
)
public:
void AddRelationTo(
    To to
)
member AddRelationTo :
        to : 'To -> unit

Parameters

to
Type: To
To object to be added
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).RemoveRelationTo Method

RelationOneToManyFrom, ToRemoveRelationTo Method

Removes relation to a To object. Removed from "many" collection.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveRelationTo(
    To to
)
Public Function RemoveRelationTo (
    to As To
) As Boolean
public:
bool RemoveRelationTo(
    To to
)
member RemoveRelationTo :
        to : 'To -> bool

Parameters

to
Type: To
To object to be removed.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDb.TypeInfo.RelationOneToMany`2.RemoveRelationTo(`1)"]

See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToMany(From, To).Unpersist Method

RelationOneToManyFrom, ToUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

RelationOneToManyFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To) Class

RelationOneToOneFrom, To Class

Use for one to one relations.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoRelation
VelocityDb.TypeInfoRelationOneToOneFrom, To

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RelationOneToOne<From, To> : Relation
where From : IOptimizedPersistable
where To : IOptimizedPersistable

<SerializableAttribute>
Public Class RelationOneToOne(Of From As IOptimizedPersistable, To As IOptimizedPersistable)
    Inherits Relation
[SerializableAttribute]
generic<typename From, typename To>
where From : IOptimizedPersistable
where To : IOptimizedPersistable
public ref class RelationOneToOne : public Relation
[<SerializableAttribute>]
type RelationOneToOne<'From, 'To when 'From : IOptimizedPersistable when 'To : IOptimizedPersistable> =
    class
        inherit Relation
    end

Type Parameters

From
Type of From object
To
Type of To object

The RelationOneToOneFrom, To type exposes the following members.

Constructors
 | Name | Description
Public method | RelationOneToOneFrom, To | Creates the relations between From and To objects
Top
Properties
 | Name | Description
Public property | FromFieldName | Name of field referencing this object from From object
Public property | RelatedFrom | Returns the From object
Public property | RelatedTo | Returns the To object
Public property | ToFieldName | Name of field referencing this object from To object
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To) Constructor

RelationOneToOneFrom, To Constructor

Creates the relations between From and To objects

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RelationOneToOne(
    From from,
    To to,
    string fromFieldName,
    string toFieldName,
    SessionBase session
)
Public Sub New (
    from As From,
    to As To,
    fromFieldName As String,
    toFieldName As String,
    session As SessionBase
)
public:
RelationOneToOne(
    From from,
    To to,
    String^ fromFieldName,
    String^ toFieldName,
    SessionBase^ session
)
new :
        from : 'From *
        to : 'To *
        fromFieldName : string *
        toFieldName : string *
        session : SessionBase -> RelationOneToOne

Parameters

from
Type: From
From object
to
Type: To
to object
fromFieldName
Type: SystemString
Field name in from object that references this relation
toFieldName
Type: SystemString
Field name in to object that references this relation
session
Type: VelocityDb.SessionSessionBase
The active session
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To) Properties

RelationOneToOneFrom, To Properties

The RelationOneToOneFrom, To generic type exposes the following members.

Properties
 | Name | Description
Public property | FromFieldName | Name of field referencing this object from From object
Public property | RelatedFrom | Returns the From object
Public property | RelatedTo | Returns the To object
Public property | ToFieldName | Name of field referencing this object from To object
Top
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To).FromFieldName Property

RelationOneToOneFrom, ToFromFieldName Property

Name of field referencing this object from From object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string FromFieldName { get; }
Public ReadOnly Property FromFieldName As String
    Get
public:
property String^ FromFieldName {
    String^ get ();
}
member FromFieldName : string with get

Property Value

Type: String
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To).RelatedFrom Property

RelationOneToOneFrom, ToRelatedFrom Property

Returns the From object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public From RelatedFrom { get; set; }
Public Property RelatedFrom As From
    Get
    Set
public:
property From RelatedFrom {
    From get ();
    void set (From value);
}
member RelatedFrom : 'From with get, set

Property Value

Type: From
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To).RelatedTo Property

RelationOneToOneFrom, ToRelatedTo Property

Returns the To object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public To RelatedTo { get; set; }
Public Property RelatedTo As To
    Get
    Set
public:
property To RelatedTo {
    To get ();
    void set (To value);
}
member RelatedTo : 'To with get, set

Property Value

Type: To
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To).ToFieldName Property

RelationOneToOneFrom, ToToFieldName Property

Name of field referencing this object from To object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ToFieldName { get; }
Public ReadOnly Property ToFieldName As String
    Get
public:
property String^ ToFieldName {
    String^ get ();
}
member ToFieldName : string with get

Property Value

Type: String
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


RelationOneToOne(From, To) Methods

RelationOneToOneFrom, To Methods

The RelationOneToOneFrom, To generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

RelationOneToOneFrom, To Class
VelocityDb.TypeInfo Namespace


Schema Class

Holds information about persistently stored types. Used internally by VelocityDb.
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoSchema

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Schema : OptimizedPersistable
<SerializableAttribute>
Public Class Schema
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class Schema : public OptimizedPersistable
[<SerializableAttribute>]
type Schema =
    class
        inherit OptimizedPersistable
    end

The Schema type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | Do cache CacheEnum.Yes (Overrides OptimizedPersistableCache.)
Public property | LookupByType | For use in VelocityDBExtension DLL
Public property | TypesByName | All persisted types ordered by Type name
 | WeakReferencedTypes | Info about what Types another Type is referencing indirectly via object Id reference or other non explicit/weak reference. If your class persists objects with implicit/weak references to other persisted objects then register this facr by adding to this DictionaryTKey, TValue. Information provided by this DictionaryTKey, TValue is primarily used by Database Manager Schema Connectivity Window.
Top
Methods
 | Name | Description
Public method | GetTypeVersion | Opens a TypeVersion object
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | IsExpandedInternalType | Includes additional build in types
Public method | IsInternalType(UInt16) | Determine if a given slot is within the range of slots containing the build in/pre registered types
Public method | IsInternalType(VelocityDbType) | Determine if a given VelocityDbType is a build in/pre registered type
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | RegisterClass | Register a type in the persistent schema
Top
Fields
Name | Description
s_bootupTypeCount | VelocityDB internal schema requires this many slots on schema page
s_bootupTypeCountExpanded | Additional internal schema added Setember 9, 2017
SchemaDB |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


Schema Properties

The Schema type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Cache | Do cache CacheEnum.Yes (Overrides OptimizedPersistableCache.)
Public property | LookupByType | For use in VelocityDBExtension DLL
Public property | TypesByName | All persisted types ordered by Type name
 | WeakReferencedTypes | Info about what Types another Type is referencing indirectly via object Id reference or other non explicit/weak reference. If your class persists objects with implicit/weak references to other persisted objects then register this facr by adding to this DictionaryTKey, TValue. Information provided by this DictionaryTKey, TValue is primarily used by Database Manager Schema Connectivity Window.
Top
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.AllowOtherTypesOnSamePage Property

SchemaAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.Cache Property

SchemaCache Property

Do cache CacheEnum.Yes

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.LookupByType Property

SchemaLookupByType Property

For use in VelocityDBExtension DLL

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<Type, VelocityDbType> LookupByType { get; }
Public ReadOnly Property LookupByType As Dictionary(Of Type, VelocityDbType)
    Get
public:
property Dictionary<Type^, VelocityDbType^>^ LookupByType {
    Dictionary<Type^, VelocityDbType^>^ get ();
}
member LookupByType : Dictionary<Type, VelocityDbType> with get

Property Value

Type: Dictionary Type, VelocityDbType
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.TypesByName Property

SchemaTypesByName Property

All persisted types ordered by Type name

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSetOidShort<VelocityDbType> TypesByName { get; }
Public ReadOnly Property TypesByName As BTreeSetOidShort(Of VelocityDbType)
    Get
public:
property BTreeSetOidShort<VelocityDbType^>^ TypesByName {
    BTreeSetOidShort<VelocityDbType^>^ get ();
}
member TypesByName : BTreeSetOidShort<VelocityDbType> with get

Property Value

Type: BTreeSetOidShort VelocityDbType
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.WeakReferencedTypes Property

SchemaWeakReferencedTypes Property

Info about what Types another Type is referencing indirectly via object Id reference or other non explicit/weak reference. If your class persists objects with implicit/weak references to other persisted objects then register this facr by adding to this DictionaryTKey, TValue. Information provided by this DictionaryTKey, TValue is primarily used by Database Manager Schema Connectivity Window.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<Type, List<Type>> WeakReferencedTypes { get; set; }
Public Shared Property WeakReferencedTypes As Dictionary(Of Type, List(Of Type))
    Get
    Set
public:
static property Dictionary<Type^, List<Type^>^>^ WeakReferencedTypes {
    Dictionary<Type^, List<Type^>^>^ get ();
    void set (Dictionary<Type^, List<Type^>^>^ value);
}
static member WeakReferencedTypes : Dictionary<Type, List<Type>> with get, set

Property Value

Type: Dictionary Type, List Type
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema Methods

The Schema type exposes the following members.

Methods
 | Name | Description
Public method | GetTypeVersion | Opens a TypeVersion object
Public method | InitializeAfterRecreate | This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data. (Overrides OptimizedPersistableInitializeAfterRecreate(SessionBase).)
Public method | IsExpandedInternalType | Includes additional build in types
Public method | IsInternalType(UInt16) | Determine if a given slot is within the range of slots containing the build in/pre registered types
Public method | IsInternalType(VelocityDbType) | Determine if a given VelocityDbType is a build in/pre registered type
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | RegisterClass | Register a type in the persistent schema
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.GetTypeVersion Method

SchemaGetTypeVersion Method

Opens a TypeVersion object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion GetTypeVersion(
    uint pageSlot,
    SessionBase session,
    bool usePersistent = false
)
Public Function GetTypeVersion (
    pageSlot As UInteger,
    session As SessionBase,
    Optional usePersistent As Boolean = false
) As TypeVersion
public:
TypeVersion^ GetTypeVersion(
    unsigned int pageSlot,
    SessionBase^ session,
    bool usePersistent = false
)
member GetTypeVersion :
        pageSlot : uint32 *
        session : SessionBase *
        ?usePersistent : bool
(* Defaults:
        let _usePersistent = defaultArg usePersistent false
*)
-> TypeVersion

Parameters

pageSlot
Type: SystemUInt32
Page and slot of TypeVersion object
session
Type: VelocityDb.SessionSessionBase
The active session
usePersistent (Optional)
Type: SystemBoolean
Use persisted boot up type or transient one

Return Value

Type: TypeVersion
A type version
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.InitializeAfterRecreate Method

SchemaInitializeAfterRecreate Method

This function is called when an object has been read from disk before all data members (fields) have been fully loaded. Override this to provide your own initializations of transient data.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRecreate(
    SessionBase session
)
Public Overrides Sub InitializeAfterRecreate (
    session As SessionBase
)
public:
virtual void InitializeAfterRecreate(
    SessionBase^ session
) override
abstract InitializeAfterRecreate :
        session : SessionBase -> unit
override InitializeAfterRecreate :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The active session managing this object

Implements

IOptimizedPersistableInitializeAfterRecreate(SessionBase)
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.IsExpandedInternalType Method

SchemaIsExpandedInternalType Method

Includes additional build in types

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsExpandedInternalType(
    ushort slotNumber
)
Public Function IsExpandedInternalType (
    slotNumber As UShort
) As Boolean
public:
bool IsExpandedInternalType(
    unsigned short slotNumber
)
member IsExpandedInternalType :
        slotNumber : uint16 -> bool

Parameters

slotNumber
Type: SystemUInt16
slot number of a VelocityDbType or TypeVersion

Return Value

Type: Boolean
true if internal; otherwise false
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.IsInternalType Method

SchemaIsInternalType Method

Overload List
 | Name | Description
Public method | IsInternalType(UInt16) | Determine if a given slot is within the range of slots containing the build in/pre registered types
Public method | IsInternalType(VelocityDbType) | Determine if a given VelocityDbType is a build in/pre registered type
Top
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.IsInternalType Method (UInt16)

SchemaIsInternalType Method (UInt16)

Determine if a given slot is within the range of slots containing the build in/pre registered types

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsInternalType(
    ushort slotNumber
)
Public Function IsInternalType (
    slotNumber As UShort
) As Boolean
public:
bool IsInternalType(
    unsigned short slotNumber
)
member IsInternalType :
        slotNumber : uint16 -> bool

Parameters

slotNumber
Type: SystemUInt16
Slot number to check

Return Value

Type: Boolean
true if slot is within the range of build in types; otherwise false
See Also

Reference

Schema Class
IsInternalType Overload
VelocityDb.TypeInfo Namespace


Schema.IsInternalType Method (VelocityDbType)

SchemaIsInternalType Method (VelocityDbType)

Determine if a given VelocityDbType is a build in/pre registered type

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsInternalType(
    VelocityDbType velocityDbType
)
Public Function IsInternalType (
    velocityDbType As VelocityDbType
) As Boolean
public:
bool IsInternalType(
    VelocityDbType^ velocityDbType
)
member IsInternalType :
        velocityDbType : VelocityDbType -> bool

Parameters

velocityDbType
Type: VelocityDb.TypeInfoVelocityDbType

Return Value

Type: Boolean
true if slot is within the range of build in types; otherwise false
See Also

Reference

Schema Class
IsInternalType Overload
VelocityDb.TypeInfo Namespace


Schema.ReadMe Method

SchemaReadMe Method

[Missing <summary> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.TypeInfo.Schema.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.RegisterClass Method

SchemaRegisterClass Method

Register a type in the persistent schema

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion RegisterClass(
    Type type,
    SessionBase session,
    bool inFlush = false,
    bool persistIt = true
)
Public Function RegisterClass (
    type As Type,
    session As SessionBase,
    Optional inFlush As Boolean = false,
    Optional persistIt As Boolean = true
) As TypeVersion
public:
TypeVersion^ RegisterClass(
    Type^ type,
    SessionBase^ session,
    bool inFlush = false,
    bool persistIt = true
)
member RegisterClass :
        type : Type *
        session : SessionBase *
        ?inFlush : bool *
        ?persistIt : bool
(* Defaults:
        let _inFlush = defaultArg inFlush false
        let _persistIt = defaultArg persistIt true
*)
-> TypeVersion

Parameters

type
Type: SystemType
A type to register
session
Type: VelocityDb.SessionSessionBase
The active session
inFlush (Optional)
Type: SystemBoolean
Set to false if you want to avoid page flushing as a side affect
persistIt (Optional)
Type: SystemBoolean
Set to false if getting TypeVersion for a lookup (object read)

Return Value

Type: TypeVersion
An existing TypeVersion or a new one
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema Fields

The Schema type exposes the following members.

Fields
Name | Description
s_bootupTypeCount | VelocityDB internal schema requires this many slots on schema page
s_bootupTypeCountExpanded | Additional internal schema added Setember 9, 2017
SchemaDB |
Top
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.s_bootupTypeCount Field

Schemas_bootupTypeCount Field

VelocityDB internal schema requires this many slots on schema page

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_bootupTypeCount
Public Shared ReadOnly s_bootupTypeCount As UShort
public:
static initonly unsigned short s_bootupTypeCount
static val s_bootupTypeCount: uint16

Field Value

Type: UInt16
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.s_bootupTypeCountExpanded Field

Schemas_bootupTypeCountExpanded Field

Additional internal schema added Setember 9, 2017

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static readonly ushort s_bootupTypeCountExpanded
Public Shared ReadOnly s_bootupTypeCountExpanded As UShort
public:
static initonly unsigned short s_bootupTypeCountExpanded
static val s_bootupTypeCountExpanded: uint16

Field Value

Type: UInt16
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


Schema.SchemaDB Field

SchemaSchemaDB Field

[Missing <summary> documentation for "F:VelocityDb.TypeInfo.Schema.SchemaDB"]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const uint SchemaDB = 1
Public Const SchemaDB As UInteger = 1
public:
literal unsigned int SchemaDB = 1
static val mutable SchemaDB: uint32

Field Value

Type: UInt32
See Also

Reference

Schema Class
VelocityDb.TypeInfo Namespace


TypeVersion Class

Contains info about a version of a VelocityDbType. The info is used when reading/writing an object of the
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoTypeVersion

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TypeVersion : OptimizedPersistable,
    IEquatable<TypeVersion>
<SerializableAttribute>
Public Class TypeVersion
    Inherits OptimizedPersistable
    Implements IEquatable(Of TypeVersion)
[SerializableAttribute]
public ref class TypeVersion : public OptimizedPersistable,
    IEquatable<TypeVersion^>
[<SerializableAttribute>]
type TypeVersion =
    class
        inherit OptimizedPersistable
        interface IEquatable<TypeVersion>
    end

The TypeVersion type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | AnyFieldIndex | Does managed type or its base classes include a field index ?
Public property | AnyTypeIndex | Does managed type or its base classes include a type index ?
Public property | AutoIncrement | Does managed type or its base classes include an auto increment field?
Public property | BaseShape | Get the base TypeVersion or null if none exist
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides OptimizedPersistableCache.)
Public property | CountStart | Set where AutoIncrement counter should start
Public property | DataMemberArray | Get an array of fields represented as DataMember. Does not include fields from base classes.
Public property | FieldIndex | Does managed type include a field index ?
Public property | IsFixedSize | A type is fixed size if it only has fixed size fields
Public property | IsISerializable | true if ISerializable otherwise, false.
Public property | IsString | Is this schema for type System.String ?
Public property | IsValueType | Is managed type a ValueType ?
Public property | Type | Get the .NET type of the schema class
Public property | TypeIndex | Does managed type include a type index ?
Public property | VelocityDbType | Get schema class object managing a particular .NET type.
Top
Methods
 | Name | Description
Public method | EncodeForCsv | Encode a persistent object as a string for csv export
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetDataMemberList | Get a list of all DataMember of this type including base classes.
Public method | LoadMembers | Loads member fields from persistent storage
Public method | ObjectBytesFromStrings | Converts string representation of an object into VelocityDB object byte representation.
Public method | PersistRefences | Persists references from an object
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | SetCount |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | TotalShapeNumberOfBytes | Get the total size of an object of the managed type (including base class fields)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


TypeVersion Properties

The TypeVersion type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | AnyFieldIndex | Does managed type or its base classes include a field index ?
Public property | AnyTypeIndex | Does managed type or its base classes include a type index ?
Public property | AutoIncrement | Does managed type or its base classes include an auto increment field?
Public property | BaseShape | Get the base TypeVersion or null if none exist
Public property | Cache | By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do. (Overrides OptimizedPersistableCache.)
Public property | CountStart | Set where AutoIncrement counter should start
Public property | DataMemberArray | Get an array of fields represented as DataMember. Does not include fields from base classes.
Public property | FieldIndex | Does managed type include a field index ?
Public property | IsFixedSize | A type is fixed size if it only has fixed size fields
Public property | IsISerializable | true if ISerializable otherwise, false.
Public property | IsString | Is this schema for type System.String ?
Public property | IsValueType | Is managed type a ValueType ?
Public property | Type | Get the .NET type of the schema class
Public property | TypeIndex | Does managed type include a type index ?
Public property | VelocityDbType | Get schema class object managing a particular .NET type.
Top
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.AllowOtherTypesOnSamePage Property

TypeVersionAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.AnyFieldIndex Property

TypeVersionAnyFieldIndex Property

Does managed type or its base classes include a field index ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AnyFieldIndex { get; }
Public ReadOnly Property AnyFieldIndex As Boolean
    Get
public:
property bool AnyFieldIndex {
    bool get ();
}
member AnyFieldIndex : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.AnyTypeIndex Property

TypeVersionAnyTypeIndex Property

Does managed type or its base classes include a type index ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AnyTypeIndex { get; }
Public ReadOnly Property AnyTypeIndex As Boolean
    Get
public:
property bool AnyTypeIndex {
    bool get ();
}
member AnyTypeIndex : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.AutoIncrement Property

TypeVersionAutoIncrement Property

Does managed type or its base classes include an auto increment field?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool AutoIncrement { get; set; }
Public Property AutoIncrement As Boolean
    Get
    Set
public:
property bool AutoIncrement {
    bool get ();
    void set (bool value);
}
member AutoIncrement : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.BaseShape Property

TypeVersionBaseShape Property

Get the base TypeVersion or null if none exist

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion BaseShape { get; }
Public ReadOnly Property BaseShape As TypeVersion
    Get
public:
property TypeVersion^ BaseShape {
    TypeVersion^ get ();
}
member BaseShape : TypeVersion with get

Property Value

Type: TypeVersion
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.Cache Property

TypeVersionCache Property

By default, the an object cache is determined by a SessionBase constructor parameter but certain types of objects may be re opened more frequently than others, for such types override this to return a value. Caching objects this way can cause out of date object references to stay active due to lacking code to invalidate a cached object when referenced objects are replaced. We will add this automatic invalidation as soon as possible but for now use caution when caching objects. Caching objects that does not strongly reference other objects is OK to do.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override CacheEnum Cache { get; }
Public Overrides ReadOnly Property Cache As CacheEnum
    Get
public:
virtual property CacheEnum Cache {
    CacheEnum get () override;
}
abstract Cache : CacheEnum with get
override Cache : CacheEnum with get

Property Value

Type: CacheEnum

Implements

IOptimizedPersistableCache
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.CountStart Property

TypeVersionCountStart Property

Set where AutoIncrement counter should start

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong CountStart { get; }
Public ReadOnly Property CountStart As ULong
    Get
public:
property unsigned long long CountStart {
    unsigned long long get ();
}
member CountStart : uint64 with get

Property Value

Type: UInt64
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.DataMemberArray Property

TypeVersionDataMemberArray Property

Get an array of fields represented as DataMember. Does not include fields from base classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public DataMember[] DataMemberArray { get; }
Public ReadOnly Property DataMemberArray As DataMember()
    Get
public:
property array<DataMember^>^ DataMemberArray {
    array<DataMember^>^ get ();
}
member DataMemberArray : DataMember[] with get

Property Value

Type: DataMember
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.FieldIndex Property

TypeVersionFieldIndex Property

Does managed type include a field index ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool FieldIndex { get; set; }
Public Property FieldIndex As Boolean
    Get
    Set
public:
property bool FieldIndex {
    bool get ();
    void set (bool value);
}
member FieldIndex : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.IsFixedSize Property

TypeVersionIsFixedSize Property

A type is fixed size if it only has fixed size fields

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}
member IsFixedSize : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.IsISerializable Property

TypeVersionIsISerializable Property

true if ISerializable otherwise, false.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsISerializable { get; }
Public ReadOnly Property IsISerializable As Boolean
    Get
public:
property bool IsISerializable {
    bool get ();
}
member IsISerializable : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.IsString Property

TypeVersionIsString Property

Is this schema for type System.String ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsString { get; }
Public ReadOnly Property IsString As Boolean
    Get
public:
property bool IsString {
    bool get ();
}
member IsString : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.IsValueType Property

TypeVersionIsValueType Property

Is managed type a ValueType ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsValueType { get; }
Public ReadOnly Property IsValueType As Boolean
    Get
public:
property bool IsValueType {
    bool get ();
}
member IsValueType : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.Type Property

TypeVersionType Property

Get the .NET type of the schema class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.TypeIndex Property

TypeVersionTypeIndex Property

Does managed type include a type index ?

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TypeIndex { get; }
Public ReadOnly Property TypeIndex As Boolean
    Get
public:
property bool TypeIndex {
    bool get ();
}
member TypeIndex : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.VelocityDbType Property

TypeVersionVelocityDbType Property

Get schema class object managing a particular .NET type.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VelocityDbType VelocityDbType { get; }
Public ReadOnly Property VelocityDbType As VelocityDbType
    Get
public:
property VelocityDbType^ VelocityDbType {
    VelocityDbType^ get ();
}
member VelocityDbType : VelocityDbType with get

Property Value

Type: VelocityDbType
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion Methods

The TypeVersion type exposes the following members.

Methods
 | Name | Description
Public method | EncodeForCsv | Encode a persistent object as a string for csv export
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetDataMemberList | Get a list of all DataMember of this type including base classes.
Public method | LoadMembers | Loads member fields from persistent storage
Public method | ObjectBytesFromStrings | Converts string representation of an object into VelocityDB object byte representation.
Public method | PersistRefences | Persists references from an object
Public method | ReadMe | (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | SetCount |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | TotalShapeNumberOfBytes | Get the total size of an object of the managed type (including base class fields)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.EncodeForCsv Method

TypeVersionEncodeForCsv Method

Encode a persistent object as a string for csv export

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string EncodeForCsv(
    Object obj,
    PageInfo pageInfo,
    SessionBase session
)
Public Function EncodeForCsv (
    obj As Object,
    pageInfo As PageInfo,
    session As SessionBase
) As String
public:
String^ EncodeForCsv(
    Object^ obj,
    PageInfo^ pageInfo,
    SessionBase^ session
)
member EncodeForCsv :
        obj : Object *
        pageInfo : PageInfo *
        session : SessionBase -> string

Parameters

obj
Type: SystemObject
Object to be encoded
pageInfo
Type: VelocityDbPageInfo
PageInfo for page where object lives
session
Type: VelocityDb.SessionSessionBase
The active session

Return Value

Type: String
Object encoded as a string
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.Equals Method

TypeVersionEquals Method

Indicates whether the current object is equal to another object of the same type.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    TypeVersion other
)
Public Function Equals (
    other As TypeVersion
) As Boolean
public:
virtual bool Equals(
    TypeVersion^ other
) sealed
abstract Equals :
        other : TypeVersion -> bool
override Equals :
        other : TypeVersion -> bool

Parameters

other
Type: VelocityDb.TypeInfoTypeVersion
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.GetDataMemberList Method

TypeVersionGetDataMemberList Method

Get a list of all DataMember of this type including base classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<DataMember> GetDataMemberList()
Public Function GetDataMemberList As List(Of DataMember)
public:
List<DataMember^>^ GetDataMemberList()
member GetDataMemberList : unit -> List<DataMember>

Return Value

Type: List DataMember
A list of DataMember that this type or a base class contains
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.LoadMembers Method

TypeVersionLoadMembers Method

Loads member fields from persistent storage

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void LoadMembers(
    IOptimizedPersistable toLoad,
    Schema schema,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    SessionBase session,
    bool primitivesOnly = false
)
Public Sub LoadMembers (
    toLoad As IOptimizedPersistable,
    schema As Schema,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    session As SessionBase,
    Optional primitivesOnly As Boolean = false
)
public:
void LoadMembers(
    IOptimizedPersistable^ toLoad,
    Schema^ schema,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    SessionBase^ session,
    bool primitivesOnly = false
)
member LoadMembers :
        toLoad : IOptimizedPersistable *
        schema : Schema *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        session : SessionBase *
        ?primitivesOnly : bool
(* Defaults:
        let _primitivesOnly = defaultArg primitivesOnly false
*)
-> unit

Parameters

toLoad
Type: VelocityDbIOptimizedPersistable
Object to load fields for
schema
Type: VelocityDb.TypeInfoSchema
The current schema
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
To be loaded fields list
graphDepth
Type: SystemInt32
Current graph depth loaded
graphDepthToLoad
Type: SystemInt32
Max graph depth to load fields for
session
Type: VelocityDb.SessionSessionBase
The active session
primitivesOnly (Optional)
Type: SystemBoolean
If true, load only primitive values
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.ObjectBytesFromStrings Method

TypeVersionObjectBytesFromStrings Method

Converts string representation of an object into VelocityDB object byte representation.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ObjectBytesFromStrings(
    string[] members,
    string[] fieldNames,
    SessionBase session,
    Schema schema
)
Public Sub ObjectBytesFromStrings (
    members As String(),
    fieldNames As String(),
    session As SessionBase,
    schema As Schema
)
public:
void ObjectBytesFromStrings(
    array<String^>^ members,
    array<String^>^ fieldNames,
    SessionBase^ session,
    Schema^ schema
)
member ObjectBytesFromStrings :
        members : string[] *
        fieldNames : string[] *
        session : SessionBase *
        schema : Schema -> unit

Parameters

members
Type: SystemString
fieldNames
Type: SystemString
session
Type: VelocityDb.SessionSessionBase
Active session
schema
Type: VelocityDb.TypeInfoSchema
Current schema
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.PersistRefences Method

TypeVersionPersistRefences Method

Persists references from an object

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void PersistRefences(
    Object obj,
    PageInfo pageInfo,
    IOptimizedPersistable owner,
    SessionBase session,
    bool inFlush
)
Public Sub PersistRefences (
    obj As Object,
    pageInfo As PageInfo,
    owner As IOptimizedPersistable,
    session As SessionBase,
    inFlush As Boolean
)
public:
void PersistRefences(
    Object^ obj,
    PageInfo^ pageInfo,
    IOptimizedPersistable^ owner,
    SessionBase^ session,
    bool inFlush
)
member PersistRefences :
        obj : Object *
        pageInfo : PageInfo *
        owner : IOptimizedPersistable *
        session : SessionBase *
        inFlush : bool -> unit

Parameters

obj
Type: SystemObject
Object for which we want to persist all references
pageInfo
Type: VelocityDbPageInfo
PageInfo for page containing the object for which we are persisting references
owner
Type: VelocityDbIOptimizedPersistable
Owner object of the object
session
Type: VelocityDb.SessionSessionBase
Session managing the object
inFlush
Type: SystemBoolean
Are we currently within a page flush
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.ReadMe Method

TypeVersionReadMe Method

[Missing <summary> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

memberBytes
Type: SystemByte

[Missing <param name="memberBytes"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

useOidShort
Type: SystemBoolean

[Missing <param name="useOidShort"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

openRefs
Type: SystemBoolean

[Missing <param name="openRefs"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable

[Missing <param name="toLoadMembers"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepth
Type: SystemInt32

[Missing <param name="graphDepth"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

graphDepthToLoad
Type: SystemInt32

[Missing <param name="graphDepthToLoad"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

primitivesOnly
Type: SystemBoolean

[Missing <param name="primitivesOnly"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ReadMe(VelocityDb.TypeInfo.TypeVersion,System.Byte[],System.Int32@,VelocityDb.Session.SessionBase,VelocityDb.Page,System.Boolean,VelocityDb.TypeInfo.Schema,System.Boolean,System.Collections.Generic.List{VelocityDb.IOptimizedPersistable},System.Int32,System.Int32,System.Boolean)"]

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.SetCount Method

TypeVersionSetCount Method

[Missing <summary> documentation for "M:VelocityDb.TypeInfo.TypeVersion.SetCount(System.Object,VelocityDb.AutoPlacement)"]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetCount(
    Object obj,
    AutoPlacement autoPlacement
)
Public Sub SetCount (
    obj As Object,
    autoPlacement As AutoPlacement
)
public:
void SetCount(
    Object^ obj,
    AutoPlacement^ autoPlacement
)
member SetCount :
        obj : Object *
        autoPlacement : AutoPlacement -> unit

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.SetCount(System.Object,VelocityDb.AutoPlacement)"]

autoPlacement
Type: VelocityDbAutoPlacement

[Missing <param name="autoPlacement"/> documentation for "M:VelocityDb.TypeInfo.TypeVersion.SetCount(System.Object,VelocityDb.AutoPlacement)"]

See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.ToString Method

TypeVersionToString Method

[Missing <summary> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ToString"]

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDb.TypeInfo.TypeVersion.ToString"]

See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.TotalShapeNumberOfBytes Method

TypeVersionTotalShapeNumberOfBytes Method

Get the total size of an object of the managed type (including base class fields)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int TotalShapeNumberOfBytes(
    Schema schema
)
Public Function TotalShapeNumberOfBytes (
    schema As Schema
) As Integer
public:
int TotalShapeNumberOfBytes(
    Schema^ schema
)
member TotalShapeNumberOfBytes :
        schema : Schema -> int

Parameters

schema
Type: VelocityDb.TypeInfoSchema
The active schema

Return Value

Type: Int32
The total size of all fields or -1 if fields do not have a fixed size
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


TypeVersion.Unpersist Method

TypeVersionUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

TypeVersion Class
VelocityDb.TypeInfo Namespace


UseOidShort Class

Indicates that every field or selected fields of a serializable class should be referenced using a OidShort instead of a full Oid. This means that the referenced object is located in the same database as the object containing the reference. A ShortOid uses less space and references are not tied to a certain database number.
Inheritance Hierarchy
SystemObject
SystemAttribute
VelocityDb.TypeInfoUseOidShort

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class UseOidShort : Attribute
Public NotInheritable Class UseOidShort
    Inherits Attribute
public ref class UseOidShort sealed : public Attribute
[<SealedAttribute>]
type UseOidShort =
    class
        inherit Attribute
    end

The UseOidShort type exposes the following members.

Constructors
 | Name | Description
Public method | UseOidShort | Creates the attribute indicating use of OidShort (page + page)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


UseOidShort Constructor

Creates the attribute indicating use of OidShort (page + page)

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UseOidShort()
Public Sub New
public:
UseOidShort()
new : unit -> UseOidShort
See Also

Reference

UseOidShort Class
VelocityDb.TypeInfo Namespace


VelocityDbType Class

Contains persistent info for a Type
Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDb.TypeInfoVelocityDbType

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VelocityDbType : OptimizedPersistable
<SerializableAttribute>
Public Class VelocityDbType
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class VelocityDbType : public OptimizedPersistable
[<SerializableAttribute>]
type VelocityDbType =
    class
        inherit OptimizedPersistable
    end

The VelocityDbType type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Type | Get the type of the schema managed class
Public property | TypeName | Name of Type that this meta object is managing.
Public property | TypeVersions | Initially one version exist, if class is modified and UpdateClass(Type) is called other versions can exist.
Top
Methods
 | Name | Description
Public method | LastShape | Get the latest version of a schema class
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | ToString | Displays class name plus object id (Overrides OptimizedPersistableToString.)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDb.TypeInfo Namespace


VelocityDbType Properties

The VelocityDbType type exposes the following members.

Properties
 | Name | Description
Public property | AllowOtherTypesOnSamePage | Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types. (Overrides OptimizedPersistableAllowOtherTypesOnSamePage.)
Public property | Type | Get the type of the schema managed class
Public property | TypeName | Name of Type that this meta object is managing.
Public property | TypeVersions | Initially one version exist, if class is modified and UpdateClass(Type) is called other versions can exist.
Top
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.AllowOtherTypesOnSamePage Property

VelocityDbTypeAllowOtherTypesOnSamePage Property

Objects can be stored more efficiently if all object types on the page share the same type. By default mixed types are allowed. Override this to return false for types that should not share pages with other types.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowOtherTypesOnSamePage { get; }
Public Overrides ReadOnly Property AllowOtherTypesOnSamePage As Boolean
    Get
public:
virtual property bool AllowOtherTypesOnSamePage {
    bool get () override;
}
abstract AllowOtherTypesOnSamePage : bool with get
override AllowOtherTypesOnSamePage : bool with get

Property Value

Type: Boolean

Implements

IOptimizedPersistableAllowOtherTypesOnSamePage
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.Type Property

VelocityDbTypeType Property

Get the type of the schema managed class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.TypeName Property

VelocityDbTypeTypeName Property

Name of Type that this meta object is managing.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.TypeVersions Property

VelocityDbTypeTypeVersions Property

Initially one version exist, if class is modified and UpdateClass(Type) is called other versions can exist.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion[] TypeVersions { get; }
Public ReadOnly Property TypeVersions As TypeVersion()
    Get
public:
property array<TypeVersion^>^ TypeVersions {
    array<TypeVersion^>^ get ();
}
member TypeVersions : TypeVersion[] with get

Property Value

Type: TypeVersion
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType Methods

The VelocityDbType type exposes the following members.

Methods
 | Name | Description
Public method | LastShape | Get the latest version of a schema class
Public method | ReadMe | Used by code generator (Overrides OptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean).)
Public method | ToString | Displays class name plus object id (Overrides OptimizedPersistableToString.)
Public method | Unpersist | Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes. (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.LastShape Method

VelocityDbTypeLastShape Method

Get the latest version of a schema class

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TypeVersion LastShape()
Public Function LastShape As TypeVersion
public:
TypeVersion^ LastShape()
member LastShape : unit -> TypeVersion

Return Value

Type: TypeVersion
Current version of a schema class
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.ReadMe Method

VelocityDbTypeReadMe Method

Used by code generator

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ReadMe(
    TypeVersion typeVersion,
    byte[] memberBytes,
    ref int offset,
    SessionBase session,
    Page page,
    bool useOidShort,
    Schema schema,
    bool openRefs,
    List<IOptimizedPersistable> toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
)
Public Overrides Sub ReadMe (
    typeVersion As TypeVersion,
    memberBytes As Byte(),
    ByRef offset As Integer,
    session As SessionBase,
    page As Page,
    useOidShort As Boolean,
    schema As Schema,
    openRefs As Boolean,
    toLoadMembers As List(Of IOptimizedPersistable),
    graphDepth As Integer,
    graphDepthToLoad As Integer,
    primitivesOnly As Boolean
)
public:
virtual void ReadMe(
    TypeVersion^ typeVersion,
    array<unsigned char>^ memberBytes,
    int% offset,
    SessionBase^ session,
    Page^ page,
    bool useOidShort,
    Schema^ schema,
    bool openRefs,
    List<IOptimizedPersistable^>^ toLoadMembers,
    int graphDepth,
    int graphDepthToLoad,
    bool primitivesOnly
) override
abstract ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit
override ReadMe :
        typeVersion : TypeVersion *
        memberBytes : byte[] *
        offset : int byref *
        session : SessionBase *
        page : Page *
        useOidShort : bool *
        schema : Schema *
        openRefs : bool *
        toLoadMembers : List<IOptimizedPersistable> *
        graphDepth : int *
        graphDepthToLoad : int *
        primitivesOnly : bool -> unit

Parameters

typeVersion
Type: VelocityDb.TypeInfoTypeVersion
The version of the type being read
memberBytes
Type: SystemByte
offset
Type: SystemInt32
session
Type: VelocityDb.SessionSessionBase
page
Type: VelocityDbPage
useOidShort
Type: SystemBoolean
schema
Type: VelocityDb.TypeInfoSchema
openRefs
Type: SystemBoolean
toLoadMembers
Type: System.Collections.GenericList IOptimizedPersistable
graphDepth
Type: SystemInt32
graphDepthToLoad
Type: SystemInt32
primitivesOnly
Type: SystemBoolean

Implements

IOptimizedPersistableReadMe(TypeVersion, Byte, Int32, SessionBase, Page, Boolean, Schema, Boolean, ListIOptimizedPersistable, Int32, Int32, Boolean)
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.ToString Method

VelocityDbTypeToString Method

Displays class name plus object id

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String containing class name and object id.
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDbType.Unpersist Method

VelocityDbTypeUnpersist Method

Removes an object from the persistent store and makes the object a transient object. It does not automatically make referenced objects unpersisted. Best way to do so is to override this virtual function in your own classes.

Namespace: VelocityDb.TypeInfo
Assembly: VelocityDb (in VelocityDb.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase
The managing session

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

VelocityDbType Class
VelocityDb.TypeInfo Namespace


VelocityDBExtensions Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions"]

Classes
 | Class | Description
Public class | FieldsOnlyContractResolver |
Public class | ImportExportCsv |
Public class | JsonImportExport |
Public class | Sync |
Public class | SyncProvider |
Public class | Utilities |


FieldsOnlyContractResolver Class

[Missing <summary> documentation for "T:VelocityDBExtensions.FieldsOnlyContractResolver"]

Inheritance Hierarchy
SystemObject
DefaultContractResolver
VelocityDBExtensionsFieldsOnlyContractResolver

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class FieldsOnlyContractResolver : DefaultContractResolver
Public Class FieldsOnlyContractResolver
    Inherits DefaultContractResolver
public ref class FieldsOnlyContractResolver : public DefaultContractResolver
type FieldsOnlyContractResolver =
    class
        inherit DefaultContractResolver
    end

The FieldsOnlyContractResolver type exposes the following members.

Constructors
 | Name | Description
Public method | FieldsOnlyContractResolver | Initializes a new instance of the FieldsOnlyContractResolver class
Top
See Also

Reference

VelocityDBExtensions Namespace


FieldsOnlyContractResolver Constructor

Initializes a new instance of the FieldsOnlyContractResolver class

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public FieldsOnlyContractResolver()
Public Sub New
public:
FieldsOnlyContractResolver()
new : unit -> FieldsOnlyContractResolver
See Also

Reference

FieldsOnlyContractResolver Class
VelocityDBExtensions Namespace


ImportExportCsv Class

[Missing <summary> documentation for "T:VelocityDBExtensions.ImportExportCsv"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensionsImportExportCsv

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class ImportExportCsv
<ExtensionAttribute>
Public NotInheritable Class ImportExportCsv
[ExtensionAttribute]
public ref class ImportExportCsv abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ImportExportCsv =  class end

The ImportExportCsv type exposes the following members.

Methods
Name | Description
ExportToCSV |
ImportFromCSV |
Top
See Also

Reference

VelocityDBExtensions Namespace


ImportExportCsv Methods

The ImportExportCsv type exposes the following members.

Methods
Name | Description
ExportToCSV |
ImportFromCSV |
Top
See Also

Reference

ImportExportCsv Class
VelocityDBExtensions Namespace


ImportExportCsv.ExportToCSV Method

ImportExportCsvExportToCSV Method

[Missing <summary> documentation for "M:VelocityDBExtensions.ImportExportCsv.ExportToCSV(VelocityDb.Session.SessionBase,System.String)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void ExportToCSV(
    this SessionBase session,
    string directory
)
<ExtensionAttribute>
Public Shared Sub ExportToCSV (
    session As SessionBase,
    directory As String
)
public:
[ExtensionAttribute]
static void ExportToCSV(
    SessionBase^ session,
    String^ directory
)
[<ExtensionAttribute>]
static member ExportToCSV :
        session : SessionBase *
        directory : string -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.ImportExportCsv.ExportToCSV(VelocityDb.Session.SessionBase,System.String)"]

directory
Type: SystemString

[Missing <param name="directory"/> documentation for "M:VelocityDBExtensions.ImportExportCsv.ExportToCSV(VelocityDb.Session.SessionBase,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ImportExportCsv Class
VelocityDBExtensions Namespace


ImportExportCsv.ImportFromCSV Method

ImportExportCsvImportFromCSV Method

[Missing <summary> documentation for "M:VelocityDBExtensions.ImportExportCsv.ImportFromCSV(VelocityDb.Session.SessionBase,System.String)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void ImportFromCSV(
    this SessionBase session,
    string csvDirectory
)
<ExtensionAttribute>
Public Shared Sub ImportFromCSV (
    session As SessionBase,
    csvDirectory As String
)
public:
[ExtensionAttribute]
static void ImportFromCSV(
    SessionBase^ session,
    String^ csvDirectory
)
[<ExtensionAttribute>]
static member ImportFromCSV :
        session : SessionBase *
        csvDirectory : string -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.ImportExportCsv.ImportFromCSV(VelocityDb.Session.SessionBase,System.String)"]

csvDirectory
Type: SystemString

[Missing <param name="csvDirectory"/> documentation for "M:VelocityDBExtensions.ImportExportCsv.ImportFromCSV(VelocityDb.Session.SessionBase,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ImportExportCsv Class
VelocityDBExtensions Namespace


JsonImportExport Class

[Missing <summary> documentation for "T:VelocityDBExtensions.JsonImportExport"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensionsJsonImportExport

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class JsonImportExport
<ExtensionAttribute>
Public NotInheritable Class JsonImportExport
[ExtensionAttribute]
public ref class JsonImportExport abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type JsonImportExport =  class end

The JsonImportExport type exposes the following members.

Methods
Name | Description
ExportToJsonT(SessionBase, UInt64) |
ExportToJsonT(SessionBase, Oid) |
ExportToJsonT(SessionBase, Boolean, Boolean) |
ImportJsonT |
Top
See Also

Reference

VelocityDBExtensions Namespace


JsonImportExport Methods

The JsonImportExport type exposes the following members.

Methods
Name | Description
ExportToJsonT(SessionBase, UInt64) |
ExportToJsonT(SessionBase, Oid) |
ExportToJsonT(SessionBase, Boolean, Boolean) |
ImportJsonT |
Top
See Also

Reference

JsonImportExport Class
VelocityDBExtensions Namespace


JsonImportExport.ExportToJson Method

JsonImportExportExportToJson Method

Overload List
Name | Description
ExportToJsonT(SessionBase, UInt64) |
ExportToJsonT(SessionBase, Oid) |
ExportToJsonT(SessionBase, Boolean, Boolean) |
Top
See Also

Reference

JsonImportExport Class
VelocityDBExtensions Namespace


JsonImportExport.ExportToJson(T) Method (SessionBase, UInt64)

JsonImportExportExportToJsonT Method (SessionBase, UInt64)

[Missing <summary> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.UInt64)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ExportToJson<T>(
    this SessionBase session,
    ulong id
)

<ExtensionAttribute>
Public Shared Function ExportToJson(Of T) (
    session As SessionBase,
    id As ULong
) As String
public:
[ExtensionAttribute]
generic<typename T>
static String^ ExportToJson(
    SessionBase^ session,
    unsigned long long id
)
[<ExtensionAttribute>]
static member ExportToJson :
        session : SessionBase *
        id : uint64 -> string

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.UInt64)"]

id
Type: SystemUInt64

[Missing <param name="id"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.UInt64)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.UInt64)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.UInt64)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

JsonImportExport Class
ExportToJson Overload
VelocityDBExtensions Namespace


JsonImportExport.ExportToJson(T) Method (SessionBase, Oid)

JsonImportExportExportToJsonT Method (SessionBase, Oid)

[Missing <summary> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,VelocityDb.Oid)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ExportToJson<T>(
    this SessionBase session,
    Oid oid
)

<ExtensionAttribute>
Public Shared Function ExportToJson(Of T) (
    session As SessionBase,
    oid As Oid
) As String
public:
[ExtensionAttribute]
generic<typename T>
static String^ ExportToJson(
    SessionBase^ session,
    Oid oid
)
[<ExtensionAttribute>]
static member ExportToJson :
        session : SessionBase *
        oid : Oid -> string

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,VelocityDb.Oid)"]

oid
Type: VelocityDbOid

[Missing <param name="oid"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,VelocityDb.Oid)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,VelocityDb.Oid)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,VelocityDb.Oid)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

JsonImportExport Class
ExportToJson Overload
VelocityDBExtensions Namespace


JsonImportExport.ExportToJson(T) Method (SessionBase, Boolean, Boolean)

JsonImportExportExportToJsonT Method (SessionBase, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<string> ExportToJson<T>(
    this SessionBase session,
    bool includeSubclasses = false,
    bool databasePerType = true
)

<ExtensionAttribute>
Public Shared Function ExportToJson(Of T) (
    session As SessionBase,
    Optional includeSubclasses As Boolean = false,
    Optional databasePerType As Boolean = true
) As IEnumerable(Of String)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<String^>^ ExportToJson(
    SessionBase^ session,
    bool includeSubclasses = false,
    bool databasePerType = true
)
[<ExtensionAttribute>]
static member ExportToJson :
        session : SessionBase *
        ?includeSubclasses : bool *
        ?databasePerType : bool
(* Defaults:
        let _includeSubclasses = defaultArg includeSubclasses false
        let _databasePerType = defaultArg databasePerType true
*)
-> IEnumerable<string>

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

includeSubclasses (Optional)
Type: SystemBoolean

[Missing <param name="includeSubclasses"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

databasePerType (Optional)
Type: SystemBoolean

[Missing <param name="databasePerType"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

Return Value

Type: IEnumerable String

[Missing <returns> documentation for "M:VelocityDBExtensions.JsonImportExport.ExportToJson``1(VelocityDb.Session.SessionBase,System.Boolean,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

JsonImportExport Class
ExportToJson Overload
VelocityDBExtensions Namespace


JsonImportExport.ImportJson(T) Method

JsonImportExportImportJsonT Method

[Missing <summary> documentation for "M:VelocityDBExtensions.JsonImportExport.ImportJson``1(VelocityDb.Session.SessionBase,System.String)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static T ImportJson<T>(
    this SessionBase session,
    string json
)

<ExtensionAttribute>
Public Shared Function ImportJson(Of T) (
    session As SessionBase,
    json As String
) As T
public:
[ExtensionAttribute]
generic<typename T>
static T ImportJson(
    SessionBase^ session,
    String^ json
)
[<ExtensionAttribute>]
static member ImportJson :
        session : SessionBase *
        json : string -> 'T

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ImportJson``1(VelocityDb.Session.SessionBase,System.String)"]

json
Type: SystemString

[Missing <param name="json"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ImportJson``1(VelocityDb.Session.SessionBase,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityDBExtensions.JsonImportExport.ImportJson``1(VelocityDb.Session.SessionBase,System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:VelocityDBExtensions.JsonImportExport.ImportJson``1(VelocityDb.Session.SessionBase,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

JsonImportExport Class
VelocityDBExtensions Namespace


Sync Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Sync"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensionsSync

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class Sync
<ExtensionAttribute>
Public NotInheritable Class Sync
[ExtensionAttribute]
public ref class Sync abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type Sync =  class end

The Sync type exposes the following members.

Methods
Name | Description
MicrosoftSync |
SyncWith(SessionBase, SessionBase) |
SyncWith(SessionBase, SessionBase, FuncSessionBase, UInt64, Change, Boolean) |
Top
See Also

Reference

VelocityDBExtensions Namespace


Sync Methods

The Sync type exposes the following members.

Methods
Name | Description
MicrosoftSync |
SyncWith(SessionBase, SessionBase) |
SyncWith(SessionBase, SessionBase, FuncSessionBase, UInt64, Change, Boolean) |
Top
See Also

Reference

Sync Class
VelocityDBExtensions Namespace


Sync.MicrosoftSync Method

SyncMicrosoftSync Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Sync.MicrosoftSync(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static SyncOperationStatistics MicrosoftSync(
    this SessionBase sessionToUpdate,
    SessionBase sessionToRead
)
<ExtensionAttribute>
Public Shared Function MicrosoftSync (
    sessionToUpdate As SessionBase,
    sessionToRead As SessionBase
) As SyncOperationStatistics
public:
[ExtensionAttribute]
static SyncOperationStatistics^ MicrosoftSync(
    SessionBase^ sessionToUpdate,
    SessionBase^ sessionToRead
)
[<ExtensionAttribute>]
static member MicrosoftSync :
        sessionToUpdate : SessionBase *
        sessionToRead : SessionBase -> SyncOperationStatistics

Parameters

sessionToUpdate
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionToUpdate"/> documentation for "M:VelocityDBExtensions.Sync.MicrosoftSync(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

sessionToRead
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionToRead"/> documentation for "M:VelocityDBExtensions.Sync.MicrosoftSync(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

Return Value

Type: SyncOperationStatistics

[Missing <returns> documentation for "M:VelocityDBExtensions.Sync.MicrosoftSync(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Sync Class
VelocityDBExtensions Namespace


Sync.SyncWith Method

SyncSyncWith Method

Overload List
Name | Description
SyncWith(SessionBase, SessionBase) |
SyncWith(SessionBase, SessionBase, FuncSessionBase, UInt64, Change, Boolean) |
Top
See Also

Reference

Sync Class
VelocityDBExtensions Namespace


Sync.SyncWith Method (SessionBase, SessionBase)

SyncSyncWith Method (SessionBase, SessionBase)

[Missing <summary> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void SyncWith(
    this SessionBase sessionToUpdate,
    SessionBase sessionOther
)
<ExtensionAttribute>
Public Shared Sub SyncWith (
    sessionToUpdate As SessionBase,
    sessionOther As SessionBase
)
public:
[ExtensionAttribute]
static void SyncWith(
    SessionBase^ sessionToUpdate,
    SessionBase^ sessionOther
)
[<ExtensionAttribute>]
static member SyncWith :
        sessionToUpdate : SessionBase *
        sessionOther : SessionBase -> unit

Parameters

sessionToUpdate
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionToUpdate"/> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

sessionOther
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionOther"/> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Sync Class
SyncWith Overload
VelocityDBExtensions Namespace


Sync.SyncWith Method (SessionBase, SessionBase, Func(SessionBase, UInt64, Change, Boolean))

SyncSyncWith Method (SessionBase, SessionBase, FuncSessionBase, UInt64, Change, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase,System.Func{VelocityDb.Session.SessionBase,System.UInt64,VelocityDb.Sync.Change,System.Boolean})"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static void SyncWith(
    this SessionBase sessionToUpdate,
    SessionBase sessionToRead,
    Func<SessionBase, ulong, Change, bool> doUpdate
)
<ExtensionAttribute>
Public Shared Sub SyncWith (
    sessionToUpdate As SessionBase,
    sessionToRead As SessionBase,
    doUpdate As Func(Of SessionBase, ULong, Change, Boolean)
)
public:
[ExtensionAttribute]
static void SyncWith(
    SessionBase^ sessionToUpdate,
    SessionBase^ sessionToRead,
    Func<SessionBase^, unsigned long long, Change^, bool>^ doUpdate
)
[<ExtensionAttribute>]
static member SyncWith :
        sessionToUpdate : SessionBase *
        sessionToRead : SessionBase *
        doUpdate : Func<SessionBase, uint64, Change, bool> -> unit

Parameters

sessionToUpdate
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionToUpdate"/> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase,System.Func{VelocityDb.Session.SessionBase,System.UInt64,VelocityDb.Sync.Change,System.Boolean})"]

sessionToRead
Type: VelocityDb.SessionSessionBase

[Missing <param name="sessionToRead"/> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase,System.Func{VelocityDb.Session.SessionBase,System.UInt64,VelocityDb.Sync.Change,System.Boolean})"]

doUpdate
Type: SystemFunc SessionBase, UInt64, Change, Boolean

[Missing <param name="doUpdate"/> documentation for "M:VelocityDBExtensions.Sync.SyncWith(VelocityDb.Session.SessionBase,VelocityDb.Session.SessionBase,System.Func{VelocityDb.Session.SessionBase,System.UInt64,VelocityDb.Sync.Change,System.Boolean})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SessionBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Sync Class
SyncWith Overload
VelocityDBExtensions Namespace


SyncProvider Class

[Missing <summary> documentation for "T:VelocityDBExtensions.SyncProvider"]

Inheritance Hierarchy
SystemObject
SyncProvider
KnowledgeSyncProvider
VelocityDBExtensionsSyncProvider

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class SyncProvider : KnowledgeSyncProvider,
    IChangeDataRetriever, INotifyingChangeApplierTarget
Public Class SyncProvider
    Inherits KnowledgeSyncProvider
    Implements IChangeDataRetriever, INotifyingChangeApplierTarget
public ref class SyncProvider : public KnowledgeSyncProvider,
    IChangeDataRetriever, INotifyingChangeApplierTarget
type SyncProvider =
    class
        inherit KnowledgeSyncProvider
        interface IChangeDataRetriever
        interface INotifyingChangeApplierTarget
    end

The SyncProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SyncProvider | Initializes a new instance of the SyncProvider class
Top
Properties
 | Name | Description
Public property | IdFormats | (Overrides KnowledgeSyncProvider.IdFormats.)
Top
Methods
 | Name | Description
Public method | BeginSession | (Overrides KnowledgeSyncProvider.BeginSession(SyncProviderPosition, SyncSessionContext).)
Public method | EndSession | (Overrides KnowledgeSyncProvider.EndSession(SyncSessionContext).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetChangeBatch | (Overrides KnowledgeSyncProvider.GetChangeBatch(UInt32, SyncKnowledge, Object).)
Public method | GetDataRetriever |
Public method | GetFullEnumerationChangeBatch | (Overrides KnowledgeSyncProvider.GetFullEnumerationChangeBatch(UInt32, SyncId, SyncKnowledge, Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetNextTickCount |
Public method | GetSyncBatchParameters | (Overrides KnowledgeSyncProvider.GetSyncBatchParameters(UInt32, SyncKnowledge).)
Public method | LoadChangeData |
Public method | ProcessChangeBatch | (Overrides KnowledgeSyncProvider.ProcessChangeBatch(ConflictResolutionPolicy, ChangeBatch, Object, SyncCallbacks, SyncSessionStatistics).)
Public method | ProcessFullEnumerationChangeBatch | (Overrides KnowledgeSyncProvider.ProcessFullEnumerationChangeBatch(ConflictResolutionPolicy, FullEnumerationChangeBatch, Object, SyncCallbacks, SyncSessionStatistics).)
Public method | SaveChangeWithChangeUnits |
Public method | SaveConflict |
Public method | SaveItemChange |
Public method | StoreKnowledgeForScope |
Public method | ToString | (Overrides ObjectToString.)
Public method | TryGetDestinationVersion |
Top
See Also

Reference

VelocityDBExtensions Namespace


SyncProvider Constructor

Initializes a new instance of the SyncProvider class

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public SyncProvider(
    SessionBase session
)
Public Sub New (
    session As SessionBase
)
public:
SyncProvider(
    SessionBase^ session
)
new :
        session : SessionBase -> SyncProvider

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.SyncProvider.#ctor(VelocityDb.Session.SessionBase)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider Properties

The SyncProvider type exposes the following members.

Properties
 | Name | Description
Public property | IdFormats | (Overrides KnowledgeSyncProvider.IdFormats.)
Top
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.IdFormats Property

SyncProviderIdFormats Property

[Missing <summary> documentation for "P:VelocityDBExtensions.SyncProvider.IdFormats"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override SyncIdFormatGroup IdFormats { get; }
Public Overrides ReadOnly Property IdFormats As SyncIdFormatGroup
    Get
public:
virtual property SyncIdFormatGroup^ IdFormats {
    SyncIdFormatGroup^ get () override;
}
abstract IdFormats : SyncIdFormatGroup with get
override IdFormats : SyncIdFormatGroup with get

Property Value

Type: SyncIdFormatGroup

Implements

IChangeDataRetriever.IdFormats
INotifyingChangeApplierTarget.IdFormats
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider Methods

The SyncProvider type exposes the following members.

Methods
 | Name | Description
Public method | BeginSession | (Overrides KnowledgeSyncProvider.BeginSession(SyncProviderPosition, SyncSessionContext).)
Public method | EndSession | (Overrides KnowledgeSyncProvider.EndSession(SyncSessionContext).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetChangeBatch | (Overrides KnowledgeSyncProvider.GetChangeBatch(UInt32, SyncKnowledge, Object).)
Public method | GetDataRetriever |
Public method | GetFullEnumerationChangeBatch | (Overrides KnowledgeSyncProvider.GetFullEnumerationChangeBatch(UInt32, SyncId, SyncKnowledge, Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetNextTickCount |
Public method | GetSyncBatchParameters | (Overrides KnowledgeSyncProvider.GetSyncBatchParameters(UInt32, SyncKnowledge).)
Public method | LoadChangeData |
Public method | ProcessChangeBatch | (Overrides KnowledgeSyncProvider.ProcessChangeBatch(ConflictResolutionPolicy, ChangeBatch, Object, SyncCallbacks, SyncSessionStatistics).)
Public method | ProcessFullEnumerationChangeBatch | (Overrides KnowledgeSyncProvider.ProcessFullEnumerationChangeBatch(ConflictResolutionPolicy, FullEnumerationChangeBatch, Object, SyncCallbacks, SyncSessionStatistics).)
Public method | SaveChangeWithChangeUnits |
Public method | SaveConflict |
Public method | SaveItemChange |
Public method | StoreKnowledgeForScope |
Public method | ToString | (Overrides ObjectToString.)
Public method | TryGetDestinationVersion |
Top
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.BeginSession Method

SyncProviderBeginSession Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.BeginSession(Microsoft.Synchronization.SyncProviderPosition,Microsoft.Synchronization.SyncSessionContext)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void BeginSession(
    SyncProviderPosition position,
    SyncSessionContext syncSessionContext
)
Public Overrides Sub BeginSession (
    position As SyncProviderPosition,
    syncSessionContext As SyncSessionContext
)
public:
virtual void BeginSession(
    SyncProviderPosition position,
    SyncSessionContext^ syncSessionContext
) override
abstract BeginSession :
        position : SyncProviderPosition *
        syncSessionContext : SyncSessionContext -> unit
override BeginSession :
        position : SyncProviderPosition *
        syncSessionContext : SyncSessionContext -> unit

Parameters

position
Type: SyncProviderPosition

[Missing <param name="position"/> documentation for "M:VelocityDBExtensions.SyncProvider.BeginSession(Microsoft.Synchronization.SyncProviderPosition,Microsoft.Synchronization.SyncSessionContext)"]

syncSessionContext
Type: SyncSessionContext

[Missing <param name="syncSessionContext"/> documentation for "M:VelocityDBExtensions.SyncProvider.BeginSession(Microsoft.Synchronization.SyncProviderPosition,Microsoft.Synchronization.SyncSessionContext)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.EndSession Method

SyncProviderEndSession Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.EndSession(Microsoft.Synchronization.SyncSessionContext)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void EndSession(
    SyncSessionContext syncSessionContext
)
Public Overrides Sub EndSession (
    syncSessionContext As SyncSessionContext
)
public:
virtual void EndSession(
    SyncSessionContext^ syncSessionContext
) override
abstract EndSession :
        syncSessionContext : SyncSessionContext -> unit
override EndSession :
        syncSessionContext : SyncSessionContext -> unit

Parameters

syncSessionContext
Type: SyncSessionContext

[Missing <param name="syncSessionContext"/> documentation for "M:VelocityDBExtensions.SyncProvider.EndSession(Microsoft.Synchronization.SyncSessionContext)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.Equals Method

SyncProviderEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.Equals(System.Object)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDBExtensions.SyncProvider.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.Equals(System.Object)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetChangeBatch Method

SyncProviderGetChangeBatch Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetChangeBatch(System.UInt32,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ChangeBatch GetChangeBatch(
    uint batchSize,
    SyncKnowledge destinationKnowledge,
    out Object changeDataRetriever
)
Public Overrides Function GetChangeBatch (
    batchSize As UInteger,
    destinationKnowledge As SyncKnowledge,
    <OutAttribute> ByRef changeDataRetriever As Object
) As ChangeBatch
public:
virtual ChangeBatch^ GetChangeBatch(
    unsigned int batchSize,
    SyncKnowledge^ destinationKnowledge,
    [OutAttribute] Object^% changeDataRetriever
) override
abstract GetChangeBatch :
        batchSize : uint32 *
        destinationKnowledge : SyncKnowledge *
        changeDataRetriever : Object byref -> ChangeBatch
override GetChangeBatch :
        batchSize : uint32 *
        destinationKnowledge : SyncKnowledge *
        changeDataRetriever : Object byref -> ChangeBatch

Parameters

batchSize
Type: SystemUInt32

[Missing <param name="batchSize"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetChangeBatch(System.UInt32,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

destinationKnowledge
Type: SyncKnowledge

[Missing <param name="destinationKnowledge"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetChangeBatch(System.UInt32,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

changeDataRetriever
Type: SystemObject

[Missing <param name="changeDataRetriever"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetChangeBatch(System.UInt32,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

Return Value

Type: ChangeBatch

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.GetChangeBatch(System.UInt32,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetDataRetriever Method

SyncProviderGetDataRetriever Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetDataRetriever"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IChangeDataRetriever GetDataRetriever()
Public Function GetDataRetriever As IChangeDataRetriever
public:
virtual IChangeDataRetriever^ GetDataRetriever() sealed
abstract GetDataRetriever : unit -> IChangeDataRetriever
override GetDataRetriever : unit -> IChangeDataRetriever

Return Value

Type: IChangeDataRetriever

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.GetDataRetriever"]

Implements

INotifyingChangeApplierTarget.GetDataRetriever
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetFullEnumerationChangeBatch Method

SyncProviderGetFullEnumerationChangeBatch Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override FullEnumerationChangeBatch GetFullEnumerationChangeBatch(
    uint batchSize,
    SyncId lowerEnumerationBound,
    SyncKnowledge knowledgeForDataRetrieval,
    out Object changeDataRetriever
)
Public Overrides Function GetFullEnumerationChangeBatch (
    batchSize As UInteger,
    lowerEnumerationBound As SyncId,
    knowledgeForDataRetrieval As SyncKnowledge,
    <OutAttribute> ByRef changeDataRetriever As Object
) As FullEnumerationChangeBatch
public:
virtual FullEnumerationChangeBatch^ GetFullEnumerationChangeBatch(
    unsigned int batchSize,
    SyncId^ lowerEnumerationBound,
    SyncKnowledge^ knowledgeForDataRetrieval,
    [OutAttribute] Object^% changeDataRetriever
) override
abstract GetFullEnumerationChangeBatch :
        batchSize : uint32 *
        lowerEnumerationBound : SyncId *
        knowledgeForDataRetrieval : SyncKnowledge *
        changeDataRetriever : Object byref -> FullEnumerationChangeBatch
override GetFullEnumerationChangeBatch :
        batchSize : uint32 *
        lowerEnumerationBound : SyncId *
        knowledgeForDataRetrieval : SyncKnowledge *
        changeDataRetriever : Object byref -> FullEnumerationChangeBatch

Parameters

batchSize
Type: SystemUInt32

[Missing <param name="batchSize"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

lowerEnumerationBound
Type: SyncId

[Missing <param name="lowerEnumerationBound"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

knowledgeForDataRetrieval
Type: SyncKnowledge

[Missing <param name="knowledgeForDataRetrieval"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

changeDataRetriever
Type: SystemObject

[Missing <param name="changeDataRetriever"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

Return Value

Type: FullEnumerationChangeBatch

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.GetFullEnumerationChangeBatch(System.UInt32,Microsoft.Synchronization.SyncId,Microsoft.Synchronization.SyncKnowledge,System.Object@)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetHashCode Method

SyncProviderGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetHashCode"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.GetHashCode"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetNextTickCount Method

SyncProviderGetNextTickCount Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetNextTickCount"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetNextTickCount()
Public Function GetNextTickCount As ULong
public:
virtual unsigned long long GetNextTickCount() sealed
abstract GetNextTickCount : unit -> uint64
override GetNextTickCount : unit -> uint64

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.GetNextTickCount"]

Implements

INotifyingChangeApplierTarget.GetNextTickCount
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.GetSyncBatchParameters Method

SyncProviderGetSyncBatchParameters Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.GetSyncBatchParameters(System.UInt32@,Microsoft.Synchronization.SyncKnowledge@)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void GetSyncBatchParameters(
    out uint batchSize,
    out SyncKnowledge knowledge
)
Public Overrides Sub GetSyncBatchParameters (
    <OutAttribute> ByRef batchSize As UInteger,
    <OutAttribute> ByRef knowledge As SyncKnowledge
)
public:
virtual void GetSyncBatchParameters(
    [OutAttribute] unsigned int% batchSize,
    [OutAttribute] SyncKnowledge^% knowledge
) override
abstract GetSyncBatchParameters :
        batchSize : uint32 byref *
        knowledge : SyncKnowledge byref -> unit
override GetSyncBatchParameters :
        batchSize : uint32 byref *
        knowledge : SyncKnowledge byref -> unit

Parameters

batchSize
Type: SystemUInt32

[Missing <param name="batchSize"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetSyncBatchParameters(System.UInt32@,Microsoft.Synchronization.SyncKnowledge@)"]

knowledge
Type: SyncKnowledge

[Missing <param name="knowledge"/> documentation for "M:VelocityDBExtensions.SyncProvider.GetSyncBatchParameters(System.UInt32@,Microsoft.Synchronization.SyncKnowledge@)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.LoadChangeData Method

SyncProviderLoadChangeData Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.LoadChangeData(Microsoft.Synchronization.LoadChangeContext)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object LoadChangeData(
    LoadChangeContext loadChangeContext
)
Public Function LoadChangeData (
    loadChangeContext As LoadChangeContext
) As Object
public:
virtual Object^ LoadChangeData(
    LoadChangeContext^ loadChangeContext
) sealed
abstract LoadChangeData :
        loadChangeContext : LoadChangeContext -> Object
override LoadChangeData :
        loadChangeContext : LoadChangeContext -> Object

Parameters

loadChangeContext
Type: LoadChangeContext

[Missing <param name="loadChangeContext"/> documentation for "M:VelocityDBExtensions.SyncProvider.LoadChangeData(Microsoft.Synchronization.LoadChangeContext)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.LoadChangeData(Microsoft.Synchronization.LoadChangeContext)"]

Implements

IChangeDataRetriever.LoadChangeData(LoadChangeContext)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.ProcessChangeBatch Method

SyncProviderProcessChangeBatch Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ProcessChangeBatch(
    ConflictResolutionPolicy resolutionPolicy,
    ChangeBatch sourceChanges,
    Object changeDataRetriever,
    SyncCallbacks syncCallbacks,
    SyncSessionStatistics sessionStatistics
)
Public Overrides Sub ProcessChangeBatch (
    resolutionPolicy As ConflictResolutionPolicy,
    sourceChanges As ChangeBatch,
    changeDataRetriever As Object,
    syncCallbacks As SyncCallbacks,
    sessionStatistics As SyncSessionStatistics
)
public:
virtual void ProcessChangeBatch(
    ConflictResolutionPolicy resolutionPolicy,
    ChangeBatch^ sourceChanges,
    Object^ changeDataRetriever,
    SyncCallbacks^ syncCallbacks,
    SyncSessionStatistics^ sessionStatistics
) override
abstract ProcessChangeBatch :
        resolutionPolicy : ConflictResolutionPolicy *
        sourceChanges : ChangeBatch *
        changeDataRetriever : Object *
        syncCallbacks : SyncCallbacks *
        sessionStatistics : SyncSessionStatistics -> unit
override ProcessChangeBatch :
        resolutionPolicy : ConflictResolutionPolicy *
        sourceChanges : ChangeBatch *
        changeDataRetriever : Object *
        syncCallbacks : SyncCallbacks *
        sessionStatistics : SyncSessionStatistics -> unit

Parameters

resolutionPolicy
Type: ConflictResolutionPolicy

[Missing <param name="resolutionPolicy"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

sourceChanges
Type: ChangeBatch

[Missing <param name="sourceChanges"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

changeDataRetriever
Type: SystemObject

[Missing <param name="changeDataRetriever"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

syncCallbacks
Type: SyncCallbacks

[Missing <param name="syncCallbacks"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

sessionStatistics
Type: SyncSessionStatistics

[Missing <param name="sessionStatistics"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.ChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.ProcessFullEnumerationChangeBatch Method

SyncProviderProcessFullEnumerationChangeBatch Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void ProcessFullEnumerationChangeBatch(
    ConflictResolutionPolicy resolutionPolicy,
    FullEnumerationChangeBatch sourceChanges,
    Object changeDataRetriever,
    SyncCallbacks syncCallbacks,
    SyncSessionStatistics sessionStatistics
)
Public Overrides Sub ProcessFullEnumerationChangeBatch (
    resolutionPolicy As ConflictResolutionPolicy,
    sourceChanges As FullEnumerationChangeBatch,
    changeDataRetriever As Object,
    syncCallbacks As SyncCallbacks,
    sessionStatistics As SyncSessionStatistics
)
public:
virtual void ProcessFullEnumerationChangeBatch(
    ConflictResolutionPolicy resolutionPolicy,
    FullEnumerationChangeBatch^ sourceChanges,
    Object^ changeDataRetriever,
    SyncCallbacks^ syncCallbacks,
    SyncSessionStatistics^ sessionStatistics
) override
abstract ProcessFullEnumerationChangeBatch :
        resolutionPolicy : ConflictResolutionPolicy *
        sourceChanges : FullEnumerationChangeBatch *
        changeDataRetriever : Object *
        syncCallbacks : SyncCallbacks *
        sessionStatistics : SyncSessionStatistics -> unit
override ProcessFullEnumerationChangeBatch :
        resolutionPolicy : ConflictResolutionPolicy *
        sourceChanges : FullEnumerationChangeBatch *
        changeDataRetriever : Object *
        syncCallbacks : SyncCallbacks *
        sessionStatistics : SyncSessionStatistics -> unit

Parameters

resolutionPolicy
Type: ConflictResolutionPolicy

[Missing <param name="resolutionPolicy"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

sourceChanges
Type: FullEnumerationChangeBatch

[Missing <param name="sourceChanges"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

changeDataRetriever
Type: SystemObject

[Missing <param name="changeDataRetriever"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

syncCallbacks
Type: SyncCallbacks

[Missing <param name="syncCallbacks"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

sessionStatistics
Type: SyncSessionStatistics

[Missing <param name="sessionStatistics"/> documentation for "M:VelocityDBExtensions.SyncProvider.ProcessFullEnumerationChangeBatch(Microsoft.Synchronization.ConflictResolutionPolicy,Microsoft.Synchronization.FullEnumerationChangeBatch,System.Object,Microsoft.Synchronization.SyncCallbacks,Microsoft.Synchronization.SyncSessionStatistics)"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.SaveChangeWithChangeUnits Method

SyncProviderSaveChangeWithChangeUnits Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.SaveChangeWithChangeUnits(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeWithChangeUnitsContext)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SaveChangeWithChangeUnits(
    ItemChange change,
    SaveChangeWithChangeUnitsContext context
)
Public Sub SaveChangeWithChangeUnits (
    change As ItemChange,
    context As SaveChangeWithChangeUnitsContext
)
public:
virtual void SaveChangeWithChangeUnits(
    ItemChange^ change,
    SaveChangeWithChangeUnitsContext^ context
) sealed
abstract SaveChangeWithChangeUnits :
        change : ItemChange *
        context : SaveChangeWithChangeUnitsContext -> unit
override SaveChangeWithChangeUnits :
        change : ItemChange *
        context : SaveChangeWithChangeUnitsContext -> unit

Parameters

change
Type: ItemChange

[Missing <param name="change"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveChangeWithChangeUnits(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeWithChangeUnitsContext)"]

context
Type: SaveChangeWithChangeUnitsContext

[Missing <param name="context"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveChangeWithChangeUnits(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeWithChangeUnitsContext)"]

Implements

INotifyingChangeApplierTarget.SaveChangeWithChangeUnits(ItemChange, SaveChangeWithChangeUnitsContext)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.SaveConflict Method

SyncProviderSaveConflict Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.SaveConflict(Microsoft.Synchronization.ItemChange,System.Object,Microsoft.Synchronization.SyncKnowledge)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SaveConflict(
    ItemChange conflictingChange,
    Object conflictingChangeData,
    SyncKnowledge conflictingChangeKnowledge
)
Public Sub SaveConflict (
    conflictingChange As ItemChange,
    conflictingChangeData As Object,
    conflictingChangeKnowledge As SyncKnowledge
)
public:
virtual void SaveConflict(
    ItemChange^ conflictingChange,
    Object^ conflictingChangeData,
    SyncKnowledge^ conflictingChangeKnowledge
) sealed
abstract SaveConflict :
        conflictingChange : ItemChange *
        conflictingChangeData : Object *
        conflictingChangeKnowledge : SyncKnowledge -> unit
override SaveConflict :
        conflictingChange : ItemChange *
        conflictingChangeData : Object *
        conflictingChangeKnowledge : SyncKnowledge -> unit

Parameters

conflictingChange
Type: ItemChange

[Missing <param name="conflictingChange"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveConflict(Microsoft.Synchronization.ItemChange,System.Object,Microsoft.Synchronization.SyncKnowledge)"]

conflictingChangeData
Type: SystemObject

[Missing <param name="conflictingChangeData"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveConflict(Microsoft.Synchronization.ItemChange,System.Object,Microsoft.Synchronization.SyncKnowledge)"]

conflictingChangeKnowledge
Type: SyncKnowledge

[Missing <param name="conflictingChangeKnowledge"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveConflict(Microsoft.Synchronization.ItemChange,System.Object,Microsoft.Synchronization.SyncKnowledge)"]

Implements

INotifyingChangeApplierTarget.SaveConflict(ItemChange, Object, SyncKnowledge)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.SaveItemChange Method

SyncProviderSaveItemChange Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.SaveItemChange(Microsoft.Synchronization.SaveChangeAction,Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeContext)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SaveItemChange(
    SaveChangeAction saveChangeAction,
    ItemChange change,
    SaveChangeContext context
)
Public Sub SaveItemChange (
    saveChangeAction As SaveChangeAction,
    change As ItemChange,
    context As SaveChangeContext
)
public:
virtual void SaveItemChange(
    SaveChangeAction saveChangeAction,
    ItemChange^ change,
    SaveChangeContext^ context
) sealed
abstract SaveItemChange :
        saveChangeAction : SaveChangeAction *
        change : ItemChange *
        context : SaveChangeContext -> unit
override SaveItemChange :
        saveChangeAction : SaveChangeAction *
        change : ItemChange *
        context : SaveChangeContext -> unit

Parameters

saveChangeAction
Type: SaveChangeAction

[Missing <param name="saveChangeAction"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveItemChange(Microsoft.Synchronization.SaveChangeAction,Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeContext)"]

change
Type: ItemChange

[Missing <param name="change"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveItemChange(Microsoft.Synchronization.SaveChangeAction,Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeContext)"]

context
Type: SaveChangeContext

[Missing <param name="context"/> documentation for "M:VelocityDBExtensions.SyncProvider.SaveItemChange(Microsoft.Synchronization.SaveChangeAction,Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.SaveChangeContext)"]

Implements

INotifyingChangeApplierTarget.SaveItemChange(SaveChangeAction, ItemChange, SaveChangeContext)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.StoreKnowledgeForScope Method

SyncProviderStoreKnowledgeForScope Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.StoreKnowledgeForScope(Microsoft.Synchronization.SyncKnowledge,Microsoft.Synchronization.ForgottenKnowledge)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void StoreKnowledgeForScope(
    SyncKnowledge knowledge,
    ForgottenKnowledge forgottenKnowledge
)
Public Sub StoreKnowledgeForScope (
    knowledge As SyncKnowledge,
    forgottenKnowledge As ForgottenKnowledge
)
public:
virtual void StoreKnowledgeForScope(
    SyncKnowledge^ knowledge,
    ForgottenKnowledge^ forgottenKnowledge
) sealed
abstract StoreKnowledgeForScope :
        knowledge : SyncKnowledge *
        forgottenKnowledge : ForgottenKnowledge -> unit
override StoreKnowledgeForScope :
        knowledge : SyncKnowledge *
        forgottenKnowledge : ForgottenKnowledge -> unit

Parameters

knowledge
Type: SyncKnowledge

[Missing <param name="knowledge"/> documentation for "M:VelocityDBExtensions.SyncProvider.StoreKnowledgeForScope(Microsoft.Synchronization.SyncKnowledge,Microsoft.Synchronization.ForgottenKnowledge)"]

forgottenKnowledge
Type: ForgottenKnowledge

[Missing <param name="forgottenKnowledge"/> documentation for "M:VelocityDBExtensions.SyncProvider.StoreKnowledgeForScope(Microsoft.Synchronization.SyncKnowledge,Microsoft.Synchronization.ForgottenKnowledge)"]

Implements

INotifyingChangeApplierTarget.StoreKnowledgeForScope(SyncKnowledge, ForgottenKnowledge)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.ToString Method

SyncProviderToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.ToString"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.ToString"]

See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


SyncProvider.TryGetDestinationVersion Method

SyncProviderTryGetDestinationVersion Method

[Missing <summary> documentation for "M:VelocityDBExtensions.SyncProvider.TryGetDestinationVersion(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.ItemChange@)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetDestinationVersion(
    ItemChange sourceChange,
    out ItemChange destinationVersion
)
Public Function TryGetDestinationVersion (
    sourceChange As ItemChange,
    <OutAttribute> ByRef destinationVersion As ItemChange
) As Boolean
public:
virtual bool TryGetDestinationVersion(
    ItemChange^ sourceChange,
    [OutAttribute] ItemChange^% destinationVersion
) sealed
abstract TryGetDestinationVersion :
        sourceChange : ItemChange *
        destinationVersion : ItemChange byref -> bool
override TryGetDestinationVersion :
        sourceChange : ItemChange *
        destinationVersion : ItemChange byref -> bool

Parameters

sourceChange
Type: ItemChange

[Missing <param name="sourceChange"/> documentation for "M:VelocityDBExtensions.SyncProvider.TryGetDestinationVersion(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.ItemChange@)"]

destinationVersion
Type: ItemChange

[Missing <param name="destinationVersion"/> documentation for "M:VelocityDBExtensions.SyncProvider.TryGetDestinationVersion(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.ItemChange@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.SyncProvider.TryGetDestinationVersion(Microsoft.Synchronization.ItemChange,Microsoft.Synchronization.ItemChange@)"]

Implements

INotifyingChangeApplierTarget.TryGetDestinationVersion(ItemChange, ItemChange)
See Also

Reference

SyncProvider Class
VelocityDBExtensions Namespace


Utilities Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Utilities"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensionsUtilities

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class Utilities
<ExtensionAttribute>
Public NotInheritable Class Utilities
[ExtensionAttribute]
public ref class Utilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type Utilities =  class end

The Utilities type exposes the following members.

Methods
Name | Description
ArrayToString |
ToStringDetails(OptimizedPersistable, SessionBase, Boolean) |
ToStringDetails(OptimizedPersistable, Schema, TypeVersion, Boolean) |
ToStringDetails(DataMember, Object, IOptimizedPersistable, Page, Boolean) |
Top
See Also

Reference

VelocityDBExtensions Namespace


Utilities Methods

The Utilities type exposes the following members.

Methods
Name | Description
ArrayToString |
ToStringDetails(OptimizedPersistable, SessionBase, Boolean) |
ToStringDetails(OptimizedPersistable, Schema, TypeVersion, Boolean) |
ToStringDetails(DataMember, Object, IOptimizedPersistable, Page, Boolean) |
Top
See Also

Reference

Utilities Class
VelocityDBExtensions Namespace


Utilities.ArrayToString Method

UtilitiesArrayToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ArrayToString(
    Array array,
    bool isEncodedOidArray,
    Page page,
    Type elementType,
    string prefix = ""
)
Public Shared Function ArrayToString (
    array As Array,
    isEncodedOidArray As Boolean,
    page As Page,
    elementType As Type,
    Optional prefix As String = ""
) As String
public:
static String^ ArrayToString(
    Array^ array,
    bool isEncodedOidArray,
    Page^ page,
    Type^ elementType,
    String^ prefix = L""
)
static member ArrayToString :
        array : Array *
        isEncodedOidArray : bool *
        page : Page *
        elementType : Type *
        ?prefix : string
(* Defaults:
        let _prefix = defaultArg prefix ""
*)
-> string

Parameters

array
Type: SystemArray

[Missing <param name="array"/> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

isEncodedOidArray
Type: SystemBoolean

[Missing <param name="isEncodedOidArray"/> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

elementType
Type: SystemType

[Missing <param name="elementType"/> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

prefix (Optional)
Type: SystemString

[Missing <param name="prefix"/> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Utilities.ArrayToString(System.Array,System.Boolean,VelocityDb.Page,System.Type,System.String)"]

See Also

Reference

Utilities Class
VelocityDBExtensions Namespace


Utilities.ToStringDetails Method

UtilitiesToStringDetails Method

Overload List
Name | Description
ToStringDetails(OptimizedPersistable, SessionBase, Boolean) |
ToStringDetails(OptimizedPersistable, Schema, TypeVersion, Boolean) |
ToStringDetails(DataMember, Object, IOptimizedPersistable, Page, Boolean) |
Top
See Also

Reference

Utilities Class
VelocityDBExtensions Namespace


Utilities.ToStringDetails Method (OptimizedPersistable, SessionBase, Boolean)

UtilitiesToStringDetails Method (OptimizedPersistable, SessionBase, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ToStringDetails(
    this OptimizedPersistable pObj,
    SessionBase session,
    bool skipArrays = true
)
<ExtensionAttribute>
Public Shared Function ToStringDetails (
    pObj As OptimizedPersistable,
    session As SessionBase,
    Optional skipArrays As Boolean = true
) As String
public:
[ExtensionAttribute]
static String^ ToStringDetails(
    OptimizedPersistable^ pObj,
    SessionBase^ session,
    bool skipArrays = true
)
[<ExtensionAttribute>]
static member ToStringDetails :
        pObj : OptimizedPersistable *
        session : SessionBase *
        ?skipArrays : bool
(* Defaults:
        let _skipArrays = defaultArg skipArrays true
*)
-> string

Parameters

pObj
Type: VelocityDbOptimizedPersistable

[Missing <param name="pObj"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

skipArrays (Optional)
Type: SystemBoolean

[Missing <param name="skipArrays"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.Session.SessionBase,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OptimizedPersistable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Utilities Class
ToStringDetails Overload
VelocityDBExtensions Namespace


Utilities.ToStringDetails Method (OptimizedPersistable, Schema, TypeVersion, Boolean)

UtilitiesToStringDetails Method (OptimizedPersistable, Schema, TypeVersion, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ToStringDetails(
    this OptimizedPersistable pObj,
    Schema schema,
    TypeVersion typeVersion,
    bool skipArrays
)
<ExtensionAttribute>
Public Shared Function ToStringDetails (
    pObj As OptimizedPersistable,
    schema As Schema,
    typeVersion As TypeVersion,
    skipArrays As Boolean
) As String
public:
[ExtensionAttribute]
static String^ ToStringDetails(
    OptimizedPersistable^ pObj,
    Schema^ schema,
    TypeVersion^ typeVersion,
    bool skipArrays
)
[<ExtensionAttribute>]
static member ToStringDetails :
        pObj : OptimizedPersistable *
        schema : Schema *
        typeVersion : TypeVersion *
        skipArrays : bool -> string

Parameters

pObj
Type: VelocityDbOptimizedPersistable

[Missing <param name="pObj"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

schema
Type: VelocityDb.TypeInfoSchema

[Missing <param name="schema"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

typeVersion
Type: VelocityDb.TypeInfoTypeVersion

[Missing <param name="typeVersion"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

skipArrays
Type: SystemBoolean

[Missing <param name="skipArrays"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.OptimizedPersistable,VelocityDb.TypeInfo.Schema,VelocityDb.TypeInfo.TypeVersion,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OptimizedPersistable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Utilities Class
ToStringDetails Overload
VelocityDBExtensions Namespace


Utilities.ToStringDetails Method (DataMember, Object, IOptimizedPersistable, Page, Boolean)

UtilitiesToStringDetails Method (DataMember, Object, IOptimizedPersistable, Page, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

Namespace: VelocityDBExtensions
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string ToStringDetails(
    DataMember member,
    Object obj,
    IOptimizedPersistable pObj,
    Page page,
    bool skipArrays
)
Public Shared Function ToStringDetails (
    member As DataMember,
    obj As Object,
    pObj As IOptimizedPersistable,
    page As Page,
    skipArrays As Boolean
) As String
public:
static String^ ToStringDetails(
    DataMember^ member,
    Object^ obj,
    IOptimizedPersistable^ pObj,
    Page^ page,
    bool skipArrays
)
static member ToStringDetails :
        member : DataMember *
        obj : Object *
        pObj : IOptimizedPersistable *
        page : Page *
        skipArrays : bool -> string

Parameters

member
Type: VelocityDb.TypeInfoDataMember

[Missing <param name="member"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

pObj
Type: VelocityDbIOptimizedPersistable

[Missing <param name="pObj"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

page
Type: VelocityDbPage

[Missing <param name="page"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

skipArrays
Type: SystemBoolean

[Missing <param name="skipArrays"/> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Utilities.ToStringDetails(VelocityDb.TypeInfo.DataMember,System.Object,VelocityDb.IOptimizedPersistable,VelocityDb.Page,System.Boolean)"]

See Also

Reference

Utilities Class
ToStringDetails Overload
VelocityDBExtensions Namespace


VelocityDBExtensions.CompressedBitArray Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.CompressedBitArray"]

Classes
 | Class | Description
Public class | EwahCompressedBitArray |
Public class | EwahEnumerator |
Public class | RunningLengthWord |


EwahCompressedBitArray Class

[Missing <summary> documentation for "T:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class EwahCompressedBitArray : OptimizedPersistable,
    ICloneable, IEnumerable<int>, IEnumerable
<SerializableAttribute>
Public NotInheritable Class EwahCompressedBitArray
    Inherits OptimizedPersistable
    Implements ICloneable, IEnumerable(Of Integer),
    IEnumerable
[SerializableAttribute]
public ref class EwahCompressedBitArray sealed : public OptimizedPersistable,
    ICloneable, IEnumerable<int>, IEnumerable
[<SealedAttribute>]
[<SerializableAttribute>]
type EwahCompressedBitArray =
    class
        inherit OptimizedPersistable
        interface ICloneable
        interface IEnumerable<int>
        interface IEnumerable
    end

The EwahCompressedBitArray type exposes the following members.

Constructors
 | Name | Description
Public method | EwahCompressedBitArray | Initializes a new instance of the EwahCompressedBitArray class
Public method | EwahCompressedBitArray(Int32) | Initializes a new instance of the EwahCompressedBitArray class
Top
Properties
 | Name | Description
Public property | SizeInBits |
Public property | SizeInBytes |
Top
Methods
 | Name | Description
Public method | Add(Int64) |
Public method | Add(Int64, Int32) |
Public method | AddStreamOfEmptyWords |
Public method | And |
Public method | AndNot |
 | bitCount |
 | BitmapOf |
Public method | Clone | (Overrides OptimizedPersistableClone.)
Public method | Equals | (Overrides OptimizedPersistableEquals(Object).)
Public method | GetCardinality |
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides OptimizedPersistableGetHashCode.)
Public method | GetObjectData |
Public method | GetPositions |
Public method | Intersects |
Public method | Not |
Public method | Or |
Public method | Set |
Public method | SetSizeInBits |
Public method | Shrink |
Public method | ToDebugString |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Xor |
Top
Fields
Name | Description
WordInBits |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Constructor

Overload List
 | Name | Description
Public method | EwahCompressedBitArray | Initializes a new instance of the EwahCompressedBitArray class
Public method | EwahCompressedBitArray(Int32) | Initializes a new instance of the EwahCompressedBitArray class
Top
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Constructor

Initializes a new instance of the EwahCompressedBitArray class

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray()
Public Sub New
public:
EwahCompressedBitArray()
new : unit -> EwahCompressedBitArray
See Also

Reference

EwahCompressedBitArray Class
EwahCompressedBitArray Overload
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Constructor (Int32)

Initializes a new instance of the EwahCompressedBitArray class

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray(
    int buffersize
)
Public Sub New (
    buffersize As Integer
)
public:
EwahCompressedBitArray(
    int buffersize
)
new :
        buffersize : int -> EwahCompressedBitArray

Parameters

buffersize
Type: SystemInt32

[Missing <param name="buffersize"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.#ctor(System.Int32)"]

See Also

Reference

EwahCompressedBitArray Class
EwahCompressedBitArray Overload
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Properties

The EwahCompressedBitArray type exposes the following members.

Properties
 | Name | Description
Public property | SizeInBits |
Public property | SizeInBytes |
Top
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.SizeInBits Property

EwahCompressedBitArraySizeInBits Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SizeInBits"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int SizeInBits { get; set; }
Public Property SizeInBits As Integer
    Get
    Set
public:
property int SizeInBits {
    int get ();
    void set (int value);
}
member SizeInBits : int with get, set

Property Value

Type: Int32
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.SizeInBytes Property

EwahCompressedBitArraySizeInBytes Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SizeInBytes"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int SizeInBytes { get; }
Public ReadOnly Property SizeInBytes As Integer
    Get
public:
property int SizeInBytes {
    int get ();
}
member SizeInBytes : int with get

Property Value

Type: Int32
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Methods

The EwahCompressedBitArray type exposes the following members.

Methods
 | Name | Description
Public method | Add(Int64) |
Public method | Add(Int64, Int32) |
Public method | AddStreamOfEmptyWords |
Public method | And |
Public method | AndNot |
 | bitCount |
 | BitmapOf |
Public method | Clone | (Overrides OptimizedPersistableClone.)
Public method | Equals | (Overrides OptimizedPersistableEquals(Object).)
Public method | GetCardinality |
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides OptimizedPersistableGetHashCode.)
Public method | GetObjectData |
Public method | GetPositions |
Public method | Intersects |
Public method | Not |
Public method | Or |
Public method | Set |
Public method | SetSizeInBits |
Public method | Shrink |
Public method | ToDebugString |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Xor |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Add Method

EwahCompressedBitArrayAdd Method

Overload List
 | Name | Description
Public method | Add(Int64) |
Public method | Add(Int64, Int32) |
Top
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Add Method (Int64)

EwahCompressedBitArrayAdd Method (Int64)

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Add(
    long newdata
)
Public Function Add (
    newdata As Long
) As Integer
public:
int Add(
    long long newdata
)
member Add :
        newdata : int64 -> int

Parameters

newdata
Type: SystemInt64

[Missing <param name="newdata"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64)"]

See Also

Reference

EwahCompressedBitArray Class
Add Overload
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Add Method (Int64, Int32)

EwahCompressedBitArrayAdd Method (Int64, Int32)

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64,System.Int32)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Add(
    long newdata,
    int bitsthatmatter
)
Public Function Add (
    newdata As Long,
    bitsthatmatter As Integer
) As Integer
public:
int Add(
    long long newdata,
    int bitsthatmatter
)
member Add :
        newdata : int64 *
        bitsthatmatter : int -> int

Parameters

newdata
Type: SystemInt64

[Missing <param name="newdata"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64,System.Int32)"]

bitsthatmatter
Type: SystemInt32

[Missing <param name="bitsthatmatter"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Add(System.Int64,System.Int32)"]

See Also

Reference

EwahCompressedBitArray Class
Add Overload
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.AddStreamOfEmptyWords Method

EwahCompressedBitArrayAddStreamOfEmptyWords Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AddStreamOfEmptyWords(System.Boolean,System.Int64)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int AddStreamOfEmptyWords(
    bool v,
    long number
)
Public Function AddStreamOfEmptyWords (
    v As Boolean,
    number As Long
) As Integer
public:
int AddStreamOfEmptyWords(
    bool v,
    long long number
)
member AddStreamOfEmptyWords :
        v : bool *
        number : int64 -> int

Parameters

v
Type: SystemBoolean

[Missing <param name="v"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AddStreamOfEmptyWords(System.Boolean,System.Int64)"]

number
Type: SystemInt64

[Missing <param name="number"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AddStreamOfEmptyWords(System.Boolean,System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AddStreamOfEmptyWords(System.Boolean,System.Int64)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.And Method

EwahCompressedBitArrayAnd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.And(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray And(
    EwahCompressedBitArray a
)
Public Function And (
    a As EwahCompressedBitArray
) As EwahCompressedBitArray
public:
EwahCompressedBitArray^ And(
    EwahCompressedBitArray^ a
)
member And :
        a : EwahCompressedBitArray -> EwahCompressedBitArray

Parameters

a
Type: VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.And(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Return Value

Type: EwahCompressedBitArray

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.And(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.AndNot Method

EwahCompressedBitArrayAndNot Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AndNot(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray AndNot(
    EwahCompressedBitArray a
)
Public Function AndNot (
    a As EwahCompressedBitArray
) As EwahCompressedBitArray
public:
EwahCompressedBitArray^ AndNot(
    EwahCompressedBitArray^ a
)
member AndNot :
        a : EwahCompressedBitArray -> EwahCompressedBitArray

Parameters

a
Type: VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AndNot(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Return Value

Type: EwahCompressedBitArray

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.AndNot(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.bitCount Method

EwahCompressedBitArraybitCount Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.bitCount(System.UInt64)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static ulong bitCount(
    ulong v
)
Public Shared Function bitCount (
    v As ULong
) As ULong
public:
static unsigned long long bitCount(
    unsigned long long v
)
static member bitCount :
        v : uint64 -> uint64

Parameters

v
Type: SystemUInt64

[Missing <param name="v"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.bitCount(System.UInt64)"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.bitCount(System.UInt64)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.BitmapOf Method

EwahCompressedBitArrayBitmapOf Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.BitmapOf(System.Int32[])"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static EwahCompressedBitArray BitmapOf(
    params int[] setbits
)
Public Shared Function BitmapOf (
    ParamArray setbits As Integer()
) As EwahCompressedBitArray
public:
static EwahCompressedBitArray^ BitmapOf(
    ... array<int>^ setbits
)
static member BitmapOf :
        setbits : int[] -> EwahCompressedBitArray

Parameters

setbits
Type: SystemInt32

[Missing <param name="setbits"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.BitmapOf(System.Int32[])"]

Return Value

Type: EwahCompressedBitArray

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.BitmapOf(System.Int32[])"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Clone Method

EwahCompressedBitArrayClone Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Clone"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Clone"]

Implements

ICloneableClone
ICloneableClone
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Equals Method

EwahCompressedBitArrayEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Equals(System.Object)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Equals(System.Object)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.GetCardinality Method

EwahCompressedBitArrayGetCardinality Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetCardinality"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong GetCardinality()
Public Function GetCardinality As ULong
public:
unsigned long long GetCardinality()
member GetCardinality : unit -> uint64

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetCardinality"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.GetEnumerator Method

EwahCompressedBitArrayGetEnumerator Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetEnumerator"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<int> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Integer)
public:
virtual IEnumerator<int>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<int>
override GetEnumerator : unit -> IEnumerator<int>

Return Value

Type: IEnumerator Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.GetHashCode Method

EwahCompressedBitArrayGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetHashCode"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetHashCode"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.GetObjectData Method

EwahCompressedBitArrayGetObjectData Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
member GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo

[Missing <param name="info"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.SerializationStreamingContext

[Missing <param name="context"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.GetPositions Method

EwahCompressedBitArrayGetPositions Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetPositions"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<int> GetPositions()
Public Function GetPositions As List(Of Integer)
public:
List<int>^ GetPositions()
member GetPositions : unit -> List<int>

Return Value

Type: List Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.GetPositions"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Intersects Method

EwahCompressedBitArrayIntersects Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Intersects(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Intersects(
    EwahCompressedBitArray a
)
Public Function Intersects (
    a As EwahCompressedBitArray
) As Boolean
public:
bool Intersects(
    EwahCompressedBitArray^ a
)
member Intersects :
        a : EwahCompressedBitArray -> bool

Parameters

a
Type: VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Intersects(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Intersects(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Not Method

EwahCompressedBitArrayNot Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Not"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Not()
Public Sub Not
public:
void Not()
member Not : unit -> unit
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Or Method

EwahCompressedBitArrayOr Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Or(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray Or(
    EwahCompressedBitArray a
)
Public Function Or (
    a As EwahCompressedBitArray
) As EwahCompressedBitArray
public:
EwahCompressedBitArray^ Or(
    EwahCompressedBitArray^ a
)
member Or :
        a : EwahCompressedBitArray -> EwahCompressedBitArray

Parameters

a
Type: VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Or(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Return Value

Type: EwahCompressedBitArray

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Or(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Set Method

EwahCompressedBitArraySet Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Set(System.Int32)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    int i
)
Public Function Set (
    i As Integer
) As Boolean
public:
bool Set(
    int i
)
member Set :
        i : int -> bool

Parameters

i
Type: SystemInt32

[Missing <param name="i"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Set(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Set(System.Int32)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.SetSizeInBits Method

EwahCompressedBitArraySetSizeInBits Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SetSizeInBits(System.Int32,System.Boolean)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool SetSizeInBits(
    int size,
    bool defaultvalue
)
Public Function SetSizeInBits (
    size As Integer,
    defaultvalue As Boolean
) As Boolean
public:
bool SetSizeInBits(
    int size,
    bool defaultvalue
)
member SetSizeInBits :
        size : int *
        defaultvalue : bool -> bool

Parameters

size
Type: SystemInt32

[Missing <param name="size"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SetSizeInBits(System.Int32,System.Boolean)"]

defaultvalue
Type: SystemBoolean

[Missing <param name="defaultvalue"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SetSizeInBits(System.Int32,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.SetSizeInBits(System.Int32,System.Boolean)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Shrink Method

EwahCompressedBitArrayShrink Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Shrink"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Shrink()
Public Sub Shrink
public:
void Shrink()
member Shrink : unit -> unit
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.ToDebugString Method

EwahCompressedBitArrayToDebugString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.ToDebugString"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ToDebugString()
Public Function ToDebugString As String
public:
String^ ToDebugString()
member ToDebugString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.ToDebugString"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.ToString Method

EwahCompressedBitArrayToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.ToString"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.ToString"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.Xor Method

EwahCompressedBitArrayXor Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Xor(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahCompressedBitArray Xor(
    EwahCompressedBitArray a
)
Public Function Xor (
    a As EwahCompressedBitArray
) As EwahCompressedBitArray
public:
EwahCompressedBitArray^ Xor(
    EwahCompressedBitArray^ a
)
member Xor :
        a : EwahCompressedBitArray -> EwahCompressedBitArray

Parameters

a
Type: VelocityDBExtensions.CompressedBitArrayEwahCompressedBitArray

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Xor(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

Return Value

Type: EwahCompressedBitArray

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.Xor(VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray)"]

See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray Fields

The EwahCompressedBitArray type exposes the following members.

Fields
Name | Description
WordInBits |
Top
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahCompressedBitArray.WordInBits Field

EwahCompressedBitArrayWordInBits Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.EwahCompressedBitArray.WordInBits"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const int WordInBits = 64
Public Const WordInBits As Integer = 64
public:
literal int WordInBits = 64
static val mutable WordInBits: int

Field Value

Type: Int32
See Also

Reference

EwahCompressedBitArray Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator Class

[Missing <summary> documentation for "T:VelocityDBExtensions.CompressedBitArray.EwahEnumerator"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.CompressedBitArrayEwahEnumerator

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class EwahEnumerator
Public NotInheritable Class EwahEnumerator
public ref class EwahEnumerator sealed
[<SealedAttribute>]
type EwahEnumerator =  class end

The EwahEnumerator type exposes the following members.

Constructors
 | Name | Description
Public method | EwahEnumerator | Initializes a new instance of the EwahEnumerator class
Top
Properties
 | Name | Description
Public property | Buffer |
Public property | DirtyWords |
Top
Methods
 | Name | Description
Public method | HasNext |
Public method | Next |
Top
Fields
 | Name | Description
Public field | _Rlw |
Top
See Also

Reference

VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator Constructor

Initializes a new instance of the EwahEnumerator class

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EwahEnumerator(
    long[] a,
    int sizeinwords
)
Public Sub New (
    a As Long(),
    sizeinwords As Integer
)
public:
EwahEnumerator(
    array<long long>^ a,
    int sizeinwords
)
new :
        a : int64[] *
        sizeinwords : int -> EwahEnumerator

Parameters

a
Type: SystemInt64

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.#ctor(System.Int64[],System.Int32)"]

sizeinwords
Type: SystemInt32

[Missing <param name="sizeinwords"/> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.#ctor(System.Int64[],System.Int32)"]

See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator Properties

The EwahEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Buffer |
Public property | DirtyWords |
Top
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator.Buffer Property

EwahEnumeratorBuffer Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.Buffer"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long[] Buffer { get; }
Public ReadOnly Property Buffer As Long()
    Get
public:
property array<long long>^ Buffer {
    array<long long>^ get ();
}
member Buffer : int64[] with get

Property Value

Type: Int64
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator.DirtyWords Property

EwahEnumeratorDirtyWords Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.DirtyWords"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int DirtyWords { get; }
Public ReadOnly Property DirtyWords As Integer
    Get
public:
property int DirtyWords {
    int get ();
}
member DirtyWords : int with get

Property Value

Type: Int32
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator Methods

The EwahEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | HasNext |
Public method | Next |
Top
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator.HasNext Method

EwahEnumeratorHasNext Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.HasNext"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool HasNext()
Public Function HasNext As Boolean
public:
bool HasNext()
member HasNext : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.HasNext"]

See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator.Next Method

EwahEnumeratorNext Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.Next"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RunningLengthWord Next()
Public Function Next As RunningLengthWord
public:
RunningLengthWord^ Next()
member Next : unit -> RunningLengthWord

Return Value

Type: RunningLengthWord

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.EwahEnumerator.Next"]

See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator Fields

The EwahEnumerator type exposes the following members.

Fields
 | Name | Description
Public field | _Rlw |
Top
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


EwahEnumerator._Rlw Field

EwahEnumerator_Rlw Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.EwahEnumerator._Rlw"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public readonly RunningLengthWord _Rlw
Public ReadOnly _Rlw As RunningLengthWord
public:
initonly RunningLengthWord^ _Rlw
val _Rlw: RunningLengthWord

Field Value

Type: RunningLengthWord
See Also

Reference

EwahEnumerator Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord Class

[Missing <summary> documentation for "T:VelocityDBExtensions.CompressedBitArray.RunningLengthWord"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions.CompressedBitArrayRunningLengthWord

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public sealed class RunningLengthWord : OptimizedPersistable
Public NotInheritable Class RunningLengthWord
    Inherits OptimizedPersistable
public ref class RunningLengthWord sealed : public OptimizedPersistable
[<SealedAttribute>]
type RunningLengthWord =
    class
        inherit OptimizedPersistable
    end

The RunningLengthWord type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | NumberOfLiteralWords |
Public property | RunningBit |
Public property | RunningLength |
Top
Methods
 | Name | Description
Public method | Clone | (Overrides OptimizedPersistableClone.)
Public method | ToString | (Overrides OptimizedPersistableToString.)
Top
Fields
 | Name | Description
Public field | ArrayOfWords |
 | LargestLiteralCount |
 | LargestRunningLengthCount |
Public field | Position |
 | RunningLengthBits |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord Properties

The RunningLengthWord type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | NumberOfLiteralWords |
Public property | RunningBit |
Public property | RunningLength |
Top
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.Count Property

RunningLengthWordCount Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.Count"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long Count { get; }
Public ReadOnly Property Count As Long
    Get
public:
property long long Count {
    long long get ();
}
member Count : int64 with get

Property Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.NumberOfLiteralWords Property

RunningLengthWordNumberOfLiteralWords Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.NumberOfLiteralWords"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long NumberOfLiteralWords { get; set; }
Public Property NumberOfLiteralWords As Long
    Get
    Set
public:
property long long NumberOfLiteralWords {
    long long get ();
    void set (long long value);
}
member NumberOfLiteralWords : int64 with get, set

Property Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.RunningBit Property

RunningLengthWordRunningBit Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.RunningBit"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool RunningBit { get; set; }
Public Property RunningBit As Boolean
    Get
    Set
public:
property bool RunningBit {
    bool get ();
    void set (bool value);
}
member RunningBit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.RunningLength Property

RunningLengthWordRunningLength Property

[Missing <summary> documentation for "P:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.RunningLength"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long RunningLength { get; set; }
Public Property RunningLength As Long
    Get
    Set
public:
property long long RunningLength {
    long long get ();
    void set (long long value);
}
member RunningLength : int64 with get, set

Property Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord Methods

The RunningLengthWord type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Overrides OptimizedPersistableClone.)
Public method | ToString | (Overrides OptimizedPersistableToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.Clone Method

RunningLengthWordClone Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.Clone"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.Clone"]

Implements

ICloneableClone
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.ToString Method

RunningLengthWordToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.ToString"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.ToString"]

See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord Fields

The RunningLengthWord type exposes the following members.

Fields
 | Name | Description
Public field | ArrayOfWords |
 | LargestLiteralCount |
 | LargestRunningLengthCount |
Public field | Position |
 | RunningLengthBits |
Top
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.ArrayOfWords Field

RunningLengthWordArrayOfWords Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.ArrayOfWords"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long[] ArrayOfWords
Public ArrayOfWords As Long()
public:
array<long long>^ ArrayOfWords
val mutable ArrayOfWords: int64[]

Field Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.LargestLiteralCount Field

RunningLengthWordLargestLiteralCount Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.LargestLiteralCount"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const long LargestLiteralCount = 2147483647
Public Const LargestLiteralCount As Long = 2147483647
public:
literal long long LargestLiteralCount = 2147483647
static val mutable LargestLiteralCount: int64

Field Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.LargestRunningLengthCount Field

RunningLengthWordLargestRunningLengthCount Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.LargestRunningLengthCount"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const long LargestRunningLengthCount = 4294967295
Public Const LargestRunningLengthCount As Long = 4294967295
public:
literal long long LargestRunningLengthCount = 4294967295
static val mutable LargestRunningLengthCount: int64

Field Value

Type: Int64
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.Position Field

RunningLengthWordPosition Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.Position"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Position
Public Position As Integer
public:
int Position
val mutable Position: int

Field Value

Type: Int32
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


RunningLengthWord.RunningLengthBits Field

RunningLengthWordRunningLengthBits Field

[Missing <summary> documentation for "F:VelocityDBExtensions.CompressedBitArray.RunningLengthWord.RunningLengthBits"]

Namespace: VelocityDBExtensions.CompressedBitArray
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const int RunningLengthBits = 32
Public Const RunningLengthBits As Integer = 32
public:
literal int RunningLengthBits = 32
static val mutable RunningLengthBits: int

Field Value

Type: Int32
See Also

Reference

RunningLengthWord Class
VelocityDBExtensions.CompressedBitArray Namespace


VelocityDBExtensions.Extensions.BTree Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.Extensions.BTree"]

Classes
 | Class | Description
Public class | BTreeExtensions |


BTreeExtensions Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Extensions.BTree.BTreeExtensions"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Extensions.BTreeBTreeExtensions

Namespace: VelocityDBExtensions.Extensions.BTree
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class BTreeExtensions
<ExtensionAttribute>
Public NotInheritable Class BTreeExtensions
[ExtensionAttribute]
public ref class BTreeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type BTreeExtensions =  class end

The BTreeExtensions type exposes the following members.

Methods
Name | Description
CountKey |
WhereKey |
Top
See Also

Reference

VelocityDBExtensions.Extensions.BTree Namespace


BTreeExtensions Methods

The BTreeExtensions type exposes the following members.

Methods
Name | Description
CountKey |
WhereKey |
Top
See Also

Reference

BTreeExtensions Class
VelocityDBExtensions.Extensions.BTree Namespace


BTreeExtensions.Count(Key) Method

BTreeExtensionsCountKey Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Count``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0})"]

Namespace: VelocityDBExtensions.Extensions.BTree
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int Count<Key>(
    this BTreeBase<Key, Key> sourceCollection
)

<ExtensionAttribute>
Public Shared Function Count(Of Key) (
    sourceCollection As BTreeBase(Of Key, Key)
) As Integer
public:
[ExtensionAttribute]
generic<typename Key>
static int Count(
    BTreeBase<Key, Key>^ sourceCollection
)
[<ExtensionAttribute>]
static member Count :
        sourceCollection : BTreeBase<'Key, 'Key> -> int

Parameters

sourceCollection
Type: VelocityDb.Collection.BTreeBTreeBase Key, Key

[Missing <param name="sourceCollection"/> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Count``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0})"]

Type Parameters

Key

[Missing <typeparam name="Key"/> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Count``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0})"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Count``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BTreeBase Key, Key. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BTreeExtensions Class
VelocityDBExtensions.Extensions.BTree Namespace


BTreeExtensions.Where(Key) Method

BTreeExtensionsWhereKey Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Where``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0},System.Linq.Expressions.Expression{System.Func{``0,System.Boolean}})"]

Namespace: VelocityDBExtensions.Extensions.BTree
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Key> Where<Key>(
    this BTreeBase<Key, Key> sourceCollection,
    Expression<Func<Key, bool>> expr
)

<ExtensionAttribute>
Public Shared Function Where(Of Key) (
    sourceCollection As BTreeBase(Of Key, Key),
    expr As Expression(Of Func(Of Key, Boolean))
) As IEnumerable(Of Key)
public:
[ExtensionAttribute]
generic<typename Key>
static IEnumerable<Key>^ Where(
    BTreeBase<Key, Key>^ sourceCollection,
    Expression<Func<Key, bool>^>^ expr
)
[<ExtensionAttribute>]
static member Where :
        sourceCollection : BTreeBase<'Key, 'Key> *
        expr : Expression<Func<'Key, bool>> -> IEnumerable<'Key>

Parameters

sourceCollection
Type: VelocityDb.Collection.BTreeBTreeBase Key, Key

[Missing <param name="sourceCollection"/> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Where``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0},System.Linq.Expressions.Expression{System.Func{``0,System.Boolean}})"]

expr
Type: System.Linq.ExpressionsExpression Func Key, Boolean

[Missing <param name="expr"/> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Where``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0},System.Linq.Expressions.Expression{System.Func{``0,System.Boolean}})"]

Type Parameters

Key

[Missing <typeparam name="Key"/> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Where``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0},System.Linq.Expressions.Expression{System.Func{``0,System.Boolean}})"]

Return Value

Type: IEnumerable Key

[Missing <returns> documentation for "M:VelocityDBExtensions.Extensions.BTree.BTreeExtensions.Where``1(VelocityDb.Collection.BTree.BTreeBase{``0,``0},System.Linq.Expressions.Expression{System.Func{``0,System.Boolean}})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BTreeBase Key, Key. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BTreeExtensions Class
VelocityDBExtensions.Extensions.BTree Namespace


VelocityDBExtensions.Geo Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.Geo"]

Classes
 | Class | Description
Public class | BoundingBox |
Public class | GeoHash |
Public class | WGS84Point |


BoundingBox Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.BoundingBox"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.GeoBoundingBox

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class BoundingBox
<SerializableAttribute>
Public Class BoundingBox
[SerializableAttribute]
public ref class BoundingBox
[<SerializableAttribute>]
type BoundingBox =  class end

The BoundingBox type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBox(BoundingBox) | Initializes a new instance of the BoundingBox class
Public method | BoundingBox(WGS84Point, WGS84Point) | Initializes a new instance of the BoundingBox class
Public method | BoundingBox(Double, Double, Double, Double) | Initializes a new instance of the BoundingBox class
Top
Properties
 | Name | Description
Public property | CenterPoint |
Public property | LatitudeSize |
Public property | LongitudeSize |
Public property | LowerRight |
Public property | MaxLat |
Public property | MaxLon |
Public property | MinLat |
Public property | MinLon |
Public property | UpperLeft |
Top
Methods
 | Name | Description
Public method | Contains |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | ExpandToInclude |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | Intersects |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDBExtensions.Geo Namespace


BoundingBox Constructor

Overload List
 | Name | Description
Public method | BoundingBox(BoundingBox) | Initializes a new instance of the BoundingBox class
Public method | BoundingBox(WGS84Point, WGS84Point) | Initializes a new instance of the BoundingBox class
Public method | BoundingBox(Double, Double, Double, Double) | Initializes a new instance of the BoundingBox class
Top
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox Constructor (BoundingBox)

Initializes a new instance of the BoundingBox class

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox(
    BoundingBox that
)
Public Sub New (
    that As BoundingBox
)
public:
BoundingBox(
    BoundingBox^ that
)
new :
        that : BoundingBox -> BoundingBox

Parameters

that
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="that"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(VelocityDBExtensions.Geo.BoundingBox)"]

See Also

Reference

BoundingBox Class
BoundingBox Overload
VelocityDBExtensions.Geo Namespace


BoundingBox Constructor (WGS84Point, WGS84Point)

Initializes a new instance of the BoundingBox class

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox(
    WGS84Point p1,
    WGS84Point p2
)
Public Sub New (
    p1 As WGS84Point,
    p2 As WGS84Point
)
public:
BoundingBox(
    WGS84Point^ p1,
    WGS84Point^ p2
)
new :
        p1 : WGS84Point *
        p2 : WGS84Point -> BoundingBox

Parameters

p1
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="p1"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

p2
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="p2"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

BoundingBox Class
BoundingBox Overload
VelocityDBExtensions.Geo Namespace


BoundingBox Constructor (Double, Double, Double, Double)

Initializes a new instance of the BoundingBox class

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox(
    double y1,
    double y2,
    double x1,
    double x2
)
Public Sub New (
    y1 As Double,
    y2 As Double,
    x1 As Double,
    x2 As Double
)
public:
BoundingBox(
    double y1,
    double y2,
    double x1,
    double x2
)
new :
        y1 : float *
        y2 : float *
        x1 : float *
        x2 : float -> BoundingBox

Parameters

y1
Type: SystemDouble

[Missing <param name="y1"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y2
Type: SystemDouble

[Missing <param name="y2"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(System.Double,System.Double,System.Double,System.Double)"]

x1
Type: SystemDouble

[Missing <param name="x1"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(System.Double,System.Double,System.Double,System.Double)"]

x2
Type: SystemDouble

[Missing <param name="x2"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.#ctor(System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

BoundingBox Class
BoundingBox Overload
VelocityDBExtensions.Geo Namespace


BoundingBox Properties

The BoundingBox type exposes the following members.

Properties
 | Name | Description
Public property | CenterPoint |
Public property | LatitudeSize |
Public property | LongitudeSize |
Public property | LowerRight |
Public property | MaxLat |
Public property | MaxLon |
Public property | MinLat |
Public property | MinLon |
Public property | UpperLeft |
Top
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.CenterPoint Property

BoundingBoxCenterPoint Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.CenterPoint"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual WGS84Point CenterPoint { get; }
Public Overridable ReadOnly Property CenterPoint As WGS84Point
    Get
public:
virtual property WGS84Point^ CenterPoint {
    WGS84Point^ get ();
}
abstract CenterPoint : WGS84Point with get
override CenterPoint : WGS84Point with get

Property Value

Type: WGS84Point
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.LatitudeSize Property

BoundingBoxLatitudeSize Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.LatitudeSize"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double LatitudeSize { get; }
Public Overridable ReadOnly Property LatitudeSize As Double
    Get
public:
virtual property double LatitudeSize {
    double get ();
}
abstract LatitudeSize : float with get
override LatitudeSize : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.LongitudeSize Property

BoundingBoxLongitudeSize Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.LongitudeSize"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double LongitudeSize { get; }
Public Overridable ReadOnly Property LongitudeSize As Double
    Get
public:
virtual property double LongitudeSize {
    double get ();
}
abstract LongitudeSize : float with get
override LongitudeSize : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.LowerRight Property

BoundingBoxLowerRight Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.LowerRight"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual WGS84Point LowerRight { get; }
Public Overridable ReadOnly Property LowerRight As WGS84Point
    Get
public:
virtual property WGS84Point^ LowerRight {
    WGS84Point^ get ();
}
abstract LowerRight : WGS84Point with get
override LowerRight : WGS84Point with get

Property Value

Type: WGS84Point
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.MaxLat Property

BoundingBoxMaxLat Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.MaxLat"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double MaxLat { get; }
Public Overridable ReadOnly Property MaxLat As Double
    Get
public:
virtual property double MaxLat {
    double get ();
}
abstract MaxLat : float with get
override MaxLat : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.MaxLon Property

BoundingBoxMaxLon Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.MaxLon"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double MaxLon { get; }
Public Overridable ReadOnly Property MaxLon As Double
    Get
public:
virtual property double MaxLon {
    double get ();
}
abstract MaxLon : float with get
override MaxLon : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.MinLat Property

BoundingBoxMinLat Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.MinLat"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double MinLat { get; }
Public Overridable ReadOnly Property MinLat As Double
    Get
public:
virtual property double MinLat {
    double get ();
}
abstract MinLat : float with get
override MinLat : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.MinLon Property

BoundingBoxMinLon Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.MinLon"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double MinLon { get; }
Public Overridable ReadOnly Property MinLon As Double
    Get
public:
virtual property double MinLon {
    double get ();
}
abstract MinLon : float with get
override MinLon : float with get

Property Value

Type: Double
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.UpperLeft Property

BoundingBoxUpperLeft Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.BoundingBox.UpperLeft"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual WGS84Point UpperLeft { get; }
Public Overridable ReadOnly Property UpperLeft As WGS84Point
    Get
public:
virtual property WGS84Point^ UpperLeft {
    WGS84Point^ get ();
}
abstract UpperLeft : WGS84Point with get
override UpperLeft : WGS84Point with get

Property Value

Type: WGS84Point
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox Methods

The BoundingBox type exposes the following members.

Methods
 | Name | Description
Public method | Contains |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | ExpandToInclude |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | Intersects |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.Contains Method

BoundingBoxContains Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    WGS84Point point
)
Public Overridable Function Contains (
    point As WGS84Point
) As Boolean
public:
virtual bool Contains(
    WGS84Point^ point
)
abstract Contains :
        point : WGS84Point -> bool
override Contains :
        point : WGS84Point -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.Equals Method

BoundingBoxEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Equals(System.Object)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Equals(System.Object)"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.ExpandToInclude Method

BoundingBoxExpandToInclude Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.ExpandToInclude(VelocityDBExtensions.Geo.BoundingBox)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void ExpandToInclude(
    BoundingBox other
)
Public Overridable Sub ExpandToInclude (
    other As BoundingBox
)
public:
virtual void ExpandToInclude(
    BoundingBox^ other
)
abstract ExpandToInclude :
        other : BoundingBox -> unit
override ExpandToInclude :
        other : BoundingBox -> unit

Parameters

other
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="other"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.ExpandToInclude(VelocityDBExtensions.Geo.BoundingBox)"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.GetHashCode Method

BoundingBoxGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.GetHashCode"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.GetHashCode"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.Intersects Method

BoundingBoxIntersects Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Intersects(VelocityDBExtensions.Geo.BoundingBox)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Intersects(
    BoundingBox other
)
Public Overridable Function Intersects (
    other As BoundingBox
) As Boolean
public:
virtual bool Intersects(
    BoundingBox^ other
)
abstract Intersects :
        other : BoundingBox -> bool
override Intersects :
        other : BoundingBox -> bool

Parameters

other
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="other"/> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Intersects(VelocityDBExtensions.Geo.BoundingBox)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.Intersects(VelocityDBExtensions.Geo.BoundingBox)"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


BoundingBox.ToString Method

BoundingBoxToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.ToString"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.BoundingBox.ToString"]

See Also

Reference

BoundingBox Class
VelocityDBExtensions.Geo Namespace


GeoHash Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.GeoHash"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.GeoGeoHash

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class GeoHash : IComparable<GeoHash>
<SerializableAttribute>
Public NotInheritable Class GeoHash
    Implements IComparable(Of GeoHash)
[SerializableAttribute]
public ref class GeoHash sealed : IComparable<GeoHash^>
[<SealedAttribute>]
[<SerializableAttribute>]
type GeoHash =
    class
        interface IComparable<GeoHash>
    end

The GeoHash type exposes the following members.

Properties
 | Name | Description
Public property | Adjacent |
Public property | BoundingBox |
Public property | BoundingBoxCenterPoint |
Public property | CharacterPrecision |
Public property | EasternNeighbour |
Public property | LongValue |
Public property | NorthernNeighbour |
Public property | Point |
Public property | SignificantBits |
Public property | SouthernNeighbour |
Public property | WesternNeighbour |
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Contains |
Public method | EnclosesCircleAroundPoint |
Public method | Equals | (Overrides ObjectEquals(Object).)
 | FromBinaryString |
 | FromGeohashString |
 | FromLongValue |
 | FromOrd |
 | GeoHashStringWithCharacterPrecision |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | Next |
Public method | Next(Int32) |
Public method | Ord |
Public method | Prev |
 | StepsBetween |
Public method | ToBase32 |
Public method | ToBinaryString |
Public method | ToString | (Overrides ObjectToString.)
 | withBitPrecision |
 | WithBitPrecision |
 | WithCharacterPrecision |
Public method | Within |
Top
See Also

Reference

VelocityDBExtensions.Geo Namespace


GeoHash Properties

The GeoHash type exposes the following members.

Properties
 | Name | Description
Public property | Adjacent |
Public property | BoundingBox |
Public property | BoundingBoxCenterPoint |
Public property | CharacterPrecision |
Public property | EasternNeighbour |
Public property | LongValue |
Public property | NorthernNeighbour |
Public property | Point |
Public property | SignificantBits |
Public property | SouthernNeighbour |
Public property | WesternNeighbour |
Top
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Adjacent Property

GeoHashAdjacent Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.Adjacent"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash[] Adjacent { get; }
Public ReadOnly Property Adjacent As GeoHash()
    Get
public:
property array<GeoHash^>^ Adjacent {
    array<GeoHash^>^ get ();
}
member Adjacent : GeoHash[] with get

Property Value

Type: GeoHash
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.BoundingBox Property

GeoHashBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.BoundingBox"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get
public:
property BoundingBox^ BoundingBox {
    BoundingBox^ get ();
}
member BoundingBox : BoundingBox with get

Property Value

Type: BoundingBox
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.BoundingBoxCenterPoint Property

GeoHashBoundingBoxCenterPoint Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.BoundingBoxCenterPoint"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WGS84Point BoundingBoxCenterPoint { get; }
Public ReadOnly Property BoundingBoxCenterPoint As WGS84Point
    Get
public:
property WGS84Point^ BoundingBoxCenterPoint {
    WGS84Point^ get ();
}
member BoundingBoxCenterPoint : WGS84Point with get

Property Value

Type: WGS84Point
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.CharacterPrecision Property

GeoHashCharacterPrecision Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.CharacterPrecision"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CharacterPrecision { get; }
Public ReadOnly Property CharacterPrecision As Integer
    Get
public:
property int CharacterPrecision {
    int get ();
}
member CharacterPrecision : int with get

Property Value

Type: Int32
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.EasternNeighbour Property

GeoHashEasternNeighbour Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.EasternNeighbour"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash EasternNeighbour { get; }
Public ReadOnly Property EasternNeighbour As GeoHash
    Get
public:
property GeoHash^ EasternNeighbour {
    GeoHash^ get ();
}
member EasternNeighbour : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.LongValue Property

GeoHashLongValue Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.LongValue"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long LongValue { get; }
Public ReadOnly Property LongValue As Long
    Get
public:
property long long LongValue {
    long long get ();
}
member LongValue : int64 with get

Property Value

Type: Int64
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.NorthernNeighbour Property

GeoHashNorthernNeighbour Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.NorthernNeighbour"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash NorthernNeighbour { get; }
Public ReadOnly Property NorthernNeighbour As GeoHash
    Get
public:
property GeoHash^ NorthernNeighbour {
    GeoHash^ get ();
}
member NorthernNeighbour : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Point Property

GeoHashPoint Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.Point"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WGS84Point Point { get; }
Public ReadOnly Property Point As WGS84Point
    Get
public:
property WGS84Point^ Point {
    WGS84Point^ get ();
}
member Point : WGS84Point with get

Property Value

Type: WGS84Point
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.SignificantBits Property

GeoHashSignificantBits Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.SignificantBits"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int SignificantBits { get; }
Public ReadOnly Property SignificantBits As Integer
    Get
public:
property int SignificantBits {
    int get ();
}
member SignificantBits : int with get

Property Value

Type: Int32
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.SouthernNeighbour Property

GeoHashSouthernNeighbour Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.SouthernNeighbour"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash SouthernNeighbour { get; }
Public ReadOnly Property SouthernNeighbour As GeoHash
    Get
public:
property GeoHash^ SouthernNeighbour {
    GeoHash^ get ();
}
member SouthernNeighbour : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.WesternNeighbour Property

GeoHashWesternNeighbour Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.GeoHash.WesternNeighbour"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash WesternNeighbour { get; }
Public ReadOnly Property WesternNeighbour As GeoHash
    Get
public:
property GeoHash^ WesternNeighbour {
    GeoHash^ get ();
}
member WesternNeighbour : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash Methods

The GeoHash type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Contains |
Public method | EnclosesCircleAroundPoint |
Public method | Equals | (Overrides ObjectEquals(Object).)
 | FromBinaryString |
 | FromGeohashString |
 | FromLongValue |
 | FromOrd |
 | GeoHashStringWithCharacterPrecision |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | Next |
Public method | Next(Int32) |
Public method | Ord |
Public method | Prev |
 | StepsBetween |
Public method | ToBase32 |
Public method | ToBinaryString |
Public method | ToString | (Overrides ObjectToString.)
 | withBitPrecision |
 | WithBitPrecision |
 | WithCharacterPrecision |
Public method | Within |
Top
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.CompareTo Method

GeoHashCompareTo Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.CompareTo(VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    GeoHash o
)
Public Function CompareTo (
    o As GeoHash
) As Integer
public:
virtual int CompareTo(
    GeoHash^ o
) sealed
abstract CompareTo :
        o : GeoHash -> int
override CompareTo :
        o : GeoHash -> int

Parameters

o
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="o"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.CompareTo(VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.CompareTo(VelocityDBExtensions.Geo.GeoHash)"]

Implements

IComparableTCompareTo(T)
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Contains Method

GeoHashContains Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WGS84Point point
)
Public Function Contains (
    point As WGS84Point
) As Boolean
public:
bool Contains(
    WGS84Point^ point
)
member Contains :
        point : WGS84Point -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.EnclosesCircleAroundPoint Method

GeoHashEnclosesCircleAroundPoint Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.EnclosesCircleAroundPoint(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool EnclosesCircleAroundPoint(
    WGS84Point point,
    double radius
)
Public Function EnclosesCircleAroundPoint (
    point As WGS84Point,
    radius As Double
) As Boolean
public:
bool EnclosesCircleAroundPoint(
    WGS84Point^ point,
    double radius
)
member EnclosesCircleAroundPoint :
        point : WGS84Point *
        radius : float -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.EnclosesCircleAroundPoint(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

radius
Type: SystemDouble

[Missing <param name="radius"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.EnclosesCircleAroundPoint(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.EnclosesCircleAroundPoint(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Equals Method

GeoHashEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Equals(System.Object)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Equals(System.Object)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.FromBinaryString Method

GeoHashFromBinaryString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromBinaryString(System.String)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash FromBinaryString(
    string binaryString
)
Public Shared Function FromBinaryString (
    binaryString As String
) As GeoHash
public:
static GeoHash^ FromBinaryString(
    String^ binaryString
)
static member FromBinaryString :
        binaryString : string -> GeoHash

Parameters

binaryString
Type: SystemString

[Missing <param name="binaryString"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromBinaryString(System.String)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromBinaryString(System.String)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.FromGeohashString Method

GeoHashFromGeohashString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromGeohashString(System.String)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash FromGeohashString(
    string geohash
)
Public Shared Function FromGeohashString (
    geohash As String
) As GeoHash
public:
static GeoHash^ FromGeohashString(
    String^ geohash
)
static member FromGeohashString :
        geohash : string -> GeoHash

Parameters

geohash
Type: SystemString

[Missing <param name="geohash"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromGeohashString(System.String)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromGeohashString(System.String)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.FromLongValue Method

GeoHashFromLongValue Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromLongValue(System.Int64,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash FromLongValue(
    long hashVal,
    int significantBits = 64
)
Public Shared Function FromLongValue (
    hashVal As Long,
    Optional significantBits As Integer = 64
) As GeoHash
public:
static GeoHash^ FromLongValue(
    long long hashVal,
    int significantBits = 64
)
static member FromLongValue :
        hashVal : int64 *
        ?significantBits : int
(* Defaults:
        let _significantBits = defaultArg significantBits 64
*)
-> GeoHash

Parameters

hashVal
Type: SystemInt64

[Missing <param name="hashVal"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromLongValue(System.Int64,System.Int32)"]

significantBits (Optional)
Type: SystemInt32

[Missing <param name="significantBits"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromLongValue(System.Int64,System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromLongValue(System.Int64,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.FromOrd Method

GeoHashFromOrd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromOrd(System.Int64,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash FromOrd(
    long ord,
    int significantBits
)
Public Shared Function FromOrd (
    ord As Long,
    significantBits As Integer
) As GeoHash
public:
static GeoHash^ FromOrd(
    long long ord,
    int significantBits
)
static member FromOrd :
        ord : int64 *
        significantBits : int -> GeoHash

Parameters

ord
Type: SystemInt64

[Missing <param name="ord"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromOrd(System.Int64,System.Int32)"]

significantBits
Type: SystemInt32

[Missing <param name="significantBits"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromOrd(System.Int64,System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.FromOrd(System.Int64,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.GeoHashStringWithCharacterPrecision Method

GeoHashGeoHashStringWithCharacterPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GeoHashStringWithCharacterPrecision(System.Double,System.Double,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string GeoHashStringWithCharacterPrecision(
    double latitude,
    double longitude,
    int numberOfCharacters
)
Public Shared Function GeoHashStringWithCharacterPrecision (
    latitude As Double,
    longitude As Double,
    numberOfCharacters As Integer
) As String
public:
static String^ GeoHashStringWithCharacterPrecision(
    double latitude,
    double longitude,
    int numberOfCharacters
)
static member GeoHashStringWithCharacterPrecision :
        latitude : float *
        longitude : float *
        numberOfCharacters : int -> string

Parameters

latitude
Type: SystemDouble

[Missing <param name="latitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GeoHashStringWithCharacterPrecision(System.Double,System.Double,System.Int32)"]

longitude
Type: SystemDouble

[Missing <param name="longitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GeoHashStringWithCharacterPrecision(System.Double,System.Double,System.Int32)"]

numberOfCharacters
Type: SystemInt32

[Missing <param name="numberOfCharacters"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GeoHashStringWithCharacterPrecision(System.Double,System.Double,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GeoHashStringWithCharacterPrecision(System.Double,System.Double,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.GetHashCode Method

GeoHashGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GetHashCode"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.GetHashCode"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Next Method

GeoHashNext Method

Overload List
 | Name | Description
Public method | Next |
Public method | Next(Int32) |
Top
See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Next Method

GeoHashNext Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Next"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash Next()
Public Function Next As GeoHash
public:
GeoHash^ Next()
member Next : unit -> GeoHash

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Next"]

See Also

Reference

GeoHash Class
Next Overload
VelocityDBExtensions.Geo Namespace


GeoHash.Next Method (Int32)

GeoHashNext Method (Int32)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Next(System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash Next(
    int step
)
Public Function Next (
    step As Integer
) As GeoHash
public:
GeoHash^ Next(
    int step
)
member Next :
        step : int -> GeoHash

Parameters

step
Type: SystemInt32

[Missing <param name="step"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Next(System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Next(System.Int32)"]

See Also

Reference

GeoHash Class
Next Overload
VelocityDBExtensions.Geo Namespace


GeoHash.Ord Method

GeoHashOrd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Ord"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long Ord()
Public Function Ord As Long
public:
long long Ord()
member Ord : unit -> int64

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Ord"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Prev Method

GeoHashPrev Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Prev"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHash Prev()
Public Function Prev As GeoHash
public:
GeoHash^ Prev()
member Prev : unit -> GeoHash

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Prev"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.StepsBetween Method

GeoHashStepsBetween Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.StepsBetween(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static long StepsBetween(
    GeoHash one,
    GeoHash two
)
Public Shared Function StepsBetween (
    one As GeoHash,
    two As GeoHash
) As Long
public:
static long long StepsBetween(
    GeoHash^ one,
    GeoHash^ two
)
static member StepsBetween :
        one : GeoHash *
        two : GeoHash -> int64

Parameters

one
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="one"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.StepsBetween(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

two
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="two"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.StepsBetween(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.StepsBetween(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.ToBase32 Method

GeoHashToBase32 Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToBase32"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ToBase32()
Public Function ToBase32 As String
public:
String^ ToBase32()
member ToBase32 : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToBase32"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.ToBinaryString Method

GeoHashToBinaryString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToBinaryString"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ToBinaryString()
Public Function ToBinaryString As String
public:
String^ ToBinaryString()
member ToBinaryString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToBinaryString"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.ToString Method

GeoHashToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToString"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.ToString"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.withBitPrecision Method

GeoHashwithBitPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.withBitPrecision(VelocityDBExtensions.Geo.WGS84Point,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash withBitPrecision(
    WGS84Point point,
    int numberOfBits
)
Public Shared Function withBitPrecision (
    point As WGS84Point,
    numberOfBits As Integer
) As GeoHash
public:
static GeoHash^ withBitPrecision(
    WGS84Point^ point,
    int numberOfBits
)
static member withBitPrecision :
        point : WGS84Point *
        numberOfBits : int -> GeoHash

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.withBitPrecision(VelocityDBExtensions.Geo.WGS84Point,System.Int32)"]

numberOfBits
Type: SystemInt32

[Missing <param name="numberOfBits"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.withBitPrecision(VelocityDBExtensions.Geo.WGS84Point,System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.withBitPrecision(VelocityDBExtensions.Geo.WGS84Point,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.WithBitPrecision Method

GeoHashWithBitPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithBitPrecision(System.Double,System.Double,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash WithBitPrecision(
    double latitude,
    double longitude,
    int numberOfBits = 64
)
Public Shared Function WithBitPrecision (
    latitude As Double,
    longitude As Double,
    Optional numberOfBits As Integer = 64
) As GeoHash
public:
static GeoHash^ WithBitPrecision(
    double latitude,
    double longitude,
    int numberOfBits = 64
)
static member WithBitPrecision :
        latitude : float *
        longitude : float *
        ?numberOfBits : int
(* Defaults:
        let _numberOfBits = defaultArg numberOfBits 64
*)
-> GeoHash

Parameters

latitude
Type: SystemDouble

[Missing <param name="latitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithBitPrecision(System.Double,System.Double,System.Int32)"]

longitude
Type: SystemDouble

[Missing <param name="longitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithBitPrecision(System.Double,System.Double,System.Int32)"]

numberOfBits (Optional)
Type: SystemInt32

[Missing <param name="numberOfBits"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithBitPrecision(System.Double,System.Double,System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithBitPrecision(System.Double,System.Double,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.WithCharacterPrecision Method

GeoHashWithCharacterPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithCharacterPrecision(System.Double,System.Double,System.Int32)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GeoHash WithCharacterPrecision(
    double latitude,
    double longitude,
    int numberOfCharacters
)
Public Shared Function WithCharacterPrecision (
    latitude As Double,
    longitude As Double,
    numberOfCharacters As Integer
) As GeoHash
public:
static GeoHash^ WithCharacterPrecision(
    double latitude,
    double longitude,
    int numberOfCharacters
)
static member WithCharacterPrecision :
        latitude : float *
        longitude : float *
        numberOfCharacters : int -> GeoHash

Parameters

latitude
Type: SystemDouble

[Missing <param name="latitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithCharacterPrecision(System.Double,System.Double,System.Int32)"]

longitude
Type: SystemDouble

[Missing <param name="longitude"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithCharacterPrecision(System.Double,System.Double,System.Int32)"]

numberOfCharacters
Type: SystemInt32

[Missing <param name="numberOfCharacters"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithCharacterPrecision(System.Double,System.Double,System.Int32)"]

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.WithCharacterPrecision(System.Double,System.Double,System.Int32)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


GeoHash.Within Method

GeoHashWithin Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Within(VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Within(
    GeoHash boundingBox
)
Public Function Within (
    boundingBox As GeoHash
) As Boolean
public:
bool Within(
    GeoHash^ boundingBox
)
member Within :
        boundingBox : GeoHash -> bool

Parameters

boundingBox
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="boundingBox"/> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Within(VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.GeoHash.Within(VelocityDBExtensions.Geo.GeoHash)"]

See Also

Reference

GeoHash Class
VelocityDBExtensions.Geo Namespace


WGS84Point Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.WGS84Point"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.GeoWGS84Point

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WGS84Point
<SerializableAttribute>
Public Class WGS84Point
[SerializableAttribute]
public ref class WGS84Point
[<SerializableAttribute>]
type WGS84Point =  class end

The WGS84Point type exposes the following members.

Constructors
 | Name | Description
Public method | WGS84Point(WGS84Point) | Initializes a new instance of the WGS84Point class
Public method | WGS84Point(Double, Double) | Initializes a new instance of the WGS84Point class
Top
Properties
 | Name | Description
Public property | Latitude |
Public property | Longitude |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDBExtensions.Geo Namespace


WGS84Point Constructor

Overload List
 | Name | Description
Public method | WGS84Point(WGS84Point) | Initializes a new instance of the WGS84Point class
Public method | WGS84Point(Double, Double) | Initializes a new instance of the WGS84Point class
Top
See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point Constructor (WGS84Point)

Initializes a new instance of the WGS84Point class

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WGS84Point(
    WGS84Point other
)
Public Sub New (
    other As WGS84Point
)
public:
WGS84Point(
    WGS84Point^ other
)
new :
        other : WGS84Point -> WGS84Point

Parameters

other
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="other"/> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.#ctor(VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

WGS84Point Class
WGS84Point Overload
VelocityDBExtensions.Geo Namespace


WGS84Point Constructor (Double, Double)

Initializes a new instance of the WGS84Point class

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public WGS84Point(
    double latitude,
    double longitude
)
Public Sub New (
    latitude As Double,
    longitude As Double
)
public:
WGS84Point(
    double latitude,
    double longitude
)
new :
        latitude : float *
        longitude : float -> WGS84Point

Parameters

latitude
Type: SystemDouble

[Missing <param name="latitude"/> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.#ctor(System.Double,System.Double)"]

longitude
Type: SystemDouble

[Missing <param name="longitude"/> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.#ctor(System.Double,System.Double)"]

See Also

Reference

WGS84Point Class
WGS84Point Overload
VelocityDBExtensions.Geo Namespace


WGS84Point Properties

The WGS84Point type exposes the following members.

Properties
 | Name | Description
Public property | Latitude |
Public property | Longitude |
Top
See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point.Latitude Property

WGS84PointLatitude Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.WGS84Point.Latitude"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double Latitude { get; }
Public Overridable ReadOnly Property Latitude As Double
    Get
public:
virtual property double Latitude {
    double get ();
}
abstract Latitude : float with get
override Latitude : float with get

Property Value

Type: Double
See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point.Longitude Property

WGS84PointLongitude Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.WGS84Point.Longitude"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual double Longitude { get; }
Public Overridable ReadOnly Property Longitude As Double
    Get
public:
virtual property double Longitude {
    double get ();
}
abstract Longitude : float with get
override Longitude : float with get

Property Value

Type: Double
See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point Methods

The WGS84Point type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point.Equals Method

WGS84PointEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.Equals(System.Object)"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.Equals(System.Object)"]

See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point.GetHashCode Method

WGS84PointGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.GetHashCode"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.GetHashCode"]

See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


WGS84Point.ToString Method

WGS84PointToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.ToString"]

Namespace: VelocityDBExtensions.Geo
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.WGS84Point.ToString"]

See Also

Reference

WGS84Point Class
VelocityDBExtensions.Geo Namespace


VelocityDBExtensions.Geo.query Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.Geo.query"]

Classes
 | Class | Description
Public class | GeoHashBoundingBoxQuery |
Public class | GeoHashCircleQuery |
Interfaces
 | Interface | Description
Public interface | GeoHashQuery |


GeoHashBoundingBoxQuery Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.queryGeoHashBoundingBoxQuery

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GeoHashBoundingBoxQuery : GeoHashQuery
<SerializableAttribute>
Public Class GeoHashBoundingBoxQuery
    Implements GeoHashQuery
[SerializableAttribute]
public ref class GeoHashBoundingBoxQuery : GeoHashQuery
[<SerializableAttribute>]
type GeoHashBoundingBoxQuery =
    class
        interface GeoHashQuery
    end

The GeoHashBoundingBoxQuery type exposes the following members.

Constructors
 | Name | Description
Public method | GeoHashBoundingBoxQuery | Initializes a new instance of the GeoHashBoundingBoxQuery class
Top
Properties
 | Name | Description
Public property | BoundingBox |
Public property | SearchHashes |
Public property | WktBox |
Top
Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery Constructor

Initializes a new instance of the GeoHashBoundingBoxQuery class

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHashBoundingBoxQuery(
    BoundingBox bbox
)
Public Sub New (
    bbox As BoundingBox
)
public:
GeoHashBoundingBoxQuery(
    BoundingBox^ bbox
)
new :
        bbox : BoundingBox -> GeoHashBoundingBoxQuery

Parameters

bbox
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.#ctor(VelocityDBExtensions.Geo.BoundingBox)"]

See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery Properties

The GeoHashBoundingBoxQuery type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox |
Public property | SearchHashes |
Public property | WktBox |
Top
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.BoundingBox Property

GeoHashBoundingBoxQueryBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.BoundingBox"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get
public:
property BoundingBox^ BoundingBox {
    BoundingBox^ get ();
}
member BoundingBox : BoundingBox with get

Property Value

Type: BoundingBox
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.SearchHashes Property

GeoHashBoundingBoxQuerySearchHashes Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.SearchHashes"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IList<GeoHash> SearchHashes { get; }
Public ReadOnly Property SearchHashes As IList(Of GeoHash)
    Get
public:
virtual property IList<GeoHash^>^ SearchHashes {
    IList<GeoHash^>^ get () sealed;
}
abstract SearchHashes : IList<GeoHash> with get
override SearchHashes : IList<GeoHash> with get

Property Value

Type: IList GeoHash

Implements

GeoHashQuerySearchHashes
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.WktBox Property

GeoHashBoundingBoxQueryWktBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.WktBox"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string WktBox { get; }
Public ReadOnly Property WktBox As String
    Get
public:
virtual property String^ WktBox {
    String^ get () sealed;
}
abstract WktBox : string with get
override WktBox : string with get

Property Value

Type: String

Implements

GeoHashQueryWktBox
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery Methods

The GeoHashBoundingBoxQuery type exposes the following members.

Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.Contains Method

GeoHashBoundingBoxQueryContains Method

Overload List
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Top
See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.Contains Method (GeoHash)

GeoHashBoundingBoxQueryContains Method (GeoHash)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    GeoHash hash
)
Public Function Contains (
    hash As GeoHash
) As Boolean
public:
virtual bool Contains(
    GeoHash^ hash
) sealed
abstract Contains :
        hash : GeoHash -> bool
override Contains :
        hash : GeoHash -> bool

Parameters

hash
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="hash"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Implements

GeoHashQueryContains(GeoHash)
See Also

Reference

GeoHashBoundingBoxQuery Class
Contains Overload
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.Contains Method (WGS84Point)

GeoHashBoundingBoxQueryContains Method (WGS84Point)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WGS84Point point
)
Public Function Contains (
    point As WGS84Point
) As Boolean
public:
virtual bool Contains(
    WGS84Point^ point
) sealed
abstract Contains :
        point : WGS84Point -> bool
override Contains :
        point : WGS84Point -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Implements

GeoHashQueryContains(WGS84Point)
See Also

Reference

GeoHashBoundingBoxQuery Class
Contains Overload
VelocityDBExtensions.Geo.query Namespace


GeoHashBoundingBoxQuery.ToString Method

GeoHashBoundingBoxQueryToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.ToString"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashBoundingBoxQuery.ToString"]

See Also

Reference

GeoHashBoundingBoxQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.query.GeoHashCircleQuery"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.queryGeoHashCircleQuery

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GeoHashCircleQuery : GeoHashQuery
<SerializableAttribute>
Public Class GeoHashCircleQuery
    Implements GeoHashQuery
[SerializableAttribute]
public ref class GeoHashCircleQuery : GeoHashQuery
[<SerializableAttribute>]
type GeoHashCircleQuery =
    class
        interface GeoHashQuery
    end

The GeoHashCircleQuery type exposes the following members.

Constructors
 | Name | Description
Public method | GeoHashCircleQuery | Initializes a new instance of the GeoHashCircleQuery class
Top
Properties
 | Name | Description
Public property | BoundingBox |
Public property | SearchHashes |
Public property | WktBox |
Top
Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery Constructor

Initializes a new instance of the GeoHashCircleQuery class

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHashCircleQuery(
    WGS84Point center,
    double radius
)
Public Sub New (
    center As WGS84Point,
    radius As Double
)
public:
GeoHashCircleQuery(
    WGS84Point^ center,
    double radius
)
new :
        center : WGS84Point *
        radius : float -> GeoHashCircleQuery

Parameters

center
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="center"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.#ctor(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

radius
Type: SystemDouble

[Missing <param name="radius"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.#ctor(VelocityDBExtensions.Geo.WGS84Point,System.Double)"]

See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery Properties

The GeoHashCircleQuery type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox |
Public property | SearchHashes |
Public property | WktBox |
Top
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.BoundingBox Property

GeoHashCircleQueryBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.BoundingBox"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBox BoundingBox { get; }
Public ReadOnly Property BoundingBox As BoundingBox
    Get
public:
property BoundingBox^ BoundingBox {
    BoundingBox^ get ();
}
member BoundingBox : BoundingBox with get

Property Value

Type: BoundingBox
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.SearchHashes Property

GeoHashCircleQuerySearchHashes Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.SearchHashes"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IList<GeoHash> SearchHashes { get; }
Public ReadOnly Property SearchHashes As IList(Of GeoHash)
    Get
public:
virtual property IList<GeoHash^>^ SearchHashes {
    IList<GeoHash^>^ get () sealed;
}
abstract SearchHashes : IList<GeoHash> with get
override SearchHashes : IList<GeoHash> with get

Property Value

Type: IList GeoHash

Implements

GeoHashQuerySearchHashes
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.WktBox Property

GeoHashCircleQueryWktBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.WktBox"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string WktBox { get; }
Public ReadOnly Property WktBox As String
    Get
public:
virtual property String^ WktBox {
    String^ get () sealed;
}
abstract WktBox : string with get
override WktBox : string with get

Property Value

Type: String

Implements

GeoHashQueryWktBox
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery Methods

The GeoHashCircleQuery type exposes the following members.

Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.Contains Method

GeoHashCircleQueryContains Method

Overload List
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Top
See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.Contains Method (GeoHash)

GeoHashCircleQueryContains Method (GeoHash)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    GeoHash hash
)
Public Function Contains (
    hash As GeoHash
) As Boolean
public:
virtual bool Contains(
    GeoHash^ hash
) sealed
abstract Contains :
        hash : GeoHash -> bool
override Contains :
        hash : GeoHash -> bool

Parameters

hash
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="hash"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Implements

GeoHashQueryContains(GeoHash)
See Also

Reference

GeoHashCircleQuery Class
Contains Overload
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.Contains Method (WGS84Point)

GeoHashCircleQueryContains Method (WGS84Point)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WGS84Point point
)
Public Function Contains (
    point As WGS84Point
) As Boolean
public:
virtual bool Contains(
    WGS84Point^ point
) sealed
abstract Contains :
        point : WGS84Point -> bool
override Contains :
        point : WGS84Point -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Implements

GeoHashQueryContains(WGS84Point)
See Also

Reference

GeoHashCircleQuery Class
Contains Overload
VelocityDBExtensions.Geo.query Namespace


GeoHashCircleQuery.ToString Method

GeoHashCircleQueryToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.ToString"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashCircleQuery.ToString"]

See Also

Reference

GeoHashCircleQuery Class
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery Interface

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.query.GeoHashQuery"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public interface GeoHashQuery
Public Interface GeoHashQuery
public interface class GeoHashQuery
type GeoHashQuery =  interface end

The GeoHashQuery type exposes the following members.

Properties
 | Name | Description
Public property | SearchHashes |
Public property | WktBox |
Top
Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Top
See Also

Reference

VelocityDBExtensions.Geo.query Namespace


GeoHashQuery Properties

The GeoHashQuery type exposes the following members.

Properties
 | Name | Description
Public property | SearchHashes |
Public property | WktBox |
Top
See Also

Reference

GeoHashQuery Interface
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery.SearchHashes Property

GeoHashQuerySearchHashes Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashQuery.SearchHashes"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
IList<GeoHash> SearchHashes { get; }
ReadOnly Property SearchHashes As IList(Of GeoHash)
    Get
property IList<GeoHash^>^ SearchHashes {
    IList<GeoHash^>^ get ();
}
abstract SearchHashes : IList<GeoHash> with get

Property Value

Type: IList GeoHash
See Also

Reference

GeoHashQuery Interface
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery.WktBox Property

GeoHashQueryWktBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.query.GeoHashQuery.WktBox"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
string WktBox { get; }
ReadOnly Property WktBox As String
    Get
property String^ WktBox {
    String^ get ();
}
abstract WktBox : string with get

Property Value

Type: String
See Also

Reference

GeoHashQuery Interface
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery Methods

Methods
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Top
See Also

Reference

GeoHashQuery Interface
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery.Contains Method

GeoHashQueryContains Method

Overload List
 | Name | Description
Public method | Contains(GeoHash) |
Public method | Contains(WGS84Point) |
Top
See Also

Reference

GeoHashQuery Interface
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery.Contains Method (GeoHash)

GeoHashQueryContains Method (GeoHash)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    GeoHash hash
)
Function Contains (
    hash As GeoHash
) As Boolean
bool Contains(
    GeoHash^ hash
)
abstract Contains :
        hash : GeoHash -> bool

Parameters

hash
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="hash"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.GeoHash)"]

See Also

Reference

GeoHashQuery Interface
Contains Overload
VelocityDBExtensions.Geo.query Namespace


GeoHashQuery.Contains Method (WGS84Point)

GeoHashQueryContains Method (WGS84Point)

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo.query
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    WGS84Point point
)
Function Contains (
    point As WGS84Point
) As Boolean
bool Contains(
    WGS84Point^ point
)
abstract Contains :
        point : WGS84Point -> bool

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.query.GeoHashQuery.Contains(VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

GeoHashQuery Interface
Contains Overload
VelocityDBExtensions.Geo.query Namespace


VelocityDBExtensions.Geo.util Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.Geo.util"]

Classes
 | Class | Description
Public class | BoundingBoxGeoHashIterator |
Public class | BoundingBoxSampler |
Public class | GeoHashSizeTable |
Public class | LongUtil |
Public class | TwoGeoHashBoundingBox |
Public class | VincentyGeodesy |


BoundingBoxGeoHashIterator Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.BoundingBoxGeoHashIterator"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilBoundingBoxGeoHashIterator

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxGeoHashIterator : IEnumerable<GeoHash>,
    IEnumerable
Public Class BoundingBoxGeoHashIterator
    Implements IEnumerable(Of GeoHash), IEnumerable
public ref class BoundingBoxGeoHashIterator : IEnumerable<GeoHash^>,
    IEnumerable
type BoundingBoxGeoHashIterator =
    class
        interface IEnumerable<GeoHash>
        interface IEnumerable
    end

The BoundingBoxGeoHashIterator type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxGeoHashIterator | Initializes a new instance of the BoundingBoxGeoHashIterator class
Top
Properties
 | Name | Description
Public property | BoundingBox |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


BoundingBoxGeoHashIterator Constructor

Initializes a new instance of the BoundingBoxGeoHashIterator class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxGeoHashIterator(
    TwoGeoHashBoundingBox bbox
)
Public Sub New (
    bbox As TwoGeoHashBoundingBox
)
public:
BoundingBoxGeoHashIterator(
    TwoGeoHashBoundingBox^ bbox
)
new :
        bbox : TwoGeoHashBoundingBox -> BoundingBoxGeoHashIterator

Parameters

bbox
Type: VelocityDBExtensions.Geo.utilTwoGeoHashBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxGeoHashIterator.#ctor(VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox)"]

See Also

Reference

BoundingBoxGeoHashIterator Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxGeoHashIterator Properties

The BoundingBoxGeoHashIterator type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox |
Top
See Also

Reference

BoundingBoxGeoHashIterator Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxGeoHashIterator.BoundingBox Property

BoundingBoxGeoHashIteratorBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.util.BoundingBoxGeoHashIterator.BoundingBox"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual TwoGeoHashBoundingBox BoundingBox { get; }
Public Overridable ReadOnly Property BoundingBox As TwoGeoHashBoundingBox
    Get
public:
virtual property TwoGeoHashBoundingBox^ BoundingBox {
    TwoGeoHashBoundingBox^ get ();
}
abstract BoundingBox : TwoGeoHashBoundingBox with get
override BoundingBox : TwoGeoHashBoundingBox with get

Property Value

Type: TwoGeoHashBoundingBox
See Also

Reference

BoundingBoxGeoHashIterator Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxGeoHashIterator Methods

The BoundingBoxGeoHashIterator type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

BoundingBoxGeoHashIterator Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxGeoHashIterator.GetEnumerator Method

BoundingBoxGeoHashIteratorGetEnumerator Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxGeoHashIterator.GetEnumerator"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<GeoHash> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of GeoHash)
public:
virtual IEnumerator<GeoHash^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<GeoHash>
override GetEnumerator : unit -> IEnumerator<GeoHash>

Return Value

Type: IEnumerator GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxGeoHashIterator.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

BoundingBoxGeoHashIterator Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.BoundingBoxSampler"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilBoundingBoxSampler

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxSampler
Public Class BoundingBoxSampler
public ref class BoundingBoxSampler
type BoundingBoxSampler =  class end

The BoundingBoxSampler type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxSampler(TwoGeoHashBoundingBox) | Initializes a new instance of the BoundingBoxSampler class
Public method | BoundingBoxSampler(TwoGeoHashBoundingBox, Int32) | Initializes a new instance of the BoundingBoxSampler class
Top
Properties
 | Name | Description
Public property | BoundingBox |
Top
Methods
 | Name | Description
Public method | Next |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Constructor

Overload List
 | Name | Description
Public method | BoundingBoxSampler(TwoGeoHashBoundingBox) | Initializes a new instance of the BoundingBoxSampler class
Public method | BoundingBoxSampler(TwoGeoHashBoundingBox, Int32) | Initializes a new instance of the BoundingBoxSampler class
Top
See Also

Reference

BoundingBoxSampler Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Constructor (TwoGeoHashBoundingBox)

Initializes a new instance of the BoundingBoxSampler class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxSampler(
    TwoGeoHashBoundingBox bbox
)
Public Sub New (
    bbox As TwoGeoHashBoundingBox
)
public:
BoundingBoxSampler(
    TwoGeoHashBoundingBox^ bbox
)
new :
        bbox : TwoGeoHashBoundingBox -> BoundingBoxSampler

Parameters

bbox
Type: VelocityDBExtensions.Geo.utilTwoGeoHashBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxSampler.#ctor(VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox)"]

See Also

Reference

BoundingBoxSampler Class
BoundingBoxSampler Overload
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Constructor (TwoGeoHashBoundingBox, Int32)

Initializes a new instance of the BoundingBoxSampler class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxSampler(
    TwoGeoHashBoundingBox bbox,
    int seed
)
Public Sub New (
    bbox As TwoGeoHashBoundingBox,
    seed As Integer
)
public:
BoundingBoxSampler(
    TwoGeoHashBoundingBox^ bbox,
    int seed
)
new :
        bbox : TwoGeoHashBoundingBox *
        seed : int -> BoundingBoxSampler

Parameters

bbox
Type: VelocityDBExtensions.Geo.utilTwoGeoHashBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxSampler.#ctor(VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox,System.Int32)"]

seed
Type: SystemInt32

[Missing <param name="seed"/> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxSampler.#ctor(VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox,System.Int32)"]

See Also

Reference

BoundingBoxSampler Class
BoundingBoxSampler Overload
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Properties

The BoundingBoxSampler type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox |
Top
See Also

Reference

BoundingBoxSampler Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler.BoundingBox Property

BoundingBoxSamplerBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.util.BoundingBoxSampler.BoundingBox"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual TwoGeoHashBoundingBox BoundingBox { get; }
Public Overridable ReadOnly Property BoundingBox As TwoGeoHashBoundingBox
    Get
public:
virtual property TwoGeoHashBoundingBox^ BoundingBox {
    TwoGeoHashBoundingBox^ get ();
}
abstract BoundingBox : TwoGeoHashBoundingBox with get
override BoundingBox : TwoGeoHashBoundingBox with get

Property Value

Type: TwoGeoHashBoundingBox
See Also

Reference

BoundingBoxSampler Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler Methods

The BoundingBoxSampler type exposes the following members.

Methods
 | Name | Description
Public method | Next |
Top
See Also

Reference

BoundingBoxSampler Class
VelocityDBExtensions.Geo.util Namespace


BoundingBoxSampler.Next Method

BoundingBoxSamplerNext Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxSampler.Next"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual GeoHash Next()
Public Overridable Function Next As GeoHash
public:
virtual GeoHash^ Next()
abstract Next : unit -> GeoHash
override Next : unit -> GeoHash

Return Value

Type: GeoHash

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.BoundingBoxSampler.Next"]

See Also

Reference

BoundingBoxSampler Class
VelocityDBExtensions.Geo.util Namespace


GeoHashSizeTable Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.GeoHashSizeTable"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilGeoHashSizeTable

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class GeoHashSizeTable
Public Class GeoHashSizeTable
public ref class GeoHashSizeTable
type GeoHashSizeTable =  class end

The GeoHashSizeTable type exposes the following members.

Constructors
 | Name | Description
Public method | GeoHashSizeTable | Initializes a new instance of the GeoHashSizeTable class
Top
Methods
Name | Description
NumberOfBitsForOverlappingGeoHash |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


GeoHashSizeTable Constructor

Initializes a new instance of the GeoHashSizeTable class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GeoHashSizeTable()
Public Sub New
public:
GeoHashSizeTable()
new : unit -> GeoHashSizeTable
See Also

Reference

GeoHashSizeTable Class
VelocityDBExtensions.Geo.util Namespace


GeoHashSizeTable Methods

The GeoHashSizeTable type exposes the following members.

Methods
Name | Description
NumberOfBitsForOverlappingGeoHash |
Top
See Also

Reference

GeoHashSizeTable Class
VelocityDBExtensions.Geo.util Namespace


GeoHashSizeTable.NumberOfBitsForOverlappingGeoHash Method

GeoHashSizeTableNumberOfBitsForOverlappingGeoHash Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.GeoHashSizeTable.NumberOfBitsForOverlappingGeoHash(VelocityDBExtensions.Geo.BoundingBox)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int NumberOfBitsForOverlappingGeoHash(
    BoundingBox boundingBox
)
Public Shared Function NumberOfBitsForOverlappingGeoHash (
    boundingBox As BoundingBox
) As Integer
public:
static int NumberOfBitsForOverlappingGeoHash(
    BoundingBox^ boundingBox
)
static member NumberOfBitsForOverlappingGeoHash :
        boundingBox : BoundingBox -> int

Parameters

boundingBox
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="boundingBox"/> documentation for "M:VelocityDBExtensions.Geo.util.GeoHashSizeTable.NumberOfBitsForOverlappingGeoHash(VelocityDBExtensions.Geo.BoundingBox)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.GeoHashSizeTable.NumberOfBitsForOverlappingGeoHash(VelocityDBExtensions.Geo.BoundingBox)"]

See Also

Reference

GeoHashSizeTable Class
VelocityDBExtensions.Geo.util Namespace


LongUtil Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.LongUtil"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilLongUtil

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class LongUtil
Public Class LongUtil
public ref class LongUtil
type LongUtil =  class end

The LongUtil type exposes the following members.

Constructors
 | Name | Description
Public method | LongUtil | Initializes a new instance of the LongUtil class
Top
Methods
Name | Description
CommonPrefixLength |
Top
Fields
Name | Description
FIRST_BIT |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


LongUtil Constructor

Initializes a new instance of the LongUtil class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public LongUtil()
Public Sub New
public:
LongUtil()
new : unit -> LongUtil
See Also

Reference

LongUtil Class
VelocityDBExtensions.Geo.util Namespace


LongUtil Methods

The LongUtil type exposes the following members.

Methods
Name | Description
CommonPrefixLength |
Top
See Also

Reference

LongUtil Class
VelocityDBExtensions.Geo.util Namespace


LongUtil.CommonPrefixLength Method

LongUtilCommonPrefixLength Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.LongUtil.CommonPrefixLength(System.Int64,System.Int64)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int CommonPrefixLength(
    long a,
    long b
)
Public Shared Function CommonPrefixLength (
    a As Long,
    b As Long
) As Integer
public:
static int CommonPrefixLength(
    long long a,
    long long b
)
static member CommonPrefixLength :
        a : int64 *
        b : int64 -> int

Parameters

a
Type: SystemInt64

[Missing <param name="a"/> documentation for "M:VelocityDBExtensions.Geo.util.LongUtil.CommonPrefixLength(System.Int64,System.Int64)"]

b
Type: SystemInt64

[Missing <param name="b"/> documentation for "M:VelocityDBExtensions.Geo.util.LongUtil.CommonPrefixLength(System.Int64,System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.LongUtil.CommonPrefixLength(System.Int64,System.Int64)"]

See Also

Reference

LongUtil Class
VelocityDBExtensions.Geo.util Namespace


LongUtil Fields

The LongUtil type exposes the following members.

Fields
Name | Description
FIRST_BIT |
Top
See Also

Reference

LongUtil Class
VelocityDBExtensions.Geo.util Namespace


LongUtil.FIRST_BIT Field

LongUtilFIRST_BIT Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Geo.util.LongUtil.FIRST_BIT"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const long FIRST_BIT = -9223372036854775808
Public Const FIRST_BIT As Long = -9223372036854775808
public:
literal long long FIRST_BIT = -9223372036854775808
static val mutable FIRST_BIT: int64

Field Value

Type: Int64
See Also

Reference

LongUtil Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilTwoGeoHashBoundingBox

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class TwoGeoHashBoundingBox
Public Class TwoGeoHashBoundingBox
public ref class TwoGeoHashBoundingBox
type TwoGeoHashBoundingBox =  class end

The TwoGeoHashBoundingBox type exposes the following members.

Constructors
 | Name | Description
Public method | TwoGeoHashBoundingBox | Initializes a new instance of the TwoGeoHashBoundingBox class
Top
Properties
 | Name | Description
Public property | BottomLeft |
Public property | BoundingBox |
Public property | TopRight |
Top
Methods
 | Name | Description
 | FromBase32 |
Public method | ToBase32 |
 | WithBitPrecision |
 | WithCharacterPrecision |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox Constructor

Initializes a new instance of the TwoGeoHashBoundingBox class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public TwoGeoHashBoundingBox(
    GeoHash bottomLeft,
    GeoHash topRight
)
Public Sub New (
    bottomLeft As GeoHash,
    topRight As GeoHash
)
public:
TwoGeoHashBoundingBox(
    GeoHash^ bottomLeft,
    GeoHash^ topRight
)
new :
        bottomLeft : GeoHash *
        topRight : GeoHash -> TwoGeoHashBoundingBox

Parameters

bottomLeft
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="bottomLeft"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.#ctor(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

topRight
Type: VelocityDBExtensions.GeoGeoHash

[Missing <param name="topRight"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.#ctor(VelocityDBExtensions.Geo.GeoHash,VelocityDBExtensions.Geo.GeoHash)"]

See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox Properties

The TwoGeoHashBoundingBox type exposes the following members.

Properties
 | Name | Description
Public property | BottomLeft |
Public property | BoundingBox |
Public property | TopRight |
Top
See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.BottomLeft Property

TwoGeoHashBoundingBoxBottomLeft Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.BottomLeft"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual GeoHash BottomLeft { get; }
Public Overridable ReadOnly Property BottomLeft As GeoHash
    Get
public:
virtual property GeoHash^ BottomLeft {
    GeoHash^ get ();
}
abstract BottomLeft : GeoHash with get
override BottomLeft : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.BoundingBox Property

TwoGeoHashBoundingBoxBoundingBox Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.BoundingBox"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual BoundingBox BoundingBox { get; }
Public Overridable ReadOnly Property BoundingBox As BoundingBox
    Get
public:
virtual property BoundingBox^ BoundingBox {
    BoundingBox^ get ();
}
abstract BoundingBox : BoundingBox with get
override BoundingBox : BoundingBox with get

Property Value

Type: BoundingBox
See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.TopRight Property

TwoGeoHashBoundingBoxTopRight Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.TopRight"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual GeoHash TopRight { get; }
Public Overridable ReadOnly Property TopRight As GeoHash
    Get
public:
virtual property GeoHash^ TopRight {
    GeoHash^ get ();
}
abstract TopRight : GeoHash with get
override TopRight : GeoHash with get

Property Value

Type: GeoHash
See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox Methods

The TwoGeoHashBoundingBox type exposes the following members.

Methods
 | Name | Description
 | FromBase32 |
Public method | ToBase32 |
 | WithBitPrecision |
 | WithCharacterPrecision |
Top
See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.FromBase32 Method

TwoGeoHashBoundingBoxFromBase32 Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.FromBase32(System.String)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static TwoGeoHashBoundingBox FromBase32(
    string base32
)
Public Shared Function FromBase32 (
    base32 As String
) As TwoGeoHashBoundingBox
public:
static TwoGeoHashBoundingBox^ FromBase32(
    String^ base32
)
static member FromBase32 :
        base32 : string -> TwoGeoHashBoundingBox

Parameters

base32
Type: SystemString

[Missing <param name="base32"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.FromBase32(System.String)"]

Return Value

Type: TwoGeoHashBoundingBox

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.FromBase32(System.String)"]

See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.ToBase32 Method

TwoGeoHashBoundingBoxToBase32 Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.ToBase32"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual string ToBase32()
Public Overridable Function ToBase32 As String
public:
virtual String^ ToBase32()
abstract ToBase32 : unit -> string
override ToBase32 : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.ToBase32"]

See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.WithBitPrecision Method

TwoGeoHashBoundingBoxWithBitPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithBitPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static TwoGeoHashBoundingBox WithBitPrecision(
    BoundingBox bbox,
    int numberOfBits
)
Public Shared Function WithBitPrecision (
    bbox As BoundingBox,
    numberOfBits As Integer
) As TwoGeoHashBoundingBox
public:
static TwoGeoHashBoundingBox^ WithBitPrecision(
    BoundingBox^ bbox,
    int numberOfBits
)
static member WithBitPrecision :
        bbox : BoundingBox *
        numberOfBits : int -> TwoGeoHashBoundingBox

Parameters

bbox
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithBitPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

numberOfBits
Type: SystemInt32

[Missing <param name="numberOfBits"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithBitPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

Return Value

Type: TwoGeoHashBoundingBox

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithBitPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


TwoGeoHashBoundingBox.WithCharacterPrecision Method

TwoGeoHashBoundingBoxWithCharacterPrecision Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithCharacterPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static TwoGeoHashBoundingBox WithCharacterPrecision(
    BoundingBox bbox,
    int numberOfCharacters
)
Public Shared Function WithCharacterPrecision (
    bbox As BoundingBox,
    numberOfCharacters As Integer
) As TwoGeoHashBoundingBox
public:
static TwoGeoHashBoundingBox^ WithCharacterPrecision(
    BoundingBox^ bbox,
    int numberOfCharacters
)
static member WithCharacterPrecision :
        bbox : BoundingBox *
        numberOfCharacters : int -> TwoGeoHashBoundingBox

Parameters

bbox
Type: VelocityDBExtensions.GeoBoundingBox

[Missing <param name="bbox"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithCharacterPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

numberOfCharacters
Type: SystemInt32

[Missing <param name="numberOfCharacters"/> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithCharacterPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

Return Value

Type: TwoGeoHashBoundingBox

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.TwoGeoHashBoundingBox.WithCharacterPrecision(VelocityDBExtensions.Geo.BoundingBox,System.Int32)"]

See Also

Reference

TwoGeoHashBoundingBox Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Geo.util.VincentyGeodesy"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.Geo.utilVincentyGeodesy

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class VincentyGeodesy
Public Class VincentyGeodesy
public ref class VincentyGeodesy
type VincentyGeodesy =  class end

The VincentyGeodesy type exposes the following members.

Constructors
 | Name | Description
Public method | VincentyGeodesy | Initializes a new instance of the VincentyGeodesy class
Top
Methods
Name | Description
DistanceInMeters |
MoveInDirection |
Top
Fields
Name | Description
DegToRad |
EPSILON |
Top
See Also

Reference

VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy Constructor

Initializes a new instance of the VincentyGeodesy class

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VincentyGeodesy()
Public Sub New
public:
VincentyGeodesy()
new : unit -> VincentyGeodesy
See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy Methods

The VincentyGeodesy type exposes the following members.

Methods
Name | Description
DistanceInMeters |
MoveInDirection |
Top
See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy.DistanceInMeters Method

VincentyGeodesyDistanceInMeters Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.DistanceInMeters(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static double DistanceInMeters(
    WGS84Point foo,
    WGS84Point bar
)
Public Shared Function DistanceInMeters (
    foo As WGS84Point,
    bar As WGS84Point
) As Double
public:
static double DistanceInMeters(
    WGS84Point^ foo,
    WGS84Point^ bar
)
static member DistanceInMeters :
        foo : WGS84Point *
        bar : WGS84Point -> float

Parameters

foo
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="foo"/> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.DistanceInMeters(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

bar
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="bar"/> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.DistanceInMeters(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.DistanceInMeters(VelocityDBExtensions.Geo.WGS84Point,VelocityDBExtensions.Geo.WGS84Point)"]

See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy.MoveInDirection Method

VincentyGeodesyMoveInDirection Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.MoveInDirection(VelocityDBExtensions.Geo.WGS84Point,System.Double,System.Double)"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static WGS84Point MoveInDirection(
    WGS84Point point,
    double bearingInDegrees,
    double distanceInMeters
)
Public Shared Function MoveInDirection (
    point As WGS84Point,
    bearingInDegrees As Double,
    distanceInMeters As Double
) As WGS84Point
public:
static WGS84Point^ MoveInDirection(
    WGS84Point^ point,
    double bearingInDegrees,
    double distanceInMeters
)
static member MoveInDirection :
        point : WGS84Point *
        bearingInDegrees : float *
        distanceInMeters : float -> WGS84Point

Parameters

point
Type: VelocityDBExtensions.GeoWGS84Point

[Missing <param name="point"/> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.MoveInDirection(VelocityDBExtensions.Geo.WGS84Point,System.Double,System.Double)"]

bearingInDegrees
Type: SystemDouble

[Missing <param name="bearingInDegrees"/> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.MoveInDirection(VelocityDBExtensions.Geo.WGS84Point,System.Double,System.Double)"]

distanceInMeters
Type: SystemDouble

[Missing <param name="distanceInMeters"/> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.MoveInDirection(VelocityDBExtensions.Geo.WGS84Point,System.Double,System.Double)"]

Return Value

Type: WGS84Point

[Missing <returns> documentation for "M:VelocityDBExtensions.Geo.util.VincentyGeodesy.MoveInDirection(VelocityDBExtensions.Geo.WGS84Point,System.Double,System.Double)"]

See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy Fields

The VincentyGeodesy type exposes the following members.

Fields
Name | Description
DegToRad |
EPSILON |
Top
See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy.DegToRad Field

VincentyGeodesyDegToRad Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Geo.util.VincentyGeodesy.DegToRad"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const double DegToRad = 0.0174532925199433
Public Const DegToRad As Double = 0.0174532925199433
public:
literal double DegToRad = 0.0174532925199433
static val mutable DegToRad: float

Field Value

Type: Double
See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VincentyGeodesy.EPSILON Field

VincentyGeodesyEPSILON Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Geo.util.VincentyGeodesy.EPSILON"]

Namespace: VelocityDBExtensions.Geo.util
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const double EPSILON = 1E-12
Public Const EPSILON As Double = 1E-12
public:
literal double EPSILON = 1E-12
static val mutable EPSILON: float

Field Value

Type: Double
See Also

Reference

VincentyGeodesy Class
VelocityDBExtensions.Geo.util Namespace


VelocityDBExtensions.Spatial Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions.Spatial"]

Classes
 | Class | Description
Public class | PriorityQueuePriority, Value |
Public class | PriorityQueueRTree |
Public class | RTree |
Structures
 | Structure | Description
Public structure | Point |
Public structure | Rectangle |


Point Structure

[Missing <summary> documentation for "T:VelocityDBExtensions.Spatial.Point"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public struct Point
Public Structure Point
public value class Point
[<SealedAttribute>]
type Point =  struct end

The Point type exposes the following members.

Constructors
 | Name | Description
Public method | Point | Initializes a new instance of the Point class
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

VelocityDBExtensions.Spatial Namespace


Point Constructor

Initializes a new instance of the Point class

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Point(
    double x,
    double y
)
Public Sub New (
    x As Double,
    y As Double
)
public:
Point(
    double x,
    double y
)
new :
        x : float *
        y : float -> Point

Parameters

x
Type: SystemDouble

[Missing <param name="x"/> documentation for "M:VelocityDBExtensions.Spatial.Point.#ctor(System.Double,System.Double)"]

y
Type: SystemDouble

[Missing <param name="y"/> documentation for "M:VelocityDBExtensions.Spatial.Point.#ctor(System.Double,System.Double)"]

See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


Point Methods

The Point type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ValueTypeToString.)
Top
See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


Point.ToString Method

PointToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Point.ToString"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Point.ToString"]

See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


Point Fields

The Point type exposes the following members.

Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


Point.x Field

Pointx Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Spatial.Point.x"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double x
Public x As Double
public:
double x
val mutable x: float

Field Value

Type: Double
See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


Point.y Field

Pointy Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Spatial.Point.y"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double y
Public y As Double
public:
double y
val mutable y: float

Field Value

Type: Double
See Also

Reference

Point Structure
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value) Class

PriorityQueuePriority, Value Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Spatial.PriorityQueue`2"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.SpatialPriorityQueuePriority, Value
VelocityDBExtensions.SpatialPriorityQueueRTree

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class PriorityQueue<Priority, Value>
where Priority : IComparable

Public Class PriorityQueue(Of Priority As IComparable, Value)
generic<typename Priority, typename Value>
where Priority : IComparable
public ref class PriorityQueue
type PriorityQueue<'Priority, 'Value when 'Priority : IComparable> =  class end

Type Parameters

Priority

[Missing <typeparam name="Priority"/> documentation for "T:VelocityDBExtensions.Spatial.PriorityQueue`2"]

Value

[Missing <typeparam name="Value"/> documentation for "T:VelocityDBExtensions.Spatial.PriorityQueue`2"]

The PriorityQueuePriority, Value type exposes the following members.

Constructors
 | Name | Description
Public method | PriorityQueuePriority, Value | Initializes a new instance of the PriorityQueuePriority, Value class
Top
Properties
 | Name | Description
Public property | Count |
Public property | PriorityPeek |
Public property | SortOrderAscending |
Public property | ValuePeek |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Insert |
Public method | Pop |
Top
See Also

Reference

VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value) Constructor

PriorityQueuePriority, Value Constructor

Initializes a new instance of the PriorityQueuePriority, Value class

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PriorityQueue(
    bool sortOrderAscending = true,
    int initialCapacity = 25
)
Public Sub New (
    Optional sortOrderAscending As Boolean = true,
    Optional initialCapacity As Integer = 25
)
public:
PriorityQueue(
    bool sortOrderAscending = true,
    int initialCapacity = 25
)
new :
        ?sortOrderAscending : bool *
        ?initialCapacity : int
(* Defaults:
        let _sortOrderAscending = defaultArg sortOrderAscending true
        let _initialCapacity = defaultArg initialCapacity 25
*)
-> PriorityQueue

Parameters

sortOrderAscending (Optional)
Type: SystemBoolean

[Missing <param name="sortOrderAscending"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.#ctor(System.Boolean,System.Int32)"]

initialCapacity (Optional)
Type: SystemInt32

[Missing <param name="initialCapacity"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.#ctor(System.Boolean,System.Int32)"]

See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value) Properties

PriorityQueuePriority, Value Properties

The PriorityQueuePriority, Value generic type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | PriorityPeek |
Public property | SortOrderAscending |
Public property | ValuePeek |
Top
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).Count Property

PriorityQueuePriority, ValueCount Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.PriorityQueue`2.Count"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).PriorityPeek Property

PriorityQueuePriority, ValuePriorityPeek Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.PriorityQueue`2.PriorityPeek"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Priority PriorityPeek { get; }
Public ReadOnly Property PriorityPeek As Priority
    Get
public:
property Priority PriorityPeek {
    Priority get ();
}
member PriorityPeek : 'Priority with get

Property Value

Type: Priority
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).SortOrderAscending Property

PriorityQueuePriority, ValueSortOrderAscending Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.PriorityQueue`2.SortOrderAscending"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SortOrderAscending { get; set; }
Public Overridable Property SortOrderAscending As Boolean
    Get
    Set
public:
virtual property bool SortOrderAscending {
    bool get ();
    void set (bool value);
}
abstract SortOrderAscending : bool with get, set
override SortOrderAscending : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).ValuePeek Property

PriorityQueuePriority, ValueValuePeek Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.PriorityQueue`2.ValuePeek"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Value ValuePeek { get; }
Public ReadOnly Property ValuePeek As Value
    Get
public:
property Value ValuePeek {
    Value get ();
}
member ValuePeek : 'Value with get

Property Value

Type: Value
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value) Methods

PriorityQueuePriority, Value Methods

The PriorityQueuePriority, Value generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Insert |
Public method | Pop |
Top
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).Clear Method

PriorityQueuePriority, ValueClear Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Clear"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).Insert Method

PriorityQueuePriority, ValueInsert Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Insert(`1,`0)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Value value,
    Priority priority
)
Public Overridable Sub Insert (
    value As Value,
    priority As Priority
)
public:
virtual void Insert(
    Value value,
    Priority priority
)
abstract Insert :
        value : 'Value *
        priority : 'Priority -> unit
override Insert :
        value : 'Value *
        priority : 'Priority -> unit

Parameters

value
Type: Value

[Missing <param name="value"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Insert(`1,`0)"]

priority
Type: Priority

[Missing <param name="priority"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Insert(`1,`0)"]

See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueue(Priority, Value).Pop Method

PriorityQueuePriority, ValuePop Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Pop"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Value Pop()
Public Overridable Function Pop As Value
public:
virtual Value Pop()
abstract Pop : unit -> 'Value
override Pop : unit -> 'Value

Return Value

Type: Value

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueue`2.Pop"]

See Also

Reference

PriorityQueuePriority, Value Class
VelocityDBExtensions.Spatial Namespace


PriorityQueueRTree Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Spatial.PriorityQueueRTree"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions.SpatialPriorityQueue Double, Rectangle
VelocityDBExtensions.SpatialPriorityQueueRTree

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class PriorityQueueRTree : PriorityQueue<double, Rectangle>
Public Class PriorityQueueRTree
    Inherits PriorityQueue(Of Double, Rectangle)
public ref class PriorityQueueRTree : public PriorityQueue<double, Rectangle>
type PriorityQueueRTree =
    class
        inherit PriorityQueue<float, Rectangle>
    end

The PriorityQueueRTree type exposes the following members.

Constructors
 | Name | Description
Public method | PriorityQueueRTree | Initializes a new instance of the PriorityQueueRTree class
Top
See Also

Reference

VelocityDBExtensions.Spatial Namespace


PriorityQueueRTree Constructor

Initializes a new instance of the PriorityQueueRTree class

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PriorityQueueRTree(
    bool sortOrderAscending = true,
    int initialCapacity = 25
)
Public Sub New (
    Optional sortOrderAscending As Boolean = true,
    Optional initialCapacity As Integer = 25
)
public:
PriorityQueueRTree(
    bool sortOrderAscending = true,
    int initialCapacity = 25
)
new :
        ?sortOrderAscending : bool *
        ?initialCapacity : int
(* Defaults:
        let _sortOrderAscending = defaultArg sortOrderAscending true
        let _initialCapacity = defaultArg initialCapacity 25
*)
-> PriorityQueueRTree

Parameters

sortOrderAscending (Optional)
Type: SystemBoolean

[Missing <param name="sortOrderAscending"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueueRTree.#ctor(System.Boolean,System.Int32)"]

initialCapacity (Optional)
Type: SystemInt32

[Missing <param name="initialCapacity"/> documentation for "M:VelocityDBExtensions.Spatial.PriorityQueueRTree.#ctor(System.Boolean,System.Int32)"]

See Also

Reference

PriorityQueueRTree Class
VelocityDBExtensions.Spatial Namespace


Rectangle Structure

[Missing <summary> documentation for "T:VelocityDBExtensions.Spatial.Rectangle"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public struct Rectangle : IComparable
Public Structure Rectangle
    Implements IComparable
public value class Rectangle : IComparable
[<SealedAttribute>]
type Rectangle =
    struct
        interface IComparable
    end

The Rectangle type exposes the following members.

Constructors
 | Name | Description
Public method | Rectangle | Initializes a new instance of the Rectangle class
Top
Properties
 | Name | Description
Public property | Area |
Public property | AspectRatio |
Public property | Centre |
Public property | Height |
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Public property | Width |
Top
Methods
 | Name | Description
Public method | add |
Public method | Add |
Public method | CompareTo |
Public method | containedBy |
Public method | Contains |
Public method | distance |
Public method | Distance(Point) |
Public method | Distance(Rectangle) |
Public method | distanceSq |
Public method | edgeOverlaps |
 | enlargement |
Public method | Enlargement |
Public method | Equals |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | Intersects |
Public method | sameObject |
Public method | set |
Public method | ToString | (Overrides ValueTypeToString.)
Public method | union |
Top
See Also

Reference

VelocityDBExtensions.Spatial Namespace


Rectangle Constructor

Initializes a new instance of the Rectangle class

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Rectangle(
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub New (
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double
)
public:
Rectangle(
    double x1,
    double y1,
    double x2,
    double y2
)
new :
        x1 : float *
        y1 : float *
        x2 : float *
        y2 : float -> Rectangle

Parameters

x1
Type: SystemDouble

[Missing <param name="x1"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y1
Type: SystemDouble

[Missing <param name="y1"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

x2
Type: SystemDouble

[Missing <param name="x2"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y2
Type: SystemDouble

[Missing <param name="y2"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.#ctor(System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle Properties

The Rectangle type exposes the following members.

Properties
 | Name | Description
Public property | Area |
Public property | AspectRatio |
Public property | Centre |
Public property | Height |
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Public property | Width |
Top
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Area Property

RectangleArea Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.Area"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.AspectRatio Property

RectangleAspectRatio Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.AspectRatio"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double AspectRatio { get; }
Public ReadOnly Property AspectRatio As Double
    Get
public:
property double AspectRatio {
    double get ();
}
member AspectRatio : float with get

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Centre Property

RectangleCentre Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.Centre"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Point Centre { get; }
Public ReadOnly Property Centre As Point
    Get
public:
property Point Centre {
    Point get ();
}
member Centre : Point with get

Property Value

Type: Point
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Height Property

RectangleHeight Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.Height"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.MaxX Property

RectangleMaxX Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.MaxX"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double MaxX { get; set; }
Public Property MaxX As Double
    Get
    Set
public:
property double MaxX {
    double get ();
    void set (double value);
}
member MaxX : float with get, set

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.MaxY Property

RectangleMaxY Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.MaxY"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double MaxY { get; set; }
Public Property MaxY As Double
    Get
    Set
public:
property double MaxY {
    double get ();
    void set (double value);
}
member MaxY : float with get, set

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.MinX Property

RectangleMinX Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.MinX"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double MinX { get; set; }
Public Property MinX As Double
    Get
    Set
public:
property double MinX {
    double get ();
    void set (double value);
}
member MinX : float with get, set

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.MinY Property

RectangleMinY Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.MinY"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double MinY { get; set; }
Public Property MinY As Double
    Get
    Set
public:
property double MinY {
    double get ();
    void set (double value);
}
member MinY : float with get, set

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Width Property

RectangleWidth Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.Rectangle.Width"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Type: Double
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle Methods

The Rectangle type exposes the following members.

Methods
 | Name | Description
Public method | add |
Public method | Add |
Public method | CompareTo |
Public method | containedBy |
Public method | Contains |
Public method | distance |
Public method | Distance(Point) |
Public method | Distance(Rectangle) |
Public method | distanceSq |
Public method | edgeOverlaps |
 | enlargement |
Public method | Enlargement |
Public method | Equals |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | Intersects |
Public method | sameObject |
Public method | set |
Public method | ToString | (Overrides ValueTypeToString.)
Public method | union |
Top
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.add Method

Rectangleadd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.add(VelocityDBExtensions.Spatial.Point)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void add(
    Point p
)
Public Sub add (
    p As Point
)
public:
void add(
    Point p
)
member add :
        p : Point -> unit

Parameters

p
Type: VelocityDBExtensions.SpatialPoint

[Missing <param name="p"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.add(VelocityDBExtensions.Spatial.Point)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Add Method

RectangleAdd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Add(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Rectangle r
)
Public Sub Add (
    r As Rectangle
)
public:
void Add(
    Rectangle r
)
member Add :
        r : Rectangle -> unit

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Add(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.CompareTo Method

RectangleCompareTo Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.CompareTo(System.Object)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object o
)
Public Function CompareTo (
    o As Object
) As Integer
public:
virtual int CompareTo(
    Object^ o
) sealed
abstract CompareTo :
        o : Object -> int
override CompareTo :
        o : Object -> int

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.CompareTo(System.Object)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.containedBy Method

RectanglecontainedBy Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.containedBy(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool containedBy(
    Rectangle r
)
Public Function containedBy (
    r As Rectangle
) As Boolean
public:
bool containedBy(
    Rectangle r
)
member containedBy :
        r : Rectangle -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.containedBy(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.containedBy(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Contains Method

RectangleContains Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Contains(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Rectangle r
)
Public Function Contains (
    r As Rectangle
) As Boolean
public:
bool Contains(
    Rectangle r
)
member Contains :
        r : Rectangle -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Contains(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Contains(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.distance Method

Rectangledistance Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distance(System.Double,System.Double)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double distance(
    double pX,
    double pY
)
Public Function distance (
    pX As Double,
    pY As Double
) As Double
public:
double distance(
    double pX,
    double pY
)
member distance :
        pX : float *
        pY : float -> float

Parameters

pX
Type: SystemDouble

[Missing <param name="pX"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distance(System.Double,System.Double)"]

pY
Type: SystemDouble

[Missing <param name="pY"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distance(System.Double,System.Double)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distance(System.Double,System.Double)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Distance Method

RectangleDistance Method

Overload List
 | Name | Description
Public method | Distance(Point) |
Public method | Distance(Rectangle) |
Top
See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Distance Method (Point)

RectangleDistance Method (Point)

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Point)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Distance(
    Point p
)
Public Function Distance (
    p As Point
) As Double
public:
double Distance(
    Point p
)
member Distance :
        p : Point -> float

Parameters

p
Type: VelocityDBExtensions.SpatialPoint

[Missing <param name="p"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Point)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Point)"]

See Also

Reference

Rectangle Structure
Distance Overload
VelocityDBExtensions.Spatial Namespace


Rectangle.Distance Method (Rectangle)

RectangleDistance Method (Rectangle)

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Distance(
    Rectangle r
)
Public Function Distance (
    r As Rectangle
) As Double
public:
double Distance(
    Rectangle r
)
member Distance :
        r : Rectangle -> float

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Distance(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
Distance Overload
VelocityDBExtensions.Spatial Namespace


Rectangle.distanceSq Method

RectangledistanceSq Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distanceSq(System.Double,System.Double)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double distanceSq(
    double pX,
    double pY
)
Public Function distanceSq (
    pX As Double,
    pY As Double
) As Double
public:
double distanceSq(
    double pX,
    double pY
)
member distanceSq :
        pX : float *
        pY : float -> float

Parameters

pX
Type: SystemDouble

[Missing <param name="pX"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distanceSq(System.Double,System.Double)"]

pY
Type: SystemDouble

[Missing <param name="pY"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distanceSq(System.Double,System.Double)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.distanceSq(System.Double,System.Double)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.edgeOverlaps Method

RectangleedgeOverlaps Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.edgeOverlaps(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool edgeOverlaps(
    Rectangle r
)
Public Function edgeOverlaps (
    r As Rectangle
) As Boolean
public:
bool edgeOverlaps(
    Rectangle r
)
member edgeOverlaps :
        r : Rectangle -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.edgeOverlaps(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.edgeOverlaps(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.enlargement Method

Rectangleenlargement Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.enlargement(VelocityDBExtensions.Spatial.Rectangle,VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static double enlargement(
    Rectangle r1,
    Rectangle r2
)
Public Shared Function enlargement (
    r1 As Rectangle,
    r2 As Rectangle
) As Double
public:
static double enlargement(
    Rectangle r1,
    Rectangle r2
)
static member enlargement :
        r1 : Rectangle *
        r2 : Rectangle -> float

Parameters

r1
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r1"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.enlargement(VelocityDBExtensions.Spatial.Rectangle,VelocityDBExtensions.Spatial.Rectangle)"]

r2
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r2"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.enlargement(VelocityDBExtensions.Spatial.Rectangle,VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.enlargement(VelocityDBExtensions.Spatial.Rectangle,VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Enlargement Method

RectangleEnlargement Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Enlargement(VelocityDBExtensions.Spatial.Rectangle@)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public double Enlargement(
    ref Rectangle r
)
Public Function Enlargement (
    ByRef r As Rectangle
) As Double
public:
double Enlargement(
    Rectangle% r
)
member Enlargement :
        r : Rectangle byref -> float

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Enlargement(VelocityDBExtensions.Spatial.Rectangle@)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Enlargement(VelocityDBExtensions.Spatial.Rectangle@)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Equals Method

RectangleEquals Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Equals(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Rectangle r
)
Public Function Equals (
    r As Rectangle
) As Boolean
public:
bool Equals(
    Rectangle r
)
member Equals :
        r : Rectangle -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Equals(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Equals(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.GetHashCode Method

RectangleGetHashCode Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.GetHashCode"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.GetHashCode"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.Intersects Method

RectangleIntersects Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Intersects(System.Nullable{VelocityDBExtensions.Spatial.Rectangle}@)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Intersects(
    ref Nullable<Rectangle> r
)
Public Function Intersects (
    ByRef r As Nullable(Of Rectangle)
) As Boolean
public:
bool Intersects(
    Nullable<Rectangle>% r
)
member Intersects :
        r : Nullable<Rectangle> byref -> bool

Parameters

r
Type: SystemNullable Rectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Intersects(System.Nullable{VelocityDBExtensions.Spatial.Rectangle}@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.Intersects(System.Nullable{VelocityDBExtensions.Spatial.Rectangle}@)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.sameObject Method

RectanglesameObject Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.sameObject(System.Object)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool sameObject(
    Object o
)
Public Function sameObject (
    o As Object
) As Boolean
public:
bool sameObject(
    Object^ o
)
member sameObject :
        o : Object -> bool

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.sameObject(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.sameObject(System.Object)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.set Method

Rectangleset Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.set(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void set(
    Rectangle r
)
Public Sub set (
    r As Rectangle
)
public:
void set(
    Rectangle r
)
member set :
        r : Rectangle -> unit

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.set(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.ToString Method

RectangleToString Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.ToString"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.ToString"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


Rectangle.union Method

Rectangleunion Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.union(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Rectangle union(
    Rectangle r
)
Public Function union (
    r As Rectangle
) As Rectangle
public:
Rectangle union(
    Rectangle r
)
member union :
        r : Rectangle -> Rectangle

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.union(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Rectangle

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.Rectangle.union(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

Rectangle Structure
VelocityDBExtensions.Spatial Namespace


RTree Class

[Missing <summary> documentation for "T:VelocityDBExtensions.Spatial.RTree"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions.SpatialRTree

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class RTree : OptimizedPersistable
Public Class RTree
    Inherits OptimizedPersistable
public ref class RTree : public OptimizedPersistable
type RTree =
    class
        inherit OptimizedPersistable
    end

The RTree type exposes the following members.

Constructors
 | Name | Description
Public method | RTree | Initializes a new instance of the RTree class
Top
Properties
 | Name | Description
Public property | Bounds |
Public property | Count |
Top
Methods
 | Name | Description
Public method | Add |
Public method | checkConsistency |
Public method | Contains |
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | Intersects |
Public method | Nearest |
Public method | NearestN |
Public method | Remove |
Top
Fields
Name | Description
defaultMaxNodeEntries |
defaultMinNodeEntries |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions.Spatial Namespace


RTree Constructor

Initializes a new instance of the RTree class

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RTree(
    int minNodeEntries = 80,
    int maxNodeEntries = 200
)
Public Sub New (
    Optional minNodeEntries As Integer = 80,
    Optional maxNodeEntries As Integer = 200
)
public:
RTree(
    int minNodeEntries = 80,
    int maxNodeEntries = 200
)
new :
        ?minNodeEntries : int *
        ?maxNodeEntries : int
(* Defaults:
        let _minNodeEntries = defaultArg minNodeEntries 80
        let _maxNodeEntries = defaultArg maxNodeEntries 200
*)
-> RTree

Parameters

minNodeEntries (Optional)
Type: SystemInt32

[Missing <param name="minNodeEntries"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.#ctor(System.Int32,System.Int32)"]

maxNodeEntries (Optional)
Type: SystemInt32

[Missing <param name="maxNodeEntries"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.#ctor(System.Int32,System.Int32)"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree Properties

The RTree type exposes the following members.

Properties
 | Name | Description
Public property | Bounds |
Public property | Count |
Top
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Bounds Property

RTreeBounds Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.RTree.Bounds"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Rectangle> Bounds { get; }
Public ReadOnly Property Bounds As Nullable(Of Rectangle)
    Get
public:
property Nullable<Rectangle> Bounds {
    Nullable<Rectangle> get ();
}
member Bounds : Nullable<Rectangle> with get

Property Value

Type: Nullable Rectangle
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Count Property

RTreeCount Property

[Missing <summary> documentation for "P:VelocityDBExtensions.Spatial.RTree.Count"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree Methods

The RTree type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | checkConsistency |
Public method | Contains |
Public method | InitializeAfterRead | (Overrides OptimizedPersistableInitializeAfterRead(SessionBase).)
Public method | Intersects |
Public method | Nearest |
Public method | NearestN |
Public method | Remove |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Add Method

RTreeAdd Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.Add(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Rectangle r
)
Public Sub Add (
    r As Rectangle
)
public:
void Add(
    Rectangle r
)
member Add :
        r : Rectangle -> unit

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Add(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.checkConsistency Method

RTreecheckConsistency Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.checkConsistency"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool checkConsistency()
Public Function checkConsistency As Boolean
public:
bool checkConsistency()
member checkConsistency : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.RTree.checkConsistency"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Contains Method

RTreeContains Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.Contains(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Contains(
    Rectangle r,
    Func<Rectangle, bool> v
)
Public Sub Contains (
    r As Rectangle,
    v As Func(Of Rectangle, Boolean)
)
public:
void Contains(
    Rectangle r,
    Func<Rectangle, bool>^ v
)
member Contains :
        r : Rectangle *
        v : Func<Rectangle, bool> -> unit

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Contains(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

v
Type: SystemFunc Rectangle, Boolean

[Missing <param name="v"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Contains(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.InitializeAfterRead Method

RTreeInitializeAfterRead Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void InitializeAfterRead(
    SessionBase session
)
Public Overrides Sub InitializeAfterRead (
    session As SessionBase
)
public:
virtual void InitializeAfterRead(
    SessionBase^ session
) override
abstract InitializeAfterRead :
        session : SessionBase -> unit
override InitializeAfterRead :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.InitializeAfterRead(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableInitializeAfterRead(SessionBase)
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Intersects Method

RTreeIntersects Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.Intersects(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Intersects(
    Rectangle r,
    Func<Rectangle, bool> v
)
Public Function Intersects (
    r As Rectangle,
    v As Func(Of Rectangle, Boolean)
) As Boolean
public:
bool Intersects(
    Rectangle r,
    Func<Rectangle, bool>^ v
)
member Intersects :
        r : Rectangle *
        v : Func<Rectangle, bool> -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Intersects(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

v
Type: SystemFunc Rectangle, Boolean

[Missing <param name="v"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Intersects(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.RTree.Intersects(VelocityDBExtensions.Spatial.Rectangle,System.Func{VelocityDBExtensions.Spatial.Rectangle,System.Boolean})"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Nearest Method

RTreeNearest Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.Nearest(VelocityDBExtensions.Spatial.Point,System.Double)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PriorityQueueRTree Nearest(
    Point p,
    double furthestDistance
)
Public Function Nearest (
    p As Point,
    furthestDistance As Double
) As PriorityQueueRTree
public:
PriorityQueueRTree^ Nearest(
    Point p,
    double furthestDistance
)
member Nearest :
        p : Point *
        furthestDistance : float -> PriorityQueueRTree

Parameters

p
Type: VelocityDBExtensions.SpatialPoint

[Missing <param name="p"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Nearest(VelocityDBExtensions.Spatial.Point,System.Double)"]

furthestDistance
Type: SystemDouble

[Missing <param name="furthestDistance"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Nearest(VelocityDBExtensions.Spatial.Point,System.Double)"]

Return Value

Type: PriorityQueueRTree

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.RTree.Nearest(VelocityDBExtensions.Spatial.Point,System.Double)"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.NearestN Method

RTreeNearestN Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.NearestN(VelocityDBExtensions.Spatial.Point,System.UInt32,System.Double)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PriorityQueueRTree NearestN(
    Point p,
    uint count,
    double furthestDistance
)
Public Function NearestN (
    p As Point,
    count As UInteger,
    furthestDistance As Double
) As PriorityQueueRTree
public:
PriorityQueueRTree^ NearestN(
    Point p,
    unsigned int count,
    double furthestDistance
)
member NearestN :
        p : Point *
        count : uint32 *
        furthestDistance : float -> PriorityQueueRTree

Parameters

p
Type: VelocityDBExtensions.SpatialPoint

[Missing <param name="p"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.NearestN(VelocityDBExtensions.Spatial.Point,System.UInt32,System.Double)"]

count
Type: SystemUInt32

[Missing <param name="count"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.NearestN(VelocityDBExtensions.Spatial.Point,System.UInt32,System.Double)"]

furthestDistance
Type: SystemDouble

[Missing <param name="furthestDistance"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.NearestN(VelocityDBExtensions.Spatial.Point,System.UInt32,System.Double)"]

Return Value

Type: PriorityQueueRTree

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.RTree.NearestN(VelocityDBExtensions.Spatial.Point,System.UInt32,System.Double)"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.Remove Method

RTreeRemove Method

[Missing <summary> documentation for "M:VelocityDBExtensions.Spatial.RTree.Remove(VelocityDBExtensions.Spatial.Rectangle)"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    Rectangle r
)
Public Function Remove (
    r As Rectangle
) As Boolean
public:
bool Remove(
    Rectangle r
)
member Remove :
        r : Rectangle -> bool

Parameters

r
Type: VelocityDBExtensions.SpatialRectangle

[Missing <param name="r"/> documentation for "M:VelocityDBExtensions.Spatial.RTree.Remove(VelocityDBExtensions.Spatial.Rectangle)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions.Spatial.RTree.Remove(VelocityDBExtensions.Spatial.Rectangle)"]

See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree Fields

The RTree type exposes the following members.

Fields
Name | Description
defaultMaxNodeEntries |
defaultMinNodeEntries |
Top
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.defaultMaxNodeEntries Field

RTreedefaultMaxNodeEntries Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Spatial.RTree.defaultMaxNodeEntries"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const int defaultMaxNodeEntries = 200
Public Const defaultMaxNodeEntries As Integer = 200
public:
literal int defaultMaxNodeEntries = 200
static val mutable defaultMaxNodeEntries: int

Field Value

Type: Int32
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


RTree.defaultMinNodeEntries Field

RTreedefaultMinNodeEntries Field

[Missing <summary> documentation for "F:VelocityDBExtensions.Spatial.RTree.defaultMinNodeEntries"]

Namespace: VelocityDBExtensions.Spatial
Assembly: VelocityDBExtensions (in VelocityDBExtensions.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public const int defaultMinNodeEntries = 80
Public Const defaultMinNodeEntries As Integer = 80
public:
literal int defaultMinNodeEntries = 80
static val mutable defaultMinNodeEntries: int

Field Value

Type: Int32
See Also

Reference

RTree Class
VelocityDBExtensions.Spatial Namespace


VelocityDBExtensions2 Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions2"]

Classes
 | Class | Description
Public class | AzureSession |


AzureSession Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AzureSession"]

Inheritance Hierarchy
SystemObject
VelocityDb.SessionSessionBase
VelocityDb.SessionSessionNoServer
VelocityDBExtensions2AzureSession

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class AzureSession : SessionNoServer
Public Class AzureSession
    Inherits SessionNoServer
public ref class AzureSession : public SessionNoServer
type AzureSession =
    class
        inherit SessionNoServer
    end

The AzureSession type exposes the following members.

Constructors
 | Name | Description
Public method | AzureSession | Initializes a new instance of the AzureSession class
Top
Methods
 | Name | Description
Public method | ContainsDatabase | (Overrides SessionBaseContainsDatabase(DatabaseLocation, UInt32, String).)
Public method | CreateDirectory | (Overrides SessionBaseCreateDirectory(String).)
Public method | DatabaseStillExist | (Overrides SessionBaseDatabaseStillExist(Database).)
Public method | DeleteFile | (Overrides SessionBaseDeleteFile(FileInfo).)
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | (Overrides SessionBaseFileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean).)
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | (Overrides SessionBaseFileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean).)
Public method | OpenAllDatabases | (Overrides SessionBaseOpenAllDatabases(Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

VelocityDBExtensions2 Namespace


AzureSession Constructor

Initializes a new instance of the AzureSession class

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AzureSession(
    string connectionString,
    string shareName,
    string systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enableCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum.Yes
)
Public Sub New (
    connectionString As String,
    shareName As String,
    systemDir As String,
    Optional waitForLockMilliseconds As Integer = 5000,
    Optional optimisticLocking As Boolean = true,
    Optional enableCache As Boolean = true,
    Optional objectCachingDefaultPolicy As CacheEnum = CacheEnum.Yes
)
public:
AzureSession(
    String^ connectionString,
    String^ shareName,
    String^ systemDir,
    int waitForLockMilliseconds = 5000,
    bool optimisticLocking = true,
    bool enableCache = true,
    CacheEnum objectCachingDefaultPolicy = CacheEnum::Yes
)
new :
        connectionString : string *
        shareName : string *
        systemDir : string *
        ?waitForLockMilliseconds : int *
        ?optimisticLocking : bool *
        ?enableCache : bool *
        ?objectCachingDefaultPolicy : CacheEnum
(* Defaults:
        let _waitForLockMilliseconds = defaultArg waitForLockMilliseconds 5000
        let _optimisticLocking = defaultArg optimisticLocking true
        let _enableCache = defaultArg enableCache true
        let _objectCachingDefaultPolicy = defaultArg objectCachingDefaultPolicy CacheEnum.Yes
*)
-> AzureSession

Parameters

connectionString
Type: SystemString

[Missing <param name="connectionString"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

shareName
Type: SystemString

[Missing <param name="shareName"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

systemDir
Type: SystemString

[Missing <param name="systemDir"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

waitForLockMilliseconds (Optional)
Type: SystemInt32

[Missing <param name="waitForLockMilliseconds"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

optimisticLocking (Optional)
Type: SystemBoolean

[Missing <param name="optimisticLocking"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

enableCache (Optional)
Type: SystemBoolean

[Missing <param name="enableCache"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

objectCachingDefaultPolicy (Optional)
Type: VelocityDbCacheEnum

[Missing <param name="objectCachingDefaultPolicy"/> documentation for "M:VelocityDBExtensions2.AzureSession.#ctor(System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean,VelocityDb.CacheEnum)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession Methods

The AzureSession type exposes the following members.

Methods
 | Name | Description
Public method | ContainsDatabase | (Overrides SessionBaseContainsDatabase(DatabaseLocation, UInt32, String).)
Public method | CreateDirectory | (Overrides SessionBaseCreateDirectory(String).)
Public method | DatabaseStillExist | (Overrides SessionBaseDatabaseStillExist(Database).)
Public method | DeleteFile | (Overrides SessionBaseDeleteFile(FileInfo).)
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | (Overrides SessionBaseFileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean).)
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | (Overrides SessionBaseFileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean).)
Public method | OpenAllDatabases | (Overrides SessionBaseOpenAllDatabases(Boolean).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ExportToCSV | (Defined by ImportExportCsv.)
Public Extension Method | ExportToJsonT(UInt64) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Oid) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ExportToJsonT(Boolean, Boolean) | Overloaded. (Defined by JsonImportExport.)
Public Extension Method | ImportFromCSV | (Defined by ImportExportCsv.)
Public Extension Method | ImportJsonT | (Defined by JsonImportExport.)
Public Extension Method | MicrosoftSync | (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase) | Overloaded. (Defined by Sync.)
Public Extension Method | SyncWith(SessionBase, FuncSessionBase, UInt64, Change, Boolean) | Overloaded. (Defined by Sync.)
Top
See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.ContainsDatabase Method

AzureSessionContainsDatabase Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.ContainsDatabase(VelocityDb.DatabaseLocation,System.UInt32,System.String)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool ContainsDatabase(
    DatabaseLocation location,
    uint dbNum,
    string extension = ".odb"
)
Public Overrides Function ContainsDatabase (
    location As DatabaseLocation,
    dbNum As UInteger,
    Optional extension As String = ".odb"
) As Boolean
public:
virtual bool ContainsDatabase(
    DatabaseLocation^ location,
    unsigned int dbNum,
    String^ extension = L".odb"
) override
abstract ContainsDatabase :
        location : DatabaseLocation *
        dbNum : uint32 *
        ?extension : string
(* Defaults:
        let _extension = defaultArg extension ".odb"
*)
-> bool
override ContainsDatabase :
        location : DatabaseLocation *
        dbNum : uint32 *
        ?extension : string
(* Defaults:
        let _extension = defaultArg extension ".odb"
*)
-> bool

Parameters

location
Type: VelocityDbDatabaseLocation

[Missing <param name="location"/> documentation for "M:VelocityDBExtensions2.AzureSession.ContainsDatabase(VelocityDb.DatabaseLocation,System.UInt32,System.String)"]

dbNum
Type: SystemUInt32

[Missing <param name="dbNum"/> documentation for "M:VelocityDBExtensions2.AzureSession.ContainsDatabase(VelocityDb.DatabaseLocation,System.UInt32,System.String)"]

extension (Optional)
Type: SystemString

[Missing <param name="extension"/> documentation for "M:VelocityDBExtensions2.AzureSession.ContainsDatabase(VelocityDb.DatabaseLocation,System.UInt32,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.ContainsDatabase(VelocityDb.DatabaseLocation,System.UInt32,System.String)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.CreateDirectory Method

AzureSessionCreateDirectory Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.CreateDirectory(System.String)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool CreateDirectory(
    string path
)
Public Overrides Function CreateDirectory (
    path As String
) As Boolean
public:
virtual bool CreateDirectory(
    String^ path
) override
abstract CreateDirectory :
        path : string -> bool
override CreateDirectory :
        path : string -> bool

Parameters

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:VelocityDBExtensions2.AzureSession.CreateDirectory(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.CreateDirectory(System.String)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.DatabaseStillExist Method

AzureSessionDatabaseStillExist Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.DatabaseStillExist(VelocityDb.Database)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool DatabaseStillExist(
    Database db
)
Public Overrides Function DatabaseStillExist (
    db As Database
) As Boolean
public:
virtual bool DatabaseStillExist(
    Database^ db
) override
abstract DatabaseStillExist :
        db : Database -> bool
override DatabaseStillExist :
        db : Database -> bool

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDBExtensions2.AzureSession.DatabaseStillExist(VelocityDb.Database)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.DatabaseStillExist(VelocityDb.Database)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.DeleteFile Method

AzureSessionDeleteFile Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.DeleteFile(System.IO.FileInfo)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void DeleteFile(
    FileInfo fileInfo
)
Public Overrides Sub DeleteFile (
    fileInfo As FileInfo
)
public:
virtual void DeleteFile(
    FileInfo^ fileInfo
) override
abstract DeleteFile :
        fileInfo : FileInfo -> unit
override DeleteFile :
        fileInfo : FileInfo -> unit

Parameters

fileInfo
Type: System.IOFileInfo

[Missing <param name="fileInfo"/> documentation for "M:VelocityDBExtensions2.AzureSession.DeleteFile(System.IO.FileInfo)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.FileOpen Method

AzureSessionFileOpen Method

Overload List
 | Name | Description
Public method | FileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean) | (Overrides SessionBaseFileOpen(Database, FileAccess, String, FileMode, Boolean, Int32, Boolean).)
Public method | FileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean) | (Overrides SessionBaseFileOpen(FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean).)
Top
See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


AzureSession.FileOpen Method (Database, FileAccess, String, FileMode, Boolean, Int32, Boolean)

AzureSessionFileOpen Method (Database, FileAccess, String, FileMode, Boolean, Int32, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Stream FileOpen(
    Database db,
    FileAccess fileAccess,
    ref string errorMessage,
    FileMode fileMode = FileMode.Open,
    bool excusiveAccess = false,
    int waitOverride = -1,
    bool signalError = true
)
Public Overrides Function FileOpen (
    db As Database,
    fileAccess As FileAccess,
    ByRef errorMessage As String,
    Optional fileMode As FileMode = FileMode.Open,
    Optional excusiveAccess As Boolean = false,
    Optional waitOverride As Integer = -1,
    Optional signalError As Boolean = true
) As Stream
public:
virtual Stream^ FileOpen(
    Database^ db,
    FileAccess fileAccess,
    String^% errorMessage,
    FileMode fileMode = FileMode::Open,
    bool excusiveAccess = false,
    int waitOverride = -1,
    bool signalError = true
) override
abstract FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride -1
        let _signalError = defaultArg signalError true
*)
-> Stream
override FileOpen :
        db : Database *
        fileAccess : FileAccess *
        errorMessage : string byref *
        ?fileMode : FileMode *
        ?excusiveAccess : bool *
        ?waitOverride : int *
        ?signalError : bool
(* Defaults:
        let _fileMode = defaultArg fileMode FileMode.Open
        let _excusiveAccess = defaultArg excusiveAccess false
        let _waitOverride = defaultArg waitOverride -1
        let _signalError = defaultArg signalError true
*)
-> Stream

Parameters

db
Type: VelocityDbDatabase

[Missing <param name="db"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

fileAccess
Type: System.IOFileAccess

[Missing <param name="fileAccess"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

errorMessage
Type: SystemString

[Missing <param name="errorMessage"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

fileMode (Optional)
Type: System.IOFileMode

[Missing <param name="fileMode"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

excusiveAccess (Optional)
Type: SystemBoolean

[Missing <param name="excusiveAccess"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

waitOverride (Optional)
Type: SystemInt32

[Missing <param name="waitOverride"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

signalError (Optional)
Type: SystemBoolean

[Missing <param name="signalError"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

Return Value

Type: Stream

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(VelocityDb.Database,System.IO.FileAccess,System.String@,System.IO.FileMode,System.Boolean,System.Int32,System.Boolean)"]

See Also

Reference

AzureSession Class
FileOpen Overload
VelocityDBExtensions2 Namespace


AzureSession.FileOpen Method (FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean)

AzureSessionFileOpen Method (FileInfo, FileAccess, String, FileShare, FileMode, Int32, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Stream FileOpen(
    FileInfo fileInfo,
    FileAccess fileAccess,
    ref string errorMessage,
    FileShare fileShare,
    FileMode fileMode,
    int waitForLockMilliseconds,
    bool useExternalStorage,
    bool signalError = true
)
Public Overrides Function FileOpen (
    fileInfo As FileInfo,
    fileAccess As FileAccess,
    ByRef errorMessage As String,
    fileShare As FileShare,
    fileMode As FileMode,
    waitForLockMilliseconds As Integer,
    useExternalStorage As Boolean,
    Optional signalError As Boolean = true
) As Stream
public:
virtual Stream^ FileOpen(
    FileInfo^ fileInfo,
    FileAccess fileAccess,
    String^% errorMessage,
    FileShare fileShare,
    FileMode fileMode,
    int waitForLockMilliseconds,
    bool useExternalStorage,
    bool signalError = true
) override
abstract FileOpen :
        fileInfo : FileInfo *
        fileAccess : FileAccess *
        errorMessage : string byref *
        fileShare : FileShare *
        fileMode : FileMode *
        waitForLockMilliseconds : int *
        useExternalStorage : bool *
        ?signalError : bool
(* Defaults:
        let _signalError = defaultArg signalError true
*)
-> Stream
override FileOpen :
        fileInfo : FileInfo *
        fileAccess : FileAccess *
        errorMessage : string byref *
        fileShare : FileShare *
        fileMode : FileMode *
        waitForLockMilliseconds : int *
        useExternalStorage : bool *
        ?signalError : bool
(* Defaults:
        let _signalError = defaultArg signalError true
*)
-> Stream

Parameters

fileInfo
Type: System.IOFileInfo

[Missing <param name="fileInfo"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

fileAccess
Type: System.IOFileAccess

[Missing <param name="fileAccess"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

errorMessage
Type: SystemString

[Missing <param name="errorMessage"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

fileShare
Type: System.IOFileShare

[Missing <param name="fileShare"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

fileMode
Type: System.IOFileMode

[Missing <param name="fileMode"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

waitForLockMilliseconds
Type: SystemInt32

[Missing <param name="waitForLockMilliseconds"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

useExternalStorage
Type: SystemBoolean

[Missing <param name="useExternalStorage"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

signalError (Optional)
Type: SystemBoolean

[Missing <param name="signalError"/> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

Return Value

Type: Stream

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.FileOpen(System.IO.FileInfo,System.IO.FileAccess,System.String@,System.IO.FileShare,System.IO.FileMode,System.Int32,System.Boolean,System.Boolean)"]

See Also

Reference

AzureSession Class
FileOpen Overload
VelocityDBExtensions2 Namespace


AzureSession.OpenAllDatabases Method

AzureSessionOpenAllDatabases Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AzureSession.OpenAllDatabases(System.Boolean)"]

Namespace: VelocityDBExtensions2
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override List<Database> OpenAllDatabases(
    bool update = false
)
Public Overrides Function OpenAllDatabases (
    Optional update As Boolean = false
) As List(Of Database)
public:
virtual List<Database^>^ OpenAllDatabases(
    bool update = false
) override
abstract OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>
override OpenAllDatabases :
        ?update : bool
(* Defaults:
        let _update = defaultArg update false
*)
-> List<Database>

Parameters

update (Optional)
Type: SystemBoolean

[Missing <param name="update"/> documentation for "M:VelocityDBExtensions2.AzureSession.OpenAllDatabases(System.Boolean)"]

Return Value

Type: List Database

[Missing <returns> documentation for "M:VelocityDBExtensions2.AzureSession.OpenAllDatabases(System.Boolean)"]

See Also

Reference

AzureSession Class
VelocityDBExtensions2 Namespace


VelocityDBExtensions2.AspNet.Identity Namespace

[Missing <summary> documentation for "N:VelocityDBExtensions2.AspNet.Identity"]

Classes
 | Class | Description
Public class | AspNetIdentity |
Public class | IdentityRole |
Public class | IdentityUser |
Public class | KeyFormats |
Public class | RoleStoreT |
Public class | UserLoginInfoAdapter |
Public class | UserStoreT |


AspNetIdentity Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions2.AspNet.IdentityAspNetIdentity

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class AspNetIdentity : OptimizedPersistable
Public Class AspNetIdentity
    Inherits OptimizedPersistable
public ref class AspNetIdentity : public OptimizedPersistable
type AspNetIdentity =
    class
        inherit OptimizedPersistable
    end

The AspNetIdentity type exposes the following members.

Constructors
 | Name | Description
Public method | AspNetIdentity | Initializes a new instance of the AspNetIdentity class
Top
Properties
 | Name | Description
Public property | AdapterMap |
Public property | EmailToId |
Public property | Name |
Public property | RoleSet |
Public property | UserNameToId |
Public property | UserSet |
Top
Methods
 | Name | Description
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity Constructor

Initializes a new instance of the AspNetIdentity class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public AspNetIdentity(
    SessionBase session
)
Public Sub New (
    session As SessionBase
)
public:
AspNetIdentity(
    SessionBase^ session
)
new :
        session : SessionBase -> AspNetIdentity

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.#ctor(VelocityDb.Session.SessionBase)"]

See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity Properties

The AspNetIdentity type exposes the following members.

Properties
 | Name | Description
Public property | AdapterMap |
Public property | EmailToId |
Public property | Name |
Public property | RoleSet |
Public property | UserNameToId |
Public property | UserSet |
Top
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.AdapterMap Property

AspNetIdentityAdapterMap Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.AdapterMap"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMap<string, UserLoginInfoAdapter> AdapterMap { get; }
Public ReadOnly Property AdapterMap As BTreeMap(Of String, UserLoginInfoAdapter)
    Get
public:
property BTreeMap<String^, UserLoginInfoAdapter^>^ AdapterMap {
    BTreeMap<String^, UserLoginInfoAdapter^>^ get ();
}
member AdapterMap : BTreeMap<string, UserLoginInfoAdapter> with get

Property Value

Type: BTreeMap String, UserLoginInfoAdapter
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.EmailToId Property

AspNetIdentityEmailToId Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.EmailToId"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMap<string, ulong> EmailToId { get; }
Public ReadOnly Property EmailToId As BTreeMap(Of String, ULong)
    Get
public:
property BTreeMap<String^, unsigned long long>^ EmailToId {
    BTreeMap<String^, unsigned long long>^ get ();
}
member EmailToId : BTreeMap<string, uint64> with get

Property Value

Type: BTreeMap String, UInt64
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.Name Property

AspNetIdentityName Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Name"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.RoleSet Property

AspNetIdentityRoleSet Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.RoleSet"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<IdentityRole> RoleSet { get; }
Public ReadOnly Property RoleSet As BTreeSet(Of IdentityRole)
    Get
public:
property BTreeSet<IdentityRole^>^ RoleSet {
    BTreeSet<IdentityRole^>^ get ();
}
member RoleSet : BTreeSet<IdentityRole> with get

Property Value

Type: BTreeSet IdentityRole
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.UserNameToId Property

AspNetIdentityUserNameToId Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.UserNameToId"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeMap<string, ulong> UserNameToId { get; }
Public ReadOnly Property UserNameToId As BTreeMap(Of String, ULong)
    Get
public:
property BTreeMap<String^, unsigned long long>^ UserNameToId {
    BTreeMap<String^, unsigned long long>^ get ();
}
member UserNameToId : BTreeMap<string, uint64> with get

Property Value

Type: BTreeMap String, UInt64
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.UserSet Property

AspNetIdentityUserSet Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.UserSet"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<IdentityUser> UserSet { get; }
Public ReadOnly Property UserSet As BTreeSet(Of IdentityUser)
    Get
public:
property BTreeSet<IdentityUser^>^ UserSet {
    BTreeSet<IdentityUser^>^ get ();
}
member UserSet : BTreeSet<IdentityUser> with get

Property Value

Type: BTreeSet IdentityUser
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity Methods

The AspNetIdentity type exposes the following members.

Methods
 | Name | Description
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


AspNetIdentity.Persist Method

AspNetIdentityPersist Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement

[Missing <param name="place"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

persistRefs (Optional)
Type: SystemBoolean

[Missing <param name="persistRefs"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

disableFlush (Optional)
Type: SystemBoolean

[Missing <param name="disableFlush"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable

[Missing <param name="toPersist"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.AspNetIdentity.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

AspNetIdentity Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.IdentityRole"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions2.AspNet.IdentityIdentityRole

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class IdentityRole : OptimizedPersistable,
    IRole<ulong>
Public Class IdentityRole
    Inherits OptimizedPersistable
    Implements IRole(Of ULong)
public ref class IdentityRole : public OptimizedPersistable,
    IRole<unsigned long long>
type IdentityRole =
    class
        inherit OptimizedPersistable
        interface IRole<uint64>
    end

The IdentityRole type exposes the following members.

Constructors
 | Name | Description
Public method | IdentityRole | Initializes a new instance of the IdentityRole class
Public method | IdentityRole(String) | Initializes a new instance of the IdentityRole class
Top
Properties
 | Name | Description
Public property | Name |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Constructor

Overload List
 | Name | Description
Public method | IdentityRole | Initializes a new instance of the IdentityRole class
Public method | IdentityRole(String) | Initializes a new instance of the IdentityRole class
Top
See Also

Reference

IdentityRole Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Constructor

Initializes a new instance of the IdentityRole class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IdentityRole()
Public Sub New
public:
IdentityRole()
new : unit -> IdentityRole
See Also

Reference

IdentityRole Class
IdentityRole Overload
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Constructor (String)

Initializes a new instance of the IdentityRole class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IdentityRole(
    string name
)
Public Sub New (
    name As String
)
public:
IdentityRole(
    String^ name
)
new :
        name : string -> IdentityRole

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.IdentityRole.#ctor(System.String)"]

See Also

Reference

IdentityRole Class
IdentityRole Overload
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Properties

The IdentityRole type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IdentityRole Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole.Name Property

IdentityRoleName Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityRole.Name"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IRole.Name
See Also

Reference

IdentityRole Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityRole Methods

The IdentityRole type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

IdentityRole Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.IdentityUser"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions2.AspNet.IdentityIdentityUser

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class IdentityUser : OptimizedPersistable,
    IUser<ulong>
Public Class IdentityUser
    Inherits OptimizedPersistable
    Implements IUser(Of ULong)
public ref class IdentityUser : public OptimizedPersistable,
    IUser<unsigned long long>
type IdentityUser =
    class
        inherit OptimizedPersistable
        interface IUser<uint64>
    end

The IdentityUser type exposes the following members.

Constructors
 | Name | Description
Public method | IdentityUser | Initializes a new instance of the IdentityUser class
Public method | IdentityUser(String) | Initializes a new instance of the IdentityUser class
Top
Properties
 | Name | Description
Public property | AccessFailedCount |
Public property | Claims |
Public property | Email |
Public property | EmailConfirmed |
Public property | LockoutEnabled |
Public property | LockoutEndDateUtc |
Public property | PasswordHash |
Public property | PhoneNumber |
Public property | PhoneNumberConfirmed |
Public property | Roles |
Public property | SecurityStamp |
Public property | TwoFactorEnabled |
Public property | UserLoginIds |
Public property | UserName |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Constructor

Overload List
 | Name | Description
Public method | IdentityUser | Initializes a new instance of the IdentityUser class
Public method | IdentityUser(String) | Initializes a new instance of the IdentityUser class
Top
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Constructor

Initializes a new instance of the IdentityUser class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IdentityUser()
Public Sub New
public:
IdentityUser()
new : unit -> IdentityUser
See Also

Reference

IdentityUser Class
IdentityUser Overload
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Constructor (String)

Initializes a new instance of the IdentityUser class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IdentityUser(
    string username
)
Public Sub New (
    username As String
)
public:
IdentityUser(
    String^ username
)
new :
        username : string -> IdentityUser

Parameters

username
Type: SystemString

[Missing <param name="username"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.IdentityUser.#ctor(System.String)"]

See Also

Reference

IdentityUser Class
IdentityUser Overload
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Properties

The IdentityUser type exposes the following members.

Properties
 | Name | Description
Public property | AccessFailedCount |
Public property | Claims |
Public property | Email |
Public property | EmailConfirmed |
Public property | LockoutEnabled |
Public property | LockoutEndDateUtc |
Public property | PasswordHash |
Public property | PhoneNumber |
Public property | PhoneNumberConfirmed |
Public property | Roles |
Public property | SecurityStamp |
Public property | TwoFactorEnabled |
Public property | UserLoginIds |
Public property | UserName |
Top
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.AccessFailedCount Property

IdentityUserAccessFailedCount Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.AccessFailedCount"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int AccessFailedCount { get; set; }
Public Property AccessFailedCount As Integer
    Get
    Set
public:
property int AccessFailedCount {
    int get ();
    void set (int value);
}
member AccessFailedCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.Claims Property

IdentityUserClaims Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.Claims"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ICollection<Claim> Claims { get; set; }
Public Property Claims As ICollection(Of Claim)
    Get
    Set
public:
property ICollection<Claim^>^ Claims {
    ICollection<Claim^>^ get ();
    void set (ICollection<Claim^>^ value);
}
member Claims : ICollection<Claim> with get, set

Property Value

Type: ICollection Claim
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.Email Property

IdentityUserEmail Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.Email"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Property Value

Type: String
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.EmailConfirmed Property

IdentityUserEmailConfirmed Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.EmailConfirmed"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool EmailConfirmed { get; set; }
Public Property EmailConfirmed As Boolean
    Get
    Set
public:
property bool EmailConfirmed {
    bool get ();
    void set (bool value);
}
member EmailConfirmed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.LockoutEnabled Property

IdentityUserLockoutEnabled Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.LockoutEnabled"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool LockoutEnabled { get; set; }
Public Property LockoutEnabled As Boolean
    Get
    Set
public:
property bool LockoutEnabled {
    bool get ();
    void set (bool value);
}
member LockoutEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.LockoutEndDateUtc Property

IdentityUserLockoutEndDateUtc Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.LockoutEndDateUtc"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LockoutEndDateUtc { get; set; }
Public Property LockoutEndDateUtc As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LockoutEndDateUtc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LockoutEndDateUtc : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.PasswordHash Property

IdentityUserPasswordHash Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.PasswordHash"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string PasswordHash { get; set; }
Public Property PasswordHash As String
    Get
    Set
public:
property String^ PasswordHash {
    String^ get ();
    void set (String^ value);
}
member PasswordHash : string with get, set

Property Value

Type: String
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.PhoneNumber Property

IdentityUserPhoneNumber Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.PhoneNumber"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string PhoneNumber { get; set; }
Public Property PhoneNumber As String
    Get
    Set
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
member PhoneNumber : string with get, set

Property Value

Type: String
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.PhoneNumberConfirmed Property

IdentityUserPhoneNumberConfirmed Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.PhoneNumberConfirmed"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool PhoneNumberConfirmed { get; set; }
Public Property PhoneNumberConfirmed As Boolean
    Get
    Set
public:
property bool PhoneNumberConfirmed {
    bool get ();
    void set (bool value);
}
member PhoneNumberConfirmed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.Roles Property

IdentityUserRoles Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.Roles"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ICollection<IdentityRole> Roles { get; set; }
Public Property Roles As ICollection(Of IdentityRole)
    Get
    Set
public:
property ICollection<IdentityRole^>^ Roles {
    ICollection<IdentityRole^>^ get ();
    void set (ICollection<IdentityRole^>^ value);
}
member Roles : ICollection<IdentityRole> with get, set

Property Value

Type: ICollection IdentityRole
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.SecurityStamp Property

IdentityUserSecurityStamp Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.SecurityStamp"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SecurityStamp { get; set; }
Public Property SecurityStamp As String
    Get
    Set
public:
property String^ SecurityStamp {
    String^ get ();
    void set (String^ value);
}
member SecurityStamp : string with get, set

Property Value

Type: String
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.TwoFactorEnabled Property

IdentityUserTwoFactorEnabled Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.TwoFactorEnabled"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool TwoFactorEnabled { get; set; }
Public Property TwoFactorEnabled As Boolean
    Get
    Set
public:
property bool TwoFactorEnabled {
    bool get ();
    void set (bool value);
}
member TwoFactorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.UserLoginIds Property

IdentityUserUserLoginIds Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.UserLoginIds"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IList<UserLoginInfo> UserLoginIds { get; set; }
Public Property UserLoginIds As IList(Of UserLoginInfo)
    Get
    Set
public:
property IList<UserLoginInfo^>^ UserLoginIds {
    IList<UserLoginInfo^>^ get ();
    void set (IList<UserLoginInfo^>^ value);
}
member UserLoginIds : IList<UserLoginInfo> with get, set

Property Value

Type: IList UserLoginInfo
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser.UserName Property

IdentityUserUserName Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.IdentityUser.UserName"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

IUser.UserName
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


IdentityUser Methods

The IdentityUser type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

IdentityUser Class
VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.KeyFormats"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions2.AspNet.IdentityKeyFormats

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static class KeyFormats
Public NotInheritable Class KeyFormats
public ref class KeyFormats abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeyFormats =  class end

The KeyFormats type exposes the following members.

Methods
Name | Description
GetKey |
Top
Fields
Name | Description
LoginFormat |
UserFormat |
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats Methods

The KeyFormats type exposes the following members.

Methods
Name | Description
GetKey |
Top
See Also

Reference

KeyFormats Class
VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats.GetKey Method

KeyFormatsGetKey Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.KeyFormats.GetKey(System.Object,System.Object)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string GetKey(
    Object loginKey,
    Object userKey
)
Public Shared Function GetKey (
    loginKey As Object,
    userKey As Object
) As String
public:
static String^ GetKey(
    Object^ loginKey,
    Object^ userKey
)
static member GetKey :
        loginKey : Object *
        userKey : Object -> string

Parameters

loginKey
Type: SystemObject

[Missing <param name="loginKey"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.KeyFormats.GetKey(System.Object,System.Object)"]

userKey
Type: SystemObject

[Missing <param name="userKey"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.KeyFormats.GetKey(System.Object,System.Object)"]

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.KeyFormats.GetKey(System.Object,System.Object)"]

See Also

Reference

KeyFormats Class
VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats Fields

The KeyFormats type exposes the following members.

Fields
Name | Description
LoginFormat |
UserFormat |
Top
See Also

Reference

KeyFormats Class
VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats.LoginFormat Field

KeyFormatsLoginFormat Field

[Missing <summary> documentation for "F:VelocityDBExtensions2.AspNet.Identity.KeyFormats.LoginFormat"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string LoginFormat
Public Shared LoginFormat As String
public:
static String^ LoginFormat
static val mutable LoginFormat: string

Field Value

Type: String
See Also

Reference

KeyFormats Class
VelocityDBExtensions2.AspNet.Identity Namespace


KeyFormats.UserFormat Field

KeyFormatsUserFormat Field

[Missing <summary> documentation for "F:VelocityDBExtensions2.AspNet.Identity.KeyFormats.UserFormat"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static string UserFormat
Public Shared UserFormat As String
public:
static String^ UserFormat
static val mutable UserFormat: string

Field Value

Type: String
See Also

Reference

KeyFormats Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T) Class

RoleStoreT Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.RoleStore`1"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions2.AspNet.IdentityRoleStoreT

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class RoleStore<T> : IQueryableRoleStore<T, ulong>,
    IRoleStore<T, ulong>, IDisposable
where T : IdentityRole

Public Class RoleStore(Of T As IdentityRole)
    Implements IQueryableRoleStore(Of T, ULong), IRoleStore(Of T, ULong),
    IDisposable
generic<typename T>
where T : IdentityRole
public ref class RoleStore : IQueryableRoleStore<T, unsigned long long>,
    IRoleStore<T, unsigned long long>, IDisposable
type RoleStore<'T when 'T : IdentityRole> =
    class
        interface IQueryableRoleStore<'T, uint64>
        interface IRoleStore<'T, uint64>
        interface IDisposable
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:VelocityDBExtensions2.AspNet.Identity.RoleStore`1"]

The RoleStoreT type exposes the following members.

Constructors
 | Name | Description
Public method | RoleStoreT | Initializes a new instance of the RoleStoreT class
Top
Properties
 | Name | Description
Public property | Roles |
Top
Methods
 | Name | Description
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | Dispose | Releases all resources used by the RoleStoreT
Public method | FindByIdAsync |
Public method | FindByNameAsync |
Public method | UpdateAsync |
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T) Constructor

RoleStoreT Constructor

Initializes a new instance of the RoleStoreT class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public RoleStore(
    AspNetIdentity identity
)
Public Sub New (
    identity As AspNetIdentity
)
public:
RoleStore(
    AspNetIdentity^ identity
)
new :
        identity : AspNetIdentity -> RoleStore

Parameters

identity
Type: VelocityDBExtensions2.AspNet.IdentityAspNetIdentity

[Missing <param name="identity"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.#ctor(VelocityDBExtensions2.AspNet.Identity.AspNetIdentity)"]

See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T) Properties

RoleStoreT Properties

The RoleStoreT generic type exposes the following members.

Properties
 | Name | Description
Public property | Roles |
Top
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).Roles Property

RoleStoreTRoles Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.Roles"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IQueryable<T> Roles { get; }
Public ReadOnly Property Roles As IQueryable(Of T)
    Get
public:
virtual property IQueryable<T>^ Roles {
    IQueryable<T>^ get () sealed;
}
abstract Roles : IQueryable<'T> with get
override Roles : IQueryable<'T> with get

Property Value

Type: IQueryable T

Implements

IQueryableRoleStore.Roles
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T) Methods

RoleStoreT Methods

The RoleStoreT generic type exposes the following members.

Methods
 | Name | Description
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | Dispose |
Public method | FindByIdAsync |
Public method | FindByNameAsync |
Public method | UpdateAsync |
Top
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).CreateAsync Method

RoleStoreTCreateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.CreateAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task CreateAsync(
    T role
)
Public Function CreateAsync (
    role As T
) As Task
public:
virtual Task^ CreateAsync(
    T role
) sealed
abstract CreateAsync :
        role : 'T -> Task
override CreateAsync :
        role : 'T -> Task

Parameters

role
Type: T

[Missing <param name="role"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.CreateAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.CreateAsync(`0)"]

Implements

IRoleStore.CreateAsync(UTP)
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).DeleteAsync Method

RoleStoreTDeleteAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.DeleteAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task DeleteAsync(
    T role
)
Public Function DeleteAsync (
    role As T
) As Task
public:
virtual Task^ DeleteAsync(
    T role
) sealed
abstract DeleteAsync :
        role : 'T -> Task
override DeleteAsync :
        role : 'T -> Task

Parameters

role
Type: T

[Missing <param name="role"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.DeleteAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.DeleteAsync(`0)"]

Implements

IRoleStore.DeleteAsync(UTP)
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).Dispose Method

RoleStoreTDispose Method

Releases all resources used by the RoleStoreT

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).FindByIdAsync Method

RoleStoreTFindByIdAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByIdAsync(System.UInt64)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindByIdAsync(
    ulong roleId
)
Public Function FindByIdAsync (
    roleId As ULong
) As Task(Of T)
public:
virtual Task<T>^ FindByIdAsync(
    unsigned long long roleId
) sealed
abstract FindByIdAsync :
        roleId : uint64 -> Task<'T>
override FindByIdAsync :
        roleId : uint64 -> Task<'T>

Parameters

roleId
Type: SystemUInt64

[Missing <param name="roleId"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByIdAsync(System.UInt64)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByIdAsync(System.UInt64)"]

Implements

IRoleStore.FindByIdAsync(UTP)
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).FindByNameAsync Method

RoleStoreTFindByNameAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByNameAsync(System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindByNameAsync(
    string roleName
)
Public Function FindByNameAsync (
    roleName As String
) As Task(Of T)
public:
virtual Task<T>^ FindByNameAsync(
    String^ roleName
) sealed
abstract FindByNameAsync :
        roleName : string -> Task<'T>
override FindByNameAsync :
        roleName : string -> Task<'T>

Parameters

roleName
Type: SystemString

[Missing <param name="roleName"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByNameAsync(System.String)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.FindByNameAsync(System.String)"]

Implements

IRoleStore.FindByNameAsync(String)
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


RoleStore(T).UpdateAsync Method

RoleStoreTUpdateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.UpdateAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task UpdateAsync(
    T role
)
Public Function UpdateAsync (
    role As T
) As Task
public:
virtual Task^ UpdateAsync(
    T role
) sealed
abstract UpdateAsync :
        role : 'T -> Task
override UpdateAsync :
        role : 'T -> Task

Parameters

role
Type: T

[Missing <param name="role"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.UpdateAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.RoleStore`1.UpdateAsync(`0)"]

Implements

IRoleStore.UpdateAsync(UTP)
See Also

Reference

RoleStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.UserLoginInfoAdapter"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityDBExtensions2.AspNet.IdentityUserLoginInfoAdapter

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class UserLoginInfoAdapter : OptimizedPersistable
Public Class UserLoginInfoAdapter
    Inherits OptimizedPersistable
public ref class UserLoginInfoAdapter : public OptimizedPersistable
type UserLoginInfoAdapter =
    class
        inherit OptimizedPersistable
    end

The UserLoginInfoAdapter type exposes the following members.

Constructors
 | Name | Description
Public method | UserLoginInfoAdapter | Initializes a new instance of the UserLoginInfoAdapter class
Top
Properties
 | Name | Description
Public property | LoginInfo |
Public property | UserId |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter Constructor

Initializes a new instance of the UserLoginInfoAdapter class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UserLoginInfoAdapter()
Public Sub New
public:
UserLoginInfoAdapter()
new : unit -> UserLoginInfoAdapter
See Also

Reference

UserLoginInfoAdapter Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter Properties

The UserLoginInfoAdapter type exposes the following members.

Properties
 | Name | Description
Public property | LoginInfo |
Public property | UserId |
Top
See Also

Reference

UserLoginInfoAdapter Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter.LoginInfo Property

UserLoginInfoAdapterLoginInfo Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.UserLoginInfoAdapter.LoginInfo"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UserLoginInfo LoginInfo { get; set; }
Public Property LoginInfo As UserLoginInfo
    Get
    Set
public:
property UserLoginInfo^ LoginInfo {
    UserLoginInfo^ get ();
    void set (UserLoginInfo^ value);
}
member LoginInfo : UserLoginInfo with get, set

Property Value

Type: UserLoginInfo
See Also

Reference

UserLoginInfoAdapter Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter.UserId Property

UserLoginInfoAdapterUserId Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.UserLoginInfoAdapter.UserId"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public ulong UserId { get; set; }
Public Property UserId As ULong
    Get
    Set
public:
property unsigned long long UserId {
    unsigned long long get ();
    void set (unsigned long long value);
}
member UserId : uint64 with get, set

Property Value

Type: UInt64
See Also

Reference

UserLoginInfoAdapter Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserLoginInfoAdapter Methods

The UserLoginInfoAdapter type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

UserLoginInfoAdapter Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T) Class

UserStoreT Class

[Missing <summary> documentation for "T:VelocityDBExtensions2.AspNet.Identity.UserStore`1"]

Inheritance Hierarchy
SystemObject
VelocityDBExtensions2.AspNet.IdentityUserStoreT

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class UserStore<T> : IUserLoginStore<T, ulong>,
    IUserStore<T, ulong>, IDisposable, IUserClaimStore<T, ulong>,
    IUserRoleStore<T, ulong>, IUserSecurityStampStore<T, ulong>, IQueryableUserStore<T, ulong>,
    IUserPasswordStore<T, ulong>, IUserPhoneNumberStore<T, ulong>, IUserLockoutStore<T, ulong>,
    IUserTwoFactorStore<T, ulong>, IUserEmailStore<T, ulong>
where T : IdentityUser

Public Class UserStore(Of T As IdentityUser)
    Implements IUserLoginStore(Of T, ULong), IUserStore(Of T, ULong),
    IDisposable, IUserClaimStore(Of T, ULong), IUserRoleStore(Of T, ULong),
    IUserSecurityStampStore(Of T, ULong), IQueryableUserStore(Of T, ULong),
    IUserPasswordStore(Of T, ULong), IUserPhoneNumberStore(Of T, ULong),
    IUserLockoutStore(Of T, ULong), IUserTwoFactorStore(Of T, ULong),
    IUserEmailStore(Of T, ULong)
generic<typename T>
where T : IdentityUser
public ref class UserStore : IUserLoginStore<T, unsigned long long>,
    IUserStore<T, unsigned long long>, IDisposable,
    IUserClaimStore<T, unsigned long long>, IUserRoleStore<T, unsigned long long>,
    IUserSecurityStampStore<T, unsigned long long>, IQueryableUserStore<T, unsigned long long>,
    IUserPasswordStore<T, unsigned long long>, IUserPhoneNumberStore<T, unsigned long long>,
    IUserLockoutStore<T, unsigned long long>, IUserTwoFactorStore<T, unsigned long long>,
    IUserEmailStore<T, unsigned long long>
type UserStore<'T when 'T : IdentityUser> =
    class
        interface IUserLoginStore<'T, uint64>
        interface IUserStore<'T, uint64>
        interface IDisposable
        interface IUserClaimStore<'T, uint64>
        interface IUserRoleStore<'T, uint64>
        interface IUserSecurityStampStore<'T, uint64>
        interface IQueryableUserStore<'T, uint64>
        interface IUserPasswordStore<'T, uint64>
        interface IUserPhoneNumberStore<'T, uint64>
        interface IUserLockoutStore<'T, uint64>
        interface IUserTwoFactorStore<'T, uint64>
        interface IUserEmailStore<'T, uint64>
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:VelocityDBExtensions2.AspNet.Identity.UserStore`1"]

The UserStoreT type exposes the following members.

Constructors
 | Name | Description
Public method | UserStoreT | Initializes a new instance of the UserStoreT class
Top
Properties
 | Name | Description
Public property | Users |
Top
Methods
 | Name | Description
Public method | AddClaimAsync |
Public method | AddLoginAsync |
Public method | AddToRoleAsync |
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | Dispose | Releases all resources used by the UserStoreT
Public method | FindAsync |
Public method | FindByEmailAsync |
Public method | FindByIdAsync |
Public method | FindByNameAsync |
Public method | GetAccessFailedCountAsync |
Public method | GetClaimsAsync |
Public method | GetEmailAsync |
Public method | GetEmailConfirmedAsync |
Public method | GetLockoutEnabledAsync |
Public method | GetLockoutEndDateAsync |
Public method | GetLoginsAsync |
Public method | GetPasswordHashAsync |
Public method | GetPhoneNumberAsync |
Public method | GetPhoneNumberConfirmedAsync |
Public method | GetRolesAsync |
Public method | GetSecurityStampAsync |
Public method | GetTwoFactorEnabledAsync |
Public method | HasPasswordAsync |
Public method | IncrementAccessFailedCountAsync |
Public method | IsInRoleAsync |
Public method | RemoveClaimAsync |
Public method | RemoveFromRoleAsync |
Public method | RemoveLoginAsync |
Public method | ResetAccessFailedCountAsync |
Public method | SetEmailAsync |
Public method | SetEmailConfirmedAsync |
Public method | SetLockoutEnabledAsync |
Public method | SetLockoutEndDateAsync |
Public method | SetPasswordHashAsync |
Public method | SetPhoneNumberAsync |
Public method | SetPhoneNumberConfirmedAsync |
Public method | SetSecurityStampAsync |
Public method | SetTwoFactorEnabledAsync |
Public method | UpdateAsync |
Top
See Also

Reference

VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T) Constructor

UserStoreT Constructor

Initializes a new instance of the UserStoreT class

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public UserStore(
    AspNetIdentity identity
)
Public Sub New (
    identity As AspNetIdentity
)
public:
UserStore(
    AspNetIdentity^ identity
)
new :
        identity : AspNetIdentity -> UserStore

Parameters

identity
Type: VelocityDBExtensions2.AspNet.IdentityAspNetIdentity

[Missing <param name="identity"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.#ctor(VelocityDBExtensions2.AspNet.Identity.AspNetIdentity)"]

See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T) Properties

UserStoreT Properties

The UserStoreT generic type exposes the following members.

Properties
 | Name | Description
Public property | Users |
Top
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).Users Property

UserStoreTUsers Property

[Missing <summary> documentation for "P:VelocityDBExtensions2.AspNet.Identity.UserStore`1.Users"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IQueryable<T> Users { get; }
Public ReadOnly Property Users As IQueryable(Of T)
    Get
public:
virtual property IQueryable<T>^ Users {
    IQueryable<T>^ get () sealed;
}
abstract Users : IQueryable<'T> with get
override Users : IQueryable<'T> with get

Property Value

Type: IQueryable T

Implements

IQueryableUserStore.Users
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T) Methods

UserStoreT Methods

The UserStoreT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddClaimAsync |
Public method | AddLoginAsync |
Public method | AddToRoleAsync |
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | Dispose |
Public method | FindAsync |
Public method | FindByEmailAsync |
Public method | FindByIdAsync |
Public method | FindByNameAsync |
Public method | GetAccessFailedCountAsync |
Public method | GetClaimsAsync |
Public method | GetEmailAsync |
Public method | GetEmailConfirmedAsync |
Public method | GetLockoutEnabledAsync |
Public method | GetLockoutEndDateAsync |
Public method | GetLoginsAsync |
Public method | GetPasswordHashAsync |
Public method | GetPhoneNumberAsync |
Public method | GetPhoneNumberConfirmedAsync |
Public method | GetRolesAsync |
Public method | GetSecurityStampAsync |
Public method | GetTwoFactorEnabledAsync |
Public method | HasPasswordAsync |
Public method | IncrementAccessFailedCountAsync |
Public method | IsInRoleAsync |
Public method | RemoveClaimAsync |
Public method | RemoveFromRoleAsync |
Public method | RemoveLoginAsync |
Public method | ResetAccessFailedCountAsync |
Public method | SetEmailAsync |
Public method | SetEmailConfirmedAsync |
Public method | SetLockoutEnabledAsync |
Public method | SetLockoutEndDateAsync |
Public method | SetPasswordHashAsync |
Public method | SetPhoneNumberAsync |
Public method | SetPhoneNumberConfirmedAsync |
Public method | SetSecurityStampAsync |
Public method | SetTwoFactorEnabledAsync |
Public method | UpdateAsync |
Top
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).AddClaimAsync Method

UserStoreTAddClaimAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddClaimAsync(`0,System.Security.Claims.Claim)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task AddClaimAsync(
    T user,
    Claim claim
)
Public Function AddClaimAsync (
    user As T,
    claim As Claim
) As Task
public:
virtual Task^ AddClaimAsync(
    T user,
    Claim^ claim
) sealed
abstract AddClaimAsync :
        user : 'T *
        claim : Claim -> Task
override AddClaimAsync :
        user : 'T *
        claim : Claim -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddClaimAsync(`0,System.Security.Claims.Claim)"]

claim
Type: System.Security.ClaimsClaim

[Missing <param name="claim"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddClaimAsync(`0,System.Security.Claims.Claim)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddClaimAsync(`0,System.Security.Claims.Claim)"]

Implements

IUserClaimStore.AddClaimAsync(UTP, Claim)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).AddLoginAsync Method

UserStoreTAddLoginAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task AddLoginAsync(
    T user,
    UserLoginInfo login
)
Public Function AddLoginAsync (
    user As T,
    login As UserLoginInfo
) As Task
public:
virtual Task^ AddLoginAsync(
    T user,
    UserLoginInfo^ login
) sealed
abstract AddLoginAsync :
        user : 'T *
        login : UserLoginInfo -> Task
override AddLoginAsync :
        user : 'T *
        login : UserLoginInfo -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

login
Type: UserLoginInfo

[Missing <param name="login"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Implements

IUserLoginStore.AddLoginAsync(UTP, UserLoginInfo)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).AddToRoleAsync Method

UserStoreTAddToRoleAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddToRoleAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task AddToRoleAsync(
    T user,
    string roleName
)
Public Function AddToRoleAsync (
    user As T,
    roleName As String
) As Task
public:
virtual Task^ AddToRoleAsync(
    T user,
    String^ roleName
) sealed
abstract AddToRoleAsync :
        user : 'T *
        roleName : string -> Task
override AddToRoleAsync :
        user : 'T *
        roleName : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddToRoleAsync(`0,System.String)"]

roleName
Type: SystemString

[Missing <param name="roleName"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddToRoleAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.AddToRoleAsync(`0,System.String)"]

Implements

IUserRoleStore.AddToRoleAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).CreateAsync Method

UserStoreTCreateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.CreateAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task CreateAsync(
    T user
)
Public Function CreateAsync (
    user As T
) As Task
public:
virtual Task^ CreateAsync(
    T user
) sealed
abstract CreateAsync :
        user : 'T -> Task
override CreateAsync :
        user : 'T -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.CreateAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.CreateAsync(`0)"]

Implements

IUserStore.CreateAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).DeleteAsync Method

UserStoreTDeleteAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.DeleteAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task DeleteAsync(
    T user
)
Public Function DeleteAsync (
    user As T
) As Task
public:
virtual Task^ DeleteAsync(
    T user
) sealed
abstract DeleteAsync :
        user : 'T -> Task
override DeleteAsync :
        user : 'T -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.DeleteAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.DeleteAsync(`0)"]

Implements

IUserStore.DeleteAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).Dispose Method

UserStoreTDispose Method

Releases all resources used by the UserStoreT

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).FindAsync Method

UserStoreTFindAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindAsync(Microsoft.AspNet.Identity.UserLoginInfo)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindAsync(
    UserLoginInfo login
)
Public Function FindAsync (
    login As UserLoginInfo
) As Task(Of T)
public:
virtual Task<T>^ FindAsync(
    UserLoginInfo^ login
) sealed
abstract FindAsync :
        login : UserLoginInfo -> Task<'T>
override FindAsync :
        login : UserLoginInfo -> Task<'T>

Parameters

login
Type: UserLoginInfo

[Missing <param name="login"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindAsync(Microsoft.AspNet.Identity.UserLoginInfo)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindAsync(Microsoft.AspNet.Identity.UserLoginInfo)"]

Implements

IUserLoginStore.FindAsync(UserLoginInfo)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).FindByEmailAsync Method

UserStoreTFindByEmailAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByEmailAsync(System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindByEmailAsync(
    string email
)
Public Function FindByEmailAsync (
    email As String
) As Task(Of T)
public:
virtual Task<T>^ FindByEmailAsync(
    String^ email
) sealed
abstract FindByEmailAsync :
        email : string -> Task<'T>
override FindByEmailAsync :
        email : string -> Task<'T>

Parameters

email
Type: SystemString

[Missing <param name="email"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByEmailAsync(System.String)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByEmailAsync(System.String)"]

Implements

IUserEmailStore.FindByEmailAsync(String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).FindByIdAsync Method

UserStoreTFindByIdAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByIdAsync(System.UInt64)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindByIdAsync(
    ulong userId
)
Public Function FindByIdAsync (
    userId As ULong
) As Task(Of T)
public:
virtual Task<T>^ FindByIdAsync(
    unsigned long long userId
) sealed
abstract FindByIdAsync :
        userId : uint64 -> Task<'T>
override FindByIdAsync :
        userId : uint64 -> Task<'T>

Parameters

userId
Type: SystemUInt64

[Missing <param name="userId"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByIdAsync(System.UInt64)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByIdAsync(System.UInt64)"]

Implements

IUserStore.FindByIdAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).FindByNameAsync Method

UserStoreTFindByNameAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByNameAsync(System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<T> FindByNameAsync(
    string userName
)
Public Function FindByNameAsync (
    userName As String
) As Task(Of T)
public:
virtual Task<T>^ FindByNameAsync(
    String^ userName
) sealed
abstract FindByNameAsync :
        userName : string -> Task<'T>
override FindByNameAsync :
        userName : string -> Task<'T>

Parameters

userName
Type: SystemString

[Missing <param name="userName"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByNameAsync(System.String)"]

Return Value

Type: Task T

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.FindByNameAsync(System.String)"]

Implements

IUserStore.FindByNameAsync(String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetAccessFailedCountAsync Method

UserStoreTGetAccessFailedCountAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetAccessFailedCountAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<int> GetAccessFailedCountAsync(
    T user
)
Public Function GetAccessFailedCountAsync (
    user As T
) As Task(Of Integer)
public:
virtual Task<int>^ GetAccessFailedCountAsync(
    T user
) sealed
abstract GetAccessFailedCountAsync :
        user : 'T -> Task<int>
override GetAccessFailedCountAsync :
        user : 'T -> Task<int>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetAccessFailedCountAsync(`0)"]

Return Value

Type: Task Int32

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetAccessFailedCountAsync(`0)"]

Implements

IUserLockoutStore.GetAccessFailedCountAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetClaimsAsync Method

UserStoreTGetClaimsAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetClaimsAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<IList<Claim>> GetClaimsAsync(
    T user
)
Public Function GetClaimsAsync (
    user As T
) As Task(Of IList(Of Claim))
public:
virtual Task<IList<Claim^>^>^ GetClaimsAsync(
    T user
) sealed
abstract GetClaimsAsync :
        user : 'T -> Task<IList<Claim>>
override GetClaimsAsync :
        user : 'T -> Task<IList<Claim>>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetClaimsAsync(`0)"]

Return Value

Type: Task IList Claim

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetClaimsAsync(`0)"]

Implements

IUserClaimStore.GetClaimsAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetEmailAsync Method

UserStoreTGetEmailAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<string> GetEmailAsync(
    T user
)
Public Function GetEmailAsync (
    user As T
) As Task(Of String)
public:
virtual Task<String^>^ GetEmailAsync(
    T user
) sealed
abstract GetEmailAsync :
        user : 'T -> Task<string>
override GetEmailAsync :
        user : 'T -> Task<string>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailAsync(`0)"]

Return Value

Type: Task String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailAsync(`0)"]

Implements

IUserEmailStore.GetEmailAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetEmailConfirmedAsync Method

UserStoreTGetEmailConfirmedAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailConfirmedAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> GetEmailConfirmedAsync(
    T user
)
Public Function GetEmailConfirmedAsync (
    user As T
) As Task(Of Boolean)
public:
virtual Task<bool>^ GetEmailConfirmedAsync(
    T user
) sealed
abstract GetEmailConfirmedAsync :
        user : 'T -> Task<bool>
override GetEmailConfirmedAsync :
        user : 'T -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailConfirmedAsync(`0)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetEmailConfirmedAsync(`0)"]

Implements

IUserEmailStore.GetEmailConfirmedAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetLockoutEnabledAsync Method

UserStoreTGetLockoutEnabledAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEnabledAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> GetLockoutEnabledAsync(
    T user
)
Public Function GetLockoutEnabledAsync (
    user As T
) As Task(Of Boolean)
public:
virtual Task<bool>^ GetLockoutEnabledAsync(
    T user
) sealed
abstract GetLockoutEnabledAsync :
        user : 'T -> Task<bool>
override GetLockoutEnabledAsync :
        user : 'T -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEnabledAsync(`0)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEnabledAsync(`0)"]

Implements

IUserLockoutStore.GetLockoutEnabledAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetLockoutEndDateAsync Method

UserStoreTGetLockoutEndDateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEndDateAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<DateTimeOffset> GetLockoutEndDateAsync(
    T user
)
Public Function GetLockoutEndDateAsync (
    user As T
) As Task(Of DateTimeOffset)
public:
virtual Task<DateTimeOffset>^ GetLockoutEndDateAsync(
    T user
) sealed
abstract GetLockoutEndDateAsync :
        user : 'T -> Task<DateTimeOffset>
override GetLockoutEndDateAsync :
        user : 'T -> Task<DateTimeOffset>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEndDateAsync(`0)"]

Return Value

Type: Task DateTimeOffset

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLockoutEndDateAsync(`0)"]

Implements

IUserLockoutStore.GetLockoutEndDateAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetLoginsAsync Method

UserStoreTGetLoginsAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLoginsAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<IList<UserLoginInfo>> GetLoginsAsync(
    T user
)
Public Function GetLoginsAsync (
    user As T
) As Task(Of IList(Of UserLoginInfo))
public:
virtual Task<IList<UserLoginInfo^>^>^ GetLoginsAsync(
    T user
) sealed
abstract GetLoginsAsync :
        user : 'T -> Task<IList<UserLoginInfo>>
override GetLoginsAsync :
        user : 'T -> Task<IList<UserLoginInfo>>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLoginsAsync(`0)"]

Return Value

Type: Task IList UserLoginInfo

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetLoginsAsync(`0)"]

Implements

IUserLoginStore.GetLoginsAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetPasswordHashAsync Method

UserStoreTGetPasswordHashAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPasswordHashAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<string> GetPasswordHashAsync(
    T user
)
Public Function GetPasswordHashAsync (
    user As T
) As Task(Of String)
public:
virtual Task<String^>^ GetPasswordHashAsync(
    T user
) sealed
abstract GetPasswordHashAsync :
        user : 'T -> Task<string>
override GetPasswordHashAsync :
        user : 'T -> Task<string>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPasswordHashAsync(`0)"]

Return Value

Type: Task String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPasswordHashAsync(`0)"]

Implements

IUserPasswordStore.GetPasswordHashAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetPhoneNumberAsync Method

UserStoreTGetPhoneNumberAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<string> GetPhoneNumberAsync(
    T user
)
Public Function GetPhoneNumberAsync (
    user As T
) As Task(Of String)
public:
virtual Task<String^>^ GetPhoneNumberAsync(
    T user
) sealed
abstract GetPhoneNumberAsync :
        user : 'T -> Task<string>
override GetPhoneNumberAsync :
        user : 'T -> Task<string>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberAsync(`0)"]

Return Value

Type: Task String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberAsync(`0)"]

Implements

IUserPhoneNumberStore.GetPhoneNumberAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetPhoneNumberConfirmedAsync Method

UserStoreTGetPhoneNumberConfirmedAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberConfirmedAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> GetPhoneNumberConfirmedAsync(
    T user
)
Public Function GetPhoneNumberConfirmedAsync (
    user As T
) As Task(Of Boolean)
public:
virtual Task<bool>^ GetPhoneNumberConfirmedAsync(
    T user
) sealed
abstract GetPhoneNumberConfirmedAsync :
        user : 'T -> Task<bool>
override GetPhoneNumberConfirmedAsync :
        user : 'T -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberConfirmedAsync(`0)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetPhoneNumberConfirmedAsync(`0)"]

Implements

IUserPhoneNumberStore.GetPhoneNumberConfirmedAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetRolesAsync Method

UserStoreTGetRolesAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetRolesAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<IList<string>> GetRolesAsync(
    T user
)
Public Function GetRolesAsync (
    user As T
) As Task(Of IList(Of String))
public:
virtual Task<IList<String^>^>^ GetRolesAsync(
    T user
) sealed
abstract GetRolesAsync :
        user : 'T -> Task<IList<string>>
override GetRolesAsync :
        user : 'T -> Task<IList<string>>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetRolesAsync(`0)"]

Return Value

Type: Task IList String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetRolesAsync(`0)"]

Implements

IUserRoleStore.GetRolesAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetSecurityStampAsync Method

UserStoreTGetSecurityStampAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetSecurityStampAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<string> GetSecurityStampAsync(
    T user
)
Public Function GetSecurityStampAsync (
    user As T
) As Task(Of String)
public:
virtual Task<String^>^ GetSecurityStampAsync(
    T user
) sealed
abstract GetSecurityStampAsync :
        user : 'T -> Task<string>
override GetSecurityStampAsync :
        user : 'T -> Task<string>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetSecurityStampAsync(`0)"]

Return Value

Type: Task String

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetSecurityStampAsync(`0)"]

Implements

IUserSecurityStampStore.GetSecurityStampAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).GetTwoFactorEnabledAsync Method

UserStoreTGetTwoFactorEnabledAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetTwoFactorEnabledAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> GetTwoFactorEnabledAsync(
    T user
)
Public Function GetTwoFactorEnabledAsync (
    user As T
) As Task(Of Boolean)
public:
virtual Task<bool>^ GetTwoFactorEnabledAsync(
    T user
) sealed
abstract GetTwoFactorEnabledAsync :
        user : 'T -> Task<bool>
override GetTwoFactorEnabledAsync :
        user : 'T -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetTwoFactorEnabledAsync(`0)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.GetTwoFactorEnabledAsync(`0)"]

Implements

IUserTwoFactorStore.GetTwoFactorEnabledAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).HasPasswordAsync Method

UserStoreTHasPasswordAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.HasPasswordAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> HasPasswordAsync(
    T user
)
Public Function HasPasswordAsync (
    user As T
) As Task(Of Boolean)
public:
virtual Task<bool>^ HasPasswordAsync(
    T user
) sealed
abstract HasPasswordAsync :
        user : 'T -> Task<bool>
override HasPasswordAsync :
        user : 'T -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.HasPasswordAsync(`0)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.HasPasswordAsync(`0)"]

Implements

IUserPasswordStore.HasPasswordAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).IncrementAccessFailedCountAsync Method

UserStoreTIncrementAccessFailedCountAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IncrementAccessFailedCountAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<int> IncrementAccessFailedCountAsync(
    T user
)
Public Function IncrementAccessFailedCountAsync (
    user As T
) As Task(Of Integer)
public:
virtual Task<int>^ IncrementAccessFailedCountAsync(
    T user
) sealed
abstract IncrementAccessFailedCountAsync :
        user : 'T -> Task<int>
override IncrementAccessFailedCountAsync :
        user : 'T -> Task<int>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IncrementAccessFailedCountAsync(`0)"]

Return Value

Type: Task Int32

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IncrementAccessFailedCountAsync(`0)"]

Implements

IUserLockoutStore.IncrementAccessFailedCountAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).IsInRoleAsync Method

UserStoreTIsInRoleAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IsInRoleAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task<bool> IsInRoleAsync(
    T user,
    string roleName
)
Public Function IsInRoleAsync (
    user As T,
    roleName As String
) As Task(Of Boolean)
public:
virtual Task<bool>^ IsInRoleAsync(
    T user,
    String^ roleName
) sealed
abstract IsInRoleAsync :
        user : 'T *
        roleName : string -> Task<bool>
override IsInRoleAsync :
        user : 'T *
        roleName : string -> Task<bool>

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IsInRoleAsync(`0,System.String)"]

roleName
Type: SystemString

[Missing <param name="roleName"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IsInRoleAsync(`0,System.String)"]

Return Value

Type: Task Boolean

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.IsInRoleAsync(`0,System.String)"]

Implements

IUserRoleStore.IsInRoleAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).RemoveClaimAsync Method

UserStoreTRemoveClaimAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveClaimAsync(`0,System.Security.Claims.Claim)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task RemoveClaimAsync(
    T user,
    Claim claim
)
Public Function RemoveClaimAsync (
    user As T,
    claim As Claim
) As Task
public:
virtual Task^ RemoveClaimAsync(
    T user,
    Claim^ claim
) sealed
abstract RemoveClaimAsync :
        user : 'T *
        claim : Claim -> Task
override RemoveClaimAsync :
        user : 'T *
        claim : Claim -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveClaimAsync(`0,System.Security.Claims.Claim)"]

claim
Type: System.Security.ClaimsClaim

[Missing <param name="claim"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveClaimAsync(`0,System.Security.Claims.Claim)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveClaimAsync(`0,System.Security.Claims.Claim)"]

Implements

IUserClaimStore.RemoveClaimAsync(UTP, Claim)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).RemoveFromRoleAsync Method

UserStoreTRemoveFromRoleAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveFromRoleAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task RemoveFromRoleAsync(
    T user,
    string roleName
)
Public Function RemoveFromRoleAsync (
    user As T,
    roleName As String
) As Task
public:
virtual Task^ RemoveFromRoleAsync(
    T user,
    String^ roleName
) sealed
abstract RemoveFromRoleAsync :
        user : 'T *
        roleName : string -> Task
override RemoveFromRoleAsync :
        user : 'T *
        roleName : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveFromRoleAsync(`0,System.String)"]

roleName
Type: SystemString

[Missing <param name="roleName"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveFromRoleAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveFromRoleAsync(`0,System.String)"]

Implements

IUserRoleStore.RemoveFromRoleAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).RemoveLoginAsync Method

UserStoreTRemoveLoginAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task RemoveLoginAsync(
    T user,
    UserLoginInfo login
)
Public Function RemoveLoginAsync (
    user As T,
    login As UserLoginInfo
) As Task
public:
virtual Task^ RemoveLoginAsync(
    T user,
    UserLoginInfo^ login
) sealed
abstract RemoveLoginAsync :
        user : 'T *
        login : UserLoginInfo -> Task
override RemoveLoginAsync :
        user : 'T *
        login : UserLoginInfo -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

login
Type: UserLoginInfo

[Missing <param name="login"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.RemoveLoginAsync(`0,Microsoft.AspNet.Identity.UserLoginInfo)"]

Implements

IUserLoginStore.RemoveLoginAsync(UTP, UserLoginInfo)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).ResetAccessFailedCountAsync Method

UserStoreTResetAccessFailedCountAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.ResetAccessFailedCountAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task ResetAccessFailedCountAsync(
    T user
)
Public Function ResetAccessFailedCountAsync (
    user As T
) As Task
public:
virtual Task^ ResetAccessFailedCountAsync(
    T user
) sealed
abstract ResetAccessFailedCountAsync :
        user : 'T -> Task
override ResetAccessFailedCountAsync :
        user : 'T -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.ResetAccessFailedCountAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.ResetAccessFailedCountAsync(`0)"]

Implements

IUserLockoutStore.ResetAccessFailedCountAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetEmailAsync Method

UserStoreTSetEmailAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetEmailAsync(
    T user,
    string email
)
Public Function SetEmailAsync (
    user As T,
    email As String
) As Task
public:
virtual Task^ SetEmailAsync(
    T user,
    String^ email
) sealed
abstract SetEmailAsync :
        user : 'T *
        email : string -> Task
override SetEmailAsync :
        user : 'T *
        email : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailAsync(`0,System.String)"]

email
Type: SystemString

[Missing <param name="email"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailAsync(`0,System.String)"]

Implements

IUserEmailStore.SetEmailAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetEmailConfirmedAsync Method

UserStoreTSetEmailConfirmedAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailConfirmedAsync(`0,System.Boolean)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetEmailConfirmedAsync(
    T user,
    bool confirmed
)
Public Function SetEmailConfirmedAsync (
    user As T,
    confirmed As Boolean
) As Task
public:
virtual Task^ SetEmailConfirmedAsync(
    T user,
    bool confirmed
) sealed
abstract SetEmailConfirmedAsync :
        user : 'T *
        confirmed : bool -> Task
override SetEmailConfirmedAsync :
        user : 'T *
        confirmed : bool -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailConfirmedAsync(`0,System.Boolean)"]

confirmed
Type: SystemBoolean

[Missing <param name="confirmed"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailConfirmedAsync(`0,System.Boolean)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetEmailConfirmedAsync(`0,System.Boolean)"]

Implements

IUserEmailStore.SetEmailConfirmedAsync(UTP, Boolean)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetLockoutEnabledAsync Method

UserStoreTSetLockoutEnabledAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEnabledAsync(`0,System.Boolean)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetLockoutEnabledAsync(
    T user,
    bool enabled
)
Public Function SetLockoutEnabledAsync (
    user As T,
    enabled As Boolean
) As Task
public:
virtual Task^ SetLockoutEnabledAsync(
    T user,
    bool enabled
) sealed
abstract SetLockoutEnabledAsync :
        user : 'T *
        enabled : bool -> Task
override SetLockoutEnabledAsync :
        user : 'T *
        enabled : bool -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEnabledAsync(`0,System.Boolean)"]

enabled
Type: SystemBoolean

[Missing <param name="enabled"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEnabledAsync(`0,System.Boolean)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEnabledAsync(`0,System.Boolean)"]

Implements

IUserLockoutStore.SetLockoutEnabledAsync(UTP, Boolean)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetLockoutEndDateAsync Method

UserStoreTSetLockoutEndDateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEndDateAsync(`0,System.DateTimeOffset)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetLockoutEndDateAsync(
    T user,
    DateTimeOffset lockoutEnd
)
Public Function SetLockoutEndDateAsync (
    user As T,
    lockoutEnd As DateTimeOffset
) As Task
public:
virtual Task^ SetLockoutEndDateAsync(
    T user,
    DateTimeOffset lockoutEnd
) sealed
abstract SetLockoutEndDateAsync :
        user : 'T *
        lockoutEnd : DateTimeOffset -> Task
override SetLockoutEndDateAsync :
        user : 'T *
        lockoutEnd : DateTimeOffset -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEndDateAsync(`0,System.DateTimeOffset)"]

lockoutEnd
Type: SystemDateTimeOffset

[Missing <param name="lockoutEnd"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEndDateAsync(`0,System.DateTimeOffset)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetLockoutEndDateAsync(`0,System.DateTimeOffset)"]

Implements

IUserLockoutStore.SetLockoutEndDateAsync(UTP, DateTimeOffset)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetPasswordHashAsync Method

UserStoreTSetPasswordHashAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPasswordHashAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetPasswordHashAsync(
    T user,
    string passwordHash
)
Public Function SetPasswordHashAsync (
    user As T,
    passwordHash As String
) As Task
public:
virtual Task^ SetPasswordHashAsync(
    T user,
    String^ passwordHash
) sealed
abstract SetPasswordHashAsync :
        user : 'T *
        passwordHash : string -> Task
override SetPasswordHashAsync :
        user : 'T *
        passwordHash : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPasswordHashAsync(`0,System.String)"]

passwordHash
Type: SystemString

[Missing <param name="passwordHash"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPasswordHashAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPasswordHashAsync(`0,System.String)"]

Implements

IUserPasswordStore.SetPasswordHashAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetPhoneNumberAsync Method

UserStoreTSetPhoneNumberAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetPhoneNumberAsync(
    T user,
    string phoneNumber
)
Public Function SetPhoneNumberAsync (
    user As T,
    phoneNumber As String
) As Task
public:
virtual Task^ SetPhoneNumberAsync(
    T user,
    String^ phoneNumber
) sealed
abstract SetPhoneNumberAsync :
        user : 'T *
        phoneNumber : string -> Task
override SetPhoneNumberAsync :
        user : 'T *
        phoneNumber : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberAsync(`0,System.String)"]

phoneNumber
Type: SystemString

[Missing <param name="phoneNumber"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberAsync(`0,System.String)"]

Implements

IUserPhoneNumberStore.SetPhoneNumberAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetPhoneNumberConfirmedAsync Method

UserStoreTSetPhoneNumberConfirmedAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberConfirmedAsync(`0,System.Boolean)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetPhoneNumberConfirmedAsync(
    T user,
    bool confirmed
)
Public Function SetPhoneNumberConfirmedAsync (
    user As T,
    confirmed As Boolean
) As Task
public:
virtual Task^ SetPhoneNumberConfirmedAsync(
    T user,
    bool confirmed
) sealed
abstract SetPhoneNumberConfirmedAsync :
        user : 'T *
        confirmed : bool -> Task
override SetPhoneNumberConfirmedAsync :
        user : 'T *
        confirmed : bool -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberConfirmedAsync(`0,System.Boolean)"]

confirmed
Type: SystemBoolean

[Missing <param name="confirmed"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberConfirmedAsync(`0,System.Boolean)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetPhoneNumberConfirmedAsync(`0,System.Boolean)"]

Implements

IUserPhoneNumberStore.SetPhoneNumberConfirmedAsync(UTP, Boolean)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetSecurityStampAsync Method

UserStoreTSetSecurityStampAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetSecurityStampAsync(`0,System.String)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetSecurityStampAsync(
    T user,
    string stamp
)
Public Function SetSecurityStampAsync (
    user As T,
    stamp As String
) As Task
public:
virtual Task^ SetSecurityStampAsync(
    T user,
    String^ stamp
) sealed
abstract SetSecurityStampAsync :
        user : 'T *
        stamp : string -> Task
override SetSecurityStampAsync :
        user : 'T *
        stamp : string -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetSecurityStampAsync(`0,System.String)"]

stamp
Type: SystemString

[Missing <param name="stamp"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetSecurityStampAsync(`0,System.String)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetSecurityStampAsync(`0,System.String)"]

Implements

IUserSecurityStampStore.SetSecurityStampAsync(UTP, String)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).SetTwoFactorEnabledAsync Method

UserStoreTSetTwoFactorEnabledAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetTwoFactorEnabledAsync(`0,System.Boolean)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task SetTwoFactorEnabledAsync(
    T user,
    bool enabled
)
Public Function SetTwoFactorEnabledAsync (
    user As T,
    enabled As Boolean
) As Task
public:
virtual Task^ SetTwoFactorEnabledAsync(
    T user,
    bool enabled
) sealed
abstract SetTwoFactorEnabledAsync :
        user : 'T *
        enabled : bool -> Task
override SetTwoFactorEnabledAsync :
        user : 'T *
        enabled : bool -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetTwoFactorEnabledAsync(`0,System.Boolean)"]

enabled
Type: SystemBoolean

[Missing <param name="enabled"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetTwoFactorEnabledAsync(`0,System.Boolean)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.SetTwoFactorEnabledAsync(`0,System.Boolean)"]

Implements

IUserTwoFactorStore.SetTwoFactorEnabledAsync(UTP, Boolean)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


UserStore(T).UpdateAsync Method

UserStoreTUpdateAsync Method

[Missing <summary> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.UpdateAsync(`0)"]

Namespace: VelocityDBExtensions2.AspNet.Identity
Assembly: VelocityDBExtensions2 (in VelocityDBExtensions2.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Task UpdateAsync(
    T user
)
Public Function UpdateAsync (
    user As T
) As Task
public:
virtual Task^ UpdateAsync(
    T user
) sealed
abstract UpdateAsync :
        user : 'T -> Task
override UpdateAsync :
        user : 'T -> Task

Parameters

user
Type: T

[Missing <param name="user"/> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.UpdateAsync(`0)"]

Return Value

Type: Task

[Missing <returns> documentation for "M:VelocityDBExtensions2.AspNet.Identity.UserStore`1.UpdateAsync(`0)"]

Implements

IUserStore.UpdateAsync(UTP)
See Also

Reference

UserStoreT Class
VelocityDBExtensions2.AspNet.Identity Namespace


VelocityGraph Namespace

[Missing <summary> documentation for "N:VelocityGraph"]

Classes
 | Class | Description
Public class | Edge |
Public class | EdgeType |
Public class | Element |
Public class | Graph |
Public class | GraphJsonSettings |
Public class | PropertyType |
Public class | PropertyTypeNoDuplicateValuesT |
Public class | PropertyTypeTT |
Public class | Vertex |
Public class | VertexType |
Enumerations
 | Enumeration | Description
Public enumeration | DataType |
Public enumeration | PropertyKind |


DataType Enumeration

[Missing <summary> documentation for "T:VelocityGraph.DataType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum DataType
Public Enumeration DataType
public enum class DataType
type DataType
Members
Member name | Value | Description
Boolean | 0 |
Integer | 1 |
Long | 2 |
Double | 3 |
Single | 4 |
DateTime | 5 |
String | 6 |
Object | 7 |
IOptimizedPersistable | 8 |
See Also

Reference

VelocityGraph Namespace


Edge Class

[Missing <summary> documentation for "T:VelocityGraph.Edge"]

Inheritance Hierarchy
SystemObject
DictionaryElement
VelocityGraphElement
VelocityGraphEdge

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Edge : Element, IEdge, IElement,
    IDictionary<string, Object>, ICollection<KeyValuePair<string, Object>>,
    IEnumerable<KeyValuePair<string, Object>>, IEnumerable,
    IDictionary, ICollection, IEqualityComparer<Edge>
Public Class Edge
    Inherits Element
    Implements IEdge, IElement, IDictionary(Of String, Object),
    ICollection(Of KeyValuePair(Of String, Object)), IEnumerable(Of KeyValuePair(Of String, Object)),
    IEnumerable, IDictionary, ICollection, IEqualityComparer(Of Edge)
public ref class Edge : public Element,
    IEdge, IElement, IDictionary<String^, Object^>,
    ICollection<KeyValuePair<String^, Object^>>, IEnumerable<KeyValuePair<String^, Object^>>,
    IEnumerable, IDictionary, ICollection, IEqualityComparer<Edge^>
type Edge =
    class
        inherit Element
        interface IEdge
        interface IElement
        interface IDictionary<string, Object>
        interface ICollection<KeyValuePair<string, Object>>
        interface IEnumerable<KeyValuePair<string, Object>>
        interface IEnumerable
        interface IDictionary
        interface ICollection
        interface IEqualityComparer<Edge>
    end

The Edge type exposes the following members.

Properties
 | Name | Description
Public property | EdgeId |
Public property | EdgeType |
Public property | Head |
Public property | Id | (Overrides DictionaryElement.Id.)
Public property | Tail |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Edge, Edge) |
Public method | GetEdgePeer |
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Edge) |
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Public method | GetPropertyKeys | (Overrides DictionaryElement.GetPropertyKeys.)
Public method | Remove | (Overrides DictionaryElement.Remove.)
Public method | RemoveProperty | (Overrides DictionaryElement.RemoveProperty(String).)
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

VelocityGraph Namespace


Edge Properties

The Edge type exposes the following members.

Properties
 | Name | Description
Public property | EdgeId |
Public property | EdgeType |
Public property | Head |
Public property | Id | (Overrides DictionaryElement.Id.)
Public property | Tail |
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.EdgeId Property

EdgeEdgeId Property

[Missing <summary> documentation for "P:VelocityGraph.Edge.EdgeId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int EdgeId { get; }
Public ReadOnly Property EdgeId As Integer
    Get
public:
property int EdgeId {
    int get ();
}
member EdgeId : int with get

Property Value

Type: Int32
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.EdgeType Property

EdgeEdgeType Property

[Missing <summary> documentation for "P:VelocityGraph.Edge.EdgeType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType EdgeType { get; }
Public ReadOnly Property EdgeType As EdgeType
    Get
public:
property EdgeType^ EdgeType {
    EdgeType^ get ();
}
member EdgeType : EdgeType with get

Property Value

Type: EdgeType
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Head Property

EdgeHead Property

[Missing <summary> documentation for "P:VelocityGraph.Edge.Head"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex Head { get; }
Public ReadOnly Property Head As Vertex
    Get
public:
property Vertex^ Head {
    Vertex^ get ();
}
member Head : Vertex with get

Property Value

Type: Vertex
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Id Property

EdgeId Property

[Missing <summary> documentation for "P:VelocityGraph.Edge.Id"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Id { get; }
Public Overrides ReadOnly Property Id As Object
    Get
public:
virtual property Object^ Id {
    Object^ get () override;
}
abstract Id : Object with get
override Id : Object with get

Property Value

Type: Object

Implements

IElement.Id
IElement.Id
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Tail Property

EdgeTail Property

[Missing <summary> documentation for "P:VelocityGraph.Edge.Tail"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex Tail { get; }
Public ReadOnly Property Tail As Vertex
    Get
public:
property Vertex^ Tail {
    Vertex^ get ();
}
member Tail : Vertex with get

Property Value

Type: Vertex
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge Methods

The Edge type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Edge, Edge) |
Public method | GetEdgePeer |
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Edge) |
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Public method | GetPropertyKeys | (Overrides DictionaryElement.GetPropertyKeys.)
Public method | Remove | (Overrides DictionaryElement.Remove.)
Public method | RemoveProperty | (Overrides DictionaryElement.RemoveProperty(String).)
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Equals Method

EdgeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Edge, Edge) |
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Equals Method (Object)

EdgeEquals Method (Object)

[Missing <summary> documentation for "M:VelocityGraph.Edge.Equals(System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object other
)
Public Overrides Function Equals (
    other As Object
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
abstract Equals :
        other : Object -> bool
override Equals :
        other : Object -> bool

Parameters

other
Type: SystemObject

[Missing <param name="other"/> documentation for "M:VelocityGraph.Edge.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.Edge.Equals(System.Object)"]

See Also

Reference

Edge Class
Equals Overload
VelocityGraph Namespace


Edge.Equals Method (Edge, Edge)

EdgeEquals Method (Edge, Edge)

[Missing <summary> documentation for "M:VelocityGraph.Edge.Equals(VelocityGraph.Edge,VelocityGraph.Edge)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Edge x,
    Edge y
)
Public Function Equals (
    x As Edge,
    y As Edge
) As Boolean
public:
virtual bool Equals(
    Edge^ x,
    Edge^ y
) sealed
abstract Equals :
        x : Edge *
        y : Edge -> bool
override Equals :
        x : Edge *
        y : Edge -> bool

Parameters

x
Type: VelocityGraphEdge

[Missing <param name="x"/> documentation for "M:VelocityGraph.Edge.Equals(VelocityGraph.Edge,VelocityGraph.Edge)"]

y
Type: VelocityGraphEdge

[Missing <param name="y"/> documentation for "M:VelocityGraph.Edge.Equals(VelocityGraph.Edge,VelocityGraph.Edge)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.Edge.Equals(VelocityGraph.Edge,VelocityGraph.Edge)"]

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

Edge Class
Equals Overload
VelocityGraph Namespace


Edge.GetEdgePeer Method

EdgeGetEdgePeer Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetEdgePeer(VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex GetEdgePeer(
    Vertex vertex
)
Public Function GetEdgePeer (
    vertex As Vertex
) As Vertex
public:
Vertex^ GetEdgePeer(
    Vertex^ vertex
)
member GetEdgePeer :
        vertex : Vertex -> Vertex

Parameters

vertex
Type: VelocityGraphVertex

[Missing <param name="vertex"/> documentation for "M:VelocityGraph.Edge.GetEdgePeer(VelocityGraph.Vertex)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetEdgePeer(VelocityGraph.Vertex)"]

See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.GetHashCode Method

EdgeGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Edge) |
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.GetHashCode Method

EdgeGetHashCode Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetHashCode"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetHashCode"]

See Also

Reference

Edge Class
GetHashCode Overload
VelocityGraph Namespace


Edge.GetHashCode Method (Edge)

EdgeGetHashCode Method (Edge)

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetHashCode(VelocityGraph.Edge)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Edge obj
)
Public Function GetHashCode (
    obj As Edge
) As Integer
public:
virtual int GetHashCode(
    Edge^ obj
) sealed
abstract GetHashCode :
        obj : Edge -> int
override GetHashCode :
        obj : Edge -> int

Parameters

obj
Type: VelocityGraphEdge

[Missing <param name="obj"/> documentation for "M:VelocityGraph.Edge.GetHashCode(VelocityGraph.Edge)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetHashCode(VelocityGraph.Edge)"]

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

Edge Class
GetHashCode Overload
VelocityGraph Namespace


Edge.GetProperty Method

EdgeGetProperty Method

Overload List
 | Name | Description
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.GetProperty Method (String)

EdgeGetProperty Method (String)

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object GetProperty(
    string key
)
Public Overrides Function GetProperty (
    key As String
) As Object
public:
virtual Object^ GetProperty(
    String^ key
) override
abstract GetProperty :
        key : string -> Object
override GetProperty :
        key : string -> Object

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Edge.GetProperty(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetProperty(System.String)"]

Implements

IElement.GetProperty(String)
IElement.GetProperty(String)
See Also

Reference

Edge Class
GetProperty Overload
VelocityGraph Namespace


Edge.GetProperty Method (PropertyType)

EdgeGetProperty Method (PropertyType)

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetProperty(VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IComparable GetProperty(
    PropertyType property
)
Public Function GetProperty (
    property As PropertyType
) As IComparable
public:
IComparable^ GetProperty(
    PropertyType^ property
)
member GetProperty :
        property : PropertyType -> IComparable

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Edge.GetProperty(VelocityGraph.PropertyType)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetProperty(VelocityGraph.PropertyType)"]

See Also

Reference

Edge Class
GetProperty Overload
VelocityGraph Namespace


Edge.GetPropertyKeys Method

EdgeGetPropertyKeys Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.GetPropertyKeys"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<string> GetPropertyKeys()
Public Overrides Function GetPropertyKeys As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetPropertyKeys() override
abstract GetPropertyKeys : unit -> IEnumerable<string>
override GetPropertyKeys : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String

[Missing <returns> documentation for "M:VelocityGraph.Edge.GetPropertyKeys"]

Implements

IElement.GetPropertyKeys
IElement.GetPropertyKeys
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.Remove Method

EdgeRemove Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.Remove"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Remove()
Public Overrides Sub Remove
public:
virtual void Remove() override
abstract Remove : unit -> unit
override Remove : unit -> unit

Implements

IElement.Remove
IElement.Remove
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.RemoveProperty Method

EdgeRemoveProperty Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.RemoveProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object RemoveProperty(
    string key
)
Public Overrides Function RemoveProperty (
    key As String
) As Object
public:
virtual Object^ RemoveProperty(
    String^ key
) override
abstract RemoveProperty :
        key : string -> Object
override RemoveProperty :
        key : string -> Object

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Edge.RemoveProperty(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.Edge.RemoveProperty(System.String)"]

Implements

IElement.RemoveProperty(String)
IElement.RemoveProperty(String)
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.SetProperty Method

EdgeSetProperty Method

Overload List
 | Name | Description
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Top
See Also

Reference

Edge Class
VelocityGraph Namespace


Edge.SetProperty Method (String, Object)

EdgeSetProperty Method (String, Object)

[Missing <summary> documentation for "M:VelocityGraph.Edge.SetProperty(System.String,System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetProperty(
    string key,
    Object value
)
Public Overrides Sub SetProperty (
    key As String,
    value As Object
)
public:
virtual void SetProperty(
    String^ key,
    Object^ value
) override
abstract SetProperty :
        key : string *
        value : Object -> unit
override SetProperty :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Edge.SetProperty(System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:VelocityGraph.Edge.SetProperty(System.String,System.Object)"]

Implements

IElement.SetProperty(String, Object)
IElement.SetProperty(String, Object)
See Also

Reference

Edge Class
SetProperty Overload
VelocityGraph Namespace


Edge.SetProperty Method (PropertyType, IComparable)

EdgeSetProperty Method (PropertyType, IComparable)

[Missing <summary> documentation for "M:VelocityGraph.Edge.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetProperty(
    PropertyType property,
    IComparable v
)
Public Sub SetProperty (
    property As PropertyType,
    v As IComparable
)
public:
void SetProperty(
    PropertyType^ property,
    IComparable^ v
)
member SetProperty :
        property : PropertyType *
        v : IComparable -> unit

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Edge.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

v
Type: SystemIComparable

[Missing <param name="v"/> documentation for "M:VelocityGraph.Edge.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

See Also

Reference

Edge Class
SetProperty Overload
VelocityGraph Namespace


Edge.ToString Method

EdgeToString Method

[Missing <summary> documentation for "M:VelocityGraph.Edge.ToString"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityGraph.Edge.ToString"]

See Also

Reference

Edge Class
VelocityGraph Namespace


EdgeType Class

[Missing <summary> documentation for "T:VelocityGraph.EdgeType"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphEdgeType

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EdgeType : OptimizedPersistable, IComparable<EdgeType>,
    IEqualityComparer<EdgeType>
<SerializableAttribute>
Public Class EdgeType
    Inherits OptimizedPersistable
    Implements IComparable(Of EdgeType), IEqualityComparer(Of EdgeType)
[SerializableAttribute]
public ref class EdgeType : public OptimizedPersistable,
    IComparable<EdgeType^>, IEqualityComparer<EdgeType^>
[<SerializableAttribute>]
type EdgeType =
    class
        inherit OptimizedPersistable
        interface IComparable<EdgeType>
        interface IEqualityComparer<EdgeType>
    end

The EdgeType type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeType | Initializes a new instance of the EdgeType class
Top
Properties
 | Name | Description
Public property | Directed |
Public property | HeadType |
Public property | MyGraph |
Public property | SubTypes |
Public property | TailType |
Public property | TypeId |
Public property | TypeName |
Public property | Unrestricted |
Top
Methods
 | Name | Description
 | Compare |
Public method | CompareTo |
Public method | CountEdges |
Public method | Equals |
Public method | FindProperty |
Public method | GetEdge(Int32, Boolean, Boolean) |
Public method | GetEdge(Int32, Vertex, Vertex) |
Public method | GetEdges |
Public method | GetHashCode |
Public method | GetPropertyKeys |
Public method | GetPropertyTypes |
Public method | GetPropertyValue |
Public method | NewEdge |
Public method | NewEdgeX |
Public method | NewProperty |
Public method | Remove |
Public method | RemoveEdge |
Public method | SetPropertyValue |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


EdgeType Constructor

Initializes a new instance of the EdgeType class

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType(
    int aTypeId,
    string aTypeName,
    VertexType tailType,
    VertexType headType,
    bool birectional,
    EdgeType baseType,
    Graph graph
)
Public Sub New (
    aTypeId As Integer,
    aTypeName As String,
    tailType As VertexType,
    headType As VertexType,
    birectional As Boolean,
    baseType As EdgeType,
    graph As Graph
)
public:
EdgeType(
    int aTypeId,
    String^ aTypeName,
    VertexType^ tailType,
    VertexType^ headType,
    bool birectional,
    EdgeType^ baseType,
    Graph^ graph
)
new :
        aTypeId : int *
        aTypeName : string *
        tailType : VertexType *
        headType : VertexType *
        birectional : bool *
        baseType : EdgeType *
        graph : Graph -> EdgeType

Parameters

aTypeId
Type: SystemInt32

[Missing <param name="aTypeId"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

aTypeName
Type: SystemString

[Missing <param name="aTypeName"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

tailType
Type: VelocityGraphVertexType

[Missing <param name="tailType"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

headType
Type: VelocityGraphVertexType

[Missing <param name="headType"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

birectional
Type: SystemBoolean

[Missing <param name="birectional"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

baseType
Type: VelocityGraphEdgeType

[Missing <param name="baseType"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

graph
Type: VelocityGraphGraph

[Missing <param name="graph"/> documentation for "M:VelocityGraph.EdgeType.#ctor(System.Int32,System.String,VelocityGraph.VertexType,VelocityGraph.VertexType,System.Boolean,VelocityGraph.EdgeType,VelocityGraph.Graph)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType Properties

The EdgeType type exposes the following members.

Properties
 | Name | Description
Public property | Directed |
Public property | HeadType |
Public property | MyGraph |
Public property | SubTypes |
Public property | TailType |
Public property | TypeId |
Public property | TypeName |
Public property | Unrestricted |
Top
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Directed Property

EdgeTypeDirected Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.Directed"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Directed { get; }
Public ReadOnly Property Directed As Boolean
    Get
public:
property bool Directed {
    bool get ();
}
member Directed : bool with get

Property Value

Type: Boolean
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.HeadType Property

EdgeTypeHeadType Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.HeadType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType HeadType { get; }
Public ReadOnly Property HeadType As VertexType
    Get
public:
property VertexType^ HeadType {
    VertexType^ get ();
}
member HeadType : VertexType with get

Property Value

Type: VertexType
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.MyGraph Property

EdgeTypeMyGraph Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.MyGraph"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Graph MyGraph { get; }
Public ReadOnly Property MyGraph As Graph
    Get
public:
property Graph^ MyGraph {
    Graph^ get ();
}
member MyGraph : Graph with get

Property Value

Type: Graph
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.SubTypes Property

EdgeTypeSubTypes Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.SubTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<EdgeType> SubTypes { get; }
Public ReadOnly Property SubTypes As List(Of EdgeType)
    Get
public:
property List<EdgeType^>^ SubTypes {
    List<EdgeType^>^ get ();
}
member SubTypes : List<EdgeType> with get

Property Value

Type: List EdgeType
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.TailType Property

EdgeTypeTailType Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.TailType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType TailType { get; }
Public ReadOnly Property TailType As VertexType
    Get
public:
property VertexType^ TailType {
    VertexType^ get ();
}
member TailType : VertexType with get

Property Value

Type: VertexType
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.TypeId Property

EdgeTypeTypeId Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.TypeId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int TypeId { get; }
Public ReadOnly Property TypeId As Integer
    Get
public:
property int TypeId {
    int get ();
}
member TypeId : int with get

Property Value

Type: Int32
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.TypeName Property

EdgeTypeTypeName Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.TypeName"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Unrestricted Property

EdgeTypeUnrestricted Property

[Missing <summary> documentation for "P:VelocityGraph.EdgeType.Unrestricted"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Unrestricted { get; }
Public ReadOnly Property Unrestricted As Boolean
    Get
public:
property bool Unrestricted {
    bool get ();
}
member Unrestricted : bool with get

Property Value

Type: Boolean
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType Methods

The EdgeType type exposes the following members.

Methods
 | Name | Description
 | Compare |
Public method | CompareTo |
Public method | CountEdges |
Public method | Equals |
Public method | FindProperty |
Public method | GetEdge(Int32, Boolean, Boolean) |
Public method | GetEdge(Int32, Vertex, Vertex) |
Public method | GetEdges |
Public method | GetHashCode |
Public method | GetPropertyKeys |
Public method | GetPropertyTypes |
Public method | GetPropertyValue |
Public method | NewEdge |
Public method | NewEdgeX |
Public method | NewProperty |
Public method | Remove |
Public method | RemoveEdge |
Public method | SetPropertyValue |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Compare Method

EdgeTypeCompare Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.Compare(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static int Compare(
    EdgeType aId,
    EdgeType bId
)
Public Shared Function Compare (
    aId As EdgeType,
    bId As EdgeType
) As Integer
public:
static int Compare(
    EdgeType^ aId,
    EdgeType^ bId
)
static member Compare :
        aId : EdgeType *
        bId : EdgeType -> int

Parameters

aId
Type: VelocityGraphEdgeType

[Missing <param name="aId"/> documentation for "M:VelocityGraph.EdgeType.Compare(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

bId
Type: VelocityGraphEdgeType

[Missing <param name="bId"/> documentation for "M:VelocityGraph.EdgeType.Compare(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.Compare(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.CompareTo Method

EdgeTypeCompareTo Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.CompareTo(VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    EdgeType obj
)
Public Function CompareTo (
    obj As EdgeType
) As Integer
public:
virtual int CompareTo(
    EdgeType^ obj
) sealed
abstract CompareTo :
        obj : EdgeType -> int
override CompareTo :
        obj : EdgeType -> int

Parameters

obj
Type: VelocityGraphEdgeType

[Missing <param name="obj"/> documentation for "M:VelocityGraph.EdgeType.CompareTo(VelocityGraph.EdgeType)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.CompareTo(VelocityGraph.EdgeType)"]

Implements

IComparableTCompareTo(T)
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.CountEdges Method

EdgeTypeCountEdges Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.CountEdges"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long CountEdges()
Public Function CountEdges As Long
public:
long long CountEdges()
member CountEdges : unit -> int64

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.CountEdges"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Equals Method

EdgeTypeEquals Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.Equals(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    EdgeType x,
    EdgeType y
)
Public Function Equals (
    x As EdgeType,
    y As EdgeType
) As Boolean
public:
virtual bool Equals(
    EdgeType^ x,
    EdgeType^ y
) sealed
abstract Equals :
        x : EdgeType *
        y : EdgeType -> bool
override Equals :
        x : EdgeType *
        y : EdgeType -> bool

Parameters

x
Type: VelocityGraphEdgeType

[Missing <param name="x"/> documentation for "M:VelocityGraph.EdgeType.Equals(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

y
Type: VelocityGraphEdgeType

[Missing <param name="y"/> documentation for "M:VelocityGraph.EdgeType.Equals(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.Equals(VelocityGraph.EdgeType,VelocityGraph.EdgeType)"]

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.FindProperty Method

EdgeTypeFindProperty Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.FindProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType FindProperty(
    string name
)
Public Function FindProperty (
    name As String
) As PropertyType
public:
PropertyType^ FindProperty(
    String^ name
)
member FindProperty :
        name : string -> PropertyType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.EdgeType.FindProperty(System.String)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.FindProperty(System.String)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetEdge Method

EdgeTypeGetEdge Method

Overload List
 | Name | Description
Public method | GetEdge(Int32, Boolean, Boolean) |
Public method | GetEdge(Int32, Vertex, Vertex) |
Top
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetEdge Method (Int32, Boolean, Boolean)

EdgeTypeGetEdge Method (Int32, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge GetEdge(
    int edgeId,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Function GetEdge (
    edgeId As Integer,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Edge
public:
Edge^ GetEdge(
    int edgeId,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
member GetEdge :
        edgeId : int *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Edge

Parameters

edgeId
Type: SystemInt32

[Missing <param name="edgeId"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,System.Boolean,System.Boolean)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,System.Boolean,System.Boolean)"]

See Also

Reference

EdgeType Class
GetEdge Overload
VelocityGraph Namespace


EdgeType.GetEdge Method (Int32, Vertex, Vertex)

EdgeTypeGetEdge Method (Int32, Vertex, Vertex)

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge GetEdge(
    int edgeId,
    Vertex tailVertex,
    Vertex headVertex
)
Public Function GetEdge (
    edgeId As Integer,
    tailVertex As Vertex,
    headVertex As Vertex
) As Edge
public:
Edge^ GetEdge(
    int edgeId,
    Vertex^ tailVertex,
    Vertex^ headVertex
)
member GetEdge :
        edgeId : int *
        tailVertex : Vertex *
        headVertex : Vertex -> Edge

Parameters

edgeId
Type: SystemInt32

[Missing <param name="edgeId"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

tailVertex
Type: VelocityGraphVertex

[Missing <param name="tailVertex"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

headVertex
Type: VelocityGraphVertex

[Missing <param name="headVertex"/> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetEdge(System.Int32,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

See Also

Reference

EdgeType Class
GetEdge Overload
VelocityGraph Namespace


EdgeType.GetEdges Method

EdgeTypeGetEdges Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetEdges(System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Edge> GetEdges(
    bool polymorphic = false
)
Public Function GetEdges (
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Edge)
public:
IEnumerable<Edge^>^ GetEdges(
    bool polymorphic = false
)
member GetEdges :
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Edge>

Parameters

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.EdgeType.GetEdges(System.Boolean)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetEdges(System.Boolean)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetHashCode Method

EdgeTypeGetHashCode Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetHashCode(VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    EdgeType t
)
Public Function GetHashCode (
    t As EdgeType
) As Integer
public:
virtual int GetHashCode(
    EdgeType^ t
) sealed
abstract GetHashCode :
        t : EdgeType -> int
override GetHashCode :
        t : EdgeType -> int

Parameters

t
Type: VelocityGraphEdgeType

[Missing <param name="t"/> documentation for "M:VelocityGraph.EdgeType.GetHashCode(VelocityGraph.EdgeType)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetHashCode(VelocityGraph.EdgeType)"]

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetPropertyKeys Method

EdgeTypeGetPropertyKeys Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetPropertyKeys"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetPropertyKeys()
Public Function GetPropertyKeys As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetPropertyKeys()
member GetPropertyKeys : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetPropertyKeys"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetPropertyTypes Method

EdgeTypeGetPropertyTypes Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetPropertyTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PropertyType> GetPropertyTypes()
Public Function GetPropertyTypes As IEnumerable(Of PropertyType)
public:
IEnumerable<PropertyType^>^ GetPropertyTypes()
member GetPropertyTypes : unit -> IEnumerable<PropertyType>

Return Value

Type: IEnumerable PropertyType

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetPropertyTypes"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.GetPropertyValue Method

EdgeTypeGetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IComparable GetPropertyValue(
    int elementId,
    PropertyType property
)
Public Function GetPropertyValue (
    elementId As Integer,
    property As PropertyType
) As IComparable
public:
IComparable^ GetPropertyValue(
    int elementId,
    PropertyType^ property
)
member GetPropertyValue :
        elementId : int *
        property : PropertyType -> IComparable

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.EdgeType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.EdgeType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.NewEdge Method

EdgeTypeNewEdge Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.NewEdge(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge NewEdge(
    Vertex tail,
    Vertex head
)
Public Function NewEdge (
    tail As Vertex,
    head As Vertex
) As Edge
public:
Edge^ NewEdge(
    Vertex^ tail,
    Vertex^ head
)
member NewEdge :
        tail : Vertex *
        head : Vertex -> Edge

Parameters

tail
Type: VelocityGraphVertex

[Missing <param name="tail"/> documentation for "M:VelocityGraph.EdgeType.NewEdge(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

head
Type: VelocityGraphVertex

[Missing <param name="head"/> documentation for "M:VelocityGraph.EdgeType.NewEdge(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.NewEdge(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.NewEdgeX Method

EdgeTypeNewEdgeX Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge NewEdgeX(
    WeakReferenceList<PropertyType> propertyType,
    PropertyType tailAttr,
    Object tailV,
    PropertyType headAttr,
    Object headV,
    SessionBase session
)
Public Function NewEdgeX (
    propertyType As WeakReferenceList(Of PropertyType),
    tailAttr As PropertyType,
    tailV As Object,
    headAttr As PropertyType,
    headV As Object,
    session As SessionBase
) As Edge
public:
Edge^ NewEdgeX(
    WeakReferenceList<PropertyType^>^ propertyType,
    PropertyType^ tailAttr,
    Object^ tailV,
    PropertyType^ headAttr,
    Object^ headV,
    SessionBase^ session
)
member NewEdgeX :
        propertyType : WeakReferenceList<PropertyType> *
        tailAttr : PropertyType *
        tailV : Object *
        headAttr : PropertyType *
        headV : Object *
        session : SessionBase -> Edge

Parameters

propertyType
Type: VelocityDb.CollectionWeakReferenceList PropertyType

[Missing <param name="propertyType"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

tailAttr
Type: VelocityGraphPropertyType

[Missing <param name="tailAttr"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

tailV
Type: SystemObject

[Missing <param name="tailV"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

headAttr
Type: VelocityGraphPropertyType

[Missing <param name="headAttr"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

headV
Type: SystemObject

[Missing <param name="headV"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.NewEdgeX(VelocityDb.Collection.WeakReferenceList{VelocityGraph.PropertyType},VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object,VelocityDb.Session.SessionBase)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.NewProperty Method

EdgeTypeNewProperty Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType NewProperty(
    string name,
    DataType dt,
    PropertyKind kind
)
Public Function NewProperty (
    name As String,
    dt As DataType,
    kind As PropertyKind
) As PropertyType
public:
PropertyType^ NewProperty(
    String^ name,
    DataType dt,
    PropertyKind kind
)
member NewProperty :
        name : string *
        dt : DataType *
        kind : PropertyKind -> PropertyType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.EdgeType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

dt
Type: VelocityGraphDataType

[Missing <param name="dt"/> documentation for "M:VelocityGraph.EdgeType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

kind
Type: VelocityGraphPropertyKind

[Missing <param name="kind"/> documentation for "M:VelocityGraph.EdgeType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Remove Method

EdgeTypeRemove Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.Remove"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.RemoveEdge Method

EdgeTypeRemoveEdge Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.RemoveEdge(VelocityGraph.Edge)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemoveEdge(
    Edge edge
)
Public Sub RemoveEdge (
    edge As Edge
)
public:
void RemoveEdge(
    Edge^ edge
)
member RemoveEdge :
        edge : Edge -> unit

Parameters

edge
Type: VelocityGraphEdge

[Missing <param name="edge"/> documentation for "M:VelocityGraph.EdgeType.RemoveEdge(VelocityGraph.Edge)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.SetPropertyValue Method

EdgeTypeSetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetPropertyValue(
    int elementId,
    PropertyType property,
    IComparable v
)
Public Sub SetPropertyValue (
    elementId As Integer,
    property As PropertyType,
    v As IComparable
)
public:
void SetPropertyValue(
    int elementId,
    PropertyType^ property,
    IComparable^ v
)
member SetPropertyValue :
        elementId : int *
        property : PropertyType *
        v : IComparable -> unit

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.EdgeType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.EdgeType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

v
Type: SystemIComparable

[Missing <param name="v"/> documentation for "M:VelocityGraph.EdgeType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.ToString Method

EdgeTypeToString Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.ToString"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityGraph.EdgeType.ToString"]

See Also

Reference

EdgeType Class
VelocityGraph Namespace


EdgeType.Unpersist Method

EdgeTypeUnpersist Method

[Missing <summary> documentation for "M:VelocityGraph.EdgeType.Unpersist(VelocityDb.Session.SessionBase)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.EdgeType.Unpersist(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

EdgeType Class
VelocityGraph Namespace


Element Class

[Missing <summary> documentation for "T:VelocityGraph.Element"]

Inheritance Hierarchy
SystemObject
DictionaryElement
VelocityGraphElement
VelocityGraphEdge
VelocityGraphVertex

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract class Element : DictionaryElement
Public MustInherit Class Element
    Inherits DictionaryElement
public ref class Element abstract : public DictionaryElement
[<AbstractClassAttribute>]
type Element =
    class
        inherit DictionaryElement
    end

The Element type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

VelocityGraph Namespace


Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Element Class
VelocityGraph Namespace


Element.GetHashCode Method

ElementGetHashCode Method

[Missing <summary> documentation for "M:VelocityGraph.Element.GetHashCode"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.Element.GetHashCode"]

See Also

Reference

Element Class
VelocityGraph Namespace


Graph Class

[Missing <summary> documentation for "T:VelocityGraph.Graph"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphGraph

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Graph : OptimizedPersistable, IGraph
<SerializableAttribute>
Public Class Graph
    Inherits OptimizedPersistable
    Implements IGraph
[SerializableAttribute]
public ref class Graph : public OptimizedPersistable,
    IGraph
[<SerializableAttribute>]
type Graph =
    class
        inherit OptimizedPersistable
        interface IGraph
    end

The Graph type exposes the following members.

Constructors
 | Name | Description
Public method | Graph | Initializes a new instance of the Graph class
Top
Properties
 | Name | Description
Public property | Features |
Public property | ObjectsPerPage | (Overrides OptimizedPersistableObjectsPerPage.)
Public property | VertexIdSetPerType |
Top
Methods
 | Name | Description
Public method | AddEdge |
Public method | AddVertex |
Public method | AddVertex(Object) |
Public method | Clear |
 | CombineIntersection |
Public method | ContainsVertex |
Public method | CountEdges |
Public method | CountVertices |
Public method | Edges |
Public method | ExportToGraphJson(Stream) |
Public method | ExportToGraphJson(String) |
Public method | ExportToGraphJson(Stream, GraphJsonSettings) |
Public method | ExportToGraphJson(String, GraphJsonSettings) |
Public method | ExportToGraphSon(Stream, IEnumerableString, IEnumerableString, GraphSonMode) |
Public method | ExportToGraphSon(String, IEnumerableString, IEnumerableString, GraphSonMode) |
Public method | FindEdgeType |
Public method | FindEdgeTypes |
Public method | FindVertex |
Public method | FindVertexProperty |
Public method | FindVertexType |
Public method | FindVertexTypes |
Public method | GetEdge |
Public method | GetEdges |
Public method | GetEdges(String, Object) |
Public method | GetEdgesT(String, T) |
Public method | GetEdgeType |
Public method | GetValues |
Public method | GetVertex(Int32) |
Public method | GetVertex(Object) |
Public method | GetVertexType |
Public method | GetVertices |
Public method | GetVertices(String, Object) |
Public method | ImportGraphJson(String) |
Public method | ImportGraphJson(Stream, Int32) |
Public method | ImportGraphSon(String) |
Public method | ImportGraphSon(Stream, Int32) |
Public method | NewEdge(EdgeType, Vertex, Vertex) |
Public method | NewEdge(EdgeType, PropertyType, Object, PropertyType, Object) |
Public method | NewEdgeProperty |
Public method | NewEdgeType(String, Boolean, EdgeType) |
Public method | NewEdgeType(String, Boolean, VertexType, VertexType, EdgeType) |
Public method | NewVertex |
Public method | NewVertexProperty |
Public method | NewVertexType |
 | Open |
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | Query |
Public method | RemoveEdge |
Public method | RemovePropertyType |
Public method | RemoveVertex |
Public method | RemoveVertexType |
Public method | Select(PropertyType, FuncIComparable, IComparable, Boolean, IComparable) |
Public method | Select(PropertyType, FuncIComparable, IComparable, IComparable, Boolean, IComparable, IComparable) |
Public method | Shutdown |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Traverse |
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


Graph Constructor

Initializes a new instance of the Graph class

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Graph(
    SessionBase session,
    bool vertexIdSetPerVertexType = true
)
Public Sub New (
    session As SessionBase,
    Optional vertexIdSetPerVertexType As Boolean = true
)
public:
Graph(
    SessionBase^ session,
    bool vertexIdSetPerVertexType = true
)
new :
        session : SessionBase *
        ?vertexIdSetPerVertexType : bool
(* Defaults:
        let _vertexIdSetPerVertexType = defaultArg vertexIdSetPerVertexType true
*)
-> Graph

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.Graph.#ctor(VelocityDb.Session.SessionBase,System.Boolean)"]

vertexIdSetPerVertexType (Optional)
Type: SystemBoolean

[Missing <param name="vertexIdSetPerVertexType"/> documentation for "M:VelocityGraph.Graph.#ctor(VelocityDb.Session.SessionBase,System.Boolean)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph Properties

The Graph type exposes the following members.

Properties
 | Name | Description
Public property | Features |
Public property | ObjectsPerPage | (Overrides OptimizedPersistableObjectsPerPage.)
Public property | VertexIdSetPerType |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Features Property

GraphFeatures Property

[Missing <summary> documentation for "P:VelocityGraph.Graph.Features"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Features Features { get; }
Public Overridable ReadOnly Property Features As Features
    Get
public:
virtual property Features^ Features {
    Features^ get ();
}
abstract Features : Features with get
override Features : Features with get

Property Value

Type: Features

Implements

IGraph.Features
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ObjectsPerPage Property

GraphObjectsPerPage Property

[Missing <summary> documentation for "P:VelocityGraph.Graph.ObjectsPerPage"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ushort ObjectsPerPage { get; }
Public Overrides ReadOnly Property ObjectsPerPage As UShort
    Get
public:
virtual property unsigned short ObjectsPerPage {
    unsigned short get () override;
}
abstract ObjectsPerPage : uint16 with get
override ObjectsPerPage : uint16 with get

Property Value

Type: UInt16

Implements

IOptimizedPersistableObjectsPerPage
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.VertexIdSetPerType Property

GraphVertexIdSetPerType Property

[Missing <summary> documentation for "P:VelocityGraph.Graph.VertexIdSetPerType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool VertexIdSetPerType { get; }
Public ReadOnly Property VertexIdSetPerType As Boolean
    Get
public:
property bool VertexIdSetPerType {
    bool get ();
}
member VertexIdSetPerType : bool with get

Property Value

Type: Boolean
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph Methods

The Graph type exposes the following members.

Methods
 | Name | Description
Public method | AddEdge |
Public method | AddVertex |
Public method | AddVertex(Object) |
Public method | Clear |
 | CombineIntersection |
Public method | ContainsVertex |
Public method | CountEdges |
Public method | CountVertices |
Public method | Edges |
Public method | ExportToGraphJson(Stream) |
Public method | ExportToGraphJson(String) |
Public method | ExportToGraphJson(Stream, GraphJsonSettings) |
Public method | ExportToGraphJson(String, GraphJsonSettings) |
Public method | ExportToGraphSon(Stream, IEnumerableString, IEnumerableString, GraphSonMode) |
Public method | ExportToGraphSon(String, IEnumerableString, IEnumerableString, GraphSonMode) |
Public method | FindEdgeType |
Public method | FindEdgeTypes |
Public method | FindVertex |
Public method | FindVertexProperty |
Public method | FindVertexType |
Public method | FindVertexTypes |
Public method | GetEdge |
Public method | GetEdges |
Public method | GetEdges(String, Object) |
Public method | GetEdgesT(String, T) |
Public method | GetEdgeType |
Public method | GetValues |
Public method | GetVertex(Int32) |
Public method | GetVertex(Object) |
Public method | GetVertexType |
Public method | GetVertices |
Public method | GetVertices(String, Object) |
Public method | ImportGraphJson(String) |
Public method | ImportGraphJson(Stream, Int32) |
Public method | ImportGraphSon(String) |
Public method | ImportGraphSon(Stream, Int32) |
Public method | NewEdge(EdgeType, Vertex, Vertex) |
Public method | NewEdge(EdgeType, PropertyType, Object, PropertyType, Object) |
Public method | NewEdgeProperty |
Public method | NewEdgeType(String, Boolean, EdgeType) |
Public method | NewEdgeType(String, Boolean, VertexType, VertexType, EdgeType) |
Public method | NewVertex |
Public method | NewVertexProperty |
Public method | NewVertexType |
 | Open |
Public method | Persist | (Overrides OptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable).)
Public method | Query |
Public method | RemoveEdge |
Public method | RemovePropertyType |
Public method | RemoveVertex |
Public method | RemoveVertexType |
Public method | Select(PropertyType, FuncIComparable, IComparable, Boolean, IComparable) |
Public method | Select(PropertyType, FuncIComparable, IComparable, IComparable, Boolean, IComparable, IComparable) |
Public method | Shutdown |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Traverse |
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.AddEdge Method

GraphAddEdge Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual IEdge AddEdge(
    Object id,
    IVertex outVertex,
    IVertex inVertex,
    string label
)
Public Overridable Function AddEdge (
    id As Object,
    outVertex As IVertex,
    inVertex As IVertex,
    label As String
) As IEdge
public:
virtual IEdge^ AddEdge(
    Object^ id,
    IVertex^ outVertex,
    IVertex^ inVertex,
    String^ label
)
abstract AddEdge :
        id : Object *
        outVertex : IVertex *
        inVertex : IVertex *
        label : string -> IEdge
override AddEdge :
        id : Object *
        outVertex : IVertex *
        inVertex : IVertex *
        label : string -> IEdge

Parameters

id
Type: SystemObject

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

outVertex
Type: IVertex

[Missing <param name="outVertex"/> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

inVertex
Type: IVertex

[Missing <param name="inVertex"/> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

label
Type: SystemString

[Missing <param name="label"/> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.AddEdge(System.Object,Frontenac.Blueprints.IVertex,Frontenac.Blueprints.IVertex,System.String)"]

Implements

IGraph.AddEdge(Object, IVertex, IVertex, String)
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.AddVertex Method

GraphAddVertex Method

Overload List
 | Name | Description
Public method | AddVertex |
Public method | AddVertex(Object) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.AddVertex Method

GraphAddVertex Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.AddVertex"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual Vertex AddVertex()
Public Overridable Function AddVertex As Vertex
public:
virtual Vertex^ AddVertex()
abstract AddVertex : unit -> Vertex
override AddVertex : unit -> Vertex

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.AddVertex"]

See Also

Reference

Graph Class
AddVertex Overload
VelocityGraph Namespace


Graph.AddVertex Method (Object)

GraphAddVertex Method (Object)

[Missing <summary> documentation for "M:VelocityGraph.Graph.AddVertex(System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual IVertex AddVertex(
    Object id
)
Public Overridable Function AddVertex (
    id As Object
) As IVertex
public:
virtual IVertex^ AddVertex(
    Object^ id
)
abstract AddVertex :
        id : Object -> IVertex
override AddVertex :
        id : Object -> IVertex

Parameters

id
Type: SystemObject

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.AddVertex(System.Object)"]

Return Value

Type: IVertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.AddVertex(System.Object)"]

Implements

IGraph.AddVertex(Object)
See Also

Reference

Graph Class
AddVertex Overload
VelocityGraph Namespace


Graph.Clear Method

GraphClear Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Clear"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.CombineIntersection Method

GraphCombineIntersection Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.CombineIntersection(System.Collections.Generic.HashSet{VelocityGraph.Edge},System.Collections.Generic.HashSet{VelocityGraph.Edge})"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static HashSet<Edge> CombineIntersection(
    HashSet<Edge> objs1,
    HashSet<Edge> objs2
)
Public Shared Function CombineIntersection (
    objs1 As HashSet(Of Edge),
    objs2 As HashSet(Of Edge)
) As HashSet(Of Edge)
public:
static HashSet<Edge^>^ CombineIntersection(
    HashSet<Edge^>^ objs1,
    HashSet<Edge^>^ objs2
)
static member CombineIntersection :
        objs1 : HashSet<Edge> *
        objs2 : HashSet<Edge> -> HashSet<Edge>

Parameters

objs1
Type: System.Collections.GenericHashSet Edge

[Missing <param name="objs1"/> documentation for "M:VelocityGraph.Graph.CombineIntersection(System.Collections.Generic.HashSet{VelocityGraph.Edge},System.Collections.Generic.HashSet{VelocityGraph.Edge})"]

objs2
Type: System.Collections.GenericHashSet Edge

[Missing <param name="objs2"/> documentation for "M:VelocityGraph.Graph.CombineIntersection(System.Collections.Generic.HashSet{VelocityGraph.Edge},System.Collections.Generic.HashSet{VelocityGraph.Edge})"]

Return Value

Type: HashSet Edge

[Missing <returns> documentation for "M:VelocityGraph.Graph.CombineIntersection(System.Collections.Generic.HashSet{VelocityGraph.Edge},System.Collections.Generic.HashSet{VelocityGraph.Edge})"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ContainsVertex Method

GraphContainsVertex Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.ContainsVertex(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsVertex(
    int vertexId
)
Public Function ContainsVertex (
    vertexId As Integer
) As Boolean
public:
bool ContainsVertex(
    int vertexId
)
member ContainsVertex :
        vertexId : int -> bool

Parameters

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.Graph.ContainsVertex(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.Graph.ContainsVertex(System.Int32)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.CountEdges Method

GraphCountEdges Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.CountEdges"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long CountEdges()
Public Function CountEdges As Long
public:
long long CountEdges()
member CountEdges : unit -> int64

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.Graph.CountEdges"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.CountVertices Method

GraphCountVertices Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.CountVertices"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long CountVertices()
Public Function CountVertices As Long
public:
long long CountVertices()
member CountVertices : unit -> int64

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.Graph.CountVertices"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Edges Method

GraphEdges Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Edges(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> Edges(
    EdgeType etype,
    Vertex tail,
    Vertex head
)
Public Function Edges (
    etype As EdgeType,
    tail As Vertex,
    head As Vertex
) As IEnumerable(Of IEdge)
public:
IEnumerable<IEdge^>^ Edges(
    EdgeType^ etype,
    Vertex^ tail,
    Vertex^ head
)
member Edges :
        etype : EdgeType *
        tail : Vertex *
        head : Vertex -> IEnumerable<IEdge>

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.Graph.Edges(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

tail
Type: VelocityGraphVertex

[Missing <param name="tail"/> documentation for "M:VelocityGraph.Graph.Edges(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

head
Type: VelocityGraphVertex

[Missing <param name="head"/> documentation for "M:VelocityGraph.Graph.Edges(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.Edges(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ExportToGraphJson Method

GraphExportToGraphJson Method

Overload List
 | Name | Description
Public method | ExportToGraphJson(Stream) |
Public method | ExportToGraphJson(String) |
Public method | ExportToGraphJson(Stream, GraphJsonSettings) |
Public method | ExportToGraphJson(String, GraphJsonSettings) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ExportToGraphJson Method (Stream)

GraphExportToGraphJson Method (Stream)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.IO.Stream)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphJson(
    Stream jsonOutputStream
)
Public Sub ExportToGraphJson (
    jsonOutputStream As Stream
)
public:
void ExportToGraphJson(
    Stream^ jsonOutputStream
)
member ExportToGraphJson :
        jsonOutputStream : Stream -> unit

Parameters

jsonOutputStream
Type: System.IOStream

[Missing <param name="jsonOutputStream"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.IO.Stream)"]

See Also

Reference

Graph Class
ExportToGraphJson Overload
VelocityGraph Namespace


Graph.ExportToGraphJson Method (String)

GraphExportToGraphJson Method (String)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphJson(
    string filename
)
Public Sub ExportToGraphJson (
    filename As String
)
public:
void ExportToGraphJson(
    String^ filename
)
member ExportToGraphJson :
        filename : string -> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.String)"]

See Also

Reference

Graph Class
ExportToGraphJson Overload
VelocityGraph Namespace


Graph.ExportToGraphJson Method (Stream, GraphJsonSettings)

GraphExportToGraphJson Method (Stream, GraphJsonSettings)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.IO.Stream,VelocityGraph.GraphJsonSettings)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphJson(
    Stream jsonOutputStream,
    GraphJsonSettings settings
)
Public Sub ExportToGraphJson (
    jsonOutputStream As Stream,
    settings As GraphJsonSettings
)
public:
void ExportToGraphJson(
    Stream^ jsonOutputStream,
    GraphJsonSettings^ settings
)
member ExportToGraphJson :
        jsonOutputStream : Stream *
        settings : GraphJsonSettings -> unit

Parameters

jsonOutputStream
Type: System.IOStream

[Missing <param name="jsonOutputStream"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.IO.Stream,VelocityGraph.GraphJsonSettings)"]

settings
Type: VelocityGraphGraphJsonSettings

[Missing <param name="settings"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.IO.Stream,VelocityGraph.GraphJsonSettings)"]

See Also

Reference

Graph Class
ExportToGraphJson Overload
VelocityGraph Namespace


Graph.ExportToGraphJson Method (String, GraphJsonSettings)

GraphExportToGraphJson Method (String, GraphJsonSettings)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.String,VelocityGraph.GraphJsonSettings)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphJson(
    string filename,
    GraphJsonSettings settings
)
Public Sub ExportToGraphJson (
    filename As String,
    settings As GraphJsonSettings
)
public:
void ExportToGraphJson(
    String^ filename,
    GraphJsonSettings^ settings
)
member ExportToGraphJson :
        filename : string *
        settings : GraphJsonSettings -> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.String,VelocityGraph.GraphJsonSettings)"]

settings
Type: VelocityGraphGraphJsonSettings

[Missing <param name="settings"/> documentation for "M:VelocityGraph.Graph.ExportToGraphJson(System.String,VelocityGraph.GraphJsonSettings)"]

See Also

Reference

Graph Class
ExportToGraphJson Overload
VelocityGraph Namespace


Graph.ExportToGraphSon Method

GraphExportToGraphSon Method

Overload List
 | Name | Description
Public method | ExportToGraphSon(Stream, IEnumerableString, IEnumerableString, GraphSonMode) |
Public method | ExportToGraphSon(String, IEnumerableString, IEnumerableString, GraphSonMode) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ExportToGraphSon Method (Stream, IEnumerable(String), IEnumerable(String), GraphSonMode)

GraphExportToGraphSon Method (Stream, IEnumerableString, IEnumerableString, GraphSonMode)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.IO.Stream,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphSon(
    Stream jsonOutputStream,
    IEnumerable<string> vertexPropertyKeys = null,
    IEnumerable<string> edgePropertyKeys = null,
    GraphSonMode mode = GraphSonMode.NORMAL
)
Public Sub ExportToGraphSon (
    jsonOutputStream As Stream,
    Optional vertexPropertyKeys As IEnumerable(Of String) = Nothing,
    Optional edgePropertyKeys As IEnumerable(Of String) = Nothing,
    Optional mode As GraphSonMode = GraphSonMode.NORMAL
)
public:
void ExportToGraphSon(
    Stream^ jsonOutputStream,
    IEnumerable<String^>^ vertexPropertyKeys = nullptr,
    IEnumerable<String^>^ edgePropertyKeys = nullptr,
    GraphSonMode mode = GraphSonMode::NORMAL
)
member ExportToGraphSon :
        jsonOutputStream : Stream *
        ?vertexPropertyKeys : IEnumerable<string> *
        ?edgePropertyKeys : IEnumerable<string> *
        ?mode : GraphSonMode
(* Defaults:
        let _vertexPropertyKeys = defaultArg vertexPropertyKeys null
        let _edgePropertyKeys = defaultArg edgePropertyKeys null
        let _mode = defaultArg mode GraphSonMode.NORMAL
*)
-> unit

Parameters

jsonOutputStream
Type: System.IOStream

[Missing <param name="jsonOutputStream"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.IO.Stream,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

vertexPropertyKeys (Optional)
Type: System.Collections.GenericIEnumerable String

[Missing <param name="vertexPropertyKeys"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.IO.Stream,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

edgePropertyKeys (Optional)
Type: System.Collections.GenericIEnumerable String

[Missing <param name="edgePropertyKeys"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.IO.Stream,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

mode (Optional)
Type: GraphSonMode

[Missing <param name="mode"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.IO.Stream,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

See Also

Reference

Graph Class
ExportToGraphSon Overload
VelocityGraph Namespace


Graph.ExportToGraphSon Method (String, IEnumerable(String), IEnumerable(String), GraphSonMode)

GraphExportToGraphSon Method (String, IEnumerableString, IEnumerableString, GraphSonMode)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.String,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ExportToGraphSon(
    string filename,
    IEnumerable<string> vertexPropertyKeys = null,
    IEnumerable<string> edgePropertyKeys = null,
    GraphSonMode mode = GraphSonMode.NORMAL
)
Public Sub ExportToGraphSon (
    filename As String,
    Optional vertexPropertyKeys As IEnumerable(Of String) = Nothing,
    Optional edgePropertyKeys As IEnumerable(Of String) = Nothing,
    Optional mode As GraphSonMode = GraphSonMode.NORMAL
)
public:
void ExportToGraphSon(
    String^ filename,
    IEnumerable<String^>^ vertexPropertyKeys = nullptr,
    IEnumerable<String^>^ edgePropertyKeys = nullptr,
    GraphSonMode mode = GraphSonMode::NORMAL
)
member ExportToGraphSon :
        filename : string *
        ?vertexPropertyKeys : IEnumerable<string> *
        ?edgePropertyKeys : IEnumerable<string> *
        ?mode : GraphSonMode
(* Defaults:
        let _vertexPropertyKeys = defaultArg vertexPropertyKeys null
        let _edgePropertyKeys = defaultArg edgePropertyKeys null
        let _mode = defaultArg mode GraphSonMode.NORMAL
*)
-> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.String,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

vertexPropertyKeys (Optional)
Type: System.Collections.GenericIEnumerable String

[Missing <param name="vertexPropertyKeys"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.String,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

edgePropertyKeys (Optional)
Type: System.Collections.GenericIEnumerable String

[Missing <param name="edgePropertyKeys"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.String,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

mode (Optional)
Type: GraphSonMode

[Missing <param name="mode"/> documentation for "M:VelocityGraph.Graph.ExportToGraphSon(System.String,System.Collections.Generic.IEnumerable{System.String},System.Collections.Generic.IEnumerable{System.String},Frontenac.Blueprints.Util.IO.GraphSON.GraphSonMode)"]

See Also

Reference

Graph Class
ExportToGraphSon Overload
VelocityGraph Namespace


Graph.FindEdgeType Method

GraphFindEdgeType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindEdgeType(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType FindEdgeType(
    string name
)
Public Function FindEdgeType (
    name As String
) As EdgeType
public:
EdgeType^ FindEdgeType(
    String^ name
)
member FindEdgeType :
        name : string -> EdgeType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.FindEdgeType(System.String)"]

Return Value

Type: EdgeType

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindEdgeType(System.String)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.FindEdgeTypes Method

GraphFindEdgeTypes Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindEdgeTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<EdgeType> FindEdgeTypes()
Public Function FindEdgeTypes As IEnumerable(Of EdgeType)
public:
IEnumerable<EdgeType^>^ FindEdgeTypes()
member FindEdgeTypes : unit -> IEnumerable<EdgeType>

Return Value

Type: IEnumerable EdgeType

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindEdgeTypes"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.FindVertex Method

GraphFindVertex Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindVertex(VelocityGraph.PropertyType,System.IComparable,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex FindVertex(
    PropertyType property,
    IComparable v,
    bool errorIfNotFound = true
)
Public Function FindVertex (
    property As PropertyType,
    v As IComparable,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
Vertex^ FindVertex(
    PropertyType^ property,
    IComparable^ v,
    bool errorIfNotFound = true
)
member FindVertex :
        property : PropertyType *
        v : IComparable *
        ?errorIfNotFound : bool
(* Defaults:
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Graph.FindVertex(VelocityGraph.PropertyType,System.IComparable,System.Boolean)"]

v
Type: SystemIComparable

[Missing <param name="v"/> documentation for "M:VelocityGraph.Graph.FindVertex(VelocityGraph.PropertyType,System.IComparable,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.Graph.FindVertex(VelocityGraph.PropertyType,System.IComparable,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindVertex(VelocityGraph.PropertyType,System.IComparable,System.Boolean)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.FindVertexProperty Method

GraphFindVertexProperty Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindVertexProperty(VelocityGraph.VertexType,System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType FindVertexProperty(
    VertexType vertexType,
    string name
)
Public Function FindVertexProperty (
    vertexType As VertexType,
    name As String
) As PropertyType
public:
PropertyType^ FindVertexProperty(
    VertexType^ vertexType,
    String^ name
)
member FindVertexProperty :
        vertexType : VertexType *
        name : string -> PropertyType

Parameters

vertexType
Type: VelocityGraphVertexType

[Missing <param name="vertexType"/> documentation for "M:VelocityGraph.Graph.FindVertexProperty(VelocityGraph.VertexType,System.String)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.FindVertexProperty(VelocityGraph.VertexType,System.String)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindVertexProperty(VelocityGraph.VertexType,System.String)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.FindVertexType Method

GraphFindVertexType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindVertexType(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType FindVertexType(
    string name
)
Public Function FindVertexType (
    name As String
) As VertexType
public:
VertexType^ FindVertexType(
    String^ name
)
member FindVertexType :
        name : string -> VertexType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.FindVertexType(System.String)"]

Return Value

Type: VertexType

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindVertexType(System.String)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.FindVertexTypes Method

GraphFindVertexTypes Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.FindVertexTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<VertexType> FindVertexTypes()
Public Function FindVertexTypes As IEnumerable(Of VertexType)
public:
IEnumerable<VertexType^>^ FindVertexTypes()
member FindVertexTypes : unit -> IEnumerable<VertexType>

Return Value

Type: IEnumerable VertexType

[Missing <returns> documentation for "M:VelocityGraph.Graph.FindVertexTypes"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetEdge Method

GraphGetEdge Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetEdge(System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEdge GetEdge(
    Object id
)
Public Function GetEdge (
    id As Object
) As IEdge
public:
virtual IEdge^ GetEdge(
    Object^ id
) sealed
abstract GetEdge :
        id : Object -> IEdge
override GetEdge :
        id : Object -> IEdge

Parameters

id
Type: SystemObject

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.GetEdge(System.Object)"]

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetEdge(System.Object)"]

Implements

IGraph.GetEdge(Object)
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetEdges Method

GraphGetEdges Method

Overload List
 | Name | Description
Public method | GetEdges |
Public method | GetEdges(String, Object) |
Public method | GetEdgesT(String, T) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetEdges Method

GraphGetEdges Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetEdges"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges()
Public Function GetEdges As IEnumerable(Of IEdge)
public:
virtual IEnumerable<IEdge^>^ GetEdges() sealed
abstract GetEdges : unit -> IEnumerable<IEdge>
override GetEdges : unit -> IEnumerable<IEdge>

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetEdges"]

Implements

IGraph.GetEdges
See Also

Reference

Graph Class
GetEdges Overload
VelocityGraph Namespace


Graph.GetEdges Method (String, Object)

GraphGetEdges Method (String, Object)

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetEdges(System.String,System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<IEdge> GetEdges(
    string key,
    Object value
)
Public Overridable Function GetEdges (
    key As String,
    value As Object
) As IEnumerable(Of IEdge)
public:
virtual IEnumerable<IEdge^>^ GetEdges(
    String^ key,
    Object^ value
)
abstract GetEdges :
        key : string *
        value : Object -> IEnumerable<IEdge>
override GetEdges :
        key : string *
        value : Object -> IEnumerable<IEdge>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Graph.GetEdges(System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:VelocityGraph.Graph.GetEdges(System.String,System.Object)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetEdges(System.String,System.Object)"]

Implements

IGraph.GetEdges(String, Object)
See Also

Reference

Graph Class
GetEdges Overload
VelocityGraph Namespace


Graph.GetEdges(T) Method (String, T)

GraphGetEdgesT Method (String, T)

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetEdges``1(System.String,``0)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<IEdge> GetEdges<T>(
    string key,
    T value
)
where T : IComparable

Public Overridable Function GetEdges(Of T As IComparable) (
    key As String,
    value As T
) As IEnumerable(Of IEdge)
public:
generic<typename T>
where T : IComparable
virtual IEnumerable<IEdge^>^ GetEdges(
    String^ key,
    T value
)
abstract GetEdges :
        key : string *
        value : 'T -> IEnumerable<IEdge>  when 'T : IComparable
override GetEdges :
        key : string *
        value : 'T -> IEnumerable<IEdge>  when 'T : IComparable

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Graph.GetEdges``1(System.String,``0)"]

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.Graph.GetEdges``1(System.String,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:VelocityGraph.Graph.GetEdges``1(System.String,``0)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetEdges``1(System.String,``0)"]

See Also

Reference

Graph Class
GetEdges Overload
VelocityGraph Namespace


Graph.GetEdgeType Method

GraphGetEdgeType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetEdgeType(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType GetEdgeType(
    int id
)
Public Function GetEdgeType (
    id As Integer
) As EdgeType
public:
EdgeType^ GetEdgeType(
    int id
)
member GetEdgeType :
        id : int -> EdgeType

Parameters

id
Type: SystemInt32

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.GetEdgeType(System.Int32)"]

Return Value

Type: EdgeType

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetEdgeType(System.Int32)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetValues Method

GraphGetValues Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetValues(VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IComparable> GetValues(
    PropertyType property
)
Public Function GetValues (
    property As PropertyType
) As IEnumerable(Of IComparable)
public:
IEnumerable<IComparable^>^ GetValues(
    PropertyType^ property
)
member GetValues :
        property : PropertyType -> IEnumerable<IComparable>

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Graph.GetValues(VelocityGraph.PropertyType)"]

Return Value

Type: IEnumerable IComparable

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetValues(VelocityGraph.PropertyType)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetVertex Method

GraphGetVertex Method

Overload List
 | Name | Description
Public method | GetVertex(Int32) |
Public method | GetVertex(Object) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetVertex Method (Int32)

GraphGetVertex Method (Int32)

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetVertex(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex GetVertex(
    int id
)
Public Function GetVertex (
    id As Integer
) As Vertex
public:
Vertex^ GetVertex(
    int id
)
member GetVertex :
        id : int -> Vertex

Parameters

id
Type: SystemInt32

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.GetVertex(System.Int32)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetVertex(System.Int32)"]

See Also

Reference

Graph Class
GetVertex Overload
VelocityGraph Namespace


Graph.GetVertex Method (Object)

GraphGetVertex Method (Object)

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetVertex(System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IVertex GetVertex(
    Object id
)
Public Function GetVertex (
    id As Object
) As IVertex
public:
virtual IVertex^ GetVertex(
    Object^ id
) sealed
abstract GetVertex :
        id : Object -> IVertex
override GetVertex :
        id : Object -> IVertex

Parameters

id
Type: SystemObject

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.GetVertex(System.Object)"]

Return Value

Type: IVertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetVertex(System.Object)"]

Implements

IGraph.GetVertex(Object)
See Also

Reference

Graph Class
GetVertex Overload
VelocityGraph Namespace


Graph.GetVertexType Method

GraphGetVertexType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetVertexType(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType GetVertexType(
    int id
)
Public Function GetVertexType (
    id As Integer
) As VertexType
public:
VertexType^ GetVertexType(
    int id
)
member GetVertexType :
        id : int -> VertexType

Parameters

id
Type: SystemInt32

[Missing <param name="id"/> documentation for "M:VelocityGraph.Graph.GetVertexType(System.Int32)"]

Return Value

Type: VertexType

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetVertexType(System.Int32)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetVertices Method

GraphGetVertices Method

Overload List
 | Name | Description
Public method | GetVertices |
Public method | GetVertices(String, Object) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.GetVertices Method

GraphGetVertices Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetVertices"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IVertex> GetVertices()
Public Function GetVertices As IEnumerable(Of IVertex)
public:
virtual IEnumerable<IVertex^>^ GetVertices() sealed
abstract GetVertices : unit -> IEnumerable<IVertex>
override GetVertices : unit -> IEnumerable<IVertex>

Return Value

Type: IEnumerable IVertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetVertices"]

Implements

IGraph.GetVertices
See Also

Reference

Graph Class
GetVertices Overload
VelocityGraph Namespace


Graph.GetVertices Method (String, Object)

GraphGetVertices Method (String, Object)

[Missing <summary> documentation for "M:VelocityGraph.Graph.GetVertices(System.String,System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IVertex> GetVertices(
    string key,
    Object value
)
Public Function GetVertices (
    key As String,
    value As Object
) As IEnumerable(Of IVertex)
public:
virtual IEnumerable<IVertex^>^ GetVertices(
    String^ key,
    Object^ value
) sealed
abstract GetVertices :
        key : string *
        value : Object -> IEnumerable<IVertex>
override GetVertices :
        key : string *
        value : Object -> IEnumerable<IVertex>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Graph.GetVertices(System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:VelocityGraph.Graph.GetVertices(System.String,System.Object)"]

Return Value

Type: IEnumerable IVertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.GetVertices(System.String,System.Object)"]

Implements

IGraph.GetVertices(String, Object)
See Also

Reference

Graph Class
GetVertices Overload
VelocityGraph Namespace


Graph.ImportGraphJson Method

GraphImportGraphJson Method

Overload List
 | Name | Description
Public method | ImportGraphJson(String) |
Public method | ImportGraphJson(Stream, Int32) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ImportGraphJson Method (String)

GraphImportGraphJson Method (String)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ImportGraphJson(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ImportGraphJson(
    string filename
)
Public Sub ImportGraphJson (
    filename As String
)
public:
void ImportGraphJson(
    String^ filename
)
member ImportGraphJson :
        filename : string -> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:VelocityGraph.Graph.ImportGraphJson(System.String)"]

See Also

Reference

Graph Class
ImportGraphJson Overload
VelocityGraph Namespace


Graph.ImportGraphJson Method (Stream, Int32)

GraphImportGraphJson Method (Stream, Int32)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ImportGraphJson(System.IO.Stream,System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ImportGraphJson(
    Stream grapJsonInputStream,
    int bufferSize = 1000
)
Public Sub ImportGraphJson (
    grapJsonInputStream As Stream,
    Optional bufferSize As Integer = 1000
)
public:
void ImportGraphJson(
    Stream^ grapJsonInputStream,
    int bufferSize = 1000
)
member ImportGraphJson :
        grapJsonInputStream : Stream *
        ?bufferSize : int
(* Defaults:
        let _bufferSize = defaultArg bufferSize 1000
*)
-> unit

Parameters

grapJsonInputStream
Type: System.IOStream

[Missing <param name="grapJsonInputStream"/> documentation for "M:VelocityGraph.Graph.ImportGraphJson(System.IO.Stream,System.Int32)"]

bufferSize (Optional)
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:VelocityGraph.Graph.ImportGraphJson(System.IO.Stream,System.Int32)"]

See Also

Reference

Graph Class
ImportGraphJson Overload
VelocityGraph Namespace


Graph.ImportGraphSon Method

GraphImportGraphSon Method

Overload List
 | Name | Description
Public method | ImportGraphSon(String) |
Public method | ImportGraphSon(Stream, Int32) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ImportGraphSon Method (String)

GraphImportGraphSon Method (String)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ImportGraphSon(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ImportGraphSon(
    string filename
)
Public Sub ImportGraphSon (
    filename As String
)
public:
void ImportGraphSon(
    String^ filename
)
member ImportGraphSon :
        filename : string -> unit

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:VelocityGraph.Graph.ImportGraphSon(System.String)"]

See Also

Reference

Graph Class
ImportGraphSon Overload
VelocityGraph Namespace


Graph.ImportGraphSon Method (Stream, Int32)

GraphImportGraphSon Method (Stream, Int32)

[Missing <summary> documentation for "M:VelocityGraph.Graph.ImportGraphSon(System.IO.Stream,System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void ImportGraphSon(
    Stream jsonInputStream,
    int bufferSize
)
Public Sub ImportGraphSon (
    jsonInputStream As Stream,
    bufferSize As Integer
)
public:
void ImportGraphSon(
    Stream^ jsonInputStream,
    int bufferSize
)
member ImportGraphSon :
        jsonInputStream : Stream *
        bufferSize : int -> unit

Parameters

jsonInputStream
Type: System.IOStream

[Missing <param name="jsonInputStream"/> documentation for "M:VelocityGraph.Graph.ImportGraphSon(System.IO.Stream,System.Int32)"]

bufferSize
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:VelocityGraph.Graph.ImportGraphSon(System.IO.Stream,System.Int32)"]

See Also

Reference

Graph Class
ImportGraphSon Overload
VelocityGraph Namespace


Graph.NewEdge Method

GraphNewEdge Method

Overload List
 | Name | Description
Public method | NewEdge(EdgeType, Vertex, Vertex) |
Public method | NewEdge(EdgeType, PropertyType, Object, PropertyType, Object) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.NewEdge Method (EdgeType, Vertex, Vertex)

GraphNewEdge Method (EdgeType, Vertex, Vertex)

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge NewEdge(
    EdgeType edgeType,
    Vertex tail,
    Vertex head
)
Public Function NewEdge (
    edgeType As EdgeType,
    tail As Vertex,
    head As Vertex
) As Edge
public:
Edge^ NewEdge(
    EdgeType^ edgeType,
    Vertex^ tail,
    Vertex^ head
)
member NewEdge :
        edgeType : EdgeType *
        tail : Vertex *
        head : Vertex -> Edge

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

tail
Type: VelocityGraphVertex

[Missing <param name="tail"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

head
Type: VelocityGraphVertex

[Missing <param name="head"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex,VelocityGraph.Vertex)"]

See Also

Reference

Graph Class
NewEdge Overload
VelocityGraph Namespace


Graph.NewEdge Method (EdgeType, PropertyType, Object, PropertyType, Object)

GraphNewEdge Method (EdgeType, PropertyType, Object, PropertyType, Object)

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEdge NewEdge(
    EdgeType edgeType,
    PropertyType tailAttr,
    Object tailV,
    PropertyType headAttr,
    Object headV
)
Public Function NewEdge (
    edgeType As EdgeType,
    tailAttr As PropertyType,
    tailV As Object,
    headAttr As PropertyType,
    headV As Object
) As IEdge
public:
IEdge^ NewEdge(
    EdgeType^ edgeType,
    PropertyType^ tailAttr,
    Object^ tailV,
    PropertyType^ headAttr,
    Object^ headV
)
member NewEdge :
        edgeType : EdgeType *
        tailAttr : PropertyType *
        tailV : Object *
        headAttr : PropertyType *
        headV : Object -> IEdge

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

tailAttr
Type: VelocityGraphPropertyType

[Missing <param name="tailAttr"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

tailV
Type: SystemObject

[Missing <param name="tailV"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

headAttr
Type: VelocityGraphPropertyType

[Missing <param name="headAttr"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

headV
Type: SystemObject

[Missing <param name="headV"/> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewEdge(VelocityGraph.EdgeType,VelocityGraph.PropertyType,System.Object,VelocityGraph.PropertyType,System.Object)"]

See Also

Reference

Graph Class
NewEdge Overload
VelocityGraph Namespace


Graph.NewEdgeProperty Method

GraphNewEdgeProperty Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType NewEdgeProperty(
    EdgeType edgeType,
    string name,
    DataType dt,
    PropertyKind kind
)
Public Function NewEdgeProperty (
    edgeType As EdgeType,
    name As String,
    dt As DataType,
    kind As PropertyKind
) As PropertyType
public:
PropertyType^ NewEdgeProperty(
    EdgeType^ edgeType,
    String^ name,
    DataType dt,
    PropertyKind kind
)
member NewEdgeProperty :
        edgeType : EdgeType *
        name : string *
        dt : DataType *
        kind : PropertyKind -> PropertyType

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

dt
Type: VelocityGraphDataType

[Missing <param name="dt"/> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

kind
Type: VelocityGraphPropertyKind

[Missing <param name="kind"/> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewEdgeProperty(VelocityGraph.EdgeType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.NewEdgeType Method

GraphNewEdgeType Method

Overload List
 | Name | Description
Public method | NewEdgeType(String, Boolean, EdgeType) |
Public method | NewEdgeType(String, Boolean, VertexType, VertexType, EdgeType) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.NewEdgeType Method (String, Boolean, EdgeType)

GraphNewEdgeType Method (String, Boolean, EdgeType)

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType NewEdgeType(
    string name,
    bool biderectional,
    EdgeType baseType = null
)
Public Function NewEdgeType (
    name As String,
    biderectional As Boolean,
    Optional baseType As EdgeType = Nothing
) As EdgeType
public:
EdgeType^ NewEdgeType(
    String^ name,
    bool biderectional,
    EdgeType^ baseType = nullptr
)
member NewEdgeType :
        name : string *
        biderectional : bool *
        ?baseType : EdgeType
(* Defaults:
        let _baseType = defaultArg baseType null
*)
-> EdgeType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.EdgeType)"]

biderectional
Type: SystemBoolean

[Missing <param name="biderectional"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.EdgeType)"]

baseType (Optional)
Type: VelocityGraphEdgeType

[Missing <param name="baseType"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.EdgeType)"]

Return Value

Type: EdgeType

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.EdgeType)"]

See Also

Reference

Graph Class
NewEdgeType Overload
VelocityGraph Namespace


Graph.NewEdgeType Method (String, Boolean, VertexType, VertexType, EdgeType)

GraphNewEdgeType Method (String, Boolean, VertexType, VertexType, EdgeType)

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public EdgeType NewEdgeType(
    string name,
    bool biderectional,
    VertexType tailType,
    VertexType headType,
    EdgeType baseType = null
)
Public Function NewEdgeType (
    name As String,
    biderectional As Boolean,
    tailType As VertexType,
    headType As VertexType,
    Optional baseType As EdgeType = Nothing
) As EdgeType
public:
EdgeType^ NewEdgeType(
    String^ name,
    bool biderectional,
    VertexType^ tailType,
    VertexType^ headType,
    EdgeType^ baseType = nullptr
)
member NewEdgeType :
        name : string *
        biderectional : bool *
        tailType : VertexType *
        headType : VertexType *
        ?baseType : EdgeType
(* Defaults:
        let _baseType = defaultArg baseType null
*)
-> EdgeType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

biderectional
Type: SystemBoolean

[Missing <param name="biderectional"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

tailType
Type: VelocityGraphVertexType

[Missing <param name="tailType"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

headType
Type: VelocityGraphVertexType

[Missing <param name="headType"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

baseType (Optional)
Type: VelocityGraphEdgeType

[Missing <param name="baseType"/> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

Return Value

Type: EdgeType

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewEdgeType(System.String,System.Boolean,VelocityGraph.VertexType,VelocityGraph.VertexType,VelocityGraph.EdgeType)"]

See Also

Reference

Graph Class
NewEdgeType Overload
VelocityGraph Namespace


Graph.NewVertex Method

GraphNewVertex Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewVertex(VelocityGraph.VertexType,System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex NewVertex(
    VertexType vertexType,
    int vId = 0
)
Public Function NewVertex (
    vertexType As VertexType,
    Optional vId As Integer = 0
) As Vertex
public:
Vertex^ NewVertex(
    VertexType^ vertexType,
    int vId = 0
)
member NewVertex :
        vertexType : VertexType *
        ?vId : int
(* Defaults:
        let _vId = defaultArg vId 0
*)
-> Vertex

Parameters

vertexType
Type: VelocityGraphVertexType

[Missing <param name="vertexType"/> documentation for "M:VelocityGraph.Graph.NewVertex(VelocityGraph.VertexType,System.Int32)"]

vId (Optional)
Type: SystemInt32

[Missing <param name="vId"/> documentation for "M:VelocityGraph.Graph.NewVertex(VelocityGraph.VertexType,System.Int32)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewVertex(VelocityGraph.VertexType,System.Int32)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.NewVertexProperty Method

GraphNewVertexProperty Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType NewVertexProperty(
    VertexType vertexType,
    string name,
    DataType dt,
    PropertyKind kind
)
Public Function NewVertexProperty (
    vertexType As VertexType,
    name As String,
    dt As DataType,
    kind As PropertyKind
) As PropertyType
public:
PropertyType^ NewVertexProperty(
    VertexType^ vertexType,
    String^ name,
    DataType dt,
    PropertyKind kind
)
member NewVertexProperty :
        vertexType : VertexType *
        name : string *
        dt : DataType *
        kind : PropertyKind -> PropertyType

Parameters

vertexType
Type: VelocityGraphVertexType

[Missing <param name="vertexType"/> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

dt
Type: VelocityGraphDataType

[Missing <param name="dt"/> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

kind
Type: VelocityGraphPropertyKind

[Missing <param name="kind"/> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewVertexProperty(VelocityGraph.VertexType,System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.NewVertexType Method

GraphNewVertexType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.NewVertexType(System.String,VelocityGraph.VertexType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType NewVertexType(
    string name,
    VertexType baseType = null
)
Public Function NewVertexType (
    name As String,
    Optional baseType As VertexType = Nothing
) As VertexType
public:
VertexType^ NewVertexType(
    String^ name,
    VertexType^ baseType = nullptr
)
member NewVertexType :
        name : string *
        ?baseType : VertexType
(* Defaults:
        let _baseType = defaultArg baseType null
*)
-> VertexType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.Graph.NewVertexType(System.String,VelocityGraph.VertexType)"]

baseType (Optional)
Type: VelocityGraphVertexType

[Missing <param name="baseType"/> documentation for "M:VelocityGraph.Graph.NewVertexType(System.String,VelocityGraph.VertexType)"]

Return Value

Type: VertexType

[Missing <returns> documentation for "M:VelocityGraph.Graph.NewVertexType(System.String,VelocityGraph.VertexType)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Open Method

GraphOpen Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Open(VelocityDb.Session.SessionBase,System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static Graph Open(
    SessionBase session,
    int graphInstance = 0
)
Public Shared Function Open (
    session As SessionBase,
    Optional graphInstance As Integer = 0
) As Graph
public:
static Graph^ Open(
    SessionBase^ session,
    int graphInstance = 0
)
static member Open :
        session : SessionBase *
        ?graphInstance : int
(* Defaults:
        let _graphInstance = defaultArg graphInstance 0
*)
-> Graph

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.Graph.Open(VelocityDb.Session.SessionBase,System.Int32)"]

graphInstance (Optional)
Type: SystemInt32

[Missing <param name="graphInstance"/> documentation for "M:VelocityGraph.Graph.Open(VelocityDb.Session.SessionBase,System.Int32)"]

Return Value

Type: Graph

[Missing <returns> documentation for "M:VelocityGraph.Graph.Open(VelocityDb.Session.SessionBase,System.Int32)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Persist Method

GraphPersist Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override ulong Persist(
    Placement place,
    SessionBase session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable> toPersist = null
)
Public Overrides Function Persist (
    place As Placement,
    session As SessionBase,
    Optional persistRefs As Boolean = true,
    Optional disableFlush As Boolean = false,
    Optional toPersist As Queue(Of IOptimizedPersistable) = Nothing
) As ULong
public:
virtual unsigned long long Persist(
    Placement^ place,
    SessionBase^ session,
    bool persistRefs = true,
    bool disableFlush = false,
    Queue<IOptimizedPersistable^>^ toPersist = nullptr
) override
abstract Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64
override Persist :
        place : Placement *
        session : SessionBase *
        ?persistRefs : bool *
        ?disableFlush : bool *
        ?toPersist : Queue<IOptimizedPersistable>
(* Defaults:
        let _persistRefs = defaultArg persistRefs true
        let _disableFlush = defaultArg disableFlush false
        let _toPersist = defaultArg toPersist null
*)
-> uint64

Parameters

place
Type: VelocityDbPlacement

[Missing <param name="place"/> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

persistRefs (Optional)
Type: SystemBoolean

[Missing <param name="persistRefs"/> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

disableFlush (Optional)
Type: SystemBoolean

[Missing <param name="disableFlush"/> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

toPersist (Optional)
Type: System.Collections.GenericQueue IOptimizedPersistable

[Missing <param name="toPersist"/> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:VelocityGraph.Graph.Persist(VelocityDb.Placement,VelocityDb.Session.SessionBase,System.Boolean,System.Boolean,System.Collections.Generic.Queue{VelocityDb.IOptimizedPersistable})"]

Implements

IOptimizedPersistablePersist(Placement, SessionBase, Boolean, Boolean, QueueIOptimizedPersistable)
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Query Method

GraphQuery Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Query"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IQuery Query()
Public Function Query As IQuery
public:
virtual IQuery^ Query() sealed
abstract Query : unit -> IQuery
override Query : unit -> IQuery

Return Value

Type: IQuery

[Missing <returns> documentation for "M:VelocityGraph.Graph.Query"]

Implements

IGraph.Query
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.RemoveEdge Method

GraphRemoveEdge Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.RemoveEdge(Frontenac.Blueprints.IEdge)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemoveEdge(
    IEdge edge
)
Public Sub RemoveEdge (
    edge As IEdge
)
public:
virtual void RemoveEdge(
    IEdge^ edge
) sealed
abstract RemoveEdge :
        edge : IEdge -> unit
override RemoveEdge :
        edge : IEdge -> unit

Parameters

edge
Type: IEdge

[Missing <param name="edge"/> documentation for "M:VelocityGraph.Graph.RemoveEdge(Frontenac.Blueprints.IEdge)"]

Implements

IGraph.RemoveEdge(IEdge)
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.RemovePropertyType Method

GraphRemovePropertyType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.RemovePropertyType(VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemovePropertyType(
    PropertyType pt
)
Public Sub RemovePropertyType (
    pt As PropertyType
)
public:
void RemovePropertyType(
    PropertyType^ pt
)
member RemovePropertyType :
        pt : PropertyType -> unit

Parameters

pt
Type: VelocityGraphPropertyType

[Missing <param name="pt"/> documentation for "M:VelocityGraph.Graph.RemovePropertyType(VelocityGraph.PropertyType)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.RemoveVertex Method

GraphRemoveVertex Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.RemoveVertex(Frontenac.Blueprints.IVertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemoveVertex(
    IVertex vertex
)
Public Sub RemoveVertex (
    vertex As IVertex
)
public:
virtual void RemoveVertex(
    IVertex^ vertex
) sealed
abstract RemoveVertex :
        vertex : IVertex -> unit
override RemoveVertex :
        vertex : IVertex -> unit

Parameters

vertex
Type: IVertex

[Missing <param name="vertex"/> documentation for "M:VelocityGraph.Graph.RemoveVertex(Frontenac.Blueprints.IVertex)"]

Implements

IGraph.RemoveVertex(IVertex)
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.RemoveVertexType Method

GraphRemoveVertexType Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.RemoveVertexType(VelocityGraph.VertexType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemoveVertexType(
    VertexType type
)
Public Sub RemoveVertexType (
    type As VertexType
)
public:
void RemoveVertexType(
    VertexType^ type
)
member RemoveVertexType :
        type : VertexType -> unit

Parameters

type
Type: VelocityGraphVertexType

[Missing <param name="type"/> documentation for "M:VelocityGraph.Graph.RemoveVertexType(VelocityGraph.VertexType)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Select Method

GraphSelect Method

Overload List
 | Name | Description
Public method | Select(PropertyType, FuncIComparable, IComparable, Boolean, IComparable) |
Public method | Select(PropertyType, FuncIComparable, IComparable, IComparable, Boolean, IComparable, IComparable) |
Top
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Select Method (PropertyType, Func(IComparable, IComparable, Boolean), IComparable)

GraphSelect Method (PropertyType, FuncIComparable, IComparable, Boolean, IComparable)

[Missing <summary> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.Boolean},System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IElement> Select(
    PropertyType property,
    Func<IComparable, IComparable, bool> condition,
    IComparable value
)
Public Function Select (
    property As PropertyType,
    condition As Func(Of IComparable, IComparable, Boolean),
    value As IComparable
) As IEnumerable(Of IElement)
public:
IEnumerable<IElement^>^ Select(
    PropertyType^ property,
    Func<IComparable^, IComparable^, bool>^ condition,
    IComparable^ value
)
member Select :
        property : PropertyType *
        condition : Func<IComparable, IComparable, bool> *
        value : IComparable -> IEnumerable<IElement>

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.Boolean},System.IComparable)"]

condition
Type: SystemFunc IComparable, IComparable, Boolean

[Missing <param name="condition"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.Boolean},System.IComparable)"]

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.Boolean},System.IComparable)"]

Return Value

Type: IEnumerable IElement

[Missing <returns> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.Boolean},System.IComparable)"]

See Also

Reference

Graph Class
Select Overload
VelocityGraph Namespace


Graph.Select Method (PropertyType, Func(IComparable, IComparable, IComparable, Boolean), IComparable, IComparable)

GraphSelect Method (PropertyType, FuncIComparable, IComparable, IComparable, Boolean, IComparable, IComparable)

[Missing <summary> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IElement> Select(
    PropertyType property,
    Func<IComparable, IComparable, IComparable, bool> condition,
    IComparable lower,
    IComparable higher
)
Public Function Select (
    property As PropertyType,
    condition As Func(Of IComparable, IComparable, IComparable, Boolean),
    lower As IComparable,
    higher As IComparable
) As IEnumerable(Of IElement)
public:
IEnumerable<IElement^>^ Select(
    PropertyType^ property,
    Func<IComparable^, IComparable^, IComparable^, bool>^ condition,
    IComparable^ lower,
    IComparable^ higher
)
member Select :
        property : PropertyType *
        condition : Func<IComparable, IComparable, IComparable, bool> *
        lower : IComparable *
        higher : IComparable -> IEnumerable<IElement>

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

condition
Type: SystemFunc IComparable, IComparable, IComparable, Boolean

[Missing <param name="condition"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

lower
Type: SystemIComparable

[Missing <param name="lower"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

higher
Type: SystemIComparable

[Missing <param name="higher"/> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

Return Value

Type: IEnumerable IElement

[Missing <returns> documentation for "M:VelocityGraph.Graph.Select(VelocityGraph.PropertyType,System.Func{System.IComparable,System.IComparable,System.IComparable,System.Boolean},System.IComparable,System.IComparable)"]

See Also

Reference

Graph Class
Select Overload
VelocityGraph Namespace


Graph.Shutdown Method

GraphShutdown Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Shutdown"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Shutdown()
Public Sub Shutdown
public:
virtual void Shutdown() sealed
abstract Shutdown : unit -> unit
override Shutdown : unit -> unit

Implements

IGraph.Shutdown
See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.ToString Method

GraphToString Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.ToString"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityGraph.Graph.ToString"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Traverse Method

GraphTraverse Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Traverse(VelocityGraph.Vertex[],VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<Vertex, HashSet<Edge>> Traverse(
    Vertex[] vertices,
    EdgeType etype,
    Direction dir
)
Public Function Traverse (
    vertices As Vertex(),
    etype As EdgeType,
    dir As Direction
) As Dictionary(Of Vertex, HashSet(Of Edge))
public:
Dictionary<Vertex^, HashSet<Edge^>^>^ Traverse(
    array<Vertex^>^ vertices,
    EdgeType^ etype,
    Direction dir
)
member Traverse :
        vertices : Vertex[] *
        etype : EdgeType *
        dir : Direction -> Dictionary<Vertex, HashSet<Edge>>

Parameters

vertices
Type: VelocityGraphVertex

[Missing <param name="vertices"/> documentation for "M:VelocityGraph.Graph.Traverse(VelocityGraph.Vertex[],VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.Graph.Traverse(VelocityGraph.Vertex[],VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Graph.Traverse(VelocityGraph.Vertex[],VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: Dictionary Vertex, HashSet Edge

[Missing <returns> documentation for "M:VelocityGraph.Graph.Traverse(VelocityGraph.Vertex[],VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

Graph Class
VelocityGraph Namespace


Graph.Unpersist Method

GraphUnpersist Method

[Missing <summary> documentation for "M:VelocityGraph.Graph.Unpersist(VelocityDb.Session.SessionBase)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.Graph.Unpersist(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

Graph Class
VelocityGraph Namespace


GraphJsonSettings Class

[Missing <summary> documentation for "T:VelocityGraph.GraphJsonSettings"]

Inheritance Hierarchy
SystemObject
VelocityGraphGraphJsonSettings

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class GraphJsonSettings
Public Class GraphJsonSettings
public ref class GraphJsonSettings
type GraphJsonSettings =  class end

The GraphJsonSettings type exposes the following members.

Constructors
 | Name | Description
Public method | GraphJsonSettings | Initializes a new instance of the GraphJsonSettings class
Top
Properties
 | Name | Description
Public property | ClusterFuncProp |
Public property | ClusterProp |
 | Default |
Public property | EdgeCaptionProp |
Public property | EdgeTypeFuncProp |
Public property | IdProp |
Public property | NodeCaptionProp |
Public property | SourceProp |
Public property | TargetProp |
Public property | TypeProp |
Public property | VertexTypeFuncProp |
Top
See Also

Reference

VelocityGraph Namespace


GraphJsonSettings Constructor

Initializes a new instance of the GraphJsonSettings class

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public GraphJsonSettings()
Public Sub New
public:
GraphJsonSettings()
new : unit -> GraphJsonSettings
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings Properties

The GraphJsonSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClusterFuncProp |
Public property | ClusterProp |
 | Default |
Public property | EdgeCaptionProp |
Public property | EdgeTypeFuncProp |
Public property | IdProp |
Public property | NodeCaptionProp |
Public property | SourceProp |
Public property | TargetProp |
Public property | TypeProp |
Public property | VertexTypeFuncProp |
Top
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.ClusterFuncProp Property

GraphJsonSettingsClusterFuncProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.ClusterFuncProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Func<IVertex, int> ClusterFuncProp { get; set; }
Public Property ClusterFuncProp As Func(Of IVertex, Integer)
    Get
    Set
public:
property Func<IVertex^, int>^ ClusterFuncProp {
    Func<IVertex^, int>^ get ();
    void set (Func<IVertex^, int>^ value);
}
member ClusterFuncProp : Func<IVertex, int> with get, set

Property Value

Type: Func IVertex, Int32
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.ClusterProp Property

GraphJsonSettingsClusterProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.ClusterProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string ClusterProp { get; set; }
Public Property ClusterProp As String
    Get
    Set
public:
property String^ ClusterProp {
    String^ get ();
    void set (String^ value);
}
member ClusterProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.Default Property

GraphJsonSettingsDefault Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.Default"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public static GraphJsonSettings Default { get; }
Public Shared ReadOnly Property Default As GraphJsonSettings
    Get
public:
static property GraphJsonSettings^ Default {
    GraphJsonSettings^ get ();
}
static member Default : GraphJsonSettings with get

Property Value

Type: GraphJsonSettings
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.EdgeCaptionProp Property

GraphJsonSettingsEdgeCaptionProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.EdgeCaptionProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string EdgeCaptionProp { get; set; }
Public Property EdgeCaptionProp As String
    Get
    Set
public:
property String^ EdgeCaptionProp {
    String^ get ();
    void set (String^ value);
}
member EdgeCaptionProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.EdgeTypeFuncProp Property

GraphJsonSettingsEdgeTypeFuncProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.EdgeTypeFuncProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Func<IEdge, string> EdgeTypeFuncProp { get; set; }
Public Property EdgeTypeFuncProp As Func(Of IEdge, String)
    Get
    Set
public:
property Func<IEdge^, String^>^ EdgeTypeFuncProp {
    Func<IEdge^, String^>^ get ();
    void set (Func<IEdge^, String^>^ value);
}
member EdgeTypeFuncProp : Func<IEdge, string> with get, set

Property Value

Type: Func IEdge, String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.IdProp Property

GraphJsonSettingsIdProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.IdProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string IdProp { get; set; }
Public Property IdProp As String
    Get
    Set
public:
property String^ IdProp {
    String^ get ();
    void set (String^ value);
}
member IdProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.NodeCaptionProp Property

GraphJsonSettingsNodeCaptionProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.NodeCaptionProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string NodeCaptionProp { get; set; }
Public Property NodeCaptionProp As String
    Get
    Set
public:
property String^ NodeCaptionProp {
    String^ get ();
    void set (String^ value);
}
member NodeCaptionProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.SourceProp Property

GraphJsonSettingsSourceProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.SourceProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string SourceProp { get; set; }
Public Property SourceProp As String
    Get
    Set
public:
property String^ SourceProp {
    String^ get ();
    void set (String^ value);
}
member SourceProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.TargetProp Property

GraphJsonSettingsTargetProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.TargetProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string TargetProp { get; set; }
Public Property TargetProp As String
    Get
    Set
public:
property String^ TargetProp {
    String^ get ();
    void set (String^ value);
}
member TargetProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.TypeProp Property

GraphJsonSettingsTypeProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.TypeProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string TypeProp { get; set; }
Public Property TypeProp As String
    Get
    Set
public:
property String^ TypeProp {
    String^ get ();
    void set (String^ value);
}
member TypeProp : string with get, set

Property Value

Type: String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


GraphJsonSettings.VertexTypeFuncProp Property

GraphJsonSettingsVertexTypeFuncProp Property

[Missing <summary> documentation for "P:VelocityGraph.GraphJsonSettings.VertexTypeFuncProp"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Func<IVertex, string> VertexTypeFuncProp { get; set; }
Public Property VertexTypeFuncProp As Func(Of IVertex, String)
    Get
    Set
public:
property Func<IVertex^, String^>^ VertexTypeFuncProp {
    Func<IVertex^, String^>^ get ();
    void set (Func<IVertex^, String^>^ value);
}
member VertexTypeFuncProp : Func<IVertex, string> with get, set

Property Value

Type: Func IVertex, String
See Also

Reference

GraphJsonSettings Class
VelocityGraph Namespace


PropertyKind Enumeration

[Missing <summary> documentation for "T:VelocityGraph.PropertyKind"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public enum PropertyKind
Public Enumeration PropertyKind
public enum class PropertyKind
type PropertyKind
Members
Member name | Value | Description
Indexed | 0 |
Unique | 1 |
NotIndexed | 2 |
See Also

Reference

VelocityGraph Namespace


PropertyType Class

[Missing <summary> documentation for "T:VelocityGraph.PropertyType"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphPropertyType
VelocityGraphPropertyTypeTT

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class PropertyType : OptimizedPersistable
<SerializableAttribute>
Public MustInherit Class PropertyType
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class PropertyType abstract : public OptimizedPersistable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PropertyType =
    class
        inherit OptimizedPersistable
    end

The PropertyType type exposes the following members.

Properties
 | Name | Description
Public property | IsVertexProperty |
Public property | MyGraph |
Public property | Name |
Public property | PropertyId |
Public property | TypeId |
Public property | ValueType |
Top
Methods
 | Name | Description
Public method | GetPropertyEdge |
Public method | GetPropertyEdges |
Public method | GetPropertyValue |
Public method | GetPropertyVertex |
Public method | GetPropertyVertices |
Public method | HasPropertyValue |
Public method | RemovePropertyValue |
Public method | SetPropertyValue |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


PropertyType Properties

The PropertyType type exposes the following members.

Properties
 | Name | Description
Public property | IsVertexProperty |
Public property | MyGraph |
Public property | Name |
Public property | PropertyId |
Public property | TypeId |
Public property | ValueType |
Top
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.IsVertexProperty Property

PropertyTypeIsVertexProperty Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.IsVertexProperty"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool IsVertexProperty { get; }
Public ReadOnly Property IsVertexProperty As Boolean
    Get
public:
property bool IsVertexProperty {
    bool get ();
}
member IsVertexProperty : bool with get

Property Value

Type: Boolean
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.MyGraph Property

PropertyTypeMyGraph Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.MyGraph"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Graph MyGraph { get; }
Public ReadOnly Property MyGraph As Graph
    Get
public:
property Graph^ MyGraph {
    Graph^ get ();
}
member MyGraph : Graph with get

Property Value

Type: Graph
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.Name Property

PropertyTypeName Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.Name"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.PropertyId Property

PropertyTypePropertyId Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.PropertyId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int PropertyId { get; }
Public ReadOnly Property PropertyId As Integer
    Get
public:
property int PropertyId {
    int get ();
}
member PropertyId : int with get

Property Value

Type: Int32
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.TypeId Property

PropertyTypeTypeId Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.TypeId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int TypeId { get; }
Public ReadOnly Property TypeId As Integer
    Get
public:
property int TypeId {
    int get ();
}
member TypeId : int with get

Property Value

Type: Int32
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.ValueType Property

PropertyTypeValueType Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyType.ValueType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract Type ValueType { get; }
Public MustOverride ReadOnly Property ValueType As Type
    Get
public:
virtual property Type^ ValueType {
    Type^ get () abstract;
}
abstract ValueType : Type with get

Property Value

Type: Type
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType Methods

The PropertyType type exposes the following members.

Methods
 | Name | Description
Public method | GetPropertyEdge |
Public method | GetPropertyEdges |
Public method | GetPropertyValue |
Public method | GetPropertyVertex |
Public method | GetPropertyVertices |
Public method | HasPropertyValue |
Public method | RemovePropertyValue |
Public method | SetPropertyValue |
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.GetPropertyEdge Method

PropertyTypeGetPropertyEdge Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdge(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract Edge GetPropertyEdge(
    IComparable value
)
Public MustOverride Function GetPropertyEdge (
    value As IComparable
) As Edge
public:
virtual Edge^ GetPropertyEdge(
    IComparable^ value
) abstract
abstract GetPropertyEdge :
        value : IComparable -> Edge

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdge(System.IComparable)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdge(System.IComparable)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.GetPropertyEdges Method

PropertyTypeGetPropertyEdges Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdges(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerable<Edge> GetPropertyEdges(
    IComparable value
)
Public MustOverride Function GetPropertyEdges (
    value As IComparable
) As IEnumerable(Of Edge)
public:
virtual IEnumerable<Edge^>^ GetPropertyEdges(
    IComparable^ value
) abstract
abstract GetPropertyEdges :
        value : IComparable -> IEnumerable<Edge>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdges(System.IComparable)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.GetPropertyEdges(System.IComparable)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.GetPropertyValue Method

PropertyTypeGetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.GetPropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IComparable GetPropertyValue(
    int elementId
)
Public MustOverride Function GetPropertyValue (
    elementId As Integer
) As IComparable
public:
virtual IComparable^ GetPropertyValue(
    int elementId
) abstract
abstract GetPropertyValue :
        elementId : int -> IComparable

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyValue(System.Int32)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.GetPropertyValue(System.Int32)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.GetPropertyVertex Method

PropertyTypeGetPropertyVertex Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract Vertex GetPropertyVertex(
    IComparable value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public MustOverride Function GetPropertyVertex (
    value As IComparable,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
virtual Vertex^ GetPropertyVertex(
    IComparable^ value,
    bool polymorphic = false,
    bool errorIfNotFound = true
) abstract
abstract GetPropertyVertex :
        value : IComparable *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.GetPropertyVertices Method

PropertyTypeGetPropertyVertices Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertices(System.IComparable,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerable<Vertex> GetPropertyVertices(
    IComparable value,
    bool polymorphic = false
)
Public MustOverride Function GetPropertyVertices (
    value As IComparable,
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
virtual IEnumerable<Vertex^>^ GetPropertyVertices(
    IComparable^ value,
    bool polymorphic = false
) abstract
abstract GetPropertyVertices :
        value : IComparable *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertices(System.IComparable,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertices(System.IComparable,System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.GetPropertyVertices(System.IComparable,System.Boolean)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.HasPropertyValue Method

PropertyTypeHasPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.HasPropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract bool HasPropertyValue(
    int elementId
)
Public MustOverride Function HasPropertyValue (
    elementId As Integer
) As Boolean
public:
virtual bool HasPropertyValue(
    int elementId
) abstract
abstract HasPropertyValue :
        elementId : int -> bool

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.PropertyType.HasPropertyValue(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.HasPropertyValue(System.Int32)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.RemovePropertyValue Method

PropertyTypeRemovePropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.RemovePropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract IComparable RemovePropertyValue(
    int elementId
)
Public MustOverride Function RemovePropertyValue (
    elementId As Integer
) As IComparable
public:
virtual IComparable^ RemovePropertyValue(
    int elementId
) abstract
abstract RemovePropertyValue :
        elementId : int -> IComparable

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.PropertyType.RemovePropertyValue(System.Int32)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.PropertyType.RemovePropertyValue(System.Int32)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyType.SetPropertyValue Method

PropertyTypeSetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyType.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public abstract void SetPropertyValue(
    int elementId,
    int typeId,
    IComparable value
)
Public MustOverride Sub SetPropertyValue (
    elementId As Integer,
    typeId As Integer,
    value As IComparable
)
public:
virtual void SetPropertyValue(
    int elementId,
    int typeId,
    IComparable^ value
) abstract
abstract SetPropertyValue :
        elementId : int *
        typeId : int *
        value : IComparable -> unit

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.PropertyType.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

typeId
Type: SystemInt32

[Missing <param name="typeId"/> documentation for "M:VelocityGraph.PropertyType.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyType.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

See Also

Reference

PropertyType Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T) Class

PropertyTypeNoDuplicateValuesT Class

[Missing <summary> documentation for "T:VelocityGraph.PropertyTypeNoDuplicateValues`1"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphPropertyType
VelocityGraphPropertyTypeT UInt64
VelocityGraphPropertyTypeNoDuplicateValuesT

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PropertyTypeNoDuplicateValues<T> : PropertyTypeT<ulong>
where T : IComparable

<SerializableAttribute>
Public Class PropertyTypeNoDuplicateValues(Of T As IComparable)
    Inherits PropertyTypeT(Of ULong)
[SerializableAttribute]
generic<typename T>
where T : IComparable
public ref class PropertyTypeNoDuplicateValues : public PropertyTypeT<unsigned long long>
[<SerializableAttribute>]
type PropertyTypeNoDuplicateValues<'T when 'T : IComparable> =
    class
        inherit PropertyTypeT<uint64>
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:VelocityGraph.PropertyTypeNoDuplicateValues`1"]

The PropertyTypeNoDuplicateValuesT type exposes the following members.

Properties
 | Name | Description
Public property | ValueType | (Overrides PropertyTypeTTValueType.)
Top
Methods
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeTTGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeTTGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Public method | GetPropertyValue | (Overrides PropertyTypeTTGetPropertyValue(Int32).)
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeTTGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeTTGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Public method | SetPropertyValue | (Overrides PropertyTypeTTSetPropertyValue(Int32, Int32, IComparable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T) Properties

PropertyTypeNoDuplicateValuesT Properties

The PropertyTypeNoDuplicateValuesT generic type exposes the following members.

Properties
 | Name | Description
Public property | ValueType | (Overrides PropertyTypeTTValueType.)
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).ValueType Property

PropertyTypeNoDuplicateValuesTValueType Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyTypeNoDuplicateValues`1.ValueType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Type ValueType { get; }
Public Overrides ReadOnly Property ValueType As Type
    Get
public:
virtual property Type^ ValueType {
    Type^ get () override;
}
abstract ValueType : Type with get
override ValueType : Type with get

Property Value

Type: Type
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T) Methods

PropertyTypeNoDuplicateValuesT Methods

The PropertyTypeNoDuplicateValuesT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeTTGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeTTGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Public method | GetPropertyValue | (Overrides PropertyTypeTTGetPropertyValue(Int32).)
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeTTGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeTTGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Public method | SetPropertyValue | (Overrides PropertyTypeTTSetPropertyValue(Int32, Int32, IComparable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdge Method

PropertyTypeNoDuplicateValuesTGetPropertyEdge Method

Overload List
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeTTGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdge Method (IComparable)

PropertyTypeNoDuplicateValuesTGetPropertyEdge Method (IComparable)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Edge GetPropertyEdge(
    IComparable value
)
Public Overrides Function GetPropertyEdge (
    value As IComparable
) As Edge
public:
virtual Edge^ GetPropertyEdge(
    IComparable^ value
) override
abstract GetPropertyEdge :
        value : IComparable -> Edge
override GetPropertyEdge :
        value : IComparable -> Edge

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(System.IComparable)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(System.IComparable)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyEdge Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdge Method (T)

PropertyTypeNoDuplicateValuesTGetPropertyEdge Method (T)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(`0)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge GetPropertyEdge(
    T value
)
Public Function GetPropertyEdge (
    value As T
) As Edge
public:
Edge^ GetPropertyEdge(
    T value
)
member GetPropertyEdge :
        value : 'T -> Edge

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(`0)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdge(`0)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyEdge Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdges Method

PropertyTypeNoDuplicateValuesTGetPropertyEdges Method

Overload List
 | Name | Description
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeTTGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdges Method (IComparable)

PropertyTypeNoDuplicateValuesTGetPropertyEdges Method (IComparable)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<Edge> GetPropertyEdges(
    IComparable value
)
Public Overrides Function GetPropertyEdges (
    value As IComparable
) As IEnumerable(Of Edge)
public:
virtual IEnumerable<Edge^>^ GetPropertyEdges(
    IComparable^ value
) override
abstract GetPropertyEdges :
        value : IComparable -> IEnumerable<Edge>
override GetPropertyEdges :
        value : IComparable -> IEnumerable<Edge>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(System.IComparable)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(System.IComparable)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyEdges Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyEdges Method (T)

PropertyTypeNoDuplicateValuesTGetPropertyEdges Method (T)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(`0)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Edge> GetPropertyEdges(
    T value
)
Public Function GetPropertyEdges (
    value As T
) As IEnumerable(Of Edge)
public:
IEnumerable<Edge^>^ GetPropertyEdges(
    T value
)
member GetPropertyEdges :
        value : 'T -> IEnumerable<Edge>

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(`0)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyEdges(`0)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyEdges Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyValue Method

PropertyTypeNoDuplicateValuesTGetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IComparable GetPropertyValue(
    int element
)
Public Overrides Function GetPropertyValue (
    element As Integer
) As IComparable
public:
virtual IComparable^ GetPropertyValue(
    int element
) override
abstract GetPropertyValue :
        element : int -> IComparable
override GetPropertyValue :
        element : int -> IComparable

Parameters

element
Type: SystemInt32

[Missing <param name="element"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyValue(System.Int32)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyValue(System.Int32)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertex Method

PropertyTypeNoDuplicateValuesTGetPropertyVertex Method

Overload List
 | Name | Description
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeTTGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertex Method (IComparable, Boolean, Boolean)

PropertyTypeNoDuplicateValuesTGetPropertyVertex Method (IComparable, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Vertex GetPropertyVertex(
    IComparable value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Overrides Function GetPropertyVertex (
    value As IComparable,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
virtual Vertex^ GetPropertyVertex(
    IComparable^ value,
    bool polymorphic = false,
    bool errorIfNotFound = true
) override
abstract GetPropertyVertex :
        value : IComparable *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex
override GetPropertyVertex :
        value : IComparable *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyVertex Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertex Method (T, Boolean, Boolean)

PropertyTypeNoDuplicateValuesTGetPropertyVertex Method (T, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex GetPropertyVertex(
    T value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Function GetPropertyVertex (
    value As T,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
Vertex^ GetPropertyVertex(
    T value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
member GetPropertyVertex :
        value : 'T *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyVertex Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertices Method

PropertyTypeNoDuplicateValuesTGetPropertyVertices Method

Overload List
 | Name | Description
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeTTGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Top
See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertices Method (IComparable, Boolean)

PropertyTypeNoDuplicateValuesTGetPropertyVertices Method (IComparable, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<Vertex> GetPropertyVertices(
    IComparable value,
    bool polymorphic = false
)
Public Overrides Function GetPropertyVertices (
    value As IComparable,
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
virtual IEnumerable<Vertex^>^ GetPropertyVertices(
    IComparable^ value,
    bool polymorphic = false
) override
abstract GetPropertyVertices :
        value : IComparable *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>
override GetPropertyVertices :
        value : IComparable *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyVertices Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).GetPropertyVertices Method (T, Boolean)

PropertyTypeNoDuplicateValuesTGetPropertyVertices Method (T, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(`0,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Vertex> GetPropertyVertices(
    T value,
    bool polymorphic = false
)
Public Function GetPropertyVertices (
    value As T,
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
IEnumerable<Vertex^>^ GetPropertyVertices(
    T value,
    bool polymorphic = false
)
member GetPropertyVertices :
        value : 'T *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(`0,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(`0,System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.GetPropertyVertices(`0,System.Boolean)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
GetPropertyVertices Overload
VelocityGraph Namespace


PropertyTypeNoDuplicateValues(T).SetPropertyValue Method

PropertyTypeNoDuplicateValuesTSetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetPropertyValue(
    int element,
    int typeId,
    IComparable value
)
Public Overrides Sub SetPropertyValue (
    element As Integer,
    typeId As Integer,
    value As IComparable
)
public:
virtual void SetPropertyValue(
    int element,
    int typeId,
    IComparable^ value
) override
abstract SetPropertyValue :
        element : int *
        typeId : int *
        value : IComparable -> unit
override SetPropertyValue :
        element : int *
        typeId : int *
        value : IComparable -> unit

Parameters

element
Type: SystemInt32

[Missing <param name="element"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

typeId
Type: SystemInt32

[Missing <param name="typeId"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeNoDuplicateValues`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

See Also

Reference

PropertyTypeNoDuplicateValuesT Class
VelocityGraph Namespace


PropertyTypeT(T) Class

PropertyTypeTT Class

[Missing <summary> documentation for "T:VelocityGraph.PropertyTypeT`1"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphPropertyType
VelocityGraphPropertyTypeTT
VelocityGraphPropertyTypeNoDuplicateValuesT

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PropertyTypeT<T> : PropertyType
where T : IComparable

<SerializableAttribute>
Public Class PropertyTypeT(Of T As IComparable)
    Inherits PropertyType
[SerializableAttribute]
generic<typename T>
where T : IComparable
public ref class PropertyTypeT : public PropertyType
[<SerializableAttribute>]
type PropertyTypeT<'T when 'T : IComparable> =
    class
        inherit PropertyType
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:VelocityGraph.PropertyTypeT`1"]

The PropertyTypeTT type exposes the following members.

Properties
 | Name | Description
Public property | ValueType | (Overrides PropertyTypeValueType.)
Top
Methods
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Public method | GetPropertyValue | (Overrides PropertyTypeGetPropertyValue(Int32).)
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Public method | HasPropertyValue | (Overrides PropertyTypeHasPropertyValue(Int32).)
Public method | RemovePropertyValue | (Overrides PropertyTypeRemovePropertyValue(Int32).)
Public method | SetPropertyValue | (Overrides PropertyTypeSetPropertyValue(Int32, Int32, IComparable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


PropertyTypeT(T) Properties

PropertyTypeTT Properties

The PropertyTypeTT generic type exposes the following members.

Properties
 | Name | Description
Public property | ValueType | (Overrides PropertyTypeValueType.)
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).ValueType Property

PropertyTypeTTValueType Property

[Missing <summary> documentation for "P:VelocityGraph.PropertyTypeT`1.ValueType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Type ValueType { get; }
Public Overrides ReadOnly Property ValueType As Type
    Get
public:
virtual property Type^ ValueType {
    Type^ get () override;
}
abstract ValueType : Type with get
override ValueType : Type with get

Property Value

Type: Type
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T) Methods

PropertyTypeTT Methods

The PropertyTypeTT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Public method | GetPropertyValue | (Overrides PropertyTypeGetPropertyValue(Int32).)
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Public method | HasPropertyValue | (Overrides PropertyTypeHasPropertyValue(Int32).)
Public method | RemovePropertyValue | (Overrides PropertyTypeRemovePropertyValue(Int32).)
Public method | SetPropertyValue | (Overrides PropertyTypeSetPropertyValue(Int32, Int32, IComparable).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdge Method

PropertyTypeTTGetPropertyEdge Method

Overload List
 | Name | Description
Public method | GetPropertyEdge(IComparable) | (Overrides PropertyTypeGetPropertyEdge(IComparable).)
Public method | GetPropertyEdge(T) |
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdge Method (IComparable)

PropertyTypeTTGetPropertyEdge Method (IComparable)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Edge GetPropertyEdge(
    IComparable value
)
Public Overrides Function GetPropertyEdge (
    value As IComparable
) As Edge
public:
virtual Edge^ GetPropertyEdge(
    IComparable^ value
) override
abstract GetPropertyEdge :
        value : IComparable -> Edge
override GetPropertyEdge :
        value : IComparable -> Edge

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(System.IComparable)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(System.IComparable)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyEdge Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdge Method (T)

PropertyTypeTTGetPropertyEdge Method (T)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(`0)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge GetPropertyEdge(
    T value
)
Public Function GetPropertyEdge (
    value As T
) As Edge
public:
Edge^ GetPropertyEdge(
    T value
)
member GetPropertyEdge :
        value : 'T -> Edge

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(`0)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdge(`0)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyEdge Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdges Method

PropertyTypeTTGetPropertyEdges Method

Overload List
 | Name | Description
Public method | GetPropertyEdges(IComparable) | (Overrides PropertyTypeGetPropertyEdges(IComparable).)
Public method | GetPropertyEdges(T) |
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdges Method (IComparable)

PropertyTypeTTGetPropertyEdges Method (IComparable)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<Edge> GetPropertyEdges(
    IComparable value
)
Public Overrides Function GetPropertyEdges (
    value As IComparable
) As IEnumerable(Of Edge)
public:
virtual IEnumerable<Edge^>^ GetPropertyEdges(
    IComparable^ value
) override
abstract GetPropertyEdges :
        value : IComparable -> IEnumerable<Edge>
override GetPropertyEdges :
        value : IComparable -> IEnumerable<Edge>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(System.IComparable)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(System.IComparable)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyEdges Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyEdges Method (T)

PropertyTypeTTGetPropertyEdges Method (T)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(`0)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Edge> GetPropertyEdges(
    T value
)
Public Function GetPropertyEdges (
    value As T
) As IEnumerable(Of Edge)
public:
IEnumerable<Edge^>^ GetPropertyEdges(
    T value
)
member GetPropertyEdges :
        value : 'T -> IEnumerable<Edge>

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(`0)"]

Return Value

Type: IEnumerable Edge

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyEdges(`0)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyEdges Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyValue Method

PropertyTypeTTGetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IComparable GetPropertyValue(
    int element
)
Public Overrides Function GetPropertyValue (
    element As Integer
) As IComparable
public:
virtual IComparable^ GetPropertyValue(
    int element
) override
abstract GetPropertyValue :
        element : int -> IComparable
override GetPropertyValue :
        element : int -> IComparable

Parameters

element
Type: SystemInt32

[Missing <param name="element"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyValue(System.Int32)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyValue(System.Int32)"]

See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertex Method

PropertyTypeTTGetPropertyVertex Method

Overload List
 | Name | Description
Public method | GetPropertyVertex(IComparable, Boolean, Boolean) | (Overrides PropertyTypeGetPropertyVertex(IComparable, Boolean, Boolean).)
Public method | GetPropertyVertex(T, Boolean, Boolean) |
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertex Method (IComparable, Boolean, Boolean)

PropertyTypeTTGetPropertyVertex Method (IComparable, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Vertex GetPropertyVertex(
    IComparable value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Overrides Function GetPropertyVertex (
    value As IComparable,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
virtual Vertex^ GetPropertyVertex(
    IComparable^ value,
    bool polymorphic = false,
    bool errorIfNotFound = true
) override
abstract GetPropertyVertex :
        value : IComparable *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex
override GetPropertyVertex :
        value : IComparable *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(System.IComparable,System.Boolean,System.Boolean)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyVertex Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertex Method (T, Boolean, Boolean)

PropertyTypeTTGetPropertyVertex Method (T, Boolean, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex GetPropertyVertex(
    T value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Function GetPropertyVertex (
    value As T,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
Vertex^ GetPropertyVertex(
    T value,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
member GetPropertyVertex :
        value : 'T *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertex(`0,System.Boolean,System.Boolean)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyVertex Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertices Method

PropertyTypeTTGetPropertyVertices Method

Overload List
 | Name | Description
Public method | GetPropertyVertices(IComparable, Boolean) | (Overrides PropertyTypeGetPropertyVertices(IComparable, Boolean).)
Public method | GetPropertyVertices(T, Boolean) |
Top
See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertices Method (IComparable, Boolean)

PropertyTypeTTGetPropertyVertices Method (IComparable, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<Vertex> GetPropertyVertices(
    IComparable value,
    bool polymorphic = false
)
Public Overrides Function GetPropertyVertices (
    value As IComparable,
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
virtual IEnumerable<Vertex^>^ GetPropertyVertices(
    IComparable^ value,
    bool polymorphic = false
) override
abstract GetPropertyVertices :
        value : IComparable *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>
override GetPropertyVertices :
        value : IComparable *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(System.IComparable,System.Boolean)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyVertices Overload
VelocityGraph Namespace


PropertyTypeT(T).GetPropertyVertices Method (T, Boolean)

PropertyTypeTTGetPropertyVertices Method (T, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(`0,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Vertex> GetPropertyVertices(
    T value,
    bool polymorphic = false
)
Public Function GetPropertyVertices (
    value As T,
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
IEnumerable<Vertex^>^ GetPropertyVertices(
    T value,
    bool polymorphic = false
)
member GetPropertyVertices :
        value : 'T *
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(`0,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(`0,System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.GetPropertyVertices(`0,System.Boolean)"]

See Also

Reference

PropertyTypeTT Class
GetPropertyVertices Overload
VelocityGraph Namespace


PropertyTypeT(T).HasPropertyValue Method

PropertyTypeTTHasPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.HasPropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool HasPropertyValue(
    int elementId
)
Public Overrides Function HasPropertyValue (
    elementId As Integer
) As Boolean
public:
virtual bool HasPropertyValue(
    int elementId
) override
abstract HasPropertyValue :
        elementId : int -> bool
override HasPropertyValue :
        elementId : int -> bool

Parameters

elementId
Type: SystemInt32

[Missing <param name="elementId"/> documentation for "M:VelocityGraph.PropertyTypeT`1.HasPropertyValue(System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.HasPropertyValue(System.Int32)"]

See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).RemovePropertyValue Method

PropertyTypeTTRemovePropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.RemovePropertyValue(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IComparable RemovePropertyValue(
    int element
)
Public Overrides Function RemovePropertyValue (
    element As Integer
) As IComparable
public:
virtual IComparable^ RemovePropertyValue(
    int element
) override
abstract RemovePropertyValue :
        element : int -> IComparable
override RemovePropertyValue :
        element : int -> IComparable

Parameters

element
Type: SystemInt32

[Missing <param name="element"/> documentation for "M:VelocityGraph.PropertyTypeT`1.RemovePropertyValue(System.Int32)"]

Return Value

Type: IComparable

[Missing <returns> documentation for "M:VelocityGraph.PropertyTypeT`1.RemovePropertyValue(System.Int32)"]

See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


PropertyTypeT(T).SetPropertyValue Method

PropertyTypeTTSetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.PropertyTypeT`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetPropertyValue(
    int element,
    int typeId,
    IComparable value
)
Public Overrides Sub SetPropertyValue (
    element As Integer,
    typeId As Integer,
    value As IComparable
)
public:
virtual void SetPropertyValue(
    int element,
    int typeId,
    IComparable^ value
) override
abstract SetPropertyValue :
        element : int *
        typeId : int *
        value : IComparable -> unit
override SetPropertyValue :
        element : int *
        typeId : int *
        value : IComparable -> unit

Parameters

element
Type: SystemInt32

[Missing <param name="element"/> documentation for "M:VelocityGraph.PropertyTypeT`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

typeId
Type: SystemInt32

[Missing <param name="typeId"/> documentation for "M:VelocityGraph.PropertyTypeT`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

value
Type: SystemIComparable

[Missing <param name="value"/> documentation for "M:VelocityGraph.PropertyTypeT`1.SetPropertyValue(System.Int32,System.Int32,System.IComparable)"]

See Also

Reference

PropertyTypeTT Class
VelocityGraph Namespace


Vertex Class

[Missing <summary> documentation for "T:VelocityGraph.Vertex"]

Inheritance Hierarchy
SystemObject
DictionaryElement
VelocityGraphElement
VelocityGraphVertex

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public class Vertex : Element, IVertex,
    IElement, IDictionary<string, Object>, ICollection<KeyValuePair<string, Object>>,
    IEnumerable<KeyValuePair<string, Object>>, IEnumerable,
    IDictionary, ICollection, IEqualityComparer<Vertex>
Public Class Vertex
    Inherits Element
    Implements IVertex, IElement, IDictionary(Of String, Object),
    ICollection(Of KeyValuePair(Of String, Object)), IEnumerable(Of KeyValuePair(Of String, Object)),
    IEnumerable, IDictionary, ICollection, IEqualityComparer(Of Vertex)
public ref class Vertex : public Element,
    IVertex, IElement, IDictionary<String^, Object^>,
    ICollection<KeyValuePair<String^, Object^>>, IEnumerable<KeyValuePair<String^, Object^>>,
    IEnumerable, IDictionary, ICollection, IEqualityComparer<Vertex^>
type Vertex =
    class
        inherit Element
        interface IVertex
        interface IElement
        interface IDictionary<string, Object>
        interface ICollection<KeyValuePair<string, Object>>
        interface IEnumerable<KeyValuePair<string, Object>>
        interface IEnumerable
        interface IDictionary
        interface ICollection
        interface IEqualityComparer<Vertex>
    end

The Vertex type exposes the following members.

Constructors
 | Name | Description
Public method | Vertex | Initializes a new instance of the Vertex class
Top
Properties
 | Name | Description
Public property | Id | (Overrides DictionaryElement.Id.)
Public property | VertexId |
Public property | VertexType |
Top
Methods
 | Name | Description
Public method | AddEdge(String, IVertex) |
Public method | AddEdge(EdgeType, Vertex) |
Public method | AddEdge(Object, String, IVertex) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Vertex, Vertex) |
Public method | GetEdges(Direction, String) |
Public method | GetEdges(EdgeType, Direction) |
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Vertex) |
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Vertex, Direction) |
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Public method | GetPropertyKeys | (Overrides DictionaryElement.GetPropertyKeys.)
Public method | GetVertices |
Public method | Query |
Public method | RelatedVertices |
Public method | Remove | (Overrides DictionaryElement.Remove.)
Public method | RemoveProperty | (Overrides DictionaryElement.RemoveProperty(String).)
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Public method | ToString | (Overrides ObjectToString.)
Public method | Traverse(Direction, ISetEdgeType) |
Public method | Traverse(EdgeType, Direction) |
Public method | Traverse(Int32, Boolean, Direction, Vertex, ISetEdgeType, ISetVertexType, ISetVertexType, ISetVertex, ISetVertex, ISetEdge, ISetEdge, ISetPropertyType, ISetPropertyType, ISetPropertyType, ISetPropertyType, FuncVertex, Boolean, FuncEdge, Boolean, FuncListEdge, Boolean) |
Top
See Also

Reference

VelocityGraph Namespace


Vertex Constructor

Initializes a new instance of the Vertex class

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex(
    Graph g,
    VertexType eType,
    int eId
)
Public Sub New (
    g As Graph,
    eType As VertexType,
    eId As Integer
)
public:
Vertex(
    Graph^ g,
    VertexType^ eType,
    int eId
)
new :
        g : Graph *
        eType : VertexType *
        eId : int -> Vertex

Parameters

g
Type: VelocityGraphGraph

[Missing <param name="g"/> documentation for "M:VelocityGraph.Vertex.#ctor(VelocityGraph.Graph,VelocityGraph.VertexType,System.Int32)"]

eType
Type: VelocityGraphVertexType

[Missing <param name="eType"/> documentation for "M:VelocityGraph.Vertex.#ctor(VelocityGraph.Graph,VelocityGraph.VertexType,System.Int32)"]

eId
Type: SystemInt32

[Missing <param name="eId"/> documentation for "M:VelocityGraph.Vertex.#ctor(VelocityGraph.Graph,VelocityGraph.VertexType,System.Int32)"]

See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex Properties

The Vertex type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Overrides DictionaryElement.Id.)
Public property | VertexId |
Public property | VertexType |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Id Property

VertexId Property

[Missing <summary> documentation for "P:VelocityGraph.Vertex.Id"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object Id { get; }
Public Overrides ReadOnly Property Id As Object
    Get
public:
virtual property Object^ Id {
    Object^ get () override;
}
abstract Id : Object with get
override Id : Object with get

Property Value

Type: Object

Implements

IElement.Id
IElement.Id
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.VertexId Property

VertexVertexId Property

[Missing <summary> documentation for "P:VelocityGraph.Vertex.VertexId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int VertexId { get; }
Public ReadOnly Property VertexId As Integer
    Get
public:
property int VertexId {
    int get ();
}
member VertexId : int with get

Property Value

Type: Int32
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.VertexType Property

VertexVertexType Property

[Missing <summary> documentation for "P:VelocityGraph.Vertex.VertexType"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public VertexType VertexType { get; }
Public ReadOnly Property VertexType As VertexType
    Get
public:
property VertexType^ VertexType {
    VertexType^ get ();
}
member VertexType : VertexType with get

Property Value

Type: VertexType
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex Methods

The Vertex type exposes the following members.

Methods
 | Name | Description
Public method | AddEdge(String, IVertex) |
Public method | AddEdge(EdgeType, Vertex) |
Public method | AddEdge(Object, String, IVertex) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Vertex, Vertex) |
Public method | GetEdges(Direction, String) |
Public method | GetEdges(EdgeType, Direction) |
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Vertex) |
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Vertex, Direction) |
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Public method | GetPropertyKeys | (Overrides DictionaryElement.GetPropertyKeys.)
Public method | GetVertices |
Public method | Query |
Public method | RelatedVertices |
Public method | Remove | (Overrides DictionaryElement.Remove.)
Public method | RemoveProperty | (Overrides DictionaryElement.RemoveProperty(String).)
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Public method | ToString | (Overrides ObjectToString.)
Public method | Traverse(Direction, ISetEdgeType) |
Public method | Traverse(EdgeType, Direction) |
Public method | Traverse(Int32, Boolean, Direction, Vertex, ISetEdgeType, ISetVertexType, ISetVertexType, ISetVertex, ISetVertex, ISetEdge, ISetEdge, ISetPropertyType, ISetPropertyType, ISetPropertyType, ISetPropertyType, FuncVertex, Boolean, FuncEdge, Boolean, FuncListEdge, Boolean) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.AddEdge Method

VertexAddEdge Method

Overload List
 | Name | Description
Public method | AddEdge(String, IVertex) |
Public method | AddEdge(EdgeType, Vertex) |
Public method | AddEdge(Object, String, IVertex) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.AddEdge Method (String, IVertex)

VertexAddEdge Method (String, IVertex)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.AddEdge(System.String,Frontenac.Blueprints.IVertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEdge AddEdge(
    string label,
    IVertex inVertex
)
Public Function AddEdge (
    label As String,
    inVertex As IVertex
) As IEdge
public:
IEdge^ AddEdge(
    String^ label,
    IVertex^ inVertex
)
member AddEdge :
        label : string *
        inVertex : IVertex -> IEdge

Parameters

label
Type: SystemString

[Missing <param name="label"/> documentation for "M:VelocityGraph.Vertex.AddEdge(System.String,Frontenac.Blueprints.IVertex)"]

inVertex
Type: IVertex

[Missing <param name="inVertex"/> documentation for "M:VelocityGraph.Vertex.AddEdge(System.String,Frontenac.Blueprints.IVertex)"]

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.AddEdge(System.String,Frontenac.Blueprints.IVertex)"]

See Also

Reference

Vertex Class
AddEdge Overload
VelocityGraph Namespace


Vertex.AddEdge Method (EdgeType, Vertex)

VertexAddEdge Method (EdgeType, Vertex)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.AddEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Edge AddEdge(
    EdgeType edgeType,
    Vertex head
)
Public Function AddEdge (
    edgeType As EdgeType,
    head As Vertex
) As Edge
public:
Edge^ AddEdge(
    EdgeType^ edgeType,
    Vertex^ head
)
member AddEdge :
        edgeType : EdgeType *
        head : Vertex -> Edge

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Vertex.AddEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex)"]

head
Type: VelocityGraphVertex

[Missing <param name="head"/> documentation for "M:VelocityGraph.Vertex.AddEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex)"]

Return Value

Type: Edge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.AddEdge(VelocityGraph.EdgeType,VelocityGraph.Vertex)"]

See Also

Reference

Vertex Class
AddEdge Overload
VelocityGraph Namespace


Vertex.AddEdge Method (Object, String, IVertex)

VertexAddEdge Method (Object, String, IVertex)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.AddEdge(System.Object,System.String,Frontenac.Blueprints.IVertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEdge AddEdge(
    Object edgeId,
    string label,
    IVertex inVertex
)
Public Function AddEdge (
    edgeId As Object,
    label As String,
    inVertex As IVertex
) As IEdge
public:
virtual IEdge^ AddEdge(
    Object^ edgeId,
    String^ label,
    IVertex^ inVertex
) sealed
abstract AddEdge :
        edgeId : Object *
        label : string *
        inVertex : IVertex -> IEdge
override AddEdge :
        edgeId : Object *
        label : string *
        inVertex : IVertex -> IEdge

Parameters

edgeId
Type: SystemObject

[Missing <param name="edgeId"/> documentation for "M:VelocityGraph.Vertex.AddEdge(System.Object,System.String,Frontenac.Blueprints.IVertex)"]

label
Type: SystemString

[Missing <param name="label"/> documentation for "M:VelocityGraph.Vertex.AddEdge(System.Object,System.String,Frontenac.Blueprints.IVertex)"]

inVertex
Type: IVertex

[Missing <param name="inVertex"/> documentation for "M:VelocityGraph.Vertex.AddEdge(System.Object,System.String,Frontenac.Blueprints.IVertex)"]

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.AddEdge(System.Object,System.String,Frontenac.Blueprints.IVertex)"]

Implements

IVertex.AddEdge(Object, String, IVertex)
See Also

Reference

Vertex Class
AddEdge Overload
VelocityGraph Namespace


Vertex.Equals Method

VertexEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Vertex, Vertex) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Equals Method (Object)

VertexEquals Method (Object)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Equals(System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object other
)
Public Overrides Function Equals (
    other As Object
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
abstract Equals :
        other : Object -> bool
override Equals :
        other : Object -> bool

Parameters

other
Type: SystemObject

[Missing <param name="other"/> documentation for "M:VelocityGraph.Vertex.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Equals(System.Object)"]

See Also

Reference

Vertex Class
Equals Overload
VelocityGraph Namespace


Vertex.Equals Method (Vertex, Vertex)

VertexEquals Method (Vertex, Vertex)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Equals(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Vertex x,
    Vertex y
)
Public Function Equals (
    x As Vertex,
    y As Vertex
) As Boolean
public:
virtual bool Equals(
    Vertex^ x,
    Vertex^ y
) sealed
abstract Equals :
        x : Vertex *
        y : Vertex -> bool
override Equals :
        x : Vertex *
        y : Vertex -> bool

Parameters

x
Type: VelocityGraphVertex

[Missing <param name="x"/> documentation for "M:VelocityGraph.Vertex.Equals(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

y
Type: VelocityGraphVertex

[Missing <param name="y"/> documentation for "M:VelocityGraph.Vertex.Equals(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Equals(VelocityGraph.Vertex,VelocityGraph.Vertex)"]

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

Vertex Class
Equals Overload
VelocityGraph Namespace


Vertex.GetEdges Method

VertexGetEdges Method

Overload List
 | Name | Description
Public method | GetEdges(Direction, String) |
Public method | GetEdges(EdgeType, Direction) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.GetEdges Method (Direction, String[])

VertexGetEdges Method (Direction, String)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetEdges(Frontenac.Blueprints.Direction,System.String[])"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges(
    Direction direction,
    params string[] labels
)
Public Function GetEdges (
    direction As Direction,
    ParamArray labels As String()
) As IEnumerable(Of IEdge)
public:
virtual IEnumerable<IEdge^>^ GetEdges(
    Direction direction,
    ... array<String^>^ labels
) sealed
abstract GetEdges :
        direction : Direction *
        labels : string[] -> IEnumerable<IEdge>
override GetEdges :
        direction : Direction *
        labels : string[] -> IEnumerable<IEdge>

Parameters

direction
Type: Direction

[Missing <param name="direction"/> documentation for "M:VelocityGraph.Vertex.GetEdges(Frontenac.Blueprints.Direction,System.String[])"]

labels
Type: SystemString

[Missing <param name="labels"/> documentation for "M:VelocityGraph.Vertex.GetEdges(Frontenac.Blueprints.Direction,System.String[])"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetEdges(Frontenac.Blueprints.Direction,System.String[])"]

Implements

IVertex.GetEdges(Direction, String)
See Also

Reference

Vertex Class
GetEdges Overload
VelocityGraph Namespace


Vertex.GetEdges Method (EdgeType, Direction)

VertexGetEdges Method (EdgeType, Direction)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges(
    EdgeType edgeType,
    Direction dir
)
Public Function GetEdges (
    edgeType As EdgeType,
    dir As Direction
) As IEnumerable(Of IEdge)
public:
IEnumerable<IEdge^>^ GetEdges(
    EdgeType^ edgeType,
    Direction dir
)
member GetEdges :
        edgeType : EdgeType *
        dir : Direction -> IEnumerable<IEdge>

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Vertex.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

Vertex Class
GetEdges Overload
VelocityGraph Namespace


Vertex.GetHashCode Method

VertexGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | (Overrides ElementGetHashCode.)
Public method | GetHashCode(Vertex) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.GetHashCode Method

VertexGetHashCode Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetHashCode"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetHashCode"]

See Also

Reference

Vertex Class
GetHashCode Overload
VelocityGraph Namespace


Vertex.GetHashCode Method (Vertex)

VertexGetHashCode Method (Vertex)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetHashCode(VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Vertex obj
)
Public Function GetHashCode (
    obj As Vertex
) As Integer
public:
virtual int GetHashCode(
    Vertex^ obj
) sealed
abstract GetHashCode :
        obj : Vertex -> int
override GetHashCode :
        obj : Vertex -> int

Parameters

obj
Type: VelocityGraphVertex

[Missing <param name="obj"/> documentation for "M:VelocityGraph.Vertex.GetHashCode(VelocityGraph.Vertex)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetHashCode(VelocityGraph.Vertex)"]

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

Vertex Class
GetHashCode Overload
VelocityGraph Namespace


Vertex.GetNumberOfEdges Method

VertexGetNumberOfEdges Method

Overload List
 | Name | Description
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Vertex, Direction) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.GetNumberOfEdges Method (EdgeType, Direction)

VertexGetNumberOfEdges Method (EdgeType, Direction)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long GetNumberOfEdges(
    EdgeType edgeType,
    Direction dir
)
Public Function GetNumberOfEdges (
    edgeType As EdgeType,
    dir As Direction
) As Long
public:
long long GetNumberOfEdges(
    EdgeType^ edgeType,
    Direction dir
)
member GetNumberOfEdges :
        edgeType : EdgeType *
        dir : Direction -> int64

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

Vertex Class
GetNumberOfEdges Overload
VelocityGraph Namespace


Vertex.GetNumberOfEdges Method (EdgeType, Vertex, Direction)

VertexGetNumberOfEdges Method (EdgeType, Vertex, Direction)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long GetNumberOfEdges(
    EdgeType edgeType,
    Vertex headVertex,
    Direction dir
)
Public Function GetNumberOfEdges (
    edgeType As EdgeType,
    headVertex As Vertex,
    dir As Direction
) As Long
public:
long long GetNumberOfEdges(
    EdgeType^ edgeType,
    Vertex^ headVertex,
    Direction dir
)
member GetNumberOfEdges :
        edgeType : EdgeType *
        headVertex : Vertex *
        dir : Direction -> int64

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

headVertex
Type: VelocityGraphVertex

[Missing <param name="headVertex"/> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetNumberOfEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

See Also

Reference

Vertex Class
GetNumberOfEdges Overload
VelocityGraph Namespace


Vertex.GetProperty Method

VertexGetProperty Method

Overload List
 | Name | Description
Public method | GetProperty(String) | (Overrides DictionaryElement.GetProperty(String).)
Public method | GetProperty(PropertyType) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.GetProperty Method (String)

VertexGetProperty Method (String)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object GetProperty(
    string key
)
Public Overrides Function GetProperty (
    key As String
) As Object
public:
virtual Object^ GetProperty(
    String^ key
) override
abstract GetProperty :
        key : string -> Object
override GetProperty :
        key : string -> Object

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Vertex.GetProperty(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetProperty(System.String)"]

Implements

IElement.GetProperty(String)
IElement.GetProperty(String)
See Also

Reference

Vertex Class
GetProperty Overload
VelocityGraph Namespace


Vertex.GetProperty Method (PropertyType)

VertexGetProperty Method (PropertyType)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetProperty(VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object GetProperty(
    PropertyType property
)
Public Function GetProperty (
    property As PropertyType
) As Object
public:
Object^ GetProperty(
    PropertyType^ property
)
member GetProperty :
        property : PropertyType -> Object

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Vertex.GetProperty(VelocityGraph.PropertyType)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetProperty(VelocityGraph.PropertyType)"]

See Also

Reference

Vertex Class
GetProperty Overload
VelocityGraph Namespace


Vertex.GetPropertyKeys Method

VertexGetPropertyKeys Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetPropertyKeys"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<string> GetPropertyKeys()
Public Overrides Function GetPropertyKeys As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetPropertyKeys() override
abstract GetPropertyKeys : unit -> IEnumerable<string>
override GetPropertyKeys : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetPropertyKeys"]

Implements

IElement.GetPropertyKeys
IElement.GetPropertyKeys
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.GetVertices Method

VertexGetVertices Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.GetVertices(Frontenac.Blueprints.Direction,System.String[])"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IVertex> GetVertices(
    Direction direction,
    params string[] labels
)
Public Function GetVertices (
    direction As Direction,
    ParamArray labels As String()
) As IEnumerable(Of IVertex)
public:
virtual IEnumerable<IVertex^>^ GetVertices(
    Direction direction,
    ... array<String^>^ labels
) sealed
abstract GetVertices :
        direction : Direction *
        labels : string[] -> IEnumerable<IVertex>
override GetVertices :
        direction : Direction *
        labels : string[] -> IEnumerable<IVertex>

Parameters

direction
Type: Direction

[Missing <param name="direction"/> documentation for "M:VelocityGraph.Vertex.GetVertices(Frontenac.Blueprints.Direction,System.String[])"]

labels
Type: SystemString

[Missing <param name="labels"/> documentation for "M:VelocityGraph.Vertex.GetVertices(Frontenac.Blueprints.Direction,System.String[])"]

Return Value

Type: IEnumerable IVertex

[Missing <returns> documentation for "M:VelocityGraph.Vertex.GetVertices(Frontenac.Blueprints.Direction,System.String[])"]

Implements

IVertex.GetVertices(Direction, String)
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Query Method

VertexQuery Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Query"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IVertexQuery Query()
Public Function Query As IVertexQuery
public:
virtual IVertexQuery^ Query() sealed
abstract Query : unit -> IVertexQuery
override Query : unit -> IVertexQuery

Return Value

Type: IVertexQuery

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Query"]

Implements

IVertex.Query
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.RelatedVertices Method

VertexRelatedVertices Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.RelatedVertices(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<Vertex> RelatedVertices(
    Direction dir = Direction.Both,
    ISet<EdgeType> edgeTypesToTraverse = null
)
Public Function RelatedVertices (
    Optional dir As Direction = Direction.Both,
    Optional edgeTypesToTraverse As ISet(Of EdgeType) = Nothing
) As List(Of Vertex)
public:
List<Vertex^>^ RelatedVertices(
    Direction dir = Direction::Both,
    ISet<EdgeType^>^ edgeTypesToTraverse = nullptr
)
member RelatedVertices :
        ?dir : Direction *
        ?edgeTypesToTraverse : ISet<EdgeType>
(* Defaults:
        let _dir = defaultArg dir Direction.Both
        let _edgeTypesToTraverse = defaultArg edgeTypesToTraverse null
*)
-> List<Vertex>

Parameters

dir (Optional)
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.RelatedVertices(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

edgeTypesToTraverse (Optional)
Type: System.Collections.GenericISet EdgeType

[Missing <param name="edgeTypesToTraverse"/> documentation for "M:VelocityGraph.Vertex.RelatedVertices(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

Return Value

Type: List Vertex

[Missing <returns> documentation for "M:VelocityGraph.Vertex.RelatedVertices(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Remove Method

VertexRemove Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Remove"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Remove()
Public Overrides Sub Remove
public:
virtual void Remove() override
abstract Remove : unit -> unit
override Remove : unit -> unit

Implements

IElement.Remove
IElement.Remove
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.RemoveProperty Method

VertexRemoveProperty Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.RemoveProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override Object RemoveProperty(
    string key
)
Public Overrides Function RemoveProperty (
    key As String
) As Object
public:
virtual Object^ RemoveProperty(
    String^ key
) override
abstract RemoveProperty :
        key : string -> Object
override RemoveProperty :
        key : string -> Object

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Vertex.RemoveProperty(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.Vertex.RemoveProperty(System.String)"]

Implements

IElement.RemoveProperty(String)
IElement.RemoveProperty(String)
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.SetProperty Method

VertexSetProperty Method

Overload List
 | Name | Description
Public method | SetProperty(String, Object) | (Overrides DictionaryElement.SetProperty(String, Object).)
Public method | SetProperty(PropertyType, IComparable) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.SetProperty Method (String, Object)

VertexSetProperty Method (String, Object)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.SetProperty(System.String,System.Object)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void SetProperty(
    string key,
    Object value
)
Public Overrides Sub SetProperty (
    key As String,
    value As Object
)
public:
virtual void SetProperty(
    String^ key,
    Object^ value
) override
abstract SetProperty :
        key : string *
        value : Object -> unit
override SetProperty :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:VelocityGraph.Vertex.SetProperty(System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:VelocityGraph.Vertex.SetProperty(System.String,System.Object)"]

Implements

IElement.SetProperty(String, Object)
IElement.SetProperty(String, Object)
See Also

Reference

Vertex Class
SetProperty Overload
VelocityGraph Namespace


Vertex.SetProperty Method (PropertyType, IComparable)

VertexSetProperty Method (PropertyType, IComparable)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetProperty(
    PropertyType property,
    IComparable v
)
Public Sub SetProperty (
    property As PropertyType,
    v As IComparable
)
public:
void SetProperty(
    PropertyType^ property,
    IComparable^ v
)
member SetProperty :
        property : PropertyType *
        v : IComparable -> unit

Parameters

property
Type: VelocityGraphPropertyType

[Missing <param name="property"/> documentation for "M:VelocityGraph.Vertex.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

v
Type: SystemIComparable

[Missing <param name="v"/> documentation for "M:VelocityGraph.Vertex.SetProperty(VelocityGraph.PropertyType,System.IComparable)"]

See Also

Reference

Vertex Class
SetProperty Overload
VelocityGraph Namespace


Vertex.ToString Method

VertexToString Method

[Missing <summary> documentation for "M:VelocityGraph.Vertex.ToString"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityGraph.Vertex.ToString"]

See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Traverse Method

VertexTraverse Method

Overload List
 | Name | Description
Public method | Traverse(Direction, ISetEdgeType) |
Public method | Traverse(EdgeType, Direction) |
Public method | Traverse(Int32, Boolean, Direction, Vertex, ISetEdgeType, ISetVertexType, ISetVertexType, ISetVertex, ISetVertex, ISetEdge, ISetEdge, ISetPropertyType, ISetPropertyType, ISetPropertyType, ISetPropertyType, FuncVertex, Boolean, FuncEdge, Boolean, FuncListEdge, Boolean) |
Top
See Also

Reference

Vertex Class
VelocityGraph Namespace


Vertex.Traverse Method (Direction, ISet(EdgeType))

VertexTraverse Method (Direction, ISetEdgeType)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Traverse(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<Vertex, HashSet<Edge>> Traverse(
    Direction dir,
    ISet<EdgeType> edgeTypesToTraverse = null
)
Public Function Traverse (
    dir As Direction,
    Optional edgeTypesToTraverse As ISet(Of EdgeType) = Nothing
) As Dictionary(Of Vertex, HashSet(Of Edge))
public:
Dictionary<Vertex^, HashSet<Edge^>^>^ Traverse(
    Direction dir,
    ISet<EdgeType^>^ edgeTypesToTraverse = nullptr
)
member Traverse :
        dir : Direction *
        ?edgeTypesToTraverse : ISet<EdgeType>
(* Defaults:
        let _edgeTypesToTraverse = defaultArg edgeTypesToTraverse null
*)
-> Dictionary<Vertex, HashSet<Edge>>

Parameters

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.Traverse(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

edgeTypesToTraverse (Optional)
Type: System.Collections.GenericISet EdgeType

[Missing <param name="edgeTypesToTraverse"/> documentation for "M:VelocityGraph.Vertex.Traverse(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

Return Value

Type: Dictionary Vertex, HashSet Edge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Traverse(Frontenac.Blueprints.Direction,System.Collections.Generic.ISet{VelocityGraph.EdgeType})"]

See Also

Reference

Vertex Class
Traverse Overload
VelocityGraph Namespace


Vertex.Traverse Method (EdgeType, Direction)

VertexTraverse Method (EdgeType, Direction)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Traverse(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Dictionary<Vertex, HashSet<Edge>> Traverse(
    EdgeType etype,
    Direction dir
)
Public Function Traverse (
    etype As EdgeType,
    dir As Direction
) As Dictionary(Of Vertex, HashSet(Of Edge))
public:
Dictionary<Vertex^, HashSet<Edge^>^>^ Traverse(
    EdgeType^ etype,
    Direction dir
)
member Traverse :
        etype : EdgeType *
        dir : Direction -> Dictionary<Vertex, HashSet<Edge>>

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.Vertex.Traverse(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.Traverse(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: Dictionary Vertex, HashSet Edge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Traverse(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

Vertex Class
Traverse Overload
VelocityGraph Namespace


Vertex.Traverse Method (Int32, Boolean, Direction, Vertex, ISet(EdgeType), ISet(VertexType), ISet(VertexType), ISet(Vertex), ISet(Vertex), ISet(Edge), ISet(Edge), ISet(PropertyType), ISet(PropertyType), ISet(PropertyType), ISet(PropertyType), Func(Vertex, Boolean), Func(Edge, Boolean), Func(List(Edg

VertexTraverse Method (Int32, Boolean, Direction, Vertex, ISetEdgeType, ISetVertexType, ISetVertexType, ISetVertex, ISetVertex, ISetEdge, ISetEdge, ISetPropertyType, ISetPropertyType, ISetPropertyType, ISetPropertyType, FuncVertex, Boolean, FuncEdge, Boolean, FuncListEdge, Boolean)

[Missing <summary> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<List<Edge>> Traverse(
    int maxHops,
    bool all = true,
    Direction dir = Direction.Both,
    Vertex toVertex = null,
    ISet<EdgeType> edgeTypesToTraverse = null,
    ISet<VertexType> includedVertexTypes = null,
    ISet<VertexType> excludedVertexTypes = null,
    ISet<Vertex> includedVertices = null,
    ISet<Vertex> excludedVertices = null,
    ISet<Edge> includedEdges = null,
    ISet<Edge> excludedEdges = null,
    ISet<PropertyType> includedVertexProperty = null,
    ISet<PropertyType> excludedVertexProperty = null,
    ISet<PropertyType> includedEdgeProperty = null,
    ISet<PropertyType> excludedEdgeProperty = null,
    Func<Vertex, bool> validateVertex = null,
    Func<Edge, bool> validateEdge = null,
    Func<List<Edge>, bool> validateEdges = null
)
Public Function Traverse (
    maxHops As Integer,
    Optional all As Boolean = true,
    Optional dir As Direction = Direction.Both,
    Optional toVertex As Vertex = Nothing,
    Optional edgeTypesToTraverse As ISet(Of EdgeType) = Nothing,
    Optional includedVertexTypes As ISet(Of VertexType) = Nothing,
    Optional excludedVertexTypes As ISet(Of VertexType) = Nothing,
    Optional includedVertices As ISet(Of Vertex) = Nothing,
    Optional excludedVertices As ISet(Of Vertex) = Nothing,
    Optional includedEdges As ISet(Of Edge) = Nothing,
    Optional excludedEdges As ISet(Of Edge) = Nothing,
    Optional includedVertexProperty As ISet(Of PropertyType) = Nothing,
    Optional excludedVertexProperty As ISet(Of PropertyType) = Nothing,
    Optional includedEdgeProperty As ISet(Of PropertyType) = Nothing,
    Optional excludedEdgeProperty As ISet(Of PropertyType) = Nothing,
    Optional validateVertex As Func(Of Vertex, Boolean) = Nothing,
    Optional validateEdge As Func(Of Edge, Boolean) = Nothing,
    Optional validateEdges As Func(Of List(Of Edge), Boolean) = Nothing
) As List(Of List(Of Edge))
public:
List<List<Edge^>^>^ Traverse(
    int maxHops,
    bool all = true,
    Direction dir = Direction::Both,
    Vertex^ toVertex = nullptr,
    ISet<EdgeType^>^ edgeTypesToTraverse = nullptr,
    ISet<VertexType^>^ includedVertexTypes = nullptr,
    ISet<VertexType^>^ excludedVertexTypes = nullptr,
    ISet<Vertex^>^ includedVertices = nullptr,
    ISet<Vertex^>^ excludedVertices = nullptr,
    ISet<Edge^>^ includedEdges = nullptr,
    ISet<Edge^>^ excludedEdges = nullptr,
    ISet<PropertyType^>^ includedVertexProperty = nullptr,
    ISet<PropertyType^>^ excludedVertexProperty = nullptr,
    ISet<PropertyType^>^ includedEdgeProperty = nullptr,
    ISet<PropertyType^>^ excludedEdgeProperty = nullptr,
    Func<Vertex^, bool>^ validateVertex = nullptr,
    Func<Edge^, bool>^ validateEdge = nullptr,
    Func<List<Edge^>^, bool>^ validateEdges = nullptr
)
member Traverse :
        maxHops : int *
        ?all : bool *
        ?dir : Direction *
        ?toVertex : Vertex *
        ?edgeTypesToTraverse : ISet<EdgeType> *
        ?includedVertexTypes : ISet<VertexType> *
        ?excludedVertexTypes : ISet<VertexType> *
        ?includedVertices : ISet<Vertex> *
        ?excludedVertices : ISet<Vertex> *
        ?includedEdges : ISet<Edge> *
        ?excludedEdges : ISet<Edge> *
        ?includedVertexProperty : ISet<PropertyType> *
        ?excludedVertexProperty : ISet<PropertyType> *
        ?includedEdgeProperty : ISet<PropertyType> *
        ?excludedEdgeProperty : ISet<PropertyType> *
        ?validateVertex : Func<Vertex, bool> *
        ?validateEdge : Func<Edge, bool> *
        ?validateEdges : Func<List<Edge>, bool>
(* Defaults:
        let _all = defaultArg all true
        let _dir = defaultArg dir Direction.Both
        let _toVertex = defaultArg toVertex null
        let _edgeTypesToTraverse = defaultArg edgeTypesToTraverse null
        let _includedVertexTypes = defaultArg includedVertexTypes null
        let _excludedVertexTypes = defaultArg excludedVertexTypes null
        let _includedVertices = defaultArg includedVertices null
        let _excludedVertices = defaultArg excludedVertices null
        let _includedEdges = defaultArg includedEdges null
        let _excludedEdges = defaultArg excludedEdges null
        let _includedVertexProperty = defaultArg includedVertexProperty null
        let _excludedVertexProperty = defaultArg excludedVertexProperty null
        let _includedEdgeProperty = defaultArg includedEdgeProperty null
        let _excludedEdgeProperty = defaultArg excludedEdgeProperty null
        let _validateVertex = defaultArg validateVertex null
        let _validateEdge = defaultArg validateEdge null
        let _validateEdges = defaultArg validateEdges null
*)
-> List<List<Edge>>

Parameters

maxHops
Type: SystemInt32

[Missing <param name="maxHops"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

all (Optional)
Type: SystemBoolean

[Missing <param name="all"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

dir (Optional)
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

toVertex (Optional)
Type: VelocityGraphVertex

[Missing <param name="toVertex"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

edgeTypesToTraverse (Optional)
Type: System.Collections.GenericISet EdgeType

[Missing <param name="edgeTypesToTraverse"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

includedVertexTypes (Optional)
Type: System.Collections.GenericISet VertexType

[Missing <param name="includedVertexTypes"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

excludedVertexTypes (Optional)
Type: System.Collections.GenericISet VertexType

[Missing <param name="excludedVertexTypes"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

includedVertices (Optional)
Type: System.Collections.GenericISet Vertex

[Missing <param name="includedVertices"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

excludedVertices (Optional)
Type: System.Collections.GenericISet Vertex

[Missing <param name="excludedVertices"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

includedEdges (Optional)
Type: System.Collections.GenericISet Edge

[Missing <param name="includedEdges"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

excludedEdges (Optional)
Type: System.Collections.GenericISet Edge

[Missing <param name="excludedEdges"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

includedVertexProperty (Optional)
Type: System.Collections.GenericISet PropertyType

[Missing <param name="includedVertexProperty"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

excludedVertexProperty (Optional)
Type: System.Collections.GenericISet PropertyType

[Missing <param name="excludedVertexProperty"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

includedEdgeProperty (Optional)
Type: System.Collections.GenericISet PropertyType

[Missing <param name="includedEdgeProperty"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

excludedEdgeProperty (Optional)
Type: System.Collections.GenericISet PropertyType

[Missing <param name="excludedEdgeProperty"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

validateVertex (Optional)
Type: SystemFunc Vertex, Boolean

[Missing <param name="validateVertex"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

validateEdge (Optional)
Type: SystemFunc Edge, Boolean

[Missing <param name="validateEdge"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

validateEdges (Optional)
Type: SystemFunc List Edge , Boolean

[Missing <param name="validateEdges"/> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

Return Value

Type: List List Edge

[Missing <returns> documentation for "M:VelocityGraph.Vertex.Traverse(System.Int32,System.Boolean,Frontenac.Blueprints.Direction,VelocityGraph.Vertex,System.Collections.Generic.ISet{VelocityGraph.EdgeType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.VertexType},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Vertex},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.Edge},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Collections.Generic.ISet{VelocityGraph.PropertyType},System.Func{VelocityGraph.Vertex,System.Boolean},System.Func{VelocityGraph.Edge,System.Boolean},System.Func{System.Collections.Generic.List{VelocityGraph.Edge},System.Boolean})"]

See Also

Reference

Vertex Class
Traverse Overload
VelocityGraph Namespace


VertexType Class

[Missing <summary> documentation for "T:VelocityGraph.VertexType"]

Inheritance Hierarchy
SystemObject
VelocityDbOptimizedPersistable
VelocityGraphVertexType

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VertexType : OptimizedPersistable
<SerializableAttribute>
Public Class VertexType
    Inherits OptimizedPersistable
[SerializableAttribute]
public ref class VertexType : public OptimizedPersistable
[<SerializableAttribute>]
type VertexType =
    class
        inherit OptimizedPersistable
    end

The VertexType type exposes the following members.

Properties
 | Name | Description
Public property | EdgeTypes |
Public property | MyGraph |
Public property | SubTypes |
Public property | TypeId |
Public property | TypeName |
Top
Methods
 | Name | Description
Public method | CountVertices |
Public method | FindProperty |
Public method | GetEdges(EdgeType, Direction) |
Public method | GetEdges(Vertex, Direction) |
Public method | GetEdges(EdgeType, Vertex, Direction, Vertex) |
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Int32, Direction) |
Public method | GetPropertyKeys |
Public method | GetPropertyTypes |
Public method | GetPropertyValue |
Public method | GetTopNumberOfEdges |
Public method | GetVertex |
Public method | GetVerticeIds |
Public method | GetVertices(Boolean) |
Public method | GetVertices(EdgeType, Vertex, Direction) |
Public method | NewProperty |
Public method | NewVertex |
Public method | Remove |
Public method | RemoveVertex |
Public method | SetPropertyValue |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VelocityGraph Namespace


VertexType Properties

The VertexType type exposes the following members.

Properties
 | Name | Description
Public property | EdgeTypes |
Public property | MyGraph |
Public property | SubTypes |
Public property | TypeId |
Public property | TypeName |
Top
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.EdgeTypes Property

VertexTypeEdgeTypes Property

[Missing <summary> documentation for "P:VelocityGraph.VertexType.EdgeTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public BTreeSet<EdgeType> EdgeTypes { get; }
Public ReadOnly Property EdgeTypes As BTreeSet(Of EdgeType)
    Get
public:
property BTreeSet<EdgeType^>^ EdgeTypes {
    BTreeSet<EdgeType^>^ get ();
}
member EdgeTypes : BTreeSet<EdgeType> with get

Property Value

Type: BTreeSet EdgeType
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.MyGraph Property

VertexTypeMyGraph Property

[Missing <summary> documentation for "P:VelocityGraph.VertexType.MyGraph"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Graph MyGraph { get; }
Public ReadOnly Property MyGraph As Graph
    Get
public:
property Graph^ MyGraph {
    Graph^ get ();
}
member MyGraph : Graph with get

Property Value

Type: Graph
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.SubTypes Property

VertexTypeSubTypes Property

[Missing <summary> documentation for "P:VelocityGraph.VertexType.SubTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public List<VertexType> SubTypes { get; }
Public ReadOnly Property SubTypes As List(Of VertexType)
    Get
public:
property List<VertexType^>^ SubTypes {
    List<VertexType^>^ get ();
}
member SubTypes : List<VertexType> with get

Property Value

Type: List VertexType
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.TypeId Property

VertexTypeTypeId Property

[Missing <summary> documentation for "P:VelocityGraph.VertexType.TypeId"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public int TypeId { get; }
Public ReadOnly Property TypeId As Integer
    Get
public:
property int TypeId {
    int get ();
}
member TypeId : int with get

Property Value

Type: Int32
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.TypeName Property

VertexTypeTypeName Property

[Missing <summary> documentation for "P:VelocityGraph.VertexType.TypeName"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType Methods

The VertexType type exposes the following members.

Methods
 | Name | Description
Public method | CountVertices |
Public method | FindProperty |
Public method | GetEdges(EdgeType, Direction) |
Public method | GetEdges(Vertex, Direction) |
Public method | GetEdges(EdgeType, Vertex, Direction, Vertex) |
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Int32, Direction) |
Public method | GetPropertyKeys |
Public method | GetPropertyTypes |
Public method | GetPropertyValue |
Public method | GetTopNumberOfEdges |
Public method | GetVertex |
Public method | GetVerticeIds |
Public method | GetVertices(Boolean) |
Public method | GetVertices(EdgeType, Vertex, Direction) |
Public method | NewProperty |
Public method | NewVertex |
Public method | Remove |
Public method | RemoveVertex |
Public method | SetPropertyValue |
Public method | ToString | (Overrides OptimizedPersistableToString.)
Public method | Unpersist | (Overrides OptimizedPersistableUnpersist(SessionBase).)
Top
Extension Methods
 | Name | Description
Public Extension Method | ToStringDetails(SessionBase, Boolean) | Overloaded. (Defined by Utilities.)
Public Extension Method | ToStringDetails(Schema, TypeVersion, Boolean) | Overloaded. (Defined by Utilities.)
Top
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.CountVertices Method

VertexTypeCountVertices Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.CountVertices"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long CountVertices()
Public Function CountVertices As Long
public:
long long CountVertices()
member CountVertices : unit -> int64

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.VertexType.CountVertices"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.FindProperty Method

VertexTypeFindProperty Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.FindProperty(System.String)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType FindProperty(
    string name
)
Public Function FindProperty (
    name As String
) As PropertyType
public:
PropertyType^ FindProperty(
    String^ name
)
member FindProperty :
        name : string -> PropertyType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.VertexType.FindProperty(System.String)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.VertexType.FindProperty(System.String)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetEdges Method

VertexTypeGetEdges Method

Overload List
 | Name | Description
Public method | GetEdges(EdgeType, Direction) |
Public method | GetEdges(Vertex, Direction) |
Public method | GetEdges(EdgeType, Vertex, Direction, Vertex) |
Top
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetEdges Method (EdgeType, Direction)

VertexTypeGetEdges Method (EdgeType, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges(
    EdgeType etype,
    Direction dir
)
Public Function GetEdges (
    etype As EdgeType,
    dir As Direction
) As IEnumerable(Of IEdge)
public:
IEnumerable<IEdge^>^ GetEdges(
    EdgeType^ etype,
    Direction dir
)
member GetEdges :
        etype : EdgeType *
        dir : Direction -> IEnumerable<IEdge>

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetEdges Overload
VelocityGraph Namespace


VertexType.GetEdges Method (Vertex, Direction)

VertexTypeGetEdges Method (Vertex, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges(
    Vertex vertex1,
    Direction dir
)
Public Function GetEdges (
    vertex1 As Vertex,
    dir As Direction
) As IEnumerable(Of IEdge)
public:
IEnumerable<IEdge^>^ GetEdges(
    Vertex^ vertex1,
    Direction dir
)
member GetEdges :
        vertex1 : Vertex *
        dir : Direction -> IEnumerable<IEdge>

Parameters

vertex1
Type: VelocityGraphVertex

[Missing <param name="vertex1"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetEdges Overload
VelocityGraph Namespace


VertexType.GetEdges Method (EdgeType, Vertex, Direction, Vertex)

VertexTypeGetEdges Method (EdgeType, Vertex, Direction, Vertex)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IEdge> GetEdges(
    EdgeType edgeType,
    Vertex vertex1,
    Direction dir,
    Vertex vertex2 = null
)
Public Function GetEdges (
    edgeType As EdgeType,
    vertex1 As Vertex,
    dir As Direction,
    Optional vertex2 As Vertex = Nothing
) As IEnumerable(Of IEdge)
public:
IEnumerable<IEdge^>^ GetEdges(
    EdgeType^ edgeType,
    Vertex^ vertex1,
    Direction dir,
    Vertex^ vertex2 = nullptr
)
member GetEdges :
        edgeType : EdgeType *
        vertex1 : Vertex *
        dir : Direction *
        ?vertex2 : Vertex
(* Defaults:
        let _vertex2 = defaultArg vertex2 null
*)
-> IEnumerable<IEdge>

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

vertex1
Type: VelocityGraphVertex

[Missing <param name="vertex1"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

vertex2 (Optional)
Type: VelocityGraphVertex

[Missing <param name="vertex2"/> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

Return Value

Type: IEnumerable IEdge

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetEdges(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction,VelocityGraph.Vertex)"]

See Also

Reference

VertexType Class
GetEdges Overload
VelocityGraph Namespace


VertexType.GetNumberOfEdges Method

VertexTypeGetNumberOfEdges Method

Overload List
 | Name | Description
Public method | GetNumberOfEdges(EdgeType, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Direction) |
Public method | GetNumberOfEdges(EdgeType, Int32, Int32, Direction) |
Top
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetNumberOfEdges Method (EdgeType, Direction)

VertexTypeGetNumberOfEdges Method (EdgeType, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long GetNumberOfEdges(
    EdgeType etype,
    Direction dir
)
Public Function GetNumberOfEdges (
    etype As EdgeType,
    dir As Direction
) As Long
public:
long long GetNumberOfEdges(
    EdgeType^ etype,
    Direction dir
)
member GetNumberOfEdges :
        etype : EdgeType *
        dir : Direction -> int64

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetNumberOfEdges Overload
VelocityGraph Namespace


VertexType.GetNumberOfEdges Method (EdgeType, Int32, Direction)

VertexTypeGetNumberOfEdges Method (EdgeType, Int32, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long GetNumberOfEdges(
    EdgeType etype,
    int vertexId,
    Direction dir
)
Public Function GetNumberOfEdges (
    etype As EdgeType,
    vertexId As Integer,
    dir As Direction
) As Long
public:
long long GetNumberOfEdges(
    EdgeType^ etype,
    int vertexId,
    Direction dir
)
member GetNumberOfEdges :
        etype : EdgeType *
        vertexId : int *
        dir : Direction -> int64

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetNumberOfEdges Overload
VelocityGraph Namespace


VertexType.GetNumberOfEdges Method (EdgeType, Int32, Int32, Direction)

VertexTypeGetNumberOfEdges Method (EdgeType, Int32, Int32, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public long GetNumberOfEdges(
    EdgeType edgeType,
    int vertexId,
    int vertexId2,
    Direction dir
)
Public Function GetNumberOfEdges (
    edgeType As EdgeType,
    vertexId As Integer,
    vertexId2 As Integer,
    dir As Direction
) As Long
public:
long long GetNumberOfEdges(
    EdgeType^ edgeType,
    int vertexId,
    int vertexId2,
    Direction dir
)
member GetNumberOfEdges :
        edgeType : EdgeType *
        vertexId : int *
        vertexId2 : int *
        dir : Direction -> int64

Parameters

edgeType
Type: VelocityGraphEdgeType

[Missing <param name="edgeType"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

vertexId2
Type: SystemInt32

[Missing <param name="vertexId2"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetNumberOfEdges(VelocityGraph.EdgeType,System.Int32,System.Int32,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetNumberOfEdges Overload
VelocityGraph Namespace


VertexType.GetPropertyKeys Method

VertexTypeGetPropertyKeys Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetPropertyKeys"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetPropertyKeys()
Public Function GetPropertyKeys As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetPropertyKeys()
member GetPropertyKeys : unit -> IEnumerable<string>

Return Value

Type: IEnumerable String

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetPropertyKeys"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetPropertyTypes Method

VertexTypeGetPropertyTypes Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetPropertyTypes"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PropertyType> GetPropertyTypes()
Public Function GetPropertyTypes As IEnumerable(Of PropertyType)
public:
IEnumerable<PropertyType^>^ GetPropertyTypes()
member GetPropertyTypes : unit -> IEnumerable<PropertyType>

Return Value

Type: IEnumerable PropertyType

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetPropertyTypes"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetPropertyValue Method

VertexTypeGetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Object GetPropertyValue(
    int vertexId,
    PropertyType propertyType
)
Public Function GetPropertyValue (
    vertexId As Integer,
    propertyType As PropertyType
) As Object
public:
Object^ GetPropertyValue(
    int vertexId,
    PropertyType^ propertyType
)
member GetPropertyValue :
        vertexId : int *
        propertyType : PropertyType -> Object

Parameters

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.VertexType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

propertyType
Type: VelocityGraphPropertyType

[Missing <param name="propertyType"/> documentation for "M:VelocityGraph.VertexType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetPropertyValue(System.Int32,VelocityGraph.PropertyType)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetTopNumberOfEdges Method

VertexTypeGetTopNumberOfEdges Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetTopNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex[] GetTopNumberOfEdges(
    EdgeType etype,
    int howMany,
    Direction dir
)
Public Function GetTopNumberOfEdges (
    etype As EdgeType,
    howMany As Integer,
    dir As Direction
) As Vertex()
public:
array<Vertex^>^ GetTopNumberOfEdges(
    EdgeType^ etype,
    int howMany,
    Direction dir
)
member GetTopNumberOfEdges :
        etype : EdgeType *
        howMany : int *
        dir : Direction -> Vertex[]

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.VertexType.GetTopNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

howMany
Type: SystemInt32

[Missing <param name="howMany"/> documentation for "M:VelocityGraph.VertexType.GetTopNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetTopNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetTopNumberOfEdges(VelocityGraph.EdgeType,System.Int32,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetVertex Method

VertexTypeGetVertex Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetVertex(System.Int32,System.Boolean,System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex GetVertex(
    int vertexId,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
Public Function GetVertex (
    vertexId As Integer,
    Optional polymorphic As Boolean = false,
    Optional errorIfNotFound As Boolean = true
) As Vertex
public:
Vertex^ GetVertex(
    int vertexId,
    bool polymorphic = false,
    bool errorIfNotFound = true
)
member GetVertex :
        vertexId : int *
        ?polymorphic : bool *
        ?errorIfNotFound : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
        let _errorIfNotFound = defaultArg errorIfNotFound true
*)
-> Vertex

Parameters

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.VertexType.GetVertex(System.Int32,System.Boolean,System.Boolean)"]

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.VertexType.GetVertex(System.Int32,System.Boolean,System.Boolean)"]

errorIfNotFound (Optional)
Type: SystemBoolean

[Missing <param name="errorIfNotFound"/> documentation for "M:VelocityGraph.VertexType.GetVertex(System.Int32,System.Boolean,System.Boolean)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetVertex(System.Int32,System.Boolean,System.Boolean)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetVerticeIds Method

VertexTypeGetVerticeIds Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetVerticeIds"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<int> GetVerticeIds()
Public Function GetVerticeIds As IEnumerable(Of Integer)
public:
IEnumerable<int>^ GetVerticeIds()
member GetVerticeIds : unit -> IEnumerable<int>

Return Value

Type: IEnumerable Int32

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetVerticeIds"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetVertices Method

VertexTypeGetVertices Method

Overload List
 | Name | Description
Public method | GetVertices(Boolean) |
Public method | GetVertices(EdgeType, Vertex, Direction) |
Top
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.GetVertices Method (Boolean)

VertexTypeGetVertices Method (Boolean)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetVertices(System.Boolean)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Vertex> GetVertices(
    bool polymorphic = false
)
Public Function GetVertices (
    Optional polymorphic As Boolean = false
) As IEnumerable(Of Vertex)
public:
IEnumerable<Vertex^>^ GetVertices(
    bool polymorphic = false
)
member GetVertices :
        ?polymorphic : bool
(* Defaults:
        let _polymorphic = defaultArg polymorphic false
*)
-> IEnumerable<Vertex>

Parameters

polymorphic (Optional)
Type: SystemBoolean

[Missing <param name="polymorphic"/> documentation for "M:VelocityGraph.VertexType.GetVertices(System.Boolean)"]

Return Value

Type: IEnumerable Vertex

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetVertices(System.Boolean)"]

See Also

Reference

VertexType Class
GetVertices Overload
VelocityGraph Namespace


VertexType.GetVertices Method (EdgeType, Vertex, Direction)

VertexTypeGetVertices Method (EdgeType, Vertex, Direction)

[Missing <summary> documentation for "M:VelocityGraph.VertexType.GetVertices(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IVertex> GetVertices(
    EdgeType etype,
    Vertex vertex1,
    Direction dir
)
Public Function GetVertices (
    etype As EdgeType,
    vertex1 As Vertex,
    dir As Direction
) As IEnumerable(Of IVertex)
public:
IEnumerable<IVertex^>^ GetVertices(
    EdgeType^ etype,
    Vertex^ vertex1,
    Direction dir
)
member GetVertices :
        etype : EdgeType *
        vertex1 : Vertex *
        dir : Direction -> IEnumerable<IVertex>

Parameters

etype
Type: VelocityGraphEdgeType

[Missing <param name="etype"/> documentation for "M:VelocityGraph.VertexType.GetVertices(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

vertex1
Type: VelocityGraphVertex

[Missing <param name="vertex1"/> documentation for "M:VelocityGraph.VertexType.GetVertices(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

dir
Type: Direction

[Missing <param name="dir"/> documentation for "M:VelocityGraph.VertexType.GetVertices(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

Return Value

Type: IEnumerable IVertex

[Missing <returns> documentation for "M:VelocityGraph.VertexType.GetVertices(VelocityGraph.EdgeType,VelocityGraph.Vertex,Frontenac.Blueprints.Direction)"]

See Also

Reference

VertexType Class
GetVertices Overload
VelocityGraph Namespace


VertexType.NewProperty Method

VertexTypeNewProperty Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public PropertyType NewProperty(
    string name,
    DataType dt,
    PropertyKind kind
)
Public Function NewProperty (
    name As String,
    dt As DataType,
    kind As PropertyKind
) As PropertyType
public:
PropertyType^ NewProperty(
    String^ name,
    DataType dt,
    PropertyKind kind
)
member NewProperty :
        name : string *
        dt : DataType *
        kind : PropertyKind -> PropertyType

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:VelocityGraph.VertexType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

dt
Type: VelocityGraphDataType

[Missing <param name="dt"/> documentation for "M:VelocityGraph.VertexType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

kind
Type: VelocityGraphPropertyKind

[Missing <param name="kind"/> documentation for "M:VelocityGraph.VertexType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

Return Value

Type: PropertyType

[Missing <returns> documentation for "M:VelocityGraph.VertexType.NewProperty(System.String,VelocityGraph.DataType,VelocityGraph.PropertyKind)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.NewVertex Method

VertexTypeNewVertex Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.NewVertex(System.Int32)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public Vertex NewVertex(
    int vId = 0
)
Public Function NewVertex (
    Optional vId As Integer = 0
) As Vertex
public:
Vertex^ NewVertex(
    int vId = 0
)
member NewVertex :
        ?vId : int
(* Defaults:
        let _vId = defaultArg vId 0
*)
-> Vertex

Parameters

vId (Optional)
Type: SystemInt32

[Missing <param name="vId"/> documentation for "M:VelocityGraph.VertexType.NewVertex(System.Int32)"]

Return Value

Type: Vertex

[Missing <returns> documentation for "M:VelocityGraph.VertexType.NewVertex(System.Int32)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.Remove Method

VertexTypeRemove Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.Remove"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.RemoveVertex Method

VertexTypeRemoveVertex Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.RemoveVertex(VelocityGraph.Vertex)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void RemoveVertex(
    Vertex vertex
)
Public Sub RemoveVertex (
    vertex As Vertex
)
public:
void RemoveVertex(
    Vertex^ vertex
)
member RemoveVertex :
        vertex : Vertex -> unit

Parameters

vertex
Type: VelocityGraphVertex

[Missing <param name="vertex"/> documentation for "M:VelocityGraph.VertexType.RemoveVertex(VelocityGraph.Vertex)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.SetPropertyValue Method

VertexTypeSetPropertyValue Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public void SetPropertyValue(
    int vertexId,
    PropertyType propertyType,
    IComparable v
)
Public Sub SetPropertyValue (
    vertexId As Integer,
    propertyType As PropertyType,
    v As IComparable
)
public:
void SetPropertyValue(
    int vertexId,
    PropertyType^ propertyType,
    IComparable^ v
)
member SetPropertyValue :
        vertexId : int *
        propertyType : PropertyType *
        v : IComparable -> unit

Parameters

vertexId
Type: SystemInt32

[Missing <param name="vertexId"/> documentation for "M:VelocityGraph.VertexType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

propertyType
Type: VelocityGraphPropertyType

[Missing <param name="propertyType"/> documentation for "M:VelocityGraph.VertexType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

v
Type: SystemIComparable

[Missing <param name="v"/> documentation for "M:VelocityGraph.VertexType.SetPropertyValue(System.Int32,VelocityGraph.PropertyType,System.IComparable)"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.ToString Method

VertexTypeToString Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.ToString"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:VelocityGraph.VertexType.ToString"]

See Also

Reference

VertexType Class
VelocityGraph Namespace


VertexType.Unpersist Method

VertexTypeUnpersist Method

[Missing <summary> documentation for "M:VelocityGraph.VertexType.Unpersist(VelocityDb.Session.SessionBase)"]

Namespace: VelocityGraph
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
public override void Unpersist(
    SessionBase session
)
Public Overrides Sub Unpersist (
    session As SessionBase
)
public:
virtual void Unpersist(
    SessionBase^ session
) override
abstract Unpersist :
        session : SessionBase -> unit
override Unpersist :
        session : SessionBase -> unit

Parameters

session
Type: VelocityDb.SessionSessionBase

[Missing <param name="session"/> documentation for "M:VelocityGraph.VertexType.Unpersist(VelocityDb.Session.SessionBase)"]

Implements

IOptimizedPersistableUnpersist(SessionBase)
See Also

Reference

VertexType Class
VelocityGraph Namespace


VelocityGraph.Exceptions Namespace

[Missing <summary> documentation for "N:VelocityGraph.Exceptions"]

Classes
 | Class | Description
Public class | EdgeDoesNotExistException |
Public class | EdgeTypeDoesNotExistException |
Public class | EdgeTypeInUseException |
Public class | InvalidHeadVertexTypeException |
Public class | InvalidPropertyIdException |
Public class | InvalidTailVertexTypeException |
Public class | InvalidTypeIdException |
Public class | PropertyTypeInUseException |
Public class | VertexAllreadyExistException |
Public class | VertexDoesNotExistException |
Public class | VertexTypeDoesNotExistException |
Public class | VertexTypeInUseException |


EdgeDoesNotExistException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.EdgeDoesNotExistException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsEdgeDoesNotExistException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EdgeDoesNotExistException : Exception
<SerializableAttribute>
Public Class EdgeDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class EdgeDoesNotExistException : public Exception
[<SerializableAttribute>]
type EdgeDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


EdgeTypeDoesNotExistException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.EdgeTypeDoesNotExistException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsEdgeTypeDoesNotExistException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EdgeTypeDoesNotExistException : Exception
<SerializableAttribute>
Public Class EdgeTypeDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class EdgeTypeDoesNotExistException : public Exception
[<SerializableAttribute>]
type EdgeTypeDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


EdgeTypeInUseException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.EdgeTypeInUseException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsEdgeTypeInUseException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EdgeTypeInUseException : Exception
<SerializableAttribute>
Public Class EdgeTypeInUseException
    Inherits Exception
[SerializableAttribute]
public ref class EdgeTypeInUseException : public Exception
[<SerializableAttribute>]
type EdgeTypeInUseException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


InvalidHeadVertexTypeException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.InvalidHeadVertexTypeException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsInvalidHeadVertexTypeException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidHeadVertexTypeException : Exception
<SerializableAttribute>
Public Class InvalidHeadVertexTypeException
    Inherits Exception
[SerializableAttribute]
public ref class InvalidHeadVertexTypeException : public Exception
[<SerializableAttribute>]
type InvalidHeadVertexTypeException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


InvalidPropertyIdException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.InvalidPropertyIdException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsInvalidPropertyIdException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidPropertyIdException : Exception
<SerializableAttribute>
Public Class InvalidPropertyIdException
    Inherits Exception
[SerializableAttribute]
public ref class InvalidPropertyIdException : public Exception
[<SerializableAttribute>]
type InvalidPropertyIdException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


InvalidTailVertexTypeException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.InvalidTailVertexTypeException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsInvalidTailVertexTypeException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidTailVertexTypeException : Exception
<SerializableAttribute>
Public Class InvalidTailVertexTypeException
    Inherits Exception
[SerializableAttribute]
public ref class InvalidTailVertexTypeException : public Exception
[<SerializableAttribute>]
type InvalidTailVertexTypeException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


InvalidTypeIdException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.InvalidTypeIdException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsInvalidTypeIdException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidTypeIdException : Exception
<SerializableAttribute>
Public Class InvalidTypeIdException
    Inherits Exception
[SerializableAttribute]
public ref class InvalidTypeIdException : public Exception
[<SerializableAttribute>]
type InvalidTypeIdException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


PropertyTypeInUseException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.PropertyTypeInUseException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsPropertyTypeInUseException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PropertyTypeInUseException : Exception
<SerializableAttribute>
Public Class PropertyTypeInUseException
    Inherits Exception
[SerializableAttribute]
public ref class PropertyTypeInUseException : public Exception
[<SerializableAttribute>]
type PropertyTypeInUseException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


VertexAllreadyExistException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.VertexAllreadyExistException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsVertexAllreadyExistException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VertexAllreadyExistException : Exception
<SerializableAttribute>
Public Class VertexAllreadyExistException
    Inherits Exception
[SerializableAttribute]
public ref class VertexAllreadyExistException : public Exception
[<SerializableAttribute>]
type VertexAllreadyExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


VertexDoesNotExistException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.VertexDoesNotExistException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsVertexDoesNotExistException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VertexDoesNotExistException : Exception
<SerializableAttribute>
Public Class VertexDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class VertexDoesNotExistException : public Exception
[<SerializableAttribute>]
type VertexDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


VertexTypeDoesNotExistException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.VertexTypeDoesNotExistException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsVertexTypeDoesNotExistException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VertexTypeDoesNotExistException : Exception
<SerializableAttribute>
Public Class VertexTypeDoesNotExistException
    Inherits Exception
[SerializableAttribute]
public ref class VertexTypeDoesNotExistException : public Exception
[<SerializableAttribute>]
type VertexTypeDoesNotExistException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace


VertexTypeInUseException Class

[Missing <summary> documentation for "T:VelocityGraph.Exceptions.VertexTypeInUseException"]

Inheritance Hierarchy
SystemObject
SystemException
VelocityGraph.ExceptionsVertexTypeInUseException

Namespace: VelocityGraph.Exceptions
Assembly: VelocityGraph (in VelocityGraph.dll) Version: 8.4.0.0 (8.4)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class VertexTypeInUseException : Exception
<SerializableAttribute>
Public Class VertexTypeInUseException
    Inherits Exception
[SerializableAttribute]
public ref class VertexTypeInUseException : public Exception
[<SerializableAttribute>]
type VertexTypeInUseException =
    class
        inherit Exception
    end
See Also

Reference

VelocityGraph.Exceptions Namespace